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Getting Started with XGbT

You can use this Reference document to get started with testing the Ethernet
physical layer using the TekExpress XGbT-10GBASE-T application that provides
the capability for multi-equipment control.

NOTE. For complete operating instructions, refer to the application online help.

XGDbT application is an easy-to-use software and uses a Windows-based interface.
It helps in debugging and designing of the I0GBASE-T physical layer.

It provides an IEEE Std 802.3an-2006 compliance solution for performing Clock
Frequency, Droop, Jitter-Master, and Jitter-Slave measurements. Using the
spectral features of the oscilloscope, the application also facilitates performing
the spectral-based measurements such as Power Spectral Density, Power Level,
Linearity (All Tones), and Return Loss. You can select, configure, and run
measurements.

XGbT users will also have to qualify their DUTs for
1000BASE-T/100BASE-T/10BASE-T compliance. To meet this, Tektronix
provides the necessary softwares (TekExpress XGbT-10GBASE-T Automated
Solution and TDSET3 Ethernet Compliance Software), fixture (TF-XGbT and
TF-GBE), oscilloscopes, Arbitrary Waveform Generators, and probes.

For up-to-date information on Tektronix XGbT-10GBASE-T Automated Solution,
access the www.tektronix.com Web page.
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Getting Started with XGbT

Products supported

Tektronix DPO/DSA70404, DPO/DSA70604, DPO/DSA70804, DPO/DSA71254,

DPO/DSA71604, and DPO/DSA72004 series oscilloscopes

Tektronix DPO/DSA70404B, DPO/DSA70604B, DPO/DSA70804B,
DPO/DSA71254B, DPO/DSA71604B, and DPO/DSA72004B series

oscilloscopes

Tektronix MSO70404, MSO70604, MSO70804, MSO71254, MSO71604, and
MSO072004 series oscilloscopes

Recommended AWGs for Return Loss Measurement. Tektronix AWG7101,
AWGT7101B, AWG7102, and AWG7102B

Table 1: Recommended probes

Oscilloscope

For Droop, Power Spectral
Density, Linearity, Clock
Frequency, Jitter-Master,
and Jitter-Slave
measurements

For Return Loss
measurement

Tektronix DPO7000
Series

Tektronix P6330 - A minimum
of one and a maximum of four
are required.

Tektronix P6330 - A
minimum of two are required.

Tektronix SMA cables - A
minimum of two are required.

TDP3500 - A minimum of
two are required.

Tektronix TDP3500 - A
minimum of one and a
maximum of four are required.

Tektronix DPO70000,

DSA70000, MSO70000,

DPO70000B, and
DSA70000B Series

Tektronix P6330 - A minimum
of one and a maximum of four
are required.

Tektronix P6330 - A
minimum of two are required.

Tektronix P7330 and P7350
- A minimum of one and a
maximum of four are required.

Tektronix P7330 and P7350
- A minimum of two are
required.

Tektronix Trimode probes
(P7520, P7516, P7513A,
P7508, P7506, and P7504)

- A minimum of one and a
maximum of four are required.

Tektronix Trimode probes
(P7520, P7516, P7513A,
P7508, P7506, P7504) - A
minimum of two are required.

Tektronix SMA cables - A
minimum of two are required.

Tektronix P7340A, P7360A,
P7313, and P7380A -

Tektronix P7350SMA,
P7380SMA, and P7313SMA
- A minimum of one and a
maximum of four are required.

A minimum of two are
required.
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Example Measurement

Example Measurement

In the following example, we are providing the details on performing the Droop
measurement.

For more details on performing the Droop, Power Spectral Density, Linearity,
Clock Frequency, Jitter-Master, Jitter-Slave, and Return Loss measurements,
refer to the TekExpress XGbT-10GBASE-T Automated Solution Online Help
(076-0195-XX).
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Example Measurement

Running the Droop  The steps for performing the Droop measurement are as follows:

Measurement 1. Connect the Device Under Test (DUT) and the test fixture (TF-XGbT) to the

configured oscilloscope channel using the above mentioned probes or SMA
cables. The test setup is as shown:

SMA Probe
(Differential Source)

Test Fixture

] Digital Oscilloscope

P7380 SMA

J10
O

J8
To DUT ) @C'

p— | J7
p— | © B+

Pe j©§ ~
TC1 D. g |
10GBASE-T Jﬁ’QE 3
DROOP, LINEARITY

B-
j@i
JITTER MASTER, PSD
POWER LEVEL TESTS @ @ /
D- D+
s/ © Y s

O O] TF-XGbT_REV03 |© © To Differential

\/ SMA PrObe

Note: When using high input impedance differential probe, ensure
that each of the single ended lanes is terminated with 50 Q. 060002

Figure 1: Connections with an SMA Probe (Differential Source) for Droop
Measurement
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Example Measurement

Differential Probe

Test Fixture

Digital Oscilloscope

DUT

To Oscilloscope

5
(w)
c
—

10GBASE-T P
DROOP LINEARTY -1 J3 @ B-
JITTER MASTER  PSD
POWER LEVEL TESTS

0o
O Of TF-XGbT_REV031© ©

Note: When using high input impedance differential probe, ensure
that each of the single ended lanes is terminated with 50 Q. 0o

Figure 2: Connections with a Differential Probe (Differential Source) for Droop
Measurement
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Example Measurement

SMA Cable
(Single-Ended Source)
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Figure 3: Connections with a SMA Cable (Single-Ended Source) for Droop
Measurement
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2. Double-click the icon ?’/ on the desktop.
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Example Measurement

3. Click the Select tab and select Differential or Single Ended as the source.
Select one of the test lanes. Enter the DUT ID. Select the Droop measurement.
You can select Click to view image of the waveform to see a snapshot of
the Droop signal.

¥ TekExpress XGbT-10GBASE-T Automated Solution (Evaluation Version) (LaneA)*
Fle  Wiew Toos  Help

o (01 B G (=

Select " Acquire || Analyze ” Feport |

Source Test Lanes DUT Automation
() Differential ) All Lanes ) Using MDID
) Single Ended () Select Lane © Manual

LaneA [JLaneB [JLaneC []LaneD

Test Measurements Test Description

Droop --> [IEEE 5td 802.3an-2006

Dizon section 55.5.3.1); Set the DUT to

& il Power Spectral Density operate in test mode 6. Droop Positive
. : is f d by i Itage levels
= [ Linearity at 10 ns and 90 ns after the zero
i croszing on the rizing edge. Similarly,

Droop Negative is performed by

Click to view image of the waveform

=l Clock Frequency
F Jitter-Master

o 4 Jitter-Slave

- []Return Loss  { Calibrate )

TekExpress launched successfully. 'Ihktl'l]l'li_x"

Figure 4: Select Panel with Droop Measurement Selected

4. Click Configure to configure the test parameters for the Droop measurement.
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Example Measurement

\% Configuration Panel

Configuration for Device - Suite

Parameter Yalue

Feal Time Scope DSAT0404 [ GRIBE:1:IMSTR )
Humber of selected lane 1

Source Tupe Differential

Configuration for Droop

Acquire = Analyze | Limits Comments

Parameter Value

Ref Levels Percentage
MidLevel 50
Hysteresis 5

Start Time [ns) 10

End Time [ns) =li]
Population 1000

@ Compliance Mode Default Settings

O User Defined Mode ﬁiiﬂli Apply &

Figure 5: Configuration panel to set the Droop Parameters

5. Inthe Acquire panel, select either Acquire Live Waveform to analyze the live
waveform or select Use Pre-recorded (See page 11, Performing Analysis
Using Prerecorded Waveforms.) to analyze the prerecorded waveform files.

NOTE. When using prerecorded waveform files, the waveforms in the Report
panel are not available after the measurement is run.

6. Click Acquire and select Acquire Step By Step, to display a snapshot of the
input signal of the Droop measurement. This helps you to compare the applied
input signal with the snapshot of a typical Droop input signal, allowing you
to change the setup before acquisition. The application then prompts you to
configure the DUT to transmit the Droop signal in the correct test mode.

NOTE. When using prerecorded waveform files, the Acquire Step By Step option
is not available.
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Example Measurement

Figure 6: Snapshot of the Droop Signal for Differential Source
7. Click Run.

8. The status of the measurement is displayed in the Analyze panel.

* TekExpress XGbT-10GBASE-T Automated Solution (Untitled)*

File  V¥iew Tools Help
DUT D |DUTODT Run Stop
Select Acquire Analyze Repart
Device - Suite [ Show Pass i Fail
Lane A Overall Test Result: " Pass Lo
TestMame Status Measurement Limit Resuks Margn Pass/Fal
Draop Positi 0% -10% 232 7B %
Croop Test Completed ‘ 1o0p Fosie | ‘ | v Pass
|Dracp Negative [o2-10% [218 7822 |
Lane B Overall Test Result:  + Pass
TestMame Status Measurement Limit Resuks Margin Pass/Fal
Droop Pasit 0%-10% 203 797 %
Croop Test Completed ‘ 1oop Fosive | ‘ | v Pass
|Dracp Negative [0%-10% [1.25 larsx |
Lane C Overall Test Result: " Pass
TestName Status Measurement Limit Resuks Maran Pass/Fal | b
E/29/2009 5:01 PM::Setting export format to:png Al
£/29/2009 5:071 PM::Setting export file name to:Lane D_Droop Negative.png (Dl St
E/29/2009 501 PM::Setting export palette to COLOR Auta Sorall
E/29/2009 5:01 PM::Setting export readout to: ONGRATICULE
B/29/2009 5:01 PM::Setting export start Clear Al
£/29/2009 5:071 PM::Started acquisition
£/29/2009 501 PM::Completed Droop-Device test Save Status
E/29/2009 5:01 PM::Generating Tek Report
E/29/2009 5:02 PM:: Test execution completed b
TekExpress launched successfully, 'Ibkmn_ix"

Figure 7: Analyze panel after Droop Measurement is Run

9. After the measurement runs successfully, a summary report of all lanes and
detailed reports of each of the lanes are displayed in the Report panel.

TekExpress XGbT-10GBASE-T Automated Solution 9
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10

\:Té. TekExpress XGbT-10GBASE-T Automated Solution (Untitled)*

File  Wiew Tools  Help

DUTID [DUTON | Fun St

Select Acquire Analyze Report

Device : Suite

T(ﬂ(lmn/lx TekExpress Automation Framework
Enabilng Insovation XGbT Signal Characteristics Test Report
DUT ID: DUTO01 Device Type : Tr i Compli Mode :
Date(Time : 6/29/09 17:01  Execution Time : 4 Min  Overall Test Result :
Scope Model: DSAT0404 Scope Serial Number Q006 Scope FAW Verzion 4.3.3 BULD 12
Calioration Status : PASEPASS TekExpress Version 1.3.4.124 XGET Version 08.1.5
Lane-A:
Test Name Measurement Limit1 Measured Test
Result
IClock Freguency Clock Freguency -
[ Droop Positve [ 0.00 | 232 [ 1000 | Pass
proop [ Droop Negative | 0.00 | 218 | 1000 ] » oo TRUE 1 Min
| Linearity Tone-1 \ \ | | | |
| Linearity Tone-2 | | - [ | | v
< >
« < = » [[Report Summaryi[ Lane A Lane B [ Lane C [ LaneD |
TekExpress launched successfully, 'Ihktl‘l:lnix"

Figure 8: Report panel after Droop Measurement is Run

The reports are automatically saved in MHT format to the default location:

X:\XGbT-10GBASE-T\Untitled Session\<DUTID>\<DATE>
(YYYYMMDD) _<TIME> (HHMMSS)

or

My Documents\My TekExpress\XGbT-10GBASE-T\Untitled
Session\<DUTID>\<DATE> (YYYYMMDD)_<TIME> (HHMMSS)

= ¥ My TekExpress
= I5) %GhT-10GEASE-T
= [C3) Untitled Session
= I£5) ouTool

Figure 9: Location of the saved report file

NOTE. After a measurement is complete and a report is generated, if you select
File>Save Report As and save the file in MHT format a blank .mht file is created
at the target location. This is a known problem and happens because of an issue
with Internet Explorer. Instead copy the generated .mht file to a different location
manually.
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Example Measurement

Performing Analysis Using 1. Open the session that you have saved using File > Open Session or File >
Prerecorded Waveforms Recently Recalled Setup (a recent file). Then a drop-down box appears
showing the session name with the date details.

2. Select Use Pre-recorded in the Acquire panel and select one of the sessions
listed in the drop-down box.

3. You have options to modify the waveform file for each lane of the
measurements, add or delete a lane, and even add or delete a new measurement
to the existing test suite. Once you select run, data corresponding for that run
is populated (such as the selected test, the test configuration settings, and the
test summary status).
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XGbT Menu Tree

XGbT Menu Tree

MewSessian
Opendession
Savelession

Save 3essionAs
Recently Recalled Setup
Save Heportds
PrintPreviewRepor

PrintReport
Exit

File

Yipw — Loy

[ InstrumentBench
Tools ———— E.pailSettings
ReturnLossCalibration

TekExpressHelp
Help —— 1 aboutTekExpress
ActivateLicense

Figure 10: XGbT menu tree
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