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Getting started

Table 1: Tutorial descriptions

This set of eleven tutorials helps you learn more about operating the Tektronix
MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer. Perform
tutorials 1 through 11 in the order they are presented, regardless of the video
standard of interest. Tutorial 10 relates only to MPEG-2 and interlaced video.

NOTE. Although the order code for this product is MTS4EAV7, the product is
generally referred to as the MTS4EA throughout the software and documentation.

For information about H.265/HEVC stream analysis, see the MTS4EAV7 User
Manual (Tektronix part number 071-3228-XX).

The tutorials will help you answer the following questions:

= How do you know that your video compression complies with the standards

B If your codec doesn't work well with other vendors' codecs, where is the
problem — is it with your codec or theirs

B Are you optimizing your Codec

®  Are you making the best use of available bandwidth

B Which frames and movement types use the most bits and why

B What changes to your codec software give the best reductions in bits used for
the least reduction in visual quality

= What types of video content does your codec work poorly with and why

A description for each tutorial follows. (See Table 1.)

Tutorial Name Standard Areas Covered

1 H.261 H.261 Syntax error; compression
optimization; graph analysis

2 H.263 Compliance and Motion H.263 Baseline Errors and error log; motion vectors.

Vectors

3 MPEG-4 Compliance MPEG-4 Simple Profile Common errors; searching for areas
of codec optimization.

4 MPEG-4 Optimization MPEG-4 Adv. Simple Profile Common errors; HexView
bitstream analysis; video navigator;
synchronize views; project files

5 MP4 Compliance Basics MP4/ Simple Profile/ L1(2) Extract and examine container files;
level conformance error.

6 MP4 Optimization MP4/ Simple Profile/ L1(2) Using MB type overlays and

searching for areas of optimization.
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Getting started

Table 1: Tutorial descriptions (cont.)

Tutorial Name Standard Areas Covered

7 3GPP/MPEG-4 Compliance 3GPP/MPEG-4 Simple Profile/ L1 Common errors; searching for areas
for optimization

8 H.264/AVC Syntax Error H.264/AVC Extended Profile/ L3 Syntax error in PPS; trace analysis
of syntax

9 MPEG-4 and H.264/AVC Buffer MPEG-4 ASP and H.264/AVC Buffer analysis in MPEG-4 and

Analysis H.264/AVC; fixing problems.

10 MPEG-2 Compliance MPEG-2 Main Profile / Main Level Syntax errors; MPEG structure
analysis; interlace.

11 Fidelity Analysis MPEG-4, MPEG-2, and H.264 Fidelity analysis; visual difference.

Basic functions

To complete the tutorial procedures, you must be familiar with the following basic
functions. (See Table 2.) To perform the desired function, click the associated
icon or type the appropriate keyboard shortcut.

Table 2: Basic functions

Function Forward Backward

Icon Keyboard shortcut Icon Keyboard shortcut
Play video [ 2 Ctrl+P - Ctrl + Shift + P
Stop video [ Ctrl+ S [ ] Ctl+S
Pause/step one frame I Ctrl+ A -l Ctrl + Shift + A
Fast forward/backward L Ctrl+ F ] Ctrl + Shift + F
Pause on frame [ e
Skip to next frame B3 Ctrl + K s Ctrl + Shift + K
type/number/time

How to begin a tutorial

1. After starting MTS4EA, click anywhere to remove the splash screen. If you
do nothing, the splash screen will disappear after 4 seconds.

2. Load the desired tutorial stream. Note that the demo version of the MTS4EA

will only play the provided example video files.
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Tutorial 1: H.261

This tutorial shows non-compliance issues with the H.261 standard using temporal
references and graphical analysis.

Procedure

1. To load the H.261 tutorial, click File > Example files > H.261 stream >
Conference Room. The window title changes to MTS4EA-H.261 Example
- Conference Room, and a warning message appears. (See Figure 1.)

= H.261 Example - (

™ Skip this Waming only in fulure
I Skip ALL Waming alerts in future

Abot | Pause Continve | Goto v |

Figure 1: Initial warning message

NOTE. The H.261 standard states that the temporal reference (TR) value is the
previous TR value + 1 + the number of skipped or non-reference pictures at the
picture clock frequency (PCF). TR is 8 bits only, 0-255, at the standard PCF of
29.97 frames per second. However, if a custom PCF is used, then TR is 10 bits: 8§
LSBs are denoted as TR and 2 MSBs are ETR, but they are taken together as a
single 10-bit number.

2. View the warning message elements:
= Warning - Indicates that two consecutive temporal references are zero.

= Summary - Gives summary information about the stream.

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials 3



Tutorial 1: H.261

= Skip this Warning only in the future - elects to skip this particular
warning in the future (recommended).

= Skip ALL Warning alerts in the future - elects to skip this alert and
all other alerts in the future.

3. Select Skip this Warning only in the future, and then click Continue.

4. Click the ™. toolbar icon or type CTRL + P to resume playing the video.
5. As you view the video, notice the following: (See Figure 2.)

= Movement in the video is too quick (requires PC with processing speed
of greater than or equal to 1 GHz)

= Unwanted noise (visual artifacts) is visible when the man waves his arm
(starting around frame 128, continuing into frame 161, with some artifacts
remaining until frame 203)

= Status bar notes that one alert is disabled

Although the video stream will play and will probably be decoded by other
H.261 decoders, the H.261 sequence was incorrectly encoded, showing
temporal issues.

% H.261 Fxample - Conference Room [. n'lrl(

Figure 2: Visual artifacts
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Tutorial 1: H.261

6. Click Overlay on the menu and select MB Types, or click the Overlay icon

% 6n the toolbar. MB (macroblock) Types are color coded and can be
undocked, resized, or switched off. (See Figure 3.)

NOTE. The H.261 standard has 10 MB types. For more information on using
these, see the user manual.

P MTS4FA - H.281 Fxample - Conlerence Noom
pin by oy Apdlves gt window  dolp
B w <o dami-r ol e fume = me @ "

% |1. 264 [xample - Conference Raom ';”E E|

F:00004

(] mren, mTERary, NTERMyYSFL

o [l] rremea

NTER +h +COBFF, BITER M +FL+CORFF

TER MY COEFF 463, INTER MY SFL | COBFF 42

" MEOVTE | oo fra'w e Bl 04 clnbled Eaves

Figure 3: MB overlay
7. Check that the video is in either Play or Pause mode.
8. Click the MB Tooltip icon 4 on the toolbar. The Tooltip typically docks at

the left edge of the window, but you can undock it by pressing <CTRL> on
your keyboard while dragging the Tooltip with your mouse.

9. Move the mouse over the video. A white box will display around the MB
from which data is being read. The Tooltip shows information about that
MB. (See Figure 4.)
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Tutorial 1: H.261

T MISAEE H. AT bmample  Canlecence Haom
Fle Moy Cwerlay Apshems Alert Window b
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a
[T/ | I Friniing.g
iwm

T S T N I

Lheliiied / (nee. P 1) e U

£

Figure 4: MB types and data

10. Advance through the video frame by frame, noting many green Intra MBs in
the background wall. These block types use the most bits. (See Figure 5.)

2 MTS4EA - H.261 Example - Conference Room
File Play Owerlay Analvsis  Alert Window  Help

FER = dadadammr eEm o R

Macroblock

=

@ H.261 Example - Confe

Pizel location FElumu)]
MB location [
= 0:x008c1 7 (dec. 358630 kit 0

B nreea

Cant

Zegment §

o coooon

Figure 5: Intra MBs in the background wall and MB data
11. Stop the video sequence.

12. To analyze the MB data, select Analysis from the menu and select Video
graph enable. A dialog box will appear. (See Figure 6.)
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Tutorial 1: H.261

!

Analysis options
Frame r::l'lge] Trace Graphs |Vm.|d :H'femrmrﬁ:leﬂﬂ

¥ Enable
Filename

[h261.4s J

Options

[ Spatial bitz/MEB coded
[ MV histogram

[ Spalial average quant
[JDCT requency

[ MB coded frequency
Infra coded frequency

0K Cancel |  apoy |

Figure 6: Analysis dialog box

13. Check the Enable, Spatial bits/MB, and Intra coded frequency boxes in the
Analysis dialog box.

14. Select the output filename: h261 xls.
15. Click OK and then play the video.

16. When play ends, the data is exported to the .xls file and MS Excel will open.
Click Enable macros. The screen will flash as the macros run.

17. Click Spatial Bits per MB to view a graph of the spatial bits per MB. (See
Figure 7.)
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Tutorial 1: H.261

Spatial Bits per MB

]

100 - : - — - = = o L H..H 5 B

fwverage bits 01 2 3 45 6 7 8 91011 121314151617 1819 20 21

MB Columns

Figure 7: Spatial bits per MB

@ = @ th & W k=D

NOTE. Notice that many bits are used in the center (by the man), top left (too
many), and along the bottom edge (too many). These last two are errors.

18. Click the Intra Coded Frequency tab to view a graph of the Intra Coded
Frequency. (See Figure 8.)
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Tutorial 1: H.261

Intra Coded Frequency

U =

Freq

U1 23486 /7/B2W0WNNREBMLBIAEIPN
ME Calumns

Figure 8: Intra coded frequency

NOTE. Notice that there are many Intra-coded MBs at the top left of the graph.
This indicates that there is an error with Intra-coding in the encoder.

Conclusion

This tutorial demonstrated that the H.261 bitstream is not standard compliant and
that there were coding inefficiencies. These problems were discovered through
TR errors and frequency of playing. Coding inefficiencies were discovered
through graphical analysis.
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Tutorial 2: H.263 compliance and motion vectors

Tutorial 2: H.263 compliance and motion vectors

This tutorial covers the standards and compliance issues in H.263 and also
demonstrates the proper functioning of the motion vectors.

Procedure

1. To load the H.263 tutorial, click File > Example files > H.263 stream >
Rally (250K). The window title changes to MTS4EA-H.263 Example -
Rally (250k), and a warning message appears. (See Figure 9.)

T MTEADA - ¥ide? Vigw: |1.26] Ceampld - Rally {230k)
w Fla il e D fw AT s
[ o ] o0 o oo s M e Me e e i
(=0 S R R B
Decode Warning J1731: PSUPF being sent
| 2] Widen View: H 283 E wiwning Firhar | oe

P3| annl | | bil
/l e Pk O e GRS T

fimennty

Nl
UL

CORIE fufiiddtd (dor 0) hET

Tuee fewn | L UL

m hlul' 1

™ bt U Wi wrbe o1 Luduaw
[T Sha ALL Woammng whehe 1) lubaw

Fu.iil'i F e

Figure 9: Initial warning message

2. View the warning message elements:
= Warning - Indicates that the PSUPP field is being sent and ignored.

= Summary - Gives summary information about the stream.
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Tutorial 2: H.263 compliance and motion vectors

= Skip this Warning only in the future - elects to skip this particular
warning in the future (recommended).

= Skip ALL Warning alerts in the future - elects to skip this alert and
all other alerts in the future.

3. Select Skip this Warning only in the future, and then click Continue.

4. Click the * toolbar icon or type CTRL + P to resume playing the video.
Another error message appears. (See Figure 10.)

5. View the error information provided, which indicates a more serious error that
occurs at bitstream byte address 0x0c9cfa, bit 3, after frame 326.

Decode Error 21761: Error in MCBPC_P VLC

Ermar ME Layer
Q Ermar in MBCPC_PLC at position Oxc3M6 [dec. 827382] bit 7

Summary

|®

Image size [ r T
image format RGN N
tx0cBcfa (dec. 526618) bit 3 B
after 21.979

T o s !

[ Skip thiz Error only in future
[ Skip ALL Ernor alerts in future

Pavze | Continue Gaoto w

Figure 10: Initial error message
6. Click Continue. Another error message will appear. (See Figure 11.)

7. Note that it was an MBCPC error that resulted in the Out of Sync alert
message. This often occurs when one syntax error triggers a series of alerts.
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Tutorial 2: H.263 compliance and motion vectors

Decode Error 21502: Out of sync

Errar Gareral
Q Ot of sync at postion Dxc9F7 [dec. #27383) bit 2

Summany

YUV 4:2:0 8-bit
ixiccta (dec. 326618) bit 3 B
after 21.979

UGB after 326 W

|[»

[ Skip thiz Error only in future
[ Skip ALL Ernor alerts in future

Pauze | Contirue Golo

Figure 11: Out of sync error message

8. Select the Skip ALL Error alerts in the future check box, and then click
Continue.

9. To open the Alert Log, click the Alert Log icon 2. The Alert log window
will appear. (See Figure 12.)

10. Note the active filter button in the toolbar. Because Skip ALL error alerts in
the future was selected, the alert log view is filtered and the filter button is
active. The status bar indicates that 23 of 24 alerts are hidden.

11. Click the Filter icon to deactivate the filter and view all alerts. (See Figure 13.)
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Tutorial 2: H.263 compliance and motion vectors

Q-Fatd 13024 Video General Unexpected ... 327 Video OocOcSffa Unexpected ...

Figure 12: Alert Log window, filtered

Video View: H.263 Example - Rally (250k) =3

! Alert Log: H.263 Example - Rally (250k)
BT

Level | D | Source | Class | Title | Decode | Display | Address (bytes) | Details fad

L\,Waming 31751 Video Picture Layer PSUPP being ... 1 Video 0x000006 PSUPP being .

BWaming 31751 Video Picture Layer PSUPP being ... 2 Video 0x00306c PSUPP being .

LWarning 31751 Video Picture Layer PSUPP being ... 3 dae R READD s i

% Warning 31751 Video Picture Layer PSUPP being ... 4 Decode Warning 31751: PSUPP being sent

L\,Warnlng 31751 Video Picture Layer PSUPP being... 5 . .
DWarning 31751 Video PictreLayer  PSUPP being... 6 iz IR
I Warning 31751 Video Picture Layer  PSUPP being... 7 & EFDUDZE;BE’EBE%?[%32291”2"3]:35”‘3{%‘1

ﬁ\fv‘arning 31751 Video Picture Layer PSUPP being ... 8

ﬁWarning 31751 Video Picture Layer PSUPP being ... 9

L\,Waming 31751 Video Picture Layer PSUPP being ... 10

LWaming 31751 Video Picture Layer PSUPP being ... 11 SR

ﬁWaming 31751 Video Picture Layer PSUPP being ... 12

BWBrnlng 31751 Video Picture Layer PSUPP being ... 13 352 x 288 |
% Warning 31751 Video Picture Layer PSUPP being ... 14 YUV 4:2:0 8-bit L
BWarning 31751 Video Picture Layer PSUPP being ... 15 208 i
L\,Warning 31751 Video Picture Layer PSUPP being ... 16 =)
Ty Warning 31751 Video Pictre Layer  PSUPP being ... 17 DI6T e RS L]

L\,Warnlng 31751 Video Picture Layer PSUPP being ... 18 b2

2 Warning 31751 Video Picture Layer PSUPP being ... 19 P Frame

Iy Warning 31751 Video Picture Layer  PSUPP being... 20 2 2

21761 Video ME Layer Error in MCEP... 327
— 122 moe -~ 'L‘(;f T e = Skip this Warming ol in future
Total: 24 glerts | Al alerts shown = Skip ALL Warring alerts i future
Goto w |

Figure 13: Alert Log and Alert Details
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Tutorial 2: H.263 compliance and motion vectors

Level

M warning
M Warning
ﬂ\"‘!arning
L\,Warning
M warning
I warning
ﬁ'ﬂu‘arning
L\,Warning
ﬁ'\“farning
ﬂ'ﬂ’arning
ﬁ‘l"!arning
L\,Warning
B warming
A warning

1

Warning

Figure 14: Alert Log, unfiltered

14

D

31751
31751
31751
31751
31751
31751
31751
31751
31751
31751
31751
31751
31751
31751

21751

Source
Video
Video
Video
Video
video
Video
Video
Video
Video
Video
Video
Video
video
Video

Video

12. Double-click an alert to view the alert details and then click Close. View
the columns that appear in the alert log and note the column descriptions
that follow. (See Figure 14.)

13

14.

15

16

17.

Level - the severity level for the alert. Levels include Info, Warning,
Error, and Fatal.

ID - MTS4EA unique alert ID number.
Class - Syntax area where the alert occurs.
Title - Alert title.

Decode and Display - Frame numbers where the alert is decoded and
displayed (can vary).

Address - The address of the alert in the bitstream.

Details - Alert details.

Class Tite Decode Display Address (bytes) | Details

Picture Layer PSUPP being ... 1 Video 0000006 PSUPF being ...
Picture Layer PSUPP being «. 2 Video 0x00306c PSLPP being ...
Picture Layer PSUPP being ... 3 Video 0x0037e6 PSUPP being ...
Picture Layer PSUPF being ... 4 Video 0004074 FSURF being ...
Picture Layer PSUPP being ... 5 Video 0x004718 PSUPF being ...
Picture Layer PSUPP being .. 6 Video Ox005024 PSLPP being ...
Picture Layer PSUPP being ... 7 Video 0x005713 PSUPP being ...
Picture Layer FSUPF being ... & Video Ox005d52 FSURF being ...
Picture Layer PSUPP being ... 9 Video 0x0063a8 PSUPP being ...
Picture Layer PSUPP being ... 10 Video Ox0068d3 PSLPP being ...
Picture Layer PSUPP being ... 11 Video 0x006d37 PSUPP being ...
Picture Layer PSUPF being ... 12 Video 000723 FSURP being ...
Picture Layer PSUPP being ... 13 Video 0x007831 PSUPP being ...
Picture Layer PSUPP being ... 14 Video O0x007d3d PSLPP being ...
Birhire | aver P2 PP heinn 15 Viden MaeNE 129 PS PP heina

Close the Alert log and return to the main page of the application.

Click the ~ icon to play the video again with the Motion Vectors (MVs)
visible. (See Figure 15.)

Note the following about the image:

The white dots are at the center of each MacroBlock.

The white lines indicate motion vectors. The arrows for each MV point to
the position in the previous frame that contains the data for the current
MacroBlock.

Click the color transfer icon ™ to change the overlay from white to black.

To play the video again, click the ™ icon or type CTRL + A. Note that the
motion vectors are clear and accurate.

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials



Tutorial 2: H.263 compliance and motion vectors

Figure 15: Video image

Conclusion

This tutorial demonstrated where there is a standards-compliance issue in the
H.263 bitstream, but also showed that other aspects of the H.263 bitstream, such
as the motion vectors, are implemented properly.
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Tutorial 3: MPEG-4 compliance

Tutorial 3: MPEG-4 compliance

Procedure

16

This tutorial covers the following:

Basic functions

Alerts for syntax errors

Video summary tooltip
MacroBlock overlay MB types
Optimization

Frequency of intra-coding

To load the H.263 tutorial, click File > Example files > MPEG-4 Elementary
Streams > Space. An error message will appear. (See Figure 16.)

View the error details:
= The error occurs at bitstream byte address 0x11, bit 3, before VOP 1.

= The error is present in the header, and MTS4EA does an initial check of
the file header when it loads the file.

= The error indicates that method 1 quantization is in use, which is not
allowed because the stream is Simple Profile.

Click Continue. MTS4EA loads the stream, and the window title changes to
MTS4EA-MPEG4 Example-Space.

Click the ™ icon or type CTRL + P to resume playing the stream. The same
error message will appear. (See Figure 16.)

Click Continue. A warning message will appear. (See Figure 17.)

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials



Tutorial 3: MPEG-4 compliance

Decode Error 23042: Method 1 quantisation not allowed in SP' [zi

Emor ideo Object Layer
Error: quant_type is "1’ at position 0x11 [dec. 17), bit start 3. Not allowed

in Simple Profile.

Summary

1>

T e
Sream s 05y1ee B
[ e [
T

I e
.

[~ Skip thiz Error only in future
[ Skip ALL Erer slerts in fuluie

[ Abot_| Pause l Cnntinual Golo vI

Figure 16: Initial error message

Decode Warning 33001: modulo_time_base is zero

W aming Video Object Plane
WARNING: modulo_time_base is zero after vop_time_increment is reset
al position 046186 [dec. 24968, bit 3

Sumnmeary

I 2 0 5
Ry re
TS 0006182 (dec. 24352) b2 7

e R

o [ .

R0yl after 12

= .

I~ Skip this Waming ondy in fulure
[™ Skip ALL Waming aletts in fulure

Figure 17: Initial warning message

6. Click Goto, and then click Hex. (See Figure 17.) The Hex view appears with
the error location highlighted. (See Figure 18.)

7. Close the Hex view and again view the initial error shown message. The error
occurs because modulo time base was set to 1 after a whole second elapsed

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials 17



Tutorial 3: MPEG-4 compliance

™ Bin

: MPEG4 Example - Space

¥ Hex W aSCl [ ~ | Bytes per e Gote IAbsqut& addiess v| & Hex " Dec

since the modulo_time base was last 1 (at which time vop_time increment
should be reset, although not necessarily to zero).

8. Click the ™ icon or type CTRL + P to resume playing the stream. An alert
appears again. (See Figure 17.)

9. In the alert dialog box, select Skip this Warning only in the future, and
then click Continue.

10. Complete the video and observe whether it works properly.

N616E
06174
06174
06180
06186
De18C
06192
06198
0613E
06144
061AA
0&61ED
061E6
061BC
061C2
061C8
061CE
061D4
061D4
0&1ED
061E&
061EC

niiionii
11100001
11011111
11011011
01010000
10110110
11001100
10110111
11000001
01111110
01101101
00110000
11011111
11011011
10011011
10000111
00111101
0111001
11110000
11001100
nioo0111
10110111

01101101
11001101
10000111
01111110
10111000
11111100
00010001
11100001
00011110
00011100
11111000
01000111
10000111
01111110
01101101
00110110
10110111
10110110
11100110
00010001
10110110
11100001

Address: Ox6186 (24066) bit 3

10111111
10110110
00110110
00000000
00000100
00111001
11101101
11001101
11011011
11011011
01110011
10110110
00110110
00011100
11111000
11011011
11100001
11011111
00001000
11101101
11111100
11001101

00001110 01101101 10110111 E 6D B7 sm =m ~
11111100 00111001 10110110 EL CD BG FC 3% B6 3
11011011 11110000 11100110 DF 87 36 DB FO E6 6
00000000 00000001 10110110 DB 7E 00 00 01 B =~
10000111 00110000 01000111 S0 B2 04 87 20 47 P0G
10110110 11011111 11100001 B6 FC 39 B6 DF El 9
10111111 00001110 01101101 CC 11 ED BF OE 6D e
10110110 11111110 00011100 B7 E1 CD Bé FE 1C
11110000 11100110 11011011 C1 1E DE FO E6 DB
01101111 11000011 10011011 7E 1C DB 6F C3 9B ~ o
01101101 10111111 10000111 6D F8 73 6D BF 87 m =n

11111100 00111001 10110110 30 47 Bs FC 39 B6 0G 9
11011011 11110000 11100110 DF 87 36 DB FO E6 &
11011011 01101111 11000011 DB 7E IC DB 6F C3 ~ o
01110011 01101101 10111111 9B 6D F& 73 6D BF m sm
11111100 00111001 10000010 87 36 DB FC 3% 82 6
11001101 10110110 11111100 3D B7 EL CD Bé FC =
10000111 00110110 11011011 39 Be DF 87 36 DB 9 &

11110110 11011111 11100001 FO0 Ee 08 Fe DF El

10111111 10000111 00110000 CC 11 ED BF &7 30 1]
00111001 10000010 00111101 47 Be FC 39 82 3D G 9 =
10110110 11111100 00111001 B7 E1 CD Be FC 39 9

Figure 18: Hex view with error location
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11. From the Overlay menu, click Video summary tooltip to enable the Video
Summary tooltip.

12. View the Final Video Summary Tooltip and note these field descriptions.
(See Figure 19.)

Image size: 352 pixels high x 288 pixels wide (CIF).
Stream size: 976 kBytes.

Total frames: 175.

Total play time of the sequence: 13.920 seconds.
Total bits: 7,998,576.

Bandwidth required to transmit this: 574 kbits/second.
Frame play rate: 12.50 frames per second (Hz).

Clip is MPEG-4 Simple Profile with Resync markers & Method 1
quantification.
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13. Observe how the sequence looks, and then close the Final Video Summary

window.
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Figure 19: Final video summary tooltip
14.

To see if the codec makes the best use of the MPEG-4 standard, open the

Overlay menu, and then click MB Types (you can also type CTRL+ Y).

The MB Types key appears.

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials

Move forward 3 frames. The MB types are color-coded. (See Figure 20.)
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Figure 20: MB Types color key

16. Move forward to frame 34. Note that there are several green (intra) coded
MacroBlocks in the static black background (intra coded MBs generally use
the most bits). (See Figure 21.)

17. View frames 35, 36 and 37, and observe that the MacroBlocks disappear.
(See Figure 22.)

18. Go back to frame 34.

19. From the Overlay menu, click MB Statistics, and then click Bits. Note that
the black background uses a high number of bits. (See Figure 23.)

20. View frames 35, 36 and 37, and observe that the background uses
progressively fewer bits. (See Figure 24.)

21. Compare frame 34 with frame 37. Observe that the black background in
frame 34 is coded and uses many bits, while the black background in frame
37 is not coded, and it uses no bits.
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© MPEG4 Example - Space
Fiooo34 | |

© MPEG4 Example - Space D MPEG4 Example - Space
| |F00036) | | | ([ P

Figure 22: Frames 35, 36, and 37, color key

Video View: MPEG4 Example - Space (=113

Figure 23: Frame 34
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[E] Video View: MPEG4 Example - Space E)E)R) | [ video View: MPEG4 Example - Space [E)EX] | [E] video View: MPEG4 Exam

F:00036 F:00037

Figure 24: Frames 35, 36 and 37

Conclusion
This tutorial demonstrated how to:
®  Use and interpret the alert pop-up messages.
B Use the Video summary tooltip and understand the information provided.
m  Use the MacroBlock overlays: MB types and motion vectors.

B Use the hexview bitstream viewer.

Additional information It appears that the encoder chooses MB types less than optimally by using intra
covered  MBs for the background, which wastes many bits.

B Consider whether there are software bugs, such that the encoder is too
sensitive to minor changes in the gray level.

B Check the encoder part of the codec that decides when to use Intra MBs and
Inter MBs, and when to not code the MB.

Fixing this problem would save many wasted data bits.

NOTE. The MPEG-4 standard provides more data bits for intensity-gray level
than for color information, so it is naturally more sensitive to changes in gray
level (this mimics the human visual system). However, it appears that the
sensitivity to gray in this example is too great.
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Tutorial 4: MPEG-4 optimization

This tutorial covers the following:

Use of the video navigator view.

Use of trace.

Common error: stuffing bits; using HexView to examine bitstream data.
Synchronizing views.

Saving a setup in project files.

This tutorial requires that you have completed the previous tutorials and that
you can perform the following tasks:

Procedure

Play, stop, step forward, and fast forward a video.

Use and interpret the alert messages.

Use the Video summary tooltip and understand the provided information.
Use the MacroBlock overlays: MB types and motion vectors.

Use the MacroBlock and Summary tooltips.

Use the hexview bitstream viewer.

View Trace files: Parse bitstream and interpret.

To load the MPEG-4 tutorial, click File > Example files > MPEG-4
Elementary streams> Window Car. A stuffing_bits error occurs at stream
address 0x9, bit 1, when the file is loaded. (See Figure 25.)

Check the box next to Skip this, and then click Continue when the
stuffing_bits alert appears.
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Decode Warning 33002: Incorrect stuffing bits

Wanng Video Object Plane

WARNING: frst b of shufing bats s ot T at bt 1 88 posion [ [dec
i 1 9} going on to next brte.

Summary

IR i a
Stream size (\Bytes) £

e

Detore 1

I Skip this Wairing only in fuluee
™ SkipALL Warng slerts i future

| Pouse | Contiwe | Goto v

Figure 25: Stuffing_bits alert

3. Play the video to the end. Select Skip this and then click Continue when the

VCYV overflow alert appears. (See Figure 26.)

Decode Warning 33015: VCV overflow

Video Object Plane
mwvmmmmwmnumm ~
£ e 0,000 The rame 2,

bistream position 0x1c04 [dec. 71721 muww.\rmmuw
5 594.0 Maceob s and the madmm lmdt i 395.0 MacroBs. VOV
Mmmmamedlmpolh_m_mﬂ_mmn 2

NOTE: displary ve. dacoos ofder

|

I Ship the: Waming only in fulure
I™ Ship ALL Wairing alests in future

Aot | Pame | Contiwe | Gowo v |

Figure 26: VCV overflow alert

4. Click the Video Navigator icon @ The Video Navigator window will appear
in either Detail (See Figure 27.) or Thumbnail view. (See Figure 28.)

Display frame # 3 0 A—
wmber: not ) e —
number: polte y [T 3 A MR e

diffarence to

- . = e
fram
dacodea frame
e (L] nw e
R ' n W D0

e »

Hex address
" of start of

decode frame

Bite for the
b= frame

| Display Lme

(sacondls)

Figure 27: Video Navigator window, detail view
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* Video Mavigator: MPEG4 Example - Window Car
is m

N = e

B-VOP2:0,033s B-¥OP: 3:0.067s B-WOP:4:0.100s

=

B-¥OP:8:0.233s

=

S{GMC}-VOP:5:0,1335 B-VOPi6:0.167s

! g E S
- L - e

S{GMCHYVOP:9:0.267s B-VOP: 10:0.300s B-¥OP:11:0.333s B-VOP:12:0.367s

L S

[ e T D e T T e bt
Figure 28: Video Navigator window, thumbnail view

5. To synchronize the video window and the video navigator, start by selecting
Tile Horizontally on the Window menu to view the tiles horizontally. The
following views can also be synchronized:

= Buffer analysis
= HexView

= Alert log

= Fidelity analysis

= Trace/Parse bitstream and Trace/Interpret

Figure 29: Horizontal view

6. Click the synchronize views icon. (See Figure 30.)
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26

D m S4EA - Video Navigator: MPEG4 Example - Window Car
jgiley Apslysis Alert Window Help

L W A A W [ M o IVOP ~]| /@

Figure 30: Synchronizing views

7.

Play through the entire sequence again. This time, the video navigator and the
video views are synchronized.

Click the icon at the top left corner of the video navigator window to see the
thumbnail view. Each thumbnail is labeled with the frame type, display frame
number, and the display time (in seconds). (See Figure 31.)
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£

- - A
BVOPI66:2.1675 B-VOP:67:2.2005 B-VOP:68:2.2335 5!

-
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B-YOP:76:2.500s S{GMCH-WOP:77:2.533s B-WOP78:2.567s B-VOP:79:2.6005 B-VIOP:80:2.633s
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Figure 31: Video Navigator window, thumbnail view

NOTE. The last frame should now be displayed in the video window.

9. Double-click on frame 57. Decoding restarts from the beginning and stops at
frame 57. (See Figure 32.)

Figure 32: Synced navigator and video window views of frame 57 and frame 51
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10. Double-click on frame 51 and note that the view immediately changes and
does not start from the beginning again. (See Figure 32.)

NOTE. MTS4EA has a cache of data, the size of which is selectable in the Play
menu under Decoder Options and then the General tab. However, if the video is
stopped (for example, played to the end), then the cache must be refilled.

11. Right-click on any view. Select Goto view, and then select Trace/Interpret
from the drop-down menu. View the Trace files, frames 1-3. An alert will
appear. (See Figure 33.)

} (128 H ’ ¥
i« ¥

Figure 33: Trace files warning, frames 1-3

NOTE. Warnings, errors, and fatals are always shown in the Trace/Parse
bitstream and Trace/Interpret files, whether or not the pop-up alerts are enabled.

12. In the Trace/Interpret window, select the address 0x00000009,1 and
right-click. Select Goto view and then Hex. The HexView will open with
the selected location highlighted. MTS4EA shows exactly where the problem
is: bits 1 and 0 of byte 9 are both 1, but for stuffing bits, they should be 01.
(See Figure 34.)
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Hex: MPEGA Example  Window Car

Hex © Uac

00000001 10110101 00000000 00000000 00000001 DOODOOOL
00000000 0QQOOooD 00100000 Q0001000 11001000 10001000
10000000 00001111 01010000 10110000 01000010 01000001 01100000
L1000UL0 U0l1uguy U1111111 YUyUouuu gouououy uoouyuul 1011011e
00010000 01100010 Q0011001 00000101 O0041110 i}
00100101 10110100 ALLODLOO
10011111 fii1i001
niplinnn 11101010
10100001 11111101 11011
10000111 11100111 10100
11110101 01100110 11011101 11011110 01100011 10101110

11011001 U1UUULUL 110331100 1UUUIILU U11UU111 110UU11 UULUULLL E u
11100000 10010000 111010010 10101801 01100101 10101110 10100011 (-}
b2 DREUUNIIER LS S L A L e R B D A SN IS afr

Figure 34: Selecting Hex from the Trace window

13. View the HewView window and its information. You can search for items

(T3]

using “.” as a wildcard character. For example, you can enter the start code
0001b. to find 0001b1, 0001b5, and 0001b6. (See Figure 35.)

View binary, - -

’ Set bytes ) ,
hex, ASCIT W,V.",‘.\ﬁ.",[ Find / Goto previous / next address,
inany lire binary/ hex/asSCll data
combination

Hex: M GA Window Car
Convert
yyeuuRRY YUUU 1110WVIN PUUUUULY yuuuuugy W Fd VO ““Ll
anoannol 10 nnon oonaanns aonnonnl noooaaal 0 o0 o
. nAAnnnDn pnn nnna nnaninan antenn 1aaninnn nna ca Val“ﬁs
1UOUUURY UUUULL111 VAVIVOUY LUL1UUUY UIUVUNID ULUUUUUL UV11UUUO0 ¥V UF SU BU 42 41 &0 F EA
1000010 00110000 61111111 BO0NOOOON DAOOOOAA OAOOOOO1 10114116 £ 30 *F 00 OO 01 B& O dccir”dl
QUOLUOUY ULLU0ULU YUULLUUL DUGUULUL UUULLLLY LLLUUUUL 1lU11U01 AV BZ 1Y 0% LEEL DY b
16AL6L 10110100 O118GLA0 61011101 11681111 GLAL1L10 OOAL1011 2% B4 64 50 CF 5K IA & d4] * b hex
11900111 10011111 11959001 00010100 11099990 11110000 11100018 E? 9F F9 14 DE Fn E3
41110101 01011000 11102010 01110101 OOL11101 OLOULOUL0 10000100 K% 56 EA 7% JD %2 94 X weR d
AO0LIOL0 10100061 11100001 LIOLLOLO 61611001 OLOLLOO0 10116118 1A AL FD DA SF 5S4 Bé = 4 (En
01140111 10000111 11900141 10100100 11110090 A0111101 10111940 77 87 E? A4 F? 3D BE » - 1
1110101 01100110 11011101 L1011110 01100011 10101110 00101101 F% 66 DD DE €3 AE 20 & = - vice-
11011001 01000101 11011100 10001110 01100911 11000111 00100112 D9 45 D AF 67 €7 27 E w ' .
41101101 10010000 11101001 LO101101 01100401 10101110 10100011 ED 90 E9 AD (5 AE AD L] VFIEE}
B I L D R
2 e
Bitstream \ / \
g1
address of Address of
start of nighlighted data Binary data Hex data ASCIT data

line (hex)

Figure 35: HexView window

14. Save your setup by clicking File and then selecting Save project. You can
change the filename. (See Figure 36.)
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Conclusion

30

Save project file @El

Save n | 3 MTS4EA = ok B~
ﬁl default.vpp

File name: ampl pp

Save as lype: |HTS 4EA projects (vpp) l] Cancel

Figure 36: Saving a project file
15. Close MTS4EA completely.
16. Restart MTS4EA.

17. Select the project file that you saved previously from the File drop-down
menu. An alert will pop up when the video file is loaded. Dismiss it by
selecting Skip this and Continue. (See Figure 37.)

T MTS4EA - MTS4EAT
P8 Play Overlay  Analysis  Alet  Window

= Open vides, ., Chel+O

[A Mew project

(2 Open project. ..

B save poject...
Save project as.,,

Open other..,

Example files K

1 MPEG4 Examgle - Wincow Car.vpp

2 Window car inkerpret F1-3.vpt \
3 Window car parse bitslrearn F1-3,vpt

4 Canary wharf interpret f1-2.vpt

5 Canay wharf parse bitstream f1-2.vpt

& ave_2.vpk
Zmp2_3.vpt
Bmp2_2.vpt

Exit

Figure 37: Opening the project file

This tutorial demonstrated how to:
= View different video data and navigate between different views.
®  Store setups.

B [dentify stuffed bit errors.
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This tutorial covers the following:

Tutorial 5: MP4 compliance basics

B Opening an MP4 file and viewing the tracks.

B Syntax error: not obeying Profile/Level restrictions.

B Extracting and saving the video track.

B Viewing MP4 file structure.

This tutorial requires that you have completed the previous tutorials and that

you can perform the following tasks:

® Play, stop, step forward, and fast forward a video.

B Use and interpret the alert messages.

B Use the Video summary tooltip and understand the provided information.

m  Use the MacroBlock overlays: MB types and motion vectors.

B Use the hexview bitstream viewer.

Procedure

1. To load the MP4 tutorial, click File > Example files > MP4 Files> Packet
Woman. A list of tracks included in the MP4 appears in a dialog box. (See

Figure 38.)

2. View the track information included in the dialog box. The video track ID,
for example, is 001. Although there can be multiple tracks, the first video

track is selected automatically.

3. Click OK. The video track is analyzed, and an error message appears. (See

Figure 39.)

4. View the error message details: (See Figure 39.)

= The VOP has more MacroBlocks (396) than allowed in MPEG-4 / Simple
Profile / Level 1: the maximum number allowed is 99.

= This is likely an error with the level. It is stated as Level 1 in the encoded
file, but it is actually the size of a Level 2.

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials
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32

®

M Elementary stream select

Select elementary streams to decode from MP4 file

Select | Type [D | Desaiption | Bytes | Soambled | Decoder
Fl & wveecapartz 001 Visual stream 690840 No MPEG-4 part 2

<

>
[ Hide unknown streams Video: Iuack:mi M

¥ Hide emply streams
¥ Hide liee pudio: [N selection)

Estended stream search

Search

| | 0K I Cancel I

Figure 38: Track list

Decode Error 23021: Too many MBs for ProfileflLevel @

Enar ‘Yideo Object Layer

[WOL) {MP4} Error: VOP [ height * width ) gives no. of MBz = 396 : too
mary MBz for Profile/Level (max = 39 (Eror ignored: actual width &
height used ]

Surnrmary

~
[ unknown

Stream size (kBytes) Lp

Time (secs) LOEC]

I e o

a

¥ Skip this Errar only in future
[ Skip ALL Error alerts in fubure

spot | Pause | [ Contime |  Gowo ¥

Figure 39: Initial error message
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5. Select Skip this Error only in the future, and then click Continue.
MTS4EA will continue, by using the actual size. A buffer conformance
warning message appears. (See Figure 40.)

6. View the warning message details: (See Figure 40.)

= Overflow by 297 MB.

= This error is to be expected, because the Level is incorrectly given as
L1 (which has a limit of 99 MBs) whereas it should be L2 (which has
a limit of 396 MBs).

Deeocde Warning 33015: VCV overflow @

‘waming Yideo Object Plans

F"' Wideo Complexity Verifier model has overflowed by 297 0 MacioBs at S
E/ H time 0.000s.The overflow occumed duing the decoding of fame 1,
bitstream position 00 [dec. 0). The total VOV bulfer occupancy is
396.0 MacroB s and the masimum Bmit is 99.0 MacioBs. WCV
parameters were derrved from profle_and_level_indication in -

Sumemary NOTE: display vs. decode order

IS 552 x 268 2

Stream size (kBytes) [xH
0x00001c (dec. 28) bt 7
Time (secs) QAT

WOP type (80
Vo]
[ vorro | 2

W Skip this Waming only in futue
[~ Skip ALL Warning alests in fulure

| Al]:lli | Pwse || Eﬂnﬁnuel | Goto x|

Figure 40: VCV overflow warning message

7. Select Skip this Warning only in the future, and then click Continue.
Another buffer conformance warning message appears. (See Figure 41.)

8. Select Skip this Warning only in the future, and then click Continue.
9. To ensure that the application window is active, click the Title bar.

10. From the analysis menu, select View video stream structure. The Structure
window appears. (See Figure 42.)

11. View the top-level atoms in the MP4 file. Click the + next to each atom to
view the data for the atom.
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Decocde Warning 33014: VBY underflow

‘waming

Summary

X

Video Object Plane

' Wideo Buffer Verifier model has underflowed by 16015 bits at time
it 0.3603. The undetflow occuned during the decoding of frame 10,
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derived from profile_and_level_indication in VisualObjectS equence
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VOP type B 4
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)
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Figure 41: VBV underflow warning

E Structure: MPEG4 File Example - Packet Woman (video)

CEX

Strean: IMP4
Syritax Value Start bat Size (bits)
= file 0x000000, 7 5549 134
=59 fyp 0x000000, 7 192
123 size 24 0x000000,7 32
123 type ftvp 0x000004,7 32
123 major_brand mp42 0x000008, 7 32
123 Minor_Version
== compatible_brands Lt 0x000010,7 0
=-dy mdat 0x000018,7 5526560
123 size 630820 0x000018,7 32
123 type mdat 0x00001c,7 32
data [32, 630844 0x000020,7 5526496
=y mdat 0x0a8a0c, 7 368
123 size 46 0x0a8a%¢c,7 32
123 type mdat 0x0a8aa0,7 2
(o] data [690852, 530820] 0x028224,7 304
=3 moov Ox0a8aca,7 22064
i23 size 2753 0xDaBaca,7 32
123 type Mmooy OxDaBace,7 32
#-5 unknawn 0x0aBad2,7 64
(3 iods 0Ox0asb3e,7 33%
9 trak 0x0a8b&d, 7 9696
+ g wak 0x055024,7 3432
= trak 0x0a91d1,7 3304
# (9 udta 0x0a336e,7 4368
15| | 55
— —_—

Figure 42: Structure window

12. From the File menu, click Close stream, and then reopen the stream.

13. When the track list appears, click Extract. (See Figure 43.) The Save stream
file as dialog box appears. (See Figure 44.)
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Figure 43: Track list

Save stream file as

Eaveir_lif_“]viden j © @ cF B-
e mpegz-conf,
Dasp () Other

) Customer ) Simple
JH263 ) Tutorial
h2é4 vl

mpd ) vchips

( - — - } .:
File name: |.m4v | Save I
Save as type: IMF'EG-4 Elementary Stream [*.mdw] :J Cancel |

Figure 44: Save stream file as dialog box

14. In the Save stream file as dialog box, type a different file name if required.
The track ID and video file type has been automatically appended to the file
name.

NOTE. To open this dialog box in the future for a video track that was not
extracted at the time the MP4 file was first opened, open the File menu and then
click Save stream file as.

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials 35



Tutorial 5: MP4 compliance basics

This tutorial demonstrated how to:

Conclusion
| |
| |
| |
| |
36

View the tracks in an MP4 file.
Extract and play a video, while checking for errors.
Identify and locate the Level conformance error.

Identify two buffer conformance errors (see Tutorial 5 for details about buffer
analysis).
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Tutorial 6: MP4 optimization

Procedure

This tutorial covers the following:
B Opening an MP4 file and viewing the video track.
B Using the Video summary tooltip and the MB types overlay.

B Performing optimization checks that could reduce bit usage by 45% in this
sequence.

This tutorial requires that you have completed the previous tutorials, and that
you know how to:

m  Play, stop, step forward, and fast forward the video.

®  Use and interpret the pop-up alerts.

B Use the Video summary tooltip and understand the information provided.
m  Use the MacroBlock overlays: MB types and motion vectors.

®  Use the hexview bitstream viewer.

B Open MP4 files, view/extract the video, and view the MP4 file structure.

1. To load the MP4 tutorial, click File > Example files > MP4 Files > Picadilly

Circus. A list of tracks included in the MP4 appears in a dialog box. (See
Figure 45.)

2. View the track information included in the dialog box. The video track ID,

for example, is 001. Although there can be multiple tracks, the first video
track is selected automatically.

3. Click OK.
4. To view the Video Summary tooltip, click the & icon or type CTRL + U.
5. To view the MB types overlay, click the £ jcon or type CTRL + M.

6. Click the * icon. A VCV buffer conformance warning message appears.
(See Figure 46.)
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M Elementary stream select EL
Select elementany streams o decode from MP4 file
Select | Type [ [ Desaription [ eytes [ Soombled | Decoder
[ & wrec4part2 001 Visual stream 733169 Mo MPEG-4 part 2
002 Object descriptor stream 0 No
003 Scene description stream 0 No
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= : rack:
P Video:  [ack:001 Goto
W~ Audio: EiNo selection)
Estended stieam search
Search |
| 0k | Cancel
|

Figure 45: Track list
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tire 0.040z. The overflow occured duning the decoding of frame 2, ;
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Sumenary MOTE: display ws. decode order

image size Berp e e
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WOP type LA
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| Decode VOP no. B @

¥ Skip this Warning only in future
7 Skip ALL ‘Wearning alerts in uture

&bort | Fause ! Vﬁoto v]

Figure 46: VCV buffer conformance warning message

7. Select Skip this Warning only in the future, and then click Continue.

8. View the progression of frames, and note that the first frame is green, as is
every third frame (Intra MBs). (See Figure 47.) Another buffer conformance

warning message appears. (See Figure 48.)
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Figure 48: VBV underflow warning

9. Select Skip this Warning only in the future, and then click Continue.

10. To replay the video file, click Pause, step forward. Note that the first frame
takes 32,456 bits. (See Figure 49.)
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Figure 49: Frame 1
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11.

12.
13.

14.
15.

TR v e AT Fadany B Dl 4 Rl

Click the red close button to remove the MB Types Key window.

Click the # icon twice to reopen the MB Types Key window.

To undock the MB Types Key window, hold the CTRL key, while dragging
it with the mouse pointer.

View the next six frames, including Frame 2. (See Figure 50.)

For each frame, view the details, which are outlined in Table 3.
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Figure 50: Frame 2

Table 3: Frame details

Frame Frame type Bits used
2 P-VOP 7,208

3 P-VOP 7,792

4 [-VOP 33,152

5 P-VOP 7,216

6 P-VOP 8,776

7 [-VOP 34,344

This tutorial demonstrated the following:

®  The [I-VOPs require about 4.5 times as many bits as the P-VOPs.

B There are [-VOPs every 3rd frame.

B There is no need to have [-VOPs so often. If the frequency of I-VOPs were
reduced to 1 in 30, the bits used for the sequence would reduce by ~45%.

B You can reduce the number of bits used.
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Tutorial 7: 3GPP/MPEG-4 compliance

Tutorial 7: 3GPP/MPEG-4 compliance

This tutorial covers the following:

42

Opening a 3GPP file and viewing the tracks.
Viewing syntax errors using reserved Profile/Level indication.

Performing optimization checks that may or may not be applicable in a
wireless environment.

This tutorial requires that you have completed the previous tutorials, and that
you know how to:

Play, stop, step forward, and fast forward the video.

Use and interpret the pop-up alerts.

Use the Video summary tooltip and understand the information provided.
Use the MacroBlock overlays: MB types and motion vectors.

Use the hexview bitstream viewer.

Open MP4 files, view/extract the video, and view the MP4 file structure.
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Tutorial 7: 3GPP/MPEG-4 compliance

Procedure

1. To load the 3GPP tutorial, click File > Example files > 3GPP File > Mobile
Hands. A list of tracks included in the 3GPP appears in a dialog box. The
first video track is automatically selected. (See Figure 51.)

M Elementary stream select E]

Select elementary streams to decode from MP4 file
select | Type [ | Description | Bytes | Scrambled | Decoder
& wPEG-4part2 001 visual stream 273233 No MPEG-4 part 2
002 Object descriptor stream 0 Mo
003 Scene description stream 0 MNe
< >
I Hi ; :
Video: |track:001 Goto
- ' ]
[¥ Hide tree Audiac I[No selection]
Extended stream search
Search I
| 0K | Cancel

Figure 51: 3GPP track list
2. Click OK.

3. An alert will appear for a syntax error. This error shows as a reserved value
(0) for profile_and level indication. (See Figure 52.)

4. Click Continue and do not enable Skip.
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Decode Error 23001: Reserved Profile/level E|

Error Wisual Object Sequence

Enor: VOS] {MP4} Profile/Level = 0x0 at pasition Oxd (dec. 4), bit start
7.1s RESERVED value or not supported in this version of Yprave -
value will be ignored

Summary

: M
| image size [T -
Stream size (kBytes) P4

Y

Figure 52: Syntax error alert

5. Run Trace/Interpret (frame 1) and look at the error at address 4, bit 7. (See
Figure 53.)

= lrace: Mahile hands Inferprad.wpi

[ Loerwmberr | Fed  Frev | Med| @ e W Wenng B beme [ Tl

Standard HPEG=4. Simple Protile -
Hemyno, Data Fartibioning

Frama mizm: 1Tix144

Filesize 166 kBytes

(Ouinooonmm, 75 [VO=] [HFE] wimual obyeoh eequencoe_atark_ococde = Oelbd {should e Gelbi)

LLLLLALLLLE L L
Error
i

(Ox0D0DO0004,7) Erver: [VOS] (HP4)} Proafdle-Taeal = Oe0 at posdtdien Oxd (de= 4), bit stare 4

(Un00O0000S.7) } {IH{ v::uu ~abject_ctart_code = lebe [thcm.d ba Ux1b%)
(MuRBNONODG, 7) '.'rn mal_ohjoot_identifier mual chjootk wvernion T ok
f0wNONNNAAY ) (VN 1 (MPAY wizual Abiaet rwas = 0001 - u-m-n m

Figure 53: Trace/Interpret error at address 4, bit 7

6. Play the video again and at the error, click Goto and then select Hex from the
drop-down menu. (See Figure 54.)
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Tutorial 7: 3GPP/MPEG-4 compliance
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Figure 54: Selecting Hex from the Goto drop down menu

7. The HexView window will appear with the location of the error bits
highlighted. (See Figure 55.)

1 1
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BO0Ld OLOOOOOD O0O0OLI0 OLLOLODO GOLOLLOO QOLOODON
BO0LY LOBLOOOD 1OLOO0LIO LOOOLLIL OODGOODD QGOOOOON
DOOLT OARORODL 10LLOLIO GOOLOOO0 GLLOGOLO QOOLODON
UUULS 10111011 BU111111 11010111 110 U pupusuw i
DU UUII0U1I1 1111111 UGUDUUUL UDUUULUY LUUDUDUUT 33 YF U unoul g
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U4y 10101111 1001100 UBUDUUUD UL10UL10 UBDUUULD Ak AL UU BB U0 L
UUUEy UUDUDULUY 100UUUID IUUUUUIU UUULULILIU 11011131 UU B2 BY 1e DE
UUUAC LIUL0aUl 1L1L1ULUL lUUUUUUY UUUULIUN LLIULLILL U% By WU UL DF
UUUdl UUUUOUDY UUUUDUUY LUUUUULL LUUUUULU UOULULLD VU uU B2 Y b
00046 11010101 OL111010 10110110 10110000 OOO00O0OL DS 74 B6 BD 01 2
00048 10111000 00100100 10111001 0QOOOOOO0 OOQOOOQOD B9 24 B2 0D 00 9
00030 10000100 10000010 00100010 11011111 00110101 B4 B2 22 DF 35 - 9 -~

JAkbrrisi el (1)

Figure 55: HexView window with error locations highlighted
8. To look at the VOP types, first stop the stream if it is playing.
9. Click the Summary tooltip icon 1=l to turn on the tooltip.

10. Click the MB Types Overlay icon # (o turn on the overlay.

11. Play or Pause/Step forward through the sequence to the end. Notice that the
first frame and every second frame are Intra-MBs. (See Figure 56.)
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Figure 56: Viewing VOP types

12. Now examine the error resilience by clicking the Summary tooltip icon El
to turn the tooltip on again, if it is not already on.

13. Click the Pause/Step Forward icon ™ {0 move to frame 1.

14. Notice in the Summary window that resync markers and data partitioning
are both on. This is vital for good error resilience in a mobile environment.
(See Figure 57.)

Summary

| 0000000 (dec. 0) bit 7
1 0040

ve (A e

1

} 1

1 12800

2kl MPEG-4
Simple Profile
Resync, Data Partitioning

Figure 57: Summary window data
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Conclusion

This tutorial demonstrated the following:
®  Using the Summary tooltip allows you to look at VOP types.

B Reducing the frequency of [-VOPs can allow for better quality video in the
same bit-rate.

B With error resilience tools in use, the frequency of I-VOPs can be reduced,
reducing the bit-rate by approximately 15%.
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Tutorial 8: H.264/AVC syntax error

Tutorial 8: H.264/AVC syntax error

This tutorial covers the following:

Procedure

48

Opening an H.264/AVC byte stream.
Syntax error in PPS
Finding the frame number of the error.

Examining the byte stream syntax and finding the error using Trace/Parse
bitstream and Trace/Interpret.

To load the tutorial, click File > Example files > H.264/AVC Byte Streams>
Canary Wharf.

An incorrect direct_8x8_inference_flag error will occur at address 0x0, bit 7,
when the file is loaded. (See Figure 58.)

Decode Error 24027: Incorrect direct_8x8_inference_flag rz|

Error RBSP.SPS
Q direct_Bw8_mference_flag iz 0. This iz not permitted n Extended Profile.

S

i

176 x 144 st
0000000 (dec. 0) kit 7

befare Frame 1

betore Frame 1

Decode Frame no. §

[ Skip this Enor only in fubure
[T Skip ALL Ewor alests in future

| Abort | Pauze Continue ] -

Figure 58: Direct_8x8_inference_flag error alert

3. Notice that the syntax error occurs before frame 1. This is the displayed frame

number. Check the Skip this box and then click Continue. (See Figure 58.)
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4. An invalid Picture Parameter Set ID error will occur during the decode of
frame 1. Use the scroll bar to view all of the information in the error dialog
box. (See Figure 59.)

Decode Error 24304: Invalid Picture Parameter Set [?l

Error RBSP

Trwing to use an invalid [uninitialized] Picture Parameter SetwithID 1, at
pozition Oxlc [dec. 28], bit 7. Vprove will attempt ko use value from
presvious slice header, 1D 0

0x000000 (dec. 0) bit 7

L ER &= before Frame 1

(=N =N bafore Frame 1
Decods Frame no. i

W
[ Skip this Error anly in futune
[ Skip ALL Error alerts in future
&bart Pause Continue Goto -

Figure 59: Invalid Picture Parameter Set ID error

5. Click on Analysis in the menu. Select Trace enable and then select Frame
range from the drop-down menu.

6. Set the frame range from 1 to 2. This will run the Trace/Interpret and
Trace/Parse bitstream on frames 1 and 2.

7. View the Trace file and clear the Frame box. Click Find Next three times.
An error alert will appear. (See Figure 60.)

I | e, Fall |n.|:uu| Fim 7 ween [ e [ Ted
000l DRE {0x00DDBEIE. 6} . SLICE_TTFE -
(111 m——— plimiiiiiE e, ¥) ¢ PG PEMARKTION T 1D

ne pemivien i+

Figure 60: Trace/Parse bitstream error
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Tutorial 8: H.264/AVC syntax error

Conclusion
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8. View the Trace/Interpret for the same range. Clear the Frame box and click

Find Next twice. An error alert will appear. (See Figure 61.)
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Figure 61: Trace/Interpret error alert

9. To determine if the pic_parameter_set_id number 1 has been set, search for
it in the Trace/Interpret file that is already open (frames 1 and 2).

10. Select the Text box in the Trace/Interpret window and type
pic_parameter_set_id= in the text box.

11. Click Find Prev to search for an occurrence of pic_parameter_set id before
the error. Note that it does not occur before the location of the PPS ID error

(at Ox1c, 7). (See Figure 62.)
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Figure 62: Pic_parameter_set_id error location search

This tutorial demonstrated the following:

B The pic_parameter_set id=1 did not occur before the slice header tried to use

this in frame 1, and therefore caused an error.

B Jtis an error to set the PPS ID to 1 at stream address 0x1c, bit 7.
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Tutorial 8: H.264/AVC syntax error

m  With this error, the MTS4EA decoder uses the data from the last known good
pic_parameter Set id (ID 0) and continues decoding.

NOTE. This may not always be possible and could generate other consequential
errors.

®  THE MTS4EA showed what the error was and where it occurred.

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials 51



Tutorial 9: MPEG-4 and H.264/AVC buffer analysis

Tutorial 9: MPEG-4

and H.264/AVC buffer analysis

This tutorial covers the following:

Buffer analysis in real-time (VBV, VCV, VMV of MPEG-4 ES).

= Information provided - values, overflow/underflow indications.
= Icon controls for navigation through the graphs.

Buffer conformance errors/alerts.

= Graphs.

= Error dialog boxes.

Achieving conformance.

= Altering the buffer parameters and seeing the effect in the graph.
= Adjusting values to prevent overflow.

HRD buffer analysis in H.264/AVC.

This tutorial requires that you have completed the previous tutorials, and that

you
[

know how to:
Play, stop, step forward, and fast forward a video.

Use and interpret the alert messages.

This tutorial also requires that you already understand the principles of buffer
analysis/conformance (VBV, VCV, VMV) in MPEG-4 and H.264/AVC (HRD).

The following table provides the functions of each Buffer Analysis toolbar icon.
(See Table 4.)

Table 4: Buffer analysis icons

Icon

Function

Zoom in (+) and zoom out (-) centered on the window; affected by the
Lock X /Y icons.

Fit all data into window.

Go to origin (zero), which is the start of the video sequence.

B || @

Lock X/Y zoom infout and scrolling/panning. When the Lock Y button is
pressed, zoom in and zoom out and scroll/pan only affect the X-direction.
This allows you to keep a useful vertical scale, while still viewing the length
of the video sequence.

&P

Autoscroll; fill the analysis data in real time as the video is being decoded
and scroll the window to the right.

52

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials



Tutorial 9: MPEG-4 and H.264/AVC buffer analysis

Table 4: Buffer analysis icons (cont.)

Icon Function

EE Measure the data at the cursor. The data values are reported on the status
line at the bottom of the analysis window. Offsets and angles/slopes of
lines can also be measured by holding the mouse and dragging.

Scroll/pan (the cursor changes to show the scroll/pan direction); this is
affected by the Lock X-Y icons.

B
i Zoom in/zoom out centered on the location of this cursor; this is affected by
Plamat | the Lock X-Y icons. Press the <shift> key to zoom out.

Procedure

[S—
.

To load the tutorial, click File > Example files > MPEG-4 Elementary
Streams> Man Walking. Ensure that the video is not playing.

2. From the Analysis menu, click View buffer analysis. The Buffer Analysis
window appears. (See Figure 63.)

3. View the buffer analysis graph example, as well as the descriptions in the
table. (See Table 5.)
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& Uge paramesters hom stream hesder
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I [ peofie_and_level_indication 140 WOy -
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Simgle Profile.

" Use custom parametess e

Comparative Video Verifiers 4

¥ Widea Butler Verier Butfer B as| g o
T

bR_rate: bts/s 10]__f-
wb_bufes_size: bis f
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¥ ideo Complexty Vedher
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Figure 63: Buffer analysis window, example graph
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Table 5: Buffer analysis descriptions

Area Description

1 Graph window control toolbar.

2 Frame type, number.

3 Graph window.

4 List of analyses for VBV, VCV, and VMV.

5 Location of overflows and underflows in stream.

6 Scroll bar for sequence.

7 Time through sequence.

8 Vertical blue line at time=0; vertical gray lines at each VOP decode time.
9 Status lines.

10 Custom values.

11 Switch on/off VBV, VCV, VMV graphs.

12 Source of buffer analysis values.

4. Observe the VBV, VCV and VMV values that appear beside the graph. (See

Figure 64.) These parameters are specified in the stream, or from the implied
values from the Profile/Level, as given in the standard, or the implied values

Configuration

from the Object Type (Simple or Advanced Simple), at the highest level for
each. You can enter them manually by selecting Use custom parameters.

(™ Use parameters from stream header

[~ vbv_parameters
[ profile_and_level_indication
[ video_object_type_indication

|Simple Profile

(% {Jse custom parameters

v Wideo Bulfer Verifier

bit_rate: 393216 biteds

: EFRIEN La

Figure 64: VBV, VCV and VMV values

5. Click the Pause/ Step Forward icon ™ three times. Nothing appears in
the window because the Man Walking sequence contains B-VOPs, and the
buffer analysis cannot start until there is sufficient data for the calculations
(this will not occur until frame 4).

6. Click the Pause/ Step Forward icon ™ one more time. The graph appears.
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Tutorial 9: MPEG-4 and H.264/AVC buffer analysis

7. Click the Fit to Window icon ﬂ for a more detailed view of the graph.
(See Figure 65.)

8. Click the Fast forward icon ® . A warning message occurs. (See Figure 66.)

9. Note that the VBV overflow occured while decoding frame 55 (the display
frame number is 54).

; [ i |
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X . S
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: : Comparative Video Verifiers
v {lse parameters from sheam header R ” ’ . s ; " ;
i H R}
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IAdvanced Simplz Prafile/Level 0 7 110 Burrer limit
" Use custom parameters = 10 [ ]
L5
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2 &0
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v \ideo Complexity Yerifier % 10 / | | H | { | | ]
] 08 -0 04 02 O 0z 04 0B 08
wey_buffer_size: I % MacroBs Time (s)
woy_decoderrate; I MacioBsds 2 E
<] cl C
s @ u
YBY: 0 aver, 0 under YO 0 aver Wil O over

Figure 65: Buffer analysis graph, detailed view
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Decode Warning 33013: VBV overflow rz|

‘warning ideo Object Plane

' Wideo Buffer Vernfier model has Uvethwecl by 782 bits at time ~
] 3 21675, The overflow occuned duting the decoding of frame 55,
bitstream position 07158 (dec. 291]31 The total VBV bulfer
accupancy is 164622 bitz and the masamum limit iz 163840 bits. YBWY
parameters were denived from profle_and_level_indication in w

Summary NOTE: display vs. decodle order
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0007188 {dec. 29095) bit 7
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v Skip this Waming enly in huture
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Figure 66: VBV overflow warning
10. Select Skip this Warning only in the future, and then click Continue.

11. Observe that the red VBV line goes above the Buffer limit line. (See
Figure 67.)

12. Observe that when the decoding stops, the graph looks like the section that
appears between 75% and 105% buffer occupancy. Note also that the number
of frames with VBV overflow appears at the bottom of the screen. In this
case, the number of frames with VBV overflow is 106.
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Comparative Video Verifiers
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Figure 67: Buffer limit graph

13. To fit the graph to the window, click the El icon on the Buffer Analysis
toolbar. The red line displays the VBV overflow. (See Figure 68.)
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Buffer Cocupancy (%)

Comparative Video Verifiers
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Figure 68: Comparative video verifier graph

14. Consider the information presented by the graph. The standard values used
for a frame result in a VBV overflow, which means that the decoding rate

15.

C

annot keep up with the input data rate, and frames will drop, beginning with

frame 54.

S

olutions include:
Increase the vbv_buffer size so that it does not overflow.

Decrease the bit-rate, which is the rate at which the encoder sends the
data to the decoder.

Increase the displayed frame rate, so that the decoder removes bits more
quickly.

Increase the number of bits per frame by changing the quantizer or
increasing the frame size.

Change the Profile/Level indication, so that it stays within the set limits
(for example, change to ASP at Level 2).

Use custom values in the vbv_parameters in the sequence header.

Clear the check boxes for VCV and VMYV so that only the VBV check box
is selected. Note that the vertical scale is now measured in bits, not %. (See
Figure 69.)
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16. Observe that the VBV line has disappeared because it is beyond the scale
set for the VBV.

17. Click the El icon on the Buffer Analysis toolbar, and then click the L icon
three times for a detailed view of the graph. (See Figure 70.)

&t Buffer Analysis: MPEG4 Example - Man Walking E]E|rz|
De BB I++a

7 ~
Configuration

% Use parameters fiom stieam header

™ wbv_parameters
¥ profile_and_lewel_indication
[T video_object_type_indication

|Advaruced Simple Profile/Level 0

Video Buffer Verifier

PA3E (FIA [Fi4D [PAdB [PA4E [PRaF [Pdsh [Past |P1st
[ ]

(N |

‘

|
200000 | | Wimim|
1

" Use custom paramelers why | butter| size

150000 [ O I
|

whv_buffer_size: | S0 bats
whv_occupancy: | bits:

100000 [ 8 Y

WEY Butier © coupancy (his)

[~ Videa Complesiy Veifier 50000 [

wiy_bulfer_size: | MacroBs

[
vov,_decodet_ate: | MacroBs/s §4 5% 58 57 58 58 6 61 62 63

™ Wideo Memory Verifier

Figure 69: Frame 2
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Ve o R

Figure 70: Graph details
18. Note the following details about the graph:

= The Y scale of the graph is locked, which keeps the graph at a useful
zoom level.

= The VBV graph is higher at the end of every frame than at the start, which
shows that the VBV buffer is filling faster than the decoder can empty it.

19. Click the — icon to zoom out.

20. Select the Use custom parameters option button. (See Figure 71.) The word
BUF appears in a yellow box in the main MTS4EA status bar, indicating that
custom buffer parameters are in use. (See Figure 72.)
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Configuration

" Use parameters from stream he ader
[ wbv_parameters
[+ profile_and_level_indication
[ wideo_object_type_indication

|.-’-".|:|van|:ed Simple Profile/Lewvel 0

{* i1ze custom parameters

Iv “ideno Buffer Verifier

bit_rate: 131072 bitz/s
whre_buffer_size: 163840 pits

vby_occupancy: 108300 bits

[ “ideo Complesity Werifier

wiw_buffer_size: 93 MacoBs
wev_decoder_rate; 2370 MacroBs/s

I Widea Meman Verifier

wim_buffer_size: 297 MacoBs

Figure 71: Buffer analysis configurations

B

W 253 over, 0 under WOV O over VI O over
re Alerts disabled BUF all Disabled: 1

Figure 72: Buffer parameter indicator

21. View the video buffer verifier. (See Figure 73.) The default vbv_buffer size
for ASP L0 is 163,840 bits = 20,480 bytes, which is not very large.

22. Enter 655,360 bits = 80 kbytes, click Apply, and then click the Fit to window

icon E . Observe that the graph stays below the limit and there are no
overflows or underflows.
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23. Consider the following:

= What if your mobile device cannot spare 80 KBs of memory, and can only
spare 20 KBs, as specified by the standard?

= By how much does the input data rate need to be reduced?

= Does this comply with the specifications of the network on which your
device will operate?

Video Buffer Veriﬁer

Al

-

k|
i

R

VBY: 0 over, 0 under WCW: 0 over WMY: 0over

900000 [
800000 |
700000 [ vbv_bul
600000 [
500000 |

400000 |

VBV Bufier Occupancy (bits)

|

300000 [

200000 [

o Alllﬂ|||\||M|||||||I||\I||}|

Figure 73: Video buffer verifier graph

24. Reset the parameters by clicking Use parameters from stream header, and
then reselect the Use custom parameters check box. The VBV graph shows
that the decoder is being supplied with data faster than it can decode.

25. Reduce the bit rate to 121072 bits, and then click Apply. (See Figure 74.)
The graph goes up slightly and there are fewer frames with overflow. (See
Figure 75.)
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~Iv Mideo Buffer Verifier

bit_rate: I 121072  bits/s
vbv_bulffer_size: I 163840  bits

vbv_occupancy: 108800  bits

Figure 74: Bit rate configurations

Video Buffer Verifier
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Figure 75: Video buffer verifier graph
26. Reduce the bit rate to 111072 bits and then click Apply. (See Figure 76.)
27. Observe that the graph line now stays below the buffer limit. (See Figure 77.)

28. Consider whether the maximum rate of 111,072 bits meets your network's
specifications.
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bi_lde: I 111072 bits/s
vby_buffer_size: I 163840  pits

vbv_occupancy: 108800 bits

Figure 76: Video buffer verifier configurations
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Figure 77: Video buffer verifier graph

Conclusion

This tutorial demonstrated that the buffer analysis of the MPEG-4 example, Man
Walking, showed that the stream does not comply with the buffer constraints. The
tutorial recommended ways to resolve this issue.

The tutorial also brought up the following considerations:

B  How much memory needs to be allocated? Can your hardware allow this
much memory usage?

B s the input data rate limit appropriate for your network?
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Tutorial 10: MPEG-2 compliance

Procedure

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials

This tutorial covers the following:

Opening an MPEG-2 program stream.
Interpreting syntax errors:
= Person track: invalid VLC for dct_differential.

= Grenadier guards: frame rate extension denominator and numerator
equal but not zero.

Using the HexView:

= Going from the alert pop-up to the HexView.
= Examining the bitstream in the HexView.
Looking at the MPEG-2 program stream structure.

Looking at MacroBlock types in an interlaced video.

To load this tutorial, click File > Example files > MPEG-2 Program
Streams> Person Track. A list of tracks included in the MPEG-2 program
stream appears in a dialog box. (See Figure 78.)

View the track information included in the dialog box. The video track ID,
for example, is 0xe0. Although there can be multiple tracks, the first video
track is selected automatically.
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M Flementary stream select @
Select elementary streams to decade from MPEG-2 part 1 PS file
select | Type | steam id | Desaription | Bytes | Scrambled | Decoder
Oxbe padding_stream 3340 Mo
¥ & video ES Oxe0 MPEG-1, MPEG-2, MPEG +4... 850305 Mo MPEG-2 part 2

%

[ Hide unknown streams

[ Hide emply streams

W Hide tree Audo: |[No selection)
Estended shieam search

Search |

Wideo: Islleam:[lxe[]

I8 |

0K Cancal

Figure 78: Track list

3.
4.

Click OK. The video track is analyzed and an error appears. (See Figure 79.)

View the error message details, which provide a summary of the stream up to
the point of the error.

Click Continue. Ensure that the Skip this Error only in the future check

box is not selected. Another buffer conformance error message appears.
(See Figure 80.)

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials



Tutorial 10: MPEG-2 compliance

Decode Error 22210: Bad slice order @

Eror

Slices must be contained within a single row of macroblocks. The
current macroblock (x=0, y=4) belongs to a slice from a previous row.
Stream position: Oxfeb (dec. 4070, bit 1

Bitstream context: [WSQIPCDISLI]

Picture

Summary

e 2
&+ (partially exiracted)

befare Frame 1

|

betore Frame 1

= .

[ Skip this Eror only in future
™ Skip ALL Emor alerts in future

ot I Pause | Curx‘nuel Goto »

&

Figure 79: Initial error message

Decode Error 22112;: Bad VYLC for dct_differential

Eror Block
Invalid VLC for det_differential: encountered bit pattein
'00000000000000000°, This does not match any valid code value.

Stream position: 0x1000 (dec. 4096), start bit 5

Bitstream context: [VSQIPCDISLIMBKIBLK]

Summary

TR T 352 x 285 »
B EEERCNE N ) 8+ (partially extracted)

LGN EEEE)] before Frame 1
Frame type i}

TR before Frame 1

Decode Frame no. i

[ Skip this Eror only in future
I Skip ALL Error alerts in future

Abort | Pause I Conlinuel Goto =

Figure 80: Invalid VLC error message

6. View the error message details. An invalid VLC has been used for the
dct_differential field at bitstream byte address 0x1000, bit 5.

7. Click Continue. Ensure that the Skip this Error only in the future check box
is not selected. Repeat this step for an additional error message that appears.

8. Resume playing the video. Observe that the error is visible in frame 1. (See
Figure 81.)
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i

Figure 81: Error in image

9. Click the Pause, Step forward icon ™ . An error message appears.

10. Click Continue. An Invalid VLC error message appears. (See Figure 82.)
11. From the Goto menu, click Hex.

12. Click Continue, and then view the HexView window. Note that the error is
highlighted automatically. (See Figure 83.)

13. Observe the bits surrounding the error and consider whether it is a start code
emulation.
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Decode Error 2211 2: Bad YLC for det  differential
diferentish encounbered bit patizm

Im.!ld

0 . This does not malch any valid code value.
Stiearn paslion: D:('IE[IJ[det 4035, Had bit'S
Bitstizam context: [VSQIPCDISLIMBKBLY]

Summany

miage izs vk ]
RS 8+ (patinly extracted)
] e reriome
o]
Delmﬁm‘l
[ecoierianen [

[~ Skip thizE ror anly i futune
[ Skip ALL Ervor sbeits in fubune

|

Figure 82: Invalid VLC error message

Hex: mp2_2 - stream Oxel (vide o)

¥ He« ¥ ASCIL [Auto  ~| Byssperine| e[ Gow0 W
01101111 10110101 10001111 11101110 11011100 10110010 F EE DC B2 o ~
10100117 00000101 10100001 01100111 11101100 01100110 47 0% AL €7 BC 66 — g ¢
00010011 11001110 01101001 10011100 01000011 01110111 13 CE 69 9C 43 77 i Cw
01110001 11101111 10110110 01100110 01011101 01000101 71 EF B6 66 5D 45 g f£]E
10010001 00001110 01100110 11000011 00000000 000000DQO0 91 OE &6 C3 00 00
00000000 00000001 00000101 01111011 11010111 10010011 00 01 05 7B D7 93 {
00011110 11111100 01110110 11101100 01110110 01010010 1E FC 76 EC 76 52 w vR
11110110 11011010 10000101 01000001 10010000 00110110 F6 DA 85 41 90 36 A &
10011100 11011100 00111110 01011111 11000000 00000001 9C DC 3E SF CO 01 >
11111111 11000111 10010110 10111011 11001011 00100011 FF C7 96 BE CB 23 *
11100001 01010110 00100100 00101010 10110101 11100100 E1 56 24 24 BS E4 V=
01100101 00000000 10110111 10010100 01000000 00011100 65 00 B7 94 40 1IC = @
01100001 11100001 00101101 10011111 10111010 00001000 61 E1 2D 9F B 08 a -
01011111 11101110 00101010 10010100 01010110 01101101 SF EE 24 94 56 6D _ = Vm
01001001 00100000 00001111 01100011 01011011 01100110 49 20 OF 63 SB 66 T c[f
11011110 01111111 10010111 11100110 10000000 01011001 DE 7F 97 E6 80 59 ¥
00100110 11001010 00001000 01011111 11110101 11000101 26 CA 08 SF F5 C5 & _
00101010 11001010 00110110 10110011 01111101 01101000 2A CA 36 B3 7D 68 % 6 }h &
(Address: 0x 1000 (4096) bit 5 /‘.

Figure 83: HexView window

14. To open the Grenadier Guards program stream, Click File > Example files
> MPEG-2 Program Streams> Grenadier Guards. An error message
appears. (See Figure 84.)
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15. View the details of the error message: the value of the denominator of
frame rate extension is 1, but it must be 0 in Main Profile.

Decode Error 22082: Invalid frame_rate_extension_n @

Error Video Sequence
Irvalid value. frame_rate_extension_n = ‘01"

frarme_rate_extension_n must be O in Main profile,

Streamn position: 0415 (dee. 21), start bit &

Bitstneam context: [VSQIS 0X]

Summary

Image size [5G 0
2= et Ul ] 144+ (partially extracted)
Acldry

Time (zecz) o ol

befare 1

v Skip this Error ondy in fulure
[~ Skip ALL Erior alerts in futire

Abort | Pause I {7

Figure 84: Error message

16. Select Skip this Error only in the future, and then click Continue. The
status bar indicates one disabled alert. (See Figure 85.) An error message (See
Figure 86.) and a warning message (See Figure 87.) appear.

MNOTE: one/more Alerts disabled Lol | Disabled: 1

Figure 85: Disabled alert indicator

17. For both error messages, select Skip this Error or Warning in the future,
and then click Continue. Do not resume playing the video.
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Emar Wideo Sequence

Invalid value, frame_rate_extension_d = "00007"
frame_rate_extenion_d must be 0 in Main profile.
S tream pogitior: 0x1 5 [dec. 21, start bit 4
Bitstream contest: [VSOIS0x]

Surmmary

~
unknown
=L RN S 1 4+ (partially extracted)

Time (secs) ForCR
type
Decode no.

Ic Skip thiz Error only in future
[ Skip ALL Error alerts in fubure

Abort | Pause | Emli'uel Golo w

Figure 86: Error message

Decode Warning 32196: Incorrect frame rate fraction FZ|

\Warning Yideo Sequence
) ‘whete the numerator and denominator of frama_rate_extension are
+ % equal they must be set to 0 [found: rum=1, denom=1]

Stream position: 0515 (dec. 21, bit &

Bitstream contexl: [VS0IS0X)

Summary

e 2
14+ (patially extracted)
] befere 1
P vetore 1
¢

v Skip this Warming orly in future
[T SkipALL Warning alerts in future

Gots »

Abork I Pause |

Figure 87: Warning message

18. From the Analysis menu, select View video stream structure. The Structure
window appears. (See Figure 88.)

19. View the top-level atoms in the MPEG-2 program stream. Click the + next to
each atom to view the data for the atom.
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E Structure: MPEG-2 Example - Grenadier guards (video)

Stream: IMFEGKE part 1 PS
| Syntax Value | Start bit Size (bits)
= m MPEG-2 Program Stream 0x000000,7 UNKNOWN A

+[% pack_header 0x000000,7 256

+ [, PES_packet program_stream,,, 0x000020,7 192

- [, PES_packet MPEG-1, MPEG-,.. 0x000038,7 16560
101 packst_start_code_p... Ol 0x000038,7 24
 stream_id Oxed MPEG-1, M,., 0x00003b,7 B8
123 PES_packet_length 2064 0x00003c, 7 16
123 10 2 0x00003e,7 2
123 PES_scrambling_control 0 0x00003e,5 2
123 PES_priority 1] 0x00003e,3 1
123 data_alignment_indic... 0 0x00003e,2 1
123 copyright 0 0x00003e, 1 1
123 original _or _copy 0 0x00003e,0 1
123 PTS_DTS_flags 3 0x00003f,7 2
123 ESCR _flag o 0x00003f,5 1
123 ES_rate_flag o 0x00003f,4 1
123 DSM_trick_mode_flag 0 0x00003F,3 1
123 additonal_copy_info... 0O 0x00003f,2 1
123 PES_CRC_flag o 0x00003f,1 1
123 PES_extension_flag 1 0x00003F,0 1.
123 PES_header_data_le... 13 0x000040,7 8
iz3 0011 3 0x000041,7 4
o PTS 49157 0x000041,3 36
123 0001 1 0x000048,7 4
«~ DTS 47357 0x000048,3 36 e

Figure 88: Structure window

20. Resume playing the video. The Interlace toolbar appears. (See Figure 89.)

Figure 89: Interlace toolbar

21. Click the Pause, Step Forward icon "™ to view frame 2.

22. On the Interlace toolbar, click the Split fields view icon = . The top and
bottom fields are displayed separately. (See Figure 90.)
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. OEX

Figure 90: Frame 2

23. Maximize the video window.

24. Click the ¥ icon. Different MB types appear in the top and bottom fields.

(See Figure 91.)

@ MTS4EA - [MPEG-2Z Example - Grenadier guards - stream Oxe0]

[ £le Play Overley Apalysis mlert Window Help /
DER s ddqcamprpEm ol C@
EEE&O

niEEeE=

T --=- Emwrmpream=

BpE===p

Figure 91: Varied MB types
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Conclusion

This tutorial demonstrated the following:

B There is one error in the Person Track stream:
= The error is in frame 1, at bitstream location 0x1000, bit start 5.
= This error affects the visual quality.

B There are two errors and one warning message in the Grenadier Guards
stream:

= The errors are in the header (before frame 1), at bitstream location 0x15,
bit start 6.

= The warning message highlights the same error.
= This does not appear to affect the visual quality.

B You can see the different MacroBlock types in the top and bottom fields.
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Tutorial 11: Fidelity analysis

This tutorial covers the following:

®  Fidelity analysis in real-time (PSNR).
= Using a YUV source reference file.
= Fidelity metrics.
= Graph navigation.

®  Comparing the fidelity of the same bitstream compressed with either MPEG-2
or H.264/AVC.

B Viewing the visual difference between the compressed bitstream and the YUV
source reference video.

This tutorial requires that you have completed the previous tutorials and that
you can:

®  Open example streams.

®  Play, stop, step forward, and rewind a video.

m  Use and interpret alert pop-up messages.

®  Use the icons and controls on the buffer analysis graphical display.

This tutorial also requires that you already understand the principles of fidelity
analysis (this topic is not covered in this tutorial; however, the user manual
contains descriptions of the fidelity metrics).

Procedure

1. To load the tutorial, click File > Example files > MPEG-4 Elementary
Streams> Man Walking. Ensure that the video is not playing.

2. From the Analysis menu, click Enable fidelity analysis. The Video analysis
options dialog box appears for theYUV reference file. This file will later be
used for comparison with the compressed video file. The YUV reference
file is provided as an example, as indicated by the text under the Reference
filename field. (See Figure 92.)

3. Set the Frame rate to 30. (See Figure 92.)
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Video analysis options

(X)

Frame range | Trace ~Visual diference./Fidelity ]

Iv Enable fidelty analysis

Feferents flename -

” - :
Jman_walkmg _yuv

Thists an-embedded YLV fils for use with tutaials — ™

Encoding: |O|1§b1,rl£ - LI

Header skig: |0 Bytes™
-~ -

v Llsef_gmiae for synchronisation

Frame rahg: (300001001 Framé¥ per szcond

-

Metric: [PSNR full signal range) Il

Figure 92: Video analysis options

4. From the Metric drop-down menu, select PSNR (full signal range), and
then click OK. (A detailed description of each fidelity metric is available
in the user manual).

5. From the Analysis menu, click Enable fidelity trace.

6. On the Trace tab, select the Enable check box, choose the filename
mp4asp_1_video and then, under Options, select VOP Fidelity. (See
Figure 93.)

7. On the Frame range tab, select the All frames check box and then click

OK. The video window appears with the fidelity analysis icon ™ enabled in
the Views toolbar. (See Figure 94.)
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Video analysis options

Framerange Trace | Visual dfference/Fidelty |

Imadesp_1 _videa vpt J
Available disk space: 68175 MBytes
File size limit: |0 MBytes

Options
(21 VOP fidelity
[] MB fidelity

I 0K I Canc

Figure 93: Video analysis options

Video analysis options

Frame range ]TIT:I{:E': l Wisual diFFerenc:efFideI'rt-_.']
Frame range

First frame Last frame

| o |

Figure 94: Frame range tab

8. Click the Fidelity analysis icon ™ . The Fidelity analysis graph view
appears. Observe that the graph is empty because a video has not been played.
(See Figure 95.)

9. Click the ™ jcon four times. A graph appears. (See Figure 96.)
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10. Observe the following about the graph:

= The graph area is not filled with each click because the bitstream includes
B-VOPS, and a certain number of frames must be decoded before each
frame can be displayed.

= Some of the YUV PSNR values are not visible. This is because the graph

auto-scales with the first few values. You can click the ﬂ icon to rescale
the graph.

= The thumbnail bar view shows that the fidelity data has been collected.

11. View the descriptions of the Fidelity analysis window in the figure and the
table. (See Figure 97.) (See Table 6.)

IE‘_I Fidelity Analysis: MPEG4 Example - Man Walking

-0 o @@ ++Qe@

Decoded image PSNR (full signal range)

03

0§

or

06

05

PSNR (db)

04

03

02

LiE]

Time (5]

Figure 95: Fidelity analysis graph
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I Fidelity Analysis: MPEG4 Example - Man Walking
-Do R/ |+

Decoded image PSNR (255 signal range)
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Figure 96: Fidelity analysis graph
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Analysis: MPEG4 Example - Man Walking
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Figure 97: Fidelity analysis window descriptions

Table 6: Fidelity analysis window descriptions

Area Description

1 Graph window

2 YUV color key

3 Scroll bar; appears and disappears according to zoom scale

4 Time through sequence

5 Status line; display measurements

6 Thumbnail bar line; displays overview

7 Vertical blue line at time=0; vertical gray lines at each VOP decode time
8 Frame type, number

9 Graph window control toolbar

—
[

. To open the Grenadier Guards program stream, Click File > Example files
> MPEG-2 Program Streams> Grenadier Guards. An error message
appears.

13. Select Skip this Error only in the future, and then click Continue.

14. From the Analysis menu, select View analysis options.
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15. On the Visual difference/ Fidelity tab, set the YUV frame rate to 25, and
then click OK.

16. An error message appears because there are only 10 frames of YUV data.
Click OK, and then view the graph result. (See Figure 98.)

17. Load the MPEG-2 program stream example, Grenadier Guards. (See
Figure 99.)

18. Compare the first MPEG-2 program stream with the H.264/AVC PSNR

example. (See Figure 99.) (See Figure 100.) Note that the PSNR is higher for
H.264/AVC in Y, U, and V.

' Fidelity Analysis: H. 264/AVC Example - Grenadier Guards
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Figure 98: Graph result, YUV frame rate 25
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I__I Fidelity Analysis: MPEG-2 Example - Grenadier guards - stream OxeQ
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Figure 99: MPEG-2 program stream, Grenadier Guards

') Fidelity Analysis: H.264/AVC Example - Grenadier Guards
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Figure 100: H.264/AVC stream, Grenadier Guards
19. Click the View trace icon. (See Figure 101.)
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Figure 101: View trace icon

20. The trace view gives the numerical values for the pictures' PSNR. (See
Figure 102.)

21. Consider the following:

= What encoder parameters, such as frame type, were used for H.264/AVC
and MPEG-2?

= Could the H.264/AVC or the MPEG-2 encoding parameters be changed to
improve the areas of lower PSNR?

= Compare other fidelity analyses; do the same kinds of differences occur?

= Although the PSNR is better for the H.264/AVC sequence, it does not
necessarily look better. Consider the visual differences.

Trace: mp2_3_video.vpt

| B | [ Line numbers Find. Prev | Mest| I Emor  [v Waming v Frame [~ Text

Frame.Field. PSNR(Y¥). PSNR(U). PSNR(V)

] . 3% 1551205054, 44 1527441439, 44 1070618585
362410429823, 43 1333866825, 42 £9069TEEED
34 2408434076, 41 0828362775, 40.5495890441
348244399239, 40 8747086796, 40.3956140428
34 1695327233, 40 GE71772657, 40.1094564965
34,1792322830, 40.5634068211, 29,9926959618
34,1895275709, 40.0741906012, 297654673372
33.7246588453, 40,1144933741, 29,7156823394
33.4360061215, 40, 0695929584, 39 6645728375
33.6821124513, 39, 7911766114, 29, 4529675380
33 5875051373, 39 8044087588, 39 2026888440
2754493764, 39 7546294297 39 1679362998
33.1654188777. 39.1565268088. 38.6190367668
33 7616897922, 39.4076A6E535. 30 8532040654
33 0906394650, 39.5244317504. 35.7354762727
33.0525714220. 30.9345453769. 35.1391305374
33.4113761027. 39.2114152344. 35.4411214339
33.0349589228. 39.1469252959. 35.4015575604
33.4844855563. 39.1007939494. 35 4926066341
33 7436073016, 39.0919941194. 38.5918053711
error
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Figure 102: H.264/AVC sequence
22. Load the MPEG-2 stream, Grenadier Guards.

23. From the Overlay menu, click Visual difference, and then select the Enable
check box.

24. Set the Frame rate to 25, and then click OK. The Visual difference toolbar
appears.

25. Use the following icons to view the visual difference.

MTS4EAV7 HEVC / AVC Video and Compressed Audio Analyzer Tutorials 83



Tutorial 11: Fidelity analysis

Conclusion

84

Table 7: Visual difference icons

Icon Function
m View encoded
| View YUV reference
" View difference
1 View luma only (not U or V)

26. Load the H.264/AVC stream, Grenadier Guards. Consider whether there is a
difference in visual quality between the two streams.

This tutorial demonstrated the following:
B A method for assessing visual quality through:

= The use of metrics such as PSNR.

Identifying the visual difference between the encoded video and the
reference (source) video that is used for the encoding.

Visual quality analysis and visual quality improvement require that you
consider encoding parameters (such as frame types and motion vectors) and
bit-rates of encoding.

This tutorial provided the tools to help you begin your visual analysis in a
quantifiable and logical fashion.
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