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Getting help and support Related documentation

Related documentation

The following manuals are available as part of the TekExpress USBPWR Compliance and Debug Solution
documentation set.

Table 1: Product documentation

Item Purpose Location

Online Help In-depth operation and UI help

PDF of the Online Help Printable version of the compiled
Online help

+

xxx

See also

Technical support (see page 2)

Conventions used in help

Online Help uses the following conventions:

The term “DUT” is an abbreviation for Device Under Test.

The term “select” is a generic term that applies to the two methods of choosing an option: using
a mouse or using the touch screen.
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Getting help and support Technical support

Technical support

Tektronix values your feedback on our products. To help us serve you better, please send us your
suggestions, ideas, or comments on your application or oscilloscope. Contact Tektronix through mail,
telephone, or the Web site. See Contacting Tektronix for more information.

When you contact Tektronix Technical Support, please include the following information (be as specific as
possible):

General information

All instrument model numbers

Hardware options, if any

Probes used

Your name, company, mailing address, phone number, FAX number

Please indicate if you would like to be contacted by Tektronix about your suggestion or comments.

Application specific information

Software version number

Description of the problem such that technical support can duplicate the problem

If possible, save the setup files for all the instruments used and the application

If possible, save the TekExpress setup files, log.xml, *.TekX (session files and folders), and status
messages text file

If possible, save the waveform on which you are performing the measurement as a .wfm file
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Getting started Minimum system requirements

Minimum system requirements

The following table shows the minimum system requirements needed for an oscilloscope to run
TekExpress USBPWR.

Table 2: System requirements

Oscilloscope See Supported oscilloscopes (see page 4)

Processor Same as the oscilloscope

Operating System Same as the oscilloscope:

Windows 7 (64-bit only) Windows 7 user account
settings (see page 3)

Memory Same as the oscilloscope

Hard Disk Same as the oscilloscope

Display Same as the oscilloscope 1

Firmware TekScope 6.4.5 and later (Windows 7)

Software Microsoft .NET 4.0 Framework

Microsoft Internet Explorer 7.0 SP1 or later

Microsoft Photo Editor 3.0 or equivalent software for
viewing image files

Adobe Reader 7.0 or equivalent software for viewing
portable document format (PDF) files

Recommended Accessories One set of TPP0500, TPP1000, P6139B, or P5100A
probe with standard accessories are recommended

Additionally, one set of TCA to BNC converter and
TCA-1MEG TekConnect 1 MΩ adapter is recommended
when using a P6139B or P5100A probe with a
DPO/DSA/MSO70000C/GSA Series Oscilloscope

Please refer to www.tek.com/probes for further information
on recommended probes and probe adapters.

xxx

1 If TekExpress is running on an instrument having a video resolution lower than 800x600 (for example, a sampling oscilloscope), it is recommended
that you connect a secondary monitor, which must be enabled before launching the application.

Windows 7 user account settings

Windows 7 instruments need to have the User Account Control Settings set to Never Notify. To set
User Account Control Settings:

TekExpress USB Power Adapter / EPS Compliance Automated Test Solution Software 3
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Getting started Supported oscilloscopes

1. Go to Control Panel > User Accounts > Change User Account Control settings.

2. Set it to Never Notify as shown in the image.

See also

Supported oscilloscopes (see page 4)

Supported oscilloscopes

The TekExpress USBPWR application (Option USBPWR) is compatible with the following Tektronix
oscilloscopes:

MSO/DPO5000/GSA Series (350 MHz and above)

DPO7000C/GSA Series

DPO/DSA/MSO70000C/GSA Series

NOTE. DPO/DSA/MSO70000D Series oscilloscopes are not supported for Option USBPWR.

See also

Minimum system requirements (see page 3)
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Install the software

Use the following steps to install the USBPWR application on any compatible instrument running
Microsoft Windows 7 (64-bit). See Minimum System Requirements (see page 3) for details.

1. Close all applications (including the TekScope application).

2. Go to the www.tek.com Web site and search for TekExpress USB PWR to locate the installation file.
Download the file TekExpress_USB_PWR_Deployment_Package.exe.

3. Copy or download the USBPWR installer to the oscilloscope.

4. Double-click the installer .exe file to extract the installation files and launch the InstallShield Wizard.
Follow the on-screen instructions.

5. The software installs in the following location:

C:\Program Files\Tektronix\TekExpress\TekExpress USB-PWR

6. The installer updates the TekScope Analyze menu to include the installed options.

See also

Minimum system requirements (see page 3)
Supported oscilloscopes (see page 4)
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Activate the license

Activate the license using the Option Installation wizard on the oscilloscope. Instructions for using the
Options Installation window to activate licenses for installed applications is provided in the oscilloscope
online Help:

1. From the oscilloscope menu bar, click Utilities > Option Installation.

The TekScope Option Installation wizard opens.

2. Push the F1 key on the oscilloscope keyboard to open the Option Installation help topic. Follow the
directions in the topic to activate the license.

See also

View version and license information (see page 7)
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View software version and license information

Use the following instructions to view version information for the application and for the application
modules such as the Programmatic Interface and the Programmatic Interface Client.

To view version information for USBPWR:

1. In the USBPWR application, click the Options button and select About TekExpress.

2. Click the View Version Details link to view the version numbers of the installed test suites.

To view license and option key information:

1. From the TekScope menu, select Help > About TekScope.

2. Scroll through the Options section list to locate USBPWR.

3. To view the Option key, look below the Options list.

See also

Activate the license (see page 6)
Options menu (see page 13)
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USBPWR features and benefits

Welcome to the TekExpress® USB Power Adapter / EPS Compliance Automated Test Solution Software
(referred to as TekExpress USBPWR or USBPWR in the rest of the document). USBPWR provides
an automated, simple, and efficient way to test USB power interfaces and devices consistent to the
requirements of the USB2.0 Battery Charger Specification v1.1 and IEC 62684.

USBPWR is based on TekExpress version 2, the Tektronix Test Automation Framework, developed to
support your current and future test automation needs. TekExpress uses a highly modular architecture
that lets you deploy automated test solutions for various standards.

Key features and benefits of USBPWR include:

Automates compliance measurements for USB2.0 Battery Charger Specification v1.1 and IEC 62684:

AC Voltage Frequency Component measurement

AC CommonMode Voltage measurement

Ripple Voltage measurement

Maximum Slew measurement

Reduces the time required to conduct testing

Minimizes user intervention when conducting time-consuming testing

Provides individual or group test selection by using a tree-structure menu

Built-in reporting features:

Provides a Pass/Fail summary table

Provides margin details on each test

Provides a consolidated report for all tests

Complete programmatic interface enables automation scripts to call USBPWR functions

Application directories and their contents

TekExpress USBPWR application

The TekExpress USBPWR application files are installed at the following location:
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C:\Program Files\Tektronix\TekExpress\TekExpress USB-PWR

The following table lists the application directory names and their purpose.

Table 3: Application directories and usage

Directory names Usage

Bin Contains miscellaneous USBPWR application libraries

Compliance Suites Contains compliance-specific files

Documents Contains the technical documentation for the USBPWR
application

Examples Contains various support files

ICP Contains instrument and USBPWR application-specific
interface libraries

Lib Contains utility files specific to the USBPWR application

Report Generator Contains style sheets for report generation

Tools Contains instrument and USBPWR application-specific files

xxx

See also

View test-related files (see page 32)
File name extensions (see page 10)
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File name extensions

The USBPWR application uses the following file name extensions:

File name extension Description

.TekX The application session files (the extensions may not be
displayed).

.py The test sequence file

.xml The test-specific configuration information (encrypted) file

The application log file

.wfm The test waveform file

.mht The test result reports (default). Test reports can also be
saved in HTML format (see page 33).

xxx

See also

Select report options (see page 33)
View test-related files (see page 32)
Application directories and their contents (see page 8)
Before you click start (see page 45)
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Run the application

To run the USBPWR application, do either of the following:

Select Analyze > TekExpress USB PWR from the TekScope menu.

Double-click any saved USB PWR session file (<file name>.TekX).

When you first run the application after installation, the application checks for a file called
Resources.xml located in the C:\Users\<username>\My Documents folder. The Resources.xml
file gets mapped to the X: drive when the application launches. Session files are then stored inside the
X:\USB PWR folder. The Resources.xml file contains information about available network-connected
instruments. If this file is not found, the application runs an instrument discovery program, before
launching USBPWR, to locate available instruments.

To keep the application window on top, select Keep On Top from the USBPWR Options menu (see
page 13). If the application goes behind the oscilloscope application, click Analyze > TekExpress USB
PWR to move the application to be in front.

See also

Activate the license (see page 6)

Exit the application

Use the following method to exit the application:

NOTE. Using other methods to exit the application results in abnormal termination of the application.

1. Click on the application title bar.

2. Do one of the following:

If you have an unsaved session or test setup, you are asked to save it before exiting. To save it,
click Yes. Otherwise click No. The application closes.

A message box appears asking if you really want to exit TekExpress. To exit, click Yes.
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Application controls
Table 4: Application controls descriptions

Item Description

Options menu (see page 13) Menu to display global application controls

Panels (see page 18) Visual frames with sets of related options.

Command buttons Buttons that initiate an immediate action. Examples of
command buttons are the Start, Stop, Pause, Continue,
and Clear buttons.

Start button

Use the Start button to start the execution of the
measurements in the selected order. If prior acquired
measurements have not been cleared, the new
measurements are added to the existing set.

Stop button

Use the Stop button to abort the test.

Pause \ Continue button

Use the Pause button to temporarily interrupt the current
acquisition. When a test is paused, the button name
changes to “Continue.”
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Table 4: Application controls descriptions (cont.)

Item Description

Clear button

Use the Clear button to clear all existing measurement
results. Adding or deleting a measurement, or changing a
configuration parameter of an existing measurement, also
clears measurements. This is to prevent the accumulation
of measurement statistics or sets of statistics that are not
coherent. This button is available only on the Results panel
(see page 30).

Application window move icon

Place the cursor over the three-dot pattern in the upper left
corner of the application window. When the cursor changes
to a hand, drag the window to the desired location.

xxx

Options menu overview

The Options menu is located in the upper right corner of the application.

The Options menu (see page 14) has the following selections:

Menu Function

Default Test Setup Opens an untitled test setup with defaults selected

Open Test Setup Opens a saved test setup

Save Test Setup Saves the current test setup selections

Save Test Setup As Creates a new test setup based on an existing one

Open Recent Displays a menu of recently opened test setups to select
from

Instrument Control Settings (see page 14) Shows the list of instruments connected to the test setup
and allows you to locate and refresh connections to those
instruments

Keep On Top Keeps the TekExpress USBPWR application on top of other
open windows on the desktop

Email Settings (see page 15) Use to configure email options for test run and results
notifications
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Menu Function

Help Displays the TekExpress USBPWR Online help

About TekExpress Displays application details such as software name,
version number, and copyright

Provides access to license information (see page 7) for
your USBPWR installation

Provides a link to the Tektronix Web site

xxx

Options menu

See also

Application controls (see page 12)

Instrument control settings

Use the TekExpress Instrument Control Settings dialog box to search for and list the connected resources
(instruments) found on specified connections (LAN, GPIB, USB, and so on) and each instruments
connection information. You access this dialog box from the Options menu.

Access this dialog box from the Options menu.
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Use the Instrument Control Settings feature to search for connected instruments (see page 41) and view
instrument connection details. Connected instruments displayed here can be selected for use under Global
Settings in the test configuration section.

See also

Options menu overview (see page 13)

Email settings

Use the Email Settings utility to configure email notifications (see page 16) to receive notifications when a
test completes, produces an error, or fails. Select the type of test session information to include in the
notification, such as test reports and test logs, the email message format, and the email message size limit.

Access this dialog box from the Options menu.

NOTE. Recipient email address, sender’s address, and SMTP Server are mandatory fields.
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See also

Configure email settings (see page 16)
Options menu (see page 13)
Select test notification preferences (see page 25)

Configure email settings

To be notified by email when a test completes, fails, or produces an error, configure the email settings.

1. Options > Email Settings to open the Email Settings (see page 17) dialog box.

2. (Required) For Recipient email Address(es), enter one or more email addresses to which to send the
test notification. To include multiple addresses, separate the addresses with commas.

3. (Required) For Sender’s Address, enter the email address used by the instrument. This address consists
of the instrument name followed by an underscore followed by the instrument serial number, then the
@ symbol and the email server used. For example: DPO72016C_B130099@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server address of the Mail server
configured at the client location, and the SMTP Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name, password, and host name
in the corresponding fields.

NOTE. If any of the above required fields are left blank, the settings will not be saved and email
notifications will not be sent.
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5. In the Email Attachments section, select from the following options:

Reports: Select to receive the test report with the notification email.

Status Log: Select to receive the test status log with the notification email. If you select this
option, then also select whether you want to receive the full log or just the last 20 lines.

6. In the Email Configuration section:

Select the message file format to send: HTML (the default) or plain text.

Enter a maximum file size for the email message. Messages with attachments larger than this
limit will not be sent. The default is 5 MB.

Enter the number in the Number of Attempts to Send field, to limit the number of attempts that the
system makes to send a notification. The default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use this check box to quickly
enable or disable email notifications.

8. To test your email settings, click Test Email.

9. To apply your settings, click Apply.

10. Click Close when finished.

Email settings
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Application panel overview

Panels group related configuration, test, and results settings.

The TekExpress USBPWR panels are:

Table 5: Application panels

Panel Name Purpose

Setup (see page 18) The Setup panel shows the test setup controls. Click the
Setup button to open this panel.

Use this panel to:

Select DUTparameters (see page 19).

Select the test(s) (see page 20).

Set acquisitions parameters (see page 21) for selected
tests.

Configuration test parameters (see page 27)

Select test notification preferences (see page 25).

Status (see page 29) View the progress and analysis status of the selected tests,
and view test logs.

Results (see page 30) View a summary of test results and select result viewing
preferences.

Reports (see page 33) Browse for reports, save reports as specific file types,
specify report naming conventions, select report content to
include (such as summary information, detailed information,
user comments, setup configuration, application
configuration), and select report viewing options.

xxx

See also

Application controls (see page 12)
about setting up tests (see page 39)

Setup panel overview

The Setup panel (see page 19) contains sequentially ordered tabs that help guide you through a typical
test setup process. Use the tabs on this panel to:

Set the DUT parameters (see page 19)

Select test(s) (see page 20)

Select acquisition parameters (see page 21)

Set configuration parameters (see page 27)
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Select test notification preferences (see page 25)

Set DUT parameters

Use the Setup panel (see page 19) DUT tab to select parameters for the device under test. The settings
are global and apply to all tests for the current session. DUT settings also affect the list of available
tests in the Test Selection tab.

Click Setup > DUT to access the DUT parameters:

Table 6: DUT tab settings

Setting Description

DUT ID Adds an optional text label for the DUT to reports. The
default value is DUT001.

Comments icon (to the right of the DUT ID field)
Opens a Comments dialog box in which to enter optional
text to add to a report. Maximum size is 256 characters. To
enable or disable comments appearing on the test report,
see Select report options (see page 33).)

Acquire live waveforms Acquire active signals from the DUT for testing.

Use prerecorded waveform files Run tests on a saved waveform. Open (load) a saved test
setup (see page 50)

Version Sets the DUT generation version.
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Table 6: DUT tab settings (cont.)

Setting Description

Specification USBPWR currently supports USB2.0 Battery Charger
Specification v1.1 and IEC 62684.

View Sets the overall testing mode. Select Compliance or
Advanced:

Compliance: Preselects tests and parameters to meet
compliance specifications for the selected version,
specification, and device type.

View configuration settings by clicking Setup > Test
Selection > Configure.

Advanced: Enables the user to select specific tests and
set custom parameters for tests.

This also enables the Configuration tab on the
Setup panel to quickly access test parameters.

Suite Sets the DUT device type (Permanent cable or Detachable
type)

xxx

See also

About setting up tests (see page 39)
Select a test (see page 20)

Select tests

Use the Test Selection tab to select the tests to run on the connected DUT.

1. Click Setup > Test Selection.

2. Select the test(s) to run:

Click + to expand a group of commands. Click the check box adjacent to a test group to select all
tests in that group. Click check boxes adjacent to individual tests to select those tests.

Click Deselect All to deselect all tests. All tests are selected by default.

Click Select All to select all tests.

Click Schematic to view a diagram that shows the correct DUT and equipment setup for the
selected test. Use to verify your test equipment setup before running the test.

Click Configure to open the configuration settings for a selected test.
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NOTE. The Configure button is not displayed if the View (in the DUT tab) is set to Advanced.

Click Schematic to display a schematic diagram that shows the DUT test setup. Use the diagram
to verify the test setup before running the test.

See also

Set acquisition parameters (see page 21)
About setting up tests (see page 39)

Set acquisition parameters

Use the Acquisition tab in the Setup panel to view and select test acquisition parameters, such as the
signal source channel and waveform save options.

Click on Channel Selection to select the channel to which the DUT has been connected. (Channel
Selection is only available when acquiring live waveforms.)

Click the Acquisition and Save Options (see page 23) controls to set how the application acquires
and analyzes signals (Save all waveforms before analysis, Analyze immediately without saving
waveforms, or Save and Analyze acquisitions in sequence).

Click on Show Acquire Parameters to display the acquisition parameters for each acquisition.

TekExpress USB Power Adapter / EPS Compliance Automated Test Solution Software 21



Operating basics Set acquisition parameters

Active waveforms

Acquisitions tab: using active waveforms

Prerecorded waveforms

Acquisitions tab: using prerecorded waveforms
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When using prerecorded waveform files, this panel lists available prerecorded waveform files. You can
only select the source of the prerecorded waveform file for each test. See Set acquisition waveform
source for prerecorded waveform files (see page 24).

Set acquisition and save options

Select an Acquisition and Save Options to set the order in which waveforms are acquired and analyzed:

Save all waveforms before analysis: Acquire & save all waveforms required by tests before
performing analysis. All required user interventions (such as connecting the setup in different setups)
are completed, and waveforms acquired & saved, before the analysis is run. You can turn off the DUT
after the acquisitions are completed.

Analyze immediately - No waveforms saved: Waveforms are acquired but not saved. For each type
of acquisition, analysis is done just after acquisition. Waveforms are discarded when the analysis is
complete.

Save and analyze acquisitions in sequence: Acquire and save waveforms and analyze for each
test before proceeding to the next test. Use this setting to stop the testing when an error occurs,
investigate and correct DUT, instrument connections, or change application settings. Restart testing
after any changes.

TekExpress USB Power Adapter / EPS Compliance Automated Test Solution Software 23



Operating basics Set acquisition waveform source for prerecorded waveform files

Set acquisition waveform source for prerecorded waveform files

Select a Save Option to set how to save acquired test waveforms.

When using prerecorded waveform files, there are no acquisition source selections to make. You can only
select the source of the prerecorded waveform files for each test.

If you selected to use a prerecorded waveform file (in the DUT tab), the Acquisition tab shows a table of
the waveforms used for the required test acquisitions.

You can load a different waveform file for each table item. To load a different waveform file:

1. Click the ellipsis button ( ) of the waveform file to change.

2. Select the waveform task to perform (replace, remove, or select the waveform file).

3. Use the dialog box to navigate to and select the waveform file with which to replace the current file.

See also
Set acquisition options (see page 23)

24 TekExpress USB Power Adapter / EPS Compliance Automated Test Solution Software



Operating basics Set test notification preferences

Set test notification preferences

Use the Preferences tab to set the application action when a test measurement fails:

1. Click Setup > Preferences.

2. Select On Test Failure, stop and notify me of the failure to stop the test and send an email when
a test fails. Click Email Settings to verify that Email Test Results when complete or on error is
selected, and verify the email address.

See also

About setting up tests (see page 39)
Select report options (see page 33)

About configuring test parameters

Use the configuration settings to view the measurement parameters for selected tests. How the test
configurations are accessed depend on the View selected in the DUT tab.

If you set the view to Compliance in the DUT tab, then in the Test Selection tab, select the desired
test in the list and then click the Configure button.

Use the Test Selection button to return to the Test selection display.

If you set the view to Advanced in the DUT tab, click the Configuration tab in the Setup panel.

NOTE. You cannot change test parameters that are grayed out.
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See also

Configuration tab parameters (see page 27)
About setting up tests (see page 39)
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About running tests (see page 45)

Configuration tab parameters

The following table lists the Configuration tab settings and parameters.

Table 7: Common parameters and values

Parameter Type Parameter and Default Value

Compliance/User Defined Mode Determines whether test parameters are in compliance or
can be edited (User Defined Mode).

Compliance: Most test parameter values cannot be
edited.

User Defined: Enables editing of most test parameters.

Limits Editor Shows the upper and lower limits for the applicable
measurement using different types of comparisons.

In Compliance Mode, use the Limits Editor to view the
measurement high and low limits used for selected tests.

In User Defined Mode, use the Limits Editor to edit the limit
settings.

To edit a value, click that field and either select from the
displayed list or enter a new value. Use the bottom scroll
bar to view all available fields.

Instruments Detected Displays a list of the connected instruments found during the
instrument discovery. Instrument types include equipment
such as oscilloscopes and signal generators. Select
Instrument Control Settings to refresh the connected
instrument list (see page 14).
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Table 7: Common parameters and values (cont.)

Parameter Type Parameter and Default Value

Test Parameters (for Ripple voltage) To select the parameter values for AC Frequency, AC
Voltage, Load & Temperature for Ripple test needs.

Record Length, Sample Rate These settings apply to all tests selected for the indicated
data rate.

Record Length: Specifies the waveform record length.

Sample Rate: Specifies the oscilloscope sample rate to
use for all tests.

xxx

See also

About acquisitions (see page 21)
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Status panel overview

The Status panel provides status on test acquisition and analysis (Test Status (see page 29) tab) and a
listing of test tasks performed (Log View (see page 30) tab). The application opens the Test Status tab
when you start a test run. You can select the Test Status or the Log View tab to view these items while
tests are running.

Test status view
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Log view

The Log View display has several viewing options:

Message History: This window timestamps and displays all run messages.

Show Detailed Log: Select this check box to record a detailed history of test execution. This must
be checked before starting a measurement.

Auto Scroll: Select this check box to have the program automatically scroll down as information
is added to the log during the test.

Clear Log: Click this button to clear all messages from the display.

Save: Click this button to save the log file as a text file. A standard Save File window is displayed
to name and save the file.

See also

Application panel overview (see page 18)

Results panel overview

When a test finishes, the application switches to the Results panel (see page 31) to display a summary
of signal and preset test results. The Overall Test Result is displayed at the top left of the Results table.
If all of the tests for the session pass, the overall test result is Pass. If one or more tests fail, the overall
test result is Fail.

30 TekExpress USB Power Adapter / EPS Compliance Automated Test Solution Software



Operating basics Results panel overview

Set viewing preferences for this panel from the Preferences menu in the upper right corner. Viewing
preferences include showing whether a test passed or failed, summary results or detailed results, and
enabling wordwrap.

Results panel

When a test finishes, the application switches to the Results panel (see page 30), which displays a
summary of test results.

NOTE. NAN (Not A Number) is displayed in the test results if an invalid waveform was supplied for the test.

Each test result occupies a row in the Results table. By default, results are displayed in summary format
with the measurement details collapsed and with the Pass/Fail column visible. Change the view in the
following ways:

To expand all tests listed, select View Results Details from the Preferences menu in the upper right
corner.

To expand and collapse tests, click the plus and minus buttons.

To collapse all expanded tests, select Preferences > View Results Summary.

To remove or restore the Pass/Fail column, select Preferences > Show Pass/Fail.

To enable or disable the wordwrap feature, select Preferences > Enable Wordwrap.
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To expand the width of a column, place the cursor over the vertical line that separates the column
from the column to the right. When the cursor changes to a double-ended arrow, hold down the mouse
button and drag the column to the desired width.

To clear all test results displayed, click Clear.

See also

View a report (see page 35)
About panels (see page 18)

View test-related files

Files related to tests are stored in the My TekExpress\USB PWR folder. Each test setup in this folder has
a test setup file and a test setup folder, both with the test setup name.

The test setup file is preceded by the TekExpress icon and usually has no visible file name extension.

Inside the test setup folder is another folder named for the DUT ID used in the test sessions. The default
is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has a folder and file pair, both
named for the test session using the naming convention (date)_(time). Each session file is stored outside
its matching session folder:

Each session folder contains image files of any plots generated from running the test session. If you
selected to save all waveforms or ran tests using prerecorded waveform files, these are included here.

The first time you run a new, unsaved session, the session files are stored in the Untitled Session

folder located at ..\My TekExpress\USB PWR. When you name and save the session, the files are
placed in a folder with the name that you specify. A copy of the test files stay in the Untitled Session folder
until you run a new test or until you close the USBPWR application.

See also

File name extensions (see page 10)
Before you click start (see page 45)

32 TekExpress USB Power Adapter / EPS Compliance Automated Test Solution Software



Operating basics Reports panel overview

Reports panel overview

Use the Reports panel (see page 33) to browse for reports, name and save reports, select report content to
include, and select report viewing options.

For information on setting up reports, see Select report options (see page 33). For information on viewing
reports, see View a Report (see page 35).

Reports panel

See also

About panels (see page 18)

Select report options

Use the Reports panel (see page 33) to select which test information to include in the report, and the naming
conventions to use for the report. For example, always give the report a unique name or select to have the
same name increment each time you run a particular test. Generally, you would select report options before
running a test or when creating and saving test setups. Report settings are included in saved test setups.
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In the Reports panel, select from the following report options:

Table 8: Report options

Setting Description

Generate new report Creates a new report.

Replace current test values with the new results Replaces the previous test results with the latest test
results. Newly added tests results are appended to the end
of the report.

Append to previous report Appends the latest test results to the end of the current test
results report.

Report Path Displays the name and location from which to open a
report. The default location is at \My TekExpress\USB
PWR\Untitled Session. The report file in this folder gets
overwritten each time you run a test unless you specify a
unique name or select to auto increment the report name.

Change the report name or location.

Do one of the following:

In the Report Path field, type over the current
folder path and name.

Double-click in the Report Path field
and then make selections from the popup
keyboard and click the Enter button.

Be sure to include the entire folder path, the file name,
and the file extension. For example: C:\Documents
and Settings\your user name\My Documents\My
TekExpress\USB PWR\DUT001_Test_72.7.1.3.mht.

NOTE. You cannot set the file location using the Browse
button.

Open an existing report.

Click Browse, locate and select the report file and then click
View at the bottom of the panel.

Save As Type Saves a report in the specified file type. Lists supported file
types to choose from.

NOTE. If you select a file type different from the default,
be sure to change the report file name extension in the
Report Name field to match.

View Report After Generating Automatically opens the report in a Web browser when the
test completes. This option is selected by default.

Include Pass/Fail Results Summary Sets the application to include the color block labeled Test
Result (indicating whether the test passed or failed) in the
report. For details, see Report Contents in View a report
(see page 35).
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Table 8: Report options (cont.)

Setting Description

Include Detailed Results Sets the application to include parameter limits and
test-specific comments generated during the test.

Include Plot Images Sets the application to include plotted diagrams.

Include Setup Configuration Sets the application to include hardware and software
information in the summary box at the top of the report.
Information includes: the oscilloscope model and serial
number, probe model and serial number, the oscilloscope
firmware version, SPC and factory calibration status,
and software versions for applications used in the
measurements.

Include User Comments Select to include any comments about the test that you or
another user added in the DUT tab of the Setup panel.

xxx

See also

View a report (see page 35)
About setting up tests (see page 39)

View a report

The application automatically generates a report when test analysis is completed and displays the report
in your default Web browser (unless you cleared the View Report After Generating check box in the
Reports panel before running the test). If you cleared this check box, or to view a different test report,
do the following:

1. Click the Browse button and locate and select the report file to view.

NOTE. If you did not save the test setup after running the report and you either closed the application or
you ran another report, the report file was not saved.

2. In the Reports panel, click View.

For information on changing the file type, file name, and other report options, see Select report options
(see page 33).

Report contents

A report shows specified test details, as defined in the Reports panel.

TekExpress USB Power Adapter / EPS Compliance Automated Test Solution Software 35



Operating basics Report contents

NOTE. NAN (Not A Number) is displayed in the report contents if an invalid waveform was supplied
for the test.

Setup configuration information

Setup configuration information is listed in the summary box at the beginning of the report. This
information includes the oscilloscope model and serial number, and software versions. To exclude this
information from a report, clear the Include Setup Configuration check box in the Reports panel before
running the test.

Test result summary

The Test Result column indicates whether a test passed or failed. If the test passed, the column cell is
green. If the test failed, it is red. To exclude this information from a report, clear the Include Pass/Fail
Results Summary check box in the Reports panel before running the test.
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See also

Results panel overview (see page 30)
View test-related files (see page 32)
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About setting up tests

Set up tests using the tabs in the Setup panel (see page 18).

Tests are saved when you save a test setup. To avoid overwriting test results, remember to assign a unique
name to the test either before running it or immediately after.

See also

Test setup overview (see page 43)
Before you click start (see page 45)
About test setups (see page 49)
About running tests (see page 45)

TekExpress USB Power Adapter / EPS Compliance Automated Test Solution Software 39



Setting up and configuring tests Equipment connection setup

Equipment connection setup

The following diagrams shows how to connect the DUT to the oscilloscope for the measurements.

Common Mode connection

Ripple Voltage connection

See also

Minimum system requirements (see page 3)
View connected instruments (see page 41)
About setting up tests (see page 39)
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View connected instruments

Use the Instrument Control Settings dialog box to view or search for connected instruments required for
the tests. The application uses TekVISA to discover the connected instruments.

To refresh the list of connected instruments:

1. From the Options menu, select Instrument Control Settings.

2. In the Search Criteria section of the Instrument Control Settings dialog box, select the connection types
of the instruments for which to search.

Instrument search is based on the VISA layer, but different connections determine the resource type,
such as LAN, GPIB, and USB. For example, if you choose LAN, the search will include all the
instruments supported by TekExpress that are communicating over the LAN. If the search does not
find any instruments that match a selected resource type, a message appears telling you that no such
instruments were found.

3. Click Refresh. TekExpress searches for connected instruments.

4. After discovery, the dialog box lists the instrument-related details based on the search criteria you
selected. For example, if you selected LAN and GPIB as the search criteria, the application checks for
the availability of instruments over LAN, then GPIB.
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The details of the instruments are displayed in the Retrieved Instruments table. The time and date of
instrument refresh is displayed in the Last Updated field.

See also

Configuration test parameters (see page 27)
Equipment connection setup (see page 40)
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Test setup overview

Test setup includes acquisition and configuration parameters. You can also select report options when
setting up tests. Use the options in the Setup panel (see page 18) and Reports panel (see page 33) to
select and configure tests.

1. Set DUT parameters (see page 19).

2. Select one or more tests (see page 20).

3. Select acquisitions (see page 21).

4. Configuration test parameters (see page 27).

5. Set test measurement notification options (see page 25).

6. Select report options (see page 33).

See also

About test setups (see page 49)
Prerun checklist (see page 48)
Before you click start (see page 45)
About running tests (see page 45)
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About running tests

After selecting and configuring tests, review the prerun checklist (see page 48) and then click Start to
run the tests. While tests are running, you cannot access the Setup or Reports panels. To monitor the test
progress, switch back and forth between the Status panel and the Results panel.

The application displays a report when the tests are complete. While the tests are running, other
applications may display windows in the background. The TekScope application takes precedence over
other applications, but you can switch to other applications by using the Alt + Tab key combination. To
keep the TekExpress USBPWR application on top, select Keep On Top from the TekExpress Options
menu.

See also

Before you click start (see page 45)
About configuring tests (see page 25)
About setting up tests (see page 39)

Before you click start

Before you run tests for the first time, do the following:

1. Understand where your test files are stored on the instrument.

After you install and launch TekExpress USBPWR, it creates the following folders on the oscilloscope:

\My Documents\My TekExpress\USB PWR

\My Documents\My TekExpress\USB PWR\Untitled Session

Every time you launch TekExpress USBPWR, an Untitled Session folder is created in the USB
PWR folder. The Untitled Session folder is automatically deleted when you exit the USBPWR
application. To preserve your test session files, save the test setup before exiting the TekExpress
application.

CAUTION. Do not modify any of the session files or folders because this may result in loss of data
or corrupted session files. Each session has multiple files associated with it. When you save a
session, a .TekX file, and a folder named for the session that contains associated files, is created
on the oscilloscope X: drive.

2. Map the shared My TekExpress folder (see page 47) as X: (X drive) on the instruments used in test
setups running Microsoft Windows Operating System.

The My TekExpress folder has the share name format <domain><user ID>My TekExpress. Or, if
the instrument is not connected to a domain, the share name format is <instrument name><user
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ID>My TekExpress. This shared folder is used to save the waveform files and is used during other
file transfer operations.

NOTE. If the X: drive is mapped to any other shared folder, the application will display a warning message
asking you to disconnect the X: drive manually.

3. Make sure that the My TekExpress folder has read and write access, and that the contents are not set
to be encrypted:

a. Right-click the folder and select Properties.

b. Select the General tab and then click Advanced.

c. In the Advanced Attributes dialog box, make sure that the option Encrypt contents to secure
data is NOT selected. Example.

4. See the prerun checklist (see page 48) before you run a test.

See also

Configuration test parameters (see page 27)
View test-related files (see page 32)
Application directories and usage (see page 8)
File name extensions (see page 10)
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Map the My TekExpress folder

In the case where you operate the TekExpress application on one oscilloscope, but acquire data from
another (remotely-accessed) oscilloscope, you need to share and map the My TekExpress folder on the
remote instrument with the USBPWR application.

To map the My TekExpress folder on a remote instrument:

1. Open Windows Explorer.

2. From the Windows Explorer menu, click Computer.

3. In the menu bar, click Map network drive.

4. Select the Drive letter as X: (if there is any previous connection on X:, disconnect it first through
Tools > Disconnect Network drive menu of Windows Explorer. Windows 7 users: if you do not see
the Tools menu, press the Alt key).

5. In the Folder field, enter the remote My TekExpress folder path (for example, \\192.158.97.65\ My
TekExpress).

6. Click Finish.

To determine the IP address of the instrument where the My TekExpress folder exists, do the following:

1. On the instrument where the My TekExpress folder exists, click Start and select Run.

2. Type cmd and press Enter.

3. At the command prompt, type ipconfig and press Enter.
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Prerun checklist

Do the following before you click Start to run a test. If this is the first time you are running a test on a
setup, refer to the information in Before you click start (see page 45).

1. Make sure that all the required instruments are properly warmed up (approximately 20 minutes).

2. Perform Signal Path Compensation (SPC).

a. On the oscilloscope main menu, select the Utilities menu.

b. Select Instrument Calibration.

3. Verify that the application is able to find the DUT. If it cannot, perform a search for connected
instruments (see page 41).

a. In USBPWR, select the Setup panel and then click the Test Selection tab.

b. Select any test and then click Configure.

c. In the Configuration section, click Global Settings.

d. In the Instruments Detected section, click the drop-down arrow to the right of Real Time
Scope and make sure that the oscilloscope with the (GPIB8::1::INSTR) designation is in
the list.

See also

Equipment connection setup (see page 40)
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About test setups

TekExpress USBPWR opens with the default setup selected. Run a test before or after saving a setup.
When you save a setup, the test information, such as the selected oscilloscope, general parameters,
acquisition parameters, measurement limits, waveforms (if applicable), and other configuration settings are
all saved under the setup name at X:\USB PWR.

Use test setups to:

Run a saved test in prerecorded mode.

View all the information associated with a saved test, including the log file, the history of the test
status as it executed, and the results summary.

Create a new test setup based on an existing one.

Run a new session, acquiring live waveforms, using a saved test configuration.

See also

About setting up tests (see page 39)
Save a test setup (see page 49)
Recall a saved test setup (see page 50)

Save a test setup

Save a test setup before or after running a test to save the test configuration. Create a new test setup
from any open setup or from the default setup. When you select the default test setup, all parameters
are returned to the application’s default values.

To save the current setup session to the same setup name, select Options > Save Test Setup.

To save the current setup session to a new setup name, select Options > Save Test Setup As.

To create and save a new setup from the default test setup:

1. Select Options > Default Test Setup.

2. Select Setup and set required options and parameters in the tabs (DUT, Test Selection, and so on).

3. Select Reports and set your report options (see page 33).

4. Optional: Click Start to run the test and verify that it runs correctly and captures the information you
want. If it does not, edit the parameters and repeat this step until the test runs to your satisfaction.

Running the test helps verify that all parameters are set correctly, but it is not a necessary step.

5. Select Options > Save Test Setup. Enter the file name for the setup file. The application saves the
file to X:\USB PWR\<session_name.
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See also

About setting up tests (see page 39)
Test setup overview (see page 43)
View test-related files (see page 32)
About configuring tests (see page 25)

Open (load) a saved test setup

These instructions are for recalling saved test setups.

1. Select Options > Open Test Setup.

2. Select the setup from the list and click Open. Setup files must be located at X:\USB PWR.

See also

About test setups (see page 49)
Create a new test setup based on an existing one (see page 50)
Test setups overview (see page 43)

Create a new test setup based on an existing one

Use this method to create a variation on a test setup without having to create the setup from the beginning.

1. Select Options > Open Test Setup.

2. Select a setup from the list and then click Open.

3. Use the Setup and Reports panels to modify the parameters to meet your testing requirements.

4. Select Options > Save Test Setup As.

5. Enter a test setup name and click Save.

See also

About test setups (see page 49)
Set DUT parameters (see page 19)
Configuration parameters (see page 27)
Select acquisitions (see page 21)
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About the programmatic interface

The Programmatic interface seamlessly integrates the TekExpress test automation application with the
high-level automation layer. This also lets you control the state of the TekExpress application running on a
local or a remote computer.

The following terminology is used in this section to simplify description text:

TekExpress Client: A high-level automation application that communicates with TekExpress using
TekExpress Programmatic Interface.

TekExpress Server: The TekExpress application when being controlled by TekExpress Client.

TekExpress leverages .Net Marshalling to enable the Programmatic Interface for TekExpress Client.
TekExpress provides a client library for TekExpress clients to use the programmatic interface. The
TekExpress client library is inherited from .Net MarshalByRef class to provide the proxy object for the
clients. The TekExpress client library maintains a reference to the TekExpress Server and this reference
allows the client to control the server state.

See also

Requirements for Developing TekExpress Client (see page 51)

Requirements for developing TekExpress client

While developing TekExpress Client, use the TekExpressClient.dll. The client can be a VB .Net, C#
.Net, TestStand, or Web application. The examples for interfaces in each of these applications are in the
Samples folder.
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References required

TekExpressClient.dll has an internal reference to IIdlglib.dll and IRemoteInter-
face.dll.

IIdlglib.dll has a reference to TekDotNetLib.dll.

IRemoteInterface.dll provides the interfaces required to perform the remote automations. It is an
interface that forms the communication line between the server and the client.

IIdlglib.dll provides the methods to generate and direct the secondary dialog messages at the
client-end.

NOTE. The end-user client application does not need any reference to the above mentioned DLL files.
It is essential to have these DLLs (IRemoteInterface.dll, IIdlglib.dll and TekDotNetLib.dll) in the same
folder as that of TekExpressClient.dll.

Required steps for a client

The client uses the following steps to use TekExpressClient.dll to programmatically control the
server:

Develop a client UI to access the interfaces exposed through the server. This client loads
TekExpressClient.dll to access the interfaces. After TekExpressClient.dll is loaded, the client
UI can call the specific functions to run the operations requested by the client. When the client is up and
running, it does the following to run a remote operation:

1. To connect to the server, the client provides the IP address of the PC where the server is running.

2. The client locks the server application to avoid conflict with any other Client that may try to control
the server simultaneously. “Lock” would also disable all user controls on the server so that server
state cannot be changed by manual operation.

If any other client tries to access a server that is locked, it will receive a notification that the server
is locked by another client.

3. When the client has connected to and locked the server, the client can access any of the programmatic
controls needed to run the remote automations.

4. After the client operations finish, the client unlocks the server.

See also

USB PWR application commands flow (see page 60)
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Remote proxy object

The server exposes a remote object to let the remote client access and perform the server-side operations
remotely. The proxy object is instantiated and exposed at the server-end through marshalling.

The following is an example:

RemotingConfiguration.RegisterWellKnownServiceType (typeof (TekExpressRe-

moteInterface), “TekExpress Remote interface”, WellKnownObjectMode.Singleton);

This object lets the remote client access the interfaces exposed at the server side. The client gets the
reference to this object when the client gets connected to the server.

For example,

//Get a reference to the remote object

remoteObject = (IRemoteInterface)Activator.GetObject(typeof(IRemoteInterface),

URL.ToString());

Client proxy object

Client exposes a proxy object to receive certain information.
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For example,

//Register the client proxy object

WellKnownServiceTypeEntry[] e = RemotingConfiguration.GetRegisteredWell-

KnownServiceTypes();

clientInterface = new ClientInterface();

RemotingConfiguration.RegisterWellKnownServiceType(typeof(ClientInterface),

“Remote Client Interface”, WellKnownObjectMode.Singleton);

//Expose the client proxy object through marshalling

RemotingServices.Marshal(clientInterface, "Remote Client Inteface");

The client proxy object is used for the following:

To get the secondary dialog messages from the server.

To get the file transfer commands from the server while transferring the report.

Examples

clientObject.clientIntf.DisplayDialog(caption, msg,iconType, btnType);

clientObject.clientIntf.TransferBytes(buffer, read, fileLength);

For more information, click the following links:

Secondary Dialog Message Handling

The secondary dialog messages from the Secondary Dialog library are redirected to the client-end when a
client is performing the automations at the remote end.

In the secondary dialog library, the assembly that is calling for the dialog box to be displayed is checked
and if a remote connection is detected, the messages are directed to the remote end.

File Transfer Events
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When the client requests the transfer of the report, the server reads the report and transfers the file by
calling the file transfer methods at the client-end.

Client programmatic interface example

The following is an overview of the client programmatic interface:

Process flowchart diagram
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Process overview:
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1. Connect to a server or remote object using a programmatic interface.

2. Get the client ID that is created when connecting to the remote object. This client ID is one of the
required parameters to communicate with the server.

NOTE. The server identifies the client with this ID only and rejects any request if the ID is invalid.

3. Lock the server for further operations. This disables the application interface.

NOTE. You can get values from the server or set values from the server to the client only if the application
is locked.

4. Register for receiving notifications on status change events on the server. To register you need to give
a handler as a parameter. For details, see Handler of Status Change Notification (see page 57).

NOTE. Whenever there is a change in the status of the server, all the clients registered with the server
receive a notification from the server.

5. Select the tests that you want to run through the programmatic interface.

6. Set the necessary parameters for each test.

7. Run the tests.

8. Poll for the status of the application.

NOTE. Skip step 8 if you are registered for the status change notification and the status is Ready.

9. After completing the tests, get the results.

10. Create a report or display the results and verify or process the results.

11. Unlock the server after you complete all the tasks.

12. Disconnect from the remote object.

Handler of status change notification

1. Get the status. If the status is Wait or Error, get the information that contains the title, message
description, and the expected responses for the status.

2. Perform the actions based on the status information.

3. Set the response as expected.
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See also

USB PWR application commands flow (see page 60)
Program remote access code example (see page 59)
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Program remote access code example

This code example shows how to communicate between a remote PC and TekExpress USBPWR.

Table 9: Remote access code example

Task Code

Start the
application

Connect through
an IP address.

m_Client.Connect("localhost") 'True or False

clientID = m_Client.getClientID

Lock the server m_Client.LockServer(clientID)

Disable the
Popups

m_Client.SetVerboseMode(clientID, false)

Set the DUT ID m_Client.SetDutId(clientID, "DUT_Name")

Select a test mClient.SelectsingleTest(clientID, "Transmitter", "Detachable",

“Spec 1.0”, "400KHz-1MHz", true)

Select a Sample
Rate

mClient.SetAcquireParameter(clientID, "Transmitter", "Detachable",

"400KHz-1MHz", "Sample Rate (Ms/sec)$250")

Select a Record
Length

mClient.SetAcquireParameter(clientID, "Transmitter", "Detachable",

"400KHz-1MHz", "Record Length$10")

Run with set
configurations

m_Client.Run(clientID)

Wait for the test to
complete.

Do

Thread.Sleep(500)

m_Client.Application_Status(clientID)

Select Case status

Case "Wait"

Get the current
state information

mClient.GetCurrentStateInfo(clientID, WaitingMsbBxCaption,

WaitingMsbBxMessage, WaitingMsbBxButtontexts)

Send the
response

mClient.SendResponse(clientID, WaitingMsbBxCaption, WaitingMsb-

BxMessage, WaitingMsbBxResponse)

End Select

Loop Until status = "Ready"

Save results Save all results values from folder for current run

m_Client.TransferResult(clientID, logDirname)

Unlock the server m_Client.UnlockServer(clientID)

Disconnect from
server

m_Client.Disconnect()

Exit the
application

xxx
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USBPWR application commands flow

Click a client action link to see the associated command name, description, parameters, return value,
and an example.

Connect through an IP address (see page 65)

Lock the server (see page 66)

Disable the popups (see page 67)

Set or get the DUT ID (see page 68)

Set the configuration parameters for a suite or measurement (see page 69)

Query the configuration parameters for a suite or measurement (see page 70)

Select a test (see page 71)

Select a suite (see page 72)

Select a channel (see page 73)

Configure the selected measurement (see page 74)

Run with set configurations or stop the run operation (see page 75)

Handle error codes (see page 76)

Get or set the timeout value (see page 77)

Wait for the test to complete (see page 78)

After the test is complete (see page 80)

Save, recall, or query a saved session (see page 84)

Unlock the server (see page 85)

Disconnect from the server (see page 85)

string id

Name Type Direction Description

id string IN Identifier of the client performing the
remote function

xxx

Ready: Test configured and ready to start

Running: Test running

Paused: Test paused

Wait: A popup that needs your inputs

Error: An error is occurred
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string dutName

Name Type Direction Description

dutName string IN The new DUT ID of the setup

xxx

out bool saved

Name Type Direction Description

saved bool OUT Boolean representing whether the
current session is saved

xxx

This parameter is used as a check in SaveSession() and SaveSessionAs() functions.

string ipAddress

Name Type Direction Description

ipAddress string IN The ip address of the server to which the
client is trying to connect. This is required to
establish the connection between the server
and the client.

xxx

out string clientID

Name Type Direction Description

clientid string OUT Identifier of the client that is connected to the
server

clientId = unique number + ipaddress of the
client. For example, 1065–192.157.98.70

xxx

NOTE. If the dutName parameter is null, the client is prompted to provide a valid DUT ID.

NOTE. The server must be active and running for the client to connect to the server. Any number of
clients can be connected to the server at a time.

NOTE. When the client is disconnected, it is unlocked from the server and then disconnected. The id
is reused.
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string dutId

Name Type Direction Description

dutId string OUT The DUT ID of the setup.

xxx

The dutId parameter is set after the server processes the request.

string device

Name Type Direction Description

device string IN Specifies the name of the device.

xxx

string suite

Name Type Direction Description

suite string IN Specifies the name of the suite

xxx

string test

Name Type Direction Description

test string IN Specifies the name of the test to obtain the pass or fail status
or a test result value.

xxx

string parameterString

Name Type Direction Description

parameterString string IN Selects or deselects a test

xxx

int rowNr

Name Type Direction Description

rowNr int IN Specifies the zero based row index of
the sub-measurement for obtaining
the result value

xxx

NOTE. When the client tries to lock a server that is locked by another client, the client gets a
notification that the server is already locked and it must wait until the server is unlocked. If the client
locks the server and is idle for a certain amount of time then the server is unlocked automatically
from that client.
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out string[] status

Name Type Direction Description

status string array OUT The list of status messages generated
during the run

xxx

string name

Name Type Direction Description

name string IN The name of the session being
recalled

xxx

The name parameter cannot be empty. If it is empty, the client is prompted to provide a valid name.

NOTE. When the run is performed, the status of the run is updated periodically using a timer.

string name

Name Type Direction Description

name string IN The name of the session being saved

xxx

The name parameter cannot be empty. If it is empty, the client is prompted to provide a valid name.

Once the session is saved under ‘name’ you cannot use this method to save the session in a different
name. Use SaveSessionAs instead.

string name

Name Type Direction Description

name string IN The name of the session being
recalled

xxx

The same session is saved under different names using this method. The name parameter cannot be
empty. If it is empty, the client is prompted to provide a valid name.

bool isSelected

Name Type Direction Description

isSelected bool IN Selects or deselects a test

xxx
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string time

Name Type Direction Description

time string IN The time in seconds
that refers to the timeout
period

xxx

The time parameter gives the timeout period, which is the time the client is allowed to be locked and
idle. After the timeout period if the client is still idle, it gets unlocked.

The time parameter should be a positive integer; otherwise, the client is prompted to provide a
valid timeout period.

bool_verbose

Name Type Direction Description

_verbose bool IN Specifies whether the verbose mode
should be turned ON or OFF

xxx

NOTE. When the session is stopped, the client is prompted to stop the session and is stopped at
the consent.

string filePath

Name Type Direction Description

filePath string IN The location where the report must
be saved in the client

xxx

NOTE. If the client does not provide the location to save the report, the report is saved at
C:\ProgramFiles.

NOTE. When the client is disconnected, the client is unlocked automatically.

out string WaitingMsbBxCaption

Name Type Direction Description

caption string OUT The wait state or error state message sent to
you

xxx
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out string WaitingMsbBxMessage

Name Type Direction Description

message string OUT The wait state/error state message sent to you

xxx

out string[] WaitingMsbBxButtontexts

Name Type Direction Description

buttonTexts string array OUT An array of strings containing the
possible response types that you can
send

xxx

string WaitingMsbBxResponse

Name Type Direction Description

response string IN A string containing the response
type that you can select (it must be
one of the strings in the string array
buttonTexts)

xxx

out string clientID

Name Type Direction Description

clientID string OUT Identifier of the client that is connected to the
server

clientID = unique number + IP address of the
client. For example, 1065–192.157.98.70

xxx

Connect through an IP address
Command name Parameters Description Return value Example

Connect() string
ipAddress (see
page 61)

out string
clientID (see
page 61)

This method
connects the client
to the server.
Note (see page 61)

The client provides
the IP address
to connect to the
server.

The server
provides a unique
client identification
number when
connected to it.

Return value is
either True or
False

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as boolean

returnval = m_Client.Con-
nect(ipaddress,m_clientID)

xxx
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NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

Lock the server
Command name Parameters Description Return value Example

LockSession() string clientID
(see page 65)

This method locks
the server.
Note (see page 62)

The client must
call this method
before running
any of the remote
automations. The
server can be
locked by only one
client.

String value
that gives the
status of the
operation after
it was performed

The return value
is "Session
Locked...” on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval =
m_Client.LockServer(clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Disable the popups

Use these commands to disable popup messages that require user intervention.

Command name Parameters Description Return value Example

SetVerboseMode() string clientID
(see page 65)

bool _verbose
(see page 64)

This method sets
the verbose mode
to either true or
false.

When the value
is set to true, any
message boxes
that appear during
the application
are routed to the
client machine
that is controlling
TekExpress.

When the value is
set to false, all the
message boxes
are shown on the
server machine.

String that gives
the status of the
operation after it
was performed

When Verbose
mode is set to
true, the return
value is “Verbose
mode turned on.
All dialog boxes
will be shown to
client”.

When Verbose
mode is set to
false, the return
value is “Verbose
mode turned off.
All dialog boxes
will be shown to
server”.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Verbose mode is turned on

return=m_Client.SetVerbose-
Mode(clientID, true)

Verbose mode is turned off

returnval=m_Client.SetVer-
boseMode(clientID, false)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Set or get the DUT ID
Command name Parameters Description Return value Example

SetDutId() string clientID
(see page 65)

string dutName
(see page 61)

This method
changes the DUT
ID of the setup.
The client must
provide a valid
DUT ID.

String that gives
the status of the
operation after it
was performed

Return value
is “DUT Id
Changed” on
success

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

return=m_Client.SetDutId(clien-
tID,desiredDutId)
Note (see page 61)

GetDutId() string clientID
(see page 65)

string dutId (see
page 62)

This method gets
the DUT ID of the
current setup.

String that gives
the status of the
operation after it
was performed

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

return=m_Client.GetDutid(clien-
tID, out DutId)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Set the configuration parameters for a suite or measurement
Command name Parameters Description Return value Example

SetGeneralParame-
ter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method
sets the general
configuration
parameters
for a suite or
measurement.

String that gives
the status of
the operation
after it has been
performed

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Select email on failure
preference example (see
page 70)

SetAnalyzeParame-
ter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method sets
the configuration
parameters in the
Analyze panel of
the Configuration
Panel dialog box
for a suite or
measurement.

String that gives
the status of
the operation
after it has been
performed The
return value is ""
(an empty String)
on success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.
returnval as string

SetAcquireParame-
ter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method sets
the configuration
parameters in the
Acquire panel of
the Configuration
Panel dialog box
for a suite or
measurement.

String that gives
the status of
the operation
after it has been
performed The
return value is ""
(an empty String)
on success.

//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnVal = remoteObject.Se-
tAcquireParameter( id, device,
suite, test, parameterString)

if ((OP_STATUS) returnVal !=
OP_STATUS.SUCCESS)

return CommandFailed(return-
Val)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Select email on failure preference example

returnval=mClient.SetGeneralParameter(clientID, "Transmitter", "Detachable", "400KHz-1MHz",
"On Failure Stop and Notify$False")

Query the configuration parameters for a suite or measurement
Command name Parameters Description Return value Example

GetGeneralParam-
eter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method
gets the general
configuration
parameters
for a suite or
measurement.

The return value
is the general
configuration
parameter for
a specified suite
or measurement
that is set.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Query email on failure
preference example (see
page 71)

GetAnalyzeParam-
eter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method gets
the configuration
parameters set
in the Analyze
panel of the
Configuration
Panel dialog
box for a
specified suite
or measurement.

The return
value is the
configuration
parameter set
in the Analyze
panel of the
Configuration
Panel dialog
box for a
specified suite
or measurement.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

GetAcquireParame-
ter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method gets
the configuration
parameters set
in the Acquire
panel for a
specified suite
or measurement.

The return
value is the
configuration
parameter set
in the Acquire
panel for a
specified suite
or measurement.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

xxx
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NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

Query email on failure preference example

returnval = mClient.GetGeneralParameter(clientID, "Transmitter", "Detachable", "400KHz-1MHz",
"On Failure Stop and Notify")

Select a test
Command name Parameters Description Return value Example

GetGeneralParam-
eter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

bool isSelected
(see page 63)

This method
selects or
deselects a
specified test.

If this Setting
parameter is
set to true, you
can select a
measurement.

If this Setting
parameter is
set to false, you
can deselect a
measurement.

String that
displays the
status of the
operation after
it has been
performed.

The return
value is "" (an
empty String) on
success.

//m_Client is a reference to the
Client class in the Client DLL

returnval as string

Select test example (see
page 72)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Select test example

To select measurement test Common mode- 400KHz-1MHz:

returnval = mClient.SelectTest(clientID, "Transmitter", "Detachable", "400KHz-1MHz", true)

Select a suite

Test suite must be set for Detachable or Permanent tests.

Command name Parameters Description Return value Example

SelectSuite string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

bool isSelected
(see page 63)

This method
selects or
deselects a
specified suite.

When this
parameter is
set to true, you
can select a
suite. When this
parameter is set
to false, you can
deselect a suite.

String that gives
the status of
the operation
after it has been
performed.

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Select Suite (Default):

returnval=mClient.Select-
Suitet(clientID, "Transmitter",
"Detachable", true)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Select a channel
Command name Parameters Description Return value Example

SetGeneralParame-
ter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method sets
the parameters
that are not
specific to any
one test.

NOTE. Using
this command we
can select a lane,
channel, or source
type.

String that gives
the status of
the operation
after it has been
performed.

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Set channel source example
(see page 74)

SetAnalyzeParame-
ter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method sets
the configuration
parameters in the
Analyze panel of
the Configuration
Panel dialog
box for a
specified suite
or measurement.

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.
returnval as string

SetAcquireParame-
ter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method sets
the configuration
parameters in the
Acquire panel of
the Configuration
Panel dialog
box for a
specified suite
or measurement.

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnVal = remoteObject.Se-
tAcquireParameter( id, device,
suite, test, parameterString)

if ((OP_STATUS) returnVal !=
OP_STATUS. SUCCESS) return
CommandFailed(returnVal)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Set channel source example

returnval = mClient.SetGeneralParameter(clientID, "Transmitter", "Detachable", "400KHz-1MHz",
"Channel Selection$CH1")

Configure the selected measurement
Command name Parameters Description Return value Example

SetAnalyzeParame-
ter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method
sets the Analyze
parameters
(Configuration
parameters) for a
specified test.

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.
returnval as string

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Run with set configurations or stop the run operation
Command name Parameters Description Return value Example

Run() string clientID
(see page 65)

Runs the selected
tests Note (see
page 63)

After the server
is set up and
configured, run
it remotely using
this function.

String that gives
the status of the
operation after it
was performed.

The return value
is "Run started..."
on success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Run(clien-
tID)

Stop() string clientID
(see page 65)

Stops the running
tests. Note (see
page 64)

String that gives
the status of the
operation after it
was performed

The return value
is "Stopped..." on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Stop(clien-
tID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

TekExpress USB Power Adapter / EPS Compliance Automated Test Solution Software 75



TekExpress programmatic interface Handle error codes

Handle error codes

The return value of the remote automations at the server-end is OP_STATUS, which changes to a string
value depending on its code, and returned to the client. The values of OP_STATUS are as follows:

Code Value Description

-1 FAIL The operation failed

1 SUCCESS The operation succeeded

2 NOT FOUND Server not found

3 LOCKED The server is locked by another client, so the operation cannot be performed

4 UNLOCK The server is not locked; lock the server before performing the operation

0 NULL Nothing

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Get or set the timeout value
Command name Parameters Description Return value Example

GetTimeOut() string clientID
(see page 65)

Returns the current
timeout period set
by the client

String that gives
the status of the
operation after it
was performed

The default
return value is
1800000.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.GetTime-
Out()

SetTimeOut() string clientID
(see page 65)

string time (see
page 64)

Sets a timeout
period specified
by the client.
After this timeout
period expires, the
server is unlocked
automatically.

String that gives
the status of the
operation after it
was performed

On success the
return value is
“TimeOut Period
Changed”.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.SetTime-
Out(clientID, desiredTimeOut)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Wait for the test to complete

The commands in this group execute while tests are running. The GetCurrentStateInfo() and
SendResponse() commands are executed when the application is running and in the wait state.

Command name Parameters Description Return value Example

ApplicationStatus() string clientID
(see page 65)

This method gets the
status of the server
application.

The states are
Running, Paused,
Wait, or Error (see
page 60)

String value that
gives the status
of the server
application

m_Client = new Client()
//m_Client is a reference to
the Client class in the Client
DLL.

returnval as string

returnval=m_Client.Applica-
tionStatus(clientID)

QueryStatus() string clientID
(see page 65)

out string[]
status (see
page 63)

An interface for
the user to transfer
Analyze panel status
messages from the
server to the client

String that gives
the status of the
operation after it
was performed

On success the
return value is
“Transferred...”.

m_Client = new Client()
//m_Client is a reference to
the Client class in the Client
DLL.

returnval as string

Query status example (see
page 80)
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Command name Parameters Description Return value Example

GetCurrentState-
Info()

NOTE. This
command is
used when the
application is
running and is in
the wait or error
state.

string clientID
(see page 65)

out string Wait-
ingMsbBx-
Caption (see
page 64)

out string Wait-
ingMsbBxMes-
sage (see
page 65)

out string[]
WaitingMsb-
BxButtontexts
(see page 65)

This method gets the
additional information
of the states when the
application is in Wait
or Error state.

Except client ID, all
the others are Out
parameters.

This command
does not return
any value.

This function
populates the
Out parameters
that are passed
when invoking
this function.

m_Client = new Client()
//m_Client is a reference to
the Client class in the Client
DLL

mClient.GetCurrentState-
Info(clientID, WaitingMsbBx-
Caption, WaitingMsbBxMes-
sage, WaitingMsbBxButton-
texts)

SendResponse()

NOTE. This
command is
used when the
application is
running and is in
the wait or error
state.

string clientID
(see page 65)

out string Wait-
ingMsbBx-
Caption (see
page 64)

out string Wait-
ingMsbBxMes-
sage (see
page 65)

string Wait-
ingMsbBxRe-
sponse (see
page 65)

After receiving the
additional information
using the method
GetCurrentStateInfo(),
the client can decide
which response to
send and then send
the response to the
application using
this function. The
response should be
one of the strings that
was received earlier
as a string array in the
GetCurrentStateInfo
function. The _caption
and _message should
match the information
received earlier in the
GetCurrentStateInfo
function.

This command
does not return
any value.

m_Client = new Client()
//m_Client is a reference to
the Client class in the Client
DLL

mClient.SendResponse(cli-
entID, WaitingMsbBxCaption,
WaitingMsbBxMessage, Wait-
ingMsbBxResponse)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Query status example

returnVal=m_Client.QueryStatus(clientID, out statusMessages)

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Status updated...”

else

return CommandFailed(returnVal)

After the test is complete
Command name Parameters Description Return value Example

GetPassFailSta-
tus()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

This method gets
the pass or fail
status of the
measurement after
test completion.

NOTE. Execute
this command
after completing
the measurement.

String that gives
the status of the
operation after it
was performed.

Returns the pass
or fail status in the
form of a string.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

GetResultsValue() string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 62)

This method gets
the result values of
the measurement
after the run.

String that gives
the status of the
operation after it
was performed.

Returns the result
value in the form
of a string.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as srting

returnval=m_Client.GetRe-
sultsValue(clientID, device,
devicesuite, test, parameter-
String)
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Command name Parameters Description Return value Example

GetReportParame-
ter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 82)

This method gets
the general report
details such as
oscilloscope model
and TekExpress
version.

The return
value is the
oscilloscope
model,
TekExpress
application
version, or
USBPWR
application
version.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Oscilloscope Model

returnval=m_Client.GetRe-
portParameter(clientID,"Scope
Model")

TekExpress Version

returnval=m_Client.GetReport-
Parameter(clientID,"TekExpress
Version")

USB PWR Version

returnval=m_Client.GetReport-
Parameter(clientID,"Application
Version")

GetResultsValue-
ForSubMeasure-
ments()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 82)

int rowNr (see
page 62)

This method gets
the result values
for individual
submeasurements
after the run.

String that gives
the status of
the operation
after it has been
performed.

Returns the result
value in the form
of a string.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Get results for a
submeasurement example
(see page 83)

GetReportParame-
ter()

string clientID
(see page 65)

string device
(see page 62)

string suite (see
page 62)

string test (see
page 62)

string parame-
terString (see
page 82)

This method
gets the general
report details such
as oscilloscope
model,
TekExpress
version, and
USB-PWR
version.

The return
value is the
oscilloscope
model,
TekExpress
version, and
USB-PWR
version.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Oscilloscope Model

returnval=m_Client.GetReport-
Parameter( clientID,"Scope
Model")

TekExpress Version

returnval=m_Client.GetReport-
Parameter(clientID,"TekExpress
Version")

USB-PWR Version

returnval=m_Client.GetReport-
Parameter(clientID,"Application
Version")
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Command name Parameters Description Return value Example

TransferReport() string clientID
(see page 65)

string filePath
(see page 64)

This method
transfers the report
generated after the
run.

The report
contains the
summary of the
run.

The client must
provide the
location where
the report is to
be saved at the
client-end.

String that gives
the status of
the operation
after it has been
performed.

Transfers all the
result values in
the form of a
string.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.TransferRe-
port(clientID,"C:\Report”)

TransferImages() string clientID
(see page 65)

string filePath
(see page 64)

This method
transfers all the
images (screen
shots) from the
specified client
and folder for
the current run
(for a suite or
measurement).

NOTE. Every
time you click
Start, a folder is
created in the X:
drive. Transfer the
waveforms before
clicking Start.

String that gives
the status of the
operation after it
was performed.

Transfers all the
images in the
form of a string.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.TransferIm-
ages(clientID, "C:\Waveforms”)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

string parameterString

Name Type Direction Description

parameterString string IN Specifies the oscilloscope model,
TekExpress version, and USB-PWR
version

xxx
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Get results for a submeasurement example

This example returns the specified submeasurement results for test Common mode test
400KHz-1MHz.

returnval=m_Client.GetResultsValue( clientID,"Transmitter", "Detachable", "400KHz-1MHz",
"Measured Value",0)

returnval=m_Client.GetResultsValue( clientID,"Transmitter", "Detachable", "1MHz-100MHz",
"Measured Value",1)
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Save, recall, or query a saved session
Command name Parameters Description Return value Example

CheckSession-
Saved()

string clientID
(see page 65)

out bool saved
(see page 61)

This method
checks whether
the current session
is saved.

Return value is
either True or
False.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Check-
SessionSaved(m_clientID, out
savedStatus)

RecallSession() string clientID
(see page 65)

string name
(see page 63)

Recalls a saved
session. The
client provides
the session name.

String that gives
the status of
the operation
after it has been
performed.

The return value
is “Session
Recalled...”

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.RecallSes-
sion(clientID, savedSession-
Name)

SaveSession() string clientID
(see page 65)

string name
(see page 63)

Saves the current
session. The
client provides
the session name.

String that gives
the status of
the operation
after it has been
performed.

The return value
is "Session Sav-
ed..."/"Failed..."

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.SaveSes-
sion(clientID, desiredSession-
Name)

SaveSessionAs() string clientID
(see page 65)

string name
(see page 63)

Saves the current
session under a
different name
every time this
method is called.
The client provides
the session name.

String that gives
the status of
the operation
after it has been
performed.

The return value
is "Session
Saved..."

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.SaveSes-
sionAs(clientID, desiredSes-
sionName)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Unlock the server
Command name Parameters Description Return value Example

UnlockSession() string clientID
(see page 65)

This method
unlocks the server
from the client.
The ID of the client
to be unlocked
must be provided.
Note (see page 64)

String that gives
the status of
the operation
after it has been
performed.

The return value
is "Session
UnLocked..."

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Unlock-
Server(clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

Disconnect from the server
Command name Parameters Description Return value Example

Disconnect() string clientID
(see page 65)

This method
disconnects the
client from the
server.
Note (see page 61)

Integer value that
gives the status
of the operation
after it has been
performed.

1 for Success

–1 for Failure.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Discon-
nect(m_clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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