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Welcome
 

 

Welcome to the TekExpress® USB2 Automated Test Solution application.
TekExpress USB2 is a Signal Quality, Non-Signal Quality, Power Measurement
and Receiver Sensitivity Measurement solution, which provides an automated,
simple, and efficient way to test USB2 interfaces and devices consistent to the
requirements of the USB2 specifications.

Key features and benefits
■ Comprehensive test coverage; select or deselect individual tests
■ Precise debugging and troubleshooting
■ USB-IF Signal Quality measurements integrated with TekExpress USB2
■ Automated Receiver Sensitivity measurement
■ User-friendly interface for plot inspection
■ Minimizes user intervention when performing time-consuming testing
■ Consolidated report for High Speed, Full Speed and Low Speed

measurements
■ Complete programmatic interface enables automation scripts to call

TekExpress USB2 functions
■ Flexible probe configuration
■ Comprehensive signal validation check



■ Automated DUT test mode control
■ USB-IF Signal Quality measurements integrated with TekExpress USB2



Getting help and support

Related documentation
The following documents are available as part of the TekExpress® USB2
Automated Test and Compliance Solution documentation set.

Table 1: Product documentation

Item Purpose Location
Application Help Application operation and User

Interface help

Press F1 on the oscilloscope
keyboard to open Application
Help.

PDF of the help Printable version of the
compiled help

PDF file that ships with USB2
(USB2-Automated-Test-
Solution-Software-Printable-
Help-EN-US.pdf).

See also Technical support
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Conventions used in help
Online Help uses the following conventions:

■ The term “DUT” is an abbreviation for Device Under Test.

■ The term “select” is a generic term that applies to the two methods of
choosing a screen item (button, control, list item): using a mouse or using the
touch screen.

Table 2: Icon descriptions

Icon Meaning
This icon identifies important information.

This icon identifies conditions or practices that could result in loss of data.

This icon identifies additional information that will help you use the application more
efficiently.

Technical support
Tektronix values your feedback on our products. To help us serve you better,
please send us your suggestions, ideas, or comments on your application or
oscilloscope. Contact Tektronix through mail, telephone, or the Web site. See 
Contacting Tektronix for more information.

When you contact Tektronix Technical Support, please include the following
information (be as specific as possible):

General information ■ All instrument model numbers
■ Hardware options, if any
■ Probes used
■ Your name, company, mailing address, phone number, FAX number
■ Please indicate if you would like to be contacted by Tektronix about your

suggestion or comments.

Getting help and support  
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Application specific
information

■ Software version number
■ Description of the problem such that technical support can duplicate the

problem
■ If possible, save and send the setup files for all the instruments used and the

application
■ If possible, save and send the TekExpress USB2 setup files, *.TekX (session

files and folders), and status messages text file
■ If possible, save and send the waveform on which you are performing the

measurement as a .wfm file
■ If possible, log files of Tektronix HSETT Controller from folder C:\Program

Files\Tektronix\TekApplication\Tektronix.\HSETT Controller\

 Getting help and support
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Getting started

Installing the software

Minimum system
requirements

The following table shows the minimum system requirements needed for an
oscilloscope to run TekExpress USB2.

Table 3: TekExpress USB2 system requirements

Component Requirement
Oscilloscope See Supported instruments
Processor Same as the oscilloscope
Operating System Same as the oscilloscope:

■ Windows 7 (64-bit only) SP1 Windows
7 user account settings

Memory Same as the oscilloscope
Hard Disk Same as the oscilloscope
Display Super VGA resolution or higher video adapter

(800 x 600 minimum video resolution for small
fonts or 1024 x 768 minimum video resolution
for large fonts). The application is best viewed at
96 dpi display settings 1 

Firmware ■ TekScope 6.8.1 and later (for Windows 7)

Software ■ Microsoft Internet Explorer 7.0 SP1 or later,
or other Web browser for viewing reports.

■ Adobe Reader software 7.0 or later for
viewing portable document format (PDF)
files.

1 If TekExpress USB2 is running on an instrument that has a video resolution less than 800x600, connect and configure a second monitor to the
instrument.
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Supported instruments Table 4: Required equipment

Resource Model supported
Real-time oscilloscope Tektronix DPO/DSA/MSO70000C, D, and DX

series oscilloscopes (Windows 7 OS 64 bits)
Tektronix MSO/DPO5000 and MSO/DPO5000B
Series

Probes Two TCA-SMA cables
P7313SMA differential probe
TCP0030A/TCP202/A probe
TDP1500/TDP2500 differential probe
P7500 differential probe

Host test fixtures USB-IF fixture set (host/device SQ and drop/
droop) 2 

TDSUSBR (Tek fixture)
Device test fixtures USB-IF fixtures (host/device SQ and drop/droop) 2

TDSUSBR (Tek fixture)
Tektronix AWG instruments AWG7102, AWG7122 Series

All AWG7000, AWG5000 Series
AWG5014B, AWG5014C,AWG5012C,
AWG5002C, AWG7001A, AWG7002A

See also. Minimum system requirements

Required windows 7 user
account setting

Windows 7 instruments need to have the User Account Control Settings set to
Never Notify. To set User Account Control Settings:

1. Go to Control Panel > User Accounts > Change User Account Control
settings.

2. Set the sliding control to Never Notify as shown in the image, and click OK.

 

2 Available through USB-IF.
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See also. Supported oscilloscopes

Install the software Use the following steps to obtain the latest TekExpress USB2 software from the
Tektronix Web site and install on any compatible instrument running Microsoft
Windows 7 (64-bit). See Minimum System Requirements for details.

1. Close all applications (including the TekScope application).

2. Go to the www.tek.com Web site and locate the Downloads fields.

3. Enter tekexpress usb2 in the Model or Keyword field, select Software from
the Select Download Type list, and click GO.

4. Select the latest version of software from the search result. Follow
instructions to download the software file.

5. Copy or download the TekExpress USB2 installer executable file to the
oscilloscope.

6. Double-click the installer .exe file to extract the installation files and launch
the InstallShield Wizard. Follow the on-screen instructions.

Software is installed at C:\Program Files (x86)\Tektronix
\TekExpress\TekExpress USB2

7. Verify application installation

See also.  
Minimum system requirements

Supported instruments

Required \My TekExpress folder settings

 Getting started
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Verify application
installation

To verify the installation was successful:

1. Open the TekScope application.

2. Click the Analyze menu.

3. Verify that TekExpress USB2 is listed in the Analyze menu.

4. Click TekExpress USB2 to open the application. Verify that the application
opens successfully.

See also.  
Activate the license

Required \My TekExpress folder settings

Activate the license Activate the license using the Option Installation wizard in the TekScope
application:

1. In the TekScope application menu bar, click Utilities > Option Installation.

TheTekScope Option Installation wizard opens.

2. Push the F1 key on the oscilloscope keyboard to open the Option Installation
help topic.

3. Follow the directions in the help topic to activate the license.

See also.  
View version and license information

Required \My TekExpress folder settings

View software version Use the following instructions to view version information for the application and
for the application modules such as the Programmatic Interface and the
Programmatic Interface Client.

To view version information for TekExpress USB2, click the Options button and
select About TekExpress.

To view license and option key information in the TekScope applicaion:

1. In the TekScope application, select Help > About TekScope.

The Options dialog box is displayed.

2. Scroll through the Options list to locate USB2: TekExpress USB2.

3. To view the Option installation key value, look below the Options list.

See also.  
Activate the license

Options menu

Getting started  
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Required my TekExpress
folder settings

Before you run tests for the first time, you need to Set the \My TekExpress folder
permissions.

See also.  
Application directories and usage

File name extensions

Set the my TekExpress
folder permissions

Make sure that the My TekExpress folder has read and write access. Also verify
that the folder is not set to be encrypted:

1. Right-click the folder and select Properties.

2. Select the General tab and then click Advanced.

3. In the Advanced Attributes dialog box, make sure that the option Encrypt
contents to secure data is NOT selected.

4. Click the Security tab and verify that the correct read and write permissions
are set.

See also.  
Application directories and usage

File name extensions

 Getting started
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Application directories
and their contents

The TekExpress USB2 application files are installed at the following location:

C:\Program Files (x86)\Tektronix\TekExpress\TekExpress USB2

 

 

The following table lists the application directory names and their purpose.

Table 5: Application directories and usage

Directory names Usage
Bin Contains TekExpress USB2 application libraries
Compliance Suites Contains compliance-specific files
Examples Contains various support files
ICP Contains instrument and TekExpress USB2

application-specific interface libraries
Lib Contains utility files specific to the TekExpress

USB2 application
Report Generator Contains style sheets for report generation
Tools Contains instrument and TekExpress USB2

application-specific files
AWG Files Contains files required for Receiver Sensitivity

measurement

See also.  
View test-related files

File name extensions

Getting started  
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File name extensions The TekExpress USB2 application uses the following file name extensions:

File name extension Description
.py Python sequence file
.xml Test-specific configuration information

(encrypted) files
Application log files

.wfm Test waveform files

.mht Test result reports (default)
Test reports can also be saved in HTML format

.xslt Style sheet used to generate reports

See also.  
View test-related files

Application directories and their contents

Where test files are stored When you launch TekExpress USB2 for the first time, it creates the following
folders on the oscilloscope:

■ \My Documents\My TekExpress\USB2

■ \My Documents\My TekExpress\USB2\Untitled Session

Every time you launch TekExpress USB2, an Untitled Session folder is
created in the USB2 folder. The Untitled Session folder is automatically
deleted when you exit the application. To preserve your test session files, save
the test setup before exiting the application.

CAUTION. Do not modify any of the session files or folders because this may
result in loss of data or corrupted session files. Each session has multiple files
associated with it. When you save a session, the application creates a .TekX file,
and a folder named for the session that contains associated files, on the
oscilloscope X: drive.

See also.  
Set the \My TekExpress folder permissions

Application directories and usage

File name extensions

 Getting started
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Operating basics

Run the application
To start the TekExpress USB2 application, select Analyze > TekExpress USB2
from the TekScope menu.

The oscilloscope opens the TekExpress USB2 application:
 

 

When you first run the application after installation, the application checks for
Resources.xml located in the C:\Users\<username>\My TekExpress
\USB2 folder. The Resources.xml file gets mapped to the X: drive when the
application launches. Session files are then stored inside the X:\USB2 folder. The
Resources.xml file contains information about available network-connected
instruments. If this file is not found, the application runs an instrument discovery
program to detect connected instruments before launching TekExpress USB2.

NOTE. Do the steps in the Required\My TekExpress folder settings topic before
running tests with the TekExpress USB2 application for the first time.
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To keep the TekExpress USB2 application window on top, select Keep On Top
from the Options menu. If the application goes behind the oscilloscope
application, click Analyze > TekExpress USB2 to move the application to be in
front.

See also  

Required My TekExpress folder settings

Activate the license

Exit the application

Application controls

Application panel overview

Exit the application

To exit the application, click    on the application title bar. Follow on-screen
prompts to save any unsaved session, save test setup files, or exit the application.

NOTE. Using other methods to exit the application can result in abnormal
termination of the application.

Operating basics  
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Application controls

Table 6: Application controls descriptions

Item Description
Options menu
 

 

Menu to display global application controls.

Test Panel buttons
 

 

Controls that open panels for configuring test
settings and options.

Start / Stop button
 

 
 

 

Use the Start button to start the test run of the
measurements in the selected order. If prior
acquired measurements have not been cleared,
the new measurements are added to the
existing set.
The button toggles to the Stop mode while tests
are running. Use the Stop button to abort the
test.

 Operating basics
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Item Description
Pause / Continue button
 

 
 

 

Use the Pause button to temporarily interrupt
the current acquisition. When a test is paused,
the button name changes to “Continue.”

Clear button
 

 

Use the Clear button to clear all existing
measurement results. Adding or deleting a
measurement, or changing a configuration
parameter of an existing measurement, also
clears measurements. This is to prevent the
accumulation of measurement statistics or sets
of statistics that are not coherent. This button is
available only on the Results panel.

Application window move icon
 

 

Place the cursor over the three-dot pattern in the
upper left corner of the application window.
When the cursor changes to a hand, drag the
window to the desired location.

See also Application panel overview

Operating basics  
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Options menu

Options menu overview The Options menu is located in the upper right corner of the application.

The Options menu has the following selections:

Menu Function
Default Test Setup Opens an untitled test setup with defaults

selected
Open Test Setup Opens a saved test setup
Save Test Setup Saves the current test setup selections
Save Test Setup As Creates a new test setup based on an existing

one
Open Recent Displays a menu of recently opened test setups

to select from
Instrument Control Settings Detects, lists, and refreshes the connected

instruments found on specified connections
(LAN, GPIB, USB, and so on)

Keep On Top Keeps the TekExpress USB2 application on top
of other open windows on the desktop

Email Settings Use to configure email options for test run and
results notifications

Help Displays the TekExpress USB2 help
About TekExpress ■ Displays application details such as

software name, version number, and
copyright

■ Provides access to License information for
your TekExpress USB2 installation

■ Provides a link to the Tektronix Web site

Options menu

 Operating basics

TekExpress® USB2 Printable Application Help 17



See also. Application controls

Instrument control
settings

Use the TekExpress Instrument Control Settings dialog box to search for and
list the connected resources (instruments) detected on selected connections
(LAN, GPIB, USB), and each instruments connection information.

To access, click Options > Instrument Control Settings.
 

 

Use the Instrument Control Settings feature to search for connected instruments
and view instrument connection details. You can select listed connected
instruments for use in the Global Settings tab in the test Configuration pane.

See also. Options menu overview

View connected
instruments

Use the Instrument Control Settings dialog box to view or search for connected
instruments required for the tests. The application uses TekVISA to discover the
connected instruments on all selected connection types.

NOTE. The correct instruments for the current test setup must be connected and
recognized by the application before running tests.

To refresh the list of connected instruments:

1. From the Options menu, select Instrument Control Settings.

2. In the Search Criteria section of the Instrument Control Settings dialog
box, select the connection types of the instruments for which to search.

Operating basics  

18 TekExpress® USB2 Printable Application Help



Instrument search is based on the VISA layer, but different connections
determine the resource type, such as LAN, GPIB, and USB. For example, if
you choose LAN, the search will include all the instruments supported by
TekExpress that are communicating over the LAN.

3. Click Refresh. TekExpress searches for connected instruments.

4. After searching, the dialog box lists the instrument-related details based on
the search criteria you selected. For example, if you selected LAN and GPIB
as the search criteria, the application checks for the availability of
instruments over LAN, then GPIB, and then lists detected instruments on
those connection types.

The Retrieved Instruments table lists instrument details. The time and date of
the last time this table was updated is displayed in the Last Updated field.

See also. Equipment connection setup

 Operating basics
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Email settings Use the Email Settings utility to configure email notifications to receive an email
message when a test completes, produces an error, or fails. Select the type of test
session information to include in the email, such as test reports and test logs, the
email message format, and the email message size limit.

Select Options > Email Settings to open this dialog box.

NOTE. Recipient email address, sender’s address, and SMTP Server are
mandatory fields.

 

 

See also.  
Configure email settings

Options menu

Select test notification preferences

Configure email settings Use the Email Settings dialog box to be notified by email when a test completes,
fails, or produces an error:

1. Select Options > Email Settings to open the Email Settings dialog box.

2. (Required) For Recipient email Address(es), enter one or more email
addresses to which the test notification has to be sent. To include multiple
addresses, separate the addresses with commas.

3. (Required) For Sender’s Address, enter the email address used by the
instrument. This address consists of the instrument name followed by an
underscore followed by the instrument serial number, then the @ symbol and
the email server used. For example:
DPO72016C_B130099@yourcompany.com.

Operating basics  

20 TekExpress® USB2 Printable Application Help



4. (Required) In the Server Configuration section, type the SMTP Server
address of the Mail server configured at the client location, and the SMTP
Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name,
password, and host name in the corresponding fields.

NOTE. If any of the above required fields are left blank, the settings will not
be saved and email notifications will not be sent.

5. In the Email Attachments section, select from the following options:

■ Reports: Select to receive the test report with the notification email.

■ Status Log: Select to receive the test status log with the notification
email. If you select this option, select whether you want to receive the
full log or just the last 20 lines.

6. In the Email Configuration section:

■ Email Format: Select the message file format to send: HTML (the
default) or plain text.

■ Max Email Size (MB): Enter a maximum file size for the email
message. Messages with attachments larger than this limit will not be
sent. The default is 5 MB.

■ Number of Attempts to Send: Enter the number to limit the number of
attempts that the system makes to send a notification. The default is 1.
You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use
this check box to quickly enable or disable email notifications.

8. To test your email settings, click Test Email.

9. To apply your settings, click Apply.

10. Click Close when finished.

Email settings

 Operating basics
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Application Panels

Application panels overview
TekExpress USB2 uses panels to group related configuration, test, and results
settings. Click a button to open the associated panel. A panel may have one or
more tabs that list the selections available in that panel. Controls in a panel can
change depending on settings made in that panel or another panel.
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Table 7: Application panels overview

Panel Name Purpose
Setup The Setup panel shows the test setup controls.

Click the Setup button to open this panel.
Use this panel to:

■ Select DUT parameters.

■ Select the test(s).

■ Set acquisition parameters for selected
tests.

■ Select test notification preferences.

Status View the progress and analysis status of the
selected tests, and view test logs.

Results View a summary of test results and select result
viewing preferences.

Reports Browse for reports, save reports as specific file
types, specify report naming conventions, select
report content to include (such as summary
information, detailed information, user
comments, setup configuration, application
configuration), and select report viewing options.

Plots View a summary of plot generated during run.

See also Application controls

Application Panels  
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Setup tab

Setup controls overview The Setup panel contains sequentially ordered tabs that guide you through a
typical test setup and execution process. Click a tab to open the associated panel
and controls.
 

 

The tabs on this panel are:

DUT: Set the DUT parameters

Test Selection: Select test(s)

Acquisitions: Select acquisition parameters

Preferences: Select test fail notification preferences

 Application Panels
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Set DUT parameters Use the DUT tab to select parameters for the device under test. The settings are
global and apply to all tests for the current session. DUT settings also affect the
list of available tests in the Test Selection tab.

 

 

Click Setup > DUT to access the DUT parameters:

Table 8: DUT tab settings

Setting Description
DUT ID Adds an optional text label for the DUT to

reports. The default value is DUT001. The
maximum number of characters is 32.
You cannot use the following characters in an ID
name: (.,..,...,\,/:?”<>|*)

   Comments icon (to the right of the DUT
ID field)

Opens a Comments dialog box in which to enter
optional text to add to a report. Maximum
number of characters is 256. To enable or
disable comments appearing on the test report,
see Select report options.)

Acquire live waveforms Acquire active signals from the DUT for
measurement and analysis.

Use prerecorded waveform files Run tests on a saved waveform. Open (load) a
saved test setup

Select DUT Sets the DUT device type to test (Device, Host
or Hub).
Selecting the DUT device type preloads other
fileds on the DUT panel.

Application Panels  
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Setting Description
Test Mode ■ Compliance: Preselects tests and

parameters needed to meet compliance
specifications for the selected device type.
Disables the compliance filter controls.

■ User Defined: Enables the user to select
specific tests and set custom parameters
for tests (using the Configuration button).

Version Lists the supported USB2 generations.
Device Profile
Low Speed, Full Speed and High Speed Sets the available test parameters for the Device

Profile area. Device Profile parameter availability
depends on the Test Mode setting.
The default test mode setting is High Speed.

Test Method Sets the algorithms used to measure and
analyze the signal.

■ USBET: Select to perform measurements
implemented in USBET.

■ Tektronix: Select to perform measurements
implemented by Tektronix.

Test point Sets the Near End or Far End test point location.

■ Near End: Select if you connect the device
with a captive cable.

■ Far End: Select if you connect the device
with other than captive cable.

Signal Direction Sets the Up or Down stream data signal
direction.

■ Up Stream: Direction of data is towards the
host.

■ Down Stream: Direction of data is away
from the host.

Tier Sets the Tier based on the position in the hub
where the device is connected.

Power Condition Sets the energy source as Self Powered or Bus
Powered.

■ Self Powered: Select if the power is drawn
from an external energy source.

■ Bus Powered: Select if the power is drawn
from the USB port.

Port Enter the number of port used to connect to the
host.

 Application Panels
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See also. Select a test

Select tests Use the Test Selection tab to select USB2 tests. Listed tests depend on settings in
the DUT panel.
 

 

Table 9: Test Selection tab settings

Setting Description
Deselect All, Select All buttons Deselect or select all tests in the list.
Tests Click a test to select or deselect. Selecting a test

also shows details about that test in the Test
Description pane.
The application automatically selects all required
tests when in Compliance mode.

Schematic button Shows an equipment and test fixture setup
schematic (connection diagram) for the selected
test. Use to set up the equipment and fixtures or
to verify the setup before running the test.

NOTE. All tests are selected by default.

See also. Set acquisition parameters
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Set acquisition parameters Select the Acquisition tab in the Setup panel to view test acquisition parameters.
You can also use this tab to load pre-recorded (saved) test session waveform files
on which you can run tests.

Contents displayed on this tab depend on the DUT type and selected tests.
 

 

NOTE. TekExpress USB2 acquires all waveforms required by each test group and
generation being tested before performing analysis.
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Table 10: Acquisitions tab settings

Setting Description
Differential Configuration Lists the signal type and input channel assigned

to that type.
 

 
Single Ended Configuration Click in a Source fields to assign a channel

source to a signal type.
 

 
Qualifier Acquires the signals from the reference device.

Select the appropriate channel.
Probe Type Sets the probe type based on the

measurements.
View Probes button Shows the detected probe configurations, and

enable or disable probe signal source access in
the application. Only available for live
waveforms.

TekExpress USB2 saves all acquisition waveforms to files by default.
Waveforms are saved to a folder that is unique to each session (a session starts
when you click the Start button). The folder path is X:\TekExpress
USB2\Untitled Session\<dutid>\<date>_<time>. Images created for
each analysis, test session reports, and other information specific to that session
are also saved in this folder.

When the session is saved, content is moved to that session folder and the
“Untitled Session” name is replaced by the session name.

See also. Running tests on prerecorded saved waveforms
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Running tests on
prerecorded (saved)

waveforms

To load a saved waveform file on which to run tests:

1. Click DUT.

2. Click Use pre-recorded waveform files.

3. Click Acquisitions. The Waveform Filename column now shows browse
buttons.
 

 

4. Click the browse button ( ) for each test acquisition type (For example,
LSSQ, FSSQ, HSSQ).

The Select a Waveform file dialog box appears.

5. Select the required waveform file(s). You must select all waveforms required
for the acquisition type.

6. To change, remove, or add a file to the list, click the browse button next to
the file name to change, and use the menu items to replace, remove (delete)
or add a file in the list.

7. Click Start.

Configuration tab
parameters

Use the Configuration tab to set and view global instrument parameters for the
selected tests. Available fields for editing depend on the selected test mode
(Compliance or User Defined) as set in this tab or the DUT tab.

NOTE. You cannot change test parameters that are grayed out.
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See also. Configuration tab: Global settings parameters

Configuration tab: global
settings and measurement

parameters

The following table lists the Configuration tab settings and measurement
parameters. Fields shown on this tab can change depending on selected items.
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Table 11: Configuration tab Global and Measurement Settings

Control Description
Test Mode Determines whether test parameters are in

compliance or are able to be edited.

■ Compliance: Most test parameter values
cannot be edited. Select this for compliance
mode testing.

■ User Defined: Enables editing of
measurement configuration.

Limits Editor button Opens the Limits Editor dialog box.
In User Defined Mode, use the Limits Editor to
edit individual test limit settings.

In Compliance Mode, use the Limits Editor to
view the measurement high and low limits used
for selected tests. You cannot edit values while
in Compliance mode.

Global Settings Tab Displays a list of the connected instruments.
Instruments Detected Displays a list of the connected instruments

found during the instrument discovery.
Instrument types include equipment such as
oscilloscopes and signal sources (AWG). Select
Options > Instrument Control Settings to 
refresh the connected instrument list.

DUT Control Display options for controlling DUT test mode.
Manual: Select this option to control DUT test mode

manually.
Automated: Select this option to let TekExpress USB2

control the DUT test mode.
Controller PC IP: Enter the IP address of
Controller PC or Laptop.

Scope Bandwidth Sets the oscilloscope bandwidth to use for Low
Speed, Full Speed and High Speed tests.
Select the bandwidth from the drop-down menu.
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Control Description
Measurements Setting Tab Displays a list of selected measurements and

tests.
Acquire/Analyze Tab Sets additional parameters for specified

measurements.
For example, if you select Eye Diagram
measurement under High Speed Signal Quality,
the Acquire and Analyze tabs are populated with
additional parameters to set.
Probe Type: Select the appropriate probe.
Custom Eye Mask: Browse to select a mask file.

See also.  
About acquisitions

Preferences tab Use the Preferences tab to set the application action when a test measurement
fails.
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Table 12: Preferences tab settings

Setting Description
On Test Failure, stop and notify me of the failure Stops the test and sends an email when a test

fails.
Click Email Settings button and verify that
“Email Test Results when complete or on error”
is selected, and to verify the address to which
the email is sent.

Always display weiver mask for High Speed
near end and Low Speed eye diagrams

Sets the application to add the weiver mask for
High Speed near end and Low Speed eye
diagrams to the reports.

Status panel overview
The Status button accesses the Test Status and Log View tabs, which provide
status on test acquisition and analysis (Test Status tab) and a listing of test tasks
performed (Log View tab). The application opens the Test Status tab when you
start a test run. You can select the Test Status or the Log View tab to view these
items while tests are running. 

Test status view
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Log view

Table 13: Status panel : Log View pane settings

Control Description
Message History Window that lists all executed test operations

and timestamp information.
Auto Scroll Enables automatic scrolling of the log view as

information is added to the log during the test.
Clear Log Clears all messages from the log view.
Save Saves the log file to a text file. Use the standard

Save File window to navigate to and specify the
folder and file name to which to save the log
text.

See also Application panel overview
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Results panel

Results panel overview When a test finishes, the application automatically opens the Results panel to
display a summary of test results.
 

 

The Overall Test Result is displayed at the top left of the Results table. If all of
the tests for the session pass, the overall test result is Pass. If one or more tests
fail, the overall test result is Fail.

Set viewing preferences for this panel from the Preferences menu in the upper
right corner. Viewing preferences include showing whether a test passed or
failed, summary or detailed results, and enabling wordwrap.

Each test result occupies a row in the Results table. By default, results are
displayed in summary format with the measurement details collapsed and with
the Pass/Fail column visible. Change the view in the following ways:

■ To expand and collapse tests to show more or less detail, click the plus and
minus buttons in the table.

■ To expand the width of a column, place the cursor over the vertical line that
separates the column from the column to the right. When the cursor changes
to a double-ended arrow, hold down the mouse button and drag the column to
the desired width.

■ To clear all test results displayed, click Clear.

■ Use the Preferences menu to change how some items display in the Results
panel.

See also.  
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View a report

Application panels overview

Preferences menu The Preferences menu is part of the Results panel display. Use the Preferences
menu to change how some items display in the Results panel.

■ To stop the test and send an email when test fails, select Preferences > On
Test Failure, stop and notify me of the failure.

■ To display the weiver mask for High Speed near end and Low Speed eye
diagrams in the reports, select Preferences > Always display weiver mask
for High Speed near end and Low Speed eye diagrams.

See also. Results panel overview

View test-related files Files related to tests are stored in the My TekExpress\USB2 folder. Each test
setup in this folder has a test setup file and a test setup folder, both with the test
setup name.

The test setup file is preceded by the TekExpress icon and usually has no visible
file name extension.

Inside the test setup folder is another folder named for the DUT ID used in the
test sessions. The default is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has
a folder and file pair, both named for the test session using the naming
convention (date)_(time). Each session file is stored outside its matching session
folder:
 

 

Each session folder contains image files of any plots generated from running the
test session. If you selected to save all waveforms or ran tests using prerecorded
waveform files, these are included here.
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The first time you run a new, unsaved session, the session files are stored in the
Untitled Session folder located at ..\My TekExpress\TekExpress
USB2. When you name and save the session, the files are placed in a folder with
the name that you specify. A copy of the test files stay in the Untitled Session
folder until you run a new test or until you close the application.

See also. '
File name extensions

Required \My TekExpress folder settings

Plots panel
The Plots panel displays a summary of plot generated during run.

Depending on DUT speed and selected measurement(s), application will generate
one/two plot(s) for each speed. These two plots are waveform plot and eye
diagram plot.

These plots have zoom, cursors, save, and dock/undock features.
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See also Application panel overview

Reports panel

Reports panel overview Use the Reports panel to view saved reports, name and save reports from the
current session, select test content to include in reports, and select report viewing
options.
 

 

For information on setting up reports, see Select report options. For information
on viewing reports, see View a Report.

See also. About panels
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Select report options Click the Reports button and use the Reports panel controls to select which test
result information will be included in the report, and the naming conventions to
use for the report.

Select report options before running a test or when creating and saving test
setups. Report settings are included in saved test setups.

In the Reports panel, select from the following report options:

Table 14: Report options

Setting Description
Report Generation
Generate new report Creates a new report.
Append to previous run session Appends the latest test results to the end of the

current session’s test results report.
Replace current test in previous run session Replaces the previous test results with the latest

test results. Results from newly added tests are
appended to the end of the report.

Report name Displays the name and location from which to
open a report. The default location is at \My
TekExpress\USB2\Untitled Session. The report
file in this folder gets overwritten each time you
run a test unless you specify a unique name or
select to auto increment the report name.
Change the report name or location.

Do one of the following:

■ In the Report Path field, enter a new folder
path and name.

■ Double-click in the Report Path field and
then make selections from the popup
keyboard and click the Enter button.

Be sure to include the entire folder path, the file
name, and the file extension. For example: C:
\Documents and Settings\your user name\My
Documents\My TekExpress\USB
\DUT001_Test_72.7.1.3.mht.

NOTE. You cannot set the file location using the
Browse button.

Open an existing report.
Click Browse, locate and select the report file
and then click View at the bottom of the panel.

Save as type Saves a report in the selected output format
(Web archive or PDF).
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Setting Description
Auto increment report name if duplicate Sets the application to automatically increment

the name of the report file if the application finds
a file with the same name as the one being
generated. For example: DUT001, DUT002,
DUT003. This option is enabled by default.

Contents To Save
Include pass/fail info in details table Select to include the column labeled Test Result

(indicating whether the test passed or failed) in
the report. For details, see Report Contents in 
View a report.

Include detailed results Select to include detailed results of a test
Include plot images Select to include plotted diagrams such as Eye

diagram.
Include setup configuration Select to include hardware and software

information in the summary box at the top of the
report. Information includes: the oscilloscope
model and serial number, probe model and
serial number, the oscilloscope firmware
version, SPC and factory calibration status, and
software versions for applications used in the
measurements.

Include user comments Select to include any comments about the test
that you or another user added in the DUT tab of
the Setup panel. Comments appear in the
Comments section, under the summary box at
the beginning of each report.

View Report After Generating Select to automatically open the report in a Web
browser when the test completes. This option is
selected by default.

View button Click to view the most current report.
Generate Report Generates a new report based on the current

(most-recent) analysis results.
Save As Specify a name for the report.
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View a report The application automatically generates a report when test analysis is completed
and displays the report in your default Web browser (unless you cleared the View
Report After Generating check box in the Reports panel before running the
test). If you cleared this check box, or to view a different test report, do the
following: 

1. Click the Reports button.

2. Click the Browse button and locate and select the report file to view.

3. In the Reports panel, click View.

For information on changing the file type, file name, and other report options, see 
Select report options.

Report contents A report shows specified test details, such as detailed results and plots, as set in
the Reports panel.

Setup configuration information

Setup configuration information is listed in the summary box at the beginning of
the report. This information includes the oscilloscope model and serial number,
and software versions. To exclude this information from a report, clear the
Include Setup Configuration check box in the Reports panel before running the
test.

User comments

If you include comments in the test report, any comments you added in the DUT
tab are shown at the top of the report.

Test result summary
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The Test Result column indicates whether a test passed or failed. If the test
passed, the cell text is green. If the test failed, the text is red. To exclude this
information from a report, clear the Include Pass/Fail Results Summary check
box in the Reports panel before running the test.

See also.  
Results panel overview

View test-related files
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Running tests

Test process flow
Allow test instrument to warm up for 20 minutes before running tests and use the
following list to set up and perform USB2 tests.

1. Set up test equipment.

2. Verify that required instruments are connected to USB2 fixtures.

3. Set DUT parameters.

4. Select tests.

5. View acquisition settings.

6. Set global signal-related parameters.

7. Select test notification preferences.

8. Select report options.

9. Check the prerun checklist.

10. Click Start to Run tests.

See also About test setups

About running tests

Instrument and DUT connection setup
Click the Setup > Test Selection > Schematic button to open a PDF file that
shows the compliance test setup diagrams (instrument, DUT, and cabling) for
supported testing configurations. 

See also Minimum system requirements

View connected instruments
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Running tests
After selecting and configuring tests, review the prerun checklist and then click
Start to run the tests. While tests are running, you cannot access the Setup or
Reports panels. To monitor the test progress, switch back and forth between the
Status panel and the Results panel.

The application displays a report when the tests are complete. While the tests are
running, other applications may display windows in the background. The
TekScope application takes precedence over other applications, but you can
switch to other applications by using the Alt + Tab key combination. To keep the
TekExpress USB2 application on top, select Keep On Top from the Options
menu.

See also Configuration tab parameters

Prerun checklist
Make sure that all the required instruments are properly warmed up for
20 minutes before running tests and do the following before you click the Start
button to run a test:

NOTE. If this is the first time you are running a test on the application, make sure
that you have done the steps in Required\My TekExpress folder settings before
continuing.

1. Perform Signal Path Compensation (SPC)

a. On the oscilloscope main menu, select the Utilities menu.

b. Select Instrument Calibration.

c. Follow the on-screen instructions.

2. Verify that the correct instruments are connected (oscilloscope and signal
sources):

a. In TekExpress USB2, click Setup > Configuration.

b. Click Global Settings.

c. In the Instrument Detected list, verify that the test setup instruments are
shown. If they are not, click the arrow button to list and select from all
detected instruments. If the required instrument is still not listed, use the
TekExpress Instrument Control Settings dialog box to scan for and
detect instruments (see View connected instruments).

See also Instrument and DUT connection setup
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Saving and recalling test setup files

Test setup files overview
Saved test setup information (such as the selected oscilloscope, general
parameters, acquisition parameters, measurement limits, waveforms (if
applicable), and other configuration settings) are all saved under the setup name
at X:\USB2.

Use test setups to:
■ Run a new session, acquiring live waveforms, using a saved test

configuration.
■ Create a new test setup based on an existing one.
■ View all the information associated with a saved test, including the log file,

the history of the test status as it executed, and the results summary.
■ Run a saved test using saved waveforms.

See also Save a test setup

Recall a saved test setup

Save a test setup file
Save a test setup before or after running a test to save the test settings. Create a
new test setup from any open setup or from the default setup. When you select
the default test setup, all parameters are returned to the application’s default
values.

To immediately save the current setup session to the same setup name, select
Options > Save Test Setup.

To immediately save the current setup session to a new setup name, select
Options > Save Test Setup As.

To create and save a new setup from the default test setup:

1. Select Options > Default Test Setup to return the application to default test
settings.

2. Click the application Setup button and use the setup tabs to set required
options and parameters (DUT, Test Selection).

3. Click the application Reports button and set report options.
4. Optional: Click Start to run the test and verify that it runs correctly and

captures the specified test information and reports. If it does not, edit the
parameters and repeat this step until the test runs to your satisfaction.
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Running the test helps verify that all parameters are set correctly, but it is not
a necessary step.

5. Select Options > Save Test Setup. Enter the file name for the new setup file.
The application saves the file to X:\USB2\<session_name>.

See also Test process flow

View test-related files

Configuration tab parameters

Open (load) a saved test setup file
These instructions are for recalling saved test setups.

1. Select Options > Open Test Setup.

2. Select the setup from the list and click Open. Setup files must be located at
X:\USB2.

See also About test setups

Create a new test setup based on an existing one

Test setups overview

Run a saved test in prerecorded mode
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Run a saved test in prerecorded mode
Use this option to rerun a complete test using just the oscilloscope and the saved
test setup files including the captured waveforms from the saved test. 

NOTE. When you run a saved test in prerecorded mode and then save it under the
same name, the test results are saved in a new session folder named for the date
and time of the session. Any test settings that you changed for the session are
saved as a new test session file and are paired with a folder of the same name.
For example, when you open a test setup that has multiple sessions and you
select a session from the Run session list in the DUT tab, the settings associated
with that test session are restored.

Each test session folder has a matching test session file that stores the individual
test settings for that session.

1. Use the Options menu to Open a saved test setup file

2. Select Setup > DUT and then select Use pre-recorded waveform files. A
Run session drop-down list appears that displays the previous saved sessions
for this test.

3. Select the session to run.

NOTE. If you select a session for which no waveform files were saved, you
will receive an error message. Either select another test session or select
waveform files to use.

4. Click Start.

5. To save the test results, session settings, and related files, save the test setup
before selecting another test setup or exiting the application.

See also About test setups

Create a new test setup based on an existing one

Test setups overview
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Create a new test setup file based on an existing one
Use this method to create a variation on a test setup without having to create the
setup from the beginning.

1. Select Options > Open Test Setup.

The File Open dialog box appears.

2. Select a setup from the list and then click Open.

3. Use the Setup and Reports panels to modify the parameters to meet your
testing requirements.

4. Select Options > Save Test Setup As.

5. Enter a test setup name and click Save.

See also About test setups

Set DUT parameters

Select acquisitions
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TekExpress USB2 programmatic interface

About the programmatic interface
The Programmatic interface seamlessly integrates the TekExpress USB2
application with the high-level automation layer. This also lets you control the
state of the TekExpress USB2 application running on a local or a remote
computer.
 

 

The following terminology is used in this section to simplify description text:

■ TekExpress USB2 Client: A high-level automation application that
communicates with TekExpress USB2 using TekExpress USB2
Programmatic Interface.

■ TekExpress USB2 Server: The TekExpress USB2 application when being
controlled by TekExpress USB2 Client.

TekExpress USB2 leverages .Net Marshalling to enable the Programmatic
Interface for TekExpress USB2 Client. TekExpress USB2 provides a client
library for TekExpress USB2 clients to use the programmatic interface. The
TekExpress USB2 client library is inherited from .Net MarshalByRef class to
provide the proxy object for the clients. The TekExpress USB2 client library
maintains a reference to the TekExpress USB2 Server and this reference allows
the client to control the server state.
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See also Requirements for Developing TekExpress Client

To enable remote access
To access and remotely control an instrument using the TekExpress USB2
programmatic interface, you need to change specific firewall settings as follows:

1. Access the Windows Control Panel and open the Windows Firewall tool
(Start > Control Panel > All Control Panel Items > Windows Firewall).

2. Click Advance Settings > Inbound Rules.

3. Scroll through the Inbound Rules list to see if the following items (or with a
similar name) are shown:

■ TekExpress USB2

■ TekExpress
 

 

4. If both items are shown, you do not need to set up any rules. Exit the
Windows Firewall tool.

5. If one or both are missing, use the following procedure to run the New
Inbound Rule Wizard and add these executables to the rules to enable
remote access to the TekExpress USB2 application.

6. On the client side, include controller.exe through which TekExpress USB2
application is remotely controlled. For example, if the application is
controlled using python scripts the"ipy64.exe" should be included as part
of Inbound rules.
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Run the New Inbound Rule
Wizard

1. Click New Rule (in Actions column) to start the New Inbound Rule
Wizard.
 

 
2. Verify that Program is selected in the Rule Type panel and click Next.
3. Click Browse in the Program panel and navigate to and select one of the

following TekExpress USB2 applications (depending on the one for which
you need to create a rule):

■ TekExpress USB2.exe

■ TekExpress.exe

NOTE. See Application directories and contentfor the path to the application
files.

4. Click Next.
5. Verify that Allow the connection is selected in the Action panel and click

Next.
6. Verify that all fields are selected (Domain, Private, and Public) in the

Profile panel and click Next.
7. Use the fields in the Name panel to enter a name and optional description for

the rule. For example, a name for the TekExpress USB2 application could be
TekExpress USB2 Application. Add description text to further identify the
rule.

8. Click Finish to return to the main Windows Firewall screen.
9. Scroll through the Inbound Rules list and verify that the list shows the rule

that you just entered.
 

 
10. Repeat steps 1 through 11 to enter the other TekExpress USB2 executable if

it is missing from the list. Enter TekExpress USB2 PI as the name.
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11. Scroll through the Inbound Rules list and verify that the list shows the rule
that you just entered.

12. Exit the Windows Firewall tool.

To use the remote access: 1. Obtain the IP address of the instrument on which you are running
TekExpress USB2.

2. On the PC from which you are accessing the remote instrument, use the
instrument IP address as part of the TekExpress USB2 PI code to access that
instrument. For example:

object obj = piClient.Connect(“134.64.235.198”,out
clientid);

Requirements for developing TekExpress USB2 client
While developing a TekExpress USB2 Client, use the TekExpressClient.dll. The
client can be a VB .Net, C# .Net, Python, or Web application. Examples for
interfaces in each of these applications are in the Samples folder.

References required ■ TekExpressClient.dll has an internal reference to IIdlglib.dll and
IRemoteInterface.dll.

■ IIdlglib.dll has a reference to TekDotNetLib.dll.

■ IRemoteInterface.dll provides the interfaces required to perform the
remote automations. It is an interface that forms the communication line
between the server and the client.

■ IIdlglib.dll provides the methods to generate and direct the secondary
dialog messages at the client-end.

NOTE. The end-user client application does not need to reference to these DLL
files. It is essential to have these DLLs (IRemoteInterface.dll, IIdlglib.dll and
TekDotNetLib.dll) in the same folder as that of TekExpressClient.dll.
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Required steps for a client The client uses the following steps to use TekExpressClient.dll to
programmatically control the server:

Develop a client UI to access the interfaces exposed through the server. This
client loads TekExpressClient.dll to access the interfaces. After
TekExpressClient.dll is loaded, the client UI can call the specific functions
to run the operations requested by the client. When the client is up and running, it
does the following to run a remote operation:

1. To connect to the server, the client provides the IP address of the PC where
the server is running.

2. The client locks the server application to avoid conflict with any other Client
that may try to control the server simultaneously. “Lock” would also disable
all user controls on the server so that server state cannot be changed by
manual operation.

If any other client tries to access a server that is locked, it will receive a
notification that the server is locked by another client.

3. When the client has connected to and locked the server, the client can access
any of the programmatic controls needed to run the remote automations.

4. After the client operations finish, the client unlocks the server.

Remote proxy object
The server exposes a remote object to let the remote client access and perform the
server-side operations remotely. The proxy object is instantiated and exposed at
the server-end through marshalling.

 

 

The following is an example:

RemotingConfiguration.RegisterWellKnownServiceType (typeof

(TekExpressRemoteInterface), “TekExpress Remote interface”,

WellKnownObjectMode.Singleton);

This object lets the remote client access the interfaces exposed at the server side.
The client gets the reference to this object when the client gets connected to the
server.

For example,
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//Get a reference to the remote object

remoteObject =

(IRemoteInterface)Activator.GetObject(typeof(IRemoteInterfac

e), URL.ToString());

Client proxy object
The client exposes a proxy object to receive certain information.
 

 

For example,

//Register the client proxy object

WellKnownServiceTypeEntry[] e =

RemotingConfiguration.GetRegisteredWellKnownServiceTypes();

clientInterface = new ClientInterface();

RemotingConfiguration.RegisterWellKnownServiceType(typeof(Cl

ientInterface), “Remote Client Interface”,

WellKnownObjectMode.Singleton);

//Expose the client proxy object through marshalling

RemotingServices.Marshal(clientInterface, "Remote Client

Inteface");

The client proxy object is used for the following:

■ To get the secondary dialog messages from the server.

■ To get the file transfer commands from the server while transferring the
report.

Examples

clientObject.clientIntf.DisplayDialog(caption, msg,iconType,

btnType);
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clientObject.clientIntf.TransferBytes(buffer, read,

fileLength);

For more information, click the following links:

Secondary Dialog Message Handling

The secondary dialog messages from the Secondary Dialog library are redirected
to the client-end when a client is performing the automations at the remote end.

In the secondary dialog library, the assembly that is calling for the dialog box to
be displayed is checked and if a remote connection is detected, the messages are
directed to the remote end.

File Transfer Events

When the client requests the transfer of the report, the server reads the report and
transfers the file by calling the file transfer methods at the client-end.
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Client programmatic interface example
An example of the client programmatic interface is described and shown as
follows:

Process flowchart 

1. Connect to a server or remote object using the programmatic interface
provided.

2. Get the client ID that is created when connecting to the remote object. This
client ID is one of the required parameters to communicate with the server.

NOTE. The server identifies the client with this ID only and rejects any
request if the ID is invalid.
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3. Lock the server for further operations. This disables the application interface.

NOTE. You can get values from the server or set values from the server to the
client only if the application is locked.

4. Register for receiving notifications on status change events on the server. To
register you need to give a handler as a parameter.

NOTE. Whenever there is a change in the status of the server, all the clients
registered with the server receive a notification from the server.

5. Select the tests that you want to run through the programmatic interface.

6. Set the necessary parameters for each test.

7. Run the tests.

8. Poll for the status of the application.

NOTE. Skip step 8 if you are registered for the status change notification and
the status is Ready.

9. After completing the tests, get the results.

10. Create a report or display the results and verify or process the results.

11. Unlock the server after you complete all the tasks.

12. Disconnect from the remote object.

Handler of status change
notification

1. Get the status. If the status is Wait or Error, get the information that contains
the title, message description, and the expected responses for the status.

2. Perform the actions based on the status information.
3. Set the response as expected.

See also Program remote access code example
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Program remote access code example
This code example shows how to communicate between a remote PC and
TekExpress USB2.

Table 15: Remote access code example

Task Code
Start the application
Connect through an IP address. m_Client.Connect("localhost")

'True or False
clientID = m_Client.getClientID

Lock the server m_Client.LockServer(clientID)

Disable the Popups m_Client.SetVerboseMode(clientID

, false)

Set the DUT ID m_Client.SetDutId(clientID,

"DUT_Name")

Run with set configurations m_Client.Run(clientID)

Wait for the test to complete. Do

Thread.Sleep(500)

m_Client.Application_Status(clie

ntID)

Select Case status

Case "Wait"

Get the current state information mClient.GetCurrentStateInfo(clie

ntID, WaitingMsbBxCaption,

WaitingMsbBxMessage,

WaitingMsbBxButtontexts)

Send the response mClient.SendResponse(clientID,

WaitingMsbBxCaption,

WaitingMsbBxMessage,

WaitingMsbBxResponse)

End Select

Loop Until status = "Ready"

Save results 'Save all results values from folder for current
run
m_Client.TransferResult(clientID

, logDirname)

Unlock the server m_Client.UnlockServer(clientID)

Disconnect from server m_Client.Disconnect()

Exit the application
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Command list

Application status() ApplicationStatus(clientId). This method gets the status (ready, running, paused)
of the server application.

Parameters.

Name Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function.
clientId example

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."

Return value. String value that gives the status of the server application.

Example. m_Client = new Client() //m_Client is a reference to
the Client class in the Client DLL.

returnval as string

returnval=m_Client.ApplicationStatus(clientID)

Comments. The application is in the Running, Paused, Wait, or Error state at any
given time.

Related command(s).  
Get Current State Info

Query status

Send response

Status
in string clientId example
clientId = <client_id_number>-<client_IP_address>.

For example, 1065–192.157.98.70 
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Check session saved() CheckSavedSession(clientID, savedStatus). This command checks whether the
current session is saved.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function.

savedStatus boolean OUT Boolean representing
whether the current
session is saved

Return value. Return value is either True or False.

Example. m_Client = new Client() //m_Client is a reference to the Client class in
the Client DLL.

returnval as string

returnval=m_Client.CheckSessionSaved(m_clientID, out savedStatus)

Related command(s).  
Recall session

Save session

Save session as

Connect() Connect(hostIPAddress,clientInterface,clientID). This command connects the client
to the server. The client provides the IP address of the server to connect to the
server. The server provides a unique clientId when the client is connected to it.

NOTE. The server must be active and running for the client to connect to the
server. You can connect multiple clients to the server at a time.

Parameters.

Parameter Type Direction Description
HostIPAddress string IN The IP address of the

server to which the
client is trying to
connect. This is
required to establish
the connection between
the server and the
client.

clientIntf string IN The handle of the
remote object interface

clientId string OUT Identifier of the client
that is performing the
remote function.
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Return value. Value that indicates the connection status (connection was
established or an error occurred). The return value can be a boolean value (true),
or a string (returning the error message).

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."

Example. try {
IPAddress[] hostIPAddr =
Dns.GetHostAddresses(Dns.GetHostName());

// Connect to the remoter Server

remoteObject.Connect(hostIPAddress, clientInterface, out
clientID);

return true;

}

catch (Exception error)

{

return error;

}

Related command(s).  
Disconnect
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Disconnect() Disconnect(clientId). This command disconnects the client from the server it is
connected to.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function.

Return value. Integer value that indicates the status of the operation upon
completion.

1: Success

–1: Failure

Example. try
{

string returnVal = UnlockServer(clientId);

remoteObject.Disconnect(clientId);

return 1;

}

Comments. When the client is disconnected, it is unlocked from the server and
then disconnected. The id is reused.

Related command(s).  
Connect

DUT automation() Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
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out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 

string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set the device
as Device, Host or Hub.

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid values are
Device
Connector,Host
Connector and Hub
Connector.

string parameterString (for test rate)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
The first parameter is
the Test mode. Valid
value is DUT
paramaters
The second parameter
sets the test mode.
Valid value is
55.577.88.89.
String example: "DUT
Automation

$True".

Related command(s).  
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Enter controller PC IP address

Enter controller PC IP
address()

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string

out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 

string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set the device
as Device, Host or Hub.

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid values are
Device
Connector,Host
Connector and Hub
Connector.
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string parameterString (for test rate)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
The first parameter is
the Test mode. Valid
value is Controller PC
IP
The second parameter
sets the test mode.
Valid value is
55.577.88.89.
String example:
"Controller PC

IP$23.55.78.99".

Related command(s).  
DUT automation

Get current status info() GetCurrentStatusInfo(clientID, WaitingMsbBxCaption, WaitingMsbBxMessage,
WaitingMsbBxButtontexts). This command gets the additional information of the
states when the application is in Wait or Error state.

Except client ID, all the others are Out parameters.

NOTE. This command is used when the application is running and is in the wait
or error state.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function.

WaitingMsbBxCaption string OUT The wait state or error
state caption sent to
you

WaitingMsbBxMessage string OUT The wait state/error
state message sent to
you

WaitingMsbBxButtonte
xts

string array OUT An array of strings
containing the possible
response types that
you can send
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NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."

Return value. This command does not return any value.

This function populates the Out parameters that are passed when invoking this
function.

Example. m_Client = new Client() //m_Client is a reference to the Client class in
the Client DLL

mClient.GetCurrentStateInfo(clientID, WaitingMsbBxCaption,
WaitingMsbBxMessage, WaitingMsbBxButtontexts)

Related command(s).  
Application status

Query status

Send response

Get or set timeout value() Command name Parameters Description Return value Example
GetTimeOut() string clientID Returns the

current timeout
period set by the
client

String that gives
the status of the
operation after it
was performed
The default return
value is 1800000.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
returnval=m_Clien
t.GetTimeOut()

SetTimeOut() string clientID
string time

Sets a timeout
period specified by
the client. After
this timeout period
expires, the server
is unlocked
automatically.

String that gives
the status of the
operation after it
was performed
On success the
return value is
“TimeOut Period
Changed”.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
returnval=m_Clien
t.SetTimeOut(clien
tID,
desiredTimeOut)

TekExpress USB2 programmatic interface  

68 TekExpress® USB2 Printable Application Help



out string clientID

Name Type Direction Description
clientiD string OUT Identifier of the client

that is connected to the
server
clientID = unique
number + IPaddress of
the client. For example,
1065–192.157.98.70 

string time

Name Type Direction Description
time string IN The time in seconds

that refers to the
timeout period

The time parameter gives the timeout period, which is the time the client is
allowed to be locked and idle. After the timeout period if the client is still idle, it
gets unlocked.

The time parameter should be a positive integer; otherwise, the client is prompted
to provide a valid timeout period.

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."

 TekExpress USB2 programmatic interface

TekExpress® USB2 Printable Application Help 69



Get pass fail status() GetPassFailStatus(clientId, device, deviceConnector, test). This command gets the
pass or fail status of the measurement after test completion.

NOTE. Execute this command after completing the measurement.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

device string IN Specifies the DUT type
(Host or Device).

deviceConnector string IN string with device
connection type. Valid
values are Host
Connector and Device
Connector

test string IN Specifies the name of
the test for which to
obtain the pass or fail
status.

Return value. String value that indicates the status of the operation upon
completion.

Example. GetPassFailStatus(clientId, “Device”, “Device Connector”, test);

GetPassFailStatus(clientId, “Host”, “Host Connector”, test);

Get report parameter() GetReportParameter(clientId, device, suite, test, parameterString). This command
gets the general report details such as oscilloscope model,TekExpress Firm Ware
version and Application version.

Parameters.
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Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

device string IN Specifies the DUT type
(Host or Device).

deviceConnector string IN string with device
connection type. Valid
values are Host
Connector and Device
Connector

test string IN Specifies the name of
the test for which to
obtain the pass or fail
status or a test result
value.

parameterString string IN Specifies to return the
measured value for the
indicated test. Enter
“Scope Model”,
“TekExpress
Version”, or
“Application Version”
for this argument

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."

Return value. The return value is the connected oscilloscope model, TekExpress
base software version, or TekExpress USB2 application version.

Example. GetReportParameter(clientId, “Device”, “Device Connector”, test,
"Application Version")
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Get results value() GetResultsValue (clientId, device, deviceConnector, test, parameterString). This
command gets the result values of the specified measurement after the run.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

device string IN Specifies the DUT type
(Host or Device).

deviceConnector string IN string with device
connection type. Valid
values are Host
Connector and Device
Connector

test string IN Specifies the name of
the test for which to
obtain the test result
value.

parameterString string IN Specifies to return the
measured value for the
indicated test. Enter
“Value” for this
argument

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."

Return value. String value that indicates the status of the operation upon
completion. Returns the result value in the form of a string.

Example. GetResultsValue(clientId, “Device”, “Device Connector”, test,
"Value");
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Lock server() LockServer(clientID). This command locks the server to which it is connected.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function

Return value. Integer value that indicates the status of the operation upon
completion.

Example. try
{

string returnVal = remoteObject.lockServer(clientId);

remoteObject.connect(clientId);

return 1;

}

Related command(s).  
Unlock server

Lock session() LockSession(clientId). This command locks the server. The client has to call this
command before running any of the remote automations. The server is locked by
only one client.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function

Return value. Returns the status of the operation upon completion.

Example. if (locked)
return “Session has already been locked!”;

returnVal = remoteObject.LockSession(clientId);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

{

locked = true;

return “Session Locked...”;

}
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Comments. When the client tries to lock a server that is locked by another client,
the client gets a message that the server is already locked and it has to wait until
the server is unlocked.

If the client locks the server and is idle for a certain amount of time, then the
server is automatically unlocked from that client.

Related command(s).  
Unlock session

Query status() QueryStatus (clientID, out status): This command transfers Analyze panel
status messages from the server to the client.

Table 16: Parameters

Parameter Type Direction Description
clientID string IN Identifier of the client

that is connected to the
server

status string array OUT The list of status
messages generated
during the run

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."

Return value

String value that indicates the status of the operation upon completion. On
success the return value is “Transferred...”.

Example

returnVal=m_Client.QueryStatus(clientID, out statusMessages)

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Status updated...”

else

return CommandFailed(returnVal)
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Related command(s).  
Application status

Get current state Info

Send response

Register status change
notification()

RegisterStatusChangeNotification(clientID, statusChangeHandler). There are two
ways to poll the application when it comes out of the Busy state. This command
registers when there is an event, which indicates that activity is complete.

This command is used to select the particular version for a specific suite.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function

statusChangeHandler Delegate of type
TekExpressClient.Statu
sChangeHandler

IN Handler

Return value. Returns an empty string when the operation is successful; otherwise
it returns an error description.

Example. m_Client.RegisterStatusChangeNotification(clientId,
new TekExpressClient.StatusChangeHandler (OnStatusChange));

public void OnStatusChange(string _status)

 {

 _status = m_Client.Application_Status(clientId);

 if (_status.CompareTo("Wait") == 0 ||
_status.CompareTo("Error") == 0)

   {

   string caption = "", message = "";

   string[] buttonTexts = null;

   m_Client.GetCurrentStateInfo(clientId, out caption, out
message, out buttonTexts);

   Console.WriteLine("Caption:" + caption);

   Console.WriteLine("Message:" + message);

   Console.WriteLine("Message Type:" +
FormatStringArray(buttonTexts));

   Console.WriteLine("Press Enter to send response . Waiting
for Response...");

   string response = Console.ReadLine();
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   m_Client.SendResponse(clientId, caption, message,
response);

   Console.WriteLine("Message Response " + response + "
Sent");

   }

 }

Run with set
configurations or stop the

run operation

Command name Parameters Description Return value Example
Run() string clientID Runs the selected

tests Note
After the server is
set up and
configured, run it
remotely using this
function.

String that gives
the status of the
operation after it
was performed.
The return value is
"Run started..." on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
returnval=m_Clien
t.Run(clientID)

Stop() string clientID Stops the running
tests. Note

String that gives
the status of the
operation after it
was performed
The return value is
"Stopped..." on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
returnval=m_Clien
t.Stop(clientID)

out string clientID

Name Type Direction Description
clientiD string OUT Identifier of the client

that is connected to the
server
clientID = unique
number + IPaddress of
the client. For example,
1065–192.157.98.70 

NOTE. When the run is performed, the status of the run is updated periodically
using a timer.

NOTE. When the session is stopped, the client is prompted to stop the session and
is stopped at the consent.

NOTE. The Fail condition for PI commands occurs in any of the following cases:
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If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."
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Save, recall or query a
saved session

Command name Parameters Description Return value Example
CheckSessionSav
ed() 

string clientID
out bool saved

This method
checks whether
the current
session is saved.

Return value is
either True or
False

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
returnval=m_Clien
t.CheckSessionSa
ved(m_clientID,
out savedStatus)

RecallSession() string clientID
string name

Recalls a saved
session. The client
provides the
session name.

String that gives
the status of the
operation after it
was performed
The return value is
“Session
Recalled...”

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
returnval=m_Clien
t.RecallSession(cli
entID,
savedSessionNam
e)

SaveSession() string clientID
string name

Saves the current
session. The client
provides the
session name.

String that gives
the status of the
operation after it
was performed
The return value is
"Session
Saved..."/"Failed...
"

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
returnval=m_Clien
t.SaveSession(clie
ntID,
desiredSessionNa
me)

SaveSessionAs() string clientID
string name

Saves the current
session under a
different name
every time this
method is called.
The client provides
the session name.

String that gives
the status of the
operation after it
was performed
The return value is
"Session Saved..."

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
returnval=m_Clien
t.SaveSessionAs(c
lientID,
desiredSessionNa
me)
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out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 

out bool saved

Name Type Direction Description
saved bool OUT Boolean representing

whether the current
session is saved

This parameter is used as a check in SaveSession() and SaveSessionAs()
functions.

string name

Name Type Direction Description
name string IN The name of the

session being recalled

The name parameter cannot be empty. If it is empty, the client is prompted to
provide a valid name.

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."
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Save session as() SaveSessionAs(clientId,sessionName). Saves the current session in a different
name every time this command is called. The name of the session is provided by
the client.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

sessionName string IN The name of the
session being saved.

Return value. String that indicates the status of the operation upon completion.

Example. returnVal =
remoteObject.SaveSessionAs(clientId,sessionName);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Session Saved...”;

else

return CommandFailed(returnVal);

Comments. The same session is saved under different names using this command.
The name parameter cannot be empty. If it is empty, the client is prompted to
provide a valid name.

Related command(s). '
Recall session

Save session

Select device() Selectdevice(clientId, device, true). This command selects the DUT type (Device,
Host, or Hub).

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

device string IN String with the device
DUT type. Valid values
are Device, Host
andHub.

Return value. String value that indicates the status of the operation upon
completion.

Example. SelectDevice(clientId, "Device", true);

SelectDevice(clientId, "Host", true);
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SelectDevice(clientId, "Hub", true);

Select pre-recorded
waveform files

Set pre-recorded waveform files (clientID, bset, ERRORString). This command
selects the “Use pre-recorded waveform files” control in the DUT panel of the
application UI.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function

bset string IN This should be “True”
or “False” based on the
condition

ERRORString string IN Error message to print
if the command did not
execute

Return value. 1 if pass, -1 if fail.

Example. m_Client = new Client() //m_Client is a reference to
the Client class in the Client DLL.

returnval as Integer = m_Client.SetPrerecorded(clientId,
True, “ ”)

Where:

clientId = clientId

bset= True

Error= ""

Comments.  
Use Recall session() before using this command.
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Select port()

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string

out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 

string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set the device
asHub

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid value is Hub
Connector.
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string parameterString (for test rate)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
The first parameter is
the Ports. Valid value is
Ports
The second parameter
sets the Test Method.
Valid values are Tier 1,
Tire 2,Tire 3,Tire
4,Tire 5,Tire 6
String example: "Port
$1".

Select probe type()

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string

out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 
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string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set the device
as Device, Host or Hub

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid values are
Device
Connector,Host
Connector and Hub
Connector.

string parameterString (for test rate)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
The first parameter is
the Probe Type: DUT
Signal Probing. Valid
value is Probe Type:
DUT Signal Probing
The second parameter
sets the Probe Type:
DUT Signal Probing.
Valid values are
Differential, and
Single-ended.
String example:
"Probe Type:DUT

Signal Probing

$Differential".

TekExpress USB2 programmatic interface  

84 TekExpress® USB2 Printable Application Help



Get results value for sub
measurement()

GetResultsValueforsubmeasurements (clientId, device, deviceConnector, test,
parameterString, rownumber). This command gets the result values of the sub
measurement after the run.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

device string IN Specifies the DUT type
(Host or Device).

deviceConnector string IN string with device
connection type. Valid
values are Host
Connector and Device
Connector

test string IN Specifies the name of
the test for which to
obtain the test result
value.

parameterString string IN Specifies to return the
measured value for the
indicated test. Enter
“Value” for this
argument

rownumber string IN Specifies the row
number of the results
panel.

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."

Return value. String value that indicates the status of the operation upon
completion. Returns the result value in the form of a string.

Example. GetResultsValueForSubMeasurements(clientId, "Device", "Device
Connector", "EL21_EL22_EL25", "Value", 0)

Related command(s).  
Get results value
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Select power condition()

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string

out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 

string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set this to Hub.

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid value is ,Hub
Connector.
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string parameterString (for test rate)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
The first parameter is
the Power Condition.
Valid value is Power
Condition
The second parameter
sets the Power
Condition. Valid values
are Self Powered, Bus
Powered.
String example: "
Power Condition

$Self Powered".

Select qualifier()

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string

out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 
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string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set the device
as Device, Host, and
Hub.

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid values are
Device
Connector,Host
Connector and Hub
Connector.

string parameterString (for test rate)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
The first parameter is
the Qualifier. Valid
value is Qualifier
The second parameter
sets the Qualifier. Valid
values are CH1, and
CH2,CH3,CH4
String example:
"Qualifier$CH1".
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Select single test() SelectSingleTest(clientID, device, suite, version, test). This command is to select a
single test from a group of tests.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function

device string IN Device DUT type
suite string IN Host type
version string IN Enter a null value for

this field
test string IN Name of the test

Return value. Returns an empty string if the command is executed properly,
otherwise returns the string “Failed.”

Example. m_Client = new Client()
Note: m_Client is a reference to the Client class in the Client DLL.

To return a string:

returnval=m_Client.SelectSingleTest(clientId, device, suite,
Version, test)

Where:

clientId = clientId

device = "Device" or "Host"

suite = "Device Connector" or "Host Connector"

Version= "" (null)

To select High Speed Eye Diagram Test:

test = "HS_EyeDiagram"

To select Full Speed Eye Diagram Test:

test = "FS_EyeDiagram"

To select Low Speed Eye Diagram Test:

test = "LS_EyeDiagram"
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Select suite() Selectsuite (clientId, device, device Connector, true). This command selects one of
the three suites: "Device Connector" or "Host Connector" or "Hub Connector".

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

device string IN String with the device
DUT type. Valid values
are Host and
DeviceHub.

device Suite string IN string with device
connection type. Valid
values are Host
Connector and Device
ConnectorHub
Connector

Return value. String value that indicates the status of the operation upon
completion.

Example. SelectSuite(clientId,"Device","Device Connector",true);

SelectSuite(clientId,"Device","Host Connector",true);

SelectSuite(clientId,"Host","Device Connector",true);

SelectSuite(clientId,"Host","Host Connector",true);

Select test method()

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
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out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 

string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set this as
Device, Host or Hub .

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid values are
Device
Connector,Host
Connector and Hub
Connector.

string parameterString (for test rate)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
The first parameter is
the Test Method. Valid
value is Test Method
The second parameter
sets the Test Method.
Valid values are
USBET, and
Tektronix.
String example: "Test
mode$USBET".
"Test mode

$Tektronix"
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Select test mode()

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string

out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 

string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set the device
as Device,Host or Hub.

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid values are
Device
Connector,Host
Connector and Hub
Connector.
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string parameterString (for test rate)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
The first parameter is
the Test mode. Valid
value is Test Mode
The second parameter
sets the test mode.
Valid values are
Compliance and User
Defined.
String example: "Test
mode

$Compliance".

Select test point:Near
End()

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string

out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 
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string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set device as
Device, Host or Hub.

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid values are
Device
Connector,Host
Connector and Hub
Connector.

string parameterString (for test point)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
To select Test Point,
the first parameter is
Near End . Valid value
is Near End ,and
To select Test Point,
the second parameter
is Near End Valid
values are True,False
String example: "Test
point$Near End".

TekExpress USB2 programmatic interface  

94 TekExpress® USB2 Printable Application Help



Select test point:Far End

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string

out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 

string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set device as
Host or Hub.

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid values are Host
Connector and Hub
Connector.
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string parameterString (for test point)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
To select Test Point,
the first parameter is
Far End . Valid value is
Far End ,and
To select Test Point,
the second parameter
is Far End Valid values
are True,False
String example: "Far
End$True".

Select Tier()

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string

out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 
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string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set the device
as Device, Host and
Hub

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid values are
Device
Connector,Host
Connector and Hub
Connector.

string parameterString (for test rate)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
The first parameter is
the Tier. Valid value is
Tier
The second parameter
sets the Tier. Valid
values are Tier 1,Tier 2
Tier 3Tier 4Tier 5Tier
6
String example: "Tier
$Tier1".
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Send response() SendResponse(clientID, WaitingMsbBxCaption, WaitingMsbBxMessage,
WaitingMsbBxButtontexts). After receiving the additional information using the
command GetCurrentStateInfo, the client can decide which response to send and
then send the response to the application using this function. The response should
be one of the strings that was received earlier as a string array in the
GetCurrentStateInfo function. The _caption and _message should match the
information received earlier in the GetCurrentState Info function.

NOTE. This command is used when the application is running and is in the wait
or error state.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

WaitingMsbBxCaption string OUT The wait state or error
state message sent to
you

WaitingMsbBxMessage string OUT The wait state/error
state message sent to
you

WaitingMsbBxButtonte
xts

string array OUT An array of strings
containing the possible
response types that
you can send

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."

Return value. This command does not return any value.

Example. m_Client = new Client() //m_Client is a reference to the Client class in
the Client DLL

mClient.SendResponse(clientID, out WaitingMsbBxCaption, out
WaitingMsbBxMessage, out WaitingMsbBxButtontexts)

Related command(s).  
Application status

Get current state Info
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Query status

Select versions()

Command name Parameters Description Return value Example
SetGeneralParam
eter

clientID
device
devicesuite
parameterString

Sets the data rate
parameter.

String that gives
the status of the
operation after it
was performed.
The return value is
"" (an empty
String) on
success.

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string

out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 

string device

Name Type Direction Description
device string IN Specifies the name of

the device. For USB2
testing, set the device
as Device, Host and
Hub.

string devicesuite

Name Type Direction Description
devicesuite string IN Specifies the name of

the USB2 device suite
enclosed in quotes.
Valid values are
Device
Connector,Host
Connector and Hub
Connector.
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string parameterString (for test rate)

Name Type Direction Description
parameterString string IN A string containing two

parameters separated
by a $ symbol,
enclosed in quotes.
The first parameter is
the Version. Valid value
is Version
The second parameter
sets the Version. Valid
values are Low
Speed,Full Speed
andHigh Speed
String example: "Low
Speed$True".
"Full Speed

$True"."High
Speed$True"

Set or get the DUT ID Command name Parameters Description Return value Example
SetDutId() string clientID

string dutName
This method
changes the DUT
ID of the setup.
The client must
provide a valid
DUT ID.

String that gives
the status of the
operation after it
was performed
Return value is
“DUT Id Changed”
on success

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
return=m_Client.S
etDutId(clientID,de
siredDutId) Note

GetDutId() string clientID
string dutId

This method gets
the DUT ID of the
current setup.

String that gives
the status of the
operation after it
was performed

m_Client = new
Client() //m_Client
is a reference to
the Client class in
the Client DLL.
returnval as string
return=m_Client.G
etDutid(clientID,
out DutId)
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out string clientID

Name Type Direction Description
clientid string OUT Identifier of the client

that is connected to the
server
clientId = unique
number + ipaddress of
the client. For example,
1065–192.157.98.70 

string dutName

Name Type Direction Description
dutName string IN The new DUT ID of the

setup

string dutId

Name Type Direction Description
dutId string OUT The DUT ID of the

setup. for example,

The dutId parameter is set after the server processes the request.

NOTE. If the dutName parameter is null, the client is prompted to provide a valid
DUT ID.

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."
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Set instrument() SetInstrument(clientID, device, suite, test, paramString). Sets the specified
instrument as a general configuration parameter to the selected test.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function

device string IN Device DUT type
suite string IN Host type
test string IN Name of the test
paramString string IN Specifies the control to

set

Return value. Returns the string value of the instrument specified for setting in
configuration parameter.

Example. mClient = new Client()
Dim clientId As String

Dim DUTType As String = “Device” or “Host”

Dim TekExpress_Suite As String = “Device Connector” or “Host
Connector”

Dim str As String

Str= mClient.SetInstrument(clientId, DUTType,
TekExpress_Suite, "UI-Unit Interval", " AnalyzeInstrument
$Real Time Scope$ DPO71254B ( GPIB0::1::INSTR )")

Set verbose mode() SetVerboseMode(clientId, verboseMode). This command sets the verbose mode to
either true or false. When the value is set to true, event messages are routed to the
client machine that is controlling TekExpress USB2.

When the value is set to false, event messages are shown only on the server
machine.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

verboseMode boolean IN Sets the verbose mode
to be turned ON (true)
or OFF (false).

Return value. String that gives the status of the operation after it was performed.
Returnval as string.
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When Verbose mode is set to true, the return value is “Verbose mode turned on.
All dialog boxes will be shown to client”.

When Verbose mode is set to false, the return value is “Verbose mode turned off.
All dialog boxes will be shown to server”.

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is LOCKED then the message shown is "Server is locked by another
client".

If the session is UNLOCKED then the message shown is "Lock Session to execute
the command".

If the server is NOTFOUND then the message shown is "Server not
found...Disconnect!".
When none of these fail conditions occur, then the message shown is "Failed...".

Example. m_Client = new Client() //m_Client is a reference to
the Client class in the Client DLL.

Turn on verbose mode:

return=m_Client.SetVerboseMode(clientId, true);

Turn off verbose mode:

returnval=m_Client.SetVerboseMode(clientId, false);

Status() Status(clientId, out statusMessages). This command gives the status of the run as
messages. The status messages are generated once the run is started.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

statusMessage string array OUT The list of status
messages generated
during run.

Return value. String that indicates the status of the operation upon completion.

Example. returnVal = remoteObject.QueryStatus(clientId, out
statusMessages);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Status updated...”;

else

return CommandFailed(returnVal);
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Comments. The status messages are updated periodically after the run begins. The
status is an out parameter which is set when the server processes the request.

Related command(s).  
Application status

Transfer images() TransferImages(clientId, filePath). This command transfers all the images (screen
shots) to the specified client and folder (directory) from the current run.

NOTE. Every time you click Start, a folder is created in the X: drive. Transfer the
waveforms before clicking Start.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

filePath string IN The location where the
screen shots must be
saved in the client.

NOTE. If the client
does not provide the
location to save the
report, the report is
saved at C:
\ProgramFiles.

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client."

If the session is unlocked, the application displays "Lock session to execute the
command."

If the server is not found, the application displays "Server not found-
Disconnect!."

If the fail condition is not one of the above types, the application displays
"Failed."

Return value. String value that indicates the status of the operation upon
completion. Transfers all the images in the form of a string.

Example. TransferImages(clientId, "C:\Images”)
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Transfer result() TransferResult(clientID, Filepath). Transfers (saves) the result from the results
panel information to the specified path.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function

Filepath string IN Specifies the
destination path of the
file to be saved

Return value. Return a string as “Transferred…”

Example. m_Client = new Client() //m_Client is a reference to
the Client class in the Client DLL

TransferResult as string = m_Client.TransferResult(clientId,
“C:\abc\Results\”);

Transfer waveforms() TransferWaveforms(clientID, path). This command transfers all the acquired
waveforms to the specified location.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function

path string IN Path to location at
which to store
waveforms

Return value. Returns a string as “Transferred…”

Example. m_Client = new Client() //m_Client is a reference to
the Client class in the Client DLL

TransferWaveforms as string =
m_Client.TransferWaveforms(clientId, “C:\abc\Waveforms\”);
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Unlock server() UnlockServer(clientID, path). This command unlocks the server to which it is
connected.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is performing the
remote function

Return value. Returns and integer value that indicates the status of the operation
upon completion. Session UnLocked…

Example. try
{

string returnVal = remoteObject.UnlockServer (clientId);

remoteObject.disconnect (clientId);

return 1;

}

Comments. When the client is disconnected, it is unlocked from the server and
then disconnected. The ID is reused.

Unlock session() UnlockSession(clientId). This command unlocks the server from the client. The
client id of the client to be unlocked has to be provided.

Parameters.

Parameter Type Direction Description
clientId string IN Identifier of the client

that is connected to the
server

Return value. String that indicates the status of the operation upon completion.

Example. returnVal = remoteObject.UnlockSession(clientId);
if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

{

locked = false;

return “Session UnLocked...”;

}

Comments. When the client is disconnected, it is automatically unlocked.

Related commands.  
Lock session

TekExpress USB2 programmatic interface  

106 TekExpress® USB2 Printable Application Help



Reference

Handle error codes
The return value of the remote automations at the server-end is OP_STATUS,
which changes to a string value depending on its code, and is returned to the
client. The values of OP_STATUS are as follows:

Code Value Description
-1 FAIL The operation failed
1 SUCCESS The operation succeeded
2 NOT FOUND Server not found
3 LOCKED The server is locked by another

client, so the operation cannot
be performed

4 UNLOCK The server is not locked; lock
the server before performing
the operation

0 NULL Nothing

NOTE. The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another
client".

If the session is unlocked, the application displays "Lock session to execute the
command".

If the server is not found, the application displays " Server not found-
Disconnect!".

If the fail condition is not one of the above types, the application displays
"Failed".
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HSETT controller

Setting up controller PC
for automated DUT test

mode

Pre-requisites for the controller PC/Laptop:

■ Windows 7 64-bit OS with at least one USB3.0 port

■ USB-IF supplied xHCI HSETT v1.2.0.0 or later installed

Installation:

1. Use the Tektronix HSETT Controller Installer to install HSETT Controller
on the controller PC/Laptop.

2. Follow the installation instructions.

3. Note the IP address of the controller PC to be provide to TekExpress USB2.

Verifying HSETT Controller installation:

1. Ensure that Tektronix HSETT Controller Service appears in Windows
Service Manager (using services.msc) or Windows Task Manager.

2. Ensure path C:\Program Files\Tektronix\TekApplication\Tektronix HSETT
Controller\ is created.

Signal validation
TekExpress USB2 automatically performs signal validation before analyzing and
is based on the test method selected. For Test Method selected as USBET, signal
validation is done by USBET algorithms. If an invalid signal is detected,
application shows the following message dialog box:
 

 

   

■ Click ReAcquire to start the acquisition again.

■ Click Skip Pattern to skip all the tests associated with that test pattern. The
rest of the selected measurements continue.

Reference  

108 TekExpress® USB2 Printable Application Help



For Test Method selected as Tektronix, signal validation is done by Tektronix
algorithms. If an invalid signal is detected, application shows the following
message dialog box:
 

 

   

■ Click ReAcquire to start the acquisition again.

■ Click Use Current to continue with the currently acquired waveform.

■ Click Skip Pattern to skip all the tests associated with that test pattern. The
rest of the selected measurements continue.

 Reference
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Acquire parameters

including in test reports, 41
viewing in reports, 43
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Activate the TekExpress USB2 license, 8
application directory setup, 9
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Before you click Start, 46
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CheckSessionSaved(), 78
Client proxy object, 56
Code example, remote access, 60
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Compliance Mode, 32
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Device parameters, 26
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DUT parameters, 26
DUT type

device, 26
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Email notifications, 20

Enable remote access, 52
Equipment setup, 45
Error notification (email), 20
Evaluation mode, 14
Exiting the application, 14

F
Fail notification (email), 20
File name extensions, 11
Firewall (remote access), 52
Free trials, 14

G
GetDutId(), 100
GetTimeOut(), 68
Global settings, 32

H
Help conventions, 2

I
Inbound Rule Wizard (remote access), 52
Initial application directory setup, 9
Installing the software

TekExpress application for USB2, 7
Instruments

discovering connected, 18
viewing connected, 18

Instruments detected, 32
Interface, 51
Interface error codes, 107
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Keep On Top, 14
Key, 14

L
License, 14
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License agreement, 8
Limits Editor, 32
Loading a test setup, 48
Loading saved waveform files, 29, 31
Log view

save file, 35
Log View tab, 35

M
Measurement limits, 32
Menus, 17
Minimum system requirements, 5
Mode

Compliance, 32
User Defined, 32

My TekExpress folder
files stored in, 39

My TekExpress folder permissions, 9

N
New Inbound Rule Wizard, 52
Notifications (email), 20

O
Opening a saved test setup, 48
Option Installation wizard, 8
Options menu

Instrument control settings, 18
Keep On Top, 14

Overall test result, 37, 39

P
Panels, 23
Pass/Fail info in details table

including in reports, 42
Pass/Fail summary

viewing, 43
PI cmnds

data rate, 82, 83, 86, 87, 90, 92, 93, 95, 96, 99
Plot images

including in reports, 42
viewing, 43

Plots panel, 39

Preferences menu, 37, 38
Preferences tab, 25, 34
Prerecorded waveform files

selecting run sessions for, 26
Prerun checklist, 46
Program example, 60
Programmatic interface, 51

R
Reactivate the TekExpress USB2 license, 8
Real time oscilloscope, 32
Recalling a test setup, 48
RecallSession(), 78
Record length, 32
Related documentation, 1
Remote access firewall settings, 52
Remote proxy object, 55
Report name, 41
Report options, 41
Report sections, 43
Reports

receiving in email notifications, 20
Reports panel, 23, 40
Resource file, 14
Results panel, 37, 38
Run a saved test session, 49
Run(), 76

S
Sample Rate, 32
Save log file, 35
SaveSession(), 78
SaveSessionAs(), 78
Saving test setups, 47
Saving tests, 39
Schematic button, 28
Search for connected instruments, 18
Select All (tests), 28
Selecting test report contents, 41
Selecting tests, 28
Server, 54
Session files, 39
Session folders, 39
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set My TekExpress folder permissions, 9
Set remote access, 52
SetDutId(), 100
SetTimeOut(), 68
Setting up controller PC for automated DUT test

mode, 108
Setting up equipment, 45
Setting up tests, 45
Setup files, 47
Setup panel, 23, 25
Setup panel views, 26
Signal validation, 108
Software installation

activate TekExpress USB2 license, 8
TekExpress USB2, 7

Software version, 8
Status panel, 35
Stop(), 76
Support, 2
System requirements, 5

T
Technical support, 2
TekExpress USB2 client, 51
TekExpress USB2 client requirements, 54
TekExpress USB2 installation, 7
TekExpress USB2 license activation, 8
TekExpress USB2 server, 51
Test completion notification (email), 20
Test groups, 28
Test parameters (Configuration tab), 32
Test reports, 43
Test results

emailing, 20
Test selection controls, 28
Test setup files, 39, 47
Test setup steps, 45
Test setups

creating, 50
load, 48
open, 48
recalling, 48
saving, 47

Test Status tab, 35
Test-related files, 39
Tests

running, 46
selecting, 28

U
Use saved waveforms to run a test, 49
User account setting (Windows 7), 6
User comments

location in reports, 43
User Comments

including in reports, 42
User Defined Mode, 32

V
Verify application installation, 8

W
Waveform files

locating and storing, 39
Windows 7 user account setting, 6
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