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1 Introduction to the DPOJET USB 3.0 Setup Library 
 

This document provides the Methods of Implementation (MOI) for making USB 3.0 measurements 

with Tektronix DPO/DSA70000 Series real time oscilloscopes (8 GHz models and above) and 

probing solutions.  

DPOJET (Jitter and Eye Analysis Tools) is available on DPO/DSA70000 Series instruments. 

Instrument Setup files using DPOJET measurements are used to perform USB 3.0 specific 

measurements. DPOJET along with its associated setup files provides transmitter path 

measurements (amplitude, timing, and jitter), waveform mask testing and limit testing described in 

the USB 3.0 specification at respective test points. 

 

Table 1 – Supported Specifications 

Spec Revision USB 3.0  Specification Title MOI Test Points Defined 

Rev1.0 Universal Serial Bus 3.0 Specification Informative Transmitter and Normative 
Transmitter 

 

Refer to http://www.usb.org/developers/docs/usb_30_spec.zip for the latest specifications.  

In the subsequent sections, step-by-step procedures are described to help you perform USB 3.0 

measurements. Each measurement is described as a Method of Implementation (MOI).  

For the latest version of this document as well as the latest USB 3.0 DPOJET Setup Library refer to 

www.tek.com/software, (keyword ‘DPOJET USB 3.0’).  

For further reference on USB test specifications and compliance testing, consult documents offered 

to USB-IF members at www.usb.org.  
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2 USB3.0 Physical Layer - Transmitter Specifications 
   

2.1 Differential Transmitter (TX) Eye Diagrams 

Fixture-1 shows the eye mask definitions for the USB 3.0. The eye diagrams are a graphical 

representation of the voltage and time limits of the signal. This eye mask applies to jitter after the 

application of the appropriate jitter transfer function and reference receiver equalization. In all cases, the 

eye is to be measured for 10
6
 consecutive UI. The budget for the link is derived assuming a total 10

-12
 bit 

error rate and is extrapolated from a measurement of 10
6
 UI assuming the random jitter is Gaussian.  

Referring to the figure, the time is measured from the crossing points of Txp/Txn. The time is called the 

eye width, and the voltage is the eye height. The eye height is to be measured at the maximum opening 

(at the center of the eye width ± 0.05 UI).  

The eye diagrams are to be centered using the jitter transfer function (JTF). The recovered clock is 

obtained from the data and processed by the JTF. The center of the recovered clock is used to position the 

center of the data in the eye diagram. 

   The eye diagrams are to be measured into 50-Ω single-ended loads. 

 

 

Figure 1. Generic Eye Mask 

This section provides a summary of the measurement parameters measured in DPOJET and how 

they are related to the symbol and test limits in the specification.    
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2.2  SuperSpeed USB Setup Library 

The SuperSpeed USB Setup Library consists of the following software file types. 

 

USB 3.0 Setup Files for the DPO/DSA70000 

System Location: C:\TekScope\setups\USB 

Description: Saved Setups have been created by using the Save > Setup function of the DPO/DSA70000 

Series scope. If any changes are made to the Setup file it is recommended you re-save the file as a different 

name so not to change the parameters in the distribution files.  

The USB folder contains the following setup files. Refer to Section 3.5 of this document for further 

description.  

USB_3_0_Rx_Normative.set – USB 3.0 Compliance test point referred to as TP1 in the specification. 

USB_3_0_Tx_Informative.set – USB 3.0 Informative Transmitter test point 

USB_3_0_Tx_LP_Informative.set – USB 3.0 Informative Transmitter test point for a low power device.  

 

USB 3.0 Channel Model Filters 

Setup Library File Path: C:\TekScope\  

Description: The USB 3.0 Math Arbitrary Filters library allows you to perform SW Channel Emulation of 

the reference channels defined in the specification. Refer to Section 3.5 for details and a full listing of the 

available filters in the distribution. 

 

USB 3.0 Waveform Masks 

Setup Library File Path: C:\TekApplications\DPOJET\Masks\USB 

Description: The USB 3.0 Mask library contains the waveform mask files used by the various setup files. 

Waveform masks are used to perform Pass/Fail template testing on the waveform eye diagram. Refer to 

Section 3.5 for a full listing and description of the masks available in the distribution.  

 

USB 3.0 Limits Files 

Setup Library File Path: C:\TekApplications\DPOJET\Limits\USB 

Description: The USB 3.0 Limits library contains the measurement limit files used by the various setup 

files. Measurement limits are used to provide Pass/Fail indication for each measurement. Refer to Section 

3.5 for a full listing and description of the masks available in the distribution.  

 

Important:  The Setup file defines the system location of the Channel Model Filter, Mask, and Limits files 

used for the test. Thus, all files must be in the proper location for proper operation.  
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2.3 Differential Transmitter Specifications (Informative and Normative) 

The following table shows the available measurements in DPOJET and their test limits defined at each test 

point in the Specification. The Informative Tx test point is defined at the pins of the transmitter device in a 

USB 3.0 link. The Normative Rx test point is defined at the end of a reference channel.  

   Table 2- Supported MOIs - USB 3.0 specification transmitter measurements 

Measurements Supported in Setup Files 

Spec 
Reference Symbol(s) Parameter 

DPOJET 

Measurement 

Method 

Informative 

Tx  

(ie, Near-end) 

Informative 

Tx Low Power 

(ie, Near-end) 

Normative 

Rx  

(ie, far-end) 

Figure 6-9 Clock Recovery   

2nd Order PLL 

Fc = 10MHz 

.707 Damping 

2nd Order PLL 

Fc = 10MHz 

.707 Damping 

2nd Order PLL 

Fc = 10MHz 

.707 Damping 

Table 6-12 Eye Height 
Transmitter Eye 
Mask 

Eye Height1  

(Tbitt or Both) 

Eye Height2 

(nTbit with 
DeEmphasis) 

Height1:   

0.8 V (min) 

Height2: 

0.505 V (min) 

Height 1: 

0.4 V (min) 

Height1: 

100mV (min) 

 

Table 6-11 TTX-EYE 
Transmitter Eye - 
Dual Dirac at 10

-12
 

BER 

Width@BER (min) 

 

.625 UI (min) 

125 ps (min) 

.625 UI (min) 

125 ps (min) 

. 34 UI (min) 

68 ps (min) 

Table 6-8 

Table 6-12 
Dj, TTX-DJ-DD 

Tx deterministic 

Jitter – Dual Dirac 

DJ–δδ 

(max) 

.205 UI (max) 

 41 ps (max) 

.205 UI (max) 

 41 ps (max) 

.43 UI (max) 

86ps (max) 

Table 6-8 

Table 6-12 

Rj  

 

Tx random jitter -  
Dual Dirac 

RJ–δδ 

(max) 

.0121 UI (max) 

2.42 ps (max) 

RMS 

.0121 UI (max) 

2.42 ps (max) 

RMS 

.23 UI (max) 

46 ps (max) 

Pk-Pk 

3.29 ps (max) 

RMS 

Table 6-8 

Table 6-12 
Tj 

Tx toal jitter - Dual 
Dirac at 10

-12
 BER 

TJ@BER (max) 
.375 UI (max) 

75 ps (max) 

.375 UI (max) 

75 ps (max) 

.66 UI (max) 

132 ps (max) 

Table 6-10 UI 
Unit Interval 
including SSC 

Data Period1 

(max/min) 

199.94 (min) 

201.06 (max) 

199.94 (min) 

201.06 (max) 

199.94 (min) 

201.06 (max) 

Table 6-10 

VTX-DIFF-PP 

VTX-DIFF-PP-
LOW 

Differential p-p 

Tx voltage swing 

High–Low  

With Tbit Only Selected 

(max/min) 

0.8 V (min) 

1.2 V (max) 

0.4 V (min) 

1.2 V (max) 

100mV (min) 

1.2 V (max) 
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Measurements Supported in Setup Files 

Spec 
Reference Symbol(s) Parameter 

DPOJET 

Measurement 

Method 

Informative 

Tx  

(ie, Near-end) 

Informative 

Tx Low Power 

(ie, Near-end) 

Normative 

Rx  

(ie, far-end) 

Table 6-10 VTX-DE-RATIO 

De-emphasized 
output voltage 
ratio 

T/nT Ratio (max/min) 
-3.0 dB (min) 

-4.0 dB (max) 
  

Table 6-11 VTX-DC-CM 

Transmitter DC 

common-mode 

voltage 

Common Mode 

Mean (min/max) 

0 (min) 

2.2 (max) 

0 (min) 

2.2 (max) 
 

Table 6-11 
VTX-CM-AC-
PP-ACTIVE 

Tx AC common 

mode voltage 

active 

Common Mode 

Pk-Pk (max) 
100 mV (max) 100 mV (max)  

Table 6-9 
tSSC-MOD-
RATE 

SSC Modulation 
Rate 

Trend of Data Period 

With 2MHz LPF 

Cursors 

30 KHz (min) 

33 kHz (max) 

30 KHz (min) 

33 kHz (max) 
 

Table 6-9 
tSSC-FREQ-
DEVIATION 

SSC Deviation 

Trend of Data Period 

With 2MHz LPF 

Cursors 

+0/-4000 ppm 
(min) 

+0/-5000ppm 
(max) 

+0/-4000 ppm 
(min) 

+0/-5000ppm 
(max) 
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3 Preparing to Take Measurements 
 

3.1 Required Equipment 

The following equipment is required to take the measurements: 

• Oscilloscope Selection:  

It is recommended that ≥12.5 GHz system BW is used for USB 3.0 Informative measurements or 

normative measurements when channel emulation is being used. This ensures that any 5
th
 harmonic 

frequency content is considered in the analysis. Tektronix models that meet this recommendation are 

DPO/DSA71254 and above. The DPO70804 (8 GHz) model is also suitable for Normative measurements 

if the waveform is being acquired at the receiver (TP1 defined in Figure 6-14 of the specification).  

• DPOJET Jitter and Eye Analysis Tool (v1.2.0 build2 or later) installed. 

• SDLA software for Channel DeEmbed and custom filter development (optional) 

• Probes – Two TCA-SMA or One P7300SMA/P7500 differential probe. 

• SMA Breakout Fixture - 'Early' breakout fixture are orderable directly from Ellisys Corp. 

www.ellisys.com (It's Japan distributor: www.gailogic.co.jp) 

• AWG7122B Arbitrary Waveform Generator (v3.0.136.602 or later) (optional) for initiating electrical 

loopback and receiver testing.  

 

3.2 Probing Options for Transmitter Testing 

 

Two TCA-SMA Connectors (Ch1-Ch2 Pseudo-Differential) 

The differential signal is created by the DPOJET from the math waveform Ch1-Ch2. This probing 

technique requires breaking the link and terminating into a 50 Ω/side termination of the oscilloscope. Ch-

Ch de-skew is required using this technique because two channels are used. This configuration does not 

compensate for cable loss in the SMA cables. The measurement reference plane is at the input of the 

TCA-SMA connectors on the oscilloscope. Any cable loss should be measured and entered into the 

vertical attenuation menu for accurate measurements at the SMA cable attachment point. 

 

One P7300SMA Differential SMA Probe (Ch1 True Differential)  

The differential signal is measured across the termination resistors inside the P7300SMA series probe. 

This probing technique requires breaking the link. Matched cables are provided with the probe to avoid 

introducing de-skew into the system. Only one channel of the oscilloscope is used. The P7300SMA 

provides a calibrated system at the Test Fixture attachment point, eliminating the need to compensate for 

cable loss associated with the probe configuration. The P7300SMA Series is better suited for Compliance 

applications where the link is broken.  
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One P7500 Tri-Mode  Differential Probe (Ch1 True Differential)  

The differential signal is measured across the termination resistors inside the DUT. Probing must be 

performed at TP1 in the system (at the receiver pins) to be considered valid per the specification. This 

probing technique can be used in an active system and the exact compliance test pattern may not be 

available.  Only one channel of the oscilloscope is used. The P7500 Tri-Mode probe provides the added 

ability to view and make measurements on D+, D-, Ddiff, and Dcm with a single probing connection. 

The P7500 Tri-Mode probe is better suited for Design Validation and Debug applications where the DUT 

is in an active system.  

 

3.3 Initial Oscilloscope Setup 

After connecting the DUT by the proper probing configuration for the test, click DEFAULT SETUP and 

turn on Ch2 to view the signal.  

 

3.4 Running the DPOJET Software 

1. On DPO70000 series, go to Analysis> Jitter and Eye Analysis>Select 

 

Figure 2: Default menu of the DPOJET software 

Figure 2 shows the oscilloscope display. The default mode of the software is the Serial Analysis 

module. 
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3.5 Configuring the Software to take Various measurements  
    

Selecting Measurements 

In the DPOJET Select menu, select the desired measurements. One can select either a single 

measurement or recalling a setup file he/she can run multiple measurements at a time. Recalling 

the setup files will give all the required setup for those measurements by default. 

 

Figure 3.Jitter and Eye Analysis window for single measurement selection 

 

 

Selecting Limit Files 

 If a measurement has a pass/fail limit associated with it in the test point file, then to select the 

limit files, go to Analyze>Jitter and Eye Analysis>Limits and then select the limit file from the 

folder where the limit files are saved. Measurements with pass/fail limits will show up in the 

Results Summary panel when the compliance test is run.  

 

Configure Mask file: 

i. In DPOJET application go to ‘Plots’ if you want to enable the Mask file. 

ii. Select measurement from the measurement column. 

iii. Click ‘Configure’ button to change the default setup for that measurement. It will 

open Mask selection window. 

iv. In the Mask file selection window, Press the ‘Off’ button first and then click 

‘Browse’ to select the Mask file. 
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Figure. 7g Mask File Selection 

 

v.  Select relevant mask file (For example, USB_3_0_NORMATIVE.msk) file and then 

click ‘Open’. 

vi.  Enable the file by selecting ‘On’ button, and click OK button. 

 

Configuring Source of Waveforms 

           Source selections are dependent on which probe type is selected. The selections are as follows: 

   If Differential is selected as Probe Type:  

• Live/Ref/Math source selection (uses single differential signal as data source) 

Live channel selections–Ch1, Ch2, Ch3, Ch4 

Reference waveform selections–Ref1, Ref2, Ref3, Ref4 

• File source selection <TBD> 

If Single-Ended is selected as Probe Type:  

• Live/Ref/Math1 source selection (uses two single-ended signals as data source) 

Live source selections–Select Math1 and then put (Ch1-Ch2), (Ch1-Ch4), (Ch2-Ch3), (Ch2-

Ch4) which one is required in Math1. Select Math1 to perform selected measurement. 

• Reference waveform selections – Select Math1 and then put (Ref1-Ref2), (Ref1-Ref4), 

(Ref2-Ref3), (Ref2-Ref4) which one is required in Math1. Select Math1 to perform selected 

measurement.    
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Configure Clock Recovery 

In the Configure menu, select Clock Recovery and select the type of clock recovery to be used. 

 

Figure 4. Clock recovery 

 From the Figure. 6.9 in base specification, Clock recovery configuration is given below. 

 Select Method >PLL-Custom Bandwidth. 

 Select PLL Model > Type II 

 Select Damping > 0.707 

 Select Bandwidth 10MHz. And then select  advanced button and configure Bit Rate to 5Gb/s. 

 If more than one measurement are selected at a time then click Apply to All buttons. 

 

 

Figure 5. Clock Recovery selection window 

 

Selecting a Test Point and Channel Model 

Two compliance points are defined in the specification - Normative Transmitter Test Point 

(TP1) and Informative Transmitter Test Point. 
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 Normative Transmitter Test Point (TP1) 

Table 6-12 of USB 3.0 spec represents the Normative Test Point, defined as TP1 in Figure 6-14 

in the specification. Compliance measurements in Table 6-12 are made after acquiring the 

waveform at TP1’ for the device under test as show in the following diagram. 

 

Test points 

The compliance channel model is combined with the CTLE (Continuous Time Linear 

Equalization) function into a single filter. (FIR filter). It is then applied to the acquired 

waveform and analyzed for compliance using  DPOJET. The result gives the measurement 

values along with the Pass/Fail report.  

 

 Informative Transmitter Test Point 

Table 6-10 and 6-11 of the Specification define parameters to be taken at the pins of the 

transmitter device and represent the Informative Transmitter Test Point. This test point requires 

the measurement channel be De-Embedded from the measurement. The waveform is acquired at 

TP1’ as with the Normative test. 

 

Channel Models: 

The Channel Models are available in the “DSA/Channel Filters” folder in the distribution, with 

description of respective functions as below: 

 

Table 4 – Supported Channel Models and Corresponding Pre-defined Filter Files 

Channel Model for Silicon Testing 

Filter-File Name Description of Filter Function 

USB3_Front_Cable_Device_CTLE.flt Combines Host Front Panel, Cable, Device 

Reference Channel and CTLE 

USB3_Back_Cable_Device_CTLE.flt Combines Host Back Panel, Cable, Device 

Reference Channel and CTLE 

 

Channel Model for Host or Device Testing 

Filter-File Name Description of Filter Function 
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USB3_Cable_Back_CTLE.flt Combines Cable, Host Back Panel Reference 

Channel, and CTLE for Device Testing.  

USB3_Cable_Front_CTLE.flt Combines Cable, Host Front Panel Reference 

Channel, and CTLE for Device Testing.  

USB3_Cable_Device_CTLE.flt Combines Cable and Device Reference Channel 

for Host Testing.  

 

Individual Channel Filters 

Filter-File Name Description of Filter Function 

USB3_BackPanel.flt Host Back Panel Reference Channel.  

USB3_FrontPanel.flt Host Front Panel Reference Channel. 

USB3_Cable.flt 3 Meter USB 3.0 Cable 

USB3_Device.flt Device Reference Channel 

USB3_CTLE.flt USB 3.0 CTLE Filter 
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4 USB3.0 Transmitter Test Procedure 
This section provides the Methods of Implementation (MOIs) for Transmitter tests using a 

Tektronix real-time oscilloscope, probes, and the DPOJET software.  

 

4.1 Step-by-Step Normative Testing 

The following procedure discusses how to use DPOJET to test the Normative test point in the USB 

3.0 Specification. Differences in the procedure for testing the Informative test point are discussed 

but not detailed.  

 

Initial Scope Setup 

i. Configure the DUT to transmit the compliance pattern (CP0 – Scrambled D0.0) 

ii. Connect to the Transmitter port of the DUT using one of the probing configurations 

described in Section 3.2 of this document. If using pseudo-differential input (Ch1-

Ch2), perform channel-channel de-skew procedure and record the de-skew value for 

Ch2. If using a differential probe de-skew is not necessary.  

iii. Press the  DEFAULT SETUP  button.  

iv. Turn on Ch2 (if using pseudo-differential input) to view the signal under test. 

v. Confirm that the D0.0 pattern is being transmitted from the DUT.  

 

Scrambled D0.0 (CP0) Pattern 
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Recalling the Setup file  

vi. Start DPOJET Application. And, go to Analyze> Jitter and Eye Analysis>Select. 

 

Selecting DPOJET 

 

vii. Go to file menu, select ‘Recall’. Then, select ‘Setup’ from the ‘Recall’ window. 

 

 

Recalling Setup File 
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viii. Select the appropriate setup file from the USB folder setups folder. (For this 

example, select USB_3_0_Rx_Normative.set) to test for Compliance at TP1 of the 

specification.  

ix. Select ‘Recall’ to open the setup file. 

 

Adjust the Vertical Amplitude and ensure proper De-skew calibration 

This part of the procedure should be run the first time the Setup file is recalled on the 

oscilloscope to ensure accurate measurements. 

x. Press the Zoom button to turn off zoom.  

xi. Turn off Math2 in the Math Menu.  

xii. Adjust Horizontal Scale to 2nsec/div. 

xiii. Press the Run/Stop Button so that the acquisition is running.  

xiv. Adjust the vertical amplitude of the active channels to be 9-10 divisions on the 

screen. This takes full advantage of the oscilloscopes A/D range without clipping the 

waveform. In the below example this is Ch1 and Ch2 is set to 120mV/div. 

xv. Go to the De-skew menu and enter the proper value for Ch2.  

xvi. Adjust Horizontal Scale back to 20usec/div. 

xvii. Turn on the Zoom Button and return the Zoom factor to 20000. The display should 

look similar to the following: 
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Optimized Vertical Settings with 1Million UI Capture 

 

Configuring the desired Test Point as Math2: 

xviii. In ‘Math’ window, Select ‘Math2’ and then go to Math editor using ‘Editor’ button. 

xix. Clear the default values from the ‘math2’ using ‘Clear’ button in the Math editor. 

xx.  Go to ‘Filter’ menu in the ‘Math’ window. Select ‘Load’ button. 

xxi. From the Channel Filter File, select ‘USB3_Front_Cable_Device_CTLE’ file and 

click ‘Open’. 

 

Math2 Selection 

xxii. Click the button ‘Flt1’ from the Math Editor. Enter Ch1-Ch2 as the argument of the 

ArbFlt1 function. 
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xxiii. Click ‘Apply’. And then click ‘OK’ button in the Math Editor.  

xxiv. Apply ‘Ch1-Ch2’ in ‘Math1’ clicking ‘Apply’ button 

 

Math2 Waveform Appears 
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Run the Normative Setup file 

xxv. After configuring the Acquisition Channel and the desired Reference Channel, return 

to Analyze > Jitter and Eye Analysis > Select  

xxvi. Select ‘Single’ to run the setup. 

xxvii. After running the application, the results will appear:  

 

 

Normative Test Results  
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Run and Save Test Report: 

xxviii. Select the Reports Button in the DPOJET Menu 

xxix. Press the ‘Save As’ Button and give the report a name 

xxx. The Report will appear onscreen 

 

Test Report Giving Pass/Fail Status 
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4.2 Informative Test Point Example 

The following procedure discusses how to use DPOJET to test the Normative test point in the USB 

3.0 Specification. Differences in the procedure for testing the Informative test point are discussed 

but not detailed.  

 

Transmitter Test Point Example 
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4.3 Informative Low Power Test Point Example 

The following procedure discusses how to use DPOJET to test the Normative test point in the USB 

3.0 Specification. Differences in the procedure for testing the Informative test point are discussed 

but not detailed.  

 

Low Power Transmitter Test Point Example 

 

 

4.4 Tx Eye Height MOI 

 

Definition: 

Eye Height measurement is defined as the clear vertical eye opening at the center of the unit interval. 

Height = High(min) – Low(max)  

Limits: 

Refer to Table 1 for specified limits on the EYETXT
−

 measurement.  

Test Procedure: 

Ensure that Eye Height is selected in the Select menu. 

Measurement Algorithm: 
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The Eye Height measurement is the measured minimum vertical eye opening at the zero reference level.  

The application calculates this measurement using the following equation:  

There are three types of eye height values: 

Eye Height: 

MAXLOEYEMINHIEYEHEIGHTEYE VVV
−−−−−

−=
 

Where: 

MINHIEYEV
−−  is the minimum of the high voltage at mid UI 

MAXLOEYEV
−−  is the maximum of the low voltage at mid UI 

Eye Height – Transition: 

MAXTRANLOEYEMINTRANHIEYETRANHEIGHTEYE VVV
−−−−−−−−

−=
 

Where: 

MINTRANHIEYEV
−−−  is the minimum of the high transition bit eye voltage at mid UI 

MAXTRANLOEYEV
−−−  is the maximum of the low transition bit eye voltage at mid UI 

Eye Height – Non-Transition: 

MAXNTRANLOEYEMINNTRANHIEYENTRANHEIGHTEYE VVV
−−−−−−−−

−=
 

Where: 

MINNTRANHIEYEV
−−−  is the minimum of the high non-transition bit eye voltage at mid UI 

MAXNTRANLOEYEV
−−−  is the maximum of the low non-transition bit eye voltage at mid UI 

 

4.5 TX Deterministic and Random Jitter (Dual Dirac) MOI 

 

Definition: 

DJ–δδ (Deterministic jitter only assuming the Dual Dirac Distribution) Deterministic Jitter is the 

statistics for all timing errors that follow deterministic behavior. Deterministic Jitter is typically 

characterized by its peak-to-peak value. Deterministic Jitter as defined above, but calculated based on a 

simplified assumption that the histogram of all deterministic jitter can modeled as a pair of equal-

magnitude Dirac functions (impulses known as delta-functions).  
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Limits: 

Refer to Table 2 for specified limits on the EYETXT
−

 measurement.  

Test Procedure: 

Ensure that Jitter DJ–δδ is selected in the Select > Jitter menu. 

Measurement Algorithm: 

Dual Dirac Deterministic Jitter (DJ–δδ) the peak-to-peak magnitude for all timing errors exhibiting 

deterministic behavior, calculated based on a simplifying assumption that the histogram of all 

deterministic jitter can modeled as a pair of equal magnitude Dirac functions (impulses). A single DJ–δδ 

value is determined for each acquisition, by means of RJ/DJ separation analysis.  

Rj/Dj Separation Based on Dual Dirac Model: 

Dual Dirac model based Rj/Dj separation method fits the Bathtub curve to a theoretical model of Rj and 

Dj where Rj is assumed to have a Gaussian distribution, Dj is assumed to have a distribution of two Dirac 

impulses with the same height. Curve fitting at different BER levels in Bathtub curve yields the standard 

deviation value of Rj and peak-to-peak value of Dj. The Bathtub curve is obtained from the spectrum 

analysis based or the arbitrary pattern analysis based Rj/Dj separation methods. Rj and Dj based on the 

Dual-Dirac model can be denoted as gRJ  and ddDJ . 

After gRJ  and ddDJ  are obtained, Tj can be calculated using 

ddg DJRJBERQBERTJ +×= )(2)(
 

where Q is the function of BER that has a value of about 7 when 1210 −
=BER . Eye opening is 

computed in the same way as it is computed in the spectrum analysis based Rj/Dj separation. 

Dual Dirac model based Rj/Dj separation method is used. Usually, actual Dj does not have a pure Dual-

Dirac distribution. So the value of gRJ  is often greater than the value of Rj obtained from the spectrum 

analysis based or the arbitrary pattern analysis based Rj/Dj separation. The value of ddDJ  is often less 

than that of its corresponding one. 

 

4.6 TX Total Jitter MOI 

 

Definition: 

TJ@BER (Total Jitter at a specified Bit Error Rate (BER)). This combines the Random and Deterministic 

effects, and predicts a peak-to-peak jitter that will only be exceeded with a probability equal to the BER.  

Limits: 

Refer to Table 1 for specified limits on the EYETXT
−  measurement.  

Test Procedure: 
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Ensure that Jitter TJ@BER is selected in the Select > Jitter menu. 

Measurement Algorithm: 

Total Jitter at a specified Bit Error Rate (BER). This extrapolated value predicts a peak-to-peak jitter that 

will only be exceeded with a probability equal to the BER. It is generally not equal to the total jitter 

actually observed in any given acquisition. A single TJ@BER value is determined for each acquisition, 

by means of RJ/DJ separation analysis. 

 

4.7 TX Unit Interval Measurement MOI 

 

Test Definition Notes from the Specification:  

- UI (Unit Interval) is specified to be +/- 300 ppm  

- UI does not account for SSC dictated variations  

Definition:  

UI is defined in the base specification.  

Limits: 

Refer to Table 2 for specified limits on UI measurement.  

Test Procedure: 

Ensure that Unit Interval is selected in the Measurements> Select > Period menu. 

Measurement Algorithm: 

This measurement is made over the Analysis Window of 250 consecutive bits (or over the entire record if 

the sw PLL is used) as defined in the Base Specification. 

The Unit Interval measurement calculates the cycle duration of the recovered clock. 

)()1()( ntntnUI CLKRCLKR −−
−+=

 

))(( nUIMeanUI AVG =
 

Where:  

CLKRt −  is a recovered clock edge 

n is the index to UI in the waveform 

 

4.8 TX Differential Pk-Pk Output Voltage MOI 
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Definition: 

pDIFFpTXV
−−  (Differential Output Pk-Pk Voltage) is defined in the base specification. This measurement is 

solved by two measurements. One is Differential Peak Voltage measurement and the other is Eye Height: 

Transition Bits measurement. If you select Differential Voltage and Eye Width/Eye Height, you will get 

five measurements: Eye Height, Eye Height: Transition Bits, Eye Height: Non-Trans Bits, Eye Width 

and Differential Peak Voltage.  

Test Definition Notes from the Specification:  

- ||2
−−+−−−

−∗= DTXDTXpDIFFpTX VVV  

- Specified at the measurement point into a timing and voltage compliance test load as shown in the base 

specification and measured over specified number of UIs. Also refer to the transmitter compliance eye 

diagram shown in the base specification. 

Limits: 

Refer to Table 2 for specified limits on the pDIFFpTXV
−−  measurement.   

Test Procedure: 

Ensure that Differential Voltage is selected in the Measurements > Select > Ampl >High-Low menu. 

Measurement Algorithm: 

Differential Peak Voltage Measurement: The Differential Peak Voltage measurement returns two 

times the larger of the Min or Max statistic of the differential voltage waveform.  

)))(());(((2 ivMinivMaxMaxV DIFFDIFFPKDIFF ∗=
−  

Where:  

i is the index of all waveform values 

DIFFv
 is the differential voltage signal 

 

4.9 TX De-Emphasized Differential Output Voltage (Ratio) MOI 

 

Definition: 

RATIODETXV
−−  (De-Emphasized Differential Output Voltage (Ratio)) is defined in the base specification. 

Test Definition Notes from the Specification: 
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- This is the ratio of the pDIFFpTXV
−−  of the second and following bits after a transition divided by the 

pDIFFpTXV
−−  of the first bit after a transition. 

- Specified at the measurement point into a timing and voltage compliance test load as shown in the base 

specification over the specified number of UIs. Also refer to the transmitter compliance eye diagram 

shown the base specification. 

Limits: 

Refer to Table 2 for specified limits on the RATIODETXV
−−

 measurement.   

Test Procedure: 

Ensure that De-Emphasis is selected in the Analyze > Jitter and Eye Analysis > Select > Ampl > T/nT 

Ratio menu. 

 

Measurement Algorithm: 

The de-emphasis measurement calculates the ratio of any non-transition eye voltage (2
nd

, 3
rd

, etc. eye 

voltage succeeding an edge) to its nearest preceding transition eye voltage (1
st
 eye voltage succeeding an 

edge). In Figure 6, it is the ratio of the black voltages over the blue voltages. The results are given in dB.  

 

Figure 6. De-emphasis measurement 
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or 





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Where: 

TRANHIEYEv
−−  is the high voltage at mid UI following a positive transition 

TRANLOEYEv
−−  is the low voltage at mid UI following a negative transition 

NTRANHIEYEv
−−  is the high voltage at mid UI following a positive transition bit 

NTRANLOEYEv
−−  is the low voltage at mid UI following a negative transition bit 

m is the index for all non-transition UIs 

n is the index for the nearest transition UI preceding the UI specified by m 

 

4.10  Minimum TX Eye Width MOI 

 

Definition: 

EYETXT
−

 
(Minimum TX Eye Width) is defined in the base specification. It is defined as, clear 

horizontal eye opening at the middle reference level.  

Width = UI(mean) – TIE(max) – TIE(min) 

  

Limits: 

Refer to Table 2 for specified limits on the EYETXT
−

 measurement.  

 

Test Procedure: 

Ensure that Eye Width is selected in the Select menu. 

Measurement Algorithm: 

The Eye Width measurement is the measured minimum horizontal eye opening at the zero 

reference level.  

The application calculates this measurement using the following equation: 

TEYE-WIDTH = UIAVG - TIEpk-pk 
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Where:  

UIAVG is the average UI.  

TIEpk-pk is the Peak-Peak TIE.  

 

4.11 TX Delta DC Common Mode Voltage MOI 

 

Definition: 

DELTALINEDCCMTXV
−−−−

 
 (Absolute Delta of DC Common Mode Voltage between D+ and D-) is defined in 

the base specification.  

Test Definition Notes from the Specification: 

||

||

25||

)(

)(

−−−−−−

+−+−−

−−−−+−−−

=

=

≤−

DTXavgDDCCMTX

DTXavgDDCTXCM

DDCCMTXDDCCMTX

VofDCV

VofDCV

mVVV

 

- Specified at the measurement point into a timing and voltage compliance test load as shown in the base 

specification and measured over the specified number of UIs. 

Limits: 

Refer to Table 2 for specified limits on 
DELTALINEDCCMTXV

−−−−
 measurement. 

Test Procedure: 

Ensure that Differential Average is selected in the Measurements> Select menu. 

Measurement Algorithm: 

The Differential Average measurement returns the mean of the differential voltage waveform.  

))(( ivMeanV DIFFAVGDIFF =
−  

Where: 

i is the index of all waveform values 

DIFFv
 is the differential voltage signal 

   

4.12  TX AC Common Mode Output Voltage MOI 

 

Definition:  
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ACpCMTXV
−−  (RMS AC Pk Common Mode Output Voltage) is defined in Rev1.0a Base Specification. The 

nomenclature ACp is retained to be consistent with the specification. However, the measurement is 

defined and reported as an RMS value, not a Pk value. 

Test Definition Notes from the Specification: 

|
2

|)|
2

(| )(
−−+−

−−−−

−−+−

−−

+
=−

+
=

DTXDTX

avgDCCMTXDCCMTX

DTXDTX

ACpCMTX

VV
ofDCVV

VV
RMSV  

- Specified at the measurement point into a timing and voltage compliance test load as shown in the base 

specification and measured over the specified number of TX UIs. 

Limits: 

Refer to Table 2 for specified limits on ACpCMTXV
−−   measurement. 

Test Procedure: 

Ensure that AC CM Voltage is selected in the Measurements> Select menu. 

Note: This measurement is available only when the probe type is single-ended.  

Measurement Algorithm:  

AC CM RMS Voltage: The AC Common Mode RMS Voltage measurement calculates the RMS 

statistic of the common mode voltage waveform with the DC value removed. 

))(()( ivRMSiv MACCMRMSAC −−−
=  

Where: 

i is the index of all waveform values 

CMRMSACv
−−

 is the RMS of the AC common mode voltage signal 

MACv
−

 is the AC common mode voltage signal 

 

4.13  SSC Modulation Rate MOI 
  

SSC measurements are made by applying a 2MHz Low Pass Filter to the Data Period measurement and 

creating a plot of the SSC profile. Cursors can be used to investigate the detail of the SSC profile. Data 

jitter, voltage, and eye diagram measurements are made by applying a Type II Golden PLL clock recovery 

with a loop BW of 10MHz to the data signal under test.  

Measurement Algorithm: 

Run the Period measurement with a low pass filter of cutoff frequency 10MHz.   In the Informative 

Setup files a second Period measurement (Period2) is used to provide the filtered measurement to be 

plotted.     
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Plot the time trend. (DPOJET  � Plots � Time trend; see the below figure) 

 

 

Place the vertical cursor at the zero crossings and find the ∆x (as in the figure) . Now one can 

calculate the SSC modulation rate as 

SSC modulation rate = 1/ ∆x 

 

4.14  SSC Deviation MOI 

 

Measurement Algorithm: 

Run the Period measurement with a low pass filter of cutoff frequency 10MHz. In the Informative 

Setup files a second Period measurement (Period2) is used to provide the filtered measurement to be 

plotted.     

Plot the time trend. (DPOJET  � Plots � Time trend; see the below figure) 

 

 

 

Place the horizontal cursor to find the peak to peak value-∆y (as in the figure) to find the SSC deviation.   

SSC Deviation = ∆y  


