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1 Introduction to the DPOJET USB 3.0 Setup Library 
 

This document provides the Methods of Implementation (MOI) for making USB 3.0 measurements with 
Tektronix DPO/DSA70000 Series real time oscilloscopes (8 GHz models and above) and probing solutions.  

DPOJET (Jitter and Eye Analysis Tools) is available on DPO/DSA70000 Series instruments. Instrument 
Setup files using DPOJET measurements are used to perform USB 3.0 specific measurements. DPOJET 
along with its associated setup files, provides transmitter path measurements (amplitude, timing, and jitter), 
waveform mask testing and limit testing described in the USB 3.0 specification at respective test points. 

 

Table 1 – Supported Specifications 
Spec Revision USB 3.0  Specification Title MOI Test Points Defined 

Rev1.0 Universal Serial Bus 3.0 Specification Informative Transmitter and Normative 
Transmitter 

 

Refer to http://www.usb.org/developers/docs/usb_30_spec.zip for the latest specifications.  

In the subsequent sections, step-by-step procedures are described to help you perform USB 3.0 
measurements. Each measurement is described as a Method of Implementation (MOI).  

For the latest version of this document and the latest USB 3.0 DPOJET Setup Library refer to 
www.tek.com/software, (keyword ‘DPOJET USB 3.0’).  

For further reference on USB test specifications and compliance testing, consult documents offered to USB-
IF members at www.usb.org.  
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2 USB3.0 Physical Layer - Transmitter Specifications 
   

2.1 Differential Transmitter (TX) Eye Diagrams 
Fixture-1 shows the eye mask definitions for the USB 3.0. The eye diagrams are a graphical 
representation of the voltage and time limits of the signal. This eye mask applies to jitter after the 
application of the appropriate jitter transfer function and reference receiver equalization. In all cases, the 
eye is to be measured for 106 consecutive UI. The budget for the link is derived assuming a total 10-12 bit 
error rate and is extrapolated from a measurement of 106 UI assuming the random jitter is Gaussian.  

Referring to the figure, the time is measured from the crossing points of Txp/Txn. The time is called the 
eye width, and the voltage is the eye height. The eye height is to be measured at the maximum opening 
(at the center of the eye width ± 0.05 UI).  

The eye diagrams are to be centered using the jitter transfer function (JTF). The recovered clock is 
obtained from the data and processed by the JTF. The center of the recovered clock is used to position the 
center of the data in the eye diagram. 

   The eye diagrams are to be measured into 50-Ω single-ended loads. 

 

 

Figure 1: Generic Eye Mask 

This section provides a summary of the test parameters measured in DPOJET and how they are related to the 
symbol and test limits in the specification.    
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2.2  SuperSpeed USB Setup Library 
The SuperSpeed USB Setup Library consists of the following software file types. 

 

USB 3.0 Setup Files for the DPO/DSA70000 
System Location: C:\TekApplications\DPOJET\Setups\USB  

Description: The USB folder contains two sub folders, Host and Device. Under these two folders, 
according to the test points(Normative and Informative) and DUT signals (CP0, CP1 and LFPS) setup files 
are created.  Refer to Section 3.5 of this document for further description.  

Saved Setups have been created by using the Save > Setup function of the DPO/DSA70000 Series 
oscilloscope. If any changes are made to the Setup file it is recommended you re-save the file as a different 
name so not to change the parameters in the distribution files.  

 
USB 3.0 Channel Model Filters 

Filter Library File Path: C:\TekApplications\DPOJET\Filters\USB    

Description: The USB 3.0 Math Arbitrary Filters library allows you to perform SW Channel Emulation of 
the reference channels defined in the specification. Refer to Section 3.5 for details and a full listing of the 
available filters in the distribution. 

 
USB 3.0 Waveform Masks 

Mask Library File Path: C:\TekApplications\DPOJET\Masks\USB 

Description: The USB 3.0 Mask library contains the waveform mask files used by the various setup files. 
Waveform masks are used to perform Pass/Fail template testing on the waveform eye diagram. Refer to 
Section 3.5 for a full listing and description of the masks available in the distribution.  

 

USB 3.0 Limits Files 
Limit Library File Path: C:\TekApplications\DPOJET\Limits\USB 

Description: The USB 3.0 Limits library contains the measurement limit files used by the various setup 
files. Measurement limits are used to provide Pass/Fail indication for each measurement. Refer to Section 
3.5 for a full listing and description of the masks available in the distribution.  

 

Important:  The Setup file defines the system location of the Channel Model Filter, Mask, and Limits files 
used for the test. Thus, all files must be in the proper location for correct operation.  
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2.3 Differential Transmitter Specifications (Informative & Normative) 
The following table shows the available measurements in DPOJET and their test limits defined at each test 
point in the Specification. The Informative Tx test point is defined at the pins of the transmitter device in a 
USB 3.0 link. The Normative Rx test point is defined at the end of a reference channel.  

   Table 2- Supported MOIs - USB 3.0 specification transmitter measurements 

Measurements Supported in Setup Files 

Spec 
Reference Symbol(s) Parameter 

DPOJET 

Measurement 

Method 

Informative 

Tx  

(ie, Near-end) 

Informative 

Tx Low Power 

(ie, Near-end) 

Normative 

Rx  

(ie, far-end) 

Figure 6-9 Clock Recovery   

2nd Order PLL 

Fc = 4.9MHz 

0.707 Damping 

2nd Order PLL 

Fc = 4.9MHz 

0.707 Damping 

2nd Order PLL 

Fc = 4.9MHz 

0.707 
Damping 

Table 6-12 Eye Height Transmitter Eye 
Mask 

Eye Height1  

(Tbit or Both) 

Eye Height2 

(nTbit with De-
Emphasis) 

Height1:   

0.8 V (min) 

Height2: 

0.505 V (min) 

Height 1: 

0.4 V (min) 

Height1: 

100mV (min) 

 

Table 6-11 TTX-EYE 
Transmitter Eye - 
Dual Dirac at 10-12 
BER 

Width@BER (min) 

 

0.625 UI (min) 

125 ps (min) 

0.625 UI (min) 

125 ps (min) 

0. 34 UI (min) 

68 ps (min) 

Table 6-8 

Table 6-12 
Dj, TTX-DJ-DD 

Tx deterministic 

Jitter – Dual Dirac 

DJ–δδ 

(max) 

0.205 UI (max) 

 41 ps (max) 

0.205 UI (max) 

 41 ps (max) 

0.43 UI (max) 

86ps (max) 

Table 6-8 

Table 6-12 

Rj  

 
Tx random jitter -  
Dual Dirac 

RJ–δδ 

(max) 

0.0121 UI (max) 

2.42 ps (max) 

RMS 

0.0121 UI (max) 

2.42 ps (max) 

RMS 

0.23 UI (max) 

46 ps (max) 

Pk-Pk 

3.29  ps (max) 

RMS 

Table 6-8 

Table 6-12 
Tj 

Tx total jitter - 
Dual Dirac at 10-12 
BER 

TJ@BER (max) 
0.375 UI (max) 

75 ps (max) 

0.375 UI (max) 

75 ps (max) 

0.66 UI (max) 

132 ps (max) 

Table 6-10 UI 
Unit Interval  

(no SSC) 
USB UI 

199.94 (min) 

200.06 (max) 

199.94 (min) 

200.06 (max) 

199.94 (min) 

200.06 (max) 

Table 6-10 
VTX-DIFF-PP 

VTX-DIFF-PP-
LOW 

Differential p-p 

Tx voltage swing 
USB VTx-Diff-PP 

(max/min) 

0.8 V (min) 

1.2 V (max) 

0.4 V (min) 

1.2 V (max) 

100mV (min) 

1.2 V (max) 
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Measurements Supported in Setup Files 

Spec 
Reference Symbol(s) Parameter 

DPOJET 

Measurement 

Method 

Informative 

Tx  

(ie, Near-end) 

Informative 

Tx Low Power 

(ie, Near-end) 

Normative 

Rx  

(ie, far-end) 

Table 6-10 VTX-DE-RATIO De-emphasized 
output voltage ratio T/nT Ratio (max/min) -3.0 dB (min)      

-4.0 dB (max)   

Table 6-10 Tcdr_SLEW_MAX Maximum Slew 
Rate (df/dt) USB TCdr-Slew-Max 10ms/s (max) 10ms/s (max) 10ms/s (max) 

Table 6-11 tMIN-PULSE-Tj Tx min pulse USB Tmin-Pulse-Tj 0.90 UI (max)     
180 ps (max) 

0.90 UI (max) 
180 ps (max)  

Table 6-11 tMIN-PULSE-Dj 
Deterministic  min 
pulse USB Tmin-Pulse-Dj 0.96 UI (max) 

192 ps (max) 
0.96 UI (max) 
192 ps (max)  

Table 6-11 VTX-DC-CM Txr DC Common 
mode voltage 

Common Mode       
Mean (min/max) 

0 (min)           
2.2 (max) 

0 (min)           
2.2 (max)  

Table 6-11 VTX-CM-AC-
PP-ACTIVE 

Tx AC Common 
mode voltage active 

Common Mode         
Pk-Pk (max) 2.2 V (max) 100 mV (max)  

Table 6-9 tSSC-MOD-
RATE 

SSC Modulation 
Rate USB-SSC-MOD-RATE 30 KHz (min)     

33 kHz (max) 
30 KHz (min)     
33 kHz (max) 

30 KHz (min)     
33 kHz (max) 

Table 6-9 
tSSC-FREQ-
DEVIATION-
MAX 

SSC Deviation Max SSC-FREQ-DEV-MAX 

+300 to -300 ppm 
(min) 

+300 to -300 ppm 
(max) 

+300 to -300 ppm 
(min)          

+300 to -300 ppm 
(max) 

+300 to -300 
ppm (min)        

+300 to -300 
ppm (max) 

Table 6-9 
tSSC-FREQ-
DEVIATION-
MIN 

SSC Deviation Min SSC-FREQ-DEV-MIN 
-3700 to -5300 

ppm (min)          
-3700 to -5300 

ppm (max) 

-3700 to -5300 
ppm (min)          

-3700 to -5300 
ppm (max) 

-3700 to -5300 
ppm (min)        

-3700 to -5300 
ppm (max) 

Table 6-10 tPeriod LFPS Period Period   20 ns(min)       
100 ns(max) 

Table 6-10 Vcm-AC-LFPS LFPS Common 
mode voltage Common Mode   100mV(max) 

Table 6-10 tRiseFall2080 LFPS Rise Time Rise Time   4 ns(max) 

Table 6-10 tRiseFall2080 LFPS Fall Time Fall TIme   4 ns(max) 

Table 6-10 Duty Cycle LFPS Duty Cycle +Duty Cycle   40%(min) 
60%(max) 

Table 6-10 Vtx-DIFF-PP-
LFPS 

Differential p-p 
LFPS voltage 
swing 

USB VTx-Diff-PP   0.8 V (min)        
1.2 V (max) 
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3 Preparing to Take Measurements 
 

3.1 Required Equipment 
The following equipment is required to take the measurements: 
• Oscilloscope:  

It is recommended that ≥12.5 GHz system BW is used for USB 3.0 Informative measurements or 
normative measurements when channel emulation is being used. This ensures that any 5th harmonic 
frequency content is considered in the analysis. Tektronix models that meet this recommendation are 
DPO/DSA71254 and above. The DPO70804 (8 GHz) model is also suitable for Normative measurements 
if the waveform is being acquired at the receiver (TP1 defined in Figure 6-14 of the specification).  

• DPOJET Jitter and Eye Analysis Tool application (v1.2.0 build2 or later) installed. 
• SDLA software for Channel De-Embed and custom filter development (optional) 
• Probes – Two TCA-SMA or one P7300SMA/P7500 differential probe. 
• SMA Breakout Fixture - 'Early' breakout fixture are orderable directly from Ellisys Corp. 

www.ellisys.com (It's Japan distributor: www.gailogic.co.jp) 
• AWG7122B Arbitrary Waveform Generator (v3.0.136.602 or later) (optional) for initiating electrical 

loopback and receiver testing(optional).  

 

3.2 Probing Options for Transmitter Testing 
 

Two TCA-SMA Connectors (Ch1-Ch2 Pseudo-Differential) 
The differential signal is created by the DPOJET from the math waveform Ch1-Ch2. This probing 
technique requires breaking the link and terminating into a 50 Ω/side termination of the oscilloscope. Ch-
Ch deskew is required using this technique because two channels are used. This configuration does not 
compensate for cable loss in the SMA cables. The measurement reference plane is at the input of the 
TCA-SMA connectors on the oscilloscope. Any cable loss should be measured and entered into the 
vertical attenuation menu for accurate measurements at the SMA cable attachment point. 

 

One P7300SMA Differential SMA Probe (Ch1 True Differential) 
The differential signal is measured across the termination resistors inside the P7300SMA series probe. 
This probing technique requires breaking the link. Matched cables are provided with the probe to avoid 
introducing deskew into the system. Only one channel of the oscilloscope is used. The P7300SMA 
provides a calibrated system at the Test Fixture attachment point, eliminating the need to compensate for 
cable loss associated with the probe configuration. The P7300SMA series is best suited for Compliance 
applications where the link is broken.  

 

One P7500 Tri-Mode  Differential Probe (Ch1 True Differential) 
The differential signal is measured across the termination resistors inside the DUT. Probing must be 
performed at TP1 in the system (at the receiver pins) to be considered valid per the specification. This 
probing technique can be used in an active system and the exact compliance test pattern may not be 

DPOJET USB3.0 MOI     6 
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available.  Only one channel of the oscilloscope is used. The P7500 Tri-Mode probe provides the added 
ability to view and make measurements on D+, D-, Ddiff, and Dcm with a single probing connection. 
The P7500 Tri-Mode probe is better suited for Design Validation and Debug applications where the DUT 
is in an active system.  

 

3.3 Initial Oscilloscope Setup 
After connecting the DUT by the proper probing configuration for the test, click DEFAULT SETUP and 
turn on Ch2 to view the signal. 

 

3.4 Accessing the DPOJET USB 3.0 Measurement Menu 
1. On DPO70000 series, go to Analyze> USB 3.0 Essentials 

 

Figure 2: Default menu of the DPOJET software 

Figure  shows the oscilloscope display. The default mode of the software is the Serial Analysis 
module. 
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3.5 Configuring the Software to take various measurements  
    

Selecting Measurements 

In the DPOJET USB 3.0 menu, select the desired measurements. One can select either a single 
measurement or recalling a setup file he/she can run multiple measurements at a time. Recalling 
the setup files will give all the required setup for those measurements by default. 

 
Figure 3: Jitter and Eye Analysis window for single measurement selection 

 

Selecting Limit Files 

 If a measurement has a pass/fail limit associated with it in the test point file, go to 
Analyze>Jitter and Eye Analysis>Limits to select the limit file from the folder where the limit 
files are saved. Measurements with pass/fail limits will show up in the Results Summary panel 
when the compliance test is run.  

 

Configure Mask file: 
i. In the DPOJET application go to ‘Plots’ if you want to enable the Mask file. 

ii. Select measurement from the measurement column. 

iii. Click ‘Configure’ to change the default setup for that measurement. The mask 
selection window opens as shown: 

iv. In the Mask file selection window, press the ‘Off’ button first and then click 
‘Browse’ to select the Mask file. 

DPOJET USB3.0 MOI     8 
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Figure 4: Mask File Selection 
 

v.  Select the relevant mask file (For example, USB_3_0_NORMATIVE.msk) file and 
click ‘Open’. 

vi.  Enable the file by selecting the ‘On’ button, and click OK. 

 

Configuring Source of Waveforms 
           Source selections are dependent on which probe type is selected. The selections are as 
 follows: 
   If Differential is selected as Probe Type:  

• Live/Ref/Math source selection (uses single differential signal as data source) 

 Live channel selections–Ch1, Ch2, Ch3, Ch4 

 Reference waveform selections–Ref1, Ref2, Ref3, Ref4 

• File source selection <TBD> 

 
  If Single-Ended is selected as Probe Type:  

• Live/Ref/Math1 source selection (uses two single-ended signals as data source) 

Live source selections–Select Math1 and then put (Ch1-Ch2), (Ch1-Ch4), (Ch2-Ch3), (Ch2-Ch4) which one is 
required in Math1. Select Math1 to perform selected measurement. 

• Reference waveform selections – Select Math1 and then put (Ref1-Ref2), (Ref1-Ref4), 
(Ref2-Ref3), (Ref2-Ref4) which one is required in Math1. Select Math1 to perform selected 
measurement.    
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Configure Clock Recovery 
 In the Configure menu, select Clock Recovery and select the type of clock recovery to be used. 

 

Figure  5. Clock recovery 

  From the Figure. 6.9 in base specification, Clock recovery configuration is given below. 

  Select Method >PLL-Custom Bandwidth. 

  Select PLL Model > Type II 

  Select Damping > 0.707 

  Select Bandwidth 4.9MHz. select  Advanced button and configure Bit Rate to 5Gb/s. 

  If more than one measurement is selected at a time, then click Apply to All buttons. 
 

 

Figure 6: Clock Recovery selection window 
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Source and Reference Level Autoset  
Below steps are recommended before taking any measurement. However, these steps are not 
required if you are using the setup files. 

Select the 'Source Configuration' window  (Figure 1)  
Press 'Vert & Horiz' under 'Source Autoset'  

 

Figure 7: Source Configuration window 
 
Press 'Autoset' under 'Reverence Levels Source Configuration' 
 
Horizontal Setup  
Now go to the 'Horiz/Acq'  'Horizontal /Acquisition Setup'  
 

 

Figure 8: Horizontal/Acquisition setup 
Change the 'Record Length' to the required value.  
 
For all the measurements 10M record length (at 50GS/s sample rate) is required to meet the 
specification.  
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Selecting a Test Point and Channel Model 
Two compliance points are defined in the specification - Normative Transmitter Test Point 
(TP1) and Informative Transmitter Test Point. 
 

Normative Transmitter Test Point (TP1) 
Table 6-12 of USB 3.0 specification represents the Normative Test Point, defined as TP1 in 
Figure 6-14 in the specification. Compliance measurements in Table 6-12 are made after 
acquiring the waveform at ‘TP1’ for the device under test as shown in the following diagram. 

 

Figure 9: Test points 

The compliance channel model is combined with the CTLE (Continuous Time Linear 
Equalization) function into a single filter. (FIR filter). It is then applied to the acquired 
waveform and analyzed for compliance using DPOJET. The result gives the measurement 
values along with the Pass/Fail report.  

 
Informative Transmitter Test Point 
Tables 6-10 and 6-11 of the specification define parameters to be taken at the pins of the 
transmitter device and represent the Informative Transmitter Test Point. This test point requires 
the measurement channel be De-Embedded from the measurement. The waveform is acquired at 
‘TP1’ as with the Normative test. 
 

Channel Models: 

The Channel Models are available in the “DSA/Channel Filters” folder in the distribution, with 
the functions described as below: 
 

Table 4 – Supported Channel Models and Corresponding Pre-defined Filter Files 

Channel Model for Silicon Testing 

Filter-File Name Description of Filter Function 

USB3_Front_Cable_Device_CTLE.flt Combines Host Front Panel, Cable, Device 
Reference Channel and CTLE 
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USB3_Back_Cable_Device_CTLE.flt Combines Host Back Panel, Cable, Device 
Reference Channel and CTLE 

 

Channel Model for Host or Device Testing 

Filter-File Name Description of Filter Function 

USB3_Cable_Back_CTLE.flt Combines Cable, Host Back Panel Reference 
Channel, and CTLE for Device Testing.  

USB3_Cable_Front_CTLE.flt Combines Cable, Host Front Panel Reference 
Channel, and CTLE for Device Testing.  

USB3_Cable_Device_CTLE.flt Combines Cable and Device Reference Channel 
for Host Testing.  

 

Individual Channel Filters 

Filter-File Name Description of Filter Function 

USB3_BackPanel.flt Host Back Panel Reference Channel.  

USB3_FrontPanel.flt Host Front Panel Reference Channel. 

USB3_Cable.flt 3 Meter USB 3.0 Cable 

USB3_Device.flt Device Reference Channel 

USB3_CTLE.flt USB 3.0 CTLE Filter 
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4 USB3.0 Transmitter Test Procedure 
This section provides the Methods of Implementation (MOIs) for Transmitter tests using a Tektronix 
real-time oscilloscope, probes, and the DPOJET software.  
 

4.1 Step-by-Step Normative Testing 
The following procedure discusses how to use DPOJET to test the Normative test point in the USB 3.0 
Specification. Differences in the procedure for testing the Informative test point are discussed but not 
detailed.  

 

Initial Scope Setup 
i. Configure the DUT to transmit the compliance pattern (CP0 – Scrambled D0.0) 

ii. Connect to the Transmitter port of the DUT using one of the probing configurations 
described in Section 3.2 of this document. If using pseudo-differential input (Ch1-
Ch2), perform channel-channel deskew procedure and record the deskew value for 
Ch2. If using a differential probe de-skew is not necessary.  

iii. Press the  DEFAULT SETUP button.  

iv. Turn on Ch2 (if using pseudo-differential input) to view the signal under test. 

v. Confirm that the D0.0 pattern is being transmitted from the DUT.  

 
Figure 10: Scrambled D0.0 (CP0) Pattern 

Recalling the Setup file  
vi. Start DPOJET Application. go to Analyze> USB3.0 Essentials. 
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Figure 11: Selecting DPOJET 

 
vii. From the test point, click setup and recall the setup form USB3.0 setup library.  

 

Figure 12: Recalling Setup File 
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viii. Select the appropriate setup file from the USB setups folder. Example: Select 

USB_3_0_Normative.set to test for Compliance at TP1 of the specification.  

ix. Select ‘Recall’ to open the setup file. 

 

Adjust the Vertical Amp and ensure proper De-skew calibration 
This part of the procedure should be carried out the first time the Setup file is recalled on 
the oscilloscope to get accurate measurements. 

x. Press the Zoom button to turn off zoom.  

xi. Turn off Math2 in the Math Menu.  

xii. Adjust Horizontal Scale to 2 nsec/div. 

xiii. Press the Run/Stop button so that the acquisition is running.  

xiv. Adjust the vertical amplitude of the active channels to be 9-10 divisions on the 
screen. This takes full advantage of the oscilloscopes A/D range without clipping the 
waveform. In this below example, Ch1 and Ch2 is set to 120 mV/div. 

xv. Go to the Deskew menu and enter the proper value for Ch2.  

xvi. Adjust Horizontal Scale back to 20 usec/div. 

xvii. Turn on the Zoom and return the Zoom factor to 20000. The display should look 
similar to the following: 

 
Figure 13: Optimized Vertical Settings with 1Million UI Capture 
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Configuring the desired Test Point as Math2: 
xviii. In the ‘Math’ window, Select ‘Math2’ and then go to Math editor using ‘Editor’ 

button. 

xix. Clear the default values from the ‘math2’ using ‘Clear’ button in the Math editor. 

xx.  Go to ‘Filter’ menu in the ‘Math’ window. Select ‘Load’ button. 

xxi. From the Channel Filter File, select ‘USB3_Front_Cable_Device_CTLE’ file and 
click ‘Open’. 

 

 

Figure 14: Math2 Selection 
xxii. Click the button ‘Flt1’ from the Math Editor. Enter Ch1-Ch2 as the argument of the 

ArbFlt1 function. 

 
Figure 15: Filtering differential data signal 

xxiii. Click ‘Apply’. And then click ‘OK’ button in the Math Editor.  

xxiv. Apply ‘Ch1-Ch2’ in ‘Math1’ clicking ‘Apply’ button 
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Figure 16:  Math2 Waveform Appears 

 
Run the Normative Setup file 

xxv. After configuring the Acquisition Channel and the desired Reference Channel, return 
to Analyze > Jitter and Eye Analysis > Select. 

xxvi. Select ‘Single’ to run the setup. 

xxvii. After running the application, the results are as shown:  

 

 
Figure 17: Normative Results  
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Run and Save Test Report: 
xxviii. Select the Reports button in the DPOJET menu. 

xxix. Press the ‘Save As’ button and enter the report name. 

xxx. The Report is as shown: 

 
Figure 18: Test Report Giving Pass/Fail Status 

 

4.2 Informative Test Point Example 
The following procedure discusses how to use DPOJET to test the Normative test point in the USB 3.0 
Specification. Differences in the procedure for testing the Informative test point are discussed but not in 
detail.  

 
Figure 19: Transmitter Test Point Example 
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4.3 Informative Low Power Test Point Example 
The following procedure discusses how to use DPOJET to test the Normative test point in the USB 3.0 
Specification. Differences in the procedure for testing the Informative test point are discussed but not 
detailed.  

 
Figure 20:  Low Power Transmitter Test Point Example 

 

 

4.4 Tx Eye Height MOI 
 

Definition: 

Eye Height measurement is defined as the clear vertical eye opening at the center of the unit interval. 
Height = High(min) – Low(max)  

Limits: 

Refer to Table 1 for the specified limits on the  measurement.  EYETXT −

Test Procedure: 

Ensure that Eye Height is selected in the Select menu. 

Measurement Algorithm: 

The Eye Height measurement is the measured minimum vertical eye opening at the zero reference level.  

The application calculates this measurement using the following equation:  

There are three types of eye height values: 

Eye Height: 
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MAXLOEYEMINHIEYEHEIGHTEYE VVV −−−−− −=  

Where: 

  is the minimum of the high voltage at mid UI MINHIEYEV −−

  is the maximum of the low voltage at mid UI MAXLOEYEV −−

 Eye Height – Transition 

  MAXTRANLOEYEMINTRANHIEYETRANHEIGHTEYE VVV −−−−−−−− −=

Where: 

  is the minimum of the high transition bit eye voltage at mid UI MINTRANHIEYEV −−−

  is the maximum of the low transition bit eye voltage at mid UI MAXTRANLOEYEV −−−

 Eye Height – Non-Transition 

  MAXNTRANLOEYEMINNTRANHIEYENTRANHEIGHTEYE VVV −−−−−−−− −=

Where: 

  is the minimum of the high non-transition bit eye voltage at mid UI MINNTRANHIEYEV −−−

  is the maximum of the low non-transition bit eye voltage at mid UI MAXNTRANLOEYEV −−−

 

4.5 TX Deterministic and Random Jitter (Dual Dirac) MOI 
 

Definition: 

DJ–δδ (Deterministic jitter only assuming the Dual Dirac Distribution) Deterministic Jitter is the 
statistics for all timing errors that follow deterministic behavior. Deterministic Jitter is typically 
characterized by its peak-to-peak value. Deterministic Jitter as defined above, but calculated based on a 
simplified assumption that the histogram of all deterministic jitter can modeled as a pair of equal-
magnitude Dirac functions (impulses known as delta-functions).  

Limits: 

Refer to Table 2 for specified limits on the DJ–δδ and RJ–δδ measurements.  
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Test Procedure: 

Ensure that Jitter DJ–δδ is selected in the Select > Jitter menu. 

Measurement Algorithm: 

Dual Dirac Deterministic Jitter (DJ–δδ) is the peak-to-peak magnitude for all timing errors exhibiting 
deterministic behavior, calculated based on a simplifying assumption that the histogram of all 
deterministic jitter can modeled as a pair of equal magnitude Dirac functions (impulses). A single DJ–δδ 
value is determined for each acquisition, by means of RJ/DJ separation analysis.  

Rj/Dj Separation Based on Dual Dirac Model: 

Dual Dirac model based Rj/Dj separation method fits the Bathtub curve to a theoretical model of Rj and 
Dj where Rj is assumed to have a Gaussian distribution, Dj is assumed to have a distribution of two Dirac 
impulses with the same height. Curve fitting at different BER levels in Bathtub curve yields the standard 
deviation value of Rj and peak-to-peak value of Dj. The Bathtub curve is obtained from the spectrum 
analysis based or the arbitrary pattern analysis based Rj/Dj separation methods. Rj and Dj based on the 
Dual-Dirac model can be denoted as  and . gRJ ddDJ

After  and  are obtained, Tj can be calculated using gRJ ddDJ

ddg DJRJBERQBERTJ +×= )(2)(  

where Q is the function of BER that has a value of about 7 when . Eye opening is 
computed in the same way as it is computed in the spectrum analysis based Rj/Dj separation. 

1210 −=BER

Dual Dirac model based Rj/Dj separation method is used. Usually, actual Dj does not have a pure Dual-
Dirac distribution. So the value of  is often greater than the value of Rj obtained from the spectrum 

analysis based or the arbitrary pattern analysis based Rj/Dj separation. The value of  is often less 
than that of its corresponding one. 

gRJ

ddDJ

 

4.6 TX Total Jitter MOI 
 

Definition: 

TJ@BER (Total Jitter at a specified Bit Error Rate (BER)). This combines the Random and Deterministic 
effects, and predicts a peak-to-peak jitter that will only be exceeded with a probability equal to the BER.  

Limits: 

Refer to Table 1 for specified limits on the  measurement.  EYETXT −

Test Procedure: 

Ensure that Jitter TJ@BER is selected in the Select > Jitter menu. 
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Measurement Algorithm: 

Total Jitter at a specified Bit Error Rate (BER). This extrapolated value predicts a peak-to-peak jitter that 
will only be exceeded with a probability equal to the BER. It is generally not equal to the total jitter 
actually observed in any given acquisition. A single TJ@BER value is determined for each acquisition, 
by means of RJ/DJ separation analysis. 

 

4.7 TX Unit Interval Measurement MOI 
 

Test Definition Notes from the Specification:  

- UI (Unit Interval) is specified to be +/- 300 ppm  

- UI does not account for SSC dictated variations  

Definition:  

UI is defined in the base specification.  

Limits: 

Refer to Table 2 for specified limits on UI measurement.  

Test Procedure: 

Ensure that the Unit Interval is selected in the Measurements > Standard > USB > Select > USB UI 
menu. 

Measurement Algorithm: 

This measurement is made over the analysis window of 250 consecutive bits (or over the entire record if 
the sw PLL is used) as defined in the base specification. 

The Unit Interval measurement calculates the cycle duration of the recovered clock. 

)()1()( ntntnUI CLKRCLKR −− −+=  

))(( nUIMeanUI AVG =  

Where:  

CLKRt −  is the recovered clock edge 

n is the index to UI in the waveform 
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4.8 TX De-Emphasized Differential Output Voltage (Ratio) MOI 
Definition: 

RATIODETXV −−  (De-Emphasized Differential Output Voltage (Ratio)) is defined in the base specification. 

Test Definition Notes from the Specification: 

- This is the ratio of the  of the second bit and following bits after a transition divided by the 

 of the first bit after a transition. 

pDIFFpTXV −−

pDIFFpTXV −−

- Specified at the measurement point into a timing and voltage compliance test load as shown in the base 
specification over the specified number of UIs. Also refer to the transmitter compliance eye diagram 
shown in the base specification. 

Limits: 

Refer to Table 2 for specified limits on the  measurement.   RATIODETXV −−

Test Procedure: 

Ensure that De-Emphasis is selected in the Analyze > Jitter and Eye Analysis > Select > Ampl > T/nT 
Ratio menu. 

Measurement Algorithm: 

The de-emphasis measurement calculates the ratio of any non-transition eye voltage (2nd, 3rd, etc. eye 
voltage succeeding an edge) to its nearest preceding transition eye voltage (1st eye voltage succeeding an 
edge), it is the ratio of the black voltages over the blue voltages. The results are given in dB.  

 

Figure 21: De-emphasis measurement 
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Where: 

  is the high voltage at mid UI following a positive transition TRANHIEYEv −−

  is the low voltage at mid UI following a negative transition TRANLOEYEv −−

  is the high voltage at mid UI following a positive transition bit NTRANHIEYEv −−

  is the low voltage at mid UI following a negative transition bit NTRANLOEYEv −−

 m is the index for all non-transition UIs 

  n is the index for the nearest transition UI preceding the UI specified by m 

 

4.9  Minimum TX Eye Width MOI 
Definition: 

EYETXT −
 (Minimum TX Eye Width) is defined in the base specification. It is defined as, clear 

horizontal eye opening at the middle reference level.  

Width = UI(mean) – TIE(max) – TIE(min) 

  
Limits: 

Refer to Table 2 for specified limits on the  measurement.  EYETXT −

 

Test Procedure: 

Ensure that Eye Width is selected in the Select menu. 

Measurement Algorithm: 

The Eye Width measurement is the measured minimum horizontal eye opening at the zero 
reference level.  

The application calculates this measurement using the following equation: 
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TEYE-WIDTH = UIAVG - TIEpk-pk

 

Where:  

UIAVG is the average UI.  

TIEpk-pk is the Peak-Peak TIE.  

 

 

 

4.10   TX DC Common Mode Voltage MOI 
 

Definition: 

VTX-DC-CM  ( DC Common Mode Voltage between D+ and D-) is defined in the base specification.  

Test Definition Notes from the Specification: 

||

||
25||

)(

)(

−−−−−−

+−+−−

−−−−+−−−

=

=
≤−

DTXavgDDCCMTX

DTXavgDDCTXCM

DDCCMTXDDCCMTX

VofDCV

VofDCV
mVVV

 

- Specified at the measurement point into a timing and voltage compliance test load as shown in the base 
specification and measured over the specified number of UIs. 

Limits: 

Refer to Table 2 for specified limits on VTX-DC-CM  measurement. 

Test Procedure: 

Ensure that Differential Average is selected in the Measurements > Select> Ampl > Common Mode 
menu. 

Measurement Algorithm: 

The Differential Average measurement returns the mean of the differential voltage waveform.  

))(( ivMeanV DIFFAVGDIFF =−  

Where: 

 i is the index of all waveform values 

  is the differential voltage signal DIFFv

 

DPOJET USB3.0 MOI     26 
                                                                           



  Methods of Implementation 

4.11  TX AC Common Mode Output Voltage MOI 
 

Definition:  

ACpCMTXV −−  (RMS AC Pk Common Mode Output Voltage) is defined in Rev1.0 Base Specification. The 
nomenclature ACp-p is retained to be consistent with the specification. However, the measurement is 
defined and reported as an RMS value, not a Pk value. 

Test Definition Notes from the Specification: 

|
2

|)|
2

(| )(
−−+−

−−−−
−−+−

−−
+

=−
+

= DTXDTX
avgDCCMTXDCCMTX

DTXDTX
ACpCMTX

VVofDCVVVVRMSV  

- Specified at the measurement point into a timing and voltage compliance test load as shown in the base 
specification and measured over the specified number of TX UIs. 

Limits: 

Refer to Table 2 for specified limits on   measurement. ACpCMTXV −−

Test Procedure: 

Ensure that ‘Comm Mode Voltage’ is selected in the Measurements> Select menu. 

Select Math= (Ch1 + Ch2)/ 2 and then perform the measurement. 

Note: This measurement is available only when the probe type is single-ended.  

Measurement Algorithm:  

AC CM RMS Voltage: The AC Common Mode RMS Voltage measurement calculates the RMS 
statistic of the common mode voltage waveform with the DC value removed. 

))(()( ivRMSiv MACCMRMSAC −−− =  

Where: 

 i is the index of all waveform values 

  is the RMS of the AC common mode voltage signal CMRMSACv −−

  is the AC common mode voltage signal MACv −
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4.12 TX Differential Pk-Pk Output Voltage MOI 
Definition: 

VTX-DIFF--pp(Differential Output Pk-Pk Voltage) is defined in the base specification Rev 1.0. This 
measurement is done using T-Tx-Diff-PP measurement available under Standards >> USB 3.0 tab. The 
Result panel would display the Mean , Maximum and Minimum differential output pk-pk voltage. 

 

Test Definition Notes from the Specification: 

| - Specified at the measurement point into a timing and voltage 
compliance test load as shown in the base specification and measured over specified number of 
UIs. Also refer to the transmitter compliance eye diagram shown in the base specification.

 

|2 −−+−−− −∗= DTXDTXpDIFFpTX VVV

Limits: 

Refer to Table 2 for specified limits on the  measurement.   pDIFFpTXV −−

Test Procedure: 
Ensure that VTx-Diff-PP is selected in the Jitter and Eye diagram Analysis Tools > USB 3.0 > 
Select menu. This measurement is available under Standards > USB 3.0 tab. 

Select the Jitter and Eye diagram Analysis Tools > Configure from the panel and set the 
Configure > Clock Recovery >PLL – Custom BW > PLL model – Type II > Damping –0.707 > 
Loop BW – 4.9MHz (Which is selected by default) as shown in figure below. 

 

 
Figure 22: USB 3.0 Clock Recovery 

Configure > General >Off 

Configure > Global > Off 

 

 Measurement Algorithm: 

Differential Peak Voltage Measurement: The Differential Peak Voltage measurement returns two 
times the larger of the Min or Max statistic of the differential voltage waveform.  

)))(());(((2 ivMinivMaxMaxV DIFFDIFFPKDIFF ∗=−  
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Where:  

   i is the index of all waveform values 

     is the differential voltage signal DIFFv

 

4.13 TX Minimum Pulse Width MOI 
Definition: 

TMIN-PULSE-TJ (Instantaneous lone pulse width including all Jitter source measurement) is defined in 
the base specification Rev1.0. 

This measurement is done using the USB3.0 Tmin-Pulse-Tj measurement available under 
Standards > USB 3.0 tab. The Result panel would display the minimum pulse width results. 

Test Definition Notes from the Specification: 

TMIN-PULSE-TJ (Instantaneous lone pulse width including all Jitter source) is measured from 
transition center to the next transition center, and that the transition centers will not always occur 
at the differential zero crossing point. In particular, transitions from a de-emphasized level to a 
full level will have a center point offset from the differential zero crossing. 

Limits: 

Refer to Table 2 for specified limits on the TMIN-PULSE-TJ   measurement. 

Test Procedure: 

Ensure that Tmin-Pulse-Tj is selected in the Jitter and Eye diagram Analysis Tools > USB 3.0>  
Selectmenu. This measurement is available under Standards >  USB 3.0 tab.  

Select the Jitter and Eye diagram Analysis Tools >  Configure from the panel and set the 
Configure >  Clock Recovery > PLL – Custom BW >  PLL model – Type II > Damping –0.707 
> Loop BW – 4.9MHz (which is selected by default) as shown in figure below. 

 

Configure > General >Off 

Configure > Global > Off 

Measurement Algorithm: 
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Tmin-Pulse-Tj (minimum single pulse width TMin-Pulse including all Jitter source) is measured from 
one transition center to the next. 

The application calculates TMin-Pulse-Tj using the following equation: 

Tmin-Pulse-Tj = (Tn+1 – Tn) 

       Where: 

   Tmin-Pulse-Tj is the minimum pulse width 

              T is the transition center 

 

4.14 TX Minimum Pulse Width (Deterministic Jitter source) MOI 
Definition: 

TMIN-PULSE-DJ (Instantaneous lone pulse width including only deterministic jitter source 
measurement) is defined in the base specification Rev1.0. 

This measurement is done using the USB3.0 Tmin-Pulse-Dj measurement available under 
Standards >> USB 3.0 tab. The Result panel would display the minimum pulse width results. 

 

Test Definition Notes from the Specification: 

TMIN-PULSE-DJ (Instantaneous lone pulse width including only deterministic jitter source) is 
measured from transition center to the next transition center, and removing all random jitter 
source from the total jitter. 

Limits:                                                                                           

Refer to Table 2 for specified limits on the TMIN-PULSE-DJ   measurement. 

Test Procedure: 
Ensure that Tmin-Pulse-Dj is selected in the Jitter and Eye diagram Analysis Tools >>USB 3.0>> 
Select menu. This measurement is available under Standards >> USB 3.0 tab.  

Select the Jitter and Eye diagram Analysis Tools >> Configure from the panel and set the 
Configure >> Clock Recovery >>Constant Clock mean (Which is selected by default) as 
shown in figure below. 
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Figure 23: Clock Recovery for T-min-Pulse 

Configure > Filters >Off 

Configure > General >Off 

Configure > Global > Off 

Measurement Algorithm: 

Tmin-Pulse-Dj (minimum single pulse width TMin-Pulse including only deterministic  
  jitter) is measured from one transition center to the next. 

The application calculates Tmin-Pulse-Dj using the following steps: 

 Find the TIE trend for the given waveform 
 Take the FFT of the TIE trend.  
 Separate the Rj and Dj values from the TIE spectrum 
 Remove the Rj components from the TIE spectrum (Find the noise floor and 

   replace the Rj values with the noise values) 
 Take IFFT of the TIE spectrum without Rj component and reconstruct the clock 

   based on the TIE trend without Rj components. 
 Find the minimum pulse width in this reconstructed clock. 

 
 
4.15 TX Maximum Slew Rate MOI 

Definition: 

TCdr-Slew-Max(minimum single pulse width TMin-Pulse including all Jitter source) is defined in the 
base specification Rev1.0. 

This measurement is done using the USB3.0 T-Cdr-Slew-Max. The Result panel would display 
the maximum results. 

Test Definition Notes from the Specification: 

The CDR is a slew rate limited phase tracking function. The combination of SSC and all other 
jitter sources within the bandwidth of  the CDR must not exceed the maximum allowed slew 
rate.  The measurement is performed by filtering the phase jitter with the CDR function and 
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taking the first difference of the phase jitter to obtain the filtered period jitter. The peak of the 
peak jitter must not exceed TCdr-Slew-Max  given in the base specification.  

Limits: 

Refer to Table 2 for specified limits on the TCdr-Slew-Max   measurement. 

Test Procedure: 

Ensure that TCdr-Slew-Max is selected in the Jitter and Eye diagram Analysis Tools >>USB 3.0>> Select 
menu. 

Select the Jitter and Eye diagram Analysis Tools > Configure from the panel and set the Configure > 
Constant Clock-Mean  and, 

Configure > Filter > Low pass > 2nd Order > Frequency > 1.98 MHz (Which is selected by default) as 
shown in figure below. 

 

Figure 24: Filter for Slew measurement 

Configure > General >Off 

Configure > Global > Off 

Measurement Algorithm: 

• Find the period jitter. DPOJET period measurement with a LPF of 1.98MHz is used to find the 
period jitter. 

• Get the phase jitter (taking the cumulative sum of the period jitter gives the phase jitter) 

• Filter the phase jitter with the CDR transfer function. 

 
• Get the filtered period jitter from the phase jitter. 

• Find out the peak-to-peak period jitter. 

• Compare the peak to peak slew rate with the below specification limit. 
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4.16 TX SSC Modulation Rate MOI 
 

Definition:  

 Spread spectrum modulation, which can be defined as any modulation technique that requires a 
 transmission bandwidth much greater than the modulating signal bandwidth, independently of 
 the bandwidth of the modulating signal.

 

Test Definition Notes from the Specification:  

-- All ports are required to have Spread Spectrum Clocking(SSC) modulation. 

-- The SSC Modulation may not violate phase slew rate specification. 
 

 

                              Figure 25: Period Modulation from triangular SSC 

Limits:  

Refer to Table 2 for specified limits on tSSC-MOD-RATE measurement. 

 

Test Procedure:  

Ensure that  TSSC-MOD-RATE is selected in the Jitter and Eye diagram Analysis Tools >USB 3.0 
Essentials > Select menu.  

Select the Jitter and Eye diagram Analysis Tools > Configure from the panel and set the 
Configure > Constant Clock > Mean and,  

Configure > Filter > Low pass > 2
nd 

Order > Frequency > 1.98 MHz (Which is elected by 
default) as shown in figure below.  
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Figure 26: Filter for SSC Mod Rate  measurement  

Configure > General >Off  

Configure > Global > Off 

 

Measurement Algorithm: 

• Run the measurement and get the SSC profile 

• Find the 50% edges on the SSC profile. 

• Find time difference between the  consecutive crossings of the mid reference voltage level ( Δt =  
Tn+1 - Tn ; where Tn - is the VRefMid crossing time, Tn+1 – is next VRefMid crossing  time) 

• Calculate the Modulation Rate as 1/Δt ( Modulation Rate = 1/Δt ) 
 

4.17  TX SSC Frequency Deviation Max MOI  
 

Definition:  
SSC Frequency Deviation Max, can be defined as the maximum frequency shift as a function of 
time.

Test Definition Notes from the Specification:  
-- The data rate is modulated from 0 to -5000 ppm for nominal data rate frequency and scales 
with data rate. 

-- This is measured below 2MHz only. 

Limits:  
Refer to Table 2 for specified limits on tSSC-FREQ-DEV-MAX measurement. 

Test Procedure:  

Ensure that  SSC-FREQ-DEV-MAX is selected in the Jitter and Eye diagram Analysis Tools 
>>USB 3.0 Essentials >> Select menu.  
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Select the Jitter and Eye diagram Analysis Tools >> Configure from the panel and set the 
Configure >> Constant Clock-Mean and,  

Configure >> Filter >> Low pass >> 2
nd 

Order >> Frequency >> 1.98 MHz (Which is 
selected by default) as shown in figure below.  

 

Figure 27: Filter for SSC Frequency Deviation Max measurement  

Configure >> General >>Off  

Configure >> Global >> Off 

 

Measurement Algorithm: 

• Find the 50% edges on the SSC profile 

• Between the 'n' and 'n+1' th edge find the High value.  

• Find the Maximum Frequency deviation as High. 

• Freq Dev Max (ppm) = {(Maximum Frequency - nominal Data rate)/ nominal Data rate} * 1e6. 
Represent the FreqDev in terms of ppm (parts per million)  

 

4.18 TX SSC Frequency Deviation Min MOI  
 

Definition:  
SSC Frequency Deviation Min, can be defined as the minimum frequency shift as a function of 
time.

Test Definition Notes from the Specification:  

-- The data rate is modulated from 0 to -5000 ppm for nominal data rate frequency and scales 
with data rate. 

-- This is measured below 2MHz only. 
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Limits:  

Refer to Table 2 for specified limits on tSSC-FREQ-DEV-MIN measurement. 

Test Procedure:  

Ensure that  SSC-FREQ-DEV-MIN is selected in the Jitter and Eye diagram Analysis Tools 
>>USB 3.0 Essentials >> Select menu.  

Select the Jitter and Eye diagram Analysis Tools >> Configure from the panel and set the 
Configure >> Constant Clock-Mean and,  

Configure >> Filter >> Low pass >> 2
nd 

Order >> Frequency >> 1.98 MHz (Which is 
selected by default) as shown in figure below.  

 

Figure 28: Filter for SSC Frequency Deviation Min measurement  

Configure >> General >>Off  

Configure >> Global >> Off 

 

Measurement Algorithm: 

• Find the 50% edges on the SSC profile 

• Between the 'n' and 'n+1' th edge find the Low value.  

• Find the Minimum Frequency deviation as Low. 

• Freq Dev Min (ppm) = {(Minimum Frequency - nominal Data rate)/ nominal Data rate} * 1e6. 
Represent the FreqDev in terms of ppm (parts per million)  
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4.19 LFPS Measurements MOI 
 

Definition:  

Low Frequency Periodic Signaling (LFPS) is used for side band communication between two 
ports across a link that is in a low power link state. There are few parameters which have to 
measure to perform complete LFPS measurements. Those parameters are: tperiod, 
tRiseFall2080, Duty cycle, VCM-AC-LFPS, and VTX-DIFF-PP-LFPS. 

Limits:  
Refer to Table 2 for specified limits on LFPS measurements. 

Test Procedure:  

Scope Settings: 
 Enable Ch1 and Ch 2 and set the vertical scale to 100mV/Div.  
 Set the Record Length to 5M and Sample rate to 50GS/s. 
 Trigger on Ch1 and set the Trigger level to 50 mV. Put the acquisition mode into 

‘Single’. 
 Math Settings:  

 Go to Math Setup and set Math1-Math4 with the following: 
 Math1=CH1-CH2. 
 Math2=Arbfilt(Math1). Use usb3_Cable_Device_CTLE.flt filter for Host and 

USB3_Cable_Back_CTLE.flt filter for Device. 
 Math3=Arbfilt(CH3). Arbfilt equals a 30 KHz High Pass filter. 
 Math4=Arbfilt(CH4). Arbfilt equals a 30 KHz High Pass filter 

 

To measure all LFPS parameters, select the following measurements from Jitter and Eye 
Analysis >> Select menu. 

LFPS Parameter DPOJET measurement Source 

tPeriod Period Math1 

Duty Cycle + Duty Cycle Math2 

tRiseFall2080 Rise Time Math2 

tRiseFall2080 Fall Time Math2 

VCM-AC-LFPS Common Mode Math3,Math4 

VTX-DIFF-PP-LFPS USB VTx-Diff-PP Math1 
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Select the measurements listed above and from Jitter and Eye diagram Analysis Tools >> 
Configure tab, set Configure >>Global >> Gating >> Cursors. All other configurations are by 
default.  

 

Figure 29: Gating for LFPS  measurements 
 

Measurement Algorithm: 

 
Figure 30: LFPS signaling 

 

• For tperiod, tRiseFall2080, Duty cycle, VCM-AC-LFPS, and VTX-DIFF-PP-LFPS 
measurements the start of an LFPS burst is defined as starting when the absolute value of 
the differential voltage has exceeded 100 mV and the end of an LFPS burst is defined as 
when the absolute value of the differential voltage has been below 100 mV for 50 ns.   

• LFPS parameters are only measured during the period from 100 nanoseconds after the 
burst start to 100 nanoseconds before the burst stop. 
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