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1 Introduction to the DPOJET PCI Express Setup 

Library
1
 

This document provides the procedures for taking PCI Express measurements with Tektronix 

DPO/DSA70000 Series Oscilloscopes with DPOJET (Jitter and Eye Analysis Tools) and probing 

solutions.  

DPOJET and its PCI Express Setup Library provide transmitter path measurements (amplitude, timing, 

and jitter), waveform mask, and limits testing described in multiple variants of the PCI Express 

specifications.  

Table 1 – Supported Specifications in the DPOJET Setup Library 

Test Methods Spec 
Revision 

PCI Express Specification Title Test Points Defined 

Rev1.1 Rev 1.1 Base Specification Transmitter & Receiver 

 (Section 4.3) 

Rev 1.1 CEM Specification System and Add-In Card  

(Section 4.7) 

Reference Clock (Section 2.1) 

Rev 1.1 MXM Specification  System and Module(0 & 3.5dB 
DeEmphasis)(Section 2.4 & 2.5) 

Rev 1.1 Ref Clock Specification Reference Clock(Section 2.6) 

Rev 1.0 Express Module Specification  Transmitter Path and System Board (Section 
5.4) 

Rev 1.0 PCMCIA Express Card Standard Host System Transmitter 

Express Card Transmitter 

(Section 4.2.1.2) 

 

Rev2.0  

 

Rev 1.0 External Cabling Specification Transmitter and Receiver Path (Section 2.12 
& 2.13) 

Rev 2.0 External Cabling Specification Transmitter and Receiver Path (Section 2.12 
& 2.13) 

Rev 2.0  Base Specification  Transmitter & Receiver (Section 4.4) 

Mobile Low Power Transmitter (Section 4.4) 

Rev 2.0  CEM Specification  System and Add-In Card (3.5 & 6dB 
DeEmphasis) 

(Section 4.7) 

                                                           
1 Disclaimer: The tests provided in DPOJET (which are described in this document) do not guarantee PCI Express compliance. The test results 

should be considered “Pre-Compliance”. Official PCI Express compliance and PCI-SIG Integrator List qualification is governed by the PCI-SIG 

(Special Interest Group) and can be achieved only through official PCI-SIG sanctioned testing.   
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Test Methods Spec 
Revision 

PCI Express Specification Title Test Points Defined 

Rev1.1 MXM Specification  System and Module(0 & 3.5dB 
DeEmphasis)(Section 2.4 & 2.5) 

Rev3.0  

 

Rev 1.0 Base Specification  Transmitter  

(Table 3) 

Rev 0.9 CEM Specification System and Add-In Card  

(Table 5 & 6) 

Rev 1.0 Gen2 & Gen3 Ref Clock Specification Reference Clock(Section 2.6, Table 7B & 
7C) 

Refer to http://www.pcisig.com/specifications/pciexpress/ for the latest specifications.  

In this document, for all references to the PCI Express Base Specifications and Card Electrical 

Mechanical (CEM) specifications, refer to all versions of the specifications. (Rev 1.1, 2.0, and 3.0). 

Differences between the specifications are specifically called out when appropriate.  

In the subsequent sections, step-by-step procedures are described to help you perform PCI Express 

measurements. Each measurement is described as a Method of Implementation (MOI). For further 

reference, consult the Compliance checklists and tools offered to PCI-SIG members at www.pcisig.com. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.pcisig.com/specifications/pciexpress/
http://www.pcisig.com/
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2 PCI Express Specifications 
As shown in Table 2, Electrical Specifications for PCI Express are provided in multiple documents. This 

section provides a summary of the measurement parameters measured in the DPOJET Setup Library 

module and how they are related to the symbol and test limits in the specification.    

2.1  Differential Transmitter (TX) Output Specifications 

 

The following table shows the available measurements in the PCE Module and their test limits defined in 

each of the Base Specifications.   

Table 2- Supported Base Specification transmitter measurements    

Parameter Symbol(s) 

DPOJET  

Measurement 

Specification 

2.5GT/s 
Rev1.1/Rev2.0 

5.0 GT/s 
Rev2.0  

8.0 GT/s 
Rev3.0  

Clock Recovery NA See Setup by Data Rate >> 1st Order PLL 

Fc: 1MHz 

Emulates 1st 
Order filter at 

1.5MHz with 75% 
edge density of 

Compliance 
Pattern 

2nd Order PLL 
CDR w/ .707 

Damping  

Fc: 1.0MHz 

- And -  

3rd  Order LPF 

Fc: 1.5MHz 

Emulates Step 
Function Filter at 

1.5MHz 

1st Order PLL 

Fc: 10MHz 

Assumes 
Scrambled 
Compliance 

Pattern with 50% 
Edge Density 

Unit interval  UI PCIe UI 

(min/max) 

SSC filtered with 3rd order 
HPF: Fc = 198kHz 

399.88 (min) 

400.12 (max) 

199.94 (min) 

200.06 (max) 

124.9625 (min) 

125.0375 (max) 

Differential p-p TX 
voltage swing 

pDIFFpTXV   

VTX-SWING 

VTX-EYE-FULL 

PCIe T-Tx-Diff-PP 

Eye Height
 

0.8 V (min) 

1.2 V (max) 

0.8 V (min) 

1.2 V (max) 

TBD 

1.2 V (max) 

Low power differential   
p-p TX voltage swing 

VTX-SWING-LOW 

VTX-EYE-HALF 

PCIe T-Tx-Diff-PP 

Eye Height
 

Not Specified 0.4 V (min) 

0.7 V (max) 

0.1 V (min) 

0.8 V (max) 

De-emphasized output 
voltage ratio 

RATIODETXV   PCIe T/nT Ratio 

 

-3.0 dB (min) 

-4.0 dB (max) 

-5.5 dB (min) 
-6.5 dB (max) 

or 
-3.0 dB (min) 
-4.0 dB (max) 

Not Specified 

Instantaneous lane 
pulse width  

TMIN-PULSE PCIe Tmin-Pulse  Not Specified 0.9UI (min) 

150 ps (min) 

Not Specified 

Transmitter eye 
including all jitter 
sources 

EYETXT   

tTX-EYE_TJ 

For Rev1.1: Eye Width 

For Rev2/3: PCIe T-TX 

.75 UI (min) 

300 ps (min) 

.75 UI (min) 

150 ps (min) 

TBD 

Maximum time between 
the jitter median and 
maximum deviation 

 

TTX-EYEMEDIAN-to-

PCIe Med-Mx Jitter 

 

.125 UI 
(min/max) 

Not Specified Not Specified 
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Parameter Symbol(s) 

DPOJET  

Measurement 

Specification 

2.5GT/s 
Rev1.1/Rev2.0 

5.0 GT/s 
Rev2.0  

8.0 GT/s 
Rev3.0  

from the median MAXJITTER  

Deterministic jitter TTX-DJ-DD DJ–δδ 

 

Not Specified 0.15 UI (max) 

30 ps (max) 

TBD 

Tx RMS jitter < 
1.5MHz 

TTX-LF-RMS TIE1 Jitter w/  
3rd Order LPF 
Fc: 1.5 MHz 

Std. Deviation 

Not Specified 3.0 ps (max) Not Specified 

D+/D- TX output rise/fall 
Time 2 

RISETXT 

FALLTXT    

PCIe T-Tx-Rise 

PCIe T-Tx-Fall 

0.125 UI (min) 

50 ps (min) 

0.15 UI (min) 

30 ps (min) 

Not Specified 

Tx rise/fall 

mismatch 
TRF-MISMATCH PCIe T-RF-Mismch Not Specified 0.1 UI (max) Not Specified 

AC common mode 
output voltage 

VTX-CM-AC-PP Common Mode 

Pk-Pk 
 

Not Specified 100 mV (max) 100 mV (max) 

AC common mode 
output voltage 

VTX-CM-AC-P Common Mode 

Rev1.1 : StdDev  

20mV RMS 

(max) 

Not Specified 20mV RMS 

(max) 

Absolute delta of DC 
common mode voltage 
between D+ and D- 

DELTALINEDCCMTXV   
Common Mode 

Mean  

0 V (min) 

25 mV (max) 

0 V (min) 

25 mV (max) 

0 V (min) 

25 mV (max) 

                                                           
2
 Rise/Fall time measurements in DPOJET are compliant to the Rev1.0a and Rev1.1 specification. For Gen2,  rise and fall 

time is limited to  TF2 and TR2 as defined in section 4.3.3.8 of the Base Specification 

 

 

Table 3- Specific PCI Express 3.0 Base transmitter measurements    

Parameter Symbol(s) DPOJET Measurement 8.0 GT/s 
Rev3.0  

Clock Recovery NA See Setup by Data 
Rate >> 

1
st
  Order PLL 

Fc: 10MHz 

Assumes 
Scrambled 
Compliance 

Pattern with 50% 
Edge Density 

Full Swing Tx voltage 

with noTxEq 
VTX-FS-NO-EQ V-TX-NO-EQ 

1300 mV(max) 

800 mV(min) 

Reduced Swing Tx 

voltage with noTxEq 
VTX-RS-NO-EQ V-TX-NO-EQ 

1300 mV(max) 

 

Min swing during 

EIEOS for full swing 
VTX-EIEOS-FS V-TX-EIEOS 250 mV(min) 
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Parameter Symbol(s) DPOJET Measurement 8.0 GT/s 
Rev3.0  

Min swing during 

EIEOS for reduced swing 
VTX-EIEOS-RS V-TX-EIEOS 232 mV(min) 

Pseudo package loss 
ps21TX

 
ps21TX -3.0dB(min) 

Tx uncorrelated total 

jitter TTX-UTJ T-TX-UTJ 31.25ps(max) 

Tx uncorrelated 

deterministic jitter TTX-UDJDD T-TX-UDJDD 12ps(max) 

Data dependent jitter TTX-DDJ T-TX-DDJ 18ps(max) 

Total uncorrelated 

PWJ TTX-UPW-TJ T-TX-UPW-TJ 24ps(max) 

Deterministic DjDD 

uncorrelated PWJ TTX-UPW-DJDD T-TX-UPW-DJDD 10ps(max) 

Maximum Boost voltage 

ratio V-TX-BOOST V-TX-BOOST 8dB(max) 

 

 

2.2 Differential Transmitter (TX) Compliance Eye Diagrams 

Figure 1a shows the eye mask definitions for the Rev1.1 Base Specification. It provides an example 

of a transmitter mask for a signal with de-emphasis. Transition and non-transition bits must be 

separated to perform the mask testing. The amplitude and jitter mask geometries are derived from 

the amplitude and jitter specifications. Low power transmitter variants in both Gen1 and Gen2 do 

not use de-emphasis (This is shown in Figure 1b). 

 

 

 

 

 

 

 

 

 

1. Rev1.1/2.0 Transmitter eye 
masks for transition and non-
transition bits 

2. Rev1.1/2.0 transmitter eye 
mask for low power 
variant where de-

3. Rev3.0  transmitter eye mask 
definition – Mask Geometries 
TBD for Gen3.  

Normalized Time (UI) 
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Fail
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 emphasis is not used  

Figure 1: PCI Express Transmitter Eye Mask Definitions 

2.3 Differential Receiver (RX) Input Specifications 

The following table shows the available measurements in the PCE Module and their test limits 

defined in each of the Base specifications.   

Table 4 – Supported base specification receiver measurements  for Gen1 and Gen2 

 

Parameter Symbol  

DPOJET  

Measurement 

2.5GT/s 

Rev1.1/Rev2.0 

5.0 GT/s 

Rev2.0  

Clock Recovery NA See Setup by Data Rate >> 1st Order PLL 

Fc: 1MHz 

 

 

 

Emulates 1st Order 
filter at 1.5MHz with 
75% edge density of 
Compliance Pattern 

2nd Order PLL 
CDR w/ .707 

Damping  

Fc: 1.0MHz 

- And -  

3rd  Order LPF 

Fc: 1.5MHz 

Emulates Step 
Function Filter at 

1.5MHz 

Unit interval  UI PCIe UI 

(min/max) 

SSC filtered with 3rd order 
HPF: Fc = 198kHz 

399.88 (min) 

400.12 (max) 

199.94 (min) 

201.06 (max) 

Minimum receiver eye height  VRX_EYE PCIe T-Tx-Diff-PP 

Eye Height
 

.175 V (min) 

1.2 V (max) 

.120 V (min) 

1.2 V (max) 

Minimum receiver eye width  
EYERXT   For Rev1.1: Eye Width 

For Rev2: PCI T-TX
 

.40 UI (min) 

160ps (min) 

Not Specified 

Receiver deterministic jitter –
Dj   

TRX_DJ_DD DJ–δδ Not Specified   .30 UI (max) 

60 ps (max) 

Minimum width 

pulse at Rx 

TRX-MIN-PULSE PCIe Tmin-Pulse Not Specified .60 UI (min) 

120ps (max) 

Maximum time between the 
jitter median and maximum 
deviation from the median. 

TTX-EYEMEDIAN-to-

MAXJITTER 
PCIe Med-Mx Jitter 

 

.30 UI (max) Not  

Specified 

Rx AC common 

mode voltage 

VRX-CM-AC-P Common Mode 

Rev2/3 : Pk-Pk
 

150mV 150mV 
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Differential Receiver (RX) Eye Diagrams 

Figure 2 shows the receiver eye mask definitions for the Rev1.1 Base Specification. The amplitude 

and jitter mask geometries are derived from the amplitude and jitter specifications.  

 

 Figure 2: Receiver input eye mask 
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2.4 Add-In Card Transmitter Path Compliance Specifications 

Table 5 is derived from the Card Electrical Mechanical Specifications (CEM). See the CEM 

Specification for additional notes and test definitions. 

Table 5 – Supported CEM add-in card measurements 

Parameter Symbol  DPOJET  

Measurement 

2.5GT/s 

Rev1.1/Rev2.0 

5.0 GT/s 

Rev2.0 

8.0 GT/s 

Rev3.0  

Clock Recovery NA See Setup by Data 
Rate >> 

1st Order PLL 

Fc: 1MHz 

 

 

Emulates 1st 
Order filter at 

1.5MHz with 75% 
edge density of 

Compliance 
Pattern 

2nd Order PLL CDR w/ 
.707 Damping  

Fc: 1.0MHz 

- And -  

3rd  Order LPF 

Fc: 1.5MHz 

Emulates Step Function 
Filter at 1.5MHz 

  1st Order PLL 

Fc: 10MHz 

 

Unit interval  UI PCIe UI 

(min/max) 

SSC filtered with 3rd 
order HPF: Fc = 

198kHz 

399.88 (min) 

402.12 (max) 

199.94 (min) 

200.06 (max) 

124.9625 (min) 

 125.6625 (max) 

Differential P-P Voltage VDiff-PP PCIe VTx-Diff-PP Not Specified Not Specified 50mV (min) 

1200mV(max) 

Eye height of transition bits  VTXA Eye Height1 0.514 V (min) 

1.2 V (max) 

 3.5dB De-emphasis 

 .380 V (min) 

1.2 V (max) 

6.0dB De-emphasis .306 
V (min) 

1.2 V (max) 

50mV (min) 

1200mV(max) 

Eye height of non-transition 
bits 

VTXA_d Eye Height2 0.360 V (min) 

1.2 V (max) 

3.5dB De-emphasis 

 .380 V (min) 

1.2 V (max) 

6.0dB De-emphasis .260 
V (min) 

1.2 V (max) 

50mV (min) 

1200mV(max) 

Eye width with sample size 
of 106 UI 

TTXA In Rev1.1 Eye Width 287 ps (min) Not Specified Not Specified 

Jitter eye opening at BER 
10-12 

TTXA In Rev2.0 For Rev1.1: Eye 
Width 

For Rev2/3: PCIe T-
TX 

274 ps (min) 

Informative 

123 ps (min) 

with Crosstalk 

 

45.00ps(min) 

Maximum median-max jitter 
outlier with sample size of 

106 UI 

JTXA-MEDIAN-to-
MAX-JITTER 

PCIe Med-Mx Jitter 

 

56.5 ps (max) Not Specified Not Specified 

Total Jitter at BER 10-12 Tj at BER 10-12 TJ@BER Not Specified 77 ps (max) 80.00 ps(max) 

Deterministic Jitter at BER 
10-12 

Max Dj  DJ–δδ Not Specified 57 ps (max) Not Specified 

Random Jitter at BER 10-12 Max Rj RJ–δδ Not Specified Not Specified 3.0 ps (max) 
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Specific PCI Express Gen3 measurements derived from SigTest Compliance tool for Add In Card: -  

 

Parameter DPOJET  

Measurement 

8.0 GT/s 

Rev3.0 

Clock Recovery See Setup 1st Order PLL 

Fc: 10MHz 

Min TBit Voltage(Max) Eye Low -25mV(max) 

-600mV(Min) 

Min nTBit Voltage(Max) Eye Low -25mV(max) 

-600mV(Min) 

Max TBit Voltage(Min) Eye High 25mV(max) 

600mV(Min) 

Max nTBit Voltage(Min) Eye High 25mV(max) 

600mV(Min) 
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Add-In Card Eye Diagrams 

The amplitude and jitter masks are derived from the amplitude and jitter specifications in Table 5.  

 

Figure 3: Add-in card compliance eye masks 

Load the Add-In Card Setup File in DPOJET: 

1. In the scope menu, select Analyze->PCI Express 

2. In the DPOJET standard tab, click the select button to choose the Test Point 

3. Select Rev3.0 -->SDLA_Add-In-Card->R30_SDLA_Add-in-Card.set 

4. In the Math Menu, set Math1 to Channel 1-Channel 2(Data)  

 

Figure 4: Setup File Selection 

Applying Channel and Behavioral Equalizer from SDLA: 

(Note: for Windows XP and 32-bit Win 7 Scopes, go to Appendix A and follow the procedure) 

These measurements are done using SDLA (Serial Data Link Analysis) behavioral equalizer and channel 

embedding. Open SDLA from Analyze menu.  
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Figure 5: Serial Data Link Analysis window 

5. Click Recall and select ‘PCIE_R30_SDLA_Add-in-Card.sdl’. It will set Equalizer CTLE and DFE 

values as per the PCI Express 3.0 specification. For details of the PCI Express Gen 3 De-

embedding procedure refer to the following document in  http://www.tek.com/method-

implementation/pci-express-30-de-embedding-method-implementation-version-10 

 

Figure 6: Setup file selection in SDLA 

6. Click ‘Apply’ in SDLA. SDLA will process waveform from DUT by embedding the compliance 

channel and applying the reference equalizer (CTLE + 1 Tap DFE) and it will also automatically 

run DPOJET based on the current DPOJET configuration.  The resulting waveform is placed in 

reference memory (Ref4). At the end user can generate a report containing the measurement 

results and test configuration by selecting the Report tab in DPOJET and clicking the save button.     

NOTE:  It is critical that the DPOJET setup file is recalled as described above before SDLA is ran. 

The results will be displayed as below. 

http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
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Figure 7: DPOJET Measurement Results 

7. To configure SDLA manually, follow procedure described in Appendix B. 
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8.  

2.5 System Board Transmitter Path Specifications 

 Table 6 is derived from the Card Electrical Mechanical Specifications (CEM) and PHY Test 

Specification. See the CEM and Test Specification for additional notes and test definitions.  

Table 6 – Supported CEM System Board Measurements  

Parameter Symbol  DPOJET  

Measurement 

2.5GT/s 

Rev1.1/Rev2.0 

5.0 GT/s 

Rev2.0 

8.0 GT/s 

Rev3.0  

Clock Recovery NA See Setup by Data Rate >> 2nd Order PLL 
CDR w/ .707 

Damping  

Fc: 1.0MHz 

- And -  

1st  Order LPF 

Fc: 1.5MHz 

Emulates 3rd 
Order 3500:250 

Method 

Explicit Clock 2nd 
Order PLL 

Clock Multiplier=50 

CDR w/ .707 
Damping  

Fc: 1.0MHz 

 

Emulates Step 
Function Filter at 

1.5MHz 

Explicit Clock 2nd 
Order PLL 

Clock 
Multiplier=80 

Clock Edge 
Rising 

0 .707 Damping  

Fc(JTF): 2.0MHz 

 

Unit interval  UI PCIe UI 

(min/max) 

SSC filtered with 3rd order 
HPF: Fc = 198kHz 

399.88 (min) 

402.12 (max) 

199.94 (min) 

201.06 (max) 

124.9625 ps 
(min) 

125.6625ps 
(max) 

Eye height of transition bits VTXS Eye Height1 0.274 V (min) 

1.2 V (max) 

0.250 V (min) 

 

46mV (min) 

1200mV(max) 

Eye height of non-transition bits VTXS_d Eye Height2 0.253 V (min) 

1.2 V (max) 

0.250 V (min) 46mV (min) 

1200mV(max) 

Eye width with sample size of 
106 UI 

TTXS 

In Rev1.1 

Eye Width 246 ps (min) Not Specified   Not Specified 

Jitter eye opening at BER 10-12 TTXS 

In Rev2.0 

For Rev1.1: Eye Width 

For Rev2/3: PCIe T-TX 

233 ps (min) 

Informative 

95 ps (min) 

with Crosstalk  

41.25ps(min)  

Maximum median-max jitter 
outlier with sample size of 106 
UI 

JTXA-

MEDIAN-to-

MAX-JITTER 

PCIe Med-Mx Jitter 

 

77 ps (max) Not Specified  Not Specified  

Total Jitter at BER 10-12 Tj at BER 
10-12 

TJ@BER Not Specified 105  ps (max) 83.75 ps(max) 

Deterministic Jitter at BER 10-12 Max Dj  DJ–δδ Not Specified 57 ps (max) Not Specified  

Random Jitter at BER 10-12 Max Rj RJ–δδ Not Specified Not Specified 3.0 ps (max) 
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Specific PCI Express Gen3 measurements derived from SigTest Compliance tool for System: -  

 

Parameter DPOJET  

Measurement 

8.0 GT/s 

Rev3.0 

Clock Recovery See Setup 2nd Order PLL 

Fc: 2MHz 

Min TBit Voltage(Max) Eye Low -23mV(max) 

-600mV(Min) 

Min nTBit Voltage(Max) Eye Low -23mV(max) 

-600mV(Min) 

Max TBit Voltage(Min) Eye High 23mV(max) 

600mV(Min) 

Max nTBit Voltage(Min) Eye High 23mV(max) 

600mV(Min) 
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System Board Eye Diagrams 

The amplitude and jitter masks are derived from the amplitude and jitter specifications in Table 6. 

 

Figure 8: System Board Compliance Eye Masks 

Load the System Setup File in DPOJET: 

1. In the scope menu, select Analyze->PCI Express 

2. In the DPOJET standard tab, click the select button to choose the Test Point 

3. Select Rev3.0->SDLA_System->R30_SDLA_SYSTEM.set 

4. In the Math Menu, set Math1 to Channel 3-Channel4(Data) and Math2 to Channel 1-

Channel2(Clock) 

 

Figure 9: Setup File Selection 

 

Applying Channel and Behavioral Equalizer from SDLA: 

(Note: for Windows XP, go to Appendix A and follow the procedure) 

These measurements are done using SDLA (Serial Data Link Analysis) behavioral equalizer and 

channel embedding. Open SDLA from Analyze menu.  
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Figure 10: Serial Data Link Analysis window 

5. Click Recall and select ‘PCIE_R30_SDLA_SYSTEM.sdl’. It will set Equalizer CTLE and DFE 

values as per the PCI Express 3.0 specification. For details of the PCI Express Gen 3 De-

embedding procedure refer to the following document in  http://www.tek.com/method-

implementation/pci-express-30-de-embedding-method-implementation-version-10 

 

Figure 11: Setup file selection in SDLA 

 

6. Click ‘Apply’ in SDLA. SDLA will process waveform from DUT and it will also process DPOJET 

analysis. At the end user will get a complete report of System Board. 

The results will be displayed as below. 

http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
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Figure 12: DPOJET Measurement Results 

Note: Nominally the PCIe Rev3.0 bit rate is 8 Gb/s. But if a  signal with SSC is tested, the bit rate  

should be set to 7.98 Gb/s. (0.25% lower). Alternatively, use the Auto Detect bit rate feature in 

SDLA Visualizer that will determine the exact clock frequency near the specified rate. 

To repeat measurements, you can clear previous results by pressing Clear in DPOJET and press 

Apply in SDLA. New acquisition and calculations will be completed automatically. This is 

necessary when testing different presets.  

7. To configure SDLA manually, follow procedure described in Appendix B. 

When measuring systems with short channels, or when doing exploratory testing, CTLE 

equalization may be sufficient. Then use R30_SYSTEM.set in R30_SYSTEM folder. This setup 

does not require SDLA and sets up a CTLE with -7dB gain as an ArbFilter. It does not embed the 

channel. Press Single to acquire waveforms and calculate measurements. In this mode Free Run is 

possible. 

To change the CTLE filter, follow the procedure described below. 

1. Load R30_SYSTEM.set file from R30_SYSTEM folder. 

2. Click on Math menu and go to ‘Editor’ in Math subsystem. 
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Figure 13: Filter settings in Math menu 

3. Select ‘Filter’ tab and  click ‘Load’ button in ‘Flt1’ section. It will guide to the desired filters 

location. Select any of seven filters(-6dB to -12dB CTLE filters) and click Open. It will apply 

the desired filter to differential data. 

 

Figure 14: Selecting CTLE Filter 

4. Click ‘Single’ in DPOJET. 
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2.6 2Reference Clock Specification 

Table 7 is derived from the PCI Express Card Electromechanical Specification for Gen1 Clock 

and PCI Express Base Specification Rev 3.0 for Gen2 and Gen3.  

Table 7A – Supported Ref Clock Rev1.1 Measurements  

Parameter Symbol  DPOJET  

Measurement 

Rev1.1 

Clock Recovery NA See Setup 2nd Order PLL 

Fc: 1.5MHz 

0.54 damping 

Time Interval Error  

TIE 

TIE 

 Filtered with 2nd 
order LPF: Fc = 

22MHz 

86 ps(P-P) 

Time Interval Error  

TIE 

TIE 

 Filtered with 2nd 
order LPF: Fc = 

1.5MHz 

86 ps(P-P) 

Frequency Fclk Freq NA 

 

Table 7B – Supported Ref Clock Rev2.0 Measurements  

 

 

Gen 2 Clock Setup files 

 Clock Recovery Filter Limit 

R20_RefClk_5MHZ_FIRST.set 

   

TIE 1 
PLL Custom BW, 1.5 MHz and 

0.54 damping 2nd order, 16 MHz 3.1 ps(max) 

TIE 2 
PLL Custom BW, 1.5 MHz and 

1.16 damping 2nd order, 5 MHz 3 ps(max) 

R20_RefClk_5MHZ_STEP.set 

   

TIE 1 
PLL Custom BW, 1.5 MHz and 

0.54 damping 2nd order, 16 MHz 3.1 ps(max) 

TIE 2 
PLL Custom BW, 1.5 MHz and 

1.16 damping 2nd order, 5 MHz 3 ps(max) 

R20_RefClk_8MHZ_FIRST.set 

   

TIE 1 
PLL Custom BW, 1.5 MHz and 

0.54 damping 2nd order, 16 MHz 3.1 ps(max) 

TIE 2 
PLL Custom BW, 1.5 MHz and 

0.54 damping 2nd order, 8 MHz 3 ps(max) 

R20_RefClk_8MHZ_STEP.set 

   

TIE 1 
PLL Custom BW, 1.5 MHz and 

0.54 damping 2nd order, 16 MHz     3.1 ps(max) 

TIE 2 
PLL Custom BW, 1.5 MHz and 

0.54 damping 2nd order, 8 MHz     3 ps(max) 
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Table 7C – Supported Ref Clock Rev3.0 Measurements 

Gen 3 Clock Setup files 

 Clock Recovery Filter Limit 

R30_RefClk_2MHZ_0.73Zeta.set   

  

TIE 1 
PLL Custom BW, 2 MHz 
and 0.73 damping 3rd order, 2MHz 1 ps(max) 

Freq NA NA 
99.97ns (Min) 

100.03 ns(Max) 

R30_RefClk_4MHZ_0.73Zeta.set   

  

TIE 1 
PLL Custom BW, 4 MHz 
and 0.73 damping 3rd order, 4MHz 1 ps(max) 

Freq NA NA 
99.97ns (Min) 

100.03 ns(Max) 

R30_RefClk_2MHZ_1.15Zeta.set   

  

TIE 1 
PLL Custom BW, 2 MHz 
and 1.15 damping 3rd order, 2MHz 1 ps(max) 

Freq NA NA 
99.97ns (Min) 

100.03 ns(Max) 

R30_RefClk_5MHZ_1.15Zeta.set   

  

TIE 1 
PLL Custom BW, 5MHz 
and 1.15 damping 3rd order, 5MHz 1 ps(max) 

Freq NA NA 
99.97ns (Min) 

100.03 ns(Max) 

 

 

2.7 MXM System Board Specifications  

 Table 8 is derived from the Mobile PCI Express MXM Electrical Mechanical Specifications. See 

the MXM Specification for additional notes and test definitions. 

Table 8 – Supported MXM System Board Measurements  

Parameter Symbol DPOJET 
Measurements 

2.5GT/s 2.5GT/s 5GT/s 5GT/s 5GT/s 

Clock 
Recovery 

N/A See Setup by 
Data Rate >> 

2nd Order PLL 
CDR w/ .707 

Damping  

Fc: 1.0MHz 

- And -  

1st  Order LPF 

Fc: 1.5MHz 

Emulates 3rd 
Order 3500:250 
Method 

2nd Order PLL 
CDR w/ .707 

Damping  

Fc: 1.0MHz 

- And -  

1st  Order LPF 

Fc: 1.5MHz 

Emulates 3rd 
Order 
3500:250 
Method 

Explicit Clock 2nd 
Order PLL 

Clock 
Multiplier=25 

CDR w/ .707 
Damping  

Fc: 1.0MHz 

 

Emulates Step 
Function Filter at 
1.5MHz 

Explicit Clock 
2nd Order PLL 

Clock 
Multiplier=25 

CDR w/ .707 
Damping  

Fc: 1.0MHz 

 

Emulates Step 
Function Filter 
at 1.5MHz 

Explicit Clock 
2nd Order PLL 

Clock 
Multiplier=25 

CDR w/ .707 
Damping  

Fc: 1.0MHz 

 

Emulates Step 
Function Filter 
at 1.5MHz 
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Swing   Low Standard Low Standard Standard 

DeEmphasis 
Setting 

  0dB 3.5dB 0dB 3.5dB 6.0dB 

Unit interval UI PCIe UI 

(min/max) 

SSC filtered with 
3rd order HPF: Fc 
= 198kHz 

400.12ps(max) 

399.88(min) 

400.12ps(max
)  

399.88(min) 

200.06 ps(max) 
199.94 ps(min) 

200.06 ps(max) 
199.94 ps(min) 

200.06 ps(max) 
199.94 ps(min) 

Eye height of 
transition bits 

VTXS Eye Height1 216 mV(min) 232 mV(min) 170 mV(min) 200 mV(min) 200 mV(min) 

Eye height of 
non-transition 
bits 

VTXS_d Eye Height2 N/A 223 mV(min) 170 mV(min) 200 mV(min) 200 mV (min) 

Eye width TTXA PCIe T-TX 242 ps (min) 242 ps (min) 95 ps (min) 95 ps (min) 95 ps (min) 

Total Jitter at 
BER 10-12 

Tj@BER10-12 TJ@BER Not Specified Not Specified 105 ps (max) 105 ps (max) 105 ps (max) 

Deterministic 
Jitter 

Max Dj DJ–δδ Not Specified Not Specified 57 ps(max) 57 ps(max) 57 ps(max) 

 

2.8 MXM System Board Compliance Eye Diagrams 

                The amplitude and jitter masks are derived from the amplitude and jitter specifications in Table 2(a & b).  

 

 

Figure 13: MXM System Board Compliance Eye Masks 
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2.9 PCI ExpressModule™ Specifications 

  The specifications in this section are taken from the PCI Express ExpressModule™ 

specification, which is a companion specification to the PCI Express Base Specification. Its primary 

focus is the implementation of a modular I/O form factor that is focused on the needs of 

workstations and servers. Measurements in the PCE module support add-in card and system 

transmitter path measurements at the PCI Express connector. 

 

ExpressModule Add-In Card Transmitter Path Specifications 

Table 9 is derived from Section 5.4.1 of the ExpressModule Electro-Mechanical Specifications 

Rev. 1.0.  

 Table 9 – Supported ExpressModule Add-In Card Measurements 

Parameter Symbol  DPOJET  

Measurement 

Rev1.0 

Clock Recovery NA See Setup by 
Data Rate >> 

1st Order PLL 

Fc: 1MHz 

Emulates 1st Order 
filter at 1.5MHz with 
75% edge density of 
Compliance Pattern 

Unit interval  UI  PCIe UI 

(min/max) 

SSC filtered with 
3rd order HPF: 
Fc = 198kHz 

399.98 (min) 

400.12 (max) 

Eye height of transition Bits VTXA . Eye Height1 .514 V (min) 

1.2 V (max) 

Eye height of non-transition Bits VTXA_d Eye Height2 .360 V (min) 

Eye width with sample size of 106 UI TTXA 

In Rev1.1 

Eye Width 287 ps (min) 

Jitter eye opening at BER 10-12  Eye 
Width@BER 

274 ps (min) 

Informative 

Maximum median-max jitter outlier 
with sample size of 106 UI 

JTXA-MEDIAN-to-

MAX-JITTER 
PCIe Med-Mx 

Jitter 
56.5 ps (max) 
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ExpressModule Add-In Card Eye Diagrams 

        The amplitude and jitter masks are derived from the amplitude and jitter specifications in 

Table 9. 

 

Figure 14: ExpressModule add-in card compliance eye masks 
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2.10 MXM ExpressModule Specifications  

Table 10 is derived from the Mobile PCI Express MXM Electrical Mechanical Specifications. See the 

MXM Specification for additional notes and test definitions. 

Table 10 – Supported MXM Express Module Measurements 

Parameter Symbol DPOJET 
Measurements 

2.5GT/s 2.5GT/s 5GT/s 5GT/s 5GT/s 

Clock 
Recovery 

N/A See Setup by 
Data Rate >> 

2nd Order PLL 
CDR w/ .707 

Damping  

Fc: 1.0MHz 

- And -  

1st  Order LPF 

Fc: 1.5MHz 

Emulates 3rd 
Order 3500:250 
Method 

2nd Order PLL 
CDR w/ .707 

Damping  

Fc: 1.0MHz 

- And -  

1st  Order LPF 

Fc: 1.5MHz 

Emulates 3rd 
Order 3500:250 
Method 

Explicit Clock 
2nd Order PLL 

Clock 
Multiplier=25 

CDR w/ .707 
Damping  

Fc: 1.0MHz 

 

Emulates Step 
Function Filter 
at 1.5MHz 

Explicit Clock 
2nd Order PLL 

Clock 
Multiplier=25 

CDR w/ .707 
Damping  

Fc: 1.0MHz 

 

Emulates 
Step Function 
Filter at 
1.5MHz 

Explicit Clock 
2nd Order PLL 

Clock 
Multiplier=25 

CDR w/ .707 
Damping  

Fc: 1.0MHz 

 

Emulates Step 
Function Filter 
at 1.5MHz 

Swing   Low Standard Low Standard Standard 

DeEmphasis 
Setting 

  0dB 3.5dB 0dB 3.5dB 6.0dB 

Unit interval UI PCIe UI 

(min/max) 

SSC filtered with 
3rd order HPF: 
Fc = 198kHz 

400.12ps(max) 

399.88(min) 

400.12ps(max)  

399.88(min) 

200.06 ps(max) 
199.94 ps(min) 

200.06 
ps(max) 
199.94 
ps(min) 

200.06 ps(max) 
199.94 ps(min) 

Eye height of 
transition bits 

VTXS Eye Height1 262 mV(min) 466 mV(min) 170 mV(min) 340 mV(min) 300 mV(min) 

Eye height of 
non-transition 
bits 

VTXS_d Eye Height2 N/A 314 mV(min) 170 mV(min) 340 mV(min) 260 mV (min) 

Eye width TTXA PCIe T-TX 254 ps (min) 254 ps (min) 123 ps (min) 123 ps (min) 123 ps (min) 

Total Jitter at 
BER 10-12 

Tj@BER10-12 TJ@BER Not Specified Not Specified 77 ps (max) 77 ps (max) 77 ps (max) 

Deterministic 
Jitter 

Max Dj DJ–δδ Not Specified Not Specified 57 ps(max) 57 ps(max) 57 ps(max) 
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MXM System Board Compliance Eye Diagrams 

The amplitude and jitter masks are derived from the amplitude and jitter specifications in Table 10 

(a & b).  

 

Figure 15: MXM System Board Compliance Eye Masks 

 

2.11 ExpressModule System Board Transmitter Path Specifications 

Table 11 is derived from Section 5.4.3 of the ExpressModule Electro-Mechanical Specifications 

Rev. 1.0. 

   Table 11 – Supported ExpressModule system board measurements  

Parameter Symbol  DPOJET  

Measurement 

Gen1 

Rev1.0 

Clock Recovery NA See Setup by Data 
Rate >> 

2nd Order PLL CDR w/ .707 Damping  
Fc: 1.0MHz 

- And -  
1st  Order LPF 

Fc: 1.5MHz 

Emulates 3rd Order 3500:250 Method 

Unit interval  UI PCIe UI 

(min/max) 

SSC filtered with 3rd 
order HPF: Fc = 

198kHz 

399.98 (min) 

400.12 (max) 

Eye height of transition bits VTXS . Eye Height1 .274 V (min) 

1.2 V (max) 

Eye height of non-transition bits VTXS_d Eye Height2 .253 V (min) 

Eye width with sample size of 106 
UI 

TTXS Eye Width 246 ps (min) 

Jitter eye opening at BER 10-12  Eye Width@BER 233 ps (min) 

 

Maximum median-max jitter outlier 
with sample size of 106 UI 

JTXA-MEDIAN-

to-MAX-JITTER 
TIE Jitter 77 ps (max) 
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Express Module System Board Compliance Eye Diagrams 

The amplitude and jitter masks are derived from the amplitude and jitter specifications in Table11.  

 

Figure 16: ExpressModule system board compliance eye masks 

2.12 PCI Express External Cabling Specifications 

The specifications in this section are taken from the PCI Express External Cabling Specification. Its 

primary focus is the implementation of a cabled interconnects. Measurements in the PCE module 

support transmitter path and receiver path measurements. These measurements represent the test 

points at the transmitter end of the cable and the receiver end of the cable respectively.  

 

External Cabling Transmitter Path Specifications 

Table 12 is derived from Section 3.3.1 of the External Cabling Specification Rev. 1.0.  

 Table 12 – Supported external cabling transmitter path measurements  

Parameter Symbol  DPOJET  

Measurement 

Rev1.0 Rev2.0 

Clock Recovery NA See Setup by Data Rate >> 1st Order PLL 

Fc: 1MHz 

Emulates 1st Order filter 
at 1.5MHz with 75% edge 

density of Compliance 
Pattern 

2nd Order PLL CDR w/ 
.707 Damping  
Fc: 1.0MHz 

 

Unit interval  UI  PCIe UI 

(min/max) 

SSC filtered with 3rd order 
HPF: Fc = 198kHz 

399.88 (min) 

400.12 (max) 

199.94 (min) 

200.06 (max) 

Eye height of 
transition bits 

VTXA . Eye Height1 .654 V (min) 

1.2 V (max) 

.612 V (min) 

1.2 V (max) 

Eye height of non-
transition bits 

VTXA_d Eye Height2 .450 V (min) .369 V (min) 

Jitter eye opening at 
BER 10-12 

TrxA @ BER 10
-12

 Eye Width@BER 296 ps (min) 

 

149 ps (min) 

 

Eye width with 
sample size of 106 UI 

TrxA @ 10
6

 

Samples 
Eye Width 309 ps (min) 148 ps (min) 
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Cable (Transmitter Side) Eye Diagrams 

The amplitude and jitter masks are derived from the amplitude and jitter specifications.  
 

 

Figure 17: Cable (transmitter side) compliance eye masks 

2.13 External Cabling Receiver Path Specifications  

Table 13 is derived from Section 3.3.2 of the External Cabling Specification Rev. 1.0.  

   Table 13 – Supported CEM system board measurements  

Parameter Symbol  DPOJET  

Measurement 

Rev1.0 Rev2.0 

Clock Recovery NA See Setup by Data Rate >> 1st Order PLL 

Fc: 1MHz 

Emulates 1st Order 
filter at 1.5MHz with 
75% edge density 

of Compliance 
Pattern 

2nd Order PLL CDR 
w/ .707 Damping  

Fc: 1.0MHz 

 

Unit interval  UI  PCIe UI 

(min/max) 

SSC filtered with 3rd order 
HPF: Fc = 198kHz 

399.98 (min) 

400.12 (max) 

199.94 (min) 

200.06 (max) 

Eye height of transition bits VRXA . Eye Height1 .208 V (min) 

1.2 V (max) 

.203 V (min) 

1.2 V (max) 

Eye height of non-transition 
bits 

VRXA_d Eye Height2 .192 V (min) .203 V (min) 

Jitter eye opening at BER 10-12 TrxA @ BER 10
-12

 Eye Width@BER 234 ps (min) 

 

122 ps (min) 

 

Eye width with sample size of 
106 UI 

TrxA @ 10
6

 

Samples 
Eye Width 247 ps (min) 127 ps (min) 
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Cable (Receive Side) Eye Diagrams 

The amplitude and jitter masks are derived from the amplitude and jitter specifications.  

 
 

 

Figure 18: Cable (receiver side) compliance eye masks 

 

2.14 PCMCIA ExpressCardTM  Specifications 

          The specifications in this section are taken from the PCMCIA ExpressCard Standard 

(Release 1.0).The  primary focus is a small modular add-in card technology based on the PCI 

Express and USB interfaces. Measurements in the PCE module support host system and 

ExpressCard transmitter path measurements. 

 

ExpressCard - Module Transmitter Path Specifications 

Table 14 is derived from Section 4.2.1.3.2 of the ExpressCard Specification Release 1.0. 

    Table 14 – Supported ExpressCard transmitter path measurements 

Parameter Symbol  DPOJET  

Measurement 

Release 1.0 

Clock Recovery NA See Setup by Data 
Rate >> 

1st Order PLL 

Fc: 1MHz 

Emulates 1st Order 
filter at 1.5MHz with 
75% edge density of 
Compliance Pattern 

Unit interval  UI  PCIe UI 

(min/max) 

SSC filtered with 3rd 
order HPF: Fc = 

198kHz 

399.98 (min) 

400.12 (max) 
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Eye height of transition bits VTXA . Eye Height1 538 V (min) 

1.2 V (max) 

Eye height of non-transition bits VTXA_d Eye Height2 .368 V (min) 

Eye width across any 250 UIs TTXA Eye Width@BER 237 ps (min) 

 

ExpressCard Transmitter Path Eye Diagrams 

The amplitude and jitter masks are derived from the amplitude and jitter specifications in Table 

14.  
 

 

Figure 19: ExpressCard Module Transmitter compliance eye masks 

 

ExpressCard - Host System Transmitter Path Specifications 

Table15 from Section 4.2.1.3.2 of the ExpressCard Specification Release 1.0. 

   Table 15 – Supported ExpressCard Host System Transmitter Path Measurements  

Parameter Symbol  DPOJET  

Measurement 

Release 1.0  

Clock Recovery NA See Setup by Data 
Rate >> 

2nd Order PLL CDR w/ 
.707 Damping  
Fc: 1.0MHz 

- And -  
1st  Order LPF 

Fc: 1.5MHz 

Emulates 3rd Order 
3500:250 Method 

Unit interval  UI PCIe UI 

(min/max) 

SSC filtered with 3rd 
order HPF: Fc = 

198kHz 

399.98 (min) 

400.12 (max) 

Eye height of transition bits VtxS . Eye Height1 .262 V (min) 

1.2 V (max) 

Eye height of non-transition bits VtxS_d Eye Height2 .247 V (min) 

Eye width across any 250 UIs TTxS Eye Width@BER 183 ps (min) 
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ExpressCard – Host System Eye Diagrams 

The amplitude and jitter masks are derived from the amplitude and jitter specifications in Table 

15.  
 

 

Figure 20: ExpressCard Host System compliance eye masks 
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3 PCI Express Library Contents 
The following table shows a list of the PCI Express standards supported by the DPOJET Setup Library 

and their default probing configurations. All Rev1.0 and Rev1.1 setup files are for 2.5 GT/s. Rev 2.0 

setup files are for 5.0 GT/s and Rev3.0 setup files are for 8.0 GT/s. Revision numbers are made 

according to the test methods. See Table 1 for more details. The setup file library is located in 

C:\Users\Public\Tektronix\TekApplications\PCI Express\ for 2.5GT/s and 5.0 GT/s and 

C:\Users\Public\Tektronix\TekApplications\PCI Express 3.0\ for 8.0 GT/s. 

 

Table 16 – Setup Files and default probing configurations 

PCI-SIG Specification Bit Rate  Setup File Name Default Probing Configuration  

Rev1.1 Base Specification 

Transmitter and Receiver 

2.5GT/s R11_Tx_Base.set 

R11_Rx_Base.set 

Data = Math1 = Ch1-Ch2 

Rev1.1 MXM 

Specification 

Module and System 

2.5GT/s R11_MXM_Mod_0dB_Low.set 

R11_MXM_Sys_0dB_Low.set 

R11_MXM_Tx_Mod_3.5dB.set 

R11_MXM_Tx_Sys_3.5dB.set 

Data = Math1 = Ch1-Ch2 

Rev1.1 CEM Specification 

Add-In Card and System 

2.5GT/s R11_Tx_ADD_CON.set 

R11_Tx_SYSTEM_3500-250.set 

Data = Math1 = Ch1-Ch2 

Rev 1.1 Ref  Clock 

Specification 

2.5 GT/s R11_RefClk.set RefClk = Math1 = Ch1-Ch2 

Rev1.0 Cable 

Specification 

Near End and Far End 

2.5GT/s R10_Tx_Cable.set 

R10_Rx_Cable.set 

Data = Math1 = Ch1-Ch2 

Rev1.0 ExpressModule 

Specification 

Add-In Card and System 

2.5GT/s R10_Tx_ExpMod_ADD_CON.set 

R10_Tx_ExpMod_SYSTEM.set 

Data = Math1 = Ch1-Ch2 

Rev1.0 ExpressCard 

Specification 

Host and Module 

2.5GT/s R10_Tx_ExpressCard_Host.set 

R10_Tx_ExpressCard_Module.set 

Data = Math1 = Ch1-Ch2 

Rev2.0 Base Specification 

Transmitter with 3.5dB 

and 6.0 dB De-Emphasis 

and Low Swing 

5GT/s R20_Base_Tx_3.5dB.set 

R20_Base_Tx_6.0dB.set 

R20_Base_Tx_Low_Swing.set 

Data = Math1 = Ch1-Ch2 

Rev1.1 MXM 

Specification 

Module and System 

5GT/s R20_MXM_Mod_3.5dB_Low.set 

R20_MXM_Sys_3.5dB_Low.set 

R20_MXM_Tx_Mod_3.5dB.set 

R20_MXM_Tx_Mod_6dB.set 

R20_MXM_Tx_Sys_3.5dB.set 

Data = Math1 = Ch1-Ch2 
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R20_MXM_Tx_Sys_6dB.set 

Rev2.0 CEM Specification 

Add-In Card with 3.5dB 

and 6.0dB De-Emphasis 

and System 

5GT/s R20_Tx_ADD_CON_3.5dB.set 

R20_Tx_ADD_CON_6.0dB.set 

R20_Tx_SYSTEM.set 

Add-In Card:  

Data = Math1= Ch1-Ch2 

System:  

RefClk = Math1 = Ch1-Ch2 

Data = Math2 = Ch3 – Ch4 

Rev2.0 Cable 

Specification 

Near End and Far End 

5GT/s R20_Tx_Cable.set 

R20_Rx_Cable.set 

Data = Math1 = Ch1-Ch2 

Rev 3.0 Base Specification   

Transmitter Full and Half 

Swing 

8GT/s R30_V-TX-FS-NO-EQ.set 

R30_V-TX-RS-NO-EQ.set 

R30_V-TX-EIEOS-FS.set 

R30_V-TX-EIEOS-RS.set 

R30_T-TX-UTJ.set 

R30_T-TX-UPW-DJDD.set 

R30_T-TX-DDJ.set 

R30_T-TX-UPW-TJ.set 

R30_T-TX-UDJDD.set 

R30_ps21Tx.set 

R30_V-Tx-Boost.set 

R30_BaseMeas_FS.set 

R30_BaseMeas_RS.set 

R30_Base_Rx.set 

Data = Math1 = Ch1-Ch2 

The following setups are for 

recalling specific measurement 

for standalone evaluation 

 

 

 

 

 

 

 

These setups are for combined 

measurements at transmitter or 

receiver test point 

Rev3.0 CEM Specification 

Add-In Card 

8GT/s R30_ADD_CON.set 

R30_SDLA_Add-in-Card.set 

Data = Math1= Ch1-Ch2 

RefClk = Ref3 (From SDLA) 

Rev3.0 CEM Specification 

System Board 

8GT/s R30_System.set 

 

R30_SDLA_SYSTEM.set 

Data = Math1 = Ch3 - Ch4 

RefClk = Math2 = Ch1-Ch2 

Data = Ref4 (From SDLA) 

RefClk=Math2= Ch1-Ch2 

Rev3.0 Clock 

Specification 

5GT/s R20_RefClk_5MHZ_FIRST.set 

R20_RefClk_5MHZ_STEP.set 

R20_RefClk_8MHZ_FIRST.set 

R20_RefClk_8MHZ_STEP.set 

RefClk = Math1 = Ch1-Ch2 

 

Rev3.0 Clock 

Specification 

8GT/s R30_RefClk_2MHZ_0.73Zeta.set 

R30_RefClk_4MHZ_0.73Zeta.set 

R30_RefClk_2MHZ_1.15Zeta.set 

R30_RefClk_5MHZ_1.15Zeta.set 

RefClk = Math1 = Ch1-Ch2 
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In the above table DPOJET setup library contains setup files for all individual measurements as well as 

combined setup files for base measurements and CEM measurements. Individual setup files can run with 

higher record length up to 50M and combined setup files can run with a record length of 20M. So if user 

wants to run measurements with the original compliance pattern, he/she can go with individual setup files 

or else user can go with combined setup file and get an overall results for PCI Express 3.0 measurements. 

To change the probing configuration to use differential probes, change the Source of the Data and RefClk 

as appropriate in the measurement configuration menu in DPOJET. Refer to the DPOJET Online Help for 

details.  

3.1 Retaining Deskew  

User can retain his/her own deskew setting unchanged while recalling any setup files. User has to follow 

the following procedure: 

Go to ‘File’ and select ‘Recall’ to recall a PCI Express setup. When the window will appear, select the 

required setup file from and before clicking ’Recall’, enable the check box saying “Don’t recall deskew 

values. Keep existing deskew settings”. 

 

Figure 21: Retaining deskew setting unchanged 
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4 Preparing to Take Measurements 
4.1 Required Equipment 

The following equipment is required to take the measurements: 

 Oscilloscope:  

o Rev 1.1 (2.5 GT/s) – The PCI-SIG recommends a minimum of 6 GHz system BW 

for compliance testing. However, some silicon can have rise time in the 50ps range. 

Thus, Tektronix recommends DPO/DSA70000 8 GHz and above for 2.5 GT/s 

transmitter measurements. 

o Rev 2.0 (5 GT/s) – DPO/DSA70000 12.5 GHz and above are recommended for 5 

GT/s and above and required for Base Specification transmitter measurements.  

o Rev 3.0 (8 GT/s) – DPO/DSA70000 16 GHz and above are recommended for 8 

GT/s measurements.  

 DPOJET software (Version 4.0 or above) with PCI Express Measurements (Opt. PCE, PCE3) 

installed. 

 Probes – See Section 4.2 for probing options.  

 Test Fixtures 

o Test Fixtures for System and Add-In card testing are available from the PCI-SIG. 

Rev1.1 Fixtures (CLB1, CBB1) break transmitter signals out into SMA 

connections. Rev 2.0 Fixtures (CLB2, CBB2) break transmitter signals out into 

SMP connections. These fixtures are available at:  

http://www.pcisig.com/specifications/ordering_information/ordering_information. 

o Test fixtures for ExpressCard testing are available from the following URL: 

http://www.expresscard.org/web/site/testtools.jsp 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.pcisig.com/specifications/ordering_information/ordering_information
http://www.expresscard.org/web/site/testtools.jsp
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4.2 Probing Options for Transmitter Testing 

 The first step is to probe the link. Use one of the following four methods to connect probes to the 

 link. Default probing selection is Ch1-Ch2 for single-ended signals, and to create  differential 

 signal use Math1=Ch1-Ch2. 

4.2.1 SMA Input Connection  
 

A. Two TCA-SMA inputs using 

SMA cables (Ch1) and (Ch2)  
The differential signal is created 

from the math waveform (Math1 = 

Ch1-Ch2). The Common mode AC 

measurement is also available in 

this configuration from the common 

mode waveform (Ch1+Ch3)/2. This 

probing technique requires breaking 

the link and terminating into a 

50 /side termination of the 

oscilloscope. While in this mode, 

the PCI Express SerDes will 

transmit the compliance test pattern. 

Ch-Ch de-skew is required using 

this technique because two channels 

are used. This configuration does 

not compensate for cable loss in the 

SMA cables. The measurement 

reference plane is at the input of the 

TCA-SMA connectors on the 

oscilloscope.  

 

 

SMA Pseudo-differential 

B. One P7300SMA series differential 

active probe (Ch1)  
The differential signal is measured 

across the termination resistors 

inside the P7300SMA series probe. 

This probing technique requires 

breaking the link. While in this 

mode, the PCI Express SerDes will 

transmit the compliance test pattern. 

Matched cables are provided with 

the probe to avoid introducing de-

skew into the system. Only one 

channel of the oscilloscope is used. 

The P7300SMA provides a 

calibrated system at the Test Fixture 

attachment point, eliminating the 

need to compensate for cable loss 

associated with the probe 

configuration A. 

 

 

SMA Input Differential Probe  
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4.2.2 ECB pad connection 
 

C. Two active probes (Ch1) and (Ch2)  
The differential signal is created from 

the math waveform (Math1 = Ch1-

Ch2). The Common mode AC/DC 

measurements are available in this 

configuration from the common mode 

waveform (Ch1+Ch3)/2. This probing 

technique can be used for either a live 

link that is transmitting data, or a link 

that has terminated into a “dummy 

load.” In both cases, the single-ended 

signals should be probed as close as 

possible to the termination resistors on 

both sides with the shortest ground 

connection possible. Ch-Ch de-skew is 

required using this technique because 

two channels are used. 

 

 

D. One P7300 or P7500 series 

Differential probe (Ch1) 

The differential signal is measured 

directly across the termination 

resistors. This probing technique can 

be used for either a live link that is 

transmitting data, or a link that is 

terminated into a “dummy load.” In 

both cases, the signals should be 

probed as close as possible to the 

termination resistors. De-skew is not 

necessary because a single channel of 

the oscilloscope is used. If using a 

P7500 Tri-Mode Probe, common 

mode voltage measurements can be 

made directly with the probe.  
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4.2.3 Dual Port Connection 
E. Dual Port   

For Rev 2.0 and 3.0 

System testing (Described 

in Section 2.4), the ‘Dual 

Port’ method is used to 

capture differential Data 

and RefClk. Direct SMA 

input can be used (where 

RefClk=Math1=Ch1-Ch2 

and Data=Math2=Ch3-

Ch4); or Two P7313SMA 

probes can be used (where 

RefClk = Ch1 and Data = 

Ch2).  
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4.3 Running the Test 

The following is a step-by-step procedure on how to run a test in the DPOJET PCI Express Setup 

Library.  Refer to Table 12 for default probing configurations for each Setup. 

      Source and Reference level Autoset 

       Below steps are recommended before doing any measurements. However these steps  

       are  not required if you are using the setup files. 

       Select the ‘Source configuration’ window (Figure below). 

        Press ‘Vertical & Horizontal’ under ‘Source Autoset’. 

 

Figure 22: Source Configuration window 

      Press 'Autoset' under 'Reverence Levels Source Configuration'. 

4.3.1  Horizontal Setup  

  Now go to the 'Horiz/Acq'  'Horizontal /Acquisition Setup' and Select the 'Manual'  

  mode.  

Figure 23: Horizontal setup 
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Change the 'Record Length' to the required value.  

 For all the measurements 20M record length (at 50GS/s sample rate) is required to  

 meet the specification. 

From Acquisition, select Acquisition Mode to ‘Sample’ and Sampling Mode to ‘Real 

Time’. 

 

Figure 24: Acquisition setup 

4.3.2  Vertical Setup: 

Now, from Vertical Settings, Termination 50 Ω and Bandwidth to 16GHz if you are using 

16GHz or higher BW scopes. Otherwise set it to maximum BW available. Make sure that 

Digital Filters(DSP) Enabled option is chosen. 

 

Figure 25: Vertical Setup 

On the same window open Channel Deskew and set the following parameters for all the 

Channels: 

Ch<x> Deskew Time 0.0s, External Atten  1.0 and External Atten(dB)0.0 dB. These 

are the default values. If user wants to add Deskew values, select the channel and add 

Deskew time to align with the other channels. 
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Figure 26: Channel Deskew 

4.3.3  Math Setup: 

 If user wants to set any specific filter with the Math signal, this is the procedure: 

 Go to Math  Editor Filter and then click ‘Load’. 

 Browse required filter file from your saved filters or you can use existing filter files from 

DPOJET. 

 Select the filter and then click ‘Flt1’ if you have loaded the filter in ‘Flt1’. In the Math 

Equation Editor, put Math1 = ArbFlt1(Ch1-Ch2) if you are using single ended probe. 

 

Figure 27: Math Setup 

    From the DPO/DSA Analysis Menu, Select PCI Express. Allow DPOJET to load.  

    From the Test Point, Click Setup and navigate to the DPOJET PCIE Setup Library 
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  Figure 28: Recall the desired file from the Setup Library. 

Press the ‘Single’ button on the instrument front panel. The screen should look similar to the 

following image. Adjust Vertical Scale to take full advantage of the A/D range of the oscilloscope 

enter channel De-Skew values as needed. The Horizontal Scale is set to capture 1 Million UI (10
6
 

bits) as required by the specifications.  

 

Figure 29: Setting DPOJET measurements 

Press the Single Button in DPOJET (Jitter and Eye Analysis Tools) Menu. The end result should 

look similar to the following screenshot. Pass/Fail results are viewed by expanding the measurement 

results using the ‘+’ icon next to each measurement.  
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Figure 30: Displaying results in DPOJET panel. 

 

5  Parameter Definitions and Method of 

Implementation 
The DPOJET PCI Express Setup Library combines measurements native to the standard DPOJET package 

with unique measurements offered in the Standards > PCI Express tab of the DPOJET Measurement 

Select menu. PCI Express specific measurements requires Opt. PCE and DPOJET Version 2.1 or above of 

is installed on the oscilloscope.  

Measurements selected in the setup file are dependent on the specification that is designed to test. Refer to 

Table 2 through Table 11 for the clock recovery method and for each measurement in the setup file. Refer 

to the DPOJET OLH (Online Help) for measurement algorithms and setup parameters for measurements 

native to DPOJET.  

The algorithm and setup parameters of the PCI Express specific measurements are described in the 

following sections.  

 

5.1 UI (Unit Interval) MOI 

Definition: 

UI (Unit Interval) is defined in the base specification Rev2.0. This measurement is done using the 

PCIe–UI.  The Result panel would display the Unit interval values   

 

Test Definition Notes from the Specification:  

The specified UI is equivalent to a tolerance of  ±300 ppm for each Refclk source.  Period does not 

account for SSC induced variations.   
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Limits: 

Refer to Table 2 thru Table 11 for specified limits on the UI measurement. 

Test Procedure: 

Ensure that PCIe UI is selected in the Jitter and Eye diagram Analysis Tools >> Select menu. 

Set the following parameters 

Horizontal Record length to at least 500K.  

Configure >> Edges  >> Auto 

Configure >> Filter >> Low pass - 198kHz 

Configure >> Global >> off  

Measurement Algorithm:  

The Unit interval measurement calculates the duration of a cycle as defined by a start and a stop 

edge. Edges are defined by polarity, threshold, and hysteresis. The application calculates clock 

period measurement using the following equation:  

 

Where:  

P
Clock

 is the clock period.  

T is the VRefMid crossing time for the selected polarity.  

 

5.2 TX Differential Pk-Pk Output Voltage MOI 

Definition: 

pDIFFpTXV   (Differential Output Pk-Pk Voltage) is defined in the base specification Rev 2.0. This 

measurement is done using PCIe T-Tx-Diff-PP.  The Result panel would display the Mean , 

Maximum and Minimum  differential output pk-pk voltage. 

 

Test Definition Notes from the Specification:  

||2   DTXDTXpDIFFpTX VVV  

Measured on individual bits, first bit from a sequence in which all bits have same polarity, over 

specified number of UIs. The voltage measurement is referenced to the centre of each UI. 

Limits: 

                           Refer to Table 2 thru Table 11 for specified limits on the pDIFFpTXV   measurement 
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Test Procedure: 

Ensure that PCIe T-Tx-Diff-PP is selected in the Jitter and Eye diagram Analysis Tools >> 

Select menu. 

Select Configure >> Clock Recovery. Configure the Clock Recovery to be consistent with the 

Clock Recovery method shown in Tables 2-13.  

Measurement Algorithm: 

Differential Peak Voltage Measurement: The Differential Peak Voltage measurement returns two 

times the larger of the Min or Max statistic of the differential voltage waveform.  

)))(());(((2 ivMinivMaxMaxV DIFFDIFFPKDIFF   

Where:  

i is the index of all waveform values 

DIFFv  is the differential voltage signal 

 

5.3 TX De-Emphasis Ratio 

Definition: 

VTX-DE-RATIO(De-Emphasized Differential Output Voltage (Ratio)) is defined in the base 

specification. This measurement uses PCIe DeEmph measurement. 

Test Definition Notes from the Specification:  

This is the ratio of the VTX-DIFFp-p of the second and the following bits after a transition divided by the   

VTX-DIFFp-p of the first bit after a transition. 

Limits: 

                           Refer to Table 2 thru Table 14 for specified limits on the VTX-DE-RATIO measurement 

Measurement Algorithm: 

 The De-emphasis Ratio measurement reports the amplitude ratio between transition and non-

 transition bits.  

 The measurement calculates the ratios of all non-transition eye voltages (2nd and subsequent eye 

 voltages after one edge but before the next) to their nearest preceding transition eye voltage (1st 

 eye voltage succeeding an edge). In the accompanying diagram, it is the ratio of the Black voltages 

 to the Blue voltages. The results are given in dB.  
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The application calculates the T/nT(transition to non-transition) Ratio using the following 

equations:  












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)(

)(
)(

nv
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NTRANHIEYE

 

following a rising edge. 


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






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following a falling edge. 

Where:  

vEYE–HI–TRAN is the High voltage at the interpolated midpoint of the first unit interval following a 

positive transition.  

vEYE–LO–TRAN is the Low voltage at the interpolated midpoint of the first unit interval following a 

negative transition.  

vEYE–HI–NTRAN is the High voltage at the interpolated midpoint of all unit intervals except the first 

following a positive transition.  

vEYE–LO–NTRAN is the Low voltage at the interpolated midpoint of all unit intervals except the first 

following a negative transition.  

m is the index for all non-transition UIs.  

n is the index for the nearest transition UI preceding the UI specified by m.  

In a time trend plot of the measurement results, there is one measurement for each non-transition 

bit in the waveform (that is the black arrows in the diagram).  

NOTE. PCIe DeEmph measurement uses Brick Wall filter. 
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5.4 TX Minimum Pulse Width MOI  

Definition: 

TMIN-PULSE (Instantaneous lone pulse width measurement) is defined in the base specification 

Rev2.0. This measurement uses the PCIe Tmin-Pulse.  The Result panel would display the 

minimum pulse width results. 

 

Test Definition Notes from the Specification:  

TMIN-PULSE (Instantaneous lone pulse width measurement) is measured from transition center to the 

next transition center, and that the transition centers will not always occur at the differential zero 

crossing point.  In particular, transitions from a de-emphasized level to a full level will have a 

center point offset from the differential zero crossing. 

Limits: 

                           Refer to Table 2 thru Table 14 for specified limits on the TMIN-PULSE measurement 

Test Procedure: 

Ensure that PCIe Tmin-Pulse is selected in the Jitter and Eye diagram Analysis Tools > Select 

menu. 

Set the following parameters 

Select Configure > Clock Recovery. Configure the Clock Recovery to be consistent with the 

Clock Recovery method shown in Tables 2-14.  

Configure > General >Off 

Configure > Global > Off  

Measurement Algorithm:  

Tmin-Pulse (minimum single pulse width TMin-Pulse) is measured from one transition center to the 

next.  

The application calculates TMin-Pulse using the following equation:  

 

Where: 

TMin-Pulse is the minimum pulse width  

T is the transition center 
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5.5 TX Rise/Fall Time Mismatch MOI  

Definition: 

TRF-MISMATCH (Rise time, Fall time mismatch) is defined in the base specification. This 

measurement uses PCIe T-RF-Mismch.  The Result panel would display the Mean , Maximum and 

Minimum  Rise time, Fall time mismatch values. 

 

Limits: 

Refer to Table 2 through Table 14 for TRF-MISMATCH measurement.  

Test Procedure: 

Ensure that PCIe T-RF-Mismch is selected in Jitter and Eye diagram Analysis Tools > Select 

menu is selected. 

Set the following parameters 

Select Configure > Clock Recovery. Configure the Clock Recovery to be consistent with the 

Clock Recovery method shown in Tables 2-14.  

Configure > Filter > No filter 

Configure > General >Off 

Configure > Global > Population  

Measurement Algorithm:  

PCIe T-RF-Mismch (Rise and Fall Time mismatch measurement) is the mismatch between Rise 

time (TRise) and Fall time(TFall). The application calculates this measurement using the 

following equation:  

 

Where: 

T
Mismatch

 is the rise and fall time mismatch  

T
Rise

 is the rise time  

T
Fall

 is the fall time  

 

5.6 Minimum TX Eye Width MOI 

Definition: 

EYETXT   
(Minimum TX Eye Width) is defined in the base specification.  . See Section 4.7.2 of PCI 

Express Card Electromechanical Specification, Rev. 2.0 for the Gen2 definition for both 3.5 dB 
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and 6 dB De-emphasis. The eye diagrams defined in this section represent the compliance eye 

diagrams that must be met for both add-in card and a system board interfacing with such an add-in 

card. A sample size of 10
6
 UI is assumed for the measurement. 

EYETXT   
is defined to be the Jitter Eye Opening.  

 

Test Definition Notes from the Specification: 

- The maximum Transmitter jitter can be derived as EYETXJITTERTXMAX TT  1  

- Specified at the measurement point into a timing and voltage compliance test load as shown in 

the base specification and measured over the specified number of UIs. Also refer to the transmitter 

compliance eye diagram shown in the base specification. 

Limits: 

Refer to Table 2 thru Table 14 on the EYETXT   measurement.  

Test Procedure: 

Ensure that the measurement PCI T-TX is selected in the Jitter and Eye diagram Analysis Tools 

> Select menu. 

Configure the measurement by setting the following parameters. 

Select Configure > Clock Recovery. Configure the Clock Recovery to be consistent with the 

Clock Recovery method shown in Tables 2-14.  

Configure > General > off. 

Measurement Algorithm: 

The measured minimum horizontal eye opening at the zero reference level as shown in the eye 

diagram below. 

PkPkAVGWIDTHEYE TIEUIT  
 

Where: AVGUI  is the average UI 

PkPkTIE   is the Peak-Peak TIE 

Where TtxA is the Eye width, VtxA  is the full scale peak to peak voltage and VtxA_d  is the De-

emphasized peak to peak voltage.  
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Figure 31: Configure Panel 

 

5.7 TX Median-to-Max Jitter MOI 

Definition:  

MAXJITTERtoEYEMEDIANTXT    (maximum time between the jitter median and maximum deviation from 

the median). A step response Band pass filter is being used to remove the low frequency jitter as 

specified in Rev2.0 of the base specification. 

 

Limits: 

Refer to Table 2 thru Table 14 for MAXJITTERtoEYEMEDIANTXT   measurement.   

Test Procedure: 

Ensure that PCIe Med-Mx Jitter is selected in Jitter and Eye diagram Analysis Tools > Select 

menu is selected. 

Set the following parameters 

Configure > Edges > Signal Type > Auto 

Select Configure > Clock Recovery. Configure the Clock Recovery to be consistent with the 

Clock Recovery method shown in Tables 2-14.  

Configure > Filter > Brick Wall Filter  

Configure > General >Off 

Measurement Algorithm:  

The measured time difference between a data edge and a recovered clock edge. 

)()()( ntntntie DATDATR    

Where: 
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DATt  is the original data edge 

DATRt   is the recovered data edge (for example, the recovered clock edge corresponding to the UI 

boundary of DATt ) 

n is the index of all edges in the waveform 

Med_Tie= median (tie (n)) 

Where: 

Med_Tie is the Median of the tie measured. 

TTx-EYEMEDIAN-to MAXJitter = Abs (Med_Tie – Maximum deviation of tie (n) from the Med_Tie) 

 

5.8 VRX Max-Min Ratio (Voltage) MOI 

Definition:  

VRX-MAX-MIN-RATIO defines the voltage range ratio over which a particular receiver must operate for 

the consecutive UI. Figure 12 shows a typical voltage plot into a reference load that yields a near 

worst case VRX-MAX-MIN-RATIO. VSWING-MAX is defined in relation to VSWING-MIN 

over an interval of 2.0 UI. The right hand side of the 2 UI intervals is placed on the peak of the 

waveform corresponding to VSWING-MIN.  The 2 UI separation guarantees that VSWING-

MAX.  A 2 UI interval guarantees that VSWING-MAX is measured on the flat portion of its curve 

and accounts for worst case jitter and dispersive channel effects. 

 

Figure 32: Signal at Receiver Reference Load Showing Min/Max Swing 
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Limits: 

Refer to Table 2 thru Table 14 for VRX-MAX-MIN-RATIO measurement.   

Test Procedure: 

Ensure that PCIe MAX-MIN Ratio is selected in Jitter and Eye diagram Analysis Tools > 

Select menu is selected. 

Set the following parameters 

Configure > Edges > Signal Type > Auto 

Select Configure > Clock Recovery. Configure the Clock Recovery to be consistent with the 

Clock Recovery method shown in Tables 2-14.  

Configure > General >Off 

Configure > Global >Off 

Measurement Algorithm:  

 Find the 50% edges ( this may not give the correct 50% edge, However this value allows to 

 identify the edge, and allows to navigate in forward and backward direction from the 50% level, to 

 find out the peak-to peak voltage) 

 On the rising edge find the VSWING_MIN  

 From the VSWING_MIN point trace back 2 unit intervals and find the VSWING_MAX  

 VRX-MAX-MIN-RATIO (VRX-MAX-MIN-RATIO  = VSWING-MAX / VSWING_MIN) 

 

 

5.9 TX SSC Frequency Deviation MOI 

Definition:  

SSC Frequency Deviation (or SSC Modulation Profile), can be defined as the frequency shift as a 

function of time. 

Test Definition Notes from the Specification:  

-- The data rate is modulated from 0 to -5000 ppm for nominal data rate frequency and scales with 

data rate. 

-- This is measured below 2 MHz only. 

Limits:  

Refer to Table 2 thru Table 14 for specified limits on TSSC-FREQ-DEV measurement. 

Test Procedure:  

Ensure that  PCIe SSC-FREQ-DEV is selected in the Jitter and Eye diagram Analysis Tools 

>>PCI Express >> Select menu.  

Select the Jitter and Eye diagram Analysis Tools >> Configure from the panel and set the 

Configure >> Constant Clock-Mean and,  
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Configure >> Filter >> Low pass >> 2
nd 

Order >> Frequency >> 1.98 MHz (Which is elected 

by default) as shown in figure below.  

 

Figure 33: Filter for SSC Frequency Deviation measurement  

Configure >> General >>Off  

Configure >> Global >> Off 

 

 Measurement Algorithm: 

 Find the 50% edges on the SSC profile 

 Between the 'n' and 'n+1' th edge find the High value. and also between 'n+1' and 'n+2' edge find 

 the Low. 

 Find the Frequency deviation as High – Low (FreqDev = High – Low) 

 Represent the FreqDev in terms of ppm (parts per million)  

 FreqDevppm = (nominal data rate – FreqDev)/nominal data rate * 1e6.  

 

5.10 TX Rise Time MOI 

Definition:  

PCIe T-Tx-Rise is the time difference between the VRefHi(80%) reference level crossing and the 

VRefLo(20%) reference level crossing on the rising edge of the waveform. The VRefHi and 

VRefLo are calculated based on the voltage level of the previous UI. There are two distinct 

thresholds corresponding to de-emphasized transitions from low to high, and full swing transitions 

for VRefHi and VRefLo. Limits: 

Refer to Table 2 thru Table 14 for TTX-RISE-FALL measurement.   

Test Procedure: 

Ensure that PCIe T-Tx-Rise is selected in Jitter and Eye diagram Analysis Tools >PCI Express 

> Select menu. 

Set the following parameters 

Configure > Edges > Signal Type > Auto 

Select Configure > Clock Recovery. Configure the Clock Recovery to be consistent with the 

Clock Recovery method shown in Tables 2-14.  
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Configure > Bit Config > All Bits(By Default) 

Configure > Filter > Brick Wall Filter  

Configure > General >Off 

Configure > General >Off 

Measurement Algorithm:  

 

Figure 34. Rise Time Definition 

The application calculates this measurement using the following equation:  

Tn
Rise 

= ( Tn
Hi+

 -Tn
Lo+

) 

Where: 

  T 
Rise

 is the Rise time  

  T
Hi+

 is the VRefHi crossing on the rising edge  

  T
Lo+

 is the VRefLo crossing on the rising edge  

 

5.11 TX Fall Time MOI 

Definition:  

PCIe T-Tx-Fall is the time difference between the VRefLo(20%) reference level crossing 

and the VRefHi(80%) reference level crossing on the falling edge of the waveform. The 

VRefLo and VRefHi are calculated based on the voltage level of the previous UI. There 

are two distinct thresholds corresponding to de-emphasized transitions from high to low, 

and full swing transitions for VRefLo and VRefHi.  

Limits: 

Refer to Table 2 thru Table 14 for TTX-RISE-FALL measurement.   
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Test Procedure: 

Ensure that PCIe T-Tx-Fall is selected in Jitter and Eye diagram Analysis Tools >PCI Express 

> Select menu. 

Set the following parameters 

Configure > Edges > Signal Type > Auto 

Select Configure > Clock Recovery. Configure the Clock Recovery to be consistent with the 

Clock Recovery method shown in Tables 2-14.  

Configure > Bit Config > All Bits(By Default) 

Configure > Filter > Brick Wall Filter  

Configure > General >Off 

Configure > General >Off 

 

Measurement Algorithm:  

 

Figure 35. Fall Time Definition 

The application calculates this measurement using the following equation:  

Tn
Fall 

= ( Tn
Lo+

 -Tn
Hi+

) 

Where: 

  T 
Fall

 is the Fall time  

  T
Lo–

 is the VRefLo crossing on the falling edge  

  T
Hi–

 is the VRefHi crossing on the falling edge  
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5.12 Data Dependent Jitter MOI(TTX-DDJ) 

Definition: 

T-TX-DDJ (Data Dependent Jitter) is defined in the base specification Rev 1.0. This measurement 

is done using the     T-TX-DDJ.  The Result panel would display the Data Dependent Jitter values.   

 

Test Definition Notes from the Specification:  

Data dependent jitter is defined as the time delta between the PDF’s mean for each zero crossing 

point and the corresponding recovered clock edge.   

Limits: 

Refer to Table 3 for specified limits on the T-TX-DDJ measurement. 

Test Procedure: 

Ensure that T-TX-DDJ is selected in the Jitter and Eye diagram Analysis Tools >> Select menu. 

Set the following parameters: 

Horizontal Record length to at least 500K.  

Configure >> Clock Recovery >> PLL Custom BW >> Type I >> 10MHz 

Configure >> Global >> off  

Configure >> Global >> off  

Measurement Algorithm:  

Separation of jitter into data dependent and uncorrelated components may be achieved by 

averaging techniques; for example, by having the Tx repeatedly drive the compliance test pattern 

which is a repeating pattern. 

 

 

Figure 36: Relation between Data Edge PDF and Recovered Data Clock. 

Steps for doing the measurement: 

 

1. Recover the clock and convert it bit stream.  
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2. Find the repeating patterns and find the Pattern_Length and Pattern_Repeate_Count 

3.  

For k =0 to Pattern_Length find  

 For i = 0 to Pattern_Repeate_Count find  

  EdgeJitteri = Edgei – RecoveredClockEdgei 

 Find CorrelatedJitterk = mean (EdgeJitter) 

End 

4. Calculate Data dependent jitter as 

Data dependent jitter = max(CorrelatedJitter) - min(CorrelatedJitter) 

 

5.13 Uncorrelated Total Jitter (TTX-UTJ) 

Definition: 

T-TX-UTJ (Uncorrelated Total Jitter) is defined in the base specification Rev 1.0. This 

measurement is done using the     T-TX-UTJ.  The Result panel would display the Uncorrelated 

Total Jitter values. 

Test Definition Notes from the Specification:  

This type of jitter is referenced to a recovered data clock generated by means of a CDR tracking 

function. Uncorrelated total jitter may be derived after removing the DDJ component from each 

PDF and combining the PDFs for all edges in the pattern. 

Limits: 

Refer to Table 3 for specified limits on the T-TX-UTJ measurement. 

Test Procedure: 

Ensure that T-TX-UTJ is selected in the Jitter and Eye diagram Analysis Tools >> Select menu. 

Set the following parameters: 

Horizontal Record length to at least 500K.  

Configure >> Clock Recovery  >> PLL Custom BW >> Type I >> 10MHz 

Configure >> RjDj >> BER >> 1E-12 

Configure >> Global >> off  

Configure >> Global >> off  
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Measurement Algorithm:  

 

Figure 37: Derivation of TTX-UTJ and TTX-UDJDD 

Steps for doing the measurement: 

 

1. Recover the clock and convert it bit stream.  
2. Find the repeating patterns and find the Pattern_Length and Pattern_Repeate_Count 
3.  

For k =0 to Pattern_Length find  

 For i = 0 to Pattern_Repeate_Count find  

  EdgeJitteri = Edgei – RecoveredClockEdgei 

  

 Find CorrolatedJitterk = mean (EdgeJitter) 

//find un-correlated max and min jitter values by removing the correlated jitter values 

max_uncorrolatedJitter = max(max_uncorrolatedJitter, EdgeJitter - CorrolatedJitterk) 

min_uncorrolatedJitter = max(min_uncorrolatedJitter, EdgeJitter - CorrolatedJitterk) 

End 

 

4. Find the absolute maximum un correlated jitter (max_abs_uj) 
5. Based on the max_abs_uj create a histogram with appropriate bin length(this is used for 
creating the PDF). 
6. Create the PDF and combine all the PDFs for all the edges 
7. Convert the PDF into Q scale and draw a gaussian line(Gaussian Fit) to calculate  

 Vertical opening on left side and right side of the Q-scale curve and use these values to 
calculate Uncorrelated Total Jitter( T_TX_UTJ) = vertical open left – vertical open right. 
 
 
 



Methods of Implementation     

DPOJET PCI Express MOI   Page 62 of 89 

5.14 Uncorrelated Deterministic Jitter(TTX-UDJDD) 

Definition: 

T-TX-UDJDD (Uncorrelated Total Jitter) is defined in the base specification Rev 1.0. This 

measurement is done using the T-TX- UDJDD.  The Result panel would display the Uncorrelated 

Deterministic Jitter values. 

 

Test Definition Notes from the Specification:  

Uncorrelated deterministic jitter is defined as uncorrelated jitter at the zero crossing point and the 

corresponding recovered clock edge. 

Limits: 

Refer to Table 3 for specified limits on the T-TX-UDJDD measurement. 

Test Procedure: 

Ensure that T-TX-UDJDD is selected in the Jitter and Eye diagram Analysis Tools >> Select 

menu. 

Set the following parameters: 

Horizontal Record length to at least 500K.  

Configure >> Clock Recovery  >> PLL Custom BW >> Type I >> 10MHz 

Configure >> RjDj >> BER >> 1E-12 

Configure >> Global >> off  

Configure >> Global >> off  

Measurement Algorithm:  

 

Figure 38: Derivation of  TTX-UDJDD 
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Steps for doing the measurement: 

 

1. Recover the clock and convert it bit stream.  

2. Find the repeating patterns and find the Pattern_Length and Pattern_Repeate_Count 

3.  

For k =0 to Pattern_Length find  

For i = 0 to Pattern_Repeate_Count find  

EdgeJitteri = Edgei – RecoveredClockEdgei 

 

Find CorrolatedJitterk = mean (EdgeJitter) 

//find un-correlated max and min jitter values by removing the correlated jitter values 

max_uncorrolatedJitter = max(max_uncorrolatedJitter, EdgeJitter - CorrolatedJitterk) 

min_uncorrolatedJitter = max(min_uncorrolatedJitter, EdgeJitter - CorrolatedJitterk) 

       End 

 

4. Find the absolute maximum un correlated jitter (max_abs_uj) 

5. Based on the max_abs_uj create a histogram with appropriate bin length(this is used for 

creating    the PDF). 

6. Create the PDF and combine all the PDFs for all the edges 

7. Convert the PDF into Q scale and draw a gaussian line(Gaussian Fit) to calculate  

8. Vertical opening on left side and right side of the Q-scale curve and use these values to 

calculate Uncorrelated Total Jitter( T_TX_UTJ) = vertical open left – vertical open right 

9. Find where the gaussian line crosses the zero crossing and calculate TTX-UDJDD 
 

 
 

5.15 Uncorrelated Total Pulse Width Jitter (TTX-UPW-TJ) 

Definition: 

T-TX-UPW-TJ (Uncorrelated Total Pulse Width Jitter) is defined in the base specification Rev 

1.0. This measurement is done using the T-TX- UPW-TJ.  The Result panel would display the 

Uncorrelated Total Pulse Width Jitter values. 

 

Test Definition Notes from the Specification:  

Pulse width jitter is defined as an edge to edge phenomenon on consecutive edges. 

Limits: 

Refer to Table 3 for specified limits on the T-TX-UDJDD measurement. 

Test Procedure: 

Ensure that T-TX-UDJDD is selected in the Jitter and Eye diagram Analysis Tools >> Select 

menu. 

Set the following parameters: 
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Horizontal Record length to at least 500K.  

Configure >> Clock Recovery  >> PLL Custom BW >> Type I >> 10MHz 

Configure >> RjDj >> BER >> 1E-12 

Configure >> Global >> off  

Configure >> Global >> off  

 

Measurement Algorithm:  

 

Figure 39: Definition of TTX-UPW-TJ 

 

Steps for doing the measurement: 

1. Recover the clock and convert it bit stream.  

2. Find the repeating patterns and find the Pattern_Length and Pattern_Repeate_Count 

3. Find the correlated jitter 

For k =0 to Pattern_Length find  

 For i = 0 to Pattern_Repeate_Count find  

  EdgeJitteri = Edgei – RecoveredClockEdgei 

 Find CorrelatedJitterk = mean (EdgeJitter) 

End 

4. Replicate the correlated jitter for each of the pattern repeat. 

5. Calculate the PWJ referencing to a fixed leading edge and having jitter contributions from 

both edges appear at the trailing edge and calculate the mean_pwj. 

6. Based on the mean_pwj find the appropriate histogram and fit all the PWJ in this 

histogram to create the PDF. 

7. Calculate the Q-Scale extrapolation for this PWJ-PDF 

8. Vertical opening on left side and right side of the Q-scale curve and use these values to 

calculate Uncorrelated Total PWJ(TX-UPW-TJ) = vertical open left – vertical open right. 
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5.16 Uncorrelated Deterministic Pulse Width Jitter (TTX-UPW-DJDD) 

Definition: 

T-TX-UPW-DJDD (Uncorrelated Deterministic Pulse Width Jitter) is defined in the base 

specification Rev 1.0. This measurement is done using the T-TX-UPW-DJDD.  The Result panel 

would display the Uncorrelated Deterministic Pulse Width Jitter values. 

 

Test Definition Notes from the Specification:  

Uncorrelated Deterministic PWJ is defined as uncorrelated PWJ at the zero crossing. 

Limits: 

Refer to Table 3 for specified limits on the T-TX-UDJDD measurement. 

Test Procedure: 

Ensure that T-TX-UDJDD is selected in the Jitter and Eye diagram Analysis Tools >> Select 

menu. 

Set the following parameters: 

Horizontal Record length to at least 500K.  

Configure >> Clock Recovery  >> PLL Custom BW >> Type I >> 10MHz 

Configure >> RjDj >> BER >> 1E-12 

Configure >> Global >> off  

Configure >> Global >> off  

 

Measurement Algorithm:  

 

Figure 40: Definition of TTX-UPW-DJDD 
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Steps for doing the measurement: 

1. Recover the clock and convert it bit stream.  

2. Find the repeating patterns and find the Pattern_Length and Pattern_Repeate_Count 

3. Find the correlated jitter 

For k =0 to Pattern_Length find  

 For i = 0 to Pattern_Repeate_Count find  

  EdgeJitteri = Edgei – RecoveredClockEdgei 

 Find CorrelatedJitterk = mean (EdgeJitter) 

End  

4. Replicate the correlated jitter for each of the pattern repeat. 

5. Calculate the PWJ referencing to a fixed leading edge and having jitter contributions from 

both edges appear at the trailing edge and calculate the mean_pwj. 

6. Based on the mean_pwj find the appropriate histogram and fit all the PWJ in this 

histogram to create the PDF. 

7. Calculate the Q-Scale extrapolation for this PWJ-PDF 

8. Vertical opening on left side and right side of the Q-scale curve and use these values to 

calculate Uncorrelated Total PWJ(TX-UPW-TJ) = vertical open left – vertical open right 

9. Find where the gaussian line crosses the zero crossing and calculate the uncorrelated 

Deterministic PWJ(TTX-UPW-DJDD ) 

 

5.17 Voltage swing with No Equalizer (VTX-NO-EQ) 

Definition: 

V-TX-NO-EQ (Voltage swing with No Equalizer) is defined in the base specification Rev 1.0. 

This measurement is done using the V-TX-NO-EQ.  The Result panel would display the voltage 

swing without any equalization values. 

 

Test Definition Notes from the Specification:  

VTX-NO-EQ is defined by setting c-1 and c+1 to zero and measuring the PP voltage on the 64-

ones/64-zeroes segment of the compliance pattern. 

Limits: 

Refer to Table 3 for specified limits on the V-TX-NO-EQ measurement. 

Test Procedure: 

Ensure that V-TX-NO-EQ is selected in the Jitter and Eye diagram Analysis Tools >> Select 

menu. 

Set the following parameters: 

Horizontal Record length to at least 500K.  

Configure >> Clock Recovery  >> PLL Custom BW >> Type I >> 10MHz 

Configure >> Global >> off  
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Configure >> Global >> off  

 

Measurement Algorithm: 
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Figure 41: No Equalization PP Tx Voltage definition 

 

1. Find the 64 zeros/64 ones between two consecutive edges. 

2. Find the voltage between 57
th
 UI to 62

nd
 UI of positive cycle and negative cycle. 

3. Calculate the average voltage of the positive and negative cycle. 

4. Find the voltage difference between positive and negative cycles. 
 
 

5.18 P-P voltage swing in EIEOS sequence (VTX-EIEOS) 

Definition: 

V-TX-EIEOS (P-P voltage swing in EIEOS sequence) is defined in the base specification Rev 1.0. 

This measurement is done using the V-TX-EIEOS.  The Result panel would display the voltage 

swing in EIEOS sequence. 

 

Test Definition Notes from the Specification:  

VTX-EIEOS is defined by setting c+1 coefficient value of -0.33 and a c-1 coefficient of 0.0 and 

measuring the p-p voltage on the 8-ones/8-zeroes segment of the compliance pattern, where the 

pattern is repeated for a total of 128 UI. 

Limits: 

Refer to Table 3 for specified limits on the V-TX-EIEOS measurement. 

Test Procedure: 

Ensure that  V-TX-EIEOS  is selected in the Jitter and Eye diagram Analysis Tools >> Select 

menu. 
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Set the following parameters: 

Horizontal Record length to at least 500K.  

Configure >> Clock Recovery  >> PLL Custom BW >> Type I >> 10MHz 

Configure >> Global >> off  

Configure >> Global >> off  

 

Measurement Algorithm: 

 

Figure 42: EIEOS PP Tx Voltage definition. 

 

1. Find the 8 zeros/8 ones between two consecutive edges. 

2. Find the voltage between 3
rd

 UI to 7
th
 UI of positive cycle and negative cycle. 

3. Calculate the average voltage of the positive and negative cycle. 

4. Find the voltage difference between positive and negative cycles. 
 

5.19 Effective Tx package Loss ratio(Ps21TX) 

Definition: 

Ps21Tx (P-P voltage swing in EIEOS sequence) is defined in the base specification Rev 1.0. This 

measurement is done using the ps21Tx.  The result panel would display  

Test Definition Notes from the Specification:  

Ps21Tx is defined by setting c-1 and c+1 to zero and measuring the PP voltage on the 64-ones/64-

zeroes segment of the compliance pattern. 

Limits: 

Refer to Table 3 for specified limits on the Ps21Tx measurement. 
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Test Procedure: 

Ensure that ps21Tx is selected in the Jitter and Eye diagram Analysis Tools >> Select menu. 

Set the following parameters: 

Horizontal Record length to at least 500K.  

Configure >> Clock Recovery >> PLL Custom BW >> Type I >> 10MHz 

Configure >> Global >> off  

Configure >> Global >> off  

 

Measurement Algorithm: 

 

Figure 43: Effective Tx package Loss Ratio definition. 

 

1. Find the 1010 bit pattern (V101) for 128 UI in the compliance pattern. 

2. Find 64 ones/64zeros bit pattern (V111) adjacent to 1010 pattern. 

3. Find the 50,52 and 54
th
 bits from positive UIs and 49,51 and 53

rd
 bits from negative UIs of        

1010 bit pattern. 

4. Calculate the peak to peak voltage difference between positive and negative UIs. 

5. Find the voltage between 57
th
 UI to 62

nd
 UI of positive cycle and negative cycle in V111 

pattern. 

6. Calculate the average voltage of the positive and negative cycle. 

7. Find the voltage difference between positive and negative cycles. 

8. Calculate the Package Loss Ratio = 20log10(V101/V111). 
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5.20 Maximum Boost Ratio(V-Tx-Boost) 

Definition: 

V-Tx-Boost (P-P voltage swing after low frequency sequence) is defined in the base specification 

Rev 1.0. This measurement is done using the V-TX-BOOST.  The Result panel would display the 

voltage ratio. 

 

Test Definition Notes from the Specification:  

V-Tx-Boost is defined when  c-1 and c+1 are non-zero and measuring the PP voltage on the 64-

ones/64-zeroes segment of the compliance pattern and with immediate single transition bit voltage. 

Limits: 

Refer to Table 3 for specified limits on the V-Tx-Boost measurement. 

Test Procedure: 

Ensure that ps21Tx is selected in the Jitter and Eye diagram Analysis Tools >> Select menu. 

Set the following parameters: 

Horizontal Record length to at least 500K.  

Configure >> Clock Recovery >> PLL Custom BW >> Type I >> 10MHz 

Configure >> Global >> off  

Configure >> Global >> off  

 

Measurement Algorithm: 

 

Figure 44: Maximum Boost Ratio definition. 
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1. Find 64 ones/64zeros bit pattern 

2. Find the voltage between 57
th
 UI to 62

nd
 UI of positive cycle and negative cycle in       V111   

pattern. 

3. Calculate the average voltage of the positive and negative cycle (V111) in each 4680 pattern. 

4. Add all averaged voltage for entire waveform. 

5. Average again by number of repetitions of 4680 bit patterns in entire waveform, this is Vb. 

6. Find Single UI pulse after 64 ones/64 zeros. 

7. Calculate the peak to peak voltage difference between positive and negative UI (V1UI). 

8. Average all V1UI for entire waveform. 

9. Calculate the VBoost = 20log10(V1UI/V111). 

 

6  Appendix A 
Add-In Card Eye Diagrams 

PCI Express Gen 3 testing using SDLA version 1.2. Available on 32-bit Windows XP and Windows 7 

scopes. The amplitude and jitter masks are derived from the amplitude and jitter specifications in Table 4.  

 

Figure A1: Add-in card compliance eye masks 

Load the Add-In Card Setup File in DPOJET: 

1. In the scope menu, select Analyze->PCI Express 

2. In the DPOJET standard tab, click the select button to choose the Test Point 

3. Select Rev3.0->SDLA_Add-In-Card->R30_SDLA_Add-in-Card.set 
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4. In the Math Menu, set Math1 to Channel 1-Channel 2(Data)  

 

Figure A2: Setup File Selection 

 

Applying Channel and Behavioral Equalizer from SDLA: 

These measurements are done using SDLA (Serial Data Link Analysis) behavioral equalizer and channel 

embedding. Open SDLA from Analyze menu. Select ‘Equalizer’ and set the CTLE and DFE values as per 

the PCI Express 3.0 specification. For details of the PCI Express Gen 3 De-embedding procedure refer to 

the following document in  http://www.tek.com/method-implementation/pci-express-30-de-embedding-

method-implementation-version-10 

 

Figure A3: Serial Data Link Analysis window 

5.   Embed the Compliance Channel 

a. Select the Channel Block on the main SDLA window  

b. Under Data Input Type Select S-Parameter and click browse.  Select 

AicTx_Test_Embed01_SigTest_Mixed.s4p 

(File is available on C:\Users\Public\Tektronix\TekApplications\SDLA\input S 

parameters\) 

c. Select 4-port as the Touchstone format 

http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
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d. In the S-Parameter Specification section, select Differential as the Derive Filter From 

Selection 

e. Under Bandwidth Limit Click Apply 

f. Select Ok 

6.   Apply the PCI Express Reference Equalizer 

a. Select the Equalizer Block on the main SDLA window 

b. Select the CTLE and PcieC checkboxes  

c. Select the FFE/DFE and PcieD checkboxes 

d. Select Ok (Note:  Run EQ can be selected if the channel model has already been applied.  

Otherwise the waveform needs to be processed by using the Apply button in the main 

SDLA window)  

7.  Process waveform 

a. Select the TpB button on the main SDLA window.  This will ensure that Math3 is not 

overwritten as the Clock is assigned to Math3 

b. Select Math 1 as the input to SDLA 

c. Select 8Gb/s as the data rate 

d. Select Apply on the main SDLA window 

e. SDLA will automatically apply the channel model and determine the optimal CTLE and 

DFE settings.  This process must be re-run anytime a new acquisition is needed.   

 

Figure A4: SDLA Equalizer Setup Menu 

After SDLA is done processing, go to DPOJET and hit "Clear" and "ReCalc" to run the measurements.  

The results will be displayed as below: 
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Figure A5: DPOJET Measurement Results 
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System Board Eye Diagrams 

PCI Express Gen 3 testing using SDLA version 1.2. Available on 32-bit Windows XP and 

Windows 7 scopes. The amplitude and jitter masks are derived from the amplitude and jitter 

specifications in Table 5. 

 

Figure A6: System Board Compliance Eye Masks 

Load the System Setup File in DPOJET: 

1. In the scope menu, select Analyze->PCI Express 

2. In the DPOJET standard tab, click the select button to choose the Test Point 

3. Select Rev3.0->SDLA_System->R30_SDLA_SYSTEM.set 

4. Go to Horiz/Acq menu and change Record Length to 4M. 

5. In the Math Menu, set Math1 to Channel 3-Channel4(Data) and Math2 to Channel 1-

Channel2(Clock) 

 

Figure A7: Setup File Selection 

Applying Channel and Behavioral Equalizer from SDLA: 

These measurements are done using SDLA (Serial Data Link Analysis) behavioral equalizer and channel 

embedding. Open SDLA from Analyze menu. Select ‘Equalizer’ and set the CTLE and DFE values as per 

the PCI Express 3.0 specification. For details of the PCI Express Gen 3 De-embedding procedure refer to 
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the following document in http://www.tek.com/method-implementation/pci-express-30-de-embedding-

method-implementation-version-10 

 

Figure A8: Serial Data Link Analysis window 

6.   Embed the Compliance Channel 

a. Select the Channel Block on the main SDLA window  

b. Under Data Input Type Select S-Parameter and click browse.  Select 

SystemTx_Embed01_SigTest_Mixed.s4p 

(File is available on C:\Users\Public\Tektronix\TekApplications\SDLA\input S parameters\) 

c. Select 4-port as the Touchstone format 

d. In the S-Parameter Specification section, select Differential as the Derive Filter from 

Selection 

e. Under Bandwidth Limit Click None 

f. Select Ok 

7. Apply the PCI Express Reference Equalizer 

a. Select the Equalizer Block on the main SDLA window 

b. Select the CTLE and PcieC checkboxes  

c. Select the FFE/DFE and PcieD checkboxes 

d. Select Ok (Note:  RunEq can be selected if the channel model has already been applied.  

Otherwise the waveform needs to be processed by using the Apply button in the main 

SDLA window)  

8. Process waveform 

a. Select Math1 as the input to SDLA 

b. Select 8Gb/s as the data rate 

c. Select Apply on the main SDLA window 

d. SDLA will automatically apply the channel model and determine the optimal CTLE and 

DFE settings.  This process must be re-run anytime a new acquisition is needed.   

Note: Nominally the PCIe Rev3.0 bit rate is 8 Gb/s. But if a  signal with SSC is tested, the bit rate  should 

be set to 7.98 Gb/s. (0.25% lower)  

http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
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Figure A9: SDLA Equalizer 

After SDLA is done processing, go to DPOJET and hit "Clear" and "ReCalc" to run the measurements.  

The results will be displayed as below. 

To repeat measurements press Apply in SDLA and once the new acquisition and calculations are 

complete, press Recalc in DPOJET for analysis. Optionally, you can clear previous results by pressing 

Clear. This is necessary when testing different presets.  

When measuring systems with short channels, or when doing exploratory testing, CTLE equalization may 

be sufficient. Then use the setup in R30_SYSTEM folder. This setup does not require SDLA and sets up a 

CTLE with -7dB gain as an ArbFilter. It does not embed the channel. Press Single to acquire waveforms 

and calculate measurements. In this mode Free Run is possible. 

 

Figure A10: DPOJET Measurement Results 
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7 Appendix B 
To run SDLA in Win7 64 bit manually, user can follow the following steps: 

Add-In Card Eye Diagrams 

PCI Express Gen 3 testing using SDLA version 2.0. Available on Windows7 64 bit scopes. The amplitude 

and jitter masks are derived from the amplitude and jitter specifications in Table 5.  

 

Figure B1: Add-in card compliance eye masks 

Load the Add-In Card Setup File in DPOJET: 

1. In the scope menu, select Analyze->PCI Express 

2. In the DPOJET standard tab, click the select button to choose the Test Point 

3. Select Rev3.0->SDLA_Add-In-Card->R30_SDLA_Add-in-Card.set 

4. In the Math Menu, set Math1 to Channel 1-Channel 2(Data)  

 

Figure B2: Setup File Selection 

 

Applying Channel and Behavioral Equalizer from SDLA: 

These measurements are done using SDLA (Serial Data Link Analysis) behavioral equalizer and channel 

embedding. Open SDLA from Analyze menu. Select ‘Equalizer’ and set the CTLE and DFE values as per 
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the PCI Express 3.0 specification. For details of the PCI Express Gen 3 De-embedding procedure refer to 

the following document in  http://www.tek.com/method-implementation/pci-express-30-de-embedding-

method-implementation-version-10 

 

Figure B3: Serial Data Link Analysis window 

5. Embed the Compliance Channel 

a. Select Dual Input on the main SDLA window and select Ch1 and Ch2 as input. 

b. Select Embed block on the main SDLA window  

c. Under Embed block, click ‘File’. In Model parameter, select ‘4-Port Differential’ type. 

Click ‘Browse’ and Select ‘AicTx_Test_Embed01_SigTest_Mixed.s4p’ 

(File is available on C:\Users\Public\Tektronix\TekApplications\SDLA\input S 

parameters\) 

d. Select Ok 

 

Figure B4: Embadding Channel configuration 

6. Apply the PCI Express Reference Equalizer 

a. Select the Rx Equalizer Block on the main SDLA window 

b. Select ‘User’ button and set ‘On’. Select CTLE type as PCIE3.  

c. In Clock Recovery, select Bit Rate as ‘Auto Detect’. 

d. FFE/DFE set it to ‘On’. 

http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
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e. Select Ok (Note:  Run EQ can be selected if the channel model has already been applied.  

Otherwise the waveform needs to be processed by using the Apply button in the main 

SDLA window) 

 

Figure B5: Equalizer settings 

7. Process waveform 

a. Select the Tp3 button on the main SDLA window and select Math3 as Tp3. 

b. Also enable Tp5 (Ref3) for recovered Clock and Tp4 (Ref4) for Data. 

c. Select Apply on the main SDLA window 

d. SDLA will automatically apply the channel model and determine the optimal CTLE and 

DFE settings.  This process must be re-run anytime a new acquisition is needed.   

After SDLA is done processing, go to DPOJET and hit "Clear" and "ReCalc" to run the measurements.  

The results will be displayed as below: 

 

Figure B6: DPOJET Measurement Results 
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System Board Eye Diagrams 

PCI Express Gen 3 testing using SDLA version 2.0. Available on 64-bit Windows 7 scopes. The amplitude 

and jitter masks are derived from the amplitude and jitter specifications in Table 6. 

 

Figure B7: System Board Compliance Eye Masks 

Load the System Setup File in DPOJET: 

1. In the scope menu, select Analyze->PCI Express 

2. In the DPOJET standard tab, click the select button to choose the Test Point 

3. Select Rev3.0->SDLA_System->R30_SDLA_SYSTEM.set 

4. In the Math Menu, set Math1 to Channel 3-Channel4(Data) and Math2 to Channel 1-Channel 

2(Clock) 

 

Figure B8: Setup File Selection 

Applying Channel and Behavioral Equalizer from SDLA: 

These measurements are done using SDLA (Serial Data Link Analysis) behavioral equalizer and channel 

embedding. Open SDLA from Analyze menu. Select ‘Equalizer’ and set the CTLE and DFE values as per 

the PCI Express 3.0 specification. For details of the PCI Express Gen 3 De-embedding procedure refer to 

the following document in http://www.tek.com/method-implementation/pci-express-30-de-embedding-

method-implementation-version-10 

http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
http://www.tek.com/method-implementation/pci-express-30-de-embedding-method-implementation-version-10
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Figure B9: Serial Data Link Analysis window 

1. Embed the Compliance Channel 

a. Select Dual Input on the main SDLA window and select Ch1 and Ch2 as input. 

b. Select Embed block on the main SDLA window  

c. Under Embed block, click ‘File’. In Model parameter, select ‘4-Port Differential’ type. 

Click ‘Browse’ and Select ‘SystemTx_Embed01_SigTest_Mixed.s4p’ 

(File is available on C:\Users\Public\Tektronix\TekApplications\SDLA\input S 

parameters\) 

d. Select Ok 

 

Figure B10: Embedding compliance channel 

2.  Apply the PCI Express Reference Equalizer 

a. Select the Rx Equalizer Block on the main SDLA window 

b. Select ‘User’ button and set ‘On’. Select CTLE type as PCIE3.  

c. In Clock Recovery, select Bit Rate as ‘Auto Detect’. 

d. FFE/DFE set it to ‘On’. 

e. Select Ok (Note:  Run EQ can be selected if the channel model has already been applied.  

Otherwise the waveform needs to be processed by using the Apply button in the 

main SDLA window) 
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Figure B10: Equalizer settings 

3. Process waveform 

a. Select the Tp3 button on the main SDLA window and select Math3 as Tp3. 

b. Also enable Tp5 (Ref3) for recovered Clock and Tp4 (Ref4) for Data. 

c. Select Apply on the main SDLA window 

d. SDLA will automatically apply the channel model and determine the optimal CTLE and 

DFE settings.  This process must be re-run anytime a new acquisition is needed.   

e. After SDLA is done processing, go to DPOJET and hit "Clear" and "ReCalc" to run the 

measurements.  The results will be displayed as below: 

Note: Nominally the PCIe Rev3.0 bit rate is 8 Gb/s. But if a signal with SSC is tested, the bit rate should 

be set to 7.98 Gb/s. (0.25% lower)  

After SDLA is done processing, go to DPOJET and hit "Clear" and "ReCalc" to run the measurements.  

The results will be displayed as below. 

 

Figure B11: DPOJET Measurement Results 
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8 Appendix C 
 

8.1 Updated Limit Files 

 

The table shows the update to the limits of certain measurements in the specified limit files. All 

the other limits not specified in this table remain the same. The changes have been made based on 

latest limits extracted from SigTest 

 

Limit File Name Measurement Old Limit  New Limit 

R30_Tx_ADD_CON.xml 

T_TXA(Min) (in s) 0 0 

  4.125E-11 4.500E-11 

PCIe VTx-Diff-PP(Mean) (in V) 1.200E+00 1.200E+00 

  3.400E-02 5.000E-02 

VTXA(Mean) (in V) 1.200E+00 1.200E+00 

  3.400E-02 5.000E-02 

VTXA_d(Mean)(in V) 1.200E+00 1.200E+00 

  3.400E-02 5.000E-02 

Min TBit Voltage(Max)(in V) -2.300E-02 -2.500E-02 

  -6.000E-01 -6.000E-01 

Min nTBit Voltage(Max)(in V) -2.300E-02 -2.500E-02 

  -6.000E-01 -6.000E-01 

Max TBit Voltage(Min)(in V) 6.000E-01 6.000E-01 

  2.300E-02 2.500E-02 

Max nTBit Voltage(Min)(in V) 6.000E-01 6.000E-01 

  2.300E-02 2.500E-02 

TJ@BER1(Mean)(in s) 8.375E-11 8.000E-11 

  0 0 

PCIe UI1(Mean) (in s) 1.813E-10 1.26E-10 

  8.125E-11 1.25E-10 

R30_Tx_SDLA_Add-in-
Card.xml 

T_TXA(Min) (in s) 0 0 

  4.125E-11 4.500E-11 

PCIe VTx-Diff-PP(Mean) (in V) 1.200E+00 1.200E+00 

  3.400E-02 5.000E-02 

VTXA(Mean) (in V) 1.200E+00 1.200E+00 

  3.400E-02 5.000E-02 

VTXA_d(Mean) (in V) 1.200E+00 1.200E+00 

  3.400E-02 5.000E-02 

Min TBit Voltage(Max) (in V) -2.300E-02 -2.500E-02 

  -6.000E-01 -6.000E-01 
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Min nTBit Voltage(Max) (in V) -2.300E-02 -2.500E-02 

  -6.000E-01 -6.000E-01 

Max TBit Voltage(Min) (in V) 6.000E-01 6.000E-01 

  2.300E-02 2.500E-02 

Max nTBit Voltage(Min) (in V) 6.000E-01 6.000E-01 

  2.300E-02 2.500E-02 

TJ@BER1(Mean) (in s) 8.375E-11 8.000E-11 

  0 0 

PCIe UI1(Mean) (in s) 1.813E-10 1.257E-10 

  8.125E-11 1.250E-10 

R30_Base_Rx.xml 

TJ@BER(Max) (in s) N.A 8.125E-11 

   0 

DJ–δδ(Max) (in s) N.A 3.925E-11 

   0 

 

8.1 New Limit Files and Limits 

The following table shows the limit values from new limit files need to be added to perform PCI 

Express measurement with SSC. 

 

Limit File Name Measurement  Limit Value  

R11_Tx_ADD_CON_SSC.xml 

PCIe UI (Mean) (in s) 4.02E-10 

  4.00E-10 

Height1(Min) (in V) 1.20E+00 

  5.14E-01 

Height2(Min) (in V) 1.20E+00 

  3.60E-01 

Width(Min)(in s) 0.00E+00 

  2.87E-10 

PCIe Med-Mx Jitter(Max)(in s) 5.65E-11 

  0.00E+00 

R11_Tx_SYSTEM_SSC.xml 

PCIe UI (Mean) (in s) 4.02E-10 

  4.00E-10 

Height1(Min)(in V) 1.20E+00 

  2.74E-01 

Height2(Min) (in V) 1.20E+00 

  2.53E-01 

Width(Min)(in s) 0.00E+00 

  2.33E-10 

PCIe Med-Mx Jitter(Max)(in s) 7.70E-11 

  0.00E+00 
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TJ@BER(Max)(in s) 8.13E-11 

  0.00E+00 

DJ–δδ(Max) (in s) 3.93E-11 

  0.00E+00 

 

 




