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Service Safety Summary
Only qualified personnel should perform service procedures. Read this Service
Safety Summary and the General Safety Summary located in the RSA6100A
Service manual (Tektronix part number 071-1914-XX) before performing any
service procedures.

Do Not Service Alone. Do not perform internal service or adjustments of this
product unless another person capable of rendering first aid and resuscitation is
present.

Disconnect Power. To avoid electric shock, switch off the instrument power, then
disconnect the power cord from the mains power.

Use Care When Servicing With Power On. Dangerous voltages or currents may
exist in this product. Disconnect power, remove battery (if applicable), and
disconnect test leads before removing protective panels, soldering, or replacing
components.

To avoid electric shock, do not touch exposed connections.
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Kit Description

Kit Description
This kit describes the installation of the RTT/DPX (Option 200) Board and
the CPU bracket in an RSA6100A Series Real-Time Spectrum Analyzer. The
RTT/DPX (Option 200) board enables Enhanced DPX and Triggers functionality,
and replaces the RTT/DPX board in the instrument.

NOTE. You may not need to install the CPU bracket, check your instrument to
verify which bracket is installed. (See Figure 2 on page 5.)

Products
RSA6100A Series. All instruments

Kit Parts List
Quantity Part number Description
1 ea 863-0273-XX CIRCUIT BD ASSY;

RTT/DPX,PB-FREE,870027300
FUNCTIONALLY TESTED,878027300
TESTED,389367101 WIRED, OPTION 200

1 ea 407-5142-XX 1 BRACKET,SUPPORT; SLOT PC
1 ea 075-0987-00 INSTRUCTION,KIT; DPX BOARD

INSTALLATION FOR RSA6UP 200,PRINTED
1 ea 020-2715-XX PACKAGING KIT; INSTRUMENT SOFTWARE
1 ea 063-3930-XX SOFTWARE;DOCUMENTS CD
1 You may or may not need to install the CPU bracket, check your instrument.
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Installation Instructions

Installation Instructions
This section contains all procedures needed to install the RTT/DPX (Option
200) Board, the CPU bracket, and the product software in RSA6100A Series
instruments.

Minimum Tool and Equipment List
The following tools are required to remove the instrument covers, the bracket,
and reinstall the VGA cable. All tools are standard tools that should be readily
available.

Table 1: Tools required for installation
Item
no. Name Description
1 Screwdriver

handle
(magnetic)

Torque driver handle. Accepts 1/4-in. hex-head driver tips

2 T-15 TORX
tip

TORX-driver tip for T-15 size screws on the instrument covers

3 5/32-in. hex
wrench

Hex wrench to remove Allen head screws at front of top cover

4 T-10 TORX
tip

TORX-driver tip for T-10 size screw heads on the VGA cable
connector

5 3/16-in. nut
driver

Nut driver to remove the hex posts from the bracket (Slot PC
board)

Optional: A torque wrench helps to ensure reliable connections to meet the
nominal torque values that may be listed in these instructions.

These instructions are for qualified service personnel who are familiar
with servicing the product. If you need further details for disassembling or
reassembling the product, refer to the product service manual, Tektronix part
number 071-1914-xx.

Remove Cosmetic Top Cover

NOTE. Right-side or left-side references in these instructions assume you are
viewing the instrument from the front panel.

WARNING. To avoid electric shock which may result in injury or loss of life, switch
off the instrument power, then disconnect the power cord from the mains power.
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Installation Instructions

1. Remove the power cord.

2. If it is installed, pull the front protective cover off the instrument.

3. Remove the two T-15 TORX-driver screws that secure the plastic carrying
handle to the side of the instrument. (It is not necessary to remove the black
metal handles.) (See Figure 1.)

4. Remove four T-15 screws along each side that secure the top and bottom
covers to the instrument, and remove two 5/32-in. Allen head screws near the
front edge of the top cover (next to the folding handles).

5. Remove the top cover (leave the bottom cover in place). Remove the top
cover by pulling straight back about 1 inch. Then pull the sides of the top
cover outward, flexing them slightly to clear the instrument chassis, and pull
it away from the instrument.

6. Remove the 18 T-15 screws that secure the top internal cover to the chassis,
and then remove the top internal cover from the instrument.

Figure 1: Removing the Cosmetic Top Cover
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Installation Instructions

Remove the RTT/DPX Board and Bracket

NOTE. The slot numbers are labeled on the Digital Interface board by the
connectors.

1. Remove the RTT/DPX board from the instrument (Slot 5). Discard this board
as recommended by your company policy.

NOTE. Check if your instrument already has the CPU bracket installed as shown.
(See Figure 2.) If it does, skip the remaining steps in this section and install the
RTT/DPX (Option 200) board. Beginning with step 10. (See page 15.)

If you need to install the CPU bracket, follow these steps.

Figure 2: CPU bracket installed on Slot PC board
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Installation Instructions

2. If Option 05 (RT/IQ board) is installed in Slot 3, disconnect the cabling from
the RT/IQ board to gain sufficient clearance to remove the Slot PC board:

a. Use the board ejectors to disconnect the RT/IQ board connector.

b. Disconnect the IQ Out cables from the RT/IQ board, and lay them over
the rear panel.

c. Disconnect the IF Out cable from the SMB connector on the RT/IQ board.
Note the routing of this cable for reinstallation.

d. Disconnect the RT/IQ ground cable from its two-pin connector. Note the
routing of this cable for reinstallation.

Figure 3: Removing the cables from RT/IQ board

3. Remove the RT/IQ board from the instrument.

CAUTION. Do not remove the Acquisition board from the instrument. The
calibration of the instrument may be compromised, requiring a return to the
factory for recalibration.
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Installation Instructions

4. Disconnect the IDE cable to the HDD and/or DVD connector (Blue connector
on the IDE cable) from the Slot PC board.

Figure 4: IDE cable location

NOTE. Only disconnect the following cables from the Digital Interface Board. Do
not disconnect these cables from the Slot PC board (except for the Ethernet cable).

5. Disconnect these cables from the Digital Interface board:

Ethernet cable from J20 (PC NETWORK) and the Slot PC board

VGA cable from J28 (PC VIDEO)

Figure 5: Cables J20 and J28 locations
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Installation Instructions

12-pin Power cable from J36 (PC POWER). Hold down the latches on
either side of the connector to remove the cable.

40-pin cable from J29 (LVDS VIDEO IN). See note below.

NOTE. The 40-pin cable (J29) is difficult to connect and seat in the connector
on the Digital Interface board. When reinstalling, make sure that the
connector is fully seated.

10-pin ribbon cable from J34 (AC97 IN).

Figure 6: Cables J29, J34, and J36 locations [being updated, Mel]

6. Remove the two screws that secure the bracket to the side of the chassis using
a T-15 driver. (See Figure 6.)

7. Lift the Slot PC board, to disengage the PCI connector from the Digital
Interface board, but do not remove it completely from the instrument yet.
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Installation Instructions

8. Disconnect these cables from the Digital Interface board as shown. (See
Figure 7.)

44-pin ribbon cable from J32 (COM/USB/FP).

5-pin cable from J4.

Figure 7: Cables J4 and J32 locations
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Installation Instructions

9. Remove the Slot PC board from the instrument.

NOTE. If you accidently remove the J32 cable from the Slot PC board, reconnect
the ribbon cables as shown.

Figure 8: Ribbon cable locations (for J32) on the Slot PC board
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Installation Instructions

10. Remove the existing bracket from the Slot PC board:

Using a T-10 driver, remove the two screws from the VGA video cable
on the bracket.

Disconnect the VGA video cable from the socket.

Using the 3/16” nut driver, remove the four hex posts that attach the
RS232 connector and VGA connector to the bracket.

Figure 9: Slot PC board with older bracket
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Installation Instructions

Install the RTT/DPX (Option 200) Board and CPU Bracket

NOTE. Check if your instrument already has the CPU bracket installed as shown.
If it does, skip the following steps and install the RTT/DPX (Option 200) board.
Go to step 10. (See page 15.)

If you need to install the CPU bracket, follow these steps.

1. Install the CPU bracket on the Slot PC board as shown using the existing hex
posts (4) disconnected in step 10 of the removal procedure. (See page 11.)

Figure 10: CPU Bracket and Slot PC board

2. Install the Slot PC board by reconnecting the cables disconnected in steps 4
through 5 of the removal procedure. (See page 7.)

12 RSA6100A Series RSA6UP Option 200 Upgrade



Installation Instructions

3. Using a T-15 wrench and the two existing bracket screws, install the CPU
bracket on the chassis (torque to 8.0 in-lb). (See Figure 11.)

4. Dress the VGA cable through the black plastic grommet on the CPU bracket
and connect the VGA cable to the VGA connector on the CPU bracket.

5. Using a T-10 wrench and the two existing VGA-connector screws, secure the
VGA connector to the hex posts on the CPU bracket (torque to 5.5 in-lb).

6. Dress the Ethernet cable through the black plastic grommet on the CPU
bracket and connect the Ethernet cable to the Ethernet connector on the CPU
bracket.

Figure 11: CPU bracket installed on the chassis
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Installation Instructions

7. Reconnect the IDE cable to the Slot PC board. (See Figure 12.)

8. Using a cable tie, rebundle the IDE cables to the top of the CPU bracket (on
the smooth edge).

Figure 12: IDE cables and cable tie location (for Options 06 and 08)

Figure 13: IDE cables and cable tie locations (for Option 07)
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Installation Instructions

9. If the RT/IQ (Option 05) board was installed in Slot 3, reconnect the cables
disconnected in step 2. (See page 5, Remove the RTT/DPX Board and
Bracket.) (Reseat the RT/IQ board into the Digital Interface board connector.
Be careful not to bend the pins on the Digital Interface board when seating
the RT/IQ board.)

Figure 14: RT/IQ (Option 05) and RTT/DPX (Option 200) boards installed.

CAUTION. To prevent damage to the connector on the Digital Interface board,
gently slide and then connect the RTT/DPX (Option 200) board into the Digital
Interface board connector.

10. Install the RTT/DPX (Option 200) board (Slot 5). Be careful not to bend
the pins on the Digital Interface board when seating the RTT/DPX (Option
200) board.

11. Reinstall the top internal cover. (See Figure 1 on page 4.)

Place the top internal cover onto the instrument, aligning the two
protrusions on the cover with the two slots in the chassis.

Replace the 18 T-15 screws that secure the top internal cover to the
chassis. Torque these screws to 8.0 in/lb.
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Installation Instructions

Reinstall Cosmetic Top Cover
Reinstall the top and bottom covers. (See Figure 1 on page 4.)

1. Place the instrument on the rear feet, so the front panel is facing up and the
top is toward you.

2. Place the top cover over the top of the instrument and slide it toward the
front panel. Make sure that the top cover wraps around the flanges on the
rear panel on all three sides.

3. Reinstall the four 5/32-in. Allen head screws (two on each side) near the
front edge of the top cover (next to the folding handles) that secure the top
cover to the instrument.

4. Align the four screw holes on each side in the top and bottom covers with the
holes in the chassis, and install eight T-15 screws, four on each side. Torque
these screws to 8.0 in/lb.

5. Position the plastic carrying handle and its bracket on the right side of the
instrument, and install the two T-15 screws that secure it in place. Torque
these screws to 8.0 in/lb.

Software Installation
Use the RSA6100A Series product software disc to reinstall the spectrum analyzer
product software if your instrument software version is earlier than the software
version listed on the disc.

1. If a keyboard is not installed, connect one to the instrument (the supplied
accessory keyboard plugs into the USB connector).

2. If your instrument has a removable hard drive (Option 06) or a solid-state hard
drive (Option 08), connect a USB external DVD drive to the instrument.

3. Power on the instrument.
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Installation Instructions

4. After the instrument completes booting up, exit the product software
application (Select File > Exit).

5. Insert the Product Software disc in the front-panel DVD drive (or external
drive), and close the drive tray.

6. The Setup Wizard starts. Follow the instructions to install the product
software.

CAUTION. When the Setup Wizard displays the Select Installation Folder
screen, the Setup Wizard allows you to select whether the software is installed
for Everyone or Just me. Always select Everyone to ensure proper software
operation.

7. When the product software installation is complete, the Installation
Complete screen appears. Click Close to exit the Setup Wizard.

8. When the RSA6100A Setup dialog box appears, click OK.

The Product Software is now ready to use.

Install Option Key To activate the enhanced DPX and Trigger functionality option:

1. In the spectrum analyzer application, select Tools > Install Upgrades. The
Install Upgrade wizard starts, as shown in Figure 1. Click Continue.

Figure 15: Starting the option upgrade

2. The Install Upgrade Enter Key screen appears as shown.
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Installation Instructions

Figure 16: Entering the option installation key

3. Type the option installation key into the empty text box and click Continue.
An Installation Success dialog box opens, as shown.

Figure 17: Upgrade success notification
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Installation Instructions

4. Click Close. Exit and restart the RSA6100A application to enable the new
feature.

5. Select Help > About Tektronix Real Time Spectrum Analyzer.

6. In the installed Options window verify that Option 200 is listed.

7. Click Ok.

Installing the Option Key
Label

Place the new option key label over the existing label on the instrument rear panel.

This completes the installation of the Enhanced DPX and Trigger functionality
(Option 200) upgrade kit.

<End of Document>
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