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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to
this product or any products connected to it. To avoid potential hazards, use this
product only as specified.
Only qualified personnel should perform service procedures.
While using this product, you may need to access other parts of the system. Read
the General Safety Summary in other system manuals for warnings and cautions
related to operating the system.
To Avoid Fire or Personal Injury:
Connect and Disconnect Properly: Do not connect or disconnect probes or test
leads while they are connected to a voltage source.
Observe All Terminal Ratings: To avoid fire or shock hazard, observe all
ratings and markings on the product. Consult the product manual for further
ratings information before making connections to the product.
Do Not Operate With Suspected Failures: If you suspect there is damage to
this product, have it inspected by qualified service personnel.
Symbols and Terms: The following terms and symbols may appear in the online
help.

WARNING. Warning statements identify conditions or practices that could
result injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could
result in damage to this product or other property.

Terms on the Product: The following terms may appear on the product:
DANGER indicates an injury hazard immediately accessible as you read the
marking.
WARNING indicates an injury hazard not immediately accessible as you read
the marking.
CAUTION indicates a hazard to property including the product.
Symbols on the Product: The following symbol(s) may appear in the product:
CAUTION
Refer to Help
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Introduction to the PTD Application
The Protocol Trigger and Decode (PTD) application enables you to decode and
simultaneously display protocol-level information and physical layer signaling.
The PTD application includes the following features:
• Simultaneously view signal, characters, and protocol
• Decode 8b/10b encoded serial data
• Correlate events across physical and link layers
• Synchronize your oscilloscope and protocol views

Related Documentation
Refer to the Optional Applications Software on Windows-Based Oscilloscope
Installation Manual for the following information:
• Software warranty
• List of all available applications, compatible oscilloscopes, and relevant
software and firmware version numbers
• Applying a new label
• Installing an application
• Enabling an application
• Downloading updates from the Tektronix Web site
Note: You can view PDF file of the installation manual from the CD Installation
Browser and from the Documents directory on the Optional Applications
Software on a Windows-Based Oscilloscope CD-ROM.

Application CD Contents
The Optional Applications Software on a Windows Based Oscilloscope CD-ROM
includes files for the following types of documentation:
• Printable file of the RT-Eye Serial Data Compliance and Analysis online help
• Printable file of the Protocol Trigger and Decode Tool online help
• PDF files of the Methods of Implementation (MOI) for the InfiniBand, PCI
Express, and FB-DIMM serial data standards as they apply to the
corresponding compliance modules
• Reference guides
• Optional Applications Installation manual
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Access to PDF Files
You can use any of the following methods to view the various PDF files
associated with this application:
• Access a file in the Documents directory on the Applications CD from any PC
• Select a file from the Start menu in the oscilloscope task bar; you may need to
first minimize the application
• Access a file from the Help drop-down list in the PTD application

Conventions
Online help topics use the following conventions:
• The term "click" is used to indicate choosing an option either with a mouse or
by tapping as you would with a Touch Screen
• The term "Compliance Module" refers to optional "plug-in applications" from
Tektronix used for compliance testing to specific serial data standards
• The term "channel" is context dependent. It can refer to the transmit channel
of the device under test or to an oscilloscope channel
• The term "DUT" is an abbreviation for Device Under Test
• When steps require a sequence of selections using the application interface,
the ">" delimiter marks each transition between a menu and an option. For
example, one of the steps to recall a setup file would appear as File> Recall
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Feedback
Tektronix values your feedback on our products. To help us serve you better,
please send us suggestions, ideas, or other comments you may have about your
application or oscilloscope.
You can email your feedback to techsupport@tektronix.com,
FAX at (503) 627-5695, or by phone. Please be as specific as possible and
include the following information:
General Information
• Oscilloscope model number and hardware options, if any
• Probes used
• Serial data standard
• Signaling rate
• Your name, company, mailing address, phone number, FAX number
Note: Please indicate if you would like to be contacted by Tektronix regarding
your suggestion or comments.

Application Specific Information
• Software version number
• Description of the problem such that technical support can duplicate the
problem
• If possible, save the oscilloscope waveform file as a .wfm file
• If possible, save the oscilloscope and application setup files from the
application to obtain both the oscilloscope .set file and the application .ini file.
Refer to Saving a Setup File
Once you have gathered this information, you can contact technical support by
phone or through e-mail. If using e-mail, be sure to enter "TDSJIT3 v2 Problem"
in the subject line, and attach the .set, .ini, and .wfm files.
Note: To include screen shots, from the oscilloscope menu bar, select File >
Export. In the Export dialog box, enter a file name with a .bmp extension and
select Save. The file is saved in the C:\TekScope\Images directory. You can then
attach the file to your email (depending on the capabilities of your email editor).
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Getting Started
Protocol Trigger and Decode Control Window
The Protocol Trigger and Decode control window consists of three windows,
which you can show or hide from view. Use the Display Window drop-down list
in the application window to select which windows to show and which ones to
hide from view.

Figure 1: Protocol Trigger and Decode control window
The application window includes:
• Controls for selecting data sources and serial standards
• Controls for the type of information displayed
• Controls for oscilloscope acquisitions
• Controls for synchronization
• Status readout of the decode process
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The symbolic window includes:
• Character and protocol displays
• Controls for configuring information display
The waveform window includes:
• Waveform display
• Horizontal zoom controls
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Basic Operation
Application Controls
The application window includes controls for selecting data sources and serial
standards, the type of information displayed, and oscilloscope acquisitions and
synchronization.

Figure 2: Application view
Use the Data Source drop-down list to select your data source. Data sources can
be Channels 1-4, or Ref 1-4. Selecting File allows you to browse for waveforms
stored in .wfm format.
The Decode Status is a scrolling area that displays information about the
decoding process.
Use the Serial Standard drop-down list to select the serial standard that you
want to use in your analysis. You can select PCI Express, SATA, or a userdefined standard. The standard that you select will also determine what appears
in the Character and Protocol displays.
Use the Display Window drop-down list to display or hide the Waveform and
Symbolic windows. Select All from the list to display both the Waveform and
Symbolic windows.
Click the Decode Data button to analyze the data that is currently selected in the
Data Source drop-down list.
If you need to acquire data, click the Single button. This button works similarly
to the Single button on the front panel of an oscilloscope. Clicking the Single
button in the application starts an acquisition, analyzes the acquired data, and
then updates the display windows. Use the Force Trig button if you need to
simulate a trigger event to complete the acquisition. After the acquisition is
complete, the application analyzes the acquired data and updates the display
windows.
To synchronize the host oscilloscope with the data that is displayed by the
application, use the buttons under Synchronize Oscilloscope with Character. If
you want to see the same area on your oscilloscope that is displayed in the
Waveform window of the PTD application, click Zoom 1. The oscilloscope will
zoom in on the portion of the waveform that you have displayed in the PTD
application.
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To synchronize the host oscilloscope using cursors, be sure that you have cursors
turned on and set to V-bars on the host instrument. Select a line in either the
Character or Protocol display, and then click Cursor 1. The position of Cursor 1
on the oscilloscope will be updated to match the selection in the PTD application.

Symbolic Window Controls
The symbolic window controls character and word displays as well as
configuring information displays.

Figure 3: Symbolic window control
Use the Data Filter drop-down list to select the level of abstraction that you want
in the Protocol display.
The Data Filter drop-down list contains the following choices:
• Primitives—Dwords (four-character sequences) beginning with a control
character
• FIS—Frame Information Structure, disassembly includes frame header
information
• ATAPI—AT Attachment Packet Interface
Note: The protocol window will be blank if you select FIS or ATAPI with
standards other than SATA. Only SATA contains FIS and ATAPI.
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Waveform Window Controls
The waveform window displays the waveform and annotations and allows you to
zoom on a displayed waveform.
To display the entire waveform, click the Show All button. To magnify the
waveform horizontally, click the In button. To reduce the waveform, click the
Out button. Click the Dword button to set the waveform window to contain four
10b symbols of data.

Figure 4: Waveform window controls

Trigger Setup Controls
Use the Trigger Setup control window to set up direct hardware triggering on
8b/10b characters and words. This enables you to fill the memory of the
instrument with an event of interest rather than taking a random snapshot. Serial
protocol triggering allows you to isolate a variety of link layer control sequences,
or faults. To open this control window, go to the PTD Trigger menu and select
Setup.

Figure 5: Trigger Setup control window
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Use the Trigger On drop-down list to select different serial trigger types: 8b/10b
Word, 8b/10b Character, 8b/10b Code Error, or Bit Pattern. Selecting 8b/10b
Word allows you to specify a four-character sequence of 8b/10b-coded characters
to trigger on. This can be either from a list of predefined words or as individual
characters. To select predefined primitives, select Word from the Edit group box,
and then use the 8b/10b Word drop-down list to select the word. The standard
determines which predefined words are available in the list.
To select individual characters, you must choose Character from the Edit group
box. The Character 1-4 buttons display the value for the currently selected word.
You can change the character values by clicking a Character button.
Select 8b/10b Character from the Trigger On drop-down list to trigger on only
one character. Selecting Specific Character from the Edit group box allows you
to trigger on one specific character. Click the Character button to change the
character value that you want to trigger on. Selecting Any Valid Control
Character allows you to trigger on the first valid control character found.

Figure 6: Trigger Setup with Code Error selected
By default, the trigger system is loaded with patterns for both positive and
negative running disparity. You can use the Pattern drop-down list to select only
characters that arrive after a positive or a negative running disparity. Note that
the Trigger Patterns reflect your selection in the Pattern drop-down list.
To trigger on a code error select 8b/10b Code Error from the Trigger On dropdown-list, and then select the type of errors that you want to trigger on. You can
select any combination of errors from the list.
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To trigger on a specific bit pattern, select Bit Pattern from the Trigger On dropdown list, and then select either Binary or Hex from the Format drop-down list.
Enter the bit pattern, and then click Apply.

Figure 7: Trigger Setup with Binary Bit Pattern selected

Figure 8: Trigger Setup with Hex Bit Pattern selected

Character Entry Dialog Box
Use the Character Entry dialog box to modify or change the characters that you
want to trigger on. To access this dialog box, click a Character button in the
Trigger Setup control window.
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Select either Character or Hex Data Format. In Character format, click either
K or D, and then enter the decimal values for the character. If you entered a
K-character, its symbolic name is shown in the Value/Name field. If you entered
a D-character, its hexadecimal value is shown in the Value/Name field. You can
also click a Control Symbol button, and the Character field will show the value
of that control symbol.

Figure 9: Character Entry dialog box
In Hex Data format, enter the Hex Data Byte using the keypad. The
corresponding code value is shown in the Character field. You can also click a
Control Symbol button, and the Character field will show the value of that
control symbol. The Value/Name field displays the 8b/10b character equivalent.

Figure 10: Character Entry dialog box when Hex Data format selected
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How To?
Synchronize Data in the Symbolic and Waveform Windows
When you click any word in the Protocol field, the Waveform displays the
beginning of that sequence, starting at the left. The corresponding character in the
Character field is highlighted.

Figure 11: Waveform with character in the character field highlighted
When you click any character in the character field, the Waveform displays the
beginning of that sequence, starting at the left. The word in the Protocol field will
be highlighted.

Figure 12: Waveform with word in the protocol field highlighted
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Synchronize Data with the Host Oscilloscope
To synchronize a zoom window on the host oscilloscope with the data that is
displayed by the PTD application, do the following:
Click Zoom 1 under Synchronize Oscilloscope with Character. The oscilloscope
Zoom 1 display changes to match the area of the waveform that you have
displayed in the PTD application.
To synchronize cursors in the host oscilloscope with the data that is displayed by
the PTD application, do the following:
1. From the protocol window in PTD, click a character or primitive.
2. From the application window in PTD, click Cursor 1 or Cursor 2. The
corresponding cursor in the host oscilloscope moves to the same location.

Define Your Own Standard
To define your own standard, do the following:
1. Open the User file located in C:\TekApplications\TSDPTD\Macros.
2. Use Microsoft Excel or a similar application to edit the file. The file is in
.CSV format.
3. Select Save As from the File menu and type in a unique name in the File
name text box.
4. Select .CSV format from the Save as type drop-down list.
Your file will appear in the Standard drop-down list in the PTD application.
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Show and Hide Windows
To show or hide windows, do the following:
1. Click the Display Window drop-down list.
2. Select the window(s) that you want to show.
•

All displays both the Symbolic and Waveform windows

•

Symbolic displays the Symbolic window but hides the Waveform
window

•

Waveform displays the Waveform window but hides the Symbolic
window

•

None hides both the Symbolic and Waveform windows

Change the Window Size
To change the size of the symbolic window or the waveform window, do the
following:
1. Click the white line that separates the window from other windows. The
white line will change color.
2. Drag the line either up or down.
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