TG700
TV Signal Generator Platform
PC Tools

Technical Reference

DO O 00 0 RO 10 TEktronix
077-0138-01 7/






TG700
TV Signal Generator Platform
PC Tools

Technical Reference

www.tektronix.com Tektronix
077-0138-01 Ve



Copyright © Tektronix. All rights reserved. Licensed software products are owned by Tektronix or its subsidiaries
or suppliers, and are protected by national copyright laws and international treaty provisions.

Tektronix products are covered by U.S. and foreign patents, issued and pending. Information in this publication
supersedes that in all previously published material. Specifications and price change privileges reserved.

TEKTRONIX and TEK are registered trademarks of Tektronix, Inc.

Contacting Tektronix

Tektronix, Inc.

14200 SW Karl Braun Drive
P.O. Box 500

Beaverton, OR 97077

USA

For product information, sales, service, and technical support:
= In North America, call 1-800-833-9200.
= Worldwide, visit www.tektronix.com to find contacts in your area.


http://www.tektronix.com/contact

Warranty

Tektronix warrants that this product will be free from defects in materials and workmanship for a period of one (1)
year from the date of shipment. If any such product proves defective during this warranty period, Tektronix, at its
option, either will repair the defective product without charge for parts and labor, or will provide a replacement

in exchange for the defective product. Parts, modules and replacement products used by Tektronix for warranty
work may be new or reconditioned to like new performance. All replaced parts, modules and products become
the property of Tektronix.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of
the warranty period and make suitable arrangements for the performance of service. Customer shall be responsible
for packaging and shipping the defective product to the service center designated by Tektronix, with shipping
charges prepaid. Tektronix shall pay for the return of the product to Customer if the shipment is to a location within
the country in which the Tektronix service center is located. Customer shall be responsible for paying all shipping
charges, duties, taxes, and any other charges for products returned to any other locations.

This warranty shall not apply to any defect, failure or damage caused by improper use or improper or inadequate
maintenance and care. Tektronix shall not be obligated to furnish service under this warranty a) to repair damage
resulting from attempts by personnel other than Tektronix representatives to install, repair or service the product;
b) to repair damage resulting from improper use or connection to incompatible equipment; c) to repair any damage
or malfunction caused by the use of non-Tektronix supplies; or d) to service a product that has been modified or
integrated with other products when the effect of such modification or integration increases the time or difficulty
of servicing the product.

THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE PRODUCT IN LIEU OF ANY
OTHER WARRANTIES, EXPRESS OR IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY
IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE.
TEKTRONIX’ RESPONSIBILITY TO REPAIR OR REPLACE DEFECTIVE PRODUCTS IS THE SOLE

AND EXCLUSIVE REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF THIS WARRANTY.
TEKTRONIX AND ITS VENDORS WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL,
OR CONSEQUENTIAL DAMAGES IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS
ADVANCE NOTICE OF THE POSSIBILITY OF SUCH DAMAGES.

[W2 — 15AUG04]






Table of Contents

General Safety SUMMATY .......oiiii et ettt e e e e aeeaees v
Environmental ConsSiderations ............o.ueuueute ettt e ettt e aaeaans vii
PO A .. e X
PrOAUCES . . e ix
PO TO0IS e ix
Related ManUalS ........oiiiti i e e e e e e e X
PC System ReqUITCIMENTS . ......uutieette ettt et et e et e e et e et e e ee e eeeeaneeanes X
Using TG7 Setup to Set Parameters ... ....oouiiiittii it et et e e e e e e e eee e 1
Installation Instructions and Ethernet Setup ..........coviiiiiiiiii e 1
Starting and EXiting TG7 SetUP .....iiuriiriiitt it et e ae e e eaeaaeens 3
Elements of the TG7 Setup WINdOW .......o.oitiitiiiii e 3
USINg the TG7 SETUP MEIUS ....uuitiitt ittt ettt ettt et ettt e e ee et e ee et e teerteenneenneennees 4
TGT7 Setup TUtOrial .. ... e e e e e e e, 5
Using TG7 Comm for File Transfers...........oooiii i 8
Installation Instructions and Ethernet Setup ..........ooviiiiiiiiiiii e 8
Starting and EXiting TG7 COmIM.........cuuiiiiiiiiti it e e e e e e e aaeeenens 10
Elements of the TG7 Comm WIndOW ...........ooiiiiiiiiii i 10
Using the TGT7 Comm IMEINUS .....vviititett ettt et et e e et e e e ee e e eeeeaneeaaneeen 12
TG7 Comm TULOTIAlS . . ..o e e e e 14
USING the File Copy TOO0LS .. ..uuiieitit ettt et e e et et e e e et et et e ae e eneenes 17
Installation Instructions and Ethernet Setup ..........coiiiiiiii i e 17
Starting and Exiting the File Copy ToOIS ......c..oiiiiiii e 18
File Copy Tools TULOTIALS . ...ttt et et ettt e et e et e et e e e e eneaaans 18
Using Frame Picture Generator ........o.uuiiititiit ittt e e et e et e e e eeeeaaeeanaas 23
Installation INSIIUCHIONS ... ....uiti e 23
Starting and Exiting Frame Picture Generator. ..........o.vvvuiiiiiiiiiiiii et ieieneeneenneenaans 24
Elements of the Frame Picture Generator Window .............coiiiiiiiiiiiiiiiii i, 24
Using the Frame Picture Generator MENUS ..........c.ootiitiiirtete et et et eiteeiteaineanneanneanns 26
Frame Picture Generator Tutorials.......... ..o 28
USING LOZO GENETALOT ...ttt ettt et ettt et e e e e eaee 32
Installation INSIIUCHIONS ... ...t e 32
Starting and EXiting Logo Generator............viiiuiiiiitt it ii e e eie e e eeaee e 33
Elements of the Logo Generator WindoOW...........c.oviuiiiiiiiiiiii it eeeeaeennns 33
Using the Logo Generator MEIUS. . ... ...uuuteeett et et et te e eeeee e eee e eneeeaneeaanaenn 35
Logo Generator TULOTIALS .. .....oueit it 37
Firmware UPrade. .......oouiiiii ittt et et et et et et et e et et et et et e e ne s 39
Equipment ReqUITEd. .........oiiiiii i e e e e e 39
UPErade ProCedUuIes ........o.uiniinii i 39
Firmware Version Check . ..... ..o e 42

TG700 TV Signal Generator Platform PC Tools Technical Reference i



Table of Contents

Network Interface SpecifiCations ............oouiiniiiiii 43
Checking Remote Command OPeration. .. ......ovuueurentiiteieteterteneeneerieeaeeaieeneenness 44
Index

ii TG700 TV Signal Generator Platform PC Tools Technical Reference



List of Figures

Figure 1:
Figure 2:
Figure 3:
Figure 4:
Figure 5:
Figure 6:
Figure 7:
Figure 8:
Figure 9:

Figure 10:
Figure 11:
Figure 12:
Figure 13:
Figure 14:
Figure 15:
Figure 16:
Figure 17:

Ethernet dialog box for TG7 SetUP .....eineiiiniiii e 2
TG7 Setup application WINAOW ........c.uvnuiiititiit et eieeeeeaeeans 3
Rename dialog DOX ....oieriiii e 5
Setup window for DVG7 module .........o.ooiiiiiiiii e 6
Ethernet dialog box for TG7 CommM ... ....iiiriiiit it eeeeaaeaas 10
TG7 Comm application WINAOW .........ouutenutit ettt et e 11
File name confirmation dialog bOX.........c.vviriiiiiiiii e 15
Sequence File dialog DOX ......viiiiiiiii i e 16
TG7 BacKup WindOW .....uiiii it e e e e et e e 20

Dialog box shows backup 18 COMPIEte ........oveiiiiiiii i e e 20
TG7 REStOre WINAOW. ... eetietet et et et et et et et et et et et et e e e e eas 21
Dialog box shows restore iS COMPIELe. ... ...vvuvriieit it eeaeeaes 21
TG7 DUPLICAtOr WINAOW ... .ut ittt ettt et e e e e e et e et e e e eae e e aneeeneannaans 22
Dialog box shows file transfer is complete ...........ooiiiiiiiiiiiii e 22
Frame Picture Generator application Window .............ccoviiiiiiiiiiiiiiiiiiiii e, 25
BUILDING PIC FILES dialog DOX. .. .ottt et ee e 29
Logo Generator application WiNAOW ..........vuiviriinttitieteiite et e eeeaeeannes 34

Figure 18: Gray Scale Settings dialog DOX .........oiiiiiiii e 36
Figure 19: Miscellaneous Settings dialog bOX ........oiiiiiiiiiiii i e 37
Figure 20: BMP to LGO File Conversion dialog DoX .........couviiiiiiiiiii i, 38
Figure 21: TG700 Upgrade dialog DOX .....o.viiniiiiiitiit ettt et et e e eaeen 40
Figure 22: Message box appearing after the file transfer is complete ..., 41

TG700 TV Signal Generator Platform PC Tools Technical Reference ii



Table of Contents

List of Tables

v

Table 1: Elements of the TG7 Setup WindoW .........ooviiiriiiiiii it eeeneans 4
Table 2: TG7 Setup File menu commands..........c.ovuiiitiiiiitt ittt ittt eereeaeanans 4
Table 3: Elements of the TG7 Comm WinAOW ........c.uiiiiitiitiitiiie et rieeaaaeenn 11
Table 4: Toolbar button deSCIIPLIONS ......uuiii ittt ettt et e et e e e e e e eae e aaaeennenns 12
Table 5: TG7 Comm File menu commands ............c.ooiiiiiiiii i e e 13
Table 6: TG7 Comm View Menu COMMANGS.......uutetinetettetettatereeneeneeneereeaeenneennens 13
Table 7: TG7 Comm Utility menu COMMANS ........o.eivutiintitirtt ittt ereeneereeneerneanens 14
Table 8: Elements of the Frame Picture Generator Window .............oovviiiiiiiiiiiiieiiiiiieeinannn.. 25
Table 9: Toolbar button deSCIIPLIONS ... .o.uuititt ettt e e e et e e e e e ae e aaaeeanenes 25
Table 10: Frame Picture Generator File menu commands................coooiiiiiiiiiiiiiiiiiii e 26
Table 11: Frame Picture File Build menu commands .............ccovviiiiiiiiiiiiiiiiiiiiiiiiieeeeeees 27
Table 12: Frame Picture Generator Settings menu commands ...........o.vvveivniiiiriiieeiinerneinennn.. 27
Table 13: Elements of the Logo Generator Window ............oouiiiiiiiiiiiiieiii i e eanenns 34
Table 14: Toolbar button deSCIIPIONS. . ...ttt ettt ettt et e et e e ee e e eeaaeeaaaeennenns 35
Table 15: Logo Generator File menu commands .............oeiiiiiiiiiiiiiii e 35
Table 16: Logo Generator Build menu commands ............c.cooiiiiiiiiiiiiiiiiiiiii i 35
Table 17: Logo Generator Settings menu COMMANAS ........ouveuterreerneenteeteenreeneernearneerneannens 36
Table 18: Logo Generator Help menu command ..............oooiiiiiiiiiiie i eeaenes 37

TG700 TV Signal Generator Platform PC Tools Technical Reference



General Safety Summary

General Safety Summary

Review the following safety precautions to avoid injury and prevent damage to
this product or any products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

To Avoid Fire or Personal  Use Proper Power Cord. Use only the power cord specified for this product and
Injury  certified for the country of use.

Ground the Product. This product is grounded through the grounding conductor
of the power cord. To avoid electric shock, the grounding conductor must be
connected to earth ground. Before making connections to the input or output
terminals of the product, ensure that the product is properly grounded.

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all ratings
and markings on the product. Consult the product manual for further ratings
information before making connections to the product.

Power Disconnect. The power cord disconnects the product from the power source.
Do not block the power cord; it must remain accessible to the user at all times.

Do Not Operate Without Covers. Do not operate this product with covers or panels
removed.

Do Not Operate With Suspected Failures. If you suspect that there is damage to this
product, have it inspected by qualified service personnel.

Avoid Exposed Circuitry. Do not touch exposed connections and components
when power is present.

Wear Eye Protection. Wear eye protection if exposure to high-intensity rays or
laser radiation exists.

Do Not Operate in Wet/Damp Conditions.
Do Not Operate in an Explosive Atmosphere.
Keep Product Surfaces Clean and Dry.

Provide Proper Ventilation. Refer to the manual’s installation instructions for
details on installing the product so it has proper ventilation.
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General Safety Summary

Terms in this Manual  These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result
in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in
damage to this product or other property.

B DANGER indicates an injury hazard immediately accessible as you read
the marking.

B WARNING indicates an injury hazard not immediately accessible as you
read the marking.

B CAUTION indicates a hazard to property including the product.

A A B @

CAUTION warNING  Dovble
Refer to Manual ~ High Voltage

@

Not suitable for
connection to
the public telecom-
munications network

Protective Ground
(Earth) Terminal
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Environmental Considerations

This section provides information about the environmental impact of the product.

Product End-of-Life Observe the following guidelines when recycling an instrument or component:
Handling

Equipment Recycling. Production of this equipment required the extraction and
use of natural resources. The equipment may contain substances that could be
harmful to the environment or human health if improperly handled at the product’s
end of life. In order to avoid release of such substances into the environment and
to reduce the use of natural resources, we encourage you to recycle this product
in an appropriate system that will ensure that most of the materials are reused or
recycled appropriately.

This symbol indicates that this product complies with the European Union’s
requirements according to Directive 2002/96/EC on waste electrical and
electronic equipment (WEEE). For information about recycling options, check
the Support/Service section of the Tektronix Web site (www.tektronix.com).

Restriction of Hazardous  This product has been classified as Monitoring and Control equipment, and is
Substances  outside the scope of the 2002/95/EC RoHS Directive.
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Preface

This manual provides information about various PC tools that can be used with
the TG700 TV Signal Generator Platform and related modules.

Products
The information in this manual applies to the following products:
B TG700 TV Generator Platform
B AG7 Audio Generator Module
®  AGL7 Analog Genlock Module
B ATG7 Analog Test Generator Module
B AVG7 Analog Video Generator Module
B AWVG7 Analog Wideband Video Generator Module
B BG7 Black Generator Module
®  DVGT7 Digital Video Generator Module
®  GPS7 GPS Synchronization and Timecode Module
B HDLG7 HD Dual Link Generator Module
= HDVG7 HDTYV Digital Video Generator Module
®  HD3G7 HD 3 Gb/s SDI Video Generator Module

PC Tools

The following utilities and software applications are described in this manual:
B TG7 Setup

B TG7 Comm

®m  File copy tools

®  Frame Picture Generator

B Logo Generator

m  Firmware upgrade
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Preface

Related Manuals
The following documents are also available for the TG700:

B The TG700 TV Signal Generator Platform User Manual (Tektronix part
number 071-1970-XX) describes how to install and operate the mainframe
and related modules.

B The TG700 TV Signal Generator Platform Specifications and Performance
Verification Technical Reference (Tektronix part number 077-0137-XX)
describes the mechanical, electrical, and environmental specifications for the
mainframe and related modules. This manual also provides performance
verification procedures.

®  The TG700 TV Signal Generator Platform Programmer Manual (Tektronix
part number 077-0139-XX) provides programming information for the
mainframe and related modules.

B The TG700 TV Signal Generator Platform Service Manual (Tektronix part
number 077-0230-XX) describes how to service the TG700 mainframe to
the module level (such as circuit boards and fuses) and provides general
information about servicing generator modules. Specific service information
for a module is located in its service manual. Service manuals are optional
and must be ordered separately.

PC System Requirements

Each application described in this manual requires certain minimum system
requirements.

TG7 Setup and TG7 Comm require the following:

B Microsoft Windows 95, 98, 2000, XP, Vista, or NT4.0 (for Windows 95 or NT
4.0, Internet Explorer 4.01 or later needs to be installed)

®m  Ethernet interface

Using the File Copy Tools requires the following:

B Microsoft Windows 2000/XP

B Ethernet interface

Using Frame Picture Generator requires the following:
B Microsoft Windows 95, 98, 2000, or NT4.0

B True Color (more than 24 bits) display mode
Using Logo Generator requires the following:

B Microsoft Windows 95, 98, 2000, or NT4.0

X TG700 TV Signal Generator Platform PC Tools Technical Reference



Using TG7 Setup to Set Parameters

TG7 Setup, a standard accessory with the TG700, is a software application for a
PC using the Microsoft Windows system. TG7 Setup provides the capability to set
all of the parameters of the TG700 mainframe and installed modules using a PC.

This section provides the following information:
B Installation instructions and Ethernet setup
®  Starting and exiting TG7 Setup

= Elements of the TG7 Setup window

B Using the TG7 Setup menus

m  TG7 Setup tutorial

Installation Instructions and Ethernet Setup

This subsection contains instructions to install and configure the TG7 Setup
application on your PC.

Installing TG7 Setup  The following installation instructions require that you are familiar with the basics
of using the Windows operating system. If necessary, read your Windows user
documentation before installing TG7 Setup.

Perform the following procedure to install TG7 Setup software:

1. Be sure that your PC meets the requirements before proceeding with the
installation. (See page x, PC System Requirements.)

2. Insert the TG700 Signal Generator Platform SW Library and
Documentation CD (063-3939-XX) into a CD drive on your PC.

3. When the Product Software and Documentation Browser window appears,
select the TG7 Tools Software link.

4. Seclect the TG7 Setup link to install the software. Follow the on-screen
instructions to complete the software installation.

Creating a Desktop  Perform the following procedure to create an icon on your PC desktop that you
Shortcut Icon  can use to run the TG7 Setup application.

1. On your PC display, right click to open the desktop menu.

2. Use the New > Shortcut command to create a shortcut to the TG7setup.exe
file.

3. You can start the TG7 Setup application by double-clicking the shortcut icon.

TG700 TV Signal Generator Platform PC Tools Technical Reference 1



Using TG7 Setup to Set Parameters

Connecting Your PC(s) to
the TG700

Setting Ethernet Network
Parameters

TG7 Setup uses the rear-panel 10 BASE-T port on the TG700 to communicate
with a PC.

Refer to Connecting to a Network in the TG700 TV Signal Generator Platform
User Manual (Tektronix part number 071-1970-XX) for detailed information
about how to connect your PC(s) to the TG700.

Before you can use TG7 Setup to set the parameters of the TG700 mainframe and
installed modules, you must set the Ethernet network parameters for both the
TG700 platform and the TG7 Setup application.

NOTE. Use the ping command from the PC to verify network communications
after you set the Ethernet network parameters for the TG700 platform and for the
TG7 Setup application.

Ethernet Parameters for the TG700. The Ethernet network parameters for the
TG700 can be set using the NETWORK SETUP submenu in the UTILITY main
menu. Refer to Setting Ethernet Network Parameters in the TG700 user manual
for detailed information about how to set the network parameters.

Ethernet Parameters for TG7 Setup. When you start the TG7 Setup application,
the Ethernet dialog box appears as shown in the following figure. Use this dialog
box to set the Ethernet network parameters for the TG7 Setup application.

Ethernet Ed

IP Address |1?2 17 37 &0

Ik I Gancel |

Figure 1: Ethernet dialog box for TG7 Setup

Perform the following procedure to set the Ethernet network parameters for the
TG7 Setup application:

1. Use the IP Address field in the dialog box to enter the IP address that you
assigned to the TG700.

2. Click the OK button to accept the settings and close the dialog box.

TG700 TV Signal Generator Platform PC Tools Technical Reference



Using TG7 Setup to Set Parameters

Starting and Exiting TG7 Setup

When you complete the installation procedure, you can use any of the following
methods to start the TG7 Setup application:

B Double-click the TG7Setup.exe shortcut icon on the PC desktop that you
created during the installation procedure.

B Double-click the TG7Setup.exe file name in the Program Manager window.
m  Select TG7Setup from the Start - Programs menu.

To exit the TG7 Setup application, select File > Exit in the application window.

NOTE. When you start the TG7 Setup application, the TG700 front-panel are
disabled once the application window appears. (See Figure 2.)

Elements of the TG7 Setup Window

The following figure shows the TG7 Setup application window. For description of
the elements in the application window refer to the following table.

Title bar = TG7Setup - HDVG7[2]
Menu bar File View Window Help

= HDVG7[2]

Signal |Mcwing F'ictutel Dverlayl Audio | Yideo I Black I Black [fwudic 4 I ’I

Format
| 1080 59.94i =] T Frame picture

Signal set Ficture set
|COLOR BAR R4l

Setup window ————> Signal Picture

| SMPTE Color Bars Al

Timing
‘“ertical Lines Horizontal Delay

= | 0.0000-% [usec]

Cancel

Status bar Ready [ hm[ 4

0138-001

Figure 2: TG7 Setup application window
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Using TG7 Setup to Set Parameters

Table 1: Elements of the TG7 Setup window

Element Description

Title bar The Title bar displays the name of the application and contains
the standard window-sizing boxes for Windows.

Menu bar The Menu bar displays the names of the four pull-down menus.
(See page 4, Using the TG7 Setup Menus.)

Setup window Use the Setup window to set the parameters for the installed

modules or mainframe. This window appears after you select
the Open Module or Open TG700 command from the File
pull-down menu.

Status bar The Status bar displays the short explanation of the currently
selected command and the information related to the operation.

Using the TG7 Setup Menus

File Menu

The Menu bar displays the names of the four pull-down menus: File, View,
Window, and Help. This section describes the function of each selection in these
menus.

The File menu contains commands for opening a setup window, for managing
preset operations, and for exiting the TG7 Setup application. The following
describes each of the File menu commands.

Table 2: TG7 Setup File menu commands

Command Function

Open TG700 Opens the setup window for the TG700 mainframe.

Open Module Opens the setup window for the selected module.

Recall Preset Recalls the selected preset.

Save Preset Saves the current instrument settings to the selected preset.
Rename Preset Renames the selected preset name. When you select this

command, the Rename dialog box appears. (See page 4,
Rename Dialog Box.)

Exit Exits the TG7 Setup application.

Rename Dialog Box. The Rename dialog box (following figure) appears after you
select the Rename Preset command. You can use this box to assign a new name
to the selected preset.

TG700 TV Signal Generator Platform PC Tools Technical Reference



View Menu

Window Menu

Help Menu

TG7 Setup Tutorial

Setting Parameters

Using TG7 Setup to Set Parameters

Rename

Currant Mame

|FRESET 2

Mew Mame

| 4 I Cancel

Figure 3: Rename dialog box

The View menu Status Bar command toggles the display of the Status bar on and
off in the application window. A check mark precedes the command in the menu
when the Status bar is selected for display.

The Window menu commands (Cascade, Tile, and Arrange Icons) control the
appearance of the setup windows in the application window. Use Arrange Icons
when the setup windows are minimized.

The Help menu About TG7Setup... command displays information including the
TG7 Setup software version number and copyright information.

After you have connected the TG700 to the PC using an Ethernet cable and set the
required network parameters, you can use TG7 Setup to set the parameters for the
TG700 mainframe and installed modules.

NOTE. Refer to the Operating Basics section of each module’s User manual for
detailed explanation of the parameters and their setting ranges.

This subsection explains how to set the parameters of an installed module. In this
example, you will set the parameters for the DVG7 module.

Perform the following steps to set parameters:

1. Select File > Open Module > DVG7 to open the setup window for the
DVG7 module as shown in the following figure.

TG700 TV Signal Generator Platform PC Tools Technical Reference 5



Using TG7 Setup to Set Parameters

= DVGT[2] M=

Tab for selecting
the parameter item

» Signal | Moving Picture | Overlay | Audio | Video | Black | Black (Audio) |

Format
[525-270 =] I Frams picturs:
Signal =t Bictirgisst
JCOLOR BAR =l |58 =l
Signal Ficture
|‘IDEI% Color Bars ;l |kann02 ;l
Timing
Wertical Lines Horizontal Delay
| 0= | 28074 = [usec]
’TI Cancel fpply

Figure 4: Setup window for DVG7 module

At the top of the setup window, there are several tabs to select parameters.
When you click one of the tabs, you access the fields associated with that
parameter. In this example, the Signal tab is selected and the fields for setting
the signal format, signal set, output signal, frame picture, and timing are
displayed.

When you change any parameter in the window, the Apply button at the
bottom of the window becomes active. Press this button to enable the new
parameter settings.

2. Click the tab associated with the parameter you want to set. This opens the
parameter fields for that tab.

3. Set parameters in the displayed fields.
4. Repeat Steps 2 and 3 until all of the parameter settings are completed.

5. When you finish making changes to the parameters, click the Apply button.
This enables the parameter settings in the setup window and transfers them to
the TG700.

6 TG700 TV Signal Generator Platform PC Tools Technical Reference



Using TG7 Setup to Set Parameters

NOTE. If you select a signal file or a picture file that is not assigned to a test
signal button on the TG700 front panel, an error message appears when you
click the Apply button. If this happens, you need to assign the file to a test signal
button. Refer to SIGNAL KEY ASSIGN Submenu in the TG700 user manual for
more information.

When you change parameters for a module, that module is selected in the TG700,
regardless of what is shown on the display. To prevent addressing the wrong
module from the front panel after you exit TG7 Setup, first select any of the
modules using the MODULE button and then make settings.

TG700 TV Signal Generator Platform PC Tools Technical Reference 7



Using TG7 Comm for File Transfers

Using TG7 Comm for File Transfers

TG7 Comm, a standard accessory with the TG700, is a software application for a
PC using the Microsoft Windows system. TG7 Comm provides the capability to
transfer signal, logo, preset, frame picture, or sequence files between a PC and the
TG700 using the Ethernet interface.

This section provides the following information:

Installation instruction and Ethernet setup
Starting and exiting TG7 Comm
Elements of TG7 Comm window

Using the TG7 Comm menus

TG7 Comm tutorials

Installation Instructions and Ethernet Setup

Installing TG7 Comm

This subsection contains instructions to install and configure the TG7 Comm
application on your PC.

The following installation instructions require that you are familiar with the basics
of using the Windows operating system. If necessary, read your Windows user
documentation before installing the TG7 Comm software.

Perform the following procedure to install TG7 Comm:

1.

Be sure that your PC meets the requirements before proceeding with the
installation. (See page x, PC System Requirements.)

Insert the TG700 Signal Generator Platform SW Library and
Documentation CD into a CD drive on your PC.

When the Product Software and Documentation Browser window appears,
select the TG7 Tools Software link.

Select the TG7Comm link to install the software. Follow the on-screen
instructions to complete the software installation.

TG700 TV Signal Generator Platform PC Tools Technical Reference



Using TG7 Comm for File Transfers

Creating a Desktop  Perform the following procedure to create an icon on your PC desktop that you
Shortcut Icon  can use to run the TG7 Comm application.

1. On your PC display, right click to open the desktop menu.

2. Use the New > Shortcut command to create a shortcut to the TG7Comm.exe
file.

3. You can start the TG7 Comm application by double-clicking the shortcut icon.

Connecting Your PC(s)to ~ TG7 Comm uses the rear-panel 10 BASE-T port on the TG700 to communicate
the TG700  with a PC.

Refer to Connecting to a Network in the TG700 TV Signal Generator Platform
User Manual (Tektronix part number 071-1970-XX) for detailed information
about how to connect your PC(s) to the TG700.

Setting Ethernet Network  Before you can use TG7 Comm to transfer files between the TG700 and your
Parameters  PC(s), you must set the Ethernet network parameters for both the TG700 and
the TG7 Comm application.

NOTE. Use the ping command from the PC to verify network communications
after you set the Ethernet network parameters for the TG700 and for the TG7
Comm application.

Ethernet Parameters for the TG700. The Ethernet network parameters for the
TG700 can be set using the NETWORK SETUP submenu in the UTILITY main
menu. Refer to Setting Ethernet Network Parameters in the TG700 TV Signal
Generator Platform User Manual (Tektronix part number 071-1970-XX) for
detailed information about how to set the network parameters.

TG700 TV Signal Generator Platform PC Tools Technical Reference 9



Using TG7 Comm for File Transfers

Ethernet Parameters for TG7 Comm.

Perform the following procedure to set the Ethernet network parameters for the
TG7 Comm application:

1. Select Network from the Utility menu of the TG7 Comm application. This
will open the Ethernet dialog box. (See Figure 5.)

2. Use the IP Address field in the dialog box to enter the IP address that you
assigned to the TG700.

3. Click the OK button to accept the settings and close the dialog box.

Ethernet

Target Device
’7 IF Address I 172 17 37 90
| Ok I Cancel I

Figure 5: Ethernet dialog box for TG7 Comm

Starting and Exiting TG7 Comm

When you complete the installation procedure, you can use any of the following
methods to start the TG7 Comm application:

m  Double-click the TG7Comm.exe shortcut icon on the PC desktop that you
created during the installation procedure.

B Double-click the TG7Comm.exe file name in the Program Manager window.
m  Select TG7comm from the Start - Programs menu.

To exit the TG7 Comm application, select File > Exit in the application window.

Elements of the TG7 Comm Window

The following figure shows the TG7 Comm application window. For description
of the elements in the application refer to the following table.

10 TG700 TV Signal Generator Platform PC Tools Technical Reference



Title bar —
Menu bar —

B& 167 Comm
File Wview Utlity Help

Using TG7 Comm for File Transfers

Toolbar —

Tree view

[l TG700 [128,131.103,199]
-3 AGT

-3 AGL7
®-{13 ATGT
-3 AVGT
-3 awve7
=-Z3 B67

- PRESET
-7 SIGNAL
F-C3 cPU

-3 DVGT

2 HD3G7
{23 PRESET
=-{Z3 HOLG7

| | Mame

Size I

,.! 5 Step~Staircase.cmp

,.! Limit Ramp,cmp

,.! Ramp.cmp

,.! Shallow Ramp“Matrix.cmp
,.! Shallow ~R.amp.cmp

,.! Valid Ramp.cmp

- PRESET -
L =0 SIGNAL
List view s O e
=0 1035 60i
. -3 coLor BAR
M
Status bar ——»Jready

1,853
5,904
5,385
22,470
3,028
39,571

|6 object[s]

|?6.6KB [Memory free: 35, 7ME]

2|

Figure 6: TG7 Comm application window

0138048

Table 3: Elements of the TG7 Comm window

Element Description

Title bar The Title bar displays the name of the application and contains
the standard window-sizing boxes for Windows.

Menu bar The Menu bar displays the names of the four pull-down menus.
(See page 12, Using the TG7 Comm Menus.)

Toolbar The Toolbar provides shortcut buttons for many of the most
often used menu commands. Click a toolbar button to select the
corresponding command. You can toggle the toolbar display on
and off using the Toolbar command in the View pull-down menu.
(See Table 4.)

Tree view The Tree view displays the TG700 file structure. The contents

of the selected directory are displayed in the List view. The IP
address of the selected TG700 is displayed at the top of the
Tree.
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Table 3: Elements of the TG7 Comm window (cont.)

Element Description

List view The List view displays the contents of the selected directory in
the Tree view. You can use the View pull-down menu to alter the
display in the List view.

Status bar The Status bar displays the number of files (objects) stored in the
selected directory, the total file size of the selected directory, and
the amount of free disk space in the TG700’s system memory.

Table 4: Toolbar button descriptions

Icon Name Function
PCto TG Equivalent to the PC toTG
command in the File menu.
(] TGto PC Equivalent to the TG toPC
e command in the File menu.
= Up One Level Moves from the current
3 folder to the upper level
folder.
o Large Icons Equivalent to the Large
= Icons command in the View
menu.
Small Icons Equivalent to the Small
Icons command in the View
menu.
List Equivalent to the List

command in the View menu.

Details Equivalent to the Details
command in the View menu.

Using the TG7 Comm Menus

12

File Menu

The Menu bar displays the names of the four pull-down menus: File, View, Utility,
and Help. This section describes the function of each selection in these menus.

The File menu contains commands for managing file operations and for exiting
the TG7 Comm application. The following table describes each of the File menu
commands.
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Table 5: TG7 Comm File menu commands

Command Function

PCto TG Displays the PC to TG Download dialog box, where you can
select the file you want to transfer from your PC to the directory
in the TG700 selected in the Tree view.

TG to PC When you select this command after you highlight a file in the
List view of the TG7 Comm application, the TG to PC Upload
dialog box appears. You can select a destination path and file
name for the file you want to transfer to your PC.

New Creates a new folder in the selected directory of the TG700.
Delete Deletes the file or empty folder selected in the TG700.
Rename Renames the file or folder selected in the TG700.

Exit Exits the TG7 Comm application.

View Menu  The View menu contains commands that control the appearance of the TG7
Comm application window. The following table describes each of the View
menu commands.

Table 6: TG7 Comm View menu commands

Command Function

Toolbar Toggles the display of the Toolbar on and off in the application
window. A check mark precedes the command in the menu
when the Toolbar is selected for display.

Status Bar Toggles the display of the Status bar on and off in the application
window. A check mark precedes the command in the menu
when the Status bar is selected for display.

Large Icons Causes the application to display files or folders in the List view
using large icons. A check mark precedes the command in the
menu when Large Icons is selected.

Small Icons Causes the application to display files or folders in the List view
using small icons. A check mark precedes the command in the
menu when Small Icons is selected.

List Causes the application to display files or folders in the List view
in a vertical list form. A check mark precedes the command in
the menu when List is selected.

Details Causes the application to display files or folders in the List view
in a detailed column format which includes the file size and last
modified date of each file. A check mark precedes the command
in the menu when Details is selected.

When you select Details, you can click on the column names
in the List view to reorder the contents of the directory by file
name, by file size, or by file date.
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Utility Menu

Help Menu

TG7 Comm Tutorials
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Table 6: TG7 Comm View menu commands (cont.)

Command Function

Arrange Icons Sets the display order for the folders and files in the List view.
You can arrange the List view display by Name, Size, or Date.

Refresh Refreshes the file display in the List view.

The Utility menu contains commands for setting the network parameters.

Table 7: TG7 Comm Utility menu commands

Command Function

Network Opens the Ethernet dialog box where you can set the IP address
of the target TG700. (See page 9, Setting Ethernet Network
Parameters.)

Check Error Opens the TG Error dialog box, which lists the errors detected
in the TG700.

Options Opens the Set Options dialog box, where you can specify which

text editor application you will use to describe a sequence file.

The Help menu About... command displays information including the TG7 Comm
software version number and copyright information.

You can set the network parameters for the TG700 using the NETWORK SETUP
submenu.

After you have connected the TG700 to the PC using an Ethernet cable and set the
required network parameters, you can use TG7 Comm to transfer files between
the PC and the TG700.

NOTE. The convention used by the TG7 Comm application is to call file transfers
from the PC to the TG700 a "download," and to call file transfers from the TG700
to the PC an "upload.”
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You can download and upload the following types of files:
B Signal file (*.dnl)

B Logo file (*.Igo)

m  Frame picture file (*.pic)

B Preset file (*.p00 to *.p14)

®m  Sequence file (*.seq)

c CAUTION. Do not execute any operations except for Delete and Rename for a
*.cmp file in the SIGNAL folder of each module.

Downloading a File to the  This subsection provides the procedures to download a file from the PC to the
TG700 TG700.

NOTE. When you download files to the TG700, make sure that the TG700 has at
least 1 MB of free memory space. This information is displayed on the status
bar in the application window.

Signal File, Logo File, Frame Picture File, or Preset File. Perform the following
steps to download a signal file, logo file, frame picture file, or preset file from
the PC to the TG700.

1. In the Tree view of the TG7 Comm application, select the destination folder
for the file you are going to download to the TG700.

2. Select File > PC to TG.

3. Inthe PC to TG Download dialog box, select the file on the PC that you want
to download and the type of file, and then click the Download button to open
the dialog box to confirm the file name. Refer to the following figure.

4. In the dialog box, confirm the file and then click the OK button to download
the file.

File:  |C:%Program FileshTektronixh TGE7O0MT G Comm\HDWGF.LGO

| ]9 | | Cancel

Figure 7: File name confirmation dialog box

TG700 TV Signal Generator Platform PC Tools Technical Reference 15



Using TG7 Comm for File Transfers

Uploading a File to the PC

16

Sequence File. Perform the following steps to download a sequence file from
the PC to the TG700.

1. In the Tree view of the TG7 Comm application, select the destination folder
for the file you are going to download to the TG700.

2. Select File > PC toTG.

3. Inthe PC to TG Download dialog box, select the file on the PC that you want
to download and the type of file (*.seq), and then click the Download button
to open the Sequence File dialog box. (See Figure 8.)

4. Confirm the sequence file that you want to download.

5. When you click the Edit button, you can view the content of the sequence
file and edit it.

6. Click the OK button to download the file.

Sequence file

File:  [C:\Program Files\Tektronix\TG700\TG7Comm\scpi_1.seq

Edit I

Cancel |

Figure 8: Sequence File dialog box

Perform the following steps to upload a file from the TG700 to the PC (the
procedure for uploading is the same for all file types):

1. In the List view of the TG7 Comm application, select the file you want to
upload to the PC.

2. Select File > TG toPC.

3. Inthe TG to PC Upload dialog box, specify the destination folder for the file
you are going to upload to your PC.

4. Click the Upload button to upload the file from the TG700 to your PC.

About Uploading a Preset File. When you save instrument settings as a preset,
separate preset files are created for each module. Therefore, when you upload a
preset file using the TG7 Comm application, you need to create the folders for
each module and upload all the files in it.

Once you have uploaded a preset file from the TG700 to the PC, you can
download the file to another TG700 with the same configuration and use it as
a known setting.

A preset file can easily be backed up and restored by the TG7 Backup and TG7
Restore applications. (See page 17, Using the File Copy Tools.)
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Using the File Copy Tools

The file copy tools (TG7 Backup, TG7 Restore, and TG7 Duplicator, standard
accessories with the TG700) are software applications for a PC using the
Microsoft Windows system. TG7 Backup and TG7 Restore provide the capability
to back up and restore preset files between a PC and the TG700 using the Ethernet
interface. TG7 Duplicator provides the capability to transfer all of the files
between two TG700 Generators, using the Ethernet interface.

This section provides the following information:
B Installation instructions and Ethernet setup
B Starting and exiting the file copy tools

m  File copy tools tutorials

Installation Instructions and Ethernet Setup

This subsection provides instructions to install and connect the file copy tools
on your PC.

Installing the File Copy  The following installation instructions require that you are familiar with the basics
Tools  of using the Windows operating system. If necessary, read your Windows user
documentation before installing the file copy tools.

Perform the following procedure to install the file copy tools:

1. Be sure that your PC meets the requirements before proceeding with the
installation. (See page x, PC System Requirements.)

2. Insert the TG700 Signal Generator Platform SW Library and
Documentation CD into a CD drive on your PC.

3. When the Product Software and Documentation Browser window appears,
select the TG7 Tools Software link.

4. Select the File Copy Tools link to install the software. Follow the on-screen
instructions to complete the software installation.

Creating a Desktop  Perform the following procedure to create icons on your PC desktop that you can
Shortcut Icon  use to run the file copy tools; TG7 Backup, TG7 Restore, and TG7 Duplicator.

1. On your PC display, right click to open the desktop menu.

2. Use the New > Shortcut command to create a shortcut to the TG7Backup.exe,
TG7Duplicator.exe, or TG7Restore.exe file.

3. You can start the application by double-clicking the shortcut icon.
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Connecting Your PC(s) to
the TG700

Setting Ethernet Network
Parameters

TG7 Backup, TG7 Restore, and TG7 Duplicator use the rear-panel 10 BASE-T
port on the TG700 to communicate with a PC or another TG700.

Refer to Connecting to a Network in the TG700 TV Signal Generator Platform
User Manual (Tektronix part number 071-1970-XX) for detailed information
about how to connect your PC(s) to the TG700.

Before you can use the TG7 Backup, TG7 Restore, or TG7 Duplicator to transfer
files between the TG700 and your PC(s) or between two TG700 Generators, you
must first set the Ethernet network parameters for the TG700.

NOTE. Use the ping command from the PC to verify network communications
after you set the Ethernet network parameters for the TG700 and for the TG7
Backup or TG7 Restore application.

Ethernet Parameters for the TG700. The Ethernet network parameters for the
TG700 can be set using the NETWORK SETUP submenu in the UTILITY main
menu. Refer to Setting Ethernet Network Parameters in the TG700 TV Signal
Generator Platform User Manual (Tektronix part number 071-1970-XX) for
detailed information about how to set the network parameters.

Starting and Exiting the File Copy Tools

When you complete the installation procedure, you can use any of the following
methods to start the file copy tools:

B Double-click the TG7Backup.exe, TG7 Dupli.exe, or TG7Restore.exe
shortcut icon on the PC desktop that you created during the installation
procedure.

B Double-click the TG7Backup.exe, TG7Dupli.exe, or TG7Restore.exe file
name in the Program Manager window.

B Select TG7Backup, TG7Dupli, or TG7Restore from the Start - Programs
menu.

To exit the TG7 Backup, TG7 Duplicator, or TG7 Restore application, select
File > Exit in the application window.

File Copy Tools Tutorials
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This subsection describes the basics of operating the TG7 Backup, TG7 Restore,
and TG7 Duplicator applications.
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Backing up Preset Files by ~ The TG7 Backup application allows you to back up all of the preset files saved in
TG7 Backup the TG700 to your PC.

About a Preset File. A preset file is a file saved in the PRESET folders of all of
the installed modules and has the following format:

MSTATE<slot_number>.P<preset_number>

For example, MSTATE1.P01 is the preset for the module installed in slot 1 of the
TG700, with preset number 1.

All of the folders and files in the TG700 file system are displayed using the TG7
Comm application. (See page 8, Using TG7 Comm for File Transfers.)
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Restoring Preset Files with
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TG7 Restore

Back Up Procedure.

Perform the following steps to back up all of the preset files from the TG700 to
the PC:

1. Start the TG7 Backup application to open the TG7 Backup window shown in
the following figure.

rj; TGT Backup

File

IP Address

128.131.119. 19

Save directory
[C:\Program FileshT ektionis\T G 7004B ackup L]

Backup Cancel

Figure 9: TG7 Backup window

2. Use the IP Address field in the window to enter the IP address of the TG700.

3. Use the Save directory field in the dialog box to specify the destination folder
for the preset files you are going to back up to your PC.

4. Click the Backup button to start the backup operation.

When the backup operation is complete, the dialog box appears as shown in
the following figure.

TG? Backup

12 files are backed up.

Figure 10: Dialog box shows backup is complete

5. Click the OK button.

The TG7 Restore application allows you to restore all of the preset files saved in
the PC to the TG700.

NOTE. To restore the all of the preset files to the TG700 and reuse them, the
hardware configuration of the TG700 must be the same hardware configuration as
when the preset files were backed up.
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Perform the following steps to restore all of the preset files from the PC to the
TG700:

1. Start the TG7 Restore application to open the TG7 Restore window shown in
the following figure.

mi TG7 Restore

File
IF Address
128.181.119. 19

Fiestore directaory

[C:Program Files\T ektoniehT G 7004 Preset_Files L]

Restare Cancel

Figure 11: TG7 Restore window

2. Use the IP Address field in the window to enter the IP address of the TG700.

3. Use the Restore directory field in the dialog box to specify the folder in
which the preset files are saved.

4. Click the Restore button to start the restore operation.

When the restore operation is complete, the dialog box appears as shown in
the following figure.

TG7 Restore

b fileg are restored.

Figure 12: Dialog box shows restore is complete

5. Click the OK button.

Transferring Files by TG7  The TG7 Duplicator application allows you to transfer all of the files in one
Duplicator ~ TG700 to another TG700.

NOTE. To transfer files between the two TG700 using the TG7 Duplication
application, both of the instruments need to be the same memory size.
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Perform the following steps to transfer all of the files in one TG700 to another
TG700:

1. Start the TG7 Duplicator application to open the TG7 Duplicator window
shown in the following figure.

#2TG7 Duplicator
Eile

Source IP addr. —— Target IP addr. —————
’V| 172 17 43 32 ’V| 172 17 43 3

Gopy |

Figure 13: TG7 Duplicator window

2. Use the Source IP addr. field in the window to enter the IP address of the
source instrument.

3. Use the Target IP addr. field in the window to enter the IP address of the
target instrument.

4. Click the Copy button to start the file transfer operation.

The progress gauge appears to show that file transfer is progressing.

CAUTION. Do not power off either of the TG700s until file transfer is complete.
Doing so will prevent both instruments from starting normally.

When the file transfer is complete, the dialog box appears as shown in the
following figure.

TE7 Duplicator

Duplication s successfully completed'

Figure 14: Dialog box shows file transfer is complete

5. Click the OK button.
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Using Frame Picture Generator

Frame Picture Generator is a software application for a PC using the Microsoft
Windows system. Frame Picture Generator provides the capability to convert a
Windows bitmap file (.bmp) to a frame picture file (.pic) that can be used by the
TG700. Using this application, you can convert a natural picture or a test pattern
in bitmap format to a frame picture file and output it as a picture.

This section provides the following information:

B Installation instructions

B Starting and exiting Frame Picture Generator

®m  Elements of the Frame Picture Generator window
B Using the Frame Picture Generator menus

®  Frame Picture Generator tutorials

Installation Instructions

This subsection provides instructions to install the Frame Picture Generator
application on your PC.

Installing Frame Picture ~ The following installation instructions require that you are familiar with the basics
Generator  of using the Windows operating system. If necessary, read your Windows user
documentation before installing Frame Picture Generator.

Perform the following procedure to install the Frame Picture Generator:

1. Be sure that your PC meets the requirements before proceeding with the
installation. (See page x, PC System Requirements.)

2. Insert the TG700 Signal Generator Platform SW Library and
Documentation CD (063-3939-XX) into a CD drive on your PC.

3. When the Product Software and Documentation Browser window appears,
select the TG7 Tools Software link.

4. Select the Frame Picture Generator link to install the software. Follow the
on-screen instructions to complete the software installation.
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Creating a Desktop  Perform the following procedure to create an icon on your PC desktop that you
Shortcut Icon  can use to run the Frame Picture Generator application.

1. On your PC display, right click to open the desktop menu.

2. Use the New > Shortcut command to create a shortcut to the FrameGEN.exe
file.

3. You can start the TG7 Frame Picture Generator application by double-clicking
the shortcut icon.

Starting and Exiting Frame Picture Generator

When you complete the installation procedure, you can use any of the following
methods to start the Frame Picture Generator application:

®  Double-click the FrameGEN.exe shortcut icon on the PC desktop that you
created during the installation procedure.

m  Double-click the FrameGEN.exe file name in the Program Manager window.
®  Select FrameGen from the Start - Programs menu.

To exit the Frame Picture Generator application, select File > Exit in the
application window.

Elements of the Frame Picture Generator Window

The following figure shows the Frame Picture Generator application window. For
description of the elements in the application window, refer to the following table.
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Title bar —>

Menubar — FEile Build Settings Window Help

Toolbar —— | il| M| ==|°%[2.| ®|=|m| B
>

BMP View, FrameBMP View,
and PicBMP View windows <
display area

t. FrameBMP View - C:¥Program Files¥SonyT... [H[=] E1

t.. BMP View - C:¥Program Files¥Sony

\_ |FrameBEMP: 1928000 * 10300H) PixelFormat24bit (Farmatbame:fih 2

|EiAP: 192000 * 1363H) PixelFormat24bit S

Figure 15: Frame Picture Generator application window

Table 8: Elements of the Frame Picture Generator window

Element

Description

Title bar

The Title bar displays the name of the application and contains
the standard window-sizing boxes for Windows.

Menu bar

The Menu bar displays the names of the five pull-down menus.
(See page 26, Using the Frame Picture Generator Menus.).

Toolbar

The Toolbar provides shortcut buttons for many of the most
often used menu commands. Click a toolbar button to select the
corresponding command. (See Table 9.)

BMP View window

The BMP View window displays the selected bitmap image
before conversion.

FrameBMP View window

The FrameBMP View window displays the frame bitmap image
converted to the specified video format size.

PicBMP View window

The PicBMP View window displays the frame picture image
converted to the bitmap file.

Table 9: Toolbar button descriptions

Icon

Name Function

3|

Open Equivalent to the Open

command in the File menu.
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Table 9: Toolbar button descriptions (cont.)

Icon Name Function

E Save Frame Bmp As Equivalent to the Save
Frame BmpAs command in
the File menu.

Save Pic Bmp As Equivalent to the Save Pic
- BmpAs command in the
File menu.

Build Frame Bmp Equivalent to the Build
Frame Bmp command in
the Build menu.

Build Pic File Equivalent to the Build Pic
File command in the Build
menu.

Build Pic Bmp Equivalent to the Build Pic
Bmp command in the Build
menu.

m]
+
-]

[m]
me

o
12

Cascade Equivalent to the Cascade
command in the Window
menu.

I

Horizontal Equivalent to the Horizontal
command in the Window
menu.

\m

Vertical Equivalent to the Vertical
command in the Window
menu.

Exit Equivalent to the Exit
command in the File menu.

= 3

Using the Frame Picture Generator Menus

The Menu bar displays the names of the five pull-down menus: File, Build,
Settings, Window, and Help. This section describes the function of each selection
in these menus.

File Menu  The File menu contains commands for managing file operations and for exiting
the Frame Picture Generator application. The following table describes each
of the File menu commands.

Table 10: Frame Picture Generator File menu commands

Command Function

Open Opens a bitmap file. When you select a bitmap file, the image is
displayed in the BMP View window.
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Table 10: Frame Picture Generator File menu commands (cont.)

Command Function

Save Frame Bmp As Saves the frame bitmap image displayed in the FrameBMP
View window as a bitmap file.

Save Pic Bmp As Saves the frame picture image displayed in the PicBMP View
window as a bitmap file.

Exit Exits the Frame Picture Generator application.

Build Menu  The Build menu contains commands that create a frame bitmap file or frame

picture file and convert a frame picture file to a bitmap file. The following table

describes each of the Build menu commands.

Table 11: Frame Picture File Build menu commands

Command Function

Build Frame Bmp Converts the bitmap image displayed in the BMP View window
to the bitmap file with the specified video format size.

Build Pic File Converts the frame bitmap file displayed in the FrameBMP View
window to the frame picture file (.pic) that can be used by the
TG700.

Since the AVG7 module outputs a signal using the 2-time over
sampling technique, one pixel of a bitmap image corresponds
to two samples of the signal. Therefore, when creating a frame
picture file for the AVG7 module, the application uses each pixel
of a bitmap image twice.

Build Pic Bmp Converts the selected frame picture file (.pic) to the bitmap
file and displays its image in the PicBMP View window. Note
that this command cannot reproduce the original bitmap file
completely because the data of the frame picture file is changed
when itis converted from the bitmap file. This command is useful
when you want to check any frame picture images on the PC.

Settings Menu  The Settings menu contains commands for setting the video format size and
background color. The following table describes each of the Settings menu
commands.

Table 12: Frame Picture Generator Settings menu commands

Command Function

Background Specifies the color used for the background of the bitmap image.
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Table 12: Frame Picture Generator Settings menu commands (cont.)

Command Function

Filter Eliminates unnecessary high frequency components contained
in the bitmap image. These high frequency components derive
from rapid changes of intensity or hue in the image generated
by using a graphic program. This command is only available for
the video format sizes of the DVG7 and HDVGT.

Format Specifies the video format size when the frame bitmap is
created.

Window Menu  The Window commands control the appearance of the view windows. Use
Arrange Icon when the windows are minimized.

Help Menu  The Help menu About FrameGen command displays the Frame Picture Generator
software version number and copyright information.

Frame Picture Generator Tutorials

This subsection describes the basics of operating the Frame Picture Generator
application.
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Creating a Frame Picture = Perform the following steps to create a frame picture file (.pic) from a Windows
File  bitmap file (.bmp).

1. Select File > Open.

2. Select the bitmap file on the PC that you want to convert, and then click the
Open button. This will display the bitmap image in the BMP View window.

3. Select Settings > Background to specify the background color for the frame
bitmap.

4. Select Settings > Format to select the video format size when the frame
bitmap is created.

5. Select Build > Build Frame Bmp. This will display the frame bitmap image
converted to the specified video format size in the FrameBMP View window.

6. Seclect Build > Build Pic File to convert the frame bitmap file to the frame
picture file. While the conversion is in progress, the BUILDING PIC FILES
dialog box shown in the following figure appears.

BUILDING PIC FILES

Building FIC File . ..

INNENNNNEER B0 %

Figure 16: BUILDING PIC FILES dialog box
7. When the file conversion is completed, the Pic File dialog box appears.

8. In the dialog box specify the destination folder where you want to save the
frame picture file, and the file name.

9. Click the Save button to save the file.

Downloading a Frame A frame picture file created by Frame Picture Generator is output as a picture

Picture File and Outputting by downloading to the TG700.
the Picture

NOTE. Make sure to download a frame picture file to a folder for a generator
module that can output the correct video format for the frame picture. If the
video format for the frame picture file is different from the video format for the
generator module, the picture is not output correctly.

Note for Downloading a Frame Picture File. It is reccommended that you download
up to 32 MB of frame picture files to the TG700 (the amount of free space in the
TG700’s system memory can be confirmed on the status bar in the TG7 Comm
application).
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The total number of lines of frame pictures and test signals that can be downloaded
into a module is 4096. Since line numbers vary depending on a module and
signal format, the number of frame picture files that can be downloaded into each
module is as follows:

B AVGT: 7 files
B AWVGT7: 3 files
m DVGT7: 7 files
= HDVGT7: 3 files

NOTE. The flash memory of the TG700 is shared among system files, test signal
files, and frame picture files. Therefore, if you use the whole free memory space for
frame pictures, system files may not be installed when upgrading the instrument,
or additional test signals may not be installed.

If you have more pictures to be output, you can output them by saving another
folder and then assigning it to the front-panel button.

Downloading a Frame Picture File to the TG700.

Perform the following steps to download a frame picture file from the PC to the
TG700:

1. Start the TG7 Comm application after you connect your PC and TG700
using the appropriate Ethernet cable. (See page 8, Using TG7 Comm for
File Transfers.)

2. Create a folder corresponding to a format name (for example 1080 _60i) under
the PICTURE folder of the appropriate generator module.

3. Download the frame picture file to the folder using the PC to TG command
of the TG7 Comm application.

Outputting the Picture. Perform the following steps to output the frame picture
file as a picture.
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1. Assign the frame picture file to the OTHER test signal button on the front
panel.

Refer to the SIGNAL KEY ASSIGN Submenu in the TG700 user manual about
how to assign a frame picture file to the OTHER test signal button.

2. Press the front-panel MODULE button to select the module from which you
want to output the picture.

3. Press the front-panel FORMAT button to select the video format for the
frame picture file.

4. Press the OTHER test signal button.

5. Press the left () or right (») arrow button, or the OTHER test signal button
repeatedly to select the picture that you want to output.

TG700 TV Signal Generator Platform PC Tools Technical Reference 31



Using Logo Generator

Using Logo Generator

Logo Generator, a standard accessory with the TG700, is a software application
for a PC using the Microsoft Windows system. Logo Generator provides the
capability to convert a Windows bitmap file (.bmp) to a logo file (.1go) that can be
used with the logo overlay feature of the DVG7 or HDVG7 module.

This section provides the following information:
m Installation instructions

B Starting and exiting Logo Generator

m  Elements of Logo Generator window

m  Using the Logo Generator menus

®  Logo Generator tutorials

Installation Instructions

Installing Logo Generator

32

This subsection provides instructions to install the Logo Generator application
on your PC.

The following installation instructions require that you are familiar with the basics
of using the Windows operating system. If necessary, read your Windows user
documentation before installing Logo Generator.

Perform the following procedure to install the Logo Generator software:

1. Be sure that your PC meets the requirements before proceeding with the
installation. (See page x, PC System Requirements.)

2. Insert the TG700 Signal Generator Platform SW Library and
Documentation CD into a CD drive on your PC.

3. When the Product Software and Documentation Browser window appears,
select the TG7 Tools Software link.

4. Select the Logo Generator link to install the software. Follow the on-screen
instructions to complete the software installation.
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Creating a Desktop  Perform the following procedure to create an icon on your PC desktop that you
Shortcut Icon  can use to run the Logo Generator application.

1. On your PC display, right click to open the desktop menu.

2. Use the New > Shortcut command to create a shortcut to the Logogen.exe
file.

3. You can start the TG7 Setup application by double-clicking the shortcut icon.

Starting and Exiting Logo Generator

When you complete the installation procedure, you can use any of the following
methods to start the Logo Generator application:

m  Double-click the Logogen.exe shortcut icon on the PC desktop that you
created during the installation procedure.

B Double-click the Logogen.exe file name in the Program Manager window.
®  Select LOGOGEN from the Start - Programs menu.

To exit (quit) the Logo Generator application, select File > Exit in the application
window.

Elements of the Logo Generator Window

The following figure shows the Logo Generator application window. For
description of the elements in the application window, refer to the following table.
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Title bar — ERT AN e e O] x]

Menu bar — File Build Settinez  Help

Toolbar —— EI El 3”

‘ BMP Vi ‘ LGO View

BMP view —>
LGO view
Status bar — Ready [200 % 100, 8 bep [oox

Figure 17: Logo Generator application window

Table 13: Elements of the Logo Generator window

Element Description

Title bar The Title bar displays the name of the application and contains
the standard window-sizing boxes for Windows.

Menu bar The Menu bar displays the names of the four pull-down

menus. Refer to Using the Logo Generator Menus for detailed
information about the menu functions. (See page 35, Using the
Logo Generator Menus.)

Toolbar The Toolbar provides shortcut buttons for many of the most
often used menu commands. Click a toolbar button to select the
corresponding command. You can toggle the toolbar display on
and off using the Toolbar commands in the Settings pull-down
menu. (See Table 14.)

BMP View The BMP View displays the selected bitmap image.

LGO View The LGO View displays the logo image converted to a gray
scale.

Status bar The status bar displays the bitmap size, bits per pixel, and

conversion status (%) of the gray scale image.
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Table 14: Toolbar button descriptions

Icon Name Function

Open Equivalent to the Open
command in the File menu.

Build Logo File Equivalent to the Build
Logo File command in the
Build menu.

,CE About Equivalent to the About
LogoGen command in the
Help menu.

ALY

Using the Logo Generator Menus

The Menu bar displays the names of the four pull-down menus: File, Build,

Settings, and Help. This section describes the function of each selection in these
menus.

File Menu  The File menu contains commands for managing file operation and for exiting

the Logo Generator application. The following table describes each of the File
menu commands.

Table 15: Logo Generator File menu commands

Command Function

Open Displays the Open dialog box where you can select the bitmap
file you want to convert to a logo file.

Exit Exits the Logo Generator application.

Build Menu  The Build menu contains a command that creates a logo file. The following table
describes the Build menu command.

Table 16: Logo Generator Build menu commands

Command Function
Build Logo File Create a logo file (.Igo) from a bitmap file (.bmp).

Settings Menu  The Settings menu contains commands for setting the gray level and background

color for a logo image. The following table describes each of the Settings menu
commands.
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Table 17: Logo Generator Settings menu commands

Command

Function

Gray Level...

Sets the gray level when a bitmap image is converted to a logo
image. When you click this command, the Gray Scale Settings
dialog box appears. (See page 36, Gray Scale Settings Dialog
Box.)

Miscellaneous...

Sets a logo name, user comment, and display position. When
you click this command, the Miscellaneous Settings dialog box
appears. (See page 37, Miscellaneous Settings Dialog Box.)

Background Sets the background color.

Toolbar Toggles the display of the Toolbar on and off in the application
window.

Status Bar Toggles the display of the Status bar on and off in the application
window.

Save Settings Specifies whether all the settings are saved.

Gray Scale Settings Dialog Box. The Gray Scale Settings dialog box (following
figure) appears after you click the Gray Level command.

Gray Scale Settings

—Gray Scale Limits

Wihite Limit

192 _I
Gray Limit

I'l 28 _l:
Blankine Limit

G4 _I

Cancel |

Rezet Values I
Detault Wales |
Update Displaw |

Figure 18: Gray Scale Settings dialog box

In this dialog box, you can set the following parameters:

B White Limit: Sets the maximum level for the Gray 2 level. The gray scale
values grater than this value become white level. You can set the value from
0 to 255. The default value is 192.

B Gray Limit: Sets the maximum level for the Gray 1 level. You can set the
value from 0 to 255. The default value is 128.

B Blanking Limit: Sets the maximum level for the Transparent. You can set
the value from O to 255. The default value is 64.

Reset Values button resets all of the settings to the values that were in effect
when the dialog box was first displayed.

Default Values button resets all of the settings to their default values.
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Update Display button enables all of the settings with the dialog box opened.

Miscellaneous Settings Dialog Box. The Miscellaneous Settings dialog box
(following figure) appears after you click the Miscellaneous... command.

Mizcellaneous Settings
Logn Mame:
IHDUG?_LD:D
Comment :
Wertical Pozition Horizontal Pozition
n = 0 =
Caneel |

Figure 19: Miscellaneous Settings dialog box
In this dialog box, you can set the following parameters:

®  Logo Name: Sets the logo name. This logo name is used when you select a
logo from the LOGO OVERLAY submenu of the DVG7 or HDVG7 module.
The default logo name is the file name.

B Comment: Sets the user comment described in the logo file. You need not
enter any comments in general use.

B Vertical Position: Sets the vertical position where the logo is displayed on the
monitor. You can set the value from -100% to 0%. The vertical position can
be set from the LOGO OVERLAY submenu of the DVG7 or HDVG7 module.

®  Horizontal Position: Sets the horizontal position where the logo is displayed
on the monitor. You can set the value from -100% to 0%. The horizontal
position can be set from the LOGO OVERLAY submenu of the DVG7 or
HDVG7 module.

Help Menu  The Help menu contains a command that displays the Logo Generator application
version information. The following table describes the Help menu command.

Table 18: Logo Generator Help menu command

Command Function

About LogoGen... Displays information including the Logo Generator software
version number and copyright information.

Logo Generator Tutorials

This subsection describes the basics of operating the Logo Generator application.
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Creating a Logo File

Perform the following steps to create a logo file (.1go) from a Windows bitmap

file (.bmp).

1. Select File > Open.

2. Select the bitmap file on the PC that you want to convert, and then click the
Open button. This will display the bitmap image in the BMP View and the
logo image converted to a gray scale in the LGO View.

3. Select Settings > Gray Level to open the Gray Scale Settings dialog box.
(See Figure 18 on page 36.)

4. Set the gray levels for the logo image. You can change the background color
for the logo image using the Background command.

5. Select Settings > Miscellaneous to open the Miscellaneous Settings dialog
box. (See Figure 19 on page 37.)

6. Set the vertical and horizontal positions for the logo to be displayed on the
monitor. If necessary, set the logo name and user comment.

7. Select Build > Build Logo File from the Build pull-down menu to open the

BMP to LGO File Conversion dialog box shown in the following figure.

BMP to LGO File CGonversion

File has been converted from

C:\Program Files" Tektront . TG 700 LogoGen  BMPs logo bmp

C:MProgram Files Tektronx' TG 700 LogoGen EMPs logo lgo

Figure 20: BMP to LGO File Conversion dialog box

8.

Click the OK button to create the logo file.
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Firmware Upgrade

The TG700 firmware must be upgraded when a newly released module is
installed. This section describes the upgrade.

Equipment Required

The following equipment is required to upgrade the firmware:

Upgrade Procedures

PC with Windows 2000/XP and Ethernet interface installed
10 BASE-T Ethernet cable

TG700 Signal Generator Platform SW Library and Documentation CD, which
is provided with the new module

NOTE. You must move any downloaded frame picture files that are stored in

the
the

TG700 mainframe, to your PC before starting the following procedures. If
mainframe does not have enough memory space, you cannot upgrade the

firmware normally.

Perform the following procedure to upgrade the firmware. It is not necessary to
uninstall the earlier version.

1.

Connect the 10 BASE-T port on the TG700 rear panel to the Ethernet port
on your PC using the Ethernet cable. Refer to Connecting the TG700 to
your PC(s) in the TG700 user manual for detailed information about how
to connect the TG700 to your PC.

Power on the TG700 and your PC.

Set the network parameters of the TG700. Refer to Setting Ethernet Network
Parameters in the TG700 user manual for detailed information about how
to set the parameters.

Insert the TG700 Signal Generator Platform SW Library and
Documentation CD provided with the new module into the CD drive on
your PC.

When the Product Software and Documentation Browser window appears,
select the Mainframe and Module Software link.
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6. Read the following note, and then, select Upgrade to V5.1 if your mainframe
has 32 MB or more of memory.

NOTE. You must install the AGL7 patch before you upgrade to version 5.1 to
have the full version 5.1 functionality (the CPU code from version 5.1 must be
installed and running on the mainframe). If you install the AGL7 patch after
installing version 5.1, you will not be able to run the GPS7 (plus BG7 and
HDVG7) modules correctly.

Select Upgrade to V4.1 if your mainframe has 16 MB of memory. Select
Install V4.7 Patch for AGL7 Module if you wish to add the genlock alarm
function to an AGL7 module (requires mainframes have at least 32 MB of
memory; the AGL7 module must be installed in the mainframe during the
software upgrade). The PC will open a Windows Explorer window displaying
the contents of the selected upgrade folder.

7. Double-click the tgUpgrade.exe icon in the folder. The TG700 Upgrade

dialog box appears as shown in the following figure.

E& 16700 Upgrade ] S ||
IP iAddrezz: I_

0 NOT TURN OFF THE POWER OF TG700 UNTIL COMPLETED

rEtatus
[ |
|
Select Modules to download signals
[T ATE? [ DVG? Copy |
[V LVGE7 [~ HDVG?
[V LUWGT
it |

Figure 21: TG700 Upgrade dialog box

NOTE. In the following cases, an error message appears when you double-click
the tgUpgrade.exe icon. If this happens, copy the all of the files in the UPGRADE
folder to the hard disk, and then repeat the operation.
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= When you upgrade the TG700 with firmware version 1.3 or earlier and
use the ATG7, AVG7, or AWVG7 module in it.

= When you upgrade the TG700 with firmware version 2.1 or earlier and
use the AVG7 or AWVG7 module in it.

8. In the dialog box, enter the IP address that you assigned to your TG700.

9. Ifyou want to download the signals for the specified modules, use the check
boxes at the bottom of the dialog box. Normally, you need not select any
check boxes. Select the appropriate check boxes under the following cases:

= ATG7 check box: when you upgrade the TG700 with firmware version 1.3
or earlier and use the ATG7 module in it.

= AVGT7 check box: when you upgrade the TG700 with firmware version
2.1 or earlier and use the AVG7 module in it.

=  AWVGT7 check box: when you upgrade the TG700 with firmware version
2.1 or earlier and use the AWVG7 module in it.

10. Click the Copy button. The PC will start transferring the files in the Upgrade
folder to the TG700.

CAUTION. Do not power off the TG700 until file transfer is complete. Doing so
will prevent the instrument from starting up normally.

11. When the file transfer is complete, the message box shown in the following
figure appears.

TG700 Upgrade (%)

Copy successfully completed !
Flease reboot the TG00,
Memory Size:

free= 5.2 MB,total=30.9 MB

Figure 22: Message box appearing after the file transfer is complete
12. Click the OK button in the message box.

13. Disconnect the power cable from the power cord connector on the TG700 rear
panel, and then connect it again to restart the instrument.

14. If your TG700 includes an HDLG7 module, proceed with the following steps
to complete the upgrade:

a. Power on the TG700.
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Firmware Version Check

42

b. When Startup TG700 appears on the display, press the FORMAT button

and leave it pressed until "HDLG7[n]" appears.

c. Wait for all modules to start up.

d. When TG700 : PRESET appears on the display, disconnect the power to

the instrument, then connect it again to restart the instrument.

Perform the following procedure to verify that the new firmware version was
properly installed:

1.
2.

3.
4.
S.

Press the front-panel MODULE button to display the TG700 main menu.

Use the up (A) or down (V) arrow button to select UTILITY, and then press
the ENTER button.

Use the up (A ) or down (V) arrow button to select VERSION INFO (F/W).
Use the left () or right (») arrow button to select CPUJ0].

Verify that the new firmware version number is displayed in the menu.

Refer to the TG700 Release Notes for information about the new firmware
version. You can find these notes on the Web at www.tek.com/manuals.
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Network Interface Specifications

NOTE. Refer to the Connecting to a Network section of the TG700 TV Signal
Generator Platform User Manual for instructions on connecting the TG700 to a
single PC or a network and setting the network parameters for the 10 BASE-T
port.

The TG700 supports remote control using the Ethernet interface. This section
describes the TG700 network interface specifications.

The TCP/IP is used as the network protocol, and the port number is fixed 5000.
The commands can be sent from the application program through the socket
interface of the TCP/IP. Also, the query can be received through the interface.

Keep the following in mind while controlling the TG700 remotely with the
Ethernet interface.

B The Line Feed (LF) code is needed at the end of a message as a terminator.

®  The IEEE 488.1 standard (such as Device Clear and Service Request) is not
supported.

B The Message Exchange Control Protocol in the IEEE 488.2 is not supported.
However, the common commands such as *ESE and the event handling
features are supported.

B The Indefinite format (the block start at #0) in the <ARBITRARY BLOCK
PROGRAM DATA> of the IEEE 488.2 is not supported.
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Checking Remote Command Operation

44

To check remote command operation of the TG700 mainframe, perform the
following procedure:

1.

w

NS n e

9.

Connect the TG700 to your PC using an Ethernet cable. Refer to Connecting
to a Network in the TG700 TV Signal Generator Platform User Manual
(Tektronix part number 071-1970-XX) for detailed information about how
to connect the TG700 to your PC.

Click Windows Start button and select Run from the start menu
In the dialog box, type telnet and then click OK.

The TELNET window appears.

Select Terminal > Preferences.

Select Local Echo and click OK.

Select Connect > Remote System.

Enter the IP address of the TG700 in the Host Name field and 5000 in the
Port field.

Click Connection.

Type *IDN in the command line and press the Enter key.

10. Check that the ID information of the TG700 appears on the PC.

NOTE. If you use a PC running Windows 2000/XP, connect the TG700 and your
PC using the Hyper Terminal application supplied with Windows. Refer to
Windows Online Help or other documentation for detailed information about
Hyper Terminal.
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