Warranty

Tektronix warrants that this product will be free from defects in materials and workmanship for a period of one (1) year from the date of shipment. If any such product proves defective during this warranty period, Tektronix, at its option, either will repair the defective product without charge for parts and labor, or will provide a replacement in exchange for the defective product. Parts, modules and replacement products used by Tektronix for warranty work may be new or reconditioned to like new performance. All replaced parts, modules and products become the property of Tektronix.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of the warranty period and make suitable arrangements for the performance of service. Customer shall be responsible for packaging and shipping the defective product to the service center designated by Tektronix, with shipping charges prepaid. Tektronix shall pay for the return of the product to Customer if the shipment is to a location within the country in which the Tektronix service center is located. Customer shall be responsible for paying all shipping charges, duties, taxes, and any other charges for products returned to any other locations.

This warranty shall not apply to any defect, failure or damage caused by improper use or improper or inadequate maintenance and care. Tektronix shall not be obligated to furnish service under this warranty a) to repair damage resulting from attempts by personnel other than Tektronix representatives to install, repair or service the product; b) to repair damage resulting from improper use or connection to incompatible equipment; c) to repair any damage or malfunction caused by the use of non-Tektronix supplies; or d) to service a product that has been modified or integrated with other products when the effect of such modification or integration increases the time or difficulty of servicing the product.

THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE PRODUCT IN LIEU OF ANY OTHER WARRANTIES, EXPRESS OR IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. TEKTRONIX' RESPONSIBILITY TO REPAIR OR REPLACE DEFECTIVE PRODUCTS IS THE SOLE AND EXCLUSIVE REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF THIS WARRANTY. TEKTRONIX AND ITS VENDORS WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS ADVANCE NOTICE OF THE POSSIBILITY OF SUCH DAMAGES.

[W2 – 15AUG04]
# Table of Contents

General Safety Summary ................................................................. v
Preface .......................................................................................... vii

Products ....................................................................................... vii
PC Tools ....................................................................................... vii
Related Manuals ........................................................................ viii
PC System Requirements .............................................................. ix

Using TG7 Setup to Set Parameters ................................................ 1
Installation Instructions and Ethernet Setup ..................................... 1
Starting and Exiting TG7 Setup ....................................................... 3
Elements of the TG7 Setup Window ............................................... 3
Using the TG7 Setup Menus ......................................................... 4
TG7 Setup Tutorial ........................................................................ 6

Using TG7 Comm for File Transfers .............................................. 8
Installation Instructions and Ethernet Setup ................................. 8
Starting and Exiting TG7 Comm ................................................... 10
Elements of the TG7 Comm Window ............................................. 11
Using the TG7 Comm Menus ....................................................... 13
TG7 Comm Tutorials ...................................................................... 15

Using the File Copy Tools ............................................................ 18
Installation Instructions and Ethernet Setup ................................. 18
Starting and Exiting the File Copy Tools ....................................... 19
File Copy Tools Tutorials ............................................................. 19

Using Frame Picture Generator .................................................... 23
Installation Instructions ............................................................... 23
Starting and Exiting Frame Picture Generator .............................. 24
Elements of the Frame Picture Generator Window ....................... 25
Using the Frame Picture Generator Menus .................................... 27
Frame Picture Generator Tutorials ............................................... 29

Using Logo Generator ............................................................... 32
Installation Instructions ............................................................... 32
Starting and Exiting Logo Generator .......................................... 33
Elements of the Logo Generator Window .................................... 34
Using the Logo Generator Menus ............................................... 35
Logo Generator Tutorials ............................................................ 38

Firmware Upgrade ....................................................................... 39
Equipment Required ................................................................. 39
Mainframe Memory Requirements .............................................. 39
Upgrade Procedures ..................................................................... 40
Firmware Version Check ............................................................. 45
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network Interface Specifications</td>
<td>46</td>
</tr>
<tr>
<td>Checking Remote Command Operation</td>
<td>47</td>
</tr>
<tr>
<td>Index</td>
<td></td>
</tr>
</tbody>
</table>
# List of Figures

<table>
<thead>
<tr>
<th>Figure</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Ethernet dialog box for TG7 Setup</td>
<td>2</td>
</tr>
<tr>
<td>2</td>
<td>TG7 Setup application window</td>
<td>3</td>
</tr>
<tr>
<td>3</td>
<td>Rename dialog box</td>
<td>5</td>
</tr>
<tr>
<td>4</td>
<td>Setup window for DVG7 module</td>
<td>6</td>
</tr>
<tr>
<td>5</td>
<td>Ethernet dialog box for TG7 Comm</td>
<td>10</td>
</tr>
<tr>
<td>6</td>
<td>TG7 Comm application window</td>
<td>11</td>
</tr>
<tr>
<td>7</td>
<td>File name confirmation dialog box</td>
<td>16</td>
</tr>
<tr>
<td>8</td>
<td>Sequence File dialog box</td>
<td>17</td>
</tr>
<tr>
<td>9</td>
<td>TG7 Backup window</td>
<td>20</td>
</tr>
<tr>
<td>10</td>
<td>Dialog box shows backup is complete</td>
<td>20</td>
</tr>
<tr>
<td>11</td>
<td>TG7 Restore window</td>
<td>21</td>
</tr>
<tr>
<td>12</td>
<td>Dialog box shows restore is complete</td>
<td>21</td>
</tr>
<tr>
<td>13</td>
<td>TG7 Duplicator window</td>
<td>22</td>
</tr>
<tr>
<td>14</td>
<td>Dialog box shows file transfer is complete</td>
<td>22</td>
</tr>
<tr>
<td>15</td>
<td>Frame Picture Generator application window</td>
<td>25</td>
</tr>
<tr>
<td>16</td>
<td>BUILDING PIC FILES dialog box</td>
<td>29</td>
</tr>
<tr>
<td>17</td>
<td>Logo Generator application window</td>
<td>34</td>
</tr>
<tr>
<td>18</td>
<td>Gray Scale Settings dialog box</td>
<td>36</td>
</tr>
<tr>
<td>19</td>
<td>Miscellaneous Settings dialog box</td>
<td>37</td>
</tr>
<tr>
<td>20</td>
<td>BMP to LGO File Conversion dialog box</td>
<td>38</td>
</tr>
<tr>
<td>21</td>
<td>TG700 Upgrade dialog box</td>
<td>43</td>
</tr>
<tr>
<td>22</td>
<td>Message box appearing after the file transfer is complete</td>
<td>44</td>
</tr>
</tbody>
</table>
# List of Tables

Table 1: Elements of the TG7 Setup window ................................................................. 4  
Table 2: TG7 Setup File menu commands ................................................................. 4  
Table 3: Elements of the TG7 Comm window ......................................................... 11  
Table 4: Toolbar button descriptions ..................................................................... 12  
Table 5: TG7 Comm File menu commands ............................................................. 13  
Table 6: TG7 Comm View menu commands ......................................................... 13  
Table 7: TG7 Comm Utility menu commands ......................................................... 14  
Table 8: Elements of the Frame Picture Generator window .................................. 25  
Table 9: Toolbar button descriptions .................................................................. 26  
Table 10: Frame Picture Generator File menu commands ...................................... 27  
Table 11: Frame Picture File Build menu commands ............................................ 27  
Table 12: Frame Picture Generator Settings menu commands ................................ 28  
Table 13: Elements of the Logo Generator window ............................................. 34  
Table 14: Toolbar button descriptions .................................................................. 35  
Table 15: Logo Generator File menu commands ................................................... 35  
Table 16: Logo Generator Build menu commands ................................................ 35  
Table 17: Logo Generator Settings menu commands ............................................ 36  
Table 18: Logo Generator Help menu command ................................................... 37
General Safety Summary

Review the following safety precautions to avoid injury and prevent damage to this product or any products connected to it.

To avoid potential hazards, use this product only as specified.

*Only qualified personnel should perform service procedures.*

**To Avoid Fire or Personal Injury**

**Use proper power cord.** Use only the power cord specified for this product and certified for the country of use.

**Ground the product.** This product is grounded through the grounding conductor of the power cord. To avoid electric shock, the grounding conductor must be connected to earth ground. Before making connections to the input or output terminals of the product, ensure that the product is properly grounded.

**Observe all terminal ratings.** To avoid fire or shock hazard, observe all ratings and markings on the product. Consult the product manual for further ratings information before making connections to the product.

**Power disconnect.** The power cord disconnects the product from the power source. Do not block the power cord; it must remain accessible to the user at all times.

**Do not operate without covers.** Do not operate this product with covers or panels removed.

**Do not operate with suspected failures.** If you suspect that there is damage to this product, have it inspected by qualified service personnel.

**Avoid exposed circuitry.** Do not touch exposed connections and components when power is present.

**Wear eye protection.** Wear eye protection if exposure to high-intensity rays or laser radiation exists.

**Do not operate in wet/damp conditions.**

**Do not operate in an explosive atmosphere.**

**Keep product surfaces clean and dry.**

**Provide proper ventilation.** Refer to the manual's installation instructions for details on installing the product so it has proper ventilation.
These terms may appear in this manual:

**WARNING.** Warning statements identify conditions or practices that could result in injury or loss of life.

**CAUTION.** Caution statements identify conditions or practices that could result in damage to this product or other property.

These terms may appear on the product:

- **DANGER** indicates an injury hazard immediately accessible as you read the marking.
- **WARNING** indicates an injury hazard not immediately accessible as you read the marking.
- **CAUTION** indicates a hazard to property including the product.

The following symbol(s) may appear on the product:
Preface

This manual provides information about various PC tools that can be used with the TG700 TV Signal Generator Platform and related modules.

Products

The information in this manual applies to the following products:

- TG700 TV Generator Platform
- AG7 Audio Generator Module
- AGL7 Analog Genlock Module
- ATG7 Analog Test Generator Module
- AVG7 Analog Video Generator Module
- AWVG7 Analog Wideband Video Generator Module
- BG7 Black Generator Module
- DVG7 Digital Video Generator Module
- GPS7 GPS Synchronization and Timecode Module
- HDLG7 HD Dual Link Generator Module
- HDVG7 HDTV Digital Video Generator Module
- HD3G7 HD 3 Gb/s SDI Video Generator Module
- SDI7 Dual Channel SD/HD/3G SDI Video Generator Module

PC Tools

The following utilities and software applications are described in this manual:

- TG7 Setup
- TG7 Comm
- File copy tools
- Frame Picture Generator
- Logo Generator
- Firmware upgrade
Related Manuals

The following documents are also available for the TG700:

- The *TG700 TV Signal Generator Platform User Manual* (Tektronix part number 071-1970-XX) describes how to install and operate the mainframe and related modules.

- The *TG700 TV Signal Generator Platform Specifications and Performance Verification Technical Reference* (Tektronix part number 077-0137-XX) describes the mechanical, electrical, and environmental specifications for the mainframe and related modules. This manual also provides performance verification procedures.

- The *TG700 TV Signal Generator Platform Programmer Manual* (Tektronix part number 077-0139-XX) provides programming information for the mainframe and related modules.

- The *TG700 TV Signal Generator Platform Service Manual* (Tektronix part number 077-0230-XX) describes how to service the TG700 mainframe to the module level (such as circuit boards and fuses) and provides general information about servicing generator modules. Specific service information for a module is located in its service manual.

- The *TG700 TV Signal Generator Platform Release Notes* (Tektronix part number 077-0228-XX English; 077-0443-XX Japanese) describes the new features, improvements, and limitations of the most recent available firmware for the TG700 TV Signal Generator Platform.

- The *Video Sync Pulse Generator & Electronic Changeover Unit System Integration Technical Reference* (Tektronix part number 077-0563-XX) provides information for system integrators who are designing systems for high-definition (HD) and standard-definition (SD) digital video content where Tektronix electronic changeover units and video sync pulse generators are to be deployed.
PC System Requirements

Each application described in this manual requires the minimum system requirements listed below.

All of the applications require one of the following operating systems:

- Microsoft Windows XP or 7

TG7 Setup, TG7 Comm, and the File Copy Tools require the following since they interact directly with the instrument:

- Ethernet interface

The Frame Picture Generator requires the following:

- True Color (more than 24 bits) display mode
Using TG7 Setup to Set Parameters

TG7 Setup, a standard accessory with the TG700, is a software application for a PC using the Microsoft Windows operating system. TG7 Setup provides the capability to set all of the parameters of the TG700 mainframe and installed modules using a PC.

This section provides the following information:
- Installation instructions and Ethernet setup
- Starting and exiting TG7 Setup
- Elements of the TG7 Setup window
- Using the TG7 Setup menus
- TG7 Setup tutorial

Installation Instructions and Ethernet Setup

This subsection contains instructions to install and configure the TG7 Setup application on your PC.

Installing TG7 Setup

The following installation instructions require that you are familiar with the basics of using the Windows operating system.

Perform the following procedure to install TG7 Setup software:
1. Be sure that your PC meets the requirements before proceeding with the installation. (See page ix, PC System Requirements.)
2. Insert the TG700 Signal Generator Platform SW Library and Documentation CD (063-3939-XX) into a CD drive on your PC.
3. When the Product Software and Documentation Browser window appears, select the TG7 Tools Software link.
4. Select the TG7 Setup link to install the software. Follow the on-screen instructions to complete the software installation.

Creating a Desktop Shortcut Icon

Perform the following procedure to create an icon on your PC desktop that you can use to run the TG7 Setup application.
1. On your PC display, right click to open the desktop menu.
2. Use the New > Shortcut command to create a shortcut to the TG7setup.exe file.
3. You can start the TG7 Setup application by double-clicking the shortcut icon.
Using TG7 Setup to Set Parameters

Connecting Your PC(s) to the TG700

TG7 Setup uses the rear-panel 10 BASE-T port on the TG700 to communicate with a PC.

Refer to the *TG700 TV Signal Generator Platform User Manual* (Tektronix part number 071-1970-XX) for detailed information about how to connect your PC(s) to the TG700.

Setting Ethernet Network Parameters

Before you can use TG7 Setup to set the parameters of the TG700 mainframe and installed modules, you must set the Ethernet network parameters for both the TG700 platform and the TG7 Setup application.

**NOTE.** Use the ping command from the PC to verify network communications after you set the Ethernet network parameters for the TG700 platform and for the TG7 Setup application.

Ethernet Parameters for the TG700. The Ethernet network parameters for the TG700 can be set using the NETWORK SETUP submenu in the UTILITY main menu. Refer to Setting Ethernet Network Parameters in the TG700 user manual for detailed information about how to set the network parameters.

Ethernet Parameters for TG7 Setup. When you start the TG7 Setup application, the Ethernet dialog box appears as shown in the following figure. Use this dialog box to set the Ethernet network parameters for the TG7 Setup application.

![Ethernet dialog box for TG7 Setup](image)

**Figure 1: Ethernet dialog box for TG7 Setup**

Perform the following procedure to set the Ethernet network parameters for the TG7 Setup application:

1. Use the **IP Address** field in the dialog box to enter the IP address that you assigned to the TG700.
2. Click the **OK** button to accept the settings and close the dialog box.
Starting and Exiting TG7 Setup

When you complete the installation procedure, you can use any of the following methods to start the TG7 Setup application:

- Double-click the TG7Setup.exe shortcut icon on the PC desktop that you created during the installation procedure.
- Double-click the TG7Setup.exe file name in the Program Manager window.
- Select TG7Setup from the Start - Programs menu.

To exit the TG7 Setup application, select **File > Exit** in the application window.

**NOTE.** When you start the TG7 Setup application, the TG700 front-panel are disabled once the application window appears. (See Figure 2.)

Elements of the TG7 Setup Window

The following figure shows the TG7 Setup application window. For description of the elements in the application window refer to the following table.

![TG7 Setup application window](image)

**Figure 2: TG7 Setup application window**
Table 1: Elements of the TG7 Setup window

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title bar</td>
<td>The Title bar displays the name of the application and contains the standard window-sizing boxes for Windows.</td>
</tr>
<tr>
<td>Menu bar</td>
<td>The Menu bar displays the names of the four pull-down menus. (See page 4, Using the TG7 Setup Menus.)</td>
</tr>
<tr>
<td>Setup window</td>
<td>Use the Setup window to set the parameters for the installed modules or mainframe. This window appears after you select the Open Module or Open TG700 command from the File pull-down menu.</td>
</tr>
<tr>
<td>Status bar</td>
<td>The Status bar displays the short explanation of the currently selected command and the information related to the operation.</td>
</tr>
</tbody>
</table>

Using the TG7 Setup Menus

The Menu bar displays the names of the four pull-down menus: File, View, Window, and Help. This section describes the function of each selection in these menus.

**File Menu**

The File menu contains commands for opening a setup window, for managing preset operations, and for exiting the TG7 Setup application. The following describes each of the File menu commands.

Table 2: TG7 Setup File menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open TG700</td>
<td>Opens the setup window for the TG700 mainframe.</td>
</tr>
<tr>
<td>Open Module</td>
<td>Opens the setup window for the selected module.</td>
</tr>
<tr>
<td>Recall Preset</td>
<td>Recalls the selected preset.</td>
</tr>
<tr>
<td>Save Preset</td>
<td>Saves the current instrument settings to the selected preset.</td>
</tr>
<tr>
<td>Rename Preset</td>
<td>Renames the selected preset name. When you select this command, the Rename dialog box appears. (See page 5, Rename Dialog Box.)</td>
</tr>
<tr>
<td>Exit</td>
<td>Exits the TG7 Setup application.</td>
</tr>
</tbody>
</table>
**Rename Dialog Box.** The Rename dialog box (following figure) appears after you select the **Rename Preset** command. You can use this box to assign a new name to the selected preset.

![Rename dialog box](image)

**Figure 3: Rename dialog box**

**View Menu** The View menu Status Bar command toggles the display of the Status bar on and off in the application window. A check mark precedes the command in the menu when the Status bar is selected for display.

**Window Menu** The Window menu commands (Cascade, Tile, and Arrange Icons) control the appearance of the setup windows in the application window. Use Arrange Icons when the setup windows are minimized.

**Help Menu** The Help menu About TG7Setup... command displays information including the TG7 Setup software version number and copyright information.
TG7 Setup Tutorial

After you have connected the TG700 to the PC using an Ethernet cable and set the required network parameters, you can use TG7 Setup to set the parameters for the TG700 mainframe and installed modules.

**NOTE.** Refer to the Operating Basics section of each module's User manual for detailed explanation of the parameters and their setting ranges.

### Setting Parameters

This subsection explains how to set the parameters of an installed module. In this example, you will set the parameters for the DVG7 module.

Perform the following steps to set parameters:

1. Select **File > Open Module > DVG7** to open the setup window for the DVG7 module as shown in the following figure.

![Figure 4: Setup window for DVG7 module](image)

At the top of the setup window, there are several tabs to select parameters. When you click one of the tabs, you access the fields associated with that parameter. In this example, the Signal tab is selected and the fields for setting the signal format, signal set, output signal, frame picture, and timing are displayed.

When you change any parameter in the window, the Apply button at the bottom of the window becomes active. Press this button to enable the new parameter settings.
2. Click the tab associated with the parameter you want to set. This opens the parameter fields for that tab.

3. Set parameters in the displayed fields.

4. Repeat Steps 2 and 3 until all of the parameter settings are completed.

5. When you finish making changes to the parameters, click the Apply button. This enables the parameter settings in the setup window and transfers them to the TG700.

**NOTE.** If you select a signal file or a picture file that is not assigned to a test signal button on the TG700 front panel, an error message appears when you click the Apply button. If this happens, you need to assign the file to a test signal button. Refer to SIGNAL KEY ASSIGN Submenu in the TG700 user manual for more information.

When you change parameters for a module, that module is selected in the TG700, regardless of what is shown on the display. To prevent addressing the wrong module from the front panel after you exit TG7 Setup, first select any of the modules using the MODULE button and then make settings.
Using TG7 Comm for File Transfers

TG7 Comm, a standard accessory with the TG700, is a software application for a PC using the Microsoft Windows operating system. TG7 Comm provides the capability to transfer signal, logo, preset, frame picture, or sequence files between a PC and the TG700 using the Ethernet interface.

This section provides the following information:
- Installation instruction and Ethernet setup
- Starting and exiting TG7 Comm
- Elements of TG7 Comm window
- Using the TG7 Comm menus
- TG7 Comm tutorials

Installation Instructions and Ethernet Setup

This subsection contains instructions to install and configure the TG7 Comm application on your PC.

**Installing TG7 Comm**

The following installation instructions require that you are familiar with the basics of using the Windows operating system.

Perform the following procedure to install TG7 Comm:

1. Be sure that your PC meets the requirements before proceeding with the installation. (See page ix, *PC System Requirements*.)
2. Insert the **TG700 Signal Generator Platform SW Library and Documentation CD** into a CD drive on your PC.
3. When the Product Software and Documentation Browser window appears, select the **TG7 Tools Software** link.
4. Select the **TG7Comm** link to install the software. Follow the on-screen instructions to complete the software installation.

**Creating a Desktop Shortcut Icon**

Perform the following procedure to create an icon on your PC desktop that you can use to run the TG7 Comm application.

1. On your PC display, right click to open the desktop menu.
2. Use the **New > Shortcut** command to create a shortcut to the **TG7Comm.exe** file.
3. You can start the TG7 Comm application by double-clicking the shortcut icon.
TG7 Comm uses the rear-panel 10 BASE-T port on the TG700 to communicate with a PC.

Refer to Connecting to a Network in the TG700 TV Signal Generator Platform User Manual (Tektronix part number 071-1970-XX) for detailed information about how to connect your PC(s) to the TG700.

Before you can use TG7 Comm to transfer files between the TG700 and your PC(s), you must set the Ethernet network parameters for both the TG700 and the TG7 Comm application.

NOTE. Use the ping command from the PC to verify network communications after you set the Ethernet network parameters for the TG700 and for the TG7 Comm application.

Ethernet Parameters for the TG700. The Ethernet network parameters for the TG700 can be set using the NETWORK SETUP submenu in the UTILITY main menu. Refer to Setting Ethernet Network Parameters in the TG700 TV Signal Generator Platform User Manual (Tektronix part number 071-1970-XX) for detailed information about how to set the network parameters.
Using TG7 Comm for File Transfers

Ethernet Parameters for TG7 Comm.

Perform the following procedure to set the Ethernet network parameters for the TG7 Comm application:

1. Select **Network** from the **Utility** menu of the TG7 Comm application. This will open the Ethernet dialog box. (See Figure 5.)

2. Use the **IP Address** field in the dialog box to enter the IP address that you assigned to the TG700.

3. Click the **OK** button to accept the settings and close the dialog box.

![Ethernet dialog box for TG7 Comm](image)

Starting and Exiting TG7 Comm

When you complete the installation procedure, you can use any of the following methods to start the TG7 Comm application:

- Double-click the TG7Comm.exe shortcut icon on the PC desktop that you created during the installation procedure.
- Double-click the TG7Comm.exe file name in the Program Manager window.
- Select TG7comm from the Start - Programs menu.

To exit the TG7 Comm application, select **File > Exit** in the application window.
Elements of the TG7 Comm Window

The following figure shows the TG7 Comm application window. For description of the elements in the application refer to the following table.

Figure 6: TG7 Comm application window

Table 3: Elements of the TG7 Comm window

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title bar</td>
<td>The Title bar displays the name of the application and contains the standard window-sizing boxes for Windows.</td>
</tr>
<tr>
<td>Menu bar</td>
<td>The Menu bar displays the names of the four pull-down menus. (See page 13, Using the TG7 Comm Menus.)</td>
</tr>
<tr>
<td>Toolbar</td>
<td>The Toolbar provides shortcut buttons for many of the most often used menu commands. Click a toolbar button to select the corresponding command. You can toggle the toolbar display on and off using the Toolbar command in the View pull-down menu. (See Table 4.)</td>
</tr>
<tr>
<td>Tree view</td>
<td>The Tree view displays the TG700 file structure. The contents of the selected directory are displayed in the List view. The IP address of the selected TG700 is displayed at the top of the Tree.</td>
</tr>
</tbody>
</table>
### Table 3: Elements of the TG7 Comm window (cont.)

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>List view</td>
<td>The List view displays the contents of the selected directory in the Tree view. You can use the View pull-down menu to alter the display in the List view.</td>
</tr>
<tr>
<td>Memory Free indicator</td>
<td>The Memory Free indicator lists how much memory is free in the TG700. Check this indicator to verify there is enough available memory space before you attempt to transfer files to the TG700.</td>
</tr>
<tr>
<td>Status bar</td>
<td>The Status bar displays the number of files (objects) stored in the selected directory, the total file size of the selected directory, and the amount of free disk space in the TG700’s system memory.</td>
</tr>
</tbody>
</table>

### Table 4: Toolbar button descriptions

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>PC to TG</td>
<td>Equivalent to the <a href="#">PC toTG</a> command in the File menu.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>TG to PC</td>
<td>Equivalent to the <a href="#">TG toPC</a> command in the File menu.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Up One Level</td>
<td>Moves from the current folder to the upper level folder.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Large Icons</td>
<td>Equivalent to the <a href="#">Large Icons</a> command in the View menu.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Small Icons</td>
<td>Equivalent to the <a href="#">Small Icons</a> command in the View menu.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>List</td>
<td>Equivalent to the <a href="#">List</a> command in the View menu.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Details</td>
<td>Equivalent to the <a href="#">Details</a> command in the View menu.</td>
</tr>
</tbody>
</table>
**Using the TG7 Comm Menus**

The Menu bar displays the names of the four pull-down menus: File, View, Utility, and Help. This section describes the function of each selection in these menus.

### File Menu

The File menu contains commands for managing file operations and for exiting the TG7 Comm application. The following table describes each of the File menu commands.

**Table 5: TG7 Comm File menu commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>PC to TG</td>
<td>Displays the PC to TG Download dialog box, where you can select the file you want to transfer from your PC to the directory in the TG700 selected in the Tree view.</td>
</tr>
<tr>
<td>TG to PC</td>
<td>When you select this command after you highlight a file in the List view of the TG7 Comm application, the TG to PC Upload dialog box appears. You can select a destination path and file name for the file you want to transfer to your PC.</td>
</tr>
<tr>
<td>New</td>
<td>Creates a new folder in the selected directory of the TG700.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the file or empty folder selected in the TG700.</td>
</tr>
<tr>
<td>Rename</td>
<td>Renames the file or folder selected in the TG700.</td>
</tr>
<tr>
<td>Exit</td>
<td>Exits the TG7 Comm application.</td>
</tr>
</tbody>
</table>

### View Menu

The View menu contains commands that control the appearance of the TG7 Comm application window. The following table describes each of the View menu commands.

**Table 6: TG7 Comm View menu commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbar</td>
<td>Toggles the display of the Toolbar on and off in the application window. A check mark precedes the command in the menu when the Toolbar is selected for display.</td>
</tr>
<tr>
<td>Status Bar</td>
<td>Toggles the display of the Status bar on and off in the application window. A check mark precedes the command in the menu when the Status bar is selected for display.</td>
</tr>
<tr>
<td>Large Icons</td>
<td>Causes the application to display files or folders in the List view using large icons. A check mark precedes the command in the menu when Large Icons is selected.</td>
</tr>
<tr>
<td>Small Icons</td>
<td>Causes the application to display files or folders in the List view using small icons. A check mark precedes the command in the menu when Small Icons is selected.</td>
</tr>
<tr>
<td>List</td>
<td>Causes the application to display files or folders in the List view in a vertical list form. A check mark precedes the command in the menu when List is selected.</td>
</tr>
</tbody>
</table>
Table 6: TG7 Comm View menu commands (cont.)

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Details</td>
<td>Causes the application to display files or folders in the List view in a detailed column format which includes the file size and last modified date of each file. A check mark precedes the command in the menu when Details is selected. When you select Details, you can click on the column names in the List view to reorder the contents of the directory by file name, by file size, or by file date.</td>
</tr>
<tr>
<td>Arrange Icons</td>
<td>Sets the display order for the folders and files in the List view. You can arrange the List view display by Name, Size, or Date.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refreshes the file display in the List view.</td>
</tr>
</tbody>
</table>

Utility Menu

The Utility menu contains commands for setting the network parameters.

Table 7: TG7 Comm Utility menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network</td>
<td>Opens the Ethernet dialog box where you can set the IP address of the target TG700. (See page 9, Setting Ethernet Network Parameters.)</td>
</tr>
<tr>
<td>Check Error</td>
<td>Opens the TG Error dialog box, which lists the errors detected in the TG700.</td>
</tr>
<tr>
<td>Options</td>
<td>Opens the Set Options dialog box, where you can specify which text editor application you will use to describe a sequence file.</td>
</tr>
</tbody>
</table>

Help Menu

The Help menu About... command displays information including the TG7 Comm software version number and copyright information.

You can set the network parameters for the TG700 using the NETWORK SETUP submenu.
TG7 Comm Tutorials

After you have connected the TG700 to the PC using an Ethernet cable and set the required network parameters, you can use TG7 Comm to transfer files between the PC and the TG700.

**NOTE.** The convention used by the TG7 Comm application is to call file transfers from the PC to the TG700 a "download," and to call file transfers from the TG700 to the PC an "upload."

You can download and upload the following types of files:

- **Signal file** (one of the following):
  - *.bmp for the SDI7 module only
  - *.xml for the HD3G7 and SDI7 modules only
  - *.dnl for all other modules
- **Logo file** (one of the following):
  - *.bmp for the SDI7 module only
  - *.lgo for all other modules
- **Frame picture file** (*.pic)
- **Text file** (*.txt for the SDI7 module only)
- **Preset file** (*.p00 to *.p14)
- **Sequence file** (*.seq)

**CAUTION.** Do not execute any operations except for Delete and Rename for a *.cmp file in the SIGNAL folder of each module.
This subsection provides the procedures to download a file from the PC to the TG700.

**NOTE.** When you download files to the TG700, make sure that the TG700 has enough free memory space. The size of frame picture files can be 4-7 MB each, depending on the raster size. The amount of free memory is displayed in the status bar of the TG7 Comm application window. (See Figure 6 on page 11.)

**Signal File, Logo File, Frame Picture File, or Preset File.** Perform the following steps to download a signal file, logo file, frame picture file, or preset file from the PC to the TG700.

1. In the Tree view of the TG7 Comm application, select the destination folder for the file you are going to download to the TG700.

2. Select File > PC to TG.

3. In the PC to TG Download dialog box, select the file on the PC that you want to download and the type of file, and then click the Download button to open the dialog box to confirm the file name. Refer to the following figure.

4. In the dialog box, confirm the file and then click the OK button to download the file.

![Figure 7: File name confirmation dialog box](image)
**Sequence File.** Perform the following steps to download a sequence file from the PC to the TG700.

1. In the Tree view of the TG7 Comm application, select the destination folder for the file you are going to download to the TG700.

2. Select **File > PC to TG**.

3. In the PC to TG Download dialog box, select the file on the PC that you want to download and the type of file (*.seq), and then click the **Download** button to open the Sequence File dialog box. (See Figure 8.)

4. Confirm the sequence file that you want to download.

5. When you click the **Edit** button, you can view the content of the sequence file and edit it.

6. Click the **OK** button to download the file.

![Sequence File dialog box](image)

**Figure 8: Sequence File dialog box**

**Uploading a File to the PC**

Perform the following steps to upload a file from the TG700 to the PC (the procedure for uploading is the same for all file types):

1. In the List view of the TG7 Comm application, select the file you want to upload to the PC.

2. Select **File > TG to PC**.

3. In the TG to PC Upload dialog box, specify the destination folder for the file you are going to upload to your PC.

4. Click the **Upload** button to upload the file from the TG700 to your PC.

**About Uploading a Preset File.** When you save instrument settings as a preset, separate preset files are created for each module. Therefore, when you upload a preset file using the TG7 Comm application, you need to create the folders for each module and upload all the files in it.

Once you have uploaded a preset file from the TG700 to the PC, you can download the file to another TG700 with the same configuration and use it as a known setting.

A preset file can easily be backed up and restored by the TG7 Backup and TG7 Restore applications. (See page 18, *Using the File Copy Tools*.)*
Using the File Copy Tools

The file copy tools (TG7 Backup, TG7 Restore, and TG7 Duplicator, standard accessories with the TG700) are software applications for a PC using the Microsoft Windows system. TG7 Backup and TG7 Restore provide the capability to back up and restore preset files between a PC and the TG700 using the Ethernet interface. TG7 Duplicator provides the capability to transfer all of the files between two TG700 Generators, using the Ethernet interface.

This section provides the following information:

- Installation instructions and Ethernet setup
- Starting and exiting the file copy tools
- File copy tools tutorials

Installation Instructions and Ethernet Setup

This subsection provides instructions to install and connect the file copy tools on your PC.

Installing the File Copy Tools

The following installation instructions require that you are familiar with the basics of using the Windows operating system. If necessary, read your Windows user documentation before installing the file copy tools.

Perform the following procedure to install the file copy tools:

1. Be sure that your PC meets the requirements before proceeding with the installation. (See page ix, PC System Requirements.)

2. Insert the TG700 Signal Generator Platform SW Library and Documentation CD into a CD drive on your PC.

3. When the Product Software and Documentation Browser window appears, select the TG7 Tools Software link.

4. Select the File Copy Tools link to install the software. Follow the on-screen instructions to complete the software installation.

Creating a Desktop Shortcut Icon

Perform the following procedure to create icons on your PC desktop that you can use to run the file copy tools; TG7 Backup, TG7 Restore, and TG7 Duplicator.

1. On your PC display, right click to open the desktop menu.

2. Use the New > Shortcut command to create a shortcut to the TG7Backup.exe, TG7Duplicator.exe, or TG7Restore.exe file.

3. You can start the application by double-clicking the shortcut icon.
Using the File Copy Tools

**Connecting Your PC(s) to the TG700**

TG7 Backup, TG7 Restore, and TG7 Duplicator use the rear-panel 10 BASE-T port on the TG700 to communicate with a PC or another TG700.

Refer to *Connecting to a Network* in the *TG700 TV Signal Generator Platform User Manual* (Tektronix part number 071-1970-XX) for detailed information about how to connect your PC(s) to the TG700.

**Setting Ethernet Network Parameters**

Before you can use the TG7 Backup, TG7 Restore, or TG7 Duplicator to transfer files between the TG700 and your PC(s) or between two TG700 Generators, you must first set the Ethernet network parameters for the TG700.

*NOTE. Use the ping command from the PC to verify network communications after you set the Ethernet network parameters for the TG700 and for the TG7 Backup or TG7 Restore application.*

**Ethernet Parameters for the TG700.** The Ethernet network parameters for the TG700 can be set using the NETWORK SETUP submenu in the UTILITY main menu. Refer to *Setting Ethernet Network Parameters* in the *TG700 TV Signal Generator Platform User Manual* (Tektronix part number 071-1970-XX) for detailed information about how to set the network parameters.

**Starting and Exiting the File Copy Tools**

When you complete the installation procedure, you can use any of the following methods to start the file copy tools:

- Double-click the TG7Backup.exe, TG7Dupli.exe, or TG7Restore.exe shortcut icon on the PC desktop that you created during the installation procedure.
- Double-click the TG7Backup.exe, TG7Dupli.exe, or TG7Restore.exe file name in the Program Manager window.
- Select TG7Backup, TG7Dupli, or TG7Restore from the Start - Programs menu.

To exit the TG7 Backup, TG7 Duplicator, or TG7 Restore application, select **File > Exit** in the application window.

**File Copy Tools Tutorials**

This subsection describes the basics of operating the TG7 Backup, TG7 Restore, and TG7 Duplicator applications.
The TG7 Backup application allows you to back up all of the preset files saved in the TG700 to your PC.

**About a Preset File.** A preset file is a file saved in the **PRESET** folders of all of the installed modules and has the following format:

```
MSTATE<slot_number>.P<preset_number>
```

For example, MSTATE1.P01 is the preset for the module installed in slot 1 of the TG700, with preset number 1.

All of the folders and files in the TG700 file system are displayed using the TG7 Comm application. (See page 8, *Using TG7 Comm for File Transfers*.)

**Back Up Procedure.**

Perform the following steps to back up all of the preset files from the TG700 to the PC:

1. Start the TG7 Backup application to open the TG7 Backup window shown in the following figure.

![Figure 9: TG7 Backup window](image)

2. Use the **IP Address** field in the window to enter the IP address of the TG700.
3. Use the **Save directory** field in the dialog box to specify the destination folder for the preset files you are going to back up to your PC.
4. Click the **Backup** button to start the backup operation. When the backup operation is complete, the dialog box appears as shown in the following figure.

![Figure 10: Dialog box shows backup is complete](image)

5. Click the **OK** button.
Restoring Preset Files with TG7 Restore

The TG7 Restore application allows you to restore all of the preset files saved in the PC to the TG700.

**NOTE.** To restore all of the preset files to the TG700 and reuse them, the hardware configuration of the TG700 must be the same hardware configuration as when the preset files were backed up.

Perform the following steps to restore all of the preset files from the PC to the TG700:

1. Start the TG7 Restore application to open the TG7 Restore window shown in the following figure.

   ![Figure 11: TG7 Restore window](image)

   **Figure 11: TG7 Restore window**

2. Use the IP Address field in the window to enter the IP address of the TG700.

3. Use the Restore directory field in the dialog box to specify the folder in which the preset files are saved.

4. Click the Restore button to start the restore operation. When the restore operation is complete, the dialog box appears as shown in the following figure.

   ![Figure 12: Dialog box shows restore is complete](image)

   **Figure 12: Dialog box shows restore is complete**

5. Click the OK button.
**Transferring Files by TG7 Duplicator**

The TG7 Duplicator application allows you to transfer all of the files in one TG700 to another TG700.

*NOTE.* To transfer files between the two TG700 using the TG7 Duplication application, both of the instruments need to be the same memory size.

Perform the following steps to transfer all of the files in one TG700 to another TG700:

1. Start the TG7 Duplicator application to open the TG7 Duplicator window shown in the following figure.

   ![Figure 13: TG7 Duplicator window](image)

2. Use the **Source IP addr.** field in the window to enter the IP address of the source instrument.

3. Use the **Target IP addr.** field in the window to enter the IP address of the target instrument.

4. Click the **Copy** button to start the file transfer operation.
   
   The progress gauge appears to show that file transfer is progressing.

   *CAUTION.* Do not power off either of the TG700's until file transfer is complete. Doing so will prevent both instruments from starting normally.

   When the file transfer is complete, the dialog box appears as shown in the following figure.

   ![Figure 14: Dialog box shows file transfer is complete](image)

5. Click the **OK** button.
Using Frame Picture Generator

The Frame Picture Generator application is used only with the following modules:

- AVG7 Analog Video Generator Module
- AWVG7 Analog Wideband Video Generator Module
- DVG7 Digital Video Generator Module
- HDVG7 HDTV Digital Video Generator Module

Frame Picture Generator is a software application for a PC using the Microsoft Windows system. Frame Picture Generator provides the capability to convert a Windows bitmap file (.bmp) to a frame picture file (.pic) that can be used by the TG700. Using this application, you can convert a natural picture or a test pattern in bitmap format to a frame picture file and output it as a picture.

This section provides the following information:

- Installation instructions
- Starting and exiting Frame Picture Generator
- Elements of the Frame Picture Generator window
- Using the Frame Picture Generator menus
- Frame Picture Generator tutorials

Installation Instructions

This subsection provides instructions to install the Frame Picture Generator application on your PC.

The following installation instructions require that you are familiar with the basics of using the Windows operating system. If necessary, read your Windows user documentation before installing Frame Picture Generator.

Perform the following procedure to install the Frame Picture Generator:

1. Be sure that your PC meets the requirements before proceeding with the installation. (See page ix, PC System Requirements.)

2. Insert the TG700 Signal Generator Platform SW Library and Documentation CD (063-3939-XX) into a CD drive on your PC.

3. When the Product Software and Documentation Browser window appears, select the TG7 Tools Software link.

4. Select the Frame Picture Generator link to install the software. Follow the on-screen instructions to complete the software installation.
Perform the following procedure to create an icon on your PC desktop that you can use to run the Frame Picture Generator application.

1. On your PC display, right click to open the desktop menu.

2. Use the New > Shortcut command to create a shortcut to the FrameGEN.exe file.

3. You can start the TG7 Frame Picture Generator application by double-clicking the shortcut icon.

Starting and Exiting Frame Picture Generator

When you complete the installation procedure, you can use any of the following methods to start the Frame Picture Generator application:

- Double-click the FrameGEN.exe shortcut icon on the PC desktop that you created during the installation procedure.
- Double-click the FrameGEN.exe file name in the Program Manager window.
- Select FrameGen from the Start - Programs menu.

To exit the Frame Picture Generator application, select File > Exit in the application window.
Elements of the Frame Picture Generator Window

The following figure shows the Frame Picture Generator application window. For description of the elements in the application window, refer to the following table.

![Frame Picture Generator application window](image)

Figure 15: Frame Picture Generator application window

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title bar</td>
<td>The Title bar displays the name of the application and contains the standard window-sizing boxes for Windows.</td>
</tr>
<tr>
<td>Menu bar</td>
<td>The Menu bar displays the names of the five pull-down menus. (See page 27, Using the Frame Picture Generator Menus.).</td>
</tr>
<tr>
<td>Toolbar</td>
<td>The Toolbar provides shortcut buttons for many of the most often used menu commands. Click a toolbar button to select the corresponding command. (See Table 9.)</td>
</tr>
<tr>
<td>BMP View window</td>
<td>The BMP View window displays the selected bitmap image before conversion.</td>
</tr>
<tr>
<td>FrameBMP View window</td>
<td>The FrameBMP View window displays the frame bitmap image converted to the specified video format size.</td>
</tr>
<tr>
<td>PicBMP View window</td>
<td>The PicBMP View window displays the frame picture image converted to the bitmap file.</td>
</tr>
</tbody>
</table>
### Table 9: Toolbar button descriptions

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Open Icon]</td>
<td>Open</td>
<td>Equivalent to the Open command in the File menu.</td>
</tr>
<tr>
<td>![Save Frame Bmp As Icon]</td>
<td>Save Frame Bmp As</td>
<td>Equivalent to the Save Frame BmpAs command in the File menu.</td>
</tr>
<tr>
<td>![Save Pic Bmp As Icon]</td>
<td>Save Pic Bmp As</td>
<td>Equivalent to the Save Pic BmpAs command in the File menu.</td>
</tr>
<tr>
<td>![Build Frame Bmp Icon]</td>
<td>Build Frame Bmp</td>
<td>Equivalent to the Build Frame Bmp command in the Build menu.</td>
</tr>
<tr>
<td>![Build Pic File Icon]</td>
<td>Build Pic File</td>
<td>Equivalent to the Build Pic File command in the Build menu.</td>
</tr>
<tr>
<td>![Build Pic Bmp Icon]</td>
<td>Build Pic Bmp</td>
<td>Equivalent to the Build Pic Bmp command in the Build menu.</td>
</tr>
<tr>
<td>![Cascade Icon]</td>
<td>Cascade</td>
<td>Equivalent to the Cascade command in the Window menu.</td>
</tr>
<tr>
<td>![Horizontal Icon]</td>
<td>Horizontal</td>
<td>Equivalent to the Horizontal command in the Window menu.</td>
</tr>
<tr>
<td>![Vertical Icon]</td>
<td>Vertical</td>
<td>Equivalent to the Vertical command in the Window menu.</td>
</tr>
<tr>
<td>![Exit Icon]</td>
<td>Exit</td>
<td>Equivalent to the Exit command in the File menu.</td>
</tr>
</tbody>
</table>
Using the Frame Picture Generator Menus

The Menu bar displays the names of the five pull-down menus: File, Build, Settings, Window, and Help. This section describes the function of each selection in these menus.

File Menu

The File menu contains commands for managing file operations and for exiting the Frame Picture Generator application. The following table describes each of the File menu commands.

Table 10: Frame Picture Generator File menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>Opens a bitmap file. When you select a bitmap file, the image is displayed in the BMP View window.</td>
</tr>
<tr>
<td>Save Frame Bmp As</td>
<td>Saves the frame bitmap image displayed in the FrameBMP View window as a bitmap file.</td>
</tr>
<tr>
<td>Save Pic Bmp As</td>
<td>Saves the frame picture image displayed in the PicBMP View window as a bitmap file.</td>
</tr>
<tr>
<td>Exit</td>
<td>Exits the Frame Picture Generator application.</td>
</tr>
</tbody>
</table>

Build Menu

The Build menu contains commands that create a frame bitmap file or frame picture file and convert a frame picture file to a bitmap file. The following table describes each of the Build menu commands.

Table 11: Frame Picture File Build menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Build Frame Bmp</td>
<td>Converts the bitmap image displayed in the BMP View window to the bitmap file with the specified video format size.</td>
</tr>
<tr>
<td>Build Pic File</td>
<td>Converts the frame bitmap file displayed in the FrameBMP View window to the frame picture file (.pic) that can be used by the TG700. Since the AVG7 module outputs a signal using the 2-time over sampling technique, one pixel of a bitmap image corresponds to two samples of the signal. Therefore, when creating a frame picture file for the AVG7 module, the application uses each pixel of a bitmap image twice.</td>
</tr>
<tr>
<td>Build Pic Bmp</td>
<td>Converts the selected frame picture file (.pic) to the bitmap file and displays its image in the PicBMP View window. Note that this command cannot reproduce the original bitmap file completely because the data of the frame picture file is changed when it is converted from the bitmap file. This command is useful when you want to check any frame picture images on the PC.</td>
</tr>
</tbody>
</table>
Using Frame Picture Generator

**Settings Menu**
The Settings menu contains commands for setting the video format size and background color. The following table describes each of the Settings menu commands.

**Table 12: Frame Picture Generator Settings menu commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background</td>
<td>Specifies the color used for the background of the bitmap image.</td>
</tr>
<tr>
<td>Filter</td>
<td>Eliminates unnecessary high frequency components contained in the bitmap image. These high frequency components derive from rapid changes of intensity or hue in the image generated by using a graphic program. This command is only available for the video format sizes of the DVG7 and HDVG7.</td>
</tr>
<tr>
<td>Format</td>
<td>Specifies the video format size when the frame bitmap is created.</td>
</tr>
</tbody>
</table>

**Window Menu**
The Window commands control the appearance of the view windows. Use Arrange Icon when the windows are minimized.

**Help Menu**
The Help menu About FrameGen command displays the Frame Picture Generator software version number and copyright information.
This subsection describes the basics of operating the Frame Picture Generator application.

Perform the following steps to create a frame picture file (.pic) from a Windows bitmap file (.bmp).

1. Select File > Open.
2. Select the bitmap file on the PC that you want to convert, and then click the Open button. This will display the bitmap image in the BMP View window.
3. Select Settings > Background to specify the background color for the frame bitmap.
4. Select Settings > Format to select the video format size when the frame bitmap is created.
5. Select Build > Build Frame Bmp. This will display the frame bitmap image converted to the specified video format size in the FrameBMP View window.
6. Select Build > Build Pic File to convert the frame bitmap file to the frame picture file. While the conversion is in progress, the BUILDING PIC FILES dialog box shown in the following figure appears.

![BUILDING PIC FILES dialog box](image)

7. When the file conversion is completed, the Pic File dialog box appears.
8. In the dialog box specify the destination folder where you want to save the frame picture file, and the file name.
9. Click the Save button to save the file.
A frame picture file created by Frame Picture Generator is output as a picture by downloading to the TG700.

**NOTE.** Make sure to download a frame picture file to a folder for a generator module that can output the correct video format for the frame picture. If the video format for the frame picture file is different from the video format for the generator module, the picture is not output correctly.

**Note for Downloading a Frame Picture File.** It is recommended that you download up to 32 MB of frame picture files to the TG700 (the amount of free space in the TG700's system memory can be confirmed on the status bar in the TG7 Comm application).

The total number of lines of frame pictures and test signals that can be downloaded into a module is 4096. Since line numbers vary depending on a module and signal format, the number of frame picture files that can be downloaded into each module is as follows:

- AVG7: 7 files
- AWVG7: 3 files
- DVG7: 7 files
- HDVG7: 3 files

**NOTE.** The flash memory of the TG700 is shared among system files, test signal files, and frame picture files. Therefore, if you use the whole free memory space for frame pictures, system files may not be installed when upgrading the instrument, or additional test signals may not be installed.

If you have more pictures to be output, you can output them by saving another folder and then assigning it to the front-panel button.

**Downloading a Frame Picture File to the TG700.**

Perform the following steps to download a frame picture file from the PC to the TG700:

1. Start the TG7 Comm application after you connect your PC and TG700 using the appropriate Ethernet cable. (See page 8, *Using TG7 Comm for File Transfers.*)

2. Create a folder corresponding to a format name (for example 1080_60i) under the PICTURE folder of the appropriate generator module.

3. Download the frame picture file to the folder using the PC to TG command of the TG7 Comm application.
Outputting the Picture. Perform the following steps to output the frame picture file as a picture.

1. Assign the frame picture file to the OTHER test signal button on the front panel.
   
   Refer to the `SIGNAL KEY ASSIGN Submenu` in the TG700 user manual about how to assign a frame picture file to the OTHER test signal button.

2. Press the front-panel MODULE button to select the module from which you want to output the picture.

3. Press the front-panel FORMAT button to select the video format for the frame picture file.

4. Press the OTHER test signal button.

5. Press the left (◄) or right (►) arrow button, or the OTHER test signal button repeatedly to select the picture that you want to output.
Using Logo Generator

The Logo Generator application is used only with the following modules:

- DVG7 Digital Video Generator Module
- HDVG7 HDTV Digital Video Generator Module

Logo Generator is a software application for a PC using the Microsoft Windows system. Logo Generator provides the capability to convert a Windows bitmap file (.bmp) to a logo file (.lgo) that can be used with the logo overlay feature of the DVG7 or HDVG7 module.

This section provides the following information:

- Installation instructions
- Starting and exiting Logo Generator
- Elements of Logo Generator window
- Using the Logo Generator menus
- Logo Generator tutorials

Installation Instructions

This subsection provides instructions to install the Logo Generator application on your PC.

Installing Logo Generator

The following installation instructions require that you are familiar with the basics of using the Windows operating system. If necessary, read your Windows user documentation before installing Logo Generator.

Perform the following procedure to install the Logo Generator software:

1. Be sure that your PC meets the requirements before proceeding with the installation. (See page ix, PC System Requirements.)

2. Insert the TG700 Signal Generator Platform SW Library and Documentation CD into a CD drive on your PC.

3. When the Product Software and Documentation Browser window appears, select the TG7 Tools Software link.

4. Select the Logo Generator link to install the software. Follow the on-screen instructions to complete the software installation.
Creating a Desktop Shortcut Icon

Perform the following procedure to create an icon on your PC desktop that you can use to run the Logo Generator application.

1. On your PC display, right click to open the desktop menu.
2. Use the **New > Shortcut** command to create a shortcut to the **Logogen.exe** file.
3. You can start the TG7 Setup application by double-clicking the shortcut icon.

Starting and Exiting Logo Generator

When you complete the installation procedure, you can use any of the following methods to start the Logo Generator application:

- Double-click the Logogen.exe shortcut icon on the PC desktop that you created during the installation procedure.
- Double-click the Logogen.exe file name in the Program Manager window.
- Select LOGOGEN from the Start - Programs menu.

To exit (quit) the Logo Generator application, select **File > Exit** in the application window.
Elements of the Logo Generator Window

The following figure shows the Logo Generator application window. For description of the elements in the application window, refer to the following table.

![Logo Generator Window](image)

**Figure 17: Logo Generator application window**

<table>
<thead>
<tr>
<th>Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title bar</td>
<td>The Title bar displays the name of the application and contains the standard window-sizing boxes for Windows.</td>
</tr>
<tr>
<td>Menu bar</td>
<td>The Menu bar displays the names of the four pull-down menus. Refer to <em>Using the Logo Generator Menus</em> for detailed information about the menu functions. (See page 35, <em>Using the Logo Generator Menus</em>.)</td>
</tr>
<tr>
<td>Toolbar</td>
<td>The Toolbar provides shortcut buttons for many of the most often used menu commands. Click a toolbar button to select the corresponding command. You can toggle the toolbar display on and off using the Toolbar commands in the Settings pull-down menu. (See Table 14.)</td>
</tr>
<tr>
<td>BMP View</td>
<td>The BMP View displays the selected bitmap image.</td>
</tr>
<tr>
<td>LGO View</td>
<td>The LGO View displays the logo image converted to a grayscale.</td>
</tr>
<tr>
<td>Status bar</td>
<td>The status bar displays the bitmap size, bits per pixel, and conversion status (%) of the grayscale image.</td>
</tr>
</tbody>
</table>
Using the Logo Generator Menus

The Menu bar displays the names of the four pull-down menus: File, Build, Settings, and Help. This section describes the function of each selection in these menus.

File Menu

The File menu contains commands for managing file operation and for exiting the Logo Generator application. The following table describes each of the File menu commands.

Table 15: Logo Generator File menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open</td>
<td>Displays the Open dialog box where you can select the bitmap file you want to convert to a logo file.</td>
</tr>
<tr>
<td>Exit</td>
<td>Exits the Logo Generator application.</td>
</tr>
</tbody>
</table>

Build Menu

The Build menu contains a command that creates a logo file. The following table describes the Build menu command.

Table 16: Logo Generator Build menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Build Logo File</td>
<td>Create a logo file (.lgo) from a bitmap file (.bmp).</td>
</tr>
</tbody>
</table>

Settings Menu

The Settings menu contains commands for setting the gray level and background color for a logo image. The following table describes each of the Settings menu commands.

Table 14: Toolbar button descriptions

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Open icon]</td>
<td>Open</td>
<td>Equivalent to the Open command in the File menu.</td>
</tr>
<tr>
<td>![Build icon]</td>
<td>Build Logo File</td>
<td>Equivalent to the Build Logo File command in the Build menu.</td>
</tr>
<tr>
<td>![About icon]</td>
<td>About</td>
<td>Equivalent to the About LogoGen command in the Help menu.</td>
</tr>
</tbody>
</table>
Table 17: Logo Generator Settings menu commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gray Level...</td>
<td>Sets the gray level when a bitmap image is converted to a logo image. When you click this</td>
</tr>
<tr>
<td></td>
<td>command, the Gray Scale Settings dialog box appears. (See page 36, Gray Scale Settings</td>
</tr>
<tr>
<td></td>
<td>Dialog Box.)</td>
</tr>
<tr>
<td>Miscellaneous...</td>
<td>Sets a logo name, user comment, and display position. When you click this command, the</td>
</tr>
<tr>
<td></td>
<td>Miscellaneous Settings dialog box appears. (See page 37, Miscellaneous Settings Dialog Box.)</td>
</tr>
<tr>
<td>Background</td>
<td>Sets the background color.</td>
</tr>
<tr>
<td>Toolbar</td>
<td>Toggles the display of the Toolbar on and off in the application window.</td>
</tr>
<tr>
<td>Status Bar</td>
<td>Toggles the display of the Status bar on and off in the application window.</td>
</tr>
<tr>
<td>Save Settings</td>
<td>Specifies whether all the settings are saved.</td>
</tr>
</tbody>
</table>

**Gray Scale Settings Dialog Box.** The Gray Scale Settings dialog box (following figure) appears after you click the **Gray Level** command.

![Figure 18: Gray Scale Settings dialog box](image)

In this dialog box, you can set the following parameters:

- **White Limit**: Sets the maximum level for the Gray 2 level. The gray scale values greater than this value become white level. You can set the value from 0 to 255. The default value is 192.

- **Gray Limit**: Sets the maximum level for the Gray 1 level. You can set the value from 0 to 255. The default value is 128.

- **Blanking Limit**: Sets the maximum level for the Transparent. You can set the value from 0 to 255. The default value is 64.
**Reset Values** button resets all of the settings to the values that were in effect when the dialog box was first displayed.

**Default Values** button resets all of the settings to their default values.

**Update Display** button enables all of the settings with the dialog box opened.

**Miscellaneous Settings Dialog Box.** The Miscellaneous Settings dialog box (following figure) appears after you click the **Miscellaneous...** command.

![Miscellaneous Settings dialog box](image)

**Figure 19: Miscellaneous Settings dialog box**

In this dialog box, you can set the following parameters:

- **Logo Name**: Sets the logo name. This logo name is used when you select a logo from the LOGO OVERLAY submenu of the DVG7 or HDVG7 module. The default logo name is the file name.

- **Comment**: Sets the user comment described in the logo file. You need not enter any comments in general use.

- **Vertical Position**: Sets the vertical position where the logo is displayed on the monitor. You can set the value from -100% to 0%. The vertical position can be set from the LOGO OVERLAY submenu of the DVG7 or HDVG7 module.

- **Horizontal Position**: Sets the horizontal position where the logo is displayed on the monitor. You can set the value from -100% to 0%. The horizontal position can be set from the LOGO OVERLAY submenu of the DVG7 or HDVG7 module.

**Help Menu**

The Help menu contains a command that displays the Logo Generator application version information. The following table describes the Help menu command.

<table>
<thead>
<tr>
<th>Command</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>About LogoGen...</td>
<td>Displays information including the Logo Generator software version number and copyright information.</td>
</tr>
</tbody>
</table>
Logo Generator Tutorials

This subsection describes the basics of operating the Logo Generator application.

Creating a Logo File

Perform the following steps to create a logo file (.lgo) from a Windows bitmap file (.bmp).

1. Select File > Open.

2. Select the bitmap file on the PC that you want to convert, and then click the Open button. This will display the bitmap image in the BMP View and the logo image converted to a gray scale in the LGO View.

3. Select Settings > Gray Level to open the Gray Scale Settings dialog box. (See Figure 18 on page 36.)

4. Set the gray levels for the logo image. You can change the background color for the logo image using the Background command.

5. Select Settings > Miscellaneous to open the Miscellaneous Settings dialog box. (See Figure 19 on page 37.)

6. Set the vertical and horizontal positions for the logo to be displayed on the monitor. If necessary, set the logo name and user comment.

7. Select Build > Build Logo File from the Build pull-down menu to open the BMP to LGO File Conversion dialog box shown in the following figure.

![Figure 20: BMP to LGO File Conversion dialog box](image)

8. Click the OK button to create the logo file.
Firmware Upgrade

The TG700 firmware must be upgraded when a newly released module is installed. This section describes the upgrade.

Equipment Required

The following equipment is required to upgrade the firmware:

- PC with Windows 2000/Vista/XP/7 and Ethernet interface installed
- 10 BASE-T Ethernet cable (crossover or straight)
- TG700 Signal Generator Platform Software Library CD-ROM provided with the new module

Mainframe Memory Requirements

With software version 5.6, the TG700 mainframe must have at least 32 MB of memory installed. If you intend to install frame picture files (*.pic), created by the Frame Picture Generator application for the DVG7, HDVG7, AVG7, or AWVG7 modules, or if you intend to install bitmap frame picture files (*.bmp) for the SDI7 module, then the mainframe must have 64 MB of memory installed.

Software Upgrades

If your existing mainframe has 32 MB of memory and you have loaded the TG700 memory with frame picture files, you may not be able to upgrade the instrument to software version 5.6.

If you receive a memory error while attempting to upgrade the software version, you need to either delete some of the frame picture files or upgrade your instrument to 64 MB of memory.

Memory Upgrades

Option FP provided extra memory, which allowed the TG700 mainframe to support frame picture images. This option is no longer necessary for new TG700 mainframes.

If you have an older mainframe with less than 64 MB of memory, you can increase the memory in your mainframe to 64 MB by ordering the following upgrade kit: 040-1698-xx. Contact your local Tektronix representative for more information.
Upgrade Procedures

**NOTE.** Refer to Mainframe Memory Requirements before you perform the upgrade procedures. (See page 39.)

Perform the following procedure to upgrade the firmware. It is not necessary to uninstall the earlier version.

1. If you are connecting the TG700 directly to a PC:
   
   a. Using a crossover Ethernet cable, connect between the 10 BASE-T port on the TG700 and the Ethernet port or NIC on the PC.
   
   b. Power on the TG700 and the PC.
   
   c. Identify the PC’s IP address and subnet mask.
   
   **NOTE.** You can find the PC’s IP address and subnet mask by bringing up the “Command Prompt”, using the “Startup” menu under “Accessories” and typing “ipconfig” at the prompt.
   
   d. Set the IP address of the TG700 such that all the digits are the same except for the last digit, which should be changed by 1.
   
   e. Set the subnet mask of the TG700 to the same subnet as the PC.
   
   f. Proceed to step 4.
2. If you are connecting the TG700 to your local Ethernet network using a static IP address:

> **CAUTION.** Using an IP address that is already in use can cause network conflicts, resulting in system instability and/or the system locking up. Ensure that the IP address is not already in use before connecting to the network. Contact the network administrator for assistance.

a. Power on the TG700.

b. Set the IP address of the TG700 as specified by the network administrator.

c. Set the subnet mask of the TG700 as specified by the network administrator.

d. Using a straight Ethernet cable, connect between the 10 BASE-T port on the TG700 and the Ethernet hub port of your local network. By connecting to an Ethernet network, you can access the TG700 using any PC on the network.

e. Power on a PC connected to the network and proceed to step 4.

3. If you are connecting the TG700 to your local Ethernet network using a DHCP server (dynamically allocated IP addresses):

a. Power on the TG700.

b. Set the NET SETUP:DHCP setting to Enable on the TG700.

c. Power off the TG700.

d. Using a straight Ethernet cable, connect the 10 BASE-T port on the TG700 to the Ethernet hub port of your local network. By connecting to an Ethernet network, you can access the TG700 using any PC on the network.

e. Power on the TG700 and a PC connected to the network.

f. Identify the IP address assigned to the TG700 by the DHCP server.

g. Proceed to step 4.
4. Insert the *TG700 Signal Generator Platform SW Library and Documentation CD−ROM* provided with the new module into the CD drive on your PC.

5. When the Product Software and Documentation Browser window appears, select the **Mainframe and Module Software** link.

6. Select one of the following upgrade options:
   - Select **Upgrade to V5.X** if your mainframe has 32 MB or more of memory.
   - Select **Upgrade to V4.1** if your mainframe has 16 MB of memory.

   The PC will open a Windows Explorer window displaying the contents of the selected upgrade folder.

**NOTE.** With software version 5.6 and later, it is strongly recommended that the TG700 mainframe have 64 MB of memory if you intend to install logo and/or frame picture files into a DVG7, HDVG7, or SDI7 module. (See page 39, *Mainframe Memory Requirements.*)
7. Double-click the tgUpgrade.exe icon in the folder. The TG700 Upgrade dialog box appears as shown in the following figure.

![TG700 Upgrade dialog box](image)

**Figure 21: TG700 Upgrade dialog box**

*NOTE. In the following cases, an error message appears when you double-click the tgUpgrade.exe icon. If this happens, copy all of the files in the Upgrade folder to the hard disk, and then repeat the operation.*

- When you upgrade the TG700 with firmware version 1.3 or earlier and use the ATG7, AVG7, or AWVG7 module in it.
- When you upgrade the TG700 with firmware version 2.1 or earlier and use the AVG7 or AWVG7 module in it.
8. In the dialog box, enter the IP address that you assigned to your TG700.

9. If you want to download the signals for the specified module(s), use the check boxes at the bottom of the dialog box. Normally, you do not need to select any check boxes. Select the appropriate check box(es) in the following cases:

   - ATG7 check box: when you upgrade the TG700 mainframe with firmware version 1.3 or earlier and use the ATG7 module in the mainframe.
   - AVG7 check box: when you upgrade the TG700 mainframe with firmware version 2.1 or earlier and use the AVG7 module in the mainframe.
   - AWVG7 check box: when you upgrade the TG700 mainframe with firmware version 2.1 or earlier and use the AWVG7 module in the mainframe.

10. Click the Copy button. The PC will start transferring the files in the Upgrade folder to the TG700.

   **CAUTION.** Do not power off the TG700 until the file transfer is complete. Doing so will prevent the instrument from starting up normally.

11. When the file transfer is complete, the message box shown below appears.

![TG700 Upgrade](image)

   **Figure 22: Message box appearing after the file transfer is complete**

12. Click the OK button in the message box.

13. Disconnect the power cable from the power cord connector on the TG700 rear panel, and then connect it again to restart the instrument.
14. If your TG700 includes an HDLG7 module, proceed with the following steps to complete the upgrade:

**CAUTION.** While upgrading, do not press the front panel buttons or cycle the instrument power. Doing so can corrupt the module memory and FPGA image.

a. Power on the TG700.
b. Press the **MODULE** button until the name of the module you are upgrading appears.
c. Press and hold the **ENTER** button until “Upgrade FPGA” appears.
d. Press the **ENTER** button to upgrade the module.
e. The upgrade will take approximately three minutes. After it is complete, remove power from the TG700 and then reapply power to reboot the system.

**NOTE.** If you are upgrading the FPGA of multiple modules, you need to upgrade them separately and reboot the instrument after each upgrade. For example, if you have three HDLG7s, the FPGA upgrade process sequence will be: select and upgrade a module, then reboot, then select and upgrade another module, then reboot, select and upgrade the final module, then reboot. You do not need to upgrade the modules in any particular order.

### Firmware Version Check

Perform the following procedure to verify that the new firmware version was properly installed:

1. Press the front-panel MODULE button to display the TG700 main menu.
2. Use the up (▲) or down (▼) arrow button to select **UTILITY**, and then press the **ENTER** button.
3. Use the up (▲) or down (▼) arrow button to select **VERSION INFO (F/W)**.
4. Use the left (◄) or right (►) arrow button to select **CPU[0]**.
5. Check that the new firmware version number is displayed in the menu.

Refer to the *Release Notes* included on the CD-ROM for information about the new firmware version.
Network Interface Specifications

NOTE. Refer to the TG700 TV Signal Generator Platform User Manual for instructions on connecting the TG700 to a single PC or a network and setting the network parameters for the 10 BASE-T port.

The TG700 supports remote control using the Ethernet interface. This section describes the TG700 network interface specifications.

The TCP/IP is used as the network protocol, and the port number is fixed 5000. The commands can be sent from the application program through the socket interface of the TCP/IP. Also, the query can be received through the interface.

Keep the following in mind while controlling the TG700 remotely with the Ethernet interface.

- The Line Feed (LF) code is needed at the end of a message as a terminator.
- The IEEE 488.1 standard (such as Device Clear and Service Request) is not supported.
- The Message Exchange Control Protocol in the IEEE 488.2 is not supported. However, the common commands such as *ESE and the event handling features are supported.
- The Indefinite format (the block start at #0) in the <ARBITRARY BLOCK PROGRAM DATA> of the IEEE 488.2 is not supported.
Checking Remote Command Operation

To check remote command operation of the TG700 mainframe, perform the following procedure:

1. Connect the TG700 to your PC using an Ethernet cable. Refer to the TG700 TV Signal Generator Platform User Manual (Tektronix part number 071-1970-XX) for detailed information about how to connect the TG700 to your PC.

2. Click Windows Start button and select Run from the start menu

3. In the dialog box, type telnet and then click OK.

   The TELNET window appears.

4. Select Terminal > Preferences.

5. Select Local Echo and click OK.


7. Enter the IP address of the TG700 in the Host Name field and 5000 in the Port field.

8. Click Connection.

9. Type *IDN in the command line and press the Enter key.

10. Check that the ID information of the TG700 appears on the PC.

NOTE. If you use a PC running Windows 2000/XP/7, connect the TG700 and your PC using the Hyper Terminal application supplied with Windows. Refer to Windows Online Help or other documentation for detailed information about Hyper Terminal.
Index

B
Backing up preset files by TG7 Backup, 20
Build menu (Frame Picture Generator), 27
Build menu (Logo Generator), 35

C
Comm application
  Ethernet, 10
  Exiting, 10
  File menu, 13
  File transfers, 8
  Help menu, 14
  Installation, 8
  Starting, 10
  Tutorials, 15
  Utility menu, 14
  View menu, 13
Creating a frame picture file, 29
Creating a logo file, 38

D
Downloading a file to the TG700 mainframe, 16

E
Ethernet
  Comm application, 10
  Setup application, 2
Exiting the file copy tools, 19
Exiting the Frame Picture Generator application, 24
Exiting the Logo Generator application, 33

F
File copy tools tutorials, 19
File menu
  Comm application, 13
  Setup application, 4
  File menu (Frame Picture Generator), 27
  File menu (Logo Generator), 35
  File transfers See Comm application
  Firmware upgrade, 39
  Frame Picture Generator application, 23
  Frame Picture Generator tutorials, 29

G
Gray Scale Settings dialog box (Logo Generator), 36

H
Help menu
  Setup application, 5
  Help menu (Frame Picture Generator), 28
  Help menu (Logo Generator), 37

I
Installing Frame Picture Generator, 23
Installing Logo Generator, 32
Installing the file copy tools, 18

L
Logo Generator application, 32
Logo Generator tutorials, 38

M
Mainframe memory requirements, 39
Manuals
  related, viii
  service, viii
Memory Free indicator, 12
Memory requirements, 39
Miscellaneous Settings dialog box (Logo Generator), 37

P
PC system requirements, ix

R
Restoring preset files by TG7 Restore, 21, 22

S
Safety Summary, v
Settings menu (Frame Picture Generator), 28
Settings menu (Logo Generator), 35
Setup
  tutorial, 6
Setup application, 1
  Ethernet, 2
  Exiting, 3
  File menu, 4
  Help menu, 5
  installation, 1
  Starting, 3
  View menu, 5
  Window elements, 3
  Window menu, 5
Starting the file copy tools, 19
Starting the Frame Picture Generator application, 24
Starting the Logo Generator application, 33

T
TG7 Backup application See File Copy Tools
TG7 Comm application See Comm application
TG7 Duplicator application See File Copy Tools
Index

TG7 File Copy Tools  See File Copy Tools
TG7 Restore application  See File Copy Tools
TG7 Setup application  See Setup application

Tutorial  
    Setup, 6

Tutorials  
    Comm application, 15
    File copy tools, 19
    Frame Picture Generator, 29
    Logo Generator, 38

U  
Upgrading the firmware, 39
Uploading a file to a PC, 17, 30
Utility menu  
    Comm application, 14

V  
View menu  
    Comm application, 13, 14
    Setup application, 5

W  
Window menu  
    Setup application, 5
    Window menu (Frame Picture Generator), 28