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Preface

This manual supports the Multiplexer demo.

Other documents are available on the Tektronix Web site (www.tektronix.com/
manuals):

H MTS400 Series MPEG Test System Generator Application User Manual
(077-0204-xx)

H MTS400 Series MPEG Test System Analyzer Application User Manual
(077--0205--xx)

H MTS400 Series MPEG Test System Carousel Application User Manual
(077--0203--xx)

H MTS400 Series MPEG Test System Programmer Manual (077-0206-xx)
This manual specifies the remote control and status monitoring interfaces
available to a management application.

Manual Conventions
The following formatting conventions apply to this manual:

H Bold text refers to specific interface elements that you are instructed to
select, click, or clear.
Example: Select Settings from the Configuration menu.

H Mono--spaced text can indicate the following:

H Text you enter from a keyboard.
Example: Enter the network identity (http://TSMonitor01).

H Characters you press on your keyboard.
Example: Press CTRL+C to copy the selected text.

H Paths to components on your hard drive.
Example: The program files are installed at the following location:
C:\Program Files\Tektronix\.
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Introduction to the Demo Version

The Tektronix Multiplexer (Demo version) provides off-line multiplexing of
ATSC, MPEG-2, DVB, and ISDB transport streams.

Transport streams (TS), elementary streams (ES), packetized elementary streams
(PES), Packet Identifiers (PID) can all be selected, manipulated, and recombined
to form customized, synthesized transport streams in the demo version.

On opening, streams are analyzed and displayed according to the selected
standard: MPEG, DVB, ATSC, or ISDB.

Installing the Demo Version
You can download the MultiplexerSetup.exe file from
www.tektronix.com/software and follow these steps to install the demo version
of Multiplexer.

1. Double-click MultiplexerSetup.exe to start the InstallSheild Wizard that
installs the Multiplexer demo version on your computer. Click Next to
continue.



Introduction to Demo Version

2 Multiplexer (Demo) User Manual

2. Click Install to begin the installation process.

The InstallShield Wizard installs the application while displaying the
progress.
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3. Click Finish to exit the Wizard once the demo version is successfully
installed.

Starting the Program
Start the program by selecting the Multiplexer option from the Start > Programs
> Tektronix (Demo versions) > Generators menu or by double-clicking the
Tektronix Multiplexer (Demo version) shortcut on the desktop.
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Once the demo program starts and is ready for use, it opens a main window as
follows:

The title bar of the main window shows Multiplexer to be a demo version.

The Export mode is disabled for the demo version. You cannot export data from
the Programs view (section data), the Tables view (section data), or the Pids view
(elementary stream and payload data).

All of the Export options (Export Payload, Export Elementary Stream, and
Export Section Data) of the Edit menu are also disabled.

Initial Appearance

Export Mode
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When you click the Export and Export As options of the File menu, the file is
not exported. Instead a message informs you that the export mode is disabled.

The demo version does not generate an output TS file, so you will not be
prompted to save the output file. However, the Mux cycle will end.

When you start the Multiplex Engine, a message informs you that the output TS
file is not generated.

The Multiplexer in demo mode cannot play out the multiplexed files. The
Playout menu/toolbar option is disabled.

Multiplex Process

Pseudo Realtime Playout
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Multiplexer - Getting Started

The Tektronix Multiplexer (Full version) provides off-line multiplexing of
ATSC, MPEG-2, DVB, and ISDB transport streams.

Transport streams (TS), elementary streams (ES), packetized elementary streams
(PES), Packet Identifiers (PID) can all be selected, manipulated and recombined
to form customized, synthesized transport streams. Program Specific Information
(PSI), Service Information (SI), and Program and System Information Protocol
(PSIP) are often referred to as simply SI in this section.

The functionality provided includes:
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H Wizards that facilitate the completion of common tasks, such as populating
streams with Program Specific Information, Service Information, Program
and System Information Protocol (PSI/SI/PSIP), and programs.

H Table contents are displayed in and edited from structure diagrams (tree
diagrams).

H Transport Streams that either conform strictly to the standards selected for
interpretation or have precisely engineered, known, nonconformances.

H Two or more instances of Multiplexer can run concurrently. This allows table
information to be copied from one file to another.

H The source data for nonconformant streams can be saved in a raw format,
which can be quickly reloaded as the basis for generating more stream data.

H Conformance of edits to the standards is checked interactively and enforced
by default. Checking and enforcement can be turned off when specifying
nonconformances to be introduced into the new transport stream.

On opening, streams are analyzed and displayed according to the selected
standard: MPEG, DVB, ATSC, or ISDB. Scripts are used by the analysis
process; this allows private PSI/SI tables and descriptors to be defined.

NOTE. Most examples given in this section of the user manual are based on DVB
SI. Multiplexer is equally at home with all major DTV standards, MPEG-2,
DVB, ATSC, and ISDB as well as the major regions to those standards.

The Transport Stream Analyzer program should always be used for reliable
analysis of transport streams containing DSM-CC or MPE addressable sections.

In the absence of TS Analyzer, it is acceptable to use Multiplexer for analysis,
provided that the DSM-CC or MPE scripts are first applied using Expert mode
in the Stream Interpretation dialog box (see Scripts, page 13).

However, when you are multiplexing streams containing DSM-CC or MPE
addressable sections, the related scripts must not be active.

You can initiate a playout in the Multiplexer application using the playout feature
as soon as the multiplex operation is complete. Multiplexer creates a temporary
transport stream in the location specified by the Playout Settings and then
initiates a playout by loading this file into the player. To play the stream in the
loop mode, enable the loop mode in the Playout settings.

Multiplexer in Playout
mode
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To open Playout Settings dialog box, select Multiplex > Playout settings.

NOTE. The Playout functionality is not available in demo version.

H.264 ES Input Characteristics
The H.264 elementary streams used by the Multiplexer should comply with
ISO/IEC-14496-10/2005 Rec. H.264. The transport stream generated by the
Multiplexer should comply with ISO/IEC-13818-1/2000/AMD_3/2004.

H SEI (Supplemental enhancement information) stream support

The multiplexer detects a H.264 stream as an SEI stream if the following
conditions are met:

H VUI (video usability information) packet contains the coded bit rate.

H HRD (hypothetical reference decoder) parameters are specified in the
SEI packets.

H Non-SEI stream support

Those streams that are not detected as SEI streams are assumed to be
non-SEI streams.

Table 1 lists the stream properties of H.264/AVC and generated transport stream
characteristics.

PTS/DTS Timestamp
Generation
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Table 1: PTS/DTS Timestamp Updates

H.264/AVC stream properties Comments Generated TS characteristics

SEI VUI
BM(Valid Buff-
ering Mes-
sages)

Bit rate Comments

-- -- --

Stream without any
buffering messages

Prompted or auto de-
tected

TS will have PTS and DTS calcu-
lated at a constant frame rate from
the VUI parameters of the stream
unless you change the parameters.
If the stream does not have VUI
parameters 25 fps is taken as the
default.

F -- --

SEI NAL units poten-
tially carrying private
data

Prompted or auto de-
tected

TS will have PTS and DTS calcu-
lated at a constant frame rate from
the VUI parameters of the stream
unless you change the parameters.
If the stream does not have VUI
parameters 25 fps is used as the
default.

F F --

SEI stream without full
HRD data

Prompted or auto de-
tected

TS will have PTS and DTS calcu-
lated at a constant frame rate from
the VUI parameters of the stream
unless you change the parameters.
If the stream does not have VUI
parameters 25 fps is used as the
default.

F F F

SEI stream with both
buffering period and
picture timing present
(HRD Compliant)

Coded bit rate will be
auto-detected

TS will carry PTS and DTS as
coded by the SEI timing informa-
tion.

The stream bit rate is calculated as follows.

Bitrate= File Size
Number of Frames∕ Frame Rate)

Starting the Program
The program can be started by selecting the Tektronix Multiplexer option from
the Start > Programs menu or by double-clicking on the Tektronix Multiplexer
shortcut on the desktop.

Auto detection
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Once the program has started and is ready for use, it will open a main window
that looks like the following illustration.

Use the View menu to select a standard that will be used to interpret transport
streams, and then open a transport stream file or import a multiplex configura-
tion file.

When the application is opened, you are presented with options relevant only to
opening new or existing multiplex files. Options that are not relevant at this time
are inactive (grayed out).

Initial Appearance

Initial Menu Options
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File Menu Options. Table 2 lists the options available in the initial File menu.

Table 2: File menu options

Command Function

New Opens a new multiplex configuration file.

Open Opens an MPEG file for use. The program opens the file
selection dialog box allowing you to choose the required file.

Examine TS Opens the Examine TS window, which allows a brief summary
of the stream to be viewed before it is subjected to full
analysis.

Close (Currently disabled - see page 23.)

Import... Opens a previously saved multiplex configuration file.

Export (Currently disabled -- see page 23.)

Export As (Currently disabled -- see page 23.)

1 <filename>

2 <filename>

3 <filename>

4 <filename>

A list of the four most recently used files. If the program has
recently been installed, the list might be empty or hold less
than four files.

Selecting a file name opens that file for use.

Exit Finishes running the program.

View Menu Options. Table 3 lists the options available in the initial View menu.

Table 3: View menu options

Command Function

Interpretation Opens the Stream Interpretation dialog box. This allows the
scripts to be used in stream analysis to be selected.

Event Log Opens the Event Log window.

Toolbar Displays or hides the Toolbar.

Status Bar Shows or hides the Status Bar.

A check mark next to an option indicates that the object is currently visible.



Multiplexer - Getting Started

Multiplexer (Demo) User Manual 13

Scripts
SI scripts are necessary to enable SI table and descriptor data to be analyzed
successfully. Scripts are used to enable analysis of SI data dictated by the various
international standards, for example, MPEG-2, DVB, ATSC, and ISDB.

Essential scripts are installed and enabled using the Stream Interpretation dialog
box. In the absence of any enabled scripts, only the PAT table will be analyzed;
all other data will be presented as private data.

If a suitably configured script is selected and enabled before a stream is opened,
custom data will be analyzed when the stream is opened. If the script is not
selected or enabled, the stream will be analyzed, but any custom data will be
reported as either an error in the stream configuration or as an elementary stream
PID.

Scripts can be selected and enabled only when no files are open. The Stream
Interpretation dialog box is available when a file is open, but all activity is
disabled.

Note that a script file will not be used for analysis until:

H It is present in the Scripts text box in the current analysis mode.

H It is successfully enabled by closing the Stream Interpretation dialog box
using the OK button.

To open the Stream Interpretation dialog box, with all files closed, select
View > Interpretation.

Handling Scripts
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The Stream Interpretation dialog box is displayed as shown.

Expert mode controls

Script
Selection

Current

The top half of the dialog box is concerned with selecting scripts. The text box
(Scripts) lists the scripts currently selected. The area adjacent to the text box is
dedicated to Expert mode controls.

The selection area of the Stream Interpretation dialog box is best viewed and
used from left to right.

The Base Standard drop--down allows the MPEG-2, DVB, ATSC, or ISDB
standard to be selected for analysis.

MPEG-2 only Interprets and analyzes the packets in conformance to
the MPEG-2 standards.

DVB Interprets and analyzes the Transport Stream Packets
according to the specifications of the DVB and MPEG-2
standards.

ATSC Interprets and analyzes the Transport Stream Packets
according to the specifications of the ATSC and
MPEG-2 standards.

ISDB Interprets and analyzes the Transport Stream Packets
according to the specifications of the ISDB and
MPEG-2 standards.

The selected standard will dictate the availability of the remaining options in the
Regions and Data Standards sections.

Selecting Scripts
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The Regions section allows country-specific regions to be added to the basic
standard scripts. If None is selected, only the standard scripts are listed in the
Scripts text box. The remaining country-specific regions add extra scripts to the
current listing. As with the Base Standard, the choice of Regions option will
dictate the availability of the options in the Data Standards section. The Custom
selection in the Regions section allows users to include their own selection of
scripts using Expert Mode controls.

The Data Standards section offers a choice of data-specific scripts.

Note that the scripts listed by default are those resident in the default installation
directory (tektronix\scripts). Other directory locations can be specified in Expert
Mode. All selections will be retained between sessions.

Scripts are syntactically analyzed when the OK button is selected. They are also
checked when the application is opened. A fault in the syntax of a script will not
necessarily prevent a stream from being analyzed, but it might result in
incomplete analysis of the stream.

Scripts listed in the Scripts text box will not be used for stream analysis until
they have been successfully checked (the application has been opened or the
Stream Interpretation dialog box has been closed with no script-related error
messages issued).

An intermediate check of scripts listed in the Scripts text box can be made by
selecting the Reload Scripts button. This performs the same action as the OK
button but leaves the dialog box open.

Syntax errors will be indicated and reported in the Event Log (see page 69).

Checking Syntax
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Expert Mode allows you to select and customize the scripts to be used in
stream analysis and multiplexing. Note that when the expert mode is selected,
the Custom region option is automatically selected and the management buttons
are enabled. In Expert mode, all scripts become available to be added to the
script list. The scripts will be checked and loaded, ready to be used for analysis,
when the OK button is selected.

Script Management

The script management buttons act on the scripts currently listed in the Scripts
text box.

Table 4: Script Management

Buttons Function
Script files are parsed in the order that they are listed; in some circum-
stances this might be important. To move a file in a list, highlight the file
name and select the Up or Down arrow button as required. Each press of
the button will move the file up or down one place in the list until it reaches
the top or the bottom.

Add a script to the list: A standard Windows file selection dialog box is
opened. The default file extension is .scp. Select the required file. The
selected script will be added to the bottom of the list. If necessary, move it
using the Up and Down buttons.

Scripts can be loaded from any directory.

Delete the highlighted script.

Expert Mode
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Table 4: Script Management (Cont.)

Buttons Function

Change scripts default directory: by default, all scripts are found in a default
directory created during installation (tektronix\scripts). This button can be
used to set a different default directory.

Note that all scripts supplied by Tektronix in the default installation are
installed in a single directory; as long as this directory is designated as the
default directory, they will work satisfactorily.

View highlighted script with the associated application; by default, script files
are associated with the ScriptPad utility.

For a script file to be viewed successfully, the file extension (.scp) must be
associated with a text editor in the Microsoft Windows environment. The MPEG
Test System installation program by default associates a script editing utility
called ScriptPad; you can use another text editor, for example, Microsoft
Notepad, if preferred. ScriptPad is a simple script editor that can be installed
with the MPEG Test System. Scripts can be viewed and edited as required
(depending upon the file permissions).

Opening a Stream
Two options are available when opening a stream for multiplexing: to open an
existing stream or to open a previously prepared multiplex configuration file.

Three options are available when preparing a stream to be multiplexed:

H Create a new null stream (using File > New)

H Open an existing stream

H Import a multiplexer configuration file

Any file holding a recorded or synthesized sample of a stream that conforms to
the relevant standards can be opened and used as a basis for a new multiplex.
Note that the Examine TS option (see page 70) can be used to preview stream.

Some nonconformant streams can be opened, although, only the conformant
parts can be edited usefully. Any tables that are carried in a conformant PID and
have the correct syntax will appear in the output transport stream, as will any
elementary streams (whether referenced by a table or not) which are in the input
transport stream.

To open a file holding a transport stream, select the File > Open. If the required
file is in the list of recent files, it can be opened from the list using the Open File
dialog box.

Opening an MPEG Stream
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Alternatively use the Ctrl+O keyboard shortcut or drag the file from Windows
Explorer and drop it into the Multiplexer window. A shortcut button is available
on the Toolbar for opening a file.

Any file holding a recorded or synthesized sample of a stream, which conforms
to the relevant standards, can be opened. Many nonconformant streams can be
opened provided that the PAT, PMT, and MGT tables correctly specify all the
other tables and their PIDs.

Multiplexer is used for generating both conformant and nonconformant streams.
Having generated a nonconformant stream, it might not be possible to success-
fully open it again in Multiplexer.

The specification for a new transport stream can be saved to a multiplex
configuration file. This also saves time for opening large MPEG files, since the
specification contains the results of the analysis from opening the original
MPEG file.

NOTE. The multiplex configuration file does not contain a copy of the transport
stream; instead it refers to the original MPEG file by the full path name.
Deleting or moving the MPEG file will result in a dialog box prompting for the
new location of the file.

Double-clicking on a *.muxml or *.mux file in Windows Explorer will open the
file in a new instance of Multiplexer.

Importing a File. Importing opens a multiplex configuration file and the MPEG
file on which it is based.

To open a previously exported multiplex configuration file, select the
File > Import. If the required file is in the list of recent files, it can be opened

Opening Multiplex
Configuration Files
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from the list to save using the Import file dialog box.

Alternatively use the Ctrl+I keyboard shortcut or drag the file from Windows
Explorer and drop it into the Multiplexer window.

NOTE. Multiplexer reads the name and location of the MPEG file from the
multiplex configuration file and then opens it automatically. The previously
stored changes in the configuration file are applied to the display.

Note that the import dialog box offers a choice of file types: *.muxml, *.mux
and *.*.

The Navigator Tables view window is opened as soon as a file is opened or
imported. The program now starts to analyze the file with the loaded scripts to
determine what tables are present.

As the file is analyzed, the Top Levels of the Transport Structure diagram are
drawn in the Navigator window. The rightmost pane in the Status Bar at the
bottom of the program window shows the progress of analysis.

Initial Stream Analysis
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Files that are imported require less processing because they were analyzed in the
session from which they were exported.

The file can now be manipulated to form a specification with which to synthesize
a new transport stream. Tables, elementary streams, and PIDs are viewed and
selected using the Navigator views. The components of any table selected in the
Navigator views are viewed and selected using the Section View window.

Tables, Programs and PIDs can be added and modified using the wizards
provided or manually. A selection of menu options is provided to facilitate
manipulation of the data.

The Multiplex menu has options to inhibit and reenable forced conformance to
the selected standards.

Having manipulated the file, a transport stream can be synthesized to the new
specification by the multiplex engine. The engine is started from the Multiplex
menu or using a toolbar button. The source file is used as reference data by
Multiplexer and the output written to a different file.

The illustration on page 21 gives an overview of the Multiplex process.

What to Do Next
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Open/Import

Any file holding a recorded or synthesized sample of a
stream that conforms to the relevant standards can be
opened. See Opening an MPEG file.

Importing opens a multiplex configuration file and the
MPEG file on which it is based.

See Importing a File, page 18.

Transport Structure Modifications

The file can now be manipulated to act as the specification
to synthesize a new transport stream. The tables and
elementary streams are viewed and selected either with the
aid of Wizards or in the Navigator windows.

Output/Export

The Multiplex Engine synthesizes a new transport stream
and writes it to an MPEG file.

To ensure that the specification for any synthesized stream
can be reused, it can be saved to a multiplex configuration
file.

See Multiplexing Transport Streams, page 125.

Transport Structure Demultiplex

As the file is analyzed, the Top Levels of the Transport
Structure diagram are drawn in the Transport Navigator.

See Initial Stream Analysis, page 19.
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Closing Files
To close the files, select File > Close. This will close both the MPEG file and
any multiplex configuration file that is open.

A shortcut button is also available on the Toolbar for closing a file, which has a
standard file close symbol.

If a multiplex configuration file has been edited, and the changes not exported,
the program will ask if the file should be saved.

Select Yes to export the file, No to close the file without saving, or Cancel to
undo the close command and keep the file open.
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Menus and Controls

This section describes the various menu options, toolbar controls, status bar,
icons, and user interface.

Menu Options
The following pages describe all of the menu options. Since many of the options
are context sensitive, they will be available only when their function is appropri-
ate for the selected display or window element. When a menu option is not
available, the option is grayed out.

Table 5 lists the options available in the File menu.

Table 5: File menu options

Command Function

Close Closes the current file. This option is available as soon as
analysis starts. If the wrong file is being opened, or the wrong
options are selected, selecting this option will abandon the
analysis and close the file.

Examine TS Opens the Examine TS window, which allows a brief summary
of the stream to be viewed before it is subjected to full
analysis.

Export... Exports the current multiplex specification in a form that can be
imported even if it no longer generates a conformant transport
stream. This option is disabled when no file is open.

Export As... Exports the current file, as above, and allows a different file
name to be specified. This options is disabled when no file is
open.

Exit Closes any file that is open and terminates the program.

File menu options
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Table 6 lists the options available in the Edit menu.

Table 6: Edit menu options

Command Function

Add Adds a table/section/loop to the currently selected item in the
Navigator or Section View.

Modify Edits the information in the currently selected field or item.

Delete Deletes the item currently selected.

Cut Cuts the current selection from the Window.

Copy Copies the contents of the current selection to the clipboard.

Paste Pastes data from the clipboard to the part of the transport
structure that holds that type of data.

Export Payload Extracts and exports the payload of the source transport
stream PID in the form of a simple data file.

Export Elementary Stream Removes the transport stream PID and PES headers and
exports the remaining information as a simple data file.

Export Section Data Extracts and exports section data. The created file can be
imported as ES using Multiplexer’s Add function or as SI using
the Import Section Data option (see next option).

Import Section Data Imports SI data from a file and analyzes it. The section is
added to the Navigator view.

Table 7 lists the options available in the View menu.

Table 7: View menu options

Command Function

Interpretation Displays a read--only dialog box for viewing scripts that have
been selected for analysis (see also Initial Menu Options,
page 11).

Section View Opens the window and displays the table section currently
selected in the Navigator view.

Event Log Displays the list of events that are recorded in the Event Log.

Component Bit rate Displays a graphical comparison of the stream bit rates.

Component Duration Displays a graphical comparison of the stream component
durations.

Available Bit rate Displays a graphical view of the bit rate in the stream.

Properties Opens a properties dialog box for editing the currently selected
item in the Transport Navigator window.

Edit menu options

View menu options
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Table 7: View menu options (Cont.)

Command Function

Zoom In Zooms in the Available Bit rate and Component Duration
views.

Zoom Out Zooms out from the Available Bit rate and Component Duration
views.

Synchronize Synchronizes zoom levels of the Available Bit rate and
Component Duration views (toggle).

Show Cursor Shows or hides the cursor in the Available Bit rate and
Component Duration views.

Toolbar Shows or hides the Toolbar.

Status Bar Shows or hides the Status Bar.

Table 8 lists the options available in the Options menu.

Table 8: Options menu options

Command Function

Display Filter Opens the SI Filter dialog box.

Single Section View Selects single or multiple section view. When disabled, multiple
section views can be opened.

Program Wizard Invokes the Program wizard.

Transport Wizard Invokes the Transport wizard.

Scan Settings Opens the Scan Settings dialog box.

Options menu options
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Table 9 lists the options available in the Multiplex menu.

Table 9: Multiplex menu options

Command Function

Start Starts the Multiplex Engine, to synthesize a new transport
stream file.

Stop Aborts multiplexing. The output file is closed and contains all of
the data synthesized up to the point where the multiplex engine
stopped. This option is available only while the Multiplex
Engine is running.

Standard Mode Enforces conformance to the selected standards when editing
some fields that can be generated automatically.

Expert Mode Inhibits the above conformance checking so that nonconfor-
mant files can be created.

Report Provides the option of printing all or part of the transport
structure to either a file or a printer.

Seamless When enabled, the program specified in Seamless Settings is
processed and made seamless.

Seamless Settings Opens a dialog box in which the Make seamless parameters
are specified.

Playout When enabled, generates and captures
MPEG--2 transport streams that are compliant
with ATSC, DVB, and ARIB standards. This option is not
available in demo version.

Playout Settings Opens the Playout Settings dialogbox in
which, the path of the MPEG player application
and the folder where the temporary files are
specified. This option is not available in demo version.

Loop Sets whether the stream is output using the looping method.
This option is not available in demo version.

Update Opens a dialog box in which the parameters
in a stream are updated when looped. This option is not
available in demo version.

Multiplex menu options
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Table 10 lists the options available in the Window menu.

Table 10: Window menu options

Command Function

Cascade Cascades the open windows when Options > Single Section
View is disabled.

Tile Tiles the windows horizontally when Options > Single Section
View is disabled.

Arrange Icons Aligns icons of any minimized windows at the bottom of the
program’s main window.

1 <window title>
2 <window title>
3 ... etc.

Makes the named window active, putting it on top of any
windows that had been hiding all or part of it.

Table 11 lists the options available in the Help menu.

Table 11: Help menu options

Command Function

About Multiplexer Opens a dialog box that displays the program version number.

Toolbar

Toolbars provide a set of convenient shortcuts for the more frequently used menu
options. The buttons are context sensitive and are enabled or disabled depending
upon the currently highlighted view or the action being performed.

The Toolbar can be hidden from view by selecting View > Toolbar.

Window menu options

Help menu options
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Status Bar
The Status Bar might be hidden from view, but when displayed it is always at the
bottom of the main window. For example:

Message Filter

Standard
interpretation

TS Rate TS Duration Progress

ProcessingUser mode

The following information is displayed from left to right on the Status Bar:

Message Field Provides a description of any button or menu option
over which the cursor pointer is placed. Other noncriti-
cal messages might also be shown.

Filter Status Indicates the status (On/Off) of the SI Filter.

Standard Interpretation Indicates the selected standard with which the file is pro-
cessed: MPEG-2, ATSC, DVB, or ISDB.

TS Rate & Duration Shows the transport stream rate and the duration at that
rate. A default rate is displayed during initial analysis.

User Mode Shows User mode selected: Expert or Standard. The
Standard mode prevents changes to certain fields. The
Expert mode enables editing.

Processing Status Indicates the progress (%) during initial analysis and
multiplexing.

Processing Progress Indicates the progress during initial analysis and multi-
plexing.

The Status bar can be hidden from view by selecting View > Status Bar.

NOTE. The status bar (Standard interpretation) displays ISDB--T SS whenever
the ISDB interpretation with Single segment extension is selected. Similarly,
when the Brazil Single segment is selected, the status bar displays ISDB--TB SS.
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User Interface

Title bar

Menu
bar

Toolbar

Status

Navigator area

Section area

Log View

Right--click menu

NOTE. The Menu Bar contains the complete selection of options available in the
Multiplexer. Shortcuts to options are available through the toolbar and
context-sensitive shortcut menus.
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Icons are used throughout the Multiplexer user interface to assist you to identify
components and make visual links with toolbar shortcuts and menu options.

The following table lists all the icons used.

Table 12: Icons

Icon Description Icon Description

About Multiplexer Program

Add Program Group

Audio stream Program Wizard

Bit field Properties

Close Report

Container/Loop Seamless

Copy Seamless Settings

Current selection Section

Cut Section timing

Delete Section View

Display Filter dialog box Single window

Examine Transport Stream Standard mode

Exit Start

Expert mode Stop

Export Table

Icons
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Table 12: Icons (Cont.)

Icon DescriptionIconDescription

Export As Transport Stream icon

Export Elementary Stream Transport Wizard

Export Payload Unknown

Export Section Data Video stream

Import Section Data View Event Log

Modify View Component Duration

New View Component Bit rate

Open View Available Bit Rate

Paste
Playout

Loop

Update

NOTE. The Playout, Loop and Update icons are not available in demo version.
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Table types, sections, and PIDs can be cut, copied, and pasted using the
Windows clipboard. Only one selection can be held on the clipboard at a time.
Alternatively, a selection can be dragged and dropped using the mouse.

Cutting a Selection to the Clipboard.A selection (table type, section or PID) can
be deleted and automatically placed on the Windows clipboard. It can then be
pasted to a different file or back into the current file. Highlight the selection in
the Navigator Tables or PIDs view and select Edit > Cut or use the Ctrl+X
keyboard shortcut.

Copying a Selection to the Clipboard.A selection (table type, section or PID) can
be copied to the Windows clipboard. From the clipboard, it can be pasted to a
different file or back into the current file.

Highlight the required selection in the Navigator Tables or PIDs view and then
select Edit > Copy or use the Ctrl+C keyboard shortcut.

Pasting a Selection from the Clipboard.More than one instance of Multiplexer can
run concurrently on a machine. A selection (table type, section, or PID) can be
pasted from the clipboard into any open transport stream file. The contents of the
clipboard are not affected by the paste operation, so the section can be pasted to
many files and more than once to the same file.

Activate the Navigator Tables or PIDs view of the required transport stream file
(that is, in an instance of Multiplexer). Then select Edit > Paste or use the
Ctrl+V keyboard shortcut.

The section/version is always appended to the end of the list under the appropri-
ate table. Program/version numbers are automatically created. If the table is not
present in the multiplex configuration, it will be created automatically.

Cutting and Pasting
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A concept familiar to Windows users is “drag and drop” in which files can be
highlighted by clicking on them with the mouse and then dragged and dropped to
a new location, either in the same application or across applications.

In Multiplexer, the main uses of the drag and drop feature are to modify
multiplexes and to build new ones.

Elements can be dragged within Multiplexer, or from the Multiplexer Browser,
Windows Explorer or other instances of Multiplexer.

Program references and numbering will be automatically added and/or updated
when a new program is dropped onto the Navigator Programs view.

NOTE. Only the MPEG aspects of the transport structure are updated. Tables
specific to DVB and ATSC are not updated.

Manipulation in Program view. The following manipulations are available in the
Program view:

H When using Navigator Program view, a program can be copied or dragged.
The program can be dropped only on the transport stream node of the
Program view.

H Only the standard MPEG elements are copied, namely the PAT entry, the
PMT section and the elementary streams. Standard dependent information is
not copied, for example, DVB SDT.

H Where a conflict occurs with the target, new values will be allocated for the
Program and PID numbers.

H Elementary streams can also be dragged and dropped between Program
Views. They can be dropped only onto the elementary stream root node.

H An elementary stream can have a stream type, a component tag and
descriptors associated with it; this information is retained during a drag and
drop in the program view. The program view displays this information when
the properties dialog box is activated.

Dragging and Dropping
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Wizards

In the Navigator Programs view, wizards provide you with a step-by-step
approach to building streams to be multiplexed by offering defaults for PSI/SI
and the opportunity to include user-selected programs. The standard previously
selected in the Interpretation dialog box will dictate which PSI/SI components
are offered.

There are two major wizards: the Transport Wizard and the Program Wizard.
Other minor wizards can be opened by these major wizards or they can be
opened in a new window to facilitate specific tasks, such as adding EIT
information. When configuring a new multiplex, the Transport Wizard is opened,
followed by the Program Wizard; although, on completion of the Transport
phase, an opportunity to exit the wizard process is offered before the Program
Wizard opens. For some detailed operations, only the appropriate wizard can be
opened.

At their most basic level, wizards open, in a logical order, the property dialog
boxes that are available when building a stream manually.

The following paragraphs provide a step-by-step description of the wizards.

The following control buttons are provided on the wizard dialog boxes where
relevant:

Next Retain changes made using this dialog box and
move to next dialog box.

Back Discard changes made using this dialog box and
return to the previous dialog box.

Cancel Exit the wizard and discard all changes.

Finish Exit the wizard and implement all changes.

Transport Wizard
Toolbar icon:

The Transport wizard allows you to easily create a basic stream populated with
the PSI/SI necessary to hold program information. It can also be opened when
PSI/SI is to be added to an existing stream.

Wizard Controls
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The following steps show the screens used in the creation of a DVB stream.

NOTE. When the Transport Wizard is used to populate a new stream, if the
defaults in the various dialog boxes are retained, then the resulting stream will
conform to the selected standard.

1. Open a new file; File > New.

2. Select the Program tab in the Navigator view.

3. Select and highlight the Transport Structure element; at this stage in the
creation of a new stream, this will be the only element visible in the Program
Navigator view.

4. Select Add from the shortcut menu.

Creating a New Transport
Stream
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The Transport Stream Settings dialog box allows you to set up the transport
stream identity (part of the PAT section) and version. Adjustments can also
be made to the PAT timing, if required, by selecting the PAT button.

PAT timing - see Editing PSI/SI Table Properties, page 98.

NOTE. You cannot add a PAT with the ISDB or ISDB--TB interpretation and
Single segment extension selected. When you click Add, Add a Program wizard is
displayed instead of the Transport Stream Settings.

5. Select Next to move to the Optional Tables dialog box.

6. This dialog box allows you to include, and if required, configure basic
PSI/SI information.
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As the check box next to each table is enabled, the table name is added to the
graphical representation on the left. The associated buttons are also enabled
to allow timing or other aspects of the table to be modified.

NIT, TOT, and TDT Timing - see Editing PSI/SI Table Properties, page 98
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To set up the Network Information Table (NIT), enter or select the required
values and select the OK button. Note that if a Delivery System other than
Undefined is selected, an additional settings dialog box becomes available,
specific to the Delivery System chosen.

NIT Settings
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7. Select Next to move to the Transport Wizard Complete dialog box.

This dialog box allows you to review the changes made by the wizard before
confirming the process.

The process can be cancelled, thereby losing all changes, by selecting the
Cancel button.

At this stage in the creation of a new multiplex, if you want to add programs,
leave the Add Program Wizard check box enabled and select Next. If you want
to add them by some other means, clear the Add a Program Wizard check box.
The Next button label will change to Finish, which allows you to exit the wizard
and implement all changes.

When the Transport Wizard has closed, note that the Navigator views are
updated with the new PSI/SI.
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Program Wizard
Toolbar Icon:

The Program Wizard allows you to add programs as required to a stream that is
already populated with basic PSI/SI. Each use of the Program Wizard allows the
addition of one program. Adding more programs requires the wizard to be
opened each time.

If a new stream is being created, the Transport Wizard offers an opportunity to
open the Program Wizard. Alternatively, in the Navigator Programs view,
highlight the Programs node and select Add from the shortcut menu.

To add a program to the transport stream, follow these steps:

NOTE. If, when the Program Wizard is used to add programs to a stream, the
defaults in the various dialog boxes are retained, the resulting stream will
conform to the DVB standard.

1. When you open the Program Wizard, either as a continuation of creating a
new stream or as an attempt to add a new program, a dialog box similar to
that shown below is displayed:

Adding a Program to a
Transport Stream
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The values placed automatically in the three displayed fields will be the next
in the sequence of programs. (In the example screen, the stream contains no
prior programs, hence this is program number 1. PID 32 is used because that
is the first free PID after the reserved PSI/SI PIDs.)

PMT Timing - see Editing PSI/SI Table Properties, page 98.

2. Select Next to move to the Add Service Description dialog box.

NOTE. If ISDB interpretation with Single Segment extension is selected the
program number starts from 8 (default). However, you can enter numbers from 1
to 7.

The Service Description dialog box allows you to identify the Service Provider
to be associated with a program.

3. By default, the Add Service Description check box is clear. When it is
enabled, a Service Provider Name and a Service Name must be entered and a
Service Type selected from the drop-down list. If no details are provided, the
section will still be created but the relevant descriptors will be empty.

Service Description Dialog
Box
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Enabling the Use Single Section check box will cause the SDT descriptors to
be added to the existing SDT section. If the stream contains no SDT section,
the check box is disabled.

SDT timing - see Editing PSI/SI Table Properties, page 98.

4. Select Next to move to the Program Content dialog box.

This dialog box allows you to compile a list of elementary streams to be
associated with the program in the final multiplex.

5. Select Add to display the Add Program Stream dialog box.

Program Content Dialog
Box



Multiplexer -- Wizards

44 Multiplexer (Demo) User Manual

This dialog box allows you to identify elementary streams to be included in
the new multiplex. You must specify the PID and Stream Type of the new
stream. A Component Tag can also be allocated.

If the Component Tag is enabled, it can be referenced by other tables, for
example, the Event Information Table.

The dialog box consists of three tabbed pages that specify the source of the
stream, its timing within the multiplex, and whether it should be carrying a
PCR PID.

6. Select a Stream Type from the drop-down list.



Multiplexer -- Wizards

Multiplexer (Demo) User Manual 45

This will be the Stream Type allocated to the stream in the new multiplex.

NOTE. The Stream Type drop--down list displays the previously selected stream
as the default type.

7. Allocate a PID Number in which the elementary stream is to be carried.

8. Enable the Component Tag check box, if required. Enter a Component Tag
number (0--255) in the enabled field.

Source Tab. The Source tab of the Add Program dialog box is used to select and
specify elementary streams to be included in the new multiplex.

9. Enter an elementary stream File Name. You can enter it directly or use the
Browse button to open a standard Windows file selection dialog box.

10. Select the File type of the selected stream from the drop-down list.

H If you select MPEG-2 video, the bit rate is detected automatically and
displayed in the Bit rate field.

H If you select H.264 video with SEI messages, the bit rate is detected
automatically and displayed in the Bit rate field.
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H If you select H.264 video without SEI messages, the bit rate is not
detected automatically.

H When the selected file type does not match with the selected file name,
an error message is displayed and you will have to reselect the correct
file type.

The remaining fields on this tab will be enabled or disabled depending on the
Stream Type selected. Complete the enabled fields as necessary.

11. If you select H.264 video with SEI stream, a Suppress PTS/DTS insertion
check box is displayed. The PTS/DTS insertion can be suppressed by
selecting this check box.
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Enter Bit rate for H.264 non-SEI streams.You can assign the bit rate in the
following ways:

H If you know the actual bit rate of the ES, enter the value in the Bit rate
field. Select the frame rate from Frame rate box and click Accept. The
entered bit rate will be displayed in the Bit rate field of the Source tab.

H If you want the Multiplexer to auto detect the possible bit rate, select the
Frame rate and click Detect Bit rate. A progress bar is displayed giving
the percentage of the scan completed and the bit rate is automatically
filled in the Bit rate field of the Source tab.
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You can detect the bit rate by setting the scan value in the Scan settings
dialog box. Select the options accordingly to scan the entire source file,
bytes of the source file, or percentage of the source file.
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Timing Tab. The Timing tab of the Add Program dialog box is used to specify the
portion of the new multiplex that the selected stream will use. The default start
time is set to 0.002 s.

12. Complete the fields as required. The default settings assume that the stream
is to be carried throughout the new multiplex, looping if necessary.

PCR Tab. The PCR tab of the Add Program dialog box is used to specify whether
PCR information should be carried with the selected elementary stream or in a
separate associated PID.

13. If the PCR is to be held in an associated PID, disable the Carry PCR check
box and enter a PCR PID number.

14. If the PCR is to be carried with the stream, enable the Carry PCR check box
and complete the remaining fields as required.

Set Defaults returns the settings to their initial values.
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15. Select the OK button to complete adding an elementary stream to the listing
in the Program Wizard.

16. More streams can be added using the Add button. Listed streams can be
deleted using the Delete button. Details of listed streams can be modified
using the Update button.

This completes the addition of one or more program streams.

17. Select Next to move to the Event Information dialog box.

For more details about the fields on these tabs, refer to Adding an Unreferenced
Elementary Stream, page 105.
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The Event Information dialog box allows you to add Present and Following
event information.

18. If the Event Information Table (EIT) is to be included in the multiplex,
enable the Event Information Table check box.

19. Enable the Present and Following check boxes as required.

Present/Following timing -
For more information on Present/Following timing see Editing PSI/SI Table
Properties, page 98.

Event Information Dialog
Box
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20. Use the Settings buttons to open the Present/Following Events dialog box
and add and specify events as required.

21. Select Next to move to the Program Complete dialog box.
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The Program Complete dialog box provides you with a summary of the created
Transport Structure.

22. To confirm and implement the Transport Structure, select the Finish button.
Note that the proposed structure is created in the Navigator views.

This completes the procedure of adding a program to a transport stream using the
Program Wizard.

Program Complete Dialog
Box
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Views

The Multiplexer contains a number of views, which are displayed in the working
area of the user interface. All of the views can be manipulated using convention-
al Windows techniques. The Navigator and Error Log views can be docked
against the edges of the UI or floated independently of the Multiplexer window.
The Section view can be manipulated within the Multiplexer window, including
tiling and cascading where multiple Section views are displayed.

Each available view displays a different aspect or level of detail of stream
analysis and manipulation.
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Navigator Views
The Navigator view contains three subviews or tabs: Programs, Tables, and
PIDs.

The Navigator Programs view extracts and displays system information that is
relevant to programs. Information that is not directly related to programs (for
example, NIT), or that has not been incorporated into a program (for example,
elementary streams not listed in a PMT) will be omitted from the Program view.
The system information is still available for viewing in the Navigator Tables and
PIDs views.

Manipulation of programs and elementary streams should take place from the
Program view.

Program Views
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The Tables view displays high-level structure of the Program and System
Information Protocol (PSIP), Service Information (SI), and Program Specific
Information (PSI) tables. More detailed payload information can be examined
and edited, for a selected section of a table, using the Section View.

Any PSI/SI information that the program cannot confidently analyze will be
shown in the PIDs view.

Tables View
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The PIDs view displays the PIDs contained in the stream. The PIDs are
displayed in ascending numerical order.

PSI/SI table types are identified in the section nodes of System Information
nodes.

Elementary stream PIDs are identified by source and type where possible.

PIDs View
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Section View
The Section View displays the contents of the currently selected section in any of
the Navigator views.

The Section view is dynamic in that it will be instantly refreshed if a new section
is highlighted in the Navigator view. If no section is selected, the Section view
will be blank.

The lock icon - - adjacent to certain elements of the table in the Section view
indicates that those items have restricted access due to the mode of user
operation: Expert or Standard.
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The following diagram shows a section from a Master Guide Table (MGT).

The syntax specified for an MGT in the ATSC standard A65 is:

master_guide_table_section () {
table_id
section_syntax_indicator
private_indicator
zero
section_length
table_id_extension
reserved
version_number
current_next_indicator
section_number
last_section_number
protocol_version
tables_defined
for (i=0;i<tables_defined;i++) {

Syntax of a Section



Multiplexer -- Views

Multiplexer (Demo) User Manual 61

table_type
reserved
table_type_PID
reserved
table_type_version_number
number_bytes
reserved
table_type_descriptors_length
for (k=0;k<N;k++)

descriptor()
}
reserved
descriptor tag
descriptors_length
for (I = 0;I< N;I++)

descriptor()
CRC_32

}

The terms used in this manual to describe the components, represented by nodes,
in the structure diagram are:

Container A term used to describe a node in the structure diagram
which can contain zero, one or more loops. It is analo-
gous to the for (i=0;i<loops_defined;i++) statement used
to describe the syntax of a table in the ATSC standards.
The container is always preceded by a field which speci-
fies the number of loops it contains.

Loop Describes a data structure composed of a specified set of
fields and subordinate loops. The structure diagram
shows each loop as a node with the fields and subordi-
nate loops as children. Each loop node in the section
view represents one iteration of the loop body (the con-
tents of the curly braces { }) in the syntax specified by
the ATSC standards.

Field Fields are referred to in the standards documents as both
data items and fields. They are the smallest pieces of
information that make up a table.
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For example, taking an MGT that defines three tables, the Section View
represents the syntax and contents of the Tables container like this:

Container for a
set of zero or
more

Contents
of the first
loop

Number of loops

Container

First loop

Second loop
Last loop

The loop for the first table, EIT-0 has been expanded to show the fields and
subordinate loops that it contains.
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The ATSC standard A65 defines a data structure called the Multiple String
Structure. An instance of this structure can contain zero or more strings and each
string can contain zero or more segments. The syntax specified for a Multiple
String Structure in A65 is:

multiple_string_structure () {
number_strings
for (i= 0;i< number_strings;i++) {

ISO_639_language_code
number_segments

for (j=0;j<number_segments;j++) {
compression_type

mode
number_bytes
for (k= 0;k<number_bytes;k++)

compressed_string_byte [k]
}

}
}

Using the notation of container, loop, and field nodes, Section View represents
the Multiple String Structure in the same way as any other data structure. For
example: an Extended Text Table (ETT) carries its extended_text_message in a
Multiple String Structure. The default view of a section of an ETT in the Section
View looks like this:

Section view displays a node for the extended_text_message with as much as
possible of the first segment from the first string.

Syntax of a Multiple String
Structure
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Expanding the node reveals a number_strings field which specifies the number
of strings and a container which holds them (strings):

The number_strings field shows that there are two strings in this example.
Expanding the strings container shows the loop for each string. From this it can
be seen that both strings are in English.

Expanding each of the strings reveals the number of segments (number_seg-
ments) that make up each string and a segments container. Similarly, expanding
the segments container reveals segments.
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The contents of each segment loop define what compression and character set are
used, followed by the actual text. The text is held in the compressed_string field.
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The Multiplexer has two modes of operation for conformance checking when
editing table contents. These are selected from the Multiplex menu. The checks
that affect the Navigator are:

Standard Mode Prevents changing the PID of a table whose PID number
is specified in the standard, for example, PID 0x0 carries
the PAT.

Expert Mode A warning is displayed and confirmation requested be-
fore changing the PID of a table whose PID number is
specified in the standard.

An adjacent check mark indicates the mode selected. The mode is also indicated
on the Status Bar.

Expert and Standard
Modes
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In the Section View a padlock symbol is displayed adjacent to all of the
fields that cannot be edited in the current mode. For example, the screens below
show the same tables in Standard and Expert mode.

Standard Mode Expert Mode

NOTE. The current_next_indicator in both Standard and Expert mode cannot be
edited. This is because the field is affected solely by the Section Properties
concerned with Version Timing (see Version Timing, page 100).

The selected mode is also reflected in the Wizards that are used to facilitate
creation of multiplexes. Elements that are restricted in the tables in Standard
mode will also be restricted in the relevant wizard. Similarly, elements that are
enabled in Expert mode will be enabled in the associated Wizard.

NOTE. The section view might need to be closed and reopened in order to update
the padlock icons.
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Structure Diagram Manipulation
A tree diagram, with the “root node” or highest level component at the top
represents the Transport Structure. A square box indicates components that
contain more information beneath them in the structure.

Click on the box
to show or hide
the details
under the node.

Clicking on the box does not select that node. It only shows or hides the next
level of detail under that node.

If the node has a minus sign in the box the level of detail below it is currently
displayed. The lower level(s) can be hidden by clicking the mouse pointer on the
box.

If the box contains a plus sign, there is another level in the node that is currently
hidden. Click the mouse pointer on the box to display the next level of informa-
tion under the node.

Components that are connected to a branch of the tree without a square box are
leaf nodes; the accompanying icon indicates the node type. They display the
lowest and finest level of detail available in this diagram. These are either a
Section of a Table or a PID.
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Fields in the Section view that cannot be edited directly are indicated by a

padlock symbol, . This protection can be switched off by selecting Expert
Mode from the Multiplex menu. It can be reenabled by selecting Standard Mode.

Event Log
Messages about significant events are written to the Event Log from the time a
file is first opened. The Event Log can be opened for viewing at any time during
or after the initial analysis. When the initial analysis is done, the mean transport
rate, bit rate for each PEES PID, and a Demultiplex complete message are
written in the Event Log.

The start and end times for generating a new transport stream are shown by the
Multiplexer started and Multiplexer completed messages.

Note that when demultiplexing and multiplexing streams, the bit rate at which
the demultiplex or the multiplex is performed is given in the Event Log. This is
in addition to the stream bit rate derived from the stream itself.

When synthesizing a new transport stream any errors or warnings about the new
stream are written to the Event Log between the start and completed messages.

The Category column indicates the type of event. The subject or time of the
event is shown in the Reference column and the details are given in the
Comment column.

The complete text can be copied onto the Windows clipboard, using the Copy
option from the shortcut menu. The text can also be cleared with the Clear
command. Both commands are also available from the Edit menu.
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Examine Transport Stream Window
The Examine Transport Stream (Examine TS) window (File > Examine TS)
performs two main functions within the Multiplexer:

H It allows you to take an overview of a transport stream before subjecting it to
full analysis.

H It allows tables and programs to be dragged and dropped from the examined
stream to the file that is currently open in Multiplexer.

Menu
Bar

File
Summary

Navigator
Views
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The Examine TS window menu bar contains only two items: File and Edit.

File Menu. Table 13 lists the items in the File menu.

Table 13: Examine TS - File menu options

Command Function

Open... Analyzes and opens the selected file in the Examine TS
window. Closes the current file.

Close Closes the Examine TS window.

Edit Menu. Table 14 lists the items in the Edit menu.

Table 14: Examine TS - Edit menu options

Command Function

Copy Copies the currently highlighted section to the clipboard.

These fields provide a brief summary of the analyzed file.

Filename The filename of the examined stream.

Interpretation The interpretation applied to the stream. This is the same
as that selected in the Multiplexer application through
the View menu: MPEG-2, DVB, ATSC, or ISDB.

TS Rate The transport stream bit rate derived from the stream.

Duration The duration of the transport stream.

Status The status of the stream analysis.

The Examine TS Navigator views correspond to the Navigator views in the main
application. Programs, Tables, and PIDs are shown as they would be after a full
analysis. The PSI/SI tables are expanded and collapsed in the same manner. The
Section view is not available in the Examine TS window.

Menu Bar

File Summary

Navigator Views
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While examining transport streams, it is possible to copy sections to the main
multiplex using the standard Windows techniques: copy and paste or by dragging
and dropping them with the aid of the mouse.

For example, to import a section that is visible in the Examine TS window into
the new multiplex configuration:

1. Select the Navigator Tables view.

2. Highlight the section to be copied in the Examine TS window and do one of
the following:

H Select Edit > Copy. With the Navigator Tables view active, select Edit >
Paste.

H Using the mouse, place the cursor over the highlighted section, press and
hold the left button on the mouse and drag the section onto the Navigator
Tables view. Release the mouse button.

3. Note that the copied section is placed in the PSI/SI structure at the correct
location. If any conflict arises concerning similar PID numbers, a new
version is created.

Examine TS Section Copy



Multiplexer -- Views

Multiplexer (Demo) User Manual 73

SI Filtering
Table elements can be excluded from the Navigator Tables view using the
Display Filter available through Options > Display Filter.

The following dialog box is displayed:
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Example: Before filtering, the stream tree might appear be as shown below:

In the Filter SI Display dialog box, table identities are listed in the Table Id
drop-down menu.

All sections of a table can be excluded by enabling the Exclude all table sections
check box.

To preview the result of filtering, select the Apply button.

Note that all reference to the PMT tables is removed as shown below:

Selecting a Table for
Filtering
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To exclude a range of sections, enable the section by selecting from the Table ID
drop-down list and entering the required range.

Note that section names shown in the dialog box change according to which
table is selected.

To preview the result of filtering, select the Apply button.

For example, the following settings will result in the display shown overleaf:

NOTE. Minimum and maximum values can be entered in either decimal (12345)
or hexadecimal (0xA12B) format.
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The parameters for each table must be set individually. Overall settings can be
applied individually by selecting the Apply button when a setting is made or as a
whole by making all of the settings and selecting the OK button.

To preview the result of filtering, select the Apply button. All settings can be
cleared by selecting the Clear All button.

Note that filter settings remain in force for as long as the current multiplex is
active. The settings are lost when the Multiplexer is closed unless they have been
previously saved.

The filter settings made in the Display Filter dialog box can be saved and
subsequently reapplied to the same stream or other streams.

To save the current filter settings, select the Save button and enter a name (and
location) in the Save As dialog box. To retrieve or load filter settings, select the
Load button and identify the filter file in the Open dialog box. The file extension
*.fil is used.

Saving/Loading SI Filter
Settings
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Component Views
The Component views provide a graphical view of the bit rate and duration of
the components of a stream. The management of the views has a number of
common features; these are described in the Common Features, page 83.

The Component Bit rate view provides a graphical comparison of the stream
components.

Open the Component Bit rate view either by selecting View > Component Bit
rate from the Menu Bar or the toolbar button.

Each component includes the following information: Program name, PID,
Description and the Bit rate in numerical and graphical form. Where appropriate,
the Service ID and the Service Name is displayed (extracted from the SDT).

The Component Duration view provides a graphical view of the timing and
duration of each program/component within the current stream. Adjustments can
be made to the duration of each component.

Component Bit rate

Component Duration
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Open the Component Duration view by selecting either View > Component
Duration from the Menu Bar or the toolbar button.

The following data is displayed for each component of the stream: Program,
Description, PID, Start and Stop time (in numerical and graphical form), Length
and Bit rate. The timing and bit rate elements of this information are also
available in the Program Stream Properties dialog box. (See Program Content
Dialog Box, page 43.)
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Scaling Bar. The Scaling bar, which is displayed at the top of the Component
Duration view, allows you to select the portion of the transport stream that is to
be displayed.

(After
adjustment)

(On opening)

Stream limits

Display limits

Display Limits Pointer position

Pointer

The Stream limits bar represents the full extent of the stream. The Display limits
bar (dark portion) indicates the portion of the stream that is currently displayed
in the body of the view.

The Display limits fields indicate the extents of the Display limits bar and the
current Pointer position.

The Pointer can be dragged to a new position on the Stream limits bar. The
Display limits bar will center on the Pointer.
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Duration Control. The duration of each element in the stream is given by the Start
and Stop values and shown graphically by the associated bar. The components
are color coded according to which program group they belong to.

The Start, Stop and Length values can be changed by clicking on the appropriate
field and entering the required value. The associated bar will reflect the change.

The Start, Stop and Length values can also be changed graphically by manipulat-
ing the bar. The cursor shape indicates the action that can be taken.

The changes are reflected in the associated field values.

Components can be changed individually. In addition, whole Program groups
can be changed by manipulating the Program duration bar, but only when the
view is sorted by Program.

Program duration

A vertical dotted line indicates the upper limit of the multiplexed stream.



Multiplexer -- Views

Multiplexer (Demo) User Manual 81

In the Transport Stream Properties dialog box (View > Properties with the
Transport Stream node highlighted in the Navigator Programs view), you can
determine how and if the stream duration is updated. The available options will
be:

H Select Fixed to ensure that the stream duration can only be updated in the
Stream Properties dialog box.

H Select Set to the greatest component stop time to ensure that the stream
duration is set to the greatest stop time recorded in the SI/PSI/PSIP tables.

Component start and stop times changed in the Component Duration view are
automatically updated in the SI/PSI tables.
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The Available Bit rate view displays in graphical form the available bit rate for
the duration of the multiplex.

The bit rate is calculated using the MGB2 measure (Ref: ETSI TR 101 290).
Open the Available Bit rate view by selecting View > Available Bit rate from the
Menu Bar or by using the toolbar button.

If the bit rate falls below zero, the points will be highlighted in red. When
editing a multiplex, you can add components which cause the bit rate to fall
below zero and no warnings will be displayed. However, if a transport stream is
then generated, errors will be logged and displayed in the Log view.

Use Refresh to redraw the graph. Clicking anywhere within the graph will place
a vertical cursor at that point; the position and bit rate are displayed in the Time
and Available Bit rate fields.

The zoom level and cursor placement of the Available Bit rate and the Compo-
nent Duration views can be synchronized by selecting View > Synchronize.

Available Bit rate
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Columns in the Component views can be sorted and rearranged to suit your
preferences. Column management in the two Component views is similar.

Field Selection.You can select the fields to be displayed in each Component
view. The Header bar indicates which fields are currently displayed.

When you right-click on the Header bar, a menu is displayed. You can select
which fields are to be displayed. A check mark next to a field name indicates that
the field display is currently enabled.

The version number of the PAT and PMT can be displayed in the Description
column by enabling the Show program version option in the shortcut menu from
the Description column header.

Similarly, the PID numbers can be displayed in hexadecimal, by selecting
Display in hexadecimal from the PID column shortcut menu.

Common Features



Multiplexer -- Views

84 Multiplexer (Demo) User Manual

Column Repositioning. Columns can be repositioned as required. Click and drag
the column to the required position.

Column Width. Columns can be resized as required. Place the cursor over the
dividing line between two columns; it will change to the resizing cursor. Click
and drag the column to the required width. The change will be made to the
column to the left of the cursor.

Double-clicking the column divider will automatically resize the column to the
left to the optimum size required to view the content.
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Column Sort. Columns can be sorted in ascending or descending order. Click the
cursor on the heading to sort the column. Clicking again will sort the column in
reverse order.

Similarly, the columns can be grouped in Program order, by clicking the
Program header.
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Common Menu Options
The specifications for components of the various views can be manipulated by
options from the Edit menu, View Menu, and Toolbar.

There is also a shortcut menu that provides the Add, Modify, Delete, Import,
Export and Properties options. Place the mouse pointer over the component to
change and click the right mouse button to open the menu.

A typical shortcut menu is shown here:

The menu options are context-sensitive and will be enabled or disabled
according to the current selection in the view.

The following options are available from the various shortcut menus:

Add Adds a component to the currently selected item.

Modify Opens the properties dialog box.

Delete Deletes the currently selected component.

Properties Opens a properties dialog box for editing the
currently selected item.

Export Payload Extracts and exports the payload of the source
transport stream in the form of a simple data file.

Export Elementary
Stream

Removes the transport stream and PES headers and
exports the remaining information in the form of a
simple data file.

Export Section Data Extracts and exports section data. The created file
can be imported as ES using Multiplexer’s Add
function or as SI using the Import Section Data...
option.

Import Section Data Imports SI data form a file and analyzes it. The
section is added to the Navigator view.
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Editing in the Navigator Views

Multiplexer provides a variety of ways of building and modifying transport
streams for multiplexing. In addition to the Menu Bar options and Toolbar
shortcuts built into the Multiplexer, many of the operations can be carried out
using familiar drag and drop Windows techniques.

In the following descriptions, the alternative methods for carrying out a task are
given at the head of the section, but only one method is described for each
action. Other methods for the same action often invoke the same dialog boxes
and sequence of follow-on actions.

Dragging and Dropping
To drag a file, click on its name and hold down the left button of the mouse
while dragging the file to the required location. The cursor will change according
to the background that it is dragged over:

(With Ctrl key held) when dropped, the file will
be copied.

When dropped, the file will be moved (cut and
pasted).

When dropped, no action will be taken.

Note that as the file is dragged over elements in the Navigator, receptive
elements (elements where the file can be meaningfully dropped) will be
highlighted.
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Transport Stream

For information on Opening a Stream, refer to page 17.

For information on Opening a Stream, refer to page 17.

To specify a new bit rate or duration for the transport stream, select and highlight
the Transport Structure component in the Navigator view.

From the shortcut menu, select Properties. The dialog box shown below will be
displayed.

Edit the Bit rate and the Duration as required, then click on the OK button.

Opening an MPEG File

Opening a Multiplexer File

Changing Transport
Stream Bit rate and

Duration
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Programs
The introduction of the Navigator Programs view has provided a more program-
centered means of manipulating SI/PSI. Whole programs can be added to the
multiplex and the application will update the associated tables, including the PAT
and PMT.

Note that the nodes of the tree structure in the Navigator Programs view are
context sensitive. When dragging and dropping files from either the Examine TS
window or from another instance of Multiplexer, a node will only be highlighted
as the cursor passes over it when the operation proposed is legal. There can be a
short delay before the node is highlighted, while the legality of the operation is
checked.

With the Transport Stream ID field highlighted in the Navigator Programs view,
selecting the Add option either from the shortcut menu (PAT highlighted in
Navigator Programs view) or the Menu Bar (Edit > Add) will open the Program
Wizard (see page 41).

In the Navigator Programs view, the PAT is represented by the Transport Stream
ID field.

Adding a New Program
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Methods available:

H Drag and drop (copy only) from the Examine TS window (Programs view)
to the Navigator Programs view.

H Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Programs view.

In the Navigator Programs view, programs can only be dropped onto the PAT
node.

Copying/Moving a
Program
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Tables

Methods available:

H Highlight the PSI/SI Tables level in the Navigator Tables view and select
Add from the shortcut menu.

H Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

H Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

Any Table that is defined in the selected standards, and not already present, can
be added the transport stream. To add a table to the transport stream, click on
PSI/SI Tables in the Navigator Tables view:

1. Highlight the PSI/SI Tables level and select Add from the shortcut menu.

Adding a New PSI/SI Table



Multiplexer -- Editing in the Navigator Views

92 Multiplexer (Demo) User Manual

This will open the Select dialog box. The dialog box displays a list of the
table types that are not already present in the stream.

NOTE. A PAT table cannot be added when ISDB interpretation with Single
segment extension is selected.

2. Highlight the required table type and then select the OK button.

Pressing Cancel will abandon the operation without adding a new table.

Only the table types that are not currently specified for the stream are listed.
If the required table type is not listed, press the Cancel button to close the
dialog box without affecting the specification for the stream.

The Select PID & Table ID dialog box is displayed only if a PID and/or
Table ID need to be identified. Otherwise, the selected Table type is
automatically created.
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A single section is automatically added to the newly created table type.
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Methods available:

H Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

H Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

Tables can be copied (or moved) from existing multiplexes, using either of the
available methods.

If a similar table type is already present in the multiplex, the contents of the
copied table will be integrated with it.

A table is automatically removed when the last section is deleted
(see page 102).

For more information on Exporting a Section, refer to page 103.

For more information on Importing a Section, refer to page 104.

Copying a PSI/SI Table

Deleting a PSI/SI Table

Exporting a Table

Importing a Table
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Sections

Methods available:

H Highlight the parent table level in the Navigator Tables view and select Add
from the shortcut menu.

H Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

H Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

To add a section to a table, select the parent table in the Navigator Tables view.
For example, to add a section to the SDT, select SDT Tables:

Then select Add from the shortcut menu.

The Select PID & Table ID dialog box is displayed only if a PID and/or Table ID
need to be identified. Otherwise the selected section is automatically created.

Adding a New Section to a
PSI/SI Table



Multiplexer -- Editing in the Navigator Views

96 Multiplexer (Demo) User Manual

Select the required PID and Table ID (where enabled) and press OK.

Pressing Cancel will abandon the Add operation without adding a new section.

The version/section of a table is created with a new version or section number.
The rules used by Multiplexer for numbering are:

H For tables that the selected standard dictates should always have a section
number of 0, the version number is increased by one. The new version
number is based on the version currently in the table with the most recent
number. The version_number is a 5-bit field, so if the new version would be
32, it is reset to 0.

version_numberNEW = (version_numberRECENT + 1) modulo 32

H For any table type that allows a section_syntax_indicator, the Add multiple
sections check box in the Generate subtable part of the dialog box is enabled.
Additionally, the One section per segment check box will only be enabled
for the EIT schedule table type.
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H Up to 256 sections can be added.

H Additions to existing subtables using the same Table Id Extensions and
Versions will be rejected.

H When multiple EIT Schedule sections are being added, the One section per
segment check box is enabled. When it is checked, only the first section in
each segment will be created, rather than all sections numbered between First
section and Last section.

When dragging and dropping a section, the Multiplexer will resolve any
numbering conflicts by creating new versions of duplicated tables.
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Table and Section Properties are edited by selecting and highlighting one of the
versions/sections within the transport structure and selecting the Properties
option from the shortcut menu.

This opens a dialog box with four tabs, one for each property. Depending on the
type of table, properties can be applied to a specific version or section of the
table. Multiplexer allows only operations that make sense in the context of the
selected table type.

Editing PSI/SI Table
Properties
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The properties that can be edited from the Navigator Tables view are:

PID Number. The PID tab is displayed by default when the Section Properties
dialog box is opened.

Edit the value and select OK to change the PID number.

Edit the value and select Apply to make the changes and update the other
properties (tabs) without having to close this dialog box.

Multiplexer checks the new PID number against the selected standards and warns
of any nonconformance issues. If a conflict is found, a warning message is
displayed, with the option to continue. Multiplexer also checks for conflicts with
other PIDs. If the new PID number conflicts with an existing PID, an error
message is displayed and the change is rejected; in this case, either choose a
different PID number for the table or edit the number of the PID that is currently
the owner.

If no conflict is found, another dialog box is opened to define the scope of the
changes:
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Select the required scope and click OK. Selecting Cancel will abandon the
change.

Version Timing. The Version timing tab shows the time when the version will
become current, and the start and end times. New values can be specified for any
of these times.

Start Time Specifies the time at which sections of this version
will start to appear in the transport stream.

Signalled As Current
Time

Controls the time when the sections with this
version will have the current_next_field set to 1.

By default when these sections start to appear in the
transport stream, the current_next_field of the
section set to 0. To specify a version that is always
current set the Start Time and Signaled As Current
Time fields to the same value.

Transmit until end of
transport stream

Enables the section to be repeated until the end of
the transport stream. If the check box is disabled,
the Stop Time becomes active.

Stop Time Specifies the time after which no sections of this
version will appear in the transport stream.

All of the times are in seconds, taken from the start of the transport stream file.
The default start time for PAT is 0.00 s and for PMT is 0.001 s.

Edit the values and select OK to change the timings. Edit the values and select
Apply to make the changes and update the other properties (tabs) without having
to close this dialog box.
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Subtable Timing. Service information is usually constrained to appear at regular
intervals in the transport stream. This is usually implemented as a maximum
time between appearances of all the sections of a subtable (where a table is
defined by the table_id, table_id_extension and version_number on the same
PID).

Use the Subtable Timing tab to specify the desired and the maximum acceptable
period between instances of the subtable. When an MPEG file has been opened,
this shows the mean time between instances of the subtable in the transport
stream.

Cycle Time Displays the mean time between instances of the subt-
able specified for synthesizing a new MPEG file. The
value can be edited to specify a different cycle time.

Beneath the Cycle Time, the dialog box displays subtable specific information
from the currently selected standard.

Edit the values and select OK to change the Cycle Times. Select Apply to make
the changes and update the other properties (tabs) without having to close this
dialog box.

When synthesizing a new transport stream, the multiplex engine tries to insert
the subtable at the frequency specified by the Cycle Time. An error message is
written to the event log whenever a subtable cannot be multiplexed into the
stream within the period specified by the maximum cycle time.
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Section Timing.Where a table can contain only a single section (for example,
TOT and TDT), a section timing tab is displayed in the Properties dialog box.

Start Time Specifies the time at which the first appearance of this section
will occur.

Stop Time When enabled, specifies the time at which the last ap-
pearance of this section will occur.

Transmit until end... When enabled, specifies that the section should be trans-
mitted until the end of the stream.

Cycle Time Specifies the interval at which the section should be
transmitted.

Max cycle time... Gives the cycle time recommended by the current stan-
dard.

Edit the values and select OK to change the timings. Select Apply to make the
changes and update the other properties (tabs) without having to close this dialog
box.

An error message is written to the event log when a table cannot be multiplexed
in accordance with the timings set.

A section can be deleted from a table by highlighting it in the Navigator Tables
view and selecting Delete from the shortcut menu. To delete more than one
section, select and delete each one in turn. When the last section is deleted from
a table, the table is automatically deleted from the structure.

Deleting a Section
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Section data can be exported in the form of a binary file. In the Navigator Tables
view, highlighting a Table node (for example, PMT Tables), allows all sections
of the table to be exported. Similarly, highlighting a single section entry (for
example, Program 123) allows only that section to be exported.

Highlight the required section or Table node in the Navigator Tables view. From
the shortcut menu, select Export Section Data. Name the file to be created and
choose a location. Select Save to confirm the action.

Individual sections can also be exported using the Navigator Programs view.
Highlight the required section to be exported. From the shortcut menu, select
Export Section Data. Name the file to be created and choose a location. Select
Save to confirm the action. Note that not all tables are shown in the Navigator
Programs view, for example, TOT.

Exporting a Section



Multiplexer -- Editing in the Navigator Views

104 Multiplexer (Demo) User Manual

In the Navigator Tables view, highlight the PSI/SI Table node. From the shortcut
menu, select Import Section Data. In the PID tab of the Import Section Data
dialog box, identify the PID that is to carry the information. Similarly, in the
Source tab, identify the file that holds the section data to be imported. Select OK
to confirm the selection. During the import action, the content of the file is
examined to determine where the section(s) should be placed.

ES PIDs
ES PIDs that carry additional Elementary Streams can be multiplexed into the
synthesized transport stream. The following actions are required when defining
an elementary stream to be added:

H Allocate a PID number

H Define the source of the elementary stream to be added

H Define the timing to be applied to the new stream

H Define the PCR placement

Importing a Section
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Methods available:

H Highlight the ES PIDs in the Navigator Tables view and select Add from the
shortcut menu.

H Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

H Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

To add a new stream, highlight ES PIDs in the Navigator Tables view and select
Add from the shortcut menu.

This opens the Add Stream dialog box; the Source tab is displayed by default.

Adding an Unreferenced
Elementary Stream
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Defining the PID Source. In the Add Stream dialog box, select the Source tab; this
allows the PID source to be selected and defined.

File name Enter the file name of the stream to be multiplexed.
If the file name is unknown, select Browse to open
a standard file browser dialog box and locate the file
required.

The names of files being copied to the multiplex
will be automatically filled in.

File type Select the type of file to be multiplexed from the
drop-down list box.

The following file types are available:

MPEG-1 video ES or PES
MPEG-2 video ES or PES
MPEG-2 audio ES or PES (MPEG-1 or MPEG-2)
MPEG-2 AAC audio ES or PES (ADTS format
only)
AC-3 audio ES or PES
(ES - Elementary Stream;
PES - Packetized Elementary Stream)
H.264 video ES or PES
MPEG-4 Audio ES and PES

Transport Packets: A single PID stream. The Bit rate
value will require setting. The Original TS PID will
require setting.
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Section: The content of the file will be Sections.
The sections will be in binary form. The file will
consist of one section or many sections appended
one after the other.

When multiplexed, the sections will be encoded on
the given PID as SI. If the resulting multiplex is
subsequently opened in the Multiplexer, the sections
will be interpreted as SI and displayed under the SI
Tables node in the tree.

A file generated using the Edit > Export Section
Data menu option can be used here. The Bit rate
value will require setting.

Other: Any binary or ASCII file that is to be
packetized into the transport stream at the specified
bit rate. The Bit rate value will require setting.

The remaining fields are interactive and will only be enabled when a value is
required.

Bitrate When first defining a source, the bit rate is
unknown and 0 Kbps is displayed. If a Transport
Packet Stream or an “Other” File Type is selected,
the field is enabled and a value (in Kbps) can be
entered. If MPEG-2 video or H.264 video with SEI
messages is selected, the bit rate value is detected
automatically and displayed. If H.264 video without
SEI messages is selected, the bit rate is not detected
automatically.

Original TS PID For streams other than transport streams, this field
will be blank and disabled.

Extra DTS offset When multiplexing ES or PES streams, the
Multiplexer will derive an offset between the PCR
and the decoded timestamp (DTS) of the first access
unit (video picture / audio frame).

You can override this offset and make it larger
(positive number) or smaller (negative number).
Changing this value might cause the resultant
stream to be nonconformant with respect to the
T-STD of the MPEG-2 standard. Enter the DTS
offset in seconds required.
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Stream_id Only enabled for elementary stream types. This
number specifies the value of the stream_id field in
the PES packet header.

Only needs to be set for DVB stream. Stream
identity in the PES header.

Start each field in a new
PES packet

Only enabled when File Type: MPEG-2 Video is
selected.

When disabled, both field pictures making up a
coded frame are put in a single PES packet.
Otherwise, each field picture is put into a separate
PES packet. This setting has no effect upon frame
pictures.

Start each section in a
new packet

Only enabled when File Type: Section is selected.

When disabled, SI data is placed in the packet
payloads in the most efficient manner. The start of a
section will immediately follow the end of the
previous section; no stuffing bytes will be used.

When enabled, each section will begin in a new
packet and stuffing bytes will be used to pad any
payloads that are not full.
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Defining the Stream Timing. In the Add Stream dialog box, select the Timing tab.
This tab will allow timing parameters for the selected source stream to be
defined.

NOTE. To achieve compatibility between MUX and MTS4EA, the start time is set
to the following default values: PAT is 0.000, PMT is 0.001, and ES is 0.002.

Start/Stop Time Enter the times that the selected source stream is to start
and stop within the host transport stream. Note that the
overall duration of the host transport stream is defined
through the Transport Stream Properties dialog box.

Loop Select this check box to loop the selected source stream
for the duration of the synthesis. A Loop Interval can be
set that introduces a delay between each repeat of the
source stream; if zero is entered, the source stream will
loop continuously. The Loop check box will always be
disabled for transport stream types. The Multiplexer can-
not loop transport streams.

Select OK to accept all changes and close the dialog box.
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Defining the PCR Placement. In the Add Stream dialog box select the PCR tab;
this will allow PCR placement to be defined.

PCR for Elementary Streams. (Includes File Type: Transport Packets.)
PCRs are placed in the packets at the specified interval, starting with the
specified initial value.

PCR for Remultiplexed PIDs. (Includes File Type: Transport Stream)

H If the Carry PCR check box is not enabled, any PCRs in the packets will be
removed.

H If the Carry PCR check box is enabled, PCRs will be sent as follows: If
Preserve PCR Inaccuracy is set, the PCRs from the original transport stream
will be used, otherwise the initial PCR value can be specified.

H If the Preserve PCR Intervals check box is enabled, PCRs will be sent in
those packets that originally contained them, otherwise PCRs are inserted
into packets at the specified intervals.
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Enter the PID number. A new value can be entered using either decimal or
hexadecimal notation. Values are assumed to be decimal unless preceded with
0x. The dialog box is not case sensitive and values can include zeros after the
prefix and before any significant digits.

When all details (in all tabs) are satisfactory, select OK to accept all changes and
close the dialog box.

Methods available:

H Highlight an Elementary Stream node in the Navigator Programs view and
select Add from the shortcut menu.

H Drag and drop (copy only) from the Examine TS window (Programs view)
to the Navigator Programs view.

H Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Programs view.

Specifying the PID
Number

Adding Elementary
Streams to the Program

Structure
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Elementary stream data can be added using the Navigator Programs view.

1. In the Navigator Programs view, highlight an Elementary Streams node to
which the elementary stream is to be added.

2. From the shortcut menu, select Add. The Add Program Stream dialog box is
displayed.

The dialog box tabs allows the input elementary stream to be selected and speci-
fied. The main dialog box fields Stream Type and Pid Number dictate the PID
that will carry the stream and the stream type entry that will be made in the PMT.

3. The functionality of the tabbed dialog boxes is described in the following
pages:

Source See Defining the PID Source, page 106,
Timing See Defining the Stream Timing, page 109,
PCR See Defining the PCR Placement, page 110.

4. Enable the Component Tag check box, if required. Enter a Component Tag
number (0 - 255) in the enabled field. If the Component Tag is enabled, it
can be referenced by other tables, for example, Event Information Table.
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The Export Elementary Stream option allows the nonpacketized elementary
stream data to be extracted from an elementary stream and saved to a binary file.
Note that this data will not include the transport packet or the PES packet
headers.

In the Navigator Programs view, highlight the elementary stream whose payload
is to be exported. Select the Export Elementary Stream... option from the shortcut
menu. Name the file to be created and choose a location. Select Save to confirm
the action.

The Export Payload option allows the PES packets to be extracted from an
elementary stream and saved to a binary file. This data will not include the
transport packet headers.

In the Navigator Programs view, highlight the elementary stream whose payload
is to be exported. Select the Export Payload option from the shortcut menu.
Name the file to be created and choose a location. Select Save to confirm the
action.

To modify any of the ES PID parameters, highlight the required PID in the
Navigator Tables view and select Properties from the shortcut menu. The Stream
Properties dialog box and its tabs are identical to the Add Stream dialog box.
Refer to Adding an Unreferenced Elementary Stream, page 105. Locate the
parameter to be changed, and click OK when it is changed.

ES PID parameters can also be modified in the Navigator Programs view.
Highlight an Elementary Stream in the Programs view and select Properties from
the shortcut menu. The dialog box thus displayed (Program Stream Properties) is
similar to the Add Program Stream dialog box shown on page 111.

An elementary stream can be removed from the multiplex by deleting the PID.
To delete a PID, highlight the required PID and select Delete from the shortcut
menu. Then select the Delete option from the Edit or pop-up menus. Alternative-
ly, click the delete button from the toolbar.

Multiplexer asks for confirmation before removing the PID from the multiplex.
Select Yes to delete the stream or No to abandon the operation and leave the
stream unchanged.

Exporting Elementary
Streams

Exporting PES Packets

Modifying PES PID Details

Deleting a PES PID
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DSM-CC

Methods available:

H Highlight the ES PIDs node in the Navigator Tables view and select Add
from the shortcut menu.

H Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

H Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

Adding an unreferenced DSM-CC section is similar to adding an unreferenced
elementary stream (see page 105), with the following modifications:

In the Source tab of the Add Stream dialog box, select Transport Packets /
Sections as the File type and set the bit rate.

Adding an Unreferenced
DSM-CC Section
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Methods available:

H Highlight an Elementary Stream in the Navigator Programs view and select
Add from the shortcut menu.

H Drag and drop (copy only) from the Examine TS window (Programs view)
to the Navigator Programs view.

H Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Programs view.

Adding a DSM-CC section to the program structure is similar to adding an
elementary stream to the program structure (see page 105), with the following
modifications:

H The main dialog box fields Stream Type and Pid Number dictate the PID that
will carry the stream and the stream type entry that will be made in the PMT.
The Stream Type should be set to one of the DSM-CC entries.

H In the Source tab of the Add Program Stream dialog box, identify the File
name to be added. Select Transport Packets / Sections as the Stream type and
set the bit rate.

The DSM-CC section will be added.

Adding DSM-CC Sections
to the Program Structure
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A DSM-CC section can be deleted from a table by highlighting it in the
Navigator view and selecting Delete from the shortcut menu. To delete more
than one section, select and delete each one in turn.

DSM-CC data can be exported in the form of a binary file.

Highlight the required DSM-CC section in the Navigator Tables view. From the
shortcut menu, select Export Section Data. Name the file to be created and
choose a location. Select Save to confirm the action.

Individual DSM-CC sections can also be exported using the Navigator Programs
view. Under any Elementary Streams node, highlight the DSM-CC section to be
exported. From the shortcut menu, select Export Section Data.... Name the file to
be created and choose a location. Select Save to confirm the action.

Delete a DSM-CC Section

Export a DSM-CC Section
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Editing in Section View

Use the Section View window to modify the contents of a version/section. This
includes version, section, and table-specific data that the Navigator Tables view
displays. If the Section View window it is not already open, select View >
Section View.

If a section/version is selected in the Navigator Tables view, the contents are
automatically displayed in the Section View; otherwise the Section View
window is blank.

To open a table version/section in Section View, select the component in the
Navigator Tables view. The Section View is updated immediately to show the
selected section/version.
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Editing Fields
To add, change, or delete a field, element or loop in a section/version, the parent
table must be selected in the Navigator Tables view. Highlight the appropriate
line in the Section view and select the required option from the shortcut menu.

To select a field or container, place the mouse pointer over it and click the left
button.

The magnifying glass icon indicates the selected component.

If Standard Mode is selected, the magnifying glass selection cannot be placed on
a field that is locked. To select and edit locked fields, first select the Expert
Mode option from the Multiplex menu.

Selecting a Field
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To add an element to a loop, select the parent loop that will contain it, and then
select Add from the shortcut menu. For example, to add a program to a PAT,
highlight the Programs container and select Add from the shortcut menu.

In this example, a dialog box is displayed in which the Program Number and
Program Map PID can be accepted or changed. Other table loops might not
display any dialog box, but immediately create a new element with default
contents. An entry is displayed for the new element, with its details collapsed, at
the end of the list of elements in the loop. In addition, the section length field is
automatically recalculated and amended. For the preceding example, the new
entry is program_number = 6 (0x6).

Adding an Element to
Loop
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NOTE. The preceding example was taken with Standard mode selected. In
Standard mode, all recalculation is done automatically. In Expert mode, a
program element will be added, but the program number and PID must be
manually adjusted. Similarly, the section length will need to be calculated and
amended manually (see also Expert and Standard Modes, page 66).

To delete a loop element, in the Section view, highlight the element and select
Delete from the shortcut menu.

The element is deleted and the Section View window updated to reflect the
changes.

To edit the contents of a field, highlight the field and select Modify from the
shortcut menu. This will open an appropriate dialog box for modifying the type
of data held by the field.

The following paragraphs describe the different types of data that can be
modified.

Enumerated Value. The Modify value dialog box displays the name of the field
and the current value. The value is shown as a number followed by the inter-
pretation of the governing standards.

In this figure, the field being edited is a modulation_mode and the current text is
1 (analog).

Type the number, without any text, for the required value. When the changes are
accepted, Multiplexer will display the interpretation in the Section View window.

Alternatively, click the down arrow to select the value from the drop down list.

Deleting an Element in a
Loop

Modifying the Contents of
a Field
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This displays a list of the defined values and their interpretation. The list will
vary depending upon the field being edited.

Enter the required value and select OK to continue. Multiplexer might open a
simple context-sensitive dialog box offering advice and/or asking for more
information or confirmation. An error message is displayed if the number that
was typed in requires more bits than are allocated to the field.

Date and Time. The Modify Time dialog box displays the name of the field. It
displays the time in both interpreted and raw formats; only the interpreted mode
can be edited.

Edit the numbers in any of the fields as required. All fields are updated as each
digit is added, changed or deleted. Select OK to commit the changes or Cancel to
abandon editing and keep the original time.

The Set to all ones check box, when enabled, sets the 40-bit date field to
0xFFFFFFFFF. This might be required when setting the start_date for an event
in a Near Video on Demand (NVOD) reference service.



Multiplexer -- Editing in Section View

122 Multiplexer (Demo) User Manual

Compressed String. The Modify dialog box displays the name of the field, which
is always a compressed string, and the contents of the selected string segment.
Text can be entered, deleted, selected, copied to and pasted from the Windows
clipboard.

Edit the text and select OK to continue. Select Cancel to abandon the edits and
leave the original segment unchanged. The Multiplexer checks to ensure that the
new string length does not cause the total section length to exceed the maximum
specified by the standards.

If the total section length exceeds the maximum specified by the standards, an
error message is displayed:

Select OK to return to the Modify dialog box and shorten the string.
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Text. The Modify Text dialog box displays the name of the field and the current
text on a single line. Text can be entered, deleted, copied to and pasted from the
Windows clipboard.

In the following figure, the field being edited is an ISO_639_language_code and
the current text is eng.

View Value As You can choose between viewing the text as an ASCII
character string or a hexadecimal sequence.

Most text strings have a maximum length, specified by the governing standards,
which this dialog box will enforce. Edit the text and select OK to continue.
Select Cancel to abandon the edits and leave the original text unchanged.

Numeric. The Modify dialog box displays the name of the field and the current
value in decimal. Edit the existing value or type in a new value.

In the following figure, the field being edited is a version_number and the
current value is 0xc.

A new value can be entered using either decimal or hexadecimal notation. Values
are assumed to be decimal unless preceded by 0x. The dialog box is not case
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sensitive and values might include zeros after the prefix and before any
significant digits.

Edit or replace the existing value and then select OK to continue. Select Cancel
to abandon any changes made in the field.

The Multiplexer will check the new value against the governing standards and
check for conflicts with other fields. It may open a simple context-sensitive
dialog box offering advice and/or asking for more information or confirmation.
For example: when changing a version_number, a dialog box is opened to
determine the scope of the change.
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Multiplexing Transport Streams

The Multiplex Engine in the Multiplexer synthesizes a new transport stream and
writes it to an MPEG file. The contents of the new stream are multiplexed
according to the specification currently held in memory, which is shown in the
Navigator and Section views.

The tables that are displayed in the Navigator are synthesized from the current
specification. Elementary streams and other data are acquired from the original
MPEG file and other stream files and remultiplexed according to the specifica-
tion.

Starting the Multiplex Engine
To start the Multiplex Engine, select the Start option from the Multiplex menu.
Alternatively, select the start button on the Toolbar.

Multiplexer opens a standard file browser dialog box to specify the file name and
path for the synthesized transport stream.

A new file can be created or an existing file can be selected to be overwritten.
The program will seek confirmation before overwriting an existing file.

NOTE. The Multiplexer automatically creates 188 byte packets in the transport
stream output file, regardless of the source material size.
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Errors and Reporting
The right pane of the status bar indicates progress as the Multiplex Engine
synthesizes the new transport stream.

Any errors are recorded in the Event Log, which can be opened at any time
before, during, and after processing. Here is an example where a table cannot be
multiplexed into the new stream at the specified rate.

Each table has a specification for nominal and maximum interval, in millisec-
onds, between instances of the table. These can be edited using the Navigator.
The multiplex engine will try to multiplex the table into the synthesized transport
stream at the nominal repetition rate. Errors are reported whenever packets for
any PID cannot be encoded at their specified minimum rate.

The complete text can be copied onto the Windows clipboard, using the Copy
option from the shortcut menu. The text can also be cleared with the Clear
command. Both commands are also available from the Edit menu.
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Stopping the Multiplex Engine
The Multiplex Engine can be stopped at any time while it is running. This will
abandon processing and close the file. The file will contain all of the packets
synthesized up to the time the engine was stopped.

To stop the Multiplex Engine, select Multiplex > Stop.

Alternatively, select the stop button on the Toolbar.
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Exporting the Multiplex Configuration File

NOTE. Multiplexer is used for generating both conformant and nonconformant
streams. Use the Export and Export As options to save copies of the specification
for nonconformant streams in a multiplex configuration file. This file does not
include a copy of the transport stream, instead, it refers to the original MPEG
file by name and location.

The multiplex configuration file can be reopened using the Import option
(see page 18).

Select File > Export to save any changes to the current multiplex configuration
file. Alternatively, use the Ctrl+E keyboard shortcut.

If a multiplex configuration file has not been opened, Export opens a standard
file browser dialog box to specify the file. This is the same as selecting the
Export As... option.

Export
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File > Export As exports a file with a user-specified name.

Multiplexer opens a standard file browser dialog box to select an existing file or
specify a new file.

If you are creating a new file, specify the name of the exported file and select
where it will be saved. By default, files are be created with .muxml as the file
extension.

Export As
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Make Seamless

When you loop a transport stream to simulate continuous playout, errors can be
generated at the loop point caused by discontinuities in timing information. The
Seamless option provides the opportunity of creating seamless MPEG-2 files.

The option can be set up and enabled so that all multiplex operations result in
seamless output or none.

Enabling the Seamless option
Toggle the Seamless option by selecting Multiplex > Seamless

or the toolbar button .
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Seamless Settings
Open the Seamless Settings dialog box by selecting Multiplex > Seamless
Settings.... The dialog box shown below is displayed.

First program in PAT has
priority

If this setting is enabled, the first program specified
in the PAT will be given priority in the make
seamless process.

If the setting is disabled, the priority program can be
specified in the Priority Program. The number can
be deduced by inspecting the results of the transport
stream analysis.

Priority Program
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Make PSI seamless If enabled, the service information contained in the
transport stream is processed to make it seamless.

If the setting is disabled, the PSI/SI is not processed
but simply copied to the output transport stream.

Make remaining pro-
grams seamless

If enabled, the remaining programs are made
seamless but are constrained by limits defined by
the priority program. This can lead to these
remaining programs having a gap at the beginning
and end of the file.

PSI Settings
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Reference

Abbreviations

AIT Application Information Table

ASCII American Standard Code for Information Inter-
change

ATSC Advanced Television Systems Committee

CAT Conditional Access Table (MPEG

CDT Carrier Definition Table

CVCT Cable Virtual Channel Table (ATSC)

DSM-CC Digital Storage Media - Command and Control

DTS Decoding Time Stamp

EIT Event Information Table (DVB/ATSC)

ES Elementary Stream

ETT Extended Text Table (ATSC)

MGT Master Guide Table (ATSC)

MMT Modulation Mode Table

NIT Network Information Table (DVB)

PAT Program Association Table (MPEG)

PES Packetized Elementary Stream

PID Packet IDentifier

PIT Program Information Table (ATSC)

PMT Program Map Table (MPEG)

PSI Program Specific Information (MPEG)

PSIP Program and System Information Protocol (ATSC)

PTS Presentation Time Stamp

RAID Redundant Array of Independent Disks

RRT Regional Ratings Table (ATSC)

RST Running Status Table (DVB)

SDT Service Description Table (DVB)

SEI Supplemental Enhancement Information (H.264)

SI Service Information (DVB)
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SIT Satellite Information Table

STT System Time Table (ATSC)

TDT Transponder Data Table (ATSC)

TNT Transponder Name Table

TOT Time Offset Table (DVB)

TS Transport Stream

TSTD Transport Streams Description Table

T-STD Transport Stream System Target Decoder

TVCT Terrestrial Virtual Channel Table (ATSC)

UTC Universal Coordinated Time

VCT Virtual Channel Table (ATSC)

VUI Video Usability Information (H.264)

XML Extensible Markup Language
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