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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to this product or any
products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system. Read the safety sections
of the other component manuals for warnings and cautions related to operating the system.

To Avoid Fire or Personal Injury
Connect and disconnect properly. Connect the probe output to the measurement instrument before
connecting the probe to the circuit under test. Connect the probe reference lead to the circuit under test
before connecting the probe input. Disconnect the probe input and the probe reference lead from the circuit
under test before disconnecting the probe from the measurement instrument.

Observe all terminal ratings. To avoid fire or shock hazard, observe all ratings and markings on the product.
Consult the product manual for further ratings information before making connections to the product.

Do not operate without covers. Do not operate this product with covers or panels removed.

Do not operate with suspected failures. If you suspect that there is damage to this product, have it inspected
by qualified service personnel.

Avoid exposed circuitry. Do not touch exposed connections and components when power is present.

Terms in This Manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in damage to this product
or other property.
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Introduction Using Online Help

Using Online Help
Select Help from the menu to open the help file. You can also find an electronic copy of the help file in the
Documents directory on the 063-4068-XX DVD.

Tables of Contents (TOC) tab—Organizes the Help into book-like sections. Select a book icon to open
a section; select any of the topics listed under the book.

Index tab— Enables you to scroll a list of alphabetical keywords. Select the topic of interest to bring
up the appropriate help page.

Search tab— Allows a text-based search.

Follow these steps:

1. Type the word or phrase you want to find in the search box. If the word or phrase is not found, try the
Index tab.

2. Choose a topic in the lower box, and then select the Display button.

General Help Functions
Select the Print button from the Help topics menu bar to print a topic.

To return to the previous window, select the Back button.

Use hyperlinks to jump from one topic to another.

If the Back button is grayed out or a jump is not available, choose the Help Topics button to return to
the originating help folder.

Related Documentation
In addition to TekExpress USB Online Help, the following documentation is included with the software:

DPOJET SuperSpeed (USB 3.0) Setup Library Methods of Implementation (MOI) for Verification,
Debug and Characterization, Tektronix part number 077-0266-xx.

TekExpress USB Online Help (PDF version), Tektronix part number 077-0350-XX.
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Introduction Conventions

Conventions
The online help uses the following conventions:

The term “DUT” is an abbreviation for Device Under Test.

The term “select” is a generic term that applies to the two mechanical methods of choosing an option:
using a mouse or using the touch screen.

Table 1: Icon descriptions
Icon Meaning

This icon identifies important information.

This icon identifies conditions or practices that could result in loss of data.

This icon identifies additional information that will help you use the
application more efficiently.

xxx
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Introduction Technical Support

Technical Support
Tektronix values your feedback on our products. To help us serve you better, please send us your
suggestions, ideas, or comments on your application or oscilloscope.

When you contact Tektronix Technical Support, please include the following information (be as specific as
possible):

General Information
All instrument model numbers.

Hardware options, if any.

Probes used.

Your name, company, mailing address, phone number, FAX number.

Please indicate if you would like to be contacted by Tektronix about your suggestion or comments.

Application Specific Information
Software version number.

Description of the problem such that technical support can duplicate the problem.

If possible, save the setup files for all the instruments used and the application.

If possible, save the application setup files, log.xml and status messages text file.

If possible, save the waveform on which you are performing the measurement as a .wfm file.

Forward the information to technical support using one of these methods:

E-mail – techsupport@tektronix.com

FAX – (503) 627-5695
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Getting Started What is new in this release

What is new in this release
This version of TekExpress USB provides the following feature enhancements:

LFPS Tburst & Trepeat tests.

Windows 7 Support.

New UI for toggle options using AWG/AFG/Scope.

Accessories

About the Test Fixture

For Host Testing. TF-USB3-A-P (for best signal quality) or for more mechanical flexibility use
TF-USB-B-R (with included 13 cm USB 3.0 Cable - Part number 174-5772-00). For precision De-Embed
of TF-USB3-A plug fixture, order TF-USB3-AB-KIT (includes Cal Kit).

For Device Testing. TF-USB3-A-R (includes short USB 3.0 Cable).

Supported Probes
The following probes support TekExpress USB application:

P7313 SMA differential probe

P7500 Tri-Mode probe
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Minimum System Requirements
The minimum system requirements for a PC to run the application are as follows:

Table 2: System requirements
Processor Pentium 4/M or equivalent processor.
Operating System Windows XP Service Pack 2.
Memory 512 MB of memory.
Hard Disk Approximately 2 GB of available hard-disk space for the recommended

installation, which includes full TekExpress installation and distributed
components.

Drive DVD drive
Display Super VGA resolution or higher video adapter (800x600 minimum video

resolution for small fonts or 1024x768 minimum video resolution for large fonts).
The application is best viewed at 96 dpi display settings 1.

Software TekExpress Framework (v1.4.6 or later) installed.

SigTest 3.1.30 or later installed.

DPOJET Jitter and Eye Analysis Tool (v3.4.0 or later) with Advanced Jitter
and Eye analysis (DJA option) installed.

SDLA software for Channel De-Embed for custom filter development
(optional).

Microsoft Internet Explorer 7.0 or later.

Adobe Reader 6.0 or equivalent software for viewing portable document
format (PDF) files.

Other Devices Microsoft compatible mouse or compatible pointing device.

Four USB ports (2 USB ports minimum).

PCI-GPIB or equivalent interface for instrument connectivity 2.
xxx

1 If TekExpress is running on an instrument that has a video resolution lower than 800x600 (for example, sampling oscilloscope), it is recommended
to connect a secondary monitor and this has to be enabled before launching the application.

2 If TekExpress is installed on a Tektronix oscilloscope, the virtual GPIB port cannot be used by TekExpress for communicating with oscilloscope
applications.
If external devices like USB-GPIB or equivalent are used for instrument connectivity, ensure that the Talker Listener utility is enabled in the
MSO/DPO/DSA oscilloscope's GPIB menu.
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Application Directories and Usage
TekExpress USB is installed the following directory path, depending on the Windows operating system.

For Windows 7:

C:\Program Files (x86)\Tektronix\TekExpress\TekExpress USB

For Windows XP and Windows XP-Embedded:

C:\Program Files\Tektronix\TekExpress\TekExpress USB

The application directory and associated files are organized as follows:
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The following table lists the default directory names and their usage:

Table 3: Default directory names and their usage
Directory names Usage
InstallDir\TekExpress Contains the TekExpress application and associated

files.
\TekExpress\TekExpress USB Contains files specific to TekExpress USB.
\TekExpress USB\Compliance Suites Contains compliance specific sequence files. The

folders under this directory represent the devices
to be tested.

\TekExpress USB\Compliance Suites\USB Includes the Device and Host Transmitter folders.
\TekExpress USB\Compliance Suites\USB\Device Includes the “Device Connector” folder.
\TekExpress USB\Compliance Suites\USB\Device\Device
Connector

Contains application specific files for Device.

\TekExpress USB\Compliance Suites\USB\Host Includes the “Host Connector” folder.
\TekExpress USB\Compliance Suites\USB\Host\Host Connector Contains application specific files for Host.
\TekExpress USB\ACP
\TekExpress USB\SCP
\TekExpress USB\ICP

Includes instrument and application specific
interface libraries of TekExpress.

\TekExpress USB\Data Manager
\TekExpress USB\Data Storage
\TekExpress USB\Report Generator

Includes the result management specific libraries of
TekExpress are present in these folders.

\TekExpress USB\Documents Includes the Method of Implementation documents
and technical documentation for the application.

\TekExpress USB\Bin
\TekExpress USB\Lib
\TekExpress USB\Tools

Includes the miscellaneous libraries of TekExpress.

xxx
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File Name Extensions
The software uses the following file name extensions:

File name extension Description
.TekX The session file will be saved in this format.
.seq The test sequence file.
.xml The encrypted XML file that contains the test specific configuration information. The

log file extension is also xml.
.mht This file details the test report.
.PDF The PDF file that details the method of implementation for the test.
.msk The mask file.
.flt The filter file.
.html The html file.
xxx

How To Activate the License
Follow the steps below to activate the license:

NOTE. Ensure that your TekExpress USB dongle is installed on your host system.

1. Click Help > About to view the license information.

2. Click the View Version Details link to check the version numbers of the installed test suites.

TekExpress USB Automated Solutions Help 9



Getting Started How To Activate the License

3. Click the View End-User License Agreement link to open the following Tektronix Software License
Agreement window. Click Print to print the License Agreement.

4. Click License Info to view the available software options. This window shows the license key and the
various options with their status (active or inactive) with the current license key.

5. If you are activating the license for the first time, the license key field will be empty. To activate the
license, connect the USB dongle to your computer, enter the license key provided in the license

key certificate, and click Activate. If the activation is successful, a sign is displayed next to
the license key field.
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6. If you are reactivating the license, click Reactivate, enter the new license key and click Activate.

Before You Click Run
After you first launch TekExpress, it creates the following folders on your computer:

\My Documents\My TekExpress

NOTE. Ensure that the “My TekExpress” folder has read and write access.

NOTE. If a user with a different Windows login ID launches TekExpress, a new My TekExpress folder is
created under that user's My Documents folder.

\My Documents\My TekExpress\USB.

\My Documents\My TekExpress\USB\Untitled Session. Every time the USB.exe is
launched an Untitled Session folder is created under USB folder. The Untitled Session folder
is deleted when you exit TekExpress.

CAUTION. Each session has multiple files associated with it. Do not modify any of the session files and/or
folders as this may result in loss of data or corrupted session files.

The My TekExpress folder is created as a shared folder with share name as <domain><user
ID> My TekExpress (or if the PC is not connected to domain then share name is <Computer
name><user ID> My TekExpress).
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NOTE. If the X: drive is mapped as a Local Disk and you want to map X: to a shared network location
on a PC on which TekExpress is running, you need to manually unmap the Local Disk X: using the
command (subst x: /d) from the command prompt and then manually map X: on the oscilloscope to
desired network location.

The above shared folder is mapped as X: (X drive) on the PC where TekExpress is running.

NOTE. If X drive is mapped to any other shared folder, TekExpress will display a warning message window
asking you to disconnect the X: drive manually.

Do the following before you click Run:

NOTE. Ensure that the network connectivity is enabled on the PC running TekExpress.

1. Map the shared My TekExpress folder as X: (X drive) on all the instruments used in the test setup
running Microsoft Windows Operating System. This share folder is used to save the waveform files
or any other file transfer operations.

2. Right click on the My TekExpress folder and open the Properties dialog box. Select the General tab
and then Advanced. In the Advanced Attributes window, ensure that the option Encrypt contents
to secure data is NOT selected. Click here to view the picture.

3. Ensure that all the required instruments are properly warmed up, and that Signal Path Compensation
(SPC) is performed.

Mapping My TekExpress folder
To map the My TekExpress folder on the instruments, follow the steps below:

1. Open Windows Explorer.

2. From the Windows Explorer menu, select Tools > Map Network drive.

3. Select the Drive letter as X: (if there is any previous connection on X:, disconnect it first through
Tools > Disconnect Network drive menu of Windows Explorer).

4. In the Folder field, enter remote My TekExpress folder path (for example, \\192.158.97.65\My
TekExpress).

5. You can determine the IP address of the PC where “My TekExpress” folder exists by doing
the following:

Select Start > Run menu on the PC where My TekExpress folder exists.

Enter cmd and click Enter.

At command prompt, type ipconfig.
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You can find SPC by following the steps below:

1. On the oscilloscope main menu, click Utilities menu.

2. Click Instrument Calibration option.
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Operating Basics TekExpress Application Overview

TekExpress Application Overview
TekExpress is the Tektronix Compliance Test Automation Framework, developed to support current and
future test automation needs of customers. It is a highly modular architecture that enables deploying
automated test solutions for various serial standards in a relatively short time.

The TekExpress USB application (Opt. USB-TX) is the automated version of USB3.0 measurements from
DPOJET Timing and Analysis tool. With TekExpress USB, Tektronix provides Fully-Automated Tx
solution for verification, characterization, and debug.

Key Features
The following are the key features of TekExpress USB application:

Comprehensive test coverage

Precise debugging and troubleshooting

Accurate and reliable results

Integrated Signal Test Tool (Sigtest Tool software installation is required — available from the
USB-IF.)
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Starting the Application
To start the application, you can do one of the following:

Click Start > Programs > Tektronix > TekExpress > TekExpress USB. Other applications follow
similar pattern.

Double click the icon on the desktop.

If you have previously saved a session, you can double-click the session file stored under My
TekExpress\USB.

When the application is launched it displays the splash screen providing launch information. The
application also checks for the presence and validity of the USB dongle.

NOTE. If the application was not terminated properly during the last use, a dialog box prompts to recall
the previously unsaved session.

Resizing the Application Window

To minimize the application, click on the application title bar. To restore the application to its

previous size, select in the Windows task bar.

To maximize the application, click . To restore it to previous size, click on the application
title bar.
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Exiting the Application
To exit the application, do one of the following:

Click File > Exit.

Click on the application title bar.

Global Controls
The menus and controls that appear outside the individual tabs are called “Global Controls”. These are
used to specify the devices to be tested.

Table 4: Controls and Functions
Control name Function
DUT ID The device ID is specified at the global level and the

information is stored in the default location for all data
files. This field cannot be empty and does not allow these
special characters (.,..,...,\,/:?”<>|*). The maximum length
of characters allowed is 32.
You will be able to run, pause, resume and stop the tests.

xxx
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File Menu
Click File on the application menu bar.

The File menu has the following selections:

Menu Function
New Session Starts a default session of TekExpress.
Open Session Opens a saved session.
Save Session Saves the session.
Save Session As Saves a session in a different name.
Recently Recalled Setup Lists all the recent and previously recalled setup files.
Save Report As Saves the report in user specified location.
Print Preview Report Previews the report before printing.
Print Report Opens the Windows “Print” dialog box.
Exit Closes the application.
xxx
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View Menu
Click View on the application menu bar.

The View menu has the following selections:

Menu Function
Log Opens the log (log.xml) file in the default viewer.
xxx

Tools Menu
Click Tools on the application menu bar.

The Tools menu has the following selections:

Menu Function
Instrument Bench Opens a dialog box showing the list of instruments attached to the test setup.
Email Settings (see page 21) Opens a dialog box showing e-mail setting details.
xxx

Tools > Instrument Bench
The Instrument Bench window shows the list of VISA and Non-VISA resources found on different
interfaces/connections. It serves two purposes at the launch of TekExpress:

Discovers the connected instruments.

Confirms the instrument connection setup.

When you click Tools > Instrument Bench, the following dialog box is displayed:
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Search Criteria: The various connections on which you can search. Non-VISA Resources are the
instruments that cannot be searched using TekVISA.

Retrieved Instruments: Displays the count and details of instruments that were discovered.

Last Updated: Displays the time when the last time search was performed.

TekVISA Refresh Timeout (Seconds): This time out specifies the maximum time that TekExpress
can wait for TekVISA update.

NOTE. TekExpress uses TekVISA for instrument search. Ensure that TekVISA is running on your system
before you refresh the instrument bench window.

Table 5: Retrieved Resources properties in the Instrument Bench window
Title Description
Connection Shows the type of connection with the instrument.
Resource Shows the name of the resource.
Serial Number Shows the serial number of the resource.
Options Shows the options available on the instrument. 1

Resource Address Shows IP Address/Port number of the resource.
xxx

1 The options column displays the options that fit in the field. To view complete options on the instrument, move the mouse cursor over the option.

20 TekExpress USB Automated Solutions Help



Operating Basics Tools Menu

Table 6: Button controls on Instrument Bench dialog box
Button Function
Refresh The application searches on the selected connection for resources. While searching

resources it shows the Instrument Bench discovery window. The Instrument Discovery
window shows the connection currently being scanned and the percentage of task
completed.

Close Closes the dialog box.
xxx

Tools > E-mail Settings
Use the E-mail Settings utility to configure and set the e-mail options. The following fields are mandatory
for receiving e-mail notification from TekExpress:

1. Recipient Email Addresses. For example, User@domain.com.

2. Sender's Address.

3. SMTP Server address of the Mail server configured at client location.

If any of these fields are left blank, the settings are not saved and e-mail notification will not be sent.

Select the option “E-mail Test Results When Complete or on Error” has to be checked to receive the
e-mail. The attachment list depends on what you have selected while configuring the e-mail setup.

NOTE. Among the e-mail attachments, the Analysis Screenshot is not yet functional.
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Help Menu
Click Help on the application menu bar.

The Help menu has the following selections:

Selection Function
TekExpress Help Displays TekExpress Help (F1).
About TekExpress Displays application details such as software name, version

number and copyright.
Activate License Displays available software options and also about license

activation.
xxx
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Deskew Real Time Oscilloscopes
The following procedure is used for deskewing direct input SMA channels on a real time oscilloscope.

NOTE. If you are using DPOJET, it has an automatic deskew option under Analyze > Jitter And Eye
Analysis > Deskew. Refer to your DPOJET online help on how to deskew the channels.

1. Run Signal Path Compensation (SPC) on the oscilloscope.

2. Connect a SMA Power Splitter (preferred) or SMA 50 ohm coaxial “T” connector to the Fast Edge
output of the oscilloscope.

3. Connect SMA cables from each of the two channels to be deskewed to the power splitter (or SMA
coaxial “T” connector). It is best to use matched cables when making high speed serial measurements.
It is important to use the same cables that will be used for subsequent measurements.

4. Select Default Setup, and then select Autoset on the oscilloscope front panel.

5. Set the oscilloscope for 70% to 90% full screen amplitude on both channels. Center both traces
so that they overlap.

6. Make sure that volts/div, position, and offset are identical for the two channels being deskewed.

7. Set the time/div to approximately 100 ps/div or less, with sample rate at 1 ps/pt. These settings
are not critical, but should be close.

8. Set the horizontal acquisition mode to average, which provides a more stable display.

9. Select Deskew from the Vertical menu.

10. Verify that the reference channel (typically CH1 or CH2) is set to 0 ps deskew.

11. In the deskew control window, select the channel to deskew (typically CH3 or CH4). Adjust the
deskew to overlay the rising edge as best as possible.

NOTE. Typical values are in the 10’s of ps or less with cables connected directly from Fast Edge to SMA
inputs. If you are using a switch box (for example, Keithley), deskew the complete path from where the
test fixture connects, through the switch, and into the oscilloscope. Deskew values in these cases may
be as much as 30 ps or more.

There are sometimes significant differences in the skew between two TCA-SMA adapters. If you find
that a system requires a very large correction, it might be better to find a pair of TCA-SMA adapters
that match each other better.
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Select the Test(s)
The application tests USB transmitter devices for compliance. The Select panel allows you to select tests
to configure and run.

This panel provides the following functions:

Version
USB 3.0 SuperSpeed is the default version selected.

Electrical Test Spec
0.9 is the default value for electrical test specification.

Test Method
Select DPOJET or USB-IF as appropriate for the measurement you want to run. If you select the USB-IF
option, a drop-down list appears showing the SigTest Tool software version installed currently on your
computer.

Select DUT type
Select the Device or Host as the device to be tested.
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Test Point Selection
Select the appropriate test point location. For example, Compliance[TP1] with CTLE, Connector and so on.

Probing Location
Select the appropriate probing location from where the DUT is tested. In the example screen shown, the
DUT is being tested with a test fixture at the Device Connector (Near End connection) and the Channel
Configuration being emulated is the Host's Back Panel or Front Panel.

Channel Definition
Select Hardware or Software option.

Channel Filter File Type
Select the filter file from the drop-down menu.

The Custom Filter File selection allows you to choose your own filter file.

Measurements are grouped under different categories according to standard specifications such as Tx
Informative Electrical Parameters (see page 26), Normative Speed Spectrum Clocking (see page 26), Tx
Normative Eye Mask (see page 26), and LFPS measurement (see page 26).

NOTE. If any of the measurements are grayed, you cannot make any changes.

Once you select a row, the following options are available:

Table 7: Button controls on the Select panel
Button Description

Opens the configuration panel for the selected test.

Opens the PDF file for the method of implementation (MOI) for the
selected test.

Opens the schematic for the selected test. This is useful if you want to
verify the test setup before running the test.

Selects all tests in the table.

Deselects all tests in the table.

Indicates system on low disk space.

xxx
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Tx Informative Electrical Parameters
Includes measurements such as UI-Unit Interval, VTx-Diff-PP-Differential PP Tx voltage swing,
TCDR_Slew_Max-Maximum Slew Rate, Rj-Tx-random jitter-Dual Dirac, and Mask Hits.

Normative Speed Spectrum Clocking
Includes measurements such as TSSC-Freq-Dev-Max, TSSC-Freq-Dev-Min, TSSC-Mod-Rate-SSC
Modulation rate, and TSSC USB Profile.

Tx-Normative Eye Mask
Includes measurements such as TJ-Tx total jitter-Dual Dirac at 10E-12 BER, DJ-Tx-deterministic
Jitter-Dual Dirac, Eye Height- Transmitter Eye Mask, and Width@BER.

LFPS Measurement
Includes measurements such as LFPS Duty Cycle, LFPS Fall Time, LFPS Rise Time, LFPS TPeriod,
LFPS TBurst, LFPS TRepeat, LFPS Vcm-AC, and LFPS VTx-DIFF-PP.

Configure and Run the Test(s)
The configuration panel is used to create, view, and edit the parameters associated with the acquisition and
the analysis of the selected test. In the Select panel, click Configure.

In the Configure panel, you have the following options:
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To change the parameters associated with the configuration of acquisition.

To change the parameters associated with analysis configuration.

NOTE. You can select different filter files under Filter Selection option for different test suites.

The upper part of the Configure panel has general parameters that are common for all the tests under
the selected test suite that are editable.

Select the appropriate instrument.

Select the Probing Configuration (see page 29).

Select an appropriate parameter for “CP0–CP1 Toggle using” (AWG/AFG/Scope/Do Not Use).

Select to enable Pattern type validation. Selecting Yes enables the process of validating that each test
pattern is correct. Selecting No skips the test pattern validation.

The lower part of the Configure panel has test specific parameters.

NOTE. If any of the test parameters are grayed, it means that these parameters cannot be modified in the
compliance mode. When you switch to the user defined mode, these parameters are editable.

Table 8: Test parameters
Parameters to configure Description
Acquire Shows the various parameters

related to acquisition of a selected
test. These parameters can vary
from one test to another.

Analyze Shows the various parameters
related to analysis of a selected test.
The Analyze parameters shows the
default analysis parameters for the
selected test.
Refer to:
Using NonStandard Waveform
Mask
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Table 8: Test parameters (cont.)

Parameters to configure Description
Limits Applies to a specific test. It shows

the measurement limits using
different types of comparisons.

Comments You can specify a comment up to
256 characters long for the selected
test.

Compliance settings
Restores the default settings.

Saves all changes made in the
Configuration Panel and closes the
dialog box.
Closes the dialog box and without
apply changes.

xxx

Click Run in the Select panel to run the selected tests.

Refer to the following table for different test limit comparisons:

Table 9: Different test limit comparisons
Comparison string Description
EQ(==) Equal to
NE(!=) Not equal to
GT(>) Greater than
LT(<) Less than
GE(>=) Greater than or Equal to
LE(<=) Less than or Equal to
GTLT(> <) Greater than and Less than
GELE(>= <=) Greater than or equal to and Less than or equal to
GELT(>= <) Greater than or equal to and Less than
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Table 9: Different test limit comparisons (cont.)

Comparison string Description
GTLE(> <=) Greater than and Less or equal to
LTGT(< >) Less than and Greater than
LEGE(<= >=) Less than or equal to and Greater than or equal to
LEGT(<= >) Less than or equal to and Greater than
LTGE(< >=) Less than and Greater than or equal to
xxx

Using Reference Waveforms
If you want to use an existing reference waveform from your storage location for analysis and run,
click Probing Configuration field to select the different waveforms for example, ref1, or ref1-ref2
and so on from the drop-down list.

View and Select Connected Instruments

Viewing Connected Instruments
The Tools > Instrument Bench menu item is used to discover connected instruments required for the
tests. The application uses TekVISA to discover the connected instruments. Once the search is done, the
Instrument Bench dialog box resumes operation and lists the instrument-related details based on the
selected search criteria.

NOTE. When the TekVISA Instrument Manager checks for connected instruments, the Instrument Bench
dialog box does not respond.
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For example, if you select LAN and GPIB as the search criteria in the Instrument Bench dialog box and
click Refresh, the TekVISA Instrument Manager checks for the instruments available over LAN and GPIB
and the details of the instrument are displayed in the Retrieved Instruments table.

You can provide the time in the TekVISA Timeout (Seconds) field, within which if the TekVISA
Instrument Manager does not find the instruments, the TekExpress application resumes operation.

If you choose Non-VISA resources, all the instruments supported by TekExpress but not communicating
over the VISA layer can be searched.

Selecting Connected Instruments
You can view the instruments connected in the Configuration panel. The upper part of the panel displays
the general parameters for the tests under the selected test suite.
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NOTE. The list of instruments displayed is specific to the selected test suite. It does not show all the
connected instruments.

Use the Prerecorded Waveform for Analysis
From the Acquire tab, you can see unique acquisitions, acquisition parameters, acquisition status, and
prerecorded waveform files of the selected test suite. The Acquire panel is specific to a suite and is updated
every time the selected test suite is changed. This panel shows the acquisition details for the tests in the
currently selected suite. The tests with the common acquisition parameters are grouped together and
shown as a single acquisition.

Column name Function
Status Test acquisition status of the running test passed at intervals.
Test Name of the tests performing acquisitions. One or more tests can perform

the same acquisitions.
Acquisition Acquisition name
Waveform File(s) Prerecorded waveform files of unique acquisitions. You can select waveform

files by selecting browse on individual cells. This allows you to select any
waveform file using the standard file open window.

xxx
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The following Acquire source options are available:

Use Pre-Recorded Waveform files: Enabling or disabling the option shows or hides the waveform
file column in the acquisition table. When you save a session and then select this option, the DUT
ID text box changes to a drop-down list, in which you can select the DUT ID up to the point where
the session was saved. A drop-down box appears above the Waveform file column, showing the run
details, including the date and time of each run. If you select a run, corresponding data for that run will
be populated (such as the selected test, the test configuration settings, and the test summary status).

NOTE. If you want to select the waveform files manually, you need to select all the waveform (.wfm)
files required for the measurement. To select multiple files, hold down the Ctrl key to enable selecting
multiple files in the File Open dialog screen. If any required files are not selected, the measurement
may not run properly.

Acquire Step by Step: Selecting this option prompts you at the end of each acquisition before
proceeding to the next one.

Show Acquire Parameters: On enabling this option, the acquisition parameters for each unique
acquisition are displayed in the acquisition table.

When you select “Use Pre-Recorded Waveform Files”, the first column shows the waveform type and the
second column shows the tests that use that waveform type for analysis.
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View the Progress of Analysis
You can view the progress of the analysis in the Analyze panel. As the analysis of each test is complete,
the result value is updated.

Analysis Table
The table contains the following:

The test name.

The status of the tests that are being run.

The measured, limit and margin values of the tests.

The tests that are not yet started are shown with a “To be Started” status. A summarized status of the
currently running test is shown on the Status Messages panel.

The Status Messages window timestamps all runtime messages and displays them. You can do the
following:

Display Status: Enable/Disable status messages.

Auto Scroll: Scrolls status messages automatically.

Clear All: Clear all status messages in Status Window.

Save Status: Save all status messages in text file. Displays a standard save file window and saves the
status messages in the user specified file.

NOTE. The Status Messages window is dockable and can be resized.
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View the Report
After the analysis, a report is automatically generated and displayed in the report panel. The report shows
the results of the tests, including device information and pass/fail status of each test. The following screen
is an example report of a test run using only DPOJET software.

The Report View Area contains an mht report. You can select any area of the report and copy it to the
clipboard to make it available to other application.
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View Test Related Files
All the test related files for currently selected tests are always saved under My Documents\My

TekExpress\USB\Untitled Session.

When you save a session, it is saved with the session name under the path My Documents\My

TekExpress\USB\SessionName for future references.

The session that is currently running will be stored in the same path as “Untitled Session” until you save it.

WARNING. Do not save a session named “Untitled Session” or “Backup” because there are
application-specific files and are deleted when you exit the application.

A session folder can contain results for more than one DUT, and a DUT folder can contain more than one
run data folder marked by date-time stamp as folder name.

Here is an example image of data storage:

Select and Run a Test Using SigTest Software
Select and run a test using the USB-IF software. The steps are same as running a test using the DPOJET
software. Refer to How To Select the Tests (see page 24).

1. Select the USB-IF option in the Select Panel. Under Test Method, browse to the latest version of
USB-IF installed on your machine. Click Run.

NOTE. If you have not installed USB-IF software (SigTest) on your instrument/PC, the Test method option
is disabled.
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2. While running, the application automatically switches to the Acquire tab and displays the status of
acquisition.

3. The Analyze tab displays the Measured, High and Low limit values.
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4. A SigTest tool pop-up appears which shows that the application is using SigTest as the test method to
perform the analysis.

5. During test execution, once the analysis is completed, SigTest application automatically closes and
generates a report with the details. Click USB-IF Report link on the TekExpress Report tab to view
the report location. Double-click the .html file to view the test report.

NOTE. Results shown in the TekExpress report tab are results from DPOJET.
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Use Filters

Using the Nonstandard Filter
The following procedure explains how to select and enter any filter file in the configuration panel.

1. Click the Channel Filter File Type option in the Select panel and select Custom Filter File option
from the drop-down menu.

2. Click Browse to view the location of filter files from where you can choose from. Select the file
and click Open.
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Filter files to be used for de-embdding the fixture are:

— DeEmbedDeviceFixture8GEmbedBackChannelFLTCTLE.flt

— DeEmbedDeviceFixture8GEmbedChannelCable12-5GCTLE.flt

— DeEmbedDeviceFixture8GEmbedFrontChannelCableFLTCTLE.flt

— DeEmbedHostFixture8GEmbedChannelCable12-5GCTLENEW.flt

The remaining filter files are for embedding the fixture.

NOTE. The filter files are located in the TekExpress Filters folder.

For Microsoft Windows 7, the Filters folder file path is:

C:\Program Files (x86)\Tektronix\TekExpress\TekExpress USB\Setupfiles\Filters

For Microsoft Windows XP or Windows XP Embedded, the Filters folder file path is:

C:\Program Files\Tektronix\TekExpress\TekExpress USB\Setupfiles\Filters
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Using the Nonstandard Waveform Mask
If you want to use a nonstandard mask file, follow this procedure:

1. Select the Mask Hits test in the Select panel and click Configure.

2. Click the Analyze tab in the Configure panel.

3. Enter the mask file name in the Analyze tab of the Configuration panel as shown. Click Save.

NOTE. The mask files are located in the TekExpress Masks folder.

For Microsoft Windows 7, the Masks folder file path is:

C:\Program Files (x86)\Tektronix\TekExpress\TekExpress USB\Setupfiles\Masks

For Microsoft Windows XP or Windows XP Embedded, the Masks folder file path is:

C:\Program Files\Tektronix\TekExpress\TekExpress USB\Setupfiles\Masks

CP0-CP1 Toggle Using Mechanisms

Scope Based Toggle
To use the oscilloscope based toggle, follow this procedure.

NOTE. Scope based toggle is not guaranteed to work for all DUTs.
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1. In the configuration panel, for the parameter CP0-CP1 Toggle using, select an oscilloscope (E.g.
DPO72004 (TCPIP::192.158.96.152::INSTR)).

2. Connect the AUX OUT from the oscilloscope to the USB 3.0 Device Fixture 2 RX+ and connect a
USB cable from USB 3.0 Device Fixture 2 to Device fixture 1.

3. Click the Run button. If the CP1 measurements are selected, then when the CP1 pattern is being
acquired, a pop up displays to prompt you to make the necessary connections. Select to either skip the
pattern or make a new acquisition after the DUT is transmitting CP1.

4. If you select OK (Acquire Now), a new acquisition is done. If Pattern Type validation is set to Yes,
a Pattern Type validation is done on the acquired signal to check if it is a CP1 signal. If it is a CP1
signal, the measurements proceed normally. If not, the following pop up displays.

NOTE. If Pattern type validation is set to No, then the measurement proceeds with the acquired waveform.
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5. Choose how to proceed.

■ Select OK (Acquire now) to start the acquisition again.

■ Select Continue Anyway to cause the measurements to proceed with acquired waveform.

■ Select Skip Pattern to skip all CP1 tests. The rest of the selected measurements proceed. If CP1 is
skipped and CP0 is aquired, TJ and RJ will be computed on CP0 for informational purposes.

AWG Based Toggle
To use the arbitrary waveform generator (AWG) based toggle, follow this procedure.

1. In the configuration panel, for the parameter CP0-CP1 Toggle using, select an AWG (E.g. AWG7122C
(TCPIP::192.158.96.152::INSTR)).

2. Connect the interleave (analog and analog) output of Ch1 of the AWG to the USB 3.0 Device Fixture
2 (RX+ and RX-) and connect a USB cable from the USB 3.0 Device Fixture 2 to USB 3.0 Device
fixture 1.

3. Click the Run button. If the CP1 measurements are selected, then when the CP1 pattern is being
acquired, a command is sent to the AWG to send a trigger to toggle the DUT from CP0 to CP1.
Next, the waveform is acquired. If Pattern type validation is set to Yes, then the validation is done.
If the pattern is valid, the measurement proceeds normally. If the pattern is not valid, the following
pop up displays.
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NOTE. If Pattern type validation is set to No, then the measurement proceeds with the acquired waveform.

4. If you select Toggle Pattern, then the toggle sequence is initiated again to toggle the DUT. (The
pop up remains displayed during this toggle process.) You can visually verify whether the acquired
pattern is correct. If not, keep clicking the Toggle Pattern button until the desired pattern is acquired.
Once the desired pattern is acquired, select OK (Acquire now) to save the waveform and proceed
with the measurement.

5. At any time, you can select Continue Anyway to proceed with current acquired waveform. You can
also select Skip pattern to skip the CP1 acquisition and proceed with rest of selected measurements.

AFG Based Toggle
To use the arbitrary function generator (AFG) based toggle, follow this procedure.

1. In the configuration panel, for the parameter CP0-CP1 Toggle using, select an AFG (E.g. AFG3102
(TCPIP::192.158.96.152::INSTR)).

2. Connect Ch1 of the AFG to the Device fixture 2 (RX+) and connect a 3 meter USB cable from Device
fixture 2 to Device fixture 1.

3. Click the Run button. If the CP1 measurements are selected, then when the CP1 pattern is being
acquired, a command is sent to AFG to send a trigger to toggle the DUT from CP0 to CP1. Next, the
pattern is acquired. If Pattern type validation is set to Yes, then the validation is done. If the pattern is
valid, the measurement proceeds normally. If the pattern is not valid, the following pop up displays.
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NOTE. If Pattern type validation is set to No, then the measurement proceeds with the acquired waveform.

4. If you select Toggle Pattern, then the toggle sequence is initiated again to toggle the DUT. (The
pop up remains displayed during this toggle process.) You can visually verify whether the acquired
pattern is proper. If not, keep clicking the Toggle Pattern button until the desired pattern is acquired.
Once the desired pattern is acquired, select OK (Acquire now) to save the waveform and proceed
with the measurement.

5. At any time, you can select Continue Anyway to proceed with current acquired waveform. You can
also click Skip pattern to skip the CP1 acquisition and proceed with rest of selected measurements.

No Toggle
To not use the toggle tool, follow this procedure.

1. In the configuration panel, for the parameter CP0-CP1 Toggle using, set to Do not use.

2. The following pop up is displayed just before acquiring the CP0/CP1 pattern to allow you to manually
transmit the desired pattern and acquire the waveform.
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3. Click OK to acquire the waveform. If Pattern type validation is set to Yes, a pattern type validation is
done on the acquired signal. If it is a valid pattern, the measurement proceeds normally.

If it is not a valid CP1 pattern, the following pop up displays.

If it is not a valid CP0 pattern, the following pop up displays.
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NOTE. If Pattern type validation is set to No, then the measurement proceeds with the acquired waveform.

4. Choose how to proceed.

■ Select OK (Acquire now) to start the acquisition again.

■ Select Continue Anyway to cause the measurements to proceed with acquired waveform.

■ Select Skip Pattern to skip all CP0-CP1 tests. The rest of the selected measurements proceed.
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LFPS Pattern Type Validation
When the Pattern type validation is set to Yes, during the acquisition of LFPS pattern, a validation is
done. If the pattern is valid, the measurement proceeds normally. If the pattern is invalid, the following
pop up displays.

NOTE. If Pattern type validation is selected as “No”, then the measurement proceeds with the acquired
waveform.

Choose how to proceed.
■ Select OK (Acquire now) to start the acquisition again.
■ Select Continue Anyway to cause the measurements to proceed with acquired waveform.
■ Select Skip Pattern to skip all LFPS tests. The rest of the selected measurements proceed.
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CP0 Pattern Type Validation
When the Pattern type validation is set to Yes, during the acquisition of a CP0 pattern, a validation is
done. If the pattern is valid, the measurement proceeds normally. If the pattern is invalid, the following
pop up displays.

NOTE. If Pattern type validation is selected as “No”, then the measurement proceeds with the acquired
waveform.

Choose how to proceed.
■ Select OK (Acquire now) to start the acquisition again.
■ Select Continue Anyway to cause the measurements to proceed with acquired waveform.
■ Select Skip Pattern to skip all CP0 tests. The rest of the selected measurements proceed.

CP1 Pattern Type Validation
Refer to the section CP0-CP1 Toggle Mechanisms (see page 40).

48 TekExpress USB Automated Solutions Help



Application Examples Mask Testing on a Device with a Hardware Channel

Mask Testing on a Device with a Hardware Channel
The following procedure discusses how to use TekExpress to test a Device with a hardware channel using
USB-IF as the test method. For the required equipment and setup diagram click here.

NOTE. USB compliance testing is done by using software to emulate the channel and cable when Channel
Definition is set to Software mode. When Hardware mode is selected, the same testing is performed
with a physical channel.

1. Select Device as the DUT type.

2. Choose Compliance[TP1] with CTLE as your test point location.

3. Select the USB3_CTLE.flt as the required channel filter file type. This applies the USB-IF compliant
file to open the eye before the measurements are taken.

4. Select TX Normative Electrical Parameters as the test to be run.

5. Click Configure to configure the test parameters. Note that Configure panel will be Compliance
Mode only.

6. You can configure any test to help you analyze measurement results. To refer to the DPOJET
SuperSpeed (USB 3.0) Setup Library Methods of Implementation (MOI) document for information on
how to configure the Deterministic Jitter test, click Show MOI in the Select panel.

7. Click Close to close the dialog box.
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8. Click Run in the Select panel to run the selected test.

9. The Acquire panel shows the status of the waveform acquisition. To know more about the Acquire
panel, click here.

10. The Analyze tab displays the Measured, High and Low limit values and a SigTest tool pop-up appears.
The Analyze tab shows the DPOJET results, not the SigTest re sults.

NOTE. For toggling from CP0 to CP1, refer to section CP0-CP1 Toggle Using Mechanisms (see page 40).

11. After the tests complete, the application prompts you to save the session. Unless the session is saved,
the report is not generated.
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12. Once the session is saved, click USB-IF Report link on the TekExpress report tab to view the report
location. Double-click the .html file to view the test report.

The html report looks like the screen below.
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Set Up the Equipment
You need the following equipment:

Table 10: Required equipment
Resource Model supported
Real-time oscilloscope Tektronix MSO/DPO/DSA71254 Series. Also MSO/DPO/DSA70804 Series

is suitable for Normative measurements.
A minimum of 12 GHz bandwidth is required for compliance testing.

Probes Two TCS-SMA or one P7300SMA/P7500 differential probe.
Test Fixture TF-USB3-KIT (includes short USB 3.0 cable) or USB-IF fixtures 1.
AWG/AFG (optional) AWG7102 (v3.3), AWG7122 Series (v4.1.1.5), with options 6,8.

AFG3252, AFG3251, AFG3102, AFG3101.
xxx

1 Available through USB-IF.
Connect the equipment as shown in the following diagram:

NOTE. The VBUS on the device fixture is typically powered from an external power supply, not from
the AWG.
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Testing Deterministic Jitter on a Device Back Panel
The following procedure discusses how to use TekExpress to test the Device back panel.

1. Select Device as the DUT type.

2. Select Device Connector (Through Back Panel) as the probing location.

3. Select Compliance[TP1] with CTLE as the test point.

4. Select DJ-Tx deterministic Jitter-Dual Dirac as the test to be run.

5. Click Configure to configure the test parameters.

6. You can configure any test to help you analyze measurement results. To refer to the DPOJET
SuperSpeed (USB 3.0) Setup Library Methods of Implementation (MOI) document for information on
how to configure the Deterministic Jitter test, click Show MOI in the Select panel.

7. Once you change the parameters, click Apply to apply the new settings for the selected test. If you
want to restore the default settings, click Restore.

Click Close to close the dialog box.
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8. Click Run in the Select panel to run the selected test.

9. The Acquire panel shows the status of the waveform acquisition. To know more about the Acquire
panel, click here.

10. The Analyze tab displays the Measured, High, and Low limit values.
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11. After the tests complete, a report is generated and displayed in the Report panel.

NOTE. For toggling from CP0 to CP1, refer to section CP0-CP1 Toggle Using Mechanisms (see page 40).

You can save the report using the File > Save Report As option. The following dialog box is displayed.
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If CP1 is skipped, then the measurements RJ and TJ are done on CP0 for information only.
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About the Programmatic Interface
The Programmatic interface allows you to seamlessly integrate the TekExpress test automation application
with the high-level automation layer. This also allows you to control the state of TekExpress application
running on a local or a remote PC. The following operations can be performed using the programmatic
interface exposed by TekExpress:

(see page 68) Query DUT ID

(see page 69) Set DUT ID

(see page 70) SaveSession

(see page 72) RecallSession

(see page 73) Run the TekExpress execution

(see page 74) Stop the TekExpress execution

(see page 76) Transfer result files

(see page 77) Check the application status

NOTE. The programmatic interface is not available for the following pop-up screens:

— Scope as Toggle Tool (User Action Required, two button pop-up for CP1)

— AWG as Toggle Tool (Invalid Signal, four button pop-up)

— AWG as Toggle Tool (Invalid Signal, four button pop-up)

For simplifying the descriptions, the following terminologies are used in this section:

TekExpress Client: A high level automation application that communicates with TekExpress using
TekExpress Programmatic Interface.

TekExpress Server: The TekExpress application when being controlled by TekExpress Client.

TekExpress leverages .Net Marshalling to enable the Programmatic Interface for TekExpress Client.
TekExpress provides a client library for TekExpress clients to use the programmatic interface. The
TekExpress client library is inherited from .Net MarshalByRef class to provide the proxy object for the
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clients. The TekExpress client library maintains a reference to the TekExpress Server and this reference
allows the client to control the server state.

Click the following links to get details on them:

What does one need to have to develop TekExpress Client ?

While developing TekExpress Client one needs to use the TekExpressClient.dll. The client can be a VB
.Net, C# .Net, TestStand, or a web application. The examples for interfaces in each of these applications
are in Samples folder.

References required
TekExpressClient.dll has internal reference to IIdlglib.dll and IRemoteInterface.dll IIdlglib.dll has a
reference to TekDotNetLib.dll. IRemoteInterface.dll provides the interfaces required to perform the remote
automations. It is an interface that forms the communication line between the server and the client.
IIdlglib.dll provides the methods to generate and direct the secondary dialog messages at the client-end.

NOTE. The end-user client application does not need any reference to above mentioned DLL files. It is
essential to have these DLLs (IRemoteInterface.dll, IIdlglib.dll and TekDotNetLib.dll) in same folder
location as that of TekExpressClient.dll.

What steps does a client need to follow ?

The following are the steps that a client needs to follow to use the TekExpressClient.dll to programmatically
control the server:

A client UI has to be developed to access the interfaces exposed through the server. This client needs to
load TekExpressClient.dll to access the interfaces. Once the TekExpressClient.dll is loaded, the
client UI can call the specific functions to run the operations requested by the client. Once the client is up
and running, it has to do the following to run a remote operation:

1. The client needs to provide the IP address of the PC at which the server is running in order to connect
to the server.
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2. The client needs to lock the server application to avoid conflict with any other Client that may try to
control the server simultaneously. “Lock” would also disable all user controls on server so that server
state cannot be changed by manual operation.

3. If any other client tries to access a server which is locked, it will get a notification that the server
is locked by another client.

4. When the client has connected to and locked the server, the client can access any of the programmatic
controls to run the remote automations.

5. Once the client operations are completed, the server needs to be “unlocked” by the client.

Server and Client Proxy Objects

Remote Proxy Object
The server exposes a remote object to let the remote client access and perform the server side operations
remotely. The proxy object is instantiated and exposed at the server-end through marshalling.

The following is an example:

RemotingConfiguration.RegisterWellKnownServiceType (typeof (TekExpressRe-

moteInterface), “TekExpress Remote interface”, WellKnownObjectMode.Singleton);

This object lets the remote client access the interfaces exposed at the server side. The client gets the
reference to this object when the client gets connected to the server.

For example,

//Get a reference to the remote object

remoteObject = (IRemoteInterface)Activator.GetObject(typeof(IRemoteInterface),

URL.ToString());
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Client Proxy Object
Client exposes a proxy object to receive certain information.

For example,

//Register the client proxy object

WellKnownServiceTypeEntry[] e = RemotingConfiguration.GetRegisteredWell-

KnownServiceTypes();

clientInterface = new ClientInterface();

RemotingConfiguration.RegisterWellKnownServiceType(typeof(ClientInterface),

“Remote Client Interface”, WellKnownObjectMode.Singleton);

//Expose the client proxy object through marshalling

RemotingServices.Marshal(clientInterface, "Remote Client Interface");

The client proxy object is used for the following:

1. To get the secondary dialog messages from the server.

2. To get the file transfer commands from the server while transferring the report.

Click here to see examples.

clientObject.clientIntf.DisplayDialog(caption, msg,iconType, btnType);

clientObject.clientIntf.TransferBytes(buffer, read, fileLength);
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To know more on the topics below, click the links.

Secondary Dialog Message Handling

The secondary dialog messages from the Secondary Dialog library are redirected to the client-end when a
client is performing the automations at the remote end.

In the secondary dialog library, the assembly that is calling for the dialog box to be displayed is checked
and if a remote connection is detected, the messages are directed to the remote end.

File Transfer Events

When the client requests the transfer of the report, the server reads the report and transfers the file by
calling the file transfer methods at the client-end.

Connect()

Connect(string ipAddress, IRemoteClientInterface clientIntf, out string clientID)
This method connects the client to the server. The client provides the ip address of the server to connect to
the server. The server provides a unique clientId when the client is connected to it.
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Parameters

Name Type Direction Description
ipAddress String IN The ip address of the server to which the client is

trying to connect to. This is required to establish
the connection between the server and the client.

clientIntf String IN Is the handle of the remote object interface
clientid String OUT Identifier of the client that is connected to the

server.
clientId = unique number + ipaddress of the
client. For example, 1065–192.157.98.70

xxx

Return Value
Value that suggests the status if the connection was established or an error occurred. The return value is an
object that can be a boolean value, returning true or a string, returning the error message.

Example
try {

IPAddress[] hostIPAddr = Dns.GetHostAddresses(Dns.GetHostName());

// Connect to the remoter Server

remoteObject.Connect(hostIPAddress, clientInterface, out clientID);

return true;

}

catch (Exception error)

{

return error;

}

Comments
The server has to be active and running for the client to connect to the server. Any number of clients can
be connected to the server at a time. Each client will get a unique id.
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Disconnect()

Disconnect(string id)
This method disconnects the client from the server it is connected to.

Parameters

Name Type Direction Description
id String IN Identifier of the client that is performing

the remote function.
xxx

Return Value
Integer value that suggests the status of the operation after it has been performed.

1 – Success

–1 – Failure

Example
try

{

string returnVal = UnlockServer (clientId);

remoteObject.Disconnect (clientId);

return 1;

}

Comments
When the client is disconnected, it is unlocked from the server and then disconnected. The id is reused.
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LockSession()

LockSession(string id)
This method locks the server. The client has to call this method before running any of the remote
automations. The server can be locked by only one client.

Parameters

Name Type Direction Description
id String IN Identifier of the client that is performing

the remote function.
xxx

Return Value
String value that suggests the status of the operation after it has been performed.

Example
if (locked)

return “Session has already been locked!”;

returnVal = remoteObject.LockSession(clientId);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

{

locked = true;

return “Session Locked...”;

}

Comments
When the client tries to lock a server that is locked by another client, the client gets a notification that the
server is already locked and it has to wait until the server is unlocked.

If the client locks the server and is idle for a certain amount of time then the server is unlocked
automatically from that client.
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UnlockSession()

UnlockSession(string id)
This method unlocks the server from the client. The client id of the client to be unlocked has to be provided.

Parameters

Name Type Direction Description
id string IN Identifier of the client that is performing

the remote function.
xxx

Return Value
String that suggests the status of the operation after it has been performed.

Example
returnVal = remoteObject.UnlockSession(clientId);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

{

locked = false;

return “Session Un-Locked...”;

}

Comments
When the client is disconnected, it is automatically unlocked.
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GetDutId()

GetDutId(string id, string dutId)
This method gives the DUT id of the current set-up.

Parameters

Name Type Direction Description
id string IN Identifier of the client that is performing

the remote function.
dutId string OUT The DUT id of the set-up.
xxx

Return Value
String that gives the timeout period (in seconds) of the client.

Example
returnVal = remoteObject.GetDutId(clientId, out id);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

{

return id;

}

else

return CommandFailed(returnVal);

Comments
The dutId is an OUT parameter whose value is set after the server processes the request.
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ChangeDutId()

ChangeDutId(string id, string dutName)
This method changes the DUT id of the set-up. The client has to provide a valid DUT id.

Parameters

Name Type Direction Description
id string IN Identifier of the client that is performing

the remote function.
dutName string IN The new DUT id of the set-up.
xxx

Return Value
String that suggests the status of the operation after it has been performed.

Example
If (dut Id.Length <=0 && locked == true)

return “Enter a valid DUT-ID”;

returnVal = remoteObject.ChangeDutId(clientId, dutId);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “DUT Id Changed...”;

else

return CommandFailed(returnVal);

Comments
If the dutName parameter is null, the client is prompted to provide a valid DUT id.
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SaveSession()

SaveSession(string id, string name)
Saves the current session. The name of the session is provided by the client.

Parameters

Name Type Direction Description
id string IN Identifier of the client that is performing

the remote function.
name string IN The name of the session being saved.
xxx

Return Value
String that suggests the status of the operation after it has been performed.

Example
returnVal = remoteObject.SaveSession(clientId,sessionName);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Session Saved...”;

else

return CommandFailed(returnVal);

Comments
The name parameter cannot be empty. If it is empty, the client is prompted to provide a valid name.

Once the session is saved under ‘name’ you cannot use this method to save the session in a different name.
Instead SaveSessionAs can be used.
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SaveSessionAs()

SaveSessionAs(string id, string name)
Saves the current session in a different name every time this method is called. The name of the session is
provided by the client.

Parameters

Name Type Direction Description
id string IN Identifier of the client that is performing

the remote function.
name string IN The name of the session being saved.
xxx

Return Value
String that suggests the status of the operation after it has been performed.

Example
returnVal = remoteObject.SaveSessionAs(clientId,sessionName);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Session Saved...”;

else

return CommandFailed(returnVal);

Comments
The same session is saved under different names using this method. The name parameter cannot be empty.
If it is empty, the client is prompted to provide a valid name.
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RecallSession()

RecallSession(string id, string name)
Recalls a saved session. The name of the session is provided by the client.

Parameters

Name Type Direction Description
id string IN Identifier of the client that is performing

the remote function.
name string IN The name of the session being recalled.
xxx

Return Value
String that suggests the status of the operation after it has been performed.

Example
returnVal = remoteObject.RecallSession(clientId,sessionName);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Session Recalled...”;

else

return CommandFailed(returnVal);

Comments
The name parameter cannot be empty. If it is empty, the client is prompted to provide a valid name.
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Run()

Run(string id)
Runs the setup. Once the server is set up and is configured, it can be run remotely using this function.

Parameters

Name Type Direction Description
id string IN Identifier of the client that is performing

the remote function.
xxx

Return Value
String that suggests the status of the operation after it has been performed.

Example
returnVal = remoteObject.Run(clientId);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Run started...”;

else

return CommandFailed(returnVal);

Comments
When the run is performed the status of the run is updated periodically using a timer.
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Stop()

Stop(string id)
Stops the run operation.

Parameters

Name Type Direction Description
id string IN Identifier of the client that is performing

the remote function.
xxx

Return Value
String that suggests the status of the operation after it has been performed.

Example
returnVal = remoteObject.Stop(clientId);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Stopped...”;

else

return CommandFailed(returnVal);

Comments
When the session is stopped the client is prompted to stop the session and is stopped at the consent.
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Status()

Status(string id, out string[] status)
This method gives the status of the run as messages. The status messages are generated once the run
is started.

Parameters

Name Type Direction Description
id string IN Identifier of the client that is performing

the remote function.
status string array OUT The list of status messages generated

during run.
xxx

Return Value
String that suggests the status of the operation after it has been performed.

Example
returnVal = remoteObject.QueryStatus(clientId, out statusMessages);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Status updated...”;

else

return CommandFailed(returnVal);

Comments
The status messages are updated periodically after the run begins. The status is an out parameter which is
set when the server processes the request.
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TransferReport()

TransferReport(string id)
This method transfers the report generated after the run. The report contains the summary of the run. The
client has to provide the location where the report is to be saved at the client-end.

Parameters

Name Type Direction Description
id string IN Identifier of the client that is performing

the remote function.
xxx

Return Value
String that suggests the status of the operation after it has been performed.

Example
returnVal = remoteObject.TransferReport(clientId);

if ((OP_STATUS)returnVal == OP_STATUS.SUCCESS)

return “Transferred...”;

else

return CommandFailed(returnVal);

Comments
If the client does not provide the location to save the report, the report is saved at C:\ProgramFiles.
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ApplicationStatus()

ApplicationStatus(string id)
This method gets the status (ready, running, paused) of the server application.

Parameters

Name Type Direction Description
Id string IN Identifier of the client that is performing

the remote function.
xxx

Return Value
String value that gives the status of the server application.

Example
returnVal = remoteObject.ApplicationStatus(clientId);

return returnVal;

Comments
The application can be in one of the following states at a given time:

Ready – Test configured and ready to start

Running – Test running

Paused – Test paused
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Select Panel Parameters
Parameters Default Value Options/Range Example

Select DUT
Type

Device, Host SelectDevice(clientId, device, true);

Select Test SelectTest(clientId, device, devicesuite,
"UI-Unit Interval", boolSelect);

Version List from
available
versions

SetGeneralParameter(clientId, device,
devicesuite, "", "Version$Compliance (TP1)
without CTLE")

Probing
Location

List from
available probing
locations

SetGeneralParameter(clientId, device,
devicesuite, "", "Probing Location$TP1
(Through Back Panel)")

Channel
Definition

Software,
Hardware

SetGeneralParameter(clientId,
device, devicesuite, "", "Channel
Definition$Software")

Test Tool DPOJET,
USB-IF, Both

SetGeneralParameter(clientId, device,
devicesuite, "", "Test Tool$USB-IF")

Channel
Filter File
Type

List from the filter
files available
with the software

SetGeneralParameter(clientId, device,
devicesuite, "", "Channel Filter File
Type$Custom Filter File")

Select
parameters
from Select
Panel

Custom Filter
File

List from
available user
defined filter files

SetGeneralParameter(clientId, device,
devicesuite, "", " Custom Filter
File$USB4_Cable.flt ")

Real Time
Scope

<Instrument
Address>

List from
Instrument
discovery

SetInstrument(clientId, device,
devicesuite, "UI-Unit Interval", "
AnalyzeInstrument$Real Time Scope$
DPO71254C (GPIB0::1::INSTR )")

Instrument
Configuration

Signal
Generator

<Instrument
Address>

List from
Instrument
discovery

SetInstrument(clientId, device,
devicesuite, "UI-Unit Interval",
"AnalyzeInstrument$Signal
Generator$AWG7122B (GPIB0::2::INSTR
)");

Probing
Configuration

List from
available probing
locations

SetGeneralParameter(clientId,
device, devicesuite, "", "Probing
Configuration$Differential (Ch1)")

Record
Length

500 – 10000000 SetGeneralParameter(clientId, device,
devicesuite, "", "Record Length$7000");

Selecting
general
parameters
from
Configuration
panel

CP0 SetAcquireParameter(clientId, device,
devicesuite, "UI-Unit Interval", "CP0$NA$7")

xxx
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Error Codes
The return value of the remote automations at the server-end is OP_STATUS which is changed to a string
value depending on its code and returned to the client.

The values of OP_STATUS are as follows:

Value Code Description
FAIL −1 The operation failed.
SUCCESS 1 The operation succeeded.
NOTFOUND 2 Server not found
LOCKED 3 The server is locked by another client, so operation cannot

be performed.
UNLOCK 4 The server is not locked. Lock the server before performing

the operation.
NULL 0 Nothing
xxx
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Example
The following is an example for NI TestStand Client available in the following path.

For Windows 7 — C:\Program Files (x86)\Tektronix\TekExpress\TekExpress

USB\Examples\Programmatic Interface\TestStand.

For Windows XP and XP Embedded — C:\Program Files\Tektronix\TekExpress\TekExpress

USB\Examples\Programmatic Interface\TestStand
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Instrument Connectivity
If the instrument(s) are displayed in TekVISA Instrument Manager but not in the TekExpress Instrument
Bench, check the following:

Only those instruments that respond to *idn? and *opt? queries successfully, are displayed in
Instrument Bench.

Ensure that VXI-11 Server is running on the instruments.

If Instrument initialization fails during test sequence execution, do the following:

It is observed that GPIB communication with instrument over Tek-VISA layer is not initialized if in
TekVISA Instrument manager the search criteria is turned-off, even if a valid instrument is connected in
the network. It is necessary to turn ON the respective search criteria by opening the TekVISA Instrument
manager.

TestStand Run time Engine Installation
Managing multiple versions of TestStand installed on the system.

TekExpress installs TestStand version 4.2.1 runtime engine. If you have other versions, ensure that the
version shipped with TekExpress is active while working with TekExpress. You can do so by clicking
Start > Programs > National Instruments > TestStand 4.2.1 > TestStand Version Selector.
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Reference Shortcut Keys

Shortcut Keys
The following table lists the short cut keys to access the application:

Table 11: Keyboard shortcut keys
Menu Shortcut keys
File Alt + F
New Session Ctrl + N
Open Session... Ctrl + O
Save Session... Ctrl + S
Save Session As Alt + F + A
Save Report As... Alt + F + R
Print Preview Report Alt + F + V
Print Report... Ctrl + P
Exit Ctrl + X
View Alt + V
Log Ctrl + L
Tools Alt + T
Instrument Bench Ctrl + I
E-mail settings Ctrl + E
Help Alt + H
TekExpress Help (F1) Alt + H + H
About TekExpress Alt + H + A
Activate License Alt + H + L
xxx
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Index

A
About menu, 22
About TekExpress, 15
Acquire options, 32
Acquire parameters, 27
Acquire Parameters, 32
Acquire tab, 31
acquisition table, 32
acquisitions, 31
Activating license, 9
AFG Based Toggle, 43
Analyze parameters, 27
Application

exiting, 17
resizing, 16
starting, 16

Application overview, 15
Application summary, 15
AWG Based Toggle, 42

B
Before clicking Run, 11

C
Client, 59
Compliance mode, 26
Configure button, 25
Controlling the Server, 60
CP0 Pattern Type, 48
CP0-CP1 Toggle, 40
CP1 Pattern Type, 48

D
Data storage, 35
Default directory usage, 7
Deskew

real time oscilloscopes, 23
Deterministic Jitter test, 54
Directory structure, 7
Dongle, 9
DPOJET, 6
DUT type, 24

E
E-mail Configuration, 21
E-mail Settings, 21
Exit, 18
Exiting the application, 17

F
File name extensions, 9
Filter selection, 38
Filters, 38

G
General parameters, 27
Global Controls, 17

I
Instrument bench, 19
Instrument Bench menu, 29
Instrument discovery, 30
Instrument initialization, 81
Interface, 59
Interface commands

ChangeDutId, 69
Connect, 63
Disconnect, 65
GetDutId, 68
LockSession, 66
Recall Session, 72
Run, 73
SaveSession, 70
SaveSessionAs, 71
Status, 75
Stop, 74
Transfer report, 76
UnlockSession, 67

Interface error codes, 79

K
Key features, 15

L
LFPS Pattern Type, 47
Log file, 19

M
Mapping My TekExpress

folder, 12
Masks, 40
Menus

File, 18
Help, 22
Tools, 19
View, 19

Minimum System Require-
ments, 6

My TekExpress, 35
My TekExpress folder, 11

N
No Toggle, 44
Non VISA resources, 20
Nonstandard waveform mask, 40

P
Parameters to configure, 26
Prerecorded Waveform, 31
Probes, 5
Programmatic interface, 59
Progress of analysis, 33
Proxy object

client, 62
remote, 61

R
Recipient Address, 21
Report

preview, 18
print, 18
save, 18

Report panel overview, 34
Required equipment, 53
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Resizing the application, 16
Retrieved instruments, 20
Run, 11

Run button, 17
Run button, 17

S
Safety Summary, v
Save

report, 18
session, 18

Scope Based Toggle, 40
SDLA software, 6
Selecting connected

instruments, 30
Server, 59
Session

new, 18
open, 18
save, 18

Session folder, 35
Set up diagram, 53
Shortcut keys, 83
Show MOI button, 25

Show schematic button, 25
Signal Path Compensation

(SPC), 12
SMA Breakout Fixture, 5
SMTP Server address, 21
Software version, 22
Starting the application, 16
Supported Probes, 5
System requirements, 6

T
Technical support, 3
TekVISA instrument manager, 29
Test

configure, 26
report, 34
select, 24

Test limits, 28
Test method

DPOJET, 24
USB-IF, 24

Test parameters, 27
Test point, 25
Test point selection, 25

Test related files, 35
TestStand client example, 80
Toggle

AFG based, 43
AWG based, 42
No toggle, 44
Scope based, 40

Troubleshooting
instrument connectivity, 81
TestStand Run-time Engine

installation, 81

U
Untitled session, 11
USB devices, 24
User defined filter file, 38
User defined mode, 26
Using filters, 38

V
View scorecard, 34
Viewing connected

instruments, 29
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