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General Safety Summary

General Safety Summary
Review the following safety precautions to avoid injury and prevent damage to this product or any products connected to it.

To avoid potential hazards, use this product only as specified.

Only qualified personnel should perform service procedures.

While using this product, you may need to access other parts of a larger system. Read the safety sections of the other
component manuals for warnings and cautions related to operating the system.

To Avoid Fire or Personal Injury
Use proper power cord. Use only the power cord specified for this product and certified for the country of use.

Use proper voltage setting. Before applying power, ensure that the line selector is in the proper position for the
source being used.

Connect and disconnect properly. Do not connect or disconnect probes or test leads while they are connected
to a voltage source.

Ground the product. This product is indirectly grounded through the grounding conductor of the mainframe power cord.
To avoid electric shock, the grounding conductor must be connected to earth ground. Before making connections to the input
or output terminals of the product, ensure that the product is properly grounded.

Observe all terminal ratings. To avoid fire or shock hazard, observe all ratings and markings on the product. Consult the
product manual for further ratings information before making connections to the product.

The inputs are not rated for connection to mains or Category II, III, or IV circuits.

Do not apply a potential to any terminal, including the common terminal, that exceeds the maximum rating of that terminal.

Power disconnect. The power cord disconnects the product from the power source. Do not block the power cord; it
must remain accessible to the user at all times.

Do not operate without covers. Do not operate this product with covers or panels removed.

Do not operate with suspected failures. If you suspect that there is damage to this product, have it inspected by
qualified service personnel.

Avoid exposed circuitry. Do not touch exposed connections and components when power is present.

Use proper AC adapter. Use only the AC adapter specified for this product.

Do not operate in wet/damp conditions.

Do not operate in an explosive atmosphere.

Keep product surfaces clean and dry.
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General Safety Summary

Terms in This Manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in damage to this product or other property.

Symbols and Terms on the Product
These terms may appear on the product:

DANGER indicates an injury hazard immediately accessible as you read the marking.

WARNING indicates an injury hazard not immediately accessible as you read the marking.

CAUTION indicates a hazard to property including the product.

The following symbol(s) may appear on the product:

iv TekExpress HEAC Quick Start User Manual



Compliance Information

Compliance Information
This section lists the environmental standards with which the instrument complies.

Environmental Considerations
This section provides information about the environmental impact of the product.

Product End-of-Life Handling
Observe the following guidelines when recycling an instrument or component:

Equipment Recycling. Production of this equipment required the extraction and use of natural resources. The
equipment may contain substances that could be harmful to the environment or human health if improperly handled at the
product’s end of life. In order to avoid release of such substances into the environment and to reduce the use of natural
resources, we encourage you to recycle this product in an appropriate system that will ensure that most of the materials are
reused or recycled appropriately.

This symbol indicates that this product complies with the applicable European Union requirements according
to Directives 2002/96/EC and 2006/66/EC on waste electrical and electronic equipment (WEEE) and
batteries. For information about recycling options, check the Support/Service section of the Tektronix Web
site (www.tektronix.com).

Restriction of Hazardous Substances
This product has been classified as Monitoring and Control equipment, and is outside the scope of the 2002/95/EC RoHS
Directive.
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Preface

Preface
TekExpress is the Tektronix Compliance Test Automation Framework, developed to support current and future test
automation needs of customers. Developed using National Instruments’ TestStand, TekExpress leverages on the capabilities
of the Microsoft .NET framework. TekExpress HEAC provides a test and compliance solution that address the needs
of the of HDMI 1.4 and CTS 1.4 standards.

Key Features
The application provides the following features:

Reliable testing

Conformance to HDMI 1.4 (HEAC) standards and test specifications CTS 1.4 ensures reliable results

Accurate Transmitter (Tx) and Receiver (Rx) testing and violation testing ensures reliable tests

Sophisticated measurement techniques eliminate errors in jitter measurements

Closed loop measurements eliminate non-linearities of test setup enables precise testing

Significantly reduced test times for Sink and Audio tests

Optimal setups ensure accurate results

Fast testing

Remote control of signal sources automates Source and Sink tests and reduces test times

One-button selection of multiple tests ensures faster testing

Automatic mask fit, measurements, and Pass/Fail notification delivers quick results

Test margins and statistical information aid analysis to help find answers quickly

One-button CSV-format summary and MHT report saves time

Complete testing

Wide range of tests for Source and Sink devices enables complete validation

Complete compliance solution with a test fixture and signal sources
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Preface

Documentation
This manual describes the basic installation and operation of the TekExpress application. For more detailed information, see
the online help. The following information is available for this product:

Table i: Related documentation
TekExpress HEAC Online Help, English 076-0191-xx

TekExpress HEAC User Manual, English (PDF)
TekExpress HEAC Quick Start User Manual,
English (PDF)

077-0388-xx
077-0389-xx

Software Upgrades
Periodic software upgrades may become available. To check for upgrades:

Go to the Tektronix Web site (www.tektronix.com/software).

Enter the product name (TekExpress HEAC).
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Install the Software

Install the Software
The TekExpress application must be installed on a computer or on a Tektronix oscilloscope.

Before Installation
Read the Readme.txt file provided with the product software.

Prerequisites
The product software installer automatically installs all the necessary software and components needed to run the
TekExpress HEAC solution. The following are the prerequisites:

Microsoft .NET Framework

National Instruments TestStand Runtime Engine

OpenChoice TekVISA

DK2 DESKey Driver

TekExpress Framework

Installation
1. Close all applications.

2. Download HEACWebinstaller_<version>.EXE.

3. Double-click the executable to extract the files. After extraction, the HEAC installer launches and the software is installed
in C:\Program Files\Tektronix\TekExpress\TekExpress HEAC.

4. Download the executables: HEAC_AudioRX_Patterns_AWG5K.EXE and HEAC_AudioRX_Pat-

terns_AWG7K.EXE.

5. Double-click the executables to extract the files. The audio patterns are extracted to C:\HEAC Patterns.

TekExpress HEAC Quick Start User Manual 1



Install the Software

Required Test Equipment
Each test suite requires specific equipment setups. Click Show Schematic within the select pane to see how to connect the
device under test and test equipment to your oscilloscope.

The following Tektronix test fixtures are required, depending on the tests that you will be running:

TF-HEAC-TPA-KIT consisting of:

TF-HEAC-TPA-MAIN

TF-HEAC-TPA-AP

TF-HEAC-TPA-CP

TF-HEAC-TDR-AR (2 numbers)

TF-HEAC-TDR-CR (2 numbers)

TF-HDMI-TPA-CE (EDID board) consisting of:

EDID fixture PCBA

EEPROM with HDMI 1.4 software

Ribbon cable

TF-HDMID-TPA-KIT (required for HEAC testing of Type D devices) consisting of:

Plug assembly

Receptacle cable assembly (2 numbers)

The following arbitrary waveform generators are required for running common mode receiver tests:

Tektronix AWG5000 Series or AWG5000B Series

Tektronix AWG7000 Series or AWG7000B Series

Start the Software
To start the software, do one of the following:

From the Start menu, select Start > Programs > Tektronix > TekExpress > TekExpress HEAC.

Double-click on the desktop.

Close the Software
To close the software, do one of the following:

Select File > Exit.

Click .
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Use the TekExpress Software

Use the TekExpress Software

Process Flow
Follow steps 1 through 11 to select and run a test to check for compliance. Details for each of these actions are given on
the following pages.

1. Set up the switches on the HEAC-TPA-MAIN fixture.

2. Set up the jumpers on the HEAC-TPA-MAIN fixture.

3. Select a device.

4. Select the test suite and choose the version.

5. Select the test.

6. Configure the test parameters.

7. View and select connected instruments.

8. Run the test.

9. View the progress of acquisition.

10. View the progress of analysis.

11. View and print the generated report.
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Set Up the Switches on the HEAC-TPA-MAIN Fixture
The following diagram shows the fixture configuration switches on the HEAC-TPA-MAIN fixture.

The following table shows the settings to configure on the HEAC-TPA-MAIN fixture.

Table 1: HEAC-TPA-MAIN switch setup

Test ID Description DUT
+5 V
from S1 S2 S3 S4 S7

Source J6, J8 Right Right Right Left Right5-1 Differential Mode
Operating DC Sink J8 Left Left Left Right Left

Source J6 Right Right Right Right Right5-2 to 5-5 Differential Mode
Transmitter Sink J8 Left Left Left Right Left

5-6 to 5-10 Common Mode
Transmitter

Sink J8 Left Left Left Right Left

5-11 to 5-15 Single Mode
Transmitter

Sink J8 Left Left Left Right Left

Source J6 Right Right Right Right Right5-16 Differential Mode
Receiver Sink J8 Left Left Left Right Left

5-17 Common Mode
Receiver

Source J6 Right Right Right Right Right
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Use the TekExpress Software

Table 1: HEAC-TPA-MAIN switch setup (cont.)

Test ID Description DUT
+5 V
from S1 S2 S3 S4 S7

5-18 Single Mode
Receiver

Source J6, J8 Right Right Right Left Right

5-19 Common Mode
Operating DC

Source J6, J8 Right Right Right Left Right

5-20 Single Mode
Operating DC

Source J6, J8 Right Right Right Left Right

Set Up the Jumpers on the HEAC-TPA-MAIN Fixture
The following table shows the jumper settings to configure on the HEAC-TPA-MAIN fixture.

Table 2: HEAC-TPA-MAIN jumper setup

Test ID Description
Termi-
nation

Signal Source
output
impedance JP1 JP2 JP3 JP4

5-1 to 5-5 Differential Mode
Transmitter

50 Ω - ON OFF ON OFF

5-6 to 5-10 Common Mode
Transmitter

50 Ω - ON OFF ON OFF

5-11 to 5-15 Single Mode
Transmitter

55 Ω - OFF OFF OFF OFF

110 Ω OFF OFF OFF OFF
100 Ω ON OFF ON OFF

5-16 Differential Mode
Receiver

-

90 Ω ON ON ON ON
5-17 to 5-19 Common Mode

Receiver
- 50 Ω ON OFF ON OFF

5-18 to 5-20 Single Mode
Receiver

- 55 Ω OFF OFF OFF OFF
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Select a Device, Test Suite, and Test
1. Click the Select tab.

2. Select a Device type.

3. Select the Test Suite.

4. Choose the version of the selected test
suite from the Version drop-down list.

5. Select the test to run. You can select
multiple tests from the list.

6. Click Select All to select all the tests in
the list.

7. Click Deselect All to disable the tests.

8. Click Show Schematic to see the
schematic diagram of the test setup.

Configure the Test Parameters
1. Click the test name to configure.

2. Click Configure.

3. If multiple instruments are connected,
choose the correct instrument from the
drop-down list in the parameter-value list.

4. Verify schematic-related parameters
such as DUT HEAC Signal connected to
Real Time Scope at and others. You can
also change other parameters such as
Minimum signal threshold.

5. The Compliance Mode is selected by
default. You can generally use the
default settings in Compliance Mode.
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Use the TekExpress Software

6. Click the Acquire tab to view parameters
related to acquisition.

7. Click the Analyze tab to view the test
analysis parameters.

8. Click the Limits tab to view the
measurement limits.
See the online help for various test limit
comparisons.

9. Click the Comments tab to enter
test-specific comments.

10. Click Apply.

11. Click Close.

NOTE. Use the File menu to save the
session.
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Connect and Configure the Equipment
The equipment connection is given in detail in the Application Examples section of this document. (See page 10, Application
Examples.)

You can click Show Schematic to display a diagram of the test setup for each of the test suites.

Run the Test

1. Enter the ID of the Device to be tested
in the DUT ID field.

2. Click Run to run the test.

3. Click the Acquire tab to view the
waveform acquisition details for the tests
in the currently selected test suite.

4. Click the Analyze tab when the tests are
running to view the status and progress
of the tests. The application checks to
see if the device has passed the test.
The Status Messages window time
stamps all runtime messages and
displays them.

8 TekExpress HEAC Quick Start User Manual



Use the TekExpress Software

Interpret the Test Result
When the test completes, the report summary appears. Check the report to see if the device passed the test.

1. The report displays the DUT ID, the date
and time the test was run, and execution
time.

2. Test information like the Device Type,
Version, Execution Time, Compliance
Mode (Yes or No), and Overall Test
Result (Pass or Fail), MAC Address (in
case of Receiver tests) are shown.

3. Instrument information like the models,
serial numbers, and firmware/software
versions are shown.

4. A table displays the Test Name,
Measurement Details, Limit1 and Limit2,
CRC Status, CRC Details, Test Result,
Compliance Mode, Analysis Time, and
Comments.

Generate, Save, and Print a Report
After you have successfully run one or more test(s), a report summary is generated in MHT format.

To save the report summary in the desired location, select File > Save Report As.

To preview the report before printing, select File > Print Preview Report. Select File > Print Report.
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Application Examples

Differential Mode Transmitter Tests
Required equipment Model supported
Real-time oscilloscope Tektronix DPO7000 Series, DPO70000 Series, DPO70000B

Series, DSA70000 Series, DSA70000B Series, and
MSO70000 Series Digital and Mixed Signal Oscilloscopes

Probe Tektronix P6247, P6248, P6330, or P7330 for a
DPO70000 Series, DPO70000B Series, DSA70000 Series,
DPO70000B, and MSO70000 Series Digital and Mixed
Signal Oscilloscope
Tektronix P6330, TDP1000, TDP1500,, or TDP3500 for a
Tektronix DPO7000 Series Digital Oscilloscope

Test fixture TF-HEAC-TPA-P (A/C) or TF-HEAC-TPA-KIT,
TF-HDMID-TPA-KIT

50 Ω SMA Terminators Any terminator that meets the following requirements:

50 Ω impedance ± 1% or better

Connects directly to the SMA female connector
DUT An HEAC sink or source device
SMA Cables Tektronix part number 174-1428-00 (1.5 meter)

Tektronix part number 174-1341-00 (1 meter)
HDMI Cable HDMI cable with HEAC capability

This tests the DUT for compliance with differential mode transmitter tests.
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1. Connect the DUT to the equipment as shown.

NOTE. This equipment setup diagram and connections are the same for all differential transmitter tests except the
Operating DC Voltage test.

Connect the CEC or CDC Controller to the CEC/CDC Control Port on the HEAC-TPA main board.

Connect the HEAC-TPA plug board to the HEAC connector on the Source/Sink DUT.

Connect the 50 Ω SMA terminators to the HEAC-TPA main board.

Connect a differential probe to the HEAC± differential signal probe point on the HEAC-TPA main board.

If you are testing a Sink DUT, set the HEAC-TPA main board to enable the Sink DUT test. Set switch S7 position to the
left (Off position) on the HEAC-TPA adapter.
If you are testing a Source DUT, set the HEAC-TPA main board to enable the Source DUT test. Activate +4 V bias using
the +5 V power from the Source DUT. Set switch S7 to the right (On position) on the HEAC-TPA main fixture.

Activate the HEC transmission on the HEAC Source/Sink DUT using CEC/CDC controller.
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2. Select HEAC-Transmitter as the device
type.
By default, the Differential-Tx is selected
as the Test Suite.
The default version CTS 1.4.
All the differential mode transmitter tests,
except the Template test, are selected
by default.

NOTE. The Template test is an informative
test and not a part of the CTS 1.4.

3. Enter the DUT identification in the DUT
ID field.

4. Click Show Schematic to display a
diagram of the test setup and confirm
that your test setup is correct.

5. Click Configure to open the
Configuration panel.

6. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. To change acquisition parameter
values, click User Defined Mode. A
message appears prompting you that if you
make changes to a test, the test may no
longer be compliant. Click OK to proceed
with the User Defined Mode.

7. Click Close.

8. Click Run in the Select panel.
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9. Click the Analyze tab to view test
analysis results.

10. The application displays the status of the
tests in the Status Messages window.
Click Save Status to save the status
messages.

11. When the tests complete, the application
shows a report in the Report panel.
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Differential Mode Operating DC Voltage Test (Transmitter)
Required equipment Model supported
Real-time oscilloscope Tektronix DPO7000 Series, DPO70000 Series, DPO70000B

Series, DSA70000 Series, DSA70000B Series, and
MSO70000 Series Digital and Mixed Signal Oscilloscopes

Probe Tektronix P6247, P6248, P6330, or P7330 for a
DPO70000 Series, DPO70000B Series, DSA70000 Series,
DPO70000B, and MSO70000 Series Digital and Mixed
Signal Oscilloscope
Tektronix P6330, TDP1000, TDP1500, or TDP3500 for a
Tektronix DPO7000 Series Digital Oscilloscope

Test fixture TF-HEAC-TPA-P (A/C) or TF-HEAC-TPA-KIT,
TF-HDMID-TPA-KIT

50 Ω SMA Terminators Any terminator that meets the following requirements:

50 Ω impedance ± 1% or better

Connects directly to the SMA female connector
DUT An HEAC sink or source device
SMA Cables Tektronix part number 174-1428-00 (1.5 meter)

Tektronix part number 174-1341-00 (1 meter)
HDMI Cable HDMI cable with HEAC capability

This tests the DUT for compliance with differential mode operating DC voltage (Transmitter) tests.
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1. Connect the equipment as shown.

NOTE. Use two probes for DC voltage measurement. Use the differential mode configuration for other measurements.

Connect the CEC or CDC Controller to the CEC/CDC Control Port of the HEAC-TPA main board.

Connect the HEAC-TPA plug board to the HEAC connector of the Source/Sink DUT.

Connect the 50 Ω SMA terminators to the HEAC-TPA main board.

Connect the first single-ended probe from Ch1 of the digital oscilloscope to the HEAC+ probe point on the HEAC-TPA
main board, and the second single-ended probe from Ch2 to the HEAC- probe point.

If you are testing a Sink DUT, set the HEAC-TPA main board to enable the Sink DUT test. Set switch S7 to the left
(Off position) on the HEAC-TPA main fixture.
If you are testing a Source DUT, set the HEAC-TPA main board to enable the Source DUT test, and use +5 V power
from the DC Power Supply. Set switch S7 to the right (On position) and the switch S4 is set to the left (Off position)
on the HEAC-TPA main fixture.

NOTE. Do not use +5 V power from the Source DUT.

Connect and configure the DC Power Supply to supply +5 V to the HEAC-TPA main board.

Power on the Source/Sink DUT.

Activate the HEC transmission capability for the HEAC Source/Sink DUT using the CEC/CDC controller.
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2. Select HEAC-Transmitter as the device
type.
By default, Differential-Tx is selected as
the Test Suite.
The default version CTS 1.4.

3. Click Deselect All and select only the
Operating DC Voltage test.

4. Enter the DUT identification in the DUT
ID field.

5. Click Show Schematic to display a
diagram of the test setup and confirm
that your test setup is correct.

6. Click Configure to open the
Configuration panel.

7. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. To change acquisition parameter
values, click User Defined Mode. A
message appears prompting you that If you
make changes to a test, the test may no
longer be compliant. Click OK to proceed
with the User Defined Mode.

8. Click Close.
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9. Click Run in the Select panel.
The application switches to the Acquire
tab.

10. Follow the on-screen prompts and the
schematics to change the setup. Click
OK to continue.

11. Click the Analyze tab to view test
analysis results.

12. The application displays the status of the
tests in the Status Messages window.
Click Save Status to save the status
messages.

13. When the tests complete, the application
shows a report in the Report panel.
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Common Mode Transmitter Tests
Required equipment Model supported
Real-time oscilloscope Tektronix DPO7000 Series, DPO70000 Series, DPO70000B

Series, DSA70000 Series, DSA70000B Series, and
MSO70000 Series Digital and Mixed Signal Oscilloscopes

Probe Tektronix P6243 or P6245 for Tektronix DPO70000
Series, DPO70000B Series, DSA70000 Series, and
DSA70000B Series, and MSO7000 Series Digital and
Mixed Oscilloscopes
Tektronix P6243, P6245, or TAP1500 for Tektronix
DPO7000 Series Digital Oscilloscopes

NOTE. You can also use two differential probes in
single-ended mode.

Test fixture TF-HEAC-TPA-P (A/C) or TF-HEAC-TPA-KIT,
TF-HDMID-TPA-KIT

50 Ω SMA Terminators Any terminator that meets the following requirements:

50 Ω impedance ± 1% or better

Connects directly to the SMA female connector
DUT An HEAC sink device
SMA Cables Tektronix part number 174-1428-00 (1.5 meter)

Tektronix part number 174-1341-00 (1 meter)
HDMI Cable HDMI cable with HEAC capability
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This tests the DUT for compliance with common mode (Transmitter) tests.

1. Connect the equipment as shown.

Connect the CEC or CDC Controller to the CEC/CDC Control Port of the HEAC-TPA main board.

Connect the HEAC-TPA plug board to the HEAC connector of the Sink DUT.

Connect the 50 Ω terminators to the HEAC-TPA main /board.

Connect the first single-ended probe from Ch1 of the digital oscilloscope to the HEAC+ probe point on the HEAC-TPA
main board, and the second single-ended probe from Ch2 to the HEAC– probe point.

Set the HEAC-TPA main board to enable the Sink DUT test.

Connect and configure DC Power Supply to drive +5 V to the HEAC-TPA main board.

Power on the Sink DUT.

Activate the ARC (Common mode) transmission on the HEAC Sink DUT using the CEC/CDC controller.
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2. Select HEAC-Transmitter as the device
type.

3. Select CommonMode-Tx.
The default version CTS 1.4.
All the common mode transmitter tests
are selected by default.

4. Enter the DUT identification in the DUT
ID field.

5. Click Show Schematic to display a
diagram of the test setup and confirm
that your test setup is correct.

6. Click Configure to open the
Configuration panel.

7. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. To change acquisition parameter
values, click User Defined Mode. A
message appears prompting you that If you
make changes to a test, the test may no
longer be compliant. Click OK to proceed
with the User Defined Mode.

8. Click Close.

9. Click Run in the Select panel.
The application switches to the Acquire
tab.
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10. Click the Analyze tab to view test
analysis results.

11. The application displays the status of the
tests in the Status Messages window.
Click Save Status to save the status
messages.

12. Follow the on-screen prompts. For the
Rise-Fall Time test, configure the DUT to
transmit an MLT-3 signal and click OK.

13. When prompted, configure the DUT to
disable the MLT-3 signal and click OK.
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14. The Transmit Jitter MAX test is run
at three frequencies. The application
prompts you to configure the DUT for
each of these frequencies: 4.096 MHz,
5.688 MHz, and 6.144 MHz. If your
device supports the frequency, configure
the DUT, and click OK.
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15. The IEC Stream Verification test is run
under three conditions: With +5 V power
turned on and ARC activated, With +5 V
power turned off, and With +5 V power
turned on and ARC not activated. Follow
the prompts and click OK.

16. When the tests complete, the application
shows a report in the Report panel.
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Single Mode Transmitter Tests
Required equipment Model supported
Real-time oscilloscope Tektronix DPO7000 Series, DPO70000 Series, DPO70000B

Series, DSA70000 Series, DSA70000B Series, and
MSO70000 Series Digital and Mixed Signal Oscilloscopes

Probe Tektronix P6243 or P6245 for Tektronix DPO70000
Series, DPO70000B Series, DSA70000 Series, and
DSA70000B Series, and MSO7000 Series Digital and
Mixed Oscilloscopes
Tektronix P6243, P6245, or TAP1500 for Tektronix
DPO7000 Series Digital Oscilloscopes

NOTE. You can also use two differential probes in
single-ended mode.

Test fixture TF-HEAC-TPA-P (A/C) or TF-HEAC-TPA-KIT,
TF-HDMID-TPA-KIT

50 Ω SMA Terminators Any terminator that meets the following requirements:

50 Ω impedance ± 1% or better

Connects directly to the SMA female connector
DUT An HEAC sink device
SMA Cables Tektronix part number 174-1428-00 (1.5 meter)

Tektronix part number 174-1341-00 (1 meter)
HDMI Cable HDMI cable with HEAC capability
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This tests the DUT for compliance with single mode (Transmitter) tests.

1. Connect the equipment as shown.

Connect the CEC or CDC Controller to the CEC/CDC Control Port on the HEAC-TPA main board.

Connect the HEAC-TPA plug board to the HEAC connector on the Sink DUT.

Connect the 50 Ω SMA terminators to the HEAC-TPA main board.

Set the Impedance Conversion Circuit on the HEAC-TPA main board to 55 Ω.

Connect a single-ended probe from Ch1 of the digital oscilloscope to the HEAC+ probe point on the HEAC-TPA main
board.

Set the HEAC-TPA main board to enable the Sink DUT test.

Connect and set the DC Power Supply to supply +5 V to the HEAC-TPA main board. Set switch S7 to the left (Off
position) on the HEAC-TPA main fixture.

Power on the Sink DUT.

Activate the ARC (Single mode) transmission on the HEAC Sink DUT using the CEC/CDC controller.
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2. Select HEAC-Transmitter as the device
type.

3. Select SingleMode-Tx.
The default version CTS 1.4.
All the single mode transmitter tests are
selected by default.

4. Enter the DUT identification in the DUT
ID field.

5. Click Show Schematic to display a
diagram of the test setup and confirm
that your test setup is correct.

6. Click Configure to open the
Configuration panel.

7. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. To change acquisition parameter
values, click User Defined Mode. A
message appears prompting you that If you
make changes to a test, the test may no
longer be compliant. Click OK to proceed
with the User Defined Mode.

8. Click Close.

9. Click Run in the Select tab.
The application switches to the Acquire
tab.
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10. Click the Analyze tab to view test
analysis results.

11. The application displays the status of the
tests in the Status Messages window.
Click Save Status to save the status
messages.

12. The Transmit Jitter MAX test is run
at three frequencies. The application
prompts you to configure the DUT for
each of these frequencies: 4.096 MHz,
5.688 MHz, and 6.144 MHz. If your
device supports the frequency, configure
the DUT, and click OK.
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13. The IEC Stream Verification test is run
under three conditions: with +5 V power
turned on and ARC activated, with +5 V
power turned off, and with +5 V power
turned on and ARC not activated. Follow
the prompts and click OK.

14. When the tests complete, the application
shows a report in the Report panel.
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Differential Receiver Tests
Required equipment Model supported
Real-time oscilloscope Tektronix DPO7000 Series, DPO70000 Series, DPO70000B

Series, DSA70000 Series, DSA70000B Series, and
MSO70000 Series Digital and Mixed Signal Oscilloscopes

Arbitrary waveform generator Tektronix AWG5000 Series, AWG5000B, AWG7000 Series,
or AWG7000B Series Arbitrary Waveform Generator

Probe Tektronix P6247, P6248, P6330, or P7330 for a
DPO70000 Series, DPO70000B Series, DSA70000 Series,
DPO70000B, and MSO70000 Series Digital and Mixed
Signal Oscilloscope
Tektronix P6330, TDP1000, TDP1500, or TDP3500 for a
Tektronix DPO7000 Series Digital Oscilloscope

Test fixture TF-HEAC-TPA-P (A/C) or TF-HEAC-TPA-KIT,
TF-HDMID-TPA-KIT

DUT An HEAC sink or source device
SMA Cables Tektronix part number 174-1428-00 (1.5 meter)

Tektronix part number 174-1341-00 (1 meter)
HDMI Cable HDMI cable with HEAC capability

This tests the DUT for compliance with differential receiver tests.
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1. Connect the DUT to the equipment as shown.

Connect a LAN cross-cable from the digital oscilloscope to the waveform generator, and enable the TekVISA connection
to the waveform generator and to the digital oscilloscope.

Connect an SMA cable to the Ch1 Marker1 output and to Ch2 on the digital oscilloscope.

Connect the HEAC-TPA plug board to the HEAC connector of the Source/Sink DUT.

Connect the Ch1 Analog(+) output of the arbitrary waveform generator to the HEAC+ SMA connector on the HEAC-TPA
main board and the Ch2 Analog(+) to HEAC–.

Set the Impedance Conversion Circuit on the HEAC-TPA main board to 50 Ω.

Connect a differential probe to the HEAC± differential signal probe point on the HEAC-TPA main board.

Connect the CEC or CDC Controller to the CEC/CDC Control Port of the HEAC-TPA main board.

If you are testing a Sink DUT, set the HEAC-TPA main board to enable the Sink DUT test. Set switch S7 to the left
(Off position) on the HEAC-TPA main board.
If you are testing a Source DUT, set the HEAC-TPA main board to enable the Source DUT test. Activate +4 V bias by
using the +5 V power from the Source DUT. Set switch S7 to the right (On position) on the HEAC-TPA main fixture.

Activate the HEC transmission on the HEAC Source/Sink DUT using the CEC/CDC controller.
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2. Select HEAC-Receiver as the device
type.

3. Select the Differential-Rx as the Test
Suite.
The default version CTS 1.4.
All the differential mode receiver tests
are selected by default.

4. Enter the DUT IP Address.

5. Enter the DUT identification in the DUT
ID field.

6. Click Show Schematic to display a
diagram of the test setup and confirm
that your test setup is correct.

7. Click Configure to open the
Configuration panel.

8. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. The User Defined Mode is not
available for HEAC Differential Receiver
tests.

9. Click Close.

10. Click Run in the Select panel to run the
test.
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11. Click the Acquire tab to view the
acquisition details.

12. The application displays the status of the
tests in the Status Messages window.
Click Save Status to save the status
messages.

13. When the tests complete, the application
shows a report in the Report panel.
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Common Mode Receiver Tests
Required equipment Model supported
Real-time Oscilloscope Tektronix DPO7000 Series, DPO70000 Series, DPO70000B

Series, DSA70000 Series, DSA70000B Series, and
MSO70000 Series Digital and Mixed Signal Oscilloscopes

Arbitrary waveform generator Tektronix AWG5000 Series, AWG5000B Series, AWG7000,
or AWG7000B Series Arbitrary Waveform Generator

HEAC TPA-P adapter Tektronix HEAC-TPA-P
Test fixture TF-HEAC-TPA-P (A/C) or TF-HEAC-TPA-KIT,

TF-HDMID-TPA-KIT
DUT An HEAC source device
SMA Cables Tektronix part number 174-1428-00 (1.5 meter)

Tektronix part number 174-1341-00 (1 meter)
HDMI Cable HDMI cable with HEAC capability

This tests the DUT for common mode receiver tests.

1. Connect the DUT to the equipment as shown.

NOTE. This equipment setup diagram and connections are the same for all common mode receiver tests except the
Operating DC Voltage Test.
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Connect the HEAC-TPA main board to the HEAC connector on the Source DUT.

Connect the CEC or CDC Controller to the CEC/CDC Control Port of the HEAC-TPA main board.

Connect the Ch1 Analog(+) output from a waveform generator to the HEAC+ SMA connector of the HEAC-TPA main
board, and the Ch2 Analog(+) to the HEAC– SMA connector.

Set the Impedance Conversion Circuit on the HEAC-TPA main board to 50 Ω.

Set the HEAC-TPA main board to enable the Source DUT test.

Activate +4 V bias using the +5 V power from the Source DUT.

Activate ARC (Common mode) transmission capability for the HEAC Source DUT using the CEC/CDC controller.
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2. Select HEAC-Receiver as the device
type.

3. Select CommonMode-Rx as the Test
Suite.
All the common mode receiver tests are
selected by default.
The default version CTS 1.4.

4. Enter the DUT identification in the DUT
ID field.

5. Click Show Schematic to display a
diagram of the test setup and confirm
that your test setup is correct.

6. Click Configure to open the
Configuration panel.

7. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. The User Defined Mode is not
available for HEAC Common Mode Receiver
tests.

8. Click Close.

9. Click Run in the Select panel to run the
test.
The application switches to the Acquire
tab.
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10. Click the Analyze tab.

11. The application displays the status of the
tests in the Status Messages window.
Click Save Status.
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12. As the selected tests are executed,
the application prompts you to verify
the audio response from the DUT.
Click Detected or Not Detected as
appropriate for each test.

13. Follow the on-screen prompts and the
schematics to change the setup. Click
OK to continue.

14. When the tests complete, the application
shows a report in the Report panel.
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Common Mode Operating DC Voltage Test (Receiver)
Required equipment Model supported
Real-time oscilloscope Tektronix DPO7000 Series, DPO70000 Series, DPO70000B

Series, DSA70000 Series, DSA70000B Series, and
MSO70000 Series Digital and Mixed Signal Oscilloscopes

Arbitrary waveform generator Tektronix AWG5000 Series, AWG5000B, AWG7000 Series,
and AWG7000B Series Arbitrary Waveform Generator

Probe Tektronix P6243 or P6245 for Tektronix DPO70000
Series, DPO70000B Series, DSA70000 Series, and
DSA70000B Series, and MSO7000 Series Digital and
Mixed Oscilloscopes
Tektronix P6243, P6245, or TAP1500 for Tektronix
DPO7000 Series Digital Oscilloscopes

HEAC TPA-P adapter Tektronix HEAC-TPA-P
Test fixture TF-HEAC-TPA-P (A/C) or TF-HEAC-TPA-KIT,

TF-HDMID-TPA-KIT
DUT An HEAC source device
SMA Cables Tektronix part number 174-1428-00 (1.5 meter)

Tektronix part number 174-1341-00 (1 meter)
HDMI Cable HDMI cable with HEAC capability

This tests the DUT for compliance with common mode operating DC voltage (Receiver) tests.
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1. Connect the DUT to the equipment as shown.

Connect the HEAC-TPA plug board to the HEAC connector on the Source DUT.

Connect the CEC or CDC Controller to the CEC/CDC Control Port on the HEAC-TPA main board.

Connect the Ch1 Analog(+) output from a waveform generator to the HEAC+ SMA connector of the HEAC-TPA main
board, and the Ch2 Analog(+) to the HEAC– SMA connector.

Set the Impedance Conversion Circuit on the HEAC-TPA main board to 50 Ω.

Connect a single-ended probe from Ch1 of the Digital Oscilloscope to the HEAC+ probe point on the HEAC-TPA main
board, and a second single-ended probe from Ch2 to the HEAC- probe point.

Set the HEAC-TPA main board to enable the Source DUT test, and to use +5 V power from the DC Power Supply. Set
switch S7 to the right (On position) on the HEAC-TPA main fixture.

NOTE. Do not use +5 V power from the Source DUT.

Connect and set the DC Power Supply to supply +5 V to the HEAC-TPA main board.

Power on the Source DUT.

Activate the ARC (Common mode) transmission on the HEAC Source DUT using the CEC/CDC controller.
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2. Select HEAC-Receiver as the device
type.

3. Select the CommonMode-Rx as the
Test Suite.
The default version CTS 1.4.

4. Click Deselect All and select the
Operating DC VoltageTest.

5. Enter the DUT identification in the DUT
ID field.

6. Click Show Schematic to display a
diagram of the test setup and confirm
that your test setup is correct.

7. In the Select panel, highlight the test and
click Configure.
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8. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. To change acquisition parameter
values, click User Defined Mode. A
message appears prompting you that If you
make changes to a test, the test may no
longer be compliant. Click OK to proceed
with the User Defined Mode.

9. Click Close.

10. In the Select panel, click Run to start the
test.
The application switches to the Acquire
tab.
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11. Click the Analyze tab.

12. The application displays the status of the
tests in the Status Messages window.
Click Save Status to save the status
messages.

13. When the tests complete, the application
shows a report in the Report panel.
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Single Mode Receiver Tests
Required equipment Model supported
Real-time oscilloscope Tektronix DPO7000 Series, DPO70000 Series, DPO70000B

Series, DSA70000 Series, DSA70000B Series, and
MSO70000 Series Digital and Mixed Signal Oscilloscopes

Arbitrary waveform generator Tektronix AWG5000 Series, AWG5000B Series, AWG7000
Series, or AWG7000B Series Arbitrary Waveform Generator

Probe Tektronix P6243 or P6245 for Tektronix DPO70000
Series, DPO70000B Series, DSA70000 Series, and
DSA70000B Series, and MSO7000 Series Digital and
Mixed Oscilloscopes
Tektronix P6243, P6245, or TAP1500 for Tektronix
DPO7000 Series Digital Oscilloscopes

HEAC TPA-P adapter Tektronix HEAC-TPA-P
Test fixture TF-HEAC-TPA-P (A/C) or TF-HEAC-TPA-KIT,

TF-HDMID-TPA-KIT
DUT An HEAC sink or source device
SMA Cables Tektronix part number 174-1428-00 (1.5 meter)

Tektronix part number 174-1341-00 (1 meter)
HDMI Cable HDMI cable with HEAC capability
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This tests the DUT for compliance with single mode (Receiver) tests.

1. Connect the DUT to the equipment as shown.
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Connect the HEAC-TPA plug board to the HEAC connector on the Source DUT.

Connect the CEC or CDC Controller to the CEC/CDC Control Port on the HEAC-TPA main board.

Connect the Ch1 Analog(+) output from a waveform generator to the HEAC+ SMA connector of the HEAC-TPA main
board.

Set the Impedance Conversion Circuit on the HEAC-TPA main board to 55 Ω.

Connect a single-ended probe from Ch1 of the digital oscilloscope to the HEAC+ probe point on the HEAC-TPA main
board.

Set the HEAC-TPA main to use +5 V power from the DC Power Supply.

NOTE. Do not use +5 V power from the Source DUT.

Load the waveform data on the arbitrary waveform generator and generate the waveforms.

Activate the ARC (Single mode) transmission on the HEAC Sink DUT using the CEC/CDC controller.

2. Select HEAC-Receiver as the device
type.

3. Select the SingleMode-Rx as the Test
Suite.
The default version CTS 1.4.
All the single mode receiver tests are
selected by default.

4. Enter the DUT identification in the DUT
ID field.

5. Click Show Schematic to display a
diagram of the test setup and confirm
that your test setup is correct.

6. In the Select panel, highlight the test and
click Configure.
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7. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. To change acquisition parameter
values, click User Defined Mode. A
message appears prompting you that If you
make changes to a test, the test may no
longer be compliant. Click OK to proceed
with the User Defined Mode.

8. Click Close.

9. Click Run in the Select panel.
The application switches to the Acquire
tab.

10. Click the Analyze tab.

11. The application displays the status of the
tests in the Status Messages window.
Click Save Status to save the status
messages.
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12. The single mode receiver tests are run at
three terminal voltage levels (Vel): 0 V,
2.5 V, and 5 V.

13. The application prompts you to verify
the audio response from the DUT.
Click Detected or Not Detected as
appropriate for each test.

14. Repeat Steps 13 and 14 for different
terminal voltage levels and audio
patterns of various frequencies.

15. When the tests complete, the application
shows a report in the Report panel.
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Single Mode Operating DC Voltage Test (Receiver)
Required equipment Model supported
Real-time oscilloscope Tektronix DPO7000 Series, DPO70000 Series, DPO70000B

Series, DSA70000 Series, DSA70000B Series, and
MSO70000 Series Digital and Mixed Signal Oscilloscopes

Arbitrary waveform generator Tektronix AWG5000 Series, AWG5000B Series, AWG7000
Series, or AWG7000B Series Arbitrary Waveform Generator

Probe Tektronix P6243 or P6245 for Tektronix DPO70000
Series, DPO70000B Series, DSA70000 Series, and
DSA70000B Series, and MSO7000 Series Digital and
Mixed Oscilloscopes
Tektronix P6243, P6245, or TAP1500 for Tektronix
DPO7000 Series Digital Oscilloscopes

HEAC TPA-P adapter Tektronix HEAC-TPA-P
Test fixture TF-HEAC-TPA-P (A/C) or TF-HEAC-TPA-KIT,

TF-HDMID-TPA-KIT
DUT An HEAC source device
SMA Cables Tektronix part number 174-1428-00 (1.5 meter)

Tektronix part number 174-1341-00 (1 meter)
HDMI Cable HDMI cable with HEAC capability

This tests the DUT for compliance with single mode operating DC voltage (Receiver) tests.
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1. Connect the DUT to the equipment as shown.

Connect the HEAC-TPA plug board to the HEAC connector on the Source DUT.

Connect the CEC or CDC Controller to the CEC/CDC Control Port on the HEAC-TPA main board.

Connect the Ch1 Analog(+) output from a waveform generator to the HEAC+ SMA connector of the HEAC-TPA main
board.

Set the Coupling & Impedance Conversion Circuit on the HEAC-TPA main board to 55 Ω.

Connect a single-ended probe from Ch1 of the digital oscilloscope to the HEAC+ probe point on the HEAC-TPA main
board.

Set the HEAC-TPA main board to enable the Source DUT test, and to use +5 V power from the DC Power Supply. Set
switch S7 to the right (On position) on the HEAC-TPA main fixture.

NOTE. Do not use +5 V power from the Source DUT.

Connect and set the DC Power Supply to supply +5 V to the HEAC-TPA main board.

Power on the Source DUT.

Activate the ARC (Single mode) transmission on the HEAC Source DUT using the CEC/CDC controller.

Load the nominal audio waveform data on the arbitrary waveform generator and generate the waveform.
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2. Select HEAC-Receiver as the device
type.

3. Select the SingleMode-Rx as the Test
Suite.
The default version CTS 1.4.

4. Click Deselect All and select the
Operating DC Voltage test.

5. Enter the DUT identification in the DUT
ID field.

6. Click Show Schematic to display a
diagram of the test setup and confirm
that your test setup is correct.

7. In the Select panel, highlight the test and
click Configure.
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8. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. To change acquisition parameter
values, click User Defined Mode. A
message appears prompting you that If you
make changes to a test, the test may no
longer be compliant. Click OK to proceed
with the User Defined Mode.

9. Click Close.

10. Click Run in the Select panel.
The application switches to the Acquire
tab.
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11. The operating DC voltage test runs at
three terminal voltages: 0 V, 2.5 V, and
5 V. Adjust the voltage and click OK to
continue.
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12. Click the Analyze tab.

13. The application displays the status of the
tests in the Status Messages window.
Click Save Status to save the status
messages.

14. When the tests complete, the application
shows a report in the Report panel.

TekExpress HEAC Quick Start User Manual 53



Application Examples

54 TekExpress HEAC Quick Start User Manual



Index

Index

A
Acquire, 8
Analyze, 8, 13, 17, 21, 27, 32
Arbitrary waveform generator, 29,

33, 38, 43, 48

C
Common mode

receiver, 35
Compliance mode, 6, 12, 16, 20,

26, 31, 32, 35, 41, 46, 51
Configure, 6

Acquire panel, 7
Analyze panel, 7
Comments panel, 7
Limits panel, 7
receiver test, 31, 35, 40, 45, 50
transmitter test, 12, 16, 20, 26

Conformance
CTS 1.4 specifications, vi
HDMI 1.4 standards, vi

Connect
equipment, 2

Connections
common mode receiver

tests, 34
common mode tests, 34
differential mode

transmitter, 11, 15, 19,
25

differential receiver tests, 30,
39, 49

single mode receiver tests, 44,
45

D
Device, 6
Differential mode

Operating DC Voltage test, 14
receiver, 31, 40, 50
transmitter, 12, 16, 20

Differential mode Operating DC
Voltage transmitter tests
Probe, 14
Real-time oscilloscope, 14

Differential mode transmitter
tests, 10

DUT, 10, 14, 18, 24, 29, 33
id, 8

DUT IP Address, 31

H
HDMI Cable, 10
HTML report, vi

J
Jumper setup, 5

M
Multiple tests, 6

P
Pass/Fail notification, vi
Probe, 10, 18, 24, 29

R
Readme, 1
Real-time oscilloscope, 10, 18, 24,

29, 38, 43, 48
Receiver test

common mode, 33
differential mode, 29, 38, 48
single mode, 44

Related documentation, vii
Report, 13, 17, 23, 28, 32

generate, 9
HTML, 9
previewing, 9
print, 9
printing, 9
save, 9
saving, 9

Run
test, 8

S
Safety Summary, iii

Show Schematic, 2, 6, 12, 16, 20,
26, 31, 35, 40, 45, 50

Single mode
receiver, 45
transmitter, 26

SMA Cables, 10
Software

closing the, 2
features, vi
installation, 1
process flow, 3
starting the, 2
upgrades, vii

Status messages, 8, 13, 17, 21, 27,
32

Switch setup, 4

T
Test

configuring, 6
details, 9
interpreting the result, 9
parameters, 6
report, 9
running, 8
selecting, 6

Test fixture, 10, 14, 18, 24, 29, 30,
33, 39, 45, 49
TF-HEAC-TPA-KIT, 2

Test suite, 6, 12, 16, 20, 26, 31, 35,
40, 45, 50
version, 6

Tests
Deselect All, 6
Select All, 6

Transmitter test
differential mode, 10, 14, 19,

25
Transmitter tests

Operating DC Voltage test, 14

U
User defined mode, 13, 17, 20, 26,

32, 35

TekExpress HEAC Quick Start User Manual 55


	toc
	General Safety Summary
	Compliance Information
	Environmental Considerations

	Preface
	Key Features
	Documentation
	Software Upgrades

	Install the Software
	Before Installation
	Prerequisites
	Installation
	Required Test Equipment
	Start the Software
	Close the Software

	Use the TekExpress Software
	Process Flow
	Set Up the Switches on the HEAC-TPA-MAIN Fixture
	Set Up the Jumpers on the HEAC-TPA-MAIN Fixture
	Select a Device, Test Suite, and Test
	Configure the Test Parameters
	Connect and Configure the Equipment
	Run the Test
	Interpret the Test Result
	Generate, Save, and Print a Report

	Application Examples
	Differential Mode Transmitter Tests
	Differential Mode Operating DC Voltage Test (Transmitter)
	Common Mode Transmitter Tests
	Single Mode Transmitter Tests
	Differential Receiver Tests
	Common Mode Receiver Tests
	Common Mode Operating DC Voltage Test (Receiver)
	Single Mode Receiver Tests
	Single Mode Operating DC Voltage Test (Receiver)



