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Welcome Welcome to the 80SJARB Jitter Analysis of Arbitrary Data Software

Welcome to the 80SJARB Jitter Analysis of Arbitrary Data Software
The 80SJARB Jitter Analysis of Arbitrary Data software enhances the capabilities of the CSA8000B,
TDS8000B, DSA8200, CSA8200, and TDS8200 Series Tektronix sampling oscilloscopes. This application
provides basic jitter measurements for arbitrary data signals, including:

J2 – Total jitter for Bit Error Rate (BER) = 2.5E-03

J9 – Total jitter for BER = 2.5E-10

Tj – Total jitter for BER = 1.0E-12

DJdd – Deterministic jitter (Dual Dirac method)

RJdd – Random jitter (Dual Dirac method)

Jitter bathtub curve graph (both measured and extrapolated data)

Histogram of the acquired data

The accuracy and repeatability of all measurements improves as the application acquires additional data.
While the standards specify that J2 and J9 measurements be taken on a minimum of 10,000 points, the
80SJARB application acquires data beyond this minimum requirement (in free-run mode) and shows the
number of points used for the extrapolated measurement calculations.

Tektronix also offers two other optional jitter measurement applications for the 8000 Series oscilloscopes:
80SJNB (Jitter, Noise and BER Analysis Essentials) and 80SJNB-01 (Jitter, Noise and BER Analysis
Advanced). Comparison of Jitter Measurement Applications (see page 16) provides a comparison of the
jitter analysis applications for the Tektronix 8000 Series.

See Also:
Requirements (see page 5)

Starting the 80SJARB Application (see page 7)

Using Online Help
Online help has many advantages over a printed manual because of advanced search capabilities. The
main (opening) Help screen shows a series of book icons and three tabs along the top menu, each of
which offers a unique mode of assistance:
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Welcome Conventions

Contents tab - organizes the Help into book-like sections. Select a book icon to open a section;
select any of the topics listed under the book.

Index tab - enables you to scroll a list of alphabetical keywords. Select the topic of interest to display
the corresponding help page.

Search tab - enables you to search the entire help contents for keywords. Select the topic of interest to
display the corresponding help page. Search results do not include text contained within illustrations
or screen shots.

NOTE. Blue-underlined text in a topic indicates a hyperlink to another topic. For example, select the blue
text in this sentence to jump to the topic on Feedback and Technical Support (see page 3).

TIP. When you use a mouse, the normal cursor changes to a link cursor when over an active hyperlink.

Conventions
Online help topics use the following conventions:

The terms “80SJARB”, “80SJARB application” or “application” refer to the 80SJARB Jitter Analysis
of Arbitrary Data software.

The term “oscilloscope” refers to the product on which this application runs.

The term “select” is a generic term that applies to the two mechanical methods of choosing an option:
with a mouse or with the touch screen.

When steps require a sequence of selections in the application interface, the “>” delimiter marks
each transition between a menu and an option. For example, File > Exit indicates to select the File
menu, then select the Exit submenu item.

2 80SJARB Jitter Analysis Printable Help



Welcome Feedback and Technical Support

Feedback and Technical Support
Tektronix values your feedback on our products. To help us serve you better, please send us your
suggestions, ideas, or comments about your application or oscilloscope.

When you contact Tektronix Technical Support with suggestions, or to help you resolve a problem, please
include the following information (be as specific as possible):

General Information
Oscilloscope model number, firmware version number, and hardware options, if any.

Module and probe configuration. Include model numbers and the channel/slot location.

Serial data standard.

Signaling rate.

Pattern type and length.

Your name, company, mailing address, phone number, FAX number.

Application-Specific Information
80SJARB Software version number.

Description of the problem such that technical support can duplicate the problem.

If possible, save the oscilloscope waveform file as a .wfm file.

If possible, save the oscilloscope and application .stp setup files.

Once you have gathered this information, you can Contact Tektronix ) by phone or through e-mail. If
using e-mail, be sure to enter 80SJARB Problem in the subject line, and attach the .stp and .wfm files.

TIP. To include screen shots, select File > Export Waveform from the oscilloscope menu bar. In the Export
dialog box, enter a file name with a .bmp extension and select Save. The oscilloscope saves the file in
the C:\My Documents\TEKSCOPE\UI directory.
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Getting Started Requirements

Requirements
A Tektronix 8000 Series oscilloscope running Microsoft Windows XP (service pack 2 or greater).

A Tektronix 8000 Series oscilloscope with firmware version 5.0.0 or higher.

The 80SJNB Jitter, Noise and BER Analysis Essentials Application software installed on the
oscilloscope (the application does not need to have a license/keycode, but it must be installed on
the oscilloscope).

An 80SJARB, 80SJNB, or 80SJNB-01 application license. To check if an application license is already
active on the instrument, click Utilities > System Properties and look at the Options tab contents.

NOTE. You do not need to purchase a license for 80SJARB if you already have a license for 80SJNB or
80SJNB-01.

NOTE. You can run the 80SJARB software up to seven times in the free trial mode. Once the trials are
used, the software will no longer start.

See Also:
Install and Activate the Software (see page 5)

Install and Activate the Software
NOTE. Make sure to check the requirements (see page 5) before installing and activating the 80SJARB
application.

1. Download the 80SJARB software from the Tektronix Web site (www.tek.com). Enter 80SJARB in the
Downloads field, select Software from the list, and click GO to locate the software download file.
Follow on-screen directions.

2. Copy the install software to the oscilloscope.

3. Double-click the install software file to begin installation. Follow on-screen instructions.

4. Restart the oscilloscope after installing the 80SJARB software.

5. Click the Applications menu and verify that 80SJARB is listed.

6. Click Utilities > Option Installation and follow the instructions to enable the 80SJARB application if
you purchased a license and key code.
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Getting Started Install and Activate the Software

NOTE. You do not need a license and Option Installation Key for 80SJARB if you already have a license
and key for 80SJNB or 80SJNB-01. If you do not have a key for the 80SJNB or 80SJNB-01 application,
you must purchase a license and key code for 80SJARB.

See Also:
Starting the 80SJARB Application (see page 7)
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Operating Basics Starting the 80SJARB Application

Starting the 80SJARB Application
Use any of the following methods to start the 80SJARB application:

Click Applications > 80SJARB in the oscilloscope menu.

Double-click the 80SJARB shortcut on the desktop.

Click Start > All Programs > Tektronix Applications > 80SJARB > 80SJARB.

Activate 80SJARB remotely by using GPIB commands with the oscilloscope programmable interface.
See Remote Control Introduction (see page 19).

All of these methods open the 80SJARB user interface (see page 7).

NOTE. You can run only one oscilloscope application at a time. Running more than one application
causes one or more of the running applications to fail. To run the 80SJARB application, close all other
applications (such as 80SJNB). To run another application, you must close the 80SJARB application. The
optional applications communicate with the oscilloscope over VISA to detect commands to itself. A
communications conflict happens when two applications run simultaneously.

Please contact Tektronix if activating multiple applications simultaneously is important to your use of the
instrument.

NOTE. To start the 80SJARB application more quickly, click the oscilloscope Run/Stop button to stop the
oscilloscope signal acquisition before you start the 80SJARB application.

See Also:
The 80SJARB User Interface (see page 7)

Measurement Workflow (see page 13)

Operating Modes (see page 15)

Remote Control Introduction (see page 19)

The 80SJARB User Interface
The 80SJARB user interface consists of menus, function buttons, a measurement readout pane, and
a status bar at the bottom of the display. The application also displays a progress bar to indicate the
approximate completion status of each step.
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Operating Basics Menu Items

See Also:
Menu Items (see page 8)

Function Buttons (see page 9)

Measurement Readout (see page 10)

Status Bar (see page 11)

Bathtub and Histogram Graphs (see page 12)

Measurement Workflow (see page 13)

Operating Modes (see page 15)

Menu Items
Menu Submenu Description

Hibernate Places the application in a suspended mode where it remains running but does not
communicate with the oscilloscope. This prevents 80SJARB from interfering with
other applications.
To wake up the application, click File and unselect the Hibernate menu item. You
can also wake up the application by selecting Applications > 80SJARB in the
oscilloscope menu.

File

Exit Exits the application.
BER Bathtub Displays a graph of the cumulative density function, in Q scale versus time.View
Histogram
Data

Displays a normalized histogram of the acquired data.
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Operating Basics Function Buttons

Menu Submenu Description
Online Help Displays the application online help (this document).Help
About
80SJARB

Displays an About dialog box that contains the version number of 80SJARB.

xxx

See Also:
Function Buttons (see page 9)

Measurement Readout (see page 10)

Status Bar (see page 11)

Bathtub and Histogram Graphs (see page 12)

Function Buttons
80SJARB provides three control buttons: Free Run, Run, and Stop.

Button Name Description
Free Run Enables or disables the Free-Run (continuous) measurement mode. In Free Run mode

the oscilloscope continues to acquire data after a single measurement is taken. 80SJARB
continues to process and display updated measurement results, including the number of
hits in the histogram. The number of hits continues to increase when in this mode.
This button does not start a measurement acquisition; you must click the Run button to
start taking measurements.

Run Starts a measurement sequence (single or Free Run). 80SJARB takes a measurement
acquisition based on the oscilloscope settings, then processes and displays the
measurement values.

Stop Stops the 80SJARB measurement sequence. The application does not display
measurements from a stopped single Run sequence. The application displays
measurements from a stopped Free Run sequence if the application has acquired the
minimum 10,000 points.

xxx

See Also:
Menu Items (see page 8)

Measurement Readout (see page 10)

Status Bar (see page 11)
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Operating Basics Measurement Readout

Measurement Readout
The Measurement Readout pane displays the 80SJARB measurement results. You can select and copy
measurement readout values to paste them into a report or other document.

See Also:
Menu Items (see page 8)

Function Buttons (see page 9)

Status Bar (see page 11)
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Operating Basics Status Bar

Status Bar
The status bar at the bottom of the display shows the measurement status and error and warning messages
(see page 24). The following table lists the measurement status messages:

Message Description
Ready 80SJARB is ready to take measurements.
Setting up 80SJARB is taking preliminary measurements and setting up the oscilloscope as needed to

acquire the histogram data.
Acquiring The oscilloscope is acquiring data into the histogram for later processing.
Processing 80SJARB is processing the histogram data to produce the J2 and J9 measurement results.
Stopped The Stop button was clicked during a Run mode before the measurement and processing

sequence was completed.
Hibernating 80SJARB has stopped communicating with the oscilloscope to allow another application to run.

To wake up the application, click File and unselect the Hibernate menu item. You can also
wake up the application by selecting Applications > 80SJARB in the oscilloscope menu.

xxx

See Also:
Menu Items (see page 8)

Function Buttons (see page 9)

Measurement Readout (see page 10)
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Operating Basics Bathtub and Histogram Graphs

Bathtub and Histogram Graphs
Select BER Bathtub or Histogram Data in the View menu to display a graph of these items. Use the
Toolbar buttons on the graphs to zoom in or out of the graph, pan the graph, rotate the graph to view it in
2D or 3D mode, or use cursors to take measurements on the graph. Each graph mode has its own unique
context-sensitive menu (displayed by right-clicking on the graph).
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Operating Basics Measurement Workflow

Measurement Workflow
1. Click Utilities > Default Setup to restore the oscilloscope to the default instrument settings.

2. Set the oscilloscope to properly display an eye diagram. One method is to use a defined test mask and
then perform a mask autoset.

3. In the 80SJARB application, click the Run button. For more accurate measurements, click the Free
Run button to enable the Free Run mode before clicking Run. 80SJARB communicates with the
oscilloscope, changes measurement settings as required, and displays the measurement values in the
Measurement Results pane.

4. Click View > BER Bathtub or View > Histogram Data to view a Bathtub or histogram plot.

5. Click File > Exit to close the application.

See Also:
Measurement Modes (see page 15)

Measurement Methodology (see page 17)
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Reference Measurement Modes

Measurement Modes
The oscilloscope setup determines which measurement mode the application will use: the automatic
(preferred) or manual setup of the waveform database and histogram.

80SJARB requires the oscilloscope to be ready to acquire an eye diagram; it is best if one is already
displayed on the Main view (main time base window) for 80SJARB to work properly.

80SJARB uses the oscilloscope measurement system to find the amplitude of the signal and the crossing
level of the eye diagram to calculate the size and position of the histogram box. The height of the
histogram box is set to 1% of the signal amplitude and is centered on the crossing level. 80SJARB sets the
oscilloscope to acquire 10,000 hits in the histogram box.

Automatic Setup of Waveform Database and Histogram
For this mode, the oscilloscope is running with a waveform set up for an eye diagram but the histogram is
not enabled. The oscilloscope acquisition can be running or stopped. The Stop After acquisition mode
should be set to Run/Stop Button Only.

80SJARB measures the parameters of the eye on the Main view by turning on needed measurements using
a waveform database. 80SJARB enables the Mag1 view and enables a waveform database and histogram
on the Mag1 view while taking measurements. The Mag1 view is set to capture the left crossing of the
eye diagram, and the histogram box is set to 1% of the signal amplitude (centered on the crossing level).
80SJARB also sets the acquisition to conditionally acquire waveforms until this histogram has 10,000 hits.
When the acquisition is complete, the 80SJARB application analyzes the histogram data to produce the J2
and J9 measurements. This is the fastest way to capture a new set of data for analysis.

After processing the data, the application turns off the histogram, waveform database and Mag1 view,
and displays the measurement results.

Manual Setup of Waveform Database and Histogram
Manual mode requires you to set up a histogram (and optionally a waveform database) on the main or
Mag1 view for the selected channel or math waveform. 80SJARB uses the histogram that you set up (and
enables a waveform database as needed) and takes measurements using the existing data (if acquisitions
are stopped) or after waiting for 10,000 hits to accumulate in the histogram (if acquisitions are running).
The 80SJARB application then displays the measurement results.

See Also:
Measurement Methodology (see page 17)
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Reference Comparison of Jitter Measurement Applications

Measurement Readouts and Accuracy (see page 18)

Comparison of Jitter Measurement Applications
Capability 80SJARB 80SJNB 80SJNB-01
NRZ data supported Any data, including

PRBS31 or random traffic
Repetitive pattern up to
PRBS16

Repetitive pattern up to
PRBS16

J2 jitter result Yes
(on a histogram according
to IEEE 802.3ba)

Yes
(on every edge; set the
BER level to BER=2.5E-03)

Yes
(on every edge; set the
BER level to BER=2.5E-03)

J9 jitter result Yes
(on a histogram according
to IEEE 802.3ba)

Yes
(on every edge; set the
BER level to 2.5E-10)

Yes
(on every edge; set the
BER level to 2.5E-10)

TJ total jitter result Yes
(at BER=1E-12)

Yes
(at settable BER; default
BER=1.0E-12)

Yes
(at settable BER; default
BER=1.0E-12)

DJdd, RJdd 1 Yes Yes Yes
Jitter and Noise analysis
(PJ, RJ, DDJ, PN, RN,
DDN, and so on)

No Yes Yes

BER surface graphs No Yes Yes
SDLA features
(channel emulation,
fixture de-embedding,
equalization)

No No Yes

Additional Features As the tools are updated periodically, please consult the latest data sheet from www.tek.com
for up-to-date information.

xxx

1 dd = Dual Dirac.

16 80SJARB Jitter Analysis Printable Help



Reference Measurement Methodology

Measurement Methodology
80SJARB works with the selected channel or math waveform. If no waveform is selected, or if the selected
waveform is not a channel or math waveform, 80SJARB displays an error message.

80SJARB uses the oscilloscope’s measurement system to capture eye diagram parameters to take proper
measurements. This means that at least one measurement slot (measurement type is set to NONE) and
one waveform database must be available. If a measurement slot or waveform database is not available,
80SJARB displays an error message.

Under certain conditions 80SJARB enables the Mag1 viewer, a high-resolution acquisition window, to
gather histogram data for its measurements. It also enables waveform database and histogram analysis
if needed. When the 80SJARB enables an additional resource (such as a waveform database or a
Magnification view), it turns off the resource after completing the measurements.

See Also:
Measurement Readouts and Accuracy (see page 18)
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Measurement Readouts and Accuracy
80SJARB provides the following measurement readouts: J2, J9, TJ (at 1.0E-12), DJdd, RJdd, and the
number of hits in the histogram.

The J2 measurement is the total jitter measured at a BER of 2.5E-3 by measuring from 0.5th to the 99.5th
percentile of the jitter histogram according to IEEE 802.3, paragraph 86.8.3.

Remaining measurements are calculated from a linear extrapolation in Q-space. The J9 measurement is the
total jitter measured at a BER of 2.5E-10. TJ is the total jitter at BER=1.0E-12. DJdd and RJdd are the
Deterministic Jitter Dual Dirac and Random Jitter Dual Dirac measurements, respectively.

NOTE. While 80SJARB allows measurement on any data (such as larger PRBS patterns, scrambled data,
or live traffic), the accuracy of extrapolated jitter measurements depends on many factors (such as type of
data, probability function of jitter, and amount of data captured) and is less reliable than in a measurement
method that performs full jitter analysis, such as 80SJNB. For this reason the extrapolated results, and the
DJdd and RJdd in particular, should be considered as mostly relative values. For best accuracy, use the
Free Run mode until the extrapolated results stabilize, or use the 80SJNB application.

For additional information on the Dual Dirac method, please see the Tektronix white paper What the
Dual-Dirac Model is and What it is Not, available at www.tek.com.

80SJARB resets the measurement results when you click the Run button and updates the Hits measurement
with the number of hits that have accumulated into the histogram. After processing is completed, the
readouts show the latest results.

In Free Run mode, once the first set of data is processed, the analysis continues processing new sets of
histogram data and updates the measurement readouts until you click the Stop button.

See Also:
Measurement Methodology (see page 17)
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Remote Control Introduction
You can control the 80SJARB application through the programmatic interface (PI) of the sampling
oscilloscope on which it is running. You communicate with the application by using VARIABLE:VALUE
remote GPIB commands.

Use the PI command APPlication:ACTivate “80SJARB” to start the 80SJARB application.

Your program should comply with the following guidelines:

The 80SJARB application startup must complete before sending GPIB commands to the application.
Querying the variable “Application” returns “80SJARB” when the application startup is complete.

The measurements cycle must complete before you query data. Querying the variable
“SequencerState” returns “Stop” when the data is ready.

Because the oscilloscope software hosts the GPIB interface for the 80SJARB application, there is some
additional information that is helpful for successful programming.

See Also:
GPIB Reference Materials (see page 19)

Programming Tips (see page 20)

Syntax (see page 22)

80SJARB GPIB Commands (see page 22)

Error and Warning Codes and Messages (see page 24)

GPIB Reference Materials
To use GPIB commands with your oscilloscope, see the programmer manual for your oscilloscope.

See Also:
Remote Control Introduction (see page 19)

Programming Tips (see page 20)

Syntax (see page 22)

80SJARB GPIB Commands (see page 22)

Error and Warning Codes and Messages (see page 24)
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Programming Tips

How the Variable Value Table Works
Programmable Interface (PI) commands for the 80SJARB appliation use a variable/value table.
This table associates named variables with text values. These values are set (variable:value
“VariableName”,“VariableValue”) or queried (variable:value? “VariableName”) from the PI.

If the variable does not already exist in the table when a set command is received, that variable is created
and the specified value is associated with that variable. If the variable is already in the table, the specified
value replaces the existing value. There is no checking done by the table on variable names or values.
Since both items are strings, any arbitrary pair of strings can be associated with each other in this table.

Polling and Limit of Variable Values
Each time a change is made to a variable’s value in the table, an event is generated. The 80SJARB
software application polls the oscilloscope software application every 200 ms to see if an event occurred.
If so, 80SJARB queries for the event information which tells 80SJARB which variable changed and
the new value. 80SJARB parses this information to find the variables pertinent to its operation and
reads the new values for those variables. These new values can change the state of 80SJARB (such as
changing the state of the free-run mode) or can cause 80SJARB to perform an operation (such as setting
the sequencer mode to Run).

Because 80SJARB polls for changes at a fixed rate, the oscilloscope application may indicate that a list
of variables has changed since the last time 80SJARB polled for changes. A result of this operation is
when 80SJARB receives a list of changes but does not necessarily execute those changes in the order
in which they were sent. For example, sending a command to change the sequence mode (such as
“SequenceMode”,“Freerun”) followed immediately by a command to start a measurement sequence
(“SequencerState”,“Run”) does not guarantee that the sequencer mode changed before 80SJARB began
the sequencing operation. To enable the proper execution order of these commands, insert a delay of at
least 400 ms before the SequencerState command.

How the Variable Value Table is Updated
80SJARB updates table entries when sequencing is started and when there is new data to report. For
example, if an error occurs during sequencing, 80SJARB updates the variables “ErrorCode” and
“ErrorMessage” with new values. These values are set to null strings when sequencing starts again.

Variables to set to null strings (“”) before starting a sequence operation include:

ErrorCode

ErrorMessage

WarningCode

WarningMessage

All measurement values
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Determining if 80SJARB is Running
The “Application” variable indicates the run status of the 80SJARB application. When it is running, this
variable is set to “80SJARB”. When 80SJARB exits normally, the variable is set to “Done”. However, if
the application encounters an error and exits abnormally, 80SJARB does not set the “Application” variable
to “Done”, leaving the variable set to “80SJARB”. If you are not sure that 80SJARB is running, you can
send the command to start it again. If 80SJARB is already running, the new copy immediately exits
(only one copy of 80SJARB can run at a time).

See Also:
Remote Control Introduction (see page 19)

GPIB Reference Materials (see page 19)

Syntax (see page 22)

80SJARB GPIB Commands (see page 22)

Error and Warning Codes and Messages (see page 24)
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Syntax
The VARIABLE:VALUE command structure accepts string arguments for a control or data variable and
a value to which to set the argument.

To set a variable to a value:

VARIABLE:VALUE "<VariableName>","<VariableValue>"

For example:

VARIABLE:VALUE "SequencerState","Stop"

NOTE. The arguments <variable name> and <variable value> are required in the order shown with no
spaces allowed.

To query the value in a variable:

VARIABLE:VALUE? <variable name>

For example:

VARIABLE:VALUE? "TJ"

NOTE. The <variable name> and <variable value> arguments are case and space sensitive. The program
will not operate correctly if you do not follow the capitalization and spacing precisely.

See Also:
Remote Control Introduction (see page 19)

GPIB Reference Materials (see page 19)

Programming Tips (see page 20)

80SJARB GPIB Commands (see page 22)

Error and Warning Codes and Messages (see page 24)

80SJARB GPIB Commands
Use the PI command APPlication:ACTivate “80SJARB” to start the 80SJARB application. This
command also wakes up the application when it is in the hibernate state.

The following table lists the 80SJARB application commands. These arguments are in addition to the
instrument and module PI arguments.
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Variable Value(s) Description Query form returns
Application Exit | Hibernate Exits the application or

enters the application
hibernate mode

Done

DJdd Returns the deterministic
jitter computed using the
Dual-Dirac method

Current value
0 = results have been cleared

ErrorCode Returns a numeric code
corresponding to the last
error

Current value
0 = errors have been cleared

ErrorMessage Returns the last error
message

Current value
"" = errors have been cleared

Hits Returns the number of hits
in the processed histogram

Current value
0 = results have been cleared

J2 Returns the measured J2
value

Current value
0 = results have been cleared

J9 Returns the measured J9
value

Current value
0 = results have been cleared

RJdd Returns the random
jitter computed using the
Dual-Dirac method

Current value
0 = results have been cleared

SequencerMode {SingleSequence |
Freerun}

Sets or returns the
sequencer mode
Startup default is Free Run

Sequencer mode

SequencerState {Run | Stop} Sets or returns the
Measurement Sequencing
or the Stop Sequencing
command

Sequencer state

TJ Returns the measured total
jitter at BER 1E-12

Current value
0 = results have been cleared

WarningCode Returns a numeric code
corresponding to the last
warning code

Current value
0 = warnings have been cleared

WarningMessage Returns the last warning
message

Current value
"" = warnings have been cleared

xxx

See Also:
Remote Control Introduction (see page 19)

GPIB Reference Materials (see page 19)

Programming Tips (see page 20)

Syntax (see page 22)

Error and Warning Codes and Messages (see page 24)
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Error and Warning Codes and Messages
Table 1: Error codes and messages
Error code Error message Description
1 Error: No waveform

is selected.
No waveforms have been turned on. Turn on the channel or math waveform
on which you want to take measurements.

2 Error: Selected
waveform is not a
channel or math.

The selected waveform is a reference waveform. 80SJARB cannot take
measurements on a reference waveform.

3 Error: Waveform
database is not
available.

All waveform databases are in use and none are available for use on the
selected channel. Turn off at least one waveform database to make it
available to take measurements.

4 Error: Measurement
slot is not available.

All measurement slots are in use. Set at least one measurement slot type to
NONE to make it available for use by 80SJARB.

5 Error: Histogram is
not available.

The histogram is assigned to a waveform other than the selected waveform.
Turn the histogram off or set its source to the selected waveform.

6 Error: Could not find
the bit crossing level.

The oscilloscope measurement system reports an error when it cannot
find the bit crossing level of the eye diagram. In most cases this error is
generated because the eye diagram does not show an open eye, or one
of the crossings is too close to the edge of the screen or is off the screen.
Make sure that the oscilloscope displays an open eye diagram.

7 Error: Could not find
the bit crossing time.

The oscilloscope measurement system reports an error when it cannot
find the bit crossing time of the eye diagram. In most cases this error is
generated because the eye diagram does not show an open eye, or the left
transition is too close to the edge of the screen or is off the screen. Make
sure that the oscilloscope displays an open eye diagram.

8 Error: Could not
measure the bit
interval.

The oscilloscope measurement system reports an error when it cannot find
the bit interval of the eye diagram. In most cases this error is generated
because the eye diagram does not show an open eye, or one of the
crossings is too close to the edge of the screen or is off the screen. Make
sure that the oscilloscope displays an open eye diagram.

9 Error: Could not
measure the signal
amplitude.

The oscilloscope measurement system reports an error when it cannot
measure the amplitude of the signal. Make sure that the signal is not larger
than the dynamic input range of the sampling module.

10 Error: Could
not measure the
peak-to-peak jitter.

The oscilloscope measurement system reports an error when it cannot
measure the amplitude of the peak-to-peak jitter on the left crossing of the
eye. In most cases this error is caused because the eye diagram does
not show an open eye, or one of the crossings is too close to the edge of
the screen or is off the screen. Make sure that the oscilloscope displays
an open eye diagram.

11 Error: More than one
eye on the main time
base.

The oscilloscope is displaying more than one eye diagram associated with
the main time base. 80SJARB only works properly with one eye diagram
displayed on the main time base.
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Table 1: Error codes and messages (cont.)

Error code Error message Description
98 Error: Measurement

error.
The oscilloscope has returned a measurement error that is not covered by
one of the error codes above.

99 Error MATLAB error. An error occurred in MATLAB that was not otherwise handled.
xxx

Table 2: Warning codes and messages
Warning code Warning message Description
1 Warning: Low

Resolution.
Several conditions can cause this warning to be issued, including:

An insufficient number of points in the histogram.

The histogram is distributed in only a few vertical columns.
xxx

See Also:
Remote Control Introduction (see page 19)

GPIB Reference Materials (see page 19)

Programming Tips (see page 20)

Syntax (see page 22)

80SJARB GPIB Commands (see page 22)
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