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Warranty
Tektronix warrants that this product will be free from defects in materials and workmanship for a period of one (1) year from the date of
shipment. If any such product proves defective during this warranty period, Tektronix, at its option, either will repair the defective
product without charge for parts and labor, or will provide a replacement in exchange for the defective product. Parts, modules and
replacement products used by Tektronix for warranty work may be new or reconditioned to like new performance. All replaced
parts, modules and products become the property of Tektronix.

In order to obtain service under this warranty, Customer must notify Tektronix of the defect before the expiration of the warranty period
and make suitable arrangements for the performance of service. Customer shall be responsible for packaging and shipping the
defective product to the service center designated by Tektronix, with shipping charges prepaid. Tektronix shall pay for the return of the
product to Customer if the shipment is to a location within the country in which the Tektronix service center is located. Customer shall
be responsible for paying all shipping charges, duties, taxes, and any other charges for products returned to any other locations.

This warranty shall not apply to any defect, failure or damage caused by improper use or improper or inadequate maintenance and
care. Tektronix shall not be obligated to furnish service under this warranty a) to repair damage resulting from attempts by personnel
other than Tektronix representatives to install, repair or service the product; b) to repair damage resulting from improper use or
connection to incompatible equipment; c) to repair any damage or malfunction caused by the use of non-Tektronix supplies; or
d) to service a product that has been modified or integrated with other products when the effect of such modification or integration
increases the time or difficulty of servicing the product.

THIS WARRANTY IS GIVEN BY TEKTRONIX WITH RESPECT TO THE PRODUCT IN LIEU OF ANY OTHER WARRANTIES,
EXPRESS OR IMPLIED. TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE. TEKTRONIX’ RESPONSIBILITY TO REPAIR OR REPLACE DEFECTIVE PRODUCTS
IS THE SOLE AND EXCLUSIVE REMEDY PROVIDED TO THE CUSTOMER FOR BREACH OF THIS WARRANTY. TEKTRONIX
AND ITS VENDORS WILL NOT BE LIABLE FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES
IRRESPECTIVE OF WHETHER TEKTRONIX OR THE VENDOR HAS ADVANCE NOTICE OF THE POSSIBILITY OF SUCH
DAMAGES.
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Preface

Preface
TekExpress is the Tektronix Compliance Test Automation Framework, developed to support current and future test
automation needs of customers. Developed using National Instruments’ TestStand, TekExpress leverages on the capabilities
of the Microsoft .NET framework. The TekExpress DiiVA Automated Solution meets the DiiVA draft specification, and
automates a comprehensive range of tests, enabling unprecedented efficiency with reliable results.

Key Features
The key features of the application are:

Reliable testing:

Conformance to DiiVA standards and test specifications CTS draft ensures reliable results

Complete validation to standards with wide range of tests

Sophisticated measurement techniques eliminate errors in jitter measurements

Closed loop measurements eliminate nonlinearities of test setup enable precise sink tests

Optimal setups ensure accurate results

Quick testing:

Remote control of signal sources automates sink tests and cuts test times

Automatic Mask-fit, measurements and Pass/Fail notification delivers quick results

One-button selection of multiple tests ensures faster testing

Mask margins aid analysis and help find answers quickly

One-button .MHT report saves time

Documentation
This manual describes how to install and operate the TekExpress DiiVA application. For more detailed information, see the
online help. The following information is available for this product:

Table i: Related documentation
TekExpress DiiVA Online Help, English 076-0225-XX

TekExpress DiiVA User Manual, English (PDF)
TekExpress DiiVA Quick Start User Manual,
English (PDF) (this manual)

077-0507-XX
077-0508-XX
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Preface

Software Upgrades
Periodic software upgrades may become available. To check for upgrades:

1. Go to the Tektronix Web site (www.tektronix.com/software).

2. Enter the product name (TekExpress DiiVA) in the Search Software field.

3. Click GO.
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Install the Software

Install the Software
You must install the TekExpress application on a computer or on a Tektronix Microsoft Windows-based oscilloscope.

Before Installation
Read the Readme.txt file provided with the product software.

Prerequisites
The following items must already be installed before installing the TekExpress DiiVA application:

Microsoft Windows XP Service Pack 2.

Microsoft .NET Framework

National Instruments TestStand Run time Engine

OpenChoice TekVISA

DK2 DESKey Driver

TekExpress Framework

Installation
1. Close all applications.

2. Download DiiVAWebinstaller_<version>.EXE from the Web.

3. Double-click the executable to extract the files. After extraction, the DiiVA installer launches and the software is installed
in C:\Program Files\Tektronix\TekExpress.

TekExpress DiiVA Quick Start User Manual 1



Install the Software

Required Test Equipment
The following equipment is required, depending on the tests that you will be running:

Tektronix DPO/DSA71254, DPO/DSA71604, and DPO/DSA72004 Series Digital Oscilloscopes, Tektronix
DPO/DSA71254B, DPO/DSA71604B, and DPO/DSA72004B Series Digital Oscilloscopes, Tektronix MSO71254,
MSO71604, and MSO72004 Series Mixed Signal Oscilloscopes

Tektronix P7313 SMA differential probes (quantity two or four) with matched pair cables

Golden DiiVA Video Sink board

Golden DiiVA Video Source board

TF-DiiVA-TPA-P plug, TF-DiiVA-TPA-R receptacle, and TF-DiiVA-C calibration fixture

SMA cables (quantity eight)

DC blocks (quantity eight)

Barrel connectors (quantity two or eight)

Start the Software
To start the software, do one of the following:

From the Start menu, select Start > Programs > Tektronix > TekExpress > TekExpress DiiVA.

Double-click the TekExpress DiiVA icon on the desktop.

Close the Software
To close the software, do one of the following:

Select File > Exit.

Click .

2 TekExpress DiiVA Quick Start User Manual



Using the Software

Using the Software
The following steps describe a typical compliance test process. Details for each of these steps are given on the following
pages.

1. Set up the equipment.

2. Select a device.

3. Select the lane configuration (number of video lanes and target lanes) and CTS version.

4. Select the test.

5. Configure the test parameters.

6. View and select connected instruments.

7. Run the test.

8. View the progress of acquisition.

9. View the progress of analysis.

10. View and print the generated report.

TekExpress DiiVA Quick Start User Manual 3



Using the Software

Connect and Configure the Equipment
The Application Examples section describes the equipment connections in detail.(See page 10, Application Examples.)

You can click Show Schematic to display a diagram of the test setup for each of the test suites.

Select a Device, Lane Configuration, and Test
1. Click the Select tab.

2. Select a Device.

3. Select Video Link or Hybrid Link, or both.

4. Select the Video Link Bitrate.

5. Select the Hybrid Link Speed.

6. Select the test to run. You can select
multiple tests from the list.

4 TekExpress DiiVA Quick Start User Manual



Using the Software

7. Define the Lane Configuration.

Select the number of video lanes.

Select the video lane combination.

8. Select the target lanes for Video Link
measurements and the Hybrid Lane for
Hybrid Link measurements.

9. Choose the version of the selected test
suite from the Version drop-down list.

10. Click Show Schematic to see the
schematic diagram of the test setup.

Configure the Test Parameters
1. Click the test name to configure.

2. Click Configure.

TekExpress DiiVA Quick Start User Manual 5



Using the Software

3. If multiple instruments are connected,
choose the correct instrument from the
parameter-value list.

4. The Compliance Mode is selected
by default. You can use the default
settings in Compliance Mode. Click the
Acquire tab to view parameters related
to acquisition.

NOTE. Use the User Defined Mode to
change the parameter values as required. If
you do so, you will not be testing the device
against the values specified for compliance.

5. Click the Analyze tab to view analysis
parameters.

6 TekExpress DiiVA Quick Start User Manual



Using the Software

6. Click the Limits tab to view the
measurement limits.
See the online help for various test limit
comparisons.

7. Click the Comments tab to enter
test-specific comments.

8. Click Cancel.
NOTE. Use the File menu to save the
session.

TekExpress DiiVA Quick Start User Manual 7



Using the Software

Run the Test
1. Click Run to run the test.

2. Click Acquire to view the waveform
acquisition details for the tests in the
sselected test suite.

3. Click Analyze while the tests are running
to view the status and progress of the
tests. The application checks to see if
the device has passed the test.
The application displays run-time
messages with time-stamp data.

8 TekExpress DiiVA Quick Start User Manual



Using the Software

Interpret the Test Result
The report summary appears when the test complete. Check the report to see if the device passed the test.

1. The report displays the DUT ID, the date
and time the test was run, and execution
time.

2. Test information like the Device Type,
Version, Execution Time, Compliance
Mode (Yes or No), and Overall Test
Result (Pass or Fail), are shown.

3. The test results include iInstrument
information such as the models,
serial numbers, and firmware/software
versions are shown.

4. A table displays the Test Name, Lane,
Channel and Speed, Measurement
Details, Low and High Limits, Margin,
Test Result, Compliance Mode, Analysis
Time, and Comments.

Generate, Save, and Print a Report
A report summary is generated in MHT format after you have successfully run one or more test(s).

To save the report summary, select File > Save Report As.

To preview the report before printing, select File > Print Preview Report.

To print the report, select File > Print Report.

TekExpress DiiVA Quick Start User Manual 9
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Application Examples
The measurements are classified based on the test pattern. The following examples show a test individually for both video
link and hybrid link. For details on other tests, see the TekExpress DiiVA Automated Solution online help.

Upstream Video Link Test: Differential Pk-Pk Voltage
This test checks the DUT for compliance with upstream video link tests.

Required equipment Description or quantity
Oscilloscope with DiiVA test automation software installed Tektronix DPO/DSA71254, Tektronix DPO/DSA71254,

Tektronix DPO/DSA71604, Tektronix DPO/DSA72004,
Tektronix MSO71254, Tektronix MSO71604, or
TektronixMSO72004 oscilloscope

Differential Probes with matched pair cables Two Tektronix P7313 probes
Golden DiiVA Sink board used as HLCS Test Controller
and TPA

One

TF-DiiVA-TPA-P test fixtures Two
SMA cables Six

Tektronix part number 174-1428-00 (1.5 meter)
Tektronix part number 174-1341-00 (1 meter)

DC blocks Six
50 Ω terminators Six

10 TekExpress DiiVA Quick Start User Manual



Application Examples

1. Connect the DUT to the equipment as shown.

Connect the DUT to the TF-DiiVA-TPA-P fixture.

Connect the TF-DiiVA-TPA-P board to the oscilloscope using the probes (three pairs, one for each video lane).

NOTE. Always attach all lanes through DC blocks, since these lines can carry 5 V power.

Connect the second TF-DiiVA-TPA-P board to Golden DiiVA Sink board.

Connect the TF-DiiVA-TPA-P board to the second TF-DiiVA-TPA-P board using two SMA cables or barrel adapters.

Terminate unused lanes with 50 Ω after connecting the DC blocks.

Connect a USB cable from the controlling device to the HLCS/μC Control Port input of the Golden DiiVA Sink board.

TekExpress DiiVA Quick Start User Manual 11



Application Examples

2. Launch TekExpress DiiVA.

3. Enter the DUT ID.

4. Select the device as DiiVA UpStream.

5. Select Test 2.2.2.2-Differential Pk-Pk
Voltage Measurement VTX-DIFF-PP.

6. Set the number of video lanes toOne.

7. Set the VL Combination toVL0

8. Set the Video Link Bitrate to4.5 Gbps.

9. Select the CTS version.

10. Click Configure to open the configuration
panel.

12 TekExpress DiiVA Quick Start User Manual



Application Examples

11. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. To change acquisition parameter
values, click User Defined Mode. A message
appears prompting you that if you make
changes to a test, the test may no longer
be compliant. Click OK to proceed with the
User Defined Mode.

12. Click Cancel

13. Click Acquire.

14. Set the channel for the video lane to VL0.

15. Click Run.

16. When prompted, check the channel and
probe connections. Click OK.

TekExpress DiiVA Quick Start User Manual 13



Application Examples

17. When prompted, configure the DUT
to transmit the pattern at the selected
speed. Click OK.

18. The application prompts you to confirm
on the generation of the test pattern.
Click OK.

19. The application automatically switches to
the Analyze tab. The application displays
the status of the tests in the Status
Messages window. Click Save Status to
save the status messages.

14 TekExpress DiiVA Quick Start User Manual



Application Examples

20. When the tests complete, the application
shows a report in the Report tab.
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Application Examples

Upstream Hybrid Link Test: Differential Pk-Pk Voltage
This test checks the DUT for compliance with upstream hybrid link tests.

Required equipment Description or quantity
Digital Storage Oscilloscope with DiiVA test automation
software installed

Tektronix DPO/DSA71254, Tektronix DPO/DSA71254,
Tektronix DPO/DSA71604, Tektronix DPO/DSA72004,
Tektronix MSO71254, Tektronix MSO71604, or
TektronixMSO72004 oscilloscope

Differential Probe with matched pair cables One Tektronix P7313 probe
Golden DiiVA Video Sink board used as HLCS Test
Controller and TPA

One

TF-DiiVA-TPA-P test fixtures Two
SMA cables Two

Tektronix part number 174-1428-00 (1.5 meter)
Tektronix part number 174-1341-00 (1 meter)

DC blocks Two
50 Ω terminators Six
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Application Examples

1. Connect the DUT to the equipment as shown.

Connect the DUT to the first TF-DiiVA-TPA-P board.

Connect the second TF-DiiVA-TPA-P board to the Golden DiiVA Sink board.

NOTE. Always attach all lanes through DC blocks, since these lines can carry 5 V power.

Connect the hybrid link of the two TF-DiiVA-TPA-P fixtures using SMA cables or barrel adapters.

Connect the hybrid link output from the Golden DiiVA Sink board to the oscilloscope channel using the differential probes.

Terminate the unused lanes with 50 Ω after connecting the DC blocks.

Connect a USB cable from the controlling device to the HLCS/μC Control Port input of the Golden DiiVA Sink board.
During manual operation, commands are manually sent to the Golden DiiVA Sink board.
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Application Examples

2. Launch TekExpress DiiVA.

3. Enter the DUT ID.

4. Select the device as DiiVA UpStream.

5. Select Test 2.3.3.2-Differential Pk-Pk
Voltage Measurement VHTX-DIFF-PP.

6. Set the Hybrid Link Speed to All.

7. Select the Target Lane as Hybrid Lane.

8. Select the CTS version.

9. Click Configure to open the configuration
panel.
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Application Examples

10. Use the default values in the Compliance
Mode to run the tests for compliance with
the standards.

NOTE. To change acquisition parameter
values, click User Defined Mode. A message
appears prompting you that if you make
changes to a test, the test may no longer
be compliant. Click OK to proceed with the
User Defined Mode.

11. Click Cancel.

12. Click Acquire

13. Select the channel for the hybrid lane.

14. Click Run.

15. When prompted, check the channel
connections and click OK.
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Application Examples

16. When prompted, configure the DUT
to transmit the pattern at the selected
speed, and click OK.

17. When prompted, program the DUT to
generate the test pattern. Click OK.

18. Repeat steps 15 through 17 for each of
the speeds.

19. The application automatically switches to
the Analyze tab. The application displays
the status of the tests in the Status
Messages window. Click Save Status to
save the status messages.
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Application Examples

20. When the tests complete, the application
shows a report in the Report tab.
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Application Examples

22 TekExpress DiiVA Quick Start User Manual



Index

Index

A
Acquire, 8
Analyze, 8

C
Compliance mode, 6
Configure, 5

Acquire panel, 6
Analyze panel, 6
Comments panel, 7
Limits panel, 7

Connections
Hybrid link, 17
Video link, 11

D
DC blocks, 10, 16
Device, 4
DiiVA UpStream, 12, 18

E
Equipment, 2

G
Golden DiiVA Sink board, 10
Golden DiiVA Video Sink board, 16

H
Hybrid lane, 18
Hybrid link

Differential Pk-Pk Voltage
Measurement, 18

I
Installation, 1

L
Lane configuration, 5

M
Multiple tests, 4

P
Prerequisites, 1
Probe, 10, 16

R
Readme, 1
Real-time oscilloscope, 10, 16
Report

generate, 9
MHT, 9
previewing, 9
print, 9
printing, 9
save, 9
saving, 9

Run
test, 8

S
Show Schematic, 2, 5
SMA cables, 10
SMA Cables, 16

Software
closing the, 2
process flow, 3
starting the, 2
upgrades, iii

Status messages, 8

T
Terminators, 10, 16
Test

configuring, 5
details, 9
interpreting the result, 9
parameters, 5
report, 9
running, 8
selecting, 4

Test fixtures, 10, 16
Test suite

version, 5

U
User defined mode, 13, 21

V
Video link

Differential Pk-Pk Voltage
Measurement, 12

TekExpress DiiVA Quick Start User Manual 23


	toc
	Preface
	Key Features
	Documentation
	Software Upgrades

	Install the Software
	Before Installation
	Prerequisites
	Installation
	Required Test Equipment
	Start the Software
	Close the Software

	Using the Software
	Connect and Configure the Equipment
	Select a Device, Lane Configuration, and Test
	Configure the Test Parameters
	Run the Test
	Interpret the Test Result
	Generate, Save, and Print a Report

	Application Examples
	Upstream Video Link Test: Differential Pk-Pk Voltage
	Upstream Hybrid Link Test: Differential Pk-Pk Voltage



