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Preface
About This Manual

This manual describes the functions and features of the TimeView™ Modulation
Domain Analyzer Software application. The TimeView application supports
the following Tektronix instruments:
FCA3000 Series (FCA3000, FCA3003, and FCA3020)
Timer/Counter/Analyzers
FCA3100 Series (FCA3100, FCA3103, and FCA3120)
Timer/Counter/Analyzers
MCA3000 Series (MCA3027 and MCA3040) Microwave Counter/Analyzers
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Running TimeView Software and Hardware Connection
You must connect TimeView to the FCA3000, FCA3100, or MCA3000 Series
instrument before you can take and analyze measurements in the TimeView
application.
NOTE. You can also view saved data files in TimeView. However, a very limited
set of functions is available when viewing a saved data file as opposed to taking
and analyzing a live measurement acquisition.

Connecting the Instrument
Do the following to connect the instrument to TimeView:
1. Open the TimeView application.
2. Use a USB or GPIB cable to connect the instrument to the PC with the
TimeView software.
3. Turn on the instrument and wait for about 10 seconds. Verify that the
instrument is set for the correct remote connection (USB or GPIB).
4. In TimeView, click Instrument > Connect. TimeView automatically
recognizes the instrument and opens a dialog box listing the instrument.
5. Click OK. The main TimeView window changes to enable the tool bar
functions.

Disconnecting the
Instrument from TimeView

To disconnect the instrument from the TimeView software, click Instrument >
Disconnect. You can now disconnect the instrument from the USB or GPIB
cable and/or power off the instrument.
NOTE. You must disconnect the instrument from the TimeView software before
powering down the instrument.

TimeView User Manual
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Interface Overview
The following pages describe the TimeView application interface and functions.

The TimeView application window contains the Menu bar, the Toolbar, the
Capture Data area, the Graph area, and the Status readout.
1. Menu bar (See page 4, The Menu Bar.)
2. Toolbars (See page 8, The Toolbars.)
3. Graph area (See page 18, The Graph Area.)
4. Status readout (See page 22, The Status Readout.)
5. Information tabs (See page 16, The Capture Data Area.)

TimeView User Manual
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The Menu Bar
The Menu bar provides access to all TimeView functions. The following sections
describe each menu item.

File Menu
Item

Description

Open

Opens a data file created by the TimeView application.
*.ssd – Free Running Measurement File
*.rsd – Repetitive Sampling Data File
*.wad – Waveform Data File
*.tsd – Time stamp Data File

Save As

Saves the current captured waveform data (not available with
30-day trial version of software).

Load/Save settings

Loads/Saves the current application configuration to allow easy,
quick switching between different types of measurements.

Print

Prints the active graph. If zoomed, only the zoomed part is
printed (not available with 30-day trial version of software).

Recent files

Lists recently opened waveform data files. This area remains
blank until the first file is opened.

Item

Description

Connect/Disconnect

Connects or disconnects a product instrument to the TimeView
application.

Instrument Menu

NOTE. Always use this menu item to disconnect the instrument
from the TimeView application before disconnecting the USB or
GPIB cable from the instrument or computer.
GPIB/USB Timeout

4

Sets the amount of time the application will wait for data from
the instrument before incurring a time-out error. This is an
instrument-specific menu item and is only available for particular
product equipment.
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Item

Description

Settings

Configures connected counter settings. Opens a window with
access to all configurable settings available on the instrument.
The functions present in the window are instrument dependent,
that is, different instruments may have different settings.

NOTE. Selecting Default Settings in the Counter Settings

dialog box will reset all tabs of the instrument settings to their
defaults, not just those settings on the selected tab.

Load Default Settings

Resets the counter to its default configuration. This does not
affect TimeView application settings, though the application
toolbar will show instrument setting changes.

Capture Menu
Configures settings to control capture and display of waveforms.
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Item

Description

Free Running

Captures the selected measurement function in a continuous
block of time.

Repetitive Sampling

Captures the selected measurement function, such as frequency
at delayed time intervals. Requires external arming.

Waveform

Captures the shape of the waveform in terms of voltage versus
time.

Raw Timestamp

Captures trigger level crossings on the measured waveform. The
captured data consists of groups each containing four samples.
Time marks are displayed by a square wave with its positive and
negative transitions corresponding to the positive and negative
transitions of the measured waveform.

Totalize (FCA3100
Series only)

Performs different arithmetic combinations of two waveforms
measured on the A and B channels. After the measurement
is taken the arithmetic combinations are available through the
shortcut menu on the graph (right-clicking on the graph area).

Start selected capturing

Captures waveform data as set by the current measurement
configuration.

Abort current capturing

Stops a continuous capture.

Continuous

Will continuously capture waveform data per the current
measurement configuration until manually interrupted.

Measurement Readout

Displays a real-time readout of a selected measurement function
in a separate window. Measurement Readout is only available
when Capture Type is set to Free Running.

Signal Readout

Displays a snapshot summary of basic information about the
current signal read by the counter. Click Update to refresh the
display.
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Item

Description

Settings

The settings window mirrors all of the functions available on the
toolbar for each of the different Capture Types. (See page 11,
Time Stamp.)

Load Default Settings

Loads the TimeView application default settings.

Item

Description

Source Data

Displays the raw data as collected per the measurement function
setting.

Histogram

Displays the data as a histogram.

Spectrum

Displays the data in its frequency spectrum using the FFT.

Smooth

Displays a waveform based on the averaging of a user definable
number of coincident points.

Options

Displays additional settings related to the Tools menu items:

Tools Menu

Bin Units toggles the y-axis to have units of either a percentage
of samples per bin, or number of samples per bin.
Number of Bins changes the granularity of the range of values
associated with each bin, or bar, in the histogram.
Auto FFT Size enables the application to determine the ideal
number of points to compute the FFT if selected.
Rectangular, Hamming, Hanning window sets the type of
windowing algorithm to use for FFT measurements.
Number of average sets the number of coincident points to use
when finding the average value for a particular point. This will
affect the total number of points displayed on the graph. For
example, with 100 samples, a value of 50 would reduce the total
number of points on the graph to 50.

Graph Menu
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Item

Description

Cursor Style

Changes the cursors displayed on the graph to a small circle,
medium rectangle, or large cross.

Data Draw Style

Sets the line styles to use for data display.

Color Theme

Controls the colors of graphical objects. You can create and
save one custom theme, which is automatically saved when
you click OK.

TimeView User Manual
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Item

Description

Zoom In/Zoom Out

Zooms in and out on the graph; however, a better way to zoom
is to click-and-hold on the graph while dragging the dotted
rectangular box formed by the click-and-hold action over the
desired region.

Clear All

Deletes the collected data, removing the graphs, and numerical
data.

NOTE. You cannot undo this operation.
Vertical Axis Range,
Horizontal Axis Range

Allows manual definition of magnitudes of units and ranges to
show on the axes.

Item

Description

Panes Layout

Changes the number of graphs that appear in the graph pane.
You can display up to four graphs simultaneously. Each new
graph is randomly chosen from the options remaining. To change
the graph appearing in one of the new graph sub-panes, click
that sub-pane, and select the desired graph from the Tools menu
or the toolbar.

Toolbar Standard

Enables or disables displaying the Standard toolbar.

Toolbar Counter

Enables or disables displaying the Counter toolbar.

Toolbar Measuring

Enables or disables displaying the Measuring toolbar.

Information Pane

Enables or disables displaying the data information pane.

Item

Description

Help

Opens the TimeView online help window.

About TimeView

Displays TimeView software version number and PC/instrument
configuration information.

Registration

Opens a dialog box that lets you register the TimeView
application. Software registration is not available for the 30-day
free trial version of the software; you must purchase the
TimeView software CD to obtain a registration key.

View Menu

Help Menu

TimeView User Manual
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The Toolbars

The toolbars provide fast access to most of the functions available in the
application menus. There are three toolbars:
The Standard toolbar (See page 8, The Standard Toolbar.)
The Counter toolbar (See page 12, The Counter Toolbar.)
The Measurement toolbar (See page 13, The Measurement Toolbar.)

The Standard Toolbar

Figure 1: Standard toolbar
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Item

Description

Open File

Opens a data file created by the TimeView application.
*.ssd – Free Running Measurement File
*.rsd – Repetitive Sampling Data File
*.wad – Waveform Data File
*.tsd – time stamp Data File

Save Data

Saves the current captured waveform data (available with the
licensed version of the application) per the types listed in Open
File.

Print

Prints the active graph. If zoomed only the zoomed part is printed
(available with the licensed version of the application).

TimeView User Manual
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Item

Description

Capture Type

The list of types displayed in the menu changes based on
connected hardware. Five capture types exist over all hardware
lines:
Free Running captures the selected measurement function in a
continuous block of time.
Repetitive Sampling captures the selected measurement
function (such as frequency) at delayed time intervals. Requires
external arming.

NOTE. Once external arming is activated, the instrument uses
external arming for all other capture types until it is disabled.
Time Stamp captures trigger level crossings on the measured
waveform. The captured data consists of groups each containing
four samples. Time marks are displayed by a square wave
with its positive and negative transitions corresponding to the
measured waveform and its trigger level crossings with positive
and negative slope. Up to 125 kHz (interpolator calibration ON) or
250 kHz (interpolator calibration OFF), all transitions can be time
stamped, both positive (+ Slope) and negative (- Slope). Above
these limits, there is a certain dead time, 8 µs or 4 µs, before the
next group is recorded. Changing the pacing parameter can also
extend the sampling interval. (See Figure 2 on page 11.)
Totalize (FCA3100 Series only) allows different arithmetic
combinations of two waveforms measured on the A and B
channels. After the measurement is performed, the arithmetic
combinations are available through the shortcut menu on the
graph (right-clicking on the graph area).
Waveform captures the shape of the waveform in terms of
voltage versus time.

TimeView User Manual

Continuous Capture

Continually collects data, and displays each collection until
manually stopped, at which point the last collected and displayed
data is kept.

Run Capture

Runs the measurement.

Stop Capture

Stops the current measurement.

Source Graph

Displays a graph of the data as collected per the measurement
function with no manipulation.

Histogram

Displays a graph of the collected data in a histogram. Uses the
Histogram settings available in the Tool Options dialog box.

FFT

Displays a graph of the collected data after application of a FFT.
Uses the FFT settings available in the Tool Options dialog box.

Smooth Graph

Applies a smoothing algorithm to the a graph of the collected
data. Uses the Smooth settings available in the Tool Options
dialog box.
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Item

Description

Zoom

Zooms the current graph in or out about the midpoint of the
x-axis by dividing or multiplying the total time displayed on the
x-axis by 2.
You can use the cursors to zoom on an area of interest. Position
the cursors on the graph (See page 19, Cursors.) Then right-click
the graph and select Zoom In To Cursors.
You can also click and hold on the graph to zoom in on the area
of interest on the graph.

NOTE. Auto Range must be selected in the Define Axis window

to enable the toolbar zoom functions. The Define Axis window is
accessed in the graph shortcut menu. (See page 19, The Graph
Shortcut Menus.)
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Graph Layout

Controls how many graphs (up to four) are displayed in the graph
pane.
You can configure each new sub-pane in the graph pane to
display a different type of graph by clicking in the desired
sub-pane and selecting one of the four different types of graphs
(Source, Histogram, FFT, Smooth) from the toolbar.

About

Displays information about the TimeView application.

Help

Opens the TimeView help documentation to information about
that specific piece of the application if it exists.

TimeView User Manual
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Time Stamp

Figure 2: Raw time stamp example
The preceding figure displays the result of a raw time stamp function on a 10 MHz
periodic input signal, zoomed to show only one group. The group consists of
four time stamps taken on consecutive trigger level crossings, without dead
time. So the time stamps in this case are recorded every 50 ns. The time to the
next group of time stamps is set by the pacing parameter. Its setting range is 0
to 500 seconds, but the real minimum time is 4 µs or 8 µs, the latter value being
valid if the interpolator calibration is ON. You can see the influence of the pacing
by zooming out the graph.
However, the counter that accumulates clock ticks every 10 ns is not interrupted
but read off at the pacing intervals. From there the basic 10 ns resolution can be
improved to 100 ps (FCA3000 Series) or 50 ps (FCA3100 Series) by the analog
interpolators that are continually calibrated, if this function is activated. The
trade-off is the longer dead time. The cursors (red and green X’s) are positioned
to measure one period of the input waveform from one zero crossing to the next
with positive slope.
You also need an event counter to keep track of the total number of periods of
the input signal at the time stamps recorded for the positive transitions. You can
see the contents of this counter as a new graph by right-clicking in the graph and
then selecting Event Count from the pop-up menu.
By combining event and time stamp data in a postprocessing block, you can
calculate the statistics functions ADEV and MADEV, also by right-clicking in the
Trigger Event graph and selecting the desired function from the pop-up menu.

TimeView User Manual
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The Counter Toolbar

12

Item

Description

Measurement Function

Allows selection of the different measurements possible on
the connected counter. See the instrument user manual for
descriptions of the available measurements.

Input 1 Source

Selects the source input on the counter to use as input 1 in the
application.

Input 2 Source

Selects the source input on the counter to use as input 2 in the
application. This input is only used with particular Measurement
Functions. If the Measurement Function requires this input it
will become available in the application when that function is
selected.

Measurement Time (for
frequency and period
average measurements
only)

Sets the time interval between samples. For Burst measurements
the time interval should be shorter than the burst.
See the Single-Cycle Measurement description that follows for
more measurement information.

Single-Cycle
Measurement

The FCA3000, FCA3100, and MCA3000 Series instruments
are single-cycle measurement instruments. In the TimeView
application, the Single-Cycle Measurement check box is grayed
out.

Pacing (Interval Between
Measurements)

Sets the time between individual measurements.
See the Single-cycle Measurement description above for more
measurement information.

Real-Time Measurement
Readout

Opens a window that displays a real-time readout of whichever
Measurement Function is selected.

Counter Settings

See the instrument user manual for information on how to
configure these settings.

Capture Settings

(See page 5, Capture Menu.)

TimeView User Manual
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The Measurement Toolbar
Unlike the other Toolbars, which activate or deactivate fields based on choice of
Capture Type, but maintain the same layout, the Measurement Toolbar changes its
layout based on the Capture Type selected. A different Measurement toolbar is
shown for each Capture Type.

Free Running
Measurement Toolbar

TimeView User Manual

Item

Description

Samples in Block

The number of samples per block.

Blocks

The number of blocks of samples to collect.

Total Samples

Total number of samples = samples in block x blocks

Block Time Delay

The time interval to wait between capturing each block of
samples.

Statistics

Collects the data based on measurement settings, then
calculates and displays the value associated with the selected
Statistics Function.

Statistics Function

The selected statistics algorithm is applied to the collected data,
and the result displayed in the graph pane.
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Repetitive Sampling
Measurement Toolbar

Item

Description

Start Time

Sets a delay from the arming signal to the start of data collection.

Sample Interval

The interval at which samples are collected.

Number of Samples

Stops the data collection after a given number of samples.

Auto Stop

Automatically chooses a stop time. Stop Time in the Auto
Calculation Parameter performs the same function as this
function.

Stop Time

Stops the collection of data after a given time, or displays the
stop time that was automatically selected if Auto Stop is set up
correctly.

Auto Calculation
Parameter

The TimeView application automatically selects the value for this
parameter. If Stop Time is the selected parameter, then Auto
Stop is superfluous.

Time Stamp Measurement
Toolbar

Number of groups. This is the only time stamp parameter that you can select.
Each group contains four samples. See Time Stamp for more information. (See
page 11.)
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Waveform Measurement
Toolbar

TimeView User Manual

Item

Description

Waveform Time
Resolution

The minimum time between successive samples at a voltage
resolution level.
Setting the resolution higher than the period of the input wave
can cause only one cycle of the wave to be displayed even if
Stop Time is set so it would display multiple cycles.
As an example, assume a 10 MHz sine wave input signal with a
period of 100 ns. If the resolution is set at 100 ns, the expected
number of cycles is based on the Stop Time. For a Stop Time =
300 ns, the application selects 3 cycles.
If everything remains set the same, except the resolution is
changed to 150 ns, the middle cycle of the 3 expected cycles
is missing.

Start Time

Sets a delay to start the data collection.

Auto Stop Time

The application sets the stop time.

Stop Time

Manually set the stop time of data collection.

Auto Voltage Resolution

The application sets the trigger step interval between voltage
levels to a value resulting in approximately 50 steps between
peak-to-peak voltage levels.

Voltage Resolution

Manually set the step interval voltage between trigger events.
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The Capture Data Area
The Capture Data area displays information about the measurement setup and
detailed information about values associated with the graph cursors. There are two
tabs in the Capture Data area: the Measurement Data tab and the Graph Data tab.

Measurement Data Tab
The Measurement Data tab provides a brief summary of high-level settings for the
current measurement.

16
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The Capture Data Area

Graph Data Tab
The Measurement Data tab provides detailed information about values associated
with the graph cursors.

TimeView User Manual

Item

Description

Cursors Readout

Displays information about the cursors including absolute
position, distance of separation, and the associated units. These
values automatically update as you move the cursors in the
graph pane.

Statistic Parameters

Displays all of the statistics for the measurement without requiring
an individual run for each desired statistic. The statistics also
appear for some capture types without a statistics option on their
toolbar.
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The Graph Area

The Graph area displays the information collected from the measurement in
visual form.
You can use the Graph Layout buttons to split the Graph area into the selected
screen layout. (See page 8, The Standard Toolbar.) Each sub-pane contains a
different graph type. Click a pane to activate it and update the Graph Data tab
with values from that pane.
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The Graph Area

To change the type of graph shown in the graph area or sub-pane, click in the
graph area and click one of the graph types from the Standard Toolbar. (See
page 8, The Standard Toolbar.)

Cursors
Two cursors appear on a graph, or on the sub-pane of the selected graph if the
graph area is split. Use the mouse to click and drag a cursor to a desired position.
You can also use the keyboard arrow keys to move the left cursor (red by default),
or press and hold the Shift key and use the arrow keys to move the right cursor
(green by default).

The Graph Shortcut Menus
A shortcut menu is available for each graph by right-clicking with the cursor
positioned within the graph area. The shortcut menu content changes depending
on the graph type.

Free Running, FFT, and
Smooth Graph Shortcut
Menus

The following menu items are available on Free Running, FFT, and Smooth
graph types:
Zoom In/Out. Provides the same functionality as the zoom functions on the
standard toolbar.
Zoom in to cursors. This is the best way to zoom into a particular region of a
graph. By setting the cursors to the desired range using the techniques described
in Cursors, and then selecting this function, the graph zooms the data between the
cursors.
Zoom out full graph. Zooms out to the extent necessary to display all of the
collected data. This is the fastest way to return the graph to its furthest zoom.

TimeView User Manual
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Horizontal/Vertical axis. Manually sets the range of the x or y axis. To manually
set the range, deselect Auto Range, and enter the desired values into the Max/Min
fields.

NOTE. Deselecting the Auto Range check box will disable the ability to zoom. The
Auto Range check box must be checked to zoom.
The Vertical Axis has an AutoZoom option. This automatically adjusts the vertical
range to create some space between min/max points and the edges of the graph. It
is recommended to leave this option selected.

Histogram Context Menu

Limited Histogram. Acts similar to a zoom. Based on the position of the cursors,
selecting this option zooms the histogram to only display the range necessary to
contain the data between the cursors.
Full Histogram. Returns the histogram to the necessary range to display all of
the collected data.
Limit Statistics to Data Between Cursors. Recalculates the statistics based on the
values between the cursors, and places lines on the source graph representing the
new range of data used to calculate the statistical values.
NOTE. The application calculates the statistics based on sampled points. Even
though the Source Graph may display lines connecting those points, and the new
limited range may include those lines, the lines themselves do not contain data
that can be used in the statistical calculation. This may result in an inability to
compute the statistics due to lack of data.
Reset Limits. Resets the Limit to include the entire range of data.
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The Graph Area

Source Graph Shortcut
Menu

The Source Graph shortcut menu contains the Free Running, FFT, and Smooth
Graph shortcut menu items, and also the following menu items:
Limit Tools to Data Between Cursors. Changes the range of data used in the
calculation of the other graph types, updating those graphs to reflect their
calculations based on the newly defined data range.
Reset Limits. Resets the Limit to include the entire range of data.
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The Status Readout

The Status Readout
The Status readout displays text messages relevant to the current measurement
task, the data capture completion status, and the instrument connection status.
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Taking a Quick Measurement

Taking a Quick Measurement
This section shows you how to take a very quick measurement in the TimeView
application using the instrument 10 MHz signal output as the source. The
TimeView application must be running and the instrument connected to
TimeView. (See page 1, Connecting the Instrument.)
1. On the FCA3000, FCA3100, or MCA3000 Series instrument, connect a 50 Ω
BNC cable from the 10 MHz output on the rear panel of the instrument to
the Input A connector.
2. In TimeView, click Instrument > Settings.
3. Click the Basic tab, click the Default Settings button, and click OK. This
sets the instrument to its default settings.
4. Click Capture > Load Default Settings and click Yes.
5. Click Tools > Source Data.
6. Click the green arrow button on the toolbar to capture the instrument data
and display it in the TimeView application. A complete measurement (data
capture) takes about 26 seconds. Use the toolbar buttons and functions to
explore the user interface with the newly generated capture, or recapture data
using a different capture or measurement type. (See page 8, The Toolbars.)
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Viewing Example Data Captures

Viewing Example Data Captures
TimeView software includes a file of examples for different types of data capture.
The examples are in the C:\Program Files\Tektronix\TimeView 2\Samples folder
(default installation location). Use these capture sample files to explore TimeView
features.
Do the following to view a sample file (or any saved file):
1. Click File > Open in the TimeView application.
2. Navigate to the Samples folder.
3. Select a sample file and click OK.
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