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TSP Toolkit Quick Start Guide

Introduction

The Tektronix TSP™ Toolkit is an open-source Microsoft™ Visual Studio Code™ extension that provides support for
Tektronix's Test Script Processor (TSP) technology to edit and execute scripts on TSP-enabled Tektronix instruments.

The extension includes language features such as syntax error detection, code navigation, and code-completion
suggestions, as well as TSP command-set documentation and hover help.

This guide shows you how to:

Install the TSP Toolkit extension

Set up your workspace

Connect to an instrument

Configure a project

Run a TSP script

Use the Terminal

Use the debugger

Use automated TSP script generation
Use the TriggerFlow feature

Use the data export feature
Download and use TSP example scripts

NOTE: You can download Visual Studio Code from https://code.visualstudio.com!/.

Install the TSP Toolkit extension

NOTE: Before installing the extension from the Marketplace, select Help > Check for Updates to make sure that
you have the most recent version of Visual Studio Code.

If you are using Microsoft Windows, be sure to also have the latest Visual C++ Redistributable library installed.
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To install the extension from the Visual Studio Code Marketplace:

1. Select the extensions icon.

] File Edit Selection View Go

EXTENSIONS

~ INSTALLED

s . Lua

] File Edit Selection View Go Run Terminal Help
EXTENSIONS: MARKETPLACE

tektronix.tsp-tool kid

3. Select Install under the Tektronix TSP Toolkit.

Tektronix TSP Toolkit 1K RS
VSCode extension for Tektronix and Keithley instruments that support Test ...

'H'Tektmn'u Install

4. The extension installs. Reload the window if you are prompted.

Set up your workspace

To set up your workspace in Visual Studio Code:

1. Select the explorer icon.

EXPLORER
» DESKTOP
» OUTLINE

» TIMELINE
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2. Select File.

3. Select Open Folder to select a folder or create a new folder to use as your workspace.

] File Edit Selection View Go Run Terminal

@ Mew Text File Ctri+M

Mew File... Chrl+ Alt+Windows+ M
Mew Window Ctrl+Shift+ M

Mew Window with Profile

Open File... Ctrl+O

Open Folder... “ Ctri+K Ctrl+O

Open Workspace from File...

4. In your workspace, use the New File and New Folder icons to create new TSP files and subfolders.

) File Edit Selection View Go Run Terminal Help

@ EXPLORER
~ TSP

L

» tspConfig

? GitHub Examples

Connect to an instrument

You can connect your TSP-enabled instrument to your computer with a LAN, GPIB, or USB connection. GPIB and USB
connections require a VISA driver.

NOTE: If your instrument is operating using secure connections, TSP Toolkit will prompt for a password to be
entered before connecting. The security settings for your instrument must be configured before using TSP Toolkit.
For more information on configuring your instrument's security settings, visit tek.com for supporting
documentation.
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To connect to a TSP-enabled instrument:
1. Select the TSP icon on the left of the screen to open the instruments menu.

)] File Edit Selection View Go Run Terminal Help

~ INSTRUMENTS
A 2461#04331961 Mode
192.0.2.20
TCPIPO= 192.0.2.23 =inst0zINSTR

USBO:0x05ES

Offline Instruments

2. Hover over the instrument you want to connect to, then select Connect.

If the connection was successful, a terminal window opens, and the *IDN? string is displayed.

Configure a project

You can configure your project to have language features enabled for your TSP instruments and TSP-Link node network.

To configure a project:
1. Select the TSP icon on the left of the screen to open the Instruments menu.

2. Be sure that the System Configurations menu is selected.

| welcome X
v Instruments

.-

v System Configurations

~ S¥STEM CONFIGURATIONS
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5. Define your test system, then select Save.
P TOOLKIT

> INSTRUMENTS
- SYSTEM CONFIGURATIONS

System Name:

localnode:

2450

~ Nodes

node[| 1 ]

2450

When your project is configured, you are shown relevant code-completion suggestions, signature help, and command
documentation for your connected instruments.

Run a TSP script

To run a .TSP script:
1. Open a TSP script in the editor by clicking on it in the workspace or by selecting File > Open File.
2. Right-click anywhere within the script editor to display the context menu.

3. Select Send Script to Terminal to run the script.

' Demo.tsp X
y Demo.tsp > [®]lim
reset()

volts = smu.FUNC_DC_VOLTAGE

nction setSMU(fun, Send Script to Terminal

smu.source.func = Go to Definition

NOTE: When scripts or commands are run from the Terminal, errors are only returned after the requested action
completes. No new errors are printed while the operation is in progress.
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Using the Terminal

Once you have established a connection with your instrument, the Terminal can be used to send TSP commands and run
TSP scripts.

To close the Terminal and disconnect from the instrument, send the . exit command.

TERMINAL

Keithley TSP Shell

Type

.help for more commands.

Keithley Instruments,MODEL 2450,04484447.1.7.14h

2460
2460
2460
2460
2460
2460
2460
2460
done

.script "c:\Users\stenagli\OneDrive - Fortive\Documents\Scripts\TSP\Demo.tsp"
Source Function is smu.FUNC_DC_VOLTAGE

Current Limit is ©.001

Source Level is 5

Output is smu.ON

Source Function is smu.FUNC_DC_VOLTAGE

Current Limit is ©.001

Source Level is 5]

Output is smu.OFF

,exitl

Using the Debugger feature

To debug a TSP script using the TSP Toolkit extension:
1. Add a breakpoint by clicking to the left of a line number.

smu.measure . func
smu.measure._tern

Click to add a breakpoint -

sSmu.measure.n [Z'J.l':

2. In the upper-right corner of the script editor, select the Run and Debug icon and then select Debug TSP File. The
script runs until the breakpoint is triggered.

;e 0B O

b

Send Script to Terminal

Debug TSP File

Quick Start Guide WWW.TEK.COM| 6



TSP Toolkit

TSP Toolkit Quick Start Guide

3. When the breakpoint is triggered, use the debugger controls to step through the script.

> < ¥ T 90

4. You can navigate to the Debug view at any time by selecting Run and Debug.

o>

To add expressions to the Watch menu:
1. Select the add icon in the top right corner.

2. Enter the variable, command, or expression you wish to monitor, then press Enter.

3. You can also highlight the expression within the script, then right-click and select Add to Watch.

Fvaluate in Debug Console

Add Inline Breakpoint Shift+F9

Add to Watch

Run to Cursor

Quick Start Guide

WWW.TEK.COM |7



TSP Toolkit TSP Toolkit Quick Start Guide

Using the automated TSP script generation feature

NOTE: This feature is only compatible with the Tektronix MP5000 Series test system PSU and SMU modules.

Automated TSP script generation is not compatible with cloud-based workspaces in Microsoft OneDrive™. If you
are using OneDrive, be sure that your TSP Toolkit workspace is saved to your local computer.

To create a TSP script using the Script Generation Ul:
1. From the Explorer menu, select Script Generation.

2. Select + to view the TSP Toolkit Script Generation user interface.

v SCRIPT GENERATION
~ |-V Characterization -+

Test View Script Generation Ul
7

3. Use the Ul controls to configure the source and measure settings. You can use the waveform previews to verify that
the settings produce the desired sourcing behavior.

4. When you are finished adjusting parameters, select Open Script.

Open Script

5. The generated script is displayed in a new editor tab. You can run, save, or edit the script.
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Using the TriggerFlow feature

The MP5000 Series trigger model can be represented with a graphical display in TSP Toolkit called TriggerFlow™. This
interactive tool lets you configure complex trigger models by arranging operation blocks for the instrument to execute
instead of creating a script through conventional programming. You can add up to six trigger models to your script.

To create a trigger model with TriggerFlow:
1. From the Tools menu, navigate to TriggerFlow, then select + to begin a new session.

TSP TOOLKIT

» INSTRUMENTS
2 SYSTEM CONFIGURATIONS

~ TOOLS
» |-V Characterization Script Generation

v TriggerFlow

Family of Curves

2. From the search field, enter a name for the session, then press <Enter>.

T2

Enter name for th Enter' to confirm o

3. Open the Templates menu to add a predefined trigger model onto the canvas. You can drag and drop or select
individual action blocks from the Blocks > Actions menu.
Connect Branch blocks to other blocks by selecting a green dot on the block and dragging to a green dot on the target
block.

>
™ SOURCE ACTION STEP
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4. Select a block to edit its parameters.

Blocks with red borders require additional parameters set after adding them to the canvas. Some action blocks may
not have adjustable parameters.

>
< LOOP COUNTER

Target Count

10

5. Select Open Script to generate the script code.
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Completing the script

While the TriggerFlow feature automatically generates trigger model code, additional configuration code must be added
and other tasks must be completed before a TSP script will run:

» Source and measure settings must be configured
» Configuration lists and sweeps must be created

» TSP-Link must be initialized and nodes configured
* Reading buffers must be initialized and configured

Commented text within the generated code includes detailed descriptions and examples to help complete these tasks.
You can edit these notes and remove commenting tags as necessary.
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Using the data export feature

The data export feature allows you to export and save instrument buffers as well as record and store commands and
output. You can save the data to your PC using either the *.csv or *. txt file format.

To save instrument buffers to your PC:
1. From the Instruments menu, navigate to your connected instrument and select Save buffers to a file.

TSP TOOLKIT

INSTRUMENTS
Lo MP5103#4666710 Model: M

Ce

Offline Instruments

2. Enter the variable buffer names separated by a comma, then press <Enter> to continue.

Buffer Variable Names

slot[1].smu[1].defbuffer1, slot[1].smu[1].defbuffer2

Enter the buffer variable names separated by a comma (',") (Press ‘Enter’ to confirm or ‘Escape’ to
cancel)

3. Specify a string separator for the data fields, then press <Enter> to continue.
4. Select the fields to include in the export, then select OK.

Fields to print

absolute_timestamps
relative_timestamps
readings
measurefunctions
measureranges

sourcefunctions

'“ sourceoutputstates

sourceranges
sourcevalues

statuses

5. Enter a file name with a * . csv or *. txt extension, then select Save.

Quick Start Guide WWW.TEK.COM |12



TSP Toolkit TSP Toolkit Quick Start Guide

To record instrument commands and output and save it to your PC:

1. From the Instruments menu, navigate to your connected instrument and select Save commands and output.

TSP TOOLKIT

INSTRUMENTS s O
» (@ MP5103#4666710 Model: MP... %

C1° Save commands and out]
Offline Instruments

2. Enter a file name with a * . csv or *. txt extension, then select Save. The terminal session will begin recording.
3. When you are finished recording, select Stop saving commands and output.
TSP TOOLKIT

INSTRUMENTS
(@ MP5103#4666710 Model: MF

TO Stop saving commands and

Offline Instruments
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Downloading and using TSP example scripts

Example TSP Scripts are available for download on the TSP GitHub Repository.

To download and use a script:

1. Select either the Application_Specific or Instrument_Examples folder to find TSP scripts.

[ tektronix / keithley ' Public
<> Code ( lIssues 9 Pullrequests ©J Discussions () Actions (@ Security |+ Insights
¥ main ~ ¥ 1Branch § 0 Tags Q Gotofile
@ Little-LiZard Fix BrokenLink @ v 9004829 . 2 weeksage &Y 571 Commits
I .github Update Repo Code of Conduct 10 months ago
[0 .idea Test Templates and their Data 2 years ago
| Application_Specific Move LIV scripts 2 months ago
B9 Drivers Fix erros in DM6500 Sockets Driver 10 months ago
9 Instrument_Examples Fix Broken Link 2 weeks ago
[0 KickStart_Template_Projects mprove wording and capitalization 2 years ago
[0 TTI_Apps Update README.md last year
D .gitattributes Update .gitattributes 5 years ago
(] .gitignore Add gitignore 2 months ago
[ CONTRIBUTING.md Update Repo Code of Conduct 10 months ago
[ uCENSE Updated README for license 5 years ago
D README.md Add Link to new TSP Toolkit extension 6 months ago

2. Navigate the folders to find example scripts organized by instrument and application.

3. You can click on a script to view the code within GitHub. Select the download icon to copy the script to your computer.

keithley / Instrument_Examples / Series_2600 / Pulsed_Sweep / KE26XXB_Pulsed_Sweep_Single.tsp (5

@ Brad-0 Move Files around acdlebe - 2 months ago {0 History

Code | Blame 246 lines (211 loc) - 5.23 6 - @ Raw @: - @

2 Title: KE26XXB Pulsed Sweep Single
. Des example demonstra:

5 MU channel

10

11

12

=

14 Ea
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4. When the download is finished, copy the script to your TSP Toolkit Workspace file location.

EXPLORER

TSP
.tspConfig
vscode

GitHu

VW W W W

Benc
Demo.tsp
inFami

Untitled-1

Card Regression Test

Home Share View

v 4 ¥ « Downloads > Today

~
3¢ Quick access

I Desktop

‘ Downloads j KE26XXB_Pulsed_Sweep_Single.tsp

E Docurmnents

&= Pictures
Screenshots
TSP
TSP Toolkit G5G

m Videos

@ OneDrive - Fortive
.eclipse
4200 Work
Apps

Arnne Goids
Titem  1item selected 9.28 KB

on main{)
setSMU(volts, ¢

toggleOutput (smu.C

Additional resources and tutorials

Application note: How to write scripts for TSP

Tektronix TSP GitHub script example repository

TSP page on Tek.com

TSP Toolkit feature walkthrough video

TSP Toolkit product page

TSP video series

Quick Start Guide

Mame

~ Today (1)
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