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Welcome
 

 

Welcome to the Tektronix 100G-TXE, an Tektronix oscilloscope application
software that addresses 100GBASE-CR4, 100GBASE-KR4, and
CAUI-4 standards of IEEE. These three electrical standards make up the
backbone of the current 100G Ethernet industry, and the TekExpress 100G-TXE
automation test solution facilitates turnkey electrical transmitter validation of
most 100G Ethernet systems today.

The 100G-TXE solution specifically targets sections 83 of the IEEE 802.3bm
standard as well as sections 92 and 93 of the IEEE 802.3bj specification. These
tools allow quick verification to these IEEE electrical standards, while offering
comprehensive test automation, results margining, data logging, and results
reporting in an advanced testing framework.
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Key features of TekExpress 100G-TXE include:

■ 100G-TXE offers Transmitter 100GBASE-CR4 time domain transmitter
characterization, tracking Table 92-6 Transmitter characteristics at TP2 from
the IEEE 802.3bj cabled I/O specification. This offers a checklist approach to
performing all jitter, Linear impulse response pulse peak and Signal to Noise
and Distortion Ratio measurements, as well as basic AC parametric and
timing operations.

■ 100G-TXE also incorporates 100GBASE-KR4 time domain transmitter
characterization, tracking Table 93-4 Transmitter characteristics at TP0a
from the IEEE 802.3bj backplane specification. While the measurements are
identical to 100GBASE-CR4, the electrical limits for 100GBASE-KR4 are
more stringent.

■ 100G-TXE includes a third electrical test suite, for Annex 83 of IEEE
802.3bm, tracking Chip-to-module 100 Gb/s four-lane Attachment Unit
Interface (CAUI-4), Table 83E-1 at TP1a and TP4. The user defined test
point selection allows unique test limits relevant to host channel or module
validation. The CAUI-4 support offers advance CTLE scanning provisions to
find optimal eye opening/width.
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Getting help and support

Related documentation
The following documentation is available as part of the TekExpress® 100G-TXE
Solution application.

Table 1: Product documentation

Item Purpose Location
Help Application operation

and User Interface help

PDF of the help Printable version of the
compiled help

PDF file that ships with 100G-TXE Solution
software distribution (TekExpress 100G-TXE-
Automated-Test-Solution-Software-Printable-
Help-EN-US.pdf).

See also Technical support
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Conventions
Help uses the following conventions:

■ The term "Application," and "Software" refers to the TekExpress 100G-TXE
Solution application.

■ The term "CAUI4" refers to CAUI-4, IEEE 802.3bm standard.

■ The term "KR4 / CR4" refers to 100GBASE-KR4 or 100GBASE-CR4, IEEE
802.3bj standard.

■ The term “DUT” is an abbreviation for Device Under Test.

■ The term “select” is a generic term that applies to the two methods of
choosing a screen item (button, control, list item): using a mouse or using the
touch screen.

Table 2: Icon descriptions

Icon Meaning
This icon identifies important information.

This icon identifies conditions or practices that could result in loss
of data.

This icon identifies additional information that will help you use
the application more efficiently.

Technical support
Tektronix values your feedback on our products. To help us serve you better,
please send us your suggestions, ideas, or comments on your application or
oscilloscope. Contact Tektronix through mail, telephone, or the Web site. See 
Contacting Tektronix at the front of this document for contact information.

When you contact Tektronix Technical Support, please include the following
information (be as specific as possible):

Getting help and support  
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General information ■ All instrument model numbers
■ Hardware options, if any
■ Modules used
■ Your name, company, mailing address, phone number, FAX number
■ Please indicate if you would like to be contacted by Tektronix about your

suggestion or comments.

Application specific
information

■ Software version number
■ Description of the problem such that technical support can duplicate the

problem
■ If possible, save the setup files for all the instruments used and the

application
■ If possible, save the TekExpress setup files, log.xml, *.TekX (session files

and folders), and status messages text file

 Getting help and support
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Getting started

Minimum system requirements
The following table shows the minimum system requirements to install and run
the TekExpress 100G-TXE solution.

Table 3: System requirements

Component Description
Oscilloscope ■ Tektronix DPO70K series scope

■ Opt DJA and DJAN

Processor Same as the oscilloscope
Operating System Same as the oscilloscope:
Memory Same as the oscilloscope
Hard Disk Same as the oscilloscope
Display Super VGA resolution or higher video adapter (800 x 600 minimum video

resolution for small fonts or 1024 x 768 minimum video resolution for
large fonts). The application is best viewed at 96 dpi display settings  1

Firmware ■ Frimware Version: 10.3.0 or above

Software ■ IronPython 2.7.3 installed

■ PyVisa 1.0.0.25 installed

■ Microsoft .NET 4.0 Framework

■ Microsoft Internet Explorer 7.0 SP1 or greater, or other Web browser
for viewing reports

■ Adobe Reader software 7.0 or greater for viewing portable
document format (PDF) files

1 If TekExpress is running on an instrument that has a video resolution less than 800x600, connect and configure a
second monitor to the instrument.
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Instruments and accessories required
TekExpress100G-TXE application is launched on DPO70K series scope. The
following table lists the instruments and accessories required for this application. 

Table 4: Instruments and accessories required for 100G-TXE application

Instrument/Accessory Model number Quantity
Oscilloscope DPO72304SX, DPO72304DX,

MSO72304DX, DPO72504DX,
MSO72504DX, DPO73304SX,
DPO73304DX, MSO73304DX,
DPO75002SX, DPO75902SX,
DPO77002SX, DPS75004SX,
DPS75904SX, DPS77004SX

1 

Adapter  2 Broadband Balun with
bandwidth >= 40 GHz

1 

Cables Compatible SMA cables with
bandwidth greater than 40 GHz
for connecting single ended
sources ATI channel.

1 

Fixtures ■ Host compliance board for
CAUI4 at TP1a and CR4 at
TP2

■ Module compliance board
for CAUI4 at TP4

■ Transmitter test fixture for
KR4 at TP0a  3

1 

DC Blocks Compatible DC block with
bandwidth range 50 KHz to
65 GHz

2 

Attenuator 3, 6, or 10 dB attenuators 2 
Probes  4 Tektronix P7600 or P7700

series
1 

2 Required to operate in differential mode for single stack ATI scopes.
3 If required, De-Embed the fixtures using filter files.
4 Required to acquire signal at TP0a test point for KR4 suite.
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Installing the software
Follow the steps to download and install the latest TekExpress 100G-TXE
Solution. See Minimum system requirements for compatibility.

1. Type the URL www.tek.com in the address bar of web browser and click
Software Downloads

2. Enter TekExpress 100G-TXE Solution in the Enter your keywords field,
and click Search

3. Select the latest version of software and follow the instructions to download.
Copy the executable file into the oscilloscope.

4. Double-click the executable and follow the on-screen instructions. The
software is installed at C:\Program Files\Tektronix\TekExpress\TekExpress
100G-TXE\

5. Select Analyze > TekExpress 100G-TXE from the TekScope menu to 
launch the application

View software version
Use the following instructions to view version information for the application and
for the application modules such as the Programmatic Interface and the
Programmatic Interface Client.

To view version information for 100G-TXE, click  button in the TekExpress
application and select About TekExpress.

NOTE. This example shows a typical Version Details dialog box, and may not
reflect the actual values as shown when you open this item in the application.

 Getting started
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Application directories

TekExpress 100G-TXE
application

The TekExpress 100G-TXE application files are installed at the following
location: 

C:\Program Files\Tektronix\TekExpress\TekExpress 100G-TXE
 

 

The following table lists the application directory names and their purpose.

Table 5: Application directories and usage

Directory names Usage
Bin Contains TekExpress 100G-TXE application libraries
Compliance Suites Contains compliance-specific files
Examples Contains various support files
ICP Contains instrument and TekExpress 100G-TXE application-

specific interface libraries
Images Contains images of the TekExpress 100G-TXE application
Lib Contains utility files specific to the TekExpress 100G-TXE

application
Report Generator Contains style sheets for report generation
Tools Contains instrument and TekExpress 100G-TXE application-

specific files

Getting started  
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See also View test-related files

File name extensions

File name extensions
The TekExpress 100G-TXE application uses the following file name extensions:

File name extension Description
.TekX Application session files (the extensions may not be displayed)
.py Python sequence file
.xml Test-specific configuration information (encrypted) files

Application log files
.csv Test result reports

Plot data
.mht Test result reports (default)

Test reports can also be saved in HTML format
.pdf Test result reports

Application help document
.xslt Style sheet used to generate reports

See also View test-related files

Application directories

 Getting started
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Operating basics

Launch the application
To launch the TekExpress 100G-TXE solution, select Analyze > TekExpress
100G-TXE from the TekScope menu.
 

 

When you launch the application for the first time, the file C:\Users\<username>
\My Documents\My TekExpress\100G-TXE\Resources.xml is mapped to drive
X:. This file contains information about available network-connected
instruments. The session files are stored in X:\100G-TXE\. If this file is not
found, then the application runs Instrument Discovery Program to detect the
network-connected instruments before launching 100G-TXE solution.

If the application is behind the oscilloscope application, click Analyze >
TekExpress 100G-TXE to bring it to the front. To keep the 100G-TXE
application window on top, select Keep On Top from the 100G-TXE Options
menu.
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See also Application controls

Application panel overview

Application panels overview
TekExpress 100G-TXE solution uses panels to group Configuration, Results, and
Reports settings. Click any button to open the associated panel. A panel may
have one or more tabs that list the selections available in that panel. Controls in a
tab can change depending on settings made in the same tab or another tab.
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Table 6: Application panels overview

Panel Name Purpose
Setup panel The Setup panel shows the test setup controls. Click the Setup button to

open this panel.
Use this panel to:

■ Set DUT tab parameters

■ Select tests

■ Set acquisition tab parameters

■ Set configuration tab parameters

■ Set preferences tab parameters

Status panel View the progress and analysis status of the selected tests, and view test
logs.

Results panel View the summary of test results and select result viewing preferences.
Reports panel Browse for reports, save reports as specific file types, specify report

naming conventions, select report content to include (summary
information, detailed information, user comments, setup configuration,
application configuration), and select report viewing options.

See also Application controls

Global application controls

Application controls This section describes the application controls.

 Operating basics
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Table 7: Application controls description

Item Description
Options menu
 

 

To select global application controls.

Test Panel buttons
 

 

Controls that open tabs for configuring test settings and options.

Start / Stop button
 

 

Use the Start button to start the test run of the measurements in the
selected order. If prior acquired measurements are not cleared, then new
measurements are added to the existing set.
The button toggles to the Stop mode while tests are running. Use the
Stop button to abort the test.

Pause / Continue
button
 

 

Use the Pause button to pause the acquisition. When a test is paused,
this button changes as Continue.

Clear button
 

 

Use the Clear button to clear all existing measurement results. Adding or
deleting a measurement, or changing a configuration parameter of an
existing measurement, also clears measurements. This is to prevent the
accumulation of measurement statistics or sets of statistics that are not
coherent. This button is available only on Results panel.
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14  TekExpress® 100G-TXE Printable Application Help



Item Description
Application window
move icon
 

 

Place the cursor over the three-dot pattern in the upper left corner of the
application window. When the cursor changes to a hand, drag the
window to the desired location.

Minimize icon
 

 

Click to minimize the application.

Close icon
 

 

Click to close the application.

See also. Application panel overview

Options menu overview To access Options menu, click  in the upper-right corner of the application. It
has the following:

 Operating basics
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Options menu

Menu Function
Default Test Setup Opens an untitled test setup with defaults selected

Acquire Live Waveforms
Mode: User Defined
Standards: CAUI4
Specification: IEEE802.3bm, Annex 83E.3.1 
Data rate: 25.78125 
Pattern Type: PRBS9
Source: Single ended

Open Test Setup Opens a saved test setup
Save Test Setup Saves the current test setup
Save Test Setup As Saves the current test setup with a different file name or file type
Open Recent Displays the recently opened test setups to open
Instrument Control
Settings

Detects, lists, and refreshes the connected instruments found on
specified connections (LAN, GPIB, USB, and so on)

Keep On Top Keeps the TekExpress 100G-TXE application on top of all the application
Email Settings Use to configure email options for test run and results notifications
Deskew Allows to read the skew and attenuation values from the TekScope

application. Before using this option, manually compensate for skew and
attenuations in Tekscope application.

Help Displays the TekExpress 100G-TXE help
About TekExpress ■ Displays application details such as software name, version number,

and copyright

■ Provides a link to the end-user license agreement

■ Provides a link to the Tektronix Web site

Operating basics  
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See also. Application controls

TekExpress instrument
control settings

Use TekExpress Instrument Control Settings dialog box to search the instruments
(resources) connected to the application. You can use the Search Criteria to
search the connected instruments depending on the connection type. The details
of the connected instrument is displayed in the Retrieved Instruments window.

You can access this dialog box from the Options menu.
 

 

The connected instruments displayed here can be selected for use under Global
Settings in the test configuration section.

NOTE. Select GPIB (Default) when using TekExpress 100G-TXE application.

See also. Options menu overview

 Operating basics
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View connected
instruments

Use TekExpress Instrument Control Settings dialog box to search the instruments
(resources) connected to the application. The application uses TekVISA to
discover the connected instruments.

NOTE. The instruments required for the test setup must be connected and it must
be recognized by the application before running the test.

To refresh the list of connected instruments:

1. From the Options menu, select Instrument Control Settings.

2. In the Search Criteria section of the Instrument Control Settings dialog box,
select the connection types of the instruments to search.

Instrument search is based on the VISA layer, but different connections
determine the resource type, such as LAN, GPIB, and USB. For example, if
you choose LAN, the search will include all the instruments supported by
TekExpress that are communicating over the LAN.

3. Click Refresh. TekExpress searches for connected instruments.

4. After searching, the dialog box lists the instrument-related details based on
the search criteria. For example, For the Search Criteria as LAN and GPIB,
the application displays all LAN and GPIB instruments connected to the
application.

Operating basics  
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The details of the instruments are displayed in the Retrieved Instruments table.
The time and date of instrument refresh is displayed in the Last Updated field.

See also. Equipment connection setup

Configure email settings Use the Email Settings utility to get notified by email when a measurement
completes, or produces any error condition. Follow the steps to configure email
settings:

1. Select Options > Email Settings to open the Email Settings dialog box.

2. (Required) For Recipient email Address(es), enter one or more recipient
email addresses. To include multiple addresses, separate the addresses with
commas.

3. (Required) For Sender’s Address, enter the email address used by the
instrument. This address consists of the instrument name, followed by an
underscore, followed by the instrument serial number, then the @ symbol,
and the email server ID. For example: user@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server
address of the Mail server configured at the client location, and the SMTP
Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name,
password, and host name in the corresponding fields.

NOTE. If any of the above required fields are left blank, the settings will not
be saved and email notifications will not be sent.

5. In the Email Attachments section, select from the following options:

■ Reports: Select to receive the test report with the notification email.

■ Status Log: Select to receive the test status log with the notification
email. If you select this option, then also select whether you want to
receive the full log or just the last 20 lines.

6. In the Email Configuration section:

■ Enter a maximum file size for the email message. Messages with
attachments larger than this limit will not be sent. The default is 5 MB.

■ Enter the number in the Number of Attempts to Send field, to limit the
number of attempts that the system makes to send a notification. The
default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use
this check box to quickly enable or disable email notifications.

8. To test your email settings, click Test Email.

9. To apply your settings, click Apply.

10. Click Close when finished.

 Operating basics
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Email Settings
 

 

Setup panel

Setup panel overview The Setup panel contains sequentially ordered tabs that help you guide through
the test setup and execution process. 
 

Operating basics  

20  TekExpress® 100G-TXE Printable Application Help



 

Set DUT parameters Use the DUT tab to select parameters for the device under test. These settings are
global and apply to all tests of current session. DUT settings also affect the list of
available tests in the Test Selection tab.
 

 Operating basics
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Click Setup > DUT to access the DUT parameters:

Table 8: DUT tab settings

Setting Description
DUT ID Adds an optional text label for the DUT to reports. The default

value is DUT001. The maximum number of characters is 32.
You cannot use the following characters in an ID name: (.,..,...,
\,/:?”<>|*)

   Comments icon (to the
right of the DUT ID field)

Opens Comments dialog box to enter text to add to the report.
Maximum size is 256 characters. To enable or disable comments
appearing on the test report, see Select report options.

Acquire live waveforms Perform analysis on live waveforms.
Use pre-recorded waveform
files

Perform analysis on pre-recorded waveforms.

Mode ■ Compliance
■ User Defined

Standards Test Points Specification
CAUI4  1 TP1a IEEE802.3bm, Annex 83E.3.1 

TP4 IEEE802.3bm, Annex 83E.3.2 

1 CAUI4 (CAUI-4) is 100G chip-to-module IEEE 802.3bm interface, operating on four 25 Gb/s lanes.

Operating basics  
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Setting Description
KR4  2 TP0a IEEE802.3bj, Section 93 
CR4  3 TP2 IEEE802.3bj, Section 92 

Data Rate Set the data rate to be tested within the range 18 to 28.05. The
default value is 25.78125 

Pattern Type Select the pattern type. The available options are PRBS7, 9, 11,
and 15. By default, it is PRBS9.

Source ■ Differential - Source as differential signal
■ Single Ended -Source as single-ended signals

See also. Select tests

Select tests Use the Test Selection tab to select the tests. The test measurements available
depends on the standards selected in the DUT tab.

Figure 1: CAUI4 TX measurements

2 KR4 (100GBASE-KR4) is an Ethernet IEEE 802.3bj standard for 100G backplanes.
3 CR4 (100GBASE-CR4) is an Ethernet IEEE802.3bj standard for 100G over twin-axial cables.

 Operating basics
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Figure 2: KR4 TX measurements

Figure 3: CR4 TX measurements

Operating basics  
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Table 9: Test Selection tab settings

Setting Description
Tests Click on a test to select or unselect. Highlight a

test to show details in the Test Description pane.
Test Description Shows brief description of the highlighted test in

the Test field.

See also. Set acquisition tab parameters

Set acquisition tab
parameters

Use Acquisitions tab to view the test acquisition parameters. The contents
displayed on this tab depends on the DUT type and the tests selected.

 

 

NOTE. 100G-TXE application acquires all waveforms needed by each test group
before performing analysis.

 Operating basics
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Table 10: Acquisitions tab settings

Setting Description
Show Acquire Parameters Select to view the acquisition parameters.
Signal Validation: Sets the application to validate acquisition

signals and perform the specified action to take
when acquired signals do not meet
requirements. Select the action from the list.

TekExpress 100G-TXE saves all acquisition waveforms to files by default.
Waveforms are saved in a unique folder for each session (a session is started
when you click the Start button). The folder path is X:\100G-TXE\Untitled
Session\<dutid>\<date>_<time>. Images created for each analysis, CSV files
with result values, reports, and other information specific to that particular
execution are also saved in this folder.

Saving a session moves the session file contents from the Untitled Session folder
to the specified folder name, and changes the session name to the specified name.

Set configuration tab
parameters

Use Configuration tab to view and configure the Global Settings and the
measurement configurations. The Global Settings and the measurements with
configurations available in this tab depends on the Standards selected in the DUT
tab.

Figure 4: Configuration tab: Global Settings

Operating basics  
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Table 11: Configuration tab settings

Setting Description
Compliance Mode Select compliance mode. By default Compliance Mode is

selected.
User Defined Mode Select user defined mode
Global Settings
Instruments Detected Displays the instruments connected to this application. Click on

the instrument name to open a list of available (detected)
instruments.
Select Options > Instrument Control Settings and click
Refresh to update the instrument list.

NOTE. Verify that the GPIB search criteria (default setting) in the
Instrument Control Settings is selected when using TekExpress
100G-TXE application.

Ref Levels
Absolute Select to set the Ref Levels in Absolute
Percentage Select to set the Ref Levels in Percentage
Mid Level Select the mid level in absolute or percentage
Hysteresis Select the hysteresis in absolute or percentage

Bandwidth Select the bandwidth as Full BW or 50 GHz. By default Full BW
is selected.

Record Length for Jitter
measurements

Select the record length for jitter measurements. The available
values are 20 M, 30 M, 40 M. By default 40 M is selected.

NOTE. This configuration is applicable for jitter measurements
only.

Record Length for Eye
measurements

Select the record length for jitter measurements. The available
values are 20 M, 30 M, 40 M. By default 40 M is selected.

NOTE. This configuration is applicable for eye measurements
only.

 Operating basics
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Setting Description
De-Embedding Filter Select to apply the de-embed filter file. Click Browse and select

the folder containing de-embedding filter files (.flt).
For single ended mode, save two de-embedding filter files in a
folder, in the below specified format.

■ Source file name for data Positive :
DataPositiveSourceDeEmbeddingfilter.flt

■ Source file name for data negative :
DataNegativeSourceDeEmbeddingfilter.flt

For Differential mode, save one filter file in a folder, in the below
specified format.

■ Differential source filter file name:
DifferentialDeEmbeddingfilter.flt

NOTE. Browse option is enabled only when you select Use filter
file for de-embedding.

CTLE Filter File Select the CTLE Filter File.
Compliance mode

■ All: Application will run through all CTLE filters from 1 dB -
9 dB (at TP1a) and 1 dB - 2 dB (at TP4)

■ Best CTLE: After the first run, Best CTLE filter option gets
enabled. User can run the measurement with Best CLTE
instead of looping through all CTLE filters in the
specification.

User Defined mode

■ User can run the measurement with any specified CTLE
filter. The application provides CTLE filters from 1 dB - 9 dB
for data rate of 25.78125 Gbps. It is recommended to create
custom CTLE filter files for any other data rates.

Select the CTLE filters from the drop-down list or Custom to
browse and select the custom CTLE filter files.

NOTE. Custom CTLE filter files is to be named in the format
<user defined name>_ndB.flt, where n is the gain of the
filter.

Measurements - CAUI4 TXE
Analyze Measurement Range - 20%-80%

De-embedding filter. You can de-embed the signal path from fixture output to the
scope channel input. Manual filter files can also be created using SDLA or any
other method.
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Mid Level. Use to prevent small amounts of noise in a waveform from producing
multiple threshold crossings. Use when the rising and falling thresholds for a
given reference voltage level are set to the same value.

Hysteresis. A reference voltage level that defines when the waveform state
transition occurs at a given threshold.

Set preferences tab
parameters

Use Preferences tab to set the application action on completion of a
measurement.
 

 

Table 12: Preferences tab settings

Setting Description
Number of Runs
Acquire/Analyze each test <no> times (not
applicable to Custom Tests)

Select to repeat the test run by setting the
number of times. By default, it is selected with
1 run.

Actions on Test Measurement Failure
On Test Failure, stop and notify me of the failure Select to stop the test run on Test Failure, and

to get notified via email. By default, it is
unselected.
Click Email Settings to configure.
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Setting Description
Popup Settings
Auto close Warnings and Informations during
Sequencing
Auto close after <no> Seconds

Select to auto close warnings/informations
during sequencing. Set the Auto close time. By
default it is unselected.

Auto close Error Messages during Sequencing.
Show in Reports
Auto close after <no> Seconds

Select to auto close Error Messages during
Sequencing. Set the Auto close time. By default
it is unselected.

Status panel

Status panel overview The Status panel accesses the Test Status and Log View tabs, which provide
status on test acquisition and analysis (Test Status tab) and a listing of test tasks
performed (Log View tab). The application opens the Test Status tab when you
start a test run. You can select the Test Status or the Log View tab to view these
items while tests are running. 

Test status view
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Log view

Table 13: Status panel Log View controls

Control Description
Message History Lists all executed test operations and timestamp

information.
Auto Scroll Enables automatic scrolling of the log view as

information is added to the log during the test.
Clear Log Clears all messages from the log view.
Save Saves the log file to a text file. Use the standard

Save File window to navigate to and specify the
folder and file name to which to save the log
text.

See also. Application panel overview
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Results panel

Results panel overview When a test execution is complete, the application automatically opens the
Results panel to display a summary of test results.

 

 

See also. View a report

Application panels overview

View test-related files Files related to tests are stored in My TekExpress\100G-TXE\ . Each test setup in
this folder has both a test setup file and a test setup folder, both with the test setup
name.

The test setup file is preceded by the TekExpress icon and usually has no visible
file name extension.

Inside the test setup folder is another folder named for the DUT ID used in the
test sessions. The default is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has
a folder and file pair, both named for the test session using the naming
convention (date)_(time). Each session file is stored outside its matching session
folder:
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Each session folder contains image files of any plots generated from running the
test session. If you selected to save all waveforms or ran tests using prerecorded
waveform files, these are included here.

The first time you run a new, unsaved session, the session files are stored in the
Untitled Session folder located at ..\My TekExpress\100G-TXE\. When you
name and save the session, the files are placed in a folder with the name that you
specify. A copy of the test files stay in the Untitled Session folder until you run a
new test or until you close the 100G-TXE application.

See also. File name extensions

Reports panel

Reports panel overview Use Reports panel to browse for reports, name and save reports, select test
content to include in reports, and select report viewing options.
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For information on setting up reports, see Select report options. For information
on viewing reports, see View a report.

See also. Applications panel overview

Select report options Click Reports panel and use the Reports panel controls to select which test result
information to include in the report, and the naming conventions to use for the
report. For example, always give the report a unique name or select to have the
same name increment each time you run a particular test.

Select report options before running a test or when creating and saving test
setups. Report settings are included in saved test setups.

In the Reports panel, select from the following report options:

Table 14: Report options

Setting Description
Report Update Mode
Generate new report Creates a new report. The report can be in either .mht or .pdf file formats.
Append with previous run session Appends the latest test results to the end of the current test results report.
Include header in appended reports Select to include header in appended reports
Replace current test in previous run session Replaces the previous test results with the latest test results. Results from newly added

tests are appended to the end of the report.
Report Creation Settings
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Setting Description
Report name Displays the name and location from which to open a 100G-TXE report. The default

location is at \My TekExpress\100G-TXE\Untitled Session. The report file in this folder gets
overwritten each time you run a test unless you specify a unique name or select to auto
increment the report name.
Change the report name or location.

Do one of the following:

■ In the Report Path field, type over the current folder path and name.
■ Double-click in the Report Path field and then make selections from the popup

keyboard and click the Enter button.

Be sure to include the entire folder path, the file name, and the file extension. For example:
C:\Documents and Settings\your user name\My Documents\My TekExpress\100G-TXE
\DUT001.mht.

NOTE. You cannot set the file location using the Browse button.

Open an existing report.
Click Browse, locate and select the report file and then click View at the bottom of the
panel.

Save as type Saves a report in the specified file type, selected from the drop-down list.

NOTE. If you select a file type different from the default, be sure to change the report file
name extension in the Report Name field to match.

Auto increment report name if duplicate Sets the application to automatically increment the name of the report file if the application
finds a file with the same name as the one being generated. For example: DUT001,
DUT002, DUT003. This option is enabled by default.

Create report automatically at the end of the
run

Creates report at the end of the run.

Contents To Save
Include pass/fail info in details table Includes pass/fail info in the details table of the report.
Include detailed results Includes detailed results in the report.
Include plot images Includes plot images in the report.
Include setup configuration Sets the application to include hardware and software information in the summary box at

the top of the report. Information includes: the oscilloscope model and serial number, the
oscilloscope firmware version, and software versions for applications used in the
measurements.

Include user comments Select to include any comments about the test that you or another user added in the DUT
tab of the Setup panel. Comments appear in the Comments section, under the summary
box at the beginning of each report.

Group Report By
Test Name Select to group the tests in the report by test name.
Test Result Select to group the tests in the report by test results

View report after generating Automatically opens the report in a Web browser when the test completes. This option is
selected by default.
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Setting Description
View Click to view the most current report.
Generate Report Generates a new report based on the current analysis results.
Save As Specify a name for the report.

View a report The application automatically generates a report when test execution is complete
and displays the report in your default Web browser (unless you cleared the View
Report After Generating check box in the Reports panel before running the
test). If you cleared this check box, or to view a different test report, do the
following: 

1. Click the Reports button.
2. Click the Browse button and locate and select the report file to view.
3. In the Reports panel, click View.

For information on changing the file type, file name, and other report options, see 
Select report options.

Report contents A report shows detailed results and plots, as set in the Reports panel.
 

 

Setup configuration information

The summary box at the beginning of the report lists setup configuration
information. This information includes the oscilloscope model and serial number,
optical module model and serial number, and software version numbers of all
associated applications.

To exclude this information from a report, clear the Include Setup
Configuration check box in the Reports panel before running the test.

User comments
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If you selected to include comments in the test report, any comments you added
in the DUT tab are shown at the top of the report.

See also. Results panel overview

View test-related files
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Running tests

Equipment connection diagram
Click Setup > Test Selection > Schematic to view the equipment setup
diagram(s). 

Figure 5: CAUI4 TP1a (Single ended)

Figure 6: CAUI4 TP1a (Differential)
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Figure 7: CAUI4 TP4 (Single ended)

Figure 8: CAUI4 TP4 (Differential)
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Figure 9: CAUI4 Eye Width / Eye Height TP1a (Single ended)
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Figure 10: CAUI4 Eye Width / Eye Height TP1a (Differential)
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Figure 11: CAUI4 Eye Width / Eye Height TP4 (Single ended)
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Figure 12: CAUI4 Eye Width / Eye Height TP4 (Differential)

Figure 13: CR4 TP2 (Single ended)
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Figure 14: CR4 TP2 (Differential)

Figure 15: KR4 TP0a (Single ended)
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Figure 16: KR4 TP0a (Differential)
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Prerequisite

Compensate the signal
path

Use the following procedure to compensate the internal signal acquisition path.
Perform this procedure if the ambient temperature has changed more than 5 °C
(9 °F) since you performed the last signal path compensation. Perform the signal
path compensation once a week. Failure to do so may result in the instrument not
meeting warranted performance levels. 

1. Power on and wait for the instrument to complete its warm up period before
continuing with this procedure.

2. Disconnect any probes you have connected to the input channels.

3. Set the instrument to Menu mode.

4. Select Instrument Calibration from the Utilities menu.

5. Note any instructions that appear in the resulting control window.

6. Click Run SPC to begin the procedure. The procedure may take several
minutes to complete.

7. Verify that the Status changes to Compensated after the procedure is
complete. If the Calibration Status field indicates anything other than
Compensated, see Signal Path Compensation Status for information on the
readout and recommended action.

NOTE. When making measurements at vertical scale settings less than or equal to
5 mV, you should perform the signal path compensation at least once a week.
Failure to do so may result in the instrument not meeting warranted performance
levels at those volts/div settings.

Deskew If skew is present between positive and negative channels, then the channels need
to be deskewed before being used for waveform measurements. TekExpress
100G-TXE provides support for channel deskew and attenuation using the
following method:

1. Determine what the skew is for each channel.

2. From the TekScope menu, select Vertical > Deskew.

3. In the Deskew/Attenuation window, click the channel (1 – 4) button for the
first channel to be deskewed.

4. Click in the Ch(x) Deskew Time entry field and enter the skew. The skew
can be +ve or –ve.

5. Click the channel button for the next channel and repeat step  4.

6. After entering the skew for all the channels that require it, from the Options
menu in TekExpress 100G-TXE, select Deskew.
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7. In the Deskew dialog box, select the desired level:

■ Less than 100 mV signal amplitude: Select this if the signal amplitude is
such that the oscilloscope’s vertical setting is less than 100 mV/division.

■ 100 mV or greater signal amplitude: Select this if the signal amplitude is
such that the oscilloscope’s vertical setting is greater than 100 mV/
division.

Figure 17: Deskew

8. Click Read Deskew/Attn.

9. When the status in the dialog box indicates the deskew is finished, click
Close.

Each input channel has its own deskew settings. Deskew compensates individual
channels for probes or cables of different lengths. The instrument applies the
delay values after each completed acquisition. The deskew values are saved as
part of the instrument setup. The deskew values for the selected channel are
retained until you change the probe, you restore a saved setup, or you recall the
factory setup.
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Running tests
Select tests, set acquisition parameters, set configuration parameters, set
preferences parameters, and click Start to run the tests. While tests are running,
you cannot access the Setup or Reports panels. To monitor the test progress,
switch between the Status panel and the Results panel. 

While the tests are running, other applications may display windows in the
background. The TekScope application takes precedence over other applications,
but you can switch to other applications by using Alt + Tab key combination. To
keep the TekExpress 100G-TXE application on top, select Keep On Top from
the TekExpress Options menu.

The application displays report when the tests execution is complete.

Prerun checklist 1. Make sure that the instruments are warmed up (approximately 20 minutes)
and stabilized.

2. Perform compensation: In the oscilloscope main menu, select Utilities >
Instrument Compensation. Click Help in the compensation window for
steps to perform instrument compensation.
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Saving and recalling test setup

Test setup files overview
Saved test setup information (such as the selected oscilloscope, general
parameters, acquisition parameters, measurement limits, waveforms (if
applicable), and other configuration settings) are saved under the setup name at
X:\100G-TXE.

Use test setups to:

■ Run a new session, acquiring live waveforms, using a saved test
configuration.

■ Create a new test setup using an existing one.

■ View all the information associated with a saved test, including the log file,
the history of the test status as it executed, and the results summary.

■ Run a saved test using saved waveforms.

See also Save a test setup

Open (load) a saved test setup

Save a test setup
You can save a test setup before or after running a test. You can create a test
setup from already created test setup, or using default test setup. When you
select the default test setup, the parameters are set to the application’s default
value.

Select Options > Save Test Setup to save the opened setup.

Select Options > Save Test Setup As to save the setup with different name.
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Open (load) a saved test setup
To Open (load) a saved test setup, do the following:

1. Select Options > Open Test Setup.

2. Select the setup from the list and click Open. Setup files are located at X:
\100G-TXE\.

See also About test setups

Create a test setup using an existing one

Create a test setup from default settings

Create a test setup from default settings
To create a test setup using default settings, follow the steps:

1. Select Options > Default Test Setup. For default test setup, the parameters
are set to the application’s default value.

2. Click application Setup and set the parameters

3. Click application Reports and set the report options

4. Optional: Click Start to run the test and verify that it runs correctly and
captures the specified test information and reports. If it does not, then edit the
parameters and repeat this step until the test runs to your satisfaction

5. Select Options > Save Test Setup. Enter the file name and click Save. The
application saves the file to X:\100G-TXE\<session_name>

Create a test setup using an existing one
To create a test setup using an existing one, follow the steps:

1. Select Options > Open Test Setup

2. Select a setup from the list and then click Open

3. Click application Setup and modify the parameters

4. Click application Reports and modify the report options

5. Select Options > Save Test Setup As

6. Enter test setup name, and click Save
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CAUI4 TXE compliance measurements

DC common mode output voltage
This section verifies that the mean of the common mode signal is within the
conformable limits according to the specification.

Required test equipment

Minimum system requirements

Equipment connection diagram

Standards Test points Specification
CAUI4 TP1a IEEE 802.3bm, Section 83E.3.1.2, Table 83E-1 

TP4 IEEE 802.3bm, Section 83E.3.1.2, Table 83E-3 

Measurement procedure

The supported voltage range of ATI channel of the scope is ±0.3 V and the DC
voltage of the DUT can be beyond the supported voltage limits. Hence, use
external digital multimeter to measure the voltage and enter it in the application.

Limits

At TP1a: -0.3 V to 2.8 V

At TP4: -0.35 V to 2.85 V
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Diff peak to peak output voltage - Tx disabled
This section verifies that the peak to peak differential output voltage when the
transmitter is disabled is within the conformable limits according to the
specification.

Required test equipment

Minimum system requirements

Equipment connection diagram

Standards Test points Specification
CAUI4 TP1a IEEE 802.3bm, Section 83E.3.1.2, Table 83E-1 

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) without any filtering.

Measurement procedure

1. Add Peak to Peak measurement.

2. The value of the pk-pk voltage is the differential output voltage (pk-pk).

Limits

At TP1a:

■ Lower limit: NA

■ Higher limit: 35 mV

Diff peak to peak output voltage - Tx enabled
This section verifies that the peak to peak differential output voltage is within the
conformable limits according to the specification.

Required test equipment

Minimum system requirements

Equipment connection diagram

Standards Test points Specification
CAUI4 TP1a IEEE 802.3bm, Section 83E.3.1.2, Table 83E-1 

TP4 IEEE 802.3bm, Section 83E.3.1.2, Table 83E-3 

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.
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Measurement procedure

1. Add Peak to Peak measurement.

2. The value of the pk-pk voltage is the differential output voltage (pk-pk).

Limits

At TP1a and TP4:

■ Lower limit: NA

■ Higher limit: 900 mV

AC common mode output voltage
This section verifies that the RMS value of the common mode signal is within the
conformable limits according to the specification.

Required test equipment

Minimum system requirements

Equipment connection diagram

Standards Test points Specification
CAUI4 TP1a IEEE 802.3bm, Section 83E.3.1.2, Table 83E-1 

TP4 IEEE 802.3bm, Section 83E.3.1.2, Table 83E-3 

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Measurement procedure

1. Create a common mode signal using Math = (Data Positive + Data Negative)/
2.

2. Create Vertical histogram on the common mode signal.

3. Add Standard deviation measurement.

4. Standard deviation of the signal is measured as AC common mode voltage.

Limits

At TP1a and TP4:

■ Lower limit: NA

■ Higher limit: 17.5 mV
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Single ended output voltage
This section verifies that the max and min of data positive and negative signals
are within conformable limits as per the specification.

Required test equipment

Minimum system requirements

Equipment connection diagram

Standards Test points Specification
CAUI4 TP1a IEEE 802.3bm, Section 83E.3.1.2, Table 83E-1 

Inputs

■ Two single ended sources (Positive and Negative) filtered through fourth
order 33 GHz Bessel Thomson filter.

Measurement procedure

1. Find the max and min of the signal using base scope measurement option
(select Measure > Amplitude. Select Maximum and Minimum).

2. Single Ended output voltage (max) = DC Common mode voltage + Max of
Single Ended signal (without DC).

3. Single Ended output voltage (min) = DC Common mode voltage + Min of
Single Ended signal (without DC).

4. Perform Step  2 and  3 on single ended data positive and data negative
signals.

Limits

At TP1a:

■ Lower limit: -0.4 V

■ Higher limit: 3.3 V
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Signaling rate
This section verifies that the signaling rate (data rate) of the DUT per lane is
within the conformable limits according to the specification.

Required test equipment

Minimum system requirements

Equipment connection diagram

Standards Test points Specification
CAUI4 TP1a IEEE 802.3bm, Section 83E.3.1.1, Table 83E-1 

TP4 IEEE 802.3bm, Section 83E.3.1.1, Table 83E-3 

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Measurement procedure

1. This measurement is performed using DPOJET Period measurement as
prerequisite.

2. Period is found edge to edge which gives the Unit interval (UI) of the signal.

3. The result of the period measurement (UI) is used to find the data rate of the
signal. Data Rate = 1/Unit interval.

Limits

At TP1a and TP4:

■ Lower limit: Configured Date Rate - 100 ppm

■ Higher limit: Configured Date Rate + 100 ppm
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Eye width and Eye height
This section verifies that the eye width and eye height are within the conformable
limits according to the specification.

Required test equipment

Minimum system requirements

Equipment connection diagram

Standards Test points Specification
CAUI4 TP1a IEEE 802.3bm, Section 83E.3.1.6, Table 83E-1 

TP4 IEEE 802.3bm, Section 83E.3.2.1, Table 83E-3 

Inputs
■ Differential signal created using two single ended sources (Positive and

Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.
Calibration:

Before running the Eye width / Eye height measurement, the below setup has to
be calibrated with a crosstalk generator, as mentioned in the following settings:
■ For Host (TP1a): Calibrate the crosstalk generator at TP4 with target

differential peak-to-peak amplitude of 900 mV and target transition time of
12 ps (section 83E.3.1.6).

■ For Module (TP4): Calibrate the crosstalk generator at TP1a with target
differential peak-to-peak amplitude of 900 mV and target transition time of
19 ps (section 83E.3.2.1).

Measurement procedure

Eye width and Eye height calculation

Signal is captured such that it has more than 1e6 edges. Measurements are done
using Dual-Dirac jitter model as specified in section 83E.4.

EW15 = EW6 - 3.19*(RJR + RJL)

Where,

EW15 is the eye width extrapolated to 10-15 probability

EW6 is the eye width at 10-6 probability

RJL is the RMS value of the jitter estimated from CDFL

RJR is the RMS value of the jitter estimated from CDFR

EW15 = EW6 - 3.19*(RN0 - RN1)

Where,

EW15 is the eye width extrapolated to 10-15 probability

EW6 is the eye width at 10-6 probability

RJL is the RMS value of the jitter estimated from CDF1
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RJR is the RMS value of the jitter estimated from CDF0

Compliance method to find Eye width and Eye height results

The signal filtered through Bessel Thomson filter is equalized using different
CTLE filters (1 dB - 9 dB for Host) and (1 dB - 2 dB for Module). CTLE filter
result which has the maximum Eye area (Eye width * Eye height) and passing
both Eye height and Eye width results is chosen as reference CTLE filter.

Host (TP1a): The CTLE peaking in the reference receiver shall be set to three
values:

1. The recommended CTLE peaking value provided by the host (CTLE 1 dB to
9 dB)

2. The value 1 dB higher if present

3. The value 1 dB lower if present

A compliant host should pass both the eye width and eye height A limit using at
least one of the settings and passes eye height B in two or three settings.

Module (TP4): A compliant module has to pass both eye width and eye height at
least one of the CTLE settings (CTLE 1 dB to 2 dB).

Limits

At TP1a:

■ Eye Width: LL: 0.46 UI and UL: NA

■ Eye Height A: LL: 95 mV and UL: NA

■ Eye Height B: LL: 80 mV and UL: NA

At TP4:

■ Eye Width: LL: 0.57 UI and UL: NA

■ Eye Height: LL: 228 mV and UL: NA
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Vertical eye closure
This section verifies that the vertical eye closure of the signal is within the
conformable limits according to the specification IEEE 802.3bm, and Section
83E.4.2.1.

Required test equipment

Minimum system requirements

Equipment connection diagram

Standards Test points Specification
CAUI4 TP4 IEEE 802.3bm, Section 83E.4.2.1, Table 83E-3 

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Measurement procedure

1. The filtered signal is equalized using reference or best CTLE filter. If
reference CTLE filter is not present, the application will loop through
required CTLE filters to find the reference CTLE filter.

2. Eye height@BER of 1e-15 and Eye amplitude are calculated for the
equalized signal using Dual-Dirac jitter separation model as explained
section 83E.3.2.1.

3. Vertical eye closure is calculated using the following formula:

VEC = 20log(AV/EH15)

Where,

VEC is vertical eye closure in dB

AV is the eye amplitude of the equalized waveform. Eye amplitude is defined
as the mean value of logic one minus the mean value of logic zero in the
central 5% of the eye

EH15 is the eye height at BER of 1e-15 

Limits

At TP4:

■ Lower limit: NA

■ Higher limit: 5.5 dB
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Transition time
This section verifies that the transition time of the DUT is within the conformable
limits according to the specification.

Required test equipment

Minimum system requirements

Equipment connection diagram

Standards Test points Specification
CAUI4 TP1a IEEE 802.3bm, Section 83E.3.1.5, Table 83E-1 

TP4 IEEE 802.3bm, Section 83E.3.1.5, Table 83E-3 

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Measurement procedure

1. Measure the nominal Unit interval of the filtered signal.

2. For PRBS9, measure Voltage High in region 000001111 for Rise Time and
Voltage Low in region 11111111100000 for fall time. Within these regions,
take average amplitude in -3 UI to -2 UI range from edge for finding voltage
low. Also take average amplitude in 2 UI to 3 UI range from edge for finding
voltage high.

3. Find the transition time in search patterns (000001111 for Rise and
11111111100000 for Fall) by taking difference in time from 20% to 80% of
the signal amplitude.

Limits

At TP1a:

■ Lower limit: 10 ps

■ Higher limit: NA

At TP4:

■ Lower limit: 12 ps

■ Higher limit: NA
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CR4 / KR4 TXE compliance measurements

DC common mode output voltage
This section verifies that the mean of the common mode signal is within the
conformable limits according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.1, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.3, Table 93-4 

Required test equipment

Minimum system requirements

Equipment connection diagram

Measurement procedure

The supported voltage range of the scope is ±0.3 V and the DC voltage of the
DUT can be beyond the supported voltage limits. Hence, use external digital
multimeter to measure the voltage and enter it in the application.

Limits

CR4 0 V to 1.9 V
KR4 0 V to 1.9 V
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Diff peak to peak output voltage - Tx disabled
This section verifies that the peak to peak differential output voltage when
transmitter is disabled is within the conformable limits according to the
specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.1, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.3, Table 93-4 

Required test equipment

Minimum system requirements

Equipment connection diagram

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) without any filtering.

Measurement procedure

1. Add Peak to Peak measurement.

2. The value of the pk-pk voltage is measured as differential output voltage (pk-
pk).

Limits

CR4 Peak-to-Peak Differential output (Tx Disabled)
<= 35 mV

KR4 Peak-to-Peak Differential output (Tx Disabled)
<= 30 mV
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Diff peak to peak output voltage - Tx enabled
This section verifies that the peak to peak differential output voltage is within the
conformable limits according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.1, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.3, Table 93-4 

Required test equipment

Minimum system requirements

Equipment connection diagram

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Measurement procedure

1. Add Peak to Peak measurement.

2. The value of the pk-pk voltage is measured as differential output voltage (pk-
pk).

Limits

CR4 Peak-to-Peak Differential output <= 1200 mV
KR4 Peak-to-Peak Differential output <= 1200 mV
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AC common mode output voltage
This section verifies that the RMS value of the common mode signal is within the
conformable limits according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.1, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.3, Table 93-4 

Required test equipment

Minimum system requirements

Equipment connection diagram

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Measurement procedure

1. Create a common mode signal using Math = (Data Positive + Data Negative)/
2.

2. Create Vertical histogram on the common mode signal.

3. Add Standard deviation measurement.

4. Standard deviation of the signal is measured as AC common mode voltage.

Limits

CR4 AC Common mode output voltage <= 30 mV
RMS with respect to ground

KR4 AC Common mode output voltage <= 12 mV
RMS with respect to ground
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Signaling rate
This section verifies that the signaling rate (data rate) of the DUT per lane is
within the conformable limits according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.9, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.2, Table 93-4 

Required test equipment

Minimum system requirements

Equipment connection diagram

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Measurement procedure

1. This measurement is performed using DPOJET Period measurement as
prerequisite.

2. Period is found edge to edge which gives the Unit interval (UI) of the signal.

3. The result of the period measurement (UI) is used to find the data rate of the
signal. Data Rate = 1/Unit interval.

Limits

CR4 At TP1a and TP4:

■ Lower limit: Configured Date Rate -
100 ppm

■ Higher limit: Configured Date Rate +
100 ppm

KR4 At TP1a and TP4:

■ Lower limit: Configured Date Rate -
100 ppm

■ Higher limit: Configured Date Rate +
100 ppm
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Transmitter waveform requirements

Common procedure for
transmitter waveform

requirements

This section describes the general procedure to be performed for Transmitter
output waveform measurements. Perform the general procedure and the
measurement specific procedure for each sub-measurements.

Required test equipment

Minimum system requirements

Equipment connection diagram

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Common procedure for transmitter waveform requirements

1. Configure the DUT to transmit the PRBS 7, 9, 11, or 15 signal continuously
at the specified data rate.

2. Acquire the signal at a sampling rate of 200 Gbps and record length of 5M
samples.

3. Oversample the signal to get more than 32 samples per bit and average the
signal across the PRBS patterns.

4. Process the signal using steps as per specification section 92.8.3.5 to measure
the various Transmitter waveform parameters.

Linear fit pulse peak This section verifies that the linear fit pulse peak value is within the conformable
limits according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.5.2, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.5.2, Table 93-4 

Measurement procedure

1. Set the DUT in PRESET mode by setting the coefficients C(-1), C(0) and
C(1) to zero.

2. Capture the signal and calculate linear fit filter coefficients of the signal. The
peak value of the linear fit curve is measured as Linear Fit pulse peak.

Limits

CR4 Linear Fit Pulse Peak > 0.45 * Steady state
voltage

KR4 Linear Fit Pulse Peak > 0.71 * Steady state
voltage
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Steady state voltage This section verifies that the steady state voltage is within the conformable limits
according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.5.2, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.5.2, Table 93-4 

Measurement procedure

1. Set the DUT in PRESET mode by setting coefficients C(-1), C(0) and C(1) to
zero.

2. Capture the signal and calculate linear fit pulse of the signal. The average
value of the linear fit curve is measured as Steady state output voltage (DC
voltage) of the signal.

Limits

CR4 ■ Min: 0.34 V
■ Max: 0.6 V

KR4 ■ Min: 0.4 V
■ Max: 0.6 V

Minimum pre-cursor full
scale ratio

This section verifies that the minimum pre-cursor equalization ratio is within the
conformable limits according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.5.5, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.5.5, Table 93-4 

Measurement procedure

1. Set the DUT in PRESET mode and compute the filter coefficients.

2. Calculate equalizer coefficients C(-1), C(0) and C(1). Minimum pre-cursor
equalization ratio is calculated as below:

Min Pre-Cursor Eq Ratio = [C(0) – C(-1)] / [C(0) + C(-1)]

Limits

CR4 Minimum pre cursor equalization ratio >= 1.54 
KR4 Minimum pre cursor equalization ratio >= 1.54 
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Minimum post-cursor full
scale ratio

This section verifies that the minimum pre-cursor equalization ratio is within the
conformable limits according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.5.5, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.5.5, Table 93-4 

Measurement procedure

1. Set the DUT in PRESET mode and compute the filter coefficients.

2. Calculate equalizer coefficients C(-1), C(0) and C(1). Minimum Post cursor
equalization ratio is calculated as below:

Min Post-Cursor Eq Ratio = [C(0) – C(1)] / [C(0) + C(1)]

Limits

CR4 Minimum post cursor equalization ratio >= 4 
KR4 Minimum post cursor equalization ratio >= 4 

Normalized coefficient
step size

This section verifies that the increment and decrement step size of transmitter
equalizer coefficients (C(-1), C(0) and C(1)) of the DUT are in conformable
limits according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.5.4, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.5.4, Table 93-4 

Measurement procedure

C(-1) Increment step size and C(-1) Decrement step size:

1. Set the DUT in PRESET state; acquire the signal and calculate the filter
coefficients.

2. Configure all the DUT’s transmitter equalizer coefficients to INITIALIZE
state.

3. Measure the C(-1) coefficient value and denote as C(-1)_Initilaize

4. Configure the DUT’s transmitter equalizer coefficient C(-1) to
INCREMENT, C(0) and C(1) to HOLD state.

5. Measure the C(-1) coefficient value and denote as C(-1)_Increment

6. C(-1) Increment step size is calculated as: Δc = C(-1)_Increment –
C(-1)_Initialize

7. Configure the DUT’s transmitter equalizer coefficient C(-1) to
DECREMENT, C(0) and C(1) to HOLD state.
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8. Measure the C(-1) coefficient value and denote as C(-1)_Decrement

9. C(-1) Increment step size is calculated as: Δc = C(-1)_Decrement –
C(-1)_Increment

C(0) Increment step size and C(0) Decrement step size:

1. Set the DUT in PRESET state; acquire the signal and calculate the filter
coefficients.

2. Configure all the DUT’s transmitter equalizer coefficients to INITIALIZE
state.

3. Measure the C(0) coefficient value and denote as C(0)_Initilaize

4. Configure the DUT’s transmitter equalizer coefficient C(0) to INCREMENT,
C(-1) and C(1) to HOLD state.

5. Measure the C(0) coefficient value and denote as C(0)_Increment

6. C(0) Increment step size is calculated as: Δc = C(0)_Increment –
C(0)_Initialize

7. Configure the DUT’s transmitter equalizer coefficient C(0) to
DECREMENT, C(-1) and C(1) to HOLD state.

8. Measure the C(0) coefficient value and denote as C(0)_Decrement

9. C(0) Increment step size is calculated as: Δc = C(0)_Decrement –
C(0)_Increment

C(1) Increment step size and C(1) Decrement step size:

1. Set the DUT in PRESET state; acquire the signal and calculate the filter
coefficients.

2. Configure all the DUT’s transmitter equalizer coefficients to INITIALIZE
state.

3. Measure the C(1) coefficient value and denote as C(1)_Initilaize

4. Configure the DUT’s transmitter equalizer coefficient C(1) to INCREMENT,
C(-1) and C(0) to HOLD state.

5. Measure the C(1) coefficient value and denote as C(1)_Increment

6. C(1) Increment step size is calculated as: Δc = C(1)_Increment –
C(1)_Initialize

7. Configure the DUT’s transmitter equalizer coefficient C(1) to
DECREMENT, C(-1) and C(0) to HOLD state.

8. Measure the C(1) coefficient value and denote as C(1)_Decrement

9. C(1) Increment step size is calculated as: Δc = C(1)_Decrement –
C(1)_Increment

Limits
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CR4 ■ Min: 0.0083 
■ Max: 0.05 

KR4 ■ Min: 0.0083 
■ Max: 0.05 

Signal to noise and distortion ratio
This section verifies that the signal to noise and distortion ratio of the DUT is
within the conformable limits according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.7, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.6, Table 93-4 

Required test equipment

Minimum system requirements

Equipment connection diagram

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Measurement procedure

1. Configure the DUT in OPTIMAL state and capture the signal for
measurement.

2. Compute the Linear fit pulse response (Pmax) and the RMS value of the
linear fit error σ(e) from the signal.

3. Measure the RMS deviation of voltage from the mean and denote it as (σ(n).
This has to be measured at the flat portion of the waveform where the slope is
close to zero.

4. Signal to Noise an Distortion ratio is measured using below equation:
 

 

Limits
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CR4 SNDR > 26 dB
KR4 SNDR > 27 dB

Output Jitter

Even-odd jitter peak to
peak

This section verifies that the value of the even odd jitter is within the
conformable limits according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.8, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.7, Table 93-4 

Required test equipment

Minimum system requirements

Equipment connection diagram

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Measurement procedure

1. Capture a long sequence of PRBS pattern.

2. Even Odd Jitter is measured as the magnitude of the difference between the
average deviation of all even numbered transitions and the average deviation
of all odd numbered transitions, where even odd transitions are not possible
transitions, but actual transitions.

3. The Even Odd Jitter is carried out by DPOJET using F/n measurement with n
being set to 2.

Limits

CR4 Even Odd Jitter <= 0.035 UI
KR4 Even Odd Jitter <= 0.035 UI
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Effective bounded and
total uncorrelated jitter

peak to peak

This section verifies that the jitter components are within the conformable limits
according to the specification.

Standards Test points Specification
CR4 TP2 IEEE 802.3bj, Section 92.8.3.8, Table 92-6 
KR4 TP0a IEEE 802.3bj, Section 93.8.1.7, Table 93-4 

Required test equipment

Minimum system requirements

Equipment connection diagram

Inputs

■ Differential signal created using two single ended sources (Positive and
Negative) and filtered through fourth order 33 GHz Bessel Thomson filter.

Measurement procedure

1. Capture PRBS signal with minimum of 2e3 edges present in the signal.

2. For calculating jitter application, consider the edges attached with long
sequence of ones and zeros. This makes sure that the only uncorrelated jitter
is measured. Application performs this measurement with longer record
length to get more accurate results.

3. EBUJ (Effective bounded uncorrelated jitter) and ERJ (Effective random
jitter) are calculated from the signal using dual-dirac jitter analysis as given
in specification section 92.8.3.8.2.

Effective total uncorrelated jitter is calculated using the equation Effective
total uncorrelated jitter = 7.9 * ERJ + EBUJ.

Limits

CR4 and KR4 Effective bounded uncorrelated jitter <= 0.1 UI
peak-to-peak
Effective total uncorrelated jitter <= 0.18 UI
peak-to-peak
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SCPI commands

About SCPI command
You can use Standard Commands for Programmable Instruments (SCPI) to
communicate with the TekExpress application.

Socket configuration for SCPI commands
This section describes the steps for TCPIP socket configuration and TekVISA
configuration to execute the SCPI commands.

TCPIP socket
configuration

1. Click Start > Control Panel > System and Security > Windows Firewall >
Advanced settings
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2. In Windows Firewall with Advanced Security menu, select Windows
Firewall with Advanced Security on Local Computer > Inbound Rules
and click New Rule…
 

 
3. In New Inbound Rule Wizard menu
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a. Select Port and click Next
 

 

 SCPI commands

TekExpress® 100G-TXE Printable Application Help 77



b. Select TCP as rule apply and enter 5000 for Specific local ports and
click Next
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c. Select Allow the connection and click Next
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d. Select Domain, Private, Public and click Next
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e. Enter Name, Description (optional), and click Finish
 

 
4. Check whether the Rule name is displayed in Windows Firewall with

Advanced Security menu > Inbound Rules
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TekVISA configuration 1. Click Start > All Programs > TekVISA > OpenChoice Instrument
Manager
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2. Click Search Criteria. In Search Criteria menu, click LAN to Turn-on.
Select Socket from the drop-down list, enter the IP address of the

TekExpress device in Hostname and type Port as 5000. Click  to
configure the IP address with Port.

Enter the Hostname as 127.0.0.1 if the TekVISA and TekExpress application
are in the same system, else enter the IP address of the TekExpress
application system.
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3. Click Search to setup the TCPIP connection with the host. Check whether
the TCPIP host name is displayed in OpenChoice Instrument Manager >
Instruments
 

 
4. Double-click OpenChoice Takler Listener and enter the Command *IDN?

in command entry field and click Query. Check that the Operation is
successful and Talker Listener Readout displays the Command / Data.
 

 

SCPI commands  

84  TekExpress® 100G-TXE Printable Application Help



TEKEXP:*IDN?
This command queries the active TekExpress application name running on the
scope. 

Syntax TEKEXP:*IDN?\n

Inputs NA

Outputs Returns active TekExpress application name running on the scope

TIP. Click here for examples.

TEKEXP:*OPC?
This command queries the execution status of the last executed command. 

Syntax TEKEXP:*OPC?\n

Inputs NA

Outputs 0 - last command execution is not complete

1 - last command execution is complete

TIP. Click here for examples.
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TEKEXP:ACQUIRE_MODE
This command sets the acquire mode as live or pre-recorded.

Syntax TEKEXP:ACQUIRE_MODE {LIVE | PRE-RECORDED}\n

Inputs {LIVE | PRE-RECORDED}

Outputs NA

TIP. Click here for examples.

TEKEXP:ACQUIRE_MODE?
This command queries the acquire mode type.

Syntax TEKEXP:ACQUIRE_MODE?\n

Inputs NA

Outputs {LIVE | PRE-RECORDED}

TIP. Click here for examples.
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TEKEXP:EXPORT
This command returns all the bytes of data to the specified file. 

Syntax Outputs
TEKEXP:EXPORT REPORT\n Returns the report file in bytes
TEKEXP:EXPORT WFM,"<FileName>"\n Returns the specified waveform file in bytes
TEKEXP:EXPORT IMAGE,"<FileName>"\n Returns the specified image file in bytes

Inputs FileName - Specifies the file name

TIP. Click here for examples.

TEKEXP:INFO?
This command queries the information about the file(s).

Syntax Outputs
TEKEXP:INFO? REPORT\n <ReportFileSize>,"<ReportFileName.mht>"
TEKEXP:INFO? WFM\n <WfmFile1Size>,"<WfmFileName1.wfm>";<Wfm

File2Size>,"<WfmFileName2.wfm>";...
TEKEXP:INFO? IMAGE\n <Image1FileSize>,"<Image1FileName>";<Image

2FileSize>,"<Image2FileName>" ;...

TIP. Click here for examples.

 SCPI commands

TekExpress® 100G-TXE Printable Application Help 87



TEKEXP:INSTRUMENT
This command sets the value for the selected instrument type. 

Syntax TEKEXP:INSTRUMENT "<InstrumentType>",<Value>"\n

Inputs InstrumentType

Value

TIP. Check Command parameters list for InstrumentType and Value parameters.

Outputs NA

TIP. Click here for examples.

TEKEXP:INSTRUMENT?
This command queries the instrument selected for the specified instrument type. 

Syntax TEKEXP:INSTRUMENT? "<InstrumentType>"\n

Inputs InstrumentType

TIP. Check Command parameters list for InstrumentType parameters.
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Outputs Returns the instrument selected for the specified instrument type

TIP. Click here for examples.

TEKEXP:LASTERROR?
This command queries the last error string occurred for the current TCP session.
If there are no errors since startup, or since the last call to
TEKEXP:LASTERROR?\n, this command returns an empty string.

Syntax TEKEXP:LASTERROR?\n

Inputs NA

Outputs <string>

TIP. Click here for examples.

TEKEXP:LIST?
This command queries the list of available device, suite, test, version or
instrument. 

Syntax Outputs
TEKEXP:LIST? DEVICE\n Returns the list of available device(s) as comma

separated values.
TEKEXP:LIST? SUITE\n Returns the list of available suite(s) as comma

separated values.
TEKEXP:LIST? TEST\n Returns the list of available test(s) as comma

separated values.
TEKEXP:LIST? VERSION\n Returns the list of available version(s) as comma

separated values.
TEKEXP:LIST?
INSTRUMENT,"<InstrumentType>"\n

Returns the list of available instruments' for the
given Instrument type as comma separated
values.
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NOTE. This command returns the list of items within double quotes (""). Iterate
the receive procedure until the list ends with double quotes otherwise the next
query commands won’t work as expected.

Inputs InstrumentType

TIP. Check Command parameters list for InstrumentType parameters.

TIP. Click here for examples.

TEKEXP:MODE
This command sets the execution mode as compliance or user defined. 

Syntax TEKEXP:MODE {COMPLIANCE | USER-DEFINED}\n

Inputs {COMPLIANCE | USER-DEFINED}

Outputs NA

TIP. Click here for examples.
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TEKEXP:MODE?
This command queries the execution mode type. 

Syntax TEKEXP:MODE?\n

Inputs NA

Outputs {COMPLIANCE | USER-DEFINED}

TIP. Click here for examples.

TEKEXP:POPUP
This command sets the response to the active popup shown in the application.

Syntax TEKEXP:POPUP “<PopupResponse>”\n

Inputs PopupResponse

Outputs NA

TIP. Click here for examples.
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TEKEXP:POPUP?
This command queries the active popup information shown in the application.

Syntax TEKEXP:POPUP?\n

Inputs NA

Outputs Returns the active popup information in the application.

TIP. Click here for examples.

TEKEXP:REPORT
This command generates the report for the current session. 

Syntax TEKEXP:REPORT GENERATE\n

Inputs GENERATE

Outputs NA

TIP. Click here for examples.
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TEKEXP:REPORT?
This command queries the queried header field value in the report.

Syntax TEKEXP:REPORT? “<HeaderField>”\n

Inputs HeaderField - Specifies to return the measured value for the indicated test.

TIP. Check Report for HeaderField parameters.

Outputs Returns the queried header field value in the report

TIP. Click here for examples.

TEKEXP:RESULT?
This command queries the result available in report summary/details table.

Syntax Outputs
TEKEXP:RESULT? "<TestName>"\n Return Pass/Fail status of the test.
TEKEXP:RESULT?
"<TestName>","<ColumnName>"\n

Returns all the row values of the specified
column for the test.

TEKEXP:RESULT?
"<TestName>","<ColumnName>",<RowNumber
>\n

Returns the column value for the specified row
number  1.

1 Row number starts from zero.
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Inputs TestName - Specifies the name of the test for which to obtain the test result
value.

ColumnName - Specifies the column name for the measurement

RowNumber - Specifies the row number of the measurement

TIP. Check Report for TestName, ColumnName, and RowNumber parameters.

TIP. Click here for examples.

TEKEXP:SELECT
This command selects the device, suite, version, or test. 

Syntax TEKEXP:SELECT <string1>,<string2>,<string4>\n

TEKEXP:SELECT TEST,<string3>,<string4>\n

Inputs <string1> = {DEVICE | SUITE | VERSION}

<string2> = {DeviceName | SuiteName | VersionName}

<string3> = {“<TestName>"| ALL| REQUIRED }

<string4> = {TRUE | FALSE}

TIP. Check Command parameters list for DeviceName, SuiteName, VersionName,
and TestName parameters.

TIP. Click here for examples.
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Outputs NA

TEKEXP:SELECT?
This command queries the name of the selected device, suite, version, or test. 

Syntax TEKEXP:SELECT? {DEVICE | SUITE | TEST | VERSION}\n

Inputs {DEVICE | SUITE | TEST | VERSION}

Outputs Returns the name of the selected device, suite, version, or test.

TIP. Click here for examples.

TEKEXP:SETUP
This command sets the value of the current setup.

Syntax Outputs
TEKEXP:SETUP DEFAULT\n Restore to default Setup
TEKEXP:SETUP OPEN,"<SessionName>"\n Open the session
TEKEXP:SETUP SAVE\n Save the session
TEKEXP:SETUP SAVE,"<SessionName>"\n Save the session

Inputs SessionName - The name of the session

TIP. Click here for examples.
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TEKEXP:STATE
This command sets the execution state of the application.

Syntax TEKEXP:STATE {RUN | STOP | PAUSE | RESUME}\n

Inputs {RUN | STOP | PAUSE | RESUME}

Outputs NA

TIP. Click here for examples.

TEKEXP:STATE?
This command queries the current setup state. 

Syntax Outputs
TEKEXP:STATE? RUNNING | PAUSED | WAIT | ERROR | READY

| STOPPED
TEKEXP:STATE? SETUP SAVED | NOT_SAVED

TIP. Click here for examples.
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TEKEXP:VALUE
This command sets the value of parameters of type General, Acquire, Analyze, or
DUTID. 

Syntax TEKEXP:VALUE GENERAL,"<ParameterName>",“<Value>”\n

TEKEXP:VALUE ACQUIRE,"<AcquireType>", "<ParameterName>",
“<Value>”\n

TEKEXP:VALUE ANALYZE,"<ParameterName>".“<Value>”\n

TEKEXP:VALUE DUTID,“<Value>”\n

Inputs ParameterName - Specifies the parameter name

AcquireType - Specifies the acquire type

Value - Specifes the value to set

TIP. Check Command parameters list for ParameterName, AcquireType, and
Value parameters.

Outputs NA

TIP. Click here for examples.

 SCPI commands

TekExpress® 100G-TXE Printable Application Help 97



TEKEXP:VALUE?
This command queries the value of the parameter for type General, Acquire,
Analyze, or DUTID.

Syntax Outputs
TEKEXP:VALUE?
GENERAL,"<ParameterName>"\n

Returns the value of Parameter for type
GENERAL

TEKEXP:VALUE?
ACQUIRE,"<AcquireType>","<ParameterName>
"\n

Returns the value of Parameter for type
ACQUIRE

TEKEXP:VALUE?
ANALYZE,"<ParameterName>"\n

Returns the value of Parameter for type
ANALYZE

TEKEXP:VALUE? DUTID\n Returns the DUTID value

Inputs ParameterName - Specifies the parameter name

AcquireType - Specifies the acquire type

TIP. Check Command parameters list for ParameterName and AcquireType
parameters.

Outputs Returns the value of Parameter for type GENERAL | ACQUIRE | ANALYZE |
DUTID.

TIP. Click here for examples.

SCPI commands  

98  TekExpress® 100G-TXE Printable Application Help



Command parameters list
This section provides the parameters list for the SCPI commands.

TekExpress 100G-TXE
command parameters

Parameters Description
InstrumentType Specifies the instrument type.

Valid values are:

■ AWG

■ Real Time Scope

Value Specifies the value parameters.

■ For InstrumentType, valid values are:

■ Do not use

■ GPIB8::1::INSTR

■ For DUTID, valid value is:

■ Comment

DeviceName Specifies the device name. Valid values are:

■ CAUI4-TX

■ KR4-TX

■ CR4-TX

SuiteName Specifies the suite name.
Valid values are:

■ TP1a, TP4 for CAUI4

■ TP0a for CR4

■ TP2 for KR4

VersionName Specifies the version name. Valid values are

■ 100GBASE Tx, IEEE 802.3bm, Annex 83E.3.1 

■ 100GBASE Tx, IEEE 802.3bm, Annex 83E.3.2 

■ 100GBASE Tx, IEEE 802.3bj - Section 93 

■ 100GBASE Tx, IEEE 802.3bj - Section 92 

 SCPI commands

TekExpress® 100G-TXE Printable Application Help 99



Parameters Description
TestName for CAUI4 ■ DC Common Mode Output Voltage

■ Diff Peak to Peak Output Voltage -Tx Disabled

■ Diff Peak to Peak Output Voltage -Tx Enabled

■ AC Common Mode Output Voltage

■ Single Ended Output Voltage

■ Signaling Rate

■ Eye Width

■ Eye Height Differential

■ Transition Time

■ Vertical Eye closure
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Parameters Description
TestName for KR4 ■ DC Common Mode Output Voltage

■ Diff Peak to Peak Output Voltage -Tx Disabled

■ Diff Peak to Peak Output Voltage -Tx Enabled

■ AC Common Mode Output Voltage

■ Single Ended Output Voltage

■ Signaling Rate

■ Linear Fit Pulse Peak

■ Minimum Pre-cursor full scale ratio

■ Minimum Post-cursor full scale ratio

■ Normalized Coefficient Step Size

■ Signal To Noise And Distortion Ratio

■ Steady State Voltage

■ Even-Odd Jitter Peak to Peak

■ Effective total uncorrelated jitter peak to peak

■ Effective bounded uncorrelated jitter peak to peak

TestName for CR4 ■ DC Common Mode Output Voltage

■ Diff Peak to Peak Output Voltage -Tx Disabled

■ Diff Peak to Peak Output Voltage -Tx Enabled

■ AC Common Mode Output Voltage

■ Single Ended Output Voltage

■ Signaling Rate

■ Linear Fit Pulse Peak

■ Minimum Pre-cursor full scale ratio

■ Minimum Post-cursor full scale ratio

■ Normalized Coefficient Step Size

■ Signal To Noise And Distortion Ratio

■ Steady State Voltage

■ Even-Odd Jitter Peak to Peak

■ Effective total uncorrelated jitter peak to peak

■ Effective bounded uncorrelated jitter peak to peak

ParameterName and Value for General, Acquire and Analyze

Specifies the ParameterName and Value for General, Acquire and Analyze. The
configuration parameters available are not same for measurements.
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Table 15: ParameterName and Value for General

ParameterName Value
Report Update Mode ■ New

■ Append

■ Replace

Auto increment report name if
duplicate

TRUE or FALSE

Include Pass/Fail Results
Summary

TRUE or FALSE

Include Detailed Results TRUE or FALSE
Include Plot Images TRUE or FALSE
Include Setup Configuration TRUE or FALSE
Include User Comments TRUE or FALSE
Save As Type ■ Web Archive (*.mht;*.mhtml)

■ PDF (*.pdf;)

■ CSV (*.csv;)

View Report After Generating TRUE or FALSE
Report Group Mode ■ Test Name

■ Test Result

Create report at the end ■ Included

■ Excluded

DUTID Comment User comment
Run Test More than Once TRUE or FALSE
Number of Runs 1 to 200 
On Failure Stop and Notify TRUE or FALSE
Timer Warning Info Message
Popup ■ "True"

■ "FALSE"

Timer Warning Info Message
Popup Duration

1 to 300 

Timer Error Message Popup ■ "True"

■ "False"

Timer Error Message Popup
Duration

1 to 300 

Probing Type ■ SINGLE ENDED

■ Differential
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ParameterName Value
Signal Validation ■ Prompt me if Signal Validation Fails

■ Skip Test if Signal Validation Fails

■ Use signal as is - Don't Validate

Pattern Type ■ PRBS7

■ PRBS9

■ PRBS11

■ PRBS15

Data Rate valid value is 18 to 28.05 
MODE ■ COMPLIANCE

■ USER-DEFINED

ACQUIRE_MODE ■ LIVE

■ PRE-RECORDED

Bandwidth ■ Full BW

■ 50GHz

RL for JItter ■ 20 

■ 30 

■ 40 

RL for Eye ■ 20 

■ 30 

■ 40 

Apply Filter True or False
De-Embedding filter Filter path

Example: TEKEXP:VALUE GENERAL,"De-Embedding filter","C:\Users\sqetest\Desktop"
Ref levels ■ Absolute

■ Percentage

Hysteresis ■ For Percentage, valid value is 0 to 10 

■ For Absolute, valid value is -2 to 2 

Mid level ■ For Percentage, valid value is 45 to 55 

■ For Absolute, valid value is -10 to 10 
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ParameterName Value
CTLE FilterFIle ■ All

■ CTLE_1dB.flt

■ CTLE_2dB.flt

■ CTLE_3dB.flt

■ CTLE_4dB.flt

■ CTLE_5dB.flt

■ CTLE_6dB.flt

■ CTLE_7dB.flt

■ CTLE_8dB.flt

■ CTLE_9dB.flt

■ Custom

■ BestCTLE

Custom Filter Path (when CTLE
FilterFIle is Custom)

CTLE filter file path
Example: TEKEXP:VALUE GENERAL,"Custom Filter Path","C:\Program Files\Tektronix\TekExpress
\TekExpress 100G-TXE\Compliance Suites\CAUI4-TX\TP1a\CTLE Filters\25.78125"

Custom Filter File (to select
multiple custom CTLE filter file)

Names of CTLE filter files to select
Example: TEKEXP:VALUE GENERAL,"Custom Filter File","CTLE_5dB.flt;CTLE_2dB.flt"

Table 16: ParameterName and Value for Analyze

Test Name ParameterName Value
Transition Time Measurement Range ■ 10% - 90%
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Examples
This section provides the examples for the SCPI commands.

Example Description
TEKEXP:*IDN?\n It returns the active TekExpress application name running on the

scope.
TEKEXP:*OPC?\n It returns the last command execution status.
TEKEXP:ACQUIRE_MODE PRE-RECORDED\n It sets the acquire mode as pre-recorded.
TEKEXP:ACQUIRE_MODE?\n It returns LIVE when acquire mode is set to live.
TEKEXP:EXPORT REPORT\n It returns the report file in bytes. This can be written into another file

for further analysis.
TEKEXP:INFO? REPORT\n It returns “100,”ReportFileName.mht”", when 100 is the filesize in

bytes for the filename ReportFileName.
TEKEXP:INFO? WFM\n It returns “100,“WfmFileName1.wfm”";“200,“WfmFileName2.wfm”"

when 100 is the filesize in bytes for the filename
WfmFileName1.wfm and 200 is the filesize in bytes for the filename
WfmFileName2.wfm.

TEKEXP:INSTRUMENT "Real Time Scope",DPO72504D
( GPIB8::1::INSTR )\n

It sets the instrument value as DPO72504D ( GPIB8::1::INSTR ) for
the selected instrument type Real Time Scope.

TEKEXP:INSTRUMENT? “Real Time Scope”\n It returns "IDPO72504D ( GPIB8::1::INSTR ), when DPO72504D
( GPIB8::1::INSTR )" is the selected instrument for the instrument
type Real Time Scope.

TEKEXP:LASTERROR?\n It returns ERROR: INSTRUMENT_NOT_FOUND, when no
instrument is found.

TEKEXP:LIST? DEVICE\n It returns "TX-Device,RX-Device" when TX-Device, RX-Device are
the available device.

TEKEXP:LIST? INSTRUMENT,"Real Time Scope"\n It returns "DPO72504D ( GPIB8::1::INSTR ),MSO72504 ( TCPIP::
134.64.248.91::INSTR )" when DPO72504D ( GPIB8::1::INSTR ),
MSO72504 ( TCPIP::134.64.248.91::INSTR ) are the list of available
instruments.

TEKEXP:MODE COMPLIANCE\n It sets the execution mode as compliance.
TEKEXP:MODE?\n It returns COMPLIANCE when the execution mode is compliance.
TEKEXP:POPUP “OK”\n It sets OK as the response to active popup in the application.
TEKEXP:POPUP?\n It returns "OK", when OK is the active popup information shown in

the application.
TEKEXP:REPORT GENERATE\n It generates report for the current session.
TEKEXP:REPORT? “Scope Model”\n It returns "DPO73304SX" when DPO73304SX is the scope model.
TEKEXP:REPORT? “DUT ID”\n It returns "DUT001" when DNI_DUT001 is the DUT ID.
TEKEXP:RESULT? "Period using SCOPE (Acquire-Analyze
Combined)"\n

It returns Pass when the test result is Pass.

TEKEXP:RESULT? "Period using SCOPE (Acquire-Analyze
Combined)","Margin",1\n

It returns "L:-50.000ps H:2000.000ps" when L:-50.000ps H:
2000.000ps is the value.

TEKEXP:SELECT DEVICE, TX_Device, TRUE\n It selects TX_Device
TEKEXP:SELECT? DEVICE\n It returns "TX-Device" when TX-Device is the selected device type.
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Example Description
TEKEP:SETUP DEFAULT\n It restores the application to default setup.
TEKEXP:STATE STOP\n It stops the test execution.
TEKEXP:STATE?\n It returns as READY when the application is ready to run next

measurement.
TEKEXP:STATE? SETUP\n It returns as NOT_SAVED when the current setup is not saved.
TEKEXP:VALUE GENERAL,"Signal Type", "N1N0"\n It sets the signal type parameter value to N1N0.
TEKEXP:VALUE? GENERAL,"Signal Type"\n It returns "N1N0" when N1N0 is the Signal Type value.
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100GBASE-KR4, vi

A
About TekExpress, vi
Acquire parameters

including in test reports, 34
viewing in reports, 36

Acquisition tab, 25
Analysis options, 29
Application directories, 8
Application panels overview, 12
Application version (show), 7
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Button
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Email settings, 29
save, 30
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C
Calibration button, 25
CAUI-4, vi
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AC common mode output voltage, 55, 56
DC common mode output voltage, 53
Diff peak to peak output voltage - Tx disabled, 54
Diff peak to peak output voltage - Tx enabled, 54
Eye width and Eye height, 58
Signaling rate (data rate), 57
Transition time, 61
Vertical eye closure, 60

CLTE filters for eye width, 58
Compensate the signal path, 47
Configuration tab, 20
Configuration tab parameter

instruments detected, 26
Configuration tab parameters

global settings, 26
Connected instruments

searching for, 17, 18
Connection requirements, 39
Contacting Tektronix, 2
CR4 / KR4 measurements

AC common mode output voltage, 66
DC common mode output voltage, 63
Diff peak to peak output voltage - Tx disabled, 64
Diff peak to peak output voltage - Tx enabled, 65

Output jitter
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peak, 74
Even-odd jitter peak to peak, 73
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Transmitter waveform requirement

Linear fit pulse peak, 68
Minimum post-cursor full scale ratio, 70
Minimum pre-cursor full scale ratio, 69
Normalized coefficient step size, 70
Signal to noise and distortion ratio, 72
Steady state voltage, 69

Create a test setup from default settings, 52
Create a test setup using an existing one, 52

D
DUT ID, 22
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device, 22
device profile, 22
optical module settings, 22
optical power, 22

DUT type
device, 22
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Equipment setup, 39
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Extensions, file names, 9

F
Features (100G-TXE), vi
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H
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I
Installing the software
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Instruments

discovering connected, 17
viewing connected, 18
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Instruments detected, 26
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L
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License agreement (show), 7
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Loading a test setup, 52
Log view

save file, 30
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Opening a saved test setup, 52
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Setup
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Setup files, 51
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preferences tab, 20
test selection, 20
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Software installation
TekExpress 100G-TXE Solution, 7

Source, 22

Status panel
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message history, 30
test status tab, 30

Support, 2
System requirements, 5

T
Technical support, 2
Tek Link, 17
Test Name, 25
Test reports, 36
Test results

send by email, 19
Test selection

100G-TXE, 23
optical tests, 23
test description, 23

Test selection controls, 23
Test setup files, 33, 51
Test setups

load, 52
open, 52
recalling, 52

Test status
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analysis status, 30
auto scroll, 30

Test-related files, 33
Tests

running, 49
selecting, 23

U
USB, 17
User Comments

including in reports, 35

V
View a report, 36
View application license agreement, 7
View application software version, 7
View optical modules button, 25
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VXI, 17

W
Waveform files
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