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About ArbExpress Version 3.3 AXW100 Software

About ArbExpress Version 3.3 AXW100 Software
ArbExpress AXW100 Waveform Creation and Editing Tool for Tektronix AWG/AFG is PC-based
software that runs on the Windows 7 Enterprise, Windows 98, Windows NT, Windows 2000, Windows XP
Professional, and Windows Me operating systems.
ArbExpress generates waveforms for Tektronix signal-source instruments. You can create and edit
waveforms: transfer waveforms to and from Tektronix oscilloscopes, Arbitrary Waveform Generators
(AWG ), and Arbitrary Function Generators (AFG), and remotely control AWGs and AFGs. ArbExpress
generates the following standard waveforms: — Sine, Square, Triangle, Pulse, DC, Exponential Rise,
Exponential Decay, Noise, Sinc, Sweep, Multi-Tone, and Lorentz.

Configuration
The minimum requirements for the ArbExpress AXW100 application:
OS supported

Minimum requirements

Windows 7 Enterprise
Windows XP Professional Service Pack 1
Or
Windows 2000
Or
Windows 98/Me
Or
Windows NT Service Pack 6a

Pentium III @ 800 MHz and higher
256 MB RAM
300 MB Free Disk Space
Microsoft Windows® Internet Explorer® 5.01
800 X 600 Display Resolution

xxx

The following table lists the conditions under which ArbExpress uses TekVisa version 4.0.0.80 and newer
to send data to a Tektronix arbitrary waveform generator. If TekVisa is not already installed on your PC,
you can download the software from www.tektronix.com/software.
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Communication type

AWG/AFG

Oscilloscope

LAN

The AWG400, AWG500, AWG600,
and AWG700 series of instruments
are supported through raw sockets
(TekVisa may not be required 1).
The AFG2000 and AFG3000 series
of instruments are supported through
VXI 11 server.
These instruments are not supported
through raw sockets (TekVisa is
required).
MDO3000 Series oscilloscopes with
MDO3AFG option enabled.

TekVisa required

GPIB

TekVisa required

TekVisa required

RS232

Not supported

TekVisa required

TekVisa

USB

required 2

TekVisa required

xxx

1
2

* AFG300 and AWG2000 series instruments do not support LAN
** Only the AFG 2000 and AFG3000 series instruments support USB

ArbExpress supports file transfer and control from MATLAB version 6.1, release 12.1. To use this feature,
install TekVisa.

Installation
This section describes how to install the ArbExpress AXW100 application using the InstallShield Wizard.
1. Insert the ArbExpress CD-ROM into the CD-ROM drive.
2. If the installation program does not automatically start, double–click setup.exe in the folder
\ArbExpress on the CD-ROM. The installation wizard opens.
3. Follow the onscreen instructions. To navigate through the wizard, click Next or Back to move to
the next or previous screen.
The installation wizard sequence of screens:
Welcome
License Agreement
Choose Destination Location
Start Copying Files
Setup Status
View Release Notes
4. In the Welcome screen, click Next.

2
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5. In the License Agreement screen:
a. Read the License Agreement carefully.
b. Select I accept the terms of the License agreement, and then click Next.
6. In the Choose Destination Location screen:
a. To install ArbExpress in the default folder C:\Program Files\Tektronix\ArbExpress, click Next.
—or—
b. To install ArbExpress elsewhere, click Browse.
7. In the Start Copying Files screen, click Next.
The Setup Status screen opens and displays a progress bar. ArbExpress is installed in the folder you
selected in the Choose Destination Location screen, and a shortcut is added to the Start menu.
When the installation is complete, the message "ArbExpress Software Setup completed successfully"
is displayed. If TekVisa is not already on your computer, ArbExpress displays a message to install
them. The installation programs are located on the ArbExpress CD-ROM in the folders \TekVisa
and \DotNet Framework.
If the USB Device Driver does not install automatically, you must install it manually:
a. Power on the USBTMC-compliant instrument and connect it to the computer.
b. In the Found New Hardware wizard, follow the onscreen instructions.
c. Choose Install from a list or specific location.
d. Select Don't choose, I will choose the driver to install.
e. For the location of the driver, enter C:\vxipnp\winnt\tekvisa\bin.
f.

Select TekUSB.inf, and then click Open.
The driver is installed. For more information, see the TekVisa readme.pdf file.

8. Click Finish to exit.
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Using Help
Select Help on the right side of the application menu bar to show the Help.
Table of Contents (TOC) tab — organizes the Help into book-like sections. Select a book icon to open a
section; select any of the topics listed under the book.
Index tab — enables you to scroll through alphabetical list of keywords. Select the topic of interest to
show the appropriate help page.
Search tab — allows a text-based search.
To search with the Search tab:
1. Type the word or phrase you want to find in the search box.
2. Select some matching words in the next box to narrow your search.
3. Choose a topic in the lower box, and then click Display.
To print a topic, click Print on the Help Topics menu bar.
Select Options from the menu bar to access other commands, such as annotating a topic or keeping the
help window on top, or to use system colors.
Click Back to return to the previous help window. Use the hyperlink to jump from one topic to
another. If the Back button is grayed out or a jump is not available, click Help Topics to return to
the originating help folder.
Browse buttons (Next and Previous) allow you to move forward and backward through topics in the
order of the Table of Contents (TOC).
Notes indicate particularly important information.
NOTE. Certain aspects of the online help are unique. Blue-underlined text indicates a jump (hyperlink) to
another topic. Click the blue text to jump to the related topic. For example, select the blue text to jump to
the topic on Online Help and Related Documentation and the Back button to return to the previous page.
You can tell when the cursor is over an active hyperlink (button, jump, or pop-up), because the cursor
arrow changes to a small hand.
For help on specific dialog boxes, display the TOC for this help file, and then navigate to Operating
Basics > Dialog Boxes.

See Also:
Printing from the Online Help (see page 5)
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Printing from the Online Help
You can print topics and information from the Help viewer. Some help topics have color images that might
not print if you use a monochrome printer. Instead, print the topic from the PDF file that corresponds to the
Online Help. You can find the file in the main directory on the CD-ROM disk. Images in the PDF file are
gray scale, so the relevant information appears in print.
To print a single topic:
1. Find the topic in the Table of Contents (TOC) pane.
2. Click Print from the menu.
3. Click Print the selected topic.
4. Click OK.
To print all topics in a TOC book:
1. Find the book in the TOC pane.
2. Click Print from the menu.
3. Click Print the selected heading and all subtopics.
4. Click OK.
TIP. If topics include expanding or drop-down hotspots, click the hotspots to display the information
before you print.
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Basic Operations

Basic Operations
ArbExpress AXW100 Waveform Creation and Editing Tool for Tektronix AWG/AFG is Windows-based
software with a graphical user interface that you can use to create, edit, and transfer standard waveforms to
an Arbitrary Waveform Generator, an Arbitrary Function Generator, or an oscilloscope.
In this online help, all menu selections are indicated as Menu name > Menu options. You can access a
command or a menu option in more than one way. Several main menu options are available as toolbars
that you can use instead of selecting the option from the main menu. You can show or hide the toolbars
and also create customized toolbars. Shortcut menus, which open with a right-click, are provided for
waveform editing, connecting to an instrument, and transferring a waveform to an arbitrary waveform
generator or an arbitrary function generator.
The Shortcut View on the left of the screen shows options that are available in the main menu or in the
toolbars. The Shortcut View provides the most common commands.
Some dialog boxes also have a Help button that displays help for that dialog box. Some other dialog boxes
have a toolbar for basic operations like Open, Save, Connect, Disconnect, and Show/Hide Properties.
The following figure shows the application screen, the menu, and the toolbars.
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File Name Extensions

In the ArbExpress software, you can enter values in fields in different ways. In some fields, you type in the
values. In others, you select from a drop-down list, and in others, you can use the spin-box to increase
or decrease the values. You can type in the characters K for Kilo, G for Giga, M for Mega, u for Micro,
m for milli, and n for nano.

File Name Extensions
The application uses these file name extensions to identify the file type. The following table lists the
file name extensions.

8
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File name extensions

Description

.wfm

Oscilloscope waveform files AWG waveform files created
by AWG400-700, and AWG2000 series of waveform
generators

.pat

AWG pattern format files

.tfw

Waveform files for the AFG2000 and AFG3000 series
arbitrary/function generators

.isf
.csv

Waveform files for the TDS3000 instruments

.txt

Text files

.equ/.eqa

Equation files

.set
.p

AWG setup information files

.m

MATLAB equation files

.ico

Icon files

.chm

Compiled HTML Help files

.dll
.exe

Application extension files

Comma separated variable files

MATLAB compiled files

Application file

xxx

Application File Names and Directories
The application uses specific directories to save files. The following table lists the default directory names.
Directory

Function

C:\Program Files\Tektronix\ArbExpress\System

Stores the application file — .exe, .dll, Release notes.c,
and .chm

C:\Program Files\Tektronix\ArbExpress\Documentation

Stores the user manual and the installation manual (.pdf)

C:\Program Files\Tektronix\ArbExpress\Samples\Waveform

Stores the sample waveform files (.wfm)

C:\Program Files\Tektronix\ArbExpress\Samples\Equation

Stores the sample equation files (.eqa)

C:\Program Files\Tektronix\ArbExpress\Samples\Tools\Matlab

Stores the sample MATLAB equation files (.m)

xxx

You can install ArbExpress in a directory of your choice.
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Starting the Application

Starting the Application
1. Run the application from the Windows Start menu by clicking Start > Programs > Tektronix
ArbExpress > ArbExpress Application.
—or—
2. Go to the folder where you have installed ArbExpress, and double-click ArbExpress.exe.
—or—
3. Start the application from OpenChoice Instrument Manager.

Opening a Waveform
File > Open
To open a waveform, select File > Open. Browse and select the waveform file to open. You can open
files with .wfm, .pat, TekScope .wfm, .tfw, .csv, and .txt, extensions.
When more than one waveform is opened in a window, the active waveform is a solid line and the inactive
waveform is a dashed line.

Working with Waveforms
To select the active waveform, select Waveform1 or Waveform2.
Set the cursor positions by entering values in the Cursor1 and Cursor2 fields.
Drag the cursors to change the cursor readout values.
A tool tip dynamically displays the voltage values at the cursor position.

10
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Opening a Waveform

See Also:
Creating a Waveform (see page 12)
Saving a Waveform (see page 13)
Closing a Waveform (see page 14)
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Creating a Waveform

Creating a Waveform
File > Blank sheet
File > Standard Waveform
File > Equation Editor
The File menu contains three options for creating a waveform: Blank Sheet, Standard Waveform, and
Equation Editor.
Blank Sheet — opens a blank sheet in a window. By default, the application opens the waveform with
1024 points, which you can change using Waveform > Properties. After you specify the number of
points using Waveform Properties, the next time you create a new blank sheet, the application opens a
blank sheet using the number of points that you specified.

Example
1. Click File > Blank Sheet.
2. Click Waveform > Properties, and then change the number of points to 500.
3. Click File > Blank Sheet.
The new blank sheet has 500 points.
4. Click File > Blank Sheet.
The new blank sheet has 1024 points.
Standard Waveform — displays the Standard Waveform dialog box. Use the Standard Waveform to
create any of the standard waveforms that are available.
Equation Editor — displays the Equation Editor dialog box (see page 46). Use the Equation Editor to
create a waveform or edit an existing waveform equation.

See Also:
Sine Wave (see page 79)
Square Wave (see page 82)
Triangle Wave (see page 85)
Pulse Wave (see page 88)
Noise Wave (see page 91)
DC Wave (see page 94)
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Exponential Rise Wave (see page 96)
Exponential Decay Wave (see page 98)
Sinc Wave (see page 101)
Sweep Wave (see page 103)
Multi-Tone Wave (see page 106)
Lorentz Wave (see page 109)
Using the Equation Editor (see page 75)

Saving a Waveform
File > Save
File >Save As
You can save the waveform in the following formats: AWG Wfm (.wfm), AWG Pat (.pat), AWG
2000 Wfm (.wfm), AWG. csv (.csv), MDO3000 csv (.csv), and AFG Tfw (.tfw).
The application automatically saves a .set file with the same name as the waveform file. The .set file
contains the voltage values and the offset of the waveform, and the .wfm file contains the normalized
waveform.

See Also:
Creating a Waveform (see page 12)
Opening a Waveform (see page 10)
Closing a Waveform (see page 14)
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Closing a Waveform

Closing a Waveform
File> Close
When you close a waveform, the application closes the current window. If the waveform is not saved, you
are prompted to save it. In a multiple waveform display, Close closes the active waveform.

See Also:
Creating a Waveform (see page 12)
Opening a Waveform (see page 10)
Saving a Waveform (see page 13)
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Exiting the Application

Exiting the Application
File> Exit
If you have not saved the waveforms, you are prompted to do so.

Shortcut Keys
You can use the following shortcut keys for the application commands:
Menu item

Shortcut key

File> Blank Sheet

Ctrl + N

File> Standard Waveform

Ctrl + W

File> Open

Ctrl + O

File> Save

Ctrl + S

File> Exit

Ctrl + E

Edit> Undo

Ctrl + Z

Edit> Redo

Ctrl + Y

Edit> Cut

Ctrl + X

Edit> Copy

Ctrl + C

Edit> Paste

Ctrl + V

Edit> Select All

Ctrl + A

Edit> Invert

Ctrl + I

Edit> Mirror

Ctrl + M

Edit> Freehand

Ctrl + F

Display> Zoom In

Alt + Shift + Z

Display> Zoom Out

Alt + Shift + X

Display> Fit to Window

Alt + Shift + F

Display> Cursor

Ctrl + Shift + C

Display> Marker

Ctrl + Shift + M

Display> Properties

Ctrl + Shift + P

xxx
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Shortcut Keys

ArbExpress AXW100 Printable Help

Operating Basics

Menus

Menus
The application menu bar changes depending on whether a waveform is displayed. If no waveform is
open, the menu bar is:

When a waveform is open, the menu bar is:

See Also:
File Menu (see page 18)
Edit Menu (see page 19)
View Menu (see page 21)
Display Menu (see page 21)
Waveform Menu (see page 23)
Math Menu (see page 24)
Communication Menu (see page 26)
Window Menu (see page 27)
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File Menu

Help Menu (see page 28)

File Menu

Menu selection

Description

Blank sheet (see page 12)

Opens a blank waveform file (.wfm)

Standard Waveform (see page 12)

Opens the Standard Waveform dialog box that you can use
to create standard waveforms

Equation Editor (see page 12)

Opens the Equation Editor dialog box that you can use to
create waveforms

Open (see page 10)

Opens a waveform file (.wfm, .pat, .tfw, . csv, .txt )

Close (see page 14)

Closes an open waveform file

Save (see page 13)

Saves changes to the currently open waveforms

Save As (see page 13)

Saves files to a different file name using the Save as dialog
box (.wfm, AWG wfm, AWG2000 wfm), .pat, .csv, .tfw)

Exit (see page 15)

Exits the application

xxx

See Also:
Edit Menu (see page 19)
View Menu (see page 21)
Display Menu (see page 21)
Waveform Menu (see page 23)
Math Menu (see page 24)
Communication Menu (see page 26)
Window Menu (see page 27)
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Edit Menu

Help Menu (see page 28)

Edit Menu
The Edit menu is visible only if a waveform window is open.
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Edit Menu

Menu selection

Description

Undo (see page 117)

Undoes the last operation performed on a waveform

Redo (see page 117)

Redoes the last operation performed on a waveform

Cut (see page 118)

Cuts the portion of a waveform that is between cursors

Copy (see page 118)

Copies the portion of a waveform that is between cursors

Paste (see page 119)

Displays the paste options allowing you to choose where to
paste

Select All (see page 120)

Selects and copies the entire waveform into the memory

Copy to System Clipboard (see page 121)

Copies the waveform that can be pasted in Microsoft Excel
or Microsoft Word

Copy as Bitmap (see page 122)

Copies the selected waveform window as a bitmap that can
be pasted into Microsoft Word or Microsoft Excel

Invert (see page 122)

Inverts the portion of a waveform between the cursors

Mirror (see page 123)

Mirrors the portion of a waveform between the cursors

Shift/Rotate (see page 44)

Shifts the waveform by the defined amplitude or rotates the
waveform by a defined number of points

Freehand (see page 123)

Draws a waveform along the path you trace

Horizontal Draw (see page 124)

Allows drawing only horizontally

Vertical Draw (see page 124)

Allows drawing only vertically

Point Draw (see page 125)

The submenu options are: Enable Point Draw, Edit Point
Draw Table..., Linear, Smooth, Staircase, Dynamic Compile,
Compile Point Draw, Next Point Draw Point, Previous Point
Draw Point, Delete Point, Clear All.

Validate active waveform

Verifies whether the active waveform can be generated in
the target instrument

xxx

See Also:
File Menu (see page 18)
View Menu (see page 21)
Display Menu (see page 21)
Waveform Menu (see page 23)
Math Menu (see page 24)
Communication Menu (see page 26)
Window Menu (see page 27)
Help Menu (see page 28)
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View Menu

Menu selection

Description

Show/Hide Shortcut View (see page 36)

Displays and hides the shortcut view

Standard Toolbar (see page 31)

Displays and hides the standard toolbar

Waveform Toolbar (see page 31)

Displays and hides the waveform toolbar

Zoom Bar (see page 33)

Displays and hides the zoom toolbar

Instrument Bar (see page 34)

Displays and hides the instrument bar

Point Draw Toolbar (see page 35)

Displays the point draw toolbar

Status Bar (see page 36)

Displays and hides the status bar

xxx

See Also:
File Menu (see page 18)
Edit Menu (see page 19)
Display Menu (see page 21)
Waveform Menu (see page 23)
Math Menu (see page 24)
Communication Menu (see page 26)
Window Menu (see page 27)
Help Menu (see page 28)

Display Menu
The Display menu is available only when a waveform is displayed in the window.
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Display Menu

Menu selection

Description

Zoom In (see page 114)

Zooms in to the area selected

Zoom Out (see page 114)

Zooms out from the point selected

Horizontal Zoom In (see page 115)

Zooms in horizontally from the point selected

Fit to Window (see page 115)

Restores the view to the state that it was before the first
zoom operation

Cursor (see page 113)

Shows or hides the cursors

Cursor Position... (see page 113)

Positions the cursor exactly at the points or time specified

Marker (see page 112)

Shows or hides horizontal markers that you can set patterns
and triggers

Crosshair (see page 116)

Changes the cursor type to crosshair

Graticule (see page 116)

Shows or hides the graticule for the waveform

Time Scale (see page 116)

Displays time along the X-axis

Properties... (see page 116)

Displays the properties – color, line style, line width, and
cursor colors – of the selected waveform

xxx

See Also:
File Menu (see page 18)
Edit Menu (see page 19)
View Menu (see page 21)
Waveform Menu (see page 23)
Math Menu (see page 24)
Communication Menu (see page 26)
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Waveform Menu

Window Menu (see page 27)
Help Menu (see page 28)

Waveform Menu

Menu selection

Description

Equation Editor... (see page 75)

Creates a waveform using the equation editor

Sine... (see page 79)

Creates a sine wave

Square... (see page 82)

Creates a square wave

Triangle... (see page 85)

Creates a triangular wave

Pulse... (see page 88)

Creates a pulse wave

Noise... (see page 91)

Creates a noise wave

Dc... (see page 94)

Creates a DC wave

Exponential Rise... (see page 96)

Creates a exponential rise wave

Exponential Decay... (see page 98)

Creates a exponential decay wave

Sinc... (see page 101)

Creates a sinc wave

Sweep... (see page 103)

Creates a sweep wave

Multi-Tone... (see page 106)

Creates a multi-tone wave
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Math Menu

Menu selection

Description

Lorentz ... (see page 109)

Creates a Lorentz wave

Properties... (see page 42)

Displays the multi-waveform properties, waveform
properties, and preferences

xxx

See Also:
File Menu (see page 18)
Edit Menu (see page 19)
View Menu (see page 21)
Display Menu (see page 21)
Math Menu (see page 24)
Communication Menu (see page 26)
Window Menu (see page 27)
Help Menu (see page 28)

Math Menu
The Math menu is available only when a waveform window is open.

Menu Selection

Description

Waveform Math...
Operations:

24

Add

Adds the points of the selected waveforms and displays the resulting
waveform

Subtract

Subtracts the points of the selected waveforms and displays the
resulting waveform

Multiply

Multiplies the points of the selected waveforms and displays the
resulting waveform

Divide

Divides the points on the waveform and displays the resulting
waveform (available only when applying a scalar value)
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Math Menu

Menu Selection

Description

Scalar Value

Performs a scalar operation (addition, subtraction, multiplication,
division) on the waveform

Copy from Clipboard

Performs an operation (addition, subtraction, multiplication, division)
on the selected waveform with points copied to the clipboard

Normalize (see page 157)

Scales the waveform signal value to a ±1.0 range, with 0 as the
center

xxx

See Also:
File Menu (see page 18)
Edit Menu (see page 19)
View Menu (see page 21)
Display Menu (see page 21)
Waveform Menu (see page 23)
Communication Menu (see page 26)
Window Menu (see page 27)
Help Menu (see page 28)
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Communication Menu

Communication Menu

Menu selection

Description

AWG / AFG File Transfer... (see page 135)

Connects and transfers files to and from an arbitrary
waveform or function generator and allows you to change
instrument parameters like clock frequency, voltage, offset
and others of the instrument connected

Import from Scope... (see page 144)

Connects and acquires a waveform from an oscilloscope

Scope Acquisition Wizard (see page 149)

Guides you through steps to acquire data from a connected
oscilloscope

Send Waveform to Arb (see page 148)

Sends the waveform to a connected AWG/AFG

xxx

See Also:
File Menu (see page 18)
Edit Menu (see page 19)
View Menu (see page 21)
Display Menu (see page 21)
Waveform Menu (see page 23)
Math Menu (see page 24)
Window Menu (see page 27)
Help Menu (see page 28)

26

ArbExpress AXW100 Printable Help

Operating Basics

Window Menu

Window Menu

Menu selection

Description

Cascade

Arranges the open windows in the application client area
from upper-left to lower-right so that they overlap one
another

Tile Horizontally

Arranges the open windows horizontally in the application
client area without overlapping

Tile Vertically

Arranges the open windows vertically in the application
client area without overlapping

Close All

Closes all open windows in the client area

List of open windows

Allows you to jump to an open or inactive window

xxx

See Also:
File Menu (see page 18)
Edit Menu (see page 19)
View Menu (see page 21)
Display Menu (see page 21)
Waveform Menu (see page 23)
Math Menu (see page 24)
Communication Menu (see page 26)
Window Menu (see page 27)
Help Menu (see page 28)
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Help Menu

Help Menu
The Help menu is always visible.

Menu selection

Description

Help Topics

Displays the Help contents

Help on Window

Displays the help topic for the active window

Technical Support...

Displays the Tektronix Technical Support Web site for the
ArbExpress application

About...

Displays version and copyright information

xxx

See Also:
File Menu (see page 18)
Edit Menu (see page 19)
View Menu (see page 21)
Display Menu (see page 21)
Waveform Menu (see page 23)
Math Menu (see page 24)
Communication Menu (see page 26)
Window Menu (see page 27)

Use Shortcut Menu for Waveforms
View the shortcut menu by right-clicking inside an open waveform window.
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Use Shortcut Menu for Waveforms

Menu selection

Description

Open (see page 10)

Opens a waveform file (.wfm, .pat, .csv, .txt)

Save

Saves the currently selected waveform

Close

Closes the currently selected waveform

Cut (see page 118)

Cuts the portion of a waveform that is between cursors

Copy (see page 118)

Copies the portion of a waveform that is between cursors

Paste (see page 119)

Pastes the selected portion of a waveform at the cursor
which has a lower value

Select All (see page 120)

Selects and copies the entire waveform into the memory

Zoom (see page 114)

Opens a submenu with options to zoom in, zoom out, and
Fit to Window

Time Scale (see page 116)

Displays the waveform with time as the X-axis and voltage
along the Y-axis

Set Cursor Position (see page 113)

Positions the cursor exactly at the points or time specified

Freehand (see page 123)

Draws a waveform along the path you trace

Horizontal Draw (see page 124)

Allows drawing only horizontally

Vertical Draw (see page 124)

Allows drawing only vertically

Waveform Properties (see page 42)

The dialog box has three tabs: Active Waveform,
Multi-waveform, and Preferences.

Send Waveform to Arb (see page 148)

Sends the waveform to the connected instrument

xxx
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Use Shortcut Menu for Waveforms

In Point Draw mode, right-click inside an open waveform window to display the following shortcut menu:

Menu item

Description

Disable Point Draw

Disables point draw mode

Zoom

Has options that you can use to Zoom In, Zoom Out,
Horizontal Zoom In, and Fit to Window

Set Cursor Position...

Opens the Cursor Position dialog box that you can use to
set the cursor position in points or seconds

Time Scale

Changes the values on X axis into time domain

Select Previous Point

Highlights the previous point in the sequence

Select Next Point

Highlights the next point in the sequence

Edit Point Draw Table...

Opens the point draw table where you can edit the points
and set the interpolation method

Delete Selected Point

Deletes the selected point

Clear All Points

Clears the display of all the points but the continues to
display the waveform

Interpolation

Sets the interpolation method to use while generating the
waveform. You can choose form Smooth, Linear, and
Staircase.

Dynamic Compile

Compiles the waveform as you click the points using the
interpolation method you have chosen

Compile Draw Points

Compiles the waveform using the interpolation method you
have chosen only when you click Compile

xxx
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Standard Toolbar

Standard Toolbar
View> Standard Toolbar
The standard toolbar is displayed, by default, below the main menu. You can place the toolbar anywhere in
the application window.
The toolbar has icons for the standard functions — New blank waveform, Open existing waveform,
Save the waveform, Cut waveform between cursors, Copy waveform between cursors, Paste waveform,
Undo, Redo, and Help.

See Also:
Waveform Toolbar (see page 31)
Zoom Bar (see page 33)
Instrument Bar (see page 34)
Status Bar (see page 36)

Waveform Toolbar
View> Waveform Toolbar
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Waveform Toolbar

The waveform toolbar is displayed, by default, below the standard toolbar. You can place the toolbar
anywhere within the application window. The waveform toolbar has icons for the functions — Cursors,
Markers, Freehand Draw, Horizontal Draw, Vertical Draw, Equation Editor, Basic Waveform, Advanced
Waveform, and Validate.

See Also:
Standard Toolbar (see page 31)
Zoom Bar (see page 33)
Instrument Bar (see page 34)
Status Bar (see page 36)
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Zoom Bar

Zoom Bar
View> Zoom Bar
The zoom toolbar is displayed, by default, alongside the waveform toolbar. You can place the toolbar
anywhere within the application window. The zoom toolbar has icons for the functions — Zoom In, Zoom
Out, Zoom In Horizontally, and Fit to Window.

See Also:
Standard Toolbar (see page 31)
Waveform Toolbar (see page 31)
Instrument Bar (see page 34)
Status Bar (see page 36)
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Instrument Bar

Instrument Bar
View> Instrument Toolbar
The instrument toolbar is displayed, by default, below the main menu. You can place the toolbar anywhere
within the application window. The toolbar has icons for the standard functions — File Transfer and
Control, Scope Acquisition Wizard, Import from Scope, and Send Waveform to Arb.

See Also:
Standard Toolbar (see page 31)
Waveform Toolbar (see page 31)
Zoom Bar (see page 33)
Status Bar (see page 36)
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Point Draw Toolbar

Point Draw Toolbar
The point draw toolbar is displayed, by default, below the main menu. You can place the toolbar anywhere
within the application window.
The toolbar has icons for the functions — Enable Point Draw, Select Draw Point, Previous PD Point, Next
PD point, Delete Point, Edit PD Table, Interpolation Method, Dynamic Compile, and Compile.

See Also:
Standard Toolbar (see page 31)
Waveform Toolbar (see page 31)
Instrument Bar (see page 34)
Zoom Bar (see page 33)
Status Bar (see page 36)
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Status Bar

Status Bar
View> Status Bar
The application has two status bars: the Application status bar, and the Waveform status bar.
The Application status bar is displayed at the bottom of the application window. It shows the type of
instrument that is connected and its status. You can turn on or off the Application Status bar from
the View menu.

The Waveform status bar displays the sampling rate, points, signal voltage, editing mode, and cursor
difference. When you view a standard waveform, the voltage readout on the status bar displays the height
of the waveform where it crosses the active cursor or the vertical line of the pointer/crosshair. In draw
mode, the voltage readout is the actual vertical height of the draw pointer.

See Also:
Standard Toolbar (see page 31)
Waveform Toolbar (see page 31)
Zoom Bar (see page 33)
Instrument Bar (see page 34)

Shortcut View
The Shortcut View occupies the left part of the display. You can keep the shortcut view open by clicking
the pin at the top right corner of the panel. You can show or hide each selection in the shortcut panel by
pressing the double arrow at the top right corner of each panel.
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Shortcut View

Menu selection

Description

New Waveform (see page 38)

Allows you to create a new or blank waveform, standard
waveform, or a new equation

Easy Edit (see page 39)

Allows you to shift or rotate the waveform
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New Waveform View

Menu selection

Description

Import/Transfer Waveform (see page 41)

Allows you to acquire or import waveform from an
oscilloscope

Multi-Waveform Properties (see page 40)

It also allows you to open a existing waveform in either a
new window or an existing window

xxx

New Waveform View
View > Shortcut View
Use the New Waveform panel in the Shortcut View to create a standard waveform, a waveform using the
equation editor, or a blank waveform. You can view and modify the properties of one or more waveforms,
and set preferences. A single window displays a maximum of two waveforms.

Menu selection

Description

Standard Waveform...

Displays a Standard Function dialog box where you can
select the type of waveform to generate and set the
parameters

Equation Editor...

Displays the Equation Editor dialog box where you can
select an equation from the standard equations provided,
modify it, or create a new equation

Blank...

Displays a blank screen where you can draw or generate
a waveform

Properties...

The dialog box has three tabs: Multi-waveform, Waveform,
and Preferences

xxx

See Also:
Sine Wave (see page 79)
Square Wave (see page 82)
Triangle Wave (see page 85)
Pulse Wave (see page 88)
Noise Wave (see page 91)
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Easy Edit

DC Wave (see page 94)
Using the Equation Editor (see page 75)
Waveform Properties (see page 42)

Easy Edit
View > Shortcut View
Use the Easy Edit bar to shift or rotate the waveform by a defined number of points and amplitude. You
can shift the waveform or the portion of the waveform that is between cursors left, right, up, or down. You
can rotate the waveform left or right.

Type the number of points and amplitude by which to rotate or shift the waveform. If the option Rotate
Waveform is checked, the waveform is rotated. If the selection is cleared, the waveform is shifted.

ArbExpress AXW100 Printable Help

39

Operating Basics

Multi-Waveform Properties

Multi-Waveform Properties
View > Shortcut View
Use the Multi-Waveform Properties panel in the Shortcut View to select the window for opening a new
or existing waveform.
When you select the New Window option, the waveform is opened in a new window.
When you select the Existing Window option, the waveform is opened in an existing window. Select the
existing window using the Wave Book list box in the panel.

To display the waveform in an existing window, ensure that the new waveform has:
The same sampling rate as the existing waveform; if the sampling rate is different, then select Change
the Incoming waveform’s Sampling rate to change the sampling rate of the new waveform to match
that of the existing waveform. Or, select Change the Existing waveform’s Sampling rate to change
the sampling rate of the existing waveform to match that of the incoming waveform.
Equal number of points as the existing waveform.
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Import or Transfer Waveform

Import or Transfer Waveform
View > Shortcut View
Use the Import/Transfer Waveform panel in the Shortcut View to import a waveform from a file or acquire
it from an oscilloscope, File Transfer and Control, and Scope Acquisition Wizard.

Menu selection

Description

File Transfer and Control

Displays the File Transfer and Control dialog box, which
you can use to transfer files to an AWG/AFG and control
the instrument.

Import Waveform from Scope

Displays the Import Waveform from Scope dialog box, which
you can use to import a waveform from and oscilloscope

Scope Acquisition Wizard

Launches the Scope Acquisition Wizard, which you can use
to acquire data from a connected oscilloscope

xxx

See Also:
Import from Oscilloscope (see page 144)
File Transfer and Control (see page 135)
Scope Acquisition Wizard (see page 149)

Dialog Boxes
Most of the ArbExpress application dialog boxes have a corresponding help topic. To display descriptions
for the dialog boxes, display the dialog box and click Help.
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Waveform Properties Dialog Box

For help on specific dialog boxes, display the Table of Contents for this help file, and then navigate
to Operating Basics > Dialog Boxes.

Waveform Properties Dialog Box
Waveform > Properties
Use this dialog box to view and modify properties of multiple waveforms, a selected waveform, and
the application preferences. The dialog box has three tabs: Active Waveform, Multi-waveform, and
Preferences.

Active Waveform
Select the Waveform tab to view and modify the properties of the selected waveform. For multiple
waveform display, choose the waveform by selecting the Waveform1 or Waveform2 button located just
above the waveform display.
To save the waveform, click File > Save or File > Save As.
Option

Description

Instrument

Select the instrument from the list.

Sampling Rate

Displays the sampling rate of the selected waveform.

Resampling waveform using

Shows the number of points used for resampling.

Select resampling method

Select the algorithm to use when resampling and recreating
the waveform (Sinc, linear, or Add Points with zero
amplitude). Marker data is not resampled, but marker data
may be added or removed.

Normalize the waveform before saving the file

Normalizes the waveform before saving it. The waveform
amplitude is set between – 1 and +1 before the waveform
is saved.

xxx

Multi-waveform
Select the Multi-waveform tab to set up the window in which to display the waveforms.
When more than one waveform is displayed in a window or a wave book, you can select the waveform
to edit or work with by selecting the Waveform1 or Waveform2 button located just above the waveform
display. When you open or display a second waveform in the same window or wave book, the first
waveform is shown as a dotted line.
NOTE. A window or wave book can display a maximum of two waveforms. If you try to open or display
more than two waveforms in a single window or wave book, you are prompted with the message "Only two
waveforms can be opened or created in a Wave Book".
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Paste Option Dialog Box

NOTE. Only waveforms with the same number of samples can be displayed in a wave book.
Option

Description

New Window

Displays or opens the waveform in a new window

Existing Window

Displays or opens the waveform in an existing window

Wave book

Displays the list of wave books to choose to display the
waveform

Change the incoming waveform's clock

Changes the incoming or new waveform clock to match the
clock of the existing waveform

Change the existing waveform's clock

Changes the existing waveform clock to match the incoming
or new waveform clock

xxx

Preferences
Use the Preferences tab to set preferences for a waveform.
Option

Description

Save .set file along with .wfm and .pat files

The .set file contains the voltage and offset of the waveform.
Enable this before creating a waveform

Show paste option before pasting

Displays the Paste option dialog box before pasting the
contents

Always enables the instrument's outputs after transferring
the waveform

Switches on the destination channel to which the waveform
is transferred and sets the instrument in the Run mode

xxx

Paste Option Dialog Box
Edit > Paste
Use this dialog box to paste the copied portion of the waveform.
If you select Don't show this again and always paste at active cursor, the application does not display
the Paste Options dialog box and always pastes the contents at the active cursor.
Option

Description

Paste at active cursor

Pastes the contents at the active cursor. The active cursor
in indicated by a solid line.

Prepend to the waveform

Pastes the copied contents at the beginning of the waveform

Append to the waveform

Pastes the copied contents at the end of the waveform

Replace between cursors

Pastes the copied contents the between the cursors

Don't show this again and always paste at active cursor

If checked, always pastes the copied contents at the active
cursors and does not display the dialog box next time

xxx
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Shift/Rotate Dialog Box

Shift/Rotate Dialog Box
Edit > Shift/Rotate
Use this dialog box to set the number of points and amplitude by which to shift or rotate the waveform or
the portion of the waveform that is between cursors. The amplitude value is used only during waveform
shift and not during waveform rotation.
The direction of rotation is either left or right. The direction of shift is either up, down, left, or right.
Option

Description

Points

Sets the number of points by which to rotate the waveform

Amplitude

Sets the amplitude by which to shift the waveform

Vertical Segment
Shift Up

Shifts the waveform up by the specified amplitude

Shift Down

Shifts the waveform down by the specified amplitude

Horizontal Segment
Rotate Right

Rotates the waveform to the right by the specified number
of points

Rotate Left

Rotates the waveform to the left by the specified number
of points

Shift Right

Shifts the waveform to the right by the specified number
of points

Shift Left

Shifts the waveform to the left by the specified number of
points

xxx
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Point Draw Table Dialog Box

Point Draw Table Dialog Box
Edit > Point Draw > Edit Point Draw Table
Use this dialog box to enter waveform points in a blank table or edit a point draw table that has points in it
already. This table works similarly to a Microsoft Excel worksheet.
Option

Description

Insert Point

Inserts a row (point) above the selected row

Delete Point

Delete the selected row (point)

Clear All

Clears all the rows (points) in the table

Interpolation

Sets the interpolation method to Linear, Smooth, or
Staircase

X Value

Displays the X value in Positions (points) or in Time
(seconds)

xxx

The application checks the values you enter for the following:
X-value (sampling point) must always be unique. If you try to repeat this value, the message, “Values
of the sampling index should be unique” appears.
If you leave the amplitude (Y) blank, the applications fills it with a zero.
If you enter a Y value but no corresponding X value, an error appears.
Click OK. If the application finds no errors, the point draw table closes and the waveform in the Wave
Book window is updated to reflect the changes that you made in the point draw table.

Cursor Position Dialog Box
Display > Cursor Position
Use this dialog box to specify the cursor position in points or seconds.
Option

Description

Points/Seconds
Points

Select Points to set the cursor position in points.

Seconds

Select Seconds to set the cursor position in seconds.

Cursor Position
Cursor 1

Enter the position for Cursor 1 in the units selected in the
previous option.

Cursor 2

Enter the position for Cursor 2 in the units selected in the
previous option.

xxx
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Display Properties Dialog Box

Display Properties Dialog Box
Display > Properties
Use this dialog box to view the waveform display properties.
Option

Description

Waveform Name

Lists the waveforms available in the active window

Enable Graticule

Displays the graticule when checked

Background Color

Changes the background color of the waveform window

Waveform Properties
Color

Displays the waveform color and allows you to change the waveform color

Line Style

Displays the waveform line style and allows you to change the style

Line Width

Displays the waveform line width and allows you to change the line width

Marker Color
Marker1

Displays the color of Marker1 and allows you to change it

Marker2

Displays the color of Marker2 and allows you to change it

Cursor Color
Cursor1

Displays the color of Cursor1 and allows you to change it

Cursor2

Displays the color of Cursor2 and allows you to change it

Preview

Displays the preview of the waveform

xxx

When more than one waveform is displayed in one wave book or window, the inactive waveform has a
dashed line and the active waveform has a solid line.

See Also:
Marker (see page 112)
Cursor (see page 113)
Graticule (see page 116)

Equation Editor Dialog Box
File > Equation Editor, Waveform > Equation Editor
Use this dialog box to create a waveform using the Equation Editor.
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Equation Editor Dialog Box

Option

Description

Number of Points

Indicates the number of samples, typically in one cycle of
the waveform

Sampling Rate

Indicates the number of samples per second

Total Range

Indicates the duration of the waveform in seconds

Lock Total Range

Locks the Total Range value when checked. You can then
edit only the other two variables.

xxx

The Equation Editor window has a toolbar that has icons for opening a file and saving a file. Click Open
to open an equation file (.equ ) from the sample files. Use the other toolbar icons to perform operations
such as Close, Cut, Copy, and Paste.

You can create an equation using either of these two methods:
Editing an existing equation. Sample equations are provided in the \ArbExpress\Samples\Equation
folder.
1. From the Equation Editor window, click the Open icon.
2. Browse the equations (.equ or .eqa) listed in the folder \ArbExpress\Samples\Equation.
3. Edit the equation using the Edit menu or by placing the pointer over the equation.
Using the functions, operators, and constants
1. Create an equation in the edit area, using the functions and operators available under Function.
Always define a range first.
2. Under Settings, set the Total Range to the sum of all the ranges you have defined in the equation. To
do this, enter the Number of Points and Sampling Rate. After you set the total range, you can lock it
and change the number of points or sampling rate.
3. Click Compile. The compiled equation is displayed in Preview. The compilation status and messages
are displayed in Output.
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Sine Wave Dialog Box

If the equation compiles without any errors, the application displays the waveform in the specified window.
If compilation errors occur, the application displays a message in the output pane. The OK button is
enabled only if the compilation is successful.
The application supports the AWG2000 equation editor model. Equations created using the equation editor
cannot be used on the AWG400 through AWG700 series waveform generators. For more information, see
Equation Editor Reference (see page 201). Equations created using the equation editor cannot be used on
the AWG400 through AWG700 series waveform generators.
To transfer the waveform to an AWG or AFG, click Send to Arb (see page 148). This button is enabled
only when an instrument (AWG or AFG) is connected. You can select the channel to send the waveform to.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Equation Editor dialog box.

Sine Wave Dialog Box
File > Standard Waveform
Use this dialog box to create a sine waveform.
Description

Option
Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.

Vertical
Amp/Offset

Select Amp/Offset to set the amplitude and offset for the
selected waveform.

Amplitude

Enter the amplitude of the waveform in volts.

Offset

Enter the offset of the waveform in volts.

Max/Min

Select Max/Min to set the amplitude voltage range for the
selected waveform.

Maximum

Enter the maximum amplitude or the waveform in volts.

Minimum

Enter the minimum amplitude or the waveform in volts.

Full DAC Value

Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal

48

Show Advanced Mode

Select this to show the advanced options for the horizontal
parameters.

Frequency

Enter M for Megahertz, and G for Gigahertz.

Cycles

Enter the number of cycles in the waveform.

Phase

Enter the phase in degrees.
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Sine Wave Dialog Box

Advanced Options
Horizontal
Frequency

Displays the frequency as Samples per Second divided by
Number of Points per Cycle. You can set the frequency
by entering the number of Samples per Second and the
Number of Points per cycle.
You can lock the desired frequency and adjust either the
Samples per Second or the Points per Cycle to achieve
the frequency.

Samples/sec

You can lock the desired Samples per Second and adjust
either the Frequency or the Points per Cycle to achieve the
sampling rate.

Points/cycle

You can lock the desired Points per Cycle and adjust either
the Frequency or the Samples per Second to achieve the
number of points per cycles.

xxx

The Show Advanced Mode option is not available for the AFG2000, AFG3000, or MDO3000 series of
instruments. For the AFG2000 and AFG3000 series of instruments, type the Total Number of Points,
Frequency in Hertz, Phase in degrees, and Cycles. The Sampling Rate is a fixed value for the selected
instrument. The Sampling Rate depends on the total number of points. For the AFG3101, AFG3102,
AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C instruments, if the total
number of points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to 250 MHz. For
the AFG3251, AFG3251C, AFG3252, and AFG3252C instruments, if the total number of points exceeds
16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. For the MDO3000 series of
instruments, the sampling rate is limited to 250 MHz.
To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
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Square Wave Dialog Box

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

Square Wave Dialog Box
File > Standard Waveform
Use this dialog box to create a square waveform.
Description

Option
Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.

Vertical
Amp/Offset
Amplitude
Offset
Max/Min

Select Amp/Offset to set the amplitude and offset for the
selected waveform.
Enter the amplitude of the waveform in volts.
Enter the offset of the waveform in volts.
Select Max/Min to set the amplitude voltage range for the
selected waveform.

Maximum

Enter the maximum amplitude or the waveform in volts.

Minimum

Enter the minimum amplitude or the waveform in volts.

Full DAC Value

Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal
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Show Advanced Mode

Select this to show the advanced options for the horizontal
parameters.

Frequency

Enter M for Megahertz, and G for Gigahertz.

Cycles

Enter the number of cycles in the waveform.

Phase

Enter the phase in degrees.

Duty Cycle

Enter the Duty Cycle as a percentage of the waveform width.
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Square Wave Dialog Box

Advanced Options
Horizontal
Frequency

Displays the frequency as Samples per Second divided by
Number of Points per Cycle. You can set the frequency
by entering the number of Samples per Second and the
Number of Points per cycle.
You can lock the desired frequency and adjust either the
Samples per Second or the Points per Cycle to achieve
the frequency.

Samples/sec

You can lock the desired Samples per Second and adjust
either the Frequency or the Points per Cycle to achieve
the sampling rate.

Points/cycle

You can lock the desired Points per Cycle and adjust either
the Frequency or the Samples per Second to achieve the
number of points per cycles.

Transitions
Rise Time

Enter the Rise time in number of points or in seconds.

Ramp

Select Ramp.

Sine2

Select Sine2.

Fall Time

Enter the Fall time in points or seconds.

Ramp

Select Ramp.

Sine2

Select Sine2 .

xxx

The Show Advanced Mode option is not available for the AFG2000, AFG3000, or MDO3000 series of
instruments. For the AFG2000 and AFG3000 series of instruments, type the Total Number of Points,
Frequency in Hertz, Phase in degrees, Cycles, and Duty Cycle. The Sampling Rate is a fixed value for
the selected instrument. The Sampling Rate depends on the total number of points. For the AFG3101,
AFG3102, AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C instruments,
if the total number of points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to
250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total number
of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. Under
Transitions (10%-90%), set the Rise Time and Fall Time parameters. For the MDO3000 series of
instruments, the sampling rate is limited to 250 MHz.
To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
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Triangle Wave Dialog Box

If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

Triangle Wave Dialog Box
File > Standard Waveform
Use this dialog box to create a triangle waveform.
Description

Option
Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.

Vertical
Amp/Offset

Select Amp/Offset to set the amplitude and offset for the
selected waveform.

Amplitude

Enter the amplitude of the waveform in volts.

Offset

Enter the offset of the waveform in volts.

Max/Min

Select Max/Min to set the amplitude voltage range for the
selected waveform.

Maximum

Enter the maximum amplitude or the waveform in volts.

Minimum

Enter the minimum amplitude or the waveform in volts.

Full DAC Value

Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal
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Show Advanced Mode

Select this to show the advanced options for the horizontal
parameters.

Frequency

Enter M for Megahertz, and G for Gigahertz .

Cycles

Enter the number of cycles in the waveform.

Phase

Enter the phase in degrees.
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Triangle Wave Dialog Box

Advanced Options
Horizontal
Frequency

Displays the frequency as Samples per Second by Number
of Points per Cycle. You can set the frequency by entering
the number of Samples per Second and the Number of
Points per cycle.
You can lock the desired frequency and adjust either the
Samples per Second or the Points per Cycle to achieve
the frequency.

Samples/sec

You can lock the desired Samples per Second and adjust
either the Frequency or the Points per Cycle to achieve the
sampling rate.

Points/cycle

You can lock the desired Points per Cycle and adjust either
the Frequency or the Samples per Second to achieve the
number of points per cycle.

xxx

The Show Advanced Mode option is not available for the AFG2000, AFG3000, or MDO3000 series of
instruments. For the AFG2000 and AFG3000 series of instruments, type the Total Number of Points,
Frequency in Hertz, Phase in degrees, and Cycles. The Sampling Rate is a fixed value for the selected
instrument. The Sampling Rate depends on the total number of points. For the AFG3101, AFG3102,
AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C instruments, if the total
number of points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to 250 MHz. For
the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total number of points exceeds
16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. For the MDO3000 series of
instruments, the sampling rate is limited to 250 MHz.
To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG, AFG, or MDO3000
with MDO3AFG option enabled) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
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Pulse Wave Dialog Box

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

Pulse Wave Dialog Box
File > Standard Waveform
Use this dialog box to create a pulse waveform.
Description

Option
Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.

Vertical
Amp/Offset
Amplitude
Offset
Max/Min

Select Amp/Offset to set the amplitude and offset for the
selected waveform.
Enter the amplitude of the waveform in volts.
Enter the offset of the waveform in volts.
Select Max/Min to set the amplitude voltage range for the
selected waveform

Maximum

Enter the maximum amplitude or the waveform in volts.

Minimum

Enter the minimum amplitude or the waveform in volts.

Full DAC Value

Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal
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Show Advanced Mode

Select this to show the advanced options for the horizontal
parameters.

Frequency

Enter M for Megahertz, and G for Gigahertz.

Cycles

Enter the number of cycles in the waveform.

Delay

Enter the delay in seconds.

Pulse Width (50%)

Enter the pulse width in seconds, typically 50% of the entire
waveform width.
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Pulse Wave Dialog Box

Advanced Options
Horizontal
Frequency

Displays the frequency as Samples per Second divided by
Number of Points per Cycle. You can set the frequency
by entering the number of Samples per Second and the
Number of Points per cycle.
You can lock the desired frequency and adjust either the
Samples per Second or the Points per Cycle to achieve
the frequency.

Samples/sec

You can lock the desired Samples per Second and adjust
either the Frequency or the Points per Cycle to achieve the
sampling rate.

Points/cycle

You can lock the desired Points per Cycle and adjust either
the Frequency or the Samples per Second to achieve the
number of points per cycle.

Transitions
Pulse Direction
Positive
Negative
Rise Time

Select the pulse direction.
Select positive pulse direction.
Select negative pulse direction.
Enter the Rise time in number of points or in seconds.

Ramp

Select Ramp.

Sine2

Select Sine2 .

Fall Time

Enter the Fall time in points or in seconds.

Ramp

Select Ramp.

Sine2

Select Sine2 .

xxx

The Show Advanced Mode option is not available for the AFG2000, AFG3000, or MDO3000 series of
instruments. For the AFG2000 and AFG3000 series of instruments, type the Total Number of Points,
Frequency in Hertz, Delay, Cycles, and Pulse Width. The Sampling Rate is a fixed value for the selected
instrument. The Sampling Rate depends on the total number of points. For the AFG3101, AFG3102,
AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C instruments, if the total
number of points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to 250 MHz. For
the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total number of points exceeds
16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. Under Transitions (10%-90%),
set the Pulse Direction, Rise Time, and Fall Time parameters. For the MDO3000 series of instruments, the
sampling rate is limited to 250 MHz.
To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
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Noise Wave Dialog Box

NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

Noise Wave Dialog Box
File > Standard Waveform
Use this dialog box to create a noise waveform. The waveform has no advanced options.
Description

Option
Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.

Vertical
Amp/Offset

Select Amp/Offset to set the amplitude and offset for the
selected waveform.

Amplitude

Enter the amplitude of the waveform in volts.

Offset

Enter the offset of the waveform in volts.

Max/Min

Select Max/Min to set the amplitude voltage range for the
selected waveform.

Maximum

Enter the maximum amplitude or the waveform in volts.

Minimum

Enter the minimum amplitude or the waveform in volts.

Full DAC Value

Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal
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Gaussian White Noise

Select this to create a Gaussian White Noise waveform.

Pink Noise

Select this to create a Pink Noise waveform.
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Option

Noise Wave Dialog Box
Description

Sampling Rate

Enter the sampling rate for the waveform.

Total Number of Points

Enter the total number of points.

xxx

For the AFG2000, AFG3000, or MDO3000 series of instruments, type the Total Number of Points. The
Sampling Rate is a fixed value for the selected instrument. The Sampling Rate depends on the total number
of points. For the AFG3101, AFG3102, AFG3101C, AFG3102C, AFG3051C, AFG3052C, AFG3151C,
and AFG3152C instruments, if the total number of points exceeds 16,384 (16 K points), the sampling rate
changes from 1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments,
if the total number of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to
250 MHz. For the MDO3000 series of instruments, the sampling rate is limited to 250 MHz.
To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.
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DC Wave Dialog Box

DC Wave Dialog Box
File > Standard Waveform
Use this dialog box to create a DC waveform. The waveform has no advanced options.
Description

Option
Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.

Vertical
Amp/Offset
Offset
Full DAC Value

Select Amp/Offset to set the amplitude and offset for the
selected waveform.
Enter the offset of the waveform in volts.
Select Full DAC Value to set the waveform values between
–1 and + 1.

Horizontal
Sampling Rate

Enter the sampling rate for the waveform.

Total Number of Points

Enter the total number of points in the waveform.

xxx

For the AFG2000, AFG3000, or MDO3000 series of instruments, type the Total Number of Points. The
Sampling Rate is a fixed value for the selected instrument. The Sampling Rate depends on the total number
of points. For the AFG3101, AFG3102, AFG3101C, AFG3102C, AFG3051C, AFG3052C, AFG3151C,
and AFG3152C instruments, if the total number of points exceeds 16,384 (16 K points), the sampling rate
changes from 1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments,
if the total number of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to
250 MHz. For the MDO3000 series of instruments, the sampling rate is limited to 250 MHz.
To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
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Exponential Rise Wave Dialog Box

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

Exponential Rise Wave Dialog Box
File > Standard Waveform
Use this dialog box to create an exponential rise waveform. The waveform has no advanced options.
Description

Option
Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.

Vertical
Amp/Offset

Select Amp/Offset to set the amplitude and offset for the
selected waveform.

Amplitude

Enter the amplitude of the waveform in volts.

Offset

Enter the offset of the waveform in volts.

Max/Min

Select Max/Min to set the amplitude voltage range for the
selected waveform.

Maximum

Enter the maximum amplitude or the waveform in volts.

Minimum

Enter the minimum amplitude or the waveform in volts.

Full DAC Value

Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal
Sampling Rate

Enter the sampling rate for the waveform.

Cycles

Enter the number of cycles in the waveform.

Phase

Enter the phase in degrees.

Total Number of Points

Enter the total number of points in the waveform.

Damp Factor

Enter the damp factor.

xxx

For the AFG2000, AFG3000, or MDO3000 series of instruments, type the Phase in degrees, Cycles, Total
Number of Points, and Damp Factor. The Sampling Rate is a fixed value for the selected instrument.
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Exponential Decay Wave Dialog Box

The Sampling Rate depends on the total number of points. For the AFG3101, AFG3102, AFG3101C,
AFG3102C, AFG3051C, AFG3052C, AFG3151C, and AFG3152C instruments, if the total number
of points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to 250 MHz. For the
AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total number of points exceeds
16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. For the MDO3000 series of
instruments, the sampling rate is limited to 250 MHz.
To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

Exponential Decay Wave Dialog Box
File > Standard Waveform
Use this dialog box to create an exponential decay waveform. The waveform has no advanced options.
Option

Description

Settings
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Function

Select a standard function from the list.

Instrument

Select an instrument from the list.
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Exponential Decay Wave Dialog Box
Description

Option
Vertical
Amp/Offset

Select Amp/Offset to set the amplitude and offset for the
selected waveform.

Amplitude

Enter the amplitude of the waveform in volts.

Offset

Enter the offset of the waveform in volts.

Max/Min

Select Max/Min to set the amplitude voltage range for the
selected waveform.

Maximum

Enter the maximum amplitude or the waveform in volts.

Minimum

Enter the minimum amplitude or the waveform in volts.

Full DAC Value

Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal
Sampling Rate

Enter the sampling rate for the waveform.

Cycles

Enter the number of cycles in the waveform.

Phase

Enter the phase in degrees.

Total Number of Points

Enter the total number of points in the waveform.

Damp Factor

Enter the damp factor.

xxx

For the AFG2000, AFG3000, or MDO3000 series of instruments, type the Phase in degrees, Cycles, Total
Number of Points, and Damp Factor. The Sampling Rate is a fixed value for the selected instrument.
The Sampling Rate depends on the total number of points. For the AFG3101, AFG3102, AFG3101C,
AFG3102C, AFG3051C, and AFG3052C instruments, if the total number of points exceeds 16,384 (16 K
points), the sampling rate changes from 1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C,
and AFG3252C instruments, if the total number of points exceeds 16,384 (16 K points), the sampling
rate changes from 2 GHz to 250 MHz. For the MDO3000 series of instruments, the sampling rate
is limited to 250 MHz.
To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
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Sweep Wave Dialog Box

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

Sweep Wave Dialog Box
File > Standard Waveform
Use this dialog box to create a Sweep waveform. The waveform has no advanced options.
Description

Option
Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.

Vertical
Amp/Offset

Select Amp/Offset to set the amplitude and offset for the
selected waveform.

Amplitude

Enter the amplitude of the waveform in volts.

Offset

Enter the offset of the waveform in volts.

Max/Min

Select Max/Min to set the amplitude voltage range for the
selected waveform.

Maximum

Enter the maximum amplitude or the waveform in volts.

Minimum

Enter the minimum amplitude or the waveform in volts.

Full DAC Value

Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal
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Start Frequency

Enter the frequency that you want at the beginning of the
waveform.

End Frequency

Enter the frequency that you want at the end of the
waveform.

Time Duration*

Enter the time between the start and end of the waveform.
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Sweep Wave Dialog Box
Description

Sampling Rate

Enter the sampling rate for the waveform.

Total Number of Points**

Enter the total number of points that make up the waveform.

xxx

1

* For the AFG2000 and AFG3000 series of instruments, type the Start Frequency, End Frequency, and Total Number of Points. The Sampling
Rate is a fixed value for the selected instrument. The Sampling Rate depends on the total number of points. The Time Duration is calculated
according to the following equation:

For the AFG3101, AFG3102, AFG3101C, AFG3102C, AFG3051C, AFG3052C, AFG3151C, AFG3152C,
and MDO3000 series instruments, if the total number of points exceeds 16,384 (16 K points), the
sampling rate changes from 1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C, and
AFG3252C instruments, if the total number of points exceeds 16,384 (16 K points), the sampling rate
changes from 2 GHz to 250 MHz. For the MDO3000 series of instruments, the sampling rate is limited to
250 MHz.
2

** The field Total Number of Points is disabled for the AWG7xx, AWG6xx, AWG5xx, AWG4xx, AWG2xxx, and AFG3xx series of instruments. The
application calculates the Total Number of Points as the product of Time Duration and Sampling Rate.

To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
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Sinc Wave Dialog Box

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

Sinc Wave Dialog Box
File > Standard Waveform
Use this dialog box to create a Sinc waveform. The waveform has no advanced options.
Description

Option
Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.

Vertical
Amp/Offset

Select Amp/Offset to set the amplitude and offset for the
selected waveform.

Amplitude

Enter the amplitude of the waveform in volts.

Offset

Enter the offset of the waveform in volts.

Max/Min

Select Max/Min to set the amplitude voltage range for the
selected waveform.

Maximum

Enter the maximum amplitude or the waveform in volts.

Minimum

Enter the minimum amplitude or the waveform in volts.

Full DAC Value

Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal
Sampling Rate

Enter the sampling rate for the waveform.

Phase

Enter the phase in degrees.

Cycles

Enter the number of cycles in the waveform.

Total Number of Points

Enter the total number of points in the waveform.

Number of Zero Crossings

Enter the number of zero crossings for the waveform.

xxx

For the AFG2000, AFG3000, or MDO3000 series of instruments, type the Phase in degrees, Cycles, Total
Number of Points, and Number of Zero Crossings. The Sampling Rate is a fixed value for the selected
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Multi-Tone Wave Dialog Box

instrument. The Sampling Rate depends on the total number of points. For the AFG3101, AFG3102,
AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C instruments, if the total
number of points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to 250 MHz. For
the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total number of points exceeds
16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. For the MDO3000 series of
instruments, the sampling rate is limited to 250 MHz.
To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

Multi-Tone Wave Dialog Box
File > Standard Waveform
Use this dialog box to create a Multi-Tone waveform. The waveform has no advanced options.
Option

Description

Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.
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Description

Option
Vertical
Amp/Offset

Select Amp/Offset to set the amplitude and offset for the
selected waveform.

Amplitude

Enter the amplitude of the waveform in volts.

Offset

Enter the offset of the waveform in volts.

Max/Min

Select Max/Min to set the amplitude voltage range for the
selected waveform.

Maximum

Enter the maximum amplitude or the waveform in volts.

Minimum

Enter the minimum amplitude or the waveform in volts.

Full DAC Value

Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal
Start Frequency

Enter the frequency that you want at the beginning of the
waveform.

End Frequency

Enter the frequency that you want at the end of the
waveform.

Tone Spacing*

Enter the frequency interval between the frequencies that
make up waveform.

Sampling Rate

Enter the sampling rate for the waveform.

Total Number of Points**

Enter the total number of points.

xxx

1

* For the AFG2000 and AFG3000 series of instruments, type the Start Frequency, End Frequency, and Total Number of Points. The Sampling Rate
is a fixed value for the selected instrument. The Sampling Rate depends on the total number of points.

The Tone Spacing is calculated according to the following equation:

For the AFG3101, AFG3102, AFG3101C, AFG3102C, AFG3051C, AFG3052C, and MDO3000 series
instruments, if the total number of points exceeds 16,384 (16 K points), the sampling rate changes from
1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total
number of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. For
the MDO3000 series of instruments, the sampling rate is limited to 250 MHz.
2

**The field Total Number of Points is disabled for the AWG7xx, AWG6xx, AWG5xx, AWG4xx, AWG2xxx, and AFG3xx series of instruments. The
Total Number of Points is calculated according to the following equation:

To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
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To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

Lorentz Wave Dialog Box
File > Standard Waveform
Use this dialog box to create a Lorentz waveform. The waveform has no advanced options.
Description

Option
Settings
Function

Select a standard function from the list.

Instrument

Select an instrument from the list.

Vertical
Amp/Offset

Select Amp/Offset to set the amplitude and offset for the
selected waveform.

Amplitude

Enter the amplitude of the waveform in volts.

Offset

Enter the offset of the waveform in volts.

Max/Min
Maximum
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Select Max/Min to set the amplitude voltage range for the
selected waveform.
Enter the maximum amplitude or the waveform in volts.
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Lorentz Wave Dialog Box
Description

Option
Minimum
Full DAC Value

Enter the minimum amplitude or the waveform in volts.
Select Full DAC Value to set the waveform values between
– 1 and + 1.

Horizontal
Sampling Rate

Enter the number of samples per second.

Phase

Enter the phase in degrees.

Cycles

Enter the number of cycles in the waveform.

Total Number of Points*

Enter the total number of points in the waveform.

Time Delay**

Enter the delay in seconds.

Half Width

Enter the half width.

xxx

1

* The field Total Number of Points is disabled for the AWG7xx, AWG6xx, AWG5xx, AWG4xx, AWG2xxx, and AFG3xx series of instruments. Type
the Sampling Rate of the waveform, the number of Cycles, and the Phase in degrees. Enter the Time Delay and Half Width. The Total number of
points is given by: The Total number of points is given by:

2

** For the AFG2000 and AFG3000 series of instruments, type the Phase in degrees, Cycles, Half Width, and Total Number of Points. The
Sampling Rate is a fixed value for the selected instrument. The Sampling Rate depends on the total number of points for the AFG3101, AFG3102,
AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C instruments, if the total number of points exceeds 16,384 (16 K
points), the sampling rate changes from 1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total
number of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz.

For AFG3xx, AFG2000, and AFG3000 series of instruments Time Delay is calculated according to
the following equation:

To preview the waveform, click Preview.
To restore the default values for the waveform, click Default.
To save your current values and create the waveform, click OK.
To send the waveform directly to an arbitrary waveform or function generator that is connected, click Send
to Arb (see page 148). Send to Arb is enabled only when an instrument (AWG or AFG) is connected.
To view or vary the waveform properties, click Multi-Waveform Properties (see page 42). The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear when you click Preview:
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Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Select one of the options and click OK.

File Transfer and Instrument Control Dialog Box
Communication > AWG/AFG File Transfer and Control
Use this dialog box to control the instrument from the application.
Option

Description

Arb List

Lists the instruments that can be connected

Instrument Folders

Lists the folders on the instruments hard disk drive

Instrument Files

Lists the files in the folder selected on the instrument hard
disk

PC Folders

Lists the folders on the PC hard disk

PC Files

Lists the files in the folder selected on the PC hard disk

Instrument Control
Channel Selector

Selects the channel that you want to control

Output ON

Turns the output on or off

Load File to AWG

Enter or select the file to load. You can drag and drop the file
from the Instrument file list and the file name automatically
appears here.

Vertical

Control the vertical parameters.

Filter

Use this to filter frequencies greater than the value specified.

Amplitude

Enter the voltage for the waveform.

Offset

Enter or select the offset for the waveform.

Marker1
High

Set the High value for Marker1.

Low

Set the Low value for Marker1.

Marker2
High

Set the High value for Marker2.

Low

Set the Low value for Marker2.
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Instrument Control
Clock

Enter the clock frequency.

Run/Stop

Changes the instrument from the Run to Stop mode or vice
versa.

Apply

Applies the changes to the waveform.

xxx

For the AFG3xx series, you can transfer the waveform files in the following directions — PC to Edit
memory, PC to User memory, and Edit memory to User memory.
For the AFG2000 and AFG3000 series, you can transfer the waveform in the following directions — PC to
Edit memory, PC to User memory, Edit memory to User memory, and Edit memory to PC.
For the MDO3000 series, you can transfer the waveform in the following directions — PC to Edit memory
and Edit memory to PC.
When you transfer a waveform from the Edit memory to the PC, the file has the name EMEM<n> in the
destination folder. When you transfer a waveform from the PC to the Edit memory, the EMEM<n>
waveform text box shows the waveform file name. When you drag the EMEM<n> file to User<n>, the
User<n> text box shows the file name as EMEM<n>.
When you drag a file from the PC Files list and drop it to the destination Edit or User memory, the
destination text "Drag source file and drop here" is replaced with the name of the transferred file. When
you close the dialog box or reinvoke it, the destination text reappears.
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Waveform Math Dialog Box
Math > Waveform Math
Use this dialog box to perform mathematical operation on the selected portion of the waveform. To operate
with the selected waveform, you can either use a standard waveform, a scalar value, or a waveform
that you have copied to the clipboard.
The mathematical operations that are available are Add, Subtract, Multiply, and Divide. Division is
applicable only when you use a scalar value or copy from the clipboard.
Option

Description

Waveform Library
Select the waveform

This appears in the Math Source preview.

Amplitude Pk-Pk

Type the amplitude in volts of the selected waveform

Cycles

Type the number of cycles of the selected waveform.

Phase

Type the phase in degrees of the selected waveform.

Duty Cycle/Pulse Width/Damp Factor

Type the duty cycle, pulse width, or the Damp Factor for
the selected waveform.

Scalar Value
Amplitude
Copy from clipboard

Type the amplitude in volts.
Uses the waveform copied to the memory to perform math
operations.

Operation
Add

Adds every point of the selected waveform to every point on
the math source waveform.

Subtract

Subtracts every point of the selected waveform from every
point on the math source waveform.

Multiply

Multiplies every point on the selected waveform with every
point of the math source waveform.

Divide

Divides every point on the selected waveform with every
point of the math source waveform This operation is not
available when you select a standard waveform from the list
to operate with.

Only between cursors

Select this to perform the operation only on that section of
the waveform between the cursors.

xxx

The resultant waveform is displayed in the Resultant Waveform preview.
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Filter Setup Dialog Box
Communication > AWG/AFG File Transfer and Control >
Use this dialog box to set the filters for displaying waveform files.
1. Select one or more file type to show: . wfm, .tfw, .isf, .pat, . csv, . txt, *.*. The default filter type is *.*.
2. Click Default to restore the default file type.
3. Click Enable to enable the Filter On/Off button. If the filter is set to On, clicking Enable changes
nothing.

Set IP Address Dialog Box
Communication > AWG File Transfer and Control > Set IP Address (from the shortcut menu)
Use this dialog box to set the IP Address of the instrument you want to connect to. The application
displays the last ten recently connected instruments and their IP addresses. If you select any of these, the
corresponding IP address appears in the IP address field.

Instrument Properties Dialog Box
Communication > File Transfer >
Use this dialog box to view the instrument properties.
Option

Description

Instrument Model

Displays the model of the selected instrument

Connection Status

Displays the status of the instrument — connected or not
connected

Interface String

Displays the resource string or IP address of the connected
instrument

Bus Type

Displays the bus type: Serial, GPIB, or Ethernet

xxx
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Import from Oscilloscope Dialog Box
Use the Import from Scope dialog box to connect to a Tektronix Oscilloscope and import a waveform
into ArbExpress in the AWG7xx waveform file format. Currently ArbExpress supports the TDS1000,
TDS2000, TDS3000, TDS5000, TDS6000, TDS7000, TBS1000, DPO2000, DPO3000, DPO4000,
MSO2000, MSO3000, MSO4000, MDO3000, and MDO4000 families of oscilloscopes. The following
steps describe how to use this dialog box.
Before you show the Import from Scopedialog box, refresh the TekVisa resource list.

Before Connecting
Ensure that the oscilloscope you intend to connect to is detected by the TekVisa Resource manager tool.
Without this, ArbExpress will not show it in its Scope list. Refer to the help on VisaRM for information on
how to search for an oscilloscope using the TekVisa Resource Manager tool.

Connecting to an Oscilloscope
The Scope list shows the oscilloscopes to which you can connect. You can choose any one of them and
connect to it. Once successfully connected, the Scope list shows the available data sources — Channels,
Reference waveforms, and Math waveforms in the oscilloscope.

Importing a Waveform
To import a waveform, you must first select a data source (a channel, ref or math). When you select one of
the available data sources, its status is displayed in the bottom half of the dialog box. After selecting the
data source, you can either drag and drop the source into one of the folders on the hard disk, or select the
Acquire option from the shortcut menu for the selected data source and paste it in a folder on the PC.
When the transfer is complete, a waveform file with the name of the form <model number>_<channel
number>.wfm is created in the selected folder.
NOTE. If you have a Ref waveform of a particular record length, you can successfully import the waveform
only if the oscilloscope current record length is the same as the Ref waveform record length.

Changing Parameters of a Channel
Right-click a channel to change the parameters. You can change the following parameters:
Run Mode (single sequence or continuous mode)
Record length (except for TDS1000, TDS2000, and TBS1000 family of oscilloscopes)
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Acquisition mode (supports Sample, Peak Detect and Average modes on all families of oscilloscopes.
In addition to these three, supports Hi Res, and Peak to Peak modes for TDS5000, TDS6000 and
TDS7000 series of oscilloscope)
Acquire

Directly Transferring a Waveform from the Oscilloscope to a Waveform View
You can acquire a waveform from the oscilloscope and open it in a Waveform view in a single action. To
do this, you have to select a data source as described above. Then click the "Open in New Window" button
on the oscilloscope toolbar. The file is transferred and saved to the current directory and then opened in a
Waveform View. You can close the Import from Scope dialog box to work with the acquired waveform.
NOTE. Closing the dialog box does not close the connection.

Set Pattern Dialog Box
Display > Marker
Use this dialog box to create a marker pattern. Right-click within the marker display area, and select
Set Pattern from the shortcut menu.
Option

Description

Target
Marker1

Select Marker1 as the target to set the pattern for Marker1.

Marker2

Select Marker2 as the target to set the pattern for Marker2.

Data
Hex

Select Hexadecimal as the data type to set the pattern in
hexadecimal.

Binary

Select Binary as the data type to set the pattern in binary.

Pattern

Use characters 0 – 9 and A– F to create a hexadecimal
pattern, and 0 and 1 to create a binary pattern.

xxx
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Using the Equation Editor
File > Equation Editor
Waveform > Equation Editor
You can create waveforms using the equation editor. The application provides a set of sample equations
that you can use directly or modify and use.

Use the Equation pane to edit the equations, use the Command list to select the commands, functions,
units and operations, use the Settings pane to set the Total Range, and use the Preview pane to preview the
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waveform after the equation is compiled. The OK button is enabled only when the equation compiles
successfully.

Equation Editor Tool Bar

The equation editor toolbar has icons for standard functions — Open, Save, Close, Cut, Copy, Paste,
and Instrument list.

Creating an Equation
To use a sample equation:
1. Select Waveform > Equation Editor.
2. From the Equation Editor window, select File > Open.
3. Browse the equations (.equ or .eqa) listed in the folder \ArbExpress\Samples\Equation.
4. Edit the equation using the Command list options or by placing the pointer over the equation and
typing in the equation.
NOTE. Ensure that the total range you specify in the equation and the total range defined in the Settings
match.
To create a new equation:
1. Select Waveform > Equation Editor. The equation editor screen is displayed with a sample equation.
2. Create an equation in the Equation pane, using the functions and operators available in the Command
list. Always define a range first.
3. Under Settings, set the Total Range to the sum of all the ranges you have defined in the equation. To
do this, enter the Number of Points and Sampling Rate. After you set the Total Range, you can lock it
and change the Number of Points or the Sampling Rate.
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For the AFG2000, AFG3000, or MDO3000 series of instruments, the sampling rate is replaced with
the Equivalent Sampling Rate. If you lock the Total Range, the Equivalent Sampling Rate is the
calculated depending upon the Number of Points. The application displays the sampling rate of
the current instrument.
If the total range defined in the equation is greater than the total range in Settings, the equation fails to
compile. The output pane displays a message and the error.

If the number of points specified in the Settings is more than the range specified in the equation, then
the available extra points have a value of zero.
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4. Click Compile. The compiled equation is displayed in Preview. The compilation status and messages
are displayed in Output. If the compilation is successful, you can click OK.
Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG or AFG) is connected. You can select the channel to send the
waveform to. A progress bar displays the status of the operation. In the AFG3xx, AFG2000, AFG3000,
and MDO3000 series, the waveform is sent to the edit memory. A message "Are you sure you want to
overwrite EMEM<n> with this file?" warns you that the instrument edit memory will be overwritten.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The Waveform
Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Equation Editor dialog box.
The application supports the AWG2000 equation editor model and follows the same syntax. See Equation
Editor Reference (see page 201) for more details. Equations created using the equation editor cannot be
used on the AWG400 through AWG700 series waveform generators.

78

ArbExpress AXW100 Printable Help

How to ...

Sine Wave

See Also:
Send Waveform to Arb (see page 148)
Transfer Files to an AWG/AFG (see page 137)

Sine Wave
File > Standard Waveform

To create a sine wave:
1. Under Settings, set the Function to Sine, and set the Instrument to the target instrument.
2. Under Vertical, choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies the
amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which the
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
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3. Under Horizontal, type the Frequency of the waveform in Hertz, the number of Cycles, and the Phase
in degrees. Select Show Advanced Mode to show advanced parameter options for the sine wave.

The Show Advanced Mode option is not available for the AFG2000, AFG3000, or MDO3000
series of instruments. For the AFG2000 and AFG3000 series of instruments, type the Total Number
of Points, Frequency in Hertz, Phase in degrees, and Cycles. The Sampling Rate is a fixed value
for the selected instrument. The Sampling Rate depends on the total number of points. For the
AFG3101, AFG3102, AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C
instruments, if the total number of points exceeds 16,384 (16 K points), the sampling rate changes
from 1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if
the total number of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to
250 MHz. For the MDO3000 series of instruments, the sampling rate is limited to 250 MHz.
4. If you have selected Show Advanced Mode, set the Frequency as the number of samples per second
divided by the number of points per cycle. You can lock any one of the parameters – Frequency,
Samples/sec, or Points/cycle – and vary the other two.
5. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:
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Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG, AFG, or MDO3000 series) is connected. You can select
the channel to send the waveform to.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The
Waveform Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
6. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in
the Shortcut view.

See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)
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Square Wave
File > Standard Waveform

To create a square wave:
1. Under Settings, set the Function to Square, and set the Instrument to the target instrument.
2. Under Vertical, you can choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies the
amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which the
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
3. Under Horizontal, type the Frequency of the waveform in hertz, the number of Cycles, and the Phase
in degrees. Set the Duty Cycle to a percentage. Select Show Advanced Mode to show advanced
parameter options for the square wave.
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The Show Advanced Mode option is not available for the AFG2000, AFG3000, or MDO3000 series
of instruments. For these instruments, type the Total Number of Points, Frequency in Hertz, Phase
in degrees, Cycles, and Duty Cycle. The Sampling Rate is a fixed value for the selected instrument.
The Sampling Rate depends on the total number of points. For the AFG3101, AFG3102, AFG3101C,
AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C instruments, if the total number
of points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to 250 MHz. For
the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total number of points
exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. Under Transitions
(10%-90%), set the Rise Time and Fall Time parameters. For the MDO3000 series of instruments, the
sampling rate is limited to 250 MHz.

4. If you have selected Show Advanced Mode, set the Frequency as the number of samples per second
divided by the number of points per cycle. You can lock any one of the parameters – Frequency,
Samples/sec, or Points/cycle– and vary the other two. Another pane titled Transitions (10%-90%)
appears.
Set the number of points for Rise Time and select rise type to Ramp or Sine2.
Set the number of points for Fall Time and the fall type to Ramp or Sine2. The equivalent value is
displayed in seconds.

5. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:
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Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG or AFG) is connected. You can select the channel to send
the waveform to.
Click the Multi-Waveform Properties (see page 42) button to view or vary the waveform properties.
The Waveform Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
6. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in the
Shortcut view.

See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)
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Triangle Wave
File > Standard Waveform

To create a triangular wave:
1. Under Settings, set the Function to Triangle, and set the Instrument to the target instrument.
2. Under Vertical, choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies the
amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which the
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
3. Under Horizontal, type the Frequency of the waveform in Hertz, the number of Cycles, and the
Phase in degrees. Select Show Advanced Mode to show advanced parameter options for the triangle
wave. You can lock any one of the parameters – Frequency, Samples/sec, or Points/cycle – and
vary the other two.
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The Show Advanced Mode option is not available for the AFG2000, AFG3000, or MDO3000
series of instruments. For the AFG2000 and AFG3000 series of instruments, type the Total Number
of Points, Frequency in Hertz, Phase in degrees, and Cycles. The Sampling Rate is a fixed value
for the selected instrument. The Sampling Rate depends on the total number of points. For the
AFG3101, AFG3102, AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C
instruments, if the total number of points exceeds 16,384 (16 K points), the sampling rate changes
from 1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if
the total number of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to
250 MHz. For the MDO3000 series of instruments, the sampling rate is limited to 250 MHz.

4. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:
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Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG or AFG) is connected. You can select the channel to send
the waveform to.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The
Waveform Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
5. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in
the Shortcut view.

See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)
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Pulse Wave
File > Standard Waveform

To create a pulse wave:
1. Under Settings, set the Function to Pulse, and set the Instrument to the target instrument.
2. Under Vertical, you can choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies the
amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which the
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
3. Under Horizontal, type the Frequency of the waveform in Hertz, the number of Cycles, the Delay in
seconds, and the Pulse Width in seconds. Select Show Advanced Mode to show advanced parameter
options for the pulse wave. You can lock any one of the parameters – Frequency, Samples/sec, or
Points/cycle– and vary the other two.
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The Show Advanced Mode option is not available for the AFG2000, AFG3000, or MDO3000 series
of instruments. For the AFG2000 and AFG3000 series of instruments, type the Total Number of
Points, Frequency in Hertz, Delay, Cycles, and Pulse Width. The Sampling Rate is a fixed value
for the selected instrument. The Sampling Rate depends on the total number of points. For the
AFG3101, AFG3102, AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C
instruments, if the total number of points exceeds 16,384 (16 K points), the sampling rate changes
from 1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments,
if the total number of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz
to 250 MHz. Under Transitions (10%-90%), set the Pulse Direction, Rise Time, and Fall Time
parameters. For the MDO3000 series of instruments, the sampling rate is limited to 250 MHz.

4. If you selected Show Advanced Mode, the Transitions (10%-90%) pane appears.
Set the Pulse Direction to Positive or Negative.
Set the number of points for Rise Time and the rise type to Ramp or Sine2.
Set the number of points for Fall Time and the fall type to Ramp or Sine2. The equivalent value is
displayed in seconds.

5. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:
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Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG or AFG) is connected. You can select the channel to send
the waveform to.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The
Waveform Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
6. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in
the Shortcut view.

See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)
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Noise Wave
File > Standard Waveform

To create a noise wave:
1. Under Settings, set the Function to Noise, and set the Instrument to the target instrument.
2. Under Vertical, you can choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies
the amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
3. Under Horizontal, select Gaussian White Noise or Pink Noise. Enter the Sampling Rate and the Total
Number of Points for the waveform. For the AFG2000, AFG3000, or MDO3000 series of instruments,
type the Total Number of Points. The Sampling Rate is a fixed value for the selected instrument. The
Sampling Rate depends on the total number of points. For the AFG3101, AFG3102, AFG3101C,
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AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C instruments, if the total number of
points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to 250 MHz. For the
AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total number of points exceeds
16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. For the MDO3000 series of
instruments, the sampling rate is limited to 250 MHz.

4. Click Preview to view the waveform.
The following figures show a preview of the Gaussian White Noise and Pink Noise waveforms.

If the number of points is fewer than the number of points supported by the instrument, the following
options appear:
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Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG, AFG, or MDO3000 with MDO3AFG option enabled) is
connected. You can select the channel to send the waveform to.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The
Waveform Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
5. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in
the Shortcut view.

See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)
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DC Wave
File > Standard Waveform

To create a DC wave:
1. Under Settings, set the Function to DC, and set the Instrument to the target instrument.
2. Under Vertical, choose one of the following:
Amp/Offset — to enter the Offset value. Enter the offset value. This value cannot exceed the
maximum offset supported by the instrument.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
3. Under Horizontal, enter the Sampling Rate and the Total Number of Points for the waveform. For
the AFG2000, AFG3000, or MDO3000 series of instruments, type the Total Number of Points. The
Sampling Rate is a fixed value for the selected instrument. The Sampling Rate depends on the total
number of points. For the AFG3101, AFG3102, AFG3101C, AFG3102C, AFG3151C, AFG3152C,
AFG3051C, and AFG3052C instruments, if the total number of points exceeds 16,384 (16 K points),
the sampling rate changes from 1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C, and
AFG3252C instruments, if the total number of points exceeds 16,384 (16 K points), the sampling rate
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changes from 2 GHz to 250 MHz. For the MDO3000 series of instruments, the sampling rate is
limited to 250 MHz.

4. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG, AFG, or MDO3000 with MDO3AFG option enabled) is
connected. You can select the channel to send the waveform to.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The
Waveform Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
5. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in
the Shortcut view.
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See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)

Exponential Rise Wave
File > Standard Waveform

To create an exponential rise wave:
1. Under Settings, set the Function to Exponential Rise, and set the Instrument to the target instrument.
2. Under Vertical, choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies the
amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which the
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
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3. Under Horizontal, enter the Sampling Rate of the waveform, the Phase in degrees, and the number of
Cycles per second. Enter the Total number of Points, and Damp Factor.
For the AFG2000 and AFG3000 series of instruments, type the Phase in degrees, Cycles, Total
Number of Points, and Damp Factor. The Sampling Rate is a fixed value for the selected instrument.
The Sampling Rate depends on the total number of points. For the AFG3101, AFG3102, AFG3101C,
AFG3102C, AFG3151C, AFG3152C, AFG3051C, AFG3052C, and MDO3000 series instruments, if
the total number of points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to
250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total number
of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. For the
MDO3000 series of instruments, the sampling rate is limited to 250 MHz.
4. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG, AFG, or MDO3000 with MDO3AFG option enabled) is
connected. You can select the channel to send the waveform to.
Click the Multi-Waveform Properties (see page 42) button to view or vary the waveform properties.
The Waveform Properties dialog box opens.
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NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
5. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in the
Shortcut view.

See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)

Exponential Decay Wave
File > Standard Waveform

To create an exponential decay wave:
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1. Under Settings, set the Function to Exponential Decay, and set the Instrument to the target
instrument.
2. Under Vertical, you can choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies the
amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which the
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
3. Under Horizontal, enter the Sampling Rate of the waveform, the Phase in degrees, and the number of
Cycles per second. Enter the Total number of Points, and Damp Factor.
For the AFG2000, AFG3000, or MDO3000 series of instruments, type the Phase in degrees, Cycles,
Total Number of Points, and Damp Factor. The Sampling Rate is a fixed value for the selected
instrument. The Sampling Rate depends on the total number of points. For the AFG3101, AFG3102,
AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C instruments, if the
total number of points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to
250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total number
of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. For the
MDO3000 series of instruments, the sampling rate is limited to 250 MHz.
4. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
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Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG, AFG, or MDO3000 with MDO3AFG option enabled) is
connected. You can select the channel to send the waveform to.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The
Waveform Properties dialog box opens.

NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
5. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in the
Shortcut view.

See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)
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Sinc Wave
File > Standard Waveform

To create a sinc wave:
1. Under Settings, set the Function to Sinc, and set the Instrument to the target instrument.
2. Under Vertical, choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies
the amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
3. Under Horizontal, type the Sampling Rate of the waveform, the number of Cycles, and the Phase in
degrees. Enter the Total number of Points and the Number of Zero Crossings.
For the AFG2000, AFG3000, or MDO3000 series of instruments, type the Phase in degrees, Cycles,
Total Number of Points, and Number of Zero Crossings. The Sampling Rate is a fixed value for the
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selected instrument. The Sampling Rate depends on the total number of points. For the AFG3101,
AFG3102, AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C
instruments, if the total number of points exceeds 16,384 (16 K points), the sampling rate changes
from 1 GHz to 250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if
the total number of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to
250 MHz. For the MDO3000 series of instruments, the sampling rate is limited to 250 MHz.

4. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
Click Send to Arb (see page 148) transfer the waveform to an AWG or an AFG. This button is enabled
only when an instrument (AWG, AFG, or MDO3000 with MDO3AFG option enabled) is connected.
You can select the channel to send the waveform to.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The
Waveform Properties dialog box opens.
NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
5. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in the
Shortcut view.
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See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)

Sweep Wave
File > Standard Waveform

To create a sweep wave:
1. Under Settings, set the Function to Sweep, and set the Instrument to the target instrument.
2. Under Vertical, choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies
the amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
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3. Under Horizontal, type the Start Frequency, End Frequency, Time Duration, and Sampling Rate. The
application calculates the Total Number of Points as the product of Time Duration and Sampling
Rate. This is applicable for the AWG7xx, AWG6xx, AWG5xx, AWG4xx, AWG2xxx, and AFG3xx
series of instruments.

For the AFG2000 and AFG3000 series of instruments, type the Start Frequency, End Frequency,
and Total Number of Points. The Sampling Rate is a fixed value for the selected instrument. The
Sampling Rate depends on the total number of points. The Time Duration is calculated according to
the following equation:

For the AFG3101, AFG3102, AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C,
AFG3052C, and MDO3000 series instruments, if the total number of points exceeds 16,384 (16
K points), the sampling rate changes from 1 GHz to 250 MHz. For the AFG3251, AFG3252,
AFG3251C, and AFG3252C instruments, if the total number of points exceeds 16,384 (16 K points),
the sampling rate changes from 2 GHz to 250 MHz. For the MDO3000 series of instruments, the
sampling rate is limited to 250 MHz.
4. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx
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Click Default to restore the default values for the parameters.
Click Send to Arb (see page 148) transfer the waveform to an AWG or an AFG. This button is enabled
only when an instrument (AWG, AFG, or MDO3000 with MDO3AFG option enabled) is connected.
You can select the channel to send the waveform to.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The
Waveform Properties dialog box opens.

NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
5. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in the
Shortcut view.

See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)
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Multi-Tone Wave
File > Standard Waveform

To create a multi-tone wave:
1. Under Settings, set the Function to Multi Tone, and set the Instrument to the target instrument.
2. Under Vertical, choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies
the amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
3. Under Horizontal, type the Start Frequency, End Frequency, Tone Spacing, and Sampling Rate. The
Total Number of Points is calculated according to the following equation:
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For the AFG2000 and AFG3000 series of instruments, type the Start Frequency, End Frequency, and
Total Number of Points. The Sampling Rate is a fixed value for the selected instrument. The Sampling
Rate depends on the total number of points.
The Tone Spacing is calculated according to the following equation:

For the AFG3101, AFG3102, AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C,
AFG3052C, and MDO3000 series instruments, if the total number of points exceeds 16,384 (16
K points), the sampling rate changes from 1 GHz to 250 MHz. For the AFG3251, AFG3252,
AFG3251C, and AFG3252C instruments, if the total number of points exceeds 16,384 (16 K points),
the sampling rate changes from 2 GHz to 250 MHz. For the MDO3000 series of instruments, the
sampling rate is limited to 250 MHz.
4. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
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Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG, AFG, or MDO3000 with MDO3AFG option enabled) is
connected. You can select the channel to send the waveform to.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The
Waveform Properties dialog box opens.

NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
5. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
To display the waveform in a new or existing window, select Multi-Waveform Properties in the
Shortcut view.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in the
Shortcut view.

See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)
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Lorentz Wave
File > Standard Waveform

To create a Lorentz wave:
1. Under Settings, set the Function to Lorentz, and set the Instrument to the target instrument.
2. Under Vertical, choose one of the following:
Amp/Offset — to enter the Amplitude (Pk-Pk) and Offset in volts. The amplitude specifies
the amplitude of the waveform (along the Y-axis ) and the offset specifies the volts by which
waveform will be offset from the origin along the Y-axis . The sum of the amplitude and offset
must not exceed the voltage range supported by the target instrument.
Max/Min — to enter the Maximum and Minimum voltage values for the waveform.
Full DAC Value — to create a waveform for the maximum amplitude supported by the instrument.
3. Under Horizontal, type the Sampling Rate of the waveform, the number of Cycles, and the Phase in
degrees. Enter the Time Delay and Half Width. The Total number of Points is given by:
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For the AFG2000, AFG3000, or MDO3000 series of instruments, type the Phase in degrees, Cycles,
Half Width, and Total Number of Points. The Sampling Rate is a fixed value for the selected
instrument. The Sampling Rate depends on the total number of points. For the AFG3101, AFG3102,
AFG3101C, AFG3102C, AFG3151C, AFG3152C, AFG3051C, and AFG3052C instruments, if the
total number of points exceeds 16,384 (16 K points), the sampling rate changes from 1 GHz to
250 MHz. For the AFG3251, AFG3252, AFG3251C, and AFG3252C instruments, if the total number
of points exceeds 16,384 (16 K points), the sampling rate changes from 2 GHz to 250 MHz. For the
MDO3000 series of instruments, the sampling rate is limited to 250 MHz.
For AFG3xx, AFG2000, and AFG3000 series of instruments, Time Delay is calculated according to
the following equation:

4. Click Preview to view the waveform.
If the number of points is fewer than the number of points supported by the instrument, the following
options appear:

Option

Description

Manually change the Horizontal settings to reach minimum
number of points

Select this and change the parameters to increase the total
number of points in the waveform to achieve the minimum
number of points.

Add zeros to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points of zero voltage to the waveform.

Add last vector to achieve minimum number of points

Select this to achieve the minimum number of points by
appending points with the voltage value of the last point
to the waveform.

xxx

Click Default to restore the default values for the parameters.
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Lorentz Wave
Click Send to Arb (see page 148) to transfer the waveform to an AWG or an AFG. This button is
enabled only when an instrument (AWG, AFG, or MDO3000 with MDO3AFG option enabled) is
connected. You can select the channel to send the waveform to.
Click Multi-Waveform Properties (see page 42) to view or vary the waveform properties. The
Waveform Properties dialog box opens.

NOTE. The Active Waveform tab is disabled when invoked from the Standard Waveform dialog box.
5. Click OK to display the waveform in a new or an existing window. The window values are saved for
this waveform type and the selected instrument.
NOTE. To display the waveform in a new or existing window, select Multi-Waveform Properties in the
Shortcut view.

See Also:
Valid Parameter Ranges (see page 197)
Default Settings (see page 190)
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Marker

Marker
Display > Marker
Selecting Display > Marker from the menu toggles the display of the markers.
Select a marker to edit it. Right-click in the marker field to display a shortcut menu listing the following
options:
Option

Description

Create 0/1 pattern

Fills the entire marker area with a 0/1 pattern

Random pattern

Fills the entire marker area with a random pattern

Clear Pattern

Clears the entire marker area

Invert Pattern

Inverts the marker area values

Freehand

Use the mouse to enter 0,1 data in the marker area by
clicking the mouse to place a data point.

Shift

Shifts marker bits one point to the right or left

Right
Left

Shifts the marker bits one point to the right
Shifts the marker bits one point to the left

Set Pattern

Displays a dialog box where you can set the pattern type
(Hexadecimal or Binary) for the markers

Make High

Sets the data values to high

Make Low

Sets the data values to low

Rotate

Rotates marker bits one point to the right or left

Right
Left

Rotates the marker bits one point to the right
Rotates the marker bits one point to the left

xxx

Edit Markers
To edit markers, select a marker and right-click in the marker pane. From the shortcut menu, select
Freehand to edit marker patterns. Click the points on the marker to edit. Right-click to end freehand
editing.
A tool-tip 'Right-click to end' appears when you are in the freehand editing mode.
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Cursor

Cursor
Display > Cursor
Selecting Display > Cursor from the menu toggles the display of the cursors.
Point to a cursor and select it. The selected cursor or the active cursor is displayed with a solid line and
the other cursor is displayed with a dash-dot line.

See Also:
Cursor Position (see page 113)
Properties (see page 116)

Cursor Position
Display > Cursor Position
Selecting Display > Cursor Position from the menu sets the cursor position in points or seconds.
You can also double-click the cursor head to display the cursor position dialog box.

See Also:
Cursor (see page 113)
Properties (see page 116)
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Zoom In

Zoom In
Display > Zoom In
Select Display > Zoom In from the menu. You can zoom the area of interest by doing either of the
following:
Clicking near a point
Selecting an area of interest
ArbExpress supports unlimited zoom. The zoom extent is limited by the number of points (10) displayed
on the X-axis.

See Also:
Zoom Out (see page 114)
Horizontal Zoom In (see page 115)
Fit to Window (see page 115)

Zoom Out
Display > Zoom Out
Select Display > Zoom Out from the menu to zoom out. You can use Zoom out only after you have
zoomed in. If the markers are displayed, the corresponding marker area is also zoomed.

See Also:
Zoom In (see page 114)
Horizontal Zoom In (see page 115)
Fit to Window (see page 115)
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Horizontal Zoom In

Horizontal Zoom In
Display > Horizontal Zoom In
Select Display > Horizontal Zoom In to zoom the area of interest horizontally. The voltage values
displayed on the Y-axis remain unchanged during horizontal zoom. You can zoom the area of interest
doing either of the following:
Clicking near a point
Selecting an area of interest
If the markers are displayed, the corresponding marker area is also zoomed. ArbExpress supports
unlimited zoom. The zoom extent is limited by the number of points (10) displayed on the X-axis.

See Also:
Zoom In (see page 114)
Zoom Out (see page 114)
Fit to Window (see page 115)

Fit to Window
Display > Fit to Window
Select this to fit the waveform in the window and restore the waveform to its state before the first zoom in.
This option is enabled only after a zoom in or a horizontal zoom. If you have turned on marker display, Fit
to Window also fits the markers within the marker window.

See Also:
Zoom In (see page 114)
Zoom Out (see page 114)
Horizontal Zoom In (see page 115)
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Crosshair

Crosshair
Display > Crosshair
Display the crosshairs by selecting Display > Crosshair from the menu. This toggles the display of the
crosshairs . If there is a check mark next to this command, the crosshairs are on; if there is no check
mark, the crosshairs are off.

See Also:
Cursor (see page 113)
Cursor Position (see page 113)

Graticule
Display > Graticule
Display the graticule by selecting Display > Graticule from the menu. This toggles the display of the
graticule . If there is a check mark next to this command, the graticule is on; if there is no check mark, the
graticule is off.

Time Scale
Display > Time Scale
Select Display > Time Scale to display the waveform with time as the X-axis and voltage along the Y-axis
. If there is a check mark next to this command, the waveform is displayed with Time along the X-axis; if
there is no check mark, Time Scale display is off.

Properties
Display > Properties
Display the waveform, cursor, and marker properties by selecting Display > Properties from the menu.
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Menu selection

Description

Waveform Name

Select the waveform to view or change the properties.

Enable Graticule

Select this to show or hide the graticule.
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Undo

Menu selection

Description

Background Color

Changes the background color of the waveform window

Waveform Properties
Color

Select the color for the waveform.

Line Style

Select the line style for the waveform.

Line Width

Select the line width for the waveform.

Marker Color
Marker1

Select the color for marker1.

Marker2

Select the color for marker2.

Cursor Color
Cursor 1

Select the color for cursor 1.

Cursor 2

Select the color for cursor 2.

xxx

When more than one waveform is displayed in one wave book or window, the inactive waveform is
displayed with a dashed line style and the active waveform is displayed with a solid line style.

Undo
Edit > Undo
Select this to undo the last operation performed on the waveform and restore it to its previous state. This
command can be repeated to undo the last operations indefinitely.

See Also:
Redo (see page 117)

Redo
Edit > Redo
Select this to redo the last operation performed on the waveform.

See Also:
Undo (see page 117)
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Cut

Cut
Edit > Cut
To cut a portion of the waveform:
1. Select the portion of the waveform that you want to cut by turning on the cursors and positioning them
on the waveform. To see the cursors, select Display > Cursors.
2. Select Edit > Cut from the menu or click the icon in the toolbar. The portion of the waveform within
the cursors is cut. If the cursors are hidden, the portion of the waveform that is between the cursors
is cut.

See Also:
Select All (see page 120)
Copy (see page 118)
Paste (see page 119)

Copy
Edit > Copy
To copy a portion of the waveform:
1. Select the portion of the waveform that you want to copy by turning on the cursors and positioning
them on the waveform. To see the cursors, select Display > Cursors. To copy the complete waveform,
select Edit > Select All.
2. Select Edit > Copy from the menu or click the icon in the toolbar. The portion of the waveform
within the cursors is copied to the clipboard. If the cursors are hidden, the portion of the waveform
that is between the cursors is copied.

See Also:
Select All (see page 120)
Cut (see page 118)
Paste (see page 119)
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Paste

Paste
Edit >Paste
To paste a copied portion of the waveform:
1. Select Edit > Paste from the menu. The following dialog box appears:

2. Select an option from the dialog box, and click OK.
Select Paste at active cursor to paste the contents at the currently active cursor. The active cursor
is indicated by a solid line style, and the inactive cursor by a dashed line type.
Select Prepend to the waveform to paste the contents at the beginning of the waveform.
Select Append to the waveform to paste the contents at the end of the waveform.
Select Replace between Cursors to paste the contents between the cursors.
Select Don't show this again and always paste at active cursor option to disable the dialog box
from appearing again and always paste the contents at the currently active cursor. To turn this
option off, select Waveform > Preferences and select Show paste option before pasting.
If the cursors are hidden, the copied portion of the waveform is still pasted. You can paste the
copied waveform across waveforms in any window. You can also paste the waveform into
Microsoft Notepad or Microsoft Excel.
NOTE. To display the cursors, select Display > Cursor.
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Select All
NOTE. In multiple waveform display, ArbExpress pastes the contents to both waveforms to maintain
the same waveform length for both.

See Also:
Copy (see page 118)
Cut (see page 118)
Select All (see page 120)
Cursor (see page 113)

Select All
Edit > Select All
To copy the entire waveform in an active window, select Edit > Select All from the application menu.

See Also:
Copy (see page 118)
Paste (see page 119)
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Copy to System Clipboard

Copy to System Clipboard
Edit > Copy to System Clipboard
To copy the waveform and paste in Microsoft Excel or Microsoft Word, select Edit > Copy to System
Clipboard. You can use these data points to generate the waveform in another application.
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Copy as Bitmap

Copy as Bitmap
Edit > Copy as Bitmap
You can paste the captured image as a bitmap in Microsoft Word or Microsoft Excel.

Invert
Edit > Invert
To invert a portion of the waveform:
1. Select the portion of the waveform that you want to invert by turning on the cursors and positioning
them on the waveform. To see the cursors, select Display > Cursors.
2. Select Edit > Invert from the menu or click the icon in the toolbar. The portion of the waveform
within the cursors is inverted along the X-axis. If the cursors are hidden, the portion of the waveform
that is between the cursors is still inverted.

See Also:
Mirror (see page 123)
Cursor (see page 113)
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Mirror

Mirror
Edit > Mirror
To mirror a portion of the waveform:
1. Select the portion of the waveform that you want to mirror by turning on the cursors and positioning
them on the waveform. To see the cursors, select Display > Cursors.
2. Select Edit > Mirror from the menu or click the icon in the toolbar. The portion of the waveform
within the cursors is mirrored along the Y-axis . If the cursors are hidden, the portion of the waveform
that is between the cursors is still mirrored.

See Also:
Invert (see page 122)
Cursor (see page 113)

Freehand
Edit > Freehand
Select Edit > Freehand to enable the freehand drawing mode or click the icon in the toolbar. Use this
mode to draw a new waveform or to edit an existing waveform. Move the pointer to the point on the
waveform that you want to edit. Click and move the selected point; it moves in the direction the pointer
moves. The voltage readout in the status bar is the actual vertical height of the draw pointer.
Turn off the freehand draw mode by selecting Edit > Freehand or by clicking the corresponding icon.

See Also:
Horizontal Draw (see page 124)
Vertical Draw (see page 124)
Point Draw (see page 125)
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Horizontal Draw

Horizontal Draw
Edit > Horizontal Draw
Select Edit > Horizontal Draw to enable the horizontal draw mode or click the icon in the toolbar. Use
this mode to draw a new waveform or to edit an existing waveform. You can move the selected point
only in the horizontal direction. All vertical movement is restricted.
Move the pointer to the point on the waveform that you want to edit. Click and move the selected point; it
moves only horizontally. The voltage readout in the status bar is the actual vertical height of the draw
pointer.
Turn off the horizontal draw mode by selecting Edit > Horizontal Draw or by clicking the corresponding
icon.

See Also:
Freehand (see page 123)
Vertical Draw (see page 124)
Point Draw (see page 125)

Vertical Draw
Edit > Vertical Draw
Select Edit > Vertical Draw to enable the vertical draw mode or click the icon in the toolbar. Use this
mode to draw a new waveform or to edit an existing waveform. You can move the selected point only in
the vertical direction. All horizontal movement is restricted.
Move the pointer to the point on the waveform that you want to edit. Click and move the selected point; it
moves only vertically. The voltage readout in the status bar is the actual vertical height of the draw pointer.
Turn off the vertical draw mode by selecting Edit > Vertical Draw or by clicking the corresponding icon.

See Also:
Freehand (see page 123)
Horizontal Draw (see page 124)
Point Draw (see page 125)
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Point Draw

Point Draw
Edit > Point Draw
Select Edit > Point Draw > Enable Point Draw to enable the point draw mode or click Enable Point
Draw in the toolbar.
You can use the point draw feature to define points and create a waveform. Before you can enable point
draw, you must have a blank or existing wave book window open. The markers disappear and the Point
Draw toolbar items are enabled.
You can use the Point Draw feature in two ways to create a waveform in a new or existing window:
Enable Point Draw and click points within the waveform window.
Enable Point Draw and select Point Draw Table. Type the coordinates (X, Y) of the points in the
Point Draw Table.

Using Point Draw
Select Point Draw in the toolbar. By default, Dynamic Compile mode is enabled. When Dynamic
Compile mode is enabled, the application generates the waveform dynamically as you click the points.
Select Interpolation mode — Smooth, Linear, or Staircase — to use when then application generates the
waveform. By default, the interpolation method is Smooth.
The Shortcut Menu options are:
Menu item

Description

Disable Point Draw

Disables the point draw mode

Zoom

Has options that you can use to Zoom In, Zoom Out,
Horizontal Zoom In, and Fit to Window

Set Cursor Position...

Opens the Cursor Position dialog box that you can use to
set the cursor position in points or seconds

Time Scale

Changes the values on X axis into time domain

Select Previous Point

Highlights the previous point in the sequence

Select Next Point

Highlights the next point in the sequence

Edit Point Draw Table...

Opens the point draw table where you can edit the points
and set the interpolation method

Delete Selected Point

Deletes the selected point

Clear All Points

Clears the display of all the points but the continues to
display the waveform

Interpolation

Sets the interpolation method to use while generating the
waveform. You can choose form Smooth, Linear, and
Staircase
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Point Draw

Menu item

Description

Dynamic Compile

Compiles the waveform as you click the points using the
interpolation method you have chosen

Compile Draw Points

Compiles the waveform using the interpolation method you
have chosen only when you click Compile

xxx

To Add a Point with Point Draw:
Click a point inside the wave book window. A mark appears at that point indicating the point. In dynamic
compile mode, the point is linked to the nearest two points and the waveform points are recalculated using
the selected interpolation method. If dynamic compile mode is turned off, then the points are compiled
only when you click Compile.

To Delete a Point with Point Draw:
Use the shortcut menu or the toolbar to select a point on the waveform. Select Delete from the Shortcut
Menu or press the Delete key to delete the point. To move to the next or previous point, use the left
and right arrow keys.

To Move a Point with Point Draw:
Press Shift and the left or right arrow keys to move a point by 10 units along the X-axis.

Using the Point Draw Table
You can either enter points in a blank table or edit a point draw table that already has points in it. The
following figure shows the Point Draw table.
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Point Draw

To Add a Point with the Point Draw Table:
You can insert a point in the table by positioning the cursor over a row or point and clicking Insert Point.
Insert Point inserts a row above the selected row or point. Type the X,Y values of a point in the new row.

To Delete a Point with the Point Draw Table:
You can delete a point in the table by positioning the cursor over a row and clicking Delete Point. Delete
Point deletes the currently selected row or point.
You can set the interpolation method to use to any one of these – Linear, Smooth, or Staircase. This setting
determines the method to use while creating a waveform using the points that you defined.
You can clear all the points by clicking Clear All.
You can set the X value to either Time (seconds) or Points. The table refreshes to display the X-value in
the selected unit. This is similar to selecting Display> Time Scale from the application’s main menu.
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Addition

The application checks the values you enter for the following:
X-value (sampling point) must always be unique. If you try to repeat this value, the message “Values
of the sampling index should be unique” appears.
If you leave the amplitude (Y) blank, the applications fills it with a zero.
If you enter a Y value but no corresponding X value, an error appears.
Click OK and if the application finds no errors, the Point Draw Table closes and the waveform in the Wave
Book window is updated to reflect the changes that you made in the Point Draw Table.
If you change from the point draw mode to other modes like Freehand, Horizontal Draw or Vertical Draw
modes, the point s are not lost. If you return to the point draw mode, the points reappear.
From the point draw mode, if you edit the waveform using Cut, Paste, Invert, Mirror, Shift/Rotate, or Math
operations the following message appears: “This edit operation would flush the draw point and you might
lose the current draw points. Do you want to proceed?”

See Also:
Point Draw Toolbar (see page 35)
Freehand (see page 123)
Horizontal Draw (see page 124)
Vertical Draw (see page 124)

Addition
Math > Waveform Math
Enable the math operations by selecting Math > Waveform Math from the menu. A Waveform Math
screen is displayed.

Adding from the Waveform Library
To add a waveform to an existing waveform:
1. Select the type of waveform to add from the Waveform Library. Enter the peak-peak Amplitude,
number of Cycles, and the Offset in degrees for the selected waveform.
The original waveform, the standard waveform to add, and the resulting waveform are displayed in the
Selected Waveform, Math Source, and Resultant Waveform panes.
2. Select Add from Operation.

Adding a Scalar Value
To add a scalar value to the waveform:
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Addition

1. Select Scalar and type a scalar value to add to the waveform.
2. Select Add from Operation.

Adding a Waveform Copied to the Clipboard
To add a waveform from the clipboard:
1. Copy the waveform, or portion of it, by selecting Edit > Copy or Edit > Cut. To define the portion
of the waveform to copy or cut, select Display > Cursor Position to position the cursors over the
waveform. To copy the entire waveform, select Edit > Select All, and Edit > Copy.
2. Select Math > Waveform Math.
3. Click Copy from clipboard and from Operation, click Add. Click OK.
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Subtraction

Subtraction
Math > Waveform Math
Enable the math operations by selecting Math > Waveform Math from the menu. A Waveform Math
screen is displayed.

Subtracting from the Waveform Library
To subtract a waveform from an existing waveform:
1. From the Waveform Library, select the type of waveform to subtract. Enter the peak-peak Amplitude,
number of Cycles, and the Offset in degrees for the selected waveform.
The original waveform, the standard waveform to subtract from, and the resulting waveform are
displayed in the Selected Waveform, Math Source, and Resultant Waveform panes.
2. Select Subtract from Operation.

Subtracting a Scalar Value
To add a scalar value to the waveform:
1. Select Scalar and type a scalar value to subtract from the waveform.
2. Select Subtract from Operation.

Subtracting a Waveform Copied to the Clipboard
To subtract a waveform that has been copied to the clipboard:
1. Copy the waveform, or portion of it, by selecting Edit > Copy or Edit > Cut. To define the portion
of the waveform to copy or cut, select Display> Cursor Position to position the cursors over the
waveform. To copy the entire waveform, select Edit > Select All and then Edit > Copy.
2. Select Math > Waveform Math.
3. Click Copy from clipboard and from Operation, click Subtract. Click OK.
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Multiplication

Multiplication
Math > Waveform Math
Enable the math operations by selecting Math > Waveform Math from the menu. A Waveform Math
screen is displayed.

Multiplying from the Waveform Library
To multiply a waveform with an existing waveform:
1. Select the type of waveform with which to multiply from the Waveform Library.
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Multiplication
The original waveform, the standard waveform to multiply with, and the resulting waveform are
displayed in the Selected Waveform, Math Source, and Resultant Waveform panes.

2. Select Multiply from Operation.

Multiplying with a Scalar Value
To multiply the waveform with a scalar value:
1. Select Scalar and type a scalar value to multiply the waveform with.
2. Select Subtract from Operation.

Multiplying with a Waveform Copied to the Clipboard
To multiply with a waveform that has been copied to the clipboard:
1. Copy the waveform, or portion of it, by selecting Edit > Copy or Edit > Cut. To define the portion
of the waveform to copy or cut, select Display > Cursor Position to position the cursors over the
waveform. To copy the entire waveform, select Edit > Select All, and Edit > Copy.
2. Select Math > Waveform Math.
3. Click Copy from clipboard and from Operation, click Multiply. Click OK.
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Division

Division
Math > Waveform Math
Enable the math operations by selecting Math > Waveform Math from the menu. A Waveform Math
screen is displayed. Waveform division is available only with scalar operations and with a waveform
copied to the clipboard.

Dividing with a Scalar Value
To divide points on an existing waveform with a scalar value:
1. Select Scalar and type a scalar value with which to divide the waveform.
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Division
The original waveform, the standard waveform to multiply with, and the resulting waveform are
displayed in the Selected Waveform, Math Source, and Resultant Waveform panes.

2. Select Divide from Operation.

Dividing with a Waveform Copied to the Clipboard
To divide with a waveform that has been copied to the clipboard:
1. Copy the waveform, or portion of it, by selecting Edit > Copy or Edit > Cut. To define the portion
of the waveform to copy or cut, select Display > Cursor Position to position the cursors over the
waveform. To copy the entire waveform, select Edit > Select All, and Edit > Copy.
2. Select Math > Waveform Math.
3. Click Copy from clipboard and from Operation, click Divide. Click OK.
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AWG/AFG File Transfer and Control

AWG/AFG File Transfer and Control
Communication > AWG/AFG File Transfer and Control
You can use ArbExpress to transfer files to and from an arbitrary waveform generator, a function generator,
or an MDO3000 (with MDO3AFG option enabled) connected to the computer. From the main menu,
select Communication > AWG/AFG File Transfer and Control.
The screen shows a toolbar and the panes — Arb List, PC Folders, PC Files, Instrument Folders,
Instrument Files, and Instrument Control.

ArbExpress AXW100 Printable Help

135

How to ...

AWG/AFG File Transfer and Control

Toolbar
The toolbar contains the following buttons:

Option

Description

Filter setup

Shows the file types to select from

Filter On/Off

Toggles between the enable filter and disable filter modes

Instrument Properties

Displays properties of the instrument selected from the Arb
list

Connect

Connects to a selected instrument

Disconnect

Disconnects a selected instrument if it is connected

Refresh Instrument List

Rereads the instrument file list and updates the Arb list

Show/Hide Instrument Control

Hides the instrument control panel

Help

Displays the help

xxx

Arb List
The instrument list shows a list of Tektronix waveform or function generator models that are supported by
ArbExpress. When you invoke AWG/AFG File Transfer and Control, ArbExpress automatically refreshes
the Arb List and disables the Refresh icon in the toolbar. Refresh is enabled once the Arb List is updated.
When no instruments are available to connect to either over LAN or over GPIB, this view shows only
“AWG Ethernet ” and the IP address last used. Expand the list to display the Visa resource string. Select
the Visa resource string and right-click to display the shortcut menu.
NOTE. It is recommended that you refresh the TekVisa instrument list by right-clicking and selecting
"Refresh" on the system tray TekVisa option to display an active list of instruments in the application
Arb List.
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Transfer Files to an AWG/AFG

Shortcut Menu for the Instrument
Select an instrument and right-click. The shortcut menu displays three options — Connect, Disconnect,
and Properties for GPIB resources. For resources over LAN, the shortcut menu displays four options —
Connect, Disconnect, Set IP Addr, and Properties. Click Connect to connect to the instrument, click
Disconnect to disconnect the instrument, and click Properties to display the properties of the instrument.
The Instrument Properties displayed are Instrument Model, Bus Type (such as GPIB or LAN), Interface
String (such as GPIB0::09:: INSTR — if it is a Visa resource) and connection status (connected or not
connected). Set IP Addr allows you to enter a new IP address for the instrument that is connected over the
LAN.
To prevent multiple connections to an instrument, the Connect button is disabled following a successful
Connect command. When no instrument is connected, the Disconnect button is disabled.

File and Folder Views
The file folder view has two sections. The upper section always shows the PC folder list. This list is shown
whether an instrument is connected or not. When an instrument is connected the lower section shows the
files and folders on the instrument. If the instrument connected is an AFG300 series instrument, it shows
the user memories and edit memories instead of files and folders.
When no instruments are connected, the remote file folder or remote memories are not visible. The
instrument control pane is shown only when an instrument is connected, otherwise it is hidden.

See Also:
Import from Oscilloscope (see page 144)
Transfer Files using MATLAB (see page 159)
Control an Instrument using MATLAB (see page 161)
Scope Acquisition Wizard (see page 149)

Transfer Files to an AWG/AFG
Communication > AWG/AFG File Transfer and Control
You can use ArbExpress to transfer files to and from an arbitrary waveform or function generator
connected to the computer.
To transfer a file to an AWG or an AFG:
1. Select Communication > AWG/AFG File Transfer and Control from the menu.
2. Select the AWG or AFG from the Arb list and expand the tree to see the Resource ID used to connect.
If no AFGs or AWGs are available, the Arb list view displays — AWG Ethernet, with the IP address
used for the last connection. No instrument properties are shown.
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Transfer Files to an AWG/AFG

3. Select the resource string (for example, GPIB1::01:: INSTR ) and right-click to display the shortcut
menu. Click Connect in the shortcut menu. If you connect to the instrument successfully, the
instrument File and Folder views show the data files of the connected AWG or the edit and user
memories of the AFG.
4. Expand the Folder tree to view the list of folders and files within. Select a file in the instrument File
view and right-click to display the shortcut menu. Select Copy.
5. Select a PC folder, right-click the PC file list, and select Paste. A progress bar shows the percentage of
task completed.
6. You can transfer the waveform using one of the following methods:
Directly on a USB flash drive.
Wherever a .set file is created for a waveform (.wfm or .pat) file in ArbExpress, it contains
information including the name of the waveform file, the voltage, offset, and clock information.
You can save the .wfm, .pat, and the .set file to a USB flash drive and transfer it manually to
an AWG or an AFG.
By dragging and dropping the .wfm file from the PC to the instrument or from the instrument to
the PC. The application automatically drags and drops the .set file.
Follow these steps to drag and drop a waveform file to the instrument:
a. Select Communication > AWG/AFG File Transfer and Instrument Control.
b. Use the shortcut menu or the toolbar to connect to the instrument.
c. Drag and drop the required .wfm/.pat file from PC list view to instrument files view
for an AWG. The application automatically transfers the .set file to instrument (not for
AWG2000 series).
d. For an AFG, drag and drop the .wfm or .pat file to the Edit memory or User memories.
For the AFG3xx series, you can transfer the waveform files in the following directions — PC
to Edit memory, PC to User memory, and Edit memory to User memory.
For the AFG2000 and AFG3000 series, you can transfer the waveform in the following
directions— PC to Edit memory, PC to User memory, Edit memory to User memory, and
Edit memory to PC.
For the MDO3000 series, you can transfer the waveform in the following directions — PC to
Edit memory and Edit memory to PC.
When you transfer a waveform from the Edit memory to the PC, the file has the name
EMEM<n> in the destination folder. When you transfer a waveform from the PC to the Edit
memory, the EMEM<n> waveform text box shows the waveform file name. When you drag
the EMEM<n> file to User<n>, the User<n> text box shows the file name as EMEM<n>.
When you drag a file from the PC Files list and drop it to the destination Edit or User memory,
the default destination text "Drag source file and drop here" is replaced with the name of
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the file transferred. When you close the dialog box or reinvoke it, the default destination
text reappears.
e. In the AWG, load the .wfm or .pat file using the Load/Restore button.
Directly send the waveform from a Wave book, Standard Waveform dialog, or Equation Editor
dialog to the instrument.
Use the Send to Arb option to select a channel on the target instrument and send the waveform
directly from the wave book, Standard Waveform dialog box, or Equation Editor dialog box.
The application provides an option in the Preference tab – Channel output On after waveform
transfer using "Send to Arb" – to turn the target channel on and output the waveform data. The
waveform is sent to the target channel and loaded on to it. The corresponding amplitude and offset
will also be set on the instrument.
In the AFG3xx, AFG2000, AFG3000, and MDO3000 series, the waveform is sent to the edit
memory. A message "Are you sure you want to overwrite EMEM<n> with this file?" warns you
that the instrument edit memory will be overwritten.
Follow these steps to transfer the waveform directly to the instrument from a Wave book:
a. Select Communication > AWG/AFG File Transfer and Instrument Control and establish
connection between the instrument and the PC. Once the connection is successfully
established, you can close the File Transfer dialog box. The connection is not lost by closing
the file transfer dialog.
b. Create a waveform and from the shortcut menu, click Send Waveform to Arb and choose the
target channel to which to transfer the waveform.
c. The voltage, offset, and other parameters that are set while creating the waveform, are set on
the instrument automatically. After the file is transferred successfully the parameters are
set, and if the preference Channel Output ON after waveform transfer using "Send to
Arb" is selected, the target channel is switched on, and instrument is set in Run mode. If this
preference is not selected, then the target channel is switched off.
NOTE. When you use this mode of file transfer, an associated .set file is not created. The
transferred file is loaded in the instrument internal memory.
In an AFG, the transferred file is loaded in the Edit memory, and in an AWG it is loaded
on the destination channel.
d. Repeat step b and step c to transfer a waveform form the Equation Editor or Standard
Waveform dialog boxes.
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Control an AFG
Communication > AWG/AFG File Transfer and Control
You can use ArbExpress to control an AFG or MDO3000 series (with MDO3AFG option enabled)
connected to the computer. The AFG3xx series parameters can be controlled from the instrument control
pane.
NOTE. The MDO3000 series with option MDO3AFG enabled provides some, but not all, of the AFG
controls described in the section. Features or functions that do not apply to the MDO3000 will be noted as
such.
To control an AFG:
1. Select an AFG from the instrument list. Even though the PC is physically connected to an AFG, the
screen does not show the Instrument Control panel. Select an AFG, and from the shortcut menu select
Connect. The instrument control panel appears. All the controls are updated for the selected channel.
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AWG/AFG File Transfer and Control screen. This screen will look slightly different if you are using an MDO3000
series instrument with option MDO3AFG.
2. Select the channel in the channel selection box to output data. The number of channels shown depends
upon the number of channels of the instrument that is connected. You can select only one channel at a
time. Channel 1 is the default. (The MDO3000 only has 1 channel.)
You can set the Function parameter in the list by selecting the function form the function list. Click
Apply to reflect the new selection.
The Vertical parameters — Phase, Amplitude, and Offset values — are loaded from the file. The
Function field displays the waveform type that is loaded.
3. Set the Operating Mode, Output Frequency in Hertz, and EMEM size in bytes, or use the default
settings for the instrument.
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The operating modes available for the AFG2000 and AFG3000 series are: Continuous, Sweep, Burst
1-cycle, Burst N-cycle, Burst Gated, Burst Inf cycle, Modulation AM, Modulation FM, Modulation
PM, and Modulation FSK. The operating mode depends on the function that you have selected. The
operating modes available for AFG3xx series are: Continuous, Trigger, and Burst.
The operating mode available for the MDO3000 is Continuous.

4. Select the Output On check box to generate the waveform output for the channel selected. Clear the
check box to stop generating the output.
5. You can change the Phase, Amplitude, and Offset values and click Apply to reflect the new values in
the output waveform.
NOTE. Run/Stop is disabled for all AFGs.

Control an AWG
Communication > AWG/AFG File Transfer and Control
You can use ArbExpress to control any AWG parameters that are displayed in the Instrument Control pane.
To control an AWG:
1. Connect an AWG from the Arb list. All the controls are updated for the selected channel.
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2. Select the channel in the channel selection group box. The number of channels shown depends
upon the number of channels of the instrument that is connected. You can select only one channel
at a time. Channel 1 is the default.
3. Select the Output On check box to enable the selected channel. In case of AWG2xxx, the selected
channel is enabled and the waveform is output.
NOTE. It is recommended that you load a file in this channel and then enable or disable the channel.
4. Drag and drop a .wfm or .pat file from the instrument files list to the File Name field or type the
file name and click Load. The Vertical parameters — Filter, Amplitude, Offset, and Clock values
— are updated.
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If you click once on a file in the Instrument Files view, the name of the selected file appears in the Load
File to AWGtext box. If you click twice (double click) on the file in the Instrument Files view, the
name of the selected file appears in the Load File to AWGtext box and is also loaded in the instrument.

5. Change the Clock frequency to set the output frequency for the selected channel.
6. Set the High and Low values for Marker1 and Marker2. When no file is loaded, these fields display
the values for the selected channel.
7. Click Run/Stop to generate or stop the waveform output for the selected channel.
NOTE. It is recommended that you load a file on the selected channel and then click Run/Stop.
8. You can change the Filter, Amplitude, and Offset values and click Apply to reflect the new values in
the output waveform.

Import from Oscilloscope
Communication > Import from Scope
You can use ArbExpress to acquire data from an oscilloscope connected to the computer.
To import from an oscilloscope:
1. Select Communication > Import from Scope from the menu.
2. Select the oscilloscope from the instrument list and right-click. From the shortcut menu, select
Connect.
3. Expand the oscilloscope tree to view the channels. Select a channel and right-click to set or change
the parameters.
4. Select Import from Scope from the shortcut menu.
5. Move to the computer file folder view and select a folder. Right-click and select Paste. A progress bar
shows the percentage of task completed. ArbExpress automatically assigns file names in the form
<Model Name>_<Channel Number>. wfm . For example, if you have acquired the waveform from
Ref3 of a Tektronix TDS2024 Oscilloscope, the file name would be TDS 2024_Ref3.wfm.
The screen shows a toolbar and the panes — Scope List, PC Folders, PC Files, and Status.
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Toolbar
The toolbar contains the following buttons:
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Option

Description

Filter Setup

Selects types of files available

Filter On/Off

Enables or disables filters

Instrument Properties

Displays properties of the selected oscilloscope

Connect

Connects to a selected oscilloscope

Disconnect

Disconnects a selected oscilloscope if it is connected

Refresh Instrument List

Rereads the instrument file list and updates the instrument
view

Open in New Window

Acquires data from selected channel and displays it in a
new window

Help

Displays the help for the dialog box

xxx

Instrument List
The instrument list shows a list of Tektronix oscilloscope models that are supported by ArbExpress.
ArbExpress supports TDS1000, TPS2000, TDS2000, TDS3000, TDS5000, TDS6000, TDS7000,
TBS1000, DPO2000, DPO3000, DPO4000, MSO2000, MSO3000, MSO4000, MDO3000, and
MDO4000 series oscilloscopes. When the oscilloscopes are not connected, the channels are not visible.
Before you acquire data, you must connect to the oscilloscope. You can do this either by selecting one
of the listed oscilloscope models and clicking the Connect button in the toolbar or by bringing up the
shortcut menu by right clicking on an oscilloscope in the instrument view. When you connect successfully
to the selected oscilloscope, you will see the available Channels, Math, and Ref channels.
Assigning friendly names to listed oscilloscopes: You can associate a "Friendly name" with the
oscilloscope you want to connect to. You can do this by giving the VISA resource string associated
with the Oscilloscope an alias in the TekVisa Resource Manager dialog box. The Alias appears in the
instrument list within brackets as shown in the following figure.
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Shortcut Menu for the Oscilloscope
Select an oscilloscope and right-click. The shortcut menu displays three options — Connect, Disconnect,
and Properties. Click Connect to connect to the oscilloscope and click Disconnect to disconnect the
oscilloscope. Click Properties to show the Instrument Model, Connection Status, Interface String, and
Bus Type.

Shortcut Menu for Each Channel
Select an oscilloscope channel and right-click. The shortcut menu is displayed showing the channel
parameters that you can set. This shortcut menu is available only when the oscilloscope is connected.
Option

Description

Run Mode

Displays the second level of menu with item — Continuous,
and Single Sequence. Continuous acquisition puts the
oscilloscope in the Run mode. Single Sequence acquisition
stops the acquisition as soon as the oscilloscope acquires
one full waveform.

Acquisition Mode

Displays a submenu with the acquisition modes that
ArbExpress supports. The mode currently selected is
checked. To change the mode, select it from the drop-down
list.

Record Length

Displays the available record lengths for the connected
instrument. A check mark shows the currently selected
record length. If you are connected to a model other than
the TDS1000, TPS2000, TDS2000, or TBS1000 series, you
can change the record length to any other value in the list.

Acquire

Copies the waveform into ArbExpress application buffer.

xxx

File Folder View
The File folder view displays the directory tree of the computer hard disk drive. You can navigate the
files as you do with Windows Explorer. Right-click the file list to see a shortcut menu with the Paste
command . You can copy a waveform from a Channel, Ref or Math, and paste it in the current folder.
You can also select a Channel, Ref or Math from the Instrument List view and drop it into the selected
folder to acquire the waveform.

Channel Status
Channel status is a list of read-only data, displayed below the PC file folder view. This shows the details of
the currently selected channel.
NOTE. An entry – Math Equation – appears only for Math channels. This entry displays the equation
used for creating the math waveform.
When no oscilloscopes are connected, this list contains no data.
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See Also:
AWG/AFG File Transfer and Control (see page 135)
Scope Acquisition Wizard (see page 149)

Send Waveform to Arb
Communication > Send Waveform to Arb
Select this option to send the waveform to an AWG/AFG. If no instrument is connected, the message “No
Arb is connected. Do you want to connect now?” appears. If you are connected to an AWG/AFG, then the
waveform is transferred to the instrument. A progress bar displays the status of the operation. You can use
the Send to Arb option to select a channel on the target instrument and send the waveform directly from
the Wave book, Standard Waveform dialog box, or Equation Editor dialog box. Once connected, all the
channels available on that instrument are displayed in the toolbar and menu.
The application provides an option in the Preference tab – Channel output On after waveform transfer
using “Send to Arb”– to turn the target channel on and output the waveform data. The waveform is
sent to the target channel and loaded on to it. The corresponding amplitude and offset will also be set
on the instrument.
In the AFG3xx, AFG2000, AFG3000, and MDO3000 series, the waveform is sent to the edit memory. The
message "Are you sure you want to overwrite EMEM<n> with this file?" warns you that the instrument
edit memory will be overwritten.
Follow these steps to transfer the waveform directly to the instrument from a Wave book:
1. Select Communication > AWG/AFG File Transfer and Instrument Control and establish
connection between the instrument and PC. Once the connection is successfully established, you can
close the File Transfer dialog box. The connection is not lost by closing the File Transfer dialog box.
2. Create a waveform. In the shortcut menu, click Send Waveform to Arb and choose the target channel
to which to transfer the waveform.
3. The voltage, offset, and other parameters that are set while creating the waveform are set on the
instrument automatically. After the file is transferred successfully the parameters are set, and if the
preference Channel Output ON after waveform transfer using "Send to Arb" is selected, the
target channel is switched on, and instrument is set in Run mode. If this preference is not selected,
then the target channel is switched off.
NOTE. When you use this mode of file transfer, an associated .set file is not created. The transferred
file is loaded in the instrument internal memory.
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In an AFG, the transferred file is loaded in the Edit memory, and in an AWG it is loaded on the
destination channel.

4. Repeat steps 2 and 3 to transfer a waveform from the Equation Editor or Standard Waveform
dialog boxes.

See Also:
Transferring Files to an AWG/AFG (see page 137)
Scope Acquisition Wizard (see page 149)
Valid Parameter Ranges (see page 197)

Scope Acquisition Wizard
Communication > Scope Acquisition Wizard
The wizard guides you through a series of steps to acquire data from a connected oscilloscope.
1. Select Communication > Scope Acquisition Wizard from the application main menu. The wizard
starts with the Welcome to the Scope Acquisition Wizard screen.
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2. Click Next. The wizard displays the next screen, searches and displays a list of instruments that are
connected to your PC. If no instruments are found, the message “No instruments found” appears.
Connect an instrument and click Refresh in the Wizard.
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3. Select an instrument to see its details. The first instrument in the list is selected by default. To refresh
the instrument list, click Refresh.
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Click Next to connect to the selected instrument and display the Set Up Acquisition screen.
Depending on the selected oscilloscope, the channel, math, and ref details are displayed. Select the
channel, math, or ref from which to acquire data. If no math and ref are available for the selected
instrument, the following text appears:
No math channels were found.
No reference channels were found.
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In the Select Instrument screen, the following happens:
If the instrument is already connected through the Import from Scope menu, then the connected
instrument is selected in the list.
Selecting another instrument disconnects the connected instrument.
Scanning for instruments does not happen if it has already happened through the Import from
Scope menu. The scanned instruments are displayed in the instrument list.

4. Select the record length from the drop-down list. Choose from the list of record lengths supported
by the instrument connected.
5. Select the acquisition mode form the drop-down list. Choose from Sample, PeakDetect, Average,
Hires, and Envelope.
6. Browse for the target directory to save the data in a .wfm format. The target directory
defaults to the directory that you last selected. The default path and file name are –
C:\AcquiredFiles\<Oscilloscope_channel>.wfm. Scope Acquisition Wizard. If you have a file with
the same file name as that specified in the path, the warning message “A file already exists with this
name in this folder. Do you want to overwrite?” appears. Click Yes to overwrite the file, and No
to specify another file name.
7. Click Next to display the Preview Waveform screen.
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Choose one of the following:
No changes: Make no changes to the waveform before importing.
Extract a segment manually: Extract a part of the waveform by defining the cursor positions.
The wizard opens another screen.
8. Click Next to import or extract a sample of the waveform.
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To import a waveform:
a. Enter the number of points.
b. Select whether to rotate left or right. This would help to locate any disconnect toward the end of
the waveform. The waveform will be rotated only in this view.
c. Select whether to open the waveform in a new window.
d. Click Finish to import the waveform.
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To extract a segment of the waveform:
a. Enter the position of Cursor1.
b. Enter the position of Cursor2.
c. Select the target instrument and click Validate to validate the waveform against the instrument.
The application presents a dialog that indicates whether the currently selected instrument can
accommodate the waveform. If the waveform is not valid for the selected instrument, text in the
dialog indicates the waveform is not valid and provides details about the selected instrument’s
capability.
d. Click Next. The Ready to Import Waveform screen appears. Follow the steps as in importing a
waveform with no change.
e. Click Finish to import the waveform.

9. The waveform acquired is opened in a new window or will be stored in the path shown.

Normalize
Math > Normalize
You can normalize a waveform such that all points on it lie between +1 and – 1.
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1. Select the waveform to normalize.
2. Select Math > Normalize.
The resulting waveform is as shown.

Creating Waveforms Using Matlab
This section describes how to use MATLAB software to connect to Tektronix AWGs . To use the
MATLAB support, you must:
Ensure that you have installed MATLAB version 6, release 12. The function supplied might work with
lower release numbers but they are tested on MATLAB release 12.
Ensure that you have installed TekVisa.
Ensure that the system path includes the path where ArbEther.dll is installed. By default, this
ArbEther.dll is copied to the directory where ArbExpress is installed. You need this DLL if you
connect to AWGs over Ethernet.
This ArbExpress MATLAB utility is installed, by default, in the path ArbExpress\Tools\Matlab. The
directory contains a “.p” file for each command and a corresponding “. m ” file that has the documentation
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for the command. A sample MATLAB Script, “ Sample.m ” is provided to show how to use the commands
in a MATLAB Environment.
The MATLAB script is stored in a .m file that is created using the MATLAB built-in editor. When you
compile a .m file, you get a .p file.
The following files must be present in the directory before you start using the commands documented here:

Commands
NewSession.p
CloseSession.p
query.p
read.p
write.p
LoadWfm.p
TransferWfm.p

Sample Script File
sample.m

DLL File with Gateway Routine
matarb.dll

Transferring Files from Matlab
1. Start MATLAB.
2. Go to the directory where you stored the MATLAB library files that are supplied with ArbExpress
(C:\ProgramFiles\Tektronix\ArbExpress\Tools\Matlab).

3. Open a session on an AWG connected either through LAN, GPIB, or USB to your PC.
Connecting through GPIB:
You can connect to the AWG using the NewSession command as follows for an instrument connected
through GPIB.
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[ SessionID , StatusMsg ] = NewSession ('GPIB0::9::INSTR', 'GPIB')

This command works only if the GPIB resource string is found by TekVisa resource Manager. For
more information, refer to the TekVisa Resource manager documentation for help on adding new
instruments to the PC.
Connecting through LAN:
You can connect to the AWG using the NewSession command as follows for an instrument connected
through LAN. Since TekVisa does not support connection over raw sockets, TekVisa does not list the
resource name.
Connecting to an AFG2000 and AFG3000 series instrument using Visa:
[SessionID, StatusMsg] = NewSession ('TCPIP::10.20.30.40::INSTR', 'LAN')

Connecting to AFG300, AWG2000, AWG400/500/600/700 series not using Visa (support through
raw sockets):
[SessionID, StatusMsg] = NewSession ('10.20.30.40', 'TCPIP')

Connecting through USB:
You can connect to the AWG using the NewSession command as follows for an instrument connected
through USB.
[ SessionID , StatusMsg ] = NewSession
('USB0::0x0699::0x0343::JU010107::INSTR', 'USB')

If the command is executed successfully, the session ID is available in the SessionID variable and the
StatusMsg is a null string. If the command is not successful, the SessionID contains an error code with
the StatusMsg containing the text describing the failure.
4. Create a Waveform using the MATLAB mathematical functions such as Sin or Exp.
The following script for example, creates a sine waveform having a thousand points and stores it in a
variable called Data. Enter the text in the MATLAB editor and save it as a .m file.
Frequency = 1e2;
Period = 1/Frequency;
Pts = [1:1000] * Period;
Data = sin(Pts );

5. Use this variable to transfer the Sine wave created to the AWG as shown:
[Status,StatusMsg] = SendWfm (SessionID, 'example.wfm', Data, 1000)

where the SessionID is the session you have opened earlier, example.wfm is the name of the waveform
file, and 1000 is the number of points in the waveform.
If the file transfer is successful, you should see the waveform file with the selected name in the
current directory of AWG.
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NOTE. Current directory refers to the directory path returned by MMEM : CDIR command – not the
directory as seen on the instrument display.
6. Close the session using the CloseSession command as shown:
CloseSession( <SessionID>)

where SessionID is the session you created.

Controlling the Instrument
You can control the instrument from the MATLAB environment.
1. Open a session using the NewSession command.
2. Once connected to the AWG, use the Write command to send any command that is supported by
the current AWG.
3. Use the Query command to query the instrument parameters.
For example, the following command shows how to load a file and output it from channel 1 of the
AWG:
[Status, StausMsg ] = LoadWfm(SessionID , 'example.Wfm', 1)

This attempts to load the file “example.Wfm” from the current directory path and output it from
Channel 1 of the AWG. This command fails if the file is of a wrong format or not found in the
current directory. You may not see any output if the channel number chosen is not supported by the
connected instrument.
NOTE. ”Current directory” here refers to the directory path returned by MMEM : CDIR command – not
the directory as seen on the instrument display.

Example Program:
%A very preliminary sample code to show how to use MATLAB functions %to talk
to an AWG from MATLAB %Please compile this using 'PCODE <filename>' before
%running it.
%This script only with Visa resource strings %Turn off echo
echo off
%Open a session. If you are connecting over LAN to an AWG %the first
parameter to NewSession would be the IP address %and the second parameter
would be the string 'tcpip'
s=NewSession('gpib0::9::instr','gpib');
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%IDN query outputs two values:
the instrument.

Status of the query, and the %Response from

[status,idn]=query(s, '*idn?');
%Writes a single command to the connected AWG. The status will %be Zero if
write is successful
status=Write(s,'Output1:State 1');
%Following script creates a sine waveform with %1000 points
Frequency = 1e2;
Period = 1/Frequency;
Pts = [1:1000] * Period;
Data = sin(Pts);
%Following command transfers the waveform in %'Data' variable to the current
%directory of %AWG.
TransferWfm(s, 'example.wfm', Data, 1000)
%Closes the connection
CloseSession(s);
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Commands
ArbExpress implements the following commands for communication with Tektronix AWGs:

Session Management
NewSession
CloseSession

Instrument Control and Data Transfer
Read
Write
LoadWfm
TransferWfm
Query

See Also:
NewSession.p (see page 164)
CloseSession.p (see page 165)
query.p (see page 170)
Read.p (see page 167)
Write.p (see page 166)
LoadWfm.p (see page 168)
TransferWfm.p (see page 169)
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NewSession Command
Description
This command opens a communication session with a Tektronix AWG connected to the PC using GPIB or
LAN cable.

Syntax
[nSessionID, strErrMsg] = NewSession(strResourceID, strBusType)

Parameters
strResourceID — A MATLAB string containing the resource name in the standard Visa format.
strBusType — Communication bus used for connection. Supported values are "GPIB" and "TCPIP".

Return Values
nSessionID — A numeric variable that holds the session ID to be used in subsequent communication
with the instrument.
strErrMsg — Contains the error description if you fail to connect to the instrument. When the connection
is successful it contains a null string.
NOTE. Before trying to connect to the instrument, make sure that the instrument is accessible by TekVisa
Resource manager. See the TekVisa VisaRM documentation for help on how to configure VisaRM to
detect the instrument.

Example
[SessionID , StatusMsg] = NewSession ('GPIB0::9::INSTR', 'GPIB')
[SessionID , StatusMsg] = NewSession ('TCPIP::10.20.30.40::INSTR', 'TCPIP')
[SessionID , StatusMsg] = NewSession ('USB0::0x0699::0x0343::JU010107::INSTR',
'USB')
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CloseSession Command
Description
This command closes the connection with instrument.

Syntax
CloseSession(nSessionID)

Parameters
nSessionID — A Numeric value of the session obtained when NewSession command was called.

Return Values
None.
NOTE. You must have an active connection with an instrument before calling CloseSession.

Example
CloseSession( <SessionID>)
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Write Command
Description
This command sends a SCPI command to the connected instrument.

Syntax
[nStatus, strErrMsg] = Write (nSessionID, strCmd)

Parameters
nSessionID — Session ID obtained by NewSession command.
strCmd — SCPI command string

Return Values
nStatus — Zero if successful, error code if the operation failed.

Example
[nStatus, strErrMsg] = Write (nSessionID, '*IDN?')
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Read Command
Description
This command reads responses from instruments. Response to the query sent in a previous call to Write
command or error message if the query failed.

Syntax
[nStatus, strResponse] = Read(nSessionID)

Parameters
nSessionID — Session ID obtained from NewSession command

Return Values
nStatus — Zero if successful, error code if the operation failed.
strResponse — Response to the query sent in strQuery parameter or error message if the query failed.
NOTE. Read will return a proper response only when it is called immediately after a Write operation that
wrote one of the SCPI query commands.

Example
Read(nSessionID)
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LoadWfm Command
Description
This command loads a waveform into the connected AWG internal memory and outputs it from the
selected channel.

Syntax
[nStatus, strErrMsg] = LoadWfm(nSessionID, strWfmName, nCh)

Parameters
nSessionID — Session ID obtained by calling NewSession command
strWfmName — Name of the Waveform file with or without the extension.
nCh — Channel number.

Return Value
The command always returns Zero as the return value.
NOTE. The waveform file you are trying to load must be in the current directory. If the file is in any other
directory, change the path to the directory where the desired file is located by using the MMEM:CDIR
command. When the load command is sent, the instrument takes time to load the file, especially if they
are big files. Because the call is synchronous, the program does not return until the load operation is
completed on the instrument.
If the waveform file is corrupt or in the wrong format, the instrument does not load it.

Example
[Status, StausMsg ] = LoadWfm(SessionID , 'example.Wfm', 1)
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TransferWfm Command
Description
This command transfers a waveform from the MATLAB environment to the connected instrument mass
memory.

Syntax
TransferWfm[nSessionID, strWfmName,double dDataPoints[], nSize)

Parameters
nSessionID — Session ID obtained from NewSession command
strWfmName — The name of the waveform file to be created in the instrument
dDataPoints — One-dimensional array of doubles containing data points
nSize — Number of data points in the file.

Return Values
None.
NOTE. Use this function to transfer an array of data values into an AWG and store it in the form of a
waveform file. Be cautious while using this function because if you choose a file name that already exists
in the current directory of the Instrument, it will be overwritten without warning.
Also note that this is only a transfer command and the transferred file is not loaded into the internal
memory of the instrument.

Example
TransferWfm(SessionID, 'example.wfm', Data, 1000)
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Query Command
Description
This command sends a query and returns the response from the instrument.

Syntax
[nStatus, strResponse] = Query(nSessionID, strQuery)

Parameters
nSessionID — Session ID obtained from NewSession Command
strQuery — Standard SCPI query

Return Values
nStatus — Zero if successful, error code otherwise
strResponse — Response to the query sent in strQuery parameter or error message if the query failed.
NOTE. This is a combination of Write and Read commands. The return value always returns the result
of the read operation

Example
[nStatus, strResponse] = Query(nSessionID, '*IDN?')
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Error code

Error message

Description

Possible solution

1001

ArbExpress instance
already running

The application displays
this message if you try to
run ArbExpress when an
instance is already open.

Close ArbExpress and try
again.

1002

Do you want to overwrite?

A file with the same name
is found in the currently
selected folder.

Rename the file in the
selected folder or select a
different folder.

1003

Do you want to proceed?

This message appears
when user tries to do any
edit operations in point
draw mode.

Choosing "Yes" would
continue with edit operation
but all the draw points
will be flushed. Choosing
"No" would abort the edit
operation.

1004

Total number of points in
the waveform is less than
minimum points required
by the instrument

This error message
appears when the user tries
to transfer the waveform
(or when user validates
the waveform manually)
to a connected/selected
instrument and the total
points is less than the
minimum points supported
by the instrument.

For minimum points
required by the instrument,
refer to the Instrument
Specifications.

1005

Total number of points
exceeds maximum memory
supported by the instrument

This error message
appears when the user tries
to transfer the waveform
(or when user validates
the waveform manually)
to a connected/selected
instrument and the total
points exceeds the
maximum memory limit
of the instrument.

Change the total points
such that it does not exceed
the maximum memory limit
of the instrument. For
maximum memory limit of
the instrument, refer to the
Instrument Specifications.

Main Application
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Error message

Description

Possible solution

1006

Total number of points
is not a multiple of point
step supported by the
instrument

This error message
appears when the user tries
to transfer the waveform
(or when user validates
the waveform manually)
to a connected/selected
to instrument and the total
points is not a multiple of
the point step.

The total points should
be a multiple of point
step supported by the
instrument. For step size
of the selected instrument,
refer to the Instrument
Specifications.

1007

This waveform can be
loaded successfully into the
instrument selected

This error message
appears when user
validates the waveform
for the selected instrument
and the waveform can
successfully generated in
the selected instrument.

This message indicates the
waveform conforms to the
specification of the selected
instrument.

7001

Invalid file or no data points
available

The file you tried to open
is either corrupt or the file
does not have enough
data points to create a
waveform.

Ensure that you are
opening a valid file. If you
need help to open your file
or want to verify your file
send the file to techsupport
@tektronix.com with the
description and format of
the file.

7002

Error in file format

The file you opened is of
the wrong format.

Ensure that the file format
is one of the following —
wfm, .pat, TekScope .wfm
csv, .txt.

7003

Do you want to Save
changes to the file
<filename>?

This message appears
when you try to close the
waveform or application
without saving.

Select Yes to save the
file or No to close without
saving.

7004

Unexpected file format

This error message
appears when the file is not
supported by ArbExpress
or if it is a corrupted file.

Verify that the file is not
corrupted. Verify that the
file format is supported by
ArbExpress. If the file is not
corrupt and is valid, please
contact customer support
for more clarification.

Main Application

File Handling
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Multiple Waveforms
6001

Only two waveforms can
be opened or created in a
Wave Book

A maximum of two
waveforms can be opened
in a Wave Book. You have
tried to open or create more
than two waveforms in a
Wave Book.

Open or create the
waveform in another Wave
Book or a new window.

6002

You can open only files with
"####" points in this Wave
Book.
To open the file <filename>
in a new window, set
Multi-Waveform Properties
to New Window and select
File> New or Open.
You can also use the
Open or New icon from the
toolbar

Only waveforms with files of
the same number of points
in size can be opened
or created in the same
window.

You can:

You can create only
waveforms with ####
points in this Wave Book
To create a waveform
in a new window, set
Multi-waveform properties
to New window and select
File> New

Only waveforms with files of
the same number of points
in size can be opened
or created in the same
window.

6003

Select a new
window by setting
the Multi-Waveform
Properties to New
Window.
Select a waveform with
the same number of
points as the existing
waveform in the Wave
Book.
You can:
Select a new
window by setting
the Multi-Waveform
Properties to New
Window.
Select a waveform with
the same number of
points as the existing
waveform in the Wave
Book.

Standard Waveform
1201

Enter a value

This message appears when
no value has been entered in
a field.

For more details refer to the
instrument specification.

1202

Invalid value

This message appears if you
have entered an invalid value
in the editable fields.

The value must not cross
the selected instruments
specification. For more
details, refer to the Instrument
Specifications.

1203

Invalid amplitude. Voltage
range supported is xx–xx

The value entered is not
within the instrument range.

Enter a value that lies
within the amplitude range
supported by the instrument.
For more details, refer to the
Instrument Specifications.

1204

Invalid Offset, Range +x.x to
–x.x

This message appears when
offset crosses the range
supported by the instrument.

Enter a value that lies within
the range.
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1205

Instrument cannot generate
this frequency

This message appears
when the instrument cannot
generate the frequency
entered because the points
per cycles is less than 2 for
sine and triangle and less
than 10 for square and pulse.

Enter the frequency such that
there are at least 2 points per
cycle for Sine and Triangle
and at least 10 points per
cycle for Square and Pulse.

1206

Invalid Sampling Rate Range
supported by the instrument
is xx - xx

This message appears if the
sampling rate exceeds range
supported by the instrument.

Enter a value that lies within
the range of the selected
instrument. Refer to the
instrument specifications for
the range supported.

1207

Start frequency greater than
end frequency

This message appears when
the start frequency entered
for sweep and multi-tone
waveforms is greater than the
end frequency.

Start frequency entered
should be less than the end
frequency.

1208

Points per Cycle*Cycle,
exceeds the Maximum
memory limit of the instrument

This message appears
for sine, triangle, pulse,
and square waves when
Points per Cycle multiplied
by Cycles exceeds the
maximum memory limit of the
instrument.

Enter values for points
per cycle and cycle such
it does not exceed the
maximum memory limit of
the instrument. For more
details, refer to the instrument
specifications.

1209

Invalid cycles, points per
cycle less than 2.

This message appears if
number of points per cycle
for the sine and triangle
waveforms is less than 2.

Increase the number of
points per cycle. For sine and
triangle waves, the points
per cycle should be greater
than two to generate a good
waveform.

1210

The number of points per
cycle is less than 10, change
the points per cycle

This message appears if
number of points per cycle for
the square and pulse waves
is less than 10.

Increase the number of
points per cycle. For square
and pulse waves, the points
per cycle should be greater
than two to generate a good
waveform.

1211

Points per cycle = Total
Points/Cycle
Number of points per cycle
less than 10. Change cycles
or total points

This message appears when
points per cycle is less
than 10 for exponential rise,
exponential decay, and Sinc
waveforms.

Change the cycle or total
points such that points per
cycle is greater than 10.

1212

Points per cycle =
TotalPoints/Cycles.
Number of points per cycle
less than 10. Change cycles
or total points (Sampling Rate
* Delay)

This message appears when
points per cycle is less than
10 for Lorentz waveform.

Increase the points per
cycle change cycle or total
points (Total points = Delay
* Sampling Rate). Change
the total points by changing
sampling rate or delay.
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1213

The value exceeds the total
number of points

This message appears when
the value entered for Rise
Time or Fall Time for Square
or Pulse waveform exceeds
the total number of points.

The maximum value that can
be entered for Rise Time or
Fall Time should be less the
than total number of points.
Rise Time plus Fall Time
should not cross the Total
number of points.

1214

Rise Time + Fall Time of the
waveform should be less than
the total number of points

This message appears
when Rise Time + Fall Time
exceeds the total number of
points.

Enter values for Rise Time
and Fall Time, such that Rise
Time plus Fall Time do not
cross the total number of
points.

1215

Number of zero crossings
greater than the total number
of points

This message appears when
the number of zero crossings
entered for Sinc exceeds the
total number of points.

Enter number of zero
crossings that lies within the
total number of points.

1216

Total Points = Duration *
Sampling Rate.
Total points exceeds the
maximum memory limit of the
instrument

This message appears for
the Sweep waveform when
the total points (Duration
*Sampling Rate) exceeds the
maximum memory limit of the
instrument.

Change the sampling rate or
the duration so that the total
points is within the instrument
specification.

1217

Total Points = Delay *
Sampling Rate
Total points exceeds the
maximum memory limit of the
instrument

This message appears for
Lorentz waveform when
the total points (Delay *
Sampling Rate) exceeds the
maximum memory limit of the
instrument.

Change the sampling rate
or Delay so that the total
points is within the instrument
specification.

1218

Total Points = Sampling Rate
/Tone Spacing
Total points exceeds the
maximum memory limit of the
instrument

This message appears for
Multi Tone waveform when
the total points (Delay *
Sampling Rate) exceeds the
maximum memory limit of the
instrument.

Change the sampling rate or
tone spacing so that the total
points is within the instrument
specification.

1219

Total Points = Duration *
Sampling Rate
Change duration or sampling
rate

This message appears if total
points is zero for sweep.

Change the duration or
sampling rate so that total
points is greater than zero.

1220

Total Points = Delay *
Sampling Rate
Change delay or sampling
rate

This message appears if total
points is zero for the Lorentz
waveform.

Change the Delay or
sampling rate so that total
points is greater than zero.

1221

Total Points = Sampling
Rate/Tone Spacing
Change sampling rate or tone
spacing

This message appears if total
points is zero for multi-tone
waveform.

Change the Tone Spacing or
sampling rate such that total
points is greater than zero.
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1222

Total number of points
exceeds the maximum
memory limit of the instrument

This message appears
when total number of points
exceeds the maximum
memory limit of the instrument
selected.

Enter total number of points
such that it does not exceed
the memory limit of the
instrument selected.
For more details refer to the
instrument specification.

1223

Total Points not a multiple
of 4. Change frequency or
cycles.

This message appears for
the sine, triangle, square,
and pulse waveforms (in
the basic mode) when total
points is not a multiple of four
and the instrument selected
is AWG710, AWG520, and
AWG510.

For the sine, triangle, square,
and pulse waveforms,
total points = points per cycle
* cycles. When total points is
not a multiple of four, change
the frequency so that points
per cycle changes or use the
advanced option to change
points per cycle directly.
You can also change the
number of cycles.

1224

Total Points not a multiple of
4.

This message appears
when the total number of
points is not a multiple of
4 for waveforms other than
sine, triangle, square, and
pulse waveforms, when
the selected instrument
is AWG710, AWG710B,
AWG615, AWG510, and
AWG520.

Ensure that the total points
are a multiple of 4.

1225

Total Points not a multiple
of 8. Change frequency or
cycles.

This message appears for
the sine, triangle, square, and
pulse waveforms (in the basic
mode) when the total points
is not a multiple of eight and
the instrument is AWG2021.

For the sine, triangle, square,
and pulse waveforms,
total points = points per cycle
* cycles
When the total points is not
a multiple of eight, change
the frequency so that points
per cycle changes or use the
advanced option to change
points per cycle directly.
You can also change the
number of cycles.

1226

Total Points not a multiple of
8.

This message appears
when the total number of
points is not a multiple of
8 for waveforms other than
sine, triangle, square, and
pulse waveforms, when
the selected instrument is
AWG2021, and AWG610.

Ensure that the total points
are a multiple of 8.
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1227

Delay + Pulse width + Rise
Time + Fall Time should be
less than total points

This message appears for
pulse if the value given for
delay, pulse width, rise time
and fall time added together
exceeds or is equal to the
total points.

Enter values so that with the
given parameters when the
waveform is generated it is
within the total points.

1228

Delay + Pulse Width exceeds
total number of points

This message appears for
pulse waveform if the sum
of delay and pulse width
exceeds total points.

Enter Delay and Pulse width
so that it does not exceed
total points.

1229

Rise Time + Fall Time + Duty
Cycle should be less than
total points

This message appears for
the square waveform when
the sum of rise time, fall time,
and duty cycle exceeds or is
equal to the total points.

Ensure that the sum of rise
time, fall time, and duty cycle
does not exceed total points.

1230

Value range 0 – 360 degree

This message appears when
value entered for the phase
in not within the range.

For phase, range is between
0–360.
Enter a value within this
range.

1231

Half Width exceeds Delay

For the Lorentz waveform,
Half Width should not exceed
delay.

For the Lorentz waveform,
enter a value for Half Width
so that it does not exceed the
delay.

1232

Sampling rate should be at
least twice than that of the
highest frequency component

This message appears
when the end frequency
(the highest frequency
component) entered for
the sweep and multi-tone
waveforms is less than the
sampling rate.

Enter end frequency so that
the sampling rate is at least
twice that of the highest
frequency component.

1233

Tone Spacing is greater
than difference between the
frequencies

This message appears for
multi-tone if the tone spacing
is greater than the difference
between the start and end
frequency.

Enter value such that
tone spacing is within the
difference between start and
end frequency.

1234

Total Range = Total
Points/Sampling Rate.
Duration greater than total
range

This message appears for the
sweep waveform when the
duration entered is greater
than the total range.

Change duration so that
it is within the total range.
Total range = Total Points /
Sampling rate

1235

End frequency should be
greater than start frequency

This message appears if
the end frequency is greater
than start frequency for
the multi-tone and sweep
waveforms.

End frequency should be
always greater than start
frequency.
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1236

Value range 1 – 99.9

This message appears for the
square waveform when the
duty cycle is not within the
limits.

Enter a value within the range
specified.

1237

Cycles exceeds the maximum
limit of the instrument

This message appears when
the number of cycles exceeds
half the maximum memory
limit.

So the maximum cycles than
can be entered is half the
maximum memory limit.

1238

Invalid amplitude: change
voltage entered

This message appears when
you enter an invalid voltage
in the Max/Min mode.

There should at least two
points per cycle. Enter a
voltage value that lies within
the voltage range supported
by the instrument.

1239

Total Points = Cycles * Points
per cycle .Change cycles or
points per cycle

This error message appears
for the sine, triangle, square,
and pulse waveforms if the
total points is zero.

Change points per cycle or
cycles to change the total
points.

1240

Frequency range supported
is x mHz – x MHz

This error message
appears for the AFG2000
and AFG3000 series of
instruments when the value
entered is not within the
instrument range.

Enter a value that lies
within the frequency range
supported by the instrument.
For more details, refer to the
Instrument Specifications.

1241

Total number of points: XX.
Minimum number of points
required is XXX

This error message appears
when the total points entered
is less than the minimum
number of points required by
the instrument.

Increase the total points such
that it meets the minimum
number of points supported
by the instrument.

1242

Total Points less than the
minimum points required

This message appears when
the total points is less than
minimum points required and
the user selects OK button.

Make sure total points
is within the instruments
specification. For any
instrument selected the
Min and Max memory limit
is mentioned in the Notes
section of the dialog box.

1243

Unable to generate this
waveform

This message appears when
the parameters given to
generate the waveform is
not valid and the user has
selected OK button.

The parameters given to
generate the waveform
should be within the selected
the instrument specification.
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1244

Total Points not a multiple
of 4. Change either the
frequency, sampling rate
points per cycle, or cycles.

This message appears for
the sine, triangle, square,
and pulse waveforms (in the
advanced mode) when total
points is not a multiple of four
and the instrument selected
is AWG710, AWG520, and
AWG510.

For the sine, triangle, square,
and pulse waveforms,
total points = points per cycle
* cycles.
When total points is not a
multiple of four, change the
frequency so that points per
cycle changes or change
points per cycle and sampling
rate directly. You can also
change the number of cycles.

1245

Total Points not a multiple
of 8. Change either the
frequency, sampling rate
points per cycle, or cycles.

This message appears for
the sine, triangle, square, and
pulse waveforms in advanced
mode when total points is
not a multiple of eight and
the instrument selected is
AWG2021.

For the sine, triangle, square,
and pulse waveforms,
total points = points per cycle
* cycles.
When total points is not a
multiple of eight, change the
frequency so that points per
cycle changes or change
points per cycle, sampling
rate directly. You can also
change the number of cycles.

1246

Invalid Amplitude Voltage
range supported is Vamp ≤
2(|Vmax|-|Voffset|)

This error message appears
for the AFG310 and AFG320
when the amplitude entered
is not within the range of the
instrument.

The amplitude supported by
the instrument is
Vamp ≤ 2(|Vmax|–|Voffset|)
Where Vmax is the maximum
output voltage (Vmax) that
the instrument can produce
(±5 V) when terminated with
50 ohm.
For example, if offset is zero
then amplitude is 10 = 2(5– 0)

1247

Invalid Offset. Range
supported is – 0.75 V to
+0.75 V

This error message appears
for the AFG310 and AFG320
when the offset entered is
not within the range of the
instrument.

The valid range for the offset
voltage setting is in the range
± 0.75 V when the amplitude
setting is 500 mVp-p or
smaller.
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1248

Invalid Offset. Range
supported is |Voffset| ≤
|Vmax| - Vamp/2

This error message appears
for the AFG310 and AFG320
when the offset entered is
not within the range of the
instrument.

The valid range for the offset
voltage setting is restricted
according to the following
formula when the amplitude
setting is 505 mVp-p or
larger, for a Vmax
value of ±5 V.
|Voffset| ≤ |Vmax|- Vamp/2
Example: if amplitude is 10
the offset is
0 = 5 – 10/2.

1249

Total Points = Delay *
Sampling Rate. For given
delay total points exceeds
maximum memory limit

This error message appears
when the value entered for
delay multiplied by sampling
rate exceeds the maximum
memory limit of the instrument

For Lorentz wave,
Total points = Delay *
sampling rate.
The value entered for delay
multiplied by sampling rate
should not exceed maximum
memory limit of the selected
instrument.

1250

Connected instrument and
selected instrument do not
match. Do you want to
continue?

This message appears
in standard waveform
and equation editor when
connected instrument and
selected instrument do not
match.

The connected instrument
and the selected instrument
should match for a successful
transfer. If they differ, a
warning message appears.
You can select Yes to
proceed, however, depending
on the connected instrument
memory size and step size
the transfer may fail.

xxx

Error Messages and Warnings II
Error code

Error message

Description

Possible solution

1301

Cursors 1 and 2 are in the
same location

This message appears If
both cursors 1 and 2 are at
the same point.

Change the cursor
locations.

1302

No waveform data in
clipboard

This message appears
when nothing has been
copied to the clipboard.

Copy a waveform, or part
of it, to the clipboard.

Waveform Math
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Import from Oscilloscope
1401

Cannot access the folder

You do not have enough
permission to see the
contents of this folder.

Go to folder properties
on Windows Explorer and
change the permissions to
have enough permission.

1402

A file with this name already
exists in this folder. Do you
want to overwrite?

A file with the same name
is found in the currently
selected folder.

Rename the file in the
selected folder or select a
different folder.

1403

Switch on Ref# on the
oscilloscope

The reference memory
on the oscilloscope is
switched off.

Switch on the reference
memory on the
oscilloscope using front
panel buttons.

1404

FFT Waveforms cannot be
imported. Select a Dual
Math waveform

FFT waveforms are
frequency domain
waveforms. This version
of ArbExpress does
not support this type of
waveforms.

NA

1405

Disconnect failed. Refresh
Visa resource list and try to
reconnect

Communication with
the oscilloscope is lost.
Therefore all commands
including 'Disconnect’ fail.

Check the physical
connection, refresh the
Visa resource and try to
reconnect.

1406

Connect failed. Refresh
Visa resource list, check if
the instrument is properly
connected and try again.

This message can appear
for several reasons.

Do one of the following:

Physical connection
between PC and
oscilloscope is
improper or does not
exist.
The connected
oscilloscope is not
in the Visa resource
list.
The oscilloscope is not
in the Talk/Listen mode
(If it is connected using
GPIB cable).

Check the physical
connection to ensure
that everything is fine.
Refresh VisaRM if
and Instrument list
in the Oscilloscope
Acquisition dialog.
Using oscilloscope
front panel, select
Talk/Listen mode.
Refresh Visa resource
and refresh the
Instrument list in
the Oscilloscope
Acquisition dialog.

1407

Visa not found on this PC.

Visa was not found on the
PC.

Install TekVisa.

1408

Error finding Visa resources.

The application cannot find
Visa resources.

Refresh the VisaRM
and then refresh the
ArbExpress instrument list.

1409

An oscilloscope is already
connected. Disconnect
it before connecting a
different oscilloscope.

You are trying to connect
to a second oscilloscope
while you are already
connected to one.

Disconnect the
oscilloscope currently
connected, select the other
and try to connect.
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1410

No resources are found.
Refresh TekVisa Resource
manager and click Refresh
button again.

ArbExpress did not find
any oscilloscopes that can
be connected. Therefore,
the Scope List is empty.

Refresh TekVisa resource
manager and wait until
the TekVisa Resource
Manager dialog shows
"Ready" state. Then, click
the Refresh button on
Import From Oscilloscope
dialog.

1411

No Math equation is set on
the Oscilloscope.

You have not set a
math equation for this
math source on the
Oscilloscope.

Set a math equation that
generates a time domain
signal for this math source.

Could not connect to the
instrument. Check:

When the instrument is
connected to the PC via
the GPIB or LAN, and
the user fails to connect
because

File Transfer and Control
1601

the GPIB connection
the instrument mode
the IP Address

The GPIB /LAN cable
is not connected
properly.
The instrument may
be switched off.
The instrument is not
in GPIB/LAN mode.
The IP Address is
incorrect for the LAN
connection.
VISA resource list is
not updated.

Verify the GPIB
(Talk/Listen)/LAN
connection. Ensure
there is no loose
connection.
Refresh the Visa
resource list.
Check that the
instrument is
powered on and is
in GPIB/Network mode.
For LAN connection,
ping from the
instrument to the PC
and vice versa.
Verify that instrument
is ready for
communication.
Try reconnecting to the
instrument.
Connect only one
PC connected to an
instrument.

1602

182

Error getting instrument's
file list, folder list.

The instrument is
successfully connected
via the GPIB bus but the
user cannot get instrument
folder/file list. This may
happen if the connection to
the instrument is lost.

Verify that instrument
is ready for
communication.
Try reconnecting to the
instrument.
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File Transfer and Control
1603

Visa32.dll not found.
Install TekVisa.

This message appears
when you try to access the
File Transfer dialog.
TekVisa files not found
in Windows' system
folder (system32
or system folder
depending on the
Windows Operating
System).
TekVisa files may be
corrupt.

1604

Error finding VISA
resources
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The user has set up the
physical connection to this
instrument via GPIB bus
but is unable to get the
instrument resource in the
instrument list.

Do the following:
1. Ensure that the
Windows Operating
System is installed on
the PC.
2. Uninstall TekVisa
if already installed.
Reinstall TekVisa.
3. Ensure that the
Tekvisa32.dll is placed
in the Windows system
folder (system or
system32 folder).
Start> Programs>TekVISA>TekVISA
Configuration. Refresh the
TekVisa resource list.
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File Transfer and Control
1605

Unable to write to the
instrument

The user tried to transfer
a file from the PC to the
instrument. The transfer
failed due to:
lost instrument
connection
insufficient hard disk
space
the file that is being
transferred is opened
by another application
The write operation failed
due to:
Large file size. The
edit memory can have
a maximum of 16000
points
Incompatible file
format

Check instrument
connection
Check hard disk space
Check whether the
file is being used by
another application
Check whether the
instrument file size
and file format are
compatible
Ensure that the file
being transferred
from the PC to the
AWG2000 series
instrument is
compatible with the
AWG2000 file format
or NVRam has enough
memory.

No communication
between the application
and the instrument.
This message also
appears while transferring
a file from the PC to
an AWG2000 series
instrument whose file
format is incompatible with
the AWG2000 file format or
NVRam may be full.

184

1606

Failed to get the
instrument's default
directory

You tried to transfer a
file from the instrument’s
memory to the PC. The
application failed to get
the instrument’s current
default directory (MAIN)
because the connection
to the instrument was lost
during file transfer.

Verify whether the
instrument is connected
and is ready to
communicate.

1607

A file with this name already
exists in this folder. Do you
want to overwrite?

You tried to transfer a file to
the destination folder in a
PC or an instrument but a
file with the same file name
exists in this folder.

Rename the existing file
and then transfer the file
again. Or select Yes to
overwrite the existing file.
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File Transfer and Control
1608

An instrument is already
connected. Disconnect
it to connect to a new
instrument.

The software allows one
connection at a time
— either through GPIB
or LAN. The user tried
to connect to a second
instrument.

Disconnect the connected
instrument and connect a
new instrument.

1609

This file is empty. Cannot
transfer this file.

You tried to transfer an
empty file from the PC
to the instrument or vice
versa.

NA

1610

Unable to load the file.
Check the instrument
connection.

You tried to load a file by
pressing the Load button
in the instrument control
pane. The application
failed to load the file
because:

Do one of the following:

The connection to the
Instrument is lost.
The file format is
invalid.

Check the instrument
connection and
whether the
instrument is ready
to communicate
Check if the file is a
.wfm, .pat, or .set file.
Check if the file is
present.

1611

No waveform/sequence file
is loaded.

This message appears
when the waveform or
sequence file is not loaded
in the instrument’s internal
memory, and user presses
Run/Stop button in the
instrument control pane.
This also appears when
the user tries to enable the
AWG channel by selecting
the On/Off Channel in the
instrument control pane.
This is applicable only to
AWGs.

Load a waveform into
the internal memory of
the connected AWG
instrument, then perform
Run/Stop.

1612

Enter a value.

This message appears
when no value has been
entered in a field.

Enter a valid value for the
field that is supported by
the application.
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File Transfer and Control
1613

Failed to write to the PC

This message appears
when the user tries to
transfer the remote file from
the connected instrument
to the PC file list. The
application fails to do so
because:
the instrument is not
ready.

Check whether
The instrument
connection is alive.
The instrument is
ready.
The destination folder
exists.

the destination folder
in the PC has a file
with same name that
is being accessed by
another application.
the destination folder
in the PC may not exist.
Instrument connection
is lost.
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1614

Invalid amplitude. Voltage
range supported is xx – xx.

The value entered is
not within the instrument
range.

Enter a value that
is supported by the
instrument.

1615

Invalid offset. Voltage range
supported is xx – xx.

The value entered is
not within the instrument
range.

Enter a value that
is supported by the
instrument.

1616

Invalid marker voltage.
Voltage range supported is
xx – xx.

The value entered is
not within the instrument
range.

Enter a value that
is supported by the
instrument.

1617

Invalid clock. Frequency
range supported is xx – xx.

The value entered is
not within the instrument
range.

Enter a value that
is supported by the
instrument.

1618

Invalid phase. Range
supported is xx – xx.

The value entered is
not within the instrument
range.

Enter a value that
is supported by the
instrument.

1619

Invalid output frequency.
Frequency range supported
is xx – xx.

The value entered is
not within the instrument
range.

Enter a value that
is supported by the
instrument.

1620

Invalid EMEM size. Point
range supported is xx – xx.

The value entered is
not within the instrument
range.

Enter a value that
is supported by the
instrument.
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File Transfer and Control
1621

Insert a floppy.

This is caused when
you select "DISK" on the
Instrument Folder/PC
folder.

Ensure that the floppy
disk is inserted in
the disk drive and is
working.

Floppy drive may not
have a disk.

Instrument/PC floppy
drive is working.

Floppy drive or the
floppy disk may be bad.
1622

Are you sure you want to
overwrite EMEM<n> with
<PC file name>?

This message appears
when user transfers file
from PC to the Edit memory
of the instrument (AFG).

NA

1623

Are you sure you want to
overwrite USER<n> with
EMEM<n>?

This message appears
when user transfers file
from Edit memory to
the User memory of the
instrument (AFG).

NA

1624

Are you sure you want to
overwrite USER<n> with
<PC file name>?"

This message appears
when user transfers file
from PC to the User<n>
memory of the instrument
(AFG).

NA

1625

No Arb is connected. Do
you want to connect now?

This message appears if
the "Send To Arb" button is
pressed in the application
when no instrument is
connected. Pressing Yes
invokes the File Transfer
and Control dialog.

NA

1626

Unable to load the file,
format not supported.

This message is displayed
when the user tries to load
a .seq file in File Transfer
and Instrument Control
dialog box.

NA

xxx
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Error Messages and Warnings III
Error code

Error message

Description

Possible solution

1701

No resources are found.
Refresh TekVisa Resource
manager and click Refresh
button again.

This error message
appears when the user
tries to refresh or select
“Select Instrument” page
and when there are no
instruments listed after the
scan.

Refresh TekVisa.

1702

Connect failed.
Refresh Visa resource list,
check if the instrument is
properly connected and try
again.

This error message
appears when the user
tries to connect to a
particular instrument and
connection fails.

Refresh TekVisa.

1703

Switch on Ref# on the
oscilloscope.

This error occurs when the
user tries to acquire from
Reference memory and
reference is turned off.

Turn on the Reference
memory.

1704

No Math equation is set on
the Oscilloscope.

This error occurs when the
user tries to acquire from
Math data source when the
equation is null.

Check whether the math
equation is valid.

1705

No data points available.
Please change the settings
and acquire again.

This error occurs when the
user tries to acquire data
from a source and when no
points are available.

Change the acquisition
settings and acquire again.

1706

Frequency Domain
Waveforms cannot be
imported. Select a Dual
Math waveform.

This error appears when
the user tries to acquire
waveform in frequency
domain. For this error
to happen the data
source should be a MATH
waveform.

Select a Dual Math
waveform.

1707

Number of points match
the instrument - "Selected
Instrument Name."

This message appears
when the user selects
Validate button in the
“Extract Segment" page
and the number of
points should match the
instrument selected.

NA

1708

A file already exists with
this name in this folder. Do
you want to overwrite?

This message appears
when the file is about to be
overwritten.

NA

Scope Acquisition Wizard
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Point Draw
1801

Only 100 PD Points are
allowed.

This message appears
when PD points exceed
100.

Remove the existing PD
point and then add new PD
point.

1901

Enter units in right place.

This message appears
when units are not entered
properly for the time value.
Time value can be entered
when Time button is
selected under XY group.
The user will not be able to
click the next cell until the
right value is entered.

Enter the units
appropriately.

1902

Please enter only digits.

This message appears
when input is not correct
for the time value. Time
value can be entered when
Time button is selected
under XY group. The user
will not be able to click
the next cell until the right
value is entered.

Enter the time value
correctly.

1903

Please enter the units
correctly.

This message appears
when units are not entered
properly for the time value.
Time value can be entered
when Time button is
selected under XY group.
The user will not be able to
click the next cell until the
units are entered correctly.

Enter the units
appropriately.

1904

Please enter correct double
value.

This message appears
when the input value for
Voltage is not correct. The
user will not be able to click
the next cell until the right
voltage value is entered.

Enter the correct voltage
value.

1905

The time value entered
should be within maximum
time range.

The maximum time
value will depend on
the waveform length. Time
value can be entered when
Time button is selected
under XY group. The user
will not be able to click
the next cell until the right
voltage value is entered.

The time value entered
should be within the range.
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Point Draw
1906

Sampling Index should be
within Maximum Sampling
value.

This message appears
when the point value
exceeds the waveform
length. Point mode can be
selecting the Points under
the XY group.

Enter the point within the
range.

1907

Value of the Sampling Index
should be unique.

The sampling index should
always be a unique value.

Enter unique sampling
index.

1908

There should be minimum
time difference of at least
MinimumTimeDifference.

This message appears
when time values
in two cells have a
difference of less than the
MinimumTimeDifference.
Time value can be entered
when Time button is
selected under XY group.

Entering the time
value in the cell such
that they have the
MinimumTimeDifference
between them.

xxx

Default Settings
Parameter

Selection

Default Setting

Edit> Paste

Paste at active cursor Prepend to the
waveform Append to the waveform
Replace between cursors.

Paste at active cursor.

Don't show this again and always
paste at active cursor.

Not selected by default.

Shift/Rotate

Point Draw Table

Display> Cursor Position

190

Points

10

Amplitude

.5 V

Vertical Segment: Shift Up, Shift
Down

Shift Up

Horizontal Segment: Rotate Right,
Rotate Left, Shift Left, Shift Right

Rotate Right

Interpolation: Linear, Smooth,
Staircase

Smooth

X Value: Time, Points

Depends on the X axis units of the
active wavebook or window

Points
Seconds

The selection is based on the
waveform. If the X-axis is Time, the
setting is Seconds.

Cursor 1

Reflects the current location, in points
or seconds, of Cursor 1

Cursor 2

Reflects the current location, in points
or seconds, of Cursor 2
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Parameter

Selection

Default Setting

Display> Properties

Waveform Name

Displays the name of the selected
waveform

Enable Graticule

Enabled by default

Waveform Properties

Displays the currently selected
waveform color, line style, and line
width

Marker Color

Displays the marker colors of Marker
1 and Marker 2

Background Color

Displays the background color of the
selected waveform

Cursor Color

Displays the cursor colors of Cursor 1
and Cursor 2

Instrument

AWG710

Sampling Rate

1000000

Number of Points

1000

Total Range

0.001

Equation

#Change the range according to you
settings
range (0,1ms)
#Your equation goes here sin(w)

Instrument

Displays the currently selected
instrument in the waveform

Sampling Rate

Displays the sampling rate of the
selected waveform

Resampling waveform using

Shows the number of points used for
resampling

Resampling method: Sinc, Linear,
Add points with zero amplitude

Sinc

Normalize waveform before saving
the file

Selected by default

New Window/Existing Window

New Window

Wave Book Selection

Displays the currently selected wave
book

Change the incoming waveform's
sampling rate. Change the existing
waveform's sampling rate

Change the incoming waveform
sampling rate

Save .set file along with the .wfm and
.pat files.
Show paste option before pasting.
Always enable instrument's outputs
after transferring the waveform.

All the options are selected
When the channel is turned on or off,
the complementary channels are also
turned on or off

Equation Editor

Waveform> Properties> Active
Waveform tab

Waveform> Properties>
Multi-Waveform Properties tab

Waveform> Properties> Preferences
tab
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Parameter

Selection

Default Setting

Math> Waveform Math

Math Source
Waveform Library — Sine, Square,
Triangle, DC, Noise, Pulse,
Exponential Rise, Exponential
Decay
Scalar
Copy from Clipboard

Waveform Library Amplitude 2.0,
Cycles 1, Phase 0, Duty Cycle 50,
Pulse Width 50, Damp Factor 50
Amplitude 1.0

Operation
Add
Subtract
Multiply
Divide

Add

Only Between Cursors

Always selected

xxx

Default Settings Cont...
This table lists the default settings for the standard waveforms.
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Parameter

Selection

Default Setting

Waveform> Sine

Amplitude Peak to peak

2

Points

1000

Vertical offset

0

Cycles

10

Frequency

Maximum sampling rate / Points per
cycle(100)
Maximum sampling rate / Points per
cycle(128) (AWG7000 series)

Phase

0

Sampling Rate

Maximum sampling rate supported by
the instrument

Points per cycle

100
128 (AWG7000 series)
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Parameter

Selection

Default Setting

Waveform> Square

Amplitude Peak to peak

2

Points

1000

Vertical offset

0

Cycles

10

Frequency

Maximum sampling rate / Points per
cycle(100)
Maximum sampling rate / Points per
cycle(128) (AWG7000 series)

Sampling Rate

Maximum sampling rate supported by
the instrument

Points per cycle

100
128 (AWG7000 series)

Phase

0

Duty Cycle

50

Rise Time / Fall Time

0

Rise Time / Fall Time Type

Ramp

Amplitude Peak to peak

2

Points

1000

Vertical offset

0

Cycles

10

Frequency

Maximum sampling rate / Points per
cycle(100) Maximum sampling rate /
Points per cycle(128) (AWG7000 series)

Phase

0

Sampling Rate

Maximum sampling rate supported by
the instrument

Points per cycle

1000
128 (AWG7000 series)

Waveform> Triangle
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Selection

Default Setting

Waveform> Pulse

Amplitude Peak to peak

2

Vertical offset

0

Cycles

10

Frequency

Maximum sampling rate / Points per
cycle(100) Maximum sampling rate /
Points per cycle(128) (AWG7000 series)

Sampling Rate

Maximum sampling rate supported by
the instrument

Points per cycle

100
128 (AWG7000/ series)

Delay

0

Pulse Width

10

Rise Time / Fall Time

0

Rise Time / Fall Time Type

Ramp

Transition Pulse Direction

Positive

Amplitude Peak to peak

2

Points

1000

Vertical offset

0

Sampling Rate

Maximum sampling rate supported by
the instrument

Amplitude Peak to peak

2

Points

1000

Vertical offset

0

Cycles

1

Phase

0

Sampling Rate

Maximum sampling rate supported by
the instrument

Damp factor

5

Amplitude Peak to peak

2

Points

1000

Vertical offset

0

Cycles

1

Phase

0

Sampling Rate

Maximum sampling rate supported by
the instrument

Damp factor

5

Waveform> DC

Waveform> Exponential Rise

Waveform> Exponential Decay
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Parameter

Selection

Default Setting

Waveform> Noise

Amplitude Peak to peak

2

Points

1000

Vertical offset

0

Noise Type

Gaussian White Noise

Sampling Rate

Maximum sampling rate supported by
the instrument

Amplitude Peak to peak

2

Points

1000

Vertical offset

0

Cycles

1

Phase

0

Number of zero crossings

10

Sampling Rate

Maximum sampling rate supported by
the instrument

Amplitude Peak to peak

1000

Vertical offset

0

Points

Duration * Sampling Rate

Start frequency

1M

End frequency

5M

Time Duration

1μ (AWG710 – AWG2021,
AWG5000 series, and AWG7000 series)
10μ (AWG2005 – AFG320)
1000/Maximum sampling rate
(AFG2000 and AFG3000 series)

Sampling Rate

Maximum sampling rate supported by
the instrument. The default sampling
rate for AWG2021 is 248.
The default sampling rate for
AWG7000 series is 3.2 G.

Waveform> Sinc

Waveform> Sweep
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Parameter

Selection

Default Setting

Waveform> Multi-Tone

Amplitude Peak to peak

2

Vertical offset

0

Points

SamplingRate/ToneSpacing

Start frequency

1M (AWG710 – AWG2021,
AWG5000 series, AWG7000 series,
AFG2000, and AFG3000 series) 1K
(AWG2005 – AFG320)

End Frequency

5M (AWG710 – AWG2021,
AWG5000 series, AWG7000 series,
AFG2000, and AFG3000 series) 5K
(AWG2005 – AFG320)

Tone Spacing

1M (AWG710 – AWG2021,
AWG5000 series, and AWG7000 series)
1K (AWG2005 – AFG320)
1000/Maximum sampling rate
(AFG2000 and AFG3000 series)

Sampling Rate

Maximum sampling rate supported by
the instrument. The default sampling
rate for AWG2021 is 248.
The default sampling rate for
AWG7000 series is 3.2 G.
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Parameter

Selection

Default Setting

Waveform> Lorentz

Amplitude Peak to peak

2

Vertical offset

0

Points

Delay * Sampling Rate

Cycles

1

Phase

0

Delay

1μ (AWG710 – AWG2021, AWG5000,
and AWG7000) 10μ (AWG2005 –
AFG320) 1000/Maximum sampling rate
* cycles (AFG2000 and AFG3000 series)

Half Width

0.3 μs

Sampling Rate

Maximum sampling rate supported by
the instrument. The default sampling
rate for AWG2021 is 248.
The default sampling rate for
AWG7000 series is 3.2 G.

Manually change the Horizontal settings
to reach minimum number of points
Add zeros to achieve minimum number
of points
Add last vector to achieve minimum
number of points

Manually change the Horizontal settings
to reach minimum number of points

Waveform Padding Options

xxx

Valid Parameter Ranges
The table below lists the filters, amplitudes, offsets, and levels supported by the AWGs and AFGs.
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The table below lists the output styles, number of channels, memory lengths, and marker out levels
supported by the AWGs and AFGs.

198
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The table below lists the output types and number of channels supported by the AFG2000 series of
instruments.

The table below lists the output styles and the number of channels supported by the AFG3xxx series of
instruments.

ArbExpress AXW100 Printable Help

199

Reference

Valid Parameter Ranges

The table below lists the output styles and the number of channels supported by the MDO3000 series of
oscilloscope. The oscilloscope AFG is a 50 Ω source. The levels described in this table apply when the
output load impedance is set to 50 Ω.

The table below lists the output styles and the number of channels supported by the AWG7xxx and
AWG5xxx series of instruments.
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Equation Editor Reference I
Use the equation editor to edit files with the extension of .equ, .eqa, or *.*. The default selection is *.eqa.
Equation file data takes the form of mathematical equations. An equation program file can have up to 100
lines. An equation file is compiled to create a waveform file and to output the waveform.

The component menu contains the items used to set the time range as well as functions, operators, variables,
constants, syntax items and characters. You can use these items to create equations and enter comments.
Component

Symbol

Meaning

Example

Syntax Items

()

These are parentheses —
(and) — for specifying the
order of operations. Each
opening (left) parenthesis
must be paired with a closing
(right) parenthesis. When
there are two arguments – for
example, range, max, min –
they are separated with a ,
(comma).

NA

Variables. Here are the
variables that can be used in
an equation.

t
x
v

Time from the head of that
range() statement
Variable taking on a value
from 0.0 to 1.0 within that
range ( )
Variable showing the current
value of the waveform data at
that position statement

NA
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Component

Symbol

Meaning

Example

Operators

+, –, *, /

These add, subtract, multiply,
or divide the components.
The priorities are the same as
usual for these four operators
– * and / have priority over +
and –.

NA

^

Expresses exponents. Only
integers can be raised to a
higher power. ^ has the same
priority as * and /. Therefore,
parentheses are required to
give priority to multiplication.

Example: pi * (2^3) * x where
2^3 = two raised to the third
power.

Comment

#

Comments are preceded by
a number sign (#). When a
number sign is entered, all
characters after that until the
end of the line are treated as
a comment. All of the items in
the component menu can be
used in a comment.

NA

Characters

a–z, %, $, &, @, A, _

The characters available in
the component menu are the
letters of the alphabet (a–z)
and several symbols (%, $, &,
@, A and _ ). These are used
in comments.

NA

Other items

pi, e, k, =,

NA
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Symbol

Meaning

Example

pi

The circumferential ratio.

NA

e

Exponent (for an implied
10). The range for numbers
expressed in this scientific
notation is from |5.9e–39| to
|3.4e38|.

Examples: 1e6=1,000,000,
1e–3=0.001

k

The k0–k9 can be specified;
these are constants that
may be used in equations.
Specifying a new value for
the same k# replaces the old
value with the new one. If no
constant
is defined for k, this value will
be automatically set to 0.

NA

=

Equals sign. = is used with k
constants.

Example: k0=2*pi

Ends the line for the range or
equation; inserting a return

NA

(
) in the middle of the
line partitions it.
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Component

Symbol

Meaning

Example

Functions

sin(, cos(

The arguments for these
trigonometric functions are in
radians.

Example:
range(0,100 s)cos(2*pi*x)
Example:
range(0,100 s)sin(2*pi*1e4*t)

exp(, log(, ln(

Exponential function,
common log function, natural
log function. The log and ln
arguments must be positive.

Example: range(0,50 _s)
1–exp(–5*x)
range(50 _s,100 _s)
exp(–5*x)
Example: range(0,100 _s)
log(10*(x+0.1))
Example: range(0,100 _s)
ln(2*(x+0.2))

sqrt(

The square root; the
argument must be a positive
value.

Example: range(0,100 _s)
sqrt(sin(pi*x))

abs(

The absolute value.

Example: range(0,100 _s)
abs(sin(2*pi*x))

int(

Truncates the fraction to
obtain the integer.

Example: range(0,100 _s)
int(5*sin(2*pi*x))/5

round(

Rounds off the fraction to
obtain the integer.

Example: range(0,100 _s)
round(5*sin(2*pi*x))/5

norm(

Normalizes the range
specified with range() and
scales the amplitude values
so that the maximum absolute
value is 1.0 (that is, a value
of +1.0 or –1.0). The norm()
statement comprises an
entire line.

Example: range(0,100 _s)
sin(2*pi*x)+rnd()/10
norm()

max(
min(

Takes the larger of two values.
Takes the smaller of two
values.

Example: range(0,100 _s)
sin(2*pi*x) range(0,50 _s)
min(v,0.5) range(50 _s,100
_s) max(v,–0.5)

range(

The equation must specify
range(0,1ms) Time range
the time domain. If the
sin(2*pi*x) Equation
time domain is not defined,
this is an error. The time
domain is specified with
range().
When making a new equation
file, range(0, is input in the
first line of equation. Next, the
time is specified. This setting
is valid until the next range(
item is specified. With the
first range() specification, any
number of lines of equation
can be input. Text written
after the range() on the same
line is invalid. Here is the
ArbExpress AXW100 Printable Help
format for the range( item.
range( Equation starting time,
Equation ending time )
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Equation Editor Reference II
Use the equation editor Units menu to specify the units for the parameters or variables used in the equation.

The following table lists the units that you can use and their descriptions.
Unit
m

Meaning
milli (e– 3 )

u

micro (e– 6 )

n

nano (e– 9 )

p

pico (e– 12 )

s

second

,

comma separator

K

Kilo (e3)

M

Mega (e6)

xxx

Use the selection menu to confirm, backspace, or clear the equation.

The following table lists the units that you can use and their descriptions.
Button

Meaning

Enter

Confirms the selection and moves to the next line of the
equation

BKSP

Backspaces over the last character. Works like the
backspace key on the keyboard

CLR

Clears the entire equation

xxx
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Index
A
About ArbExpress, 1
Add waveforms, 128
Application file names and
directories, 9

C
Communication Menu, 26
Compile, 125
Configuration, 1
Copy, 118
Copy as bitmap, 122
Copy to clipboard, 121
Create marker patterns, 112
Creating waveforms, 12
Creating waveforms using
Matlab, 158
DC wave, 94
Exponential Decay wave, 98
Exponential Rise wave, 96
Lorentz wave, 109
Multi-tone wave, 106
Noise wave, 91
Pulse wave, 88
Sinc wave, 101
Sine wave, 79
Square wave, 82
Sweep wave, 103
Triangle wave, 85
Cursor, 113
Cursor Position, 113
Cursor position, 113

D
Dialog boxes, 41
Cursor Position, 45
DC wave, 58
Display Properties, 46
Equation Editor, 46
Exponential Decay, 60
Exponential Rise, 59
File transfer and instrument
control, 69
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Filter setup, 72
Import from oscilloscope, 73
Instrument properties, 72
Lorentz wave, 67
Multi-tone wave, 65
Noise wave, 56
Paste Option, 43
Pulse wave, 54
Set IP address, 72
Set pattern, 74
Sinc wave, 64
Sine wave, 48
Square wave, 50
Sweep wave, 62
Triangle wave, 52
Waveform Math, 71
Waveform properties, 42
Display Menu, 21
Divide waveforms, 133
Dynamic compile, 35

E
Edit Marker, 112
Edit Menu, 19
Editing waveforms, 124
Copy, 118
Copy as Bitmap, 122
Copy to System
Clipboard, 121
Cut, 118
Freehand, 123
Horizontal Draw, 124
Invert, 122
Mirror, 123
Paste, 119
Point Draw, 125
Select All, 120
Vertical Draw, 124
Equation Editor, 75
Creating a waveform, 12
Reference, 201
Using the equation editor, 75
Error messages and warnings, 171

Exiting the application, 15

F
File Menu, 18
File name extensions, 8
File transfer and instrument
control, 135
Fit to Window, 115
Free hand editing, 123
Freehand editing, 123

G
Graticule, 116
Properties, 116

H
Help Menu, 28
Horizontal draw, 124
Horizontal Zoom In, 115

I
Import from oscilloscope, 41
Import or transfer
waveform, 41
Scope acquisition wizard, 149
Instrument bar, 34
Instrument control, 161
AWG/AFG file transfer and
control, 135
Controlling an AFG, 140
Controlling an AWG, 142
Controlling an instrument
using Matlab, 161
Interpolation, 125
Invert, 122

M
Marker, 112
Edit marker, 112
Properties, 116
Math Menu, 24
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Index
Matlab commands, 163
CloseSession command, 165
LoadWfm command, 168
NewSession command, 164
Query command, 170
Read command, 167
TransferWfm command, 169
Write command, 166
Matlab support
Creating waveform using
Matlab, 158
Transferring files from
Matlab, 159
Menus, 17
Communication menu, 26
Display menu, 21
Edit menu, 19
File menu, 18
Help menu, 28
Math menu, 24
View menu, 21
Waveform menu, 23
Window menu, 27
Mirror, 123
Multiply waveforms, 131

N
Normalize waveforms, 157

P
Parameter ranges, 197
Paste, 119
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Printing from the Online Help, 5

W

Using online help, 4

Waveform
Addition, 128
Closing a waveform, 14
Creating a waveform, 12
Creating a waveform using
Matlab, 158
Division, 133
Edit operations, 19
Multi-waveform
properties, 40
Multiplication, 131
Normalize, 157
Opening a waveform, 10
Saving a waveform, 13
Sending waveform to
Arb, 148
Subtraction, 130
Transferring files from
Matlab, 159
Waveform Math, 71
Waveform addition, 128
Waveform division, 133
Waveform Menu, 23
Waveform multiplication, 131
Waveform subtraction, 130
Window Menu, 27

V

Z

S
Scope Acquisition Wizard, 149
Select All, 120
Shortcut keys, 15
Shortcut menu, 28
Shortcut View, 144
Standard tool bar, 31
Starting the application, 10
Status bar, 36
Subtract waveforms, 130
System requirements, 1

T
Time scale, 116
Tool bars, 34
Instrument bar, 34
Point draw toolbar, 35
Standard toolbar, 31
Status bar, 36
Waveform toolbar, 31
Zoom bar, 33

U

Vertical draw, 124
View Menu, 21

Zoom, 114
Zoom bar, 33
Zoom In, 114
Zoom Out, 114
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