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Welcome
Advanced Power Measurement and Analysis software allows power supply
designers to configure multiple measurements with custom defined settings,
measure and analyze power dissipation in switching devices, and measure and
analyze magnetic parameters in a single acquisition. The addition of new
measurements such as Inrush current, Capacitance, and Reactive power provides
more insight into the input / output characterization of power supplies. Designers
who otherwise spend a lot of time manually analyzing power dissipations per
cycle can now, with the Switching loss plot and the Time trend plot, measure
power dissipation at all switching cycles graphically. A single .mht format with
the append feature provides an easy way to generate reports that include
measurements, test results, and plot images. This solution elevates your
productivity to a new level and helps SMPS designers meet pre-compliance
requirements.

Advanced Power Measurement and Analysis software with version > 2.0.0 runs
on DPO/DSA7000C, MSO/DPO5000/B, MSO/DSA/DPO70000C, DPO/
DSA700000D, and MSO/DPO/DSA70000DX series oscilloscopes with
Windows 7 64-bit OS. For WinXP series oscilloscopes DPOPWR solution
version is 1.0.13.

Features and benefits
The software includes the following key features:

■ New measurements such as Inrush current, Capacitance, Reactive power and
Switching loss trajectory plot which provide more insight to Input/output
characterization.

■ Custom source Autoset for vertical and horizontal sets the scope parameters
automatically, increasing your productivity and measurement repeatability.

■ Automatic computation of line frequency provide more accurate results to
Voltage and current Harmonics.

■ Automatic detection of PFC circuit waveforms and prompts the user to use
VG for noisy/ringing switching waveforms.

■ Multiple measurements can be run at same time for single acquisition,
providing correlated power measurements.

■ Synchronization of Time trend plot with actual waveform allow you to
observe the variation of measurements over time.

■ Automatic detection of probes, AutoZero / Degauss, and de-skew utilities.
■ Reference waveform helps you to do post analysis now available for all

measurements.
■ Seamless integration of the application with the oscilloscope allows you to

switch between application and scope easily and debug more effectively.
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■ Global configuration features such as acquisition mode (HiRes), cursor
gating, coupling, and BW limits are applied uniformly across a group of
measurements.

■ Programmatic interface command support.

Key measurements
The key measurements of DPOPWR include the following:

■ Switching Loss measurement computes TON, TOFF, and total loss values
and trajectory plot of ON and OFF values for all switching cycles.

■ Hi Power Finder identifies all the peaks in the power waveform (MATH) and
has interactive detail results. It allows traversing between the peak values and
the result shows energy and loss values for each ON-ON switching cycle.

■ RDS(on) and SOA, measures dynamic internal resistance and customizable
Safe Operating Area mask testing with linear and log scales. SOA X-Y
RDS(on) does not support reference waveforms.

■ Magnetics measurements compute total magnetic loss, inductance of core and
shows graph of relationship between B and H.

■ Power Quality measurement, computes THD, True Power, Apparent Power,
Power Factor, and Crest Factor. All these analysis outputs are shown in a
quick view in the Summary results table.

■ Current Harmonics enables all precompliance testing to cover EN61000-3-2,
EN61000-3-2 AM14, and MIL 1399 (400 Hz) standards. User defined mode
displays up to the 100th harmonic in both table and bar graph formats.

■ Voltage Harmonics provide a frequency-domain view of the AC voltage,
such as at the output of an inverter.

■ Inrush current measurement identifies the peak currents based on configured
threshold level.

■ Capacitance measurement computes peak capacitance value above
configured threshold value.

■ Timing/Modulation analysis displays a time-trend plot of the cycle-to-cycle
variations in the modulated switching signal based on positive and negative
pulse width, positive and negative duty cycle, frequency, period, and skew
measurements.

■ Amplitude measurement computes High, Low, High-Low, Cycle Min, Cycle
Max and Cycle Pk-Pk. All these analysis outputs are shown in the Results
table, Time trend, and Histogram plots.

What do you want to do?
Study online help and related documentation

Read product description

Go to installation procedures

Welcome  
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General safety summary

General safety summary
Review the following safety precautions to avoid injury and prevent damage to
the measurement instrument or any products connected to it. To avoid potential
hazards, use the software and measurement instrument only as specified.

While using this software, you may need to access other parts of the system.
Read the general safety summary and specification sections in other equipment
manuals for warnings, cautions, and ratings related to operating the system with
this software.

To avoid fire and personal
injury

Connect and disconnect properly. Connect the probe output to the
measurement instrument before connecting the probe to the circuit under test.
Disconnect the probe input and the probe ground from the circuit under test
before disconnecting the probe from the measurement instrument.

Observe all terminal ratings. To avoid fire or shock hazard, observe all ratings
and markings on the measurement instrument and other equipment used with this
software. Consult the individual product manuals for further ratings information
before making connections to the circuit under test.

Do not operate with suspected failures. If you suspect there is damage to the
measurement instrument or other equipment being used with this software, have
it inspected by qualified service personnel.

Terms in this manual These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could
result in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result
in damage to the measurement instrument or other property.
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Terms in the application When launched from the oscilloscope menu, the application displays a caution
dialog box, warning you to use only appropriately rated voltage and current
probes, accessories, and other equipment. Click OK.
 

 

General safety summary  

2  Advanced Power Analysis



Introduction

Online help and related documentation
Access the information on how to operate the application with the oscilloscope
through the following related documents and online help.

What do you want to do? Conventions

Related Documentation

Contact Tektronix

Provide feedback on this Tektronix product

Printing from online help
Some online help topics have color in the examples of the displayed application.
To print this type of topic on a monochrome printer, some information may not
print because of certain colors. Instead, you should print the topic from the PDF
(portable document format) file that corresponds to the online help.
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Related documentation
In addition to the online help, you can access other information on how to operate
the oscilloscope through the following related documents:

■ Oscilloscope Information: The user manual and user online help for your
oscilloscope provide general information on how to operate the oscilloscope.

TIP. You can download PDF versions of many user manuals from the Tektronix
Web site.

■ Programmer Information: The online programmer guide for your
oscilloscope provides details on how to use GPIB commands to control the
oscilloscope.

Conventions
Online help uses the following conventions:

■ Refers to the DPOPWR Power Measurements solution as Advanced Power
Analysis Application.

■ When steps require a sequence of selections using the application interface,
the ">" delimiter marks each transition between a menu and an option. For
example, one of the steps to save a setup file would appear as File> Save.

■ The Source Configuration Panel is common to many measurements.

■ GP knob refers to the general-purpose knob.

Feedback
Tektronix values your feedback on our products. To help us serve you better,
please send us your suggestions, ideas, or comments on your oscilloscope.

Direct your feedback using e-mail to

techsupport@tektronix.com or FAX at (503) 627-5695

and include the following information. Please be as specific as possible.

Introduction  
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General information: ■ Oscilloscope model number and hardware options, if any
■ Probes used
■ Your name, company, mailing address, phone number, FAX number
■ Please indicate if you would like to be contacted by Tektronix about your

suggestion or comments

Application specific
information:

■ Software version number
■ Description of the problem such that technical support can duplicate the

problem
■ If possible, save the oscilloscope and application setup files as .set files
■ If possible, save the waveform on which you are performing the

measurement as a .wfm file

Once you have gathered this information, contact technical support by phone or
through e-mail. If using e-mail, be sure to enter in the subject line "DPOPWR
Problem," and attach the .set and .wfm files.

 Introduction
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Getting started

Introduction and product description
Advanced Power Measurement and Analysis software (DPOPWR) with version
> 2.0.0 runs on DPO/DSA7000C, MSO/DPO5000/B, MSO/DSA/DPO70000C,
DPO/DSA700000D, and MSO/DPO/DSA70000DX series oscilloscopes with
Windows 7 64-bit OS. For WinXP series oscilloscopes DPOPWR solution
version is 1.0.13. It allows you to acquire, measure, and analyze various
switching power supply signals at multiple test points. The application provides
simple and direct way to obtain results about switching devices, magnetic
components, and compliance tests to EN 61000-3-2 standard for Switch mode
Power supply. The features of DPOPWR are:

■ Switching Analysis: It analyzes the switching devices in the power supply,
such as FET (Field Effect Transistor), BJT ( BiPolar Junction Transistor),
and IGBT (Integrated Gated BiPolar Junction Transistor). The measurements
include Switching Loss, Trajectory plot with ON and OFF values for all
switching cycles, Hi-Power Finder, Safe Operating Area (SOA), SOA X-Y
(DPX), Dynamic Resistance RDS(on), di/dt, and dv/dt.

■ Timing Analysis: It analyzes the switching devices in the power supply,
such as FET, BJT, and IGBT. The measurements include Pulse Width
modulation, Period modulation, Duty Cycle modulation, Frequency
measurement, and Skew.

■ Magnetics: It measures Inductance, Magnetic Property, Magnetic Loss, and

.

■ Input Analysis: It measures Power Quality, Current Harmonics (upto 100th
harmonic value is displayed in table and bar graph format), Voltage
Harmonics, Total Power Quality, In Rush Current, and Capacitance.

■ Output Analysis: It measures Line Ripple, Switching Ripple, Turn-On
Time, and Spectral Analysis. Spectral Analysis analyses the electromagnetic
interference frequency and measures the noise/ripple frequency range at
output DC voltage. Support of POE specification filter in Spectral
Measurement.

■ Amplitude: It measures High, Low, High-Low, Cycle Min, Cycle Max and
Cycle Pk-Pk for periodic waveforms.

■ A Report tool with append capability to create and print custom reports
in .mht format.

■ SOA Overlay, Deskew, Auto detect of probes, DeGauss Autoset,
Autocalc loss without Vg, and SOA Mask Editor utilities.
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What do you want to do? Current probes

Compatibility

Requirements and restrictions

Installing the application

Compatibility
To view number of channels required for any measurement, click Help > About
TekScope. The oscilloscope displays the channel dependencies in option panel.

Measurement Name Number of Channels
Switching Analysis

di /dt 1 
dv /dt 1 
Hi-Power Finder 2 - 3 
RDS(On) 2 
SOA 2 
SOA X-Y (DPX) 2 
Switching Loss 2 - 3 

Timing Analysis
Duty Cycle 1 
Frequency 1 
Period 1 
Pulse Width 1 
Skew 2 

Magnetics
I vs ∫V 2 
Magnetic Loss 2 
Magnetic Property 2 - 4 
Inductance 2 

Input Analysis
In Rush Current 1 
Input Capacitance 2 
Current Harmonics 2 
Power Quality 2 
Total Power Quality 2 
Voltage Harmonics 1 

Output Analysis
Line Ripple 1 
Switching Ripple 1 

Getting started  
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Measurement Name Number of Channels
Spectral Analysis 1 
Turn-On time 2 to 4 
Amplitude
High 1 
Low 1 
High Low 1 
Cycle Min 1 
Cycle Max 1 
Cycle Pk-Pk 1 

Requirements and restrictions
Install Microsoft .NET Framework Version 4.0 as a prerequisite prior to
installing DPOPWR application. Microsoft Windows Internet browser is required
to view report.

Current probes
The application supports the following probes:

■ AM503B series with A6302

■ AM503B series with A6302XL

■ AM503B series with A6303

■ AM503B series with A6303XL

■ AM503B series with A6304XL

■ AM503 Series with A6312

■ TCP0020

■ TCP0030

■ TCP0030A

■ TCP0150

■ TCP202

■ TCP2020

■ TCP202A

■ TCP202A and TPA-BNC

■ TCPA300 with TCP303

■ TCPA300 with TCP303 and TPA-BNC

 Getting started
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■ TCPA300 with TCP305
■ TCPA300 with TCP305 and TPA-BNC
■ TCPA300 with TCP305A
■ TCPA300 with TCP305A and TPA-BNC
■ TCPA300 with TCP312
■ TCPA300 with TCP312 and TPA-BNC
■ TCPA300 with TCP312A
■ TCPA300 with TCP312A and TPA-BNC
■ TCPA400 with TCP404XL
■ TCPA400 with TCP404XL and TPA-BNC
■ TekVPI TCP0030

Voltage probes
The application supports the following probes:

■ P5050
■ P5050B
■ P5100
■ P5100A
■ P5200A
■ P5200A
■ P5202A
■ P5205
■ P5205A
■ P5210
■ P5210A
■ P6015A (10 ft)
■ P6015A (25 ft)
■ P6021A
■ P6131 (1.3 m)
■ P6131 (2 m)
■ P6138A
■ P6139A
■ P6139B
■ P6158

Getting started  
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■ P6243

■ P6245

■ P6246

■ P6247

■ P6248

■ P6250

■ P6251

■ TAP1500

■ TAP2500

■ TDP0500

■ TDP1000

■ TDP1500

■ TDP3500

■ TekVPI TAP1500

■ TekVPI TAP2500

■ TekVPI TPA-BNC

■ THDP0100

■ THDP0200

■ TMDP0200

■ TPP0500

■ TPP0500B

■ TPP0502

■ TPP0850

■ TPP1000

Voltage probes The application supports the Deskew Fixture (Tektronix part number: 067-1686-
XX).

NOTE. For further information about probes visit www.tek.com/probes.

NOTE. If you are using external fixtures to measure Turn-On Time and Ripple,
then enter the external attenuation factor values in the Vertical > External
Attenuation menu for accurate results.

 Getting started
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Updates through the web site
Find information about DPOPWR and other applications at the Tektronix Inc.
Web site, www.tektronix.com. Check this site for updates and free applications.

To install an application update, you must download it from the Tektronix Web
site to the oscilloscope hard disk.

NOTE. Refer to the Readme.txt file on the web site for steps to install and more
information.

Installing the application
Your instrument comes with the application preinstalled on the hard drive.

NOTE. If you install the new Advanced Power Analysis application, the old
DPOPWR application is uninstalled.

Getting started  
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Operating basics

About basic operations

About basic operations This section contains information on:

Application interface

Using basic oscilloscope functions

Setting up the software

Saving and recall setups

Application interface The application uses a Microsoft Windows interface.

Application directories and file names

Application interface menu controls

NOTE. The oscilloscope application shrinks to half size and appears in the top
half of the display when the application is running.

Application interface
menu controls

Item Description
Menu bar Located at the top of the oscilloscope that is used to start the

application
Tab Labeled group of options containing similar items
Area Enclosed visual frame with a set of related options
Option button Button that defines a particular command or task
Drop-Down List box Box that contains a list of items from which you can select one

item
Field Box that you use to type in text, or to enter a value with the

Keypad or a Multipurpose knob
Check Boxes Square box that you use to select or clear preferences
Scroll bar Vertical or horizontal bar at the side or bottom of a display area

that is used for moving around in that area
Browse Displays a window where you can look through a list of

directories and files
Command button Button that initiates an immediate action
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Item Description
Keypad Appears when you select the box and enter a value
MP / GP knob Select the multipurpose ( MP or GP ) knob to display a line

between the knob and the box; turn the knob on the oscilloscope
to select a value

Basic application functions

Application directories
and file names

The application uses directories to save and recall setup files and uses file name
extensions to identify the file type.

The following table lists default directory names.

Directory Used For
C: \ Users\Public\Tektronix\TekApplications
\Advanced Power Analysis\Waveforms\

Stores the waveforms used for the tutorial

C:\User\<Current User>\Tektronix
\TekApplicaitons\Advanced Power Analysis
\Reports\

Stores the default reports

C:\User\Public\Tektronix\TekApplicaitons
\Advanced Power Analysis\SOA Mask\

Stores the SOA mask data as a comma
separated value file

C:\User\<current user>\Tektronix
\TekApplicaitons\Advanced Power Analysis
\SwitchingLoss\

Stores the per cycle loss information of
Switching loss in csv format

See also.  
File name extensions

File name extensions Extension Description
.csv Is a file that uses a “comma separated variable” format
.ini Is an application setup file
.set Is an oscilloscope setup file saved and recalled with an .ini file; both the

files will have the same file name
.wfm Is a waveform file that can be recalled into a reference memory
.mht Is the file format for reports
.jpg Is the format of the image file of the various plots
.msk Is the format of the SOA mask file
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Returning to the
application

When you access oscilloscope functions, the oscilloscope fills the display. Access
oscilloscope functions in the following ways:

■ Choose the Menu on the oscilloscope and access the application

■ Push front-panel buttons

Saving and recalling setups

Saving a setup To save the application state and the oscilloscope settings to a setup file, follow
these steps:

1. Select File> Save As> Setup.
 

 

2. Select the Save menu.

3. Select the directory to save the setup file.

4. Select or enter a file name. The application appends an ".xml" extension to
the name of setup files.

5. Choose Save.

NOTE. While saving a Report, the application does not validate for the available
size in the drive.
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Recalling a saved setup To recall the application setup and the oscilloscope settings from a saved setup
file, follow these steps:

1. Select File> Recall.

2. Select the directory from which you can recall the application settings.

3. Select or enter a file name.

NOTE. The application also recalls the oscilloscope setup from a ".xml" file when
you recall an application setup.

Recalling the default setup To recall the application settings from the Default setup file Select File> Recall
Default Setup.
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Utilities

DeGauss Degaussing is a mandatory operation for current probes. Every current probe
must be degaussed before using it.

Degaussing a current probe requires:

■ Current probe jaws should be closed before it is degaussed

■ Probe should not be connected to any active point or no signal in the probe

The application checks the Degauss status of each probe at the beginning of
every autoset and the application prompts to degauss the probe if necessary.
Select a measurement, and launch the source control window, select the De-
Gauss button. This will guide you through the De-Gauss process.
 

 

Alternatively, you can do it manually by pressing the degauss button on the
current probe.

Auto Zero AutoZero is a feature which computes vertical zero-volt error (DC offset) and
compensates during acquisition. When AutoZero button is pressed the scope
makes acquisitions and measurements, to adjust the offset. AutoZero is useful for
voltage probes which are used to measure current. 

To perform AutoZero, connect the voltage probe and short the input terminals
together.
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NOTE. Ensure no input signals are connected to probe tips.

NOTE. Auto Zero is applicable for voltage probes.

Preferences setup ■ Click I-Probe Settings to display TCP, Shunt, Custom and AM503S Settings.
Click the TCP button if you are using TCP series probes.
 

 

NOTE. If you are using a TCA-1MEG probe, terminate the input side with
50 Ohms for a current probe that does not automatically change the
termination. If you are using a TCA to BNC probe, you do not have to
terminate the input side.
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Deskew MSO/DPO5000/B series oscilloscopes: Deskewing Probes and Channels

To ensure accurate results, deskew the probes before taking measurements from
your device under test.

The application provides you two deskew options. They are:

■ Static deskew

■ Real time deskew using TEK-DPG (Deskew Pulse Generator) or an external
source

Deskew can be accessed using the Preferences dialog box.

NOTE. For THDP probes, it is recommended that you use static deskew because
of Noise.

 

 

NOTE. Connect the probes to the fastest transition while using the external signal
mode.
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To deskew a current probe perform these steps:

1. Select the IProbe tab.

2. Select the current sources and probes by selecting the source and probe from
the Current Sources and Current Probes drop-down lists.

3. After configuring the current probe, select Deskew Static or Deskew Real
Time tab and click Perform Deskew to start the deskew procedure.
 

 

To perform a static deskew perform these steps:

1. Select the Deskew Static tab.

2. Select the To and From sources by selecting the sources from the Source
drop-down lists.

3. Select the To and From probes by selecting the probes from the Probe drop-
down lists.

4. Click Perform Deskew to start the deskew procedure.
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To perform a real time deskew perform these steps:

1. Select the Deskew Real Time tab.

2. Select the To and From sources by selecting the sources from the Source
drop-down lists.

3. To change the reference level or hysteresis values, double click the text box
and enter the desired value using the pop up keyboard.

4. Select the Slope as either Rise or Fall.

5. Select the Source as Tektronix DeSkew Fixture and Pulse generator (TEK-
DPG).

6. Set Ch1 to Voltage, Ch2 to Current.

7. Connect the probe tips to the Deskew fixture, and connect the TEK-DPG to
Ch3.

8. Select Output enable on the TEK-DPG probe.

9. Click Perform Deskew to start the deskew procedure.

A popup asks whether you want to do an autoset or not. Click Yes to allow
the application to set up the oscilloscope for deskew; click No if you have
already set up the oscilloscope and just want to perform deskew.
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Deskewing probes and
channels

Static deskew. Static deskew automatically sets the deskew based on the probe
type supported. The propagation values of the probes are fixed. You do not need
an external deskew fixture to deskew the channels.

The application supports the following combination between any two-channel
probes for DPO/DSA7000C, MSO/DPO5000/B, MSO/DSA/DPO70000C, DPO/
DSA700000D, and MSO/DPO/DSA70000DX series oscilloscopes:

Probe Model Skew in ns
AM503B w/ A6302 30.1 
AM503B w/ A6303 55.0 
AM503B w/ A6312 30.1 
AM503B w/ A6302XL 60.3 
AM503B w/ A6303XL 105.0 
AM503B w/ A6304XL 105.0 
P5050 5.5 
P5050B 6.0 
P5100 14.9 
P5100A 6.0 
P5200 20.0 
P5200A 21.0 
P5202A 18.0 
P5205 17.3 
P5205A 18.0 
P5210 20.3 
P5210A 18.0 
P6015A (10 ft) 14.7 
P6015A (25 ft) 33.3 
P6021A 9.0 
P6131 (1.3 m) 6.3 
P6131 (2 m) 9.1 
P6138A 6.3 
P6139A 6.3 
P6139B 6.0 
P6158 5.0 
P6243 5.3 
P6245 5.3 
P6246 7.7 
P6247 7.3 
P6248 6.8 
P6250 6.5 
P6251 6.5 
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Probe Model Skew in ns
TAP1500 5.3 
TAP2500 5.3 
TCP0020 16.6 
TCP0030 14.6 
TPP1000 5.67 
TCP0030A 14.5 
TCP0150 21.0 
TCP202 17.3 
TCP202A 17.2 
TCP2020 17.0 
TCP202A;TPA-BNC 17.2 
TCPA300 w/ TCP303 40.0 
TCPA300 w/ TCP303 + TPA-BNC 40.3 
TCPA300 w/ TCP305 19.0 
TCPA300 w/ TCP305 + TPA-BNC 19.3 
TCPA300 w/ TCP305A 19.0 
TCPA300 w/ TCP305A + TPA-BNC 19.3 
TCPA300 w/ TCP312 17.0 
TCPA300 w/ TCP312 + TPA-BNC 17.3 
TCPA300 w/ TCP312A 17.0 
TCPA300 w/ TCP312A + TPA-BNC 17.3 
TCPA400 w/ TCP404XL 80.0 
TCPA400 w/ TCP404XL + TPA-BNC 80.3 
TDP0500 6.5 
TDP1000 6.5 
TDP1500 5.4 
TDP3500 5.3 
TekVPI TCP0030 14.6 
TekVPI TAP1500 5.3 
TekVPI TAP2500 5.3 
TekVPI TPA-BNC 0.25 
THDP0100 16.0 
THDP0200 14.0 
TMDP0200 14.0 
TPP0500 5.3 
TPP0500B 5.3 
TPP0502 5.3 
TPP0850 6.1 
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Follow these steps to perform the Static Deskew:

1. Select Analyze> Advanced Power Analysis, and then select Preferences.

2. Click the Deskew Static tab.

3. In the From panel, select the Source and the corresponding Probe type.

4. In the To panel, select the Source and the corresponding Probe type.
 

 

5. Click Perform Deskew to deskew the selected probe.

NOTE. Static deskew is performed between any two channels of your choice.
Retain the From panel parameters and change the To panel parameters to
perform deskew for more than two channels. If you are using a Custom probe, the
application adjusts the deskew and sets the value when you perform static
deskew.
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DPO70000 series oscilloscopes. DPO/DSA7000C, MSO/DSA/DPO70000C,
DPO/DSA700000D, and MSO/DPO/DSA70000DX series oscilloscopes.

Use the Aux Output signal (DPO7000C) and the Deskew fixture (Tektronix part
number: 067-1686-XX) to deskew the probes and channels.

Follow these steps to deskew with an internal source:

1. Connect the AUX OUT of the oscilloscope to the B side input of the deskew
fixture to deskew the voltage probe and current probe.

2. Follow the instructions for the Probe Calibration and Deskew fixture to make
the connections.

3. Set up the oscilloscope as follows:

■ Use the Horizontal Scale knob to set the oscilloscope to an acquisition
rate so that there are two or more samples on the deskew edge.

■ Use the Vertical Scale and Position knobs to adjust and display the
signals on the screen.

■ Set the Record Length so that there are more samples for the edges in the
acquisition. It is recommend that you set the record length to
25000 points.

4. To start the application, select Analyze > Advanced Power Analysis, and
then select Preferences.

5. Select the Deskew Real Time tab. Click the Internal Source button in the
Source panel.

6. In the From panel, set the Source to Ch1. The remaining channels are
deskewed to the Source waveform, which is the reference point.

7. In the To panel, set the Source to Ch2, the channel to be deskewed.

8. To start the deskew utility, click the Perform Deskew button and confirm the
operation.
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9. Use Ch1 as the reference point and deskew the remaining channels.

The following figure shows a waveform before and after deskew.

Figure 1: Waveform before deskew

Figure 2: Waveform after deskew

10. Only 1 edge is displayed on the screen, and you can see that the skew has
been removed.
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NOTE. The oscilloscope setup is saved before deskew and recalled after deskew.
If the acquisition setup is in Stop condition before saving the setup, the setup with
the stop condition is recalled. When deskew recalls this setup, the application
does not display the waveform. To view the waveform, push the Run or the Stop
button in the oscilloscope application.

See also.  
Static deskew

Deskewing using a power deskew fixture

Deskewing using a power deskew fixture. The Power Measurements Deskew
Fixture with Tektronix part number (067-1686-XX), supports up to 150 A AC/
DC current probes.

Follow these steps to deskew:

■ Connect the AUX OUT of the oscilloscope to the J1, J2 ( Cal signal input)
input of the deskew fixture to deskew the voltage probe and current probe.

■ Follow the steps 2-10 in the topic Deskewing in DPO/DSA7000C, MSO/
DSA/DPO70000C, DPO/DSA700000D, and MSO/DPO/
DSA70000DX series oscilloscope to complete the procedure.
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Advanced power measurement and analysis

Setting up DPOPWR to take measurements

Setting up the software Setup the application to view waveform analysis results in table format. You can
also view the results in 2D plot format or save as report for later analysis.

The following are the categories of measurements. Click the link for
measurements in that category:

1. Switching analysis

2. Timing analysis

3. Magnetics

4. Input analysis

5. Output analysis

6. Amplitude
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Table of options-Source
configuration

Area Option Description
Source selection panel Current (I)

Voltage (V)
Gate Voltage(Vg)

Current Source

■ Select Ch1-Ch4 for live
waveform

■ Select Ref1- Ref4 for the
Ref waveform

Voltage Source

■ Select Ch1-Ch4 for live
waveform

■ Select Math1- Math4 for
the Ref waveform

Gate Voltage

■ Select Ch1-Ch4 for live
waveform

■ Select Math1- Math4 for
the Ref waveform

Gate selection is applicable for
the selected measurements. It
will sync with gate or edge
source selection under the
configuration of the selected
measurements.

NOTE. Availability of Ch3, Ch4,
Ref3, Ref4 depends on the
oscilloscope.
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Table of measurements and configurations-Switching analysis.

Measurement SubType/Configurations Description
Switching Analysis
Switching Analysis Analyzes the power dissipated

in the switching cycles across a
switching device.

Switching Loss Measures the instantaneous minimum and maximum average
energy consumed across the switching device. The loss is
measured on each cycle of the acquired waveform. The results
include minimum, maximum and the average loss and energy for
the complete cycles in a single record.
Type PWM Type

Device
PFC Type  1

OnOffLevel Autocalc loss without Vg
Units
Device
V-Level
I-Level
Math Destination

Options Units
Ref Level
Hysteresis
Filter Current
Signal Condition
Log Switching Cycles

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

1 Acquires atleast one cycle of input line frequency and turns on cursor gating.
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Measurement SubType/Configurations Description
Hi-Power Finder Hi Power Finder analyzes the power loss in switching

components, ensuring that the instantaneous power remains
within the specified limits.
PWMType Fixed

Variable
OnOffLevel Units

Device
V-Level
I-Level
Math Destination

Edges Units
Ref Level
Hysteresis
Filter Current

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Safe Operating Area (SOA) Plots the Voltage and Current waveform in a single record in XY
mode. The Enable mask check box is enabled only for SOA
Normal. Use the Mask Editor to apply the mask to the SOA Plot
only for SOA Normal option.
Mask Editor Enable

X Co-ord.
Y Co-ord.
Add
Update
Clear
Clear All
Save
Recall
Graph
Preview

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

SOA X-Y (DPX) Sets up the oscilloscope in XY mode with infinite persistence for
the voltage and current waveforms.

RDS(on) Method V/I
dV/dI

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Advanced power measurement and analysis  

32  Advanced Power Analysis



Measurement SubType/Configurations Description
dv/dt Measures the differentiation of the voltage dv/dt

Options Units
Ref Level
Hysteresis
Ref High
Ref Low

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

di/dt Measures the differentiation of the current di/dt
Options Units

Ref Level
Hysteresis
Ref High
Ref Low

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Table of measurements
and configurations-Timing

analysis

Measurement SubType/Configurations Description
Modulation Analysis
Pulse Width Is a trend plot of the pulse width variation for the acquired

waveform. It is the time difference between the leading and the
trailing edge of a pulse.
Edges Polarity

■ Positive
■ Negative

Options Units
Ref Level
Hysteresis

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode
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Measurement SubType/Configurations Description
Period Is a trend plot of the variation of the period measured from a

leading edge to a leading edge or a trailing edge to a trailing
edge.
Edges Edge Type

■ Rise
■ Fall

Options Units
Ref Level
Hysteresis

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Duty Cycle Measures the duty cycle of the waveform and is a trend plot. The
duty cycle can be a positive or a negative duty cycle.
Edges Edge Type

■ Rise
■ Fall

Polarity

■ Positive
■ Negative

Options Units
Ref Level
Hysteresis

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Frequency Is a trend plot of the variation of the frequency of the signal.
Edges Edge Type

■ Rise
■ Fall

Options Units
Ref Level
Hysteresis

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Time Analysis
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Measurement SubType/Configurations Description
Skew The Skew measurement calculates the difference in time

between the designated edge on a principle waveform to the
designated edge on another waveform.
Edges From Edge

■ Rise
■ Fall
■ Both

To Edge

■ Same as From
■ Inverse of From

Options Units
Ref Level
Hysteresis

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Table of measurements
and configurations-

Magnetics

Measurement SubType /Configurations Description
Inductance Edges Edge Source

Options Units
Ref Level
Hysteresis

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode
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Measurement SubType /Configurations Description
Magnetic Property Source Voltage Source

Freq and Duty

■ Fixed
■ Variable

Physical Chars1 Units
Cross Section Area
Magnetic Length

Physical Chars2 Primary Winding:

■ Single
■ Multiple

# of Turns (Primary Winding)
Secondary Windings:

■ # of Winding

■ Two
■ More

■ Magnetizing Current
■ Winding1 Source:

■ # of Turns
■ Winding 2 Source:

■ # of Turns

Options Units
Ref Level
Hysteresis

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Magnetic Loss Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

I vs ∫V Plots the integral of the voltage waveform and the current
waveform in a XY plot. Integral of V is proportional to B and the
current waveform I is proportional to H.
Global Coupling

BW Limit
Cursor Gating
Acquisition Mode
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Table of measurements
and configurations-Input

analysis

Measurement SubType / Configurations Description
Select input analysis
Power quality Measures the effects of distortions caused by nonlinear loads,

including the power supply itself.
Global Coupling

BW limit
Cursor gating
Acquisition mode

Current harmonics Captures the predefined limit values for the harmonics. This will
be used to compare the measured value of the harmonics.
Standard Type

■ 61000-3-2 
■ AM - 14 
■ MIL 1399 

Line Frequency

■ Auto: Calculates input
signal frequency
automatically.

■ 50 Hz
■ 60 Hz
■ Custom: User is allowed to

set the Line frequency in
range 1 Hz to 4000 Hz
using numerical keypad.

Harmonics Order

■ For 61000-3-2 and AM
14 type, range is 40 to
100 harmonics.

■ For MIL 1399, range is
50 to 100 harmonics.

I-Probe impedance Impedance table
Edit

Harmonics Class
Harmonic
Edit
Input power
Power factor
Filter check box
Fundamental current

Global Coupling
BW limit
Cursor gating
Acquisition mode
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Measurement SubType / Configurations Description
Voltage harmonics Captures the predefined limit values for the harmonics. This will

be used to compare the measured value of the harmonics.
Line Frequency ■ Auto: Calculates input

signal frequency
automatically.

■ 50 Hz
■ 60 Hz
■ Custom: User is allowed to

set the Line frequency in
range 1 Hz to 4000 Hz
using numerical keypad.

Global Coupling
BW limit
Cursor gating
Acquisition mode
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Measurement SubType /Configurations Description
Total Power Quality Measures and displays:

■ RMS value of the current and voltage

■ True power

■ Apparent power

■ Crest factor of current and voltage, Current harmonics

■ Reactive Power

■ Power factor

■ Total harmonic distortion

It is a combination of Power Quality and Current Harmonics
measurement.
Standard Type

■ 61000-3-2 
■ AM - 14 
■ MIL 1399 

Line Frequency

■ Auto: Calculates input
signal frequency
automatically.

■ 50 Hz
■ 60 Hz
■ Custom: User is allowed to

set the Line frequency in
range 1 Hz to 4000 Hz
using numerical keypad.

I Probe The impedance of the current
probe and the frequency can be
edited in this table and is used
to calculate the current
harmonics value. In the default
state, I-probe is not enabled.
Impedance table
Edit

Harmonics Table Class
Harmonic
Edit
Input Power
Power Factor
Filter check box
Fundamental Current

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode
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Measurement SubType /Configurations Description
In Rush Current Measures both positive and negative peaks of inrush current for

a switching power supply during in-circuit operation.
Options Units

Ref Level
Hysteresis
Peak (Amps)

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Input Capacitance Measures capacitance above Ref Level using input current and
voltage for switching power supply during in-circuit operation.
Options Units

Ref Level
Hysteresis
Peak (Amps)

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Table of measurements
and configurations-Output

analysis

Measurement SubType /Configurations Description
Select Output Analysis
Line Ripple Measures the amount of AC-output signal related to the input line

frequency
Line Ripple Freq Measures the:

■ AC component voltage
present on a DC.

■ Low frequency AC voltage
in the peak-to-peak
voltage.

50 Hz
60 Hz
400 Hz

Global Coupling
Bandwidth Limit
Cursor Gating
Acquisition Mode

Switching Ripple Measures the maximum AC voltage present on a DC
Ripple Freq Switching Ripple Frequency
Global Coupling

BW Limit
Cursor Gating
Acquisition Mode
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Measurement SubType /Configurations Description
Select Spectral Analysis
Spectral Analysis Analyzes, measures and displays the frequency component in a

signal based on the selected Start, Stop and RBW values.
Spectral Config Frequency Start

Frequency Stop
Window Type
Res BW
Update
Auto Setup
DC Block
Log Results
Filter type (POE Specific
Filter) :

■ PoE 500 Hz

■ PoE 500 Hz-150 KHz

■ PoE 150 KHz-500 KHz

■ PoE 500 KHz- 1 MHz

Filter Source
Global Coupling

BW Limit
Cursor Gating
Acquisition Mode
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Measurement SubType /Configurations Description
Turn On Time Measures the time delay difference between the input voltage

applied to the system and the time to develop the steady state
output voltage.
Input Convertor

DC-DC
AC-DC
Frequency
Source
Maximum Voltage
Trigger Level
Max Turn on Time

Output Source1
On
Off
Max Voltage
Source2
On
Off
Max Voltage
Source3
On
Off
Max Voltage

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Table of measurements
and configurations-

Amplitude

Measurement SubType /Configurations Description
High
Low
High-Low

Edge Measure the Center X% of the
signal
Methods

Options Units
Ref Level
Hysteresis

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode
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Measurement SubType /Configurations Description
Cycle Min
Cycle Max
Cycle Pk-Pk

Signal Type AC
DC

Options Units
Ref Level
Hysteresis

Global Coupling
BW Limit
Cursor Gating
Acquisition Mode

Taking a new measurement

About taking
measurements

To take measurements:
1. Connect the required voltage and the current probe to the DUT.
2. Set the Current source and the Voltage source on the Source Configuration

panel.
3. Select and run the measurements to view the acquired waveform results. You

can also view the results in 2D plot format or save as report for later analysis.

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the for more information.

NOTE. When you run any measurement, select Real Time Sampling Mode.

Viewing results Summary result and detailed result are displayed for successfully completed
measurement. Select Results > Detailed to view detailed result. The details
displayed vary for the measurements.

Select the Detailed Results tab to view details of the results. Details vary
depending on the displayed measurements.
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Summary results can be current and accumulated. Current shows the results for
the current acquisition. Accumulated shows the statistics of all acquisitions
(previous and current). Select the Accumulated tab to view the summary of the
measurement.

 

 

The application displays the statistics for selected measurements in the results
menu. The statistics displayed are the following:

■ Max: The maximum value calculated using Max(X) = Most Positive Value
of X.

■ Min: The minimum value calculated using Min(X) = Most Negative Value
of X.

■ Mean: The mean value calculated using the following equation:

 

 

■ Std Dev The standard deviation value calculated using the following
equation:

 

 

■ Peak-Peak: . The peak to peak value calculated using the following
equation:
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■ Population. Population is the total number of events or observations over
which the other statistics were calculated. The Population (X) will represent
the number of cycles of the waveform, and for measurements where cycles
are not meaningful, Population shows as number of acquisitions.

■ Result. This field indicates whether the measurement is success or fail. If
there was any error during the analysis, then fail is displayed. When the
measurement is in RUN state, Not Available is displayed and changes to
Success or Failure depending on the measurement outcome.

NOTE. Modifying the configuration clears the previously calculated results in
table.

Select the More tab to view additional measurement results. The details displayed
vary for the measurements.

 

 

Plot components and
features

Use the plots menu bar to control plot details and features.

 

 

Menu item Description
Select X or Y or both axes to enable the zoom in and
zoom out of the selected axis.

Reset the plot window to the initial state.

Use hand option to pan the plot window and move around
the displayed waveform.

Moves the plot cursors to the center of the display area.
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Menu item Description
Set Plot cursors as horizontal, vertical, or both. Show
Legend will display the cursor position.
Connects the plot data points using linear interpolation.

Saves the plot image in .png format. The default directory
is C:\Users\<users>\Tektronix\TekApplications\Advanced
Power Analysis\Images\
Displays additional details about the plot like traversing
between peaks, different vertical scale.

If there is more than one plot, the Layout button is
enabled. Use the Summary Layout to arrange the plots
either horizontally or vertically. A maximum of 4 plots are
displayed at a time

Plot view. When you have multiple plots, select either a Grid and Flow view from
the Layout (multiple plots) view selector.

Multiple plot options.
 

 

Multiple plot options.
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Grid view. Multiple plots can viewed and compared simultaneously. Grid view is
recommended to view and compare plots side by side. By default Grid view is
selected. The number adjacent to Grid specify the number of plots to display side
by side for each row. The maximum number allowed is 4.

■ Grid 1 (1*1): Displays one plot in row.
 

 
■ Grid 2 (1*2): Displays two plots side by side in row.

 

 
■ Grid 3 (1*3): Displays three plots side by side in row.
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■ Grid 4 (1*4): Displays four plots side by side in row.
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Flow view. The plot window arranges plots based on the size. By default plots are
aligned in single row. You can adjust the size of the plot window to change the
configuration to see the selected plots. For example below Flow view displays
four plots arranged in single row (4*1). Flow view is useful to view one plot at a
time.

Flow view.
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Flow view.

Viewing plots Successful completion of measurements generate plots. Select Analysis >
Advanced Power Analysis, and then select the Plots navigation tab to configure
and view the plots for the selected measurements. 
 

 

NOTE. A maximum of four plots can be added, and they are displayed in a single
window. Double-clicking the plot will toggle between full screen and compact
size. See Plot components and features for additional details.

 

 

Click Plot button to add the plot to the plots table. Click Clear button to remove
the selected plot and click Clear All to remove all plots from the table. Click
Show Plots button to display the plots.

A Magnetic BH Curve plot is shown in this example.
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Double click the plot to show added detailed results. Click a point on the plot to
show detail for that point.

NOTE. The plot operation may become slow with higher record length updates.
Do not perform any operation on the application user interface during record
length updates. During FREE RUN, the application uses large amount of plot
data for longer record lengths. To stop the FREE RUN, Click Stop on the RUN/
STOP button of the oscilloscope. Continue sequencing by pressing the RUN.
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Plot autoscale. By default, the plots will autoscale based on the selected mask
range. For example, if a mask violation happens, then only the region of violation
is shown when the plot is displayed. To view the complete data on the plot
window, click the Reset button in the plot tool box.

Figure 3: Plot with violation

Figure 4: Reset to get the complete rendering

NOTE. If there is no mask violation, then resetting will render the plot to complete
display area.
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Position cursors to center. This is used to position the cursors to center. The
close-up view of the waveform will make the cursor lines move out of the screen.
Position cursors to center helps to move the cursors to center of the display area.

Figure 5: Plot with cursor enabled

Figure 6: Plot cursors positioned to center

Reports Successful completion of measurements generate reports. Select Reports to set up
and view the report. 
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To design your report do the following steps:

1. In the Report Name pane, click browse, navigate to the directory and select
the report or double-click in the field, enter the path and the file name using
the pop-up keyboard.

2. Check the Auto increment report name if duplicate box to auto increment the
report name if its already exists. The auto generated report name is of
YYMMDD_HHMMSS_savedfile.mht format.

3. Check View report after generating to open the generated report.

4. In the Content To Save pane, check the items you want included in your
report.

■ Include results summary includes the results summary status in the
generated report.

■ Included detailed results includes the measurement result details in the
generated report.

■ Include plot images includes the plot images like measurement plots and
the oscilloscope waveform in the generated report.

■ Include user comments includes any comments in the generated report.
To add comments, click the Add Comment button.

■ Include setup configuration includes setup information like DPOPWR
version, oscilloscope version, and status in the generated report.

■ Include complete application configuration includes the complete
configuration details in the generated report.

5. Click the Append button to add the current settings to an existing report.

6. Click the Save or Save As buttons to save the report changes in the default
report directory. The report name is modified based on Auto increment report
name if duplicate option.

7. Click the View button to display the report. An example report is shown in
the following images.
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Figure 7: Report

Figure 8: Plot

Figure 9: Oscilloscope Waveform
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Selecting a measurement To take a measurement, select Analyze > Advanced Power Analysis. The
application launches with the Select tab (default) displaying the category of
measurements.

There are six categories of measurements:

■ Switching analysis

■ Timing analysis

■ Magnetics

■ Input analysis

■ Output analysis

■ Amplitude

The measurements in each category are shown in the following table:

Switching
analysis

Timing
analysis

Magnetics Input analysis Output
analysis

Amplitude

Switching Loss Pulse Width Inductance Power Quality Line Ripple High
Hi-Power
Finder

Period Magnetic Loss Current
Harmonics

Switching
Ripple

Low

SOA Duty Cycle Magnetic
Property

Total Power
Quality

Spectral
Analysis

High Low

SOA X-Y
(DPX)

Frequency Ivs ∫V In Rush
Current

Turn-On Time Cycle Min

dv/dt Skew  Input
Capacitance

 Cycle Max

di/dt   Voltage
Harmonics

 Cycle Pk-Pk

RDS(on)     

Select the measurements and configure the measurement settings, the waveform
source, and the probe settings. Click the Results tab for statistical results.
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Source configuration Source configuration panel. The following image shows the source configuration
panel.
 

 

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components are used within their ratings. Refer to the General Safety Summary.

Follow these steps to configure the options in the source configuration panel:

1. Select the Ref option to use a reference waveform of the oscilloscope. Select
the Ch option to acquire the waveform from the unit under test. The default
selection is Ch1.

■ If you select the Live source, the default Voltage source is Ch1 and the
Current source is Ch2. The available selections are: Ch1, Ch2, Ch3, Ch4,
Math1, Math2, Math3 and Math4. The Math selections are available only
if you select Live and not Ref channels. Use the buttons in the Voltage
and the Current field to select specific channels. Ripple supports REF.
Except for SOA X-Y( DPX) all measurements support both REF and
Live channels. You do not have the Math selections here.
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■ If you select the Ref option, the default Voltage source is Ref1 and the
Current source is Ref2. Use the buttons in the Voltage and the Current
field to select specific channels.

NOTE. When Math is chosen as a voltage source, it should be
independent of the selected math destination. The math destination is
defined with a predefined function only if the selected math destination is
independent of any selected measurement or any math definition. User
cannot select the same channel source in the Voltage and Current field.
Example: If you select Ch1 in the Voltage field and Ch1 in the Current
field and select Run, the application displays an error message "Conflict
in selection of voltage source and current source." The Voltage and
Current source selection is dependent on the measurement selected.

Double-click the Vg Level field and use the keypad that appears to enter the
values. The acceptable range of Vg values are 0 V to 50 V and the default
value is 1.5 V, if you have selected the Vg option in Source configuration
window. You can change the default value of the start of switch ON when
you select the gate voltage. The default value is 5% of the maximum of Vg or
1.5 V of Vg, whichever is lower.

2. Press the Vert Scale, Horiz Res, or Vert & Horiz buttons in the Source
Autoset panel to automatically set the scale and resolution to the best settings
for the measurement.

3. Press Undo in the Source Autoset panel to revert to the last autoset operation.
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Source autoset. Source Autoset automatically adjust the oscilloscope vertical and/
or horizontal settings according to the measurement group for the live sources
(Ch1-Ch4). The Source Autoset panel includes the following buttons:

■ Vert Scale

■ Horiz Res

■ Vert & Horiz

■ Undo

Clicking Vertical Scale automatically checks the peak-to-peak level of live
sources. The vertical scale and offset of the signals with peak-to-peak value less
than six divisions are adjusted to eight divisions. If the maximum or minimum
value of a signal is clipped, the vertical scale and offset are adjusted so that the
peak-to-peak value is eight or higher divisions. An error message is displayed
when clipping is detected.

Clicking the Horiz Res adjusts the time base for live channels so that at least
10 complete cycles for very low frequency (200 Hz) and more cycles for higher
signal frequencies are displayed. The measurements in Switching Loss,
Modulation Analysis and Magnetic Property set up the oscilloscope in similar
way. The measurements such as Spectral, Line Ripple, and Switching Ripple
under Input and Output Analysis set up differently, Since the horizontal time base
is set based on the Resolution Bandwidth (RBW) and ripple frequency.

Clicking Vert & Horiz defines the vertical and the horizontal settings for all
channel sources. It also applies autoset on each channel before performing the
vertical scale and horizontal resolution autoset.
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NOTE. Autoset accounts for the deskew value. If the deskew value is less than the
sample interval set by autoset, then the deskew value is rounded to 0.0 s by the
oscilloscope. This can be seen in the Vertical >Deskew menu. In this situation, it
is recommended that you use a higher sample rate.

Selecting and configuring
measurements

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Click SOA in Switching Analysis tab.

Follow the steps to use the SOA Mask Editor:

1. Select the Enable check box in the Mask pane to apply the mask to the SOA
plot.
 

 

2. Double-click the Mask X and Mask Y fields and use the keypad that appears
to set the XY coordinates of mask values.

■ Click the Add button to add the mask values as a new mask point.

■ Click the Update button to update the selected mask point with the new
mask values.

■ Click the Recall button to retrieve a saved mask from the default
directory or the directory where you have saved the mask.
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3. Click the Graph button to preview the mask.
 

 

4. Configure SOA and click Run to display the SOA Plot with the mask in the
background.
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5. Select scale as Log and follow steps 1 to 4 to generate a mask for log.
 

 
 

 

6. Click the Save button to save the mask in .msk file. The default directory is
C:\User\Public\Tektronix\TekApplications\Advanced Power Analysis\SOA
Mask\. The SOA plot displays the Pass/Fail region in different colors.

7. Mask can be created graphically by clicking Graph button or by entering
coordinates in the mask editor.

In Graph mode, you can construct the graph by free hand drawing using
mouse clicks. Once the drawing is completed click Apply.
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8. Click the close button and you can observe the mask editor is filled with
mask points which are from the Graph.

9. You can switch between Log and Linear Mask creation, by selecting the
appropriate buttons.

You can set the Mask Values and define a mask. Select the Clear button to
remove the selected mask point, select the Clear All button to remove all mask
points.

Configuring global
settings

The Global tab settings apply to all measurements.
 

 

In the Global tab make the following settings:

■ Set the coupling: AC or DC.

■ Select the bandwidth limit from the Bandwidth limit pane: 20 MHz,
250 MHz or the Full option. The Full option refers to the maximum
bandwidth available in an oscilloscope. These options may not be available
on all supported oscilloscopes. Please refer to your oscilloscope bandwidth
options.

■ Turn cursor gating On or Off: Select On to enable gated measurement to
analyze a specific section of the waveform. When you enable Cursor Gating
and then click Run or Single, the application displays a message “Place the
cursors at the appropriate region of the waveform". Position the cursor as
required. If you select Yes, the application analyzes and plots the time trend
of the selected section of the waveform between the cursors.

■ Select the acquisition mode: Hi Res, Average, or Sample mode. When
average mode is selected, you can change the average value (in the
oscilloscope Horizontal acquisition menu). By default the average value is set
to 16.
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Configuring options To set the Units, Ref Level, Hysteresis, Log Switching Cycles, Signal Condition,
and Filter Current, select the Options tab.
 

 

1. Enable the Signal Condition option. If you enable the Signal Condition
option, the application resets the switch current to zero after the switch OFF
to the next switch ON. If you select the Filter Current option, the switch
current has ringing at the low levels during switch ON.

2. Enable the Filter Current option. If you select the Filter Current option, the
switch current has ringing at the low levels during switch ON. The default
value is 5% of the maximum of Vg or 1.5 V of Vg, whichever is lower.

3. Enable the Log Switching cycles to log the switching cycles in a .csv file.

4. Select the Percentage option in the Units drop-down menu to set the Ref
Level, Hysteresis, V-Level, and I-Level values as a percentage or the
Absolute option to set the absolute value of the peak-to-peak signal.

5. Double-click the Ref Level field and use the keypad that appears to set the
absolute or the percentage of the ref level value.

6. Double-click the Hysteresis field and use the keypad that appears to set the
absolute or the percentage of the hysteresis value.

Configuring edges To set the edge polarity, select the Edges tab and select either Positive or
Negative polarity.
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Control panel The Control Panel appears on the right of the application window. Using this
panel, you can start or stop the sequence of processes for the application and the
oscilloscope to acquire information from the waveform. 
 

 

The control panel includes Show Plots when a plot is selected:
 

 

The following list describes each of these controls:

■ Clear clears the current result display and resets any statistical results and
autoset ref levels

■ Recalc runs the selected measurements on the current acquisition

■ Single initiates a new acquisition and runs the selected measurements

■ Run initiates a new acquisition and runs the selected measurements
repeatedly until Stop is clicked. Run is used only for live sources

■ Show Plots displays the plot summary window. This button appears in the
control panel only when a plot is selected
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Switching measurement and analysis

Switching loss Selecting and configuring measurements-Switching loss.

1. From the oscilloscope menu bar, Select Analyze > Advanced Power
Analysis, and then press the Select navigation tab to display the default
screen.

2. Click Switching Analysis to display the Switching Analysis screen.

3. Click Switching Loss in the Switching Analysis pane. Click Configure.

NOTE. Perform vertical and horizontal source Autoset for optimal signals.

NOTE. We recommend you to use the Hi-Res acquisition mode to analyze
switching loss.

1. The Switching Loss option calculates the amount of power dissipated across
the switching device under the steady state of operation. The results vary
according to the selected measurement.

2. Configure the parameters by clicking the Type, On-Off Level, Options, and
Global tabs.

Switching loss
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Switching loss edge source.

In the Edge Source pane, follow the steps given to configure the Switching Loss
Control Signal parameters:

1. The Edge Source is the Voltage source configured in the Source
Configuration Panel.

The application identifies:

■ The edges on the switch voltage

■ The Switch On and Switch Off portions using the switch voltage and
switch current

2. Select the Percentage option in the Units drop-down menu to set the Ref
Level and Hysteresis values as a percentage or the Absolute option to set the
absolute value of the peak-to-peak signal.

3. Double-click the Ref Level field and use the keypad that appears to set the
absolute or the percentage of the ref level value or double-click the
Hysteresis field and use the keypad that appears to set the absolute or the
percentage of the hysteresis value.

If the measurement is successful, the application automatically displays the
results.
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Switching loss type. In the Type tab, use the following steps to configure the
Switching Loss parameters:

1. In the Device pane, click the User button to enable the switching device type
options. Select either the MOSFET or the BJT / GBT switching device. If
you select MOSFET, double-click the RDS field and use the keypad that
appears to enter the RDS value that is available in the data sheet, for the
specified temperature of operation. If you select the Auto button, the
application calculates the total power loss and energy using the switch
voltage and current and checks for the vertical scale of the switch voltage. If
the switch voltage scale is greater than ten volts per division, the application
displays a warning message: "Vertical Scale of Switch Voltage > 10 V and
the user defined RDSon is not selected. So the calculated energy and loss
may not be accurate."

When PFC is selected, application sets up the oscilloscope to acquire at least
20 milliseconds duration or at least two cycles of line frequency (50 or
60 Hz). For more details about PFC type, Click here
 

 

If the measurement is successful, the application automatically displays the
results.

NOTE. When PFC type is selected, it turns ON the Cursor gating. When PFC type
is unchecked, the cursors will retain the previous state. Users can use Global
configuration to control the cursors ON and OFF.
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Switching loss TOn and TOff ref levels. In the TOn and TOff Levels pane, follow
the steps to configure the Switching Loss TOn and TOff RefLevel (V-level and I-
level) parameters:
 

 

1. Select the semiconductor type (DUT) from the Device drop-down menu. The
available options are: N-Channel and P-Channel. In an N-Channel device, the
Switch Voltage, Switch Current and the Gate Voltage are positive. In a P-
Channel device, the Gate Voltage can either be positive and negative or only
negative.

2. Select the Percentage option in the Units drop-down menu to set the Ref
Level and Hysteresis values as a percentage or the Absolute option to set the
absolute value of the peak-to-peak signal.

3. Double-click the V-Level field and use the keypad that appears to set the
absolute or the percentage of the V-level value. The V-Level value for the
Start of TOn is five percent of the switch current and for Stop of TOn is five
percent of the maximum switch voltage.

4. Double-click the I-Level field and use the keypad that appears to set the
absolute value or the percentage of the I-level value.

5. Select the math destination from the drop-down menu. The default
destination is Math1.

NOTE. When switching current or voltage amplitude varies in an envelope shape.
The TOn and TOff levels should be in Absolute Units for accurate results.

If the measurement is successful, the application automatically displays the
results.
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Switching loss - Autocalc loss without Vg. Select Autocalc loss without Vg for
automatic computation of switching loss without using gate voltage source. User
can configure V-Level and I-Level in OnOffLevel tab (percentage units) to define
the start and stop of loss regions. The V and I levels is updated in Absolute Units
and Optimal Reflevel in Options tab, after the Run. 
 

 

Table 1: Settings disabled when Autocalc loss without Vg is selected

Configuration tab Settings
OnOffLevel V-Level when Units is Absolute

I-Level when Units is Absolute
Options Units

Edge RefLevel
Filter Current
Signal Condition

Type PFC Type

NOTE. Make sure the record length is 10K, having 10 switching cycles.

NOTE. Gate Voltage(Vg) in source configuration is disabled when Autocalc is
selected.

NOTE. This method is not recommended for PFC type.

This method is recommended, when switching voltage is ringing in nature and
switching current has spikes. However when both voltage and current have very
bad ringing as shown in the following figure, then it is suggested to use gate
voltage source for correct results.
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Switching loss options. In the Options tab, follow the steps to configure the
Switching Loss Options parameters:
 

 

1. If current signal has ringing at low level during Switch-ON, enable the Signal
Condition and Filter Current Options. The default value is 5% of the
maximum of Vg or 1.5 V of Vg, whichever is lower.

2. Select the Percentage option in the Units drop-down menu to set the Ref
Level and Hysteresis values as a percentage or the Absolute option to set the
absolute value of the peak-to-peak signal.

3. Double-click the Ref Level field and use the keypad that appears to set the
absolute or the percentage of the ref level value.

4. Double-click the Hysteresis field and use the keypad that appears to set the
absolute or the percentage of the hysteresis value.

5. To globally set the coupling, bandwidth limit, cursor gating, and acquisition
mode, see Configuring global settings.

6. Press Run to acquire the data.

If the measurement is successful, the application automatically displays the
results.

NOTE.
■ It is not recommend to use cursor position in SW Cycle in case of noisy VG

source and plot may not place the cursors properly.
■ It is recommend for Switching loss measurement for PFC and other

topologies to have at least 10 complete switching cycles to measure properly.
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Switching loss - PFC. This section describes the flow when you run the
measurement with PFC selected.

1. Application allows you to place cursors for region of interest.
 

 

2. It suggests using gate voltage for PFC signals.
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3. If the application detects ringing with Vg and pops up error message, then
adjust REF level as described in REF level computation for noisy VG source.
 

 

4. By observation Switch voltage is good, so change to Vds and then run the
measurement.
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Switching Loss PFC - Cursor gating. Cursor gating is used to ensure that the
switching loss measurements represent the losses across all of the switching
cycles within an integer number of line-voltage-half-cycles, usually one half-
cycle of line period frequency. For AC/DC switching power supply, designers
design heat sink to remove all heat energy dissipated by the device under steady
state operation. This dissipated heat is proportional to the measured loss across
the device. During initial phase, the current will be very low and the switching
voltage is in DC mode. So the average loss is measured for region of interest that
is for one line period of the acquired waveform.

The cursors should be placed near the zero crossings of the line voltage such that
time duration of half cycle of 50/60 Hz is covered. Place the cursors, by zooming
the switching waveforms and observe where the current goes to zero. By placing
the cursors near the zero crossing of the line voltage, the exact cursor placement
is less critical because the switching losses are lowest around the line voltage
zero crossings, and any measurement errors are minimized. You can make sure
half a cycle region of 100/120 Hz between the cursors.

Switching waveforms where the current goes to zero
 

 

Switching waveforms with cursors near zero crossing
 

 

It is recommended to use gate voltage as edge source in case of PFC topology for
post-processing. The switch voltage can vary in duty cycle and operating
frequency as shown in the following image. The switch voltage can operate in
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both continuous conduction mode and discontinuous conduction modes, hence
switching cycle cannot be identified using the switch voltage. So the gate drive
signal is used to identify the correct switching cycles and also the gate voltage
will be a clean pulse and does not have ringing as it is from IC.

The following figure shows the duty and frequency variation. Ref1 is the switch
voltage captured across the switching device and Ref2 is the gate drive signal.
Ref1 goes into discontinuous conduction mode within the switching cycle.
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Viewing results-Switching loss. Do not disturb the oscilloscope settings during the
post analysis of the results. Changing settings will put the oscilloscope into
Preview mode. This could lead to incorrect interpretation of results.

Select Analyze > Advanced Power Analysis > Results, from the oscilloscope
menu bar, and then press Current for current results. Current results show
statistics of Total Average Loss values,
 

 

Select Analyze > Advanced Power Analysis > Results, from the oscilloscope
menu bar, and then press Detailed for detailed results. Detailed result shows
TON, TOFF and Conduction loss and energy statistics.
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The application displays the results for the Switching Loss measurement in two
panes: Power Loss and Energy.

1. In the Power Loss column, the Min field displays the minimum loss in the
acquisition in Watts. The Max displays the maximum loss in the acquisition
in Watts. The Average Loss is the sum of TOn average, TOff average and the
Conduction Loss.

2. In the Energy column, the Min field displays the minimum of all the energy
values calculated for each cycle. The Max field displays the maximum of all
the energy values calculated for each cycle in Watts. The Average energy
displays the sum of TOn energy, TOff energy and the Conduction energy in
Joules.

NOTE. Total Avg in the Detailed result tab includes conduction loss and is
computed result for entire acquisition.

NOTE. Negative switching loss results may be due to the DC offset in the voltage
and current probes used. To avoid this, compensate the probes for DC offset and
also run Signal Path Compensation option (SPC) on the oscilloscope before
starting the application. Make sure to use only DC coupling.

NOTE. Gate voltage is recommended as edge source for PFC and topologies such
as Flyback technologies as application is not able to compute edges on Switching
Voltage and Current waveforms due to ringing which leads to false edges.
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NOTE. The TOn and TOff definitions for switching loss measurements when gate
voltage is selected are as follows:

■ TOn is defined as the time from the gating signal turns on to the time that the
switching device turns on.

■ TOff is defined as the time from the gating signal turns off to the time that the
switching device turns off.

Switching loss plots. If the Switching ON OFF plot is selected, click Show Plots
to display the plot.
 

 

The Plot View allows you to view the plots for all cycle and single cycle based
table values.

■ All SW Cycles: Displays the plots for all cycle table values.
■ SW Cycle: Displays the plots for the selected Cursor Position:

■ Cycle: The selected switching cycle is zoomed and the scope cursors are
placed between start of Turn-on and stop of Turn-off.

Switching Loss plot when Cursor Position > Cycle is selected
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■ OnLoss: The selected switching cycle Turn-on loss is zoomed and the

scope cursors are placed between start and stop of Turn-on loss region. .

Switching Loss plot when Cursor Position > OnLoss is selected
 

 
■ OffLoss: The selected switching cycle Turn-off loss is zoomed and the

scope cursors are placed between start and stop of Turn-off loss region. .

Switching Loss plot when Cursor Position > OffLoss is selected
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■ ConductionLoss: The selected switching cycle conduction Loss is

zoomed and the scope cursors are placed between stop of Turn-on and
start of Turn-off. .

Switching Loss plot when Cursor Position > ConductionLoss is
selected
 

 

 Advanced power measurement and analysis

Advanced Power Analysis 81



NOTE. The Plot View and the Marker Value table for Switching loss plots is
displayed in Details view.

NOTE. Sometimes plot view for selected cycles show either ON or OFF region
only. This happens with PFC waveforms when you select 50 / 60Hz region. Load
PFC waveforms, and select cursors at 120Hz region, RUN the measurement, to
get plot and results. I n plot view to individual cycles, observe that only OFF
cycle is present since there is no ON loss or zero ON loss on the time domain
waveform or vice versa. So you will not see ON-OFF pair in the plot.

See also.  
Selecting and configuring measurements-Switching loss

Plot components and features
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Troubleshooting switching loss results.

The figure on the left shows the current waveform of a switching device. The
figure on the right shows the zoomed signal. During Turn On of the switch
current, a spike occurs as shown in the previous figures. If you configure the I-
value in the TOn and TOff tab to 5 %, during analysis, the application converts
the 5% value to the absolute as the product of (5/100) and maximum of the
switch current. The maximum of the switch current indicates the spike in the
signal. This is valid only during TOn. The calculated maximum switch current
value is used to identify the stop of Turn Off. Since you are using the maximum
spike values to calculate TOn and TOff, the stop of TOn value is inaccurate. To
overcome this, enter the reference value only in Absolute units.

What do you do when you get zero values in the switching loss results?
 

 

■ When you clear the Filter Current check box in the Options tab, and the
switching current waveform is similar to the one in the previous figure, the
application finds the start of Ton from the cursor 2 position. The algorithm
searches from the cursor 2 position for the configured level and logs on to the
first level. In this case, the start of TOn is calculated after the stop of Ton and
the energy and loss is zero.

■ When the configured I-level is out of the signal range, the TOn and TOff
energy and the loss is zero, the application displays a warning message.
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■ If you select the Vg option button in the Edge Finder tab, the gate voltage
should be a clean pulse without any glitch or ringing as shown in the
previous figure. The gate voltage is used to identify the edges, TOn or TOff
portions. When a glitch occurs, the application displays incorrect results. This
type of signal can result in multiple edges (wrong edges) within a switching
cycle.

 

 

If the signal (Push Pull device) is similar to the one shown in the previous
figures, configure the Ref level only at the switching portion of the voltage. The
switching occurs only at the lower portion of the switch voltage. Enter the Ref
value as 30% which falls midway between the lower switching portion.

If you have selected the P-channel device, the switching voltage and current is
negative and the gate voltage is negative or positive and negative. The
application inverts the waveform and analyzes it like the one on an N-channel
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device. Select the Vertical Setup > Invert option in the oscilloscope menu to
invert the switch voltage, current, gate, and set the device to N-channel.

Hi-Power finder Selecting and configuring measurements-Hi-Power finder.

1. From the oscilloscope menu bar, Select Analyze > Advanced Power
Analysis, and then press the Select navigation tab to display the default
screen.

2. Click Switching Analysis to display the switching analysis measurements
screen.

3. Click Hi-Power Finder in the Switching analysis pane. Hi-Power Finder
calculates the instantaneous peak power on the switching waveform. The
results vary according to the selected measurement.

4. Click Configure. You can configure the parameters by clicking the PWM
Type, On-Off Level, Edges, and Global tabs.

NOTE. The waveform height should be >8 divisions, which is possible by using
vertical Autoset, divisions to take the measurements. It is recommend that you use
the Hi-Res acquisition mode to analyze Hi-Power Finder.

Hi-Power finder.

Hi-Power finder edge source.

Follow the steps given below to configure the Hi-Power finder parameters in the
Edge Source pane:

1. The Edge Source is the Voltage source configured in the Source Selection
Panel.

The application identifies:

■ The edges on the switch voltage

■ The Switch On and Switch Off portions using the switch voltage and
switch current

2. Select the Percentage option in the Units drop-down box to set the Ref Level
and Hysteresis values as a percentage or the Absolute option to set the
absolute value of the peak-to-peak signal.

3. Double-click the Ref Level field and use the keypad that appears to set the
absolute or the percentage of the ref level value or double-click the
Hysteresis field and use the keypad that appears to set the absolute or the
percentage of the hysteresis value.

If the measurement is successful, the application automatically displays the
results.
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Hi-Power finder type. Follow the steps given below to configure the Hi-Power
Finder parameters in the Type tab:
 

 

1. Click the Variable button if a switching device operates with a variable Duty
Cycle with or without Discontinuous Conduction Mode. If the Variable
option is selected, the voltage edge source selection in the On-Off Level tab
switches to Vg (gate drive signal). If the Fixed option is selected, the
application measures the switching loss for all the topologies with a constant
duty cycle.

If the measurement is successful, the application automatically displays the
results.
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Hi-Power finder ton and toff ref levels. Follow the steps given below to configure
the Hi-Power Finder parameters in the OnOff Level pane:
 

 

1. Select the semiconductor type (DUT) from the Device drop-down menu. The
available options are: N-Channel and P-Channel. In an N-Channel device, the
Switch Voltage, Switch Current and the Gate Voltage are positive. In a P-
Channel device, the Gate Voltage can either be positive and negative or only
negative.

2. Select the Percentage option in the Units drop-down box to set the V-Level
and I-Level values in percentage of the peak-to-peak signal or select the
Absolute option to set the absolute value of V-Level and I-Level in amperes.
The V-level and I-level values should be less than the sum of the Ref Level
and Hysteresis divided by two.

3. Double-click the V-Level field and use the keypad that appears to set the
absolute or the percentage of the v-level value. The V-Level value for the
Start of Ton is five percent of the switch current and for Stop of Ton is five
percent of the maximum switch voltage.

4. Double-click the I-Level field and use the keypad that appears to set the
absolute or the percentage of the I-level value.

5. To globally set the coupling, bandwidth limit, cursor gating, and acquisition
mode, see Configuring global settings.

6. Press Run to acquire the data.

If the measurement is successful, the application automatically displays the
results.
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Viewing results-Hi-Power finder. Do not change or touch the oscilloscope settings
during the post analysis of the results. This could lead to incorrect interpretation
of results.

Follow these steps to view the results:

1. From the oscilloscope menu bar, select Analyze> Advanced Power Analysis,
and then press Results.

2. The application displays the results for Hi-Power Finder measurement as
shown below.

3. View the results of the Peak Finder and Switching Finder options.

 

 

In the Peak Finder tab options:

■ The Summary displays maximum and minimum value of the power
waveform peaks. It also displays the occurrences or positions of the On type
and Off type peaks in a single waveform.

■ In the Range panel, End and Start fields display the peaks between a range.
Double-click these fields and use the keypad that appears to enter the
numeric inputs. Click Update.

■ The Peak Value panel displays the peaks between End range and Start range
in descending order. Click Link to identify the peak portion in the voltage
and current waveform. Use the Prev button to move the cursor position to the
previous peak from the linked position. Use the Next button to move the
cursor position to the next peak from the linked position. By default, the
application positions the cursors on the first peak.
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■ Select the Zoom to zoom in at the cursor location.

In the More tab location:

■ The application displays On Time and Energy results between the cursors.
Energy is the amount of energy dissipated from On to Off of the waveform.

■ On Time is the conduction time for any switching device. You can move the
Peak Pair Cursors depending on the order of their placement.

■ Use the Prev Pair button to move the cursor to the previous cursors and the
Next Pair button to move the cursors to the next pair of cursors.

NOTE. The value displayed in population column under Current and Accumulated
result tab for Hi-Power finder is the count of number of peaks. Number of cycles
count is displayed in the Detailed result tab.

NOTE. To get effect of clicking a value in the results table, select the Link button
to associate the cursors with the time domain waveform on the oscilloscope
screen. The same steps are expected for the Zoom function to work properly.
Select the Zoom check box and then Link button to see the zoom-in operation.

NOTE. If the current waveform is less than a division high, the application
displays an error message, "Unable to find the correct edges." This is because
the variation of data points with in single division is very high and the hysteresis
band is insufficient to find the correct edges. Therefore, for the voltage
waveform, the vertical range should be greater than one division.

NOTE. Negative Switching loss results may be due to the DC offset in the voltage
and current probes used. To avoid this, compensate the probes for DC offset and
also run the Signal Path Compensation option ( SPC ) on the oscilloscope before
starting the application.

See also.  
Selecting and configuring measurements-Hi-Power finder
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RDS(on) Selecting and configuring measurements- RDS(on).

1. Select Analyze > Advanced Power Analysis, from the oscilloscope menu bar,
and then click the Select navigation tab.

2. Click Switching Analysis to display the switching analysis measurements
screen.

3. Click RDS(on) in the Switching Analysis pane. Now, click the Configure
button.

4. The following diagram shows equipment setup for RDS(on).

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General safety
summary for more information.

Figure 10: Equipment setup for RDS(on)

Configuring measurements. Follow the steps to configure the selected
measurement:

NOTE. The Ref and Deskew options are disabled in the Source Configuration
panel as dynamic resistance measures live signals.
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1. Configure the options in the Source Configuration Panel.
 

 
2. There are two methods, first method is V/I, which is a ratio of instantaneous

voltage and current samples. This is suitable for switching devices. The
second method is dV/dI, which is ratio of rate of change of voltage and
current. This is suitable for PN junctions and diodes.

The zeros and infinity values of resistance have been interpolated for both
methods.

The default method is V/I.
3. To globally set the coupling, bandwidth limit, cursor gating, and acquisition

mode, see Configuring global settings.
4. Press Run to acquire the data.

If the measurement is successful, the application automatically displays the
results.
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Viewing results-RDS(on). Follow these steps to view the results:

1. Select Analyze > Advanced Power Analysis, from the oscilloscope menu bar,
and then press Results, to view the results for the Instantaneous RDS(on) and
the Average RDS(on). Use the cursor button in the oscilloscope panel to
place the cursor.
 

 

NOTE. In some instances, the application may display the result screen with
no values. In this happens, use cursor gating to identify the region of interest.

2. Click Configure > Global and Cursor Gating On button to enable cursor
gating.

3. Click Single to measure. When prompted, manually place the cursors in the
conduction region to select the desired region of the waveform and click OK.
This causes the application to measure the on-resistance only in the selected
portion of the waveform.

4. The application displays the Destination, the Minimum, the Maximum and
the Average values of the Instantaneous RDS(on). If you select the Run
mode, the application automatically updates the resistance values in the table.

If the Time Trend plot is selected, click Show Plots to display the plot.
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See also.  
Selecting and configuring measurements-RDS(on)

Plot components and features
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di-dt Selecting and configuring measurements-di-dt. To select and configure Power
Quality Measurement, follow these steps:

1. Select Analyze> Advanced Power Analysis, from the oscilloscope menu bar,
and then press the Select navigation tab.

2. Click the Switching Analysis tab to display Switching Analysis screen.

3. Click di /dt in the Switching Analysis pane. Now, click the Configure button.

4. The next figure shows a typical equipment setup for di /dt.

WARNING. Warning: When connecting to a circuit with hazardous voltages, see
the warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General safety
summary for more information.

Configuring the measurement. Follow the steps to configure the selected
measurement:

NOTE. The Ref source, Deskew and Voltage in the Source Configuration panel is
disabled. You can configure only the Current options.

1. Configure the Current options in the Source configuration panel.
 

 
2. Select the Percentage option in the Units combo box to set the Ref Level and

Hysteresis values in percentage of the peak-to-peak signal. Select the
Absolute option in the Units combo box to set the absolute value of Ref
Level and Hysteresis values in amperes. The Ref Level is set to 50% and
Hysteresis is set to 5% by default. Configure the high and low level of the
edges using Ref High and Ref Low. Default values are set to 90% and 10%.

3. To globally set the coupling, bandwidth limit, cursor gating, and acquisition
mode, see Configuring global settings. Ref High and Low set the start and
stop regions on the rising and falling edges where this measurement will
occur.

4. Press Single to measure.
5. If the measurement is successful, the application automatically displays the

results.
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Viewing results-di-dt. To view the results, follow these steps:

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis,
and then press Results.

2. All the edge results are displayed in the results table, Rise & Fall edges are
tabulated separately.
 

 

3. Click an edge in the detailed results to associate the edge with the cursors.

Viewing plots-di-dt

If Time Trend and Histogram plots are selected, click Show Plots to display the
plot.
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See also.  
Selecting and configuring measurements-di-dt

Plot components and features
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dv-dt Selecting and configuring measurements-dv-dt.

1. From the oscilloscope menu bar, select Analyze> Advanced Power Analysis,
and then press the Select navigation tab.

2. Click Switching Analysis to display the Switching Analysis screen.

3. Click dv/dt in the Measurements pane.

4. Click the Configure button.

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General safety
summary for more information.

Configuring the measurement. Follow the steps to configure the selected
measurement:

NOTE. Ref, Current, Deskew and I-Probe Settings in the Source Configuration
panel is disabled. You can configure only the Voltage options.

1. Configure the Voltage options in the Source configuration panel.
 

 
2. Select Percentage from the Units combo box to set the Ref Level and

Hysteresis values in percentage of the peak-to-peak signal. Select Absolute
from the Units combo box to set the absolute value of Ref Level and
Hysteresis values in volts. Configure the high and low level of the edges
using Ref High and Ref Low. Default values are set to 90% and 10%.

3. To globally set the coupling, bandwidth limit, cursor gating, and acquisition
mode, see Configuring global settings.

4. Press Single to measure.

If the measurement is successful, the application automatically displays the
results.
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Viewing results-dv-dt. To view the results, follow these steps:

1. All the edge results are displayed in the results table, Rise & Fall edges are
tabulated separately.

2. Click an edges number to position the oscilloscope cursors on the High and
Low levels of the waveform and on the edge you have set. This displays the
updated results for the selected edge.
 

 

3. The application displays the results, which is a differential of the voltage
waveform with respect to time in units of volts per microsecond.

NOTE. If you observe the cursor positions on the oscilloscope screen in the
following figure, the absolute values of the signal level read by the cursor does
not match with the entered high and low levels in the result panel. This is because
the values entered in Low and High levels may lie in between the samples of the
waveform. This happens for di/dt and dv/dt measurements.

Viewing plots-dv-dt

If a Rise Edge, Fall Edge, or Histogram plot is selected, click Show Plots to
display the plot.
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See also.  
Selecting and configuring measurements-dv-dt

Plot components and features
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Safe operating area Selecting and configuring measurements-Safe operating area.

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis,
and then click the Select tab.

2. From the Switching Analysis tab, select the Safe Operating Area (SOA)
measurement. Select the Configure option.

The next figure shows a typical equipment setup for Safe Operating Area.

Figure 11: Equipment setup for Safe Operating Area

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the General safety
summary topic for more information.

Configuring measurements. Follow the steps to configure the selected
measurement:

1. Select SOA.

Figure 12: SOA configuration
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2. Configure the options in the Source Configuration Panel.

NOTE. Make sure there are waveforms on the oscilloscope or the application
displays an error message.

Plot Type Description
SOA Plots the Voltage and Current waveform in a single record in XY

mode

3. Double-click the Mask X and Mask Y fields and use the keypad that appears
to set the XY coordinates of mask values.

4. Click the Add button to add the mask values as a new mask point.
5. Click the Update button to update the selected mask point with the new mask

values.
6. Click the Clear button to remove the selected mask point.
7. Click Clear All to remove all mask points.
8. Click the Save button to save the mask.
9. Click the Recall button to retrieve a saved mask from the default directory or

the directory where you have saved the mask.
10. Click Graph to display a preview of the mask.
11. In the Global tab, click On or Off in the Cursor Gating panel to enable cursor

gating. Press the Run or Single button. If Cursor Gating is on, the message
"Set cursors to required position" is displayed. Select OK to display the
results for the selected portion of the waveform.

12. In the Mask Pane of the Config tab, select Enable to define and apply masks
on the SOA plot. If the Enable is selected and there is no mask defined,
selecting the Run button displays a warning message, "SOA Mask is enabled,
but not defined. Do you wish to continue?". Select Yes to continue without
the mask.

13. Press Run to display the SOA plot.
14. Place the cursor on the plot to display the following results:

■ Voltage value
■ Current value
■ Power value
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Viewing results-Safe operating area. The SOA Measurement plots the current and
waveform results in the SOA Plot. Follow these steps to view the results:

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis,
and then click Results.

2. The application displays the SOA results as shown below:

SOA results
 

 
3. Click Plot to display the SOA0 plot.

SOA plots
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SOA Plot gives information about current vs voltage waveforms and mask.
When user selects the point on SOA plot, it creates the list of points nearby
region and updates the Marker value Table. It also zoom the region on scope,
where this points present in time domain. User can travels through Marker
Value Table points in various cycles. It allows to analyze waveform region
on oscilloscope, where waveform violates the mask coordinates.

4. In the Global tab, click On or Off in the Cursor Gating panel to enable cursor
gating. Press the Run button to display the message, "Set cursors to required
position."

5. Select Yes to run the application. The Cursor Linkage allows you to locate
the point in a SOA plot to the time domain waveform and link the data index
of the waveform. Place the cursor at the region of the waveform you want to
plot SOA and display the plotted area.

6. Select the Detailed tab. Click Plot to display the plot.

7. Click Save to save the plot data in .csv format. The default directory and the
file name is C: \User\Public\ TekApplications \Advanced Power Analysis\.

NOTE. When you change from Linear to Log-Log, the mask does not get
converted between Linear and Log-Log scales. However plot data does get
converted when Linear to Log or Log to Linear is changed.

NOTE. If the Cursor control button is enabled, the zoom buttons are disabled.

8. Place the Cursor to select any data point in the plot.

9. Click the + button to zoom in. Drag the mouse to define the area of interest.
Click the – button to zoom out. You can use the + and – buttons until the
application reaches the maximum and the minimum zoom limit. You can use
the Zoom buttons in three different ways:

■ Dragged zoom-in: where the area is selected by dragging on the
displayed window

■ Single-clicked zoom-in: when a point is clicked on the displayed
window, the resulting window is equal to 1/4th of the displayed window.

■ Single-clicked zoom-out: when a point is clicked on the displayed
window, the resulting plot is the previous zoom state of the displayed
window.

10. Select the Reset Display option to restore the plot to its original display after
zooming.

11. Use the cursor in the oscilloscope and the Link button to link the waveform
from the SOA plot. When you select the Link button, the plot automatically
resizes to the half screen mode. The Link Cursor Position field displays the
number of occurrences of the particular data points. Here minimum is 1 and
maximum is the number of occurrences of data points.
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12. Place the cross hair cursor at the point of interest on the plot and press the
Link button. This enables the cursor on the oscilloscope and places it on the
waveform corresponding to the selected data point in the plot panel.

13. In case of multiple occurrences, select the Prev button to select the previous
data point and the Next button to select the next data point.

14. You can view the plot and the time domain waveform simultaneously. Select
the Link check box to select the data point to link the waveform in the
oscilloscope to the SOA Plot. Place the cross hair cursor on the plot and enter
the values in the Cursor Linkage Occurrences field. Use the Zoom button to
zoom the area of interest in the plot and display in the oscilloscope.

NOTE. You can view the result either in the half screen mode or in the full
screen mode.

15. The application displays the result for Voltage, Current, Power, Mean Power
and Standard Deviation at the cursor location.

See also.  
Selecting and configuring measurements-Safe operating area

Plot components and features
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SOA overlay. Select the Save Plot button in the SOA Graph plot from the Detailed
results window to save the plot as a . plt file before using this utility.

Purpose: Plot, view, and compare SOA Plots of the device operating at various
load conditions. The SOA Overlay utility helps you to overlay multiple SOA
plots simultaneously. Use this feature to view multiple plots on the same grid.

Initially, the application adjusts the SOA scale according to the selected plot(s)
but you can also observe the plot for the voltage and current range of operation
under various conditions.
 

 

The X-axis represents the voltage values in volts and the Y-axis represents the
current in amperes.

Follow these steps to perform SOA Overlay:
1. Click the Recent button to automatically load the SOA plots saved in the

current run of the application.

You can load only the last ten plots. Select the Recall button to manually load
the SOA plots from any folder or from the default folder C: \Users\Public
\Tektronix\TekApplications\Advanced Power Analysis\SOA\Data directory.
You can load any of the ten plots.

2. Click the Plot selection check box next to the plot name to display the SOA
plot on the grid area of the screen. When the utility displays the first plot, it
automatically scales the plot. Continue this procedure to overlay and display
all the plots. SOA Overlay displays the plot based on the color set in the Plot
Name pane. The most recently selected plot is drawn over the previously
selected plots. You can simultaneously view and compare different SOA
plots under multiple conditions.

3. Click the Plot Name and then the Clear button to remove the plot from the
grid area.
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4. Click the Clear All button to clear all the plots from the grid area.

5. Select the Save button to save the plot as a .csv file to any folder of your
choice or to the default folder C: \User\Public\ Tektronix\TekApplications
\Advanced Power Analysis\.

6. Click OK to close the display window.

SOA Saving waveforms when mask fails. In Free Run mode, if there are any
violation of SOA Mask, the failed incidents with their corresponding V, I
waveforms will be saved. The first run will save SOA mask fails at C:\Users
\Public\TekApplications\Advanced Power Analysis\MaskFail Waveforms\ Run1.
Each mask failure will save two waveforms in the RUN folder and the folder can
have maximum twenty waveform files (ten failures).

For the first twenty five runs, folders will be created and the failed incidents will
be saved to respective folder. The twenty sixth run will overwrite the first run
folder saved data i.e. Run1 with user approval and so on.

NOTE. Waveforms will not be saved if there is no enough available space to
waveform. User need to make sure there is enough available space in C drive.

Example

C:\Users\Public\TekApplications\Advanced Power Analysis\MaskFail
Waveforms\ Run1 corresponds to first run which has mask failed waveforms
saved in it.
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Safe operating area X-Y Selecting and configuring measurements-Safe operating area X-Y.

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis,
and then press the Select navigation tab.

2. From the Switching Analysis tab, select the SOA X-Y measurement. Select
the Configure option.

The next figure shows equipment setup for Safe Operating Area X-Y.

Figure 13: Equipment setup for Safe Operating Area X-Y

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General safety
summary for more information.

Configuring measurements. Follow the steps to configure the selected
measurement:

1. Select SOA X-Y.
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2. Configure the options in the Source Configuration Panel.

NOTE. Make sure that there are waveforms on the oscilloscope or the
application displays an error message.

Plot Type Description
SOA X-Y (DPX) Measures and plots the voltage and current waveforms using the XY

mode display of the oscilloscope. Use this option to measure multiple
acquisitions of the same waveform in real time testing

3. Press Run to display the SOA X-Y plot.

Viewing results-Safe operating area X-Y. The SOA Measurement plots the current
and waveform results in the SOA Plot. Follow these steps to view the results.

Viewing Results for SOA X-Y (DPX). You can view the result in the oscilloscope as
a real time plot.

NOTE. For frequencies <4 GHz, select the paired channels as Ch1 and Ch2 or
Ch3 and Ch4. For frequencies ≥4 GHz, select the paired channels as Ch1 and
Ch3 or Ch2 and Ch4.

 

 

See also.  
Selecting and configuring measurements-Safe operating area X-Y

Plot components and features
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Timing measurement and analysis

Pulse width Selecting and configuring measurements-Pulse width.

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Timing Analysis; click Pulse Width in the measurement pane.

3. Click Configure to configure the measurement.

The following figure shows equipment setup for Pulse Width analysis.

Figure 14: Equipment setup for Pulse Width analysis

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General safety
summary for more information.

Configuring the measurement.
Follow the steps to configure the Pulse Width measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Edge tab:

■ Select the Polarity by clicking either Positive or Negative.
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3. Configuration under Options tab:

■ Set the Units to Absolute or Percentage. If you select Absolute, the
application displays the Ref Level and Hysteresis in Volts.

■ Set Ref level value within the range 100 mV to 5.99 KV for absolute
units and 1% to 99% for units as percentage. The Default value is 0V and
50%.

■ Set Hysteresis value within the range 0V to 3 KV for absolute units and
1% to 99% for units as percentage. The Default value is 6V and 5%.

4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

NOTE. The application replaces any data in the selected ref destination when you
analyze and measure timing analysis. You do not get a warning message here.
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Viewing results-Pulse width. Click Results to view the result for the selected Pulse
Width measurement.
 

 

Viewing plots-Pulse width. Click Plots and select Time Trend to view the plots for
the selected Pulse Width measurement.
 

 

See also.  
Selecting and configuring measurements-Pulse width

Plot components and features
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Duty cycle Selecting and configuring measurements-Duty Cycle.

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Timing Analysis; click Duty Cycle in the measurement pane.

3. Click Configure to configure the measurement.

Configuring the measurement.
Follow the steps to configure the Duty Cycle measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Edge tab:

■ Select the Edge Type by clicking either Rise or Fall.
■ Select the Polarity by clicking either Positive or Negative.

3. Configuration under Options tab:

■ Set the Units to Absolute or Percentage. If you select Absolute, the
application displays the Ref Level and Hysteresis in Volts.

■ Set Ref level value within the range 100 mV to 5.99 KV for absolute
units and 1% to 99% for units as percentage. The Default value is 0V and
50%.

■ Set Hysteresis value within the range 0V to 3 KV for absolute units and
1% to 99% for units as percentage. The Default value is 6V and 5%.

4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

NOTE. The application replaces any data in the selected ref destination when you
analyze and measure timing analysis. You do not get a warning message here.
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Viewing results-Duty cycle. Click Results to view the result for the selected Duty
Cycle measurement.
 

 

Viewing plots-Duty cycle. Click Plots and select Time Trend to view the plots for
the selected Duty Cycle measurement.
 

 

See also.  
Selecting and configuring measurements-Duty cycle

Plot components and features
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Period Selecting and configuring measurements-Period.

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Timing Analysis; click Period in the measurement pane.

3. Click Configure to configure the measurement.

Configuring the measurement.
Follow the steps to configure the Period measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Edge tab:

■ Select the Edge Type by clicking either Rise or Fall.
3. Configuration under Options tab:

■ Set the Units to Absolute or Percentage. If you select Absolute, the
application displays the Ref Level and Hysteresis in Volts.

■ Set Ref level value within the range 100 mV to 5.99 KV for absolute
units and 1% to 99% for units as percentage. The Default value is 0V and
50%.

■ Set Hysteresis value within the range 0V to 3 KV for absolute units and
1% to 99% for units as percentage. The Default value is 6V and 5%.

4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

NOTE. The application replaces any data in the selected ref destination when you
analyze and measure modulation. You do not get a warning message here.
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Viewing results-Period. Click Results to view the result for the selected Period
measurement.
 

 

Viewing plots-Period. Click Plots and select Time Trend to view the plots for the
selected Period measurement.
 

 

See also.  
Selecting and configuring measurements-Period

Plot components and features
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Frequency Selecting and configuring measurements-Frequency.

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Timing Analysis; click Frequency in the measurement pane.

3. Click Configure to configure the measurement.

Configuring the measurement.
Follow the steps to configure the Frequency measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Edge tab:

■ Select the Edge Type by clicking either Rise or Fall.
3. Configuration under Options tab:

■ Set the Units to Absolute or Percentage. If you select Absolute, the
application displays the Ref Level and Hysteresis in Volts.

■ Set Ref level value within the range 100 mV to 5.99 KV for absolute
units and 1% to 99% for units as percentage. The Default value is 0V and
50%.

■ Set Hysteresis value within the range 0V to 3 KV for absolute units and
1% to 99% for units as percentage. The Default value is 6V and 5%.

4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

NOTE. The application replaces any data in the selected ref destination when you
analyze and measure modulation. You do not get a warning message here.

Advanced power measurement and analysis  

116  Advanced Power Analysis



Viewing results-Frequency. Click Results to view the result for the selected
Frequency measurement.
 

 

Viewing plots-Frequency. Click Plots and select Time Trend to view the plots for
the selected Frequency measurement.
 

 

See also.  
Selecting and configuring measurements-Frequency

Plot components and features
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Skew Selecting and configuring measurements-Skew.

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Timing Analysis; click Skew in the measurement pane.

3. Click Configure to configure the measurement.

Configuring the measurement.
 

 

Follow the steps to configure the Skew measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Edge tab:

■ Click From Edge as Rise, Fall or Both.
■ Click From Edge as Rise, Fall or Both and To Edge as Same as From or

Inverse of From
3. Configuration under Options tab:

■ Set the Units to Absolute or Percentage. If you select Absolute, the
application displays the Ref Level and Hysteresis in Volts.

■ Set Ref level value within the range 100 mV to 5.99 KV for absolute
units and 1% to 99% for units as percentage. The Default value is 0V and
50%.

■ Set Hysteresis value within the range 0V to 3 KV for absolute units and
1% to 99% for units as percentage. The Default value is 6V and 5%.

 

 
4. Configuration under Global tab:
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See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

NOTE. The application replaces any data in the selected ref destination when you
analyze and measure modulation. You do not get a warning message here.

See also.  
Viewing results-Skew
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Viewing results-Skew. Click Results to view the result for the selected Skew
measurement.

Viewing plots-Skew. Click Plots and select Time Trend and/or Histogram to view
the plots for the selected Skew measurement.
 

 

See also.  
Selecting and configuring measurements-Skew

Plot components and features
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Magnetics measurement and analysis

Inductance Selecting and configuring measurements-Inductance.

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Magnetics; click Inductance in the measurement pane.

3. Click Configure to configure the measurement.

NOTE. When you are measuring the inductance of a transformer, do not load the
secondary winding. The measurement of the inductance at the primary winding
under no load condition is as good as measuring the inductance for a single
winding. When you are measuring the inductance of the coupled inductor with
multiple windings on the same core, the measured value of the inductance will
deviate from the actual value due to the influence of the current on other
winding. You can use this measured value to calculate the Ripple current.

Configuring the measurement. Follow the steps to configure the Inductance
measurement:
 

 

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Edges tab:

■ Select the Edge Source from the drop-down list.
3. Configuration under Options tab:

■ Set the Units to Absolute or Percentage. If you select Absolute, the
application displays the Ref Level and Hysteresis in Volts.

■ Set Ref level value within the range -5.99 kV mV to 5.99 kV for absolute
units and 1% to 99% for units as percentage. The Default value is 50V
and 50%.
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■ Set Hysteresis value within the range 0V to 3 KV for absolute units and
1% to 99% for units as percentage. The Default value is 5V and 10%.

 

 
4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

NOTE. The application replaces any data in the selected ref destination when you
analyze and measure Magnetics. You do not get a warning message here.
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Viewing results-Inductance. Click Results to view the result for the selected
Inductance measurement.
 

 

Viewing plots-Inductance. Click Plots and select Inductance curve to view the
plots for the selected Inductance measurement.
 

 

See also.  
Selecting and configuring measurements-Inductance
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Magnetic property Selecting and configuring measurements-Magnetic property.

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Magnetics, and then click Magnetic Property in the measurement pane.

3. Click Configure to configure the measurement.

Configuring the measurement. Follow the steps to configure the Magnetic
Property measurement:
 

 

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Source tab:

■ Select the Voltage Source from the drop-down list and select the Freq
and Duty as Fixed or Variable.

NOTE. For the Variable operation, connect the gated drive signal to the edge
source because the amplitude of the voltage acquired across the inductor will
vary with time.

3. Configuration under Physical Chars1 tab:

■ Select the Units as SI or CGS from the drop-down list. If you select SI,
the dimensions of the component are measured in meters and units of
magnetics in Tesla and Amperes or Turns per meter. If you select CGS,
the unit of measurement is centimeter and the result units are in Gauss
and Oersted.

■ Double-click the Cross Section Area field and use the keypad that
appears to set the cross section dimensions of the magnetic component.
The acceptable ranges of the Cross Section Area values are:

■ 1 nm2 to 1 Mm2 for SI
■ 1 ncm2 to 1 Mcm2 for CGS

■ Double-click the Magnetic Length field and use the keypad that appears
to set the cross section dimensions of the magnetic length component.
The acceptable ranges of the Cross Section Area values are:

■ 0 m to 1 Mm if you have selected SI
■ 0 cm to 1 Mcm if you have selected CGS
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4. Configuration under Physical Chars2 tab:

■ Click the Single button for a single winding and enter the number of
primary turns.

■ Go the step 5 for further configuration.
■ Click the Multiple button to configure the "Secondary Windings"

NOTE. Magnetic Property with "Multiple" winding configuration cannot
be group to run with other measurements. Only one instant of the
measurement allow to add with this configuration.

■ Configure for the Two "#of winding" : Measure the magnetic
property of the components having windings like a coupled inductor
or transformer that has multiple windings on the same core.
 

 

■ Select the Secondary Winding1Source from the drop-down menu
and enter the number of turns in the " # of Turns" field.

■ Select the Secondary Winding2Source from the drop-down menu
and enter the number of turns in the # of Turns filed or select
Unused from the Winding2Source drop-down menu in case of
having single winding on secondary side.

■ Follow the connection combinations of the voltage and current
probe at the primary or the main winding at the secondary or the
other windings to the · dot as shown in the next figure. The
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voltage probe should be connected so that the voltage is read as
positive when the current rises.
 

 

WARNING. When connecting to a circuit with hazardous
voltages, see the warnings for the individual products and verify
that the probes and other components used are within their
ratings. Also refer to the topic General safety summary for more
information.

■ In the Magnetising Current combo box, select the Ref channel to
view the net magnetizing current.

NOTE. In case of Ref configuration, selected net "Magnetising
Current" source displays over the Ref source on the
Oscilloscope. In free Run, the net Magnetising Current gets
disabled.

■ Configure for the More "#of winding": If you do not have a current
probe to acquire the waveform simultaneously on two windings,
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select the Multiple Windings pane and follow the procedures given
below:

■ Select More from the "# of Winding" drop-down menu. This
disables the "Secondary Windings" sources.

■ Press the Run button in the application.

The application acquires the voltage and current waveform of the
main winding and prompts you to select a current probe to the
Secondary winding. Click Next button if you have another
winding.

■ Connect the current probe to the other secondary winding. Set #
of Turn in the pop up message box and click Next button.

■ Click Ignore button, if you want to ignore the selected secondary
winding. This RUN the measurement.

■ In the Magnetising Current combo box, select the Ref channel to
view the net magnetizing current.

NOTE. In case of Ref configuration, selected net "Magnetising
Current" source displays over the Ref source on the Oscilloscope.
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NOTE. Selecting Variable duty cycle enables Cursor Gating even if the
Cursor Gating selection is Off.

5. Configuration under Options tab:

■ Set the Units to Absolute or Percentage. If you select Absolute, the
application displays the Ref Level and Hysteresis in Volts.

■ Set Ref level value within the range -5.99 kV mV to 5.99 kV for absolute
units and 1% to 99% for units as percentage. The Default value is 50V
and 50%.

■ Set Hysteresis value within the range 0V to 3 KV for absolute units and
1% to 99% for units as percentage. The Default value is 5V and 10%.

 

 
6. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

7. After configuration, navigate to the Source Configuration dialog box and
then click Vert&Horiz button. It setups the scope channels as per the
configuration.

8. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

NOTE. The application replaces any data in the selected ref destination when you
analyze and measure Magnetics. You do not get a warning message here.
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Viewing results-Magnetic property. Click Results to view the result for the selected
Magnetic property measurement.
 

 

Field Description
Bpeak The maximum magnetic flux density induced in a magnetic

component.
Br The induced magnetic flux density (B) that remains in the

material after the externally applied magnetic field (H) is returned
to zero while generating the hysteresis loop. Here the maximum
value of the Br on the Bpeak cycle is measured.

Hc The value of H at the intersection of the H-axis and the
hysteresis loop. This represents the external field required to
cause the induced flux density (B) to reach zero during while
measuring a hysteresis loop. Hc is symmetrical with the positive
and the negative H-axis.

Hmax The maximum value of H at the intersection of the H-axis and the
hysteresis loop.

I-ripple The peak-to-peak value of the current.
ΔH The magnetic field strength
ΔB The magnetic flux density
Permeability The measure of the ability of a material to support the formation

of its Magnetic field in electromagnetism.
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Viewing plots-Magnetic property. Click Plots and select BH curve to view the plots
for the selected Magnetic property measurement.
 

 

1. Use the Cursor buttons to place the cursor on the maximum flux density
curve. Cursor1 and Cursor2 help you calculate the permeability, delta B,
delta H on the region of interest on the maximum flux density curve.

2. The Bpeak button toggles between Bpeak Cycles and All Cycles. When the
Bpeak is selected, you can see only the two Bpeak cycles that have the
maximum flux density. If the Bpeak is not selected, you can see all the cycles
for the component.

3. Click the + button to zoom in. You can zoom up to five times the normal
view. Drag the mouse to define the area of interest. Click the – button to
zoom out. You can use the + and – buttons until the application reaches the
maximum and the minimum zoom limit. You can use the Zoom buttons in
three different ways:

■ Dragged zoom-in: where the area is selected by dragging on the
displayed window.

■ Single-clicked zoom-in: when a point is clicked on the displayed
window, the resulting window is equal to 1/4th of the displayed window.
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■ Single-clicked zoom-out: when a point is clicked on the displayed
window, the resulting plot is the previous zoom state of the displayed
window.

NOTE. If the current waveform is less than a division high, the application
displays an error message, "Unable to find the correct edges". This is
because of the variation of data points within single division is very high and
hysteresis band is insufficient to find the correct edges. Therefore, for the
current waveform, the vertical range should be greater than one division.

4. Select the Reset option to restore the plot to its original display after
zooming.

See also.  
Selecting and configuring measurements-Inductance

Magnetic loss Selecting and configuring measurements - Magnetic loss.
1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.

The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Magnetics; click Magnetic Loss in the measurement pane.

3. Click Configure to configure the measurement.

Configuring the measurement. Follow the steps to configure the Magnetic loss
measurement:
 

 
1. Configure the Source configuration for the measurement. Click  for the

measurement for source configuration.
2. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

3. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

NOTE. The application replaces any data in the selected ref destination when you
analyze and measure Magnetics. You do not get a warning message here.
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Viewing results-Magnetic loss. Click Results to view the result for the selected
Magnetic loss measurement.
 

 

I vs (integral-of)V Selecting and configuring measurements - I vs ∫V.

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Magnetics; click I vs ∫V in the measurement pane.

3. Click Configure to configure the measurement.

Configuring the measurement. Follow the steps to configure the Magnetic
Property measurement:
 

 

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

3. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

NOTE. The application replaces any data in the selected ref destination when you
analyze and measure Magnetics. You do not get a warning message here.
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Viewing results - I vs ∫V. Click Results to view the result for the selected I vs ∫V
measurement.
 

 

Viewing plots - I vs ∫V. Click Plots and select I vs ∫V to view the plots for the
selected Magnetic property measurement.
 

 

1. Click the + button to zoom in. Zoom up to five times the normal view. Drag
the mouse to define the area of interest. Click the – button to zoom out. Use
the Zoom In and Zoom Out buttons until the application reaches the
maximum and the minimum zoom limit. You can use the Zoom buttons in
three different ways:

■ Dragged zoom-in: Here the area is selected by dragging on the displayed
window.
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■ Single-clicked zoom-in: When a point is clicked on the displayed
window, the resulting window is equal to 1/4th of the displayed window.

■ Single-clicked zoom-out: When a point is clicked on the displayed
window, the resulting plot is the previous zoom state of the displayed
window.

2. Select the Reset option to restore the plot to its original display.
3. Use the cursor in the Hits field to display the number of cursor hits at

selected data points. When you place the cross hair icon on the I vs ∫V plot
and if multiple occurrences of the data points exist at the same position, the
values are displayed in the Hits field.
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Input measurement and analysis

Power quality Selecting and configuring measurements-Power quality. To select and configure
Power Quality Measurement, follow the steps:

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Input Analysis; click Power Quality in the measurement pane.

3. Click Configure to configure the measurement.

The following figure shows equipment setup for Pulse Quality analysis.

Figure 15: Equipment setup for Pulse Quality analysis

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General safety
summary for more information.

Configuring the measurement. Follow the steps to configure the Power Quality
measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.
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2. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.
 

 
3. Click Run to acquire the data. If the measurement is successful, the

application displays the results.
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Viewing results-Power quality. Click Results to view the result for the selected
Power Quality measurement.

Viewing plots-Power quality

Click Plots and select V*I Power Waveform and/or ∫ (V*I) Energy Waveform to
view the plots for the selected Power Quality measurement.
 

 

See also.  
Selecting and configuring measurements-Power quality

Plot components and features
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Current harmonics Selecting and configuring measurements-Current harmonics. To select and
configure Current Harmonics Measurement, follow these steps: Configuring the
measurement

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Input Analysis; click Current Harmonics in the measurement pane.

3. Click Configure to configure the measurement.

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings.

NOTE. If you are using the same voltage source as used for any previous
measurement, you can skip the procedure for configuring the common
configuration options.

Follow the steps to configure the Current Harmonics measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Standard tab:

■ Select the Type as international EMC (Electro Magnetic Compatibility)
standards 61000-3-2, AM 14 and MIL 1399 for which you can perform
compliance test.
 

 

Click this hyperlink to see what the application does if you select the
61000-3-2 standard.

Follow these steps to configure the 61000-3-2 Standard configurations:

a. Click the 61000-3-2 button in the Type pane. By default Line frequency is
Auto which calculates input signal frequency automatically. Line frequency
can be set to 50Hz, 60 Hz or Custom. Custom frequency value can be set

Advanced power measurement and analysis  

138  Advanced Power Analysis



between 1 Hz and 4 KHz. Harmonics Order is 40 by default. Harmonics
order can be set between 40 to 100.
 

 

NOTE. Source Autoset takes input from Line Frequency and Harmonic Order.
To set the minimum acquisition of ten cycles of line frequency, run the source
autoset Vert & Horiz.

b. In the Harmonics Table tab, use the Harmonics drop-down box to select the
table and click the Edit button to edit the table. The values in these tables are
used as Limit values.

c. Select any one of the ten available Tables. Table 1 is the default table. If you
select the harmonic table, the application displays the class associated with it
in the Class drop-down box. If you run the application for the first time, the
application associates Class A with all the harmonic tables. If you change the
Class settings, the application retains the change after you exit and rerun the
application.

d. Click the Edit button to display a table editor. The table editor displays the
Harmonic Number from 1-40 for 61000-3-2 standard and 1-50 or
1-100 (based on the configuration parameter selected) for MIL
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1399 standard, Harmonic Limits in milliamperes and the Harmonic Limits in
decibel microamperes. Click OK to update the values in the table.
 

 

NOTE. You can edit only the Harmonic limits values Amperes table. The same
change is updated in the db μa column.

e. Select a Class using the drop-down arrow in the Class field. The available
classes are: A to D.

NOTE. You can edit the harmonic table for Class A and B but not Class C and
D.

If you select Class C, the application calculates the power factor limit and
updates the limit table. If you select Class D, the application calculates the
limit value of the harmonic from the true power of the unit under test.

f. These tables are applicable only to 61000-3-2 standards and the AM
14 standards.

IEC issued an amendment (amendment 14) to the 61000-3-2 harmonics standard.
This is documented as the 61000-3-2 amendment 14.

This amendment changes the class definitions, reclassifies many products to
Class A and clearly defines what Class-D products are (Class D products are
limited to personal computers + monitors < 600 W, television receivers <600W)
and affects the newly defined Class-D. The Class C and D limits are based on
Manufacturer's Ratings which must be verified by measurement.

Click this hyperlink to see what the application does if you select the AM
14 standard.
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Follow these steps to configure the AM 14 configurations:

a. Click the AM 14 button in the Type pane. By default Line frequency is Auto
which calculates input signal frequency automatically. Line frequency can be
set to 50Hz, 60 Hz or Custom. Custom frequency value can be set between
1 Hz and 4 KHz. Harmonics Order is 40 by default. Harmonics order can be
set between 40 to 100.
 

 

NOTE. Source Autoset takes input from Line Frequency and Harmonic Order.
To set the minimum acquisition of sixty cycles of line frequency, run the
source autoset Vert & Horiz.

b. In the Harmonics Table tab, select the Table using the Harmonics drop-down
box and click the Edit button to edit the table. Select any one of the ten
available Tables.Table1 is the default table. If you set the harmonic table, the
application displays the Class associated with in the Class combo box. If you
run the application for the first time, the application associates Class A with
all the harmonic tables. If you change the class settings, the application
retains the change after you exit and rerun the application.

NOTE. You can edit the harmonic table for Class A and B but not Class C and
D.

c. Click the Edit button to display a table editor. The table editor displays the
Harmonic Number from 1-40 for IEC standard, Harmonic Limits in
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milliamperes and the Harmonic Limits in decibel microamperes. Click OK to
update the values in the table.

d. Select the Class using the Class drop-down box. The available classes are: A
to D. The Controls option provides additional inputs only to Class C or D.
 

 

e. Double-click the Input Power, Power Factor or Fundamental Current field
and use the keypad that appears to enter the values and select OK. The
acceptable ranges for:

■ Input Power is 0 W to 600 W. The default value is 100 W

■ Power Factor is 0 to 1. The default value is 1 

f. Fundamental Current is 0 A to 16 A. The default value is 15 A.

g. Select the Filter check box to obtain filtered harmonic values.

NOTE. The signal is expected to be in steady state during the Tobs period where
Tobs is the acquisition period for this measurement. This measurement is set for
very short cycle Tsv =3 seconds.

Click this hyperlink to see what the application does if you select the
MIL 1399 standard.

Click the MIL 1399 button in the Type pane. By default Line frequency is Auto
which calculates input signal frequency automatically. Line frequency can be set
to 50Hz, 60 Hz or Custom. Custom frequency value can be set between 1 Hz and
4 KHz. Harmonics Order is 50 by default. Harmonics order can be set between
50 to 100.
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NOTE. Source Autoset takes input from Line Frequency and Harmonic
Order. To set the minimum acquisition of ten cycles of line frequency,
run the source autoset Vert & Horiz.

3. Configuration under I-Probe Impedance tab:

Enter the frequency derating of the custom probe that you are using for the
current measurement. I-Probe is applicable for the selected current source
where the frequency derating is compensated in measurements such as
61000-3-2, AM 14 and MIL 1399 standards. Use the drop-down arrow in the
Impedance Table to select any one of the ten available tables. The Impedance
table enables to enter frequency response of the probe. This helps you to
measure the frequency component altered by the frequency response of the
probe. Table 1 is the default table. Use the Edit button to edit the impedance
table.

Use the Reset button in the Impedance Table Editor to reset the ratio and dB
values to the default values.
 

 

Use the Impedance table to set the transfer impedance of the probe at each
harmonic frequency. The table editor displays the Harmonic Number from
1-40 for IEC standard and 1-50 or 1-100 (based on the configuration
parameter selected) for MIL standard, the Impedance ratio and the
Impedance ratio in decibels.

4. Configuration under Harmonics Table tab:

In the Harmonics Table tab, click the Edit button to display a table editor.
The table editor displays the Harmonic Number from 1-40 for
61000-3-2 standard and 1-50 or 1-100 (based on the configuration parameter
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selected) for MIL standard, the Impedance ratio in decibel units. You can edit
only the Impedance ratio column in the table. Select OK.

NOTE. You can edit the harmonic table for Class A and B but not Class C and
D.

5. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

6. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

NOTE. Current harmonics works for any record length and time base
combination for IEC61000-3-2 and AM14 type. For MIL1399 type it works for
the time base set by the application Autoset.
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Viewing results-Current harmonics. Click Results and then click View Results in
Detailed, to view the result for the selected Current Harmonics measurement.
 

 

61000-3-2 and MIL 1399 results. If you have selected the 61000-3-2 or MIL
1399 standard, the Current Harmonic Results displays the following information:
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Option Description
Harmonic Displays the harmonic number
Value Displays the measured value in dB μA
Limit Displays the harmonic limits in dB μA
Margin Displays the difference between the Value and Limit in dB μA. The status

depends on the positive or negative margin value
Status Displays the status of the measurement - Pass or Fail

Table 2: Result

Field Value
Class Configured class
V-THD Total harmonic distortions of voltage signal
I-THD Total harmonic distortions of current signal
Irms Root mean square of current signal
V(f)rms Root mean square computed using harmonic frequencies
Harmonic Frequency Configured line frequency
Actual Signal
Frequency

Actual input line frequency

True Power True power of the waveform

Table 3: Customize result

Field Value
Unit
dBμA Margin values are displayed in dB μA measurement unit.
A Margin values are displayed in A (Ampere) measurement unit.
Harmonics
All Harmonics with both odd and even values are displayed.
Odd Harmonics with only odd values are displayed.
Even Harmonics with only even values are displayed.
Margin
Diff Difference of Limit to Value is displayed in Margin.
% of F % of difference of Limit to Value is displayed in Margin.
Save Data Allows you to save the result in *.csv file format.

AM 14 results.
If you have selected the AM 14 standard, the Current Harmonic Results displays
40 harmonic values with the following information:
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Option Description
Harmonic Displays the harmonic number.
Value Displays the measured value in dB μA.
Limit Displays the harmonic limits in dB μA.
Margin Displays the difference between the Value and Limit in dB μA. The Status

depends on the positive or negative margin value.
Result Displays the status of the measurement-Pass or Fail.

Table 4: Result

Field Value
Class Configured class
V-THD Total Harmonic distortions of voltage signal.
I-THD Total Harmonic distortions of current signal.
Irms Root Mean Square of current signal.
Vrms Root mean square of voltage signal
Harmonic Frequency Configured line frequency
Actual Signal
Frequency

Actual input Line frequency

POHC Measured Partial odd harmonic current measured.
POHC Limit Partial odd harmonic current limit.
POHC Status Partial odd harmonic current status Pass/Fail.
True Power True power of the waveform
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Table 5: Customize result

Field Value
Unit
dBμA Margin values are displayed in dB μA measurement unit.
A Margin values are displayed in A (Ampere) measurement unit.
Harmonics
All Harmonics with both odd and even values are displayed.
Odd Harmonics with only odd values are displayed.
Even Harmonics with only even values are displayed.
Margin
Diff Difference of Limit to Value is displayed in Margin.
% of F % of difference of Limit to Value is displayed in Margin.

If you have selected the AM 14 standard with Filter, the Current Harmonic
Results displays 50 harmonic values with the following information:

Option Description
Average Filtered
Harmonics

Displays the average value of the individual harmonic currents taken over
the entire test period ((measured average harmonics, limit average
harmonics and margin (difference between limit and measured value)).

Peak Filtered
Harmonics

Displays the maximum value for each filtered harmonics.

Value Displays the measured value in dB μA.
Limit Displays the harmonic limits in dB μA.
Margin Displays the difference between the Value and Limit in dB μA. The Status

depends on the positive or negative margin value.
Result Displays the status of the measurement-Pass or Fail.

Table 6: Result

Field Value
Class Configured class
V-THD Total Harmonic distortions of voltage signal.
I-THD Total Harmonic distortions of current signal.
Irms Root Mean Square of current signal.
Vrms Root mean square of voltage signal
Harmonic Frequency Configured line frequency
Actual Signal
Frequency

Actual input Line frequency

POHC Measured Partial odd harmonic current measured.
POHC Limit Partial odd harmonic current limit.
POHC Status Partial odd harmonic current status Pass/Fail.
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Field Value
True Power True power of the waveform

Table 7: Customize result

Field Value
Unit
dBμA Margin values are displayed in dB μA measurement unit.
A Margin values are displayed in A (Ampere) measurement unit.
Harmonics
All Harmonics with both odd and even values are displayed.
Odd Harmonics with only odd values are displayed.
Even Harmonics with only even values are displayed.
Margin
Diff Difference of Limit to Value is displayed in Margin.
% of F % of difference of Limit to Value is displayed in Margin.

Viewing plots-Current harmonics. Click Plots and select Harmonics Bar Graph to
view the plots for the selected Current Harmonics measurement.

Figure 16: Even harmonics bar graph
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Figure 17: Odd harmonics bar graph

NOTE. Marker Value, Overview of Results table fields and information about
calculation are explained in Current/Voltage harmonics.

See also.  
Selecting and configuring measurements-Current harmonics

Plot components and features
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Voltage harmonics Selecting and configuring measurements-Voltage harmonics. To select and
configure Voltage Harmonics Measurement, follow these steps:

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Input Analysis; click Voltage Harmonics in the measurement pane.

3. Click Configure to configure the measurement.

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings.

NOTE. If you are using the same voltage source as used for any previous
measurement, skip the procedure for configuring the common configuration
options.

Configuring the measurement. Follow the steps to configure the Voltage
Harmonics measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Line Frequency tab:

■ Select Auto (Calculates the input signal frequency automatically), 50 Hz,
60 Hz, Custom (Set the Line frequency in range 1 Hz to 4000 Hz using
numerical keypad).

 

 
3. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

4. Click Run to acquire the data. If the measurement is successful, the
application displays the results.
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Viewing results-Voltage harmonics. Click Results and then click View Results in
Detailed, to view the result for the selected Voltage Harmonics measurement.
 

 

Option Description
Harmonic Displays the harmonic number
Frequency (Hz) Displays the frequency in Hz
Value Displays the value

Table 8: Result

Field Value
V-THD Total harmonic distortions of voltage signal.
Vrms Root mean square of voltage signal
Harmonic Frequency Configured line frequency
Actual Signal
Frequency

Actual input line frequency

Table 9: Customize result

Field Value
Unit
dBμV Margin values are displayed in dB μV measurement unit.
V Margin values are displayed in V (Volt) measurement unit.
Harmonics
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Field Value
All Harmonics with both odd and even values are displayed.
Odd Harmonics with only odd values are displayed.
Even Harmonics with only even values are displayed.
Save Data Allows you to save the result in *.csv file format.

Viewing plots-Voltage harmonics. Click Plots and select Harmonics Bar Graph to
view the plots for the selected Voltage Harmonics measurement.
 

 

TIP. Click Show Plots  to open the Plot(s) window, when closed.

NOTE. Marker Value, Overview of Results table fields and information about
calculation are explained in Current/Voltage harmonics.

See also.  
Selecting and configuring measurements-Voltage harmonics

Plot components and features
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Total power quality Selecting and configuring measurements-Total power quality. Selecting and
configuring measurements-Total Power QualityConfiguring the measurement

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Input Analysis; click Total Power Quality in the measurement pane.

3. Click Configure to configure the measurement.

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General safety
summary for more information.

NOTE. If you use the same voltage source as used for an earlier measurement,
you can skip the procedure for configuring the source configuration options.

Follow the steps to configure the Total Power Quality measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configurations under Standard tab:

■ Select the Type as international EMC (Electro Magnetic Compatibility)
standards 61000-3-2, AM 14 and MIL 1399 for which you can perform
compliance test.

 

 

Click this hyperlink to see what the application does if you select the
61000-3-2 standard.

Follow these steps to configure the 61000-3-2 Standard configurations:

a. In the Standard tab, select the 61000-3-2 button. Line Frequency is 50 Hz and
Harmonics Order is 40 by default. Select Auto to automatically detect the
input signal frequency. Click 60 Hz or Custom and set frequency within 1 Hz

Advanced power measurement and analysis  

154  Advanced Power Analysis



to 4000 Hz range for line frequency. Harmonics order can be set between
40 to 100.
 

 

b. In the Harmonics Table tab, click the Harmonic combo box to select the table
and click the Edit button to edit the table.

c. Select any one of the ten available Tables. Table 1 is the default table. If you
set the harmonic table, application displays the Class associated with in the
Class combo box. If you run the application for the first time, the application
associates Class A with all the harmonic tables. If you change the Class
settings, the application retains the change after you exit and rerun the
application.

d. Click the Edit button to display a table editor. The table editor displays the
Harmonic Number from 1-40 for IEC standard and 1-50 or 1-100 (based on
the configuration parameter selected) for MIL standard, Harmonic Limits in
milliamperes and the Harmonic Limits in decibel microamperes. Click OK to
update the values in the table.

NOTE. You can edit only the Harmonic Limits values mA table.

e. Click the Class combo box to select a Class. The available Classes are: A to
D.

NOTE. You can edit the harmonic table for Class A and B but not Class C and D.

a. If you select the Class C, the application calculates the power factor limit and
updates the limit table. If you select Class D, the application calculates the
limit value of the harmonic from the true power of the unit under test.

b. Click the Set button to set the Harmonic table to the selected standard.

IEC issued an amendment (amendment 14) to the 61000-3-2 harmonics standard.
This is documented as the 61000-3-2 amendment 14.

This amendment changes the class definitions, reclassifies many products to
Class A and clearly defines what Class-D products are (Class D products are
limited to personal computers + monitors < 600 W, television receivers <600W).

Click this hyperlink to see what the application does if you select the AM
14 standard.
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Follow these steps to configure the AM 14 Standard configurations:

a. In the Standard tab, select the AM 14 button. Line Frequency is 50 Hz and
Harmonics Order is 40 by default. Select Auto to automatically detect the
input signal frequency. Click 60 Hz or Custom and set frequency within 1 Hz
to 4000 Hz range for line frequency. Harmonics order can be set between
40 to 100.

a. In the Harmonics Table tab, click the Harmonic drop-down list to select the
table and use the Edit button to edit the table.
 

 

b. Select any one of the ten available Tables. Table 1 is the default table. If you
set the harmonic table, application displays the Class associated with in the
Class combo box. If you run the application for the first time, the application
associates Class A with all the harmonic tables. If you change the Class
settings, the application retains the change after you exit and rerun the
application.

c. Click the Edit button to display a table editor. The table editor displays the
Harmonic Number from 1-40 for IEC standard, Harmonic Limits in
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milliamperes and the Harmonic Limits in decibel microamperes. Click OK to
update the values in the table.

d. Use the Class combo box to select a Class. The available Classes are: A to D.
The Controls option provides additional inputs only to Class C or D.

e. Select the Controls button to display the controls screen.

f. Double-click the Input Power, Power Factor or Fundamental Current field
and use the keypad that appears to enter the values and select OK. The
acceptable ranges for:

■ Input Power is 0 W to 2 KW. The default value is 100 W

■ Power Factor is 0 to 1. The default value is 1 

■ Fundamental Current is 0 A to 16 A. The default value is 16 A

g. Set the Filter Off if you do not want to obtain filtered harmonic values.

Click this hyperlink to see what the application does if you select the MIL
1399 standard.

In the Standard tab, select the MIL 1399 button. Line Frequency is 400 Hz and
Harmonics Order is 50 by default. Select Auto to automatically detect the input
signal frequency. Click 60 Hz or Custom and set frequency within 1 Hz to
4000 Hz range for line frequency. Harmonics order can be set between 50 to 100.

3. Configuration under I-Probe Impedance tab:

Enter the frequency derating of the custom probe that you are using for the
current measurement. I-Probe is applicable for the selected current source
where the frequency derating is compensated in measurements such as
61000-3-2, AM 14 and MIL 1399 standards. Use the drop-down arrow in the
Impedance Table to select any one of the ten available tables. The Impedance
table enables to enter frequency response of the probe. This helps you to
measure the frequency component altered by the frequency response of the
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probe. Table 1 is the default table. Use the Edit button to edit the impedance
table.

Use the Reset button in the Impedance Table Editor to reset the ratio and dB
values to the default values.

 

 

Use the Impedance table to set the transfer impedance of the probe at each
harmonic frequency. The table editor displays the Harmonic Number from
1-40 for IEC standard and 1-50 or 1-100 (based on the configuration
parameter selected) for MIL standard, the Impedance ratio and the
Impedance ratio in decibels.

4. Configuration under Harmonics Table tab:

In the Harmonics Table tab, click the Edit button to display a table editor.
The table editor displays the Harmonic Number from 1-40 for
61000-3-2 standard and 1-50 or 1-100 (based on the configuration parameter
selected) for MIL standard, the Impedance ratio in decibel units. You can edit
only the Impedance ratio column in the table. Select OK.

NOTE. You can edit the harmonic table for Class A and B but not Class C and
D.

5. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

6. Click Run to acquire the data. If the measurement is successful, the
application displays the results.
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Viewing results-Total power quality. 

1. Click Results to view the result for the selected Total Power Quality
measurement.
 

 

NOTE. Since the measurement is a combination of Power Quality and
Current Harmonics measurements, the results also reflects the same
combination.
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2. Select the View button to display the following results:

 

 

Option Description
Harmonic Displays the harmonic number
Value Displays the measured value
Limit Displays the IEC standard limits or the user defined limits set by you
Margin Displays the difference between the Value and Limit
Result Displays the status of the measurement-Pass or Fail

Table 10: Result

Field Value
Class Specifies the class
V-THD Total harmonic distortions of voltage signal
I-THD Total harmonic distortions of current signal
Irms Root mean square of current signal
V(f)rms Root mean square computed using harmonic frequencies
Harmonic Frequency Specified configure Line frequency
Actual Signal
Frequency

Actual input line frequency

POHC Measured Partial odd harmonic current measured
POHC Limit Partial odd harmonic current limit
POHC Status Partial odd harmonic current status Pass/Fail
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Field Value
True Power Specifies true power of the waveform
Apparent Power Specifies apparent power of the waveform
V Crest Factor Specifies V Crest factor of the waveform
I Crest Factor Specifies I Crest factor of the waveform
Power Factor Specifies the power factor of the waveform

NOTE. Class, POHC measured, POHC limit and POHC status filed will not
be displayed in result table for MIL 1399 standard type.

If you have selected MIL 1399 standard, the application displays 50 or
100 harmonic values depending on the configuration set. In the Field and
Value table, the Class value is displayed as NA, Mode displays MIL
Standard, Line Frequency value in Hz and Total Harmonic Distortion in
percentage.

3. Select the Table or Graph option from the View pane. If you have set the
MIL Standard, the mask option is not available in the View field. The Mask
option is available only if the harmonic table has Class A or D device. In the
Mask results, Red indicates the mask boundary, yellow indicates one half
cycle of the input current waveform. X-axis displays the waveform angle in
degrees. Y-axis indicates the i/i peak where i is the current and i peak is the
peak of the current in one half cycle.

4. In the bar graph, the red indicates Fail status, green indicates Pass and gray is
for set limits. The mask option displays the True Power and the class of the
device detected.

5. Select the drop-down arrow in the Harmonics field to display the harmonics
in three modes -All, Even and Odd. All harmonics displays the complete set
of harmonic values. Even harmonics display the even numbered values from
2-40. Odd harmonics display the odd numbered values from 1-39.

6. Click dB μA or A in Units pane to set the units to decibel microamperes or
amperes. The default units is dB μA.

NOTE. Any change in the units reflects in the Value, Limit and Margin fields
of the table and the bar graph. Export the .csv file only if you select the table
format.

Viewing results-Total power quality

If the Harmonics Bar Graph plot is selected, click Show Plots to display the plot.
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See also.  
Selecting and configuring measurements-Total power quality

Plot components and features
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Inrush current Selecting and configuring measurements-In rush current. Selecting and
configuring measurements-Inrush currentConfiguring the measurement

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Input Analysis; click In Rush Current in the measurement pane.

3. Click Configure to configure the measurement.

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General safety
summary for more information.

NOTE. If you use the same voltage source as used for an earlier measurement,
you can skip the procedure for configuring the source configuration options.

Follow the steps to configure the In Rush Current measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Options tab:

■ Select the Units as Percentage or Absolute to set the Ref Level and
Hysteresis values in percentage or the absolute value of the peak-to-peak
signal.

■ Set the Ref level value within the range -100 Amp to 100 Amp for
absolute units and 1% to 99% for units as percentage.

The input current waveform can be divided into different regions. The
region is defined as when a current waveform enters and exits the
threshold level. The measurement computes the positive and negative
peaks for each region. The REF Level is used to detect the first valid
peak. After this other peaks are detected above and below the REF level.

■ Set the Hysteresis value within the range 0 Amp to 100 Amp for absolute
units and 1% to 99% for units as percentage.
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■ Set the Peak (Amps) within the range -100 Amp to 100 Amp for absolute
units and 1% to 99% for units as percentage.
 

 

3. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

4. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

Viewing results-In rush current. Click Results to view the result for the selected In
Rush Current measurement.
 

 

In rush current detailed result
 

 

See also.  
Selecting and configuring measurements-In rush current

Advanced power measurement and analysis  

164  Advanced Power Analysis



Input capacitance Selecting and configuring measurements-Input capacitance. Selecting and
Configuring Measurements-Input CapacitanceConfiguring the measurement

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Input Analysis; click Input Capacitance in the measurement pane.

3. Click Configure to configure the measurement.

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General safety
summary for more information.

NOTE. If you use the same voltage source as used for an earlier measurement,
you can skip the procedure for configuring the source configuration options.

Follow the steps to configure the Input Capacitance measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Options tab:

■ Select the Units as Percentage or Absolute to set the Ref Level and
Hysteresis values in percentage or the absolute value of the peak-to-peak
signal.

■ Set the Ref level value within the range -100 Amp to 100 Amp for
absolute units and 1% to 99% for units as percentage.

The input current waveform can be divided into different regions. The
region is defined as when a current waveform enters and exits the
threshold level. The measurement computes the positive and negative
peaks for each region. The REF Level is used to detect the first valid
peak. After this other peaks are detected above and below the REF level.

■ Set the Hysteresis value within the range 0 Amp to 100 Amp for absolute
units and 1% to 99% for units as percentage.
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■ Set the Peak (Amps) within the range -100 Amp to 100 Amp for absolute
units and 1% to 99% for units as percentage.
 

 

3. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

4. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

Viewing results-Input capacitance. Click Results to view the result for the selected
Input Capacitance measurement.
 

 

See also.  
Selecting and configuring measurements-Input capacitance
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Output measurement and analysis

Line ripple Selecting and configuring measurements-Line ripple. To select and configure
Ripple Measurement, follow these steps:

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Output Analysis; click Line Ripple in the measurement pane.

3. Click Configure to configure the measurement.

Configuring the measurement. Follow the steps to configure the Input Capacitance
measurement:
 

 

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under LineRipple Freq tab:

■ Set the Ripple Freq to 50 Hz, 60 Hz, or 400 Hz
3. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

4. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

 Advanced power measurement and analysis

Advanced Power Analysis 167



Viewing results-Line ripple. Click Results to view the result for the selected Line
Ripple measurement
 

 

NOTE. The smaller the resolution bandwidth (RBW) the better the resolution for
spectral measurement results. When Update button is selected, the RBW is
computed based on the range (Start and Stop values ), and an appropriate record
length and sample rate are selected. The list of RBW values are displayed in the
drop down list. You can configure specific RBW values based on the desired
resolution, and to get the effect of RBW, check the Autoset box. This will enable
the source Autoset and takes into account of RBW value and finally sets up the
horizontal parameters on the oscilloscope. If the autoset is not performed then
expect an error message indicating RBW does not have the required horizontal
time base.

See also.  
Selecting and configuring measurements-Line ripple
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Spectral analysis Selecting and configuring measurements-Spectral analysis. Purpose

To analyze the frequency component that contributes to the electromagnetic
interference and measure the noise/ripple at the output DC voltage frequency
range. The result plot component plots the spectrum amplitude on Y-axis and
Frequency (units: Hz) on X-axis. Follow these steps to use the Spectral Analysis
tool:

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.

The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Output Analysis, and then click Spectral Analysis in the measurement
pane.

3. Click Configure to configure the measurement.
4.

Click  to open the Source Configure dialog box, and then configure the
options in the Source Configuration dialog box.

The Source specifies the input source to which the DUT is connected. The
available options are: Ch1-Ch4, Math1-Math4 and Ref1-Ref4. These
selections depend on the number of channels in the oscilloscope.

5. Double-click in Start and Stop field to set the frequency.

The Start and Stop frequency define the frequency range values of the input
signal to be analyzed. The Start and Stop field value can be set between 0 Hz
to Scope supported Bandwidth. The default value is 50 Hz in Start and Scope
supported bandwidth in Stop.

6. Check the Filter check box to set the filter type and math to the filter source.

Selecting the Frequency check box will automatically disable the controls:
Start, Stop, Window type, Update button, Auto set, and Res BW (Hz) of the
Spectral Config panel. For more information, refer POI filter details.

NOTE. While adding the measurement, ensure that the Filter Source Math
channel you select is not used for any other added measurements. If the
Source configuration Vert & Horiz Autoset is not performed, then
measurements will not set the required frequency resolution to perform the
filter operation. Here Vert & Horiz Autoset configures the sampling
frequency 3.125 MHz and 500k record length after the first run, other PoE
filters can be run with the same acquisition by using the Recalc button.

7. Select Log Results check box to save the first 10 peak frequencies in .csv
file. By default, it is selected.

A new CSV file is created for Single, Recalc and Freerun. The file is saved in
C:\Users\<user>\Tektronix\TekApplications\Advanced Power Analysis
\SpectralAnalysis\

8. Click the Window Type combo box to set the window type.

The window type reduces the spectral leakage, excluding the Rectangular
Window, when using the spectral analysis. The available window types are:
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Rectangular, Hamming, Hanning, Black-Harris, Gaussian, Flattop2, Kaiser-
Bessel and TekExp. In the Options pane, the Auto Setup is selected by
default. The application automatically sets the record length and the time
base for the given Start, Stop and Window Type inputs. In the Frequency
Values pane, click the drop-down arrow to set the RBW(Resolution and
Bandwidth) value. The application calculates the RBW values depending on
the Start, Stop and Window Type inputs. Click the Update button to update
the RBW values. If the Auto Setup check box is not selected, the Update
button is disabled and the application runs with the existing record length and
time base available in the oscilloscope.

If you have selected a live source in the Source field, enable the DC Block.
Clicking the DC Block adjusts the vertical sensitivity of the signal and
measures the frequency component of the noise at the output DC voltage.

9. To globally set the coupling, bandwidth limit, cursor gating, and acquisition
mode, see Configuring global settings.

10. Open the Source Configuration window, and then click Vert & Horiz button
before running the measurements.

11. Select the Run button to acquire the data. If you have entered the Start and
Stop frequency values, the application calculates the selected RBW value,
sets it to the highest RBW and runs the measurement. If the measurement is
successful, the application automatically displays the results.

Configuring the measurement. Follow the steps to configure the Spectral Analysis
measurement:

■ Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

■ Configuration under Options tab:

■ Set the Start and Stop frequency. The Start and Stop frequency define the
frequency range values of the input signal to be analyzed. The Start and
Stop field value can be set between 0 Hz to Scope supported Bandwidth.
The default value is 50 Hz in Start and Scope supported bandwidth in
Stop.

■ Select the Window Type from the drop-down list. The window type
reduces the spectral leakage, excluding the Rectangular window, when
using the spectral analysis. The available window types are: Rectangular,
Hamming, Hanning, Black-Harris, Gaussian, Flattop2, Kaiser-Bessel and
TekExp.

In the Options pane, the Auto Setup is checked by default. The
application automatically sets the record length and the time base for the
given Start, Stop and Window Type inputs.

If you have selected a live source in the Source field, enable the DC
Block. Clicking the DC Block adjusts the vertical sensitivity of the signal
and measures the frequency component of the noise at the output DC
voltage.

Select Log Results to save the first 10 peak frequencies in .csv file. By
default, it is selected. A new CSV file is created for Single, Recalc and
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Freerun. The file is saved in C:\Users\<user>\Tektronix\TekApplications
\Advanced Power Analysis\SpectralAnalysis

After setting up window type, start, and stop values, click Update button
to automatically update the supported Res BW(Hz). Select from the drop-
down list and perform Vert&Horiz "Autoset" from Source Configuration
tab. If Autoset is not performed, highest RBW will be considered based
on start, stop and horizontal resolution.

The supported Res BW(Hz) values after update is shown in the following
image
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■ Spectral config (Filter):
 

 
 

 
Select the Filter check box, and then select one PoE specific filter from Type
drop-down and Math Filter Source. After selecting Filter, navigate to the
Source configuration tab and perform the "Vert&Horiz" auto set.

■ Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

■ Open the Source Configuration dialog box, and then click Vert & Horiz
button before running the measurements.

■ Click Run to acquire the data. If the measurement is successful, the
application displays the results.
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Viewing results-Spectral analysis. Click Results to view the result for the selected
Spectral Analysis measurement.

Click Results > Detailed to view the first ten peak frequencies, RBW,
PeakToPeak and DC value. Click the file name to view the logged result log file.
The file is saved in C:\Users\<user>\Tektronix\TekApplications\Advanced Power
Analysis\SpectralAnalysis\
 

 

NOTE. The result summary shows the statistics of all peaks. The Results detail
shows the top 10 peaks.

Viewing plots-Spectral analysis
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1. Click Plots, and then the Spectrum. Click the Single button to view the
spectrum plot as below.
 

 

The application plots the Frequency values on the X axis and the Amplitude
on the Y axis.

In the Vertical Scale pane, you can switch the plot between the different
vertical scale values like dB and Rms.

Select Details in plot menu to display the Marker Value, Vertical Scale and
Save Data options.

NOTE. Use the Next button to move the cursor position to the next peak from
the listed position. By default, the application positions the cursor on the first
peak. You can travel through the first 500 peak in plot market table or Min
based on RL.

2. Click the Zoom In button and place the cursor on the specific region to zoom
the plot. You can also use the Zoom Out button to zoom out.

3. Click the Save button to save the plot in .csv format in the default directory
C:\Users\Public\Tektronix\TekApplications\Advanced Power Analysis\.

See also.  
Selecting and configuring measurements-Spectral analysis

Plot components and features

Troubleshooting spectral analysis error messages. If the minimum record length
required to configure the Start and Stop values is greater than the maximum
record length supported by the application, the application displays the error
message "Frequency Range higher than range supported."
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Switching ripple Selecting and configuring measurements-Switching ripple. To select and configure
Ripple Measurement, follow these steps:

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Output Analysis; click Spectral Ripple in the measurement pane.

3. Click Configure to configure the measurement.

Configuring the measurement. Follow the steps to configure the Switching Ripple
measurement:
 

 

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Ripple Freq tab:

■ Double-click the Switching Ripple Frequency field and use the keypad
that appears to select a switching frequency. The default value is 10 KHz.

 

 
3. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

4. Click Run to acquire the data. If the measurement is successful, the
application displays the results.
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Viewing results-Switching ripple. Click Results to view the result for the selected
Switching Ripple measurement.
 

 

See also.  
Selecting and configuring measurements-Switching ripple
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Turn-On time Selecting and configuring measurements-Turn-On time. To select and configure
Turn-On Time Measurement, follow these steps:

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Output Analysis; click Turn On Time in the measurement pane.

3. Click Configure to configure the measurement.

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic for more
information.

Configuring the measurement. Follow the steps to configure the Turn On Time
measurement:
 

 

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Input tab:
■ In the Convertor pane, select the type of convertor used: DC-DC or AC-

DC. Select the AC-DC option to enable the Frequency option. Double-
click the Frequency field and use the keypad that appears to set the line
input frequency.

■ In the Source pane, enter the Max Voltage and Trigger Level (1 V to
500 V), by double-clicking the respective field and use the keypad that
appears.

■ Double-click the Max Turn-On Time field and use the keypad that
appears to enter the expected turn on time. This enables you to set the
timing window of the oscilloscope.

3. Configuration under Output tab:
■ Click the ON button to enable Source1. Click the Source1 channel source

from the drop-down list. Double-click the Max Voltage field and use the
keypad that appears to enter the maximum voltage value.

■ Repeat previous step for Source 2 and Source 3 selections.
4. Switch on the device under test.
5. Configuration under Global tab:
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See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

6. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

Viewing results-Turn-On time. To view the results, follow these steps:

NOTE. To view the results when the application is running, turn off the power
supply and turn on to display the results.

1. From the oscilloscope menu bar, select Analyze> Advanced Power Analysis,
and then press Results.

2. The application displays the results for the Turn-On Time measurement with
the following data.

 

 

See also.  
Selecting and configuring measurements-Turn-on time
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Amplitude

Cycle min Select and configure measurement-Cycle Min. To select and configure Cycle Min
measurement, follow these steps: 

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Amplitude; click Cycle Min in the measurement pane.

3. Click Configure to configure the measurement.

 

 

Configuring the measurement

Follow the steps to configure the Cycle Min measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Signal Type tab:

■ Select the signal type as AC or DC. The cycle measurements with DC
signal type should be used for measuring signals with large DC
components.
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3. Configuration under Options tab:

■ Select the Units as Percentage or Absolute to set the Ref Level and
Hysteresis values in percentage or in absolute value.

■ Set the Ref level value within the range --5.99 kV to 5.99 kV for absolute
units and 1% to 99% for units as percentage.

■ Set the Hysteresis value within the range 0 V to 3 kV for absolute units
and 1% to 99% for units as percentage.

 

 

4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

See also.  
Viewing results-cycle min

Source configuration panel

Source autoset
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Viewing result-cycle min. Click Results to view the result for the selected Cycle
Min measurement.

Viewing plots-cycle min

Click Plots and select Time Trend or Histogram to view the plots for the selected
Cycle Min measurement

See also.  
Select and configure measurement - cycle min
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Cycle max Select and configure measurement-Cycle Max. To select and configure Cycle Max
measurement, follow these steps: 

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Amplitude; click Cycle Max in the measurement pane.

3. Click Configure to configure the measurement.

 

 

Configuring the measurement

Follow the steps to configure the Cycle Max measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Signal Type tab:

■ Select the signal type as AC or DC. The cycle measurements with DC
signal type should be used for measuring signals with large DC
components.

3. Configuration under Options tab:

■ Select the Units as Percentage or Absolute to set the Ref Level and
Hysteresis values in percentage or in absolute value.

■ Set the Ref level value within the range --5.99 kV to 5.99 kV for absolute
units and 1% to 99% for units as percentage.

■ Set the Hysteresis value within the range 0 V to 3 kV for absolute units
and 1% to 99% for units as percentage.
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4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

See also.  
Viewing results-cycle max

Source configuration panel

Source autoset
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Viewing results-cycle max. Click Results to view the result for the selected Cycle
Max measurement.

Viewing plots-cycle max

Click Plots and select Time Trend and/or Histogram to view the plots for the
selected Cycle Max measurement

See also.  
Select and configure measurement - cycle max
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Cycle peak-to-peak (Pk-
Pk)

Select and configure measurement-Cycle peak-to-peak. To select and configure
Cycle peak-to-peak measurement, follow these steps: 

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Amplitude; click Cycle PkPk in the measurement pane.

3. Click Configure to configure the measurement.

 

 

Configuring the measurement

Follow the steps to configure the Cycle PkPk measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Signal Type tab:

■ Select the signal type as AC or DC. The cycle measurements with DC
signal type should be used for measuring signals with large DC
components.

3. Configuration under Options tab:

■ Select the Units as Percentage or Absolute to set the Ref Level and
Hysteresis values in percentage or in absolute value.

■ Set the Ref level value within the range --5.99 kV to 5.99 kV for absolute
units and 1% to 99% for units as percentage.

■ Set the Hysteresis value within the range 0 V to 3 kV for absolute units
and 1% to 99% for units as percentage.
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4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

See also.  
Viewing results-cycle peak-to-peak

Source configuration panel

Source autoset

Advanced power measurement and analysis  

186  Advanced Power Analysis



Viewing results-Cycle peak-to-peak. Click Results to view the result for the
selected Cycle peak-to-peak measurement.

Viewing plots-Cycle peak-to-peak

Click Plots and select Time Trend and/or Histogram to view the plots for the
selected Cycle PkPk measurement

See also.  
Select and configure measurement - cycle peak-to-peak
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High Select and configure measurement-Amplitude High. To select and configure
Amplitude High measurement, follow these steps: 

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Amplitude; click High in the measurement pane.

3. Click Configure to configure the measurement.

 

 

Configuring the measurement

Follow the steps to configure the Amplitude High measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Edge tab:

■ Move the Center X% of the signal determines what % (1 to 100) of a unit
interval, centered in the middle of the bit shall be admitted in each
measurement. The waveform points selected by the % form a distribution
(vertical histogram) from which a single value is extracted, based on the
method control.

■ Method determines whether the Mean value or the Median of the selected
distribution is used for the measurement value for each unit interval.

3. Configuration under Options tab:

■ Select the Units as Percentage or Absolute to set the Ref Level and
Hysteresis values in percentage or in absolute value.

■ Set the Ref level value within the range --5.99 kV to 5.99 kV for absolute
units and 1% to 99% for units as percentage.

■ Set the Hysteresis value within the range 0 V to 3 kV for absolute units
and 1% to 99% for units as percentage.

4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.
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See also.  
Viewing results-Amplitude high

Source configuration panel

Source autoset

Viewing results-Amplitude High. Click Results to view the result for the selected
Amplitude High measurement.

Viewing plots-Amplitude High

Click Plots and select Time Trend or Histogram to view the plots for the selected
Amplitude High measurement

See also.  
Select and configure measurement - Amplitude high
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Low Select and configure measurement-Amplitude Low. To select and configure
Amplitude Low measurement, follow these steps: 

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Amplitude; click Low in the measurement pane.

3. Click Configure to configure the measurement.

 

 

Configuring the measurement

Follow the steps to configure the Amplitude Low measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Edge tab:

■ Move the Center X% of the signal determines what % (1 to 100) of a unit
interval, centered in the middle of the bit shall be admitted in each
measurement. The waveform points selected by the % form a distribution
(vertical histogram) from which a single value is extracted, based on the
method control.

■ Method determines whether the Mean value or the Median of the selected
distribution is used for the measurement value for each unit interval.
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3. Configuration under Options tab:

■ Select the Units as Percentage or Absolute to set the Ref Level and
Hysteresis values in percentage or in absolute value.

■ Set the Ref level value within the range --5.99 kV to 5.99 kV for absolute
units and 1% to 99% for units as percentage.

■ Set the Hysteresis value within the range 0 V to 3 kV for absolute units
and 1% to 99% for units as percentage.

 

 

4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.

See also.  
Viewing results-Amplitude low

Source configuration panel

Source autoset
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Viewing results-Amplitude Low. Click Results to view the result for the selected
Amplitude Low measurement.

Viewing plots-Amplitude Low

Click Plots and select Time Trend or Histogram to view the plots for the selected
Amplitude Low measurement

See also.  
Select and configure measurement - Amplitude low
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High-low Select and configure measurement-Amplitude High Low. To select and configure
Amplitude High Low measurement, follow the steps: 

1. From the oscilloscope menu bar, select Analyze > Advanced Power Analysis.
The application launches with the Select tab (default) displaying the category
of measurements.

2. Select Amplitude; click High Low in the measurement pane.

3. Click Configure to configure the measurement.

 

 

Configuring the measurement

Follow the steps to configure the Amplitude High Low measurement:

1. Configure the Source configuration for the measurement. Click  for the
measurement for source configuration.

2. Configuration under Edge tab:

■ Move the Center X% of the signal determines what % (1 to 100) of a unit
interval, centered in the middle of the bit shall be admitted in each
measurement. The waveform points selected by the % form a distribution
(vertical histogram) from which a single value is extracted, based on the
method control.

■ Method determines whether the Mean value or the Median of the selected
distribution is used for the measurement value for each unit interval.

3. Configuration under Options tab:

■ Select the Units as Percentage or Absolute to set the Ref Level and
Hysteresis values in percentage or in absolute value.

■ Set the Ref level value within the range --5.99 kV to 5.99 kV for absolute
units and 1% to 99% for units as percentage.

■ Set the Hysteresis value within the range 0 V to 3 kV for absolute units
and 1% to 99% for units as percentage.

4. Configuration under Global tab:

See Configuring global settings. to set the coupling, bandwidth limit, cursor
gating and acquisition mode.

5. Click Run to acquire the data. If the measurement is successful, the
application displays the results.
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See also.  
Viewing results-Amplitude high-low

Source configuration panel

Source autoset

Viewing results-Amplitude High Low. Click Results to view the result for the
selected Amplitude High Low measurement.

Viewing plots-Amplitude High Low

Click Plots and select Time Trend or Histogram to view the plots for the selected
Amplitude High Low measurement

See also.  
Select and configure measurement - Amplitude high-low
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Tutorial

Introduction to the tutorial
This tutorial teaches you the following:

1. Reference waveform and mask files

2. Starting the Application

3. Setting Up the Oscilloscope

4. Measuring Switching Loss and viewing results

5. Measuring Magnetics and viewing results

Reference waveform and mask files
Installing the application provides the reference waveform and mask files. The
reference waveforms can be used to learn the application and the features. The
reference mask can be used to learn the mask feature for the SOA measurement.

The waveform files are found at C:\Users\Public\Tektronix\TekApplications
\Advanced Power Analysis\Waveforms\.
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The mask files are found at C:\Users\Public\Tektronix\TekApplications
\Advanced Power Analysis\SOA Mask\.
 

 

Starting the application
To start the application, from the oscilloscope menu, select Analyze > Advanced
Power Analysis.

Setting up the oscilloscope
To set up the oscilloscope, select File > Default Setup. The oscilloscope is
configured to default factory settings.
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Measuring Switching Loss
This section discuss how to measure switching loss, view the results and generate
the report. To perform these tasks, install the application and enable the option
key.

The following steps explain how to measure switching loss:

1. From the oscilloscope menu, select File > Recall.

2. In Recall window, select Waveform, set the Destination to Ref1, select
SwitchingLossSteadyStateVoltage.wfm from C:\Users\Public\Tektronix
\TekApplications\Advanced Power Analysis\Waveforms\Switching Wfms
and click Recall.

3. From the oscilloscope menu, select File> Recall.

4. In Recall window, select Waveform, set the Destination to Ref2, select
SwitchingLossSteadyStateCurrent.wfm from C:\Users\Public\Tektronix
\TekApplications\Advanced Power Analysis\Waveforms\Switching Wfms
and click Recall.

5. In DPOPWR application, select Switching Analysis tab. Click Switching
Loss, then the Configure button.
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6. In the source selection panel, set the Source to Ref, Voltage to Ref1 and
Current to Ref2.
 

 

7. Configure the options in the Type, On-Off Level, and the Options tabs. Press
the Single button.
 

 

8. The application displays the results as Turn-on Power Loss, Turn-off Power
Loss and Power Loss.
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9. Click Results tab to view the statistical results.
 

 

Measuring Magnetics
This section discuss how to measure the Magnatics, view the results and generate
the report. To perform these tasks, Installing the application and enable the
option key.

The following steps explain how to measure magnetics:

1. From the oscilloscope menu, select File > Recall.

2. In Recall window, select Waveform, set the Destination to Ref1, select
MagVoltage.wfm from C:\Users\Public\Tektronix\TekApplications
\Advanced Power Analysis\Waveforms\Magnetic Wfms and click Recall.

3. From the oscilloscope menu, select File > Recall.

4. In Recall window, select Waveform, set the Destination to Ref1, select
MagCurrent.wfm from C:\Users\Public\Tektronix\TekApplications
\Advanced Power Analysis\Waveforms\Magnetic Wfms and click Recall.

5. In DPOPWR application, select the Magnetics tab.
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1. Select the Magnetic Property option and click Configure.
 

 

2. In the Source Configuration panel, set the Source to Ref, Voltage to Ref1 and
Current to Ref2.

 

 

1. Select the Freq and Duty button, Cursor Gating Off button, # of Windings
button from the Source, Global, and Physical Chars2 tab.

2. In the Physical Chars1 tab, select the SI Unit, set the Magnetic Length to
0.0265m, and the Cross section Area to .00001358m2. In the Physical Chars2
tab, set the # of Turns to 50.
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3. Click Single to display the results in a B-H Curve format. The application
displays the results for the Bpeak, Br, Hc, HMax and I-ripple.

4. Click Results tab to view the magnetic property results.
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Application examples

About application examples
This section presents application examples. The simplified AC/DC circuit
diagram example highlight the application measurements and give you the ideas
on how to use the application to solve the test problems.

To run the application examples, install the application and enable the option key
on the oscilloscope, connect the probes to the device under test and configure the
device. To install the application, refer to Installation procedures. For more
information on compatible probes, refer to the section, Compatibility and Current
probes. To configure the application, refer to Setting up the application.

See also  

Measure switching loss

Measure Hi-Power finder

Measure magnetic loss

To increase efficiency in a switching power supply

Measure Switching Loss Purpose: To optimize the power loss at switching device and improve the
efficiency of power supply.

Specifying the equipment:.
1. Tektronix oscilloscope mentioned in the Compatibility section
2. DPOPWR application
3. Ccurrent probe and differential probe. Refer Current probes for details.
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Equipment setup:. Refer to General Safety Summary before connecting to a
circuit.

1. To measure the voltage across the drain, connect the voltage probe and the
current probe to the switching source of the MOSFET as shown in the
following diagram.

Figure 18: Equipment connection setup for Switching loss

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General
Safety Summary for more information.

2. From the Oscilloscope menu, select Analyze > Advanced Power Analysis
3. Select the Switching Analysis tab and click Switching Loss.
4. Click the configure button. In the Preferences window, select the I-Probe

Settings. Select the Perform Deskew button to deskew the probes and the
channels.

5. Select Run to acquire data and click Results to view the results..

Result Description
Minimum Measures the minimum power loss or cycle in the acquired data
Maximum Measures the maximum power loss or cycle in the acquired data
Average Measures the variation in the power loss for multiple acquisitions
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Measure Hi-Power finder Purpose: To analyze the Hi-Power Finder in a switching device in a dynamic
environment.

Specifying the equipment:.
1. Tektronix oscilloscope mentioned in the Compatibility section
2. DPOPWR application
3. Current probe and differential probe. Refer Current probes for details.
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Equipment setup:. Refer to General Safety Summary before connecting to a
circuit.

1. To measure the voltage across drain, connect the Tektronix differential and
current probe to the switching source of the MOSFET as shown in the
following diagram.

Figure 19: Equipment connection setup for Hi-Power finder

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General
Safety Summary for more information.

2. From the Oscilloscope menu, select Analyze > Advanced Power Analysis
3. Select the Switching Analysis tab.
4. Select Hi-Power Finder option and press the Configure button.
5. In the common configuration panel, select the I-Probe Settings. In the

preferences window, select the Deskew button to deskew probes and
channels.

6. Select the Hi-Power Finder measurement.
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7. Select the Deskew button to deskew. Select Run by setting the appropriate
trigger related to the dynamic environment and display the results.
 

 

The results display the instantaneous peak power in the switching and the
number of peaks in the acquired data. Select the range of interest to view the
area of interest in the instantaneous peak power.

8. You can link the cursor by selecting the instantaneous peak power from the
table.

9. Select the zoom button to view the detailed information around the cursor.

Measure magnetic loss Purpose: To measure Magnetic Loss.

Specifying the equipment:.
1. Tektronix oscilloscope mentioned in the Compatibility section
2. DPOPWR application
3. Current probe and differential probe. Refer the section Current probes for

details.
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Equipment setup:. Refer to General Safety Summary before connecting to a
circuit

1. Connect the Tektronix differential and current probe to the switching to
measure the voltage across the inductor as shown in the following diagram.

Figure 20: Equipment connection setup for Magnetic loss

WARNING. When connecting to a circuit with hazardous voltages, see the
warnings for the individual products and verify that the probes and other
components used are within their ratings. Also refer to the topic General
Safety Summary for more information.

2. From the Oscilloscope menu, select Analyze > Advanced Power Analysis
3. Select the Magnetics tab.
4. Select Magnetic Loss measurement. Select Configure. In the Global tab,

select the Cursor Gating option.
5. In the configuration tabs, set the appropriate I-Probe Settings. In the

Preferences window, select the Deskew button to deskew the voltage and
current signal.
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6. Press Run to measure and display the result shown below:
 

 
7. The result displays the power loss of the magnetic material.

Result:. The results of the Switching Loss, Hi-Power Finder and Magnetic Loss
help locate the power dissipation, reduce power loss and improve efficiency.
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GPIB commands

DPOPWR LAUnch
This command allows you to launch advance power analysis application.

Syntax DPOPWR LAUnch

DPOPWR:ADDMeas
This set-only command adds the specified measurement to the bottom of the
current Advanced Power Analysis list of measurements and will appear in the
results summary page. 

Syntax

DPOPWR:ADDMeas {SWITCHingloss | HIGHPOwerfinder | SOA | RDSon |
DVDt | DIDt | SOAXY | PULSEWidth | DUTYCycle | PERIod | FREQuency |
SKEw | INDuctance | MAGNeticproperty | MAGNETICLOSS | IV | PQuality |
CURRENTHarmonics | TOTALPowerquality | INRUSHCurrent |
INPUTCAPacitance | VOLTAGEHarmonics | LINERipple | SWITCHINGRipple
| SPECTralanalysis | TURNontime | HIGh | LOW | HIGHLow | CYCLICMIn |
CYCLICMAx | CYCLICPKpk}

Arguments UI Name Description
SWITCHingloss Switching Loss It measures the turn-on, turn-off and conduction

losses of each cycle of voltage and current
signals.

HIGHPOwerfinder Hi-Power Finder It measures the power peaks for turn-on and
turn-off region, which are positions where
maximum power dissipation is happening.

SOA SOA It measures Graphically represent the Safe
Operating area of power semiconductor devices
indicating the maximum operation voltage and
current on the acquired waveform for the entire
acquired record length.

RDSon RDS(on) It measures Dynamic resistance offered by the
switching device while is in ON condition.

DVDt dv/dt It measuresTransient response which
represents the change of voltage during
switching.

DIDt di/dt It measures Current Transient response which
represents the rate of change of current during
switching.
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Arguments UI Name Description
SOAXY SOA X-Y(DPX) It is Plotting of the Voltage on the X-axis and

Current on the Y -axis.
PULSEWidth Pulse Width The difference in time (positive or negative)

between the leading edge and trailing edge of a
pulse.

DUTYCycle Duty Cycle Calculate the ratio of the positive (or negative)
portion of the cycle relative to the period.

PERIod Period Clock Period measurement which calculates the
duration of a cycle as defined by a start and a
stop edge.

FREQuency Frequency Clock Frequency measurement which calculates
the inverse of the clock period for each cycle.

SKEw Skew To measure the delay between two periodic
signals.

INDuctance Inductance The value of inductance will give the picture of
the Core behavior while it is under operation.

MAGNeticproperty Magnetic Property It measures the parameters related to the
magnetic material in a magnetic component
used in an in-circuit operation.

MAGNETICLOSS Magnetic Loss Cycle of the data points of the integral waveform
is identified using the cycle in current waveform
as reference.

IV It is an XY plot of integral of voltage against
current.

PQuality Power Quality Power Quality, which provides a single table of
measurements and measurement statistics for
the AC input section of a power conversion
circuit.

CURRENTHarmonics Current Harmonics It performs the harmonic calculation in dbA and
RMS units based on fundamental harmonic
frequency for various standards.

TOTALPowerquality Total Power Quality Provides power quality and current harmonics
measurements in a single display.

INRUSHCurrent In Rush Current To perform Peak Inrush Current measurement
and Capacitance value for switching power
supply during in-circuit operation.

INPUTCAPacitance Input Capacitance Measures the capacitance value using switching
voltage and current during turn on of the
switching device.

VOLTAGEHarmonics Voltage Harmonics It performs the harmonic calculation for the
voltage source channel based on fundamental
harmonic frequency.

LINERipple Line Ripple It measures peak-to-peak ripple voltage present
on a DC or low-frequency AC voltage stated for
each cycle.
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Arguments UI Name Description
SWITCHINGRipple Switching Ripple It Measures the amount of AC signal related to

switching frequency.
SPECTralanalysis Spectral Analysis Spectral analysis measures frequency

components of the output voltage of a power
converter.

TURNontime Turn On Time AC Turn ON time is the time difference between
the input voltage applied to the system and the
time to develop the output voltage.

HIGh High The High Amplitude measurement calculates the
mean or mode of a selected portion of each unit
interval.

LOW Low The Low Amplitude measurement calculates the
mean or mode of a selected portion of each unit
interval.

HIGHLow High Low The High–Low measurement calculates the
change in voltage level across a transition in the
waveform.

CYCLICMIn Cycle Min Cycle Min measures negative peak of the
waveform for all cycles. It is the minimum
voltage for each cycle from the mid level of Fall
to the Rise slope.

CYCLICMAx Cycle Max Cycle Max measures positive peak for all cycles.
It is the maximum voltage for each cycle from
the mid level of rise to the fall slope.

CYCLICPKpk Cycle PkPk Cycle Pk-Pk measures the absolute difference
between the maximum and minimum amplitude
for every cycle of the waveform.

Example

DPOPWR:ADDMeas HIGh to add the High measurement to the measurement
table list.
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DPOPWR:CLEARALLMeas
This clear only command allows you to clear all the added measurements. 

Syntax

DPOPWR:CLEARALLMeas
Example

DPOPWR:CLEARALLMeas to clear all the added measurements.

DPOPWR:CLEARALLPlots
This clear only command allows you to clear all the added plots. 

Syntax

DPOPWR:CLEARALLPlots
Example

DPOPWR:CLEARALLPlots to clear all the added plots.

DPOPWR:FREerun
This set only command allows you to start the continuous run on the list of
measurements. 

Syntax

DPOPWR:FREerun
Example

DPOPWR:FREerun to start the continuous run on the list of measurements.
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DPOPWR:GENREPAS
This command allows you to generate the report and save as specified string. 
Syntax

DPOPWR:GENREPAS <String>
Arguments

<String> is the file name specified for the report and the argument must be in
double quotes. The file name should not exceed 240 characters and cannot
contain ",<,>,|, #,*,?.
Output

Report in *.MHTML format is generated.
Example

DPOPWR:GENREPAS "SwitchingLossPFC" to generate and save the report as
SwitchingLossPFC.MHTML.

DPOPWR:GENREPort
This command allows you to generate and open the report for the run or
completed measurement list. 

Syntax

DPOPWR:GENREPort
Example

DPOPWR:GENREPort to generate and open the report of completed
measurement list.
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DPOPWR:LASTError?
This query only command returns last occurred error. 
Syntax

DPOPWR:LASTError?
Output

Returns the error code and description of last occurred error.
Example

DPOPWR:LASTError? to query the last error occurred.

DPOPWR:MEAS(x):ACCMAx?
This command allows you to query the accumulated maximum value for the
measurement. 

Syntax

DPOPWR:MEAS<x>:ACCMAx?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the maximum value of accumulated result for the measurement.
Example

DPOPWR:MEAS2:ACCMAx? to query the maximum value of accumulated
result for the second measurement of the added list.
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DPOPWR:MEAS(x):ACCMEAn?
This command allows you to query the accumulated mean value for the
measurement. 

Syntax

DPOPWR:MEAS<x>:ACCMEAn?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the mean value of accumulated result for the measurement.
Example

DPOPWR:MEAS2:ACCMEAn? to query the mean value of accumulated result
for the second measurement of the added list.

DPOPWR:MEAS(x):ACCMIn?
This command allows you to query the accumulated minimum value for the
measurement.. 

Syntax

DPOPWR:MEAS<x>:ACCMIn?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the minimum value of accumulated result for the measurement.
Example

DPOPWR:MEAS2:ACCMIn? to query the minimum value of accumulated result
for the second measurement of the added list.
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DPOPWR:MEAS(x):ACCPKTopk?
This command allows you to query the accumulated peak to peak value for the
measurement. 

Syntax

DPOPWR:MEAS<x>:ACCPKTopk?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the peak-to-peak value of accumulated result for the measurement.
Example

DPOPWR:MEAS2:ACCPKTopk? to query the peak-to-peak value of
accumulated result for the second measurement of the added list.

DPOPWR:MEAS(x):ACCPOPulation?
This command allows you to query the accumulated population value for the
measurement. 

Syntax

DPOPWR:MEAS<x>:ACCPOPulation?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the population value of accumulated result for the measurement.
Example

DPOPWR:MEAS2:ACCPOPulation? to query population value of accumulated
result for the second measurement of the added list.
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DPOPWR:MEAS(x):ACCResult?
This command allows you to query the accumulated status value for the
measurement. 

Syntax

DPOPWR:MEAS<x>:ACCResult?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Success or Fail
Example

DPOPWR:MEAS2:ACCResult? to query status of accumulated result for the
second measurement of the added list.

DPOPWR:MEAS(x):ACCSTDdev?
This command allows you to query the accumulated standard deviation value for
the measurement. 

Syntax

DPOPWR:MEAS<x>:ACCSTDdev?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the standard deviation value of accumulated result for the measurement.
Example

DPOPWR:MEAS2:ACCSTDdev? to query standard deviation value of
accumulated result for the second measurement of the added list.
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DPOPWR:MEAS(x):ACQmode
This command allows you to query or set the acquisition mode as Sample, Hi Res
or Average. 

Syntax

DPOPWR:MEAS<x>:ACQmode?

DPOPWR:MEAS<x>:ACQmode {SAMple | HIRes | AVErage}
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.

SAMple: Set the acquisition mode as Sample.

HIRes: Set the acquisition mode as Hi-Res.

AVErage: Set the acquisition mode as Average.
Output

Returns the configured acquisition mode for the measurement.
Example

DPOPWR:MEAS2:ACQmode HIRes to set the acquisition mode as Hi Res for
all added measurement..

DPOPWR:MEAS3:ACQmode? to query the configured acquisition mode for all
added measurement..

DPOPWR:MEAS(x):ADDPLOT
This set only command allows you to add plots for the measurements. 

Syntax

DPOPWR:MEAS<x>:ADDPLOT {SWITCHINGLOSS | TIMEtrend | RISEedge
| FALLEdge | HISTogram | POWERTIMEtrend | ENErgytimetrend | BARgraph |
SPECTrum | INDUctanceplot | BHPlot | IVPlot}

Arguments UI Name Description
SWITCHINGLOSS Switching On OFF

Trajectory
It is a trajectory plot of switching voltage versus
current waveform for all ON and OFF cycles in
the acquisition.

TIMEtrend Time Trend It is waveform trace of a measurement versus
time. Each measurement value is placed
precisely at the time at which the measurement
took place.

RISEedge Rise Edge(s)-Time
Trend

It is a time trend plot of rise edge for di/dt and
dv/dt measurements.

FALLEdge Fall Edge(s)-Time
Trend

It is a time trend plot of fall edge for di/dt and dv/
dt measurements.
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Arguments UI Name Description
HISTogram Histogram It displays the results such that the horizontal

axis represents the measurement values and
the vertical axis represents the number of times
that each value occurred.

POWERTIMEtrend V*I Power Waveform It is power (V*I) waveform plot versus time.
ENErgytimetrend

Energy
Waveform

Energy waveform plot is Integral of V * I.

BARgraph Harmonics Bar Graph It has x-axis a harmonic number and y-axis is
harmonic value in dB or RMS.

SPECTrum Spectrum It is a plot in frequency domain, which Y-axis
presents the magnitude in dB/RMS of frequency
component on X-axis.

INDUctanceplot Inductance curve The property of an electric circuit as a result of
which an electromotive force is created by a
change of current in the same circuit (self-
inductance) or in a neighbouring circuit (mutual-
inductance). It is measured in henries and plot
with respect to time.

BHPlot BH Curve The BH Plot of a magnetic material represents
the relationship between its magnetic flux
density B on y-axis as a function of the magnetic
field intensity H on x-axis.

IVPlot

Example

DPOPWR:MEAS2:ADDPLOT SWITCHINGLOSS to add Switching Loss plot
for the second measurement of the added list.

NOTE. Adding plots will be successful only if the measurement supports the
particular plot. For information about correlation of measurements to plots Click
here
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DPOPWR:MEAS(x):AUTOZero
This set only command removes the DC offset, when the probe has no input
signals.

Syntax

DPOPWR:MEAS<x>:AUTOZero
Inputs

<x> defines the measurement row number. The value ranges from 1 to 10.
Example

DPOPWR:MEAS2:AUTOZero set only command removes the DC offset for
second measurement of the added list.

DPOPWR:MEAS(x):BWLimit
This command allows you to query or set the bandwidth to 20 MHz, 250 MHz or
Full. 

Syntax

DPOPWR:MEAS<x>:BWLimit?

DPOPWR:MEAS<x>:BWLimit BWL20MHz

DPOPWR:MEAS<x>:BWLimit BWL250MHz

DPOPWR:MEAS<x>:BWLimit Full
Inputs

<x> defines the measurement row number. The value ranges from 1 to 10.

BWL20MHz: To set the bandwidth limit to 20MHz

BWL250MHz: To set the bandwidth limit to 250 MHz

Full: To set the bandwidth limit to maximum value supported by scope.
Output

Returns the configured bandwidth limit value for the measurement.
Example

DPOPWR:MEAS2:BWLimit BWL20MHz to set the bandwidth limit to 20 MHz
for all added measurement..

DPOPWR:MEAS3:BWLimit? to query the configured bandwidth limit value for
all added measurement..
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DPOPWR:MEAS(x):COUPling
This command allows you to query or set the coupling to AC or DC. 

Syntax

DPOPWR:MEAS<x>:COUPling?

DPOPWR:MEAS<x>:COUPling {AC | DC}
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.

AC | DC to set the signal coupling type as AC or DC
Outputs

Returns the signal coupling type for the measurement.
Example

DPOPWR:MEAS2:COUPling DC to set the signal coupling type as DC for all
added measurement..

DPOPWR:MEAS3:COUPling? to query the signal coupling type for all added
measurement.

DPOPWR:MEAS(x):CURGATing
This command allows you to query or set the cursor gating to On or Off. 

Syntax

DPOPWR:MEAS<x>:CURGATing?

DPOPWR:MEAS<x>:CURGATing {ON | OFF}
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.

ON | OFF to set the cursor gating On or Off
Outputs

Returns the status of the cursor gating for the measurement.
Example

DPOPWR:MEAS2:CURGATing ON to set the cursor gating as On for all added
measurement..

DPOPWR:MEAS3:CURGATing? to query the cursor gating status for all added
measurement..
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DPOPWR:MEAS(x):CURRENTMAx?
This command allows you to query the current maximum value for the
measurement. 

Syntax

DPOPWR:MEAS<x>:CURRENTMAx?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the maximum value of current result for the measurement.
Example

DPOPWR:MEAS2:CURRENTMAx? to query maximum value of current result
for the second measurement of the added list.

DPOPWR:MEAS(x):CURRENTMEAn?
This command allows you to query the current mean value for the measurement. 

Syntax

DPOPWR:MEAS<x>:CURRENTMEAn?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the mean value of current result for the measurement.
Example

DPOPWR:MEAS2:CURRENTMEAn? to query mean value of current result for
the second measurement of the added list.
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DPOPWR:MEAS(x):CURRENTMIn?
This command allows you to query the current minimum value for the
measurement.

Syntax

DPOPWR:MEAS<x>:CURRENTMIn?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the minimum value of current result for the measurement.
Example

DPOPWR:MEAS2:CURRENTMIn? to query minimum value of current result
for the second measurement of the added list.

DPOPWR:MEAS(x):CURRENTPKTopk?
This command allows you to query the current peak to peak value for the
measurement. 

Syntax

DPOPWR:MEAS<x>:CURRENTPKTopk?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the peak-to-peak value of current result for the measurement.
Example

DPOPWR:MEAS2:CURRENTPKTopk? to query peak-to-peak value of current
result for the second measurement of the added list.
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DPOPWR:MEAS(x):CURRENTPOPulation?
This command allows you to query the current population value for the
measurement.

Syntax

DPOPWR:MEAS<x>:CURRENTPOPulation?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the population value of current result for the measurement.
Example

DPOPWR:MEAS2:CURRENTPOPulation? to query population value of current
result for the second measurement of the added list.

DPOPWR:MEAS(x):CURRENTResult?
This command allows you to query the current status value for the measurement. 

Syntax

DPOPWR:MEAS<x>:CURRENTResult?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Success or Fail
Example

DPOPWR:MEAS2:CURRENTResult? to query the status of current result for the
second measurement of the added list.
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DPOPWR:MEAS(x):CURRENTSTDdev?
This command allows you to query the current standard deviation value for the
measurement. 

Syntax

DPOPWR:MEAS<x>:CURRENTSTDdev?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Returns the standard deviation value of current result for the measurement.
Example

DPOPWR:MEAS2:CURRENTSTDdev? to query standard deviation value of
current result for the second measurement of the added list.

DPOPWR:MEAS(x):CUSTomname?
This command allows you to query the measurement instants name in the table.
This command is useful when multiple instants of same measurements are added.

Syntax

DPOPWR:MEAS<x>:CUSTomname?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Measurement instants name and number
Example

DPOPWR:MEAS2:CUSTomname? to query the measurement instance of the
second measurement in the list. For e.g. If second measurement in the list is
Switching Loss1 then output will be Switching Loss1
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DPOPWR:MEAS(x):DEGauss
This set only command performs Degauss on current probe.

Syntax

DPOPWR:MEAS<x>:DEGauss
Inputs

<x> defines the measurement row number. The value ranges from 1 to 10.
Example

DPOPWR:MEAS2:DEGauss set only command performs degauss on current
probe for second measurement of the added list.

DPOPWR:MEAS(x):GATESOURce
This command allows you to query or set the source of the selected
measurement.. 

Syntax

DPOPWR:MEAS<x>:GATESOURce?

DPOPWR:MEAS<x>:GATESOURce <source>
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.

<source> = CH1, CH2, CH3, CH4, MATH1, MATH2, MATH3, MATH4, REF1,
REF2, REF3, REF4.
Outputs

Returns the gate source channel for the measurement.
Example

DPOPWR:MEAS3:GATESOURce CH1 to set the gate source channel as CH1
for the third measurement of the added list.

DPOPWR:MEAS2:GATESOURce? to query the gate source channel for the
second measurement of the added list.
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DPOPWR:MEAS(x):ISOURce
This command allows you to query or set the current source of the selected
measurement.. 

Syntax

DPOPWR:MEAS<x>:ISOURce?

DPOPWR:MEAS<x>:ISOURce <source>
Input

<x> defines the measurement row number. The value ranges from 1 to 10.

<source> = CH1, CH2, CH3, CH4, MATH1, MATH2, MATH3, MATH4, REF1,
REF2, REF3, REF4.
Output

Returns the current source channel for the measurement.
Example

DPOPWR:MEAS3:ISOURce CH1 to set the current source channel as CH1 for
the third measurement of the added list.

DPOPWR:MEAS2:ISOURce? to query the current source channel for second
measurement of the added list.

DPOPWR:MEAS(x):NAMe?
This command allows you to query the measurement name of the added list. 

Syntax

DPOPWR:MEAS<x>:NAMe?
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Output

Measurement name
Example

DPOPWR:MEAS3:NAMe? to query the measurement name of the third
measurement from the added list. For e.g. If third measurement in the list is
Switching Loss1 then output will be Switching Loss
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DPOPWR:MEAS(x):SELectmeas
This command allows you to select the instant from the list of added
measurement.

Syntax

DPOPWR:MEAS<x>:SELectmeas
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.
Example

DPOPWR:MEAS1:SELectmeas to select the first measurement of the added
measurement list.

DPOPWR:MEAS(x):SOURCEAPPLYAll
This set only command allows you to apply the source configuration of
measurement <x> to all the measurements in the added list. 

Syntax

DPOPWR:MEAS<x>:SOURCEAPPLYAll
Inputs

<x> defines the measurement row number. The value ranges from 1 to 10.
Example

DPOPWR:MEAS1:SOURCEAPPLYAll to apply the source configuration of
measurement 1 to all the measurements in the added list.
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DPOPWR:MEAS(x):SOURCEAutoset
This command allows you to query or set the source autoset for the
measurements. 
Syntax

DPOPWR:MEAS<x>:SOURCEAutoset?

DPOPWR:MEAS<x>:SOURCEAutoset {VERTical | HORizontal | Both |
UNDO}
Input

<x> defines the measurement row number. The value ranges from 1 to 10.

VERTical: To set the source autoset as vertical

HORizontal: To set the source autoset as horizontal

Both: To set the source autoset to both vertical and horizontal

UNDO: To remove the source autoset configuration.
Output

Returns the source autoset for the measurement.
Example

DPOPWR:MEAS2:SOURCEAutoset VERTical to set the source autoset as
vertical for the second measurement of the added list.

DPOPWR:MEAS3:SOURCEAutoset? to query the source autoset for the third
measurement of the added list.

NOTE. Source autoset will set the scale of the scope, which satisfy all the added
measurement list.
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DPOPWR:MEAS(x):VSOURce
This command allows you to query or set the voltage source channel for the
measurement. 

Syntax

DPOPWR:MEAS<x>:VSOURce?

DPOPWR:MEAS<x>:VSOURce <source>
Arguments

<x> defines the measurement row number. The value ranges from 1 to 10.

<source> = CH1, CH2, CH3, CH4, MATH1, MATH2, MATH3, MATH4, REF1,
REF2, REF3, REF4.
Outputs

Returns the voltage source channel for the measurement.
Example

DPOPWR:MEAS3:VSOURce CH1 to set the voltage source channel as CH1 for
the third measurement of the added list.

DPOPWR:MEAS2:VSOURce? to query the voltage source channel for second
measurement of the added list.

DPOPWR:OPC?
This command allows you to query whether last performed operation is
completed or not.

Syntax DPOPWR:OPC?

Output Returns 1 if the last performed operation is completed else 0.
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Example DPOPWR:OPC? to query whether last performed operation is completed or not.

DPOPWR:RECalc
This command recalculates the selected measurements on the current acquisition. 

Syntax

DPOPWR:RECalc
Example

DPOPWR:RECalc to recalculate results the list of measurements for the acquired
waveform.

DPOPWR:SELECTEDMeas?
This query command displays the selected measurement information. 

Syntax

DPOPWR:SELECTEDMeas?
Output

Returns the selected measurement name.
Example

DPOPWR:SELECTEDMeas? to query the selected measurement name.
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DPOPWR:SINgle
This command allows you to perform single run for the list of added
measurements. 

Syntax

DPOPWR:SINgle
Example

DPOPWR:SINgle to perform single run for the list of measurements.

DPOPWR:Stop
This set only command allows you to stop the continuous run on the list of
measurements. 

Syntax

DPOPWR:Stop
Example

DPOPWR:Stop to stop the continuous run on the list of measurements.

DPOPWR:VERsion?
This command allows you to query version number of the installed advance
power analysis application.

Syntax DPOPWR:VERsion?

Output Returns version number of installed advance power analysis application.
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Reference

Error codes for DPOPWR

Error Codes Error Message Description Possible Solutions
800 Selected point is not

valid.
Error cause from unit
testing.

Error solution from unit
testing.

1000 To avoid potential
shock while using " +
DPOPowerConstants.A
pplicationLongName +
" application, use only
appropriately rated
voltage and current
probes, accessories
and other equipment.
Refer to manufacturer's
documentation for each
product.

Check the probes are
in working condition.

Check the probes are
in working condition

1001 The maximum number
of MATH dependent
measurements has
been reached.

All math channels have
been consumed either
to display or input the
measurements.

Remove at least one
math dependent
measurement to run
any other.

1002 Mismatch in
measurements group
detected. Press Yes to
clear the list and add
the new measurement.
Press No to return
without any
modification.

Some measurements
like SOA X-Y (DPX),
Turn On Time, and
similar measurements,
cannot be run with
other measurements as
they need their own
autoset.

To run other
measurements, remove
these measurements
from the list. Clicking
Yes will clear the list
and add the new
measurement. Clicking
No will retain the old
one.

1003 Conflict in selection of
Math Input and
Destination in
<Measurement Name>.

In measurements which
have Math as both
input and output, there
should not be a conflict
in the Math channels
selected.

Change either one of
Math input/output
destinations to continue
with the measurement.

1004 Empty waveform. The waveform acquired
has no samples.

Connect a valid signal
to the channels
selected, and the
device should be
turned On.
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Error Codes Error Message Description Possible Solutions
1005 Conflict in selection of

output sources.
In Turn On Time
measurement, 3 output
sources can be
selected. If any two of
them are the same, this
error is displayed.

Select different
channels for all
3 outputs in Turn On
Time.

1006 Conflict in selection of
input and output
sources.

In Turn On Time
measurement, 1 input
and a maximum
3 output sources can
be selected. If the input
source channel
matches any of the
output source
channels, this error is
displayed.

Select a different input
channel from any of the
output channels
selected.

1007 Cannot select Live and
Ref sources together in
<Measurement Name>.

In Source OCW, for
any particular
measurement, Ref and
Live sources cannot be
selected as input. The
measurement with the
conflict is mentioned at
the end of the error
message.

Select either Ref or
Live for both channels.

1008 Conflict in selection of
sources in
<Measurement Name>.

This error is generated
if there is a conflict in
any measurement
where sources can be
configured from the
configuration panel, like
Magnetic Property
secondary Windings.

Select different
channels as primary
sources and secondary
sources in Magnetic
Property.

1009 Cannot select Ref as
Input source and Live
as Output source.

In Turn On Time
measurement, input
source has been
selected as Ref and
output source(s) as
Live.

Select either both input
and output as Ref or
both as Live.

1010 Please disconnect
probes on <Channel(s)
Name> and click Ok to
continue.

Pre Degauss message,
shown to halt execution
until probes are
disconnected and Ok is
clicked.

Disconnect the probes
and click ok to continue
with the Degauss
procedure.

1011 DeGauss Done,
reconnect the probes.

DeGauss Done Rreconnect the probes
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Error Codes Error Message Description Possible Solutions
1012 Positive and/or

negative clipping
detected. Please check
the device and run
again.

The waveform has
positive or negative
clipping and the
measurement should
not be run.

Make sure that the
vertical scale is set
properly and the device
is working properly.

1013 Conflict in selection of
Math destinations in
<Measurement Name>.

In Switching Loss and
High Power Finder,
when run on different
channels, same Math
destination is
configured for output.

Change the output
Math destination in
either one of the
measurements
selected.

1014 Set cursors to required
position. Press Yes to
continue. Press No to
Stop processing.

Cursors need to be set
before measurement
continues.

Set cursors to required
position. Press Yes to
continue. Press No to
Stop processing.

1015 Degauss hasn't been
done. Please Degauss
before autoset.

Autoset is being
performed without
degaussing the current
probe(s) connected.
This will stop the
autoset process.

Degauss the current
probes first, before
clicking any of the
autoset methods.

1016 Degauss Failed. Either the Jaw of the
current probe(s) is
open or it is still
connected to the
probing point with
power.

Close the jaw properly
and/or disconnect the
current probe from the
probing point.

1017 SOA is a plot
dependent
measurement and the
maximum number of
plots has been
reached. Please clear a
measurement or a plot
and then add the SOA
measurement for
analysis.

A maximum of 4 plots
can be added in the
plots list, and SOA is a
plot dependent
measurement, so
maximum of
4 instances of SOA can
be run at once.

Remove at least one
SOA measurement
from the active list to
run any other
measurement with a
plot.

1018 Unable to acquire the
waveform. Run the
measurement again.

Unable to trigger and
acquire the waveform.

Set the trigger level
properly, connect a
valid signal to the
probes, and run the
measurement again.
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Error Codes Error Message Description Possible Solutions
1019 Magnetic Property

cannot be analyzed
with other
measurements with
More windings
configuration.

With More windings
configuration, only
1 instance of Magnetic
Property can be run.
Also, it cannot be
grouped with other
measurements in this
case.

Run Magnetic Property
with More windings
configuration alone or
change it to Two/Single
winding to run it with
other measurements.

1020 The maximum number
of Current Harmonics
or Total Power Quality
measurements has
been reached.

Only one instance at a
time is allowed for
current harmonics and
power quality
measurements.

Select only one
instance at a time for
current harmonics and
total power quality.

1021 Unable to Degauss
probe on
<ChannelName>.

Degauss is taking too
long, possibly the probe
is faulty.

Check the probe and
replace with a working
probe if faulty.

1022 No Data available to
plot in
<MeasurementName>.
Check the waveform(s)
and configurations and
then re-run the
measurement.

The acquisition and/or
measurement may
have failed.

Acquire again and
Rerun the
measurement with
appropriate
configurations.

1023 No ON cycle data
available to plotting.
Check the waveform(s)
and then re-run the
measurement.

ON cycle(s) are not
found in the selected
area of the waveform
(happens if the cursor
gating is on and a
narrow region of the
waveform is selected)
or this happens when
coupling is set to AC in
application Global
parameter.

Adjust the scale to
have at least one ON
cycle and rerun the
measurement or check
coupling in application
Global parameter,
make sure appropriate
coupling is set
otherwise both Voltage
and Current can go
negative when DC
rejection happens. Set
the coupling to DC
coupling and perform
autoset.

1024 No OFF cycle data
available to plotting.
Check the waveform(s)
and then re-run the
measurement.

OFF cycle(s) are not
found in the selected
area of the waveform
(happens if the cursor
gating is on and a
narrow region of the
waveform is selected).

Adjust the scale to
have at least one OFF
cycle and rerun the
measurement.
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Error codes for DPOPWR cont.

Error Codes Error Message Description Possible Solutions
1700 Unable to perform

computation on the
waveform data. Source
waveforms have
different time/div
settings.

The voltage and current
waveforms have
different time/div
settings.

Try to run the selected
measurement with the
voltage and current
waveforms acquired
simultaneously.

1701 Unable to perform
computation on the
waveform data. Source
waveforms have
different record lengths.

The voltage and current
waveforms have
different record lengths.

Try to run the selected
measurement with the
voltage and current
waveforms acquired
simultaneously with the
same record length.

1702 Higher sample rate is
required for accurate
measurement.

The time/div settings
for the selected
waveform is too high.
Alternatively, sampling
rate is too low.

On the oscilloscope
menu bar, click Horiz /
Acq > Horizontal/
Acquisition Setup. In
the Horizontal tab,
decrease the time base
or increase the record
length value.

1703 Ensure that at least one
complete cycle is
available for analysis.

The signal has less
than one cycle in the
specified record length.

Decrease the time/div
settings of the
oscilloscope to have
more cycles.

1704 Ensure that the cycle
has more than
20 sample points.

Make sure that the
cycle has more than
20 sample points.

Increase the record
length value and/or
decrease the time/div
settings of the
oscilloscope.

1705 Unable to get the
frequency value when
queried from the
oscilloscope.

Unable to measure
Frequency due to the
non availability of a
complete cycle.

Run the measurement
again.

1706 Insufficient edges for
the Modulation Analysis
measurement.

Insufficient edges found
on the source
waveform. At least two
edges are required to
run the measurement.

1) Decrease the
horizontal scale to get
complete cycles of the
waveform.
2) Select the source
that has a signal cyclic
in nature.
3) Adjust the Ref and
Hysteresis Levels of
the signal to find the
edge at the required
level.
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Error Codes Error Message Description Possible Solutions
1707 The Ref Level value is

outside the voltage
range of the waveform.
Enter a proper Ref
Level value.

Unable to locate the
edges on the waveform
at the transition
because the voltage
level does not fall in the
transition of the
waveform.

Enter the Ref Level
value where the
transition occurs on the
waveform. Enter
50 percent of the level
of the peak-to-peak
transition level.

1708 Unable to plot SOA
because of insufficient
data points.

There are insufficient
data points to plot.

Place the cursors on
the waveform where at
least two data points
are present between
the cursors.

1709 Change the time/div
setting to 10 ms/div.

The current harmonics
algorithm (IEC
standard) requires the
horizontal scale to be
10 ms.

Change the horizontal
scale to 10 ms using
the knobs on the
oscilloscope front
panel.

1710 Incorrect record length. The current harmonics
algorithm (IEC
Standard) requires the
record length value of
the waveform to be
2500.

The record length
availability for the set
time base depends
upon the number of
active channels. Turn
off the channels which
are not required for the
measurement. On the
oscilloscope menu bar,
click Horiz /Acq >
Horizontal/Acquisition
Setup. In the Horizontal
tab, change the record
length value to 2500.

1711 Calculated true power
is negative.

This happens if: 1) The
direction of current and
voltage polarity is
reversed. 2) The
current has phase shift
more than voltage by
90 degrees. 3) The
frequency of the signal
is not equal to the
selected input
frequency for the
harmonic
measurement.

Make sure that the
direction of current and
voltage polarity is right.
Make sure that the
frequency of the signal
is equal to the selected
frequency.

1712 Class D detected;
Harmonic limits will be
set to Class D.

Equipment Class A was
selected; Class D is
detected.

Configure Class D and
run the measurement
again.

1713 Class A detected;
Harmonic limits will be
set to Class A.

Equipment Class D
was selected; Class D
is not detected.

Configure Class A and
run the measurement
again.
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1714 Set the horizontal scale

to 200 ms and the
record length value to
1 M.

The current harmonics
algorithm (MIL
standard) requires the
horizontal scale to be
200 ms and the record
length value to be 1 M.

1) Unable to set the
required length and
time base combination
because the record
length availability for
the set time base
depends upon the
number of active
channels. 2) Turn off
the channels which are
not required for the
measurement. 3)
Change the horizontal
scale to 200 ms and
the record length value
to 1 M.

1715 Set the horizontal scale
to 400 ms and the
record length value to
2 M.

The current harmonics
algorithm (MIL
standard) requires the
horizontal scale to be
400 ms and the record
length value to be 2 M.

1) Unable to set the
required length and
time base combination
because the record
length availability for
the set time base
depends upon the
number of active
channels. 2) Turn off
the channels which are
not required for the
measurement. 3)
Change the horizontal
scale to 400 ms using
the oscilloscope front
panel. Set the record
length value to 2 M.

1716 Set the horizontal scale
to 200 ms and the
record length value to
125000.

The current harmonics
algorithm (MIL
standard) requires the
horizontal scale to be
200 ms and the record
length value to be
125000.

Change the horizontal
scale to 200 ms and
the record length value
to 125000.

1717 Set the horizontal scale
to 400 ms and the
record length value to
1 M.

The current harmonics
algorithm (IEC
A14 standard) requires
the horizontal scale to
be 400 ms and the
record length value to
be 1 M.

Change the horizontal
scale to 400 ms and
the record length value
to 1 M.
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1718 Set the horizontal scale

to 400 ms and the
record length value to
125000.

The current harmonics
algorithm (MIL
standard) requires the
horizontal scale to be
400 ms and the record
length value to be
125000.

Change the horizontal
scale to 400 ms and
the record length value
to 125000.

1719 Unable to calculate
harmonics for the
record length and
sampling rate
combination.

Current harmonics
could not be run for the
record length and
sample rate
combination.

Change the horizontal
scale and the record
length value.

1720 Calculated power is
more than 25 W. Set
the value greater than
25 W and enter the
power factor and input
current.

IEC Amendment
14 requires that the
power factor and input
current are entered by
the user for Class C
equipment when the
power is more than
25 W.

Enter power greater
than 25 W and enter
the current and power
factor values.

1721 Not enough samples
available for analysis.

The slope calculation
requires at least three
samples.

On the oscilloscope
menu bar, click Horiz /
Acq > Horizontal/
Acquisition Setup. In
the Horizontal tab,
increase the record
length value.

1722 Low level cannot be
greater than high level.

The dv /dt low level
cannot be greater than
high level.

Enter levels such that
low is lesser than high.

1723 Levels entered are not
within the range of the
waveform.

Unable to locate the
edges on the waveform
at the transition
because the voltage
level does not fall in the
transition of the
waveform.

Enter the Ref Level
voltage where the
transition occurs on the
waveform. Enter the
50 percent of the level
of the peak-to-peak
transition level.

1724 Oscilloscope settings
changed. Run the
measurements di/dt
and dv/dt again.

If you change any of
the vertical or
horizontal settings, then
the oscilloscope goes
into preview mode after
running di/dt and dv /dt
for edge analysis.

Do not change the
settings after the
results are obtained for
di/dt and dv /dt.

1725 Unable to perform di/dt
for the configured
levels.

The configured levels
are not found on the
edge. The cursors are
placed for maximum di/
dt.

Reconfigure the levels.
Run the measurement
again.
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1726 Unable to associate

cursor to the selected
data.

Unable to associate the
cursor to the identified
data of the power.

The oscilloscope
settings have been
altered. Run the
measurement again.

1727 Unable to calculate dv/
dt for the configured
levels.

Configured levels not
found on the edge.

Reconfigure the levels.

1728 Set the coupling to
1 M Ohm.

Selected channel input
coupling is set to
50 Ohm.

Use TCS-1M convertor
to run the
measurement with DC
block enabled. Then,
run the measurement
with DC block disabled.
Change the coupling to
1 M on the
oscilloscope.

1729 Start frequency cannot
be more than or equal
to stop frequency.

The entered value of
start frequency is
higher than stop
frequency.

The entered value of
start frequency is
higher than stop
frequency.

1730 The frequency
resolution (sample rate/
record length) is more
than the stop
frequency.

The frequency
resolution of the signal
for the record length
and sampling rate
combination is more
than the stop frequency
component.

Increase the record
length value or
decrease the sampling
rate such that the stop
frequency is more than
the frequency
resolution (frequency
resolution = sampling
rate/record length) and
run the measurement
again.

1731 Configured sample rate
is less than twice the
stop frequency.

Sampling rate should
be more than or equal
to twice the stop
frequency for accurate
analysis to prevent
aliasing.

Increase the sampling
rate such that sampling
rate is more than or
equal to twice the stop
frequency.

1732 Frequency resolution
(sample rate/record
length) is larger than
the range of frequency.

The frequency
resolution of the signal
for the record length
and sampling rate
combination is more
than the range of
frequencies to be
analyzed.

Decrease the stop
frequency value to run
or use the autoset
option for automatic
record length and time
base settings.

1733 1 M Coupling required;
DC block cannot be
performed.

50 ohms coupling is
required for the DC
block operation.

Set coupling to 1 Meg.
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1734 File path not available

to save the Spectral
Analysis plot.

Path entered for saving
the plot is not valid.

Enter a valid path
name.

1735 The RBW value was
not updated. It will be
set to the maximum
value.

RBW values are not
updated for the
selected start, stop
frequency, and window
type.

Update RBW values
after selecting start/
stop frequency and
window type before you
run the measurement.

1736 The oscilloscope
settings have changed.
Cannot set the selected
RBW value.

You might have
changed the settings
on the oscilloscope
after updating the RBW
values for the selected
start/stop frequency
window type.

Update RBW values
after selecting start/
stop frequency/window.
Do not change the
oscilloscope settings
after updating RBW
values.

1737 The configured
frequency range is not
supported by the
spectral analysis
measurement.

For the range selected,
there are no RBW
values available for the
spectral analysis
measurement.

Increase the start
frequency value or
decrease the stop
frequency value. To run
without autoset,
uncheck Auto Setup in
the options pane.

1738 Timing synchronization
of the previously
acquired waveform is
not matching the
current acquisition.

Time domain
synchronization is
essential for the
calculation of results
even though the
waveforms were not
acquired
simultaneously.

The synchronization is
checked for the given
trigger level, trigger
position, and cursor
position for the present
waveform with the
previously acquired
waveform. Do not
change these settings,
which results in loss of
synchronization. Run
the Magnetic Property
measurement again.

1739 Number of data points
in a cycle is less than
10.

The number of data
points in the identified
cycle is less than 10.
Increase hysteresis and
Ref Level for the
correct identification of
edge source.

Use the switching
device gate waveform
as the edge source if
the ringing is more on
the voltage waveform
across the magnetic
component.
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1740 Not enough samples

for correct calculation
of the DC flux density
to position the
Hysteresis curve on the
plot.

The number of data
points available for the
calculation of DC value
of flux density is
insufficient in: 1)
Number of data points
in identified cycle 2)
Lesser number of data
points in identified
integral number of
cycles.

1) If you are using the
current source as edge
source, then increase
the number of divisions
of the current
waveform.
2) If the current
waveform is noisy, use
Hires mode to remove
noise.
3) Increase hysteresis
and adjust the Ref
Level for the correct
identification of edge
and integral number of
cycles.

1741 Amplitude of each cycle
is improper for
computation.

The amplitude of the
signal is very low.

Decrease the vertical
scale of the voltage and
current channels.

1742 The calculated skew
value is more than the
oscilloscope deskew
range.

The skew computed is
more than the
oscilloscope deskew
range. So, the deskew
is done to the
maximum range value.

The deskew is done to
the maximum deskew
value applicable to the
oscilloscope.

1743 Edges on the waveform
are lesser than the
number of edges
configured. Number of
edges set by the user
to deskew is not
available on the
waveform.

Configured value of the
number of edges is not
found on the waveform.

Make sure that the
number of edges in the
waveform and the
display in the numeric
input are same. Adjust
the horizontal scale to
increase the number of
transitions that are
required for adjusting
the deskew.

1744 Edges on the waveform
are more than the
required number of
edges for internal
deskew.

Internal deskew
expects only one edge
in the waveform for
deskew.

The waveform or the
setup may be wrong.
To make accurate
connections, follow the
procedure in the
section Deskewing
Probes and Channels
of the online help.

1745 (Hysteresis Level/2 +
Ref Level) cannot be
more than 100 percent
of the maximum signal
level.

Level for finding the
edge is more than the
maximum level of the
signal.

Adjust the Ref Level
and Hysteresis Level
such that it should not
exceed the maximum
level of the signal in
percentage.
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1746 Error in copying the

delays.txt file.
File is corrupted to run
the static deskew
measurement.

Restart the application
with the correct deskew
file.

1747 Unable to find the
required edges.
Reacquire waveform.

The waveform may not
be able to find the
required edges due to
the following reasons:
1) Noisy signal 2) Low
hysteresis band level 3)
Oscilloscope is in the
preview mode 4) The
same error reflects low
record length leading to
less number of
samples.

If the signal is too
noisy, enable Average
mode, instead of
sample mode, and
acquire the signal. This
reduces the jitter on the
signal and smooths the
signal. Increase the
hysteresis band level
from the application to
compensate for noise
in the signal.

1748 Number of sample
points available for
analysis during Ton or
Toff is zero.

Due to low record
length, the number of
samples present during
Ton or Toff is zero,
which leads to infinity
when calculating the
switching frequency
that is calculated for
every switching.

Increase the record
length value and run
the measurement
again. Increase the
record length value to
have enough samples
during each switching.

1749 Number of sample
points available for
analysis during Ton or
Toff should be more
than two.

If the number of
samples between
10 percent and
90 percent of switching
ON or OFF portion of
the voltage waveform is
less than two, then the
application displays a
warning message.

Increase the record
length value to have
enough samples during
each switching.

1750 All three outputs are
OFF. Ensure that at
least one output is ON.

Before you run the
measurement, set the
state of the used output
to the ON state.

Make sure that at least
one output is set to ON.

1751 The trigger voltage
cannot be set to more
than the maximum line
voltage.

The trigger voltage
should be less than the
maximum line voltage.

Set the trigger voltage
level lower than the
maximum line voltage
level.
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1752 Calculated power loss

value is zero. One
complete switching ON
to ON cycle may not be
available or the
conduction portion of
the power signal may
be negative. Reacquire
with at least two
complete cycles.

Power loss minimum or
maximum and average
value can become zero
under the following
conditions: 1) When
coupling used is AC,
then signal can vary
from negative to
positive and power loss
calculated can become
zero. 2) AC-coupled
current and voltage
signals are multiplied to
get power-signal. To
calculate the power
loss, integration of the
power signal is done,
which varies from
negative to positive
where the probability of
calculating a zero value
is possible. 3) When
the probe has DC
offset.

Make sure that the
coupling used is DC.
DC offset on the probes
used should be
compensated before
you run the
measurement again.

1753 RDS ON or Vce(Sat) is
not Configured. The
calculated energy and
loss may not be
accurate.

This warning message
appears if the vertical
scale of the switch
voltage is more than
10 V per division and
device parameter RDS
On or Vce(SAT) is not
selected.

Select device type
MOSFET or IGBT/BJT
and enter the
respective parameter.

1754 Total loss and total
energy not calculated.

Total loss and total
energy not calculated.

Error.

1755 Multiple edges found in
a switching cycle, or
DC offset present in the
waveform.

This error appears in
two scenarios: 1) When
multiple edges are
found within a switching
cycle. This is because
of improper ref and
hysteresis levels. 2) If
voltage and current
probes are not properly
compensated for DC
offset, then the
configured Ton and
Toff levels are not met.

Set the ref hysteresis
level for the voltage
edge source. Remove
the DC offset in the
probes and run the
measurement again.
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1756 The calculated edge at

(Ref Level ±/-
Hysteresis/2) is less
than the Ton and Toff
voltage level.

The error appears
when the configured
Ton and Toff levels are
less than the edge (Ref
Level + Hysteresis /2).

Set the ref and
hysteresis level/2 more
than the Ton and Toff
level on the voltage
waveform and run the
measurement again.

1757 The calculated edge at
(Ref Level ±
Hysteresis/2) is less
than Ton and Toff
current level.

The error appears
when the configured
Ton and Toff levels are
less than the edge (Ref
Level + Hysteresis /2).

Set the ref and
hysteresis level/2 more
than the Ton and Toff
level for the current
waveform and run the
measurement again.

1758 The calculated edge at
(Ref Level ±
Hysteresis/2) is more
than 80 percent of the
gate voltage.

The error appears
when the configured
edge (Ref Level +
Hysteresis/2) is more
than 80 percent of the
gate voltage.

Set the ref and
hysteresis level/2 less
than 80 percent of the
gate voltage and run
the measurement
again.

1759 (Ref Level ±
Hysteresis/2) is more
than 100 percent.

The error appears
when the edge Ref
Level + Hysteresis/2) is
more than 100 percent.

Set the ref and
hysteresis level/2 less
than 100 percent and
run the measurement
again.

1760 Failed to process the
waveform.

When the oscilloscope
is unable to return the
maximum and
minimum levels, this
error appears.

Run the measurement
again.

1761 Switching loss and
energies in the result
can be zero.

The probable reason is
that there can be a
sharp spike in the
switch current during
turn ON. The amplitude
of the spike is more
than the remaining
portion of the switch
current cycle. This
affects the configured I-
level (percent) and is
converted to absolute
as product of the
maximum spike current
and percentage level.

Check the I and V
levels and run the
measurement again.
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1762 The calculated

switching loss and
energy is zero.

There may be a sharp
spike in the switch
current during turn ON
or the amplitude of the
spike may be more
than the remaining
portion of the switch
current cycle.

Check the I and V
levels and run the
measurement again.
The spike can be
because of the parasitic
effect of the associated
components and
extended current loop.
Use a small loop to
measure current and a
small lead to measure
the voltage.

1763 The number of samples
between the cursors is
less than two.

This is caused by
improper placing of
cursors such that there
are no sample points
between the cursors.

Reposition the cursors
and run the
measurement again.

1764 The calculated total
loss and energy is less
than the sum of Ton
loss and energy and
Toff loss and energy.

The calculated total
loss and energy is less
than the sum of Ton
loss and energy and
Toff loss and energy.

Error.

1765 The number of samples
between the
consecutive edges is
less than ten. Increase
the sample rate and
use the HiRes
acquisition mode.

This warning appears
when multiple edges
are found within a
switching cycle. The
probable reason for
multiple edges is
ringing that is present
in the switch voltage.

Configure the edge
level to avoid ringing
portions and increase
the hysteresis band.
Set Hi Res as an
acquisition mode.

1766 Invalid data for
HiPower Finder results.

The waveform does not
have enough edges or
the waveform is not
proper for the selected
measurement to run
successfully.

Decrease the horizontal
scale of the waveform,
or increase the record
length value.

1767 Switching Loss results
are Negative. This may
be due to DC offset in
the voltage and current
probes used. To avoid
this, compensate the
probes for DC offset
and also run Signal
Path Compensation
(SPC) on the
oscilloscope before
starting the application.

This may be due to DC
offset in the voltage
and current probes
used.

To avoid this,
compensate the probes
for DC offset and also
run Signal Path
Compensation (SPC)
on the oscilloscope
before starting the
application.
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1768 Inadequate acquisition

duration, increase the
record length and run
again.

This error appears
when the frequency
resolution is more than
the selected frequency
range.

Try running the
measurement with
more record length.

1769 Select the appropriate
edge source (either
voltage or current
channel).

In Magnetic Property,
edge source is neither
set to the voltage nor
the current channel.

Go to the Source
configuration panel, set
the edge source to
either the voltage or the
current channel.

1770 V(ce) cannot be
negative. Check the
coefficient values and
run the measurement
again.

The coefficients
entered to calculate
Vce ended up in a
negative value of Vce
which is not possible.

Check the coefficient
values and enter valid
values for a positive
Vce.

1771 Not enough samples
between edges.

Not enough samples
between edges.

Not enough samples
between edges.

1772 From and To Channels
are the same.

From and To channels
selected in deskew are
the same.

Select different from
and to channels for real
time deskew.

1773 Too many edges in the
waveform. Only 1 edge
is required.

According to the
configuration, only
1 edge is required to
perform deskew.
However, too many
edges exist in the
acquired waveform.

Set the Record length
properly to have just
1 edge and run deskew
again.

1774 The skew calculated is
more than the
oscilloscope
permissible value, so it
will be set to the
maximum.

The calculated skew is
more than what is
supported by the
oscilloscope.

Connect valid signals to
the channels.

1775 The skew calculated is
lower than the
oscilloscope
permissible value, so it
will be set to the
minimum.

The calculated skew is
less than what is
supported by the
oscilloscope.

Connect valid signals to
the channels.

1776 Not enough samples
for current harmonics.

Not enough samples
for the given number of
harmonics and signal
frequency.

Increase the number of
samples and run the
measurement again.

1777 Given current threshold
is not applicable for the
current waveform.

The threshold value is
not applicable for the
acquired current
waveform.

Set the proper
threshold value and run
the measurement
again.
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1778 No peaks are found in

the selected region,
please change the
cursor position.

The region selected by
cursors does not have
any peaks.

Adjust the cursor
positions and run the
measurement again.

1779 No peaks are found in
the waveform, please
acquire again.

The waveform is not
proper and does not
have any peaks.

Reacquire the
waveforms and rerun
the measurement.

1780 Low sampling rate,
please increase the
sampling rate and run
the measurement
again.

The sampling rate set
is not enough for
spectral analysis.

Set the sampling rate at
a higher value and run
the measurement
again.

1781 Waveform sampling
rate and/or record
length does not match.

The sampling rate and
record length of voltage
and current channels
do not match.

Make sure both
channels have the
same record length and
sampling rate, and run
the measurement
again.

1782 Insufficient number of
cycles.

No full cycle is
available for power
quality measurement.

Increase the horizontal
scale to have at least
one cycle and rerun the
measurement.

1783 Low record length,
please increase the
sampling rate and run
the measurement
again.

The record length of
the waveform is
insufficient for the
measurement.

Set the record length
higher, and run the
measurement again.

1784 Start frequency and
stop frequency can't be
the same.

In the Spectral analysis
Configuration panel,
Start and Stop
frequency have been
set to the same value.
This is not allowed.

Set different values to
Start and Stop
frequencies.

1785 AutoSet failed:
Oscilloscope is not
responding, please
recall default setup and
run again.

Oscilloscope is not
responding, thus
autoset failed.

Recall default setup
and run autoset again.

1786 Ref level and
hysteresis are not
applicable for the
signal.

Ref level and
hysteresis are not
applicable for the
signal.

Change the levels, and
rerun the
measurement.

1787 Autoset save failed.
Check system drive
accessibility.

Unable to save autoset
data.

Check that the drive is
accessible with
appropriate
permissions.

1788 Autoset save failed. Unable to save autoset
data.

Autoset again.
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1789 Recall Plot failed. The

plot does not match the
measurement.

The plot that is being
recalled is not
applicable to that
particular
measurement.

Recall appropriate plots
related to that
measurement.

1790 Autoset failed:
Incompatible signal.

Autoset failed due to
improper signal. This
may be because there
is too much noise in the
input.

Connect a valid signal
to the channel and run
autoset again.

1791 Deskew performed
successfully.

Deskew operation
completed.

Deskew operation
completed.

1792 Autoset Error. Autoset failed to set the
coupling/bandwidth on
selected channels
because the probe
connected to respective
channels does not
support selected
bandwidth or coupling.

Select appropriate
coupling and/or
bandwidth from the
global configurations
panel.

1793 Autoset Completed Done with the autoset. Done with the autoset.
1794 Selected resolution

bandwidth is not
applicable for input
waveform, display
results for available
resolution?

The RBW selected
from the configuration
panel is not matching
with the calculated
RBW on the waveform.

Run at least horizontal
autoset once before
running spectral
measurement.

1795 No edges found in the
waveform. Adjust the
waveform and rerun the
measurement.

No edges found in the
waveform acquired.

Change the
oscilloscope horizontal
settings to have at least
one edge and rerun the
measurement.

1796 Negative capacitance
detected still showing
the result please
change ref levels and
run the measurement
again.

The average
capacitance value
calculated is negative.

Change reference
levels from the
configuration panel and
rerun the
measurement.

1797 Do you want to
autoset?

This pop up comes
before performing
adeskew operation.

It is a yes or no pop up.
If clicked yes it will
autoset and continue
the deskew, else it will
just perform deskew.
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1798 Unable to set the

calculated skew value
of ... value in scope
vertical De-skew, since
the Skew value is <
Sample Interval.
Increase the sample
Rate and adjust the
Record Length, such
that Sample Interval is
< " +
GetFormattedValue(sk
ewValue) + "\n The
skew value has been
set to " +
GetFormattedValue(set
Value) + " by scope".

Slew value calculated
is less than the
sampling interval.

Increase the sampling
rate such that the
sampling interval is less
than the skew value.

1800 Turn on the device
now.

The sequencer is
waiting to acquire the
signal for turn on time
measurement.

Turn on the device and
click ok.

1801 Unable to find edges
for the region selected.
Adjust the ref levels or
change the cursor
positions and re-rerun
the measurement.

No edges found in the
selected region of the
waveform, may be the
cursors are too close to
each other or the
waveform does not
contain edges.

If cursors are too close
to each other widen the
gap between them or
change the horizontal
scale to acquire
enough edges for the
measurement.

1802 Current probe is not
connected to any of the
selected sources.

Current probe is not
detected on any of the
channels.

Connect a current
probe and perform
degauss again.

1803 No magnetic cycles
found on the waveform.
Adjust the cursors and
rerun the
measurement.

Cursor gating is turned
on but no complete
cycles are available
between cursors or no
complete cycles are
available in entire
cycle.

Widen the gap between
cursors if the cursor
gating is ON or change
the horizontal
parameters and acquire
the signal again.

1804 No magnetic cycles
found on the waveform.
Acquire again with a
longer Record length
and rerun the
measurement.

One full cycle is not
available in the entire
waveform.

Change horizontal
scale and rerun the
measurement.

1805 The configured
frequency range is not
supported by the
spectral analysis
measurement.

The difference between
start to stop frequency
is too long for
supported record length
and sampling rate.

Change start/stop
frequency such that the
difference is reduced.
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1806 No samples available in

the selected region of
the waveform.
Reposition the cursors
and run the
measurement.

The selected region
does not contain any
samples, may be both
the cursors are in the
same position.

Move one of the
cursors and rerun the
measurement.

1807 AutoSet is only
applicable for live
channels.

User tried to run
autoset on reference
sources.

Select live channels
and run autoset.

1808 Clipping detected
during autoset, Rerun
horizontal after
completing vertical
autoset.

Clipping detected
during horizontal
autoset and the autoset
is not able to identify
signal.

Run vertical autoset
first and then run
horizontal.

1809 No complete switching
cycle found in the
waveform. Reposition
the cursors, check the
waveform and re-run
the measurement.

Not a full switching
cycle is available in the
selected region of the
waveform.

Widen the gap between
cursors or change
horizontal scale and
run the measurement
again.

1810 Update and select
appropriate RBW from
measurement
configuration panel and
rerun autoset.

In Spectral
Measurement, "Auto
set" sets the horizontal
resolution based on
RBW(Hz). This need to
update or set before
performing
measurement.

Click Configure >
Spectral Config >
Update / select Res
BW(Hz)

1811 Consecutive mask
point can't be same,
change values and
click Add/Update
button.

SOA measurement has
a feature to create a
mask using “Mask
Designer”. Condition is
only that lines
connected to between
points should not
intersect.

Avoid creating points,
which lines are
intersect.

1812 Mask is not valid
(Specify more number
of points(Minimum
3 points) and make
sure points do not lie
on a straight line).
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Error Codes Error Message Description Possible Solutions
1813 Mask points are not

valid. It could be
because.

Mask has less number
of points. All the points
in the mask are on a
straight line. Redesign
the mask and use
preview to check the
validity of mask or
disable the mask from
configuration panel and
run the measurement
again.

1814 60 cycles of Line
Frequency is required
OR Make sure
Configure ->Line
Frequency is correct.

“AM14” standard of
Current Harmonic
measurement need a
60 cycle to create a
15 parts of each
4 cycles to do analysis.

1. Click Configure >
Standard > Line
Frequency >
Auto

2. Configure >
Standard >
Harmonic Order

3. Open Source
Configure > Vert/
Horiz

1815 Unable to find edges
for the configured
trigger level.

Adjust the trigger level
and re-run the
measurement.

1816 Unable to find edges
for the configured
output max voltage
level.

Adjust the voltage level
and re-run the
measurement.

1817 Not a valid mask, make
sure lines are not
intersecting.

The coordinates used
to draw the mask has
only one or two points.

Generate mask with
atleast three points and
not all of them in a
straight line.

1818 Make sure input signals
are not DC in nature.

Check the setup for
further analysis.

1819 For most (>80%) of the
acquisition duration, the
input waveform is DC in
nature, since difference
of samples yields zero
values. A plot with the
same name is already
added.

RDS(on) measurement
expect input to be AC
in nature. In some
case, if the user gives
pure DC input or input
which has 80% of the
time DC in nature,
Measurement do not
work and through an
error message.

Make sure to have
proper transitions in the
waveforms to analyze
for entire waveform.
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Error Codes Error Message Description Possible Solutions
1820 Plot already added with

selected row color.
Select some other row
or clear the selected
row and try Recall
option.

SOA overlay
measurement has a
feature to plot various
result on a single plot.

Select a new row to
reference with new
overlay plot data.

1821 Recent plots does not
exist. Run
measurement to get the
recent saved plots.

Recent, opens the plot
data saved or Recalled
and Cleared plot.

Either Plot data should
be saved or Recalled
and Cleared, to open
Recent plot.

1822 Selected scale and
scale in the selected
mask file does not
match. Do you want to
change the scale?

NA
(We are automatically
changing the scale by
Yes/No popup)

NA

1823 Selected mask file may
be corrupted. Recall a
valid mask file.

If user saves the invalid
mask, It cannot recall.

Create a valid mask,
which can be shows on
Graph. “Graph” button
is present in
Configuration > Mask
Editor.

1824 No coordinates found.
Recall a valid mask file.

If user saves the invalid
mask, It cannot recall.

Create a valid mask,
which can be shows on
Graph. “Graph” button
is present in
Configuration > Mask
Editor.

1825 Coordinate values are
not within the specified
range.

1826 File not found. When user try to recall
a file, which is not a
valid or not presented,
error message comes
up.

Make sure, the
recalling file is present
at the specified path.

1827 Changing the scale will
clear the unsaved
mask. Press Yes to
clear the mask. Press
No to return.

NA
(We are not asking to
user, if user changes
the scale)

NA

1828 Could not log the data,
check if the file is in
use.

If the file is already
Open, logging of data is
not possible.

Close the opened file
and rerun.
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Error Codes Error Message Description Possible Solutions
1829 Record Length is

chopped to 12.5M with
respected start point.

For the case of
Spectral measurement,
if the RL is greater than
12.5 M, Signal is
chopped from
0 position or 1cusrosr
position to 12.5M.

It just an informative
message to user.

1830 Zoom is not applied as
very few complete
cycles are available.

In case of Low
frequency inputs, if
Auto set is
performance, it sets
only few cycles to
acquire for time limit
operation. In such a
case Zoom after auto
set is not applicable.

It just an informative
message to user.

1831 Make sure Sampling
minimum frequency is '
Line Frequency x
Harmonics No.x 2.2'
times.

In Total Power Quality,
Current harmonic and
Voltage Harmonic, If
the user is running with
condition of aliasing,
this error message is
displayed.

1. Click on
Configure >
Standard > Line
Frequency >
Auto

2. Configure >
Standard >
Harmonic Order

3. Open Source
Configure > Vert/
Horiz

1832 File not found. File is not available at
the specified location.

Rerun the
measurement.

1833 No sufficient data
available for Time trend
Plot. Increase the
record length or
number of cycles being
captured.

Not Used
NA

Not Used
NA

1834 Acquired waveform is
negative in nature.
Inverse the probing
points and re-acquire.

Inverse the probing
points and re-acquire.

1835 Please wait while
plotting.

Data rendering is in
progress.

Please wait for the
rendering to happen.

1836 Edges found are not
proper, may be due to
ringing in the wfm.

Configure Gate voltage
as an edge source to
compute edges.

Make sure at least
100 sample points are
present in each
switching cycle. We
recommend to use
source autoset.
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Error Codes Error Message Description Possible Solutions
1837 For a REF source the

REF voltage cannot be
set more than the
maximum line voltage.

1838 For most (>80%) of the
acquisition duration, the
input waveform is DC in
nature and consecutive
differenceof samples
yield zero values.

RDS(on) measurement
expect input to be AC
in nature. In some
case, if the user gives
pure DC input or input
which has 80% of the
time DC in nature,
Measurement do not
work and through an
error message.

Make sure to have
proper transitions in the
waveforms to analyze
for entire waveform.

1839 SOA-X-Y(DPX) cannot
run with other
measurements of
Switching Analysis.

Select only SOA-X-Y
(DPX) to run it.

Press Yes to clear the
list and add the new
measurement. Press
No to return back
without any
modification.

1840 Use Gate Voltage (Vg),
If Signal is noisy

In Switching Loss
Analysis, it has an
option of PFC signal.
Generally, PFC need a
Gate Voltage to detect
the edges.

It is just a reminder to
user if PFC is selected.

1841 AutoZero performed
successfully

All the measurement,
Source Configuration
has a option of
“AutoZero”, which set
the DC offset.

It’s a message of
completion of operation
“AutoZero”.

1842 AutoZero: Computed
DC Offset value

Turn On Time cannot
run with other
measurements of
Output Analysis.

Remove the grouping
of such measurements
and run them
separately.

1843 Turn On Time cannot
run with other
measurements of
Output Analysis.

Select only Turn On
Time to Run it.

Press Yes to clear the
list and add the new
measurement. Press
No to return back
without any
modification.

1844 In Rush Current cannot
run with other
measurements of Input
Analysis.

Select only Inrush
Current to Run it.

Press Yes to clear the
list and add the new
measurement. Press
No to return back
without any
modification.
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Error Codes Error Message Description Possible Solutions
1845 Input Capacitance

cannot run with other
measurements of Input
Analysis.

Select only Input
Capacitance to Run it.

Press Yes to clear the
list and add the new
measurement. Press
No to return back
without any
modifications.

1846 No edges were found in
the waveform, possible
due to ringing in the
switching transitions.

The minimum number
of samples between
consecutive edges
must be atleast six or
more.

In case of PFC
configuration, adjust
the edge REF level and
the hysteresis value
higher than default
levels to overcome no
or any false edges. For
other topologies you
may need to re-acquire
the waveforms.

1847 Max X Scale should be
greater than Min X
Scale.

In SOA mask designer,
if maximum X scale
value is entered lesser
than minimum X scale
value, This error
comes.

Set maximum X scale
value greater than
minimum X scale value

1848 Min X Scale should be
lesser than Max X
Scale.

In SOA mask designer,
if minimum X scale
value is entered greater
than maximum X scale
value, This error
comes.

Set minimum X scale
value lesser than
maximum X scale value

1849 Max Y Scale should be
greater than Min Y
Scale.

In SOA mask designer,
if maximum Y scale
value is entered lesser
than minimum Y scale
value, This error
comes.

Set maximum Y scale
value greater than
minimum Y scale value

1850 Min Y Scale should be
lesser than Max Y
Scale.

In SOA mask designer,
if minimum Y scale
value is entered greater
than maximum Y scale
value, This error
comes.

Set minimum Yscale
value lesser than
maximum Y scale value

1851 Probe is already
Degaussed.

Probe is already
Degaussed.

Not required to
degauss probe.

1852 Default vertical gain of
10e-3 V/div is set for
probe type am503s.

This message is
displayed for AM503
probe series.

When user performs
vertical or both autoset
on AM503 series, it
displays the information
about vertical settings.
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Error Codes Error Message Description Possible Solutions
1854 Voltage & Current

signals are noisy
Voltage & Current
signals are noisy

Recommended to
setup Gate Voltage(Vg)
and deselect Auto
Level.

1855 Make sure the
RecordLength is at
least 10K having
10 switching cycles

The RecordLength
should be at least 10K
having 10 switching
cycles.

Make sure the
RecordLength is at
least 10K having
10 switching cycles.

1856 The ‘Start’ and ‘Stop’
frequency values
should be less than
sample rate of the
reference waveform.

The ‘Start’ and ‘Stop’
frequency values
should be less than
sample rate of the
reference waveform.

Re-acquire with higher
sample rate and set
‘Start’ and ‘Stop’
frequencies lower than
acquired sample rate.
The measurement
continues by computing
for full bandwidth of the
REF waveform.

Correlation of measurement to configurations
The following table list the configurations for each measurement.

Table 11: Switching Analysis

UI Name Global Options Edges Type PWMTyp
e

OnOffLe
vel

Mask
Editor

Method

Switching
Loss
Hi-Power
Finder
SOA
RDS(on)
dv/dt
di/dt
SOA X-Y
(DPX)

Reference  

260  Advanced Power Analysis



Table 12: Timing Analysis

UI Name Global Options Edges Edge
Pulse width
Duty Cycle
Period
Frequency
Skew

Table 13: Magnetics

UI Name Global Options Edges Source Physical
Chars1

Physical
Chars2

Inductance
Magnetic
Property
Magnetic
Loss

Table 14: Input Analysis

UI Name Global Options Harmonics
Table

Line
Frequency

Standard I-Probe
Impedance

Power
Quality
Current
Harmonics
Total Power
Quality
In-Rush
Current
Input
Capacitance
Voltage
Harmonics
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Table 15: Output Analysis

UI Name Global Line Ripple
Freq

Ripple Freq Spectral
Config

Input Output

Line Ripple
Switching
Ripple
Spectral
Analysis
Turn On
Time

Table 16: Amplitude

UI Name Global Options Edge Signal Type
High
Low
High Low
Cycle Min
Cycle Max
Cycle PkPk

Correlation of measurement to plots
The following table list the plots displayed for each measurement.

Table 17: Switching Analysis

UI Name Time Trend Histogram Switching
On OFF

SOA Graph Rise
Edge(s)-
Time Trend

Fall
Edge(s)-
Time Trend

Switching
Loss
Hi-Power
Finder
SOA
RDS(on)
dv/dt
di/dt
SOA X-Y
(DPX)
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Table 18: Timing Analysis

UI Name Time Trend Histogram
Pulse width
Duty Cycle
Period
Frequency
Skew

Table 19: Magnetics

UI Name Inductance Curve BH Curve

Inductance
Magnetic Property
Magnetic Loss

Table 20: Input Analysis

UI Name V*I Power Waveform Harmonics Bar Graph

Power Quality
Current Harmonics
Total Power Quality
In-Rush Current
Input Capacitance
Voltage Harmonics

Table 21: Output Analysis

UI Name Spectrum
Line Ripple
Switching Ripple
Spectral Analysis
Turn On Time

Table 22: Amplitude

UI Name Time Trend Histogram
High
Low

 Reference

Advanced Power Analysis 263



UI Name Time Trend Histogram
High Low
Cycle Min
Cycle Max
Cycle PkPk

Parameters

About application
parameters

This section describes the Advanced Power Analysis application parameters, and
includes the default menu settings. You should refer to the user manual for your
oscilloscope for operating details of other controls, such as front–panel buttons.

The parameters for the menus and options list the selections available for each
and include the default values.

Sequencer parameters Parameters Selections
Clear None
Recalc None
Single None
Run None

Measurement menu
parameters

Parameters Selection Default Setting
Switching Analysis Switching Loss, Hi-Power

Finder, SOA, SOA X-Y (DPX),
di/dt, dv/dt, RDS(on)

None

Timing Analysis Pulse Width, Period, Duty
Cycle, Frequency

None

Magnetics Inductance, Magnetic Loss,
Magnetic Property, I vs∫ V

None

Input Analysis Power Quality, Current
Harmonics, Voltage Harmonics,
Total Power Quality, In Rush
Current, Capacitance

None

Output Analysis Line Ripple, Switching Ripple,
Turn on Time, Spectral Analysis

None

Amplitude Cycle min, Cycle max, Cycle
peak-to-peak, High, Low, High-
Low

None
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Configure measurements
menu parameters

You can configure the parameters for the selected measurements.

Source Configuration Parameters

SOA Parameters

di/dt Parameters

dv/dt Parameters

Magnetics Parameters

Total Power Quality Parameters

Current Harmonics Parameters

Pulse Width Modulation Parameters

Period Modulation Parameters

Duty Cycle Modulation Parameters

Frequency Modulation Parameters

Source configuration
parameters

Parameter Selection Default Setting
Voltage Ch1, Ch2, Ch3, Ch4, Math1,

Math2, Math3, Math4, Ref1,
Ref2, Ref3, Ref4

Ch1

Current Ch1, Ch2, Ch3, Ch4, Math1,
Math2, Math3, Math4, Ref1,
Ref2, Ref3, Ref4

Ch2

Configure Hi-Power finder
and switching loss

parameters

Parameter Selection Default Setting
Hi-Power Finder
Type tab Fixed, Variable Fixed
On-Off Level tab Vsw, Vg Vsw
Vg Source Ch1-Ch4, Math1-Math4 Ch3
Units Absolute, Percentage Percentage
Hysteresis % - 10%
Ref Level - 50%
Reference Absolute 0 V
Hysteresis Absolute 0 V
Device N-Channel, P-Channel N-Channel
V-level percentage - 5%
I-level percentage - 5%
V-level absolute - 5 V
I-level absolute - 1 A
Options tab
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Parameter Selection Default Setting
Vg Level - 1.5 V
Filter Current - Checked
Switch On - Disabled
Details
Switching Loss
Type tab
PWM Type Fixed, Variable Fixed
Cursor gating On, Off Off
Device Auto, User Auto
Type MOSFET, BJT/IGBT BJT/IGBT
RDS On - 20 mohm
On-Off Level tab Vsw, Vg Vg if PFC is selected else Vsw
Vg Source Ch1-Ch4, Math1-Math4 Ch3
Units Absolute, Percentage Percentage
Hysteresis % - 10%
Autocalc loss without Vg - Unchecked
Ref Level - 50%
Reference Absolute 50 V
Hysteresis Absolute 5 V
Device N-Channel, P-Channel N-Channel
V-level percentage - 5%
I-level percentage 5%
V-level absolute - 5 V
I-level absolute 1 A
Option tab
Vg Level - 1.5 V
Signal Condition - Checked
Filter Current - Checked
Switch On - Disabled
Details
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Configure magnetics
parameters

Parameter Selection Default Setting
Magnetic Loss tab
Cursor Gating Details On, Off Off
Inductance-Edge Source Ch1-Ch4, Math1-Math4 Ch1
Ref Level Absolute, Percentage Percentage
Ref Level Absolute - 0 V
Hysteresis Absolute - 0 V
Ref Level Percentage - 50%
Hysteresis Percentage - 10%
Single, Multiple Single, Multiple Single
Magnetic Property tab-Type
and Edge Source
Freq/Duty Fixed, Variable Fixed
Cursor Gating On, Off Off
# of Windings ( Primary
Windings )

- One

Edge Source Ch1-Ch4, Math1-Math4 Ch1
Units Absolute, Percentage Percentage
Ref Level Percentage 10-90% 50%
Hysteresis Percentage 5-40% 10%
Magnetic Property tab-Physical
Chars
Units SI, CGS SI
Number of Turns 1-1 M 1 
Cross Section Area-SI 1 m2
Cross Section Area-CGS 1 cm2
Magnetic Length-SI 1 m
Magnetic Length-CGS 1 CM
# of Windings Two, More Two
Windings 1 Source Ch1-Ch4 Ch3
Magnetizing Current Ref1-Ref4 Ref1
Windings 2 Source Ch1-Ch4, Unused Unused
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Configure SOA
parameters

Parameter Selection Default Setting
Cursor Gating On, Off Off
Mask Editor Enable
Utility Overlay

SOA mask Parameter Selection Default Setting
Mask Grid
Scale Log, Linear Linear
Linear Mask Values X-Min, X-Max

-40 KV to 40 KV
Y-Min, Y-Max
-40 KA to 5 KA

Log Mask Values X-Min, X-Max
-40 KV to 40 KV
Y-Min, Y-Max
-40 KA to 5 KA

Configure di-dt
parameters

Parameter Selection Default Setting
Units Percentage, Absolute Percentage
Ref Level Percentage 50%
Hysteresis Percentage 10%
Ref Level Absolute 0A
Hysteresis Absolute 0A

Configure dv-dt
parameters

Parameter Selection Default Setting
Units Percentage, Absolute Percentage
Ref Level Percentage 50%
Hysteresis Percentage 10%
Ref Level Absolute 0 V
Hysteresis Absolute 0 mV
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Configure current
harmonics parameters

Parameter Selection Default Setting
Standards 61000-3-2, AM 14, MIL 1399 61000-3-2 
61000-3-2 
Line Frequency 50 Hz, 60 Hz 50 Hz
Harmonic Table Table 1-10 Table 1 
Class Class A-Class D Class A
AM 14 
Line Frequency 50 Hz, 60 Hz 50 Hz
Harmonic Table Table 1-10 1 
Class Class A-Class D Class A

Filter Checked
Controls> Input Power 100W
Controls> Power Factor 1 
Controls> Fundamental Current 15A

MIL 1399 
Harmonics 50,100 50 
Line Frequency 60 Hz, 400 Hz 60 Hz
i-Probe Impedance
Transfer Impedance Table Table 1-10 Table 1 
Use Impedance Table Check
box

Unchecked, Checked Unchecked

Configure voltage
harmonics parameters

Parameter Selection Default Setting
Line Frequency
Line Frequency 50 Hz, 60 Hz, Custom (1 Hz to

4 KHz)
50 Hz

Harmonics order 40 - 100 40 
Global
Coupling AC, DC DC
Bandwidth Limit 20 MHz, 250 MHz, Full  1 20 MHz
Switching Freq 50 Hz to 1 MHz 100 Hz
Acquisition Mode Hi Res, Sample, Pk Detect Hi Res

1 *These options may not be available on all supported oscilloscopes. Please refer to your oscilloscope bandwidth
options.
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Configure total power
quality parameters

Parameter Selection Default Setting
Standards 61000-3-2, AM 14, MIL 1399 61000-3-2 
61000-3-2 
Line Frequency 50 Hz, 60 Hz 50 Hz
Harmonic Table Table 1-10 Table 1 
Class Class A-Class D Class A
AM 14 
Line Frequency 50 Hz
Harmonic Table 1 
Class Class A

Filter Checked
Controls> Input Power 100W
Controls> Power Factor 1 
Controls> Fundamental Current 15A

MIL 1399 
Harmonics 50,100 50 
Line Frequency 60 Hz, 400 Hz 60 Hz
i-Probe Impedance
Transfer Impedance Table Table 1-10 Table 1 
Use Impedance Table Check
box

Unchecked, Checked Unchecked

Configure line ripple
parameters

Parameter Selection Default Setting
Coupling AC, DC DC
Bandwidth Limit 20 MHz, 250 MHz, Full  2 20 MHz
Acquisition Mode Hi Res, Pk Detect, Sample Hi Res
Ripple Freq 50 Hz, 60 Hz, 400 Hz 50 Hz

2 *These options may not be available on all supported oscilloscopes. Please refer to your oscilloscope bandwidth
options.
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Configure switching ripple
parameters

Parameter Selection Default Setting
Ripple Freq
Switching Ripple Frequency 50 Hz to 1 MHz 100 KHz
Global
Coupling AC, DC DC
Bandwidth Limit 20 MHz, 250 MHz, Full  3 20 MHz
Switching Freq 50 Hz to 1 MHz 100 Hz
Acquisition Mode Hi Res, Sample, Pk Detect Hi Res

Configure Turn-On time
parameters

Parameter Selection Default Setting
Input
Source Ch1, Ch2, Ch3, Ch4 Ch1
Converter AC-DC, DC-DC AC-DC
Max Voltage 1 V-500 V 230 V
Trigger Level 1 V-500 V 230 V
Max Turn-On Time 1 us to 5 s 200 ms
Output
Source 1 On, Off On
Source 2 On, Off Off
Source 3 On, Off Off
Source 1 Ch1-Ch4 Ch2
Max Voltage -5.9 KV to 5.9 KV 5.0 V

Configure pulse width
timing analysis

parameters

Parameter Selection Default Setting
Source Ch1, Ch2, Ch3, Ch4, Ch1
Ref Destination Ref1, Ref2, Ref3, Ref4 Ref1
Units Level, Percentage Percentage
Percentage Ref Level Hysteresis Ref Level: 50% Hysteresis: 5%
Absolute Ref Level Hysteresis Ref Level:0 V Hysteresis:6 V
Edge Positive, Negative Positive
Cursor Gating Off
Polarity Positive, Negative Positive

3 *These options may not be available on all supported oscilloscopes. Please refer to your oscilloscope bandwidth
options.
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Configure period timing
analysis parameters

Parameter Selection Default Setting
Source Ch1, Ch2, Ch3, Ch4, Ch1
Ref Dest Ref1, Ref2, Ref3, Ref4 Ref1
Ref Level Mode Level, Percentage Percentage
Percentage Ref Level Hysteresis Ref Level: 50% Hysteresis: 5%
Absolute Ref Level Hysteresis Ref Level:0 V Hysteresis:6 V
Edge Type Rise, Fall Rise
Cursor Gating On, Off Off

Configure duty cycle
timing analysis

parameters

Parameter Selection Default Setting
Source Ch1, Ch2, Ch3, Ch4, Ch1
Ref Dest Ref1, Ref2, Ref3, Ref4 Ref1
Edge Level: Units Level, Percentage Percentage
Percentage Ref Level Hysteresis Ref Level: 50% Hysteresis: 5%
Absolute Ref Level Hysteresis Ref Level:0 V Hysteresis:6 V
Edge Rise, Fall Rise
Cursor Gating On, Off Off
Polarity Positive, Negative Positive

Configure frequency
parameters

Parameter Selection Default Setting
Source Ch1, Ch2, Ch3, Ch4, Ch1
Edge Type Rise, Fall Rise
Edge Level: Units Percentage, Absolute Percentage
Ref Level: Percentage 1% to 99% 50%
Ref Level: Absolute 0 V to 6 V 0 V
Hysteresis 0 V to 3 KV 6 V
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Utilities menu The parameter available under Utilities Menu is:

■ Deskew

■ SOA Overlay

■ Degauss

■ Autoset

See also.  
Deskew

SOA Overlay

DeGauss

Autoset
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Static deskew Parameters Selections Default Setting
From Source Ch1, Ch2, Ch3, Ch4 Ch1
Probe TAM503B w/ A6302, AM503B

w/ A6303, AM503B w/ A6312,
AM503B w/ A6302XL, AM503B
w/ A6303XL, AM503B w/
A6304XL, P5050, P5050B,
P5100, P5100A, P5200,
P5200A, P5202A, P5205,
P5205A, P5210, P5210A,
P6015A (10 ft), P6015A (25 ft),
P6021A, P6131 (1.3 m), P6131
(2 m), P6138A, P6139A,
P6139B, P6158, P6243, P6245,
P6246, P6247, P6248, P6250,
P6251, TAP1500, TAP2500,
TCP0020, TCP0030,
TCP0030A, TCP0150, TCP202,
TCP202A, TCP2020,
TCP202A;TPA-BNC, TCPA300
w/ TCP303, TCPA300 w/
TCP303 + TPA-BNC, TCPA300
w/ TCP305, TCPA300 w/
TCP305 + TPA-BNC, TCPA300
w/ TCP305A, TCPA300 w/
TCP305A + TPA-BNC,
TCPA300 w/ TCP312,
TCPA300 w/ TCP312 + TPA-
BNC, TCPA300 w/ TCP312A,
TCPA300 w/ TCP312A + TPA-
BNC, TCPA400 w/ TCP404XL,
TCPA400 w/ TCP404XL + TPA-
BNC, TDP0500, TDP1000,
TDP1500, TDP3500, TekVPI
TCP0030, TekVPI TAP1500,
TekVPI TAP2500, TekVPI TPA-
BNC, THDP0100, THDP0200,
TMDP0200, TPP0500,
TPP0500B, TPP0502,
TPP0850, TPP1000, Custom.

Custom

To Source Ch1, Ch2, Ch3, Ch4 Ch2
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Parameters Selections Default Setting
Probe AM503B w/ A6302, AM503B w/

A6303, AM503B w/ A6312,
AM503B w/ A6302XL, AM503B
w/ A6303XL, AM503B w/
A6304XL, P5050, P5050B,
P5100, P5100A, P5200,
P5200A, P5202A, P5205,
P5205A, P5210, P5210A,
P6015A (10 ft), P6015A (25 ft),
P6021A, P6131 (1.3 m), P6131
(2 m), P6138A, P6139A,
P6139B, P6158, P6243, P6245,
P6246, P6247, P6248, P6250,
P6251, TAP1500, TAP2500,
TCP0020, TCP0030,
TCP0030A, TCP0150, TCP202,
TCP202A, TCP2020,
TCP202A;TPA-BNC, TCPA300
w/ TCP303, TCPA300 w/
TCP303 + TPA-BNC, TCPA300
w/ TCP305, TCPA300 w/
TCP305 + TPA-BNC, TCPA300
w/ TCP305A, TCPA300 w/
TCP305A + TPA-BNC,
TCPA300 w/ TCP312,
TCPA300 w/ TCP312 + TPA-
BNC, TCPA300 w/ TCP312A,
TCPA300 w/ TCP312A + TPA-
BNC, TCPA400 w/ TCP404XL,
TCPA400 w/ TCP404XL + TPA-
BNC, TDP0500, TDP1000,
TDP1500, TDP3500, TekVPI
TCP0030, TekVPI TAP1500,
TekVPI TAP2500, TekVPI TPA-
BNC, THDP0100, THDP0200,
TMDP0200, TPP0500,
TPP0500B, TPP0502,
TPP0850, TPP1000, Custom.

Custom
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Real Time Deskew.

Parameters Selections Default Setting
From Source Ch1, Ch2, Ch3, Ch4 Ch1
To Source Ch1,Ch2 Ch3, Ch4, Ch2
Slope Rise, Fall Rise
Edges  1

Ref Level Min:0,Max:100% 50%
Hysteresis Min:0,Max:25% 5%
Source Internal, External External
Edges - 1 

Prevailing switch mode power supply (SMPS)

Figure 21: SMPS block diagram

1 One is recommended. You can use up to 5 edges.
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The most common architecture to ensure high efficiency power conversion is the
switch-mode power supply. This architecture minimizes the use of lossy
components. Instead, it uses switch-mode semiconductor devices, magnetic and
passive components which are all, ideally, lossless. SMPS devices typically
include a control section containing elements such as pulse-width modulated
regulators, pulse-rated modulated regulators, and feedback loops. Sometimes,
control sections may have their own power supplies. Switch mode power supply
technology rests on power semiconductor switching devices such as Metal Oxide
Semiconductor Field Effect Transistors (MOSFETs) and Insulated Gate Bipolar
Transistors (IGBTs). These devices offer fast switching times and are able to
withstand erratic voltage spikes. Equally important, they dissipate very little
power in either the On or Off states, achieving high efficiency with low heat
dissipation. For the most part, the switching device determines the overall
performance of an switch mode power supply. Common measurements for each
major section of the switch-mode power supply are shown here. For the
switching device, key measurements include switching loss, average power loss
and safe operating area. For the transformer section, power supply performance
will depend on the magnetic properties and magnetic power loss in this section.
It’s also necessary to analyze how the supply interacts with its service
environment. For this, measurements like power quality, harmonics and total
harmonic distortion are important. 

Figure 22: SMPS circuit diagram
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Switching loss (PFC)

Switch current spikes
during turn ON

During switch ON, the switch current increases and can have sudden spike or
close ringing. These ringing cause wrong identification of start of TON. While
identifying the start index on the current waveform, the current waveform is
passed through the 4 point software moving average filter (MAV) to reduce
ringing. The filtered current waveform is used for identifying the start index. The
index of the filtered current waveform is mapped to the actual current for the
calculation of Ton Loss.

Figure 23: Current spikes during turn ON

Cursor placement Select two switching loss measurements, one with two sources VDS and ID and
second instance with three sources VDS, ID and VG. Place the cursor-1 and
2 such that the region includes 120Hz hump, as shown in following figure.

Reference  

278  Advanced Power Analysis



Figure 24: Cursor placement

Observe that VG has ringing and VDS is very clean, from following diagram.

Figure 25: Ringing VG during TOFF
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Figure 26: Clean VDS

Continue the measurement to get results and plots:

Observe that plot with VDS is correct since both current and voltage range on X-
axis too 400V.
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Figure 27: Measurement results and switching loss plot

REF level computation for
noisy VG source

For PFC gate votlage is recommended to use as edge source. Zoom the gate
voltage and observe that there are ringings during turn ON of each switching
cycle. This ringining will cause false edges and leads to error in the
measurement. The default values will not work in this case.

Measure the clean region of the gate voltage where edges can be computed, as
shown in figure-1. Set 12.25V value in the application configuration for edges.
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How to compare between
plot and result

Select a particular switching cycle and click Details. Select any Turn ON region,
from the plot Prev and Next button, as shown in following figure.

Observe that scope built-in area measurement with cursor gating turned on is ~
75.32nWs. This matches with energy of TON statistics.
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To calculate loss in watts multiply scope built-in value by switching frequency
that is 164 KHz, which gives 12.35mW, which lies in within TON loss statistics.

In summary, you cannot directly compare values from plot to scalar results. To
compare between plot cycle and results value, you need to add all values for
TON and TOFF separately. Enable dot connect, as shown below, add all yellow
points which corresponds to ON region, then multiply by sample interval to get
particular energy.
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Algorithms

About Algorithms
An algorithm is a method expressed as a finite list of well-defined instructions for
calculating a function. This section explains the DPOPWR measurement
algorithms.

Equipment setup
guidelines

Advanced Power Analysis sets the oscilloscope parameters appropriately for each
measurement before running the measurements. The voltage or current
waveforms are expected in any Ch1-Ch4 or Ref1-Ref4. In the case of two
channel oscilloscopes, they are expected in CH1-CH2 or Ref1-Ref2.

1. For best results, the vertical scale for the waveform must be set such that the
waveform does not exceed the vertical range of the oscilloscope. You should
set the vertical scale so that the waveform occupies the full screen.

2. The sample rate must be set to capture enough waveform detail and avoid
"aliasing" here.

Options configuration
This configuration tab allows you to select waveform edge(s) the application
should use to take each measurement.

Figure 28: Hysteresis

The hysteresis input helps you to identify the cross over time on the waveform at
specified reference levels as shown in the preceding figure. If there is any noise at
the Reference level, the hysteresis band (H Band 1) helps to identify the single
cross over.

If the hysteresis band (H Band 2) is less than the signal noise at the Reference
level, this shows as three edges or transitions instead of one transition. Hysteresis
band helps you to identify the correct transition.

Ref Level
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The REF Level is used to compute the edges for configured source at specified
level.

Switching analysis

Switching loss Switch-Mode Power Supply (SMPS) design has three types of losses, they are
Turn-On (TOn), Turn-Off (TOff) and Conduction loss. To achieve the maximum
efficiency, losses should be reduced. This section details about the basics of
Switching Loss Analysis. A simplified SMPS schematic is shown in SMPS
circuit diagram.

Figure 29: SMPS circuit diagram

SMPS circuit diagram shows the points where switching loss can be measured.
After full wave rectification, the current signal should pass through the harmonic
standard and enters for DC conversation. MOSFET plays an important role to
meet the design of SMPS.

Regions of TOn, TOff and Conduction loss with voltage source (Vds) and current
source(Ids) are shown in Switching Loss TOn, TOff and Conduction loss regions.
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Figure 30: Switching Loss TOn, TOff and Conduction loss regions

All the switching losses are measured on Power signal based on Vds and Ids
transition

TOn Loss region: When Vds starts rolling towards zero, the Ids starts to roll
upward.

TOff Loss region: When Vds starts rolling upwards, the Ids start to roll towards
zero.

Conduction Loss region: The region when the Ids is high and Vds is low.

Figure 31: Switching Loss Power signal and Losses regions

T1: First switching cycle

T2 : Second switching cycle

■ TOn and TOff losses
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TOn and TOff losses per switching cycle are computed as in the following
equations:

 

 

Where,

TONi - Turn ON loss of the ith switching cycle, in watt

TOFFi - Turn OFF loss of the ith switching cycle, in watt

fswi - Switching frequency of the ith switching cycle, in Hz

tonsi - Start point of TONi region of the ith switching cycle, in time unit

tonei - End point of a power TON region of the ith switching cycle, in time unit

toffei - End point of TOffi region, in time unit

toffsi - Start point of TOffi region, in time unit

Vds - Voltage drain current, in Volts

Ids - Drain current, in Amps

■ Energy Loss Computation

Energy loss computation for TON and TOFF are as below:

 

 

TEONi: ith switching cycle turn on energy loss in joule.

TEOFFi - ith switching cycle turn off energy loss in joule.

■ Computation of Conduction
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Conduction is computed as RDS(on) value for the MOSFET is used to calculate
total loss in the application. To measure conduction loss in a MOSFET, use the
following equation:
 

 

Conduction loss and energy are computed using above equations.

Here,

tcei: th Cycle's stop/end point of conduction region.

tcsi: th Cycle's start point of conduction region.

RDSon: Dynamic resistance, in Ω

ConductionLossi: ithswitching cycle conduction loss in watt.

ConductionEnergyi: ithswitching cycle conduction energy in joule.

To measure conduction loss in a BJT/IGBT, use the following equation:
 

 

Here,

Vce(SAT) - is the voltage in volt, which should be configure in application

■ Computation of Average Loss and Total Loss

Average and Total loss are computed as:
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Where,

fSWi: ith switching cycle frequency, in Hz

i:Cycle number

Nc: Number of conduction cycles
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Total Switching Loss=Ton Loss+Toff Loss+Conduction Loss.

Basic Algorithm: For the calculation of the TOn, TOff, and average Total loss.

 

 

Concept to identify TOn and TOff using gate voltage for edge analysis:

Use gate voltage for edge analysis with default 50% edge level and hysteresis
10%.

■ To find the start of TOn: The start of the TOn is 5% or 1.5 V whichever is
lower on the rise slope of the gate voltage.

■ To find the stop of TOn: The start index on the switch voltage is 5% or 1.5 V
of the rise slope gate voltage. Move forward on the switch voltage from the
start index until 5% or the configured level is met.

■ To find the start of TOff: The start index is 80% of the gate voltage. From the
Stop index, search for 5% of the switch voltage (on rise slope).

■ To find the stop of TOff: The 80% of the gate voltage is start index. From
this start index on switch current (fall slope) move forward until 5% of the
max (switch current) is met.

If you select the Filter check box in the application, use the following equation to
calculate moving average filter.

 

 

y(n)= is the output

x(n)= is the input

M is four sample points that are averaged
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Benefits of Vg Source and
SWL configuration

The switching circuit of interest has three types of signal:

1. Vds(t) switching voltage

2. Ids(t) switching current waveform

3. Vgs(t) is the gate to source voltage waveforms

The gate voltage signal from IC/Oscillator switching circuit is a clean signal. But
switching voltage and current signals can be noisy and has ringing based on
various SMPS topologies.

Gate voltage is recommended for below scenarios:

Case1:

The switching voltage can vary in duty cycle and operating frequency as shown
in the Discontinuous switching mode diagram. In this switch voltage can operate
in both continuous conduction mode and discontinuous conduction mode. The
switching cycles cannot be identified using switch voltage in this scenario. So,
gate signal is used to identify the correct switching cycles, which follow the
switching current Ids.

Figure 32: Discontinuous switching mode

Case 2:

For example, in Flyback topology lot of ringing can be observed during TOff and
spikes on switching current as shown in Impulsive voltage source diagram. In
such cases, voltage source cannot locate accurate TOn and TOff transition, and
needs Vg source which is in phase with current signal.
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Figure 33: Impulsive voltage source

Case 3:

By default, TOn and TOff regions are 5% of V - Level & I - Level of
'OnOffLevel' configuration. Example of sudden spike/ringing is shown in
Impulsive current signal diagram. This ringing causes wrong identification of
start of TOn region. In such case use 'Absolute' unit of 'OnOffLevel'
configuration and manual setting of the 'I-Level' and 'V-Level' in case of Vg
source.

Figure 34: Impulsive current signal

So Vg is recommended in above cases, so that the start and stop of TOn and TOff
regions are properly computed.

Switching Loss Configurations
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To compute losses, resonance on sources needs to be avoided, and it is described
in the configuration on setup in the next section.

1. In Case 1 and 2, use the Gate Voltage (Vg) source for noisy Vds and Ids
signals, which can be selected as shown in the Switching Loss source
configuration diagram.

Figure 35: Switching Loss source configuration

2. In Case 3, select Switching Loss and select Configure > OnOffLevel

Figure 36: Switching Loss On and OnOff Level configuration

Set Units as Absolute in

■ V-Level: Set the minimum V-Level above noise level on Vds as shown
in the Switching Loss On and OnOff Level configuration diagram

■ I-Level: Set the minimum I-Level above noise level on Ids as shown in
the Switching Loss On and OnOff Level configuration diagram
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3. In case if Vg source has spikes, then the manual setting can be found as
shown in Spike on Vg source.

Figure 37: Spike on Vg source

Gate voltage Vg should be expected without any ringing and spike. The
spikes gives incorrect edges. To avoid spikes as edges, use the Options
configuration.

Select Units as Absolute and set Ref Level above the spike peak value. By
default it is Percentage.

Figure 38: Switching Loss Edge configuration

4. Run the measurement.
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Switching loss - PFC Power factor correction (PFC) is a special circuit used by SMPS to make the
input current follow the sinusoidal shape of the AC input voltage, this helps to
correct the power factor. There are two types of PFC, passive and active in
nature. 

The following waveforms show typical switching voltage, current and gate
voltage scenario captured from electronic ballast.

You can observe that Switching Loss current at the start of operating frequency is
almost zero and ramps up in envelope shape to higher current levels and starts
reducing to zero level. So it is not possible to find edges with current waveform
and we had to use gate voltage.

Gate voltage as a third source is recommended to find proper ON and OFF edge
transitions because the switch voltage can vary in duty cycle and operating
frequency as shown in the figure. Switch voltage can operate in both continuous
conduction mode and discontinuous conduction mode.

The following figure shows 50 Hz captured switching voltage waveform bursts.
The zoomed portion shows the transitions. Place cursors 1 and 2 such that one
region is covered that is 100 Hz range.

Figure 39: Zoom-in of the VDS (Drain-Source) Voltage Switching cycles

During turn on time, a spike appears as shown below in the current waveform. To
have a more accurate analysis, a Gate voltage is recommended.
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Figure 40: Zoom-in of the IDS (Drain-Source) Current Switching cycles

The current waveform is in-phase with the Gate voltage and the Gate voltage is
ideally a pulse wave without ringing. If the gate voltage is noisy, it is
recommended to set the edge REF levels in the measurement > Configuration >
Options tab appropriately. The levels can be observed manually by using
horizontal cursors.

Figure 41: Zoom-in of the (VG)Gate Voltage
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Figure 42: VDS, IDS and VG overlapped

Figure 43: PFC Results
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Figure 44: Typical PFC plot over many cycles

For PFC Switching Loss plot, select Details button on the Plots menu to display
detailed Plot view options as below:

The Plot View drop-down has two options to select: All SW Cycle, SW Cycle.
 

 

When you select the SW Cycle drop-down, it will show four options: Cycle,
OnLoss, OffLoss, ConductionLoss.
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NOTE.
■ It is recommend to use "Cursor Position" in SW Cycle in case of noisy VG

source and plot may not place the cursors properly.
■ It is recommend for Switching Loss measurement for PFC and other

topologies to have at least 10 complete switching cycles to measure properly.

Hi-Power finder The computation of TON, TOFF and Total loss for Hi-Power finder is same as
Switching Loss measurements.

Safe operating area This measurement has three options:

■ SOA: Plots the graph of the voltage and current waveform.

■ SOA X-Y (DPX): Invokes the oscilloscope’s built in XY mode. This is
applicable only for live channels.
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Results:. The voltage vs current graph (also known as SOA Plot) displays the
value of voltage, current and power for a selected portion on the graph.

The occurrence field displays:

■ The number of occurrences of the selected voltage and current position in the
acquired waveforms

■ Average power
■ Standard deviation for the selected data point

The application calculates the Power Value using the following equation:
 

 

Where:

Pn is the instantaneous power value

Vn is the voltage value

In is the current value

n is the sample at the particular point

The application calculates the Average Power using the following equation:
 

 

Where:

N is the number of samples which has the same value in the plot.

The application calculates the Standard Deviation using the following equation:
 

 

Where:

XI is the Power Value

X is the Mean Power
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RDS(on) Dynamic resistance (RDS(on)) is the resistance offered by a switching device
when it is in the ON condition. DPOPWR helps to monitor the dynamic
resistance through V/I curve using oscilloscope built-in Math capability.

Place the cursor in the area of interest on resistance curve to get the resistance
value.

di-dt di/dt measurement represents the rate at which the current changes during
switching. The application uses the oscilloscope’s built in math feature to provide
a differentiation waveform of the current input.

When you run the measurement, the application calculates di/dt for the first edge
by taking the default levels as 10% and 90% and displays the results.

Select a specific section of the waveform on the live signal by providing inputs
for high and low levels in terms of percentage and absolute value of voltage and
current. Select the edge of interest by viewing it visually on the oscilloscope. You
can also enter the edge number on the results panel. The application displays the
results for the selected edge and levels on the results panel.

The application calculates di/dt using the following equation:
 

 

Where:

X=timing values

Y=Vertical values of the waveform data

dv-dt dv/dt represents the rate at which the voltage changes during switching. The
application uses the math feature to provide a differentiation waveform of the
voltage input.

When you run the measurement, the application calculates dv/dt for the first edge
by taking the default levels as 10% and 90% and displays the results.

Select a specific section of the waveform on the live signal by providing inputs
for high and low levels in terms of percentage and absolute value of voltage and
current. Select the edge of interest by viewing it visually on the oscilloscope. You
can also enter the edge number on the results panel. The application displays the
results for the selected edge and levels on the results panel.

The application calculates dv/dt using the following equation:
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where:

X =timing values

Y= Vertical(Voltage) values of the waveform data between the cursors.

Timing analysis
This section explains the algorithm details of the following measurements which
are part of Modulation Analysis:
■ Pulse Width
■ Period
■ Duty Cycle
■ Frequency
The application measures the signals on the complete cycles in the voltage
waveform. All these measurements are related with the time locations of the
edges in an acquisition. The result is displayed in graphical format in one of the
reference memory selected as part of the setup of the measurement.

Period and frequency  

 

The above diagram is a sample period-modulated signal that explains period and
frequency modulation. The annotations A to I in the above diagram represent the
V ref mid crossing in an acquired waveform.

The application calculates the period and frequency using the following equation:
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Where:

A, B, C, D, E, F, G, H, I are the data points

Pulse width and duty cycle  

 

The above diagram is a sample pulse width-modulated signal that calculates the
pulse width and duty cycle modulation. The annotations A to G in the above
diagram represent the V ref Mid crossing in an acquired waveform.

You can also configure the positive or negative pulse width or duty cycle.

The application calculates the pulse width and duty cycle using the following
equation:
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Where:

A, B, C, D, E, F, G are the data points.

Skew
This section explains the algorithm details of the following measurements which
are part of Timing Analysis:

The Skew measurement calculates the difference in time between the designated
edge on a principle waveform to the designated edge on another waveform.

The range limits where closest data edge to the clock edge falls is calculated by
following equation:

Tn
Skew = Tn

Main = Tn
2nd

Where:

Tn
Skew is the timing skew.

Tn
Main is the main input VRefMidMain crossing time in the specified direction.

Tn
2nd is the 2nd input VRefMid2nd crossing time in the specified direction.

n = 1 to number of edges.
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Magnetics
The Magnetics measurement displays I vs ∫V and measures Inductance, Magnetic
Property and Magnetic Loss. When using the integral of voltage, take care to
check that the voltage ‘V’ does not have any DC components. Use the
oscilloscope AC coupling to avoid any DC shifts on the integral of the voltage
waveform. The application creates a single cycle by averaging multiple cycles of
current and integrated voltage.

 

 

In the previous figure:

Bs is the Saturation Flux Density

Br is the Remanence Flux Density

Hc is the Coercive Force(Hc )

Ui is the Initial Permeability

Ua is the Max Amplitude permeability

NOTE. The data waveform starts from the Max value of H and Decreases and
increases again ( M-N-O-P ).

Magnetic Field Strength (H): The previous figure shows the hysteresis in a
typical magnetic material. The magnetic field induces a magnetic flux in the
DUT. The units of measurement are Ampere/ mtr in SI unit and Oersted in CGS
unit.
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Saturation Flux Density (Bs): The maximum magnetic flux density induced in
the material regardless of the magnitude of the externally applied field H.

This is calculated on the maximum flux density cycle on the acquired waveform
and let this be the Kth cycle on the acquired waveform.

Bs = Max ( Bk)

The Magnetic Field Intensity H is also calculated on the Maximum flux density
cycle Bk.

Bs = Max ( B)

Index I where H is maximum

I = Index of ( Max(H))

Bs = B(I) (2)

Remanence (Br): Is the Induced magnetic flux density that remains in the
material after the externally applied magnetic field (H) is returned to zero during
the generation of the Hysteresis loop.

Remanence also calculated on the kth cycle (Bk) where the maximum flux
density occurs in the entire acquired waveform.

Find the index at Zero value of H on the H waveform and calculate the maximum
value of B from these indexes.

Let ‘q’ be the index at Zero value of H on H waveform. Let the q1 and q2 be the
index of the waveform. Calculate the value of B at the Index q1 and q2 on the K
th cycle. The maximum magnitude value of B is the remanence Flux density.

Coercive Force(Hc): The value of H found at the intersection of the H-axis with
the Hysteresis loop is the coercive force. This represents the external field
required to cause the induced flux density (B) to reach zero during the
measurement cycle of a Hysteresis loop. HC is symmetrical with positive and
negative axis.

Coercivity Hc is also calculated on the kth cycle where the maximum flux
density occurs in the entire acquired waveform.

Finding the index at Zero B value on the B waveform: Let 'q' be the index at Zero
value of B on B waveform. Let q1 and q2 be the index on the B waveform where
B is Zero.

The maximum magnitude of the H data at the index of q1 and q2 is the
coercivity.

Permeability: It is the ratio of B and H calculated on the Bk cycle.

Select the points on the BH plot using the cursor and calculate the slope of the
BH curve using the data selected between the cursor. You can chose the portion
of the plot using the cursor to obtain the results.

Slope Calculation

There are N data points between the cursors
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Find Hav = (H1+HX2+…Hn)/N

Bav = (B1+B2+…Bn)/N

Hnormi = Hi-Hav, i=1..N

Bnormi = Bi-Bav, i=1..N

B/H = SUM(Hnorm1*Bnorm1+Hnorm2*Bnorm2+…+HnormN*BnormN)

/ SUM(Hnorm1*Hnorm1+Hnorm2*Hnorm2+…HnormN*HnormN)

Input analysis

Power quality The Power Quality measurement calculates the root mean square value for
voltage, root mean square value for current, true power, apparent power, power
factor, crest factor for voltage and crest factor for current.

The application calculates the RMS Voltage using the following equation:
 

 

Where:

RMS(v) is voltage

N is the number of samples

n is the data point

v(n) is the absolute value of the voltage at the particular data point

NOTE. The voltage RMS is for all time domain cycles in the acquisition.

The application calculates the RMS Current using the following equation:
 

 

Where:

i is current
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N is the number of samples

n is the data point

i(n) is the absolute value of the current at the particular data point

The application calculates the True Power using the following equation:

 

 

Where:

N is the number of samples

n is the data point

The application calculates the Apparent Power using the following equation:

 

 

Where:

RMS(v) is the root mean square of the voltage

RMS(i) is the root mean square of the current

The application calculates the Power Factor using the following equation:

 

 

Where:

P real is the real power

P appar is the apparent power

Crest factor is the ratio of the PK value of the signal to the RMS value of the
signal. Use the following equation to calculate the crest factor for the voltage and
current.
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Where:

Vpk is the peak value of the voltage

Vrms is the rms value of the voltage
 

 

Where:

Ipk is the peak value of the current

Irms is the RMS value of the current

Phase angle measurement

Phase Angle is the angle (-90 to +90) whose cosine is the true power factor. Unit
of Phase Angle is degrees. The angle is positive if the Ch1 waveform (typically
voltage) leads the Ch2 waveform (typically current). The angle is negative if the
Ch1 waveform lags behind the Ch2 waveform.
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Power Quality, which provides a single table of measurements and measurement
statistics for the AC input section of a power conversion circuit which includes:

■ RMS voltage and current.

■ True power (P) or the actual power delivered to the resistive part of the load,
measured in Watts. It is also VRMS * IRMS * cos(φ).

■ Apparent power (S), the product of the RMS voltage and current
(mathematically, the absolute value of the vector sum of the true and reactive
power), measured in Volt-Amperes or VA.

■ Reactive power (Q) or the imaginary power delivered to and temporarily
stored in the reactive (inductive or capacitive) elements of the load, measured
in units of Volt-Amperes-Reactive or VAR. It is also VRMS * IRMS *
sin(φ).

■ Voltage and current crest factors, which are the peak-to-RMS ratios for the
signals Frequency.

■ Power factor, the ratio of true power to apparent power. (If the signals are
pure sine waves, the power factor is the cosine of the phase angle between
the current and voltage waveforms).

NOTE. The phase angle can be easily derived from the other measurement results.

■ Phase angle (φ), which is the angle between the real and apparent power
vectors, equal to the impedance phase angle.

■ Mathematically, cos(φ) = P/S and sin(φ) = Q/S.

Current/Voltage
harmonics

Harmonics are sinusoidal voltages or currents having frequencies that are integer
multiples of the frequency at which the supply system is designed to operate
(termed the fundamental frequency). Distorted waveforms can be decomposed
into a sum of the fundamental frequency and the harmonics.

Current/Voltage measurements f0llow the below steps to calculate harmonics:
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1. It uses the Discrete Fourier Transform (DFT) to calculate real
component(Re(k)) and imaginary component Im(k)
 

 

Where

ki = The index for the harmonics as per acquired recorded length (N)

i = 1, 2, .... Harmonic order (OH).

ki = Index of input line harmonic × i

x(n) = The discreet set of acquire time samples

Rek = Real component of kth harmonic

Imk = Imaginary component of kth harmonic
2. Magnitude of frequency domain component

 

 
fk - kth harmonic

Unit of fk for voltage signal is volt and for current signal is ampere.
3. Harmonic is converted into dB using below equation

 

 

NOTE. In case of ‘AM 14’ standard, acquired signal is divided into 15 chunks
and all harmonic are calculated for each chunk. For each individual
harmonic maximum is taken out of 15 values.

RMS of harmonic is calculated from harmonic in unit of volt or ampere below
formula:
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f1 = Fundamental harmonic or line harmonic

Total harmonic distortion (THDF) is measured as a ratio to the RMS value of the
fundamental component of the source waveform. Reported as a percentage and
calculated by below formula:
 

 

Total harmonic distortion (THDR) is measured as a ratio to the RMS value of the
source waveform. Reported as a percentage and calculated by below formula:
 

 

Phase calculation

Alternatively, the frequency domain can be expressed in polar form. In this
notation, real (Rex[ ])& imaginary (ImX[ ]) component in frequency domain are
replaced with two other arrays, called the Magnitude of X[ ],Mag X[ ], and the
Phase of X[ ], written as: Phase X[ ]. The magnitude and phase are a pair-for-pair
replacement for the real and imaginary parts. For example, Mag X[0] and Phase
X[0] are calculated using only ReX[0] and Im X[0]. Likewise, Mag X[14] and
Phase X[14] are calculated using only ReX[14] and Im X[14], and so forth. To
understand the conversion, consider what happens when you add a cosine wave
and a sine wave of the same frequency. The result is a cosine wave of A cos(x) +
B sin (x) = M cos( x + Φ).
 

 

Where:
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i = Index of harmonics

RelX[i] = Real component of the harmonic (Cos frequency)

ImgX[i] = Imaginary component of the harmonic (Sin frequency)
 

 

If, RelX[i] < 0 & ImgX[i] < 0  Phase[i] = Phase[i] - π

If, RelX[i] < 0 & ImgX[i] > 0  Phase[i] = Phase[i] + π

NOTE. For "AM 14" standard phase values are shown in result of maximum
amplitude value of harmonic.

Partial Odd Harmonic Current (POHC)

For the 21st standard higher odd order harmonics, the average values obtained for
each individual odd harmonic over the full observation period, calculated from
acquired waveform. The measured partial odd harmonic current does not exceed
the partial odd harmonic current which can be calculated from the applicable
limits.
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Total power quality The algorithm for this measurement is a combination of the Current harmonics
and Power quality algorithms.

In-Rush current Typical scenario to measure Peak Inrush current is when the switching power
supply is first turned ON. Power converters have inrush currents much higher
than their steady state currents, due to the charging current of the input
capacitance. So we have devised a general measurement which can cater to all
situations.

Algorithm:

The In-Rush current is measured for the region of interest and not on the entire
waveform. The start region is defined as, when the waveform crosses the 'In-
Rush threshold' to stop region where the current waveform again crosses this
level. The measurement is automatic and identifies the In-Rush region
algorithmically. However user can specify the inrush region by placing the scope
cursors. The start and stop of In-Rush region depends on the threshold (Ref Level
configuration) value which is used to identify region. Typically the start region is
when the waveform crosses the threshold and stop region is identified where the
current waveform again crosses the threshold.
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Input capacitance The current waveform is used to compute the capacitance value. The application
provides configuration to enter peak voltage values, so waveform is not require to
acquire. The accumulated charge is computed using the trapezoidal integration of
current samples taken from start to stop regions.

Algorithm:

The charge, 

Where:

K stands for current samples between start and stop index.

The capacitance is computed using the equation 

Hence capacitance in Henry is 

Output analysis

Ripple line and ripple
switching

The Ripple measurements display the ripple content in the signal. In Ripple Line,
the time base is set to have three cycles of 50 Hz or 60 Hz in the input waveform.
In Ripple switching, depending the switching frequency input sets the time base
to display four cycles.

Depending upon the coupling type you select, the application sets the required
offset and adjusts the vertical scale to the appropriate sensitivity. The application
measures the peak-to-peak value and displays the result.

Spectral analysis Spectral Analysis measures the magnitude of the signal over the specified
frequency range by computing the Fast Fourier Transform.

The application calculates the two sided amplitude spectrum using the following
equation:

Amplitude spectrum in quantity peak = Magnitude [ FFT (A)]/N

Where:

N = number of sampling points and

A is the signal

The application calculates the two sided amplitude spectrum using the following
equation:

Single sided Amplitude spectrum in volts rms = 1.141*Magnitude [ FFT (A)]/N
for i = 1 to N/2 –1 
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= Magnitude [FFT (A)]/N for i = 0(DC)

Where:

i is the frequency line number of the FFT of A

Each frequency other than the DC is multiplied by 2 and the second half of the
array is discarded.

Amplitude spectrum is closely related to the power spectrum. Single sided power
spectrum is computed by squaring the single-sided rms amplitude spectrum.

The application calculates the single sided amplitude spectrum using the
following equation:

Where:

P is the measured power

Pr is the reference power

Db = 20log10A/Ar

Where:

A is the measured amplitude measured in Decibel

Ar is the reference amplitude measured in Decibel

The application calculates the FFT using the following equation:
 

 

Where:

X (K) is the discrete Fourier transform of x computed using a Fast Fourier
Transform algorithm.

x(n) is the discrete set of time samples

k is the index for the computed set of discrete frequency components

N is the number of samples considered
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Selecting RBW value. Algorithm uses scope record length and selected ‘Stop’
frequency (Selecting and configuring measurements-Spectral analysis)

Where,

FStop = Selected ‘Stop’ frequency in Spectral Configuration

RL – Scope Record length {2k, 5k, 10k, 20k, 50k, 100k, 200k, 500k, 1M, 2M };

PoE Specific filter details. Following table describes the settings of PoE Specific
filters:

Table 23: PoE filter settings

Filter name Filter type Start frequency
(Hz)

Stop frequency
(Hz)

Window type

PoE 500 Hz Low pass 0 Hz 500 Hz Kaiser
PoE
500 Hz-150 KHz

Band pass 500 Hz 150KHz Kaiser

PoE
150 KHz-500 KHz

Band pass 150 KHz 500KHz Kaiser

PoE 500 KHz-
1 MHz

Band pass 500 KHz 1MHz Kaiser

Figure 45: POE150KTO500K
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Turn-On time Turn-On Time is the time taken to get the output voltage of the power supply
after the input voltage is applied. DPOPWR provides an option of measuring
three output signals concurrently in case of four channel oscilloscopes.

The application measures Turn-On Time with the following inputs.

You have to have the following inputs to measure Turn-On Time:
■ Levels of all the channels voltages
■ Maximum Turn-On Time
The application sets the vertical settings for the waveform to occupy at least two
divisions. The horizontal settings are set according to the configuration inputs
mentioned above.

Amplitude

High The High Amplitude measurement calculates the mean or mode of a selected
portion of each unit interval.

The application calculates this measurement using the following equation:

VHIGH(n) = Func(Vpercent(n))

Where:

VHIGH(n) is the high amplitude measurement result.

Func [ ] is the selected operation (either Mean or Mode).

Vpercent(n) is the region around the upper portion center of each cycle ranging
from 1% to 100%.

n is the index of a high bit.

Low The Low Amplitude measurement calculates the mean or mode of a selected
portion of each unit interval. 

The application calculates this measurement using the following equation:

VLow(n) = Func(Vpercent(n))

Where:

VLow(n) is the low amplitude measurement result.

Func [ ] is the selected operation (either Mean or Mode). Mean method is the
arithmetic average from the histogram for each cycle in entire acquisition. Mode
method is the most commonly occurred value from the histogram for each cycle
in entire acquisition.

Vpercent(n) is the region around the lower portion center of each cycle ranging
from 1% to 100%.

n is the index of a high bit.
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High-Low The High–Low measurement calculates the change in voltage level across a
transition in the waveform.

The application calculates this measurement using the following equation:

VHigh-Low(n) = Func(Vlevel(i) - Vlevel(i+1))

Where:

VHigh-Low(n) is the high-low amplitude measurement result.

i is the index of the first edge location of the acquired waveform.

Cycle min Cycle min measures lower region of the waveform for all cycles. It is the
minimum voltage for each cycle from the mid level of Fall to the Rise slope.

VCycleMin = Min(f(FallIndex(i) to RiseIndex(i+1))

Where:

i = 1 to the valid edge of the last cycle.

f is the function, which finds the minimum sample point in the defined region.

Cycle max Cycle max measures upper region for all cycles. It is the maximum voltage for
each cycle from the mid level of rise to the fall slope.

The application calculates this measurement using the following equation:

VCycleMax = Max(f(RiseIndex(i) to FallIndex(i+1))

Where:

i = 1 to the valid edge of the last cycle.

f is the function, which finds the maximum sample point in the defined region.

Cycle peak-to-peak (Pk-
Pk)

Cycle peak-to-peak measures the absolute difference between the maximum and
minimum amplitude for every cycle of the waveform. The peak value is
measured from fall slope to the next rise if the valid slope is a fall and the next
peak would be from rise to next fall slope. The peak-to-peak value is calculated
on all the pairs of minimum and maximum values available.

The application calculates the Cycle Pk-Pk using the following equation:

Vpk-pk(n) = ABS (VCycleMax - VCycleMin)

Where:

VCycleMax (n) is the maximum peak amplitude.

VCycleMin (n) is the minimum peak amplitude.

n is the number of cycles from 1 to the last valid edge.
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Appendix

Appendix A
Use differential voltage and current probes to probe voltage and current signals in
a switching power supply. Since these probes have active circuits, correct the DC
offset errors. The DC voltage error adds to the test signal to display wrong
results. The different propagation in differential voltage probes and current
probes causes errors in time-correlated measurements and displays wrong power
waveform measurements.

Follow the procedure below to eliminate these errors:

For P5205 probe 1. Connect P5205 to Channel 1 of the oscilloscope.
2. Set the probe at 50X position.
3. Connect the + and - probe inputs to the same test point.
4. Set the coupling to DC.
5. Set the vertical sensitivity to maximum.
6. Check for no DC voltage offset on screen.
7. If there is a DC offset on the oscilloscope screen, use a small screwdriver and

set "adjust offset" potentiometer at the BNC end of P5205, so that the DC
voltage is zero.

For TCP202 probe 1. Connect TCP202 to Channel 2 of the oscilloscope.
2. Close the TCP202 clamp.
3. Press degauss and release degauss button at the BNC connector of TCP202.
4. If DC offset is present on screen, use "Balance" at the BNC connector of

TCP202 to adjust the DC current level to zero.

NOTE. P5205 and TCP202 are matched probes. You do not have to deskew
these probes because they have the same propagation delay.

5. The test setup is ready to take power measurements.
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Appendix B
1. The application expects the data waveform in a nonequivalent time mode

(ET) for its analysis. If the equivalent time mode is turned AUTO, the
application switches off the equivalent time mode and measures the signal.
The application does not display a warning message and the record length
may vary according to the horizontal settings.

2. The application uses the reference memory and/or the math based on the
measurement selected. The application does not display a warning message.

3. The application runs with a record length of 2M or less when measurement is
selected with plots.

4. While measuring Power Dissipation, SOA and Magnetics, do not disturb the
oscilloscope settings during the post analysis of the results. This leads to
wrong interpretation of results.

5. Connect the current probe in the correct direction. If not, the application
displays negative results for the inductance value.

6. Compensate the DC offset in the current probe and voltage probe. If not, the
core loss result becomes negative or Peak Finder measurement displays
improper cursor association.

7. Select the appropriate voltage and current channels according to the voltage
and current probes connected to the channels. If not, the B-H curve is
reversed and other measurements may provide wrong results.
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Glossary

AC signal
A time-varying signal whose polarity varies with a period of time T, and whose
average value is zero.

Crest factor: cf The ratio of the peak value to the rms value of an AC waveform measured under
steady-state conditions. It is unit-less, and the ratio for a pure sine wave is equal

to .

where Vin is the voltage at the user input terminals.

dB The abbreviation for decibels.

Current probe(s) A current probe is used to measure DC, AC, or composite currents. DC current
probes should measure DC and composite currents to within ± 1% with a probe
calibrator and ± 3% without the calibrator. AC current probes should measure AC
currents to within ± 5%. This accuracy should be maintained up to the worst case
expected peak current. Proper bandwidth should also be ensured.

DC signal A signal whose polarity and amplitude do not vary with time.
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Electrical power dissipation
The difference between the electrical input power to the UUT and its electrical
output power, expressed in watts.
 

 

Alternatively, power dissipation is expressed as:
 

 

Harmonics
Sinusoidal voltage or current components (distortion) of a periodic waveform
which occur at a frequency that is an integer multiple of the fundamental
frequency.

Most nonlinear loads generate odd-numbered harmonics, for example, as a result
of full wave rectification of the input power. The frequencies at which these
"characteristic harmonics" are produced by a user with an input rectifier can be
determined by the equation:
 

 

where

fH = the characteristic harmonic (for example, the "third harmonic" when H = 3);

H = the number of the harmonic;

k = an integer, beginning with 1;

q = an integer, representing the number of rectifier commutations per cycle;

f1 = the fundamental frequency.
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Half wave rectification produces even-numbered harmonics that cause very
undesirable results (for example, DC content) in the ac power system. Full wave
rectification at the input of single-phase power loads results in ‘triplen’
harmonics at odd multiples of three times the fundamental frequency. These are
also very undesirable, considering the potential quantity of single-phase loads
and the fact that these harmonics interact with the distribution system’s normally
high zero sequence impedance. User distortion current requirements are
intentionally restrictive therefore for even and triplen harmonics.

Power factor
(displacement)

For user equipment, the displacement power factor is equal to the cosine of the
angle, j, between the input current and the input voltage at the fundamental
frequency.
 

 

This definition of power factor does not include the effect of distortion in the
input current (and/or voltage) waveform.

Power, total or apparent The total or apparent power (S) is the product of rms voltage and current (VA).

Power factor
(displacement)

For user equipment, the displacement power factor is equal to the cosine of the
angle, j, between the input current and the input voltage at the fundamental
frequency.
 

 

This definition of power factor does not include the effect of distortion in the
input current (and/or voltage) waveform.
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Power factor (distortion) The distortion power factor is defined as:
 

 

where THD (Total Harmonic Distortion) is defined in 1.22.

This definition of power factor does not include effect of displacement.

Power factor (true) For user equipment, the true power factor is the ratio of the active, or real, power
(P) consumed in watts to the apparent power (S) drawn in volt-amperes, with:
 

 

where

PF = power factor;

P = active power in watts;

Q = reactive power in vars;

S = total power in volt-amperes.

This definition of power factor includes the effect of both displacement and
distortion in the input current (and/or voltage) waveform.

Alternatively, if there are no inter-harmonics, equation 7 can be simplified to

.
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In rush
A hot plug measurement of the maximum value or peak of the inrush current.
Results of the measurement include peak power, energy during inrush, and
duration of the inrush current.

Input capacitance
Measures the capacitance using the voltage and current, by using the equation
c=q/v.

where

c - capacitance in farad;

q - accumulated charge, which is integration of current waveform;

v - peak-peak voltage.

RMS value (voltage)(voltage)
The square root of the average of the square of the value of the function taken
throughout the period. For instance, the rms voltage value for a sinewave may be
computed as:
 

 

where

T = waveform time period;

v(t) = instantaneous voltage at time t;

Vrms = rms voltage value.
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Total harmonic distortion The ratio, expressed as a percent, of the rms value of the ac signal after the
fundamental component is removed and inter-harmonic components are ignored,
to the rms value of the fundamental. The formula defining total harmonic
distortion (THD) is provided in equation (7). The variables ‘X1’ and xn may
represent either voltage or current, and may be expressed either as rms or peak
values, so long as all are expressed in the same fashion.

 

 

Where:

X1 = Fundamental value of current or voltage;

xn = n th harmonic value of current or voltage.

Transfer impedance
The output voltage divided by the input current while the output is delivering
rated current.

Hysteresis The difference between the threshold voltage for the UVLO and the threshold
voltage for turn-on.

V max input The maximum allowable input voltage rating at which UUT can operate to
specifications.

V min input The minimum allowable input voltage rating at which UUT can operate to
specifications.

V nom input The stated or objective value of the input voltage, which may not be the actual
value measured. The value should be between the minimum and maximum input
value.

Voltage probe A connecting device, usually consisting of a two-conductor shielded cable and
frequency-compensating network, with a hand-held tip, for use with an
oscilloscope to measure the amplitude and waveshape of a DC, AC or a
composite signal. It should include a ground reference. The measurement
bandwidth should be at least 10 times greater than the frequency of interest. The
impedance should be at least 50 times greater than the node impedance under
measurement. A low impedance probe should be used for measurement purposes.
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Additional topics

Current harmonics bar graph results
 

 

Select the Save button to save the bar graph to the default location C:\Program
Data\Tektronix\TekApplications\Advanced Power Analysis\Images or any other
location of your choice.
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File menus
There are no parameters for the File menu items.

Configuration parameter specifications

Measureme
nt/ Sub
Type

Menu Minimum Maximum Default Resolution Units

Common
Configuratio
n

I-Probe
Settings>
Transfer
Impedance

0.001 10 0.5 0.001 Ω

Common
Configuratio
n

I-Probe
Settings>
Custom
Scale Factor

100p 10G 1 1 NA

Common
Configuratio
n

I-Probe
Settings>
Custom
Propagation
Delay

0 150n 0 1n s

Power
Dissipation

RDS On 0 100 20m 0.0001 Ω

VCE Sat 100m 50 2 0.1 V
Edge Levels
Hysteresis
percentage

5 40 10 1 %

Ref Level
percentage

10 90 50 1 %

Hysteresis
absolute

0 3000 5 0.001 V

Ref Level
absolute

-5999 5999 50 0.001 V

V Level
percentage

1 90 5 1 %

I level
percentage

1 90 5 0 %

V level
absolute

-5999 5999 5 0.001 V

I Level
absolute

-100 100 1 0.001 A

Vg Level -100 100 1.5 0.1 V
Magnetics Hysteresis

percentage
5 40 10 1 %
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Measureme
nt/ Sub
Type

Menu Minimum Maximum Default Resolution Units

Ref Level
percentage

10 90 50 1 %

Hysteresis
absolute

0 3000 150m 0.001 V

Ref Level
absolute

-5999 5999 5 0.001 V

Num of
Turns

1 1M 1 1 NA

Cross
section area-
SI

1u 1M 1 1u m2

Length-SI 1u 1M 1 1n m
Cross
section area-
CGS

1un 1M 1 1n cm2

Length-CGS 1un 1M 1 1n cm
Current
Harmonics

Ampere
Value (in
Harmonic
Table Editor)

0 10 0 0.00001 A

Ratio (In
Impedance
table Editor)

0.001 2 0 0.001 NA

A14 Input
Power (for
Class C and
Class D
only )

0 600 100 10m W

A14 Power
Factor (for
Class C
Only)

0 1 1 10m NA

A14
Fundamental
Current (for
class C only)

0 16 16 10m A

Switching
Ripple

Switching
Frequency

50 1M 10K 1 Hz

Turn on
Time

Maximum
Line Voltage

1 500 230 1 V

Voltage
1 Maximum
Value

- 5999 5999 5 0.01 V
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Measureme
nt/ Sub
Type

Menu Minimum Maximum Default Resolution Units

Voltage
2 Maximum
Value

- 5999 5999 5 0.01 V

Voltage
3 Maximum
Value

- 5999 5999 5 0.01 V

Maximum
Turn-on

1u 5 200m 1u s

Custom
Frequency
for AC-DC

50 1M 50 1 Hz

Trigger
Voltage

1 500 230 1 V

Utilities>
Deskew

From Ref
Level

0 100 50 1 %

From
Hysteresis

0 25 5 1 %

To Ref Level 0 100 50 1 %
To
Hysteresis

0 25 5 1 %

Edges 1 100 1 1 NA

Measureme
nt/ Sub
Type

Menu Minimum Maximum Default Resolution Units

Pulse Width, Duty Cycle, Period, Frequency
Absolute Ref
Level

Ref Level -5999 5999 0 0.001 V

Absolute
Hysteresis

Ref Level 0 3000 6 0.001 V

Percentage
Ref Level

NA 1 99 50 1 %

Percentage
Hysteresis

NA 0 50 3 1 %

SOA
SOA Mask
Editor

Y Max (-40K) 5K 10 A

Y Min (-40K) 5K 0 A
X Max (-40K) 40K 500 1m V
X Min (-40K) 40K 0 1m V

SOA Overlay Y Max -40 5 10 A
Y Min -40 5 0 A
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Measureme
nt/ Sub
Type

Menu Minimum Maximum Default Resolution Units

X Max -40 5 500 V
X Min -40 40Kv 0 V

Spectral
Analysis
Start
Frequency

NA 0 499 M
299 M for
TDS5032,
TDS5034

50 5 Hz

Stop
Frequency

NA 50 500 M
499 M for
TDS5032,
TDS5034

1000 5 Hz

PoE Filter

Measurement/ Sub Type Menu Minimum, Maximum
SOA Plot Cursor Position Dynamic depending on results
Power Energy Power Finder
results

Peak Count Dynamic depending on results

Occurrence Dynamic depending on results
Core Saturation Plot Cursor Position Dynamic depending on results

Measurement/
Sub Type

Minimum Maximum Default Resolution Units

di/dt configuration
Ref Level in
Amps

-999 999 5 0.001 A

Hysteresis in
Amps

0 3000 150m 0.001 A

Ref Level in
percentage

1 99 50 1 %

Hysteresis in
percentage

5 50 10 1 %

dv/dt configuration
Ref Level in
Volts

-5999 5999 5 0.001 V

Hysteresis in
Volts

0 3000 150m 0.001 V

Ref Level in
Percentage

-5999 5999 50 1 %

Hysteresis in
Percentage

5 50 10 1 %
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Measureme
nt/Sub Type

Menu Minimum Maximum Default Resolution Units

di/dt results
Ref Level in
Amps

High -999 999 10 0.001 A

Low -999 999 1 0.001 A
Ref Level in
percentage

High 1 99 90 1 %

Low 1 99 10 1 %
dv/dt results
Ref Level in
Volts

High -5999 5999 10 0.001 V

Ref Level in
Volts

Low -5999 5999 1 0.001 V

Ref Level in
Percentage

High 1 99 90 1 %

Ref Level in
Percentage

Low 1 99 10 1 %

Edge
Number

Dynamic depending on results NA

SOA plot functionality
The zero reference line in green represents the X and Y values where X is the
current and Y, the voltage. This appears if zero values occur in SOA
measurement. The horizontal zero reference line appears if the horizontal value is
zero and a vertical reference line appears if the vertical value is zero. If the X and
Y axis have zero value, it is represented by (0,0). The input is the X and Y
waveform and the output is the plot.

Dot Connect Feature: You can connect successive data points in a plot. You can
identify when a single data is spread sparingly on the plot area. This feature is not
available in Zoom In or Zoom Out mode.

Link: Select the Link button to link the data points. When you link the data
points, the application automatically resizes the plot to the half screen.

Reset: Use the Reset button to reset the zoomed plot to its original state.

Saving the Plot: Use the Save button to save the XY plot. This will save the plot
area in . jpeg format in the default directory C: \ User\Public\TekApplications
\DPOPWR\Images.

Zoom In, Zoom Out: Select the Zoom control buttons to enable the Zoom
buttons. You can zoom in/out the data Points on the XY plot with a single mouse
click on the plot area. Draw a rectangle on the plot to select the portion you want
to zoom. This zooms the selected area.
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Setting up the application and taking measurements
To set up the oscilloscope follow these steps:

1. You must warm up the oscilloscope for twenty minutes before you can start
to take measurements.

2. You must run the compensation signal path on the oscilloscope.

3. You must make sure that the default factory setups are recalled before you
start using the application in the oscilloscope. To do so, push the recall
default setup button on the front-panel of the oscilloscope to recall the default
factory settings.

4. You should always use calibrated probes and degauss the current probes.

I-Probe settings-AM503S settings configuration
If you are using an AM503S series probe, select the AM503S Settings button and
use the drop-down arrow in the Probe Type field to select the probe type. Select
the Range value from the drop-down list to display the range of the selected
probe in the Probe Type field. Select OK to return to commit the change.

View recall waveform from the oscilloscope
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Index
A
About application examples, 203
About Application Parameters, 264
About Basic Operations, 13
About taking new measurements, 43
AC Signal, 323
Amplitude

cycle max, 320
cycle min, 320
cycle peak-to-peak, 320
high, 319
high-low, 320
low, 319

Analyze Switching Loss, 205
Appendix, 321
Application Directories and File Names, 14
Application Interface, 13
Auto Zero, 17
Autocalc loss without Vg, 71
Autoset, 60

C
Configuring edges, 65
Configuring global settings, 64
Configuring options, 65
Control panel, 66
Conventions, 4
Current Harmonics, 311
Current probes, 9
Current Transient Response, 302

D
Degauss, 17
Deskew Real Time, 25
Deskewing in DPO7000 series Oscilloscope, 25
Deskewing Probes and Channels, 19
Deskewing using a fixture, 27
di/dt, 302
dv/dt, 302

E
Edges

configuring, 65

Electrical Power Dissipation, 324
Equipment setup guidelines, 285

F
Feedback

techsupport, 4
File Menus, 330
Functionalities of the XY Plot, 334

G
General Safety Summary, 1
Global settings, 64
Glossary, 323
GPIB command

accumulated results
DPOPWR׃MEAS‹x›׃ACCMAx?, 216
DPOPWR׃MEAS‹x›׃ACCMEAn?, 217
DPOPWR׃MEAS‹x›׃ACCMIn?, 217
DPOPWR׃MEAS‹x›׃ACCPKTopk?, 218
DPOPWR׃MEAS‹x›׃ACCPOPulation?,

218
DPOPWR׃MEAS‹x›׃ACCResult?, 219
DPOPWR׃MEAS‹x›׃ACCSTDdev?, 219

add measurements
DPOPWR׃ADDMeas, 211

current results
DPOPWR׃MEAS‹x›׃CURRENTMAx?,

224
DPOPWR׃MEAS‹x›׃CURRENTMEAn?,

224
DPOPWR׃MEAS‹x›׃CURRENTMIn?,

225
DPOPWR׃MEAS‹x›׃

CURRENTPKTopk?, 225
DPOPWR׃MEAS‹x›׃

CURRENTPOPulation?, 226
DPOPWR׃MEAS‹x›׃CURRENTResult?,

226
DPOPWR׃MEAS‹x›׃

CURRENTSTDdev?, 227
error

DPOPWR׃LASTError, 216
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general
DPOPWR׃CLEARALLMeas, 214
DPOPWR׃FREerun, 214
DPOPWR׃MEAS‹x›׃CUSTomname?,

227
DPOPWR׃MEAS‹x›׃NAMe?, 229
DPOPWR׃MEAS(x)׃SELECTMEAS,

230
DPOPWR׃MEAS(x)׃

SOURCEAPPLYAll, 230
DPOPWR׃RECalc, 233
DPOPWR׃SELECTEDMEAS?, 233
DPOPWR׃SINgle, 234

global configure
DPOPWR׃MEAS‹x›׃ACQmode, 220
DPOPWR׃MEAS‹x›׃BWLimit, 222
DPOPWR׃MEAS‹x›׃COUPling, 223
DPOPWR׃MEAS‹x›׃CURGATing, 223

plots
DPOPWR׃CLEARALLPlots, 214
DPOPWR׃MEAS‹x›׃ADDPLOT, 220

report
DPOPWR׃GENREPAS, 215
DPOPWR׃GENREPort, 215

source autoset
DPOPWR׃MEAS‹x›׃SOURCEAutoset,

231
source selection

DPOPWR׃MEAS‹x›׃GATESOURce, 228
DPOPWR׃MEAS‹x›׃ISOURce, 229
DPOPWR׃MEAS‹x›׃VSOURce, 232

H
Harmonics, 324
Hi-Power finder Ton and Toff levels, 87
Hi-Power finder type, 86

I
I-Probe Settings-AM503S Settings Configuration, 335
In Rush, 327
Input Capacitacne, 327
Installing the application, 12
Introduction and Product Description

Installing the Application, 7, 12
Requirements and Restrictions, 9

Introduction to the Tutorial, 195
iProbe, 19

M
Magnetic loss, 131
Magnetics, 306
Measure Magnetic Loss, 207
Measure Switching Loss, 203
Measuring Magnetics, 199
Measuring Power Dissipation, 197

O
Online Help and Related documentation

Conventions, 3
Customer Feedback, 3

Options
Configuring, 65

P
Power factor correction (PFC), 296
Power Quality, 308
Preferences dialog, 19
Printing from the Online Help, 3

R
RDS(on), 302
Real time deskew, 25
Recalling a Saved Setup, 16
Recalling the Default Setup, 16
Related documentation, 4
Reports, 54
Requirements and Restrictions, 9
Returning to the Application, 15
Ripple Line and Ripple Switching, 316
RMS Voltage, 327

S
Safe Operating Area, 300
Saving a Setup, 15
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Select and configure measurement - Amplitude high-
low, 193

Select and configure measurement - cycle peak-to-
peak, 185

Selecting a measurement, 57
Selecting and configuring measurements

Spectral analysis, 169
Turn-on time, 177

Selecting and Configuring Measurements
di/dt, 94

Selecting and configuring measurements - amplitude
high, 188

Selecting and configuring measurements - amplitude
low, 190

Selecting and configuring measurements - cycle max,
182

Selecting and configuring measurements - cycle min,
179

Selecting and configuring measurements-Line ripple,
167

Selecting and configuring measurements-Power
quality, 135

Selecting and configuring measurements-Switching
ripple, 175

Setting up the application, 29
Setting Up the Application and Taking Measurements,

335
Setting Up the Oscilloscope, 196
Setting up the software, 29
Source selection panel, 58
Spectral Analysis, 317
Starting the Application, 196
Switch mode power supply, 277
Switching loss options, 72
Switching loss TOn and TOff levels, 70

T
Timing analysis

modulation measurements, 303
time measurements, 305

Total Power Quality, 315
Transfer Impedance, 328
Troubleshooting Spectral Analysis, 174
Turn-On Time, 319

U
Updates through the web site

Readme, 12
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