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Welcome
Welcome to the TekExpress® Ethernet Electrical Testing software application.
The application provides more visibility into your Ethernet designs with
1000BASE-T/100BASE-TX/10BASE-T PHY measurements as outlined in IEEE
802.3 Section 40, ANSI X3.263, and IEEE 802.3 Section 14 specific
measurements for different Ethernet standards to the already existing rich tool set
of generic jitter, timing, and signal quality measurements in Tektronix
Oscilloscope.

Key features:

■ Solution offers most comprehensive Ethernet PHY test coverage supporting
multiple speeds.

■ Highly optimized, intuitive user interface flow that sets up the test
configuration for easy ethernet electrical validation.

■ Compliance and margin testing for accurate analysis and improved
interoperability.

■ Time-domain and frequency-domain measurements made with single
analysis instrument.

■ Jitter and timing measurements with and without filters.

■ Amplitude and droop testing for transmitter performance.

■ User-defined mode enables flexible parameter control for characterization
and margin analysis. Detailed test reports with margin and statistical
information and analysis.

■ Ability to modify limits of test parameters in TekExpress for debug and
characterization.

■ Ability to easily configure multiple test runs.

■ Ability to preview test mode waveform prior to running the tests.

■ Additional Peak Distortion Vs Phase Offset and Error Values Vs Symbol
Number plots for 1000BASE-T distortion test.

■ Plot panel is available to view the plot for Return Loss measurement.
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Getting help and support

Conventions
Help uses the following conventions:

■ The term "Application" and "Software" refers to the TekExpress Ethernet
Electrical Testing Application.

■ The term “DUT” is an abbreviation for Device Under Test.

■ The term “select” is a generic term that applies to the different methods of
choosing a screen item (button, control, list item): using a mouse or using the
touch screen.

Icon Meaning
This icon identifies important information.

This icon identifies conditions or practices that
could result in loss of data.

This icon identifies additional information that
will help you use the application more efficiently.
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Related documentation
The following documentation is available as part of the TekExpress® Ethernet
Electrical Testing Application.

Table 1: Product Information

Item Purpose Location
Help Application operation and User

Interface help

PDF of help Printable version of the
compiled help

PDF file that ships with
TekExpress Ethernet solution
(TekExpress-Ethernet-Solution-
Software-Printable-Help-EN-
US.pdf).
You can download the PDF
version of the manual from the
Tektronix website.
Part number: 077-1504-02 
www.tek.com

Technical support
Tektronix values your feedback on our products. To help us serve you better,
please send us your suggestions, ideas, or comments on your application or
oscilloscope. Contact Tektronix through mail, telephone, or the Web site, 
www.tek.com

When you contact Tektronix Technical Support, please include the following
information (be as specific as possible):
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General Information ■ All instrument model numbers
■ Hardware options, if any
■ Probes used
■ Your name, company, mailing address, phone number, and FAX number
■ Please indicate if you would like to be contacted by Tektronix about your

suggestion or comments.

Application Specific
Information

■ Software version number
■ Description of the problem such that technical support can duplicate the

problem
■ If possible, save the setup files for all the instruments used and the

application.
■ If possible, save the TekExpress setup files, log.xml, *.TekX (session files

and folders), and status messages text file.
■ If possible, save the waveform on which you are performing the

measurement as a .wfm file.

 Getting help and support
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Getting started

Minimum system requirements
The following table shows the minimum system requirements to install and run
the TekExpress Ethernet solution.

Table 2: System requirements

Component Description
Oscilloscope MSO/DPO5000, DPO7000C and MSO/DPO70000C/DX/SX
Firmware ■ Firmware Version: 10.10.1 or above for Windows 10 

■ Firmware 10.8.3 only for Windows 7 

Software ■ IronPython 2.7.3 installed

■ PyVisa 1.0.0.25 installed

■ Microsoft .NET 4.0 Framework

■ Microsoft Internet Explorer 7.0 SP1 or greater, or other Web browser
for viewing reports

■ Adobe Reader software 7.0 or greater for viewing portable
document format (PDF) files
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Instruments and accessories required
The following table lists the instruments and accessories required for this
application. 

Table 3: Instruments and accessories required for Ethernet application

Instrument/Accessory Model number Quantity
Oscilloscope MSO/DPO5000, DPO7000C

and MSO/DPO70000C/DX/SX
One

Arbitrary Function Generator AFG3000
AFG31102
AFG31152
AFG31252

One

Arbitrary Waveform Generator ■ AWG520x
■ AWG5000 Series
■ AWG7000 Series

One

Fixtures TF-GBE-BTP
1000/100/10BASE-T Basic Test
Package (consists of test fixture
PCB set and RJ45 interconnect
cable).

One

TF-GBE-JTC 103 meter
1000BASE-T jitter test channel
cable

One

TF-GBE-SIC (Short 4-inch (0,
1-meter) RJ45 interconnect
cable)

One

Differential Probes ■ TDP1500
■ P6247
■ P6248
■ TDP3500

Two

NOTE.
■ TF-GBE-ATP fixture set contains TF-GBE-BTP and TF-GBE-JTC fixtures.
■ TF-GBE-BTP fixture set contains TF-GBE-SIC.
■ TF-GBE-BTP is required for Jitter-Slave test only.
■ TPA-BNC adapter is required for P6247 and P6248 differential probes.
■ For 1000BASE-T Slave jitter testing an additional differential probe is

required.
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Installing the software
Complete the following steps to download and install the latest Ethernet
application. See Minimum system requirements for compatibility.

1. Go to www.tek.com.

2. Click Downloads. In the Downloads menu, select DOWNLOAD TYPE as
Software and enter Ethernet in the MODEL OR KEYWORD field and click
SEARCH.
 

 

3. Select the latest version of software and follow the instructions to download.
Copy the executable file to the oscilloscope.

4. Double-click the executable and follow the on-screen instructions. The
software is installed at C:\Program Files\Tektronix\TekExpress\TekExpress
Ethernet.

5. Select Applications > TekExpress Ethernet from the TekScope menu to 
Launch the application.

Application directories

TekExpress Ethernet
application

The TekExpress Ethernet application files are installed at the following location: 

C:\Program Files\Tektronix\TekExpress\TekExpress Ethernet
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The following table lists the application directory names and their purpose:

Table 4: Application directories and usage

Directory names Usage
AWG Waveforms Contains waveform files
Bin Contains TekExpress Ethernet application libraries
Compliance Suites Contains compliance-specific files
Examples Contains examples for SCPI commands
ICP Contains instrument and TekExpress Ethernet application-

specific interface libraries
Images Contains images of the TekExpress Ethernet application
Lib Contains utility files specific to the TekExpress Ethernet

application
Miscellaneous Contains log files
Report Generator Contains style sheets for report generation
Tools Contains instrument and TekExpress Ethernet application-

specific files

See also View test-related files

File name extensions

File name extensions
The TekExpress Ethernet application uses the following file name extensions:

File name extension Description
.TekX Application session files (the extensions may not be displayed)
.py Python sequence files
.xml Test-specific configuration information (encrypted) files

Application log files
.csv Test result reports

Plot data
.mht Test result reports (default)

Test reports can also be saved in HTML format
.pdf Test result reports

Application help documents
.xslt Style sheet used to generate reports

Getting started  

8  TekExpress® Ethernet Electrical Testing Application Help



See also View test-related files

Application directories

View software version
Use the following instructions to view version information for the application and
for the application modules such as the Programmatic Interface and the
Programmatic Interface Client.

To view version information for Ethernet, click  button in the TekExpress
application and select About TekExpress.
 

 

NOTE. This example shows a typical Version Details dialog box, and may not
reflect the actual values as shown when you open this item in the application.

 Getting started
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Operating basics

Launch the application
To launch the TekExpress Ethernet solution, select Applications > TekExpress
Ethernet from the TekScope menu.
 

 

When you launch the application for the first time, the file C:\Users\<username>
\My Documents\My TekExpress\Ethernet\Resources.xml is mapped to drive X:.
This file contains information about available network-connected instruments.
The session files are stored in X:\Ethernet\. If this file is not found, then the
application runs Instrument Discovery Program to detect the network-connected
instruments before launching Ethernet solution.

If the application is behind the oscilloscope application, click Applications >
TekExpress Ethernet to bring it to the front. To keep the Ethernet application
window on top, select Keep On Top from the Ethernet Options menu.

NOTE. After installing the application, wait until the instruments gets discovered
in the TEKVISA before launching the application.
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See also Application controls

Application panel overview

Application panels overview
TekExpress Ethernet solution uses panels to group Configuration, Results, and
Reports settings. Click any button to open the associated panel. A panel may
have one or more tabs that list the selections available in that panel. Controls in a
tab can change depending on settings made in the same tab or another tab.
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Table 5: Application panels overview

Panel Name Purpose
Setup panel The Setup panel shows the test setup controls. Click the Setup button to

open this panel.
Use this panel to:

■ Set DUT tab parameters

■ Select tests

■ Set acquisition tab parameters

■ Set configuration tab parameters

■ Set preferences tab parameters

Status panel View the progress and analysis status of the selected tests, and view test
logs.

Results panel View the summary of test results and select result viewing preferences.
Plots panel View the plot for Return Loss measurement. Plot is displayed as a two

dimensional plot for additional measurement analysis.
Reports panel Browse for reports, save reports as specific file types, specify report

naming conventions, select report content to include (summary
information, detailed information, user comments, setup configuration,
application configuration), and select report viewing options.

See also Application controls

 Operating basics
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Global application controls

Application controls This section describes the application controls.

Table 6: Application controls description

Item Description
Options menu
 

 

To select global application controls.

Test Panel buttons
 

 

Controls that open tabs for configuring test settings and options.

Start / Stop button
 

 

Use the Start button to start the test run of the measurements in the
selected order. If prior acquired measurements are not cleared, then new
measurements are added to the existing set.
The button toggles to the Stop mode while tests are running. Use the
Stop button to abort the test.

Pause / Continue
button
 

 

Use the Pause button to pause the acquisition. When a test is paused,
this button toggles to Continue.
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Item Description
Clear button
 

 

Use the Clear button to clear all existing measurement results. Adding or
deleting a measurement, or changing a configuration parameter of an
existing measurement, also clears measurements. This is to prevent the
accumulation of measurement statistics or sets of statistics that are not
coherent. This button is available only on Results panel.

Application window
move icon
 

 

Place the cursor over the three-dot pattern in the upper left corner of the
application window. When the cursor changes to a hand, drag the
window to the desired location.

Minimize icon
 

 

Click to minimize the application.

Close icon
 

 

Click to close the application.

Mini view / Normal view
 

 
 

 

Toggles the application between mini view and normal view.
Mini view displays the run messages with the time stamp, progress bar,
Start / Stop button, and Pause / Continue button.
The application moves to mini view when you click the Start button.
 

 

See also. Application panel overview
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Options menu overview To access Options menu, click  in the upper-right corner of the application. 

Options menu

Menu Function
Default Test Setup Opens an untitled test setup with defaults selected.

Acquire Live Waveforms.
Data rate: 1000BASE-T.

Open Test Setup Opens a saved test setup.
Save Test Setup Saves the current test setup.
Save Test Setup As Saves the current test setup with a different file name or file type.
Open Recent Displays the recently opened test setups to open.
Instrument Control
Settings

Detects, lists, and refreshes the connected instruments found on
specified connections (LAN, GPIB, USB, and so on).

Keep On Top Keeps the TekExpress Ethernet application on top of all applications.
Email Settings Use to configure email options for test run and result notification.
Help Displays the TekExpress Ethernet help.
About TekExpress ■ Displays application details such as software name, version number,

and copyright.

■ Provides a link to the end-user license agreement.

■ Provides a link to the Tektronix Web site.

See also. Application controls
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TekExpress instrument
control settings

Use TekExpress Instrument Control Settings dialog box to search the instruments
(resources) connected to the application. You can use the Search Criteria to
search the connected instruments depending on the connection type. The details
of the connected instrument is displayed in the Retrieved Instruments window.

You can access this dialog box from the Options menu.
 

 

The connected instruments displayed here can be selected for use under Global
Settings in the test configuration section.

NOTE. Select GPIB (Default) when using TekExpress Ethernet application.

See also. Options menu overview

View connected
instruments

Use TekExpress Instrument Control Settings dialog box to search the instruments
(resources) connected to the application. The application uses TekVISA to
discover the connected instruments.

NOTE. The instruments required for the test setup must be connected and it must
be recognized by the application before running the test.

To refresh the list of connected instruments:

1. From the Options menu, select Instrument Control Settings.

2. In the Search Criteria section of the Instrument Control Settings dialog box,
select the connection types of the instruments to search.

 Operating basics
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Instrument search is based on the VISA layer, but different connections
determine the resource type, such as LAN, GPIB, and USB. For example, if
you choose LAN, the search will include all the instruments supported by
TekExpress that are communicating over the LAN.

3. Click Refresh. TekExpress searches for connected instruments.

4. After searching, the dialog box lists the instrument-related details based on
the search criteria. For example, For the Search Criteria as LAN and GPIB,
the application displays all LAN and GPIB instruments connected to the
application.

The details of the instruments are displayed in the Retrieved Instruments table.
The time and date of instrument refresh is displayed in the Last Updated field.

See also. 1000BASE-T connection setup

100BASE-T connection setup

10BASE-T connection setup
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Configure email settings Use the Email Settings utility to get notified by email when a measurement
completes, or produces any error condition. Follow the steps to configure email
settings:

1. Select Options > Email Settings to open the Email Settings dialog box.

2. (Required) For Recipient email Address(es), enter one or more recipient
email addresses. To include multiple addresses, separate the addresses with
commas.

3. (Required) For Sender’s Address, enter the email address used by the
instrument. This address consists of the instrument name, followed by an
underscore, followed by the instrument serial number, then the @ symbol,
and the email server ID. For example: user@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server
address of the Mail server configured at the client location, and the SMTP
Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name,
password, and host name in the corresponding fields.

NOTE. If any of the above required fields are left blank, the settings will not
be saved and email notifications will not be sent.

5. In the Email Attachments section, select from the following options:

■ Reports: Select to receive the test report with the notification email.

■ Status Log: Select to receive the test status log with the notification
email. If you select this option, then also select whether you want to
receive the full log or just the last 20 lines.

6. In the Email Configuration section:

■ Enter a maximum file size for the email message. Messages with
attachments larger than this limit will not be sent. The default is 5 MB.

■ Enter the number in the Number of Attempts to Send field, to limit the
number of attempts that the system makes to send a notification. The
default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use
this check box to quickly enable or disable email notifications.

8. To test your email settings, click Test Email.

9. To apply your settings, click Apply.

10. Click Close when finished.
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TekExpress® Ethernet Electrical Testing Application Help 19



Email Settings
 

 

Setup panel

Setup panel overview The Setup panel contains sequentially ordered tabs that help you guide through
the test setup and execution process. 
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Set DUT parameters Use the DUT tab to select parameters for the device under test. These settings are
global and apply to all tests of current session. The DUT settings also affect the
list of available tests in the Test Selection tab.
 

 

Click Setp > DUT to access the DUT parameters:

Table 7: DUT tab settings

Setting Description
DUT ID Adds an optional text label for the DUT to reports. The default

value is DUT001. The maximum number of characters is 32.
You cannot use the following characters in an ID name: (.,..,...,
\,/:?”<>|*)

   Comments icon (to the
right of the DUT ID field)

Opens Comments dialog box to enter text to add to the report.
Maximum size is 256 characters. To enable or disable comments
appearing on the test report, see Select report options.

Acquire live waveforms Perform analysis on live waveforms.
Use pre-recorded waveform
files

Perform analysis on pre-recorded waveforms.

Data Rate
1000BASE-T IEEE 802.3, Section 40 
100BASE-T ANSIX 3.263-1995 
10BASE-T IEEE 802.3, Section 14 

See also. Select tests
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Select tests Use the Test Selection tab to select the tests. The test measurements available
depends on the standard selected in the DUT tab.

Figure 1: TekExpress Ethernet measurements

Table 8: Test Selection tab settings

Setting Description
Deselect All Click to clear all tests.
Select Required Click to select all the tests required for

compliance.
Select All Click to select all tests. All tests are selected by

default.
Tests Click on a test to select or unselect. Highlight a

test to show details in the Test Description pane.
Test Description Shows brief description of the highlighted test in

the Test field.
Preview Click to preview the schematic and the expected

waveform example for the selected test.

See also. Set acquisition tab parameters
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Set acquisition tab
parameters

Use Acquisitions tab to view the test acquisition parameters. The contents
displayed on this tab depends on the DUT type and the tests selected.

 

 

NOTE. TekExpress Ethernet application acquires all waveforms needed by each
test group before performing analysis.
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Table 9: Acquisitions tab settings

Setting Description
View Probes Click to view the detected probe configuration.

Use the View Probes dialog box to enable or
disable probe signal source access in the
application.

Source Select the signal source for Data, Master Clock
and/or Slave Clock for the measurement.
Ensure that no two sources have the same
channel selected.
Same set of channels can be used for Return
Loss with a Data as positive input and Master
Clock as negative input and Slave Clock for
sync input.

Aux Select to use oscilloscope's Aux channel.
Acquisition and Save Options

■ Save All Waveforms
■ Delete All Waveforms After Analysis

■ Saves all the waveforms after the analysis.
■ Deletes all the waveforms after the

analysis.

Show Acquire Parameters Select to view the acquisition parameters.

TekExpress Ethernet saves all acquisition waveforms to files by default.
Waveforms are saved in a unique folder for each session (a session is started
when you click the Start button). The folder path is X:\Ethernet\Untitled Session
\<dutid>\<date>_<time>. Images created for each analysis, CSV files with result
values, reports, and other information specific to that particular execution are also
saved in this folder.

Saving a session moves the session file contents from the Untitled Session folder
to the specified folder name, and changes the session name to the specified name.

Set configuration tab
parameters

Use Configuration tab to view and configure the Global Settings and the
measurement configurations. The Global Settings and the measurements with
configurations available in this tab depends on the Standards selected in the DUT
tab.

 Operating basics
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Figure 2: Configuration tab: Global Settings

Figure 3: Configuration tab: Measurements Settings
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Table 10: Configuration tab settings

Setting Description
Compliance Mode Select to run test(s) in compliance mode. By default Compliance Mode is selected.
User Defined Mode Select to run test(s) in user defined mode.
Global Settings
Instruments Detected Displays the instruments connected to this application. Click on the instrument name to

open a list of available (detected) instruments.
Select Options > Instrument Control Settings and click Refresh to update the instrument
list.

NOTE. Verify that the GPIB search criteria (default setting) in the Instrument Control
Settings is selected when using TekExpress Ethernet application.

JigMatch Calibration Measures the Amplitude and the Frequency of the disturbing signals. The default values
can be set. The application measures and displays the values in the Measured Value fields.
You can validate the disturbing signal by comparing the Measured Value with the Expected
Value.

Return Loss Calibration Displays the schematics for Return Loss Calibration. The Transmitter and Receiver Return
Loss calibration for OPEN, SHORT, and LOAD terminations can be performed.

Table 11: Measurements configuration for Analyze 1000BASE-T

Measurements Configuration Value
Template Point A
Template Point B
Template Point C
Template Point D
Template Point F
Template Point H
Template Point A (D)
Template Point B (D)
Template Point C (D)
Template Point D (D)
Template Point F (D)
Template Point H (D)
Peak Point A
Peak Point B
Peak Point C
Peak Point D
Peak Point A (D)
Peak Point B (D)
Peak Point C (D)
Peak Point D (D)

Analyze External Filter Include or Exclude

Transmitter Distortion Without TX_TCLK
Transmitter Distortion With TX_TCLK
Transmitter Distortion Without TX_TCLK (D)
Transmitter Distortion With TX_TCLK (D)

Analyze LP Filter Include or Exclude
Hi Resolution 16 to 64 

Master Filtered Without TX_TCLK
Master UnFiltered Without TX_TCLK

Clock Edge RISE, FALL
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Measurements Configuration Value
Slave Filtered Without TX_TCLK
Slave UnFiltered Without TX_TCLK
Master Filtered With TX_TCLK
Master UnFiltered With TX_TCLK
Slave Filtered With TX_TCLK
Slave UnFiltered With TX_TCLK

Hysteresis 0% - 10 %

Transmitter Return Loss Analyze Smoothing Averages 1 to 10 
Loads (Ohm) ■ 85, 100, 115 

■ 100 

CM Voltage Filter Type ■ None
■ 1 MHZ(High Pass)
■ 100 MHz(Low Pass)
■ (1-100)

MHz(Baseband)

Table 12: Measurements configuration for Analyze 100BASE-T

Measurements Configuration Value
AOI Template Analyze Polarity ■ Both

■ Pos
■ Neg

Fail Threshold 1 to 5000 
Fall Time (Pos)
Fall Time (Neg)
Rise Time (Pos)
Rise Time (Neg)
RF Symmetry (Pos)
RF Symmetry (Neg)
Overshoot (Pos)
Overshoot (Neg)
Differential Output Voltage (Pos)
Differential Output Voltage (Neg)
Amplitude Symmetry

Analyze

Jitter Measurement Type ■ Tie
■ Histogram

Duty Cycle Distortion
Receiver Return Loss
Transmitter Return Loss

Smoothing Averages
Loads(Ohm)

1 to 10 

■ 85, 100, 115 
■ 100 
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Table 13: Measurements configuration for Analyze 10BASE-T

Measurements Configuration Value
Link Pulse Load With TPM Analyze Mark Selection

Fail Threshold
Head, Tail, Both
1 Link Pulse Load Without TPM

Link Pulse Timing With TPM Analyze
Link Pulse Timing Without TPM
Differential Voltage Analyze Peak ■ Min

■ Min Max
TP_IDL Load Without TPM
TP_IDL Load With TPM

Mark Selection
Fail Threshold

Head, Tail, Both
1 

Jitter Normal with TPM Analyze MAU Type ■ Internal
■ ExternalJitter Normal without TPM

Jitter 8.0 with TPM
Jitter 8.0 without TPM
Jitter 8.5 with TPM
Jitter 8.5 without TPM
MAU Internal Fail Threshold 1 
MAU External
MAU Internal (Inverted)
MAU External (Inverted)
Transmitter Return Loss
Receiver Return Loss

Smoothing Averages 1 to 10 
Loads (Ohm) ■ 85, 100, 115 

■ 100 

CM Voltage Filter Type ■ None
■ 1 MHz (High Pass)
■ 100 MHz (Low Pass)
■ 1-100 MHz (Band pass)

Table 14: Measurements configuration for Acquire 1000BASE-T

Measurements Configuration Value
Template Point A
Template Point B
Template Point C
Template Point D
Template Point F
Template Point H
Template Point A (D)
Template Point B (D)
Template Point C (D)

Acquire AcquisitionAverage 16 to 256 
TriggerLevel (A) -5 V to 5 V
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Measurements Configuration Value
Template Point D (D)
Template Point F (D)
Template Point H (D)

TriggerLevel (B) -5 V to 5 V

Transmitter Distortion Without TX_TCLK
Transmitter Distortion With TX_TCLK
Transmitter Distortion Without TX_TCLK (D)
Transmitter Distortion With TX_TCLK (D)
Peak Point A
Peak Point B
Peak Point C
Peak Point D
Droop Point G
Droop Point J
Peak Point A (D)
Peak Point B (D)
Peak Point C (D)
Peak Point D (D)
Droop Point G (D)
Droop Point J (D)

Acquire Acquisition Average 16 to 256 

Master Filtered Without TX_TCLK
Master UnFiltered Without TX_TCLK
Slave Filtered Without TX_TCLK
Slave UnFiltered Without TX_TCLK
Master Filtered With TX_TCLK
Master UnFiltered With TX_TCLK
Slave Filtered With TX_TCLK
Slave UnFiltered With TX_TCLK

Measurement
Duration

1 ms, 10 ms, 100 ms,
1000 ms

Number Of Clock
Edges

100000, 1000000,
10000000 

Transmitter Return Loss Acquisition Average 100 to 10000 
CM Voltage

Table 15: Measurements configuration for Acquire 100BASE-T

Measurements Configuration Value
AOI Template Acquire Number of samples 5000 to 2147400000 
Fall Time (Pos)
Fall Time (Neg)
Rise Time (Pos)
Rise Time (Neg)
RF Symmetry (Pos)
RF Symmetry (Neg)
Overshoot (Pos)
Overshoot (Neg)
Differential Output Voltage (Pos)
Differential Output Voltage (Neg)
Amplitude Symmetry

Acquisition Type Sample, Average
Number of
Waveforms

2 to 10000 

Jitter
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Measurements Configuration Value
Duty Cycle Distortion Acquisition Type Sample, Average
Receiver Return Loss
Transmitter Return Loss

Acquisition Average 100 to 10000 

Table 16: Measurements configuration for Acquire for 10BASE-T

Measurement Configuration Value
Link Pulse Timing Without TPM
Link Pulse Timing With TPM
Link Pulse Load Without TPM
Link Pulse Load With TPM

Acquire Number of Acquisitions
Number of Waveforms

2 to 10000 
1 to 10000 

Differential Voltage Acquisition Average 2 to 1000 
Acquisition Delay 1 to 10000 (Micro-seconds)
Acquisition Type ■ Sample

■ Average

TP_IDL Load With TPM
TP_IDL Load Without TPM

Number of Acquisitions
Number of Waveforms

2 to 10000 
1 to 10000 

Jitter Normal with TPM
Jitter Normal without TPM
Jitter 8.0 with TPM
Jitter 8.0 without TPM
Jitter 8.5 with TPM
Jitter 8.5 without TPM

Acquire Number of Acquisitions 2 to 10000 
1000 to 10000 

MAU Internal
MAU External
MAU Internal (Inverted)
MAU External (Inverted)
Harmonic Acquire Acquisition Delay 1 to 10000 (Micro-seconds)

Math Average 2 to 10000 
Transmitter Return Loss
Receiver Return Loss

Acquire Acquisition Average 100 to 10000 

CM Voltage
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Return Loss Calibration steps. You can configure a DUT (Device Under Test) by
adjusting it to conform to a dependable measure before running the Return Loss
measurement.

Complete OPEN, SHORT, and LOAD calibrations before running the Return
Loss measurement.

To run the Return Loss calibration, follow the steps given below:

1. Use TC1 in the test fixture.

Make the connections as shown in the following figure.

 
Figure 4: Connection diagram for SHORT Calibration

2. Connect a BNC Cable between channel 1 of AWG/channel 1 of AFG and
J290.

3. Connect a BNC Cable between  AWG/channel 2 of AFG and J291.
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4. Connect Differential Probes from configured channels of the oscilloscope to
P1 and P2 for Transmitter Return Loss, P3 and P4 for Receiver Return Loss.

NOTE. Connect the termination SHORT, LOAD, and OPEN to J200 one by
one, for calibration.

5. In the TekExpress Ethernet application click the DUT panel and select the
Suite of interest.

6. Click the Acquisitions panel and select the channels for calibration.

7. If Aux is selected as Source3 (Trigger Sync Input), select the checkbox.

NOTE. Aux channel is present only in 6 Series MSO oscilloscopes.

8. In the Options > Instrument Control settings, refresh to view the connected
AWG/AFG.

9. In the Configuration Panel, select the Signal source model (For Return Loss
test: AWG/AFG).

10. Click Return Loss.

Figure 5: Configuration Panel to select Signal Source and to perform Return Loss
Calibration

 

11. In the Calibration dialog, select Tx for Transmission or Rx for Receiver
Return Loss Calibration.
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12. Perform SHORT, OPEN, and LOAD Calibration one by one with connection
changes (detailed below) and click Apply. This completes the Return Loss
Calibration.

Figure 6: Calibration panel before performing calibration

The corresponding date and time for the latest successful Calibration and Apply
are displayed.

Figure 7: Calibration panel after calibration is performed for OPEN, SHORT, and LOAD and
then Apply
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SHORT calibration:

Perform the above-mentioned steps with SHORT termination connected to J200
as shown below:

 
Figure 8: Connection diagram for SHORT Calibration

The following figure displays a typical waveform for Return Loss SHORT
Calibration.

Figure 9: Calibration output for SHORT calibration
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OPEN Calibration:

Figure 10: Connection diagram for OPEN Calibration

 

The following figure shows a typical waveform for Return Loss OPEN
Calibration.

Figure 11: Calibration output for OPEN calibration
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LOAD Calibration:

Perform the above mentioned steps with LOAD termination connected to J200 as
shown below:

Figure 12: Calibration output for LOAD calibration

 

The following figure shows a typical waveform for Return Loss LOAD
Calibration.
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Figure 13: Calibration output for LOAD calibration

After OPEN, SHORT, and LOAD calibration, click Apply in Return Loss
Calibration window which generates the Return Loss measurements pre-requisite
data by using calibration values.

NOTE. Clicking Apply will not apply any setting on the oscilloscope nor does any
acquisition.

NOTE. If you change any of the following configurations, calibration for Open,
Short, and Load must be performed again before running the return loss
measurement:

■ Channels and Trigger Sync input
■ Signal Source selected
■ Return Loss type (Transmitter or Receiver)

Method to set up the Signal Source for Do not use configuration:

In Configuration Panel if the Signal source is selected as For Return Loss test:
AWG/AFG is Do not use, then the waveform need to be manually loaded in the
Signal Source before running the Calibration or Return Loss measurement.

Figure 14: Return Loss Signal Source selection, with Do not use configuration

 

Method for loading the waveform on the supported AWG:

■ Copy the waveform available at Oscilloscope at C:\Program Files\Tektronix
\TekExpress\TekExpress Ethernet\AWG Waveforms\10BaseT Return Loss
\AWG Format\RL10_AWG.wfm, to the AWG using LAN or USB.

Operating basics  

38  TekExpress® Ethernet Electrical Testing Application Help



Example mentioned above is for 10BaseT, select the folder accordingly for
1000BaseT or 100BaseT. The above path is applicable for all supported
AWG models.

■ Open the waveform for the corresponding speed and AWG series from Open
File option, and when prompted, select option Max & Preserve Offset
settings.

■ Set Amplitude to 1.5 Vpp. (Maximum supported Amplitude)
■ Click Setup > Clock > set the Sample Rate to 250 MS/s.
■ Click Setup > Channel > set the Resolution(bits) to (15 + 1 Mkr).
■ Switch ON the channel and click Play.

Figure 15: AWG with Return Loss waveform loaded

 

Method for loading the waveforms on the supported AFG:

For AFG3000 series:

1. Copy the waveform available at Oscilloscope at C:\Program Files\Tektronix
\TekExpress\TekExpress Ethernet\AWG Waveforms\10BaseT Return Loss
\AFG Format\RL10_AFG.tfw, to AFG using USB. Example mentioned above
is for 10BaseT, select the folder accordingly for 1000BaseT or 100BaseT.
The above path is applicable for all supported AFG 3000 series models.

2. Click Arb > Arb Waveform menu > USB > select the waveforms (.tfw) on
both the channels.

3. Set the Frequency to 6.052682549 kHz for 100BaseT and 1000BaseT and
6.097560976 kHz for 10BaseT, for both the channels.

4. Set the Amplitude to 2.0 Vpp, for both the channels.

5. Invert the waveforms on channel 2.

6. Switch ON both the channels.
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Figure 16: AFG with Return Loss waveforms loaded

 

For AFG31000 series:

1. Copy the waveform available at Oscilloscope at C:\Program Files\Tektronix
\TekExpress\TekExpress Ethernet\AWG Waveforms\10BaseT Return Loss
\AFG Format\RL10_AFG.tfw, to AFG using USB. Example mentioned above
is for 10BaseT, select the folder accordingly for 1000BaseT or 100BaseT.
The above path is applicable for all the supported AFG models.

2. Click Home > ArbBuilder > Open > USB, select corresponding folder and
file (.tfw) and click OK.

3. Click Save As and save the waveform on the Memory (.tfwx). Click OK.

4. Click Home > Basic > select Arb from drop down menu for the channel 1.

5. From Shape > File > USB > select the waveform file for the corresponding
speeds from Memory(.tfwx).

6. Repeat steps 4 and 5 for channel 2.

7. Set the Frequency to 6.052682549 kHz for 100BaseT and 1000BaseT and
6.097560976 kHz for 10BaseT, for both the channels.

8. Set the Amplitude to 2.0 Vpp, for both the channels.

9. Invert the waveforms on channel 2.

10. Switch ON both the channels.
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JigMatch calibration steps. You can measure the Amplitude and Frequency of the
disturbing signal and set the default values. The application measures and
displays the values in Measured Value fields. You can validate the disturbing
signal by comparing the measured value with the expected value.

To do the JigMatch calibration in the TekExpress application follow the steps
below:

1. In the DUT panel and select the Suite of interest.

2. In the Acquisitions panel and select the channel for measurement.

3. In the Instrument Control settings, refresh to view the connected AWG/
AFG.

4. From the Configuration panel, select the Signal source model in For
JigMatch test: AWG/AFG/Scope AFG.

5. Click JigMatch.

Figure 17: Configuration Panel for selecting Signal Source and to perform JigMatch
Calibration

JigMatch calibration includes the following:

■ Disturber Compensation
■ Test Fixture Compensation Step 1
■ Test Fixture Compensation Step 2

To measure the Disturbing Signal using JigMatch, follow the steps given below:

1. Use TC5 of the test fixture.
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2. Make the connections as shown in the following figure:

Figure 18:

NOTE.
■ Do not connect the Ethernet cable to J700 and the test port of the DUT.
■ Short the jumpers J621, J630, J620, J623, J721, J723, J680, and J781.

Figure 19: Disturber Compensation in JigMatch

3. In the Jig Match dialog box, click Measure in the Disturber Compensation
group box.

4. Compare the Measured Value with the Expected Value.

5. If the Measured Value is not approximately equal to the Expected Value,
modify the amplitude and clock frequency settings of the Arbitrary
Waveform Generator/Arbitrary Function Generator. Click Measure and
compare the values until it is approximately equal.
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To compensate the linearities of Test Fixture (TC2) using JigMatch, follow the
steps given below:

Test Fixture Compensation, Step 1:

1. Use TC2 of the test fixture.

2. Make the connections as shown in the following figure.

Figure 20: Connection diagram to measure linearities of Test Fixture using JigMatch

3. For Template, Droop, and Peak Voltage tests, set the DUT to generate Test
Mode 1 signal. For Distortion test, set the DUT to generate Test Mode
4 signal.

4. Connect the Ethernet cable to J490 and the test port of the DUT.

5. In the JigMatch dialog box > Test Fixture Compensation group box,
selectMeasure.

Figure 21: Test Fixture Compensation in JigMatch
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To compensate the linearities of Test Fixture (TC5) using JigMatch, follow the
steps given below:

Test Fixture Compensation, Step 2:

1. Use TC5 of the test fixture.

2. Make the connections as shown in the following figure.

Figure 22: Connection diagram to measure linearities of the Test Fixture using JigMatch

3. For Template, Droop, and Peak Voltage tests, set the DUT to generate Test
Mode 1 signal. For Distortion test, set the DUT to generate Test Mode
4 signal.

4. Connect the Ethernet cable to J700 and test port of the DUT.

5. Switch OFF the Arbitrary Waveform Generator/Arbitrary Function
Generator.

NOTE. Short the jumpers J621, J630, J623, J721, J723, J680, and J781.

6. Connect the differential probe to P18 and configured channel of the
oscilloscope.
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7. In the Jig Match dialog box >under step 2 of Test Fixture Compensation
group box, select Measure.

Figure 23: Test Fixture Compensation in JigMatch

Method to set up the Signal Source for Do not use configuration:

In Configuration Panel if the Signal source is selected as For JigMatch test:
AWG/AFG/Scope AFG is Do not use, then the waveform need to be manually
loaded in the Signal Source before running the JigMatch Calibration.

Figure 24: JigMatch Signal Source selection, with Do not use configuration

To load the waveform follow the steps below:

Method to setup the supported AWG For Test Mode 1:

1. Copy the waveform available in Oscilloscope located at C:\Program Files
\Tektronix\TekExpress\TekExpress Ethernet\AWG Waveforms
\AWG_Automation_Files\Template5K.wfm, to the AWG using LAN or USB.

The above mentioned path is applicable for all supported AWG models.

2. Set Amplitude on the AWG to 700 mVpp.

3. Switch ON the channel and click Play.

Figure 25: AWG with Test Mode 1 waveform loaded
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Method to setup the supported AWG For Test Mode 4:

1. Copy the waveform available in Oscilloscope located at C:\Program Files
\Tektronix\TekExpress\TekExpress Ethernet\AWG Waveforms
\AWG_Automation_Files\Distortion5K.wfm, to the AWG using LAN or
USB.

The above mentioned path is applicable for all supported AWG models.

2. Set Amplitude on AWG to 1.35 Vpp.

3. Switch ON the channel and click Play.

Figure 26: AWG with Test Mode 4 waveform loaded

Method to setup the supported AFG For Test Mode 1:

1. Set signal source on both the channels as Sine.

2. Set the Frequency on both the channels to 31.25 MHz.

3. Set the Amplitude on both the channels to 700 mVpp.

4. Set Phase of channel 2 to 180 degrees.

5. Switch ON both the channels.
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Figure 27: AFG with Test Mode 1 waveform loaded

Method to setup the supported AWG For Test Mode 4:

1. Set signal source on both the channels as Sine.

2. Set the Frequency on both the channels to 20.833 MHz.

3. Set the Amplitude on both the channels to 1.35 mVpp.

4. Set Phase of channel 2 to 180 degrees.

5. Switch ON both the channels.

Figure 28: AFG with Test Mode 4 waveform loaded
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Set preferences tab
parameters

Use Preferences tab to set the application action on completion of a
measurement.
 

 

Table 17: Preferences tab settings

Setting Description
Number of Runs
Acquire/Analyze each test <no> times (not
applicable to Custom Tests)

Select to repeat the test run by setting the
number of times. By default, it is selected with
1 run.

Actions on Test Measurement Failure
On Test Failure, stop and notify me of the failure Select to stop the test run on Test Failure, and

to get notified via email. By default, it is
unselected.
Click Email Settings to configure.

Popup Settings
Auto close Warnings and Informations during
Sequencing
Auto close after <no> Seconds

Select to auto close warnings/informations
during sequencing. Set the Auto close time. By
default it is unselected.

Auto close Error Messages during Sequencing.
Show in Reports
Auto close after <no> Seconds

Select to auto close Error Messages during
Sequencing. Set the Auto close time. By default
it is unselected.
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Status panel

Status panel overview The Status panel accesses the Test Status and Log View tabs, which provide
status on test acquisition and analysis (Test Status) and a listing of test tasks
performed (Log View tab). The application opens the Test Status tab when you
start a test run. You can select the Test Status or the Log View tab to view these
items while tests are running. 

Test status view

Log view
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Table 18: Status panel Log View controls

Control Description
Message History Lists all executed test operations and timestamp

information.
Auto Scroll Enables automatic scrolling of the log view as

information is added to the log during the test.
Clear Log Clears all messages from the log view.
Save Saves the log file to a text file. Use the standard

Save File window to navigate to and specify the
folder and file name to which to save the log
text.

See also. Application panel overview

Results panel

Results panel overview When a test execution is complete, the application automatically opens the
Results panel to display a summary of test results.
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See also. View a report

Application panel overview

View test-related files Files related to tests are stored in My TekExpress\Ethernet\ . Each test setup in
this folder has both a test setup file and a test setup folder, both with the test setup
name.

The test setup file is preceded by the TekExpress icon and usually has no visible
file name extension.

Inside the test setup folder is another folder named for the DUT ID used in the
test sessions. The default is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has
a folder and file pair, both named for the test session using the naming
convention (date)_(time). Each session file is stored outside its matching session
folder:
 

 

Each session folder contains image files of any plots generated from running the
test session. If you selected to save all waveforms or ran tests using prerecorded
waveform files, these are included here.

The first time you run a new, unsaved session, the session files are stored in the
Untitled Session folder located at ..\My TekExpress\Ethernet\. When you name
and save the session, the files are placed in a folder with the name that you
specify. A copy of the test files stay in the Untitled Session folder until you run a
new test or until you close the Ethernet application.

See also. File name extensions
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Plots panel

Plots panel overview The Plots panel displays the result as a two-dimensional plot for additional
measurement analysis. The plots are displayed only for Return Loss
measurements.
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Toolbar functions in plot windows. The Plot Toolbar window includes the
following functions:

Icon Functions
 

 
Save

Saves the plot.

 

 
Select & Zoom

Expands the selected plot area. Left-click and drag the mouse to mark
the region on the plot to zoom.

 

 
Zoom In

Expands part of the plot (Horizontal and Vertical); the data appears in
more detail.

 

 
Zoom Out

Contracts part of the plot (Horizontal and Vertical); the data appears in
less detail.

 

 
Pan

Moves the plot anywhere within the scale.

 

 
Hide Gridlines

Hides the gridlines.

 

 
Reset

Resets the zoom to 100%.

 

 
Choose Waveform
Colors

Sets the plot color. Click and select the color in the Color window and
click OK. Click in the plot area to apply the color.
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Icon Functions
 

 
Show/Hide Markers

Displays or hides the markers

 

 
UnDock/Dock

Click to undock/dock the plot window.

Select Test Select the measurement.

Reports panel

Reports panel overview Use Reports panel to browse for reports, name and save reports, select test
content to include in reports, and select report viewing options.
 

 

For information on setting up reports, see Select report options. For information
on viewing reports, see View a report.
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See also. Application panel overview

Select report options Click Reports panel and use the Reports panel controls to select which test result
information to include in the report, and the naming conventions to use for the
report. For example, always give the report a unique name or select to have the
same name increment each time you run a particular test.

Select report options before running a test or when creating and saving test
setups. Report settings are included in saved test setups.

In the Reports panel, select from the following report options:

Table 19: Report options

Setting Description
Report Update Mode
Generate new report Creates a new report. The report can be in either .mht or .pdf file

formats.
Append with previous run
session

Appends the latest test results to the end of the current test
results report.

Include header in appended
reports

Select to include header in the appended reports.

Replace current test in previous
run session

Replaces the previous test results with the latest test results.
Results from newly added tests are appended to the end of the
report.

Report Creation Settings
Report name Displays the name and location from which to open an Ethernet

report. The default location is at \My TekExpress\Ethernet
\Untitled Session. The report file in this folder gets overwritten
each time you run a test unless you specify a unique name or
select to auto increment the report name.
Change the report name or location.

Do one of the following:

■ In the Report Path field, type over the current folder path and
name.

■ Double-click in the Report Path field and then make
selections from the popup keyboard and click the Enter
button.

Be sure to include the entire folder path, the file name, and the file
extension. For example: C:\Documents and Settings\your user
name\My Documents\My TekExpress\Ethernet\DUT001.mht.

NOTE. You cannot set the file location using the Browse button.

Open an existing report.
Click Browse, locate and select the report file and then click View
at the bottom of the panel.
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Setting Description
Save as type Saves a report in the specified file type, selected from the drop-

down list.

NOTE. If you select a file type different from the default, be sure
to change the report file name extension in the Report Name field
to match.

Auto increment report name if
duplicate

Sets the application to automatically increment the name of the
report file if the application finds a file with the same name as the
one being generated. For example: DUT001, DUT002, DUT003.
This option is enabled by default.

Create report automatically at
the end of the run

Creates report at the end of the run.

Contents To Save
Include pass/fail info in details
table

Includes pass/fail info in the details table of the report.

Include detailed results Includes detailed results in the report.
Include plot images Includes plot images in the report.
Include setup configuration Sets the application to include hardware and software

information in the summary box at the top of the report.
Information includes: the oscilloscope model and serial number,
the oscilloscope firmware version, and software versions for
applications used in the measurements.

Margin value in percentage Select to include the margin value in percentage in the report.
Include user comments Select to include any comments about the test that you or

another user added in the DUT tab of the Setup panel.
Comments appear in the Comments section, under the summary
box at the beginning of each report.

View report after generating Automatically opens the report in a Web browser when the test
completes. This option is selected by default.

View Click to view the most current report.
Generate Report Generates a new report based on the current analysis results.
Save As Specify a name for the report.

Operating basics  

56  TekExpress® Ethernet Electrical Testing Application Help



View a report The application automatically generates a report when test execution is complete
and displays the report in your default Web browser (unless you cleared the View
Report After Generating check box in the Reports panel before running the
test). If you cleared this check box, or to view a different test report, do the
following: 

1. Click the Reports button.

2. Click the Browse button and locate and select the report file to view.

3. In the Reports panel, click View.

For information on changing the file type, file name, and other report options, see 
Select report options.

Report contents A report shows detailed results and plots, as set in the Reports panel.
 

 

Setup configuration information

The summary box at the beginning of the report lists setup configuration
information. This information includes the oscilloscope model and serial number,
optical module model and serial number, and software version numbers of all
associated applications.

To exclude this information from a report, clear the Include Setup
Configuration check box in the Reports panel before running the test.

User comments

If you selected to include comments in the test report, any comments you added
in the DUT tab are shown at the top of the report.
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See also. Results panel overview

View test-related files
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Running tests

1000BASE-T connection diagram
Click Setup > Test Selection > Preview to view the equipment setup diagram(s). 

Figure 29: 1000BASE-T Template, Peak Volt, and Droop (Without Disturber)
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Figure 30: 1000BASE-T Template, Peak Volt, and Droop (With Disturber)
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Figure 31: Distortion with Disturber with Clock
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Figure 32: Distortion with Disturber without Clock
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Figure 33: Distortion without Disturber with Clock
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Figure 34: Distortion without Disturber without Clock
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Figure 35: Master and Slave Jitter without Clock
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Figure 36: Master Filtered with Clock - Connection 1
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Figure 37: Master Filtered with Clock - Connection 2
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Figure 38: Master Unfiltered with Clock
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Figure 39: Slave Filtered with Clock - Connection 1
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Figure 40: Slave Filtered with Clock - Connection 2
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Figure 41: Slave Unfiltered with Clock
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Figure 42: 1000BASE-T CM Voltage
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Figure 43: 1000BASE-T Transmitter Return Loss
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Figure 44: 1000BASE-T Receiver Return Loss
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100BASE-T connection diagram
Click Setup > Test Selection > Preview to view the equipment setup diagram(s).

Figure 45: 100BASE-T connection diagram for all tests except Return Loss

 

 

 

 Running tests

TekExpress® Ethernet Electrical Testing Application Help 75



Figure 46: 100BASE-T Transmitter Return Loss
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Figure 47: 100BASE-T Receiver Return Loss
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10BASE-T connection diagram

Figure 48: 10BASE-T MAU, Jitter, TP_IDL Load With TPM, Link Pulse Timing With TPM, and
Link Pulse Load With TPM
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Figure 49: 10BASE-T TP_IDL Load Without TPM, Jitter, Link Pulse Load Without TPM,
Harmonic, and Link Pulse Timing Without TPM , and Differential Voltage
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Figure 50: 10BASE-T Transmitter Return Loss
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Figure 51: 10BASE-T Receiver Return Loss

Refer Return Loss Calibration steps on page 32
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Prerequisite

Compensate the signal
path

Use the following procedure to compensate the internal signal acquisition path.
Perform this procedure if the ambient temperature has changed more than 5 °C
(9 °F) since you performed the last signal path compensation. Perform the signal
path compensation once a week. Failure to do so may result in the instrument not
meeting warranted performance levels. 

1. Power on and wait for the instrument to complete its warm up period before
continuing with this procedure.

2. Disconnect any probes you have connected to the input channels.

3. Set the instrument to Menu mode.

4. Select Instrument Calibration from the Utilities menu.

5. Note any instructions that appear in the resulting control window.

6. Click Run SPC to begin the procedure. The procedure may take several
minutes to complete.

7. Verify that the Status changes to Pass after the procedure is complete. If the
Calibration Status field indicates anything other than Compensated, see
Signal Path Compensation Status for information on the readout and
recommended action.

NOTE. When making measurements at vertical scale settings less than or equal to
5 mV, you should perform the signal path compensation at least once a week.
Failure to do so may result in the instrument not meeting warranted performance
levels at those volts/div settings.
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Running tests
Select tests, set acquisition parameters, set configuration parameters, set
preferences parameters, and click Start to run the tests. While tests are running,
you cannot access the Setup or Reports panels. To monitor the test progress,
switch between the Status panel and the Results panel. 

While the tests are running, other applications may display windows in the
background. The TekScope application takes precedence over other applications,
but you can switch to other applications by using Alt + Tab key combination. To
keep the TekExpress Ethernet application on top, select Keep On Top from the
TekExpress Options menu.

The application displays report when the tests execution is complete.

Prerun checklist 1. Make sure that the instruments are warmed up (approximately 20 minutes)
and stabilized.

2. Perform compensation: In the oscilloscope main menu, select Utilities >
Instrument Compensation. Click Help in the compensation window for
steps to perform instrument compensation.

View test results
When a test completes, the application switches to the Results panel, which
shows a summary of test results.

Each test result occupies a row in the Results table. By default, results are
displayed in summary format, with the measurement details collapsed. You can
change the view in the following ways:

■ To view the results grouped by lane, test, or data rate, select the
corresponding item from the Preferences menu.

■ To expand all tests listed, select View Results Details from the Preferences
menu.

■ To expand and collapse tests, use the plus and minus buttons to the left of the
test rows.

■ To collapse all expanded tests, select Preferences > View Results
Summary.

■ To enable or disable the wordwrap feature, select Preferences > Enable
Wordwrap.

■ To expand the width of a column, place the cursor over the vertical line that
separates the column from the one to the right. When the cursor changes to a
double-ended arrow, hold down the mouse button and drag the column to the
desired width.
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■ To sort the test information by column, click the column head. When sorted
in ascending order, a small up arrow is displayed. When sorted in descending
order, a small down arrow is displayed.

■
To clear all test results displayed, click Clear ( ).

See Also View a report
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Saving and recalling test setup

Test setup files overview
Saved test setup information (such as the selected oscilloscope, general
parameters, acquisition parameters, measurement limits, waveforms (if
applicable), and other configuration settings) are saved under the setup name at
X:\Ethernet.

Use test setups to:

■ Run a new session, acquiring live waveforms, using a saved test
configuration.

■ Create a new test setup using an existing one.

■ View all the information associated with a saved test, including the log file,
the history of the test status as it executed, and the results summary.

■ Run a saved test using saved waveforms.

See also Save a test setup

Open (load) a saved test setup

Save a test setup
You can save a test setup before or after running a test. You can create a test
setup from already created test setup, or using default test setup. When you
select the default test setup, the parameters are set to the application’s default
value.

Select Options > Save Test Setup to save the opened setup.

Select Options > Save Test Setup As to save the setup with different name.
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Open (load) a saved test setup
To Open (load) a saved test setup, do the following:

1. Select Options > Open Test Setup.

2. Select the setup from the list and click Open. Setup files are located at X:
\Ethernet\.

See also About test setups

Create a test setup using an existing one

Create a test setup from default settings

Create a test setup from default settings
To create a test setup using default settings, follow the steps:

1. Select Options > Default Test Setup. For default test setup, the parameters
are set to the application’s default value.

2. Click application Setup and set the parameters.

3. Click application Reports and set the report options.

4. Optional: Click Start to run the test and verify that it runs correctly and
captures the specified test information and reports. If it does not, then edit the
parameters and repeat this step until the test runs to your satisfaction.

5. Select Options > Save Test Setup. Enter the file name and click Save. The
application saves the file to X:\Ethernet\<session_name>.

Create a test setup using an existing one
To create a test setup using an existing one, follow the steps:

1. Select Options > Open Test Setup.

2. Select a setup from the list and then click Open.

3. Click application Setup and modify the parameters.

4. Click application Reports and modify the report options.

5. Select Options > Save Test Setup As.

6. Enter test setup name, and click Save.
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SCPI Commands

About SCPI command
You can use Standard Commands for Programmable Instruments (SCPI) to
communicate with the TekExpress application.

Socket configuration for SCPI commands
This section describes the steps for TCPIP socket configuration and TekVISA
configuration to execute the SCPI commands.

TCPIP socket
configuration

1. Click Start > Control Panel > System and Security > Windows Firewall >
Advanced settings.
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2. In Windows Firewall with Advanced Security menu, select Windows
Firewall with Advanced Security on Local Computer > Inbound Rules
and click New Rule…
 

 
3. In New Inbound Rule Wizard menu

a. Select Port and click Next.
 

 

SCPI Commands  

88  TekExpress® Ethernet Electrical Testing Application Help



b. Select TCP as rule apply and enter 5000 for Specific local ports and
click Next.
 

 
c. Select Allow the connection and click Next.
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d. Select Domain, Private, Public and click Next.
 

 
e. Enter Name, Description (optional), and click Finish.
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4. Check whether the Rule name is displayed in Windows Firewall with
Advanced Security menu > Inbound Rules.
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TekVISA configuration 1. Click Start > All Programs > TekVISA > OpenChoice Instrument
Manager.
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2. Click Search Criteria. In Search Criteria menu, click LAN to Turn-on.
Select Socket from the drop-down list, enter the IP address of the

TekExpress device in Hostname and type Port as 5000. Click  to
configure the IP address with Port.

Enter the Hostname as 127.0.0.1 if the TekVISA and TekExpress application
are in the same system, else enter the IP address of the TekExpress
application system.
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3. Click Search to setup the TCPIP connection with the host. Check whether
the TCPIP host name is displayed in OpenChoice Instrument Manager >
Instruments.
 

 
4. Double-click OpenChoice Talker Listener and enter the Command *IDN?

in command entry field and click Query. Check that the Operation is
successful and Talker Listener Readout displays the Command / Data.
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TEKEXP:*IDN?
This command queries the active TekExpress application name running on the
oscilloscope. 

Syntax TEKEXP:*IDN?\n

Inputs NA

Outputs Returns active TekExpress application name running on the oscilloscope.

TEKEXP:*OPC?
This command queries the execution status of the last executed command. 

Syntax TEKEXP:*OPC?\n

Inputs NA

Outputs 0 - last command execution is not complete

1 - last command execution is complete
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TEKEXP:ACQUIRE_MODE
This command sets the acquire mode as live or pre-recorded.

Syntax TEKEXP:ACQUIRE_MODE {LIVE | PRE-RECORDED}\n

Inputs {LIVE | PRE-RECORDED}

Outputs NA

TEKEXP:ACQUIRE_MODE?
This command queries the acquire mode type.

Syntax TEKEXP:ACQUIRE_MODE?\n

Inputs NA

Outputs {LIVE | PRE-RECORDED}
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TEKEXP:EXPORT
This command returns all the bytes of data to the specified file. 

Syntax Outputs
TEKEXP:EXPORT REPORT\n Returns the report file in bytes
TEKEXP:EXPORT WFM,"<FileName>"\n Returns the specified waveform file in bytes
TEKEXP:EXPORT IMAGE,"<FileName>"\n Returns the specified image file in bytes

Inputs FileName - Specifies the file name

TEKEXP:INFO?
This command queries the information about the file(s).

Syntax Outputs
TEKEXP:INFO?
REPORT\n

<ReportFileSize>,"<ReportFileName.mht>"

TEKEXP:INFO? WFM
\n

<WfmFile1Size>,"<WfmFileName1.wfm>";<WfmFile2Size>,"<WfmFileNa
me2.wfm>";...

TEKEXP:INFO?
IMAGE\n

<Image1FileSize>,"<Image1FileName>";<Image2FileSize>,"<Image2File
Name>" ;...
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TEKEXP:INSTRUMENT
This command sets the value for the selected instrument type. 

Syntax TEKEXP:INSTRUMENT "<InstrumentType>",<Value>"\n

Inputs InstrumentType

Value

TIP. Check Command parameters list section for InstrumentType and Value
parameters.

Outputs NA

TEKEXP:INSTRUMENT?
This command queries the instrument selected for the specified instrument type. 

Syntax TEKEXP:INSTRUMENT? "<InstrumentType>"\n

Inputs InstrumentType

TIP. Check Command parameters list section for InstrumentType parameters.

Outputs Returns the instrument selected for the specified instrument type
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TEKEXP:LASTERROR?
This command queries the last error string occurred for the current TCP session.
If there are no errors since startup, or since the last call to
TEKEXP:LASTERROR?\n, this command returns an empty string.

Syntax TEKEXP:LASTERROR?\n

Inputs NA

Outputs <string>

TEKEXP:LIST?
This command queries the list of available device, suite, test, version or
instrument. 

Syntax Outputs
TEKEXP:LIST? DEVICE\n Returns the list of available device(s) as comma

separated values.
TEKEXP:LIST? SUITE\n Returns the list of available suite(s) as comma

separated values.
TEKEXP:LIST? TEST\n Returns the list of available test(s) as comma

separated values.
TEKEXP:LIST? VERSION\n Returns the list of available version(s) as comma

separated values.
TEKEXP:LIST?
INSTRUMENT,"<InstrumentType>"\n

Returns the list of available instruments' for the
given Instrument type as comma separated
values.

NOTE. This command returns the list of items within double quotes (""). Iterate
the receive procedure until the list ends with double quotes otherwise the next
query commands won’t work as expected.
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Inputs InstrumentType

TIP. Check Command parameters list section for InstrumentType parameters.

TEKEXP:MODE
This command sets the execution mode as compliance or user defined. 

Syntax TEKEXP:MODE {COMPLIANCE | USER-DEFINED}\n

Inputs {COMPLIANCE | USER-DEFINED}

Outputs NA

TEKEXP:MODE?
This command queries the execution mode type. 

Syntax TEKEXP:MODE?\n

Inputs NA

Outputs {COMPLIANCE | USER-DEFINED}
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TEKEXP:POPUP
This command sets the response to the active popup shown in the application.

Syntax TEKEXP:POPUP “<PopupResponse>”\n

Inputs PopupResponse

Outputs NA

TEKEXP:POPUP?
This command queries the active popup information shown in the application.

Syntax TEKEXP:POPUP?\n

Inputs NA

Outputs Returns the active popup information in the application.
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TEKEXP:REPORT
This command generates the report for the current session. 

Syntax TEKEXP:REPORT GENERATE\n

Inputs GENERATE

Outputs NA

TEKEXP:REPORT?
This command queries the queried header field value in the report.

Syntax TEKEXP:REPORT? “<HeaderField>”\n

Inputs HeaderField - Specifies to return the measured value for the indicated test.

TIP. Check Report for HeaderField parameters.

Outputs Returns the queried header field value in the report
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TEKEXP:RESULT?
This command queries the result available in report summary/details table.

Syntax Outputs
TEKEXP:RESULT? "<TestName>"\n Return Pass/Fail status of the test.
TEKEXP:RESULT?
"<TestName>","<ColumnName>"\n

Returns all the row values of the specified
column for the test.

TEKEXP:RESULT?
"<TestName>","<ColumnName>",<RowNumber
>\n

Returns the column value for the specified row
number  1

Inputs TestName - Specifies the name of the test for which to obtain the test result
value.

ColumnName - Specifies the column name for the measurement

RowNumber - Specifies the row number of the measurement

TIP. Check Results panel for TestName, ColumnName, and RowNumber
parameters.

1 Row number starts from zero.
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TEKEXP:SELECT
This command selects the device, suite, version, or test. 

Syntax TEKEXP:SELECT <string1>,<string2>,<string4>\n

TEKEXP:SELECT TEST,<string3>,<string4>\n

Inputs <string1> = {DEVICE | SUITE | VERSION}

<string2> = {DeviceName | SuiteName | VersionName}

<string3> = {“<TestName>"| ALL| REQUIRED }

<string4> = {TRUE | FALSE}

TIP. Check Command parameters list section for DeviceName, SuiteName,
VersionName, and TestName parameters.

Outputs NA

TEKEXP:SELECT?
This command queries the name of the selected device, suite, version, or test. 

Syntax TEKEXP:SELECT? {DEVICE | SUITE | TEST | VERSION}\n

Inputs {DEVICE | SUITE | TEST | VERSION}
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Outputs Returns the name of the selected device, suite, version, or test.

TEKEXP:SETUP
This command sets the value of the current setup.

Syntax Outputs
TEKEXP:SETUP DEFAULT\n Restore to default Setup
TEKEXP:SETUP OPEN,"<SessionName>"\n Open the session
TEKEXP:SETUP SAVE\n Saves the already existing modified session
TEKEXP:SETUP SAVE,"<SessionName>"\n Save the session

Inputs SessionName - The name of the session

TEKEXP:STATE
This command sets the execution state of the application.

Syntax TEKEXP:STATE {RUN | STOP | PAUSE | RESUME}\n

Inputs {RUN | STOP | PAUSE | RESUME}

Outputs NA
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TEKEXP:STATE?
This command queries the current setup state. 

Syntax Outputs
TEKEXP:STATE? RUNNING | PAUSED | WAIT | ERROR | READY
TEKEXP:STATE? SETUP SAVED | NOT_SAVED

TEKEXP:VALUE
This command sets the value of parameters of type General, Acquire, Analyze, or
DUTID. 

Syntax TEKEXP:VALUE GENERAL,"<ParameterName>",“<Value>”\n

TEKEXP:VALUE ACQUIRE,“<TestName>","<AcquireType>",
"<ParameterName>",“<Value>”\n

TEKEXP:VALUE ANALYZE,“<TestName>","<ParameterName>".“<Value>”
\n

TEKEXP:VALUE DUTID,“<Value>”\n

TEKEXP:VALUE VERBOSE,{TRUE | FALSE}\n

TEKEXP:VALUE
WFMFILE,<Test_Name>,<Aquire_Type>,<FilesName1$FileName2>\n

Inputs ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

Value - Specifes the value to set

FilesName1$FileName2 - Specifies the waveform file name

TRUE - Pop-ups are enabled

FALSE - Pop-ups are disabled

TIP. Check Command parameters list section for ParameterName, AcquireType,
and Value parameters.
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Outputs NA

TEKEXP:VALUE?
This command queries the value of the parameter for type General, Acquire,
Analyze, or DUTID.

Syntax Outputs
TEKEXP:VALUE?
GENERAL,"<ParameterName>"\n

Returns the value of Parameter for type
GENERAL

TEKEXP:VALUE? ACQUIRE,“<TestName>",
"<AcquireType>","<ParameterName>"\n

Returns the value of Parameter for type
ACQUIRE

TEKEXP:VALUE? ANALYZE,
“<TestName>","<ParameterName>"\n

Returns the value of Parameter for type
ANALYZE

TEKEXP:VALUE? DUTID\n Returns the DUTID value
TEKEXP:VALUE?
WFMFILE,<Test_Name>,<Aquire_Type>\n

Returns the waveform file name

TEKEXP:VALUE? VERBOSE Returns the verbose mode type

Inputs ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

TRUE - Pop-ups are enabled

FALSE - Pop-ups are disabled

TIP. Check Command parameters list section for ParameterName and
AcquireType parameters.

Outputs Returns the value of Parameter for type GENERAL | ACQUIRE | ANALYZE |
DUTID.
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Command parameters
This section provides the parameters list for the SCPI commands.

Table 20: ParameterName and Value for DUT tab

Parameters Description
DUT ID Specifies the value parameters

For DUTID, valid value is: Comment
Acquiremode Specifies the acquire mode parameters

■ Acquire live waveforms

■ Use pre-recorded waveform files

Suite ■ 1000BASE-T

■ 100BASE-T

■ 10BASE-T
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Table 21: ParameterName and Value for Test Selection tab

Parameters Description
Test Measurements for 1000BASE-T Specifies the test measurement name.

Without Disturber

■ TemplateA_Without_Disturber

■ TemplateB_Without_Disturber

■ TemplateC_Without_Disturber

■ TemplateD_Without_Disturber

■ TemplateF_Without_Disturber

■ TemplateH_Without_Disturber

■ PeakvoltageA_Without_Disturber

■ PeakvoltageB_Without_Disturber

■ PeakvoltageC_Without_Disturber

■ PeakvoltageD_Without_Disturber

■ DroopG_Without_Disturber

■ DroopJ_Without_Disturber

■ Transmitter Distrortion

■ Distortion_Without_Disturber_With_TX_TCLK

■ Distortion_Without_Disturber_Without_TX_TCLK

With Disturber

■ TemplateA_With_Disturber

■ TemplateB_With_Disturber

■ TemplateC_With_Disturber

■ TemplateD_With_Disturber

■ TemplateF_With_Disturber

■ TemplateH_With_Disturber

■ PeakvoltageA_With_Disturber

■ PeakvoltageB_With_Disturber

■ PeakvoltageC_With_Disturber

■ PeakvoltageD_With_Disturber

■ DroopG_With_Disturber

■ DroopJ_With_Disturber

■ Transmitter Distrortion

■ Distortion_With_Disturber_With_TX_TCLK
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Parameters Description

■ Distortion_With_Disturber_Without_TX_TCLK

Transmitter Jitter

■ MasterFiltered_Jitter_Without_TX_TCLK

■ MasterUnfiltered_Jitter_Without_TX_TCLK

■ SlaveFiltered_Jitter_Without_TX_TCLK

■ SlaveUnfiltered_Jitter_Without_TX_TCLK

■ MasterFiltered_Jitter_With_TX_TCLK

■ MasterUnfiltered_Jitter_With_TX_TCLK_TCLK

■ SlaveFiltered_Jitter_With_TX_TCLK

■ SlaveUnfiltered_Jitter_With_TX_TCLK

ReturnLoss_Transmitter
CM Voltage

Test Measurements for 100BASE-T Specifies the test measurement name.

■ AOI_Template

■ Fall_Time_Pos

■ Fall_Time_Neg

■ Rise_Time_Pos

■ Rise_Time_Neg

■ RF_Symmetry_Pos

■ RF_Symmetry_Neg

■ Overshoot_Pos

■ Overshoot_Neg

■ Differential_Output_Voltage_Pos

■ Differential_Output_Voltage_Neg

■ Amplitude_Symmetry

■ Jitter

■ Duty Cycle Distortion

■ ReturnLoss_Transmitter

■ ReturnLoss_Receiver
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Parameters Description
Test Measurements for 10BASE-T Specifies the test measurement name.

■ Link Pulse

■ Link Pulse Load1 With Twisted Pair cable

■ Link Pulse Load2 With Twisted Pair cable

■ Link Pulse Load3 With Twisted Pair cable

■ Link Pulse Load1 Without Twisted Pair cable

■ Link Pulse Load2 Without Twisted Pair cable

■ Link Pulse Load3 Without Twisted Pair cable

■ Link Pulse Timing

■ Link Pulse Timing Load1 With Twisted Pair cable

■ Link Pulse Timing Load2 With Twisted Pair cable

■ Link Pulse Timing Load3 With Twisted Pair cable

■ Link Pulse Timing Load1 Without Twisted Pair cable

■ Link Pulse Timing Load2 Without Twisted Pair cable

■ Link Pulse Timing Load3 Without Twisted Pair cable

■ Differential Voltage

■ TP_IDL

■ TP_IDL Load1 With Twisted Pair cable

■ TP_IDL Load2 With Twisted Pair cable

■ TP_IDL Load3 With Twisted Pair cable

■ TP_IDL Load1 Without Twisted Pair cable

■ TP_IDL Load2 Without Twisted Pair cable

■ TP_IDL Load3 Without Twisted Pair cable

■ Jitter

■ Jitter Normal With Twisted Pair cable

■ Jitter 8.0 With Twisted Pair cable

■ Jitter 8.5 With Twisted Pair cable

■ Jitter Normal Without Twisted Pair cable

■ Jitter 8.0 Without Twisted Pair cable

■ Jitter 8.5 Without Twisted Pair cable

■ MAU Internal

■ MAU External

■ MAU Internal Inverted

■ MAU External Inverted

■ Harmonic
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Parameters Description

■ Transmitter Return Loss

■ Receiver Return Loss

■ CM Voltage

Table 22: ParameterName and Value for Acquisitions

ParameterName Value
Source 1 Specifies the test mode source channel for each listed signal. Valid

values are CH1 to CH4.
Source 2 Specifies the test mode source channel for each listed signal. Valid

values are CH1 to CH4.
Source 3 Specifies the test mode source channel for each listed signal. Valid

values are CH1 to CH4.
Aux TRUE or FALSE
Show Acquire Parameters TRUE or FALSE

Table 23: ParameterName and Value for Preferences tab

Parameters Description
Number of Runs 1 to 250 
Acquire /Analyze each test TRUE or FALSE
Action on Test measurement Failure ON or OFF
Popup Settings ■ Auto Close Warnings and Informations during Sequencing.

Auto Close after (1 to 60 ) seconds

■ Auto Close Error Message during Sequencing Show in
Reports. Auto Close after (1 to 60 ) seconds

Table 24: ParameterName and Value for Acquire (1000BASE-T)

Test Name Acquire Type Parameter Name Values
TemplateA_Without_Disturber
TemplateB_Without_Disturber
TemplateC_Without_Disturber
TemplateD_Without_Disturber
TemplateF_Without_Disturber
TemplateH_Without_Disturber
TemplateA_With_Disturber
TemplateB_With_Disturber
TemplateC_With_Disturber
TemplateD_With_Disturber
TemplateF_With_Disturber
TemplateH_With_Disturber

TemplateA_Without_Disturber
TemplateB_Without_Disturber
TemplateC_Without_Disturber
TemplateD_Without_Disturber
TemplateF_Without_Disturber
TemplateH_Without_Disturber
TemplateA_With_Disturber
TemplateB_With_Disturber
TemplateC_With_Disturber
TemplateD_With_Disturber
TemplateF_With_Disturber
TemplateH_With_Disturber

AcquisitionAverage 16 to 256 
TriggerLevel (A) -5 V to 5 V
TriggerLevel (B) -5 V to 5 V

SCPI Commands  

112  TekExpress® Ethernet Electrical Testing Application Help



Test Name Acquire Type Parameter Name Values
PeakVoltageA_Without_Disturber
PeakVoltageB_Without_Disturber
PeakVoltageC_Without_Disturber
PeakVoltageD_Without_Disturber
DroopG_Without_Disturber
DroopJ_Without_Disturber
PeakVoltageA_With_Disturber
PeakVoltageB_With_Disturber
PeakVoltageC_With_Disturber
PeakVoltageD_With_Disturber
DroopG_With_Disturber
DroopJ_With_Disturber
Distortion_Without_Disturber_With_TX_TCL
K
Distortion_With_Disturber_Without_TX_TCL
K

PeakVoltageA_Without_Disturber
PeakVoltageB_Without_Disturber
PeakVoltageC_Without_Disturber
PeakVoltageD_Without_Disturber
DroopG_Without_Disturber
DroopJ_Without_Disturber
PeakVoltageA_With_Disturber
PeakVoltageB_With_Disturber
PeakVoltageC_With_Disturber
PeakVoltageD_With_Disturber
DroopG_With_Disturber
DroopJ_With_Disturber
Distortion_Without_Disturber_With_TX_TCL
K
Distortion_With_Disturber_Without_TX_TCL
K

Acquisition Average 16 to 256 

MasterFilter_Jitter_Without_TX_TCLK
MasterUnfilter_Jitter_Without_TX_TCLK
SlaveFilter_Jitter_Without_TX_TCLK
SlaveUnfilter_Jitter_Without_TX_TCLK
MasterFilter_Jitter_With_TX_TCLK
MasterUnfilter_Jitter_With_TX_TCLK
SlaveFilter_Jitter_With_TX_TCLK
SlaveUnfilter_Jitter_With_TX_TCLK

MasterFilter_Jitter_Without_TX_TCLK
MasterUnfilter_Jitter_Without_TX_TCLK
SlaveFilter_Jitter_Without_TX_TCLK
SlaveUnfilter_Jitter_Without_TX_TCLK
MasterFilter_Jitter_With_TX_TCLK
MasterUnfilter_Jitter_With_TX_TCLK
SlaveFilter_Jitter_With_TX_TCLK
SlaveUnfilter_Jitter_With_TX_TCLK

Measurement
Duration

1 ms, 10 ms, 100 ms,
1000 ms

Number Of Clock
Edges

100000, 1000000,
10000000 

Transmitter Return Loss ReturnLoss_Transmitter Acquisition Average 100 to 10000 
CM Voltage CM Voltage

Table 25: ParameterName and Value for Acquire (100BASE-T)

Test Name Acquire Type Parameter Name Values
AOI_Template AOI_Template Number of samples 5000 to 2147400000 
Fall_Time_Pos
Fall_Time_Neg
Rise_Time_Pos
Rise_Time_Neg
RF_Symmetry_Pos
RF Symmetry_Neg
Overshoot_Pos
Overshoot_Neg
Differential_Output Voltage_Pos
Difftrerential_Output_Voltage_Neg
Amplitude_Symmetry

Fall_Time_Pos
Fall_Time_Neg
Rise_Time_Pos
Rise_Time_Neg
RF_Symmetry_Pos
RF Symmetry_Neg
Overshoot_Pos
Overshoot_Neg
Differential_Output Voltage_Pos
Difftrerential_Output_Voltage_Neg
Amplitude_Symmetry

Acquisition Type Sample, Average
Number of
Waveforms

2 to 10000 

Duty Cycle Distortion Duty Cycle Distortion Acquisition Type Sample, Average
Transmitter Return Loss ReturnLoss_Transmitter Acquisition Average 100 to 10000 
Receiver Return Loss ReturnLoss_Receiver
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Table 26: ParameterName and Value for Acquire (10BASE-T)

Test Name Acquire Type Parameter Name Values
Link Pulse Timing Load1 With Twisted
Pair cable
Link Pulse Timing Load2 With Twisted
Pair cable
Link Pulse Timing Load3 With Twisted
Pair cable
Link Pulse Timing Load1 Without
Twisted Pair cable
Link Pulse Timing Load2 Without
Twisted Pair cable
Link Pulse Timing Load3 Without
Twisted Pair cable

Link Pulse Load1 With Twisted Pair
cable
Link Pulse Load2 With Twisted Pair
cable
Link Pulse Load3 With Twisted Pair
cable
Link Pulse Load1 Without Twisted Pair
cable
Link Pulse Load2 Without Twisted Pair
cable
Link Pulse Load3 Without Twisted Pair
cable

Number of Acquisitions
Number of Waveforms

2 to 10000 
1 to 10000 

Differential Voltage Differential Voltage Acquisition Average 2 to 1000 
Acquisition Delay 1 to 10000 (Micro-

seconds)
Acquisition Type ■ Sample

■ Average

TP_IDL Load1 With Twisted Pair cable
TP_IDL Load2 With Twisted Pair cable
TP_IDL Load3 With Twisted Pair cable
TP_IDL Load1 Without Twisted Pair
cable
TP_IDL Load2 Without Twisted Pair
cable
TP_IDL Load3 Without Twisted Pair
cable

TP_IDL Load1 With Twisted Pair cable
TP_IDL Load2 With Twisted Pair cable
TP_IDL Load3 With Twisted Pair cable
TP_IDL Load1 Without Twisted Pair
cable
TP_IDL Load2 Without Twisted Pair
cable
TP_IDL Load3 Without Twisted Pair
cable

Number of Acquisitions
Number of Waveforms

2 to 10000 
1 to 10000 

Jitter Normal With Twisted Pair Cable
Jitter 8.0 With Twisted Pair Cable
Jitter 8.5 With Twisted Pair Cable
Jitter Normal Without Twisted Pair
Cable
Jitter 8.0 Without Twisted Pair Cable
Jitter 8.5 Without Twisted Pair Cable

Jitter Normal With Twisted Pair Cable
Jitter 8.0 With Twisted Pair Cable
Jitter 8.5 With Twisted Pair Cable
Jitter Normal Without Twisted Pair
Cable
Jitter 8.0 Without Twisted Pair Cable
Jitter 8.5 Without Twisted Pair Cable

Number of Acquisitions 2 to 10000 

MAU Internal
MAU External
MAU Internal Inverted
MAU External Inverted

MAU Internal
MAU External
MAU Internal Inverted
MAU External Inverted

1000 to 10000 

Harmonic Harmonic Acquisition Delay 1 to 10000 (Micro-
seconds)

Math Average 2 to 10000 
Transmitter Return Loss
Receiver Return Loss

Transmitter Return Loss Acquisition Average 100 to 10000 
Receiver Return Loss

CM Voltage CM Voltage
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Table 27: ParameterName and Value for Analyze (1000BASE-T)

Test Name Acquisition Type Parameter Name Values
TemplateA_Without_Disturber
TemplateB_Without_Disturber
TemplateC_Without_Disturber
TemplateD_Without_Disturber
TemplateF_Without_Disturber
TemplateH_Without_Disturber
TemplateA_With_Disturber
TemplateB_With_Disturber
TemplateC_With_Disturber
TemplateD_With_Disturber
TemplateF_With_Disturber
TemplateH_With_Disturber
PeakVoltageA_Without_Disturber
PeakVoltageB_Without_Disturber
PeakVoltageC_Without_Disturber
PeakVoltageD_Without_Disturber
PeakVoltageA_With_Disturber
PeakVoltageB_With_Disturber
PeakVoltageC_With_Disturber
PeakVoltageD_With_Disturber

TemplateA_Without_Disturber
TemplateB_Without_Disturber
TemplateC_Without_Disturber
TemplateD_Without_Disturber
TemplateF_Without_Disturber
TemplateH_Without_Disturber
TemplateA_With_Disturber
TemplateB_With_Disturber
TemplateC_With_Disturber
TemplateD_With_Disturber
TemplateF_With_Disturber
TemplateH_With_Disturber
PeakVoltageA_Without_Disturber
PeakVoltageB_Without_Disturber
PeakVoltageC_Without_Disturber
PeakVoltageD_Without_Disturber
PeakVoltageA_With_Disturber
PeakVoltageB_With_Disturber
PeakVoltageC_With_Disturber
PeakVoltageD_With_Disturber

External Filter ■ Include

■ Exclude

Distortion_Without_Disturber_Without_TX_T
CLK
Distortion_With_Disturber_Without_TX_TCL
K

Distortion_Without_Disturber_Without_TX_T
CLK
Distortion_With_Disturber_Without_TX_TCL
K

LP Filter ■ Include

■ Exclude

Hi Resolution 16 to 64 

MasterFilter_Jitter_Without_TX_TCLK
MasterUnfilter_Jitter_Without_TX_TCLK
SlaveFilter_Jitter_Without_TX_TCLK
SlaveUnfilter_Jitter_Without_TX_TCLK
MasterFilter_Jitter_With_TX_TCLK
MasterUnfilter_Jitter_With_TX_TCLK
SlaveFilter_Jitter_With_TX_TCLK
SlaveUnfilter_Jitter_With_TX_TCLK

MasterFilter_Jitter_Without_TX_TCLK
MasterUnfilter_Jitter_Without_TX_TCLK
SlaveFilter_Jitter_Without_TX_TCLK
SlaveUnfilter_Jitter_Without_TX_TCLK
MasterFilter_Jitter_With_TX_TCLK
MasterUnfilter_Jitter_With_TX_TCLK
SlaveFilter_Jitter_With_TX_TCLK
SlaveUnfilter_Jitter_With_TX_TCLK

Clock Edge ■ RISE

■ FALL

Hysteresis 0% to 10%

Transmitter Return Loss ReturnLoss_Transmitter Smoothing Averages 1 to 10 
Load (Ohm) ■ 85, 100, 115 

■ 100 

CM Voltage CM Voltage Filter Type ■ None

■ 1 MHZ (High
Pass)

■ 100 MHZ (Low
Pass)

■ 1-100 MHZ
(Base band)
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Table 28: ParameterName and Value for Analyze (100BASE-T)

Test Name Acquisition Type Parameter Name Values
Transmitter Return Loss
Receiver Return Loss

Transmitter Return Loss
Receiver Return Loss

Smoothing Averages 1 to 10 
Load(Ohm) ■ 85, 100, 115 

■ 100 

AOI_Template AOI_Template Fail Threshold 1 to 5000 
Jitter Pos
Jitter Neg

Jitter Pos
Jitter Neg

Measurement Type ■ Tie

■ Histogram
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Table 29: ParameterName and Value for Analyze (10BASE-T)

Test Name Acquire Type Parameter Name Values
Link Pulse Load1 With Twisted
Pair cable
Link Pulse Load2 With Twisted
Pair cable
Link Pulse Load3 With Twisted
Pair cable
Link Pulse Load1 Without
Twisted Pair cable
Link Pulse Load2 Without
Twisted Pair cable
Link Pulse Load3 Without
Twisted Pair cable
TP_IDL Load1 With Twisted Pair
cable
TP_IDL Load2 With Twisted Pair
cable
TP_IDL Load3 With Twisted Pair
cable
TP_IDL Load1 Without Twisted
Pair cable
TP_IDL Load2 Without Twisted
Pair cable
TP_IDL Load3 Without Twisted
Pair cable
MAU Internal
MAU External
MAU Internal Inverted
MAU External Inverted

Link Pulse Load1 With Twisted
Pair cable
Link Pulse Load2 With Twisted
Pair cable
Link Pulse Load3 With Twisted
Pair cable
Link Pulse Load1 Without
Twisted Pair cable
Link Pulse Load2 Without
Twisted Pair cable
Link Pulse Load3 Without
Twisted Pair cable
TP_IDL Load1 With Twisted Pair
cable
TP_IDL Load2 With Twisted Pair
cable
TP_IDL Load3 With Twisted Pair
cable
TP_IDL Load1 Without Twisted
Pair cable
TP_IDL Load2 Without Twisted
Pair cable
TP_IDL Load3 Without Twisted
Pair cable
MAU Internal
MAU External
MAU Internal Inverted
MAU External Inverted

Fail Threshold 1 to 5000 

Link Pulse Timing Load1 With
Twisted Pair cable
Link Pulse Timing Load2 With
Twisted Pair cable
Link Pulse Timing Load3 With
Twisted Pair cable
Link Pulse Timing Load1 Without
Twisted Pair cable
Link Pulse Timing Load2 Without
Twisted Pair cable
Link Pulse Timing Load3 Without
Twisted Pair cable

Link Pulse Timing Load1 With
Twisted Pair cable
Link Pulse Timing Load2 With
Twisted Pair cable
Link Pulse Timing Load3 With
Twisted Pair cable
Link Pulse Timing Load1 Without
Twisted Pair cable
Link Pulse Timing Load2 Without
Twisted Pair cable
Link Pulse Timing Load3 Without
Twisted Pair cable

Jitter Normal with Twisted Pair
cable
Jitter 8.0 with Twisted Pair cable
Jitter 8.5 with Twisted Pair cable
Jitter Normal without Twisted Pair
cable
Jitter 8.0 without Twisted Pair
cable
Jitter 8.5 without Twisted Pair
cable

Jitter Normal with Twisted Pair
cable
Jitter 8.0 with Twisted Pair cable
Jitter 8.5 with Twisted Pair cable
Jitter Normal without Twisted Pair
cable
Jitter 8.0 without Twisted Pair
cable
Jitter 8.5 without Twisted Pair
cable

MAU Type ■ Internal

■ External
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Test Name Acquire Type Parameter Name Values
Differential Voltage Differential Voltage Peak ■ Min

■ MinMax

Transmitter Return Loss
Receiver Return Loss

Transmitter Return Loss
Receiver Return Loss

Smoothing Average
Load (Ohm)

1 to 10 

■ 85, 100, 111 

■ 100 

ParameterName and Value for General, Acquire and Analyze: Specifies the
ParameterName and Value for General, Acquire, and Analyze.

Table 30: ParameterName and Value for General

ParameterName Value
Report Update Mode ■ New

■ Append

■ Replace

■ in previous run, current session

■ in any run, any session

Report name X:\Ethernet\Reports\DUT001.mht
Auto increment report name if duplicate ■ Included

■ Excluded

Create report automatically at the end of the run ■ Included

■ Excluded

Include pass/fail results Summary ■ Included

■ Excluded

Include detailed results ■ Included

■ Excluded

Include plot images ■ Included

■ Excluded

Include setup configuration ■ Included

■ Excluded

Include complete configuration ■ Included

■ Excluded
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ParameterName Value
Include user comments ■ Included

■ Excluded

View report after generating ■ Included

■ Excluded

Save As type ■ Web Archive (*.mht;*.mhtml)

■ PDF (*.pdf)

■ CSV (*.csv;)

Examples
This section provides the examples for the SCPI commands.

Example Description
TEKEXP:*IDN? It returns the active TekExpress application name running on the

scope.
TEKEXP:*OPC? It returns the last command execution status.
TEKEXP:ACQUIRE_MODE PRE-RECORDED It sets the acquire mode as pre-recorded.
TEKEXP:ACQUIRE_MODE? It returns LIVE when acquire mode is set to live.
TEKEXP:EXPORT REPORT It returns the report file in bytes. This can be written into another file

for further analysis.
TEKEXP:INFO? REPORT It returns "100,"ReportFileName.mht"", when 100 is the filesize in

bytes for the filename ReportFileName.
TEKEXP:INFO? WFM It returns "100,"WfmFileName1.wfm"";"200,"WfmFileName2.wfm""

when 100 is the filesize in bytes for the filename
WfmFileName1.wfm and 200 is the filesize in bytes for the filename
WfmFileName2.wfm.

TEKEXP:INSTRUMENT "Real Time Scope",MSO58
(GPIB8::1::INSTR)

It sets the instrument value as MSO58 ( GPIB8::1::INSTR ) for the
selected instrument type Real Time Scope.

TEKEXP:INSTRUMENT? "Real Time Scope" It returns "MSO58 ( GPIB8::1::INSTR ), when MSO58
( GPIB8::1::INSTR )" is the selected instrument for the instrument
type Real Time Scope.

TEKEXP:LASTERROR? It returns ERROR: INSTRUMENT_NOT_FOUND, when no
instrument is found.

TEKEXP:LIST? DEVICE It returns "Ethernet Tx" when Ethernet Tx application is the available
device.

TEKEXP:LIST? INSTRUMENT,"Real Time Scope" It returns "MSO58 ( GPIB8::1::INSTR ),MSO64 ( TCPIP::
134.64.248.91::INSTR )" when MSO58 ( GPIB8::1::INSTR ), MSO64
( TCPIP::134.64.248.91::INSTR ) are the list of available
instruments.
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Example Description
TEKEXP:MODE COMPLIANCE It sets the execution mode as compliance.
TEKEXP:MODE? It returns COMPLIANCE when the execution mode is compliance.
TEKEXP:POPUP "OK" It sets OK as the response to active popup in the application.
TEKEXP:POPUP? It returns "OK", when OK is the active popup information shown in

the application.
TEKEXP:REPORT GENERATE It generates report for the current session.
TEKEXP:REPORT? "Scope Model" It returns "MSO58" when MSO58 is the scope model.
TEKEXP:REPORT? "DUT ID" It returns "DUT001" when DNI_DUT001 is the DUT ID.
TEKEXP:RESULT? "PeakVoltageD_Without_Disturber" It returns Pass, then the test result is Pass.
TEKEXP:RESULT? "PeakVoltageD_Without_Disturber", "Margin" It returns list of values then that is 'Margin' column data.
TEKEXP:RESULT? "PeakVoltageD_Without_Disturber", "Units",0 It returns the unit of the first row of result.
TEKEXP:SELECT DEVICE,"TekExpress Ethernet" It selects device "TekExpress Ethernet".
TEKEXP:SELECT TEST,"TemplateA_Without_Disturber", TRUE It selects "TemplateA_Without_Disturber" measurement.
TEKEXP:SETUP DEFAULT It restores the application to default setup.
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References

1000BASE-T

1000BASE-T template This measurement verifies that the transmitter output fits the time domains
transmit templates.

Reference:

Subclause 40.6.1.2.3 of IEEE standard 802.3-2015 

Description

According to standard, the Test Mode 1 signal from the DUT needs to be
normalized. This should be compared to the differential output templates shown
in Figure 40-26 of the standard. The normalization factors to be applied to
various points:

For Point A: Normalization with the peak voltage at point A.

For Point B: Normalization with the negative of peak voltage at point A.

For Point C: Normalization with 0.5 times the peak voltage at point A.

For Point D: Normalization with the negative of 0.5 times the peak voltage at
point A.

For Point F and H: The waveform around points F and H are compared to time
domain transmit template 2 after the following normalization factors are applied:

Normalization with the peak voltage at point F.

Normalization with the peak voltage at point H.

According to standard, the waveform can be shifted in time to fit the template.
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1000BASE-T peak voltage This measurement verifies the transmitter output levels.

Reference:

Subclause 40.6.1.2.1 of IEEE standard 802.3-2015 

Description

According to standard, magnitude of peak differential output voltage measure at
points A and B should be between 670 and 820 mV. Also, these conditions
should be met:

 

 
 

 

1000BASE-T droop This measurement verifies that the transmitter output level does not decay faster
than the maximum specified rate.

Reference:

Subclause 40.6.1.2.2 of IEEE standard 802.3-2015 

Description

According to standard, the Point G and J are exactly 500 ns from Points F and H
respectively. The magnitude of voltage at Point G should be greater than 73.1%
magnitude of voltage at Point F and magnitude of voltage at Point J should be
greater than 73.1% magnitude of voltage at Point H.

References  
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1000BASE-T jitter (with
TX_TCLK)

This measurement verifies that the transmitter output level does not reduce faster
than the maximum specified rate.

Reference:

Subclause 40.6.1.2.5 of IEEE standard 802.3-2015 

Description

Jitter Master Unfiltered — According to the standard, the peak-to-peak value of
jitter waveform on MASTER TX_TCLK relative to unfiltered reference should
be less than 1.4 ns.

Jitter Master Filtered — According to the standard, the peak-to-peak value of
jitter waveform on MASTER TX_TCLK when filtered by a high pass filter,

with the transfer function below + JTx out of Data related to the corresponding
edge of MASTER TX_TCLK should be less than 0.3 ns.
 

 

Jitter Slave Unfiltered — According to the standard, the peak-to-peak value of
jitter waveform on SLAVE TX_TCLK relative to unfiltered reference should be
less than 1.4 ns.

Jitter Slave Filtered —According to the standard, the peak-to-peak value of jitter
waveform on SLAVE TX_TCLK when filtered by a high pass filter, Hjf2(f) with
the transfer function below + JTx out of data related to the corresponding edge of
SLAVE TX_TCLK should be less than 0.4 ns + peak-to-peak value of jitter
waveform on MASTER TX_TCLK when filtered by a high pass filter, Hjf1(f).
 

 

NOTE. J denotes the square root of -1.

 References
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1000BASE-T jitter (without
TX_TCLK)

To provide an analysis of the Transmitter Timing Jitter test method defined in
Clause 40.6.1.2.5 of IEEE 802.3-2002, and to propose an alternative method that
may be used in cases where a device does not provide access to the TX_TCLK
signal.

Reference:

1. IEEE standard 802.3-2015, subclause 40.6.1.1.1 – Test channel

2. Ibid., subclause 40.6.1.1.2, figure 40-20 – Test modes

3. Ibid., subclause 40.6.1.1.3, figure 40-25 – Test fixtures

4. Ibid., subclause 40.6.1.2.5 – Transmitter Timing Jitter

5. Test suite appendix 40.6.A – 1000BASE-T transmitter test fixtures

NOTE. The references mentioned here are proposed, and not part of a standard.
This is an alternate test method for jitter measurement being proposed, when
TX_TCLK is not accessible. This is an informal test method.

Transmitting Timing Jitter (Alternate Method):

Jitter Master Unfiltered — The peak-to-peak value of jitter waveform on data in
Test Mode 2 relative to unjittered reference should be less than 1.4 ns (pass).

The peak-to-peak value of jitter waveform on data in Test Mode 2 relative to
unjittered reference should be more than 1.4 ns (inconclusive).

Jitter Master Filtered — The peak-to-peak value of jitter waveform on data in
Test Mode 2 relative to unjittered reference, when filtered by a high pass filter,
Hjf1(f) with the transfer function below should be less than 0.3 ns (pass).

The peak-to-peak value of jitter waveform on data in Test Mode 2 relative to
unjittered reference, when filtered by a high pass filter, Hjf1(f)with the transfer
function below should be more than 0.3 ns (inconclusive).
 

 

Jitter Slave Unfiltered — The difference between the peak-to-peak value of jitter
waveform on data in Test Mode 3 relative to unjittered reference and the peak-to-
peak value of jitter waveform on data in Test Mode 2 relative to unjittered
reference should be less than 1.4 ns (pass).

The difference between the peak-to-peak value of jitter waveform on data in Test
Mode 3 relative to unjittered reference and the peak-to-peak value of jitter
waveform on data in Test Mode 2 relative to unjittered reference should be more
than 1.4 ns (fail).
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Jitter Slave Filtered — The difference between the peak-to-peak value of jitter
waveform on data in Test Mode 3 relative to unjittered reference, when filtered
by a high pass filter,

Hjf1(f) with the transfer function below, and the peak-to-peak value of jitter
waveform on data in Test Mode 2 relative to unjittered reference, when filtered
by a high pass filter,

Hjf1(f) with the transfer function below, should be less than 0.4 ns (pass).

The difference between the peak-to-peak value of jitter waveform on data in Test
Mode 3 relative to unjittered reference, when filtered by a high pass filter,

Hjf1(f) with the transfer function below, and the peak-to-peak value of jitter
waveform on data in Test Mode 2 relative to unjittered reference, when filtered
by a high pass filter,

Hjf1(f) with the transfer function below, should be more than 0.4 ns (fail).
 

 
 

 

1000BASE-T distortion This measurement verifies that the peak transmitter distortion of the DUT is less
than 10 mV for at least 60% of the UI within the eye-opening.

Reference:

IEEE standard 802.3-2015, sub clause 40.6.1.2.4 

PMA Test suite, version 2.5, Test 40.1.6 

Description

The peak distortion of the Test Mode 4 differential signal, when sampled with the
symbol rate TX_TCLK at an arbitrary phase and processing this block of any
2047 consecutive samples, should be less than 10 mV.

 References

TekExpress® Ethernet Electrical Testing Application Help 125



1000BASE-T return loss This measurement verifies that the Return Loss of the Device Under Test (DUT)
is above the conformance limit.

Reference:

Subclause 40.8.3.1 of IEEE standard 802.3-2015 

Description

At least 16 dB over the frequency range of 1.0 MHz to 40 MHz and at least
10 -20log 10 (f /80) dB over the frequency range 40 MHz to 100 MHz (f in
MHz).

1000BASE-T CM voltage This measurement verifies that the common-mode voltage of the DUT is within
the conformance limits.

Reference:

Subclause 40.8.3.3 of IEEE standard 802.3-2015 

Description

The magnitude of the total common-mode output voltage, Ecm_out, on any
transmit circuit, shall be less than 50 mV peak-to-peak when transmitting data at
frequencies above 1 MHz.

100BASE-T

100BASE-T template This measurement verifies that the transmitter output fits the time domain
transmit template.

Reference:

Annex J of ANSIX3.263-1995 

Description

According to standard, Active Output Interface (AOI) transmitting scrambled
Halt Line State should fit in the template.

References  
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100BASE-T differential
output voltage

This measurement verifies that the differential output voltage of the device under
test (DUT) is within the conformance limits.

Reference:

Subclause 9.1.2.2 of ANSI X3.263-1995 

Description

According to standard, differential output voltage (Vout) should lie in the range of
950 mV to 1050 mV in both positive and negative excursion.

100BASE-T signal
amplitude symmetry

This measurement verifies that the signal amplitude symmetry of the device
under test (DUT) is within the conformance limits.

Reference:

Subclause 9.1.4 of ANSI X3.263-1995 

Description

The ratio of the + Vout magnitude to – Vout magnitude shall be between the limits:

0.98 ≤ |+Vout| / |-Vout| ≤ 1.02 

100BASE-T rise and fall
time

This measurement verifies that the response times of the DUT are within the
conformance limits.

Reference:

Subclause 9.1.6 of ANSI X3.263-1995 

Description

Active Output Interface (AOI) rise and fall time shall be in the range of 3.0 ns
and 5.0 ns. Rise and fall times are defined as time difference between 10% and
90% voltage levels. Both positive and negative rise/fall times should be
validated.

The difference between the maximum and the minimum of all measured rise and
fall times should be less than 0.5 ns.

 References
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100BASE-T waveform
overshoot

This measurement verifies that the waveform overshoot of the DUT is below the
conformance limit.

Reference:

Subclause 9.1.3 of ANSI X3.263-1995 

Description

According to standard, Overshoot is the percentage excursion of the differential
signal transition beyond Vout. Differential signal overshoot should not exceed
5%. Both positive and negative overshoot are to be measured.

100BASE-T Jitter This measurement verifies the jitter of the DUT is within the conformance limits.

Reference:

Subclause 9.1.9 of ANSI X3.263-1995 

Description

The transmitter output jitter when measured at the output of the twisted-pair
model should lie within ±5.5 ns. As per B.4.3.3 Note for 14.3.1.2.3 of IEEE
standard 802.3-2015, failure of this test does not demonstrate noncompliance.

The transmitter output jitter when measured without the twisted-pair model
should lie within ±8.0 ns.

100BASE-T return loss This measurement verifies the return loss at the transmitter or receiver of the
device under test (DUT) is above the conformance limit.

Reference:

Subclause 9.1.5 and 9.2.2 of ANSI X3.263-1995 

Description

Greater than 16 dB from 2 MHz to 30 MHz.

Greater than (16-20log(f/30 MHz)) dB from 30 MHz to 60 MHz.

Greater than 10 dB from 60 MHz to 80 MHz.
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100BASE-T duty cycle
distortion

This measurement verifies that the duty cycle distortion of the DUT is below the
conformance limit.

Reference:

Subclause 9.1.3 of ANSI X3.263-1995 

Description

According to standard, duty cycle distortion should be measured at the 50%
voltage points on rise and fall transitions of the differential output waveform and
should not exceed ±0.25 ns.

10BASE-T

10BASE-T MAU Ext This measurement verifies that the transmitter output equalization meets standard
specifications.

Reference:

Subclause 14.3.1.2.1 of IEEE standard 802.3-2015 

Description

According to standard, the transmitter waveform should lie within the template
(Normal and Inverted) for all data sequences at the twisted-pair model’s output
with 100 Ohm termination.

10BASE-T MAU Int This measurement verifies that the transmitter output equalization meets standard
specifications.

Reference:

Subclause 14.3.1.2.1 of IEEE standard 802.3-2015 

Description

According to standard, the transmitter waveform should lie within the template
(Normal and Inverted) for all data sequences at the twisted-pair model’s output
with 100 Ohm termination.

 References
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10BASE-T TP_IDL This measurement verifies that the transmitter functions properly after a
transition to the idle state.

Reference:

Subclause 14.3.1.2.1 of IEEE standard 802.3-2015 

Description

According to standard, the TP_IDL pulse should lie within the template. This test
shall be done across each of the specified test loading Load 1, Load 2, and Load
3 with and without twisted-pair model.

10BASE-T link pulse This measurement verifies that the link test pulse waveforms meet specification.

Reference:

Subclause 14.3.1.2.1 of IEEE standard 802.3-2015 

Description

According to standard, the link test pulse should lie within the template. This test
shall be done across each of the specified test loading Load 1, Load 2, and Load
3 with and without twisted-pair model.

10BASE-T differential
voltage

This measurement verifies that the differential voltage of the DUT is within the
conformance limits.

Reference:

Subclause 14.3.1.2.1 of IEEE standard 802.3-2015 

Description

Peak differential voltage of transmitter waveform when terminated with a
100 Ohm resistor should lie between 2.2 V and 2.8 V for all data sequences.

10BASE-T harmonic This measurement verifies that the harmonic content of the DUT is within the
conformance limits.

Reference:

Subclause 14.3.1.2.1 of IEEE standard 802.3-2015 

Description

Harmonic test is done when the DO circuit is driven by all ones. Each harmonic
measured at the output of the transmitter shall be at least 27 dB below the
fundamental.

References  
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10BASE-T return loss This measurement verifies the return loss at the transmitter or receiver of the
device under test (DUT) is above the conformance limit.

Reference

Subclause 14.3.1.2.2 of IEEE standard 802.3-2015 ab

Description

At least 15 dB over the frequency range of 5.0 to 10 MHz.

10BASE-T jitter This measurement verifies the jitter of the DUT is within the conformance limits.

Reference:

Subclause 14.3.1.2.3 of IEEE standard 802.3-2015 

Annexure B.4.3.2 Note for 14.3.1.2.3 of IEEE standard 802.3-2015 

Description

The transmitter output jitter when measured at the output of the twisted-pair
model should lie within ±5.5 ns. As per B.4.3.3 Note for 14.3.1.2.3 of IEEE
standard 802.3-2015, failure of this test does not demonstrate noncompliance.

The transmitter output jitter when measured without the twisted-pair model
should lie within ±8.0 ns.

10BASE-T CM Voltage This measurement verifies that the common-mode voltage at the transmitter or
receiver of the device under test (DUT) is above the conformance limit.

Reference:

Subclause 14.3.1.2.5 of IEEE standard 802.3-2015 

Description

At least 15 dB over the frequency range of 5.0 to 10 MHz.
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A
Acquire parameters

including in test reports, 55
viewing in reports, 57

Acquisition tab, 24
Analysis options, 48
Application directories, 7
Application panels overview, 12
Application version (show), 9

B
Button

calibration, 24
clear log, 49
save, 49
view optical modules, 24

C
Calibration button, 24
Clearing test results, 83
Compensate the signal path, 82
Configuration tab, 20
Configuration tab parameter

instruments detected, 25
Configuration tab parameters

global settings, 25
Connected instruments

searching for, 17
Connection requirements, 59
Create a test setup from default settings, 86
Create a test setup using an existing one, 86

D
DUT ID, 22
DUT parameter

device, 22
device profile, 22
optical module settings, 22
optical power, 22

DUT type

device, 22
DUT-instrument setup, 59

E
Email notification and setup, 19
Equipment setup, 59
Extensions, file names, 8

F
File name extensions, 8

G
GPIB, 17

I
Installing the software

switch matrix application, 7
Instrument-DUT setup, 59
Instruments

discovering connected, 17
viewing connected, 17

Instruments and accessories required, 6
Instruments detected, 25

K
Keep on top, 11

L
LAN, 17
License agreement (show), 9
Live waveforms, 22
Loading a test setup, 86
Log view

save file, 49

M
Menus
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Options, 16
Preferences, 83

Minimum system requirements, 5
My TekExpress folder

files stored in, 51

N
Names, file extensions, 8
Non-VISA, 17

O
Opening a saved test setup, 86
Options menu

Instrument control settings, 17
keep on top, 11

Oscilloscope compensation, 82

P
Panels, 12
Pattern, 22
Pattern type, 22
Preferences menu, 50
Preferences tab

send an Email, 48
setup panel, 48

R
Recalling a test setup, 86
Report contents, 57
Report name, 55
Report options, 55
Report sections, 57
Reports

receiving in email notifications, 19
Reports panel, 12, 54
Resource file, 11
Results panel

summary of test results, 50
test name, 50

Results Panel, 83
Running tests, 83

S
Save log file, 49

Saving tests, 51
Schematic button (DUT-instrument setup), 59
SCPI commands

TEKEXP׃*IDN?, 95
TEKEXP׃*OPC?, 95
TEKEXP׃ACQUIRE_MODE, 96
TEKEXP׃ACQUIRE_MODE?, 96
TEKEXP׃EXPORT, 97
TEKEXP׃INFO?, 97
TEKEXP׃INSTRUMENT, 98
TEKEXP׃INSTRUMENT?, 98
TEKEXP׃LASTERROR?, 99
TEKEXP׃LIST?, 99
TEKEXP׃MODE, 100
TEKEXP׃MODE?, 100
TEKEXP׃POPUP, 101
TEKEXP׃POPUP?, 101
TEKEXP׃REPORT, 102
TEKEXP׃REPORT?, 102
TEKEXP׃RESULT?, 103
TEKEXP׃SELECT, 104
TEKEXP׃SELECT?, 104
TEKEXP׃SETUP, 105
TEKEXP׃STATE, 105
TEKEXP׃STATE?, 106
TEKEXP׃VALUE, 106
TEKEXP׃VALUE?, 107

Search for connected instruments, 17
Selecting test report contents, 55
Selecting tests, 23
Serial, 17
Session folders and files, 51
Setting up equipment, 59
Setup

acquisition tab, 24
Setup files, 85
Setup panel

DUT parameter, 20
preferences tab, 20
test selection, 20

Show acquire parameters, 24
Signal conditioning

bandwidth, 22
filter, 22
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Software installation
switch matrix application, 7

Source, 22
Status panel

log view, 49
message history, 49
test status tab, 49

System requirements, 5

T
Tek Link, 17
Test Name, 24
Test reports, 57
Test results

send by email, 19
Test Results

clearing displayed, 83
Test selection

Ethernet, 23
optical tests, 23
test description, 23

Test selection controls, 23
Test setup files, 51, 85
Test setups

load, 86
open, 86
recalling, 86

Test status

acquire status, 49
analysis status, 49
auto scroll, 49

Test-related files, 51
Tests

running, 83
selecting, 23

U
USB, 17
User Comments

including in reports, 56

V
View a report, 57
View application license agreement, 9
View application software version, 9
View optical modules button, 24
VXI, 17

W
Waveform files

locating and storing, 51
Wavelength, 22
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