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Welcome
HDMXpress is a HDMI signal generation software that runs on the Master
AWG. HDMXpress supports the generation of HDMI 2.0 patterns that can be
used to perform electrical, protocol and margin tests.

The TekExpress HDM application acts as a controller that controls, and
communicates with the HDMXpress application running on the Master AWG.
The TekExpress HDM application is also used to synchronize and load patterns
generated using HDMXpress.

The HDMXpress software is designed to work with the following Tektronix
arbitrary waveform generators:

■ AWG70002A series arbitrary waveform generator (firmware V3.0 and
above).

■ AWG7122C series arbitrary waveform generators (V4.6.0.7).

The software can be run in the following way.

From the Start menu, click All Programs > HDMXpress. You can also double-
click the HDMXpress shortcut on the desktop.





Introduction

Conventions
The online help uses the following conventions:

■ When steps require a sequence of selections using the software interface, the
">" delimiter marks each transition between a menu and an option. For
example, File > Save.

■ DUT refers to the Device Under Test.

■ The terms "waveform" and "signal" are used interchangeably.

■ The term AWG refers to a Tektronix Arbitrary Waveform Generator.

Feedback
Tektronix, Inc.

14200 SW Karl Braun Drive

P.O. Box 500

Beaverton, OR 97077

USA

For product information, sales, service, and technical support:

■ In North America, call 1-800-833-9200.

■ Worldwide, visit www.tektronix.com to find contacts in your area.
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Getting started

Minimum system requirements
The minimum requirements of the HDMXpress application are listed in the
following table:

Table 1: Minimum system requirements

Supported OS Windows 7 Professional
Minimum Requirements 2 GB free disk space

.Net 4.0 
Matlab® Compiler Runtime version 7.14 

Prerequisites TekVisa is required to communicate with the AWG70002A / AWG7122C signal
generators (or other test instruments), over a LAN. If TekVisa is not already
installed in your system, you can download the software from
www.tektronix.com.

Installation
An installation wizard installs HDMXpress. If you have not installed MATLAB
Runtime and .NET 4.0, the installer will detect and install it. 

You can uninstall in either of these two ways:

■ From Start > All Programs > Tektronix HDMXpress > Uninstall
HDMXpress.

■ From Add/Remove programs in Control panel.
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Activate the license

NOTE. The HDM-DSM option has to be enabled on an oscilloscope connected to
the AWG in which the HDMXpress is installed.

Activate the license using the option installation wizard on the oscilloscope.
Follow these steps to activate the HDMXpress license:

1. From the oscilloscope menu bar, click Utilities > Option Installation.

The TekScope Option Installation wizard opens.
 

 

2. Instructions for using the Options Installation window to activate licenses for
installed applications is provided in the oscilloscope online help. Press the F1
key on the oscilloscope keyboard to open the Option Installation help topic.
Follow the directions in the topic to activate the license.

Getting started  
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View version and license information
To view version information

Click Help > About HDMXpress.
 

 

Option Information

From the oscilloscope Help menu, select About TekScope.

The Options section in the dialog box displays a list of installed options,
including HDMXpress (option HDM-DSM).

NOTE. Option HDM-DSM must be installed on the oscilloscope. The oscilloscope
is connected to the AWG (where HDMXpress is installed) through LAN network.

Additional Information

For HDMXpress to be activated on the AWG, the AWG with the HDMXpress
software installed must be connected via the network to an oscilloscope with
option HDM-DSM installed.

Specify the IP address of the oscilloscope in the HDMXpress > Instrument
Control, in the Scope group box to ensure that the HDMXpress installed on the
AWG is connected to the oscilloscope with the option HDM-DSM enabled.
 

 

 Getting started
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Connection setups

NOTE. Signal connections from an AWG to an oscilloscope is not required for
protocol tests as physical parameters calibration is not performed for protocol
tests.

However for HDMXpress to run, the AWG (were the HDMXpress software is
installed) must be connected to an oscilloscope on the network were option
HDM-DSM enabled.

For the electrical tests, connect the instruments as per the below table.

Test number and characteristic tested Setup diagram
Test ID HF2-1: Sink TMDS Electrical - 6G - Min/
Max Differential Swing Tolerance

Setup for Test ID HF2-1: Sink TMDS Electrical -
6G - Min/Max Differential Swing Tolerance, Max
connections for AWG70002A

Test ID HF2-1: Sink TMDS Electrical - 6G - Min/
Max Differential Swing Tolerance

Setup for Test ID HF2-1: Sink TMDS Electrical -
6G - Min/Max Differential Swing Tolerance, Min
and Nominal connections for AWG70002A

Test ID HF2-3: Sink TMDS Electrical - 6G - Jitter
Tolerance

Setup for Test ID HF2-3: Sink TMDS Electrical -
6G - Jitter Tolerance for AWG70002A

Test ID HF2-2: Sink TMDS Electrical - 6G -
Intra-Pair Skew

Setup for Test ID HF2-2: Sink TMDS Electrical -
6G - Intra-Pair Skew for AWG70002A

Test ID HF2-1: Sink TMDS Electrical - 6G - Min/
Max Differential Swing Tolerance

Setup for Test ID HF2-1: Sink TMDS Electrical -
6G - Min/Max Differential Swing Tolerance, Max/
Min/Nominal connections for AWG7122C

Test ID HF2-3: Sink TMDS Electrical - 6G - Jitter
Tolerance

Setup for Test ID HF2-3: Sink TMDS Electrical -
6G - Jitter Tolerance for AWG7122C

Test ID HF2-2: Sink TMDS Electrical - 6G -
Intra-Pair Skew

Setup for Test ID HF2-2: Sink TMDS Electrical -
6G - Intra-Pair Skew for AWG7122C

Getting started  
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Sink TMDS Electrical - 6G - Min / Max Differential Swing Tolerance, Max
connections for AWG70002A
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Sink TMDS Electrical - 6G - Min / Max Differential Swing Tolerance, Min
and Nominal connections for AWG70002A
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Sink TMDS Electrical - 6G - Jitter Tolerance for AWG70002A
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Sink TMDS Electrical - 6G - Intra-Pair Skew for AWG70002A
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Sink TMDS Electrical - 6G - Min / Max Differential Swing Tolerance, Max /
Min / Nominal connections for AWG7122C
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Sink TMDS Electrical - 6G - Jitter Tolerance for AWG7122C
 

 

Getting started  

12  HDMXpress Printable Application Help



Sink TMDS Electrical - 6G - Intra-Pair Skew for AWG7122C
 

 

 Getting started
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Operating basics

Overview of the software
HDMXpress is a HDMI signal generation software that runs on the Master
AWG. HDMXpress supports the generation of HDMI 2.0 patterns used to
perform electrical, protocol and margin tests.

The TekExpress HDM application, running on an oscilloscope acts as the
controller that controls, and communicates with the HDMXpress application
running on the AWG. The TekExpress HDM application is also used to
synchronize and load patterns generated in HDMXpress.

The patterns created by the HDMXpress application will be used by the
TekExpress HDM application when performing tests.

Key Features HDMXpress has the following key features:

■ Supports all the VIC (Video Identification Code) specified in the CEA861-F
specification

■ 24, 30, 36, and 48 bit color depths are supported
■ Color sub sampling like RGB, YCBCR 4-4-4, YCBCR 4-2-0, and YCBCR

4-2-2 
■ All 3D frame types and 3D structures like FP, SSH, and TB are supported
■ Color Bar, Chess board, Special image, Aspect ratio test image, Custom

images (image of user choice) are all supported
■ Ability to sync the patterns created in the HDMXpress to the TekExpress

HDM solution
■ Supports Closed loop calibration and has the ability to create patterns for

margin testing
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Starting the software
From the Start menu, click All Programs > HDMXpress. You can also double-
click the HDMXpress shortcut on the desktop.

Exiting the software
Select File > Exit to exit the application. If you have not saved patterns, you are
prompted to do so. This option is always enabled.

File name extensions
The application uses the following file name extensions:

Table 2: File name extensions

File name extension Description
.csv Ascii file containing Comma Separated Values. This file format may be

read by any ascii text editor (such as Microsoft Notepad) or may be
imported into spreadsheets such as Microsoft Excel.

.wfm Binary file containing an AWG waveform record in a recallable.
proprietary format.

.flt Files containing the inverse filter co-efficient.

.png Files containing the schematics and images.

.sxs XML (Extensible Markup Language) file containing setup information that
can be saved and recalled whenever necessary for creating a pattern.

Operating basics  
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Menus and toolbars

Menu bar The HDMXpress menu has the following items:

File

Use the File menu to:

■ Restore Default Configuration: Restore the default configuration.

■ Open Setup: Open a saved setup file.

■ Save Setup: Save the setup file in the .sxs format in a folder in your C drive.

■ Save Setup As: Save the setup under another name in the .sxs format.

■ Exit: Exit the application.

Edit

Use the Edit menu to:

■ Delete: Deletes the selected configurations.

■ Select All: Selects all the configurations.

View

 Operating basics
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Use the View menu to:

■ Standard Toolbar: View or hide the toolbar. If the toolbar is hidden before
closing the application, it remains hidden when the application is opened
again.

■ Status Bar: View or hide the status bar. If the status bar is hidden before
closing the application, it remains hidden when the application is opened
again.

Pattern

Use the Pattern menu to:

■ New: Creates a new pattern file based on current settings.

■ Add to Configuration List: Adds a pattern to the configuration list.

■ Generate: Generates the new pattern. The pattern will be created in both the
AWG's (Master and Slave).

■ Stop: Stop generating the pattern.

Help

Use the Help menu to:

■ Help Topics: Open the online help.

■ About HDMXpress: Display information about the application, such as the
version number.

Operating basics  
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Standard toolbar Select View > Standard toolbar to hide or show the toolbar. The toolbar is
displayed by default. The Standard toolbar uses icons that provide a quick access
to many frequently used functions. 
 

 

The Standard toolbar has the following options:
■ New Configuration: Creates a new pattern based on the current settings.
■ Add To Configuration List : The configured pattern is added to the

Configuration list.
■ Delete Configuration: Deletes the selected configuration from the

Configuration list.
■ Generate: Generates the configured pattern. The pattern will be created in

both the AWG's (Master and Slave).
■ Stop: Stops generating the pattern.

Status bar Select View > Status Bar to hide or show the status bar. The status bar displays
the AWG name on which the HDMXpress is installed. The status bar is displayed
by default.

Configuration list Configuration list displays a list of all the patterns. By default it is displayed and
opens in the leftmost area of the display window.

After you configure the pattern in the Configuration - New window, select Add
To List. The configured pattern data will be saved and displayed in the
Configuration List window. The Configuration list displays the Label, Test ID,
VIC, Frame Type, 3D Structure, HDMI Version, Color Depth, Color Mode, and
Image Type of the pattern data.

NOTE. You can configure any number of patterns and add them to the
configuration list.

After you select a pattern to generate, you must compile it to create the data.
Once you generate a pattern (using Generate from the toolbar), a pattern is
created.

To save a configured pattern that is available in the list, select the pattern and
select File > Save Setup As. The configured pattern is saved as a (.sxs) file in the
specified location. 

NOTE. If you close the application without saving the configured pattern, the
pattern data is lost. You can compile the pattern again from the setup, if you have
saved the setup using File > Save Setup or Save Setup As.

 Operating basics
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You can select multiple contiguous and non-contiguous patterns using the Shift
and Ctrl keys, respectively. Selecting multiple configured patterns and selecting
the Delete option deletes all the selected patterns. Selecting multiple configured
patterns and selecting the Generate option generates all the pattens for the
selected pattern configurations.

Operating basics  
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Generating a pattern
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Protocol test

Configure the settings In the Configuration - New group:

1. Enter the label name for the pattern in the Label text box.
 

 

Labeling helps to identify or group one or more patterns in the TekExpress
HDM application, as shown in the below TekExpress HDM application
figure.
 

 
2. Select the Test ID for the pattern to be created.

 

 

NOTE.
■ Based on the selected Test ID, the application displays the fields that are

configurable for that test.
■ The patterns created for the specific Test ID will only appear in the

TekExpress HDM application for the corresponding tests.

3. Configure the HDMI patterns to be created.

Generating a pattern  
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In the Base Configuration group,

4. Configure the VIC, Frame Type, Color Depth, Color Mode, and Image
Type from the respective fields. You can view the image, in the Image Type
group.

Save the configuration Once the pattern is configured, it should be saved.

To save the configured pattern, follow the steps.

1. Click Save Setup from the File menu, to save the current configuration of
HDMXpress.

The setup files can be recalled later by selecting Open Setup in the File
menu.

2. Click New to create a new pattern settings using either of these methods:

■
Pattern menu click New  icon, or

■
Toolbar menu click New Configuration  icon.
 

 

A popup prompts you to include the Current Configuration to the list.

■ Click Yes, to add the current configuration to the Configuration List
in the left side. Automatically the Configuration Panel parameters
will set to the default pattern settings.

■ Click No, to discard the settings. This also sets the default pattern
settings.

■ Click Cancel, to close the popup window. There will be no effect on
the Configuration panel settings.

3. Click Add to List to add the current configuration to the Configuration List.

■
You can click the Add To List  icon either from
Configuration tab, or

■
Click the Add To Config List  icon from the toolbar menu

 Generating a pattern
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Create a pattern To create a pattern, follow the steps.

1. Select one or more pattern from the Configuration List.

2. Click Generate  icon, either from the

■ Tool bar, or
■ Pattern, menu

The pattern will be created automatically on Master AWG and Slave
AWG.

All the generated patterns will be created automatically. View the saved
location of the generated patterns in the Output window.
 

 

NOTE. Generated pattern files will be saved as Setup1.awgx/Setup1.awg
on Master AWG and Setup2.awgx/Setup2.awg on Slave AWG.

Electrical Test

Configure the settings To configure the settings, follow the steps.

1. Enter the name to be given to the pattern in the Label text box

2. Select the test for which the pattern is created from the Test ID drop-down
box.

NOTE.
■ Based on the selected Test ID, the application displays the fields that are

configurable for the test.
■ The patterns created for the specific Test ID will only appear in the

TekExpress application for the corresponding tests.

3. Configure the HDMI patterns to be created.

In the Base Configuration group,

4. Configure the VIC , Frame Type, Color Depth, Color Mode, and Image
Type from the respective fields.

You can view the image, in the Image Type group.

Generating a pattern  
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In the Test Configuration group, when the Compliance mode is selected, you
can only specify the Frequency Profile and select the Percentage Deviation of
Result for Auto Calibration. The Clock Jitter, Data Jitter, Voltage Swing and
Cable Emulator fields are not-editable in Compliance mode, and default values
are used.

When the User Defined mode is selected, you can modify the default values for
Clock Jitter, Data Jitter, and Voltage Swing parameters. You can also specify
the Frequency Profile, browse to select the Cable Emulator and select the
Percentage Deviation of Result for calibration.

NOTE. In the Frequency Profile field

■ If FP1 is selected, the pattern for the frequency profile1 (500 KHz, 10 MHz )
is generated.

■ If FP2 is selected, the pattern for the frequency profile2 (1 MHz, 7 MHz ) is
generated.

■ If Both are selected, both frequency profiles 1 and 2 will be generated and
saved.

Save the configuration Once the pattern is configured, it should be saved.

 Generating a pattern
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To save the configured pattern, follow the steps.

1. Click Save Setup from the File menu, to save the current configuration of
HDMXpress.

The setup files can be recalled later by selecting Open Setup in the File
menu.

2. Click New to create a new pattern settings using wither of these methods:

■
Pattern menu click New  icon, or

■
Toolbar menu click New Configuration  icon
 

 

A popup prompts you to include the Current Configuration to the list.

■ Click Yes, to add the current configuration to the Configuration List
in the left side. The Configuration Panel parameters will set to the
default pattern settings.

■ Click No, to discard the settings. This also sets the configuration
parameters to default settings.

■ Click Cancel, to close the popup window. There will be no effect on
the Configuration panel settings.

3. Click Add to List to add the current configuration to the Configuration List.

■ You can click the Add To List  icon either from Configuration
tab, or

■ Click the Add To Config List  icon from the toolbar menu

Generating a pattern  
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Create the pattern The auto calibration module generates the required pattern and then performs the
required measurement using DPOJET. The application automatically configures
DPOJET for performing these measurements. The auto calibration module
performs the closed loop calibration based on the measured values, and creates
the pattern within the specified accuracy. Once the signal is created, the setup file
is saved in the location defined for HDMXpress setup files.

Once a pattern is loaded onto the AWG, the auto calibration module manages the
DPOJET measurements. Auto calibration estimates final reacquired input for
specific output and sends feedback to the impairments algorithm to generate the
signal. Once the signal is created, the setup file is saved in the location defined
for HDMXpress setup files.

Once the pattern is generated, the Output window is updated with the path of the
saved pattern file.
 

 

Instrument control setting
HDMXpress works with the following arbitrary waveform generators.

■ AWG70002A

■ AWG7122C

HDMXpress creates patterns on both the Master and the Slave AWG.

Clock and Data0 patterns are created on the Master AWG. Data1 and Data2
patterns are created on the Slave AWG.

Configure the Slave AWG and Oscilloscpe IP address.

 Generating a pattern
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Run pattern generated using HDMXpress in TekExpress
HDM application

To run the pattern generated using HDMXpress in TekExpress HDM application,
follow the below steps:

1. Go to Setup panel, and select the Test Selection tab.

2. Select the test.
 

 

3. Click Configuration panel > Global Settings tab to define the Master and
Slave IP address.
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4. Click the Measurements tab.
 

 

5. Select the Pattern Settings, and then in the Pattern Type group, select
Custom Pattern.

NOTE. If Standard Pattern is selected, you will see a list of patterns supplied
as part of AWG Pattern installer.

6. Click the Pattern Table button, which displays the Pattern Selection pop-
up window.
 

 

7. Click Sync. HDMXpress will display the patterns created for this particular
test in the Patterns Selection table. All the labels will be updated in the
patterns drop-down. Label is the label entered in the HDMXpress when
creating the pattern.

Run pattern generated using HDMXpress in TekExpress HDM application  
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8. Select a label in the Label drop-down. You will then see all the patterns that
are created under the same label in the HDMXpress.

NOTE. If All is selected, you can view all the created labels and the patterns.

 

 

9. Select a waveform from the list.

10. Click OK.

11. Click the Start button to perform the test.

 Run pattern generated using HDMXpress in TekExpress HDM application
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Algorithms

HF-2-1 Sink Min Max measurement
Application calibrates the pattern for Min Voltage Swing and Max Voltage
Swing. The below algorithm is used for Min and Max Voltage Swing calibration.

Voltage Swing calibration algorithm

1. VmeasuredAmplitude = 0 

2. Vdiff = (VmeasuredAmplitude - Required Amplitude)

3. Calculate

a. awgGain = AWG Gain = Vamplitude (AWG7K)

b. awgGain = Vamplitude /2.0 (AWG7K)

4. While (Vdiff > allowed devation)

a. Set the awgGain

b. Measure the amplitude on the oscilloscope(VmeasuredAmplitude)

c. Vdiff = (Required Amplitude - VmeasuredAmplitude)

d. awgGain = awgGain + awgGain * (Vdiff / VmeasuredAmplitude)

NOTE. Max Voltage swing pattern on AWG70K is generated on the Marker
channel. You need to perform the skew calibration manually.

HF-2-2 Sink Intra Pair Skew measurement
Application calibrates the Voltage Swing as per the specification.

Voltage Swing calibration algorithm

1. VmeasuredAmplitude = 0 

2. Vdiff = (VmeasuredAmplitude - Required Amplitude as per specification)

3. Calculate

a. awgGain = AWG Gain = Vamplitude (AWG7K)

b. awgGain = Vamplitude /2.0 (AWG7K)

4. While (Vdiff > allowed devation)

a. Set the awgGain

b. Measure the amplitude on the oscilloscope(VmeasuredAmplitude)
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c. Vdiff = (Required Amplitude - VmeasuredAmplitude )

d. awgGain = awgGain + awgGain * (Vdiff / VmeasuredAmplitude)

NOTE. You have to perform the skew calibration manually.

HF-2-3 Sink Jitter Tolerance measurement
Application calibrates Jitter and Amplitude parameters.

Voltage Swing calibration algorithm

1. VmeasuredAmplitude = 0 

2. Vdiff = (VmeasuredAmplitude - Required Amplitude)

3. Calculate

a. awgGain = AWG Gain = Vamplitude (AWG7K)

b. Measure the amplitude on the oscilloscope(VmeasuredAmplitude)

c. Vdiff = (Required Amplitude - VmeasuredAmplitude)

d. awgGain = awgGain + awgGain * (Vdiff / VmeasuredAmplitude)

Jitter parameter

Application calibrates C_Jitter and D_Jitter parameters to the required value

1. CJMagnitude = CJMagnitudeRequired ; DJMagnitude =
DJMagnitudeRequired

2. Insert CJMagnitude and DJMagnitude and generate the pattern.

3. Measure the CJMagnitudeMeasured and DJMagnitudeMeasured and find the
result variation. If the result variation is within the specified range then stop.

4. Below step is required for jitter components which does not meet the
required criteria)

■ If it is first time then

a. Proportionately increase/decrease the input jitter values

5. Go back to step b

Algorithms  
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Reference

Shortcut keys

Table 3: Shortcut keys

Menu/Menu item Shortcut key
File Alt+F
File > Open Setup Ctrl+O
File > Save Setup Ctrl+S
View Alt+V
Pattern Alt+P
Help Alt+H

Default values

Table 4: Default values and selection

Item Option Default value/selection
Configuration - New group
Label Test name defined by you HDM
Version HDMI specification version CTS 2.0 
Test ID Define the compliance tests as

mentioned in the CTS
HF2_6

Base Configuration group: Includes all the Protocol configuration
VIC Code Video identification code,

represents resolution of the
video format

96 : 3840x2160p @ 50Hz

Frame Type Video dimension 2D
Color Depth Image pixel intensity 24 
Color Mode Pixel encoding format RGB444
Image Type Kind of image used for pattern

generation
Gray Scale

Test Configuration group
Compliance Sets default values for electrical

configurations as defined by the
CTS specification

Selected by default

User Defined You can specify the values for
electrical configurations.

NA
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Item Option Default value/selection
Clock Jitter Amount of the jitter to be

inserted on the clock signal in
terms of Unit Interval

0.30 UI

Data Jitter Amount of jitter to be inserted
on the data signal in terms of
Unit Interval

0.60 UI

Voltage Swing Output signal amplitude 800 mV
Frequency Profile Both
Cable Emulator Filter file used for applying the

cable effect
NA

Auto Calibration Calibrates the signal in terms of Unit Interval
Percentage Deviation Of Result Percentage of variation in the

calibrated values acceptable
5.0 %

Instrument Control: Tab for providing AWG and scope addresses
Address Instrument TCP-IP or GPIB

address required for
communication

Clock AWG channels to output the
lanes

Ch 1: Analog
Data0 Ch 2: Analog
Data1 Ch 1: Analog
Data2 Ch 2: Analog

Reference  

36  HDMXpress Printable Application Help



Index
A
Activating the license, 4
Application

exiting, 16
installation, 3
system requirements, 3

C
Configuration list, 19
Conventions, 1

F
Feedback, 1

L
License, 5
License activation, 4

M
Menu bar

Edit, 17
File, 17
Help, 18
Pattern, 18
View, 17

S
Sink

Intra pair skew, 33
jitter tolerance, 34
Max, 33
Min, 33

Status bar, 19

T
Toolbar, 19

V
Version, 5

HDMXpress Printable Application Help 37



Index  

38  HDMXpress Printable Application Help


	Table of Contents
	Welcome
	Introduction
	Conventions
	Feedback

	Getting started
	Minimum system requirements
	Installation
	Activate the license
	View version and license information
	Connection setups

	Operating basics
	Overview of the software
	Starting the software
	Exiting the software
	File name extensions
	Menus and toolbars
	Menu bar
	Standard toolbar
	Status bar
	Configuration list


	Generating a pattern
	Protocol test
	Configure the settings
	Save the configuration
	Create a pattern

	Electrical Test
	Configure the settings
	Save the configuration
	Create the pattern

	Instrument control setting

	Run pattern generated using HDMXpress in TekExpress HDM application
	Algorithms
	HF-2-1 Sink Min Max measurement
	HF-2-2 Sink Intra Pair Skew measurement
	HF-2-3 Sink Jitter Tolerance measurement

	Reference
	Shortcut keys
	Default values

	Index

