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Important safety information

Important safety information

This manual contains information and warnings that must be followed by the user
for safe operation and to keep the product in a safe condition.

To safely perform service on this product, additional information is provided at
the end of this section. (See page x, Service safety summary.)

General safety summary

viii

Use the product only as specified. Review the following safety precautions to
avoid injury and prevent damage to this product or any products connected to it.
Carefully read all instructions. Retain these instructions for future reference.

Comply with local and national safety codes.

For correct and safe operation of the product, it is essential that you follow
generally accepted safety procedures in addition to the safety precautions specified
in this manual.

The product is designed to be used by trained personnel only.

Only qualified personnel who are aware of the hazards involved should remove
the cover for repair, maintenance, or adjustment.

Before use, always check the product with a known source to be sure it is
operating correctly.

This product is not intended for detection of hazardous voltages.

Use personal protective equipment to prevent shock and arc blast injury where
hazardous live conductors are exposed.

While using this product, you may need to access other parts of a larger system.
Read the safety sections of the other component manuals for warnings and
cautions related to operating the system.

When incorporating this equipment into a system, the safety of that system is the
responsibility of the assembler of the system.
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To avoid fire or personal  Use proper power cord. Use only the power cord specified for this product and
injury certified for the country of use. Do not use the provided power cord for other
products.

Ground the product. This product is grounded through the grounding conductor
of the power cord. To avoid electric shock, the grounding conductor must be
connected to earth ground. Before making connections to the input or output
terminals of the product, make sure that the product is properly grounded. Do not
disable the power cord grounding connection.

Power disconnect. The power switch disconnects the product from the power
source. See instructions for the location. Do not position the equipment so that it
is difficult to disconnect the power switch; it must remain accessible to the user at
all times to allow for quick disconnection if needed.

Observe all terminal ratings. To avoid fire or shock hazard, observe all ratings
and markings on the product. Consult the product manual for further ratings
information before making connections to the product.

Do not apply a potential to any terminal, including the common terminal, that
exceeds the maximum rating of that terminal.

The measuring terminals on this product are not rated for connection to mains or
Category II, 111, or IV circuits.

Do not operate without covers. Do not operate this product with covers or panels
removed, or with the case open. Hazardous voltage exposure is possible.

Avoid exposed circuitry. Do not touch exposed connections and components
when power is present.

Do not operate with suspected failures. If you suspect that there is damage to this
product, have it inspected by qualified service personnel.

Disable the product if it is damaged. Do not use the product if it is damaged
or operates incorrectly. If in doubt about safety of the product, turn it off and
disconnect the power cord. Clearly mark the product to prevent its further
operation.

Examine the exterior of the product before you use it. Look for cracks or missing
pieces.

Use only specified replacement parts.
Use proper fuse. Use only the fuse type and rating specified for this product.

Wear eye protection. Wear eye protection if exposure to high-intensity rays or
laser radiation exists.

Do not operate in wet/damp conditions. Be aware that condensation may occur if
a unit is moved from a cold to a warm environment.
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Important safety information

Do not operate in an explosive atmosphere.

Keep product surfaces clean and dry. Remove the input signals before you clean
the product.

Provide proper ventilation. Refer to the installation instructions in the manual for
details on installing the product so it has proper ventilation.

Slots and openings are provided for ventilation and should never be covered or
otherwise obstructed. Do not push objects into any of the openings.

Provide a safe working environment. Always place the product in a location
convenient for viewing the display and indicators.

Avoid improper or prolonged use of keyboards, pointers, and button pads.
Improper or prolonged keyboard or pointer use may result in serious injury.

Be sure your work area meets applicable ergonomic standards. Consult with an
ergonomics professional to avoid stress injuries.

Use care when lifting and carrying the product. This product is provided with
handles for lifting and carrying.

Service safety summary

The Service safety summary section contains additional information required to
safely perform service on the product. Only qualified personnel should perform
service procedures. Read this Service safety summary and the General safety
summary before performing any service procedures.

To avoid electric shock. Do not touch exposed connections.

Do not service alone. Do not perform internal service or adjustments of this
product unless another person capable of rendering first aid and resuscitation is
present.

Disconnect power. To avoid electric shock, switch off the product power and
disconnect the power cord from the mains power before removing any covers or
panels, or opening the case for servicing.

Use care when servicing with power on. Dangerous voltages or currents may exist
in this product. Disconnect power, remove battery (if applicable), and disconnect
test leads before removing protective panels, soldering, or replacing components.

Verify safety after repair. Always recheck ground continuity and mains dielectric
strength after performing a repair.
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Important safety information

Terms in this manual

These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result

in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in

damage to this product or other property.

Symbols and terms on the product

These terms may appear on the product:

B DANGER indicates an injury hazard immediately accessible as you read
the marking.

B WARNING indicates an injury hazard not immediately accessible as you
read the marking.

®  CAUTION indicates a hazard to property including the product.

When this symbol is marked on the product, be sure to consult the manual

A to find out the nature of the potential hazards and any actions which have to
be taken to avoid them. (This symbol may also be used to refer the user to
ratings in the manual.)

The following symbol(s) may appear on the product:

A S O | ¢

CAUTION Protective Ground Mains Disconnected  Mains Connected  gyandh
Refer to Manual (Earth) Terminal OFF (Power) ON (Power) anaby

MTS4000 and MTS4SAV3 Generator Applications User Manual
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Preface

Preface

The MTS4000 MPEG system applications are described in three user manuals:
B Analyzer applications

m  Generator applications

B Carousel applications

The full list of applications can be found in the MTS4000 Quick Start User
Manual. This manual describes the generator related applications. All applications
are available on the MTS4000 and MTS4SAV3 products:

Table i: Overview of the MTS4000 generator applications

Application Desktop icon
Multiplexer — Multiplexes table information and packetized elementary streams together to synthesize

new transport streams. A fine level of control is provided to allow nonconformances and test cases to be @
specified for new transport streams.

Multiplexer

TS Editor — Viewing and editing transport stream packets, using a hexadecimal view of the packet
contents and semantic interpretation of the header. Provides facilities to remap PIDs, recalculate PCR %

values and introduce PCR inaccuracies.
TS Editar

ISDB-T Remux — Remultiplexes an existing 188- or 204-byte transport stream file into an ISDB-T/Tb
(ARIB STD-B31) compliant file (204 bytes per packet). The created file extension is .RMX and includes ey
TMCC and IIP sections.
ISDB-T
Remux

MPEG Player — Plays MPEG-2 streams. E

Make Seamless Wizard — Guides the user through the process of creating an MPEG-2 file for use by
Stream Player in continuously looped operation. ﬁ

Make
Seamless
‘Wizard

o

Skrearn Cutter

TS Cutter — Extracts sections of MPEG-2 files to new files.
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Table i: Overview of the MTS4000 generator applications (cont.)

Application Desktop icon
Script Pad — Enables users to create and modify System Information (SI) scripts.

ScriptPad
TTS Utility — Converts time stamped transport streams to standard transport stream format.

TTS Utility
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Product documentation

The following table lists the documentation available for your MTS4000 or
MTS4SAV3 product:

Document (Tektronix part number)

Purpose

Location

MTS4000 and MTS4SAV3 Quick Start User

Manual

(071-2970-xx English,
077-0665-xx Simplified Chinese,
077-0666-xx Japanese,
077-0657-xx Russian)

Describes how to install and get
started using the test systems.

MTS4000 and MTS4SAV3 Analyzer

Describes the operation of the

Applications User Manual following analyzer applications: @ + B 5
(077-0622-xx) TSCA, PES Analyzer, T-STD Buffer o e Ktronx com
Analyzer, and ES Analyzer.
MTS4000 and MTS4SAV3 Generator Describes the operation of the S
Applications User Manual following generator applications: @ + —Ea
(077-0623-xx) Multiplexer, MPEG Player, TS www Tekironix.com
Editor, ISDB-T Remux, Make
Seamless Wizard, Transport
Stream Cutter, and Script Pad.
MTS4000 and MTS4SAV3 Carousel Optional manual supporting @ +

Applications User Manual
(077-0624-xx)

module-level servicing of the
instrument.

www. Tektronix.com

MTS4000 and MTS4SAV3 Release Notes
(077-0627-xx)

Describes known issues with the
test systems.

MTS4EAV7 HEVC / AVC Video and
Compressed Audio Analyzer User Manual
(077-1134-xx)

Describes the operation of the
MTS4EAV7 application software.

MTS4CC Elementary Stream Compliance
Checker User Manual
(071-2075-xx)

Describes the operation of the
MTS4CC application software.

www. Tektronix.com

PQABO0C and PQASW Picture Quality

Describes the operation of the PQA

/\
Analyzer User Manual application software. @ + <= + .
(077-1 1 37-XX) w;;;;.:‘l'ektronix.com
VQS1000 Video Quality Software Quick Describes the operation of the
Start User Manual - +

(077-0489-xx)

VQS1000 application software.

www. Tektronix.com
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The Tektronix Multiplexer provides off-line multiplexing of ATSC, MPEG-2,
DVB, and ISDB transport streams.

= Tektronix Multiplexer - D:¥Test Streamsidvb_625_mcpc3.mpg

File Edit Wiew Options Muliplex ‘Window Help
sl@R| o]0 e Ble]k] =] | 1] SlmfE el ool | =@
- Navigator: D:\Test Streams\dvb_625_mcpc3.mpg [=[B]5¢} - section: NIT_actual Network ID 0 Version 0 Section 0 [Pid 16 (0x
—HED Metwork 1D 0Version 0 5Section O [Pid 16 (04101
{} table_header
& network_descriptors_length =17

=I-{} descriptorz
=-{} network_name_descriptor
EQ descriptor_tag = B4 [0=40]

3[, P5I/51 Tables

& descriptor_length = 15
320 network_name = Dennis’ Metwork,

T @ tranzport_strearn_loop_length = 30
= ER O arsport_stieam [T 505
@rsT Mo e e
& 50T _actual 01 POR_SUBE ™o fify
- o1+ tranzport_sl
& 10T 100 riginal_ e Delete
o1 ey
& 10T

& transport_d| o
{1 descriptars Copy
L 151 CRC_32 = 129248

&) T5_description

Paste

Properties

Programs Tab|ele‘ids I

= Event Log: D:\Test Streamsidvb_625_mcpc3.mpg

Cakegor: Reference Zornrnent
Tirne 12:07:54 Demultiplex started

Information Found PAT,

Information Stream bitrate is 27,647 1Mbit/s,

Information Stream length is 31.2317s,

Information Found 19 pids and 21 sections,

Tirne 12:07:36 Demultiplex complete, Demultiplex bitrate 347.61Mbit/s,

Filter OFF |DVE TS Rate 27.6471Mbitfs [Duration 31.2317s |Standard [Ready | 4

Transport streams (TS), Elementary Streams (ES), Packetized Elementary Streams
(PES), and Packet Identifiers (PID) can be selected, manipulated and recombined
to form customized, synthesized transport streams. Program Specific Information
(PSI), Service Information (SI), and Program and System Information Protocol
(PSIP) are often referred to as simply SI in this section.

The functions provided include:

B Wizards for common tasks, such as populating streams with Program Specific
Information/Service Information/Program and System Information Protocol
(PSI/SI/PSIP), and programs.

m  Table contents that are displayed in and edited from structure diagrams (tree
diagrams).
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m  Transport Streams that either conform strictly to the standards selected for
interpretation or have precisely engineered, known, nonconformances.

B Two or more instances of Multiplexer can run concurrently. This allows table
information to be copied from one file to another.

B The source data for nonconformant streams can be saved in a raw format,
which can be quickly reloaded as the basis for generating more stream data.

m  Conformance of edits to the standards is checked interactively and enforced
by default. Checking and enforcement may be turned off when specifying
nonconformances to be introduced into the new transport stream.

On opening, streams are analyzed and displayed according to the selected
standard: MPEG, DVB, ATSC, or ISDB. Scripts are used by the analysis process;
this allows private PSI/SI tables and descriptors to be defined.

NOTE. Most examples given in this section of the manual are based on DVB SI.
You should remember that the Multiplexer is equally at home with all major DTV
standards, MPEG-2, DVB, ATSC, and ISDB as well as the major extensions to
those standards.

The Transport Stream Analyzer program should always be used for reliable
analysis of transport streams containing DSM-CC or MPE addressable sections.

In the absence of TS Analyzer, it is acceptable to use Multiplexer for analysis,
provided that the DSM-CC or MPE scripts are first applied using Expert mode in
the Stream Interpretation dialog box (See page 7, Scripts.)

However, when multiplexing streams containing DSM-CC or MPE addressable
sections, the related scripts must not be active.
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Multiplexer in Playout You can initiate a playout in the Multiplexer application using the playout feature
mode  as soon as the multiplex operation is complete. Multiplexer creates a temporary
transport stream in the location specified by the Playout Settings and then initiates
a playout by loading this file into the player. To play the stream in the loop mode,
enable the loop mode in the Playout settings.

To open Playout Settings dialog box, select Multiplex >Playout settings.
Playout Settings x|
Port number used by the MPEG player application: I

Path of the MPEG player application:

IC:\Frngram Files Tektronix{MpegPlayer MpeagPlaye Browse ... |

Path of the folder where the temporory playout files are generated:

I C:\Temp\Tektronix{Tempaorory Playout Files Change ... |
Mame of the playout file:
I Playout.mpg

K Cancel

NOTE. It may be necessary to run the Multiplexer as an administrator and disable
the Window's firewall. for the playout feature to function.
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H.264 ES input characteristics

PTS/DTS timestamp
generation

H.265/HEVC support

H.264 elementary streams received by the Multiplexer should comply with
ISO/IEC-14496-10/2005 Rec. H.264. Transport streams generated by the
Multiplexer should comply with ISO/IEC-13818-1/2000/AMD_3/2004.

B The generated transport stream will contain DTS and PTS values calculated
at a constant frame and bit rate. A default frame rate of 25 fps will be used,
unless otherwise specified by the user or derived from the optional VUI
(Video Usability Information) parameters within the stream.

B You can specify the constant bit rate or it may be detected automatically by
scanning the transport stream. The scanned bit rate is calculated as follows:
Scanned Number of Bytes

Bit rate =
(Number of Frames/Frame Rate)

B [f the transport stream contains the optional HRD (Hypothetical Reference
Decoder) parameters, then the contained maximum bit rate value is displayed
to the user as a guide.

B [fthe transport stream contains optional HRD parameters together with SEI
(Supplemental Enhancement Information) Buffering Period and Picture
Timing messages then the PTS and DTS values will be derived from them.
That is, the PTS/DTS values will always be consistent with any ES layer
parameters.

The Multiplexer will open and remultiplex CBR transport stream files that
include H.265/HEVC video elements. The streams received and generated by the
Multiplexer should comply with the following standards:

B H.265/HEVC: ITU-T H.265, Series H: Audiovisual and Multimedia Systems,
Infrastructure of audiovisual services — Coding of moving video, High
efficiency video coding April 2013

m HEVC in TS: ISO/IEC 13818-1:201X/PDAM 3 (E) Rec. ITU-T H.
222.0/Amd.3, Information Technology — Generic Coding of Moving Pictures
and Associated Audio Information: Systems, Amendment 3, Transport of
High Efficiency Video Coding (HEVC) Streams over ITU-T Rec H.222.0 |
ISO/IEC 13818-1

Be aware of the following:

®  The Examine TS window allows you to copy H.265/HEVC elements or
programs from another CBR transport stream file into a new Multiplexer file
(See page 59, Examine Transport Stream window.)

®  The Multiplexer will not import H.265/HEVC elements directly from disk
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Starting the program

The program can be started by selecting the Tektronix Multiplexer option from
the Start > All Programs > Tektronix MTS4000 > Generators menu or

by double-clicking on Deferred Generators from the desktop and selecting
Multiplexer.

L Tektronix MT54000

Q OptionKey Wizard

J. Analysers

| Generators
E Carousel Generator
55 1SDB-T Remux
;1 Multiplexer
7 T Editor

1. Player

L. Utilities

Mulkiplexer

Initial appearance ~ Once the program has started and is ready for use, it will open a Main Window
that looks like the following figure:

File View Opuans ‘Window Help

e{@®| 1| o] elmle ] =] | =] 2= wlslE ool | =

Fiker OFF 1508 [

[Ready Iy

Use the View menu to select a standard that will be used to interpret transport

streams, and then open a transport stream file or import a multiplex configuration
file.
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Initial menu options When the application is opened, you are presented with options relevant only
to opening new or existing multiplex files. Options that are not relevant at this
time are inactive (grayed out).

File menu options. The following table lists the options available in the initial
File menu.

Table 1: File menu options

Command Function
New Opens new multiplex configuration file.
Open Opens an MPEG file for use. The program

opens the file selection dialog box allowing
you to choose the required file.

Examine TS Opens the Examine TS window, which allows
a brief summary of the stream to be viewed
before it is subjected to full analysis.

Close Currently disabled

Import... Opens a previously saved multiplex
configuration file.

Export... Currently disabled

Export As... Currently disabled

1 <filename> A list of the four most recently used files. If

2 <filename> the program has recently been installed the

list may be empty or hold less than four files.

3 <filename> . . .
4 <filename> Selecting a file name opens that file for use.
Exit Finishes running the program.

View menu options. The following table lists the options available in the initial
View menu.

Table 2: View menu options

Command Function

Interpretation Opens the Stream Interpretation dialog box.
This allows the scripts to be used in stream
analysis to be selected.

Event Log Opens the Event Log window.
Toolbar Displays or hides the Toolbar.
Status Bar Shows or hides the Status Bar.

A check mark next to an option indicates that the object is currently visible.
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Scripts

MTS4000 and MTS4SAV3 Generator Applications User Manual

SI scripts are necessary to enable SI table and descriptor data to be analyzed
successfully. Scripts are used to enable analysis of SI data dictated by the various
international standards, for example, MPEG-2, DVB, ATSC, and ISDB.

Essential scripts are installed and enabled using the Stream Interpretation dialog
box. In the absence of any enabled scripts, only the PAT table will be analyzed; all
other data will be presented as private data.

If a suitably configured script is selected and enabled before a stream is opened,
custom data will be analyzed when the stream is opened. If the script is not
selected or enabled, the stream will be analyzed, but any custom data will be
reported as either an error in the stream configuration or as an elementary stream
PID.

Scripts can be selected and enabled only when no files are open. The Stream
Interpretation dialog box is available when a file is open, but all activity is
disabled.

Note that a script file will not be used for analysis until:
®  Jtis present in the Scripts text box in the current analysis mode.

B It is successfully enabled by closing the Stream Interpretation dialog box
using the OK button.
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Handling scripts

Cptions — Mulkiple:

Inkerpretation...

Section Yiew

Ewvent Log
Component Bitrakte
Component Durakion
Available Bitrate

Synchronize

v Toolbar
v Sktatus Bar

To open the Stream Interpretation dialog box, with all files closed, select View >
Interpretation. The Stream Interpretation dialog box is displayed as shown.

Stream Interpretation f@
Standard Settings [rata Standards
B
Baze Standard |D\-"B ﬂ ™ MHP
Fegion |Nnne ﬂ

g Reload Scriptz

o
3] _

a8l Cancel

i

The top half of the dialog box is concerned with selecting scripts. The Scripts
text box lists the scripts currently selected. The area adjacent to the text box
is dedicated to Expert mode controls.
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Selecting scripts

The selection area of the Stream Interpretation dialog box is best viewed and

used from left to right.

In the Base Standard section, select the MPEG-2, DVB, ATSC, or ISDB standard

for analysis.

The selected standard dictates the availability of the remaining options in the
Regions and Data Standards sections.

In the Regions section, select the country-specific region to be added to the basic
standard scripts. If you select None, only the standard scripts are listed in the
Scripts text box. The remaining country-specific extensions add extra scripts to
the current listing. The choice of Regions option dictates the availability of the
options in the Data Standards section.

Base Standard Description Region

MPEG-2 only Interprets and analyzes None
the packets in Custom
conformance to the
MPEG-2 standards.

DVB Interprets and analyzes None
the Transport Stream Custom
Packets according to UK DTG
the specifications of Australian
the DVB and MPEG-2 Nordig
standards.

ATSC Interprets and analyzes None
the Transport Stream Custom
Packets according to
the specifications of
the ATSC and MPEG-2
standards.

ISDB Interprets and analyzes ISDB-T
the Transport Stream ISDB-S
Packets according to ISDB-T (One segment

the specifications of
the ISDB and MPEG-2
standards.

ISDB-TB (Brazil)
ISDB-TB (One segment Brazil)

The Data Standards section offers a choice of data-specific scripts.

NOTE. The scripts listed by default reside in the default installation directory
(tektronix\scripts). Other directory locations can be specified in Expert Mode. All
selections will be retained between sessions.
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10

Checking syntax

Expert mode

Scripts are syntactically analyzed when the OK button is selected. They are also
checked when the application is opened. A fault in the syntax of a script will not
necessarily prevent a stream from being analyzed, but it may result in incomplete
analysis of the stream.

Scripts listed in the Scripts text box will not be used for stream analysis until they
have been successfully checked (the application has been opened or the Stream
Interpretation dialog box has been closed with no script-related error messages
issued).

For an intermediate check of scripts listed in the Scripts text box, select the
Reload Scripts button. This performs the same action as the OK button but
leaves the dialog box open.

Syntax errors will be indicated and reported in the Event Log (See page 58.).

El Expert Mode allows you to select and customize the scripts to be used in
stream analysis and multiplexing. Note that when the expert mode is selected, the
Custom extension option is automatically selected and the management buttons
are enabled. In Expert mode, all scripts become available to be added to the script
list. The scripts will be checked and loaded, ready to be used for analysis, when
the OK button is selected.

iy

% Custom

Scriptz

DWE.zcp I E-]
OB _AC3Deszchptor.zcp
MHP. zcp

The script management buttons act on the scripts currently listed in the Scripts
text box.
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Table 3: Script management

Buttons Function
ﬂ Script files are parsed in the order that they

are listed; in some circumstances this may be
ﬂ important. To move a file in a list, highlight the file

name and select the Up or Down arrow button as
required. Each press of the button will move the file
up or down one place in the list until it reaches the
top or the bottom.

H Add a script to the list: A standard Windows file
selection dialog box is opened. The default file
extension is .scp. Select the required file. The
selected script will be added to the bottom of the
list. If necessary, move it using the Up and Down
buttons.

Scripts can be loaded from any directory.

ﬂ Delete the highlighted script.
ﬂ Change scripts default directory: by default, all
scripts are found in a default directory created

during installation (tektronix\scripts). This button
can be used to set a different default directory.

Note that all scripts supplied by Tektronix in the
default installation are installed in a single directory;
as long as this directory is designated as the default
directory, they will work satisfactorily.

i View highlighted script with the associated
= application; by default, script files are associated
with the ScriptPad utility.

For a script file to be viewed successfully, the file extension (.scp) must be
associated with a text editor in the Microsoft Windows environment. The MPEG
Test System installation program by default associates a script editing utility
called ScriptPad; you can use another text editor, for example, Microsoft Notepad,
if preferred. ScriptPad is a simple script editor that can be installed with the
MPEG Test System. Scripts can be viewed and edited as required (depending
upon the file permissions).
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Opening a stream

Opening an MPEG stream

12

When opening a multiplexing, you can, open an existing stream or to open a
previously prepared multiplex configuration file.

When a preparing a stream to be multiplexed, you can:
B Create a new null stream (using File > New)
B Open an existing stream

B [mport a multiplexer configuration file

Any file holding a recorded or synthesized sample of a stream that conforms to the
relevant standards can be opened and used as a basis for a new multiplex. Note
that the Examine TS option can be used to preview stream. (See page 59.)

Some nonconformant streams can be opened, although, only the conformant
parts can be edited usefully. Any tables that are carried in a conformant PID
and have the correct syntax will appear in the output transport stream, as will
any elementary streams (whether referenced by a table or not) which are in the
input transport stream.

To open a file holding a transport stream, select File > Open. If the required file is
in the list of recent files, open it from the list using the Open File dialog box.

EI-N View Options  \Window  Help
Pl ZErl+R

CIpern. ..
Examine TS Chrl+T

Impart, .. Chel4+I

1 [\ Test Streamsiatsc_gkables
2 lucentls

Exit

Alternatively use the Ctrl+O keyboard shortcut or drag the file from Windows
Explorer and drop it into the Multiplexer window. A shortcut button is available
on the Toolbar for opening a file.
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Opening multiplex  Any file holding a recorded or synthesized sample of a stream, which conforms

configuration files  to the relevant standards, can be opened. Many nonconformant streams can be
opened provided that the PAT, PMT, and MGT tables correctly specify all the
other tables and their PIDs.

Multiplexer is used for generating both conformant and nonconformant streams.
Having generated a nonconformant stream, it may not be possible to successfully
open it again in Multiplexer.

The specification for a new transport stream may be saved to a multiplex
configuration file. This also saves time for opening large MPEG files, since the
specification contains the results of the analysis from opening the original MPEG
file.

NOTE. The multiplex configuration file does not contain a copy of the transport
stream; instead it refers to the original MPEG file by the full path name. Deleting
or moving the MPEG file will result in a dialog box prompting for the new
location of the file.

Double-clicking on a *.muxml or *.mux file in Windows Explorer will open the
file in a new instance of Multiplexer.

Importing a file. Importing opens a multiplex configuration file and the MPEG
file on which it is based.

To open a previously exported multiplex configuration file, select File > Import.
If the required file is in the list of recent files, it can be opened from the list to
save using the Import file dialog box.

F=8 Wigw Options  Window  Help

MeEw Chel4M
Cpen... Chrl4+0
Examine TS Chel4+T

Imnport... Ckrl+I

1 lucentl1s
2 D1\ Test Streams!atsc_gtables

Exit
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Alternatively, use the Ctrl+I keyboard shortcut or drag the file from Windows
Explorer and drop it into the Multiplexer window.

NOTE. Multiplexer reads the name and location of the MPEG file from the
multiplex configuration file and then opens it automatically. The previously stored
changes in the configuration file are applied to the display.

Note that the import dialog box offers a choice of file types: *.muxml, *.mux
and *.*.

File name: I Oper

Filez of twpe; IM Iti

Multiple:-cer Files [*.rmus)
All Files [#7]

Initial stream analysis =~ The Navigator Tables view window is opened as soon as a file is opened or
imported. The program now starts to analyze the file with the loaded scripts to
determine what tables are present.

As the file is analyzed, the Top Levels of the Transport Structure diagram are
drawn in the Navigator window. The right pane in the Status Bar at the bottom of
the program window shows the progress of analysis.

[Filter OFF [DVE | | |Standard |Demultiplexing |F31% Complete | NN El

|Filker OFF |D%E  |T5 Rate 24 1283Mbitds | Duration 21,8748 |Standard |Ready | | -

Files that are imported require less processing because they were analyzed in the
session from which they were exported.
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What to do next  The file can now be manipulated to form a specification with which to synthesize
a new transport stream. Tables, elementary streams, and PIDs are viewed and
selected using the Navigator views. The components of any table selected in the
Navigator views are viewed and selected using the Section View window.

Tables, Programs and PIDs can be added and modified using the wizards or
manually. A selection of menu options is provided to facilitate manipulation of
the data.

The Multiplex menu has options to inhibit and re-enable forced conformance to
the selected standards.

Having manipulated the file, a transport stream can be synthesized to the new
specification by the multiplex engine. The engine is started from the Multiplex
menu or using a toolbar button. The source file is used as reference data by
Multiplexer and the output written to a different file.

The following illustration gives an overview of the Multiplex process.
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) Data Structure
changes

.
e

/
L] s e
|

Open/Import

Any file holding a recorded or synthesized
sample of a stream that conforms to the
relevant standards can be opened. (See
page 75, Opening an MPEG file.)

Importing opens a multiplex configuration file
and the MPEG file on which it is based.

(See page 13, Importing a file.)

Transport Structure Demultiplex

As the file is analyzed, the Top Levels of the
Transport Structure diagram are drawn in the
Transport Navigator.

(See page 14, Initial stream analysis.)

Transport Structure Modifications

The file can now be manipulated to act as the
specification to synthesize a new transport
stream. The tables and elementary streams
are viewed and selected either with the aid
of Wizards or in the Navigator windows.

Output/Export

The Multiplex Engine synthesizes a new
transport stream and writes it to an MPEG
file.

To ensure that the specification for any
synthesized stream can be reused, it can be
saved to a multiplex configuration file.

(See page 107, Multiplexer - Multiplexing
transport streams.)
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Closing files

To close the files, select File > Close. This will close both the MPEG file and any
multiplex configuration file that is open.

@-8 Edit Wiew Options

Examine TS Crrl+T

Export, .. Chrl+E
Expaort As...

Ezxit

A shortcut button is also available on the Toolbar for closing a file, which has
a standard file close symbol.

=@ R

If a multiplex configuration file has been edited, and the changes not exported, the
program will ask if the file should be saved.

Select Yes to export the file, No to close the file without saving, or Cancel to undo
the close command and keep the file open.

Multiplexer |

& Save changes to AT est.mpg?
o | Eanu:ell
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Multiplexer - Menus and controls

Menu options

18

File menu options

This section describes the various menu options, toolbar controls, status bar,
icons, and user interface.

The following pages describe all of the menu options. Since many of the options
are context sensitive, they will be available only when their function is appropriate
for the selected display or window element. When a menu option is not available,
the option is grayed out.

The following table lists the options available in the File menu.

Table 4: File menu options

Command Function

Close Closes the current file. This option is
available as soon as analysis starts. If the
wrong file is being opened, or the wrong
options are selected, selecting this option will
abandon the analysis and close the file.

Examine TS Opens the Examine TS window, which allows
a brief summary of the stream to be viewed
before it is subjected to full analysis.

Export... Exports the current multiplex specification
in a form that can be imported even if it no
longer generates a conformant transport
stream. This option is disabled when no file
is open.

Export As... Exports the current file, as above, and allows
a different file name to be specified. This
options is disabled when no file is open.

Exit Closes any file that is open and terminates
the program.
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Edit menu options

View menu options

The following table lists the options available in the Edit menu.

Table 5: Edit menu options

Command Function

Add Adds a table/section/loop to the currently
selected item in the Navigator or Section
View.

Modify Edits the information in the currently selected
field or item.

Delete Deletes the item currently selected.

Cut Cuts the current selection from the Window.

Copy Copies the contents of the current selection
to the clipboard.

Paste Pastes data from the clipboard to the part of
the transport structure that holds that type
of data.

Export Payload Extracts and exports the payload of the

source transport stream PID in the form of a
simple data file.

Export Elementary Stream

Removes the transport stream PID and
PES headers and exports the remaining
information as a simple data file.

Export Section Data

Extracts and exports section data. The
created file can be imported as ES using
Multiplexer's Add function or as Sl using the
Import Section Data option (see next option).

Import Section Data

Imports Sl data from a file and analyzes it.
The section is added to the Navigator view.

The following table lists the options available in the View menu.

Table 6: View menu options

Command Function

Interpretation Displays a read-only dialog box for viewing
scripts that have been selected for analysis.
See Initial Menu Options, (See page 255.)

Section View Opens the window and displays the table
section currently selected in the Navigator
view.

Event Log Displays the list of events that are recorded

in the Event Log.

Component Bit rate

Displays a graphical comparison of the
stream bit rates.

MTS4000 and MTS4SAV3 Generator Applications User Manual
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Options menu options

Table 6: View menu options (cont.)

Command

Function

Component Duration

Displays a graphical comparison of the
stream component durations.

Available Bit rate

Displays a graphical view of the bit rate in
the stream.

Properties Opens a properties dialog box for editing
the currently selected item in the Transport
Navigator window.

Zoom In Zooms in the Available Bit rate and
Component Duration views.

Zoom Out Zooms out from the Available Bit rate and
Component Duration views.

Synchronize Synchronizes zoom levels of the Available Bit

rate and Component Duration views (toggle).

Show Cursor

Shows or hides the cursor in the Available
Bit rate and Component Duration views.

Toolbar

Shows or hides the Toolbar.

Status Bar

Shows or hides the Status Bar.

The following table lists the options available in the Options menu.

Table 7: Options menu options

Command

Function

Display Filter

Opens the SI Filter dialog box.

Single Section View

Selects single or multiple section view. When
disabled, multiple section views can be
opened.

Program Wizard

Invokes the Program wizard.

Transport Wizard

Invokes the Transport wizard.

H264/H265 Bitrate detection settings

Opens the H264/H265 stream bitrate
detection settings dialog box. (See
page 39.)
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Multiplex menu options

The following table lists the options available in the Multiplex menu.

Table 8: Multiplex menu options

Command Function

Start Starts the Multiplex Engine, to synthesize a
new transport stream file.

Stop Aborts multiplexing. The output file is closed

and contains all of the data synthesized
up to the point where the multiplex engine
stopped. This option is available only while
the Multiplex Engine is running.

Standard Mode

Enforces conformance to the selected
standards when editing some fields that can
be generated automatically.

Expert Mode Inhibits the above conformance checking so
that nonconformant files may be created.

Report Provides the option of printing all or part of
the transport structure to either a file or a
printer.

Seamless When enabled, the program specified in

Seamless Settings is processed and made
seamless.

Seamless Settings

Opens a dialog box in which the Make
seamless parameters are specified.

Playout

When enabled, generates and captures
MPEG-2 transport streams that are compliant
with ATSC, DVB, and ARIB standards.

Playout Settings

Opens the Playout Settings dialog box in
which path of the MPEG player application
and the folder where the temporary files are
specified.

Loop

Sets whether the stream is output using the
looping method.

Update

Opens a dialog box in which the parameters
in a stream are updated when looped.
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Window menu options

Help menu options

The following table lists the options available in the Window menu.

Table 9: Window menu options

Command Function

Cascade Cascades the open windows when Options > Single
Section View is disabled.

Tile Tiles the windows horizontally when Options >

Single Section View is disabled.

Arrange Icons

Aligns icons of any minimized windows at the
bottom of the program's main window.

1 <window title>
2 <window title>
3 ... etc.

Makes the named window active, putting it on top of
any window that had been hiding all or part of it.

The following table lists the options available in the Help menu.

Table 10: Help menu options

Command

Function

About Multiplexer

Opens a dialog box that displays the program version
number and license number.
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Toolbar
:n?”l.' — o & | o — [ o
@& B | o eolm|ree| =] e | =] oBl@[D ex(ew] s Gl (%] | mfEr
Toolbars provide a set of convenient shortcuts for the more frequently used menu
options. The buttons are context sensitive and are enabled or disabled depending
upon the currently highlighted view or the action being performed.
The Toolbar can be hidden from view by selecting View > Toolbar.
Status bar
The Status Bar may be hidden from view, but when displayed it is always at the
bottom of the main window. For example:
Standard Usermode  Processing
interpretation
Filker ON  |DVE T5 Rate SMbitfs Duration 9.99991s |Standard Ready
Message Filter TS rate TS duration Progress

The following information is displayed from left to right on the Status Bar:

Message field. Provides a description of any button or menu option over which
the cursor pointer is placed. Other noncritical messages may also be shown.

Filter status. Indicates the status (On/Off) of the SI Filter.

Standard interpretation. Indicates the selected standard with which the file is
processed: MPEG-2, ATSC, DVB, or ISDB.

TS rate and duration. Shows the transport stream rate and the duration at that rate.
A default rate is displayed during initial analysis.

User mode. Shows the User mode selected: Expert or Standard. The Standard
mode prevents changes to certain fields. The Expert mode enables editing.

Processing status. Indicates the progress (%) during initial analysis and
multiplexing.

Processing progress. Indicates the progress during initial analysis and
multiplexing.

The Status bar can be hidden from view by selecting View > Status Bar.

NOTE. The status bar (Standard interpretation) displays ISDB-T SS whenever the
ISDB interpretation with Single segment extension is selected.

MTS4000 and MTS4SAV3 Generator Applications User Manual 23



Multiplexer - Menus and controls

User interface

Title bar
\ = Tektronix Multiplexer - C:\Mest streams\Sym5.mpg

Menu bar_>F\Ie Edit View Options Multiplex  Window Help
| [er 5= |

& &) ol

Right-click menu

[ -] S18J5 gl oloz] | e

Toolbar -7

AEE

+ Navigator: C:Mest streamsiSym3.mpg = Section: NIT_actual Netdbrk ID 43981 Version 0 Section 0 [Pid 16 {0x10] [ |[5][5
P PSI75] Tables - Metwork 1D 43951 Version | Section 0 [Pid 16 [0x10)]
'+' BAT +-{} table_header
() EIT_actual_of % zelwo}):ﬁdescnplorsjeng h=42
~EINL C‘ua‘ & llansppurl_sllaam_\uup_\a gh=13
& ={}
¥ E’;‘; =) (}_g:ansport_st
+HE ST _actual oft tra_"sw" 1
+ETOT S vt e
* o =] {j descript
+-{} satel descriptor
Navigator 191 CRC_32=13g  Paste 75]
area -
Section area °
< >
Programs  Tables | Pids
0g P& |
Category Reference Comment
Time 11141116 Demulkiplex started
Infarmation Found PAT,
Infarmation Stream bitrate is 8Mbitjs.
Infarmation Stream length is 59,972s.
Infarmation Found 9 pids and 9 sections.
Time 11:41:17 Demultiples: complete. Demultiple: bitrate 479, 776Mbit/s.
Log view ——— e
Status bar — s addnod Filter OFF |DVE TS Rate aMbits Duration 59,9725 [Standard Ready
(L04-008
NOTE. The Menu Bar contains the complete selection of options available in
the Multiplexer. Shortcuts to options are available through the toolbar and
context-sensitive shortcut menus.
Icons  Icons are used throughout the Multiplexer user interface to help you to identify
components and make visual links with toolbar shortcuts and menu options.
The following table lists all the icons used.
Table 11: Icons
Icon Description  Icon Description
? About (= Program
Multiplexer
4 Add oe Program
"a Group
Ia Audio B Program
stream Wizard
101 Bit field ) Properties
o1 P
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Table 11: Icons (cont.)

Icon Description  Icon Description
B Close S Report
0 Container/Loop of Seamless
. Copy Seamless
Ep: :
& Settings
Current Section
'::l selection
Cut Section
& @ timing
o Delete = Section View
Display Single
i Filter dialog = window
box
Examine Standard
=3
Lo Transport @ mode
Stream
E Exit . Start
ot Expert - Stop
mode
= Export Table
Export As Transport
= 1[' Stream icon
ks Export o Transport
o Elementary Wizard
Stream
Export 7 Unknown
- Payload ;
Equrt - Video stream
Section
Data
- Import View Event
= Section 6’ Log
Data
Modify = View
=] Fo Component
Duration
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Cutting and pasting

Table 11: Icons (cont.)

Icon Description  Icon Description
New View
O = Component
Bit rate
~ Open View
e = Available Bit
Rate
Paste —_ Playout-
&2 ﬂ Playout the
created TS
using Mpeg
Player
E Loop " d Update

Table types, sections, and PIDs can be cut, copied, and pasted using the Windows
clipboard. Only one selection can be held on the clipboard at a time. Alternatively,
a selection can be dragged and dropped using the mouse.

Cutting a selection to the clipboard. A selection (table type, section or PID)
can be deleted and automatically placed on the Windows clipboard. It can then
be pasted to a different file or back into the current file. Highlight the selection
in the Navigator Tables or PIDs view and select Edit > Cut or use the Ctrl+X
keyboard shortcut.

Copying a selection to the clipboard. A selection (table type, section or PID) can
be copied to the Windows clipboard. From the clipboard, it can be pasted to a
different file or back into the current file.

Highlight the required selection in the Navigator Tables or PIDs view and then
select Edit > Copy or use the Ctrl+C keyboard shortcut.

Pasting a selection from the clipboard. More than one instance of Multiplexer can
run concurrently on a machine. A selection (table type, section, or PID) can be
pasted from the clipboard into any open transport stream file. The contents of the
clipboard are not affected by the paste operation, so the section can be pasted to
many files and more than once to the same file.

Activate the Navigator Tables or PIDs view of the required transport stream file
(that is, in an instance of Multiplexer). Then select Edit > Paste or use the
Ctrl+V keyboard shortcut.

The section or version is always appended to the end of the list under the
appropriate table. Program or version numbers are automatically created. If the
table is not present in the multiplex configuration, it will be created automatically.

MTS4000 and MTS4SAV3 Generator Applications User Manual



Multiplexer - Menus and controls

Dragging and dropping A concept familiar to Windows users is "drag and drop" in which files can be
highlighted by clicking on them with the mouse and then dragged and dropped to
a new location, either in the same application or across applications.

In Multiplexer, the main uses of the drag and drop feature are to modify
multiplexes and to build new ones.

Elements can be dragged within Multiplexer, or from the Multiplexer Browser,
Windows Explorer or other instances of Multiplexer.

The program references and the numbering will be automatically added and/or
updated when a new program is dropped onto the Navigator Programs view.

NOTE. Only the MPEG aspects of the transport structure are updated. Tables
specific to DVB and ATSC are not updated.

Manipulation in Program view.
The following manipulations are available in the Program view:

B When using the Navigator Program view, a program can be copied or
dragged. The program can be dropped only on the transport stream node
of the Program view.

®  Only the standard MPEG elements are copied, namely the PAT entry, the
PMT section and the elementary streams. Standard dependent information is
not copied, for example, DVB SDT.

B When a conflict occurs with the target, new values will be allocated for the
Program and PID numbers.

B Elementary streams can also be dragged and dropped between the Program
Views. They can be dropped only onto the elementary stream root node.

®  An elementary stream may have a stream type, a component tag and
descriptors associated with it; this information is retained during a drag and
drop in the program view. The program view displays this information when
the properties dialog box is activated.
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Wizard controls

In the Navigator Programs view, wizards provide you with a step-by-step approach
to building streams to be multiplexed by offering defaults for PSI/SI and the
opportunity to include user-selected programs. The standard previously selected
in the Interpretation dialog box will dictate which PSI/SI components are offered.

There are two major wizards: the Transport Wizard and the Program Wizard.
Other minor wizards may be opened by these major wizards or they may

be opened in a new window to facilitate specific tasks, such as adding EIT
information. When configuring a new multiplex, the Transport Wizard is opened,
followed by the Program Wizard; although, on completion of the Transport phase,
an opportunity to exit the wizard process you have before the Program Wizard
opens. For some detailed operations, only the appropriate wizard can be opened.

At their most basic level, wizards open, in a logical order, the property dialog
boxes that are available when building a stream manually.

The following paragraphs provide a step-by-step description of the wizards.

The following control buttons are provided on the wizard dialog boxes where
relevant:

Next Retain changes made using this dialog box
and move to next dialog box.

Back Discard changes made using this dialog and
return to the previous dialog box.

Cancel Exit the wizard and discard all changes.

Finish Exit the wizard and implement all changes.
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Transport wizard

Creating a new transport
stream

Toolbar icon:
ﬁ
The Transport wizard allows you to easily create a basic stream populated with

the PSI/SI necessary to hold program information. It may also be opened when
PSI/SI is to be added to an existing stream.

The following steps show the screens used in the creation of a DVB stream.

NOTE. When the Transport Wizard is used to populate a new stream, if the
defaults in the various dialog boxes are retained, then the resulting stream will
conform to the selected standard.

1. To open a new file, select File > New.

2. Select the Program tab in the Navigator view.

| Tables | Pids |

3. Select and highlight the Transport Structure element. At this stage of creating
a new stream, this will be the only element visible in the Program Navigator
view.
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4. Select Add from the shortcut menu. The Transport Stream Settings dialog
box appears.

= Mavigatorn: Untitled

. I

Properties

Programs |TEI|:I|ES Fids

The Transport Stream Settings dialog box allows you to set up the transport
stream identity (part of the PAT section) and version. Adjustments can also be
made to the PAT timing, if required, by selecting the PAT button. PAT timing -
see Editing PSI/SI Table Properties. (See page 84.)

Transport Stream Settings &|

'.'lt. Tranzport Stream Tranzpart Stream: ([

P&T Section
ersion Mumber: |0

| Mest > | Cancel

NOTE. You cannot add a PAT with the ISDB interpretation and Single segment
extension selected. When you click Add, the Add a Program wizard is displayed
instead of the Transport Stream Settings.
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5. In the Transport Stream Settings dialog box, click Next to move to the
Optional Tables dialog box. This dialog box allows you to include and
configure basic PSI/SI information if required.

Optional Tables for the S5tream E'
ki Tramspert Stream Select Optional tables for the strean:
PAT Section [ Metwork Information T able [MIT]
MIT | |

[ Time Offzet Table [TOT]

TaT J

[~ Time and Date Table [TDT]

T J

< Back | M et > | Cancel

6. Select the check box next to each table to add the table name. The table name
is added to the graphical representation on the left and the associated buttons

are also enabled. You can modify the settings of the table such as, timing.

For NIT, TOT, and TDT Timing information, see Editing PSI/SI Table
Properties. (See page 84.)
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NIT settings 7. In the Optional Tables for the Stream dialog box, click Settings for the
Network Information Table (NIT). The Set up the NIT dialog box appears.

Set up the it E'
Wersion : 0
Metwork, 1d: |'I [&stra Satellite Metwork, 19.2E] j

Metwark, Mame: ‘

Transpart Stream

Original Metwark 14 |0
Dielivery Spstem Termestrial Settings

(] | Cancel

8. Enter or select the required values and click OK.

NOTE. If a Delivery System other than Undefined is selected, an additional
settings dialog box becomes available, specific to the Delivery System chosen.
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9. Select Next to move to the Transport Wizard Complete dialog box. This
dialog box allows you to review the changes made by the wizard before
confirming the process. The process can be cancelled, thereby losing all
changes, by selecting the Cancel button.

Transport Wizard Complete Pz|

d am

" PAT Tranzport Stream |d - 0 [0x0] Wersion 0 Section 0 [Pid 0 [0=0]]
TOT [Fid 20 [0x14]]
TOT [Pid 20 [0x14]]
MIT_actual Metwark 1D 1 Version 0 Section 0 [Pid 16 [0«10]]

< >

Tranzport Wizard Complete. Add a Progran ‘Wizard v

< Back | Mest » | Cancel |

At this stage in the creation of a new multiplex, if you want to add programs,
leave the Add Program Wizard check box enabled and select Next. If you want to
add them by some other means, clear the Add a Program Wizard check box. The
Next button label will change to Finish, which allows you to exit the wizard and
implement all changes.

When the Transport Wizard has closed, note that the Navigator views are updated
with the new PSI/SI.

Program wizard
2

Toolbar Icon:
The Program Wizard allows you to add programs as required to a stream that is
already populated with basic PSI/SI. Each use of the Program Wizard allows
the addition of one program. Adding more programs requires the wizard to be
opened each time.

If a new stream is being created, the Transport Wizard offers an opportunity
to open the Program Wizard. Alternatively, in the Navigator Programs view,
highlight the Programs node and select Add from the shortcut menu.
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Adding a program to a  To add a program to the transport stream, follow these steps:
transport stream

NOTE. When the Program Wizard is used to add programs to a stream, if the
defaults in the various dialogs are retained, the resulting stream will conform
to the DVB standard.

1. When you open the Program Wizard, either as a continuation of creating a
new stream or as an attempt to add a new program, a dialog box similar to that
shown below is displayed:

Add A Program P§|

hd Tranzpart Stream .
e PAT Section Settings for Program:

TOT Section Program nurmber:
TODT Section

MIT Section Yersion number: |0
I=) Frogram
PHMT Section Program map PID: |32

et 3 |

< Back | Meut » | Cancel |

The values placed automatically in the three displayed fields will be the next
in the sequence of programs. (In the example screen, the stream contains no
prior programs, therefore this is program number 1. PID 32 is used because

that is the first free PID after the reserved PSI/SI PIDs.)

PMT Timing - see Editing PSI/SI Table Properties. (See page 84.)

2. Select Next to move to the Add Service Description dialog box.

NOTE. If ISDB interpretation with Single Segment extension is selected the
program number starts from 8 (default). However, you can enter numbers from 1
to 7.
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Service description dialog
box  be associated with a program.

Add Service Description

The Service Description dialog box allows you to identify the Service Provider to

Et. Transport Stream
P&T Section
TOT Sectian
TDT Sectian
MIT Section
IS Frogram

PMT Section
SOT Section

Add Service Description [

Service Provider Mame:

-

|T ektronix Systems

Service Marme:

|Serviu:e WYz

Service Tupe:

|'I (0= 1] [digital televizion service]

50T @

¢ Back | Hext » |

&l

Cancel

3. By default, the Add Service Description check box is clear. When it is
enabled, a Service Provider Name and a Service Name must be entered and a
Service Type selected from the drop-down list. If no details are provided, the
section will still be created but the relevant descriptors will be empty.

Enabling the Use Single Section check box will cause the SDT descriptors to

be added to the existing SDT section. If the stream contains no SDT section,

the check box is disabled.

SDT timing - see Editing PSI/SI Table Properties. (See page 84.)

4. Select Next to move to the Program Content dialog box.
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Program Content dialog ~ This dialog box allows you to compile a list of elementary streams to be associated
box  with the program in the final multiplex.

Add the Program Content b_<|

51. Transport Stream Set up the shreams:

PAT Section add | Delete | Update |
TOT Section
TODT Section
MIT Sectian Pid | Type | Filename
= Program

PMT Section
SOT Section

Streams added zo far:

|
|

< Back Cancel |

5. Select Add to display the Add Program Stream dialog box. This dialog box
allows you to identify elementary streams to be included in the new multiplex.
You must specify the PID and Stream Type of the new stream. A Component
Tag can also be allocated.

Add Program Stream [$_<|

Stream T ype |2 (0x02] (MPEG-2 Videa) ﬂ

Fid Mumber: |33

Source | Timing | PCR |

File narme: |E:"~D|:u:uments and 5 ettingzhdrinist Browse. ..

RN M PEG -2 video Bitrate: kbiz

Qriginal TS PID: | Extra DTS offset; |0 %
Stream_id: 0 Start each figld in a new pes packet [

[ Componentlag | k. Cancel

If the Component Tag is enabled, it can be referenced by other tables, for
example, the Event Information Table.
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The dialog box consists of three tabbed pages that specify the source of the

stream, its timing within the multiplex, and whether it should be carrying
a PCR PID.

Select a Stream Type from the drop-down list. This will be the Stream Type
allocated to the stream in the new multiplex.

v SN ==
| |

Stream Type

Fid Mumber: ? [ erved]
39 [0=27] [HEWL - H265 Yidea)
40 [0428] [Rezerved]

I Source |'|“|mir1 BE [0x42] [A%S Yidea]

NOTE. The Stream Type drop-down list displays the previously selected stream as
the default type.

7. Allocate a PID Number in which the elementary stream is to be carried.

Section properties Transport Stream 1D 0 Ver... E|

FID l"-.fersin:nn Timing] Subtable Timing]

|1?

Ok | Cancel

8. Enable the Component Tag check box, if required. Enter a Component Tag
number (0-255) in the enabled field.
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Source tab. Use the Source tab of the Add Program dialog box to select and
specify the elementary stream to be included in the new multiplex.

Source | Timing | PCR |

File name: |E:'\test gtreamshS pmd.mpg Browse... |
File tupe: |F'Iease chooze a lype j Bitrate: li kbisz
Original TS PID: Ewtra DTS offzet; %
Strearm_id: [

[~ ComponentT ag ] Cancel

9. Enter an elementary stream File Name. You can enter it directly or use the
Browse button to open a standard Windows file selection dialog box.

10. Select the File type of the selected stream from the drop-down list.

= If you select MPEG-2 video, the bit rate is detected automatically and
displayed in the Bit rate field.

= If you select H.264/H.265 video, the Bitrate Detection dialog box is
opened.

If the video stream contains HRD information, the bit rate is automatically
calculated. (See page 39, Calculating the bit rate for H.264 / H.265 HRD
streams.)

If the video stream does not contain HRD information, the bit rate must be
calculated manually. (See page 40, Calculating the bit rate for H.264 /
H.265 non-HRD streams.)

When the selected file type does not match with the selected file name, an
error message is displayed and you will have to reselect the correct file type.

Error opening file §|

@ Mot Supported LOAS MPEG4 Audio

NOTE. If H.265 is selected and the stream contains errors, then the following
error pop-up appears.

38 MTS4000 and MTS4SAV3 Generator Applications User Manual



Multiplexer - Wizards

-~ "y

Error @

Yideo file has one or more errors in MAL header.File is not valid HevcVideo.
Do you want to proceed with muxing?

QK Cancel

11. If you select H.264 video with SEI stream, a Suppress PTS/DTS insertion
check box is displayed. Select this check box to suppress the PTS/DTS
insertion.

Calculating the bit rate for H.264 / H.265 HRD streams. If HRD information is
detected in the stream, the maximum bit rate is calculated automatically and
displayed in the Bitrate Detection dialog, as shown in the following screen
capture. You can override the calculated bit rate, either by entering a value
manually or by selecting Detect Bitrate.

+ Tektronix Multiplexer - bbc_text.mpg
Fle Edi iew Options Muliplx Window Help

g i (e N e [ o S R I MR o = R SN T BRI P g

* Navigator: bbe_text.mpg

¥ Transport Stream
=1 B8 Frograms (Stream 1d 4103 Version 18)
=} {9 4167 BEC ONE [BBC]
(8 Service Sections
Event Sections
S Eementary [ 1 29)]
8 Pid 600 Stream type: 2 (0x02) (MPEG-2 Videa)
«# Pid 32 (M =
01 Fids01 54
" Pid603S

4231B8CTWO I Gyoam Type |2 10x02) MPEG 2 Video) -

4351 BBC CHOI

4415BBCNEWS | Fid Number, |32

BN a 4479 BEC TEXT
454BBCPARLY  Source | Ting | FCR |

Fle name: [COMLWork\Gana \atearms bus o Browse
Fletpe: [H28Video | Berate l.—kb/s
Original TS PID Bxra DTS offset: |0 s
Stream_id: |0 Stat each section in & new packet 7

[~ CompanentTeg [ Cancel

Bitrate detection H264 stream bitrate detection settings

Progiams [ Tables | Fids

Masimum stresm bisate is 588.8540 Kbils/s Sean

" Sca
Enter the mean bitrate to be sed or et Muliplener detect it SErliEat R

6t # Sean bytes of the source stream
Bitiate: [596.664 Kbits/s  Detect Birate Scan [soo0000 byt

" Scan a percentage of the source stream

Enter the frame rate to be used

The accuracy of the detected bitrate increases with increase of the
percentage of the source stream thatis scanned. Ttis recommended

Frame rate: [1250 = s to scan at least 5% of the stream.
[~ Automatialy start detecting bitrate
Soan seifings . Accept

[Filter OFF DVE TS Rate 24,1283Mbit/s _|Duration 132.374s Standard Ready [

12. When the displayed bit rate is satisfactory, select Accept.

13. To alter the settings used for bit rate detection, before the bit rate is detected,
select Scan Settings.

When you select Scan Settings, the H264/H265 Stream Bitrate Detection
Settings dialog box is displayed.
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The H264/H265 Stream Bitrate Detection Settings dialog box has three
Scan Duration options. Select one of the following options to proceed:

= Scan the entire source stream
= Select the number of bytes in the stream to scan

= Select a percentage of the stream to scan.

NOTE. The accuracy of the detected bit rate increases with the percentage of

the source stream that is specified.

The chosen setting will be used in subsequent calculations. Select
Automatically start detecting bitrate to use the selected setting.

Fi= Edt Vien Options Mubplex Window Help

Calculating the bit rate for H.264 / H.265 non-HRD streams. If no HRD information
is detected in the stream, you must either enter a value manually or use the Detect
Bitrate function in the Bitrate Detection dialog box.

sl R o] o] elmlelw] = =] oo mlsla alal 5] | =fEhr

+ Navigator: bbc_text.mpg

7 Transport Stream
= BB Programs {stream Id 4103 Version 19)
= [ 4167 BBC ONE [BEC]
Service Sections
Event Sections
=5

. Pid 600
gh Pid 37 (Misgina) Sirazm tmae 110,02 040
FEPEPE! Add Program Stream

7> Pid 6035

) 4231 BBCTWO Stieam Type |2 (0402) (MPEG-2 Yideo) -

& (B 4351 BBC CHOX

[ ) HISEBCMEWS | PidNumber: |32

a 4479 BBC TEXT
=@ 954388C PN Sourcs | Tming | PCR |

Fie name: [C-0MLofk Gan streams'bus jnd Browse
Fie type: [H264 Video | Birate: [F22 257
Onginal TSPID: | BamDTSofet 0 s
Stream_id: ,“— Start each section in anew packet I~

Suppress PTS/DTS insertion [

I~ ComponentTag |1 aK o
Frograms [ Tables | Fids P —

= H264 stream bitrate detection settings.
Bitrate detection
Scan

Section 0 [Pi.... [= |[E][K]

" Scan the entire source stream

@ Bcani [s000000  bytes of the source stream

€ Scan a percentage of the source stream

The accuracy of the detected bifrate increases with increase of the:
percentage of the source stream that is scanned. Itis recommended
to scan at least 5% of the stream.

The stieam does not cartain any HAD parameter

Enter the mean bitiate to be used or let Mulliplexer detect i

Bitrate: (1 Kbitsfs  Detect Bitate

Enter the frame rate to be used

Frame rate; [25.00 N

I~ Automatically start detecting bitrate

Scan settings Aecept

[Filter OFF |DVB TS Rate 24.1283Mbit/s_[Duration 132.374s [Standard [Ready

[ [offine | Y |

MTS4000 and MTS4SAV3 Generator Applications User Manual



Multiplexer - Wizards

Timing tab. The Timing tab of the Add Program dialog box is used to specify the
portion of the new multiplex that the selected stream will use. The default start
time is set to 0.002 s.

Source TimiﬂEIIF'EFH l

=

Stop time: ‘59.9995?32592258 2

Loop interval: ‘D £ v Loop

12. Complete the fields as required. The default settings assume that the stream is
to be carried throughout the new multiplex, looping if necessary.

PCR tab. The PCR tab of the Add Program dialog box is used to specify
whether PCR information should be carried with the selected elementary
stream or in a separate associated PID.

Su:uuru:e] Timing PCR |

[ Cary PCR PCR PID: |E‘191
Initial PCR: FCR Interval: me

r r

[ ComponentT ag k. Cancel

13. If the PCR is to be held in an associated PID, disable the Carry PCR check
box and enter a PCR PID number.

14. If the PCR is to be carried with the stream, enable the Carry PCR check box
and complete the remaining fields as required.

Set Defaults returns the settings to their initial values.

15. Select the OK button to complete adding an elementary stream to the listing
in the Program Wizard.

16. More streams can be added using the Add button. Listed streams can be
deleted using the Delete button. Details of listed streams can be modified
using the Update button.
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Event Information dialog
box

42

Add the Program Content E|
=) Frogram Set up the streams:
PMT Section Adld Delete |  Update |
- It Active PIDs .
b Pidk 33 Type: 2 (O] Streamns added so far:
EL Tranzport Stream | Filename

TOT Section C:\Prograr File

HIT Section

|
|

|A
|

< Back | Mext > |

Cancel |

This completes the addition of one or more program streams.
17. Select Next to move to the Event Information dialog box.

For more details about the fields on these tabs, refer to Adding an Unreferenced
Elementary Stream. (See page 89.)

The Event Information dialog box allows you to add the Present and the Following
event information.

Event Information &|

) Program Add event information

PMT Section
+ Ewent Information
=B Active PIDs
al Pid: 33 Type: 2 (040
35:‘ Transport Stream
TOT Sechion
HIT Section

Evert Information Tables [EITE v

Pregent W . Settings
Following o 3 Settings

|
4

< Back | Mest » |

Cancel |

18. If the Event Information Table (EIT) is to be included in the multiplex, enable
the Event Information Table check box.
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19. Enable the Present and Following check boxes as required.

@ Present/Following timing - For more information on Present/Following
timing, see Editing PSI/SI Table Properties. (See page 84.).

20. Use the Settings buttons to open the Present/Following Events dialog box.

Present Events [5_<|

Add | Update | Delete |

Event | Mame | Tirne | Duration |

k. | Cancel

21. In the Present/Following Events dialog box, click Add. The Event dialog box
appears. Add and specify events as required.

Event ['5_<|

Event Id 1 Statusz |4 [running] ﬂ

Start Time | 2008-12-22 11:48:54 AM ~

Event Name |news Durgtion  |12:00:004M =

D escription ||:un the: hour, every hour

Content?
ot Toms |EI [reserved for future uze) j

Stream [tem [T ag) |EI Select Tag

Stream Description |

oK Cancel |
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Program Complete dialog

44

box

22. Click OK.

Present Events E'
Add Update |  Delete |
Ewent | M ame | Tirne | Duration |
1[01]  news 2008A1/512:2753.. 121500
ak Cancel

23. In the Event Information dialog box, click Next to move to the Program
Complete dialog box.

The Program Complete dialog box provides you with a summary of the created
Transport Structure.

Program Complete fE

Press finish to add the new program.

53:. Transport Stream ~
PaT Tranzport Stream [d 0 [0€0] Werzsion 0 Section O [Fid 00
TOT [Fid 20 [0=14]]

TDT [Fid 20 [0=14]]
MIT_actual Metwork. ID - O%ersion 0 Section 0 [Fid 16 [0x10]]
= Frogram

PT Program 7 [0«0001] YWersion 0 Section O [Pid 32 [0=20]]

SDT_actual Tranzport Stream D 0% erzion 0Section 0[Fid1

Evertt Infarmatian

i Active PIDs
wdl Fid: 33 Type: 2 [0202) [MPEG-2 Yidea] File: D:\Test Streamshs w

| >

+

|

< Back | Firizh | Cancel

24. To confirm and implement the Transport Structure, select the Finish button.

Note that the proposed structure is created in the Navigator views.

This completes the procedure of adding a program to a transport stream using the
Program Wizard.
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Multiplexer - Views

Multiplexer contains a number of views, which are displayed in the working area
of the user interface. All of the views can be manipulated using conventional
Windows techniques. The Navigator and Error Log views can be docked against
the edges of the Ul or floated independently of the Multiplexer window. The
Section view can be manipulated within the Multiplexer window, including tiling
and cascading where multiple Section views are displayed.

Each available view displays a different aspect or level of detail of stream analysis
and manipulation.
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Navigator views

The Navigator view contains three subviews or tabs: Programs, Tables, and PIDs.

Program views  The Navigator Programs view extracts and displays system information that is
relevant to programs. Information that is not directly related to programs (for
example, NIT), or that has not been incorporated into a program (for example,
elementary streams not listed in a PMT) will be omitted from the Program view.
The system information is still available for viewing in the Navigator Tables
and PIDs views.

= Mavigator: D:XTest Streamsidvb_ 625 mcpc3.mpg

L Transport Stream
(= EE Frograms [Stream |d 1 Yersion 0]
-HE 1 625 PAL Matrix [Denniz' TW]
- Service Sections
Tranzport Stream 1D 1 Verzsion 05Sechon O[Pid 17 [0x11]]
+ RST Sections
- Event Sectionz
Table ID Oxde Service ID 1 Yerzsion 0Section O[Fid 18 [00012]]
Table ID Oxde Service ID 1 Yerzsion 0Section 1[Pid 18 [00012]]
Table ID 050 Service ID 1 Yerzsion 0Section O[Fid 18 [00012]]
- _ni Elementary Streams [PMT Werzion 0]
«mf Pid 49 Stream type: 2 [0x02] [MPEG-2 Video]
J] Pid 52 Stream type: 4 (0x04] [MPEG-2 Audio)
+HE 2 BBC Clip [Denmiz' TW]
e = |2 Flower Garden [Dennis' TV]

< |
Programz Tablez | Pids

It is recommended that manipulation of programs and elementary streams should
take place from the Program view.

|
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Tables view The Tables view displays a high-level structure of the Program and System
Information Protocol (PSIP), Service Information (SI), and Program Specific
Information (PSI) tables. More detailed payload information can be examined and
edited, for a selected section of a table, using the Section View.

= Mayvigatorn: D:YTest Streamsidvb_625 mcpc3.mpg

?LE. PS1451 T ables

+ BAT
+ CAT
+ EIT_actual_pf
- EIT_actual_scheduls
Table D 0x50 Service I 1 Version 0S5ection O[Fid 18 [0x0012]]
Table D 0x50 Service I 2%ersion 0S5ection O[Fid 18 [0x0012]]
Table D 0x50 Service I 3Version 0S5ection O[Fid 18 [0x0012]]
- MIT_actual
Metwork D0 O%ersion 0Section 0 [Pid 16 [0«10]]
- PAT
Transpaort Stream 1d 7 [081] Yerzsion 0 Section 0 [Fid O [0x=0]]
+ FPrT

+ RST
- SDT_actual
Transpart Stream 1D 1 Wersion 0 Section O [Pid 17 [0x11]]

+E] T0T

+ TaT
+ TS_description

<
Frograms T ables |F'i|:|s

Any PSI/SI information that the program cannot confidently analyze, will be
shown in the PIDs view.

|
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48

PIDs view

The PIDs view displays the PIDs contained in the stream. The PIDs are displayed
in ascending numerical order.

= Mavigator: D:XTest Streamsidvb_625 mecpc3.mpg

ELE. Fids
- 1 Syztemn Information
FAT Tranzport Stream Id 1 [0x1] Yersion 0 Section 0 [Pid 0 [Ox0]]
1 Syztem Information
& Syztem Information
16 Systern Information
17 Seatern Information
18 Sestem Information
19 Spztem Information
- 20 Spzter Information
TDT [Fid 20[0x14]]
TOT [Fid 20[0x14]]
- 48 Spztern Information
PrT Program 1 [0=0001]Yerzion 0 Section 0 [Fid 48 [0=30]]
8 49 Elementary stream ppe: MPEG-2 Video [dvb_B25_moped.mpag]
JJ 52 Elementary stream type: MPEG-2 Audio [dvb_E25_mecpc3.mpg]
- B4 Spztern Information
PT Program 2 [0=0002] Yerzsion 0 Section 0 [Fid B4 [0=40]]
8 65 Elementary stream twpe: MPEG-2 Video [dvb_B25_meoped.mpa]
J1 B8 Elementary strear type: MPEG-2 Audio [dvb_E25_meps3.mpa]
- 30 Spztemn Infarmation
PMT Program 3 [0=0003] Verzion 0 Section 0 [Fid 80 [0=50]]
«f 31 Elementary stream tppe: MPEG-2 Video [dvb_B25_mcpc3.mpg]
JJ 84 Elementary stream type: MPEG-2 Audio [dvb_E25_meps3.mpag]
o 2049 Elermentary stream type: Unknown [dvb_B25_mcpe3.mpg]

+ [+

<

| ™

Program:s J Table:  Pigs

PSI/SI table types are identified in the section nodes of System Information nodes.

Elementary stream PIDs are identified by source and type where possible.
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Section view

The Section View displays the contents of the currently selected section in any
of the Navigator views.

= Tektronix Multiplexer - D:\Test Streamsidvb_625_mcpc3.mpg
File Edt ‘iew Options Mulkiplex Window Help

©]8] 0] | almle]sl 21| ] H@fE a7 ol (=] | R

= Navigator: D:tTest Streamsidvb,_625_mcpc3.mpg = Section: NIT_actual Network ID. 0 Yersion, 0 Section, 0/[Pid 16 {0x10)

e )@ NetwokiD OVesion 0Secton 0[Fid 16 (Ox10]
3[' PSI;iITTab‘ES +-{} table_header
* cat & network_descriptars_length = 17
|

—-{} descriptars
=1-{} network_name_dsscriptar
& descriptor_tag = 64 [0x40]

+ EIT_actual_pf
+HE EIT_actual_schedule

~HED MIT_actual . I & descriptor_length = 15
) on 0 on (0 [Pid 16 (0100} 124 network_name = Denris' Metwork
+ @ PAT & hansport_stream_loop_length = 30
L PMT SR @R ranzport_stream_loop|
* RST =1-{} tansport_stream_id =1 [0x1]
+) SDT_actual 2% trarsport_stieam_id = 1 [0x1]
+ igl 224 original_netwark_id = 0 [0x0]
: 5. deseriton # transport_descriptors_length = 24

+-{} descriptars
120 CRC_32 = 1292468364 [On4d19808c]

Programz  Tables | Pidz

Filter OFF |DVE TS Rate 27.6471Mbitfs  Duration 31.2317s Standard Ready

The Section view is dynamic in that it will be instantly refreshed if a new section

is highlighted in the Navigator view. If no section is selected, the Section view
will be blank.

The lock icon - - adjacent to certain elements of the table in the Section view
indicates that those items have restricted access due to the mode of user operation:
Expert or Standard.
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Syntax of a section ~ The following diagram shows a section from a Master Guide Table (MGT).

- Section: MGT Version O Section O [Pid 8187 (0x1FFB)] M=1E3

- Werzion 0 Section 0[Fid 8187 [0x1FFE]]

—1-{} table_header

f table_id = 199 [0«C7 MGT)

gechon_syntax_indicator =1
gechon_length = 36
table_id_extenzion =0
verzion_number = 0 [0x0]
current_next_indicator =1

gechon_number =10

lazt_zection_number =0

protocol_version = 0 [Dx0]
#  tables_defined = 2 [0x2]
—1-{} tables
- {} 2 [Eal:ule WCT waith current_nest_indicator = 1]
; table_type = 2 [Cable WCT with curent_next_indicator = 1]
: '. table_twpe_PID = 8187 [0x1ffh]
4 table_type_werzsion_number = 0 [0=0]
4 number_bytesz = 0 [0x0]
table_type_descriptors_len = 0 [0=0]
{} descriptors
- {} T-"EEI [RRT waith rating region 1-255)
5 table_type = FE3 [RRT with rating region 1-255]
: '. table_twpe_PID = 8187 [0x1ffh]
4 table_type_werzsion_number = 0 [0=0]
% number_bytes = 0 [0x0]
table_type_descriptors_len = 0 [0=0]
{} descriptors
o descrlptnrs length = 0 [0x0]

Pn 1

» 98242523

» 98242523

| &

The syntax specified for an MGT in the ATSC standard A65 is:

master guide table section () {
table id
section_syntax_indicator
private_indicator
zero
section_length
table id extension
reserved
version_number
current_next_indicator
section_number
last_section_number
protocol_version
tables defined
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for (i=0;i<tables defined;i++) {
table type
reserved
table type PID
reserved
table type version_number
number_bytes
reserved
table type descriptors length
for (k=0;k<N;k++)
descriptor()
/
reserved
descriptor tag
descriptors_length
for (I = 0;1< N;I++)
descriptor()
CRC 32

/

The terms used in this manual to describe the components, represented by nodes,
in the structure diagram are:

Container. A term used to describe a node in the structure diagram

which may contain zero, one or more loops. It is analogous to the for
(i=0;i<loops_defined;i++) statement used to describe the syntax of a table in the
ATSC standards. The container is always preceded by a field which specifies the
number of loops it contains.

Loop. Describes a data structure composed of a specified set of fields and
subordinate loops. The structure diagram shows each loop as a node with the
fields and subordinate loops as children. Each loop node in the section view
represents one iteration of the loop body (the contents of the curly braces { }) in
the syntax specified by the ATSC standards.

Field. Fields are referred to in the standards documents as both data items and
fields. They are the smallest pieces of information that make up a table.

For example, taking an MGT that defines three tables, the Section View represents
the syntax and contents of the Tables container like this:

The loop for the first table, EIT-0 has been expanded to show the fields and
subordinate loops that it contains.
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Syntax of a multiple string
structure

52

== Section: MGT Yersion 0 Section 0 [Pid 8187 [0x1F

EI---{} TaI:nIe Header

table_id = 199 [0xC7 MGT)

5 gection_suntay_indicator = 1

zection_lenagth = 37

table_id_extenzion = 0

werzion_number = 0 [Ox0]

current_nest_indicatar = 1

zechon_number =

lazt_section_number = 0

-----‘.;.':"- protacol_werzion = 0 [0=0]

3% tables_defined = 1 [0x1]

-{} tables
E---{} 256 [EIT-0ta EIT-127)

‘ .;.':'- table_type = 256 [EIT-0 to EIT-127)
2 table_type_PID = 21 [015]
‘.;.':"- table_twpe verzion_number =

.;.':' nurmber_byptes = 16 [Ox110]

i ':'D

=-{}

2525 28252528598

0 [0=0]

5 table_type_deszcriptorz_len = B [0xE]

descriptors

=- {} reqistration_descriptar
pi% descriptor_tag = 5 [0x5]
.;.'?‘ descrptor_length = 4
8% format_identifier = 1094795585
“{} additional_info

~-nyq descriptors_length = 6 [0x6]

The ATSC standard A65 defines a data structure called the Multiple String
Structure. An instance of this structure may contain zero or more strings and each

string may contain zero or more segments. The syntax specified for a Multiple
String Structure in A65 is:

multiple string_structure () {
number_strings
for (i= 0;i< number_strings;i++) {
1SO 639 language code
number_segments
for (j=0,;j<number_segments,;j++) {
compression_type
mode
number _bytes
for (k= 0;k<number_bytes /k++)
compressed_string byte [k]
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Using the notation of container, loop, and field nodes, the Section View represents
the Multiple String Structure in the same way as any other data structure. For
example: an Extended Text Table (ETT) carries its extended text message in a
Multiple String Structure. The default view of a section of an ETT in the Section
View looks like this:

== Section: ETT Yersion 0 Section 0 ETM_Id 16 [Pid 21 [0x15]] M= E

5]

El-{} Table_Header

----- ™ table_id = 204 (0xCCETT)

----- B gechon_syntad_indicator = 1
----- ™ zection_length = 380 [0x1 7]
----- % table_id_extenzion =16

----- ™ werzion_number = 0 [0=0]

----- ™ current_nest_indicator = 1

----- ™ gection_number = 0 [0x0]

----- o last_section_number = 0 [0x0]
----- f protocaol_version = 0 [0=0]

iy ETM_id = 16 [0x10]

F-{} text_emtended message = "First segment of text in the first string's loop."
(74 CRC_32 = Oxffed 41d

Section View displays a node for the extended text message (with as much as
possible of the first segment) from the first string.

Expanding the node reveals a number_strings field which specifies the number of
strings and a container which holds them (strings):

Srpry BEM_d = b (Ukid)
E-{} test_extended_message = "First segment of text in the first sting's loop."
© ™ rumber_strings = 2

-4} strings
B o =Tl O = L R

The number_strings field shows that there are two strings in this example.
Expanding the strings container shows the loop for each string. From this it can
be seen that both strings are in English.

Expanding each of the strings reveals the number of segments (number segments)
that make up each string and a segments container. Similarly, expanding the
segments container reveals segments.

segie BETM_ = Tk [UsiU]
E---{} tewt_extended_messzage = "First segment of text in the first sting's loop,"
E ----- = number_strings = 2
=-{} stings
---{} I50_E33_LanguageCode = eng
P H-{} 150_E39_LanguageCade = eng
YR 27 2 uiEed141d
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Expert and Standard
modes

cegig BENM_id = Tk UxTU]
=- {} text_ewmtended_meszage = "First segrment of text in the first string's loop."
------ .E nurmber_strings = 2
El A4} strings
B- {} IS0_E39 Languagelode = eng
e [50_639_LanguageCode = eng
----- .E number_segments = 3
E-{} segments
---{_"r zegment "First segrent of text in the first sting's loop. "
---{_"r zegment "'Second segment of text in the firgt string's loop. !
-4 zegment “Last zegment of text in the first sting's loop."
= {} ISO_E39 Languagelode = eng
e IS0_E39_LanguageCode = eng
----- .% number_segments = 1
=-{} segments

M-} zegment "First segrent af text in the second sting's loop."
CRC 32 = NufRed1 474

101

The contents of each segment loop define what compression and character set are
used, followed by the actual text. The text is held in the compressed_string field.

The Multiplexer has two modes of operation for conformance checking when
editing table contents. These are selected from the Multiplex menu. The checks
that affect the Navigator are:

Standard mode. Prevents changing the PID of a table whose PID number is
specified in the standard, for example, PID 0x0 carries the PAT.

Expert mode. A warning is displayed and confirmation requested before changing
the PID of a table whose PID number is specified in the standard.

al=ES indow  Help
Start

v Standard Mode
Expert Mode

Fepart...

Seamlass
Seamless Settings...

Playout

Playout Setfings ...
¥ Loop

Update
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An adjacent check mark indicates the mode selected. The mode is also indicated
on the Status Bar.

In the Section View a padlock symbol il is displayed adjacent to all of the fields
that cannot be edited in the current mode. For example, the following screens
show the same tables in Standard and Expert mode.

= Section: MGT Yersion 0O Section 0/[Pid 8187 (Ox1FFB]]

—HED Version 0 Section 0 [Pid 8187 [0x1FFB]]

- {} table_header
2% table_id = 199 [0xC7 MGT)
, zection_syntas_indicator = 1
% section_length = 36
, table_id_extenzion =0
4 werzion_number = 0 [0x0]
cunent_nexst_indicator =1
, zection_number = 0
1% last_section_number = 0

% protocal_wersion = 0 [0x0]

190 tables_defined = 2 [0x2]
=l {} tahles

=4} 2[Cable\-"ET with current_next_indicatar = 1]
97 table_type = 2 [Cable WCT with current_nest_indicator = 1]
% table_type_PID = 8187 [Ox16h]
, table_type_wverzion_number = 0 [0x0]
% number_byptes = 0 [0x0]
, table_type_descriptors_len = 0 [0=0]
} descriptars
= {} ?ES [RRT with rating region 1-255)
97 table_type = 769 [RRT with rating region 1-255)
% table_type_PID = 8187 [Ox16h]
, table_type_wverzion_number = 0 [0x0]
% number_byptes = 0 [0x0]
, table_type_descriptors_len = 0 [0=0]

{} descriptars

190 descriptors_length = 0 [0x0]

2293y 2325222593

395239393

]

95925939393

9% CRC_32 = 04719424

Figure 1: Expert mode

NOTE. The current next_indicator in both Standard and Expert mode cannot
be edited. This is because the field is affected solely by the Section Properties
concerned with Version Timing. (See page 85.)

The selected mode is also reflected in the Wizards that are used to create of
multiplexes. Elements that are restricted in the tables in Standard mode will also
be restricted in the relevant wizard. Similarly, elements that are enabled in Expert
mode will be enabled in the associated wizard.
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= Section: MGT Yersion 0 Section 0 [Pid 8187 (Ox1FEFB)]

=] Wergion 0 Section 0[Pid 8187 [0x1FFB]]
=-{} table_keader
B table_id =199 [02C7 MGT)
section_syntax_indicatar = 1
section_length = 36
tahle_id_estension =0
versian_nurmber = 0 [0x0]
current_next_indicator =1
section_number =0
& last_section_nurmber = 0
& protocal_version = 0 [0x0]
™ tables_defined = 2 [0x2]
=1-{} tablez
=-{} 2[Cable ¥CT with current_next_indicatar = 1]
107 table_type = 2 [Cable WCT with current_next_indicator = 1]
% table_type_PID = 8187 [Ox1§k]
" table_type_wersion_mumber = 0 [0x0]
" humber_bytes = 0 [0x0]
™ table_type_descriptors_len = 0 [0=0]
{} descriptars
=-{} 7B [RRAT with rating reqion 1-265]
107 table_type = 7R3 [RRT with rating region 1-255)
% table_type_PID = 8187 [Ox1§k]
table_| r_rumber = 0 [0x0]
" humber_bytes = 0 [0:0]
™ table_type_descriptors_len = 0 [0=0]
{} descriptars
& descriptors_length = 0 [0x0]
{} descriptars
% CRC_32 = 0x719242ac

BREREEI

5 23928239

5 23222338

Figure 2: Standard mode

(=19

NOTE. The Section View may need to be closed and reopened to update the

padlock icons.
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Structure diagram manipulation

A tree diagram, with the "root node" or highest level component at the top
represents the Transport Structure. A square box indicates components that

contain more information beneath them in the structure.

== Navigator: BBC1AUG27 mpg

if T ables:

@) PAT
@ PMT

Programs  T:

== Navigator: BBC1AUG27.mpg

Y i

) PAT

= PMT
Program 4167 Yerzion 12 Section 0 [Fid 4167 [041047]]
Program 4231 Yersion & Section 0 [Fid 4231 [0:1087])
Program 4351 Yerzion 24 Section 0 [Fid 4351 [Q«10FF]]
Program 4415 erzion 11 Section 0 [Fid 4415 [04173F]]
Program 4473 Version 4 Section 0 [Fid 4473 [04117F])]
@D Program 4543 Yersion 4 Section 0 [Pid 4543 (011BF))

Programs Tat.|ESIF'iu:Is I

Clicking on the box does not select that node. It only shows or hides the next

level of detail under that node.

If the node has a minus sign in the box the level of detail below it is currently
displayed. The lower level(s) may be hidden by clicking the mouse pointer on

the box.

If the box contains a plus sign, there is another level in the node that is currently
hidden. Click the mouse pointer on the box to display the next level of information

under the node.

Components that are connected to a branch of the tree without a square box are
leaf nodes; the accompanying icon indicates the node type. They display the
lowest and finest level of detail available in this diagram. These are either a

Section of a Table or a PID.

Fields in the Section view that cannot be edited directly are indicated by a padlock

symbol, il This protection can be switched off by selecting Expert Mode from
the Multiplex menu. It can be reenabled by selecting Standard Mode.
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Event log

58

Messages about significant events are written to the Event Log from the time a
file is first opened. You can open the Event Log for viewing at any time during
or after the initial analysis. When the initial analysis is done, the mean transport
rate, bit rate for each PEES PID, and a Demultiplex complete message are written
in the Event Log.

= Event Log: lucent1 6

Cakeqory Reference Cornrment

Time 12:25:01 Demultiplex skarted

Information Found PAT.

Error Pid 8187 Section on pid 8187 (0:1Ffb) has unknown table ID 199 (0xc?), Section is disc...
Error Pid 5187 Section on pid £157 (0:1Ffb) has unknown table ID 200 (0xcd), Section is disc...
Information Stream bitrate is 19, 3927Mbit)s,

Information Stream length is 31.0518s,

Information Found 11 pids and Z sections,

Time 12:25:02 Demultiplex complete, Demultiples: bitrate 513, 803Mbitfs,

The start and end times for generating a new transport stream are shown by the
Multiplexer started and Multiplexer completed messages.

Note that when demultiplexing and multiplexing streams, the bit rate at which the
demultiplex or the multiplex is performed is given in the Event Log. This is in
addition to the stream bit rate derived from the stream itself.

When synthesizing a new transport stream any errors or warnings about the new
stream are written to the Event Log between the start and completed messages.

The Category column indicates the type of event. The subject or time of the
event is shown in the Reference column and the details are given in the Comment
column.

The complete text can be copied onto the Windows clipboard, using the Copy
option from the shortcut menu. The text can also be cleared with the Clear
command. Both commands are also available from the Edit menu.
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Examine Transport Stream window

The Examine Transport Stream (Examine TS) window (File > Examine TS)
performs two main functions within the Multiplexer:

m ]t allows you to take an overview of a transport stream before subjecting it
to full analysis.

® It allows tables and programs to be dragged and dropped from the examined
stream to the file that is currently open in Multiplexer.

Examine Transport Stream [Z”E”ls__q
File Edit

Filename: |E:'\Ducuments and SettingshsrachD esktophtest. mpg

Interpretation |OVE TS Rate |8.000 kbit's Duration 9.99991 =

3, PSI1/S1 Tables

L EIT_actual_pi

+ HIT_actual

- PaT

Traneport Stream [d - 0 [0x0] Verzion 0 Section 0 [Pid O [0=0]]

PrAT

SOT_actual

DT

TaT

I S B e B

Frogramz T ables |F'ic|s J

Status : Ready

Menu bar  The Examine TS window menu bar contains only two items: File and Edit.

File menu. The following table lists the items in the File menu.

Table 12: Examine TS - File menu options

Command Function

Open... Analyzes and opens the selected file in the
Examine TS window. Closes the current file.

Close Closes the Examine TS window.

Edit menu. The following table lists the items in the Edit menu.

Table 13: Examine TS - Edit menu options

Command Function

Copy Copies the currently highlighted section to
the clipboard.
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File summary  These fields provide a brief summary of the analyzed file.

Filename: The file name of the examined stream.

Interpretation: The interpretation applied to the stream. This is the same as
that selected in the Multiplexer application through the View menu: MPEG-2,
DVB, ATSC, or ISDB.

TS Rate: The transport stream bit rate derived from the stream.
Duration: The duration of the transport stream.

Status: The status of the stream analysis.

Navigator views  The Examine TS Navigator views correspond to the Navigator views in the main
application. Programs, Tables, and PIDs are shown as they would be after a full
analysis. The PSI/SI tables are expanded and collapsed in the same manner. The
Section view is not available in the Examine TS window.

Examine TS section copy =~ While examining transport streams, it is possible to copy sections to the main
multiplex using the standard Windows techniques: copy and paste or by dragging
and dropping them with the aid of the mouse.

For example, to import a section that is visible in the Examine TS window into the
new multiplex configuration:

1.
2.

60

Select the Navigator Tables view.

Highlight the section to be copied in the Examine TS window and do one
of the following:

= Select Edit > Copy. With the Navigator Tables view active, select Edit
> Paste.

= Using the mouse, place the cursor over the highlighted section, press and
hold the left button on the mouse and drag the section onto the Navigator
Tables view. Release the mouse button.

Note that the copied section is placed in the PSI/SI structure at the correct
location. If any conflict arises concerning similar PID numbers, a new version
is created.
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Examine H.265/HEVC  The Multiplexer allows you to copy H.265/HEVC elements or programs from
streams  another CBR transport stream file into a new file.

NOTE. The Multiplexer will not import H.265/HEVC elements directly from disk.

File Edit

Filenarne:; IC:'\temp'\eiKSDF'_sequence"HSD - Copy.mztz

Interpretation IDVE TS Rate |24.584 btz Diuration IB'I 59394 ¢

3, Transport Stream
E}gg Programs (Stream Id 1 Version Q)
Y =
=1 I Elementary Streams (PMT Version 0)
.d Pid 481 Stream type: 36 (0x24) (HEVC - H265 Video)
... ]9 Pid 482 Stream type: 135 (0x87) (E-AC-3)

Programs | Tables | Pids |

Statuz : Ready
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Sl filtering

62

Table elements can be excluded from the Navigator Tables view using the Display
Filter available through Options > Display Filter.

gl Multiplex  \Windo

v Single Section Yiew
Program \Wizard
Transport Wizard

Scan settings

The following dialog box is displayed:

Filter, 31 Display

Clear Al

Table 10 |MEHE

3

Settings
AT Load ... | ITI
| Apply | Save .. | Cancel |

Exclude all table sections [

tranzport_strearn_id [ Min [
version_number [ Min b an
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Selecting a table for ~ Example: Before filtering, the stream tree may be as shown below:
filtering

= Mavigator: D:\Test Streamsidvb_625_ mepe_100mbps.mpg |Z||E| X

HE. PSI/5S] Tables

+ BAT

+ CAT

+ EIT_actual_pf

+ EIT_actual_schedule

+ MIT_actual

+ PAT

- PMT
Frogram 1 [0x0001]Yerzsion 0Section 0[Pid 48 [0x30]]
Program 2 [0x0002] Version 0 Section 0 [Pid 64 [Dx40]]
Program 3 [0x0003] Version 0 Sechon 0 [Pid 80 [0x50]]

+ RST

+ SDT_actual

+ TDT

+ TaT

+ T5_deszcription

Frogramz  Tables |F'ic|s J

In the Filter SI Display dialog box, table identities are listed in the Table Id
drop-down menu.

Table 10 (=il

L

(w00 PAT -
(01 (1] CAT —
003 [3] TS_descrption

(=40 [64] MIT _actual o

All sections of a table can be excluded by enabling the Exclude all table sections
check box.
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Filter SI Display X
Settingz
Tale ID: (0402 PMT <] Lead. | ok |
Clear All | Apply | Save .. | Canicel |

Exclude all table zections v
[ Min b ax
[~ Min P ax

To preview the result of filtering, click the Apply button.

Note that all references to the PMT tables is removed as shown below:

B

= Mavigator: D:XTest Streamsidvb_625 ... |:

ﬁt. PSI/51 Tables

+E) BAT

CAT

EIT_actual_pf
EIT_actual_schedule
MIT_actual

PAT

RST
& S0T_actual

D

El
.
-
2

[
=
—\ =
LS -
=

g Ny B B

il TS_description

Frogramz  Tables |F'ids

To exclude a range of sections, enable the section by selecting from the Table ID
drop-down list and entering the required range.

Note that section names shown in the dialog box change according to which
table is selected.

64 MTS4000 and MTS4SAV3 Generator Applications User Manual



Multiplexer - Views

To preview the result of filtering, click the Apply button.

For example, the following settings will result in the display as shown:

Filter SI Display X
Settingz
Table ID: [0400 PAT <] | Load. | ok |
Clear All | Apply | Save .. | Cancel |

Exclude all table sections [
transport_strearn_id W Min |4 Max |EBAIE

wersion_number W Min (0 Max |31

NOTE. Minimum and maximum values may be entered in either decimal (12345)
or hexadecimal (0xA12B) format.

115

B

= Navigator: C:\Documents and Settings\srao\Deskt... |Z

EE, PSI/51 Tables
+ EIT_actual_pf
+ MIT_actual

¥ PAT

- PRT
Frogram 1 [0x0001]Yersion 0 5ection 0 [Pid 32 [0:20]]

Frogram 2 [0x0002] Yersion 0 5ection 0 [Pid 33 [0:21]]
Frogram 3 [0x0003] Yersion 0Section 0 [Pid 34 [0x22]]
+ SOT_actual
+
+ TaT

2
Programs T ables |F'ids

The parameters for each table must be set individually. Overall settings can be
applied individually by selecting the Apply button when a setting is made or as a
whole by making all of the settings and selecting the OK button.

|
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To preview the result of filtering, select the Apply button. All settings can be
cleared by selecting the Clear All button.

Note that filter settings remain in force for as long as the current multiplex is
active. The settings are lost when the Multiplexer is closed unless they have
been previously saved.

Saving/loading Sl filter ~ The filter settings made in the Display Filter dialog box can be saved and
settings subsequently reapplied to the same stream or other streams.

To save the current filter settings, select the Save button and enter a name (and
location) in the Save As dialog box. To retrieve or load filter settings, select the
Load button and identify the filter file in the Open dialog box. The file extension
* fil is used.
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Component views

Component Bit Rate view

Component Duration view

The Component views provide a graphical view of the bit rate and duration of the
components of a stream. The management of the views has a number of common
features; these are described in the Common Features.

The Component Bit rate view provides a graphical comparison of the stream
components.

Open the Component Bit rate view either by selecting View > Component Bit
rate from the Menu Bar or by using the toolbar button.

5| ] e

Each component includes the following information: Program name, PID,
Description and the Bit rate in numerical and graphical form. Where appropriate,
the Service ID and the Service Name are displayed (extracted from the SDT).

Frogram Fid Drezcription Bitrate [Mbis) Bitrate 1=
1 Tektronix |
0x0052  MPEG-1/2 Audio 0.407349 1
0x0078  MPEG-1/2 Audio 0.094015 I
0x006e  MPEG-1/2 Wideo 2029531 -
2 Tektronix 11
0x00ds  MPEG-1/2 Audic 0.1586E7 I
Ow00efs  MPEG-1/2 Audio 0.034015 I
0x00d2  MPEG-1/2 Wideo 4.007834 =
3 Tekbtronix 111
Ox0140  MPEG-1/2 Audio 0219347 I
Ox014a  MPEG-1/2 Audic [0.156652 I
036 MPEG-1/2 Wideo 5031631 —
4 Tekbtronix IV
Ox01ad MPEG-1/2 Audic 0282013 I b
Owllae MPEG-1/2 Audio 0219356 I
04019 MPEG-1/2 Viden in0sgEzs /3
L Tekbronix ¥
0x0208  MPEG-1/2 Audio 0.407350 1
0x0212  MPEG-1/2 Audia 0282012 I
Oulife  MPEG-1/2 Viden 15168652 E/— <

The Component Duration view provides a graphical view of the timing and
duration of each program/component within the current stream. Adjustments can
be made to the duration of each component.

Open the Component Duration view by selecting either View > Component
Duration from the Menu Bar or by using the toolbar button.

R E] |
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Showing: [0.00  : ]9.993¢ Curent: |[0.00

for A

Display Limits  Pointer position

\ 4

|Showing: 3313|533 Current: |4.313F |I

=g Component Duration: tek_sym1_test. mpg |_ (O] x|
N e ————————————————— —
Frogram I Drescription I F'idI Startl Stop I Length I Extent I
1 Tektronix | 0.00 5984 59.84 1

MPEG-1/2%ideo 110 000  59.84 5984 1
MPEG-1/2 Audio 130 000 5332 5332 1
MPEG-1/2 Audic 120 002 5332 5330 1

2 Tektronix 1l 0.00 5984 59.84 1
MPEG-1/2%iden 210 000 5984 5384 1
MPEG-1/2 Audio 2200 001 5316 5315 1
MPEG-1/2 Audio 230 0.02 5328 5325 1
3 Tektronix 11l 000 53982 59.82 k|
MPEG-1/2%ideo 310 000 5382 5382 1
MPEG-1/2 Audio 320 001 5332 5331 1
MPEG-1/2 Audio 330 001 5322 5321 1
4 Tektronix I¥ 0.00 53980 59.80 |
MPEG-1/2Video 410 000 5380 5380 1
MPEG-1/2 Audio 420 001 5926 5325 1
MPEG-1/2 Audio 430 0.01 5325 5324 1
5 Tektronix ¥ 000 53982 59.82 k|
MPEG-1/2%ideo 510 000 5382 5382 1
MPEG-1/2 Audio 520 000 5331 5330 1 LI

The following data is displayed for each component of the stream: Program,
Description, PID, Start and Stop time (in numerical and graphical form), Length
and Bit rate. The timing and bit rate elements of this information are also available
in the Program Stream Properties dialog box. (See Program Content Dialog
Box. (See page 36.)

Scaling bar. The Scaling bar, which is displayed at the top of the Component
Duration view, allows you to select the portion of the transport stream that is to
be displayed.

(On opening)

\ J

Y . .
Display limits Stream limits

—A (After adjustment)

68

04008

Pointer

The Stream limits bar represents the full extent of the stream. The Display limits
bar (dark portion) indicates the portion of the stream that is currently displayed in
the body of the view.

The Display limits fields indicate the extents of the Display limits bar and the
current Pointer position.

The Pointer can be dragged to a new position on the Stream limits bar. The
Display limits bar will center on the Pointer.
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Duration control. The duration of each element in the stream is given by the Start
and Stop values and shown graphically by the associated bar. The components are
color coded according to which program group they belong to.

The Start, Stop and Length values can be changed by clicking on the appropriate
field and entering the required value. The associated bar will reflect the change.

The Start, Stop and Length values can also be changed graphically by
manipulating the bar. The cursor shape indicates the action that can be taken.

<Al 1

I 1

The changes are reflected in the associated field values.

Components can be changed individually. In addition, whole Program groups can
be changed by manipulating the Program duration bar, but only when the view
is sorted by Program.

T R A SR T S EE TR

F

Pragram Diescription | Pid I Start I Stop | Length I Extent

1 Tektronix | 1121 49.76 3855 f 1
MPEG-2 Audin 120 1443 3817 2368 [ 1
MPEG-ZAudio 130 11.21 4976 3855 L 1
MPEG-2Widen 110 1121 4376 3865 L 1

2 Tektronix 11 0.00 53.84 59.84 F

A vertical dotted line indicates the upper limit of the multiplexed stream.

In the Transport Stream Properties dialog box (View > Properties with the
Transport Stream node highlighted in the Navigator Programs view), you can
determine how and if the stream duration is updated. The available options will be:

m  Select Fixed to ensure that the stream duration can only be updated in the
Stream Properties dialog box.

B Select Set to the greatest component stop time to ensure that the stream
duration is set to the greatest stop time recorded in the SI/PSI/PSIP tables.

Component start and stop times changed in the Component Duration view are
automatically updated in the SI/PSI tables.
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Available Bit Rate view

70

The Available Bit rate view displays in graphical form the available bit rate for
the duration of the multiplex.

The bit rate is calculated using the MGB2 measure (Ref: ETSI TR 101 290).
Open the Available Bit rate view by selecting View > Available Bit rate from the
Menu Bar or by using the toolbar button.

- Component Duration: tek_sym1_test. mpg !EIE
Showing: W 77.03  Cument: W I—ﬁ
Program I Diescription I F'ldI Start I Stop | Estent

1 Tektronix | 17.20 77.04 ‘

MPEG-1/2%ideo 110 17.20 7704 1
MPEG-1/24udic 130 1720 7B52 1
MPEG-1/2 Audic 1200 17.22 FEAD 1
2 Tektronix 11 0.25 6008 F h |
MPEG-1/2Video 210 0.25 6005 [ 1

MPEG-1/2 Audio 2 [t Available Bitrate (@MGB2): tek_sym1_test. mpg
MPEG-1/2 Audio &

; Time 40.000Mhps |
3 Tektronix 111 17.20 R

MPEG-1/2Video 7 || Total Bitrate
MPEG-1/2 fwdic % || 41.471Mbns [ S8 000kbps

MPEG-1/2Audin || Srale Lised

36.686Mbps

4 Tektronix 1Y Available Bitrate | 20 0000bps 4
4.785Mhps

MPEG-1/2Video 4

MPEG-1/2 budic 4 EETEET 25.000Mbps

MPEG-1/2 &udin 47
L Tekbronix ¥ 20.000mbps

MPEG-1/2Video 5
MPEG-1/2 dudia 5 15.000Mbps
MPEG-1/2 Audia &
Mull FPid & 10.000Mbps
Sustem Informnatinn 1F
5.000Mbps |
0.000Mbps
000s 2000 5 4000 60.00 s

Showing: IU.DD : |77.03 Current: |1?.2D I‘ﬁﬁ'

If the bit rate falls below zero, the points will be highlighted in red. When editing
a multiplex, you can add components which cause the bit rate to fall below

zero and no warnings will be displayed. However, if a transport stream is then
generated, errors will be logged and displayed in the Log view.

Use Refresh to redraw the graph. Clicking anywhere within the graph will place a
vertical cursor at that point; the position and bit rate are displayed in the Time
and Available Bit rate fields.

The zoom level and cursor placement of the Available Bit rate and the Component
Duration views can be synchronized by selecting View > Synchronize.

MTS4000 and MTS4SAV3 Generator Applications User Manual



Multiplexer - Views

Common features  Columns in the Component views can be sorted and rearranged to suit your
preferences. Column management in the two Component views is similar.

Field selection. You can select the fields to be displayed in each Component view.
The Header bar indicates which fields are currently displayed.

When you right-click on the Header bar, a menu is displayed. You can select
which fields are to be displayed. A check mark next to a field name indicates that
the field display is currently enabled.

You can display the version number of the PAT and PMT in the Description
column by enabling the Show program version option in the shortcut menu from
the Description column header.

gram I Dregcription I Pid
Tektronix |
MPEG-Z Audio | Dezcrption [N S Lengt!
- v Program —
Tektronix | w Diescription 9.46
MPEG-2 udio |+ Fid B30
MPEG-2 Audia ¥ Start 5,31
MPEG-2Videa | ¥ 21OP 5 45
——— ¥ Lenath —
Tektronix 11 o Extent 9.84
MPEG-2 fudio | ¥ Bitrate [Mb/s] 5,15
MPEG-2 Audia &
MPEG-2 Yideo

T

ararm I D escription | Fi

Tektronix | [PAT ~0, PMT 0]
MPEG-2 Audio 120
MEER.? Andin 19

Similarly, you can display the PID numbers in hexadecimal, by selecting Display
in hexadecimal from the PID column shortcut menu.
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72

Column repositioning. You can reposition Columns as required. Click and drag
the column to the required position.

Program | Pidi Description | Bitrate [Mb/s] | Bitrate
1 Tektronix |
120 MPEG-2 Audio 0.094025 I
130 MPEG-2 Audio 0.407350 |
Frogram I Pld% Diezcription I Bitrate [Mb/s] I Bitrate
Ak Tektronix |
120 MPEG-2 Audio 0.034025 1
130 MPEG-2 Audio 0.407350 |
Frogram 1 Pid | [ieziiiption | Bitrate [Mb.'z] Bitrate
K Teklmnix&
120 MPEG-2 Audio 0.034025 |
130 MPEG-2 Audio 0407350 |
Programm I Pid I Descript 3, I Bitrate (Mbs) I Bitrate
1 Tektronix |
120 MPEG-2 Audio 0.034025 |
130 MPEG-2 Audio 0407350 |

Frogram Drescription Fi Bitrate [Mb/s) | Bitrate

1 Tektronix |
MPEG-2 Audio 120 0.094025 I
MPEG-2 Audio 130 0.407350 1
MPEG-2 Video 110 2029528 o

Column width. You can resize Columns as required. Place the cursor over the
dividing line between two columns; it will change to the resizing cursor. Click
and drag the column to the required width. The change will be made to the
column to the left of the cursor.

Frogram Dezcription '+' Fid | Bitrate [Mbiz]
4] MPEG-2 Video 510 15.1E2EEZ (—

Double-clicking the column divider will automatically resize the column to the
left to the optimum size required to view the content.

Column sort. You can sort Columns in ascending or descending order. Click the
cursor on the heading to sort the column. Clicking again will sort the column
in reverse order.

Program | Description | Pid I Bitrate [Mb/s] | Bitrate
1 MPEG-2 Audio %120 004025 1
1 MPEG-2 Audio 130 0407350 1
2 MPEG-2 Audio 230 0.034015 1
2 MPEG-2 Audio 220 0156667 1
3 MPEG-2 Audio
Program I Description N I Pid | Bitrate [Mb/s) I Bitrate
Null Weta 27ee500 =
1 MPEG-2 Yideo 110 2029528 o
2 MPEG-2 Yideo 210 4.007834 =
3 MPEG-2 Yideo 310 6034838 —
4 MPEG-2 Yideo 410 10.066074  —
5 MPEG-2 Yideo 510 16168662  —

Similarly, the columns can be grouped in Program order, by clicking the Program
header.

MTS4000 and MTS4SAV3 Generator Applications User Manual



Multiplexer - Views

Common menu options

The specifications for components of the various views can be manipulated by
options from the Edit menu, View Menu, and Toolbar.

A shortcut menu also provides the Add, Modify, Delete, Import, Export and
Properties options. Place the mouse pointer over the component to change and
click the right mouse button to open the menu.

A typical shortcut menu is shown here:
&dd

todify

Delete

Properties

The menu options are context-sensitive and will be enabled or disabled according
to the current selection in the view.

The following options are available from the various shortcut menus:

Add Adds a component to the currently selected
item.

Modify Opens the properties dialog box.

Delete Deletes the currently selected component.

Properties Opens a properties dialog box for editing the
currently selected item.

Export Payload Extracts and exports the payload of the

source transport stream in the form of a
simple data file.

Export Elementary Stream Removes the transport stream and PES
headers and exports the remaining
information in the form of a simple data file.

Export Section Data Extracts and exports section data. The
created file can be imported as ES using
Multiplexer's Add function or as Sl using the
Import Section Data... option.

Import Section Data Imports Sl data from a file and analyzes it.
The section is added to the Navigator view.
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Multiplexer - Editing in the navigator views

Multiplexer provides a variety of ways of building and modifying transport
streams for multiplexing. In addition to the Menu Bar options and Toolbar
shortcuts built into the Multiplexer, many of the operations can be carried out
using familiar drag and drop Windows techniques.

In the following descriptions, the alternative methods for carrying out a task

are given at the head of the section, but only one method is described for each
action. Other methods for the same action often invoke the same dialog boxes and
sequence of follow-on actions.

Dragging and dropping

To drag a file, click on its name and hold down the left button of the mouse while
dragging the file to the required location. The cursor will change according to
the background that it is dragged over:

h: (With Ctrl key held) when dropped, the file will be
win copied.
When dropped, the file will be moved (cut and
%3 pasted).
® When dropped, no action will be taken.

Note that as the file is dragged over elements in the Navigator, receptive elements
(elements where the file can be meaningfully dropped) will be highlighted.
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Transport stream
Opening an MPEG file

Opening a Multiplexer file

Changing transport stream
bit rate and duration

For information on Opening a Stream, (See page 12.)

For information on Opening a Stream , (See page 12.).

To specify a new bit rate or duration for the transport stream, select and highlight
the Transport Structure component in the Navigator view.

From the shortcut menu, select Properties. The dialog box will be displayed
as shown.

= Navigator: C:\Documents and Setting... |:||E| X

B g Froga jan 0]

+=1at
+=235
+=3

Propetties

Prgg[amg Tablesz | Pids

Edit the Bit rate and the Duration as required, then click the OK button.

S5tream Properties E|
Bit rate: |E Mbit
Duration
(* Fived: |a.aaaana 3

(" Set to greatest component stap time

k. | Cancel
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Programs

76

Adding a new program

The introduction of the Navigator Programs view has provided a more
program-centered means of manipulating SI/PSI. Whole programs can be added
to the multiplex and the application will update the associated tables, including
the PAT and PMT.

Note that the nodes of the tree structure in the Navigator Programs view are
context sensitive. When dragging and dropping files from either the Examine TS
window or from another instance of Multiplexer, a node will be highlighted as
the cursor passes over it only when the operation proposed is valid. Note that
there may be a short delay before the node is highlighted while the legality of the
operation is checked.

With the Transport Stream ID field highlighted in the Navigator Programs view,
selecting the Add option either from the shortcut menu (PAT highlighted in
Navigator Programs view) or the Menu Bar (Edit > Add) will open the Program
Wizard. (See page 33.)

= Navigator: C:\Documents and Setting... |Z||E| X

+=233[33]
+=3

Export Seckion Data...

P[Dg[amg Tablez | Pids

In the Navigator Programs view, the PAT is represented by the Transport Stream
ID field.
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Copying/moving aprogram  Methods available:

®  Drag and drop (copy only) from the Examine TS window (Programs view) to
the Navigator Programs view.

B Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Programs view.

In the Navigator Programs view, programs can only be dropped onto the PAT node.

Tables

Adding a new PSI/Sl table = Methods available:

®  Highlight the PSI/SI Tables level in the Navigator Tables view and select
Add from the shortcut menu.

B Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

B Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.
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78

Any table that is defined in the selected standards, and not already present, can be
added the transport stream. To add a table to the transport stream, click on PSI/SI
Tables in the Navigator Tables view:

1. Highlight the PSI/SI Tables level and select Add from the shortcut menu.

= Navigator: C:\Documents and ... |Z E| X

i EIT_act
i MIT_acl
i PAT
a7 FrT
M S0T_ac
7107
7 T0T

+++++++:,

Import Section Data...

Properties

Programs  Tables | Pids |

This will open the Select dialog box. The dialog box displays a list of the table
types that are not already present in the stream.

Table Type

Ok |
EIT_actual_pf Y
EIT_other_pf - Cancel
EIT_actual_schedule

EIT_other_zchedule

RST

ST W

TOT

it b

NOTE. A PAT table cannot be added when ISDB interpretation with Single
segment extension is selected.

2. Select the required table type and click OK.
Pressing Cancel will abandon the operation without adding a new table.

Only the table types that are not currently specified for the stream are listed. If
the required table type is not listed, press the Cancel button to close the dialog
box without affecting the specification for the stream.
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The Select PID & Table ID dialog box is displayed only if a PID and/or Table
ID need to be identified. Otherwise, the selected Table type is automatically
created.

Select Pid & Table ID

2il.

FID ok
:

=l Cancel
TAELE ID

=

Generate subtable

-
-

TABLE ID EXTEMSION

YVERSIOM

FIRST SECTION

1T

LAST SECTION

A single section is automatically added to the newly created table type.

= Navigator: C:\Documents and Setti... |Z||E| X

'__\E. PSI/51 T ables

+) EIT_actual_pf
MIT_actual
PAT

PMT
SDT_actual

-
[Fid 20 [0«14]]

- Tar
[Fid 20 (0=14]]

Fa R B S

Frograms Tables | Fidz
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Copying a PSI/Sl table = Methods available:

®  Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

B Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

Tables can be copied (or moved) from existing multiplexes, using either of the
available methods.

If a similar table type is already present in the multiplex, the contents of the
copied table will be integrated with it.

Deleting a PSI/SI table A table is automatically removed when the last section is deleted (See page 88.)

Exporting a table ~ For more information, see Exporting a Section. (See page 88.)

Importing a Table ~ For more information, see /mporting a Section. (See page 89.)
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Sections

Adding a new sectiontoa  Methods available:

PSI/S! table Highlight the parent table level in the Navigator Tables view and select Add

from the shortcut menu.

B Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

B Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

To add a section to a table, select the parent table in the Navigator Tables view.
For example, to add a section to the SDT, select SDT Tables:

= Navigator: C:\Documents and ... |Z||E| X

3, PSIASI Tables

i+ EIT_actual_pf

+ MIT_actual

+ PAT

+ PRT

S8 S0 T _actual
Tra I | 5 i
Tra Sect
Tra Secti—

+.&y TOT
. Cut e

= Copy

[

|

Programs T

Then select Add from the shortcut menu.

The Select PID & Table ID dialog box is displayed only if a PID and/or Table ID
need to be identified. Otherwise the selected section is automatically created.

Select the required PID and Table ID (where enabled) and press OK.
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Select Pid & Table 1D

!

B
Cancel
TABLE ID

=

Generate subtable

-
-

TABLE ID EXTENSION

YERSION

FIRST SECTION

LAST SECTION

1T

Pressing Cancel will abandon the Add operation without adding a new section.

The version/section of a table is created with a new version or section number.
The rules used by Multiplexer for numbering are:

B For tables that the selected standard dictates should always have a section
number of 0, the version number is increased by one. The new version
number is based on the version currently in the table with the most recent
number. The version number is a 5-bit field, so if the new version would
be 32, it is reset to 0.

versionnumber NEW = (versionnumber RECENT + 1) modulo 32
version_numberNEW = (version numberRECENT + 1) modulo 32
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= For any table type that allows a section_syntax indicator, the Add multiple
sections check box in the Generate subtable part of the dialog box is enabled.
Additionally, the One section per segment check box will only be enabled for
the EIT schedule table type.

Select Pid & Table ID

FID 0K
CHE

di.

Cancel
TABLE ID

=

enerate zubtable

[ Add multiple sections
=
TABLE 1D EXTEMSION
YERSIOMN
FIRST SECTIOM

LAST SECTION

1T

B Up to 256 sections can be added.

= Additions to existing subtables using the same Table Id Regions and Versions
will be rejected.

B When multiple EIT Schedule sections are being added, the One section per
segment check box is enabled. When it is checked, only the first section in
each segment will be created, rather than all sections numbered between First
section and Last section.

When dragging and dropping a section, the Multiplexer will resolve any
numbering conflicts by creating new versions of duplicated tables.
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Editing PSI/SI table
properties

Table and Section Properties are edited by selecting and highlighting one of the
versions/sections within the transport structure and selecting the Properties

option from the shortcut menu.

= Navigator: C:\Documents and Settings\sra... : :

5[. PSI/51 Tables

+ EIT_actual_pf
+ MIT_actual

+ FAT

+ FrT
- S0T_actual

Transport Stream 1D

Tranzport Stream 1D 7 (011
Transport Stream |D 7011
F Delete [
+ TDT
+ (& ToT Cut
Zopy
Export Section Data...
<_ Import Section Data... l
Programs Tables Properties

This opens a dialog box with four tabs, one for each property. Depending on
the type of table, properties can be applied to a specific version or section of
the table. Multiplexer allows only operations that make sense in the context of
the selected table type.

The properties that can be edited from the Navigator Tables view are:

PID number. The PID tab is displayed by default when the Section Properties
dialog box is opened.

Section properties Transport Stream ID 0 Ver... [z|

FID l‘-.fersin:nn Timing] Subtable Timing]

|1?

Cancel

o ]

Edit the value and select OK to change the PID number.
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Edit the value and select Apply to make the changes and update the other
properties (tabs) without having to close this dialog box.

Multiplexer checks the new PID number against the selected standards and warns
of any nonconformance. If a conflict is found, a warning message is displayed,
with the option to continue. Multiplexer also checks for conflicts with other
PIDs. If the new PID number conflicts with an existing PID, an error message is
displayed and the change is rejected; in this case, either choose a different PID
number for the table or edit the number of the PID that is currently the owner.

If no conflict is found, another dialog box is opened to define the scope of the
changes:

Apply the PID change to: 0K

f* This zection anly Cancel
" All sections of this version
" All sections with the zame table id and extenzion

" All sections with the zame table id

Select the required scope and click OK. Selecting Cancel will abandon the
change.

Version timing. The Version Timing tab shows the time when the version will
become current, and the start and end times. New values may be specified for
any of these times.

Section properties Transport Stream ID

PID  Version Timing | Subtable Timing |

Start Time:

0l
Signalled Az Current Time: a z

Stop Time:

[+ Tranzmit until end of transport stream

| k. | Cancel |
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Start Time Specifies the time at which sections of this version
will start to appear in the transport stream.

Signalled As Current Time Controls the time when the sections with this version
will have the current_next_field set to 1.

By default when these sections start to appear in the
transport stream, the current_next_field of the section
set to 0. To specify a version that is always current
set the Start Time and Signalled As Current Time
fields to the same value.

Transmit until end of transport Enables the section to be repeated until the end of

stream the transport stream. If the check box is disabled, the
Stop Time becomes active.

Stop Time Specifies the time after which no sections of this

version will appear in the transport stream.

All the times are in seconds, taken from the start of the transport stream file. The
default start time for PAT is 0.00 s and for PMT is 0.001 s.

Edit the values and select OK to change the timings. Edit the values and select
Apply to make the changes and update the other properties (tabs) without having
to close this dialog box.

Subtable timing. Service information is usually constrained to appear at regular
intervals in the transport stream. This is usually implemented as a maximum time
between appearances of all the sections of a subtable (where a table is defined by
the table id, table id extension and version number on the same PID).

Use the Subtable Timing tab to specify the desired and the maximum acceptable
period between instances of the subtable. When an MPEG file has been opened,
this shows the mean time between instances of the subtable in the transport stream.

Section properties Transport Stream ID 0 Ver... E|

FID ] Yersion Timing S ubtable Timing l

Cycle Time: 1500 T

b ax cycle time recommended by ztandard: 2000 ms

k. | Cancel

Cycle Time Displays the mean time between instances of the subtable specified
for synthesizing a new MPEG file. Edit the value can be to specify a different
cycle time.
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Below the Cycle Time, the dialog box displays subtable specific information
from the currently selected standard.

Edit the values and select OK to change the Cycle Times. Select Apply to make
the changes and update the other properties (tabs) without having to close this
dialog box.

When synthesizing a new transport stream, the multiplex engine tries to insert
the subtable at the frequency specified by the Cycle Time. An error message is
written to the event log whenever a subtable cannot be multiplexed into the stream
within the period specified by the maximum cycle time.

Section timing. Where a table can contain only a single section (for example,
TOT and TDT), a Section Timing tab is displayed in the Properties dialog box.

Section properties [Pid 20 [0x14]] &|

FID Section Timing l

Start Tirne:

1

Stop Time:

[v Transmit untl end of transport streann

T

Cycle Time: ms

bax cycle time recommended by standard: 30000 ms

QK | Cancel |

Start Time Specifies the time at which the first
appearance of this section will occur.

Stop Time When enabled, specifies the time at which
the last appearance of this section will occur.

Transmit until end... When enabled, specifies that the section
should be transmitted until the end of the
stream.

Cycle Time Specifies the interval at which the section

should be transmitted.

Max cycle time... Gives the cycle time recommended by the
current standard.

Edit the values and click OK to change the timings. Click Apply to make the
changes and update the other properties (tabs) without having to close this dialog
box.

An error message is written to the event log when a table cannot be multiplexed in
accordance with the timings set.
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Deleting a section

Exporting a section

88

Highlight a section in a table in the Navigator Tables view and select Delete from
the shortcut menu. To delete more than one section, select and delete each one
in turn. When the last section is deleted from a table, the table is automatically
deleted from the structure.

Section data can be exported in the form of a binary file. In the Navigator Tables
view, highlighting a Table node (for example, PMT Tables), allows all sections
of the table to be exported. Similarly, highlighting a single section entry (for
example, Program 123) allows only that section to be exported.

Highlight the required section or Table node in the Navigator Tables view. From
the shortcut menu, select Export Section Data. Name the file to be created and
choose a location. Select Save to confirm the action.

Individual sections can also be exported using the Navigator Programs view.
Select the required section to be exported. From the shortcut menu, select Export
Section Data. Name the file to be created and choose a location. Select Save to
confirm the action. Note that not all tables are shown in the Navigator Programs
view, for example, TOT.

~u Tektronix Multiplexer - tek_sym1_test. mpg

JEiIe Edit “iew Options Multiples Window Help
@@ﬁ|ﬁ I:r'j(|‘5"cr'E|%Fl=F| [

HNavigator: tek_syml_test. mpg

EE S EEET B

o] -]

_=/Section: SDT_actual Transport Stream ID 1 Yersio

HE. Tranzport Stream
E--gg Programs [Stream 1d 1 Yersion 0]
Ea 1 Tektronix | [Tektroniz Cambridge]
| Service Sections
Tranzport Stream |0 1 Version )

EI-- Transport Stream 1D 1 Yersion 0 Section O [Fid 17 [0x11]]
#-{} TableHeader

18 original_netwark_id = 43981 [Dxabcd]
E---{_} services
Com S semvice id=1 [0x1]

ol Import Section Datar. :

Event Sections | Add ervice_id = 2 [0x2]

.’.E'g Elementary Streamns [PMT M: I f ity ervice_id = 3 [(k3]

B 2 Tektronix |l [Tekironix 5 pstems] = Dt BIV!CE_!C' =4 [0x4]

a 3 Tektroniz |11 [T ektronix Systems] ervice_id = 5 [0x5]

a 4 Tektronix IV [Tektronix Systems] ‘X’ Lu | 32 =1221004543 [0x45c70cf{]

a 5 Tektronix ¥ [Tektronix Spstems] oy
E Easte
E Expo

Save Section Data
Save jn Ia LT est j | |‘j<| |
K —
| Programs —F File: narne: tek_syrnl _testpid] 7] | Save NJ
Ex=part the section conten Save as type: | Section Files [* daf) ﬂ — | Duration 59.8394s |Standar
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Importing a section  In the Navigator Tables view, select the PSI/SI Table node. From the shortcut
menu, select Import Section Data. In the PID tab of the Import Section Data
dialog box, identify the PID that is to carry the information. Similarly, in the
Source tab, identify the file that holds the section data to be imported. Select
OK to confirm the selection. During the import action, the content of the file is
examined to determine where the section(s) should be placed.

ES PIDs

ES PIDs that carry additional Elementary Streams can be multiplexed into the
synthesized transport stream. Do the following when defining an elementary
stream to be added:

B Allocate a PID number
B Define the source of the elementary stream to be added
B Define the timing to be applied to the new stream

B Define the PCR placement

Adding an unreferenced =~ Methods available:

elementary stream Select the ES PIDs in the Navigator Tables view and select Add from the

shortcut menu.

B Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

B Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

To add a new stream, select ES PIDs in the Navigator Tables view and select
Add from the shortcut menu.
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= Mavigator: C:\Documents and Settingslsra... [E|E| X

iy

|

O g O

a0 Ei

Import Section Data...

Properties

F'ru:ugrams] Tablez Pids

This opens the Add Stream dialog box; the Source tab is displayed by default.

Defining the PID source. In the Add Stream dialog box, select the Source tab, to
select and define the PID source.

Add Stream [X|

FID  Souee | Timing| PCR |

File name: || Browse. .
File type: | MPEG-2 video ~| Bitate: kb/s

Original TS PID: Extra DTS cffzet: |0 %

Stream_id: a Start each field in a new pes packet |

k. | Cancel
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File name Enter the file name of the stream to be multiplexed. If the
file name is unknown, select Browse to open a standard file
browser dialog and locate the file required.

The names of files being copied to the multiplex will be
automatically filled in.

File type Select the type of file to be multiplexed from the drop-down
list box.

The following file types are available:

MPEG-1 video ES or PES

MPEG-2 video ES or PES

MPEG-2 audio ES or PES (MPEG-1 or MPEG-2)
MPEG-2 AAC audio ES or PES (ADTS format only)
MPEG-4 audio ES or PES

AC-3 audio ES or PES

(ES - Elementary Stream; PES - Packetized Elementary
Stream)

H.264 video ES or PES

H.265 video ES or PES

Transport Packets: A single PID stream. The Bit rate value
will require setting. The Original TS PID will require setting.

Section: The content of the file will be Sections. The sections
will be in binary form. The file will consist of one, or many
sections appended one after the other.

When multiplexed, the sections will be encoded on the given
PID as Sl. If the resulting multiplex is subsequently opened
in the Multiplexer, the sections will be interpreted as Sl and
displayed under the Sl Tables node in the tree.

A file generated using the Edit > Export Section Data menu
option can be used here. The Bit rate value will require
setting.

Other: Any binary or ASCII file that is to be packetized into
the transport stream at the specified bit rate. The Bit rate
value will require setting.

The remaining fields are interactive and will only be enabled when a value is
required.

Bitrate When first defining a source, the bit rate is unknown and
0 Kbps is displayed. If a Transport Packet Stream or an
"Other" File Type is selected, the field is enabled and a
value (in Kbps) can be entered.
If MPEG-2 video, H.264 video with HRD messages or
H.265 video with HRD messages is selected, the bit rate
value is detected automatically and displayed.
If H.264 video or H.265 video without HRD messages is
selected, the bit rate is not detected automatically.

Original TS PID For streams other than transport streams, this field will be
blank and disabled.
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Extra DTS offset

When multiplexing ES or PES streams, the Multiplexer
will derive an offset between the PCR and the decoded
timestamp (DTS) of the first access unit (video picture /
audio frame).

You can override this offset and make it larger (positive
number) or smaller (negative number). Changing

this value may cause the resultant stream to be
nonconformant with respect to the T-STD of the
MPEG-2 standard. Enter the DTS offset in seconds
required.

Stream_id

Only enabled for elementary stream types. This number
specifies the value of the stream_id field in the PES
packet header.

Only needs to be set for DVB stream. Stream identity in
the PES header.

Start each field in a new PES
packet

Only enabled when File Type: MPEG-2 Video is selected.

When disabled, both field pictures making up a coded
frame are put in a single PES packet. Otherwise, each
field picture is put into a separate PES packet. This
setting has no effect upon frame pictures.

Start each section in a new
packet

Only enabled when File Type: Section is selected.

When disabled, Sl data is placed in the packet payloads
in the most efficient manner. The start of a section will
immediately follow the end of the previous section; no
stuffing bytes will be used.

When enabled, each section will begin in a new packet
and stuffing bytes will be used to pad any payloads that
are not full.
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Defining the stream timing. In the Add Stream dialog box, select the Timing tab.
This tab will allow timing parameters for the selected source stream to be defined.

NOTE. To achieve compatibility between MUX and MTS4EAV7, the start time is
set to the following default values: PAT is 0.000, PMT is 0.001, and ES is 0.002.

Add Stream PS_<|

PID | Souwse Timing | FCR |

Start time:;
Stop tirme: |9-9999E|E .
Laop interyal ||:| s ¥ Loop

f-,
ak | Cancel | L\E |

Start/Stop Time Enter the times that the selected source stream is to
start and stop within the host transport stream. Note
that the overall duration of the host transport stream
is defined through the Transport Stream Properties
dialog box.

Loop Select this check box to loop the selected source
stream for the duration of the synthesis. A Loop
Interval can be set that introduces a delay between
each repeat of the source stream; if zero is entered,
the source stream will loop continuously. The Loop
check box will always be disabled for transport
stream types. The Multiplexer cannot loop transport
streams.

Select OK to accept all changes and close the dialog box.
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Defining the PCR placement. In the Add Stream dialog box, select the PCR tab
to PCR define the placement.

Add Stream [X|

FID ]SDurce]Timing FCR l

[ Camy PCR PCRPID:  [3191
[mitial PCR: PCR Interval: ms

[ M

PCR for elementary streams. (Includes File Type: Transport Packets.) PCRs are
placed in the packets at the specified interval, starting with the specified initial
value.

PCR for Remultiplexed PIDs. (Includes File Type: Transport Stream)

m  [f the Carry PCR check box is not enabled, any PCRs in the packets will
be removed.

®  [f the Carry PCR check box is enabled, PCRs will be sent as follows: If
Preserve PCR Inaccuracy is set, the PCRs from the original transport stream
will be used, otherwise the initial PCR value can be specified.

®  If the Preserve PCR Intervals check box is enabled, PCRs will be sent in
those packets that originally contained them, otherwise PCRs are inserted
into packets at the specified intervals.
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Specifying the PID number Enter the PID number. A new value can be entered using either decimal or
hexadecimal notation. Values are assumed to be decimal unless preceded with
0x. The dialog box is not case sensitive and values may include zeros after the
prefix and before any significant digits.

Add Stream 3

FID lSn:nurn::e] Timing] PCF ]

g

ak. | Cancel Apply

When all details (in all tabs) are satisfactory, select OK to accept all changes
and close the dialog box.

Adding elementary =~ Methods available:

streams to the program B Select an Elementary Stream node in the Navigator Programs view and select
structure Add from the shortcut menu.

®  Drag and drop (copy only) from the Examine TS window (Programs view) to
the Navigator Programs view.

B Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Programs view.
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Elementary stream data can be added using the Navigator Programs view.

In the Navigator Programs view, select an Elementary Streams node to which
the elementary stream is to be added.

2. From the shortcut menu, select Add. The Add Program Stream dialog box

is displayed.

fdd Program Stream F§|

Stream Type |2? [0=1B] [T - HZ264 video stream) ﬂ

Fid Humber: |33

Source | Timing | FCR |

File harme: || Browse...

File type: | H2E4 Video | mivae | kb
Original TS FID: Extra DTS offset: |0 E
Strearm_id: 0 [

[ ComponentT ag | ak. Cancel

The dialog box tabs allows the input elementary stream to be selected and
specified. The main dialog box fields Stream Type and PID Number dictate
the PID that will carry the stream and the stream type entry that will be made
in the PMT.

The functionality of the tabbed dialog boxes is described in the following
pages:

Source: See Defining the PID Source. (See page 90.)
Timing: See Defining the Stream Timing. (See page 93.)
PCR: See Defining the PCR Placement. (See page 94.)

Enable the Component Tag check box, if required. Enter a Component Tag
number (0 - 255) in the enabled field. If the Component Tag is enabled, it can
be referenced by other tables, for example, Event Information Table.
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Exporting elementary ~ The Export Elementary Stream option allows the nonpacketized elementary
streams  stream data to be extracted from an elementary stream and saved to a binary file.
Note that this data will not include the transport packet or the PES packet headers.

In the Navigator Programs view, highlight the elementary stream whose payload
is to be exported. Select the Export Elementary Stream... option from the
shortcut menu. Name the file to be created and choose a location. Select Save
to confirm the action.

Exporting PES packets  The Export Payload option allows the PES packets to be extracted from an
elementary stream and saved to a binary file. Note that this data will not include
the transport packet headers.

In the Navigator Programs view, select the elementary stream whose payload is to
be exported. Select the Export Payload option from the shortcut menu. Name the
file to be created and choose a location. Select Save to confirm the action.

Modifying PES PID details To modify any of the ES PID parameters, highlight the required PID in the
Navigator Tables view and select Properties from the shortcut menu. The Stream
Properties dialog box and its tabs are identical to the Add Stream dialog box.
Refer to Adding an Unreferenced Elementary Stream (See page 89.)

ES PID parameters can also be modified in the Navigator Programs view.
Highlight an Elementary Stream in the Programs view and select Properties from
the shortcut menu. The dialog box thus displayed (Program Stream Properties) is
similar to the Add Program Stream dialog box.

Deleting a PES PID An elementary stream can be removed from the multiplex by deleting the PID. To
delete a PID, highlight the required PID and select Delete from the shortcut menu.
Then select the Delete option from the Edit or pop-up menus. Alternatively, click
the delete button from the toolbar.

Multiplexer asks for confirmation before removing the PID from the multiplex.
Select Yes to delete the stream or No to abandon the operation and leave the
stream unchanged.
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DSM-CC

Adding an unreferenced

DSM-CC section

Adding DSM-CC sections

98

to the program structure

Methods available:

Select the ES PIDs node in the Navigator Tables view and select Add from
the shortcut menu.

Drag and drop (copy only) from the Examine TS window (Tables view) to
the Navigator Tables view.

Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Tables view.

Adding an unreferenced DSM-CC section is similar to adding an unreferenced
elementary stream, with the following modifications: (See page 89.)

In the Source tab of the Add Stream dialog box, select Transport
Packets/Sections as the File type and set the bit rate.

Add Stream x|

D Souce | Timing | PCA |

File name: |E:"-.D ocuments and SettingssrachDe Browse, .
File type: | EE=E0] Bitrate: lni kb/s
Original TS PID: Eutra DTS offzet;

Strearm_id: Start each section in a new packet [

g

k. | Caricel Apply

Methods available:

Select an Elementary Stream in the Navigator Programs view and select Add
from the shortcut menu.

Drag and drop (copy only) from the Examine TS window (Programs view) to
the Navigator Programs view.

Drag and drop (copy/move) from another instance of Multiplexer to the
Navigator Programs view.

Adding a DSM-CC section to the program structure is similar to adding an
elementary stream to the program structure (See page 89.), with the following
modifications:
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®m  The main dialog box fields Stream Type and PID Number dictate the PID that
will carry the stream and the stream type entry that will be made in the PMT.
The Stream Type should be set to one of the DSM-CC entries.

Add Program 5tream §|

Stream Type |2 [0x02) [MPEG-2 Videa] j

Pid Mumber; |36

Source | Timing | PCR |

File name: | Browse...

File type: |F'Iease chooze a bype ﬂ Bitrate: | kbiz

Original TS PID: Eutra DTS offset: z
Stream_id: [

[ ComponentT ag | (] Cancel

®  In the Source tab of the Add Program Stream dialog box, identify the File
name to be added. Select Transport Packets / Sections as the Stream type
and set the bit rate.

The DSM-CC section will be added.

Delete a DSM-CC section =~ A DSM-CC section can be deleted from a table by highlighting it in the Navigator
view and selecting Delete from the shortcut menu. To delete more than one
section, select and delete each one in turn.

Export a DSM-CC section = DSM-CC data can be exported in the form of a binary file.

Select the required DSM-CC section in the Navigator Tables view. From the
shortcut menu, select Export Section Data. Name the file to be created and
choose a location. Select Save to confirm the action.

Individual DSM-CC sections can also be exported using the Navigator Programs
view. Under any Elementary Streams node, select the DSM-CC section to be
exported. From the shortcut menu, select Export Section Data.... and Name the
file to be created and choose a location. Select Save to confirm the action.
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Multiplexer - Editing in Section view

Use the Section view window to modify the contents of a version/section. This
includes version, section, and table-specific data that the Navigator Tables view

displays. If the Section View window it is not already open, select View >
Section View.

If a section/version is selected in the Navigator Tables view, the contents are

automatically displayed in the Section View; otherwise the Section View window
is blank.

To open a table version/section in Section View, select the component in the
Navigator Tables view. The Section View is updated immediately to show the
selected section/version.

= Tektronix Multiplexer - C:\Documents and Settings\srao\Desktopitest.mpg |Z||E|fg|
File Edit Wiew Options Multiplex Window Help
feat) = ; X o] FEo e
@[ R] 1] =] 5] er|ms|r|ee| = > | = | S| elifn E G B[ | mfa]e
— - =L . Section: SDIT_actual Transport Stream I 0 Yersion 0 Section
3 PSI/SH T ables = Tranzport Stream [D 0Version 0 Section 0[Rid 17 [0x11]]
+ EIT_actual_pf 4 {} table_hesader
¥ NIT_actual 2% original_network_id = 0 [0x0]
+ @@ FAT +.{} services
@) PMT 19% CRC_32 = 458341906 [Ox1b51be12]
= SDT_actual
Transport Stream [0 Wersion 0 Sect
Tranzport Stream 1D tion 2 [Pid 1
Transport Stream [0 O%erzsion 05Section 4 [Pid1
+ TOT
¥ TOT
35 »

Programs T ables |F'ids ]

Filker OFF |DWE T5 Rate SMbitfs Duration 9.99991s |Standard Ready

Editing fields

To add, change, or delete a field, element or loop in a section/version, the parent
table must be selected in the Navigator Tables view. Select the appropriate line in
the Section view and select the required option from the shortcut menu.

Selecting a field  To select a field or container, place the mouse pointer over it and click the left
button.
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Adding an element to a
loop

The magnifying glass icon indicates the selected component.

If Standard Mode is selected, the magnifying glass selection cannot be placed
on a field that is locked. To select and edit locked fields, first select the Expert
Mode option from the Multiplex menu.

To add an element to a loop, select the parent loop that will contain it, and then
select Add from the shortcut menu. For example, to add a program to a PAT, select

the Programs container and select Add from the shortcut menu.

E-{} TableHeader

..... i“_l
107

101

101

=0
{_} progi E

-8
o
i

[
=
-~
L i

f=r
P
et

-4} progi [ Medi
-4} progn e

EHED Trarsport Strea
=-{} TableHead:

== Section: PAT Tranzport Stream Id 1 Versio... !E

El-- Tranzpart Stream |d 1 Yerzion 0 Section O [Pid 0 [0x=0]]

------ & table_id = 0 [0=00 FPAT]

------ £ zection_syntad_indicator = 1
----- & zechon_length = 33
tranzport_strean_id = 1 [0x1]
~egis wersion_number = 0 [0<0]

----- & curent_next_indicator = 1
g section_number = 0 [0<0]

o117 last_section_number = 0 [0:0]

Program number;

|5

Pragram map PIC: I32

Cancel |

tab'E_iL: = O OROTT ST
gection_syntas_indicator = 1
zection_length = 37

4 trangport_strear_id = 1 [0x1]
5 wersion_number = 0 [0x0]

current_nest_indicatar = 1

4 gection_number = 0 [0x0]
4 lazt_zection_number = 0 [0x0]

pragram_number = 0 [0=0]
pragram_number = 1 [0x1]
pragram_number = 2 [0=2]
pragram_number = 3 [0x3]
program_number = 4 [0xd]
pragram_number = 5 [0=5]
pragram_number = 6 [0=6]

CRC_32 = 0=4E2M 269
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Deleting an element in a

Modifying the contents of

102

loop

a field

In this example, a dialog box is displayed in which the Program Number and
Program Map PID can be accepted or respecified. Other table loops may not
display any dialog box, but immediately create a new element with default
contents. An entry is displayed for the new element, with its details collapsed, at
the end of the list of elements in the loop. In addition, the section length field is
automatically recalculated and amended. For the above example the new entry is
program_number = 6 (0x6).

NOTE. The example above was taken with Standard mode selected. In Standard
mode, all recalculation is done automatically. In Expert mode, a program element
will be added, but the program number and PID must be manually adjusted.
Similarly, the section length will need to be calculated and amended manually.
(See page 54, Expert and Standard modes.)

To delete a loop element, in the Section view highlight the element and select
Delete from the shortcut menu.

The element is deleted and the Section View window updated to reflect the
changes.

To edit the contents of a field, select the field and select Modify from the shortcut
menu. This will open an appropriate dialog box for modifying the type of data
held by the field.

The following paragraphs describe the different types of data that may be modified.
Enumerated value. The Modify value dialog box displays the name of the

field and the current value. The value is shown as a number followed by the
interpretation of the governing standards.

Modify Yalue

|'I [0 1] [digital televizion service) j -

In this figure, the field being edited is a service type and the current text is 1
(digital).

Type the number, without any text, for the required value. When the changes are
accepted, Multiplexer will display the interpretation in the Section View window.

Alternatively, click the down arrow to select the value from the drop-down list.

This displays a list of the defined values and their interpretation. The list will vary
depending upon the field being edited.
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Rodify Value

zErvice_tupe

1 [0 1] [digital televizion service]
2 (0% 2 [digital radio sound zervice)
3 [0x 3 [teletext zervice]

4 [0 4) [MYOD reterence service]
B [0x 5] MWOD time-zhifted service)
B [0x B] [mozaic service)

Enter the required value and select OK to continue. Multiplexer may open a
simple context-sensitive dialog box offering advice and/or asking for more
information or confirmation. An error message is displayed if the number that was
typed in requires more bits than are allocated to the field.

Date and time. The Modify Time dialog box displays the name of the field. It
displays the time in both interpreted and raw formats; only the interpreted mode
can be edited.

Modify Time ['5_<|

zhart_time

Time
Cancel

Haour: Minute: ||:|_ Second: ||:|_

Date

Day: |-|_ Month: |1_ Year [1997

Fraw Yalue: |I:I:-:c:51 1120000

[ Settoall ones [for NWOD reference services)

Edit the numbers in any of the fields as required. All fields are updated as each
digit is added, changed or deleted. Select OK to commit the changes or Cancel to
abandon editing and keep the original time.

The Set to all ones check box, when enabled, sets the 40-bit date field to
OxFFFFFFFFF. This may be required when setting the start date for an event in a
Near Video on Demand (NVOD) reference service.
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104

Compressed string. The Modify dialog box displays the name of the field, which
is always a compressed string, and the contents of the selected string segment.
Text can be entered, deleted, selected, copied to and pasted from the Windows
clipboard.

Modify X
compressed_ sting
Suitable for &l Aged Cancel

Edit the text and select OK to continue. Select Cancel to abandon the edits and
leave the original segment unchanged. Multiplexer checks to ensure that the
new string length does not cause the total section length to exceed the maximum
specified by the standards.

If the total section length exceeds the maximum specified by the standards, an
error message is recorded in the Event Log.

Text. The Modify Text dialog box displays the name of the field and the current
text on a single line. Text can be entered, deleted, copied to and pasted from
the Windows clipboard.

In the following figure, the field being edited is an ISO_639 language code and
the current text is eng.

Modify Value =]

[50_E339_language_code

Ieng Cancel
Wiew Walue Az
’7 & Character string i Hexadecimal number
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= Tektronix Multiplexer - Gehua-ts12.mpg

File Edit Wiew

Options  Multiplex  Window  Help

View Value As: You can choose between viewing the text as an ASCII character
string or a hexadecimal sequence. Character codes for DVB Appendix A strings
used in language code pages must be entered in double byte format and padded
with preceding zeroes if necessary. For example, 0x04 should be entered in the
hexadecimal field as 0004 and 0x51d should be entered as 051d. Switching from a

modified hexadecimal value will display the modified character string.

o e 1 2 O N B of ==Y FE SN B ) T

= Navigator: Gehua-ts12.mpg

£

EIT_other_pf Table ID 0x4f Service ID
@D EIT_other_pf Table ID 0x4f Service 1D
@D EIT_other_pf Table ID 0x4f Service 1D
@D EIT_other_pf Table 1D 0x4f Service 1D
@D EIT_other_pf Table ID 0x4f Service 1D

EIT_other_pf Table ID 0x4f Service ID

EIT_other_pf Table ID 0x4f Service ID
EIT_other_pf Table ID 0x4f Service ID
EIT_other_pf Table ID 0x4f Service ID

EIT_other_pf Table ID 0x4f Service ID
-[ED EIT_other_pfTable ID 0x4f Service ID

EIT_other_pf Table ID 0x4f Service ID

EIT_other_pf Table ID 0x4f Service ID

EIT_other_pf Table ID 0x4f Service ID
@D EIT_other_pf Table ID 0x4f Service 1D
@D EIT_other_pf Table ID 0x4f Service 1D
@D EIT_other_pf Table 1D 0x4f Service 1D
@D EIT_other_pf Table ID 0x4f Service 1D
R JFTT_other_pf Table 1D 0x4f Service 1D

[+ 20 System Information
- 220 Elementary stream type: Unknown [Gehua-ts12.mpg]
- 221 Elementary stream type: Unknown [Gehua-ts12.mpd]
- 310 Elementary stream type:
(@) 311 Elementary stream type:
[+ (€7 315 System Information

320 Elementary stream type:
(@) 321 Elementary stream type:

325 System Information

440 Elementary stream type:
445 System Information )

e 2010 Elementary stream type: MPEG-2 Video (scrambled) [Gehua-ts12.mpg]

L3 Version
181 Version
181 Version
182 Version
182 Version
183 Version
183 Version
154 Version
184 Version
185 Version
185 Version
186 Version
186 Version
187 Version
187 Version
188 Version
188 Version
189 Version
189 Version

Private sections [Gehua-ts12.
DSM-CC U-N messages [Gehug

Private sections [Gehua-ts12,
DSM-CC 4N messages [Gehua

User private [Gehua-ts 12.mpg|

I3 Secaon
14 Section
14 Section
12 Section
12 section
26 Section
26 Section
28 Section
28 Section
12 Section
12 Section

EE

I3 (U001

18 (0x0012)]
18 (0x0012)]
18 (0x0012)]
18 (0x0012)]
18 (0x0012)]
18 (0x0012)]
18 (0x0012)]
18 (0x0012)]
18 (0x0012)]
18 (0x0012)]

uration = 03:35:00
. running_status = 1 (not running)
. free_CA_mode =0
i descriptors_loop_length = 78
[=-{} descriptors
=-{} short_event_descriptor
- descriptor_tag = 77 [Dx4d]
descriptor_length = 19
2 150_639_language_code = chi

-{} content_descriptor
[#-{} multiingual_component_descriptor

1%, CRC_32 = 778728415 [0x2e6a73df]

Modify Value

event_name

IOO].EAFE].GGZFG?OQ/T' 0023003100320029

View Value As
’7 " Character string

% Hexadecimal numberi |

Character codes for Annex A strings must be entered in double byte
format, padded with preceeding zeros if necessary, e.g. 0x04
should be entered as 0004, 0x51 as 0061 and 0x51d as 051d

Modify Value

event_name

[FREEm

2

Cancel

Programs I Tables  Pids

"\c’lew Value As |

* Character string " Hexadedmal number

The string is DVE Annex A coded. Table details:
GB-2312-1980(Simplified Chinese). Editing is allowed only in the hex
mode

Filter OFF |DVB TS Rate 38.013Mbit/s  Duration 31.6327s [Standard Ready

A

Most text strings have a maximum length, specified by the governing standards,
which this dialog box will enforce. Edit the text and select OK to continue. Select
Cancel to abandon the edits and leave the original text unchanged.

MTS4000 and MTS4SAV3 Generator Applications User Manual 105



Multiplexer - Editing in Section view
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Numeric. The Modify dialog box displays the name of the field and the current
value in decimal. Edit the existing value or type in a new value.

Modify Value ]|

wersion_nurmber

Decimal 12 Hesx: O
Cancel |

IEI:-:::
"'\-"iew Walue Az

£ Character sting £ Heradecimal numter

In the following figure, the field being edited is a version_number and the current
value is 0xc.

A new value can be entered using either decimal or hexadecimal notation. Values
are assumed to be decimal unless preceded by 0x. The dialog box is not case
sensitive and values may include zeros after the prefix and before any significant
digits, for example:

Edit or replace the existing value and then select OK to continue. Select Cancel
to abandon any changes made in the field.

Multiplexer will check the new value against the governing standards and for
conflicts with other fields. It may open a simple context-sensitive dialog box
offering advice and/or asking for more information or confirmation. For example,
when changing a version_number, a dialog box appears to determine the scope
of the change.
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Multiplexer - Multiplexing transport streams

The Multiplex Engine in the Multiplexer synthesizes a new transport stream
and writes it to an MPEG file. The contents of the new stream are multiplexed
according to the specification currently held in memory, which is shown in the
Navigator and Section views.

The tables that are displayed in the Navigator are synthesized from the current
specification. Elementary streams and other data are acquired from the original
MPEG file and other stream files and remultiplexed according to the specification.

Starting the Multiplex Engine

To start the Multiplex Engine, select the Start option from the Multiplex menu.
Alternatively, select the start button on the Toolbar.

sl Window  Help

O

v Standard Made
Expert Mode

P onmrt

O | e |51

b zubtitle.mpg

Multiplexer opens a standard file browser dialog box to specify the file name and
path for the synthesized transport stream.

A new file can be created or an existing file can be selected to be overwritten. The
program will seek confirmation before overwriting an existing file.

NOTE. The Multiplexer automatically creates 188 byte packets in the transport
stream output file, regardless of the source material size.
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Errors and reporting

108

The right pane of the status bar indicates progress as the Multiplex Engine

synthesizes the new transport stream.

Event Log: D:\Streams\MuxT est\temp.mpg <] =]
Category Reference Comment
Time 13:44:40 Demultiplex started
Information Found PAT.
Information Stream bitrate is 24.1 283Mbit/s.
Infarmation Stream length is 31.8748s.
Infarmation Found 34 pids and 113 sections.
Time 134445 Demultiples complete. Demultiplex bitrate 134 738Mbit/s
warning Prograrm 4479 Yersion 4 Section 0 [Pid 4479 [0x117F]] Elementary PID 651 [0x28B] in PMT nat faund in multiples
warning Prograrm 4479 Yersion 4 Section 0 [Pid 4479 [0x117F]] Elementary PID 652 [0x28C] in PMT nat faund in multiples
W arning Program 4415 Yersion 11 Section 0 [Fid 4415 [0x113F]] Elementary PID 6571 [0x288] in PMT not found in multiples
W arning Program 4415 Yersion 11 Section 0 [Fid 4415 [0x113F]] Elementary PID 652 [0x28C] in PMT not found in multiples
W arning Program 4415 Yersion 11 Section 0 [Fid 4415 [0x113F]] Elementary PID 1015 [023F 7] in PMT not found in multiples:
Warning Program 4415 Yersion 11 Section O [Fid 4415 (02113F]] Elementary PID 1076 [043F8] in PMT nat found in multiples:
warning Program 4167 YYersion 12 Section 0 [Pid 4167 (0=1047]] Elementary PID 602 [0x254) in PMT not found in multiples
warning Program 4167 Yersion 12 Section 0 [Pid 4167 (0x1047]] Elementary PID 1006 [0<3EE]) in PMT not found in multiplex
Wwarhing Prograr 4167 Yersion 12 Section 0 [Pid 4167 (0x1047]] Elementary PID 1007 [043EF] in PMT not faund in multiples
Wwarning Prograrn 4167 Yersion 12 Section 0 [Pid 4167 (0x1047]] Elementary PID 651 [0428B] in PMT nat faund in multiples
warning Prograrn 4167 Yersion 12 Section O [Pid 4167 (0x1047]] Elementary PID 652 [0x28C) in PMT nat faund in multiples
warning Prograrm 4351 Yersion 24 Section O [Pid 4351 (0x10FF]] Elementary PID 651 [0x28B] in PMT nat faund in multiples
warning Program 4351 Yersion 24 Section 0 [Pid 4351 (0x10FF]] Elementary PID 652 [0x28C] in PMT nat faund in multiples
W arning Program 4351 Yersion 24 Section 0 [Fid 4357 [0x10FF]] Elementary PID 1012 [0x3F 4] in PMT not found in multiples:
W arning Program 4351 Yersion 24 Section 0 [Fid 4357 [0x10FF]] Elementary PID 1013 [023F5] in PMT not found in multiples:
W arning Program 4231 Yersion & Section 0 [Fid 4231 [0x1087)] Elementary PID 6571 [0x288] in PMT not found in multiples
Warning Program 4231 Yersion B Section O [Fid 4231 [0=1087]] Elementary PID 652 [0x28C) in PMT not found in multiples
Warning Program 4231 Yersion £ Section 0 [Fid 4231 [0=1087]] Elementary PID 1003 [043F1] in PMT nat found in multiple:
warning Program 4231 Yersion £ Section O [Pid 4231 [0x1087]] Elementary PID 1010 [0x3F2] in PMT not found in multiplex
“warning Prograr 4543 Yersion 4 Section 0 [Pid 4543 [0=11BF]] Elementary PID 651 [0x28B] in PMT nat faund in multiple:
Wwarning Prograrm 4543 Yersion 4 Section 0 [Fid 4543 [0211BF]] Elementary PID B52 [0x28C) in PMT nat faund in multiples
warning Prograr 4543 Yersion 4 Section 0 [Fid 4543 [0x11BF]] Elementary PID BE2 [0x29E] in PMT nat faund in multiples
warning Pragrarn 4543 Yersion 4 Section 0 [Fid 4543 [0x11BF]] Elementary PID BE3 [0x297] in PMT nat faund in multiples
Time 134510 tultiplex started
W arning Fid 8151 The multiplex occupancy is above 99.9% please check the available bitrate.
Time 134518 Multiplex complete. Multiplex bitrate 77,3471 Mbit/s.
< (L

Any errors are recorded in the Event Log, which can be opened at any time
before, after and during processing. Here is an example where a table cannot be
multiplexed into the new stream at the specified rate.

Each table has a specification for nominal and maximum interval, in milliseconds,

between instances of the table. These can be edited using the Navigator. The
multiplex engine will try to multiplex the table into the synthesized transport
stream at the nominal repetition rate. Errors are reported whenever packets for
any PID cannot be encoded at their specified minimum rate.

The complete text may be copied to the Windows clipboard, using the Copy
option from the shortcut menu. The text can also be cleared with the Clear
command. Both commands are available from the Edit menu.
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Stopping the Multiplex Engine

The Multiplex Engine can be stopped at any time while it is running. This will
abandon processing and close the file. The file will contain all of the packets
synthesized up to the time the engine was stopped.

To stop the Multiplex Engine, select Multiplex > Stop.

Iﬂmﬂa Window Help

. Start

v Standard Mode

Alternatively, select the Stop button on the Toolbar.

G B - w8

Stop
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Exporting the multiplex configuration file
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Export

Export as

NOTE. Multiplexer is used for generating both conformant and nonconformant
streams. Use the Export and Export As options to save copies of the specification
for nonconformant streams in a multiplex configuration file. This file does not
include a copy of the transport stream, instead, it refers to the original MPEG file
by name and location.

The multiplex configuration file can be reopened using the Import option. (See
page 13.)

Select File > Export to save any changes to the current multiplex configuration
file. Alternatively, use the Ctrl+E keyboard shortcut.

If a multiplex configuration file has not been opened, Export opens a standard file
browser dialog box to specify the file. This is the same as selecting the Export
As... option.

File > Export As exports a file with a user-specified name.
§=8 Edit Miew Options
Close
Examine TS Chrl4T

Expart, .. Chrl+E

Expart &s...

Exit

Multiplexer opens a standard file browser dialog box to select an existing file
or specify a new file.

Ifyou are creating a new file, specify the name of the exported file and select where
it will be saved. By default, files are be created with .muxml as the file extension.
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Multiplexer - Make seamless

When you loop a transport stream to simulate continuous playout, errors can be
generated at the loop point caused by discontinuities in timing information. The
Seamless option provides the opportunity of creating seamless MPEG-2 files.

The option can be set up and enabled so that all multiplex operations result in
seamless output or none.

NOTE. Make seamless supports the MPEG-2 video standard. It does not support
H.264 or H.265/HEVC.

Enabling the Seamless option

Toggle the Seamless option by selecting Multiplex > Seamless or by using the

Li@ .

toolbar button

WSEEEES Window  Help
Start

v Standard Mode
Expert Mode

Feport...

Seamless Settings. ..

v Playout

Playout Settings ...
v Loop
v Lipdate
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Seamless settings

Open the Seamless Settings dialog box by selecting Multiplex > Seamless >
Settings.... The Seamless Settings dialog box appears.

Seamless Settings f‘STI
Priarity program PS5l zettings
[¥ First program in PAT has pricrity ™ Make PSI seamless
Pricrity Program: : . :
I Make remaining programs seamless

ak. | Cahicel Defaults

Priority program  First program in PAT has priority If this setting is enabled, the first program
specified in the PAT will be given priority in
the make seamless process.

If the setting is disabled, the priority program
can be specified in the Priority Program. The
number can be deduced by inspecting the
results of the transport stream analysis.

PSI settings  Make PSI seamless If enabled, the service information contained in the
transport stream is processed to make it seamless.

If the setting is disabled, the PSI/SI is not processed
but simply copied to the output transport stream.

Make remaining programs If enabled, the remaining programs are made seamless

seamless but are constrained by limits defined by the priority
program. This may lead to these remaining programs
having a gap at the beginning and end of the file.
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Abbreviations
AIT

Application Information Table

ASCII

American Standard Code for Information Interchange

ATSC

Advanced Television Systems Committee

CAT

Conditional Access Table (MPEG

CDT

Carrier Definition Table

CVCT

Cable Virtual Channel Table (ATSC)

DSM-CC

Digital Storage Media - Command and Control

DTS

Decoding Time Stamp

EIT

Event Information Table (DVB/ATSC)

ES

Elementary Stream

ETT

Extended Text Table (ATSC)

HRD

Hypothetical Reference Decoder

MGT

Master Guide Table (ATSC)

MMT

Modulation Mode Table

NIT

Network Information Table (DVB)

PAT

Program Association Table (MPEG)

PES

Packetized Elementary Stream

PID

Packet IDentifier

PIT

Program Information Table (ATSC)

PMT

Program Map Table (MPEG)

PSI

Program Specific Information (MPEG)

PSIP

Program and System Information Protocol (ATSC)

PTS

Presentation Time Stamp

RAID

Redundant Array of Independent Disks

RRT

Regional Ratings Table (ATSC)

RST

Running Status Table (DVB)

SDT

Service Description Table (DVB)

SEl

Supplemental Enhancement Information (H.264 and
H.265)

Sl

Service Information (DVB)

SIT

Satellite Information Table

STT

System Time Table (ATSC)

DT

Transponder Data Table (ATSC)

TNT

Transponder Name Table

TOT

Time Offset Table (DVB)
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TS Transport Stream

TSTD Transport Streams Description Table

T-STD Transport Stream System Target Decoder
TVCT Terrestrial Virtual Channel Table (ATSC)

uTtcC Universal Coordinated Time

VCT Virtual Channel Table (ATSC)

VUI Video Usability Information (H.264 and H.265)
XML Extensible Markup Language
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Transport Stream Editor — Getting started

The Transport Stream Editor can be used to edit the contents of transport stream
packets contained in a file. It displays the complete contents of each packet in
hexadecimal and provides an interpreted view of the packet header information.

-‘*;T“Telctrunix MPEG-2 TS Editor - Copy of Ad_10s.mpg

File Edit “iew Toolz Help
=|wi|&[] [le] o] 4
Header Information | Adaptation Field I Adaptation Field Extension
FID Value |1ED
—Flags Adaptation Field Contral
[ Transpart Eror Indicator Continuity Count IE j' Note_:.-’-‘«settingof 00 or 01 will dizable all
™ Papload Urit Start Indicatar |~ Transpart Scrambling Control— the fields on the other tabbed pages
I Transport Fricrity [00-NotScrambled =] | | [11-AdaptationsPayload  ¥]
Displayed Packet 77636 PID: 160 'Ihklmn/ix
oooo 47 00 A0 38 07 10 01 40 12 D3 00 86 81 4C 00 97 .. &8...@. ... . L..
0010 e6 A5 B8 EG 93 94 03 F6 97 43 39 8E 60 88 00 76 £, ..... .. [
oozo 0e CF 24 BO 40 06 C1 50 EO OE OF FO EE A9 DE B3 = @ F. .. . ..
Qo030 08 A0 3E 00 EE GE 28 06 6F 08 20 4D CF 16 44 BD . . :. .n{.o. H. . D.
o040 Ce 00 OB 10 00 30 82 AE 58 G0 0D 58 78 4F 94 A1 .. .. 0. XP.X=z0..
oos0o D1 02 FE 3C 4 F4 50 CB 10 31 01 2D 25 07 24 77 0 ~<L.P..1.—  =w
oos0 25 A0 E1 04 58 20 8A 4E 82 00 37 €0 1C 40 22 8E % . X H. .7 .a".
o070 A1 21 OF <D 0Oe A0 01 94 A6 38 63 91 95 <3 < 85 ... .. .. 8. ...
goso Bs 1B 1s 1D 7B 18 29 96 Y8 41 11 E5 B9 F4 24 98 . . {. ) =A. &
o090 04 OF 83 Ep 73 4F 58 1B E1 DO 51 80 2D D3 CA A1 . . =0X. . Q. — .
0040 21 0C CD 8D OF 3D 8C 14 47 F3 94 70 8C 00 3C 89 V... .=.. G..p. . <.
Oo0B0 C4 47 3C 0D CB 1E 33 85 11 C7 39 DS 6D 47 BD CO G<. .. 3. . .9 miz. .
ooco BS BY BF BF 94 79 8B 4B FC BF 40 BB _ v Ko ek
PDFiter [T <] —F—— | Packet [7763 Goio |‘
Ready |File Size: 55.4ME |Packets: 300001 [Packet Size: 204

Packet headers can be edited from both the header interpretation and hexadecimal
displays. These are referred to as the Header Editor and the Hex Editor,
respectively. All changes made in one view are immediately shown in the other.
The Header Editor is context sensitive, only allowing edits that make sense with
the other fields in the header. It gives full syntax checking of all changes that are
made. The payload and any Reed Solomon data are edited from the Hexadecimal
Editor.

On the right of the Hex Editor pane, the ASCII character is displayed. Unprintable
characters are shown as a period (dot or full stop).

It is normal to edit a copy of a transport stream. Transport Stream Analyzer can
be used to view the original while editing the copy.
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Starting the program

The program may be started by selecting the Tektronix TS Editor option from

the Start > Programs menu or by double-clicking the Tektronix TS Editor
shortcut on the desktop.

@ Tektronix TS Analyzer
? Tektronix TS Cutter
.-,.l'r‘ Tektronix TS Editor
%_:_g Tektronix TS kaker

E ditar
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Initial appearance ~ Once the program has started and is ready for use, it will open a Main Window
that looks like this:

3§ MPEG-2 TS Editor - [No File]

File Edit “iew Toolz Help
|| =) B e Bl
Header Information | Adaptation Field | Adaptation Field Extension

RO |

= Flags sdaptation Eeld Eanto
I Transport Enor Indicator | | ZTimly Eourt [ Bt s skt o 00 0 o sl
™| Papload kit Starthdizaten || = ranspon Serambling Comtol allttie fields o the athertabbed pages
™| Tiranspart Friornts j I j
Displayed Packet: Mone PID: 'Ibktrnn/ix
NalData

PID Fiter I [0 o e|3]] —m———— |F'ac:ket| Elaiel|

Feady |File Size: 0 bytes |Packets:  |Packet Size:

Options

The Transport Stream Editor has a set of options relating to general use and
opening files. It is a good idea to review the options before opening a file.

The settings can be changed at any time by selecting Options... from the Edit
menu. This opens the Options dialogue box.
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Opening file

General options

118

Options |

— Opening file
O Always edit copy

i~ Alwaps edit oniginal, dont make copy
% Alwaps ask

¥ Orly open walid MPEG Transpart Streams

Mote: “walid' meanz having b conzecutive sync
bytes [0xd7] spaced either 183 ar 204 bytez
apart

[T Open az ARIB ISDB-S Transport Streams

— aeneral Options
¥ Show Wizard Introduction pages
¥ “wiarn about remapping to existing PIDs

Cancel |

Specifies how the program will interpret the packet size of the stream. The options
are mutually exclusive and are as follows:

" Always edit copy When opening a file Editor always makes a copy, without
asking.

" Always edit original, don't make copy Uses the original files without making a
copy or asking for confirmation.

*  Always ask Before opening a file for editing, asks if it should edit the original
or make a copy.

¥ Only open valid MPEG Transport Stream files Will open files that have five
or more consecutive sync bytes.

Open as ARIB ISDB-S Transport Streams Opens transport streams encoded as
ARIB ISDB-S format (including TMCC information).

¥ Show Wizard Introduction pages Causes any wizards invoked by Editor to
display their Introduction pages.

W Warn about remapping to existing PIDs Warns if an operation will remap
a PID onto one that is already in use.

MTS4000 and MTS4SAV3 Generator Applications User Manual



Transport Stream Editor — Getting started

Opening a file

Opening a file from the
menus and toolbar

Any stream that is held in a file can be edited with the Transport Stream Editor.

To edit a file, select the Open from the File menu. If the required file is in the
list of recently edited files, it may be selected from the list to save using the
Open file dialog box.

Alternatively, use the Ctrl+O keyboard shortcut.

s7dTektronix MPEG-2 TS Editor - [N

(Al Edit “iew Toolz Help

HF

1 Copy of &d_10z.mpg
2 Copy of &d_Bz.mpg
3 Copy of &d_5z.mpg
4 Copy of Test.mpg

itk [t
it Eresiem
Print Setup...

Exit

There is also a shortcut button available on the Toolbar for opening a file, which
has the standard file open symbol:

4= e e e S
W

4
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Opening a file from
Windows Explorer or a
file browser window

Copying a file before
editing

120

The program can be started and a file opened (with the last set of program options)

in a single operation from Windows Explorer or a File Browser Window.

Place the pointer over the file name or icon, press the right mouse button to open a

menu, and then select the Edit option.

51 Exploring - Samples

File Edit “iew Toolz Help

0] x]

Ia Ses

[

Bl $Ble| o] X|E| ]els

| &l Folders

| Contents of 'Ses’

Desklop

rdy Cornputer
-2 3% Floppy &)
- Disk1_voll ()

+

Size | Type | Modified
Z20TKE MPEGZ File 5421495 233 PM
41517KE  MPEGZ File 5/22/95 10:27 Al

PEGZFila 5/23/96 6:15 PM

Mame |

H-ag Video [E] Y ad3 10emp Analyse PEGZ File 5/8/95 217 PM
L Samples

& Cantral Panel

(] Prirters Send Tao ¢

TS Editor writes all edits to the file immediately. To avoid accidental changes to
prime data, the application can make a copy of the file and edit that copy. By
default, once a file has been selected for opening, you are prompted to decide
whether to edit the original or make a copy.

If you do not want to be presented with this dialog box each time a file is opened,
set the copy or edit original option as the default.

]|

Copy File

IMPORTAMT
All changes to the loaded file will be immediately written to disk, ovenariting
the file cantents. |t iz therefore recommended that a copy of the file i used
for editing in caze recovery i NeCeszan.

Do you want to edit a copy of this file?

" No, | want to edit the original.

* Yes IE:'\SampIes'\Enp_l,l of &d_10z.mpd

Browse. .. |

[ Always use the above setting when opening a file

Maote: If the abowve box iz ticked, thiz dialog will not appear again until
the “dlways Azk" zetting iz zelected in the Edit.. Optionz dialog.

k. Cancel

It is recommended that this dialog box be left as the default option.

If someone else has used the MPEG Test System, it is a good idea to look at the
Options before opening a file.
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To edit the original file, (useful when making edits to a file that is already a copy)
select the No, I want to edit the original option, and then select the OK button.

To make a copy, select the Yes option, specify the copy file, and then select OK.
While the copy is being made, the pointer changes to the busy pointer, usually
an hour glass.

When the Edit a copy option is selected, the dialog box suggests a suitable
filename, which you can edit. To look for a different directory or filename, select
the Browse button. This will open a standard file browser window, like this:

Save Copy As
Save in: |@ Shreams j &= =k E-

- 9? dvb_825_mepc3
k! # dvb_B25_mcpc_100mbps
My Recent |7 dvb_izS_mepe_t4Smbps
Documents

€]

Deskiop

o
My Documents
Iy Camputer

Fdy Metwork, File: narne: |E0p_l,l of Copy of Copy of T elefonica - Save |
Places

Save as tppe: |MPEG Files [*.mpa) j Cancel
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Transport Stream Editor — Menus and controls

The following pages contain descriptions of the different menu options, toolbar
controls, status bar, and slider bar.

Toolbar

The Toolbar provides a set of convenient shortcuts for the more frequently used
menu options. The available commands are:

5| | S| (2| Bo|Fa| B[ o o

&

E’*l Opens a file. If a file is currently
open, it will be closed when a new
file is selected.

Closes the current file. There is no
save option because all changes
are written to file immediately.

Prints the current packet.

|5,

Opens a print preview of the current
packet.

Copies the bytes that are currently
selected in the Hexadecimal Editor
from the packet to the clipboard.
The bytes are copied using the
hexadecimal representation. This
button is disabled (grayed out)
when nothing is selected that can
be copied.

Copies the entire contents of the
current packet to the clipboard.

Pastes any data, held in

the TS Editor's hexadecimal
representation, from the clipboard
into the packet starting at the
currently selected byte.

Undoes the last edit, restoring the
previous value. Selecting Undo
again undoes the previous change
and so on.

2| [ | @

1@ ||&

3

Reinstates the previously undone
change.

Opens the Options dialog box.

[ |12
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Status bar

The Status bar may be hidden from view, but if it is always visible at the bottom of
the window. It displays the following information about the program and open file:

|Readv File Size: 323.0ME  Packets: 1660416 Packet Size: 204 |

Message field File Size Packets Packet Size
Shows program status / describes Shown in bytes, Total number Ether 158 or
any hutton or menu option over KB, MB or GB of packets in 204 hytes
which the pointer is placed the file

A J1 d
Resdy. Fil Size: 55 0MB | Packets: 310001 | Packet Sive: 204 |

i*;ﬁTektrnnix MPEG-2 TS Editor - Ca
File WM *fiew Toolz Help

The message changes to

describe the function of the hutton Undo Chl+2 '
or menu option ov er w hich the mouse Heds ik
pointer is placed. Copy Chl+C
{ The description is still displayed if the Copy Packet

button or option is not availakble,
i.e. greyedout. )

Paste Chel+

Select the entire packet [File Size: 58.0MB  |Packets: 300001 |Packet Size: 204 |

When no file is open, the File Size, Packets, and Packet Size fields are all set to
zero or null:

IReady File Size: 0 bytes Packets:  Packet Size: |
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Slider bar

PID filter

Slider

124

FID Filter I'IEEI <|>| I Facket IEMEEE [t I

The contents of any transport stream packet in the currently open file can be
selected using the Slider bar. Packets are numbered according to their position in
the file, with the first packet being 0 (zero).

The controls in the slider bar are:

PID Fiker Option
In operation when
checked like thizs...

PID Humber
Zet= fiter to select only
packetz of thiz PID

PID Filker

To select
packets from a
zspecific PID...

...check the
PID Filter
option...

thentype
in the PID
nmber

Maove to slider
next Scrolls through all
packet packets in the file.
Move to \Jj. J}.
previous }
packet

of file
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Packet number
Packet Humber

Shoves current packet number .
Mew values can be typed in.

Goto Button
Selects packetz shown
in Packet number.

Toselect
a packet by

number

click in the
Fadket Number
Field and type in
the new value

then click
on the Goto
Button

It is normal to edit a copy of a transport stream. Transport Stream Analyzer uses
the same packet numbering as Editor. So the packet number can be used to find
and view a packet in Analyzer, and then edit the copy of the same packet in Editor.

The Slider Bar can be dragged from the edge of the main window into a floating
pallet. To do this, place the mouse pointer on the background (inside the Slider
Bar), hold down the left mouse button, and drag the slider bar away from the
window border. The result is a self contained window that looks like this:

PID Filer v |1E:n <]

')

Facket IEMBEIE E{zie] |

To replace the Slider Bar on the window border drag, it over the border until the

outline changes shape.
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Menu options

The following pages describe all of the menu options. Since many of the options
are context sensitive, they will be available only when their function is appropriate
for the selected window or display element. When a menu option is not available,
the option is grayed out.

File menu options  The following table lists the File menu options.

Table 14: File menu options

Command Function

Open Opens a file for editing. If a file is currently
open, it is closed when a new file is selected.

Close Closes the current file. There is no need
for a save option because all changes are
written to file immediately.

1 <filename> A list of the four most recently edited files. If
2 <filename> the program has recently been installed, the
3 <filename> list may be empty or hold less than four files.
4 <filename>

Print Prints the current packet.

Print Preview Opens a print preview of the current packet.
Print Setup Selects printer and configuration.

Exit Closes any file that is open and terminates

execution of the program.

Edit menu options  The following table lists the Edit menu options.

Table 15: Edit menu options

Command Function

Undo Undoes the last edit, restoring the previous
value. Selecting undo again undoes the
previous change.

Redo Reinstates the previously undone change.

Copy Copies the bytes that are currently selected
in the Hexadecimal Editor from the packet to
the clipboard. The bytes are copied using
the hex representation.

Copy Packet Copies the entire contents of the current
packet to the clipboard.

Paste Pastes hexadecimal from the clipboard into
the packet starting at the currently selected
byte.
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Table 15: Edit menu options (cont.)

Command Function

Select Packet Selects the entire contents of the packet.

Fill Prompts for and fills all selected bytes with
a value.

Options ... Opens the options dialog.

View menu options  The following table lists the View menu options.

Table 16: View menu options

Command Function

Toolbar Shows or hides the Toolbar, which provides
a set of convenient shortcuts for the more
frequently used menu options.

Status Bar Shows or hides the Status Bar.

The following menu options select which standard is used to interpret the values held in the
Transport Scrambling Code field. Only one standard can be selected at any time.

MPEG2 Selects the MPEG?2 interpretation of the
Transport Scrambling Code.

DVB Selects the DVB interpretation of the
Transport Scrambling Code.

ATSC Selects the ATSC interpretation of the

Transport Scrambling Code.

Tools menu options  The following table lists the Tools menu options.

Table 17: Tools menu options

Command Function

Remap PIDs... Starts the tool to Remap packets from one or
more PIDs to different PIDs.

PCR Recalculation... Opens a Wizard to Recalculate the Program
Clock References (PCR) carried in one or
more PIDs.

Help menu options ~ The following table lists the Help menu options.

Table 18: Help menu options

Command Function

About... Displays the program version number and
license number.
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Transport Stream Editor — Hex Editor

The Hex Editor displays and provides editing facilities for the contents of the
current packet in both hexadecimal representation and ASCII characters.

Displayed Packet. Packet Identifier
tatches packet numbers of the currently
in TS Analyser and dizplaved packet

tranzportation packet
zhown in FES Analvzer

Displayed Pacer 14508 FID: 57 'Ibktmn}x

oooo 47 40 20 12 02 02 BJ 2E 00 01 C1 OC 0O E1 21 RO @ ... = T I
o010 20 €2 EL 21 FJ 00 04 E1 22 FC 06 02 04 67 65 72 .. 1. ... " . . cCg
nzn 1 r4 w0 ERF1 A N& 014 AR5 RE A7 N1 N4 N K9 FN ¥ ANg ¥
0020 26 €A 04 CO 72 00 01 04 EO DA T0 0C D& 02 72 70 . fre. . s

uuan 51 L1 V¥ LD 14 8L kA FF KB OFE BE KK B OFE PR FE a.w. ... L.
0050 ¥ FF FF FF F= FF F¥ FF FF FF FF FF FF FFE
n060 IF FF FF FF FT FF F¥ FF FF FF FF FF FF FFE
0070 ¥ FF FF FF F7 FF F¥ FF FF FF FF FF FF FFE
oo XF I 0°F L O I 'Y IT I I I I'E I FUC
yual oF FE b FR BS PR BOEE FEOFE BEOFE P OFE
00A0 =F FF FF FF F= FF F> FF FF FF FE FF FE FE
D0EQ FF FF FF FF F7 IF F7 IF FF FF FF FF 25 &C
00C0 231 02 B2 7 B4 EA 1z FS 22 0C CE DB =

I ]

ASCI Editar.

skl

e
T
[
i

&

(=]
ry
]
i

Hexadecirmal Editor. :
Dizplays each byte az a pair of Dizplays each byte as
hexadecimal digits, which may an ASCll character.

be selected and edited. Unprintable characters
{and periods) are shown
az periods {dots).
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Color coding

Color coding is used to show the "footprint" of various header fields, in both the
hexadecimal and ASCII views. The packet payload and any Reed Solomon data is
shown in black. The bytes of the packet header field are shown in magenta text.

Displayed Packet 148279 PID: 32 'Ibklmnjx
0000 47 40 20 12 00 02 BO 3E 00 A1 CL 00 00 EL 21 FO G@ _...>.
0010 e 7 =0 00 04 EI 22 FO 06 04 04 67 65 -

0020 01 04 €5 EE £7 0L 04 EO0 59 # % . .enc
0030 06 0& Oy 04 E0 5 FO 05 né/u:) . fre. T
0040 61 01 77 O FF FF FF FF FF E W
0050 FF FF FF FF FF t.  "\FF ©F FF FF EFge® FF FF

0060 FF FE FF FF FF FF * | p 1o Packet “FF FF FE FE FF

o070 FF FF FF FF FF FE

Anoh T T T O T OO Header colour

coded magenta

FF FF FF FF

T T T T TT

Displayed Packet 94392 PID: 160 'Ibklmnj,x
0000 47 00 &0 37 07 10 O1 40 84 D5 00 10 46 99 0& 65 G..7.. @ .
0010 = #r. ... *® .0
gozo oL, fEaw_  WOR 91 1& D2 .. ... £z
0030 AE M. ...
0040 CO 8L S B
0050 30 07 o Ang 0. .t . .1
0060 82 "4 hyte Packet el
0070 2" Header colour ke
coded magenta
If transport private data is present it is shown in green:
Displayed Packet 17297 PID: 179 'Ihktmnjx
0ooo 47 00 E3 12 00 EE C7 F3 80 G20 ...
4. jFa
(IS - S
3&L0O. ... I
t . RO. G

[ 4 byte Padet
Header colaur

Transport Private

Adaptation Field

colour coded blue

Data colour coded

coded magenta green

NOTE. It is possible to define a transport private data area that is not contained
within the adaptation field area specified by the adaptation field length.
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Selecting and editing

Individual bytes

Block of bytes

130

One or more bytes can be selected using either the hexadecimal or ASCII view.
Changes are made using options from the menus and by typing new values in
the hexadecimal view.

When the mouse pointer is moved over either of the views in the Hex Editor, the
pointer changes to the Text Select pointer.

To edit a byte or character, position the mouse pointer over the desired character
in either the ASCII or hexadecimal view. Then click the left mouse button. A
flashing inverse video cursor appears to the left of the character.

Alternatively, double-click either view of the byte to select it for use with an
option from the Edit menu operation.

New values can be entered from the keyboard. As each character is typed, the
cursor moves on to the next. It can be repositioned with the mouse or by using the
up, down, left and right cursor keys.

The cursor will not move forward beyond the end or back before the start of the
packet. To select another packet, use the Slider Bar.

A block of bytes can be selected for operations such as copying to the clipboard
or filling with the same value.

Click on the first required byte and hold down the left mouse button. Then drag
the mouse pointer to the last byte to be selected and release the left mouse button.
Both the ASCII and Hex views can be used for selection. The selection is shown
in inverse video in the view from which the it was made, and by an outline around
the selection in the other view. For example, when made from the ASCII view, a
selection looks like this:

nooo 47 40 10
0010 FF FF FF
noz20 FF FF FF
0030 FF FF FF
0040 FF FF FF
0050 FF FF FF
0060 FF FF FF
0070 FF FF FF
0080 FF FF FF
nooso 12 40 10
00AQD 4F 52 4

00BO Td s 1%

Once selected, the block of bytes can be edited with the available options from
the Edit and the Pop-Up menus. Clicking the mouse or pressing a cursor key
clears the selection.
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To select a block using the cursor keys: position the cursor on the first byte,
and then hold down the Shift key and move the cursor with the cursor keys.
The selection is drawn between the initial and current cursor positions. Release
the Shift key when the cursor has reached the last byte. Clicking the mouse or
pressing a cursor key clears the selection.

Editing commands  The Edit menu, pop-up menu, and toolbar buttons provide a variety of options
for editing the packet contents. The Pop-Up menu is opened by clicking the right
mouse button when the pointer is over the Hex Editor, for example:

d Packet 18398 PID: 289 Ibklmn/ix
012134mmm[}?86?DDBE G4 G hg..
5 05 41 EC 11 FF 12 B4 69 18 €2 53" Lndo Chsz | .. .1..5  .P
! 2E A1 B4 42 04 BE BO 20 ED 3E 83 g . cuen B o2
1 7 FF B2 B1 68 05 36 2D 2D 38 1D _ = h.6——8..0
| A& 1B 44 33 8F 41 9% 74 E0 16 C2 L h.z....g=1
. 41 C3 A&7 07 A0 B2 20 07 24 @7 1o | oRY L I
' 82 Fh 13 9E 83 3F E2 S6 94 Be 0C | LopyPacket A - B o]
S A7 42 2C 2B 89 52 AG 71 00 84 C2 | Paste Chkd . R.a.......
* Ba 24 43 78 29 C% 71 41 DD 21 EC e gk L
1 96 34 68 10 C5 Bl 69 68 E1 94 AB | Select Packet ik, 41,
. 68 D0 &9 DF 04 32 Ei 14 4& E0 96 gy - B PO
1 1C C0 03 96 20 52 2B 66 GB 26 Ba _ = S+f[&.
Print... Chrl+P

Depending on what operations have recently been performed and on what is
selected, the menus and toolbar will offer different commands. The complete set
of menu options and associated buttons are as follows:

iI TS Editor keeps a list of recent changes.
Each Undo command backs out the most
recent change from the list. That change is
moved to the Redo list in case it needs to
be reinstated. As each change is undone
the cursor moves to the appropriate field (in
the Hex or Header Editors) and restores the
previous value.

Reinstates the most recently undone
operation. When a new edit is made, the
Redo list is cleared.

Copies the currently selected bytes to
the clipboard. From there they may be
pasted in to other packets or used by other
applications.

Copies the entire contents of the current
packet to the clipboard. From there it can be
pasted into other packets or used by other
applications.

Pastes packet contents held on the clipboard
into the current packet, starting at the current
cursor position.

2

[

&
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132

Select Packet Selects the entire packet. This is a quick
alternative to selecting all the packets with
the mouse or keyboard.

Fill Fills all the selected bytes with a hexadecimal
value.
Fill Byte

Fill " alue [in Hex] [FF
(] I Eann::ell

This option opens the Fill Byte dialog box.
Enter the fill value then select the OK button.
The Cancel button abandons the operation,
leaving the bytes in their original state.

There are no Toolbar buttons for the Select Packet and Fill commands.
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Transport Stream Editor — Header Editor

The Header Editor has three tabs. These show and allow editing of the basic
header, adaptation field, and the adaptation field extension contents. The Hex
editor is immediately updated to show the new values when changes are made in
the Header Editor.

Binary flags are shown with check boxes whose state can be changed by clicking
in the box with the mouse pointer. Multi-bit fields may be edited by typing in the
new values or selecting a value from a drop-down list.

NOTE. It is important to remember that changing a flag or field often alters the
structure of the header. The other flags and fields will be reinterpreted according
to the data underlying their new position in the structure.

Header Information tab

Header [nfarmatian | Adaptation Field | Adaptation Field Extension

FIDVale [2
—Flags Adaptation Field Control
I~ Transport Errer Indicator Contiy Court [2 <] Nate: 4 setting of 00 ar 01 wil disable &l
[¥ Paload Unit Start Indicator | - Transport Scrambling Control— | 1 fields on the ather tabbed pages
I Transport Frioity 00-Not Scrambled ¥ || [01 - Payload Only =]

The Header Information Tab interprets the contents of the Packet Header (shown
in magenta text in the Hex Editor) for ease of understanding and editing.

The PID Value field displays, and allows editing of, the 13-bit PID as a decimal
value. (The PID is packed into a pair of bytes with the Flags shown below.)

PID Y alue |32
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The Flags fields display the state of each binary flag in a check box:

Flagz

[ Tranzport Eror Indicator
v Payload Urit Start Indicatar
[ Transport Priority

= 0 or false
¥ =1 or true
Click in the box to toggle the state of a flag.

The Continuity Count field displays the value of the four bit Continuity Count
field in decimal.

Continuity Count I 2 I

To avoid any typing errors, the drop-down list allows selection of a different value.

The Transport Scrambling Control displays the two bit Transport Scrambling
Control field as a binary bit pattern, with a text description.

Tranzport Scrambling Control

EI
10 - Uszer defined
11 - User defined

Use the drop-down list to select a different value.

The text gives the interpretation for the bit pattern according to the standard that
is currently selected: MPEG2, DVB or ATSC. Use the View menu to select the
required option.
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The Adaptation Field Control displays the two bit Adaptation Field Control as a
binary bit pattern, with a text description.

Adaptation Field Contral

MHaote: & getting of 00 ar 07 will dizable all
the fieldz on the other tabbed pagez

01 - Payload Oy |

00 - Reserved for future use

10 - Adaptation Figld Only
11 - Adaptation+Payload

Use the drop-down list to select a different value.

The Adaptation Field and Adaptation Field Extension Tabs will be empty (grayed
out) when the 01 - Payload Only or 00 — Reserved values are selected.

Adaptation Field tab

Header Information  Adaptation Field I Adaptation Field E stension I

Adaptation Field Length Iﬁ I PCRFlaga ——— I Splicing Paint Flag
Flags FCR Yalue |1 2604236616 Splice Eaumtdaw I
r Dizcontinuity |ndicatar
B Rl e it " OPCRFlag— | [ [ Transport Privats Data Flag |
[ Elementary Strearn Pricrity DR I L5ta Lengtt I

™ Adaptation Field Extension Flag

The Adaptation Field Tab interprets the contents of the Adaptation field (shown in
blue text in the Hex Editor) if one is present in the packet. To be able to edit an
Adaptation Field, the Adaptation Field Control value in the Header Information
Tab must indicate that an adaptation field is present.

The Adaptation Field Length field shows the length of the Adaptation Field in
bytes and allows it to be edited in decimal.

Adaptation Field Length I?
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The Flags fields display the state of the binary flags in check boxes:

Flagz

[ Tranzport Eror Indicator
v Payload Urit Start Indicatar
[ Transport Priority

= 0 or false
W =1 or true
Click in the box to toggle the state of a flag.
The PCR Flag field displays the state of the binary PCR Flag in check boxes:

¥ PCF Flag
|VF'EH Walue |1 2E04256E16
= 0 or false

W =1 or true

When the flag is true the PCR Value is shown and can be edited in decimal
notation.

The OPCR field displays the state of the binary OPCR Flag in check boxes:

OPCR Yalue |?1 1313164970

rﬁ OFCR Flag

= (0 or false
W =1 or true.

When the flag is true, the OPCR Value is shown and can be edited in decimal
notation.

136 MTS4000 and MTS4SAV3 Generator Applications User Manual



Transport Stream Editor — Header Editor

The Splicing Point Flag fields displays the state of the Splicing Point Flag in
check boxes:

|'|7 Splicing Paint Flag

Splice Countdown IE

= 0 or false
W =1 or true

When the flag is true, the Splice Countdown value is shown and can be edited in
decimal.

The Transport Private Data Flag field displays the state of the Transport Private
Data Flag:

[V Tranzport Private Data Flag
|VData Length |1 2 —‘

= 0 or false

W =1 or true.

When the flag is true, the Data Length is shown in bytes and can be edited in
decimal.

The Adaptation Field Extension Flag indicates the state of the binary Adaptation
Field Extension flag.

W Adaptation Field E stersion Flag

= 0, no Adaptation Field Extension. The Adaptation Field Extension Tab can be
viewed, but all of the fields will be grayed out.

W = 1, Adaptation Field Extension present. The Adaptation Field Extension
Tab will show and enable editing of the information contained in the Adaptation
Field Extension.
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Adaptation Field Extension tab

Header Information | Adaptation Field Adaptation Field Extension |

Extenzion Length |21 9

¥ LT Flag ] ¥ Seamless Splice Flag
LTw Valid [ Fiscewiss Fate | 296701 Splice Type |11DD :l'
LT Offset |13525 DTS Mext AL |2325284584

The Adaptation Field Extension Tab interprets the contents of the Adaptation
Field Extension if one is present in the packet. To be able to edit an Adaptation
Field Extension the Adaptation Field Extension flag must be set to 1 (the box must
be checked) in the Adaptation Field Tab.

Shows the length of the Adaptation Field Extension in bytes and allows it to be
edited in decimal.

Extenzion Length  |219

Displays the state of the LTW Flag:

W LT Flag

LT Walid W
LTw/ Offest  [12525

=0 or false
M =1 or true

When LTW is true, the state of the LTW Valid flag and value of the LTW Offset are
shown. The Valid flag may be toggled and new Offsets can be typed in decimal.

Displays the state of the Piecewise Rate Flag:

[V Fiecewise Fate Flag

Piecewize Rate |398?U1

= 0 or false
W =1 or true

When the flag is true, the Rate is shown and can be edited in decimal notation.

138 MTS4000 and MTS4SAV3 Generator Applications User Manual



Transport Stream Editor — Header Editor

Displays the state of the Seamless Splice Flag:

¢ Seamless Splice Flag ——

Splice Type IH':":I ]"
DTS Hext AL |2325254584

=0 or false
W =1 or true
When the DTS Next AU value is shown and it can be edited in decimal notation.

The 4 bit Splice Type is shown as a bit pattern.

¥ Seamless Splice Flag

Splice Type Il:":”':' :Iv

DTS Mext &l

It has a drop-down list containing all 16 possible bit patterns.

Use the list to select a different value.
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Transport Stream Editor — PID remapping

NOTE. The packets of one or more PIDs may be remapped (moved to different
PIDs). Only the PID in the packet headers is changed. Any packet payload
contents, such as SI and PSI tables are unaffected. So remapping can break the
references from tables to PIDs, or be used as an investigation to correct broken
references.

To remap packets from one or more PIDs, select the Remap PIDs option from
the Tools menu.

MPEG-2 TS Editor - [Mo File]
T Help

PCR Recalculation... |

The program scans the file to build a list of PIDs, displaying the Hourglass mouse
pointer while it is busy. It then opens the Remap PIDs dialog box:

Remap PID= |

Toremap a PID value, first select a PID entry and
either double click or prezs the Edit button. Then
prezs the Femap button to perform the remapping.

I:urrentF'ID| Mapto = Edi... I

1] 1]
16 16 | Restare |
17 17
32 32
33 33
34 34
35 35

36 3k Elemap
aa 28 - —l
4| o ml » Cancel |

To specify a mapping from a current PID to a new PID, select the current PID
entry from the list by clicking on it.
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Remap PID= |

Toremap a PID walue, first zelect a FID enty and
either double click or prezs the Edit button. Then
prezz the Femap button to perform the remapping.

Current F'ID| b ap to :l Edit... I

114 114
115 115 Restare |
120 120
121 121
122 122

123 123 J

160 160

161 161 Eemap
162 2 - —I
4| o HT_;I_I Cancel |

Now select the Edit.. button, which opens the PID Entry dialog box.
(Alternatively, double-click on the required entry in the list.)

PID Entiy
MapPID [152 o

] I Cancel |

Type in the value for the new PID to map to and select OK.

PID Entiy

tap PID I'IEE to ISD?E
] I Eann::ell

Repeat this process for each PID that is to be remapped.
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The Restore button will change the value of the selected Map to PID back to that
of the Current PID without having to open the PID Entry dialog.

When all the mappings are specified, select the Remap button. (The Remap button
is not enabled unless one or more mappings has been specified.)

Remap PIDs |

Taoremap a PID value, first zelect a PID entry and
eithier double click or prezs the Edit button. Then
press the Remap button to perform the remapping.

EurrentF‘ID| tap tao il Edit... I

115 115

120 120 Restare |
1241 121

122 122

123 123

160 3060

161 3061

Remap

283

28 -
o T Carcel |

The hourglass mouse pointer is displayed while the program performs the
remapping. On completion, the dialog box closes and control is returned to the
main window.
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Transport Stream Editor — PCR recalculation

The Program Clock References to one or all Programs can be changed. The
rate can be changed and/or any one of six types of jitter added. Uses of PCR
Recalculation include:

B Recalculating the rate at the correct value, without adding jitter, on a recording
of a faulty stream can be used to remove suspected PCR problems. If the
recalculated stream works correctly the problem is in the PCR.

B (Creating test data with known deviations in rate for exercising other
equipment.

NOTE. Do not perform PCR Recalculation on an original recording. This
operation is not reversible, so it is strongly recommended that a copy of the
original file is used.

To modify the PCR, select the PCR Recalculation option from the Tools menu.

MPEG-2 TS Editor - [No File]

Help
J Remap PlDz... J
PCR Recalculation. ..

=N Tools
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This runs a wizard to analyze the program structure, guide the user through the
available options, and then recalculate the PCR values. The wizard presents 3, 4
or 5 pages depending upon the chosen options:

PCR Recalculation Wizard |

Thiz \Wizard guides you through the steps for moditying the
PCR walues for one or all af the programs in the curmently
apen MPEGZ file.

wiaHMING: Pleaze note that once performed, thiz operation
clears the Undo buffer and the process cannat be "undone",
Wwie therefare strangly recommend that you have a copy of
the file you are editing.

Prezzing Cancel on any of the following pages will cloge the
“Wizard and leave the file unchanged

Before pou can zelect which program(z] pou wish to modify,
the Yfizard needs to analyse the file and pull aut all program
information. Please be patient az thiz may take a few minutes
far wer large files.

Digital ¥ideo
Broadeasting [ i dont want to see this screen again, thanks

% Bach I Mest > I Cancel | Help |
SolectProgam ]

“'ou may change the PCR rate for all programs in the
ztream by ticking the box below

Alternatively, select the single program whose PCR rate
you wigh ta edit from the ligt below.

Frogiam | PMT FID | PCRPID | Rate [Mhz] |

1 a2 289 3|ma
2 i 205 3|mha
3 34 160 3805
4 25 161 38.Mm5
] 36 162 3|mha

Digital Wideo
Broadcasting

< Back I HEewts Cancel HEelm
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Select Mew Rate |
Fate Calculation

Pragram Murmber 2
Current Playout [Mbitz/z] [33.015

M ew Plapout [kbitseds]

Jitter Function |< none: j

PEG-

D\/3

Digital Wideo
Broadcasting

< Back I Hest > I Cancel | HEelm |

Select Jitter Parameters |

Y'ou have zelected to add the follawing

ektrun]x Jitker functian |
£ Jitter Funchion W

Pleasze specifty the parameters applicable
ko thiz Jitter function

Standard Deviation [ns]  |UKA

PEG-

D\/3

Digital Wideo
Broadcasting

¢ Back I Hest > I Cancel HElD

By default, the wizard will display this Introduction first.
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PCR Recalculation Wizard |

Thiz ‘Wizard guides vou through the steps for moditying the
PCR wvaluez far ane or all af the programs in the currentiy
open MPEGZ file.

WARMIMG: Please note that once performed, thiz operation
clears the Unda buffer and the process cannat be "undone",
‘Wi therefare strongly recommend that you have a copy of
the file vou are editing.

Prezzing Cancel on any of the following pages will cloge the
“Wizard and leave the file unchanged

Before you can select which program(z] vou wizh to modify,
the “wizard needs to analyze the file and pull out all program
infarmation. Pleaze be patient az this may take a few minutes
for wer large files.

Digital ¥ideo
Broadcasting [T I dont want ta zee this screen again, thanks

< Back I Mest > I Cancel Help

It may be disabled for future recalculations by selecting the check box option at
the bottom of the introductory text. Selecting the Next button moves on to the

Select Program page.

The wizard has to analyze the file to extract the relevant Program Information,

which may take a while. When analysis is complete, the Select Program page

shows a list of the programs whose PCR values may be changed (see the following

illustration).

Select Program |

“'ou may change the FCR rate for all programs in the
ztream by ticking the box below

&l programs? [~

Alternatively, zelect the zingle program whoze PCH rate
you wizh to edit from the list below,

Program | PMTPID | PCRFID | Rate (Mhz] |

1 32 289 38015
& 3.3 2805
3 34 1E0 3|ma
4 il 161 3|.Mmha
] 36 162 3805

Digital ¥ideo
Broadcasting

< Back I Mest > Cancel Helm
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To recalculate the PCR rate for all the programs, check the All programs? option.
Otherwise, select one of the programs from the list. Then select Next to move on to
the Select New Rate page. The Back button moves back to the Introductory Page.

Select Hew Rate |

R ate Calculation

Frogram Mumber 2

Current Playout [Mbitz/z] (32.015

MHew Playout [Mbitzds] 38.015
_ Jitter Function |<HDHE> j
PEG-
Digital Widen

Broadcasting

< Back I Hest » I Cancel HElm

Keeping the rate as New Playout = Current Playout and selecting Jitter Function
of <none>, will recalculate the PCR based on the current rate. This could be used,
For example, to investigate a suspected problem with the PCR by playing the
original and recalculated versions to see if there is a difference.
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A new playout rate can be specified and/or a Jitter Function can be applied to the
rate. There are seven Jitter Functions available including <none>. The available
functions are:

Select Hew Hate |

R ate Calculation

Program Murmber 2
Current Playout [Mbitz/z] [28.015

f e Plapouk [bbitsz] ISB.EH 5

.. <noner
' Impulze
Digital Video aqatrﬁgamwﬂe
Broadcasting B aussian

< Back I Mest > I Cancel HelD

Each of the jitter functions is described in more detail at the end of this subsection.

If a Jitter Function is required, choose one of the six functions from the drop-down
list, otherwise leave it set to <none>. Specify any change in the New Playout rate
and select the Next button. Selecting Back returns to the Select program page.

When no Jitter function, (<none>), was selected, the Select Jitter Parameters
page will not appear. Go on to the Summary page, which shows a picture of
a checkered flag.

With a Jitter Function selected, the next page will be Select Jitter Parameters. This
asks for additional information specific to the chosen Jitter Function. For example,
the Sine Wave function requires the parameters shown in the following illustration.
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Select Jitter Parameters |

You have zelected to add the fFallawing
Jitter function

Jitter Function  [SineWave

Pleasze specify the parameters applicable
ta thiz Jitter funchion

ektrnnjx

e b aw. Amnplitude [ng] 1.0
MPEG-2  Feiod (sl [i0
Digital Wideo

Broadcasting

< Back I Hest > I Cancel HEelm

Specify the required parameters and select Next to move on to the Summary page.
Use the Back button to return to the Select New rate page.

The Summary page displays a short list of the specified PCR rate changes.

Y'ou have chozen the following action:

Apply PCR changes to: Frogram 2

Old R ate [Mbitzz): 38.015
Mew Rate [Mbitzz]; 38.000
Jitter Function: £ NONE:

Click on Finigh to recalculate all the PCR values in the
program(z] zpecified

< Back Cancel HElm

NOTE. Select Finish to recalculate the PCR values. Remember, once Finish has
been selected, there is no going back.
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Jitter functions

150

Use the Back button to return to the previous pages to make any changes.

The program may take a while to perform the recalculations. The Summary page
will stay on screen and the Hourglass mouse pointer be displayed while the wizard
is processing. When the summary page disappears the calculation is complete and
the file can be closed or edited.

Select the required Jitter Function from the Select New rate page, then select
Next to move on to the Select Jitter Parameters page to specify the parameters
for the selected Jitter Function. The following subsections give details about
each function.

Select Hew Hate |

R ate Calculation

Program Murmber 2
Current Playout [Mbitz/z] 22015

[ ey Plapout [k bits/z] I38.D1 5

Jitter Function

PE G- <hone:
' Irmpulze
Cigital Yideo aqatr:adfmwcwe
Broadcasting C assin

< Back I Mest > I Cancel HEelm
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Impulse

Tro

D\/3

Digital ¥ideo
Broadcasting

Max Amplitude

The Impulse Jitter function adds a positive or negative value to a single PCR.

rou have zelected to add the following
Jitter function

Jitter Function  Impulse

Pleaze zpecify the parameters applicable
to thiz Jitker function

M ax. Amplitude [hz)] 1.0

T

Interval [mz]

¢ Back | Mewst » | Cancel

Specifies the size of the impulse in
nano-seconds. Type a minus sign in front of
the value for a negative impulse.

Interval

Specifies the time taken from the start of the
file at which the Impulse is to be applied.

Step  The Step Jitter Function adds a positive or negative offset to the ideal PCR values
after a specified time. The offset will be the same for all PCRs.

D\3

Digital videno
Broadcasting

Tou have gelected to add the follmwing
Jitter function

Jitter Function  5teR

Fleaze specify the parameters applicable
to thiz Jitker function

Max. Amplitude (hz) 1.0

T

Interval (mz]

< Back | Mewut > | Cancel
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Sine wave

Square wave

152

Max Amplitude Specifies the size of the offset in
nano-seconds. Place a minus sign in front of

the value for a negative offset.

Interval Specifies the time taken from the start of the
file of the first PCR to which the offset is to

be applied.

An offset that varies according to a sine function is applied to the ideal PCR
value for each PCR.

Select Jitter Parameters |

You have zelected ta add the following

B‘ktl‘l]IliX Jitter function
P Sine Wave

Jitter Function
Fleaze specify the parameters applicable
ko thiz Jitker funchon

Max. Amplitude [hs] 1.0
PEG- Period [ms] [10
Digital ¥ideo

Broadcasting

< Back I Mest > I

Cancel Helm

Max Amplitude Specifies the amplitude of the sine wave in

nanoseconds.

Period Specifies the period of the sine wave in

milliseconds.

An offset, which varies according to a square wave function is applied to the ideal
PCR value for each PCR. The square wave has an equal mark/space ratio.
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Tou have selected to add the following
Jitter function

Jitter Funclion  [Square Wave

Flease specify the parameters applicable
tar this Jitker function

Random

Period [mz]

Digital viden
Broadcasting

Max. Amplitude ()

¢ Back | Mest » | Cancel

1.0

T

Max Amplitude

Specifies the amplitude of the square wave
in nanoseconds.

Period

Specifies the period of the square wave in
milliseconds.

The PCR jitter applies offsets of a uniform random distribution to the ideal values
of the PCRs. Each offset will be within the range of + the specified amplitude.

ou have selected to add the following
Jitter function

Jitter Furiction  [Fandom

Flease zpecify the parameters applicable
to thiz Jitter function

Man. Amplitude (ns) 1.0

Digital ¥ideo
Broadcasting

¢ Back | Meut > | Cancel

Max Amplitude

Specifies the maximum amplitude of the
jitter, relative to the ideal value, that can be
added to any PCR. Only a positive value
can be entered. The amplitude is always
from -Max. Amplitude to +Max. Amplitude
centered on the ideal PCR value.
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Gaussian

154

The offsets are applied to the ideal PCR values following a Gaussian distribution
according to the specified standard deviation.

Select Jitter Parameters |

You have zelected ta add the following

ektrnnix Jitter function
P G aussian

Jitter Function
Fleaze specify the parameters applicable
ko thiz Jitker funchon

Standard Deviation [ns]  [LAL

PEG-

D\3

Digital Wideo
Broadrcasting

< Back I Mest > I

Cancel Helm

Standard Deviation Specifies the standard deviation to be used
by the jitter function in deriving the offset for
each PCR, relative to the ideal PCR value.

Only a positive value can be entered for

standard deviation.

MTS4000 and MTS4SAV3 Generator Applications User Manual



ISDB-T Remux - Getting started

The ISDB-T Remux provides the capability to create a transport stream defined
in the ARIB STD-B31 “Transmission System for Digital Terrestrial Television
Broadcasting” standard from an MPEG-2 transport stream. A transport stream
that is remultiplexed by the ISDB-T Remux can be played by the MPEG Player.

NOTE. Modulation parameter information is not inserted into SI tables of a
created transport stream file.

Starting and exiting the program
The program can be started by selecting the Tektronix ISDB-T Remux option from

the Start > Programs menu or by double-clicking on the Tektronix Multiplexer
shortcut on the desktop.

"

ISDB-T
Remux

To exit the program, select File > Exit from the menu or click the close box on
the title bar.
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Display elements

This subsection explains the name and functions of the ISDB-T Remux screen.
The following figure shows the location of display elements.

Current/Next tab
Title bar B 1SDB-T Remux / \ RE
Menu bar——} File Utility Remux Help
GCurrent T MNext
|| [ TEFile 171 G¥ISDE-T Partial Receptiontrp BitRate:32 507936
|G¥ISDE-T Partial Reception.trp J =A% PAT PID:Ox0, ThIID:0x0, TSID--, Pre:2
- . CI& NIT PIDOx10, ThIID:0x40
Mode Guard Interval — ~Partial Reception | . [0 PMT PID0x1FCS, THIIDDx2. PreNofix69s
[Mode 3 | [1/78 ~] [ON ~] CJ& PCR PID0x200
I VIDEO_H264 PID:1281, StrmTypdx B
I8 AUDIO_AAG PIDOx1283, StrmTypdxF
b t Layer A Layer B Layer © &l DSM-GG TypeD PID0x980, StrmTyp0xD
arameters : Hierarch
setting area —| Modulation | QPSK - ||| [640AM — ||| [64QAM - | - display a¥ea
CodeRate | [1/2  ~|| [3/4 <[5/ +]
Time
Ihterleavine | 4 LI | 4 LI | 4 LI
Seement | | =/ f1z  =][| 9
— Bit Rate
(hbps) P 5
Bitrate _ | Maximum | | 0312068 | [ 16867148 || | 0= =
ispl I Check and Change Laver
display area Gurrent ness0t ||| ol & | B | o | x| AL Clar = Layer change
|| | buttons
RemuxStart | | Exit |
A A A
0623-016
Remux Start button Exit button

Cancel button

Figure 3: ISDB-T Remux display elements

Title bar

Menu bar

156

The title bar displays the name of the software. It also contains the standard
window-sizing boxes for Windows.

The menu bar displays the names of the pull-down menus. (See page 162, ISDB-T
Remux — Menus.)
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Current/Next tab Switches the Current parameters setting pane from/to Next parameters setting
pane. Use the Next parameters setting pane if you want to continuously output a
transport stream file that has a different modulation scheme than the first one. You
cannot set only parameters in the Next tab.

NOTE. Be sure to deselect the Regeneration PCR command in the Utility menu if
you set parameters in both Current and Next tabs.

When playing a remultiplexed transport stream created using the Current and
Next tabs in the MPEG Player, set the Update command in the Play menu of the
MPEG Player to Off.

Parameters setting area  In the parameters setting area, there are fields to set transmission parameters
for remultiplexing a transport stream.

T5 File

I \Sample_TS4Stream3. TRP [
i ode Guard Interval Partial Reception
|Mode3 | /8 ~| |OFF  «|

Layer & Layer B Layer C

Modulation | | 6404M «| | | 6404M ~| | G404M «|

CodeRate | |34 «| |34  ~| |34  +]
Time

Interleaving | 2 j | 2 ﬂ | 2 LI
Segment | 13 ﬂ | 1] j |D

Bit Rate

[Mbps)
Maximum | | 18.28577 || o 0
Curent | 13372 | | Q|| ] 5

0623-017

Figure 4: Parameters setting area

TS File. Specifies a transport stream file to be remultiplexed. To specify a
transport stream file, use the Open TS file command in the File menu or the “...”
button next to the text box.

Mode. Seclects the transmission mode. You can select Mode 1, Mode 2, or Mode 3.

Guard Interval. Selects the guard-interval ratio. You can select 1/32, 1/16, 1/8, or
1/4.

Partial Reception. Specifies whether or not partial reception is available in the
hierarchical layer A.
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Modulation. Selects the carrier modulation scheme for each hierarchical layer.
You can select DQPSK, QPSK, 16QAM, or 64QAM.

Code Rate. Selects the inner-code coding rate for each hierarchical layer. You can

select 1/2, 2/3, 3/4, 5/6, or 7/8.

Time Interleaving. Selects the time interleaving length for each hierarchical layer.
Selectable values depend on the System Type setting in the Utility menu and

the transmission mode setting.

Table 19: Time interleaving settings and values

System Type setting Mode setting Selectable values
Digital TV Mode 1 0,4,8,16
Mode 2 0,2,4,8
Mode 3 0,1,2,4
Digital Sound 3 Segment or Mode 1 0,4,8, 16, 32
Digital Sound 1 Segment Mode 2 0,2 4 8 16
Mode 3 0,1,2,4,8

Segment. Sets the number of OFDM segments for each hierarchical layer. The

values are determined as follows:

B Hierarchical layer A: You can set the value from 1 to 13. If you set the Partial
Reception list box to ON, you cannot set values other than 1.

B Hierarchical layer B: You can set the value less than or equal to 13—(setting
value of the hierarchical layer A). At this time, the number of segments for the
hierarchical layer C is set automatically; 13—(setting value of the hierarchical
layer A)—(setting value of the hierarchical layer B).

m  Hierarchical layer C: The value depends on the settings of the hierarchical

layers A and B.
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Bit rate display area  Displays the maximum and current bit rates of the selected transport stream.
These values are calculated by 188 bytes/packet.

B Maximum: Displays the maximum bit rate calculated from the current
parameter settings.

B Current: Displays the total information bit rate of the selected transport stream.

NOTE. If the Current value is larger than the Maximum value, the background
of the Current field will turn red to indicate that you cannot perform any
remultiplexing process under the current parameter settings.

If Partial Reception is set to ON, you may not perform any remultiplexing process
even if the Current value is smaller than the Maximum value.

If the time length of an elementary stream data is shorter than that of a transport
stream file, the Current bit rate for the layer that has the elementary stream data is
not displayed correctly (see the illustration below). In this case, if you remultiplex
the file, relative time values of PCRs and PTS/DTSs in a created ISDB-T transport
stream file may become incorrect.

Transport stream file Time
Acceptable: Elementary stream data
Not acceptable: Elementary stream data [ : : : : : : : : : : : : : : : |
Not acceptable: : : : : : : : : : : : : : : : | Elementary stream data

[ ] N

0623018
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Hierarchy display area When you select a transport stream to be remultiplexed, a hierarchy display
appears in the right side of the application window. The following figure shows
the configuration of the hierarchy display.

DI__—I C:ASample_T5Flower. trp BitR ate: ¥.333336 Mbps
= [J& PAT PID:0«0, ThID:0x0
& WIT PID:0=10, ThIlD:0x40
= []#& PMT PID:0=20, ThID:0x2, Prgo: 0«2
& PCR PID:0=21
Check boxfor changing s 4|DE D PID:0x21, StmTyp: 02

layer assignment | | | |

Component information

Component name

Hierarchical layer name

0623-019

Figure 5: Configuration of the hierarchy display

Check box for changing layer assignment. Sets whether to change the hierarchical
layer for the transport stream component. When you select the check box, you can
change the hierarchical layer using buttons in the Check and Change Layer field.
(See page 161, Layer change buttons.)

Hierarchical layer name. Shows the hierarchical layer name (A, B, or C) to which
the transport stream component is assigned. For PID and IIP (ISDB-T Information
Packet) that do not exist the packet, an x-indication is displayed instead of the
hierarchical layer name.

Component name. Shows the name of the transport stream component.

Component information. Shows information about the transport stream
component such as a packet ID or table ID.

The component information is common to the information used in the MPEG
Player for ASI and 204 bytes per packet. (See page 192, Icon text and dialog box.)
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Layer change buttons By default, all of the transport stream components are assigned to the hierarchical
layer A. You can change the layer assignment for the components using the
buttons in the Check and Change Layer field.

A/BIC buttons. Changes the hierarchical layer of the transport stream component
that have a check mark to the hierarchical layer corresponding to the button.

X button. Replaces the transport stream component that have a check mark with
a null packet.

ALL button. Selects all the check boxes of the transport stream components.
Clear button. Clears all the check boxes of the transport stream components.

To change the hierarchical layer assignment for a transport stream component.

1. Click the check box(es) of the component(s) for which you want to change
the hierarchical layer. If necessary, use the ALL or Clear button. You can
select check boxes by dragging a mouse on components with the left-mouse
button pressed. (If you drag a mouse on components with the right-mouse
button pressed, you can clear check boxes).

2. Click the A, B, C, or X button to change the assignment. You can also change
the hierarchical layer assignment by clicking a layer name on the hierarchy
display. In this case, the layer name changes to A-B-C-X in turn.

There are some restrictions on the hierarchical layer assignment for the transport
stream components:

B You cannot assign the hierarchical layer that does not set the number of
segments.

m Ifa PCR is included within a packet that has the same PID as the other
component, you cannot assign different hierarchical layers to the components.

B [f there are two or more components that have the same PID, when you
change a hierarchy layer of a component, the other components are also
changed to the same hierarchical layer.

Remux start button  Starts the remultiplexing process.

Cancel button  Cancels the file loading or remultiplexing process.

Exit button  Exits the ISDB-T Remux program.

MTS4000 and MTS4SAV3 Generator Applications User Manual 161



ISDB-T Remux — Menus

ISDB-T Remux - Menus

The menu bar displays the names of the four pull-down menus: File, Utility,
Remux, and Help. This section describes the function of each selection in these
menus.

File menu

The File menu contains commands for managing file operation.

Open TS File  Selects a transport stream file to be remultiplexed. When you select File > Open
TS File, the Open dialog box appears as shown below.

Open @

Look in: | [0 Sample TS j ef E-
. 2005012800.trp & Stream3. TRP
(_-\3 2005012801 trp 2] test40. TRP
My Fecent 2005051200.trp =] tested, TRP
Flow_070.trp Test_TS1.brp
'L‘ Flower.trp Test_TS2.brp
ISDB_T.rrix
1SDB_T_M1.rmx
- M_TMCC trp
J S_TMCC.brp
My Documents Streaml. TRP
Streamz, TRP

E‘;J’! Stream3.rmx

. File name: [Test TSt | Open |
] Files of type: |Transport Stream Files (% trpik rms) j Cancel

0623-020

Figure 6: Open dialog box

Select the transport stream file you want to remultiplex in the file list and click the
Open button to open the file.

NOTE. For the selected transport stream to be recognized as a transport stream
file, sync bytes must be identified in five consecutive transport stream packets.

If a sync byte is identified in the middle of a transport stream file, the data before
the sync byte are invalid. In addition, the end of data that is less than 188 bytes is
invalid.
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Close TS File  Closes the currently selected file.

Load Parameter  Loads a saved parameter file (.prm) to use as the current settings. When you select
File > Load Parameter, and then you select a parameter file in the Open dialog
box, a dialog box appears as shown below.

Load Parameter @

|C:ASample_TSParameter_1.pm _I

Current

TS File: ICASamole TS\Stream3. TRP
Layerd, LayerB LayerC
Mode: [3 Modulation: [540aM | [

CodeRate :
Guard Interval :  [1/8 ooe _ae L ) :
Interfleaving: |2 | I
I I

Partial Reception:  |No Segment: |13

Next

TS File: IC:ASample TS4Flower o

Layerd, LayerB LayerC
Mode: |3 Maodulation : | G404M | |

Guard Interval: [1/8 CDdEH_ate © 134 [ T
Interleaving : |2 I |
| [

Partial Reception: | No Segment: [13

oK. Cancel

Figure 7: Load Parameter dialog box

If you click the “...” button at the right side of the text box, the Open dialog box
appears and you can select another parameter file.

Save Parameter  Saves the names of the transport stream files and their parameters in the Current
and Next tabs to a specified parameter file (.prm).
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164

Reset Parameter

Minimize

Exit

Resets the current parameter settings to the default values. When you select File >
Reset Parameter, a dialog box appears as shown below.

Reset Parameter

" Reset Next Parameter

" Reset Current & Next Parameter

0K | Cancel |

0623-022

Figure 8: Reset Parameter dialog box

Reset Current Parameter. Resets the parameters in the Current tab to the default
settings.

Reset Next Parameter. Resets the parameters in the Next tab to the default settings.

Reset Current & Next Parameter. Resets the parameters in the Current and Next
tabs to the default settings.

Minimizes the ISDB-T Remux application window.

Exits the ISDB-T Remux application.
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Utility menu

The Utility menu contains commands that select the digital broadcast type and set
the parameters needed for remultiplexing transmission control information.

System Type  Specifies the terrestrial digital broadcasting type.

Edit Data Rate =~ Changes the data rate of the currently loaded transport stream file. The data rate
of the loaded transport stream file may be different from the actual data rate
because it is calculated based on PCRs in the file. In this case, you can change the
data rate using this command.

When you select Utility > Edit Data Rate, a dialog box appears as shown below. If
you change the data rate, the bit rate in the parameters setting area is also changed.

Edit Data Rate X

Current
[ 30.BE375E

Mext (Mbps]
[ 28.304398
[Mbps)

0K | Cancel |

0623-023

Figure 9: Edit Data Rate dialog box
Current. Changes the data rate of the transport stream file in the Current tab.

Next. Changes the data rate of the transport stream file in the Next tab.
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Edit Information Sets parameters needed for remultiplexing transmitting control information.
When you select Utility > Edit Information, a dialog box appears as shown below.
The settings become available at the next remultiplexing process.

Edit Information E|

Emergency Flag IIP Packet FID
" On & [ff PID =0z |1FFO

0dd Mumber Frame
¢ Add dummy frame to the end
" Remove last frame
" Asis

Partial Reception PCR Interval

OFDM Frame 0.25 Frame [Mode 3)
Interval Time 57.83 ms

Cancel

0623-024

Figure 10: Edit Information dialog box
Emergency Flag. Enables the start flag for emergency-alarm broadcasting.

IIP Packet PID. Specifies the PID of the ISDB-T information packet. The default
value is Ox1FFO0.

Odd Number Frame. Selects how to process the last frame if the number of
multiplex frames are odd numbers. You can select Add dummy frame to the end,
Remove last frame, or As is.

Partial Reception PCR Interval. Sets the interval between PCR packets when
partial reception is specified in the hierarchical layer A.

Move the slider with the left mouse button pressed to set the interval time. The
value in the OFDM Frame box indicates the interval between frames that include
PCRs.
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Sets the parameters for hierarchical transmission to the hierarchical transmission
patterns defined in ARIB TR-B14. When you select Utility > Employment
Parameter, a dialog box appears as shown below.

Employment Parameter

Employment Parameter g|

TR-B14 Service Patterm

| TR14 Service Pattern 1 L]

Layerd, LayerB LayerC
Mode |Mode 3 Modulation [B404M | G404M | 6404
Gurad 78 CodeRate | 3/4 | 314 | 3/4
Interval Interleaving | 2 | 2 I 2
Partial OFF
Reception Segment | 13 | i | i]

Cancel |

0623-025

Figure 11: Employment Parameter dialog box

TR-B14 Service Pattern. Selects one of the hierarchical transmission patterns. The
following table shows the parameters for hierarchical transmission patterns set by
TR14 Service Pattern 1 to TR14 Service Pattern 6.

Table 20: Parameters for hierarchical transmission patterns

TR14 service pattern 1

Mode 3
Guard interval 1/8
Partial reception OFF

Layer A Layer B Layer C
Modulation 64QAM 64QAM 64QAM
Code rate 3/4 3/4 3/4
Interleaving 2 2 2
Segment 13 0 0
TR14 service pattern 2
Mode 3
Guard interval 1/8
Partial reception OFF

Layer A Layer B Layer C
Modulation 16QAM 64QAM 64QAM
Code rate 1/2 3/4 3/4
Interleaving 4 4 4
Segment 13 0 0
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Table 20: Parameters for hierarchical transmission patterns (cont.)

TR14 service pattern 3

Mode 3
Guard interval 1/8
Partial reception ON

Layer A Layer B Layer C
Modulation QPSK 64QAM 64QAM
Code rate 31/2 3/4 3/4
Interleaving 4 4 4
Segment 1 12 0
TR14 service pattern 4
Mode 3
Guard interval 1/8
Partial reception OFF

Layer A Layer B Layer C
Modulation 16QAM 64QAM 64QAM
Code rate 112 3/4 3/4
Interleaving 4 4 4
Segment 3 10 0
TR14 service pattern 5
Mode 3
Guard interval 1/8
Partial reception ON

Layer A Layer B Layer C
Modulation QPSK 16QAM 64QAM
Code rate 112 112 3/4
Interleaving 4 4 4
Segment 1 12 0
TR14 service pattern 6
Mode 2
Guard interval 1/4
Partial reception OFF

Layer A Layer B Layer C
Modulation QPSK 16QAM 64QAM
Code rate 112 112 3/4
Interleaving 2 2 2
Segment 1 3 9
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Regenerated PCR

Duplicate Packet

Open Setting for no PAT TS

Selects whether to recalculate PCR values when remultiplexing a transport stream.

NOTE. Be sure to clear the command if you have set the parameters in both
Current and Next tabs. In addition, if you play a remultiplexed transport stream
created using the Current and Next tabs from the MPEG Player, set the Update
command in the Play menu of the MPEG Player to Off.

Specifies whether to duplicate PAT, NIT, and CAT in null packets in the
hierarchical layer A when the following conditions are met:

m  Partial reception is specified in hierarchical layer A.
®  Either the hierarchical layer B or C is the most robust layer.

B PAT, NIT, or CAT is included in hierarchical layer B or C.

Enables loading a transport stream that does not contain any PATs (Program
Association Tables) by specifying PID values for PMTs (Program Map Tables).
When you select Utility > Open Setting for no PAT TS, a dialog box appears
as shown below.

Open Setting for no PAT TS X

v Automatically apply this data when no
PAT was found in the stream, i

PMT
FID

fFCe
ffFcs
[FCa
[FCE
ffFCC
ffFCO
fFCE
[FCF
ffFO0
fF01

»ridvanced | 0K | Cancel |

0623-026

Figure 12: Open Setting for no PAT TS dialog box

Automatically apply this data when no PAT was found in the stream. Sets whether
to load the transport stream by using the PMT PID values that are specified in
the dialog box when loading a transport stream that does not contain any PATs
(if a transport stream contains any PAT, it is loaded using the PAT). If you clear
the check box, a transport stream that does not contain a PAT cannot be loaded.
By default, the check box is selected.
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Remux menu

Help menu

170

Start

Cancel

About

PMT PID. Specifies each PID value for PMTs in a transport stream to be loaded.
By default, the upper eight PID values are set to those that are allocated by the
ARIB TR-B14 standard. If you do not specify a PID value for a PMT, it is not
recognized as a PMT.

Advanced button. If you click the Advanced button, text boxes to set more PID
values and program numbers of PMTs are displayed. Use these text boxes to load
PMTs with the same PID value but a different program number. In addition, a
text box to set a PID value for an NIT (Network Information Table) is displayed.
By default, it is set to 0x0010.

The Remux menu contains commands that start and cancel the remultiplexing
process.

Start the remultiplexing process.

Cancels the remultiplexing process.

The Help menu contains command that display the version information about the
ISDB-T Remux application.

Displays information including the software version number and copyright
information.

MTS4000 and MTS4SAV3 Generator Applications User Manual



ISDB-T Remux — Creating and outputting ISDB-T streams

ISDB-T Remux - Creating and outputting ISDB-T streams

This section describes how to create and output an ISDB-T transport stream file
from the MPEG Player.

Creating an ISDB-T transport stream

Perform the following steps to create an ISDB-T transport stream file as defined in
the ARIB STD-B31 standard.

1.
2.

Select File > Open TS File to open the Open dialog box.

Select the transport stream file you want to remultiplex, and then click the
Open button. After the file is loaded, the “Analysis Complete” message
appears.

Click the OK button in the dialog box.

Set the transmission parameter for remultiplexing the transport stream in
the parameters setting area.

a. Set the transmission mode in the Mode list box.
b. Set the guard interval ration in the Guard Interval list box.

c. Set the number of segments for hierarchical layers A and B in the
Segment list boxes.

d. Set whether or not partial reception is available in the hierarchical layer A
in the Partial Reception list box.

e. Set the carrier modulation scheme for each hierarchical layer in the
Modulation list boxes.

f. Set the inner-code coding rate for each hierarchical layer in the Code
Rate list boxes.

g. Set the time interleaving length for each hierarchical layer in the Time
Interleaving list boxes. If you use the Employment Parameter command
in the Utility menu, you can set the parameters to the hierarchical
transmission pattern defined in ARIB TR-B14.

In the hierarchy display area, change the hierarchical layer assignment (A,
B, C, or, X) for transport stream components. (See page 161, Layer change
buttons.)

If necessary, click the Next tab and repeat steps 1 through 5 to set the
parameters.

Select Utility > Edit Data Rate to open the Edit Data Rate dialog box.

In the dialog box, change the data rate of the selected transport stream.
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9. Select Utility > Edit Information to open the Edit Information dialog box.

10. In the dialog box, set the parameters needed for remultiplexing transmitting
control information.

11. When you set the all the parameters, click the Remux Start button or select
Remux > Start. The Save As dialog box appears.

12. Enter a file name in the File name text box (if you do not use the default
file name).

13. Click the Save button.

Outputting an ISDB-T transport stream

Perform the following steps to output an ISDB-T transport stream from an
MTS4000 instrument:

NOTE. To output a ISDB-T stream using the MTS4SAV3, you will need to copy the
file you created using ISDB-T Remux to an MPEG player with an ASI output.

1. Connect a cable from one of the ASI connectors on the MTS4000 instrument
to an ISDB-T modulator.

2. Open the MPEG Player.

3. Select File > Open and then browse to the desired ISDB-T file (.rmx). Click
Open to open the file. The hierarchical view of the selected file is displayed
on the screen as shown below.

NOTE. The ISDB-T transport stream is different from the typical transport stream,
so the icon is not represented as a train.

ISDB_T_M1.rmx - Tektronix MPEG Player [ E =]

File View Play ASI Utility
® 0| || .
o
28 PAT PID: Ox(] TbIID Ox(] TSID:0x0, Prg:l
© & PMT PID:0x20, ThID:0x2, Prgho:0:2
: .72 VIDEQ PID:0:21, StrTypis2
----- £ AUDIO PID:0x24, StrnTyp:0xd
e ... PCR PID:0x28
[ED NIT PID:0510, ThiID:0540
TP PID:0x1FFO
...... ‘...@) NULL PID:0LFFF

15DB-T 204 INTERMAL 32.507937Mbps =}

Figure 13: Hierarchical view of the ISDB-T transport stream file
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4. Select Play > Other to open the Others dialog box.

5. Select ARIB in the Standard drop-down list and then click OK. In the
MPEG Player window, notice that the standard shown in the lower-left corner
changes to ISDB-T if the file includes the IIP tables and TMCC as shown
above. Otherwise, ARIB is shown as the standard.

6. Select ASI > ASI Out to set the player output to the ASI connector you used
in step 1.

7. Select ASI > ASI Format to set the desired output format.

8. Click the Play button to begin streaming the ISDB-T file to an ISDB-T
modulator.
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ISDB-T Remux - Transmission control information

This section describes transmission control information multiplexed to a transport
stream according as the ARIB STD-B31 5.5 standard.
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Multiplexing to dummy byte part

The following table lists transmission control information multiplexed to dummy
byte part of each transport steam packet (189 byte to 196 byte). Some of the
information uses values set in the Edit Information dialog box in the Utility menu.

Table 21: Multiplexed information to dummy bytes

Byte Bit Syntax Description
0(189) 7 TMCC_identifier =1 Terrestrial digital TV =1 Terrestrial
6 =0 =1 digital audio
5 reserved “1”
4 buffer_reset_control_flag “0"
3 switch-on_control_for_emergency_ Set in the Edit Information dialog box
broadcasting
2 initialization_timing_head_packet_flag Start packet after changing a transmission parameter: “1”
Normally: “0”
1 frame_head_packet_flag The multiplex frame head packet: “1”
Normally: “0”
0 frame_indicator During even frame of the OFDM frame: “0”
During odd frame of the OFDM frame: “1”
1(190) 7-4 layer_indicator “0000”: dummy packet

“0001”: packet transmitted by hierarchical layer A
“0010”: packet transmitted by hierarchical layer B
“0011": packet transmitted by hierarchical layer C
“1000”: ISDB-T information packet (IIP)

3-0 count_down_index “1111”: Normally
“1110”: 15 frames before switching
“1101”: 14 frames before switching

“0601”: 2 frames before switching
“0000": 1 frame before switching

2(191) 7 AC_data_invalid_flag “”
6-5 AC_data_effective_bytes All “1”
4-0 TSP_counter A counter in which the head packet of the multiplex frame is 0
3(192) 7.0 and increments one by one in order of packet
4(193) 7-0 AC_data All 17
5(194) 7-0 AC_data Al “1”
6(195) 7-0 AC_data Al “1”
7(196) 7-0 AC_data All “1”
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Multiplexing to IIP

Information except for Table 3-3 is added to invalid hierarchy IIP
(ISDB-T_Information Packet), and the packet is replaced with one dummy
packet in a multiplex frame. Some of the information uses values set in the
Edit Information dialog box in the Utility menu. The following table shows the
configuration of the IIP packet.

Table 22: Configuration of the IIP packet

Syntax Description Number of bits
sync_byte synchronization byte: 0x47 8
transport_error_indicator Always “0” 1
payload_unit_start_indicator Always “1” 1
transport_priority Always “0” 1
PID The value is set in the Edit Information dialog box 13
Default value: 0x1FFO
transport_scrambling_control Always “00”
adaptation_field_control Always “01”
continuity_counter The value is increased with each transport stream 4
packet. It wraps around to 0 after its maximum value
(0x1111)
[IP_packet_pointer The number of packets from the multiplex position to 16
the next multiplex frame head in the multiplex frame of
the IIP
modulation_control_configuration_information (See Table 23.) 160
[IP_branch_number Always “0x00” 8
last_IIP_branch_number Always “0x00” 8
network_synchronization_information_length Always “0x00” (no SFN information) 8
stuffing_byte (OXFF) 159 (188-29) bytes OxFF 8X159
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The following table shows the configuration of modulation_control
configuration information.

Table 23: Configuration of modulation_control_configuration_information

Syntax Description Number of bits
TMCC_syncronization_word Even frame: “0” 1
Odd frame: “1”
AC_data_effective_position “1" 1
reserved Al “1” 2
initialization_timing_indicator Switching timing of mode and guard interval ratio 4
current_mode Current Mode value 2
00: reserved
01: Mode 1
10: Mode 2
11: Mode 3
current_guard_interval Current guard interval ratio 2
00: 1/32
01: 116
10: 1/8
1: 1/4
next_mode Next mode value
next_guard_interval Next guard interval ratio
system_indicator 00: Terrestrial digital TV
01: Terrestrial digital audio
count_down_index Transmission parameter switching index 4
switch-on_control_flag_used_for_alert_broadcasting  The value is set in the Edit Information dialog box 1

MTS4000 and MTS4SAV3 Generator Applications User Manual

177



ISDB-T Remux — Transmission control information

Table 23: Configuration of modulation_control_configuration_information (cont.)

Syntax

Description

Number of bits

current_configuration_information

The following current information:

(40)

partial_reception_flag

Digital TV = partial reception flag
0: without partial reception
1: with partial reception
Digital sound = system identification flag
0: 1 segment system
1: 3 segment system

1

transmission_parameter_for_layer_A

The following transmission-parameter information for
hierarchical layer A:

(13)

modulation_scheme

Carrier modulation scheme
000: DQPSK
001: QPSK
010: 16 QAM
011: 64 QAM
111: unused hierarchical layer

coding_rate_of_inner_code

Convolution coding ratio
000: 1/2
001: 2/3
010: 3/4
011: 5/6
100: 7/8
111: unused hierarchical layer

length_of_time_interleaving

Time interleaving length
000: 0 (Mode 1), 0 (Mode 2), 0 (Mode 3)
001: 4 (Mode1), 2 (Mode 2),1 (Mode 3)
010: 8 (Mode 1), 4 (Mode 2), 2 (Mode 3)
011: 16 (Mode 1), 8 (Mode 2), 4 (Mode 3)
100: 32 (Mode 1), 16 (Mode 2), 8 (Mode 3)
101-110: reserved
111: unused layer

number_of _segments

Number of segments
0001-1101: 1t0 13
1111: unused hierarchical layer

transmission_parameter_for_layer_B

Transmission parameter information for hierarchical
layer B (same as layer A)

transmission_parameter_for_layer_C

Transmission parameter information for hierarchical
layer C (same as layer A)

next_configuration_information

Next information (same as the current information)

phase_correction_of_CP_in_connected_
transmission

All 17

TMCC_reserved_future_use

All 17

12

reserved_future_use

All 17

10

CRC_32

CRC value from TMCC_syncronization_word to
reserved_future_use

32
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This section describes the default MPEG Player installed on the MTS4000 system
used to output the selected stream.

The MPEG Player generates MPEG-2 transport streams that are compliant with
ATSC, DVB, and ARIB standards.

The MPEG Player provides the following features:

B Data rate: 213 Mbps maximum; 250 Kbps minimum.

B Hierarchical display of the stored transport stream.

188, 204, non TS bytes packet size.

m  PCR jitter insertion.

® [P and ASI interfaces available.

= Playout interfaces: IP and ASI.

®  Both the commonly used IP versions - [Pv4 and IPv6 are supported.

B Stream replication (IP) with some attributes of the stream incremented by
a certain value.
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Display eleme

nts

This subsection explains the name and functions of the MPEG Player screen.

LB Sym5.mpg - Tektronix MPEG Player

Menu bar —s{File view Play 1P Utility
[ m

Toolbar 27

g", P2 9000
55 PAT PID:0x0, Thi , TSIDuOx1, Prog:l
=B PMT PID:0x64, THID:0x2, Prgho:0x1
=k VIDED PID:0x6E, StrmTyp:0x2
J AUDIC PID:0x78, StemTyp:Oxd
4 PCR PID:iOx6E

Hierarchical display of —
fransport stream

NIT PID:0x 10, ThIID:0x40
SDT FID:0x11, ThilD:Ox42
BAT PID:0x11, ThilD:Ox44
EIT PID:0x12, ThilD:0x4E
@ TOT PID:0x14, ThIID:0x70
TOT PID:Ox 14, ThIID:0x73
@ MULL PID:0x1FFF

Play status indicator —»|

A —

>

Status bar —|ove

155 INTERMAL 8.000000Mbps (IP:5.328267Mbps » 3 Streams) =)

Menu bar

Toolbar

Hierarchy display
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0204001

The following figure shows the location of display elements.

The Menu bar displays the names of the menus.

Refer to Menus and Controls for detailed information about the menus.
(See page 196.)

The toolbar provides shortcut buttons for many of the most often used menu
commands. Click a toolbar button to select the corresponding command. You can
toggle the toolbar display on and off using Toolbar command in the View menu.

Refer to Toolbar Buttons for detailed information about the function of each
toolbar button. (See page 231.)

Each icon in the hierarchy display represents an element of the stream. The
hierarchy text contains a description of the associated icon.

Refer to Hierarchical Display for detailed information about the hierarchy icons.
(See page 184.)
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Play Status indicator =~ The Play Status indicator is displayed while the selected stream is being output. It
shows the output status of the selected stream: the progress of the stream output,
the output source, the operational status, and the elapsed time.

Output Position Operation Elapsed Update Advanced Parametric
source indicator status time l protocol settings  settings
= : L = B
P, x> [oex i B © Bh 27 28
T PCR Error
Loop accurac insertion

The Play Status indicator shows the following information:

Position indicator. This indicator shows the progress of stream output using the
duration gauge.

The duration gauge is updated every second. If you output a stream with a
repetition rate of approximately three seconds, the gauge may not be displayed
correctly.

Output source. This indicator shows the output source used to output the selected
stream.

One of each set of icons is displayed, depending on the selections and status. The
icons and their meanings are as follows:

The hard disk is being used for the output source.

-
=

The RAM is being used for the output source.

Q‘F
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Operation status. Shows the current operation status of the instrument.

The icons and meanings are as follows:

The selected stream is being output.

Ld
g,‘ The selected stream is being read from the hard disk to the RAM.
o0-00-18 This box displays the elapsed time of the current stream data
. output.
Elapsed Time

This icon indicates that the stream is continuously output using
the loop method.

This icon indicates that the stream parameters are updated.

This icon indicates that the PCR accuracy is enabled.

This icon indicates that the Advanced Protocol Settings is enabled
and applied to the stream.

This icon indicates that the errors are inserted in the stream.

This icon indicates that the parametric settings are enabled and
applied to the stream.

This icon indicates that the Stream replication settings are enabled
and applied to the stream.

A i
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Status bar The Option Status bar and the IP Status bar contain several indicators that display
general information about the transport stream output status.
Bit rate
DVE 188 INTERNAL 5.000000Mbps =1
Figure 14: Option Status bar
IP bitrate Number of
streams
DWE 158 INTERMNAL 8.000000Mbps {(IP:8.328267Mbps X 3 Streams) 200 MB I\Q

Figure 15: IP Status bar

0204002

From left to right, the Status bar shows the following information:

Standard This indicator shows the standard used to display the
selected stream (MPEG2, ARIB, DVB, ATSC, or Non-TS).
Packet Size This indicator displays the packet size in bytes (188, 204, or

Non-TS) of the stream output.

Clock Source

This indicator displays the source of the reference clock
(internal only) used for the stream output.

Bit Rate When the ASI option is selected, this indicator shown
displays the bit rate (Mbps) of the stream output.

IP Bit Rate When the IP interface option is selected, this indicator
shown displays the bit rate (Mbps) of the IP stream output.

Number of Streams When the IP interface option with Stream Replication
Settings is selected, this indicator shown displays the
number of replicated streams.

RAM free space This indicator shows the RAM free space that can be used
to output the selected stream.

Output Source Target This indicator shows the output source used to output the

selected stream.
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Hierarchical display

184

The MPEG Player displays the selected transport stream using a hierarchical
structure. This section describes the hierarchical display and defines each icon
you may encounter in the display.

The MPEG Player uses icons displayed in a hierarchical structure to show the
interrelationship of transport stream components. (See Figure 16.) Additional
information about each stream component such as PID and Table ID numbers is
displayed next to each icon.

dvb_625_mcpc3 - Tektronix MPEG Player
File View Play ASI Utility
EIETIG
B 1 oo 625 mepcimpg . Packets57éi1) -
-8 PAT PID:0x0), ThIID:0x0, TSID:0xd, Prg:3 I
Ba PRAT PID:0:30, ThIID:0x2, PrgMo:0:d
- e VIDED PID:0n31, StrrTyp:0x2
- AUDIO PID:G:34, StrmTyp:0xd
B PCR PID:D:31
B PMT PID:0x40, ThIID:0:2, PrgNe:0x2
fem VIDEOD PID:eedl, StrTypeln
- AUDIO PID:Oxdd, StrenTyp:0xd
- PCR PID:0x41
=83 PMT PID:0:S0, ThiD:0:2, PrgNo:t
----- e VIDEO PID:0:S1, StrrnTypes
----- £ AUDIO PID:0:x54, StrmTyp:0d
----- PCR PID:0:51
B2 CAT PID:0xL, ThIID:0:1
--[ED NIT PID:0x0, ThiID:0xd0 T
----- TSDT PID:0x2, ThiID:0:G
----- SDT PID:0kd1, ThiID:0xd2
----- BAT PID:0:d1, ThIID:0d A
----- EIT PID:0:l 2, ThIID:0:4E
----- EIT PID:0x12, ThIID:0:50 v
188 INTERMAL 27 647058Mbps =

=N B =)

m

DVE

Figure 16: Example of the hierarchical display

The “+' symbol displayed to the left of some icons indicates that the item includes
lower-level transport stream components that are not displayed. The symbol
changes to ‘' when the lower level components are displayed. To expand the
hierarchy, click on the ‘+' symbol. Similarly, to collapse the hierarchy, click on
the ‘~' of the selected upper-level icon.

When a transport stream contains more items than displayed on the screen at a
time, a scroll bar appears at the right of the screen.

Click an element in the hierarchy to select (and highlight) it.
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Hierarchical display icons  The following table describes the icons you may encounter in the hierarchical
display of the MPEG Player for transport streams using the MPEG-2, ARIB,

DVB and ATSC formats.

Refer to Icon Text and Dialog Box for descriptions of the icon text and dialog box
associated with the hierarchy icon. (See page 192.)

Table 24: Icons used for MPEG-2, ARIB, DVB, and ATSC formats

Icon

Element type

ISDB-T

Broadcast transport stream that is defined ARIB
STD-B31.

Non-TS
Data stream other than transport stream format.

(0| Ve

Transport Stream (TS)

This icon represents all transport stream packets
that make up the stream.

Program Association Table (PAT)

One or more transport packets with a PID value
and table_id value of 0x00.

Transport Stream Description Table (TSDT)

One or more transport packets with a PID value of
0x02 and a table_id value of 0x03.

Network Information Table (NIT)

One or more transport packets with a PID value
specified by the network_PID in the PAT.

1

Conditional Access Table (CAT)

One or more transport packets with a PID value of
0x01 and a table_id value of 0x0001.

Program Map Table (PMT)

One or more transport packets with a PID value
specified by the program_map_PID in the PAT and
a table_id value of 0x02.

Program Clock Reference (PCR) .

One or more transport packets with a PID value
specified by the PCR_PID in the PMT and a
PCR_flag value of 1.

Video elementary stream

One or more transport packets with a PID value
specified by the elementary_PID in the PMT and a
stream_type value of 0x01, 0x02, or 0x10.

A lock symbol appears in the icon when the
transport_scrambling_control value is set to 01.
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Table 24: Icons used for MPEG-2, ARIB, DVB, and ATSC formats (cont.)

Icon Element type
o Audio elementary stream
[:]::_- 1)
R One or more transport packets with a PID value
] specified by the elementary_PID in the PMT and a
-"E!*;:, stream_type value of 0x03, 0x04, or 0x11.
% A lock symbol appears in the icon when the
transport_scrambling_control value is set to 01.
ﬁ'}fﬁ Audio AAC, Audio AC3 (ATSC format)
B A lock symbol appears in the icOne or more
transport packets with a PID value specified by the
'i:?‘:l" elementary_PID in the PMT and a stream_type
it value of 0xOF or 0x81 (ATSC format) on when the
transport_scrambling_control value is set to 01.
010010 Data stream
1001110
1Moo One or more transport packets with a PID value
specified by the elementary_PID in the PMT and
1'301““13 a stream_type value of other than 0x01 to 0x05,
110001 0x08, and 0xOF (in ATSC format, 0x81).

A lock symbol appears in the icon when the
transport_scrambling_control value is set to 01.

=1 Private Section

L One or more transport packets with a PID value
N specified by the elementary_PID in the PMT and a
: ﬁ1 stream_type value of 0x05.

A lock symbol appears in the icon when the
transport_scrambling_control value is set to 01.

Digital Storage Media Command and Control
(DSM-CC)

One or more transport packets with a PID value
specified by the elementary_PID in the PMT and a
stream_type value of 0x08.

A lock symbol appears in the icon when the
transport_scrambling_control value is set to 01.

Entitlement Control Message (ECM)

= One or more transport packets with a PID value
specified by the CA_PID of the CA_descriptor in
the PMT, a payload_start_unit_indicator value of 1,
and the payload does not start 000001 (section) or
the payload starts 000001 (PES).

HE?-—-:_ Entitlement Management Message (EMM)

i?ﬁi;-i' One or more transport packets with a PID value

specified by the CA_PID of the CA_descriptor in
the CAT, a payload_start_unit_indicator value of 1,
and the payload does not start 000001 (section) or
the payload starts 000001 (PES).
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Table 24: Icons used for MPEG-2, ARIB, DVB, and ATSC formats (cont.)

Icon

Element type

GHOST

One or more transport packets with a PID value
not specified in the PSI or Private Section PID file
when the transport stream is downloaded.

NULL

One or more transport packets with a PID value
of Ox1FFF.

b &

GARBAGE

One or more transport packets in the section-data
structure at the beginning of the section are not
complete.

1.8

Adaptation Field Error (ADFERR)

One or more transport packets with an
adaptation_field_control value of 0x00.
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The following table describes icons that are specific to transport streams using
DVB format.

Table 25: Icons specific to DVB format

Icon Element type
Service Description Table (SDT)
One or more transport packets with a PID

value of 0x0011 and a table_id value of 0x42.
Bouquet Association Table (BAT)

One or more transport packets with a PID
value of 0x0011 and a table_id value of 0x4A.

Event Information Table (EIT)

One or more transport packets with a PID
value of 0x0012 and a table_id value of
0x4E-0x6F.

Running Status Table (RST)

One or more transport packets with a PID
value of 0x0013 and a table_id value of
0x4E-0x71.

Stuffing Table (ST)

One or more transport packets with a PID
value of 0x0010-0x0013 and a table_id value
of 0x72.

Discontinuity Information Table (DIT)

One or more transport packets with a PID
value of Ox1E and a table_id value of OX7E.

Selection Information Table (SIT)

One or more transport packets with a PID
value of O0x1F and a table_id value of Ox7F.

L Time and Data Table (TDT)
One or more transport packets with a PID
value of 0x0014 and a table_id value of 0x72.

Time Offset Table (TOT)

One or more transport packets with a PID
value of 0x0014 and a table_id value of 0x73.
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The following table describes icons that are specific to transport streams using

ARIB format.

Table 26: Icons specific to ARIB format

Icon Element type

S== Service Description Table (SDT)
One or more transport packets with a PID
value of 0x0011 and a table_id value of 0x42.
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Bouquet Association Table (BAT)

One or more transport packets with a PID
value of 0x0011 and a table_id value of Ox4A.

Event Information Table (EIT)

One or more transport packets with a PID
value of 0x0012 and a table_id value of
0x4E-0x6F.

Running Status Table (RST)

One or more transport packets with a PID
value of 0x0013 and a table_id value of
Ox4E-0x71.

Stuffing Table (ST)

One or more transport packets with a PID
value of 0x0010-0x0013 and a table_id value
of 0x72.

Discontinuity Information Table (DIT)

One or more transport packets with a PID
value of 0x1E and a table_id value of Ox7E.

Selection Information Table (SIT)

One or more transport packets with a PID
value of Ox1F and a table_id value of Ox7F.

Local event Information Table (LIT)

One or more transport packets with a PID
value of 0x0020 and a table_id value of
0xD0. One or more transport packets with a
PID value specified by the elementary_PID
in the PMT and a table_id value of 0xD0
when a stream type value is 0x05.

Event Relation Table (ERT)

One or more transport packets with a PID
value of 0x0021 and a table_id value of
0xD1. One or more transport packets with a
PID value specified by the elementary_PID
in the PMT and a table_id value of 0xD1
when a stream type value is 0x05.
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Table 26: Icons specific to ARIB format (cont.)

Icon Element type
Index Transmission Table (ITT)
One or more transport packets with a PID
value specified by the elementary_PID in the
PMT and a table_id value of 0xD2.
Partial Content Announcement Table (PCAT)
One or more transport packets with a PID
value of 0x22 and a table_id value of 0xC2.
Software Download Trigger Table (SDTT)
One or more transport packets with a PID
value of 0x23 and a table_id value of 0xC3.
Download Control Table (DCT)
One or more transport packets with a PID
value of 0x17 and a table_id value of 0xCO.
DownLoad Table (DLT)

One or more transport packets with a

PID value specified by the DL_PID in the
DCT and a stream_type value of 0xC1. A
lock symbol appears in the icon when the
transport_scrambling_control value is set to
01.

Broadcaster Information Table (BIT)

One or more transport packets with a PID
value of 0x24 and a table_id value of 0xC4.

Network Board Information Table (NBIT) One
or more transport packets with a PID value of
0x25 and a table_id value of 0xC5 or 0xC6.

Linked Description Table (LDT)

One or more transport packets with a PID
value of 0x25 and a table_id value of 0xC7.

L Time and Data Table (TDT)
One or more transport packets with a PID
value of 0x0014 and a table_id value of 0x72.

Time Offset Table (TOT)

One or more transport packets with a PID
value of 0x0014 and a table_id value of 0x73.
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The following table describes icons that are specific to transport streams using
the ATSC format.

Table 27: Icons specific to ATSC format

Icon Element type

Master Guide Table (MGT)
One or more transport packets with a PID
value of 0x1FFB and a table_id value of
0xC7.

Terrestrial Virtual Channel Table (TVCT)
One or more transport packets with a PID

value of 0x1FFB and a table_id value of
0xC8.

Cable Virtual Channel Table (CVCT)

One or more transport packets with a PID
value of 0x1FFB and a table_id value of
0xC9.

Rating Region Table (RRT)

One or more transport packets with a PID
value of 0x1FFB and a table_id value of
0xCA.

Event Information Table (EIT)

One or more transport packets with a PID
value specified by the table_type_PID in the
MGT and a table_id value of 0xCB.

Channel Extended Text Table (CETT)

One or more transport packets with a PID
value of 0x1FFB and a table_id value of
0xC8.

Event Extended Text Table (EETT) One or
more transport packets with a PID value of
0x1FFB and a table_id value of 0xC9.

Program Identifier Table (PIT)

One or more transport packets with a PID
value specified by the elementary_PID in the
PMT and a table_id value of 0xDO when a
stream_type value is 0x85.

L System Time Table (STT)

. One or more transport packets with a PID
value of Ox1FFB and a table_id value of
0xCD.
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Icon text and dialog box

192

To the right of each icon, the MPEG Player displays text that describes each
transport stream component. In addition, for the PCR icon, you can display
a dialog box to change the parameters for the component. The following
table shows the text that will be displayed with each icon.

Table 28: Icon text

Component Text

ISDB-T Icon "xxx.rmx": Shows the file name.
Packets: Shows the total number of packets
in the broadcast transport stream.

Non-TS Icon "xxx.xx": Shows the file name.

FileSize: Shows the file size in byte.

Transport Stream (TS) Icon

"xxx.trp": Shows the file name of the
transport stream.

Packets: Shows the total number of packets
in the transport stream.

TSID: Shows the ID number for the transport
stream.

Program Allocation Table (PAT) Icon

PID: Shows the PID value of the PAT.
TblID: Shows the table_id value of the PAT.

TSID: Shows the transport_stream_id value
of the PAT.

Prg: Shows the number of programs
contained in the transport stream.

Transport Stream Description Table (TSDT)
Icon

PID: Shows the PID value of the TSDT.
TblID: Shows the table_id value of the TSDT.

Network Information Table (NIT) Icon

PID: Shows the PID value of the NIT.
TblID: Shows the table_id value of the NIT.

Conditional Access Table (CAT) Icon

PID: Shows the PID value of the CAT.
TblID: Shows the table_id value of the CAT.

Program Map Table (PMT) Icon

PID: Shows the PID value of the PMT.
TblID: Shows the table_id value of the PMT.

PrgNo: Shows the program number
associated with the PMT.

Program Clock Reference (PCR) Icon

PID: Shows the PID value of the PCR.

See also PCR Inaccuracy Dialog Box (See
page 194.)

Video Elementary Stream (VIDEQ) Icon

PID: Shows the PID value of the video
elementary stream.

StrmTyp: Shows the type of the video
elementary stream (0x01 or 0x02).
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Table 28: Icon text (cont.)

Component

Text

Audio Elementary Stream (AUDIO) Icon

PID: Shows the PID value of the audio
elementary stream.

StrmTyp: Shows the type of the audio
elementary stream (0X03 or 0X04).

AUDIO_AAC and AUDIO_AC3 Icons

PID: Shows the PID value of the audio
elementary stream.

StrmTyp: Shows the type of the audio
elementary stream (OXOF or 0x81).

Data Stream (DATA) Icon

PID: Shows the PID value of the data stream.
StrmTyp: Shows the type of the data stream.

Private Section (DATA_SECT) Icon

PID: Shows the PID value of the private
section.

TblID: Shows the table_id value of the private
section.

StrmTyp: Shows the type of the private
section.

DSM_CC Icon

PID: Shows the PID value of the data
DSM-CC.

StrmTyp: Shows the type of the DSM-CC.

Entitlement Control Message (ECM) Icon

PID: Shows the PID value of the ECM.
TblID: Shows the table_id value of the ECM.

Entitlement Management Message (EMM)
Icon

PID: Shows the PID value of the EMM.
TbIID: Shows the table_id value of the EMM.

GHOST lcon

PID: Shows the PID value of the GHOST.

Adaptation Field Error (ADFERR) Icon

PID: Shows the PID value of the ADFERR.

NULL Icon

PID: Shows the PID value of the NULL.

GARBAGE Icon

PID: Shows the PID value of the GARBAGE.

SDT, BAT, EIT, RST, ST, DIT, SIT, LIT, ERT,
ITT, PCAT, SDTT, DCT, DLT, BIT, NBIT, and
LDT Icons

PID: Shows the PID value of the SDT, BAT,
EIT, RST, ST, DIT, SIT, LIT, ERT, ITT, PCAT,
SDTT, DCT, DLT, BIT, NBIT, or LDT.

TblID: Shows the table_id value of the SDT,
BAT, EIT, RST, ST, DIT, SIT, LIT, ERT, ITT,
PCAT, SDTT, DCT, DLT, BIT, NBIT, or LDT.

TDT and TOT lcon

PID: Shows the PID value of the TDT or TOT.

TblID: Shows the table_id value of the TDT
or TOT.

MGT and PIT Icons

PID: Shows the PID value of the MGT or PIT.

TblID: Shows the table_id value of the MGT
or PIT.
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Table 28: Icon text (cont.)

Component Text
TVCT, CVCT, RRT, EIT, CETT, and EETT PID: Shows the PID value of the TVCT,
Icons CVCT, RRT, EIT, CETT, or EETT.

TblID: Shows the table_id value of the TVCT,
CVCT, RRT, EIT, CETT, or EETT.

TbIType: Shows the table_type value of the
TVCT, CVCT, RRT, EIT, CETT, or EETT.

System Time Table (STT) Icon PID: Shows the PID value of the STT.
TblID: Shows the table_id value of the STT.

PCR Inaccuracy dialog box. When you right-click PCR in the hierarchical view,
the PCR Inaccuracy dialog box appears as shown (See Figure 17.). This dialog
box allows you to add jitter to the program_clock reference base value and the
program_clock reference extension value.

Refer to Adding Jitter to PCRs for more information. (See page 233.)

?':P CR Inaccuracy @ﬂ
FCR Inaccuracy m
Fattern [Sine ~
Period 100 [Packetsz)
Arnplitude 0 /27%Hz: 0.00ns
50
Undo

Figure 17: PCR Inaccuracy dialog box
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The following table describes the PCR Inaccuracy dialog box parameters.

Table 29: PCR Inaccuracy dialog box parameters

Parameter Description

Pattern Selects the type of the waveform used to add jitter. You can
select Sine, Square, Triangle, Pulse, Sawtooth, Random,
or Offset.

Period Sets the period of the waveform used to add jitter. You can
set the value from 5 to 3000 packets in 1 packet steps.

Amplitude Sets the amplitude of the waveform used to add jitter. You
can set the value from 0/27 MHz to 135000000/27 MHz
(0Osto5s).

Pulse Width Sets the pulse width of the waveform used to add jitter. You

can set the value from 1 to (period - 1) packet(s) in 1 packet
steps. This Pulse Width parameter is available only when
the Pattern parameter is set to Pulse.
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MPEG Player - Menus and controls

This section describes the function of each selection available in the menus. This
section is divided into the following subsections:

B Menus in the Play Screen describes all of the menu commands and their
features available in the Play screen.

B TJoolbar Buttons describes the toolbar buttons and their functions.

Menus in the Play screen

196

File menu

View menu

The File menu contains commands for selecting a stream file and for loading and
saving a preset file. The following table describes the commands in the File menu.

Table 30: File menu commands (Play screen)

Command Description

Open Opens a stored stream file. When a file is selected, the MPEG
Player checks the packet size of the file. For a transport
stream the output data is in packets. If an incomplete packet
is included at the start or end point of the file, that portion
is not output.

The function uses a standard Windows Open... dialog box.
Load Preset Loads the specified preset file (*.xml). When a preset file is
loaded, the current instrument settings are changed by the

file's content. Refer to Preset File for more information about
the preset file. (See page 235.)

Save Preset Saves the current instrument settings as a preset file. Refer
to Preset File for more information about the preset file.
(See page 235.)

Exit Quits the MPEG Player application. The MPEG Player

application settings are saved.

The View menu contains commands that control the display of the Toolbar and
the Status bar. The following table describes the commands available in the
View menu.

Table 31: View menu commands

Command Description

Toolbar Shows or hides the toolbar.

Status Bar Shows or hides the status bar.

Compact Mode Displays the play screen at the bottom when set to ON and

the size of the play screen becomes compact.
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Play menu  The Play menu contains commands for defining output parameters, such as packet
size, output clock rate, and output source. The following table describes the
commands available in the Play menu.

Table 32: Play menu commands (Play screen)

Command

Description

Interface

Sets the interface to transmit or receive Ethernet packets.
You can select either IP or ASI interfaces.

Packet Size

Sets the packet size (in bytes) for the stream. You can set the
packet size to 188 (188 + 0), 204 (188 + 16), or Non-TS.

These packet sizes can only be set for an MPEG2 transport
stream. For a Non-TS stream, the packet size is fixed to
Non-TS. In addition, if you select 8VSB, the packet size is
fixed to 188.

When you select Non-TS, the MPEG Player deals with stream
data in a byte unit (not a packet unit) and outputs all of the
datain afile. If a transport stream contains any error, you can
output it by selecting Non-TS.

Clock

Sets the clock rate of the stream output. When you select
this command, the Clock dialog box appears. Refer to Clock
Dialog Box for more information. (See page 199.)

Update

Sets whether to update parameters in the stream when
looped. You can select On or Off. You cannot set to On for a
Non-TS stream.

You can select which parameters in the stream are updated
using the Others dialog box. Refer to Others Dialog Box for
more information. (See page 205.)

PCR Initial Value

Sets the initial value of the program_clock_reference_base
and program_clock_reference_extension parameters when
the transport stream is output.

When you select this command, the PCR Initial Value dialog

box appears. Refer to PCR Initial Value Dialog Box for more
information. (See page 202.)

Source

Selects the source for stream output. You can select RAM
or Disk.

Refer to ASI Interface Menu and IP Interface Menu for
detailed information about differences between the two
sources. (See page 208.) (See page 208.)

Loop

Sets whether or not the stream is output using looping
method. You can select On or Off. If you set it to On, the
selected stream is continuously output. If you set it to Off, the
selected stream is output once.

Start/Stop

Sets the start and stop position of the stream, and initial start
position of the stream for loop output.

When you select this command, the Start/Stop Position dialog
box appears. Refer to Start/Stop Position Dialog Box for more
information. (See page 203.)

MTS4000 and MTS4SAV3 Generator Applications User Manual 197



MPEG Player - Menus and controls

198

Table 32: Play menu commands (Play screen) (cont.)

Command Description

Auto play Sets whether or not the transport stream is automatically
output using the last power-down settings when you turn the
MPEG Player on. You can select On or Off. If you set it to On,
take care of the output level setting used when the MPEG
Player was last turned off and the input level of the instrument
(device) currently connected to the MPEG Player.

Timer Play Sets the date and time used to output a stream automatically.

When you select this command, the Timer Play dialog box
appears. Refer to Timer Play Dialog Box for more information.
(See page 205.)

Other Sets the standard used to display the selected stream and
display radix for the text information.

When you select this command, the Others dialog box
appears. Refer to Others Dialog Box for more information.
(See page 205.)
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Clock dialog box. When you select the Clock... command from the Play menu,
the Clock dialog box is displayed.

Clock =
Clock Source
ExtFef 10.0 Ext P Clk Ext 5 Clk
[ata Rate
3333337
v 250 = 93999993  [Mbps)
3000000

Default B ate

[ Ok ] [ Caticel

Figure 18: Clock dialog box for Option interface

Clock =

Clock Source

E«tRef 10.0 Eut P Clk Eut 5 Clk
i@ Data Rate
3333337
v &0 = 93.9593393 [Mbps]
9000000
(1 IP Data Bate

28781511 [Mbps)

Default Bate

[ 0K ] [ Cancel

Figure 19: Clock dialog box for IP interface
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Clock Source: Sets the clock that will be used as the reference for the stream
output. You can select the desired clock source from the following settings:

m  Internal uses the internal clock of the MPEG Player as the clock reference.

= Ext P Clk and Ext S CIk are disabled.

B Data Rate sets the clock rate for the transport stream output. You can enter
the clock rate using the following methods (the first method provides greater
clock-rate precision):

= Enter values into the numerator and denominator text boxes. The MPEG
Player will then calculate the clock rate based on the ratio of the numerator
and denominator values. (See Figure 18.)

= Enter a value into the clock rate text box. The MPEG Player will then
calculate the numerator and denominator text boxes based on the clock
rate.

NOTE. The IP data rate will be automatically calculated based on the TS data
rate available. IP Data Rate is calculated as follows:

IP Data Rate = (TS Data Rate x IP Packet Size) / Payload Size

= P Data Rate: Sets the clock rate for the IP packet (See Figure 19.). In the IP
mode, a change in the IP data rate will impact the TS data rate and a change
in the TS data rate will impact the [P data rate. The packet length changes
according to the selected protocol.

NOTE. The TS data rate will be automatically calculated based on the IP data
rate available and consequently influence the PCR/PTS/DTS update cycles. TS
Data Rate is calculated as follows:

TS Data Rate = (IP Data Rate x Payload Size) / IP Packet Size
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m  Default Rate: Displays the default clock rate and packet size and then
changes the values. When you select this button, the following Default Clock
dialog box appears.

Default Clock ]

Default Data Rate
333333
w20 = 939593593
3000000 (Mbps)
Facket Size
128 v
[ k. ] [ Cancel ]

Figure 20: Default Clock Dialog box

= Default Data Rate: Changes the default clock rate when the selected
stream file was downloaded.

Since the default clock rate is calculated based on the PCRs in the
downloaded stream file, the value can be different than the original clock
rate. When the elementary stream rate is fixed, the instrument refers to
the default clock rate. Therefore, if the default clock rate is different than
the original clock rate, you need to set the value to the appropriate value.
If you change the value, the clock rate value in the Data Rate dialog box
is also changed.

= Packet Size: Changes the default packet size when the selected stream
file is downloaded. If you change the value, the Packet Size setting in the
Play menu will also change.

Press the OK button to enable all setting changes.
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PCR Initial Value dialog box. When you select the PCR Initial Value... from the
Play menu, the PCR Initial Value dialog box is displayed.

PR Initial Value 3
PCR Initial Value
Base Value [33] 0
Extension Value [9] 0
I OK \ lCanceI ]

Figure 21: PCR Initial Value dialog box

B Base Value: Sets the initial value for the program_clock reference base
value. You can set the value from 0 to 8589934591. The bracketed number
represents the number of bits for the program_clock reference base field.

= Extension Value: Sets the initial value for the
program_clock reference extension value. You can set the value from
0 to 299. The bracketed number represents the number of bits for the
program_clock reference extension field.
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Start/Stop Position dialog box. When you select the Start/Stop... from the Play
menu, the Start/Stop Position dialog box is displayed.

Start/Stop Position E|
Start/Stop Pozition
1] a0 100%
(* Star 21586511 20 [#]
) Stop 107933055, 100
[ Initial
Play BE34E445| B0
Format | Bytes b l Reset ] [ k. l l Cancel

Figure 22: Start/Stop Position dialog box

Start: Sets the start position of the stream by time (h:m:s) or the number of
bytes for a Non-TS file). Use the Format field to select the method of setting
the position.

Stop: Sets the stop position of the stream by time (h:m:s) or the number of
bytes for a Non-TS file. Use the Format field to select the method of setting
the position.

Initial: Sets the initial start position of the stream for loop output. You can set
the value by time (h:m:s) or the number of bytes for a Non-TS file. Use the
Format list box to select the method of setting the position.

Play: Shows the actual time or the number of bytes for a Non-TS file) that is
calculated by the values of the Start and Stop text boxes.

Format: Specifies the method of setting the start, stop, and initial positions of
the stream. For a transport stream file, you can select Time or Packets. For a
Non-TS file, you can select Time or Bytes.

For an ISDB-T file, the start packet is defined as the first-appearing packet
including an OFDM frame start flag after the specified start position. The stop
packet is defined as the packet at the front of the last-appearing packet including
an OFDM frame start flag before the specified stop position. At this time, if the
number of OFDM frames between the start packet and stop packet is not an even
number, the packet in the last OFDM frame becomes the stop packet.

You can set the start, stop, and initial positions by using either the slider or the
text boxes.
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Using the slider. Ensure that Packets is selected from the Format drop-down list.

1.

For the start and stop positions:

a.
b.

C.

d.

€.

Select the Start option button.

Using the mouse, drag the slider to the required start position.
Select the Stop option button.

This moves the slider to the right end.

Drag the slider to the required stop position.

Select the OK button to enable the values.

2. For the initial start position for loop output:

a.
b.

C.

Enable the Initial check box. A red arrow appears on the slider.
Drag the red arrow to the required initial start position.

Select the OK button to enable the value.

Using the text boxes. Ensure that Time is selected from the Format drop-down

list.
1.
2.
3.
4.

Select the Start option button.

Enter the time in hour/minute/second format.

Repeat for the Stop time and the Initial Start Position time.

Select the OK button to enable the values.

To reset all of the settings to the values that were in effect when the dialog box
was first displayed, select the Reset button, and then press the OK button.
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Timer Play dialog box. When you select the Timer Play... command from the
Play menu, the Timer Play dialog box is displayed.

Tirmer Play @

Start at

114 222011 = 221:32PM =

0k ] [ Cancel

Figure 23: Timer Play dialog box
®  Start at: Sets the date and time when the stream output starts.

When you press the OK button after setting the date and time, the current date
and time and the set date and time are displayed. When the current date and
time coincide with the set date and time, the dialog box closes and stream output
starts automatically.

If you want to cancel the operation, select the OK button. When the dialog box
that prompts you to confirm the operation is displayed, press the OK button to
execute the operation.

Others dialog box. When you select the Other command from the Play menu,
the Others dialog box is displayed.

[ Others @

Standard | DVB -] | ToT/TOT |

MHurnernc Hex -

Ilpdate

] 4 Catizel

il

Figure 24: Others dialog box
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= Standard: Sets the standard used on the hierarchy-display screen. You can
select ARIB, ATSC, DVB, or MPEG2. For a transport stream (ARIB, ATSC,
DVB, or MPEG?2), the standard is set to the previous setting as a default. For
a ISDB-T transport stream, you need to select ARIB for proper display.

B Numeric: Sets the base value used to describe the component information in
the hierarchy display. You can select Decimal, Hex, or Octal.

m  TDT/TOT or STT: When you select this button, the following TDT/TOT
dialog box appears. The button name changes to the standard selected in the
Standard list box; TDT/TOT for ARIB or DVB, and STT for ATSC. Use
this dialog box to change the initial date and time of the TDT (Time and
Data Table), TOT (Time Offset Table), or STT (System Time Table) in the
selected stream.

TDT/TOT [X|

TOT/TOT
(%) Original
) Sustemn time
() User defined:

(] ] [ Cancel

Figure 25: TDT/TOT dialog box
The button is disabled when MPEG?2 is selected in the Standard list box.

= Original: Uses the original (default) value that is already defined in the
selected stream.

= System Time: Uses the clock/calendar of the operating system to set
the initial value. When you select this option, the date and time of
all the TDTs, TOTs, or STTs in the selected stream are locked to the
clock/calendar of the operating system.

= User Defined: Uses the user-defined value to set the initial value. When
you select this option, the list boxes for setting the initial date and time of
the TDT, TOT, or STT are available.
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m  Update: When you select this button, the following Select Update Item dialog
box appears. Use this dialog box to select which parameters in a stream are
updated when looped.

i Select Update Item @
Idpdate [tem
Continuity Counter
PCR/PTS/DTS
TDT/TOTASTT
[THPT

ok ] [ Cancel

Figure 26: Select Update Item dialog box

= Continuity Counter: Sets whether to update continuity counter.

= PCR/PTS/DTS: Sets whether to update PCR (Program Clock Reference),
PTS (Presentation Time Stamp), and DTS (Decoding Time-Stamp).
PCR/PTS/DTS are updated by adding the actual looping time (defined by
the start and stop positions) to the stream every time it is looped. There
are no timing errors in PTS/DTS, however, it is difficult to maintain
the continuity of PCRs at the loop point because the update is not
synchronized with the 27 MHz clock on the output board.

= TDT/TOT/STT: Sets whether to update TDT (Time & Data Table), TOT
(Time Offset Table), and STT (System Time Table).

= NPT: Sets whether to update NPT (Normal Play Time; STC_Reference
field in NPT Reference Descriptor defined by ISO/IEC 18318-6).

The NPT check box is available only when PCR/PTS/DTS is enabled.
When the check box is enabled, PCR/PTS/DTS becomes enabled.

Select the OK button to enable all setting changes.
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ASI interface menu

IP interface menu

The following table describes the command available in the ASI menu.

Table 33: ASI menu command

Command Description

ASI| Out Selects the ASI output port (ASI-1, ASI-2, ASI-3, ASI-4)
ASI-4 is the default selection.

ASI Format Selects the Byte mode or the Packet mode. Byte mode
evenly distributes K28.5 idles after each data word. Packet
mode sends all 188 or 204 words followed by a very long
string of K28.5 idles.

The following table describes the commands available in the I[P menu.

Table 34: IP menu commands

Command Description

Configuration Configures the IP interface. The packet size, device
name, protocol, ports, and the transmission mode can
be set.

Parametric Settings Sets the burst mode parameters and jitter parameters.

Error Insertion Inserts errors like packet loss, checksum, and sequence
errors in the transmitted stream.

Error Generation Generates errors like packet loss, checksum, and
sequence in the transmitted stream.

Statistics Displays details about parameter names, current stream
values, and the history of the previous transmission.

TTS Settings Enables whether to play out a TS file as a TTS file by

prefixing a 4-byte time stamp to each TS packet. The
TTS packet size equals 192 bytes.

Other Settings Sets the player process priority and transmitter thread
priority.

NOTE. Playing the MPEG Player at high bit rates in IP mode could saturate
the network.

NOTE. When you switch from ASI interface to IP interface, the Recommended
settings dialog box appears. This dialog box has an Auto Configure button to
configure all the settings automatically in the IP mode.
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Configuration. When you select Configuration from the IP menu, the IP Playout
Configuration dialog box is displayed as shown in the following figure. This
dialog box allows you to configure the following settings:

IP Playout Configuration El
Configuration name || v |
Pratacals
Device Hame | Metwork adapter ‘Intel{R] PRO/100 VE Metwork. Connection [Microsoft's | v |

Source [P Address | 192 158,965,217 - | Source Port 16384
Transmiszion Mode Diestination Part | 16384

DestinatinnIF'.-’-\ddress| 29 1 .1 1 |

[]Enable WLAN I:I [.&dvanced Seftings... I [Stleam Heplication...l
Packet Size
Allow T5 Fragmentation [] &llows IP Fragmentation

(#) |P Packet Size 1370 Bytes
() Mumber of T5 packets I:I

Store Settings ] [ Delete Settings I [HeselTo DefauItSettingsl I 0K l [ Cancel ]

Figure 27: IP configuration for IPv4

IP Playout Configuration E|
Configuration name | v |
Protocals
IP % ersion Protocol
Device Name | Metwork, adapter TntellR] PROAT000 MT Desktop Adapter [Microsoft's Pe s |
Source P Address | fe80- 207 2df-fe06 976 w | Source Port 16384

Tranzmizsion Maode Diestination Port | 16384

Destination IF Addiess |ff|je;;‘| |

[JEnable WLAN l:l l.&dvanced Settings... l [Stream Replication...

Packet Size
[14llow TS Fragmentation

(&) Mumber of TS packets IP Packet Size = 1390 bytes

Store Settingz I ’ Delete Settingz I ’F!esetTc- DefauItSettingsl [ ok l [ Cancel I

Figure 28: IP configuration for IPv6
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Configuration name: Allows you to enter or select a configuration name
from the drop-down list. This list can store up to ten configuration names.
The default value is blank.

IP Version: Allows you to choose the IP version (IPv4 or IPv6) from the
drop-down list. IPv4 is the default value.

Protocol: Sets the protocol (UDP, RTP) for the IP playout. RTP is set as
the default value.

Device Name: Allows you to select the device for the IP playout. The Device
Name lists all the active Network Interface Cards (NIC) in the system. The
standard MTS4000 contains two NICs. With the optional 10G card (Option
10GS), two additional NICs are available.

Device Mame lNetwmk adapter Intel(R) 82583 Gigabit Metwork Connection' on local h "]

Metwork, adapter 'Intel[R] Ethermet Server ddapter %520-2' on local host
Metwork. adapter 'Intel[R 82583\-" Gigabit Metwork, Connection’ on local host
Metwork, adapter 'IntellR] 3257300 Gigabit Hetwark Connection' on lacal hos

Metwork, adapter 'Intel[R) Ethernet Server Adapter #520-2" on local host

The first interface that has a valid IP address assigned to it is automatically
selected as the default value for both IPv4 and IPv6 versions.

Source IP Address: Sets the source IP address for the IP playout. The first
valid IP address of the selected device will be set as the default. The Source
IP Address can be modified in the Advanced Protocol Settings dialog. If the
Source IP Address is modified in the Advanced Protocol Settings dialog, then
this value is changed to "Customized".

Source Port: Sets the source port for the IP playout. The port value ranges
from 0 to 65535. The default value for UDP protocol is 0 and for RTP
protocol is 16384.

Transmission Mode: Sets the transmission mode of the protocol. Unicast,
Multicast, and Broadcast are the three transmission modes available in the
drop-down list. Multicast is set as the default value.

NOTE. In Unicast mode, the MPEG Player will auto detect the MAC address
for the destination IP Address. Hence, a valid destination IP address must be
provided for the MPEG Player. If the MAC address cannot be detected, the
destination IP address must be specified in the Advanced Protocol Settings.
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m  Destination IP Address: Sets the destination IP address for the IP playout.
239.1.1.1 is set as the default value for IPv4 and ff0e::1 is set as the default
value for IPv6. Depending on the selected transmission mode, the system
validates the entry based on the following rules:

= Unicast Range: Any IP address that does not fall into the Multicast or
the Broadcast range.

= Multicast Range: 224.0.0.0 to 239.255.255.255 for IPv4 and FFxx:Y:Y:Y
(where x is 0 to F and Y is 0000 to FFFF) for IPv6.

= Broadcast Range: The Network or node portion of an IP address will
be set to "1"s or "0"s.

®  Destination Port: Sets the destination port for the IP playout. The port value
ranges from 0 to 65535. 16384 is set as the default value.

=  Enable VLAN: Enables the VLAN layer that is present between the Ethernet
layer and IP layer. You will have to enter the VLAN ID to allow the
identification of 4096 VLANSs that is basically used by the 802.1Q standard.

B Advanced Protocol Settings: Click Advanced Protocol Settings to
view or customize the protocol settings of active protocols in the current
configuration. All the settings have only header customization for which
no validation is done.

Advanced Protocol Settings E|
Header Name Current ¥ alue Default Y alue A
Ethernet Layer
Destination Mac Address 01:00:5E:07:01:01 01:00:5E:01:01:01
Souce Mac Address 00:0%:20:06:0 %75 00:03:20:06:09:75
Protocol 2048 2048
P4 Layer
Wersion 4 4
Header Length 20 20
Type OF Service i) ]
Tatal Length 1356 1356
Time ToLive ] 5
Protocol 17 17
Source IP Address 192.158.96.217 152.158.96.217
Destination [P Address 238111 235111
UDP Layer
Source Part 16354 16354
Destination Park 16384 16384
Length 1336 1336 2

Figure 29: Advanced Protocol Settings dialog box for IPv4
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Advanced Protocol Settings

X

Header M arme Current Walue Drefault Walue L’
Ethernet Layer
Destination Mac Address 3333:00:00:00:0 33:33:00:00:00:01
Source Mac Address 00:03:20:06:05: 76 00:03:20:06:09: 76
Frotocol 34525 34528
IPE Layer
Werzion g E
Traffic Clazs 1] 0
Flaw Label a 0
Fayload length 1336 1336
Mext Header 17 17
Hop Limit 12 12
Source P Address fed:: 203 2dff.fe0E: 976 feB0::203: 2dff: felE: d97E
Destination P Address fide:1 fDe::1
LIDP Layer
Source Port 16384 16384
Destination Part 16384 16384
Length 1336 1336 A

Figure 30: Advanced Protocol Settings dialog box for IPv6

The Header Name and Default Value are read only options. The protocol
headers displayed will be limited to headers common to all packets. You
can customize the Current Value of the headers which can be specified at
packet creation. The customized valid values are displayed in lavender and

the customized invalid values are displayed in pink.

Click the Reset to Defaults button to reset the current values to default
values. Whenever any of the attributes is set, an icon is displayed in the status

bar during the play.

The parameters displayed in the Advanced Protocol Settings dialog box are as

follows:

B Ethernet Layer: Destination Mac Address, Source Mac Address, Protocol

= 802.1Q VLAN Layer: Tag Protocol Identifier, Priority Levels, Canonical
Format Indicator, VLAN Identifier

®m  [Pv4 Layer: Version (read only), Header Length (read only), Type Of Service,
Total Length (read only), Time To Live, Protocol, Source IP Address,
Destination IP Address

B  [Pv6 Layer: Version (read only), Traffic Class, Flow Label, Payload Length
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(read only), Next Header, Hop Limit, Source IP Address, Destination IP
Address
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m  UDP Layer: Source Port, Destination Port, Length (read only)

m  RTP Layer: Version (read only), Payload Type, Sequence Number, SSRC

NOTE. A condition where multicast is selected as the transmission mode and a
unicast destination address is entered in the Advanced Protocol Settings dialog
box will not be validated.

NOTE. If the destination IP address is changed in the Advanced Protocol Settings
dialog box, the application will not check for the accessibility of the address. A
change in the source and the destination IP address will not change the source
and the destination MAC address of the Advanced Screen Settings.

B Stream Replication Settings: Click Stream Replication Settings to set the
number of replicated streams and customize the attributes accordingly. This
setting is used to replicate the streams wherein a stream is replicated n times
with certain attributes of the stream incremented by a value within the n'
replicated streams. The customized valid values are displayed in lavender and
customized invalid values are displayed in pink.

You can enter the number of replications in the Number of replicated streams
text box. The table lists the attributes which can be incremented by entering a
number in the Increment Value column. All attributes except for MACs and
IP addresses will accept an integer.

Stream Replication Settings E|
Mumber of replicated streams
Replication Attribute Increment Yalue Current W alue b
Ethermnet Layer
Destination b ac Address 00:00; 00: 00 00: 00 071:00:5E:071:07:0
Source Mac Address 00 00: 00: 00:00:00 00:0320:06:03: 76
Protocal 1] 2043
|Pwd Layer
Type Of Service 0 0
Time To Live 1] 5
Protocol 1] 17
Source [P Address 0000 1010107
Destination |P Address 0000 235111
IIDF Layer
Source Port 1] 16334
Drestination Part 1] 16334
RTF Lagper
Payload Type 0 33 v

Figure 31: Stream Replication Settings for IPv4
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%)

Stream Replication Settings

Mumber of replicated streams |1
Replication Attribute Increment ' alue Current ' alue ~
Ethernet Layer
Destination b ac Address (0:00: 00:00: 0000 33:33:00:00:00: 01
Source Mac Address (0 00: 00: 00: 0 00 00:03:20:06: D3 7R
Frotocol a 34525
IPE Layer
Traffic Class il 0
Flon Label il 0
Mext Header a 17
Hop Limnit i} 12
Source IP Address 0:0:0:0: 0: 0000 feB0:: 203 2dif-fe0E:d37E
Destination 1P Address 0:0:0:0: 0: 00 00 fide::1
UDF Layer
Source Port a 16384
Destination Port a 16384
RTF Layer w

Figure 32: Stream Replication Settings for IPv6

You can click Reset to Defaults to reset the increment values to default
values. Whenever the stream replication is active, an icon is displayed in
the status bar during the play.

m  Allow TS Fragmentation: Controls the fragmentation of the transport stream
packets. If this option is selected, the transport stream packets will be split
across the IP packets else all the transport stream packets will be present
in the IP packet. By default, this is cleared. The IP Packet size option
will be enabled only if Allow TS Fragmentation option is selected. The
Number of TS packets option will be enabled irrespective of the Allow TS
Fragmentation option being enabled.

= Allow IP Fragmentation: Controls the fragmentation of IP packets. This
option is applicable to packet sizes which are greater than the MTU size of
the interface (typically 1500B). If this option is selected, the IP packets are
fragmented else they will be retained with the same size. By default this
option is cleared. The maximum packet size is 16128 when IP fragmentation
is selected. This option is available only in IPv4 version.

®  IP Packet Size: Allows you to set the size of IP packet. This option is enabled
only if TS fragmentation is allowed. When IP fragmentation is enabled, the
maximum size of IP packet for [Pv6 version is 16128 bytes and for [Pv4
version is 1500 bytes.

The IP packet size includes the headers. The payload size is calculated at runtime
using the following equation:

IP Packet Size = Payload Size + Header Size
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For IPv4 version, the header size is 54 (58 with VLAN enabled) for RTP and 42
(46 with VLAN enabled) for UDP. For IPv6 version, the header size is 74 (78 with
VLAN enabled) for RTP and 62 (66 with VLAN enabled) for UDP.

= Number of TS Packets: Allows you to type the number (integer) of TS
packets that needs to be embedded into an IP packet.

The maximum [P packet size is 1500 bytes or equivalent to TS packets.

A read only text field showing the IP packet size is displayed next to this
option. The IP packet size will be calculated automatically and displayed in
bytes. Based on the number of TS packets, the IP packet size is calculated
using the following equation:

IP Packet Size = Payload Size + Header Size
where payload size is calculated as follows:
Paylaod Size = Number of TS Packets x TS Packet Size

H  Store Settings: Stores or updates the entire configuration settings including
the Advanced Protocol Settings. All these settings will be listed out in the
Configuration Name drop-down list.

E  Delete Settings: Deletes the selected configuration setting that is displayed in
the Configuration Name drop-down list and selects the next configuration in
the list. If there are no more configurations stored in the list, the values in the
configuration dialog box will be reset to the default values.

m  Clear Settings: Clears the selected configuration setting including the
Advanced Protocol Settings and resets them to the default values.

B 802.1Q VLAN Layer: Tag Protocol Identifier, Priority Levels, Canonical
Format Indicator, and VLAN Identifier
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Parametric settings. When you select Parametric Settings from the IP menu, the
Parametric Settings dialog box is displayed as shown in the following figure.

Parametric Settings f'5_<|

(*) Burst Period |2 | ms

() Burst Size | |

Jitter
[ Low Jitter Mode
[ Jitter Distribution

[ o | [ coes |

B Burst Mode: Allows you to transmit the player thread in the form of bursts.
Burst mode is not selected by default.

= Burst Period: You can set the time during which the packets will be
transmitted in the burst mode. Burst period is selected by default.

= Burst Size: You can set the burst size which determines the number of
packets being transmitted in every burst.
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m  Jitter: Inserts jitter during IP playout.

Lower Jitter Mode: When Lower Jitter Mode is enabled, the Statistics
and the Error Generation options are disabled in the IP menu.

Parametric Settings gl

Jitter

Low Jitter Mode
[ Jitter Diistribution

Jitter Distribution: There are four types of Jitter Distribution namely
Fixed, Laplacian, Gaussian, and Sinusoidal. Fixed is the default jitter
distribution. When Fixed is selected, a Duration text box is displayed
where you can enter the jitter in microseconds. When Jitter Distribution
other than Fixed is selected, a slider is displayed where you can set the
jitter as percentage of the interpacket time by moving the slider. The
interpacket gap will follow the selected jitter distribution. The overall bit
rate of the playout is not affected by jitter insertion.
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Error insertion. When you select Error Insertion from the IP menu, the Error
Insertion dialog box is displayed as shown in the following figure. This dialog box
allows you to insert errors during playout. For Non-TS playout, Error Insertion is
limited to packet drop and checksum errors.

Error Insertion g|
[v Enable Enar Insertion
" Sequential &+ Random
Packet Erars
v Packet Loss |1 ! |1DDD Packets
[ Checksum Ermor | J [ |
RTP Ermars
¥ Sequence Ermor |1 ! |1DDD Packets
1 Packets Apart
oK | Cancel

Figure 33: Error Insertion dialog box

®  Enable Error Insertion: Enables error insertion. All error insertions are
specified as X errors per Y packets except for jitter. You can have error
insertion in sequential or random order.

= Sequential: The errors are inserted in sequential packets; that is, for every
Y packets the first X packets have errors inserted in them.

= Random: The errors are inserted in random packets; that is, for every Y
packets X random packets have errors inserted in them. Random mode
is set as the default.

B Packet Loss: Inserts packet loss. The packets are dropped at a frequency you
specify. You can specify the rate as X packets within Y packets.

m  Checksum Error: Inserts checksum error. The checksum error can be
inserted in UDP layer of both IPv4 and IPv6 versions and in the IP layer of
IPv4 version. The CRC errors are generated in packets at a frequency you
specify. You can specify the rate as X packets within Y packets.

B Sequence Error: Inserts packet sequence error. This option is enabled only
if RTP protocol is selected in the IP configuration Playout dialog box. The
packets will be reordered at the frequency specified in the Packets text box.
You can enter the number of packets after which you want the reordering to
happen in the Packets Apart text box. You can specify the rate as X packets
per Y packets after every Z number of packets.
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Error generation. When you select Error Generation from the I[P menu, the
Error Generation dialog box is displayed as shown in the following figure. This
dialog box allows you to insert errors manually.

Error Generation P§|

Generate Packet Loss

Generate Seguence Emor

Generate [P Checkzum Eror

Generate 1OP Checksum E mar

Cloze

B Generate Packet Loss: Drops an IP packet during the IP playout. The number
of packets dropped will be equal to the number of times you click the button.

®  Generate Sequence Error: Generates sequence error manually. When you
click this button the packet will be resequenced with another packet within a
100-packet boundary.

B Generate IP Checksum Error: Generates checksum errors manually in the
IP layer. This option is available in IPv4 version.

m  Generate UDP Checksum Error: Generates checksum errors manually
in the UDP layer.
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Statistics. When you select Statistics from the IP menu, the Statistics dialog
box is displayed. The player displays the current and historic statistics of IP
parameters, TS parameters, and Errors. These will be retained until the start of
next play or until a new file is opened. This option is not available when Low
Jitter Mode is enabled.

Statistics

3
Parameter Name Yalue ~
IP Parameters
Bitrate (Mbps] 0.000000
Bitrate “ariation (%] 0
Jitter [usz) 0.000000
Mumber Of Packets 1]
Packet Size [Bytes] 0
Bytes Transmitted [Bytes] 0

TS Parameters

Bitrate (Mbpz] 0.000000
Bitrate Y ariation (%] 0
Mumber Of Packets 1]
Packet Size 188
Errors
Parkets Mrnnned n ¥

Cloze

B Current: Displays the instantaneous statistics of parameters at that time.
Once the play is started, this dialog box is refreshed at the rate of every second.

IP Parameters: The current bit rate, percentage variation of this current
bit rate from the nominal (set) bit rate, number of IP packets transmitted,
and the IP packet size used for playout are all displayed. The jitter value
which reflects the insertions done at runtime is also displayed.

TS Parameters: The TS bit rate of the MPEG file being played is
displayed. The number of TS packets and the TS packet size is also
displayed. If the player is in the Non-TS mode, then all the statistics will
display Non-TS playout.

Errors: Number of packets dropped, packet loss rate, sequential errors,
and checksum errors for both IP and UDP are all displayed.

Value (per stream): When stream replication is enabled, the Current tab
displays the Value column. This column gives the value of each parameter
per stream.

Total Value (in n streams: When stream replication is enabled, the
Current tab displays the Total Value column. This column gives the total
value of each parameter for the set number of streams. Here n streams is
equal to the sum of the replicated streams and the actual stream.
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m  Historic: Displays the minimum, maximum, and average values of parameters
(IP, TS) for the current play. When stream replication is enabled, the History
tab signifies that the statistics displayed is per flow.

= IP Parameters: The current bit rate, percentage variation of this current
bit rate from the nominal (set) bit rate, and the jitter value are displayed.

= TS Parameters: The bit rate and the percentage variation from this bit
rate are displayed.

Timestamped TS playout settings. When you select TTS Settings from the IP
menu, the TTS Settings dialog box is displayed. The TTS Settings option is only
supported by the IP mode.

When TTS is enabled, each packet (188 bytes) of TS file is prefixed by a 4-byte
time stamp and converted into a TTS stream. If the TS packet size is more than
188 bytes (192, 204), the extra bytes following the 188th byte are truncated and
4-bytes of time stamp will be transmitted along with it. For a partial TS file with
the TTS settings selected (with Preserve timestamp not selected), the submenus
namely the Update mode, Clock dialog box, and the PCR initial value of the Play
menu are all enabled.

B Preserve timestamps if the file already has them: By selecting this option,
you can preserve the time stamps of the TTS file if it already exists or add
4-bytes of time stamp to the TS packet.

= Enable TTS Jitter: By selecting this option, you can insert jitter to the time
stamps that gets appended to the TS packets.

= Pattern: You can select the distribution of jitter that is inserted to time
stamp from the Pattern list. The various patterns listed are Sine, Pulse,
Triangle, Square, Saw, Random, and Offset. Sine is set as the default
pattern.

= Period: You can set the period for the time stamp as number of packets.
Based on the selected pattern, the Period text box is enabled or disabled.
100 packets is set as default period value.

= Amplitude: You can enter the amplitude of the time stamp in the
Amplitude text box. Based on the selected pattern the Amplitude text box
is enabled or disabled. 0.00 ns is set as the default amplitude.

= Pulse Width: You can set the pulse width as the number of packets.
Based on the selected pattern, the Pulse width is enabled or disabled. 50
packets is the default pulse width.

In the TTS mode, the Packet size option of the Play menu is disabled with 188
bytes selected. When the TTS mode is selected, the status bar displays TTS mode
as the standard with 192 packet size.
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The displayed IP bit rate changes because there will be four extra bytes added
to each TS packet. When TTS Playout settings is enabled, the packet size in
the Statistics screen displays the actual packet size (188 bytes) with the four
time-stamped bytes.

Other settings. When you select Other Settings from the IP menu, the Other
Settings dialog box is displayed. The Others Settings dialog box allows you to set
the priority of the player process and the transmitter thread. As a result, you can
increase or decrease the accuracy of the interpacket gaps during playout.

The Other Settings dialog box allows you to set the following parameters:

B Player: You can set the process priority for the player. The priorities are
Real Time, Normal, Above Normal, and Highest. Above Normal is set as
the default.

B Transmitter: You can set the priority for the transmitter thread. The priorities
are Idle, Below Normal, Normal, Above Normal, Highest, and Real Time.
Real Time is set as the default.
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Recommended settings for ~ This section lists the recommended settings to improve the performance of the
MPEG Player in IP mode =~ MPEG player in IP mode.

Settings for playout performance. Perform the following steps to set the options
of Administrative tools for improved performance during the Playout:

1. Click Control Panel > Administrative Tools > Services in Classic view.

2. Select Windows Firewall/Internet Connection Sharing (ICS) to open the
dialog box. Stop the service and select Disabled from the Startup type list
to disable the startup.

Windows Firewall/Internet Connection Sharing (ICS)P... |E|E|

General | Log On || Recovery | Dependencies

Service name; Sharedéccess
Display name: WWindows Firewall/Internet Caonnection Sharing [ICS]
Diescriptior: Frovides network, address tranzlation, addreszing,

”~
name rezolution and/ar intrusion prevention services w

Path to executable:
C: W TN DO S s pstern 32t svchost exe -k netsves

Startup type: Dizabled

Service status: Stopped

You can specify the start parameters that apply when you start the service
from here.

Start parameters: | |

[ QK. ] l Cancel l [ Apply ]

Figure 34: Windows Firewall/Internet Connection Sharing (ICS)
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3. Select Automatic Updates to open the dialog box. Stop the service and select
Disabled from the Startup type list to disable the startup.

Automatic Updates Properties (Local Computer) E|E|

General |Ll:|g On | Recovery | Dependencies |

Service name: wuaLsery
Dizplay name: Automatic Updates
Description; Enables the download and installation of Windows

updates. If thiz service iz disabled, thiz computer will

|0

Fath to executable:
A INDOWS haystem 32h evchost exe -k netaves

Startup type:

Semvice status: Stopped

Stop Fauze Resume

Y'ou can specify the start parameters that apply when you start the service
from here.

Start parameters: | |

[ )4 H Cancel ” Apply ]

Figure 35: Automatic Updates Properties
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4. Select IIS admin to open the dialog box. Stop the service and select Disabled
from the Startup type list to disable the startup.

IIS Admin Properties (Local Computer)

General | LogOn || Recovery || Dependencies|

Service name: 11SADMIN

Dizplay name: 115 Admin

Description: Bllowes administration of Web and FTP services
through the Intermet Information Services snap-in

Path to executable:
C: 4w DO Shaystem32hineterinetinfo. exe

Startup type:

Service status: Stopped

Stap Pauze Fiesume

You can specify the start parameters that apply when pou start the service
from here.

Start parameters: | |

[ OF. H Cancel H Apply ]

Figure 36: 1IS Admin Properties
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Settings for Java update  Perform the following steps to disable automatic Java updates:

1. Click Control Panel > Java.

2. Select the Update tab and clear the Check for Updates Automatically check
box.

ava Control Panel |Z| |§| fg|

Generall Update |Java Security | Advanced

IJpdate Motification

& The Java Update mechanism ensures you hawe the most updated
= wersion of the Java platform, The options below |t you control how
updates are obtained and applied,

Tokify Me:

[ iheck For Updates Automatically

lick the "Update Now" butbon below to check for updates, Anicon
will appear in the system tray i an update is available, Move the
cursor over the icon ko see the status of the update,

Java Update was lask run ak 3:20 PM on 7/13/07, Update Now

[ QK H Cancel H Apply ]

Figure 37: Java Control Panel

A Java warning message is displayed. Click Never Check.

Java Update - Warning r5__<|
You have chosen to never check for updates and may '
miss future security updates. AN

e strangly recommend letting Java periodically check For newer versions to ensure ywou hawve
the most secure and Fastest Java experience.

[ Check Monkhly ] [ Mewver Check

Figure 38: Java Update-Warning
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Settings for VLAN. Perform the following steps to set the options for VLAN:

1. Click Start > Run and type regedit. Press OK to display the Registry Editor
Window.

2. Browse to HKEY LOCAL MACHINE\SYSTEM\ControlSet001\
Control\Class\{4D36E972—-E325-11CE-BFC1-08002BE10318}\00XX
where XX is the instance of the network adapter that you need to see tags

on. You can check by opening and viewing the driver descriptor value
(DriverDesc value should be Intel(R) PRO/1000 MT Network Connection).

egistry Editor,

Fie Edt View Favorites Help
= 2 My Computer A Hame Type Data ~
(3 HKEY_CLASSES_ROOT [2B)(Defaul REG_SZ (walue niok set)
g HKEY_CURRENT_USER, [Bacptivelrs s .
a8 & gﬂ;ﬁm’;ﬁ“cmm [2B)automegadvertised REG_SZ 47
T
& & s [aB) autaPawersaveModeEnabled REG_SZ 0
3 scuRTTy BusNumher REG_SZ 1
(# (L] SOFTWARE BusType REG_SZ 5
= 03 svsem [f8)characteristics REG_DWORD 0200000084 (132)
52 Controlsetoot [3B]checksumpxtp REG_SZ 1
= (23 Contral [2B)checksumRixTep REG 57 1
3 A [aB)checksumTap REG_SZ 1
(] Arbiters [ab] checksumTsTen REG 57 1
(] BackupRestore [3B]calnstallersaz REG_MULTL_5Z Intelhic.dl, MicColnstallerEntry EXColnst.c
(3 Biosinfo 3] cotnstaliFlag REG_DWORD 080000001 (2147453649)
(2 BootverificationProgram [2B)Componentid REG_SZ peilven_s0863dev_100e
=0 Class [aB] custamiessages REG_5Z 1
(Z {Z5DBCES1-6CEF-4472 BA6D-BS4C2BFCEIS) [B)omaFaimess e 0
(2 {364212FF E2DB-452D-8252 BI7COIETIEET) [BoriverDate REG 57 s
% {36FCOEE0-CAE5- 11 CF-B056-444553540000} [R8DriverDatenata REG_BINARY 0080 9¢ 35 26 dd ¢4 01
o gggfgzg:ggg'i :g;’g?i’;'gg;gg;:gj:g DriverDesc REG_S7 Intel(R) PROJIO00 MT Ketwork Connectic
Drivert REG_SZ 8.4.21.0
(1] {49CEBACE-5FE6-11D2-B1ES-0080CT2E74A2} S veraion =
(1 {4D36E985-E325- 11 CE-BFC1-DB00ZBEL 0315} E"ah'epME REG 57 2
(1) {4D3eE9E6-E325-11 CE-BFC1-08002BE1 03158} CusETine REG 52 1
(1] {4D36E9E7-E325-11 CE-BFC1-0S002BEL 0318} [2]Fiowcontrol REG_SZ 0
(1] {4D36E9E8-E325-11 CE-BFC1-0S002BEL 0318} [2B]mfPath REG_SZ oems.inf
(L {4D36EDE3-E325-11CE-BFC1-08002BE10318} ]nfsection REG_SZ E100E.ndi.NTx86.5.1
(1 {4D38ESEA-E325-11CE-BFC1-08002BE10318) [3Bjme, REG_SZ 0
(1 {4D38EQEE-E325-1 1CE-BFC1-DS00ZBE 0318} [3B]LoglinkstateEvent REG_SZ 5t
(1 {4DIBEQEC-E325-11 CE-BFC1-08002BE10318} [3B]MatehingDeviceld REG_SZ pilven_s086adey_100e
(1 {4D3BEQED-E325-11 CE-BFC1-08002BE10318} i REG_SZ 16128
(21 {4D3BEQEE-E325-1 1CE-BFC1-DE00ZBE 0318} REG_DWORD 0x00000001 {1}
(21 {4D3BEQEF-E325-1 1CE-BFC1-DE00ZBE 0318} REG 57 5
(1 {4D38ET70-E325-1 1CE-BFC1-DE00ZBE 0318} [SB)wiEnatle e 0
(20 {4D36E971-E325-11CE-BFC1-UBO0ZBEL 0318} [2B]netcFatnstanceld REG_ST {9941€275-30 1 E-4F0B-9F09-9454AFC23
= (1] {4D3eE97e-E325-11 CE-BFC1-0B002ZE1 03 15) BrRsDescriptors hs e
x .
; % ggg? [2B]HumTxDescriptors REG_SZ 2048
& Linkage [aB)Peiscantethad REG_SZ 3
= ) [2B)providertisms REG_SZ Intel
B PROSemG [aB) qtagswiantralled REG_SZ 0
=03 ooz [2B]Reducespesdonpawerbonn REG_5Z 1
- o003 [aBl < avepruerinwFnahled RFG 57 1 A
o T onna L >
Iy Computer\HKEY_LOCAL_MACHINEYSYSTEM\ControlSet001yContrallClass|{4D35E872-E325- 11 CE-BRCL-0B002bE 1 031610001

Figure 39: Registry Editor

3. Right-click to select New > DWORD Value or select Edit > DWORD Value
option. Rename the option to MonitorModeEnabled.
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4. Double-click the DWORD Value to open the Edit DWORD Value dialog box.
Set the Value data to 1 and click OK.

Edit DWORD ¥alue

Yalue name:

| bd onitorkd odeE nabled

Yalue data:

[i

Baze
(%) Hexadecimal
() Decimal

x|

Cancel

Figure 40: Edit DWORD Value

NOTE. Restart the MPEG application to view the changes.

Utility menu  The following table describes the commands in the Utility menu.

Table 35: Utility menu commands

Command

Description

Communication...

Sets the port number that is needed to
remotely control the MPEG Player over an
Ethernet network and the terminator that is
used to communicate with a controller.

When you select this command, the
Communication dialog box appears. Refer
to Communications Dialog Box for more
information. (See page 229.)

About...

Displays general system information
including the software and hardware
versions.

When you select this command, the About
dialog box appears. Refer to About Dialog
Box for more information. (See page 230.)

228
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Communication dialog box. When you select the Communication command from
the Utility menu, the Communication dialog box is displayed.

- .
Communication @

Part
MNurmber 45200 =
Terminator
T« [CALF -
Re |LF -

[ Ok ][ Cancel ]

Figure 41: Communication dialog box

®  Port Number: Sets the port number needed to remotely control the MPEG
Player over an Ethernet network. You can set a value from 1024 to 65535.

= Terminator

= Tx: Selects the terminator that is used when the MPEG Player sends
information to a controller. You can select LF (linefeed), CR (carriage
return), CRLF (carriage return and linefeed), or LFCR (linefeed and
carriage return).

= Rx: Selects the terminator that is used when the MPEG Player receives
commands from a controller. You can select LF (linefeed) or CR (carriage
return).

Select the OK button to enable all setting changes.
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About dialog box. When you select the About... command from the Utility menu,
the About dialog box is displayed.

e

About MPEG Player =
Enabling Innovation

Tektronix and Tek are reqiztered trade marks of
Tektronix, [nc.

Copynght (2] 2017 Tektronix, Inc.

Froduct Mame: Tekboniz MPEG Flayer
Software Wersion: 11.0.0.3

Hardware Yerzions

M odule Yergion
451 Library 4100145
Device Driver | 3650254

This dialog box shows the version of the MPEG Player application and hardware
version of the main and installed interface modules - your versions may differ.
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Toolbar buttons

The toolbar provides shortcut buttons for many of the most often used menu
commands. Click a toolbar button to select the corresponding command.

== |

The following table shows the toolbar buttons and their functions.

Table 36: Toolbar button descriptions

Icon Name Function
| IE LOAD TS file Opens the Select File

dialog box. Equivalent
to the Open command
in the File menu.

. Load Preset Opens the Open
(== dialog box. Equivalent
to the Load Preset
command in the File
menu.

Save Preset Opens the Save as
E dialog box. Equivalent
to the Save Preset
command in the File
menu.

— Play Outputs the selected
| P | stream. Equivalent to
T the PLAY button on

the front panel.

Stop Stops the stream
L output.
0 Clock Opens the Clock
. dialog box. Equivalent

to the Clock command
in the Play menu. This
button is available
when the Play screen
is displayed.
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MPEG Player - Reference

This section contains information about the following MPEG Player features:
B Qutputting streams
®m  Adding jitter to PCRs

B Using Preset files

Interface card (ASI Option)

Refer to the MTS4000 Specifications and Performance Verification Manual for
detailed specifications of the interface card connectors.

About the data output ~ When you output the selected stream data, you can select either the hard disk or
source the RAM as an output source. This subsection describes the operation of the
MPEG Player when each output source is selected.

RAM. When you select the RAM as an output source, the MPEG Player performs
the following:

m  When data output rate is less than or equal to 120 Mbps, the MPEG Player
outputs the first stream data while transferring the data from the hard disk
to the RAM and then continuously outputs the data from the RAM using
looping methods.

B When data output rate is more than 120 Mbps, the MPEG Player continuously
outputs a stream data from the RAM using looping methods after the data is
completely transferred from the hard disk to the RAM.

If you select RAM as an output source, you cannot output data in excess of the
RAM free space for data output. This RAM free space is displayed on the status
bar.

The player displays the RAM space of 200 MB.
Hard Disk. If you select the hard disk (Disk) as an output source, the MPEG
Player always outputs the selected stream data from the hard disk regardless of the

data output rate. When the reading speed of the hard disk cannot overtake the data
output rate, the error message "Error: Output Buffer Empty" appears.

Use the Source command in the Play menu to select the output source. (See
page 197.) You can see the currently selected output source in the status bar.
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Adding jitter to PCRs

The MPEG Player provides the capability to add jitter to PCRs (Program Clock
References). Adding jitter to PCRs allows you to simulate transmission delay
variations and to test the robustness of decoders under various conditions.

The jitter function adds jitter to the program_clock reference base value and the
program_clock reference extension value in the adaptation field of transport
stream packets. You can use this function to modulate the data values of the
PCRs away from their correct values.

Adding jitter ~ Perform the following procedure to add jitter to PCRs:

1. Select a PCR element in the hierarchy display and select PCR Accuracy
Variation... from the right-click menu.

=

r:FPC“F". Inaccuracy

PCR Inaccuracy I:&

Fattern [Sine v]

Ferind 100 [Packets]
Amplitude 0 /27Hz : 0.00ns

alll

Figure 42: PCR Inaccuracy dialog box

2. The PCR Inaccuracy dialog box lets you set how the parameters for how
jitter will be added to the PCR.

= Pattern: Selects the type of the waveform used to add jitter. You can
select Sine, Square, Triangle, Pulse, Sawtooth, Random, or Offset.

= Period: Sets the period of the waveform used to add jitter. You can set the
value from 5 to 3000 packets in 1 packet steps.

= Amplitude: Sets the amplitude of the waveform used to add jitter. You
can set the value from 0/27 MHz to 135000000/27 MHz (0 s to 5 s).

= Pulse Width: Sets the pulse width of the waveform used to add jitter.
You can set the value from 1 to (period—1) packet(s) in 1 packet steps.
This Pulse Width parameter is available only when the Pattern parameter
is set to Pulse.
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3. After you have set the parameters, press the Apply button to enable the jitter

function.

Note that the PCR icon in the hierarchy display changes.

To disable the jitter function, open the PCR Inaccuracy dialog box and select the
Undo button. Note that the PCR icon in the hierarchy display changes.

The following figure shows the relationship among the parameters

and how the PCR values (program_clock reference base value and
program_clock reference extension) change when Sine is selected as a
jitter-pattern waveform. The PCR values vary by the value of sine waveform
defined by the amplitude and period. The PCR period does not change.

Jitter amplitude

PCR values ¢

Jitter period

Number of packets (time)

T

PCR period

PCR values

234

X e -Original PCR values

x - PCR values with sine jitter applied

Time
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Using preset files

You can save the instrument settings that you defined as a preset file, so that
you can later restore those settings. The preset files are stored in XML format
for your convenience.

Contents of the preset file  Saved Preset contain all of the parameter settings available in the Play menu.

Saving a preset file Use this procedure to save the current instrument settings as a preset file.
Perform the following steps to save a preset file:
1. Make the required instrument settings.

2. Select File > Save Preset. The Save As dialog box is displayed. In the File
name text box, a two-digit serial number is added to the selected file name (for
example, if the selected file name is "Test TS", the default file name becomes
"Test TS00"). Preset files use the .xml file extension.

You can change the file name as required.

3. Select OK to save the instrument settings as a preset file.

Loading a preset file ~ Perform the following steps to load an instrument setup from a preset file.
1. Select File > Load Preset. The Open dialog box is displayed.
2. Select the required file.
3. Press OK to load the preset file into the MPEG Player.

MTS4000 and MTS4SAV3 Generator Applications User Manual 235



MPEG Player - Reference

236 MTS4000 and MTS4SAV3 Generator Applications User Manual



Make Seamless Wizard

This wizard guides you through the process of creating an MPEG-2 file for use
by Stream Player in continuously looped operation.

The wizard is largely self-explanatory. The notes in this section of the manual
provide a slightly more detailed explanation of the wizard and the necessary
user responses.

NOTE. Make seamless supports the MPEG-2 video standard. It does not support
H.264 or H.265/HEVC.

Starting the wizard

To start the wizard, select the Make Seamless option from the Start menu.
Alternatively, double-click on the Make Seamless shortcut on the desktop.

The opening window is displayed:

Tektronix MakeSeamless Wizard

Make Seamless Wizard

Copyright € Tektronix [nc. 2007

Version 1,5, 3.0

Thiz wizard will guide you through the process of updating an MPEG file for uze by
Stream Player in continuously looped operation.

When combined with Continuous Time Stamping. minimal picture distubances will be
obzerved at the loop paint. Pleaze refer ta the Uzer Guide for more details.

Digital ¥ideo
Broadcasting

[ Skip thiz page on startup

Tektromnix MPEG Test
P System

Cancel |

This first page gives a short explanation of the wizard's activities and offers the
opportunity to skip the page in the future.

Select Next to move to the next screen and specify the input file.
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Progress and Information ~ The Progress and Information log displays messages during the operation of the
log wizard. Three types of message can be displayed:

INFO General processing information.

WARNING Messages which may mean that the output
stream will contain errors.

ERROR Messages indicating catastrophic information
which will cause the wizard to disable the
Next button and prevent further progress.

An icon is displayed in the top right corner of the window and as a prefix to any
messages displayed in the Progress & Information log. The icons are used to
indicate the current processing phase of the Make Seamless Wizard:

Program ®
Analysis 0y
Multiplex ()
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Selecting an input file

The first action is to identify the input or source transport stream.

Tektronix MakeSeamless Wizard - Program Info

— Input

Enter the name of a file ar hit the browse button ta find a file. Then click the Next |®
button ta get the program info from thiz file,

File: ISes_1Ds.mpg |
"Standard

& MPEG  DVE ( ATSC Scripts... |

— Progress & Information

| Type | Time | Meszage |
Digital ¥ideo
Broadcasting
Ie gy MPEG Test
k‘l.“:“'/lx System < Back I Mext » I Cancel |

Enter the filename in the File: field. The browse button (...) can be used to open a
standard Windows Open dialog box and locate files.

NOTE. Only the filename will be shown, but by resting the cursor over the
filename, the full path is shown for a short time in a tooltip.

. name af a file ar hit the browse button to find a file.
iclick the Mext buttan to get the program info fram thiz file.

(=P | C:*.5treamnshE lementamn Strean

[
T OVE " ATSC i MPEG |
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Sl scripts

240

Customized SI scripts are available to the Make Seamless Wizard to enable
custom SI table and descriptor data to be processed successfully. Basic processing
of the Standards does not require additional scripts.

If a suitably configured script is selected and enabled before a stream is analyzed,
custom data will be analyzed when the stream is opened. If the script is not
selected or enabled, the stream will not fail to be analyzed, but any custom data
will either be ignored or reported as an error in the stream configuration.

(The underlying principles of scripting are described in the Custom SI Scripting
section of this user manual.)

Handling script files. To handle SI Scripts, select the general Standard required by
enabling the appropriate radio button and select the Seripts button.

Tektronix Make5eamless Wizard - Program Info

— Input

Enter the name of & file or hit the brovese button to find & file. Then click the Hest I@
button to get the program info from this fils.

Fler ISes_ms.mpg |
Standard
’7 Scripts.. |

# MPEG " DVE (" ATSC

r— Progrezs & Information

I Type I Time | Meszage I

Add/Bemove Scripts

— Script File
DWVE . scp
[v] Takironix.scp

Digital viden
Broadcasting

Dielete

[ el ]

Move Up

—

o Do |

Tektronix MPEG Test
Va System

|

Wiew Script

Cancel |

0k |

The Script dialog box displays the scripts currently associated with each standard
and allows them to be added, removed, viewed, and manipulated.
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Add/Remove Scripts |

— Mode
" MPEG o« DiVE" O ATSC
— Scnpt Files
MPEG. zcp Add Mew...
CYE.zcp

Delete
kove Lp
Move Daown
Feload Scripts

Wiew Script

{1

Ok |

There is, in effect, one Script File list associated with each mode; script files can
be listed in one or more Script file lists. Script files are designated as MPEG, DVB
or ATSC when they are added to the Script File list. Each mode will display only
those script files associated with that mode. Further script files can be added as
required using the Add New button.

Note that a script file will not be used for analysis until:
m It is added to the Script File list in the appropriate mode.

m Itis enabled (displays a check mark in the Script File list).

Adding a script file.

1. In the Script dialog box, select the Mode to which the script is to be added; for
example, DVB.

2. Select the Add New button. A standard Windows file selection dialog box is
opened. The default file extension is .scp. Select the required file.

Note that the selected script file is now listed in the script file list and is enabled; it
will be used for any analysis.

Enabling a script file. Select the check mark adjacent to the required script file
to enable the file for analysis.

Moving a script file. Script files are applied to analysis in the order that they are

listed; in some circumstances this may be important. To move a file in a list,
highlight the file name and select the Move Up or Move Down button as required.
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Each press of the button will move the file up or down one place in the list until it
reaches the top or the bottom.

Viewing a script file. Script files can be viewed and edited in a text editor
(provided that the scp extension has been associated correctly in Windows
Explorer). To edit a script, highlight the script name and select View. This will
open the script in Notepad or its equivalent. The required edits can then be made
and the script saved.

When the filename is satisfactory and any scripting actions have been performed,
select Next to analyze the file. Progress is indicated by the progress bar and the
appearance of messages in the Progress & Information log.

Select a program to make seamless

242

During the input file's analysis the selected transport stream is analyzed to
determine it's program content. If analysis is unsuccessful in determining program
content, the stream will not be opened and an appropriate message will be
displayed in the Progress & Information log.

Each program found is displayed in the drop-down list ( Program: ) accompanied
by an indication of the number of program elements (video, audio, etc.).

At this stage a priority program must be selected in order for it to be analyzed and
tested for suitability for the "make seamless" treatment.

Tektronix MakeSeamless Wizard - Analyse E

— Input

Chooze one of the programs then select MNest to check the I@
content, Select Abort at any time to cancel the operation.
Frogram: IPngramﬂ 1 (5 elements] j
FEG Test Syste
Start packet: ID ¥ Make remaining programs seamless
Mumber of Packets: |3UUUU1 ¥ take PSI/51/PSIP seamless

— Progrezs & Infarmation

| Type | Time | Message

@ INFO 12:80:25  Searching for PAT...
@ INFO 12:50:25  Search for PAT complate.
@ INFO 12:50:25  Searching for PMTs...
@ INFO 12:50:25  Search for PMT e complete.

Cigital Videa

Broadcasting

ix MPEG Test
'Ibklmn}x System < Back I Mest > I Cancel
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Program: Highlight the required program from the drop-down list.

e programs then select Mest to check e
sl Select &bort at any time to cancel the operation.

Prograrm:

~ |Program# 1 [5 elements)
Start packet | evooramdt 2 (5 elements grars seanless

Program$t 3 [5 elements) ;
Mumber of Packets: [ Prograrmit 4[5 elements) !
Program$t 5[5 elements]

zeamless

Imfarmaticn

Start packet: This value determines from where the primary program is to be
analyzed. Indicates the offset from the original transport stream start point to start
looking for a loop start point.

Number of Packets: Initially, this value is set to the total number of packets in
the transport stream. It indicates the maximum number of packets (up to the end
of the stream) from the Start packet point that may be included in the loop.

Make remaining programs seamless: If enabled, the remaining programs are
made seamless but are constrained by limits defined by the priority program. This
may lead to these remaining programs having a gap at the beginning and end of
the file.
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Make PSI/SI/PSIP seamless: The service information contained in the transport
stream is processed to make it seamless.

If this check box is not enabled, the SI is not processed but simply copied to the
output transport stream.

Tektronix MakeSeamles: Wizard - Multiplex

— Input

Select "nest’ bo multiples this program.  The progress bar will
show the % of the file which iz complets. Hit Abort at any time
to cancel the operation.

Output File: |

— Progrezz & Infarmation
| Type | Tirne | Meszage il

@ INFO 12:58:22  Calculating transport rate...

® IMFO 12:55:22  Tranzport rate is 38.0714902 Mbits/s

@ IMFO 12:59:22  Prioiity PID i 160

@ INFO 12:58:22  Searching for priority PID loop start...

@ INFO 12:55:23  Search far priarity PID loop start complate.
Digital Video @ INFO 12:58:23  Searching for other PIDs loop start points... -
Broadcasting | E

ix MPEG Test
'Ibktmn/lx System < BEGR | HERtS | Abort I

Select Next. Once again the progress bar will indicate progress. While the stream
is being analyzed, selecting the Abort button will stop the process and allow the
program to be reselected (Note that the Abort button, which replaces the Cancel
button, is only displayed during processing).

When the file has been analyzed, a number of messages will have been posted in
the Progress & Information log.
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Selecting a multiplex output file

When a file has been analyzed and found suitable for making seamless, an output
file must be named.

Tektronix MakeSeamless Wizard - Multiplex

— Input

Select "next" to multiples this program.  The progrezs bar will I
show the % of the file which iz complete. Hit Abart at any time
to cancel the operation.

Output File: [test_seamless |

— Progress & Infarmation

| Type | Tirne | Meszage ﬂ
@ INFO 1256351 Searching for other PID s loop start points...
@ WARMIL..  1200:09  Unable to find a loop start point for every PID.
% IMFO 120009 Searching for prionty PID loop finizh point...
@

INFO 1200:09  Search faor pricrity FID loop finizh paint complete.

INFO 1200:09  Searching for other PID s laop finizh points...
Digital Video @ INFO 1300117 Search for other PID s loop finish points complete. =
Broadcasting 1] | B

Tektronix MPEG Test
Ve System < Back

A new filename can be typed or an existing file selected using the Browse button
(...), in which case confirmation of the replacement will be required. Select Next
to create the multiplexed output file.

The screen shown below is displayed upon completion of the process.
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nix MakeSeamles: Wizard - Summany

L]

Multiplesng, Chek Aberd ba cancel the cpershion,

1 Progress & Inhormaton

[ Type | Time | Heseage |
(&) wieRML., 130003 Unable tofind 2 loop start point far every PID.
@ IMFO 130008 Seanching b pionly FID bop hrish poik

@ INFO 130009 Sezichlor prceiy PID loop fnish parl complela
@ INFD 130009 Seanching fior olther PI0: loop fivish points....
(& IMFD 130071 Seanch for obhes FID 2 loop linish points complete

@ IMFD 130349 Muliplesng -
i | »
ARNERENN
Ibkl MPEG Test
I'ﬂl:lfl)i 83.'stvurﬂ’2E e e | [ seet ]

Tektonix MakeSeamless Wizard - Summarny

L]

¢

Multiplex completed. Click, Firish bo ext

1 Progress & Informaton
[ Type [ Time | Meseage |
(&) IMFO 130009  Seanching fior prionly FID loop finish poink .
@ IMFD 130009 Seanch for prceky FID loop frush pomt complele
@ INFO 120009 Sezichirg o alker PID: laop frish peirts .
@ INFO 130011 Seanchior othes FID 2 loop linish points complate,
(M) IMFD 130243 Mukiplesing.
@ IMFL 130404 KMuliplesng complele -
4] [
mklmn}xmggsm-{nﬁl < Back I Firesh I Cencel [

The output file will contain a program which when played out and looped with
the Continuous Time Stamping option enabled will demonstrate minimal picture
disturbances at the loop point.
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The Transport Stream Cutter is a wizard that creates a new file from a slice of an
existing file. It is run from the Windows desktop. There are four pages including
the optional introduction page:

MPEG-2 TS Cutter Wizard

Stream Cut Wizard

Copyright Tektronix [ne. 1935-2002
Wergion: B,7.0.0

PEG-

D\/3

Digital Yideo
Broadcasting

Thiz wizard will quide you through the process of cutting
a zection from a Mpeg File. It can alzo help you repair
zome damanged files.

Y'ou can uge the Strear Editor or Stream Analyser to
wiew the files in hexadecimal farmat to aszist in selecting
reqiong ko cut,

[T Skip thiz page on startup

'Ihktmnjx

Cancel |

B

TS Cutter Wizard - Step 1

ehrnn;x

PEG-

D\/3

Digital Wideo
Broadcasting

Y'ou can specify the source file manually, OF
Drag and drap a file fram an Explorer windaw, OF
Search for the file by clicking Browse,

II::"-.tmp"mtest.mpg

Browse... |

'Ihktmnjx

¢ Back

Cancel |
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TS Cutter Wizard - Step 2 |

Specify the packets to cut,

Enter packet number of first packet

I'I s0000
Enter number of packets to cut.

o |54E|:||:|
MPEG-Z
m Murnber of packets in selected file: 204300

Digital Wideo
Broadcasting

ektrnnjx

'Ibklmn}x < Back

Canicel |

TS Cutter Wizard - Step 3 |

Y'ou can zpecify the destination file manually, OF
Drag and drop a file from an Explorer window, OF
Search far the file by chicking Browse,

I-:: Wtmphtest_cub.mpg

Browze. . |

W Aszk before witing i file exists

Prezs the Finizh buttan to begin cutting or prezs the
Back button to review pour ophions.

'Ihklmnjx

< Back

Cancel |
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Starting the wizard

The wizard may be started by selecting the Tektronix TS Cutter option from the
Tektronix Utilities submenu of the Start > Programs menu.

Alternatively, double-click on the Tektronix TS Cutter shortcut on the desktop.

—y WIS T Capialel

f"g_, Tektronix Utilities 4 —:‘ Tektronix TS Cutter
i @ Tektronix TS Maker k

L@ Administrative Tools (Common) 4

Adobe Acrobat » &Fﬂ Tracer

Startup 4

Cutting a file

By default the wizard will display this Introduction first.

MPEG-2 TS Cutter Wizard |

Stream Cut Wizard

Copyright Tektronix Inc. 1995-2002
Werzion: B,7.0.0

Thiz wizard will guide you through the process of cutting
a gection from a Mpeg File. [t zan alzo help you repair
zome damaged files.

You can uze the Stream Editor or Sthream Analyzer to

i the files in hexadecimal farmat bo agsist in zelecting
regions o cut.

Digital Wideo
Broadcasting

[ Skip this page on startup

'Ihktmn}x Btk

Cancel |

The introductory page can be disabled by checking the Skip this page on startup
option. Select the Next button to move on to Step 1. (See page 250.)
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250

Step 1. Specify the name and location of the source file to copy a slice from:

TS Cutter Wizard - Step 1 |

Y'ou can specify the source file manually, OF
[rag and drap a file fram an Explorer windaw, OF

l’.‘ktl‘l]ll}x Search far the file by clicking Browse,
IE:Htmp'\.test.mpg

Browse... |

D\/3

Digital Wideo
Broadcasting

'Ibklmn}x < Back

Canicel |

Select the Browse... button to open a standard file browser window to look for
and choose the required file. Then select the Next button to move on to Step
2. (See page 251.)
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Step 2. The slice is specified by typing in the first packet and the number of
packets to copy. The total number of packets in the file is also shown.

Selecting the Back button will return to Step 1 (See page 250.) so that the source
file name and location may be changed.

TS5 Cutter Wizard - Step 2 |

Specify the packets to cut,

Enter packet number aof first packet

I‘I 50000
Enter number of packets to cut,

IE#EEIIJ

ektrnn‘jx

m Mumber of packets in zelected file: 204300

Digital Yideo
Broadcasting

'Ihktmnjx < Back

Cancel |
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Step 3. Specify the name and location for the new file.

Select Finish to create the file and copy the required slice of data. Select Back to
go back to change the source file, starting packet and number of packets.

TS Cutter Wizard - Step 3 |

Y'ou can zpecify the destination file manually, OF
Drag and drop a file from an Explorer window, OF
Search far the file by chicking Browse,

I-:: Wtmphtest_cub.mpg

Browze. . |

W Aszk before witing i file exists

Prezs the Finizh buttan to begin cutting or prezs the
Back button to review pour ophions.

'Ihklmnjx < Back

Cancel |

The wizard now creates the new file and copies the selected data to the destination
file specified. While it is working, this dialog box is displayed to indicate progress.

CatingFle |
L

Source: C:htmnphtest. mpg
Destination: o \mphtest_cut.mpg

When the blue progress indicator reaches the right side the dialog box disappears
and the file is ready to use.
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Setting up

Starting the program

ScriptPad is supplied with a number of Tektronix products to enable users to
create and modify System Information (SI) scripts.

The rationale underlying SI Scripting is described elsewhere in this document;
this section simply provides a guide to using ScriptPad.

It should be noted that script files are saved as ASCII files and that any ASCII text
editor can be used to view and modify the files (for example, Microsoft Notepad).
However, features such as color-coding of keywords and syntax checking will not
be available; also access to encrypted script files will not be possible.

The ScriptPad utility is installed automatically when the system is set up. There
is no additional specific set up procedure. Simple user interface management
is performed from within the utility.

ScriptPad is most often started by double-clicking an existing script file. The
necessary file associations (*.scp and *.scx) are made automatically during the
installation process.

Alternatively, you can start ScriptPad by clicking a shortcut placed on the desktop
or by selecting ScriptPad in the Start menu in the taskbar.
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Initial appearance

When the program has started and is ready for use, the main window is displayed,
as shown below:

& Sciipt Parser Files [SCP) M=l &3

Filz  Wiew Help

2 e e T R A

Ready tn1 | [WUM 4

The Toolbar (row of buttons above the dark gray area of the empty window) may
be hidden from view, moved to a separate window, either side or the bottom of
the main window.

The Status Line at the very bottom of the window may be hidden from view.

The dark gray area constitutes the Working Area.
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Initial menu options

File menu options  The following table lists the initial File menu options.

Table 37: File options

Option Function

New Opens a new file.

Open ... Opens a script file (*.scp) for analysis.
Choose the required file.

Print Setup ... Select which printer and associated options
to use.

1 <filename> A list of the four most recently analyzed files.

2 <filename> If the program has recently been installed,

3 <filename> ]t(ir;:sllst may be empty or hold less than four

4 <filename> Selecting a filename opens that file for
analysis.

Exit Closes the program.

View menu options  The following table lists the initial View menu options.

Table 38: View menu options

Option Function
Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Select an option to change its status.

Script file appearance

Scripts displayed in Script Pad are color-coded to aid understanding.

Script Pad makes no formatting corrections or changes; it is recommended that
script authors use conventional programming layout.

Single line comments are prefixed with a double slash (//); in ScriptPad they
are colored green. Multi-line comments of the form /*...*/ are also accepted by
the parser.
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Opening a file

Any script file (*.scp or *.scx) can be opened for viewing and editing by this
program.

To open a file, select the Open... option from the file menu. If the required file is
in the list of recently analyzed files, then it can be opened from the list.

& Script Parser Files [SCP)
Wiew Help

Mew Chrl+r
Frint Setup...

1 Copy of D%B.zcp
2 Copy of DWE. zom
2 0OVEB.scp

4 ARIB_DWE zcp

E xit

Alternatively, use the Ctrl+O keyboard shortcut.

There is also a shortcut button available on the Toolbar for opening a file, which
has the standard file open symbol.

E Script Parzer Files

File Wiew Help

O =&
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On opening, the script file is displayed in the working area.

2 Sciipt Parser Files [SCP) - [Copy of DVE _scp] Hi=] &

B File Edit “iew ‘window Script Help

g [ S|

D=\ »] ' [v]e] 82| BR0[3)

B T I
i

i File : DVB.scp

i Description @ SCP Script for DVB Tables - see EN 300 468 +1.3.1

i

i IMPORTANT NOTE - This script file contains the standard

i definition of the DVB tables. Change COPIES of this script

i and not the original. Copies should have this note removed.
i

i SRevision: 17 §
i SModtime: 12{04/00 5:27p §

i

i Change History

i

i 1543199 K Skilling CREATED

i 218400 M Morman Updated to a038r1

i 2719400 M White Updated walidation and formatting

i
R

#include "DVBEnums.scp"
#include "D¥YBDescriptors.scp''

! Override default to allow MPEG and DVB to be used together
{I Built in default is DVB only

validation descriptor_tag

[[descriptor_tag > - 0x40 [descriptor_tag <= 0xFE]]
[[descriptor_tag > = 0x02] [descriptor_tag <= 0x15]]

}

]

=l
Ready [ NOM [

Viewing and editing can start immediately. Note that multiple script files can be

open simultaneously.
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Script Pad - Menu and controls

The following pages contain descriptions of the menu options, toolbar controls,
and status bar.

Menu bar

Different menus and options are presented before and after file opening and
depending upon whether the file window or the message window is active.

The Menu Bar offers all of the options available currently. Options are context
sensitive; they will only be available where relevant. Some options are also
available through keyboard shortcuts; these are indicated on the menus.

A check mark next to an option indicates that the function is currently visible or
active; no check mark means that it is hidden or inactive.

File menu options  The following table lists the File menu options.

Table 39: File menu options

Option Function
New Opens a new file.
Open ... Opens a script file (*.scp) for analysis. The

program opens the file selection dialog box
allowing the user to choose the required file.

Close Closes the active script file window.
Save Saves the active script file window.
Save As ... Allows the active script file to be saved under

a different file name.

Encrypt When enabled, scripts will be saved in
encrypted format (*.scx) and unencrypted
format (*.scp).

Print ... Opens Print dialog.

Print Preview Previews print using current print settings.

Print Setup ... Opens a dialog for selecting which printer
and associated options to use.

1 <filename> A list of the four most recently analyzed files.

2 <filename> If the program has recently been installed the

3 <filename> list ma.y be empty or hold less tha.n 4 files.

4 <filename> aS:::;:ir;? a filename opens that file for

Exit Exits the program. The user is given the

opportunity to save any changed script files.
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Edit menu options  The following table lists the Edit menu options.

Table 40: Edit menu options
Option

Function

Cut

Delete the currently highlighted text and
move it to the clipboard.

Copy

Copy the currently highlighted text to the
clipboard.

Paste

Paste the contents of the clipboard to the
current cursor location.

Find ...

Finds and highlights the text string entered in
the Find dialog.

Replace ...

Finds and replaces the text string entered
in the Replace dialog.

GoTo ...

Places the cursor at the specified line
number.

View menu options  The following table lists the View menu options.

Table 41: View menu options

Option

Function

Toolbar

Shows or hides the Toolbar.

Status Bar

Shows or hides the Status Bar.

Auto Syntax Highlights

When enabled, automatically color-codes
keywords in the active file as they are typed
during editing.

Refresh Syntax Colors

Refreshes color coding of keywords in the
active file.

Window menu options  The following table lists the Window menu options.

Table 42: Window menu options

Option

Function

New Window

Opens a new empty window.

Cascade

Cascades all open windows in the
application.

Tile

Tiles all open windows in the application.

Arrange Icons

Aligns icons of any minimized windows at the
bottom of the program's main window.

1 <window title>

List the currently open windows. The
active (visible) window is indicated by the
checkmark.
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Script menu options

Help menu options

Toolbar

260

The following table lists the Script menu options.

Table 43: Script menu options

Option Function

Parse Parses the script file to check for syntax

errors.

Script Message Log Opens the parser message window.

The following table lists the Help menu options.

Table 44: Help menu options

Option Function

About ScriptPad ...

Opens the About dialog which displays the
program version number.

D|=(@] n|4[=|8] 82| &l6e[r)

The Toolbar provides a set of convenient shortcuts for the more frequently used
menu options. The available commands are:

Open a new file.

=

Allows an existing
script file to be
selected and
opened.

Saves the active
script file.

=

Finds specified text.

Allows the currently
selected text to be
cut. It can then be
pasted to another
location.

&= |[= ||

- Allows the currently
selected text to be
copied. It can then
be posted to another
location.
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E Allows text currently
held on the clipboard

(having been
previously cut
or copied from
elsewhere) to be
pasted to the cursor
location.

Allows the active
script to be printed.

Opens the About
ScriptPad dialog.

Parses the currently
active script for
syntax errors.

2 ||= ||w

Toggles the display
of the Script Parser
Messages window.

|

Allows the
color-coded
highlights in the
active script to be
refreshed.

[

Enables encryption.
Scripts saved while
this function is
enabled will be saved
in encrypted format
(*.scx) and encrypted
format (*.scp).

i

The Toolbar can be dragged off the edge of the main window into a floating pallet.
To do this click on the background inside the Toolbar, that is, not on one of

the buttons, and drag into the main window area. The result is a self contained
window which looks like this:

D[ 2@ w|s|=|e| 82| Bl

To replace the Toolbar on the window border drag it over the border until the
outline changes shape. It can be placed on the top, bottom, left or right edges.

Status bar

The Status Bar displays an information message when the cursor is placed over
any toolbar button or menu option.
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Script Pad - Script file editing and encryption

Because script files are saved as ASCII files, editing follows normal text editing
customs. However, ScriptPad does provide extra features to enhance and verify
the process.

Keyword color-coding

When the Auto Syntax Highlights option in the View menu is enabled, keywords
are automatically color-coded as they are typed.

When the Auto Syntax Highlights option is disabled, the color-coding can be
refreshed by selecting the Refresh Syntax Colors option in the View menu.

Parsing

Script files can be syntactically checked by selecting the Parse option from the

Script menu. A message box will indicate that errors were or were not found in
the file. The Script Parser Message window will be automatically opened when
the message is acknowledged.

Script Parser Message  The Script Parser Messages window logs the parsing activities and provides errors
window  and warnings when necessary.

The following icons are used in the message window.
@ Information

® Error

) Warning

Double-clicking and error message will bring the associated script file window to
the front of the display.

Messages can be cleared from the window by right-clicking anywhere within the
message window and selecting Clear messages.
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Encryption

There are an increasing number of proprietary standards emerging whereby
analysis is allowable (possibly subject to a licence fee), but the owner of the
standard does not want the script file to be viewed by users. This is solved by
using encrypted script files. The ScriptPad utility, which is used for creating and
editing script files has an Encrypt option, such that a script file is saved in an
unreadable encrypted format, that only the ScriptParser can interpret. ScriptPad
is associated with the .scp and .scx suffixes used for unencrypted and encrypted
scripts respectively during the installation process.

The script encryption process employs a robust, 128 bit symmetric-key algorithm
based on the Feistel block cipher, which is similar to that used in the dongle
encryption scheme. Additional functions have been included to increase the
entropy of the cipher text.

Each time a script is encrypted, a unique file is generated. This makes it hard to
determine the algorithm by making small changes to plain-text and then observing
the change made to the cipher-text. In addition the cipher-text is protected from
interference, meaning that changes to the cipher text are detected on decryption
and the altered file will be rejected.

NOTE. A dongle is a security or copy protection device that must be connected

to an I/0 port of the computer while the program is run. Programs that use a
dongle may query the port at start-up and at programmed intervals thereafter, and
terminate if it does not respond with the expected validation code.

MTS4000 and MTS4SAV3 Generator Applications User Manual 263



Script Pad - Script file editing and encryption

264 MTS4000 and MTS4SAV3 Generator Applications User Manual



Index

A

Adaptation field control, 135

Adaptation Field Error (ADFERR)
icon, 193

Adaptation field length, 135

Adding jitter to PCRs, 233

Amplitude, 195

Audio Elementary Stream
(AUDIO) icon, 193

B

Base value, 202
BAT icon, 188
BNC port, 208
Burst mode, 216
Burst period, 216
Burst size, 216

C

CAT icon, 185

CETT icon, 194

Checksum error, 218

Column repositioning, 72
Column sort, 72

Compressed string, 104
Contents of the preset file, 235
Copy Packet, 126

CVCT icon, 194

D

Delete settings, 215
Dialog boxes

PCR Inaccuracy, 234
Display elements, 180
DIT icon, 188
DLT icon, 190
DSM_CC icon, 193
Duration control, 69
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EETT icon, 194

EIT icon, 188

Entitlement Control Message
(ECM) icon, 193

Entitlement Management Message
(EMM ) icon, 193

Enumerated value, 102

Expert mode, 54

Export elementary stream, 73

Export section data, 73

Extension value, 202
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GARBAGE icon, 193

Gaussian jitter distribution, 217

Generate sequence error, 219

Generate UDP checksum
error, 219

GHOST icon, 193

H

H.264 input characteristics, 4
H.265/HEVC support, 4, 61
Header editor, 115

Import section data, 73
Interface

Option 7, 232
Interpretation, 6
IP data rate, 200
ISDB, 9
ISDB-T icon, 185
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Laplacian jitter distribution, 217
LDT icon, 190

Loading a preset file, 235
Lower jitter mode, 217

Max amplitude, 151
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Other settings, 208
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Packet size indicator, 183

Parametric settings, 216

PAT icon, 185

Pattern, 195

PCR icon, 185

PCR Inaccuracy dialog box, 234
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PCR recalculation, 127

PCR tab, 41

PID number, 84

PID source, 90

PMT icon, 185
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Program Clock Reference (PCR)
icon, 192

Program view manipulation, 27

Pulse width, 195
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Reed solomon, 115
Remap PIDs, 127
RST icon, 188
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Saving a preset file, 235
Scaling bar, 68
SDT icon, 188
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Transmission mode, 210

Transport Stream (TS) icon, 185

Transport structure
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