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TEKTRONIX SOFTWARE LICENSE AGREEMENT

THE PROGRAM, OR PROGRAMS, ENCODED OR INCORPORATED WITHIN EQUIPMENT OR
ACCOMPANYING THIS AGREEMENT, IS FURNISHED SUBJECT TO THE TERMS AND CONDITIONS OF
THIS AGREEMENT. RETENTION OF THE PROGRAM FOR MORE THAN THIRTY DAYS OR USE OF THE
PROGRAM IN ANY MANNER WILL BE CONSIDERED ACCEPTANCE OF THE AGREEMENT TERMS.
IF THESE TERMS ARE NOT ACCEPTABLE, THE UNUSED PROGRAM AND ANY ACCOMPANYING
DOCUMENTATION SHOULD BE RETURNED PROMPTLY TO TEKTRONIX FOR A FULL REFUND OF
THE LICENSE FEE PAID. (FOR INFORMATION REGARDING THE RETURN OF PROGRAMS ENCODED
OR INCORPORATED WITHIN EQUIPMENT, CONTACT THE NEAREST TEKTRONIX SALES OFFICE.)

DEFINITIONS.

"Tektronix" means Tektronix, Inc., an Oregon corporation, or local Tektronix’ legal entity that is supplying the
equipment.

"Program" means the Tektronix software product (executable program and/or data) enclosed with this Agreement
or included within the equipment with which this Agreement is packed.

"Customer" means the person or organization in whose name the Program was ordered.

LICENSE.

Customer may:

1. Use the Program on a single machine at any one time;

2. Copy the Program for archival or backup purposes, provided that no more than one (1) such copy is permitted
to exist at any one time;

Each copy of the Program made by Customer must include a reproduction of any copyright notice or restrictive
rights legend appearing in or on the copy of the Program as received from Tektronix;

Customer may not:

1. Use the Program on more than one machine at any one time;

2. Transfer the Program to any person or organization outside of Customer or the corporation of which Customer
is a part without the prior written consent of Tektronix, except in connection with the transfer of the equipment
within which the programs are encoded or incorporated;

3. Export or reexport, directly or indirectly, the program, any associated documentation, or the direct product
thereof, to any country to which such export or reexport is restricted by law or regulation of the United States
or any foreign government having jurisdiction without the prior authorization, if required, of the Office of
Export Administration, Department of Commerce, Washington, D.C. and the corresponding agency of such
foreign government;

4. Modify the Program, create derivative works, or merge the Program with another program;

5. Reverse compile or disassemble the Program for any purpose, beyond the extent that such activity is expressly
permitted by applicable open source licenses or applicable law notwithstanding this limitation, or

6. Copy the documentation accompanying the Program.



For Programs designed to reside on a single-machine and support one or more additional machines, either locally
or remotely, without permitting the Program to be transferred to an additional machine for local execution, the
additional machines shall be considered within the definition of "single machine." For programs permitting the
Program to be transferred to an additional machine for local execution, a separate license shall be required for each
such machine with which the Program may be used.

Title to the Program and all copies thereof, but not the media on which the Program or copies may reside, shall be
and remain with Tektronix or others for whom Tektronix has obtained a respective licensing right.

Customer shall pay when due all property taxes that may now or hereafter be imposed, levied or assessed with
respect to the possession or use of the Program or this license and shall file all reports required in connection with
such taxes.

If the Program or any related documentation is acquired by or for an agency of the U.S. Government, the
Program and documentation shall be considered “commercial computer software” or “commercial computer
software documentation” respectively, as those terms are used in 48 CFR §12.212, 48 CFR §227.7202, or 48
CFR §252.227-7014, and are licensed with only those rights as are granted to all other licensees as set forth
in this Agreement.

THE PROGRAM MAY NOT BE USED, COPIED, MODIFIED, MERGED, OR TRANSFERRED TO
ANOTHER EXCEPT AS EXPRESSLY PERMITTED BY THESE TERMS AND CONDITIONS. UPON
TRANSFER OF ANY COPY, MODIFICATION, OR MERGED PORTION OF THE PROGRAM, THE
LICENSE GRANTED HEREIN IS AUTOMATICALLY TERMINATED WITH RESPECT TO THE PARTY
THAT TRANSFERS THE PROGRAM.

TERM.

The license granted herein is effective upon acceptance by Customer, and shall remain in effect until terminated as
provided herein. The license may be terminated by Customer at any time upon written notice to Tektronix. The
license may be terminated by Tektronix or any third party from whom Tektronix may have obtained a respective
licensing right if Customer fails to comply with any term or condition and such failure is not remedied within thirty
(30) days after notice hereof from Tektronix or such third party. Upon termination by either party, Customer shall
return to Tektronix or destroy, the Program and all associated documentation, together with all copies in any form.

LIMITED WARRANTY.

The Program is provided "as is" without warranty of any kind, either express or implied. Tektronix does not
warrant that the functions contained in the Program will meet Customer's requirements or that the operation
of the Program will be uninterrupted or error-free.

TEKTRONIX AND ITS VENDORS DISCLAIM ANY IMPLIED WARRANTIES OF MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE.

LIMITATION OF LIABILITY, IN NO EVENT SHALL TEKTRONIX OR OTHERS FROM WHOM
TEKTRONIX HAS OBTAINED A LICENSING RIGHT BE LIABLE FOR ANY INDIRECT, SPECIAL,
INCIDENTAL, OR CONSEQUENTIAL DAMAGES ARISING OUT OF OR CONNECTED WITH
CUSTOMER'S POSSESSION OR USE OF THE PROGRAM, EVEN IF TEKTRONIX OR SUCH OTHERS
HAS ADVANCE NOTICE OF THE POSSIBILITY OF SUCH DAMAGES.

THIRD-PARTY DISCLAIMER.

Except as expressly agreed otherwise, third parties from whom Tektronix may have obtained a licensing right do
not warrant the program, do not assume any liability with respect to its use, and do not undertake to furnish any
support or information relating thereto.



GENERAL.

This Agreement contains the entire agreement between the parties with respect to the use, reproduction, and
transfer of the Program. Neither this Agreement nor the license granted herein is assignable or transferable by
Customer without the prior written consent of Tektronix.

This Agreement and the license granted herein shall be governed by the laws of the state of Oregon.

All questions regarding this Agreement or the license granted herein should be directed to the nearest Tektronix
Sales Office.
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Important safety information

Important safety information
This manual contains information and warnings that must be followed by the user
for safe operation and to keep the product in a safe condition.

To safely perform service on this product, additional information is provided at
the end of this section. (See page viii, Service safety summary.)

General safety summary
Use the product only as specified. Review the following safety precautions to
avoid injury and prevent damage to this product or any products connected to it.
Carefully read all instructions. Retain these instructions for future reference.

Comply with local and national safety codes.

For correct and safe operation of the product, it is essential that you follow
generally accepted safety procedures in addition to the safety precautions specified
in this manual.

The product is designed to be used by trained personnel only.

Only qualified personnel who are aware of the hazards involved should remove
the cover for repair, maintenance, or adjustment.

Before use, always check the product with a known source to be sure it is
operating correctly.

This product is not intended for detection of hazardous voltages.

Use personal protective equipment to prevent shock and arc blast injury where
hazardous live conductors are exposed.

While using this product, you may need to access other parts of a larger system.
Read the safety sections of the other component manuals for warnings and
cautions related to operating the system.

When incorporating this equipment into a system, the safety of that system is the
responsibility of the assembler of the system.
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Important safety information

To avoid fire or personal
injury

Use proper power cord. Use only the power cord specified for this product and
certified for the country of use. Do not use the provided power cord for other
products.

Ground the product. This product is grounded through the grounding conductor
of the power cord. To avoid electric shock, the grounding conductor must be
connected to earth ground. Before making connections to the input or output
terminals of the product, make sure that the product is properly grounded. Do not
disable the power cord grounding connection.

Power disconnect. The power switch disconnects the product from the power
source. See instructions for the location. Do not position the equipment so that it
is difficult to disconnect the power switch; it must remain accessible to the user at
all times to allow for quick disconnection if needed.

Observe all terminal ratings. To avoid fire or shock hazard, observe all ratings
and markings on the product. Consult the product manual for further ratings
information before making connections to the product.

Do not apply a potential to any terminal, including the common terminal, that
exceeds the maximum rating of that terminal.

The measuring terminals on this product are not rated for connection to mains or
Category II, III, or IV circuits.

Do not operate without covers. Do not operate this product with covers or panels
removed, or with the case open. Hazardous voltage exposure is possible.

Avoid exposed circuitry. Do not touch exposed connections and components
when power is present.

Do not operate with suspected failures. If you suspect that there is damage to this
product, have it inspected by qualified service personnel.

Disable the product if it is damaged. Do not use the product if it is damaged
or operates incorrectly. If in doubt about safety of the product, turn it off and
disconnect the power cord. Clearly mark the product to prevent its further
operation.

Examine the exterior of the product before you use it. Look for cracks or missing
pieces.

Use only specified replacement parts.

Use proper fuse. Use only the fuse type and rating specified for this product.

Wear eye protection. Wear eye protection if exposure to high-intensity rays or
laser radiation exists.

Do not operate in wet/damp conditions. Be aware that condensation may occur if
a unit is moved from a cold to a warm environment.

MTSA-HW and MTSA-PC Carousel Application User Manual vii



Important safety information

Do not operate in an explosive atmosphere.

Keep product surfaces clean and dry. Remove the input signals before you clean
the product.

Provide proper ventilation. Refer to the installation instructions in the manual for
details on installing the product so it has proper ventilation.

Slots and openings are provided for ventilation and should never be covered or
otherwise obstructed. Do not push objects into any of the openings.

Provide a safe working environment. Always place the product in a location
convenient for viewing the display and indicators.

Avoid improper or prolonged use of keyboards, pointers, and button pads.
Improper or prolonged keyboard or pointer use may result in serious injury.

Be sure your work area meets applicable ergonomic standards. Consult with an
ergonomics professional to avoid stress injuries.

Use care when lifting and carrying the product. This product is provided with
handles for lifting and carrying.

Service safety summary
The Service safety summary section contains additional information required to
safely perform service on the product. Only qualified personnel should perform
service procedures. Read this Service safety summary and the General safety
summary before performing any service procedures.

To avoid electric shock. Do not touch exposed connections.

Do not service alone. Do not perform internal service or adjustments of this
product unless another person capable of rendering first aid and resuscitation is
present.

Disconnect power. To avoid electric shock, switch off the product power and
disconnect the power cord from the mains power before removing any covers or
panels, or opening the case for servicing.

Use care when servicing with power on. Dangerous voltages or currents may exist
in this product. Disconnect power, remove battery (if applicable), and disconnect
test leads before removing protective panels, soldering, or replacing components.

Verify safety after repair. Always recheck ground continuity and mains dielectric
strength after performing a repair.
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Terms in this manual
These terms may appear in this manual:

WARNING. Warning statements identify conditions or practices that could result
in injury or loss of life.

CAUTION. Caution statements identify conditions or practices that could result in
damage to this product or other property.

Symbols and terms on the product
These terms may appear on the product:

DANGER indicates an injury hazard immediately accessible as you read
the marking.

WARNING indicates an injury hazard not immediately accessible as you
read the marking.

CAUTION indicates a hazard to property including the product.

When this symbol is marked on the product, be sure to consult the manual
to find out the nature of the potential hazards and any actions which have to
be taken to avoid them. (This symbol may also be used to refer the user to
ratings in the manual.)

The following symbol(s) may appear on the product:
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Preface
The MTSA MPEG system applications are described in three user manuals:

Analyzer applications

Generator applications

Carousel applications

The full list of applications can be found in the MTSA-HW and MTSA-PC Quick

Start User Manual. This manual describes the carousel related applications. All
applications are available on the MTSA-HW and MTSA-PC products:

The MTSA can be delivered to you as a rack mountable 1RU full rack instrument
(MTSA-HW), or as a standalone software (MTSA-PC). For product ordering
purposes, the following naming conventions are used in this manual:

MTSA-HW— Used for information that only applies to the MTSA-HW

instrument

MTSA-PC— Used for information that only applies to the standalone

software

MTSA— Used for information that applies to both MTSA-HW and

MTSA-PC products

Table i: Overview of the MTSA Carousel applications

Application Desktop Icon

Carousel Analyzer – Data analysis showing structure, bit rate,
repetition rate, syntax and semantics of data items.

Carousel Generator – Provides in-depth, offline generation of
MPEG-2, DVB transport streams containing a range of data
broadcast protocols.
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Product documentation
The following table lists the documentation available for the MTSA-HW and
MTSA-PC product:

Language Document title Part number Purpose

English MTSA-HW and MTSA-PC
Quick Start User Manual

071-3661-00 Describes how to install and get started using the
test systems.

English MTSA-HW and MTSA-PC
Analyzer Applications
User Manual

077-1600-00 Describes the operation of the following analyzer
applications: TSCA, PES Analyzer, T-STD Buffer
Analyzer, and ES Analyzer.

English MTSA-HW and MTSA-PC
Generator Applications
User Manual

077-1601-00 Describes the operation of the following generator
applications: Multiplexer, MPEG Player, TS
Editor, ISDB-T Remux, Make Seamless Wizard,
Transport Stream Cutter, and Script Pad.

English MTSA-HW and MTSA-PC
Carousel Applications
User Manual

077-1602-00 Optional manual supporting module-level
servicing of the instrument.

English MTSA-HW and MTSA-PC
Release Notes

077-1604-00 Describes known issues with the test systems.

English MTS4EA HEVC / AVC
Video and Compressed
Audio Analyzer User
Manual

077-1134-xx Describes the operation of the MTSA-PC
application software.

English PQA600C and PQASW
Picture Quality Analyzer
User Manual

077-1137-xx Describes the operation of the PQA application
software.
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Carousel Analyzer - Getting started
The Digital Storage Media Command and Control (DSM-CC) protocol was
originally developed to provide a VCR-like control mechanism for program
material delivered in an MPEG2 transport stream. Since then, the standard has
evolved to encompass a wide variety of applications including data broadcasting
and interactive television. DSM-CC forms a core part of a variety of both closed
and open standards such as the DVB MHP (Multimedia Home Platform) standard
for European Interactive Television.

The following DTV standards are supported: (See page 89, References.)

ISO/IEC 13818-6 Information technology - Generic coding of moving
pictures and associated audio information - Part 6: Extension for Digital
Storage Media Command and Control [MPEG] Reference 2

EN 301 192 Specification for data broadcasting [DVB] Reference 4

ARIB STD - B24 Data Coding and Transmission Specification for Digital
Broadcasting. Reference 11

Multimedia Home Platform [DVB] Reference 12

A bibliography of DTV standards documentation is given in the Reference section.

The Carousel Analyzer was developed to meet the specific need to analyze and
display the content and structure of data broadcasts. The tool provides a variety of
ways of looking at a transport stream and its contents including displaying the bit
rate, repetition rates, structure, syntax, and semantics of data items.
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The program view shows the various services in the transport stream and their
associated PIDs and data streams. Object or data (one or two layer) carousels
and U-U or U-N messages such as DSM-CC Download can also be displayed
with options to view associated, sections, carrier modules, or transport packets
for each version as required.

An object carousel in the stream can be viewed by contents as a directory structure
containing the underlying objects such as Java classes, picture, or text files. If an
object is associated with an installed application then a double-click will launch
that program, providing, for example, an easy and quick way to view the contents
of a picture file or read a text file.

The structure of the U-N download messages can be viewed showing the
relationship between DII, modules and blocks. The associated DSI and DII
messages contained in the U-N-Download tables can also be viewed in interpreted
or hex fashion; these indicate where to find and view the BIOPs that contain a
required object in the stream.

The timing relationships between the various components can also be easily
shown because the bit rates or the repetition rates of blocks, modules, objects,
U-N messages or SI tables can be shown together in a single graphical display.
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Data Broadcasting overview
Data Broadcasting allows data to be transmitted in a similar way to the way in
which video and audio services are delivered to end users. Object and Data
Carousels are intended for the periodic transmission of information in a transport
stream. DVB Data Carousels contain modules of data of unspecified content.
ARIB Data Carousels and Object Carousels contain identifiable data objects,
for example, JPEG files, text files, and application software. Multimedia Home
Platform (MHP) is also supported because the Application Information Table
(AIT) and Object Carousels (as specified in the MHP standard) can be viewed.

The diagram below shows how information carried by data and object carousels is
subdivided and ultimately carried by the transport stream.

BIOP messages contain a message header, a message sub-header and the message
body which contains data. The message body may contain complete data objects.

BIOP messages are broadcast in Modules. A Module is formed from one or more
concatenated, complete BIOP messages.

Each Module is fragmented into one or more Download Data Blocks which are in
turn transmitted in corresponding DSM-CC Sections.

Sections are transmitted in packets in the Transport Stream.

The Carousel Analyzer enables each layer of the protocol stack to be analyzed
and inspected. The following sections provide an overview of how the Carousel
Analyzer can be used to locate messages and packets of interest.
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Starting the program
The program can be started by selecting Start > Tektronix MTSA and opening
the Carousel Analyzer application, or by double clicking the Deferred Time
Analyzers folder in your desktop and selecting Carousel Analyzer.
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Initial appearance When the program has started and is ready for use, it will open the Main window,
as shown in the following figure:

Elements of the main window can be hidden during a session, but will be restored
at start-up.

The bottom section of the Carousel Analyzer is the PID filtering section.
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The Menu Bar contains all options available to the application; disabled options
are visible but grayed out. The Toolbars provide shortcuts to the more important
menu options; similarly, disabled buttons are visible but grayed out. The Transport
Packet Bar provides controls to locate and jump to transport packets. The Status
Bar shows stream information and the cursor message field.
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Initial menu options The Carousel Analyzer presents different menus and options depending upon
whether or not a stream is open for analysis. The menu options available when no
stream is open are as follows:

File menu options. The following table lists the options in the initial File menu:

Table 1: File menu options

Option Function

Open... Opens an MPEG transport stream for analysis. The program
opens the file selection dialogue allowing the user to choose
the required file.

Print Setup... Opens a dialog for selecting which printer and associated
options to use.

1 <<filename>>

2 <<filename>>

3 <<filename>>

4 <<filename>>

A list of the four most recently analyzed files. If the program
has recently been installed, the list may be empty or hold less
than four files.

Selecting a filename opens that file for analysis.

Exit Finishes running the program.

View menu options. The following table lists the options in the initial View menu:

Table 2: View menu options

Option Function

Toolbars > Submenu shows or hides the toolbar.

Transport Packet Bar Shows or hides the Transport Packet Bar.

Status Bar Shows or hides the status bar.

Analysis menu options. The following table lists the options in the initial Analysis
menu:

Table 3: Analysis menu options

Option Function

Set Interpretation > Select the Digital TV standard to be used for stream analysis.

Settings... Displays a dialog for selecting scripts to be used during analysis.
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Stream interpretation The DTV standard to be used for analysis must be selected before any streams are
opened.

Select the required standard from the submenu.

Script selection And
manipulation

Scripts are available to the Carousel Analyzer to enable structures to be analyzed
successfully.

If any script is not selected or enabled, the stream will not fail to be analyzed, but
any data normally interpreted by that script would be ignored.

Scripts can only be selected and enabled when no files are open. The is not
available when a file is open.
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Handling script files. To open the Analysis Settings dialog box, select Settings
from the Analysis menu.

The dialog box shown below is displayed:

In the Analysis Settings dialog, the left window shows a tree structure of the
test protocols available. The right window shows the scripts currently allocated
to the test protocol; in the example, the listed scripts are associated with the
DVB - Section protocol. The right window also contains the controls needed to
manipulate the scripts.

NOTE. Across the standards, the scripts are not hierarchical; that is, each DTV
standard must be self-contained in terms of the scripts that it uses.

The currently available script files are listed in the Reference section. (See
page 89, References.)

The following paragraphs describe the available script manipulation activities.
The activities are applied to the currently selected test protocol.
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Adding a script file.

1. With the required test protocol highlighted, select the Add New Script button
(Shortcut key: Insert).

2. If the script path/name is known, enter it into the blank field.

If the script name is unknown, use the browse button at the right side of the
blank field to display a standard Windows file Open dialog box.

3. The new script file name will be added at the bottom of the script list. Note
that script files are parsed in the order that they are listed, because the file may
require moving up in the list. (See page 11, Moving script files in the list.)

Removing a script file.

1. Highlight the file to be deleted and select the Delete Script button (Shortcut
key: Delete).
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Moving script files in the list. Script files are parsed in the order that they are
listed; the file may require moving up in the list

Highlight the file to be moved and select either the Move Up or Move Down
button (Shortcut keys: Alt-▲ and Alt-▼ respectively). The file will move up or
down one place for each press of the button.

Syntax checking options A number of options are available from the Analysis Settings dialog that allow
strict syntax checking to be enabled and disabled.

If any is not enabled, the relevant syntax will not fail to be checked, but will
be interpreted more loosely.

Syntax Checking Options can only be selected and enabled when no files are
open. The is not available when a file is open.

Currently, three syntax checking options are available:

Strict private data length / Message length checking. Object: U-U Object Carousel
Disabling this allows the privateDataLength field where it exists in the DSI
to be set to zero

The application will calculate it when required, using the total message length and
the position of the private data in the message. (See page 89, References.)

Strict association tag checking. Object: U-U Object Carousel The association tag
field in the stream_identifier_descriptor is an 8-bit value, while the same field
in an object carousel is a 16-bit value

When comparing these two values, the MSB of the 16-bit value should be zero.
Disabling this allows it to take other values. (See reference [4], 9.3 paragraph
3 and [6], paragraph 4.7.7.3.)

Strict CRC/Checksum checking. Object: DSM-CC Section
section_syntax_indicator and private_indicator fields should be the
complement of each other to determine whether a CRC or checksum is in use

Disabling this allows them to be the same and allows the application to work out
which method should be applied. (See reference [2], section 9.2.2 paragraphs
3 and 4.)
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Enabling a syntax checking option. To open the Analysis Settings dialog box,
select Settings... from the Analysis menu.

Select the Options tab. The dialog shown below is displayed:

In the Analysis Settings dialog box, the left window shows a tree structure of the
test protocols available. The right window shows the options currently allocated
to the test protocol; note that currently, options are only applicable to DSM-CC
Sections and U-U Object Carousels. Available options are applicable to all
standards, for example, an set in the DVB DSM-CC Section will be applied in the
MPEG and ARIB protocols.
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Opening a stream file Any Transport Stream file can be opened for browsing by the Carousel Analyzer.
However, only those streams containing Data and/or Carousel Objects will
provide meaningful results. Tektronix Transport Stream Compliance Analyzer
should be used for normal stream analysis. Only one file can be opened at a time.

To open a file, select File > Open. If the required file is in the list of recently
analyzed files, then it can be opened from the list to save using the open file dialog
box.

Alternatively, use the Ctrl+O keyboard shortcut.

There is a shortcut button available on the Toolbar for opening a file, which uses
the standard file open symbol:
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As the file opens, a progress bar is displayed; analysis may require more than one
pass through the transport stream file. The current pass number is shown in the
title line. After the first pass, a second progress bar (new resolved links) shows the
number of unresolved links at each pass.

Analysis can be halted at any time by selecting the Stop button in the dialog
box; the stream is still opened, but only the elements that have been analyzed so
far will be displayed.

14 MTSA-HW and MTSA-PC Carousel Application User Manual



Carousel Analyzer - Getting started

By default, the Services window and the Log window open as soon as a stream file
opens. Further windows can be opened by using the View Menu or the Toolbar.

NOTE. Although the options on the View menu remain the same, they are enabled
or disabled according to which protocol element is highlighted at the time.
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Menus and controls
The following pages contain descriptions of the menu options, toolbar controls,
status bars, and methods for managing the workspace.

Menu options
The following pages describe all of the menu options. Since many of the options
are context sensitive, they will be available only when their function is appropriate
for the selected window or display element. When a menu is not available, the
is grayed out.

File menu options. The following table shows the options available in the File
menu:

Table 4: File menu options

Command Function

Open... Open an MPEG transport stream for analysis. The program
opens the file selection dialogue box allowing the user to choose
the required file.

Close Closes the current file.

Save As... Saves the file to a new file name.

Print Opens the Print dialog.

Print Preview Opens the Print Preview dialog.

Print Setup... Opens the Print Setup dialog.

Exit Closes any file that is open and terminates execution of the
program.

Edit menu options. The following table shows the options available in the Edit
menu:

Table 5: Edit menu options

Command Function

Applications Opens the Application Management dialog.

Go To Next Jumps to next occurrence of the structure being viewed. The
Packet field in the Transport Packet bar will reflect the change
of packet.
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View menu options. The following table shows the options available in the View
menu:

NOTE. An active (depressed) button next to an indicates that the window or
toolbar is currently visible; an inactive button means that it is hidden.

Table 6: View menu options

Command Function

Toolbars > Submenu shows or hides the toolbar.

Transport Packet Bar Shows or hides the Transport Packet Bar.

Status Bar Shows or hides the Status Bar.

The remaining options in this menu open and close the associated window. The
options and windows are described elsewhere in this section.

Program/Services, U-N Download, Object Carousels, Data Carousels, PIDs
and Log.

BIOP Message, U-N Message, Section, Transport Packet, Transport Packet
List, Hex Dump, Timing, Carrier and Resources.

Repetition and Bitrate.
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Graph menu options. The following table shows the options available in the
Graph menu:

Table 7: Graph menu options

Command Function

Zoom Applies to Bitrate and Repetition views only.

Zoom In: Maximizes the central 50% (x-axis) of the current
graph.

Zoom Out: Takes one step back in the Zoom sequence.

Show All: Resets the graph to show all points.

Save Saves the graph in the selected format.

Copy Copies the graph to the clipboard in the selected format.
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Window menu options. The following table shows the options available in the
Window menu:

Table 8: Window menu options

Command Function

Cascade Rearranges the windows like this:

Tile Tiles the windows. For example, four windows would be tiled
like this:

Arrange Icons Aligns icons of any minimized windows at the bottom of the
program's main window.

1 <<window title>>

2 <<window title>>

3 ...etc

Makes the named window active, putting it on top of any
windows that had been hiding all or part of it.

Help menu options. The following table shows the options available in the Help
menu.

Table 9: Help menu options

Command Function

Quick Help Opens the Quick Help browser window.

About Carousel Analyzer Opens a message box that displays the program version
number and license number. This information will be required if
Tektronix Technical Support is contacted.
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Toolbars
Quick access buttons are divided between several toolbars: File, Edit, View and
Help.

A number of the toolbar functions are context-sensitive; which window is open
and which element is highlighted will dictate which buttons are enabled and
disabled.

File toolbar Icon Description

Open a file. This button is disabled when a file is open.

Save As… - BIOP file messages can be saved to separate files. Structures can
also be saved to a separate file.

Print - only available for bit rate and repetition views.

Edit toolbar Icon Description

Jumps to next occurrence of the structure being viewed.

View toolbar The buttons in this toolbar open and close the associated windows. The windows
are described elsewhere in this manual.

Icon Description Icon Description

View Programs/Services View Section

View PIDs View Transport Packet

View Object Carousels View Bitrate

View Data Carousels View Repetition Rate

View U-N Download Messages View Lifetime

View Log Zoom In

View BIOP Message Zoom Out

View U-N Message Show All

20 MTSA-HW and MTSA-PC Carousel Application User Manual



Menus and controls

Timing toolbar Icon Description Icon Description

Edit Application Timing View Carousel Cycle Time

View Entity Cycle Time View Carousel Cycle Time
Graph

View Entity Cycle Time Graph

Help toolbar Icon Description

About Carousel Analyzer: Opens a dialog box which displays the program
version number and license number. This information will be required if a
Tektronix Technical Support is contacted.
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Transport packet bar
The Transport Packet bar provides a quick method of locating and navigating to
transport packets PIDs.

Packet To locate a particular Transport Packet, enter the
Transport Packet number and select Goto.

PID Filter enable The PID navigation feature can be enabled by selecting
the checkbox (as shown).

To navigate to a specific packet: with the PID Filter disabled, enter the packet
number and select either the Previous or Next Packet button. If a PID structure
view is now requested from a View, the search for the PID will commence with
the transport packet number displayed.

Similarly, with the PID Filter enabled, each press of either the Previous/Next
button will display the previous/next transport packet containing the PID number
displayed in the PID Number field. If a PID structure view is now requested
from a View, the search for the PID will commence with the transport packet
number displayed.

NOTE. When a Transport Packet is viewed, the number in the Packet field will
increment by one.

The Transport Packet bar can be hidden from view by using the View menu
Toolbars .
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Status bar
The Status bar provides information about the stream that is currently being
displayed. A message field gives a description of the button, menu or that the
cursor is resting on; other non-critical messages may also be shown.
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Workspace
Window management In addition to the generic Cascade and Tile options available from the window

menu, management of individual windows is provided through a submenu
available by right-clicking the title bar of the individual window.

Right-click window title bar:

Each window within the workspace can be designated as Docked, Floating, or
as an MDI Child.

Docked. When docked, a window will be automatically placed against one of the
four sides of the workspace.

For example, selecting Docked > Top will dock the selected window at the top
of the workspace.

Floating. Designating a window as floating allows it to be moved around on the
monitor desktop independently of the Carousel Analyzer interface.

For example, selecting Floating will allow the window to be moved anywhere on
the desktop:
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MDI Child. Designating a window as an MDI Child allows it to be moved
anywhere within the workspace.

The MDI Child submenu allows the window to be designated as Restored,
Minimized or Maximized.

NOTE. When a window is "docked" it can be dragged (and dropped) around the
workspace; when it is at an edge it will adopt a docked position. MDI Children do
not attempt to dock with the edges of the workspace.

Version/size pane display Most of the views described later use a split-pane arrangement to display the
view data and related version, file size and PID information. The information is
displayed in the right pane. However, the default arrangement when opening
the view is that the right pane is closed. To open the pane, pass the cursor over
the right edge of the view until it changes to the split pane cursor, then move
the dividing bar to the desired position.
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Content management The principles employed in displaying the information in each workspace window
are applicable to all windows, although the content will vary from window to
window.

Tree structure. Structures are represented by tree diagrams, with the "root node"
or highest level component at the top

Components that contain more information underneath them in the structure are
indicated by a + box. Clicking on the + box will display the structure underneath
the node. Similarly, if a - box is adjacent to the node, the level of detail
immediately below it is already displayed; this detail can be hidden by clicking on
the - box. Components that are connected to a branch of the tree without a square
box are leaf nodes; they display the lowest and finest level of detail.

Right-clicking on a tree node may open a context sensitive menu.

Component selection. Components can be selected (or highlighted) either singly
or in groups.

When selected, the views available from the View menu (or a right-click menu)
will be those that can be applied to all of the selected components.

Single component selection Selected by clicking on a component.

Range selection Selected by highlighting the first
component in the required selection and, while holding
the Shift key on the keyboard, clicking on the last
component. The selected range will be highlighted.
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Multiple component selection Selected by holding
the Control key (CTRL) on the keyboard and clicking
the required components.

Node selection Selected by holding the Alt key
on the keyboard and clicking the required node; all
subcomponents will be selected.
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Saving components. Selected (or highlighted) components can be saved through
the right-click menu.

However, the manner in which the components were selected (see previous
paragraphs) will affect the file structure of the saved components.

If a Node Selection has been made, the directory structure is recreated at the
specified location and the subcomponents are saved to their equivalent directories.

If a Range or Multiple selection has been made, all files will be duplicated in
the root directory at the specified location in addition to recreating the directory
structure and saving the sub-components to their equivalent directories.

Hex displays. Hex displays follow a common format.

The eight-digit number in the left column is the address of the first (that is, left)
byte in the row. The addresses themselves are shown in hexadecimal format.

The center column displays the contents of the structure in hex format.

The right column displays the contents of the structure in ASCII format.
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Views
The Carousel Analyzer provides three types of views as a means of inspecting and
analyzing information carried in a transport stream.

Static views:

(Programs/Services, Object Carousel, U-N Download, Data Carousel, PID, Log)

Static views display information derived from the transport stream when it is
opened.

Structure views:

(Transport Packet, U-N Messages, Module, Section, BIOP Messages)

Structure views use Tektronix scripting technology to analyze structures that
appear in the transport stream, for example, tp, and BIOP messages. For repeated
structures, this view allows all occurrences to be visited.

Chart views:

(Bitrate, Repetition Rate)

Chart views present timing information in graphical form about one or more
structure in the stream.

View Page View Page

Programs/Services
View

(See page 32.) Structure Views (See page 52.)

Object Carousel
View

(See page 36.) Bitrate View (See page 55.)

U-N-Download
View

(See page 42.) Repetition View (See page 58.)

Data Carousel
(DVB) View

(See page 45.) PID View (See page 61.)

Data Carousel
(ARIB) View

(See page 46.) Log View (See page 63.)

Resource View (See page 50.) Cycle Times View (See page 65.)

In the following sections, each view is described together with the information
accessible from that view.
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The nodes displayed in the views relate to the protocol layers as shown in the
diagram below:

Table 10: Key to tree nodes

Service/Program Active PIDs/PIDs

Download Block BIOP Object Directory / ARIB
Directory

U-N Message BIOP Object / ARIB Resource

Download Module Table

Compressed Download Module Transport Packet

Data Carousel Audio Stream

Object Carousel Video Stream

Stream Object Data/Other Stream

Stream Event Object MHP Applications

Java Application HTML Application
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Key to node overlays. Overlays are used to signify additional information about
nodes; the overlays may be used individually or in combination.

Absent objects: Objects referenced but not found, for example, directory object not
found. The path in which the absent object is recognized is also marked.

Unresolved objects: When an object is found during analysis, but its key is not
referred to in the Service Gateway, it is displayed under an Unresolved Objects node.

Boot class objects: Boot class items are identified. The path in which the boot
class resides is also indicated.

Manual signaling: Indicates that a PID has been subjected to the manual signaling
process; used in the carousel and PID views only.
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Programs/Services view
Menu bar Toolbar

View > Program / Services

The Programs/Services view gives a static, DVB/ARIB service (or MPEG
program) centric view of the transport stream contents. Each program is listed
together with the service name (for DVB/ARIB). Expanding a program item will
reveal its elemental PIDs and any object (or data) carousels associated with it.

Figure 1: DVB programs/services view (typical)
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Figure 2: ARIB programs/services view (typical)

The diagram below indicates the primary nodes that are accessible from the
Program/Services view.
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Service/Program node
This node represents a specific program or service (DVB or ARIB) in a

transport stream. If a name for the program is available in the SDT (Service
Description Table), it is displayed. Each Elementary PID listed in the PMT
(Program Map Table) will have a corresponding node displayed as a child node of
the Services/Program node. Similarly, any Object or Data Carousels associated
with the Services/Program node are listed as child nodes.

Right-click menu options

Option Description

View PMT Opens the Section Table view for the PMT.

View Bitrate Activates or creates a bit rate view of the sum of the elementary
streams that are listed in the PMT for this program.

Elementary PID node
This node represents a PID referenced by a program. If the PID

carries Sections, these are represented as Table nodes.

Right-click menu options

Option Description

View Transport Packet Displays a structure view of the next transport packet
encountered on this PID from the current stream position (as
indicated by the Transport Packet number that is displayed in
the Transport Packet Bar).

View Cycle Time ► Allows either cycle time statistics or graphical view to be
selected.

View Repetition Activates or creates a view of the repetition rate of this PID in
the transport stream.

View Bitrate Activates or creates a bit rate view of this PID.
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Table node
This node represents the stream of sections present on a specific PID with a

specific table identity.

Right-click menu options.

Right-click menu options

Option Description

View Section Displays a structure view of the next section with this PID
and table identity that can be formed from the current stream
position onwards (as indicated by the Transport Packet number
displayed in the Transport Packet Bar).

View Cycle Time ► Allows either cycle time statistics or graphical view to be
selected.

View Repetition Activates or creates a view of the repetition rate of this PID in
the transport stream.

View Bitrate Activates or creates a bit rate view of this PID.
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Object Carousel view
Menu bar Toolbar

View > Object Carousels

The Object Carousel view shows a static view of every object carousel in the
transport stream.

The view is in the style of Windows Explorer. The left pane shows the directory
structure of the object carousels, and the right pane lists the versions of the BIOP
message currently selected in the left pane.

Double-clicking a file BIOP message can bring up an appropriate viewer
application if the operating system can find one (file associations can be set
through the Windows Explorer Options). File BIOP messages can also be saved
to disk by selecting File > Save As....

NOTE. The version number of the BIOP messages represents the version number
of the module that carries the BIOP message.
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The following diagram indicates the nodes accessible from the Object Carousels
view:

Object Carousel node
This node indicates that an object carousel has been signaled in the PSI / SI.

Right-click menu options

Option Description

View Application Timing Opens the Application Management dialog.

View DSI Carrying
Carousel IOR

Displays a structure view showing the U-N DSI message that
carries the service gateway IOR for this carousel.

BIOP Message node
This node represents a specific BIOP Message. If the node represents a

BIOP directory, the directory entries appear as child nodes.

Right-click menu options

Option Description

Open View the message in its native format. This only works for file
messages that have an associated viewer application on the PC.

Save As… Save the BIOP message to a separate file.

View BIOP Message Displays a structure view of the next appearance of this BIOP
message that can be formed from the current stream position
onwards (as indicated by the Transport Packet number displayed
in the Transport Packet Bar).

View Carrier Module Activates or creates the U-N download view and highlights the
module that carries this BIOP message.
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Right-click menu options (cont.)

Option Description

View Cycle Time ► Allows either cycle time statistics or graphical view of the
carousel to be selected.

View Repetition Activates or creates a view of the repetition of this BIOP
message.

View Bitrate > This BIOP message: Activates or creates a view of the bit
rate of this BIOP message.

> Including nested messages: View the sum of the bit rates
for this BIOP message and all descendant messages (that is,
all children and their children). These options are only available
for BIOP directory messages.

NOTE. If a Service Gateway is viewed in the Bitrate, Repetition, or Structure
view, its name in these views reflects the DSI transaction ID and PID in which it
was carried.
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MHP applications (See page 85, MHP support.)

Unresolved objects When an object is found during analysis, but its key is not referred to in the
Service Gateway, it is displayed under an Unresolved Objects node.

However, when a directory object is found, the keys of its child nodes can be
resolved and its tree structure built correctly, even though the directory object
itself may still be unresolved.
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Absent objects Objects referenced but not found are identified, for example, - directory object
not found. The path in which the absent object is recognized is also marked ( ).
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Manual signaling If a carousel is present in a stream, but has not been found during analysis, it can
be identified with Manual Signaling from the related PID node.

The Signal Carousel command can be found on the right-click menu associated
with each PID node. When this command is selected, the stream will be
reprocessed. During processing, only the DSM-CC tables on the selected PID
will be analyzed.

The user interface is updated when the stream has been processed. Any carousels
that have been identified are added to the Carousel view. The signal icon, used
only in the carousel and PID views, indicates that the PID has been subjected to
the manual signaling process.

The PID view will display a list of the table types that were detected during
processing.

NOTE. Carousels that span multiple PIDs will be only partially analyzed. The PID
must contain a Service Gateway for any Object Carousel view to be displayed.

The Log view is refreshed by describing the most recent action, for example,
Added Manually Signalled PID150.
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Any feedback from the Manual Signaling will be displayed in the Summary log.

U-N-Download view
Menu bar Toolbar

View > U-N-Download

This static view shows all the U-N-download (DSM-CC data carousel scenario)
messages in the transport stream.

The view is in the style of Windows Explorer. The left pane contains a hierarchical
pane on the left and a version pane on the right. The version pane will list the
versions of the U-N download message selected in the left pane.
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DII items contain module items that the DII message references. All modules are
also listed under the "Modules" item.

Modules may be in compressed form; the version of the compressed icon is

displayed in the Version column of the right pane.

Modules are listed independently of DII messages in case the DII does not
reference the module correctly; for a compliant stream, each module is listed as a
child of the DII node and within the Modules node.

The following illustration indicates the nodes that are accessible from the U-N
Download view.

U-N Message (DSI) node
This node represents a Download Server Initiate message.

Right-click menu options

Option Description

View U-N Message Displays a structure view of the next appearance of this DSI
message that can be formed from the current stream position
onwards (as indicated by the Transport Packet number displayed
in the Transport Packet Bar).

View Carrier Section Displays a structure view of the next appearance of the section
that carries this DSI message.

View Cycle Time > Allows either cycle time statistics or graphical view of the object
to be selected.

View Repetition Activates or creates a repetition view of the DSI message.

View Bitrate Activates or creates a bit rate view of the DSI message.
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U-N Message (DII) node
This node represents a Download Information Indication message. A DII

message may reference modules. If the module reference can be resolved, the DII
tree node will contain child Module nodes.

Right-click menu options

Option Description

View U-N Message Displays a structure view of the next appearance of this DII
message that can be formed from the current stream position
onwards (as indicated by the Transport Packet number displayed
in the Transport Packet Bar).

View Carrier Section Displays a structure view of the next appearance of the section
that carries this DII message.

View Cycle Time > Allows either cycle time statistics or graphical view of the object
to be selected.

View Repetition Activates or creates a repetition view of the DII message.

View Bitrate Activates or creates a bit rate view of the DII message.

Download Module node
This node represents a U-N Download Module. The download blocks

that constitute the module are listed as child nodes.

Right-click menu options

Option Description

View Hex Dump Displays a data view of the next appearance of this module
that can be formed from the current stream position onwards
(as indicated by the Transport Packet number displayed in the
Transport Packet Bar).

View Cycle Time > Allows either cycle time statistics or graphical view of the object
to be selected.

View Repetition Activates or creates a repetition view of the module.

View Bitrate Activates or creates a bit rate view of the module.
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Block node
This node represents a U-N Download Data Block (DDB).

Right-click menu options

Option Description

View U-N Message Displays a structure view of the next appearance of this DDB
message that can be formed from the current stream position
onwards (as indicated by the Transport Packet number displayed
in the Transport Packet Bar).

View Carrier Section Displays a structure view of the next appearance of the section
that carries this DDB message.

View Cycle Time > Allows either cycle time statistics or graphical view of the object
to be selected.

View Repetition Activates or creates a repetition view of the DDB message.

View Bitrate Activates or creates a bit rate view of the DDB message.

Data Carousel (DVB) view
Menu bar Toolbar

View > Data Carousel

This static view shows all the data carousels in the DVB transport stream. The
view is in the explorer style with a hierarchical view in the left pane and a version
view in the right.
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Data Carousel (ARIB) view
Menu bar Toolbar

View > Data Carousel

This static view shows all the data carousels in the ARIB transport stream. The
view is in the explorer style with a hierarchical view in the left pane and a version
view in the right.

The diagram below indicates the nodes that are accessible from the Data Carousel
(ARIB) view.
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Carousel node
This node represents a single Data Carousel in the ARIB data carousel

structure.

Right-click menu options

Option Description

View U-N Message Displays a structure view of the next appearance of this DII
message that can be formed from the current stream position
onwards (as indicated by the Transport Packet number displayed
in the Transport Packet Bar).

View Carrier Section Displays a structure view of the next appearance of the section
that carries this DII message.

View Cycle Time > Allows either cycle time statistics or graphical view of the object
to be selected.

View Repetition Activates or creates a repetition view of the DII message.

View Bitrate Activates or creates a bit rate view of the DII message.

Download Module node
This node contains all of the resources available to a module.

Right-click menu options

Option Description

View Resources Displays the Resource view of the selected module.

Save Resources Saves the resource files to a selected location. The header
information is not saved.

View Cycle Time > Allows either cycle time statistics or graphical view of the object
to be selected.

View Repetition Activates or creates a repetition view of the module.

View Bitrate Activates or creates a bit rate view of the module.

(See page 49, ARIB module versions.)
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Resource node
Each Resource node is a leaf node containing one resource file.

Right-click menu options

Option Description

Open Opens the resource in an associated application to allow it to be
viewed. If no association has been made with the file type on
the host computer, a message is displayed.

Save Saves the resource file to a selected location. The header
information is not saved.

View Displays the Resource view. The selected resource is
highlighted in the Resource view.
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ARIB module versions Note that there may be multiple versions of a single ARIB module. Each version
of the same module can potentially contain different resources. For example,
Version 1 may contain resources A, B, and C and Version 2 may contain resources
C, D, and E.

When viewing the resources in Data Carousel and Service/Program views, the
resources listed under the Module node will be all resources across all versions,
for example, A, B, C, D and E. When opening or saving any of these resources
from Data Carousel or Service/Program views, the operation will work on the first
version encountered in the stream (A, B, and C will come from Version 1 and D
and E will come from Version 2). Basically, these two views contain a summary
of all the resources encountered in that module regardless of version.

The ARIB Resource view will show only the resources contained in an individual
module version - to view resources from different module versions, the user must
use the Go To Next command or open a different version in ARIB Resource view.
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Resource view
Menu bar: View > Resources

The ARIB Resources view displays a hierarchical and raw data interpretation of
the resource structure in Data Carousels. The raw data is presented in hexadecimal
and ASCII form in the adjacent pane.

Resources node
This Resources node displays a header and the resources associated with

one Module.

Right-click menu options

Option Description

Go To Next

Displays the next occurrence of the Resource node in the
transport stream (note the change of Packet number in the
Status bar).

Save Saves the resource files to a selected location. The header
information is not saved.
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Resource node
Each Resource node displays header information and a resource.

Right-click menu options

Option Description

Open Opens the resource in an associated application to allow it to be
viewed. If no association has been made with the file type on
the host computer, a message is displayed.

Save Saves the resource file to a selected location. The header
information is not saved.

Data Represents the currently selected tree node.

Right-click menu options

Option Description

Save As …

Saves the Module Resource data to a selected location.

Go To Next

Displays the next occurrence of the Resource node in the
transport stream (Note the change of Packet number in the
Status bar).

View Transport Packet
List

Displays the Transport Packet Contributions view which lists
the transport packets that have contributed to the resources
in the module.

(See page 52, Structure views.)
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Structure views
Structure views display a hierarchical and raw data interpretation of a structure
(BIOP Message, U-N Message, Module, Section, or Transport Packet). The
hierarchical view is based on a script from the script files that are loaded. Raw
data is presented in hexadecimal and ASCII format in the lower pane. (See
page 8, Script selection And manipulation.)

Highlighting an element in the table window will automatically highlight the
section of the hexadecimal code that contains the selected information.

The view will bring up the first appearance of a particular message in the transport
stream reading from the current packet position. To view the next appearance,
select Edit > Go to Next. This will display the next repetition of the message in
the open structure view window; if necessary, it will wrap to the first occurrence.
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For example, in the following screenshot, the PAT first appears in transport
packet 0. Selecting Go to Next and viewing the section again will show the next
repetition of the PAT on transport packet 532 and so on.

Since the structure view is based on a script, the script can be edited and the
presentation of the packet or message changed.

Right-clicking on the any item in the structure view will open this menu:

Using the Save As…, the structure can be saved to a separate file.

The Go To Next moves the structure view to the next repetition of the same
item. If the current view is the last in the stream, the will loop back to the first
repetition in the stream.
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The information displayed by the structure view may be carried in one or more
transport packets. By right-clicking the item and selecting View Transport
Packet List, a list of the transport packets carrying the information will be
displayed. Highlighting a Packet Number and selecting View will display the
selected transport packet structure. Several structure views can be opened in this
way but the views are not enabled until the Transport Packet Contributions
dialog is closed.

The Low and High Index entries in the Transport Packet Contributions dialog
box indicate the first and last byte respectively of the packet that contributes to
the structure.

The screenshots below illustrate an example of this sequence of actions:
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Bitrate view
Menu bar Toolbar

View > Bitrate

This structure view charts the bit rate of a set of transport entities (for example,
BIOP message, PID, module). The bit rate calculation is a rolling average. For
any transport entity the sum of the transport packets that contribute to that entity in
each 100 ms time-slice are summed. The average is calculated every 100 ms using
the last 10 time-slices (that is, the bit rate is the average over the last second).

In some cases a choice is offered between displaying the bit rate of the selected
element or a composite bit rate of the selected element and its subsidiary (nested)
elements.

NOTE. In calculating bit rates, Carousel Analyzer returns to the stream file. For
large files, the calculation may take an appreciable amount of time.

The y-axis is automatically scaled to accommodate the maximum bit rate. The
name of the element from which the bit rate is derived and the related graph are
linked by color; a line (of the same color) is displayed to the right of the element
name.
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If the bit rate for a second element is requested, it is displayed on the same graph,
as shown in the following illustration:

Any number of element bit rates can be displayed; each will be a separate color.
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Inspecting bitrates It is possible to zoom in on an area of the graph in order to inspect the bit rate
in detail.

To zoom in on the central 50% of the displayed graph, use the Graph > Zoom

> Zoom In menu (or the Toolbar button: ; or tab key). This action can be
repeated.

To zoom in on any area of the bit rate graph, drag the mouse while holding the
left-button, to highlight the area required. When the mouse button is released, the
highlighted area will be enlarged to fill the graph area.

The menu Graph > Zoom > Zoom Out (Toolbar: ; or shift-tab key) will
zoom out one step at a time; a step being the previous zoom in actions.

The menu Graph > Zoom > Show All (Toolbar: ) will redisplay the graph
with no zoom factor applied.

Saving/copying The graph can be saved or copied in text format or as a picture file (JPEG or
bitmap).

Menu Description

Graph > Save Save the graph to a user defined location.

> Bitmap Size the graph window before saving.

> JPEG Size the graph window before saving.

> Table Tab delimited format.

Graph > Copy Copy to clipboard, from where it can be pasted into a suitable
application:

> Image

> Table Tab delimited format.
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Repetition view
Menu bar Toolbar

View > Repetition

This structure view charts the repetition of a set of data broadcast entities. This
Gantt style graph displays a row for each transport entity (for example, BIOP
message, U-N message etc) selected. A colored block on the row indicates the
presence of the message at that point in the transport stream.

NOTE. In calculating repetition rates, Carousel Analyzer returns to the stream
file. For large files, the calculation may take an appreciable amount of time.

Inspecting repetition rates It is possible to zoom in on an area of the graph in order to inspect the repetition
rate in detail.

To zoom in on the central 50% of the displayed graph, use the View > Zoom >
Zoom In menu (or the Toolbar button). This action can be repeated.

To zoom in on any area of the repetition rate graph, drag the mouse while holding
the left-button, to highlight the area required. When the mouse button is released,
the highlighted area will be enlarged to fill the graph area.
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The View > Zoom > Zoom Out menu (Toolbar: or shift-tab key) will zoom
out one step at a time; a step being the previous zoom in actions.
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The View > Zoom > Show All menu (Toolbar: ) will redisplay the graph
with no zoom factor applied.

Tooltips: When the cursor is placed over a block, a tooltip provides the PID,
time, and packet number.

Saving/copying The graph can be saved or copied in text format or as a picture file (JPEG or
bitmap).

Menu Description

Graph > Save Save the graph to a user defined location.

> Bitmap Size the graph window before saving.

> JPEG Size the graph window before saving.

> Table Tab delimited format.

Graph > Copy Copy to clipboard, from where it can be pasted into a suitable
application.

> Image Copy image.

> Table Tab delimited format.
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PID view
Menu bar Toolbar

View > PIDs Toolbar

This static view displays all the active PIDs within the transport stream. A PID
carrying sections will have nested items, which detail the table types on that
PID. The structure, bit rate, and repetition of transport packets and sections are
available from this view.

The following diagram indicates the nodes accessible from the PIDs view.
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Active PIDs node
This node represents all the PIDs found in the current transport stream; the

PIDs are listed as child items.

Right-click menu options

Option Description

View Transport Packet Displays a structure view of the packet at the current stream
position (as indicated by the Transport Packet number displayed
in the Transport Packet Bar).

PID node
Represents all the transport packets with a particular PID. If the PID carries

sections then the PID tree node will have child table tree nodes.

Right-click menu options

Option Description

View Transport Packet Displays a structure view of the next transport packet
encountered on this PID from the current stream position (as
indicated by the Transport Packet number displayed in the
Transport Packet Bar).

View Cycle Time >

View Repetition

Allows Activates or creates a view of the repetition of this PID
in the transport stream. either cycle time statistics or graphical
view to be selected.

View Bitrate Activates or creates a view of the bit rate of this PID.

Table node
This node represents the stream of sections present on a specific PID with a

specific table identity.

Right-click menu options

Option Description

View Section Displays a structure view of the next section with this PID
and table identity that can be formed from the current stream
position onwards (as indicated by the Transport Packet number
displayed in the Transport Packet Bar).

View Cycle Time > Allows either cycle time statistics or graphical view to be
selected.

View Repetition Activates or creates a view of the repetition rate of this PID with
this PID and table identity

View Bitrate Activates or creates a bit rate view of sections with this PID and
table identity.

Signal Carousel (See page 41, Manual signaling.)
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Log view
Menu bar Toolbar

View > Log

The log view is a tabbed window with each tab representing information about a
particular MPEG-2 layer. Each tab contains any miscellaneous information about
the transport stream that has been analyzed. For example, packets that have the
transport_error_bit set will have an entry in the transport log tab.

The diagram below indicates the information that is accessible from the Log view.

Summary This view provides a summary of the transport stream analysis.

Transport Packet Log view
This view displays the errors that have been logged in transport packets

during analysis of the stream.

Right-click menu options

Option Description

View Transport Packet Displays a structure view of the highlighted transport packet.
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Section Log view
This view displays the errors that have been logged in sections during

analysis of the stream.

Right-click menu options

Option Description

View Section Displays a view of the highlighted section.

DSM-CC Section Log view This view displays the errors that have been logged in DSM-CC sections during
analysis of the stream.

Right-click menu options

Option Description

View Section Displays a view of the highlighted DSM-CC section.

U-U Object Carousel This view displays the warnings that have been logged in U-U Object sections
during analysis of the stream.
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Cycle Times view
Cycle times can be calculated for either a carousel (given a starting point) or an
entity in the transport stream.

In the following diagram, a carousel is shown carrying objects A, B and C.

In this example, object B is identified as the starting point for both carousel and
entity cycle timing. The cycle time of a carousel is the time taken to receive all of
the objects within the carousel given a specified starting point in the carousel. The
cycle time of any given entity in the transport stream (including Section, BIOP
Object, PID and U-N Message) is the time taken from the start of an instance to
the start of the next instance.

The cycle times calculated give the maximum, minimum and mean times for the
occurrences of an object in a transport stream in seconds; standard deviation and
number of cycles found will also be displayed. The statistics can also displayed in
graphical format.
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Carousel cycle times
statistics

The cycle time of an object carousel is the time taken for all components of the
carousel to be received starting with a selected component of the carousel.

Selecting one or more BIOP objects from a carousel and View Carousel Cycle
Time from the right-click menu generates the Carousel Cycle Times statistics
window. The information can also be displayed in graphical form by selecting
View Carousel Cycle Time Graph.

In the Carousel Cycle Times window, the BIOP Object column identifies the PID,
Carousel ID and Object that the user identified as a starting point for the test.

The information can also be displayed in graphical form.
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Entity cycle times statistics Similarly, the cycle time of any entity (object) in the transport stream is the time
between the start of an instance of the entity and the start of the next instance.

Selecting one or more entities in any view and View Entity Cycle Time from
the right-click menu generates the Entity Cycle Times statistics window. The
information can also be displayed in graphical form by selecting View Entity
Cycle Time Graph.

The Entity column identifies the PID, Carousel ID and Object that the user
identified as a starting point for the test.

In both Carousel and Entity statistics windows, further cycle time statistics will be
added to the bottom of the list while the window remains active.

Similarly, with one or more entries in a Cycle Times window selected, the
right-click menu allows the user to display a graph of the cycle times or export
cycle time statistics to a text file.
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Application support
Carousel Analyzer provides a means of testing the effects of associating
applications with Object Carousels. An application consists of a "boot class" and
"assets". Typically, a boot class will comprise a Java or HTML class; assets may
be images or text required by the boot class.

A comprehensive range of tests and measurements is provided in addition to
application management tools.

A single Object Carousel may be timed with several applications in the Carousel
Analyzer.

Application management
The Application management dialog shows the applications currently defined and
allows the user to manage them. The user can also create new applications.

When defining an application, it may be done by adding application tree nodes
manually using context menus, or by moving parts of currently available object
carousels over to the application. It is also possible to move over sub-trees from
the hard disk to the application definition.

If an asset is specified as a wildcard, the timing will wait for that asset and all child
assets that are found in the transport stream. This means that a directory can be
specified as a wildcard asset and any content found underneath it in the transport
stream will be treated as an asset, for example, specify \bin\startup.class
as the boot class, and \images\ as a wildcard directory asset. Any content in the
\images\ directory in the carousel will be treated as an asset.
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To open the Applications management dialog, select Edit > Applications. The
following dialog box is displayed:

In the Applications management dialog, the main list displays those applications
that have already been created. Application data is stored locally in the file
C:\Program Files\Tektronix\DataTestSystem\applications.data;
this is the installation directory but it may have been modified by the user. This
data file can be copied to other Carousel Analyzer installations if required.

A summary of the highlighted application is displayed below the list; the user
should enter this summary when the application is created.

The dialog button functions are described as follows:

Option Description

New Allows a new application to be defined in the New Application
Definition dialog box. Keyboard shortcut: Insert.

Copy Creates a copy of the highlighted application. The new
application is allocated a modified name (Copy of).

Edit … Allows the highlighted application to be edited in the Edit
Application Definition dialog box. Shortcut: Double-click
application name.

Rename … Allows the highlighted application to be renamed. Keyboard
shortcut: F2.

Delete Deletes the highlighted application after receiving confirmation
from the user. Keyboard shortcut: Delete.

Auto Create ... Creates an application definition for each MHP application that
is found in the stream. The boot class for each application is
also set up.
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Select OK to close the dialog box. All of the buttons, except New, are disabled
unless an application is highlighted; New is always enabled.

Application definition
Applications are defined using the New Application Definition dialog as shown
in the following illustration:

(Initially the Application panes will be empty except for the root nodes (Boot
Class and Assets).
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The elements of the New Application Definition dialog box are as follows:

Right-click menu options

Option Description

Object Carousels tab: This displays all of the object carousels in the current transport stream. Note that if the current
transport stream carries no object carousels, then none will be displayed here.

The example screenshot below shows the Object Carousels displayed in the New Application
Definition dialog box overlaid onto the standard Object Carousel views.

Name Enter the name of the application.

Description An optional field that allows a brief description of the application to be entered.
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The boot class and the assets are displayed as parts of a tree structure in the lower
pane. The boot class is the object that must be loaded first in an application (an
executable image). Assets are data objects to be used by the Boot Class in the
same carousel (for example, picture files, and text files).

Selecting the OK button closes the dialog box and stores the new application
data. The action will be refused if a boot class object has not been specified. If a
duplicate application name has been entered, it must be renamed.

The boot class must be in the associated carousel; if it is not, the timing test cannot
be performed. An asset is a BIOP object in the carousel that is used by the boot
class. If the asset is not in the associated carousel, the user will be warned that
the assets could not be found and the tests will be performed as if those assets
had not been defined.

Selecting the Cancel button closes the dialog and discards the new application
data.
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Testing an application The Test button at the bottom of the application dialog box allows items in the
application to be tested against the currently selected carousel. This can be used to
ensure that the correct carousel has been selected for the application and that all of
the objects are present. The results of the test are displayed in the Application
Test dialog.

Adding objects to the
application

Objects are moved from the Object Carousel pane to the Boot Class or Asset
panes using the Add Asset button. To do this, highlight the object in the Object
Carousel pane, select Add Asse< , and note that the object is added to the adjacent
application structure.

Making a node that has children an asset will automatically include all the
children as assets. To include every object in a carousel, add the carousel
root node to the application.

The boot class can only contain one object; it may be at any depth in the
directory structure.

Adding an object to the Boot Class will displace any existing object.

Moving assets from the Object Carousel will automatically recreate the
directory structure from the object carousel.

Moving assets from the hard disk directory tree will only recreate the structure
below the source tree node. When moving assets from the directory tree,
highlight a node in the asset tree as a target.

A right-click context menu is available at all nodes in the application structure;
available options will depend on the node type.
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The context menu options operate on the currently highlighted node in the
application structure as follows:

Right-click menu options

Option Description

Add Child Adds a child node. It can be subsequently renamed to indicate
an object.

Rename Allows a node to be renamed.

Delete Deletes the node.

Toggle Wildcard Asset directory nodes can be identified as wildcard entries.
A wildcard directory indicates that the directory and all of its
children at the time of analysis are defined as assets.

Editing an application Application editing is similar to creating a new application.

Application timing
The Application Timing feature allows the user to observe the effect in terms of
download time of one or more applications being timed with an object carousel.

In practice, an object carousel is identified and one or more applications are
selected from the current application list to be timed with it. As each application
is selected, the software will check the availability of the Boot Class and Assets.
If the Boot Class cannot be found, the timing operation will fail. If Assets cannot
be found, the timing tests can still be performed, but they will not represent the
true effect of the application on a particular carousel.

Progress bars are displayed while the tests are being performed.
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The results of the application timing tests are presented in tabular form.

Data displayed in tabular form can be displayed in graphical form or exported
to a tab separated file.

Explanation of timing tests This section gives a graphical explanation of each of the application timing tests.

The calculations assume that control information (DSI/DII; that is, SI/PSI
information, for example, PAT, PMT) has been cached.

The boot class must be received before any of the assets can be received. This
simulates the STB not knowing which carousel objects the boot class depends on
until it has completely received and processed it.

Best transmission time. From the start of a boot class to the end of the last asset.
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The true application load time is the transmission time plus the time taken by the
set-top box (STB) to load the application. The time taken by the STB to load the
application is not included in these tests.

Worst transmission time. From the end of a boot class, through the next boot
class, to the end of the last asset.

The true application load time is the transmission time plus the time taken by the
set-top box (STB) to load the application. The time taken by the STB to load the
application is not included in these tests.
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Cycle time. From the start of a boot class, through the last asset, to the start of
the next boot class.

Best boot time. From the start of a service gateway, through the next boot class,
to the end of the last asset

MTSA-HW and MTSA-PC Carousel Application User Manual 77



Application support

Worst boot time. From the end of a service gateway, through the next service
gateway, through the next boot class, to the end of the last asset.

Cold boot time. Whereas the other timing methods assume that control
information (PAT, PMT, DSM-CC section, etc.) has been cached, this method
does not.

The user defines a sampling frequency, which is timed to start the download and
observe how long it takes to signal the carousel and download the service gateway,
the boot class and all of the assets. For example, in a 60-second stream, a Start
Point (on the Cold Boot Time Settings dialog) of five seconds will sample the
download time twelve times. The result is added to the Application Timing results
table and graph.

The boot class must be received before any of the assets can be received. This
simulates the STB, not knowing which carousel objects the boot class depends
on until it has completely received and processed it.

Directories must be received before any child objects can be received in this case.
This is because this timing method assumes no signaling caching.
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The end of each cycle will be the end of the module containing the last asset. This
is an important distinction because an asset may not be the only one in that module.
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Setting up a timing test It is assumed that applications have been created as described in the previous
section.

1. With the Object Carousel view active, select View > Timing > Application
Timing.

Alternatively, highlight an object carousel and select View Application
Timing from the right-click menu (not shown).
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2. The Timing Application dialog is displayed:

The dialog displays the selected object carousel identity and the applications
that are already defined.

Applications to be associated with the object carousel are selected by enabling
the adjacent checkbox.

Highlighting an application name will display its description and a brief report
on the availability of the boot class and assets. If the boot class is reported as
being not present, the timing operation will be aborted after the first test pass.

Select Applications… to open the Applications management dialog. (See
page 68, Application management.)

On first opening this dialog, a simple test is performed to detect the presence
of the required boot classes. Applications for which the boot class is found
will be enabled.

Subsequently, user selections will be recalled.

Treat Intermediate Directories as Assets: If this checkbox is enabled, all
directories that form part of the asset path are also treated as assets. They
must be downloaded as part of the timing test. This will not usually have
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any significant impact on the results because directories are generally much
smaller and transmitted at a higher frequency than files.

Calculate Cold Boot Time: If this checkbox is enabled, the Cold Boot timing
test will be applied and this may take some time. (See page 78, Cold boot
time.)

NOTE. In MHP mode, if the Cold Boot time is to include the AIT acquisition time,
the Application Timing selection must be made from an MHP application node
(Java or HTML). By selecting an MHP application, the application's AIT will be
automatically included in the Cold Boot timing.

3. Select Go to start the timing tests.

If the Calculate cold boot time checkbox was enabled, the Cold Boot Time
Settings dialog is displayed. Enter the starting point repetition rate required.

Select OK to continue with the tests.

Progress bars will be displayed while the test is being carried out.

4. On completion of the test, the Application Timing results table is displayed.
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The column headings are largely self-explanatory. Number of Cycles shows
the number of times that the test could be calculated for the stream.

5. To display the results in graphical form, highlight a test name and select
Graph… from the right-click menu.

If another test is selected, the results are overlaid. Color coding is used to identify
each result.

The following screenshot shows a graph showing all five test results (Cold Boot
not shown).
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Zoom in and zoom out buttons are provided on the toolbar (or use the tab and
shift-tab keys on the keyboard).

Alternatively a precise area can be selected by dragging the mouse over the
required range (hold the left-button, move the mouse, release the button).

When the mouse button is released, the zoomed area of the graph will be displayed
immediately (as shown below).
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MHP support
Although described separately here, MHP Object Carousel support is fully
integrated into Carousel Analyzer. MHP applications are displayed in the Services
and Object Carousel views. The features described here can be accessed from
menu options and right-click context menus.

The MHP application ( ) is identified by its name in the AIT. If the boot class
is found in the Service Gateway, it is attached as a child of the MHP application.
As a visual aid, boot class items are identified in the Service Gateway by green
triangles overlaying the primary icon. The path in which the boot class resides is
also indicated by green triangles.

Applications are designated as Java ( ) or HTML ( ). The color of the icon
represents the running status of the application when the carousel was recorded;
green indicates running, yellow indicates ready and red indicates not running.

MTSA-HW and MTSA-PC Carousel Application User Manual 85



MHP support

Right-click menu options Right-clicking on an MHP application node will display the following menus:

Option Description

View Application Timing (See page 74, Application timing.)

View AIT Opens the AIT structure view. (See page 52, Structure views.)

View Application Lifetime (See page 87, Application lifetimes.)
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Application lifetimes
This Gantt style graph displays an analysis of the lifetime of an MHP application.
Multiple applications can be displayed; each application is subdivided and
color-coded to indicate the changing state of the application.

The Applications Lifetimes view can be opened by highlighting an MHP
application node and selecting either the toolbar icon or View Application
Lifetime from the right-click menu.

A key to the color codes is displayed at the bottom of the view. Each application
is labeled. Placing the cursor over a color block displays details of the block,
including the block start time.
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Script files
The following scripts in the table below are shared between the Carousel
Analyzer and other Tektronix products. They exist in the C:\Program
Files(x86)\Tektronix\mpeg\MTSA\Apps\Carousel_Analyser\Scripts

directory.

Table 11: Script files - general

Script file name Purpose

MPEG.scp Scripts for MPEG sections and descriptors.

DVB.scp Scripts for DVB sections and descriptors.

ISDB-T.scp Script for ISDB-T sections and descriptors.

ISDB-S.scp Script for ISDB-S sections and descriptors.

MHP.scp Script for AIT table.

MPE.scp Scripts for DVB datagrams.

DSMCCv2.scp General purpose DSMCC structures.

DSMCC.scp Scripts for (DVB) DSM-CC sections.

ISDB_DSMCC.scp ISDB version of the DSM-CC script.

The scripts in the following table are used only by the
Carousel Analyzer. They exist in the C:\Program

Files(x86)\Tektronix\mpeg\MTSA\Apps\Carousel_Analyser\Scripts

directory.

Table 12: Script files - Carousel Analyzer

Script file name Purpose

Transport.scp Script for transport packets.

Pat_Cat.scp Script for PAT and CAT sections.

Biop.scp Scripts for BIOP messages.

DSMCC_DataCarouselObject.scp Script for DSM-CC objects, which relate a
Data Carousel.

DSMCC_DataCarouselSection.scp Script for DSM-CC sections, which relate a
Data Carousel.

DSMCC_ObjectCarouselObject.scp Script for DSM-CC objects, which relate an
Object Carousel.

DSMCC_ObjectCarouselSection.scp Script for DSM-CC sections, which relate an
Object Carousel.

DSMCC_Object Script for DSM-CC objects, whose content is
not assumed to be either data or objects.
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Error checking
DSM-CC sections have two bit fields called section_syntax_indicator and
private_indicator (Ref 13818-6 section 9.2.2). If the section_syntax_indicator
field is 1, there is a CRC32 at the end of the section; if set to 0, there is a checksum
at the end of the section. The private_data field should always be the complement
of the section_syntax_indicator field.

If both these fields are set to the same value, the application cannot be absolutely
sure whether a CRC or a checksum is being used. It therefore attempts to use the
CRC method first and then the checksum. If neither method works, the section is
rejected.

Currently nothing will be reported in the error logs if these bits are set incorrectly.
This issue will be addressed in a future release of Carousel Analyzer.
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[1] ISO/IEC 13818-1 Information technology - Generic coding of moving pictures
and associated audio information: Systems [MPEG]

[2] ISO/IEC 13818-6 Information technology - Generic coding of moving pictures
and associated audio information - Part 6: Extension for Digital Storage Media
Command and Control [MPEG]

[3] ETS 300 468 Digital broadcasting systems for television, sound and data
services; Specification of Service Information in Digital Video Broadcasting
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[4] EN 301 192 Specification for data broadcasting [DVB]

[5] A027 Specification for the transmission of data services in DVB bitstreams
[DVB]

[6] A047 Implementation guidelines for Data Broadcasting [DVB]

[7] SI-DAT 382 Rev.4 Implementation guidelines for data broadcasting [DVB]
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Carousel Generator – Getting started
The Carousel Generator is aimed principally at the content provider user who
simply wants to create a carousel to deliver content to a set-top box quickly
and efficiently. The product also aims to support the more experienced MPEG
user who wants to modify a carousel to test the effects on equipment along the
broadcast chain. Similarly, the more experienced MPEG user can incorporate a
carousel into a transport stream alongside video and audio content.

The assembled transport stream can be saved to an MPEG file.

Data Broadcasting overview
Data Broadcasting allows data to be transmitted in a similar way to the way in
which video and audio services are delivered to end users. Object and Data
Carousels are intended for the periodic transmission of information in a transport
stream. Data Carousels contain modules of data of unspecified content, whereas
Object Carousels contain identifiable data objects, such as JPEG files, text files
and, application software. Multimedia Home Platform (MHP) builds on object
carousels by defining parameters such as the boot class and application life cycle
in the Application Information Table (AIT).

The diagram below shows how information carried by data and object carousels is
subdivided and ultimately carried by the transport stream.
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BIOP messages contain a message header, a message sub-header and the message
body, which contains data. The message body may contain complete data objects.

BIOP messages are broadcast in modules. A module is formed from one or more
concatenated, complete BIOP messages.

Each Module is fragmented into one or more Download Data Blocks that are in
turn transmitted in corresponding DSM-CC Sections.

Sections are transmitted in packets in the Transport Stream.

Carousel Generator overview
Activity in the Carousel Generator is referred to as a "session". During a session,
data objects are assembled into one or more carousels. Video and audio content
can also be added. Mandatory SI tables are added automatically. The structure of
the carousel can be saved in XML format; this definition file can be subsequently
reopened in a new session for further edits.

The end result of a session is the creation of a transport stream, which can be
saved to a file.

One of the main advantages of Carousel Generator is that many of the more
complex concepts in the various Object Carousel standards are hidden from the
user for the sake of clarity and user friendliness.

Three views of the assembled stream are offered: Carousels, Collections and
Programs. Each view displays aspects of the stream from a single perspective.
The three following screenshots show the same stream in each of the views.
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Carousels view The Carousels view lists the carousels and the associated objects that are included
in the session.

Carousel types. The supported carousel types are as follows: Object Carousels:
DSMCC, DVB, DTT, MHP

Object carousels Reference specification

DSM-CC Digital Storage Media - Command and Control (MPEG only)

DVB Digital Video Broadcast

DTT Digital Terrestrial Television

MHP Multimedia Home Platform

The type of carousel being edited dictates the available options and user interface
elements.

MTSA-HW and MTSA-PC Carousel Application User Manual 93



Carousel Generator – Getting started

Collections view Objects associated with a carousel can be grouped together in collections. The
properties of each collection can be adjusted to give the most efficient delivery
in the transport stream.

The way that individual objects in a carousel are to be transmitted often varies.
Each object in the carousel has properties including its minimum repetition rate
(maximum cycle time) and whether it is compressed. Files that need to be
transmitted with similar properties or which are logically related can be grouped
into a module. As the DSMCC module is a limited size, the process of adding an
object to a module would require calculating whether the object would fit into the
module's available space (possibly after compression) and if no space is available,
generating a new module and feeding this back to the user. This would slow this
aspect of the user interface down appreciably.

Consequently, the concept of a collection is used to replace the size-limited
DSMCC module, with a "module of unlimited size". Any number of objects can
be added to a collection; during stream generation, this may translate to many
modules with the same properties.
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Programs view In the Program view, the root is the Carousel Session (as in the other views).
Immediately below this are nodes giving access to the supported (mandatory)
SI/PSI tables and a listing of PCR PIDs. There is also an Elementary Streams
node, which lists all of the imported elementary streams included in the stream
and the Program nodes, which show the allocation of carousels and elementary
streams to programs.

Carousel definition file The current state of the Carousel Generator session can be saved to disk at any
time during the creation process, using the carousel definition file. The format
of the saved file is standard XML and can be viewed in any XML compatible
viewer (for example, Internet Explorer 5 and up); editing the XML file directly is
not recommended.
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Starting the application
The application can be started by selecting Start > Tektronix MTSA and
choosing the Carousel Generator application, or by double-clicking the
Generators folder on your desktop and opening Carousel Generator.
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In addition, files with an XML extension have an additional in the right-click
menu ( Open with Carousel Generator ). When this is selected, Carousel
Generator opens and attempts to use the file as a Carousel Definition File. (See
page 166, Carousel definition file.)
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Initial appearance

The full range of options available to the Carousel Generator can be accessed by
using the Menu Bar. However, the selection of options varies during the stages
of carousel creation; unavailable options are normally grayed out. The Toolbar
provides shortcuts to the more common options. The bottom section of the
Carousel Generator is the Summary section.

The working area of the Carousel Generator screen contains three windows:
the Session window, the Properties window and the Log window. The Session
window and the Summary section can each be either floated (moved to anywhere
on the desktop) or docked to one of the four sides of the application window. The
content of the Properties window is context-sensitive; it will provide a summary
of the properties of the node highlighted in the Session window.

A full description of the Carousel Generator screen components can be found in
the Menus and Controls. (See page 114, Menus and controls.)

Session window. The Session window is the workspace in which carousels and
collections are built and manipulated
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The window has three tabs: Carousels, Collections and Programs. Each window
displays different aspects of the current session in the form of a tree structure.

Tab Description

Carousel Tab The Carousels Session window displays all of the carousels in the current
session and the directories and files associated with each carousel. It is in
this window that carousels are built and manipulated.

Collections Tab The Collections Session window displays the collections associated with
each carousel and the allocation of files and directories within them.

Programs Tab The Program session window displays the contents of the stream from the
program or service point of view.

Properties window. The Properties window provides an immediate view of the
parameters and values associated with each node in the Carousels and Collections
Session windows

The values displayed are those of the currently selected node.

Log window. The Log window displays errors and warnings as the carousel
building and stream generation progresses

A full description of the Carousel Generator screen components can be found in
the Menus and controls. (See page 114, Menus and controls.)

MTSA-HW and MTSA-PC Carousel Application User Manual 99



Carousel Wizard

Carousel Wizard
The Carousel Wizard makes the process of creating a single carousel easier. The
carousel is added to the current session. The final step of the wizard allows a
transport stream to be created using the information in the current session.

Default parameters are provided at all stages of the wizard, but the user can
change them either in the wizard screens or subsequently in the various property
dialog boxes.

The description in this section provides an overview of the wizard and carousel
creation. Individual properties and activities are described in more detail in the
Reference section. Extensive tooltips are provided with the wizard screens. Place
the cursor over any element of a screen to reveal the tooltip.

If a carousel session is in progress, the user must decide whether a new session is
required or a new carousel is to be added to an existing session.

To start a new carousel session, select File > New Carousel Session.

Any open carousel session will be closed with an to save.
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The following screen is displayed:

For a new session or adding a carousel to an existing session, the wizard can
now be invoked.
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Step 1: Select carousel
1. In the work area select Carousel Wizard or select Session > Carousel

Wizard.

Step 1: Select Carousel of the Carousel Wizard is displayed.

2. Highlight the required Carousel type.

Note that depending on the type selected, some of the subsequent wizard
screens will vary in content. The content is dictated by the carousel type
selected.

3. Select Next to display Step 2: Carousel Properties.

102 MTSA-HW and MTSA-PC Carousel Application User Manual



Carousel Wizard

Step 2: Carousel properties

In Step 2, the Carousel Properties are selected. Defaults are supplied but all
properties can be edited. Properties can also be edited after the carousel has been
created from the main window.

4. Make any required adjustments to the Carousel properties.

5. Select how many times the carousel should appear in the output stream.

NOTE. When using the wizard, only a single carousel is being assembled.
However, more than one carousel may be created within a session.

The number of repetitions can be specified for each carousel. The length of the
transport stream will be dictated by the carousel that requires the longest time by
virtue of its size or the number of requested repetitions. Carousels in the same
session requiring less time to fulfill their size/repetition criteria will be repeated.

6. Select Next to displayStep 3: Carousel Contents.
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Step 3: Carousel contents

Files and directories containing applications and resources are added to the
carousel during this step.

The buttons on the right side of the window allow individual files or complete
directory structures to be added to highlighted nodes of the carousel. Files and
directories can also be dragged and dropped from Windows Explorer.

Add files: Add directories:

Files and directories can be dragged and dropped within the wizard window,
to allow final adjustments to be made.

Highlighted files and directories can be also be deleted .
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7. Build the carousel structure as required.

Highlighting an object and selecting Properties from the right-click menu
allows access to the object properties.

8. Select Next to display Step 4: Collection Contents.
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Step 4: Collection contents

The files added in the previous step are automatically placed in a single default
Collection (as shown above). Collections allow objects to share transmission
properties including minimum repetition rate (maximum cycle time) and
compression. This step allows the user to change the properties of the default
Collection, create new Collections, and move files between the various collections.
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To modify the collection properties, highlight the required Collection node and
select Properties from the right-click menu.

9. Select to create a new collection header.
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10. Highlight a collection node and select to modify the collection's
properties.

NOTE. If the previous wizard step is reselected (Back) and more files added or
removed, the Collection assignment is maintained for existing files and new files
are placed in the parent directory's collection by default.

To modify the collection properties, highlight the required Collection node
and select Properties from the right-click menu.

11. Select Next to display Step 5: Imported Elementary Streams.
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Step 5: Imported elementary streams
In addition to the carousel objects, elementary streams from a transport stream
can be included in the session.

To modify the collection properties, highlight the required Collection node and
select Properties from the right-click menu.

12. Use the Source File: button to identify and select the transport stream.

The contents of the source file are displayed.
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13. Select one or more elements from this tree to import into the current session,
or select a program node to import every element contained by the program.

NOTE. Elements only from the same source program can be selected. All elements
included in the session will be included in the output stream, whether they are
referenced by a program or not.

Where possible, elementary streams will be carried on the same PID used in the
source stream; where a conflict within the session occurs, a new PID will be
automatically allocated or can be allocated manually.

14. Having identified the source stream and the individual elementary streams to
be included in the session, select Next to display Step 6: Program Entry.
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Step 6: Program entry
At this step, a new entry will be created in the PMT referencing this carousel.
Also, the elementary streams identified in the previous steps can be associated
with a new program.

15. Select the elementary streams to be included in the new program.

16. Select Next to display Step 7: Output Stream Properties.
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Step 7: Output stream properties

Use this screen to specify the name and properties of the transport stream that is
to be created.

17. Enter the TS Bitrate.

18. Enter minimum duration for the output transport stream if required.

19. Enter or select ( ) an Output File name.

20. Select Next to displayStep 8: Congratulations.
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Step 8: Congratulations

The carousel is now prepared. If the to create the transport stream is enabled, then
all carousels in the current session will be included. The carousel created with the
wizard will be added to the session screen.

21. Select Finish to exit the wizard.
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Menus and controls
The following pages contain descriptions of different menu options, toolbar
controls, status bar, log window, and properties window.

Menus options
The following pages describe all of the menu options. Since many of the options
are context sensitive, they will be available only when their function is appropriate
for the selected window or display element. When a menu is not available, the
is grayed out.

File menu options Table 13: File menu options

Option Function

New Carousel Session Opens a new carousel session. An opportunity to save the
current session is offered, if relevant.

Open Carousel
Session…

Opens an existing carousel session using a saved carousel
definition file.

Save Carousel Session Saves the current carousel session in the form of a carousel
definition file. If the file has not been saved, an opportunity is
offered to name it.

Save Carousel Session
As…

Allows the current carousel session to be named and saved in
the form of a carousel definition file.

Most Recently Used List Lists the most recently used carousel session files. Click on a
file name to reopen it. The number of files displayed is set in the
Carousel Generator Options dialog box ( Tools > Options ).

Exit Closes the application. An opportunity is offered to save the
session if it has not been saved.
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Edit menu options Table 14: Edit menu options

Option Function

Cut Cuts the currently highlighted item. The item is stored on the
Windows clipboard.

Copy Copies the currently highlighted item. The item is stored on the
Windows clipboard.

Paste Paste the item currently on the Windows clipboard.

Empty Carousel (Carousel contents node highlighted.) Deletes the carousel
contents.

Delete Collections (Collection node highlighted.) Deletes the selected collection
(The Collection must be empty; the contents must be moved to
another collection first).

Delete Program (Program node highlighted.) Deletes the selected program and
the carousel(s) it contains.

View menu options Table 15: View menu options

Option Function

MHP Applications List MHP applications where they are included in a session.

Carousels; Log;
Generator Toolbar;
Player Toolbar; Status
Bar

Allows the screen elements listed to be shown or hidden.
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Session menu options Table 16: Session menu options

Option Function

New Program… (Program view.) Adds a new program node.

Import Elementary
Stream(s)…

(Program view.) Allows elementary streams to be added to the
Elementary Streams node.

New Carousel (Carousel view or Program node.) Allows a new carousel type
to be created.

Carousel Wizard Opens the Carousel Wizard which takes the user through
carousel and stream generation step-by-step.

Carousel Properties… Opens the Carousel Properties dialog box.

Facilitates the file activities listed below (the menu content is
context sensitive):

Contents

Empty Carousel Empty currently highlighted carousel.

Delete Object Deletes currently highlighted object (and
dependant objects).

Add File(s)… Adds one or more files to the selected carousel.

Add Directory… Adds a directory to the selected carousel.

New Directory… Creates a new directory at the selected node.

Move to Collection Moves the selected objects to another
collection.

HTML Application commands Makes, Removes, and Edits
HTML applications.

Java Application commands Makes, Removes, and Edits Java
applications.

These HTML and Java Application commands are only
applicable to file objects (when a file is selected).

Synchronize Synchronizes the carousel contents with the source files.

Delete Carousel Deletes the selected carousel.

Delete All Carousels Deletes all carousels in the current session.

Player menu options Table 17: Player menu options

Option Function

Stream Generation
Properties…

Opens the Stream Generation Properties dialog box.

Start Playout Initiates output stream generation using information in the
current session.

Stop Playout Stops output generation.

View Packets/Time Switches between packet count and time display during playout.
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Tools menu options Table 18: Tools menu options

Option Function

Launch Multiplexer Opens the Multiplexer application.

Launch Carousel
Analyzer

Opens the Carousel Analyzer application.

Launch TS Analyzer Opens the Transport Stream Analyzer application.

Options… Opens the Carousel Generator options dialog box. This is used
to set the basic Carousel Generator and session defaults.

Help menu options Table 19: Help menu options

Option Function

Quick Help Opens an HTML help page containing summarized help
information.

User Guide Opens the Carousel Generator User Guide in Adobe Acrobat™
(PDF) format.

About Carousel
Generator…

Displays information about Carousel Generator, including
Software Version and Serial Number. This information will be
required if Tektronix support is required.
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Toolbars
Two toolbars can be displayed: Generator and Player. The toolbars can be shown
or hidden using the View menu or by right-clicking in the toolbar area.

Toolbars provide a set of convenient shortcuts for the more frequently used menu
options. The buttons are context-sensitive and are enabled or disabled dependent
upon the currently highlighted view or the action being performed.

Generator toolbar

Table 20: Generator toolbar icons

Icon Function Equivalent Menu Bar Command

Carousel wizard Session > Carousel Wizard
(Ctrl+W)

New carousel session File > New Carousel Session
(Ctrl+N)

Open carousel session File > Open Carousel Session
(Ctrl+O)

Save carousel session File > Save Carousel Session
(Ctrl+S)

Toggle workspace view View > Carousels

Add directory Session > Contents > Add
Directory…

Add files Session > Contents > Add Files…

New collection (Right-click on Collection node) >
New Collection

Insert program Session > New Program…

Synchronize carousel Session > Synchronise…

Launch Carousel Analyzer Tools > Launch Carousel Analyzer

Launch Multiplexer Tools > Launch Multiplexer

Launch Transport Stream Analyzer Tools > Launch TS Analyzer
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Player toolbar

Table 21: Player toolbar icons

Icon Function Equivalent Menu Bar Command

Playout Carousel Player > Start Playout

Stop playout Player > Stop Playout

Toggle Packet/Time display

Player > View Packets/Time

Toolbars can be dragged off the edge of the main window into a floating pallet. To
do this, place the mouse pointer on the background inside the Toolbar, (not on
one of the buttons), hold the left button down, and drag the toolbar into the main
window area. The result is a self-contained window that looks like this:

To replace the Toolbar on the window border, drag it over the border until the
outline changes shape. It can be placed on the top, bottom, left or right edge.

The Toolbar may be hidden from view - View > Toolbar.
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Icons. The icons in Session windows are used to provide the user with a graphical
indication of status. Icons incorporating an arrow indicate a shortcut function; for
example, elementary streams displayed in a Program node in the Programs view
indicate a shortcut to the elementary stream in the Elementary Streams node.

Table 22: Session icons

Icon Function

Collections node

Collection node containing the Service Gateway.

At least one collection must exist during any session. The collection
containing the Service Gateway cannot be deleted.

Ordinary collection node.

Not containing Service Gateway.

Compressed collection.

Directory object Included in Carousel; Included in Synchronization.

Directory object Included in Carousel; Not included in Synchronization.

Directory object Not included in Carousel; Included in Synchronization.

Directory object shared.

File object Included in Carousel.

File object Not included in Carousel.

PCR node

DVB SI / MPEG PSI

Table node

Transport Stream node

Program node

Carousel object

Elementary Stream - Audio

Elementary Stream - Video

Elementary Stream - Private data
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Log window
The Log Window contains three tabbed views:

The Summary log records information on the general activities in the
Carousel Generator.

The Definition File Syntax log records information on activities concerning
the definition file.

The TS Generation log records information during stream generation
activities.

During file loading and saving and the generation of transport streams, error
messages are routed to the appropriate Log window tab. More information about
each error can be accessed by clicking on the error entry or selecting the Details
… from the right-click menu.

The following icons are used to indicate the severity of the error:

(Blue)
Event Event Indicates normal processing

activity.

(Gray)
Warning Warning Indicates that information

was not available or was invalid.
The operation will often be
completed.

(Yellow)
Error Error Indicates that a sub-operation

could not be completed; the overall
task may still be completed.

(Red)
Fatal Fatal Indicates that a fatal error

has occurred; an activity has failed
to reach completion.

A right-click menu allows the user to clear the displayed log or all logs.
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Status bar
The Status Bar displays tooltips when the mouse pointer is over active elements of
the window, for example, toolbar buttons and menu options.

Properties window (list control)
In properties windows that display lists (for example, contents lists), one column
can be selected to sort the list into ascending or descending order.

To sort a list, click the key column header. If the same column needs to be sorted
in reverse order, click the header again; note that the arrow icon in the header bar
indications the sort direction.
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Carousel generation
This section describes the processes required to create a transport stream
containing one or more carousels. In broad terms it echoes the steps outlined in
the Wizard, but more background information is provided.

Setting overall Carousel Generator properties
Although not essential during every session, the general properties of the Carousel
Generator can be set using the Carousel Generator Options dialog box. Note that
settings such as the Output Filename can be overridden in the current session;
however, the settings made here will be used as the defaults in any new session.

Select Tools > Options… to open the Carousel Generator Options dialog box.

Carousel Generator
options

The following screens are available in this dialog box: General, New Session
Defaults and Event / Error messages. To view a screen, click the name in the
left panel.

General screen
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Item Description

Number of items… A list of the most recently used carousel definition files is
displayed in the File menu. Use this parameter to select how
many file names should be displayed. Range: 0 to 15

Relative Paths The paths of source components associated with a carousel file
can be stored in relative or absolute format.

Update base path… When a carousel definition is saved to a different (new) location,
components stored with paths relative to the original carousel
definition may no longer be found at the same (relative) location.
If Yes is selected from the dropdown list, the base path will be
modified so that the components can still be found. Select Ask
to allow the user to make a decision when the carousel definition
is saved. If No is selected, no modification will be made to the
base path; carousel components may no longer be accessible to
the definition file.

Fix relative paths… When the base path for components referenced by a carousel
definition file is changed, the existing relative paths may not refer
to the correct locations. If Yes is selected from the dropdown list,
the relative paths will be adjusted so that they are referenced
correctly to the new base path.

Regenerate… When enabled, launching Carousel Analyzer, Transport Analyzer
or Multiplexer causes the output stream to be regenerated using
the current session properties. This ensures that the properties
that have been entered in the Carousel Generator are the same
as those shown in the Carousel Analyzer, Transport Analyzer
or Multiplexer.

Show message… When enabled, a message will be displayed during stream
generation if an error occurs which causes the stream generation
to terminate. The error will always be reported in the TS
Generation tab of the Log window.
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New Session Defaults
screen

This screen provides default values to be used for all new sessions and
consequently in the carousel definition files and generated transport streams. The
default values can originate from a template or be set individually. The values can
be overridden in individual carousel sessions.

Item Description

Startup Template Select this and identify a file to be used as a
startup template.

Any carousel session file (XML format) can
be used as a template. It can be used
primarily to retain settings which are required
from session to session, for example,
network settings.
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Startup settings. Select the Use the following settings ... to set the session
defaults locally.

Item Description

TS Bitrate The bit rate of the output transport stream. Range: 0.25 Mbit/s
to 90 Mbit/s

Duration The duration value (in seconds) available when this feature is
enabled will dictate the minimum length of the transport stream.

PSI/SI Type This selection will dictate the tables that are automatically
created at startup.

If MPEG PSI is selected, only the PAT and PMT will be
generated. If DVB SI is selected, the mandatory DVB tables
(NIT actual, TDT, SDT actual and EIT P/F actual) will also be
generated.

Select the Warn before… checkbox to display a message when
a change to the Stream Generation PSI/SI Type property is
attempted. (See page 129, Stream Generation Properties
screen.)

Output Settings

Output File Enter the filename to be used in generating an output transport
stream or browse to find an existing filename.

Automatically set the default values…

If at the start of a session (with no carousels defined), changes are made to the
Stream Generation Properties, whether or not the changes are saved as Carousel
Generator defaults is dictated by this setting. (See page 129, Stream Generation
Properties screen.) The options operate as follows:

Ask: The dialog box shown below will allow the user to choose between using
the revised settings as future defaults or to only use them for this session.

If the Always use… checkbox in the dialog box is enabled, the Automatically
set… in this screen will be reset to concur.

No: The revised settings will not be used as future defaults.

Yes: The revised settings will be used as future defaults.
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Event/Error messages
screen

The Log view, which can be displayed as part of the main application, displays
a series of status and error messages, which advise the user of the progress of
carousel and stream generation.

This screen allows the user to indicate which messages should be displayed. The
Log view contains three tabbed screens: Summary, Definition File Syntax and
TS Generation. These correspond to the message categories Summary messages,
Definition File errors and TS Generation errors in this screen.

Each message category contains four levels of severity: Events, Warnings, Errors
and Fatal Errors. Individual messages that can be displayed in the Log view
are listed at each level.

Message selection. The checkmarks associated with each message icon indicate
the reporting status of the message.

Icon Description

Enabled (permanent): this message type will always be reported in the
log view.

Enabled / disabled (toggle): this message type is enabled/disabled by the
user. It will only be reported in the log view when enabled.

If one or more of the subsidiary message types in a category (Events,
Warnings Errors) is disabled, this icon is displayed.

If one or more of the subsidiary message types in a category (Events, Warnings
Errors) is disabled, this icon is displayed.

MTSA-HW and MTSA-PC Carousel Application User Manual 127



Carousel generation

All messages in the Summary category and Fatal Error messages in all categories
are all permanently enabled; they cannot be disabled. The remaining messages in
the Carousel Definition File and Stream Generation categories can be enabled and
disabled as required by clicking on the message icon.

A brief description of a message can be displayed by clicking on the message
name. (See page 121, Log window.)

Creating a session
A session in Carousel Generator is the activity during which objects are assembled
in one or more carousels with a transport stream being the end result.

The initial activity when starting a session is to note the defaults that are already
displayed in the Stream Generation Properties screen; these are derived from
the Carousel Generator Options. If required, the values can be modified for the
current session.

The values may be changed at any time in the session; it may be useful to review
these settings at the end of a session, before the transport stream is created.

Select Player > Stream Generation Properties to open the Stream Generation
Properties dialog box or select Edit in the properties window or double-click in
the properties window.
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Stream Generation
Properties screen

This screen provides stream generation values to be used in the current session.

Item Description

TS Bitrate The bit rate of the output transport stream. Range: 0.25 Mbit/s
to 90 Mbit/s.

PSI/SI Type This selection will dictate the tables that are created in the
generated stream. If MPEG PSI is selected, only the PAT and
PMT will be present. If DVB SI is selected, the mandatory DVB
tables (NIT actual, TDT, SDT actual, and EIT p/f actual) will also
be generated.

A warning may be issued noting that SI settings may be lost.
(See page 125, New Session Defaults screen.)

Output File: Enter the name and path of the output file. Select to specify a
location on local or network drives.

Relative Paths in
Session…

The paths of source components associated with a carousel file
can be stored in relative or absolute format.
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Item Description

Allow relative paths
based on

When enabled, Carousel Generator will interpret all incomplete
paths as being relative to the base path specified in the adjacent
text box.

The specified base path can be an absolute path (such as
c:\data) or it can be relative to the current location of the
carousel definition file. Note that if ‘.' is entered in the box,
all relative paths are referenced to the current location of the
carousel definition file.

Any automatically created paths will also be made relative to the
base path, if possible.

If the checkbox is cleared (disabled), only absolute paths will
be used.

Update all existing… When enabled, Carousel Generator will attempt to convert all
paths used in the session to be relative to the specified base
path (where possible).

If the checkbox is cleared (disabled), existing absolute paths
will be left unchanged.

Selecting the carousel type
There are a number of carousel types available from the various standards
authorities. Carousel Generator makes available the types listed in the following
table:

Carousel type Guiding standard

DSMCC Object ISO/IEC 13818-6: 1998 (MPEG)

DVB Object DVB EN301 192 V1.2.1

DTT Object DTG DTT Requirements for Interoperability
V3.1

MHP Object ETSI TS101 812 V1.1.2 & V1.1.1

Select Session > New Carousel and click on the required carousel type. A new
(empty) carousel of the required type will be added to the session. The carousel
will be assigned an identity number (ID) and allocated to a PID automatically.

Additional carousels can be added; successive IDs and PIDs will be allocated.
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Modifying the carousel properties
The properties of individual carousel can be modified as required. A summary of
the carousel properties is displayed in the Properties window.

The contents of the carousel are displayed when the Carousel Contents node is
highlighted.

To edit individual carousel properties, in the Carousels tab of the Sessions window
and with the carousel node highlighted, select Session > Carousel Properties
or select Edit in the Properties window. The Carousel Properties dialog box
is displayed.

The number of screens available in the Carousel Properties dialog box is dependent
on the carousel type selected. In the following notes, screens dedicated to only a
single carousel type are identified; all other screens are common to all types.

The Carousel Properties dialog box can display up to four screens: General PID
settings, DSI/DII settings, DTT Applications (DTT only), and MHP (MHP only).
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General screen

Item Description

Carousel ID Unique carousel identity. The Carousel ID is normally generated
automatically but can be changed by the user.

Range: 0 to 4294967295

Maximum module size The maximum size of the modules used to carry the carousel
objects. During output stream generation, if a module has one
or more objects and does not have enough space for the next
object, a new module will be created. If a module is empty and
the object added will exceed the maximum size, the object is still
added, but no more objects will be placed in that module.

Range: 0 to 4294967295 Default: 65536

Carousel PID (DSI PID) Select the required Association Tag from the dropdown list.
During carousel creation, a default Association is generated to
carry the Carousel/DSI PID. This cannot be removed.

Include in Output… This flag allows the carousel to be included in or excluded from
the output stream. If the checkbox is disabled, no reference to
this carousel or its contents will appear in the generated output
stream.

Minimum number… Enter the minimum number of times that the carousel is to
appear in the output stream; this can be repeated for each
carousel in the session. The resulting output stream will be
long enough to accommodate at least the minimum number of
repetitions requested for each carousel.
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PID Settings screen The tree structure in the PID Settings screen shows the PID usage for the selected
carousel's program. The DSI and DII messages carried in the carousel use an
Association tag, which allows the BIOP messages in the carousel to be linked to
a PID in the stream (see "BS ISO/IEC 13818-6:1998 Information Technology
- Generic coding of moving pictures and associated audio information - Part
6: Extensions for DSM-CC).

To place the DII and DSI messages on different Association Tags, use the DSI/DII
settings screen. (See page 135, DSI/DII settings screen.)

During stream generation, each Association Tag specified will result in the
following:

An elementary stream (ES) with a stream type of 11 (DSMCC U-N messages)
and the entered PID being added to the PMT ES loop.

The Association Tag value will be inserted into an association_tag_descriptor
inside this ES's descriptor loop.

Highlighting any of the association nodes will display the PID associations in the
Selected PID association panel.

Select New Assoc to create a new association node in the tree. The PID and
Association Tag will be automatically allocated, but they can be changed in the
Selected PID association panel.
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Selected PID association Item Description

PID This is the PID of the elementary stream (ES) carrying the DII
and/or DSI messages. . (See page 134, PID values.)

Range: 0 to 8191

Association Tag This is the 16 bit value carried in the association_tag_descriptor
which is inserted in the ES descriptor loop of the PMT signaling
this carousel.

Range: 0 to 65535

Maximum bitrate… This is the maximum bit rate allocated in the stream for this PID.
If there is not enough bandwidth to support this rate, the actual
bit rate will be less.

Range: 0.25 Mbit/s to 90 Mbit/s

PID values. As stated, the valid range for PIDs is 0 to 8191

However, there are a number of restrictions on the actual values that can be used,
since some are reserved or may be used in other carousels. The following table
shows the elements that can and cannot share PID values. Unless otherwise noted,
"No" indicates the entities in the row and column headers may not share a PID
value in any carousel in a single session. 'Yes' indicates that the PID value may
be shared with other entities in the same session; unless otherwise indicated in
the Notes below.

Reserved PCR PMT AIT DSI DII

DII No No No No Yes (Same as
Carousel)

Yes (Same as
Carousel)

DSI No No No No No -

AIT No No No No - -

PMT No No Yes - - -

PCR No No - - - -

Reserved No The Reserved PIDs are PIDs 0 to 31 (0x00 to 0x1F) and the Null PID 8191 (0x1FFF)

NOTE. PIDs 0 to 15 (0x0000 to 0x000F) are reserved by MPEG; PIDs 16 to 31
(0x0010-0x001F) are additionally reserved by DVB.

PMTs cannot share PIDs with anything but other PMTs. Multiple PMT sections
can be on the same PID, so, if required, every carousel could have its PMT entry
on the same PID (usually not done that way, but it can be).

The DIIs belonging to a single carousel can be on the same PID as its DSI or its
other DIIs, but not on the same PID as DSIs or DIIs belonging to other carousels.
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For example, the yes/no indicators in the PMT row/column indicate that the value
of the PID carrying a PMT may not be shared with any other entities in the
session. However, in the case of the PMT, see the above note.

DSI/DII settings screen The tree structure in the DSI/DII Settings screen shows the DSI and DIIs that
will be generated in the stream for the selected carousel. Each DSI/DII has an
Association Tag and a cycle time, and DIIs have a user definable name.

Highlighting any of the DII nodes will display the PID associations in the
Selected DII panel.

Select New DII to create a new DII using default values. The default Association
Tag to use is decided by first checking if an existing DII uses the DSI tag. If so,
this tag is used, otherwise the tag of the first DII in the list is used.
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Selected DII Item Description

Name This is a user allocated name for this DII. The name does not
appear anywhere in the generated stream, only within the
Carousel Generator.

Assoc. tag This is the list of all the currently defined Association tags
listed for this carousel. Assigning a different Association Tag to
the DII effectively changes the PID that the DII messages will
be carried on. (Association tags can be added from the PID
Settings screen.)

Cycle time (ms) This sets the time taken for this DII to be repeated. For example,
DIIs referencing boot classes may be given shorter cycle times
to speed up the boot process.

Range: 1 ms to 3600 s.

To associate a collection with a DII, first create the DII, giving it a meaningful
name, set the Association tag and Cycle time of the DII and close this dialog box.
On the Collections tab of the Session window, edit the collection's properties to
set the field Using DII to the new DII.

MHP
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Item Description

AIT PID This is the PID that carries the Application Information Table
(AIT).

(See page 134, PID values.)

Range: 0 to 8191

AIT cycle time Set the time to be taken for the selected Carousel's AIT to be
repeated.

Default: 100 ms.

Use… Select this to allow the AIT cycle time to be set manually.

Range: 1 ms to 3600 s.

Use old-style… If this box is checked, the DVB-HTML application descriptor
format as defined by MHP v1.0.0 (see MHP; ETSI 101812,
Version 1.1.2 and 1.1.1) will be used.

If this box is not checked, the new format as defined in MHP
v1.1.2 (see MHP; ETSI 101812, Version 1.1.2 and 1.1.1) will be
used. This will cause the DVB-HTML Application Descriptor
to be properly formed and include an empty set of application
IDs. To add application IDs to this descriptor, use the HTML
Properties page on the MHP File Properties dialog box.

DTT applications
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Application codes. The entries in this list will be added to the
data_broadcast_id_descriptor in the elementary stream descriptor loop of the PMT

This descriptor lists the application types that can be booted from the elementary
stream with which it is associated. The Boot Priority Hint is an indication of the
application that should be booted in the case of more than one in the list being
supported. The application with the highest Boot Priority Hint, in the range 0 to
255, will be booted first.

Item Description

Add Displays the Add Application Code dialog box.

Remove Removes the highlighted Application Code.

Initial objects. The Initial Object list allows different languages to have
different boot objects. On stream generation, entries here will appear in the
ServiceContextList part of the Service Gateway object.

Item Description

Add Displays the Add Initial Object dialog box.

The Application Code should correspond to a code that is
already listed in the Application Codes panel. A Language
Code can be selected from the dropdown list. The object can
be given a name in the Carousel Object field. If objects have
already been associated with the carousel, the adjacent button
will display the contents of the carousel, from which an object
can be selected.

Remove Removes the highlighted Initial Object.
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Carousel contents
Each carousel initially contains two subnodes: Carousel Contents and Service
Gateway. The carousel will eventually contain all of the objects associated with
a particular function or feature. These objects can be arranged in a hierarchy of
directories and files all displayed beneath the Service Gateway node.

Files and directories can be manipulated in a variety of ways:

All commands are accessible via the Menu Bar or context sensitive right-click
menus.

Files and directories can be dragged and dropped within Carousel Generator.

Files and directories can be dragged from Windows Explorer.

The properties of files and directories can be edited after they have been
incorporated into a carousel.
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Adding an object
(file/directory)

Individual files or complete directory structures can be added to a carousel. New
directories can be created. The location that an object is to be added to should be
highlighted.

Adding directories.

1. Highlight the node in the carousel where the directory is to be added.

2. Select Carousel > Contents > Add Directory.
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The Add Directory dialog box is displayed.

The Add Directory allows the user to select any available directory. The
directory path is shown in the top field; the most recently accessed directories
are available in the dropdown list. The adjacent checkboxes have the
following functions:

Item Description

Add Contained Files All files contained in the selected directory (and any
subdirectories if Add Subdirectories is enabled) will be added
to the carousel.

Add Subdirectories All subdirectories of the selected directory will be added to the
carousel.

Include Topmost
Directory

The selected directory will be added to the carousel (not just
the files and/or subdirectories).

Include in
Synchronization

The selected directory will by synchronized with its source
directory. (See page 152, Synchronicity.)
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3. Select the required directory and enable the required checkbox options. Select
OK to add the directory to the carousel.

4. The new directory is added below the highlighted node.

NOTE. When directories are dragged and dropped from Windows Explorer, all
subdirectories and files will be included. If the Shift key is held down during this
action, the topmost directory name is not included.
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Adding files.

1. Highlight the directory node in the carousel where the file is to be added.

2. Select Carousel > Contents > Add file(s).

The Select File(s) to Add dialog box is displayed.

3. Select the file(s) to be added.

4. Select OK to add the files to the carousel.
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5. The new file(s) are added to the selected directory node.

Creating a new directory.

1. Highlight the node in the carousel where the directory is to be created. (In this
screenshot, the new directory is the first object to be created.)

2. Select Carousel > Contents > New Directory.
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3. Enter the name of the new directory and select OK to create the directory.

4. The new directory is created below the highlighted node.

Moving an object Files and directories are moved within a carousel using standard Windows
commands and techniques, such as Copy, Cut and Paste and Drag, and Drop.

Removing an object Files and directories are removed from a carousel using standard Windows
commands and techniques.

File properties When a file is highlighted, the properties of that file are summarized in the
Properties window. The properties can be viewed in detail and edited by selecting
Edit…and displaying the File Properties dialog box.
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The File Properties dialog boxes for files contained in all types of carousel
are similar. However, for the MHP carousel type, if a file is designated as an
application (Java or HTML), there are additional properties; these are described in
the following sections.

Item Description

Include in Carousel: If this box is checked, the file object will be included in the
generated carousel. If not checked, the file object will not be
included in the generated carousel.

Name in Carousel: This is the name of the object as it will appear in the BIOP
message in the output stream.
Range: 254 characters maximum (specified by the DSMCC
specification. Additional characters will be truncated.) ASCII
character set excluding: \ : / * ? " < > |.

Source File: This field is set when the object is added to the carousel and can
be edited to point to another object if required. This field does
not appear in the output stream and is limited to 260 characters.

Member of Collection: This is a list of all the collections currently included in this
carousel. Selecting a different collection effectively put this
object into a different module possibly with different cycle times
and compression characteristics. In the case of a directory
object, all child objects below it are also moved to the selected
collection.

New Create a new collection

(See page 155, Adding a new collection.)

Collection Properties: Displays a summary of the properties of the collection that the
object is a member of. The properties can be edited by using the
Edit… button to open the collection Properties dialog box. (See
page 155, Collection properties.)
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Directory properties When a directory is highlighted, the properties of that directory are summarized
in the Properties window. The properties can be viewed in detail and edited by
selecting Edit…and displaying the Directory Properties dialog box.

Item Description

Include in Carousel: If this box is checked, the directory object will be included in the
generated carousel. If not checked, the directory object will not
be included in the generated carousel.

Include in
Synchronization

If this box is checked, the source directory will be included in
the Synchronization process which aims to match the source
directory structure with the carousel structure, removing and
adding file and directory objects as necessary.

If this box is cleared, this directory will not be compared to the
source directory and neither will any subdirectories, regardless
of their individual settings.

Name in Carousel: This is the name of the object as it will appear in the BIOP
message in the output stream.
Range: 254 characters maximum (specified by the DSMCC
specification. Additional characters will be truncated);.

ASCII character set excluding: \ : / * ? " < > |

Source Directory: This field is set when the directory is added to the carousel
and can be edited to point to another directory if required.
Newly created directories may not initially have a correct source
directory, but this can be edited if desired. This field does not
appear in the output stream and is limited to 260 characters.

The Source Directory will be used when the carousel is
synchronized only if the Include in Synchronization box is
checked.

(See page 152, Synchronicity.)
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Item Description

Member of Collection: This is a list of all the collections currently included in this
carousel. Selecting a different collection effectively put this
object into a different module with possibly different cycle times
and compression characteristics. In the case of a directory
object, all child objects below it are also moved to the selected
collection.

New Create a new collection. (See page 155, Adding a new
collection.)

Collection Properties: This panel displays a summary of the properties of the collection
of which the object is a member. The properties can be edited
by using the Edit… button to open the Collection Properties
dialog box. (See page 155, Collection properties.)

Applications In MHP, applications are transmitted in object carousels. Applications can be
written in Java or HTML. All files that make up the application should be added
to the carousel. However, the receiver must be made aware of the entry point
into the application and certain other information about the characteristics of the
application. This information is sent in the Application Information Table (AIT),
which the receiver must process before it can start any application.

To define an application entry point and other application information, highlight a
file and select Carousel > Contents > Make Java Application orMake HTML
Application. The Application Properties dialog box will be displayed. The
components of the Application Properties screens are described in the following
paragraphs. Note that when the file properties of an application are viewed, the
File Properties General screen is also displayed.
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Application Descriptor screen. The Application Descriptor screen is common
to both Java and HTML applications.

All the properties on this screen are described in the Application Signaling
section of the MHP specification; TS 101 812 v1.1.1, Section 10, Application
Signaling.

Application descriptor name TS 101 812 identity

Application Name: Application Name Descriptor

Language Code: Application Name Descriptor

Application ID: Application Identifier

Control Code: application_control_code

Origination ID: Application Identifier

Service Bound: Application Descriptor

Visibility: Application Descriptor

Priority: Application Descriptor

Application Profiles: Application Descriptor
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Java Properties screen. All the properties on this screen are described in the
DVB-HTML Specific descriptors of the MHP specification; TS 101 812 v1.1.1,
Section 10, Application Signaling.

Application descriptor name TS 101 812 identity

Initial Class: DVB-J Application Location Descriptor

Base Directory: DVB-J Application Location Descriptor

Class Path Extension: DVB-J Application Location Descriptor

Parameters DVB-J Application Descriptor

150 MTSA-HW and MTSA-PC Carousel Application User Manual



Carousel generation

HTML Properties screen. All the properties on this page are described in the
DVB-Java Specific descriptors of the MHP specification: TS 101 812 v1.1.1,
Section 10, Application Signaling.

Application descriptor name TS 101 812 identity

Initial Path: DVB-HTML Application Location Descriptor

Physical Root Drive: DVB-HTML Application Location Descriptor

Parameter String: DVB-HTML Application Descriptor
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Synchronicity Directory objects included in carousels are simply references to directories that
exist elsewhere; for example, a PC hard drive.

If the Include in Synchronization checkbox is enabled for a directory,
the directory will be included in the Synchronization process. When
Session>Synchronize is selected, the source directory structure is matched
with the carousel directory structure. Any objects missing from either the
source directory structure or the carousel directory structure are listed in the
Synchronizing MHP Object Carousel dialog box (as shown in the following
screenshot).

Files or directories available at source but not currently included in the carousel
can be automatically added to the carousel by enabling the checkbox (Select this
if you wish to add any missing files or directories to the carousel). Individual files
and directories listed in the panel can be included or excluded from the activity by
enabling or disabling the adjacent checkbox.

Files or directories listed in the carousel but not available at the source can be
automatically removed from the carousel by enabling the checkbox (Select this if
you wish to delete invalid links from the carousel). Individual files and directories
listed in the panel can be included or excluded from the activity by enabling or
disabling the adjacent checkbox.
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Select Synchronize to synchronize the carousel with the source files in accordance
with the checkbox selections.

NOTE. If the Include in Synchronization checkbox is disabled for a directory,
this directory will not be compared to the source directory and neither will any
subdirectories, regardless of their individual settings.

Collections
(See page 92, Carousel Generator overview.)

Collections provide a means by which objects can be grouped and transmitted in a
single carousel with differing properties, such as repetition rate and compression.
Each collection can have different properties; all objects in a collection are
transmitted with the same properties.
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Collections can be viewed by selecting the Collections tab in the Session window.

A summary of a collection's properties is displayed in the Properties window.
With a collection node highlighted, the contents of the collection can be viewed.

Three icons are used at the Collection node:

Icon Description

(orange)
Collection containing the Service Gateway. At least one collection must
exist during any session. The collection containing the Service Gateway
cannot be deleted

(red)
Ordinary collection

Compressed collection

To open the Collection properties dialog box, select Edit in the Collection
Properties bar.
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Collection properties

Item Description

Name: Enter the required name.

Using DII This is the list of all the DIIs in the carousel. The Collections in
the carousel (and therefore the generated DSMCC modules)
can be distributed among several DIIs or all be referenced by
a single DII. This enables, for example, a minimal collection
containing just the objects needed for booting to be referenced
in a DII with a short cycle time.

Weighting: This is the relative priority of the collections in a single carousel.
For example, the objects in a collection with a weighting of 1.5
will be repeated half as often as those in a collection with a
weighting of three.

This enables, for example, boot classes in a collection to be
given a higher weighting than the other files in a carousel. The
weighting is a floating point value so virtually any ratio can be
achieved.

Range: 0 to 10000

A value of 0 signifies the objects will not appear in the stream.

Compression:
The modules can be optionally compressed to decrease

module size. There are 10 levels of compression ranging from 0
(no compression) to 9 (maximum compression). Compression
is applied to the complete collection, although compression can
be applied via any of the property dialog boxes. The collection
node icon in the Collections view will indicate that compression
is to be applied.

Adding a new collection To add a new collection, right-click on the collections node in the Collections
Session window and select New Collection. The properties of the new collection
can be modified as required.
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Removing a collection To delete a collection, highlight the collection node and select Edit > Delete
Collection. However, note that a collection cannot be deleted while it contains
objects or while it contains the Service Gateway. These objects must be deleted or
moved to another collection.

Moving objects between
collections

Objects can be dragged and dropped or cut and pasted between collections in
the same carousel.

When dragging and dropping directories, pressing the Shift key down while the
object is moved will move only the directory, not the contained items. If the Shift
key is not used, the directory and its contents are moved.

When items (file or directory) that are part of a tree structure are moved between
collections, the complete path, from the Service Gateway is shown. The icons
above the moved object are grayed out to indicate that they are carried in another
collection (in the screenshot, they are the directory icons without a check mark or
a cross within them).

The node description indicates the owning collection.

NOTE. When an object is not included in the synchronization process, the icon

changes from to . (See page 152, Synchronicity.)
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Objects can also be moved between collections in the same carousel by
right-clicking on the object to be moved and selecting the collection from the
Move to Collection list. All current collections will be included in the list.

Programs
(See page 92, Carousel Generator overview.)

Programs allow audio and video content to be added to the carousel-carrying
stream. An example of the Program view follows:

NOTE. The Carousel Session is still the ‘root' of the view, but in this view, the
program content is also shown; this includes tables and streams.

PCR PID references are displayed under the Clock Reference node.
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Mandatory PSI/SI information is created by default and included in the generated
stream. Changes made to the stream content are reflected in the PSI/SI
information. Individual settings are accessible in the various Programs properties
dialog boxes.

The PSI/SI node displays either MPEG or DVB service information that cannot
be easily included elsewhere.

For MPEG PSI, only the Transport Stream ID, which is carried in the PAT,
is displayed.

For DVB SI, the Transport Stream ID is augmented by mandatory DVB SI
(NIT, SDT (actual), EIT (actual present/following) and TDT.) The TDT
(Time/Date Table) and the NIT (Network) are the only entries under the
PSI/SI node. Parameters for the other tables are available in other dialog
boxes.

Under each Program node is a list of all the program components - Carousels and
video and audio elementary streams.

The Elementary Streams node lists the elementary streams that are included in
the stream. These can be associated with one or more programs. Note that the
elementary streams will be included in the generated stream even if they are
not associated with a program.

Clock reference This node indicates which PIDs are carrying PCRs.

Adding a PCR.

1. Highlight the Clock Reference node in the Programs view.

2. From the right-click menu select New PCR.
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3. In the PCR PID Properties dialog box, make the changes required and select
OK.

NOTE. The new PCR is added to the Clock Reference node.

Also available on the Clock Reference right-click menu are Cut, Copy, and
Paste. These operations follow normal Windows conventions. Messages will
be displayed where conflicts arise between existing PCRs and proposed new
or pasted PCRs.

PCR edit. The PCR PID Properties dialog box of an existing PCR PID can
be opened by highlighting the PCR PID and selecting Properties from the
right-click menu.
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PSI/SI The content of the SI node will depend on the SI Type selected: MPEG or DVB.

SI type. SI Type is normally set in the Stream Generation properties. (See
page 129, Stream Generation Properties screen.)

However, a change can be made at any time before generation of the stream.

Switching SI types may involve some loss of data or some creation of default
values. When switching from MPEG PSI to DVB SI, default values are applied
to the TDT and Network information; the Transport Stream ID will be copied.
Switching from DVB SI to MPEG PSI requires only the Transport Stream ID to
be copied. In this phase, any user changes to the default values in the DVB SI
properties will be lost and will need to be reentered if the SI type is changed back
to DVB, or a new session is created.

The EIT and SDT information is maintained between switching SI type as it is
stored in the Program Properties. The tables will simply not be generated if the
type is MPEG.
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To switch between SI types during a session, highlight the SI node in the Programs
view and select the required SI Type from the right-click menu.

Figure 3: MPEG PSI

Figure 4: DVB SI
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Time/Date Table (DVB Only). The Time/Date Table carries a UTC time in the
stream, which is set to a starting value when the stream is generated.

It is then continually updated throughout the stream to reflect the passing of time.
The default setting of the initial value will be the time the generation is started,
but this can be changed to any user defined value.

To edit the Time/Date Table parameters, highlight the Time/Date Table node and
select Properties form the right-click menu. The Time/Date Table Properties
dialog box is displayed.

Cycle Time gives the frequency at which the time and date information should
be repeated in the generated stream.
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Elementary streams and
programs

Audio and video elementary can be imported and incorporated into the generated
stream. Subsequently, the imported streams can be associated with one or more
programs.

Importing elementary streams.

1. In the Programs view, highlight the Elementary Streams node and select
Import Elementary Stream(s) from the right-click menu.

The Add New Elementary Stream dialog box is displayed:

2. Use the browse button to select the source file (mpg) from which the
elementary streams are to be imported:

All programs in the source file are displayed, but only one program, or the
elementary streams from one program, can be imported into a session.
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3. Highlight the program or elementary stream(s) to be imported.

Select OK to import the program/stream(s).

NOTE. The selected elementary streams are displayed under the Elementary
Streams node in the Programs view.
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Elementary stream properties. Imported elementary streams are allocated to the
same PID used in the source program.

If there is any conflict with existing PIDs in the session, a warning is displayed
and an opportunity offered to make changes.

The elementary stream properties dialog box allows the PID to be changed. A
warning will be displayed if a conflict with an existing PID occurs. Continuous
looping of the stream during generation can also be enabled.

To select the Elementary Stream Properties dialog box, highlight the elementary
stream and select Elementary Stream Properties from the right-click menu.

Linking elementary streams to programs. When a carousel is created, a Program
node is automatically created.

If the Carousel Wizard is used, elementary streams can be added during the
process. Streams can also be added from a selected program as required.

Streams are added to the Program node(s) by dragging and dropping them from
the Elementary Stream node.

NOTE. In this case, they are simply linked to the Elementary Stream entry; if they
are deleted from the program, they will continue to be listed under the Elementary
Stream node. However, if an elementary stream is deleted from the Elementary
Streams node, it will also be deleted from the programs in which it is used.

NOTE. The Elementary Streams Properties dialog box (when accessed via
the Program entry) allows descriptors to be added to the elementary stream
information loop in the PMT.
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Output stream generation
To start generating the output stream, select Player > Start Playout. The
parameters used are part of the Stream Generation properties. (See page 129,
Stream Generation Properties screen.)

Errors occurring during stream generation are reported in the TS Generation tab
of the Log view.

Carousel definition file
The current state of the carousel generator session can be saved to disk at any time
during the creation process using the File>Save Carousel Session or File>Save
Carousel Session As options. This can then be reloaded at any time using theFile
> Open Carousel Session . The format of the saved file is standard XML and can
be viewed in any XML compatible viewer (for example, Internet Explorer 5 and
up); editing the XML file is not recommended. Errors in the syntax of the XML
file will be reported in the Definition File Syntax tab of the Log view; errors are
summarized on the Summary tab of the Log view.
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PSI and SI in the Carousel Generator output stream
The Carousel Generator creates various PSI and SI tables while generating its
output stream. The exact contents of the PSI and SI depends on many user
settings; this section describes most of the auto-generated content and which
options or properties affect that content.

NOTE. All PSI/SI related properties can be accessed through nodes in the
program tab.

PSI/SI mode settings
There is one field that has a huge effect on the PSI and SI tables that Carousel
Generator produces - the Session's ‘PSI/SI type' field. This can be accessed from
the Stream Generation Properties dialog box (Player > Stream Generation
Properties), or by right-clicking on the SI node in the program tab, selecting the
SI Type sub-menu, and selecting one of the two options.

Item Description

MPEG PSI PAT, PMT, and AIT (for MHP carousels) will be generated.

DVB SI In addition to the standard MPEG tables, Carousel Generator
will output NIT actual, SDT actual, EIT present/following actual
and TDT sections.
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MPEG PSI tables
Table 23: Program Association Table (PAT)

Table syntax CG value Comment

program_association_section() {

table_id 0x00

section_syntax_indicator 1

‘0' 0

reserved 0x3

section_length auto

transport_stream_id user SI node > Properties… > (MPEG SI page)
‘Transport Stream ID' field.

reserved 0x3

version_number 0 CG does not support table versioning.

current_next_indicator 1

section_number auto depends on the number of programs.

last_section_number auto depends on the number of programs.

for (i=0; i<n; i++) {

program_number user Program node > Properties… > (PMT entry page)
‘Program Number' field.

reserved 0x7

if (program_number == 0) { CG does not specify the network PID.

network_PID n/a 13818-1 describes it as‘optional'.

}

else {

program_map_PID user Program node > Properties… > (PMT entry page)
‘PMT PID' field.

}

}

CRC_32 auto

}

( ISO/IEC 13818-1 (Systems) section 2.4.4.3)

Table 24: Program Map Table (PMT)

Table syntax CG value Comment

TS_program_map_section() {

table_id 0x02

section_syntax_indicator 1

‘0' 0

reserved 0x3
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Table 24: Program Map Table (PMT) (cont.)

Table syntax CG value Comment

section_length auto

program_number user Program node > Properties… > (PMT entry page)
‘Program Number' field.

reserved 0x3

version_number 0 CG does not support table versioning.

current_next_indicator 1

section_number 0

last_section_number 0

reserved 0x7

PCR_PID user Program node > Properties… > (PMT entry page)
‘PCR PID' dropdown menu.

reserved 0xF

program_info_length auto

for (i=0; i<program_info_length; i++) {

descriptor() auto + user Auto generation depends on carousel type. (See
page 170, Carousel descriptors in the PMT.)

User can add additional descriptors via Program
node > Properties… > (Program Descriptors
page)

}

for (i=0; i<N1; i++) { Carousel Generator will add elementary streams
as required. Streams include carousel data, AITs,
and imported PIDs.

stream_type auto Stream type 11 for carousel data, stream type 5
for AIT data, and the source stream type of any
imported PIDs.

reserved 0x7

elementary_PID user User editable - edit method depends on the type
of stream.

reserved 0xF

ES_info_length auto

for (i=0;i<N2;i++) {

descriptor() auto + user Auto generation depends on stream type and
carousel type.

}

}

CRC_32 auto

}

( ISO/IEC 13818-1 section 2.4.4.8 )
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Carousel descriptors in the
PMT

The various standards supported by the Carousel Generator have differing
signaling requirements, so the type and content of descriptors added to the PMT
depend on the carousel types contained in a program.

DSM-CC object carousels (ISO / IEC 13818-6 defined). The basic 13818-6 standard
only supports a single carousel per program, and requires that a
carousel_identifier_descriptor be inserted in the program_info loop (first
descriptor loop) of the PMT section for a program carrying a DSM-CC carousel

Table 25: DSM-CC object carousels - Carousel identifier descriptor

Descriptor syntax CG value Comment

carousel_identifier_descriptor {

descriptor_tag 0x13

descriptor_length auto

carousel_identifier user Carousel node > Properties… > (General)
Carousel ID

for (n=0; n<N; n++) {

private_data_byte n/a These bytes are not used when signaling

} a basic DSM-CC Object Carousel

}

(ISO/IEC 13818-6 (Extensions for DSM-CC) section 11.4.1)
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DSM-CC Object Carousels are carried on one or more PIDs referenced by the
PMT with stream type 11. The ES_info loop for each of these streams contains
an association_tag_descriptor which maps the association_tag used by DSM-CC
messages to a particular PID.

Table 26: DSM-CC object carousels - Association tag descriptor

Descriptor syntax CG value Comment

association_tag_descriptor {

descriptor_tag 0x14

descriptor_length auto

association_tag user Carousel node > Properties… > (PID Settings)
Association tag

use auto 0 if the PID is used for a DSI, 1 otherwise

selector_byte_length auto

for (n=0; n<N1; n++) {

selector_byte auto not used if ‘use' is 1, otherwise follows the
use_0_selector_bytes format

}

for (n=0; n<N2; n++) {

private_data_byte n/a not used

}

}

use_0_selector_bytes {

transaction_id auto Matches the transaction id of the DSI

timeout 0xFFFFFFFF timeout unknown

}

(ISO/IEC 13818-6 section 11.4.2)
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DVB object carousels (ETSI EN 301 192 defined). Although not mentioned in
the DVB data standard (ETSI EN 301 192: Specification for the transmission
of data services in DVB bitstreams), the DVB implementation guidelines for
data broadcasting allow support for multiple Object Carousels per program,
by allowing the carousel_identifier_descriptor to be transmitted in the second
descriptor loop of the PMT

"DVB Guideline: The carousel_identifier_descriptor() shall be inserted in the
second descriptor loop of the PMT (ES_info) corresponding to the elementary
stream carrying the DSI of the object carousel. This allows more than one object
carousel per MPEG-program and implicitly identifies the PID on which each
carousel should be booted from." (TR 101 202 (Implementation Guidelines for
Data Broadcasting) section 4.7.7.1)

Carousel Generator therefore transmits a carousel_identifier_descriptor for every
DVB Object Carousel in a program, as specified by this implementation guideline.

DVB also extends the carousel_identifier_descriptor slightly, by defining
the contents of the private_data_byte section further with what it calls a
FormatSpecifier. However, Carousel Generator only uses the required parts of this
extension - it sets the FormatId to zero, which indicates that no format specifier
is provided.

Table 27: DVB object carousels - Private_data_byte syntax

Private_data_byte syntax CG value Comment

carousel_identifier::private_data_bytes {

FormatId 0 0 indicates no FormatSpecifier present

FormatSpecifier() {

FormatSpecifier_byte n/a Not used by Carousel Generator

}

for (n=0; n<N1; n++) {

private_data_byte n/a Not used by Carousel Generator

}

}

TR 101 202 (Implementation Guidelines for Data Broadcasting) section 4.7.7.1

An association_tag_descriptor is added to the ES_info loop in exactly the same
way as for DSM-CC object carousels.
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Two more descriptors are also added to the ES_info loop for streams
carrying DVB object carousels - the data_broadcast_id_descriptor and the
stream_identifier_descriptor. Both are defined in EN300 468 (Specification for
Service Information in DVB systems).

Table 28: DVB object carousels - Descriptors

Descriptor syntax CG value Comment

stream_identifier_descriptor {

descriptor_tag 0x52

descriptor_length 1

component_tag user LSB of the association_tag for this stream

}

data_broadcast_id_descriptor {

descriptor_tag 0x66

descriptor_length 2

data_broadcast_id 7 DVB Object Carousel code

for (i=0; i<N; i++) {

id_selector_byte n/a DVB Object Carousels do not use these

} selector bytes

}

DTT object carousels (DTG D-Book (DTT requirements for interoperability)). Most
of the PMT signaling for DTT Object Carousels is the same as for DVB Object
Carousels

However, the D-Book does specify the contents of the id_selector_byte section
of the data_broadcast_id_descriptor, and also requires that the data_broadcast_id
value in that descriptor is 262 (0x106).

Table 29: DTT object carousels

DTT id_selector_bytes syntax CG value Comment

for (i=0; i<descriptor_length-2; i++) {

application_type_code user DTT Object Carousel node > Properties… >
(DTT Applications page). Application codes list
contains the app codes used.

boot_priority_hint user Boot priorities accessed as above.

app_specific_data_length (N2) 0

for (j=0; j<N2; j++) {

app_specific_data_byte n/a Not used.

}

}

(UK DTG D-Book (Digital Terrestrial Television Requirements for Interoperability) section 18.5.2.1)
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MHP object carousels (ETSI TS 101 812). MHP uses an additional table, the AIT,
for most of its signaling requirements

The location of the AIT table for a program is identified through an elementary
stream PID entry in the PMT with stream type 5. The ES_info loop for the AIT
PID also carries an application_signaling descriptor (AIT information is given in
the DVB SI Tables section of this appendix):

Table 30: MHP object carousels - Application signaling

Descriptor syntax CG value Comment

application_signaling_descriptor {

descriptor_tag 0x6F

descriptor_length auto

for (i=0; i<descriptor_length; i++) {

application_type auto An entry for application_type 1 will be present if
any Java apps are defined in the carousel, and
an entry for type 2 will be present if any HTML
apps are defined in the carousel.

reserved_future_use 0x7

AIT_version_number 0 CG does not support table versioning - all tables
have version number 0.

}

}

(ETSI TS 101 812 (Multimedia Home Platform (MHP) specification) section 10.7.1)

The PMT signaling for MHP carousel carrying streams is very similar to that
for DVB Object Carousels. The only difference is that, like DTT, MHP defines
additional content for the data_broadcast_id_descriptor's data_broadcast_id value
and id_selector bytes. The MHP data_broadcast_id value is 240 (0xF0), and the
id_selector bytes are as defined below:

Table 31: MHP object carousels - ID selector

MHP id_selector_bytes syntax CG value Comment

for (i=0; i<descriptor_length-2; i++) {

application_type auto An entry for application_type 1 will be present if
any Java apps are defined in the carousel, and
an entry for type 2 will be present if any HTML
apps are defined in the carousel.

}

(ETSI TS 101 812 section 10.7.2.2)
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DVB SI tables
The following SI is only generated when the session's SI type is set to DVB SI.
All user-editable properties of these tables can be accessed through nodes in the
Programs tab.

Network Information Table
(NIT)

The Carousel Generator only generates NIT actual sections, and the contents
of the NIT can be accessed by editing the properties of the Network node and
its children.

Table 32: Network information table

Table syntax CG value Comment

network_information_section() {

table_id 0x40 NIT actual - CG does not generate NIT other
sections.

section_syntax_indicator 1

reserved_future_use 1

reserved 0x3

section_length auto

network_id user Network node > Properties… > ‘Network ID' field

reserved 0x3

version_number 0 CG does not support table versioning

current_next_indicator 1

section_number auto

last_section_number auto

reserved_future_use 0xF

network_descriptors_length auto

for (i=0;i<N;i++) { A network_name_descriptor will always be
added, with the name

descriptor() auto + user Specified in the Network Properties > ‘Name' field.

} The user can add custom descriptors to this
loop by editing the descriptor list in the Network
Properties dialog box.

reserved_future_use 0xF

transport_stream_loop_length auto

for (i=0; i<N; i++) { CG will always add at least one transport stream
to this loop (the ‘actual' transport stream' but the
user can add additional transport streams (by
right-clicking on the network node).

transport_stream_id user Transport Stream node > Properties… >
(Transport Stream page) Transport Stream ID
field

original_network_id user As above > Original Network ID field
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Table 32: Network information table (cont.)

Table syntax CG value Comment

reserved_future_use 0xF

transport_descriptors_length auto

for (j=0; j<N; j++) { One of the three delivery system descriptors will
always be present.

(See page 176, Delivery system descriptors.)

descriptor() auto + user The user can also add custom descriptors
via Transport Stream node > Properties… >
(Transport Stream page) Descriptors list

}

}

CRC_32 auto

}

(ETSI EN 300 468 (Specification for Service Information in DVB systems) section 5.2.1)

Delivery system
descriptors

Every transport stream listed in the NIT will contain at least one descriptor - one
of either the cable delivery system descriptor (ETSI EN 300 468 section 6.2.12.1),
the satellite delivery system descriptor (ETSI EN 300 468 section 6.2.12.2) or the
terrestrial delivery system descriptor (ETSI EN 300 468 section 6.2.12.3). The
type of descriptor used, and the contents of all its fields, are edited by selecting
Transport Stream node > Properties > Delivery System.

All of the delivery system descriptor fields defined in EN 300 468 can be modified.
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Table 33: System descriptor

Table syntax CG value Comment

service_description_section() {

table_id 0x42 SDT actual - CG does not generate SDT other
sections.

section_syntax_indicator 1

reserved_future_use 1

reserved 0x3

section_length auto

transport_stream_id user Matches the transport_stream_id of the actual
transport stream

reserved 0x3

version_number 0 CG does not support table versioning

current_next_indicator 1

section_number auto

last_section_number auto

original_network_id user Matches the original_network_id of the actual
transport stream

reserved_future_use 0xFF

for (i=0; i<N; i++) { CG auto-generates an entry for every program
in the session.

service_id auto Matches the program number

reserved_future_use 0x3F

EIT_schedule_flag 0 EIT schedule tables not supported.

EIT_present_following_flag user Transmission of an EIT_pf is user-controllable
per service. (See page 180, Event Information
Table (EIT).)

running_status 0x4 Always set to 4 - Running

free_ca_mode 0 Always set to 0 - No scrambling

descriptors_loop_length auto

for (j=0; j<N; j++) {

descriptor() auto A service_descriptor is always added, and
depending on the carousel content of the
program, data_broadcast_ descriptor(s) may be
added.

}

}

CRC_32 auto

}

(ETSI EN 300 468 section 5.2.3)
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Service_descriptor

Table 34: Service descriptor

Descriptor syntax CG value Comment

service_descriptor() { All of the properties in this descriptor are
accessed via the Program node that is associated
with the service. Program node > Properties… >
Additional SI page

descriptor_tag 0x48

descriptor_length auto

service_type user > Service Type dropdown

service_provider_name_length auto

for (i=0; i<N; i++) {

char user > Service Provider field

}

service_name_length auto

for (i=0; i<N; i++) {

char user > Service Name field

}

}

(ETSI EN 300 468 section 6.2.30)

Data_broadcast_descriptor The data_broadcast_descriptor is a DVB defined descriptor that can be used in
either the SDT or EIT to indicate that a carousel is associated with a service or
event. Carousel Generator only supports associating a carousel with a service, so
will only add the data_broadcast_descriptor to the SDT.

Table 35: Data broadcast descriptor

Descriptor syntax CG value Comment

data_broadcast_descriptor() {

descriptor_tag 0x64

descriptor_length auto

data_broadcast_id auto depends on the type of carousel

component_tag user LSB of the assoc_tag of the PID carrying the
carousel's DSI

selector_length auto

for (i=0; i<selector_length; i++) {

selector_byte auto depends on the type of carousel

}

ISO_639-2[3]_language_code "und" CG does not use the text field, so the language
code is set to "und"efined
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Table 35: Data broadcast descriptor (cont.)

Descriptor syntax CG value Comment

text_length 0

for (i=0; i<text_length; i++) {

text_char n/a Not used

}

}

(ETSI EN 300 468 section 6.2.10)

The use of the data_broadcast_descriptor, and the contents of the
data_broadcast_id and selector_bytes fields depend on the type of carousel(s) in
the program.

DSM-CC object carousel. The DSM-CC standard does not define the
data_broadcast_descriptor, and so a data_broadcast_descriptor is not added to the
service entry for a program containing a DSM-CC object carousel

MHP object carousels. MHP uses the AIT for all its signaling requirements, and
so does not require the use of the data_broadcast_descriptor

DVB object carousels. A data_broadcast_descriptor is added for every DVB
Object Carousel contained in a program

The data_broadcast_id is set to 7, and the selector_byte format is as follows:

Table 36: DVB object carousel

DVB selector_bytes syntax CG value Comment

Carousel_type_id 0x2

Reserved 0x3F

Transaction_id auto Matches the carousel DSI transaction ID

time_out_value_DSI 0xFFFFFFFF not used

time_out_value_DII 0xFFFFFFFF not used

Reserved 0x3

leak_rate 0

for (i=0; i<N; i++) {

ISO_639_language_code n/a The object names loop is not used by the
Carousel Generator.

object_name_length n/a

for (j=0; j<object_name_length; j++) {

object_name_char n/a

}

}

(ETSI EN 300 468 section 6.2.10)
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DTT object carousels. The DTG D-Book requires that there only be a single
data_broadcast_descriptor per service, to identify the application type carried
in that service

The Carousel Generator uses the first Carousel it encounters in a program
that has at least one application id set as the carousel referenced by the
data_broadcast_descriptor. Generally, only one of the DTT Object Carousels in a
program should have any application IDs set.

Because only a single data_broadcast_descriptor is allowed per service, the
component_tag value of the descriptor is set to zero - the descriptor does not
identify any particular stream as carrying a carousel.

The data_broadcast_id for the descriptor is set to 262 (0x106), and the
selector_bytes format is as follows:

Table 37: 2−25: DTT object carousel

DTT selector_bytes syntax CG value Comment

for (i=o; i<selector_byte_length;i++) {

application_type_code user The first application id defined in a DTT carousel
contained in the service.

number_languages 0

for (j=0; j<number_languages;j++) {

ISO_639_language_code n/a Not used

}

application_specific_data_length 0

for (j=0; j<a_s_d_length; j++) {

application_specific_data_byte n/a Not used

}

}

(UK DTG D-Book section)

Event Information Table
(EIT)

The Carousel Generator only supports the creation of EIT present following
information, for the actual transport stream. The presence of EIT p/f sections for
a particular service is user controllable, but where transmitted, information will
only be included for the present (now) event. The following (next) event section
will always be empty. If an EIT p/f is present for a particular service, the relevant
EIT_present_following_flag in the SDT will be set.
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Table 38: Event Information Table (EIT)

Table syntax CG value Comment

service_description_section() {

table_id 0x4E EIT actual present/following - CG does not
generate any other form of EIT.

section_syntax_indicator 1

reserved_future_use 1

reserved 0x3

section_length auto

service_id auto

reserved 0x3

version_number 0 CG does not support table versioning

current_next_indicator 1

section_number auto section 0 is present event, 1 is following event

last_section_number 1

transport_stream_id user Matches the transport_stream_id of the actual
transport stream

original_network_id user Matches the original_network_id of the actual
transport stream

segment_last_section_number 1 p/f table is not segmented

last_table_id 0x4E Only table id 0x4E is used

for (i=0; i<N; i++) { The present event section (section 0) will always
contain a single event, while the following event
section (section 1) will not contain any events.
The following fields are therefore only used in
section 0 of the EIT.

event_id 0 Event ID is always set to zero

start_time user The start time will match the start time of the TDT.

duration 99:59:59

running_status 0x4 Always set to 4 - Running

free_CA_mode 0 Always set to 0 - No scrambling

descriptors_loop_length auto CG always adds a single descriptor

for (i=0; i<N; i++) { to the event descriptors loop, the

descriptor() auto short_event_descriptor.

}

}

CRC_32 auto

}

(ETSI EN 300 468 section 5.2.4)
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Short_event_descriptor The fields of the short_event_descriptor for the present event are all accessed
through Program Node > Properties…> Additional SI

Table 39: Short event descriptor

Descriptor syntax CG value Comment

short_event_descriptor() {

descriptor_tag 0x4D

descriptor_length auto

ISO_639-2[3]_language_code user > Language Code dropdown

event_name_length auto

for (i=0; i<event_name_length;i++) {

event_name_char user Set to match the service name field

}

text_length auto

for (i=0; i<text_length; i++) {

text_char user > Description field

}

}

(ETSI EN 300 468 section 6.2.33)

Time and Date Table (TDT) The TDT is accessed through the Time/Date Table node under the DVB SI node
in the program tab. It carries current time information, and the user can specify
whether that information will be filled with the current system time, or start at a
time specified by the user and increment in real time.

Table 40: Time and date table

Table syntax CG value Comment

time_date_section() {

table_id 0x70

section_syntax_indicator 0

reserved_future_use 1

reserved 0x3

section_length 5

UTC_time auto/user This value starts at the time specified by the
user (Time/Date Table node > Properties… >
Start Time) and increments appropriately during
stream output.

}

(ETSI EN 300 468 section 5.2.4)
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Application Information
Table (AIT)

The AIT (ETSI TS 101 812 section 10.4) is the main signaling component of
the MHP standard, and the Carousel Generator will generate an AIT for every
program that carries one or more MHP carousels containing applications.

NOTE. If the MHP carousel(s) in a program do not have any applications defined
an AIT will not be generated for that program.

The AIT is split into subtables based on the application_type value. The current
MHP spec defines two application types, Java and HTML, and Carousel
Generator supports both. If only Java applications are present in the carousels in a
program, only the Java subtable will be generated, and the same is true for HTML
applications. If both application types are present in the carousel(s) in a program,
both subtables of the AIT will exist for that program.

Table 41: Application information table

Table syntax CG value Comment

application_information_section() {

table_id 0x74

section_syntax_indicator 1

reserved_future_use 1

reserved 0x3

section_length auto

application_type auto

reserved 0x3

version_number 0 CG does not support table versioning

current_next_indicator 1

section_number auto

last_section_number auto

reserved_future_use 0xF

common_descriptors_length 0
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Table 41: Application information table (cont.)

Table syntax CG value Comment

for (i=0; i<c_d_length; i++) {

descriptor() n/a

}

DVB_reserved_future_use 0xF

application_loop_length auto

for (i=0; i<app_loop_length; i++) { Carousel Generator will add applications as
defined in the carousel. To create an application,
right-click on the file and select Make HTML
Application or Make Java Application.

application_identifier() {

organisation_id user File node > Properties… > (Application Descriptor
page) Organization ID field

application_id user File node > Properties… > (Application Descriptor
page) Application ID field

}

application_control_code user File node > Properties… > (Application Descriptor
page) Control Code dropdown

app_descriptors_loop_length auto

for (j=0; j<a_d_l_length; j++) {

descriptor() auto/user Carousel Generator creates the appropriate
descriptors for each application type automatically.
However, fields in the properties pages allow the
contents of these descriptors to be edited. (See
page 184, Application descriptors in the AIT.)

}

}

CRC_32 auto

}

Application descriptors in
the AIT

Every application listed in the AIT will have five descriptors in the
app_descriptors_loop, but two of these depend upon the type of application
(Java or HTML). The three common descriptors are the application_descriptor,
application_name_descriptor and transport_protocol_descriptor, and the
two app specific descriptors will either be dvb_j_application_descriptor
and dvb_j_application_location_descriptor (for Java apps) or
dvb_html_application_descriptor and dvb_html_application_location_descriptor
(for HTML apps).
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Common application descriptors.

Table 42: Application descriptor

Descriptor syntax CG value Comment

application_ descriptor { Note. All of the user editable fields are accessed
through File > Properties… > Application
Descriptor page

descriptor_tag 0x00

descriptor_length auto

application_profiles_length

for (i=0; i<N; i++) { > Application profiles list

application_profile user

version.major user

version.minor user

version.micro user

}

service_bound_flag user > Service Bound checkbox

visibility user > Visibility dropdown

reserved_future_use 0x1F

application_priority user > Priority

for (i=0; i<N; i++) {

transport_protocol_label auto Matches the transport_protocol_label value in the
transport_protocol_descriptor.

}

}

(ETSI TS 101 812 section 10.7.3)

Table 43: Application name descriptor

Descriptor syntax CG value Comment

application_name_descriptor { Accessed through the same page as described.

descriptor_tag 0x01

descriptor_length auto

for (i=0; i<descriptor_length; i++) {

ISO_639_language_code user > Language Code dropdown

app_name_length auto

for (i=0; i<a_n_length;i++){

app_name_char user > Application Name field

}

}

MTSA-HW and MTSA-PC Carousel Application User Manual 185



PSI and SI in the Carousel Generator output stream

Table 43: Application name descriptor (cont.)

Descriptor syntax CG value Comment

}

(ETSI TS 101 812 section 10.7.4)

Table 44: Transport protocol descriptor

Descriptor syntax CG value Comment

transport_protocol_descriptor {

descriptor_tag 0x02

descriptor_length auto

protocol_id 0x0001 Transport via OC

transport_protocol_label auto Set to match the component tag value

remote_connection 0 CG does not support remote carousels

component_tag auto Matches the component tag in the
stream_identifier_descriptor for the DSI of
the MHP Object Carousel that contains this
application.

}

(ETSI TS 101 812 section 10.8.1)

Java application descriptors.

Table 45: Java application descriptor

Descriptor syntax CG value Comment

dvb_j_application_descriptor { This descriptor specifies the Java application
parameters, and is accessed on the Java app file
> Properties… > Java Properties page.

The parameter list is edited by using the
Parameters list box and buttons.

descriptor_tag 0x03

descriptor_length auto

for (i=0; i<N; i++) {

parameter_length auto

for (j=0; j<parameter_length; j++) {

parameter_byte user

}

}

}

(ETSI TS 101 812 section 10.9.1)
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Table 46: Java application location descriptor

Descriptor syntax CG value Comment

dvb_j_application_location_descriptor { This descriptor specifies the Java application
path, and is accessed via Java app file >
Properties… > Java Properties page.

descriptor_tag 0x04

descriptor_length auto

base_directory_length auto

for (i=0; i<base_directory_length; i++) {

base_directory_byte user > Base Directory field

}

classpath_extension_length auto

for (i=0; i<classpath_ext_length; i++) {

classpath_extension_byte user > Classpath extension field

}

for (i=0; i<N; i++) {

initial_class_byte user > Initial class field

}

}

(ETSI TS 101 812 section 10.9.2)

HTML application descriptors.

Table 47: HTML application descriptor

Descriptor syntax CG value Comment

dvb_html_application_descriptor { This descriptor specifies the HTML application
parameters, and is accessed via HTML app file >
Properties… > HTML Properties page.

Descriptor_tag 0x03

descriptor_length auto

appid_set_length auto

for (i=0; i<appid_set_length; i++) {

application_id user > Application IDs list box

}

for (j=0; j<N; j++) {

parameter_bytes auto > Parameter String edit box

}
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Table 47: HTML application descriptor (cont.)

Descriptor syntax CG value Comment

}

(ETSI TS 101 812 section 10.10.1)

NOTE. The dvb_html_application_descriptor format shown above is that defined
in TS 101 812 v1.1.2 (MHP v1.0.1) - previous versions of the standard did not
have the application_id loop. Carousel Generator can be made to revert to the
older version of the descriptor (v1.0.0) for a particular carousel by checking the
MHP Object Carousel node > Properties… > (MHP page) Use old style (MHP
v1.0.0) HTML application descriptor checkbox.

Table 48: HTML application location descriptor

Descriptor Syntax CG Value Comment

dvb_html_application_location_descriptor { This descriptor specifies the HTML application
path, and is accessed on the HTML app file >
Properties… > HTML Properties page.

descriptor_tag 0x04

descriptor_length auto

physical_root_length auto

for (i=0; i<physical_root_length; i++) {

physical_root_bytes user > Physical Root Directory field

}

for (i=0; i<N; i++) {

initial_path_bytes user > Initial Path field

}

}

(ETSI TS 101 812 section 10.10.2)

Summary
Carousel Generator v2.0 is designed to generate enough SI to create a fully DVB
conformant stream, which should be enough to drive most set-top boxes. If any
additional SI is required, another suitable tool (the Tektronix Multiplexer) should
be used to insert the extra information into the generated stream.
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