
Printed Help Document

TDSPWR3
Power Measurement and Analysis Software

Adapted from the TDSPWR3 Power Measurement and Analysis Online Help
PHP0249, Version 1.00, 2003



Copyright � Tektronix, 2003, Inc. All rights reserved. Licensed software products are owned by Tektronix or its suppliers
and are protected by United States copyright laws and international treaty provisions.

Use, duplication, or disclosure by the Government is subject to restrictions as set forth in subparagraph (c)(1)(ii) of the Rights
in Technical Data and Computer Software clause at DFARS 252.227-7013, or subparagraphs (c)(1) and (2) of the
Commercial Computer Software – Restricted Rights clause at FAR 52.227-19, as applicable.

Tektronix products are covered by U.S. and foreign patents, issued and pending. Information in this documentation
supercedes that in all previously published material. Specifications and price change privileges reserved.

Tektronix, Inc., P.O. Box 500, Beaverton, OR 97077

TEKTRONIX, TEK and TEKPROBE are registered trademarks of Tektronix, Inc.
TDSPWR3 PHP0249, Version 1.00, 2003.



Table Of Contents 

GENERAL SAFETY SUMMARY ............................................................................................................. 1 

To avoid Fire and Personal Injury ......................................................................................................................... 1 
Terms in this Manual ............................................................................................................................................. 1 
Terms in the Application ....................................................................................................................................... 1 

INTRODUCTION...................................................................................................................................... 3 

Welcome.................................................................................................................................................................... 3 

Online Help and Related documentation............................................................................................................... 4 

Using Online Help.................................................................................................................................................... 4 

Printing from Online Help ...................................................................................................................................... 5 

Related documentation............................................................................................................................................ 5 

Conventions .............................................................................................................................................................. 6 

Contacting Tektronix .............................................................................................................................................. 7 

Feedback ................................................................................................................................................................... 7 

GETTING STARTED................................................................................................................................ 9 

Introduction and Product Description................................................................................................................... 9 

Compatibility.......................................................................................................................................................... 10 

Requirements and Restrictions............................................................................................................................. 11 

Accessories.............................................................................................................................................................. 11 

Current Probes....................................................................................................................................................... 12 

Differential Probes................................................................................................................................................. 12 

Updates through the website................................................................................................................................. 13 

Installation procedures.......................................................................................................................................... 13 
Installing the application...................................................................................................................................... 13 

TDSPWR3 Software Analysis Printed Help Document                       i 



Table of Contents 

UTILITIES .............................................................................................................................................. 15 

Deskewing Probes and Channels ..........................................................................................................................15 
Static Deskew.......................................................................................................................................................15 
Deskewing in TDS5000 series Oscilloscope with an Internal source..................................................................18 
Deskewing in TDS7000, TDS6000 and CSA7000 series Oscilloscopes with an Internal source .......................20 
Deskewing in TDS5000, TDS6000, TDS7000 and CSA7000 series Oscilloscopes with an External source.....23 
Deskewing using a Power Deskew Fixture..........................................................................................................26 

SOA Overlay...........................................................................................................................................................27 

OPERATING BASICS ........................................................................................................................... 31 

Application Interface .............................................................................................................................................31 

Application Interface Menu Controls ..................................................................................................................31 

Basic Application Functions..................................................................................................................................32 

Using Online Help ..................................................................................................................................................32 

Minimizing and Maximizing the Application Window ......................................................................................32 

Application Directories and File Names ..............................................................................................................32 

File Name Extensions.............................................................................................................................................33 

Returning to the Application.................................................................................................................................34 

Exiting the Application..........................................................................................................................................34 

Setting up TDSPWR3 to take Measurements .....................................................................................................34 

Setting Up the Software .........................................................................................................................................34 

Table of Options-Common Configurations .........................................................................................................35 

Table of Measurements and Configurations-Power Device Analysis................................................................36 

Table of Measurements and Configurations-Line Power Analysis ...................................................................40 

Table of Measurements and Configurations-Output Analysis ..........................................................................42 

Table of Measurements and Configurations-Modulation Analysis...................................................................44 

Table of Measurements and Configurations-Analysis Tools .............................................................................45 

Taking a New Measurement .................................................................................................................................46 

ii                                                                                       TDSPWR3 Software Analysis Printed Help Document                             



Table of Contents 

About Taking Measurements................................................................................................................................ 46 
Acquiring Data..................................................................................................................................................... 46 

Analyzing the Results ............................................................................................................................................ 47 

Selecting a Measurement....................................................................................................................................... 47 

Common Configuration Panel .............................................................................................................................. 48 

Math Setup ............................................................................................................................................................. 50 

Hysteresis................................................................................................................................................................ 52 

SOA Mask Editor................................................................................................................................................... 52 

Power Device Analysis - Power Dissipation......................................................................................................... 54 
Selecting and Configuring Measurements-Power Dissipation ............................................................................ 54 
Viewing Results-Power Dissipation .................................................................................................................... 63 
Generating Reports-Power Dissipation................................................................................................................ 65 
Troubleshooting Switching Loss Results............................................................................................................. 66 

B-H Analysis........................................................................................................................................................... 68 
Selecting and Configuring Measurements-B-H Analysis .................................................................................... 68 
Configuring Measurements.................................................................................................................................. 69 
Viewing Results-B-H Analysis............................................................................................................................ 76 
Generating Reports-B-H Analysis ....................................................................................................................... 82 

Total Loss................................................................................................................................................................ 82 
Selecting and Configuring Measurements-Total Loss......................................................................................... 82 
Configuring Measurements.................................................................................................................................. 83 
Viewing Results-Total Loss................................................................................................................................. 86 
Generating Reports-Total Loss ............................................................................................................................ 88 

Safe Operating Area .............................................................................................................................................. 88 
Selecting and Configuring Measurements-Safe Operating Area ......................................................................... 88 
Viewing Results-Safe Operating Area................................................................................................................. 90 
SOA Overlay........................................................................................................................................................ 95 
Utilities> SOA Overlay ....................................................................................................................................... 95 
Generating Reports-Safe Operating Area ............................................................................................................ 97 

Dynamic Resistance ............................................................................................................................................... 97 
Selecting and Configuring Measurements-Dynamic Resistance ......................................................................... 97 
Viewing Results-Dynamic Resistance ................................................................................................................. 99 
Generating Reports-Dynamic Resistance .......................................................................................................... 100 

di/dt ....................................................................................................................................................................... 100 
Selecting and Configuring Measurements-di/dt ................................................................................................ 100 
Viewing Results-di/dt ........................................................................................................................................ 102 
Generating Reports-di/dt.................................................................................................................................... 103 

 

TDSPWR3 Software Analysis Printed Help Document           iii 



Table of Contents 

dv/dt.......................................................................................................................................................................104 
Selecting and Configuring Measurements-dv/dt................................................................................................104 
Viewing Results-dv/dt........................................................................................................................................105 
Generating Reports-dv/dt ...................................................................................................................................106 

Line Power Analysis-Power Quality...................................................................................................................107 
Selecting and Configuring Measurements-Power Quality.................................................................................107 
Viewing Results-Power Quality.........................................................................................................................108 
Generating Reports-Power Quality ....................................................................................................................109 

Current Harmonics..............................................................................................................................................110 
Selecting and Configuring Measurements-Current Harmonics .........................................................................110 
Configuring the Measurement............................................................................................................................110 
Viewing Results-Current Harmonics .................................................................................................................115 
Generating Reports-Current Harmonics ............................................................................................................119 

Total Power Quality.............................................................................................................................................120 
Selecting and Configuring Measurements-Total Power Quality .......................................................................120 
Viewing Results-Total Power Quality ...............................................................................................................124 
Generating Reports-Total Power Quality...........................................................................................................127 

Output Analysis-Ripple Line ..............................................................................................................................127 
Selecting and Configuring Measurements-Ripple Line .....................................................................................127 
Viewing Results-Ripple Line.............................................................................................................................128 
Generating Reports-Ripple Line ........................................................................................................................129 

Ripple Switching ..................................................................................................................................................130 
Selecting and Configuring Measurements-Ripple Switching ............................................................................130 
Viewing Results-Ripple Switching ....................................................................................................................131 
Generating Reports-Ripple Switching ...............................................................................................................131 

Turn-On Time ......................................................................................................................................................132 
Selecting and Configuring Measurements-Turn-On Time.................................................................................132 
Viewing Results-Turn-On Time ........................................................................................................................133 
Generating Reports-Turn-On Time....................................................................................................................134 

Modulation Analysis-Pulse Width ......................................................................................................................135 
Selecting and Configuring Measurements-Pulse Width ....................................................................................135 
Viewing Results-Pulse Width ............................................................................................................................136 
Generating Reports-Pulse Width........................................................................................................................137 

Duty Cycle.............................................................................................................................................................138 
Selecting and Configuring Measurements-Duty Cycle......................................................................................138 
Viewing Results-Duty Cycle..............................................................................................................................139 
Generating Reports-Duty Cycle.........................................................................................................................140 

Clock Period .........................................................................................................................................................140 
Selecting and Configuring Measurements-Clock Period ...................................................................................140 
Viewing Results-Clock Period...........................................................................................................................141 
Generating Reports-Clock Period ......................................................................................................................142 

iv                                                                                       TDSPWR3 Software Analysis Printed Help Document                            



Table of Contents 

Frequency Modulation ........................................................................................................................................ 142 
Selecting and Configuring Measurements-Frequency....................................................................................... 142 
Viewing Results-Frequency............................................................................................................................... 144 
Generating Reports-Frequency .......................................................................................................................... 144 

Analysis Tools-Spectral Analysis........................................................................................................................ 145 
Selecting and Configuring Measurement........................................................................................................... 145 
Viewing Results ................................................................................................................................................. 147 
Generating Reports ............................................................................................................................................ 148 
Troubleshooting Spectral Analysis Error Messages .......................................................................................... 149 

Saving and Recalling Setups ............................................................................................................................... 149 
Saving a Setup ................................................................................................................................................... 149 
Recalling a Saved Setup..................................................................................................................................... 149 
Recalling the Default Setup ............................................................................................................................... 150 
Recently Recalled Setup .................................................................................................................................... 150 
Recently Saved Setup ........................................................................................................................................ 150 

TUTORIAL ........................................................................................................................................... 151 

Introduction to the Tutorial................................................................................................................................ 151 

Starting the Application ...................................................................................................................................... 151 

Setting Up the Oscilloscope ................................................................................................................................. 151 

Measuring Power Dissipation ............................................................................................................................. 151 

Measuring B-H Analysis ..................................................................................................................................... 154 

Stopping the Tutorial........................................................................................................................................... 157 

Returning to the Tutorial .................................................................................................................................... 157 

APPLICATION EXAMPLES ................................................................................................................ 159 

About Application Examples .............................................................................................................................. 159 

To Increase Efficiency in a Switching Power Supply ....................................................................................... 159 
Measure Switching Loss .................................................................................................................................... 159 
Analyze Switching Loss .................................................................................................................................... 161 
Measure Magnetic Loss ..................................................................................................................................... 163 

GPIB COMMANDS .............................................................................................................................. 165 

About the GPIB Program ................................................................................................................................... 165 

GPIB Reference Materials .................................................................................................................................. 165 

TDSPWR3 Software Analysis Printed Help Document           v 



Table of Contents 

Guidelines to GPIB Programming .....................................................................................................................165 

Introduction to GPIB Commands ......................................................................................................................166 

Starting and Setting Up the Application Using GPIB ......................................................................................166 

Sample Program...................................................................................................................................................167 

Variable: TDS Command....................................................................................................................................178 

Variable:Value TDS Command Arguments and Queries-Application, Sequencer .......................................179 

Variable:Value TDS Command Arguments and Queries-Save, Recall ..........................................................179 

Variable:Value TDS Command Arguments and Queries-Measurement .......................................................180 

Variable:Value TDS Command Arguments and Queries-Common Configuration......................................180 

Variable:Value TDS Command Arguments and Queries-B-H Analysis ........................................................181 

Variable:Value TDS Command Arguments and Queries-BH Analysis-Inductance .....................................181 

Variable:Value TDS Command Arguments and Queries-Magnetic Loss ......................................................181 

Variable:Value TDS Command Arguments and Queries-Magnetic property...............................................182 

Variable:Value TDS Command Arguments and Queries-Current Harmonics .............................................184 

Variable:Value TDS Command Arguments and Queries-Current Harmonics-IEC Standard....................184 

Variable:Value TDS Command Arguments and Queries-Current Harmonics-AMD14 ..............................185 

Variable:Value TDS Command Arguments and Queries-Current Harmonics-MIL....................................185 

Variable:Value TDS Command Arguments and Queries-Power Dissipation................................................185 

Variable:Value TDS Command Arguments and Queries-Power Dissipation-Switching Loss .....................186 

Variable:Value TDS Command Arguments and Queries-Ripple Line...........................................................188 

Variable:Value TDS Command Arguments and Queries-Ripple Switching..................................................188 

Variable:Value TDS Command Arguments and Queries-Total Power Quality ............................................189 

Variable:Value TDS Command Arguments and Queries-SOA.......................................................................190 

Variable:Value TDS Command Arguments and Queries-Power Quality ......................................................191 

Variable:Value TDS Command Arguments and Queries-Spectral Analysis .................................................191 

Variable:Value TDS Command Arguments and Queries- Pulse Width Modulation....................................192 

vi                                                                                       TDSPWR3 Software Analysis Printed Help Document                            



Table of Contents 

Variable:Value TDS Command Arguments and Queries- Duty Cycle Modulation...................................... 193 

Variable:Value TDS Command Arguments and Queries- Clock Period Modulation .................................. 193 

Variable:Value TDS Command Arguments and Queries- Frequency Modulation ...................................... 194 

Variable:Value TDS Command Arguments and Queries-Error Codes ......................................................... 195 

REFERENCE ....................................................................................................................................... 197 

Short Cut Keys for TDSPWR3........................................................................................................................... 197 

Error Codes for TDSPWR3................................................................................................................................ 198 

Error Codes for TDSPWR3 Cont... ................................................................................................................... 200 

Error Codes for TDSPWR3 Cont... ................................................................................................................... 201 

Error Codes for TDSPWR3 Cont... ................................................................................................................... 205 

Error Codes for TDSPWR3 Cont... ................................................................................................................... 207 

Error Codes for TDSPWR3 Cont... ................................................................................................................... 208 

Configuration Parameter Specifications............................................................................................................ 209 

Parameters............................................................................................................................................................ 213 
About Application Parameters ........................................................................................................................... 213 
File Menu........................................................................................................................................................... 213 
Save/Recall Menu Parameters ........................................................................................................................... 213 
Preferences Parameters ...................................................................................................................................... 213 
Measurement Menus.......................................................................................................................................... 214 
Measurement Menu Parameters......................................................................................................................... 214 
Control Panel Parameters................................................................................................................................... 214 
Common Configuration Parameters .................................................................................................................. 215 
Configure Power Dissipation Parameters .......................................................................................................... 216 
Configure B-H Analysis Parameters.................................................................................................................. 217 
Configure Total Loss Parameters....................................................................................................................... 218 
Configure SOA Parameters................................................................................................................................ 219 
Configure Dynamic Resistance Parameters....................................................................................................... 219 
SOA Mask.......................................................................................................................................................... 219 
Configure di/dt Parameters ................................................................................................................................ 219 
Configure dv/dt Parameters ............................................................................................................................... 220 
Configure Power Quality Parameters ................................................................................................................ 220 
Configure Current Harmonics Parameters......................................................................................................... 220 
Configure Total Power Quality Parameters ....................................................................................................... 221 
Configure Ripple Line Parameters..................................................................................................................... 221 
Configure Ripple Switching Parameters............................................................................................................ 222 
Configure Turn-On Time Parameters ................................................................................................................ 222 
Configure Pulse Width Modulation Parameters ................................................................................................ 222 

TDSPWR3 Software Analysis Printed Help Document           vii 



Table of Contents 

Configure Clock Period Modulation Parameters ...............................................................................................223 
Configure Duty Cycle Modulation Parameters ..................................................................................................223 
Configure Frequency Modulation Parameters ...................................................................................................223 
Configure Spectral Analysis ..............................................................................................................................224 
Results Menu......................................................................................................................................................224 
Utilities Menu ....................................................................................................................................................224 
Deskew-Static Deskew ......................................................................................................................................224 
Real Time Deskew .............................................................................................................................................225 
Report Menu ......................................................................................................................................................225 
Help Menu..........................................................................................................................................................225 

Measurement Algorithms....................................................................................................................................225 
About Measurement Algorithms........................................................................................................................225 
Oscilloscope Setup Guidelines...........................................................................................................................225 
Power Dissipation ..............................................................................................................................................226 
B-H Analysis......................................................................................................................................................230 
Total Loss...........................................................................................................................................................232 
Safe Operating Area...........................................................................................................................................232 
Dynamic Resistance ...........................................................................................................................................234 
di/dt ....................................................................................................................................................................234 
dv/dt ...................................................................................................................................................................235 
Power Quality ....................................................................................................................................................235 
Current Harmonics .............................................................................................................................................238 
Total Power Quality ...........................................................................................................................................239 
Ripple Line and Ripple Switching .....................................................................................................................239 
Turn-On Time ....................................................................................................................................................240 
Modulation Analysis ..........................................................................................................................................240 
Clock Period and Frequency Modulation ..........................................................................................................240 
Spectral Analysis................................................................................................................................................242 

APPENDIX........................................................................................................................................... 245 

Appendix A ...........................................................................................................................................................245 
For P5205 probe.................................................................................................................................................245 
For TCP202 probe..............................................................................................................................................245 

Appendix B ...........................................................................................................................................................246 

GLOSSARY ......................................................................................................................................... 247 

INDEX .................................................................................................................................................. 253 
 

viii                                                                                       TDSPWR3 Software Analysis Printed Help Document                          



General Safety Summary  

General Safety Summary 

Review the following safety precautions to avoid injury and prevent damage to 
the measurement instrument or any products connected to it. To avoid potential 
hazards, use the software and measurement instrument only as specified. 

While using this software, you may need to access other parts of the system. 
Read the General Safety Summary and specification sections in other equipment 
manuals for warnings, cautions, and ratings related to operating the system with 
this software. 

 To avoid Fire and Personal Injury 

Connect and Disconnect Properly. Connect the probe output to the 
measurement instrument before connecting the probe to the circuit under test. 
Disconnect the probe input and the probe ground from the circuit under test 
before disconnecting the probe from the measurement instrument. 

Observe All Terminal Ratings. To avoid fire or shock hazard, observe all 
ratings and markings on the measurement instrument and other equipment used 
with this software. Consult the individual product manuals for further ratings 
information before making connections to the circuit under test. 

Do Not Operate With Suspected Failures. If you suspect there is damage to the 
measurement instrument or other equipment being used with this software, have 
it inspected by qualified service personnel. 

 

Terms in this Manual  

These terms may appear in this manual: 

WARNING. Warning statements identify conditions or practices that could 
result in injury or loss of life. 

CAUTION. Caution statements identify conditions or practices that could result 
in damage to the measurement instrument or other property. 

 

Terms in the Application 

The application displays a caution dialog box warning you to use only 
appropriately rated voltage and current probes when launched from the 
oscilloscope menu. Press OK to start the application. If you do not select Ok, the 
application waits for ten seconds and automatically displays the default screen. 
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Introduction 

 

Introduction 

Welcome 

 
TDSPWR3 is a power measurement and analysis software that runs on TDS5000, 
TDS6000, TDS7000 and CSA7000 series oscilloscopes. TDSPWR3 allows you 
to acquire, measure and analyze various switching power supply signals at 
different test points. The application provides a simple and direct means of 
obtaining results about Switching devices, Magnetic components and 
Precompliance tests to EN 61000-3-2 Std for the Switch Mode Power Supply. 
The features of TDSPWR3 are:  

� 

� 

� 

� 

� 

� 

� 

Power Device Analysis analyzes the switching devices in the power supply 
such as FET  (Field Effect Transistor), BJT (Bi Polar Junction Transistor) 
and IGBT (Integrated Gated Bi Junction Transistor). The measurements 
include Power Dissipation, B- H Analysis, Total loss, Safe Operating Area 
(SOA), SOA Mask test, Dynamic Resistance, di/dt and dv/dt. 

Line Power Analysis measures Power Quality, Current Harmonics and 
Total Power Quality. 

Output Analysis measures Ripple Line, Ripple Switching and Turn-On 
Time. 

Modulation Analysis is trend plot of Pulse Width Modulation, Clock 
Period Modulation, Duty Cycle Modulation and Frequency Modulation with 
cursor gated measurements.  

Spectral Analysis analyses the frequency component that contributes to the 
electromagnetic interference and measures the noise/ripple at the DC output 
voltage.  

A Report Generator tool helps you create and print custom reports. 

Deskew and SOA Overlay utilities. 
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Introduction  

 

To return to the Table of Contents, select Help Topics from the Help 
Topic menu.  

Online Help and Related documentation 

You can access the information on how to operate the application along with the 
oscilloscope through the following related documents and online help. 

 

Using Online Help 

Select Help on the right side of the application menu bar to bring up the help file. 

Tables of Contents (TOC) tab —- organizes the Help into book-like sections. 
Select a book icon to open a section; select any of the topics listed under the 
book. 

Index tab —- enables you to scroll a list of alphabetical keywords. Select the 
topic of interest to bring up the appropriate help page. 

Find tab —- allows a text-based search. Follow these steps: 

1. Type the word or phrase you want to find in the search box. 

2. Select some matching words in the next box to narrow your search. 

3. Choose a topic in the lower box, and then select the Display button. 

To print a topic, select the Print button from the Help Topics menu bar. 

Select Options from the menu bar for other commands, such as to annotate a 
topic, keep the help window on top, or to use system colors. 

Select the Back button to return to the previous help window. Use the Hyperlink 
to jump from one topic to another. If the Back button is grayed out or a jump is 
not available, choose the Help Topics button to return to the originating help 
folder.  

Browse buttons (Next >> and Previous <<) allow you to move forward and 
backward through topics in the order of the Table of Contents (TOC). 

Sometimes you will see the word, Note, in the topic text. This indicates 
important information.  

 

Note: 
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Certain aspects of the online help are unique to applications that run on the 
oscilloscope. 

Green text (with no underlines) indicates a pop-up. Select the green text to 
display a pop-up for a brief help message. Select the help message to return to the 
topic. 

Green-underlined text indicates a jump (hyperlink) to another topic. Select the 
green text to jump to the related topic. For example, select the green text to jump 
to the topic on Online Help and Related Documentation and the Back button to 
return to the topic’s page. 

You can tell when the cursor is over an active hyperlink (button, jump, or 
pop-up), because the cursor arrow changes to a small hand. 

Note: the light bulb and word Tip in the graphic  This graphic indicates 
additional information to help you function more efficiently. 

Printing from Online Help 

Some online help topics have color in the examples of the displayed application. 
If you want to print this type of topic on a monochrome printer, some 
information may not print because of certain colors. Instead, you should print the 
topic from the PDF (portable document format) file that corresponds to the 
Online Help. You can find the file in the Documents directory on the Optional 
Applications Software on Windows-Based Oscilloscopes CD-ROM. The figures 
of application menus in the PDF file are gray scale so the relevant information 
will appear on the printed page. 

Related documentation 

In addition to the Online Help, you can access other information on how to 
operate the oscilloscope through the following related documents: 

� 

� 

� 

� 

Oscilloscope Information: The user manual and user online help for your 
oscilloscope provides general information on how to operate the 
oscilloscope. 

You can download PDF versions of many user manuals from the Tektronix 
Website. 

Programmer Information: The online programmer guide for your 
oscilloscope provides details on how to use GPIB commands to control the 
oscilloscope.  

You can download programmer information and examples from the 
Tektronix Website. 
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Refer to the Optional Applications Software on Windows-Based Oscilloscopes 
Installation Manual for the following information: 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

Software warranty 

Software license agreement 

List of all available applications, compatible oscilloscopes, and relevant 
software and firmware version numbers 

How to apply a new label 

Installation procedures  

How to enable an application 

How to download updates from the Tektronix Website 

You can find a PDF (portable document format) file for this document in the 
Documents directory on the Optional Applications Software on Windows-Based 
Oscilloscopes CD-ROM. The CD booklet only contains information on installing 
the application from the CD and on how to apply a new label. 

Conventions 

Online help uses the following conventions: 

Refers to the TDSPWR3 Power Measurements solution as TDSPWR3 
Application or as the Application or as Power Measurements 3. 

Refers to the configuration panel on the left side of the application as the 
Common Configuration Panel or Configuration Panel. This is common to 
many measurements. 

When steps require a sequence of selections using the application interface, 
the ">" delimiter marks each transition between a menu and an option. For 
example, one of the steps to recall a setup file would appear as 
File>Save/Recall>Recall.  
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Contacting Tektronix 

Phone 1–800–833–9200* 

Address 

Tektronix, Inc. 

Department or name (if known) 

14200 SW Karl Braun Drive 

P.O. Box 500 

Beaverton, OR 97077 

USA 

Website www.tektronix.com 

Sales 

support 
1–800–833–9200, select option 1* 

Service 

Support 
1–800–833–9200, select option 2* 

Technical 

Support 

Email: techsupport@tektronix.com 

1–800–833–9200, select option 3* 

6:00 a.m. - 5:00 p.m. Pacific time 

* This Telephone number is toll free in North America. After office hours, please leave a 
voice mail message.  Outside North America, contact a Tektronix sales office or 
distributor; See the Tektronix web site for a list of offices. 

Feedback 

Tektronix values your feedback on our products. To help us serve you better, 
please send us your suggestions, ideas, or comments on your oscilloscope. 

Direct your feedback via email to  

techsupport@tektronix.com or FAX at (503) 627-5695  

and include the following information. Please be as specific as possible. 

General information: 

� 

� 

� 

� 

Oscilloscope model number and hardware options, if any 

Probes used 

Your name, company, mailing address, phone number, FAX number 

Please indicate if you would like to be contacted by Tektronix about your 
suggestion or comments 

Application specific information: 
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� 

� 

� 

� 

Software version number 

Description of the problem such that technical support can duplicate the 
problem 

If possible, save the oscilloscope and application setup files as .set files 

If possible, save the waveform on which you are performing the 
measurement as a .wfm file 

Once you have gathered this information, you can contact technical support by 
phone or through e-mail. If using e-mail, be sure to enter in the subject line 
"TDSPWR3 Problem," and attach the .set and .wfm files. 
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Getting Started 

Getting Started 

Introduction and Product Description 

TDSPWR3 is a power measurement and analysis software that runs on TDS5000 
(TDS5032, TDS5034, TDS5052, TDS5054, TDS5104), TDS6000 (TDS6404, 
TDS6604) CSA7000 (CSA7154, TDS7404) and TDS7000 (TDS7404, TDS7154, 
TDS7254, TDS7054, TDS7104) series oscilloscopes. TDSPWR3 allows you to 
acquire, measure and analyze various switching power supply signals at different 
test points. The application provides a simple and direct means of obtaining 
results about Switching devices, Magnetic Components and Precompliance tests 
to EN 61000-3-2 Std for the Switch mode Power supply. The features of 
TDSPWR3 are:  
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� 

� 

� 

� 

� 

Power Device Analysis analyzes the switching devices in the power supply 
such as FET (Field Effect Transistor), BJT (Bi Polar Junction Transistor) 
and IGBT (Integrated Gated Bi Junction Transistor). The measurements 
include power dissipation, B-H Analysis, Total Loss, Safe Operating Area 
(SOA), SOA Mask test, Dynamic Resistance, di/dt and dv/dt. 

Line Power Analysis measures Power Quality, Current Harmonics and Total 
Power Quality. 

Output Analysis measures Ripple Line, Ripple Switching and Turn-On 
Time. 

Modulation Analysis measures Pulse Width Modulation, Clock Period 
Modulation, Duty Cycle Modulation and Frequency Modulation.  

Spectral Analysis analyses the frequency component that contributes to the 
electromagnetic interference and measure the noise/ripple at the output DC 
voltage frequency range.  

A Report Generator tool helps you create and print custom reports. 

Deskew and SOA Overlay utilities. 

 



Getting Started 

Compatibility 

The TDSPWR3 application is compatible with the following TDS5000, 
TDS6000 and TDS7000 series oscilloscopes: 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

TDS5032 

TDS5034 

TDS5052 

TDS5054 

TDS5104 

TDS7054 

TDS7104 

TDS7154 

TDS7254 

TDS7404 

TDS6404 

TDS6604 

TDS7154B 

TDS7254B 

TDS7404B 

TDS7704B 

CSA7404B 

CSA7154 

CSA7404 

Measurement dependencies on the number of channels and oscilloscope options: 

To view measurement dependencies on the number of channels: 

Select Help> About TekScope. The oscilloscope displays the channel 
dependencies in the option panel. 
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Table 2-1: Measurements and channel 
dependencies 

Measurement Name 
 

Number of Channels 

Power Dissipation 2 or 4 
B-H Analysis 2 or 4 
Total Loss 4 
Safe Operating Area 2 
Dynamic Resistance   2 
di/dt 1  
dv/dt  1  
Power Quality 2  
Current Harmonics  2  
Total Power Quality 2  
Ripple Line 1  
Ripple Switching 1  
Turn-On time 2 or 4 
Pulse Width Modulation 1 
Duty Cycle Modulation 1 
Clock Period Modulation  1 
Frequency Modulation  1 

Requirements and Restrictions 

The Sun Java Run-Time Environment V1.4.2 must be installed on the 
oscilloscope to operate the TDSPWR3 application. 

Accessories 

The standard accessories of the application are: 

� 

� 

� 

Optional Application Software on Windows-Based Oscilloscope CD-ROM 

Optional Application Software on Windows-Based Oscilloscope Installation 
Manual 

TDSPWR3 Package Reference 
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Current Probes 

The application supports the following probes: 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

� 

TCP202 

TCPA300 with TCP305 

TCPA300 with TCP303 

TCPA300 with TCP312 

TCPA400 with TCP404XL 

AM503 Series with A6312 

AM503 Series with A6303 

AM503 Series with A6302 

AM503B with A6302XL 

AM503B with A6303XL 

AM503B with A6304XL 

AM502B with A6312 

AM502B with A6302 

AM502B with A6303 

Differential Probes 

P5200 

P5205 

P5210 

ADA400A 

The application also supports the Deskew Fixture (Tektronix part number: 067-
1478-xx). 

Note: If you are using external fixtures, to measure Turn-On Time and Ripple, 
enter the external attenuation factor values in Vertical> External Attenuation 
menu of the oscilloscope for correct results. 
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Updates through the website 

You can find information about this and other applications at the Tektronix Inc. 
web site, www.tektronix.com. Check this site for application updates and other 
free applications. 

To install an application update, you will need to download it from the Tektronix 
web site to the oscilloscope hard disk.  

Note: More information about changes to the application or installation is in a 
Readme.txt file on the web site. You should read it before you continue. 

Installation procedures 

Installing the application 

Refer to the Optional Applications Software on Windows-Based Oscilloscopes 
Installation Manual for the following information: 

� 

� 

� 

� 

Installation procedures  

How to apply a new label  

How to enable an application 

How to download updates from the Tektronix web site 

You can find a PDF (portable document format) file for this document in the 
Documents directory on the Optional Applications Software on Windows-Based 
Oscilloscopes CD-ROM. The CD booklet contains information on how to install 
the application from the CD and on how to apply a new label. 

Note: Refer the Probe manual for probe specifications such as bandwidth, 
maximum voltage, maximum current etc. 
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Utilities 

Deskewing Probes and Channels 

To ensure accurate results, deskew the probes before taking measurements from 
your device under test. Refer Appendix for procedural steps to degauss and clear 
the offset before you deskew. 

Note: The deskew range of ± 75ns is supported on TDS5000 series of 
oscilloscopes with firmware version 1.1.2 and above. 

Note: In TDS 7000 series oscilloscopes, if  the skew has been set on the channels, 
the available record length depends on the Time Base and Sampling Rate 
settings. The maximum record length with Option 4 M may reduce to 8M when 
the deskew is enabled at certain combinations of time base and sampling rate. 
 

The application provides you two deskew options. They are: 

� 

� 

Static Deskew  

Real time deskew for the TDS5000 series and TDS7000 series oscilloscopes 
using the internal source and for TDS5000, TDS6000, TDS7000, CSA7000 
series with an external source. 

Note: Connect the probes to the fastest transition while using the external signal 
mode.  

Static Deskew 

Static deskew automatically sets the deskew based on the probe type supported. 
The propagation values of the probes are fixed.You do not need an external 
deskew fixture to deskew the channels. 
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The application supports the following combination between any two-channel 
probes for TDS5000: 

Table 2-2: Probes and skew support

Probe Model Skew in ns 
P5205 17 
P5210  20 
P5100  14.9 
P5050  5.5 
TCP202  17 
TCPA300 with TCP305  19 
TCPA300 with TCP303  53 
TCPA300 with TCP312  17 
TCPA400 with TCP404XL  103 
P6246   7.4ns 
P6247    7.0ns 
P6248   6.5ns 
AM503 Series with A6312  30 
AM503 Series with A6303  55 
AM503 Series with A6302  30 
AM503B with   A6302XL  60 
AM503Bwith   A6303XL  105 
AM503B with    A6304XL  105 

 
The application supports the following combination between any two-channel 
probes for TDS7000, CSA7000 and TDS6000 Series oscilloscopes. 

Table 2-3: Probes and skew support

Probe Model Skew in ns 

P5205  17 
P5210  20 
P5100  14.9 
P5050  5.5 
P6158  5.0 
P6246   7.4ns 

P6247    7.0ns 

P6248   6.5ns 

TCP202  17 
TCPA300 with TCP305  19 
TCPA300 with TCP303  53 
TCPA300 with TCP312  17 
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AM503 Series with A6312  30 

AM503 Series with A6303  55 

AM503 Series with A6302  30 
AM503B with   A6302XL  60 

 

Note: The deskew range for TDS5000 series oscilloscopes above version 1.4.1 
has a range of + or -75ns and TDS 7000 series oscilloscopes has a range of + or 
-25ns. 
 

Follow these steps to perform the Static Deskew: 

1. Select Utilities> Deskew> Static Deskew tab. 

2. In the From panel, select the Source and the corresponding Probe type. 

3. In the To panel, select the Source and the corresponding Probe type. 

 

 

Figure 2-1: Static Deskew 

4. Select the Run button to deskew the selected probe. 

Note: Static deskew can be performed between any two channels of your choice. 
Retain the From panel parameters and change the To panel parameters to 
perform deskew for more than two channels. 

Note: If you are using a Custom probe, the application adjusts the deskew and 
sets the value when you perform static deskew.  
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Deskewing in TDS5000 series Oscilloscope with an 
Internal source 

Use the Aux Output signal (TDS5000) and the Deskew fixture (Tektronix part 
number: 067-1478-xx) to deskew the probes and channels. 

Follow these steps to deskew with an internal source: 

1. Connect the AUX OUT of the oscilloscope to the B side input of the deskew 
fixture to deskew the voltage probe and current probe.  

2. Follow the instructions of the Probe Calibration and Deskew fixture to make 
the connections. 

3. Set up the oscilloscope as follows: 

� 

� 

� 

Use the Horizontal Scale knob to set the oscilloscope to an acquisition 
rate so that there are two or more samples on the deskew edge. 

Use the Vertical Scale and Position knobs to adjust the signals and 
display them on the screen. 

Set the Record Length so that there are more samples for the edges in 
the acquisition. We recommend you to set the record length to 25000 
points. 

4. To start the application from a TDS5000 series oscilloscopes, select File> 
Run Application> Power Measurements 3. 

5. Select Utilities> Deskew> Real Time Deskew> Internal Source. 

6. In the From panel, set the Source to Ch1. The remaining channels are 
deskewed to the Source waveform, which is the reference point. 

7. In the To panel, set the Source to Ch2, the channel to be deskewed. 

8. To start the deskew utility, select the Run button and confirm the operation. 

9. Use Ch1 as the reference point and deskew the remaining channels. 

Figure 2-2 shows an example of a deskew setup. 
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Figure 2-2: Deskew setup 

Figure 2-3 displays the results after deskewing.  
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Figure 2-3: After deskew 

10. The zoomed section of the waveform available on the lower part of the 
screen displays the results of the deskew operation in detail. You will see 
that after performing the deskew operation, the skew is removed.  

Note: The oscilloscope setup is saved before deskew and recalled after deskew. If 
the acquisition setup is in Stop condition before saving the setup, the setup with 
the stop condition is recalled. 

When deskew recalls this setup, the application does not display the waveform. 
To view the waveform, press Run or Stop button in the oscilloscope. 

 

Deskewing in TDS7000, TDS6000 and CSA7000 series 
Oscilloscopes with an Internal source 

In the TDS7000 series oscilloscopes, adjust the deskew between a current probe 
and voltage probe and use the deskew fixture to deskew the channels. 
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Note:We recommend that you use an external signal source to perform real time 
deskew while using P5205 on TDS6000 (TDS6404, TDS6604) CSA7000 
(CSA7154, CSA7404) and TDS7000 (TDS7404, TDS7154, TDS7254) series of 
oscilloscopes. In a TDS7104 and TDS7054 oscilloscopes, use the probe 
compensation signal to deskew with an internal source; use a auxillary output 
signal to deskew the rest of the TDS7000 and TDS6000 series oscilloscopes. 
We recommend that you use a TCA-1MEG adapter for all the recommended 
voltage probes on TDS6000 (TDS6404, TDS6604) CSA7000 (CSA7154, 
CSA7404) and TDS7000 (TDS7404, TDS7154, TDS7254) series of oscilloscopes. 
 

To deskew with an internal source, follow these steps: 

1. Connect the Probe Compensation signal from the oscilloscope to the B side 
input of the deskew fixture to deskew between the voltage probe and current 
probe.  

2. Follow the instructions of the Probe Calibration and Deskew fixture 
(Tektronix part number: 067-1478-xx) to make the connections. 

3. Set up the oscilloscope as follows: 

� 

� 

� 

Use the Horizontal Scale knob to set the oscilloscope to an acquisition 
rate so that there are two or more edges on the deskew edge. 

Adjust the Vertical Scale and Position knobs to adjust the signals and 
display them on the screen. 

Set the Record Length so that there are more samples for the edges in 
the acquisition. We recommend you to set the record length to 25,000 
points. 

4. To start the application from TDS7000 series of oscilloscopes, select File> 
Run Application> Power Measurements 3. 

5. Select Utilities> Deskew> Real Time Deskew> Internal Source. 

6. In the From panel, set the channel Source to Ch1. The remaining channels 
are deskewed to the Source waveform, which is the reference point. 

7. In the To panel, set the channel Source to Ch2, the channel to be deskewed. 

8. To start the deskew utility, select the Run button and confirm the operation.  

9. Use Ch1 as the reference point and deskew the remaining channels. 
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Figure 2:4 shows an example of a deskew setup. 

 

Figure 2-4: Deskew setup 
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Figure 2-5: After deskew 

10. The zoomed section of the waveform available on the lower part of the 
screen in figure 2-5 shows the results of the deskew operation in detail. You 
will see that after performing the deskew operation, the skew is 
automatically removed.  

Note: The oscilloscope setup is saved before deskew and recalled after deskew. If 
the acquisition setup is in Stop condition before saving the setup, the setup with 
the stop condition is recalled. When deskew recalls this setup, the application 
does not display the waveform. To view the waveform, press Run or Stop button 
in the oscilloscope. 

Deskewing in TDS5000, TDS6000, TDS7000 and CSA7000 
series Oscilloscopes with an External source 

In the TDS5000 and the TDS7000 series oscilloscopes, adjust the probe deskew 
between a current probe and voltage probe and use the deskew fixture to deskew 
with an external signal source. 

Note: You need at least one full cycle of waveform on both the channels for 
external deskew. 
 

Follow these steps to deskew with an external source: 

1. Connect an external source to the B side input of the deskew fixture to 
deskew between a voltage probe and a current probe. Follow the instructions 
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of the Probe Calibration and Deskew fixture  
(Tektronix part number: 067-1478-xx) to make the connections. 

2. Set up the oscilloscope as follows: 

� 

� 

� 

Use the Horizontal Scale knob to set the oscilloscope to an acquisition 
rate so that there are two or more samples on the deskew edge. 

Use the Vertical Scale and Position knobs to adjust the signals to and 
display them on the screen. 

Set the Record Length so that there are more samples for the edges in 
the acquisition.  

Note: If you set the number of edges to 1 or there is only a single edge in the 
waveform, set the trigger point to fifty percent to get a complete edge (Low or 
High transition). 
 

3. To start the application from a TDS5000 or TDS7054/TDS7104 
oscilloscopes, select File> Run Application> Power Measurements 3. 

4. Select Utilities> Deskew> Real Time Deskew> External Source. 

5. The channels available for deskew are: 

� 

� 

� 

� 

Ch1 

Ch2 

Ch3 

Ch4 

6. In the From panel, set the Source to Ch1. The remaining channels are 
deskewed to the Source waveform, which is the reference point. 

7. In the To panel, set the channel Source to Ch2, the channel to be deskewed. 

8. In the To panel, set the Reference Level to Ch1. The reference level is the 
percentage level of the waveform from which to take the edges to deskew.  

9. In the To panel, set the Reference Level to Ch2 and set the reference value. 

10. In the From panel, use the GP knob to set the Hysteresis percentage for Ch1. 
Hysteresis ignores the noise level in the waveform.  

11. In the To panel, use the GP knob to set the Hysteresis percentage for Ch 2. 

12. Select the Slope, Rise or Fall, on which to perform the deskew operation.  

13. Select the numbers of edges used for deskew. 

14. To start the deskew utility, select the Run button and confirm the operation.  
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15. Use Ch1 as the reference point and deskew the remaining channels. 

16. This is an acquisition of a square signal at100 KHz, with the Record length 
set to 25,000 points to achieve the sample resolution of 1.6 ns.  

Figure 2:6 shows an example of a deskew setup. 

 

Figure 2-6: Deskew setup 

17. Set the Reference levels for Ch1 and Ch2 in the application to 50%, the 
Hysteresis to 5%, Edges to 1, and the Slope to Rise.  
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Figure 2:7 displays the results after deskewing for multiple edges.  

 

 

Figure 2-7: After deskew setup 

18. The zoomed section of the waveform, available on the lower part of the 
screen, shows the results of the deskew operation in detail. You will see that 
after performing the deskew operation, the skew is automatically removed.  

Note: We recommend that you use the external signal source for performing 
dynamic deskew. 

 

Deskewing using a Power Deskew Fixture 

The Power Measurements Deskew Fixture with Tektronix part number (067-
1478-00), supports up to 150 A AC/DC current probes.  

Follow these steps to deskew: 

� 

� 

A TDS5000 series of oscilloscopes with an internal source: Connect the 
AUX OUT of the oscilloscope to the J1, J2 (Cal signal input) input of 
the deskew fixture to deskew the voltage probe and current probe. 
Follow the steps 2-11 in the topic Deskewing in TDS5000 series 
oscilloscope with an internal source to complete the procedure. 

A TDS7000 (TDS7104, TDS7404) series of oscilloscopes with an 
Internal source: Connect the AUX OUT of the oscilloscope to the J1, J2 
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(Cal signal input) input of the deskew fixture to deskew the voltage 
probe and current probe. Follow the steps 2-10 in the topic Deskewing 
in TDS7000, TDS6000 and CSA7000 series Oscilloscopes with an 
Internal source to complete the procedure. 

Note: We recommend that you use an external signal source to perform real time 
deskew while using P5205 on TDS6000 (TDS6404, TDS6604) CSA7000 
(CSA7154, CSA7404) and TDS7000 (TDS7404, TDS7154, TDS7254) series of 
oscilloscopes. In a TDS 7104 and TDS7054 oscilloscopes, use the probe 
compensation signal to deskew with an internal source; use a auxiliary output 
signal to deskew the rest of the TDS7000 and TDS6000 series oscilloscopes. 

 

� A TDS5000, TDS6000, TDS7000 and CSA7000 series of oscilloscopes 
with an External source: Connect the AUX OUT of the oscilloscope to 
the J1, J2 (Cal signal input) input of the deskew fixture to deskew the 
voltage probe and current probe. Follow the steps 2-18 in the topic 
Deskewing in TDS5000, TDS6000, TDS7000 and CSA7000 series 
Oscilloscopes with an External source to complete the procedure. 

 

SOA Overlay 

Utilities> SOA Overlay 

Note: Select the Save Data button in the SOA results window to save the plot as a 
.plt file before using this utility. 

Purpose: Plot, view and compare SOA Plots of the device operating at different 
load conditions. The SOA Overlay utility helps you to overlay multiple SOA 
plots simultaneously. You can use this feature to view multiple plots on the same 
grid.  

Initially, the application adjusts the SOA scale according to the selected plot(s); 
but you can also observe the plot for the voltage and current range of operation 
under different conditions.  

TDSPWR3 Software Analysis Printed Help Document           27 



Utilities 

 

Figure 2-8: SOA Overlay 

 

The Y Max, Y Min, X Max and X Min gives you the flexibility to set up 
different operating voltage and current range to view the plot(s). The X axis 
represents the voltage values in volts and the Y axis represents the current in 
amperes. 

Follow these steps to perform SOA Overlay: 

1. Click the Load Recent button to automatically load the SOA plots saved in 
the current run of the application. You can load only the last ten plots. Select 
the Load Manually button to manually load the SOA plots from any folder 
or from the default folder C:\TekApplications\TDSPWR3\SOA\Data 
directory. You can load any of the ten plots. You can use the  Shift or the 
Control key to select multiple plots. 

2. Click the selection button (For example:  ) next to the plot name to 
display the SOA plot on the grid area of the screen. When the utility 
displays the first plot,  it automatically scales the plot. Continue this 
procedure to overlay and display all the plots. SOA Overlay displays the 
plot based on the color set in the Plot Name pane. The most recently 
selected plot is drawn over the previously selected plots. You can 
simultaneously view and compare different SOA plots under multiple 
conditions. You can change the XY limits to view the plot at a different 
scale. 

3. Click on the Plot selection button (For example:  ) to remove the plot 
from the grid area. 
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4. Click the Clear button to display the message,"Do you want to clear the 
Plots? Press the Yes button to clear." Select Yes to clear the plots from the 
grid area. 

5. Select the Save Plot and Legend button to save the plot as a .jpg file to any 
folder of your choice or to the default folder 
C:\TekApplications\TDSPWR3\Images. 

6. Select OK to close the display window. 
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Application Interface 

The application uses a Windows interface.  

Note: The oscilloscope application shrinks to half size and appears in the top 
half of the display when the application is running. 

Application Interface Menu Controls 

The table 3-1 lists the application interface menu controls. 

Table 3-1: Application Interface menu controls 

Item Description 
Menu bar  Located at the top of the application that displays and contains application 

menus 
Tab  Labeled group of options containing similar items  
Area  Enclosed visual frame with a set of related options 
Option button  Button that defines a particular command or task 
Drop Down List box  Box that contains a list of items from which you can select one item 
Field  Box that you can use to type in text, or to enter a value with the Keypad or a 

Multipurpose knob 
Check Boxes  Square box that you can use to select or clear preferences 
Scroll bar  Vertical or horizontal bar at the side or bottom of a display area that can be 

used for moving around in that area 
Browse  Displays a window where you can look through a list of directories and files 
Command button  Button that initiates an immediate action 
Keypad  Appears when you select the box and enter a value 
MP/GP knob  Select the multipurpose (MP or GP) knob to display a line between the knob 

and the box; turn the knob on the oscilloscope to select a value 
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Basic Application Functions 

Using Online Help 

You can use the application Help menu to access information about the 
oscilloscope. You can also use other oscilloscope functions and easily return to 
the application. 

The application includes Online Help about the menus and controls.  

To display the Online Help, follow these steps: 

1. Choose the Help> Help Topics menu from the TDSPWR3 menu bar. 

2. Use the Contents, TOC, or Index tabs to navigate through the help.  

3. In the TDS7000 series oscilloscopes, the touch screen mode of operation is 
enabled by default. You can disable this by using the Touch Screen OFF 
button in the front panel of the oscilloscope. In the TDS5000 series 
oscilloscopes, the touch screen mode of operation is optional. 

Minimizing and Maximizing the Application Window  

The application appears even when you minimize the oscilloscope. To minimize 
the application, select File> Minimize. 

To maximize the application, select TDSPWR3 in the Windows toolbar. 

To hide the application, select the Hide button . 

The Report Generator application windows are independent of the TDSPWR3 
application. Select the minimize button on the right hand corner of the relevant 
report generator screen to minimize it. 

Application Directories and File Names 

The application uses directories to save and recall setup files and uses file name 
extensions to identify the file type. 
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The table 3-2 lists default directory names. 

Table 3-2: Application directories and file names 

Directory Used For 
C:\TekApplications\TDSPWR3\setup  Stores the application setup files 
C:\TekApplications\TDSPWR3\images  Stores the images of the plot in .jpg format 
C:\TekApplications\TDSPWR3\Waveforms  Stores the waveforms used for the tutorial 
C:\TekApplications\TDSPWR3\Currentharmonics  Stores the impedance value tables and the limit tables in

Current Harmonics and Total Power Quality 
Measurements 

C:\TekApplications\TDSPWR3\ReportGenerator\Templates  Stores the default templates 
C:\TekApplications\TDSPWR3\ReportGenerator\Layouts  Stores the default report layouts 
C:\TekApplications\TDSPWR3\ReportGenerator\Reports  Stores the default reports 
C:\TekApplications\TDSPWR3\Images\SOA.jpg  Stores the image file of the plots 
C:\TekApplications\TDSPWR3\soa\data\*.plt Stores the SOA data as a plot file 
C:\TekApplications\TDSPWR3\currentharmonics\log  Stores the results of the Current Harmonics and Total 

Power Quality in .csv format 
C:\TekApplications\TDSPWR3\soa\masks  Stores the mask file in .msk format 

 

  

File Name Extensions 

The table 3-3 lists the file name extensions. 

Table 3-3: File name extensions 

Extension Description 
.csv  Is a file that uses a “comma separated variable” format 
.ini  Is a application setup file 
.set  
 Is a oscilloscope setup file saved and recalled with an .ini file; both the files will have the same file name 

.wfm  Is a waveform file that can be recalled into a reference memory 

.rgt  Is a customized Report Generation file format which indicates the template files 

.rpl  Is a customized Report Generation file format which indicates the defined layout files 

.plt Is a SOA data file format 

.rpt  Is a customized Report Generation file format, which indicates the generated report 

.jpg  Is the format of the image file of the various plots 

.smk  Is the format of the SOA mask file 
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Returning to the Application 

When you access oscilloscope functions, the oscilloscope fills the display. You 
can access oscilloscope functions in the following ways:  

� 

� 

Choose the Menu bar or the Toolbar mode on the oscilloscope and access 
the menus. 

Press front-panel buttons. 

To return to the application, choose the App button on the top right hand side of 
the oscilloscope.  

Exiting the Application 

To exit the application, select the Exit button or File> Exit or select the icon  
from the right hand corner of the application.  

Note: Do not use other methods to exit. This will result in abnormal termination 
of the application. 
 

To stop taking measurements, select the Stop button.  

In the TDS6000 (TDS6404, TDS6604) CSA7000 (CSA7154,7404) and 
TDS7000 (TDS7404,TDS7154,TDS7254, TDS7054, TDS7104), TDS5054, 
TDS5032, TDS5034, TDS5052, TDS5104 series oscilloscopes, when you exit 
the application, you can select to keep the oscilloscope setup currently in use 
with the application or restore the oscilloscope setup that was present before you 
started the application. 

 

Figure 3-1: Exiting the application 

Setting up TDSPWR3 to take Measurements 

Setting Up the Software 

You can set up the application to take measurements. In addition, you can view 
the results as a plot wherever applicable or use the report generator to generate a 
detailed report. 
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Select File> Preferences> Acquisition alert message. You can check this option 
to display the pop-up message "Have you acquired the waveform?" when you 
press the Run button to take measurements. By default, the acquisition alert 
message is unchecked. 

There are twenty seven measurements in four tabs. 

Table of Options-Common Configurations 

Table 3-4: Table of options-common configurations 

Area Option Description 
Common Configuration Panel   

Ref 
Reference waveform used as source to 
perform measurements. The options are; Ref1 
to ref4. 

Common Configuration Panel   

Live 

Live waveform used as the source. You can 
select the channel source, Ch1-Ch4 or Math1-
Math4 for the selected measurement  
Note: In two channel oscilloscopes, you can 
select only Ch1-Ch2. 

Common Configuration Panel   Voltage, Current You can assign the voltage and the current 
channel for the selected measurement. Select 
the Current Source Ch1-Ch4 for the Live 
selection, Ref1- Ref4 for the Ref Selection. 
Selection of Ch3 and Ch4 and Ref3 and Ref4 
depends on the number of channels of the 
oscilloscope. 
Select the Voltage Source Ch1-Ch4 and 
Math1-Math4 for the Live selection and Ref1-
Ref4 for the Ref selection. Selection of Ch3 
and Ch4 and Math3 and Math4 depends on 
the number of channels of the oscilloscope. 

Common Configuration Panel   Deskew Deskew the probes. The deskew types are 
Static and Real Time .  

I-Probe Settings Probe Settings Configures the selected current probe to:  
• 
• 
• 
• 

TCP Series 
Current Shunt 
Custom (Third party probes) 
AM503S Settings 

I-Probe Settings  AM503S Settings-
Probe Type  

Sets the probe type and range if the probe 
belongs to AM503S. The probe types are: 
• 
• 
• 

A63x2 
A6303/XL 
A6304/XL 

AM503S Settings-Range   AM503S Settings-
Range 

Sets the range for the probe selected:  
• A63x2-1 mA to 5 Amp Range:1 ma, 2 mA, 

5 mA, 50 mA,100 mA, 200 mA,500 mA,1 
A,2 A,5 A 

A6303-5 mA to 50 A Range:10 mA, 50 mA, • 
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100 mA, 200 mA, 500 mA, 1 A, 2 A, 5 A, 
10 A, 20 A, 50 A 

• 

• 

A6304-500 mA to200 Amp Range:500 mA, 
1 A, 2 A, 5 A, 10 A, 20 A, 50 A, 100 A, 
200 A 

A6303/XL (only for TDS5000 series)-500 
mA to 200 Amp Range:500 mA, 1 A, 2 A, 
5 A, 10 A, 20 A, 50 A, 100 A, 200 A 

 

Area Option Description 
Current Shunt Sets the transfer 

impedance value in ohms 
to configure current shunt. 
The acceptable current 
shunt range values are 1 
mohm to 10 ohms 

Custom Sets the scale factor and 
propagation delay of  non 
Tektronix probes. The 
acceptable range of the 
scale factor values are 100
p to 10 G. The acceptable 
range of the propagation 
delay factor values are  0 s
to 150 ns. 

I-Probe Settings   
 

TCP Series Sets a direct connection to 
the TCP series (TCP 202, 
TCPA with TCP series) of 
probes. The application 
does not provide any 
configuration parameters 
for this series. 

Table of Measurements and Configurations-Power 
Device Analysis 

Table 3-5: Table of Measurements and Configurations-Power Device 
Analysis 

Measurement   SubType/Configurations Description 

Select Power Device Analysis 
Safe Operating Area (SOA)  Measures and plots the voltage versus the current plot 

of a power semiconductor device and indicates the 
operating region of the device. 

SOA   
 

SOA Normal Plots the Voltage and Current waveform in a single 
record in XY mode. The Enable Mask check box is 
enabled only for SOA Normal. You can use the Mask 
Editor to apply the mask to the SOA Plot only for SOA 
Normal option. 
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 SOA Gated Plots a selected section of the Voltage and Current 
waveform between the cursor. 

SOA DPO Plots the voltage and current waveforms using the XY 
mode display of the oscilloscope. Use this option to 
measure multiple acquisitions of the same waveform in 
real time testing. 

Power Dissipation  
 

Analyses the power dissipated in the switching cycles 
across a switching device. 

Switching Loss Measures the instantaneous minimum and maximum 
average energy consumed across the switching device. 
The loss is measured on each cycle of the acquired 
waveform. The results include minimum, maximum and 
the average loss and energy for the complete cycles in 
a single record. 

Power Dissipation   
 

Hi Power Finder Measures the Peak value of Power dissipated at the 
device for each switching cycle. This includes the 
switch finder that enable you to traverse to the 
switching portion of the waveform in the entire record. 
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Measurement   SubType/Configurations Description 
Ref Level  Defines the level at which the edge on a selected 

waveform is identified to  measure the 
instantaneous peak power value. 

Hysteresis Defines the tolerance band to identify the correct 
edge at the specified ref level. 

Percentage, Absolute Sets the Ref Level, Hysteresis, High and Low 
values either in percentage of the pk-pk level or 
the absolute value of the waveform selected in the 
edge source. 

Power Dissipation  
 

Waveform Destination Defines the creation of a Power Waveform using 
the specified math waveform (Math1-Math4) on 
the oscilloscope. 

Dynamic resistance  
 

Measures the resistance offered by the switching 
device during its ON condition. 

Real Time Math Destination 
Sets the destination of the math waveform with a 
function of V/I ( selected channel for V and 
selected channel of I). 

Dynamic resistance  
 

Average Math Destination Sets the average math destination of Math1. 
di/dt Measures the differentiation of the current di/dt 
dv/dt Measures the differentiation of the voltage dv/dt 
di/dt,dv/dt   Math Destination Sets the destination of the math waveform with 

the differential function of the current waveform. 

Ref Level 
Defines the level at which the edge on a voltage 
waveform for dv/dt and current waveform for di/dt 
is identified. 

Hysteresis Defines the tolerance band to identify the correct 
edge at the specified ref level. 

di/dt, dv/dt 
 

Percentage, Absolute 
Sets the Ref and Hysteresis level either in 
percentage of the pk-pk level or the absolute 
value of the pk-pk value of the waveform selected 
as the edge source. 
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Measurement SubType/Configurations Description 
B- H Analysis  B- H Analysis  

 
Monitors and measures the parameter 
associated with a magnetic component. The 
available options are:Magnetic Loss, Inductance, 
I vs Integral V Plot and Magnetic Property. 

 I vs Integral V Plot  Plots the integral of the voltage waveform and 
the current waveform in a XY plot. Integral of V 
is proportional to B and the current waveform I is 
proportional to H. 

Magnetic Loss Measures the power loss at the magnetic 
component. 

Magnetic Property Measures the parameters related to the 
magnetic material properties in the magnetic 
component used in an in-circuit operation. 

B H Analysis 
 

Inductance Measures the inductance of the DUT (inductor) 
and displays the proportion (B-H) curve plot with 
the inductance value. 

Total Loss  
 

Measures the magnetic and switching loss 
simultaneously. This is applicable only for four 
channel oscilloscopes. 

Total Loss  
 

Switching Loss 
Measures the power loss during the switching on 
the Power waveform during fall time and rise 
time of voltage across the device. 

 

Measurement   SubType/ 
Configurations 

Description 

Probe settings Configures the selected current probe settings for: TCP Series, 
Current Shunt, Custom and AM503S Settings. 

Magnetic Loss Measures the power loss across the inductor or the transformer. 
Hysteresis Defines the band limit for the edge and prevents a false edge. 

Ref Level Defines the level at which the edge on a voltage waveform is identified 
to measure the switching area. 

Percentage Sets the percentage value of the Ref, Hysteresis, High and Low.  
Absolute Sets the absolute value of the Ref, Hysteresis, High and Low levels. 

Total Loss  
 
 

Math Destination Sets the math destination for switching loss and magnetic loss. 
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Table of Measurements and Configurations-Line Power 
Analysis 

Table 3-6: Table of Measurements and Configurations-Line Power Analysis 

Measurement   SubType/ 
Configurations 

Description 

Select Line Power Analysis 
Power Quality  Measures and displays the: 

• 
• 
• 
• 
• 
• 
• 

Root mean square value for Voltage 
Root mean square value for Current 
True Power 
Apparent Power 
Power Factor 
Crest Factor for Voltage 
Crest Factor for Current 

Energy Waveform 
Destination 

Enables the energy waveform based on the math option available on 
the oscilloscope. 

Power Quality   
 

Power Waveform 
Destination Enables the power waveform and creates the math waveform. 

Harmonic Table Captures the predefined limit values for the harmonics. This will be 
used to compare the measured value of the harmonics. 

I Probe Table The impedance of the current probe at the frequency can be edited in 
this table. This is used to calculate the current harmonics value. In the 
default state, I-probe is not enabled. 

Configure to IEC Standard Sets the limit table based on the class categories of the unit under test 
and updates the selected table with the standard values. Configures 
to the different classes of equipment like:  
• 

• 
• 
• 

Class A-Balanced three phase equipment and all other equipment 
except that stated in one of the following classes 

Class B-Portable tools, arc welding equipment 
Class C-Lighting equipment including dimming devices  
Class D-Equipment with an input current of a "special wave shape” 

and an active input power of P600W  
AM 14 Sets the line frequency and the limit table based on the Class 

categories. The Controls option is applicable only for Class C and D. 
These values will be verified by the application if the calculated Power 
Factor, Input Power and the Fundamental Current are within ten 
percent range of the manufacturer's rating entered in the Control field. 

MIL 1399 Sets the line frequency to 60 Hz or 400 Hz. 
Controls Displays the Input Power, Power Factor and Fundamental Current 

values for Class C. 
Displays the Input Power values for Class D. 

Filter Smoothens the result current harmonics. 

Current Harmonics   
 

Signal Type Measures the frequency of the line operation. They can be of two 
types: 50 Hz or 60 Hz for IEC 61000-3-2 Standard and 60 Hz Line or 
400 Hz line for MIL 1399 standard. 
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Harmonics Displays the user configurable features like harmonic table and group 
classification. 

 

Measurement   SubType/ 
Configurations 

Description 

Total Power Quality  Total Power Quality  Measures and displays: 
• 
• 
• 
• 
• 
• 
• 

Root mean square value of the current and voltage  
True power  
Apparent power 
Crest factor of current and voltage, Current harmonics 
Power factor 
Total harmonic distortion 
It is a combination of Power Quality and Current Harmonics 

measurement. 
Signal Type Measures the operating line frequency- They can be of two types: 

50 Hz or 60 Hz for IEC 61000-3-2 Standard and 60 Hz Line or 400 
Hz line for MIL 1399 standard. 

Harmonics Displays the user configurable features like Harmonic Table and 
Group Classification. 

Harmonic Table Captures the limit values for the harmonics which are used to 
compare the measured value of the harmonics. 

Total Power Quality   
 

Configure to IEC Standard  Allows you to select the limit table based on the Class categories 
of the unit under test. The selected table is updated to the standard 
values. For Class C and D, the application automatically calculates 
and the updates the limits table before comparing the harmonic 
results. 

I Probe The impedance of the current probe and the frequency can be 
edited in this table and is used to calculate the current harmonics 
value. In the default state, I-probe is not enabled. 

I Probe Impedance Table Measures the frequency response of the entire 
current probe system on the current harmonics measured value.  

Total Power Quality   
 

Waveform Destination Creates the power waveform and energy at the selected math 
destination. 
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Table of Measurements and Configurations-Output 
Analysis 

Table 3-7: Table of Measurements and Configurations-Output Analysis 

Measurement   Sub Type/Configurations Description 

Select Output Analysis 

Ripple Line  Ripple Line  
 

Measures the: 
• 
• 

AC component voltage present on a DC   
Low frequency AC voltage in the peak to peak voltage. Sets the 

time base to measure the Ripple at line Frequency to 50 Hz, 
60 Hz or 400 Hz 

Coupling  Selects the in built coupling on the oscilloscope based on two 
options: AC Coupling and DC Coupling. 

Bandwidth Removes the high frequency component on the signal. There are 
three bandwidth options: 20 MHz, 150 MHz and Full. Select 200 
MHz for TDS7000 series of oscilloscopes, 150 MHz for TDS5000 
series oscilloscopes. Full is the maximum bandwidth available in 
the oscilloscope. 

Acquisition Mode Types of acquisition modes are:  
• 
• 
• 

Peak Detect  
Hi Resolution 
Sample 

High Resolution Measures the average sample taken during an acquisition interval 
to create a record point. This results in a higher-resolution, lower-
bandwidth waveform with a real-time, non-interpolated sampling. 

Ripple Line  
      

Pk Detect  Works only with real-time, noninterpolated sampling. The 
acquisition alternates between saving the highest sample in one 
acquisition interval and lowest sample in the next acquisition 
interval. 

 Measures the maximum AC voltage present on a DC 
 

Ripple Switching  
 

Coupling Sets the in built coupling on the oscilloscope to: AC Coupling or 
DC Coupling. 

 
 

Measurement   SubType/ 
Configurations 

Description 

Bandwidth There are three bandwidth options: 20 Mhz, 150 Mhz and Full. 
Select 20 Mhz for TDS7000 series of oscilloscopes, 150 Mhz for 
TDS5000 series of oscilloscopes. Full is the maximum bandwidth 
available in the oscilloscope. 

Ripple Switching   
 

Switching Frequency Uses the GP knob to enter the switching frequency values. Min: 50 
Kz, Max: 1 MHz, Default: 10 KHz. 
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Acquisition Mode Sets the oscilloscope acquisition mode which are set to: 
• 
• 
• 

Pk Detect   
Hi Resolution  
Sample 

Peak Detect  Measures the amplitude (voltage) difference between the maximum 
and minimum amplitude. 

 

 
 

Measurement   SubType/ 
Configurations 

Description 

Turn On Time Configuration  
 

Measures the time delay difference between the input voltage 
applied to the system and the time to develop the steady state 
output voltage. 

Line Voltage Measures the Ref to measure the start of turn on time. 

Line Voltage Source Selects the channel  and connects the line voltage or the input 
voltage to the selected channel in the oscilloscope. 

Maximum Line Voltage  Measures the input voltage as a RMS value of AC or DC. 
Trigger Voltage Sets the trigger level for the line voltage source. 

Output Voltages  
Configures the parameters to select the oscilloscope channel, which 
is to be connected to the output voltage of the unit under test. The 
Output 2 and 3 panes are enabled for four channel oscilloscopes. 

Maximum Value  Measures the maximum output voltage of the unit under test 
connected to the selected channel. 

Max Turn on Time  Measures the time taken by the unit under test to develop a stable 
output voltage after applying input voltage. 

Turn On Time Configuration   
 

Converter Selection  Measures the operating input line frequency AC-DC or DC-DC. 
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Table of Measurements and Configurations-Modulation 
Analysis 

Note: Enable Gated Measurement option is common to all the Modulation 
Analysis measurements. If you select this check box, the application analyzes the 
selected portion of the waveform between the cursors. 

 

Table 3-8: Table of Measurements and Configurations-Modulation Analysis 

Measurement   Sub Type/Configurations Description 
Select Modulation Analysis 

Pulse Width Modulation  
Pulse Width Modulation 

Is a trend plot of the pulse width variation for the acquired 
waveform. It is the time difference between the leading and the 
trailing edge of a pulse.  

Mid Defines the required edge level in percentage or volts. 

Hysteresis Defines the tolerance band used to identify the correct edge at the 
specific Ref level. 

Positive Defines the positive pulse width. 

Pulse Width Modulation   
 

Negative Defines the negative pulse width. 

Clock Period Modulation Is a trend plot of the variation of the period measured from a 
leading edge to a leading edge or a trailing edge to a trailing edge. 

Mid Measures the required edge level in percentage or volts. 

Hysteresis Defines the tolerance band used to identify the correct edge at the 
specific Ref level. 

Rise Measures the time from the leading edge of the waveform to the 
next leading edge. 

Clock Period Modulation  
   

Fall Measures the edges from the trailing edge of the waveform to the 
next trailing edge. 

Duty Cycle Modulation Measures the duty cycle of the waveform and is a trend plot. The 
duty cycle can be a positive or a negative duty cycle. 

Mid Defines the required edge level in percentage or volts. 

Hysteresis Defines the tolerance band used to identify the correct edge at the 
specific Ref level. 

Positive Measures the positive pulse width. 
Negative  Measures the negative pulse width. 
Rise Measures the edges from the leading edge of the waveform. 

Duty Cycle Modulation  
 

 Fall Measures the edges from the trailing edge of the waveform. 
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Measurement   SubType/ 

Configurations 
Description 

Frequency Modulation  Frequency Modulation Is a trend plot of the variation of the frequency of the signal. 
Mid Defines the required edge level in percentage or volts. 

Hysteresis  Defines the tolerance band used to identify the correct edge at the 
specific Ref level. 

Rise Measures the edges from the leading edge of the waveform. 

Frequency Modulation   
 

Fall Measures the edges from the trailing edge of the waveform. 
 

Table of Measurements and Configurations-Analysis 
Tools 

Table 3-9: Table of Measurements and Configurations-Analysis Tools 

Measurement   Sub Type/Configurations Description 
Select Spectral Analysis 
Spectral Analysis  Analyzes, measures and displays the frequency component in a 

signal based on the selected Start, Stop and RBW values. 
Source Connects the input source for spectral analysis. 
Frequency Start-Stop Defines the frequency range for which the input signal is analyzed. 
Window Type Specifies the window type to reduce the spectral leakage when 

using the spectral analysis tool. The available window types are: 
Rectangular, Hamming, Hanning, Black-Harris, Gaussian, Flattop2,
Kaiser-Bessel and TekExp.   

Auto Setup Makes the horizontal setup to capture all the frequency component 
in a signal based on Start, Stop and RBW values. 

DC Block Removes the DC component by adding the offset and adjusting the
vertical sensitivity. 

Spectral Analysis 
 
 

RBW Displays the resolution and bandwidth values based on the Start, 
Stop and Window Type inputs defined by you. 
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Taking a New Measurement 

About Taking Measurements 

To take measurements: 

1. Connect the required voltage and the current probe to the unit under test. 

2. Set the Current source and the Voltage Configuration source on the 
configuration panel. 

Note: If you select a reference waveform as the source, you will need to recall 
and display the waveform before the application can take a measurement.  

Note: When you run any measurement, Equivalent time and Sampling mode in 
the oscilloscope should be set to OFF state. 
 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Note: If you are acquiring the long record waveform with a average mode of 
acquisition, select File> Preferences> Acquisition Alert Message, acquire the 
waveform before running the measurement. If you have acquired the waveform 
before running the measurement use Single No Acq Mode to run the 
measurement. 

Acquiring Data 

You can set the oscilloscope settings, acquire the waveform and run the selected 
measurements. However, when you select the source as Live in the common 
configuration panel and if you have selected File> Preferences> Acquisition 
Alert Message, the application prompts a message to check whether you have 
acquired the waveform.  

Follow these steps to acquire the data from live signals: 

1. In the common configuration panel, select Live as the source.  

2. Set the source to Live in the common configuration panel. 

3. Press Run to display the message, "Have you acquired the waveform?"  
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Figure 3-2: Acquire data 

Note: The message "Have you acquired the waveform?" appears only in the first 
instance if you select the Free Run mode. This message will not appear for SOA 
DPO, Ripple and Ripple Switching measurements. 

Note: Do not disturb any oscilloscope settings during measurement analysis. Any 
disturbance may result in unexpected behavior of the application. 

4. Select Yes to run the measurement and display the results. Select No to 
revert the application to the ready status. 

Analyzing the Results 

You can select and run the measurements to display the results after analyzing 
the acquired waveform. You can also refer to Viewing Results for the different 
measurements and use the Report Generator tool to create customized reports. 

Selecting a Measurement 

To take a measurement, select Measurement> Select, which is the default 
opening screen in the application.  

There are four categories of measurements: Power Device Analysis, Line Power 
Analysis, Output Analysis, Modulation Analysis and Analysis Tools.  

The measurements for the different categories are: 

 

Table 3-10: Table of Measurements and Configurations-Line Power 
Analysis 

Power Device Analysis Line Power 
Analysis 

Output Analysis Modulation Analysis Analysis Tools 

Power Dissipation   Power Quality Ripple Line  Pulse Width Modulation Spectral Analysis 

B- H Analysis    Current Harmonics Ripple Switching Clock Period 
Modulation  

Total Loss    Total Power Quality Turn on Time Duty Cycle Modulation  
SOA   Frequency Modulation  
Dynamic Resistance      
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di/dt      
dv/dt    

 

Select the measurements and configure the application based on waveform 
source, voltage, current and probe settings.  

Common Configuration Panel 

The configuration panel on the left side of the screen has the common 
configuration options: Source, Voltage, Current, Deskew and I-Probe Settings.  

Follow the steps to configure the options in the common configuration panel: 

 

Figure 3-3: Common configuration panel 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

1. Select the Ref option to use the reference waveform of the oscilloscope. 
Select the Live option to acquire the waveform from the unit under test. 
When you select the Ref option, deskew and I-Probe Settings are disabled. 
The default selection is Live. 

� If you select the Live source, the default Voltage source is Ch1 and the 
Current source is Ch2. The available selections are: Ch1, Ch2, Ch3, 
Ch4, Math1, Math2, Math3 and Math4. The Math selections are 
available only if you select Live and not Ref. Click here for information 
on what the application does if you select the Math option. Use the 
drop down arrow in the Voltage and the Current field to select specific 
channels. In Ripple Line and Ripple Switching measurement, you can 
select only Live source. The available selections are: Ch1, Ch2, Ch3 
and Ch4. You do not have the Math selections here. When the Current 
field is disabled, the I-Probe settings button is also disabled. 
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� If you select the Ref option, the default Voltage source is Ref1 and the 
Current source is Ref2. You can also use the drop down arrow in the 
Voltage and the Current field to select specific channels.  

Note: When Math is chosen as voltage source, it should be independent of the 
selected math destination. The math destination will be defined with a predefined 
function only if the selected math destination is independent of any selected 
measurement or any math definition. 

Note: You cannot select the same channel source in the Voltage and Current 
field. Example: If you select Ch1 in the Voltage field and Ch1 in the Current field 
and select Run, the application displays an error message "Conflict in selection 
of voltage source and current source." The Voltage and Current source selection 
is dependent on the measurement selected. 
In TDS5052 two-channel oscilloscope, only two channels are available for Ref 
and Live configurations. 
 

2. Select the Deskew option to deskew the signal if necessary. The application 
disables the deskew button if the Ref waveform is used and the source is 
changed to ref. 

3. Select the I-Probe settings option to configure the probe settings to display 
the default TCP Series settings screen. In the Select Type panel, select 
Current Shunt, Custom and AM503S Settings to display the configuration 
screens. Select the TCP Series button if you are using TCP series probes. 
Click on the highlighted area in the next figure to display the configuration 
screens. 

 

Figure 3-4: I-probe settings 
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Note: If you are using a TCA-1Meg probe, terminate the input side with 50 Ohms 
for the current probes that does not automatically change the termination. If you 
are using a TCA to BNC probe, you do not have to terminate the input side.  

Math Setup 

Follow these steps to configure the Math setup: 

1. In the common configuration panel, select the Live option.  

2. Click the drop down arrow in the Voltage field to set Math as the voltage 
source. The application replaces the measurement configuration screen and 
displays the Math Setup pane. 

 

Figure 3-5: Math setup 

3. In the Define Math field, use the drop down arrow to define the Math setup. 
The available options are: 

� 

� 

� 

� 

� 

� 

Scope user is the default setup 

Ch1-Ch2 

Ch1*Ch2 

Ch3-Ch4 

Ch3*Ch4 

User defined 

If you select Scope User, the application displays the existing Math defined in the 
oscilloscope in the Define/Edit Expression field. If you select the User defined 
option, you can use the popup keyboard in the Define/Edit Expression field to 
edit the Math values. 

4. Select the Apply button to apply the selected expression (- or *) on the 
selected math channel in the oscilloscope. 

5. Select the Clear button to clear the value from the Define/Edit Expression 
field. 
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6. Select the Cancel button to revert back to the measurement configuration 
screen. 

7. Select the Ok button to apply the math definition (if you have defined it 
correctly) and revert back to the measurement configuration screen. 

 

Troubleshooting Math Setup error messages 

If you select the User defined option and specify the wrong definition in the 
Define/Edit Expression field, the application displays the error message "Invalid 
Math definition. Redefine Math". A wrong definition can be a wrong syntax, 
empty definition string, invalid characters, invalid channel selection or circular 
definition. 
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Hysteresis 

 

Figure 3-6: Hysteresis 

 

The hysteresis input helps you to identify the cross over time on the waveform at 
specified reference levels as shown in the above figure. If there is any noise at the 
Reference level, the hysteresis band (H Band 1) helps to identify the single cross 
over. 

If the hysteresis band (H Band 2) is less than the signal noise at the Reference 
level, this shows as three edges or transitions instead of one transition. Hysteresis 
band helps you to identify the correct transition. 

SOA Mask Editor 

Measurement> Select> Power Device> SOA> Mask Editor 

Follow the steps to use the SOA Mask Editor: 

1. Select the Mask check box if you want to apply the mask to the SOA plot.  

 

Figure 3-7: SOA Mask editor configuration 

 

2. Click the Mask Editor button to display the SOA Mask Editor as shown in 
the next screen. 
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Figure 3-8: SOA mask editor 

 

3. Use the mouse to draw an open-ended mask on the grid and select the Set 
button. Click the mouse and select the exact points that identify the mask 
polygon and complete the mask by double clicking at the last point. Press 
the Set button to set the mask and identify the Pass or Fail zones. 

4. Select the Log or Linear radio button to set the Log or Linear scale for the 
mask.  

5. Use the GP (gray pop up) knob, keyboard or the popup keypad next to the 
Mask Values field (Y Max, Y Min, X Min, X Max) to set the XY 
coordinates of mask values. The default values of X Min is 0 V, X Max is 
250 V, Y Min is 0 A and Y Max is 10 A.  

You can use the Open option to retrieve the saved mask from the default 
directory or the directory where you have saved the mask.  

6. Configure SOA and press Run to display the SOA Plot with the mask in the 
background.  

7. Click the Save button to save the mask as an .smk file in the default 
directory C:\TekApplications\TDSPWR3\SOA\Masks or in any other folder. 
The Mask editor identifies the Pass/Fail regions on the SOA plot and 
displays them in different colors. You can also set the Mask Values and 
define masks. You can also change the mask dynamically and view different 
masks on the same SOA plot. Select the Clear button to clear the mask and 
the Undo button to undo the previous action. 
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If the data points fall inside the mask zone, they show in green as pass and if they 
fall outside the mask zone, they show as red which indicates fail. 

Note: If the x2 or y2 mask value is less than x1 or y1, the application displays an 
error message "Max should be greater than Min." You can only draw open-
ended masks. You cannot switch the scale after you have drawn the mask. If you 
do, the application clears the mask.  
  

Power Device Analysis - Power Dissipation 

Selecting and Configuring Measurements-Power 
Dissipation 

1. Select Measurements> Select from the application menu bar to display the 
default screen. 

2. In the Power Device tab, select Power Dissipation. Select the Configure 
option. 

Note: The waveform height should be at least 2-4 divisions to take the 
measurements. If the voltage waveform is less than a division, the application 
displays an error message "Unable to find the correct edges". This is due to the 
high variation in points in a single division and an insufficient hysteresis band to 
find the correct edges. The vertical range of the voltage waveform should be 
greater than one division. 

We recommend you to use the Hi-Res acquisition mode to analyze power 
dissipation. 
 

3. Configure the Current option in the Common configuration Panel. 

4. Select HiPower Finder or Switching Loss measurement. HiPower Finder 
calculates the instantaneous peak power on the switching waveform. The 
Switching Loss option calculates the amount of power dissipated across the 
switching device under the steady state of operation. The results vary 
according to the selected measurement.  

To calculate HiPower Finder, configure the parameters in the Type, Control 
Signal, Ton & Toff RefLevel and Options tabs.  
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HiPower Finder 

    

Figure 3-9: Power Dissipation-HiPower Finder 

 

Switching Loss 

 

Figure 3-10: Power Dissipation-Switching Loss 

 

 

Power Dissipation Type 

 

Figure 3-11: Power Dissipation configuration 
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Follow the steps given below to configure the HiPower Finder parameters in the 
Type tab: 

1. Select the Variable button if a switching device operates with a variable 
Duty Cycle with or without Discontinuous Conduction Mode. If  the 
Variable option is selected, the voltage edge source selection in the Control 
Signal tab switches to Vg (gate drive signal). If the Fixed option is selected, 
the application measures the switching loss for all the topologies with a 
constant duty cycle.  

2. Select the Power Waveform Destination from the drop down menu. The 
default destination is Math1. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Power Dissipation Edge Finder 

 

Figure 3-12: Power Dissipation configuration 

Follow the steps given below to configure the HiPower Finder parameters in the 
Edge Finder tab: 

1. In the Voltage pane, select the Vsw or the Vg option button to set the edge 
source. The default option is Vsw. If you have selected Vsw, the Edge 
Source is the Voltage source configured in the Common Configuration 
Panel. If you have selected Vg, from the Edge Source drop down list, select 
the Edge Source. The default is Ch1. 

If you select VSW, the application identifies: 

� 

� 

The edges on the switch voltage  

The Switch On and Switch Off portions using the switch voltage and 
switch current 

If you select Vg, the oscilloscope requires at least three channels to acquire the 
data and the application identifies: 
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� 

� 

The edges using the Vg (gate voltage)  

The Switch On and Switch Off portions using the Gate Voltage, Switch 
Voltage and Switch Current 

2. Select the Percentage option button to set the Ref Level and Hysteresis 
values as a percentage or the Absolute button to set the absolute value of the 
peak to peak signal.  

3. Use the GP knob in the Ref Level field to set the absolute or the percentage 
of the ref level value or use the GP knob in the Hysteresis field to set the 
absolute or the percentage of the hysteresis value. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Power Dissipation Ton and Toff Ref Level 

 

Figure 3-13: Power Dissipation configuration 

Follow the steps given below to configure the HiPower Finder parameters in the 
in the Ton and Toff Ref Level tab: 

1. Select the semiconductor type (DUT) from the Device drop down menu. 
The available options are: N-Channel and P-Channel. In an N-Channel 
device, the Switch Voltage, Switch Current and the Gate Voltage are 
positive. In a P-Channel device, the Gate Voltage can either be positive and 
negative or only negative. 

2. Select the Percentage radio button to set the V-Level and I-Level values in 
percentage of the peak to peak signal or select the Absolute radio button to 
set the absolute value of V-Level and I-Level  in amperes. The V-level and 
I-level values should be less than the sum of the Ref Level and Hysteresis 
divided by two. 

3. Use the GP knob next to the V-Level field to set the absolute or the 
percentage of the v-level value. The V-Level value for the Start of Ton is 
five percent of the switch current and for Stop of Ton is five percent of the 
maximum switch voltage. 
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4. Use the GP knob next to the I-Level field to set the absolute or the 
percentage of the I-level value. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

 

Power Dissipation Options 

 

Figure 3-14: Power Dissipation configuration 

 

Follow the steps given below to configure the HiPower Finder parameters in the 
Variable tab: 

1. Select the Variable option in the Type tab to enable the Signal Condition, 
Filter Current and Switch On check boxes. If you select the Signal 
Condition option, the application resets the switch current to zero after the 
Switch OFF to the next Switch ON. If you select the Filter Current option, 
the switch current has ringing at the low levels during switch ON. If you 
select the Switch ON option, you can change the default value of the start of 
switch ON. The default value is 5% of the maximum of Vg or 1.5 V of Vg, 
whichever is lower. 

2. Use the GP knob next to the Vg Level field to enter the values. The 
acceptable range of Vg values are 0 V to 50 V and the default value is 1.5 V. 
If you have selected the Vg option in the Control Signal tab as the Edge 
Source, the Vg level is used to calculate the Start of Ton. 

Note: If you select the Switch ON option, the Vg Level field is enabled. 
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If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

 

Switching Loss Type 

 

Figure 3-15: Power Dissipation configuration 

In the Type tab, use the following steps to configure the Switching Loss 
parameters: 

3. Select the Variable option if a switching device operates with a variable 
Duty Cycle with or without a Discontinuous Conduction Mode. If the 
Variable option is selected, the voltage edge source selection in the Control 
Signal tab switches to Vg (gate drive signal). If the Fixed option is selected, 
the application measures the switching loss for all the topologies with a 
constant duty cycle. 

Use VG as the Edge Source in the Edge Finder tab if: 

� 

� 

� 

� 

The switching voltage or current switches between the Discontinuous 
Mode and the Continuos Mode  

You use a ringing switch voltage to measure edge analysis 

If you select the Variable option, you can: 

Set the cursor gating to On or Off 

Configure the Edge Source as Vg or Vsw in the Edge Finder tab 

4. Select the Cursor Gating ON option to place the cursor at the specified 
portion of the waveform. In a Variable duty cycle, you can place the cursor 
at the half cycle of the input main signal.  

Note: If you select Variable, the Cursor Gating option is enabled and the voltage 
Edge Source in the Control Signal tab is Vg. 

5. In the Device pane, select the User button to enable the switching device 
type options. Select either the MOSFET or the BJT/GBT switching device. 
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If you select MOSFET, use the GP knob next to the RDS field to enter the 
RDS value, available in the data sheet, for the specified temperature of 
operation. If you select the Auto button, the application calculates the total 
power loss and energy using the switch voltage and current and checks for 
the vertical scale of the switch voltage. If the switch voltage scale is greater 
than ten volts per division, the application displays a warning message, 
"Vertical Scale of Switch Voltage > 10 V and the user defined RDSON is 
not selected. So the calculated energy and loss may not be accurate." 

6. Select the Power Waveform Destination from the drop down menu. The 
default destination is Math1. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

 

Switching Loss Control Signal 

 

Figure 3-16: Power Dissipation configuration 

In the Control Signal tab, follow the steps given to configure the Switching Loss 
Control Signal parameters: 

1. In the Voltage pane, select the VSW or the Vg option to set the edge source. 
The default option is VSW. If you have selected VSW, the Edge Source is 
the Voltage source configured in the Common Configuration Panel.  

If you select VSW, the application identifies: 

� 

� 

� 

The edges on the switch voltage  

The Switch On and Switch Off portions using the switch voltage and 
switch current 

If you select Vg, the oscilloscope requires at least three channels to acquire data 
and the application identifies: 

The edges using the Vg (gate voltage)  
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� The Switch On and Switch Off portions using the Gate Voltage, Switch 
Voltage and Switch Current 

Note: The application does not support Vg as the edge source because this 
requires three channels and magnetic loss requires two channels. This is not 
possible in a oscilloscope with four channels. 
 

2. Select the Percentage option button to set the Ref Level and Hysteresis 
values as a percentage or the Absolute button to set the absolute value of the 
peak to peak signal. 

3. Use the GP knob in the Ref Level field to set the absolute or the percentage 
of the ref level value or use the GP knob in the Hysteresis field to set the 
absolute or the percentage of the hysteresis value. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Switching Loss Ton and Toff RefLevel 

 

Figure 3-17: Power Dissipation configuration 

In the Ton and Toff RefLeval tab, follow the steps to configure the Switching 
Loss Ton and Toff RefLevel parameters: 

1. Select the semiconductor type (DUT) from the Device drop down menu. 
The available options are: N-Channel and P-Channel. In a N-Channel 
device, the Switch Voltage, Switch Current and the Gate Voltage are 
positive. In a P-Channel device, the Gate Voltage can either be positive and 
negative or only negative. 

2. Select the Percentage option button to set the Ref Level and Hysteresis 
values as a percentage or the Absolute button to set the absolute value of the 
peak to peak signal.  

3. Use the GP knob next to the V-Level field to set the absolute or the 
percentage of the v-level value. The V-Level value for the Start of Ton is 
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five percent of the switch current and for Stop of Ton is five percent of the 
maximum switch voltage. 

4. Use the GP knob next to the I-Level field to set the absolute value or the 
percentage of the I-level value. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Note: When switching current or voltage amplitude varies in an envelope shape. 
the TON and TOFF levels should be in Absolute Units for accurate results. 
 

Switching Loss Options 

 

Figure 3-18: Power Dissipation configuration 

In the Options tab, follow the steps to configure the Switching Loss Options 
parameters: 

1. Select the Variable option in the Type tab to enable the Signal Condition, 
Filter Current and Switch On check boxes. If you select  the Signal 
Condition option, the application resets the switch current to zero after the 
switch OFF to the next switch ON. If you select the Filter Current option, 
the switch current has ringing at the low levels during switch ON. If you 
select the Switch ON option, you can change the default value of the start of 
switch ON. The default value is 5% of the maximum of Vg or 1.5 V of Vg, 
whichever is lower. 

2. Use the GP knob next to the VG Level field to enter the values. The 
acceptable range of Vg values are 0 V to 50 V and the default value is 1.5 V. 
If you have selected the Vg option in the Control Signal tab as the Edge 
Source. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 
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Note: If you select the VG option in the Control Signal tab as the Edge Source, 
the VG Level field is enabled and you can use this value to calculate the Start of 
Ton. 

Viewing Results-Power Dissipation 

The Power Dissipation Measurement displays different results based on the 
selection: HiPower Finder or Switching Loss.  

Note: Do not change or touch the oscilloscope settings during the post analysis 
of the results. This could lead to incorrect interpretation of results. 
 

HiPower Finder results: 

Follow these steps to view the results: 

1. Select View> Results from the application menu bar. 

2. The application displays the results for the Power Dissipation (HiPower 
Finder) measurement as shown below.  

 

Figure 3-19: Power Dissipation results 

3. You can view the results of the Peak Finder and Switching Finder options.  

In the Peak Finder tab options, 
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� 

� 

� 

� 

� 

� 

The Summary displays maximum and minimum value of the power 
waveform peaks. It also displays the occurrences or positions of the On 
type and Off type peaks in a single waveform. 

In the Range limits panel, End and Start fields display the peaks 
between a range. You can use the GP knob, enter the numeric inputs, 
and select the Update button. 

The Peak Values panel displays the peaks between End range and Start 
range in descending order. Select the Link button to identify the peak 
portion in the voltage and current waveform. Use the Prev Peak button 
to move the cursor position to the previous peak from the linked 
position. Use the Next Peak button to move the cursor position to the 
next peak from the linked position. By default, the application positions 
the cursors on the first peak. 

Select the Zoom option to zoom in at the cursor location. 

 

In the Switching Finder tab location, 

The application displays On Time and Energy results between the 
cursors. Energy is the amount of energy dissipated from On to Off of 
the waveform. On Time is the conduction time for any switching 
device. You can move the Peak Pair Cursors depending on the order of 
their placement. Use the Prev Pair button to move the cursor to the 
previous cursors and the Next Pair to the next pair of cursors. 

Select the Zoom check box to zoom the selected portion of the math 
waveform horizontally at the cursor position. 

Note: If the current waveform is less than a division, the application displays an 
error message, "Unable to find the correct edges". This is because the variation 
of data points with in single division is very high and the hysteresis band is 
insufficient to find the correct edges. Therefore, for the voltage waveform, the 
vertical range should be greater than one division. 

Negative Switching loss results may be due to the DC offset in the voltage and 
current probes used. To avoid this, compensate the probes for DC offset and also 
run the Signal Path Compensation option (SPC) on the oscilloscope before 
starting the application. 
 

Switching Loss results: 

1. Select View> Results from the application menu bar. 

2. The application displays the results for the Switching Loss measurement in 
two panes: Power Loss and Energy. Select the Free Run mode to display the 
results. 
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Figure 3-20: Power Dissipation results 

3. In the Power Loss tab, the Min field displays the minimum loss in the 
acquisition in Watts. The Max displays the maximum loss in the acquisition 
in Watts. The Average Loss is the sum of Ton average, Toff average and the 
Conduction Loss. 

4. In the Energy tab, the Min field displays the minimum of all the energy 
values calculated for each cycle. The Max field displays the maximum of all 
the energy values calculated for each cycle in Watts. The Average energy 
displays the sum of Ton energy, Toff energy and the Conduction energy in 
Joules. 

5. The Type pane pictorially displays the On, Off and the Average portion of a 
switching cycle. 

Note: Negative switching loss results may be due to the DC offset in the voltage 
and current probes used. To avoid this, compensate the probes for DC offset and 
also run Signal Path Compensation option (SPC) on the oscilloscope before 
starting the application. Make sure to use only DC coupling. 

Generating Reports-Power Dissipation 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar, to display 
Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is HiPower_Finder.rgt for High Power Finder 
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measurement or Switching_Loss.rgt for Switching loss measurement and the 
layout file name is Power_Device.rpl. When you click on generate report, 
this template file name is displayed by default. If you want to select or 
modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Power Dissipation. You can configure all the 
parameters in the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

Troubleshooting Switching Loss Results 

  

Figure 3-21: Current waveform of a switching device 

The figure on the left shows the current waveform of a switching device. The 
figure on the right shows the zoomed signal. During Turn On of the switch 
current, a spike occurs as shown in the previous figures. If you configure the I-
value in the Ton and Toff tab to 5%, during analysis, the application converts the 
5% value to the absolute as (5/100*) maximum of the  switch current. The 
maximum of the switch current indicates the spike in the signal. This is valid 
only during Ton. The calculated maximum switch current value is used to 
identify the stop of Turn Off. Since you are using the maximum spike values to 
calculate Ton and Toff, the stop of Ton value is inaccurate. To overcome this, 
enter the reference value only in Absolute units. 
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What do you do when you get zero values in the switching loss results? 

 

 

Figure 3-22: switching waveform 

 

� 

� 

When you clear the Filter Current check box in the Options tab, and the 
switching current waveform is similar to the one in the previous figure, 
the application finds the start of Ton from the cursor 2 position. The 
algorithm searches from the cursor 2 position for the configured level 
and logs on to the first level. In this case, the start of Ton is calculated 
after the stop of Ton and the energy and loss is zero. 

When the configured I-level is out of the signal range, the Ton and Toff 
energy and the loss is zero, the application displays a warning message. 

 

 

Figure 3-23: Gate signal without a glitch 
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� If you select the Vg option button in the Edge Finder tab, the gate 
voltage should be a clean pulse without any glitch or ringing as shown 
in the previous figure. The gate voltage is used to identify the edges, 
Ton or Toff portions. When a glitch occurs, the application displays 
incorrect results. This type of signal can result in multiple edges (wrong 
edges) within a switching cycle. 

 

  

Figure 3-24: Push Pull device signal 

 

If the signal (Push Pull device) is similar to the one shown in the previous 
figures, configure the Ref level only at the switching portion of the voltage. The 
switching occurs only at the lower portion of the switch voltage. Enter the Ref 
value as 30%, which falls midway between the lower switching portion. 

If you have selected the P-channel device, the switching voltage and current is 
negative and the gate voltage is negative or positive and negative. The 
application inverts the waveform and analyzes it like the one on an N-channel 
device. Select the Vertical Setup > Invert option in the oscilloscope menu to 
invert the switch voltage, current, gate, and set the device to N-channel. 

B-H Analysis 

Selecting and Configuring Measurements-B-H Analysis 

Note: If the current waveform is less than a division, the application displays an 
error message, "Unable to find the correct edges". This is because of the high 
variation of data points in a single division and the insufficient hystersis band to 
find the correct edges. For the current waveform, the vertical range should be 
greater than one division. 
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1. Select Measurements> Select from the application menu bar. 

2. From the Power Device tab, select B-H Analysis option. Press the Configure 
button. 

The next figure shows a typical equipment setup for B-H Analysis. 

 

Figure 3-25: Equipment setup-B-H Analysis 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Configuring Measurements 

Follow the steps to configure the selected measurement: 

1. Configure the options in the Common configuration Panel. 

2. Select the option: Magnetic Loss, Inductance, I vs V Integral V Plot and 
Magnetic Property. The result varies according to the selected option. Click 
on the measurement buttons in the next figure to view their configuration 
options. 
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Figure 3-26: B-H Analysis configuration 

3. Press Run to measure B-H Analysis. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

B-H Analysis Magnetic Loss 

To use the Cursor Gating option to measure Magnetic Loss for varying frequency 
signals, follow these steps: 

1. Click the Cursor Gating ON button to enable the cursors in the oscilloscope. 

2. Place the vertical cursors between the specified area of the waveform to 
calculate the magnetic loss.  

Press the Run button to measure magnetic loss. 

B-H Analysis Inductance 

 

Figure 3-27: Inductance configuration 

Note: When you are measuring the inductance of a transformer, do not load the 
secondary winding. The measurement of the inductance at the primary winding 
under no load condition is as good as measuring the inductance for a single 
winding. 
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When you are measuring the inductance of the coupled inductor with multiple 
winding on the same core, the measured value of the inductance  will deviate 
from the actual value due to the influence of the current on other winding. You 
can use this measured value to calculate the Ripple current. 
 

To measure Inductance, 

1. Use the drop down arrow in the Edge Source field to set the edge source. 
The available options are: 

� 

� 

� 

Ch1-Ch4 

Math1-Math4 

Ref1-Ref4 

2. Select the Percentage or the Absolute option button in the Units pane to set 
the Ref Level, Hysteresis values in percentage or the absolute value of the 
peak to peak signal.  

3.  Select the Math Waveform Destination from the drop down list. The default 
destination is Math1. 

Press the Run button to measure inductance. 

 

B-H Analysis Ivs Integral V Plot 

 

Figure 3-28: I vsINT(V) Plot configuration 

To measure Ivs Integral V Plot, follow these steps: 

Select the Math Waveform Destination from the drop down list. The default 
destination is Math1.Press the Run button to measure magnetic loss. 

B-H Analysis Magnetic Property 

The Magnetic Property measures the parameters related to the magnetic material 
in a magnetic component used in an in-circuit operation. 
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Figure 3-29: Magnetic Property configuration 

In the Type tab, the application enables you to:  

� 

� 

� 

� 

� 

Define the dimensions of the magnetic core 

Select the types of in-circuit operations like Variable or Fixed duty 
cycle 

Select the Multiple Windings option for a transformer or an inductor 
that has multiple windings on the same core 

Select the Cursor Gating On button to measure the waveform data 
between the cursors 

Select the Math destination from the drop down list 

 

Figure 3-30: Magnetic Property configuration 

 

In the Ref Level tab, 

1. Use the drop down arrow in the Edge Source field to set the edge source. 
The data available in the selected channel is used to identify the complete 
integral cycle of an acquired waveform. This enables you to analyze the 
complex waveform across the inductor. The available options are: 

� 

� 

Ch1-Ch4 

Math1-Math4 
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� Ref1-Ref4 

Note: For the Variable operation, connect the gated drive signal to the Edge 
source because the amplitude of the voltage acquired across the inductor will 
vary with time. 
2. Select the Percentage or the Absolute option button in the Units pane to set 

the Ref Level, Hysteresis values in percentage or the absolute value of the 
peak to peak signal. 

 

Figure 3-31: Magnetic Property configuration 

In the Physical Characteristics tab, you can use the available parameters to 
specify the physical dimensions of the magnetic component. To do so, follow 
these steps: 

1. In the Units pane, select the SI or CGS option buttons to set the system 
units. If you select SI, the dimensions of the component are measured in 
meters and units of B-H Analysis in Tesla and Amperes or Turns per meter. 
If you select CGS, the unit of measurement is centimeter and the result units 
are in Gauss and Oersted. 

2. Use the GP knob next to the Num of Turns field to set the turns in the 
magnetic component.  

3. Use the GP knob next to the XsectionArea to set the cross section 
dimensions of the magnetic component. The acceptable ranges of the 
XsectionArea values are: 

� 

� 

� 

� 

 1nm2 to 1Mm2 if you have selected SI 

1ncm2 to 1Mcm2 if you have selected CGS 

4. Use the GP knob next to the Magnetic Length field to set the magnetic 
length of the component. The acceptable range of lengths are: 

1 mm if you have selected SI 

0.1 cm if you have selected CGS 

In the Multiple-Simultaneous Windings tab, you can measure the magnetic 
property of the components that has multiple windings like a coupled inductor.  
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To do so, follow these steps: 

a. Use the drop down arrow in the Current2 and Current3 field if you have 
connected to the other windings of the component.  

b. Connect the voltage/current probe selected in the Common 
Configuration Panel to the: 

� 

� 

Primary winding in a transformer winding 

One winding in a couple inductor that is considered as the main 
winding 

 

 

Figure 3-32: Magnetic Property configuration 

c. In the Ref Level tab, use either the main winding voltage or the current 
channel as the edge source 

d. In the PhyChars tab, enter the number of turns in the Num of Turns 
field. 

e. In the Multiple Windings tab, connect the current probe to the other 
winding or the secondary winding and enter the number of turns of the 
windings. If the number of windings is one, in the Current 3 field select 
the Unused option from the drop down list. 

f. Follow the connection combinations of the voltage and current probe at 
the primary or the main winding at the secondary or the other windings 
to the  dot as shown in the next figure. The voltage probe should be 
connected in such a way that the voltage is read as positive when the 
current rises. 

g. In the Magnetising Current field, use the drop down arrow to select the 
ref channel to view the magnetising current. 
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Figure 3-33: Windings setup  

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

 

If you do not have a current probe to acquire the waveform simultaneously on 
two windings, select the Prompt button in the Multiple Windings pane and follow 
the procedures given below: 

a. In the Ref Level tab, use either the main winding voltage or the current 
channel as the edge source. 

b. Connect the voltage/current probe selected in the Common 
Configuration Panel to the: 

� 

� 

Main winding in a transformer winding 

One winding in a couple inductor that is considered as the main 
winding 

c. Press the Run button in the application. The application acquires the 
voltage and current waveform of the main winding and prompts you to 
connect a current probe to the other winding. Select Yes if you have the 
other winding and No to proceed to the next step.  
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d. Set the current channel in the pop up message box and connect the 
current probe to the other winding. Enter the number of turns in the 
Num of Turns field for the selected winding. 

 

Viewing Results-B-H Analysis 

The B-H Analysis Measurement has different results based on the selected 
measurement. Follow these steps to view the results: 

Magnetic Loss Results: 

1. Select View> Results from the application menu bar. 

2. The application displays the results for the B-H Analysis (Magnetic 
Property) measurement in a tabular format. 

  

Figure 3-34: Magnetic property results 

Table 3-11: Magnetic property result fields 

Field Description 
Bpeak The maximum magnetic flux density induced in a magnetic component 
Br The induced magnetic flux density (B) that remains in the material after the externally applied 

magnetic field (H) is returned to zero while generating the hysteresis loop. Here the maximum 
value of the Br on the Bpeak cycle is measured. 

Hc The value of H at the intersection of the H-axis and the hysteresis loop. This represents the 
external field required to cause the induced flux density (B) to reach zero during while measuring 
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a hysteresis loop. Hc is symmetrical with the positive and the negative Haxis. 
Hmax The maximum value of H at the intersection of the H-axis and the hysteresis loop.  
I-ripple The peak to peak value of the current 

 

3. Click the View Plot option to view the half screen plot. 

 

Figure 3-35: Magnetic Property half screen results 

4. Use the Cursor button to place the cursor on the maximum flux density 
curve. The Cursor1 and Cursor2 helps you to calculate the permeability, 
delta B, delta H on the region of interest on the maximum flux density 
curve. 

5. The Bpeak Cycle button toggles between Bpeak Cycles and All Cycles. 
When the Bpeak cycle is selected, you can see only the two Bpeak cycle that 
has the maximum flux density. When All Cycles is selected, you can see all 
the cycles for the component. 

6. Select the Full Screen option to view the plot. 

7. Select the Dot connect option in the SOA Plot to connect all the data points 
and display the stray point. This ensures that all the data points display the 
visible transition. 
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Figure 3-36: Magnetic Property full screen results 

 

8. Select the Save Image option and save the image in the .jpg format. The 
default directory and the file name is 
C:/TekApplications/TDSPWR3/Images.  

9. Select the Control button to activate the Zoom buttons.  

10. Select the Reset option to restore the plot to its original display after 
zooming. 

Note: If the Cursor control button is enabled, the zoom buttons are disabled. 
 

11. Place the Cursor to select any data point in the plot. 

12. Select the Zoom control buttons to display the Zoom buttons. 

13. Select the  icon to zoom the area of interest. You can zoom up to five 
times the normal view. Drag the mouse or use a single click button to zoom 
in to define the area of interest. Select the  icon to zoom out. You can 
use the Zoom In and Zoom Out icons until the application reaches the 
maximum and the minimum zoom limit. You can use the Zoom buttons in 
three different ways: 

� Dragged zoom-in: where the area is selected by dragging on the 
displayed window 
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� 

� 

Single-clicked zoom-in: when a point is clicked on the displayed 
window, the resulting window is equal to 1/4th of the displayed 
window.  

Single-clicked zoom-out: when a point is clicked on the displayed 
window, the resulting plot is the previous zoom state of the displayed 
window. 

Note: If the current waveform is less than a division, the application displays an 
error message, "Unable to find the correct edges". This is because of the 
variation of data points within single division is very high and hysteresis band is 
insufficient to find the correct edges. Therefore, for the current waveform, the 
vertical range should be greater than one division.. 
 

I vs Integral V Plot Results: 

1. Select View> Results from the application menu bar. 

2. The application displays the I vs Integral V Plot results for the B-H Analysis 
measurement. 

3. Click the View Plot option to view the B-H curve plot of the Current and 
Integral Voltage. 

 

Figure 3-37: B-H Analysis results 

4. Select the Dot Connect option to connect all the data points. You can view 
all the data points here. 
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5. Select the Save Image option to save the plot in the .jpg format. The default 
directory is C:/TekApplications/TDSPWR3/Images. 

6. Select the Zoom controls to activate the Zoom buttons. 

7. Select the Reset option to restore the plot to its original display. 

Note: If the Cursor button is enabled, the zoom buttons are disabled. 
 
Select the Cursor option  to select any data point from the plot. 

8. Select the  icon to zoom the area of interest. Define the area of interest 
using the mouse and selecting the zoom in area.  

Select the  icon to zoom out. You can use the Zoom In and Zoom Out icons 
until the application reaches the maximum and the minimum zoom limit. 

9. Use the cursor in the Hits field to display the number of cursor hits at 
selected data points. When you place the cross hair icon on the I vs Integral 
V plot and if multiple occurrences of the data points exist at the same 
position, the values are displayed in the Hits field. 

10. The Cursor Linkage field displays the number of times a particular data 
point occurs. The minimum is 1 and the maximum is the number of times a 
data point occurs.  

11. Select the Link button to link the data point you have selected to the 
waveform in the oscilloscope. 

12. In case of multiple occurrences greater than one, select the Prev button to 
select the previous data point and the Next button to select the next data 
point. 

13. Use the Half Screen option to view the B-H Plot and the time domain 
waveform simultaneously. Select the Cursor Linkage check box to select the 
data point to link the waveform in the oscilloscope to the I Vs V Integral 
Plot. Place the cross hair cursor on the plot and enter the values in the 
Cursor Linkage Hits field. Use the Zoom button to zoom the area of interest 
in the plot and display in the oscilloscope. 

Inductance Results: 

1. Select View> Results from the application menu bar. 
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Figure 3-38: Inductance results 

2. The application displays the B-H Curve plot with the Inductance value. 

 

Figure 3-39: Inductance half screen results 

You can select the Full Screen button to view the plot in full screen mode. 
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Generating Reports-B-H Analysis 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar, to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is BH_IvsINTVPlot.rgt, BH_Magnetic_Loss.rgt, 
BH_Inductance.rgt, BH_Magnetic_Property.rgt and the layout file name is 
Power_Device.rpl. When you click on generate report, the application 
displays the default template file name. However, if you want to select or 
modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for B-H Analysis. You can configure all the parameters in 
the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

 

Total Loss 

Selecting and Configuring Measurements-Total Loss 

Refer to the General Safety Summary before connecting to a circuit.  

1. Select Measurements> Select from the application menu bar. 

2. From the Power Device tab select Total Loss option. Select the Configure 
option. 

3. The next figure shows a typical equipment setup for Total Loss. 
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Figure 3-40: Total Loss setup 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

 

Configuring Measurements 

Note: You need four channels to measure Total Loss. To measure Variable, 
switching loss requires an additional source for the gate drive signal. As all the 
channels are used to measure Total Loss, additional channels are not available. 
Thus the application cannot support a Variable gate drive signal. 
 

Total Loss is a combination of the loss across the switching device and the 
magnetic component. Use the following steps to configure the selected 
measurement: 

1. Select the Live or the Ref option. If necessary, use the Deskew button to 
deskew. If you select the Ref source, Deskew and the I-Probe settings 
buttons are disabled. 
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Figure 3-41: Total Loss configuration 

2. Select the Source tab to display the switching and magnetic loss source. In 
the Switching Loss and Magnetic Loss panel, use the drop down arrow to 
select the Voltage and Current channel. 

3. Select the I-Probe settings option to configure the probe settings to display 
the I-Probe Settings screen. The I-Probe settings button is disabled when the 
Current field is disabled. The default probes are the TCP Series probe. 

� 

� 

� 

If the probe belongs to the AM503S series, select the AM503S Settings 
button and use the drop down arrow in the Probe Type field to select 
the probe type. The Range field displays the probe range for the 
selected probe in the Probe Type field. You can also use the drop down 
arrow in the Range field to select a specific range. 

If the probe belongs to the Current Shunt series, select the Current 
Shunt button. Select the general-purpose knob in the I Probe Transfer 
Impedance field to display a pop-up calculator. Enter the values in the 
provided text box. 

If you are not using a Tektronix probe, select the Custom button. Use 
the GP knob to set the Scale Factor and Propagation Delay of the 
probe. 

4. Select OK to return to the previous panel. 

5. In the Source Contd.. tab, select the Percentage radio button to set the Ref 
Level, Hysteresis, and High and Low values in percentage of the peak to 
peak signal. Select the Absolute radio button to set the correct value of Ref 
Level, Hysteresis, and High and Low values in volts.  
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Figure 3-42: Total Loss configuration 

6. In the Switching Loss tab, click the Cursor Gating On button to enable the 
vertical cursors in the oscilloscope. Place the cursors between the specified 
area of the waveform to calculate the switching loss. Select the User check 
button to enable the switching device options. Select either the MOSFET or 
the BJT/GBT switching device. If you select MOSFET, use the GP knob 
next to the RDS On field to enter the RDS value, available in the data sheet, 
for the specified temperature of operation. In the Options pane, if you select 
the Signal Conditioning option, the application retains the switch current to 
zero after the switch OFF to the next switch ON. If you select the Auto 
button, the application calculates the total power loss and energy using the 
switch voltage and current and checks for the vertical scale of the switch 
voltage. If you select the Filter Current option, the switch current rings at the 
low levels during switch ON.  

7. In the Math Destination field, use the drop down arrow to set the math 
destination. The default is Math1. 

 

Figure 3-43: Total Loss configuration 

8. In the Ton and Toff RefLevel tab, select the type of semiconductor from the 
Device drop down menu. The available options are: N-Channel and P-
Channel. In a N-Channel device, the Switch Voltage, Switch Current and 
the Gate Voltage are positive. In a P-Channel device, the Gate Voltage can 
either be positive and negative or only negative. 
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Figure 3-44: Total Loss configuration 

9. Select the Percentage radio button to set the V-Level and I-Level values in 
percentage of the peak to peak signal in percent.  

10. Select the Absolute radio button to set the absolute value of V-Level and I-
Level in amperes. The V-level and I-level values should be less than the 
sum of Ref Level and Hysteresis divided by two. 

11. Use the GP knob next to the V-Level field to set the absolute or the 
percentage of the V-level value. The V-Level value for the start of Ton is 
five percent of the switch current and for stop of Ton is five percent of the 
maximum switch voltage. 

12. Use the GP knob next to the I-Level field to set the absolute or the 
percentage of the I-level value. 

13.  Select Run to measure Total Loss. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. If the measurement has failed, the application comes to the 
Ready state and you have to configure and run the measurement again. 

Viewing Results-Total Loss 

1. The application displays the results in two tabs-Switching Loss and 
Magnetic Loss as shown in the next figure.  
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Figure 3-45: Total Loss results 

2. Click the Magnetic Loss tab to display the next screen. 

 

Figure 3-46: Total Loss results 

3. In the Power Loss pane, the Min field displays the minimum loss in the 
acquisition in Watts, Max displays the maximum loss in the acquisition in 
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Watts and the Average Loss is the sum of Ton average, Toff average and the 
Conduction Loss. 

4. In the Energy tab, the Min field displays the minimum of all the energy 
values calculated for each cycle,  Max displays the maximum of all the 
energy values calculated for each cycle in Watts and the Average energy 
displays the sum of Ton energy, Toff energy and the Conduction energy in 
Joules. 

5. The Magnetic Loss measures and displays the area of the power waveform 
and loss incurred for the entire record length.  

Generating Reports-Total Loss 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar, to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is Total_Loss.rgt and the layout file name is 
Power_Device.rpl. When you click on generate report, the application 
displays the default template file name. However, if you want to select or 
modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Total Loss. You can configure all the parameters in the 
user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

 For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

Safe Operating Area 

Selecting and Configuring Measurements-Safe Operating 
Area 

1. Select Measurements> Select from the application menu bar. 

2. From the Power Device tab, select the Safe Operating Area (SOA) 
measurement. Select the Configure option. 

The next figure shows a typical equipment setup for Safe Operating Area. 
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Figure 3-47: SOA setup 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Configuring Measurements 

Follow the steps to configure the selected measurement:  

1. Select the Plot Type: SOA Normal, SOA Gated or SOA DPO. 

Note: The Ref option in the Configuration Panel is disabled since the SOA DPO 
option works only on live signals. You can also select the Free Run in the Mode 
field if you select SOA Normal option. 
 

2. Configure the options in the Common configuration Panel.  

Note: Make sure that there are waveforms on the oscilloscope or the application 
displays an error message. 

 

Table 3-12: SOA measurements 

Plot Type  Description 
SOA Normal  Plots the  Voltage and Current 

waveform in a single record  in 
XY mode 

SOA Gated  Plots a selected portion of the 
Voltage and Current waveform 
between the cursor in XY mode 

SOA DPO  Measures and plots the voltage 
and current waveforms using 
the XY mode display of the 
oscilloscope. Use this option to 

TDSPWR3 Software Analysis Printed Help Document           89 



Operating Basics 

measure multiple acquisitions of 
the same waveform in real time 
testing 

 

3. The result varies according to the selected plot type. Select the Mask check 
box to define and apply masks on the SOA plot. If the Mask check box is 
enabled and there is no mask set in the SOA mask editor, when you select 
the Run button, the application displays a warning message, "SOA Mask is 
enabled, but not defined. Do you wish to continue?". Select Yes to continue 
without the mask. The Mask Editor and Enable Mask options are applicable 
only for SOA Normal. 

4. Select the Mask Editor button to display the SOA Mask Editor.  

5. Press run to display the SOA Normal plot.  

6. Place the cursor on the plot to display the following results: 

� 

� 

� 

� 

� 

Voltage value  

Current value  

Power value  

Mean power  

Standard deviation 

Viewing Results-Safe Operating Area 

The SOA Measurement plots the current and waveform results in the SOA Plot. 
Follow these steps to view the results. 

1. Select View> Results from the application menu bar. 

2. The application displays the SOA Normal results as shown below:  
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Figure 3-48: SOA results 

 

 

Figure 3-48: SOA results 
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3. Select the Dot connect option in the SOA Plot to connect all the data points 
and display the stray point. This ensures that all the data points display the 
visible transition. 

4. Select the Save option and save the image in the .jpg format. The default 
directory and the file name is C:/TekApplications/TDSPWR3/Images.  

5. Select the Save Data option and save the result plot in the .plt format.  

6. Select the Control button to activate the Zoom buttons.  

7. Select the Reset option to restore the plot to its original display after 
zooming. 

Note: If the Cursor control button is enabled, the zoom buttons are disabled. 
 

8. Place the Cursor to select any data point in the plot. 

9. Select the Zoom control buttons to display the Zoom buttons. 

10. Select the  icon to zoom the area of interest. You can zoom up to five 
times the normal view. Drag the mouse or use a single click button to zoom 
in to define the area of interest. Select the  icon to zoom out. You can 
use the Zoom In and Zoom Out icons until the application reaches the 
maximum and the minimum zoom limit. You can use the Zoom buttons in 
three different ways: 

� 

� 

� 

Dragged zoom-in: where the area is selected by dragging on the 
displayed window 

Single-clicked zoom-in: when a point is clicked on the displayed 
window, the resulting window is equal to 1/4th of the displayed 
window.  

Single-clicked zoom-out: when a point is clicked on the displayed 
window, the resulting plot is the previous zoom state of the displayed 
window. 

11. Use the cursor in the oscilloscope and the Link button to link the waveform 
from the SOA plot. When you select the Link button, the plot automatically 
resizes to the half screen mode. The Link Cursor Position field displays the 
number of occurrences of the particular data points. Here minimum is 1 and 
maximum is the number of occurrences of data points.  

12. Place the cross hair cursor at the point of interest on the plot and press the 
Link button. This enables the cursor on the oscilloscope and places it on the 
waveform corresponding to the selected data point in the plot panel. 

13. In case of multiple occurrences, select the Prev button to select the previous 
data point and the Next button to select the next data point. 
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14. Use the Half Screen option to view the plot and the time domain waveform 
simultaneously. Select the Cursor Linkage check box to select the data point 
to link the waveform in the oscilloscope to the SOA Plot. Place the cross 
hair cursor on the plot and enter the values in the Cursor Linkage 
Occurrences field. Use the Zoom button to zoom the area of interest in the 
plot and display in the oscilloscope. 

Note: You can view the result either in the half screen mode or in the full screen 
mode. 
 

15. The application displays the result for Voltage, Current, Power, Mean Power 
and Standard Deviation at the cursor location. 

Viewing Results for SOA Gated 

1. From the application menu bar, select Results> Statistics to display the 
results. You can also select SOA Gated measurement and press the Run 
button to display the message, "Have you acquired the waveform?" 

2. Select Yes to run the application and display a pop-up message, "Place the 
cursors at the appropriate region of the waveform." Select OK to display the 
results for the selected portion of the waveform. 

3. The Cursor Linkage allows you to locate the point in a SOA plot to the time 
domain waveform and link the data index of the waveform. Place the cursor 
at the region of the waveform you want to plot SOA and display the plotted 
area. 

4. Select the Dot connect option in the SOA plot to connect all the data points. 
This helps to view the data points that are distant from the rest of the data 
points. 

5. Select the Save option and save the image in the. jpg format. The default 
directory is C:/TekApplications/TDSPWR3/Images. 

6. Select the Control button to activate the Zoom buttons. You can use the 
Zoom buttons to zoom up to five times the original size.  

7. Select the Reset option to restore the plot to its original display after 
zooming. 

Note: If the Cursor control button is enabled, the zoom buttons are disabled. 
 

8. Place the Cursor to select any data point in the plot. 

9. Select the Zoom control buttons to display the Zoom buttons. 

10. Select the  icon to zoom the area of interest. Drag the mouse or use a 
single click button to zoom in to define the area of interest. Select the  
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icon to zoom out. You can use the Zoom In and Zoom Out icons until the 
application reaches the maximum and the minimum zoom limit. 

11. Use the cursor in the oscilloscope to link the waveform from the SOA plot. 
Use the Link button to link the waveform in the SOA plot. When you select 
the Link button, the plot resizes to the half screen mode. The Link Cursor 
Position field displays the number of occurrences of the particular data 
points. Here the minimum is 1 and the maximum is the number of 
occurrences of data points.  

12. Place the cross hair cursor at the point of interest on the plot and press the 
Link button. This enables the cursor on the oscilloscope and places it on the 
waveform corresponding to the selected data point in the plot panel. 

13. In case of multiple occurrences, select the Prev button to select the previous 
data point and the Next button to select the next data point. 

14. Use the Half Screen option to view the plot and the time domain waveform 
simultaneously. Select the Cursor Linkage check box to select the data point 
to link the waveform in the oscilloscope to the SOA Plot. 

15. Select the Zoom check box to zoom the area of interest. Drag the mouse or 
use a single click button to zoom in to define the area of interest. 

 

Figure 3-49: SOA results 

Note: You can view the result either in the half screen mode or in the full screen 
mode. 

 

94                                                                                       TDSPWR3 Software Analysis Printed Help Document                           



Operating Basics 

16. The application displays the result for the Voltage, Current, Power, Mean 
Power and Standard Deviation. 

Viewing Results for SOA DPO 

You can view the result in the oscilloscope as a real time plot. 

Note: Select the channel as Ch1, Ch2 or Ch3, Ch4 for the SOA Plot. 

 

Figure 3-50: SOA results 

SOA Overlay 

Utilities> SOA Overlay 

Note: Select the Save Data button in the SOA results window to save the plot as a 
.plt file before using this utility. 
 

Purpose: Plot, view and compare SOA Plots of the device operating at different 
load conditions. The SOA Overlay utility helps you to overlay multiple SOA 
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plots simultaneously. You can use this feature to view multiple plots on the same 
grid.  

Initially, the application adjusts the SOA scale according to the selected plot(s); 
but you can also observe the plot for the voltage and current range of operation 
under different conditions.  

 

Figure 3-51: SOA Overlay 

 

The Y Max, Y Min, X Max and X Min gives you the flexibility to set up 
different operating voltage and current range to view the plot(s). The X axis 
represents the voltage values in volts and the Y axis represents the current in 
amperes. 

Follow these steps to perform SOA Overlay, 

1. Click the Load Recent button to automatically load the SOA plots saved in 
the current run of the application. You can load only the last ten plots. Select 
the Load Manually button to manually load the SOA plots from any folder 
or from the default folder C:\TekApplications\TDSPWR3\SOA\Data 
directory. You can load any of the ten plots. You can use the Shift or the 
Control key to select multiple plots. 

2. Click the selection button (For example:  ) next to the plot name to 
display the SOA plot on the grid area of the screen. When the utility 
displays the first plot,  it automatically scales the plot. Continue this 
procedure to overlay and display all the plots. SOA Overlay displays the 
plot based on the color set in the Plot Name pane. The most recently 
selected plot is drawn over the previously selected plots. You can 
simultaneously view and compare different SOA plots under multiple 
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conditions. You can change the XY limits to view the plot at a different 
scale. 

3. Click on the Plot selection button (For example:  ) to remove the plot 
from the grid area. 

4. Click the Clear button to display the message, "Do you want to clear the 
Plots? Press the Yes button to clear." Select Yes to clear the plots from the 
grid area. 

5. Select the Save Plot and Legend button to save the plot as a .jpg file to any 
folder of your choice or to the default folder 
C:\TekApplications\TDSPWR3\Images. 

6. Select OK to close the display window. 

Generating Reports-Safe Operating Area 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar, to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is SOA.rgt and the layout file name is 
Power_Device.rpl. When you click on generate report, the application 
displays the default template file name. However, if you want to select or 
modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Safe Operating Area. You can configure all the 
parameters in the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

Dynamic Resistance 

Selecting and Configuring Measurements-Dynamic 
Resistance 

1. Select Measurements> Select from the application menu bar. 

2. From the Power Device tab, select the Dynamic Resistance measurement. 
Select the Configure option. 
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3. The next figure shows a typical equipment setup for Dynamic Resistance. 

 

Figure 3-52: Dynamic resistance setup 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Configuring Measurements 

Follow the steps to configure the selected measurement:  

Note: The Ref and Deskew options are disabled in the Configuration panel as 
dynamic resistance measures live signals. 
 

1. Configure the options in the Common Configuration Panel.  

 

Figure 3-53: Dynamic resistance configuration 

2. Use the drop down arrow in the Real Time Math Destination field and the 
Average Math Destination field to select the math channel. You cannot 
select the same math channel for both the destinations. 
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Note: If you select the same Math destination and press Run to acquire the data, 
the application displays an error message "Conflict in selection of Math 
destinations." 

To measure the low voltage in a high voltage switching (Example 400 Volts 
peak) in P5205 probe, set the attenuation factor X 50. This will clip any voltage 
above 130 Volts. Adjust the Volts/division  to have the signal with in the dynamic 
range of the oscilloscope.   

 

3. Press Run to acquire the data. 

4. If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Viewing Results-Dynamic Resistance 

Follow these steps to view the results: 

1. Select View> Results from the application menu bar, to view the results for 
the Instantaneous RDS on at Math 1 and the Average RDS on at Math 2. 
Use the cursor button in the oscilloscope panel to place the cursor. 

 

Figure 3-54: Dynamic resistance results 

Note: In the first instance, the application displays the result screen with no 
values. Click the cursor button to display the values. 

 

2. Select the Cursors button to display a pop-up message. 
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Figure 3-55: Cursors message box 

3. Manually place the cursor in the conduction region and press OK. This 
displays the resistance between the selected portions of the waveform.  

4. The application displays the Destination, the Minimum, the Maximum and 
the Average values of the Instantaneous RDS and Average RDS. If you 
select the Free Run mode, the application automatically updates the 
resistance values  in the table. 

Generating Reports-Dynamic Resistance 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar, to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is Dynamic_resistance.rgt and the layout file name is 
Power_Device.rpl. When you click on generate report, the application 
displays the default template file name. However, if you want to select or 
modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Dynamic Resistance. You can configure all the 
parameters in the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

 For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

di/dt 

Selecting and Configuring Measurements-di/dt 

To select and configure Power Quality Measurement, follow these steps: 

1. Select Measurements> Select from the application menu bar. 
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2. From the Power Device tab and select the di/dt option. Select the Configure 
button. 

3. The next figure shows a typical equipment setup for di/dt. 

 

Figure 3-56: di/dt setup 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Configuring the Measurement 

Follow the steps to configure the selected measurement: 

Note: The Ref source, Deskew and Voltage in the Common Configuration panel 
is disabled. You can configure only the Current options. 

 

1. Configure the Current options in the Common configuration Panel.. 

 

Figure 3-57: di/dt configuration 
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2. Select the Percentage radio button to set the Ref Level and Hysteresis values 
in percentage of the peak to peak signal. Select the Absolute radio button to 
set the absolute value of Ref Level and Hysteresis values in amperes. 

3. Select the Math destination from 1 to 4 as shown in Figure 3-37. The 
selection depends on the number of channels in the oscilloscope from the 
Math Destination field. The Mode is Single Run only. Select the Math 
destination from 1 to 4. The selection depends on the number of channels in 
the oscilloscope from the Math Destination field. The Mode is Single Run 
only. 

4. Press Run to measure. 

5. If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Viewing Results-di/dt 

To view the results, follow these steps: 

6. Select View> Results from the application menu bar. 

Note: In the first instance, the application displays the result calculated for the 
first edge.  

 

7. Click on the Edges numeric keypad to enter the edge number for the 
measurement to calculate the di/dt for the region of interest. By default, 
Percentage radio button is selected. The High field is 90%, Low Level is 
10% and the Edge Number is 1. Select the Absolute radio button to enter the 
absolute values in amperes for Low and High values. The vertical cursor 
will be at 90% of the first edge and the other vertical cursor at 10% of the 
first edge. To perform di/dt analysis for any other edge, enter the edge 
number in the Edge Number field. Select the Percentage or Absolute radio 
button to enter the range of values. Use the GP knob adjacent to the High 
Level and Low Level field to enter the numeric values. This helps you to 
calculate the di/dt for the range of voltage between the High and Low level 
on the selected edge. Select the Update button to position the oscilloscope 
cursors on the High and Low levels of the waveform and on the edge you 
have set. This displays the updated results for the selected edge.  
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Figure 3-58: di/dt results 

8. The application displays the results as a differential of the current waveform 
with respect to time in units of amperes per microsecond. Select the Zoom 
button to zoom the area of interest. 

 

Generating Reports-di/dt 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar to display 
the Report Generator screen.  

2. The application provides default Factory templates are available for this 
measurement. The template file name is di_dt.rgt and the layout file name is 
Power_Device.rpl. When you click on generate report, the application 
displays the default template file name. However, if you want to select or 
modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for di/dt. You can configure all the parameters in the user 
interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

 For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 
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dv/dt 

Selecting and Configuring Measurements-dv/dt 

1. Select Measurements> Select from the application menu bar. 

2. From the Power Device tab, select the dv/dt option. Select the Configure 
option. 

3. The next figure shows a typical equipment setup for dv/dt. 

 

Figure 3-59: dv/dt setup 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Configuring the Measurement 

Follow the steps to configure the selected measurement: 

Note: Ref, Current, Deskew and I-Probe Settings in the Common Configuration 
panel is disabled. You can configure only the Voltage options. 
  

Configure the Voltage options in the Common configuration Panel. 

1. Select the Math destination depending on the number of math channels 
available in the oscilloscope. 
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Figure 3-60: dv/dt configuration 

2. Select the Percentage radio button to set the Ref Level and Hysteresis values 
in percentage of the peak to peak signal. Select the Absolute radio button to 
set the absolute value of Ref Level and Hysteresis values in volts. 

3. Select the Math destination from 1 to 4 as shown in Figure 3-37 on page 50. 
The selection depends on the number of channels in the oscilloscope from 
the Math Destination field. The Mode is Single Run only. 

4. Press Run to measure. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Viewing Results-dv/dt 

To view the results, follow these steps: 

1. From the application menu bar, select View> Results 

Note: In the first instance, the application displays the result calculated for the 
first edge. Click the cursor button to display the values. 
 

2. Click on the Edges button to display the Edge Analysis screen. By default, 
Percentage radio button is selected. The High field is 90%, Low Level is 
10% and the Edge Number is 1. Select the Absolute radio button to enter the 
absolute values in volts for Low and High values. The vertical cursor will be 
at 90% of the first edge and the other vertical cursor at 10% of the first edge. 
To perform dv/dt analysis for any other edge, enter the edge number in the 
Edge Number field. Select the Percentage or Absolute radio button. Use the 
GP knob adjacent to the High Level and Low Level field to enter the 
numeric values. This helps you to calculate the dv/dt for the range of voltage 
between the High and Low level on the selected edge. Select the Update 
button to position the oscilloscope cursors on the High and Low levels of the 
waveform and on the edge you have set. This displays the updated results 
for the selected edge.  
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Figure 3-61: dv/dt results 

3. The application displays the results, which is a differential of the voltage 
waveform with respect to time in units of volts per microsecond. Select the 
Zoom button to zoom the area of interest. 

Note: If you observe the cursor positions on the oscilloscope screen in the figure 
below, the absolute values of the signal level read by the cursor does not match 
with the entered high and low levels in the result panel. This is because the 
values entered in Low and High levels may lie in between the samples of the 
waveform. This happens for di/dt and dv/dt measurements. 
   

Generating Reports-dv/dt 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is dv_dt.rgt and the layout file name is 
Power_Device.rpl. When you click on generate report, the application 
displays the default template file name. However, if you want to select or 
modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for dv/dt. You can configure all the parameters in the user 
interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 
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5. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

   

Line Power Analysis-Power Quality 

Selecting and Configuring Measurements-Power Quality 

To select and configure Power Quality Measurement, follow these steps: 

1. Select Measurements> Select from the application menu bar. 

2. Select the Line Power tab to display the Line Power Analysis screen. Select 
the Power Quality option. Select the configure button to configure Power 
Quality. 

3. The next figure shows a typical equipment setup for Power Quality.  

 

Figure 3-62: Power Quality setup 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Configuring the Measurement 

Follow the steps to configure the selected measurement: 

1. Configure the options in the Common configuration Panel. 
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Figure 3-63: Power Quality configuration 

2. Use the drop down arrow in Power Waveform Destination field and Energy 
Waveform Destination field to set the Math option. The Math destination 
depends on the two or four channel math of the oscilloscope. The 
application automatically detects the availability of the Math channel in the 
oscilloscope. 

Note: You cannot set the same Math channel in both the fields. If you do, the 
application prompts a conflict analysis message when you select the Run button. 
The Energy Waveform destination depends on the Math option available in the 
oscilloscope. 
 

3. Press Run to measure. 

4. If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Viewing Results-Power Quality 

To view the results, follow these steps: 

1. From the application menu bar, select View> Results. 

2. The application displays the results for the Power Quality measurement with 
the following data: 

� 

� 

� 

� 

� 

� 

V Rms 

True Power 

Voltage Crest Factor 

Frequency 

I Rms 

Apparent Power 
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� 

� 

Current Crest Factor 

Power Factor 

 

Figure 3-64: Power Quality results 

Generating Reports-Power Quality 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is Power_Quality.rgt and the layout file name is 
Line_Power.rpl. When you click on generate report, the application displays 
the default template file name. However, if you want to select or modify 
another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Power Quality. You can configure all the parameters in 
the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

 For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 
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Current Harmonics 

Selecting and Configuring Measurements-Current 
Harmonics 

To select and configure Current Harmonics Measurement, follow these steps: 

1. Select Measurements> Select from the application menu bar. 

2. Select the Line Power tab to display the Line Power Analysis screen.  

3. Select the Current Harmonics option and press the configure button. 

Note: If you are using the same voltage source as used for any previous 
measurement, you can skip the procedure for configuring the common 
configuration options. 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Configuring the Measurement 

Follow these steps to configure the selected measurement: 

1. Configure the options in the Common configuration Panel on page 48. 

2. Select the Standard tab to display the next screen. The Standard tab displays 
the international EMC (Electro Magnetic Compatibility) standards IEC 
61000-3-2, Amd 14 and MIL1399 for which you can perform compliance 
testing. 

 

Figure 3-65: Current Harmonics configuration 

Follow these steps to configure the IEC Standard configurations: 

a. In the Standard tab, select the IEC 61000-3-2 button. Set the Line Frequency 
to either 50 Hz or the 60 Hz.   
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Figure 3-66: IEC standard configuration 

c. Select any one of the ten available Tables. Table1 is the default table. If 
you set the harmonic table, the application displays the class associated with 
in the Select Class combo box. If you run the application for the first time, 
the application associates Class A with all the harmonic tables. If you 
change the Class settings, the application retains the change after you exit 
and rerun the application. 

d. Select the Edit button to display a table editor. The table editor displays 
the Harmonic Number from 1-40 for IEC standard and 1-50 for MIL 
standard, Harmonic Limits in milliamperes and the Harmonic Limits in 
decibel microamperes. Click OK to update the values in the table. 

Figure 3-67: Harmonic Table editor 

b. Use the drop down arrow in the Harmonic Table field to select the table 
and use the Edit button to edit the table. The values in these tables are used 
as Limit values. 

 

Note: You can edit only the Harmonic Limits values mA table. The same change 
is updated in the dbua column. 

 

e. Select a Class using the drop down arrow in the Class field. The 
available classes are: A to D. 

Note: You can edit the harmonic table for Class A and B but not Class C and D. 
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If you select Class C, the application calculates the power factor limit and 
updates the limit table. If you select Class D, the application calculates the limit 
value of the harmonic from the true power of the unit under test. 

f. Click on the Set button to automatically set the limit values of the 
Harmonic table to the selected standard values. These tables are 
applicable only to IEC-6100-3-2 standards and the Amd 14 standards. 

 

IEC issued an amendment (amendment 14) to the IEC 61000-3-2 harmonics 
standard. This is documented as the IEC 61000-3-2 amendment 14 . 

This amendment changes the class definitions, reclassifies many products to 
Class A and clearly defines what Class-D products are (Class D products are 
limited to personal computers + monitors < 600 W, television receivers <600W) 
and affects the newly defined Class-D. The Class C and D limits are based on 
"Manufacturer's Ratings" which must be verified by measurement.   

Follow these steps to configure the Amd 14 configurations: 

a. Set the Line Frequency to either 50 Hz or 60 Hz. 

 

Figure 3-68: Amd 14 configuration 

b. Select the Table using the drop down arrow in the Harmonic Table 
field and select the Edit button to edit the table. Select any one of the 
ten available Tables. Table1 is the default table. If you set the harmonic 
table, application displays the Class associated with in the Select Class 
combo box. If you run the application for the first time, the application 
associates Class A with all the harmonic tables. If you change the class 
settings, the application retains the change after you exit and rerun the 
application. 

c. Select the Edit button to display a table editor. The table editor displays 
the Harmonic Number from 1-40 for IEC standard, Harmonic Limits in 
milliamperes and the Harmonic Limits in decibel microamperes. Click 
OK to update the values in the table. 

d. Select the Class using the drop down arrow in the Class field. The 
available classes are: A to D. The Controls option provides additional 
inputs only to Class C or D.  
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e. Select the Controls button to display the next screen. 

 

Figure 3-69: Controls screen 

f. Use the GP knob next to the Input Power, Power Factor and 
Fundamental Current field to enter the values and select OK. The 
acceptable ranges for: 

� 

� 

Input Power is 0 w to 600 w. The default value is  
100 w 

Power Factor is 0  to 1 . The default value is 0.9 

g. Fundamental Current is 0 A to 16 A. The default value is 16 A 

h. Select the Filter checkbox to obtain filtered harmonic values. 

Note: For Steady state signals Tobs to meet repeatability where Tobs is the 
observation time which is the acquisition period in this measurement. This 
measurement has been set for very short cycle Tsv = 3 seconds. 

Follow this procedure to configure the MIL standard parameters. 

Set the Line Frequency to either 50 Hz or 60 Hz. 
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Figure 3-70: Current Harmonics configuration 

3. In the I-Probe tab, check the Transfer Impedance Table box to enable the I-
Probe Impedance Tables panel. You can enter the frequency deratings of 
any custom probe that you are using for the current measurement. I-Probe is 
applicable for the selected current source where the frequency derating is 
compensated in measurements such as IEC-61000-3-2, Amd 14 and 
MIL1399 standards. Use the drop down arrow in the Impedance Table to 
select any one of the ten available tables. The Impedance table enables to 
enter frequency response of the probe. This helps you to measure the 
frequency component altered by the frequency response of the probe. Table1 
is the default table. Use the Edit button to edit the impedance table.You can 
use the Reset button in the Impedance Table Editor to reset the ratio and dB 
values to the default values.  

 

Figure 3-71: Impedance table editor 

You can use the Impedance table to set the transfer impedance of the probe at 
each harmonic frequency.  The table editor displays the Harmonic Number from 
1-40 for IEC standard and 1-50 for MIL standard, the Impedance ratio and the 
Impedance ratio in decibel.  

114                                                                                       TDSPWR3 Software Analysis Printed Help Document                         



Operating Basics 

4. To edit the harmonic value, select the value and edit the Impedance ratio 
values in the table using the numeric keypad. Select OK. 

5. Press Run to measure. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Viewing Results-Current Harmonics 

To view the results, follow these steps: 

1. From the application menu bar, select View> Results or click the View 
Results button in the Current Harmonics Results panel. 

 

Figure 3-72: Current Harmonics results 
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IEC 61000-3-2 results 

 

Figure 3-73: Current Harmonics IEC Standards results 

If you have selected the IEC standard, the Current Harmonic Results displays the 
following information: 

Table 3-13: IEC Standard result fields 

Option Description 
Harmonic  Displays the harmonic number 
Value  Displays the measured value in dBuA 
Limit  Displays the harmonic limits in dBuA 
Margin Displays the difference between the Value and Limit in 

dBuA. The Status depends on the positive or negative 
margin value 

Result Displays the status of the measurement-Pass or Fail 
 

1. Select the drop down arrow in the View field to view the results in the Mask 
or a Bar Graph format. If you have set the MIL Standard, the mask option is 
not available in the View field. Use the drop down arrow in the Units field 
to set the units to dBuA or A. The Harmonics field displays harmonic 
number as Odd, Even or All. The All option displays the complete set of 
harmonic values. Even displays the even numbered values from 2-40. Odd 
displays the odd numbered values from 1-39. 

2. In the Field and Value table, the Class value field displays the selected class, 
Mode displays the selected Standard, Line Frequency value in Hz, Total 
Harmonic Distortion in percentage, Line Voltage in Volts, Line Current in 
Amperes and Power in Watts. 

3. Select the Browse button to browse to a directory of your choice and select 
the Export button to export the results table as a .csv file. 
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4. Select the drop down arrow in the View field to select the format: Table, Bar 
graph or Mask.  In the bar graph, red indicates the Fail status, green- Pass 
and yellow, the set limits. The Mask option is available only if the harmonic 
table has Class A or D device. In the Mask results, Red indicates the mask 
boundary, yellow indicates one half cycle of the input current waveform. If 
the input waveform is completely inside the mask boundary, the percentage 
in window is 100%. The percentage window indicates how much waveform 
is inside the mask. X axis displays the waveform angle in degrees. Y axis 
indicates the i/i peak where i is the current and i peak is the peak of the 
current in one half cycle. 

5. Select the drop down arrow in the Units field to change the units to decibel 
microamperes or amperes. 

Note: Any change in the Units field is reflected in the Value, Limit and Margin 
fields of the table and the bar graph. 

You can export the .csv file only if you select the table format. 
6. Browse the destination directory, and click the export button to export the 

result in the .csv format. Click OK. 

Amd 14 results 

 

Figure 3-74: Current Harmonics Amd 14 results 

If you have selected the Amd 14 standard, the Current Harmonic Results displays 
40 harmonic values with the following information: 
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Table 3-14: Amd 14 results 

Option Description 
Harmonic  Displays the harmonic number 
Value  Displays the measured value in dBuA 
Limit  Displays the harmonic limits in dBuA 
Margin  Displays the difference between the Value and 

Limit in dBuA. The Status depends on the 
positive or negative margin value 

Result Displays the status of the measurement-Pass or 
Fail 

 

Follow these steps to view the results in the Bar Graph format: 

1. Select the drop down arrow in the View field to view the results in the Bar 
Graph format.  

2. Select the drop down arrow in the Units field to set the units to dBuA or A.  

3. Select the drop down arrow in the Harmonics field displays harmonic 
number as Odd, Even or All. The All option displays the complete set of 
harmonic values. Even displays the even numbered values from 2-40. Odd 
displays the odd numbered values from 1-39. 

In the Field and Value table, the Class value field displays the selected class, 
Mode displays the selected Standard, Line Frequency value in Hz, Total 
Harmonic Distortion in percentage, Line Voltage in Volts, Line Current in 
Amperes and Power in Watts. 

The Field and Value table in the Amendment 14 pane displays the Partial Odd 
Harmonic Current value and Limit in amperes and the Partial Odd Harmonic 
Current status as pass or fail. The Partial Odd Harmonic Current is defined as the 
total rms value of the odd harmonic components of orders 21 to 39. 

4. Browse the destination directory, and click the export button to export the 
result in the .csv format. Click OK to revert back to the current harmonics 
result panel. 
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Amd 14 results with filter 

 

Figure 3-75: Amd 14 results with filter 

If you have selected the Amd 14 standard with Filter, the Current Harmonic 
Results displays 50 harmonic values with the following information: 

Table 3-15: Amd results with Filter 

Option Description 
Average Filtered Harmonics Displays the average value of the individual 

harmonic currents taken over the entire test 
period. (measured average harmonics, limit 
average harmonics and margin (difference 
between limit and measured value) 

Peak Filtered Harmonics Displays the maximum value for each filtered 
harmonics. 

Value  Displays the measured value in dBuA 
Limit  Displays the harmonic limits in dBuA 
Margin  Displays the difference between the Value and 

Limit in dBuA. The Status depends on the 
positive or negative margin value 

Result Displays the status of the measurement-Pass or 
Fail 

Generating Reports-Current Harmonics 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar, to display 
the Report Generator screen.  

Note: The current harmonics report displays the table with the data and not the 
bar graph. You have to generate separate reports for decibel microamperes, 
amperes, even values, and odd values. 
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2. The application provides default factory templates for this measurement. We 
recommend you to use the file layout only. The template file name is 
Current_Harmonics_Page1.rgt.The layout file name is 
Current_Harmonics.rpl. If you have selected Amd 14> Filter option, the 
layout file name is Current_Harmonics_Amd14.rpl.However, if you want to 
select or modify another layout, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Current Harmonics. You can configure all the 
parameters in the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

 For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

Total Power Quality 

Selecting and Configuring Measurements-Total Power 
Quality 

1. Select Measurements> Select from the application menu bar. 

2. Select the Line Power tab and select Total Power Quality option. Select the 
Configure option. 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Configuring the Measurement 

Note: If you use the same voltage source as used for an earlier measurement, you 
can skip the procedure for configuring the common configuration options. 

Follow these steps to configure the selected measurement: 

1. Configure the options in the Common configuration Panel. 

2. Select the Standard tab to display the next screen. The Standard tab displays 
the international EMC (Electro Magnetic Compatibility) standards IEC 
61000-3-2, Amd 14 and MIL1399 for which you can perform compliance 
testing. 
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Figure 3-76: Total Power Quality configuration 

Follow these steps to configure the IEC Standard configurations: 

a. In the Standard tab, select the IEC 61000-3-2 button. Set the Line 
Frequency to either 50 Hz or the 60 Hz.   

 

Figure 3-77: Total Power Quality configuration 

b. Select the drop down arrow in the Harmonic Table field to select the 
table and use the Edit button to edit the table.  

c. Select any one of the ten available Tables. Table1 is the default table. If 
you set the harmonic table, application displays the Class associated 
with in the Select Class combo box. If you run the application for the 
first time, the application associates Class A with all the harmonic 
tables. If you change the Class settings, the application retains the 
change after you exit and re-run the application. 

d. Select the Edit button to display a table editor. The table editor displays 
the Harmonic Number from 1-40 for IEC standard and 1-50 for MIL 
standard, Harmonic Limits in milliamperes and the Harmonic Limits in 
decibel microamperes. Click OK to update the values in the table. 

Note: You can edit only the Harmonic Limits values mA table. 
 

e. Use the drop down arrow in the Class field to select a Class. The 
available Classes are: A to D. 

Note: You can edit the harmonic table for Class A and B but not Class C and D. 
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f. If you select the Class C, the application calculates the power factor 
limit and updates the limit table. If you select Class D, the application 
calculates the limit value of the harmonic from the true power of the 
unit under test. 

g. Click on the Set button to set the Harmonic table to the selected 
standard.  

IEC issued an amendment (amendment 14) to the IEC 61000-3-2 harmonics 
standard. This is documented as the IEC 61000-3-2 amendment 14 . 

This amendment changes the class definitions, reclassifies many products to 
Class A and clearly defines what Class-D products are (Class D products are 
limited to personal computers + monitors < 600 W , television receivers <600W) 
and affects he newly defined Class-D . 

Follow these steps to configure the Amd 14 Standard configurations: 

a. Set the Line Frequency to either 50 Hz or 60 Hz. 

 

Figure 3-78: Total Power Quality configuration 

 

b. Use the drop down arrow in the Harmonic Table field to select the table 
and use the Edit button to edit the table.  

c. Select any one of the ten available Tables. Table1 is the default table. If 
you set the harmonic table, application displays the Class associated 
with in the Select Class combo box. If you run the application for the 
first time, the application associates Class A with all the harmonic 
tables. If you change the Class settings, the application retains the 
change after you exit and re-run the application. 

d. Select the Edit button to display a table editor. The table editor displays 
the Harmonic Number from 1-40 for IEC standard, Harmonic Limits in 
milliamperes and the Harmonic Limits in decibel microamperes. Click 
OK to update the values in the table. 

e. Use the drop down arrow in the Class field to select a Class. The 
available Classes are: A to D. The Controls option provides additional 
inputs only to Class C or D.  

f. Select the Controls button to display the controls screen. 
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g. Use the GP knob next to the Input Power, Power Factor and 
Fundamental Current field to enter the values and select OK. The 
acceptable ranges for: 

� 

� 

� 

Input Power is 0 W to 2 Kw. The default value is 100 w 

Power Factor is 0  to 1 . The default value is 1 

Fundamental Current is 0 A to 16 A. The default value is 16 A 

h. Select the Filter checkbox to obtain filtered harmonic values. 

Follow this step to configure the MIL Standard configurations: 

Set the Line Frequency to either 50 Hz or 60 Hz. 

3. In the I-Probe tab, check the Transfer Impedance Table box to enable the I-
Probe Impedance Tables panel. Use the drop down arrow in the Impedance 
Table to select any one of the ten available tables. The Impedance table 
enables the frequency response of the probe. This helps you to measure the 
frequency component altered by the frequency response of the probe. Table1 
is the default table. Use the Edit button to edit the impedance table. The 
default table is Table1.  

 

Figure 3-79: Total Power Quality configuration 

 

4. Press the Edit button to display a table editor. The table editor displays the 
Harmonic Number from 1-40 for IEC standard and 1-50 for MIL standard, 
the Impedance ratio in decibel units. You can edit only the Impedance ratio 
column in the table. Select OK. 

5. Click on the Reset button in the Impedance Table Editor to reset the ratio 
and dB values to the default values.  Select the View button to view the 
table with the Harmonic Limits, the Harmonic Number and the Harmonic 
Limits in decibel microamperes. You can use the Impedance table to set the 
transfer impedance of the probe at each harmonic frequency.  The table 
editor displays the Harmonic Number from 1-40 for IEC standard and 1-50 
for MIL standard, the Impedance ratio and the Impedance ratio in decibel.  
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Note: You cannot edit the harmonic table for Class C and D. 
 

 

Figure 3-80: Total Power Quality configuration 

 

6. In the Waveform Destination tab, select the Math destination in the Power 
Waveform Destination and Energy Waveform Destination fields. 

7. To edit the harmonic value, select the value and edit the Impedance ratio 
values in the table using the numeric keypad. Select OK. 

8. Press Run to measure. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Viewing Results-Total Power Quality 

To view the results, follow these steps: 

1. Select View> Results to display the following screen. The applications 
displays the results if the measurement is successful or from the application 
menu bar. 
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Figure 3-81: Total Power Quality results 

Note: Since the measurement is a combination of Power Quality and Current 
Harmonics measurements, the results also reflects the same combination. 
 

2. Select the View button to display the following results: 

 

Figure 3-82: IEC Standard results 

 

Table 3-16: Total power quality results 

Option Description 
Harmonic  Displays the harmonic number 
Value  Displays the measured value 
Limit  Displays the IEC standard limits 

or the user defined limits set by 
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you 
Margin  Displays the difference between 

the Value and Limit 
Result Displays the status of the 

measurement-Pass or Fail 
 

If you have selected MIL 1399 standard, the application displays 50 harmonic 
values. In the Field and Value table, the Class value is displayed as NA, Mode 
displays MIL Standard, Line Frequency value in Hz and Total Harmonic 
Distortion in percentage. 

3. Select the drop down arrow in the View field to set the format: Table, Bar 
graph or Mask. If you have set the MIL Standard, the mask option is not 
available in the View field. The Mask option is available only if the 
harmonic table has Class A or D device. In the Mask results, Red indicates 
the mask boundary, yellow indicates one half cycle of the input current 
waveform. X axis displays the waveform angle in degrees. Y axis indicates 
the i/i peak where i is the current and i peak is the peak of the current in one 
half cycle. 

4. In the bar graph, the red indicates Fail status, green- Pass and yellow is for 
the set limits. The mask option displays the True Power and the class of the 
device detected.  

5. Select the drop down arrow in the Harmonics field to display the harmonics 
in three modes -All, Even and Odd. All harmonics displays the complete set 
of harmonic values. Even harmonics display the even numbered values from 
2-40. Odd harmonics display the odd numbered values from 1-39. 

6. Use the drop down arrow in the Units field to change the units to decibel 
microamperes or amperes. The default units is dbmicroA.  

Note: Any change in the units reflects in the Value, Limit and Margin fields of the 
table and the bar graph. 

Note: You can export the .csv file only if you select the table format. 
 

7. Browse the destination directory, and click the export button to export the 
result in the .csv format to 
c:\TekApplications\TDSPWR3\currentharmonics\log. Click OK. 
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Generating Reports-Total Power Quality 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar, to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. We 
recommend you to use the file layout only. The template file name is 
Total_Power_Quality_Page1.rgt. The layout file name is 
Total_Power_Quality.rpl. If you have selected  Amd 14> Filter> Total 
Power Quality option is selected, the layout file name is 
Total_Power_Quality_Amd14.rpl. However, if you want to select or modify 
another layout, follow the procedure given here 

Note: The current harmonics report displays the table with the data and not the 
bar graph. You have to generate separate reports for decibel microamperes, 
amperes, even values, and odd values. 
 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Total Power Quality. You can configure all the 
parameters in the user interface to create a template. The application 
displays the values corresponding to the selected units. If you change the 
unit from decibel microamperes to amperes, the generated report displays 
the updated unit. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

Output Analysis-Ripple Line 

Selecting and Configuring Measurements-Ripple Line 

To select and configure Ripple Measurement, follow these steps: 

1. Select Measurements> Select from the application menu bar. 

2. Select Output Analysis tab to display Output Analysis screen.  

3. Select Ripple Line and press the configure button. 
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Configuring the Measurement 

Follow the steps to configure the selected measurement: 

 

Figure 3-83: Ripple line configuration 

 

1. Configure the options in the Common configuration Panel. 

2. In the Coupling tab, select AC Coupling or DC Coupling. 

3. In the Bandwidth tab, select the Bandwidth option: 20 MHz, 150/250 MHz 
or Full.  

Note: If you use the TDS5000 series oscilloscopes, the application displays 150 
MHz bandwidth and for TDS7000 series oscilloscopes, 250 MHz bandwidth. 
 

4. In the Ripple Frequency tab, set the line frequency to 50 Hz or 60 Hz or 400 
Hz. 

5. In the Acquisition Mode tab, select the acquisition mode of the oscilloscope 
to Peak Detect, High Resolution or Sample mode.  

6. If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Viewing Results-Ripple Line 

To view the results, follow these steps: 

1. Select View> Results from the application menu bar. 

2. The application displays the results for the ripple line measurement with the 
following data as shown below. 
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Figure 3-84: Ripple line results 

Generating Reports-Ripple Line 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is Ripple_Line.rgt and the layout file name is 
Output_Analysis.rpl. When you click on generate report, the application 
displays the default template file name. However, if you want to select or 
modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Ripple Line. You can configure all the parameters in 
the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

TDSPWR3 Software Analysis Printed Help Document           129 



Operating Basics 

Ripple Switching 

Selecting and Configuring Measurements-Ripple 
Switching 

To select and configure Ripple Measurement, follow these steps: 

1. Select Measurements> Select from the application menu bar. 

2. Select the Output Analysis tab to display the Output Analysis screen.  

3. Select Ripple Switching and press the configure button. 

Configuring the Measurement 

Follow the steps to configure the selected measurement: 

 

Figure 3-85: Ripple Switching configuration 

 

1. Configure the options in the Common configuration Panel. 

2. Select the Coupling option from the Coupling tab: AC Coupling or DC 
Coupling. 

3. Select the Bandwidth option from the Bandwidth tab: 20 MHz, 150/250 
MHz or the Full option. The Full option refers to the maximum bandwidth 
available in an oscilloscope. 

Note: If you use the TDS5000 series oscilloscopes, the bandwidth is 
automatically displayed as 150 MHz bandwidth and for TDS7000 series 
oscilloscopes the bandwidth is displayed as 250 MHz and for TDS6000 and 
CSA7000 as 100 MHz. 
 

4. In the Switching Frequency tab, use the GP knob to select a switching 
frequency. The default value is 10 kHz. 
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5. From the Acquisition Mode tab, set the acquisition mode of the oscilloscope 
to Pk Detect, High Resolution or Sample.  

6. Select Run to acquire the data. 

7. If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Viewing Results-Ripple Switching 

To view the results, follow these steps: 

1. Select View> Results from the application menu bar. 

2. The application displays the results for the Ripple measurement with the 
following data. 

 

Figure 3-86: Ripple Switching results 

Generating Reports-Ripple Switching 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is Ripple_Switching.rgt and the layout file name is 
Output_Analysis.rpl. When you click on generate report, the application 
displays the default template file name. However, if you want to select or 
modify another template, follow the procedure given here. 
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3. Select the New Template button in Define Test Template tab to define and 
create a template for Ripple Switching. You can configure all the parameters 
in the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report.  

 For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

Turn-On Time 

Selecting and Configuring Measurements-Turn-On Time 

To select and configure Turn-On Time Measurement, follow these steps: 

1. Select Measurements> Select from the application menu bar. 

2. Select the Output Analysis tab to display the Output Analysis screen.  

3. Select the Turn-On Time and press the configure button. 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Configuring the Measurement 

Follow the steps to configure the selected measurement: 

 

Figure 3-87: Turn-On Time configuration 

1. In the Converter Selection tab, select the type of converter used: AC-DC or 
DC-DC. Select the AC-DC option to enable the Frequency option. Set the 
Line input frequency with the GP knob.  
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� 
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If you have selected AC-DC converter in the Converter tab, in the 
Voltage Level tab, set the Line Voltage Source to Ch1, Ch2, Ch3 or 
Ch4 from the drop down menu. Use the general-purpose knob to enter 
the Maximum Line Voltage and Trigger Voltage whose ranges are 1V 
to 500V.  

If you have selected DC-DC converter in the Converter tab, set the 
Voltage Source to Ch1, Ch2, Ch3 or Ch4 from the drop down menu. 
Use the general-purpose knob to enter the Maximum Voltage Level and 
Trigger Voltage whose ranges are 1V to 500V. 

2. From the Output Voltage tab, turn the OFF button to the ON position in the 
Output 1 panel. Select the channel source from the drop down menu. The 
source can be from Ch1-Ch4. The Output depends on the number of 
channels available in the oscilloscope. 

3. Use the general-purpose knob to enter the maximum voltage value. 

4. Repeat steps 2-3 for Output 2 and Output 3 selections. 

5. From the Max Turn-On Time tab, use the keypad knob to enter the expected 
turn on time in the Max Turn-On Time field. This enables you to set the 
timing window of the oscilloscope. Switch ON the device under test. 

6. Press Run to measure. 

7. If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Viewing Results-Turn-On Time  

To view the results, follow these steps: 

Note: To view the results when the application is running, turn off the power 
supply and turn on to display the results. 
 

1. Select View> Results from the application menu bar. 

2. The application displays the results for the Turn-On Time measurement with 
the following data.  
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Figure 3-88: Turn-on Time results 

 

Generating Reports-Turn-On Time 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is Turnon_time.rgt.and the layout file name is 
Output_Analysis.rpl. When you click on generate report, the application 
displays the default template file name. However, if you want to select or 
modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Turn-On Time. You can configure all the parameters in 
the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 
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Modulation Analysis-Pulse Width 

Selecting and Configuring Measurements-Pulse Width  

1. From the application menu bar, select Measurements> Select. 

2. From the Modulation Analysis tab, select the Pulse Width option. 

3. The next figure shows a typical equipment setup for Pulse Width Analysis. 

  

Figure 3-89: Pulse Width setup 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

Configuring the Measurement 

Follow the steps to configure the selected measurement: 

 

Figure 3-90: Pulse Width configuration 
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1. Select the Source for the measurement from the drop down menu. The 
options available for channel sources are: 1-4. 

2. Select the Ref Destination from the drop down menu. The options available 
for the Ref destinations are:1-4. 

3. In the Ref Level panel, set the Mid and Hysteresis defined as an absolute 
value or Percentage of Pk-Pk value. If you select the Level option, the 
application displays the Mid and Hysteresis in volts. We recommend you to 
set the mid value to 50% of the peak to peak of the source voltage.  

4. Use the GP knob to enter the Mid and Hysteresis values. 

5. Select the pulse width Polarity option: Positive or Negative.  

6. Select Enable Gated Measurement option to analyze a specific section of the 
waveform. If you select Enable Gated Measurement option, the application 
displays a message “Place the cursors at the appropriate region of the 
waveform.” Position the cursor as required. If you select Yes, the 
application analyzes and plots the time trend of the selected section of the 
waveform between the cursors. 

7. Press Run to measure.  

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Note: The application replaces any data in the selected ref destination when you 
analyze and measure modulation. You do not get a warning message here.  

Viewing Results-Pulse Width  

To view the results, follow these steps: 

1. Select View> Results from the application menu bar. 

2. The application displays the results according to the selected pulse width as 
shown below. Check the results on the oscilloscope with reference to the 
plot to display the negative or positive pulse width and time.  
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Figure 3-91: Pulse width modulation results 

Generating Reports-Pulse Width  

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is Pulse_Width.rgt.and the layout file name is 
Modulation_Analysis.rpl. When you click on generate report, the 
application displays the default template file name. However, if you want to 
select or modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Pulse Width. You can configure all the parameters in 
the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

 For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 
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Duty Cycle 

Selecting and Configuring Measurements-Duty Cycle  

1. Select Measurements> Select from the application menu bar. 

2. From the Modulation Analysis tab and select Duty Cycle option. Select the 
Configure option. 

Configuring the Measurement 

Follow the steps to configure the selected measurement: 

 

Figure 3-92: Duty cycle modulation configuration 

 

1. Select the Source for the measurement from the drop down menu. The 
available channel sources are: 1-4. 

2. Select the Ref Destination from the drop down menu. The available ref 
destinations are: 1-4. 

3. In the Ref Level panel, set the Mid and Hysteresis to Level or Percentage. If 
you select the Level option, the application displays the Mid and Hysteresis 
in volts. We recommend you to set the mid value to 50% of the peak to peak 
of the source voltage.  

4. Select the GP knob near the Mid and Hysteresis to display a numeric 
keypad. Enter the values for the Mid and Hysteresis level. 

5. Select the Polarity option: Positive or Negative for the pulse width. 

6. Select the Edge option: Rise or Fall, for the pulse width. 

7. Select Enable Gated Measurement option to analyze a specific section of the 
waveform. If you select Enable Gated Measurement option, the application 
displays a message “Place the cursors at the appropriate region of the 
waveform”. Position the cursor as required. If you select Yes, the 
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application analyzes and plots the time trend of the selected section of the 
waveform between the cursors. 

8. Press Run to acquire the data. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Note: The application replaces any data in the selected ref destination when you 
analyze and measure modulation. You do not get a warning message here.  

Viewing Results-Duty Cycle  

To view the results, follow these steps: 

1. Select View> Results from the application menu bar.  

2. The application displays the results according to the selected duty cycle. 
Check the results on the oscilloscope for the trend plot that displays the 
positive or negative duty cycle and time.  

 

Figure 3-93: Duty cycle modulation results 
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Generating Reports-Duty Cycle  

Follow these steps to generate a report: 

1. From the application menu bar, select Report> Report Generator to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is Duty_Cycle.rgt and the layout file name is 
Modulation_Analysis.rpl. When you click on generate report, the 
application displays the default template file name. However, if you want to 
select or modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Duty Cycle. You can configure all the parameters in 
the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

Clock Period 

Selecting and Configuring Measurements-Clock Period  

1. Select Measurements> Select from the application menu bar. 

2. From the Modulation Analysis tab, select Clock Period option to display the 
following screen.  

Configuring the Measurement 

Follow the steps to configure the selected measurement: 

 

Figure 3-94: Clock period modulation configuration 
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1. Select the Source for the measurement from the drop down menu. The 
available channel source is from 1-4. 

2. Select the Ref Destination from the drop down menu. The available ref 
destination is from 1-4. 

3. In the Ref Level panel, set the Mid and Hysteresis to Level or Percentage. 
Select the Level option to display the Mid and Hysteresis value in volts. We 
recommend you to set the mid value to 50% of the peak to peak of the 
source voltage.  

4. Use the GP knob to enter the values for the Mid and Hysteresis field. 

5. Select the Edge option: Rise or Fall according to the pulse width. 

6. Select Enable Gated Measurement option to analyze a specific section of the 
waveform. If you select Enable Gated Measurement option, the application 
displays a message “Place the cursors at the appropriate region of the 
waveform". Position the cursor as required. If you select Yes, the 
application analyzes and plots the time trend of the selected section of the 
waveform between the cursors. 

7. Press Run to acquire the data. 

8. If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Note: The application replaces any data in the selected Ref destination when you 
analyze and measure modulation. The application does not display a warning 
message here. 

Viewing Results-Clock Period  

To view the results, follow these steps: 

1. Select View> Results from the application menu bar. 

2. The application displays the results for the selected clock period. Check the 
results on the oscilloscope that displays the trend plot of period and time. 
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Figure 3-95: Clock period modulation results 

Generating Reports-Clock Period  

Follow these steps to generate a report: 

1. From the application menu bar, select Report> Report Generator to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is Clock_Period.rgt and the layout file name is 
Modulation_Analysis.rpl. When you click on generate report, the 
application displays the default template file name. However, if you want to 
select or modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Clock Period. You can configure all the parameters in 
the user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

Frequency Modulation 

Selecting and Configuring Measurements-Frequency  

1. Select Measurements> Select from the application menu bar. 
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2. From the Modulation Analysis tab select the Frequency option. Select the 
Configure option. 

Configuring the Measurement 

Follow the steps to configure the selected measurement: 

 

Figure 3-96: Frequency modulation configuration 

1. Select the channel Source: 1-4 

2. Select the Ref Destination:1-4 from the drop down menu 

3. In the Ref Level panel, set the Mid and Hysteresis to Level or Percentage. If 
you select the Level option, the application displays the Mid and Hysteresis 
in volts. We recommend you to set the mid value to 50% of the peak to peak 
of the source voltage.  

4. Use the GP knob to enter the Mid and Hysteresis values. 

5. Select the Edge option: Rise or Fall for the pulse width 

6. Select Enable Gated Measurement option to analyze a specific section of the 
waveform. If you select Enable Gated Measurement option, the application 
displays a message “Place the cursors at the appropriate region of the 
waveform." Position the cursor as required. If you select Yes, the 
application analyzes and plots the time trend of the selected section of the 
waveform between the cursors. 

7. Press Run to acquire the data. 

If the measurement is successful, the application automatically displays the 
results. You can also view the results by selecting View> Results from the 
application menu bar. 

Note: The application replaces any data in the selected ref destination when you 
analyze and measure modulation. You do not get a warning message here.  
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Viewing Results-Frequency  

To view the results, follow these steps: 

1. Select View> Results from the application menu bar. 

2. The application displays the results according to the selected frequency. 
Check the results on the oscilloscope with reference to the trend plot that 
displays the frequency and time.  

 

Figure 3-97: Frequency modulation results 

Generating Reports-Frequency  

Follow these steps to generate a report: 

3. Select Report> Report Generator from the application menu bar to display 
the Report Generator screen.  

4. The application provides default factory templates for this measurement. 
The template file name is Frequency.rgt and the layout file name is 
Modulation_Analysis.rpl. When you click on generate report, the 
application displays the default template file name. However, if you want to 
select or modify another template, follow the procedure given here. 

5. Select the New Template button in Define Test Template tab to define and 
create a template for Frequency. You can configure all the parameters in the 
user interface to create a template. 
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6. Select the Define Report Layout tab to define a layout for this template. 

7. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

Analysis Tools-Spectral Analysis 

Selecting and Configuring Measurement 

Purpose: To analyze the frequency component that contributes to the 
electromagnetic interference and measures the noise/ripple at the output DC 
voltage frequency range. The result plot component plots the spectrum amplitude 
on Y-axis and Frequency (units: Hz) on X-axis. Follow these steps to use the 
Spectral Analysis tool: 

Follow these steps to measure spectral analysis: 

1. Select Analysis Tools tab to display the next screen.  

 

Figure 3-98: Spectral analysis  

 

2. Select Spectral Analysis and click the configure option to display the next 
screen. 

 

Figure 3-99: Spectral analysis configuration 
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3. Click the drop down arrow in the Source field to select the input source. The 
Source field specifies the input source to which the DUT is connected. The 
available options are: Ch1-Ch4, Math1-Math4 and Ref1-Ref4. These 
selections depend on the number of channels in the oscilloscope. 

4. Click the GP knob next to the Start and Stop field to set the frequency 
values. The Frequency Start and Stop options define the frequency range 
values of the input signal to be analyzed. In the Start field, you can set the 
value between the range of 0 Hz to 499 MHz. The default value is 50 Hz. In 
the Stop field, you can set the value between the range of 50 Hz to 500 MHz 
and 300 MHz (For TDS5032 and TDS5034 oscilloscopes only). The default 
value is 10 KHz.  

5. Click the drop down arrow in the Window Type field to set the window 
type. The window type reduces the spectral leakage when using the spectral 
analysis. The available window types are: Rectangular, Hamming, Hanning, 
Black-Harris, Gaussian, Flattop2, Kaiser-Bessel and TekExp.   

In the Options pane, the Auto Setup checkbox is selected by default. The 
application automatically sets the record length and the time base for the given 
Start, Stop and Window Type inputs. Click the Update button in the RBW 
(Resolution and Bandwidth) field to update the RBW values. Use the drop down 
arrow to set the RBW value. The application calculates the RBW values 
depending on the Start, Stop and Window Type inputs.  

If the Auto Setup checkbox is not selected, the Update button is disabled and the 
application runs with the existing record length and time base available in the 
oscilloscope. 

The Options pane is enabled: 

� 

� 

If you have selected a Ref source in the Source field 

If you have selected the Single Run option in the Mode field 

If you have selected a live source in the Source field, select the DC Block check 
box. Clicking the DC Block adjusts the vertical sensitivity of the signal and 
measures the frequency component of the noise at the output DC voltage. 

6. Select the Run button to acquire the data. If you have entered the Start and 
Stop frequency values, the application calculates the selected RBW value, 
sets it to the highest RBW and runs the measurement. If the measurement is 
successful, the application automatically displays the results. You can also 
view the results by selecting View> Results from the application menu bar. 
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Viewing Results 

To view the results, follow these steps: 

1. Click View> Results from the application menu bar or click the View Plot 
button to view the spectrum plot. 

 

Figure 3-100: Spectral analysis plot 

 

The application plots the Frequency values on the X axis and the Amplitude on 
the Y axis and displays the Start and Stop range values. The Y axis shows the 
maximum and minimum range of the voltage peaks  in each division. 

In the Vertical Scale pane, you can switch the plot between the different vertical 
scale values like dB, dBM, RMS and Peak. 

2. Click the Zoom In button and place the cursor on the specific region to 
zoom the plot. You can also use the Zoom Out button to zoom out. 

3. Click the Save button to save the plot in .jpg format in the default directory 
C:\TekApplications\TDSPWR3\Images. 

4. Click the Next button to place the marker on the next highest peak. You can 
also use the Prev button to position the marker on the previous peak. The 
Frequency and Amplitude field displays the values at the specific peak in 
KHz and mV. 

The Marker positions itself on the highest peak value. The Marker Value field 
displays the marker details. The Top Peak Values field displays the first ten 
peaks and the frequencies at which they occur. 
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5. Click the Half Screen button to minimize the plot. Select the Full Screen 
button to return back to the full screen mode. 

 

Figure 3-101: Spectral analysis results 

Generating Reports 

Follow these steps to generate a report: 

1. Select Report> Report Generator from the application menu bar to display 
the Report Generator screen.  

2. The application provides default factory templates for this measurement. 
The template file name is Spectral_Analysis.rgt and the layout file name is 
Analysis_Tools.rpl. When you click on generate report, the application 
displays the default template file name. However, if you want to select or 
modify another template, follow the procedure given here. 

3. Select the New Template button in Define Test Template tab to define and 
create a template for Frequency. You can configure all the parameters in the 
user interface to create a template. 

4. Select the Define Report Layout tab to define a layout for this template. 

5. Select the Generate Report tab to generate, view and print the report. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 
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Troubleshooting Spectral Analysis Error Messages 

If the minimum record length required to configure the Start and Stop values is 
greater than the maximum record length supported by the application, the 
application displays the error message "Frequency Range higher than range 
supported." 

If the sampling rate value is lesser than twice the Stop frequency rate in the 
oscilloscope, the application displays the error message "Sampling rate lesser 
than twice stop frequency." 

Saving and Recalling Setups 

Saving a Setup 

To save the application state and the oscilloscope settings to a setup file, follow 
these steps: 

1. Select File> Save. 

2. Select the Save menu.  

3. Select the directory to save the setup file. 

4. Select or enter a file name. The application appends an ".ini" extension to 
the name of setup files. 

5. Choose Save. 

Note: The application also saves the oscilloscope setup to a ".set" file when you 
save an application setup. Both the application ".ini" file and oscilloscope ".set" 
file have the same file name. 

Note: While saving a Report, the application does not validate for the available 
size in the drive.  

Recalling a Saved Setup 

To recall the application setup and the oscilloscope settings from a saved setup 
file, follow these steps: 

1. Select File> Recall. 

2. Select the directory from which you can recall the application settings. 

3. Select or enter a file name. 

4. Choose Open to display the message "File recalled successfully". 

Note: The application also recalls the oscilloscope setup from a ".ini" file when 
you recall an application setup.  
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Recalling the Default Setup 

To recall the application settings from the Default setup file, follow these steps: 

1. Select File> Recall default to display the message, "Recall default will 
change the existing settings and restore the default settings. Do you wish to 
continue?" 

2. Select Yes to change the current settings to the default settings. Select No to 
retain the current settings. 

Recently Recalled Setup 

To recall the recent setup, follow these steps: 

1. Select File> Recently Recalled to display the last four recalled files. 

2. If you save the settings in any one file from the recently recalled file list and 
the file already exists, the application prompts with a message to overwrite 
the settings. If you select Yes, the application overwrites the settings and if 
you select No, the settings are retained. 

3. The application swaps the files accordingly. For example, if the order is 
file1, file2, file3 and file4, then, on selecting file3, the display order changed 
to file3, file1, file2 and file4. 

Note: The application should not swap the files when the first menu item (file 
name) say for example, file1 from the order file1, file2, file3 and file4; the order 
remains the same. 
 

Recently Saved Setup 

To recall the recent setup, follow these steps: 

1. Select File> Recently saved to display the last four saved files. 

2. If you save the settings in any one file from the recently saved file list and 
the file already exists, the application prompts a message to overwrite the 
settings. If you select Yes, the application overwrites the settings and if you 
select No, the settings are retained. 

3. The application swaps the files accordingly. For example, if the order is 
file1, file2, file3 and file4, then, on selecting file3, the display order changed 
to file3, file1, file2 and file4. 

Note: The application should not swap the files when the first menu item (file 
name) say for example, file1 from the order file1, file2, file3 and file4; the order 
remains the same. 
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Tutorial 

Introduction to the Tutorial 

This tutorial teaches you how to set up the application, take two types of 
measurements, and view the results. 

Before you begin the tutorial, you must do the following tasks: 
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Set up the oscilloscope  

Start the application  

Starting the Application 

Go to the File menu on the menu bar and select Run Application>Power 
Measurements menu to start the application. 

Setting Up the Oscilloscope 

To set up the oscilloscope, follow these steps: 

Go to the File menu in the oscilloscope menu bar and select Recall Default Setup 
to set the oscilloscope to the default factory settings. 

Measuring Power Dissipation 

This section discusses how to measure Power Dissipation, view the results and 
generate report. To perform these tasks, install and enable the option key for the 
application in TDS6000 (TDS6404, TDS6604) CSA7000 (CSA7154, 7404) and 
TDS7000 (TDS7404, TDS7154, TDS7254, TDS7054, TDS7104) TDS5000, 
TDS5032, TDS5034, TDS5054, TDS5052, TDS5104 series oscilloscopes.  

Follow these steps to measure Power Dissipation: 

1. From the oscilloscope menu, select File> Reference Wfm> Recall 
Waveform. 

2. In the Ref 1 tab, select Recall Ref 1 button to recall the switchvoltage.wfm 
waveform file from C:\TekApplications\TDSPWR3\waveforms folder to 
Ref 1. 



Tutorial 

3. In the Ref 2 tab, select Recall Ref 2 button to recall the switchcurrent.wfm 
waveform file from C:\TekApplications\TDSPWR3\waveforms folder to 
Ref 2. 

4. Click the App button to display the application. 

5. In TDSPWR3 application, select Power Dissipation from the Power Device 
tab. Press Configure. 

 

Figure 4-1: Power dissipation configuration 

6. In the common configuration panel, set the Source to Ref, Voltage to  
Ref 1and Current to Ref 2. 

 

Figure 4-2: Power dissipation configurations 

7. Select the Switching Loss measurement. Configure the options in the Type, 
Edge Finder, Ton & Toff Ref Level and the Options tabs. Press the Run 
button. 
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8. The application displays the results as Turn-on Power Loss, Turn-off Power 
Loss, T-Average Loss and Energy. 

Figure 4-3 shows the results in a TDS5000 series of oscilloscopes and figure 4-4 
shows the results in TDS7000 series of oscilloscopes. 

 

 

Figure 4-3: Power dissipation results in a TDS5000 oscilloscope 
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Figure 4-4: Power dissipation results in a TDS7000 oscilloscope 

9. Select Report> Report Generator to generate, view and print reports. 

Measuring B-H Analysis 

This section discusses how to measure B-H Analysis, view the results and 
generate report. To perform these tasks, install and enable the application in 
TDS6000 (TDS6404, TDS6604) CSA7000 (CSA7154, 7404) and TDS7000 
(TDS7404, TDS7154, TDS7254, TDS7054, TDS7104) TDS5000, TDS5032, 
TDS5034, TDS5054, TDS5052, TDS5104 series oscilloscopes.  

Follow these steps to measure B-H Analysis: 

1. From the oscilloscope menu, select File> Reference Wfm> Recall 
Waveform. 

2. In the Ref 1 tab, select Recall Ref 1 button to recall the ref1vol.wfm 
waveform file from C:\TekApplications\TDSPWR3\waveforms folder to 
Ref 1 

3. In the Ref 2 tab, select Recall Ref 2 button to recall the ref2cur.wfm 
waveform file from C:\TekApplications\TDSPWR3\waveforms folder to 
Ref 2. 

4. Click the App button  to display the application 

5. In TDSPWR3 application, select B-H Analysis from the Power Device tab. 
Press Configure. 
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Figure 4-5: B-H Analysis configuration 

6. In the common configuration panel, set the Source to Ref, Voltage to Ref 
1and Current to Ref 2. 

 

Figure 4-6: B-H Analysis configurations 

7. Select the Magnetic Property option. Select the Fixed duty cycle option, 
Cursor Gating Off button and Single Winding button. In the Phy Chars tab, 
select the SI Unit, set the Number of Turns to 50, XsectionArea to 
.00001358m2, Magnetic Length to 0.0265m. 

8. Press Run to display the results in a B-H Curve format. The application 
displays the results for the Bpeak, Br, Hc, HMax and I-ripple. 

Figure 4-7 shows the results in a TDS5000 series of oscilloscopes and figure 4-8 
shows the results in TDS7000 series of oscilloscopes. 
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Figure 4-7: B-H Analysis results in a TDS5000 oscilloscope 

 

 

Figure 4-8: B-H Analysis results in a TDS7000 oscilloscope 

 

9. Select Report> Report Generator to generate, view and print reports. 
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Stopping the Tutorial 

If you need more than one session to complete the tutorial lessons, you can stop 
the tutorial and return later.  

To save the application setup and stop your session, refer to Saving a Setup and 
to Exiting the Application. 

Returning to the Tutorial 

To return to the tutorial, you can start the application and then recall the saved 
setup. To recall the application setup, refer to Recalling a Saved Setup. 
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Application Examples 

About Application Examples 

This section presents many application examples. The simplified AC/DC circuit 
diagram example highlight the application measurements and give you ideas on 
how to use the application to solve your own test problems. 

To run the application examples, install and enable the TDSPWR3 application on 
the oscilloscope, connect the probes to the device under test and configure the 
device. To install the application, refer Installation procedures. For more 
information on compatible probes, refer section, Compatibility and Accessories. 
To configure the application, refer section, Setting Up the Application. 

To Increase Efficiency in a Switching Power Supply 

Measure Switching Loss 

Aim: To optimize the power loss at switching device and improve the efficiency 
of power supply 

 

Specifying the equipment: 
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Tektronix TDS6000 (TDS6404, TDS6604) CSA7000 (CSA7154, 7404) and 
TDS7000 (TDS7404, TDS7154, TDS7254, TDS7054, TDS7104) TDS5000, 
TDS5032, TDS5034, TDS5054, TDS5052, TDS5104 series oscilloscopes. 

TDSPWR3 application 

Appropriate current probe and differential probe 

 

Equipment Setup: 

Refer to General Safety Summary before connecting to a circuit  

1. To measure the voltage across the drain, connect the voltage probe and the 
current probe to the switching source of the MOSFET as shown below: 



Application Examples 

 

Figure 5-1: Equipment setup 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

2. Run the TDSPWR3 application. 

3. Select the Power Device Analysis tab. 

4. Select Power Dissipation option and press the configure button. In the 
common configuration panel, set the appropriate I-Probe Settings. Select the 
Deskew button to deskew probes and channels. 

5. Select Switching Loss measurement. 

6. Select Run to acquire data and display the following results. 

 

Table 5-1: Switching loss results 

Result Description 
Minimum  Measures the minimum power loss or cycle in the 

acquired data 
Maximum  Measures the maximum power loss or cycle in the 

acquired data 
Average  Measures the variation in the power loss for multiple 

acquisitions 
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Analyze Switching Loss 

Aim: To analyze the power dissipation in a switching device in a dynamic 
environment 

Specifying the equipment: 

� 

� 

� 

Tektronix TDS6000 (TDS6404, TDS6604) CSA7000 (CSA7154, 
CSA7404) and TDS7000 (TDS7404, TDS7154, TDS7254, TDS7054, 
TDS7104), TDS5000, TDS5032, TDS5034, TDS5054, TDS5052, TDS5104 
series oscilloscopes. 

TDSPWR3 application 

Appropriate current probe and differential probe 

 

Equipment Setup: 

Refer to General Safety Summary before connecting to a circuit  

1. To measure the voltage across drain, connect the Tektronix differential and 
current probe to the switching source of the MOSFET as shown below: 

 

 

Figure 5-2: Equipment setup 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

2. Run the TDSPWR3 application. 

3. Select the Power Device Analysis tab. 
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4. Select Power Dissipation option and press the configure button. 

5. In the common configuration panel, set the appropriate I-Probe Settings. 
Select the Deskew button to deskew probes and channels. 

6. Select the HiPower Finder measurement.. 

7. Select the Deskew button to deskew. Select Run by setting the appropriate 
trigger related to the dynamic environment and display the results. 

 

Figure 5-3: Power dissipation results 

8. The results display the instantaneous peak power in the switching and the 
number of peaks in the acquired data. Select the range of interest to view the 
area of interest in the instantaneous peak power.  

9. You can link the cursor by selecting the instantaneous peak power from the 
table. 

10. Select the zoom button to view the detailed information around the cursor. 
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Measure Magnetic Loss 

Aim: To measure Magnetic Loss 

Specifying the equipment: 

� 

� 

� 

Tektronix TDS6000 (TDS6404, TDS6604) CSA7000 (CSA7154, 7404) and 
TDS7000 (TDS7404, TDS7154, TDS7254, TDS7054, TDS7104), 
TDS5000, TDS5032, TDS5034, TDS5054, TDS5052, TDS5104 series 
oscilloscopes. 

TDSPWR3 application 

Appropriate current probe and differential probe 

 

Equipment Setup: 

Refer to General Safety Summary before connecting to a circuit  

1. Connect the Tektronix differential and current probe to the switching to 
measure the voltage across the inductor as shown below: 

 

Figure 5-4: Equipment setup 

 
When connecting to a circuit with hazardous voltages, see the warnings for the 
individual products and verify that the probes and other components are used 
within their ratings. Refer to the section General Safety Summary. 

2. Run the TDSPWR3 application. 

3. Select the B-H analysis option from the Power device tab. 
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4. Select Magnetic Loss measurement and select the Cursor Gating option. 

5. In the common configuration panel, set the appropriate I-Probe Settings. 
Select the Deskew button to deskew the voltage and current signal. 

6. Press Run to measure and display the result shown below: 

 

Figure 5-5: B-H Analysis results 

7. The result displays the power loss of the magnetic material. 

Result: 

The results of the Switching Loss, HiPower Finder and Magnetic Loss help 
locate the power dissipation, reduce power loss and improve efficiency. 
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GPIB Commands 

About the GPIB Program 

An example of a GPIB program that can execute the TDSPWR3 measurement is 
included with the application. The oscilloscope hard disk and optional 
applications compact disc both contain the file, TDSPWR3_tpq_rgpib.c. On the 
hard drive, the file resides in the C:\Program Files\TekApplications directory. 

This example shows how a GPIB program executes the application to do the 
following tasks: 

1.  Start up the application 

2.  Recall Total Power Quality setup 

3.  Run the measurement 

4.  Save and query for the result 

5.  Exit the application 

GPIB Reference Materials 

To use GPIB commands with your oscilloscope, you can refer to the following 
materials: 
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The TDSPWR3_tpq_rgpib.c file on the oscilloscope hard drive (located in 
the c:\Program Files\TekApplications directory) and optional applications 
compact disc for an example of a GPIB program that can execute the 
application 

The GPIB Program Example section for guidelines to use while designing a 
GPIB program 

The programmer information in the online help of your oscilloscope 

Guidelines to GPIB Programming 

The application includes an example file of a GPIB program. View the program 
example. Your GPIB program should comply with the following guidelines: 

The application startup must complete before sending additional GPIB 
commands to the application (see example) 
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� 

� 

� 

� 
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� 

The measurements cycle must complete before data is queried (see 
example). 

The status variable should be checked to ensure that an error has not 
occurred because of a measurement command problem 

GPIB event queue needs to be monitored. Make sure the event queue is 
clear before sending the next GPIB command to prevent event queue 
overflow 

Introduction to GPIB Commands 

With knowledge of the GPIB command syntax, you can design a GPIB program 
to do the following tasks: 

Start the TDSPWR3 application 

Recognize an active application with GPIB protocol 

Program and read application setup parameters 

Sequence measurements 

Read measurement results 

Starting and Setting Up the Application Using GPIB 

Starting and Setting Up the Application Using GPIB 

To start the TDSPWR3 application, you must send the oscilloscope the following 
GPIB command: 

application:activate ” Power Measurements 3” 

The application uses the GPIB VARIABLE: VALUE command with arguments 
to execute some features. The set of GPIB commands does not include the 
variable names and variable values necessary to select and configure the 
measurements in the GPIB program. 

You must manually set up the application and oscilloscope, selecting and 
configuring the measurements that you want to use with your GPIB program, and 
save them in a setup file. To save a setup file, refer to Saving a Setup File.Use the 
name of the saved setup file as the value for the "recallName" variables in your 
GPIB program. 

Note: When using GPIB commands, the plots or results are saved in 
C:\TekApplications\TDSPWR3\Temp directory. 
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Sample Program 

/* TDSPWR3 

  

* This is a reference program to illustrate how to communicate to TDSPWR3 

* using Remote GPIB facilities. 

  

  Typical Application does following steps 

 

 1. Start up the application 

 2. Recall Total Power Quality setup 

 3. Run the measurement 

 4. Save the result 

 5. Exit the application 

  

For the current program, we will recall a setup file named as tpqsetup. 

  

You can save setup files according to your own needs using the GUI based 
interface of 

the application. 

  

*/ 

  

 

 #include <windows.h> 

 #include <stdio.h> 

 #include <stdlib.h> 

 #include "decl-32.h" 
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 /* Forward Declarations */ 

 int start_application(int scope); 

 int exit_application(int scope); 

 int do_single_test (int scope); 

 int recall_setup( int scope, char *filename); 

 void display_results(int scope); 

  

 /* parameters needed to access the device driver 
handler */ 

 #define BDINDEX 0      // Board Index 

 #define PRIMARY_ADDR_OF_DMM 1  // Primary 
address of device 

 #define NO_SECONDARY_ADDR 0   // Secondary 
address of device 

 #define TIMEOUT T10s     // Timeout value 
= 10 seconds 

 #define EOTMODE 1      // Enable the END 
message 

 #define EOSMODE 0      // Disable the EOS 
mode 

 char    ErrorMnemonic[21][5] = {"EDVR", "ECIC", 
"ENOL", "EADR", "EARG", 

        "ESAC", "EABO", "ENEB", "EDMA", "", 

        "EOIP", "ECAP", "EFSO", "", "EBUS", 

        "ESTB", "ESRQ", "", "", "", "ETAB"}; 

   

 /* 

 * After each GPIB call, the application checks 
whether the call 

 * succeeded. If an NI-488.2 call fails, the GPIB 
driver sets the 
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 * corresponding bit in the global status 
variable. If the call 

 * failed, this procedure prints an error message, 
takes 

 * the device offline and exits. 

 */ 

  

 void GPIBCleanup(int ud, char* ErrorMsg) 

 { 

   printf("Error : %s\nibsta = 0x%x iberr = 
%d (%s)\n", 

     ErrorMsg, ibsta, iberr, 
ErrorMnemonic[iberr]); 

   if (ud != -1) 

    { 

     printf("Cleanup: Taking device 
offline\n"); 

     ibonl(ud, 0); 

   } 

   exit(0); 

 } 

  

 

 int start_application( int scope )  

 { 

   char write_buffer[100]; 

   char read_buffer[100]; 

   char app_name[] = "\"TDSPWR3\"\n"; 

   int status, timer; 
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   /* Start the TDSPWR3 application */ 

   sprintf(write_buffer, "%s", 
"Application:activate \"Power Measurements 3\""); 

   status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

   if (ibsta & ERR) 

   { 

    GPIBCleanup(scope, "Unable to start 
the application"); 

     return 0; 

         } 

  

   timer = 1; 

   while (1)  

  { 

    /* Check whether application has 
started */ 

     sprintf(write_buffer, "%s", 
"Variable:value? \"application\""); 

     status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

     status = ibrd(scope, read_buffer, 
sizeof(read_buffer)); 

     read_buffer[ibcnt] = '\0'; 

     if (strcmp(app_name, read_buffer) == 
0)  

     { 

       return 1; 

     } 

     timer++; 

     if (timer > 60)  

     { 
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       return 0; 

     } 

       Sleep(1000); 

   } 

  return 1; 

 } 

  

 

 int exit_application(int scope)  

 { 

   char write_buffer[100]; 

   printf("Exit Application ...\n"); 

   sprintf(write_buffer, "%s", 
"Variable:value \"application\",\"exit\""); 

   ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

   return 1; 

 } 

  

 

 int recall_setup(int scope, char* filename)  

 { 

   char write_buffer[100]; 

   int status; 

 

  

  

   /* Set Recall file name */ 

   sprintf(write_buffer, "%s%s%s", 
"Variable:value \"recallName\",\"", filename, "\""); 
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   status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

   if (ibsta & ERR) 

   { 

     GPIBCleanup(scope, "Unable to 
communicate with Scope"); 

     return 0; 

    } 

  

    Sleep(1000); 

  

   /* Recall setup */ 

   sprintf(write_buffer, "%s", 
"Variable:value \"setup\",\"Recall\""); 

   status = ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

   if (ibsta & ERR) 

   { 

      GPIBCleanup(scope, "Unable to 
communicate with Scope"); 

     return 0; 

   } 

  

    

   return 1; 

 } 

  

 

 int run_test (int scope) 

 { 
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   char write_buffer[100]; 

   char read_buffer[100]; 

   int timer; 

   sprintf(write_buffer, "%s", 
"Variable:value \"sequencerState\",\"Sequencing\""); 

   ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

   printf("Executing Test...\n"); 

   Sleep(100); 

  

   /* Wait for application to come to Ready 
State */ 

   timer = 1; 

   while (1)  

  { 

     timer++; 

     if (timer > 90)  

     { 

       printf("******Test Time Out 
******\n"); 

       return 0; 

     } 

     sprintf(write_buffer, "%s", 
"Variable:value? \"sequencerState\""); 

     ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

     ibrd(scope, read_buffer, 99); 

     if (ibsta & ERR)  

     { 

       GPIBCleanup(scope, "Unable to 
write to device"); 
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       } 

     read_buffer[ibcnt] = '\0'; 

     if 
(strcmp(read_buffer,"\"Ready\"\n") == 0)  

     { 

       printf("Test Complete 
...\n"); 

       return 1;     

     } 

     Sleep(1000); 

   } 

 } 

  

  

  

  void result_update(int scope,char* savefilename)  

 { 

  

   char write_buffer[100]; 

   char read_buffer[100]; 

   int status; 

  

   /* Check for errors */ 

   sprintf(write_buffer, "%s", 
"Variable:value? \"status\""); 

   ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

   ibrd(scope, read_buffer, 99); 

   if (ibsta & ERR)  

   { 
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      GPIBCleanup(scope, "Unable to write 
to device"); 

    } 

   read_buffer[ibcnt] = '\0'; 

   if (strcmp(read_buffer,"\"\"\n") != 0)  

   { 

    printf("Error has Occured. Error: 
%s\n",read_buffer); 

    return; 

   }   

 

   

  

   /* Set file name */ 

   sprintf(write_buffer, "Variable:value 
\"tpqresultExpFileName\",\"%s\"",savefilename);  
  

     status = ibwrt(scope, 
write_buffer, strlen(write_buffer)); 

   if (ibsta & ERR) 

   { 

     GPIBCleanup(scope, "Unable to 
communicate with Scope"); 

     return; 

   } 

  

   Sleep(1000); 
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   /*Save Total Power Quality resultant CSV 
file*/ 

  

   sprintf(write_buffer, "variable:value 
\"tpqresultExport\",\"Export\""); 

     ibwrt(scope, write_buffer, 
strlen(write_buffer)); 

   if (ibsta & ERR) 

   { 

     GPIBCleanup(scope, "Unable to start 
the application"); 

     return; 

    }  

  

    Sleep(2000); 

   printf("\t Total Power Quality Result 
stored\n"); 

 

  

 

  } 

  

  

  

 void main() 

 { 

   int Dev; 

   char write_buffer[100]; 

   int status; 

   Dev = ibdev (BDINDEX, PRIMARY_ADDR_OF_DMM, 
NO_SECONDARY_ADDR, 
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   TIMEOUT, EOTMODE, EOSMODE); 

   if (ibsta & ERR) 

   { 

     GPIBCleanup(Dev, "Unable to open 
device"); 

   } 

   else 

   { 

     printf("My device id - %i", Dev); 

   } 

 

   Sleep(1000); 

  

    

 

   sprintf(write_buffer, "%s", "header off"); 

   status = ibwrt(Dev, write_buffer, 
strlen(write_buffer)); 

   if (start_application(Dev))  

   { 

     printf("\nApplication 
started....\n"); 

   } 

   Sleep(10000); 

   recall_setup(Dev,"tpqsetup"); 

   Sleep(2000);  

   run_test(Dev);  

   Sleep(4000);  

   result_update(Dev,"tpq.csv"); 

   Sleep(2000);  
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   exit_application(Dev); 

   /* leave the device back elegantly */ 

   printf("Cleanup: Taking device 
offline\n"); 

   ibonl(Dev, 0); 

  

 } 

 

Variable: TDS Command 

Variable:Value TDS Command 

Description 

This command accepts string arguments for a control or data variable and a value 
to which to set the argument.  

Syntax 

VARIABLE:VALUE "<variable name>","<variable value>" 

The arguments <variable name> and <variable value> are required in the order 
indicated. 

VARIABLE:VALUE? <variable name> for query. 

Note: Commands are case and space sensitive. Your program will not operate 
correctly if you do not follow the capitalization and spacing precisely. 

To start the TDPWR2 application, you must send the oscilloscope the following 
GPIB command: 

application:activate ” Power Measurements 3” 
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Variable:Value TDS Command Arguments and Queries-
Application, Sequencer  

 

Table 5-1: Variable: Value TDS Command Arguments and Queries-Application, 
Sequencer 

Variable Name Valid Values Function Query Form 
Application 
application   exit Setting the value will terminate 

a running application.  
Querying will return the name of the 
currently running application. 

Sequencer 
sequencerState  {Sequencing} -for 

setting{Ready, Sequencing} 
- for query  

Sets the sequencer state  Returns the sequencer state 

 

 

Variable:Value TDS Command Arguments and Queries-
Save, Recall 

 

Table 5-2: Variable: Value TDS Command Arguments and Queries-Save, Recall 

Variable Name Valid Values Function Query Form 
Setup {Default, Recall, Save}   

Sets the save/recall/Default 
action  

Default value for this variable is 
an empty String. Thus variable 
is set to selected value 
momentarily and after 
completion of the task it returns 
to its default value. 

recallName Any string 1-8 chars, comprised 
of A-Z,0-9  Sets the setup recall file name  Returns the setup recall file 

name 
saveName Any string 1-8 chars, comprised 

of A-Z,  0-9   Sets the setup save file name Returns the setup save file 
name 
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Variable:Value TDS Command Arguments and Queries-
Measurement 

 

Table 5-3: Variable: Value TDS Command Arguments and Queries-Measurement 

Variable Name Valid Values Function Query Form 
measSelect   {B-H Analysis, Power Quality, 

Spectral Analysis, Current 
Harmonics, Total Power 
Quality, Power Dissipation, 
Ripple-Switching, Ripple-Line, 
SOA, Pulse Width Modulation, 
Clock Period Modulation, 
Duty Cycle Modulation, 
Frequency Modulation} 
 

Set the measurement name  Returns the set measurement 
name 

 

Variable:Value TDS Command Arguments and Queries-
Common Configuration 

 

Table 5-4: Variable: Value TDS Command Arguments and Queries-Common 
Configuration 

Variable Name Valid Values Function Query Form 

commonSourceType {Live,Ref} Set the source type Return the set source type 
commonVoltSource {Ch1, Ch2, Ch3, Ch4, Math1, 

Math2, Math3, Math4, Ref1, 
Ref2, Ref3, Ref4}. 

Set the voltage source 
depending on the source 
type 

Return the set voltage source 

commonCurrSource {Ch1, Ch2, Ch3, Ch4, Math1, 
Math2, Math3, Math4, Ref1, 
Ref2, Ref3, Ref4}. 

Set the current source 
depending on the source 
type 

Return the set currrent source 

commonProbeType {TCP,current,custom,AM503s} Set the probe type Return the Set probe type 
commonAM503sProbeType {A3x2,A303,A304,A303/XL,A30

4/XL} 
Set the AM503s probe type Return the Set  AM503s probe type 

commonAM503sProbeRange {10e-3,20e-3,50e-3,100e-
3,200e-3,500e-
3,1,2,5,10,20,50,200} 

Set the AM503s probe range Return the 
Set AM503s probe range 

commonCurrentTransferImp Any double value between the 
maximum and minimum value 

Set the current transfer 
impedance value 

Return the Set  current transfer 
impedance value 

commonCustomScaleFact Any value between the 
maximum and minimum value 

Set the custom scale factor Return the Set  custom scale factor 

commonCustomPropDelay Any value between the 
maximum and minimum value 

Set the propogation delay Return the set  propogation delay 
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Variable:Value TDS Command Arguments and Queries-B-H 
Analysis 

 

Table 5-5: Variable: Value TDS Command Arguments and Queries-B-H Analysis 

Variable Name Valid Values Function Query Form 
bhMeasType    {Inductance, Magnetic Loss, 

Magnetic Property} 
Set the B-H Analysis 
measurement type 

Returns the set  measurement 
type 

 

Variable:Value TDS Command Arguments and Queries-BH 
Analysis-Inductance   

 

Table 5-6: Variable: Value TDS Command Arguments and Queries-Inductance 

Variable Name Valid Values Function Query Form 
indEdgeSource {Ch1, Ch2, Ch3, Ch4, Math1, Math2, Math3, 

Math4, Ref1, Ref2, Ref3, Ref4}. 
Sets the edge source Returns the set edge source 

IndRefUnits {Absolute, Percentage} Sets the Reference 
Unit 

Returns the set reference unit 

indPerRefLevel Any double value between the maximum and 
minimum value 

Set the Reference 
Percentage level 

Returns the set reference Percentage level 

indPerHystLevel Any double value between the maximum and 
minimum value 

Set the Hysterisis  
Percentage  level 

Returns the set hysterisis Percentage  level 

indMathDestination { Math1, Math2, Math3, Math4, } Set the math 
destination 

Returns the set reference level 

indAbsRefLevel Any double value between the maximum and 
minimum value 

Set the Reference 
Absolute level 

Returns the set reference Absolute level 

indAbsHystLevel Any double value between the maximum and 
minimum value 

Set the Hysterisis  
Absolute level 

Returns the set hysterisis Absolute level 

indInductanceValue Any double value  Returns the inductance result 
indInductancePlotName Any string file name1-8 chars, comprised of 

A-Z,  0-9 and ending with .jpg 
Set the plot 
destination file name 

Return the set plot file name 

indInductancePlotSave Save Set the Save plot 
action 

 

 

Variable:Value TDS Command Arguments and Queries-
Magnetic Loss 

Table 5-7: Variable: Value TDS Command Arguments and Queries-Magnetic Loss
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Variable Name Valid Values Function Query Form 
magLossCursorgate     

{ 
true,false 
} 

Enable the cursor gating  

magLossPowerLoss Returns double value  Returns the power loss 
value 

 

Variable:Value TDS Command Arguments and Queries-
Magnetic property 

Table 5-8: Variable: Value TDS Command Arguments and Queries-Magnetic 
Property 

Variable Name Valid Values Function Query Form 
magPropWinding {Single,Multiple} Set the magnetic property 

winding 
Returns the set magnetic 
property winding 

magPropDuty    {Fixed,Variable} Set the magnetic property 
Fixed or variable is 
enabled/disabled 

Returns the set magnetic 
property  Fixed or variable  is 
enabled/disabled 

magPropCursor {true,false} Set the magnetic property 
cursor enabled/disabled 

Returns the set magnetic 
property cursor is 
enabled/disabled 

magPropedgeSource {Ch1, Ch2, Ch3, Ch4, 
Math1, Math2, Math3, 
Math4, Ref1, Ref2, Ref3, 
Ref4}. 

Sets the edge source Returns the set edge source 

magPropRefUnits {Absolute, Percentage} Sets the Reference Unit Returns the set reference unit 
magPropAbsRefLevel Any double value between 

the maximum and minimum 
value 

Set the Absolute 
Reference level 

Returns the set absolute 
reference level 

magPropAbsHystLevel Any double value between 
the maximum and minimum 
value 

Set the absolute  Hysterisis 
level 

Returns the set absolute  
hysterisis level 

magPropPerRefLevel Any double value between 
the maximum and minimum 
value 

Set the percentage  
Reference level 

Returns the set percentage  
reference level 

magPropPerHystLevel Any double value between 
the maximum and minimum 
value 

Set the percentage  
Hysterisis level 

Returns the set percentage  
hysterisis level 

magPropMathDestination {Math1, Math2, Math3, 
Math4 } 

Set the math destination Returns the set reference level 

magPropUnits {SI,CGS} Set the units Returns the set the units 
magPropSIXSectionArea Any double value between 

the maximum and minimum 
value 

Set the section area in SI 
units 

Returns the set section area in 
SI units 

magPropNumberOfTurn Any integer value between Set the number of turns Returns the set the number of 
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the maximum and minimum 
value 

turns 

magPropSIXMagLength Any double value between 
the maximum and minimum 
value 

Set the magnetic length in 
SI units 

Returns the set magnetic 
length in SI units 

magPropCGSXSectionArea Any double value between 
the maximum and minimum 
value 

Set the section area in 
CGS units 

Returns the set section area in 
CGS units 

magPropCGSXMagLength Any integer value between 
the maximum and minimum 
value 

Set the magnetic length in 
CGS units 

Returns the set magnetic 
length in CGS units 

magPropMulWindingType {Simultaneous} Select/Deselect Multiple 
windings   Simultaneous 
option 

Returns if multiple winding 
Simultaneous is 
selected/deselected 

magPropCurr2Channel {Ch1, Ch2, Ch3, Ch4,  Ref1, 
Ref2, Ref3, Ref4}. 

Set the current 2 channel Returns the set current 2 
channel 

magPropCurr2Turns Any integer value between 
the maximum and minimum 
value 

Set the current 2 channel 
number of turns 

Returns the set current 2 
channel 
Number of turns 

magPropCurr3Channel {Ch1, Ch2, Ch3, Ch4, Ref1, 
Ref2, Ref3, Ref4}. 

Set the current 3 channel Returns the set current 3 
channel 

magPropCurr3Turns Any integer value between 
the maximum and minimum 
value 

Set the current 3 channel 
number of turns 

Returns the set current 3 
channel 
Number of turns 

magPropBpeak Any double value  Returns the flux density result 
magPropBr Any double value  Returns the remenance flux 

density 
magPropHc Any double value  Returns the coercive Force 

result 
magPropHcmax Any double value  Returns the maximum coercive 

Force result 
magPropBrPlus  Any double value  Returns the Positive 

Remenance flux density result 
magPropBrMinus  Any double  value   Returns the negative 

Remenance flux density result 
magPropHcPlus Any double value    Returns the positive coercive 

Force result 
magPropHcMinus  Any double value   Returns the negative coercive 

Force result 
magPropIripple Any double value  Returns the maximum Ripple 

Current result 
magPropPlotName Any string file name1-8 

chars, comprised of A-Z,  0-
9 and ending with .jpg 

Set the plot destination file 
name 

Return the set plot file name 

magPropPlotSave Save Set the Save plot action  
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Variable:Value TDS Command Arguments and Queries-
Current Harmonics 

 

Table 5-9: Variable: Value TDS Command Arguments and Queries-Current 
Harmonics 

Variable Name Valid Values Function Query Form 
measType {IEC, Amd14, MIL} Set the measurement type Returns the set measurement 

type 
 

iprobeTranImped 
 

{true,false} Select/Deselect transfer impedance 
table 

Returns if the transfer impedance 
is select/deselect 

iprobeTranImpedTable {Table1, Table 2, 
Table3, Table4, Table5 
Table6, Table7, Table8, 
Table 9, Table10} 

Set the transfer impedance table Returns the set transfer 
impedance table 

resultExpFileName Any string file name1-8 
chars, comprised of A-
Z,  0-9 and ending with 
.csv 

Set the plot destination file name Return the set plot file name 

resultExport Export Set the export result action  
 

Variable:Value TDS Command Arguments and Queries-
Current Harmonics-IEC Standard 

Table 5-10: Variable: Value TDS Command Arguments and Queries-Current 
Harmonics-IEC Standard 

Variable Name Valid Values Function Query Form 
iecLineFreq {50,60} Set the line frequency Returns the set line frequency 
iecClass {ClassA,ClassB,ClassC

,ClassD} 
Set the class Returns the set class 

iecHarmonic {Table1, Table 2, 
Table3, Table4, Table5 
Table6, Table7, Table8, 
Table 9, Table10} 

Set the harmonic table Returns the set Harmonic table 

iecSet ClassType Set the table to limits of selected class  
 

184                                                                                       TDSPWR3 Software Analysis Printed Help Document                         



                                                                                                                                        GPIB Commands 

 

Variable:Value TDS Command Arguments and Queries-
Current Harmonics-AMD14 

Table 5-11: Variable: Value TDS Command Arguments and Queries-Current 
Harmonics-AMD 14 

Variable Name Valid Values Function Query Form 
amdLineFreq {50,60} Set the line frequency Returns the set line frequency 
amdFilter {true,false} Selects/Deselects the filter Returns the state of the filter set 
amdClass {ClassA,ClassB,ClassC,ClassD} Set the class Returns the set class 
amdHarmonic {Table1, Table 2, Table3, 

Table4, Table5 Table6, Table7, 
Table8, Table 9, Table10} 

Set the harmonic table Returns the set Harmonic table 

amdSet ClassType 
 

Set the table to limits of 
selected class 

 

amdInputPower Any double value between the 
maximum and minimum value 

Set the input power Returns the set input power 

amdPowerFactor Any double value between the 
maximum and minimum value 

Set the power factor Returns the set power factor 

amdFundCurr Any double value between the 
maximum and minimum value 

Set the fundamental current Returns the set  fundamental current 

Variable:Value TDS Command Arguments and Queries-
Current Harmonics-MIL 

Table 5-12: Variable: Value TDS Command Arguments and Queries-
Current Harmonics-MIL 

Variable Name Valid Values Function Query Form 
MilLineFreq {60,400} Set the line frequency Returns the set line frequency 

 

Variable:Value TDS Command Arguments and Queries-
Power Dissipation 

Table 5-13: Variable: Value TDS Command Arguments and Queries-Power 
Dissipation 

Variable Name Valid Values Function Query Form 
pdMeasType Switching Loss Set the power dissipation 

measurement type 
Returns the set power dissipation 
measurement type 
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Variable:Value TDS Command Arguments and Queries-
Power Dissipation-Switching Loss 

 

Table 5-14: Variable: Value TDS Command Arguments and Queries-Power 
Dissipation-Switching Loss 

Variable Name Valid Values Function Query Form 
switchLossCursorGating {true,false} Select/Deselect cursor gating state Returns if cursor gating 

is in Select/Deselect 
state 

switchLossDuty  {Fixed/Variable} Select/Deselect  Fixed or variable 
state  

 Returns if Fixed or 
variable is 
inSelect/Deselect state 

switchLossUser {true,false} Select/Deselect user state Returns if user is in 
Select/Deselect state 

switchLossDeviceType {MOSFET,BJT} Set the device type Returns the set device 
type 

switchLossRDSOn Any double value between 
the maximum and minimum 
value 

Set the RDSOn value  Return the set  RDSOn 
value 

switchLossVce Any double value between 
the maximum and minimum 
value 

Set the Vce value  Return the set  Vce 
value 

switchLossEdgeSource {Ch1, Ch2, Ch3, Ch4, 
Math1, Math2, Math3, 
Math4, Ref1, Ref2, Ref3, 
Ref4}. 

Set the edge source  Return the set  edge 
source 

switchLossSignalConditioning {true,false} Select/Deselect signal conditioning Returns if signal 
conditioning is in 
Select/Deselect state 

switchLossFilterCurrent {true,false} Select/Deselect FilterCurrent Returns if 
FilterCurrentis in 
Select/Deselect state 

switchLossVoltage SW,VG Set the voltage type Returns the set voltage 
type 

switchLossRefUnits {Absolute, Percentage} Sets the Reference Unit Returns the set 
reference unit 

switchLossPerRefLevel Any double value between 
the maximum and minimum 
value 

Set the Percentage Reference level Returns the set 
percentage reference 
level 

switchLossPerHystLevel Any double value between 
the maximum and minimum 
value 

Set the Percentage  Hysterisis level Returns the set 
Percentage  hysterisis 
level 

switchLossAbsRefLevel Any double value between 
the maximum and minimum 
value 

Set the Absolute Reference level Returns the set 
Absolute reference 
level 

switchLossAbsHystLevel Any double value between 
the maximum and minimum 
value 

Set the Absolute Hysterisis level Returns the set 
Absolute hysterisis 
level 
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switchLossDeviceChannel {P-Channel , N-Channel} Set the device channel  Return the set device 
channel 

switchLossVIUnits {Absolute, Percentage} Sets the VI Unit Returns the set VI unit 
switchLossPerVLevelvalues Any double value between 

the maximum and minimum 
value 

Set the Percentage   V level Value Return the set 
Percentage  V Level 

switchLossPerILevelvalues Any double value between 
the maximum and minimum 
value 

Set the Percentage  I level Value Return the set 
Percentage  I Level 

switchLossAbsVLevelvalues Any double value between 
the maximum and minimum 
value 

Set the Absolute V level Value Return the set Absolute 
V Level 

switchLossAbsILevelvalues Any double value between 
the maximum and minimum 
value 

Set the Absolute I level Value Return the set Absolute 
I Level 

switchLossSwitchOn { true , false} Select/Deselect switch On Return if switch on is 
Select/Deselect 

switchLossVgLevel Any double value between 
the maximum and minimum 
value 

Set the VG level Return the VG level 

switchLossminTonLoss Returns double value  Return the minimum 
Ton Loss 

switchLossmaxTonLoss Returns double value  Return the maximum 
Ton Loss 

switchLossavgTonLoss Returns double value  Return the average Ton 
Loss 

switchLossminTonEnergy Returns double value  Return the minimum 
Ton Energy 

switchLossmaxTonEnergy Returns double value  Return the maximum 
Ton Energy 

switchLossavgTonEnergy Returns double value  Return the average Ton 
Energy 

switchLossminToffLoss Returns double value  Return the minimum 
Toff Loss 

switchLossmaxToffLoss Returns double value  Return the maximum 
Toff Loss 

switchLossavgToffLoss Returns double value  Return the average Toff 
Loss 

switchLossminToffEnergy Returns double value  Return the minimum 
Toff Energy 

switchLossmaxToffEnergy Returns double value  Return the maximum 
Toff Energy 

switchLossavgToffEnergy Returns double value  Return the average Toff 
Energy 

switchLossTotalLoss Returns double value  Return Total loss result 
switchLossTotalEnergy Returns double value  Return Total energy 

result 
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Variable:Value TDS Command Arguments and Queries-
Ripple Line 

Table 5-15: Variable: Value TDS Command Arguments and Queries-Ripple 
Line 

Variable Name Valid Values Function Query Form 
rippleLineCoupling {AC,DC} Set the coupling type Returns the set 

coupling type 
rippleLineBW {20,150/250/100,Full}150-

For 5K scopeand 250 for 
/7054 and 7104 scope100 
for CSA,6K and 7154,7254 
and 7404 

Set the Bandwidth Returns the set 
 Bandwidth 

rippleLineFreq {50,60,400} Set the switching frequency Returns the set the 
switching frequency 

rippleLineAcqMode {High,Pk-Pk,Sample} Set the Acquisition Mode Returns the set 
Acquisition Mode 

rippleLinePKPKRipple Returns double value  Returns the pk-pk ripple 
result value 

 
 

Variable:Value TDS Command Arguments and Queries-
Ripple Switching 

 

Table 5-16: Variable: Value TDS Command Arguments and Queries-Ripple 
Switching 

Variable Name Valid Values Function Query Form 
rippleSwtCoupling {AC,DC} Set the coupling type Returns the set 

coupling type 

rippleSwtBW {20,150/250/100,Full} 
150-For 5K scope 
and  
250 for /7054 and 7104 
scope 
100 for CSA,6K and 
7154,7254 and 7404 

Set the Bandwidth Returns the set 
Bandwidth 

rippleSwtFreq Any double value between 
the maximum and minimum 
value 

Set the switching frequency Returns the set  
switching frequency 

rippleSwtAcqMode {High,Pk-Pk,Sample} Set the Acquisition Mode Returns the set  
Acquisition Mode 

rippleSwtPKPKRipple Returns double value  Returns the pk-pk ripple 
result value 
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Variable:Value TDS Command Arguments and Queries-
Total Power Quality 

 

Table 5-17: Variable: Value TDS Command Arguments and Queries-Total 
Power Quality 

Variable Name Valid Values Function Query Form 
tpqPwrDest { Math1, Math2, Math3, Math4 } Set the power waveform 

destination 
Returns the set power 
waveform destination 

tpqEnergyDest { Math1, Math2, Math3, Math4 } Set the energy waveform 
destination 

Returns the set energy 
waveform destination 

tpqIRMS Returns double value  Returns the IRMS 
result value 

tpqVRMS Returns double value  Returns the VRMS 
result value 

tpqTruePwr Returns double value  Returns the true power 
result value 

stpqAppPwr Returns double value  Returns the apparent 
power result value 

tpqvCrustFactor Returns double value  Returns the voltage 
crust result value 

tpqICrustFactor Returns double value  Returns the current 
crust result value 

tpqFreq Returns double value  Returns the Frequency 
result value  

tpqPwrFactor Returns double value  Returns the  power 
factor result value 

tpqmeasType {IEC, Amd14, MIL} Set the measurement type Returns the set 
measurement type 
 

tpqiprobeTranImped {true,false} Select/Deselect transfer impedance
table 

 Returns if the  transfer 
impedance is 
select/deselect 

tpqiprobeTranImpedTable Table1, Table 2, Table3, 
Table4, Table5 Table6, Table7, 
Table8, Table 9, Table10 

Set the transfer impedance table Returns the set transfer 
impedance table 

tpqresultExpFileName Any string file name1-8 chars, 
comprised of A-Z,  0-9 and 
ending with .csv 

Set the plot destination file name Return the set plot file 
name 

tpqResultExport Export Set the Export csv action  
tpqiecLineFreq {50,60} Set the line frequency Returns the set line 

frequency 
tpqiecClass {ClassA,ClassB,ClassC,ClassD} Set the class Returns the set class 
tpqiecHarmonic {Table1, Table 2, Table3, 

Table4, Table5 Table6, Table7, 
Table8, Table 9, Table10} 

Set the harmonic table Returns the set 
Harmonic table 

tpqiecSet  ClassType Set the table to limits of selected 
class 

 

tpqmilLineFreq {60,400} Set the line frequency Returns the set line 
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frequency 
tpqamdLineFreq {50,60} Set the line frequency Returns the set line 

frequency 
tpqamdFilter {true,false} Selects/Deselects the filter Returns the state of the 

filter set. 
tpqamdClass {A,B,C,D} Set the class Returns the set class 
tpqamdHarmonic {1,2,3,4,5,6,7,8,9,10} Set the harmonic table Returns the set 

Harmonic table 
tpqamdSet  ClassType  Set the table to limits of selected 

class  
 

tpqamdInputPower Any double value between the 
maximum and minimum value 

Set the input power Returns the set input 
power 

tpqamdPowerFactor Any double value between the 
maximum and minimum value 

Set the power factor Returns the set  power 
factor 

tpqamdFundCurr Any double value between the 
maximum and minimum value 

Set the fundamental current Returns the set  
fundamental current 

 

Variable:Value TDS Command Arguments and Queries-SOA 

Table 5-18: Variable: Value TDS Command Arguments and Queries-SOA 

Variable Name Valid Values Function Query Form 

soaPlotType   {Normal,Gated} Set soa gate type  Return the set soa 
gate type 

soaMaskTypeFileName Any string file name1-8 chars, 
comprised of A-Z,  0-9 and 
ending with .smk 

Set soa mask file name  Return the set soa 
mask file name 

soaMaskSetup {soaRecall},  Recall the set soa mask  

soaMaskEnable {true,false}   Enable/disable the soa mask Return if the soa mask 
is enable/disable 

soaPlotImageName    Any string file name1-8 chars, 
comprised of A-Z,  0-9 and 
ending with .jpg 

Save the soa image file name Return the Set soa 
image file name 

soaPlotImageSave Save   Set the Save result action   

soaPassFail {Pass,Fail}  Result Status 
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Variable:Value TDS Command Arguments and Queries-
Power Quality 

Table 5-19: Variable: Value TDS Command Arguments and Queries-Power 
Quality 

Variable Name Valid Values Function Query Form 
PwrQualityPwrDest { Math1, Math2, Math3, Math4 

} 
Set the power waveform destination Returns the set power 

waveform destination 
pwrQualityEnergyDest { Math1, Math2, Math3, Math4 

} 
Set the energy waveform destination Returns the set energy 

waveform destination 
PwrQualityIRMS Returns double value  Returns the IRMS 

result value 
pwrQualityVRMS Returns double value  Returns the VRMS 

result value 
pwrQualityTruePwr Returns double value  Returns the true power 

result value 
pwrQualityAppPwr Returns double value  Returns the apparent 

power result value 
pwrQualityVCrestFactor Returns double value  Returns the voltage 

crust result value 
pwrQualityICrestFactor Returns double value  Returns the current 

crust result value 
pwrQualityFreq Returns double value  Returns the Frequency 

result value  
pwrQualityPwrFactor Returns double value  Returns the  power 

factor result value 
 

Variable:Value TDS Command Arguments and Queries-
Spectral Analysis 

Table 5-20: Variable: Value TDS Command Arguments and Queries-
Spectral Analysis 

Variable Name Valid Values Function Query Form 
specAnalySource {Ch1, Ch2, Ch3, Ch4, Math1, 

Math2, Math3, Math4, Ref1, 
Ref2, Ref3, Ref4}. 

Sets the source  Returns the set source 

specAnalyFreqStart Any double value between the 
maximum and minimum value 

Set the frequency start value Returns the set 
frequency start value 

specAnalyFreqStop Any double value between the 
maximum and minimum value 

Set the frequency stop value Returns the set 
frequency stop value 

specAnalyWindowType {Rectangular, 
Hamming, 
Hanning, 
Black-Harris, 

Set the window type Returns the set window 
type 
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Gaussian, 
Flattop2, 
Kaiser-Bessel, 
TekExp} 
 

specAnalyOptionsAuto {true,false} Select/Deselect options auto setup Returns if the options 
auto setup is 
select/deselect 

specAnalyOptionsDC {true,false} Select/Deselect options  DC block Returns if the options 
DC block up is 
select/deselect 

specAnalyRBWUpdate {update} Update the RBW value  

ResultSpecAnalyResultNam
e 

Any string file name1-8 chars, 
comprised of A-Z,  0-9 and 
ending with .jpg 

Set the plot destination file name Return the set plot file 
name 

resultSpecAnalySaveResult Save Set the Save result action 

Variable:Value TDS Command Arguments and Queries- 
Pulse Width Modulation 

Table 5-21 Variable: Value TDS Command Arguments and Queries- 
Pulse Width Modulation 

Variable Name Valid Values Function Query Form 
PwSource {Ch1, Ch2, Ch3, 

Ch4, Math1, Math2, 
Math3, Math4, 
Ref1, Ref2, Ref3, 
Ref4}. 

Set the source channel Return the set  source 
channel 

PwRefDest {Ref1, Ref2, Ref3, 
Ref4}. 

Set the destination channel Return the set  destination 
channel 

PwEdgeType {Absolute, 
Percentage} 

Set the edge type Return the set edge type 

PwPerRefLevel Any double value 
between the 
maximum and 
minimum value 

Set the percentage reference level Returns the set 
percentage reference 
level 

PwPerHyst Any double value 
between the 
maximum and 
minimum value 

Set the percentage  hysterisis level Returns the set 
percentage  hysterisis 
level 

PwAbsRefLevel Any double value 
between the 
maximum and 
minimum value 

Set the absolute reference level Returns the set Absolute 
reference level 

PwAbsHyst Any double value 
between the 
maximum and 
minimum value 

Set the Absolute Hysterisis level Returns the set Absolute 
hysterisis level 
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pwGatingEnable {true,false} Selects/Deselects the gating Returns the state of the 
gating. 

PwPolarity {Positive,Negative} Set the polarity Return the set polarity 

Variable:Value TDS Command Arguments and Queries- 
Duty Cycle Modulation 

Table 5-22 Variable: Value TDS Command Arguments and Queries- Duty 
Cycle Modulation 

Variable Name Valid Values Function Query Form 
DcSource {Ch1, Ch2, Ch3, 

Ch4, Math1, Math2, 
Math3, Math4, Ref1, 
Ref2, Ref3, Ref4}. 

Set the source channel Return the set  source 
channel 

DcRefDest {Ref1, Ref2, Ref3, 
Ref4}. 

Set the destination channel Return the set  destination 
channel 

DcEdgeType {Absolute, 
Percentage} 

Set the edge type Return the set edge type 

DcPerRefLevel Any double value 
between the 
maximum and 
minimum value 

Set the percentage reference level Returns the set 
percentage reference 
level 

DcPerHyst Any double value 
between the 
maximum and 
minimum value 

Set the percentage  hysterisis level Returns the set 
percentage  hysterisis 
level 

DcAbsRefLevel Any double value 
between the 
maximum and 
minimum value 

Set the Absolute Reference level Returns the set Absolute 
reference level 

DcAbsHyst Any double value 
between the 
maximum and 
minimum value 

Set the Absolute Hysterisis level Returns the set Absolute 
hysterisis level 

DcGatingEnable {true,false} Selects/Deselects the gating Returns the state of the 
gating. 

DcPolarity {Positive,Negative} Set the polarity Return the set polarity 
DcEdgeSlope {Rise,Fall} Set the edge slope Return the set edge slope 
 

Variable:Value TDS Command Arguments and Queries- 
Clock Period Modulation 

Table 5-23 Variable: Value TDS Command Arguments and Queries- 
Clock Period Modulation 

Variable Name Valid Values Function Query Form 
CpSource {Ch1, Ch2, Ch3, Ch4, 

Math1, Math2, Math3, 
Set the source channel Return the set  source 

channel 
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Math4, Ref1, Ref2, 
Ref3, Ref4}. 

CpRefDest {Ref1, Ref2, Ref3, 
Ref4}. 

Set the destination channel Return the set  destination 
channel 

CpEdgeType {Absolute, Percentage} Set the edge type Return the set edge type 
CpPerRefLevel Any double value 

between the maximum 
and minimum value 

Set the percentage reference 
level 

Returns the set percentage 
reference level 

CpPerHyst Any double value 
between the maximum 
and minimum value 

Set the percentage  hysterisis 
level 

Returns the set percentage  
hysterisis level 

CpAbsRefLevel Any double value 
between the maximum 
and minimum value 

Set the Absolute Reference 
level 

Returns the set Absolute 
reference level 

CpAbsHyst Any double value 
between the maximum 
and minimum value 

Set the Absolute Hysterisis 
level 

Returns the set Absolute 
hysterisis level 

CpGatingEnable {true,false} Selects/Deselects the gating Returns the state of the 
gating. 

CpEdgeSlope {Rise,Fall} Set the edge slope Return the set edge slope 

Variable:Value TDS Command Arguments and Queries- 
Frequency Modulation 

Table 5-24 Variable: Value TDS Command Arguments and Queries- 
Frequency Modulation 

Variable Name Valid Values Function Query Form 
FmSource {Ch1, Ch2, Ch3, Ch4, 

Math1, Math2, Math3, 
Math4, Ref1, Ref2, 
Ref3, Ref4}. 

Set the source channel Return the set  source channel 

FmRefDest {Ref1, Ref2, Ref3, 
Ref4}. 

Set the destination channel Return the set  destination 
channel 

FmEdgeType {Absolute, Percentage} Set the edge type Return the set edge type 
FmPerRefLevel Any double value 

between the maximum 
and minimum value 

Set the percentage 
reference level 

Returns the set percentage 
reference level 

fmPerHyst Any double value 
between the maximum 
and minimum value 

Set the percentage  
hysterisis level 

Returns the set percentage  
hysterisis level 

fmAbsRefLevel Any double value 
between the maximum 
and minimum value 

Set the Absolute Reference 
level 

Returns the set Absolute 
reference level 

fmAbsHyst Any double value 
between the maximum 
and minimum value 

Set the Absolute Hysterisis 
level 

Returns the set Absolute 
hysterisis level 

fmGatingEnable {true,false} Selects/Deselects the 
gating 

Returns the state of the gating. 

fmEdgeSlope {Rise,Fall} Set the edge slope Return the set edge slope 
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Variable:Value TDS Command Arguments and Queries-
Error Codes 

 

Table 5-25: Variable: Value TDS Command Arguments and Queries-Error Codes 

Variable Name Valid Values Function Query Form 
status  Valid error codes   Returns the error code 
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Short Cut Keys for TDSPWR3 

 

Table 6-1: Short cut keys for TDSPWR3 

Action Shortcut Keys 
File Menu 
Recall Default  AltF+D 
Recall AltF+R 
Save AltF+S 
Recently Recalled  AltF+C 
Recently Saved  AltF+A 
Preferences AltF+E 
Acquisition Alert Message AltF+E+A 
Minimize  AltF+N 
Exit  AltF+X 
Measurements Menu 
Select  AltM+S 
Configure  AltM+C 
Results Menu 
Results  AltV+R 
Utilities  Menu 
Deskew  AltU+D 
SOA Mask  AltU+M 
Report  Menu 
Report Generator  AltP+R 
Help Menu 
Help Topics  AltH+T 
About TDSPWR3  AltH+A 

 

Note: Use the Alt key with the first keystroke only. Release the Alt key before you 
press the final key. For example, to use the key AltF+N, press the Alt and F keys 
together, release the keys, and then press N. 
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Error Codes for TDSPWR3 

*This value varies according to the acquisition memory option installed on 
the oscilloscope. 
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Table 6-2: Error Codes for TDSPWR3 

Error Codes Error Message   Description Possible Solutions 
 101 Failed to acquire the signal. 

Unable to trigger.  
The oscilloscope is not able to acquire the signal 
and trigger across the DUT (Device Under Test). 

Select the proper trigger source , 
set the trigger level appropriately 
and rerun  the measurement. 

102 Failed to import the waveform.  
 

The operation of importing the waveform from the 
acquisition memory failed. This will fail, whenever 
there is no valid waveform in the acquisition 
memory. 

Reacquire the new waveform. 

103  Failed to find the required 
edges on the waveform.  

The waveform does not have enough edges for the 
selected measurement to run successfully. 

Decrease the horizontal scale of 
the waveform or Increase the 
record length. Set proper Ref and 
hysteresis to find the correct 
edge. 

104 Set the record length lesser 
than XXXXXXX data points.   

Record Length set on the oscilloscope exceeds the 
maximum record length supported by the 
application.  

Click the "Horiz" button or 
"Horiz/Acq" Menu from the 
oscilloscope. Go to Horizontal tab 
and decrease the record length. 

105 Set the record length lesser 
than 4000000 data points. 

 Record Length set on the oscilloscope exceeds the 
maximum record length supported by the 
application to measure spectral Analysis.  

Click the "Horiz" button or 
"Horiz/Acq" Menu from the 
oscilloscope UI. Go to Horizontal 
tab and decrease the record 
length. 

106 Record length of Bpeak cycle is 
greater than 2000000. 

Number of Data points in the B peak cycle is 
greater than 2M record length. 

The number of data points in the 
B peak cycle is greater than 2M 
record length. 

107 Failed to export the waveform. 
Rerun the measurement. 

The operation of exporting the time trend to Ref has 
failed. 

Rerun the measurement. 

108 No waveform data available at 
the selected cursor position. 
Rerun the measurement. 

Cursor is positioned beyond the waveform 
horizontal range of display. 

Position the cursor inside the 
displayed waveform range. 

110 The oscilloscope was unable to 
wait in acquisition RUN state. 
Reacquire the waveform.   

Application will set the oscilloscope in single 
sequence mode and wait for the trigger .  This error 
can occur due to the Long record length and the 
acquisition is not completed if the average mode 
enabled.  

Select the proper trigger source , 
set the trigger level appropriately 
and rerun  the measurement. If 
 this error recurs in the average 
mode of acquisition, in the 
Preferences , enable the 
"Acquisition Alert Message". 

111 No waveform available. 
Reacquire the waveform.   

There is no waveform present in the acquisition 
memory of the oscilloscope. 

Recall the required Ref waveform 
or switch it ON. 

112 Make sure there is data in the 
Ref. 

The Ref waveforms not present in the oscilloscope. Recall the required ref waveform 
or switch it ON. 

113 Data Source associated with The cursor association was not proper. This is due Rerun the measurement. 



Reference 

the cursor is not correct. Rerun 
the measurement.  

to improper data in the cursor association source.  

174 Unable to process ref wfm. 
Record Length is more than 
200K* data points.  

 Click the "Horiz" button or 
"Horiz/Acq" Menu from the 
oscilloscope UI. Go to Horizontal 
tab and decrease the record 
length. Re-Acquire the Live 
waveforms. Save on ref. 

175  Unable to process ref wfm. 
Record length is more than 
4000000 

 Record Length of the ref waveform exceeds the 
maximum record length supported by the 
application for Spectral Analysis  

Click the "Horiz" button or 
"Horiz/Acq" Menu from the 
oscilloscope UI. Go to Horizontal 
tab and decrease the record 
length. Re-Acquire the Live 
waveforms  Save on ref.  
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Error Codes for TDSPWR3 Cont... 

 

Table 6-3: Error Codes for TDSPWR3 

Error Codes Error Message   Description Possible Solutions 
201 Unable to perform calculation. 

Source waveforms have different 
time/div settings. 

The voltage and current waveforms 
have different time/div settings. 

Try running the selected 
measurement with voltage and 
current waveform acquired 
simultaneously.  

202 
Unable to perform calculation. 
Source waveforms have different 
record lengths. 

The voltage and current waveforms 
have different record lengths. 

Try running the selected 
measurement with voltage and 
current waveform acquired 
simultaneously with the same 
record length. 

203 Higher sample rate is required for 
accurate measurement. Decrease 
time/div. 

 The time/div for the selected 
waveform is more. Alternatively 
sampling rate is low.  

Turn the horizontal scale button 
clockwise from the 
oscilloscope's front panel. 

204 Make sure that at least one 
complete cycle is available for 
analysis. 

The signal has less than one cycle 
in the specified record length. 

Increase the record length or 
decrease the time/div of the 
waveform.  

205 Make sure that the cycle has more 
than 20 sample points.   

Number of samples between two 
edges on a rising or a  falling slope 
is less than 20.This ensures the 
presence of  a valid signal. 

Number of samples between two 
edges on a rising or a  falling 
slope is less than 20.This 
ensures the presence of  a valid 
signal. 

206 Unable to get Frequency value, 
when queried from the 
oscilloscope. 

When oscilloscope is not able to 
return the maximum and minimum 
levels this error is thrown. 

Rerun the measurement. 

251 Insufficient edges for Modulation 
Analysis measurement. Modulation 
Analysis   

Number of edges found on the 
source waveform is fewer than the 
minimum number of edges required 
 to run the measurement. 

a) Decrease the horizontal scale 
to have more complete cycles of 
the waveform. 
b) Select the source that has the 
cyclic behaviour in nature  
c) Adjust the Ref and Hysteresis 
level of the signal to find the 
edge at the required level.  

252 Ref Level is outside the voltage 
range of the waveform. Modulation 
Analysis Enter a proper Ref Level. 

Unable to locate the edges on the 
waveform at the transition due to 
the level of the voltage do not fall in 
the transition of the waveform.  

Enter the Ref Level voltage 
where the transition is occurring 
on the waveform. Enter the 50% 
of the level of the peak to peak 
transition level. 

273 Unable to process ref wfm.  High 
sampling rate is required for 
accurate measurement   

The time/div for the selected 
waveform is more. Alternatively 
sampling rate is low. 

Turn the horizontal scale button 
clockwise from the 
oscilloscope's front panel. Re-
Acquire the Live waveforms. 
Save on ref. 

274 Unable to process ref wfm. Not 
enough signal cycles in a record. 
At least one cycle is required.   

The signal has less than one cycle 
in the specified record length. 

Increase the record length or 
decrease the time/div of the 
waveform. Re-Acquire the Live 
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waveforms. Save on ref. 
301 Conflict in selection of sources.    The sources selected for voltage 

and current is same. 
Select different channel sources 
for voltage and current.  

302 Conflict in selection of math 
destinations.   

The Math sources selected as 
destinations may be same. 

Select different math sources  as 
destinations. 

303 Invalid combination of Voltage and 
Current sources.  

Fast Acq mode  works only for 
paired channels. 

Select only paired channels like 
Ch1/Ch2 or Ch2/Ch1 or 
Ch3/Ch4 or Ch4/Ch3 to run the 
measurement. 

304 Conflict in selection of Voltage 
source and Math destination.  

The voltage math source and math 
destination are the same 

Select different channel sources 
for voltage source and math 
destination. 

305 Ref destination used in the 
definition of math voltage source. 

Math is defined as a function of Ref. Define math only as a function of 
live source. 

306 Conflict in selection of source and 
destination. 

Voltage /Edge Source is same as 
the Math destination. 

Select different channel sources 
for voltage source/edge source 
and math destination. 

351 Unable to plot SOA due to 
insufficient data points.   

Insufficient data points to plot. Place the cursors on the 
waveform where at least two 
data points are present between 
the cursors. 

 

Error Codes for TDSPWR3 Cont... 

 

Table 6-4: Error Codes for TDSPWR3 

Error Codes Error Message Description Possible Solution 
401  Set the time/div to 10ms/div.   The current harmonics algorithm 

(IEC standard) requires the 
horizontal scale to be 10ms.  

Change the horizontal scale to 
10ms using the knobs in the front 
panel of oscilloscope. 

402 Set the record length to 2500.   The current harmonics algorithm 
(IEC Standard) requires record 
length of the waveform to be 2500. 

Set the record length to 2500. 

403 
 

Calculated true power is negative. This happens if the current 
direction and voltage polarity is 
reversed or if current is more than 
voltage by 90 degree or frequency 
is not equal to input frequency. 

Ensure that the direction of 
current and voltage polarity are 
right. Ensure frequency of the 
signal is equal to the selected 
frequency. 

404 Class D detected; Harmonic Limits 
will be set to Class D. 

Equipment Class A was selected 
but Class D detected  

 

405 Class A detected; Harmonic Limits 
will be set to Class A.  

Equipment Class D was selected 
but Class D not detected 

 

406 Set Horizontal scale to 200 ms and 
record length to 10,0000.   

The current harmonics algorithm 
(MIL standard) requires horizontal 
scale to be 200 ms record length 
100000. 

Change the horizontal scale to 
200 ms record length to 10,0000. 

407 Set Horizontal scale to 400 ms and 
record length to 20,0000   

The current harmonics algorithm 
(MIL standard) requires horizontal 

Change the horizontal scale to 
400ms using the front panel of 
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scale to be 400ms record length 
20,0000. 

oscilloscope. Set the record 
length 20,0000 To get the 
appropriate record length and 
scale, set the source for the 
measurement either as Ch1 and 
Ch2 or Ch3 and Ch4.Switch of 
the unused channels. 

408 Set Horizontal scale to 200 ms and 
record length to 12,5000 

The current harmonics algorithm 
(MIL standard) requires horizontal 
scale to be 200 ms record length 
12,5000 

Change the horizontal scale to 
200 ms, record length to 12,5000. 

409 Set Horizontal scale to 400 ms and 
record length to 10,0000 

The current harmonics algorithm 
(IEC A14 standard) requires 
horizontal scale to be 400 ms 
record length 10,0000. 

Change the horizontal scale to 
400 ms, record length to 10,0000. 

410 Set Horizontal scale to 400 ms and 
record length to 12,5000 

The current harmonics algorithm 
(IEC A14 standard) requires 
horizontal scale to be 400 ms 
record length 125000. 

Change the horizontal scale to 
400 ms record length to 125000. 

411 Unable to calculate harmonics for 
the record length, sampling Rate 
combination 

Current Harmonics could not be 
run for the record length and 
sample rate combination. 

Change the horizontal scale and 
record length. 

412 Calculated Power is greater than 
25 W. Set the value greater than 25 
W and enter power factor and input 
current. 

IEC Amendment 14 requires the 
power factor and input current to 
be entered by the user for Class C 
equipment type when power is >25 

Enter Power greater than 25 and 
enter current and power factor 
values. 

451 Not enough samples available for 
analysis.  

The slope calculation requires a 
minimum of 3 samples  

Increase record length. 

452 Low Level cannot be greater than 
High Level.  

dv/dt Low level cannot be greater 
than high level 

Enter levels such that low is 
lesser than high. 

453 Levels entered not within the range 
of the waveform.    

Unable to locate the edges on the 
waveform at the transition due to 
the level of the voltage do not fall in
the transition of the waveform. 

Enter the Ref Level voltage where 
the transition is occurring on the 
waveform. Enter the 50% of the 
level of the peak to peak 
transition level. 

454 Oscilloscope settings changed. 
Rerun the measurement di/dt, 
dv/dt.   

If the user changes any of the 
vertical horizontal settings such 
that the oscilloscope goes into 
preview mode after running the 
di/dt and dv/dt for edge analysis . 

Do not change the settings after 
the results are obtained for di/dt 
and dvdt. 

455 Unable to calculate di/dt for the 
configured levels. Cursors will be 
placed for maximum di/dt. 

Configured levels not found on the 
edge . 

Reconfigure the levels. 

456 Unable to associate the cursor to 
the selected data. 

Unable to associate the cursor to 
the   identified peak value of the 
power 

Scope Setting has been altered. 
Rerun the measurement. 

457 Unable to calculate dv/dt for the 
configured levels. Cursors will be 
placed for maximum dv/dt. 

Configured levels not found on the 
edge . 

Reconfigure the levels. 

471 Unable to process ref wfm. 
Horizontal Scale is not equal to 
10ms   

The current harmonics algorithm 
for IEC standard requires the 
time/div to be 10ms/div.  

Change the time/div to 10mz/div 
using the front panel of 
oscilloscope. Reacquire the Live 
waveforms. Save on ref. 
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472 Unable to process ref wfm. Record 
Length is not equal to 2500  

The current harmonics algorithm 
for IEC Standard requires record 
length of the waveform to be 2500. 

Set the record length to 
2500.Reacquire the Live 
waveforms. Save on ref. 

476 Unable to process ref wfm. 
Horizontal scale is not equal to 
200ms/Record Length is not equal 
to 100000  

The current harmonics algorithm 
for MIL standard requires 
horizontal scale to be 200ms, 
record length 100000.  

Set the record length to 100000, 
horizontal scale to 200ms Save 
on ref. 

477 Unable to process ref wfm. 
Horizontal scale is not equal to 
400ms/Record Length is not equal 
to 200000 

The current harmonics algorithm 
for MIL standard requires 
horizontal scale to be 400ms, 
record length 200000. 

Set the record length to 200000, 
horizontal scale to 400ms Save 
on ref .To get the appropriate 
record length and scale, set the 
source for the measurement 
either as Ch1 and Ch2 or Ch3 
and Ch4.Switch of the unused 
channels. 

478 Unable to process ref wfm. 
Horizontal scale is not equal to 
200ms/Record Length is not equal 
to 125000.  

The current harmonics algorithm 
for MIL standard requires 
horizontal scale to be 
200ms,record length 125000. 

Set the record length to 125000, 
horizontal scale to 200ms Save 
on ref. 

479 Unable to process Ref waveform. 
Horizontal scale is not equal to 
400ms or Record Length is not 
equal to 100000. Current 
Harmonics.  

The current harmonics algorithm 
for IEC 61000-3-2 A14 standard 
requires horizontal scale to be 
400ms,record length 100000. 

 Set the record length to 100000, 
horizontal scale to 400ms Save 
on ref. 

481 Unable to process Ref waveform. 
Failed to calculate harmonics for 
the available record length and 
sample rate. 

Current Harmonics requires 
particular  record length , sample 
rate for each standard. 

Save ref waveform with valid 
record length and sample rate for 
the particular standard. 

482 Vertical scale of switch Voltage is 
greater than 10 V and RDSON or 
Vce(SAT) not defined. The 
calculated energy and loss may not 
be accurate.  

This is a warning message and 
comes if  the vertical scale of the 
switch voltage is greater than 10V 
per division and device parameter 
RDSON or V(SAT) ce is not 
selected. 

Select device type MOSFET or 
IGBT/BJT and enter the 
respective parameter.  

483 Total Loss and Total Energy not 
calculated. The number of 
switching cycles available is less 
than one. Switching Loss   

If the user selects portion of the 
switchng like TON or TOFF then 
switching loss cannot be calculated 
since loss requires at least one 
complete cycle 

If the loss values are required 
place the cursors or make sure 
one complete cycle is present  on 
the oscilloscope before pressing 
RUN. 

484 Multiple edges found in a switching 
cycle or DC offset present in the 
waveform.   

This error is thrown in two 
scenarios: 1) When multiple edges 
are found with in a switching cycle. 
 This is due to improper ref and 
hysteresis level. 2)If voltage and 
current probes are not properly 
compensated for DC offset the 
configured Ton and Toff level are 
not met, So error is thrown for this. 

Set the ref hysteresis level for the 
voltage edge source. Remove the 
DC offset in the probes and re-run
the measurements. 

485 The calculated edge at (Ref Level 
+/- Hysteresis/2) is less than Ton & 
Toff Voltage Level.  Reconfigure 
the levels. Switching Loss   

The error check is when the 
configured Ton and Toff level must 
be less than edge ref level + 
hysteresis /2. 

Set the ref and hysteresis level/2 
> than Ton and Toff level and re-
run the measurement. 

486 The calculated edge at (Ref Level 
+/- Hysteresis/2) is less than Ton & 

The error check is when the 
configured Ton and Toff level must 

Set the ref and hysteresis level/2 
> than Ton and Toff level and 
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Toff Current Level.  Reconfigure 
the levels.  

be less than edge ref level + 
hysteresis /2. 

rerun the measurement. 

487 The calculated edge at (Ref Level 
+/- Hysteresis/2) is greater than 
80% Gate Voltage.  Reconfigure 
the levels. 

The error check is when the 
configured edge ref level + 
hysteresis /2. is greater than 80% 
of the gate voltage. 

Set the ref and hysteresis level/2 
< 80% of the Vg and rerun the 
measurement. 

488 (Ref Level +/- Hysteresis/2)is 
greater than 100%. Reconfigure the
levels.  

The error check is the edge ref 
level + hysteresis /2 >100%.  

 Set the ref and hysteresis level/2 
<100%and re-run the 
measurement. 

489 Not able to get Max/Min value, 
when queried from the 
oscilloscope.  

When oscilloscope is not able to 
return the maximum and minimum 
levels this error is thrown. 

Re-run the measurement. 

491 Switching Loss and energies in the 
result can be zero. The probable 
reason is there can be sharp spike 
in the switch current during turn 
ON. The amplitude of the spike is 
greater than remaining portion the 
switch current cycle. This affects 
configured I-level (%) and this is 
converted to absolute as product of 
the maximum spike current and 
percentage level. So check the I 
and V levels and rerun the 
measurement. Switching Loss  

The probable reason is there can 
be sharp spike in the switch current
during turn ON. The amplitude of 
the spike is greater than remaining 
portion the switch current cycle. 
This affects configured I-level (%) 
and this is converted to absolute as
product of the maximum spike 
current and percentage level.  

So check the I and V levels and 
Rerun the measurement. 

492 Calculated Switching Loss and 
Energy are zero. There may be a 
sharp spike in the switch current 
during turn ON or the amplitude of 
the spike may be greater than the 
remaining portion of the switch 
current cycle. Check the I and V 
Levels and rerun the measurement. 
Switching Loss  

There may be a sharp spike in the 
switch current during turn ON or 
the amplitude of the spike may be 
greater than the remaining portion 
of the switch current cycle  

Check the I and V Levels and 
rerun the measurement. 

493 Number of samples between the 
cursors is less than two. Reposition 
the cursors and rerun the 
measurement.   

This is caused by improper placing 
of cursors such that there are no 
sample points between the 
cursors. 

Reposition the cursors and rerun 
the measurement. 

494 The calculated Total Loss and 
Energy is less than sum of Ton and 
Toff Loss and Energy. 

This warning is displayed when 
total loss or energy is less than 
sum of Ton and Toff loss or 
energy. This may occur when  dc 
offset is present in the switch 
Remove the dc offset in the voltage
probe by compensating and 
degauss the current probe.  

Remove the DC offset in the 
voltage probe by compensating 
and degauss the current probe. 
Check the edge ref levels and 
hysteresis band. Change the 
hysteresis band if there is 
noise/large variation of the 
sample points in the switch 
voltage or gate voltage. 

498 Number of samples between the 
consecutive edges is less than ten. 
Increase the sample rate and use 
HiRes acquisition mode. 
 

This warning occurs when multiple 
edges found with in a switching 
cycle. The probable reason for 
multiple edges is ringing present in 
the switch voltage.  
 

Configure the edge level to avoid 
ringing portions and  increase the 
hysetrisis band. Use the 
recommended  
HiRes for the acquisition mode. 
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Error Codes for TDSPWR3 Cont... 

 

Table 6-5: Error Codes for TDSPWR3 

Error Codes Error Message   Description Possible Solutions 
503 Set the coupling to 1M Ω   Selected channel input coupling is 

set to 50 Ω. 
Change the hysteresis band if 
there is noise/large variation of 
the sample points in the switch 
voltage or gate voltage. 

504 Start Frequency cannot be greater 
than or equal to Stop Frequency.  

The entered value of start frequency 
is higher than the entered value of 
stop frequency 

Stop cannot be lesser than start 
frequency Enter start frequency 
> stop frequency. 

505 Frequency Resolution (sample 
rate/record length) is greater than 
Stop Frequency. 

The Frequency resolution for the 
signal for the record length and 
sampling rate combination is greater
than the stop frequency component 
to be analyzed. 

Increase record length or 
decrease the sampling rate such 
that stop frequency > frequency 
resolution (frequency resolution 
= sampling Rate / record length) 
and run the measurement. 

506 Configured sample rate is less 
than twice Stop Frequency.  

Sampling Rate should be >= twice 
stop frequency for accurate analysis 
to prevent alaising. 

Increase sampling rate such that 
sampling rate >=2*stop 
frequency. 

507 The frequency resolution (sample 
rate/record length) is greater than 
the frequency range. 

The Frequency resolution for the 
signal for the record length and 
sampling rate combination is greater
than the range of frequencies to be 
analyzed.  

Decrease the Stop frequency to 
run or use the autoset option for 
automatic record length and time 
base settings. 

509 1M Coupling required, DC block 
cannot be performed. 

50 ohms coupling is required for DC 
 block Operation  

Set coupling to 1Meg 

510 File path not available to save the 
Spectral Analysis Plot.  

Path entered for saving the plot is 
not valid 

Enter a valid path name. 

511 The RBW value was not updated. 
It will be set to maximum value.  

RBW values are not updated for the 
selected start, stop frequency and 
window Type 

Update RBW values after 
selecting start/stop frequency 
/window type before running the 
measurement. 

512 The oscilloscope settings changed.
Cannot set the selected RBW 
value. Spectral Analysis   

User might have changed the 
settings on the oscilloscope after 
updating the RBW values for the 
selected start/stop frequency 
window type 

Update RBW values after 
selecting start/stop frequency 
/window Do not change the 
scope settings after updating 
RBW values.  

513 The configured Frequency Range 
is not supported Spectral Analysis 
  

For the range selected there are no 
RBW values available for Spectral 
analysis measurement 

Increase the start frequency or 
decrease stop frequency. To run 
without autoset uncheck 
autosetup in options panel. 

550 Timing synchronization of the 
previously acquired waveform is 
not matching with the current 
acquisition. Rerun the 
measurement Magnetic Property.  

Time domain Synchronization is 
essential for the calculation of 
results even though the waveforms 
were not acquired simultaneously. 
The synchronization is checked for 
the given trigger level , trigger 
position ,cursor position for the 

Do not alter these settings which 
result in loss of synchronization. 
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present  waveform with the 
previously acquired waveform.  

551 Number of data points in a cycle is 
less than 10. Magnetic Property.  

The  number of data Points in the 
identified cycle is less than 10  data 
points. Increase the Hysteresis, Ref 
Level, for the correct identification of 
Edge Source. 

Use the Gate waveform as edge 
source if the ringing is more on 
the Voltage waveform. 

552 Not enough samples for Bdc 
calculation. 

The Number of Data points 
available for the Calculation of DC 
value of Flux density is insufficient 
in  a) Number of data points in 
identified cycle b) Lesser number of 
data points in Identification of 
Integral Number of Cycle  

If you are Using the Current 
source as Edge source , Increase
the number of  division of the 
Current waveform, 
b) If the current waveform is 
noisy, use Hires mode to remove 
noise.  
c) Increase the Hysteresis and 
Adjust the Ref Level for the 
correct identification of edge and 
Integral number of Cycles. 

553 Not enough samples available in a 
cycle for analysis. 

Insufficient number of samples in a 
complete cycle. Magnetic Property 
The  Number of data Points in the 
identified cycle is less than 10  data 
points. 

Increase the Hysteresis , Ref 
Level, for the correct 
identification of Edge Source. B) 
Use the Gate waveform as edge 
source if the ringing is more on 
the Voltage waveform. 

602 The calculated skew value is 
greater than the oscilloscope 
deskew range 

The skew computed is greater than 
the oscilloscope deskew range. So 
the deskew will be done to 
maximum range value. 

The deskew will be done to 
maximum deskew value 
applicable to the oscilloscoope. 

603 Edges on the waveform are lesser 
than the Number of Edges 
configured. Deskew Number of 
edges set by the user for 
performing the deskew is not 
available on the waveform.   

Number of edges set by the user for 
deskewing is unavailable on the 
waveform. 

Make sure that the edges in the 
waveform has and the display in 
the numeric input are same. a) 
Adjust the horizontal scale to 
increase the number of transition 
that is required for adjusting the 
deskew.    

604 Edges on the waveform are 
greater than the required number 
of edges for internal deskew.  

Internal deskew in TDS 5000 series 
oscilloscopes expect only one edge 
in the waveform for deskew.  

The waveform or the setup may 
be wrong To make accurate 
connections, follow the 
procedure in section “Deskewing 
Probes and Channels” of the 
Online Help.  

605 Hysteresis Level / 2 + Ref  Level 
cannot be greater than 100%    

Level for finding the edge is more 
than the maximum level of the 
signal. 

Adjust the Ref level and 
Hysteresis level such that it 
should not exceed the maximum 
level of the signal in percentage. 

606 Error in copying the delays.txt file. 
Reinstall the application with the 
correct file to perform deskew.  

File corrupted to run the static 
deskew measurement. 

Restart the application with the 
correct file to perform deskew. 
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Error Codes for TDSPWR3 Cont... 

 

Table 6-6: Error Codes for TDSPWR3 

Error Codes Error Message Description Possible Solution 
801 Unable to find the required 

edges. Reacquire the waveform. 
  

The waveform may not be able to 
find the required edges due to 
following reasons: 
Noisy signal  
 Low Hysteresis band level is 
selected  
 Oscilloscope is in the preview mode 
The same error reflects   low record 
length leading to less number of 
samples. 

If the signal is too noisy, enable 
the average mode and acquire 
the signal instead of sample 
mode. This reduces the jitter on 
the signal and smoothens the 
signal. Increase the hysteresis 
band level from the application to 
compensate for noise in the 
signal. 

803 Number of samples available for 
analysis during switching ON or 
OFF is zero.  

Due to Low Record Length, number 
of samples present during Switching 
ON or OFF is zero, which leads to 
infinity when calculating the 
switching frequency which is 
calculated for every switching. 

Increase the record length and re-
run.  Increase the record length to 
have enough samples during 
each switching. 

804 Number of samples during 
switching ON or OFF should be 
greater than two. 

If the number of samples between 
10% and 90% of switching ON or 
OFF portion of the voltage waveform
is less than two , application 
displays warning message. 

Increase the record length to 
have enough samples during 
each switching. 

805 Invalid data for HiPower Finder 
results.   

The waveform does not have 
enough edges or the waveform is 
not proper for the selected 
measurement to run successfully. 

Decrease the horizontal scale of 
the waveform, or increase the 
record length. 

806 The maximum/minimum plot 
value is lesser than 1e-15 or 
greater than 1e15.Plot cannot be 
displayed. 

The application is not able to 
calculate  proper plot co-ordinates. If 
the signal (s) or the test fixture 
connections are not proper. 

Connect the proper signal to 
obtain correct value. 

851 File name has invalid 
character(s)   

This error code appears when the 
save/recall file name has any invalid 
characters. 

Make sure that the save/recall file 
name does not have any invalid 
characters. 

852  File does not exist.   Recall the present file. Recall the present file. 
853  Settings of the recalled file are 

corrupted.   
This error code appears when the 
recalled file has its data 
corrupted/modified. 

Recall the file in which the data 
remains unchanged. 

854 File name should not exceed 50 
character(s).   

File name is limited to 50 characters 
because long file name will take 
more time to save the settings. 

Make sure the save file name 
does not exceed more than 50 
characters. 

871 Unable to process ref wfm. Not 
able to find the required edges.  

WAM may not be able to find the 
 required edges due to following 
reasons 1) Noisy signal 2) Low 
Hysteresis band level selected .The 
same error also used to reflect  low 
record length leading to less number 

If the signal is too Noisy, make 
the acquisition with average 
mode enabled instead of sample 
mode. This reduces the wavery 
on the signal and smoothens the 
signal. Increase the Hysteresis 
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of samples .  band level from the application to 
compensate for noise in the 
signal. Re-Acquire the Live 
waveforms and Save on ref. 

873 Unable to process ref wfm. 
Number of samples available for 
analysis during switching ON or 
OFF is zero. 

Due to low record length, number of 
samples present during switching 
ON or OFF is zero, which leads to 
infinity when calculating the 
switching frequency which is 
calculated for every switching. 

Increase the record length to 
have enough samples during 
each switching. Acquire the 
waveforms and save on ref. 

 

Error Codes for TDSPWR3 Cont... 

 

Table 6-7: Error Codes for TDSPWR3 

Error Codes Error Message   Description Probable Solutions 
901 All the three Outputs are Off. 

Make sure at least one output is 
On. 

Before running the measurement, 
set the state of the used output to 
ON state.  

Make sure at least one output 
 set as ON. 

902 The Trigger voltage cannot be set 
more than the Maximum Line 
Voltage. 

Trigger voltage has to lesser than 
the maximum line voltage 

Set the trigger voltage level lower 
than the maximum line voltage 
level. 

905 Calculated Power Loss value is 
zero. One complete switching ON 
to ON cycle may not be available 
or the conduction portion of the 
power signal may be negative. 
Reacquire with at least two 
complete cycles. 

Power Loss minimum or maximum 
and average value can become 
zero under below conditions.  When 
coupling used is AC then signal can 
vary from negative to positive and 
power loss calculated can become 
zero. AC-coupled current and 
voltage signals are multiplied to get 
power-signal. To calculate the 
power loss integration of the power 
signal is done which is varying from 
negative to positive where 
probability of calculating zero value 
is possible.  When probe has dc 
offset the above described problem 
can occur. 

Ensure coupling used is DC . DC 
offset on the probes used should 
be compensated before 
rerunning the measurement. 

975 Unable to process Ref waveform. 
One complete switching ON to ON 
cycle is not available. At least two 
complete cycles are required. 

One cycle in switching loss  will be 
considered from start of ON 
switching to stop before next ON 
switching. If one complete switching 
cycle is not present then the error is 
intimated to the user. 

Decrease the time base to get 
accommodate at least two 
complete cycle. Acquire the 
waveforms and save on ref.  

902 Trigger voltage cannot be set 
more than the peak line voltage. 

You cannot set the trigger voltage 
value more than the maximum line 
voltage value. 

Set the trigger voltage level lower 
than the maximum line voltage 
level. 

 

208                                                                                       TDSPWR3 Software Analysis Printed Help Document                         



Reference 

Configuration Parameter Specifications 

 

Table 6-8: Configuration parameter specifications 

Measurement/ 
Sub Type       

 
Menu Minimum Maximum 

 
Default Resolution Units 

Common Configuration    I-Probe 
Settings> 
Transfer 
Impedance  

0.001 10  0.5 0.001  Ω 

Common Configuration     I-Probe 
Settings> 
Custom Scale 
Factor 

100p 10G 1  1  NA 

Common Configuration     I-Probe 
Settings> 
Custom 
Propagation 
Delay 

0 150n  0 1n  s 

Power Dissipation RDS On 
0 100 

 VCE Sat 100m 50 

 Edge Levels   

 Hysteresis 
percentage 5 40 

Ref Level 
percentage 10 90 50 1 

Hysteresis 
absolute 0 3000 5 0.001 

Ref Level 
absolute -5999     5999 50 0.001 

V Level 
percentage 1    90 5  1 

I level 
percentage 1     90 5 1 

V level absolute -5999 5999 5  0.001 

I Level absolute -100 100  1  0.001  

Vg Level -100    100 1.5 0.1 

B-H Analysis Hysteresis 5 40 10 1 % 
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percentage 

 Ref Level 
percentage 10 90 50 1 % 

 Hysteresis 
absolute 0    3000  150mV 0.001 V 

 Ref Level 
absolute -5999     5999 5 0.001 V 

 Num of Turns  1  1M  1 1  NA 
 Cross section 

area-SI 1u n  1M 1 1n   m2 

 Length-SI 1u n   1M  1 1u m 
 Cross section 

area-CGS 1u    1M 1  0.001 cm2 

 Length-CGS 1u   1M  1  1n cm 
Current Harmonics  Ampere Value 

(in Harmonic 
Table Editor)      

0 10 0 1n A 

  Ratio (In 
Impedance 
Table Editor)  

0.001 2 
 

0 
 

0.001 
 NA 

 A14  Input 
Power (for Class 
C and Class D 
only ) 

0   600  100 10m  W 

 A14 Power 
Factor (for Class 
C Only) 

0  1  1  10m  NA 

 A14 
Fundamental 
Current (for 
class C only) 

0    16 16 10m  A 

Note: The  Total Loss default values for High, Low, Ref and Hysteresis in Percentage and Absolute are same as Switching Loss 

Ripple Switching Switching 
Frequency 50 1M 10K 1 Hz 

Turn on Time        Maximum Line 
Voltage     1 500 230  1 V 

 Voltage 1 
Maximum Value 
    

- 5999 5999 5  0.01 V 

 Voltage 2 
Maximum Value 
    

- 5999 5999 5 0.01 V 

 Voltage 3 
Maximum Value 
     

- 5999 5999 5 0.01 V 

 Maximum    1u 5  200m  1u s 
 Custom 

Frequency for 50 1M  50 1 Hz 
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AC-DC     

 Trigger Voltage 1 500 230 1 V 
Utilities> Deskew From Ref Level 

    0 100 50 1  % 

 From Hysteresis 
     0 25 5 1 % 

 To Ref Level     0 100 50 1  % 
 To Hysteresis    0 25 5  1  % 
 Edges      1 100 1 1 NA 

 
 

Table 6-9: Configuration parameter specifications 

Measurement/Sub Type       
 
Menu Minimum Maximum 

 
Default Resolution Units 

Pulse Width, Duty Cycle, Clock Period, Frequency 
Absolute  Ref Level -5999 5999 0  0.001  V 
Percentage Hysteresis 0 3000 6 0.001 V 
Absolute   Ref Level 1 99 50  1 % 
Percentage Hysteresis      0 50 3 1 % 
SOA Mask Editor Y Max (-40K)    10 5K  A 
 Y Min (-40K)  5K 0   A 
 X Max (-40K)     40K 500 1m V 

X Min (-40K)     40K 1m V 
SOA Overlay Y Max -40 5 

 10  A 

 Y Min -40 5 0  A 
 X Max -40 5 500  V 
 X Min -40 40Kv 0  V 

 0 

 

Table 6-10: Configuration parameter specifications 

Measurement/Sub Type    Menu Minimum, Maximum 
SOA Plot   Cursor Position Dynamic depending on results 
Power Energy Power Finder results   Peak Count Dynamic depending on results 
 Occurrence 

Cursor Position 
Dynamic depending on results 

Core Saturation Plot   Dynamic depending on results 
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Measurement/ 
Sub Type       Minimum Maximum 

 
Default Resolution Units 

Ref Level in Amps       -999 999 5 0.001 A 
Hysteresis in Amps 0 A 3000   150m 0.001  
Ref Level in percentage
     1 99 50 1 % 

Hysteresis in 
percentage 5 50 10 1 % 

di/dt configuration 

 

Dv/dt configuration 
Ref Level in Volts       -5999 5999 5 0.001 V 
Hysteresis in Volts       0 3000 150m 0.001 V 
Ref Level in 
Percentage       -5999 5999 50 1 % 

Hysteresis in 
Percentage       5 50 10 1 % 

 

Table 6-11: Configuration Parameter specifications 

Measurement/Sub 
Type       

 
Menu Minimum Maximum 

 
Default Resolution Units 

di/dt results 
Ref Level in Amps       High -999 999 10 0.001 A 
 Low     -999 999 1 0.001  A 
Ref Level in percentage
     High 1 99 90 1 % 

 Low      1 99 10 1 % 
dv/dt results 
Ref Level in Volts       High -5999 5999 10 0.001 V 
Ref Level in Volts       Low -5999 5999 1 0.001 V 
Ref Level in 
Percentage       High 1 99 90 1 % 

Ref Level in 
Percentage       Low 1 99 10 1 % 

Edge Number   Dynamic depending on results  1  NA 
 

Spectral Analysis 
Start Frequency 

NA 0 

499 M 
299 M for 
TDS5032, 
TDS5034 

50 5 Hz 

Stop Frequency 
NA 50 

500 M 
499 M for 
TDS5032, 

1000 5 Hz 
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TDS5034 

Parameters 

About Application Parameters 

This section describes the TDSPWR3 application parameters, and includes the 
default menu settings. You should refer to the user manual for your oscilloscope 
for operating details of other controls, such as front-panel buttons.  

The parameters for the menus and options list the selections or range of values 
available for each and include the default values. For more detailed information 
about the parameter values, refer the topic Configuration parameter 
Specifications on page 2 . 09

There are no parameters for the Save and Recall menu 

  

File Menu 

There are no parameters for the File menu items.  

Save/Recall Menu Parameters 

Preferences Parameters 

Table 6-12: Preferences Parameters 

Parameter Selection Default Settings 
Preferences   Acquisition alert message Acquisition alert message is unchecked 
Preferences   Last Recalled This option is unchecked 
Preferences   SOA Plot in Full Screen Mode This option is unchecked 
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Measurement Menus 

The parameters available under the Measurements menu are:  

� 

� Configure  

Select  

Measurement Menu Parameters 

The next table lists the options in the Select Measurements menu by area: 

 

Table 6-13: Measurement Menu Parameters 

Parameters Selection Default Setting 
Power Dissipation, 
B-H Analysis 
Total Loss 
SOA 
Dynamic Resistance 
di/dt 
dv/dt 

Power Dissipation> HiPower Finder 

Line Power Analysis   Power Quality 
Current Harmonics 
Total Power Quality 

None 

Output Analysis   Ripple Line 
Ripple Switching 
Turn on Time 

None 

Modulation Analysis  Pulse Width Modulation 
Duty Cycle Modulation 
Clock Period Modulation 
Frequency Modulation  

None 

Analysis Tools Spectral Analysis None 

Power Device  

 

Control Panel Parameters 

Table 6-14: Control Panel Parameters 

Parameters Selections Default Setting 
Run   None None 
Stop   None None 
Mode   Single Run, Single with no Acquisition, Free 

Run Single Run 
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Common Configuration Parameters 

 

Table 6-15: Common Configuration Parameters 

Parameter Selection Default Setting 
Source   Ref, Live Live 
Voltage (Live)  Ch1, Ch2, Ch3, Ch4, Math1, Math2, Math3, Math4  Ch1 
Current (Live)   Ch1, Ch2, Ch3, Ch4 Ch2 
Voltage (Ref) Ref1, Ref2, Ref3, Ref4   Ref1 

Ref 1, Ref2, Ref3, Ref4 Ref2 
Probe Type  TCP Series 

Current Shunt 
Custom 
Am503S Settings  

TCP Series 

AM503S Settings Probe Type A63X2 
AM503S Settings Range A63X2-1 mA 

A6303-10 mA 
A6304-500 mA 

Current Shunt Impedance - 500 mohm 
Custom   Scale Factor  1 
Custom   Propagation delay 0 
Mode in the Sequencer Panel  Single Run, Free Run, Single with no Acquisition  

Current (Ref)    

Single Run 
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Configure Power Dissipation Parameters 

 

Table 6-16: Power Dissipation Parameters 

Selection Parameter Default Setting 

HiPower Finder tab 

Type tab Fixed, Variable Variable 
Edge Finder  VSW, Vg 

VSW 

Edge Source Ch1-Ch4, Math1-Math4 Ch3 
Math1, Math2, Math3, Math4 

Math1 

Ref Units Absolute, Percentage Percentage 

 10% 

Reference % - 50% 
Reference Absolute   50V 

 5V 
N-Channel, P-Channel N-Channel 

V-level percentage - 5% 
I-level percentage - 5% 
V-level absolute - 5 V 
I-level absolute - 1 A 
Filter Current - Checked 
Switch On - Disabled 
Vg Level - 1.5 V 

Device MOSFET, BJT/IGBT BJT/IGBT 
RDS On - 20mohm 
Control Signal tab  
 

VSW, Vg 
Vg if PFC is selected else VSW 

Edge Source Ch1-Ch4, Math1-Math4 Ch3 
Math1, Math2, Math3, Math4 

Math1 

Units-Reference Absolute  - 50 V 

Power  Waveform   

Hysteresis %  - 

Hysteresis Absolute   

Device 

Switching Loss 

Power Waveform  
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Hysteresis Absolute   - 5 V 
- 10% 

Reference % - 50% 
N-Channel, P-Channel N-Channel 

Units-V-level percentage - 5% 
I-level percentage - 5% 
V-level absolute - 5 V 
I-level absolute  1 A 

- 1.5  V 
Signal Condition - Checked 
Filter Current - Checked 
Switch ON - Disabled 

Hysteresis %  

Device 

Vg Level 

 

Configure B-H Analysis Parameters 

Table 6-17: B-H Analysis Parameters 

Parameter Selection Default Setting 
Magnetic Loss Cursor Gating off 

Cursor Gating selected 

Inductance-Edge Source Ch1-Ch4, Math1-Math4 
Ch1 

Ref Level Absolute, Percentage Percentage 
Ref Level Absolute - 5V 
Hysteresis Absolute - 150mV 
Ref Level Percentage - 50% 

- 5% 
Math Destination Math1-Math4 Math1 
Type-Windings Single, Multiple  Single 
Magnetic Property: Freq/Duty Fixed, Variable Fixed 

Cursor Gating On, Off Off 
Multiple Single 

Ref Level Edge Source Ch1-Ch4, Math1-Math4 Ch1 
Ref Level Units Absolute, Percentage Percentage 
Ref Level Percentage 10-90% 50% 
Hysteresis Percentage 5-40% 10% 
Physical Characteristics SI, CGS SI 

Hysteresis Percentage 

Windings Single, 
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Number of Turns 1-1 M 1 
Cross Section Area-SI   1 m2 
Cross Section Area-CGS   1 cm2 
Length-SI   1 m 
Length-CGS   1 CM 
Windings Simultaneous, Multiple Simultaneous 
Current 2 Ch1-Ch4 Ch3 
Current 3 Ch1-Ch4, Unused Unused 
Current 2- Number of Turns   1 
Current 3- Number of Turns   Disabled 
Magnetising Current Ref1-Ref4 Ref1 

 

Configure Total Loss Parameters 

Table 6-18: Total Loss Parameters 

Parameter Selection Default Setting 

Voltage  Ch1, Ch2, Ch3, Ch4  Ch1 
Current  Ch1, Ch2, Ch3, Ch4  Ch2 
Voltage   Ch1, Ch2, Ch3, Ch4 Ch3 

Ch1, Ch2, Ch3, Ch4 Ch4 
Hysteresis Percentage           - 10% 
Ref Level Percentage           - 50% 
Hysteresis Absolute Value          - 5 V 
Ref Level Absolute Value          - 50 V 
Device Type  MOSFET, BJT/IGBT MOSFET 
RDS ON - 20 mohm 
Options Signal Conditioning, Filter Current Signal Conditioning, Filter 

Current 
Device N-Channel, P-Channel N-Channel 
Units Absolute, Percentage Percentage 
V-Level Percentage   - 5% 
I-Level Percentage           - 5% 

- 5 V 
I-Level Absolute           - 1 A 

Current   

V-Level Absolute           
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Configure SOA Parameters 

Table 6-19: SOA Parameters 

Parameter Selection Default Setting 
SOA  SOA Normal, SOA Gated, SOA DPO SOA Normal>Live 
SOA Normal, SOA Gated Mask Unchecked 
SOA DPO Mask Disabled 

 

Configure Dynamic Resistance Parameters 

Table 6-20: Dynamic Resistance Parameters 

Parameter Selection Default Setting 
Real Time Math Destination  Math1, Math2, Math3, Math4 Math1 
Average Math Destination  Math1, Math2, Math3, Math4 Math2 

SOA Mask 

Table 6-21: SOA Mask Parameters 

Parameter Selection Default Setting 
Scale  Log, Linear  Linear 
Linear   Mask Values x1-200 V, x2-250 V 

y1-5A, y2-10A 
Log   Mask Values x1-100 V, x2-1 KV 

y1-1 A, y2-10 A 

Configure di/dt Parameters 

Table 6-22: di/dt Parameters 

Parameter Selection Default Setting 
Ref Level Type Percentage, Absolute Percentage 
Math Destination  Math1, Math2,Math3, 

Math4  Math1 

Ref Level 
Percentage 

 50% 

Hysteresis 
Percentage 

 10% 

Ref Level Absolute  5 A 
Hysteresis 
Absolute 

 150 mA 
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Configure dv/dt Parameters 

Table 6-23: dv/dt Parameters 

Parameter Selection Default Setting 
Ref Level Type Percentage, Absolute Percentage 
Math Destination  Math1, Math2, Math3, Math4  Math1 
Ref Level Percentage  50% 
Hysteresis Percentage  10% 
Ref Level Absolute  5 V 
Hysteresis Absolute  150 mV 

 

Configure Power Quality Parameters 

 

Table 6-24: Power Quality Parameters 

Parameter Selection Default Setting 
Power Waveform Destination   Math1, Math2, Math3, Math4 Math1 
Energy Waveform Destination  Math1, Math2, Math3, Math4  Math2 
 

Configure Current Harmonics Parameters 

Table 6-25: Current Harmonics Parameters 

Parameter Selection Default Setting 

IEC, Amd 14, MIL 1399 IEC 
Line Frequency 50 Hz, 60 Hz 50 Hz 
Harmonic Table Table 1-10 Table 1 
Class Class A-Class D Class C 
Amd 14 Controls> Input Power 100 W 
 Controls> Power Factor 1 
 Controls> Fundamental Current 

16 A 

MIL 1399> Line Frequency 60 Hz, 400 Hz 
400 Hz 

Transfer Impedance Table  Table 1-10 Table 1 

Standards 
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Configure Total Power Quality Parameters 

 

Table 6-26: Total Power Quality Parameters 

Parameter Selection Default Setting 

Standards IEC, Amd 14, MIL 1399 IEC 
IEC 

Line Frequency 50 Hz, 60 Hz 50 Hz 
Harmonic Table Table 1-10 Table 1 
Class Class A-Class D  Class A 
Line Frequency 50 Hz, 60 Hz 50 Hz 
Harmonic Table Table 1-10 Table 1 
Class Class A-Class D Class C 
Amd 14 

 Line Frequency 50 
 Harmonics Table 1 
 Class Class A 
 Filter Unchecked 
Amd 14 Controls> Input Power 100 W 
 Controls> Power Factor 1 
 Controls> Fundamental Current 

16 A 

MIL 139- Line Frequency 60 Hz, 400 Hz 
400 Hz 

Transfer Impedance Table  Table 1-10 Table 1 
 

Configure Ripple Line Parameters 

 

Table 6-27: Ripple Line Parameters 

Parameter Selection Default Setting 
Coupling  AC Coupling, DC Coupling  AC Coupling 
Bandwidth  20Mhz, 150Mhz, Full  20 Mhz 
Acquisition   High Resolution,  

Peak Detect, Sample High Resolution 

Ripple Frequency 50Hz, 60Hz, 400Hz 50 Hz 
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Configure Ripple Switching Parameters 

 
Table 6-28: Ripple Switching Parameters 

Parameter Selection Default Setting 
Coupling   AC Coupling, DC Coupling AC Coupling 
Bandwidth  20Mhz, 150Mhz, Full  20 Mhz 

50Hz to 1MHz 10 KHz 
Acquisition Mode  High Resolution, Sample, Peak Detect  High Resolution 
Switching Frequency   

 

Configure Turn-On Time Parameters 

 
Table 6-29: Turn-on-Time Parameters 

Parameter Selection Default Setting 
Voltage>Line Voltage Source   Ch1, Ch2, Ch3, Ch4 Ch1 
Voltage Level>Maximum Line Voltage   1V-500V 230 V 
Voltage Level>Trigger Voltage 1V-500V 230 V 
Output Voltages  Output 1-Ch1, Ch2, Ch3, Ch4 

Output 2- Ch1, Ch2, Ch3, Ch4 
Output 3- Ch1, Ch2, Ch3, Ch4  

Ch2-On 
Ch3-Off 
Ch4-Off 

Maximum Turn-On-Time   1u to 5u 200 ms 
Converter  AC-DC, DC-DC AC-DC 
Frequency Min-50 Hz, Max- 1 MHz 50 Hz 
 

Configure Pulse Width Modulation Parameters 

Table 6-30: Clock Period Modulation Parameters 

Parameter Selection Default Setting 
Source   Ch1, Ch2, Ch3, Ch4, Ch1 
Ref Destination Ref1, Ref2, Ref3, Ref4   Ref1 
Ref Level Mode  Level, Percentage  Percentage 
Percentage  Ref Level  

Hysteresis 
Ref Level: 50 % 
Hysteresis: 3 % 

Absolute  Ref Level  
Hysteresis 

Ref Level: 0 V 
Hysteresis: 6 V 

Edge   Rise, Fall Rise 
Enable Gating - Unchecked 
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Configure Clock Period Modulation Parameters 

Table 6-31: Clock Period Modulation Parameters 

Parameter Selection Default Setting 
Source   Ch1, Ch2, Ch3, Ch4, Ch1 
Ref Destination Ref1, Ref2, Ref3, Ref4   Ref1 
Ref Level Mode  Level, Percentage  Percentage 
Percentage  Ref Level  

Hysteresis 
Ref Level: 50 % 
Hysteresis: 3 % 

Absolute  Ref Level  
Hysteresis 

Ref Level: 0 V 
Hysteresis: 6 V 

Edge   Rise, Fall Rise 
Enable Gating - Unchecked 

Configure Duty Cycle Modulation Parameters 

Table 6-32: Clock Period Modulation Parameters 

Parameter Selection Default Setting 
Source   Ch1, Ch2, Ch3, Ch4, Ch1 
Ref Destination Ref1, Ref2, Ref3, Ref4   Ref1 
Ref Level Mode  Level, Percentage  Percentage 
Percentage  Ref Level  

Hysteresis 
Ref Level: 50 % 
Hysteresis: 3 % 

Absolute  Ref Level  
Hysteresis 

Ref Level: 0 V 
Hysteresis: 6 V 

Edge   Rise, Fall Rise 
Enable Gating - Unchecked 

Configure Frequency Modulation Parameters 

Table 6-33: Clock Period Modulation Parameters 

Parameter Selection Default Setting 
Source   Ch1, Ch2, Ch3, Ch4, Ch1 
Ref Destination Ref1, Ref2, Ref3, Ref4   Ref1 
Ref Level Mode  Level, Percentage  Percentage 
Percentage  Ref Level  

Hysteresis 
Ref Level: 50 % 
Hysteresis: 3 % 

Ref Level  
Hysteresis 

Ref Level: 0 V 
Hysteresis: 6 V 

Edge   Rise, Fall Rise 
Enable Gating - Unchecked 

Absolute  
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Configure Spectral Analysis  

Table 6-34: Spectral Analysis Parameters 

Parameter Selection Default Setting 
Source  Ch1, Ch2, Ch3, Ch4 

Math1, Math2, Math3, Math4 
Ref1, Ref2, Ref3, Ref4 

Ch1 

Frequency-Start Min-0 Hz, Max-499 MHz 50 Hz 
Frequency-Stop  Min-50 Hz, Max-500 MHz 10 Hz 
Window Type Rectangular, Hamming, Hanning, Black-

Harris, Gaussian, Flattop2, Kaiser-Bessel, 
TekExp 

Rectangular 

RBW Dynamic Depends on Start, Stop and Window values 
Options Auto Setup, Checked 
 DC Block Unchecked 

 

Results Menu 

There are no parameters for the Results menus. 

Utilities Menu 

The parameter available under Utilities Menu is: 

� 

� 

Deskew 

SOA Mask 

Deskew-Static Deskew 

 

Table 6-35: Static Deskew Parameters 

Parameters Selections Default Setting 
From  Source Ch1, Ch2, Ch3, Ch4  Ch1 
Probe  TCP202, P5205, P5210, AM503B with A6302, 

AM503B with A6312, AM503B with A6303, 
P6139A, P6131 (1.3 mts), P6131 (2mts), P6138A, 
P5100, P5050, AM503B w/ A6302X, AM503B w/ 
A6303XL, AM503B w/ A6304XL, P6158, P6015A 
(10ft), P6015A (25ft), TCPA300 w/ 
TCP305TCPA300 w/ TCP303TCPA400 w/ 
TCP404XL, TCPA300 w/ TCP312, Custom  

P5205 

To Source  Ch1, Ch2, Ch3, Ch4,  Ch2 
Probe  TCP202, P5205, P5210, AM503B with A6302, 

AM503B with A6312, AM503B with A6303, TCP202 
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P6139A, P6131 (1.3 mts), P6131 (2mts), P6138A, 
P5100 

Real Time Deskew 

Table 6-36: Real Time Deskew Parameters 

Parameters Selections Default Setting 
From Source  Ch1, Ch2, Ch3, Ch4  Ch1 
To Source  Ch1, Ch2 Ch3, Ch4,  Ch2 
Slope    Rise, Fall Rise 
Edges   Min: 1,Max: 50% 1% 
Ref Level  Min:0, Max: 100% 50% 
Hysteresis   Min:0, Max: 25% 5% 
Source   Internal, External Internal 
Edges - 1 

Report Menu 

The parameter available under Report Menu is: 

� Report Generator 

Help Menu 

There are no parameters for the Help menu. 

Measurement Algorithms 

About Measurement Algorithms 

This section contains information about the algorithms used by the each 
measurement. The application uses voltage or current waveforms for the 
algorithms. 

  

Oscilloscope Setup Guidelines 

TDSPWR3 sets the oscilloscope parameters appropriately for each measurement 
before running the measurements. We recommend you to follow the instructions 
for better results.  

1. The voltage or current waveforms are expected in any Ch1-Ch4 or Ref1-
Ref4. If case of two channel oscilloscopes, it is expected in Ch1-2 or  
Ref1-2. 

TDSPWR3 Software Analysis Printed Help Document           225 



Reference 

2. For better results, the vertical scale for the waveform must be set such that 
the waveform does not exceed the vertical range of the oscilloscope. We 
also recommend you to set the vertical scale in such a way that the 
waveform occupies full screen. 

3. The sample rate must be set to capture sufficient waveform detail and avoid 
"aliasing" here. 

Power Dissipation 

 

 

Figure 7-1: Calculating Total Loss 

T1 is the First switching cycle 

T2 is the Second switching cycle 

Tn is the nth switching cycle 

Use the previous figure as a reference and calculate Total Loss using the 
following equation: 
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When the RDS On value for the MOSFET is used to calculate Total Loss in the 
application, use the following equation to calculate Total Loss:  

Take Rds ON as the input for the switching device. Conduction loss is calculated 
using Rds ON as the input.  

Conduction loss =  ( Irms ) ^2 . Rds ON 

Irms  is the rms value of the switching current  (Id) . 

Total loss = TON loss (average) + TOFF loss (average) + Conduction loss 

Total energy = TON energy (average) + TOFF energy (average) + Conduction 
energy  

To measure conduction loss in a MOSFET, use the following equation: 

 

where: 

Irms is the root mean square of the switching current 

To measure conduction loss in a BJT/IGBT, use the following equation: 

 

where: 

Imean is the mean of the switch current 
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To measure conduction energy, use the following equation: 

Conduction Energy= Conduction Loss* Acquisition duration 

 

 

  

Figure 7-2: Calculating TON and TOFF energy 

From the previous figure, the application uses the following equation to calculate TON and TOFF energy. 

 

 

Total Switching Loss=Ton Loss+Toff Loss+Conduction Loss 

Basic Algorithm: For the calculation of the TON, TOFF, and average Total loss.  
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Concept to identify TON and TOFF using gate voltage for edge analysis: 

Use gate voltage for edge analysis with default 50% edge level and hysterisis 
10%. 

� 

� 

� 

� 

To find the start of TON:  The start of the TON is 5% or 1.5V which ever is 
lower on the rise slope of the gate voltage. 

To find the stop of TON: The start index on the switch voltage is 5% or 
1.5V of the rise slope gate voltage. Move forward on the switch voltage 
from the start index till 5% or the configured level is met. 

To find the start of TOFF:  The start index is 80% of the gate voltage. From 
the Stop index, search for 5% of the switch voltage (on rise slope).  

To find the stop of TOFF:  The 80% of the gate voltage is start index. From 
this start index on switch current (fall slope) move forward till 5% of the 
max (switch current) is met. 

If you select the Filter check box in the application, use the following equation to 
calculate moving average filter. 

 

 

y(n)= is the output 
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x(n)= is the input 

M is four sample points that are averaged 

B-H Analysis 

The B-H Analysis measurement displays I vs Integral V Plot and measures 
Inductance, Magnetic Property and Magnetic Loss. When using the integral of 
voltage, take care to check that the voltage ‘V’ does not have any DC 
components. Use the oscilloscope AC coupling to avoid any DC shifts on the 
integral of the voltage waveform. The application creates a single cycle by 
averaging multiple cycles of current and integrated voltage. 

 

Figure 7-3: Calculating B-H Analysis 

 

In the previous figure, 

Bs is the Saturation Flux Density 

Br is the Remenance Flux Density 

Hc is the Coercive Force(Hc) 

Ui is the Initial Permeability 

Uais the Max Amplitude permeability 
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Note: The data waveform starts from the Max value of H and Decreases and 
increases again ( M-N-O-P) 
 

Saturation Flux Density (Bs): The maximum magnetic flux density induced in 
the material regardless of the magnitude of the externally applied field H. 

This is calculated on the maximum flux density cycle on the acquired waveform 
and let this cycle is k th cycle on the acquired waveform. .   

The Magnetic Field Intensity H is also calculated on the Maximum flux density 
cycle Bk.  

Bs = Max ( B) 

I = Index of ( Max(H)) 

Bs = B(I) (2) 

Remanence is also calculated on the kth cycle(Bk ) where the maximum flux 
density occurs in the entire acquired waveform. 

 

If ‘q’  is  the index at Zero value of H on H waveform. Let the q1 and q2 be the 
index  of the waveform. Calculate the value of B at the Index q1 and q2 on the K 
th cycle. The maximum magnitude value of B is the remanence Flux density. 

Coercive Force( Hc): The value of H found at the intersection of the H-axis with 
the Hysteresis loop is the coercive force. This represents the external field 
required to cause the induced flux density (B) to reach zero during the 
measurement cycle of a Hysteresis loop. HC is symmetrical with positive and 
negative axis. 

Magnetic Field Strength (H): The previous figure shows the hysteresis in a 
typical magnetic material. The Magnetic Filed induces a magnetic flux in the 
DUT. The units of measurement are Ampere/mtr for SI unit and Oerstead in CGS 
unit. 

Bs = Max ( Bk)   

Index I where H is maximum is  

Remanence (Br): Is the Induced magnetic flux density that remains in the 
material after the externally applied magnetic filed (H) is returned to zero during 
the generation of the Hysteresis loop.  

Find the index at Zero value value H on the H waveform and calculate the 
maximum value of B from these indexes. 

Coercivity Hc  is also calculated on the kth cycle where the maximum flux 
density occurs in the entire acquired waveform. Finding the index at Zero B 
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value on the B waveform. Let ‘q ‘is the index at Zero value of B on B waveform. 
Let q1 and q2 be the index on the B waveform where B is Zero. 

The maximum magnitude of the H data at the index of q1 and q2 is the 
coercivity. 

Permeability: It is the ratio of B and H calculated on the Bk cycle. You can select 
the points on the BH plot using the cursor and calculate the slope of the BH curve 
using the data selected between the cursor. You can choose the portion of the plot 
using the cursor to obtain the  results. 

Slope Calculation  

There are N data points between the Cursor 

Find Hav = (H1+HX2+…Hn)/N 

Bav = (B1+B2+…Bn)/N 

Hnormi = Hi-Hav, i=1..N 

Bnormi = Bi-Bav, i=1..N 

 

 B/H  = SUM(Hnorm1*Bnorm1+Hnorm2*Bnorm2+…+HnormN*BnormN) 

/ SUM(Hnorm1*Hnorm1+Hnorm2*Hnorm2+…HnormN*HnormN) 

Total Loss 

The algorithm for this measurement is a combination of the Magnetic Loss and 
Switching Loss algorithms. 

Safe Operating Area 

� 

� 

� 

This measurement has three options: 

SOA Normal: Plots the graph of the voltage and current waveform. 

SOA Gated: Plots the selected portion of the waveform. 

SOA DPO: Invokes the oscilloscope’s built in XY mode. This is applicable 
only for live channels. 

Results: 

The voltage vs current graph (also known as SOA Plot) displays the value of 
voltage, current and power for a selected portion on the graph.  

The occurrence field displays: 
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� 

� 

� 

The number of occurrence of the selected voltage and current position in the 
acquired waveforms 

Average power 

Standard deviation for the selected data point 

 

The application calculates the Power Value using the following equation: 

 

 

 

Where: 

 Pn is the instantaneous power value 

 Vn is the voltage value 

 In is the current value 

 n is the sample at the particular point 

 

The application calculates the Average Power using the following equation: 

 

Where: 

N is the number of samples which has the same value in the plot 

 

The application calculates the Standard Deviation using the following equation: 
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where: 

 X I is the Power Value 

 X is the Mean Power 

Dynamic Resistance 

Dynamic resistance is the resistance offered by a switching device when it is in 
the ON condition. TDSPWR3 helps to monitor the dynamic resistance through 
V/I curve using oscilloscope built-in Math capability. 

Place the cursor in the area of interest on resistance curve to get the resistance 
value. 

di/dt 

di/dt measurement represents the rate at which the current changes during 
switching. The application uses the oscilloscope’s built in math feature to provide 
a differentiation waveform of the current input.  

When you run the measurement, the application calculates di/dt for the first edge 
by taking the default levels as 10% and 90% and displays the results. 

You can select a specific section of the waveform on the live signal by providing 
inputs for high and low levels in terms of percentage and absolute value of 
voltage and current. You can select the edge of interest by viewing it visually on 
the oscilloscope. You can also enter the edge number on the results panel. The 
application displays the results for the selected edge and levels on the results 
panel. 

The application calculates di/dt using the following equation: 

 

 
 

Where:  

 X = timing values 

Y = Vertical values of the waveform data 
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dv/dt 

dv/dt represents the rate at which the voltage changes during switching. The 
application uses the math feature to provide a differentiation waveform of the 
voltage input. 

When you run the measurement, the application calculates dv/dt for the first edge 
by taking the default levels as 10% and 90% and displays the results. 

You can select a specific section of the waveform on the live signal by providing 
inputs for high and low levels in terms of percentage and absolute value of 
voltage and current. You can select the edge of interest by viewing it visually on 
the oscilloscope. You can also enter the edge number on the results panel. The 
application displays the results for the selected edge and levels on the results 
panel 

The application calculates dv/dt using the following equation: 

 

 

where:    

X =timing values   

Y= Vertical(Voltage) values of the waveform data between the cursors  

Power Quality 

The Power Quality measurement calculates the root mean square value for 
voltage, root mean square value for current, true power, apparent power, power 
factor, crest factor for voltage and crest factor for current. 

The application calculates the RMS Voltage using the following equation: 

 

 

Where: 

RMS(v) is voltage 
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N is the number of samples  

n is the data point 

v(n) is the absolute value of the voltage at the particular data point 

The application calculates the RMS Current using the following equation: 

 

Where: 

i is current 

N is the number of samples  

n is the data point 

i(n) is the absolute value of the current at the particular data point 

 

The application calculates the True Power using the following equation: 

 

Where: 

N is the number of samples 

n is the data point 

 

The application calculates the Apparent Power using the following equation: 

 

Where: 

RMS(v) is the root mean square of the voltage 

RMS(i) is the root mean square of the current 
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The application calculates the Power Factor using the following equation: 

 

Where: 

P real is the real power 

P appar is the apparent power 

 

Crest factor is the ratio of the PK value of the signal to the RMS value of the 
signal. Use the following equation to calculate the crest factor for the voltage and 
current. 

 

Where: 

Vpk is the peak value of the voltage  

Vrms is the Rms value of the voltage 

 

 

Where: 

Ipk is the peak value of the current 

Irms is the RMS value of the current 
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Current Harmonics 

The Current Harmonics measurement calculates the harmonic emissions at 
different harmonic levels and the total harmonic distortion. 

The application calculates the harmonic emissions using the following equation: 

 

Where: 

 X (k) is the set of Fourier coefficients obtained by the discrete Fourier transform 
of x(n) 

 k is the index for the computed set of discrete frequency components 

 N is the number of samples considered 

 X (n) is the discrete set of time samples that defines the transformed waveform 

 

This value of the frequency domain component is calculated using the following 
equation: 

 

Where: 

 Re is the real part 

 Im is the imaginary part 

 

The magnitude of the Harmonics is calculated using the following equation: 
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The magnitude of the harmonics is available in Amps and decibels microamp. 
Use the following equation to convert Amps to decibels microamp. 

 

 

The application displays the results for the harmonic distortion for current and 
the harmonic measurement. Harmonic distortion is calculated using the following 
equation, where the variables X1 and xn represent voltage or current. 

 

 

 

where: 

X1 is the fundamental value of the current or voltage 

xn is the nth harmonic value of current or voltage 

Total Power Quality 

The algorithm for this measurement is a combination of the Current Harmonics 
and Power Quality algorithms. 

Ripple Line and Ripple Switching 

The Ripple measurements display the ripple content in the signal. In Ripple Line, 
the time base is set to have three cycles of 50Hz or60Hz in the input waveform. 
In Ripple switching, depending the switching frequency input sets the time base 
to display four cycles. 

Depending upon the coupling type you select, the application sets the required 
offset and adjusts the vertical scale to the appropriate sensitivity. The application 
measures the peak to peak value and displays the result. 
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Turn-On Time 

Turn-On Time is the time taken to get the output voltage of the power supply 
after the input voltage is applied. TDSPWR3 provides an option of measuring 
three output signals concurrently in case of four channel oscilloscopes.  

The application measures Turn-On Time with the following inputs. 

You have to have the following inputs to measure Turn-On Time: 

� 

� 

� 

� 

� 

� 

Levels of all the channels voltages  

Maximum Turn-On Time 

The application sets the vertical settings for the waveform to occupy a minimum 
of two divisions. The horizontal settings are set according to the configuration 
inputs mentioned above. 

Modulation Analysis 

This section explains the algorithm details of the following measurements which 
are part of Modulation Analysis  

Pulse Width  

Clock Period  

Frequency 

Duty Cycle 

 

The application measures the signals on the complete cycles in the voltage 
waveform. All these measurements are related with the time locations of the 
edges in an acquisition. The result is displayed in graphical format in one of the 
reference memory selected as part of the setup of the measurement. 

Clock Period and Frequency Modulation 

 

Figure 7-4: Calculating Clock period and frequency modulation 
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The above diagram is a sample period-modulated signal that explains clock 
period and frequency modulation. The annotations A to I in the above diagram 
represent the V ref mid crossing in an acquired waveform.  

The application calculates the period and frequency using the following equation: 

 

 

 

Where:  

A, B, C, D, E, F, G, H, I are the data points  

 

Pulse Width and Duty Cycle 

  

Figure 7-5: Calculating pulse width and duty cycle 

The above diagram is a sample pulse width-modulated signal that calculates the 
pulse width and duty cycle modulation. The annotations A to I in the above 
diagram represent the V ref Mid crossing in an acquired waveform.  

You can also configure the positive or negative pulse width or duty cycle.  

The application calculates the pulse width and duty cycle using the following 
equation: 
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Where:  

A, B, C, D, E, F, G are the data points. 

Spectral Analysis 

Spectral Analysis measures the magnitude of the signal over the specified 
frequency range by computing the Fast Fourier Transform. 

The application calculates the two-sided amplitude spectrum using the following 
equation: 

Amplitude spectrum in quantity peak = Magnitude [FFT (A)]/N 

Where:  

N = number of sampling points and  

A is the signal 

The application calculates the two sided amplitude spectrum using the following 
equation: 

Single sided Amplitude spectrum in volts rms = 1.141*Magnitude [FFT (A)]/N 
for i = 1 to N/2 –1 

= Magnitude [FFT (A)]/N for i = 0(DC) 

Where: 

i is the frequency line number of the FFT of A 

Each frequency other than the DC is multiplied by 2 and the second half of the 
array is discarded. 

242                                                                                       TDSPWR3 Software Analysis Printed Help Document                         



Reference 

Amplitude spectrum is closely related to the power spectrum. Single sided power 
spectrum is computed by squaring the single-sided rms amplitude spectrum. 

The application calculates the single sided amplitude spectrum using the 
following equation: 

DB = 10Log10P/Pr  

Where: 

P is the measured power  

Pr is the reference power 

Db = 20log10A/Ar  

Where: 

A is the measured amplitude measured in Decibel 

Ar is the reference amplitude measured in Decibel 

 

 

The application calculates the FFT using the following equation: 

 

Where: 

X (k) is the discrete Fourier transform of x computed using a Fast Fourier 
Transform algorithm.  

x(n) is the discrete set of time samples 

k is the index for the computed set of discrete frequency components 

N is the number of samples considered 
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Appendix 

Appendix A 

 

Use differential voltage and current probes to probe voltage and current signals in 
a switching power supply. Since these probes have active circuits, correct the DC 
offset errors. The DC voltage error adds to the test signal to display wrong 
results. The different propagation in differential voltage probes and current 
probes causes errors in time-correlated measurements and displays wrong power 
waveform measurements. 

Follow the procedure below to eliminate these errors: 

For P5205 probe 

1. Connect P5205 to Channel 1 of the oscilloscope. 

2. Set the probe at 50X position. 

3. Connect the + and - probe inputs to the same test point. 

4. Set the coupling to DC. 

5. Set the vertical sensitivity to maximum. 

6. Check for no DC voltage offset on screen. 

7. If there is a DC offset on the oscilloscope screen, use a small screwdriver and 
set "adjust offset" potentiometer at the BNC end of P5205, so that the DC 
voltage is zero. 

For TCP202 probe 

1. Connect TCP202 to Channel 2 of the oscilloscope. 

2. Close the TCP202 clamp.  

3. Press degauss and release degauss button at the BNC connector of TCP202. 

4. If DC offset is present on screen, use "Balance" at the BNC connector of 
TCP202 to adjust the DC current level to zero.  
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Note: P5205 and TCP202 are matched probes. You do not have to deskew these 
probes as they have the same propagation delay. 
 

5. The test set up is ready to take power measurements. 

Appendix B 

1. Do not disturb any oscilloscope settings during measurement analysis. Any 
disturbance may result in unexpected behavior of the application. 

2. To exit the application, follow the instructions in this document. Do not use 
any other method to exit the application. This results in abnormal 
termination of the application and you have to restart the oscilloscope. 

3. The application expects the data waveform in a nonequivalent time mode 
(ET) for its analysis. If the equivalent time mode is turned AUTO, the 
application switches off the equivalent time mode and measures the signal. 
The application does not display a warning message and the record length 
may vary according to the horizontal settings. 

4. The application uses the reference memory and/or the math based on the 
measurement selected. The application overwrites the data in the reference 
memory and/or math. The application does not display a warning message. 

5. The application runs with a record length of 4M or less. If you select a 
greater record length, the application limits itself to 4M. 

6. While measuring Power Dissipation, SOA and B-H Analysis, do not change 
or touch the oscilloscope settings during the post analysis of the results. This 
leads to wrong interpretation of results. 

7. Connect the current probe in the right direction. If not, the application 
displays negative results for the inductance value. 

8. Compensate the DC offset in the current probe and voltage probe. If not, the 
core loss result becomes negative or Peak Finder measurement displays 
improper cursor association. 

9. Select the appropriate voltage and current channels according to the voltage 
and current probes connected to the channels. If not, the B-H curve will be 
reversed and other measurements may provide wrong results. 
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AC Signal 

A time-varying signal whose polarity varies with a period of time T, and whose 
average value is zero.  

Crest Factor: cf 

The ratio of the peak value to the rms value of an ac waveform measured under 
steady-state conditions. It is unit-less, and the ratio for a pure sine wave is equal 
to .  

  

where Vin is the voltage at the user input terminals. 

 

dB 

The abbreviation for decibels. 

Current Probe(s) 

A current probe is used to measure dc, ac, or composite currents. DC current 
probes should measure dc and composite currents to within ± 1% with a probe 
calibrator and ± 3% without the calibrator. AC current probes should measure ac 
currents to within ± 5%. This accuracy should be maintained up to the worst case 
expected peak current. Proper bandwidth should also be ensured. 

DC Signal 

A signal whose polarity and amplitude do not vary with time. 

 

Electrical Power Dissipation 

The difference between the electrical input power to the UUT and its electrical 
output power, expressed in watts. 

TDSPWR3 Software Analysis Printed Help Document                                                                                            
247 



Glossary 

  

Alternatively, power dissipation is expressed as: 

  

 

 

Harmonics  

Sinusoidal voltage or current components (distortion) of a periodic waveform 
which occur at a frequency that is an integer multiple of the fundamental 
frequency. 

Most non-linear loads generate odd-numbered harmonics, for example, as a result 
of full wave rectification of the input power. The frequencies at which these 
"characteristic harmonics" are produced by a user with an input rectifier can be 
determined by the equation: 

  

where   

 fH = the characteristic harmonic (e.g. the "third harmonic" when H = 3); 

 H = the number of the harmonic; 

 k = an integer, beginning with 1; 

 q = an integer, representing the number of rectifier commutations per cycle 

 f1 = the fundamental frequency. 

Half wave rectification produces even-numbered harmonics that cause very 
undesirable results (e.g., dc content) in the ac power system. Full wave 
rectification at the input of single-phase power loads results in ‘triplen’ 
harmonics at odd multiples of three times the fundamental frequency. These are 
also very undesirable, considering the potential quantity of single-phase loads 
and the fact that these harmonics interact with the distribution system’s normally 
high zero sequence impedance. User distortion current requirements are 
intentionally restrictive therefore for even and triplen harmonics. 
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Power Factor (Displacement) 

For user equipment, the displacement power factor is equal to the cosine of the 
angle, ϕ, between the input current and the input voltage at the fundamental 
frequency. 

  

This definition of power factor does not include the effect of distortion in the 
input current (and/or voltage) waveform. 

 

Power, Total or Apparent 

The total or apparent power (S) is the product of rms voltage and current (VA) 

  

Power Factor (Displacement) 

For user equipment, the displacement power factor is equal to the cosine of the 
angle, ϕ, between the input current and the input voltage at the fundamental 
frequency. 

  

This definition of power factor does not include the effect of distortion in the 
input current (and/or voltage) waveform. 

Power Factor (Distortion) 

The distortion power factor is defined as: 

 

where THD (Total Harmonic Distortion) is defined in 1.22 

This definition of power factor does not include effect of displacement. 
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Glossary 

Power Factor (True)  

For user equipment, the true power factor is the ratio of the active, or real, power 
(P) consumed in watts to the apparent power (S) drawn in volt-amperes, with 

  

where   

 PF = power factor; 

 P = active power in watts; 

 Q = reactive power in vars; 

 S = total power in volt-amperes. 

This definition of power factor includes the effect of both displacement and 
distortion in the input current (and/or voltage) waveform. 

Alternatively, if there are no inter-harmonics, equation 7 can be simplified to 

. 

RMS Value (Voltage)  

The square root of the average of the square of the value of the function taken 
throughout the period. For instance, the rms voltage value for a sinewave may be 
computed as: 

  

where   

 T =  waveform time period; 

 v(t) = instantaneous voltage at time t; 

 Vrms = rms voltage value. 
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Glossary 

Total Harmonic Distortion 

The ratio, expressed as a percent, of the rms value of the ac signal after the 
fundamental component is removed and inter-harmonic components are ignored, 
to the rms value of the fundamental. The formula defining total harmonic 
distortion (THD) is provided in equation (7). The variables ‘X1’ and xn may 
represent either voltage or current, and may be expressed either as rms or peak 
values, so long as all are expressed in the same fashion. 

  

Where: 

 X1 = Fundamental value of current or voltage; 

 xn = nth harmonic value of current or voltage. 

 

Transfer Impedance  

The output voltage divided by the input current while the output is delivering 
rated current. 

 

Hysteresis  

The difference between the threshold voltage for the UVLO and the threshold 
voltage for turn-on. 

 

Vmax Input 

The maximum allowable input voltage rating at which UUT can operate to 
specifications. 

Vmin Input 

The minimum allowable input voltage rating at which UUT can operate to 
specifications. 
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Glossary 

Vnom Input 

The stated or objective value of the input voltage, which may not be the actual 
value measured. The value should be between the minimum and maximum input 
value. 

Voltage Probe 

A connecting device, usually consisting of a two-conductor shielded cable and 
frequency-compensating network, with a hand-held tip, for use with an 
oscilloscope to measure the amplitude and waveshape of a DC, AC or a 
composite signal. It should include a ground reference. The measurement 
bandwidth should be at least 10 times greater than the frequency of interest. The 
impedance should be at least 50 times greater than the node impedance under 
measurement. A low impedance probe should be used for measurement purposes. 
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