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About TDSET3 

 

Figure 1-1: TDSET3 splash screen 

The TDSET3 Ethernet Compliance Test Software tests the Ethernet 's physical 
layer for — 1000BASE-T, 100BASE-TX, 10BASE-T, and 10BASE-Te in 
compliance with IEEE 802.3-2002, IEEE 802.3az, and ANSI X3.263-1995 
standards. This version allows you to test each speed for various fields such as: 
 

1000BASE-T 
Template  
Peak Voltage 
Droop 
Jitter Master Filtered 
Jitter Master Unfiltered 
Jitter Slave Filtered 
Jitter Slave Unfiltered 
Distortion 
Return Loss 
Common mode Voltage 

100BASE-TX  
Template 
Differential Output Voltage 
Signal Amplitude Symmetry 
Rise Time 
Fall Time 
Rise / Fall Time Symmetry 
Waveform Overshoot 
Jitter 
Duty Cycle Distortion 
Return Loss 
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10BASE-T/10BASE-Te 
Template MAU Ext (10BASE/10BASE-Te) 
Template MAU Ext Inv  (10BASE/10BASE-Te) 
Template MAU Int  (10BASE/10BASE-Te) 
Template MAU Int Inv (10BASE/10BASE-Te) 
Template Link Pulse  (10BASE-T) 
Template TP_IDL  (10BASE/10BASE-Te) 
Differential Voltage  (10BASE/10BASE-Te) 
Harmonic  (10BASE/10BASE-Te) 
Jitter with cable (10BASE-T) 
Jitter without cable (10BASE-T) 
Return Loss  (10BASE-T) 
Common mode Voltage (10BASE-T) 

TDSET3 has a Report Generator tool that helps you create and print custom 
reports.  

TDSET3 also supports Remote GPIB commands. 

Note: Use the Select All button to test all the parameters of the selected speed. 

Using Online Help 
The TDSET3 online help serves as a reference for using the TDSET3 Ethernet 
Compliance Test Software.  

Contents: The Contents tab displays books and pages that represent the 
categories of information in the online Help system.  

Index: The Index tab displays a multi-level list of keywords and keyword 
phrases. These terms are associated with topics in the Help system and direct you 
to specific topics.  

Search: The Search tab enables you to search for keywords in the Help system 
and to locate topics containing those words. When the search is completed, a list 
of topics is displayed so that you can select a specific topic to view.  

Back and Forward: The Back and Forward buttons allow you to browse through 
topics. 

To print a topic: Select the Print button from the Help Topics menu bar.  
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Printing from the Online Help 
While using the online help, you can print topics and information from the 
HTML Help viewer.  

To print a single topic: 

1. Find the topic in the Contents pane. Click Print. 

2. Click Print the selected topic and click OK. 

To print all topics in a selected TOC book: 

1. Find the TOC book in the Contents pane. Click Print. 

2. Click Print the selected heading and all subtopics and click OK. 

Note: If topics include expanding or drop-down hotspots, click the hotspots to 
display the information before you print.  

Hotspot is a clickable text that displays additional information below the link. 
Click on the hotspot text to show or hide the hotspot content. 
 

Some online help topics have color in the examples of the displayed application. 
If you want to print this type of topic on a monochrome printer, some 
information may not print because of certain colors. Instead, you should print the 
topic from the PDF (portable document format) file that corresponds to the online 
help. You can find the file in the Documents directory on the Optional 
Applications Software on Windows-Based Oscilloscopes CD-ROM. 

Conventions 
Online help uses the following conventions: 

 When steps require a sequence of selections using the application interface, 
the ">" delimiter marks each transition between a menu and an option. For 
example, File > Minimize  

 DUT refers to the device transmitting the signal to be tested 

 Two or more adjacent hyperlinks are separated with "|" 

 Hotspot is a clickable text that displays additional information below the 
link. Click on the hotspot link to show or hide the hotspot content 
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The application uses this convention: 

 Three dots "..." next to any menu item means that the dialog box that pops 
up requires user input 

Feedback 
Tektronix values your feedback on our products. To help us serve you better, 
please send us your suggestions, ideas, or comments on the application. 

Direct your feedback via email to techsupport@tektronix.com or FAX at  
(503) 627-5695 and include the following information. Please be as specific as 
possible. 

General information: 

 Instrument model number and hardware options, if any 

 Probes used 

 Your name, company, mailing address, phone number, FAX number,  
email id 

 Please indicate if you would like to be contacted by Tektronix about your 
suggestion or comments 

Application specific information: 

 Software version number 

 Description of the problem such that technical support can duplicate the 
problem 

 The instrument setup file of the oscilloscope and the application is also 
required to identify the problem 

 If possible, save the waveform on which you are performing the 
measurement as a .wfm file 

Note: To know the software version number, click Help > About in the 
application. 
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Information through the Web site 
You can find information about this and other applications at the Tektronix Inc. 
Web site, www.tektronix.com. Check this site for firmware updates and other 
information about our application. You can download a free trial version of the 
TDSET3 application that allows you a five-time trial.
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Getting Started 

Compatibility 
For information on oscilloscope compatibility, refer to the Optional Applications 
Software on Windows-Based Oscilloscopes Installation Manual, Tektronix part 
number 077-0067-XX. The manual is also available as a PDF file. 

Recommended Accessories 

Table 2-1: Recommended probes  
Oscilloscope Return Loss 

measurement 
All other measurements 

DPO7000/B/C, MSO5000 
 

P6248, P6247 
 

P6247, P6248, P6330, TDP1500, TDP3500  
 

DPO70000/B/C/D, 
DSA70000/B/C/D, 
MSO70000/C 
 

P6248, P6247 
 

P6247, P6248, P6330, P7330, P7350 
 

TDS5000B 
 

P6248, P6247 
 

P6247, P6248, P6330 
 

TDS6000/B and TDS6000C 
 

P6248, P6247 
 

P6247, P6248, P6330, P7330, P7350 
 

TDS7054, TDS7104 
 

P6248, P6247 
 

P6247, P6248, P6330 
 

TDS7154, TDS7254, 
TDS7404 
 

P6248, P6247 
 

P6247, P6248, P6330, P7330, P7350 
 

TDS7000B 
 

P6248, P6247 
 

P6247, P6248, P6330, P7330, P7350 
 

CSA7000/B 
 

P6248, P6247 
 

P6247, P6248, P6330, P7330, P7350 
 

 

Differential Probes 

 P6247 — 1.0 GHz Differential Probe 

 P6248 — 1.5 GHz Differential Probe 

 P6330 — 3.5 GHz Differential Probe 
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Note: The P6247, P6248, and P6330 probes require the TPA-BNC adapter for 
interface to DPO7000 series oscilloscopes. 
 

 P7330 — 3.5 GHz Differential Probe (cannot be used with DPO7054, 
DPO7104, and DPO7254 oscilloscopes) 

 P7350 — 5.0 GHz Differential Probe (cannot be used with DPO7054, 
DPO7104, and DPO7254 oscilloscopes) 

Note: 10Base-T test without TPM and RL tests require P6247 and P6248 probes. 
Two probes are required for Return Loss tests. 

 P6243 and P6245 — 1 GHz or above depending on the oscilloscope (for 
1000BASE-T Jitter tests) 

Single Ended Probe 

 TAP1500 (two probes needed for Slave Jitter Test and one probe for Master 
Jitter Test). Compatible with DPO7000 series oscilloscopes only. TAP1500 
(single ended probe) to be used with TX_TCLK signal only. 

Arbitrary Waveform Generator/Arbitrary Function Generator 

 AWG410 — 200 MS/s, 16-Bit Arbitrary Waveform Generator 

 AWG420 — 200 MS/s, 16-Bit Arbitrary Waveform Generator 

 AWG430 — 200 MS/s, 16-Bit Arbitrary Waveform Generator 

 AWG510 — 1 GS/s, 10-Bit Arbitrary Waveform Generator 

 AWG520 — 1 GS/s, 10-Bit Arbitrary Waveform Generator 

 AWG610 — 2.6 GS/s, 8-Bit Arbitrary Waveform Generator 

 AWG710 — 4.0 GS/s, 8-Bit Arbitrary Waveform Generator 

 AWG2021 — 250 MS/s, 12-Bit Arbitrary Waveform Generator (for 
Disturbing Signal Generator) 

 AWG710B — 4.2 GS/s, 8-Bit Arbitrary Waveform Generator 

 AWG7102 (Option 02) — 10 GS/s 



 
 
 
 
 

 Getting Started 

TDSET3 Printable Help Document 2-3 
 

 AWG5014 — 1.2 GS/s, 14-Bit Arbitrary Waveform Generator 

 AFG3252 — 2 GS/s, 14-Bit Arbitrary Function Generator 

 AFG3102 — 1 GS/s, 14-Bit Arbitrary Function Generator 

Note: In the case of AWG 400 series, the 1000Base-T return loss test values after 
98.5 MHz are extrapolated. Use AWG710 waveform files for AWG710B.  
 

Note: AWG7102 with Option 02 supports all tests except the Distortion test. 
 

Note: The AFG3xxx not suitable for 1000Base-T Return Loss Testing. 
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Probe Positioner 

 PPM100 Flexible Arm Probe Positioner 

Differential Input Voltage of Differential Probes 

 P6247 — ± 8.5 V (÷10) 

 P6248 — ± 8.5 V (÷10) 

 P6330 — ± 2 V 

 P7330 — ± 2 V 

 P7350 — ± 2.5 V 

Requirements and Restrictions 
Do not change the oscilloscope settings when the test is running. If you change 
the settings when the test is running, the application may give abnormal test 
results. 

Prerequisites 

 TekVisa must be installed in the oscilloscope 

 A TDS7000/CSA7000/TDS6000 Series oscilloscope with Firmware version 
2.2.0 or later 

 A TDS7000B/CSA7000B oscilloscope with Firmware version 3.0.0 or later 

 A TDS5000B Series oscilloscope with Firmware version 2.0.0 or later 

 A TDS6000B Series ocilloscope with Firmware version 4.0.1 or later 

 A TDS6000C Series oscilloscope with Firmware version 5.0.0 or later 

 A DPO7000 Series oscilloscope with Firmware version V 5.2.1 or later 

 A DPO/DSA70000 and DPO/DSA70000B Series oscilloscope with 
Firmware version V 5.2.1 or later 

 An MSO70000 Series oscilloscope with Firmware version V 5.2.1 or later 
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For better and reliable results 

 Prior to running any test, calibrate the probes, and oscilloscope for Signal 
Path Compensation1 

 Cable length between the DUT and the test fixture should not be more than 
two inches 

 Use 500 waveforms for averaging 1000BASE-T 

 Use 64 waveforms for averaging, and 200000 samples for mask testing 
10BASE-T or 100BASE-TX wherever applicable 

 Use 48 waveforms for averaging 10BASE-T harmonics 

 If the signal is not connected and the noise level is below 50 mV, the 
application detects and gives a message as invalid signal 

1 To calibrate an oscilloscope, select Utilities > Instrument Calibration in the 
oscilloscope menu bar and select the Calibrate button 

Note: If you do not install the latest version (Version 2.2.0 or above) of TDS7000 
or CSA7000 Firmware, the application will not test the mask related parameters. 
 

Remember 

 TDS5032B and TDS5052B are two-channel oscilloscopes. The drop-down 
list for any Data, Ref, or Math sources displays only two channels 

 For 1000BASE-T Template test, the TDS5000B series oscilloscope displays 
the horizontal scale as 4 ns 

 The two-channel oscilloscopes do not support the 1000BASE-T Jitter Slave 
Filtered test 

 The TDS6000B and TDS7000B series oscilloscope do not support Flash 
Hits 
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About the Test Fixture 
The TF-GBE test fixture, designed by Tektronix and manufactured and 
distributed by Crescent Heart Software, facilitates 1000BASE-T, 100BASE-TX 
and 10BASE-T Ethernet compliance testing when used with an appropriate 
supported oscilloscope and Tektronix TDSET3 Ethernet Compliance Test 
Software. These fixtures are available from both C.H.S and Tektronix. 

The TF-GBE-EE test fixture, designed, manufactured, and distributed by 
Crescent Heart Software (C.H.S), facilitates 10BASE-Te Energy Efficient 
Ethernet (EEE) compliance testing when used with an appropriate supported 
oscilloscope and Tektronix TDSET3 Ethernet Compliance Test Software. The 
fixture is available from C.H.S. 

For more information, visit Crescent Heart Software Web site www.c-h-s.com. 

Starting the Application 
1. From the oscilloscope menu, select File > Run Application > Ethernet 

Compliance Test Software or Analyze > Ethernet Compliance Test Software.  

 

Figure 2-1: Run application 

http://www.c-h-s.com/
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2. The splash screen appears.  
 

 

 

 

 

 

 

3. The oscilloscope display resizes to fit the upper part of the screen and the 
lower part of the oscilloscope screen displays the TDSET3 application. 

  

Figure 2-2: Application interface 

4. The application is automatically set to its default settings. 

5. If you access oscilloscope functions, the oscilloscope display appears in full 
screen and the TDSET3 application recedes to the background.  

6. To return to the TDSET3 application, select the APP button in the 
oscilloscope display. 

Minimizing and Maximizing the Application 
The application appears even when you minimize the oscilloscope.  

 To minimize the application, select File > Minimize. The TDSET3 window 
minimizes to the Windows taskbar and upper half screen has the 
oscilloscope display and lower half of the screen has the desktop 

 To maximize the application, select Ethernet Compliance Test Software in 
the Windows taskbar 
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 To hide the application, select the Hide button  or select File > Hide 

The Report Generator module windows are independent of the TDSET3 
application. Select the Minimize button on the right hand corner of the relevant 
report generator window to minimize it 

Note: If you select Hide button, the TDSET3 window goes to the background and 
the oscilloscope display resizes to the whole screen. 
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Returning to the Application 
When you access oscilloscope functions, the oscilloscope fills the display. You 
can access oscilloscope functions in the following ways:  

 Choose the Menu bar or the Toolbar mode on the oscilloscope and access 
the menus 

 Press front-panel buttons 

 To return to the application, select the APP button on the top right of the 
oscilloscope display 

Exiting the Application 
To exit the application, do the following:  

 Select File > Exit or select the Exit button  

 On exiting the application a message box "Do you want to restore the 
oscilloscope settings to their state before starting this application?" 
appears 

 Select Yes, No, or Cancel. Yes is selected by default 

Note: Using other methods to exit the application results in abnormal 
termination of the application. 
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Application Directories and File Names 
The TDSET3 application uses directories to save and recall setup files and uses 
file name extensions to identify the file type. The next table lists the default 
directory names. 

Table 2-2: Application default directories 
Directory Action 
C:\TekApplications\TDSET3\Setup Stores the application settings to 

setup files. 
C:\TekApplications\TDSET3\ReportGenerator\Templates Stores the default templates of 

report generator. 
C:\TekApplications\TDSET3\ReportGenerator\Reports Stores the Reports for 10BASE-T, 

10BASE-Te, 100BASE-TX, and 
1000BASE-T. 

C:\TekApplications\TDSET3\ReportGenerator\Layouts Stores the Report Layouts for 
10BASE-T, 100BASE-TX, and 
1000BASE-T. 

C:\TekApplications\TDSET3\AWGWaveforms Stores the AWG/AFG waveforms. 
C:\TekApplications\TDSET3\Images Stores all the images. 
 

Application Software Default Layouts and Templates 

Table 2-3: 1000BASE-T default layouts and templates 
Test Default template 
1000BASE-T (Default layout — 1000T.rpl) 
Coversheet Coversheet for 1000BaseT.rgt 

Coversheet for 1000BaseT_2.rgt 
Template 1000T-TemplateA.rgt 

1000T-TemplateB.rgt 
1000T-TemplateC.rgt 
1000T-TemplateD.rgt 
1000T-TemplateF.rgt 
1000T-TemplateH.rgt 

Peak Volt 1000T-PeakVoltA.rgt 
1000T-PeakVoltB.rgt 
1000T-PeakVoltC.rgt 
1000T-PeakVoltD.rgt 
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Table 2-3: 1000BASE-T default layouts and templates (cont) 
Test Default template 
Droop 1000T-DroopG.rgt 

1000T-DroopJ.rgt 
Jitter 1000 Jitter Master filtered.rgt 

1000 Jitter Master Unfiltered[TIE].rgt 
1000 Jitter Master Unfiltered[HIS].rgt 
1000 Jitter Slave filtered.rgt 
1000 Jitter Slave Unfiltered[TIE].rgt 
1000 Jitter Slave Unfiltered[HIS].rgt 
1000T- Jitter master filtered_NOCLK.rgt 
1000T- Jitter master unfiltered[HIS]_NOCLK.rgt 
1000T- Jitter master unfiltered[TIE]_NOCLK.rgt 
1000T- Jitter slave filtered_NOCLK.rgt 
1000T- Jitter slave unfiltered[HIS]_NOCLK.rgt 
1000T- Jitter slave unfiltered[TIE]_NOCLK.rgt 

Distortion 1000T-Distortion.rgt 
Common mode Voltage 1000T-Common mode Voltage.rgt 
Return Loss 1000T-Return Loss.rgt 
 

Table 2-4: 100BASE-TX default layouts and templates 
Test Default template 
100BASE-TX (Default layout — 100TX.rpl) 
Coversheet Coversheet for 100BaseTX.rgt 
Template 100-AOI Template.rgt 
Differential Output Voltage 100-Differential Output Voltage.rgt 
Signal Amplitude Symmetry 100-Signal Amplitude Symmetry.rgt 
Rise Time 100-Rise Time.rgt 
Fall Time 100-Fall Time.rgt 
Rise/Fall Time Symmetry 100-Rise Fall Time Symmetry.rgt 
Waveform Overshoot 100-Waveform Overshoot.rgt 
Jitter 100-Transmit Jitter.rgt 
Duty Cycle Distortion 100-Duty Cycle Distortion.rgt 
Return Loss 100-Tx Return Loss.rgt 

100-Rx Return Loss.rgt 
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Table 2-5: 10BASE-T/10BASE-Te default layouts and templates 
Test Default template 
10BASE-T/10BASE-Te (Default layout — 10T.rpl) 
Coversheet Coversheet for 10BaseT.rgt 

Coversheet for 10BaseTe.rgt 
MAU Ext Template 10 MAU ext template.rgt 
MAU Ext Inv Template 10 mau ext inv template.rgt 
MAU Int Template 10 mau int template.rgt 
MAU Int Inv Template 10 mau int inv template.rgt 
Link Pulse Template Load 
with TPM 

10 Link Pulse Load1 with TPM template.rgt 
10 Link Pulse Load2 with TPM template.rgt 
10 Link Pulse 100 with TPM template.rgt 

Link Pulse Template Load 
without TPM 

10 Link Pulse Load1 without TPM template.rgt 
10 Link Pulse Load2 without TPM template.rgt 
10 Link Pulse 100 without TPM template.rgt 

Link Pulse Timing 10 Link Pulse Timing.rgt 
TP_IDL Template Load with 
TPM 

10 TP_IDL Load1 with TPM template.rgt 
10 TP_IDL Load2 with TPM template.rgt 
10 TP_IDL 100 with TPM template.rgt 

TP_IDL Template Load 
without TPM 

10 TP_IDL Load1 without TPM template.rgt 
10 TP_IDL Load2 without TPM template.rgt 
10 TP_IDL 100 without TPM template.rgt 
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Table 2-5: 10BASE-T/10BASE-Te default layouts and templates (cont) 
Test Default template 
Differential Output Voltage 10 differential output voltage.rpt 
Harmonic 10 harmonic of all ones.rgt 
Jitter with cable Normal output 
timing 

10 output timing jitter with cable.rgt 

Jitter with cable 8.0 output timing 10 8.0 output timing jitter with cable.rgt 
Jitter with cable 8.5 output timing 10 8.5 output timing jitter with cable.rgt 
Jitter without cable Normal output 
timing 

10 output timing jitter without cable.rgt 

Jitter without cable 8.0 output 
timing 

10 8.0 output timing jitter without cable.rgt 

Jitter without cable 8.5 output 
timing 

10 8.5 output timing jitter without cable.rgt 

Return Loss 10 Tx Return Loss.rgt 
10 Rx Return Loss.rgt 

Common mode Voltage 10 Common mode Voltage.rgt 
10e Common mode output voltage.rgt 
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Application Software Default Settings 
The TDSET3 application is automatically set to the default settings. The next 
table lists the default settings with which the TDSET3 application starts. 

Table 2-6: Default settings 
Parameter Selection Default setting 
Speed  1000-T 
Select > 1000-T  Template/Volt tab 
 Template/Volt tab A 
 Droop tab G 
 Jit/Distortion tab Master Unfiltered 
 Return Loss tab Return Loss 
 CM Voltage tab CM Voltage 
Select > 100-TX  Parametric tab 
 Parametric tab Template (Both Polarity) 
 Return Loss tab Transmitter 
Configure > 1000-T Data CH1 
 Master CLK CH2 
 Slave CLK CH3 
 Data (TM2) CH1 
 Data (TM3) CH2 
 TX_TCLK CH1 
 # Averages 64 
 Clock Edge Rising 
 Hi Resolution 64 
 Output Ref1 
 Disturbing Signal No 
 Filter Int 
 TX_TCLK No 
 LP Filter Yes 
 Meas Type TIE 
 Probe:P1 CH1 
 Probe:P2 CH2 
 Pair ID A 
 Load 85, 100, 115 Ohm 
 Smooth 7 
 Record Length Varies depending on the Memory option 

available on the oscilloscope. 
 Hysteresis 5.00 % 
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Table 2-6: Default settings (cont) 
Parameter Selection Default setting 
Configure > 100-TX Data CH1 
 Mask Setup 

 Samples 
Fail Threshold 

 
50K 
1 

 Mask Scale Normal 
 Acquisition Sample/Average (depends on the 

parameter selected)  
Average is the default mode 
# Waveforms = 16 

 Pulse Width 16 ns 
 Probe:P1 / Probe:P3 CH1 
 Probe:P2 / Probe:P4 CH2 
 Load 85, 100, 115 Ohm 
 Smooth 7 
 # Averages 100 for Return Loss and 48 for other 

tests 
Configure > 10-T Data CH1 
 Acquisition Sample/Average (depends on the 

parameter selected) 
Average is the default mode 
# Waveforms = 16 

 Section Both 
 MAU Type Internal 
 MAU Scale Normal 
 Mask Setup 

Samples 
Fail Threshold 

50 K 
1 

 Harmonic Ones 
Output 
# Averages 
Time/Scale 

   
Math1 
48 
10 microseconds 

 Sequence Normal (NLP) 
 Probe: P1 / Probe: P3 CH1 
 Probe: P2 / Probe: P4 CH2 
 Load 85, 100, 115 Ohm 
 Smooth 7 
 Energy Efficient No 
Report > Report Generator  Generate Report tab 
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Operating Basics 

TDSET3 Application Window 
The TDSET3 application is a Windows-based application. The application 
window comprises the Menu bar, Selection pane, Speed pane, Client pane, 
Execution pane, and Status bar. The Client pane changes between Configuration 
pane, Parameter Selection pane, Connection pane, and View Waveform pane 
depending on what you have selected in the Selection pane. The Client pane 
changes to Result pane automatically after you run the test. 

 

Figure 3-1: Application window 

TDSET3 Application Interface Controls 
The TDSET3 application interface uses the following controls: 

Table 3-1: Application interface controls 
Controls Description 
Menu bar Located at the top of the application and has the TDSET3 menus. 
Tab Labeled group of options with similar items. 
 

 

 



 
 
 
 
 
Operating Basics  

3-2 TDSET3 Printable Help Document  
 

Table 3-1: Application interface controls (cont) 
Controls Description 
Pane Enclosed visual frame with a set of related options. 
Option button Defines a particular command or task. 
Drop-down list box Lists the items from which you can select one item. 
Field Box that you can use to type in text or to enter a value with the keypad or a 

multipurpose knob. 
Check Boxes Square box that you can use to select or clear preferences. 
Scroll bar Vertical or horizontal bar at the side or bottom of a display area used to 

move around that area. 
Browse Displays a window where you can look through a list of directories and files. 
Command button Initiates an immediate action. 
Keypad Appears when you select a box and enter a value. 
MP/GP knob Displays a line between the knob and the box. You can turn the knob on the 

oscilloscope to select a value. 

Menu bar 
The menu bar of TDSET3 has the following menus.  

 File menu 

 Tests menu 

 Results menu 

 Utilities menu 

 Help menu 
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File Menu 
The File menu appears as shown by the next figure: 

 

Figure 3-2: File menu 

The next table lists the menu selection and description for the File menu: 

Table 3-2: File menu 
Menu selection Description 
Recall Default 
Setup 

Recalls the default settings for the application. 

Recall Setup Recalls the application settings from a setup file. 
Save Setup Saves the application settings to a setup file. 
Preferences Shows/Hides the message boxes displayed while running the test. 
Minimize Minimizes the Application window. 
Hide Hides the Application window. 
Exit Displays the Restore Settings dialog box and closes the Application. 

Tests Menu 
The Tests menu appears as shown by the next figure: 

 

Figure 3-3: Tests menu 



 
 
 
 
 
Operating Basics  

3-4 TDSET3 Printable Help Document  
 

The next table lists the menu selection and description for the Tests menu: 

Table 3-3: Tests menu 
Menu selection Description 
Select 

1000BASE-T Displays the point and test parameter selections for 1000BASE-T in the 
Client pane. 

100BASE-TX Displays the parameters for 100BASE-TX in the Client pane. 
10BASE-T Displays the parameters for 10BASE-T in the Client pane. 

Configure Displays the configuration details for the selected speed and test. 
Connect Displays the connection instructions for the selected speed. 
View Waveform Displays the waveform based on the settings. 

Results Menu 
The Results menu appears as shown by the next figure: 

 

Figure 3-4: Results menu 

The next table lists the menu selection and description for the Results menu: 

Table 3-4: Results menu 
Menu selection Description 
Summary Displays the results summary of last test conducted. 
Details Displays the detailed results of last test conducted. 

Utilities Menu 
The Utilities menu appears as shown by the next figure: 

 
 

Figure 3-5: Utilities menu 
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The next table lists the menu selection and description for the Utilities menu: 

Table 3-5: Utilities menu 
Menu selection Description 
Report Generator Displays the Report Generator window. 
Enable Remote GPIB Enables you to use remote GPIB commands to control the application. 
Automate AWG/AFG Enables you to automate file transfer and waveform setup on an 

Arbitrary Waveform Generator/Arbitrary Function Generator. 

Help Menu 
The Help menu appears as shown by the next figure: 

 

Figure 3-6: Help menu 

The next table lists the menu selection and description for the Help menu: 

Table 3-6: Help menu 
Menu selection Description 
Help Topics Displays the help file for the TDSET3 application. 
About Ethernet Compliance 
Test Software 

Displays a dialog box with information about the current TDSET3 
application. 

Selection pane 
The Selection pane located to the left of the Application window allows you to 
navigate through the application.  

 

Figure 3-7: Selection pane 
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The next table lists the button and the task description: 

Table 3-7: Selection pane buttons 
Button Description 
Select Displays the test selection parameters in the Client pane for the selected 

speed. 
Configure Displays the configuration parameters in the Client pane for the selected test 

parameter. 
Connect Displays the connection details in the Client pane for the selected test 

parameter. 
View Wfm Displays the waveform in the Client pane for the selected test parameter. 

Speed pane 
The Speed pane located to the left of the application window displays the speed 
to be selected.  

 

Figure 3-8: Speed pane 

Select 1000-T to test 1000BASE-T, 100-TX to test 100BASE-TX, and 10-T to 
test 10BASE-T and 10BASE-Te. 

The Client pane displays the parameters of the selected speed. 
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Client pane 
The Client pane located adjacent to the Speed pane displays the test parameters, 
configuration parameters, connections, view waveforms or results. Clicking on 
each tab changes the Client pane to display the relevant test parameters. 

1000BASE-T  
Client pane 

The following figure shows the Client pane of 
1000BASE-T Template: 

 

Figure 3-9: 1000BASE-T Client pane 

100BASE-TX  
Client pane 

The following figure shows the Client pane of 
100BASE-TX Template: 

 

Figure 3-10: 100BASE-TX Client pane 
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10BASE-T/ 
10BASE-Te 
Client pane 

The following figure shows the Client pane of 
10BASE-T/10BASE-Te Template: 

 

Figure 3-11: 10BASE-T Client pane 

Execution pane 
The Execution pane located to the right of the Application window displays the 
buttons Run Test and Result. 

 

Figure 3-12: Execution pane 
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Clicking on each button performs a particular task. The following table lists the 
button and the task description: 

Table 3-8: Execution pane 
Button Button name Description 

 Run Test Runs the selected test or tests. 

 Result Displays the Result pane that shows the test results. 

 Report Summary Displays the location to which the report summary is saved. 
Click OK to store the result details in a .csv file.  

 Report Detail 
Displays the location to which the detailed report is saved. 
Click OK to store the result details in a .rpt file depending on 
the layout selected in Report Configuration pane. 

 

Note: The report details are real time and no history is maintained. Ensure that 
you save the report details before you run another test. 

Status bar 
At the bottom of the application window is the status bar that displays the 
selected test and the important configuration parameters. 

 

Figure 3-13: Status bar 
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Result pane 
After you run a test, the Result pane automatically appears as shown by the 
following figure: 

 

Figure 3-14: Result pane for all tests 

After you run a Return Loss test, the Result pane automatically appears as shown 
by the following figure: 

 

Figure 3-15: Result pane for Return Loss tests 

The Result pane comprises Result Summary pane and Report Configuration 
pane. 
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Result  
Summary 

pane 
The Result Summary pane displays the test results as Pass/Fail/Inconclusive. 

 

Figure 3-16: Result Summary pane 

  Indicates that the test has passed. 

  Indicates that the test has failed. 

  Indicates that the test is inconclusive. 

The next table lists the buttons and the task descriptions: 

Table 3-9: Result Summary pane buttons 
Button Description 
Export Exports the return loss values in a .csv file. 
Clear Results Clears the results in the Result Summary pane. 
Result Details Displays the Result Details dialog box that shows the details of test results 

categorized as Description, Specification range, Measured Value, 
Pass/Fail/Inconclusive, and Remarks. 

Manual Fit Displays the Manual Fit dialog box that allows you to adjust the waveform to 
fit into the Mask. This button is enabled only when you test 1000BASE-T 
Template, 100BASE-TX Template or 10BASE-T Template. 

Smooth Displays the Smooth dialog box that allows you to smoothen the return loss 
waveform. This button is enabled only when you test Return Loss. 
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Report  
Configuration 

pane 

You can set the report details to identify and 
automatically generate the report. You can set a 
default report file. 

 

Figure 3-17: Report Configuration pane 

The next table lists the report configuration fields and descriptions: 

Table 3-10: Report Configuration fields 
Field Description 
Device ID To identify on which DUT the test was conducted by printing the Device ID 

on the generated report. 
Device description To identify on which DUT the test was conducted by printing the Device 

Description on the generated report. 
Pair ID To identify the unique pairs by printing the Device Description on the 

generated report. This field is enabled only for 1000BASE-T. 
Report File To specify the path and the file in which the generated report will be saved. 

A default file name and path displayed for the selected speed. 
Enable Preview To automatically preview the report after generation and have the option to 

save the report file. 
Advanced button Displays the Advanced Report Configuration dialog box. 

Dialog Boxes 

Preferences  
dialog box 

 
Use this dialog box to set the user preferences such as, show or hide the 
Overwrite Reference message box, Overwrite Math message box, 10Base-T user 
intervention for Template, 10Base-T user intervention for Jitter tests and 
1000Base-T user intervention for Distortion test. 
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Click File > Preferences to display the Preferences dialog box. 

 

Figure 3-18: Preferences dialog box 

The next table lists the preferences and task description: 

Table 3-11: Preferences 
Preference Task description 
Show or Hide the 
Overwrite 
Reference 
message box 

In Preference dialog box, select or clear the Show Ref overwrite check 
box. 
If you select Show Ref overwrite check box, the application displays the 
following warning every time you run 1000BASE-T Template, Peak Volt, 
Distortion, and Jitter tests. This dialog box also appears for Return Loss 
tests. This dialog box appears for 1000BASE-T Droop test only if Disturbing 
Signal is selected as Yes. 

 
 

 

Table 3-11: Preferences (cont) 
Preference Task description 
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Show or Hide the 
Overwrite Math 
message box 

In Preference dialog box, select or clear the Show Math overwrite check 
box. 
If you select Show Math overwrite check box, the application displays the 
following warning box every time you run 10BASE-T Harmonic Test. 

 
Show or hide 
10Base-T user 
intervention for 
Template tests 

In Preference dialog box, select or clear the Show 10Base-T Template 
user control check box. 
If you select the check box, the application displays the following warning 
box every time you run 10BASE-T Template Test. 

 
Toggle Lock Mask to Wfm between On and Off to lock or unlock the mask 
to waveform when you zoom in or zoom out. 
Toggle Mask Autofit between On and Off to allow the oscilloscope to 
automatically fit the waveform to mask. 

 

 

 

 

 

 

Table 3-11: Preferences (cont) 
Preference Task description 



 

 

 

Operating Basics 

TDSET3 Printable Help Document 3-15 
 

Show or hide 
1000Base-T user 
intervention for 
Distortion test 

In Preference dialog box, select or clear the Show 1000Base-T Distortion 
user control check box. 
If you select the check box, the application displays the following warning 
box every time you run 1000BASE-T Distortion Test. 
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Table 3-11: Preferences (cont) 
Preference Task description 
Show or hide 
10Base-T user 
intervention for 
Jitter tests 

In Preference dialog box, select or clear the Show 10Base-T Jitter user 
control check box. 
If you select the check box, the application displays the following warning 
box every time you run 10BASE-T Jitter with cable Test. 

 
If you select the check box, the application displays the following warning 
box every time you run 10BASE-T Jitter without cable Test. 
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Table 3-11: Preferences (cont) 
Preference Task description 
Show or Hide the 
message for 
alternate 
1000Base-T Jitter 
test 

In Preference dialog box, select or clear the Show 1000Base-T Jitter 
message user control check box. 
If you select the check box, the application displays the following message 
every time you run 1000BASE-T JitterTest (Alternate Method). 

 
Click OK to set the preferences. 

Click Cancel to exit the Preference dialog box. 

Advanced 
Report 

Configuration 
dialog box 

 
Select Results in the Execution pane, and Advanced in the Report Configuration 
pane of the Result pane. The Advanced Report Configuration dialog box appears 
as shown in the next figure: 

 

Figure 3-19: Advanced Report Configuration dialog box 
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The table lists the options that you can configure in the advanced report 
configuration dialog box: 

Table 3-12: Advanced report configuration 
Field Description 
Device ID Prints the Device Id on the generated report to help you identify 

on which DUT the test was conducted. 
Process Prints the Process on the generated report to help you identify 

the process used for DUT. 
Voltage Prints the Voltage on the generated report to help you identify 

the voltage values used while testing the DUT. 
Temperature Prints the Temperature on the generated report to help you 

identify the temperature values used while making the DUT. 
Last Cal date Prints the Last Cal date on the generated report to help you 

identify the date on which the oscilloscope was last calibrated. 
Use oscilloscope settings for 
image report 

Select this check box to use the oscilloscope settings for 
exporting images. 

 

Click OK to configure the report. 

Click Cancel to exit the report setup. 

Result Details  
dialog box 

 
Select Result Details button in Result pane to display the Result Details dialog 
box. 

After you have completed the test and you want to see the result details, click on 
the Result Details button in Result pane. The Result Details dialog box appears 
as shown by the following figure. The title bar displays the selected speed. 

 

Figure 3-20: Result Details dialog box 
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The results are categorized as listed in the next table: 

Table 3-13: Result Details categorization 
Category Description 
Description Displays the selected test. 
Spec Range Displays the specification range. 
Measured Value Measured value of the selected test. 
Pass/Fail Test passed or failed or inconclusive as , , 

or . 
Remarks Additional information about the test. 

Note: Locate Hits, and Flash Hits are enabled only if a template test fails. 
The TDS5000B series oscilloscopes do not support Flash Hits. 
 

Select Locate Hits to view and change the mask color and hit color. 

Select Flash Hits to flash the hits on the oscilloscope display. 

Select Show Seg to display the mask segments. 

Select Close to close the dialog box. 

Note: If you run all the tests together using Select All, the Locate Hits, Flash 
Hits, and Show Seg buttons are disabled.  

Locate Hits  
dialog box 

 
Select Result Details button in Result pane to display the Result Details dialog 
box. In the Result Details dialog box, select Locate Hits to display the Mask Hit 
Locator dialog box as shown by the following figure: 

 

Figure 3-21: Mask Segments dialog box 
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1. Selecting Locate Hits changes the mask color and hit color. Closing the 
Locate Hits dialog box will set the Mask color to default. 

2. In the Circle Color drop-down list, select the color in which you want to see 
the mask hits circled.  

3. Select Save to save the mask-hit image as a jpg or a bmp file. The default 
directory is C:\TekApplications\TDSET3\Images. 

4. Select Close to close the dialog box. 

Flash Hits  
dialog box 

 
Select Result Details button in Result pane to display the Result Details dialog 
box. In the Result Details dialog box, select Flash Hits to flash the hits on the 
oscilloscope display. The Flash Hits message box appears as shown by the 
following figure: 

 

Figure 3-22: Flash Hits message box 

Select Stop in the Flash Hits message box to stop flashing the mask hits. 
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Show 
Segments  
dialog box 

 
Select Result Details button in Result pane to display the Result Details dialog 
box. In the Result Details dialog box, select Show Seg to display the mask 
segments. The Show Segments dialog box appears as shown by the following 
figure: 

 

Figure 3-23: Show Segments dialog box 

Show Seg is enabled only if you run the template test. 

Select Close to close the dialog box. 

Manual Fit  
dialog box 

 
Select Result Details button in Result pane to display the Result Details dialog 
box. In the Result Details dialog box, select Manual Fit to display the manual fit 
dialog box.  

Note: If you select the Select All button, Manual Fit is not enabled.  
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If you are running 1000BASE-T Template test, the Manual Fit dialog box 
appears as shown by the next figure: 

 

Figure 3-24: 1000BASE-T Manual Fit dialog box 

When you test Template in 1000BASE-T, you can manually fit the waveform 
into the mask. 

If the processed waveform does not lie within the mask, use Manual Fit to 
manually fit the waveform into the mask as described below: 

1. Click the arrow buttons to adjust the waveform to fit into the Mask. 

2. Click OK to perform the mask pass/fail test again. Click Cancel to exit the 
Manual Fit dialog box without performing the mask pass/fail test 

If you are running 100BASE-TX or 10BASE-T Template tests, the Manual Fit 
dialog box appears as shown by the next figure: 

 

Figure 3-25: 100BASE-TX/10BASE-T Manual Fit dialog box 

When you test Template in 100BASE-TX, and 10BASE-T, you can manually fit 
the waveform into the mask. 
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If the processed waveform does not lie within the mask, use Manual Fit to 
manually fit the waveform into the mask as follows: 

1. To adjust the waveform to fit into the Mask, change the horizontal position 
and vertical position using the general purpose knobs or Virtual Keyboard. 

2. Click OK to perform the mask pass/fail test again. 

Jig match  
dialog box 

 
If you are running 1000BASE-T Template test, the Jig Match button appears in 
the Connect pane. Click Jig Match to display the Jig Match dialog box. 

1000-T > Template > Connect > Jig Match 

Note: Jig Match is enabled only if you select Disturbing Signal as Yes. 
 

 

Figure 3-26: Jig Match dialog box for 1000-T Template/Peak Volt/Droop test 
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1000-T > Distortion > Connect > Jig Match 

 

Figure 3-27: Jig Match dialog box for 1000-T Distortion test 

Use Jig Match to effectively remove the disturbing signal and compensate for 
non-linearities in the disturber and the test fixture. You can measure the 
disturbing signal's Amplitude, and Frequency. You can also set the default 
values. The application measures and displays the values in Measured Value 
fields. You can validate the disturbing signal by comparing the Measured Value 
with the Expected Value. 
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To compensate for the Disturbing Signal, do the following: 

1. Use TC5 of the test fixture for Disturber Compensation.  

2. Make the connections as shown by the following figure: 

 

Figure 3-28: Connections for Disturber compensation 

Note: Do not connect the Ethernet cable to J700 and the test port of the DUT. 
 

3. Connect a BNC Cable to (AWG/AFG)+ and Channel 1 of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

4. Connect a BNC Cable to (AWG/AFG)– and Channel 2 ( ) of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

5. Short the jumpers J621, J630, J620, J623, J721, J723, J680, and J781. 

6. Connect the Differential Probe to P19 and configured channel of the 
oscilloscope. 
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7. In the Jig Match dialog box, select Measure button in the Disturber 
Compensation pane. 

8. Compare the Measured Value with the Expected Value. 

9. If the Measured Value is not approximately equal to the Expected Value, 
modify the amplitude and clock frequency settings of the Arbitrary 
Waveform Generator/Arbitrary Function Generator. Then click Measure and 
compare the values to be approximately equal.  

To compensate for the Test Fixture, do the following: 

1. Use TC2 and TC5 of the test fixture for Test Fixture Compensation.  

2. Make the connections as shown by the following figure: 

 

Figure 3-29: Step 1 Connections of Test Fixture compensation  

3. For Template, Droop, and Peak Voltage tests, set the DUT to generate Test 
Mode 1 signal. 
For Distortion test, set the DUT to generate Test Mode 4 signal. 
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4. Connect the Ethernet cable to J490 and the test port of the DUT. 

5. Connect the Differential Probe to P9 and configured channel of the 
oscilloscope. 

6. In the Jig Match dialog box, select Measure button in Step 1 in the Test 
Fixture Compensation pane. 

7. Make the connections as shown by the following figure: 

 

Figure 3-30: Step 2 Connections of Test Fixture compensation  

8. For Template, Droop, and Peak Voltage tests, set the DUT to generate Test 
Mode 1 signal. 
For Distortion test, set the DUT to generate Test Mode 4 signal. 

9. Connect the Ethernet cable to J700 and test port of the DUT. 

10. Connect a BNC Cable to (AWG/AFG)+ and Channel 1 of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

11. Connect a BNC Cable to (AWG/AFG)- and Channel 2 ( ) of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

12. Switch OFF the Arbitrary Waveform Generator/Arbitrary Function 
Generator. 
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13. Short the jumpers J621, J630, J623, J721, J723, J680, and J781. 

14. Connect the Differential Probe to P18 and configured channel of the 
oscilloscope. 

15. In the Jig Match dialog box, select Measure button in Step 2 in the Test 
Fixture Compensation pane. 

Virtual 
Keyboard 

dialog box 
Selecting  adjacent to any number field displays the Virtual Keyboard. 

 

Figure 3-31: Virtual keyboard  

The field on the top displays what you have selected. After you have selected the 
required number, select Enter.  

 Selecting Space inserts a space 

 Selecting Enter enters the value for the selected field 

 Selecting Backspace deletes the value entered 

 Selecting Esc exits the Virtual Keyboard 
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Virtual 
Keypad 

dialog box 

Select the knob or the keypad icon adjacent to any text field to display the 
Virtual Keypad dialog box. 

 

Figure 3-32: Virtual keypad  

Use this dialog box to enter custom values. 

 Selecting Set to min automatically displays the minimum value of the 
selected field 

 Selecting Set to max automatically displays the maximum value of the 
selected field 

 Selecting CLR clears the value for the field selected and returns to zero 
value 

 Selecting Enter enters the value for the selected field 
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Mask Setup  
dialog box 

 
The Mask Setup button is available in the Configure pane and is enabled only 
when you run template tests.  

If you are configuring 100BASE-TX Template test, click on Mask Setup button 
in the Configure pane to display the Mask Setup dialog box. 

 

Figure 3-33: 100BASE-TX Mask Setup dialog box 

In the Samples text box, enter the number of samples to use in the test. Entering 
the number of samples stops the test when that number has been reached.  
The accepted range of samples is between 5000 and 2,147,400,000. The default 
number of samples is 16,000. 

In the Fail Thresh text box, enter the minimum number of samples that must fail 
for the test to fail.  
The accepted range of samples is between 1 and 2,147,483,647. The default fail 
threshold is 1. 

Note: You can use the Virtual Keyboard or the General Purpose knobs to enter 
the values in the Samples and Fail Thresh fields. 
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If you are configuring 10BASE-T Template test, click on Mask Setup button in 
the Configure pane to display the Mask Setup dialog box. 

 

Figure 3-34: 10BASE-T Mask Setup dialog box 

In the # of Wfms text box, enter the number of waveforms to use in the test. 
Entering the number of waveforms stops the test when that number has been 
reached.  
The accepted range of samples is between 1 and 2,147,483,647. The default 
number of samples is 16. 

In the Fail Thresh text box, enter the minimum number of samples that must fail 
for the test to fail.  
The accepted range of samples is between 1 and 2,147,483,647. The default fail 
threshold is 1. 

Smooth  
dialog box 

 
Select Result Details button in Result pane to display the Result Details dialog 
box. In the Result Details dialog box, select Smooth to smoothen the return loss 
waveform. This button is enabled only when you test Return Loss for all speeds. 

 

Figure 3-35: Smooth dialog box 

After you test Return Loss, you can change the smoothness of the waveform. The 
accepted range is within 0 to 10. The default is 7. 
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Click the arrow buttons to increase or decrease the value and view the 
smoothness of the waveform. The waveform is automatically updated as you 
change the value. 

Click Close to perform the pass/fail test again. 

Exit  
dialog box 

Select File > Exit to display the following message box: 

 

Figure 3-36: Exit dialog box 

You can exit the application by restoring the oscilloscope settings to the previous 
state before starting the application or retaining the present oscilloscope settings. 

 Select File> Exit 

 Select Yes to restore the oscilloscope settings to their original state before 
starting the application and exit the application 
or  
Select No to retain the present oscilloscope settings and exit the application 
or 
Select Cancel to cancel the operation and return to the application 

Note: Clicking  displays the Exit dialog box. 
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How To Select Test Parameters 

Selecting 1000BASE-T Test Parameters 
The following table lists how to select the 1000BASE-T test parameters: 

Table 4-1: Select 1000BASE-T test parameters 
Test parameter Selection 
1000BASE-T Click Tests > Select > 1000BASE-T or select 1000-T in the 

Speed pane. 
Template In the Template/Volt tab, select a point in the Template group. 
Peak Voltage In the Template/Volt tab, select a point in the Peak Volt group. 
Droop In the Droop tab, select a point. 
Jitter Master Filtered In the Jit/Distortion tab, select Master Filtered. 
Jitter Master Unfiltered In the Jit/Distortion tab, select Master Unfiltered. 
Jitter Slave Filtered In the Jit/Distortion tab, select Slave Filtered. 
Jitter Slave Unfiltered In the Jit/Distortion tab, select Slave Unfiltered. 
Distortion In the Jit/Distortion tab, select Distortion. 
Return Loss In the Return Loss tab, select Return Loss. 
CM Voltage In the CM Voltage tab, select CM Voltage. 

Note: The TDS5000B series oscilloscopes do not support Jitter Slave Filtered 
test. 
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Selecting 100BASE-TX Test Parameters 
The following table lists how to select the 100BASE-TX test parameters: 

Table 4-2: Select 100BASE-TX test parameters 
Test parameter Selection 
100BASE-TX Click Tests > Select > 100BASE-TX or select 100-TX in the Speed 

pane. 
Template In the Parametric tab, select Template. In the Polarity drop-down list, 

select Pos for positive, Neg for negative, or Both.  
For Positive polarity, the application tests segments 1, 2, 3, 6, and 7. 
For Negative polarity, the application tests segments 4, 5, 8, 9, and 10. 
For Both, the application tests all the segments. 

Differential Output 
Voltage 

In the Parametric tab, select Output Volt. In the Polarity drop-down list, 
select Pos for positive, Neg for negative, or Both. 

Signal Amplitude 
Symmetry 

In the Parametric tab, select Amp Sym. In the Polarity drop-down list, 
select Pos for positive, Neg for negative, or Both. 

Rise Time In the Parametric tab, select Rise Time. In the Polarity drop-down list, 
select Pos for positive, Neg for negative, or Both. 

Fall Time In the Parametric tab, select Fall Time. In the Polarity drop-down list, 
select Pos for positive, Neg for negative, or Both. 

Rise/Fall Time 
Symmetry 

In the Parametric tab, select R/F Sym. In the Polarity drop-down list, 
select Pos for positive, Neg for negative, or Both. 

Waveform Overshoot In the Parametric tab, select Overshoot. In the Polarity drop-down list, 
select Pos for positive, Neg for negative, or Both. 

Jitter In the Parametric tab, select Jitter. In the Polarity drop-down list, select 
Pos for positive, Neg for negative, or Both. 

Duty Cycle Distortion In the Parametric tab, select Distortion. 
Select Random or 010101 in the Pattern drop-down list. 

Return Loss In the Return Loss tab, select either Transmitter or Receiver. 
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Selecting 10BASE-T/10BASE-Te Test Parameters 
The following table lists how to select the 10BASE-T test parameters: 

Table 4-3: Select 10BASE-T/10BASE-Te test parameters 
Test parameter Selection 
10BASE-T Click Tests > Select > 10BASE-T or select 10-T in the Speed pane. 
10BASE-T/ 
10BASE-Te 
Template MAU 

In the Template tab, select MAU and select Normal, Inverted or Both in 
the adjacent drop-down list. Select Configure in the Selection pane and 
select the MAU Type as External or Internal. 

10BASE-T Template 
Link Pulse 

In the Template tab, select Link Pulse. In the adjacent drop-down list, 
select the load with or without TPM — Load1 w/o TPM, Load2 w/o TPM, 
100 Ohm w/o TPM*, Load1 with TPM, Load2 with TPM, or 100 Ohm with 
TPM*. 

10BASE-T/ 
10BASE-Te 
Template TP_IDL 

In the Template tab, select TP_IDL. In the adjacent drop-down list, select 
the load with or without TPM — Load1 w/o TPM, Load2 w/o TPM,  
100 Ohm w/o TPM*, Load1 with TPM, Load2 with TPM, or 100 Ohm with 
TPM*. 

10BASE-T/ 
10BASE-Te 
Differential Voltage 

In the Parametric tab, select Diff Volt. 
From the Peak drop-down list, select the peak value as Max or MinMax. 

10BASE-T/ 
10BASE-Te 
Harmonic 

In the Parametric tab, select Harmonic. 

10BASE-T Jitter with 
cable 

In the Parametric tab, select With Cable in the Jitter group. 
Select Normal, 8BT, 8.5BT, or All in the adjacent drop-down list. 

10BASE-T Jitter 
without cable 

In the Parametric tab, select w/o Cable in Jitter group. 
Select Normal, 8BT, 8.5BT, or All in the adjacent drop-down list. 

10BASE-T Return 
Loss 

In the Return Loss tab, select either Transmitter or Receiver. 

10BASE-T CM 
Voltage 

In the CM Voltage tab, select CM Voltage. 

* The loads 100 Ohm with TPM and 100 Ohm w/o TPM are optional and not required as per 
the 802.3-2002 standards (for 10BASE-Te, refer to 802.3az standard). 
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How To Configure Parameters 

Configuring 1000BASE-T 
Use this dialog box to configure 1000BASE-T for Source, # Averages, Output, 
Disturbing Signal, and Filter. 

 

Figure 5-1: 1000BASE-T Configure pane 
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The following table shows the 1000BASE-T tests parameters you can configure: 

Table 5-1: 1000BASE-T Configure parameters 
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The following table describes the 1000BASE-T configuration parameters: 

Table 5-2: 1000BASE-T Configure parameter description 
Configure parameters Description 
Source 

 

 

The Data source and CLK source should be mutually exclusive. The Data source, Master 
CLK source and Slave clock source should be mutually exclusive. 
Data — Select the channel to which the DUT signal is connected. 
Master CLK — Select the channel to which the master clock is connected. 
Slave CLK — Select the channel to which the slave clock is connected. 
TX_TCLK — Select the channel to which the TX_TCLK is connected. 
Data (TM2) — Select the channel to which data in Test Mode 2 is connected. 
Data (TM3) — Select the channel to which data in Test Mode 3 is connected. 

Note: TX_TCLK drop-down list appears only for Distortion test and if you 
have selected TX_TCLK as Yes. 
 
Data (TM2) and Data (TM3) drop-down lists appear only for Jitter tests if you have selected 
the TX_TCLK as No. 
Master CLK and Slave CLK drop-down lists appear only for Jitter tests if you have selected 
the TX_TCLK as Yes. 

# of Averages 

 

Enter the number of averages between 64 and 10000 depending on the noise present in 
the acquired waveform. 

Clock Edge 

 

Select the clock edge on which the oscilloscope finds the trigger point. 

Disturbing Signal 

 

Select Yes or No depending on whether the disturbing signal is added to the test mode 
signal. 

Filter 

 

Select Int or Ext depending on whether the filter is applied internally or externally. 

TX_TCLK 

 

Select Yes or No to perform the Distortion test with TX_TCLK. 

Output 

 

Select the reference waveform on which the processed waveform will be stored. 
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Table 5-2: 1000BASE-T Configure parameter description (cont) 
Configure parameters Description 
Meas Type 

 

Select the measurement type as either Time Interval Error (TIE) or Histogram. 

Hi Resolution 

 

Enter the number of averages to be done in the vertical domain. 
 

Return Loss 

 

   

 

 

Probe: P1 and Probe: P2 — Select the channels to which the probes are connected. 

Note: Depending on the Pair ID selected, the sources will change from 
P1/P3/P5/P7 and P2/P4/P6/P8. 
 
Load — Select the load as 85, 100, 115 Ohm or 100 Ohm. 
Pair ID — Select the Pair ID as A, B, C, or D. Depending on the Pair ID selected the 
sources will change from P1/P3/P5/P7 and P2/P4/P6/P8. 
Return Loss — Select the reference waveform on which the output waveform will be 
stored. 
0 dB Marker — Select the reference waveform on which you want the 0 dB Marker to be 
indicated. 

Note: Return Loss and 0 dB Marker fields appear only if you set Load as 
100 Ohm. 
 
# Averages — Enter the number of waveforms you want to average. 
Smooth — Enter the smoothening factor. 

Record Length 

 

Select the record length. This varies depending on the memory option available on the 
oscilloscope. 

Low Pass Filter  

 

Select Yes or No. The Low Pass Filter has a cutoff frequency of 150 MHz and when 
applied, eliminates high frequency noise. 

Hysteresis 

 

Enter the hysteresis percent value. 
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The following table lists the configuration parameters and default settings: 

Table 5-3: 1000BASE-T Configuration default settings 
Parameter Options Default 
Data CH1, CH2, CH3, CH4 CH1 
Master CLK CH1, CH2, CH3, CH4 CH2 
Slave CLK CH1, CH2, CH3, CH4 CH3 
Data (TM2) CH1, CH2, CH3, CH4 CH1 
Data (TM3) CH1, CH2, CH3, CH4 CH2 
# Averages 64 to 10000 64 
Clock Edge Rising, Falling Rising 
Disturbing Signal Yes, No No 
Filter Int, Ext Int 
TX_TCLK No, Yes No 
TX_TCLK CH1, CH2, CH3, CH4 CH2 
Output Ref1, Ref2, Ref3, Ref4 Ref1 
Meas Type Histogram, TIE TIE 
Hi Resolution 02 to 75 64 
Probe:P1/P3/P5/P7 CH1, CH2, CH3, CH4 CH1 
Probe:P2/P4/P6/P8 CH1, CH2, CH3, CH4 CH2 
Pair ID A, B, C, D A 
Load 85, 100, 115 or 100 Ohm 85, 100, 115 Ohm 

Note: The TDS5052B oscilloscope displays the graticule only for 100 Ohm 

Load. 

Smooth 0 - 10 7 
Record Length  Varies depending on the Memory option 

available on the oscilloscope. 
Low Pass Filter Yes, No Yes 
Hysteresis 5.00% to 30.00% 5.00% 
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Configuring 100BASE-TX 
Use this dialog box to configure 100BASE-TX for Data source, Acquisition, 
Rise/Fall Time Test, and Mask Setup. 

 

Figure 5-2: 100BASE-TX Configure pane 

The following table shows parameters of 100BASE-TX that you can configure: 

Table 5-4: 100BASE-TX Configure parameters 
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The following table describes the 100BASE-TX configuration parameters: 

Table 5-5: 100BASE-TX Configure parameter description 
Configure parameters Description 

Source 

 

Select the channel to which the Device Under Test (DUT) is connected. 

Acquisition 

 

Select Sample or Average depending on the acquisition mode.  
The Acquisition is only enabled for some tests. If you select Average, enter the number 
of waveforms in # of Wfms field.  
If you select Sample, the application assumes the number of waveforms as 1.  
You can use the virtual keyboard or the general-purpose knobs to enter the values in 
the Sample and Average text boxes. 

Rise/Fall Time Test 

 

Select Pulse Width as 16 ns or 80 ns. 
You can only configure this parameter for Rise/Fall Time Symmetry, Rise Time, and Fall 
Time tests. 

Mask Scale 

 

Select Mask Scale as Normal, 0.95, or 1.05 depending on the Mask scale factor. 
You can configure Mask Scale only for Template test. 
 
 

Mask Setup  

 

You can configure the Samples and Fail Thresh. You can only configure these 
parameters for the template tests. 
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Table 5-5: 100BASE-TX Configure parameter description (cont) 
Configure parameters  

Return Loss 

 

 

 

 

Probe: P1 and Probe: P2 — Select the channels to which the probes are connected on 
the fixture. 

Note: Depending on whether the Transmitter or Receiver is selected, 
the source will change from P1/P3 and P2/P4.  
 
Return Loss — Select the reference waveform on which the output waveform will be 
stored. 
0 dB Marker — Select the reference waveform on which you want the 0 dB Marker to 
be indicated. 

Note: Return Loss and 0 dB Marker fields appear only if you set Load 
as 100 Ohm.  
 
AWG/AFG Series — Select the AWG/AFG Series to use. If you select the default 
value–Select–then the application considers all AWGs/AFGs other than the AWG 4xx 
series. 
Load — Select the load as 85, 100, 115 Ohm or 100 Ohm. 
# Averages — Enter the number of waveforms you want to average. 
Smooth — Enter the smoothening factor. 

 

The following table lists the configuration parameters and default settings: 

 

 

Table 5-6: 100BASE-TX Configuration default settings 
Parameter Options Default 
Data CH1, CH2, CH3, CH4 CH1 
Acquisition Sample, Average If you select Sample, the default value is 1. 

If you select Average, the default # of Wfms 
is 16. 

Mask Scale Normal, 0.95, 1.05 Normal 
Mask Setup  See Mask Setup for information on default 

Sample and Fail Thresh. 
Pulse Width 16 ns, 80 ns 80 ns 
Probe:P1/P3 CH1, CH2, CH3, CH4 CH1 
Probe:P2/P4 CH1, CH2, CH3, CH4 CH2 
AWG/AFG Select, AWG 4xx, AWG 

2021, AWG 5xx, AWG 6xx, 
AWG 7xx, AWG 5xxx, 
AWG 7xxx, AFG 3xxx 

Select 
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Table 5-6: 100BASE-TX Configuration default settings (cont) 
Parameter Options Default 
Load 85, 100, 115 Ohm or 

100 Ohm 
85, 100, 115 Ohm 

Note: The two-channel oscilloscopes display the graticule only for 100 Ohm 

load. 

Smooth 0 - 10 7 

Configuring 10BASE-T/10BASE-Te 
Use this dialog box to configure 10BASE-T/10BASE-Te for Data source, 
Acquisition, Harmonic Ones, and Mask Setup. 

 

Figure 5-3: 10BASE-T/10BASE-Te Configure pane 

Note: The 802.3az document includes the changes required to enable the Energy 
Efficient Ethernet (EEE) operation for many existing physical layers. One of the 
supported operations is twisted pair cabling. The PHY supports 100Base-TX, 
1000Base T, 10Base-T, and other technologies. In addition to that EEE defines 
reduced amplitude operation for 10Base-T which is called 10BASE-Te. All the 
measurements of 100Base-TX and 1000Base T, and some of the measurements of 
10Base-T are not affected when performing the 10BASE-Te measurements. The 
10Base-T measurements that support the PHY tests for 10BASE-Te are modified 
with a separate configuration to select and perform.  
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The following table shows parameters of 10BASE-T/10BASE-Te to configure: 

Table 5-7: 10BASE-T/10BASE-Te Configure parameters 

 
 

 

The following table describes the 10BASE-T/10BASE-Te configuration 
parameters: 

Table 5-8: 10BASE-T/10BASE-Te Configure parameter description 
Configure parameters Description 

Source 

 

Select the channel to which the Device Under Test (DUT) is connected. 

Acquisition 

 

Select Sample or Average depending on the acquisition mode. The Acquisition is only 
enabled for some tests. 
If you select Average, enter the number of waveforms in # of Wfms field.  
If you select Sample, the application assumes the number of samples as 1. 
You can use the virtual keyboard or the general-purpose knobs to enter the values in 
the Sample and Average text boxes. 
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Table 5-8: 10BASE-T /10BASE-Te Configure parameter description (cont) 
   Configure parameters    Description 
Mask Selection 

 

 

Select MAU Type as Internal or External.  
Select MAU Scale as Normal, 0.9, or 1.1 depending on the MAU scale factor. 
Select Section as Both, Head or Tail depending on the section of mask to test. 
You can configure MAU Type and MAU Scale only for Template MAU tests. 
You can configure Section only for Template TP_IDL and Link Pulse tests. 

Mask Setup  

 

You can configure the Samples and Fail Thresh. You can only configure these 
parameters for the template tests. 

Harmonic all of ones 

 

Select the math waveform on which the processed waveform will be displayed. 
Enter the number of math waveforms to be averaged. 
Enter the time or scale depending on the packet length being transmitted. 

Sequence 

 

You can set the sequence to Normal (NLP) or Fast (FLP). You can only configure this 
parameter for the Template Link Pulse test. 

Test Options 

 

Select Both to perform Template and Timing tests, Template Only to perform Template 
tests, and Timing Only to perform Timing tests. Timing tests are available for normal link 
pulse. 
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Table 5-8: 10BASE-T/10BASE-Te Configure parameter description (cont) 
   Configure parameters    Description 
Return Loss 

 

 

 

 

Probe: P1 and Probe: P2 — Select the channels to which the probes are connected on 
the fixture. 
 

Note: Depending on whether the Transmitter or Receiver is selected, 
the source will change from P1/P3 and P2/P4.  
 
Return Loss — Select the reference waveform on which the output waveform will be 
stored. 
0 dB Marker — Select the reference waveform on which you want the 0 dB Marker to 
be indicated. 

Note: Return Loss and 0dB Marker fields appear only if you set Load as 
100 Ohm. 
 
AWG/AFG Series — Select the AWG/AFG Series to use. If you select the default 
value–Select–then the application considers all AWGs/AFGs other than the AWG 4xx 
series. 
Load — Select the load as 85, 100, 115 Ohm or 100 Ohm. 
# Averages — Enter the number of waveforms you want to average. 
Smooth — Enter the smoothening factor. 

 

Energy Efficient — Configure the test to run either in energy efficient mode or not. 
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The following table lists the configuration parameters and default settings: 

 

 

 

Table 5-9: 10BASE-T/10BASE-Te Configuration default settings 
Parameter Options Default 
Data CH1, CH2, CH3, CH4 CH1 
Acquisition Sample, Average If you select Sample, the default value is 1. 

If you select Average, the default # of Wfms 
is 16. 

Section Both, Head, Tail Both 
MAU Type Internal, External Internal 
MAU Scale Normal, 0.9, 1.1 Normal 
Mask Setup  See Mask Setup for information on default 

Sample and Fail Thresh. 
Sequence Normal (NLP), Fast (FLP) Normal (NLP) 
Test Options Both, Template Only, 

Timing Only 
Both 

Output Math1, Math2, Math3, 
Math4 

Math1 

Time/Scale 10 micro seconds, 1micro 
seconds 

10 micro seconds 

# Averages  48 for other tests and 100 for Return Loss. 
Probe:P1/P3 CH1, CH2, CH3, CH4 CH1 
Probe:P2/P4 CH1, CH2, CH3, CH4 CH2 
AWG/AFG Select, AWG 4xx, AWG 

2021, AWG 5xx, AWG 6xx, 
AWG 7xx, AWG 5xxx, 
AWG 7xxx, AFG 3xxx 

Select 

Load 85, 100, 115 Ohm or  
100 Ohm 

85, 100, 115 Ohm 

Note: The TDS5052B oscilloscope displays the graticule only for 100 Ohm 

Load. 

Smooth 0 - 10 7 
Energy Efficient Yes, No No 
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Making Connections 

1000BASE-T Connections 

1000BASE-T 
Template, 
Peak Volt, 

Droop, and 
Distortion  

 
Use TC5 of the test fixture for these tests with disturbing signal and TC2 of the 
test fixture for these tests without disturbing signal. 

With Disturbing Signal 

Make the connections as shown by the following figure: 

 

Figure 6-1: 1000BASE-T Connections with disturbing signal for Template, Peak Volt, Droop, 
and Distortion 

For Template, Peak Volt, and Droop tests, set the DUT to generate a Test Mode 1 
signal. For Distortion test, set the DUT to generate Test Mode 4 signal. 
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1. Connect the Ethernet cable to J700 and test port of the DUT. 

2. Connect a BNC Cable to (AWG/AFG)+ and Channel 1 of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

3. Connect a BNC Cable to (AWG/AFG)− and Channel 2 ( ) of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

Note: The AWG/AFG waveforms are available in 
C:\TekApplications\TDSET3\AWGWaveforms. You can use relevant waveform 
files to generate the disturbing signal. Some of the AWG/AFG models do not 
support the .set file for automatic settings. Refer to the ReadMe.txt file for 
instructions to make those settings manually. In particular, ensure that the 
AWG/AFG clock frequency is set to 250 MHz. This file is available in the 
corresponding AWG waveform file folder. You can automate the AWG/AFG to 
transfer files and settings as described in Automate AWG/AFG. 
4. To test Pair A, do the following: 

 Short the jumpers J621, J630, J623, J721, J723, J680, and J781 

 Ensure that the other jumpers are open 

 Connect the Differential Probe to P18 and configured channel of the 
oscilloscope 

5. To test Pair B, do the following: 

 Short the jumpers J620, J622, J631, J721, J723, J680, and J781 

 Ensure that the other jumpers are open 

 Connect the Differential Probe to P18 and configured channel of the 
oscilloscope 

6. To test Pair C, do the following: 

 Short the jumpers J620, J623, J720, J730, J723, J680, and J781 

 Ensure that the other jumpers are open 

 Connect the Differential Probe to P18 and configured channel of the 
oscilloscope 
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7. To test Pair D, do the following: 

 Short the jumpers J620, J623, J721, J722, J731, J680, and J781 

 Ensure that the other jumpers are open 

 Connect the Differential Probe to P18 and configured channel of the 
oscilloscope 

Without Disturbing Signal 

Make the connections as shown by the following figure: 

 

Figure 6-2: 1000BASE-T Connections without disturbing signal for Template, Peak Volt, 
Droop, and Distortion 

1. For Template, Peak Volt, and Droop tests, set the DUT to generate a Test 
Mode 1 signal. 
For Distortion test, set the DUT to generate a Test Mode 4 signal. 
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2. Connect the Ethernet cable to J490 and test port of the DUT. 

3. To test Pair A, connect the Differential Probe to P9 and configured channel 
of the oscilloscope. 

4. To test Pair B, connect the Differential Probe to P10 and configured channel 
of the oscilloscope. 

5. To test Pair C, connect the Differential Probe to P11 and configured channel 
of the oscilloscope. 

6. To test Pair D, connect the Differential Probe to P12 and configured channel 
of the oscilloscope. 

Note: Align the positive (+) probe-tip of the differential probe with the notch 
marked on the test fixture. 
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1000BASE-T 
Jitter Master 

Filtered 

 
If you have access to TX_TCLK 

Step 1 

Use TC3 of the test fixture to calculate master clock jitter. Make the connections 
as shown by the following figure: 

 

Figure 6-3: 1000BASE-T Step 1 Connections for Jitter Master Filtered 

1. Set the DUT in Normal mode as Master. 

2. Connect the Ethernet cable to J501 and test port of the DUT. 

3. Connect the Test Channel spool to J580 and Link partner. 

4. Connect the active probe from TX_TCLK of the DUT to the configured 
channel of the oscilloscope. 

5. To test Pair A, connect the Differential Probe to P13 and configured channel 
of the oscilloscope. 
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6. To test Pair B, connect the Differential Probe to P14 and configured channel 
of the oscilloscope. 

7. To test Pair C, connect the Differential Probe to P15 and configured channel 
of the oscilloscope. 

8. To test Pair D, connect the Differential Probe to P16 and configured channel 
of the oscilloscope. 
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Step 2 

Use TC2 of the test fixture to calculate data jitter with respect to master clock. 
Make the connections as shown by the following figure: 

 

Figure 6-4: 1000BASE-T Step 2 Connections for Jitter Master Filtered 

1. Set the DUT to generate a Test Mode 2 signal. 

2. Connect the Ethernet cable to J490 and test port of the DUT. 

3. Connect the active probe from TX_TCLK of the DUT to the configured 
channel of the oscilloscope. 

4. To test Pair A, connect the Differential Probe to P9 and configured channel 
of the oscilloscope. 
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5. To test Pair B, connect the Differential Probe to P10 and configured channel 
of the oscilloscope. 

6. To test Pair C, connect the Differential Probe to P11 and configured channel 
of the oscilloscope. 

7. To test Pair D, connect the Differential Probe to P12 and configured channel 
of the oscilloscope. 

If you do not have access to TX_TCLK 

 

Figure 6-5: 1000BASE-T Connections for Jitter Master Filtered 

1. Set the DUT to generate a Test Mode 2 signal. 

2. Connect the Ethernet cable to J490 and test port of the DUT. 
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3. To test Pair A, connect the Differential Probe to P9 and configured channel 
of the oscilloscope. 

4. To test Pair B, connect the Differential Probe to P10 and configured channel 
of the oscilloscope. 

5. To test Pair C, connect the Differential Probe to P11 and configured channel 
of the oscilloscope. 

6. To test Pair D, connect the Differential Probe to P12 and configured channel 
of the oscilloscope. 

1000BASE-T 
Jitter Master 

Unfiltered 

 
If you have access to TX_TCLK 

Use TC3 of the test fixture to calculate master clock jitter. Make the connections 
as shown by the following figure: 

 

Figure 6-6: 1000BASE-T Connections for Jitter Master Unfiltered 
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1. Set the DUT to generate a Test Mode 2 signal. 

2. Connect the Ethernet cable to J501 and test port of the DUT. 

3. Connect the Test Channel spool to J580 and Link partner. 

4. Connect the active probe from TX_TCLK of the DUT to the configured 
channel of the oscilloscope. 

5. To test Pair A, connect the Differential Probe to P13 and configured channel 
of the oscilloscope. 

6. To test Pair B, connect the Differential Probe to P14 and configured channel 
of the oscilloscope. 

7. To test Pair C, connect the Differential Probe to P15 and configured channel 
of the oscilloscope. 

8. To test Pair D, connect the Differential Probe to P16 and configured channel 
of the oscilloscope. 
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If you do not have access to TX_TCLK 

 

Figure 6-7: 1000BASE-T Connections for Jitter Master Unfiltered 

1. Set the DUT to generate a Test Mode 2 signal. 

2. Connect the Ethernet cable to J490 and test port of the DUT. 

3. To test Pair A, connect the Differential Probe to P9 and configured channel 
of the oscilloscope. 

4. To test Pair B, connect the Differential Probe to P10 and configured channel 
of the oscilloscope. 

5. To test Pair C, connect the Differential Probe to P11 and configured channel 
of the oscilloscope. 
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6. To test Pair D, connect the Differential Probe to P12 and configured channel 
of the oscilloscope. 

1000BASE-T 
Jitter Slave 

Filtered 

 
If you have access to TX_TCLK 

Step 1 

Use TC3 of the test fixture to calculate master and slave clock jitter. Make the 
connections as shown by the following figure: 

 

Figure 6-8: 1000BASE-T Step 1 Connections for Jitter Slave Filtered 

1. Set the DUT in Normal mode as Slave. 

2. Connect the Ethernet cable to J501 and test port of the DUT. 

3. Connect the Test Channel spool to J580 and Link partner. 

4. Connect the active probe from TX_TCLK of the DUT to the configured 
channel of the oscilloscope. 

5. Connect the active probe from TX_TCLK of the Link Partner to the 
configured channel of the oscilloscope. 
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6. To test Pair A, connect the Differential Probe to P13 and configured channel 
of the oscilloscope. 

7. To test Pair B, connect the Differential Probe to P14 and configured channel 
of the oscilloscope. 

8. To test Pair C, connect the Differential Probe to P15 and configured channel 
of the oscilloscope. 

9. To test Pair D, connect the Differential Probe to P16 and configured channel 
of the oscilloscope. 
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Step 2 

Use TC2 of the test fixture to calculate data jitter with respect to slave clock. 
Make the connections as shown by the following figure: 

 

Figure 6-9: 1000BASE-T Step 2 Connections for Jitter Slave Filtered 

1. Set the DUT to generate a Test Mode 3 signal. 

2. Connect the Ethernet cable to J490 and test port of the DUT. 

3. Connect the active probe from TX_TCLK of the DUT to the configured 
channel of the oscilloscope. 

4. To test Pair A, connect the Differential Probe to P9 and configured channel 
of the oscilloscope. 
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5. To test Pair B, connect the Differential Probe to P10 and configured channel 
of the oscilloscope. 

6. To test Pair C, connect the Differential Probe to P11 and configured channel 
of the oscilloscope. 

7. To test Pair D, connect the Differential Probe to P12 and configured channel 
of the oscilloscope. 

If you do not have access to TX_TCLK 

 

Figure 6-10: 1000BASE-T Connections for Jitter Slave Filtered 
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Step 1: 

1. Set the DUT to generate test mode 2 signal. 

2. Connect the Ethernet cable to J490 and test port of the DUT. 

3. Connect the active probe from Data (TM2) to the configured channel of the 
oscilloscope. 

4. To test Pair A, connect the Differential Probe to P9 and configured channel 
of the oscilloscope. 

5. To test Pair B, connect the Differential Probe to P10 and configured channel 
of the oscilloscope. 

6. To test Pair C, connect the Differential Probe to P11 and configured channel 
of the oscilloscope. 

7. To test Pair D, connect the Differential Probe to P12 and configured channel 
of the oscilloscope. 

Step 2: 

 
1. Set the DUT to generate test mode 3 signal. 

2. Connect the Ethernet cable to J490 and test port of the DUT. 

3. Connect the active probe from Data (TM3) to the configured channel of the 
oscilloscope. 

4. To test Pair A, connect the Differential Probe to P9 and configured channel 
of the oscilloscope. 

5. To test Pair B, connect the Differential Probe to P10 and configured channel 
of the oscilloscope. 

6. To test Pair C, connect the Differential Probe to P11 and configured channel 
of the oscilloscope. 

7. To test Pair D, connect the Differential Probe to P12 and configured channel 
of the oscilloscope. 
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If you have access to TX_TCLK 

1000BASE-T 
Jitter Slave 

Unfiltered 

 
Use TC3 of the test fixture to calculate slave clock jitter. Make the connections 
as shown by the following figure: 

 

Figure 6-11: 1000BASE-T Connections for Jitter Slave Unfiltered 

1. Set the DUT in Normal mode as Slave. 

2. Connect the Ethernet cable to J501 and test port of the DUT. 

3. Connect the Test Channel spool to J580 and Link partner. 

4. Connect the active probe from TX_TCLK of the DUT to the configured 
channel of the oscilloscope. 

5. Connect the active probe from TX_TCLK of the Link Partner to the 
configured channel of the oscilloscope. 

6. To test Pair A, connect the Differential Probe to P13 and configured channel 
of the oscilloscope. 

7. To test Pair B, connect the Differential Probe to P14 and configured channel 
of the oscilloscope. 
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8. To test Pair C, connect the Differential Probe to P15 and configured channel 
of the oscilloscope. 

9. To test Pair D, connect the Differential Probe to P16 and configured channel 
of the oscilloscope. 
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If you do not have access to TX_TCLK 

 

Figure 6-12: 1000BASE-T Connections for Jitter Slave Unfiltered (If you do not have access 
to TX_TCLK) 
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Step 1: 

1. Set the DUT to generate test mode 2 signal. 

2. Connect the Ethernet cable to J490 and test port of the DUT. 

3. Connect the active probe from Data (TM2) to the configured channel of the 
oscilloscope. 

4. To test Pair A, connect the Differential Probe to P9 and configured channel 
of the oscilloscope. 

5. To test Pair B, connect the Differential Probe to P10 and configured channel 
of the oscilloscope. 

6. To test Pair C, connect the Differential Probe to P11 and configured channel 
of the oscilloscope. 

7. To test Pair D, connect the Differential Probe to P12 and configured channel 
of the oscilloscope. 

Step 2: 

 
1. Set the DUT to generate test mode 3 signal. 

2. Connect the Ethernet cable to J490 and test port of the DUT. 

3. Connect the active probe from Data (TM3) to the configured channel of the 
oscilloscope. 

4. To test Pair A, connect the Differential Probe to P9 and configured channel 
of the oscilloscope. 

5. To test Pair B, connect the Differential Probe to P10 and configured channel 
of the oscilloscope. 

6. To test Pair C, connect the Differential Probe to P11 and configured channel 
of the oscilloscope. 

7. To test Pair D, connect the Differential Probe to P12 and configured channel 
of the oscilloscope. 
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1000BASE-T 
Return Loss 

 
Use TC1 of the test fixture for this test. Make the connections as shown by the 
following figures: 

 

Figure 6-13: 1000BASE-T Return Loss setup using an Arbitrary Waveform Generator 
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Figure 6-14: 1000BASE-T Return Loss setup using an Arbitrary Function Generator 

 

1. Set the DUT to generate a Test Mode 4 signal. 

2. Connect the Ethernet cable to J200 and test port of the DUT. 

3. Connect a BNC Cable to (AWG/AFG)+ and Channel 1 of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

4. Connect a BNC Cable to (AWG/AFG)– and Channel 2 ( ) of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

Note: The AWG/AFG waveforms are available in 
C:\TekApplications\TDSET3\AWGWaveforms. Some of the AWG/AFG models do 
not support the .set file for automatic settings. Refer to the ReadMe.txt file for 
instructions to make those settings manually. In particular, ensure that the 
AWG/AFG clock frequency is set to 250 MHz. This file is available in the 
corresponding AWG waveform file folder. You can automate the AWG/AFG to 
transfer files and settings as described in Automate AWG/AFG. 
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5. To test Pair A, connect the Differential Probes to P1 (J240) and P2 (J230), 
and configured channels of the oscilloscope. 

6. To test Pair B, connect the Differential Probe to P3 (J241) and P4 (J231), and 
configured channels of the oscilloscope. 

7. To test Pair C, connect the Differential Probe to P5 (J242) and P6 (J232), and 
configured channels of the oscilloscope. 

8. To test Pair D, connect the Differential Probe to P7 (J243) and P8 (J233), and 
configured channels of the oscilloscope. 

1000BASE-T  
CM Voltage 

 
Use TC4 of the test fixture for this test. Make the connections as shown by the 
following figure: 

 

Figure 6-15: 1000BASE-T Connections for CM Voltage 
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1. Set the DUT to generate Test Mode 4 signal. 

2. Connect the Ethernet cable to J500 and test port of the DUT. 

3. Connect a BNC Cable to J400 and configured channel of the oscilloscope. 

4. To test Pair A, short J420 using a jumper. 

5. To test Pair B, short J430 using a jumper. 

6. To test Pair C, short J431 using a jumper. 

7. To test Pair D, short J440 using a jumper. 



 

 

 

Making Connections 

TDSET3 Printable Help Document 6-25 
 

100BASE-TX Connections 

100BASE-TX 
All Tests 

except Return 
Loss 

 
Template, Differential Output Voltage, Amplitude Symmetry, Rise Time, Fall 
Time, Rise/Fall Time Symmetry, Waveform Overshoot, Jitter, Duty Cycle 
Distortion. 
Use TC2 of the test fixture for this test. Make the connections as shown by the 
following figure: 

 

Figure 6-16: All 100BASE-TX Connections except Return Loss 

1. Set the DUT to transmit scrambled idles. 

2. Connect the Ethernet cable to J490 and test port of the DUT. 

3. Connect the Differential Probe to P9 and configured channel of the 
oscilloscope. 
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100BASE-TX 
Return Loss 

 
Use TC1 of the test fixture for this test. Make the connections as shown by the 
following figure: 

 

Figure 6-17: 100BASE-TX Return Loss setup using Arbitrary Waveform Generator 
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Figure 6-18: 100BASE-TX Return Loss setup using Arbitrary Function Generator 

 

1. Set the DUT to generate scrambled idles. 

2. Connect the Ethernet cable to J200 and test port of the DUT. 

3. Connect a BNC Cable to (AWG/AFG)+ and Channel 1 of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

4. Connect a BNC Cable to (AWG/AFG)– and Channel 2 ( ) of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

Note: The AWG/AFG waveforms are available in 
C:\TekApplications\TDSET3\AWGWaveforms. Some of the AWG/AFG models do 
not support the .set file for automatic settings. Refer to the ReadMe.txt file for 
instructions to make those settings manually. In particular, ensure that the 
AWG/AFG clock frequency is set to 250 MHz. This file is available in the 
corresponding AWG waveform file folder. You can automate the AWG/AFG to 
transfer files and settings as described in Automate AWG/AFG. 
5. To test Transmitter, connect the Differential Probes to P1 (J240) and P2 

(J230), and configured channels of the oscilloscope. 
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6. To test Receiver, connect the Differential Probe to P3 (J241) and P4 (J231), 
and configured channels of the oscilloscope. 
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10BASE-T/10BASE-Te Connections 

10BASE-T 
Link Pulse 

 
Use TC6 of the test fixture for this test without twisted-pair model and use TC7 
of the test fixture for this test with twisted-pair model. 

 

Without Twisted-pair model 

Make the connections as shown by the following figure: 

 

Figure 6-19: 10BASE-T Connections for Link Pulse without Twisted-pair model 

1. Set the DUT to generate a link pulse signal. 
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2. Connect the Ethernet Cable to J800 and test port of the DUT. 

3. Connect the differential probe to P20 and configured channel of the 
oscilloscope. 

4. Using the jumpers, short the LOAD1, LOAD2 or LOAD3 (100 Ohm). 
Ensure that the jumper you have short and the LOAD you have selected in 
the application are the same. 

Note: LOAD3 (100 Ohm) is optional and not required as per the 802.3-2002 
standards. 
 

With Twisted-pair model 

Make the connections as shown by the following figure: 

 

Figure 6-20: 10BASE-T Connections for Link Pulse with Twisted-pair model 

1. Set the DUT to generate a link pulse signal. 

2. Connect the Ethernet cable to J990 and the test port of the DUT. 

3. Connect the differential probe to P22 and the configured channel of the 
oscilloscope. 
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4. Using the jumpers, short the LOAD1, LOAD2 or LOAD3 (100 Ohm). 
Ensure that the jumper you have short and the LOAD you have selected in 
the application are the same. 

Note: LOAD3 (100 Ohm) is optional and not required as per the 802.3-2002 
standards. 
 

10BASE-T 
MAU 

 
Use TC7 of the test fixture for this test. Make the connections as shown by the 
following figure: 

 

Figure 6-21: 10BASE-T Connections for MAU 

1. Set the DUT to generate a pseudo-random sequence signal. 

2. Connect the Ethernet Cable to J990 and test port of the DUT. 

3. If you have a Link Partner, connect the Ethernet Cable to J890 and link 
partner. 

If you do not have a Link Partner, short J2 using a jumper. If J2 is not 
present, go to the next step. 

4. Connect the differential probe to P22 and configured channel of the 
oscilloscope. 
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5. Short LOAD3 (100 Ohm) using a jumper. 

10BASE-Te 
MAU 

 
Use TC8 test fixture for this test. Make the connections as shown by the 
following figure: 
 

 
Figure 6-22: 10BASE-Te Connections for MAU  
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1. Set the DUT to generate a pseudo-random sequence signal. 

2. Connect the Ethernet Cable to J6 and test port of the DUT. 

3. If you have a Link Partner, connect the Ethernet Cable to J5 and link partner. 

If you do not have a link partner, short J7 using a jumper. If J7 is not present, 
go to the next step. 

4. Connect the differential probe to P2 and configured channel of the 
oscilloscope. 

5. Short LOAD3 (100 Ohm) using a jumper. 

 



 
 
 
 
 
Making Connections  

6-34 TDSET3 Printable Help Document  
 

 

10BASE-T 
/10BASE-Te 

TP_IDL 

 
Use TC6 of the test fixture for this test without Twisted-pair model and use TC7 
of the test fixture for this test with Twisted-pair model. 

 

Without Twisted-pair model (10BASE-T /10BASE-Te) 

Make the connections as shown by the following figure: 

 

Figure 6-23: 10BASE-T/10BASE-Te Connections for TP_IDL without Twisted-pair model 

1. Set the DUT to generate a pseudo-random sequence signal. 

2. Connect the Ethernet cable to J800 and test port of the DUT. 
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3. If you have a Link Partner, connect the Ethernet cable to J701 and link 
partner. If you do not have a link partner, short J1 using a jumper. If J1 is not 
present, go to the next step. 

4. Connect the Differential Probe to P20 and configured channel of the 
oscilloscope. 

5. Using the jumpers, short the LOAD1, LOAD2 or LOAD3 (100 Ohm). 
Ensure that the jumper you have short and the LOAD you have selected in 
the application are the same. 

Note: LOAD3 (100 Ohm) is optional and not required as per the 802.3-2002 
standards (for 10BASE-Te, refer to 802.3az standard). 
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With Twisted-pair model ((10BASE-T) 

Use TC7 test fixture for this test. Make the connections as shown by the 
following figure: 

 

Figure 6-24: 10BASE-T Connections for TP_IDL with Twisted-pair model 

1. Set the DUT to generate a pseudo-random sequence signal. 

2. Connect the Ethernet cable to J990 and test port of the DUT. 

3. If you have a Link Partner, connect the Ethernet cable to J890 and Link 
Partner. 

If you do not have a link partner, short J2 using a jumper. If J2 is not present, go 
to the next step. 

4. Connect the Differential Probe to P22 and configured channel of the 
oscilloscope. 
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5. Using the jumpers, short the LOAD1, LOAD2 or LOAD3 (100 Ohm). 
Ensure that the jumper you have short and the LOAD you have selected in 
the application are the same. 

Note: LOAD3 (100 Ohm) is optional and not required as per the 802.3-2002 
standards. 
 

With Twisted-pair model (10BASE-Te) 

Use TC8 test fixture for this test. Make the connections as shown by the 
following figure: 

 

Figure 6-25: 10BASE-Te Connections for TP_IDL with Twisted-pair model  
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1. Set the DUT to generate a pseudo-random sequence signal. 

2. Connect the Ethernet cable to J6 and test port of the DUT. 

3. If you have a Link Partner, connect the Ethernet cable to J5 and Link Partner. 

If you do not have a link partner, short J7 using a jumper. If J7 is not present, go 
to the next step. 

4. Connect the Differential Probe to P2 and configured channel of the 
oscilloscope. 

5. Using the jumpers, short the LOAD1, LOAD2 or LOAD3 (100 Ohm). 
Ensure that the jumper you have short and the LOAD you have selected in 
the application are the same. 

Note: LOAD3 (100 Ohm) is optional and not required as per the 802.3az 
standards. 
 

10BASE-T 
Jitter with 

cable 

 
Use TC7 of the test fixture for this test. Make the connections as shown by the 
following figure: 

 

Figure 6-26: 10BASE-T Connections for Jitter with cable 
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1. Set the DUT to generate a pseudo-random sequence signal. 

2. Connect the Ethernet cable to J990 and test port of the DUT. 

3. If you have a Link Partner, connect the Ethernet Cable to J890 and Link 
Partner. 

If you do not have a link partner, short J2 using a jumper. If J2 is not present,   
go to the next step. 

4. Connect the Differential Probe to P22 and configured channel of the 
oscilloscope. 

5. Short LOAD3 (100 Ohm) using a jumper. 
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10BASE-T 
Jitter without 

cable 

 
Use TC6 of the test fixture for this test. Make the connections as shown by the 
following figure: 

 

Figure 6-27: 10BASE-T Connections for Jitter without cable 

1. Set the DUT to generate a pseudo-random sequence signal. 

2. Connect the Ethernet cable to J800 and test port of the DUT. 

3. If you have a Link Partner, connect the Ethernet Cable to J701 and Link 
Partner. 

If you do not have a link partner, short J1 using a jumper. If J1 is not present, 
go to the next step. 
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4. Connect the Differential Probe to P20 and configured channel of the 
oscilloscope. 

5. Short LOAD3 (100 Ohm) using a jumper. 
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10BASE-T 
/10BASE-Te 
Differential 

Voltage 

 
Use TC6 of the test fixture for this test. Make the connections as shown by the 
following figure: 

 

Figure 6-28: 10BASE-T Connections for Differential Voltage 

1. Set the DUT to generate a pseudo-random sequence signal. 

2. Connect the Ethernet cable to J800 and test port of the DUT. 
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3. If you have a Link Partner, connect the Ethernet Cable to J701 and Link 
Partner. 

If you do not have a link partner, short J1 using a jumper. If J1 is not present,    
go to the next step. 

4. Connect the Differential Probe to P20 and configured channel of the 
oscilloscope. 

5. Short LOAD3 (100 Ohm) using a jumper. 

 

10BASE-T 
/10BASE-Te 

Harmonic 

 
Use TC6 of the test fixture for this test. Make the connections as shown by the 
following figure: 
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Figure 6-29: 10BASE-T Connections for Harmonic 

1. Set the DUT to generate an all-one or an all-zero sequence signal. 

2. Connect the Ethernet cable to J800 and test port of the DUT. 

3. If you have a Link Partner, connect the Ethernet Cable to J701 and Link 
Partner. 

If you do not have a link partner, short J1 using a jumper. If J1 is not present, 
go to the next step. 

4. Connect the Differential Probe to P20 and configured channel of the 
oscilloscope. 

5. Short LOAD3 (100 Ohm) using a jumper. 

 

10BASE-T 
Return Loss 

 
Use TC1 of the test fixture for this test. Make the connections as shown by the 
following figures: 

 

Figure 6-30: 10BASE-T Return Loss setup using an Arbitrary Waveform Generator 
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Figure 6-31: 10BASE-T Return Loss setup using an Arbitrary Function Generator 

 

1. Connect the Ethernet cable to J200 and test port of the DUT. 

2. Connect a BNC Cable to (AWG/AFG)+ and Channel 1 of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

3. Connect a BNC Cable to (AWG/AFG)– and Channel 2 ( ) of Arbitrary 
Waveform Generator/Arbitrary Function Generator. 

Note: The AWG/AFG waveforms are available in 
C:\TekApplications\TDSET3\AWGWaveforms. Some of the AWG/AFG models do 
not support the .set file for automatic settings. In particular, ensure that the 
AWG/AFG clock frequency is set to 250 MHz. Refer to the ReadMe.txt file for 
instructions to make those settings manually. This file is available in the 
corresponding AWG waveform file folder. You can automate the AWG/AFG to 
transfer files and settings as described in Automate AWG/AFG. 
 

4. To test Transmitter, connect the Differential Probes to P1 (J240) and P2 
(J230), and configured channels of the oscilloscope. Then, short the Jumper 
J241. 
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5. To test Receiver, connect the Differential Probe to P3 (J241) and P4 (J231), 
and configured channels of the oscilloscope. 

 

10BASE-T  
CM Voltage 

 
Use TC4 of the test fixture for this test. Make the connections as shown by the 
following figure: 

 

Figure 6-32: 10BASE-T Connections for CM Voltage 

1. Set the DUT to generate a pseudo-random sequence signal. 

2. Connect one end of the Ethernet Cable to J500 of Test Fixture TC4 and the 
other end to the test port of the DUT. 

3. Connect a BNC Cable between J400 of Test Fixture TC4 and configured 
channel of the oscilloscope. 

Note: Do not use a TPA-BNC adapter at the oscilloscope. 
 

4. Short J420 of Test Fixture TC4 using a jumper. 
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Set up the Signal 

1000BASE-T 
The DUT needs to be set in different modes for various tests according to the 
following table: 

Table 7-1: Test and pattern description 
Test Pattern BIT1 (9.15) BIT2 (9.14) BIT3 (9.13) 
Template, Peak Volt, Droop Test mode 1 0 0 1 
Jitter in Master mode Test mode 2 0 1 0 
Jitter in Slave mode Test mode 3 0 1 1 
Distortion, Return Loss, CM 
Voltage 

Test mode 4 1 0 0 

Normal Operation  0 0 0 
 

Contact your PHY vendor for a program that allows you to modify the bits 13, 
14, 15 in the GMII Management Register 9. 

100BASE-TX 
The following table lists the signal pattern that needs to be generated for each of 
the 100BASE-TX tests: 

Table 7-2: Test and pattern description 
Test Pattern 
Template Scrambled idles 
Differential Output Voltage Scrambled idles 
Signal Amplitude Symmetry Scrambled idles 
Rise Time Scrambled idles 
Fall Time Scrambled idles 
Rise/Fall Time Symmetry Scrambled idles 
Waveform Overshoot Scrambled idles 
Jitter Scrambled idles 
Duty Cycle Distortion Scrambled idles or 0101 pattern 
Return Loss Scrambled idles 
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If you are using a traffic generator to generate the signal, set the traffic generator 
to generate the signal pattern as listed in the table.  

If you are not using a traffic generator to generate the signal, contact your PHY 
vendor for a special program to generate these patterns. 

10BASE-T/10BASE-Te 
The following table lists the signal pattern that needs to be generated for each of 
the 10BASE-T/10BASE-Te tests: 

Table 7-3: Test and pattern description 
Test Pattern 
Link Pulse Link Pulse 
MAU  Pseudo-random sequence 
TP_IDL Pseudo-random sequence 
Jitter Pseudo-random sequence 
Differential Voltage Pseudo-random sequence 
Harmonic All 1s or 0s 
Return Loss Pseudo-random sequence 
CM Voltage Pseudo-random sequence 

Note: If you are using a Link Partner, ensure that you do not test the Link Pulse 
generated by the Link Partner, but test the Link Pulse generated by the DUT. 
 

If you are using a traffic generator to generate the signal, set the traffic generator 
to generate the signal pattern as listed in the table.  

If you are not using a traffic generator to generate the signal, contact your PHY 
vendor for a special program to generate these patterns. 
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How To Test 1000BASE-T 

1000BASE-T Template 
1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In Template/Volt tab, select a point in the Template group, for example, A.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 8-1: 1000BASE-T Template configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, 

or CH4 
Select the channel to which the DUT is connected. 

# Averages 64 to 10000 Enter the number of waveforms you want to average. 
Output Ref1, Ref2, Ref3, 

or Ref4 
Select the reference waveform on which the processed 
waveform will be stored. 

Disturbing Signal Yes or No 
 
 
 
 

Select the options depending on whether the 
Disturbing signal is present or not. 

Note: Selecting Disturbing Signal as Yes, 
enables the Jig Match in Connect pane. 

Filter Int or Ext Select the options depending on whether the filter is 
applied or not. If you select Ext, the application 
assumes that the filter is applied externally. 

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform.  

7. If the disturbing signal is present and you have configured Disturbing Signal 
as Yes, then click Run Test. The application does as described next. 
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 Displays a message box to confirm the overwrite of the reference 
waveform. Select Yes to continue 

 Checks whether the DUT is connected 

 Sets the trigger 

 Acquires, filters, and removes the disturbing signal 

 Normalizes the data 

 Displays the processed waveform on selected output (reference 
waveform) over the template mask 

8. If the disturbing signal is not present and you have configured Disturbing 
Signal as No, and then click Run Test.The application does the following: 

 Displays a message box to confirm the overwrite of the reference 
waveform. Select Yes to continue 

 Checks whether the DUT is connected 

 Sets the trigger 

 Acquires, filters, and normalizes the data 

 Displays the processed waveform on selected output (reference 
waveform) over the template mask 

If the test fails, the application captures the waveform, circles the hits and saves 
the information to the report. 
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The following figure shows a typical processed waveform for Template Testing 
on Points A, B, C, and D: 

 

Figure 8-1: Waveform for 1000BASE-T Template Points A, B, C, and D 

The following figure shows a typical processed waveform for Template Testing 
on Points F and H: 

 

Figure 8-2: Waveform for 1000BASE-T Template Points F and H 

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 4 ns. 
 

The application also tests for mask and displays the results as pass or fail.  

If the acquired waveform does not lie within the mask, click Manual Fit. Click 
the arrow buttons to adjust the Ref waveform to fit into the mask. This repeats 
the mask pass/fail test and displays the results in the Results Summary pane.  

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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1000BASE-T Peak Volt 
1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In Template/Volt tab, select a point in the Peak Volt group, for example, A.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 8-2: 1000BASE-T Peak Volt configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, 

or CH4 
Select the channel to which the DUT is connected. 

# Averages 64 to 10000 Enter the number of waveforms you want to average. 
Output Ref1, Ref2, Ref3, 

or Ref4 
Select the reference waveform on which the 
processed waveform will be stored. 

Disturbing Signal Yes or No Select the options depending on whether the 
Disturbing signal is present or not. 

Filter Int or Ext Select the options depending on whether the filter is 
applied or not. If you select Ext, the application 
assumes that the filter is applied externally. 

Weighted 
Average 

1 to 10 Configure the weighted averages through the .ini file 
available at  
C:\Program Files\TekApplications\TDSET3\Default.ini 

 

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform.  

7. If the disturbing signal is present and you have configured Disturbing Signal 
as Yes, and then click Run Test.  

The application does the following:  

 Displays a message box to confirm the overwrite of the reference 
waveform. Select Yes to continue 



 

 

 

How To Test 1000BASE-T 

TDSET3 Printable Help Document 8-5 
 

 Checks whether the DUT is connected 

 Acquires, filters, and removes the disturbing signal 

 Finds the peak value of the point selected after filtering 

 Compares with the specification range specified by the standard 

 Displays the processed waveform on the selected output 

8. If the disturbing signal is not present and you have configured Disturbing 
Signal as No, and then click Run Test. The application does the following: 

 Displays a message box to confirm the overwrite of the reference 
waveform. Select Yes to continue 

 Checks whether the DUT is connected 

 Acquires and filters the data 

 Finds the peak value of the point selected after filtering 

 Compares with the specification range specified by the standard 

 Displays the processed waveform on the selected output 

The following figure displays a typical DUT waveform for Peak Voltage Testing 
on Points A, B, C, and D: 

 

Figure 8-3: Waveform for 1000BASE-T Peak Volt Points A, B, C, and D 

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 4 ns. 
 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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1000BASE-T Droop 
1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In the Droop tab, select a point, for example, G.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 8-3: 1000BASE-T Droop configuration options 
Parameter Options To Do 
Data CH1, CH2, CH3, 

or CH4 
Select the channel to which the DUT is connected. 

# Averages 64 to 10000 Enter the number of waveforms you want to average. 
Output Ref1, Ref2, Ref3, 

or Ref4 
Select the reference waveform on which the processed 
waveform will be stored. 

Disturbing Signal Yes or No Select the options depending on whether the 
Disturbing signal is present or not. 

   
5. Select Tests > Connect or Connect in the Selection pane and make 

connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform.  

7. If the disturbing signal is present and you have configured Disturbing Signal 
as Yes, and then click Run Test.  

The application does the following:  

 Displays a message box to confirm the overwrite of the reference 
waveform. Select Yes to continue 

 Checks whether the DUT is connected 

 Acquires and removes the disturbing signal 

 Displays the processed waveform on selected output and places vertical 
cursors at Point F and Point G 
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 Displays the cursor values – voltage, time, voltage difference and time 
difference – at the points F and G 

8. If the disturbing signal is not present and you have configured Disturbing 
Signal as No, and then click Run Test. The application does the following: 

 Checks whether the DUT is connected 

 Displays the acquired waveform and places vertical cursors at Point F 
and Point G 

 Displays the cursor values – voltage, time, voltage difference, and time 
difference – at the Point F and Point G 

The following figure shows a typical DUT waveform showing points F and G: 

 

Figure 8-4: Waveform for 1000BASE-T Droop Points F and G 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

1000BASE-T Jitter Master Filtered 
1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In the Jit/Distortion tab, select Master Filtered.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  
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4. In the Configuration window, select the following options: 

Table 8-4: 1000BASE-T Jitter Master Filtered configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, 

or CH4 
Select the channel to which the DUT is connected. 

Master CLK CH1, CH2, CH3, 
or CH4 

Select the channel to which the Master TX_TCLK is 
connected. 

Clock Edge Rising or Falling Select the clock edge on which the oscilloscope finds 
the trigger point. 

Record Length  Varies depending on the Memory option available on 
the oscilloscope. 

TX_TCLK Yes, No Select Yes if you have access to TX_TCLK. Select No 
if you do not have access to TX_TCLK. 

Data (TM2) CH1, CH2, CH3, 
or CH4 

Select the channel to which the Test Mode 2 signal is 
connected. 

Hysteresis 5.00% to 30.00% Enter the hysteresis percent value. 
Jitter LP-Filter 1 (Yes), 0 (No)  Configure the low pass filter through the .ini file 

available at  
C:\Program Files\TekApplications\TDSET3\Default.ini 

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 
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If you have access to TX_TCLK 

Note: The application checks the frequency of the TX_TCLK. If it is within ±5% 
of 125 MHz or 62.5 MHz, the application proceeds to complete the test or else 
the application displays the error message E106. 
 

7. Click Run Test. The application displays the following dialog box: 

 

Figure 8-5: 1000BASE-T Jitter Master Filtered Step 1 

8. Set the DUT in Normal mode as Master and connect to the Link Partner.  

9. Click OK. The application does the following: 

 Checks whether the Master TX_TCLK is connected 

 Sets up the signal, where at least 105 edges (minimum of opt. 3M 
required) are available 

 Derives the jitter waveform, applies the filter 

 Determines the peak-to-peak value of the filtered waveform 
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10. The application displays the following dialog box: 

 

Figure 8-6: 1000BASE-T Jitter Master Filtered Step 2 

11. Set DUT in Test mode 2 and connect Data and Clock to the oscilloscope. 

12. Click OK. The application checks whether the Data and Master CLK signal 
are connected and then measures jitter (Jtxout) of the data with respect to the 
Master CLK. 

13. The application displays the TIE plot of the jitter waveform as shown by the 
following figure: 

 

Figure 8-7: Waveform for 1000BASE-T Jitter Master Filtered 

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 1250 
edges. 
 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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If you do not have access to TX_TCLK (this is only an informative test and 
not a compliance test), ensure that TX_TCLK is set to No in the 
Configuration. 

7. Click Run Test. A message box appears. Click OK to quit the message box 
and continue running the test. 

 
8. Set the DUT in Test Mode 2 and connect Data (TM2) to the oscilloscope. 

9. Click OK. The application does the following: 

 Checks whether Data (TM2) is connected 

 Sets up the signal, where at least 105 edges (minimum of opt. 4M 
required) are available 

 Derives the jitter waveform, applies the filter 

 Determines the peak-to-peak value of the filtered waveform 
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10. The application displays the TIE plot of the jitter waveform as follows: 

 

Figure 8-8: 1000BASE-T Jitter Master Filtered (without TX_TCLK) 

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 625 
edges. This is an alternate test method for jitter measurement being proposed, 
when TX_TCLK is not accessible. This is an informal test method. 
 

The application automatically displays the results as inconclusive or fail. Select 
Results in the Execution pane and then click Result Details button to view the 
detailed results. 

1000BASE-T Jitter Master Unfiltered 
1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In the Jit/Distortion tab, select Master Unfiltered.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  
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4. In the Configuration window, select the following options: 

Table 8-5: 1000BASE-T Jitter Master Unfiltered configuration options 
Parameter Options To do 
Master CLK CH1, CH2, CH3, 

or CH4 
Select the channel to which the Master TX_TCLK is 
connected. 

Clock Edge Rising or Falling Select the clock edge on which the oscilloscope finds 
the trigger point. 

Meas Type Histogram or TIE Select the measurement type. 
Record Length  Varies depending on the Memory option available on 

the oscilloscope. 

Note: The Record Length is enabled only if 
you select Meas Type as TIE. 
 

TX_TCLK Yes, No Select Yes if you have access to TX_TCLK. Select No 
if you do not have access to TX_TCLK. 

Data (TM2) CH1, CH2, CH3, 
or CH4 

Select the channel to which the Test Mode 2 signal is 
connected. 

Hysteresis 5.00% to 30.00% Enter the hysteresis percent value. 
Jitter LP-Filter 1 (Yes), 0 (No)  Configure the low pass filter through the .ini file 

available at  
C:\Program Files\TekApplications\TDSET3\Default.ini 

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

If you have access to TX_TCLK 

Note: The application checks the frequency of the TX_TCLK. If it is within ±5% 
of 125 MHz or 62.5 MHz, the application proceeds to complete the test or else 
the application displays the error message E106. 
 

7. Select Histogram in the Configuration. Click Run Test. The application 
does the following for Histogram method: 

 Checks whether the Master TX_TCLK is connected 

 Trigger on Master TX_TCLK clock signal at 50% of peak-to-peak 
amplitude 

 Sets up the oscilloscope horizontal and vertical scale based on Master 
clock signal 
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 Places a horizontal histogram on the pulse following the trigger pulse at 
the trigger level 

 Reads the peak-to-peak jitter from the histogram 

 Compares the read out values with the values specified in the standard 

 Takes approximately one minute to achieve approximately 13 million 
waveform acquisition 

 Displays the Master clock waveform 

8. Select TIE in the Configuration.Click Run Test. The application does the 
following for TIE method: 

 Checks whether the Master TX_TCLK is connected 

 Trigger on Master TX_TCLK clock signal at 50% of peak-to-peak 
amplitude 

 Derives the jitter waveform of the Master TX_TCLK with respect to 
unjittered reference. 

 Determines the Pk-Pk value of jitter waveform 

 Compares the read out values with the values specified in the standard 

 Displays the TIE plot of the jitter waveform 

The following figure shows a typical TIE plot of Jitter waveform: 

 

Figure 8-9: TIE Waveform for 1000BASE-T Jitter Master Unfiltered 

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 1250 
edges. 
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The following figure shows a typical Histogram plot of Jitter waveform: 

 

Figure 8-10: Histogram Waveform for 1000BASE-T Jitter Master Unfiltered 

Note: In TDS6000 and DPO7000 series oscilloscopes, approximately 13,000,000 
waveform database samples are acquired. 
 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

If you do not have access to TX_TCLK (this is only an informative test and 
not a compliance test), ensure that TX_TCLK is set to No in the 
Configuration. 

7. Click Run Test. A message box appears. Click OK to quit the message box 
and continue running the test. 

 
8. Set the DUT in Test Mode 2 and connect Data (TM2) to the oscilloscope. 

9. Select Histogram in the Configuration. Click OK. The application does the 
following for Histogram method: 

 Checks whether Data (TM2) is connected 

 Trigger on Data (TM2) signal at 50% of peak-to-peak amplitude 
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 Sets up the oscilloscope horizontal and vertical scale based on Data 
(TM2) signal 

 Places a horizontal histogram on the pulse following the trigger pulse at 
the trigger level 

 Reads the peak-to-peak jitter from the histogram 

 Compares the read out values with the values specified in the standard 

 Takes approximately one minute to achieve approximately 13 million 
waveform acquisition 

 Displays the Data (TM2) waveform.  

 
10. Select TIE in the Configuration. Click OK. The application does the 

following for TIE method: 

 Checks whether Data (TM2) is connected 

 Trigger on Data (TM2) signal at 50% of peak-to-peak amplitude 

 Derives the jitter waveform of Data (TM2) with respect to unjittered 
reference 

 Determines the Pk-Pk value of jitter waveform 

 Compares the read out values with the values specified in the standard 

 Displays the TIE plot of the jitter waveform 
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The following figure shows a typical TIE plot of Jitter waveform: 

 

Figure 8-11: TIE Waveform for 1000BASE-T Jitter Master Unfiltered 

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 625 
edges. This is an alternate test method for jitter measurement being proposed, 
when TX_TCLK is not accessible. This is an informal test method. 
 

The following figure shows a typical Histogram plot of Jitter waveform: 

 

Figure 8-12: Histogram Waveform for 1000BASE-T Jitter Master Unfiltered 

Note: In TDS6000 and DPO7000 series oscilloscopes, approximately 13,000,000 
waveform database samples are acquired. 
The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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1000BASE-T Jitter Slave Filtered 

Note: The two-channel oscilloscopes do not support the Jitter Slave Filtered test. 
1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In the Jit/Distortion tab, select Slave Filtered.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
3. To change the configuration settings, select Tests > Configure from the 

menu bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 8-6: 1000BASE-T Jitter Slave Filtered configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is connected. 
Master CLK CH1, CH2, CH3, or CH4 Select the channel to which the Master TX_TCLK 

is connected. 
Slave CLK CH1, CH2, CH3, or CH4 Select the channel to which the Slave TX_TCLK is 

connected. 
Clock Edge Rising or Falling Select the clock edge on which the oscilloscope 

finds the trigger point. 
Record Length  Varies depending on the Memory option available 

on the oscilloscope. 
TX_TCLK Yes, No Select Yes if you have access to TX_TCLK. Select 

No if you do not have access to TX_TCLK. 
Data (TM2) CH1, CH2, CH3, or CH4 Select the channel to which the Test Mode 2 signal 

is connected. 
Data (TM3) CH1, CH2, CH3, or CH4 Select the channel to which the Test Mode 3 signal 

is connected. 
Hysteresis 5.00% to 30.00% Enter the hysteresis percent value. 
Jitter LP-Filter 1 (Yes), 0 (No)  Configure the low pass filter through the .ini file 

available at  
C:\Program 
Files\TekApplications\TDSET3\Default.ini 
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5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

If you have access to TX_TCLK 

Note: The application checks the frequency of the TX_TCLK. If it is within ±5% 
of 125 MHz or 62.5 MHz, the application proceeds to complete the test or else 
the application displays the error message E106. 
 

7. Click Run Test. The application displays the following dialog box: 

 

Figure 8-13: 1000BASE-T Jitter Slave Filtered Step 1 

8. Set the DUT in Normal mode as Slave and connect to the Link Partner. 

9. Click OK. The application does the following: 

 Checks whether the Master TX_TCLK and Slave TX_TCLK are 
connected 

 Sets up the signal, where at least 105 (minimum of opt. 3M required) 
edges are available 

 Derives the jitter waveform of Master TX_TCLK with respect to 
unjittered reference 

 Derives the jitter waveform of Slave TX_TCLK with respect to Master 
TX_TCLK 

 Applies the filter, and determines the peak-to-peak value of the filtered 
waveforms 
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10. The application displays the following dialog box: 

 

Figure 8-14: 1000BASE-T Jitter Slave Filtered Step 2 

11. Set DUT in Test mode 3 and connect Data and Slave TX_TCLK to the 
oscilloscope. 

12. Click OK. The application checks whether the Data and Slave TX_TCLK are 
connected. 

13. Then, the application measures jitter (Jtxout) of the data with respect to the 
Slave TX_TCLK. 

The application displays the TIE plot of the Jitter waveform as followse: 

 

Figure 8-15: Waveform for 1000BASE-T Jitter Slave Filtered 

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 1250 
edges. 
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The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

If you do not have access to TX_TCLK (this is only an informative test and 
not a compliance test), ensure that TX_TCLK is set to No in the 
Configuration. 

7. Click Run Test. A message box appears. Click OK to quit the message box 
and continue running the test. 

 
8. Set the DUT to generate the signal in test mode 2. 

9. Click OK. The application does the following: 

Step 1: 

 Checks whether Data (TM2) is connected 

 Sets up the signal, where at least 105 edges (minimum opt. 4M 
required) are available 

 Derives the jitter waveform of Data (TM2) with respect to unjittered 
reference 

 Applies the filter, and determines the peak-to-peak value of the filtered 
waveforms 

Step 2: 

 
 Set the DUT to generate the signal in test mode 3 

 Checks whether Data (TM3) is connected 
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 Sets up the signal, where at least 105 edges (minimum opt. 4M 
required) are available 

 Derives the jitter waveform of Data (TM3) with respect to unjittered 
reference 

 Applies the filter, and determines the peak-to-peak value of the filtered 
waveforms 

The application displays the TIE plot of the Jitter waveform as shown by the next 
figure: 

 

Figure 8-16: Waveform for 1000BASE-T Jitter Slave Filtered 

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 625 
edges. This is an alternate test method for jitter measurement being proposed, 
when TX_TCLK is not accessible. This is an informal test method. 
 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

1000BASE-T Jitter Slave Unfiltered 
1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In the Jit/Distortion tab, select Slave Unfiltered.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
3. To change the configuration settings, select Tests > Configure from the 

menu bar, or click the Configure button in the Selection pane.  
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4. In the Configuration window, select the following options: 

Table 8-7: 1000BASE-T Jitter Master Unfiltered configuration options 
Parameter Options To do 
Master CLK CH1, CH2, CH3, 

or CH4 
Select the channel to which the Master TX_TCLK is 
connected. 

Slave CLK CH1, CH2, CH3, 
or CH4 

Select the channel to which the Slave TX_TCLK is 
connected. 

Clock Edge Rising or Falling Select the clock edge on which the oscilloscope finds 
the trigger point. 

Meas Type Histogram or TIE Select the measurement type. 
Record Length  

 
 
 
 

Varies depending on the Memory option available on 
the oscilloscope. 

Note: The Record Length is enabled only if 
you select Meas Type as TIE. 

TX_TCLK Yes, No Select Yes if you have access to TX_TCLK. Select No 
if you do not have access to TX_TCLK. 

Data (TM2) CH1, CH2, CH3, 
or CH4 

Select the channel to which the Test Mode 2 signal is 
connected. 

Data (TM3) CH1, CH2, CH3, 
or CH4 

Select the channel to which the Test Mode 3 signal is 
connected. 

Hysteresis 5.00% to 30.00% Enter the hysteresis percent value. 
Jitter LP-Filter 1 (Yes), 0 (No)  Configure the low pass filter through the .ini file 

available at  
C:\Program Files\TekApplications\TDSET3\Default.ini 

 

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

If you have access to TX_TCLK 

Note: The application checks the frequency of the TX_TCLK. If it is within ±5% 
of 125 MHz or 62.5 MHz, the application proceeds to complete the test or else 
the application displays the error message E106. 
 

7. Select Histogram in the Configuration. Click Run Test. The application 
does the following for Histogram method: 

 Checks whether the Master TX_TCLK and Slave TX_TCLK are 
connected 
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 Triggers on Master TX_TCLK clock signal at 50% of peak-to-peak 
amplitude 

 Sets up the oscilloscope horizontal and vertical scale based on Slave 
TX_TCLK signal 

 Places a horizontal histogram on the Slave TX_TCLK pulse following 
the trigger pulse at 50% of peak-to-peak amplitude 

 Measures the peak-to-peak jitter from the histogram 

 Compares the read out values with the values specified in the standard 

 Takes approximately one minute to achieve approximately 13 million 
waveform acquisition 

 Displays the Slave TX_TCLK waveform 

8. Select TIE in the Configuration. Click Run Test. The application does the 
following for TIE method: 

 Checks whether the Master TX_TCLK and Slave TX_TCLK are 
connected 

 Triggers on Master TX_TCLK clock signal at 50% of peak-to-peak 
amplitude 

 Derives the jitter waveform of the Slave TX_TCLK with respect to 
Master TX_TCLK 

 Determines the Pk-Pk value of jitter waveform 

 Compares the read out values with the values specified in the standard 

 Displays the TIE plot of the jitter waveform 



 

 

 

How To Test 1000BASE-T 

TDSET3 Printable Help Document 8-25 
 

The following figure shows a typical TIE plot of Jitter waveform: 

 

Figure 8-17: TIE Waveform for 1000BASE-T Jitter Slave Unfiltered 

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 1250 
edges. 
 

The following figure shows a typical Histogram plot of Jitter waveform: 

 

Figure 8-18: Histogram Waveform for 1000BASE-T Jitter Slave Unfiltered 

Note: In TDS6000 and DPO7000 series oscilloscopes, approximately 13,000,000 
waveform database samples are acquired 
 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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If you do not have access to TX_TCLK (this is only an informative test and 
not a compliance test), ensure that TX_TCLK is set to No in the 
Configuration. 

For Histogram Method 

7. Set the DUT to generate the signal in test mode 2. 

8. Select Histogram in the Configuration. Click Run Test. A message box 
appears. Click OK to quit the message box and continue running the test. 

 
The application does the following for Histogram method: 

Step 1: 

 Checks whether Data (TM2) is connected 

 Triggers on Data (TM2) at 50% of peak-to-peak amplitude 

 Sets up the oscilloscope horizontal and vertical scale based on Data 
(TM2) 

 Places a horizontal histogram on the Data (TM2) pulse following the 
trigger pulse at 50% of peak-to-peak amplitude 

 Measures the peak-to-peak Data (TM2) jitter from the histogram 

 Takes approximately one minute to achieve approximately 13 million 
waveform acquisition 

 Displays the Data (TM2) waveform 
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Step 2: 

 
 Set the DUT to generate the signal in test mode 3 

 Checks whether Data (TM3) is connected 

 Triggers on Data (TM3) at 50% of peak-to-peak amplitude 

 Sets up the oscilloscope horizontal and vertical scale based on Data 
(TM3) 

 Places a horizontal histogram on the Data (TM3) pulse following the 
trigger pulse at 50% of peak-to-peak amplitude 

 Measures the peak-to-peak Data (TM3) jitter from the histogram 

 Compares the read out values with the values specified in the standard 

 Takes approximately one minute to achieve approximately 13 million 
waveform acquisition 

 Displays the Data (TM3) waveform 
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For TIE Method 

7. Set the DUT to generate the signal in test mode 2. 

8. Select TIE in the Configuration. Click Run Test. A message box appears. 
Click OK to quit the message box and continue running the test. 

 
The application does the following for TIE method: 

Step 1: 

 Checks whether Data (TM2) is connected 

 Triggers on Data (TM2) at 50% of peak-to-peak amplitude 

 Derives the jitter waveform of the Data (TM2) with respect to 
unjittered reference 

 Determines the Pk-Pk value of Data (TM2) jitter waveform 

 Displays the TIE plot of the jitter waveform 

Step 2: 

 
 Set the DUT to generate the signal in test mode 3 

 Checks whether Data (TM3) is connected 

 Triggers on Data (TM3) at 50% of peak-to-peak amplitude 

 Derives the jitter waveform of the Data (TM3) with respect to 
unjittered reference 

 Determines the Pk-Pk value of Data (TM3) jitter waveform 
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 Compares the read out values with the values specified in the standard 

 Displays the TIE plot of the jitter waveform 

The following figure shows a typical TIE plot of Jitter waveform: 

 

Figure 8-19: TIE Waveform for 1000BASE-T Jitter Slave Unfiltered 

Note: The TDS6604 and TDS6404 oscilloscopes acquire approximately 625 
edges. This is an alternate test method for jitter measurement being proposed, 
when TX_TCLK is not accessible. This is an informal test method. 
 

The following figure shows a typical Histogram plot of Jitter waveform: 

 

Figure 8-20: Histogram Waveform for 1000BASE-T Jitter Slave Unfiltered 

Note: In TDS6000 and DPO7000 series oscilloscopes, approximately 13,000,000 
waveform database samples are acquired 
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The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

1000BASE-T Distortion 

Note: The TDS5000 series oscilloscopes are not recommended for 1000BASE-T 
Distortion test. 
 

1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In the Jit/Distortion tab, select Distortion.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 8-8: 1000BASE-T Distortion configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, 

or CH4 
Select the channel to which the DUT is connected. 

# Averages 64 to 10000 Enter the number of waveforms you want to average. 
Output Ref1, Ref2, Ref3, 

or Ref4 
Select the reference waveform on which the processed 
waveform will be stored. 

Disturbing Signal Yes or No Select the options depending on whether the 
Disturbing signal is present or not. 

TX_TCLK CH1, CH2, CH3, 
or CH4 

Select the channel to which the clock source is 
connected. 

Hi Resolution 2 to 75 Enter the number of averages to be done in the 
vertical domain. 

Low Pass Filter Yes, No Select Yes or No depending on whether the noise 
elimination filter is required. 

   
5. Select Tests > Connect or Connect in the Selection pane and make 

connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform.  
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7. If the disturbing signal is present and you have configured Disturbing Signal 
as Yes, and then click Run Test. 

8. The application does the following:  

 Displays a message box to confirm the overwrite of the reference 
waveform. Select Yes to continue 

 Checks whether the DUT is connected  

 Sets the trigger 

9. The application displays the following dialog box: 

 

Figure 8-21: 1000BASE-T Distortion user control 

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 10 ns. 
 

 Check the polarity of the signal 

 If the trigger is not stable, adjust the trigger level for proper stable 
trigger. Then click OK to continue 

10. The application does the following: 

 Acquires, filters, and removes the disturbing signal 

 If TX_TCLK is set as Yes, the application samples the differential 
signal output with the symbol rate of selected TX_TCLK source at an 
arbitrary phase and processes a block of 2047 consecutive samples 
If TX_TCLK is set as No, the application samples the differential 
signal output with the symbol rate with the estimated clock frequency 
at an arbitrary phase and processes a block of 2047 consecutive 
samples 
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 Displays the error plot on selected output (reference waveform) 

11. If the disturbing signal is not present and you have configured Disturbing 
Signal as No, and then click Run Test. The application does the following: 

 Displays a message box to confirm the overwrite of the reference 
waveform. Select Yes to continue  

 Checks whether the DUT is connected  

 Sets the trigger 

 Acquires and filters the data 

 If TX_TCLK is set as Yes, the application samples the differential 
signal output with the symbol rate of selected TX_TCLK source at an 
arbitrary phase and processes a block of 2047 consecutive samples 

 If TX_TCLK is set as No, the application samples the differential 
signal output with the symbol rate with the estimated clock frequency 
at an arbitrary phase and processes a block of 2047 consecutive 
samples 

 Displays the error plot on selected output (reference waveform) 

The following figure shows a typical error plot for Distortion: 

 

Figure 8-22: Waveform for 1000BASE-T Distortion 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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1000BASE-T Return Loss 
1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In the Return Loss tab, select Return Loss.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 8-9: 1000BASE-T Return Loss configuration options 
Parameter Options To do 
Sources  
P1/P3/P5/P7 
P2/P4/P6/P8 

 
CH1, CH2, CH3, or CH4 
CH1, CH2, CH3, or CH4 

 
Select the channel to which the DUT is 
connected. 

Output Waveform  
Return Loss 
   
0 dB Marker 

 
Ref1, Ref2, Ref3, or Ref4 
   
Ref1, Ref2, Ref3, or Ref4 
 
 
 
 

 
Select the reference waveform on which 
the output waveform will be stored. 
Select the reference waveform on which 
you want the 0 dB Marker to be indicated. 

Note: These fields appear only if 
you set Load as 100 Ohm. 

Pair ID A, B, C, D  Depending on the Pair ID selected the 
sources will change from P1/P3/P5/P7 and 
P2/P4/P6/P8. 

Load 85, 100, 115 Ohm or 100 
Ohm 

Select the load as 85, 100, 115 Ohm or  
100 Ohm. 

#Averages 100 to 10000 Enter the number of waveforms you want to 
average. 

Smooth 0 to 10 Enter the smoothening factor. 
AWG/AFG Select, AWG 4xx, AWG 2021, 

AWG 5xx, AWG 6xx, AWG 
7xx, AWG 5xxx, AWG 7xxx 

Select the AWG Series to use. If you select 
the default value–Select–then the 
application considers all AWGs  other than 
the AWG 4xx series. 
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5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Calibrate the test setup. If you do not calibrate the test setup before running 
the test, an error message Error 412: Calibration Data Not Available appears.  

7. Click Run Test. The application does the following: 

 Displays a message box to confirm the overwrite of the reference 
waveform. Select Yes to continue 

 Sets the trigger 

 Acquires, and computes the return loss  

 Displays the return loss curve on selected output (reference waveform) 

If the test fails, the application captures the waveform, circles the hits and saves 
the information to the report. The application obtains the hits information only 
for the 100 Ohm waveform. 

The following figure shows a typical waveform for Return Loss: 

 

Figure 8-23: Waveform for 1000BASE-T Return Loss 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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1000BASE-T CM Voltage 
1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In the CM Voltage tab, select CM Voltage.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 8-10: 1000BASE-T CM Voltage configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, 

or CH4 
Select the channel to which the DUT is connected. 

 

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets the trigger 

 Measures the Output Voltage amplitude for positive and negative 
pulses of 96 ns  

 Compares the values with the Standard 

 Displays the DUT waveform for Common Mode Voltage testing 
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The following figure shows a typical waveform for Common mode Voltage: 

 

Figure 8-24: Waveform for 1000BASE-T CM Voltage 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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How To Test 100BASE-TX 

100BASE-TX Template 
1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Parametric tab, select Output Volt.  

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down 
list.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

4. To change the configuration settings, select Tests > Configure from the menu 
bar, or click the Configure button in the Selection pane.  

5. In the Configuration window, select the following options: 

Table 9-1: 100BASE-TX Template configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
Acquisition Sample or Average Select the acquisition mode. If you select 

Average, # of Wfms appears. Enter the number 
of averages to test in the # of Wfms field. 

 

6. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

7. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

8. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the trigger 

 Loads the AOI template mask 

 Carries out the mask pass/fail test 
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If the test fails, the application captures the waveform, circles the hits and saves 
the information to the report. 

The following figure shows a typical DUT waveform for AOI template test: 

 

Figure 9-1: Waveform for 100BASE-TX Template for positive polarity 

 

Figure 9-2: Waveform for 100BASE-TX Template for negative polarity 

The application also tests for mask and displays the results as pass or fail.  

If the acquired waveform does not lie within the mask, click Manual Fit. To 
adjust the waveform to fit into the Mask, change the horizontal position and 
vertical position using the general purpose knobs or the Virtual Keyboard. This 
repeats the mask pass/fail test and displays the results in the Results Summary 
pane.  

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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100BASE-TX Differential Output Voltage 
1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Parametric tab, select Output Volt.  

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down 
list. 

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 
4. To change the configuration settings, select Tests > Configure from the menu 

bar, or click the Configure button in the Selection pane.  

5. In the Configuration window, select the following options: 

Table 9-2: 100BASE-TX Differential Output Voltage configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
Acquisition Sample or Average Select the acquisition mode. If you select 

Average, # of Wfms appears. Enter the number 
of averages to test in the # of Wfms field. 

 
6. Select Tests > Connect or Connect in the Selection pane and make 

connections. 

7. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

8. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the trigger 

 Measures the Output Voltage amplitude for positive and negative 
pulses of 96 ns 

 Calculates the amplitude symmetry 

 Compares the values with the standard 
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The following figure shows a typical waveform of Differential Output Voltage 
test for positive pulse: 

 

Figure 9-3: Waveform for 100BASE-TX Differential Output Voltage for positive polarity 

The following figure shows a typical waveform of Differential Output Voltage 
test for negative pulse: 

 

Figure 9-4: Waveform for 100BASE-TX Differential Output Voltage for negative polarity 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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100BASE-TX Signal Amplitude Symmetry 
1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Parametric tab, select Amp Sym.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the menu 
bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 9-3: 100BASE-TX Amplitude Symmetry configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
Acquisition Sample or Average Select the acquisition mode. If you select 

Average, # of Wfms appears. Enter the number 
of averages to test in the # of Wfms field. 

 

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the trigger 

 Measures the Output Voltage amplitude for positive and negative 
pulses of 96 ns 

 Calculates the amplitude symmetry 

 Compares the values with the standard 
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The following figure shows a typical waveform of Signal Amplitude Symmetry 
test: 

 

Figure 9-5: Waveform for 100BASE-TX Amplitude Symmetry for positive polarity 

 

Figure 9-6: Waveform for 100BASE-TX Amplitude Symmetry for negative polarity 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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100BASE-TX Rise Time 
1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Parametric tab, select Rise Time.  

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down 
list. 

 

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

4. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

5. In the Configuration window, select the following options: 

Table 9-4: 100BASE-TX Rise Time configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
Acquisition Sample or Average Select the acquisition mode. If you select 

Average, # of Wfms appears. Enter the number 
of averages to test in the # of Wfms field. 

Pulse Width 16ns or 80ns Set Pulse Width to 16 ns or 80 ns. 
 

6. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

7. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

8. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the trigger 

 Measures the rise time of the positive and negative pulses of the 
configured pulse width 

 Compares the values with the standard 
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The following figure shows a typical waveform of Rise Time test: 

 

Figure 9-7: Waveform for 100BASE-TX Rise Time for positive polarity 

 

Figure 9-8: Waveform for 100BASE-TX Rise Time for negative polarity 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

100BASE-TX Fall Time 
1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Parametric tab, select Fall Time.  

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down 
list. 

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
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4. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

5. In the Configuration window, select the following options: 

Table 9-5: 100BASE-TX Fall Time configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
Acquisition Sample or Average Select the acquisition mode. If you select 

Average, # of Wfms appears. Enter the number 
of averages to test in the # of Wfms field. 

Pulse Width 16ns or 80ns Set Pulse Width to 16 ns or 80 ns. 
 

6. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

7. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

8. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the trigger 

 Measures the fall time of the positive and negative pulses of the 
configured pulse width 

 Compares the values with the standard 

The following figure shows a typical waveform of Fall Time test: 

 

Figure 9-9: Waveform for 100BASE-TX Fall Time for positive polarity 
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Figure 9-10: Waveform for 100BASE-TX Fall Time for negative polarity 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

100BASE-TX Rise/Fall Time Symmetry 
1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Parametric tab, select R/F Sym.  

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down 
list. 

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

4. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

5. In the Configuration window, select the following options: 

Table 9-6: 100BASE-TX Rise/Fall Time Symmetry configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
Acquisition Sample or Average Select the acquisition mode. If you select 

Average, # of Wfms appears. Enter the number 
of averages to test in the # of Wfms field. 

Pulse Width 16ns or 80ns Set Pulse Width to 16 ns or 80 ns. 
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6. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

7. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

8. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the trigger 

 Measures the rise and fall time for the configured pulse width 

 Calculates the Rise/Fall Time Symmetry  

 Compares the values with the standard 

The following figure shows a typical waveform of Rise/Fall Time Symmetry test: 

 

Figure 9-11: Waveform for 100BASE-TX Rise/Fall Time Symmetry for positive polarity 

 

 

Figure 9-12: Waveform for 100BASE-TX Rise/Fall Time Symmetry for negative polarity 
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The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

100BASE-TX Waveform Overshoot 
1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Parametric tab, select Overshoot.  

3. Select Pos for positive, Neg for negative, or Both in the Polarity drop-down 
list. 

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
4. To change the configuration settings, select Tests > Configure from the 

menu bar, or click the Configure button in the Selection pane.  

5. In the Configuration window, select the following options: 

Table 9-7: 100BASE-TX Waveform Overshoot configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
Acquisition Sample or Average Select the acquisition mode. If you select 

Average, # of Wfms appears. Enter the number 
of averages to test in the # of Wfms field. 

 

6. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

7. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

8. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the trigger 

 Measures the Overshoot for positive and negative pulses of 96 ns 

 Compares the values with the standard 
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The following figure shows a typical waveform of Waveform Overshoot test: 

 

Figure 9-13: Waveform for 100BASE-TX Waveform Overshoot for positive polarity 

 

Figure 9-14: Waveform for 100BASE-TX Waveform Overshoot for negative polarity 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

100BASE-TX Jitter 
1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Parametric tab, select Jitter.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  
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4. In the Configuration window, select the following options: 

Table 9-8: 100BASE-TX Jitter configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
 

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the trigger 

 Acquires the signal 

 Places a horizontal histogram at the crossing 

 Reads the peak-top-peak jitter from the histogram 

 Compares the values with the standard 

The following figure shows a typical waveform of Jitter test: 

 

Figure 9-15: Waveform for 100BASE-TX Jitter for positive polarity 
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Figure 9-16: Waveform for 100BASE-TX Jitter for negative polarity 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

100BASE-TX Duty Cycle Distortion 
1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Parametric tab, select Distortion.  

3. Select Random or 0101 in the Pattern drop-down list. 

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

4. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

5. In the Configuration window, select the following options: 

Table 9-9: 100BASE-TX Distortion configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is connected. 
Acquisition Sample or Average Select the acquisition mode. If you select Average, 

# of Wfms appears. Enter the number of 
waveforms to test in the # of Wfms field. 

 

6. Select Tests > Connect or Connect in the Selection pane and make 
connections. 
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7. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

8. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the trigger 

 Calculates the duty cycle distortion 

 Compares the values with the standard 

The following figure shows a typical waveform of Distortion test: 

 

Figure 9-17: Waveform for 100BASE-TX Distortion 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

100BASE-TX Return Loss 
1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Return Loss tab, select Transmitter or Receiver.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  
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4. In the Configuration window, select the following options: 

Table 9-10: 100BASE-TX Return Loss configuration options 
Parameter Options To do 
Sources  
P1/P3 
P2/P4 

 
CH1, CH2, CH3, or CH4 
CH1, CH2, CH3, or CH4 

Select the channel to which the DUT is 
connected. 

Note: Depending on whether the 
Transmitter or Receiver is selected, 
the sources will change from P1/P3 
and P2/P4. 
 

Output Waveform  
Return Loss 
   
0 dB Marker 

 
Ref1, Ref2, Ref3, or Ref4 
   
Ref1, Ref2, Ref3, or Ref4 
 
 
 
 

 
Select the reference waveform on which 
the output waveform will be stored. 
Select the reference waveform on which 
you want the 0 dB Marker to be indicated. 

Note: These fields appear only if 
you set Load as 100 Ohm. 

Pair ID A, B, C, D  Depending on the Pair ID selected the 
sources will change from P1/P3/P5/P7 and 
P2/P4/P6/P8. 

Load 85, 100, 115 Ohm or  
100 Ohm 

Select the load as 85, 100, 115 Ohm or  
100 Ohm. 

AWG/AFG Select, AWG 4xx, AWG 2021, 
AWG 5xx, AWG 6xx, AWG 
7xx, AWG5xxx, AWG7xxx, 
AFG3xxx 

Select the AWG/AFG Series to use. If you 
select the default value–Select–then the 
application considers all AWGs/AFGs other 
than the AWG 4xx series. 

#Averages 100 to 10000 Enter the number of waveforms you want to 
average. 

Smooth 0 to 10 Enter the smoothening factor. 
   
5. Select Tests > Connect or Connect in the Selection pane and make 

connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application does the following: 

 Displays a message box to confirm the overwrite of the reference 
waveform. Select Yes to continue 

 Sets up the trigger 
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 Acquires and computes the return loss 

 Displays the return loss curve on selected output (reference waveform) 

If the test fails, the application captures the waveform, circles the hits and saves 
the information to the report. The application obtains the hits information only 
for the 100 Ohm waveform. 

The following figure shows a typical waveform for Return Loss Transmitter: 

 

Figure 9-18: Waveform for 100BASE-TX Return Loss Transmitter 

The following figure shows a typical waveform for Return Loss Receiver: 

 

Figure 9-19: Waveform for 100BASE-TX Return Loss Receiver 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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How To Test 10BASE-T/10BASE-Te 

10BASE-T/10BASE-Te MAU 
1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the Template tab, select MAU. In the adjacent drop-down list, select 
Normal, Inverted, or Both.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
Note2: If you select Both and if the test fails, then Locate hits and Flash hits 
display the MAU Inverted failures. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 10-1: 10BASE-T/10BASE-Te MAU configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
MAU Type Internal, or External Select the MAU Type. 

MAU Scale Normal, 0.9, 1.1 Select the MAU scale factor. 

Mask Setup Samples and Fail Thresh Select the number of samples, and the number 
of samples for fail thresh. 

Energy Efficient 
 

Yes, No 
 

Configure the test to run either in energy 
efficient mode or not. 

Report Setup Device ID, Device 
Description, and Report File 

Configure the options to identify the report. You 
can also choose to automatically preview a file. 

   
5. Select Tests > Connect or Connect in the Selection pane and make 

connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 
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 Validates the DUT for noise and loads the mask 

 Sets up the Vertical, Horizontal, and Trigger oscilloscope parameters 

The application displays the following dialog box: 

 

Figure 10-1: 10BASE-T Template user control dialog box 

 Toggle Lock Mask to Wfm between On and Off to lock or unlock the 
mask to waveform when you zoom in or zoom out 

 Toggle Mask Autofit between On and Off to allow the oscilloscope to 
automatically fit the waveform to mask 

 Click OK to continue 

The application then carries out the mask pass/fail test. 

Note: The application introduces a gap in the mask where segments 1 and 5 
merge. 
 

If the test fails, the application captures the waveform, circles the hits and saves 
the information to the report. 
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The following figure shows a typical DUT waveform for Template testing of 
MAU Ext: 

 

Figure 10-2: Waveform for 10BASE-T MAU Ext 

The following figure shows a typical DUT waveform for Template testing of 
MAU Ext Inv: 

 

Figure 10-3: Waveform for 10BASE-T MAU Ext Inv 

The following figure shows a typical DUT waveform for Template testing of 
MAU Int: 

 

Figure 10-4: Waveform for 10BASE-T MAU Int 
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The following figure shows a typical DUT waveform for Template testing of 
MAU Int Inv: 

 

Figure 10-5: Waveform for 10BASE-T MAU Int Inv 

If the acquired waveform does not lie within the mask, click Manual Fit. To 
adjust the waveform to fit into the Mask, change the horizontal position and 
vertical position using the general-purpose knobs or Virtual Keyboard. This 
repeats the mask pass/fail test and displays the results in the Results Summary 
pane. 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

10BASE-T Link Pulse 
1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the Template tab, select Link Pulse.  

3. In the adjacent drop-down list, select the load with or without TPM — Load1 
w/o TPM, Load2 w/o TPM, 100  w/o TPM, Load1 with TPM, Load2 with 
TPM, or 100  with TPM. 

Note: The 100 Ohm load with TPM and 100 Ohm load without TPM are optional 
and not required according to the 802.3-2002 standards. 

The status bar displays the major configuration details. If you do not want to 
change the configuration settings, you can skip Step 3.  
 

4. To change the configuration settings, select Tests > Configure from the menu 
bar, or click the Configure button in the Selection pane.  
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5. In the Configuration window, select the following options: 

Table 10-2: 10BASE-T Link Pulse configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
Acquisition Sample or Average Select the acquisition mode.  

If you select Average, # of Wfms appears. 
Enter the number of waveforms to test in 
the # of Wfms field. 

Section Both, Head, or Tail Select the section of mask to test. 

Note: If you select Both and if the 
test fails, then Locate hits and 
Flash hits display the Tail section 
failures. 
 

Mask Setup # of Wfms and Fail Thresh Select the number of waveforms to be 
tested and the number of waveforms that 
must fail for the test to fail. 

Sequence  Normal (NLP), Fast (FLP)  Select the type of link pulse you want to 
test. 

Test Options Both, Template Only, Timing 
Only 

Select Both to perform Template and 
Timing tests, Template Only to perform 
Template tests, and Timing Only to perform 
Timing tests. 

Note: Timing tests are available 
only for normal link pulse. 
 

   
6. Select Tests > Connect or Connect in the Selection pane and make 

connections. 

7. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

8. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the signal 

 Loads the front portion of the mask 



 
 
 
 
 
How To Test 10BASE-T 

10-6 TDSET3 Printable Help Document  
 

9. The application displays the following dialog box: 

 

Figure 10-6: 10BASE-T Template user control dialog box 

 Toggle Lock Mask to Wfm between On and Off to lock or unlock the 
mask to waveform when you zoom in or zoom out 

 Toggle Mask Autofit between On and Off to allow the oscilloscope to 
automatically fit the waveform to mask 

 Click OK to continue 

10. The application then carries out the mask pass/fail test. 

Note: If you have selected the Section as Both, the application sets up the signal 
and loads the front portion of the mask for the Head. Then, the application sets 
up the signal and loads the tail portion of the mask. The application adds the 
pass/fail result of both Head and Tail.  
 

If the test fails, the application captures the waveform, circles the hits and saves 
the information to the report. 
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The following figure shows a typical DUT waveform for Link Pulse Timing test: 

 

Figure 10-7: Waveform for 10BASE-T Link Pulse timing 

The following figure shows a typical DUT waveform for Template testing of 
Link Pulse: 

 

Figure 10-8: Waveform for 10BASE-T Link Pulse head 

 

Figure 10-9: Waveform for 10BASE-T Link Pulse tail 
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If the acquired waveform does not lie within the mask, click Manual Fit. To 
adjust the waveform to fit into the Mask, change the horizontal position and 
vertical position using the general purpose knobs or the Virtual Keyboard. This 
repeats the mask pass/fail test and displays the results in the Results Summary 
pane. 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

Note: The 100 Ohm load with TPM and 100 Ohm load without TPM are optional 
and not required according to the 802.3-2002 standards. 

Link Pulse Timing test is not available in TDS6604 and TDS6804 oscilloscopes. 

10BASE-T/10BASE-Te TP_IDL 
1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the Template tab, select TP_IDL. 

3. In the adjacent drop-down list, select the load with or without TPM — Load1 
w/o TPM, Load2 w/o TPM, 100  w/o TPM, Load1 with TPM, Load2 with 
TPM, or 100  with TPM. 

Note: The 100 Ohm load with TPM and 100 Ohm load without TPM are optional 
and not required according to the 802.3-2002 standards (for 10BASE-Te, refer to 
802.3az standard). 

The status bar displays the major configuration details. If you do not want to 
change the configuration settings, you can skip Step 3. 
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4. To change the configuration settings, select Tests > Configure from the menu 
bar, or click the Configure button in the Selection pane. In the Configuration 
window, select the following options: 

Table 10-3: 10BASE-T/10BASE-Te TP_IDL configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is 

connected. 
Acquisition Sample or Average Select the acquisition mode.  

If you select Average, # of Wfms appears. 
Enter the number of waveforms to test in 
the # of Wfms field. 

Section Both, Head, or Tail 
 
 
 
 
 

Select the section of mask to test. 

Note: If you select Both and if the 
test fails, then Locate hits and Flash 
hits display the Tail section failures. 

Energy Efficient 
 

Yes, No 
 

Configure the test to run either in energy 
efficient mode or not. 

Mask Setup # of Wfms and Fail Thresh Select the number of waveforms to be 
tested and the number of waveforms that 
must fail for the test to fail. 

   
5. Select Tests > Connect or Connect in the Selection pane and make 

connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the signal 

 Loads the front portion of the mask 
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8. The application displays the following dialog box: 

 

Figure 10-10: 10BASE-T Template user control dialog box 

 Toggle Lock Mask to Wfm between On and Off to lock or unlock the 
mask to waveform when you zoom in or zoom out 

 Toggle Mask Autofit between On and Off to allow the oscilloscope to 
automatically fit the waveform to mask 

 Click OK to continue 

9. The application then carries out the mask pass/fail test. 

Note: If you have selected the Section as Both, the application sets up the signal 
and loads the front portion of the mask for the Head. Then, the application sets 
up the signal and loads the tail portion of the mask. The application adds the 
pass/fail result of both Head and Tail.  
 

If the test fails, the application captures the waveform, circles the hits and saves 
the information to the report. 
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The following figure shows a typical DUT waveform for Template testing of 
TP_IDL: 

 

Figure 10-11: Waveform for 10BASE-T TP_IDL head 

 

Figure 10-12: Waveform for 10BASE-T TP_IDL tail 

If the acquired waveform does not lie within the mask, click Manual Fit. To 
adjust the waveform to fit into the Mask, change the horizontal position and 
vertical position using the general purpose knobs or Virtual Keyboard. This 
repeats the mask pass/fail test and displays the results in the Results Summary 
pane. 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

Note: The 100 Ohm load with TPM and 100 Ohm load without TPM are optional 
and not required according to the 802.3-2002 standards (for 10BASE-Te, refer to 
802.3az standard). 
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10BASE-T/10BASE-Te Differential Voltage 
1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the Parametric tab, select Diff Volt. From the Peak drop-down list, select 
the peak value as Max or Min Max.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the menu 
bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 10-4: 10BASE-T/10BASE-Te Differential Voltage configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is connected. 

Energy 
Efficient 

Yes, No 
 

Configure the test to run either in energy efficient 
mode or not. 

   

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the Vertical, Horizontal, Trigger oscilloscope parameters 

 Measures the maximum and minimum voltages on the waveform 
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The following figure shows a typical DUT waveform for Differential Voltage: 

 

Figure 10-13: Waveform for 10BASE-T Differential Voltage 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

Note: The application displays the probe offset value in the Result Details dialog 
box. 

10BASE-T/10BASE-Te Harmonic 
1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the Parametric tab, select Harmonic.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  
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4. In the Configuration window, select the following options: 

Table 10-5: 10BASE-T/10BASE-Te Harmonic configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is connected. 

Harmonic Ones 
Output Math1, Math2, Math3, or 

Math4 
Select the math waveform on which the processed 
waveform will be stored. 

# of Averages  Enter the number of waveforms to be averaged. 

Energy 
Efficient 

Yes, No 
 

Configure the test to run either in energy efficient 
mode or not. 

Time/Scale 1 or 10 microseconds Enter the time or scale depending on the packet 
length being transmitted. 

   

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets up the Vertical, Horizontal, Trigger and Math Spectral 
oscilloscope parameters 

 Displays the Math waveform 
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The following figure shows a typical DUT waveform for Harmonic: 

 

Figure 10-14: Waveform for 10BASE-T Harmonic 

Note: The Harmonic result starts at 2 and ends at 25. If the calculated harmonic 
frequency value is not in the range of + 0.5 MHz, then cursor- based readings of 
the harmonic value are used. 
 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

10BASE-T Jitter with cable 
1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the Parametric tab, select With Cable in the Jitter group. Select Normal, 
8BT, 8.5BT, or All in the adjacent drop-down list.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the menu 
bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 10-6: 10BASE-T Jitter with cable configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is connected. 

MAU Type Internal, or External Select the MAU Type as Internal or External. 
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5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application checks whether the DUT is connected and a 
valid signal is acquired. 

8. If you selected 8BT or 8.5BT or All (Refer Step 2), the following window 
appears: 

 

Figure 10-15: 10BASE-T Jitter with cable user control 

If the signal does not look like the one in the image, you can set up the 
oscilloscope. The signal may not match the one in the image if an interpacket 
interval is observed on the screen. Adjust these parameters in the oscilloscope: 

 Increase the trigger level so that the interpacket interval is not considered. 
Trigger level is currently set to 60 mV accounting for the noise of 50 mV 

 If the signal still does not match the one in the image, adjust the trigger hold 
off parameter. This adjustment will help in skipping the interpacket interval 
and get the stable trigger every time 

9. The application does the following: 

 Sets up the signal 

 Places the horizontal histogram at the zero crossing 

 Reads the peak-to-peak jitter from the histogram 

 Compares the read out values with the standard 

 Acquires the signal for approximately 15 seconds 
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If you have selected Output Timing Jitter as Normal, the application displays the 
typical DUT waveform for Jitter with cable testing as shown in the following 
figure: 

 

Figure 10-16: Waveform for 10BASE-T Jitter with Cable for Normal output timing jitter 

If you have selected Output Timing Jitter as 8 BT, the application displays the 
typical DUT waveform for Jitter with cable testing as shown in the following 
figure: 

 

Figure 10-17: Waveform for 10BASE-T Jitter with Cable for 8 BT output timing jitter 



 
 
 
 
 
How To Test 10BASE-T 

10-18 TDSET3 Printable Help Document  
 

If you have selected Output Timing Jitter as 8.5 BT, the application displays the 
typical DUT waveform for Jitter with cable testing as shown in the following 
figure: 

 

Figure 10-18: Waveform for 10BASE-T Jitter with Cable for 8.5 BT output timing jitter 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

10BASE-T Jitter without cable 
1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the Parametric tab, select w/o Cable in the Jitter group. Select Normal, 
8BT, 8.5BT, or All in the adjacent drop-down list.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 10-7: 10BASE-T Jitter without cable configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is connected. 

MAU Type Internal, or External Select the MAU Type as Internal or External. 

   
5.  
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6. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

7. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

8. Click Run Test. The application checks whether the DUT is connected and a 
valid signal is acquired. 

9. If you selected 8BT or 8.5BT or All (Refer Step 2), the following window 
appears: 

 

Figure 10-19: 10BASE-T Jitter without cable user control 

If the signal does not look like the one in the image, you can set up the 
oscilloscope. The signal may not match the one in the image if an interpacket 
interval is observed on the screen. Adjust these parameters in the oscilloscope: 

 Increase the trigger level so that the interpacket interval is not considered. 
Trigger level is currently set to 60 mV accounting for the noise of 50 mV 

 If the signal still does not match the one in the image, adjust the trigger hold 
off parameter. This adjustment will help in skipping the interpacket interval 
and get the stable trigger every time 

10. The application does the following: 

 Sets up the signal 

 Places the horizontal histogram at the zero crossing 

 Reads the peak-to-peak jitter from the histogram 

 Compares the read out values with the Standard 
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 Acquires the signal for approximately 15 seconds 

If you have selected Output Timing Jitter as Normal, the application displays the 
typical DUT waveform for Jitter with cable testing as shown in the following 
figure: 

 

Figure 10-20: Waveform for 10BASE-T Jitter without Cable for Normal output timing jitter 

If you have selected Output Timing Jitter as 8 BT, the application displays the 
typical DUT waveform for Jitter with cable testing as shown in the following 
figure: 

 

Figure 10-21: Waveform for 10BASE-T Jitter without Cable for 8 BT output timing jitter 
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If you have selected Output Timing Jitter as 8.5 BT, the application displays the 
typical DUT waveform for Jitter with cable testing as shown in the following 
figure: 

 

Figure 10-22: Waveform for 10BASE-T Jitter without Cable for 8.5 BT output timing jitter 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 

10BASE-T Return Loss 
1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the Return Loss tab, select Transmitter or Receiver.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  

4. In the Configuration window, select the following options: 

Table 10-8: 10BASE-T Return Loss configuration options 
Parameter Options To do 
Sources  
P1/P3 
P2/P4 

 
CH1, CH2, CH3, 
or CH4 
CH1, CH2, CH3, 
or CH4 

Select the channel to which the DUT is connected. 

Note: Depending on whether the Transmitter 
or Receiver is selected, the sources will 
change from P1/P3 and P2/P4. 
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Table 10-8: 10BASE-T Return Loss configuration options (cont) 

Parameter Options To do 
Output Waveform  
Return Loss 
   
0 dB Marker 

 
Ref1, Ref2, Ref3, 
or Ref4 
   
Ref1, Ref2, Ref3, 
or Ref4 
 
 
 

 
Select the reference waveform on which the output 
waveform will be stored. 
Select the reference waveform on which you want the  
0 dB Marker to be indicated. 

Note: These fields appear only if you set Load 
as 100 Ohm. 

AWG/AFG Select, AWG 4xx, 
AWG 2021, AWG 
5xx, AWG 6xx, 
AWG 7xx, 
AWG5xxx, 
AWG7xxx, 
AFG3xxx 

Select the AWG/AFG Series to use. If you select the 
default value–Select–then the application considers all 
AWGs/AFGs other than the AWG 4xx series. 

Load 85, 100,  
115 Ohm or  
100 Ohm 

Select the load as 85, 100, 115 Ohm or 100 Ohm. 

#Averages 100 to 10000 Enter the number of waveforms you want to average. 
Smooth 0 to 10 Enter the smoothening factor. 
   
5. Select Tests > Connect or Connect in the Selection pane and make 

connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application does the following: 

 Displays a message box to confirm the overwrite of the reference 
waveform. Select Yes to continue 

 Sets up the trigger 

 Acquires and computes the return loss 

 Displays the return loss curve on selected output (reference waveform) 

If the test fails, the application captures the waveform, circles the hits and saves 
the information to the report. The application obtains the hits information only 
for the 100 Ohm waveform. 
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The following figure shows a typical waveform for Return Loss Transmitter: 

 

Figure 10-23: Waveform for 10BASE-T Return Loss Transmitter 

The following figure shows a typical waveform for Return Loss Receiver: 

 

Figure 10-24: Waveform for 10BASE-T Return Loss Receiver 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and click Result Details button to view detailed results. 

10BASE-T CM Voltage 
1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the CM Voltage tab, select CM Voltage.  

Note: The status bar displays the major configuration details. If you do not want 
to change the configuration settings, you can skip Step 3. 
 

3. To change the configuration settings, select Tests > Configure from the 
menu bar, or click the Configure button in the Selection pane.  
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4. In the Configuration window, select the following options: 

Table 10-9: 10BASE-T CM Voltage configuration options 
Parameter Options To do 
Data CH1, CH2, CH3, or CH4 Select the channel to which the DUT is connected. 
   

5. Select Tests > Connect or Connect in the Selection pane and make 
connections. 

6. Select View Wfm in the Selection pane, to view and compare the waveform 
with the acquired waveform. 

7. Click Run Test. The application does the following: 

 Checks whether the DUT is connected and a valid signal is acquired 

 Sets the trigger 

 Measures the maximum positive and negative voltage levels 

 Compares the values with the Standard 

 Displays the DUT waveform for Common mode Voltage testing 

The following figure shows a typical waveform for Common mode Voltage: 

 

Figure 10-25: Waveform for 10BASE-T CM Voltage 

The application automatically displays the results as pass or fail. Select Results 
in the Execution pane and then click Result Details button to view the detailed 
results. 
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View Waveform for 1000BASE-T 

1000BASE-T Template, Peak Volt, Droop 

 

Figure 11-1: 1000BASE-T View Waveform for Template, Peak Volt, and Droop with disturbing 
signal 

 

Figure 11-2: 1000BASE-T View Waveform for Template, Peak Volt, and Droop without 
disturbing signal 

Ensure the waveform displayed by the application in the circled portion is similar 
to the acquired waveform. 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 For Template, Peak Volt, and Droop tests, check if the DUT is set to 
transmit Test Mode 1 signal 

 Check the polarity of the signal 

 Check the correctness of jumper connections in the fixture 
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 Check the correctness of the probing point in the fixture 

1000BASE-T Jitter Master 

 

Figure 11-3: 1000BASE-T View Waveform for Jitter Master Filtered (with TX_TCLK access) 

 

Figure 11-4: 1000BASE-T View Waveform for Jitter Master Filtered (without TX_TCLK 
access) 
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Figure 11-5: 1000BASE-T View Waveform for Jitter Master Unfiltered (with TX_TCLK access) 

 

Figure 11-6: 1000BASE-T View Waveform for Jitter Master Filtered (without TX_TCLK 
access) 

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 10 ns. 
 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is set to transmit Test Mode 2 signal 

 Check the correctness of test setup 

 Check the correctness of the probing point in the fixture 
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1000BASE-T Jitter Slave 

 

Figure 11-7: 1000BASE-T View Waveform for Jitter Slave Filtered (with TX_TCLK access) 

 

Figure 11-8: 1000BASE-T View Waveform for Jitter Master Filtered (without TX_TCLK 
access) 

 

Figure 11-9: 1000BASE-T View Waveform for Jitter Slave Unfiltered (with TX_TCLK access) 
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Figure 11-10: 1000BASE-T View Waveform for Jitter Master Filtered (without TX_TCLK 
access) 

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 10 ns. 
 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is set to transmit the appropriate Test Mode signal 

 Check the correctness of test setup 

 Check the correctness of the probing point in the fixture 

1000BASE-T Distortion 

 

Figure 11-11: 1000BASE-T View Waveform for Distortion 

Note: In TDS5000B series oscilloscopes, the horizontal scale is set to 10 ns. 
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If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is set to transmit Test Mode 4 signal 

 Check the polarity of the signal 

 Check the correctness of jumper connections in the fixture 

 Check the correctness of the probing point in the fixture 

1000BASE-T Return Loss 

 

Figure 11-12: 1000BASE-T View Waveform for Return Loss 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is set to transmit Test mode 4 signal 

 Check if the polarity of probe connection is right 

 Check the correctness of the probing point in the Test Fixture 
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1000BASE-T CM Voltage 

 

Figure 11-13: 1000BASE-T View Waveform for CM Voltage 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is set to transmit Test mode 4 signal 

 Check if the probe is properly locked to the oscilloscope 

 Check if all the connections are proper 
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View Waveform for 100BASE-TX 

All 100BASE-TX Tests except Return Loss 

 

Figure 12-1: 100BASE-TX View Waveform for all tests except Return Loss 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is set to transmit random sequence 

 Check if the polarity of probe connection is right 

 Check the correctness of the probing point in the Test Fixture 
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100BASE-TX Return Loss 

 

Figure 12-2: 100BASE-TX View Waveform for Return Loss Transmitter 

 

Figure 12-3: 100BASE-TX View Waveform for Return Loss Receiver 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is set to transmit random sequence 

 Check if the polarity of probe connection is right 

 Check the correctness of the probing point in the Test Fixture 
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View Waveform for 10BASE-T/10BASE-Te 

10BASE-T Link Pulse 

 

Figure 13-1: 10BASE-T View Waveform for Link Pulse 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is transmitting the Link Pulse 

 Check if the probe is properly locked to the oscilloscope 

 Check if the polarity of probe connection is right 

 Check if all the connections are proper 
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10BASE-T/10BASE-Te MAU 

 

Figure 13-2: 10BASE-T View Waveform for MAU 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is transmitting the Link Pulse 

 Check if the probe is properly locked to the oscilloscope 

 Check if the polarity of probe connection is right 

 Check if all the connections are proper 
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10BASE-T/10BASE-Te TP_IDL 

 

Figure 13-3: 10BASE-T View Waveform for TP_IDL with TPM 

 

Figure 13-4: 10BASE-T View Waveform for TP_IDL without TPM 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is transmitting 10Base-T packets 

 Check if the polarity of probe connection is right 

 Check if the probe is properly locked to the oscilloscope 

 Check if all the connections are proper 

10BASE-T Jitter with or without cable 
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Figure 13-5: 10BASE-T View Waveform for Jitter with cable 

 

Figure 13-6: 10BASE-T View Waveform for Jitter without cable 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is transmitting 10Base-T packets 

 Check if the probe is properly locked to the oscilloscope 

 Check if all the connections are proper 
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10BASE-T/10BASE-Te Differential Voltage 

 

Figure 13-7: 10BASE-T View Waveform for Differential Voltage 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is transmitting 10Base-T packets 

 Check if the polarity of probe connection is right 

 Check if the probe is properly locked to the oscilloscope 

 Check if all the connections are proper 
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10BASE-T/10BASE-Te Harmonic 

 

Figure 13-8: 10BASE-T View Waveform for Harmonic 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is transmitting 10Base-T packets 

 Check if the polarity of probe connection is right 

 Check if the probe is properly locked to the oscilloscope 

 Check if all the connections are proper 
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10BASE-T Return Loss 

 

Figure 13-9: 10BASE-T View Waveform for Return Loss 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is transmitting 10Base-T packets 

 Check if the polarity of probe connection is right 

 Check if the probe is properly locked to the oscilloscope 

 Check if all the connections are proper 
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10BASE-T CM Voltage 

 

Figure 13-10: 10BASE-T View Waveform for CM Voltage 

If the waveform displayed by the application is not similar to the acquired 
waveform in the graticule, do the following: 

 Check if the DUT is transmitting 10Base-T packets 

 Check if the probe is properly locked to the oscilloscope 

 Check if all the connections are proper 
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Generate Reports 

You can automatically generate reports using the Report Summary or Details 
button. You can use Report Configuration pane in the Result pane for 
configuring the DUT details and report file name.  

Use Report Generator to manually generate the report. For more information, see 
the next section About Report Generator. 

To manually generate the report, do the following: 

1. From the application menu bar, select Utilities > Report Generator to 
display Report Generator window. 

2. In the Generate Report tab, select Browse. The Open dialog box displays all 
the reports in the default directory c:\TekApplications\TDSET3\Report 
Generator\Reports. 

3. In the Open dialog box, select the relevant tests, and then select Open. 

4. In the Generate Report tab, select Generate Report, Print Report, or Load 
Report. 

5. If you select Generate Report, the Assign Data to Report dialog box appears. 

 In the Assign Data to Report dialog box, select the test templates to 
assign the current data from your measurement application 

 Select Assign. The Report Viewer displays the report with current data 
from the application. You can choose to export to rtf format 

If you select Print Report, the Report Viewer displays the selected report with 
current data from the application. 

 If the page settings do not match the page settings for the report, a Page 
Size Mismatch message box displays a message — The current page 
settings do not match the page settings for the Report. Do you want 
to continue? 

 Click Yes to continue 

 Click No to stop printing the report 

 If a printer is connected to the oscilloscope, the report is printed 

If you select View Report, the Report Viewer displays the selected report with 
current data from the application. 
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You can also define test templates, and define report layouts. 

About Report Generator 
The Report Generator enables you to generate and print reports directly from the 
oscilloscope. It enhances the TDSET3 application capabilities by simplifying the 
process of creating and maintaining reports.  

The Report Generator automates the process of compiling the test results and 
generating the reports. It allows you to set up the template layout using the 
factory default templates or custom templates. The Report Generator allows you 
to save files in the custom file formats such as .rgt, .rpl, or .rpt. The generated 
reports can also be saved as an .rtf file. The Report Generator is integrated with 
the TDSET3 application. 

To generate a report in PDF format, you can use any tool that converts RTF to 
PDF. For converting the .RPT to PDF, there are several tools such as 
RoboPDFTM, GhostWriterTM and so on. 

For more information on Report Generator, click here to view the Report 
Generator Printed Help Document. 

You can also access the file – ReportGenerator.pdf at C:\Program 
Files\TekApplications\TDSET3. 
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Automating AWG/AFG 

Automate AWG/AFG 
Utilities > Automate AWG/AFG 

This procedure will guide you through the process of connecting and configuring 
the AWG/AFG and the oscilloscope for automation. 

You will need: Tektronix AWG/AFG, Tektronix digital oscilloscope, and 
National Instruments GPIB-USB-A cable with the included software (NI-488.2 
for Windows) or GPIB-USB-B cable with pre-installed software. 

1. Connect the equipment and verify the connection. 

2. From the TDSET3 menu, select Utilities > Automate AWG/AFG. The 
following screen appears: 

 

Figure 15-1: AWG/AFG Automation Setup 
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3. Select GPIB to automate the AWG/AFG and configure GPIB setup. The 
following table describes the AWG/AFG Automation configuration 
parameters: 

Table 15-1: AWG/AFG configuration parameters and descriptions 
Configuration parameter Description 
GPIB, Manual Select GPIB to automate file transfer and settings to the 

AWG/AFG. 
Board Type Select the Board Type that you are using. 
Primary Address Select the Primary GPIB Address. 
Secondary Address Select the Secondary GPIB Address. 
Show File overwrite warnings When checked, warns you before transferring files on the 

AWG/AFG while running a test. 

Note: While running a test, the oscilloscope transfers waveform and setup files to 
the AWG/AFG. Ensure that the AWG/AFG does not have files with the same 
name to avoid overwriting those files. 
 

4. Click Test Connection and look for a message that the connection is 
successful. Test Connection is enabled only for the GPIB mode.  

5. RUN the selected test. 

If you have selected Manual to set up the AWG/AFG and configure GPIB setup, 
you must: 

 Copy the waveform files from C:\TekApplications\TDSET3\AWG 
Waveforms 

 Load the appropriate waveform onto the proper channel 

 Make the AWG/AFG settings according to the ReadMe.txt in the 
corresponding folder 

 Then RUN the test 

Configuration Parameters and Default Settings: 

Table 15-2: AWG/AFG configuration parameters and defaults 
Parameter Default  
Select: GPIB, Manual Manual 
Board Type GPIB0 
Primary Address 9 
Secondary Address 1 
Show File overwrite warnings Checked 
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Connect the Equipment and Verify the Connections 
Before you connect the equipment and verify the connection, ensure that you 
have installed NI-488.2 for Windows. If you are using the GPIB-USB-B cable 
verify that the software is pre-installed. Follow these steps to install NI-488.2 for 
Windows. 

1. Install NI-488.2 for Windows on the oscilloscope. 

During installation:  

2. Ensure that NI-VISA is NOT installed. 

3. Install the Measurement and Automation Explorer. 

4. When prompted, enable the GPIB-USB-A/B interface. 

5. Restart the oscilloscope. 

Connect the Equipment  

1. Connect the GPIB-USB-A/B to the USB port on the oscilloscope (the 
TDS7000B rear panel is shown here). The oscilloscope operating system will 
detect the USB-GPIB controller and install the appropriate driver for it.  

2. Connect the other end of the cable GPIB-USB-A/B to the AWG/AFG. 

 

Figure 15-2: Connecting the AWG/AFG and the Oscilloscope 

Verify the Equipment Connections 

3. Open the Measurement and Automation Explorer that was installed with the 
NI-488.2 software. 
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4. In the Configuration pane, look under Devices and Interfaces for the GPIB 
device.  

 

Figure 15-3: Verifying the instrument connections 

5. Right-click on the GPIB device and click Scan for Instruments.  

6. Note the GPIB Instrument Number and the Primary Address for configuring 
the instrument connection in the TDSET3 application.  

7. Right click on the instrument (Instrument0 in this example) and click 
Communicate with Instrument. 

8. In the NI-488.2 Communicator dialog box, click Query and check that 
*IDN? brings up a description of the correct equipment. 

9. From the Tekscope menu, select Utilities> GPIB Configuration. In the GPIB 
Configuration, ensure that the Talk/Listen is selected and the primary address 
matches the GPIB instrument number. 



 

 

 

Automating AWG/AFG 

TDSET3 Printable Help Document 15-5 
 

10. Search for the TekVISA configuration on one of the following: 

 Desktop 

 Start\Program Files\TekVISA\Tek VISA configuration 

 Start\Program Files\TekVISA\OpenChoice Instrument Manager 
configuration for application version 3.0.0 and above  

If you cannot find TekVISA, rename the visa32.dll in C:\winnt\system32 and 
then install the latest TekVISA.  

11. Click on the Find/Refresh button to refresh the list of devices connected to 
the oscilloscope. 

 

Figure 15-4: TekVISA Resource Manager Configuration 
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For application version 3.0.0 and above, click "search criteria" in the Instrument 
Manager. To confirm that the AWG//AFG is connected over GPIB to the 
oscilloscope, select the "Search for GPIB" option and click Done.To update the 
list of devices connected to the oscilloscope, click Update. 

 

Figure 15-5: TekVISA Resource Manager configuration (application version 3.0.0 and above) 
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12. If the NI-488.2 GPIB settings and TekVISA configuration do not match, the 
connection/configuration might not be correct. 

Note: If the AWG/AFG is not found listed in TekVISA (with the properties as in 
NI VISA), make sure that TekVISA detects the GPIB devices. Sometimes it could 
detect only those network devices that you see. 
 

13. Start the application and continue with AWG/AFG automation. 

Note: While running a test, the oscilloscope transfers waveform and setup files to 
the AWG/AFG. Ensure that the AWG does not have files with the same name to 
avoid overwriting those files. 
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Reference to Standards 

1000BASE-T 

1000BASE-T 
Template 

 
Purpose: 

To verify that the transmitter output fits the time domains transmit templates. 

Reference to Standard: 

Subclause 40.6.1.2.3 of IEEE standard 802.3-2002 ab 

What Standard says: 

According to standard, the Test Mode 1 signal from the DUT needs to be 
normalized. This should be compared to the differential output templates shown 
in Figure 40-26 of the standard. The normalization factors to be applied to 
various points: 

For Point A: Normalization with the peak voltage at point A.  

For Point B: Normalization with the negative of peak voltage at point A.  

For Point C: Normalization with 0.5 times the peak voltage at point A.  

For Point D: Normalization with the negative of 0.5 times the peak voltage at 
point A. 

For Point F and H: The waveform around points F and H are compared to time 
domain transmit template 2 after the following normalization factors are applied: 

Normalization with the peak voltage at point F.  

Normalization with the peak voltage at point H. 

According to standard, the waveform can be shifted in time to fit the template. 
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1000BASE-T 
Peak Voltage 

 
Purpose:  

To verify correct transmitter output levels. 

Reference to the Standard: 

Subclause 40.6.1.2.1 of IEEE standard 802.3-2002 ab 

What the Standard says:  

According to standard, magnitude of peak differential output voltage measure at 
points A and B should be between 670 and 820 mV. Also, these conditions 
should be met: 

 

 

1000BASE-T 
Droop 

 
Purpose: 

To verify that the transmitter output level does not decay faster than the 
maximum specified rate. 

Reference to the Standard: 

Subclause 40.6.1.2.2 of IEEE standard 802.3-2002 ab 

What the Standard says: 

According to standard, the Point G and J are exactly 500 ns from Points F and H 
respectively. The magnitude of voltage at Point G should be greater than 73.1% 
magnitude of voltage at Point F and magnitude of voltage at Point J should be 
greater than 73.1% magnitude of voltage at Point H. 

1000BASE-T 
Jitter (with 

TX_TCLK 
ACCESS) 

 
 
 
 
 
 

 
Purpose: 

To verify that the transmitter output level does not reduce faster than the 
maximum specified rate. 

Reference to the Standard: 

Subclause 40.6.1.2.5 of IEEE standard 802.3-2002 ab 

 



 

 

 

Reference to Standards 

TDSET3 Printable Help Document 16-3 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 
1000BASE-T 

Jitter (without 
TX_TCLK 
ACCESS) 

 

What the Standard says: 

Jitter Master Unfiltered — According to the standard, the peak-to-peak value 
of jitter waveform on MASTER TX_TCLK relative to unfiltered reference 
should be less than 1.4 ns. 

Jitter Master Filtered — According to the standard, the peak-to-peak value of 
jitter  

waveform on MASTER TX_TCLK when filtered by a high pass filter,  
with the transfer function below + JTx out of Data related to the corresponding 
edge of MASTER TX_TCLK should be less than 0.3 ns. 

 
Jitter Slave Unfiltered — According to the standard, the peak-to-peak value of 
jitter waveform on SLAVE TX_TCLK relative to unfiltered reference should be 
less than 1.4 ns. 

Jitter Slave Filtered —According to the standard, the peak-to-peak value of 
jitter  

waveform on SLAVE TX_TCLK when filtered by a high pass filter,  with 
the transfer function below + JTx out of data related to the corresponding edge of 
SLAVE TX_TCLK should be less than 0.4 ns + peak-to-peak value of jitter  

waveform on MASTER TX_TCLK when filtered by a high pass filter, . 

 

Note: J denotes the square root of -1. 
 

Purpose: 

To provide an analysis of the Transmitter Timing Jitter test method defined in 
Clause 40.6.1.2.5 of IEEE 802.3-2002, and to propose an alternative method that 
may be used in cases where a device does not provide access to the TX_TCLK 
signal. 

Reference: 

1. IEEE standard 802.3-2002, subclause 40.6.1.1.1 – Test channel 
2. Ibid., subclause 40.6.1.1.2, figure 40-20 – Test modes 
3. Ibid., subclause 40.6.1.1.3, figure 40-25 – Test fixtures 
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4. Ibid., subclause 40.6.1.2.5 – Transmitter Timing Jitter 
5. Test suite appendix 40.6.A – 1000BASE-T transmitter test fixtures 

Note: The references mentioned here are proposed, and not part of a standard. 
This is an alternate test method for jitter measurement being proposed, when 
TX_TCLK is not accessible. This is an informal test method. 
 

Transmitting Timing Jitter (Alternate Method): 

Jitter Master Unfiltered — The peak-to-peak value of jitter waveform on data 
in Test Mode 2 relative to unjittered reference should be less than 1.4 ns (pass). 

The peak-to-peak value of jitter waveform on data in Test Mode 2 relative to 
unjittered reference should be more than 1.4 ns (inconclusive). 

Jitter Master Filtered — The peak-to-peak value of jitter waveform on data in 
Test Mode 2 relative to unjittered reference, when filtered by a high pass filter,  

 with the transfer function below should be less than 0.3 ns (pass). 

The peak-to-peak value of jitter waveform on data in Test Mode 2 relative to 
unjittered reference,  
when filtered by a high pass filter,  with the transfer function below should 
be more than 0.3 ns (inconclusive). 

 
Jitter Slave Unfiltered — The difference between the peak-to-peak value of 
jitter waveform on data in Test Mode 3 relative to unjittered reference and the 
peak-to-peak value of jitter waveform on data in Test Mode 2 relative to 
unjittered reference should be less than 1.4 ns (pass). 

The difference between the peak-to-peak value of jitter waveform on data in Test 
Mode 3 relative to unjittered reference and the peak-to-peak value of jitter 
waveform on data in Test Mode 2 relative to unjittered reference should be more 
than 1.4 ns (fail). 

Jitter Slave Filtered — The difference between the peak-to-peak value of jitter 
waveform on data in Test Mode 3 relative to unjittered reference, when filtered 
by a high pass filter, 
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 with the transfer function below, and the peak-to-peak value of jitter 
waveform on data in Test Mode 2 relative to unjittered reference,  
when filtered by a high pass filter,  

 with the transfer function below, should be less than 0.4 ns (pass). 

The difference between the peak-to-peak value of jitter waveform on data in Test 
Mode 3 relative to unjittered reference, when filtered by a high pass filter,  

 with the transfer function below, and the peak-to-peak value of jitter 
waveform on data in Test Mode 2 relative to unjittered reference, when filtered 
by a high pass filter,  

 with the transfer function below, should be more than 0.4 ns (fail). 

 

 

1000BASE-T 
Distortion 

 
Purpose: 

To verify that the peak transmitter distortion of the DUT is less than 10 mV for 
at least 60% of the UI within the eye-opening. 
References: 
IEEE standard 802.3-2002, sub clause 40.6.1.2.4 
PMA Test suite, version 2.5,  Test 40.1.6 
What the Standard says: 

The peak distortion of the Test Mode 4 differential signal, when sampled with the 
symbol rate TX_TCLK at an arbitrary phase and processing this block of any 
2047 consecutive samples, should be less than 10 mV. 

1000BASE-T 
CM Voltage 

 
Purpose:  

To verify that the common-mode voltage of the DUT is within the conformance 
limits. 

Reference to Standard:  
Subclause 40.8.3.3 of IEEE standard 802.3-2002 

What Standard says:  
The magnitude of the total common-mode output voltage, Ecm_out, on any 
transmit circuit, shall be less than 50 mV peak-to-peak when transmitting data. 
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1000BASE-T 
Return Loss 

 
Purpose:  

To verify that the return loss of the device under test (DUT) is above the 
conformance limit.  

Reference to Standard:  

Subclause 40.8.3.1 of IEEE standard 802.3-2002 ab 

What Standard says:  

At least 16 dB over the frequency range of 1.0 MHz to 40 MHz and at least 10 -
20log 10 (f /80)dB over the frequency range 40 MHz to 100 MHz (f in MHz). 

100BASE-TX 

100BASE-TX 
Template 

 
Purpose:  

To verify that the transmitter output fits the time domains transmit templates. 

Reference to the Standard: 

Annex J of ANSIX3.263-1995  

What the Standard says:  

According to standard, Active Output Interface (AOI) transmitting scrambled 
Halt Line State should fit in the template. 

100BASE-TX 
Differential 

Output 
Voltage 

 
Purpose: 

To verify that the differential output voltage of the device under test (DUT) is 
within the conformance limits. 

Reference to the Standard: 

Subclause 9.1.2.2 of ANSI X3.263-1995 

What the Standard says:  

According to standard, differential output voltage (Vout) should lie in the range of 
950 mV to 1050 mV in both positive and negative excursion. 
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100BASE-TX 
Signal 

Amplitude 
Symmetry 

 
Purpose: 

To verify that the signal amplitude symmetry of the device under test (DUT) is 
within the conformance limits. 

Reference to Standard: 

Subclause 9.1.4 of ANSI X3.263-1995 

What Standard says:  

The ratio of the + Vout magnitude to – Vout magnitude shall be between the limits: 

0.98  |+Vout| / |- Vout|  1.02 

100BASE-TX 
Rise and Fall 

Time 

 
Purpose: 

To verify that the response times of the DUT are within the conformance limits. 

Reference to Standard: 

Subclause 9.1.6 of ANSI X3.263-1995 

What Standard says:  

Active Output Interface (AOI) rise and fall time shall be in the range of 3.0 ns 
and 5.0 ns. Rise and fall times are defined as time difference between 10% and 
90% voltage levels. Both positive and negative rise/fall times should be 
validated. 

The difference between the maximum and the minimum of all measured rise and 
fall times should be less than 0.5 ns. 

100BASE-TX 
Waveform 
Overshoot 

 
Purpose: 

To verify that the waveform overshoot of the DUT is below the conformance 
limit. 

Reference to the Standard: 

Subclause 9.1.3 of ANSI X3.263-1995 

What the Standard says: 

According to standard, Overshoot is the percentage excursion of the differential 
signal transition beyond Vout. Differential signal overshoot should not exceed 5%. 
Both positive and negative overshoot are to be measured. 
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100BASE-TX 
Jitter 

 
Purpose: 

To verify that the peak-to-peak jitter of the DUT is within the conformance 
limits. 

Reference to the Standard: 

Subclause 9.1.9 of ANSI X3.263-1995 

What the Standard says:  

According to standard, the peak-to-peak jitter should not exceed 1.4 ns. 

100BASE-TX 
Duty Cycle 
Distortion 

 
Purpose:  

To verify that the duty cycle distortion of the DUT is below the conformance 
limit. 

Reference to the Standard: 

Subclause 9.1.8 of ANSI X3.263-1995 

What the Standard says:  

According to standard, duty cycle distortion should be measured at the 50% 
voltage points on rise and fall transitions of the differential output waveform and 
should not exceed ±0.25 ns. 

100BASE-TX 
Return Loss 

 
Purpose:  

To verify that the return loss at the transmitter or receiver of the device under test 
(DUT) is above the conformance limit.  

Reference to Standard:  

Subclause 9.1.5 and 9.2.2 of ANSI X3.263-1995 

What Standard says:  

Greater than 16 dB from 2 MHz to 30 MHz 

Greater than (16–20log(f/30 MHz)) dB from 30 MHz to 60 MHz 

Greater than 10 dB from 60 MHz to 80 MHz 
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10BASE-T/10BASE-Te 

10BASE-
T/10BASE-Te 

MAU Ext 

 
Purpose: 

To verify that the transmitter output equalization meets standard specifications. 

Reference to Standard: 

Subclause 14.3.1.2.1 of IEEE standard 802.3-2002 (for 10BASE-Te, refer to 
IEEE standard 802.3az) 
 

What Standard says: 

According to standard, the transmitter waveform should lie within the template 
for all data sequences at the twisted-pair model’s output with 100 Ohm 
termination. 

 

10BASE-
T/10BASE-Te 

MAU Int 

 
Purpose: 

To verify that the transmitter output equalization meets standard specifications. 

Reference to Standard: 

Subclause 14.3.1.2.1 of IEEE standard 802.3-2002 (for 10BASE-Te, refer to 
IEEE standard 802.3az) 
 

What Standard says: 

According to standard, the transmitter waveform should lie within the template 
for all data sequences at the twisted-pair model’s output with 100 Ohm 
termination. 

10BASE-
T/10BASE-Te 

TP_IDL 

 
Purpose: 

To verify that the transmitter functions properly after a transition to the idle state. 

Reference to Standard: 

Subclause 14.3.1.2.1 of IEEE standard 802.3-2002 (for 10BASE-Te, refer to 
IEEE standard 802.3az) 
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What Standard says: 

According to standard, the TP_IDL pulse should lie within the template. This test 
shall be done across each of the specified test loading Load 1, Load 2, and  
Load 3 with and without twisted-pair model. 

10BASE-T 
Link Pulse 

 
Purpose: 

To verify that the link test pulse waveforms meet specification. 

Reference to Standard: 

Subclause 14.3.1.2.1 of IEEE standard 802.3-2002 

What Standard says: 

According to standard, the link test pulse should lie within the template. This test 
shall be done across each of the specified test loading Load 1, Load 2, and  
Load 3 with and without twisted-pair model. 

 

10BASE-
T/10BASE-Te 

Differential 
Voltage 

 
Purpose: 

To verify that the differential voltage of the DUT is within the conformance 
limits. 

Reference to Standard: 

Subclause 14.3.1.2.1 of IEEE standard 802.3-2002 (for 10BASE-Te, refer to 
IEEE standard 802.3az) 
 
What Standard says: 

Peak differential voltage of transmitter waveform when terminated with a  
100 Ohm resistor should lie between 2.2 V and 2.8 V for all data sequences. 

Note: For 10BASE-Te, the peak differential voltage of transmitter waveform 
when terminated with a 100 Ohm resistor should lie between 1.54 V and  
1.96 V for all data sequences. 
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10BASE-
T/10BASE-Te 

Harmonic 

 
Purpose: 

To verify that the harmonic content of the DUT is within the conformance limits. 

Reference to Standard: 

Subclause 14.3.1.2.1 of IEEE standard 802.3-2002 (for 10BASE-Te, refer to 
IEEE standard 802.3az) 
 

What Standard says: 

Harmonic test is done when the DO circuit is driven by all ones. Each harmonic 
measured at the output of the transmitter shall be at least 27 dB below the 
fundamental. 

 

10BASE-T 
Jitter 

 
Purpose: 

To verify that the jitter of the DUT is within the conformance limits. 

Reference to Standard: 

Subclause 14.3.1.2.3 of IEEE standard 802.3-2002 
Annexure B.4.3.3 Note for 14.3.1.2.3 of IEEE standard 802.3-2002 

What Standard says:  

The transmitter output jitter when measured at the output of the twisted-pair 
model should lie within ±5.5 ns.  
As per B.4.3.3 Note for 14.3.1.2.3 of IEEE standard 802.3-2002, failure of this 
test does not demonstrate noncompliance. 

The transmitter output jitter when measured without the twisted-pair model 
should lie within ±8.0 ns. 

10BASE-T  
CM Voltage 

 
Purpose:  

To verify that the common-mode voltage of the DUT is within the conformance 
limits. 

Reference to Standard:  

Subclause 14.3.1.2.5 of IEEE standard 802.3-2002 
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What Standard says:  

The magnitude of the total common-mode output voltage of the transmitter, Ecm, 
shall be less than 50 mV peak. 

 

10BASE-T 
Return Loss 

 
Purpose:  

To verify that the return loss at the transmitter or receiver of the device under test 
(DUT) is above the conformance limit.  

Reference to Standard:  

Subclause 14.3.1.2.2 of IEEE standard 802.3-2002 ab 

What Standard says:  

At least 15 dB over the frequency range of 5.0 to 10 MHz. 
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Remote GPIB 

About Remote GPIB 
To enable Remote GPIB, click Utilities > Enable Remote GPIB. 

With knowledge of the GPIB command syntax, you can design a GPIB program 
to do the following tasks: 

 Start the TDSET3 application 

 Recall the saved setup, either default or the user defined 

 Select the technology (speed) and the test 

 Configure test parameters 

 Run the test 

 Retrieve the results for the conducted tests 

 Generate reports 

 Save the current setup 

 Exit the application 

Starting and Setting Up the Application Using GPIB 
 

To start the TDSET3 application, you must send the oscilloscope the following 
GPIB command: 

application:activate "Ethernet Compliance Test 
Software" 

The application uses the GPIB VARIABLE:VALUE command with arguments 
to execute the supported features. 

You must continually query for application status. If the status indicates GPIB 
disabled, you must manually enable Remote GPIB by clicking  
Utilities > Enable Remote GPIB. 
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GPIB Command Syntax 
Description 

This command accepts string arguments for a control or data variable and a value 
to which to set the argument.  

Syntax 

VARIABLE:VALUE "<variable name>","<variable value>" 

Note: 

The arguments <variable name> and <variable value> are required in the order 
indicated. 

VARIABLE:VALUE? <variable name> for query. 

Note. Commands are case and space sensitive. All variables and values 
supported by the application are in lower case and without any spaces in 
between characters. 

TDSET3 Application Command Arguments and Queries 

Table 17-1: Command arguments and queries  
Group / Name Value Function Query returns 
Application 
recall The setup file name which consists 

of any string from 1 to 40 characters 
from A to Z and, or 0 to 9 or special 
characters like “.” or “default”. 
"default" refers to the default file 
name. If file extension not specified, 
it is assumed to be .ini. 

Recalls the settings for the 
application from the mentioned file. 
The directory location of the file is 
the default 
(C:\TekApplications\TDSET3\setup. 
If the file does not have appropriate 
setting values, the default settings 
will override the same. 

Query is not valid. 

save The setup file name, which consists 
of any string from 1 to 40 characters 
from A to Z and, or 0 to 9 or special 
characters like “.” If file extension 
not specified, it is assumed to be 
.ini. 

Saves the current application 
settings in the file name specified. 
The directory location of the file is 
the default (C:\TekApplications\ 
TDSET3\setup. 

Query is not valid. 
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Table 17-1: Command arguments and queries (cont) 
Group / Name Value Function Query returns 
application exitwrecall, exitworecall Exits the application. The value of application variable. 
application Minimize Minimizes the active application. The value of application variable. 
application Hide Hides the active application The value of application variable. 
application Maximize Maximizes the active application The value of application variable. 
application Show Shows the application, which was 

earlier hidden. 
The value of application variable. 

version Query only  The version number of the application. 
Speed 
speed 1000-T, 100-TX, 10-T Sets the speed The value of the set speed. 
run {on, off}*** Runs the previously selected test if 

value is ON. 
Stops the currently running test, if 
any, if the value is OFF. 

The value of test variable, on, off. 

Results and Status 
getremblk {n}**** where n >= 1 and n <= the 

value returned on querying for 
“remcounter” 

Updates “resultrem” with the remark 
block asked for. Please read the 
note on Retrieving Remarks for 
further details. 

 

processdone 
 

{no}** Indicates that a set command 
follows. Please read note on 
processdone command for further 
details. 

 

resultsum Query only  The summary of the last test 
conducted, pass, fail. 

resultstd Query only  Standard field of the result details, for 
the test queried. 

resultmeas Query only  Measured field of the result details, for 
the test queried. 

resultsts Query only  Status field of the result details, for the 
test queried. 

resultrem {Query only}****  Remark field of the result details, for 
the test queried. 

remcounter 
 

{Query only}****  Count of remarks block available for 
the last test run. 

Status***** Query only  Returns the error code or “Test 
Stopped”, “Test running”, ”Test 
Complete”, “Change Mode Required” 
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Table 17-1: Command arguments and queries (cont) 
Group / Name Value Function Query returns 
report summary, detail Invokes the report generation, 

summary or detailed. 
Query not valid. 

repname The setup file name, which consists 
of any string from 1 to 40 characters 
from A to Z and/or 0 to 9 or special 
characters like “.” 

During the next report generation, 
the application uses the layout in 
this file.  

Note: Create a layout file manually 
before using the command. 
 

The file name of the report layout file. 

deviceid Any string from 1 to 40 characters 
from A to Z and/or 0 to 9 with valid 
Windows, Dos format. 

Specifies the device ID field for 
report generation. This field is 
visible in several locations 
throughout the application 
independent of the report 
generations panel. Default setting is 
set to “ ” 1 space character. 

The specified device ID. Applies to 
Compliance modules. 

portid Any printable character from the 
keyboard. 

Sets the Port id. The value of port id. 

reppairid Any printable character from the 
keyboard. 

Sets the report pair id. The report pair id. 

devicedetails Any printable character from the 
keyboard. 

Sets the devicedetails parameter. The device details. 

process Any printable character from the 
keyboard. 

Sets the value for the process. The value of process. 

volt Any printable character from the 
keyboard. 

Sets the value for the voltage report 
config. 

The value of voltage. 

temp Any printable character from the 
keyboard. 

Sets the value for the temperature 
report config. 

The value of temparature. 

lastcaldate Any printable character from the 
keyboard. 

Sets the last calibration date. The last calibration date. 

imgport {true,false} Sets the image export. The status of image export. 
lastrepdet Query only  The last saved (detailed) report file 

name. 
lastrepsum Query only  The last saved (summary) report file 

name. 
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Table 17-1: Command arguments and queries (cont) 
Group / Name Value Function Query returns 
1000Base-T test values for "resultfor" variable 
resultfor templatea, templateb, templatec, 

templated, templatef, templateh, 
peaka, peakb, peakc, peakd, 
droopg, droopj, jitmasterfilt, 
jitmasterunfilt, jitslavefilt, 
jitslaveunfilt, distortionm, 
returnloss1000, cmvolt1000 

Sets the result variables with 
appropriate result values for that 
particular test. 

 

100Base-TX test values for "resultfor" variable 
resultfor templatepos, templateneg, 

outputvoltpos, outputvoltneg, 
ampsym, risetimepos, risetimeneg, 
falltimepos, falltimeneg, rfsympos, 
rfsymneg, rfsymmaxmin, 
overshootpos, overshootneg, jitpos, 
jitneg, dcdrand, dcd0101, 
returnlosstx100, returnlossrx100 

Sets the result variables with 
appropriate result values for that 
particular test. 

 
 
 
 
 
 
 

10Base-T test values for "resultfor" variable 
resultfor 
 

maunorm, mauinv, lpload1wotpm, 
lpload2wotpm, lp100wotpm, 
lpload1wtpm, lpload2wtpm, 
lp100wtpm, lptiming, 
tpidlload1wotpm, tpidlload2wotpm, 
tpidl100wotpm, tpidlload1wtpm, 
tpidlload2wtpm, tpidl100wtpm, 
diffvoltmaxpos, diffvoltmaxneg, 
diffvoltpos, diffvoltneg, harmonic, 
jitwcablenorm, jitwcable8bt, 
jitwcable85bt, jitwocablenorm, 
jitwocable8bt, jitwocable85bt, 
returnlosstx10, returnlossrx10, 
cmvolt10 

Sets the result variables with 
appropriate result values for that 
particular test. 

 

harmonicres0 Query only  Harmonic test’s result measured. 
Measured results from Harmonic2 to 
Harmonic5 can be got from this 
variable. 

harmonicres1 Query only  Harmonic test’s result measured. 
Measured results from Harmonic6 to 
Harmonic9 can be got from this 
variable. 
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Table 17-1: Command arguments and queries (cont) 
Group / Name Value Function Query returns 
harmonicres2 Query only  Harmonic test’s result measured. 

Measured results from Harmonic10 to 
Harmonic13 can be got from this 
variable. 

harmonicres3 Query only  Harmonic test’s result measured. 
Measured results from Harmonic14 to 
Harmonic17 can be got from this 
variable. 

harmonicres4 Query only  Harmonic test’s result measured. 
Measured results from Harmonic18 to 
Harmonic21 can be got from this 
variable. 

harmonicres5 Query only  Harmonic test’s result measured. 
Measured results from Harmonic22 to 
Harmonic25 can be got from this 
variable. 
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**Note on processdone command: 
 
Set commands are of the format variable:value “<variable_name>”,”<value>” 
Get or query commands are of the format variable:value? “<variable_name>” 
For TDSET3 versions later than 1.3.1, BEFORE every remote GPIB SET 
command , you must send <variable:value “processdone”,”no”> and AFTER 
every set command, you have to wait on "processdone" variable until it returns a 
“yes”, that is, you have to keep polling for <Variable:value? “processdone”> 
and only after it returns a “yes”, the next command, either set or get can be sent. 
 
Please ensure that this order is followed for the command script to work 
correctly. A sample script is listed here. It recalls a default setting, selects 
TemplatePeakall test, runs the test, and query the result measured for peaka test.  
variable:value “processdone”,”no” 
 variable:value “recall”,”default” 
variable:value? “processdone” 
“no” 
…..keep polling until it returns a yes 
variable:value? “processdone” 
“yes” 
variable:value “processdone”,”no” 
variable:value test”,”templatepeakall” 
variable:value? “processdone” 
“no” 
…..keep polling until it returns a “yes” 
variable:value? “processdone” 
“yes” 
variable:value “processdone”,”no” 
variable:value run”,”on” 
variable:value? “processdone” 
“no” 
…..keep polling until it returns a “yes” 
variable:value? “processdone” 
“yes” 
variable:value“processdone”,”no” 
variable:value “resultfor”,”peaka” 
variable:value? “processdone” 
“no” 
…..keep polling until it returns a “yes” 
variable:value? “processdone” 
“yes” 
variable:value? “resultmeas” 
 
*** Note on run command : 
 
After issuing a run command , you should wait for processdone command to 
return a “yes” and then query the“status”. Once the status returns “Test 
Complete” then query for the result details. 
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Sometimes after the run command is issued and if the processdone command 
returns a “yes”, the test may not be complete. The test could be stopped because 
of an error condition that caused the TDSET3 application to terminate the run 
operation and indicate processdone as “yes”. Thus it is advisable to always wait 
on “processdone” before looking for results and ensure that the test is complete 
to query the status. If status returned does not indicate any error or test stopped, 
but that the test is complete then query for results. 
 
****Note on Retrieving Remarks: 
 
Result remarks for some tests is lengthy and can not be retrieved by one query. 
Thus use the following code to retrieve all the remark blocks. 
Each block is one chunk of remarks data. 
variable:value? “remcounter” 
“4” 
//Returns the number of remark blocks available. This indicates there are four 
blocks of remarks for the last test run. If you want to retrieve first and second 
block of remarks, the following list of commands need to be sent. 
Variable:value “processdone”,”no” 
variable:value “getremblk”,”1” 
//On receiving this command TDSET3 fills “resultrem” with the first block of 
remarks.Wait on “processdone” to return “yes”, then query for result remarks. 
variable:value? “processdone” 
“yes” 
variable:value? “resultrem” 
"RMS = 1.48mV   SNR = 53.59dB 
Peak Distortion at symbol 1188 = - 5.427mV 
Peak Distortion at symbol 1863 = + 4.855mV 
Peak Disto" 
//this will return the first block of remarks data. 
variable:value “processdone”,”no” 
variable:value “getremblk”,”2” 
//On receiving this command TDSET3 fills “resultrem” with the second block of 
remarks 
variable:value? “processdone” 
“yes” 
variable:value? “resultrem” 
"rtion at symbol 222 = - 4.785mV 
TX_TCLK Freq = 125.0MHZ 
TX_TCLK ppm = 0.000006% [0.057 ppm] 
DC Offset Measured = -15.39mV" 
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*****Note : 

If any of the following tests are run through remote GPIB, 

<Variable:value "run", "on" > starts the test run. The "Status" indicates "Test 
running". 

When the "status" indicates "Change Mode Required", the application waits until 
you switch the test mode and indicate the same by sending the command 

<variable:value "changetestmode","OK"> or <variable:value 
"changetestmode","cancel">. 

If the changetestmode is OK, the test continues and the "Status" indicates "Test 
Running". At the end of the test, results are available in the result field.  

If changetestmode is "Cancel", the test is stopped, and the status is updated to 

indicate error. 

This waiting on changetestmode applies only to the following Jitter tests: 

Master filtered Jitter with TXT_CLK  

Slave filtered Jitter with TXT_CLK 

Slave filtered Jitter without TXT CLK 

Slave unfiltered Jitter without TXT_CK for both TIE and Histogram option 
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GPIB Commands for 1000BASE-T 

Table 17-2: 1000BASE-T GPIB commands  
Group / Name Value Function Query returns 
Selecting test parameters for 1000BASE-T 
test templatea, templateb, 

templatec, templated, 
templatef, templateh 

Selects the template test. The value of test variable. 

test peaka, peakb, peakc, 
peakd 

Selects the peak volt test. The value of test variable. 

test Templatepeakall Selects all the template and peak volt tests. The value of test variable. 
test droopg, droopj, droopall Selects the droop test. The value of test variable. 
test Jitmasterfilt**, 

jitmasterunfilt** 
Selects the jitter master test. The value of test variable. 

test Jitslavefilt**, jitslaveunfilt** Selects the jitter slave test. The value of test variable. 
test Distortion Selects the distortion test. The value of test variable. 
test returnloss1000 Select the return loss test. The value of test variable. 
test cmvolt1000 Select the CM voltage test. The value of test variable. 
    
Configuring test parameters for 1000BASE-T 
avgs:1000 n >= 64 and n <= 10,000 Configures the number of averages for 

template peak, and droop. 
The number of averages. 

avgs4distortion n >= 64 and n <= 10,000 Configuring the number of averages 
distortion 1000Base-T test. 

The number of averages set for 
distortion test. 

clkedge rising/falling Configures the clock edge for jitter tests. The type of clock edge - rising or 
falling. 

data:1000 {ch1/ch2/ch3/ch4}* Configures the source data for template, 
peak, droop, jitter, distortion, and cmvoltage 
tests. 

The channel chosen for source data. 

disturber yes/no Configures the disturber for template, peak, 
droop and distortion tests. 

The status indicating if the disturber is 
included or not. 

filter int/ext Configures the filter - internal or external - 
for template, and peak tests. 

The type of the filter used, either 
internal or external. 

masterclk {ch1/ch2 /ch3/ch4}* Configures the master clock for jitter 
1000Base-T test. 

The value of the channel chosen for 
master clock. 

meastype TIE/Histogram Configures the measure type for unfiltered 
jitter test. 

The measure type. 

slaveclk {ch1/ch2/ch3/ch4}* Configures the slave clock for jitter slave 
test. 

The value of the channel chosen for 
slave clock. 

output:1000 {ref1/ref2/ ref3/ref4}* Configures the output for template, peak, 
droop and distortion tests. 

The channel chosen for output. 
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Table 17-2: 1000BASE-T GPIB commands (cont) 
Group / Name Value Function Query returns 
reclen 100K, 1 Meg, 4 Meg,  

7.5 Meg, 8 Meg, 10 Meg,  
16 Meg, 20 Meg 

Configuring the record length for jitter tests 
in 1000Base-T. This is not present for 
unfiltered jitter test with measurement type 
set to Histogram. Default value is max 
memory available on the Oscilloscope. 

The value of record length previously 
set. 

resolution n >= 2 and n <= 75 Configuring the resolution for the distortion 
test in 1000Base-T. 

The value of the resolution previously 
set. 

txtclksrc {ch1, ch2, ch3, ch4}* Configuring the clock, when distortion test is 
selected and distclk is set to yes, for 
1000Base-T. 

The channel chosen for txtclock 
source. 

txtclk yes, no The status indicating if txtclk is included or 
not. 

The status indicating if txtclk is 
included or not 

distclk yes, no The status indicating if the clock is included 
or not. 

The status indicating if the disturber is 
included or not. 

lpfilter yes, no Status of the Low Pass filter for distortion 
tests. 

The status of the Low Pass filter for 
distortion tests. 

jitterlpfilter yes/no Status of the Jitter Low Pass filter for jitter 
tests. 

Status of the Jitter Low Pass filter for 
jitter tests. 

rlsrc1:1000 {ch1, ch2, ch3, ch4}* Configuring the sources P1/P3/P5/P7 for the 
return loss test in 1000Base-T. 

The value of the source1 for return 
loss. 

rlsrc2:1000 {ch1, ch2, ch3, ch4}* Configuring the sources P2/P4/P6/P8 for the 
return loss test in 1000Base T. 

The value of the source2 for return 
loss. 

rloutput:1000 {ref1, ref2, ref3, ref4}* Configuring the source for the return loss 
test in 1000Base-T. 

The value of the return loss for output 
waveform. 

rllimit:1000 {ref1, ref2, ref3, ref4}* Configuring the source for the return loss 
test in 1000Base-T. 

The value of the limit for output 
waveform of return loss. 

avgtime:1000 n >= 100 and n <= 10,000 Configuring the average time for return loss 
test for 1000Base-T. 

The value of average time. 

smooth:1000 n >= 00 and n <= 10 Configuring the average frequency for return 
loss test for 1000Base-T. 

The value of average frequency. 

pairid a, b, c, d Configuring the pair id for return loss test for 
1000Base -T. 

The value of the pair id previously set. 

load:1000 "load85/100/115","load100" Configuring the load parameter for return 
loss test in 1000Base-T. 

The value of the load parameter. 

awg:1000 {awgselect,awg4xx/awg20
21/awg5xx/awg6xx/awg7xx
/awg5xxx/awg7xxx/afg3xxx 
} 

Configure the AWG/AFG being used for 
1000Base-T return loss tests. 

The AWG/AFG series being used for 
1000Base-T return loss test. 

datatm2 {ch1, ch2, ch3, ch4}* Configuring the data test mode 2 source for 
the jitter test in 1000Base -T. 

The value of the test mode 2 source 
for jiiter test. 

datatm3 {ch1, ch2, ch3, ch4}* Configuring the data test mode 3 source for 
the jitter test in 1000Base-T. 

The value of the test mode 3 source 
for jiiter test. 

hysteresis {n} n >= 5.0 and n <= 30.0 Configuring the hysteresis value for jitter 
1000Base-T tests. 

The value of hysteresis for jitter tests. 
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Table 17-2: 1000BASE-T GPIB commands (cont) 
Group / Name Value Function Query returns 
Jig Match 
jmmeas jmdistall, jmdutamp, 

jmprobeamp 
Measure the jig match parameters. Query not valid. 

jmdef jmdistall, jmdutamp, 
jmprobeamp 

Set the jig match parameters to default. Query not valid. 

jmlastjm Query only  The last jig match parameter 
measured. 

jmamp Query only  The value of the amp. 
jmfreq Query only  The value of the freq. 
jmdutamp Query only  The value of the DUT amp. 
jmprobeamp Query only  The value of the probe point amp. 
jmatten Query only  The value of the atten. 
jmstatus Query only  The Jig Match status, either 

jmon/jmoff. ON indicates jig match 
measure is in progress. 

jmaction jmapply, jmcancel  Applies the measured values or 
cancels the same. 

Change test mode 
Changetest 
mode** 

ok, cancel Indicates the jitter test run to continue  

 

*Note on channel selections:  
Channel 3 and Channel 4 can be chosen only on a 4-channel oscilloscope. 
Ref 3 and Ref4 can be chosen only on a 4-channel oscilloscope. 
Math3 and Math4 can be chosen only on a 4-channel oscilloscope. 
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**Note:  
If any of the following tests are run through remote GPIB, 

<Variable:value "run", "on" > starts the test run. The "Status" indicates "Test 
running". 

When the "status" indicates "Change Mode Required", the application waits until 
you switch the test mode and indicate the same by sending the command 

<variable:value "changetestmode","OK"> or <variable:value 
"changetestmode","cancel">. If the changetestmode is OK, the test continues and 
the "Status" indicates "TestRunning".At the end of the test, results are available 
in the result field.  

If changetestmode is "Cancel", the test is stopped, and the status is updated to 

indicate error. 

This waiting on changetestmode applies only to the following Jitter tests: 

Master filtered Jitter with TXT_CLK  

Slave filtered Jitter with TXT_CLK 

Slave filtered Jitter without TXT CLK 

Slave unfiltered Jitter without TXT_CK for both TIE and Histogram option.  

GPIB Commands for 100BASE-TX 

Table 17-3: 100BASE-TX GPIB commands  
Group / Name Value Function Query returns 
Selecting test parameters for 100BASE-TX 
test template, templatepos, 

templateneg  
Selects the template test and the polarity. The value of test variable. 

test outputvoltboth, 
outputvoltpos, 
outputvoltneg  

Selects the output volt test and the polarity. The value of test variable. 

test ampsym  Selects the amp sym test. The value of test variable. 
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Table 17-3: 100BASE-TX GPIB commands (cont)  
Group / Name Value Function Query returns 
test risetimeboth, risetimepos, 

risetimeneg 
Selects the rise time test and the polarity. The value of test variable. 

test falltimeboth, falltimepos, 
falltimeneg 

Selects the fall time test and the polarity. The value of test variable. 

test rfsymboth, rfsympos, 
rfsymneg 

Selects the rfsym test, with the polarity. The value of test variable. 

test overshootboth, 
overshootpos, 
overshootneg  

Selects the overshoot test, with the polarity. The value of test variable. 

test jitboth, jitpos, jitneg  Selects the jitter test and the polarity. The value of test variable. 
test dcdrand, dcd0101  Selects the distortion test and pattern 

values. 
The value of test variable. 

test all  Selects all the 100Base-Tx tests with polarity 
as “both” and pattern as “random”. 

The value of test variable. 

test returnlosstx100, 
returnlossrx100  

Select the return loss test. The value of test variable. 

Configuring test parameters for 100BASE-TX 
acq:100 sample, avg  Configures the acquisition to sample or 

average for all 100Base-Tx tests except 
template and jitter. 

The type of acquisition. 

data:100 {ch1, ch2, ch3, ch4 }* Configures the source data for tests. The channel chosen for source data. 
pulsewidth 16, 80  Configures the pulse width for rise, fall time 

test, R/F sym test. 
The pulse width value. 

maskscale norm,0.95,1.05  Configuring the template scale for template 
tests of 100Base-Tx. 

The value of template scale. 

rlsrc1:100 {ch1, ch2, ch3, ch4}* Configuring the sources P1, P3 for the return 
loss test in 100Base-Tx. 

The value of the source1 for return 
loss. 

rlsrc2:100 
 

{ch1, ch2, ch3, ch4}* Configuring the sources P2, P4 for the return 
loss test in 100Base-Tx. 

The value of the source2 for return 
loss. 

rloutput:100 {ref1, ref2, ref3, ref4}* Configuring the source for the return loss 
test in 100Base-Tx. 

The value of the return loss for output 
waveform. 

rllimit:100 {ef1, ref2, ref3, ref4}* Configuring the source for the return loss 
test in 100Base-Tx. 

The value of the limit for output 
waveform of return loss. 

avgtime:100 n >= 100 and n <= 10,000 Configuring the average time for return loss 
test for 100Base-Tx. 

The value of average time. 

smooth:100 n >= 0 and n <= 10 Configuring the average frequency for return 
loss test for 100Base-Tx. 

The value of average frequency. 

load:100 "load85, 100, 
115","load100"  

Configuring the load parameter for return 
loss test in 100Base-Tx. 

The value of the load parameter. 
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Table 17-3: 100BASE-TX GPIB commands (cont)  
Group / Name Value Function Query returns 
awg:100 awg4xx, awg2021, 

awg5xx, awg6xx, awg7xx, 
awg5xxx, awg7xxx, 
afg3xxx 

Configure the AWG/AFG being used for 
100Base-Tx return loss tests. 

The AWG/AFG series being used for 
100Base-Tx return loss test. 

 

 

The following oscilloscope commands can be used to set or query the number of 
waveforms, horizontal position, and vertical position for 100Base-Tx tests. 

Table 17-4: Oscillscope GPIB commands for 100Base-Tx 
Group / Name Value Function Query returns 
ACQuire:NUMAVg x x >= 2 and x <= 10,000 

 
Sets the number of waveforms for 
100Base-Tx. 

 

ACQuire:NUMAVg ?  Queries the number of waveforms for 
100Base-Tx. 

The number of waveforms. 
 

HORIZONTAL:POSITION x x >= 0 and x <= 99.9 
 

Sets the horizontal position for 100 
BaseTx. 

 

HORIZONTAL:POSITION ?  Queries the horizontal position for 
100Base-Tx. 

The value of the horizontal position. 

CHx:POSITION y x >= 1 and x <= 4 
y >= 0.0 and y <= 5.00 

Sets the vertical position for the 
selected channel for 100Base-Tx. 

 

CHx:POSITION ?  Queries the vertical position for the 
selected channel for 100Base-Tx. 

The value of the vertical position for 
the selected channel. 

 

*Note on channel selections:  
Channel 3 and Channel 4 can be chosen only on a 4-channel oscilloscope. 
Ref 3 and Ref4 can be chosen only on a 4-channel oscilloscope. 
Math3 and Math4 can be chosen only on a 4-channel oscilloscope. 
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GPIB Commands for 10BASE-T/10BASE-Te 

Table 17-5: 10BASE-T/10BASE-Te GPIB commands  
Group / Name Value Function Query returns 
Selecting test parameters for 10BASE-T 
test mauboth, maunorm, 

mauinv  
Selects the mau test with both, normal or 
inverted. 

The value of test variable. 

test 
 

lpload1wotpm, 
lpload2wotpm, 
lp100wotpm, lpload1wtpm, 
lpload2wtpm, lp100wtpm  

Selects the link pulse with load test. The value of test variable. 

test 
 

tpidlload1wotpm, 
tpidlload2wotpm, 
tpidl100wotpm, 
tpidlload1wtpm, 
tpidlload2wtpm, 
tpidl100wtpm  

Selects the tp idl with load test. The value of test variable. 

test diffvoltmax, diffvoltall Selects the diff volt test. The value of test variable. 
test harmonic  Selects the harmonic test. The value of test variable. 
test 
 

jitwcableall, jitwcablenorm, 
jitwcable8bt, jitwcable85bt, 
jitwocableall, 
jitwocablenorm, 
jitwocable8bt, 
jitwocable85bt  

Selects the jitter test, with or without cable. The value of test variable. 

test 
 

returnlosstx10, 
returnlossrx10  

Select the return loss test. The value of test variable. 

test cmvolt10  Select the CM voltage test. The value of test variable. 
Configuring test parameters for 10BASE-T/10BASE-Te 
acq:10 sample, avg  Configures the acquisition to sample or 

average for link pulse and tp_idl tests. 
The type of acquisition. 

avgs:10 n >= 2 and n <= 10,00,000 Configures the number of averages for 
harmonic test. 

The number of averages. 

data:10 {ch1, ch2, ch3, ch4}* Configures the source data. The channel chosen for source data. 
masksel both, head, tail  Configures the mask selection section for 

link pulse or TP_IDL tests. 
The mask selection. 

mauscale norm, 0.9, 1.1  Configures the MAU scale for MAU template 
test. 

The mau scale value, either normal, 
0.9, or 1.1. 
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Table 17-5: 10BASE-T/10BASE-Te GPIB commands (cont)  
Group / Name Value Function Query returns 
mautype int, ext  Configures the mau type for jitter with, 

without cable (parameteric) and MAU 
(template) tests. 

The MAU type, either internal or 
external. 

timescale 10, 1  Configures the time scale for harmonic test. The time scale value. 
linkseq norm, fast  Configuring the sequence for Link Pulse test 

in 10Base-T. 
The type of sequencing. 

testoptions both, template, timing Configuring the test options for the link pulse 
test in 10Base-T. 

The test option chosen for the link 
pulse test. 

output:10 {math1, math2,  math3, 
math4}* 

Configures the output for harmonic test. The channel chosen for output. 

rlsrc1:10 {ch1, ch2, ch3, ch4}* Configuring the sources P1, P3 for the return 
loss test in 10Base -T. 

The value of the source1 for return 
loss. 

rlsrc2:10 {ch1, ch2, ch3, ch}* Configuring the sources P2, P4 for the return 
loss test in 10Base -T. 

The value of the source2 for return 
loss. 

rloutput:10 {ref1, ref2, ref3, ref4}* Configuring the source for the return loss 
test in 10Base-T. 

The value of the return loss for output 
waveform. 

rllimit:10 {ref1, ref2, ref3, ref4}* Configuring the source for the return loss 
test in 10Base-T. 

The value of the limit for output 
waveform of return loss. 

avgtime:10 n >= 100 and n <= 10,000 Configuring the average time for return loss 
test for 10Base-T. 

The value of average time. 

smooth:10 n >= 0 and n <= 10 Configuring the average frequency for return 
loss test for 10Base -T. 

The value of average frequency. 

load:10 "load85, 100, 115", 
"load100"  

Configuring the load parameter for return 
loss test in 10Base-T. 

The value of the load parameter. 

awg:10 awg4xx, awg2021, 
awg5xx, awg6xx, awg7xx, 
awg5xxx, awg7xxx, 
afg3xxx 

Configure the AWG/AFG being used for 
10Base-T return loss tests. 

The AWG/AFG series being used for 
10Base-T return loss test. 

ee yes, no 
 

Configure the test to run either in energy 
efficient mode or not. 
 

Returns a value indicating that the test 
mode is set either to energy efficient 
(Yes) or not (No). 

 

Note: The 802.3az document includes the changes required to enable the Energy 
Efficient Ethernet (EEE) operation for many existing physical layers. One of the 
supported operations is twisted pair cabling. The PHY supports 100Base-TX, 
1000Base T, 10Base-T, and other technologies. In addition to that EEE defines 
reduced amplitude operation for 10Base-T which is called 10BASE-Te. All the 
measurements of 100Base-TX and 1000Base T, and some of the measurements of 
10Base-T are not affected when performing the 10BASE-Te measurements. The 
10Base-T measurements that support the PHY tests for 10BASE-Te are modified 
with a separate configuration to select and perform.  
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The following oscilloscope commands can be used to set or query the number of 
waveforms, fail threshold, horizontal position, and vertical position for 10Base-T 
tests. 

Table 17-6: Oscillscope GPIB commands for 10BASE-T 
Group / Name Value Function Query returns 
ACQuire:NUMAVg x x >= 2 and x <= 10,000 

 
Sets the number of waveforms for 
10Base-T. 

 

ACQuire:NUMAVg ?  Queries the number of waveforms for 
10Base-T. 

The number of waveforms. 
 

MASK:TEST:THRESHOLD x x >= 1 and n <= 2147483647 Sets the fail threshold for 10Base-T.  
MASK:TEST:THRESHOLD ?  Queries the fail threshold for  

10Base-T. 
The value of the fail 
threshold. 

MASK:TEST:WAVEFORM x x >= 1 and n <= 2147483647 Sets the number of waveforms for 
10Base-T. 

 

MASK:TEST:WAVEFORM ?  Queries the number of waveforms for  
10Base-T. 

The number of waveforms. 

HORIZONTAL:POSITION x x >= 0 and x <= 99.9 
 

Sets the horizontal position for 
10Base-T. 

 

HORIZONTAL:POSITION ?  Queries the horizontal position for 
10Base-T. 

The value of the horizontal 
position. 

CHx:POSITION y x >= 1 and x <= 4 
y >= 0.0 and y <= 5.00 

Sets the vertical position for the 
selected channel for 10Base-T. 

 

CHx:POSITION ?  Queries the vertical position for the 
selected channel for 10Base-T. 

The value of the vertical 
position for the selected 
channel. 

 

*Note on channel selections:  
Channel 3 and Channel 4 can be chosen only on a 4-channel oscilloscope. 
Ref 3 and Ref4 can be chosen only on a 4-channel oscilloscope. 
Math3 and Math4 can be chosen only on a 4-channel oscilloscope. 
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GPIB Commands for AWG/AFG Automation 

Table 17-7: AWG/AFG Automation GPIB commands  
Group / Name Value Function Query returns 
AWG/AFG Automation 
automate gpib, manual Sets the AWG/AFG automation to GPIB 

mode or manual mode. 
The current mode of automation. 

boardtype GPIB0, GPIB1, GPIB2, 
GPIB3, GPIB4, GPIB5, 
GPIB6, GPIB7, GPIB8, 
GPIB9 

Sets the GPIB board type to the specified 
value. This will be used if the AWG/AFG is 
automated. 

The board type being used for 
automation of AWG/AFG. 

priaddr n, where n = 1 to 30 Sets the primary address to the specified 
value. This will be used if the AWG/AFG is 
automated. 

The primary address over which the 
oscilloscope talks to the AWG/AFG if 
the automation mode is GPIB. 

secaddr n, where n = 1 to 30 Sets the secondary address to the specified 
value. This will be used if the AWG/AFG is 
automated. 

The secondary address over which the 
oscilloscope talks to the AWG/AFG if 
the automation mode is GPIB. 

testconn start Initiates the connection testing process. No Query supported. 
“status” can be queried to know the 
result of test connection. 

Program Example 
The program example shows how to communicate to the TDSET3 application 
using remote GPIB commands. 

The oscilloscope hard disk and optional application compact disc both contain 
the file, DefaultRun.c. On the hard drive, the file resides in the 
C:\TekApplications\TDSET3\GPIBExamples directory. 

The Program Example shows how a GPIB program executes the application to 
do the following tasks: 

 Start the TDSET3 application 

 Run the test 

 Retrieve the results for the conducted tests 

 Recall the default setup 
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In this example, you will recall the default setup. You can use the File > Save 
function in the application to save setup files. 

#ifdef __cplusplus 

extern "C"{ 

#endif 

#include <windows.h> 

#include <stdio.h> 

#include <stdlib.h> 

#include "decl-32.h" 

#ifdef __cplusplus 

} 

#endif 

/* Forward Declarations */ 

int start_application(int Oscilloscope); 

int exit_application(int Oscilloscope); 

int recall_setup(int Oscilloscope, char* filename); 

int recall_defaultsetup(int Oscilloscope) ; 

int run_single_test (int Oscilloscope); 

void query_results(int Oscilloscope) ; 

void GPIBCleanup(int ud, char* ErrorMsg); 

// parameters needed to access the device driver handler 

#define BDINDEX 0 // Board Index 

#define PRIMARY_ADDR_OF_DMM 1 // Primary address of device 

#define NO_SECONDARY_ADDR 0 // Secondary address of device 

#define TIMEOUT T10s // Timeout value = 10 seconds 

#define EOTMODE 1 // Enable the END message 

#define EOSMODE 0 // Disable the EOS mode 
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#define APP_NOT_RUNNING -1 

#define RGPIB_ENABLED 1 

#define RGPIB_DISABLED 0 

char   ErrorMnemonic[21][5] = {"EDVR", "ECIC", "ENOL", "EADR", "EARG", 

"ESAC", "EABO", "ENEB", "EDMA", "", 

"EOIP", "ECAP", "EFSO", "", "EBUS", 

"ESTB", "ESRQ", "", "", "", "ETAB"}; 

/* 

* After each GPIB call, the application checks whether the call 

* succeeded. If an NI-488.2 call fails, the GPIB driver sets the 

* corresponding bit in the global status variable. If the call 

* failed, this procedure prints an error message, takes 

* the device offline and exits. 

*/ 

//-------------------------------------------------------------------------- 

int main() 

{ 

int Dev; 

char write_buffer[100]; 

int status; 

int nAppStatus = -1; 

Dev = ibdev (BDINDEX, PRIMARY_ADDR_OF_DMM, NO_SECONDARY_ADDR, 

TIMEOUT, EOTMODE, EOSMODE); 

if (ibsta & ERR) 

{ 

GPIBCleanup(Dev, "Unable to open device"); 

}  
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else  

{ 

printf("My device id - %i", Dev); 

} 

sprintf(write_buffer, "%s", "header off"); 

status = ibwrt(Dev, write_buffer, strlen(write_buffer)); 

nAppStatus = start_application(Dev); 

if ( nAppStatus  == RGPIB_ENABLED )  

{ 

printf("\nApplication started..\n"); 

} 

else if ( nAppStatus == RGPIB_DISABLED ) 

{ 

printf("\nRGPIB is disabled, please enable it and then press 
Enter to continue"); 

getchar(); 

} 

else if ( nAppStatus == APP_NOT_RUNNING ) 

{ 

exit_application(Dev); 

// leave the device back elegantly  

printf("Cleanup: Taking device offline\n"); 

ibonl(Dev, 0);  

exit(0); 

} 

run_single_test(Dev); 

printf("\nRun single test complete now..\n"); 
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query_results(Dev); 

printf("\nQuery results complete now..\n"); 

recall_defaultsetup(Dev); 

printf("\nRecall Default complete now..\n"); 

printf("Cleanup: Taking device offline\n"); 

ibonl(Dev, 0); 

 

printf("Press any key to exit this sample application..\n"); 

getchar(); 

} 

//-------------------------------------------------------------------------- 

/* Start Ethernet Compliance Test Software application 
*/ 

int start_application( int Oscilloscope )  

{ 

char write_buffer[100]; 

char read_buffer[100]; 

int status; 

int timer = 1; 

/* Start the application */ 

sprintf(write_buffer, "%s", "Application:activate \"Ethernet 
Compliance Test Software\""); 

status = ibwrt(scope, write_buffer, strlen(write_buffer)); 

if (ibsta & ERR) 

{ 

GPIBCleanup(scope, "Unable to start the application"); 

return 0; 

} 
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while (1)  

{ 

// Check whether application has started 

sprintf(write_buffer, "%s", "Variable:value? \"application\""); 

status = ibwrt(scope, write_buffer, strlen(write_buffer)); 

status = ibrd(scope, read_buffer, sizeof(read_buffer)); 

read_buffer[ibcnt] = '\0'; 

if ( strcmp(read_buffer,"\"GPIB Enabled\"\n") == 0 ) 

{ 

return RGPIB_ENABLED; 

} 

else if (strcmp(read_buffer,"\"GPIB Disabled\"\n") == 0 )  

{ 

return RGPIB_DISABLED; 

} 

timer++; 

if (timer >500)  

{ 

return 0; 

} 

Sleep(1000); 

} 

return APP_NOT_RUNNING;  

} 

//-------------------------------------------------------------------------- 

int exit_application(int Oscilloscope)  

{ 
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char write_buffer[100]; 

printf("Exit Application ..\n"); 

sprintf(write_buffer, "%s", "Variable:value 
\"application\",\"exitworecall\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

return 1; 

} 

//-------------------------------------------------------------------------- 

int recall_setup(int Oscilloscope, char* filename)  

{ 

char write_buffer[100]; 

int status; 

/* recall setup */ 

sprintf(write_buffer, "%s%s%s", "Variable:value \"recall\",\"", 
filename, "\""); 

status = ibwrt(scope, write_buffer, strlen(write_buffer)); 

if (ibsta & ERR) 

{ 

GPIBCleanup(scope, "Unable to communicate with Oscilloscope"); 

return 0; 

} 

return 1; 

} 

//-------------------------------------------------------------------------- 

int recall_defaultsetup(int Oscilloscope)  

{ 

char write_buffer[100]; 
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int status; 

/* recall default setup */ 

sprintf(write_buffer, "%s", "Variable:value \"recall\",\"Default\""); 

status = ibwrt(scope, write_buffer, strlen(write_buffer)); 

if (ibsta & ERR) 

{ 

GPIBCleanup(scope, "Unable to communicate with Oscilloscope"); 

return 0; 

} 

return 1; 

} 

//-------------------------------------------------------------------------- 

int run_single_test (int Oscilloscope) 

{ 

char write_buffer[100]; 

char read_buffer[100]; 

int timer; 

sprintf(write_buffer, "%s", "Variable:value \"run\",\"on\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

printf("Executing Test..\n"); 

Sleep(1000); 

// Wait for application to come to Ready State 

timer = 1; 

while (1)  

{ 

timer++; 

if (timer > 500)  
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{ 

printf("******Test Time Out ******\n"); 

return 0; 

} 

sprintf(write_buffer, "%s", "Variable:value? \"run\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

/* read the answer */ 

ibrd(scope, read_buffer, 99); 

if (ibsta & ERR)  

{ 

GPIBCleanup(scope, "Unable to write to device"); 

} 

read_buffer[ibcnt - 1] = '\0'; 

if (strcmp(read_buffer,"\"off\"") == 0)  

{ 

printf("Test Completed or stopped ..\n"); 

return 1; 

} 

Sleep(1000); 

} 

} 

//-------------------------------------------------------------------------- 

void query_results(int Oscilloscope)  

{ 

char write_buffer[100]; 

char read_buffer[100]; 

// Check for errors 
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sprintf(write_buffer, "%s", "Variable:value? \"status\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

/* read the answer */ 

ibrd(scope, read_buffer, 99); 

if (ibsta & ERR)  

{ 

GPIBCleanup(scope, "Unable to write to device"); 

} 

read_buffer[ibcnt - 1 ] = '\0'; 

if (strcmp(read_buffer,"\"Test Complete\"") != 0)  

{ 

printf("Error has Occured. %s\n",read_buffer); 

} 

else 

printf("\nstatus is %s\n",read_buffer); 

// If no error, check for results 

//result summary 

sprintf(write_buffer, "%s", "Variable:value? \"resultsum\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

/* read the answer */ 

ibrd(scope, read_buffer, 99); 

if (ibsta & ERR)  

{ 

GPIBCleanup(scope, "Unable to write to device"); 

} 

read_buffer[ibcnt - 1] = '\0'; 

printf("Result summary : %s\n",read_buffer); 
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//result standard 

sprintf(write_buffer, "%s", "Variable:value? \"resultstd\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

/* read the answer */ 

ibrd(scope, read_buffer, 99); 

if (ibsta & ERR)  

{ 

GPIBCleanup(scope, "Unable to write to device"); 

} 

read_buffer[ibcnt - 1] = '\0'; 

printf("Result standard : %s\n",read_buffer); 

//result measured 

sprintf(write_buffer, "%s", "Variable:value? \"resultmeas\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

/* read the answer */ 

ibrd(scope, read_buffer, 99); 

if (ibsta & ERR)  

{ 

GPIBCleanup(scope, "Unable to write to device"); 

} 

read_buffer[ibcnt - 1] = '\0'; 

printf("Result Measured : %s\n",read_buffer); 

//result remarks 

sprintf(write_buffer, "%s", "Variable:value? \"resultrem\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

/* read the answer */ 

ibrd(scope, read_buffer, 99); 



 
 
 
 
 
Remote GPIB 

17-30 TDSET3 Printable Help Document  
 

if (ibsta & ERR)  

{ 

GPIBCleanup(scope, "Unable to write to device"); 

} 

read_buffer[ibcnt - 1] = '\0'; 

printf("Result Remarks : %s\n",read_buffer); 

//result status 

sprintf(write_buffer, "%s", "Variable:value? \"resultsts\""); 

ibwrt(scope, write_buffer, strlen(write_buffer)); 

/* read the answer */ 

ibrd(scope, read_buffer, 99); 

if (ibsta & ERR)  

{ 

GPIBCleanup(scope, "Unable to write to device"); 

} 

read_buffer[ibcnt - 1] = '\0'; 

printf("Result Status : %s\n",read_buffer); 

} 

//-------------------------------------------------------------------------- 

void GPIBCleanup(int ud, char* ErrorMsg) 

{ 

printf("Error : %s\nibsta = 0x%x iberr = %d (%s)\n", 

ErrorMsg, ibsta, iberr, ErrorMnemonic[iberr]); 

if (ud != -1) 

{ 

printf("Cleanup: Taking device offline\n"); 

ibonl(ud, 0); 
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} 

exit(0); 

} 

//-------------------------------------------------------------------------- 

Guidelines to GPIB Programming 
 

The application includes an example file of a GPIB program. Your GPIB 
program should comply with the following guidelines: 

 You need to manually enable Remote GPIB by clicking Utilities > Enable 
Remote GPIB. The Remote GPIB remains enabled or disabled until you 
manually change it 

 You need to connect a separate GPIB cable between the PC and the 
oscilloscope for GPIB to work. GPIB commands do not work through LAN 

 You need to ensure that the startup is complete before sending additional 
GPIB commands to the application 

 After sending a GPIB command to activate the application, you can send a 
remote GPIB command to query for application variable to check if the 
application is activated or not and to know the GPIB status that is enabled or 
disabled 

 If “processdone” command is not sent before every set command or waited 
upon until it returns a “yes” before sending the next command, you need to 
include delay between commands in the GPIB command script 

 You can query for test results after the test is run and complete 

 Before running the GPIB commands, you can query for *IDN? variable to 
identify the oscilloscope and ensure that the oscilloscope is responding 

 You can query for the status variable to either know if the tests is complete 
or ensure that an error has not occurred 

 Ensure that you are in the appropriate technology for which you are 
selecting or configuring test parameters 

 You can query for lastrepdet variable to know where the last detailed report 
is saved 
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 You can query for lastrepsum variable to know where the last report 
summary is saved 

 You can query for jmstatus variable to know if the application is 
compensating a disturber or test fixture. Do not query for Jig Match 
parameters if the jmstatus variable is ON 

 You can query for variables harmonicres0 to harmonicres5 to view the 
harmonic test results 

Note on Guidelines to GPIB Programming 
 The application does not respond to commands that were sent before the 

application was activated 

 GPIB commands do not work through LAN 

 Remote GPIB commands does not support the View Waveform 
functionality 

 When the application processes remote GPIB commands, all the relevant 
message boxes are disabled 

 If you are in the Select pane while sending GPIB commands to configure a 
test parameter, the application does not display the configure pane. But if 
you are in the Configure pane while sending GPIB commands to select a 
test, the application will display the Select pane 

 While running a test, the remote GPIB commands are not processed until the 
test is complete 

 Do not operate User Interface and Front panel of the oscilloscope manually 

 The application does not display the report irrespective of the preview 
option being enabled or disabled 

 When a test is run, the results are available after the status indicates Test 
Complete. When multiple tests are run, one test result is made available. 
You can retrieve the results for other tests by setting “resultfor” with the test 
name and querying for results. For example, if "outputvoltboth" test is run 
then the result for the test "outputvoltpos" is made available and if 
1000Base-T "templatepeakall" test is run then the result for the test 
"templatea" is made available 
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The following table gives the name of multiple tests the results of which are 
made available soon after the test is complete:  

Table 17-8: Default test name and result details after multiple run 
Test name Test result 
1000-T tests 
templatepeakall templatea 
droopall droopg  
100-Tx tests 
templateall templatepos 
outputvoltboth outputvoltboth 
risetimeboth risetimepos 
falltimeboth  falltimepos 
rfsymboth rfsympos 
overshootboth overshootpos 
jitterboth jitterpos 
jitwcableall jitwcablenorm 
jitwocableall jitwocablenorm 
10-T tests 
mauboth maunorm 
diffvoltall diffvoltpos 
diffvoltmax diffvoltmaxpos 
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Calibration for Return Loss 

1000BASE-T Return Loss 
Use TC1 of the test fixture for calibration. Make the connections as shown by the 
following figure: 

 

Figure 18-1: Calibration for 1000BASE-T Return Loss 

1. Click Tests > Select > 1000BASE-T from the menu bar. 

2. In the Return Loss tab, select Return Loss.  

3. Select Tests > Connect or Connect to display the Connect pane. 
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Figure 18-2: Connect pane of 1000BASE-T Return Loss 

Note: The Open, Load and Short button are enabled only after you press New 
Cal. 
4. Click on New Cal. 

5. Connect CAT5 cable to J200 of TC1 and J702 (OPEN). 

6. Click Open. Once the open calibration is complete, the string Done appears 
below the selected calibration. The following figure shows a typical 
waveform for Return Loss Open Calibration. 

 

Figure 18-3: Waveform of 1000BASE-T Return Loss Open calibration 

7. Connect CAT5 cable to J200 of TC1 and J703 (SHORT). 

8. Click Short. Once the Short calibration is complete, the string Done appears 
below the selected calibration.  
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The following figure shows a typical waveform for Return Loss Short 
Calibration: 

 

Figure 18-4: Waveform of 1000BASE-T Return Loss Short calibration 

9. Connect CAT5 cable to J200 of TC1 and J704 (LOAD). 

10. Click Load. Once the Load calibration is complete, the string Done appears 
below the selected calibration. The following figure shows a typical 
waveform for Return Loss Load Calibration: 

 

Figure 18-5: Waveform of 1000BASE-T Return Loss Load calibration 

11. After all the calibrations are complete, the Apply Cal button is enabled. 

12. Click Apply Cal. The calibration is complete. 

13. To clear the calibrations and recalibrate, click on New Cal again. 
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100BASE-TX Return Loss Transmitter 
Use TC1 of the test fixture for calibration. Make the connections as shown by the 
following figure: 

 

Figure 18-6: Calibration for 100BASE-TX Return Loss 

1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Return Loss tab, select Transmitter.  

3. Select Tests > Connect or Connect to display the Connect pane. 

Note: The Open, Load and Short button are enabled only after you press New 
Cal. 
 

4. Click on New Cal. 

5. Connect CAT5 cable to J200 of TC1 and J702 (OPEN). 

6. Click Open. Once the open calibration is complete, the string Done appears 
below the selected calibration.  
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The following figure shows a typical waveform for Return Loss Open 
Calibration: 

 

Figure 18-7: Waveform of 100BASE-TX Return Loss Open calibration 

7. Connect CAT5 cable to J200 of TC1 and J703 (SHORT). 

8. Click Short. Once the Short calibration is complete, the string Done appears 
below the selected calibration. The following figure shows a typical 
waveform for Return Loss Short Calibration: 

 

Figure 18-8: Waveform of 100BASE-TX Return Loss Short calibration 

9. Connect CAT5 cable to J200 of TC1 and J704 (LOAD). 

10. Click Load. Once the Load calibration is complete, the string Done appears 
below the selected calibration.  
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The following figure shows a typical waveform for Return Loss Load 
Calibration: 

 

Figure 18-9: Waveform of 100BASE-TX Return Loss Load calibration 

11. After all the calibrations are complete, the Apply Cal button is enabled. 

12. Click Apply Cal. The calibration is complete. 

13. To clear the calibrations and recalibrate, click on New Cal again. 
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100BASE-TX Return Loss Receiver 
Use TC1 of the test fixture for calibration. Make the connections as shown by the 
following figure: 

 

Figure 18-10: Calibration for 100BASE-TX Return Loss 

1. Click Tests > Select > 100BASE-TX from the menu bar. 

2. In the Return Loss tab, select Receiver.  

3. Select Tests > Connect or Connect to display the Connect pane. 

Note: The Open, Load and Short button are enabled only after you press New 
Cal. 
 

4. Click on New Cal. 

5. Connect CAT5 cable to J200 of TC1 and J702 (OPEN). 
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6. Click Open. Once the open calibration is complete, the string Done appears 
below the selected calibration. The following figure shows a typical 
waveform for Return Loss Open Calibration: 

 

Figure 18-11: Waveform of 100BASE-TX Return Loss Open calibration 

7. Connect CAT5 cable to J200 of TC1 and J703 (SHORT). 

8. Click Short. Once the Short calibration is complete, the string Done appears 
below the selected calibration. The following figure shows a typical 
waveform for Return Loss Short Calibration: 

 

Figure 18-12: Waveform of 100BASE-TX Return Loss Short calibration 

9. Connect CAT5 cable to J200 of TC1 and J704 (LOAD). 

10. Click Load. Once the Load calibration is complete, the string Done appears 
below the selected calibration.  

The following figure shows a typical waveform for Return Loss Load 
Calibration: 
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Figure 18-13: Waveform of 100BASE-TX Return Loss Load calibration 

11. After all the calibrations are complete, the Apply Cal button is enabled. 

12. Click Apply Cal. The calibration is complete. 

13. To clear the calibrations and recalibrate, click on New Cal again. 
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10BASE-T Return Loss Transmitter 
Use TC1 of the test fixture for calibration. Make the connections as shown by the 
following figure: 

 

Figure 18-14: Calibration for 10BASE-T Return Loss 

1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the Return Loss tab, select Transmitter.  

3. Select Tests > Connect or Connect to display the Connect pane. 

Note: The Open, Load and Short button are enabled only after you press New 
Cal. 
 

4. Click on New Cal. 

5. Connect CAT5 cable to J200 of TC1 and J702 (OPEN). 

6. Click Open. Once the open calibration is complete, the string Done appears 
below the selected calibration.  



 

 

 

Calibration for Return Loss 

TDSET3 Printable Help Document 18-11 
 

The following figure shows a typical waveform for Return Loss Open 
Calibration: 

 

Figure 18-15: Waveform of 10BASE-T Return Loss Open calibration 

7. Connect CAT5 cable to J200 of TC1 and J703 (SHORT). 

8. Click Short. Once the Short calibration is complete, the string Done appears 
below the selected calibration. The following figure shows a typical 
waveform for Return Loss Short Calibration. 

 

Figure 18-16: Waveform of 10BASE-T Return Loss Short calibration 

9. Connect CAT5 cable to J200 of TC1 and J704 (LOAD). 

10. Click Load. Once the Load calibration is complete, the string Done appears 
below the selected calibration. 
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11. The following figure shows a typical waveform for Return Loss Load 
Calibration: 

 

Figure 18-17: Waveform of 10BASE-T Return Loss Load calibration 

12. After all the calibrations are complete, the Apply Cal button is enabled. 

13. Click Apply Cal. The calibration is complete. 

14. To clear the calibrations and recalibrate, click on New Cal again. 
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10BASE-T Return Loss Receiver 
Use TC1 of the test fixture for calibration. Make the connections as shown by the 
following figure: 

 

Figure 18-18: Calibration for 10BASE-T Return Loss 

1. Click Tests > Select > 10BASE-T from the menu bar. 

2. In the Return Loss tab, select Receiver.  

3. Select Tests > Connect or Connect to display the Connect pane. 

Note: The Open, Load and Short button are enabled only after you press New 
Cal. 
 

4. Click on New Cal. 

5. Connect CAT5 cable to J200 of TC1 and J702 (OPEN). 

6. Click Open. Once the open calibration is complete, the string Done appears 
below the selected calibration.  
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The following figure shows a typical waveform for Return Loss Open 
Calibration: 

 

Figure 18-19: Waveform of 10BASE-T Return Loss Open calibration 

7. Connect CAT5 cable to J200 of TC1 and J703 (SHORT). 

8. Click Short. Once the Short calibration is complete, the string Done appears 
below the selected calibration. The following figure shows a typical 
waveform for Return Loss Short Calibration: 

 

Figure 18-20: Waveform of 10BASE-T Return Loss Short calibration 

9. Connect CAT5 cable to J200 of TC1 and J704 (LOAD). 

10. Click Load. Once the Load calibration is complete, the string Done appears 
below the selected calibration.  
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The following figure shows a typical waveform for Return Loss Load 
Calibration: 

 

Figure 18-21: Waveform of 10BASE-T Return Loss Load calibration 

11. After all the calibrations are complete, the Apply Cal button is enabled. 

12. Click Apply Cal. The calibration is complete. 

13. To clear the calibrations and recalibrate, click on New Cal again. 
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Appendix A: Specification Range 
1000BASE-T 

Each test result depends on whether the measured value is within the 
specification range.  

The specification range for 1000BASE-T are listed in the following table: 

Table A-1:1000BASE-T specification range 
Test Specification range 
Template 
 A Fit the template 
 B Fit the template 
 C Fit the template 
 D Fit the template 
 F Fit the template 
 H Fit the template 
Peak Voltage 
 A 670 mV to 820 mV 
 B 670 mV to 820 mV 
 % Difference between A & B Test (1 - |Point A|/|Point B|) * 100 < 1% 
 C (1 - (0.5 * (|Point A| + |Point B|)/2)/|Point C|) * 100% <2% 
 D (1 - (0.5 * (|Point A| + |Point B|)/2)/|Point D|) * 100% <2% 
Droop 
 G (Point G/Point F) *100% > 73.1% 
 J (Point H/Point J) *100% > 73.1% 
Jitter TX_TCLK (Yes) 
 Master Filtered Master Filtered Pk-Pk Jitter + Jtxout < 0.3 ns 
 Master Unfiltered Master Unfiltered Pk-Pk Jitter <1.4 ns 
 Slave Filtered Slave Filtered Pk-Pk Jitter + Jtxout < 0.4 ns + Master Filtered Pk-Pk Jitter 
 Slave Unfiltered Slave Unfiltered Pk-Pk Jitter <1.4 ns 
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Table A-1: 1000BASE-T specification range (cont) 
Test  Specification range 
Jitter TX_TCLK  (No) 
 Master 

Filtered 
Data (TM2) Filtered Pk-Pk Jitter < 0.3 ns - Inconclusive 
Data (TM2) Filtered Pk-Pk Jitter > 0.3 ns – Fail 

 Master 
Unfiltered 

Data (TM2) Unfiltered Pk-Pk Jitter < 1.4 ns - Pass 
Data (TM2) Unfiltered Pk-Pk Jitter > 1.4 ns - Inconclusive 

 Slave 
Filtered 

Data (TM3) Filtered Pk-Pk Jitter - Data (TM2) Filtered Pk-Pk Jitter < 0.4 ns - Pass 
Data (TM3) Filtered Pk-Pk Jitter - Data (TM2) Filtered Pk-Pk Jitter > 0.4 ns - Fail 

 Slave 
Unfiltered 

Data (TM3) Unfiltered Pk-Pk Jitter - Data (TM2) Unfiltered Pk-Pk Jitter < 1.4 ns - 
Pass 
Data (TM3) Unfiltered Pk-Pk Jitter - Data (TM2) Unfiltered Pk-Pk Jitter > 1.4 ns - 
Fail 

Distortion < 10 mV 
Return Loss At least 16 dB over the frequency range of 1.0 MHz to 40 MHz and at least 10 -20log 10 (f 

/80) dB over the frequency range 40 MHz to 100 MHz (f in MHz) 
Common Mode Voltage < 50 mV Pk-Pk 

 

100BASE-TX 
Each test result depends on whether the measured value is within the 
specification range.  

The specification range for 100BASE-TX are listed in the following table: 

Table A-1: 100BASE-TX specification range  
Test Specification range 
Template 
 AOI Template Fit the template 
Differential Output Voltage 
 Output Voltage (+Vout) 950 mV to 1050 mV 
 Output Voltage (-Vout) –950 mV to –1050 mV 
Signal Amplitude Symmetry 
 Signal Amplitude Symmetry 0.98 to 1.02 
Rise Time 
 Rise Time (+ve)  3.0 ns to 5.0 ns 
 Rise Time (-ve) 3.0 ns to 5.0 ns 

 



 

 

 

Appendix A: Specification Range 

TDSET3 Printable Help Document A-3 
 

 

Table A-2: 100BASE-TX specification range (cont) 
Test  Specification range 
Fall Time 
 Fall Time (+ve) 3.0 ns to 5.0 ns 
 Fall Time (-ve)  3.0 ns to 5.0 ns 
Rise/Fall Time Symmetry 
 Rise/Fall Symmetry (+ve) <500 ps 
 Rise/Fall Symmetry (-ve) <500 ps 
Waveform Overshoot 
 Overshoot(+ve) <5% 
 Overshoot(-ve) <5% 
Jitter 
 Transmit Jitter <1.4ns 
Duty Cycle Distortion 
 Distortion <500 ps(+/- 250 ps) 
Return Loss >16 dB from 2 MHz to 30 MHz 

>(16 - 20log(f/30 MHz)) dB from 30 MHz to 60 MHz 
>10 dB from 60 MHz to 80 MHz 
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10BASE-T/10BASE-Te 
Each test result depends on whether the measured value is within the 
specification range. The specification ranges for 10BASE-T/10BASE-Te tests 
are listed in the following table: 

Note: The 802.3az document includes the changes required to enable the Energy 
Efficient Ethernet (EEE) operation for many existing physical layers. One of the 
supported operations is twisted pair cabling. The PHY supports 100Base-TX, 
1000Base T, 10Base-T, and other technologies. In addition to that EEE defines 
reduced amplitude operation for 10Base-T which is called 10BASE-Te. All the 
measurements of 100Base-TX and 1000Base T, and some of the measurements of 
10Base-T are not affected when performing the 10BASE-Te measurements. The 
10Base-T measurements that support the PHY tests for 10BASE-Te are modified 
with a separate configuration to select and perform.  
 

Table A-1: 10BASE-T/10BASE-Te specification ranges  
Test Specification range 
Template  
 MAU Ext Fit the Template 
 MAU Ext Inv Fit the Template 
 MAU Int Fit the Template 
 MAU Int Inv Fit the Template 
 Link Pulse Fit the Template 
 TP_IDL Fit the Template 
Differential Voltage 10BASE-T 

Positive peaks -  +2.2 V to +2.8 V 
Negative peaks -  –2.2 V to –2.8 V 
10BASE-Te 
Positive peaks -  + 1.54 V to +1.96 V 
Negative peaks -  – 1.54 V to –1.96 V 

Harmonic <Fundamental - 27 dB 
Jitter (with cable)  

Note: Jitter values are according to the Internal MAU measurement. 
 Normal 

8.0BT 
8.5BT 

<11ns (± 5.5 ns) 
<22 ns (± 11 ns) 
<22 ns (± 11 ns) 
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Table A-1: 10BASE-T/10BASE-Te specification range (cont)  
Test  Specification range 

 Jitter (without cable) 
Normal 
8.0BT 
8.5BT 

 
<16 ns (± 8 ns)  
<40 ns (± 20 ns) 
<40 ns (± 20 ns) 

Note: Jitter values are according to the External MAU measurement. 

 Jitter (with cable) 
Normal 
8.0BT 
8.5BT 

 
<7 (±3.5 ns) 
<14 (±7) 
<14 (±7) 

 Jitter (without cable) 
Normal 
8.0BT 
8.5BT 

 
<16 (±8 ns) 
<32 (±16 ns) 
<32 (±16 ns) 

Return Loss At least 15 dB over the frequency range of 5.0 to 10 MHz 
Common mode Voltage <50 mV Peak 
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Appendix B: Error Messages 
TDSET3 Error Messages 

Table B-1: TDSET3 error messages  
Code Error message Description Possible solution 
E101 Few samples, edge finding failed. The application is not able to detect 

valid clock signal. 
Ensure that the correct signal is 
connected and the configuration 
parameters are correct. 

E102 The selected input sources should be 
mutually exclusive. 

Data, Master CLK, Slave CLK cannot be 
configured to the same source.  

Ensure that the oscilloscope channels 
that you configure for the input sources 
are mutually exclusive. 

E103 Invalid signal. 
The measured clock is out of range. 

The estimated TX_TCLK for Distortion 
test is either very low or high.  

Ensure that the correct signal is 
connected and the configuration 
parameters are correct. 
Ensure that the trigger level is adjusted 
to get a stable trigger. 

E104 The measured value is unstable. 
The previous values will be restored. 

The application is not able to get stable 
measured values. 

Ensure that the correct signal is 
connected and the configuration 
parameters are correct. 

E105 Not enough clock edges. The application is not able to find 
sufficient clock edges for Distortion test.  

Ensure that the correct clock signal is 
connected and the configuration 
parameters are correct. 

E106 Invalid clock frequency. The measured TX_TCLK frequency is 
neither within ±5% of 125 MHz nor 62.5 
MHz. 

Ensure that the measured TX_TCLK 
frequency is within ±5% of 125 MHz or 
62.5 MHz. 

E401 Cannot connect to the instrument. The application is not able to 
communicate with the oscilloscope. 

Reboot the oscilloscope. 

E402 This application requires firmware 
version 2.2.0 or above. Please install 
the latest firmware available at the 
Tektronix Web site. The application will 
exit now. 

The application works only with 
Firmware version 2.2.0 or above. 

Download the latest firmware from 
Tektronix Web site. 

E403 Default file does not exist. The application's default settings file is 
not found. 

Reinstall the application. 

E404 Unable to set the mask. The Mask file is missing or corrupted. Reinstall the application. 
E405 Enter a valid file name to generate a 

report. 
The file name in the report setup is not 
valid. 

Go to Report Setup dialog box and 
enter a valid file name. 

E406 Report data base file read failed. The application's system file is 
missing/corrupted. 

Reinstall the application. 
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Table B-1: TDSET3 error messages (cont) 
Code Error message Description Possible solution 
E407 System file exception. If the oscilloscope has a file exception, 

this error is displayed at run time by the 
operating system. 

Reboot the oscilloscope. 

E408 System memory exception. If the oscilloscope has a memory 
exception, this error is displayed at run 
time by the operating system. 

Reboot the oscilloscope. 

E409 Unknown exception. If the oscilloscope has an unknown 
exception, this error is displayed at run 
time by the operating system. 

Reboot the oscilloscope. 

E410 Invalid signal. Check whether the DUT 
is connected. 

The application is not able to detect a 
valid signal. 

Ensure the correct signal is connected 
and the configuration parameters are 
correct. 

E411 This application has not been enabled. 
To enable the application, select 
Utility>Option Installation to enter a 
key. To purchase a key, contact your 
Tektronix representative. Select 
Help>Technical Support to contact 
Tektronix representative. 

The application is not purchased. Contact your Tektronix representative. 

E412 Calibration Data unavailable. Calibration is not complete for the 
selected test. 

Complete all three Load, Short, Open 
calibration steps for the selected test. 

E413 Unable to find crossover. Unable to find crossover to place the 
histogram while 100BASE-TX, and 
10BASE-T Jitter tests. 

For 100BASE-TX tests, re-run the test. 
For 10BASE-T tests, select the Show 
10Base-T Jitter User Control check 
box in the Preference dialog box and 
then re-run the test. When the 10Base-T 
Jitter User Control dialog box appears, 
adjust the TiggerHoldOff parameter of 
the oscilloscope.  

E414 The selected oscilloscope sources are 
mutually exclusive. 

The same channel is selected for 
multiple input sources, which are not 
allowed. 

Select separate channel for each input 
source. 

E415 The selected output sources are 
mutually exclusive. 

The same Reference source is selected 
for output, which is not allowed. 

Select separate Reference waveform for 
output. 

E416 External trigger unavailable. Check 
whether the ‘sync Out’ of the AWG is 
connected to the ‘AUX IN’ of the 
oscilloscope. Incase of the AFG, check 
whether the ‘TTL out’ is connected to 
the ‘AUX IN’ of the oscilloscope. 

The sync/marker1 of the AWG is not 
connected to the 'AUX IN' of the 
Oscilloscope. Incase of the AFG, the 
‘TTL out’ is not connected to the  
‘AUX IN’ of the oscilloscope. 

Connect the sync/marker1 of the AWG 
to the 'AUX IN' of the Oscilloscope. 
Incase of the AFG, connect the ‘TTL 
out’ to the ‘AUX IN’ of the oscilloscope. 

E417 System failure. There is a problem while allocating a 
system resource. 

Reboot the oscilloscope. 

E418 Unknown Error. If the application has an unknown error, 
this error message is displayed. 

Reboot the oscilloscope. 
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E419 Tekscope is not running. TDSET3 will 
now exit. 

This error message appears if you click 
on Run Test button in the TDSET3 
application after you have exit from the 
TekScope. 

Launch the TekScope and then 
TDSET3 from RunApplication menu to 
work with TDSET3 application. 

Table B-1: TDSET3 error messages (cont) 
Code Error message Description Possible solution 
E420 Change the probe attenuation to ÷10 

before continuing 
Probe attenuation switch is set to ÷1 
and the measured values may be 
invalid. 

Set the attenuation switch of the probe 
to ÷10 before you run the test. 

Note: The Error Message E419 appears only if you are running the TDSET3 
application on a TDS5000B series oscilloscope. 

Remote GPIB Error Messages 

Table B-1: Remote GPIB error messages  
Code Error message Description Possible solution 
E601  GPIB write failure The oscilloscope did not accept the 

GPIB write command. 
Reboot the oscilloscope. 

E602 GPIB read failure The oscilloscope did not accept the 
GPIB read command. 

Reboot the oscilloscope. 

E603 Unable to clear event queue  The oscilloscope event queue was not 
cleared. 

Reboot the oscilloscope. 

E604 Invalid value set; variable reset to 
nearest limit value 

The value set was not within the 
acceptable range. 

The variable value has been reset. 

E605  Conversion error: value reset to the 
old value 

The value set characteristics do not 
match.  

The variable value has been reset. 

E606  Application setup file unavailable The setup file is missing. Resend the command with the 
appropriate file name. 

E607  Selected test to query the result 
details is invalid 

Invalid test chosen for result details 
query.  

Resend the command with the 
appropriate test name. 

E608  Selected test has not been run Querying for a result before the test is 
run or the error E106 

Run the test and then query for the 
results. 

E609  Invalid value is set, old value will be 
reset 

The value set characteristics do not 
match.  

The variable value has been reset. 

E610  Test in progress, unable to retrieve 
the results 

Querying for a result before the test is 
complete. 

Query for results after the test is 
complete. 

E611  Character string too long The value field is too long. Resend the command with a value 
within the acceptable range. 

E612  Invalid test/configuration selected The test or configuration selected does 
not correspond to the current 
technology. 

Select the appropriate technology and 
then select the test or configuration. 

E613  Unable to save application settings The application settings could not be 
saved to a default file. 

Resend the command with a different 
file name. 
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Table B-2: Remote GPIB error messages (cont) 
Code Error message Description Possible solution 
E614  You cannot set values for query only 

commands 
You cannot set values for query only 
commands. 

Do not set value for query only 
commands. 

E615 Unable to retrieve remarks, test name 
unknown. 

You seem to have tried to query for a 
remark block that does not exist. 

Query for remarks block between 1 and 
x where x is the response for 
"remcounter". 

E616 Unable to retrieve remarks for 
specified block id 

You are asking for remarks of some test 
that is not run yet. 

Set the "resultfor" and "getremblk" 
appropriately in that order only and then 
query for "resultrem". 

E700  GPIB Time Out GPIB command has timed out. Reboot the oscilloscope. 
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