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Getting help and support Related documentation

Related documentation

The following manuals are available as part of the TekExpress 10G-KR Compliance and Debug Solution
documentation set.

Table 1: Product documentation

Item Purpose Location

Online Help In-depth operation and UI help

PDF of the Online Help In-depth operation and UI help

+

xxx

See also

Technical support (see page 2)

Conventions used in help

Online Help uses the following conventions:

The term “DUT” is an abbreviation for Device Under Test.

The term “select” is a generic term that applies to the two mechanical methods of choosing an option:
using a mouse or using the touch screen.
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Technical support

Tektronix values your feedback on our products. To help us serve you better, please send us your
suggestions, ideas, or comments on your application or oscilloscope. Contact Tektronix through mail,
telephone, or the Web site. See Contacting Tektronix for more information.

When you contact Tektronix Technical Support, please include the following information (be as specific as
possible):

General information

All instrument model numbers

Hardware options, if any

Probes used

Your name, company, mailing address, phone number, FAX number

Please indicate if you would like to be contacted by Tektronix about your suggestion or comments.

Application specific information

Software version number

Description of the problem such that technical support can duplicate the problem

If possible, save the setup files for all the instruments used and the application

If possible, save the TekExpress setup files, log.xml, *.TekX (session files and folders), and status
messages text file

If possible, save the waveform on which you are performing the measurement as a .wfm file
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Install the software

The software can be installed on any compatible instrument running Windows XP or Windows 7 (64-bit).
See Minimum System Requirements (see page 8) for details.

1. Close all applications (including the TekScope application).

2. Go to the www.tek.com Web site and search for 10G-KR to locate the installation file. Download
the file 10G-KRWebInstaller.exe.

3. Double-click the executable file to extract the installation files.

After extraction, the installer launches and displays the InstallShield Wizard.

Check DPOJET Plug-In to install the 10G-KR option plug-in to the TekScope DPOJET
application.

Check TekExpress application for 10G-KR to install the TekExpress 10G-KR application.
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4. The software installs in the following location:

Windows 7 location: C:\Program Files (x86)\Tektronix\TekExpress\TekExpress

10G-KR

Windows XP location: C:\Program Files\Tektronix\TekExpress\TekExpress 10G-KR

5. The installer updates the TekScope Analyze menu to include the installed options.

See also

Minimum system requirements (see page 8)
Compatibility (see page 7)
DPOJET option 10G-KR plug-in (see page 108)

Activate the license

The 10G-KR application runs in Evaluation mode if you do not provide a valid license key. You are
allowed 10 free trials in Evaluation mode. Each time you open the application without supplying a valid
license key, one free trial is used.

Activate the license using the Option Installation wizard on the oscilloscope. Instructions for using the
Options Installation window to activate licenses for installed applications is provided in the oscilloscope
online Help:

1. From the oscilloscope menu bar, click Utilities > Option Installation.
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The TekScope Option Installation wizard opens.

2. Press the F1 key on the oscilloscope keyboard to open the Option Installation help topic. Follow the
directions in the topic to activate the license.

See also

View version and license information (see page 6)
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View software version and license information

Use the following instructions to view version information for the application and for the application
modules such as the Programmatic Interface and the Programmatic Interface Client.

To view version information:

1. From the Options menu, select About TekExpress.

2. Click the View Version Details link to check the version numbers of the installed test suites.

To view license information:

1. From the oscilloscope Help menu, select About TekScope.

The Options section in the dialog box displays a list of installed options, including 10G-KR.

2. To view the Option key, look in the Option installation key section.

See also

Activate the license (see page 4)
Options menu (see page 14)
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10G-KR features and benefits

Welcome to the TekExpress® 10G-KR Transmitter Automated Solution application. 10G-KR provides an
automated, simple, and efficient way to test 10G-KR Transmitter interfaces and devices consistent to the
requirements of the IEEE 802.3ap-2007 specifications.

10G-KR is based on TekExpress version 2, the Tektronix Test Automation Framework, developed to
support your current and future test automation needs. TekExpress uses a highly modular architecture
that lets you deploy automated test solutions for various standards.

Automates compliance measurements for IEEE 802.3ap-2007 specifications

Automated test setup for measuring transmitter equalization levels generating 72 results, 12 results
for each tap

Provides both an automation solution (for compliance) and DPOJET (for debug)

RF switch support for four lanes of KR4

Reduces the time required to conduct testing

Minimizes user intervention when conducting time-consuming testing

Provision for entering filter files to de-embed the effects of backplane traces and any other components
in the signal pathway

Performs fully-automated testing for transmitter measurements

Allows you to select individual tests or test groups in the tree-structure

Built-in reporting features

Provides a Pass/Fail summary table

Provides margin details on each test

Provides a consolidated report for all tests

Complete programmatic interface available; users can call 10G-KR functions using their automation
scripts

Supported oscilloscopes

The TekExpress 10G-KR application runs on the following Tektronix oscilloscopes:

DPO/DSA/MSO71604/B/C Series Digital Oscilloscopes

DPO/DSA/MSO72004/B/C Series Digital Oscilloscopes

DPO/DSA72504D and DPO/DSA73304D Series Digital Oscilloscopes
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See also

Minimum system requirements (see page 8)

Minimum system requirements

The following table shows the minimum system requirements needed for an oscilloscope to run
TekExpress.

Table 2: System requirements

Oscilloscope See Supported oscilloscopes (see page 7)

Processor Same as the oscilloscope

Operating System Same as the oscilloscope:

Windows 7 (64-bit only)

Windows XP (32-bit) SP2 and higher

Memory Same as the oscilloscope

Hard Disk Same as the oscilloscope

Display Same as the oscilloscope 1

Firmware TekScope 5.3.4 (Windows XP)

TekScope 6.1.4 and later (Windows 7)
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Table 2: System requirements (cont.)

Software DPOJET, Jitter and Eye Diagram Analysis Tool,
3.4.0.17 or later

National Instruments LabVIEW Run-time Engine 9.0.1
or later

National Instruments TestStand Engine 4.2.1

Microsoft .NET 4.0 Framework

Microsoft Excel 2002 or above

Microsoft Internet Explorer 6.0 SP1 or later

Microsoft Photo Editor 3.0 or equivalent software for
viewing image files

Adobe Reader 7.0 or equivalent software for viewing
portable document format (PDF) files

Other Devices Microsoft compatible mouse or compatible pointing
device

Four USB ports (two USB ports minimum)

PCI-GPIB or equivalent interface for instrument
connectivity 2

xxx

1 If TekExpress is running on an instrument having a video resolution lower than 800x600 (for example, a sampling oscilloscope), it is recommended
that you connect a secondary monitor, which must be enabled before launching the application.

2 If TekExpress is installed on a Tektronix oscilloscope, TekExpress will use the virtual GPIB port for communicating with oscilloscope applications. If
external GPIB communication devices such as USB-GPIB-HS or equivalent are used for instrument connectivity, make sure that the Talker Listener
utility is enabled in the GPIB menu of the DPO/DSA oscilloscope. For ease of use, connect to an external (secondary) monitor.

User Account Control

On Windows 7 instruments, set User Account Control Settings to Never Notify. To set User Account
Control Settings, go to Control Panel > User Accounts > Change User Account Control settings and set it
to Never Notify as shown in the image.
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See also

Supported oscilloscopes (see page 7)

Application directories and usage

The application directory and associated files are organized as follows:
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The following table lists the default directory names and their usage.

Table 3: Application directories and usage

Directory names Usage

InstallDir\TekExpress\TekExpress 10G-KR Contains the application and associated files

TekExpress 10G-KR\ACP Contains instrument and 10G-KR application-specific
interface libraries

TekExpress 10G-KR\Bin Contains miscellaneous 10G-KR application libraries

TekExpress 10G-KR\Compliance Suites Contains compliance-specific files

TekExpress 10G-KR\Data Manager Contains result management-specific libraries of the
10G-KR application

TekExpress 10G-KR\Data Storage Contains libraries needed for storing data

TekExpress 10G-KR\Documents Contains the technical documentation for the 10G-KR
application

TekExpress 10G-KR\Examples Contains various support files

TekExpress 10G-KR\ICP Contains instrument and 10G-KR application-specific
interface libraries

TekExpress 10G-KR\Lib Contains utility files specific to the 10G-KR application

TekExpress 10G-KR\Report Generator Contains Excel Active X interface Library for Report
Generation

TekExpress 10G-KR\SCP Contains instrument and 10G-KR application-specific
interface libraries

TekExpress 10G-KR\Tools Contains instrument and 10G-KR application-specific files

xxx

See also

View test-related files (see page 37)
File name extensions (see page 12)
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File name extensions

The TekExpress 10G-KR application uses the following file name extensions:

File name extension Description

.TekX Session files are saved in this format but the extensions
may not be displayed.

.seq The test sequence file

.xml The encrypted XML file that contains the test-specific
configuration information

The log file extension is also xml

.wfm The test waveform file

.mht Test result reports are saved in this format by default. Test
reports can also be saved in HTML format (see page 38).

.flt The filter files.

xxx

See also

Select report options (see page 38)
View test-related files (see page 37)
Application directories and usage (see page 10)
Before you click start (see page 49)
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Run the application

To run the 10G-KR application, do either of the following:

Select Analyze > TekExpress 10G-KR from the TekScope menu.

Double-click any saved 10G-KR session file.

When you open the application after installation, the application checks for a file called Resources.xml
located in the My TekExpress folder. If this file is not found, instrument discovery is performed
before launching 10G-KR. The Resources.xml file contains information regarding instruments that
are available on your network.

If the application license was not installed using the TekScope menu Utilities > Option Installation
selection, you can open the application up to 10 times in evaluation mode. Each time you open the
application without supplying a valid license key, one of the free trials is used.

To keep the application window on top, select Keep On Top from the Options menu (see page 14).

NOTE. If the application was not terminated properly during the last use, a dialog box asks to recall the
previously unsaved session.

See also

Activate the license (see page 4)

Exit the application

Use the following method to exit the application:

NOTE. Using other methods to exit the application results in abnormal termination of the application.

1. Click on the application title bar.

2. Do one of the following:

If you have an unsaved session or test setup open, you will be asked to save it before exiting. To
save it, click Yes. Otherwise click No. The application closes.

A message box appears asking if you really want to exit TekExpress. To exit, click Yes.
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Application controls
Table 4: Application controls descriptions

Item Description

Options menu (see page 14) Opens the Options menu for access to global controls

Panels (see page 21) Visual frames with sets of related options

Command buttons Buttons that initiate an immediate action such as the Start,
Stop, Pause, Continue, and Clear command buttons

Start button

Use the Start button to continuously acquire and accumulate
measurements. If prior acquired measurements have not
been cleared, the new measurements are added to the
existing set.

Stop button

Use the Stop button to abort the test.

Pause \ Continue button

Use the Pause button to temporarily interrupt the current
acquisition. When a test is paused, the button name
changes to “Continue.”

Clear button

Use the Clear button to clear all existing measurement
results. Adding or deleting a measurement, or changing a
configuration parameter of an existing measurement, also
clears measurements. This is to prevent the accumulation
of measurement statistics or sets of statistics that are not
coherent. This button is available only on the Results panel
(see page 35).

Application window move icon

Place the cursor over the three-dot pattern in the upper left
corner of the application window. When the cursor changes
to a hand, drag the window to the desired location.

xxx

Options menu overview

The Options menu is located in the upper right corner of the application.
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The Options menu (see page 15) has the following selections:

Menu Function

Default Test Setup Opens an untitled test setup with defaults selected

Open Test Setup Opens a saved test setup

Save Test Setup Saves the current test setup selections

Save Test Setup As Creates a new test setup based on an existing one

Open Recent Displays a menu of recently opened test setups to select
from

Instrument Control Settings (see page 16) Shows the list of instruments connected to the test setup
and allows you to locate and refresh connections to those
instruments

Keep On Top Keeps the TekExpress 10G-KR utility on top of other open
windows on the desktop

Email Settings (see page 16) Use to configure email options for test run and results
notifications

Deskew (see page 107) Use to deskew channels

Help Displays TekExpress Help

About TekExpress Displays application details such as software name,
version number, and copyright

Provides access to license information (see page 6) for
your 10G-KR installation

Provides a link to the Tektronix Web site

xxx

Options menu
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See also

Application controls (see page 14)

Instrument control settings

Use the TekExpress Instrument Control Settings dialog box to search for and list the connected resources
(instruments) found on specified connections (LAN, GPIB, USB, and so on) and each instruments
connection information. You access this dialog box from the Options menu.

Use the Instrument Control Settings feature to search for connected instruments (see page 46) and view
instrument connection details. Connected instruments displayed here can be selected for use under Global
Settings in the test configuration section. See step 2 of Configure tests (see page 30) for details.

See also

Options menu overview (see page 14)

Email settings

Use the Email Settings utility to configure email notifications (see page 17) if you want to receive
notifications when a test completes, produces an error, or fails. Select the type of test session information
to include in the notification, such as test reports and test logs, the email message format, and the email
message size limit.
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NOTE. Recipient email address, sender’s address, and SMTP Server are mandatory fields.

See also

Configure email settings (see page 17)
Options menu (see page 14)
Select test notification preferences (see page 29)

Configure email settings

To be notified by email when a test completes, fails, or produces an error, configure the email settings.

1. Options > Email Settings to open the Email Settings (see page 19) dialog box.

2. (Required) For Recipient email Address(es), enter one or more email addresses to which to send the
test notification. To include multiple addresses, separate the addresses with commas.

3. (Required) For Sender’s Address, enter the email address used by the instrument. This address consists
of the instrument name followed by an underscore followed by the instrument serial number, then the
@ symbol and the email server used. For example: DPO72016C_B130099@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server address of the Mail server
configured at the client location, and the SMTP Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name, password, and host name
in the corresponding fields.
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NOTE. If any of the above required fields are left blank, the settings will not be saved and email
notifications will not be sent.

5. In the Email Attachments section, select from the following options:

Reports: Select to receive the test report with the notification email.

Status Log: Select to receive the test status log with the notification email. If you select this
option, then also select whether you want to receive the full log or just the last 20 lines.

6. In the Email Configuration section:

Select the message file format to send: HTML (the default) or plain text.

Enter a maximum file size for the email message. Messages with attachments larger than this
limit will not be sent. The default is 5 MB.

Enter the number in the Number of Attempts to Send field, to limit the number of attempts that the
system makes to send a notification. The default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use this check box to quickly
enable or disable email notifications.

8. To test your email settings, click Test Email.

9. To apply your settings, click Apply.

10. Click Close when finished.
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Email settings

Deskew

The Deskew utility reads the instrument configuration and channel deskew settings from the connected
oscilloscope and stores them in a file. When you run a test (click the Start button), TekExpress 10G-KR
resets the oscilloscope to the factory default settings, loads the instrument configuration and channel
deskew settings with the saved values, and then starts running the test session. This is to make sure that the
instrument is set to a known state before each test run.

NOTE. Make sure that you run the Deskew utility after you have finalized the DUT setup, oscilloscope
settings, and channel deskew values, and before you run compliance tests with that test configuration. See
your oscilloscope user documentation or online help for information on channel deskew procedures.

NOTE. You will need to run the Deskew utility whenever you change the oscilloscope settings or channel
deskew values for a test setup.

NOTE. TekExpress 10G-KR does not verify that the saved oscilloscope settings and deskew values are
applicable to the current instrument attached to the application.
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1. In the TekExpress Thunderbolt application, select Options > Deskew.

2. Select the level sensitive deskew setting:

Less than 100 mV Vertical Scale: Select this if the oscilloscope vertical setting is less than
100 mV/division for the signal you are measuring.

100 mV or greater Vertical Scale: Select this if the oscilloscope vertical setting is greater than
100 mV/division for the signal you are measuring.

3. Click Read Deskew/Attn. The utility stores the instrument settings and deskew settings as follows:

<100 mV: C:\Program Files\Tektronix\TekExpress\TekExpress 10G-KR\ICP\Deskew-
Attenuation.txt

≥100 mV: C:\Program Files\Tektronix\TekExpress\TekExpress 10G-KR\ICP\Deskew-
Attenuation-GE100mV.txt

4. When the status in the dialog box indicates the deskew is finished, click Close.
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Application panel overview

Panels group related configuration, test, and results settings.

The TekExpress 10G-KR panels are:

Table 5: Application panels

Panel Name Purpose

Setup (see page 21) Set the DUT, test, acquisition, and report parameters.

The Setup panel allows you to configure the test setup. Use
this panel to:

Select device parameters (see page 22).

Select the test(s) (see page 25).

Select acquisitions parameters (see page 28) for
selected tests.

Configure the selected tests (see page 30)

Select test notification preferences (see page 29).

Status (see page 33) View the progress and analysis status of the selected tests,
and view test logs.

Results (see page 35) View a summary of test results and select result viewing
preferences.

Reports (see page 37) Browse for reports, save reports as specific file types,
specify report naming conventions, select report content to
include (such as summary information, detailed information,
user comments, setup configuration, application
configuration), and select report viewing options.

xxx

See also

Application controls (see page 14)
about setting up tests (see page 43)

Setup panel overview

The Setup panel (see page 22) contains sequentially ordered tabs that help guide you through a typical
test setup process.

Set the DUT parameters. (see page 22)

Select test(s). (see page 25)

Set lane acquisition source.

Select acquisitions (see page 28)
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Configure tests (see page 30)

Select test notification preferences (see page 29)

Set DUT parameters

Use the Setup panel (see page 22) DUT tab to select parameters for the device under test. The settings
are global and apply to all tests for the current session. DUT settings also affect the list of available
tests in the Test Selection tab.

1. Click Setup > DUT.

2. (Optional) Enter the ID for the device. The default value is DUT001. The DUT ID parameter is
added to reports.

3. (Optional) To add comments to the test report, click the note pad icon ( ) to the right of the DUT ID
field. Enter comment text up to 256 characters. To enable or disable comments appearing on the test
report, see Select report options (see page 38).)

4. Select from the following parameters. Settings that do not apply to compliance testing cannot be
changed and are grayed out.
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Table 6: DUT tab settings

Setting Description

Acquire live waveforms Acquire active signals from the oscilloscope for testing.

Use pre-recorded waveform files Run tests on a saved run session file. Select a run session
file from the list.

View Determines where to access the test configuration settings:

Compliance: View configuration settings by clicking
Setup > Test Selection > Configure

Advanced: Enables the Setup > Configuration tab in
which to view configuration settings.

DUT Type Select the device type.

10GBase-KR: used for single lane devices

40GBase-KR4: used for multilane devices (up to four
lanes).

The following selections are displayed when the DUT Type is set to 40GBase-KR4.
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Table 6: DUT tab settings (cont.)

Setting Description

Number of Lanes to Test Select the desired number of test lanes to use for this test
session. The lanes shown here determines the number of
test lanes you can select.

Selected Test Lanes Displays the test lanes selected for the test session.

Click Setup to change lanes selected for testing.

a. In the Test Lane Setup dialog box, select
the desired number of lanes from the
Link Width drop-down list.

b. To select the lanes to use, click the
corresponding lane buttons:

To select both lanes at once, click
Select All. If you select this, select
2 Lanes from the Number of Lanes
to Test drop-down list.

To deselect all selected lanes, click
Deselect All.

If you select 1 Lane, select the
Lane0 button.

If you select 2 Lanes, select Lane0
and Lane1.

c. Click OK.
Your selections display in the Link Width section of the DUT
tab.

xxx

See also

About setting up tests (see page 43)
Select a test (see page 25)
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Select tests

Use the Test Selection tab to select the tests to run on the connected DUT.

1. Click Setup > Test Selection.

2. Select the test(s) to run:

Click one or more check boxes adjacent to each test.

Click Deselect All to deselect all tests. All tests are selected by default.

Click Select Required to select all tests that are required for compliance.

Click Select All to select all tests.

To select an entire test group, select the check box for the test group; tests listed under the group
are automatically selected.

To select one or more, but not all, tests in a test group, select only the check boxes for the desired
tests.

Test selection controls

Table 7: Setup panel test controls

Button Description

When the View type selected in the DUT tab is Compliance,
this button opens the configuration section for the selected
test. If the View type is Advanced, this button is not
displayed.

Displays the schematic document for the selected test. Use
to verify the test setup before running the test

Deselects all tests in the table

Selects tests required for compliance and deselects all
other tests currently selected

Selects all tests in the table

xxx

See also

Select acquisitions (see page 28)
About setting up tests (see page 43)
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About acquisitions

Use the Acquisition tab in the Setup panel to view acquisition parameters for the tests. Options available
on this tab depend on whether you selected to Acquire live waveforms or Use pre-recorded waveform
files in the Setup > DUT tab.

When using pre-recorded waveform files, there are no acquisition selections to make. You can only select
the source of the pre-recorded waveform file for each test.

When acquiring live waveforms, the acquisition selections become available.

The top section of the Acquisitions tab is the source selection area. Here is where you assign the
oscilloscope channels to the lanes.

The selections change depending on previous selections.
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For example, The number of lanes displayed to assign to source channels changes depending on the
Number of Lanes to Test selection made in the Setup > DUT tab.

If you are using an RF Switch setup, check the Automate with RF Switch check box. When checked,
the lane assignments are removed and the RF Switch Setup button is enabled. Pressing the Setup button
displays the RF Switch setup (see page 27) window. The RF Switch Setup allows you to map the lanes
to the RF switch.

See also

Set acquisition parameters source (see page 28)
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Set acquisition parameters source

Use the Acquisitions tab to set the signal source (channel) used to acquire data.

1. Click Setup > Acquisitions.

2. If you selected to use a pre-recorded waveform file, in the Acquisitions table, scroll to the Waveform
FileName column. For each acquire type row, click the ellipsis button ( ) and select the desired
waveform file or files.

3. If you selected to use live waveforms and no RF switch automation, then the Lane and Source
selection tables are displayed near the top of the tab. The number of Lane and Source selections
displayed depend on whether testing a 10GBase-KR or 40GBase-KR interface and the number of
lanes selected for testing in the Setup > DUT tab.

To see which probes are connected to which channels, click View Probes.

To refresh the probe configuration information displayed after changing any probes, click View
Probes and then click Refresh in the Probe Configuration dialog box.

To change a lane source, click in the Source column and select a channel from the drop-down list.

Click the Refresh Sources button to refresh the probe configuration. (This button performs the
same function as the Refresh button in the View Probes dialog box.)

4. If you selected to use live waveforms with RF switch automation (checked the Automate with RF
Switch check box), the Setup button will become active and the Lane and Source selection tables are
removed. Map the lanes to the relay locations.

a. Click the Setup button.

b. In the RF Switch Setup dialog box, map the lanes to the Relay locations and then click OK.

5. Select an Acquisition and Save Options to determine the order in which waveforms are acquired and
analyzed.

Select Save All Waveforms Before Analysis to save all acquired waveforms before analysis
begins.

Select Analyze Immediately - No Waveform Saved to perform an analysis without saving
the waveform.

Select Save and Analyze Acquisition in Sequence to determine the order of acquisition and
analysis during the test execution.

6. Select Show Acquire Parameters to show the acquisition parameters in the test list.
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7. Select Acquire Step By Step to have the software prompt you to continue after each phase of the
test completes.

8. Select a Signal Validation parameter:

Select Prompt me if signal fails to open a dialog box when the application fails to acquire a valid
signal. Select one of the three options in the dialog box:

Re-Acquire: The application attempts to re-acquire the signal.

Use Anyway: Use the acquired signal for all applicable tests.

Skip Test: Skip (ignore) any test(s) that depend on this acquisition. Skipped tests are listed in
the status panel and in the report.

Select Skip test if signal fails to automatically skip tests that use a particular signal if the signal
validation fails. Skipped tests are listed in the status panel and in the report.

Select Use signal as is - Don’t Check to skip signal validation and use the signal as-is for testing.
The test results may not be as expected.

See also

Select acquisitions (see page 28)
About setting up tests (see page 43)

Set test notification preferences

Use the Preferences tab to set the application to send an email when a test measurement completes:

1. Click Setup > Preferences.

2. Select Highlight yellow warning if measured value is within [xx}% of limit check box to display a
yellow warning if the measured value is within the percent of limit value.

If you select this option, enter the margin limit value.

3. Select the On Test Failure, send me an email check box to receive an email when a test fails.

If you select this option, select the Email Test Results when complete or on error check box in the
Email Settings dialog box. Click Email Settings to configure the email settings (see page 17).

See also

About setting up tests (see page 43)
Select report options (see page 38)
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About configuring test parameters

Use the configuration settings to view the measurement parameters for selected tests. How the test
configurations are accessed depend on the View selected in the DUT tab.

If you selected Compliance View in the DUT tab, then in the Test Selection tab, select the desired test
in the list and then click the Configure button.

If you selected Advanced View in the DUT tab, click the Configuration tab in the Setup panel.

See also

Configure test parameters (see page 30)
About running tests (see page 49)

Configure test parameters

The Configuration parameters let you set global and individual test parameters. To return to test selection
from the Configuration tab or panel, click the Test Selection button.

NOTE. You cannot change test parameters that are grayed out.

1. Modify Global settings (see page 30) as desired:

To select the instruments for testing, click Global Settings. In the Instruments Detected section,
click in the shaded areas to activate the drop-down lists and select an instrument. If you do not see
the desired instrument in the list, refresh the list (see page 46).

2. To modify any individual test measurement settings, clickMeasurements, select the test in the tree
view, and change the settings.

See also

About setting up tests (see page 43)

Common test parameters

The following table lists the settings and parameters common to all tests.
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Table 8: Common parameters and values

Parameter Type Parameter and Default Value

Mode Determines whether test parameters are in compliance or
can be edited (User Defined Mode).

Compliance: Most test parameter values cannot be
edited.

User Defined: Most test parameter values can be
edited.

Global Settings These settings apply to all tests selected for the current
session. You can change only some of these settings.

Instruments Detected: Displays a list of the
connected instruments found during the instrument
discovery. Instrument types include equipment such
as oscilloscopes, signal generators, and RF switches.
Select Options > Instrument Control Settings to
refresh the list (see page 16).

Sample Rate: Specifies the oscilloscope sample rate to
use for all tests.

Pattern Type: The global pattern type specifies the
pattern type to use for all applicable measurements
unless a different pattern type is selected for a test in the
Measurements tab.

Record Length: Specifies the length of the record (5M
is the default)

Analyze without de-embedding filter: All tests are
performed without a de-embedding filter.

Analyze with de-embedding filter: When selected,
provides a browse button and field for selecting a filter
to use to compensate for cable lengths.

Analyze with and without de-embedding filter: When
selected, provides a browse button and field for selecting
a filter to use to compensate for cable lengths. The tests
are performed twice, with and without the filter. Results
are provided for both cases for comparative analysis.
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Table 8: Common parameters and values (cont.)

Parameter Type Parameter and Default Value

Measurements Acquire:

Signal Type: Specifies the signal type of the acquisition
for the test selected in the tree view of the Measurements
tab. Running tests in User Defined Mode allows you
to perform the tests on different types of signal. The
default signal type varies by test. Not all tests support
all the signal types. For each test, the application
includes the signal type options that are best suited to
the measurements

Limits Editor Shows the upper and lower limits for the applicable
measurement using different types of comparisons.

In Compliance Mode, allows you to view the measurement
high and low limits used for the test selected in the tree view
of the Measurements tab.

When running tests in User Defined Mode, you can edit the
limit settings in the Limits Editor.

When running tests in User Defined Mode, the cells
in the Limits Editor table are active for editing so you
can change parameters.

xxx

See also

Configure tests (see page 30)
Set acquisition parameters source (see page 28)
De-embed using filter files (see page 107)
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Status panel overview

The Status panel provides status on test acquisition and analysis (Test Status (see page 33) tab) and a
listing of test tasks performed (Log View (see page 34) tab). The application opens the Test Status tab
when you start a test run. You can select the Test Status or the Log View tab to view these items while
tests are running.

Test Status view
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Log View

The Log View display has several viewing options:

Message History: This window timestamps and displays all run messages.

Show Detailed Log: Select this check box to record a detailed history of test execution.

This must be checked before starting a measurement.

Auto Scroll: Select this check box to have the program automatically scroll down as information
is added to the log during the test.

Clear Log: Click this button to clear all messages from the display.

Save: Click this button to save the log file as a text file for examination. A standard Save File
window is displayed to name and save the file.

See also

Application panel overview (see page 21)
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Results panel overview

When a test finishes, the application switches to the Results panel (see page 35) to display a summary of
test results.

Set viewing preferences for this panel from the Preferences menu in the upper right corner. Viewing
preferences include showing whether a test passed or failed, summary results or detailed results, and
enabling wordwrap.

For information on using this panel, see View test results (see page 36).

Results panel
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See also

About panels (see page 21)

View test results

When a test finishes, the application switches to the Results panel (see page 35), which displays a
summary of test results. The Overall Test Result is displayed at the top left of the Results table. If all of
the tests for the session pass, the overall test result will be Pass. If one or more tests fail, the overall test
result will show Fail.

NOTE. NAN (Not A Number) is displayed in the test results if an invalid waveform was supplied for the test.

Each test result occupies a row in the Results table. By default, results are displayed in summary format
with the measurement details collapsed and with the Pass/Fail column visible. Change the view in the
following ways:

To expand all tests listed, select View Results Details from the Preferences menu in the upper right
corner.

To expand and collapse tests, click the plus and minus buttons.

To collapse all expanded tests, select Preferences > View Results Summary.

To remove or restore the Pass/Fail column, select Preferences > Show Pass/Fail.

To enable or disable the wordwrap feature, select Preferences > Enable Wordwrap.

To expand the width of a column, place the cursor over the vertical line that separates the column
from the column to the right. When the cursor changes to a double-ended arrow, hold down the mouse
button and drag the column to the desired width.

To sort the test information by column, click the column head. When sorted in ascending order, a
small up arrow is displayed. When sorted in descending order, a small down arrow is displayed.

To clear all test results displayed, click Clear.

See also

View a report (see page 40)
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View test-related files

Files related to tests are stored in the My TekExpress\10G-KR folder. In the 10G-KR folder, each test
setup has a test setup file and a test setup folder, both with the test setup name:

The test setup file is preceded by the TekExpress icon and usually has no visible file extension.

Inside the test setup folder is another folder named for the DUT ID used in the test sessions. The default
is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has a folder and file pair, both
named for the test session using the naming convention (date)_(time). Each session file is stored outside
its matching session folder:

Each session folder contains image files of any plots generated from running the test session. If you
selected to save all waveforms or ran tests using prerecorded waveform files, these are included here.

The first time you run a new, unsaved session, the session files are stored in the Untitled Session

folder located at ..\My TekExpress\10G-KR. When you name and save the session, the files are placed
in a folder with the name that you specify. A copy of the test files stay in the Untitled Session folder until
you run a new test or until you close the 10G-KR application.

See also

File name extensions (see page 12)
Before you click start (see page 49)

Reports panel overview

Use the Reports panel (see page 38) to browse for reports, name and save reports, select report content to
include, and select report viewing options.

For information on setting up reports, see Select report options (see page 38). For information on viewing
reports, see View a Report (see page 40).
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Reports panel

See also

About panels (see page 21)

Select report options

Use the Reports panel (see page 37) to select which test information to include in the report, and the naming
conventions to use for the report. For example, always give the report a unique name or select to have the
same name increment each time you run a particular test. Generally, you would select report options before
running a test or when creating and saving test setups. Report settings are included in saved test setups.

In the Reports panel, select from the following report options:
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Table 9: Report options

Setting Description

Report Name Displays the name and location from which to open a report.
The default location is at \My TekExpress\10G-KR\Untitled
Session. The report file in this folder gets overwritten each
time you run a test unless you specify a unique name or
select to auto increment the report name.

Change the report name or location.

Do one of the following:

In the Report Name field, type over the
current folder path and name.

Double-click in the Report Name field
and then make selections from the popup
keyboard and click the Enter button.

Be sure to include the entire folder path, the file name,
and the file extension. For example: C:\Documents
and Settings\your user name\My Documents\My
TekExpress\10G-KR\DUT001_Test_72.7.1.3.mht.

NOTE. You cannot set the file location using the Browse
button.

Open an existing report.

Click Browse, locate and select the report file and then click
View at the bottom of the panel.

Save As Type Saves a report in the specified file type. Lists supported file
types to choose from.

NOTE. If you select a file type different from the default,
be sure to change the report file name extension in the
Report Name field to match.

Auto increment report name if duplicate Sets the application to automatically increment the name of
the report file if the application finds a file with the same
name as the one being generated. For example: DUT001,
DUT002, DUT003. This option is enabled by default.

Include Pass/Fail Results Summary Sets the application to include the color block labeled Test
Result (indicating whether the test passed or failed) in the
report. For details, see Report Contents in View a report
(see page 40).

Include Detailed Results Sets the application to include parameter limits, execution
time, and test-specific comments generated during the test.

Include Plot Images Screen shots captured from the oscilloscope during test
execution that show the waveform and measurement data
will be included.
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Table 9: Report options (cont.)

Setting Description

Include Setup Configuration Sets the application to include information about hardware
and software used in the test in the summary box at the top
of the report. Information includes: the oscilloscope model
and serial number, probe model and serial number, the
oscilloscope firmware version, SPC and factory calibration
status, and software versions for applications used in the
measurements.

Include Complete Application Configuration Sets the application to include a table listing general,
common, and acquired parameters used in the test. This
option is disabled by default.

Include User Comments Select to include any comments about the test that you
or another user added in the DUT tab of the Setup panel.
Comments appear in the Comments section under the
summary box at the beginning of each report.

Append Reports This option adds new report data to the end of an existing
report of the same name. This option is disabled by default.
This option is not available if the Auto Increment Report
Name if Duplicate option is selected.

View Report After Generating Automatically opens the report in your Web browser when
the test completes. This option is selected by default.

xxx

See also

View a report (see page 40)
About setting up tests (see page 43)

View a report

The application automatically generates a report when test analysis is completed and displays the report
in your default Web browser (unless you cleared the View Report After Generating check box in the
Reports panel before running the test). If you cleared this check box, or if you want to view a different
test report, do the following:

1. Click the Browse > Reports button and locate and select the report file to view.

NOTE. If you did not save the test setup after running the report and you either closed the application or
you ran another report, the report file was not saved.

2. At the bottom of the Reports panel, click View.

For information on changing the file type, file name, and other report options, see Select report options
(see page 38).
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Report contents

A report shows specified test details, as defined in the Reports panel.

NOTE. NAN (Not A Number) is displayed in the report contents if an invalid waveform was supplied
for the test.

Setup configuration information

Setup configuration information is listed in the summary box at the beginning of the report. This
information includes the oscilloscope model and serial number, and software versions. To exclude this
information from a report, clear the Include Setup Configuration check box in the Reports panel before
running the test.

User comments

If you selected to include comments in the test report, any comments you added in the DUT tab of the
Setup panel appear in the Comments section directly below the summary box.

Test result summary

The Test Result column indicates whether a test passed or failed. If the test passed, the column cell is
green. If the test failed, it is red. To exclude this information from a report, clear the Include Pass/Fail
Results Summary check box in the Reports panel before running the test.
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See also

View test results (see page 36)
View test-related files (see page 37)
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About setting up tests

Set up tests using the tabs in the Setup panel (see page 21). Settings in the DUT tab use a top-down,
left-to-right logic flow, so that any parameter that affects or acts as a filter for other parameters appears
either to the top of or to the left of the affected parameters.

Tests are saved when you save a test setup. To avoid overwriting test results, remember to assign a unique
name to the test either before running it or immediately after.

See also

Test setup overview (see page 48)
Before you click start (see page 49)
About test setups (see page 53)
About running tests (see page 49)
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Equipment connection setup

The following diagrams shows how to connect the DUT to the oscilloscope for the measurements.

Connection setup for differential tests

Connection setup for single ended tests
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Connection setup for 40G-KR tests

See also

Minimum system requirements (see page 8)
View connected instruments (see page 46)
About setting up tests (see page 43)
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View connected instruments

Use the Instrument Control Settings dialog box to view or search for connected instruments required for
the tests. The application uses TekVISA to discover the connected instruments.

To refresh the list of connected instruments:

1. From the Options menu, select Instrument Control Settings.

2. In the Search Criteria section of the Instrument Control Settings dialog box, select the connection
types of the instruments to search for.

Instrument search is based on the VISA layer but different connected cables determine the resource
type, such as LAN, GPIB, and USB. For example, if you choose LAN, the search will include all
the instruments supported by TekExpress that are communicating over the LAN. If the search does
not find any instruments that match a selected resource type, a message appears telling you that no
such instruments were found.

3. Click Refresh. TekExpress searches for connected instruments.

4. After discovery, the dialog box lists the instrument-related details based on the search criteria you
selected. For example, if you selected LAN and GPIB as the search criteria, the application checks for
the availability of instruments over LAN, then GPIB.
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The details of the instruments are displayed in the Retrieved Instruments table. The time and date of
instrument refresh is displayed in the Last Updated field.

See also

Configure tests (see page 30)
Equipment connection setup (see page 44)
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Test setup overview

Test setup includes acquisition and configuration parameters, but you can also select report options
when setting up tests. Use the options in the Setup panel (see page 21) and Reports panel (see page 37)
to select and configure tests.

1. Set DUT parameters (see page 22).

2. Select one or more tests (see page 25).

3. Select acquisitions (see page 28).

4. Configure tests (see page 30).

5. Set test measurement notification options (see page 29).

6. Select report options (see page 38).

See also

About test setups (see page 53)
Pre-run checklist (see page 51)
Before you click start (see page 49)
About running tests (see page 49)
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About running tests

After selecting and configuring tests, review the pre-run checklist (see page 51) and then click Start to
run the tests. While tests are running, you cannot access the Setup or Reports panels. To monitor the test
progress, switch back and forth between the Status panel and the Results panel.

The application displays a report when the tests are complete. While the tests are running, other
applications may display windows in the background. The TekScope application takes precedence over
other applications, but you can switch to other applications by using the Alt + Tab key combination. To
keep the TekExpress 10G-KR application on top, select Keep On Top from the TekExpress Options menu.

See also

Before you click start (see page 49)
About configuring tests (see page 30)
About setting up tests (see page 43)

Before you click start

Before you run tests for the first time, do the following:

1. Understand where your test files are stored on the instrument.

After you install and launch TekExpress 10G-KR, it creates the following folders on the oscilloscope:

\My Documents\My TekExpress\10G-KR

\My Documents\My TekExpress\10G-KR\Untitled Session

Every time you launch TekExpress 10G-KR, an Untitled Session folder is created in the
10G-KR folder. The Untitled Session folder is automatically deleted when you exit the 10G-KR
application. To preserve your test session files, save the test setup before exiting the TekExpress
application.

CAUTION. Do not modify any of the session files or folders because this may result in loss of data
or corrupted session files. Each session has multiple files associated with it. When you save a
session, a .TekX file, and a folder named for the session that contains associated files, is created
on the oscilloscope X: drive.

2. Map the shared My TekExpress folder (see page 113) as X: (X drive) on the instruments used in test
setups running Microsoft Windows Operating System.

The My TekExpress folder has the share name format <domain><user ID>My TekExpress. Or, if
the instrument is not connected to a domain, the share name format is <instrument name><user
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ID>My TekExpress. This shared folder is used to save the waveform files and is used during other
file transfer operations.

NOTE. If the X: drive is mapped to any other shared folder, the application will display a warning message
asking you to disconnect the X: drive manually.

3. Make sure that the My TekExpress folder has read and write access, and that the contents are not set
to be encrypted:

a. Right-click the folder and select Properties.

b. Select the General tab and then click Advanced.

c. In the Advanced Attributes dialog box, make sure that the option Encrypt contents to secure
data is NOT selected. Example.

4. See the pre-run checklist (see page 51) before you run a test.

See also

Configure tests (see page 30)
View test-related files (see page 37)
Application directories and usage (see page 10)
File name extensions (see page 12)

50 TekExpress 10G-KR Compliance, Debug and Protocol Decode Solution



Running tests Pre-run checklist

Pre-run checklist

Do the following before you click Start to run a test. If this is the first time you are running a test on a
setup, refer to the information in Before you click start (see page 49).

1. Make sure that all the required instruments are properly warmed up (approximately 20 minutes).

2. Perform Signal Path Compensation (SPC).

a. On the oscilloscope main menu, select the Utilities menu.

b. Select Instrument Calibration.

3. Deskew channels (see page 107).

4. Verify that the application is able to find the DUT. If it cannot, perform a search for connected
instruments (see page 46).

a. In 10G-KR, select the Setup panel and then click the Test Selection tab.

b. Select any test and then click Configure.

c. In the Configuration section, click Global Settings.

d. In the Instruments Detected section, click the drop-down arrow to the right of Real Time Scope
and make sure that the oscilloscope with the (GPIB8::1::INSTR) designation is in the list.

See also

Equipment connection setup (see page 44)
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About test setups

TekExpress 10G-KR opens with the default setup selected. Run a test before or after saving a setup. When
you save a setup, the test information, such as the selected oscilloscope, general parameters, acquisition
parameters, measurement limits, waveforms (if applicable), and other configuration settings are all saved
under the setup name. Use test setups to:

Run a saved test in prerecorded mode.

View all the information associated with a saved test, including the log file, the history of the test
status as it executed, and the results summary.

Create a new test setup based on an existing one.

Run a new session, acquiring live waveforms, using a saved test configuration.

See also

About setting up tests (see page 43)
Save a test setup (see page 53)
Recall a saved test setup (see page 54)

Save a test setup

Save a test setup before or after running a test using the parameters you want saved. Create a new test
setup from any open setup or from the default setup. When you select the default test setup, all parameters
are returned to their defaults.

The following instructions start from the default test setup:

1. Select Options > Default Test Setup.

2. Select Setup and set required options and parameters in the tabs (DUT, Test Selection, and so on).

3. Select Reports and set your report options (see page 38).

4. Optional: Click Start to run the test and verify that it runs correctly and captures the information you
want. If it does not, edit the parameters and repeat this step until the test runs to your satisfaction.

Running the test helps verify that all parameters are set correctly, but it is not a necessary step.

5. Select Options > Save Test Setup. Enter the file name for the setup file. The application saves
the file to X:\10G-KR\<session_name.

See also

About setting up tests (see page 43)
Test setup overview (see page 48)
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View test-related files (see page 37)
About configuring tests (see page 30)

Recall a saved test setup

These instructions are for recalling saved test setups.

1. Select Options > Open Test Setup.

2. Select the setup from the list and click Open.

See also

About test setups (see page 53)
Create a new test setup based on an existing one (see page 54)
Test setups overview (see page 48)

Create a new test setup based on an existing one

Use this method to create a variation on a test setup without having to create the setup from the beginning.

1. Select Options > Open Test Setup.

2. Select a setup from the list and then click Open.

3. Use the Setup and Reports panels to modify the parameters to meet your testing requirements.

4. Select Options > Save Test Setup As.

5. Enter a test setup name and click Save.

See also

About test setups (see page 53)
Set DUT parameters (see page 22)
Configure tests (see page 30)
Select acquisitions (see page 28)
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About the programmatic interface

The Programmatic interface allows you to seamlessly integrate the TekExpress test automation application
with the high-level automation layer. This also allows you to control the state of the TekExpress
application running on a local or a remote computer.

For simplifying the descriptions, the following terminologies are used in this section:

TekExpress Client: A high-level automation application that communicates with TekExpress using
TekExpress Programmatic Interface.

TekExpress Server: The TekExpress application when being controlled by TekExpress Client.

TekExpress leverages .Net Marshalling to enable the Programmatic Interface for TekExpress Client.
TekExpress provides a client library for TekExpress clients to use the programmatic interface. The
TekExpress client library is inherited from .Net MarshalByRef class to provide the proxy object for the
clients. The TekExpress client library maintains a reference to the TekExpress Server and this reference
allows the client to control the server state.

See also

Requirements for Developing TekExpress Client (see page 55)

Requirements for developing TekExpress client

While developing TekExpress Client, use the TekExpressClient.dll. The client can be a VB .Net, C#
.Net, TestStand or Web application. The examples for interfaces in each of these applications are in the
Samples folder.
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References required

TekExpressClient.dll has an internal reference to IIdlglib.dll and IRemoteInter-
face.dll.

IIdlglib.dll has a reference to TekDotNetLib.dll.

IRemoteInterface.dll provides the interfaces required to perform the remote automations. It is an
interface that forms the communication line between the server and the client.

IIdlglib.dll provides the methods to generate and direct the secondary dialog messages at the
client-end.

NOTE. The end-user client application does not need any reference to the above mentioned DLL files.
It is essential to have these DLLs (IRemoteInterface.dll, IIdlglib.dll and TekDotNetLib.dll) in the same
folder as that of TekExpressClient.dll.

Required steps for a client

The client uses the following steps to use TekExpressClient.dll to programmatically control the
server:

Develop a client UI to access the interfaces exposed through the server. This client loads
TekExpressClient.dll to access the interfaces. After TekExpressClient.dll is loaded, the client
UI can call the specific functions to run the operations requested by the client. When the client is up and
running, it does the following to run a remote operation:

1. To connect to the server, the client provides the IP address of the PC where the server is running.

2. The client locks the server application to avoid conflict with any other Client that may try to control
the server simultaneously. “Lock” would also disable all user controls on the server so that server
state cannot be changed by manual operation.

If any other client tries to access a server that is locked, it will receive a notification that the server
is locked by another client.

3. When the client has connected to and locked the server, the client can access any of the programmatic
controls needed to run the remote automations.

4. After the client operations finish, the client unlocks the server.

See also

About 10G-KR Application Commands (see page 61)

Client programmatic interface example

An example of the client programmatic interface is described and shown as follows:
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Process flowchart
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1. Connect to a server or remote object using the programmatic interface provided.

2. Get the client ID that is created when connecting to the remote object. This client ID is one of the
required parameters to communicate with the server.

NOTE. The server identifies the client with this ID only and rejects any request if the ID is invalid.

3. Lock the server for further operations. This disables the application interface.

NOTE. You can get values from the server or set values from the server to the client only if the application
is locked.

4. Register for receiving notifications on status change events on the server. To register you need to
give a handler as a parameter.

NOTE. Whenever there is a change in the status of the server, all the clients registered with the server
receive a notification from the server.

5. Select the tests that you want to run through the programmatic interface.

6. Set the necessary parameters for each test.

7. Run the tests.

8. Poll for the status of the application.

NOTE. Skip step 8 if you are registered for the status change notification and the status is Ready.

9. After completing the tests, get the results.

10. Create a report or display the results and verify or process the results.

11. Unlock the server after you complete all the tasks.

12. Disconnect from the remote object.

Handler of Status Change Notification

1. Get the status. If the status is Wait or Error, get the information that contains the title, message
description, and the expected responses for the status.

2. Perform the actions based on the status information.

3. Set the response as expected.
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See also

About 10G-KR application commands (see page 61)
Program example (see page 59)

Program example

This program example shows how to communicate between a PC and TekExpress 10G-KR remotely.

A typical application does the following:

1. Start the application.

2. Connect through an IP address.

m_Client.Connect("localhost") 'True or False

clientID = m_Client.getClientID

3. Lock the server.

m_Client.LockServer(clientID)

4. Disable the Popups.

m_Client.SetVerboseMode(clientID, false)

5. Set the Dut ID.

m_Client.SetDutId(clientID, "DUT_Name")

6. Select a measurement.

mClient.SelectTest(clientID, "Device", "Source", "Test72.7.1.3_Signaling

speed", true) 'Measurement selected

7. Select a channel.

mClient.SetGeneralParameter(clientID, "Device", "Source",

"Test72.7.1.3_Signaling speed", "Lane0 Connected to:Lane0:Differen-

tial$CH1") 'Channel 1 selected for Lane 0

8. Configure the selected measurement.

mClient.SetAcquireParameter(clientID, "Device", "Source",

"Test72.7.1.3_Signaling speed", "Pseudo-random pattern$Signal type$PRBs7")

'Signal type of Signaling speed set to PRBS7

9. Run with set configurations.

m_Client.Run(clientID)

10. Wait for the test to complete.

Do
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Thread.Sleep(500)

m_Client.Application_Status(clientID)

Select Case status

Case "Wait"

'Get the Current State Information

mClient.GetCurrentStateInfo(clientID, WaitingMsbBxCaption, WaitingMsbBxMes-

sage, WaitingMsbBxButtontexts)

'Send the Response

mClient.SendResponse(clientID, WaitingMsbBxCaption, WaitingMsbBxMessage,

WaitingMsbBxResponse)

End Select

Loop Until status = "Ready"

11. After the Test is Complete.

'Save all results values from folder for current run

m_Client.TransferResult(clientID, logDirname)

'Save all waveforms from folder for current run

m_Client.TransferWaveforms(clientID, logDirname)

'Save all images from folder for current run

m_Client.TransferImages(clientID, logDirname)

12. Unlock the server.

m_Client.UnlockServer(clientID)

13. Disconnect from server.

m_Client.Disconnect()

14. Exit the application.
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NI TestStand client example

The following is an example for NI TestStand Client available in the path: C:\Program
Files\Tektronix\TekExpress\TekExpress 10G-KR\Examples\Programmatic

Interface\TestStand

About 10G-KR application commands

Click a client action below to see the command name, description, parameters, return value, and an
example, associated with the action.

Connect through an IP address (see page 68)

Lock the server (see page 69)

Disable the popups (see page 70)
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Set or get the DUT ID (see page 71)

Set the configuration parameters for a suite or measurement (see page 72)

Query the configuration parameters for a suite or measurement (see page 74)

Select a measurement (see page 75)

Select a suite (see page 76)

Select a channel (see page 77)

Configure the selected measurement (see page 78)

Run with set configurations or stop the run operation (see page 79)

Handle Error Codes (see page 80)

Get or set the timeout value (see page 81)

Wait for the test to complete (see page 81)

After the test is complete (see page 84)

Save, recall, or check if a session is saved (see page 88)

Unlock the server (see page 89)

Disconnect from server (see page 90)

string id

Name Type Direction Description

id string IN Identifier of the client
performing the remote
function.

xxx

Ready: Test configured and ready to start

Running: Test running

Paused: Test paused

Wait: A popup that needs your inputs

Error: An error is occurred

string dutName

Name Type Direction Description

dutName string IN The new DUT ID of the
setup

xxx
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out bool saved

Name Type Direction Description

saved bool OUT Boolean representing
whether the current
session is saved

xxx

This parameter is used as a check in SaveSession() and SaveSessionAs() functions.

string ipAddress

Name Type Direction Description

ipAddress string IN The ip address of the
server to which the
client is trying to connect
to. This is required to
establish the connection
between the server and
the client.

xxx

out string clientID

Name Type Direction Description

clientid string OUT Identifier of the client that
is connected to the server

clientId = unique number
+ ipaddress of the
client. For example,
1065–192.157.98.70

xxx

NOTE. If the dutName parameter is null, the client is prompted to provide a valid DUT ID.

NOTE. The server must be active and running for the client to connect to the server. Any number of
clients can be connected to the server at a time.

NOTE. When the client is disconnected, it is unlocked from the server and then disconnected. The id
is reused.
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string dutId

Name Type Direction Description

dutId string OUT The DUT ID of the setup

xxx

The dutId parameter is set after the server processes the request.

string device

Name Type Direction Description

device string IN Specifies the name of the
device

xxx

string suite

Name Type Direction Description

suite string IN Specifies the name of the
suite

xxx

string test

Name Type Direction Description

test string IN Specifies the name of the
test to obtain the pass or
fail status

xxx

string parameterString

Name Type Direction Description

parameterString string IN Selects or deselects a test

xxx

int rowNr

Name Type Direction Description

rowNr int IN Specifies the zero
based row index of
the sub-measurement for
obtaining the result value

xxx

NOTE. When the client tries to lock a server that is locked by another client, the client gets a
notification that the server is already locked and it must wait until the server is unlocked. If the client
locks the server and is idle for a certain amount of time, then the server is unlocked automatically
from that client.
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out string[ ] status

Name Type Direction Description

status string array OUT The list of status
messages generated
during run

xxx

string name

Name Type Direction Description

name string IN The name of the session
being recalled

xxx

The name parameter cannot be empty. If it is empty, the client is prompted to provide a valid name.

NOTE. When the run is performed, the status of the run is updated periodically using a timer.

string name

Name Type Direction Description

name string IN The name of the session
being saved

xxx

The name parameter cannot be empty. If it is empty, the client is prompted to provide a valid name.

Once the session is saved under ‘name’ you cannot use this method to save the session in a different
name. Use SaveSessionAs instead.

string name

Name Type Direction Description

name string IN The name of the session
being recalled

xxx

The same session is saved under different names using this method. The name parameter cannot be
empty. If it is empty, the client is prompted to provide a valid name.

bool isSelected

Name Type Direction Description

isSelected bool IN Selects or deselects a test

xxx
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string time

Name Type Direction Description

time string IN The time in seconds
which refers to the timeout
period

xxx

The time parameter gives the timeout period, that is the time the client is allowed to be locked and
idle. After the timeout period, if the client is still idle, it gets unlocked.

The time parameter should be a positive integer. Else, the client is prompted to provide a valid
timeout period.

bool_verbose

Name Type Direction Description

_verbose bool IN Specifies whether the
verbose mode should be
turned ON or OFF

xxx

NOTE. When the session is stopped, the client is prompted to stop the session and is stopped at
the consent.

string filePath

Name Type Direction Description

filePath string IN The location where the
report must be saved in
the client

xxx

NOTE. If the client does not provide the location to save the report, the report is saved at
C:\ProgramFiles.

NOTE. When the client is disconnected, the client is unlocked automatically.

out string caption

Name Type Direction Description

caption string OUT The wait state or error
state message sent to you

xxx
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out string message

Name Type Direction Description

message string OUT The wait state/error state
message to you

xxx

out string[] buttonTexts

Name Type Direction Description

buttonTexts string array OUT An array of strings
containing the possible
response types that you
can send

xxx

string response

Name Type Direction Description

response string IN A string containing the
response type that can be
selected (it must be one
of the strings in the string
array buttonTexts)

xxx
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out string clientID

Name Type Direction Description

clientID string OUT Identifier of the client that
is connected to the server

clientID = unique number
+ ipaddress of the
client. For example,
1065–192.157.98.70

xxx

Connect through an IP address
Command name Parameters Description Return Value Example

Connect() string ipAddress (see
page 63)

out string clientID
(see page 63)

This method
connects the client
to the server.
Note (see page 63)

The client provides
the IP address
to connect to the
server.

The server provides
a unique client
identification number
when connected to
it.

Return value is either
True or False.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as boolean

returnval =
m_Client.Con-
nect(ipad-
dress,m_clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Lock the server
Command name Parameters Description Return Value Example

LockSession() string clientID (see
page 68)

This method locks
the server.
Note (see page 64)

The client must call
this method before
running any of the
remote automations.
The server can be
locked by only one
client.

String value that
gives the status of
the operation after it
is performed.

The return value is
"Session Locked...”
on success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

returnval =
m_Client.Lock-
Server(clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Disable the popups
Command name Parameters Description Return Value Example

SetVerboseMode() string clientID (see
page 68)

bool _verbose (see
page 66)

This method sets
the verbose mode to
either true or false.

When the value
is set to true, any
message boxes
appearing during
the application
will be routed to
the client machine
that is controlling
TekExpress.

When the value is
set to false, all the
message boxes are
shown on the server
machine.

String that gives
the status of the
operation after it is
performed

When Verbose
mode is set to true,
the return value
is “Verbose mode
turned on. All dialog
boxes will be shown
to client”.

When Verbose mode
is set to false,
the return value
is “Verbose mode
turned off. All dialog
boxes will be shown
to server”.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

Verbose mode is
turned on

return=m_Client.Set-
VerboseMode(clien-
tID, true)

Verbose mode is
turned off

returnval=m_Cli-
ent.SetVerbose-
Mode(clientID, false)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Set or get the DUT ID
Command name Parameters Description Return Value Example

SetDutId() string clientID (see
page 68)

string dutName (see
page 62)

This method
changes the DUT
ID of the set up. The
client must provide a
valid DUT ID.

String that gives
the status of the
operation after it is
performed

Return value is “DUT
Id Changed” on
success

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return=m_Client.Set-
DutId(clientID,de-
siredDutId)
Note (see page 63)

GetDutId() string clientID (see
page 68)

string dutId (see
page 64)

This method gets
the DUT ID of the
current set up.

String that gives
the status of the
operation after it is
performed

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

re-
turn=m_Client.Get-
Dutid(clientID, out
DutId)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Set the Configuration Parameters for a suite or measurement
Command name Parameters Description Return Value Example

SetGeneralParame-
ter

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method sets
the number of video
lanes for the selected
measurement.

NOTE. Use this
command to select
a lane, channel, or
source type.

String that gives
the status of the
operation after it is
performed

The return value is ""
(an empty String) on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

Select Channel (see
page 73)

Select Measurement
Method (see
page 73)

SetAnalyzeParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method sets
the configuration
parameters in the
Analyze panel of
the Configuration
Panel dialog box
for a given suite or
measurement.

The return value is ""
(an empty String) on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

SetAcquireParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method sets
the configuration
parameters in the
Acquire panel of
the Configuration
Panel dialog box
for a given suite or
measurement.

returnVal = remo-
teObject.SetAc-
quireParameter(id,
device, suite, test,
parameterString)

if ((OP_STATUS)
returnVal !=
OP_STA-
TUS.SUCCESS)

return Command-
Failed(returnVal)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

72 TekExpress 10G-KR Compliance, Debug and Protocol Decode Solution



TekExpress programmatic interface Set the Configuration Parameters for a suite or measurement

Select channel example

returnval=mClient.SetGeneralParameter(clientID, "Device", "Source", "Test 72.7.1.3_Signaling
speed", "Lane0 Connected to:Lane0:Differential$CH1")

Select measurement method example

returnval=mClient.SetGeneralParameter(clientID, "Device", "Source", "Test 72.7.1.3_Signaling
speed", "Measurement Method$Automatic")

Configure analyze parameters example

Parameter Example

Record Length returnval = mClient.SetAcquireParameter(clientID,
"Device", "Source", "Test 72.7.1.3_Signaling speed",
"Record Length$5M")

xxx
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Query the Configuration Parameters for a suite or measurement
Command name Parameters Description Return Value Example

GetGeneralParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method gets the
general configuration
parameters for
a given suite or
measurement.

The return value
is the general
configuration
parameter for a
given suite or
measurement that is
set.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

Query Channel (see
page 75)

Query Measurement
Method (see
page 75)

GetAnalyzeParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method gets
the configuration
parameters set in
the Analyze tab of
the Configuration
Panel dialog box
for a given suite or
measurement.

The return value is
the configuration
parameter set in
the Analyze tab of
the Configuration
Panel dialog box
for a given suite or
measurement.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

GetAcquireParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method gets
the configuration
parameters set in
the Acquire tab for
a given suite or
measurement.

The return value is
the configuration
parameter set in
the Acquire tab for
a given suite or
measurement.

Query Acquire
Parameters example
(see page 75)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Query channel example

returnval=mClient.GetGeneralParameter(clientID, "Device", "Source", "<Test/Measurement
Name>", "Lane0 Connected to")

Query measurement method example

returnval=mClient.GetGeneralParameter(clientID, "Device", "Source", "<Test/Measurement
Name>", "Measurement Method")

Query acquire parameter examples

Parameter Example

Record Length returnval = mClient.GetAcquireParameter(clientID,
"Device", "Source", "Test72.7.1.3_Signaling speed",
"Record Length$5M")

xxx

Select a measurement
Command name Parameters Description Return Value Example

SelectTest() string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

bool isSelected (see
page 65)

This method selects
or deselects a given
test.

When this parameter
is set to true,
you can select a
measurement.

When this parameter
is set to false,
you can deselect
a measurement.

String that displays
the status of the
operation after it is
performed

The return value is ""
(an empty String) on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL

returnval as string

Select
Measurement (Test
72.7.1.3_Signaling
speed):

return-
val=m_Client.Se-
lectTest(clientID,
"Device", "Source",
"Test 72.7.1.3_Sig-
naling speed", true)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Select a suite
Command name Parameters Description Return Value Example

SelectSuitet() string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

bool isSelected (see
page 65)

This method selects
or deselects a given
suite.

When this parameter
is set to true, you can
select a suite.

When this parameter
is set to false, you
can deselect a suite.

String that gives
the status of the
operation after it is
performed

The return value is ""
(an empty String) on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

Select Suite
(Default):

return-
val=m_Client.Se-
lectTest(clientID,
"Device", "Source",
true)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Select a channel
Command name Parameters Description Return Value Example

SetGeneralParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method sets the
parameters that are
not specific to any
given test.

NOTE. Use this
command to select
a lane, channel, or
source type.

String that gives
the status of the
operation after it is
performed

The return value is ""
(an empty String) on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

Select Channel (see
page 78)

Select Measurement
Method (see
page 78)

SetAnalyzeParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method sets
the configuration
parameters in the
Analyze tab of
the Configuration
Panel dialog box
for a given suite or
measurement.

The return value is ""
(an empty String) on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

SetAcquireParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method sets
the configuration
parameters in the
Acquire tab of
the Configuration
Panel dialog box
for a given suite or
measurement.

returnVal = remo-
teObject.SetAc-
quireParameter(id,
device, suite, test,
parameterString)

if ((OP_STATUS)

returnVal !=
OP_STA-
TUS.SUCCESS)
return Com-
mandFailed(re-
turnVal)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Select channel example

returnval=mClient.SetGeneralParameter(clientID, "Device", "Source", "Test 72.7.1.3_Signaling
speed", "Lane0 Connected to:Lane0:Differential$CH1")

Select measurement method example

returnval=mClientSetGeneralParameter(clientID, "Device", "Source", "Test 72.7.1.3_Signaling
speed", "Measurement Method$Automatic")

Configure the selected measurement
Command name Parameters Description Return Value Example

SetAnalyzeParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method sets the
Analyze parameters
(Configuration
parameters) for a
given test.

The return value is ""
(an empty String) on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

SetAcquireParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method sets the
Acquire parameters
in the Acquire tab of
the Configure Dialog
box for a given test.

returnVal = remo-
teObject.SetAc-
quireParameter(id,
device, suite, test,
parameterString)

if ((OP_STATUS)

returnVal !=
OP_STA-
TUS.SUCCESS)
return Com-
mandFailed(re-
turnVal)

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

Configure Acquire
Parameters for
Record Length (see
page 79)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Configure parameter example

Parameter Example

Record Length returnval = mClient.SetAcquireParameter(clientID,
"Device", "Source", "Test 72.7.1.3_Signaling speed",
"Record Length$5M")

xxx

Run with set configurations or stop the run operation
Command name Parameters Description Return Value Example

Run() string clientID (see
page 68)

Runs the selected
tests. Note (see
page 65)

After the server is set
up and configured,
run it remotely using
this function.

String that gives
the status of the
operation after it is
performed

The return value is
"Run started..." on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

returnval=m_Client.
Run(clientID)

Stop() string clientID (see
page 68)

Stops the currently
running tests Note
(see page 66)

String that gives
the status of the
operation after it is
performed.

The return value
is "Stopped..." on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

returnval=m_Client.
Stop(clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Handle error codes

The return value of the remote automations at the server-end is OP_STATUS, which changes to a string
value depending on its code and returned to the client. The values of OP_STATUS are as follows:

Value Code Description

FAIL −1 The operation failed.

SUCCESS 1 The operation succeeded.

NOTFOUND 2 Server not found

LOCKED 3 The server is locked by another client,
so the operation cannot be performed.

UNLOCK 4 The server is not locked. Lock
the server before performing the
operation.

NULL 0 Nothing

xxx
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Get or set the timeout value
Command name Parameters Description Return Value Example

GetTimeOut() string clientID (see
page 68)

Returns the current
timeout period set by
the client

String that gives
the status of the
operation after it is
performed

The default return
value is 1800000.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Get-
TimeOut()

SetTimeOut() string clientID (see
page 68)

string time (see
page 66)

Sets a timeout
period specified
by the client.
After this timeout
period expires, the
server is unlocked
automatically.

String that gives
the status of the
operation after it is
performed

On success the
return value is
“TimeOut Period
Changed”.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Set-
TimeOut(clientID,
desiredTimeOut)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

Wait for the test to complete

The commands in this group execute while tests are running. The GetCurrentStateInfo() and
SendResponse() commands are executed when the application is running and in the wait state.
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Command name Parameters Description Return Value Example

ApplicationStatus() string clientID (see
page 68)

This method gets the
status of the server
application.

The states at a given
time are Ready,
Running, Paused,
Wait, or Error. (see
page 62)

String value that
gives the status
of the server
application

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Ap-
plicationStatus(clien-
tID)

QueryStatus() string clientID (see
page 68)

out string[] status
(see page 65)

An interface for
the user to transfer
Analyze panel status
messages from the
server to the client.

String that gives
the status of the
operation after it is
performed

On success the
return value is
“Transferred...”.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

returnVal=m_Client-
.QueryStatus(clien-
tID, out statusMes-
sages)

if ((OP_STATUS)re-
turnVal == OP_STA-
TUS.SUCCESS)

return “Status
updated...”

else

return Com-
mandFailed(re-
turnVal)
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Command name Parameters Description Return Value Example

GetCurrentState-
Info()

NOTE. This
command is used
when the application
is running and is
in the wait or error
state.

string clientID (see
page 68)

out string caption
(see page 66)

out string message
(see page 67)

out string[]
buttonTexts (see
page 67)

This method gets
the additional
information of the
states when the
application is in Wait
or Error state.

Except client ID, all
the others are Out
parameters.

This command does
not return any value.

This function
populates the
Out parameters
that are passed
when invoking this
function.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

m_Client.GetCur-
rentStateInfo(clien-
tID, caption,mes-
sage, buttonTexts)

SendResponse()

NOTE. This
command is used
when the application
is running and is
in the wait or error
state.

string clientID (see
page 68)

out string caption
(see page 66)

out string message
(see page 67)

string response (see
page 67)

After receiving the
additional infor-
mation using the
method GetCur-
rentStateInfo(), the
client decides which
response to send,
and then sends the
response to the
application using
this function. The
response should be
one of the strings that
was received earlier
as a string array in
the GetCurrentState-
Info function. The
_caption and _mes-
sage should match
the information re-
ceived earlier in the
GetCurrentStateInfo
function.

This command does
not return any value.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

m_Client.SendR-
esponse(clientID,
caption,message,
response)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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After the test is complete
Command name Parameters Description Return Value Example

GetPassFailStatus() string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

This method gets the
pass or fail status
of the measurement
after test completion.

NOTE. Execute
this command after
completing the
measurement.

String that gives
the status of the
operation after it is
performed

Returns the pass or
fail status in the form
of a string

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Get-
PassFailStatus(cli-
entID, Device,
Source, ”Test
72.7.1.3_Signal-
ing speed”) //Pass or
Fail

GetResultsValue() string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

This method gets the
result values of the
measurement after
the run.

String that gives
the status of the
operation after it is
performed

Returns the result
value in the form of
a string

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as srting

return-
val=m_Client.Ge-
tResultsValue(cli-
entID, "Device",
"Source", "Test
72.7.1.3_Signaling
speed", "Measured
Value")
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Command name Parameters Description Return Value Example

GetResultsValue-
ForSubMeasure-
ments()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 64)

int rowNr (see
page 64)

This method gets
the result values
for individual
sub-measurements
after the run.

String that gives
the status of the
operation after it is
performed

Returns the result
value in the form of
a string

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

Test
72.7.1.3_Signaling
speed

return-
val=m_Client.Ge-
tResultsValue-
ForSubMeasure-
ments(clientID, "De-
vice", "Source", "Test
72.7.1.8_Max output
jitter (peak-peak)",
"Measured Value",0)
//For DCD measure-
ment on Max output
jitter (peak-peak)

return-
val=m_Client.Ge-
tResultsValue-
ForSubMeasure-
ments(clientID, "De-
vice", "Source", "Test
72.7.1.3_Signaling
speed", "Measured
Value",1) //For DN
wfm
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Command name Parameters Description Return Value Example

GetReportParame-
ter()

string clientID (see
page 68)

string device (see
page 64)

string suite (see
page 64)

string test (see
page 64)

string
parameterString
(see page 87)

This method gets the
general report details
such as oscilloscope
model, TekExpress
version, and 10G-KR
version.

The return value
is the oscilloscope
model, TekExpress
version, and 10G-KR
version.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

Oscilloscope
Model

return-
val=m_Client.Ge-
tReportParame-
ter(clientID,"Scope
Model")

TekExpress
Version

return-
val=m_Client.Ge-
tReportParame-
ter(clientID,"TekEx-
press Version")

10G-KR Version

return-
val=m_Client.Ge-
tReportParame-
ter(clientID,"Applica-
tion Version")

TransferReport() string clientID (see
page 68)

string filePath (see
page 66)

This method
transfers the report
generated after the
run.

The report contains
the summary of the
run.

The client must
provide the location
where the report is
to be saved at the
client-end.

String that gives
the status of the
operation after it is
performed

Transfers all the
result values in the
form of a string

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Trans-
ferReport(clien-
tID,"C:\Report”)

86 TekExpress 10G-KR Compliance, Debug and Protocol Decode Solution



TekExpress programmatic interface After the test is complete

Command name Parameters Description Return Value Example

TransferWave-
forms()

string clientID (see
page 68)

string filePath (see
page 66)

This method
transfers all the
waveforms from the
folder for the current
run.

NOTE. Each time
you click Start, a
folder is created on
the X: drive. Transfer
the waveforms
before clicking Start..

String that gives
the status of the
operation after it is
performed

Transfers all the
waveforms in the
form of a string

On success the
return value is
“Transferred...”

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Trans-
ferWaveforms(clien-
tID,"C:\Waveforms”)

TransferImages() string clientID (see
page 68)

od

string filePath (see
page 66)

This method
transfers all the
images (screen
shots) from the folder
for the current run
(for a given suite or
measurement).

NOTE. Each time
you click Start, a
folder is created in
the X: drive. Transfer
the waveforms
before clicking Start.

String that gives
the status of the
operation after it is
performed

Transfers all the
images in the form of
a string

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Trans-
ferImages(clientID,
"C:\Waveforms”)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

string parameterString

Name Type Direction Description

parameterString string IN Specifies the oscilloscope
model, TekExpress
version, and 10G-KR
version.

xxx
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Save, recall, or check if a session is saved
Command name Parameters Description Return Value Example

CheckSession-
Saved()

string clientID (see
page 68)

out bool saved (see
page 63)

This method checks
whether the current
session is saved.

Return value is either
True or False

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Check-
Session-
Saved(m_clientID,
out savedStatus)

RecallSession() string clientID (see
page 68)

string name (see
page 65)

Recalls a saved
session. The client
provides the session
name.

String that gives
the status of the
operation after it is
performed

The return value
is “Session
Recalled...”.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Re-
callSession(clientID,
savedSessionName)

SaveSession() string clientID (see
page 68)

string name (see
page 65)

Saves the current
session. The client
provides the session
name.

String that gives
the status of the
operation after it is
performed

The return value
is "Session
Saved..."/"Failed...".

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

returnval=m_Client-
.SaveSession(clien-
tID, desiredSession-
Name)

SaveSessionAs() string clientID (see
page 68)

string name (see
page 65)

Saves the current
session under a
different name every
time this method is
called. The client
provides the session
name.

String that gives
the status of the
operation after it is
performed

The return value is
"Session Saved...".

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

returnval=m_Client-
.SaveSessionAs(cli-
entID, desiredSes-
sionName)

xxx
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NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".

Unlock the server
Command name Parameters Description Return Value Example

UnlockSession() string clientID (see
page 68)

This method unlocks
the server from the
client. The ID of the
client to be unlocked
must be provided.
Note (see page 66)

String that gives
the status of the
operation after it is
performed

The return value
is "Session
Un-Locked...".

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Un-
lockServer(clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Disconnect from the server
Command name Parameters Description Return Value Example

Disconnect() string clientID (see
page 68)

This method
disconnects the
client from the
server.
Note (see page 63)

Integer value that
gives the status of
the operation after it
is performed

1 for Success

–1 for Failure

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Dis-
connect(m_clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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72.7.1.3 Signaling speed

Measures the signaling speed using the recommended PRBS11 signal. The 10GBASE-KR signaling
speed shall be 10.3125 GBd ± 100 ppm.

Measurement algorithm

TekExpress 10G-KR automatically executes the following measurements and calculations. This
measurement is performed using DPOJET.

The input signal for this test is a PRBS11 waveform.

1. Compute the differential signal on Math1 = Dp - Dn.

2. Compute Period using DPOJET with Math1 as source.

3. The required result is 1/Period (mean).

See also

Connection diagram for single ended tests (see page 44)
Connection diagram for differential tests (see page 44)

72.7.1.4 Differential peak-to-peak output voltage (max)

Measures the differential peak-peak output voltage (max) using the recommended PRBS11 signal. The
differential output voltage is constrained via the transmitter output waveform requirements specified in
72.7.1.10 of IEEE 802.3ap. The peak-to-peak differential output voltage shall be less than 1200 mV,
regardless of equalization setting. The differential output voltage test pattern shall consist of at least
eight symbols of alternating polarity.

Measurement algorithm

TekExpress 10G-KR automatically executes the following measurements and calculations. This
measurement is performed as described below.

The input signal for this test is a differential PRBS11 waveform.

1. Identify the regions with the pattern 1010 or 0101 on the input signal.

2. Measure the high voltage and low voltage in that region.

3. The voltages corresponding to the signal high regions are taken as vHigh. The voltages corresponding
to the signal low are taken as vLow. Compute the peak-to-peak (Vpk-pk) voltage by vHigh – vLow.

4. The Vpk-pk values are averaged across all regions (the required result for the differential peak to peak
measurement).
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See also

Connection diagram for single ended tests (see page 44)
Connection diagram for differential tests (see page 44)

72.6.5 Differential peak-to-peak output voltage (max) with Tx disabled

Measures the differential peak-peak output voltage (max) with Tx disabled. The differential output voltage
is constrained via the transmitter output waveform requirements specified in 72.7.1.10 of IEEE 802.3ap.
The peak-to-peak differential output voltage shall be less than 1200 mV, regardless of equalization setting.
The transmitter output voltage shall be less than 30 mV peak-to-peak when disabled. The differential
output voltage test pattern shall consist of no fewer than eight symbols of alternating polarity.

Measurement algorithm

TekExpress 10G-KR automatically executes the following measurements and calculations. This
measurement is performed as described below.

The input signal for this test is a differential PRBS11, transmitter disabled, waveform.

1. Measure the high voltage and low voltage in the waveform.

2. The voltages corresponding to the signal high regions are taken as vHigh. The voltages corresponding
to the signal low are taken as vLow. Compute the peak-to-peak (Vpk-pk) voltage by vHigh – vLow.

See also

Connection diagram for single ended tests (see page 44)
Connection diagram for differential tests (see page 44)
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72.7.1.4 Common mode voltage limits

Measures the common mode voltage limits using the recommended PRBS11 signal. The common-mode
voltage of SL(p) and SL(n) shall be between 0 V and 1.9 V with respect to signal ground.

Measurement algorithm

TekExpress 10G-KR automatically executes the following measurements and calculations. This
measurement is made using the base oscilloscope measurement.

The input signal for this test is a differential PRBS11 waveform.

1. Math1 = (Dp + Dn) ÷ 2. Switch off channels connected to Dp and Dn.

2. From the Measure menu, select Amplitude > Peak to Peak.

3. Select Math1 as the measurement source.

4. Do a single step run and measure the mean value of the histogram standard deviation. This is the
measurement result.

See also

Connection diagram for single ended tests (see page 44)
Connection diagram for differential tests (see page 44)
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72.7.1.7 Transition time

Measures the transition time (Rise time and Fall time) using the recommended N1N0 signal where N is
between 8 and 11 (inclusive). The rising and falling edge transition times shall be between 24 ps and 47 ps
as measured at the 20% and 80% levels referenced to v2 and v5 as defined in 72.7.1.11 of IEEE 802.3ap.
The measurement is done using the square wave test pattern with no equalization and a run of at least eight
consecutive ones and zeroes.

Measurement algorithm

TekExpress 10G-KR automatically executes the following measurements and calculations. This
measurement is performed as described below.

The input signal for this test is a differential N1N0 (where N lies between 8 and 11, both inclusive)
waveform.

1. Obtain the values of the upper limit (V2) and the lower limit (V5) from the Output Waveform
Characteristics measurement.

2. Find the position of the rising and falling edges in the input waveform.

3. On each rising edge, traverse forward until the first point crossing the upper limit (80%) is found
(=End) and traverse backward until the first point crossing the lower limit (20%) is found (= Start).

4. On each falling edge, traverse backward until the first point crossing the upper limit (80%) is found
(=Start) and traverse forward until the first point crossing the lower limit (20%) is found (=End).

5. Compute the Transition Time, TT (= End – Start). This value is averaged across all edges.

See also

Connection diagram for single ended tests (see page 44)
Connection diagram for differential tests (see page 44)

72.7.1.8 Max output jitter (peak-peak)

Measures the Max output jitter (peak-peak) using the recommended PRBS11 signal.

Jitter components are measured along with their limits:

Random jitter less than 0.15 UI (inclusive)

Random Jitter is the statistics for all timing errors not exhibiting deterministic behavior, based on the
assumption that they follow a Gaussian distribution. Random Jitter is typically characterized by
its standard deviation.

Deterministic jitter less than 0.15 UI (inclusive)
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Deterministic Jitter is the statistics for all timing errors that follow deterministic behavior.
Deterministic Jitter is typically characterized by its peak-to-peak value.

Duty cycle distortion less than 0.035 UI (inclusive)

Duty cycle distortion is the result of bit states that have different durations.

Total jitter less than 0.28 UI (inclusive)

Total Jitter at a specified Bit Error Rate (BER). This combines the Random and Deterministic effects,
and predicts a peak-to-peak jitter that will only be exceeded with a probability equal to the BER.

For the jitter measurement, the effect of a single-pole high-pass filter with a 3 dB point at 4 MHz is
applied to the jitter. Crossing times are defined with respect to the mid-point (0 V) of the AC-coupled
differential signal. Equalization is off during jitter testing.

Transmit jitter test requirements are specified in 72.7.1.9 of IEEE 802.3ap. The transmitter shall have
a maximum total jitter of 0.28 UI peak-to-peak, composed of a maximum deterministic component of
0.15 UI peak-to-peak and a maximum random component of 0.15 UI peak-to-peak. Duty cycle distortion
(DCD) is considered a component of deterministic jitter and shall not exceed 0.035 UI peak-to-peak. The
peak-to-peak duty cycle distortion is defined as the absolute value of the difference in the mean pulse width
of a 1 pulse or the mean pulse width of a 0 pulse (as measured at the mean of the high- and low-voltage
levels in a clock-like repeating 0101 bit sequence) and the nominal pulse width.

Jitter specifications are specified for BER 10-12.

Measurement algorithm (random jitter)

TekExpress 10G-KR automatically executes the following measurements and calculations. Measurements
are made using the base oscilloscope measurements and DPOJET.

The input signal for this test is a differential PRBS11 waveform.

1. Deskew the Data+ and Data– inputs. Compute the differential signal on Math1 = Dp – Dn.

2. Use DPOJET measurement RJ (Jitter tab) on the Math signal.

Measurement algorithm (deterministic jitter)

TekExpress 10G-KR automatically executes the following measurements and calculations. Measurements
are made using the base oscilloscope measurements and DPOJET.

The input signal for this test is a differential PRBS11 waveform.

1. Deskew the Data+ and Data- inputs. Compute the differential signal on Math1 = Dp – Dn.

2. Use DPOJET measurement RJ (Jitter tab) on the Math signal.

Measurement algorithm (duty cycle distortion)

TekExpress 10G-KR automatically executes the following measurements and calculations. This
measurement is performed as described below.
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The input signal for this test is a differential PRBS11 waveform.

1. Check if the input waveform pattern is a square wave test pattern.

2. If the input is a square wave test pattern, check for a number of continuous ones (between 8 and
11) in the test pattern.

3. Estimate the UI of the waveform (UI = bit duration). Identify the edges on the input waveform and the
regions with the patterns 1010 or 0101.

4. Find the absolute value of the difference in the mean pulse width of a 1 pulse or the mean pulse width
of a 0 pulse (from 1010 or 0101 patterns) and the nominal pulse width (estimated UI).

Measurement algorithm (total jitter)

TekExpress 10G-KR automatically executes the following measurements and calculations. Measurements
are made using the base oscilloscope measurements and DPOJET.

The input signal for this test is a differential PRBS11 waveform.

1. Deskew the Data+ and Data- inputs. Compute the differential signal on Math1 = Dp – Dn.

2. Use DPOJET measurement TJ@BER (Jitter tab) on the Math signal.

See also

Connection diagram for single ended tests (see page 44)
Connection diagram for differential tests (see page 44)
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72.7.1.10 Transmitter output waveform characteristics

Measures the output waveform characteristics using the recommended N1N0 signal where N is between 8
and 11 (inclusive).

The test pattern for the transmitter output waveform is the square wave test pattern defined in 52.9.1.2
of IEEE 802.3, with a run of at least eight consecutive ones. The transmitter output waveform test is
based on the voltages v1 through v6, Δv2, and Δv5, which shall be measured as shown in Figure 72–12
of IEEE 802.3ap.

Measurement algorithm

TekExpress 10G-KR automatically executes the following measurements and calculations. This
measurement is performed as described below.

The input signal for this test is a differential PRBS11 waveform.

1. Check if the input waveform pattern is a square wave test pattern.

2. If the input is a square wave test pattern, check for a number of continuous ones (between 8 and
11) in the test pattern.

3. Determine if the starting edge is rising or falling. Depending on the result, measure the voltages
v1, v2, v3, v4, v5, v6, and Rpre, Rpst according to the specification. Average the computed values
across all the regions.

4. Compute Rpre and Rpst values from above computed voltages. Rpre = v3/v2, Rpst = v1/v2.

5. The values of v2 and v5 are considered as the upper and lower limits for transition time measurement.

See also

Connection diagram for single ended tests (see page 44)
Connection diagram for differential tests (see page 44)

72.7.1.11a Output waveform coefficient update

Measures the output waveform coefficient update and status using the recommended N1N0 signal where N
is between 8 and 11 (inclusive).

The state of the transmitter equalizer and hence the transmitter output waveform is manipulated via the
protocol defined in 72.6.10 of IEEE 802.3ap or via management. The changes in the transmitter output
waveform resulting from coefficient update requests shall meet the requirements stated in Table 72–7 of
IEEE 802.3ap. The coefficient update requests in Table 72–7 of IEEE 802.3ap are to be followed by a
coefficient update equal to hold for all taps. The results shall be verified after the coefficient status for
all taps is reported as not_updated. For any coefficient update, the magnitudes of the changes in v1, v2,
and v3 shall be within 5 mV of each other. When sufficient increment or decrement updates have been
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applied to a given tap, it will reach a maximum or minimum limit governed by the coefficient range or
by restrictions placed on minimum steady-state or maximum peak voltage, and the coefficient status is
reported accordingly.

The transmitter output waveform shall meet the requirements of Table 72–8 of IEEE 802.3ap for all of the
limiting cases represented in the table. Implementation of c(–1) or c(1) coefficient values greater than
zero or less than the minimum defined by Rpre (min) and Rpst (min) is optional. A coefficient may be
disabled by first asserting the preset control defined in IEEE 802.3 Table 45–55 and 45.2.1.78, then
manipulating the other coefficients as required by the test.

Measurement algorithm

TekExpress 10G-KR automatically executes the following measurements and calculations. This
measurement is performed as described below.

The input signal for this test is an N1N0 (where N lies between 8 and 11, both inclusive) waveform of the
same pattern with different acquisitions captured at different states (1 through 6).

1. Check if each input waveform pattern is a square wave test pattern.

2. If the inputs are square wave test patterns, check for a number of continuous ones (between 8 and
11) in the test patterns.

3. Determine if the starting edge is rising or falling. Depending on the result, measure the voltages
v1, v2, v3, v4, v5, v6, and Rpre, Rpst according to the specification. Average the computed values
across all the regions.

4. Compute Rpre and Rpst values from above computed voltages. Rpre = v3/v2, Rpst = v1/v2 for
all input waveforms.

5. Calculate V1(k)-V1(k-1),V2(k)-V2(k-1),V3(k)-V3(k-1) for all input waveforms where K varies
from 1 to 6.

See also

Connection diagram for single ended tests (see page 44)
Connection diagram for differential tests (see page 44)
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72.7.1.11b Output waveform coefficient status

Measures the output waveform coefficient update and status using the recommended N1N0 signal where N
is between 8 and 11 (inclusive).

The state of the transmitter equalizer and hence the transmitter output waveform is manipulated via the
protocol defined in 72.6.10 of IEEE 802.3ap or via management. The changes in the transmitter output
waveform resulting from coefficient update requests shall meet the requirements stated in Table 72–7 of
IEEE 802.3ap. The coefficient update requests in Table 72–7 of IEEE 802.3ap are to be followed by a
coefficient update equal to hold for all taps. The results shall be verified after the coefficient status for
all taps is reported as not_updated. For any coefficient update, the magnitudes of the changes in v1, v2,
and v3 shall be within 5 mV of each other. When sufficient increment or decrement updates have been
applied to a given tap, it will reach a maximum or minimum limit governed by the coefficient range or
by restrictions placed on minimum steady-state or maximum peak voltage, and the coefficient status is
reported accordingly.

The transmitter output waveform shall meet the requirements of Table 72–8 of IEEE 802.3ap for all of the
limiting cases represented in the table. Implementation of c(–1) or c(1) coefficient values greater than
zero or less than the minimum defined by Rpre (min) and Rpst (min) is optional. A coefficient may be
disabled by first asserting the preset control defined in IEEE 802.3 Table 45–55 and 45.2.1.78, then
manipulating the other coefficients as required by the test.

Measurement algorithm

TekExpress 10G-KR automatically executes the following measurements and calculations. This
measurement is performed as described below.

The input signal for this test is an N1N0 (where N lies between 8 and 11, both inclusive) waveform of
same pattern with different acquisitions captured at different states (1 though 4).

1. Check if each input waveform pattern is a square wave test pattern.

2. If the inputs are square wave test patterns, check for a number of continuous ones (between 8 and
11) in the test patterns.

3. Determine if the starting edge is rising or falling. Depending on the result, measure the voltages
v1, v2, v3, v4, v5, v6, and Rpre, Rpst according to the specification. Average the computed values
across all the regions.

4. Compute Rpre and Rpst values from above computed voltages. Rpre = v3/v2, Rpst = v1/v2 for
all input waveforms.

See also

Connection diagram for single ended tests (see page 44)
Connection diagram for differential tests (see page 44)
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10G-KR protocol decoding

This solution supports KR Protocol Decode for the 64b-66b standard as defined in IEEE802.3.

NOTE. KR protocol decoding is only supported on oscilloscopes with the Windows 7 (64-bit) operating
system.

To decode KR protocol signals:

1. Connect the test setup and acquire a valid signal with the instrument.

2. Select Vertical >Bus Setup (or Digital > Bus Setup on MSO70K series oscilloscopes) to open
the Bus Setup controls.

3. Click the Config tab to open the Bus Setup pane.
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4. Click Serial and select Custom from the list.

5. Select a Custom Decoder option:

KR: Without descrambler

KR_Descrambler: With descambler support

6. Enter a decoder Threshold value based on the incoming signal.

7. Click Bus 1 On. The oscilloscope screen displays the decoded packets.

8. Click the Display tab to optionally select Busform and Waveform. The Protocol Decode Event Table
shows the list of decoded packets. You can also access the Protocol Decode Event Table from the
TekScope Analyze menu.
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9. Click Export to save the packet information to a .csv format file.

10. Select Analyze > Search in the TekScope application to enable searching on the various packet fields.

11. Click on Bus in the Type field.

12. Click the Configure tab and select the packet type to search for from the Search For list.

13. Select Data in the Search For list to search on the specific data fields.
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14. Use the Radix and Data fields to specify the data for which to search. The application highlights
the search results on the instrument graticule.

15. Click the Results tab to show the list of search results.

16. Click on items in the list to display the associated waveform on the instrument graticule.
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17. Click Export to save the search results to a .csv format file.
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De-embed using filter files

TekExpress 10G-KR provides an option to de-embed the signal path using filter files. You create the filter
files. The filter files are .flt files composed of de-embed filter coefficients for a particular sampling rate.
A filter file created for one sampling rate might not work for other sampling rates, so it is important to
understand at what sampling rate the measurements are being performed.

Also, the de-embedding filters might differ based on the type of input. For example, if a single ended input
is made via a matched SMA cable pair, a filter file for de-embedding a single SMA cable needs to be
provided, since matched SMA cables mostly have similar s-parameters. So in this case, the same filter file
would be used for de-embedding the SMA cable pair.

The maximum sampling rate provided on any channel combination on MSO/DPO/DSA70000 A and B
series oscilloscopes is 50 GS/s in realtime mode. The maximum sampling rate provided on Ch1-Ch3 and
Ch2-Ch4 channel combinations on MSO/DPO/DSA70000 C and D series oscilloscopes is 100 GS/s,
provided only 2 channels are switched on at a given time.

See also

Common test parameters and values (see page 30)
Configure tests (see page 30)

Deskew channels

If skew is present between positive and negative channels, then the channels need to be deskewed before
being used for waveform measurements. TekExpress 10G-KR provides support for channel deskew
using the following method:

1. Determine what the skew is for each channel.

2. From the TekScope menu, select Vertical > Deskew.

3. In the Deskew/Attenuation window, click the channel (1 – 4) button for the first channel to be
deskewed.

4. Click in the Ch(x) Deskew Time entry field and enter the skew. The skew can be +ve or –ve.

5. Click the channel button for the next channel and repeat step 4.

6. After entering the skew for all the channels that require it, from the Options menu in TekExpress
10G-KR, select Deskew.
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7. In the Deskew dialog box, select the desired level:

Less than 100 mV signal amplitude: Select this if the signal amplitude is such that the
oscilloscope’s vertical setting is less than 100 mV/division.

100 mV or greater signal amplitude: Select this if the signal amplitude is such that the
oscilloscope’s vertical setting is greater than 100 mV/division.

8. Click Read Deskew/Attn.

9. When the status in the dialog box indicates the deskew is finished, click Close.

Each input channel has its own deskew settings. Deskew compensates individual channels for probes or
cables of different lengths. The instrument applies the delay values after each completed acquisition. The
deskew values are saved as part of the instrument setup. The deskew values for the selected channel are
retained until you change the probe, you restore a saved setup, or you recall the factory setup.

See also

Select acquisitions (see page 28)
Prerun checklist (see page 51)

DPOJET option 10G-KR plug-in

The TekExpress 10G-KR installation process allows you to also install the 10G-KR option plug-in to the
TekScope DPOJET application.

By installing this plug-in, you’ll be able to use the DPOJET analysis tools that will allow you much greater
flexibility to make changes to the 10G-KR tests and explore other configurations to help you in your
particular test environment.

If the 10G-KR DPOJET plug-in is installed, the 10G-KR is added to the plug-in section of the TekScope
Analyze menu (see page 109) and the standard is added to the DPOJET Jitter and Eye Diagram Analysis
Tools. Selecting the 10G-KR plug-in option launches DPOJET and displays the Standard menu. The
TekScope Help menu (see page 110) is also updated to include the help topic 10G-KR MOI (Methods of
Implementation).
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Using the DPOJET 10G-KR plug-in

1. In the TekScope Analyze menu, select 10G-KR. This launches DPOJET and displays the Select >
Standard menu.

2. Click the Setup button. This opens a browsing window. Navigate to the 10G-KR folder in the
DPOJET/Setups folder. 10G-KR setup files are pre-loaded during installation.
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3. Select a setup file. selecting a setup file populates the Measurement and Source(s) window with the
10G-KR measurements based on the setup file selected.

4. Now you can use the DPOJET settings and configurations to make adjustments to the test parameters
to meet your testing or debugging needs.

Refer to the TekScope online help for detailed information about using DPOJET.

5. Select RUN to start the test.

Table 10: 10G-KR measurements map to DPOJET and 10G-KR DPOJET Plug-in measurements

10G-KR measurements
DPOJET and 10G-KR measurements
(DPOJET Standard tab: Standard set to 10G-KR)

72.7.1.3 Signaling speed Standard tab: Data rate

72.7.1.4 Differential peak-to-peak output
voltage (max)

72.6.5 Differential peak-to-peak output voltage
(max) with Tx disabled

Standard tab: Vpk-pk

72.7.1.7 Transition time Standard tab: KR Rise-Time
KR Fall-Time
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Table 10: 10G-KR measurements map to DPOJET and 10G-KR DPOJET Plug-in measurements (cont.)

10G-KR measurements
DPOJET and 10G-KR measurements
(DPOJET Standard tab: Standard set to 10G-KR)

Jitter tab: RJ
DJ
TJ@BER

72.7.1.8 Max output jitter (peak-peak)

Standard tab: KR-DCD

Standard tab: Square wave voltages:
Wfm-V1
Wfm-V2
Wfm-V3
Wfm-V4
Wfm-V5
Wfm-V6
Wfm-dV2
Wfm-dV5

72.7.1.10 Transmitter output waveform
characteristics

72.7.1.11a Output waveform coefficient
update

72.7.1.11b Output waveform coefficient status

(v1 + v4)/v1 ratio is measured by Wfm-V1V4R.
(v2 + v5)/v2 ratio is measured by Wfm-V2V5R.
(v3 + v5)/v3 ratio is measured by Wfm-V3V5R.
Rpre and Rpst are measured by Wfm-RPre and Wfm-RPost respectively.

xxx
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Map the My TekExpress folder

Follow these steps to map the My TekExpress folder on the instrument:

1. Open Windows Explorer.

2. From the Windows Explorer menu, click Computer.

3. In the menu bar, selectMap network drive.

4. Select the Drive letter as X: (if there is any previous connection on X:, disconnect it first through
Tools > Disconnect Network drive menu of Windows Explorer. Windows 7 users: if you do not see
the Tools menu, press the Alt key).

5. In the Folder field, enter the remote My TekExpress folder path (for example, \\192.158.97.65\
My TekExpress).

To determine the IP address of the instrument where the My TekExpress folder exists, do the following:

1. On the instrument where the My TekExpress folder exists, click Start and select Run.

2. Type “cmd” and then press Enter.

3. At the command prompt, type “ipconfig” and then press Enter.

See also

Before you click start (see page 49)
Install the software (see page 3)
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