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Welcome
Welcome to the TekExpress® Ethernext Tx Conformance Solution. The
application provides turnkey testing & characterization solution for 10GBASE-T
measurements as outlined in IEEE 802.3 Section 55, and for 5GBASE-T and
2.5GBASE-T as outlined in IEEE P802.3bz, Section 16; NBASE-T Spec Draft
2.3. Automation options help the customers to meet their conformance testing
needs and generate detailed reports. User-defined Mode lets customers make
changes to the test limits and perform margin testing as part of extended product
characterization.
 

 

Key features of TekExpress Ethernet Tx include:

■ Comprehensive automated solution for NBASE-T, 2.5GBASE-T, 5GBASE-
T and 10GBASE-T PHY testing

■ One-button selection of multiple tests and four-channel support

■ Detailed test reports with margin and statistical information aid analysis

■ User-defined mode enables flexible parameter control for characterization
and margin analysis

■ Single instrument analysis of time- and frequency-domain measurements

■ Signal acquisition and analysis support for differential probes or direct SMA
cabling
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Getting help and support

Related documentation
The following documentation is available as part of the TekExpress® Ethernet Tx
Solution application.

Table 1: Product documentation

Item Purpose Location
Help Application operation

and User Interface help

PDF of the help Printable version of the
compiled help

PDF file that ships with TekExpress Ethernet Tx
Solution software distribution (TekExpress
Ethernet-Tx-Automated-Test-Solution-Software-
Printable-Help-EN-US.pdf).

See also Technical support
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Conventions
Help uses the following conventions:

■ The term "Application," and "Software" refers to the TekExpress Ethernet Tx
Solution application.

■ The term “DUT” is an abbreviation for Device Under Test.

■ The term “select” is a generic term that applies to the two methods of
choosing a screen item (button, control, list item): using a mouse or using the
touch screen.

Table 2: Icon descriptions

Icon Meaning
This icon identifies important information.

This icon identifies conditions or practices that could result in loss
of data.

This icon identifies additional information that will help you use
the application more efficiently.

Technical support
Tektronix values your feedback on our products. To help us serve you better,
please send us your suggestions, ideas, or comments on your application or
oscilloscope. Contact Tektronix through mail, telephone, or the Web site, 
www.tektronix.com.

When you contact Tektronix Technical Support, please include the following
information (be as specific as possible):

General Information ■ All instrument model numbers
■ Hardware options, if any
■ Probes used
■ Your name, company, mailing address, phone number, FAX number
■ Please indicate if you would like to be contacted by Tektronix about your

suggestion or comments.
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Application Specific
Information

■ Software version number
■ Description of the problem such that technical support can duplicate the

problem
■ If possible, save the setup files for all the instruments used and the

application.
■ If possible, save the TekExpress setup files, log.xml, *.TekX (session files

and folders), and status messages text file.
■ If possible, save the waveform on which you are performing the

measurement as a .wfm file.

 Getting help and support
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Getting started

Minimum system requirements
The following table shows the minimum system requirements to install and run
the TekExpress Ethernet Tx application.

Table 3: System requirements

Component Description
Oscilloscope Supported Scopes Data Rate

DPO7254C 2.5GBASE-T and 5GBASE-T
DPO7354C
DPO/DSA/MSO70000C
DPO/MSO70000DX
DPO/DSA70000D
DPO/DPS70000SX

2.5GBASE-T, 5GBASE-T, and
10GBASE-T

Signal Generators AWG
AWG5002B/C
AWG5004B
AWG5012B/C
AWG5014B/C
AWG70002A
AWG7082C
AWG7122C

Supported for Return Loss and
Transmitter non-linear distortion
(2.5GBase-T, IEEE P802.3bz,
Section 16; NBASE-T Spec
Draft 2.3)

AFG
AFG3052C
AFG3102C
AFG3152C
AFG3252C

Supported for Transmitter non-
linear distortion (2.5GBase-T,
IEEE P802.3bz, Section 16;
NBASE-T Spec Draft 2.3)

Processor Same as the oscilloscope
Operating System Windows 7 
Memory Same as the oscilloscope
Hard Disk Same as the oscilloscope
Display Super VGA resolution or higher video adapter (800 x

600 minimum video resolution for small fonts or 1024 x
768 minimum video resolution for large fonts). The application is
best viewed at 96 dpi display settings  1

Firmware ■ TekScope 7.6.5 or above

1 If TekExpress is running on an instrument that has a video resolution less than 800x600, connect and configure a
second monitor to the instrument.
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Component Description
Software ■ IronPython 2.7.3 installed

■ PyVisa 1.0.0.25 installed

■ Microsoft .NET 4.0 Framework

■ Microsoft Internet Explorer 7.0 SP1 or greater, or other Web
browser for viewing reports

■ Adobe Reader software 7.0 or greater for viewing portable
document format (PDF) files

Other Devices ■ Microsoft compatible mouse or compatible pointing device.

■ Two USB ports (four USB ports recommended).

Supported Probes and Power splitter
The table gives the list of probes and power splitter recommended for the
TekExpress Ethernet Tx application.

Table 4: Recommended probes

Oscilloscope Model For Droop, PSD, Linearity,
Clock Frequency, Jitter-
Master and Jitter Slave
measurements

For Return Loss
measurement

DPO7354 P6330 – Minimum of one and
maximum of four are required

P6330 – Minimum of two are
required

TDP3500 – Minimum of one
and maximum of four are
required

TDP3500 – Minimum of two are
required

SMA Cables – Minimum of two
are required

NA
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Oscilloscope Model For Droop, PSD, Linearity,
Clock Frequency, Jitter-
Master and Jitter Slave
measurements

For Return Loss
measurement

DPO70000 and MSO70000 P6330 – Minimum of one and a
maximum of four are required

P6330 – Minimum of two are
required

P7330 , P7340A, P7350,
P7360A, P7380A and P7313 –
Minimum of one and maximum
of four are required

P7330 , P340A, P7350,
P7360A, P7380A and P7313 –
Minimum of two are required

Trimode probes (P7504, P7506,
P7508, P7513A, P7516 &
P7520A) – A minimum of one
and maximum of four are
required

Trimode probes (P7504, P7506,
P7508, P7513A, P7516 &
P7520A) – Minimum of two are
required

P7350SMA, P7380SMA and
P7313SMA – Minimum of one
and maximum of four are
required

NA

SMA cables – Minimum of two
and maximum of four are
required

NA

Table 5: Recommended power splitter for Transmitter non-linear distortion (Test2)

Power splitter Model
PSPL5331 5331-118 

 Getting started
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Installing the software
Follow the steps to download and install the latest TekExpress Ethernet Tx
Solution. See Minimum system requirements for compatibility.

1. Type the URL www.tek.com in the address bar of web browser and click
Software Downloads

2. Enter TekExpress Ethernet Tx Solution in the Enter your keywords field,
and click Search

3. Select the latest version of software and follow the instructions to download.
Copy the executable file into the oscilloscope.

4. Double-click the executable and follow the on-screen instructions. The
software is installed at C:\Program Files\Tektronix\TekExpress\TekExpress
Ethernet Tx\

5. Select Analyze > TekExpress Ethernet Tx from the TekScope menu to 
launch the application.

View software version
Use the following instructions to view version information for the application and
for the application modules such as the Programmatic Interface and the
Programmatic Interface Client.

To view version information for Ethernet Tx, click  button in the TekExpress
application and select About TekExpress.
 

 

NOTE. This example shows a typical Version Details dialog box, and may not
reflect the actual values as shown when you open this item in the application.
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Application directories

TekExpress Ethernet Tx
application

The TekExpress Ethernet Tx application files are installed at the following
location:

C:\Program Files\Tektronix\TekExpress\TekExpress Ethernet Tx
 

 

The following table lists the application directory names and their purpose.

Table 6: Application directories and usage

Directory names Usage
Bin Contains TekExpress Ethernet Tx application libraries
Compliance Suites Contains compliance-specific files
Examples Contains various support files
ICP Contains instrument and TekExpress Ethernet Tx application-

specific interface libraries
Images Contains images of the TekExpress Ethernet Tx application
Lib Contains utility files specific to the TekExpress Ethernet Tx

application
Report Generator Contains style sheets for report generation
Tools Contains instrument and TekExpress Ethernet Tx application-

specific files

 Getting started
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See also View test-related files

File name extensions

File name extensions
The TekExpress Ethernet Tx application uses the following file name extensions:

File name extension Description
.TekX Application session files (the extensions may not be displayed)
.py Python sequence file
.xml Test-specific configuration information (encrypted) files

Application log files
.wfm Test waveform files
.mht Test result reports (default)

Test reports can also be saved in HTML format
.pdf Test result reports

Application help document
.xslt Style sheet used to generate reports

See also View test-related files

Application directories

Getting started  

10  TekExpress® Ethernet Tx Printable Application Help



Operating basics

Launch the application
To launch the TekExpress Ethernet Tx Solution, select Analyze > TekExpress
Ethernet Tx from the TekScope menu.
 

 

When you launch the application for the first time, the file C:\Users\<username>
\My Documents\My TekExpress\Ethernet Tx\Resources.xml is mapped to drive
X:. This file contains information about available network-connected
instruments. The session files are stored in X:\Ethernet Tx\. If this file is not
found, then the application runs Instrument Discovery Program to detect the
connected instruments before launching Ethernet Tx Solution.

If the application goes behind the oscilloscope application, click Application >
Ethernet Tx to bring it to the front. To keep the Ethernet Tx application window
on top, select Keep On Top from the Ethernet Tx Options menu.
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See also Application controls

Application panel overview

Application panels overview
TekExpress Ethernet Tx Solution uses panels to group related configuration, test,
and results settings. Click any button to open the associated panel. A panel may
have one or more tabs that list the selections available in that panel. Controls in a
panel can change depending on settings made in that panel or another panel.
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Table 7: Application panels overview

Panel Name Purpose
Setup panel The Setup panel shows the test setup controls. Click the Setup button to

open this panel.
Use this panel to:

■ Set DUT tab parameters

■ Select tests

■ Set acquisition tab parameters

■ Set configuration tab parameters

■ Set preferences tab parameters

Status panel View the progress and analysis status of the selected tests, and view test
logs.

Results panel View a summary of test results and select result viewing preferences.
Reports panel Browse for reports, save reports as specific file types, specify report

naming conventions, select report content to include (such as summary
information, detailed information, user comments, setup configuration,
application configuration), and select report viewing options.

See also Application controls

Global application controls

Application controls This section describes the application controls.

 Operating basics
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Table 8: Application controls description

Item Description
Options menu
 

 

Menu to display global application controls.

Test Panel buttons
 

 

Controls that open panels for configuring test settings and options.

Start / Stop button
 

 

Use the Start button to start the test run of the measurements in the
selected order. If prior acquired measurements are not cleared, then new
measurements are added to the existing set.
The button toggles to the Stop mode while tests are running. Use the
Stop button to abort the test.

Pause / Continue
button
 

 

Use the Pause button to temporarily pause the acquisition. When a test is
paused, this button changes to “Continue.”

Clear button
 

 

Use the Clear button to clear all existing measurement results. Adding or
deleting a measurement, or changing a configuration parameter of an
existing measurement, also clears measurements. This is to prevent the
accumulation of measurement statistics or sets of statistics that are not
coherent. This button is available only on Results panel.
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Item Description
Application window
move icon
 

 

Place the cursor over the three-dot pattern in the upper left corner of the
application window. When the cursor changes to a hand, drag the
window to the desired location.

Minimize icon
 

 

Click to minimize the application.

Close icon
 

 

Click to close the application.

See also. Application panel overview

Options menu overview To access Options menu, click  in the upper-right corner of the application. It
has the following:

 Operating basics
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Options menu

Menu Function
Default Test Setup Opens an untitled test setup with defaults selected

Acquire Live Waveforms
Data Rate: 10GBASE-T
Specification: IEEE 802.3, Section 55 
Source: Differential
Number of Lanes to Test: 1 Lane

Open Test Setup Opens a saved test setup
Save Test Setup Saves the current test setup
Save Test Setup As Saves the current test setup with a different file name or file type
Open Recent Displays the recently opened test setups to open
Instrument Control
Settings

Detects, lists, and refreshes the connected instruments found on
specified connections (LAN, GPIB, USB, and so on)

Keep On Top Keeps the TekExpress Ethernet Tx application on top in the desktop
Email Settings Use to configure email options for test run and results notifications
Deskew Allows the user to deskew the probes
Help Displays the TekExpress Ethernet Tx help
About TekExpress ■ Displays application details such as software name, version number,

and copyright

■ Provides a link to the end-user license agreement

■ Provides a link to the Tektronix Web site

See also. Application controls
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TekExpress instrument
control settings

Use TekExpress Instrument Control Settings dialog box to search the instruments
(resources) connected to the application. You can use the Search Criteria to
search the connected instruments depending on the connection type. The details
of the connected instrument is displayed in the Retrieved Instruments window.

You can access this dialog box from the Options menu.
 

 

The connected instruments displayed here can be selected for use under Global
Settings in the test configuration section.

NOTE. Under Instrument Control Settings, select GPIB Option (Default setting),
when using TekExpress Ethernet Tx application.

See also. Options menu overview

View connected
instruments

Use TekExpress Instrument Control Settings dialog box to search the instruments
(resources) connected to the application. The application uses TekVISA to
discover the connected instruments.

NOTE. The correct instruments required for the test setup must be connected and
recognized by the application before running the test.

To refresh the list of connected instruments:

1. From the Options menu, select Instrument Control Settings.

2. In the Search Criteria section of the Instrument Control Settings dialog box,
select the connection types of the instruments to search.

 Operating basics
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Instrument search is based on the VISA layer, but different connections
determine the resource type, such as LAN, GPIB, and USB. For example, if
you choose LAN, the search will include all the instruments supported by
TekExpress that are communicating over the LAN.

3. Click Refresh. TekExpress searches for connected instruments.

4. After searching, the dialog box lists the instrument-related details based on
the search criteria. For example, For the Search Criteria as LAN and GPIB,
the application displays all LAN and GPIB instruments connected to the
application.

The details of the instruments are displayed in the Retrieved Instruments table.
The time and date of instrument refresh is displayed in the Last Updated field.

Operating basics  
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Configure email settings Use the Email Settings utility to get notified by email when a measurement
completes, or produces any error condition. Follow the steps to configure email
settings:

1. Select Options > Email Settings to open the Email Settings dialog box.

2. (Required) For Recipient email Address(es), enter one or more recipient
email addresses. To include multiple addresses, separate the addresses with
commas.

3. (Required) For Sender’s Address, enter the email address used by the
instrument. This address consists of the instrument name, followed by an
underscore, followed by the instrument serial number, then the @ symbol,
and the email server ID. For example:
DSA8300_B130099@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server
address of the Mail server configured at the client location, and the SMTP
Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name,
password, and host name in the corresponding fields.

NOTE. If any of the above required fields are left blank, the settings will not
be saved and email notifications will not be sent.

5. In the Email Attachments section, select from the following options:

■ Reports: Select to receive the test report with the notification email.

■ Status Log: Select to receive the test status log with the notification
email. If you select this option, then also select whether you want to
receive the full log or just the last 20 lines.

6. In the Email Configuration section:

■ Enter a maximum file size for the email message. Messages with
attachments larger than this limit will not be sent. The default is 5 MB.

■ Enter the number in the Number of Attempts to Send field, to limit the
number of attempts that the system makes to send a notification. The
default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use
this check box to quickly enable or disable email notifications.

8. To test your email settings, click Test Email.

9. To apply your settings, click Apply.

10. Click Close when finished.

 Operating basics
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Email Settings
 

 

Setup panel

Setup panel overview The Setup panel contains sequentially ordered tabs that help you guide through
the test setup and execution process. 
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Set DUT parameters Use the DUT tab to select parameters for the device under test. This settings are
global and apply to all tests for the current session. DUT settings also affect the
list of available tests in the Test Selection tab.
 

 Operating basics
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Click Setup > DUT to access the DUT parameters:

Table 9: DUT tab settings

Setting Description
DUT ID Adds an optional text label for the DUT to reports. The default value is

DUT001. The maximum number of characters is 32.
You cannot use the following characters in an ID name: (.,..,...,\,/:?”<>|*)

   Comments icon
(to the right of the DUT
ID field)

Opens a Comments dialog box in which to enter optional text to add to a
report. Maximum size is 256 characters. To enable or disable comments
appearing on the test report. See Select report options for details.

Acquire live waveforms Perform analysis on live waveforms.
Use pre-recorded
waveform files

Perform analysis on pre-recorded waveforms.

Data Rate
10GBASE-T Specification

■ IEEE 802.3, Section 55 

5GBASE-T Specification

■ IEEE P802.3bz, Section 16; NBASE-T Spec Draft 2.3 2.5GBASE-T

Source
Differential Select the source as Differential
Single Ended Select the source as Single Ended
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Setting Description
Multi-Lane Select the number of lanes to test.
Setup Click to select the lanes to test.
Selected Test Lanes Displays the selected lanes.

Figure 1: Test Lane Setup

See also. Select a test

Select tests Use the Test Selection tab to select the TekExpress Ethernet Tx tests.
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Table 10: Test Selection tab settings

Setting Description
Tests Click on a test to select or unselect. Highlight a

test to show details in the Test Description pane.
Test Description Shows a brief description of the highlighted test

in the Test field.

See also. Set acquisition tab parameters

Set acquisition tab
parameters

Use the Acquisitions tab to view test acquisition parameters. The contents
displayed on this tab depends on the DUT type and the tests selected.
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Table 11: Acquisitions tab settings

Setting Description
View Probes Click to view the probe configuration
Show Acquire Parameters Select to view the acquisition parameters.
Signal Validation Select the signal validation type

■ Prompt me if Signal Validation Fails
■ Skip test if Signal Validation Fails
■ Use signal as is - Don't Validate

TekExpress Ethernet Tx saves all acquisition waveforms to files by default.
Waveforms are saved in a unique folder for each session (a session starts when
you click the Start button). The folder path is X:\Ethernet Tx\Untitled Session
\<dutid>\<date>_<time>. Images created for each analysis, CSV files with result
values, reports, and other information specific to that particular execution are also
saved in this folder.

Saving a session moves the session file contents from the Untitled Session folder
to the specified folder name, and changes the session name to the specified name.

 Operating basics
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Set configuration tab
parameters

Use the Configuration tab to view the instruments detected (Global Settings).

Figure 2: Configuration tab: Global Settings

Table 12: Configuration tab settings

Setting Description
Compliance Mode Select to view compliance

mode. By default Compliance
Mode is selected.

User Defined Mode Select to view user defined
mode

Global Settings
Instruments Detected Displays the instruments

connected to this application.
Click on the instrument name to
open a list of available
(detected) instruments.
Select Options > Instrument
Control Settings and click
Refresh to update the
instrument list.

NOTE. Verify that the GPIB
search criteria (default setting)
in the Instrument Control
Settings is selected when using
TekExpress Ethernet Tx
application.
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Setting Description
Measurements
Maximum Output Droop Acquire Population

Analyze Ref Level
Mid Level
Hysteresis
Start Time
End Time

Power Spectrum Density Acquire Acquisition Average
Analyze Start Frequency

Stop Frequency
Resolution Bandwidth
Power Level Start Frequency
Power Level Stop Frequency
Smoothing Average

Tone-1 Acquire Acquisition Average
Analyze Start Frequency

Stop Frequency
Resolution Bandwidth

Tone-2 Acquire Acquisition Average
Analyze Start Frequency

Stop Frequency
Resolution Bandwidth

Tone-3 Acquire Acquisition Average
Analyze Start Frequency

Stop Frequency
Resolution Bandwidth

Tone-4 Acquire Acquisition Average
Analyze Start Frequency

Stop Frequency
Resolution Bandwidth

Tone-5 Acquire Acquisition Average
Analyze Start Frequency

Stop Frequency
Resolution Bandwidth

Clock Frequency Acquire Population
Analyze Ref Level

Mid Level
Hysteresis

Jitter Master Acquire Acquisition Duration
Analyze Ref Level

Mid Level
Hysteresis

 Operating basics
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Setting Description
Jitter Slave Acquire Acquisition Duration

Analyze Ref Level
Mid Level
Hysteresis

Open Tremination Acquire Acquisition Average
Analyze Smoothing Average

Calibration files path
Short Tremination Acquire Acquisition Average

Analyze Smoothing Average
Calibration files path

Load Tremination Acquire Acquisition Average
Analyze Smoothing Average

Calibration files path
Return Loss Acquire Acquisition Average

Analyze Smoothing Average
Calibration files path

Population. Specifies a limit to the amount of waveform data that is analyzed

Ref Level. Absolute Use to manually set the reference levels.

Percentage Use to set the reference levels as a percentage.

Mid Level. A reference voltage level that defines when the waveform state
transition occurs at a given threshold.

Hysteresis. Used to prevent small amounts of noise in a waveform from
producing multiple threshold crossings. Use when the rising and falling
thresholds for a given reference voltage level are set to the same value.

Start Time. Specifies the Droop measurement start time (Time from the zero
crossing).

End Time. Specifies the Droop measurement end time (Time from the zero
crossing).

Acquisition Average. Specifies the number of waveforms over which averaging is
done.

Start Frequency. Specifies the PSD curve start frequency.

Stop Frequency. Specifies the PSD curve stop frequency.

Resolution Bandwidth. Determines the smallest frequency difference that can be
resolved in the frequency domain output data.
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Power Level Start Frequency. Specifies the power level start frequency.

Power Level Stop Frequency. Specifies the power level stop frequency.

Smoothing Average. Specifies the window size in terms of number of samples
used for smoothing.

Acquisition Duration. Specifies the waveform acquired time.

Set preferences tab
parameters

Use the Preferences tab to set the application action on completion of a
measurement.
 

 

Table 13: Preferences tab settings

Setting Description
Number of Runs
Acquire/Analyze each test <no> times (not
applicable to Custom Tests)

Select to repeat the test run by setting the
number of times. By default, it is selected with
1 run.

Actions on Test Measurement Failure
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Setting Description
On Test Failure, stop and notify me of the failure Select to stop the test run on Test Failure, and

to get notified via email. By default, it is
unselected.
Click Email Settings to configure.

Popup Settings
Auto close Warnings and Informations during
Sequencing
Auto close after <no> Seconds

Select to auto close warnings/informations
during sequencing. Set the Auto close time. By
default it is unselected.

Auto close Error Messages during Sequencing.
Show in Reports
Auto close after <no> Seconds

Select to auto close Error Messages during
Sequencing. Set the Auto close time. By default
it is unselected.

Status panel overview
The Status button accesses the Test Status and Log View tabs, which provide
status on test acquisition and analysis (Test Status tab) and a listing of test tasks
performed (Log View tab). The application opens the Test Status tab when you
start a test run. You can select the Test Status or the Log View tab to view these
items while tests are running. 

Test status view
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Log view

Table 14: Status panel Log View controls

Control Description
Message History Lists all executed test operations and timestamp

information.
Auto Scroll Enables automatic scrolling of the log view as

information is added to the log during the test.
Clear Log Clears all messages from the log view.
Save Saves the log file to a text file. Use the standard

Save File window to navigate to and specify the
folder and file name to which to save the log
text.

See also Application panel overview
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Results panel

Results panel overview When a test finishes, the application automatically opens the Results panel to
display a summary of test results.

 

 

See also. View a report

Application panels overview

View test-related files Files related to tests are stored in My TekExpress\Ethernet Tx\ . Each test setup
in this folder has both a test setup file and a test setup folder, both with the test
setup name.

The test setup file is preceded by the TekExpress icon and usually has no visible
file name extension.

Inside the test setup folder is another folder named for the DUT ID used in the
test sessions. The default is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has
a folder and file pair, both named for the test session using the naming
convention (date)_(time). Each session file is stored outside its matching session
folder:
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Each session folder contains image files of any plots generated from running the
test session. If you selected to save all waveforms or ran tests using prerecorded
waveform files, these are included here.

The first time you run a new, unsaved session, the session files are stored in the
Untitled Session folder located at ..\My TekExpress\Ethernet Tx\. When you
name and save the session, the files are placed in a folder with the name that you
specify. A copy of the test files stay in the Untitled Session folder until you run a
new test or until you close the Ethernet Tx application.

See also. File name extensions

Reports panel

Reports panel overview Use the Reports panel to browse for reports, name and save reports, select test
content to include in reports, and select report viewing options.
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For information on setting up reports, see Select report options. For information
on viewing reports, see View a report.

See also. Applications panel overview

Select report options Click the Reports button and use the Reports panel controls to select which test
result information to include in the report, and the naming conventions to use for
the report. For example, always give the report a unique name or select to have
the same name increment each time you run a particular test.

Select report options before running a test or when creating and saving test
setups. Report settings are included in saved test setups.

In the Reports panel, select from the following report options:

Table 15: Report options

Setting Description
Report Update Mode
Generate new report Creates a new report. The report can be in

either .mht or .pdf file formats.
Append with previous run session Appends the latest test results to the end of the

current test results report.
Replace current test in previous run session Replaces the previous test results with the latest

test results. Results from newly added tests are
appended to the end of the report.
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Setting Description
Report Creation Settings
Report name Displays the name and location from which to

open a Ethernet Tx report. The default location
is at \My TekExpress\Ethernet Tx\Untitled
Session. The report file in this folder gets
overwritten each time you run a test unless you
specify a unique name or select to auto
increment the report name.
Change the report name or location.

Do one of the following:

■ In the Report Path field, type over the
current folder path and name.

■ Double-click in the Report Path field and
then make selections from the popup
keyboard and click the Enter button.

Be sure to include the entire folder path, the file
name, and the file extension. For example: C:
\Documents and Settings\your user name\My
Documents\My TekExpress\Ethernet Tx
\DUT001.mht.

NOTE. You cannot set the file location using the
Browse button.

Open an existing report.
Click Browse, locate and select the report file
and then click View at the bottom of the panel.

Save as type Saves a report in the specified file type, selected
from the drop-down list.

NOTE. If you select a file type different from the
default, be sure to change the report file name
extension in the Report Name field to match.

Auto increment report name if duplicate Sets the application to automatically increment
the name of the report file if the application finds
a file with the same name as the one being
generated. For example: DUT001, DUT002,
DUT003. This option is enabled by default.

Create report automatically at the end of the run Creates report at the end of the run.
Contents To Save
Include pass/fail info in details table Includes pass/fail info in the details table of the

report.
Include detailed results Includes detailed results in the report.
Include plot images Includes plot images in the report.
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Setting Description
Include setup configuration Sets the application to include hardware and

software information in the summary box at the
top of the report. Information includes: the
oscilloscope model and serial number, the
oscilloscope firmware version, and software
versions for applications used in the
measurements.

Include complete application configuration Includes complete application configuration in
the report.

Include user comments Select to include any comments about the test
that you or another user added in the DUT tab of
the Setup panel. Comments appear in the
Comments section, under the summary box at
the beginning of each report.

Group Report By
Test Name Select to group the tests in the report by test

name.
Test Result Select to group the tests in the report by test

results

View report after generating Automatically opens the report in a Web browser
when the test completes. This option is selected
by default.

View Click to view the most current report.
Generate Report Generates a new report based on the current

analysis results.
Save As Specify a name for the report.

View a report The application automatically generates a report when test analysis is completed
and displays the report in your default Web browser (unless you cleared the View
Report After Generating check box in the Reports panel before running the
test). If you cleared this check box, or to view a different test report, do the
following: 

1. Click the Reports button.

2. Click the Browse button and locate and select the report file to view.

3. In the Reports panel, click View.

For information on changing the file type, file name, and other report options, see 
Select report options.
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Report contents A report shows detailed results and plots, as set in the Reports panel.
 

 

Setup configuration information

The summary box at the beginning of the report lists setup configuration
information. This information includes the oscilloscope model and serial number,
optical module model and serial number, and software version numbers of all
associated applications.

To exclude this information from a report, clear the Include Setup
Configuration check box in the Reports panel before running the test.

User comments

If you selected to include comments in the test report, any comments you added
in the DUT tab are shown at the top of the report.

See also. Results panel overview

View test-related files
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Running tests

Equipment connection setup
Click Setup > Test Selection > Schematic to view the equipment setup
diagram(s). 

SMA Probe (Differential
Source)

This section describes the equipment connection setup to perform Differential
Source (SMA Probe) Calibration. (For details, see Minimum system
requirements).

Equipment connection setup - Differential Source (SMA Probe) applies to all
tests except Jitter-Slave, Return Loss and Transmitter non-linear distortion
(Test2).
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Figure 3: SMA Probe (Differential Source)

SMA Cable (Single-Ended
Source)

This section describes the equipments required and the connection setup to
perform Single-Ended Source Calibration. (For details, see Minimum system
requirements).

Equipment connection setup - Single-Ended Source (SMA Cable) applies to all
tests except Jitter-Slave, Return Loss and Transmitter non-linear distortion
(Test2).
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Figure 4: SMA Cable (Single-Ended Source)

Jitter-Slave SMA Probe
(Differential Source)

This section describes the equipments required and the connection setup to
perform Jitter-Slave (Differential Source) Calibration. (For details, see Minimum
system requirements).

Equipment connection setup - Jitter-Slave SMA Probe (Differential Source)
applies to Jitter-Slave measurement.
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Figure 5: Jitter-Slave SMA Probe (Differential Source)

Jitter-Slave SMA Cable
(Single-Ended Source)

This section describes the equipments required and the connection setup to
perform Jitter-Slave (Single-Ended Source) calibration. (For details, see 
Minimum system requirements).

Equipment connection setup - Jitter-Slave SMA Probe (Single-Ended Source)
applies to Jitter-Slave measurement.
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Figure 6: Jitter-Slave SMA Cable (Single-Ended Source)

Return Loss Calibration This section describes the equipments required and the connection setup to
perform Return Loss Calibration. (For details, see Minimum system
requirements).

Equipment connection setup - Return Loss Calibration applies to Open
Termination, Short Termination and Load Termination measurement.
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Figure 7: Return Loss Calibration - Open Termination
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Figure 8: Return Loss Calibration - Short Termination
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Figure 9: Return Loss Calibration - Load Termination
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Return Loss Setup This section describes the equipments required and the connection setup to
perform Return Loss Setup. (For details, see Minimum system requirements).

Equipment connection setup - Return Loss Setup applies to Return Loss
measurement

Figure 10: Return Loss Setup
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Transmitter non-linear
distortion SMA Probe
(Differential Source) -

Test2

This section describes the equipments required and the connection setup to
perform Transmitter non-linear distortion SMA Probe (Differential Source) for
2.5GBaseT (Test2). (For details, see Minimum system requirements).

Equipment connection setup - Transmitter non-linear distortion SMA Probe
(Differential Source) for 2.5GBaseT (Test2).

Figure 11: Transmitter non-linear distortion SMA Probe (Differential Source) - Test2
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Transmitter non-linear
distortion SMA Probe

(Single-Ended Source) -
Test2

This section describes the equipments required and the connection setup to
perform Transmitter non-linear distortion SMA Probe (Single-Ended Source) for
2.5GBaseT (Test2). (For details, see Minimum system requirements).

Equipment connection setup - Transmitter non-linear distortion SMA Probe
(Single-Ended Source) for 2.5GBaseT (Test2).

Figure 12: Transmitter non-linear distortion SMA Probe (Single-Ended Source) - Test2
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Prerequisite

Compensate the signal
path

Use the following procedure to compensate the internal signal acquisition path.
Perform this procedure if the ambient temperature has changed more than 5 °C
(9 °F) since you performed the last signal path compensation. Perform the signal
path compensation once a week. Failure to do so may result in the instrument not
meeting warranted performance levels. 

1. Power on and wait for the instrument to complete its warm up period before
continuing with this procedure.

2. Disconnect any probes you have connected to the input channels.

3. Set the instrument to Menu mode.

4. Select Instrument Calibration from the Utilities menu.

5. Note any instructions that appear in the resulting control window.

6. Click Run SPC to begin the procedure. The procedure may take several
minutes to complete.

7. Verify that the Status changes to Compensated after the procedure is
complete. If the Calibration Status field indicates anything other than
Compensated, see Signal Path Compensation Status for information on the
readout and recommended action.

NOTE. When making measurements at vertical scale settings less than or equal to
5 mV, you should perform the signal path compensation at least once a week.
Failure to do so may result in the instrument not meeting warranted performance
levels at those volts/div settings.

Deskew If skew is present between positive and negative channels, then the channels need
to be deskewed before being used for waveform measurements. TekExpress
Ethernet Tx provides support for channel deskew using the following method:

1. Determine what the skew is for each channel.

2. From the TekScope menu, select Vertical > Deskew.

3. In the Deskew/Attenuation window, click the channel (1 – 4) button for the
first channel to be deskewed.

4. Click in the Ch(x) Deskew Time entry field and enter the skew. The skew
can be +ve or –ve.

5. Click the channel button for the next channel and repeat step  4.

6. After entering the skew for all the channels that require it, from the Options
menu in TekExpress Ethernet Tx, select Deskew.
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7. In the Deskew dialog box, select the desired level:

■ Less than 100 mV signal amplitude: Select this if the signal amplitude is
such that the oscilloscope’s vertical setting is less than 100 mV/division.

■ 100 mV or greater signal amplitude: Select this if the signal amplitude is
such that the oscilloscope’s vertical setting is greater than 100 mV/
division.

Figure 13: Deskew

8. Click Read Deskew/Attn.

9. When the status in the dialog box indicates the deskew is finished, click
Close.

Each input channel has its own deskew settings. Deskew compensates individual
channels for probes or cables of different lengths. The instrument applies the
delay values after each completed acquisition. The deskew values are saved as
part of the instrument setup. The deskew values for the selected channel are
retained until you change the probe, you restore a saved setup, or you recall the
factory setup.
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Running tests
Select tests, set acquisition parameters, set configuration parameters, set
preferences parameters, and click Start to run the tests. While tests are running,
you cannot access the Setup or Reports panels. To monitor the test progress,
switch between the Status panel and the Results panel. 

While the tests are running, other applications may display windows in the
background. The TekScope application takes precedence over other applications,
but you can switch to other applications by using Alt + Tab key combination. To
keep the TekExpress Ethernet Tx application on top, select Keep On Top from
the TekExpress Options menu.

The application displays report when the tests execution is complete.

Prerun checklist 1. Make sure that the instruments are warmed up (approximately 20 minutes)
and stabilized.

2. Perform compensation: In the oscilloscope main menu, select Utilities >
Instrument Compensation. Click Help in the compensation window for
steps to perform instrument compensation.
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Saving and recalling test setup

Test setup files overview
Saved test setup information (such as the selected oscilloscope, general
parameters, acquisition parameters, measurement limits, waveforms (if
applicable), and other configuration settings) is saved under the setup name at X:
\Ethernet Tx.

Use test setups to:

■ Run a new session, acquiring live waveforms, using a saved test
configuration.

■ Create a new test setup based on an existing one.

■ View all the information associated with a saved test, including the log file,
the history of the test status as it executed, and the results summary.

■ Run a saved test using saved waveforms.

See also Save a test setup

Open (load) a saved test setup

Save a test setup
You can save a test setup before or after running a test. You can create a test
setup from already opened test setup, or using default test setup. When you select
the default test setup, the parameters are set to the application’s default value.

Select Options > Save Test Setup to save the opened setup.

Select Options > Save Test Setup As to save the setup with different name.
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Open (load) a saved test setup
To Open (load) a saved test setup, do the following:

1. Select Options > Open Test Setup.

2. Select the setup from the list and click Open. Setup files are located at X:
\Ethernet Tx\.

See also Create a test setup using an existing one

Create a test setup from default settings

Create a test setup from default settings
To create a test setup using default settings, follow the steps:

1. Select Options > Default Test Setup. For default test setup, the parameters
are set to the application’s default value.

2. Click application Setup and set the parameters

3. Click application Reports and set the report options

4. Optional: Click Start to run the test and verify that it runs correctly and
captures the specified test information and reports. If it does not, then edit the
parameters and repeat this step until the test runs to your satisfaction

5. Select Options > Save Test Setup. Enter the file name and click Save. The
application saves the file to X:\Ethernet Tx\<session_name>

Create a test setup using an existing one
To create a test setup using an existing one, follow the steps:

1. Select Options > Open Test Setup

2. Select a setup from the list and then click Open

3. Click application Setup and modify the parameters

4. Click application Reports and modify the report options

5. Select Options > Save Test Setup As

6. Enter test setup name, and click Save
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TekExpress Ethernet Tx measurements

Maximum output droop
This section verifies that the transmitter output level does not drop more than the
maximum specified amount.

Required test equipment

Minimum system requirements

Supported Probes

Equipment connection diagram

Inputs

■ DUT shall be configured to transmit test mode 6 waveform

■ If acquisition is single ended, then provide Data+ and Data- waveforms. If
acquisition is differential, then provide differential data waveform as input to
the measurement.

■ REFLEVEL, MIDLEVEL and HYSTERESIS for edge finding

■ START TIME and STOP TIME

■ POPULATION

■ Number of ACQUISITION AVERAGES
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Measurement procedure

1. If acquisition is single ended, then compute differential waveform (scope
math) using acquired single ended signals.

2. Compute edges of differential signal using midlevel and hysteresis dialed by
the user in the user interface.

3. If Droop type is “POSITIVE” then

a. Consider rising edges for further computation. Waveform Edges = rising
edges

Else

a. Consider falling edges for further computation. Waveform Edges =
falling edges

4. For every edge in Waveform Edges,

a. Compute average value of NAVERAGE points around the edge Position
+ start time. This gives High Voltage.

b. Compute average value of NAVERAGE points around the edge Position
+ stop time. This gives Low Voltage.

c. Compute Droop in % = ((High Voltage – Low Voltage)/High Voltage) *
100.

d. Store High Voltage, Low Voltage, Edge Position and Droop in %.

5. Compute Maximum, Minimum, Mean and number of Droops from the
collected result in step  4.

6. Maximum droop in % will be used for comparing with limits given in
specification.

Transmitter timing Jitter-Master
This section verifies that the transmitter timing jitter - master of the PMA is
within the conformance limits.

Required test equipment

Minimum system requirements

Supported Probes

Equipment connection diagram

Inputs

■ DUT shall be configured to transmit test mode 2 waveform

■ If acquisition is single ended, then provide Data+ and Data- waveforms. If
acquisition is differential then provide differential data waveform as input to
measurement.

■ REFLEVEL, MIDLEVEL and HYSTERESIS for edge finding
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■ Acquisition duration

■ Apply Band Pass Filter – Yes or No

Measurement procedure

1. If Acquisition is SINGLE_ENDED then

a. If APPLY FILTER is YES then, APPLY the band pass filter with Fc as
(200 MHz/S) with band width as 20 KHz on single ended signals.

b. Compute Differential signal (scope math) using acquired single ended
signals

Else

a. If APPLY FILTER is YES then, APPLY the band pass filter with Fc as
(200 MHz/S) with band width as 20 KHz on differential signal.

b. Acquire Differential signal

2. Compute edges of differential signal using midlevel and hysteresis dialed by
the user in the user interface.

3. Determine the direction of first edge

a. If first edge direction is rise, then consider only the rising edges for
further computation. Waveform Edges = rising edges

b. If first edge direction is rise, then consider only the falling edges for
further computation. Waveform Edges = falling edges

4. Do a least square fit using Waveform Edges. X being edge number and Y
being edge position.

Compute slope and intercept. Intercept gives starting edge position. Slope
gives ideal duration between Waveform Edges.

Using Slope and Intercept, reconstruct the ideal position of Waveform Edges.

5. For every Waveform Edge, Compute TIE.

TIE = Actual position of Waveform Edges – Ideal position of Waveform
Edges

6. Compute RMS of TIE.

7. RMS of TIE will be used for comparing with limits given in specification
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Transmitter timing Jitter-Slave
This section verifies that the transmitter-slave of the PMA is within the
conformance limits.

Required test equipment

Minimum system requirements

Supported Probes

Equipment connection diagram

Inputs

■ DUT shall be configured to transmit test mode 6 waveform

■ If acquisition is single ended, then provide Data+ and Data- waveforms. If
acquisition is differential then provide differential data waveform as input to
measurement.

■ REFLEVEL, MIDLEVEL and HYSTERESIS for edge finding

■ Acquisition duration

■ Apply Band Pass Filter – Yes or No
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Measurement procedure

1. If Acquisition is SINGLE_ENDED then,

a. If APPLY FILTER is YES, then APPLY the band pass filter with Fc as
(200 MHz/S) with band width as 20 KHz on single ended signals.

b. Compute Differential signal(scope math) using acquired single ended
signals

Else

a. If APPLY FILTER is YES then, APPLY the band pass filter with Fc as
(200 MHz/S) with band width as 20 KHz on differential signal.

b. Acquire Differential signal

2. Compute edges of differential signal using midlevel and hysteresis dialed by
the user in the user interface.

3. Determine the direction of first edge.

a. If first edge direction is rise, then consider only rising edges for further
computation. Waveform Edges = rising edges

b. If first edge direction is fall, then consider only falling edges for further
computation. Waveform Edges = falling edges

4. Do a least square fit using Waveform Edges. X being edge number and Y
being edge position.

Compute slope and intercept. Intercept gives starting edge position. Slope
gives ideal duration between Waveform Edges.

Using Slope and Intercept, reconstruct the ideal position of Waveform Edges.

5. For every Waveform Edge, Compute TIE.

TIE = Actual position of Waveform Edges – Ideal position of Waveform
Edges.

6. Compute RMS of TIE.

7. RMS of TIE will be used for comparing with limits given in specification
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Transmitter Power Spectral Density and Power level
This section verifies that the transmitter Power Spectral Density (PSD) and
transmit power level are within the conformance limits.

Required test equipment

Minimum system requirements

Supported Probes

Equipment connection diagram

Inputs

■ DUT shall be configured to transmit test mode 6 waveform

■ If acquisition is single ended, then provide Data+ and Data- waveforms. If
acquisition is differential then provide differential data waveform as input to
measurement.

■ START FREQUENCY, RESOLUTION BANDWIDTH, STOP
FREQUENCY for configuring SPECTRAL MAGNITUDE MATH function

■ ACQUISITION AVERAGES

■ SMOOTHING AVERAGES – the window size used for smoothing the PSD
curve
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Measurement procedure

1. If acquisition is single ended, then compute differential waveform (scope
math) using acquired single ended signals.

2. Compute the mean of the differential signal, the DC component.

3. Remove the DC component from the differential signal.

MATH2 = Differential signal – Mean (Differential Signal).

Mean is computed using scope measurement.

4. Compute the average of spectral magnitude of MATH2

MATH3 = AVG (SpectralMag (MATH2))

SpectralMag settings are as follows:

■ Center Frequency: STOP FREQUENCY/2 
■ Frequency Span: STOP FREQUENCY
■ Window Type: GAUSSIAN
■ Vertical Axis Scale: Linear
■ MATH3 averages: ACQUISITION AVERAGES
■ Resolution Bandwidth: RESOLUTION BANDWIDTH

■ Gate position = 0 
■ Gate Duration = (2/Resolution Bandwidth in Hz)

Factor of 2 is because of Gaussian window

5. Do a moving average of spectral signal with number of averages equal to
SMOOTHING AVERAGES dialed by user in user interface.

6. Compute linear power spectrum of moving averaged signal. Determine the
area under the linear power spectrum.

7. Compute the offset/correction value.

Offset/correction value = function (Resolution Bandwidth configured by
user, termination resistance of 100 Ohm, dB to dBm conversion factor,
constant factor of 1.05)

Offset/correction value = 10*log10 (dB to dBm conversion factor) –
10*log10 (Resolution Bandwidth) – 10*log10 (termination resistance) +
constant factor

Offset/correction value = 10*log10 (1000) – 10*log10 (Resolution
Bandwidth) – 10*log10 (100) + 1.05 

Offset/correction value = 11.05 – 10*log10 (Resolution Bandwidth)

8. Power in dBm = 10*log10(Area under the linear power spectrum) + Offset
value

9. Convert power spectrum in linear scale to dB scale.

10. Compute power spectrum in dBm/Hz
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Power Spectrum in dBm/Hz = power spectrum in dB + Offset value

11. Power in dBm is compared with limits given in specification

12. PSD curve is compared with limit curve given in specification

 

 

Transmitter clock frequency
This section verifies that the frequency of the transmit clock is within the
conformance limits.

Required test equipment

Minimum system requirements

Supported Probes

Equipment connection diagram

Inputs

■ DUT shall be configured to transmit test mode 6 waveform

■ If acquisition is single ended, then provide Data+ and Data- waveforms. If
acquisition is differential then provide differential data waveform as input to
measurement.

■ REFLEVEL, MIDLEVEL and HYSTERESIS for edge finding.
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Measurement procedure

1. If acquisition is single ended, then compute differential waveform (scope
math) using acquired single ended signals.

2. Compute edges of differential signal using midlevel and hysteresis dialed by
the user in the user interface.

3. Compute edge to edge duration

4. Determine the mean, maximum and minimum edge to edge duration

5. Determine the mean deviation, maximum deviation and minimum deviation
in terms of ppm from the nominal frequency (edge to edge frequency of test
mode 2 signal).

Mean deviation in terms of ppm = ((1/mean edge to edge duration) –
Expected edge to edge period)*1e6/Expected edge to edge period

Maximum deviation in terms of ppm = ((1/minimum edge to edge duration) –
Expected edge to edge period)*1e6/ Expected edge to edge period

Minimum deviation in terms of ppm = ((1/maximum edge to edge duration) –
Expected edge to edge period)*1e6/ Expected edge to edge period

6. Mean deviation in ppm is compared with limits.

Transmitter non-linear distortion
This section verifies that the output of the transmitter conforms to the transmitter
linearity requirements.

Required test equipment

Minimum system requirements

Supported Probes

Equipment connection diagram

Inputs

■ DUT shall be configured to transmit test mode 6 waveform

■ If acquisition is single ended, then provide Data+ and Data- waveforms. If
acquisition is differential then provide differential data waveform as input to
measurement.

■ START FREQUENCY, RESOLUTION BANDWIDTH, STOP
FREQUENCY for configuring SPECTRAL MAGNITUDE MATH function

■ ACQUISITION AVERAGES
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Measurement procedure (10GBase-T, 5GBase-T, and 2.5GBase-T)

1. If acquisition is single ended, then compute differential waveform (scope
math) using acquired single ended signals.

2. Compute the average of spectral magnitude of differential signal

MATH3 = AVG (SpectralMag (Differential Signal))

SpectralMag settings are as follows:

■ Center Frequency: STOP FREQUENCY/2 

■ Frequency Span: STOP FREQUENCY

■ Window Type: GAUSSIAN

■ Vertical Axis Scale: dB

■ MATH3 averages: ACQUISITION AVERAGES

■ Resolution Bandwidth: RESOLUTION BANDWIDTH

■ Gate position = 0 

■ Gate Duration = (2/Resolution Bandwidth in Hz)

Factor of 2 is because of Gaussian window

3. Determine the peaks (two) and their corresponding frequencies in the
spectrum.

4. Check whether peaks correspond to the tone pair (based on the sub-test
selected). If not then exit the test.

5. Intermodulation frequencies for above found peak frequencies and their
corresponding amplitudes up to 20th order are found using the spectrum

6. Determine the intermodulation distortion.

Intermodulation distortion = Sum (Amplitudes of IMF for above found peak
frequencies up to 5th order) / Sum (Amplitudes of peak frequencies)

Intermodulation distortion in % = Intermodulation distortion * 100 

7. Spurious Frequency Dynamic Range (SFDR) = Minimum (Amplitudes of
peak frequencies) – Maximum (Amplitudes of IMF).

8. SFDR is compared with limits given in specification.
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Transmitter non-linear distortion (Test2)
This section verifies that the output of the transmitter conforms to the transmitter
linearity requirements.

Required test equipment

Minimum system requirements

Supported Probes

Equipment connection diagram

Inputs

■ DUT shall be configured to transmit test mode 6 waveform

■ If acquisition is single ended, then provide Data+ and Data- waveforms. If
acquisition is differential then provide differential data waveform as input to
measurement.

■ START FREQUENCY, RESOLUTION BANDWIDTH, STOP
FREQUENCY for configuring SPECTRAL MAGNITUDE MATH function

■ ACQUISITION AVERAGES

Measurement procedure (2.5GBase-T - Test2)

Figure 14: Transmitter Test fixture 4 for linearity measurement of 2.5GBaseT with Sine wave
injection

1. If acquisition is single ended, then compute differential waveform (scope
math) using acquired single ended signals.

2. For each pair of transmitter fixtures, inject 45 MHz signal having amplitude
of 7 db below the peak of the transmitter at the MDI.

3. Feed the 45 MHz signal along with differential input signal as separate inputs
to a Power splitter and take the mixed signal as output.

4. Compute the average of spectral magnitude of differential signal

MATH3 = AVG (SpectralMag (Differential Signal))
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SpectralMag settings are as follows:

■ Center Frequency: STOP FREQUENCY/2 

■ Frequency Span: STOP FREQUENCY

■ Window Type: GAUSSIAN

■ Vertical Axis Scale: dB

■ MATH3 averages: ACQUISITION AVERAGES

■ Resolution Bandwidth: RESOLUTION BANDWIDTH

■ Gate position = 0 

■ Gate Duration = (2/Resolution Bandwidth in Hz)

Factor of 2 is because of Gaussian window

■ Determine the peaks (two) and their corresponding frequencies in the
spectrum.

5. Determine the peaks (two) and their corresponding frequencies in the
spectrum.

6. Check whether peaks correspond to the tone pair (based on the sub-test
selected). If not then exit the test.

7. Intermodulation frequencies for above found peak frequencies and their
corresponding amplitudes up to 20th order are found using the spectrum

8. Determine the intermodulation distortion.

Intermodulation distortion = Sum (Amplitudes of IMF for above found peak
frequencies up to 5th order) / Sum (Amplitudes of peak frequencies)

Intermodulation distortion in % = Intermodulation distortion * 100 

9. Spurious Frequency Dynamic Range (SFDR) = Minimum (Amplitudes of
peak frequencies) – Maximum (Amplitudes of IMF).

10. SFDR is compared with limits given in specification.

TekExpress Ethernet Tx measurements  

66  TekExpress® Ethernet Tx Printable Application Help



MDI return loss
This section verifies that the return loss of the DUT is within conformable limits.

Required test equipment

Minimum system requirements

Supported Probes

Equipment connection diagram

Return loss is a measure of the signal power that is reflected due to the
impedance mismatch.

Return loss = 20*log10 (Reflected / Incident)

Return loss describes the degree of mismatch between a load and characteristic
impedance of a transmission system.

Return loss measurement setup involves fixture, AWG, AWG signal, probes,
DUT and oscilloscope. Return loss measurement can be divided into 3 steps

■ Return Loss calibration

■ Computation of error coefficients

■ Computation of return loss

1. Return Loss Calibration

Inputs

■ Wide band calibration signal transmitted from AWG.

■ Let RJ45 patch chord be connected to open impedance.

■ Waveform acquired using a probe connected to input of reference
impedance – waveform1

■ Waveform acquired using a probe connected to input of DUT cable under
test – waveform2

■ ACQUISITION AVERAGES → Used for averaging acquired time
domain signal

■ SMOOTHING AVERAGES → Used internally by C# module for
smoothing the return loss curve
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Calibration procedure

a. Incident Signal = Waveform2 + (Waveform1 – Waveform2) =
Waveform1

b. Reflected Signal = Waveform2 – (Waveform1 – Waveform2) =
2*Waveform2 – Waveform1

c. Compute FFT of incident signal and FFT reflected signal

Real Part of FFT of Incident Signal = (SpectralReal (Waveform1))

Imaginary Part of FFT of Incident Signal = (SpectralImag (Waveform1))

Real Part of FFT of Reflected Signal = (SpectralReal (2*Waveform2 –
Waveform1))

Imaginary Part of FFT of Reflected Signal = (SpectralImag
(2*Waveform2 – Waveform1))

d. Compute Gamma (return loss without error correction) as complex
division of reflected signal by incident signal

Gamma = Complex (Real Part of FFT of Reflected Signal, Imaginary
Part of FFT of Reflected Signal) / Complex (Real Part of FFT of Incident
Signal, Imaginary Part of FFT of Incident Signal)

e. Repeat steps  1.a to  1.d with waveform1 and waveform2 captured using
short and load impedance (100 Ohm).

2. Computation of Error Coefficients

Inputs

a. Gamma (Complex) values computed with different loads – open, short
and load (Γm1, Γm2, Γm3)

Procedure/Steps:

a. Compute error coefficients a, b and c using Γm1, Γm2 and Γm3 values

 

 

3. Computation of Return Loss
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Inputs

a. Wide band calibration signal transmitted from AWG.

b. Let RJ45 patch chord be connected to DUT.

c. Waveform acquired using a probe connected to input of reference
impedance – waveform1

d. Waveform acquired using a probe connected to input of DUT cable under
test – waveform2

e. Error coefficients a, b and c

f. ACQUISITION AVERAGES → Used for averaging acquired time
domain signal

g. SMOOTHING AVERAGES → Used internally by C# module for
smoothing the return loss curve
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Procedure/Steps:

a. Incident Signal = Waveform2 + (Waveform1 – Waveform2) =
Waveform1

b. Reflected Signal = Waveform2 – (Waveform1 – Waveform2) =
2*Waveform2 – Waveform1

c. Compute FFT of incident signal and FFT reflected signal

Real Part of FFT of Incident Signal = (SpectralReal (Waveform1))

Imaginary Part of FFT of Incident Signal = (SpectralImag (Waveform1))

Real Part of FFT of Reflected Signal = (SpectralReal (2*Waveform2 –
Waveform1))

Imaginary Part of FFT of Reflected Signal = (SpectralImag
(2*Waveform2 – Waveform1))

d. Compute Gamma (return loss/reflection coefficient without error
correction) as complex division of reflected signal by incident signal
(Γm)

Gamma = Complex (Real Part of FFT of Reflected Signal, Imaginary
Part of FFT of Reflected Signal) / Complex (Real Part of FFT of Incident
Signal, Imaginary Part of FFT of Incident Signal)

e. Compute error corrected reflection coefficient

 

 
f. Compute return loss in dB scale as Return Loss = 20*log10 (Absolute

(ΓA))
g. Re-normalize the return loss to 85 Ohm and 115 Ohm.

 

 

ZA → 100 Ohm

Z1 → 85 Ohm or 115 Ohm

ΓA → Reflection coefficient with 100 Ohm impedance
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Return Loss at Z1 Ohm = 20*log10 (Absolute (Gamma at Z1 Ohm))

h. Return Loss curve is compared with limits given in specification.
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SCPI commands

About SCPI command
You can use Standard Commands for Programmable Instruments (SCPI) to
communicate with the TekExpress application.

Socket configuration for SCPI commands
This section describes the steps for TCPIP socket configuration and TekVISA
configuration to execute the SCPI commands.

TCPIP socket
configuration

1. Click Start > Control Panel > System and Security > Windows Firewall >
Advanced settings
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2. In Windows Firewall with Advanced Security menu, select Windows
Firewall with Advanced Security on Local Computer > Inbound Rules
and click New Rule…
 

 
3. In New Inbound Rule Wizard menu

a. Select Port and click Next
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b. Select TCP as rule apply and enter 5000 for Specific local ports and
click Next
 

 
c. Select Allow the connection and click Next
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d. Select Domain, Private, Public and click Next
 

 
e. Enter Name, Description (optional), and click Finish
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4. Check whether the Rule name is displayed in Windows Firewall with
Advanced Security menu > Inbound Rules
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TekVISA configuration 1. Click Start > All Programs > TekVISA > OpenChoice Instrument
Manager
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2. Click Search Criteria. In Search Criteria menu, click LAN to Turn-on.
Select Socket from the drop-down list, enter the IP address of the

TekExpress device in Hostname and type Port as 5000. Click  to
configure the IP address with Port.

Enter the Hostname as 127.0.0.1 if the TekVISA and TekExpress application
are in the same system, else enter the IP address of the TekExpress
application system.
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3. Click Search to setup the TCPIP connection with the host. Check whether
the TCPIP host name is displayed in OpenChoice Instrument Manager >
Instruments
 

 
4. Double-click OpenChoice Takler Listener and enter the Command *IDN?

in command entry field and click Query. Check that the Operation is
successful and Talker Listener Readout displays the Command / Data.
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TEKEXP:*IDN?
This command queries the active TekExpress application name running on the
scope. 

Syntax TEKEXP:*IDN?\n

Inputs NA

Outputs Returns active TekExpress application name running on the scope

TIP. Click here for examples.

TEKEXP:*OPC?
This command queries the execution status of the last executed command. 

Syntax TEKEXP:*OPC?\n

Inputs NA

Outputs 0 - last command execution is not complete

1 - last command execution is complete

TIP. Click here for examples.
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TEKEXP:ACQUIRE_MODE
This command sets the acquire mode as live or pre-recorded.

Syntax TEKEXP:ACQUIRE_MODE {LIVE | PRE-RECORDED}\n

Inputs {LIVE | PRE-RECORDED}

Outputs NA

TIP. Click here for examples.

TEKEXP:ACQUIRE_MODE?
This command queries the acquire mode type.

Syntax TEKEXP:ACQUIRE_MODE?\n

Inputs NA

Outputs {LIVE | PRE-RECORDED}

TIP. Click here for examples.
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TEKEXP:EXPORT
This command returns all the bytes of data to the specified file. 

Syntax Outputs
TEKEXP:EXPORT REPORT\n Returns the report file in bytes
TEKEXP:EXPORT WFM,"<FileName>"\n Returns the specified waveform file in bytes
TEKEXP:EXPORT IMAGE,"<FileName>"\n Returns the specified image file in bytes

Inputs FileName - Specifies the file name

TIP. Click here for examples.

TEKEXP:INFO?
This command queries the information about the file(s).

Syntax Outputs
TEKEXP:INFO? REPORT\n <ReportFileSize>,"<ReportFileName.mht>"
TEKEXP:INFO? WFM\n <WfmFile1Size>,"<WfmFileName1.wfm>";<Wfm

File2Size>,"<WfmFileName2.wfm>";...
TEKEXP:INFO? IMAGE\n <Image1FileSize>,"<Image1FileName>";<Image

2FileSize>,"<Image2FileName>" ;...

TIP. Click here for examples.
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TEKEXP:INSTRUMENT
This command sets the value for the selected instrument type. 

Syntax TEKEXP:INSTRUMENT "<InstrumentType>",<Value>"\n

Inputs InstrumentType

Value

TIP. Check Command parameters list for InstrumentType and Value parameters.

Outputs NA

TIP. Click here for examples.

TEKEXP:INSTRUMENT?
This command queries the instrument selected for the specified instrument type. 

Syntax TEKEXP:INSTRUMENT? "<InstrumentType>"\n

Inputs InstrumentType

TIP. Check Command parameters list for InstrumentType parameters.
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Outputs Returns the instrument selected for the specified instrument type

TIP. Click here for examples.

TEKEXP:LASTERROR?
This command queries the last error string occurred for the current TCP session.
If there are no errors since startup, or since the last call to
TEKEXP:LASTERROR?\n, this command returns an empty string.

Syntax TEKEXP:LASTERROR?\n

Inputs NA

Outputs <string>

TIP. Click here for examples.

TEKEXP:LIST?
This command queries the list of available device, suite, test, version or
instrument. 

Syntax Outputs
TEKEXP:LIST? DEVICE\n Returns the list of available device(s) as comma

separated values.
TEKEXP:LIST? SUITE\n Returns the list of available suite(s) as comma

separated values.
TEKEXP:LIST? TEST\n Returns the list of available test(s) as comma

separated values.
TEKEXP:LIST? VERSION\n Returns the list of available version(s) as comma

separated values.
TEKEXP:LIST?
INSTRUMENT,"<InstrumentType>"\n

Returns the list of available instruments' for the
given Instrument type as comma separated
values.
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NOTE. This command returns the list of items within double quotes (""). Iterate
the receive procedure until the list ends with double quotes otherwise the next
query commands won’t work as expected.

Inputs InstrumentType

TIP. Check Command parameters list for InstrumentType parameters.

TIP. Click here for examples.

TEKEXP:MODE
This command sets the execution mode as compliance or user defined. 

Syntax TEKEXP:MODE {COMPLIANCE | USER-DEFINED}\n

Inputs {COMPLIANCE | USER-DEFINED}

Outputs NA

TIP. Click here for examples.
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TEKEXP:MODE?
This command queries the execution mode type. 

Syntax TEKEXP:MODE?\n

Inputs NA

Outputs {COMPLIANCE | USER-DEFINED}

TIP. Click here for examples.

TEKEXP:POPUP
This command sets the response to the active popup shown in the application.

Syntax TEKEXP:POPUP “<PopupResponse>”\n

Inputs PopupResponse

Outputs NA

TIP. Click here for examples.
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TEKEXP:POPUP?
This command queries the active popup information shown in the application.

Syntax TEKEXP:POPUP?\n

Inputs NA

Outputs Returns the active popup information in the application.

TIP. Click here for examples.

TEKEXP:REPORT
This command generates the report for the current session. 

Syntax TEKEXP:REPORT GENERATE\n

Inputs GENERATE

Outputs NA

TIP. Click here for examples.
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TEKEXP:REPORT?
This command queries the queried header field value in the report.

Syntax TEKEXP:REPORT? “<HeaderField>”\n

Inputs HeaderField - Specifies to return the measured value for the indicated test.

TIP. Check Report for HeaderField parameters.

Outputs Returns the queried header field value in the report

TIP. Click here for examples.

TEKEXP:RESULT?
This command queries the result available in report summary/details table.

Syntax Outputs
TEKEXP:RESULT? "<TestName>"\n Return Pass/Fail status of the test.
TEKEXP:RESULT?
"<TestName>","<ColumnName>"\n

Returns all the row values of the specified
column for the test.

TEKEXP:RESULT?
"<TestName>","<ColumnName>",<RowNumber
>\n

Returns the column value for the specified row
number  1

1 Row number starts from zero.
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Inputs TestName - Specifies the name of the test for which to obtain the test result
value.

ColumnName - Specifies the column name for the measurement

RowNumber - Specifies the row number of the measurement

TIP. Check Results panel for TestName, ColumnName, and RowNumber
parameters.

TIP. Click here for examples.

TEKEXP:SELECT
This command selects the device, suite, version, or test. 

Syntax TEKEXP:SELECT <string1>,<string2>,<string4>\n

TEKEXP:SELECT TEST,<string3>,<string4>\n

Inputs <string1> = {DEVICE | SUITE | VERSION}

<string2> = {DeviceName | SuiteName | VersionName}

<string3> = {“<TestName>"| ALL| REQUIRED }

<string4> = {TRUE | FALSE}

TIP. Check Command parameters list for DeviceName, SuiteName, VersionName,
and TestName parameters.

TIP. Click here for examples.
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Outputs NA

TEKEXP:SELECT?
This command queries the name of the selected device, suite, version, or test. 

Syntax TEKEXP:SELECT? {DEVICE | SUITE | TEST | VERSION}\n

Inputs {DEVICE | SUITE | TEST | VERSION}

Outputs Returns the name of the selected device, suite, version, or test.

TIP. Click here for examples.

TEKEXP:SETUP
This command sets the value of the current setup.

Syntax Outputs
TEKEXP:SETUP DEFAULT\n Restore to default Setup
TEKEXP:SETUP OPEN,"<SessionName>"\n Open the session
TEKEXP:SETUP SAVE\n Save the session
TEKEXP:SETUP SAVE,"<SessionName>"\n Save the session

Inputs SessionName - The name of the session

TIP. Click here for examples.
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TEKEXP:STATE
This command sets the execution state of the application.

Syntax TEKEXP:STATE {RUN | STOP | PAUSE | RESUME}\n

Inputs {RUN | STOP | PAUSE | RESUME}

Outputs NA

TIP. Click here for examples.

TEKEXP:STATE?
This command queries the current setup state. 

Syntax Outputs
TEKEXP:STATE? RUNNING | PAUSED | WAIT | ERROR | READY

| STOPPED
TEKEXP:STATE? SETUP SAVED | NOT_SAVED

TIP. Click here for examples.
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TEKEXP:VALUE
This command sets the value of parameters of type General, Acquire, Analyze, or
DUTID. 

Syntax TEKEXP:VALUE GENERAL,"<ParameterName>",“<Value>”\n

TEKEXP:VALUE ACQUIRE,“<TestName>","<AcquireType>",
"<ParameterName>",“<Value>”\n

TEKEXP:VALUE ANALYZE,“<TestName>","<ParameterName>".“<Value>”
\n

TEKEXP:VALUE DUTID,“<Value>”\n

Inputs ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

Value - Specifes the value to set

TIP. Check Command parameters list for ParameterName, AcquireType, and
Value parameters.

Outputs NA

TIP. Click here for examples.
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TEKEXP:VALUE?
This command queries the value of the parameter for type General, Acquire,
Analyze, or DUTID.

Syntax Outputs
TEKEXP:VALUE?
GENERAL,"<ParameterName>"\n

Returns the value of Parameter for type
GENERAL

TEKEXP:VALUE? ACQUIRE,“<TestName>",
"<AcquireType>","<ParameterName>"\n

Returns the value of Parameter for type
ACQUIRE

TEKEXP:VALUE? ANALYZE,
“<TestName>","<ParameterName>"\n

Returns the value of Parameter for type
ANALYZE

TEKEXP:VALUE? DUTID\n Returns the DUTID value

Inputs ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

TIP. Check Command parameters list for ParameterName and AcquireType
parameters.

Outputs Returns the value of Parameter for type GENERAL | ACQUIRE | ANALYZE |
DUTID.

TIP. Click here for examples.
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Command parameters list
This section provides the parameters list for the SCPI commands.

TekExpress Ethernet Tx
command parameters

Parameters Description
InstrumentType Specifies the instrument type.

Valid values are:

■ AWG

■ AFG

■ Real Time Scope

Value Specifies the value parameters.

■ For InstrumentType, valid values are:

■ Do not use

■ MSO71254C ( GPIB8::1::INSTR )

■ For DUTID, valid value is:

■ Comment

DeviceName Specifies the device name. Valid value is Ethernet Tx
SuiteName Specifies the suite name.

Valid values are:

■ 10GBASE-T

■ 5GBASE-T

■ 2.5GBASE-T
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Parameters Description
VersionName Specifies the version name. Valid value is Spec 1.0
TestName Specifies the test measurement name.

Valid values are:

■ Maximum Output Droop

■ Power Spectrum Density

■ Tone-1 

■ Tone-2 

■ Tone-3 

■ Tone-4 

■ Tone-5 

■ Clock Frequency

■ Jitter Master

■ Jitter Slave

■ Open Termination

■ Short Termination

■ Load Termination

■ Return Loss

ParameterName and Value for General, Acquire and Analyze

Specifies the ParameterName and Value for General, Acquire and Analyze. The
configuration parameters available are not same for measurements.

Table 16: ParameterName and Value for General

ParameterName Value
Report Update Mode ■ New

■ Append

■ Replace

Auto increment report name if
duplicate

TRUE or FALSE

Include Pass/Fail Results
Summary

TRUE or FALSE

Include Detailed Results TRUE or FALSE
Include Plot Images TRUE or FALSE
Include Setup Configuration TRUE or FALSE
Include User Comments TRUE or FALSE
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ParameterName Value
Save As Type ■ Web Archive (*.mht;*.mhtml)

■ PDF (*.pdf;)

View Report After Generating TRUE or FALSE
Report Group Mode ■ Test Name

■ Lane Name

■ Test Result

■ Equalization

Create report at the end ■ Included

■ Excluded

DUTID Comment User comment
Number of retries for instrument
IO errors

0 to 5 

Run Test More than Once TRUE or FALSE
Number of Runs 1 to 200 
On Failure Rerun TRUE or FALSE
Number of Reruns On Failure 1 to 100 
Time between retries (seconds) 5 to 60 
Timer Warning Info Message
Popup ■ "True"

■ "FALSE"

Timer Warning Info Message
Popup Duration

0 to 20 

Timer Error Message Popup ■ "True"

■ "False"

Timer Error Message Popup
Duration

0 to 20 

On Failure Stop and Notify TRUE or FALSE
Specification Details ■ IEEE P802.3bz, Section 16; NBASE-T Spec Draft 2.3 

Probing Type ■ SINGLE ENDED

■ Differential

Link Widths ■ 1 Lane

■ 2 Lanes

■ 3 Lanes

■ 4 Lanes
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ParameterName Value
Signal Validation ■ Prompt me if Signal Validation Fails

■ Skip Test if Signal Validation Fails

■ Use signal as is - Don't Validate

Lane A Connected to:Lane
A:Differential

■ CH1
■ CH2
■ CH3
■ CH4

Lane B Connected to:Lane
B:Differential
Lane C Connected to:Lane
C:Differential
Lane D Connected to:Lane
D:Differential
Lane A Connected to:Lane A+:
Single Ended
Lane A Connected to:Lane A-:
Single Ended
Lane B Connected to:Lane B+:
Single Ended
Lane B Connected to:Lane B-:
Single Ended

Table 17: ParameterName and Value for Acquire

Test Name AcquireType ParameterName Value
Maximum Output
Droop

Maximum Output
Droop-Acquisition

Population 100 to 5000 (units - clock cycles)

Power Spectrum
Density

Power Spectrum
Density-Acquisition

AcquisitionAverage 2 to 256 

Tone-1 Tone-1-Acquisition AcquisitionAverage 2 to 100 
Tone-2 Tone-2-Acquisition AcquisitionAverage 2 to 100 
Tone-3 Tone-3-Acquisition AcquisitionAverage 2 to 100 
Tone-4 Tone-4-Acquisition AcquisitionAverage 2 to 100 
Tone-5 Tone-5-Acquisition AcquisitionAverage 2 to 100 
Clock Frequency Clock Frequency-

Acquisition
Population 10000 to 2000000 (clock cycles) for data rate

- 10G
100 to 2000000 (clock cycles) for data rate -
5G and 2.5G

Jitter Master Jitter Master-
Acquisition

AcquisitionDuration 0.1 ms to 10 ms

Jitter Slave Jitter Slave-
Acquisition

AcquisitionDuration 0.1 to 10 

Open Termination Open Termination-
Acquisition

AcquisitionAverage 2 to 128 
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Test Name AcquireType ParameterName Value
Short Termination Short Termination-

Acquisition
AcquisitionAverage 2 to 128 

Load Termination Load Termination-
Acquisition

AcquisitionAverage 2 to 128 

Return Loss Return Loss-
Acquisition

AcquisitionAverage 0 to 10 2 to 1280 to 10 

Table 18: ParameterName and Value for Analyze

Test Name ParameterName Value
Maximum Output Droop RefLevel ■ Percentage

■ Absolute

MidLevel If Ref Level is Percentage then 20 to 80 
If Ref Level is Absolute then -10 mV to 10 mV

Hysteresis If Ref Level is Percentage then 2 to 20 
If Ref Level is Absolute then -2 to 2 

StartTime 5 ns to 15 ns
EndTime ■ For 10GBASE-T, 85 ns to 95 ns

■ For 5GBASE-T, 160 ns to 180 ns

■ For 2.5GBASE-T, 320 ns to 340 ns

Power Spectrum Density StartFrequency 1 MHz to 1500 MHz
StopFrequency 1600 MHz to 4000 MHz
ResolutionBandwidth 1 MHz to 5 MHz
PowerLevelStartFrequency 1 MHz to 1500 MHz
PowerLevelStopFrequency 1600 MHz to 4000 MHz
Smoothing Average 1 to 100 

Tone-1 StartFrequency 1 kHz to 30000 kHz
StopFrequency 350000 kHz to 800000 kHz
ResolutionBandwidth 20 kHz to 500 kHz

Tone-2 StartFrequency 1 kHz to 30000 kHz
StopFrequency 350000 kHz to 800000 kHz
ResolutionBandwidth 20 kHz to 500 kHz

Tone-3 StartFrequency 1 kHz to 30000 kHz
StopFrequency 350000 kHz to 800000 kHz
ResolutionBandwidth 20 kHz to 500 kHz

Tone-4 StartFrequency 1 kHz to 30000 kHz
StopFrequency 350000 kHz to 800000 kHz
ResolutionBandwidth 20 kHz to 500 kHz

 SCPI commands

TekExpress® Ethernet Tx Printable Application Help 99



Test Name ParameterName Value
Tone-5 StartFrequency 1 kHz to 30000 kHz

StopFrequency 350000 kHz to 800000 kHz
ResolutionBandwidth 20 kHz to 500 kHz

Clock Frequency RefLevel ■ Percentage

■ Absolute

MidLevel If Ref Level is Percentage then 20 to 80 
If Ref Level is Absolute then -10 mV to 10 mV

Hysteresis If Ref Level is Percentage then 2 to 20 
If Ref Level is Absolute then 0 mV to 4 mV

Jitter Master RefLevel ■ Percentage

■ Absolute

MidLevel If Ref Level is Percentage then 20 to 80 
If Ref Level is Absolute then -10 mV to 10 mV

Hysteresis If Ref Level is Percentage then 2 to 20 
If Ref Level is Absolute then 0 mV to 4 mV

Jitter Slave RefLevel ■ Percentage

■ Absolute

MidLevel If Ref Level is Percentage then 20 to 80 
If Ref Level is Absolute then -10 mV to 10 mV

Hysteresis If Ref Level is Percentage then 20 to 80 
If Ref Level is Absolute then 0 mV to 4 mV

Open Termination SmoothingAverage 1 to 10 
Short Termination SmoothingAverage 1 to 10 
Load Termination SmoothingAverage 1 to 10 
Return Loss SmoothingAverage 1 to 10 

Examples
This section provides the examples for the SCPI commands.

SCPI commands  

100  TekExpress® Ethernet Tx Printable Application Help



Index
A
Acquire parameters

including in test reports, 34
viewing in reports, 36

Acquisition tab, 24
Analysis options, 29
Application panels overview, 12
Application version (show), 8

B
Button

clear log, 30
Email settings, 29
save, 30

C
Compensate the signal path, 50
Configuration tab, 20
Configuration tab parameter

instruments detected, 26
Configuration tab parameters

global settings, 26
Connected instruments

searching for, 17
Connection requirements, 39
Create a test setup from default settings, 54
Create a test setup using an existing one, 54

D
DUT ID, 22
DUT parameter

device, 22
device profile, 22
optical module settings, 22
optical power, 22

DUT type
device, 22

DUT-instrument setup, 39

E
Email notification and setup, 19

Equipment setup, 39
Extensions, file names, 10

F
File name extensions, 10

G
GPIB, 17

H
Help conventions, 2

I
Installing the software

TekExpress Ethernet Tx Solution, 8
Instrument-DUT setup, 39
Instruments

discovering connected, 17
viewing connected, 17

Instruments detected, 26

K
Keep on top, 11

L
LAN, 17
License agreement (show), 8
Live waveforms, 22
Loading a test setup, 54
Log view

save file, 30

M
Maximum output droop, 55
Menus

Options, 15
Minimum system requirements, 5
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My TekExpress folder
files stored in, 33

N
Names, file extensions, 10
Non-VISA, 17

O
Opening a saved test setup, 54
Options menu

Instrument control settings, 17
keep on top, 11

Oscilloscope compensation, 50

P
Panels, 12
Pattern, 22
Pattern type, 22
Preferences menu, 32
Preferences tab

send an Email, 29
setup panel, 29

R
Recalling a test setup, 54
Recommended power splitter, 6
Recommended probes, 6
Related documentation, 1
Report contents, 37
Report name, 35
Report options, 34
Report sections, 36
Reports

receiving in email notifications, 19
Reports panel, 12, 33
Resource file, 11
Results panel

summary of test results, 32
test name, 32

Running tests, 52

S
Save log file, 30

Saving tests, 33
Schematic button (DUT-instrument setup), 39
SCPI commands

Command parameters list, 95
Examples, 100
TEKEXP׃*IDN?, 81
TEKEXP׃*OPC?, 81
TEKEXP׃ACQUIRE_MODE, 82
TEKEXP׃ACQUIRE_MODE?, 82
TEKEXP׃EXPORT, 83
TEKEXP׃INFO?, 83
TEKEXP׃INSTRUMENT, 84
TEKEXP׃INSTRUMENT?, 84
TEKEXP׃LASTERROR?, 85
TEKEXP׃LIST?, 85
TEKEXP׃MODE, 86
TEKEXP׃MODE?, 87
TEKEXP׃POPUP, 87
TEKEXP׃POPUP?, 88
TEKEXP׃REPORT, 88
TEKEXP׃REPORT?, 89
TEKEXP׃RESULT?, 89
TEKEXP׃SELECT, 90
TEKEXP׃SELECT?, 91
TEKEXP׃SETUP, 91
TEKEXP׃STATE, 92
TEKEXP׃STATE?, 92
TEKEXP׃VALUE, 93
TEKEXP׃VALUE?, 94

Search for connected instruments, 17
Selecting test report contents, 34
Selecting tests, 23
Serial, 17
Session folders and files, 33
Setting up equipment, 39
Setup

acquisition tab, 24
Setup files, 53
Setup panel

DUT parameter, 20
preferences tab, 20
test selection, 20

Signal conditioning
bandwidth, 22

Index  
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filter, 22
Software installation

TekExpress Ethernet Tx Solution, 8
Source, 22
Status panel

log view, 30
message history, 30
test status tab, 30

System requirements, 5

T
Technical support, 2
Tek Link, 17
Test reports, 36
Test results

send by email, 19
Test selection

Clock Frequency, 23
Jitter Master, 23
Jitter Slave, 23
Linearity, 23
Maximum Output Droop, 23
Power Spectrum Density, 23
Return Loss, 23

Test selection controls, 23
Test setup files, 33, 53
Test setups

load, 54

open, 54
recalling, 54

Test status
acquire status, 30
analysis status, 30
auto scroll, 30

Test-related files, 33
Tests

running, 52
selecting, 23

U
USB, 17
User Comments

including in reports, 36

V
View a report, 36
View application license agreement, 8
View application software version, 8
VXI, 17

W
Waveform files

locating and storing, 33
Wavelength, 22

 Index
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