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Welcome

The FRL (Fixed Rate Link) is a video signaling technology supported in the
HDMI 2.1 Specification. FRL supports up to 4 K at 120 Hz and 8 K at 60 Hz -
for compressed and uncompressed video content. FRL supports only predefined
discrete data rates (3 Gbps, 6 Gbps, 8 Gbps, 10 Gbps, and 12 Gbps) on each of its
4 lanes which means that the FRL supports post encoded link bandwidth of up to
48 Gbps.

The TekExpress FRL compliance application gives you the tools to easily run the
High Definition Multimedia Interface (HDMI) tests under the HDMI compliance
test specification 2.1. It displays a complete and reliable solution for quick
testing.

The TekExpress FRL supports the following Source and Sink measurements:
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Source measurements

1. HFR1-1: DC Common Mode Voltage

2. HFR1-2: Vse_max, Vse_min

3. HFR1-3: Rise/Fall Slew Rate

4. HFR1-4: Inter-Pair Skew

5. HFR1-5: FRL Rates

6. HFR1-6: Data Jitter (Rj)

7. HFR1-7: Data Eye Diagram

8. HFR1-8: AC Common Mode Voltage

9. HFR1-9: FFE Monotonicity-Method 1 

10. HFR1-9: FFE Monotonicity-Method 2 

Sink measurements

1. HFR2-1: Max Differential Swing Tolerance

2. HFR2-2: Intra-Pair Skew

3. HFR2-3: Inter-Pair Skew

4. HFR2-4: Minimum Link Rate Tolerance

5. HFR2-5: Jitter Tolerance
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Getting help and support

Related documentation
The following documentation is available as part of the TekExpress® FRL
application.

Table 1: Product documentation

Item Purpose Location
Help Application operation

and User Interface help

PDF of the help Printable version of the
compiled help

PDF file that ships with FRL application
distribution (TekExpress FRL-Automated-Test-
application-Software-Printable-Help-EN-US.pdf).

See also Technical support on page 2
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Conventions
Help uses the following conventions:

■ The term "Application," and "Software" refers to the TekExpress FRL
application.

■ The term “DUT” is an abbreviation for Device Under Test.

■ The term “select” is a generic term that applies to the two methods of
choosing a screen item (button, control, list item): using a mouse or using the
touch screen.

Table 2: Icon descriptions

Icon Meaning
This icon identifies important information.

This icon identifies conditions or practices that could result in loss
of data.

This icon identifies additional information that will help you use
the application more efficiently.

Technical support
Tektronix values your feedback on our products. To help us serve you better,
please send us your suggestions, ideas, or comments on your application or
oscilloscope. Contact Tektronix through mail, telephone, or the Web site, 
www.tek.com.

When you contact Tektronix Technical Support, please include the following
information (be as specific as possible):

General Information ■ All instrument model numbers
■ Hardware options, if any
■ Probes used
■ Your name, company, mailing address, phone number, FAX number
■ Please indicate if you would like to be contacted by Tektronix about your

suggestion or comments.

Getting help and support  
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Application Specific
Information

■ Software version number
■ Description of the problem such that technical support can duplicate the

problem
■ If possible, save the setup files for all the instruments used and the

application.
■ If possible, save the TekExpress setup files, log.xml, *.TekX (session files

and folders), and status messages text file.
■ If possible, save the waveform on which you are performing the

measurement as a .wfm file.

 Getting help and support
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Getting started

Required Oscilloscopes

DPO70000SX/DX Series Real Time Oscilloscopes with Bandwidth ≥ 20 GHz

Recommended accessories

Table 3: Recommended accessories

Instruments/Accessories Description Quantity
Arbitrary Waveform Generator AWG70001A/B 4 
Sync Hub Synchronizes the signal outputs of up

to four AWG70001A/B series
instruments (AWGs). One instrument
becomes the master and three
instruments become slaves.

1 

AWG-HD Performs amplification, sets the skew
on positive and negative legs and sets
the bias voltage.

1 

HDMIA2-TPA-P Wilder Fixture, HDMI Type A(v2.1)
Test Point Adapter

1 

HDMIA2-TPA-R Wilder Fixture, HDMI Type A(v2.1)
Test Point Receptacle

1 

EDID/SCDC controller HDMI_EDID2.1-EMSS (Wilder) or
AJSC-1 (Allion)

1 

Synchronisation cable (for stack
configuration)

1 

SMA torque 1 
AWG Synchronization Hub 1 
External box 1 
Ethernet Hub 1 
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Recommended probes

Table 4: Recommended probes

Probes Quantity
SMA Cables 10 
P7625/P7633 Tri-mode probe with P76CA-292C 4 
P7720 Tri-mode probe with P77C292MM

Windows 10 user accounts
Windows 10 instruments need to have the User Account Control Settings set to
Never Notify. To set the User Account Control Settings:

1. Go to Control Panel > User Accounts > Change User Account Control
settings.

2. Set it to Never Notify as shown in the image.

Getting started  
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Installing the software
Complete the following steps to download and install the latest FRL application.
See Recommended accessories on page 5 for compatibility.

1. Go to www.tek.com.

2. Click Downloads. In the Downloads menu, select DOWNLOAD TYPE as
Software and enter HDMI 2.1 FRL in the MODEL OR KEYWORD field and
click SEARCH.
 

 

3. Select the latest version of software and follow the instructions to download.
Copy the executable file to the oscilloscope.

4. Double-click the executable and follow the on-screen instructions. The
software is installed at C:\Program Files\Tektronix\TekExpress\TekExpress
FRL .

5. Select Analyze > Tekexpress FRL from the TekScope menu to Run the
application on page 11.

 Getting started
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Activate the license
Activate the license using the option installation wizard on the oscilloscope.
Complete the following steps to activate the TekExpress FRL license:

1. From the oscilloscope menu bar, click Utilities > Option Installation.

The TekScope Option Installation wizard opens.

2. Instructions for using the Options Installation window to activate licenses for
installed applications is provided in the oscilloscope online help. Press the F1
key on the oscilloscope keyboard to open the Option Installation help topic.
Follow the directions in the topic to activate the license.

See Also View version and license information on page 9

Getting started  
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View version and license information
Use the following instructions to view application version information and
version information for the application modules such as the Programmatic
interface and the Programmatic interface client.

To view version information:

From the Options menu, select About TekExpress.

To view license information:

1. From the oscilloscope Help menu, select About TekScope.

The Options section in the dialog box displays a list of installed options,
including TekExpress FRL.

2. To view the Option key, look in the Option Installation Key section. When
finished, click OK to close the dialog box.

See Also Activate the license on page 8

Options menu on page 15

 Getting started
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Application basics

Run the application
To launch the TekExpress HDMI 2.1 FRL application, select Analyze >
TekExpress FRL from the TekScope menu.
 

 

When you launch the application for the first time, the file C:\Users\<username>
\My Documents\My TekExpress\FRL\Resource.xml is mapped to drive X:. This
file contains information about the available network-connected instruments. The
session files are stored in X:\FRL\. If this file is not found, then the application
runs Instrument Discovery Program to detect the network-connected instruments
before launching FRL application.

If the application is behind the oscilloscope application, click Analyze >
TekExpress FRL to bring it to the front. To keep the TekExpress FRL
application window on top, select Keep On Top from the TekExpress FRL 
Options menu on page 15.
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See also Application controls on page 14
Application panels overview on page 12

Application panels overview
The FRL application uses panels to group Configuration, Results, and Reports
settings. Click any button to open the associated panel. A panel may have one or
more tabs that list the selections available in that panel. The configurations in a
tab changes depending on the settings made in the same tab or another tab.
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Table 5: Application panels overview

Panel Name Purpose
Setup panel overview on page 21 The Setup panel shows the test setup controls.

Click the Setup button to open this panel.
Use this panel to:

■ Set DUT parameters on page 22
■ Select tests on page 28
■ Set acquisition parameters on page 29

(Only available when Suite=Source )
■ Set configuration tab parameters on

page 32
■ Set test notification preferences on

page 38

Status panel overview on page 39 View the progress, analysis status of the
selected tests, and view test logs.

Results panel overview on page 41 View the summary of test results and select
result viewing preferences.

Reports panel overview on page 44 Browse for reports, save reports as specific file
types, specify report naming conventions, select
report content to include (summary information,
detailed information, user comments, setup
configuration, application configuration), and
select report viewing options.

See also Application controls on page 14

 Application basics
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Global application controls

Application controls Table 6: Application control descriptions

Item Description
Options menu on page 15 Opens the Options menu for access to global

controls.
Panels Visual frames with sets of related options.
Command buttons Buttons that initiate an immediate action such as

the Start, Stop, Pause, Continue, and Clear
command buttons.

Start button Starts continuous measurement acquisition and
analysis. If prior acquired measurements have
not been cleared, the new measurements are
added to the existing set.

Stop button Stops (aborts) the current execution.

Pause \ Continue button Use the Pause button to temporarily interrupt the
current acquisition. When a test is paused, the
button name changes to Continue.

Clear button Clears all existing measurement results. This
button is available only on the Results panel
overview on page 41.

Clear Log This button is available only on the Status panel
overview on page 39 and it is used to clear all
the status log.

Save This button is available only on the Status panel
overview on page 39 and it is used to save the
status log locally for the future use.

Application basics  
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Item Description
Application window move icon Place the cursor over the three-dot pattern in the

upper left corner of the application window.
When the cursor changes to a hand, drag the
window to the desired location.

Mini view / Normal view Toggles the application between mini view and
normal view.

Mini view displays the run messages with the
time stamp, progress bar, Start / Stop button,
and Pause / Continue button.
The application moves to mini view when you
click the Start button.

Options menu The Options menu is located in the upper right corner of the application.

The Options menu has the following selections:

Menu Function
Default Test Setup Opens an untitled test setup with defaults selected.
Open Test Setup Opens a saved test setup.
Save Test Setup Saves the current test setup selections.
Save Test Setup As Creates a new test setup based on an existing one.
Open Recent Displays a menu of recently opened test setups from which to

select.

 Application basics
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Menu Function
Instrument control settings on
page 17

Shows the list of instruments connected to the test setup and
allows you to locate and refresh connections to connected
instruments.

Keep On Top Keeps the TekExpress FRL utility on top of other open windows
on the desktop.

Email Settings Displays configure email options for test run and results
notifications.

Suite Displays the suite selected as 'Source' or 'Sink'.
Identify AWG-HD (Only available when Suite = Sink)

Identifies the AWG-HD through MAC address

Help Displays TekExpress FRL application Help document (This
document).

About TekExpress ■ Displays application details such as software name, version
number, and copyright.

■ Provides access to View version and license information on
page 9 for your TekExpress FRL application installation.

■ Provides a link to the Tektronix site.

See also.
Application controls on page 14

Application basics  
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Instrument control
settings

Use the TekExpress Instrument Control Settings dialog box to search and list the
connected resources (instruments) found on specified connections (LAN, GPIB,
USB, and so on) and each instruments connection information.

Identify all the instruments through VISA resource manager, before discovering
the instruments in "Instrument control settings" and can access this dialog box
from the Options menu.

 Application basics
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Use the Instrument Control Settings feature to view instrument connection
details. Connected instruments displayed here and are selected for use in the
Global Settings tab in the configuration section. See Set configuration tab
parameters on page 32 for details.

Application basics  
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To refresh the list of connected instruments:

1. From the Options menu, select Instrument Control Settings

2. In the Search Criteria section of the Instrument Control Settings dialog box,
select the connection types of the instruments for which to search.

Instrument search is based on the VISA layer, but different connections
determine the resource type, such as LAN, GPIB, and USB. For example, if
you choose LAN, the search will include all the instruments supported by
TekExpress that are communicating over the LAN.

3. Click Refresh. TekExpress searches for connected instruments.

4. After searching, the dialog box lists the instrument-related details based on
the search criteria you selected. For example, if you selected LAN and GPIB
as the search criteria, the application checks for the availability of
instruments over LAN, then GPIB, and then lists detected instruments on
those connection types.

The Retrieved Instruments table lists instrument details. The time and date of
the last time this table was updated is displayed in the Last Updated field.

 Application basics
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See also.
Options menu on page 15

Configure email settings To be notified by email when a test completes, fails, or produces an error,
configure the email settings.

1. Select Options > Email Settings to open the Email settings dialog box.

2. (Required) For Recipient email Address(es), enter one or more email
addresses to which to send the test notification. To include multiple
addresses, separate the addresses with commas.

3. (Required) For Sender’s Address, enter the email address used by the
instrument. This address consists of the instrument name, followed by an
underscore, followed by the instrument serial number, the @ symbol and
then the email server used. For example:
DPO72004C_B130099@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server
address of the Mail server configured at the client location, and the SMTP
Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name,
password, and host name in the corresponding fields.

NOTE. If any of the above required fields are left blank, the settings will not
be saved and email notifications will not be sent.

5. In the Email Attachments section, select from the following options:

■ Reports: Attach the test report to the notification email.

■ Status Log: Attach the test status log to the notification email. If you
select this option, then also select whether you want to receive the full
log or just the last 20 lines.

Application basics  

20 TekExpress FRL Printable Application Help



6. In the Email Configuration section:

■ Select the message file format to send: HTML (default) or plain text.

■ Enter a maximum file size for the email message (message plus
attachment files). Messages with attachments larger than this limit will be
truncated. The default is 5 MB.

■ Enter the number in the Number of Attempts to Send field, to limit the
number of attempts that the system makes to send a notification. The
default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use
this check box to quickly enable or disable email notifications.

8. To test your email settings, click Test Email.

9. To save your settings, click Apply.

10. Click Close when finished.

Setup panel

Setup panel overview The Setup panel contains sequentially ordered tabs that you guides through the
test setup and execution process. The configurations in the Setup panel changes
depending on the Suite selection as Source or Sink.

Figure 1: Setup panel for Source

 Application basics
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Figure 2: Setup panel for Sink

Set DUT parameters Use the DUT tab to select the parameters for the device under test. The settings
are global and apply to all tests for the current session. The configurations
available in other tabs may depend on the settings in the DUT tab.

Application basics  
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Figure 3: DUT tab for Source

 

Figure 4: DUT tab for Sink

 Application basics
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Table 7: DUT tab settings

Setting Description
DUT ID Adds an optional text label for the DUT to reports. The default value is DUT001. The

maximum number of characters is 32. You cannot use the alphanumeric characters in an ID
name (.,..,...,\,/:?"<>|*)

Comments icon  (to the right of the
DUT ID field)

Opens Comments dialog box to enter text to add to the report.
Maximum size is 256 characters. To enable or disable comments appearing on the test
report, see Select report options.

Acquire live waveforms Acquire active signals from the DUT for testing.
Use pre-recorded waveform files The tests on a saved run session file. Select a run session file from the list.
Version Select the required CTS Version from the drop-down list. The available option is 2.1 
Suite Select the suite from the drop-down list. The available options are Source and Sink.

The configurations in the setup panel varies depending on the Suite selection made as
Source or Sink in the DUT tab.

Execute (Only available when Suite = Sink) The available options are the following:

■ Select Measurements to performs the FRL Sink electrical measurements as per the
CTS.

■ Select Verify Calibration to verify the patterns used for FRL Sink electrical
measurements

Device Profile
Data Rate Select all the data rate supported by the DUT.
Data Rate to run All selected measurements will run on minimum and/or maximum data rate as per CTS.
Vterm(V) Applies termination voltage. Vterm value is selected to 3.3 V
EDID/SSDC controller Select the controller option from the drop-down list. The available options are Allion,

Wilder, and None. By default, Wilder is selected.

NOTE. Ensure that the Allion driver software is installed on the oscilloscope while using
Allion for testing FRL Source and FRL Sink.

Perform Link Training (Only available when Suite = Sink and Execute = Measurement)
Performs the Link Training and verifies that the link training is working as expected, before
performing the sink measurements.

Application basics  
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Setting Description
Verify Select Load AWG sequence to load the sequences on all AWGs.

Select Load link training patters to load the appropriate patters in AWGs.

Click Run. Depending upon the selections made in the Link Training window, the
application loads sequence, waveforms and performs link training on the patterns.

NOTE. If you want to perform link training on selected patterns, you can load sequence and
nominal waveforms manually in AWG and you can run by unselecting load sequence and
waveforms.

Skip AWG Synchronization (Only available when Suite = Sink)
Select to skip the synchronization of AWG(s).

 Application basics
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Setting Description
Multi-Lane Setup (Only available when Suite=Source)

Click Setup to configure the multi-lane setup for the test.

Select P76XX/P77XX configuration.

1. Select P76XX/P77XX and click OK.

2. In the Test Lane Setup menu, select the number of lanes selected, the Source, and
the Probe connection for each lane and click OK.

Select Dual Stack configuration.

■ Select Dual Stack and click OK.
■ In the Test Lane Setup menu, select the number of lanes selected, the Source, and

the IP address of the oscilloscope for each lane and click OK.

Application basics  
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Setting Description

The default IP address for oscilloscope and the extension oscilloscope is GPIB8::1::
INSTR & 10.0.0.2 respectively.

Signal Validation (Only available when Suite = Source)
Validation of the Signal can be done by three options and they can be selected from the
drop-down list provided:

■ Prompt me if Signal Check Fails

When selected, user is prompted if Signal validation fails. The user will be given the
option to Reacquire, Use Anyway, Skip and Abort the execution.

■ Skip Test if Signal Check Fails

When selected, signal validation fails for the selected test is skipped.
■ Turn Off Signal Check

When selected, FRL application does not perform any signal validation.

 Application basics
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Select tests Use the Test Selection tab to select the tests to run on the connected DUT.

Figure 5: Test selections tab for Source

Figure 6: Test selection tab for Sink

Application basics  
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See also. FRL Source tests on page 61

FRL Sink Tests on page 71

Set acquisition parameters Use the Acquisitions tab to view the test acquisition parameters. The contents
displayed in this tab depends on the DUT type and the tests selected. This tab is
available when the Suite in the DUT tab is selected as Source.

 Application basics
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Table 8: Acquisition tab settings

Settings Description
Refresh Sources Displays the sources connected to the different

channels of the oscilloscope. Updates the list of
available channel sources as used by the
Source fields in the Device list. Click this button
when you change the channel connections in
the test setup.

View Probes Displays the probes connected to the different
channels of the oscilloscope. Click to view the
detected probes and enable or disable the probe
signal source access in the application.

Acquisition Options ■ Acquire all and analyze

Acquire waveforms for all the valid
acquisitions and analyzes using the saved
waveforms.

■ Acquire only

Acquires waveforms for all the valid
acquisitions.

Waveform Options ■ Retain

The Retain is enabled only when acquire
all and analyze is selected and it retains
the saved waveforms for offline analysis.

■ Delete

Deletes the saved waveforms at the end of
analysis.

Show Acquire Parameters Select to review the acquire parameters.

Application basics  
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Running tests on prerecorded (saved) waveforms. To load a saved waveform file:

1. Click DUT.

2. Click Use pre-recorded waveform files .

3. Click Acquisitions. The Waveform Filename column now shows browse
buttons.

4. Click the browse button ( ) for each test acquisition type (Lane 0, Lane 1,
Lane 2, Lane 3)

5. Navigate to and select the appropriate waveform file(s). You must select all
waveforms required for the acquisition type.

6. To change, remove, or add a file to the list, click the browse button next to
the file name to change, and use the menu items to replace, remove (delete)
or add a file in the list.

7. Click Start.

 Application basics
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NOTE.

Waveform naming based on the Acquire Parameters.

Data Rate:12 Gbps

Target Lane:Lane0

Victim Lane Pattern : LTP5678

Quite Lane Pattern : LTP5678(When Quite lane not present, Quite Lane Pattern
= Victim Lane Pattern)

FFE Level: 0 

Run no: 1 

Example 1:

FRL_Lane0_12Gbps_LTP5678_LTP5678_FFE0_SE_Pos_R1.wfm

Example 2: Specific to HFR 1-4 Measurement

Allowed lane combination in compliance Mode:

Stack: L0L1,L0L2,L0L3

Probe: L0L2,L1L3,L0L3,L1L2

FRL_Lane0_12Gbps_LTP5678_LTP5678_FFE0_SE_Neg_L0L2_R1.wfm

Set configuration tab
parameters

Use Configuration tab to configure the Global Settings and the test measurement
configurations. The Global Settings and the measurements with configurations
are available in this tab depend on the Standards selected in the DUT tab.

Application basics  

32 TekExpress FRL Printable Application Help



Source configuration settings. Use the configuration tab to configure the Global
Settings and Measurement settings for the measurements. The settings described
in this tab is available when Suite in the DUT tab is selected as Source.

Figure 7: Source configuration: Global settings

Figure 8: Source configuration: Measurement settings

 Application basics
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Table 9: Source Configuration tab settings

Settings Description
Compliance mode settings
Global settings
Instruments Detected Displays the instruments connected to this application. Click on the

instrument name to open a list of available (detected) instruments.
Select Options > Instrument Control Settings and click Refresh to
update the instrument list.

NOTE. Verify that the GPIB search criteria (default setting) in the
Instrument Control Settings is selected when using the TekExpress FRL
application.

Vertical
Autoset Auto (Default value) Manual
Offset (V) 2.75 V -5 V to 5 V
Position (div) 0 -4 to 4 
Scale(mV) 80 mV 3.48 mV to 5350 mV
Bandwidth Values changes from 2.5 GHz to 21 GHz.
De-Embed Filter Apply De-Embed Select to apply the de-

embed filter file.
Click Browse and
select the de-
embedding filter files
(.flt).

NOTE. Browse option
is enabled only when
you select Apply De-
Embed checkbox.

Table 10: Measurement configurations for Source

Measurement
Name

Configuration Default value

HFR1-6: Data
Jitter (RJ)

Clock
Recovery

PLL Custom
BW

PLL Model: Type I
Loop BW (MHz)

-

3 Gbps 4 
6 Gbps 4 
8 Gbps 5.333 
10 Gbps 6.666 
12 Gbps 8 

Cable Settings Cable Model Both
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Measurement
Name

Configuration Default value

HFR1-7: Data
Eye Diagram

Clock Recovery PLL Custom
BW

PLL Model:
Type I
Loop BW
(MHz)

-

3 Gbps 4 
6 Gbps 4 
8 Gbps 5.333 
10 Gbps 6.666 
12 Gbps 8 

Cable Settings Cable Model Both
Crosstalk With
Equalizer Options CTLE+DFE
Apply Custom Mask File Select to apply

the custom
mask file. Click
Browse and
select the
custom mask
files.

HFR1-8: AC
Common Mode
Voltage

Acquire Bandwidth
(GHz)

3 Gbps 2 
6 Gbps 3 
8 Gbps 4 
10 Gbps 5 
12 Gbps 6 
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Sink configuration settings. Use the configuration tab to configure the Global
Settings and Measurement settings for the measurements. The settings described
in this tab is available when Suite in the DUT tab is selected as Sink.

Figure 9: Global settings tab for Sink configuration

Figure 10: Measurement tab for Sink configuration
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Table 11: Sink configuration tab settings

Setting Description
Compliance mode settings
Global Settings
Instruments Detected Displays the instruments connected. Click on the instrument IP to open a list of available (detected)

instruments and assign the appropriate IP address of corresponding instruments connected .
Select Options > Instrument Control Settings and click Refresh to update the instrument list.

NOTE. Verify that the GPIB search criteria (default setting) in the Instrument Control Settings is selected when
using the TekExpress FRL application.

Link Training
Link Training Status
Message ■ Turn off

When selected, link training status messages are not displayed.
■ Prompt always

When selected, displays the status (either pass or fail) of link training status messages.
■ Prompt on failure

When selected, only failure link training status messages are displayed.

DUT Configuration
EDID Present The selection of EDID Present is dependent on the presence of EDID on the Sink DUT.
De-embed filter
Apply De-embed Select to apply the de-embed filter file. Click Browse and select the de-embedding filter files (.flt).

NOTE. Browse option is enabled only when you select Use filter file for de-embedding.

Measurements
HFR2-5: Jitter Tolerance Settings RJ Tbit Default value (0.2)

SJ Frequency (Default
value)

SJ Amplitude (T bit) (Default value)

0.1 1 
0.2 0.51 
0.5 0.22 
1 0.14 
2 0.11 
5 0.1 
10 0.1 
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Set test notification
preferences

Use the Preferences tab to set the application to send an notification when a test
measurement completes:

Table 12: Preferences tab settings

Setting Description
Number of Runs
Acquire/Analyze each test <number> times Select to repeat the test run by setting the

number of times. By default, it is selected with
1 run. The number of run feature is available
only during the live mode.

Popup Settings
Auto Close Warnings and information during
Sequencing
Auto close after <number> Seconds

Select to auto close warnings/information during
sequencing. Set the Auto close time. By default
it is unselected.

Auto Close Error Messages during Sequencing.
Show in Reports
Auto close after <number> Seconds

Select to auto close Error Messages during
Sequencing. Set the Auto close time. By default
it is unselected.

Show messages with a beep sound Select to display the messages with a beep
sound. By default it is unselected.

Read Error Counter Only available when Suite = Sink
Enter the number of times the Error count needs
to be read.

See also.
Select report options on page 44
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Status panel overview
The Status panel provides status on test acquisition and analysis (Test Status tab)
and a listing of test tasks performed (Log View tab). The application opens the
Test Status tab when you start a test run. You can select the Test Status or the
Log View tab to view these items while tests are running.

The Test Status tab lists a high level status for each test.

Table 13: Test Status tab

Column Description
Test Name Name of the test
Acquisition, Analysis Status Status of the signal acquisition or test analysis

■ To be started

■ In progress

■ Completed

The Log View tab provides a list of the actions executed during the test. Use this
information to review or troubleshoot tests.

Log View tab
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Table 14: Log View fields

Item Description
Message History Displays all run messages with timestamp

information
Auto Scroll Sets the program to automatically scroll down

the Message History window as information is
added to the log during the test.

Clear Log Clears all messages in the Message History
window.

Save Saves the log file as a text file for examination.
Displays a standard Save As File window and
saves the status messages in the file that you
specify.
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See also View test results on page 42

Results panel

Results panel overview When a test finishes, the application switches to the Results panel to display a
summary of test results. Set viewing preferences for this panel from the
Preferences menu in the upper right corner. Viewing preferences include showing
whether a test passed or failed, summary results or detailed results, and enabling
wordwrap. For information on using this panel, see View test results on
page 42.
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View test results When a test finishes, the application switches to the Results panel on page 41,
which displays a summary of test results. The overall test result is displayed at
the top left of the Results table. If all of the tests for the session pass, the overall
test result will be Pass. If one or more tests fail, the overall test result will show
Fail.

Each test result occupies a row in the Results table. By default, results are
displayed in summary format with the measurement details collapsed and with
the Pass/Fail column visible. Change the view in the following ways:

■ To expand all tests listed, select View Results Details from the Preferences
menu in the upper right corner.

■ To expand and collapse tests, click the plus and minus buttons.
■ To collapse all expanded tests, select Preferences > View Results

Summary.
■ To remove or restore the Pass/Fail column, select Preferences > Show Pass/

Fail.
■ To enable or disable the wordwrap feature, select Preferences > Enable

Wordwrap.
■ To expand the width of a column, place the cursor over the vertical line that

separates the column from the column to the right. When the cursor changes
to a double-ended arrow, hold down the mouse button and drag the column to
the desired width.

■ To sort the test information by column, click the column head. When sorted
in ascending order, a small up arrow is displayed. When sorted in descending
order, a small down arrow is displayed.

■ To clear all test results displayed, click Clear.
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See also.
View a report on page 46

View test- related files Files related to tests are stored in the Documents\My TekExpress\FRL folder. In
the FRL folder, each test setup has a test setup file and a test setup folder, both
with the test setup name. The test setup file is preceded by the FRL icon and
usually has no visible file extension.

Inside the test setup folder is another folder named for the DUT ID used in the
test sessions. The default is DUT001.

Inside the DUT001 folder are the session folders and files. Each session has a
folder and file pair, both named for the test session using the naming convention
(date)_(time). Each session file is stored outside its matching session folder.

The first time you run a new, unsaved session, the session files are stored in the
Untitled Session folder located at ..\My TekExpress\FRL. When you name and
save the session, the files are placed in a folder with the name that you specify.
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Reports panel

Reports panel overview Use the Reports panel to save reports, select report content to include, and select
report viewing options.

For information on setting up reports, see Select report options on page 44. For
information on viewing reports, see View a report on page 46.

Select report options Use the Reports panel on page 44 to select which test information to include in
the report, and the naming conventions to use for the report. For example, always
give the report a unique name or select to have the same name increment each
time you run a particular test. Generally, you would select report options before
running a test or when creating and saving test setups. Report settings are
included in saved test setups.
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In the Reports panel, select from the following options:

Table 15: Report options

Setting Description
Report Update Mode
Generate new report Creates a new report. The report can be in either .mht or html

or .pdf file formats
Append with previous run
session

Appends the latest test results to the end of the current test
results report.

Include header in appended
reports

Includes header in appended reports.

Replace current test in previous
run session

Replaces the previous test results with the latest test results.

Report Creation Settings
Report name Displays the name and location from which to open a FRL report.

The default location is at \My TekExpress\ FRL \Untitled Session.
The report file in this folder gets overwritten each time you run a
test unless you specify a unique name or select to auto
increment the report name. Change the report name or location.
Do one of the following:

■ In the Report Path field, type over the current folder path
and name.

■ Double-click in the Report Path field and then make
selections from the popup keyboard and click the Enter
button.

Be sure to include the entire folder path, the file name, and the
file extension. For example: C: \Documents and Settings\your
user name \My Documents\My TekExpress\ FRL\<Username>
\DUT001.mht. This folder (C: \Documents and Settings\<user
name> \MyDocuments\My TekExpress) is mapped as X drive in
the scope. Open an existing report.
Click Browse, locate and select the report file and then click View
at the bottom of the panel.

Save as type Saves a report in the specified file type, selected from the
dropdown list.

NOTE. If you select a file type different from the default, be sure
to change the report file name extension in the Report Name field
to match.

Auto increment report name if
duplicate

Sets the application to automatically increment the name of the
report file if the application finds a file with the same name as the
one being generated. For example: DUT001, DUT002, DUT003.
This option is enabled by default.

Create report automatically at
the end of the run

Creates report at the end of the run.

Contents To Save
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Setting Description
Include pass/fail info in details
Table

Includes pass/fail info in the details table of the report.

Include detailed results Includes detailed results in the report.
Include plot images Includes plot images in the report.
Include setup configuration Sets the application to include hardware and software

information in the summary box at the top of the report.
Information includes: the oscilloscope model and serial number,
the oscilloscope firmware version, and software versions for
applications used in the measurements.

Margin value in percentage Enable to Display the margin value in percentage
Include user comments Select to include any comments about the test that you or

another user added in the DUT tab of the Setup panel.
Comments appear in the Comments Section, under the summary
box at the beginning of each report.

View report after generating Automatically opens the report in a Web browser when the test
completes. This option is selected by default.

View Click to view the most current report.
Generate Report Generates a new report based on the current analysis results
Save As Specify a name for the report.
Include complete application
configuration

Displays the general and measurement specific parameters in
the report

See also.
View a report on page 46

View a report The application automatically generates a report when test analysis is completed
and displays the report in your default Web browser (unless you cleared the View
Report After Generating check box in the Reports panel before running the
test). If you cleared this check box, or if you want to view a different test report,
do the following:

1. Click the Reports > Browse button and locate and select the report file to
view.

NOTE. If you did not save the test setup after running the test and you either
closed the application or you ran another test, the report file was not saved.

2. At the bottom of the Reports panel, click View.

For information on changing the file type, file name, and other report options, see 
Select report options on page 44.
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Report contents A report shows specified test details, as defined in the Reports panel.

Setup configuration information

Setup configuration information is listed in the summary box at the top of the
report. This information includes the oscilloscope model and serial number,
probe model and serial number, and software versions. To exclude this
information from the report, clear the Include setup configuration check box in
the Reports panel before running the test.

Figure 11: Report for Source
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Figure 12: Calibration report for Sink

Figure 13: Measurement report for Sink

User comments

If you selected to include comments in the test report, any comments you added
in the DUT tab of the Setup panel appear in the Comments section directly below
the summary box.

Test results

This table lists the tests results. The contents of this table depend on the
selections made in the Reports panel before running the test (Include pass/fail
results summary, Include user comments, Include detailed results, Include setup
configuration, and Include user comments).
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If Include plots images is selected, then measurement waveform plots are shown
below the test results table.

See also.
View test results on page 42

View test- related files on page 43

Exit the application
Use the following method to exit the application:

1.
Click  on the application title bar.

2. Do one of the following:

■ If you have an unsaved session or test setup open, you are asked to save
it before exiting. To save it, click Yes. Otherwise click No. The
application closes.

■ A message box appears asking if you really want to exit TekExpress. To
exit, click Yes.

NOTE. Using other methods to exit the application results in abnormal
termination of the application.
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Running tests

Equipment connection setup for Source
All the tests can be performed by connecting the equipments in probe
configuration or stack configuration.

Figure 14: Probe configuration for Source
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Figure 15: Stack configuration for Source

See also Recommended accessories on page 5
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Equipment connection setup for Sink
All the tests can be performed by connecting the equipments in probe
configuration or stack configuration.

Figure 16: Calibration configuration for Sink
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Figure 17: Sink Hub configuration setup
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Figure 18: Measurement configuration for Sink
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See also Recommended accessories on page 5

Prerequisite

Compensate the signal
path

Use the following procedure to compensate the internal signal acquisition path.
Perform this procedure if the ambient temperature has changed more than 5 °C
(9 °F) since you performed the last signal path compensation. Perform the signal
path compensation once a week. Failure to do so may result in the instrument not
meeting warranted performance levels. 

1. Power on and wait for the instrument to complete its warm up period before
continuing with this procedure.

2. Disconnect any probes you have connected to the input channels.

3. Set the instrument to Menu mode.

4. Select Instrument Calibration from the Utilities menu.

5. Note any instructions that appear in the resulting control window.

6. Click Run SPC to begin the procedure. The procedure may take several
minutes to complete.

7. Verify that the Status changes to Compensated after the procedure is
complete. If the Calibration Status field indicates anything other than
Compensated, see Signal Path Compensation Status for information on the
readout and recommended action.

NOTE. When making measurements at vertical scale settings less than or equal to
5 mV, you should perform the signal path compensation at least once a week.
Failure to do so may result in the instrument not meeting warranted performance
levels at those volts/div settings.

Deskew If skew is present between positive and negative channels, then the channels need
to be deskewed before being used for waveform measurements. TekExpress FRL
provides support for channel deskew and attenuation using the following method:
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There are no different types of deskew methods. These are the pre-requisites that
need to be performed before running the measurements.

■ For Source:

1. Stack deskew :

a. Perform scope SPC

b. Perform scope channel deskew

2. Probe deskew :

a. Perform scope SPC

b. Probe DC Compensation

■ For Sink:

■ Perform Scope spc

■ Perform scope channel deskew

■ Perform WEBAC deskew

■ Perform all AWG Calibration

■ Perform Sync hub deskew

Running tests
Select tests on page 28, Set acquisition parameters on page 29, Set configuration
tab parameters on page 32, Set test notification preferences on page 38, and click
Start to run the tests. While tests are running, you cannot access the Setup or
Reports panels. To monitor the test progress, switch between the Status panel and
the Results panel. 

While the tests are running, other applications may display windows in the
background. The TekScope application takes precedence over other applications,
but you can switch to other applications by using Alt + Tab key combination. To
keep the TekExpress FRL application on top, select Keep On Top from the
TekExpress Options menu.

Once the test execution is completed, the application displays the report.

Prerun checklist 1. Make sure that the instruments are warmed up (approximately 20 minutes)
and stabilized.

2. Perform compensation: In the oscilloscope main menu, select Utilities >
Instrument Compensation. Click Help in the compensation window for
steps to perform instrument compensation.
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Saving and recalling test setup

Test setup files overview
Saved test setup information (such as the selected oscilloscope, general
parameters, acquisition parameters, measurement limits, waveforms (if
applicable), and other configuration settings) are saved under the setup name at
X:\FRL.

Use test setups to:

■ Run a new session, acquiring live waveforms, using a saved test
configuration.

■ Create a new test setup using an existing one.

■ View all the information associated with a saved test, including the log file,
the history of the test status as it executed, and the results summary.

■ Run a saved test using saved waveforms.

See also Save a test setup on page 59

Open (load) a saved test setup on page 60

Save a test setup
You can save a test setup before or after running a test. You can create a test
setup from Create a test setup using an existing one on page 60, or using 
Create a test setup from default settings on page 60. When you select the
default test setup, the parameters are set to the application’s default value.

Select Options > Save Test Setup to save the opened setup.

Select Options > Save Test Setup As to save the setup with different name.
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Open (load) a saved test setup
To Open (load) a saved test setup, do the following:

1. Select Options > Open Test Setup.

2. Select the setup from the list and click Open. Setup files are located at X:
\FRL\.

See also Test setup files overview on page 59

Create a test setup using an existing one on page 60

Create a test setup from default settings on page 60

Create a test setup from default settings
To create a test setup using default settings, follow the steps:

1. Select Options > Default Test Setup. For default test setup, the parameters
are set to the application’s default value.

2. Click application Setup panel on page 21 and set the parameters

3. Click application Reports panel on page 44 and set the report options

4. Optional: Click Start to run the test and verify that it runs correctly and
captures the specified test information and reports. If it does not, then edit the
parameters and repeat this step until the test runs to your satisfaction

5. Select Options > Save Test Setup. Enter the file name and click Save. The
application saves the file to X:\FRL\<session_name>

Create a test setup using an existing one
To create a test setup using an existing one, follow the steps:

1. Select Options > Open Test Setup

2. Select a setup from the list and then click Open

3. Click application Setup panel on page 21 and modify the parameters

4. Click application Reports panel on page 44 and modify the report options

5. Select Options > Save Test Setup As

6. Enter test setup name, and click Save
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FRL Source tests

HFR1-1: DC Common Mode Voltage
This test measurement verify that the DC bias of each side of each Data lane.

Required test equipment Equipment connection setup for Source on page 51

Recommended accessories on page 5

Measurement procedure 1. Configure the DUT to transmit the lowest supported FRL data rate with
TxFFE Level set to 0.

2. Set the DUT to output LTP5, LTP6, LTP7, LTP8 pattern Lane0, Lane1,
Lane2, and Lane3 respectively.

3. Connect the L_X_p (+ve) and L_X_m (-ve) (waveforms) to Digital
oscilloscope using either Tektronix recommended probe or TCA-SMA cable.

4. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals.
5. Set the cursor gating to 221184 unit intervals (3*4096 FRL characters).
6. Optionally de-embed Plug TPA using the TPA vendor's de-embed file.
7. Calculate L_X_DC Common Mode Voltage as,

L_X_DC Common Mode voltage = Average ((L_X_p + L_X_m)/2)
8. If L_X_DC Common Mode Voltage < AVcc-800 mV, then FAIL.

Similarly if L_X_DC Common Mode Voltage > AVcc + 30 mV, then FAIL.
9. Repeat step  6 and step  7 for all FRL lanes.
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HFR1-2: Vse_max,Vse_min
This test measurement measures the single ended max and min voltages for each
side of each data lane.

Required test equipment Equipment connection setup for Source on page 51

Recommended accessories on page 5

Measurement procedure 1. Configure the DUT to transmit lowest supported FRL data rate with TxFFE
Level set to 0.

2. Set the DUT to output LTP5, LTP6, LTP7, LTP8 pattern Lane0, Lane1,
Lane2, and Lane3 respectively.

3. Connect L_X_p (+ve) and L_X_m (-ve) (waveforms) to Digital oscilloscope
using either Tektronix recommended probe or TCA-SMA cables.

4. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals.
5. Set the cursor gating to 221184 unit intervals (2*4096 FRL characters).
6. Optionally de-embed the Plug TPA using vendor's de-embed file.
7. Perform the L_X_DC Common Mode measurement as per Test ID HFR1-1.
8. Find the Maximum L_X_p voltage as

Max V_L_X_p = MAX (L_X_p)
9. Find the Minimum L _N_p voltage:

Min V_L_X_p = MIN (L_X_p)
10. Find the Maximum L_N_n voltage:

Max V_L_X_n = MAX (L_X_n)
11. Find the Minimum L _N_p voltage:

Min V_L_X_n = MIN (L_X_n)
12. Compare the results with the test limit.
13. Repeat step  6 to step  12 for all FRL lanes.
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HFR1-3: Rise/Fall Slew Rate
The transition time must be more than the specified minimum because of
potential for radiated emissions from transmitters with fast edges and skew. This
test evaluates the transition time for an FRL Transmitter for rising and falling
edges.

Required test equipment Equipment connection setup for Source on page 51

Recommended accessories on page 5

Measurement procedure 1. Connect the DUT to the digital oscilloscope using TPA-P fixture, in one of
the configurations as shown is connection diagram.

2. Configure the DUT to transmit highest supported FRL data rate with TxFFE
Level set to 0.

3. Set the DUT to output LTP4 pattern for the lane under test and LTP2 for all
other non-target lanes.

4. Adjust the scope vertical settings such that the signal occupies around
8 divisions on the graticule.

5. Capture L_X_p (+ve) and L_X_m (-ve) single ended signals.
6. Optionally de-embed Plug TPA using the TPA vendor’s de-embed file.
7. Measure the slew rate of L_X_p (+ve) and L_X_m (-ve) over 60% - 40%

reference level. Consider at least 500 rising and 500 falling edges for the
measurement.

8. SlewRise=Average rising edge measurements.
9. SlewFall=Average falling edge measurements.
10. If either SlewRise or SlewFall is more than 16 mV/ps then FAIL.
11. Repeat step  3 to step  10 for all FRL lanes.

 FRL Source tests
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HFR1-4: Inter-Pair Skew
This test measures the difference in time between any two FRL Data Lanes.

Required test equipment Equipment connection setup for Source on page 51

Recommended accessories on page 5

Measurement procedure 1. Configure the DUT to transmit highest supported FRL data rate with TxFFE
Level set to 0.

2. Set the DUT to output LTP5, LTP6, LTP7, LTP8 pattern Lane0, Lane1,
Lane2, and Lane3 respectively.

3. Connect L_X_p (+ve) and L_X_m (-ve) (waveforms) to Digital oscilloscope
using either Tektronix recommended probe or TCA-SMA cables.

4. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals. Create the
differential signal using Math subsystem.

L_X = L_X_p - L_X_m
5. For the target lanes A and B, find the SR character in each acquisition.
6. Evaluate time difference, InterPair Skew_A_B, between the SR characters of

the target lanes.

TINTERPAIR_SKEW_A_B = Time Location of SR_A - Time Location of SR_B
7. If TINTERPAIR_SKEW_A_B is greater than 4Tbit then FAIL.
8. Repeat step  4 to step  7 for all combinations of FRL lanes A and B.

HFR1-5: FRL Rates
This test measures the frequency or data rate accuracy to the nominal FRL data
rates.

Required test equipment Equipment connection setup for Source on page 51

Recommended accessories on page 5
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Measurement procedure 1. Configure the DUT to transmit lowest supported FRL data rate with TxFFE
Level set to 0.

2. Set the DUT to output LTP3 pattern for the lane under test and LTP2 for all
other non-target lanes.

3. Connect L_X_p (+ve) and L_X_m (-ve) (waveforms) to Digital oscilloscope
using either Tektronix recommended probe or TCA-SMA cables.

4. Set the record length to include 1 million Unit Intervals.
5. Set the vertical scale such that the signal to noise ratio is minimized.
6. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals. Create the

differential signal using Math subsystem.

L_X = L_X_p - L_X_m
7. Optionally de-embed Plug TPA using the TPA vendor's de-embed file.
8. Measure data rate for target lane by measuring frequency of signal.

L_X_Data Rate = Frequency * 2 
9. Calculate L_X error from nominal bit rate targeted.
10. L_X_error = 1E6 * (L_X_Data Rate - Nominal Data Rate Setting) /

(Nominal Data Rate Setting).
11. If L_X_error > 300 ppm, then FAIL.
12. Repeat step  6 to step  11 for all FRL lanes.
13. Repeat step  1 to step  12 for the highest supported FRL data rate.

HFR1-6: Data Jitter (RJ)
This test evaluates Data Jitter (RJ peak-to-peak and RJ RMS) of the FRL link
with a clock pattern transmitted on the target channel. Data Jitter can be used in
the data eye diagram to compensate a 1E-10 BER mask to a 1E-6 BER mask.

Required test equipment Equipment connection setup for Source on page 51

Recommended accessories on page 5
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Measurement procedure 1. Configure the DUT to transmit lowest supported FRL data rate with Tx FFE
Level set to 0.

2. Set the DUT to output LTP3 pattern for the lane under test and LTP1 for all
other non-target lanes.

3. Connect L_X_p (+ve) and L_X_m (-ve) (waveforms) to Digital oscilloscope
using either Tektronix recommended probe or TCA-SMA cables.

4. Set the record length to 1 million User Intervals.
5. Set the vertical scale such that the signal to noise ratio is minimized.
6. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals. Create the

differential signal using Math subsystem.

L_X = L_X_p - L_X_m
7. Optionally de-embed Plug TPA using the TPA vendor's de-embed file.
8. Measure the RJ (RMS) and RJ (Pk-Pk) after applying the 8 dB CTLE and

WCM3 cable model.
9. If RJ (Pk-Pk) > 0.2 Tbit, then FAIL.
10. Repeat step  8 and step  9 with 1dB CTLE and SCM3 cable model.
11. Repeat step  2 and step  10 for all FRL lanes.
12. Repeat step  1 to step  11 for the highest supported FRL data rate.

HFR1-7: Data Eye Diagram
This test evaluates that the waveform parameters over a significant interval of
time to verify that with proper clock recovery there is no signal incursion into
regions defined by a mask to result in correct demodulation of data.

Required test equipment Equipment connection setup for Source on page 51

Recommended accessories on page 5
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Measurement procedure 1. Configure the DUT to transmit lowest supported FRL data rate with TxFFE
Level set to 0.

2. Set the DUT to output LTP5, LTP6, LTP7, LTP8 pattern Lane0, Lane1,
Lane2, and Lane3 respectively.

3. Connect L_X_p (+ve) and L_X_m (-ve) (waveforms) to Digital oscilloscope
using either Tektronix recommended probe or TCA-SMA cables.

4. Set the scope sampling rate to 100 G Sa/s.
5. Set the vertical scale such that the signal to noise ratio is minimized.
6. Set the record length to 2 million User Intervals.
7. Acquire single-ended L_X_p (+ve) and L_X_m (-ve) signals for all lanes.

Create the differential signal using Math subsystem.

L_X = L_X_p - L_X_m
8. Optionally de-embed Plug TPA using the TPA vendor's de-embed file.
9. For the target lane, a channel model is applied to the acquisition waveform

for that lane to comprehend the differential insertion loss for that lane.
10. Crosstalk from the non-target lanes is applied using acquisitions for each lane

and applying the crosstalk transfer function derived from the channel model.
11. Apply the equalization (CTLE and DFE, if 12 Gbps; Only CTLE, for any

other data rate) on the resulting summed waveform.

FRL rate Cable Model CTLE DFE
12 Gbps WCM3S 8 db 25 mV
12 Gbps SCM3S 1 db n/a
3/6/8/10 Gbps WCM3S 8 db n/a
3/6/8/10 Gbps SCM3S 1 db n/a

12. Apply the PLL clock recovery with the below Loop Bandwidth.

Loop BW = (Rbit / 1500), where Rbit 12 Gbps, 10 Gbps, 8 Gbps and 6 Gbps

= 4MHz when Rbit 3Gbps
13. Render eye diagram and verify no point incursions in mask area.
14. Repeat step  8 to step  13 for both channel models (WCM and SCM).
15. Repeat step  8 to step  14 for each data lane.
16. Repeat step  1 to step  15 for the highest supported FRL data rate.
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HFR1-8: AC Common Mode Voltage
This test verifies that the AC common mode noise of a transmitter is limited to a
percentage of the nominal DC differential swing to ensure that radiated emissions
due to the common mode noise are limited.

Required test equipment Equipment connection setup for Source on page 51

Recommended accessories on page 5

Measurement procedure 1. Configure the DUT to transmit highest supported FRL data rate with TxFFE
Level set to 0.

2. Set the DUT to output LTP5, LTP6, LTP7, LTP8 pattern Lane0, Lane1,
Lane2, and Lane3 respectively.

3. Connect L_X_p (+ve) and L_X_m (-ve) (waveforms) to Digital oscilloscope
using either the recommended probe or TCA-SMA cables.

4. Set the oscilloscope bandwidth to one half the data rate.
5. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals.
6. Optionally de-embed Plug TPA using the TPA vendor's de-embed file.
7. Create Common Mode Waveform of the target lane:

L_XCM = (L_X_plus + L_X_minus)/2 
8. Measure VCM_L_X_pp = peak to peak voltage of L_XCM.
9. If VCM_L_X_pp > 150 mV, then FAIL.
10. Repeat step  6 to step  9 for all FRL lanes.

HFR1-9: FFE Monotonicity-Method 1
This test verifies that the parameters of FFE, pre-shoot amplitude and de-
emphasis, are monotonic from one FFE state to the next FFE state.

Required test equipment Equipment connection setup for Source on page 51

Recommended accessories on page 5
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Measurement procedure 1. Configure the DUT to transmit highest supported FRL data rate with TxFFE
Level set to 0.

2. Set the DUT to output LTP4 pattern for the lane under test and LTP2 for all
other non-target lanes.

3. Connect L_X_p (+ve) and L_X_m (-ve) (waveforms) to Digital oscilloscope
using either Tektronix recommended probe or TCA-SMA cables.

4. Set the vertical scale such that the signal to noise ratio is minimized.
5. Setup time scale to demonstrate ~192 UI with the positive going pulse in the

middle of the screen.
6. Optionally de-embed Plug TPA using the TPA vendor's de-embed file.
7. Configure the DUT in de-emphasis only mode by setting

xFFE_De_Emphasis Only bit.
8. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals
9. Measure Vd,
10. Configure the DUT in pre-emphasis only mode by setting TxFFE_Pre_Shoot

Only bit.
11. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals.
12. Measure Vp.
13. Configure the DUT in Vn when FFE is in state 0.
14. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals.
15. Measure Vn.
16. dBDe-emphasis_FFE0=20* Log(Vn/Vp)
17. dBPre-Shoot_FFE0=20* Log(Vd/Vn)
18. Repeat step  7 to step  15 for all FFE states, X and calculate

dBDeemphasis_FFEX and dBPre-Shoot_FFEX.
19. If the difference of pre-shoot between any two successive FFE levels is

greater than 0dB then Pass.Similarly If the difference of de-emphasis
between any two successive FFE levels is less than 0dB then Pass.

20. Repeat step  7 to step  19 for all FRL lanes.
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HFR1-9: FFE Monotonicity-Method 2
This test verifies that the parameters of FFE, pre-shoot amplitude and de-
emphasis, are monotonic from one FFE state to the next FFE state.

Required test equipment Equipment connection setup for Source on page 51

Recommended accessories on page 5

Measurement procedure 1. Configure the DUT to transmit highest supported FRL data rate with TxFFE
Level set to 0.

2. Set the DUT to output LTP4 pattern for the lane under test and LTP2 for all
other non-target lanes.

3. Connect L_X_p (+ve) and L_X_m (-ve) (waveforms) to Digital oscilloscope
using either Tektronix recommended probe or TCA-SMA cables.

4. Set the vertical scale such that the signal to noise ratio is minimized.
5. Setup time scale to demonstrate ~192 UI with the positive going pulse in the

middle of the screen.
6. Optionally de-embed Plug TPA using the TPA vendor's de-embed file.
7. Configure the DUT in de-emphasis only mode by setting

xFFE_De_Emphasis Only bit.
8. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals.
9. Measure Vd= V0-|V+1|.
10. Configure the DUT in pre-emphasis only mode by setting TxFFE_Pre_Shoot

Only bit.
11. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals.
12. Measure Vp = V0-|V-1|
13. Configure the DUT in No FFE mode by setting the TxFFE_NO_FFE bit.
14. Capture L_X_p (+ve) and L_X_m (-ve) single-ended signals.
15. Measure V0.
16.

dBDe-emphasis_FFE0 =
17.

dBPre-Shoot_FFE0=
18. Repeat step  7 to step  15 for all FFE states, X and calculate

dBDeemphasis_FFEX and dBPre-Shoot_FFEX.
19. If the difference of pre-shoot between any two successive FFE levels is

greater than 0dB then Pass. Similarly If the difference of de-emphasis
between any two successive FFE levels is less than 0dB then Pass.

20. Repeat step  7 to step  19 for all FRL lanes.
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FRL Sink Tests

HRF2-1:Max Differential Swing Tolerance
This test confirms that the Sink supports FRL differential voltages at maximum
level.

Required test equipment Equipment connection setup for Sink on page 53

Recommended accessories on page 5

Measurement procedure 1. Connect the AWGs (AWG70001A/AWG70001B) to the oscilloscope
through AWG-HD box, Sync hub and TPA-PR fixture, as shown in the 
Figure 18: Measurement configuration for Sink on page 55.

2. Configure the AWGs to lowest FRL rate supported by the DUT.
3. Adjust the common mode voltage (VICM) to a level defined in HDMI

version 2.1 Table 6-25 
4. Calibrate differential mode swing voltage of the AWG at PTP2_cal with no

cable model applied to Maximum Differential Swing 1200 mV using
RXSB33PAT pattern.

5. Connect the AWGs to the Sink DUT using TPA-P as shown in Figure 18:
Measurement configuration for Sink on page 55.

6. Complete the Link Training between Sink DUT and FRL Signal Generator
for the selected FRL Rate. If Link Training is not successful, then FAIL

7. Configure the AWGs to transmit RXSB33PAT pattern.
8. Read the Error Counter from Sink DUT using I2C controller.
9. Conduct error counter test as described in section BER estimation procedure

on page 76. If error counter check fails, then FAIL.
10. Configure the AWG to highest FRL rate supported by the DUT and connect

the AWGs to the oscilloscope using AWG-HD box, Sync hub, TPA-P and
TPA-R.

11. Repeat Steps  4 to step  9 for successful link training.
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HRF2-2:Intra-Pair Skew
This test confirm that the maximum allowed timing skew within each FRL pair is
supported by the Sink DUT

Required test equipment Equipment connection setup for Sink on page 53

Recommended accessories on page 5

Measurement procedure 1. Connect the AWGs (AWG70001A/AWG70001B) to the oscilloscope
through AWG-HD box, Sync hub and TPA-PR fixture, as shown in the 
Figure 18: Measurement configuration for Sink on page 55.

2. Configure the AWGs to lowest FRL rate supported by the DUT.
3. Adjust the common mode voltage (VICM) to a level defined in HDMI

version 2.1 Table 6-25.
4. For all FRL Signals, set the single ended swing to 500 mV.
5. Calibrate for a skew of 0.15*Tbit on a line of the FRL target lane against its

complement, at TP2 using WCM3 cable model.
6. Connect the AWGs to the Sink DUT using TPA-P as shown in Figure 18:

Measurement configuration for Sink on page 55.
7. Complete the Link Training between Sink DUT and FRL Signal Generator

for the selected FRL Rate. If Link Training is not successful, then FAIL.
8. Configure the AWGs to transmit RXSB33PAT pattern.
9. Read the Error Counter from Sink DUT using I2C controller.
10. Conduct error counter test as described in section BER estimation procedure

on page 76. If error counter check fails, then FAIL.
11. Switch the setting of the signal delay on the complement line for the target

FRL Lane pair. Repeat step  7 to Step  10.
12. Configure the AWG to highest FRL rate supported by the DUT and connect

the AWGs to the oscilloscope using AWG-HD box, Sync hub, TPA-P and
TPA-R.

13. Repeat Steps  5 to step  11 for all the FRL lines.
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HRF2-3:Inter-Pair Skew
This test confirm that the maximum allowed skew between FRL Lanes is
supported by the Sink DUT.

Required test equipment Equipment connection setup for Sink on page 53

Recommended accessories on page 5

Measurement procedure 1. Connect the AWGs (AWG70001A/AWG70001B) to the oscilloscope
through AWG-HD box, Sync hub and TPA-PR fixture, as shown in the 
Figure 18: Measurement configuration for Sink on page 55.

2. Configure the AWGs to lowest FRL rate supported by the DUT.
3. Adjust the common mode voltage (VICM) to a level defined in HDMI

version 2.1 Table 6-25 
4. For all FRL Signals, set the single ended swing to 500 mV.
5. Calibrate for the inter pair skew of [4Tbit + 500 ps] on FRL Lane0 against all

other lanes, in positive direction. Perform the calibration at TP2 using
WCM3 cable model.

6. Connect the AWGs to the Sink DUT using TPA-P as shown in Figure 18:
Measurement configuration for Sink on page 55.

7. Complete the Link Training between Sink DUT and FRL Signal Generator
for the selected FRL Rate. If Link Training is not successful, then FAIL.

8. Configure the AWGs to transmit RXSB33PAT pattern.
9. Read the Error Counter from Sink DUT using I2C controller.
10. Conduct error counter test as described in section “BER estimation procedure

on page 76”. If error counter check fails, then FAIL.
11. Calibrate for the inter pair skew of [4Tbit + 500 ps] on FRL Lane0 against all

other lanes, in negative direction. Perform the calibration at TP2 using
WCM3 cable model. Repeat step  6 to Step  10.

12. Repeat the test for the remaining untested FRL lane.
13. Configure the AWG to highest FRL rate supported by the DUT and connect

the AWGs to the oscilloscope using AWG-HD box, Sync hub, TPA-P and
TPA-R.

14. Repeat Steps  5 to Step  12 for all FRL lanes.
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HRF2-4:Minimum Link Rate Tolerance
This test confirm that the Sink DUT meets FRL Link Rate Tolerance
requirements.

Required test equipment Equipment connection setup for Sink on page 53

Recommended accessories on page 5

Measurement procedure 1. Connect the AWGs (AWG70001A/AWG70001B) to the oscilloscope
through AWG-HD box, Sync hub and TPA-PR fixture, as shown in the 
Figure 18: Measurement configuration for Sink on page 55.

2. Configure the AWGs to lowest FRL rate supported by the DUT.
3. Adjust the common mode voltage (VICM) to a level defined in HDMI

version 2.1 Table 6-25.
4. For all FRL Signals, set the single ended swing to 500 mV.
5. Calibrate the data rate for +300 ppm for all FRL lanes, at TP2 using WCM3

cable model.
6. Connect the AWGs to the Sink DUT using TPA-P as shown in Figure 18:

Measurement configuration for Sink on page 55.
7. Complete the Link Training between Sink DUT and FRL Signal Generator

for the selected FRL Rate. If Link Training is not successful, then FAIL.
8. Configure the AWGs to transmit RXSB33PAT pattern.
9. Read the Error Counter from Sink DUT using I2C controller.
10. Conduct error counter test as described in section BER estimation procedure

on page 76. If error counter check fails, then FAIL.
11. Calibrate the data rate for -300 ppm for all FRL lanes, at TP2 using WCM3

cable model. Repeat step  6 to step  10.
12. Configure the AWG to highest FRL rate supported by the DUT and connect

the AWGs to the oscilloscope using AWG-HD box, Sync hub, TPA-P and
TPA-R.

13. Repeat Steps  5 to Step  11 for all FRL Lanes.
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HFR2-5:Jitter Tolerance
This test confirm that the maximum allowed jitter is supported by the Sink DUT.

Required test equipment Equipment connection setup for Sink on page 53

Recommended accessories on page 5

Measurement procedure 1. Connect the AWGs (AWG70001A/AWG70001B) to the oscilloscope
through AWG-HD box, Sync hub and TPA-PR fixture, as shown in the 
Figure 18: Measurement configuration for Sink on page 55.

2. Configure the AWGs to lowest FRL rate supported by the DUT.
3. Adjust the common mode voltage (VICM) to a level defined in HDMI

version 2.1 Table 6-25.
4. For all FRL Signals, set the single ended swing to 500 mV.
5. Calibrate Random Jitter (RJ) = 0.2 Tbit @ BER 10 - 10 using LTP3 pattern.
6. Add accurate amount of SJ = 0.10 UI @ 10 *fc.
7. Configure the AWGs to output RXSB33PAT with WCM3_CTS applied, by

keeping RJ and SJ as per step 5 and step 6.
8. Calibrate the resulting signal, marginal to the TP2_EQ eye diagram mask for

the following conditions:

a. Condition 1: Vmin (mV) = 150 mV and H (Tbit) @ BER 10 - 10 = 0.5 if
FRL rate is 3 Gbps.

b. Condition 2: Vmin (mV) = 150 mV and H (Tbit) @ BER 10 - 10 = 0.4 if
FRL rate is 6 Gbps.

c. Condition 3: Vmin (mV) = 135 mV and H (Tbit) @ BER 10 - 10 = 0.385 if
FRL rate is 8 Gbps.

d. Condition 4: Vmin (mV) = 120 mV and H (Tbit) @ BER 10 - 10 = 0.37 if
FRL rate is 10 Gbps.

e. Condition 1: Vmin (mV) = 100 mV and H (Tbit) @ BER 10 - 10 = 0.35 if
FRL rate is 12 Gbps.

a. Adjust DJ (ISI) until the measured total jitter becomes 1 – H (Tbit) @
BER 10 - 10 from step 8 when measured with CRU as defined in
Equation 6-4 of HDMI version 2.1 specification.

b. Adjust the Differential swing until the vertical opening is Vmin (mV)
@ BER 10 - 10 in step 8 measured with CRU as defined in Equation
6 - 4 of HDMI version 2.1 specification.

9. Connect the AWGs to the Sink DUT using TPA-P as shown in Figure 18:
Measurement configuration for Sink on page 55.

10. Complete the Link Training between Sink DUT and FRL Signal Generator
for the selected FRL Rate. If Link Training is not successful, then FAIL.

11. Configure the AWGs to transmit RXSB33PAT pattern.
12. Read the Error Counter from Sink DUT using I2C controller.
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13. Conduct error counter test as described in section BER estimation procedure
on page 76. If error counter check fails, then FAIL.

14. Repeat Steps  6 to step  13 with following SJ:

a. SJ = 1.0 UI @ 0.1*fc
b. SJ = 0.51 UI @ 0.2*fc
c. SJ = 0.22 UI @ 0.5*fc
d. SJ = 0.14 UI @ 1*fc
e. SJ = 0.11 UI @ 2*fc
f. SJ = 0.10 UI @ 5*fc

15. Configure the AWG to highest FRL rate supported by the DUT and connect
the AWGs to the oscilloscope using AWG-HD box, Sync hub, TPA-P and
TPA-R

16. Repeat Steps  5 to Step  14 for error control link.

BER estimation procedure
BER estimation check on all active lanes should be the PASS/FAIL criteria for
FRL Sink Electrical Tests.

1. Read the CED counter to clear it, make sure the Valid flag is set.

2. Count the errors until at least 10^11 bits were received.

3. Read error counter, calculate BER based on accumulated errors and total
elapsed time.

a. calculate the BER as (total number of errors reported by DUT since the
test started) / (bitrate * total time elapsed since the test started).

b. If BER is greater than 10^-10, then FAIL.

c. If BER is greater than 5*10^-11 (i.e. half of the allowed maximum),
repeat test period to acquire more data.

d. If this is already the 10th repetition, and BER is greater than 10^-10, then
FAIL, otherwise, continue to next step.

e. Check if tested lanes are all locked; if any lane is not locked, then FAIL.
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SCPI commands

About SCPI command
You can use Standard Commands for Programmable Instruments (SCPI) to
communicate with the TekExpress application.

Socket configuration for SCPI commands
This section describes the steps for TCPIP socket configuration and TekVISA
configuration to execute the SCPI commands.

TCPIP socket
configuration

1. Click Start > Control Panel > System and Security > Windows Firewall >
Advanced settings.
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2. In Windows Firewall with Advanced Security menu, select Windows
Firewall with Advanced Security on Local Computer > Inbound Rules
and click New Rule…
 

 
3. In New Inbound Rule Wizard menu

a. Select Port and click Next.
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b. Select TCP as rule apply and enter 5000 for Specific local ports and
click Next.
 

 
c. Select Allow the connection and click Next.
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d. Select Domain, Private, Public and click Next.
 

 
e. Enter Name, Description (optional), and click Finish.
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4. Check whether the Rule name is displayed in Windows Firewall with
Advanced Security menu > Inbound Rules.
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TekVISA configuration 1. Click Start > All Programs > TekVISA > OpenChoice Instrument
Manager.
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2. Click Search Criteria. In Search Criteria menu, click LAN to Turn-on.
Select Socket from the drop-down list, enter the IP address of the

TekExpress device in Hostname and type Port as 5000. Click  to
configure the IP address with Port.

Enter the Hostname as 127.0.0.1 if the TekVISA and TekExpress application
are in the same system, else enter the IP address of the TekExpress
application system.
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3. Click Search to setup the TCPIP connection with the host. Check whether
the TCPIP host name is displayed in OpenChoice Instrument Manager >
Instruments.
 

 
4. Double-click OpenChoice Talker Listener and enter the Command *IDN?

in command entry field and click Query. Check that the Operation is
successful and Talker Listener Readout displays the Command / Data.
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TEKEXP:*IDN?
This command queries the active TekExpress application name running on the
oscilloscope. 

Syntax TEKEXP:*IDN?\n

Inputs NA

Outputs Returns active TekExpress application name running on the oscilloscope.

TEKEXP:*OPC?
This command queries the execution status of the last executed command. 

Syntax TEKEXP:*OPC?\n

Inputs NA

Outputs 0 - last command execution is not complete

1 - last command execution is complete
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TekExpress FRL Printable Application Help 85



TEKEXP:ACQUIRE_MODE
This command sets the acquire mode as live or pre-recorded.

Syntax TEKEXP:ACQUIRE_MODE {LIVE | PRE-RECORDED}\n

Inputs {LIVE | PRE-RECORDED}

Outputs NA

TEKEXP:ACQUIRE_MODE?
This command queries the acquire mode type.

Syntax TEKEXP:ACQUIRE_MODE?\n

Inputs NA

Outputs {LIVE | PRE-RECORDED}
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TEKEXP:EXPORT
This command returns all the bytes of data to the specified file. 

Syntax Outputs
TEKEXP:EXPORT REPORT\n Returns the report file in bytes
TEKEXP:EXPORT WFM,"<FileName>"\n Returns the specified waveform file in bytes
TEKEXP:EXPORT IMAGE,"<FileName>"\n Returns the specified image file in bytes

Inputs FileName - Specifies the file name

TEKEXP:INFO?
This command queries the information about the file(s).

Syntax Outputs
TEKEXP:INFO?
REPORT\n

<ReportFileSize>,"<ReportFileName.mht>"

TEKEXP:INFO? WFM
\n

<WfmFile1Size>,"<WfmFileName1.wfm>";<WfmFile2Size>,"<WfmFileNa
me2.wfm>";...

TEKEXP:INFO?
IMAGE\n

<Image1FileSize>,"<Image1FileName>";<Image2FileSize>,"<Image2File
Name>" ;...
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TEKEXP:INSTRUMENT
This command sets the value for the selected instrument type. 

Syntax TEKEXP:INSTRUMENT "<InstrumentType>",<Value>"\n

Inputs InstrumentType

Value

TIP. Check Command parameters list section for InstrumentType and Value
parameters.

Outputs NA

TEKEXP:INSTRUMENT?
This command queries the instrument selected for the specified instrument type. 

Syntax TEKEXP:INSTRUMENT? "<InstrumentType>"\n

Inputs InstrumentType

TIP. Check Command parameters list section for InstrumentType parameters.

Outputs Returns the instrument selected for the specified instrument type
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TEKEXP:LASTERROR?
This command queries the last error string occurred for the current TCP session.
If there are no errors since startup, or since the last call to
TEKEXP:LASTERROR?\n, this command returns an empty string.

Syntax TEKEXP:LASTERROR?\n

Inputs NA

Outputs <string>

TEKEXP:LIST?
This command queries the list of available device, suite, test, version or
instrument. 

Syntax Outputs
TEKEXP:LIST? DEVICE\n Returns the list of available device(s) as comma

separated values.
TEKEXP:LIST? SUITE\n Returns the list of available suite(s) as comma

separated values.
TEKEXP:LIST? TEST\n Returns the list of available test(s) as comma

separated values.
TEKEXP:LIST? VERSION\n Returns the list of available version(s) as comma

separated values.
TEKEXP:LIST?
INSTRUMENT,"<InstrumentType>"\n

Returns the list of available instruments' for the
given Instrument type as comma separated
values.

NOTE. This command returns the list of items within double quotes (""). Iterate
the receive procedure until the list ends with double quotes otherwise the next
query commands won’t work as expected.
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Inputs InstrumentType

TIP. Check Command parameters list section for InstrumentType parameters.

TEKEXP:MODE
This command sets the execution mode as compliance or user defined. 

Syntax TEKEXP:MODE {COMPLIANCE | USER-DEFINED}\n

Inputs {COMPLIANCE | USER-DEFINED}

Outputs NA

TEKEXP:MODE?
This command queries the execution mode type. 

Syntax TEKEXP:MODE?\n

Inputs NA

Outputs {COMPLIANCE | USER-DEFINED}
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TEKEXP:POPUP
This command sets the response to the active popup shown in the application.

Syntax TEKEXP:POPUP “<PopupResponse>”\n

Inputs PopupResponse

Outputs NA

TEKEXP:POPUP?
This command queries the active popup information shown in the application.

Syntax TEKEXP:POPUP?\n

Inputs NA

Outputs Returns the active popup information in the application.
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TEKEXP:REPORT
This command generates the report for the current session. 

Syntax TEKEXP:REPORT GENERATE\n

Inputs GENERATE

Outputs NA

TEKEXP:REPORT?
This command queries the queried header field value in the report.

Syntax TEKEXP:REPORT? “<HeaderField>”\n

Inputs HeaderField - Specifies to return the measured value for the indicated test.

TIP. Check Report for HeaderField parameters.

Outputs Returns the queried header field value in the report
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TEKEXP:RESULT?
This command queries the result available in report summary/details table.

Syntax Outputs
TEKEXP:RESULT? "<TestName>"\n Return Pass/Fail status of the test.
TEKEXP:RESULT?
"<TestName>","<ColumnName>"\n

Returns all the row values of the specified
column for the test.

TEKEXP:RESULT?
"<TestName>","<ColumnName>",<RowNumber
>\n

Returns the column value for the specified row
number  1

Inputs TestName - Specifies the name of the test for which to obtain the test result
value.

ColumnName - Specifies the column name for the measurement

RowNumber - Specifies the row number of the measurement

TIP. Check Results panel for TestName, ColumnName, and RowNumber
parameters.

1 Row number starts from zero.
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TEKEXP:SELECT
This command selects the device, suite, version, or test. 

Syntax TEKEXP:SELECT <string1>,<string2>,<string4>\n

TEKEXP:SELECT TEST,<string3>,<string4>\n

Inputs <string1> = {DEVICE | SUITE | VERSION}

<string2> = {DeviceName | SuiteName | VersionName}

<string3> = {“<TestName>"| ALL| REQUIRED }

<string4> = {TRUE | FALSE}

TIP. Check Command parameters list section for DeviceName, SuiteName,
VersionName, and TestName parameters.

Outputs NA

TEKEXP:SELECT?
This command queries the name of the selected device, suite, version, or test. 

Syntax TEKEXP:SELECT? {DEVICE | SUITE | TEST | VERSION}\n

Inputs {DEVICE | SUITE | TEST | VERSION}
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Outputs Returns the name of the selected device, suite, version, or test.

TEKEXP:SETUP
This command sets the value of the current setup.

Syntax Outputs
TEKEXP:SETUP DEFAULT\n Restore to default Setup
TEKEXP:SETUP OPEN,"<SessionName>"\n Open the session
TEKEXP:SETUP SAVE\n Saves the already existing modified session
TEKEXP:SETUP SAVE,"<SessionName>"\n Save the session

Inputs SessionName - The name of the session

TEKEXP:STATE
This command sets the execution state of the application.

Syntax TEKEXP:STATE {RUN | STOP | PAUSE | RESUME}\n

Inputs {RUN | STOP | PAUSE | RESUME}

Outputs NA
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TEKEXP:STATE?
This command queries the current setup state. 

Syntax Outputs
TEKEXP:STATE? RUNNING | PAUSED | WAIT | ERROR | READY
TEKEXP:STATE? SETUP SAVED | NOT_SAVED

TEKEXP:VALUE
This command sets the value of parameters of type General, Acquire, Analyze, or
DUTID. 

Syntax TEKEXP:VALUE GENERAL,"<ParameterName>",“<Value>”\n

TEKEXP:VALUE ACQUIRE,“<TestName>","<AcquireType>",
"<ParameterName>",“<Value>”\n

TEKEXP:VALUE ANALYZE,“<TestName>","<ParameterName>".“<Value>”
\n

TEKEXP:VALUE DUTID,“<Value>”\n

TEKEXP:VALUE VERBOSE,{TRUE | FALSE}\n

TEKEXP:VALUE
WFMFILE,<Test_Name>,<Aquire_Type>,<FilesName1$FileName2>\n

Inputs ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

Value - Specifes the value to set

FilesName1$FileName2 - Specifies the waveform file name

TRUE - Pop-ups are enabled

FALSE - Pop-ups are disabled

TIP. Check Command parameters list section for ParameterName, AcquireType,
and Value parameters.
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Outputs NA

TEKEXP:VALUE?
This command queries the value of the parameter for type General, Acquire,
Analyze, or DUTID.

Syntax Outputs
TEKEXP:VALUE?
GENERAL,"<ParameterName>"\n

Returns the value of Parameter for type
GENERAL

TEKEXP:VALUE? ACQUIRE,“<TestName>",
"<AcquireType>","<ParameterName>"\n

Returns the value of Parameter for type
ACQUIRE

TEKEXP:VALUE? ANALYZE,
“<TestName>","<ParameterName>"\n

Returns the value of Parameter for type
ANALYZE

TEKEXP:VALUE? DUTID\n Returns the DUTID value
TEKEXP:VALUE?
WFMFILE,<Test_Name>,<Aquire_Type>\n

Returns the waveform file name

TEKEXP:VALUE? VERBOSE Returns the verbose mode type

Inputs ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

TRUE - Pop-ups are enabled

FALSE - Pop-ups are disabled

TIP. Check Command parameters list section for ParameterName and
AcquireType parameters.

Outputs Returns the value of Parameter for type GENERAL | ACQUIRE | ANALYZE |
DUTID.
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Command parameters
This section provides the parameters list for the SCPI commands.

Specifies the Parameter Name and Value for DUT, Test selection, Acquisition,
Configuration and Preferences tabs.

Parameters Description
DUT ID Specifies the value parameters For DUTID, valid value is: Comment
Acquiremode Specifies the acquire mode parameters

■ Acquire live waveforms
■ Use pre-recorded waveform files

Mode ■ Compliance
■ User Defined

Version CTS 2.1 
Suite ■ Source

■ Sink

Device Profile
Data Rate For 3,6,8,10,12 

■ TRUE
■ FALSE

Data Rate to run
Minimum (Gbps)

3 

Data Rate to run
Maximum (Gbps)

12 

Vterm(V) 0 to 3.4 
EDID/SCDC Controller ■ None

Signal Validation ■ Prompt me if Signal Check Fails
■ Skip Test if Signal Check Fails
■ Turn Off Signal Check

Multi-Lane (Setup) ■ P76XX/P77XX
■ Dual Stack

■ Lane 0 
■ Lane 1 
■ Lane 2 
■ Lane 3 
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Table 16: Parameter Name and Value for Test Selection tab

Parameters Description
Source Specifies the test measurement name

■ HFR1-1: DC Common Mode Voltage
■ HFR1-2: Vse_max ,Vse_min
■ HFR1-3: Rise/Fall Slew Rate
■ HFR1-4: Inter-Pair Skew
■ HFR1-5: FRL Rates
■ HFR1-6: Data Jitter(RJ)
■ HFR1-7: Data Eye Diagram
■ HFR1-8: AC Common Mode Voltage
■ HFR1-9: FFE Monotonicity-Method 1 
■ HFR1-9: FFE Monotonicity-Method 2 

Sink Specifies the test measurement name

■ HFR2-1: Max Differential Swing Tolerance
■ HFR2-2: Intra-Pair Skew
■ HFR2-3: Inter-Pair Skew
■ HFR2-4: Minimum Link Rate Tolerance
■ HFR2-5: Jitter Tolerance

Table 17: Parameter Name and Value for Acquisitions tab

Parameters Description
Acquisition Options ■ Acquire all and analyze

■ Acquire only

Waveform Options ■ Retain
■ Delete

Show Acquire Parameters ■ TRUE
■ FALSE
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Table 18: Parameter Name and Value for Preferences tab

Parameters Description
Number of Runs
Acquire/Analyze each test ■ TRUE

■ FALSE

1 to 1000 times
Popup Settings
Auto close Warnings and informations during Sequencing ■ TRUE

■ FALSE

Value to be given in seconds
Auto close Error Messages during Sequencing. Show in Reports ■ TRUE

■ FALSE

Value to be given in seconds
Show messages with a beep sound ■ TRUE

■ FALSE

Table 19: Parameter Name and Value for General

Parameters Description
Generate new report ■ TRUE

■ FALSE

Append with previous run session ■ TRUE
■ FALSE

Replace current test results ■ TRUE
■ FALSE

■ in previous run, current session
■ in any run, any session

Include Header in appended reports ■ TRUE
■ FALSE

Save As Type ■ Web Archive (*.mht;*.mhtml)
■ PDF (*.pdf)
■ CSV (*.csv)
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Parameters Description
Auto increment report name if duplicate ■ TRUE

■ FALSE

Create report automatically at the end of the run ■ TRUE
■ FALSE

Include pass/fail results Summary ■ TRUE
■ FALSE

Include detailed results ■ TRUE
■ FALSE

Include plot images ■ TRUE
■ FALSE

Include setup configuration ■ TRUE
■ FALSE

Include user comments ■ TRUE
■ FALSE

Margin value in percentage ■ TRUE
■ FALSE

View report after generating ■ TRUE
■ FALSE

Vertical Autoset ■ Auto
■ Manual

Vertical Offset(V) 0 to 4 
Vertical Position(div) -1 to 1 
Vertical Scale(mV) 30 to 100 
Vertical Bandwidth 0.5 to 21 
Horizontal Sampling Rate(GS/s) 50 to 200 
Record Length 8000000 to 16000000 
Apply DE-Embed ■ TRUE

■ FALSE
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Table 20: Parameter Name and Value for Acquire

Test Name Acquire Type Parameter Name Value

■ HFR1-8: AC
Common Mode Noise

Bandwidth (3Gbps) 2 GHz
Bandwidth (6Gbps) 3 GHz
Bandwidth (8Gbps) 4 GHz
Bandwidth (10Gbps) 5 GHz
Bandwidth (12Gbps) 6 GHz

Table 21: Parameter Name and Value for Clock Recovery

Test Name Acquire Type Parameter Name Value

■ HFR1-6: Data
Jitter(RJ)

■ HFR1-7: Data
Eye Diagram

PLL Model ■ Type I
■ Type II

3Gbps : Loop
BW(MHz)

0.000001 to 2500 

6Gbps : Loop
BW(MHz)

0.000001 to 2500 

8Gbps : Loop
BW(MHz)

0.000001 to 2500 

10Gbps : Loop
BW(MHz)

0.000001 to 2500 

12Gbps : Loop
BW(MHz)

0.000001 to 2500 
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Table 22: Parameter Name and Value for Cable Settings

Test Name Acquire Type Parameter Name Value

■ HFR1-6: Data
Jitter(RJ)

■ HFR1-7: Data
Eye Diagram

Cable Model ■ SCM
■ WCM
■ Both

Crosstalk ■ With
■ Without
■ Both

Equalizer Options ■ CTLE+DFE
■ CTLE

CTLE ■ SCM (dB)

■ 1 to 8 , All
■ WCM (dB)

■ 1 to 8 , All

Apply Custom Mask
File ■ TRUE

■ FALSE
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Examples

Example Description
TEKEXP:*IDN? It returns the active TekExpress application name running on the

scope.
TEKEXP:*OPC? It returns the last command execution status.
TEKEXP:ACQUIRE_MODE PRE-RECORDED It sets the acquire mode as pre-recorded.
TEKEXP:ACQUIRE_MODE? It returns LIVE when acquire mode is set to live.
TEKEXP:EXPORT REPORT It returns the report file in bytes. This can be written into another file

for further analysis.
TEKEXP:INFO? REPORT It returns “100,”ReportFileName.mht”", when 100 is the filesize in

bytes for the filename ReportFileName.
TEKEXP:INFO? WFM It returns “100,“WfmFileName1.wfm”";“200,“WfmFileName2.wfm”"

when 100 is the filesize in bytes for the filename
WfmFileName1.wfm and 200 is the filesize in bytes for the filename
WfmFileName2.wfm.

TEKEXP:INSTRUMENT "Real Time Scope",DPO72504D
( GPIB8::1::INSTR )

It sets the instrument value as DPO73304SX ( GPIB8::1::INSTR )
for the selected instrument type Real Time Scope.

TEKEXP:INSTRUMENT? “Real Time Scope” It returns "DPO73304SX ( GPIB8::1::INSTR ), when DPO73304SX
( GPIB8::1::INSTR )" is the selected instrument for the instrument
type Real Time Scope.

TEKEXP:LASTERROR? It returns ERROR: INSTRUMENT_NOT_FOUND, when no
instrument is found.

TEKEXP:LIST? DEVICE It returns "Source" when Source is the available suite.
TEKEXP:LIST? INSTRUMENT,"Real Time Scope" It returns "DPO73304SX ( GPIB8::1::INSTR ),DPO73304SX

( TCPIP::134.64.248.91::INSTR )" when DPO73304SX
( GPIB8::1::INSTR ), DPO73304SX ( TCPIP::
134.64.248.91::INSTR ) are the list of available instruments.

TEKEXP:MODE COMPLIANCE It sets the execution mode as compliance.
TEKEXP:MODE? It returns COMPLIANCE when the execution mode is compliance.
TEKEXP:POPUP “OK” It sets OK as the response to active popup in the application.
TEKEXP:POPUP? It returns "OK", when OK is the active popup information shown in

the application.
TEKEXP:REPORT GENERATE It generates report for the current session.
TEKEXP:REPORT? “Scope Model” It returns "DPO73304SX" when DPO73304SX is the scope model.
TEKEXP:REPORT? “DUT ID” It returns "DUT001" when DNI_DUT001 is the DUT ID.
TEKEXP:RESULT? "HFR1-1: DC Common Mode" It returns Pass, then the test result is Pass.
TEKEXP:RESULT? "HFR1-1: DC Common Mode", "Margin" It returns list of values then that is ‘Margin’ column data.
TEKEXP:RESULT? TEKEXP:RESULT? "HFR1-1: DC Common
Mode", "Units",0 

It returns the unit of the first row of result.

TEKEXP:SELECT DEVICE,"FRL" It selects device as "Source".
TEKEXP:SELECT TEST,"HFR1-1: DC Common Mode", TRUE It selects "HFR1-1: DC Common Mode" measurement.
TEKEXP:SETUP DEFAULT It restores the application to default setup.
TEKEXP:STATE STOP It stops the test execution.
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Example Description
TEKEXP:STATE? It returns as READY when the application is ready to run next

measurement.
TEKEXP:STATE? SETUP It returns as NOT_SAVED when the current setup is not saved.
TEKEXP:VALUE GENERAL, "3 Gbps", " False “ It selects 3 Gbps data rate in the DUT panel by deselecting

checkbox.
TEKEXP:SELECT TEST ,"HFR2-1: Max Differential Swing
Tolerance",True

The test "HFR2-1: Max Differential Swing Tolerance" is selected in
test selection panel.

TEKEXP:VALUE GENERAL, "Execute","Verify Calibration" It selects verify calibration in the drop-down from DUT panel.
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