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Welcome

Welcome to the TekExpress® LVDS application. The Tektronix TekExpress® LVDS transmitter test application offers physical layer test
solution for transmitter parameter measurements and characterization. The TekExpress® LVDS automated test solution, along with a
Tektronix 5/6 Series MSO or 70KC oscilloscope provides an easy way to measure, test, debug, and characterize the electrical and timing
measurements of various flavors of LVDS.

Key features and benefits

• Supports measurement from multiple LVDS standards
• Configurable test settings and limits
• Automatic mask for data rate and maximum voltage swing (MSV)
• Generic clock recovery configuration
• Reference level and filter file selection
• Multi-Run support
• Supports multiple report formats
• Supports TekExpress remote API - SCPI commands

Welcome
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Getting help and support
Related documentation
The following manuals are available as part of the TekExpress LVDS application documentation set.

Table 1: Product documentation

Item Purpose Location

Online Help In-depth operation and UI help.

PDF of the Online Help
(077-1623-xx)

In-depth operation and UI help.

Conventions
Help uses the following conventions:

• The term "Application," and "Software" refers to the TekExpress LVDS application.
• The term “DUT” is an abbreviation for Device Under Test.
• The term “select” is a generic term that applies to the two methods of choosing a screen item (button control, list item): using a mouse

or using the touch screen.
• A Note identifies important information.

Table 2: Icon descriptions

Icon Meaning

This icon identifies important information.

This icon identifies conditions or practices that could result in loss of data.

This icon identifies additional information that will help you use the application more
efficiently.

Technical Support
Tektronix values your feedback on our products. To help us serve you better, please send us your suggestions, ideas, or comments on
your application or oscilloscope. Contact Tektronix through mail, telephone, or the Web site. See Contacting Tektronix at the front of this
document for contact information.

When you contact Tektronix Technical Support, please include the following information (be as specific as possible): 

Getting help and support
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General information
• All instrument model numbers
• Hardware options, if any
• Modules used
• Your name, company, mailing address, phone number, FAX number
• Please indicate if you would like to be contacted by Tektronix about your suggestion or comments.

Application specific information
• Software version number
• Description of the problem such that technical support can duplicate the problem
• If possible, save the setup files for all the instruments used and the application
• If possible, save the TekExpress setup files, log.xml, *.TekX (session files and folders), and status messages text file
• If possible, save the waveform on which you are performing the measurement as a .wfm file

Getting help and support
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Getting started
Supported oscilloscopes

Supported models

70K series MSO with bandwidth ≥ 350 MHz.

Bandwidth selection is based on the signal characteristics (data rate) as shown below:

Some examples to calculate the bandwidth are as follows:

• For 800 Mbps data rate, (800/2) * 5 = 2 GHz
• For 1.5 Gbps data rate, (1.5/2) * 5 = 3.750 GHz
• For 5 Gbps data rate, (5/2 * 5) = 12.5 GHz

Recommended probes

The following are the list of probes required:

• Differential Probes

Two Differential probes P7700 - 70000C oscilloscopes with probe accessories
• Single ended Probes

SMA to BNC adapter (DUT fixture dependent)

Downloading and installing the software
Complete the following steps to download and install the latest LVDS application. 

1. Go to www.tek.com.
2. Click Downloads. In the Downloads menu, select DOWNLOAD TYPE as Software and enter LVDS in the MODEL OR KEYWORD

field and click SEARCH.

3. Select the latest version of software and follow the instructions to download. Copy the executable file to the oscilloscope.
4. Double-click the executable and follow the on-screen instructions. The software is installed at C:\Program

Files\Tektronix\TekExpress\TekExpress LVDS.
5. Select Analyze > TekExpress LVDS from the oscilloscope Menu bar to launch the application.

Getting started
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Activate the license
Activate the license using the Option Installation wizard in the TekScope application:

1. In the TekScope application menu bar, click Utilities > Option Installation.

The TekScope Option Installation wizard opens.
2. Push the F1 key on the oscilloscope keyboard to open the Option Installation help topic.
3. Follow the directions in the help topic to activate the license.

View software version
Use the following instructions to view version information for the application and for the application modules.

To view version information for LVDS, click Options > About TekExpress.

File name extensions
The TekExpress LVDS application uses the following file name extensions:

Table 3: File name extension

File name extension Description

.TekX Application session files (the extensions may not be displayed)

.py Python sequence file

.xml Test-specific configuration information (encrypted) files

Application log files

.csv Test result reports

Plot data

.mht Test result reports (default)

Test reports can also be saved in HTML formats.

.msk A user mask file.

.pdf Test result reports

Application help document

Table continued…

Getting started
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File name extension Description

.xslt Style sheet used to generate reports

.png Captured images

.flt Inverse filter co-efficient

Getting started
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Operating basics
Launch the application
To launch the TekExpress LVDS application, select Analyze > TekExpress LVDS from the oscilloscope Menu bar.

After first launch of Tekexpress LVDS application following changes take place on the oscilloscope.

During launch, a "My TekExpress" folder is created in the Documents folder of the current user and gets mapped to "X" drive. When the
application is closed properly, the "X" drive will get unmapped.

Note: If a user with new login ID launches "TekExpress LVDS.exe", the "My TekExpress" folder is created in the Documents folder
of the new user.

When you first run the application after installation, the application checks for Resources.xml located in the X:\ folder. The Resources.xml
file gets created in the X: drive. If the file is not found, then the application creates the file with equipment details. Session files are then
stored inside the X:\LVDS folder. If this file is not found, the application runs an instrument discovery program to detect connected
instruments before launching TekExpress LVDS.

To keep the TekExpress LVDS application window on top, select Keep On Top from the Options menu. If the application goes behind the
oscilloscope application, click Analyze > TekExpress LVDS to move the application to be in front.

Note: When Keep on Top is selected, you cannot access the combo boxes in the application panels.

See also
 

Exit the application

Operating basics
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Exit the application

To exit the application, click    on the application title bar. Follow on-screen prompts to save any unsaved session, save test setup
files, or exit the application.

Note: Using other methods to exit the application can result in abnormal termination of the application.

Application controls
This section describes the application controls.

Table 4: Application control description

Item Description
Options menu Menu to display global application controls.

Test panel Controls that open tabs for configuring test settings and options.

Start / Stop button Use the Start button to start the test run of the measurements in the selected order. If prior
acquired measurements are not cleared, then new measurements are added to the existing
set.

The button toggles to the Stop mode while tests are running. Use the Stop button to abort
the test.

Pause / Continue button Use the Pause button to pause the acquisition. When a test is paused, this button changes
as Continue.

Clear button Use the Clear button to clear all existing measurement results. Adding or deleting a
measurement, or changing a configuration parameter of an existing measurement, also
clears measurements. This is to prevent the accumulation of measurement statistics or
sets of statistics that are not coherent. This button is available only on Results panel.

Note: This button is visible only when there are results data on the panel.

Application window move icon Place the cursor over the top of the application window to move the application window to
the desired location

Table continued…
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Item Description
Minimize icon Minimizes the application.

Close icon Close the application.

Mini view / Normal view Toggles the application between mini view and normal view.

Mini view displays the run messages with the time stamp, progress bar,

Start / Stop button, and Pause / Continue button.

The application moves to mini view when you click the Start button.

Global application controls
The menus and controls that appear outside the individual tabs are called “Global Controls”. These are used to specify the devices to be
tested. 

Options menu overview

To accesses Options menu, click  in the upper-right corner of the application. It has the following selections: 

Menu Function

Default Test Setup Opens an untitled test setup with defaults selected

Open Test Setup Opens a saved test setup

Save Test Setup Saves the current test setup

Save Test Setup As Saves the current test setup with a different file name or file type

Open Recent Displays the recently opened test setups to open

Instrument Control Settings Detects, lists, and refreshes the connected instruments found on specified connections (LAN, GPIB,
USB, and so on)

Keep On Top Keeps the TekExpress LVDS application on top of all the application

Note: When Keep on Top is selected, you cannot access the combo boxes in the application
panels.

Email Settings Configures email options for test run and results notifications

Help Displays the TekExpress LVDS help

Table continued…

Operating basics
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Menu Function

About TekExpress • Displays application details such as software name, version number, and copyright

• Provides a link to the end-user license agreement

• Provides a link to the Tektronix Web site

See also
Application controls

TekExpress instrument control settings
Use the TekExpress Instrument Control Settings dialog box to search the instruments (resources) connected to the application. You can
use the Search Criteria controls to search the connected instruments depending on the connection type. The details of the connected
instrument is displayed in the Retrieved Instruments window.

To access, click Options > Instrument Control Settings. 

The connected instruments displayed here can be selected for use under Global Settings in the test configuration section.

Note: Select GPIB (Default) and LAN when using TekExpress LVDS application on 6 series MSO instruments.

See also
Options menu overview

View connected instruments
Use the TekExpress Instrument Control Settings dialog box to search the instruments (resources) connected to the application. The
application uses TekVISA to discover the connected instruments. 

Note: The instruments required for the test setup must be connected and it must be recognized by the application before running
the test.

To refresh the list of connected instruments:

Operating basics
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1. From the Options menu, select Instrument Control Settings.
2. In the Search Criteria section of the Instrument Control Settings dialog box, select the connection types of the instruments to search.

Instrument search is based on the VISA layer, but different connections determine the resource type, such as LAN, GPIB, and USB.
For example, if you choose LAN, the search will include all the instruments supported by TekExpress that are communicating over the
LAN.

3. Click Refresh. TekExpress searches for connected instruments.
4. After searching, the dialog box lists the instrument-related details based on the search criteria. For example, for the Search Criteria as

LAN and GPIB, the application displays all LAN and GPIB instruments connected to the application.

The details of the instruments are displayed in the Retrieved Instruments table. The time and date of instrument refresh is displayed in the
Last Updated field.

See also
Equipment connection diagram on page 46

Configure email settings
Use the Email Settings utility to get notified by email when a measurement completes, or produces any error condition. Follow the steps
to configure email settings: 

1. Select Options > Email Settings to open the Email Settings dialog box.
2. (Required) For Recipient email Address(es), enter one or more recipient email addresses. To include multiple addresses, separate

the addresses with commas.
3. (Required) For Sender’s Address, enter the email address used by the instrument. This address consists of the instrument name,

followed by an underscore, followed by the instrument serial number, then the @ symbol, and the email server ID. For example:
user@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server address of the Mail server configured at the client location,
and the SMTP Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name, password, and host name in the corresponding fields.

Note: If any of the above required fields are left blank, the settings will not be saved and email notifications will not be sent.

5. In the Email Attachments section, select from the following options:

• Reports: Select to receive the test report with the notification email.

• Status Log: Select to receive the test status log with the notification email. If you select this option, then also select whether you
want to receive the full log or just the last 20 lines.

6. In the Email Configuration section:

• Enter a maximum file size for the email message. Messages with attachments larger than this limit will not be sent. The default is
5 MB.

• Enter the number in the Number of Attempts to Send field, to limit the number of attempts that the system makes to send a
notification. The default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use this check box to quickly enable or disable email
notifications.

8. To test your email settings, click Test Email.
9. To apply your settings, click Apply.
10. Click Close when finished.

Operating basics
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Application panels overview
TekExpress LVDS application uses panels to group Test Setup Configuration, Results, and Reports settings. Click any button to open
the associated panel. A panel may have one or more tabs that list the selections available in that panel. Controls in a tab can change
depending on settings made in the same tab or another tab.

Table 5: Application panels overview

Panel Name Purpose

Setup panel The Setup panel shows the test setup controls. Click the Setup button to open this panel.

Use this panel to:

• Set DUT tab parameters
• Select tests
• Set acquisition tab parameters
• Set configuration tab parameters
• Set preferences tab parameters

Status panel View the progress and analysis status of the selected tests, and view test logs.

Results panel View the summary of test results and select result viewing preferences.

Reports panel Browse for reports, save reports as specific file types, specify report naming conventions, select report
content to include (summary information, detailed information, user comments, setup configuration,
application configuration, etc.), and select report viewing options.

Operating basics
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See also
Application controls

Setup panel

Setup panel overview
The Setup panel contains sequentially ordered tabs that help you guide through the test setup and execution process.

Set DUT parameters
Use the DUT tab to select parameters for the device under test. These settings are global and apply to all tests of the current session. DUT
settings also affect the list of available tests in the Test Selection tab.

Operating basics
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Click Setup > DUT to access the DUT parameters: 

Table 6: DUT tab settings

Settings Description
DUT ID Adds an optional text label for the DUT to reports. The default value is DUT001. The maximum number

of characters is 32.

You cannot use the following characters in an ID name: (.,..,...,\,/:?”<>|*)

   Comments icon (to the
right of the DUT ID field)

Opens the Comments dialog box to enter text to add to the report. Maximum size is 256 characters. To
enable or disable comments appearing on the test report, see Select report options .

Acquire live waveforms Acquires active signals from the DUT for measurement and analysis.
Session : Default Click  to save multiple config sessions or run multiple sessions together. Check Multiple-session

run on page 26 for details about how to save multiple config sessions and runs the multiple config/run
sessions together.

Device Select the device type from the drop-down list.
Standard Select the standard from the drop-down list.
Version Select the version from the drop-down list.
Device Profile
Skip Scope Settings Select to skip the oscilloscope settings.
Apply Limits for Measurement Select to apply the limits for the measurements.
Clock Embedded Select to enable the embedded clock.
Table continued…
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Settings Description
Clock Frequency (MHz) Enter the clock frequency value in the text box.
Bandwidth Limit Select to enable bandwidth limit for all lanes.
Bandwidth Value (MHz) Enter the low-pass bandwidth limit filter value in the text box.

Note: Bandwidth is adjusted to the closest available value in the oscilloscope using
geometric rounding.

Example: When you set the bandwidth limit as 50 for an oscilloscope having available
Bandwidth limit values of 20 MHz, 250 MHz, and 500 MHz, the application applies the closest
bandwidth limit (20 MHz) for all the channels of the oscilloscope.

SSC Switch the SSC enabled/disabled from the drop-down list. By default Disabled is selected.
Reference Levels Select the reference level from the drop-down list.
Data Lane Probing Select the data lane probing from the drop-down list.
Clock Lane Probing Select the clock lane probing from the drop-down list.
Cklp-Ckln Select the channel from the drop-down list.
Multi-Lane Setup Displays the test lanes selected for the test session.

To change lanes selected for testing, click Setup.

1. In the Test Lane Setup dialog box, select the desired number of lanes from the Link Width
drop-down list.

2. In the Test Lane Setup menu, select the number of lanes selected, the Source+ve, and the
Source-ve for each lane and click OK.

Note: Your selections display in the Lane Setup section of the DUT tab.

Operating basics
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See also
Select tests

Operating basics
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Multiple-session run
Multiple-sessions run feature allows you to save multiple config sessions and runs the multiple config/run sessions together.

Click ( ) button in the DUT panel. The Run/Config Sessions window displays the list of saved Run/Config sessions.

Run the test that are selected in the Test Selection tab, the Run sessions are created automatically and displayed in the Run/Config
Sessions window after the test is executed. You can also save the Config session by configuring the settings in the application.

The Run/Config sessions window provides the summary of the sessions with session name, Type. You can also note-down the
configuration changes in the comment column.

The Run/Config Session window allows you to save, load, delete, and set the sessions as default.

Operating basics
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• Session name: Enter the name to save the config session. The maximum number of character supported is 40 and special characters
(.,..,...,\,/:?”<>|*) are not supported.

• Save Session: Save current configuration as a session with the given session name.
• Close: Close the Run/Config Session window.
• Default Session: Sets the application configurations to default values.
• Load session: Load the selected config/run session.
• Delete Session(s): Delete the selected config/run session.
• Run Sessions: Run the selected config/run session.

Enable/ Disable the Multi Run session
By default the Multi Run Session is enabled in the application. Set the IsMultiSessionRunEnabled value to false to disable the Multi Run
Session feature in the TekExpress.exe.Config file, which is downloaded along the application.

Select tests
Use the Test Selection tab to select the tests. The test measurements available depends on the settings selected in the DUT. tab. 

Operating basics
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Figure 1: TekExpress LVDS Measurements

Table 7: Test Selection tab settings

Setting Description

Deselect All

Select All

Deselect or select all tests in the list.

Tests Click on a test to select or unselect. Highlight a test to show details in the Test Description pane.

Test Description Shows brief description of the highlighted test in the test tree.

Schematic Shows an equipment and test fixture setup schematic (connection diagram) for the selected test. Use to set up the
equipment and fixtures or to verify the setup before running the test.

See also
Set acquisition tab parameters

Set acquisition tab parameters
Use the Acquisitions tab to view the test acquisition parameters. The contents displayed on this tab depends on the DUT type and the
tests selected.

Operating basics
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Table 8: Acquisitions tab settings

Settings Description
View Probes Displays the detected probe configuration. Use the View Probes

dialog box to view the connected probes.
Refresh sources Refresh and updates the sources list.
Acquisition and Save options
Save All Waveforms Before Analysis Saves all the waveforms before the analysis.
Save and Analyze Acquisition In Sequence Saves and then analyses the acquisition in sequence.
Show Acquire Parameters Select to view the acquisition parameters

The TekExpress LVDS saves all acquisition waveforms to files by default. Waveforms are saved in a unique folder for each
session (a session is started when you click the Start button). The folder path is X:\TekExpress LVDS\Untitled
Session\<dutid>\<date>_<time>. Images created for each analysis, XML files with result values, reports, and other
information specific to the sessions are also saved in this folder.

Saving a session moves the session file contents from the Untitled Session folder to the specified folder name, and changes the session
name to the specified name.

Operating basics
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Set configuration tab parameters
Use the Configuration tab to view and configure the Global Settings and the measurement configurations. The measurement specific
configurations available in this tab depends on the selections made in the DUT panel and Test Selection panel. 

Table 9: Configuration tab: Common parameters

Setting Description
Limits Editor Displays the upper and lower limits for the applicable measurement using different types of

comparisons.
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Figure 2: Configuration tab: Global Settings

Table 10: Configuration tab: Global settings

Setting Description

Global Settings

Instruments Detected Displays the instruments connected to this application. Click on the instrument name to
open a list of available (detected) instruments.

Select Options > Instrument Control Settings and click Refresh to update the
instrument list.

Note: Verify that the LAN and GPIB search criteria (default setting) in the
Instrument Control Settings is selected when using the TekExpress LVDS
application.

Record Length (M) Enter the record length value in the text box.

Sample Rate (GS/s) Enter the sample rate value in the text box.

Average Acquisition Mode Select to enable the average acquisition mode.

Table continued…
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Setting Description

Average Number of Waveforms Enter the average number of Waveforms value in the text box

Available only when Average Acquisition Mode is enabled.

Mask Type Select the mask type from the drop-down list.

• Auto
• Manual

Mask Setup Mask Shape: Select the desired mask shape from the drop-down.

• Square
• Hexagon
• Octagon

Unit Interval (s): Displays the horizontal length of the segments 1 and 2, which is equal to
the unit interval of the data signal.

Max Swing Voltage (V): Displays peak to peak voltage of data signal.

Scale Factors:

• X Scale factors: Displays x co-ordinate value of a mask point relative to UI (unit
interval).

• Y Scale factors: Displays y co-ordinate value of a mask point relative to UI (unit
interval).

Default Scale Factor: Click to populate all the default values of x and y scale factors.

Generate Mask: Click to generate the automatic mask file.

Click Generate Mask: reflects only the changes done in UI .

Mask Point: Click to view the absolute values of all the points in mask file.

Close: Click to close the auto mask utility.

Table continued…
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Setting Description

Clock Recovery Method (For Data-Jitter
measurements)

Select the clock recovery method from the drop-down list.

• Constant Clock Mean
• Explicit Clock Edge
• PLL Custom Bandwidth-Type 1
• PLL Custom Bandwidth-Type 2

Clock Recovery Setup Clock Recovery Method: Select the desired clock recovery method based on the DUT.

Nominal Data Rate: Select the nominal data rate from the drop-down list.

Bit Rate (Gb/s): Enter the bit rate value, only when nominal data rate is turned on.

Apply Filter 1 Select the check box to enable the filter 1 and browse to select the filter file.

Apply Filter 2 Select the check box to enable the filter 2 and browse to select the filter file.

Note: Filter file selection for de-embedding is based on the sample rate selection on the horizontal settings tab in the
measurements panel.
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Figure 3: Configuration tab: Measurements

Table 11: Configuration tab: Measurements settings

Setting Description

Measurements Displays the measurements that are selected in the Test Selection tab. The tests are
grouped with unique acquisition type names.

Note:

• When a parent test group is selected and any change is made, the change
will be applied to all the tests.

• Individual test configuration is possible by selecting the test and making the
required changes.

Analyze

Available for Data Intra Skew (PN) and Clock Intra Skew (PN)

Skew From Edge • Rise
• Fall

Skew To Edge • SameAs
• OppositeAs

Set preferences tab parameters
Use the Preferences tab to set the application action on completion of a measurement. 
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Figure 4: Preferences tab

Table 12: Preferences tab settings

Setting Description

Execution Options

Acquire/Analyze each test <no>
times (not applicable to Custom
Tests)

Select to repeat the test run by setting the number of times. By defaultthe value is 1.

Popup Settings

Auto close Warnings and
Information during Sequencing

Auto close after <no> Seconds

Select to auto close warnings/information during sequencing. Set the Auto close time. By default it is
unselected.

Auto close Error Messages
during Sequencing. Show in
Reports

Auto close after <no> Seconds

Select to auto close Error Messages during Sequencing. Set the Auto close time. By default it is
unselected.

Status panel overview
The Status panel accesses the Test Status and Log View tabs, which provide status on test acquisition and analysis (Test Status) and a
listing of test tasks performed (Log View tab). The application opens the Test Status tab when you start a test run. You can select the Test
Status or the Log View tab to view these items while tests are running. 
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Test Status: The tests are grouped and displayed based on the Clock and Data lane. It displays the tests along with the Acquisition type,
Acquire, and Analysis status of the tests. In pre-recorded mode, Acquire status is not valid.

Log View: It displays the detailed execution status of the tests.

Figure 5: Test status view in the Status panel

Figure 6: Log view in the Status panel
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Table 13: Status panel settings

Control Description

Message History Lists all executed test operations and timestamp information.

Auto Scroll Enables automatic scrolling of the log view as information is added to the log during the test execution.

Clear Log Clears all messages from the log view.

Save Saves the log file to a text file. Use the standard Save File window to navigate to and specify the folder and file name
to which to save the log text.

See also
Application panel overview

Results panel

Results panel overview
When a test execution is complete, the application automatically opens the Results panel to display a summary of test results. 

Each test result occupies a row in the Results table. By default, results are displayed in summary format with the measurement details
collapsed and with the Pass/Fail column visible. Change the view in the following ways:

• To remove or restore the Pass/Fail column, select Preferences > Show Pass/Fail.
• To collapse all expanded tests, select Preferences > View Results Summary.
• To expand all tests listed, select View Results Details from the Preferences menu in the upper right corner.
• To enable or disable the wordwrap feature, select Preferences > Enable Wordwrap.
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• To view the results grouped by lane or test, select the corresponding item from the Preferences menu.
• To expand the width of a column, place the cursor over the vertical line that separates the column from the column to the right. When

the cursor changes to a double-ended arrow, hold down the mouse button and drag the column to the desired width.
• To clear all test results displayed, click Clear.

See also
View a report

Application panel overview

Preferences menu
The Preferences menu is part of the Results panel display. Use the Preferences menu to change how some items display in the Results
panel.

• To include pass/fail details info in the details table, select Show Pass/Fail.
• To view the results summary, select View Results Summary.
• To expand all tests listed, select View Results Details
• To enable or disable the wordwrap feature, select Enable Wordwrap.
• To group the tests by lane, select Group by Lane.
• To group the tests, select Group by Test.

See also
Results panel overview

View test-related files
Files related to tests are stored in My TekExpress\LVDS\Untitled session folder. Each test setup in this folder has both
a test setup file and a test setup folder, both with the test setup name.

The test setup file is preceded by the TekExpress icon and usually has no visible file name extension.

Inside the test setup folder is another folder named for the DUT ID used in the test sessions. The default is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has a folder and file pair, both named for the test session
using the naming convention (date)_(time). Each session file is stored outside its matching session folder:

Each session folder contains image files of any plots generated from running the test session. If you selected to save all waveforms or ran
tests using prerecorded waveform files, these are included here.

The first time you run a new, unsaved session, the session files are stored in the Untitled Session folder located at X:\LVDS.
When you name and save the session, the files are placed in a folder with the name that you specify. A copy of the test files stay in the
Untitled Session folder until you run a new test or until you close the LVDS application. 

See also
File name extensions
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Reports panel
The Report panel contains the Configuration and View Settings tabs to configure the report generation settings and select the test result
information to include in the report. You can use the Reports panel to configure report generation settings, select test content to include in
reports, generate the report, view the report, browse for reports, name and save reports, and select report viewing options.

Report configuration settings
The Configuration tab describes the report generation settings to configure the Reports panel. Select report settings before running a test
or when creating and saving test setups. Report settings configured are included in saved test setups. 

Table 14: Report configuration panel settings

Control Description
View report after generating Automatically opens the report in a Web browser when the test execution is complete. This

option is selected by default.

View Click to view the most current report.
Generate Report Generates a new report based on the current analysis results.
Save As Specify a name for the report.
Report Update Mode Settings
Table continued…
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Control Description
Generate new report Each time when you click Run and when the test execution is complete, it will create a new

report. The report can be in either .mht, .pdf, or .csv file formats.
Append with previous run session Appends the latest test results to the end of the current test results report. Each time when

you click this option and run the tests, it will run the previously failed tests and replace the
failed test result with the new pass test result in the same report.

Include header in appended reports Select to include header in appended reports.
Replace current test in previous run session Replaces the previous test results with the latest test results. Results from newly added

tests are appended to the end of the report.
In previous run, current session Select to replace current test results in the report with the test result(s) of previous run in

the current session.

In any run, any session Select to replace current test results in the report with the test result(s) in the selected run
session’s report. Click and select test result of any other run session.

Report Creation Settings
Report name Displays the name and path of the <Application Name> report. The default

location is at \My Documents>\My TekExpress\<Application
Name>\Reports. The report file in this folder gets overwritten each time you run
a test unless you specify a unique name or select to auto increment the report name.

To change the report name or location, do one of the following:

• In the Report Path field, type the current folder path and name.
• Double-click in the Report Path field and then make selections from the popup

keyboard and click Enter.

Be sure to include the entire folder path, the file name, and the file extension.
For example: C:\Documents and Settings\your user name\My
Documents\My TekExpress\<Application Name> \DUT001.mht.

Note: You cannot set the file location using the Browse button.

Open an existing report

Click Browse, locate and select the report file and then click View at the bottom of the
panel.

Save as type Saves a report in the specified file type, selected from the drop-down list. The report is
saved in .csv, .pdf, or .mht.

Note:

If you select a file type different from the default, be sure to change the report file
name extension in the Report Name field to match.

Auto increment report name if duplicate Sets the application to automatically increment the name of the report file if the application
finds a file with the same name as the one being generated. For example: DUT001,
DUT002, DUT003. This option is enabled by default.

Create report automatically at the end of the
run

Select to create the report with the settings configured, at the end of run.
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Configure report view settings
The View Settings tab describes the report view settings to configure the Reports panel. Select report view settings before running a test or
when creating and saving test setups. Report settings configured are included in saved test setups.

Table 15: Report panel view settings

Control Description
Contents To Save Settings
Include pass/fail info in details table Select to include pass/fail information in the details table of the report.
Include detailed results Select to include detailed results in the report.
Include plot images Select to include the plot images in the report.
Include setup configuration Sets the application to include hardware and software information in the summary box

at the top of the report. Information includes: the oscilloscope model and serial number,
the oscilloscope firmware version, and software versions for applications used in the
measurements.

Include complete application configuration Select to include the complete application configuration in the report.
Table continued…
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Control Description
Include user comments Select to include any comments about the test that you or another user have added in

the DUT tab of the Setup panel. Comments appear in the Comments section, below the
summary box at the beginning of each report.

Include statics table Select to include test run statistics in the report. This is enabled when you run any test for
more than once. Set Acquire/Analyze each test in the Preferences tab to more than one,
to run any test for multiple times.

Group Report By
Test Name Select to group the test results based on the test name in the report.Select to display the

test results by test name.
Test Result Select to group the test results based on the test result in the report.
Lane Name Select to display the test results by lane.

View a report
The application automatically generates a report when test execution is complete and displays the report in your default Web browser
(unless you cleared the View Report After Generating check box in the Reports panel before running the test). If you cleared this check
box, or to view a different test report, do the following: 

1. Click the Reports button.
2. Click the Browse button and locate and select the report file to view.
3. In the Reports panel, click View.

Note: The iteration column will be displayed only when more than one test run is selected.

For information on changing the file type, file name, and other report options, see Select report options.

Report content
A report shows detailed results and plots, as set in the Reports panel.
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Setup configuration information

User comments

See also
Results panel overview
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View test-related files
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Running tests
Equipment connection diagram

Running tests
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Compensate the signal path
Use the following procedure to compensate the internal signal acquisition path. Perform this procedure if the ambient temperature has
changed more than 5 °C (9 °F) since you performed the last signal path compensation. Perform the signal path compensation once a
week. Failure to do so may result in the instrument not meeting warranted performance levels. 

1. Power on and wait for the instrument to complete its warm up period before continuing with this procedure.
2. Disconnect any probes you have connected to the input channels.
3. Set the instrument to Menu mode.
4. Select Instrument Calibration from the Utilities menu.
5. Note any instructions that appear in the resulting control window.
6. Click Run SPC to begin the procedure. The procedure may take several minutes to complete.
7. Verify that the Status changes to Compensated after the procedure is complete. If the Calibration Status field indicates anything other

than Compensated, see Signal Path Compensation Status for information on the readout and recommended action.

Note: When making measurements at vertical scale settings less than or equal to 5 mV, you should perform the signal path
compensation at least once a week. Failure to do so may result in the instrument not meeting warranted performance levels at
those volts/div settings.

Running tests
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Running tests
Use Set DUT parameters, select tests, set acquisition parameters, set configuration parameters, set preferences parameters, and click
Start to run the tests. While tests are running, you cannot access the Setup or Reports panels. To monitor the test progress, switch
between the Status panel and the Results panel. 

While tests are running, the other applications will be displayed at the background. If you want the TekExpress LVDS application to run in
the foreground select Keep On Top from the TekExpress Options menu.

The application displays report when the tests execution is complete.

Prerun checklist
1. Make sure that the instruments are warmed up (approximately 20 minutes) and stabilized.
2. Perform compensation: In the oscilloscope main menu, select Utilities > Instrument Compensation. Click Help in the compensation

window for steps to perform instrument compensation.

View test results
When a test completes, the application switches to the Results panel, which shows a summary of test results.

Each test result occupies a row in the Results table. By default, results are displayed in summary format, with the measurement details
collapsed. You can change the view in the following ways: 

• To view the results grouped by lane, test, or data rate, select the corresponding item from the Preferences menu.
• To expand all tests listed, select View Results Details from the Preferences menu.
• To expand and collapse tests, use the plus and minus buttons to the left of the test rows.
• To collapse all expanded tests, select Preferences > View Results Summary.
• To enable or disable the wordwrap feature, select Preferences > Enable Wordwrap.
• To expand the width of a column, place the cursor over the vertical line that separates the column from the one to the right. When the

cursor changes to a double-ended arrow, hold down the mouse button and drag the column to the desired width.
• To sort the test information by column, click the column head. When sorted in ascending order, a small up arrow is displayed. When

sorted in descending order, a small down arrow is displayed.

• To clear all test results displayed, click Clear ( ).
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Saving and recalling test setup
Test setup files overview
Saved test setup information (such as the selected oscilloscope, general parameters, acquisition parameters, measurement limits,
waveforms (if applicable), and other configuration settings) are saved under the setup name at X:\LVDS.

Use test setups to: 

• Run a new session, to acquire live waveforms, using a saved test configuration.
• Create a new test setup using an existing one.
• View all the information associated with a saved test, including the log file, the history of the test status as it executed, and the results

summary.
• Run a saved test using saved waveforms.

See also
Save a test setup

Open (load) a saved test setup

Save a test setup
You can save a test setup before or after running a test. You can create a test setup from already created test setup, or using default test
setup. When you select the default test setup, the parameters are set to the application’s default value.

Select Options > Save Test Setup to save the opened setup.

Select Options > Save Test Setup As to save the setup with different name.

Open load a saved test setup
To Open (load) a saved test setup, do the following:

1. Select Options > Open Test Setup.
2. Select the setup from the list and click Open. Setup files are located at X:\LVDS\.

See also
About test setups

Create a test setup using an existing one

Create a test setup from default settings

Create a test setup from default settings
To create a test setup using default settings, follow the steps:

1. Select Options > Default Test Setup. For default test setup, the parameters are set to the application’s default value.
2. Click application Setup and set the parameters
3. Click application Reports and set the report options
4. Optional: Click Start to run the test and verify that it runs correctly and captures the specified test information and reports. If it does not,

then edit the parameters and repeat this step until the test runs to your satisfaction
5. Select Options > Save Test Setup. Enter the file name and click Save. The application saves the file to X:\LVDS\<session_name>

Saving and recalling test setup
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Create a test setup using an existing one
To create a test setup using an existing one, follow the steps:

1. Select Options > Open Test Setup
2. Select a setup from the list and then click Open
3. Click application setup and modify the parameters
4. Click application reports and modify the report options
5. Select Options > Save Test Setup As
6. Enter test setup name, and click Save.
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SCPI commands
About SCPI command
You can use Standard Commands for Programmable Instruments (SCPI) to communicate with the TekExpress application.

Socket configuration for SCPI commands
This section describes the steps for TCP/IP socket configuration and TekVISA configuration to execute the SCPI commands.

TCP/IP socket configuration
1. Click Start > Control Panel > System and Security > Windows Firewall > Advanced settings.

2. In Windows Firewall with Advanced Security menu, select Windows Firewall with Advanced Security on Local Computer >
Inbound Rules and click New Rule…
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3. In New Inbound Rule Wizard menu

a. Select Port and click Next.

b. Select TCP as rule apply and enter 5000 for Specific local ports and click Next.
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c. Select Allow the connection and click Next.

d. Select Domain, Private, Public and click Next.
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e. Enter Name, Description (optional), and click Finish.

4. Check whether the Rule name is displayed in Windows Firewall with Advanced Security menu > Inbound Rules.

TekVISA configuration
1. Click Start > All Programs > TekVISA > OpenChoice Instrument Manager.
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2. Click Search Criteria. In Search Criteria menu, click LAN to Turn-on. Select Socket from the drop-down list, enter the IP address of

the TekExpress device in Hostname and type Port as 5000. Click  to configure the IP address with Port.

Enter the Hostname as 127.0.0.1 if the TekVISA and TekExpress application are in the same system, else enter the IP address of the
TekExpress application system.
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3. Click Search to setup the TCPIP connection with the host. Check whether the TCPIP host name is displayed in OpenChoice
Instrument Manager > Instruments.

4. Double-click OpenChoice Talker Listener and enter the Command *IDN? in command entry field and click Query. Check that the
Operation is successful and Talker Listener Readout displays the Command / Data.
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TEKEXP:*IDN?
This command queries the active TekExpress application name running on the oscilloscope. 

Syntax
TEKEXP:*IDN?\n
Inputs
NA

Outputs
Returns active TekExpress application name running on the oscilloscope.

TEKEXP:*OPC?
This command queries the execution status of the last executed command. 

Syntax
TEKEXP:*OPC?\n
Inputs
NA
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Outputs
0 - last command execution is not complete

1 - last command execution is complete

TEKEXP:ACQUIRE_MODE
This command sets the acquire mode as live or pre-recorded.

Syntax
TEKEXP:ACQUIRE_MODE {LIVE | PRE-RECORDED}\n
Inputs
{LIVE | PRE-RECORDED}
Outputs
NA

TEKEXP:ACQUIRE_MODE?
This command queries the acquire mode type.

Syntax
TEKEXP:ACQUIRE_MODE?\n
Inputs
NA
Outputs
{LIVE | PRE-RECORDED}

TEKEXP:EXPORT
This command returns all the bytes of data to the specified file. 

Syntax Outputs
TEKEXP:EXPORT REPORT\n Returns the report file in bytes
TEKEXP:EXPORT WFM,"<FileName>"\n Returns the specified waveform file in bytes
TEKEXP:EXPORT IMAGE,"<FileName>"\n Returns the specified image file in bytes

Inputs
FileName - Specifies the file name

TEKEXP:INFO?
This command queries the information about the file(s).
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Syntax Outputs
TEKEXP:INFO?
REPORT\n

<ReportFileSize>,"<ReportFileName.mht>"

TEKEXP:INFO? WFM\n <WfmFile1Size>,"<WfmFileName1.wfm>";<WfmFile2Size>,"<WfmFileName2.wfm>";...
TEKEXP:INFO? IMAGE\n <Image1FileSize>,"<Image1FileName>";<Image2FileSize>,"<Image2FileName>" ;...

TEKEXP:INSTRUMENT
This command sets the value for the selected instrument type. 

Syntax
TEKEXP:INSTRUMENT "<InstrumentType>",<Value>"\n
Inputs
InstrumentType
Value

Tip: Check Command parameters list section for InstrumentType and Value parameters.

Outputs
NA

TEKEXP:INSTRUMENT?
This command queries the instrument selected for the specified instrument type. 

Syntax
TEKEXP:INSTRUMENT? "<InstrumentType>"\n
Inputs
InstrumentType

Tip: Check Command parameters list section for InstrumentType parameters.

Outputs
Returns the instrument selected for the specified instrument type

TEKEXP:LASTERROR?
This command queries the last error string occurred for the current TCP session. If there are no errors since startup, or since the last call to
TEKEXP:LASTERROR?\n, this command returns an empty string.

Syntax
TEKEXP:LASTERROR?\n
Inputs
NA
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Outputs
<string>

TEKEXP:LIST?
This command queries the list of available device, suite, test, version or instrument. 

Syntax Outputs
TEKEXP:LIST? DEVICE\n Returns the list of available device(s) as comma separated values.
TEKEXP:LIST? SUITE\n Returns the list of available suite(s) as comma separated values.
TEKEXP:LIST? TEST\n Returns the list of available test(s) as comma separated values.
TEKEXP:LIST? VERSION\n Returns the list of available version(s) as comma separated values.
TEKEXP:LIST?
INSTRUMENT,"<InstrumentType>"\n

Returns the list of available instruments' for the given Instrument
type as comma separated values.

Note: This command returns the list of items within double quotes (""). Iterate the receive procedure until the list ends with double
quotes otherwise the next query commands won’t work as expected.

Inputs
InstrumentType

Tip: Check Command parameters list section for InstrumentType parameters.

TEKEXP:POPUP
This command sets the response to the active popup shown in the application.

Syntax
TEKEXP:POPUP “<PopupResponse>”\n
Inputs
PopupResponse
Outputs
NA

TEKEXP:POPUP?
This command queries the active popup information shown in the application.

Syntax
TEKEXP:POPUP?\n
Inputs
NA
Outputs
Returns the active popup information in the application.
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TEKEXP:REPORT
This command generates the report for the current session. 

Syntax
TEKEXP:REPORT GENERATE\n
Inputs
GENERATE
Outputs
NA

TEKEXP:REPORT?
This command queries the queried header field value in the report.

Syntax
TEKEXP:REPORT? “<HeaderField>”\n
Inputs
HeaderField - Specifies to return the measured value for the indicated test.

Tip: Check Report for HeaderField parameters.

Outputs
Returns the queried header field value in the report

TEKEXP:RESULT?
This command queries the result available in report summary/details table.

Syntax Outputs
TEKEXP:RESULT? "<TestName>"\n Return Pass/Fail status of the test.
TEKEXP:RESULT?
"<TestName>","<ColumnName>"\n

Returns all the row values of the specified column for the test.

TEKEXP:RESULT?
"<TestName>","<ColumnName>",<RowNumber
>\n

Returns the column value for the specified row number

Inputs
TestName - Specifies the name of the test for which to obtain the test result value.

ColumnName - Specifies the column name for the measurement

RowNumber - Specifies the row number of the measurement

Tip: Check Results panel for TestName, ColumnName, and RowNumber parameters.
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TEKEXP:SELECT
This command selects the device, suite, version, or test. 

Syntax
TEKEXP:SELECT <string1>,<string2>,<string4>\n
TEKEXP:SELECT TEST,<string3>,<string4>\n
Inputs
<string1> = {DEVICE | SUITE | VERSION}
<string2> = {DeviceName | SuiteName | VersionName}
<string3> = {“<TestName>"| ALL| REQUIRED }
<string4> = {TRUE | FALSE}

Tip: Check Command parameters list section for DeviceName, SuiteName, VersionName, and TestName parameters.

Outputs
NA

TEKEXP:SELECT?
This command queries the name of the selected device, suite, version, or test. 

Syntax
TEKEXP:SELECT? {DEVICE | SUITE | TEST | VERSION}\n
Inputs
{DEVICE | SUITE | TEST | VERSION}
Outputs
Returns the name of the selected device, suite, version, or test.

TEKEXP:SESSION DELETE
Deletes the selected config/run session.

Syntax
TEKEXP:SESSION DELETE, "Session1, Session2" (set)

Command arguments
Argument Name Argument value
<Session Name> <String>

Examples
TEKEXP:SESSION DELETE, "Session1, Session2", deletes the selected config/run session.
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TEKEXP:SESSION SAVE
Overrides the selected config/run session.

Syntax
TEKEXP:SESSION SAVE,"SessionName", "True" (set)

Command arguments
Argument Name Argument Type Argument Value
<Session Name> <String> {True | False} or {1 | 0}

It represents enabled or disabled.

Where,

• True or 1 - enabled
• False or 0 - disabled

Returns
{True | False} or {0 | 1}

Examples
TEKEXP:SESSION SAVE,"SessionName", "True", overrides the selected config/run session.

TEKEXP:SESSION LIST
Returns the list of available config/run session.

Syntax
TEKEXP:SESSION? LIST
Returns
Returns the list of available config/run session.

Examples
TEKEXP:SESSION? LIST, returns the list of available config/run session.

TEKEXP:SESSION CURRENT
Returns the selected config/run session.

Syntax
TEKEXP:SESSION? CURRENT
Returns
Returns the selected config/run session.

Examples
TEKEXP:SESSION? CURRENT, returns the selected config/run session.
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TEKEXP:RESULT:STATISTICS Test Name
This query command returns the statistics for test name which is passed as argument.

Syntax
TEKEXP:RESULT:STATISTICS? “Test Name” (Query)

Returns
Returns statistics for test name which is passed as argument.

Examples
TEKEXP:RESULT:STATISTICS? “Test Name”, returns measurement results separated by ";" if it has multiple sub
measurements. Sample: <Meaurement Detail>, Min : <min value>, Max : <max value>, Avg.Value : <avg. value>, Std.Dev : <std.dev>,
Units : <unit> for test name which is passed as argument.

TEKEXP:RESULT:STATISTICS ALL
This query command returns statistics for all tests which are passed as argument.

Syntax
TEKEXP:RESULT:STATISTICS? “ALL” (Query)

Returns
Returns statistics for all tests which are passed as argument.

Examples
TEKEXP:RESULT:STATISTICS? “ALL”, returns measurement results separated by ";" if it has multiple sub measurements.
Sample: TestName : <Test Name>, Details : <Measurement Detail>, Iter.Count : <Iteration Count>, Min : <min value>, Max : <max value>,
Avg.Value : <avg. value>, Std.Dev : <std.dev>, Units : <unit> for all test name which are passed as argument.

TEKEXP:SESSION RUN
Run the selected config/run session.

Syntax
TEKEXP:SESSION RUN, “Session Name’s separated by comma” (set)

Command arguments
Argument Name Argument value
<Session Name> <String>
Session Name’s separated by comma (to run the multiple run
sessions)

<String>

Examples
TEKEXP:SESSION RUN, “Session Name’s separated by comma”, runs the selected config/run session.
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TEKEXP:SESSION SAVE
Enter the name to save the run/config session.

Syntax
TEKEXP:SESSION SAVE,“Session Name” (set)

Command arguments
Argument Name Argument value
<Session Name> <String>

Examples
TEKEXP:SESSION SAVE,“Session Name” saves the session.

TEKEXP:SESSION DEFAULT
Sets the application configurations to default value.

Syntax
TEKEXP:SESSION DEFAULT (set)

Examples
TEKEXP:SESSION DEFAULT, sets the application configurations to default value.

TEKEXP:SESSION LOAD
Load the selected config/run session.

Syntax
TEKEXP:SESSION LOAD, “Session Name” (set)

Command arguments
Argument Name Argument value
<Session Name> <String>

Examples
TEKEXP:SESSION LOAD, “Session Name”, load the selected config/run session.

TEKEXP:TESTINFO?
This command returns the complete information about the selected test.

The information includes application name, TestID, Device selected, Suite selected, version, Test name, Test description.

Syntax
TEKEXP:TESTINFO? (Query)
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Returns
<String>

Examples
TEKEXP:TESTINFO? This command returns the following details:

<TekExpress> <Test Id="11101" Device="TX-Device" Suite="Group1" Version="Spec 1.0" Name="Algorithm Library Measurement"
Description="This is Algorithm Library measurement test. Refer Section-B of TekExpress SampleApp Development Guide for more details.

TEKEXP:SETUP
This command sets the value of the current setup.

Syntax Outputs

TEKEXP:SETUP DEFAULT\n Restore to default Setup

TEKEXP:SETUP OPEN,"<SessionName>"\n Open the session

TEKEXP:SETUP SAVE\n Saves the already existing modified session

TEKEXP:SETUP SAVE,"<SessionName>"\n Save the session

Inputs
SessionName - The name of the session

TEKEXP:STATE
This command sets the execution state of the application.

Syntax
TEKEXP:STATE {RUN | STOP | PAUSE | RESUME}\n
Inputs
{RUN | STOP | PAUSE | RESUME}
Outputs
NA

TEKEXP:STATE?
This command queries the current setup state. 

Syntax Outputs
TEKEXP:STATE? RUNNING | PAUSED | WAIT | ERROR | READY
TEKEXP:STATE? SETUP SAVED | NOT_SAVED

TEKEXP:VALUE
This command sets the value of parameters of type General, Acquire, Analyze, or DUTID. 
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Syntax
TEKEXP:VALUE GENERAL,"<ParameterName>",“<Value>”\n
TEKEXP:VALUE ACQUIRE,“<TestName>","<AcquireType>", "<ParameterName>",“<Value>”\n
TEKEXP:VALUE ANALYZE,“<TestName>","<ParameterName>".“<Value>”\n
TEKEXP:VALUE DUTID,“<Value>”\n
TEKEXP:VALUE VERBOSE,{TRUE | FALSE}\n
TEKEXP:VALUE WFMFILE,<Test_Name>,<Aquire_Type>,<FilesName1$FileName2>\n
Inputs
ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

Value - Specifes the value to set

FilesName1$FileName2 - Specifies the waveform file name

TRUE - Pop-ups are enabled

FALSE - Pop-ups are disabled

Tip: Check Command parameters list section for ParameterName, AcquireType, and Value parameters.

Outputs
NA

TEKEXP:VALUE?
This command queries the value of the parameter for type General, Acquire, Analyze, or DUTID.

Syntax Outputs
TEKEXP:VALUE? GENERAL,"<ParameterName>"\n Returns the value of Parameter for type GENERAL
TEKEXP:VALUE? ACQUIRE,“<TestName>",
"<AcquireType>","<ParameterName>"\n

Returns the value of Parameter for type ACQUIRE

TEKEXP:VALUE? ANALYZE,
“<TestName>","<ParameterName>"\n

Returns the value of Parameter for type ANALYZE

TEKEXP:VALUE? DUTID\n Returns the DUTID value
TEKEXP:VALUE?
WFMFILE,<Test_Name>,<Aquire_Type>\n

Returns the waveform file name

TEKEXP:VALUE? VERBOSE Returns the verbose mode type

Inputs
ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type
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TRUE - Pop-ups are enabled

FALSE - Pop-ups are disabled

Tip: Check Command parameters list section for ParameterName and AcquireType parameters.

Outputs
Returns the value of Parameter for type GENERAL | ACQUIRE | ANALYZE | DUTID.

Command Parameters List
The section provides the parameters list for the SCPI commands.

TekExpress LVDS command parameters

ParameterName and Value for DUT, Test selection, Acquisition, Configuration and Preferences tabsSpecifies the ParameterName
and Value for DUT, Test selection, Acquisition, Configuration, and Preferences tabs.

Table 16: ParameterName and value for DUT tab

Parameters Description

DUT ID Specifies the value parameters.

For DUTID, valid value is: Comment

Acquiremode Specifies the acquire mode parameter: Acquire live waveforms

Use pre-recorded mode Specifies the pre-recorded parameter: Use pre-recorded waveform files

Device Specifies Device as Transmitter

Standard Specifies Device as Transmitter

Version Specifies version

• 1.0

Skip Scope settings • TRUE
• FALSE

Apply Limits for Measurement • TRUE
• FALSE

Clock Embedded • TRUE
• FALSE

Reference levels • 10 % to 90 %
• 20 % to 80 %

Clock Frequency (MHz) 1 to 500

Table continued…
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Parameters Description

SSC • Enabled
• Disabled

Multi-Lane Configures the lanes and channels

Clock-Lane Probing Specifies the selected source.

• Single-ended
• Differential

Data-Lane Probing Specifies the selected source.

• Single-ended
• Differential
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Table 17: ParameterName and value for test selection tab

Parameters Description

Test Name Specifies the test measurement name.

Valid values are:

• Data_Unit_Interval
• Data_Rise_Time
• Data_Fall_Time
• Data_Width
• Data_TnT
• Data_TJ_BER
• Data_TIE
• Data_RJ_Delta
• Data_Peak_to_Peak
• Data_Intra_Skew
• Data_Inter_Skew
• Data_DJ_Delta
• Data_DDJ
• Data_Clock_Data_Setup_Time
• Data_Clock_Data_Hold_Time
• Data_AC_Timing
• Clock_SS_On_Profile
• Clock_SS_On_Mod_Rate
• Clock_SS_On_Freq_Dev_Min
• Clock_SS_On_Freq_Dev_Max
• Clock_SS_On_Freq_Dev
• Clock_SS_Off_TJ@BER
• Clock_SS_Off_TIE
• Clock_SS_Off_RJ_Delta
• Clock_SS_Off_Period
• Clock_SS_Off_Peak_to_Peak
• Clock_SS_Off_Intra_Skew
• Clock_SS_Off_Frequency
• Clock_SS_Off_Fall_Time
• Clock_SS_Off_DJ_Delta
• Clock_SS_Off_DutyCycle

Table 18: ParameterName and value for acquisition tab

Parameters Description

Acquisition and Save Options Saves the acquisitions and waveforms

• Save All Waveforms Before Analysis
• Save and Analyze Acquisition in Sequence
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Table 19: ParameterName and value for Preference tab

Parameters Description

Number of Runs 1 to 1000

On Test Failure, stop and notify me of the failure TRUE or FALSE

On Test Failure, pause the test and let me investigate TRUE or FALSE

On Test Failure, rerun the test TRUE or FALSE

Auto Close Warnings and information’s during Sequencing Auto close after seconds TRUE or FALSE

Auto Close Error Message during Sequencing TRUE or FALSE

Email Settings Recipient e-mail Address Sender's Address

Table 20: ParameterName and value for analyze

TestName ParameterName Description

Data Intra Skew (PN) Skew From edge • Rise
• Fall

Data Intra Skew (PN) Analysis Mode • SameAs
• OppositeAs

Clock Intra Skew (PN) Analysis Mode • Rise
• Fall

Data Intra Skew (PN) Analysis Mode • SameAs
• OppositeAs

Table 21: ParameterName and value for General

ParameterName Description

Generate new report • TRUE
• FALSE

Append with previous run session • TRUE
• FALSE

Replace current test results • TRUE
• FALSE

Report name

Table continued…
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ParameterName Description

Save Report As Type Web Archive (*.mht;*.mhtml)

PDF (*.pdf;)

CSV (*.csv;)

Auto increment report name if duplicate • TRUE
• FALSE

Create report automatically at the end of the run • TRUE
• FALSE

Include pass/fail info in details table • TRUE
• FALSE

Include plot images • TRUE
• FALSE

Include setup configuration • TRUE
• FALSE

Include complete application configuration • TRUE
• FALSE

Include user comments • TRUE
• FALSE

View report after generating • TRUE
• FALSE

Test name • TRUE
• FALSE

Test result • TRUE
• FALSE

Lane name • TRUE
• FALSE

Record Length (M) 0.1 to 20

Sample Rate (GS/s) 1 to 50

Average Acquisition Mode • TRUE
• FALSE

Mask Type • Auto
• Manual

Table continued…
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ParameterName Description

Nominal Data Rate • On
• Off

Bit Rate (Gb\s) 0 to 1000

BandWidth (MHz) 0 to 1000

Damping Factor 0.5 to 2

Examples
This section provides the examples for the SCPI commands.

Example Description
TEKEXP:*IDN? It returns the active TekExpress application name running on the scope.
TEKEXP:*OPC? It returns the last command execution status, if status is executed it returns "1" else "0".
TEKEXP:SELECT TEST + ParameterName+ "," + value
TEKEXP:ACQUIRE_MODE PRE-
RECORDED

It sets the acquire mode as pre-recorded.

TEKEXP:ACQUIRE_MODE? It returns LIVE when acquire mode is set to live or it returns pre-recorded when acquire
mode is set to pre-recorded.

TEKEXP:EXPORT REPORT It returns the report file in bytes. This can be written into another file for further analysis.
TEKEXP:INFO? REPORT It returns “100,”ReportFileName.mht”", when 100 is the file size in bytes for the filename

ReportFileName.
TEKEXP:INFO? WFM It returns “100,“WfmFileName1.wfm”";“200, “WfmFileName2.wfm”" when 100 is the filesize

in bytes for the filename WfmFileName1.wfm and 200 is the file size in bytes for the
filename WfmFileName2.wfm.

TEKEXP:INSTRUMENT "Real
Time Scope",DPO73304SX
( GPIB8::1::INSTR)

It sets the instrument value as DPO73304SX( GPIB8::1::INSTR ) for the selected
instrument type Real Time Scope.

TEKEXP:INSTRUMENT? "Real
Time Scope"

It returns "DPO73304SX ( GPIB8::1::INSTR ), when DPO73304SX ( GPIB8::1::INSTR )" is
the selected instrument for the instrument type Real Time Scope.

TEKEXP:LASTERROR? It returns ERROR: INSTRUMENT_NOT_FOUND, when no instrument is found.
TEKEXP:LIST? DEVICE It returns "USB4" when TX-Device, RXDevice are the available device.
TEKEXP:LIST?
INSTRUMENT,"Real Time
Scope"

It returns "DPO73304SX ( GPIB8::1::INSTR ), DPO73304DX ( TCPIP::
134.64.248.91::INSTR )" when DPO73304SX ( GPIB8::1::INSTR ), DPO73304DX
( TCPIP::134.64.248.91::INSTR ) are the list of available instruments.

TEKEXP:MODE COMPLIANCE It sets the execution mode as compliance.
TEKEXP:MODE? It returns COMPLIANCE when the execution mode is compliance or It returns USER-

DEFINED when the execution mode is user defined.
TEKEXP:POPUP OK It sets OK as the response to active popup in the application.
TEKEXP:POPUP? It returns "OK", when OK is the active popup information shown in the application.
Table continued…
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Example Description
TEKEXP:REPORT GENERATE It generates report for the current session.
TEKEXP:REPORT? "Scope Model
Number"

Returns "DPO73304SX" when DPO73304SX is the scope model.

TEKEXP:REPORT? DUT ID It returns "DUT001" when DNI_DUT001 is the DUT ID.
TEKEXP:RESULT? "Total
Jitter"

It returns Pass when the test result is Pass.

TEKEXP:RESULT? "Total
Jitter",1

It returns the 2nd Sub measurements Margin L and H values.

TEKEXP:SELECT DEVICE, USB4,
TRUE

It selects USB4.

TEKEXP:SELECT? DEVICE It returns USB4
TEKEXP:SETUP DEFAULT It restores the application to default setup.
TEKEXP:STATE STOP It stops the test execution.
TEKEXP:STATE? It returns as READY when the application is ready to run next measurement.
TEKEXP:STATE? SETUP It returns as NOT_SAVED when the current setup is not saved else it returns SAVED.
TEKEXP:VALUE GENERAL,"Test
Method","DPOJET"

It sets the Test Method parameter value to DPOJET.

TEKEXP:VALUE? GENERAL,"Test
Method"

It returns "DPOJET" when DPOJET is the Test Method value.

TEKEXP:SELECT TEST ,"Total
Jitter",True

Execute this command to select an individual test. This command will select "Total Jitter"
test in the Signal Test tab.
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Algorithms
Data

Unit Interval

• If the Signal Type is Clock. The unit interval measurement calculates the time period, which is the duration of a cycle as defined by
a start and a stop edge. Edges are defined by polarity, threshold, and hysteresis. The application calculates clock period measurement
using the following equation:

Where:

PClockis the clock period.

T is the VRefMid crossing time for the selected polarity.
• If the Signal Type is Data. The unit interval measurement calculates the duration of a Unit Interval. The application calculates this

measurement using the following equation:

Where:

PData is the unit interval.

TData Data is the VRefMid crossing time in either direction.

Kn = Cn–Cn-1 is the estimated number of unit intervals between two successive edges. Cn is the calculated data bit index of Tn Data.
Each measurement result Pn Data is repeated Kn times in the measurement result vector, so that the measurement population is equal
to the number of unit intervals in the qualified waveform, rather than the number of edge pairs.

Rise Time
The Rise Time measurement is the time difference between when the VRefHi reference level is crossed and the VRefLo reference level is
crossed on the rising edge of the waveform. The Rise Time algorithm uses the VRef values as the reference voltage level. Each edge is
defined by the slope, voltage reference level (threshold), and hysteresis.

The application calculates this measurement using the following equation:

Where:

TRise is the Rise Time.

THi+ is the VRefHi crossing on the rising edge.

TLo+ is the VRefLo crossing on the rising edge.
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Fall Time
The Fall Time measurement is the time difference between when the VRefLo reference level is crossed and the VRefHi reference level is
crossed on the falling edge of the waveform. The Fall Time algorithm uses the VRef values as the reference voltage level. Each edge is
defined by the slope, voltage reference level (threshold), and hysteresis.

The application calculates this measurement using the following equation:

Where:

TFall is the Fall Time.

TLo- is the VRefLo crossing on the falling edge.

THi- is the VRefHi crossing on the falling edge.

Data Width
The Eye Width measurement is the measured minimum horizontal eye opening at the zero reference level and uses the clock recovery
settings specified in the configuration panel..

The application calculates this measurement using the following equation:

Where:

UIAVG is the average UI.

TIEpk-pk is the Peak-Peak TIE.

Data Intra Skew (PN)
Skew is the time between the mid reference level crossing on Source positive to the mid reference level crossing on Source negative of
specified lane. The direction of the edge crossing is configurable.

The application calculates this measurement using the following equation:

Where:

TSkew is the timing skew.

TMain is the Main input Mid reference crossing time in the configured direction.

T2nd is the 2nd input Mid2 reference crossing time in the configured direction.

Data Peak to Peak
Cycle Pk-Pk is a voltage measurement which measures the absolute difference between the maximum and minimum amplitude for every
cycle of the waveform. It calculates the peak-to-peak value for all cycles of the waveform. The peak value is measured from Fall slope to
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the next rise if the valid slope is a Fall. The next peak would be from Rise to next fall slope. The peak-to-peak value is calculated on all the
pairs of minimum and maximum values available.

The application calculates the Cycle Pk-Pk using the following equation:

 for consecutive cycles

Where:

VMax(n) is the maximum peak amplitude.

VMin(n) is the minimum peak amplitude.

n is the number of cycles from 1 to the last valid edge.

Jitter

AC Timing

Mask Hits

The Mask hits measurement uses the clock recovery settings specified in the Configuration panel and reports the number of unit intervals
in the acquisition for which mask hits occurred, for a user-specified mask. In the Results Summary view, the Mask hits measurement
reports the total number of unit intervals for which a mask hit occurred in at least one mask zone. In the Results Details view, the number
of hits in each of three segments is reported.

The Mask hits measurement has several unique properties:

• Unlike other measurements, it requires a Mask hits plot. Adding a Mask hits measurement will cause the corresponding plot to be
created automatically. If you delete a Mask hits plot, the application will remove the corresponding Mask hits measurement after
verifying the action with you.

• The Mask hits measurement does not support the Worst-Case Waveforms logging feature.
• The Mask hits measurement does not support Measurement Range Limits.
• The Mask hits measurement does not support Population Limit.

Hold

The Hold Time measurement is the elapsed time between when the clock waveform crosses its own voltage reference level and the
designated edge of a data waveform. The closest data edge to the clock edge that falls within the range limits is used. The Hold time is
calculated individually for every unit interval which occurs within a single clock cycle.

The application calculates this measurement using the following equation:

Where:

THold is the hold time.

TMain is the Main input (clock) Mid reference crossing time in the specified direction.

T2nd is the 2nd input (data) Mid2 reference crossing time in the specified direction.

Note: The order of the input sources for Setup and Hold measurements (Source1 = Clock, Source2 = Data) differs from the order
of input sources on the Setup/Hold Trigger menu in the oscilloscope.
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Clock-Data Setup Time

Mask Hits

The Mask hits measurement uses the clock recovery settings specified in the Configuration panel and reports the number of unit intervals
in the acquisition for which mask hits occurred, for a user-specified mask. In the Results Summary view, the Mask hits measurement
reports the total number of unit intervals for which a mask hit occurred in at least one mask zone. In the Results Details view, the number
of hits in each of three segments is reported.

The Mask hits measurement has several unique properties:

• Unlike other measurements, it requires a Mask hits plot. Adding a Mask hits measurement will cause the corresponding plot to be
created automatically. If you delete a Mask hits plot, the application will remove the corresponding Mask hits measurement after
verifying the action with you.

• The Mask hits measurement does not support the Worst-Case Waveforms logging feature.
• The Mask hits measurement does not support Measurement Range Limits.
• The Mask hits measurement does not support Population Limit.

Setup

Setup Time is the time between the mid reference level crossing of the clock source (Source1) and the closest previous mid reference level
crossing of the data source (Source2). The crossings (edges) may be configured to be rising, falling or either. The setup time is calculated
individually for every unit interval which occurs within a single clock cycle.

The application calculates this measurement using the following equation:

Where:

TSetup is the setup time.

TMain is the Main input (clock) Mid reference crossing time in the specified direction.

T2nd is the 2nd input (data) Mid2 reference crossing time in the specified direction.

Clock-Data Hold Time

Mask Hits

The Mask hits measurement uses the clock recovery settings specified in the configuration panel and reports the number of unit intervals
in the acquisition for which mask hits occurred, for a user-specified mask. In the Results Summary view, the Mask hits measurement
reports the total number of unit intervals for which a mask hit occurred in at least one mask zone. In the Results Details view, the number
of hits in each of three segments is reported.

The Mask hits measurement has several unique properties:

• Unlike other measurements, it requires a Mask hits plot. Adding a Mask hits measurement will cause the corresponding plot to be
created automatically. If you delete a Mask hits plot, the application will remove the corresponding Mask hits measurement after
verifying the action with you.

• The Mask hits measurement does not support the Worst-Case Waveforms logging feature.
• The Mask hits measurement does not support Measurement Range Limits.
• The Mask hits measurement does not support Population Limit.

Hold
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The Hold Time measurement is the elapsed time between when the clock waveform crosses its own voltage reference level and the
designated edge of a data waveform. The closest data edge to the clock edge that falls within the range limits is used. The hold time is
calculated individually for every unit interval which occurs within a single clock cycle.

The application calculates this measurement using the following equation:

Where:

THold is the hold time.

TMain is the Main input (clock) Mid reference crossing time in the specified direction.

T2nd is the 2nd input (data) Mid2 reference crossing time in the specified direction.

Note: The order of the input sources for Setup and Hold measurements (Source1 = Clock, Source2 = Data) differs from the order
of input sources on the Setup/Hold Trigger menu in the oscilloscope.

TIE
TIE (Time Interval Error) is the difference in time between an edge in the source waveform and the corresponding edge in a reference
clock. The reference clock is usually determined by a clock recovery process performed on the source waveform. For Explicit-Clock, clock
recovery process is performed on an explicitly identified source. It uses the clock recovery settings specified in the Configuration panel.

• If the Signal Type is Clock. The application calculates Clock TIE measurement using the following equation:

Where:

TIEClock is the clock time interval error.

T'Clock is the corresponding edge time for the specified reference clock.
• If the Signal Type is Data. The application calculates Data TIE measurement using the following equation:

Where:

TIEData is the data time interval error.

T'Data is the corresponding edge time for the specified reference clock.

The subscript k is used to indicate that there is one measurement per actual edge.

TJ@BER
Total Jitter at a specified Bit Error Rate (BER) extrapolated value predicts a peak-to-peak jitter that will only be exceeded with a probability
equal to the BER. It is generally not equal to the total jitter actually observed in any given acquisition. A single TJ@BER value is
determined for each acquisition, by means of RJ-DJ separation analysis and uses the clock recovery settings specified in the configuration
panel.
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DJ-Delta
Dual Dirac Deterministic Jitter (DJ–δδ) is the peak-to-peak magnitude for all timing errors exhibiting deterministic behavior, calculated
based on a simplifying assumption that the histogram of all deterministic jitter can be modeled as a pair of equal magnitude dirac functions
(impulses). A single DJ–δδ value is determined for each acquisition, by means of RJ-DJ separation analysis. It uses the clock recovery
settings specified in the configuration panel.

RJ-Delta
Dual Dirac Random Jitter (RJ–δδ) is the rms magnitude of all timing errors not exhibiting deterministic behavior, calculated based on a
simplifying assumption that the histogram of all deterministic jitter can modeled as a pair of equal magnitude dirac functions (impulses). A
single RJ–δδ value is determined for each acquisition, by means of RJ-DJ separation analysis. It uses the clock recovery settings specified
in the configuration panel.

DDJ
Data-Dependent Jitter (DDJ) is the peak-to-peak amplitude for that portion of the deterministic jitter directly correlated with the data pattern
in the waveform. A single DDJ value is determined for each acquisition, by means of RJ-DJ separation analysis. It uses the clock recovery
settings specified in the configuration panel.

De-Emphasis Level
The T/nT Ratio measurement reports the amplitude ratio between transition and non-transition bits. The measurement calculates the ratios
of all non-transition eye voltages (2nd and subsequent eye voltages after one edge but before the next) to their nearest preceding transition
eye voltage (1st eye voltage succeeding an edge). In the accompanying diagram, it is the ratio of the Black voltages to the Blue voltages.
The results are given in dB.

The application calculates the T/nT Ratio using the following equations:

 following a rising edge.

 following a falling edge.

Where:

vEYE–HI–TRAN is the High voltage at the interpolated midpoint of the first unit interval following a positive transition.

vEYE–LO–TRAN is the Low voltage at the interpolated midpoint of the first unit interval following a negative transition.

vEYE–HI–NTRAN is the High voltage at the interpolated midpoint of all unit intervals except the first following a positive transition.
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vEYE–LO–NTRAN is the Low voltage at the interpolated midpoint of all unit intervals except the first following a negative transition.

m is the index for all non-transition UIs.

n is the index for the nearest transition UI preceding the UI specified by m. In a time trend plot of the measurement results, there is one
measurement for each non-transition bit in the waveform (that is the black arrows in the diagram).

Clock (SSC off)

Frequency
Frequency measurement calculates the inverse of the data period for each cycle.

• If the Signal Type is Clock. The application calculates clock frequency measurement using the following equation:

Where:

FClock is the clock frequency.

PClock is the clock period measurement.
• If the Signal Type is Data. The application calculates data frequency measurement using the following equation:

Where:

FData is the data frequency.

PDatais the data period measurement.

Period

• If the Signal Type is Clock. The Period measurement calculates the duration of a cycle as defined by a start and a stop edge. Edges
are defined by polarity, threshold, and hysteresis. The application calculates clock period measurement using the following equation:

Where:

PClockis the clock period.

T is the VRefMid crossing time for the selected polarity.
• If the Signal Type is Data. The Period measurement calculates the duration of a Unit Interval. The application calculates this

measurement using the following equation:

Where:

PData is the data period.

TData Data is the VRefMid crossing time in either direction.
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Kn = Cn–Cn-1 is the estimated number of unit intervals between two successive edges. Cn is the calculated data bit index of Tn Data.
Each measurement result Pn Data is repeated Kn times in the measurement result vector, so that the measurement population is equal
to the number of unit intervals in the qualified waveform, rather than the number of edge pairs.

Duty Cycle
The +Duty Cycle and –Duty Cycle measurements calculate the ratio of the positive (or negative) portion of the cycle relative to the period.

The application calculates these measurements using the following equations:

Where:

D+ is the positive duty cycle.

D- is the negative duty cycle.

W+ is the positive pulse width.

W- is the negative pulse width.

PClock is the period.

Clock Intra Skew (PN)
Skew is the time between the mid reference level crossing on Source positive to the mid reference level crossing on Source negative of
specified lane. The direction of the edge crossing is configurable.

The application calculates this measurement using the following equation:

Where:

TSkew is the timing skew.

TMain is the Main input Mid reference crossing time in the configured direction.

T2nd is the 2nd input Mid2 reference crossing time in the configured direction.

Clock Peak to Peak
Cycle Pk-Pk is a voltage measurement which measures the absolute difference between the maximum and minimum amplitude for every
cycle of the waveform. It calculates the peak-to-peak value for all cycles of the waveform. The peak value is measured from Fall slope to
the next rise if the valid slope is a Fall. The next peak would be from Rise to next fall slope. The peak-to-peak value is calculated on all the
pairs of minimum and maximum values available.

The application calculates the Cycle Pk-Pk using the following equation:

 for consecutive cycles

Where:
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VMax(n) is the maximum peak amplitude.

VMin(n) is the minimum peak amplitude.

n is the number of cycles from 1 to the last valid edge.

Clock SSC ON or Data SSC ON

Profile
SSC Profile shows the modulation profile of the Spread Spectrum Clocking (SSC). It is the time trend plot of the SSC profile. All SSC
measurements use the Period measurement with a second order low pass filter. Using the profile you can analyze the SSC modulation
rate by using the horizontal cursors. You can also analyze the peak-to-peak frequency deviation by using the vertical cursors.

The following are the default configurations that are required:

• Constant Clock Recovery (CCR) Mean set as the Clock Recovery method.
• Low pass filter with 1.98 MHz cut off frequency set by default. This is the standard Fiber Channel cut off frequency.
• Available plots are Time Trend, Data Array, Histogram and Spectrum plots.

Mod Rate
SSC Modulating Rate is the modulating frequency of a spread spectrum clock. It is the rate that the clock frequency changes. Clock
recovery is used on the measurement. The method is constant clock mean.

Frequency Deviation
SSC frequency deviation is the spread spectrum clock frequency deviation from the nominal frequency in ppm (parts per million). Clock
recovery is used on the measurement. The method is constant clock mean.

Frequency Deviation Max
SSC frequency deviation MAX is defined as the maximum frequency shift as a function of time. It represents the frequency deviation in
terms of ppm (parts-per-million).

• Find the 50% edges on the SSC profile.
• Calculate the HIGH value between the n and n+1 edge.
• Find the Maximum frequency deviation as HIGH.

The application calculates the measurement using the equation:

Freq Dev Max(ppm)= ((Maximum Freq – Nominal Data Rate)/Nominal Data Rate)* 1e6

The difference between the SSC frequency deviation MAX and SSC frequency deviation MIN measurements are that they compute the
maximum frequency deviation and minimum frequency deviation separately. By doing this the limits can be applied separately. Available
plots are Time Trend, Data Array, Histogram and Spectrum plots.

Frequency Deviation Min
The SSC frequency deviation MIN is defined as the minimum frequency shift as a function of time. It represents the frequency deviation in
terms of ppm (parts per million).

• Find the 50% edges on the SSC profile.
• Calculate the LOW value between the n and n+1 edge.
• Find the Minimum frequency deviation as LOW.

The application calculates the measurement using the equation:
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Freq Dev Min(ppm)= ((Minimum Freq-Nominal Data Rate)/Nominal Data Rate)* 1e6

Available plots are Time Trend, Data Array, Histogram and Spectrum plots.
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