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Welcome
Welcome to the TekExpress® 40GBase-CR4 Compliance and Debug Solution Software application and DPOJET 40GBase-CR4 plug-in.
These applications provide an automated, simple, and efficient way to test interfaces and devices to the requirements of the IEEE
802.3-2012 section 85 and Annex 85A standard.

Key Features

• An intuitive user interface and framework decreases testing time and learning curve
• Provides measurements for electrical characterization of 40GBase-CR4 signal at TP2 and TP0
• Provides both an automation solution (for compliance) and DPOJET option (for debug), saving up to 80% on testing time as compared

to manual testing
• Has flexible parameter control for characterization and margin analysis (in user-defined mode)
• Supports N1N0 (4 <= N <= 12), PRBS7, PRBS11, PRBS15, PRBS20, PRBS23, and PRBS31 patterns in advanced/user-defined mode,

and supports PRBS9, 8180, and 1010 patterns in compliance mode
• Complete programmatic interface enables users to call 40G-CR4 functions using custom automation scripts
• Performs automatic signal validation before performing tests and displays an error message if the signal does not meet acceptable

limits
• Includes DPOJET setup files for 8180, 1010, and PRBS9 patterns to help set oscilloscope and load measurements (in DPOJET).
• Creates detailed reports (.MHT or .PDF) for compliance record keeping, with flexible reporting features such as appending the report,

auto-incrementing the report, and including user comments

Welcome
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Getting help and support
Product documents
Use the product documents for more information on the application functions, understand the theory of operation, how to remotely program
or operate the application, and do other tasks.

Table 1: TekExpress Application documents

To learn about Use this document
How to use the application

How to remotely control the instrument
TekExpress 40G-CR4 Help

PDF version of this document can be downloaded from www.tek.com/downloads

Compiled HTML (CHM) version is integrated with the application. Press F1 key from the
keyboard to start the help.

Tektronix Part Number: 077-xxxx-xx

Conventions
This application help uses the following conventions:

• The term "Application," and "Software" refers to the TekExpress 40G-CR4 application.
• The term “DUT” is an abbreviation for Device Under Test.
• The term “select” is a generic term that applies to the two methods of choosing a screen item (button control, list item): using a mouse

or using the touch screen.
• A Note identifies important information.

Table 2: Icons used in the help

Icon Description
This icon identifies important information

This icon identifies conditions or practices that could result in loss of data.

This icon identifies additional information that will help you use the application more
efficiently.

Getting help and support
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Technical support
Tektronix values your feedback on our products. To help us serve you better, please send us your suggestions, ideas, or comments on
your application or oscilloscope. Contact Tektronix through mail, telephone, or the Web site. See Contacting Tektronix at the front of this
document for contact information.

When you contact Tektronix Technical Support, please include the following information (be as specific as possible): 

General information
• All instrument model numbers
• Hardware options, if any
• Modules used
• Your name, company, mailing address, phone number, FAX number
• Please indicate if you would like to be contacted by Tektronix about your suggestion or comments.

Application specific information
• Software version number
• Description of the problem such that technical support can duplicate the problem
• If possible, save the setup files for all the instruments used and the application
• If possible, save the TekExpress setup files, log.xml, *.TekX (session files and folders), and status messages text file

Getting help and support
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Getting started
Hardware requirements

Minimum System Requirements
The following table shows the minimum system requirements needed for an oscilloscope to run this application.

Table 3: System requirements

Instruments Description
Oscilloscope See Supported instruments
Processor Same as the oscilloscope
Operating System Same as the oscilloscope:

• Windows 7 (64-bit only) SP1 Windows 7 user account settings

Memory Same as the oscilloscope
Hard Disk Same as the oscilloscope
Display Same as the oscilloscope. Super VGA resolution or higher vedio adapter (800 x 600

minimum video resolution for small fonts or 1024 x 768 minimum vedio resolution for
large fonts). The application is best viewed at 96 dpi display settings

Firmware • TekScope 10.3.3 for non-SX series digital oscilloscopes
• TekScope 10.3.0 for SX series digital oscilloscopes

Software • DPOJET, Jitter and Eye Diagram Analysis Tool, version 10.0.0.35 or later (64-bit)
• IronPython 2.7.3
• PyVisa 1.0.0.25
• Microsoft .NET 4.0 Framework
• Microsoft Internet Explorer 7.0 SP1 or later, or other Web browser for viewing

reports
• Microsoft Photo Editor 3.0 or equivalent software for viewing image files
• Adobe Reader software 7.0 or later for viewing portable document format (PDF)

files

Other Devices • Microsoft compatible mouse or compatible pointing device.
• Two USB ports minimum; four USB ports recommended.
• PCI-GPIB or equivalent interface for instrument connectivity.

Required Windows 7 user account setting
Windows 7 instruments need to have the User Account Control Settings set to Never Notify. To set User Account Control Settings:

1. Go to Control Panel > User Accounts > Change User Account Control settings.
2. Set the sliding control to Never Notify as shown in the image, and click OK.

Getting started
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See also
Supported oscilloscopes

Supported instruments
Table 4: Required equipment

Resource Description Quantity
Real-time oscilloscope DPO71604C, DPO72004C, DPO71604DX, DPO72304DX,

DPO72004DX, DPO72504D,DPO72504DX, DPO73304D,
DPO73304DX

DSA71604C, DSA72004C, DSA72504D, DSA73304D

MSO71604C, MSO72004C, MSO71604DX, MSO72004DX,
MSO72304DX, MSO72504DX, MSO73304DX

DPO72004SX, DPO72304SX, DPO72504SX, DPO73304SX,
DPO75002SX, DPO75902SX,DPO77002SX

1

Test fixtures and accessories TF-QSFP-TPA-HCB-P: QSFP+ Host Compliance Board Plug 1

TF-DC-BLOCK-KIT: DC Block Kit 4

For C series oscilloscopes: TCA-292MM adapters 4

For D series oscilloscopes: 12 dB attenuators 4

For D, DX, or SX series oscilloscopes: TCA-292D adapters 4

See also
Minimum system requirements

Getting started
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Software requirements

Downloading and installing the software
Complete the following steps to download and install the latest TekExpress 40G-CR4 application.

1. Go to www.tek.com.
2. Click Downloads. In the Downloads menu, select DOWNLOAD TYPE as Software and enter the application name in the MODEL OR

KEYWORD field and click SEARCH.

3. Select the latest version of software and follow the instructions to download the software. Copy the executable file into the
oscilloscope.

4. Double-click the executable and follow the on-screen instructions.

The software is installed at C:\Program Files\Tektronix\TekExpress\TekExpress 40G-CR4.
5. Select Application > TekExpress 40G-CR4 from the Oscilloscope menu, to open the application.

Activate the license
Activate the license using the Option Installation wizard in the TekScope application:

1. In the TekScope application menu bar, click Utilities > Option Installation. The TekScope Option Installation wizard opens.
2. Push the F1 key on the oscilloscope keyboard to open the Option Installation help topic.
3. Follow the directions in the help topic to activate the license.

View software version and license key details
To view version information of the application, click Options > About TekExpress.

Getting started
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Setting up the test environment
Search instruments connected to the application
Use the TekExpress Instrument Control Settings dialog box to search the instruments (resources) connected to the application. The
application uses TekVISA to discover the connected instruments.

Note: The instruments required for the test setup must be connected and detected by the application, before running the test.

To refresh the list of connected instruments:

1. Select Options > Instrument Control Settings.
2. In the Search Criteria section of the Instrument Control Settings dialog box, select the connection types of the instruments to

search. Instrument search is based on the VISA layer, but different connections determine the resource type, such as LAN, GPIB, and
USB. For example, if you choose LAN, the search will include all the instruments supported by the TekExpress that are communicating
over the LAN.

3. Click Refresh. The TekExpress application searches for the connected instruments.

Search status of the instruments connected to LAN

4. When the search is complete, a dialog box lists the instrument-related details based on the search criteria. For example, for the Search
Criteria as GPIB, the application displays all the GPIB instruments connected to the application.

TekExpress Instrument Control Settings window.

The details of the instruments are displayed in the Retrieved Instruments table. The time and date of instrument refresh is displayed in
the Last Updated field.

Setting up the test environment
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Deskew real-time oscilloscopes
Use the following procedure to deskew direct input SMA channels on a real time oscilloscope.

Note: DPOJET has an automatic deskew option under Analyze > Jitter And Eye Analysis > Deskew. Refer to your DPOJET online
help for information on how to deskew the channels.

1. Run Signal Path Compensation (SPC) on the oscilloscope.
2. Connect a SMA Power Splitter (preferred) or SMA 50 Ω coaxial “T” connector to the Fast Edge output of the oscilloscope.
3. Connect SMA cables from each of the two channels to be deskewed to the power splitter (or SMA coaxial “T” connector). It is best to

use matched cables when making high speed serial measurements. It is important to use the same cables that will be used for
subsequent measurements.

4. Select Default Setup, and then select Autoset on the oscilloscope front panel.
5. Set the oscilloscope for 70% to 90% full screen amplitude on both channels. Center both traces so that they overlap.
6. Make sure that volts/div, position, and offset are identical for the two channels being deskewed.
7. Set the time/div to approximately 100 ps/div or less, with sample rate at 1 ps/pt. These settings are not critical, but should be close.
8. Set the horizontal acquisition mode to average, which provides a more stable display.
9. Select Deskew from the Vertical menu.
10. Verify that the reference channel (typically CH1 or CH2) is set to 0 ps deskew.
11. In the deskew control window, select the channel to deskew (typically CH3 or CH4). Adjust the deskew to overlay the rising edge as

best as possible.

Note: Typical values are in the 10’s of ps or less with cables connected directly from Fast Edge to SMA inputs. If you are using
a switch box (for example, Keithley), deskew the complete path from where the test fixture connects, through the switch, and into
the oscilloscope. Deskew values in these cases may be as much as 30 ps or more.

Note: There can be significant differences in the skew between two TCA-SMA adapters. If you find that a system requires a very
large correction, obtain a pair of TCA-SMA adapters that closely match each other to reduce the amount of correction.

Note: TekExpress retains the user configured Deskew values, and does not override the values during test runs.

Instrument and DUT connection setup
Click the Setup > Test Selection > Schematic button to open a PDF file that shows the compliance test setup diagrams (instrument, DUT,
and cabling) for supported testing configurations.

See also
Minimum system requirements

View connected instruments

Running tests
After selecting and configuring tests, review the prerun checklist and then click Start to run the tests. To monitor the test progress, switch
between viewing the Status panel and the Results panel. You cannot edit any fields on these panels while tests are running.

The application displays a report when the tests are complete. While the tests are running, other applications may display windows in
the background. The TekScope application takes precedence over other applications, but you can switch to other applications by using
the Alt + Tab key combination. To keep the application screen on top (in front of other application screens), select Keep On Top from the
TekExpress Options menu.

Setting up the test environment
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Prerun checklist
Do the following before you click Start to run a test:

Note: If this is the first time you are running a test on the application, make sure that you have done the steps in Required \My
TekExpress folder settings before continuing.

1. Make sure that all the required instruments are properly warmed up (approximately 20 minutes).
2. Perform Signal Path Compensation (SPC)

a. On the oscilloscope main menu, select the Utilities menu.
b. Select Instrument Calibration.
c. Follow the on-screen instructions.

3. Deskew realtime oscilloscope channels
4. Verify that the application detects that the correct instruments are connected (oscilloscope and signal sources):

a. In 40GBase-CR4, click Setup > Test Selection > Configure.
b. Click Global Settings.
c. In the Instruments Detected list, verify that the test setup instruments are shown. If they are not, click on an instrument and click

the arrow button to list and select from all detected instruments. If the required instrument is still not listed, use the TekExpress
Instrument Control Settings dialog box to scan for and detect instruments (see View connected instruments).

See also
Instrument and DUT connection setup

Setting up the test environment
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Starting the application
To start the TekExpress 40G-CR4, select from the oscilloscope menu bar Applications > TekExpress 40G-CR4.

During start, a "My TekExpress" folder is created in the Documents folder of the current user and gets mapped to "X" drive. When the
application is closed properly, the "X" drive gets unmapped. Session files are then stored inside the X:\40G-CR4 folder. If this file is not
found, the application runs an instrument discovery program to detect connected instruments before starting TekExpress 40G-CR4.

To keep the TekExpress 40G-CR4 application on top of any application, select Keep On Top from the options menu. If the application goes
behind the oscilloscope application, select Applications >TekExpress 40G-CR4 to bring the application to the front.

Application user interface overview
TekExpress 40GBase-CR4 uses panels to group related configuration, test, and results settings. Click on a button to open the associated
panel. A panel can have one or more tabs that list further parameters available in that panel. Displayed controls in a panel can change
depending on settings made in that panel or another panel.

Starting the application
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Table 5: Application panels overview

Panel Name Purpose
Setup The Setup panel shows the test setup controls. Click the Setup button to open this

panel.

Use this panel to:

• Select DUTparameters.
• Select the test(s).
• Set acquisitions parameters for selected tests.
• Select test notification preferences.

Status View the progress and analysis status of the selected tests, and view test logs.
Results View a summary of test results and select result viewing preferences.
Plots View plots generated for tests
Reports Browse for reports, save reports as specific file types, specify report naming

conventions, select report content to include (such as summary information, detailed
information, user comments, setup configuration, application configuration), and select
report viewing options.

See also
Application controls

Starting the application
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Application controls
This section describes the application controls with functionality and its details.

Table 6: Application control description

Item Description
Options menu Menu to display global application controls.

Test panel Controls that open tabs for configuring test settings and options.

Start / Stop button Use the Start button to start the test run of the measurements in the selected order. If prior
acquired measurements are not cleared, then new measurements are added to the existing
set. The button toggles to the Stop mode while tests are running. Use the Stop button to
abort the test.

Pause / Continue button Use the Pause button to pause the acquisition. When a test is paused, this button changes
as Continue.

Clear button Use the Clear button to clear all existing measurement results. Adding or deleting a
measurement, or changing a configuration parameter of an existing measurement, also
clears measurements. This is to prevent the accumulation of measurement statistics or
sets of statistics that are not coherent. This button is available only on Results panel.

Note: This button is visible only when there are results data on the panel.

Application window move icon Place the cursor over the top of the application window to move the application window to
the desired location

Minimize icon Minimizes the application.

Close icon Close the application.

Table continued…

Starting the application
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Item Description
Mini view / Normal view Mini view displays the run messages with the time stamp, progress bar, Start / Stop button,

and Pause / Continue button. The application moves to mini view when you click the Start
button.

Options menu functions
To access the Options menu, click  in the upper-right corner of the application. It has the following selections:

Table 7: Options menu settings

Menu Function
Default Test Setup Opens a new test setup with default configurations.
Open Test Setup Opens a previously saved test setup. Displays the list of previously saved test setup file

names. Make the selection and click OK to open the test setup.
Save Test Setup Saves the current test configurations with the specified file name.
Save Test Setup As Saves the current test setup with a different file name or file type.
Open Recent Displays the recently opened test setup file names. Make the selection and click OK to

open the test setup.
Instrument Control Settings Detects, lists, and refreshes the connected instruments found on the specified connections

(LAN, GPIB, USB, Serial, Non-VISA Resources, TekLink, and VXI).

Keep On Top Always keeps the TekExpress 40G-CR4 application on top of all the applications.

Email Settings Configures email options for test run and result notifications.
Deskew Loads oscilloscope channel deskew settings into the application.
Help Displays the TekExpress 40G-CR4 help.
Table continued…

Starting the application
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Menu Function
About TekExpress Displays the application name, version, and hyperlink to end the user license agreement.

Starting the application
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Configure email settings
Use the Email Settings utility to get notified by email when a measurement completes or produces any error condition. Follow the steps to
configure email settings: 

Figure 1: Email settings window

1. Select Options > Email Settings to open the Email Settings dialog box.
2. (Required) For Recipient email Address(es), enter one or more recipient email addresses. To include multiple addresses, separate

the addresses with commas.
3. (Required) For Sender’s Address, enter the email address used by the instrument. This address consists of the instrument name,

followed by an underscore, followed by the instrument serial number, then the @ symbol, and the email server ID. For example:
user@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server address of the Mail server configured at the client location,
and the SMTP Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name, password, and host name in the corresponding fields.

Note: If any of the above required fields are left blank, the settings will not be saved, and email notifications will not be sent.

5. In the Email Attachments section, select from the following options:

• Reports: Select to receive the test report with the notification email.
• Status Log: Select to receive the test status log with the notification email. If you select this option, then also select whether you

want to receive the full log or just the last 20 lines.
6. In the Email Configuration section:

• Enter a maximum file size for the email message. Messages with attachments larger than this limit will not be sent. The default is
5 MB.

• Enter the number in the Number of Attempts to Send field, to limit the number of attempts that the system makes to send a
notification. The default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use this check box to quickly enable or disable email
notifications.

8. To test your email settings, click Test Email.
9. To apply your settings, click Apply.
10. Click Close when finished.

Starting the application
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TekExpress instrument control settings
Use the TekExpress Instrument Control Settings dialog box to search the instruments (resources) connected to the application. You
can use the Search Criteria options to search the connected instruments depending on the connection type. The details of the connected
instrument is displayed in the Retrieved Instruments window.

To access, click Options > Instrument Control Settings. Select GPIB as search criteria for TekExpress application and click Refresh.
The connected instruments displayed in the Retrieved Instruments window and can be selected for use under Global Settings in the test
configuration section. 
Figure 2: TekExpress Instrument Control Settings window

See also
Options menu functions on page 20

Starting the application
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Setup panel: Configure the test setup
The Setup panel contains sequentially ordered tabs that help you guide through the test setup and execution process.

Setup controls overview
The Setup panel contains sequentially ordered tabs that help guide you through a typical test setup and

execution process. Click on a tab to open the associated panel and controls.

The tabs on this panel are:

DUT: Set the DUT parameters

Test Selection: Select test(s)

Acquisitions: Select acquisition parameters

Setup panel: Configure the test setup
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Preferences: Select test fail notification preferences

Setup panel: Configure the test setup
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DUT: Set DUT settings
Use the DUT tab to select parameters for the device under test. These settings are global and apply to all tests of current session. DUT
settings also affect the list of available tests in the Test Selection tab.

Figure 3: DUT tab

Click Setup > DUT to access the DUT parameters:

Table 8: DUT tab configuration

Setting Description
DUT ID Adds an optional text label for the DUT to reports. The default value is DUT001. The

maximum number of characters is 32.

You cannot use the following characters in an ID name: (.,..,...,\,/:?”<>|*)

Comments icon(to the right of the DUT ID field)

Opens a Comments dialog box in which to enter optional text to add to a report.
Maximum size is 256 characters. To enable or disable comments appearing on the test
report, see Select report options.)

Acquire live waveforms Acquire active signals from the DUT for measurement and analysis
Use prerecorded waveform files Run tests on a saved waveform. Open (load) a saved test setup
View • Compliance: Preselects tests and parameters needed to meet compliance

specifications. Disables the compliance filter controls.
• Advanced: Enables selecting of specific tests and setting custom parameters for

tests. Selecting Advanced adds a Configuration tab to Setup panel. Advanced
(User-defined) tests are not considered to meet compliance testing requirements.

Table continued…

Setup panel: Configure the test setup
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Setting Description
Device Profile
Test point Select a test point location from those listed.
De-embedding Filter (TP0 only) Lists de-embed filter file to use for TP0. Use this filter to de-embed the signal path

between TP0 and TP2.

Click the … button to navigate and select filter files. The default location is My
Documents.

Filter files are device specific; contact the device manufacture to obtain filter files.

This control is not available when Test Point is set to TP2.

Number of Lanes to Test Selects the number of lanes to test.
Setup Opens the Test Lane Setup dialog box to select which lanes to test.

Setup panel: Configure the test setup
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Test Selection: Select the tests
Use the Test Selection tab to select the tests. The test measurements available depends on the settings selected in the DUT tab. 

Figure 4: Test selection tab

Table 9: Test Selection tab configuration

Setting Description
Deselect All, Select All buttons Clear or select all tests in the list.
Select Required button Selects all tests required for compliance certification.
Tests Click a test to select or clear. Selecting a test also show details about that test in the

Test Description pane.

All required tests are selected when in Compliance test mode.

Schematic button Shows an equipment and test fixture setup schematic (connection diagram) for the
selected test. Use to set up the equipment and fixtures or to verify the setup before
running the test.

Configure Opens the Test Selection Configuration panel.

Setup panel: Configure the test setup
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Acquisitions: Set waveform acquisition settings
Use Acquisitions tab to view the test acquisition parameters. The contents displayed on this tab depends on the DUT type and the tests
selected.

Figure 5: Acquisition tab

Table 10: Acquisitions tab configuration

Setting Description
Device Lists the signal type and input channel assigned to a lane.

Click in a Source field to assign a channel source to that lane.

Deskew Use to set deskew parameter and read instrument deskew/attenuation values
Test name/Acquisitions list Lists each test name and its associated acquisition lane/group type.
Show Acquire Parameters When selected, lists the acquisition parameters associated with each test. Parameters

are shown in a separate column.
Table continued…
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Setting Description
Acquire Step By Step When selected, the application displays equipment/signal setup and configuration

information, and examples of input signal waveform images. During execution of the
measurement acquisitions. Use the example waveform images to verify that the live
signal is correct. Click OK to continue the acquisition process.

When not selected, the application displays just equipment or signal setup/
configuration information during execution of the measurement acquisitions, as
required by selected tests. No input signal waveform images are shown.

If the live signal waveform does not match the displayed example waveform, or if an
acquisition fails, close the screen and click Stop to halt the test session,

Signal Validation Sets the signal validation actions. Select from the available list items. Signal validation
only applies to live signals; signal validation is not done on saved (pre-recorded)
waveform.

Select Prompt me if signal fails to display a dialog box when the application fails to
acquire a valid signal after a specified number of retries (as set in the Configuration tab
or fields). Select one of the following options in the dialog box:

• Re-Acquire: The application attempts to re-acquire the signal.
• Use Anyway: Use the acquired signal for all applicable tests. The test results may

not be as expected.
• Skip Test: Skip (ignore) any test(s) that depend on this acquisition. Skipped tests

are listed in the status panel and in the report.

Select Skip test if signal fails to skip all tests that depend on an acquired signal that
fails signal validation. The comments section in the report file will show the details as
"User skipped acquisitions for this pattern".

Select Use signal as it is - Don't Check to skip signal validation and use the signal
as-it-is for testing. The test results may not be as expected.

TekExpress 40G-CR4 application saves all acquisition waveforms to files by default. Waveforms are saved in a unique folder for each
session (a session is started when you click the Start button). The folder path is X:\TekExpress 40G-CR4\Untitled
Session\<dutid>\<date>_<time>. Images created for each analysis, XML files with result values, reports, and other
information specific to that particular execution are also saved in this folder.

Saving a session moves the session file contents from the Untitled Session folder to the specified folder name and changes the session
name to the specified name.

Setup panel: Configure the test setup
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Configuration: Set measurement limits for tests
Use Configuration tab to view and configure the Global Settings and the measurement configurations. The measurement specific
configurations available in this tab depends on the selections made in the DUT panel and Test Selection panel.

Table 11: Configuration tab: Common parameters

Settings Description
Limit Editor Displays the upper and lower limits for the applicable measurement using different types of comparisons.

Figure 6: Configuration tab: Global Settings

Table 12: Configuration tab: Global Settings configuration

Setting Description
Mode Sets the test measurement mode.

• Compliance: Most test parameter values cannot be edited. Select this for
compliance mode testing.

• User Defined Mode: Enables editing of measurement parameters for selected
tests (in the Measurements tab or with the Limits Editor).

Test Selection button Displays the main Test Selection panel. This button is only shown when View is set
for Compliance mode on the DUT panel, and you clicked the Configure button in the
Test Selection panel.

Table continued…
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Setting Description
Instruments Detected Displays a list of the connected instruments found during the instrument discovery.

Instrument types include equipment such as oscilloscopes and signal sources (AFG,
AWG). Select Options > Instrument Control Settings to refresh the connected
instrument list.

Record Length Sets the waveform record length to acquire. Valid range is 2M to 20M.
Use Filter File for De-embedding All tests except Group 4: When selected, provides a way to select and apply a

de-embed filter for sampling rate of 100 Gs/sec.

Group 4 tests only: When selected, provides a way to select and apply a de-
embeded filter for sampling rate of 3.3 Ts/sec.

Setup panel: Configure the test setup

TekExpress® 40G-CR4 40GBase-CR4 Compliance and Debug Solution Software Application Help 32



Preferences: Set the test run preferences
Use Preferences tab to set the application action on completion of a measurement. The Preferences tab has the feature to enable or
disable certain options related to the measurement execution.

Figure 7: Preferences tab

Refer the below table for the options available in the Preferences tab:

Table 13: Preferences tab settings

Setting Description
Analysis Options
On test completion, send me an Email Sends an email when a test finishes.

Setup panel: Configure the test setup

TekExpress® 40G-CR4 40GBase-CR4 Compliance and Debug Solution Software Application Help 33



Status panel: View the test execution status
The Status panel contains the Test Status and Log View tabs, which provides status on the test acquisition and analysis (Test Status) and
listing of test tasks performed (Log View tab). The application opens the Test Status tab when you start to execute the test. Select the
Test Status or the Log View tab to view these items while the test execution is in progress.

View test execution status
The tests are grouped and displayed based on the Clock and Data lane. It displays the tests along with the acquisition type, acquire, and
analysis status of the tests. In pre-recorded mode, Acquire Status is not valid.

The Test Status tab presents a collapsible table with information about each test as it is running. Use the symbols to expand ( ) and
collapse ( ) the table rows.

Figure 8: Test execution status view in Status panel

Table 14: Test execution status table headers

Control Description
Test Name Displays the measurement name.
Acquisition Describes the type of data being acquired.
Acquire Status Displays the progress state of the acquisition:

• To be started

Analysis Status Displays the progress state of the analysis:

• To be started
• Completed

Status panel: View the test execution status
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View test execution logs
The Test Status tab displays the detailed execution status of the tests. Also, displays each and every execution step in detail with its
timestamp information. The log details can be used to troubleshoot and resolve any issue/bug which is blocking the test execution process.

Figure 9: Log view in Status panel

Table 15: Status panel settings

Control Description
Message History Lists all the executed test operations and timestamp information.
Auto Scroll Enables automatic scrolling of the log view as information is added to the log during the test execution.

Clear Log Clears all the messages from the log view.
Save Saves the log file into a text file format. Use the standard Save File window to navigate to and specify

the folder and file name to save the log text.

Status panel: View the test execution status
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Results panel: View summary of test results
When a test execution is complete, the application automatically opens the Results panel to display a summary of test results.

In the Results table, each test result occupies a row. By default, results are displayed in summary format with the measurement details
collapsed and with the Pass/Fail column visible.

Figure 10: Results panel with measurement results

Click  icon on each measurement in the row to expand and to display the minimum and maximum parameter values of the
measurement.

Filter the test results
Each column in the result table can be customized and displayed by enabling or disabling any column as per your requirement. You can
change the view in the following ways:

• To remove or restore the Pass/Fail column, select Preferences > Show Pass/Fail.
• To collapse all expanded tests, select Preferences > View Results Summary.
• To expand all the listed tests, select View Results Details from the Preferences menu in the upper right corner.
• To enable or disable the wordwrap feature, select Preferences > Enable Wordwrap.
• To view the results grouped by lane or test, select the corresponding item from the Preferences menu.
• To expand the width of a column, place the cursor over the vertical line that separates the column from the column to the right. When

the cursor changes to a double-ended arrow, hold down the mouse button and drag the column to the desired width.
• To clear all test results displayed, click Clear.

Results panel: View summary of test results
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Plots Panel

Plots panel overview
Use the Plots panel to view waveform plots associated with test measurements, and use cursors to take measurements on the plotted
waveforms.

The toolbar at the to edge of the plot contains the plot UI controls. Position the cursor over a control to see a pop-up description of that
control. Use the Lane and Select Test controls to select and view a plot for a specific measurement.

See also
Plot cursors

Plot cursors
The plot panel provides a pair of cursors for each plot axis (X axis and Yaxis). The readout in the upper right corner of the plot shows the
difference (delta) between the cursors.

Each pair of cursors is positioned together by default. To move a cursor:

Plots Panel
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1. Position the mouse pointer over the plot cursor icon until the pointer changes to a vertical or horizontal move icon
2. Select and hold the left mouse button, then move the cursor to a new position.
3. Release the mouse button.

Plots Panel
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Reports panel: Configure report generation settings
Click Reports panel to configure the report generation settings and select the test result information to include in the report. You can use
the Reports panel to configure report generation settings, select test content to include in reports, generate the report, view the report,
browse for reports, name and save reports, and select report viewing options.

Select report generation options
This section describes the report generation settings you can configure in the Reports panel. Select report settings before running a test or
when creating and saving test setups. Report settings configured are included in saved test setups.

Figure 11: Reports panel

Report Update Mode Settings
Table 16: Report Update Mode Settings

Control Description
Generate new report Each time when you click Run and when the test execution

is complete, it will create a new report. The report can be in
either .mht, .pdf, or .csv file formats.

Append with previous run session Appends the latest test results to the end of the current test results
report. Each time when you click this option and run the tests, it will
run the previously failed tests and replace the failed test result with
the new pass test result in the same report.

Replace current test results Replaces the previous test results with the latest test results.
Results from newly added tests are appended to the end of the
report.

Table continued…

Reports panel: Configure report generation settings
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Control Description
In previous run, current session Select to replace current test results in the report with the test

result(s) of previous run in the current session.

In any run, any session Select to replace current test results in the report with the test
result(s) in the selected run session’s report. Click and select test
result of any other run session.

Report Creation Settings
Report name Displays the name and path of the TekExpress 40G-CR4

report. The default location is at \My Documents>\My
TekExpress\40G-CR4\Reports. The report file in this
folder gets overwritten each time you run a test unless you specify a
unique name or select to auto increment the report name.

To change the report name or location, do one of the following:

• In the Report Path field, type the current folder path and name.
• Double-click in the Report Path field and then make selections

from the popup keyboard and click Enter.

Be sure to include the entire folder path, the file name,
and the file extension. For example: C:\Documents and
Settings\your user name\My Documents\My
TekExpress\40G-CR4\DUT001.mht.

Note: You cannot set the file location using the Browse
button.

Open an existing report

Click Browse, locate and select the report file and then click View
at the bottom of the panel.

Save as type Saves a report in the specified file type, selected from the drop-
down list. The report is saved in .csv, .pdf, or .mht.

Note:

If you select a file type different from the default, be sure to
change the report file name extension in the Report Name
field to match.

Auto increment report name if duplicate Sets the application to automatically increment the name of the
report file if the application finds a file with the same name as the
one being generated. For example: DUT001, DUT002, DUT003.
This option is enabled by default.

Contents To Save Settings
Include pass/fail info in details table Select to include pass/fail information in the details table of the

report.
Include detailed results Select to include detailed results in the report.
Include plot images Select to include the plot images in the report.
Table continued…
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Control Description
Include setup configuration Sets the application to include hardware and software information in

the summary box at the top of the report. Information includes: the
oscilloscope model and serial number, the oscilloscope firmware
version, and software versions for applications used in the
measurements.

Include user comments Select to include any comments about the test that you or another
user have added in the DUT tab of the Setup panel. Comments
appear in the Comments section, below the summary box at the
beginning of each report.

Other settings in report panel
View report after generating Automatically opens the report in a Web browser when the test

execution is complete. This option is selected by default.

Generate Report Generates a new report based on the current analysis results.
Group Test Results By
Test Name Select to group the test results based on the test name in the report.
Add logo to report Browse the files to add logo

Reports panel: Configure report generation settings
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View a generated report
Sample report and its contents

A report shows detailed results and plots, as set in the Reports panel.

Figure 12: Report

Setup Information The summary box at the beginning of the report lists setup configuration information. This information
includes the oscilloscope model and serial number, optical module model and serial number, and software
version numbers of all associated applications.

Test Name Summary Table The test summary table lists all the tests which are executed with its result status.
Measurement The measurement table displays the measurement related details with its parameter value.
User comments If you had selected to include comments in the test report, any comments you added in the DUT tab are

shown at the top of the report.

Reports panel: Configure report generation settings

TekExpress® 40G-CR4 40GBase-CR4 Compliance and Debug Solution Software Application Help 42



Saving and recalling test setup
Overview
You can save the test setup and recall it later for further analysis. Saved setup includes the selected oscilloscope, general parameters,
acquisition parameters, measurement limits, waveforms (if applicable), and other configuration settings. The setup files are saved under
the setup name at X:\TekExpress 40G-CR4

Figure 13: Example of Test Setup File

Use test setups to:

• Recall a saved configuration.
• Run a new session or acquire live waveforms.
• Create a new test setup using an existing one.
• View all the information associated with a saved test, including the log file, the history of the test status as it executed, and the results

summary.
• Run a saved test using saved waveforms.

Note: Images that are shown in this Saving and recalling test setup chapter are for illustration purpose only and it may vary
depending on the TekExpress application.

Save the configured test setup
You can save a test setup before or after running a test. You can create a test setup from already created test setup or using a default
test setup. When you save a setup, all the parameters, measurement limits, waveform files (if applicable), test selections, and other
configuration settings are saved under the setup name. When you select the default test setup, the parameters are set to the application’s
default value.

• Select Options > Save Test Setup to save the opened setup.

Saving and recalling test setup
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• Select Options > Save Test Setup As to save the setup with different name.

Load a saved test setup
To open (load) a saved test setup, do the following:

• Select Options > Open Test Setup.

Saving and recalling test setup
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• From the File Open menu, select the setup file name from the list and click Open.

Note: Parameters that are set for the respective test setup will enable after opening the file.

Perform a test using pre-run session files
Complete the following steps to load a test setup from a pre-run session:

1. Select Options > Open Test Setup.

Saving and recalling test setup
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2. From the File Open menu, select a setup from the list and then click Open.

Note: Parameters that are set for the respective test setup will enable after opening the file.

3. Switch the mode to Use Pre-recorded waveform files in the DUT panel.

Saving and recalling test setup
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4. Select the required waveforms from the selected setup in the Acquisitions tab and click Start.

5. The selected waveform file can be removed/replaced by clicking on the ( ) icon.

Saving and recalling test setup
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6. After successful completion of the test, the waveform report files are stored at X:\<Application Name>\Reports.

7. The overall test result status after completion of the test execution is displayed in the Results Panel.

Saving and recalling test setup

TekExpress® 40G-CR4 40GBase-CR4 Compliance and Debug Solution Software Application Help 48



Save the test setup with a different name
To save a test setup with a different name, follow the steps:

1. Select Options > Save Test Setup As.

2. Enter the new test setup name and click Save.

Saving and recalling test setup
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SCPI Commands
About SCPI command
You can use the Standard Commands for Programmable Instruments (SCPI) to communicate remotely with the TekExpress application.
Complete the TCPIP socket configuration and the TekVISA configuration in the oscilloscope or in the device where you are executing the
script.

Note: If you are using an external PC to execute the remote interface commands, then install TekVISA in the PC to make the
configurations.

Socket configuration for SCPI commands
This section describes the steps to configure the TCPIP socket configuration in your script execution device and the steps to configure the
TekVISA configuration in the oscilloscope to execute the SCPI commands.

TCPIP socket configuration
1. Click Start > Control Panel > System and Security > Windows Firewall > Advanced settings.

2. In Windows Firewall with Advanced Security menu, select Windows Firewall with Advanced Security on Local Computer >
Inbound Rules and click New Rule…

SCPI Commands
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3. In New Inbound Rule Wizard menu

a. Select Port and click Next.

b. Select TCP as rule apply, enter 5000 for Specific local ports and click Next.

SCPI Commands
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c. Select Allow the connection and click Next.

d. Select Domain, Private, Public checkbox and click Next.

SCPI Commands
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e. Enter Name, Description (optional), and click Finish.

4. Check whether the Rule name is displayed in Windows Firewall with Advanced Security menu > Inbound Rules.

SCPI Commands
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TekVISA configuration
1. Click Start > All Programs > TekVISA > OpenChoice Instrument Manager.

2. Click Search Criteria. In Search Criteria menu, click LAN to Turn-on. Select Socket from the drop-down list, enter the IP address of

the TekExpress device in Hostname and type Port as 5000. Click  to configure the IP address with Port.

Enter the Hostname as 127.0.0.1 if the TekVISA and TekExpress application are in the same system, else enter the IP address of the
oscilloscope where the TekExpress application is running.

SCPI Commands
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3. Click Search to setup the TCPIP connection with the host. Check whether the TCPIP host name is displayed in OpenChoice
Instrument Manager > Instruments.

4. Double-click OpenChoice Talker Listener and enter the Command *IDN? in command entry field and click Query. Check that the
Operation is successful and Talker Listener Readout displays the Command / Data.

SCPI Commands
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Set or query the device name of application
This command sets or queries the device name of the application.

Syntax
TEKEXP:SELECT DEVICE,"<DeviceName>" (Set)

TEKEXP:SELECT? DEVICE (Query)

Command arguments
Argument Name Argument Type

<DeviceName> <String>

Returns
<String>

Examples
TEKEXP:SELECT DEVICE,"<DeviceName>" command sets the device name of the application.

TEKEXP:SELECT? DEVICE command returns the selected device name of the application.

Set or query the suite name of the application
This command sets or queries the suite name of the application.

Syntax
TEKEXP:SELECT SUITE,"<SuiteName>" (Set)

TEKEXP:SELECT? SUITE (Query)

SCPI Commands
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Command arguments
Argument Name Argument Type and value Description

<SuiteName>

• TP0
• TP2

<String> It is the name of the suite on the DUT panel
of the application

Returns
<String>

Examples
TEKEXP:SELECT SUITE,"<SuiteName>" command sets the suite name of the application.

TEKEXP:SELECT? SUITE command returns the selected suite of the application.

Set or query the test name of the application
This command selects or deselects the specified test name of the application.

Syntax
TEKEXP:SELECT TEST,"<TestName>",<Value> (Set)

TEKEXP:SELECT TEST,"<ALL>" (Set)

TEKEXP:SELECT? TEST (Query)

Command arguments
Test Name Value
TP0

• Differential peak-peak output voltage Tx disabled
• 72.7.1.9 Duty Cycle Distortion
• 72.7.1.7 Transition Time(20% - 80%)
• 85.8.3.9 Signaling Rate
• 72.7.1.9 Random Jitter(p-p)
• 72.7.1.9 Total Jitter
• 72.7.1.9 Deterministic Jitter
• 72.7.1.4 Common mode voltage limits
• 72.7.1.4 Common mode AC output voltage
• 72.7.1.5 Differential Output Return Loss
• 72.7.1.6 Common Mode Output Return Loss

{ True | False } or {1 | 0}

It represents selected or unselected.

Where,

True or 1 - Selected

Flase or 0 - Unselected

Table continued…
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Test Name Value

TP2

• Differential peak-peak output voltage Tx disabled
• 72.7.1.4 Amplitude peak to peak
• 72.7.1.9 Duty Cycle Distortion
• 85.8.3.9 Signaling Rate
• Random Jitter(p-p)
• 83A.5.1 Total Jitter excluding DDJ(UTJ)
• J2 - Informative
• J9 - Informative
• 85.8.3.3.2 Absolute coefficient step size
• 85.8.3.3.1 Coefficient Initialization Ratio1
• 85.8.3.3.1 Coefficient Initialization Ratio2
• 85.8.3.3 Linear Fit Pulse
• 85.8.3.3 RMS Normalized Error
• 85.8.3.3 Transmitter DC Amplitude
• 85.8.3.3.3 Minimum Pre-cursor full scale range
• 85.8.3.3.3 Minimum Post-cursor full scale range
• Transition Time(20% - 80%) - Informative
• 72.7.1.4 Common mode voltage limits
• 72.7.1.4 Common mode AC output voltage
• 85.8.3.1 Differential Output Return Loss

{ True | False } or {1 | 0}

It represents selected or unselected.

Where,

True or 1 - Selected

Flase or 0 - Unselected

Returns
{True | False} or {1 | 0}

Examples
TEKEXP:SELECT TEST,"<TestName>",1 command selects the specified test in the Test Panel.

TEKEXP:SELECT TEST,"<ALL>" command select all the tests in the Test Panel.

TEKEXP:SELECT? TEST command returns the list of selected tests.

Set or query the version name of the application
This command sets or queries the version name of the application.

Syntax
TEKEXP:SELECT VERSION,”<VersionName>” (Set)

TEKEXP:SELECT? VERSION (Query)

Command arguments
Version Name Argument Type Valid Values
<VersionName> <String> It is the name of the version on the DUT

panel of the application

SCPI Commands
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Returns
<String>

Examples
TEKEXP:SELECT VERSION,”<VersionName>” command sets the version name of application.

TEKEXP:SELECT? VERSION command returns the version name of application.

Set or query the general parameter values
This command sets or queries the general parameter values of the application.

Syntax
TEKEXP:VALUE GENERAL,"<ParameterName>","<Value>" (Set)

TEKEXP:VALUE? GENERAL,"<ParameterName>" (Query)

Command arguments
Table 17: Command arguments for general settings

Parameter Name Value
Device Type 40GBase-CR4
Suite Type • TP0

• TP2

Record Length Data Type: Double Range(2-20)
De-embedding filter Data Type: String File Path
Apply Filter for Group4 • Yes

• No

Filter File Path for Group4 (.flt file) File Path
Apply Filter • Yes

• No

Filter File Path (.flt file) File Path

Returns
<NRf> or <String>

Examples
TEKEXP:VALUE GENERAL,"<ParameterName>","<Value>" command set the value for the specified general
parameter.

TEKEXP:VALUE? GENERAL,"<ParameterName>" command returns the value for the specified general parameter.

SCPI Commands
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Set or query the acquire parameter values
This command sets or queries the acquire parameter values of the application.

Syntax
TEKEXP:VALUE
ACQUIRE,”<TestName>",”<AcquireType>”,”<ParameterName>","<ParameterValue>" (Set)

TEKEXP:VALUE? ACQUIRE,”<TestName>",”<AcquireType>”,”<ParameterName>" (Query)

Command arguments
Test Name Acquire Type Parameter Name Parameter Value
TP0
Diffrential peak -
peak output voltage
Tx disabled

Group 1 Data Pattern

72.7.1.9 Duty Cycle
Distortion

Group 2 1010 (Default Value)

• 1010
• PRBS7
• PRBS9
• PRBS11
• PRBS15
• PRBS20
• PRBS23
• PRBS31

72.7.1.7 Transition
Time(20% - 80%)

Group 3 8180 (Default Value)
8180, N1N0 (4 &l t; = N & lt; = 12)

85.8.3.9 Signaling
Rate

Group 4 PRBS9 (Default Value)

• 1010
• PRBS7
• PRBS9
• PRBS11
• PRBS15
• PRBS20
• PRBS23
• PRBS31

72.7.1.9 Random
Jitter(p - p)

• PRBS7
• PRBS9
• PRBS11
• PRBS15
• PRBS20

Table continued…
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Test Name Acquire Type Parameter Name Parameter Value

• PRBS23
• PRBS31

72.7.1.9 Total Jitter • PRBS7
• PRBS9
• PRBS11
• PRBS15
• PRBS20
• PRBS23
• PRBS31

72.7.1.9
Deterministic Jitter

• PRBS7
• PRBS9
• PRBS11
• PRBS15
• PRBS20
• PRBS23
• PRBS31

72.7.1.4 Common
mode voltage limits

Group 5

72.7.1.4 Common
mode AC output
voltage
72.7.1.5 Differential
Output Return Loss

Group 6 Differential Return Loss File path

72.7.1.6 Common
Mode Output Return
Loss
TP2
Differential peak-
peak output voltage
Tx disabled

Group 1

72.7.1.4 Amplitude
peak to peak

Group 2 Data Pattern • 1010
• PRBS7
• PRBS9
• PRBS11
• PRBS15
• PRBS20
• PRBS23
• PRBS31

72.7.1.9 Duty Cycle
Distortion

Table continued…
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Test Name Acquire Type Parameter Name Parameter Value
85.8.3.9 Signaling
Rate

Group 3 Data Pattern • 1010
• PRBS7
• PRBS9
• PRBS11
• PRBS15
• PRBS20
• PRBS23
• PRBS31

Random Jitter(p-p) • PRBS7
• PRBS9
• PRBS11
• PRBS15

83A.5.1 Total Jitter
excluding DDJ(UTJ)

• 1010
• PRBS7
• PRBS9
• PRBS11
• PRBS15
• PRBS20
• PRBS23
• PRBS31

J2 - Informative • 1010
• PRBS7
• PRBS9
• PRBS11
• PRBS15
• PRBS20
• PRBS23
• PRBS31

J9 - Informative • 1010
• PRBS7
• PRBS9
• PRBS11
• PRBS15
• PRBS20
• PRBS23
• PRBS31

Table continued…
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Test Name Acquire Type Parameter Name Parameter Value
85.8.3.3.2 Absolute
coefficient step size

Group
4_ABS_COEFF_STEP_S
IZE

85.8.3.3.1
Coefficient
Initialization Ratio1

Group 4_INIT_RATIO

85.8.3.3.1
Coefficient
Initialization Ratio2
85.8.3.3 Linear Fit
Pulse

Group 4

85.8.3.3 RMS
Normalized Error
85.8.3.3 Transmitter
DC Amplitude
85.8.3.3.3 Minimum
Pre-cursor full scale
range

Group 4_PRE

85.8.3.3.3 Minimum
Post-cursor full scale
range

Group 4_POST

Transition Time(20%
- 80%) - Informative

Group 5 Data Pattern 8180, N1N0 (4 & lt; = N & lt; = 12)

72.7.1.4 Common
mode voltage limits

Group 6

72.7.1.4 Common
mode AC output
voltage
85.8.3.1 Differential
Output Return Loss

Group 7 Differential Return Loss File path

Returns
<Nrf>

Examples
TEKEXP:VALUE
ACQUIRE,”<TestName>",”<AcquireType>”,"<ParameterName>","<ParameterValue>" command sets
the value for the specified test and its acquire parameter.

TEKEXP:VALUE? ACQUIRE,”<TestName>",”<AcquireType>”,"<ParameterName>" command returns the
value for the specified test and its acquire parameter.

Set or query the analyze parameter values
This command sets or queries the analyze parameter values of the application.

SCPI Commands

TekExpress® 40G-CR4 40GBase-CR4 Compliance and Debug Solution Software Application Help 63



Syntax
TEKEXP:VALUE ANALYZE,”<TestName>","<ParameterName>","<ParameterValue>" (Set)

TEKEXP:VALUE? ANALYZE,”<TestName>","<ParameterName>" (Query)

Command arguments
TestName ParameterName ParameterValue
72.7.1.9 Total Jitter BER Range (2 to 14)
Random Jitter (P - P)
83A.5.1 Total Jitter excluding DDJ (UTJ)

Returns
<Nrf>

Examples
TEKEXP:VALUE ANALYZE,”<TestName>","<ParameterName>","<ParameterValue>" command set the
value for the specified test and its analyze parameter.

TEKEXP:VALUE? ANALYZE,”<TestName>","<ParameterName>" command returns the value for the specified test
and its analyze parameter.

Query the available devices in the DUT panel of the application
Syntax
TEKEXP:LIST? DEVICE (Query)

Command arguments
Device Device Type and value Description
<Device> <String> It is the name of the device on the DUT

panel of the application.

Returns
<String>

Examples
TEKEXP:LIST? DEVICE command returns the list of available devices.

Query the available suites for the selected device
This command queries the list of available suites for the selected device as comma separated values.

Syntax
TEKEXP:LIST? SUITE (Query)

Returns
<String>
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Examples
TEKEXP:LIST? SUITE command returns the list of available suites for the selected device.

Query the list of available tests of the application
This command queries the list of available tests of the application for the selected device as comma separated values.

Syntax
TEKEXP:LIST? TEST (Query)

Command arguments
Test Name String
TP0 • Differential peak-peak output voltage Tx disabled

• 72.7.1.9 Duty Cycle Distortion
• 72.7.1.7 Transition Time(20% - 80%)
• 85.8.3.9 Signaling Rate
• 72.7.1.9 Random Jitter(p-p)
• 72.7.1.9 Total Jitter
• 72.7.1.9 Deterministic Jitter
• 72.7.1.4 Common mode voltage limits
• 72.7.1.4 Common mode AC output voltage
• 72.7.1.5 Differential Output Return Loss
• 72.7.1.6 Common Mode Output Return Loss

TP2 • Differential peak-peak output voltage Tx disabled
• 72.7.1.4 Amplitude peak to peak
• 72.7.1.9 Duty Cycle Distortion
• 85.8.3.9 Signaling Rate
• Random Jitter(p-p)
• 83A.5.1 Total Jitter excluding DDJ(UTJ)
• J2 - Informative
• J9 - Informative
• 85.8.3.3.2 Absolute coefficient step size
• 85.8.3.3.1 Coefficient Initialization Ratio1
• 85.8.3.3.1 Coefficient Initialization Ratio2
• 85.8.3.3 Linear Fit Pulse
• 85.8.3.3 RMS Normalized Error
• 85.8.3.3 Transmitter DC Amplitude
• 85.8.3.3.3 Minimum Pre-cursor full scale range
• 85.8.3.3.3 Minimum Post-cursor full scale range
• Transition Time(20% - 80%) - Informative
• 72.7.1.4 Common mode voltage limits
• 72.7.1.4 Common mode AC output voltage
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Test Name String

• 85.8.3.1 Differential Output Return Loss

Returns
<String>

Examples
TEKEXP:LIST? TEST command returns the list of available tests for the selected device.

Query the available version names of the application
This command queries the list of available version names of the application for the selected device as comma separated values.

Syntax
TEKEXP:LIST? VERSION (Query)

Returns
<String>

Examples
TEKEXP:LIST? VERSION command returns the list of version names for the selected device.

Query the list of available instruments based on the specified instrument type
This command queries the list of available instruments based on the specified instrument type.

Syntax
TEKEXP:LIST? INSTRUMENT,"<InstrumentType>" (Query)

Command argument
Argument Name Argument value
<InstrumentType> <String>

Returns
<String>

Examples
TEKEXP:LIST? INSTRUMENT,"Real Time Scope" command returns the list of available instruments based on the real
time scope type.

Set or query the IP address of the instrument based on the specified instrument
type
This command sets or queries the IP address of the instrument based on the specified instrument type.
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Syntax
TEKEXP:INSTRUMENT? "<InstrumentType>" (Query)

TEKEXP:INSTRUMENT, "<InstrumentType>","<Value>" (Set)

Command argument
Argument Name Argument Type
<InstrumentType> <String>
<Value> <String>

TCPIP::XXX.XX.XXX.XXX::INSTR

Returns
<String>

Examples
TEKEXP:INSTRUMENT? "<InstrumentType>" command returns the IP address of the oscilloscope.

TEKEXP:INSTRUMENT, "<InstrumentType>","<value>" command sets the oscilloscope to the specified IP address.

Query the information of the generated report file
This command queries the information of the generated report file in the format "<FileSize>","<FileName>".

Pre‐requisite
A session should be run earlier and the report should be generated to get the information of the report.

Syntax
TEKEXP:INFO? REPORT (Query)

Returns
<FileSize>:: <String>

<FileName>:: <String>

Examples
TEKEXP:INFO? REPORT command returns the information of the generated report in the format ("1215”,"DUT001.mht”).

Query the information of the generated waveform files
This command queries the information of the generated waveform files in the format.

<File1Size,"File1Name”>.

If there are more than one waveform, the waveform file names are displayed with the comma separated values in the format

<File1Size,"File1Name">,<File2Size,"File2Name">.

Syntax
TEKEXP:INFO? WFM (Query)
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Returns
<FileSize>:: <String>

<FileName>:: <String>

Examples
TEKEXP:INFO? WFM command returns the information of the generated waveform in the format (20000858,"X:\40G-CR4\Untitled
Session\DUT001\20200916_041609\Iter1_Short Record‐length for SCOPE Period_NoSSC_DIFF.wfm”).

Query the information of the generated image files
This command queries the information of the generated image files in the format.

<File1Size,"File1Name”>.

If there are more than one image, the image file names are displayed with the comma separated values in the format

<File1Size,"File1Name">,<File2Size,"File2Name">.

Syntax
TEKEXP:INFO? IMAGE (Query)

Returns
<FileSize>:: <String>

<FileName>:: <String>

Examples
TEKEXP:INFO? IMAGE command returns the information of the generated image in the format (109058, "X:\40G-
CR4\Untitled Session\DUT001\20200916_041609\Iter1_Short Record‐length for SCOPE Period_NoSSC_DIFF.png";22794,"X:\40G-
CR4\UntitledSession\DUT001\20 200916_041609\ScopePeriodPlot_Iteration1WithCursor.png").

Query the active TekExpress application name
This command queries the active TekExpress application name running on the oscilloscope.

Syntax
TEKEXP:*IDN? (Query)

Returns
<String>

Examples
TEKEXP:*IDN? command returns the active TekExpress application name running on the oscilloscope.

Set or query the DUTID of application
This command sets or queries the DUTID of the application.

Syntax
TEKEXP:VALUE DUTID,"<Value>" (Set)

TEKEXP:VALUE? DUTID (Query)
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Command arguments
Argument Name Argument Type
<Value> <String>

Returns
<String>

Examples
TEKEXP:VALUE DUTID,"DUT001" command sets the DUTID of the application to DUT001.

TEKEXP:VALUE? DUTID command returns the DUTID of the application.

Sets or query the acquire mode status
This command sets or queries the acquire mode status.

Syntax
TEKEXP:ACQUIRE_MODE <Mode> (Set)

TEKEXP:ACQUIRE_MODE? (Query)

Command arguments
Argument Name Argument value
<Mode> • LIVE

• PRE‐RECORDED

Returns
LIVE | PRE‐RECORDED

Examples
TEKEXP:ACQUIRE_MODE LIVE command sets the acquire mode to the Live mode.

TEKEXP:ACQUIRE_MODE? command returns the current acquire mode.

Set or query the execution mode status
This command sets or queries the execution mode status.

Syntax
TEKEXP:MODE <Mode> (Set)

TEKEXP:MODE? (Query)

Command arguments
Argument Name Argument value
<Mode> • COMPLIANCE

• USER‐DEFINED
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Returns
COMPLIANCE | USER‐DEFINED

Examples
TEKEXP:MODE COMPLIANCE command sets the execution mode to the compliance mode.

TEKEXP:MODE? command returns the current execution mode.

Generate the report for the current session
This command generates the report for the current session.

Syntax
TEKEXP:REPORT GENERATE(Set)

Arguments
N/A

Examples
TEKEXP:REPORT GENERATE command generates the report for the current session.

Query the value of specified report header field in the report
This command queries the value of specified report header field in the report.

Syntax
TEKEXP:REPORT? ”<Device Field>” (Query)

Command arguments
Argument Name Argument Type
<Device Field>

Device field is the header name of each field in the setup
information section of the report.

<String>

Returns
<String>

Examples
TEKEXP:REPORT? "DUT ID" command returns the value of DUT ID field in the report.
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Query the value of specified result detail available in report summary/details
table
This command queries the value of specified result detail available in report summary/details table.

Syntax
TEKEXP:RESULT? "<TestName>" (Query)

TEKEXP:RESULT? "<TestName>","<ColumnName>" (Query)

TEKEXP:RESULT? "<TestName>","<ColumnName>",<RowNumber> (Query)

Command arguments
Argument Name Argument Type
<TestName>

It is the test name of which the details are required in the report.

<String>

<ColumnName>

It is the column header name of which the details are required in the
report.

<String>

<RowNumber>

It is the row number of which the details are required in the report.

<String>

Returns
<String>

Examples
TEKEXP:RESULT? "<TestName>" will return the pass fail status of test.

TEKEXP:RESULT? "<TestName>","<ColumnName>" will return all the row values of specific column for the test with
comma separated values.

TEKEXP:RESULT? "<TestName>","<ColumnName>",<RowNumber> will return the column value of specified row
number.

Restore the setup to default settings
This command restores the setup to default settings.

Syntax
TEKEXP:SETUP Default(Set)

Arguments
N/A

Examples
TEKEXP:SETUP Default command restores the setup to default settings.
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Save the setup
This command saves the setup.

Syntax
TEKEXP:SETUP Save(Set)

Examples
TEKEXP:SETUP Save command saves the setup.

Save the settings to a specified session
This command saves the settings to a specified session.

Syntax
TEKEXP:SETUP Save,"<SessionName>"
Command arguments
Argument Name Argument value
<SessionName> <String>

Examples
TEKEXP:SETUP Save,"<SessionName>" command saves the settings to a specified session.

Open the setup from a specified session
This command opens the setup from a specified session.

Syntax
TEKEXP:SETUP Open,"<SessionName>"(Set)

Command arguments
Argument Name Argument value
<SessionName> <String>

Examples
TEKEXP:SETUP Open,"<SessionName>" command opens the setup from a specified session.

Query the current setup file name
This command queries the current setup file name.

Syntax
TEKEXP:SETUP? CURRENT (Query)

Returns
<String>
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Examples
TEKEXP:SETUP? CURRENT command returns the current setup file name.

Run/stop/pause/resume the selected measurements execution in the application
This command run/stop/pause/resume the selected measurements execution in the application.

Syntax
TEKEXP:STATE <operation mode> (Set)

Command arguments
Argument Name Argument value
<operation mode> • RUN

• STOP
• PAUSE
• RESUME

Returns
RUN | STOP | PAUSE | RESUME

Examples
TEKEXP:STATE RUN command runs the execution for the selected measurements.

Query the current measurement execution status
This command queries the current measurement execution status.

Syntax
TEKEXP:STATE? (Query)

Returns
RUNNING | PAUSED | WAIT | ERROR | READY

Examples
TEKEXP:STATE? command returns the current measurement execution status.

Query whether the current setup is saved or not saved
This command queries whether the current setup is saved or not saved.

Syntax
TEKEXP:STATE? SETUP (Query)

Returns
Saved or Not‐Saved
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Examples
TEKEXP:STATE? SETUP command returns whether the current setup is saved or not saved.

Exit or close the application
The command exits or close the application

Syntax
TEKEXP:EXIT(Set)

Examples
TEKEXP:EXIT command close the application.

Query the status of the previous command execution
This command queries whether the previous command execution is completed successfully.

Syntax
TEKEXP:*OPC? (Query)

Returns
{0 | 1} or {True | False}

1 or True indicates that command execution is successful.

0 or False indicates that command execution is failed.

Examples
TEKEXP:*OPC? command returns whether the previous command operation is completed successfully.

Query the last error occurred
This command queries the last error occurred.

Syntax
TEKEXP:LASTERROR? (Query)

Returns
<String>

Examples
TEKEXP:LASTERROR? command returns the last error occurred.

Set or query the popup details
This command sets or queries the popup details.

Syntax
TEKEXP:POPUP? (Query)

TEKEXP:POPUP "<PopupResponse>" (Set)

SCPI Commands

TekExpress® 40G-CR4 40GBase-CR4 Compliance and Debug Solution Software Application Help 74



Command arguments
Argument Name Argument value
<PopupResponse> • Yes

• No

Returns
The pop‐up details return in the following format:

"<Tittle>","<message>","<response1>,<response2>".

Where,

<Tittle> :: <String>

<message> :: <String>

<response1>,<response2> :: <String>

Examples
TEKEXP:POPUP? command returns the popup details in following format ": "Do you really want to exit TekExpress?";Responses: "Yes,
No".

TEKEXP:POPUP "Yes" command sets the popup response to Yes.

Sets or query the limit values in the limits editor window
This command sets or queries the limit values in the limits editor window.

Syntax
TEKEXP:VALUE LIMIT,<TestName>,<LimitHeader>,<Value1>,<CompareString>,<Value2>(Set)

TEKEXP:VALUE? LIMIT,<TestName>,<LimitHeader> (Query)

Returns
<String> or <NRf>

Examples
TEKEXP:VALUE LIMIT,<TestName>,<LimitHeader>,<Value1>,<CompareString>,<Value2> command
sets the limits value for the specified testname and limit header.

TEKEXP:VALUE? LIMIT,<TestName>,<LimitHeader> command returns the limits value for the specified testname and
limit header.

Set or query the waveform file recalled for the specified test name and acquire
type
This command set or queries the waveform file recalled for the specified test name and acquire type.

If there are more than one waveform, the waveform file names are displayed with the symbol "$" separated values in the format

<WaveformFileName1$ WaveformFileName2>.
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Syntax
TEKEXP:VALUE WFMFILE,<TestName>,<AcquireType>,<WaveformFileName> (Set)

TEKEXP:VALUE? WFMFILE,<TestName>,<AquireType> (Query)

Returns
<String>

Examples
TEKEXP:VALUE WFMFILE,<TestName>,<AquireType>,<WaveformFileName> command recalls the sepcified
waveform file for the specified testname and acquire type.

TEKEXP:VALUE? WFMFILE,<TestName>,<AquireType> command returns the waveform file name recalled for the
specified testname and acquire type.

Set or query the enable/disable status of Verbose function
This command sets or queries the enable/disable status of Verbose function.

Syntax
TEKEXP:VALUE VERBOSE,"<Value>" (Set)

TEKEXP:VALUE? VERBOSE (Query)

Arguments
Argument Name Argument value
<Value> {True | False} or {1 | 0}

It represents enabled or disabled.

Where,

• True or 1 - enabled
• False or 0 - disabled

Returns
{True | False} or {0 | 1}

Examples
TEKEXP:VALUE VERBOSE,"<Value>" command enable or disable the Verbose function.

TEKEXP:VALUE? VERBOSE command returns the enable or disable status of Verbose function.

Query the enable or disable status of Continuous run function.
This command queries the enable or disable status of Continuous run function.

Syntax
TEKEXP:VALUE? GENERAL,"Enable Continuous Run" (Query)

Returns
{True | False} or {0 | 1}
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Where,

1 or True indicates that the continuous run function is enabled.

0 or False indicates that the continuous run function is disabled.

Examples
TEKEXP:VALUE? GENERAL,"Enable Continuous Run" command returns the enable or disable status of continuous run
function.

Set or query the enable/disable status of Continuous Run function
This command sets or queries the enable/disable status of Continuous Run function.

Syntax
TEKEXP:VALUE ContinuousRun,"<Value>" (Set)

TEKEXP:VALUE? ContinuousRun (Query)

Arguments
Argument Name Argument value
<Value> {True | False} or {1 | 0}

It represents enabled or disabled.

Where,

• True or 1 - enabled
• False or 0 - disabled

Returns
{True | False} or {0 | 1}

Examples
TEKEXP:VALUE? ContinuousRun command returns the enable or disable status of Continuous run function.

TEKEXP:VALUE ContinuousRun,"<Value>" command enable or disable the Continuous run function.

Set or query the continuous run duration time value
This command sets or queries the continuous run duration time value.

Syntax
TEKEXP:VALUE? ContinuousRun_Duration (Query)

TEKEXP:VALUE ContinuousRun_Duration,"<Value>" (Set)
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Arguments
Argument Name Argument value
<Value> Infinite | hh:mm

Infinite sets the radio on button to infinite.

hh:mm sets the continuous run duration to the specified time in
hours and minutes. The minimum time duration you can set is
00:30.

Returns
Infinite | hh:mm

Examples
TEKEXP:VALUE? ContinuousRun_Duration command returns the continuous run duration time value.

TEKEXP:VALUE ContinuousRun_Duration,"<Value>" command sets the continuous run duration time value.

Set or query the session create option in the continuous run function
This command sets or queries the option for session creation in the continuous run function.

Syntax
TEKEXP:VALUE? ContinuousRun_RunSessionOptions (Query)

TEKEXP:VALUE ContinuousRun_RunSessionOptions,"Value" (Set)

Arguments
Argument Name Argument value
<Value> NewSession | SameSession_ClearResults

NewSession - creates new session for each run.

SameSession_ClearResults - Clears the test results of the current
session and starts the test execution. The session results will be
added in the same session, by erasing the previous run results.

Returns
NewSession | SameSession_ClearResults

Examples
TEKEXP:VALUE? ContinuousRun_RunSessionOptions command returns the option for session creation in the
continuous run function.

TEKEXP:VALUE ContinuousRun_RunSessionOptions,"Value" command sets the option for session creation in the
continuous run function.

Set or query the View report after generating option status
This command sets or queries the enable/disable status of the View report after generating function.
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Syntax
TEKEXP:VALUE? GENERAL,"View Report After Generating" (Query)

TEKEXP:VALUE GENERAL,"View Report After Generating",<value> (Set)

Arguments
Argument Name Argument value
<Value> {True | False} or {1 | 0}

It represents enabled or disabled.

Where,

• True or 1 - enabled
• False or 0 - disabled

Returns
{True | False} or {0 | 1}

Examples
TEKEXP:VALUE? GENERAL,"View Report After Generating" command returns the enable or disable status of
view report after generating option.

TEKEXP:VALUE GENERAL,"View Report After Generating",<value> command enable or disable the view
report after generating option.

Returns the report as XML string
This command returns the report as XML string.

Syntax
TEKEXP:REPORTASXML? (Query)

Returns
<String>

Examples
TEKEXP:REPORTASXML? command returns the report XML string.

Copies all the images from current run session to the given destination location
This command copies all the images from current run session to the given destination location.

Syntax
TEKEXP:COPYIMAGES <DestinationPath> (Set)

Command argument
<DestinationPath> :: <String>

Returns
NA
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Examples
TEKEXP:COPYIMAGES C:\Temp command copies all the images from current run session to the mentioned location.

Selects the specified test(s) and deselect all other tests
This command selects the specified test(s) and deselect all other tests.

Syntax
TEKEXP:SELECTID <”TestID”> (Set)

Command argument
Argument Name Argument value
TestID String

Returns
NA

Examples
TEKEXP:SELECTID "11101"This command select the test associated with the ID and deselects all other tests in the application.

TEKEXP:SELECTID “11101,11102”This command selects the tests associated with the IDs and other tests will be deselected.

Returns the complete information about the selected test
This command returns the complete information about the selected test.

The information includes application name, TestID, Device selected, Suite selected, version, Test name, Test description.

Syntax
TEKEXP:TESTINFO? (Query)

Returns
<String>

Examples
TEKEXP:TESTINFO? This command returns the following details:

<TekExpress> <Test Id="11101" Device="TX-Device" Suite="Group1" Version="Spec 1.0" Name="Algorithm Library Measurement"
Description="This is Algorithm Library measurement test. Refer Section-B of TekExpress SampleApp Development Guide for more details.

Set the default session
Sets the application configurations to default value.

Syntax
TEKEXP:SESSION DEFAULT (set)

Examples
TEKEXP:SESSION DEFAULT, sets the application configurations to default value.
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Save the run/config sessions
Enter the name to save/config the session.

Syntax
TEKEXP:SESSION SAVE,“Session Name” (set)

Command arguments
Argument Name Argument value
<Session Name> <String>

Examples
TEKEXP:SESSION SAVE,“Session Name” saves the session.

Load the run/config session
Load the selected config/run session.

Syntax
TEKEXP:SESSION LOAD, “Session Name” (set)

Command arguments
Argument Name Argument value
<Session Name> <String>

Examples
TEKEXP:SESSION LOAD, “Session Name”, load the selected config/run session.

Delete the run/config session
Deletes the selected config/run session.

Syntax
TEKEXP:SESSION DELETE, "Session1, Session2" (set)

Command arguments
Argument Name Argument value
<Session Name> <String>

Examples
TEKEXP:SESSION DELETE, "Session1, Session2", deletes the selected config/run session.

Run the run/config saved session
Run the selected config/run session.
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Syntax
TEKEXP:SESSION RUN, “Session Name’s separated by comma” (set)

Command arguments
Argument Name Argument value
<Session Name> <String>
Session Name’s separated by comma (to run the multiple run
sessions)

<String>

Examples
TEKEXP:SESSION RUN, “Session Name’s separated by comma”, runs the selected config/run session.

Query the available list in the run/config session
Returns the list of available config/run session.

Syntax
TEKEXP:SESSION? LIST
Returns
Returns the list of available config/run session.

Examples
TEKEXP:SESSION? LIST, returns the list of available config/run session.

Query the current run/config session
Returns the selected config/run session.

Syntax
TEKEXP:SESSION? CURRENT
Returns
Returns the selected config/run session.

Examples
TEKEXP:SESSION? CURRENT, returns the selected config/run session.

Override the run/config session
Overrides the selected config/run session.

Syntax
TEKEXP:SESSION SAVE,"SessionName", "True" (set)
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Command arguments
Argument Name Argument Type Argument Value
<Session Name> <String> {True | False} or {1 | 0}

It represents enabled or disabled.

Where,

• True or 1 - enabled
• False or 0 - disabled

Returns
{True | False} or {0 | 1}

Examples
TEKEXP:SESSION SAVE,"SessionName", "True", overrides the selected config/run session.
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Application directories
You can find the application files at C:\Program Files\Tektronix\TekExpress 40G-CR4. The application directory and associated files are
organized as follows:

The following table lists the default directory names and their usage:

Table 18: Application directories and usage

Directory names Usage
Bin Contains application libraries
Compliance Suites Contains test suite specific files
ICP Contains instrument and application specific interface libraries
Images Contains images of the application
Lib Contains utility files specific to the application
Licenses Contains all the license files
Report Generator Contains style sheets for report generation
Tools Contains instrument and application specific files

File name extensions
The TekExpress 40G-CR4 software uses the following file name extensions:

Table 19: File name extension

File name extension Description
*.TekX Application session files (the extensions may not be displayed)
*.py Python sequence file.
Table continued…
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File name extension Description
*.xml Test-specific configuration information (encrypted) files.

Application log files

*.csv Test result reports

Plot data

*.mht Test result reports (default)

Test reports can also be saved in HTML format

*.pdf Test result reports

Application help document

*.xslt Style sheet used to generate reports
*.png Captured images
.wfm Test waveform file

View test-related files
Files related to tests are stored in My Documents\TekExpress 40G-CR4\Untitled session folder. Each test setup in this folder has both a
test setup file and a test setup folder, both with the test setup name. The test setup file is preceded by the TekExpress icon.

Inside the test setup folder is another folder named for the DUT ID used in the test sessions. The default is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has a folder and file pair, both named for the test session
using the naming convention (date)_(time). Each session file is stored outside its matching session folder:

Each session folder contains image files of any plots generated from running the test session. If you selected to save all waveforms or ran
tests using prerecorded waveform files, these are included here.

The first time you run a new, unsaved session, the session files are stored in the Untitled Session folder located at X:\TekExpress
40G-CR4. When you name and save the session, the files are placed in a folder with the name that you specify. A copy of the test files
stay in the Untitled Session folder until you run a new test or until you close the application.
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