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Getting help and support Related documentation

Related documentation

The following documents are available for the TekExpress® 40GBase-CR4 (Opt. 40G-CR4) Compliance
and Debug Solution Software.

Table 1: Product documentation

Item Purpose Location

Help Application operation and User
Interface help

In the application: Options > Help.

PDF of the help Printable version of the compiled help

C:\Program Files\Tek-
tronix\TekExpress\TekExpress
40GBase-CR4\Documents\

DPOJET 40GBase-CR4 setup
library Methods of Implementation
(MOI) for verification, debug and
characterization.

Detailed information on test setup and
execution

C:\Program Files\TekApplica-
tions\DPOJET

xxx

See also

Technical support

TekExpress 40GBase-CR4 Printable Help 1



Getting help and support Conventions used in help

Conventions used in help

Online Help uses the following conventions:

The term “DUT” is an abbreviation for Device Under Test.

The term “select” is a generic term that applies to the two methods of choosing a screen item (button,
control, list item): using a mouse or using the touch screen.

Table 2: Icon descriptions

Icon Meaning

This icon identifies important information.

This icon identifies conditions or practices that could result in loss of data.

This icon identifies additional information that will help you use the
application more efficiently.

xxx
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Technical support

Tektronix values your feedback on our products. To help us serve you better, please send us your
suggestions, ideas, or comments on your application or oscilloscope. Contact Tektronix through mail,
telephone, or the Web site. See Contacting Tektronix for more information.

When you contact Tektronix Technical Support, please include the following information (be as specific as
possible):

General information

All instrument model numbers

Hardware options, if any

Your name, company, mailing address, phone number, FAX number

Please indicate if you would like to be contacted by Tektronix about your suggestion or comments.

Application specific information

Software version number

Description of the problem such that technical support can duplicate the problem

If possible, save the setup files for all the instruments used and the application

If possible, save the TekExpress setup files, log.xml, *.TekX (session files and folders), and status
messages text file

If possible, save the waveform on which you are performing the measurement as a .wfm file
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Minimum system requirements

The following table shows the minimum system requirements needed for an oscilloscope to run this
application.

Table 3: System requirements

Oscilloscope See Supported instruments

Processor Same as the oscilloscope

Operating System Same as the oscilloscope:

Windows 7 (64-bit only) SP1 Windows 7 user account settings

Memory Same as the oscilloscope

Hard Disk Same as the oscilloscope

Display Same as the oscilloscope. Super VGA resolution or higher video adapter (800 x
600 minimum video resolution for small fonts or 1024 x 768 minimum video resolution
for large fonts). The application is best viewed at 96 dpi display settings

Firmware TekScope 10.3.3 for non-SX series digital oscilloscopes

TekScope 10.3.0 for SX series digital oscilloscopes

Software DPOJET, Jitter and Eye Diagram Analysis Tool, version 10.0.0.35 or later (64-bit)

IronPython 2.7.3

PyVisa 1.0.0.25

Microsoft .NET 4.0 Framework

Microsoft Internet Explorer 7.0 SP1 or later, or other Web browser for viewing
reports

Microsoft Photo Editor 3.0 or equivalent software for viewing image files

Adobe Reader software 7.0 or later for viewing portable document format (PDF)
files

Other Devices Microsoft compatible mouse or compatible pointing device.

Two USB ports minimum; four USB ports recommended.

PCI-GPIB or equivalent interface for instrument connectivity.

xxx
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Required Windows 7 user account setting

Windows 7 instruments need to have the User Account Control Settings set to Never Notify. To set
User Account Control Settings:

1. Go to Control Panel > User Accounts > Change User Account Control settings.

2. Set the sliding control to Never Notify as shown in the image, and click OK.

See also

Supported oscilloscopes
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Supported instruments
Table 4: Required equipment

Resource Description

Real-time oscilloscope Tektronix DPO71604C, DPO72004C, DPO72304DX, DPO72504D,
DPO72504DX, DPO73304D, DPO73304DX

Tektronix DSA71604C, DSA72004C, DSA72504D, DSA73304D

Tektronix MSO71604C, MSO72004C, MSO72304DX, MSO72504DX,
MSO73304DX

Tektronix DPO72304SX, DPO73304SX, DPO75002SX, DPO75902SX,
DPO77002SX

Test fixtures and accessories TF-QSFP-TPA-HCB-P: QSFP+ Host Compliance Board Plug

TF-DC-BLOCK-KIT: DC Block Kit (quantity 4)

For C series oscilloscopes: TCA-292MM adapters (quantity 4)

For D series oscilloscopes: 12 dB attenuators (quantity 4)

For D, DX, or SX series oscilloscopes: TCA-292D adapters (quantity 4)

xxx

See also

Minimum system requirements
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Install the software

Do the following steps to download the latest TekExpress 40GBase-CR4 software from the Tektronix
Web site and install on any compatible instrument running Microsoft Windows 7 (64-bit). See Minimum
System Requirements for details.

1. Close all applications (including the TekScope application).

2. Go to the www.tek.com Web site and locate the Downloads fields.

3. Enter tekexpress 40gbase-cr4 in the Model or Keyword field, select Software from the Select
Download Type list, and click GO.

4. Select the latest version of software. Follow instructions to download the software file.

5. Copy or download the installer executable file to the oscilloscope.

6. Double-click the installer .exe file to extract the installation files and launch the InstallShield Wizard.
Follow the on-screen instructions.

Software is installed at C:\Program Files\Tektronix\TekExpress\TekExpress

40GBase-CR4

7. Verify application installation

See also

Minimum system requirements
Supported instruments
Required \My TekExpress folder settings
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Verify application installation

To verify the installation was successful:

1. Open the TekScope application.

2. Click the Analyze menu.

3. Verify that TekExpress 40GBase-CR4 (for TekExpress application) and 40GBase-CR4 (for DPOJET
plug-in) is listed in the Analyze menu.

4. Click TekExpress 40GBase-CR4 in the menu to open the application. Verify that the application
opens successfully.

5. Activate the license.

NOTE. Contact Tektronix for information about floating or fixed licenses for theTekExpress 40GBASE-CR4.

See also
Required \My TekExpress folder settings
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Activate the license

Do the following to activate the TekExpress license:

1. In the TekScope application menu bar, click Utilities > Option Installation to open the TekScope
Option Installation wizard.

2. Push the F1 key on the oscilloscope keyboard to open the Option Installation help topic.

3. Follow the directions in the Option Installation help topic to activate the license.

See also

View version and license information
Required \My TekExpress folder settings
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View software version and license
information

To view version information for the TekExpress application (application and TekExpress Framework
versions),

1. Open the TekExpress application

2. Select Options > About TekExpress to display the version information.

3. Click OK to close the dialog box.

To view license and option key information in the TekScope application:

1. In the TekScope application, select Help > About TekScope.

2. Scroll through the Options list to locate 40GBase-CR4 Compliance and Debug Solution.

3. The Option installation key value is shown below the Options list.

See also

Activate the license
Options menu
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Required \My TekExpress folder settings

Before you run tests for the first time, do the following:

1. Map the \My TekExpress folder to Drive X

2. Set the \My TekExpress folder permissions

See also

Application directories and usage
File name extensions
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Map the My TekExpress folder to drive X

The first time you run the application, it creates the following folders on the oscilloscope:

\My Documents\My TekExpress\TekExpress 40GBase-CR4

\My Documents\My TekExpress\TekExpress 40GBase-CR4\Untitled Session

You need to map (assign) the sharedMy TekExpress folder as drive X: on the instrument running the
application. The application uses this shared folder to save session waveform files and for other application
file transfer operations.

To map the My TekExpress folder on the instrument to be drive X:

1. Open Microsoft Windows Explorer.

2. From the Windows Explorer menu, select Computer > Map network drive.

3. Select the Drive letter as X: (if there is any previous connection on X:, disconnect it first through
Tools > Disconnect Network drive menu of Windows Explorer. If you do not see the Tools menu,
press the Alt key).

4. In the Folder field, enter the remote ‘My TekExpress’ folder path (for example,
\\192.158.97.65\My TekExpress).

To determine the IP address of the instrument where the ‘My TekExpress’ folder exists, do the following:

1. On the instrument where the ‘My TekExpress’ folder exists, click Start and select Run.

2. Enter cmd and press Enter.

3. At the command prompt, enter ipconfig and press Enter to list the instrument IP configuration
information.

NOTE. The My TekExpress folder has the share name format <domain><user ID>My TekExpress.

If the instrument is not connected to a domain, the share name format is <instrument name><user
ID>My TekExpress.

NOTE. If the X: drive is mapped to any other shared folder, the application displays a warning message
asking you to disconnect the X: drive manually.

See also

Set the \My TekExpress folder permissions
Application directories and usage
File name extensions
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Set the \My TekExpress folder permissions

Make sure that the My TekExpress folder has read and write access. Also verify that the folder is not set
to be encrypted:

1. Right-click the folder and select Properties.

2. Select the General tab and then click Advanced.

3. In the Advanced Attributes dialog box, make sure that the option Encrypt contents to secure data
is NOT selected.

4. Click the Security tab and verify that the correct read and write permissions are set.

See also

Map the \My TekExpress folder to Drive X
Application directories and usage
File name extensions
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Application file directories and their contents

The application files are installed at the following location:

C:\Program Files\Tektronix\TekExpress\TekExpress 40GBase-CR4

The following table lists the application directory names and their purpose.

Table 5: Application directories and usage

Directory names Usage

Bin Contains application binary libraries

Compliance Suites Contains compliance-specific files

Documents Contains application technical documentation

Examples Contains various example support files

ICP Contains instrument and application-specific interface
libraries

Images Contains the Tektronix logo graphic

Lib Contains application utility files

Mask Files Contains return loss measurement related mask files.

Report Generator Contains style sheets for report generation

Tools Contains instrument and application-specific tool files

xxx

See also

File name extensions
Where test session files are stored
View test-results files
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File name extensions

The application uses the following file name extensions:

File name extension Description

.flt Filter files

.mht Test result reports (default)
Test reports can also be saved in HTML format

.py Python sequence file

.s16p S-Parameter input files for return loss measurement

.TekX Application session files (the extensions may not be
displayed)

.wfm Test waveform files

.xml Test-specific configuration information (encrypted) files

Application log files

.xslt Style sheet used to generate reports

xxx

See also

View test-related files
Application directories and their contents
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Where test session files are stored

When you launch TekExpress 40GBase-CR4 for the first time, it creates the following folders on the
oscilloscope:

\My Documents\My TekExpress\TekExpress 40GBase-CR4

\My Documents\My TekExpress\TekExpress 40GBase-CR4\Untitled Session

Every time you start the application, the application creates an Untitled Session folder in the
TekExpress 40GBase-CR4 folder. The application automatically deletes the Untitled Session

folder when you exit the application. To preserve your test session files, save your session information
(setup, reports, and so on) before exiting the TekExpress application. When you save a session, the
application creates a .TekX file, and a folder named for the session that contains associated files, on the
oscilloscope X: drive.

CAUTION. Do not edit or modify any of the session folders or their files. Modifying these files or their
contents may result in loss of data or corrupted session files. Each session has multiple files associated
with it.

See also

Map the \My TekExpress folder to Drive X
Set the \My TekExpress folder permissions
Application directories and usage
File name extensions
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TekExpress® and DPOJET 40GBase-CR4
features

Welcome to the TekExpress® 40GBase-CR4 Compliance and Debug Solution Software application and
DPOJET 40GBase-CR4 plug-in. These applications provide an automated, simple, and efficient way to
test interfaces and devices to the requirements of the IEEE 802.3-2012 section 85 and Annex 85A standard.

Key features and benefits include:

An intuitive user interface and framework decreases testing time and learning curve

Provides measurements for electrical characterization of 40GBase-CR4 signal at TP2 and TP0

Provides both an automation solution (for compliance) and DPOJET option (for debug), saving up to
80% on testing time as compared to manual testing

Has flexible parameter control for characterization and margin analysis (in user-defined mode)

Supports N1N0 (4 <= N <= 12), PRBS7, PRBS11, PRBS15, PRBS20, PRBS23, and PRBS31 patterns
in advanced/user-defined mode, and supports PRBS9, 8180, and 1010 patterns in compliance mode

Complete programmatic interface enables users to call 40G-CR4 functions using custom automation
scripts

Performs automatic signal validation before performing tests and displays an error message if the
signal does not meet acceptable limits

Includes DPOJET setup files for 8180, 1010, and PRBS9 patterns to help set oscilloscope and load
measurements (in DPOJET).

Creates detailed reports (.MHT or .PDF) for compliance record keeping, with flexible reporting
features such as appending the report, auto-incrementing the report, and including user comments

1
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Start the application

To start the TekExpress 40G-CR4 application, do either of the following:

Select Analyze > TekExpress 40GBase-CR4 from the TekScope menu.

Double-click any saved TekExpress 40GBase-CR4 session file (<file name>.TekX).

The oscilloscope opens the TekExpress 40GBase-CR4 application:

When you first run the application after installation, the application checks for a file called Resources.xml
located in the C:\Users\<username>\My TekExpress\TekExpress 40GBase-CR4 folder.
The Resources.xml file contains information about available network-connected instruments. The
Resources.xml file gets mapped to the X: drive when the application launches. Session files are then stored
inside the X:\TekExpress 40GBase-CR4 folder.

If the application cannot find the Resources.xml file, the application runs an instrument discovery program
to detect connected instruments before launching.

NOTE. Do the steps in the Required \My TekExpress folder settings topic before running tests with the
application for the first time.

To keep the 40GBase-CR4 application window on top, select Keep On Top from the 40GBase-CR4
Options menu. If the application goes behind the oscilloscope application, click Analyze > TekExpress
40GBase-CR4 to move the application to be in front.
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See also

Required My TekExpress folder settings
Activate the license
Exit the application
Application controls
Application panel overview
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Exit the application

To exit the application, click on the application title bar. Follow on-screen prompts to save any
unsaved session, save test setup files, or exit the application.

NOTE. Using other methods to exit the application can result in abnormal termination of the application.
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Application user interface overview

TekExpress 40GBase-CR4 uses panels to group related configuration, test, and results settings. Click on
a button to open the associated panel. A panel can have one or more tabs that list further parameters
available in that panel. Displayed controls in a panel can change depending on settings made in that
panel or another panel.

Table 6: Application panels overview

Panel Name Purpose

Setup The Setup panel shows the test setup controls. Click the Setup button to open
this panel.

Use this panel to:

Select DUTparameters.

Select the test(s).

Set acquisitions parameters for selected tests.

Select test notification preferences.

Status View the progress and analysis status of the selected tests, and view test logs.

Results View a summary of test results and select result viewing preferences.

Plots View plots generated for tests

Reports Browse for reports, save reports as specific file types, specify report naming
conventions, select report content to include (such as summary information, detailed
information, user comments, setup configuration, application configuration), and
select report viewing options.

xxx

See also

Application controls
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Application controls

Application controls are accessible at all times, and provide the interface tools to the application functions.

Table 7: Application controls descriptions

Item Description

Options menu Menu to display global application controls.

Test Panel buttons Buttons that open panels to configure, monitor, and report test sessions.

Start / Stop button Use the Start button to start the test run of the measurements in the selected order.
If prior acquired measurements have not been cleared, the new measurements
are added to the existing set.

The button toggles to the Stop mode while tests are running. Use the Stop button to
abort the test.

Pause / Continue button Use the Pause button to temporarily interrupt the current acquisition. When a test is
paused, the button name changes to “Continue.”

Clear button Use the Clear button to clear all existing measurement results. Adding or deleting a
measurement, or changing a configuration parameter of an existing measurement,
also clears measurements. This is to prevent the accumulation of measurement
statistics or sets of statistics that are not coherent. This button is available only on
the Results panel.

Application window move icon Position the cursor over the three-dot pattern in the upper left corner of the application
window. When the cursor changes to a hand, drag the window to the desired location.

xxx

See also

Application panel overview
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Options menu overview

The Options menu is located in the upper right corner of the application.

The Options menu has the following selections:

Menu Function

Default Test Setup Opens an untitled test setup with defaults selected

Open Test Setup Opens a saved test setup

Save Test Setup Saves the current test setup selections

Save Test Setup As Creates a new test setup based on an existing one

Open Recent Displays a menu of recently opened test setups to select
from

Instrument Control Settings Detects, lists, and refreshes the connected instruments
found on specified connections (LAN, GPIB, USB, and so
on)

Keep On Top Keeps the application on top of other open windows on
the desktop

Email Settings Use to configure email options for test run and results
notifications

Deskew Use to set deskew parameter and read instrument
deskew/attenuation values.

Help Displays the application help

About TekExpress Displays application details such as software name,
version number, and copyright

Provides access to license information

Provides a link to the Tektronix Web site

xxx
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See also

Application controls

28 TekExpress 40GBase-CR4 Printable Help



Application controls and menus Setup controls overview

Setup controls overview

The Setup panel contains sequentially ordered tabs that help guide you through a typical test setup and
execution process. Click on a tab to open the associated panel and controls.

The tabs on this panel are:

DUT: Set the DUT parameters

Test Selection: Select test(s)

Acquisitions: Select acquisition parameters

Preferences: Select test fail notification preferences
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Set DUT parameters

Use the DUT tab to select parameters for the device under test. The settings are global and apply to all
tests for the current session. DUT settings also affect the list of available tests in the Test Selection tab.

Click Setup > DUT to access the DUT parameters:

Table 8: DUT tab settings

Setting Description

DUT ID Adds an optional text label for the DUT to reports. The default value is DUT001. The
maximum number of characters is 32.

You cannot use the following characters in an ID name: (.,..,...,\,/:?”<>|*)

Comments icon (to the right
of the DUT ID field)

Opens a Comments dialog box in which to enter optional text to add to a report.
Maximum size is 256 characters. To enable or disable comments appearing on the
test report, see Select report options.)

Acquire live waveforms Acquire active signals from the DUT for measurement and analysis.

Use prerecorded waveform files Run tests on a saved waveform. Open (load) a saved test setup

View Compliance: Preselects tests and parameters needed to meet compliance
specifications. Disables the compliance filter controls.

Advanced: Enables selecting of specific tests and setting custom parameters for
tests. Selecting Advanced adds a Configuration tab to the Setup panel. Advanced
(User-defined) tests are not considered to meet compliance testing requirements.

Device Profile

Test point Select a test point location from those listed.

De-embedding Filter (TP0 only) Lists de-embed filter file to use for TP0. Use this filter to de-embed the signal path
between TP0 and TP2.

Click the ... button to navigate to and select filter files. The default location is My
Documents.

Filter files are device specific; contact the device manufacture to obtain filter files.

This control is not available when Test Point is set to TP2.

Number of Lanes to Test Selects the number of lanes to test.

Setup Opens the Test Lane Setup dialog box to select which lanes to test.

xxx
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Test Lane Setup dialog

Use this dialog box to select which lanes to test. Link width field must match the value in the Number
of Lanes to Test field in the DUT panel.

See also

Select a test
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Select tests

Use the Test Selection tab to select tests. Listed tests depend on the test point selected in the DUT panel
(TP0 or TP2).

Table 9: Test Selection tab settings

Setting Description

Deselect All, Select All buttons Deselect or select all tests in the list.

Select Required button Selects all tests required for compliance certification.

Tests Click on a test to select or unselect. Selecting a test also show details about that
test in the Test Description pane.

All required tests are selected when in Compliance test mode.

Schematic button Shows an equipment and test fixture setup schematic (connection diagram) for the
selected test. Use to set up the equipment and fixtures or to verify the setup before
running the test.

Configure Opens the Test Selection Configuration panel.

xxx

NOTE. Select Required is the default test selection mode.

See also

Set acquisition parameters
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Set acquisition parameters

Use the Acquisition tab in the Setup panel to view test acquisition parameters. You also use this tab to
load prerecorded (saved) test session waveform files on which to run tests.

Contents displayed on this tab depend on the DUT type and selected tests.

Table 10: Acquisitions tab settings

Setting Description

Device Lists the signal type and input channel assigned to a lane.

Click in a Source field to assign a channel source to that lane.

Deskew Use to set deskew parameter and read instrument deskew/attenuation values.

Test name/Acquisitions list Lists each test name and its associated acquisition lane/group type.

Show Acquire Parameters When selected, lists the acquisition parameters associated with each test. Parameters
are shown in a separate column.
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Table 10: Acquisitions tab settings (cont.)

Setting Description

Acquire Step By Step When selected, the application displays equipment/signal setup and configuration
information, and examples of input signal waveform images, during execution of the
measurement acquisitions. Us the example waveform images to verify that the live
signal is correct. Click OK to continue the acquisition process.

When not selected, the application displays just equipment or signal
setup/configuration information during execution of the measurement acquisitions, as
required by selected tests. No input signal waveform images are shown.

If the live signal waveform does not match the displayed example waveform, or if an
acquisition fails, exit the screen and click Stop to halt the test session,

Signal Validation Sets the signal validation actions. Select from the available list items. Signal
validation only applies to live signals; signal validation is not done on saved
(pre-recorded) waveform.

Select Prompt me if signal fails to display a dialog box when the application fails to
acquire a valid signal after a specified number of retries (as set in the Configuration
tab or fields). Select one of the following options in the dialog box:

Re-Acquire: The application attempts to re-acquire the signal.

Use Anyway: Use the acquired signal for all applicable tests. The test results
may not be as expected.

Skip Test: Skip (ignore) any test(s) that depend on this acquisition. Skipped tests
are listed in the status panel and in the report.

Select Skip test if signal fails to skip all tests that depend on an acquired signal that
fails signal validation. The comments section in the report file will show the details as
"User skipped acquisitions for this pattern."

Select Use signal as is - Don’t Check to skip signal validation and use the signal
as-is for testing. The test results may not be as expected.

xxx

The application saves all acquisition waveforms to files by default. Waveforms are saved to a folder
that is unique to each session (a session starts when you click the Start button). The folder path is
X:\40GBase-CR4\Untitled Session\<dutid_folder>\<date>_<time>. Images created for each
analysis, CSV files with result values, reports, and other information specific to that particular execution
are also saved in this folder.

When the session is saved, content is moved to that session folder and the “Untitled Session” name is
replaced by the session name.

See also

Running tests on prerecorded saved waveforms
Acquire Step By Step example waveform screens
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Acquire Step By Step example waveform
screens

The Acquire Step By Step option is available in the Acquisitions panel. When selected, this function
displays the reference input waveform required for the selected measurement. Compare the example
waveform to the input waveform coming from DUT with the typical reference waveform (snap shot) to
verify the correct signal is present. If the signal does not match, you can change the setup before acquiring
the waveforms.

This is a global function that is applied to all tests (except Group6 in TP2 and Group5 in TP0) when
selected. By default, this option is deselected.

NOTE. The Acquire Step By Step function is not available when using prerecorded waveform files.

All PRBS data patterns except PRBS9

The following screen shot is shown for all PRBS(n) data patterns except PRBS9. Positive edge trigger
with level as 50% is used. This image shows that the signal to be acquired should have a random pattern.

PRBS9 data pattern

The following screen shot is shown for PRBS9 data patterns. Width trigger with positive width as equal 9
UI will be used, cursors will be placed to show that the positive pulse is representing 9 UI.
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8010 data pattern

Following screen shot will be shown

Positive edge trigger with level as 50% is used. This image shows that the signal to be acquired should
have an 8180 pattern. Cursors are placed to show that the positive width is approximately 8 UI.

1010 data pattern

Following screen shot will be shown Positive edge trigger with level as 50% is used. This image shows
that the signal to be acquired should have an 1010 pattern. Cursors are placed to show that the positive
width is approximately 1UI.

36 TekExpress 40GBase-CR4 Printable Help



Application controls and menus Acquire Step By Step example waveform screens

Differential peak to peak voltage with tx disabled test

If differential peak to peak voltage with tx disabled test is selected, the applicatin shows the following
screen. This image shows that signal which is expected with DUT tx disabled.
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Running tests on prerecorded (saved)
waveforms

To load a saved waveform file:

1. Click DUT.

2. Click Use pre-recorded waveform files.

3. Click Acquisitions. The Waveform Filename column now shows browse buttons.

4. Click the browse button ( ) for each test acquisition type.

5. Navigate to and select the appropriate waveform file(s). You will need to select all waveforms required
for the acquisition type.

6. To change, remove, or add a file to the list, click the browse button next to the file name to change, and
use the menu items to replace, remove (delete) or add a file in the list.

7. Click Start.
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Configuration tab parameters

Use the Configuration tab to set and view global instrument parameters for the selected tests. Which
fields are available to edit depends on the selected test mode (Compliance or User Defined) as set in
this tab or the DUT tab.

NOTE. The Configuration tab is only displayed when the View (test mode) field is set to Advanced
(user-defined) in the DUT tab. To access configuration settings while in Compliance testing mode (the
DUT View mode is set to Compliance), open the Test Selection tab and click the Configure button.

NOTE. You cannot change test parameters that are grayed out.

See also

Configuration: Global Settings parameters
Configuration: Measurements settings
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Configuration: Global Settings parameters

The following table lists the Configuration tab settings and parameters. This is the same panel as the one
displayed when clicking the Configure button in the Test Selection tab (when DUT panel View field is set
to Compliance). Fields shown on this tab can change depending on selected items.

Table 11: Configuration: Global Settings tab

Control Description

Mode Sets the test measurement mode.

Compliance: Most test parameter values cannot be edited. Select this for
compliance mode testing.

User Defined Mode: Enables editing of measurement parameters for selected
tests (in the Measurements tab or with the Limits Editor).

Test Selection button Displays the main Test Selection panel. This button is only shown when View is set
for Compliance mode on the DUT panel, and you clicked the Configure button in
the Test Selection panel.
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Table 11: Configuration: Global Settings tab (cont.)

Control Description

Limits Editor button Opens the Limits Editor dialog box.

In User Defined Mode, use the Limits Editor to edit individual test limit settings.

To edit a value, click that field and either select from the displayed list or enter a new
value. Use scroll bars to view all available fields.

Limits Editor: compare string definitions

In Compliance Mode, use the Limits Editor to view the measurement high and low
limits used for selected tests. You cannot edit values while in Compliance mode.

Instruments Detected Displays a list of the connected instruments found during the instrument discovery.
Instrument types include equipment such as oscilloscopes and signal sources (AFG,
AWG). Select Options > Instrument Control Settings to refresh the connected
instrument list.

Record Length Sets the waveform record length to acquire. Valid range is 2M to 20M.

Use Filter File for De-embedding All tests except Group 4: When selected, provides a way to select and apply a
de-embed filter for sampling rate of 100 Gs/sec.

Group 4 tests only: When selected, provides a way to select and appy a
de-embedding filter for sampling rate of 3.3 Ts/sec.

xxx

See also

Configuration: Measurements parameters
About acquisitions
Limits Editor: compare string definitions
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Configuration: Measurements parameters

Use the Measurements tab to view or edit individual test parameters. Select a test for which to view the
parameters; the parameters are shown if that measurement has editable parameters.

To edit measurement parameters, select User-Defined Mode, select a measurement, and make changes to
the tab fields (if any) listed below the measurement selection list.

NOTE. Not all measurements have editable settings.

Click the Test Selection button (if present) to return to the main Test Selection panel. Otherwise select
another Setup tab to exit this panel.

Table 12: Configuration: Measurements tab

Control Description

Mode Sets the test measurement mode.

Compliance: Most test parameter values cannot be edited. Select this for
compliance mode testing.

User Defined Mode: Enables editing of measurement parameters for selected
tests (in the Measurements tab or with the Limits Editor).

Test Selection button Displays the main Test Selection panel. This button is only shown when View is set
for Compliance mode on the DUT panel, and you clicked the Configure button in
the Test Selection panel.
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Table 12: Configuration: Measurements tab (cont.)

Control Description

Limits Editor button Opens the Limits Editor dialog box.

In User Defined Mode, use the Limits Editor to edit individual test limit settings
of all listed tests.

To edit a value, click that field and either select from the displayed list or enter a new
value. Use scroll bars to view all available fields.

Limits Editor: compare string definitions

In Compliance Mode, use the Limits Editor to view the measurement high and low
limits used for selected tests. You cannot edit values while in Compliance mode.

Instruments Detected Displays a list of the connected oscilloscopes and other instruments found during
the instrument discovery. Select Options > Instrument Control Settings to refresh
the connected instrument list.

Measurement list Lists test measurements as selected in the Test Selection tab. Select a test in this list
to view/edit any associated parameters.

Acquire tab Displays the available acquisition settings of the selected measurement. Not all
measurements have editable settings.

xxx

See also

Configuration tab: Global Settings parameters
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Preferences tab

Use the Preferences tab to set the application action when a test is completed.

Table 13: Preferences tab settings

Setting Description

On test completion, send me an
Email

Sends an email when a test finishes.

xxx
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Status panel

The Status button displays the Test Status and Log View tabs, which provide status on test acquisition and
analysis (Test Status tab) and a listing of test tasks performed (Log View tab).

Test Status tab

Log View tab

The application opens the Test Status tab when you start a test run. You can select the Test Status or the
Log View tab to view these items while tests are running. Use standard Windows procedures for changing
the width of a column.

TekExpress 40GBase-CR4 Printable Help 45



Application controls and menus Status panel

Table 14: Log View tab: fields and controls

Control Description

Message History Window that lists all executed test operations with timestamp information.

Auto Scroll Enables automatic scrolling of the log view as information is added to the log during
the test.

Clear Log button Clears all messages from the log view.

Save button Saves the log file to a text file. Use the standard Save File dialog box to navigate to
and specify the folder and file name to which to save the log text.

xxx
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Results panel overview

When a test finishes, the application automatically opens the Results panel to display a summary of
signal and preset test results.

The Overall Test Result is displayed at the top left of the Results table. If all of the tests for the session
pass, the overall test result is Pass. If one or more tests fail, the overall test result is Fail.

By default, results are displayed in summary format with the measurement details collapsed and with the
Pass/Fail column visible. Set viewing preferences for this panel from the Preferences menu (menu item is
in the upper right corner of this panel).

NOTE. NA (Not Available) is displayed in the test results when invalid signals cause measurement errors.
The report provides details related to the cause of the error.

See also

View a report
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Preferences menu (Results panel)

The Preferences menu is part of the Results panel display (in the upper-right area of the screen). Use the
Preferences menu to change how some items display in the Results panel.

Item Description

Show Pass/Fail Show or hide the Pass/Fail column

View Results Summary Collapse all expanded test results

View Results Details Expand all tests listed

Enable Wordwrap Enable or disable wordwrap in columns

Group By Lane Groups test results by lane number

Group By Test Groups test results by test number

xxx

See also

Results panel overview
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View test result files

Files related to tests are stored in the My TekExpress\40GBase-CR4 folder. Each test setup in this folder
has a test setup file and a test setup folder, both with the test setup name.

The test setup file is preceded by the TekExpress icon and usually has no visible file name extension.

Inside the test setup folder is another folder named for the DUT ID used in the test sessions. The default
is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has a folder and file pair, both
named for the test session using the naming convention (date)_(time). Each session file is stored outside
its matching session folder:

Each session folder contains image files of any plots generated from running the test session. If you
selected to save all waveforms or ran tests using prerecorded waveform files, these are included here.

The first time you run a new, unsaved session, the session files are stored in the Untitled Session

folder located at ..\My TekExpress\40GBase-CR4. When you name and save the session, the files are
placed in a folder with the name that you specify. A copy of the test files stay in the Untitled Session folder
until you run a new test or until you close the 40G-CR4 application.

See also

File name extensions
Required \My TekExpress folder settings
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Plots panel overview

Use the Plots panel to view waveform plots associated with test measurements, and use cursors to take
measurements on the plotted waveforms.

The toolbar at the to edge of the plot contains the plot UI controls. Position the cursor over a control to
see a pop-up description of that control. Use the Lane and Select Test controls to select and view a plot
for a specific measurement.

See also

Plot cursors
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Plot cursors

The plot panel provides a pair of cursors for each plot axis (X axis and Yaxis). The readout in the upper
right corner of the plot shows the difference (delta) between the cursors.

Each pair of cursors is positioned together by default. To move a cursor:

1. position the mouse pointer over the plot cursor icon until the pointer changes to a vertical or horizontal
move icon.

2. Press and hold the left mouse button, then move the cursor to a new position.

3. Release the mouse button.
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Reports panel overview

Use the Reports panel to append new results to a report, name and save reports from the current session,
select test content to include in reports, view saved reports, and select report conent options.

For information on setting up reports, see Select report options. For information on viewing reports,
see View a Report.

See also

About panels
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Select report options

Click the Reports button and use the Reports panel controls to select which test result information to
include in the report, and the naming conventions to use for the report. For example, always give the report
a unique name or select to have the same name increment each time you run a particular test.

Select report options before running a test or when creating and saving test setups. Report settings are
included in saved test setups.

In the Reports panel, select from the following report options:

Table 15: Report options

Setting Description

Report Generation

Generate new report Creates a new report.

Append to previous run session Appends the latest test results to the end of the current session’s test results report.

Replace current test in previous
run session

Replaces the previous test results with the latest test results. Results from newly
added tests are appended to the end of the report.

Report name Displays the name and location from which to open a report. The default location is
at \My TekExpress\40GBase-CR4\<session_name>\<dutid_folder>\<date>_<time>\.
The report file in this folder gets overwritten each time you run a test unless you
specify a unique name or select to auto increment the report name.

Change the report name or location.

Do one of the following:

In the Report Path field, type over the current folder path and
name.

Double-click in the Report Path field and then make selections
from the popup keyboard and click the Enter button.

Be sure to include the entire folder path, the file name, and the
file extension. For example: C:\<user_name>\My Documents\My
TekExpress\40GBase-CR4\DUT001_Test_72.7.1.3.mht.

NOTE. You cannot set the file location using the Browse button.

Open an existing report.

Click Browse, locate and select the report file and then click View at the bottom
of the panel.

Save as type Saves a report in the specified output format (Web archive or PDF).

NOTE. If you select a file type different from the default, be sure to change the
report file name extension in the Report Name field to match.

Auto increment report name if
duplicate

Sets the application to automatically increment the name of the report file if the
application finds a file with the same name as the one being generated. For example:
DUT001, DUT002, DUT003. This option is enabled by default.
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Table 15: Report options (cont.)

Setting Description

Add logo to report Adds the specified graphic file to the top-right area of the report title. Click the browse
button and navigate to and select the graphic file to load (.PNG or .JPG format;
maximum size = 200 pixels wide x 100 pixels high).

Contents To Save

Include pass/fail results summary Sets the application to include the color block labeled Test Result (indicating whether
the test passed or failed) in the report. For details, see Report Contents in View
a report.

Include detailed results Sets the application to include parameters measured, such as Margin, Low Limit,
High Limit, Compliance Mode Yes/No, Execution Time, and test-specific Comments
generated by the software.

Include plot images Sets the application to save waveform and measurement data screen shots that are
captured from the oscilloscope during test execution.

Include setup configuration Sets the application to include hardware and software information in the summary
box at the top of the report. Information includes: the oscilloscope model and
serial number, probe model and serial number, the oscilloscope firmware version,
SPC and factory calibration status, and software versions for applications used in
the measurements.

Include user comments Select to include any comments about the test that you or another user added in the
DUT tab of the Setup panel. Comments appear in the Comments section, under the
summary box at the beginning of each report.

Group test Results by Groups report test results by test name or Lanes.

View Report After Generating Automatically opens the report in a Web browser when the test completes. This
option is selected by default.

View button Click to view the most current report.

Generate Report Generates a new report based on the current (most-recent) analysis results.

Save As Specify a name for the report.

xxx
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View a report

The application automatically generates a report when test analysis is completed and displays the report
in your default Web browser (unless you cleared the View Report After Generating check box in the
Reports panel before running the test). If you cleared this check box, or to view a different test report,
do the following:

1. Click the Reports button.

2. Click the Browse button and locate and select the report file to view.

3. In the Reports panel, click View.

For information on changing the file type, file name, and other report options, see Select report options.
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Report contents

A report shows specified test details, such as detailed results and plots, as set in the Reports panel.

Setup configuration information is listed in the summary box at the beginning of the report. This
information includes the oscilloscope model and serial number, and software versions. To exclude this
information from a report, clear the Include Setup Configuration check box in the Reports panel before
running the test.

If you selected to include comments in the test report, any comments you added in the DUT tab are
shown at the top of the report.

The Test Result column indicates whether a test passed or failed. If the test passed, the cell text is green.
If the test failed, the text is red. To exclude this information from a report, clear the Include Pass/Fail
Results Summary check box in the Reports panel before running the test.

NOTE. NA (Not Applicable) is displayed in the report contents if an invalid waveform was supplied
for the test.

See also

Results panel overview
View test-related files
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TekExpress 40GBase-CR4 Printable Help 57



Running tests Test process flow

Test process flow

Use the following steps to set up and run tests.

1. Allow test instruments to warm up (~20 minutes).

2. Deskew the real-time oscilloscope.

3. Set up test equipment.

4. Verify that required instruments are connected to 40G-CR4.

5. Set DUT parameters.

6. Select tests.

7. View acquisition settings.

8. Set global signal-related parameters.

9. Select test notification preferences.

10. Select report options.

11. Check the prerun checklist

12. Click Start to Run tests.

See also

About test setups
About running tests

Deskew real-time oscilloscopes

Use the following procedure to deskew direct input SMA channels on a real time oscilloscope.

NOTE. DPOJET has an automatic deskew option under Analyze > Jitter And Eye Analysis > Deskew.
Refer to your DPOJET online help for information on how to deskew the channels.

1. Run Signal Path Compensation (SPC) on the oscilloscope.

2. Connect a SMA Power Splitter (preferred) or SMA 50 Ω coaxial “T” connector to the Fast Edge
output of the oscilloscope.

3. Connect SMA cables from each of the two channels to be deskewed to the power splitter (or SMA
coaxial “T” connector). It is best to use matched cables when making high speed serial measurements.
It is important to use the same cables that will be used for subsequent measurements.

4. Select Default Setup, and then select Autoset on the oscilloscope front panel.
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5. Set the oscilloscope for 70% to 90% full screen amplitude on both channels. Center both traces
so that they overlap.

6. Make sure that volts/div, position, and offset are identical for the two channels being deskewed.

7. Set the time/div to approximately 100 ps/div or less, with sample rate at 1 ps/pt. These settings
are not critical, but should be close.

8. Set the horizontal acquisition mode to average, which provides a more stable display.

9. Select Deskew from the Vertical menu.

10. Verify that the reference channel (typically CH1 or CH2) is set to 0 ps deskew.

11. In the deskew control window, select the channel to deskew (typically CH3 or CH4). Adjust the
deskew to overlay the rising edge as best as possible.

NOTE. Typical values are in the 10’s of ps or less with cables connected directly from Fast Edge to SMA
inputs. If you are using a switch box (for example, Keithley), deskew the complete path from where the
test fixture connects, through the switch, and into the oscilloscope. Deskew values in these cases may
be as much as 30 ps or more.

NOTE. There can be significant differences in the skew between two TCA-SMA adapters. If you find
that a system requires a very large correction, obtain a pair of TCA-SMA adapters that closely match
each other to reduce the amount of correction.

NOTE. TekExpress retains the user configured Deskew values, and does not override the values during test
runs.
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Instrument and DUT connection setup

Click the Setup > Test Selection > Schematic button to open a PDF file that shows the compliance test
setup diagrams (instrument, DUT, and cabling) for supported testing configurations.

See also

Minimum system requirements
View connected instruments
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Running tests

After selecting and configuring tests, review the prerun checklist and then click Start to run the tests. To
monitor the test progress, switch between viewing the Status panel and the Results panel. You cannot edit
any fields on these panels while tests are running.

The application displays a report when the tests are complete. While the tests are running, other
applications may display windows in the background. The TekScope application takes precedence over
other applications, but you can switch to other applications by using the Alt + Tab key combination. To
keep the application screen on top (in front of other application screens), select Keep On Top from
the TekExpress Options menu.

See also

Configuration tab parameters
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Prerun checklist

Do the following before you click Start to run a test:

NOTE. If this is the first time you are running a test on the application, make sure that you have done the
steps in Required \My TekExpress folder settings before continuing.

1. Make sure that all the required instruments are properly warmed up (approximately 20 minutes).

2. Perform Signal Path Compensation (SPC)

a. On the oscilloscope main menu, select the Utilities menu.

b. Select Instrument Calibration.

c. Follow the on-screen instructions.

3. Deskew realtime oscilloscope channels

4. Verify that the application detects that the correct instruments are connected (oscilloscope and signal
sources):

a. In 40GBase-CR4, click Setup > Test Selection > Configure.

b. Click Global Settings.

c. In the Instruments Detected list, verify that the test setup instruments are shown. If they are not,
click on an instrument and click the arrow button to list and select from all detected instruments. If
the required instrument is still not listed, use the TekExpress Instrument Control Settings dialog
box to scan for and detect instruments (see View connected instruments).

See also

Instrument and DUT connection setup
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Test setup files overview

Saved test setup information (such as the selected oscilloscope, general parameters, acquisition parameters,
measurement limits, waveforms (if applicable), and other configuration settings) are all saved under
the setup name at X:\40GBase-CR4.

Use test setups to:

Run a new session, acquiring live waveforms, using a saved test configuration.

Create a new test setup based on an existing one.

View all the information associated with a saved test, including the log file, the history of the test
status as it executed, and the results summary.

Run a saved test using saved waveforms.

See also

Save a test setup
Recall a saved test setup
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Save a test setup file

Save a test setup before or after running a test to save the test settings. Create a new test setup from any
open setup or from the default setup. When you select the default test setup, all parameters are returned to
the application’s default values.

To immediately save the current setup session to the same setup name, select Options > Save Test Setup.

To immediately save the current setup session to a new setup name, select Options > Save Test Setup As.

To create and save a new setup from the default test setup:

1. Select Options > Default Test Setup to return the application to default test settings.

2. Click the application Setup button and use the setup tabs to set required options and parameters (DUT,
Test Selection, and so on).

3. Click the application Reports button and set your report options.

4. Optional: Click Start to run the test and verify that it runs correctly and captures the specified test
information and reports. If it does not, edit the parameters and repeat this step until the test runs to
your satisfaction.

Running the test helps verify that all parameters are set correctly, but it is not a necessary step.

5. Select Options > Save Test Setup. Enter the file name for the new setup file. The application saves
the file to X:\40GBase-CR4\<session_name>.

See also

Test process flow
View test-related files
Configuration tab parameters

TekExpress 40GBase-CR4 Printable Help 65



Saving and recalling test setup files Open (load) a saved test setup file

Open (load) a saved test setup file

These instructions are for recalling saved test setups.

1. Select Options > Open Test Setup.

2. Select the setup from the list and click Open. Setup files must be located at X:\40GBase-CR4.

See also

About test setups
Create a new test setup based on an existing one
Test setups overview

66 TekExpress 40GBase-CR4 Printable Help



Saving and recalling test setup files Run a saved test in prerecorded mode

Run a saved test in prerecorded mode

Use this option to rerun a complete test using just the oscilloscope and the saved test setup files, provided
that you selected to save the captured waveforms when you originally ran the saved test.

NOTE. When you run a saved test in prerecorded mode and then save it under the same name, the test
results are saved in a new session folder named for the date and time of the session. Any test settings that
you changed for the session will be saved as a new test session file and be paired with a folder of the same
name. Example. When you open a test setup that has multiple sessions and you select a session from the
Run session list in the DUT tab, the settings associated with that test session are restored.

Each test session folder has a matching test session file that stores the individual test settings for that
session.

1. Use the Options menu to Open a saved test setup file

2. Select Setup > DUT and then select Use pre-recorded waveform files. A Run session drop-down
list appears that displays the previous saved sessions for this test.

3. Select the session to run. NOTE. If you select a session for which no waveform files were saved, you
will receive an error message. Either select another test session or select waveform files to use.

4. Click Start.

5. To save the test results, session settings, and related files, save the test setup before selecting another
test setup or exiting the application.
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Create a new test setup file based on an
existing one

Use this method to create a variation on a test setup without having to create the setup from the beginning.

1. Select Options > Open Test Setup.

2. Select a setup from the list and then click Open.

3. Use the Setup and Reports panels to modify the parameters to meet your testing requirements.

4. Select Options > Save Test Setup As.

5. Enter a test setup name and click Save.

See also

About test setups
Set DUT parameters
Select acquisitions
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About the programmatic interface

The Programmatic interface seamlessly integrates the TekExpress test automation application with the
high-level automation layer. This also lets you control the state of the TekExpress application running on a
local or a remote computer.

The following terminology is used in this section to simplify description text:

TekExpress Client: A high-level automation application that communicates with TekExpress using
TekExpress Programmatic Interface.

TekExpress Server: The TekExpress application when being controlled by TekExpress Client.

TekExpress leverages .Net Marshalling to enable the Programmatic Interface for TekExpress Client.
TekExpress provides a client library for TekExpress clients to use the programmatic interface. The
TekExpress client library is inherited from .Net MarshalByRef class to provide the proxy object for the
clients. The TekExpress client library maintains a reference to the TekExpress Server and this reference
allows the client to control the server state.

See also

Requirements for Developing TekExpress Client
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To enable remote access

To access and remotely control an instrument using the TekExpress programmatic interface, you need to
change specific firewall settings as follows:

1. Access the Windows Control Panel and open the Windows Firewall tool (Start > Control Panel > All
Control Panel Items > Windows Firewall).

2. Click Advance Settings > Inbound Rules.

3. Scroll through the Inbound Rules list to see if the following item(s) (or with a similar name) are
shown:

TekExpress 40GBase-CR4

4. If items are shown, you do not need to set up any rules. Exit the Windows Firewall tool.

5. If items are missing, use the following procedure to run the New Inbound Rule Wizard and add these
executables to the rules to enable remote access to the TekExpress application.

Run the New Inbound Rule wizard

1. Click on New Rule (in Actions column) to start the New Inbound Rule wizard.

2. Verify that Program is selected in the Rule Type panel and click Next.

3. Click Browse in the Program panel and navigate to and select one of the following TekExpress
applications (depending on the one for which you need to create a rule):

4. TekExpress 40GBase-CR4

5. TekExpress.exe
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NOTE. See Application directories and content for the path to the application files.

6. Click Next.

7. Verify that Allow the connection is selected in the Action panel and click Next.

8. Verify that all fields are selected (Domain, Private, and Public) in the Profile panel and click Next.

9. Use the fields in the Name panel to enter a name and optional description for the rule. For example, a
name for the TekExpress 40G-CR4 application could be TekExpress 40G-CR4 Application. Add
description text to further identify the rule.

10. Click Finish to return to the main Windows Firewall screen.

11. Scroll through the Inbound Rules list and verify that the list shows the rule that you just entered.

12. Repeat steps 1 through 11 to enter the other TekExpress executable if it is missing from the list.
Enter TekExpress PI as the name.

13. Scroll through the Inbound Rules list and verify that the list shows the rule that you just entered.

14. Exit the Windows Firewall tool.

To use the remote access:

1. Obtain the IP address of the instrument on which you are running TekExpress 40GBase-CR4. For
example, 134.64.235.198.

2. On the PC from which you are accessing the remote instrument, use the instrument IP address as part
of the PI code to access that instrument. For example:

object obj = piClient.Connect(“134.64.235.198”,out clientid);
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Requirements for developing TekExpress
client

While developing TekExpress Client, use the TekExpressClient.dll. The client can be a VB .Net, C#
.Net, Python, or Web application. The examples for interfaces in each of these applications are in the
Samples folder.

References required

TekExpressClient.dll has an internal reference to IIdlglib.dll and IRemoteInter-
face.dll.

IIdlglib.dll has a reference to TekDotNetLib.dll.

IRemoteInterface.dll provides the interfaces required to perform the remote automations. It is an
interface that forms the communication line between the server and the client.

IIdlglib.dll provides the methods to generate and direct the secondary dialog messages at the
client-end.

NOTE. The end-user client application does not need any reference to the above mentioned DLL files.
It is essential to have these DLLs (IRemoteInterface.dll, IIdlglib.dll and TekDotNetLib.dll) in the same
folder as that of TekExpressClient.dll.

Required steps for a client

The client uses the following steps to use TekExpressClient.dll to programmatically control the
server:

Develop a client UI to access the interfaces exposed through the server. This client loads
TekExpressClient.dll to access the interfaces. After TekExpressClient.dll is loaded, the client
UI can call the specific functions to run the operations requested by the client. When the client is up and
running, it does the following to run a remote operation:

1. To connect to the server, the client provides the IP address of the PC where the server is running.

2. The client locks the server application to avoid conflict with any other Client that may try to control
the server simultaneously. “Lock” would also disable all user controls on the server so that server
state cannot be changed by manual operation.

If any other client tries to access a server that is locked, it will receive a notification that the server
is locked by another client.

3. When the client has connected to and locked the server, the client can access any of the programmatic
controls needed to run the remote automations.

4. After the client operations finish, the client unlocks the server.
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Remote proxy object

The server exposes a remote object to let the remote client access and perform the server-side operations
remotely. The proxy object is instantiated and exposed at the server-end through marshalling.

The following is an example:

RemotingConfiguration.RegisterWellKnownServiceType (typeof (TekExpressRe-

moteInterface), “TekExpress Remote interface”, WellKnownObjectMode.Singleton);

This object lets the remote client access the interfaces exposed at the server side. The client gets the
reference to this object when the client gets connected to the server.

For example,

//Get a reference to the remote object

remoteObject = (IRemoteInterface)Activator.GetObject(typeof(IRemoteInterface),

URL.ToString());
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Client proxy object

Client exposes a proxy object to receive certain information.

For example,

//Register the client proxy object

WellKnownServiceTypeEntry[] e = RemotingConfiguration.GetRegisteredWell-

KnownServiceTypes();

clientInterface = new ClientInterface();

RemotingConfiguration.RegisterWellKnownServiceType(typeof(ClientInterface),

“Remote Client Interface”, WellKnownObjectMode.Singleton);

//Expose the client proxy object through marshalling

RemotingServices.Marshal(clientInterface, "Remote Client Inteface");

The client proxy object is used for the following:

To get the secondary dialog messages from the server.

To get the file transfer commands from the server while transferring the report.

Examples

clientObject.clientIntf.DisplayDialog(caption, msg,iconType, btnType);

clientObject.clientIntf.TransferBytes(buffer, read, fileLength);

For more information, click the following links:

Secondary Dialog Message Handling
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The secondary dialog messages from the Secondary Dialog library are redirected to the client-end when a
client is performing the automations at the remote end.

In the secondary dialog library, the assembly that is calling for the dialog box to be displayed is checked
and if a remote connection is detected, the messages are directed to the remote end.

File Transfer Events

When the client requests the transfer of the report, the server reads the report and transfers the file by
calling the file transfer methods at the client-end.
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Client programmatic interface example

An example of the client programmatic interface is described and shown as follows:

Process flowchart
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1. Connect to a server or remote object using the programmatic interface provided.

2. Get the client ID that is created when connecting to the remote object. This client ID is one of the
required parameters to communicate with the server.

NOTE. The server identifies the client with this ID only and rejects any request if the ID is invalid.

3. Lock the server for further operations. This disables the application interface.

NOTE. You can get values from the server or set values from the server to the client only if the application
is locked.

4. Register for receiving notifications on status change events on the server. To register you need to
give a handler as a parameter.

NOTE. Whenever there is a change in the status of the server, all the clients registered with the server
receive a notification from the server.

5. Select the tests that you want to run through the programmatic interface.

6. Set the necessary parameters for each test.

7. Run the tests.

8. Poll for the status of the application.

NOTE. Skip step 8 if you are registered for the status change notification and the status is Ready.

9. After completing the tests, get the results.

10. Create a report or display the results and verify or process the results.

11. Unlock the server after you complete all the tasks.

12. Disconnect from the remote object.

Handler of status change notification

1. Get the status. If the status is Wait or Error, get the information that contains the title, message
description, and the expected responses for the status.

2. Perform the actions based on the status information.

3. Set the response as expected.
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See also

Program remote access code example
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Program remote access code example

This code example shows how to communicate between a remote PC and TekExpress 40GBase-CR4.

Table 16: Remote access code example

Task Code

Start the
application

Connect through
an IP address.

m_Client.Connect("localhost") 'True or False

clientID = m_Client.getClientID

Lock the server m_Client.LockServer(clientID)

Disable the
Popups

m_Client.SetVerboseMode(clientID, false)

Set the DUT ID m_Client.SetDutId(clientID, "DUT_Name")

Select a
measurement.

mclient.SelectTest(clientID,"40GBase-CR4","TP2","72.7.1.4 Common

mode voltage limits",True)

Select a channel mclient.setGeneralParameter(clientID,"40GBase-CR4","TP2","","De-Em-

bedding filter" & "$" & "C:\\Program Files\\Tektronix\\TekEx-

press\\xyz.flt") 'Measurement selected

Configure
the selected
measurement

mclient.SetAcquireParameter(ClientID,"40GBase-CR4","TP2","85.8.3.9

Signaling Rate","Group4" & "$" & "Data Pattern" & "$" & "PRBS7")

Run with set
configurations

m_Client.Run(clientID)

Wait for the test to
complete.

Do

Thread.Sleep(500)

m_Client.Application_Status(clientID)

Select Case status

Case "Wait"

Get the current
state information

mClient.GetCurrentStateInfo(clientID, WaitingMsbBxCaption,

WaitingMsbBxMessage, WaitingMsbBxButtontexts)

Send the
response

mClient.SendResponse(clientID, WaitingMsbBxCaption, WaitingMsb-

BxMessage, WaitingMsbBxResponse)

End Select

Loop Until status = "Ready"

After the test is completed:

Save results 'Save all results values from folder for current run

m_Client.TransferResult(clientID, logDirname)

'Save all waveforms from folder for current run

m_Client.TransferWaveforms(clientID, logDirname)

'Save all images from folder for current run

m_Client.TransferImages(clientID, logDirname)
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Table 16: Remote access code example (cont.)

Task Code

Unlock the server m_Client.UnlockServer(clientID)

Disconnect from
server

m_Client.Disconnect()

Exit the
application

xxx
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The 40GBase-CR4 application commands

Click a client action below to see the command name, description, parameters, return value, and an
example, associated with the action.

Connect through an IP address

Lock the server

Disable the popups

Set or get the DUT ID

Set the configuration parameters for a suite or measurement

Query the configuration parameters for a suite or measurement

Select a measurement

Select a suite

Select a channel

Configure the selected measurement

Run with set configurations or stop the run operation

Handle Error Codes

Get or set the timeout value

Wait for the test to complete

After the test is complete

Save, recall, or check if a session is saved

Unlock the server

Disconnect from server

string id

Name Type Direction Description

id string IN Identifier of the client performing the
remote function.

xxx

Ready: Test configured and ready to start

Running: Test running

Paused: Test paused

Wait: A popup that needs your inputs

Error: An error is occurred
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string dutName

Name Type Direction Description

dutName string IN The new DUT ID of the setup

xxx

out bool saved

Name Type Direction Description

saved bool OUT Boolean representing whether the
current session is saved

xxx

This parameter is used as a check in SaveSession() and SaveSessionAs() functions.

string ipAddress

Name Type Direction Description

ipAddress string IN The ip address of the server to which the client
is trying to connect to. This is required to
establish the connection between the server
and the client.

xxx

out string clientID

Name Type Direction Description

clientid string OUT Identifier of the client that is connected to the
server

clientId = unique number + IP address of the
client. For example, 1065–192.157.98.70

xxx

NOTE. If the dutName parameter is null, the client is prompted to provide a valid DUT ID.

NOTE. The server must be active and running for the client to connect to the server. Any number of
clients can be connected to the server at a time.

NOTE. When the client is disconnected, it is unlocked from the server and then disconnected. The id
is reused.
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string dutId

Name Type Direction Description

dutId string OUT The DUT ID of the setup

xxx

The dutId parameter is set after the server processes the request.

string device

Name Type Direction Description

device string IN Specifies the name of the device

xxx

string suite

Name Type Direction Description

suite string IN Specifies the name of the suite

xxx

string test

Name Type Direction Description

test string IN Specifies the name of the test to
obtain the pass or fail status

xxx

string parameterString

Name Type Direction Description

parameterString string IN Selects or deselects a test

xxx

int rowNr

Name Type Direction Description

rowNr int IN Specifies the zero based row index of
the sub-measurement for obtaining
the result value

xxx

NOTE. When the client tries to lock a server that is locked by another client, the client gets a
notification that the server is already locked and it must wait until the server is unlocked. If the client
locks the server and is idle for a certain amount of time, then the server is unlocked automatically
from that client.
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out string[ ] status

Name Type Direction Description

status string array OUT The list of status messages generated
during run

xxx

string name

Name Type Direction Description

name string IN The name of the session being
recalled

xxx

The name parameter cannot be empty. If it is empty, the client is prompted to provide a valid name.

NOTE. When the run is performed, the status of the run is updated periodically using a timer.

string name

Name Type Direction Description

name string IN The name of the session being saved

xxx

The name parameter cannot be empty. If it is empty, the client is prompted to provide a valid name.

Once the session is saved under ‘name’ you cannot use this method to save the session in a different
name. Use SaveSessionAs instead.

string name

Name Type Direction Description

name string IN The name of the session being
recalled

xxx

The same session is saved under different names using this method. The name parameter cannot be
empty. If it is empty, the client is prompted to provide a valid name.

bool isSelected

Name Type Direction Description

isSelected bool IN Selects or deselects a test

xxx
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string time

Name Type Direction Description

time string IN The time in seconds
which refers to the timeout
period

xxx

The time parameter gives the timeout period, that is the time the client is allowed to be locked and
idle. After the timeout period, if the client is still idle, it gets unlocked.

The time parameter should be a positive integer. Else, the client is prompted to provide a valid
timeout period.

bool_verbose

Name Type Direction Description

_verbose bool IN Specifies whether the verbose mode
should be turned ON or OFF

xxx

NOTE. When the session is stopped, the client is prompted to stop the session and is stopped at
the consent.

string filePath

Name Type Direction Description

filePath string IN The location where the report must
be saved in the client

xxx

NOTE. If the client does not provide the location to save the report, the report is saved at
C:\ProgramFiles.

NOTE. When the client is disconnected, the client is unlocked automatically.

out string caption

Name Type Direction Description

caption string OUT The wait state or error state message sent to
you

xxx
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out string message

Name Type Direction Description

message string OUT The wait state/error state message to you

xxx

out string[] buttonTexts

Name Type Direction Description

buttonTexts string array OUT An array of strings containing the
possible response types that you can
send

xxx

string response

Name Type Direction Description

response string IN A string containing the response
type that can be selected (it must be
one of the strings in the string array
buttonTexts)

xxx

out string clientID

Name Type Direction Description

clientID string OUT Identifier of the client that is connected to the
server

clientID = unique number + IP address of the
client. For example, 1065–192.157.98.70

xxx
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Connect through an IP address
Command name Parameters Description Return Value Example

Connect() string
ipAddress

out string
clientID

This method
connects the client
to the server.
Note

The client provides
the IP address
to connect to the
server.

The server
provides a unique
client identification
number when
connected to it.

Return value is
either True or
False.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as boolean

returnval = m_Client.Con-
nect(ipaddress,m_clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Lock the server
Command name Parameters Description Return Value Example

LockSession() string clientID This method locks
the server.
Note

The client must
call this method
before running
any of the remote
automations. The
server can be
locked by only one
client.

String value
that gives the
status of the
operation after
it is performed.

The return value
is "Session
Locked.” on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval =
m_Client.LockServer(clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Disable the popups
Command name Parameters Description Return Value Example

SetVerboseMode() string clientID

bool _verbose

This method sets
the verbose mode
to either true or
false.

When the value
is set to true, any
message boxes
appearing during
the application
will be routed to
the client machine
that is controlling
TekExpress.

When the value is
set to false, all the
message boxes
are shown on the
server machine.

String that gives
the status of the
operation after it
is performed

When Verbose
mode is set to
true, the return
value is “Verbose
mode turned on.
All dialog boxes
will be shown to
client”.

When Verbose
mode is set to
false, the return
value is “Verbose
mode turned off.
All dialog boxes
will be shown to
server”.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Verbose mode is turned on

return=m_Client.SetVerbose-
Mode(clientID, true)

Verbose mode is turned off

returnval=m_Client.SetVer-
boseMode(clientID, false)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Set or get the DUT ID
Command name Parameters Description Return Value Example

SetDutId() string clientID

string dutName

This method
changes the DUT
ID of the set up.
The client must
provide a valid
DUT ID.

String that gives
the status of the
operation after it
is performed

Return value
is “DUT Id
Changed” on
success

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

return=m_Client.SetDutId(clien-
tID,desiredDutId)
Note

GetDutId() string clientID

string dutId

This method gets
the DUT ID of the
current set up.

String that gives
the status of the
operation after it
is performed

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

return=m_Client.GetDutid(clien-
tID, out DutId)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Set the configuration parameters for a suite
or measurement

Command name Parameters Description Return Value Example

SetGeneralParame-
ter

string clientID

string device

string suite

string test

string
parameterString

This method sets
the number of video
lanes for the selected
measurement.

NOTE. Use this
command to select
a lane, channel, or
source type.

String that gives
the status of the
operation after it is
performed

The return value is ""
(an empty String) on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

Select Channel

Select Measurement
Method

SetAnalyzeParame-
ter()

string clientID

string device

string suite

string test

string
parameterString

This method sets
the configuration
parameters in the
Analyze panel of
the Configuration
Panel dialog box
for a given suite or
measurement.

The return value is ""
(an empty String) on
success.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL

returnval as string

SetAcquireParame-
ter()

string clientID

string device

string suite

string test

string
parameterString

This method sets
the configuration
parameters in the
Acquire panel of
the Configuration
Panel dialog box
for a given suite or
measurement.

returnVal = remo-
teObject.SetAc-
quireParameter(id,
device, suite, test,
parameterString)

if ((OP_STATUS)
returnVal !=
OP_STA-
TUS.SUCCESS)

return Command-
Failed(returnVal)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Select channel example

returnval = mclient.setGeneralParameter(clientID,"40GBase-CR4","TP2","","De-Embedding filter"
& "$" & "C:\\Program Files\\Tektronix\\TekExpress\\xyz.flt") 'Measurement selected

Select measurement method example

returnval=mclient.SelectTest(clientID,"40GBase-CR4","TP2","85.8.3.9 Signaling Rate",True)

Configure acquire parameter example

Parameter Example

Data Pattern returnval = mclient.SetAcquireParameter(ClientID,"40GBase-
CR4","TP2","85.8.3.9 Signaling Rate","Group4" & "$" & "Data Pattern" &
"$" & "PRBS7")

xxx
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Query the configuration parameters for a
suite or measurement

Command name Parameters Description Return Value Example

GetGeneralParam-
eter()

string clientID

string device

string suite

string test

string parame-
terString

This method
gets the general
configuration
parameters for
a given suite or
measurement.

The return value
is the general
configuration
parameter for
a given suite or
measurement
that is set.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Query Channel

GetAnalyzeParam-
eter()

string clientID

string device

string suite

string test

string parame-
terString

This method gets
the configuration
parameters set in
the Analyze tab of
the Configuration
Panel dialog box
for a given suite or
measurement.

The return
value is the
configuration
parameter set in
the Analyze tab of
the Configuration
Panel dialog box
for a given suite
or measurement.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL

returnval as string

GetAcquireParame-
ter()

string clientID

string device

string suite

string test

string parame-
terString

This method gets
the configuration
parameters set in
the Acquire tab for
a given suite or
measurement.

The return
value is the
configuration
parameter set
in the Acquire tab
for a given suite
or measurement.

Query Acquire Parameters
example

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".

Query channel example

returnval = mClient.GetGeneralParameter(clientID, "40GBase-CR4", "TP2", "85.8.3.9 Signaling
Rate", "Lane0 Connected to:Data0+: Single Ended")
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Query acquire parameter examples

Parameter Example

Record Length returnval = mClient.GetAcquireParameter(clientID, "40GBase-CR4",
"TP2", "85.8.3.9 Signaling Rate", "Record Length")

xxx
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Select a measurement
Command name Parameters Description Return Value Example

SelectTest() string clientID

string device

string suite

string test

bool isSelected

This method
selects or
deselects a given
test.

When this
parameter is
set to true, you
can select a
measurement.

When this
parameter is
set to false, you
can deselect a
measurement.

String that
displays the
status of the
operation after
it is performed

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL

returnval as string

returnval=mclient.Se-
lectTest(clientID,"40GBase-
CR4","TP2","72.7.1.4 Common
mode voltage limits",True)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Select a suite
Command name Parameters Description Return Value Example

SelectSuitet() string clientID

string device

string suite

bool isSelected

This method
selects or
deselects a given
suite.

When this
parameter is set
to true, you can
select a suite.

When this
parameter is set
to false, you can
deselect a suite.

String that gives
the status of the
operation after it
is performed

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Select Suite (Default):

returnval=mclient.Select-
Suite(ClientID, "40GBase-CR4",
"TP2",True)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Select a channel
Command name Parameters Description Return Value Example

SetGeneralParame-
ter()

string clientID

string device

string suite

string test

string parame-
terString

This method sets
the parameters
that are not
specific to any
given test.

NOTE. Use this
command to select
a lane, channel, or
source type.

String that gives
the status of the
operation after it
is performed

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Select Channel

Select Measurement Method

SetAnalyzeParame-
ter()

string clientID

string device

string suite

string test

string parame-
terString

This method sets
the configuration
parameters in the
Analyze tab of
the Configuration
Panel dialog box
for a given suite or
measurement.

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

SetAcquireParame-
ter()

string clientID

string device

string suite

string test

string parame-
terString

This method sets
the configuration
parameters in the
Acquire tab of
the Configuration
Panel dialog box
for a given suite or
measurement.

returnVal = re-
moteObject.Se-
tAcquireParam-
eter(id, device,
suite, test, pa-
rameterString)

if ((OP_STATUS)

returnVal !=
OP_STA-
TUS.SUC-
CESS) return
Command-
Failed(re-
turnVal)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Select channel example

returnval = mClient.SetGeneralParameter(clientID,"40GBase-CR4", "TP2", "85.8.3.9 Signaling
Rate", "Lane0 Connected to:Data0+: Single Ended$CH1")

Select measurement method example

returnval = mClient.SetGeneralParameter(clientID,"40GBase-CR4", "TP2", "85.8.3.9 Signaling
Rate", "Data Pattern$PRBS9")
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Configure the selected measurement
Command name Parameters Description Return Value Example

SetAnalyzeParame-
ter()

string clientID

string device

string suite

string test

string parame-
terString

This method
sets the Analyze
parameters
(Configuration
parameters) for a
given test.

The return
value is "" (an
empty String) on
success.

m_Client = new Client()
//m_Client is a reference to
the Client class in the Client DLL.

returnval as string

SetAcquireParame-
ter()

string clientID

string device

string suite

string test

string parame-
terString

This method
sets the Acquire
parameters in the
Acquire tab of the
Configure Dialog
box for a given
test.

returnVal = re-
moteObject.Se-
tAcquireParam-
eter(id, device,
suite, test, pa-
rameterString)

if ((OP_STA-
TUS)

returnVal !=
OP_STA-
TUS.SUC-
CESS) re-
turn Com-
mand-
Failed(re-
turnVal)

m_Client = new Client()
//m_Client is a reference to
the Client class in the Client DLL.

returnval as string

Configure Acquire Parameters
for Data Pattern

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".

Configure parameter example

Parameter Example

Data Pattern returnval = mClient.SetAcquireParameter(clientID, "40GBase-CR4",
"TP2", "85.8.3.9 Signaling Rate", "Data Pattern$PRBS9")

xxx
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Run with set configurations or stop the run
operation

Command name Parameters Description Return Value Example

Run() string clientID Runs the selected
tests. Note

After the server
is set up and
configured, run
it remotely using
this function.

String that gives
the status of the
operation after it
is performed

The return value
is "Run started."
on success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Run(clien-
tID)

Stop() string clientID Stops the currently
running tests Note

String that gives
the status of the
operation after it
is performed.

The return value
is "Stopped." on
success.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Stop(clien-
tID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Handle error codes

The return value of the remote automations at the server-end is OP_STATUS, which changes to a string
value depending on its code and returned to the client. The values of OP_STATUS are as follows:

Value Code Description

FAIL −1 The operation failed.

SUCCESS 1 The operation succeeded.

NOTFOUND 2 Server not found

LOCKED 3 The server is locked by another client, so the operation cannot
be performed.

UNLOCK 4 The server is not locked. Lock the server before performing
the operation.

NULL 0 Nothing

xxx
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Get or set the timeout value
Command name Parameters Description Return Value Example

GetTimeOut() string clientID Returns the current
timeout period set by
the client

String that gives
the status of the
operation after it is
performed

The default return
value is 1800000.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Get-
TimeOut()

SetTimeOut() string clientID

string time

Sets a timeout
period specified
by the client.
After this timeout
period expires, the
server is unlocked
automatically.

String that gives
the status of the
operation after it is
performed

On success the
return value is
“TimeOut Period
Changed”.

m_Client = new
Client() //m_Client
is a reference to the
Client class in the
Client DLL.

returnval as string

return-
val=m_Client.Set-
TimeOut(clientID,
desiredTimeOut)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Wait for the test to complete

The commands in this group execute while tests are running. The GetCurrentStateInfo() and
SendResponse() commands are executed when the application is running and in the wait state.

Command name Parameters Description Return Value Example

ApplicationStatus() string clientID This method gets the
status of the server
application.

The states at a given
time are Ready,
Running, Paused,
Wait, or Error.

String value that
gives the status
of the server
application

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Applica-
tionStatus(clientID)

QueryStatus() string clientID

out string[]
status

An interface for
the user to transfer
Analyze panel status
messages from the
server to the client.

String that gives
the status of the
operation after it
is performed

On success the
return value is
“Transferred.”.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnVal=m_Client.QueryS-
tatus(clientID, out statusMes-
sages)

if ((OP_STATUS)returnVal ==
OP_STATUS.SUCCESS)

return “Status updated.”

else

return CommandFailed(re-
turnVal)
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Command name Parameters Description Return Value Example

GetCurrentState-
Info()

NOTE. This
command is
used when the
application is
running and is in
the wait or error
state.

string clientID

out string
caption

out string
message

out string[]
buttonTexts

This method gets the
additional information
of the states when the
application is in Wait
or Error state.

Except client ID, all
the others are Out
parameters.

This command
does not return
any value.

This function
populates the
Out parameters
that are passed
when invoking
this function.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

m_Client.GetCurrentState-
Info(clientID, caption,mes-
sage, buttonTexts)

SendResponse()

NOTE. This
command is
used when the
application is
running and is in
the wait or error
state.

string clientID

out string
caption

out string
message

string response

After receiving the
additional information
using the method
GetCurrentState-
Info(), the client de-
cides which response
to send, and then
sends the response to
the application using
this function. The
response should be
one of the strings that
was received earlier
as a string array in the
GetCurrentStateInfo
function. The _cap-
tion and _message
should match the in-
formation received
earlier in the GetCur-
rentStateInfo function.

This command
does not return
any value.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

m_Client.SendResponse(cli-
entID, caption,message,
response)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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After the test is complete
Command name Parameters Description Return Value Example

GetPassFailSta-
tus()

string clientID

string device

string suite

string test

This method gets
the pass or fail
status of the
measurement after
test completion.

NOTE. Execute
this command
after completing
the measurement.

String that gives
the status of the
operation after it
is performed

Returns the pass
or fail status in the
form of a string

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=mClient.Get-
PassFailStatus(clientID,
"40GBase-CR4", "TP2",
"85.8.3.9 Signaling Rate")

GetResultsValue() string clientID

string device

string suite

string test

string parame-
terString

This method gets
the result values of
the measurement
after the run.

String that gives
the status of the
operation after it
is performed

Returns the result
value in the form
of a string

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=mClient.Ge-
tResultsValue(clien-
tID, "40GBase-CR4",
"TP2", "85.8.3.9 Signaling
Rate","Value")

GetReportParame-
ter()

string clientID

string device

string suite

string test

string parame-
terString

This method
gets the general
report details such
as oscilloscope
model,
TekExpress
version, and
40GBase-CR4
version.

The return
value is the
oscilloscope
model,
TekExpress
version, and
40GBase-CR4
version.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

Oscilloscope Model

returnval=m_Client.GetRe-
portParameter(clientID,"Scope
Model")

TekExpress Version

returnval=m_Client.GetReport-
Parameter(clientID,"TekExpress
Version")

40GBase-CR4 Version

returnval=m_Client.GetReport-
Parameter(clientID,"Application
Version")
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Command name Parameters Description Return Value Example

TransferReport() string clientID

string filePath

This method
transfers the report
generated after the
run.

The report
contains the
summary of the
run.

The client must
provide the
location where
the report is to
be saved at the
client-end.

String that gives
the status of the
operation after it
is performed

Transfers all the
result values in
the form of a
string

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.TransferRe-
port(clientID,"C:\Report”)

TransferWave-
forms()

string clientID

string filePath

This method
transfers all the
waveforms from
the folder for the
current run.

NOTE. Each
time you click
Start, a folder is
created on the X:
drive. Transfer the
waveforms before
clicking Start

String that gives
the status of the
operation after it
is performed

Transfers all the
waveforms in the
form of a string

On success the
return value is
“Transferred.”

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Transfer-
Waveforms(clientID,"C:\Wave-
forms”)

TransferImages() string clientID

od

string filePath

This method
transfers all the
images (screen
shots) from the
folder for the
current run (for
a given suite or
measurement).

NOTE. Each
time you click
Start, a folder is
created in the X:
drive. Transfer the
waveforms before
clicking Start.

String that gives
the status of the
operation after it
is performed

Transfers all the
images in the
form of a string

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.TransferIm-
ages(clientID, "C:\Waveforms”)

xxx
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NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".

String parameterString

Name Type Direction Description

parameterString string IN Specifies the oscilloscope
model, TekExpress version, and
40GBase-CR4 version.

xxx
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Save, recall, or check if a session is saved
Command name Parameters Description Return Value Example

CheckSession-
Saved()

string clientID

out bool saved

This method
checks whether
the current session
is saved.

Return value is
either True or
False

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Check-
SessionSaved(m_clientID, out
savedStatus)

RecallSession() string clientID

string name

Recalls a saved
session. The
client provides
the session name.

String that gives
the status of the
operation after it
is performed

The return value
is “Session
Recalled.”.

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.RecallSes-
sion(clientID, savedSession-
Name)

SaveSession() string clientID

string name

Saves the current
session. The
client provides
the session name.

String that gives
the status of the
operation after it
is performed

The return value
is "Session Sav-
ed."/"Failed.".

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.SaveSes-
sion(clientID, desiredSession-
Name)

SaveSessionAs() string clientID

string name

Saves the current
session under a
different name
every time this
method is called.
The client provides
the session name.

String that gives
the status of the
operation after it
is performed

The return value
is "Session
Saved.".

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.SaveSes-
sionAs(clientID, desiredSes-
sionName)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Unlock the server
Command name Parameters Description Return Value Example

UnlockSession() string clientID This method
unlocks the server
from the client.
The ID of the client
to be unlocked
must be provided.
Note

String that gives
the status of the
operation after it
is performed

The return value
is "Session
Un-Locked.".

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Unlock-
Server(clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Disconnect from the server
Command name Parameters Description Return Value Example

Disconnect() string clientID This method
disconnects the
client from the
server.
Note

Integer value
that gives the
status of the
operation after
it is performed

1 for Success

–1 for Failure

m_Client = new Client()
//m_Client is a reference to the
Client class in the Client DLL.

returnval as string

returnval=m_Client.Discon-
nect(m_clientID)

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found.Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed.".
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Instrument control settings

Use the TekExpress Instrument Control Settings dialog box to search for and list the connected resources
(instruments) detected on selected connections (LAN, GPIB, USB), and each instruments connection
information.

Access this dialog box from Options > Instrument Control Settings.

Use the Instrument Control Settings feature to search for connected instruments and view instrument
connection details. Listed connected instruments can be selected for use in the Global Settings tab in the
test configuration pane.

See also

Options menu overview
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View connected instruments

Use the Instrument Control Settings dialog box to view or search for connected instruments required for the
tests. The application uses TekVISA to discover the connected instruments on all selected connection types.

NOTE. The correct instruments for the current test setup must be connected and recognized by
40GBase-CR4 before running tests.

To refresh the list of connected instruments:

1. From the Options menu, select Instrument Control Settings.

2. In the Search Criteria section of the Instrument Control Settings dialog box, select the connection
types of the instruments for which to search.

Instrument search is based on the VISA layer, but different connections determine the resource type,
such as LAN, GPIB, and USB. For example, if you choose LAN, the search will include all the
instruments supported by TekExpress that are communicating over the LAN.

3. Click Refresh. TekExpress searches for connected instruments.

4. After searching, the dialog box lists the instrument-related details based on the search criteria you
selected. For example, if you selected LAN and GPIB as the search criteria, the application checks
for the availability of instruments over LAN, then GPIB, and then lists detected instruments on those
connection types.
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The Retrieved Instruments table lists insrument details. The time and date of the last time this table was
updated is displayed in the Last Updated field.

See also

Equipment connection setup
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Email settings

Use the Email Settings utility to configure email notifications to receive notifications when a test completes,
produces an error, or fails. Select the type of test session information to include in the notification, such as
test reports and test logs, the email message format, and the email message size limit.

Select Options > Email Settings to open this dialog box.

NOTE. Recipient email address, sender’s address, and SMTP Server are mandatory fields.

See also

Configure email settings
Options menu
Select test notification preferences
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Configure email settings

Use the Email Settings dialog box to be notified by email when a test completes, fails, or produces an error:

1. Select Options > Email Settings to open the Email Settings dialog box.

2. (Required) For Recipient email Address(es), enter one or more email addresses to which to send the
test notification. To include multiple addresses, separate the addresses with commas.

3. (Required) For Sender’s Address, enter the email address used by the instrument. This address consists
of the instrument name followed by an underscore followed by the instrument serial number, then the
@ symbol and the email server used. For example: DPO72016C_B130099@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server address of the Mail server
configured at the client location, and the SMTP Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name, password, and host name
in the corresponding fields.

NOTE. If any of the above required fields are left blank, the settings will not be saved and email
notifications will not be sent.

5. In the Email Attachments section, select from the following options:

Reports: Select to receive the test report with the notification email.

Status Log: Select to receive the test status log with the notification email. If you select this
option, then also select whether you want to receive the full log or just the last 20 lines.

6. In the Email Configuration section:

Select the message file format to send: HTML (the default) or plain text.

Enter a maximum file size for the email message. Messages with attachments larger than this
limit will not be sent. The default is 5 MB.

Enter the number in the Number of Attempts to Send field, to limit the number of attempts that the
system makes to send a notification. The default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use this check box to quickly
enable or disable email notifications.

8. To test your email settings, click Test Email.

9. To apply your settings, click Apply.

10. Click Close when finished.
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Email settings
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Handle error codes

The return value of the remote automations at the server-end is OP_STATUS, which changes to a string
value depending on its code, and returned to the client. The values of OP_STATUS are as follows:

Code Value Description

-1 FAIL The operation failed

1 SUCCESS The operation succeeded

2 NOT FOUND Server not found

3 LOCKED The server is locked by another client, so the operation cannot be performed

4 UNLOCK The server is not locked; lock the server before performing the operation

0 NULL Nothing

xxx

NOTE. The Fail condition for PI commands occurs in any of the following cases:

The server is LOCKED and the message displayed is "Server is locked by another client".

The session is UNLOCKED and the message displayed is "Lock Session to execute the command".

The server is NOTFOUND and the message displayed is "Server not found...Disconnect!".

When none of these fail conditions occur, then the message displayed is "Failed...".
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Limits Editor: compare string definitions
The following table lists the definitions of the limit comparison strings:

Table 17: Limits Editor: comparison strings

Comparison string Description

EQ(==) Equal to

NE(!=) Not equal to

GT(>) Greater than

LT(<) Less than

GE(>=) Greater than or Equal to

LE(<=) Less than or Equal to

GTLT(> <) Greater than and Less than

GELE(>= <=) Greater than or equal to and Less than or equal to

GELT(>= <) Greater than or equal to and Less than

GTLE(> <=) Greater than and Less or equal to

LTGT(< >) Less than and Greater than

LEGE(<= >=) Less than or equal to and Greater than or equal to

LEGT(<= >) Less than or equal to and Greater than

LTGE(< >=) Less than and Greater than or equal to

xxx
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Error messages
Table 18: 40GBase-CR4 error messages

Error message Description

Waveform does not have valid test pattern.
Test pattern should have more than 8 symbols
of alternating polarity. Change the horizontal
settings to acquire longer duration of waveform.

Acquired signal contains less than eight symbols of alternating polarity.
Change the horizontal settings to acquire a longer-duration waveform.

s16p File does not contain data related to
S-Parameters. Assure that valid s16p file is
provided for the measurement.

The specified s16p file does not contain S-parameter related information.

Waveform does not have enough edges.
Acquire signal for longer duration and with
enough transitions.

Acquired signal contains less than or equal to 8 edges. Change the
horizontal settings to acquire a longer duration waveform.

Data dependent Jitter cannot be computed for
clock like signal. Feed a pseudo random signal
as input.

Clock like signal is fed as input to Total Jitter excluding DDJ
measurement. Configure the DUT to transmit CR4 signal with repeating
pseudo random pattern.

PRBS9 pattern not found in the signal. Transmit
the signal with correct pattern (PRBS9) and
try again.

Group4 measurements of TP2 require a PRBS9 signal. Configure the
DUT to transmit CR4 signal PRBS9 pattern.

Filter coefficients file does not exist. Execute
the measurement CR4 Compute Filter
Coefficients (W) and then execute the required
measurement.

This message comes from the CR4 DPOJET plug-in. All
setup files of Group 4 require measurement present in
"CR4_ComputeFilterCoefficients_TP2.set" as a prerequisite. This error
comes if prerequisite setup file is not recalled and executed.

Input waveform lengths are not the same.
Please check the signal again.

Single-ended waveforms (Data+ and Data-) fed as input to
measurements are not the same length. Acquire Data+ and Data-
waveforms with the same record length.

Repeating Patterns not found. DDJ cannot
be computed. Feed a signal with repeating
patterns.

Total jitter excluding DDJ requires signal with repeating patterns for
separating out DDJ. Configure the DUT to transmit the CR4 signal with
repeating pseudo random pattern.

Signal is not over-sampled. Acquire the Signal
with the sampling rate of 3.3 Tsamples/sec.

Group4 measurements of TP2 require PRBS9 signal to be oversampled
(3.3 TS/sec). Configure the sampling rate in horizontal settings
appropriately.

xxx
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DPOJET: Test point TP2 measurements and
setup files

This table lists the supported DPOJET 40GBase-CR4-related TP2 transmitter measurements, grouped by
setup files.

Table 19: DPOJET: Test point TP2 measurements and setup files

Measurement Description Setup file name

72.7.1.4 Amplitude peak to peak CR4_AmplitudePk2Pk CR4_1010_TP2.set

72.7.1.9 Duty Cycle Distortion CR4_DCD CR4_1010_TP2.set

Random Jitter CR4_RJ-DIRAC

J2 - Informative CR4_J2_

J9 - Informative CR4_J9_

85.8.3.9 Signaling Rate CR4_SigRate

83A.5.1 Total Jitter excluding DDJ CR4_TJExclDDJ

CR4_PRBS9_TP2.set

72.7.1.4 Common mode voltage limits CR4_DC_CommonMode

72.7.1.4 Common mode AC output
voltage

CR4_AC_CommonMode

CR4_CommonMode_TP2.set

Diff pk-pk output voltage Tx disabled CR4_DiffPk2PkTxDisable CR4_TX_Disabled_TP2.set

85.8.3.1 Differential Output Return Loss CR4_DiffRLTP2 CR4_Diff_ReturnLoss_TP2.set

72.7.1.7 Transition Time (20% - 80%) CR4_FallTime
CR4_RiseTime

CR4_8180_TP2.set

85.8.3.3 Linear Fit Pulse 1 CR4_Linear_Fit_Pulse

85.8.3.3 RMS Normalized Error 1 CR4_RMS_Error

85.8.3.3 Transmitter DC Amplitude 1 CR4_DC_Amplitude

CR4_PRESET_Measurements_TP2.set

85.8.3.3.3 Minimum Pre-cursor full scale
range 1

CR4_PreCursor CR4_PreCursor_TP2.set

85.8.3.3.3 Minimum Post-cursor full scale
range 1

CR4_PostCursor CR4_PostCursor_TP2.set

85.8.3.3.1 Coefficient Initialization
Ratio1 1

CR4_Initialization_Ratio1_

85.8.3.3.1 Coefficient Initialization
Ratio2 1

CR4_Initialization_Ratio2_

CR4_InitializationRatio_TP2.set

85.8.3.3.2 Absolute coefficient step size 1 CR4_C_Minus_1
CR4_C_Zero
CR4_C_Plus_1

CR4_InitializationRatio_TP2.set

xxx

1 Group4 measurements
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DPOJET: Test point TP0 measurements and
setup files

This table lists the supported DPOJET 40GBase-CR4-related TP0 transmitter measurements, grouped by
setup files.

Table 20: DPOJET: Test point TP0 measurements and setup files

Measurement Description Setup file name

72.7.1.9 Duty Cycle Distortion CR4_DCD CR4_1010_TP0.set

72.7.1.7 Transition Time (20% - 80%) CR4_FallTime
CR4_RiseTime

CR4_8180_TP0.set

85.8.3.9 Signaling Rate CR4_SigRate

72.7.1.9 Random Jitter CR4_RJ-DIRAC

72.7.1.9 Total Jitter CR4_TJ@BER

72.7.1.9 Deterministic Jitter CR4_DJ

CR4_PRBS9_TP0.set

72.7.1.4 Common mode voltage limits CR4_DC_CommonMode

72.7.1.4 Common mode AC output
voltage

CR4_AC_CommonMode

CR4_CommonMode_TP0.set

72.7.1.5 Differential Output Return Loss CR4_DiffRL_TP0

72.7.1.6 Common Mode Output Return
Loss

CR4_CMRLTP0

CR4_Diff_CM_ReturnLoss_TP0.set

xxx
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DPOJET: Oscilloscope horizontal settings

The DPOJET setup files have following oscilloscope horizontal settings:

Table 21: DPOJET: Oscilloscope horizontal settings

Setup file name Sampling rate Record length Sampling mode

CR4_PRESET_Measurements_TP2.set 3.3 TS/sec 10M IT

CR4_PreCursor_TP2.set 3.3 TS/sec 10M IT

CR4_PostCursor_TP2.set 3.3 TS/sec 10M IT

CR4_InitializationRatio_TP2.set 3.3 TS/sec 10M IT

CR4_Abs_Coeff_Step_Size_TP2.set 3.3 TS/sec 10M IT

All other setup files 100 GS/sec 10M RT

xxx
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DPOJET: Oscilloscope trigger settings

Setup files provided as part of 40GBase-CR4 method of implementation (MOI) have following
oscilloscope trigger settings:

Table 22:

Trigger parameter Value

Trigger Source Ch1

Trigger Type Edge

Set to 50% TRUE

Coupling DC

Slope Positive

xxx
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DPOJET: Oscilloscope vertical settings

Since 40GBase-CR4 test application requires sampling rate of 100 GS/sec or more, sources for
measurements shall be either Channel-1 and Channel-3 or Channel-2 and Channel-4. Vertical settings
(scale, position and offset) are arrived by running the vertical autoset function in DPOJET. To perform
DPOJET vertical autoset:

1. Load setup files.

2. Click Configure to view the measurements and sources information.

3. Double-click on a measurement to open a source Configuration window.

4. Click Vert Scale to perform a vertical auto set. The application computes and sets vertical settings for
channels and MATH (if used).

As part of vertical settings, bandwidth is limited to 16 GHz on all oscilloscopes. Digital Filters (DSP
enabled) feature is used for this.

Once vertical settings are done, go to the Trigger menu and click Set to 50%.

For group 4 measurements: Once vertical settings are done, make sure that horizontal settings are set
as follows:
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Mode = manual

Sample mode = IT

Sampling rate =3.3 TS/sec

Record length = 10M
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DPOJET: Accessing 40GBase-
CR4 measurements

1. Select Analyze > 40GBase-CR4 in the TekScope main menu bar to open the 40GBase-CR4 DPOJET
application. This window lists all measurements supported as part of 40GBase-CR4 method of
implementation.

NOTE. Do not select “TekExpress 40GBase-CR4” in the Analyze menu; doing so starts the
TekExpress-based application.

2. To load setup files, click Setup button and navigate to the setup file folder and select the required setup
file(s). Setup files are located in “C:\Users\Public\Tektronix\TekApplications\40GBase-CR4\Setups”.
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DPOJET: Inputs to measurements

You can use the setup files provided as part of 40GBase-CR4 option and execute the measurements.
Another way of running measurements is user can select measurements, provide his/her own scope
settings, acquire the waveform, and provide proper sources for measurements.

Inputs to measurements are:

Two single ended signals (data positive and data negative) – CH1 and CH3 for TP2 measurements.

MATH1 and MATH2 for TP0 measurements (TP0 requires a de-embedding filter).

MATH1 = (Ch1 – Ch3) for TP2 DPOJET measurements.

MATH3 = (MATH1 – MATH2) for TP0 DPOJET measurements.
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DPOJET: 40GBase-CR4 transmitter
measurement procedure

The following parameters are considered while grouping 40GBase-CR4 transmitter measurements:

Test point: TP2 and TP0 (for TP0, de-embedding option from TP2 to TP0 is provided)

Supported compliance pattern (PRBS9, 1010, or 8180)

Connection setup (common mode without DC blocks)

DUT configuration (transmitter disabled, state of DUT TX equalizer coefficients)

See DPOJET Test point TP2 measurements and setup files and DPOJET Test point TP0 measurements and
setup files for a list of all measurements grouped by setup file namess.

NOTE. To get custom plots as part of a DPOJET report, ADK requires at least one DPOJET measurement
in the setup file with its corresponding plot selected. Setup files contain a “Dummy” measurement (base
DPOJET measurement) with its corresponding plot (Time Trend).

Test procedure

This test procedure is for:

TP2 setup files: CR4_1010_TP2.set, CR4_PRBS9_TP2.set, CR4_8180_TP2.set
CR4_CommonMode_TP2.set, CR4_TX_Disabled_TP2.set

TP0 setup files: CR4_1010_TP0.set, CR4_PRBS9_TP0.set, CR4_8180_TP0.set,
CR4_CommonMode_TP0.set

1. Connect the DUT to the oscilloscope (click the Schematic button in the TekExpress 40GBase-CR4
application).

2. In the TekScope application, select Analyze > 40GBase-CR4.

3. Recall the setup file by clicking on Setup button which is next to the test point.

4. See DPOJET Oscilloscope horizontal settings and DPOJET Oscilloscope trigger settings for
oscilloscope settings for this measurement.

5. Perform vertical autoset. See DPOJET: Oscilloscope vertical settings.

6. Click Single button to acquire required waveforms and run the measurement. If required adjust the
trigger level by clicking on “set to 50%” button in trigger control window. Once the measurement is
completed, results are displayed in result panel.

Measurements related to TP0 require the de-embedding filter from TP2 to TP0. As part of the package
a dummy filter (TP2_to_TP0_De_embed.flt) is present at “C:\users\Public\Tektronix\TekApplica-
tions\40GBase-CR4\Filters”
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While testing with the device, make sure that the appropriate filter file (device specific) is placed at
above mentioned location with the same name. The de-embedding filtering is applied on CH1 signal and
CH3 signal. MATH1 and MATH2 will contain the filtered signal.

1: CR4_1010_TP0.set

2: CR4_1010_TP2.set

Duty Cycle Distortion get listed as part of CR4_1010_TP0.set

NOTE. Make sure that DUT is configured to transmit CR4 signal with 1010 pattern

Measurement Plots Observable results

Duty Cycle Distortion 1- Histogram of positive pulses

2- Histogram of negative pulses

Maximum DCD shall be less than
35 mUI

xxx

Amplitude peak to peak and Duty Cycle Distortion get listed as part of CR4_1010_TP2.set.

NOTE. Make sure that DUT is configured to transmit a CR4 signal with 1010 pattern.

Measurement Plots Observable results

Amplitude Peak to Peak Histogram of Differential Signal Maximum amplitude peak to peak shall
be less than 1.2 V

Duty Cycle Distortion 1. Histogram of positive pulses

2. Histogram of negative pulses

Maximum DCD shall be less than
35 mUI

xxx

3: CR4_8180_TP0.set

4: CR4_8180_TP2.set

Rise time and fall time get listed as part of this setup file.

NOTE. Make sure that DUT is configured to transmit a CR4 signal with 8180 pattern.

Measurement Plots Observable results

Rise Time Rising edge with 20% and 80% point
marked on the edge

Mean rise time shall be between 24 pS
and 47 pS

Fall Time Falling edge with 20% and 80% point
marked on the edge

Mean fall time shall be between 24 pS
and 47 pS

xxx

Rise time and fall time are informative measurements for TP2. So results are not compared with limits.
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5: CR4_CommonMode_TP0.set

6: CR4_CommonMode_TP2.set

AC Common mode voltage and Common mode voltage limits (DC common mode) get listed as part
of this setup file.

NOTE. Make sure that DUT is configured to transmit a CR4 signal with any pattern.

Measurement Plots Observable results

AC Common mode voltage Vertical histogram of common mode
signal

Maximum AC common mode voltage
shall be less than 30 mV

Common mode voltage Limits
(DC)

Vertical histogram of common mode
signal

Maximum DC common mode voltage
shall be less than 30 mV

xxx

7: CR4_PRBS9_TP0.set

8: CR4_PRBS9_TP2.set

Signaling rate, deterministic jitter, J9, J2, random jitter and TJ@BER are listed as part of
CR4_PRBS9_TP0.set.

NOTE. Make sure that DUT is configured to transmit a CR4 signal with PRBS9 pattern.

Measurement Plots Observable results

Signaling Rate No Plots Mean of signaling rate shall be between
10.311 Gbps and 10.314 Gbps

Deterministic Jitter No Plots Maximum value of deterministic jitter
shall be less than 14.54 pS (0.15 UI)

Random Jitter Composite Jitter Histogram Random jitter dual dirac gives RMS
random jitter. RMS random jitter shall
be manually converted to peak to peak
random jitter and compared with higher
limit of 14.54 ps (0.15UI)

Peak to peak Random Jitter = RMS
Random Jitter * α, where α is a function
of BER.

TJ@BER Bath tub curve Maximum value of TJ@BER shall be
less than 27.152 pS (0.28 UI)

xxx

Signaling rate, J2, J9, random jitter and total jitter excluding DDJ are listed as part of CR4_PRBS9_TP2.set.
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Measurement Plots Observable results

Signaling Rate No Plots Mean of signaling rate shall be between
10.311 Gbps and 10.314 Gbps

J9 No Plots Informative measurement

J2 No Plots Informative measurement

Random Jitter Composite Jitter Histogram Random jitter dual dirac gives RMS
random jitter. RMS random jitter shall
be manually converted to peak to peak
random jitter and compared with higher
limit of 14.54 ps (0.15UI)

Peak to peak Random Jitter = RMS
Random Jitter * α, where α is a function
of BER.

Total Jitter excluding DDJ Bath tub curve Maximum value of total jitter excluding
DDJ shall be less than 24.242 pS (0.25
UI)

xxx

9: CR4_TX_Disabled_TP2.set

Differential peak to peak output voltage with transmitter disabled gets listed as part of this setup file.

NOTE. Make sure that transmitter of device under test is disabled for this measurement.

Measurement Plots Observable results

Differential peak to peak voltage
with transmitter disabled

Vertical histogram of differential signal Peak to peak voltage shall be less than
30 mV

xxx

10: CR4_Diff_CM_ReturnLoss_TP0.set

Differential return loss and common mode return loss measurements at TP0 get listed as part of this
setup file.

Measurements listed as part of this setup file require s16p file (contains information for all 4 lanes) as
input. s16p files are at “C:\users\Public\Tektronix\TekApplications\40GBase-CR4\Inputs\”:

InputSParam_TP0_DiffRL.s16p: For Differential return loss measurement at TP0

InputSParam_TP0_CMRL.s16p: For Common mode return loss measurement at TP0

While testing with the device, make sure that appropriate s16p files (device specific) are at the above
mentioned location with same name. Differential return loss and common mode return loss get listed as
part of this setup file.

Test Procedure:
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1. Select Analyze > 40GBase-CR4 from the TekScope menu.

2. Load the setup fileCR4_Diff_CM_ReturnLoss _TP0.set.

3. Click Single button to run the measurement.

Measurement Plots Observable results

Differential Return Loss Plot containing differential return loss in
dB versus frequency for all 4 lanes along
with limit mask

Maximum value of differential return
loss measurement shall be equal to
zero

Common mode return loss Plot containing common mode return
loss in dB versus frequency for all 4
lanes along with limit mask

Maximum value of common mode
return loss measurement shall be equal
to zero

xxx

If computed differential return loss curves do not cross the limit curve/mask, the maximum value of the
measurement will be zero. If computed return loss curves cross the limit curve/mask, the maximum
value of the measurement will be one.

11: CR4_Diff_ReturnLoss_TP0.set

Differential return loss measurement at TP2 gets listed as part of this setup file.

Measurements listed as part of this setup file require s16p file (contains information for all 4 lanes) as
input. s16p files are at C:\users\Public\Tektronix\TekApplications\40GBase-CR4\Inputs\:

InputSParam_TP2_DiffRL.s16p: For Differential return loss measurement at TP2

While testing with the device, user has to make sure that appropriate s16p files(device specific) are placed
at above mentioned location with same name. Differential return loss and common mode return loss get
listed as part of this setup file.

Test Procedure:

1. Select Analyze > 40GBase-CR4 from the TekScope menu.

2. Load the setup fileCR4_Diff_ReturnLoss _TP2.set.

3. Click Single button to run the measurement.

Measurement Plots Observable results

Differential Return Loss Plot containing differential return loss in
dB versus frequency for all 4 lanes along
with limit mask

Maximum value of differential return
loss measurement shall be equal to
zero

xxx

12: CR4_ComputeFilterCoefficients_TP2.set

CR4_ComputeFilterCoefficients measurement at TP2 gets listed as part of this setup file.
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NOTE. This measurement is a pre-requisite for all Group4 measurements. This setup file needs to be
loaded and the measurement executed before executing any Group4 measurements.

NOTE. Make sure that DUT is configured to transmit CR4 signal with PRBS9 pattern.

This measurement computes filter coefficients “w” using the acquired waveform when DUT transmit
equalizer coefficients are in PRESET state.

Signal transmitted from DUT shall be acquired with oversampling factor of 320, i.e sampling rate of
3.3 TS/sec (10.3125e9 * 320 ≈ 3.3e12).

Test Procedure:

1. Connect the DUT (Click the Schematic button in the TekExpress 40GBase-CR4 application).

2. Select Analyze > 40GBase-CR4 from the TekScope menu.

3. Load the setup file CR4_ComputeFilterCoefficients_TP2.set (click on Setup button which is next
to the test).

4. See DPOJET Oscilloscope horizontal settings and DPOJET Oscilloscope trigger settings for
oscilloscope settings for this measurement.

5. Perform vertical autoset. See DPOJET: Oscilloscope vertical settings.

6. Click Single button to acquire waveforms and run the measurement. If required adjust the trigger level
by clicking on “set to 50%” button in trigger control window. Once the measurement is completed,
results are displayed in result panel.

Measurement Plots Observable results

Compute Filter Coefficients Plot of linear fit pulse with t0 and tX
marked

There are no observable results and
there are no pass/fail criteria. At the
end of this measurement the filter
coefficients “w” are computed using
waveform captured when the DUT’s
transmit equalizer is set to PRESET
state.

xxx

Filter coefficients are saved in a file “TxOutWfmFilterCoefficients.csv” at the location
C:\Users\Public\Tektronix\TekApplications\40GBase-CR4\IntermediateResults.

13: CR4_PRESET_Measurements_TP2.set

14: CR4_PreCursor_TP2.set

15: CR4_PostCursor_TP2.set

16: CR4_InitializationRatio_TP2.set
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The prerequisite measurement that is part of “CR4_ComputeFilterCoefficients_TP2.set” needs to be
executed before recalling any of above listed setup files and executing measurements.

NOTE. Make sure that DUT is configured to transmit CR4 signal with PRBS9 pattern.

Make sure that DUT transmit equalizer coefficients are configured as listed in following table:

Setup file State of DUT's transmit equalizer coefficients

CR4_PRESET_Measurements_TP2.set All coefficients in PRESET state

CR4_PreCursor_TP2.set C(-1) set to zero, C(0) and C(1) set to minimum

CR4_PostCursor_TP2.set C(1) set to zero, C(0) and C(1) set to minimum

CR4_InitializationRatio_TP2.set All coefficients in INITIALIZE state

xxx

Signal transmitted from DUT shall be acquired with oversampling factor of 320, i.e. sampling rate of
3.3 TS/sec (10.3125e9 * 320 ≈ 3.3e12).

Test Procedure:

1. Connect the DUT (click the Schematic button in the TekExpress 40GBase-CR4 application).

2. Select Analyze > 40GBase-CR4 from the TekScope menu to open the DPOJET application.

3. Recall the setup file by clicking on “Setup” button which is next to the test point. Measurements listed
require single ended waveforms (Data+ and Data-) as inputs.

4. See DPOJET Oscilloscope horizontal settings and DPOJET Oscilloscope trigger settings for
oscilloscope settings for this measurement.

5. Perform vertical autoset. See DPOJET: Oscilloscope vertical settings.

6. Click Single button to acquire required waveforms and run the measurement. If required, adjust the
trigger level by clicking on “set to 50%” button in trigger control window. Once the measurement is
completed, results are displayed in result panel.

CR4_PRESET_Measurements_TP2.set

Measurement Plots Observable results

Linear Fit Pulse No Plots Maximum value of linear fit pulse shall
be less than 0.63 x Transmitter DC
Amplitude 1

RMS normalized error No Plots RMS normalized error shall be less
than 0.037

Transmitter DC Amplitude No Plots Transmitter DC amplitude shall be
between 0.34V and 0.6V

xxx

1 Maximum value of linear fit pulse shall be manually compared with 63% of Transmitter DC amplitude result.

CR4_PreCursor_TP2.set
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Measurement Plots Observable results

Minimum pre cursor full scale
range

No Plots Pre-cursor value shall be less than 1.54

xxx

CR4_PostCursor_TP2.set

Measurement Plots Observable results

Minimum post cursor full scale
range

No Plots Post-cursor value shall be less than 4

xxx

CR4_InitializationRatio_TP2.set

Measurement Plots Observable results

Initialization Ratio 1 No Plots Initialization ratio1 shall be between
2.313 and 2.827 (2.57 ±10%)

Initialization Ratio 2 No Plots Initialization ratio2 shall be between
1.161 and 1.419 (1.29 ±10%)

xxx

17: CR4_Abs_Coeff_Step_Size_TP2.set

The prerequisite measurement present as part of “CR4_ComputeFilterCoefficients_TP2.set” needs to be
executed before recalling any of above listed setup files and executing measurements.

NOTE. Make sure that DUT is configured to transmit CR4 signal with PRBS9 pattern.

Signal transmitted from DUT shall be acquired with oversampling factor of 320, i.e sampling rate of
3.3 TS/sec (10.3125e9 * 320 ≈ 3.3e12). Absolute coefficient step size has to be verified for all c(i), i =
-1, 0 and 1

Test Procedure

1. Connect the DUT (click Schematic in the TekExpress 40GBase-CR4 application to view a conection
diagram for the selected test).

2. Configure the DUT’s transmit equalizer coefficients to INITIALIZE state

3. Select Analyze > 40GBase-CR4 from the TekScope menu to open the DPOJET plug-in.

4. Recall (load) the setup file by clicking on “Setup” button which is next to the test point. Measurements
listed require single ended waveforms (Data+ and Data-) as inputs

5. See DPOJET Oscilloscope horizontal settings and DPOJET Oscilloscope trigger settings for
oscilloscope settings for this measurement.
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Reference DPOJET: 40GBase-CR4 transmitter measurement procedure

6. Perform vertical autoset. See DPOJET: Oscilloscope vertical settings.

7. Click Single button to acquire required waveforms and run the measurement. If necessary, adjust the
trigger level by clicking on “set to 50%” button in the trigger control window. Once the measurement
is completed, results are displayed in result panel.

8. Record the result of CR4_C_Minus_1 measurement as C(-1)_INITIALIZE

9. Configure the DUT’s transmit equalizer coefficients:

C(-1) to INCREMENT

C(0) and C(1) to HOLD

10. Repeat steps (3) to (7).

11. Record the result of CR4_C_Minus_1 measurement as C(-1)_INCREMENT.

12. Configure the DUT’s transmit equalizer coefficients:

C(-1) to DECREMENT

C(0) and C(1) to HOLD

13. Repeat steps (3) to (7).

14. Record the result of CR4_C_Minus_1 measurement as C(-1)_DECREMENT.

15. Calculate the change in normalized amplitude of coefficient c(-1) corresponding to increment request
as follows:

∆c= C(-1)_INCREMENT – C(-1)_INITIALIZE

∆c must be between -0.05 and -0.0083.

16. Calculate the change in normalized amplitude of coefficient c(i) corresponding to decrement request
as follows:

∆c = C(-1)_DECREMENT – C(-1)_INCREMENT

∆c must be between 0.05 and 0.0083.

17. Repeat steps 1 through 16 for C(0) and C(1).
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Reference Measurements and supported patterns

Measurements and supported patterns
Measurement Supported pattern (Compliance or User defined mode)

Differential peak to peak output voltage with Tx
disabled - TP0 and TP2

Any pattern

72.7.1.4 Amplitude peak to peak - TP2

72.7.1.9 Duty Cycle Distortion - TP0 and TP2

Compliance: 1010

User defined: PRBS7, PRBS9, PRBS11, PRBS15, PRBS20,
PRBS23, PRBS31

85.8.3.9 Signaling Rate - TP0 and TP2

Random Jitter - TP0 and TP2

83A.5.1 Total Jitter excluding DDJ (UTJ) - TP2

J2 (Informative)

J9 (Informative)

Total Jitter - TP0

Deterministic Jitter - TP0

Compliance: PRBS9

User defined: PRBS7, PRBS11, PRBS15, PRBS20, PRBS23,
PRBS31

Transition Time (20% - 80%) - TP0 and TP2 Compliance: 8180

User defined: N1N0 (4 <= N <= 12)

85.8.3.3 Transmitter Output Waveform Requirements
- TP2

Compliance and User defined: PRBS9

72.7.1.4 Common mode voltage limits - TP0 and TP2

72.7.1.4 Common mode AC output voltage - TP0
and TP2

Any Pattern

85.8.3.1 Differential Output Return Loss - TP2

72.7.1.5 Differential Output Return Loss - TP0

72.7.1.6 Common mode Return Loss - TP0

Not applicable

xxx

Signal validation and patterns

The following signal validity checks are done for signals containing 1010 or N1N0 patterns:

Deviation of instantaneous edge to edge period from mean value is within 10%

Deviation of instantaneous rise to rise and fall to fall period from mean value is within 10%

The following signal validity check is done for signals containing PRBS7, PRBS9, PRBS11 and PRBS15
patterns:

PRBS pattern search is done on the bit pattern present in the signal
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Reference Differential peak to peak output voltage (max) with Tx disabled: TP2 and TP0

Differential peak to peak output voltage (max)
with Tx disabled: TP2 and TP0

Reference to specification

Not applicable.

Measurement algorithm

1. Compute the maximum and minimum of a differential waveform.

2. Compute the peak to peak output voltage of the differential waveform peak to peak voltage =
(Maximum value – Minimum value)

Limits

Peak to peak voltage shall be less than 30 mV.

Plots

Vertical histogram of acquired differential signal when DUT transmitter is disabled.
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Reference Amplitude peak to peak: TP2

Amplitude peak to peak: TP2

Reference to specification

IEEE 802.3-2012, Table 85-5, section 72.7.1.4.

Measurement algorithm

1. Check whether pattern in input signal is “1010” pattern (clock waveform) or a PRBSn pattern.

2. If the pattern is “1010” pattern (clock waveform), then find the maximum and minimum over entire
waveform and compute the peak to peak voltage as (maximum voltage – minimum voltage).

Limits

Peak to peak voltage shall be less than 1200 mV.

Plots

Vertical histogram of acquired differential signal.
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Reference Duty Cycle Distortion: TP0 and TP2

Duty Cycle Distortion: TP0 and TP2

Reference to specification

IEEE 802.3-2012, Table 85-5, section 72.7.1.9.

Measurement algorithm

1. Check whether pattern in input signal is “1010” pattern (clock waveform) or a PRBS pattern.

2. Estimate the nominal pulse width/unit interval of the acquired waveform.

3. If the pattern is “1010” pattern (clock waveform), then find the mean pulse width of a ‘1’ pulse over
the entire waveform and mean pulse width of a ‘0’ pulse over the entire waveform.

4. Find out the absolute value of the difference in the mean pulse width of a 1 pulse and the mean pulse
width of a 0 pulse (from 1010 or 0101 patterns) from the nominal pulse width (estimated UI). This
given DCD of the acquired waveform. Find the peak to peak value of the DCD

Limits

Peak to peak value of the DCD shall be less than 0.035 UI.

Plots

Histogram of positive pulses

Histogram of negative pulses
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Reference Signaling Rate: TP2 and TP0

Signaling Rate: TP2 and TP0

Reference to specification

IEEE 802.3-2012, Table 85-5, section 85.8.3.9.

Measurement algorithm

1. Determine the location of edges in the differential waveform.

2. Create a histogram with bins being 1.5+(n-1) where n = minimum consecutive bits of same
polarity(minimum pulse width) to maximum consecutive bits of same polarity (maximum pulse width).

3. Use the histogram to compute the estimated UI.

4. Use estimated UI to determine bits (1/0) in the given input waveform.

5. With bits, edge time and estimated UI as inputs, do linear regression (bits as X, edge time as Y) and
determine slope and intercept. Slope will give final Unit Interval and Intercept will give the delay
between start of acquisition and first edge time. Signaling rate = (1/unit Interval)

Limits

Signaling rate shall be between 10.31146775 Gbps and 19.31353125 Gbps

Plots

None.
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Reference Random Jitter: TP0 and TP2

Random Jitter: TP0 and TP2

Reference to specification

IEEE 802.3-2012, Table 85-5

Measurement algorithm

1. Uses DPOJET measurement RJ-δδ.

2. Differential waveform is given as input to this measurement.

3. Parameters of RJ/DJ separation need to be set based on selected pattern type pattern:

PRBS7: Pattern Type: Repeating, Pattern Length = 127.

PRBS9: Pattern Type: Repeating, Pattern Length = 511.

PRBS11: Pattern Type: Repeating, Pattern Length = 2047.

PRBS15, PRBS20, PRBS23 and PRBS31: Pattern Type: Arbitrary, Window Length = 10 UI.

4. Clock Recovery: Constant Clock Mean, Nominal Data Rate in manual mode: 10.3125 Gbps.

5. Filters: HPF, 1st Order, Cut off frequency 4 MHz.

6. RJ(P-P) is computed as follows:

7. RJ(P-P) = α * RJ(RMS), α = f(BER), where

BER α

1.00E-10 12.723

1.00E-11 13.412

1.00E-12 14.069

1.00E-13 14.698

1.00E-14 15.301

xxx

Limits

Peak to peak random jitter shall be less than 0.15 UI.

Plots

Composite jitter histogram

146 TekExpress 40GBase-CR4 Printable Help



Reference Total Jitter excluding DDJ (UTJ): TP2

Total Jitter excluding DDJ (UTJ): TP2

Reference to specification

IEEE 802.3-2012, Table 85-5, section 83A.5.1

Measurement algorithm

1. Recover the clock from the input data signal using CDR method – Constant Clock Mean

2. Use recovered clock to compute the TIE.

3. TIE(i) = edgeLocation(i) – ideal_edgeLocation(i). TIE is filtered using a first order HPF with a cut off
frequency of 4 MHz.

4. Using recovered clock, get the bit stream from data signal. Find the repeating patterns present in
bit stream. Using repeating pattern location and repeating pattern length, determine the correlated
jitter from the filtered TIE.

5. From TIE, remove the correlated jitter. Find the absolute maximvalue of the remaining TIE. Use this
absolute value to create histogram plot with 300 bins. Create PDFs and combine PDFs of all edges.

6. Convert the PDF into Q scale. Draw the Gaussian line(Gaussian fit) at the required BER and compute
the vertical opening on left and right side of Q-scale curve. UTJ = Vertical left opening – Vertical
Right Opening.

Limits

Total jitter excluding DDJ shall be less than 0.25 UI.

Plots

Bath tub curve with tail extrapolated as straight line.
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Reference J2 (Informative): TP2

J2 (Informative): TP2

Reference to specification

Not applicable.

Measurement algorithm

1. Uses DPOJET measurement for J2.

2. Differential waveform is fed as input to this measurement.

3. Parameters of RJ/DJ separation need to be set based on selected pattern type:

PRBS7: Pattern Type: Repeating, Pattern Length = 127

PRBS9: Pattern Type: Repeating, Pattern Length = 511

PRBS11: Pattern Type: Repeating, Pattern Length = 2047

PRBS15, PRBS20, PRBS23 and PRBS31: Pattern Type: Arbitrary, Window Length = 10 UI.

4. Clock Recovery: Constant Clock Mean, Nominal Data Rate in manual mode: 10.3125 Gbps.

5. Filters: HPF, 1st Order, Cut off frequency: 4 MHz

Limits

Not applicable

Plots

Bath tub curve
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Reference J9 (Informative): TP2

J9 (Informative): TP2

Reference to specification

Not applicable

Measurement algorithm

1. DPOJET measurement J9 is used.

2. Differential waveform is fed as input to this measurement.

3. Parameters of RJ/DJ separation need to be set based on selected pattern type:

PRBS7: Pattern Type: Repeating, Pattern Length = 127

PRBS9: Pattern Type: Repeating, Pattern Length = 511

PRBS11: Pattern Type: Repeating, Pattern Length = 2047

PRBS15, PRBS20, PRBS23 and PRBS31: Pattern Type: Arbitrary, Window Length = 10UI

4. Clock Recovery: Constant Clock Mean, Nominal Data Rate in manual mode: 10.3125 Gbps.

5. Filters: HPF, 1st Order, Cut off frequency: 4 MHz

Limits

Not applicable

Plots

Bath tub curve
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Reference Common mode voltage limits: TP0 and TP2

Common mode voltage limits: TP0 and TP2

Reference to specification

IEEE 802.3-2012, Table 85-5, section 72.7.1.4.

Measurement algorithm

1. Compute the common mode waveform ((data positive waveform + data negative waveform)/2).

2. Compute the mean value of the common mode signal. CM voltage = Mean(common mode signal).

Limits

Common mode voltage shall be less than 1.9 V.

Plots

Vertical histogram of common mode signal
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Reference Common mode AC output voltage: TP0 and TP2

Common mode AC output voltage: TP0 and
TP2

Reference to specification

IEEE 802.3-2012, Table 85-5, section 72.7.1.4

Measurement algorithm

1. Compute the common mode waveform ((data positive waveform + data negative waveform)/2).

2. Compute the mean of the common mode signal

3. Compute the AC RMS of the common mode signal:

AC RMS CM voltage = SQRT(Mean((CM_signal(i) – Mean_CM_Voltage)^2))

where i = 0 to (RL-1), RL = Record Length.

Limits

Common mode AC output voltage shall be less than 30 mV.

Plots

Vertical histogram of common mode signal
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Reference Differential Output Return Loss: TP0 and TP2

Differential Output Return Loss: TP0 and TP2

Reference to specification

TP2: IEEE 802.3-2012, Table 85-5, section 85.8.3.1.

TP0: IEEE 802.3-2012, Table 85A-1, section 72.7.1.5

Measurement algorithm

1. S16P file will be provided by user as input to this measurement.

2. S16P file is expected to be TOUCHSTONE format with each S-parameter given as real and imaginary
values. S-parameters will be given for different frequencies.

3. Given S-parameter file will be parsed.

4. For each given frequency, the S-parameter complex values are computed (using given real and
imaginary values).

5. Using S-parameter values, mixed mode S-parameters are computed.

6. Return loss is computed as 20*log10(abs(Sdd)), for the band of interest from 50 MHz to 10 GHz.

Limits

TP2: Differential Return loss over frequency band of interest (50 MHz to 10 GHz) shall be less than:

12 – 2 * √f dB for frequency range 0.05 GHz ≤ f < 4.11 GHz
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Reference Differential Output Return Loss: TP0 and TP2

6.3 – 13 * log10(f/5.5) dB for frequency range 4.11 GHz ≤ f < 10 GHz

TP0: Differential Return loss over frequency band of interest (50 MHz to 7500 MHz) shall be less than:

9 dB for frequency range 50 MHz ≤ f < 2500 MHz

9 – 12 * log10(f/2500 MHz) dB for frequency range 2500 MHz ≤ f < 7500 MHz

Plots

Plot of differential return loss versus frequency (for all 4 lanes) with limits shown as a mask
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Reference Common Mode Output Return Loss: TP0

Common Mode Output Return Loss: TP0

Reference to specification

IEEE 802.3-2012, Table 85A-1, section 72.7.1.6.

Measurement algorithm

1. S16P file will be provided by user as input to this measurement.

2. S16P file is expected to be TOUCHSTONE format with each S-parameter given as real and imaginary
values. S-parameters will be given for different frequencies.

3. Given S-parameter file will be parsed.

4. For each given frequency, the S-parameter complex values are computed (using given real and
imaginary values).

5. Using S-parameter values, mixed mode S-parameters are computed.

6. Return loss is computed as 20*log10(abs(Scc)), for the band of interest from 50 MHz to 10 GHz.

Limits

Common Mode Return loss over frequency band of interest (50 MHz to 7500 MHz) shall be less than:

6 dB for frequency range 50 MHz ≤ f < 2500 MHz

6 – 12 * log10(f/2500 MHz) dB for frequency range 2500 MHz ≤ f < 7500 MHz
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Reference Common Mode Output Return Loss: TP0

Plots

Plot of differential return loss versus frequency (for all 4 lanes) with limits shown as a mask
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Reference Total Jitter: TP0

Total Jitter: TP0

Reference to specification

IEEE 802.3-2012, Table 85A-1, section 72.7.1.9.

Measurement algorithm

1. DPOJET measurement TJ@BER is used.

2. Differential waveform is given as input to this measurement.

3. Computes total jitter at BER specified by user in GUI(default is 1e-12).

4. Parameters of RJ/DJ separation need to be set based on selected pattern type:

PRBS7: Pattern Type: Repeating, Pattern Length = 127

PRBS9: Pattern Type: Repeating, Pattern Length = 511

PRBS11: Pattern Type: Repeating, Pattern Length = 2047

PRBS15, PRBS20, PRBS23 and PRBS31: Pattern Type: Arbitrary, Window Length = 10UI

5. Clock Recovery: Constant Clock Mean, Nominal Data Rate in manual mode: 10.3125Gbps.

6. Filters: HPF, 1st Order, Cut off frequency: 4 MHz

Limits

Total jitter at BER of 1E-12 shall be less than 0.28 UI.

Plots

Bath tub plot

Histogram plot
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Reference Deterministic Jitter: TP0

Deterministic Jitter: TP0

Reference to specification

IEEE 802.3-2012, Table 85A-1, section 72.7.1.9

Measurement algorithm

1. DPOJET measurement DJ is used.

2. Differential waveform is given as input to this measurement.

3. Parameters of RJ/DJ separation need to be set based on selected pattern type:

PRBS7: Pattern Type: Repeating, Pattern Length = 127

PRBS9: Pattern Type: Repeating, Pattern Length = 511

PRBS11: Pattern Type: Repeating, Pattern Length = 2047

PRBS15, PRBS20, PRBS23 and PRBS31: Pattern Type: Arbitrary, Window Length = 10 UI

4. Clock Recovery: Constant Clock Mean, Nominal Data Rate in manual mode: 10.3125 Gbps

5. Filters: HPF, 1st Order, Cut off frequency: 4 MHz.

Limits

Deterministic jitter shall be less than 0.15 UI.

Plots

None.
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Reference Transmitter Output Waveform Requirements: TP2

Transmitter Output Waveform Requirements:
TP2

Reference to specification

IEEE 802.3-2012, Table 85-5, section 85.8.3.3.

Compute filter coefficients (prerequisite)

Compute the filter coefficients with the DUT in PRESET state as follows:

1. Set DUT transmit equalizer coefficients in PRESET state.

2. Capture the signal with sampling rate of 3.3 TS/sec, containing at least one complete cycle of PRBS9.

3. Compute the differential signal: Differential Signal = (Data positive waveform – Data negative
waveform).

4. Determine whether the input signal contains PRBS9. If captured signal does not contain PRBS9 then
provide proper error message and exit.

5. Down sample the waveform such that there are 32(M) samples per UI (down sampling factor of 10).
Make sure that the first M samples of waveform correspond to first bit of the test pattern; the second M
samples of waveform correspond to second bit and so on.

6. Compute the linear fit pulse response. Determine the point on linear fit corresponding to tx. tx is time
where the rising edge of linear fit pulse crosses 50% of its peak amplitude.

7. Sample the linear pulse response at symbol spaced intervals (down sample by 32) relative to time t0 =
tx + 0.5UI. Using sampled linear fit pulse response, compute filter coefficients which is reciprocal
of linear fit pulse response.

Measurement algorithm

1. Put the DUT transmit equalizer coefficients in states as listed in the following table:

Measurement Equalizer coefficient states

Transmitter DC Amplitude

Linear Fit Pulse

RMS Normalized Error

C(0), C(1) and C(-1) shall be in PRESET state

Initialization coefficient ratio1

Initialization coefficient ratio2

C(0), C(1) and C(-1) shall be in INITIALIZE state

Pre-cursor full scale range C(-1) set to ZERO, C(0) and C(1) set to MINIMUM
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Reference Transmitter Output Waveform Requirements: TP2

Measurement Equalizer coefficient states

Post-cursor full scale range C(1) set to ZERO, C(0) and C(-1) set to MINIMUM

Absolute Coefficient Step Size C(0), C(1) and C(-1) shall be in INITIALIZE state

C(-1) in INCREMENT state, C(0) and C(1) in HOLD state

C(-1) in DECREMENT state, C(0) and C(1) in HOLD state

C(0), C(1) and C(-1) shall be in INITIALIZE state

C(0) in INCREMENT state, C(-1) and C(1) in HOLD state

C(0) in DECREMENT state, C(-1) and C(1) in HOLD state

C(0), C(1) and C(-1) shall be in INITIALIZE state

C(1) in INCREMENT state, C(0) and C(-1) in HOLD state

C(1) in DECREMENT state, C(0) and C(-1) in HOLD state

xxx

2. Make acquisitions for every state listed in table, based on selected measurements.

3. Steps (2) to (6) of the “Computation of filter coefficients” are repeated.

4. Sample the linear pulse response at symbol spaced intervals (down sample by 32) relative to time
t0 = tx + 0.5 UI.

5. Using sampled linear fit pulse response and filter coefficients computed during PRESET state,
compute the equalized pulse response.

6. Using equalized pulse response, linear fit pulse response and based on measurement chosen by user,
we compute the following parameters that determine the performance of the transmit equalizer:

Transmitter DC amplitude

Wherep(k) are continuous filter coefficients.

Linear fit pulse peak

pmax = MAXIMUM(p(k)), k =1 to MNp

RMS Normalized Error

RMS value of the error between the linear fit and measured waveform e, normalized to the peak
value of the pulse

Minimum post cursor full scale range

When c(-1) is set to zero, c(0) and c(1) set to minimum, the minimum post cursor equalization
ratio is determined. Minimum post cursor equalization ratio is mathematically given as
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Reference Transmitter Output Waveform Requirements: TP2

Minimum pre cursor full scale range

When c(1) is set to zero, both c(-1) and c(0) are set to minimum, the minimum pre cursor
equalization ratio is determined. Minimum pre cursor equalization ratio is mathematically given as

Coefficient Initialization Ratio1

(c(0) + c(1) – c(-1)) / (c(0) + c(1) + c(-1))

Coefficient Initialization Ratio2

(c(0) – c(1) + c(-1)) / (c(0) + c(1) + c(-1))

Absolute Coefficient Step Size

For increment coefficient step size, cbefore(i) is with INITIALIZE state and Cafter(i) is with
INCREMENT state.

For decrement coefficient step size, cbefore(i) is with INCREMENT state and Cafter(i) is with
DECREMENT state. Values of I are -1, 0 and 1.

Limits

If Transmitter DC amplitude is between 0.34 V and 0.6 V, then test result is pass else test result is fail

If linear fit pulse peak is greater than (0.63*v_f), then test result is pass else test result is fail

If RMS normalized error is less than 0.037, then test result is pass else test result is fail

If absolute coefficient step size is between 0.0083 and 0.05, then test result is pass else test result is fail

If post cursor full scale range is greater than 4, then test result is pass else test result is fail

If pre cursor full scale range is greater than 1.54, then test result is pass else test result is fail

If (c(0) + c(1) – c(-1)) / (c(0) + c(1) + c(-1)) is between 1.161 and 1.419 (1.29±10%), then test result
is pass else test result is fail

If (c(0) – c(1) + c(-1)) / (c(0) + c(1) + c(-1)) is between 2.313 and 2.827 (2.57 ±10%), then test
result is pass else test result is fail.
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Reference Transmitter Output Waveform Requirements: TP2

Plots

Continuous linear fit pulse

Sampled linear fit pulse values marked

t0 and tX marked
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Reference Transition Time (20% - 80%): TP0 and TP2

Transition Time (20% - 80%): TP0 and TP2

Reference to specification

IEEE 802.3-2012, Table 85A-1, section 72.7.1.7.

Measurement algorithm

1. Samples present in middle 0.5UI of positive pulse are used for computing high voltage (mean value of
samples).

2. Samples present in middle 0.5UI of negative pulse are used for computing low voltage(mean value of
samples).

3. Using high and low voltages, 20% and 80% thresholds are computed.

4. Determine the rising edge positions in the given input waveform:

On each rising edge, traverse forward to find the first point crossing the upper limit (80%) (=End).

Traverse backward to find the first point crossing the lower limit (20%) (= Start).

Compute Rise Time (RT = End – Start) for each rising edge. Average value of RT across all
rising edges is given as final result.

5. Determine the falling edge positions in the given input waveform:

On each falling edge, traverse backward to find the first point crossing the upper limit (80%)
(=Start).

Traverse forward to find the first point crossing the lower limit (20%) (=End).

Compute Fall Time (FT = End – Start) for each falling edge. Average value of FT across all
falling edges is given as final result.

Limits

TP0: rise time and fall time shall be between 24 ps and 47 ps

TP2: transition time measurement is informative

Plots

Plot showing a rising edge and another plot showing falling edge
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40GBase-CR4 Application
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About TekExpress, 19
Acquire live waveforms, 30
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Connection requirements, 60

D
Default directory, 16
Deselect All (tests), 32
Deskew

real time oscilloscopes, 58
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Directories, 16
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command, 111
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DUT ID commands, 91
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device, 30
host, 30
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Enable remote access, 70
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Error code commands, 102
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Firewall (remote access), 70
Flowchart for client programmatic

interface, 76
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GetAnalyzeParameter(), 94
GetCurrentStateInfo(), 105
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GetPassFailStatus(), 106
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Global settings, 40

H
Help conventions, 2
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Inbound Rule Wizard (remote

access), 70
Initial application directory

setup, 13
Installing the software

40G-CR4, 9
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Interface error codes, 102
IP address connection

commands, 88

K
Keep On Top, 21
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L
License, 21
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Limits Editor, 40
Limits editor compare
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Loading a test setup, 66
Loading saved waveform files, 33
LockSession(), 89
Log view

save file, 45
Log View tab, 45

M
Map X drive, 14
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viewing, 55
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