
TekExpress
USB4TM Automated Test Solution Software
Printable Application Help

*P077170200*
077-1702-00





TekExpress
USB4TM Automated Test Solution Software
Printable Application Help

USB4TM, USB Type-C® and USB-C® are trademarks of USB Implementers Forum

Register now!
Click the following link to protect your product.
www.tek.com/register

077-1702-00



Copyright © Tektronix. All rights reserved. Licensed software products are owned by Tektronix or its subsidiaries or
suppliers, and are protected by national copyright laws and international treaty provisions. Tektronix products are covered
by U.S. and foreign patents, issued and pending. Information in this publication supersedes that in all previously published
material. Specifications and price change privileges reserved.

TEKTRONIX and TEK are registered trademarks of Tektronix, Inc.

Tektronix, Inc.

14150 SW Karl Braun Drive

P.O. Box 500

Beaverton, OR 97077

USA

For product information, sales, service, and technical support:

• In North America, call 1-800-833-9200.
• Worldwide, visit www.tek.com to find contacts in your area.

HTTP://WWW.TEK.COM


Table of Contents
Welcome...................................................................................................................................................................................... vii
Contacting Tektronix................................................................................................................................................................... viii
Getting help and support...............................................................................................................................................................1

Related documentation.......................................................................................................................................................... 1
Conventions used in help.......................................................................................................................................................1
Technical support................................................................................................................................................................... 1

Getting started...............................................................................................................................................................................3
Minimum system requirements.............................................................................................................................................. 3
Required windows 10 user account setting........................................................................................................................... 3
Supported instruments...........................................................................................................................................................4
Install the software................................................................................................................................................................. 4
Verify application installation..................................................................................................................................................5
Activate the license................................................................................................................................................................ 5
View software version............................................................................................................................................................ 5
Required my TekExpress folder settings................................................................................................................................6
Set my TekExpress folder permissions.................................................................................................................................. 6
Application directories and their contents.............................................................................................................................. 7
File name extensions............................................................................................................................................................. 8
Where test files are stored..................................................................................................................................................... 8

Operating basics......................................................................................................................................................................... 10
Run the application.............................................................................................................................................................. 10
Application panels overview................................................................................................................................................. 11
Global application controls...................................................................................................................................................12

Application controls.......................................................................................................................................................12
Options menu overview................................................................................................................................................ 13
TekExpress instrument control settings........................................................................................................................ 14
Configure email settings............................................................................................................................................... 16

Setup panel..........................................................................................................................................................................18
Setup panel overview................................................................................................................................................... 18
Set DUT parameters.....................................................................................................................................................18
Select tests................................................................................................................................................................... 21
Set acquisition parameters........................................................................................................................................... 22
Running tests on prerecorded (saved) waveforms....................................................................................................... 24
Set configuration tab parameters..................................................................................................................................25
Preferences tab............................................................................................................................................................ 27

Status panel......................................................................................................................................................................... 28
Status panel overview...................................................................................................................................................28

Results panel....................................................................................................................................................................... 29
Results panel overview.................................................................................................................................................29
View test-related files....................................................................................................................................................30
Preferences menu........................................................................................................................................................ 31

Reports panel.......................................................................................................................................................................32
Reports panel overview................................................................................................................................................ 32
Select report options.....................................................................................................................................................32

Table of Contents

TekExpress USB4TM Automated Test Solution Software Printable Application Help v



View a report.................................................................................................................................................................34
Report contents............................................................................................................................................................ 34

Running tests.............................................................................................................................................................................. 36
Test process flow................................................................................................................................................................. 36
Deskew real-time oscilloscopes...........................................................................................................................................36
Instrument and DUT connection setup................................................................................................................................ 37
Running tests....................................................................................................................................................................... 37
Prerun checklist................................................................................................................................................................... 37

Saving and recalling test setup files............................................................................................................................................38
Test setup files overview...................................................................................................................................................... 38
Save a test setup file............................................................................................................................................................38
Open (load) a saved test setup file...................................................................................................................................... 38
Run a saved test in prerecorded mode................................................................................................................................39
Create a new test setup file based on an existing one........................................................................................................ 39

SCPI commands......................................................................................................................................................................... 40
About SCPI command......................................................................................................................................................... 40
Socket configuration for SCPI commands........................................................................................................................... 40
TEKEXP:*IDN?.................................................................................................................................................................... 46
TEKEXP:*OPC?...................................................................................................................................................................46
TEKEXP:ACQUIRE_MODE.................................................................................................................................................47
TEKEXP:ACQUIRE_MODE?...............................................................................................................................................47
TEKEXP:EXPORT............................................................................................................................................................... 47
TEKEXP:INFO?................................................................................................................................................................... 47
TEKEXP:INSTRUMENT...................................................................................................................................................... 48
TEKEXP:INSTRUMENT?.................................................................................................................................................... 48
TEKEXP:LASTERROR?......................................................................................................................................................48
TEKEXP:LIST?.................................................................................................................................................................... 49
TEKEXP:POPUP................................................................................................................................................................. 49
TEKEXP:POPUP?............................................................................................................................................................... 49
TEKEXP:REPORT............................................................................................................................................................... 50
TEKEXP:REPORT?............................................................................................................................................................. 50
TEKEXP:RESULT?.............................................................................................................................................................. 50
TEKEXP:SELECT................................................................................................................................................................51
TEKEXP:SELECT?..............................................................................................................................................................51
TEKEXP:SETUP..................................................................................................................................................................51
TEKEXP:STATE...................................................................................................................................................................52
TEKEXP:STATE?.................................................................................................................................................................52
TEKEXP:VALUE.................................................................................................................................................................. 52
TEKEXP:VALUE?................................................................................................................................................................ 53
Command parameters......................................................................................................................................................... 53
Examples............................................................................................................................................................................. 62

Reference....................................................................................................................................................................................65
Handle error codes.............................................................................................................................................................. 65

Index........................................................................................................................................................................................... 66

Table of Contents

TekExpress USB4TM Automated Test Solution Software Printable Application Help vi



Welcome

Welcome to the TekExpress® USB4 Automated Test Solution Software application (referred to as USB4 in the rest of the
document). TekExpress USB4 provides an automated, simple, and efficient way to test USB4 transmitter interfaces and
devices for USB-IF compliance through DPOJET for better margin, debugging, and analysis.

Key features and benefits
• Automated solution for USB4 connectors which support USB4 specification and CTS (Gen2 & Gen3).
• DPOJET plugin for connectors which support USB4 specification and CTS (Gen2 & Gen3) with setup files and MOI.
• Support embedding Channels (2 m and 0.8 m) and their respective filter files for connectors.
• Manual support for compliance to debug with DPOJET USB4 and CIO plug-ins.

Welcome
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Contacting Tektronix
Tektronix, Inc.

14150 SW Karl Braun Drive

P.O. Box 500

Beaverton, OR 97077

USA

For product information, sales, service, and technical support:

• In North America, call 1-800-833-9200.
• Worldwide, visit www.tek.com to find contacts in your area.

Copyright © Tektronix. All rights reserved. Licensed software products are owned by Tektronix or its subsidiaries or
suppliers, and are protected by national copyright laws and international treaty provisions. Tektronix products are covered
by U.S. and foreign patents, issued and pending. Information in this publication supersedes that in all previously published
material. Specifications and price change privileges reserved.

TEKTRONIX and TEK are registered trademarks of Tektronix, Inc.

TriMode is a trademark of Tektronix, Inc.

TekExpress USB4 Application Help, 076-0463-00.

Contacting Tektronix
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Getting help and support
Related documentation

The following manuals are available as part of the TekExpress USB4 Automated Test and Compliance Solution
documentation set.

Table 1: Product documentation

Item Purpose Location

Help Application operation and User
Interface help

PDF of the help Printable version of the compiled help

PDF file that ships with USB4 software
distribution (USB4-Automated-Test-
Solution-Software-Printable-Help-EN-
US.pdf).

You can download the PDF version of
the manual from the Tektronix website.

USB4 DPOJET MOI. Detailed information on test setup and
execution

PDF file that ships with USB4 software
distribution.

See also
Technical support

Conventions used in help
Online help uses the following conventions:

• The term “DUT” is an abbreviation for Device Under Test.
• The term “select” is a generic term that applies to the two methods of choosing a screen item (button, control, list item):

using a mouse or using the touch screen.

Technical support
Tektronix values your feedback on our products. To help us serve you better, please send us your suggestions, ideas, or
comments on your application or oscilloscope. Contact Tektronix through mail, telephone, or the Web site. See Contacting
Tektronix for more information.

When you contact Tektronix Technical Support, please include the following information (be as specific as possible): 

General information
• All instrument model numbers

Getting help and support

TekExpress USB4 Automated Test Solution Software Printable Application Help 1



• Hardware options, if any
• Your name, company, mailing address, phone number, FAX number
• Please indicate if you would like to be contacted by Tektronix about your suggestion or comments.

Application specific information
• Software version number
• Description of the problem such that technical support can duplicate the problem
• If possible, save the setup files for all the instruments used and the application.
• If possible, save the TekExpress setup files, log.xml, *.TekX (session files and folders), and status messages text file.
• If possible, save the waveform on which you are performing the measurement as a .wfm file.

Getting help and support
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Getting started
Minimum system requirements

The following table shows the minimum system requirements needed for an oscilloscope to run TekExpress USB4. 

Table 2: TekExpress USB4 system requirements

Component Requirement

Oscilloscope See Supported instruments

Processor Same as the oscilloscope

Operating System Same as the oscilloscope:

• Windows 10 (64-bit only) SP1 Windows 10 user account settings

Memory Same as the oscilloscope

Hard Disk Same as the oscilloscope

Display Super VGA resolution or higher video adapter (800 x 600 minimum video
resolution for small fonts or 1024 x 768 minimum video resolution for large fonts).
The application is best viewed at 96 dpi display settings 1

Firmware TekScope 10.11.1 and above (for Windows 10)

Software • Microsoft .NET 4.0 Framework

• DPOJET Jitter and Eye Analysis Tool (version 10.2.0 or higher) with
Advanced Jitter and Eye analysis (DJA option) installed.

• Microsoft Internet Explorer 7.0 SP1 or later, or other Web browser for viewing
reports.

• Adobe Reader software 7.0 or later for viewing portable document format
(PDF) files.

• Serial Data Link Analysis (SDLA) software, version 3.0.9 or later, for Channel
De-Embed, for custom filter development.

Required windows 10 user account setting
Windows 10 instruments need to have the User Account Control Settings set to Never Notify. To set User Account Control
Settings:

1. Go to Control Panel > User Accounts > Change User Account Control settings.
2. Set the sliding control to Never Notify as shown in the image, and click OK.

Windows 10

1 If TekExpress is running on an instrument that has a video resolution less than 800x600, connect and configure a second monitor to the instrument.

Getting started
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See also
Supported oscilloscopes

Supported instruments
Table 3: Required equipment

Resource Model supported

Real-time oscilloscope Tektronix DPO, DX, and SX series oscilloscopes (Windows 10 OS):

• 21 GHz bandwidth is suitable for Gen2 (10 Gbps) and Gen3 (20 Gbps) measurements.

Probes Two TCA-SMA cables

Two SMP-SMA cables

USB4 fixtures • USB-IF approved Wilder-Tech fixtures for USB4 compliance testing.
• The fixture set includes Tx Host and Device testing.

Connector Type Type C Symmetrical connector on both side

See also
Minimum system requirements

Install the software
Use the following steps to obtain the latest USB4 software from the Tektronix Web site and install on any compatible
instrument running Microsoft Windows 10 (64-bit). See Minimum System Requirements for details. 

1. Close all applications (including the TekScope application).

Getting started
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2. Go to the www.tek.com Web site and locate the Downloads fields.
3. Enter tekexpress USB4 in the Model or Keyword field, select Software from the Select Download Type list, and click

GO.
4. Select the latest version of software, and then follow instructions to download the software file.
5. Copy or download the USB4 installer executable file to the oscilloscope.
6. Double-click the installer .exe file to extract the installation files and launch the InstallShield Wizard.

Follow the on-screen instructions. The software is installed at C:\Program Files\Tektronix
\TekExpress\TekExpress USB4.

7. Verify application installation

See also
Minimum system requirements

Supported instruments

Required My TekExpress folder settings

Verify application installation
To verify the installation was successful:

1. Open the TekScope application.
2. Click the Analyze menu.
3. Verify that TekExpress USB4 is listed in the Analyze menu.
4. Click TekExpress USB4 to open the application.

Verify that the application opens successfully.

See also
Activate the license

Required My TekExpress folder settings

Activate the license
Activate the license using the Option Installation wizard in the TekScope application: 

1. In the TekScope application menu bar, click Utilities > Option Installation.

The TekScope Option Installation wizard opens.
2. Push the F1 key on the oscilloscope keyboard to open the Option Installation help topic.
3. Follow the directions in the help topic to activate the license.

See also
View version and license information

Required My TekExpress folder settings

View software version
To view version information for TekExpress USB4, click the Options button and select About TekExpress.

To view license and option key information in the TekScope applicaion: 

1. In the TekScope application, select Help > About TekScope.
2. Scroll through the Options list to locate USB4: TekExpress USB4 .

Getting started
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3. To view the Option installation key value, look below the Options list.

See also
Activate the license

Options menu

Required my TekExpress folder settings
Before you run tests for the first time, you need to Set the My TekExpress folder permissions. 

See also
Application directories and usage

File name extensions

Set my TekExpress folder permissions
Ensure that the My TekExpress folder has read and write access. Also verify that the folder is not set to be encrypted: 

1. Right-click the folder and select Properties.
2. Select the General tab, and then click Advanced.
3. In the Advance Attributes dialog box, ensure that the option Encrypt contents to secure data is NOT selected.

4. Click the Security tab and verify that the correct read and write permissions are set.

Getting started
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See also
Application directories and usage

File name extensions

Application directories and their contents
TekExpress USB4application
The TekExpress USB4 application files are installed at the following location:
C:\Program Files\Tektronix\TekExpress\TekExpress USB4

The following table lists the application directory names and their purpose.

Table 4: Application directories and usage

Directory names Usage

Bin It contains USB4 application libraries.

Compliance Suites It contains compliance-specific files.

Examples It contains various support files.

ICP It contains instrument and USB4 application-specific
interface libraries.

Lib It contains utility files specific to the USB4 application.

Report Generator It contains style sheets for report generation.

Setup Files It contains setup files.

Table continued…

Getting started
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Directory names Usage

Tools It contains instrument and USB4 application-specific files.

See also
View test-related files

File name extensions

File name extensions
The TekExpress USB4 Tx application uses the following file name extensions:

File name extension Description

.TekX Application session files (the extensions may not be
displayed)

.xml Test-specific configuration information (encrypted) files

Application log files

.wfm Test waveform files

.mht Test result reports (default)

Test reports can also be saved in pdf format or in CSV
format

.flt Filter files

.xslt Style sheet used to generate reports

.pdf, .chm Help files

See also
View test-related files

Application directories and their contents

Where test files are stored
When you launch TekExpress USB4 for the first time, it creates the following folders on the oscilloscope:

• \My Documents\My TekExpress\USB4
• \My Documents\My TekExpress\USB4\Untitled Session
Every time you launch TekExpress USB4, an Untitled Session folder is created in the USB4 folder. The
Untitled Session folder is automatically deleted when you exit the USB4 application. To preserve your test
session files, save the test setup before exiting the TekExpress application.

CAUTION: Do not modify any of the session files or folders because this may result in loss of data or corrupted
session files. Each session has multiple files associated with it. When you save a session, the application creates
a .TekX file, and a folder named for the session that contains associated files, on the oscilloscope X: drive.

Getting started
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See also
Set the My TekExpress folder permissions

Application directories and usage

File name extensions

Getting started
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Operating basics
Run the application

To start the TekExpress USB4 application, do either of the following:

• Select Analyze > TekExpress USB4 from the TekScope menu.

• The oscilloscope opens the TekExpress USB4 application.

When you first run the application after installation, the application checks for a file called Resources.xml located
in the C:\Users\<username>\My TekExpress\USB4 folder. The Resources.xml file gets mapped to the
X: drive when the application launches. Session files are then stored inside the X:\USB4 folder. The Resources.xml
file contains information about available network-connected instruments. If this file is not found, the application runs an
instrument discovery program to detect connected instruments before launching USB4.

Note: Do the steps in the Required My TekExpress folder settings topic before running tests with the USB4
application for the first time.

Operating basics
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To keep the USB4 application window on top, select Keep On Top from the USB4 Options menu. If the application goes
behind the oscilloscope application, click Analyze > TekExpress USB4 to move the application to be in front. 

See also
Required My TekExpress folder settings

Activate the license

Application controls

Application panel overview

Application panels overview
TekExpress USB4 uses panels to group related configuration, test, and results settings. Click a button to open the
associated panel. A panel may have one or more tabs that list the selections available in that panel. Controls in a panel can
change depending on settings made in that panel or another panel. 

Operating basics
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Table 5: Application panels overview

Panel Name Purpose

Setup The Setup panel shows the test setup controls. Click the Setup button to open
this panel.

Use this panel to:

• Select DUT parameters.

• Select the test(s).

• Set acquisitions parameters for selected tests.

• Select test notification preferences.

Status View the progress and analysis status of the selected tests, and view test logs.

Results View a summary of test results and select result viewing preferences.

Reports Browse for reports, save reports as specific file types, specify report naming
conventions, select report content to include (such as summary information,
detailed information, user comments, setup configuration, application
configuration), and select report viewing options.

See also
Application controls

Global application controls

Application controls
Table 6: Application controls descriptions

Item Description

Options menu Menu to display global application controls.

Test Panel buttons Controls that open panels for configuring test settings and options.

Table continued…
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Item Description

Start / Stop button Use the Start button to start the test run of the measurements in the selected order. If prior acquired
measurements have not been cleared, the new measurements are added to the existing set.

The button toggles to the Stop mode while tests are running. Use the Stop button to abort the test.

Pause / Continue
button

Use the Pause button to temporarily interrupt the current acquisition. When a test is paused, the
button name changes to “Continue.”

Clear button Use the Clear button to clear all existing measurement results. Adding or deleting a measurement,
or changing a configuration parameter of an existing measurement, also clears measurements. This
is to prevent the accumulation of measurement statistics or sets of statistics that are not coherent.
This button is available only on the Results panel.

Minimize button Use the Minimize button to minimize the application.

Quit button Use the Quit button to exit the application.

Mini view/ Normal
view

Toggles the application between Mini view and Normal view. Mini view displays the run messages
with the time stamp, progress bar, Start/Stop button, and Pause/Continue button. The application
moves to Mini view when you click the Start button.

See also
Application panel overview

Options menu overview
The Options menu is located in the upper right corner of the application. The Options menu has the following selections: 

Menu Function

Default Test Setup Opens an untitled test setup with defaults selected

Open Test Setup Opens a saved test setup

Save Test Setup Saves the current test setup selections

Save Test Setup As 2 Creates a new test setup based on an existing one

Table continued…

2 In pre-recorded mode, waveform recall will not be successful if the session name is more than 10 characters.
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Menu Function

Open Recent Displays a menu of recently opened test setups to select
from

Instrument Control Settings Detects, lists, and refreshes the connected instruments
found on specified connections (LAN, GPIB, USB)

Keep On Top Keeps the TekExpress USB4 application on top of other
open windows on the desktop

Email Settings Use to configure email options for test run and results
notifications

Deskew Use to set deskew parameter and read instrument deskew/
attenuation values

Help Displays the TekExpress USB4 help

About TekExpress • Displays application details such as software name,
version number, and copyright

• Provides access to License information for your USB4
installation

• Provides a link to the Tektronix Web site

See also
Application controls

TekExpress instrument control settings

Instrument control settings

Use the TekExpress Instrument Control Settings dialog box to search for and list the connected resources (instruments)
detected on selected connections (LAN, GPIB, USB), and each instruments connection information.

Access this dialog box from Options > Instrument Control Settings. 

Operating basics
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Use the Instrument Control Settings feature to search for connected instruments and view instrument connection details.
You can select listed connected instruments for use in the Global Settings tab in the test configuration pane.

See also
Options menu overview

View connected instruments

Use the Instrument Control Settings dialog box to view or search for connected instruments required for the tests. The
application uses TekVISA to discover the connected instruments on all selected connection types. 

Note: The correct instruments for the current test setup must be connected and recognized by USB-TX before
running tests.

To refresh the list of connected instruments:

1. From the Options menu, select Instrument Control Settings.
2. In the Search Criteria section of the Instrument Control Settings dialog box, select the connection types of the

instruments for which to search.

Instrument search is based on the VISA layer, but different connections determine the resource type, such as LAN,
GPIB, and USB. For example, if you choose LAN, the search will include all the instruments supported by TekExpress
that are communicating over the LAN.

3. Click Refresh. TekExpress searches for connected instruments.

Operating basics

TekExpress USB4 Automated Test Solution Software Printable Application Help 15



4. After searching, the dialog box lists the instrument-related details based on the search criteria you selected. For
example, if you selected LAN and GPIB as the search criteria, the application checks for the availability of instruments
over LAN, then GPIB, and then lists detected instruments on those connection types.

The Retrieved Instruments table lists instrument details. The time and date of the last time this table was updated is
displayed in the Last Updated field.

See also
Equipment connection setup

Configure email settings
Use the Email Settings dialog box to be notified by email when a test completes, fails, or produces an error: 

1. Select Options > Email Settings to open the Email Settings dialog box.

Email settings

Operating basics
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2. (Required) For Recipient email Address(es), enter one or more email addresses to which to send the test notification.
To include multiple addresses, separate the addresses with commas.

3. (Required) For Sender’s Address, enter the email address used by the instrument. This address consists of the
instrument name followed by an underscore followed by the instrument serial number, then the @ symbol and the
email server used. For example: DPO72016C_B130099@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server address of the Mail server configured at the
client location, and the SMTP Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name, password, and host name in the
corresponding fields.

Note: If any of the above required fields are left blank, the settings will not be saved and email notifications
will not be sent.

5. In the Email Attachments section, select from the following options:

• Reports: Select to receive the test report with the notification email.

• Status Log: Select to receive the test status log with the notification email. If you select this option, select whether
you want to receive the full log or just the last 20 lines.

6. In the Email Configuration section:

• Email Format: Select the message file format to send: HTML (the default) or plain text.
• Max Email Size (MB): Enter a maximum file size for the email message. Messages with attachments larger than

this limit will not be sent. The default is 5 MB.
• Number of Attempts to Send: Enter the number to limit the number of attempts that the system makes to send a

notification. The default is 1. You can also specify a timeout period.
7. Select the Email Test Results When complete or on error check box. Use this check box to quickly enable or

disable email notifications.
8. To test your email settings, click Test Email.
9. To apply your settings, click Apply.
10. Click Close when finished.

Operating basics
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Setup panel

Setup panel overview
The Setup panel contains sequentially ordered tabs that help guide you through a typical test setup and execution process.
Click a tab to open the associated panel and controls. 

The tabs on this panel are:

DUT: Set the DUT parameters

Test Selection: Select test(s)

Acquisitions: Select acquisition parameters

Preferences: Select test fail notification preferences

Set DUT parameters
Use the DUT tab to select parameters for the device under test. The settings are global and apply to all tests for the current
session. The DUT settings available and the options in the drop-down list depends on the selections made in the settings.
DUT settings also affect the list of available tests in the Test Selection tab. 

Operating basics
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Click Setup > DUT to access the DUT parameters:

Table 7: DUT tab settings

Setting Description

DUT ID Adds an optional text label for the DUT to reports. The default value is DUT001. The
maximum number of characters is 32.

You cannot use the following characters in an ID name: (.,..,...,\,/:?”<>|*).

   Comments icon (to the
right of the DUT ID field)

Opens a Comments dialog box in which to enter optional text to add to a report. Maximum
number of characters is 256. To enable or disable comments appearing on the test report,
see Select report options).

Help Opens the help document with DUT page selected.

Acquire live waveforms Acquire active signals from the DUT for measurement and analysis.

Use prerecorded waveform
files

Run tests on a saved waveform. Open (load) a saved test setup.

DUT Type • Device: Select the DUT type as Device.

• Host: Select the DUT type as Host.

Version Displays the CTS version.
Table continued…
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Setting Description

Test Mode Displays the selected test mode. Preselects tests and parameters needed to meet
compliance specifications for the selected device type. Disables the compliance filter
controls.

Test Method Displays the selected test method. The selected test method, sets the algorithms used to
measure and analyze the signal. DPOJET: Select to perform measurements implemented
in DPOJET (only for RP1).

Data Rates Sets the test data rate (10 Gbps or 20 Gbps).

• Gen2: Select to include the data rate for Gen2.
• Gen3: Select to include the data rate for Gen3.

Lane Selection Select the Lane Selection as Lane 0 or Lane 1.

DUT Automation DUT Automation.

• Manual
• Automated

Enables the Setup button.

Click Setup. In the DUT Automation pop-up, select the TGL (Tiger Lake) to setup the DUT
automation. Set the DUT Port Number (0 -63) and the waiting time after automated
pattern change. Default value for port number is 0 and wait time is 5 seconds.

Table continued…
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Setting Description

Filter Selection You can change the Differential de-embed filter files, change the common mode deembed
filter files. The test mode is fixed to compliance, therefore, cable emulator (for TP3
measurements) files are fixed.

The de-embed S parameter file (.s4p) is loaded into the SDLA Equalizer to de-embed the
cables connected to the fixture. The 4 port index configuration for the chosen file is
displayed. Assign the valid port depending on the loaded .s4p file. The two ports on the
left are input ports and the two ports on the right are the output ports.

Figure 1: Filter Selection

See also
Select a test

Select tests
Use the Test Selection tab to select USB4 tests. Listed tests depend on settings in the DUT tab. 
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Table 8: Test Selection tab settings

Setting Description

Deselect All, Select All Deselect or select all tests in the list. 

Tests Click a test to select or deselect. Selecting a test also show details about that test in the
Test Description pane.

All required tests are selected when in Compliance test mode.

Schematic Displays equipment connection setup for the selected measurements. You need to select
at least a measurement before you click the Schematic.

Show MOI Displays the MOI (USB4 DPOJET MOI)

Note: All tests are selected by default.

Note: The application does not show the oscilloscope cursor1 and 2 for each burst. The application runs an
analysis on the first five bursts of an acquisition and displays the result statistics.

See also
Set acquisition parameters

Set acquisition parameters
Use the Acquisition tab in the Setup panel to view test acquisition parameters. You also use this tab to load prerecorded
(saved) test session waveform files on which to run tests.

Contents displayed on this tab depend on the DUT type and selected tests. 
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Note: USB4 acquires all waveforms required by each test group and generation being tested (Gen1, Gen2) before
performing analysis.

Table 9: Acquisitions tab settings

Setting Description

Source Selection Lists the signal type and input channel assigned to that type.

Click on Source fields to assign a channel source to a signal type.

The (Source) channels are auto selected, based on the probe type used and Lane
selected on the DUT tab.

Refresh sources Updates the list of available channel sources as used by the Source fields in the
Device list. Click this button if you change channel connections in the test setup.

View Probes Displays the Source, Probe Type, and Probe models.
Acquisision and save options Saves all waveforms before the analysis.

Table continued…
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Setting Description

Signal Validation Sets the signal validation actions. Select from the available list items.

• Prompt me if signal fails
• Skip test if signal validation fails
• Use signal as is - Don't Check

When the signal validation option is set to "Prompt me if signal validation fails", the
application validates whether the signal is PRBS31, PRBS15, SQ128, or SQ2
pattern. Additionally, it also validates if the signal is Electrical idle. If the signal is
valid, the measurement continues normally. If the signal is invalid, the following
popup displays:

Note: If Pattern type validation is selected as No, then the measurement
continues with the acquired waveform.

• Click Reacquire to start the acquisition again.
• Click Use Current to continue with the currently acquired waveform.
• Click Skip Pattern to skip all pattern type tests. The rest of the selected

measurements continue.

USB4 saves all acquisition waveforms to files by default. Waveforms are saved to a folder that is unique to each session (a
session starts when you click the Start button). The folder path is X:\TekExpress USB4\Untitled Session
\<dutid>\<date>_<time>. Images created for each analysis, reports, and other information specific to that
session are also saved in this folder.

When the session is saved, content is moved to that session folder and the “Untitled Session” name is replaced by the
session name.

See also
Running tests on prerecorded saved waveforms

Running tests on prerecorded (saved) waveforms
To load a saved waveform file: 

1. Click DUT.
2. Click Use pre-recorded waveform files.
3. Click Acquisitions. The Waveform Filename column now shows browse buttons.
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4. Click the browse button ( ) for each test acquisition type PRBS15, PRBS31, SQ128, and SQ2.
5. Navigate to and select the appropriate waveform file(s). You must select all waveforms required for the acquisition type.
6. To change, remove, or add a file to the list, click the browse button next to the file name to change, and use the menu

items to replace, remove (delete) or add a file in the list.
7. Click Start.

Set configuration tab parameters
Use the Configuration tab to set and view global instrument parameters for the selected tests. Which fields are available to
edit as set in this tab or the DUT tab.

Note: You cannot change test parameters that are grayed out.
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Figure 2: Configuration tab - Measurements

Figure 3: Configuration tab - Global Settings
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Table 10: Configuration tab settings

Setting Description

Limits Editor Opens the Limits Editor dialog box.

In Compliance Mode, use the Limits Editor to view the measurement high and
low limits used for selected tests. You cannot edit values while in Compliance
mode.

Global Settings

Instruments Detected Displays a list of the connected instruments found during the instrument
discovery. Instrument types includes oscilloscopes. Select Options > Instrument
Control Settings to refresh the connected instrument list.

Measurements
Measurements Displays the list of measurements.

Config

Select the configuration for the measurements with TP3.

Gen2 and Gen3 CTLE Select the CTLE filter file for Gen2 and Gen3.
CTLE Index Set the CTLE index value.
Perform with DFE (Max Tap Value: 50
mV)

Select to perform the DFE.

Preferences tab
Use the Preferences tab to set the application action when a test measurement fails.
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Table 11: Preferences tab settings

Setting Description

Popup Settings

Auto close Warnings and
Informations during Sequencing

Auto close after <no> Seconds

Select to auto close warnings/informations during sequencing. Set the Auto close
time. By default, it is unselected.

Auto close Error Messages during
Sequencing. Show in Reports.

Auto close after <no> Seconds

Select to auto close Error Messages during Sequencing. Set the Auto close time. By
default, it is unselected.

Show messages with a beep sound. Select to show the messages with a beep sound.

Status panel

Status panel overview
The Status button accesses the Test Status and Log View tabs, which provide status on test acquisition and analysis.( Test
Status tab) and a listing of test tasks performed (Log View tab). The application opens the Test Status tab when you start a
test run. You can select the Test Status or the Log View tab to view these items while tests are running. 

Test status view

Log view
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Table 12: Status panel settings

Control Description

Message History Window that lists all executed test operations and timestamp information.

Auto Scroll Enables automatic scrolling of the log view as information is added to the log during
the test.

Clear Log Clears all messages from the log view.

Save Saves the log file to a text file. Use the standard Save File window to navigate to and
specify the folder and file name to which to save the log text.

See also
Application panel overview

Results panel

Results panel overview
When a test finishes, the application automatically opens the Results panel to display a summary of test results. 
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The Overall Test Result is displayed at the top left of the Results table. If all of the tests for the session pass, the overall test
result is Pass. If one or more tests fail, the overall test result is Fail.

Set viewing preferences for this panel from the Preferences menu in the upper right corner. Viewing preferences include
showing whether a test passed or failed, summary or detailed results, and enabling wordwrap.

Note: NAN (Not A Number) is displayed in the test results if an invalid waveform was supplied for the test.

Each test result occupies a row in the Results table. By default, results are displayed in summary format with the
measurement details collapsed and with the Pass/Fail column visible. Change the view in the following ways:

• To expand and collapse tests to show more or less detail, click the plus and minus buttons in the table.
• To expand the width of a column, place the cursor over the vertical line that separates the column from the column to

the right. When the cursor changes to a double-ended arrow, hold down the mouse button and drag the column to the
desired width.

• To clear all test results displayed, click Clear.
• Use the Preferences menu to change how some items display in the Results panel.

See also
View a report

Application panels overview

View test-related files
Files related to tests are stored in the My TekExpress\USB4 folder. Each test setup in this folder has a test setup file
and a test setup folder, both with the test setup name.

The test setup file is preceded by the TekExpress icon and usually has no visible file name extension.

Inside the test setup folder is another folder named for the DUT ID used in the test sessions. The default is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has a folder and file pair, both named for the
test session using the naming convention (date)_(time). Each session file is stored outside its matching session folder:
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Each session folder contains image files of any plots generated from running the test session. If you selected to save all
waveforms or ran tests using prerecorded waveform files, these are included here.

The first time you run a new, unsaved session, the session files are stored in the Untitled Session folder located
at ..\My TekExpress\TekExpress USB4. When you name and save the session, the files are placed in a
folder with the name that you specify. A copy of the test files stay in the Untitled Session folder until you run a new test or
until you close the USB4 application. 

See also
File name extensions

Required My TekExpress folder settings

Preferences menu
The Preferences menu is part of the Results panel display. Use the Preferences menu to change how some items display in
the Results panel. 

• To show or hide the Pass/Fail column, select Preferences > Show Pass/Fail.
• To collapse all expanded tests, select Preferences > View Results Summary.
• To expand all tests listed, select Preferences > View Results Details.
• To enable or disable the wordwrap feature, select Preferences > Enable Wordwrap.

See also
Results panel overview
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Reports panel

Reports panel overview
Use the Reports panel to view saved reports, name and save reports from the current session, select test content to include
in reports, and select report viewing options.

For information on setting up reports, see Select report options. For information on viewing reports, see View a Report.

See also
About panels

Select report options
Click the Reports button and use the Reports panel controls to select which test result information to include in the report,
and the naming conventions to use for the report. For example, always give the report a unique name or select to have the
same name increment each time you run a particular test.

Select report options before running a test or when creating and saving test setups. Report settings are included in saved
test setups.

In the Reports panel, select from the following report options: 

Table 13: Report options

Setting Description

Report Update Mode

Generate new report Creates a new report.

Table continued…
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Setting Description

Append with previous run
session

Appends the latest test results to the end of the current session’s test results report.

Include header in appended
reports

Select to include header in the appended reports.

Replace current test in
previous run session

Replaces the previous test results with the latest test results. Results from newly added
tests are appended at the end of the report.

• In previous run, current session: Select to replace the previous run of the current
session.

• In any run, any session: Select to replace the test of any previous run and session.
Selecting this option enables a browse button which displays a list of previous
sessions and runs to select.

Report Creation Settings

Report name Displays the name and location from which to open a report. The default location is at \My
TekExpress\USB4\Untitled Session. The report file in this folder gets overwritten each
time you run a test unless you specify a unique name or select to auto increment the
report name.

Change the report name or location

Do one of the following:

• In the Report Path field, type over the current folder path and name.
• Double-click in the Report Path field and then make selections from the popup

keyboard and click the Enter button.

Note:

Be sure to include the entire folder path, the file name, and the file extension.
For example: C:\Documents and Settings\your user name\My Documents\My
TekExpress\USB4\DUT001_Test_72.7.1.3.mht.

Open an existing report

Click Browse, locate and select the report file and then click View at the bottom of the
panel.

Save as type Saves a report in the selected output format (Web archive, PDF or CSV).

Auto increment report name if
duplicate

Sets the application to automatically increment the name of the report file if the
application finds a file with the same name as the one being generated. For example:
DUT001, DUT002, DUT003. This option is enabled by default.

Contents To Save

Include pass/fail info in details
table

Select to include the column labeled Test Results (indicating whether the test passed or
failed) in the report.

For details, see Report Contents in View a report.

Table continued…
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Setting Description

Include detailed results Includes detailed results in the report

Note: If Include detailed results is deselected, Include pass/fail info in details
table will be deselcted.

Include plot images Sets the application to include plots such as Eye diagrams.

Include setup configuration Sets the application to include hardware and software information in the summary box at
the top of the report. Information includes: the oscilloscope model and serial number,
probe model and serial number, the oscilloscope firmware version, SPC and factory
calibration status, and software versions for applications used in the measurements.

Include user comments Select to include any comments about the test that you or another user added in the DUT
tab of the Setup panel. Comments appear in the Comments section, under the summary
box at the beginning of each report.

View Report After Generating Automatically opens the report in a Web browser when the test completes. This option is
selected by default.

View Click to view the most current report.

Generate Report Generates a new report based on the current (most-recent) analysis results.

Save As Specify a name for the report.

View a report
The application automatically generates a report when test analysis is completed and displays the report in your default
Web browser (unless you cleared the View Report After Generating check box in the Reports panel before running the
test). If you cleared this check box, or to view a different test report, do the following: 

1. Click the Reports button.
2. Click the Browse button and locate and select the report file to view.
3. In the Reports panel, click View.

For information on changing the file type, file name, and other report options, see Select report options.

Report contents
A report shows specified test details, such as detailed results and plots, as set in the Reports panel.
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Setup configuration information

Setup configuration information is listed in the summary box at the beginning of the report. This information includes the
oscilloscope model and serial number, and software versions. To exclude this information from a report, clear the Include
Setup Configuration check box in the Reports panel before running the test.

User comments

If you selected to include comments in the test report, any comments you added in the DUT tab are shown at the top of the
report.

Test result summary

The Test Result column indicates whether a test passed or failed. If the test passed, the cell text is green. If the test failed,
the text is red. To exclude this information from a report, clear the Include Pass/Fail Results Summary check box in the
Reports panel before running the test.

See also
Results panel overview

View test-related files

Operating basics

TekExpress USB4 Automated Test Solution Software Printable Application Help 35



Running tests
Test process flow

Use the following list to set up and performing USB4 tests. 

1. Allow test instruments to warm up (~20 minutes).
2. Deskew the real-time oscilloscope.
3. Set up test equipment.
4. Verify that required instruments are connected to USB4.
5. Set DUT parameters.
6. Select tests.
7. View acquisition settings.
8. Set global signal-related parameters.
9. Select test notification preferences.
10. Select report options.
11. Check the prerun checklist
12. Click Start to Run tests.

See also
About test setups

About running tests

Deskew real-time oscilloscopes
Use the following procedure to deskew direct input SMA channels on a real time oscilloscope.

Note: DPOJET has an automatic deskew option under. Refer to your DPOJET online help for information on how
to deskew the channels.

1. Run Signal Path Compensation (SPC) on the oscilloscope.
2. Connect a SMA Power Splitter (preferred) or SMA 50 Ω coaxial “T” connector to the Fast Edge output of the

oscilloscope.
3. Connect SMA cables from each of the two channels to be deskewed to the power splitter (or SMA coaxial “T”

connector). It is best to use matched cables when making high speed serial measurements. It is important to use
the same cables during deskew that you will use for subsequent measurements.

4. Select Default Setup, and then select Autoset on the oscilloscope front panel.
5. Set the oscilloscope for 70% to 90% full screen amplitude on both channels. Center both traces so that they overlap.
6. Make sure that volts/div, position, and offset are identical for the two channels being deskewed.
7. Set the time/div to approximately 100 ps/div or less, with sample rate at 1 ps/pt. These settings are not critical, but

should be close.
8. Set the horizontal acquisition mode to average, which provides a more stable display.
9. Select Deskew from the Vertical menu.
10. Verify that the reference channel (typically CH1 or CH2) is set to 0 ps deskew.
11. In the deskew control window, select the channel to deskew (typically CH3 or CH4). Adjust the deskew to overlay the

rising edge as best as possible.

Note: Typical values are in the 10’s of ps or less with cables connected directly from Fast Edge to SMA inputs. If
you are using a switch box (for example, Keithley), deskew the complete path from where the test fixture connects,
through the switch, and into the oscilloscope. Deskew values in these cases may be as much as 30 ps or more.

Running tests
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Note: There can be significant differences in the skew between two TCA-SMA adapters. If you find that a system
requires a very large correction, obtain a pair of TCA-SMA adapters that closely match each other to reduce the
amount of correction.

Note: TekExpress retains the user configured Deskew values, and does not override the values during test runs.

Instrument and DUT connection setup
Click the Setup > Test Selection > Schematic button to open a PDF file that shows the compliance test setup diagrams
(instrument, DUT, and cabling) for supported testing configurations. 

See also
Minimum system requirements

View connected instruments

Running tests
After selecting and configuring tests, review the prerun checklist and then click Start to run the tests. While tests are
running, you cannot access the Setup or Reports panels. To monitor the test progress, switch back and forth between the
Status panel and the Results panel.

The application displays a report when the tests are complete. While the tests are running, other applications may display
windows in the background. The TekScope application takes precedence over other applications, but you can switch to
other applications by using the Alt + Tab key combination. To keep the TekExpress USB4 application on top, select Keep
On Top from the TekExpress Options menu.

See also
Configuration tab parameters

Prerun checklist
Do the following before you click Start to run a test: 

Note: If this is the first time you are running a test on the application, make sure that you have done the steps in
Required My TekExpress folder settings before continuing.

1. Make sure that all the required instruments are properly warmed up (approximately 20 minutes).
2. Perform Signal Path Compensation (SPC)

a. On the oscilloscope main menu, select the Utilities menu.
b. Select Instrument Calibration.
c. Follow the on-screen instructions.

3. Verify that the correct instruments are connected (oscilloscope and signal sources):

a. In TekExpress USB4, click Setup > Configuration.
b. Click Global Settings.
c. In the Instruments Detected list, verify that the test setup instruments are shown. If they are not, click the arrow

button to list and select from all detected instruments. If the required instrument is still not listed, use the TekExpress
Instrument Control Settings dialog box to scan for and detect instruments (see View connected instruments).

See also
Instrument and DUT connection setup

Running tests

TekExpress USB4 Automated Test Solution Software Printable Application Help 37



Saving and recalling test setup files
Test setup files overview

Saved test setup information (such as the selected oscilloscope, general parameters, acquisition parameters, measurement
limits, waveforms (if applicable), and other configuration settings) are all saved under the setup name at X:\USB4.

Use test setups to: 

• Run a new session, acquiring live waveforms, using a saved test configuration.
• Create a new test setup based on an existing one.
• View all the information associated with a saved test, including the log file, the history of the test status as it executed,

and the results summary.
• Run a saved test using saved waveforms.

See also
Save a test setup

Recall a saved test setup

Save a test setup file
Save a test setup before or after running a test to save the test settings. Create a new test setup from any open setup or
from the default setup. When you select the default test setup, all parameters are returned to the application’s default
values.

To immediately save the current setup session to the same setup name, select Options > Save Test Setup.

To immediately save the current setup session to a new setup name, select Options > Save Test Setup As.

To create and save a new setup from the default test setup: 

1. Select Options > Default Test Setup to return the application to default test settings.
2. Click the application Setup button and use the setup tabs to set required options and parameters (DUT, Test Selection,

and so on).
3. Click the application Reports button and set your report options.
4. Optional: Click Start to run the test and verify that it runs correctly and captures the specified test information and

reports. If it does not, edit the parameters and repeat this step until the test runs to your satisfaction.

Running the test helps verify that all parameters are set correctly, but it is not a necessary step.
5. Select Options > Save Test Setup. Enter the file name for the new setup file. The application saves the file to

X:\USB4\<session_name>.

See also
Test process flow

View test-related files

Configuration tab parameters

Open (load) a saved test setup file
These instructions are for recalling saved test setups. 

1. Select Options > Open Test Setup.
2. Select the setup from the list and click Open. Setup files must be located at X:\USB4.

Saving and recalling test setup files
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See also
About test setups

Create a new test setup based on an existing one

Test setups overview

Run a saved test in prerecorded mode

Run a saved test in prerecorded mode
Use this option to re-run a complete test using just the oscilloscope and the saved test setup files, if you selected to save
the captured waveforms when you originally ran the saved test. 

Note: When you run a saved test in prerecorded mode and then save it under the same name, the test results are
saved in a new session folder named for the date and time of the session. Any test settings that you changed for
the session are saved as a new test session file and be paired with a folder of the same name. Example. When
you open a test setup that has multiple sessions and you select a session from the Run session list in the DUT tab,
the settings associated with that test session are restored.

Each test session folder has a matching test session file that stores the individual test settings for that session.

1. Use the Options menu to Open a saved test setup file
2. Select Setup > DUT and then select Use pre-recorded waveform files. A Run session drop-down list appears that

displays the previous saved sessions for this test.
3. Select the session to run. NOTE. If you select a session for which no waveform files were saved, you will receive an

error message. You have selected to use Pre-recorded waveforms. The pre-recorded waveform(s) are not specified for
the following Acquisition(s).

4. Click Start.
5. To save the test results, session settings, and related files, save the test setup before selecting another test setup or

exiting the application.

See also
About test setups

Create a new test setup based on an existing one

Test setups overview

Create a new test setup file based on an existing one
Use this method to create a variation on a test setup without having to create the setup from the beginning.

1. Select Options > Open Test Setup.
2. Select a setup from the list and then click Open.
3. Use the Setup and Reports panels to modify the parameters to meet your testing requirements.
4. Select Options > Save Test Setup As.
5. Enter a test setup name and click Save.

See also
About test setups

Set DUT parameters

Select acquisitions
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TekExpress USB4 Automated Test Solution Software Printable Application Help 39



SCPI commands
About SCPI command

You can use Standard Commands for Programmable Instruments (SCPI) to communicate with the TekExpress application.

Socket configuration for SCPI commands
This section describes the steps for TCP/IP socket configuration and TekVISA configuration to execute the SCPI
commands.

TCP/IP socket configuration
1. Click Start > Control Panel > System and Security > Windows Firewall > Advanced settings.

2. In Windows Firewall with Advanced Security menu, select Windows Firewall with Advanced Security on Local
Computer > Inbound Rules and click New Rule…
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3. In New Inbound Rule Wizard menu

a. Select Port and click Next.

b. Select TCP as rule apply and enter 5000 for Specific local ports and click Next.
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c. Select Allow the connection and click Next.

d. Select Domain, Private, Public and click Next.
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e. Enter Name, Description (optional), and click Finish.

4. Check whether the Rule name is displayed in Windows Firewall with Advanced Security menu > Inbound Rules.

TekVISA configuration
1. Click Start > All Programs > TekVISA > OpenChoice Instrument Manager.
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2. Click Search Criteria. In Search Criteria menu, click LAN to Turn-on. Select Socket from the drop-down list, enter the

IP address of the TekExpress device in Hostname and type Port as 5000. Click  to configure the IP address
with Port.

Enter the Hostname as 127.0.0.1 if the TekVISA and TekExpress application are in the same system, else enter the IP
address of the TekExpress application system.
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3. Click Search to setup the TCPIP connection with the host. Check whether the TCPIP host name is displayed in
OpenChoice Instrument Manager > Instruments.

4. Double-click OpenChoice Talker Listener and enter the Command *IDN? in command entry field and click Query.
Check that the Operation is successful and Talker Listener Readout displays the Command / Data.
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TEKEXP:*IDN?
This command queries the active TekExpress application name running on the oscilloscope. 

Syntax
TEKEXP:*IDN?\n
Inputs
NA

Outputs
Returns active TekExpress application name running on the oscilloscope.

TEKEXP:*OPC?
This command queries the execution status of the last executed command. 

Syntax
TEKEXP:*OPC?\n
Inputs
NA
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Outputs
0 - last command execution is not complete

1 - last command execution is complete

TEKEXP:ACQUIRE_MODE
This command sets the acquire mode as live or pre-recorded.

Syntax
TEKEXP:ACQUIRE_MODE {LIVE | PRE-RECORDED}\n
Inputs
{LIVE | PRE-RECORDED}
Outputs
NA

TEKEXP:ACQUIRE_MODE?
This command queries the acquire mode type.

Syntax
TEKEXP:ACQUIRE_MODE?\n
Inputs
NA
Outputs
{LIVE | PRE-RECORDED}

TEKEXP:EXPORT
This command returns all the bytes of data to the specified file. 

Syntax Outputs
TEKEXP:EXPORT REPORT\n Returns the report file in bytes
TEKEXP:EXPORT WFM,"<FileName>"\n Returns the specified waveform file in bytes
TEKEXP:EXPORT IMAGE,"<FileName>"\n Returns the specified image file in bytes

Inputs
FileName - Specifies the file name

TEKEXP:INFO?
This command queries the information about the file(s).

Syntax Outputs
TEKEXP:INFO?
REPORT\n

<ReportFileSize>,"<ReportFileName.mht>"

Table continued…
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Syntax Outputs
TEKEXP:INFO? WFM
\n

<WfmFile1Size>,"<WfmFileName1.wfm>";<WfmFile2Size>,"<WfmFileName2.wfm>";...

TEKEXP:INFO?
IMAGE\n

<Image1FileSize>,"<Image1FileName>";<Image2FileSize>,"<Image2FileName>" ;...

TEKEXP:INSTRUMENT
This command sets the value for the selected instrument type. 

Syntax
TEKEXP:INSTRUMENT "<InstrumentType>",<Value>"\n
Inputs
InstrumentType
Value

Tip: Check Command parameters list section for InstrumentType and Value parameters.

Outputs
NA

TEKEXP:INSTRUMENT?
This command queries the instrument selected for the specified instrument type. 

Syntax
TEKEXP:INSTRUMENT? "<InstrumentType>"\n
Inputs
InstrumentType

Tip: Check Command parameters list section for InstrumentType parameters.

Outputs
Returns the instrument selected for the specified instrument type

TEKEXP:LASTERROR?
This command queries the last error string occurred for the current TCP session. If there are no errors since startup, or
since the last call to TEKEXP:LASTERROR?\n, this command returns an empty string.

Syntax
TEKEXP:LASTERROR?\n
Inputs
NA
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Outputs
<string>

TEKEXP:LIST?
This command queries the list of available device, suite, test, version or instrument. 

Syntax Outputs
TEKEXP:LIST? DEVICE\n Returns the list of available device(s) as comma separated

values.
TEKEXP:LIST? SUITE\n Returns the list of available suite(s) as comma separated

values.
TEKEXP:LIST? TEST\n Returns the list of available test(s) as comma separated

values.
TEKEXP:LIST? VERSION\n Returns the list of available version(s) as comma separated

values.
TEKEXP:LIST?
INSTRUMENT,"<InstrumentType>"\n

Returns the list of available instruments' for the given
Instrument type as comma separated values.

Note: This command returns the list of items within double quotes (""). Iterate the receive procedure until the list
ends with double quotes otherwise the next query commands won’t work as expected.

Inputs
InstrumentType

Tip: Check Command parameters list section for InstrumentType parameters.

TEKEXP:POPUP
This command sets the response to the active popup shown in the application.

Syntax
TEKEXP:POPUP “<PopupResponse>”\n
Inputs
PopupResponse
Outputs
NA

TEKEXP:POPUP?
This command queries the active popup information shown in the application.

Syntax
TEKEXP:POPUP?\n
Inputs
NA
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Outputs
Returns the active popup information in the application.

TEKEXP:REPORT
This command generates the report for the current session. 

Syntax
TEKEXP:REPORT GENERATE\n
Inputs
GENERATE
Outputs
NA

TEKEXP:REPORT?
This command queries the queried header field value in the report.

Syntax
TEKEXP:REPORT? “<HeaderField>”\n
Inputs
HeaderField - Specifies to return the measured value for the indicated test.

Tip: Check Report for HeaderField parameters.

Outputs
Returns the queried header field value in the report

TEKEXP:RESULT?
This command queries the result available in report summary/details table.

Syntax Outputs
TEKEXP:RESULT? "<TestName>"\n Return Pass/Fail status of the test.
TEKEXP:RESULT?
"<TestName>","<ColumnName>"\n

Returns all the row values of the specified column for the test.

TEKEXP:RESULT?
"<TestName>","<ColumnName>",<RowNu
mber>\n

Returns the column value for the specified row number

Inputs
TestName - Specifies the name of the test for which to obtain the test result value.

ColumnName - Specifies the column name for the measurement

RowNumber - Specifies the row number of the measurement
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Tip: Check Results panel for TestName, ColumnName, and RowNumber parameters.

TEKEXP:SELECT
This command selects the device, suite, version, or test. 

Syntax
TEKEXP:SELECT <string1>,<string2>,<string4>\n
TEKEXP:SELECT TEST,<string3>,<string4>\n
Inputs
<string1> = {DEVICE | SUITE | VERSION}
<string2> = {DeviceName | SuiteName | VersionName}
<string3> = {“<TestName>"| ALL| REQUIRED }
<string4> = {TRUE | FALSE}

Tip: Check Command parameters list section for DeviceName, SuiteName, VersionName, and TestName
parameters.

Outputs
NA

TEKEXP:SELECT?
This command queries the name of the selected device, suite, version, or test. 

Syntax
TEKEXP:SELECT? {DEVICE | SUITE | TEST | VERSION}\n
Inputs
{DEVICE | SUITE | TEST | VERSION}
Outputs
Returns the name of the selected device, suite, version, or test.

TEKEXP:SETUP
This command sets the value of the current setup.

Syntax Outputs

TEKEXP:SETUP DEFAULT\n Restore to default Setup

TEKEXP:SETUP OPEN,"<SessionName>"\n Open the session

TEKEXP:SETUP SAVE\n Saves the already existing modified session

TEKEXP:SETUP SAVE,"<SessionName>"\n Save the session
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Inputs
SessionName - The name of the session

TEKEXP:STATE
This command sets the execution state of the application.

Syntax
TEKEXP:STATE {RUN | STOP | PAUSE | RESUME}\n
Inputs
{RUN | STOP | PAUSE | RESUME}
Outputs
NA

TEKEXP:STATE?
This command queries the current setup state. 

Syntax Outputs
TEKEXP:STATE? RUNNING | PAUSED | WAIT | ERROR | READY
TEKEXP:STATE? SETUP SAVED | NOT_SAVED

TEKEXP:VALUE
This command sets the value of parameters of type General, Acquire, Analyze, or DUTID. 

Syntax
TEKEXP:VALUE GENERAL,"<ParameterName>",“<Value>”\n
TEKEXP:VALUE ACQUIRE,“<TestName>","<AcquireType>", "<ParameterName>",
“<Value>”\n
TEKEXP:VALUE ANALYZE,“<TestName>","<ParameterName>".“<Value>”\n
TEKEXP:VALUE DUTID,“<Value>”\n
TEKEXP:VALUE VERBOSE,{TRUE | FALSE}\n
TEKEXP:VALUE WFMFILE,<Test_Name>,<Aquire_Type>,<FilesName1$FileName2>\n
Inputs
ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

Value - Specifes the value to set

FilesName1$FileName2 - Specifies the waveform file name

TRUE - Pop-ups are enabled

FALSE - Pop-ups are disabled
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Tip: Check Command parameters list section for ParameterName, AcquireType, and Value parameters.

Outputs
NA

TEKEXP:VALUE?
This command queries the value of the parameter for type General, Acquire, Analyze, or DUTID.

Syntax Outputs
TEKEXP:VALUE?
GENERAL,"<ParameterName>"\n

Returns the value of Parameter for type GENERAL

TEKEXP:VALUE? ACQUIRE,“<TestName>",
"<AcquireType>","<ParameterName>"\n

Returns the value of Parameter for type ACQUIRE

TEKEXP:VALUE? ANALYZE,
“<TestName>","<ParameterName>"\n

Returns the value of Parameter for type ANALYZE

TEKEXP:VALUE? DUTID\n Returns the DUTID value
TEKEXP:VALUE?
WFMFILE,<Test_Name>,<Aquire_Type>\n

Returns the waveform file name

TEKEXP:VALUE? VERBOSE Returns the verbose mode type

Inputs
ParameterName - Specifies the parameter name

TestName - Specifies the test name

AcquireType - Specifies the acquire type

TRUE - Pop-ups are enabled

FALSE - Pop-ups are disabled

Tip: Check Command parameters list section for ParameterName and AcquireType parameters.

Outputs
Returns the value of Parameter for type GENERAL | ACQUIRE | ANALYZE | DUTID.

Command parameters
This section provides the parameters list for the SCPI commands.

TekExpress USB4 command parameters

ParameterName and Value for DUT, Test selection, Acquisition, Configuration, and Preferences
tabs
Specifies the ParameterName and Value for DUT, Test selection, Acquisition, Configuration, and Preferences tabs
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Table 14: ParameterName and Value for DUT tab

ParameterName Value
InstrumentType Specifies the instrument type.

Valid value is Real Time Scope.

DeviceName Specifies the acquire mode parameter: USB4
SuiteName Device

Host

DataRate Rounded 10 Gbps Option
button

Included

Excluded

DataRate Rounded 20 Gbps Option
button

Included

Excluded

Lane Selection Lane0

Lane1

DUT Automation Manual

Automated

Embed/De-embed port selection for:
Port Selection 1 Port 1

Port Selection 2 Port 2

Port 3

Port Selection 3 Port 2

Port 3

Port Selection 4 Port 4
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Table 15: ParameterName and Value for Test Selection tab

ParameterName Description
Specifies the test measurement name. Selects\deselects the given test name.

Valid values are:

• TRUE
• FALSE

TP2

• Minimum Unit Interval 10 G
• SSC Down Spread Range 10 G
• SSC Down Spread Rate 10 G
• SSC Phase Deviation 10 G
• SSC Slew Rate 10 G
• Rise Fall Time 10 G
• Electrical Idle 10 G
• TJ (Total Jitter)

TJ using PRBS15 10 G

TJ using SQ2 10 G
• UJ (Uncorrelated Jitter) 10 G
• UDJ (Uncorrelated Deterministic Jitter) 10 G
• DDJ (Data Dependent Jitter) 10 G
• UDJ_LF (Low Frequency Uncorrelated Deterministic Jitter) 10 G
• DCD (Duty Cycle Distortion) 10 G
• AC Common Mode 10 G
• Eye Diagram TP2 10 G

TP3

• Total Jitter TP3

TJ TP3 using PRBS15 10 G

TJ TP3 using SQ2 10 G
• UJ TP3 (Uncorrelated Jitter TP3) 10 G
• DJ TP3 (Uncorrelated Deterministic Jitter TP3) 10 G
• Eye Diagram TP3 10 G

Table continued…

SCPI commands

TekExpress USB4 Automated Test Solution Software Printable Application Help 55



ParameterName Description
Transmitter Equalization

• Preset 0 10 G
• Preset 1 10 G
• Preset 2 10 G
• Preset 3 10 G
• Preset 4 10 G
• Preset 5 10 G
• Preset 6 10 G
• Preset 7 10 G
• Preset 8 10 G
• Preset 9 10 G
• Preset 10 10 G
• Preset 11 10 G
• Preset 12 10 G
• Preset 13 10G
• Preset 14 10G
• Preset 15 10G

Selects\deselects the given test name.

Valid values are:

• TRUE
• FALSE

TP2

• Minimum Unit Interval 20 G
• SSC Down Spread Range 20 G
• SSC Down Spread Rate 20 G
• SSC Phase Deviation 20 G
• SSC Slew Rate 20 G
• Rise Fall Time 20 G
• Electrical Idle 20 G
• TJ (Total Jitter)

TJ using PRBS15 20 G

TJ using SQ2 20 G
• UJ (Uncorrelated Jitter) 20 G
• UDJ (Uncorrelated Deterministic Jitter) 20 G
• DDJ (Data Dependent Jitter) 20 G
• UDJ_LF (Low Frequency Uncorrelated Deterministic Jitter) 20 G
• DCD (Duty Cycle Distortion) 20 G
• AC Common Mode 20 G
• Eye Diagram TP2 20 G

Table continued…
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ParameterName Description
TP3

• Total Jitter TP3

TJ TP3 using PRBS15 20 G

TJ TP3 using SQ2 20 G
• UJ TP3 (Uncorrelated Jitter TP3) 20 G
• DJ TP3 (Uncorrelated Deterministic Jitter TP3) 20 G
• Eye Diagram TP3 20 G

Selects\deselects the given test name.

Valid values are:

• TRUE
• FALSE

Transmitter Equilization

• Preset 0 20 G
• Preset 1 20 G
• Preset 2 20 G
• Preset 3 20 G
• Preset 4 20 G
• Preset 5 20 G
• Preset 6 20 G
• Preset 7 20 G
• Preset 8 20 G
• Preset 9 20 G
• Preset 10 20 G
• Preset 11 20 G
• Preset 12 20 G
• Preset 13 20 G
• Preset 14 20 G
• Preset 15 20 G

Table 16: ParameterName and Value for Acquisition tab

ParameterName Value
Acquisition and Save Options Saves the acquisitions and waveforms: Save All Waveforms Before Analysis

Signal Validation Promput when signal fails

Use signal as is - Dont Check

Skip test if signal validation fails

Table 17: ParameterName and Value for Configuration tab

ParameterName Value
Mode Compliance Mode
Global Settings Instruments Detected: Real Time Scope
Measurements Displays the selected measurements to configure
Table continued…
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ParameterName Value
Gen2 CTLE Index • 0 db

• 1 db
• 2 db
• 3 db
• 4 db
• 5 db
• 6 db
• 7 db
• 8 db
• 9 db

Gen3 CTLE Index • 0 db
• 1 db
• 2 db
• 3 db
• 4 db
• 5 db
• 6 db
• 7 db
• 8 db
• 9 db

Gen3 Perform with DFE Included

Excluded

Gen2 Perform with DFE Included

Excluded

Gen2 CTLE Option Fixed

Optimize

Gen3 CTLE Option Fixed

Optimize

Table 18: ParameterName and Value for Preferences tab

ParameterName Value

Auto close Warnings and informations during Sequencing

Auto close after <no> Seconds

Included

Excluded

Value to be given in seconds

Table continued…
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ParameterName Value

Auto close Error Messages during Sequencing. Show in

Reports.

Auto close after <no> Seconds

Included

Excluded

Value to be given in seconds

Show messages with a beep sound. Included

Excluded

Table 19: ParameterName and Value for General

ParameterName Value
PortSelection1 Port1

PortSelection2 • Port2
• Port3

PortSelection3 • Port2
• Port3

PortSelection4 Port4
Gen2 CTLE Option • Fixed

• Optimize

Gen2 Ctle Index • 0 db
• 1 db
• 2 db
• 3 db
• 4 db
• 5 db
• 6 db
• 7 db
• 8 db
• 9 db

Gen2 Perform DFE Checkbox • Included
• Excluded

Table continued…
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ParameterName Value
Gen3 Ctle Option • Fixed

• Optimize
• 0 db
• 1 db
• 2 db
• 3 db
• 4 db
• 5 db
• 6 db
• 7 db
• 8 db
• 9 db

Gen3 Perform DFE Checkbox • Included
• Excluded

PresetGen2 The following selects the preset calibration measurements:

• P0
• P1
• P2
• P3
• P4
• P5
• P6
• P7
• P8
• P9
• P10
• P11
• P12
• P13
• P14
• P15

Table continued…
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ParameterName Value
PresetGen3 The following selects the preset calibration measurements:

• P0
• P1
• P2
• P3
• P4
• P5
• P6
• P7
• P8
• P9
• P10
• P11
• P12
• P13
• P14
• P15

Example 1: TEKEXP: VALUE
GENERAL, "PresetGen2,
"P1_P11_P7".

This selects presets 1, 7, and 11 from preset cal Gen2

Example 2: TEKEXP: VALUE
GENERAL, "PresetGen2,
"P1_P11_P7_P8".

Value Should contain the following:

If preset 8 needs to be added along with the selected presets, then the existing
presets along with preset 8 must be specified in the command.

Data+ • CH1
• CH2
• CH3
• CH4

Data- • CH1
• CH2
• CH3
• CH4

Report Update Mode • New
• Append
• Replace
• Replace Any

Email when test setup change in
needed

• True
• False

Append Report • True
• False

Table continued…
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ParameterName Value
Auto increment report name if duplicate • True

• False

Include pass/fail results summary • Included
• Excluded

Include detailed results • True
• False

Include plot images • True
• False

Include setup configuration • True
• False

Include user comments • True
• False

Include Header in apended reports • True
• False

Include report at the end • True
• False

Save As Type • PDF (*.pdf;)
• Web Archive (*.mht;*.mhtml)
• CSV (*.csv;)

Report Generation Template Path C:\ProgramFiles\Tektronix\TekExpress\TekExpressUSB4\ReportGenerator
\TekExpress_Template_GroupByTestName_CSV.xsl

Report Path X:\USB4\Reports\USB4.csv
View Report After Generating • True

• False

Report Group Mode • Test Name
• Lane Name

Examples
This section provides the examples for the SCPI commands.

Example Description
TEKEXP:*IDN? It returns the active TekExpress application name running on

the scope.
TEKEXP:*OPC? It returns the last command execution status, if status is

executed it returns "1" else "0".
Table continued…
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Example Description
TEKEXP:SELECT TEST + ParameterName+ "," + value
TEKEXP:ACQUIRE_MODE PRE-RECORDED It sets the acquire mode as pre-recorded.
TEKEXP:ACQUIRE_MODE? It returns LIVE when acquire mode is set to live or it returns

pre-recorded when acquire mode is set to pre-recorded.

TEKEXP:EXPORT REPORT It returns the report file in bytes. This can be written into
another file for further analysis.

TEKEXP:INFO? REPORT It returns “100,”ReportFileName.mht”", when 100 is the file
size in bytes for the filename ReportFileName.

TEKEXP:INFO? WFM It returns “100,“WfmFileName1.wfm”";“200,
“WfmFileName2.wfm”" when 100 is the filesize in bytes for
the filename WfmFileName1.wfm and 200 is the file size in
bytes for the filename WfmFileName2.wfm.

TEKEXP:INSTRUMENT "Real Time
Scope",DPO73304SX ( GPIB8::1::INSTR)

It sets the instrument value as
DPO73304SX( GPIB8::1::INSTR ) for the selected
instrument type Real Time Scope.

TEKEXP:INSTRUMENT? "Real Time Scope" It returns "DPO73304SX ( GPIB8::1::INSTR ), when
DPO73304SX ( GPIB8::1::INSTR )" is the selected
instrument for the instrument type Real Time Scope.

TEKEXP:LASTERROR? It returns ERROR: INSTRUMENT_NOT_FOUND, when no
instrument is found.

TEKEXP:LIST? DEVICE It returns "USB4" when TX-Device, RXDevice are the
available device.

TEKEXP:LIST? INSTRUMENT,"Real Time
Scope"

It returns "DPO73304SX ( GPIB8::1::INSTR ),
DPO73304DX ( TCPIP:: 134.64.248.91::INSTR )" when
DPO73304SX ( GPIB8::1::INSTR ), DPO73304DX
( TCPIP::134.64.248.91::INSTR ) are the list of available
instruments.

TEKEXP:MODE COMPLIANCE It sets the execution mode as compliance or User Defined.
TEKEXP:MODE? It returns COMPLIANCE when the execution mode is

compliance or It returns USER-DEFINED when the
execution mode is user defined.

TEKEXP:POPUP OK It sets OK as the response to active popup in the
application.

TEKEXP:POPUP? It returns "OK", when OK is the active popup information
shown in the application.

TEKEXP:REPORT GENERATE It generates report for the current session.
TEKEXP:REPORT? "Scope Model Number" Returns "DPO73304SX" when DPO73304SX is the scope

model.
TEKEXP:REPORT? DUT ID It returns "DUT001" when DNI_DUT001 is the DUT ID.
TEKEXP:RESULT? "1.1.1 Data Lane LP-
TX Thevenin Output High Level
Voltage (VOH)"

It returns Pass when the test result is Pass.

Table continued…
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Example Description
TEKEXP:RESULT? "1.1.1 Data Lane LP-
TX Thevenin Output High Level
Voltage (VOH)","Margin",1

It returns the 2nd Sub measurements Margin L and H
values.

TEKEXP:SELECT DEVICE, USB4, TRUE It selects USB4.
TEKEXP:SELECT? DEVICE
TEKEXP:SETUP DEFAULT It restores the application to default setup.
TEKEXP:STATE STOP It stops the test execution.
TEKEXP:STATE? It returns as READY when the application is ready to run

next measurement.
TEKEXP:STATE? SETUP It returns as NOT_SAVED when the current setup is not

saved else it returns SAVED.
TEKEXP:VALUE GENERAL,"Test
Mode","Escape"

It sets the Test Mode parameter value to Escape .

TEKEXP:VALUE? GENERAL,"Test Mode" It returns "Escape" when Escape is the Test Mode value.
TEKEXP:SELECT TEST ,"1.1.1 Data Lane
LP-TX Thevenin Output High Level
Voltage (VOH)",True

Execute this command to select an individual test. This
command will select "1.1.1 Data Lane LP-TX Thevenin
Output High Level Voltage (VOH)" test in the Signal Test tab.

TEKEXP:VALUE ACQUIRE,"1.1.1 Data
Lane LP-TX Thevenin Output High
Level Voltage (VOH)","Data Lanes
Acquisition In Escape Mode with Data
As Trigger","Sample Rate (GS/
s)",12.5

It sets Sample Rate Parameter value to 12.5.

TEKEXP:VALUE? ACQUIRE,"1.1.1 Data
Lane LP-TX Thevenin Output High
Level Voltage (VOH)","Data Lanes
Acquisition In Escape Mode with Data
As Trigger","Sample Rate (GS/s)"

It returns the value of Sample Rate,
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Reference
Handle error codes

The return value of the remote automations at the server-end is OP_STATUS, which changes to a string value depending
on its code, and is returned to the client. The values of OP_STATUS are as follows:

Code Value Description

-1 FAIL The operation failed

1 SUCCESS The operation succeeded

2 NOT FOUND Server not found

3 LOCKED The server is locked by another client, so the operation cannot be performed

4 UNLOCK The server is not locked; lock the server before performing the operation

0 NULL Nothing

Note: The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another client".

If the session is unlocked, the application displays "Lock session to execute the command".

If the server is not found, the application displays " Server not found-Disconnect!".

If the fail condition is not one of the above types, the application displays "Failed".

Reference
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