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Welcome
The TekExpress® Thunderbolt Automated Test Solution Software application (referred as Thunderbolt in the rest of the document) provides
an automated, simple, and efficient way to test Thunderbolt transmitter interfaces and devices for Thunderbolt compliance through
DPOJET for better margin, debugging, and analysis.

Key Features

• Automated solution for Thunderbolt connectors which support Thunderbolt specification and CTS (Gen2 & Gen3).
• SigTest compliance integration for CTS Gen2 and Gen3 device and host.
• Dual lane supports for CTS Gen2 and Gen3 device and host.
• DPOJET plug-in for connectors which support Thunderbolt specification and CTS (Gen2 & Gen3) with setup files and MOI.
• Support embedding channels (2 m and 0.8 m) and their respective filter files for connectors.
• Manual support for compliance to debug with DPOJET Thunderbolt and CIO plug-ins.

Welcome
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Getting help and support
Product documents
Use the product documents for more information on the application functions, understand the theory of operation, how to remotely program
or operate the application, and do other tasks.

Table 1: TekExpress Application documents

To learn about Use this document
How to use the application

How to remotely control the instrument
TekExpress Thunderbolt Help

PDF version of this document can be downloaded from www.tek.com/downloads

Compiled HTML (CHM) version is integrated with the application. Press F1 key from the
keyboard to start the help.

Tektronix Part Number: 077-xxxx-xx

Conventions
This application help uses the following conventions:

• The term "Application," and "Software" refers to the TekExpress Thunderbolt application.
• The term “DUT” is an abbreviation for Device Under Test.
• The term “select” is a generic term that applies to the two methods of choosing a screen item (button control, list item): using a mouse

or using the touch screen.
• A Note identifies important information.

Table 2: Icons used in the help

Icon Description
This icon identifies important information

This icon identifies conditions or practices that could result in loss of data.

This icon identifies additional information that will help you use the application more
efficiently.

Getting help and support
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Technical support
Tektronix values your feedback on our products. To help us serve you better, please send us your suggestions, ideas, or comments on
your application or oscilloscope. Contact Tektronix through mail, telephone, or the Web site. See Contacting Tektronix at the front of this
document for contact information.

When you contact Tektronix Technical Support, please include the following information (be as specific as possible): 

General information
• All instrument model numbers
• Hardware options, if any
• Modules used
• Your name, company, mailing address, phone number, FAX number
• Please indicate if you would like to be contacted by Tektronix about your suggestion or comments.

Application specific information
• Software version number
• Description of the problem such that technical support can duplicate the problem
• If possible, save the setup files for all the instruments used and the application
• If possible, save the TekExpress setup files, log.xml, *.TekX (session files and folders), and status messages text file

Getting help and support
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Getting started
Hardware requirements

Minimum system requirements
The following table describes the minimum system requirements for the TekExpress Thunderbolt application. 

Table 3: Minimum system requirements

Instruments Description

Oscilloscope Refer Supported instruments
Processor Same as the oscilloscope
Operating System Same as the oscilloscope:

• Windows 10 (64-bit only) SP1 Windows 10 user account settings

Memory Same as the oscilloscope
Hard Disk Same as the oscilloscope
Display Super VGA resolution or higher video adapter (800 x 600 minimum video resolution for small

fonts or 1024 x 768 minimum video resolution for large fonts). The application is best viewed at 96
dpi display settings 1

Firmware TekScope 10.12.0 and above (for Windows 10)
Software • Microsoft .NET 4.0 Framework

• DPOJET Jitter and Eye Analysis Tool (version 10.3.0 or higher) with Advanced Jitter and Eye
analysis (DJA option) installed.

• Microsoft Internet Explorer or other Web browser for viewing reports.
• Adobe Reader software 7.0 or later for viewing portable document format (PDF) files.
• Serial Data Link Analysis (SDLA) software, version 3.0.12 or later, for Channel De-Embed, for

custom filter development.
• SigTest pre-requisites:

• MATLAB runtime compiler MCR 9.11
• Set the environment variable after installing MATLAB Runtime 9.11

• Variable: Path
• Value: C:\Program Files\MATLAB\MATLAB Runtime\v911\runtime\win64

• Copy USB4_SigTest.exe app in the C:\USB4_SigTest location

1 If TekExpress is running on an instrument that has a video resolution less than 800x600, connect and configure a second monitor to the instrument.

Getting started
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Supported instruments
Table 4: Required equipment

Resource Model supported

Real-time oscilloscope Tektronix DPO, DX, and SX series oscilloscopes (Windows 10 OS):

• 21 GHz bandwidth is suitable for Gen2 Rounded (10 Gbps), Gen2 Legacy (10.3125 Gbps), Gen3
Rounded (20 Gbps), Gen3 Legacy (20.625 Gbps) measurements

Probes Two TCA-SMA cables

Two SMP-SMA cables

Thunderbolt fixtures • Intel approved Wilder-Tech fixtures for Thunderbolt compliance testing.
• The fixture set includes Tx Host and Device testing.

Connector Type Type C Symmetrical connector on both side

Ultra sync cable Supports DPO SX series oscilloscope with bandwidth of 33, 50, 59, and 70 GHz and is only applicable for
dual-stack.

See also
Minimum system requirements

Software requirements

Downloading and installing the software
Complete the following steps to download and install the latest TekExpress Thunderbolt application.

1. Go to www.tek.com.
2. Click Downloads. In the Downloads menu, select DOWNLOAD TYPE as Software and enter the application name in the MODEL OR

KEYWORD field and click SEARCH.

3. Select the latest version of software and follow the instructions to download the software. Copy the executable file into the
oscilloscope.

4. Double-click the executable and follow the on-screen instructions.

The software is installed at C:\Program Files\Tektronix\TekExpress\TekExpress Thunderbolt3.
5. Select Application > TekExpress Thunderbolt from the Oscilloscope menu, to open the application.

Getting started

12

http://www.tek.com


Activate the license
Activate the license using the Option Installation wizard in the TekScope application:

1. In the TekScope application menu bar, click Utilities > Option Installation. The TekScope Option Installation wizard opens.
2. Push the F1 key on the oscilloscope keyboard to open the Option Installation help topic.
3. Follow the directions in the help topic to activate the license.

View software version and license key details
To view version information of the application, click Options > About TekExpress.

Required windows 10 user account setting
Windows 10 instruments need to have the User Account Control Settings set to Never Notify. To set User Account Control Settings:

1. Go to Control Panel > User Accounts > Change User Account Control settings.
2. Set the sliding control to Never Notify as shown in the image, and click OK.

Windows 10

Getting started
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See also
Supported oscilloscopes

Verify application installation
To verify the installation was successful:

1. Open the TekScope application.
2. Click the Analyze menu.
3. Verify that TekExpress Thunderbolt is listed in the Analyze menu.
4. Click TekExpress Thunderbolt to open the application.

Verify that the application opens successfully.

See also
Activate the license on page 13

Required my TekExpress folder settings on page 14

Required my TekExpress folder settings
Before you run tests for the first time, Refer Set my TekExpress folder permissions on page 15 for the folder permission. 

See also
Application directories on page 105

File name extensions on page 106

Getting started
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Set my TekExpress folder permissions
Follow the steps to ensure, you have read and write access to the My TekExpress folder and also verify that the folder is not set to be
encrypted: 

1. Right-click the folder and select Properties.
2. Select the General tab, and then click Advanced.
3. In the Advance Attributes dialog box, ensure that the option Encrypt contents to secure data is not selected.

4. Click the Security tab and verify that the correct read and write permissions are set.

See also
Application directories on page 105

File name extensions on page 106

View test-related files

Getting started
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Setting up the test environment
Test process flow
Use the following list to set up and performing Thunderbolt tests. 

1. Allow test instruments to warm up (~20 minutes).
2. Deskew the real-time oscilloscope.
3. Set up test equipment.
4. Verify the required instruments are connected to Thunderbolt (refer TekExpress instrument control settings).
5. Set DUT Parameters.
6. Select tests.
7. View acquisition settings.
8. Set global signal-related parameters.
9. Select test notification preferences.
10. Select report options.
11. Check the prerun checklist
12. Click Start to Run tests.

See also
Save the configured test setup on page 46

Running tests on page 18

Deskew real-time oscilloscopes
Use the following procedure to deskew direct input SMA channels on a Real Time Oscilloscope.

Note: DPOJET has an automatic deskew option. Refer to your DPOJET online help for information on how to deskew the
channels.

1. Run Signal Path Compensation (SPC) on the oscilloscope.
2. Connect a SMA Power Splitter (preferred) or SMA 50 Ω coaxial “T” connector to the Fast Edge output of the oscilloscope.
3. Connect SMA cables from each of the two channels to be deskewed to the power splitter (or SMA coaxial “T” connector). Use

matched cables for high speed serial measurements. Ensure that, you will use the same cables during deskew that you will use
for subsequent measurements.

4. Select Default Setup, and then select Autoset on the oscilloscope front panel.
5. Set the oscilloscope for 70% to 90% full screen amplitude on both channels. Center both traces to overlap.
6. For Deskew, Ensure that volts/div, position, and offset should be identical for the two channels.
7. Set the time/div to approximately 100 ps/div or less, with the sample rate at 1 ps/pt. These settings are not critical, but should be

close.
8. Set the horizontal acquisition mode to average, which provides a more stable display.
9. Select Deskew from the Vertical menu.
10. Verify that the reference channel (typically CH1 or CH2) is set to 0 ps deskew.
11. In the deskew control window, select the channel to deskew (typically CH3 or CH4). Adjust the deskew to overlay the rising edge as

best as possible.

Note: Typical values are in the 10’s of ps or less with cables connected directly from Fast Edge to SMA inputs. If you are using
a switch box (for example, Keithley), deskew the complete path from where the test fixture connects, through the switch, and into
the oscilloscope. Deskew values in these cases may be as much as 30 ps or more.

Setting up the test environment
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Note: There can be significant differences in the skew between two TCA-SMA adapters. If you find that a system requires a very
large correction, obtain a pair of TCA-SMA adapters that closely match each other to reduce the amount of correction.

Note: TekExpress retains the user configured Deskew values, and does not override the values during test runs.

Instrument and DUT connection setup
Click the Setup > Test Selection > Schematic button to open a PDF file that shows the compliance test setup diagrams (instrument, DUT,
and cabling) for supported testing configurations. 

See also
Minimum system requirements on page 11

TekExpress instrument control settings

Setting up the test environment
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Running tests
After selecting and configuring the tests, review the prerun checklist and then click Start to run the tests. While tests are running, you
cannot access the Setup or Reports panels. To monitor the test progress, switch back and forth between the Status panel and the Results
panel.

The application displays a report when the tests are complete. While the tests are running, other applications may display windows in the
background. The TekScope application takes precedence over other applications, but you can switch to other applications by using the Alt
+ Tab key combination. To keep the TekExpress Thunderbolt application on top, select Keep On Top from the TekExpress Options menu.

See also
Configuration tab parameters

Prerun checklist
Follow the below steps before you click Start to run a test: 

Note: If you are running a test on the application for the first time, Ensure that you have completed the procedures mentioned in
Required My TekExpress folder settings before continuing.

1. Ensure that all the required instruments are properly warmed up (approximately 20 minutes).
2. To perform Signal Path Compensation (SPC):

a. On the oscilloscope main menu, select the Utilities menu.
b. Select Instrument Calibration.
c. Follow the on-screen instructions.

3. Verify that the correct instruments are connected (oscilloscope and signal sources):

a. In TekExpress Thunderbolt, click Setup > Configuration.
b. Click Global Settings.
c. In the Instruments Detected list, verify that the test setup instruments are listed. If they are not in the list, click the arrow button

to list and select from all detected instruments. If the required instrument is still not listed, use the TekExpress Instrument Control
Settings dialog box to scan for and detect instruments (refer TekExpress instrument control settings).

See also
Instrument and DUT connection setup

Search instruments connected to the application
Use the TekExpress Instrument Control Settings dialog box to search the instruments (resources) connected to the application. The
application uses TekVISA to discover the connected instruments.

Note: The instruments required for the test setup must be connected and detected by the application, before running the test.

To refresh the list of connected instruments:

1. Select Options > Instrument Control Settings.
2. In the Search Criteria section of the Instrument Control Settings dialog box, select the connection types of the instruments to

search. Instrument search is based on the VISA layer, but different connections determine the resource type, such as LAN, GPIB, and
USB. For example, if you choose LAN, the search will include all the instruments supported by the TekExpress that are communicating
over the LAN.

3. Click Refresh. The TekExpress application searches for the connected instruments.

Search status of the instruments connected to LAN

Setting up the test environment
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4. When the search is complete, a dialog box lists the instrument-related details based on the search criteria. For example, for the Search
Criteria as GPIB, the application displays all the GPIB instruments connected to the application.

TekExpress Instrument Control Settings window.

The details of the instruments are displayed in the Retrieved Instruments table. The time and date of instrument refresh is displayed in
the Last Updated field.

Setting up the test environment
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Starting the application
To start the TekExpress Thunderbolt , select from the oscilloscope menu bar Applications > TekExpress Thunderbolt .

During start, a "My TekExpress" folder is created in the Documents folder of the current user and gets mapped to "X" drive. When the
application is closed properly, the "X" drive gets unmapped. Session files are then stored inside the X:\Thunderbolt folder. If
this file is not found, the application runs an instrument discovery program to detect connected instruments before starting TekExpress
Thunderbolt.

To keep the TekExpress Thunderbolt application on top of any application, select Keep On Top from the options menu. If the application
goes behind the oscilloscope application, select Applications >TekExpress Thunderbolt to bring the application to the front.

Starting the application
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Application panels overview
TekExpress Thunderbolt uses panels to group related configuration, test, and results settings. Click a button to open the associated panel.
A panel may have one or more tabs that list the selections available in that panel. Controls in a panel can change depending on settings
made in that panel or another panel. 

Table 5: Application panels overview

Panel Name Purpose

Setup The Setup panel shows the test setup controls. Click the Setup button to open this panel.

Use this panel to:

• Select DUT settings.
• Select the test(s).
• Set acquisitions parameters for selected tests.
• Set configuration tab preferences.
• Select test notification preferences.

Status View the progress and analysis status of the selected tests, and view test logs.
Results View a summary of test results and select result viewing preferences.
Reports Browse for reports, save reports as specific file types, specify report naming conventions,

select report content to include (such as summary information, detailed information,
user comments, setup configuration, application configuration), and select report viewing
options.

See also
Application controls

Starting the application
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Application controls
This section describes the application controls with functionality and its details.

Table 6: Application control description

Item Description
Options menu Menu to display global application controls.

Test panel Controls that open tabs for configuring test settings and options.

Start / Stop button Use the Start button to start the test run of the measurements in the selected order. If prior
acquired measurements are not cleared, then new measurements are added to the existing
set. The button toggles to the Stop mode while tests are running. Use the Stop button to
abort the test.

Pause / Continue button Use the Pause button to pause the acquisition. When a test is paused, this button changes
as Continue.

Clear button Use the Clear button to clear all existing measurement results. Adding or deleting a
measurement, or changing a configuration parameter of an existing measurement, also
clears measurements. This is to prevent the accumulation of measurement statistics or
sets of statistics that are not coherent. This button is available only on Results panel.

Note: This button is visible only when there are results data on the panel.

Application window move icon Place the cursor over the top of the application window to move the application window to
the desired location

Minimize icon Minimizes the application.

Close icon Close the application.

Table continued…

Starting the application
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Item Description
Mini view / Normal view Mini view displays the run messages with the time stamp, progress bar, Start / Stop button,

and Pause / Continue button. The application moves to mini view when you click the Start
button.

Options menu functions
To access the Options menu, click  in the upper-right corner of the application. It has the following selections:

Table 7: Options menu settings

Menu Function
Default Test Setup Opens a new test setup with default configurations.
Open Test Setup Opens a previously saved test setup. Displays the list of previously saved test setup file

names. Make the selection and click OK to open the test setup.
Save Test Setup Saves the current test configurations with the specified file name.
Save Test Setup As Saves the current test setup with a different file name or file type.
Open Recent Displays the recently opened test setup file names. Make the selection and click OK to

open the test setup.
Instrument Control Settings Detects, lists, and refreshes the connected instruments found on the specified connections

(LAN, GPIB, USB, Serial, Non-VISA Resources, TekLink, and VXI).

Keep On Top Always keeps the TekExpress Thunderbolt application on top of all the applications.

Email Settings Configures email options for test run and result notifications.
Help Displays the TekExpress Thunderbolt help.
About TekExpress Displays the application name, version, and hyperlink to end the user license agreement.

Starting the application
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Configure email settings
Use the Email Settings utility to get notified by email when a measurement completes or produces any error condition. Follow the steps to
configure email settings: 

Figure 1: Email settings window

1. Select Options > Email Settings to open the Email Settings dialog box.
2. (Required) For Recipient email Address(es), enter one or more recipient email addresses. To include multiple addresses, separate

the addresses with commas.
3. (Required) For Sender’s Address, enter the email address used by the instrument. This address consists of the instrument name,

followed by an underscore, followed by the instrument serial number, then the @ symbol, and the email server ID. For example:
user@yourcompany.com.

4. (Required) In the Server Configuration section, type the SMTP Server address of the Mail server configured at the client location,
and the SMTP Port number, in the corresponding fields.

If this server requires password authentication, enter a valid login name, password, and host name in the corresponding fields.

Note: If any of the above required fields are left blank, the settings will not be saved, and email notifications will not be sent.

5. In the Email Attachments section, select from the following options:

• Reports: Select to receive the test report with the notification email.
• Status Log: Select to receive the test status log with the notification email. If you select this option, then also select whether you

want to receive the full log or just the last 20 lines.
6. In the Email Configuration section:

• Enter a maximum file size for the email message. Messages with attachments larger than this limit will not be sent. The default is
5 MB.

• Enter the number in the Number of Attempts to Send field, to limit the number of attempts that the system makes to send a
notification. The default is 1. You can also specify a timeout period.

7. Select the Email Test Results When complete or on error check box. Use this check box to quickly enable or disable email
notifications.

8. To test your email settings, click Test Email.
9. To apply your settings, click Apply.
10. Click Close when finished.

Starting the application
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TekExpress instrument control settings
Use the TekExpress Instrument Control Settings dialog box to search the instruments (resources) connected to the application. You
can use the Search Criteria options to search the connected instruments depending on the connection type. The details of the connected
instrument is displayed in the Retrieved Instruments window.

To access, click Options > Instrument Control Settings. Select GPIB as search criteria for TekExpress application and click Refresh.
The connected instruments displayed in the Retrieved Instruments window and can be selected for use under Global Settings in the test
configuration section. 
Figure 2: TekExpress Instrument Control Settings window

See also
Options menu functions on page 23

Starting the application
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Setup panel: Configure the test setup
The Setup panel contains sequentially ordered tabs that help you guide through the test setup and execution process.

Setup panel: Configure the test setup
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DUT: Set DUT settings
Use the DUT tab to select parameters for the device under test. These settings are global and apply to all tests of current session. DUT
settings also affect the list of available tests in the Test Selection tab.

Figure 3: DUT tab

Click Setup > DUT to access the DUT parameters:

Table 8: DUT tab configuration

Setting Description
DUT ID Adds an optional text label for the DUT to reports. The default value is DUT001. The maximum number

of characters supported is 32. You cannot use the characters (.,..,...,\,/:?”<>|*) in an ID name.

 Comments icon (to the
right of the DUT ID field)

Opens a comments dialog box which allows you to enter optional text to add to a report. You can
enter a maximum number of 256 characters. Refer Configure report view settings to enable or disable
comments which displays on the test report.

Acquire live waveforms Acquire active signals from the DUT for measurement and analysis.
Use prerecorded waveform files Run tests on a saved waveform. Also refer Load a saved test setup.
DUT Type Select the DUT type form the drop-down:

• Device
• Host

CTS Version Displays the CTS version.
Version Select a supported TBT version

• TBT3

Table continued…

Setup panel: Configure the test setup
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Setting Description

• TBT4

Test Mode Displays the selected test mode. Preselects tests and parameters needed to meet the compliance
specifications for the selected device type.

When Test mode = compliance, cable emulator in the Embed/De-embed configuration menu
cannot be changed by user.

Test Method Displays the selected test method. The selected test method, sets the algorithms used to measure and
analyze the signal.

• SigTest: Select to perform measurements implemented in SigTest.
• DPOJET: Select to perform measurements implemented in DPOJET.

Test Type Select the test type from the drop-down:

• Signal Test: Select to run Unit Interval, Spread Spectrum Clocking, Jitter(TP2 & TP3), Eye (TP2 &
TP3), Transmitter Equalization, Preset Calibration and Voltage measurements.

• Preset calibration: Select to run preset calibration measurements.

Data Rates Sets the test data rate (10 Gbps, 20 Gbps, 10p3 Gbps, and 20p6 Gbps).

• Gen2(10p3 Gbps): Select to include the data rate for Gen2 Legacy.
• Gen2(10 Gbps): Select to include the data rate for Gen2 Rounded.
• Gen3(20 Gbps): Select to include the data rate for Gen3 Rounded.
• Gen2(20p6 Gbps): Select to include the data rate for Gen3 Legacy.

When TBT3 compatibility is selected, sets the test data rate at 10p3 Gbps or 20p6 Gbps

Lane Selection Select the Lane Selection from the drop-down:

• Both
• Lane 0
• Lane 1

DUT Automation There are two options for DUT Automation:

• Manual
• Automated

Click  button. Displays the DUT automation window

Table continued…
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Setting Description

In the DUT Automation window, select the appropriate DUT Type from the dropdown:

• Goshen Ridge
• Tiger Lake
• Ice Lake
• Titan Ridge
• Alpine Ridge

Set the DUT Port Number.

• For Goshen Ridge and Tiger Lake value varies from 0 to 63.
• For Ice Lake, Titan Ridge, and Alpine Ridge set the value as pa, pb or any user defined value.

Set the value for Wait till for an automated pattern change. Default value is 5 seconds.

Embed/De-embed configuration

Click  button to change the Differential de-embed filter files and common mode de-embed
filter files. The test mode is fixed to compliance, therefore, cable emulator (for TP3 measurements)
files are fixed.

The de-embed S parameter file (.s4p) is loaded into the SDLA Equalizer to deembed the cables
connected to the fixture. The 4 port index configuration for the chosen file is displayed. Assign the valid
port depending on the loaded .s4p file. The two ports on the left are input ports and the two ports on
the right are the output ports.

Setup panel: Configure the test setup
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Setting Description

Figure 4: Filter Selection

DUT automation setup
Refer to the manuals provided by Wider and USB-IF to configure the micro-controller and Electrical Test Tool respectively.

Prerequisites for running USBETT tool
• Download the USBETT tool from USB-IF forum.
• Copy the Electrical Test Tool in the file path C:\USB4ETT
Install Wilder software
• Copy the contents of the included flash drive in the Wilder hardware kit to the oscilloscope.
• Copy Wilder Controller executable in C:\USB4ETT.
• Ensure that the Wilder Controller executable and C:\USB4ETT are associated appropriately in the system environment variable.

Setup panel: Configure the test setup
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Test Selection: Select the tests
Use the Test Selection tab to select the tests. The test measurements available depends on the settings selected in the DUT tab. 

Figure 5: Test selection tab

Table 9: Test Selection tab configuration

Setting Description
Deselect All, Select All Deselect or select all tests in the list.
Tests Click a test to select or deselect. Selecting a test also show details

about the selected test in the Test Description pane.

All required tests are selected in the Compliance test mode.

Schematic Displays equipment connection setup for the selected
measurements. You need to select at least a measurement before
you click the Schematic.

Show MOI Displays the MOI (TBT_TX_MOI)
Gen2 Preset cal Select to change the preset values. By selecting or deselecting

Legacy or Rounded column header, you can select or deselect all
the presets at a single time for the selected data rate, when the
Preset calibration in the DUT panel is selected.

Gen3 Preset cal

Note: All tests are selected by default.

Note: The application does not show the oscilloscope cursor1 and 2 for each burst. The application runs an analysis on the first
five bursts of an acquisition and displays the result statistics.
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Acquisitions: Set waveform acquisition settings
Use Acquisitions tab to view the test acquisition parameters. The contents displayed on this tab depends on the DUT type and the tests
selected.

Figure 6: Acquisition tab

Note: Thunderbolt acquires all waveforms required by each test group and data rate being tested (Gen2, Gen3) before performing
analysis.

Setup panel: Configure the test setup
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Table 10: Acquisitions tab configuration

Setting Description
Source Selection Lists the signal type and input channel assigned to that type.

Click on Source fields to assign a channel source to a signal type.

The (Source) channels are auto selected, based on the probe type
used and Lane selected on the DUT tab.

Note: When the Test Method is set to SigTest in the
DUT panel, the application will not allow you to select the
source channels.

Refresh sources Updates the list of available channel sources as used by the Source
fields in the Device list. Click this button if you want to change the
channel connections in the test setup.

View Probes Displays the Source, Probe Type, and Probe models.
Acquisition and save options Saves all waveforms before the analysis.
Table continued…
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Setting Description
Signal Validation Sets the signal validation actions from the drop-down:

• Prompt me if signal fails
• Skip test if signal validation fails
• Use signal as is - Don't Check

When the signal validation option is set to "Prompt me if signal
validation fails", the application validates whether the signal is
PRBS31, PRBS15, SQ128, or SQ2 pattern. Additionally, it also
validates if the signal is Electrical idle. If the signal is valid,
the measurement continues normally. If the signal is invalid, the
following window displays:

Note: If Pattern type validation is selected as Use signal
as is - Don't Check, then the measurement continues
with the acquired waveform.

• Click Reacquire to start the acquisition again.
• Click Use Anyway to continue with the currently acquired

waveform.
• Click Skip Test to skip all pattern type tests. The rest of the

selected measurements continue.

TekExpress Thunderbolt application saves all acquisition waveforms to files by default. Waveforms are saved in a unique folder for each
session (a session is started when you click the Start button). The folder path is X:\TekExpress Thunderbolt\Untitled
Session\<dutid>\<date>_<time>. Images created for each analysis, XML files with result values, reports, and other
information specific to that particular execution are also saved in this folder.

Saving a session moves the session file contents from the Untitled Session folder to the specified folder name and changes the session
name to the specified name.

Setup panel: Configure the test setup
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Running tests on prerecorded (saved) waveforms
To load a saved waveform file: 

1. Click DUT.
2. Click Use pre-recorded waveform files.
3. Click Acquisitions. The Waveform Filename column now shows the browse buttons.

4. Click the browse button ( ) for each test acquisition type PRBS15, PRBS31, SQ128, and SQ2.
5. Navigate to and select the appropriate waveform file(s). You must select all waveforms required for the acquisition type.
6. To change, remove, or add a file to the list, click the browse button next to the file name to change, and use the menu items to replace,

remove (delete) or add a file in the list.
7. Click Start.

Setup panel: Configure the test setup
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Configuration: Set measurement limits for tests
Use Configuration tab to view and configure the Global Settings and the measurement configurations. The measurement specific
configurations available in this tab depends on the selections made in the DUT panel and Test Selection panel.

Note: You cannot change test parameters that are grayed out.

Table 11: Configuration tab: Common parameters

Settings Description
Limit Editor Displays the upper and lower limits for the applicable measurement using different types of comparisons.

Figure 7: Configuration tab: Global Settings

Table 12: Configuration tab: Global Settings configuration

Setting Description
Global Settings
Instruments Detected Displays the instruments connected to this application. Click on the

instrument name to open a list of available (detected) instruments.
Select Options > Instrument Control Settings to refresh the
connected instrument list refer TekExpress instrument control
settings.

Setup panel: Configure the test setup
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Figure 8: Configuration tab: Measurement

Table 13: Configuration tab: Measurements configuration

Setting Description
Measurements
Measurements Displays the list of measurements.
Config Select the configuration for the measurements with TP3.
Gen2 and Gen3 CTLE Select the CTLE filter file for Gen2 and Gen3 from the drop-down:

• Optimize
• Fixed

Note: The option Fixed is not available when the Test
Method is set to SigTest in the DUT panel.

Perform with DFE (Max Tap Value: 50 mV) Select to perform the DFE.

Note: The option DFE is not available when the Test
Method is set to SigTest in the DUT panel.
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Preferences: Set the test run preferences
Use Preferences tab to set the application action on completion of a measurement. The Preferences tab has the feature to enable or
disable certain options related to the measurement execution.

Figure 9: Preferences tab

Refer the below table for the options available in the Preferences tab:

Table 14: Preferences tab settings

Setting Description
Popup Settings
Auto close Warnings and informations during Sequencing

Auto close after <no> seconds

Select to close the warnings and information window automatically
after the specified amount of time.

Specify the time in seconds using the edit box.

Auto close Error Messages during Sequencing. Show in Reports

Auto close after <no> seconds

Select to close the error message window automatically after the
specified amount of time.

Specify the time in seconds using the edit box.

Show messages with a beep sound Select to display the messages with the beep sound.

Setup panel: Configure the test setup
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Status panel: View the test execution status
The Status panel contains the Test Status and Log View tabs, which provides status on the test acquisition and analysis (Test Status) and
listing of test tasks performed (Log View tab). The application opens the Test Status tab when you start to execute the test. Select the
Test Status or the Log View tab to view these items while the test execution is in progress.

View test execution status
The tests are grouped and displayed based on the Clock and Data lane. It displays the tests along with the acquisition type, acquire, and
analysis status of the tests. In pre-recorded mode, Acquire Status is not valid.

The Test Status tab presents a collapsible table with information about each test as it is running. Use the symbols to expand ( ) and
collapse ( ) the table rows.

Figure 10: Test execution status view in Status panel

Table 15: Test execution status table headers

Control Description
Test Name Displays the measurement name.
Acquisition Describes the type of data being acquired.
Acquire Status Displays the progress state of the acquisition:

• To be started
• In Progress
• Completed Acquisition

Table continued…

Status panel: View the test execution status
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Control Description
Analysis Status Displays the progress state of the analysis:

• To be started
• In Progress
• Completed
• Stopped

View test execution logs
The Test Status tab displays the detailed execution status of the tests. Also, displays each and every execution step in detail with its
timestamp information. The log details can be used to troubleshoot and resolve any issue/bug which is blocking the test execution process.

Figure 11: Log view in Status panel

Table 16: Status panel settings

Control Description
Message History Lists all the executed test operations and timestamp information.
Auto Scroll Enables automatic scrolling of the log view as information is added to the log during the test execution.

Clear Log Clears all the messages from the log view.
Save Saves the log file into a text file format. Use the standard Save File window to navigate to and specify

the folder and file name to save the log text.

Status panel: View the test execution status
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Results panel: View summary of test results
When a test execution is complete, the application automatically opens the Results panel to display a summary of test results.

In the Results table, each test result occupies a row. By default, results are displayed in summary format with the measurement details
collapsed and with the Pass/Fail column visible.

Figure 12: Results panel with measurement results

Click  icon on each measurement in the row to expand and to display the minimum and maximum parameter values of the
measurement.

Filter the test results
Each column in the result table can be customized and displayed by enabling or disabling any column as per your requirement. You can
change the view in the following ways:

• To remove or restore the Pass/Fail column, select Preferences > Show Pass/Fail.
• To collapse all expanded tests, select Preferences > View Results Summary.
• To expand all the listed tests, select View Results Details from the Preferences menu in the upper right corner.
• To enable or disable the wordwrap feature, select Preferences > Enable Wordwrap.
• To view the results grouped by lane or test, select the corresponding item from the Preferences menu.
• To expand the width of a column, place the cursor over the vertical line that separates the column from the column to the right. When

the cursor changes to a double-ended arrow, hold down the mouse button and drag the column to the desired width.
• To clear all test results displayed, click Clear.

Results panel: View summary of test results
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Reports panel: Configure report generation settings
Click Reports panel to configure the report generation settings and select the test result information to include in the report. You can use
the Reports panel to configure report generation settings, select test content to include in reports, generate the report, view the report,
browse for reports, name and save reports, and select report viewing options.

Report configuration settings
The Configuration tab describes the report generation settings to configure the Reports panel. Select report settings before running a test
or when creating and saving test setups. Report settings configured are included in saved test setups.

Figure 13: Report panel- Configuration tab

Table 17: Report configuration panel settings

Control Description
View Click to view the most current report.
Generate Report Generates a new report based on the current analysis results.
Save As Specify a name for the report.
Report Update Mode Settings
Generate new report Each time when you click Run and when the test execution is complete, it will create a new

report. The report can be in either .mht, .pdf, or .csv file formats.
Append with previous run session Appends the latest test results to the end of the current test results report. Each time when

you click this option and run the tests, it will run the previously failed tests and replace the
failed test result with the new pass test result in the same report.

Include header in appended reports Select to include header in appended reports.
Table continued…
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Control Description
Replace current test results Replaces the previous test results with the latest test results. Results from newly added

tests are appended to the end of the report.
In previous run, current session Select to replace current test results in the report with the test result(s) of previous run in

the current session.

In any run, any session Select to replace current test results in the report with the test result(s) in the selected run
session’s report. Click and select test result of any other run session.

Report Creation Settings
Report name Displays the name and path of the <Application Name> report. The default

location is at \My Documents>\My TekExpress\<Application
Name>\Reports. The report file in this folder gets overwritten each time you run
a test unless you specify a unique name or select to auto increment the report name.

To change the report name or location, do one of the following:

• In the Report Path field, type the current folder path and name.
• Double-click in the Report Path field and then make selections from the popup

keyboard and click Enter.

Be sure to include the entire folder path, the file name, and the file extension.
For example: C:\Documents and Settings\your user name\My
Documents\My TekExpress\<Application Name> \DUT001.mht.

Note: You cannot set the file location using the Browse button.

Open an existing report

Click Browse, locate and select the report file and then click View at the bottom of the
panel.

Save as type Saves a report in the specified file type, selected from the drop-down list. The report is
saved in .csv, .pdf, or .mht.

Note:

If you select a file type different from the default, be sure to change the report file
name extension in the Report Name field to match.

Auto increment report name if duplicate Sets the application to automatically increment the name of the report file if the application
finds a file with the same name as the one being generated. For example: DUT001,
DUT002, DUT003. This option is enabled by default.

Create report automatically at the end of the
run

Select to create the report with the settings configured, at the end of run.

View report after generating Automatically opens the report in a Web browser when the test execution is complete. This
option is selected by default.

Reports panel: Configure report generation settings
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Configure report view settings
The View Settings tab describes the report view settings to configure the Reports panel. Select report view settings before running a test
or when creating and saving test setups. Report settings configured are included in saved test setups.

Figure 14: Report panel-View settings tab

Table 18: Report panel view settings

Control Description
Contents To Save Settings
Include pass/fail info in details table Select to include pass/fail information in the details table of the report.
Include detailed results Select to include detailed results in the report.
Include plot images Select to include the plot images in the report.
Include setup configuration Sets the application to include hardware and software information in the summary box

at the top of the report. Information includes: the oscilloscope model and serial number,
the oscilloscope firmware version, and software versions for applications used in the
measurements.

Include complete application configuration Select to include the complete application configuration in the report.
Margin value in percentage
Include user comments Select to include any comments about the test that you or another user have added in

the DUT tab of the Setup panel. Comments appear in the Comments section, below the
summary box at the beginning of each report.

Reports panel: Configure report generation settings
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View a generated report
Sample report and its contents

A report shows detailed results and plots, as set in the Reports panel.

Figure 15: Report

Setup Information The summary box at the beginning of the report lists setup configuration information. This information
includes the oscilloscope model and serial number, optical module model and serial number, and software
version numbers of all associated applications.

Test Name Summary Table The test summary table lists all the tests which are executed with its result status.
Measurement The measurement table displays the measurement related details with its parameter value.
User comments If you had selected to include comments in the test report, any comments you added in the DUT tab are

shown at the top of the report.

Reports panel: Configure report generation settings
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Saving and recalling test setup
Overview
You can save the test setup and recall it later for further analysis. Saved setup includes the selected oscilloscope, general parameters,
acquisition parameters, measurement limits, waveforms (if applicable), and other configuration settings. The setup files are saved under
the setup name at X:\TekExpress Thunderbolt

Figure 16: Example of Test Setup File

Use test setups to:

• Recall a saved configuration.
• Run a new session or acquire live waveforms.
• Create a new test setup using an existing one.
• View all the information associated with a saved test, including the log file, the history of the test status as it executed, and the results

summary.
• Run a saved test using saved waveforms.

Note: Images that are shown in this Saving and recalling test setup chapter are for illustration purpose only and it may vary
depending on the TekExpress application.

Save the configured test setup
You can save a test setup before or after running a test. You can create a test setup from already created test setup or using a default
test setup. When you save a setup, all the parameters, measurement limits, waveform files (if applicable), test selections, and other
configuration settings are saved under the setup name. When you select the default test setup, the parameters are set to the application’s
default value.

• Select Options > Save Test Setup to save the opened setup.

Saving and recalling test setup
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• Select Options > Save Test Setup As to save the setup with different name.

Load a saved test setup
To open (load) a saved test setup, do the following:

• Select Options > Open Test Setup.

Saving and recalling test setup

TekExpress® Thunderbolt Automated Test Solution Software Application Help 47



• From the File Open menu, select the setup file name from the list and click Open.

Note: Parameters that are set for the respective test setup will enable after opening the file.

Perform a test using pre-run session files
Complete the following steps to load a test setup from a pre-run session:

1. Select Options > Open Test Setup.

Saving and recalling test setup
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2. From the File Open menu, select a setup from the list and then click Open.

Note: Parameters that are set for the respective test setup will enable after opening the file.

3. Switch the mode to Use Pre-recorded waveform files in the DUT panel.

Saving and recalling test setup
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4. Select the required waveforms from the selected setup in the Acquisitions tab and click Start.

5. The selected waveform file can be removed/replaced by clicking on the ( ) icon.

Saving and recalling test setup
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6. After successful completion of the test, the waveform report files are stored at X:\<Application Name>\Reports.

7. The overall test result status after completion of the test execution is displayed in the Results Panel.

Saving and recalling test setup
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Save the test setup with a different name
To save a test setup with a different name, follow the steps:

1. Select Options > Save Test Setup As.

2. Enter the new test setup name and click Save.

Run a saved test in prerecorded mode
Use this option to re-run a complete test using just the oscilloscope and the saved test setup files, if you selected to save the captured
waveforms when you originally ran the saved test. 

Note: When you run a saved test in prerecorded mode and then save it under the same name, the test results are saved in a new
session folder named for the date and time of the session. Any test settings that you changed for the session are saved as a new
test session file and be paired with a folder of the same name. Example. When you open a test setup that has multiple sessions
and you select a session from the Run session list in the DUT tab, the settings associated with that test session are restored.

Saving and recalling test setup
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Each test session folder has a matching test session file that stores the individual test settings for that session.

1. Use the Options menu to Open a saved test setup file
2. Select Setup > DUT and then select Use pre-recorded waveform files. A Run session drop-down list appears that displays the

previous saved sessions for this test.
3. Select the session to run.

Note: If you select a session for which no waveform files were saved, you will receive an error message. You have selected to
use Pre-recorded waveforms. The pre-recorded waveform(s) are not specified for the following Acquisition(s).

4. Click Start.
5. To save the test results, session settings, and related files, save the test setup before selecting another test setup or exiting the

application.

See also
About test setups

Create a new test setup based on an existing one

Test setups overview

Create a new test setup file based on an existing one
Use this method to create a variation on a test setup without having to create the setup from the beginning.

1. Select Options > Open Test Setup.
2. Select a setup from the list and then click Open.
3. Use the Setup and Reports panels to modify the parameters to meet your testing requirements.
4. Select Options > Save Test Setup As.
5. Enter a test setup name and click Save.

See also
About test setups

Set DUT parameters

Select acquisitions

Saving and recalling test setup
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SCPI Commands
About SCPI command
You can use the Standard Commands for Programmable Instruments (SCPI) to communicate remotely with the TekExpress application.
Complete the TCPIP socket configuration and the TekVISA configuration in the oscilloscope or in the device where you are executing the
script.

Note: If you are using an external PC to execute the remote interface commands, then install TekVISA in the PC to make the
configurations.

Socket configuration for SCPI commands
This section describes the steps to configure the TCPIP socket configuration in your script execution device and the steps to configure the
TekVISA configuration in the oscilloscope to execute the SCPI commands.

TCPIP socket configuration
1. Click Start > Control Panel > System and Security > Windows Firewall > Advanced settings.

2. In Windows Firewall with Advanced Security menu, select Windows Firewall with Advanced Security on Local Computer >
Inbound Rules and click New Rule…

SCPI Commands
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3. In New Inbound Rule Wizard menu

a. Select Port and click Next.

b. Select TCP as rule apply, enter 5000 for Specific local ports and click Next.

SCPI Commands
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c. Select Allow the connection and click Next.

d. Select Domain, Private, Public checkbox and click Next.

SCPI Commands
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e. Enter Name, Description (optional), and click Finish.

4. Check whether the Rule name is displayed in Windows Firewall with Advanced Security menu > Inbound Rules.

SCPI Commands
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TekVISA configuration
1. Click Start > All Programs > TekVISA > OpenChoice Instrument Manager.

2. Click Search Criteria. In Search Criteria menu, click LAN to Turn-on. Select Socket from the drop-down list, enter the IP address of

the TekExpress device in Hostname and type Port as 5000. Click  to configure the IP address with Port.

Enter the Hostname as 127.0.0.1 if the TekVISA and TekExpress application are in the same system, else enter the IP address of the
oscilloscope where the TekExpress application is running.

SCPI Commands
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3. Click Search to setup the TCPIP connection with the host. Check whether the TCPIP host name is displayed in OpenChoice
Instrument Manager > Instruments.

4. Double-click OpenChoice Talker Listener and enter the Command *IDN? in command entry field and click Query. Check that the
Operation is successful and Talker Listener Readout displays the Command / Data.

SCPI Commands
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Set or query the device name of application
This command sets or queries the device name of the application.

Syntax
TEKEXP:SELECT DEVICE,"<DeviceName>" (Set)

TEKEXP:SELECT? DEVICE (Query)

Command arguments
Argument Name Argument Type

<DeviceName> <String>

Returns
<String>

Examples
TEKEXP:SELECT DEVICE,"<DeviceName>" command sets the device name of the application.

TEKEXP:SELECT? DEVICE command returns the selected device name of the application.

Set or query the suite name of the application
This command sets or queries the suite name of the application.

Syntax
TEKEXP:SELECT SUITE,"<SuiteName>" (Set)

TEKEXP:SELECT? SUITE (Query)

SCPI Commands
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Command arguments
Argument Name Argument Type and value Description
<SuiteName> <String> It is the name of the suite on the DUT panel

of the application

Returns
<String>

Examples
TEKEXP:SELECT SUITE,"<SuiteName>" command sets the suite name of the application.

TEKEXP:SELECT? SUITE command returns the selected suite of the application.

Set or query the test name of the application
This command selects or deselects the specified test name of the application.

Syntax
TEKEXP:SELECT TEST,"<TestName>",<Value> (Set)

TEKEXP:SELECT TEST,"<ALL>" (Set)

TEKEXP:SELECT? TEST (Query)

SCPI Commands
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Command arguments
TestName Value
TP2

• Minimum Unit Interval 10G
• SSC Down Spread Range 10G
• SSC Down Spread Rate 10G
• SSC Phase Deviation 10G
• SSC Slew Rate 10G
• Rise Fall Time 10G
• Electrical Idle 10G
• TJ (Total Jitter)

• TJ using PRBS15 10G
• TJ using SQ2 10G

• UJ (Uncorrelated Jitter) 10G
• UDJ (Uncorrelated Deterministic Jitter) 10G
• DDJ (Data Dependent Jitter) 10G
• UDJ_LF (Low Frequency Uncorrelated Deterministic Jitter) 10G
• DCD (Duty Cycle Distortion) 10G
• AC Common Mode 10G
• Eye Diagram TP2 10G

{True | False} or {1 | 0}

It represents selected or unselected.

Where,

True or 1 - Selected

False or 0 - Unselected

TP3

• Total Jitter TP3

• TJ TP3 using PRBS15 10G
• TJ TP3 using SQ2 10G

• UJ TP3 (Uncorrelated Jitter TP3) 10G
• UDJ TP3 (Uncorrelated Deterministic Jitter TP3) 10G
• Eye Diagram TP3 10G

Table continued…
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TestName Value
Transmitter Equalization

• TXEQ Preset 0 10G
• TXEQ Preset 1 10G
• TXEQ Preset 2 10G
• TXEQ Preset 3 10G
• TXEQ Preset 4 10G
• TXEQ Preset 5 10G
• TXEQ Preset 6 10G
• TXEQ Preset 7 10G
• TXEQ Preset 8 10G
• TXEQ Preset 9 10G
• TXEQ Preset 10 10G
• TXEQ Preset 11 10G
• TXEQ Preset 12 10G
• TXEQ Preset 13 10G
• TXEQ Preset 14 10G
• TXEQ Preset 15 10G

{True | False} or {1 | 0}

It represents selected or unselected.

Where,

True or 1 - Selected

False or 0 - Unselected

TP2

• Minimum Unit Interval 20G
• SSC Down Spread Range 20G
• SSC Down Spread Rate 20G
• SSC Phase Deviation 20G
• SSC Slew Rate 20G
• Rise Fall Time 20G
• Electrical Idle 20G
• TJ (Total Jitter)

• TJ using PRBS15 20G
• TJ using SQ2 20G

• UJ (Uncorrelated Jitter) 20G
• UDJ (Uncorrelated Deterministic Jitter) 20G
• DDJ (Data Dependent Jitter) 20G
• UDJ_LF (Low Frequency Uncorrelated Deterministic Jitter) 20G
• DCD (Duty Cycle Distortion) 20G
• AC Common Mode 20G
• Eye Diagram TP2 20G

Table continued…
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TestName Value
TP3

• Total Jitter TP3

• TJ TP3 using PRBS15 20G
• TJ TP3 using SQ2 20G

• UJ TP3 (Uncorrelated Jitter TP3) 20G
• UDJ TP3 (Uncorrelated Deterministic Jitter TP3) 20G
• Eye Diagram TP3 20G

{True | False} or {1 | 0}

It represents selected or unselected.

Where,

True or 1 - Selected

False or 0 - Unselected

Transmitter Equalization

• TXEQ Preset 0 20G
• TXEQ Preset 1 20G
• TXEQ Preset 2 20G
• TXEQ Preset 3 20G
• TXEQ Preset 4 20G
• TXEQ Preset 5 20G
• TXEQ Preset 6 20G
• TXEQ Preset 7 20G
• TXEQ Preset 8 20G
• TXEQ Preset 9 20G
• TXEQ Preset 10 20G
• TXEQ Preset 11 20G
• TXEQ Preset 12 20G
• TXEQ Preset 13 20G
• TXEQ Preset 14 20G
• TXEQ Preset 15 20G

Table continued…

SCPI Commands

64



TestName Value
TP2

• Minimum Unit Interval 10p3G
• Average Unit Interval 10p3G
• SSC Down Spread Range 10p3G
• SSC Down Spread Rate 10p3G
• SSC Phase Deviation 10p3G
• SSC Slew Rate 10p3G
• Rise Fall Time 10p3G
• Electrical Idle 10p3G
• Total Jitter TP3

• TJ using PRBS15 10p3G
• TJ using SQ2 10p3G

• UJ (Uncorrelated Jitter) 10p3G
• UDJ (Uncorrelated Deterministic Jitter) 10p3G
• DDJ (Data Dependent Jitter) 10p3G
• UDJ_LF (Low Frequency Uncorrelated Deterministic Jitter)

10p3G
• DCD (Duty Cycle Distortion) 10p3G
• AC Common Mode 10p3G
• Eye Diagram TP2 10p3G

{True | False} or {1 | 0}

It represents selected or unselected.

Where,

True or 1 - Selected

False or 0 - Unselected

TP3

• Total Jitter TP3

• TJ TP3 using PRBS15 10p3G
• TJ TP3 using SQ2 10p3G

• UJ TP3 (Uncorrelated Jitter TP3) 10p3G
• UDJ TP3 (Uncorrelated Deterministic Jitter TP3) 10p3G
• Eye Diagram TP3 10p3G

Table continued…
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TestName Value
Transmitter Equalization

• TXEQ Preset 0 10p3G
• TXEQ Preset 1 10p3G
• TXEQ Preset 2 10p3G
• TXEQ Preset 3 10p3G
• TXEQ Preset 4 10p3G
• TXEQ Preset 5 10p3G
• TXEQ Preset 6 10p3G
• TXEQ Preset 7 10p3G
• TXEQ Preset 8 10p3G
• TXEQ Preset 9 10p3G
• TXEQ Preset 10 10p3G
• TXEQ Preset 11 10p3G
• TXEQ Preset 12 10p3G
• TXEQ Preset 13 10p3G
• TXEQ Preset 14 10p3G
• TXEQ Preset 15 10p3G

{True | False} or {1 | 0}

It represents selected or unselected.

Where,

True or 1 - Selected

False or 0 - Unselected

Table continued…
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TestName Value
TP2

• Minimum Unit Interval 20p6G
• SSC Down Spread Range 20p6G
• SSC Down Spread Rate 20p6G
• SSC Phase Deviation 20p6G
• SSC Slew Rate 20p6G
• Rise Fall Time 20p6G
• Electrical Idle 20p6G
• TJ (Total Jitter)

• TJ using PRBS15 20p6G
• TJ using SQ2 20p6G

• UJ (Uncorrelated Jitter) 20p6G
• UDJ (Uncorrelated Deterministic Jitter) 20p6G
• DDJ (Data Dependent Jitter) 20p6G
• UDJ_LF (Low Frequency Uncorrelated Deterministic Jitter)

20p6G
• DCD (Duty Cycle Distortion) 20p6G
• AC Common Mode 20p6G
• Eye Diagram TP2 20p6G

{True | False} or {1 | 0}

It represents selected or unselected.

Where,

True or 1 - Selected

False or 0 - Unselected

TP3

• Total Jitter TP3

• TJ TP3 using PRBS15 20p6G
• TJ TP3 using SQ2 20p6G

• UJ TP3 (Uncorrelated Jitter TP3) 20p6G
• UDJ TP3 (Uncorrelated Deterministic Jitter TP3) 20p6G
• Eye Diagram TP3 20p6G

Table continued…
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TestName Value
Transmitter Equalization

• TXEQ Preset 0 20p6G
• TXEQ Preset 1 20p6G
• TXEQ Preset 2 20p6G
• TXEQ Preset 3 20p6G
• TXEQ Preset 4 20p6G
• TXEQ Preset 5 20p6G
• TXEQ Preset 6 20p6G
• TXEQ Preset 7 20p6G
• TXEQ Preset 8 20p6G
• TXEQ Preset 9 20p6G
• TXEQ Preset 10 20p6G
• TXEQ Preset 11 20p6G
• TXEQ Preset 12 20p6G
• TXEQ Preset 13 20p6G
• TXEQ Preset 14 20p6G
• TXEQ Preset 15 20p6G

{True | False} or {1 | 0}

It represents selected or unselected.

Where,

True or 1 - Selected

False or 0 - Unselected

Returns
{True | False} or {1 | 0}

Examples
TEKEXP:SELECT TEST,"<TestName>",1 command selects the specified test in the Test Panel.

TEKEXP:SELECT TEST,"<ALL>" command select all the tests in the Test Panel.

TEKEXP:SELECT? TEST command returns the list of selected tests.

Set or query the version name of the application
This command sets or queries the version name of the application.

Syntax
TEKEXP:SELECT VERSION,”<VersionName>” (Set)

TEKEXP:SELECT? VERSION (Query)

Command arguments
Argument Name Argument Type Valid Values
<VersionName> <String> It is the name of the version on the DUT

panel of the application.

Returns
<String>
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Examples
TEKEXP:SELECT VERSION,”<VersionName>” command sets the version name of application.

TEKEXP:SELECT? VERSION command returns the version name of application.

Set or query the general parameter values
This command sets or queries the general parameter values of the application.

Syntax
TEKEXP:VALUE GENERAL,"<ParameterName>","<Value>" (Set)

TEKEXP:VALUE? GENERAL,"<ParameterName>" (Query)

Command arguments
Table 19: Command arguments for general settings

ParameterName Value
Device Type • Device

• Host

ThunderboltVersion • TBT3
• TBT4

TestMode Compliance
Test Method • Sigtest

• DPOJET

TestType • Signal Test
• Preset Calibration

Data Rates Rounded 20Gbps Option Button • Included
• ExcludedRounded 10Gbps Option Button

Legacy 20Gbps Option Button
Legacy 10Gbps Option Button

TBT3 Compatibility • Included
• Excluded

Lane Selection • Both
• Lane 0
• Lane 1

DUT Automation • Manual
• Automated

Table continued…
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ParameterName Value
DUT Automation Types • Goshen Ridge

• Tiger Lake
• Ice Lake
• Titan Ridge
• Alpine Ridge

PortNumberType For

• Goshen Ridge
• Tiger Lake

0 to 63

For

• Ice Lake
• Titan Ridge
• Alpine Ridge

• pa
• pb
• User-Defined

UserDefined PortNumber Enter any port number.
Differential Source1 File Path C:\Users\Public\Tektronix\TekApplications\Thunderbolt\Filters\sdlaT

p2DIFFSrc1.flt
Differential Source2 File Path C:\Users\Public\Tektronix\TekApplications\Thunderbolt\Filters\sdlaT

p2DIFFSrc2.flt
CommonMode Source1 File Path C:\Users\Public\Tektronix\TekApplications\Thunderbolt\Filters\sdlaT

p2CMSrc1.flt
CommonMode Source2 File Path C:\Users\Public\Tektronix\TekApplications\Thunderbolt\Filters\sdlaT

p2CMSrc2.flt
De-embed S-parameter File Path C:\Users\Public\Tektronix\TekApplications\Thunderbolt\Filters\Gore_

SN300670_SN300675_20GHz_36inch.s4p
Gen2S4p File Path TBT3_Gen2_2m.s4p
Gen3S4p File Path TBT3_Gen3_0p8m.s4p
Data+ • CH1

• CH2
• CH3
• CH4

Data- • CH1
• CH2
• CH3
• CH4

Signal Validation • Prompt me if signal validation fails
• Use signal as is - Don't Check
• Skip test if signal validation fails

Table continued…
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ParameterName Value
PresetGen2Legacy • P0

• P1
• P2
• P3
• P4
• P5
• P6
• P7
• P8
• P9
• P10
• P11
• P12
• P13
• P14
• P15

PresetGen3Legacy • P0
• P1
• P2
• P3
• P4
• P5
• P6
• P7
• P8
• P9
• P10
• P11
• P12
• P13
• P14
• P15

Table continued…
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ParameterName Value
PresetGen2Rounded • P0

• P1
• P2
• P3
• P4
• P5
• P6
• P7
• P8
• P9
• P10
• P11
• P12
• P13
• P14
• P15

PresetGen3Rounded • P0
• P1
• P2
• P3
• P4
• P5
• P6
• P7
• P8
• P9
• P10
• P11
• P12
• P13
• P14
• P15

Gen2 Ctle Option • Fixed
• Optimize

Table continued…
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ParameterName Value
Gen2 Ctle Index • 0 dB

• 1 dB
• 2 dB
• 3 dB
• 4 dB
• 5 dB
• 6 dB
• 7 dB
• 8 dB
• 9 dB

Gen2 Perform DFE Checkbox • Included
• Excluded

Gen3 Ctle Option • Fixed
• Optimize

Gen3 Ctle Index • 0 dB
• 1 dB
• 2 dB
• 3 dB
• 4 dB
• 5 dB
• 6 dB
• 7 dB
• 8 dB
• 9 dB

Gen3 Perform DFE Checkbox • Included
• Excluded

Gen2 Legacy Ctle Option • Fixed
• Optimize

Table continued…
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ParameterName Value
Gen2 Legacy Ctle Index • 0 dB

• 1 dB
• 2 dB
• 3 dB
• 4 dB
• 5 dB
• 6 dB
• 7 dB
• 8 dB
• 9 dB

Gen2 Legacy Perform DFE Checkbox • Included
• Excluded

Gen3 Legacy Ctle Option • Fixed
• Optimize

Gen3 Legacy Ctle Index • 0 dB
• 1 dB
• 2 dB
• 3 dB
• 4 dB
• 5 dB
• 6 dB
• 7 dB
• 8 dB
• 9 dB

Gen3 Legacy Perform DFE Checkbox • Included
• Excluded

Table 20: Command arguments for report settings

ParameterName Value
Report Update Mode • New

• Append
• Replace

Report Path X:\Thunderbolt\Reports\DUT001.mht

Table continued…
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ParameterName Value
Save As Type • Web Archive (*.mht;*.mhtml)

• PDF (*.pdf;)
• CSV (*.csv;)

Auto increment report name if duplicate {True | False} or {1 | 0}

It represents selected or unselected.

Where,

• True or 1 - Selected
• False or 0 - Unselected

Create report at the end {True | False} or {1 | 0}

It represents selected or unselected.

Where,

• True or 1 - Selected
• False or 0 - Unselected

Include Pass/Fail Results Summary {True | False} or {1 | 0}

It represents selected or unselected.

Where,

• True or 1 - Selected
• False or 0 - Unselected

Include Detailed Results {True | False} or {1 | 0}

It represents selected or unselected.

Where,

• True or 1 - Selected
• False or 0 - Unselected

Include Plot Images {True | False} or {1 | 0}

It represents selected or unselected.

Where,

• True or 1 - Selected
• False or 0 - Unselected

Include Setup Configuration {True | False} or {1 | 0}

It represents selected or unselected.

Where,

• True or 1 - Selected
• False or 0 - Unselected

Table continued…
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ParameterName Value
Include Complete Application Configuration {True | False} or {1 | 0}

It represents selected or unselected.

Where,

• True or 1 - Selected
• False or 0 - Unselected

Include User Comments {True | False} or {1 | 0}

It represents selected or unselected.

Where,

• True or 1 - Selected
• False or 0 - Unselected

Returns
<NRf> or <String>

Examples
TEKEXP:VALUE GENERAL,"<ParameterName>","<Value>" command set the value for the specified general
parameter.

TEKEXP:VALUE? GENERAL,"<ParameterName>" command returns the value for the specified general parameter.
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Set or query the acquire parameter values
This command sets or queries the acquire parameter values of the application.

Syntax
TEKEXP:VALUE
ACQUIRE,”<TestName>",”<AcquireType>”,”<ParameterName>","<ParameterValue>" (Set)

TEKEXP:VALUE? ACQUIRE,”<TestName>",”<AcquireType>”,”<ParameterName>" (Query)

Command arguments
Argument Name Argument Type Valid Values
<TestName> <String> It is the test name.
<AcquireType> <String> It is the acquire type.
<ParameterName> <String> It is the acquire parameter name.
<ParameterValue> <NRf> It is the acquire parameter value.

Returns
<Nrf>

Examples
TEKEXP:VALUE
ACQUIRE,”<TestName>",”<AcquireType>”,"<ParameterName>","<ParameterValue>" command sets
the value for the specified test and its acquire parameter.

TEKEXP:VALUE? ACQUIRE,”<TestName>",”<AcquireType>”,"<ParameterName>" command returns the
value for the specified test and its acquire parameter.

Set or query the analyze parameter values
This command sets or queries the analyze parameter values of the application.

Syntax
TEKEXP:VALUE ANALYZE,”<TestName>","<ParameterName>","<ParameterValue>" (Set)

TEKEXP:VALUE? ANALYZE,”<TestName>","<ParameterName>" (Query)

Command arguments
Argument Name Argument Type Description
<TestName> <String> It is the test name.
<ParameterName> <String> It is the Analyze parameter name.
<ParameterValue> <NRf> It is the Analyze parameter value.

Returns
<Nrf>
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Examples
TEKEXP:VALUE ANALYZE,”<TestName>","<ParameterName>","<ParameterValue>" command set the
value for the specified test and its analyze parameter.

TEKEXP:VALUE? ANALYZE,”<TestName>","<ParameterName>" command returns the value for the specified test
and its analyze parameter.

Query the available devices in the DUT panel of the application
This command queries the list of available devices on the DUT panel as comma separated values.

This command queries returns Thunderbolt.

Syntax
TEKEXP:LIST? DEVICE (Query)

Command arguments
Device Device Type and value Description
<Device> <String>

• Thunderbolt
It is the name of the device on the DUT
panel of the application.

Returns
<String>

Examples
TEKEXP:LIST? DEVICE command returns the list of available devices.

Query the available suites for the selected device
This command queries the list of available suites for the selected device as comma separated values.

Syntax
TEKEXP:LIST? SUITE (Query)

Returns
<String>

Examples
TEKEXP:LIST? SUITE command returns the list of available suites for the selected device.

Query the list of available tests of the application
This command queries the list of available tests of the application for the selected device as comma separated values.

Syntax
TEKEXP:LIST? TEST (Query)
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Command arguments
TestName String
Gen2
TP2 • Minimum Unit Interval 10G

• SSC Down Spread Range 10G
• SSC Down Spread Rate 10G
• SSC Phase Deviation 10G
• SSC Slew Rate 10G
• Rise Fall Time 10G
• Electrical Idle 10G
• TJ (Total Jitter)

• TJ using PRBS15 10G
• TJ using SQ2 10G

• UJ (Uncorrelated Jitter) 10G
• UDJ (Uncorrelated Deterministic Jitter) 10G
• DDJ (Data Dependent Jitter) 10G
• UDJ_LF (Low Frequency Uncorrelated Deterministic Jitter) 10G
• DCD (Duty Cycle Distortion) 10G
• AC Common Mode 10G
• Eye Diagram TP2 10G

TP3 • Total Jitter TP3

• TJ TP3 using PRBS15 10G
• TJ TP3 using SQ2 10G

• UJ TP3 (Uncorrelated Jitter TP3) 10G
• UDJ TP3 (Uncorrelated Deterministic Jitter TP3) 10G
• Eye Diagram TP3 10G

Table continued…
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TestName String
Transmitter Equalization • TXEQ Preset 0 10G

• TXEQ Preset 1 10G
• TXEQ Preset 2 10G
• TXEQ Preset 3 10G
• TXEQ Preset 4 10G
• TXEQ Preset 5 10G
• TXEQ Preset 6 10G
• TXEQ Preset 7 10G
• TXEQ Preset 8 10G
• TXEQ Preset 9 10G
• TXEQ Preset 10 10G
• TXEQ Preset 11 10G
• TXEQ Preset 12 10G
• TXEQ Preset 13 10G
• TXEQ Preset 14 10G
• TXEQ Preset 15 10G

Gen2 Legacy
TP2 • Minimum Unit Interval 10p3

• Average Unit Interval 10p3
• SSC Down Spread Range 10p3
• SSC Down Spread Rate 10p3
• SSC Phase Deviation 10p3
• SSC Slew Rate 10p3
• Rise Fall Time 10p3
• Electrical Idle 10p3
• TJ (Total Jitter)

• TJ using PRBS15 10p3
• TJ using SQ2 10p3

• UJ (Uncorrelated Jitter) 10p3
• UDJ (Uncorrelated Deterministic Jitter) 10p3
• DDJ (Data Dependent Jitter) 10p3
• UDJ_LF (Low Frequency Uncorrelated Deterministic Jitter) 10p3
• DCD (Duty Cycle Distortion) 10p3
• AC Common Mode 10p3
• Eye Diagram TP2 10p3

Table continued…
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TestName String
TP3 • Total Jitter TP3

• TJ TP3 using PRBS15 10p3
• TJ TP3 using SQ2 10p3

• UJ TP3 (Uncorrelated Jitter TP3) 10p3
• UDJ TP3 (Uncorrelated Deterministic Jitter TP3) 10p3
• Eye Diagram TP3 10p3

Transmitter Equalization • TXEQ Preset 0 10p3
• TXEQ Preset 1 10p3
• TXEQ Preset 2 10p3
• TXEQ Preset 3 10p3
• TXEQ Preset 4 10p3
• TXEQ Preset 5 10p3
• TXEQ Preset 6 10p3
• TXEQ Preset 7 10p3
• TXEQ Preset 8 10p3
• TXEQ Preset 9 10p3
• TXEQ Preset 10 10p3
• TXEQ Preset 11 10p3
• TXEQ Preset 12 10p3
• TXEQ Preset 13 10p3
• TXEQ Preset 14 10p3
• TXEQ Preset 15 10p3

Gen3
Table continued…
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TestName String
TP2 • Minimum Unit Interval 20G

• SSC Down Spread Range 20G
• SSC Down Spread Rate 20G
• SSC Phase Deviation 20G
• SSC Slew Rate 20G
• Rise Fall Time 20G
• Electrical Idle 20G
• Total Jitter TP3

• TJ using PRBS15 20G
• TJ using SQ2 20G

• UJ (Uncorrelated Jitter) 20G
• UDJ (Uncorrelated Deterministic Jitter) 20G
• DDJ (Data Dependent Jitter) 20G
• UDJ_LF (Low Frequency Uncorrelated Deterministic Jitter) 20G
• DCD (Duty Cycle Distortion) 20G
• AC Common Mode 20G
• Eye Diagram TP2 20G

TP3 • Total Jitter TP3

• TJ TP3 using PRBS15 20G
• TJ TP3 using SQ2 10p3G

• UJ TP3 (Uncorrelated Jitter TP3) 20G
• UDJ TP3 (Uncorrelated Deterministic Jitter TP3) 20G
• Eye Diagram TP3 20G

Table continued…
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TestName String
Transmitter Equalization • TXEQ Preset 0 20G

• TXEQ Preset 1 20G
• TXEQ Preset 2 20G
• TXEQ Preset 3 20G
• TXEQ Preset 4 20G
• TXEQ Preset 5 20G
• TXEQ Preset 6 20G
• TXEQ Preset 7 20G
• TXEQ Preset 8 20G
• TXEQ Preset 9 20G
• TXEQ Preset 10 20G
• TXEQ Preset 11 20G
• TXEQ Preset 12 20G
• TXEQ Preset 13 20G
• TXEQ Preset 14 20G
• TXEQ Preset 15 20G

Gen3 Legacy
TP2 • Minimum Unit Interval 20p6G

• SSC Down Spread Range 20p6G
• SSC Down Spread Rate 20p6G
• SSC Phase Deviation 20p6G
• SSC Slew Rate 20p6G
• Rise Fall Time 20p6G
• Electrical Idle 20p6G
• TJ (Total Jitter)

• TJ using PRBS15 20p6G
• TJ using SQ2 20p6G

• UJ (Uncorrelated Jitter) 20p6G
• UDJ (Uncorrelated Deterministic Jitter) 20p6G
• DDJ (Data Dependent Jitter) 20p6G
• UDJ_LF (Low Frequency Uncorrelated Deterministic Jitter)

20p6G
• DCD (Duty Cycle Distortion) 20p6G
• AC Common Mode 20p6G
• Eye Diagram TP2 20p6G

Table continued…

SCPI Commands

TekExpress® Thunderbolt Automated Test Solution Software Application Help 83



TestName String
TP3 • Total Jitter TP3

• TJ TP3 using PRBS15 20p6G
• TJ TP3 using SQ2 20p6G

• UJ TP3 (Uncorrelated Jitter TP3) 20p6G
• UDJ TP3 (Uncorrelated Deterministic Jitter TP3) 20p6G
• Eye Diagram TP3 20p6G

Transmitter Equalization • TXEQ Preset 0 20p6G
• TXEQ Preset 1 20p6G
• TXEQ Preset 2 20p6G
• TXEQ Preset 3 20p6G
• TXEQ Preset 4 20p6G
• TXEQ Preset 5 20p6G
• TXEQ Preset 6 20p6G
• TXEQ Preset 7 20p6G
• TXEQ Preset 8 20p6G
• TXEQ Preset 9 20p6G
• TXEQ Preset 10 20p6G
• TXEQ Preset 11 20p6G
• TXEQ Preset 12 20p6G
• TXEQ Preset 13 20p6G
• TXEQ Preset 14 20p6G
• TXEQ Preset 15 20p6G

Returns
<String>

Examples
TEKEXP:LIST? TEST command returns the list of available tests for the selected device.

Query the available version names of the application
This command queries the list of available version names of the application for the selected device as comma separated values.

Syntax
TEKEXP:LIST? VERSION (Query)

Returns
<String>

Examples
TEKEXP:LIST? VERSION command returns the list of version names for the selected device.
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Query the list of available instruments based on the specified instrument type
This command queries the list of available instruments based on the specified instrument type.

Syntax
TEKEXP:LIST? INSTRUMENT,"<InstrumentType>" (Query)

Command argument
Argument Name Argument value
<InstrumentType> <String>

Returns
<String>

Examples
TEKEXP:LIST? INSTRUMENT,"Real Time Scope" command returns the list of available instruments based on the real
time scope type.

Set or query the IP address of the instrument based on the specified instrument
type
This command sets or queries the IP address of the instrument based on the specified instrument type.

Syntax
TEKEXP:INSTRUMENT? "<InstrumentType>" (Query)

TEKEXP:INSTRUMENT, "<InstrumentType>","<Value>" (Set)

Command argument
Argument Name Argument Type
<InstrumentType> <String>
<Value> <String>

TCPIP::XXX.XX.XXX.XXX::INSTR

Returns
<String>

Examples
TEKEXP:INSTRUMENT? "<InstrumentType>" command returns the IP address of the oscilloscope.

TEKEXP:INSTRUMENT, "<InstrumentType>","<value>" command sets the oscilloscope to the specified IP address.

Query the information of the generated report file
This command queries the information of the generated report file in the format "<FileSize>","<FileName>".
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Pre‐requisite
A session should be run earlier and the report should be generated to get the information of the report.

Syntax
TEKEXP:INFO? REPORT (Query)

Returns
<FileSize>:: <String>

<FileName>:: <String>

Examples
TEKEXP:INFO? REPORT command returns the information of the generated report in the format ("1215”,"DUT001.mht”).

Query the information of the generated waveform files
This command queries the information of the generated waveform files in the format.

<File1Size,"File1Name”>.

If there are more than one waveform, the waveform file names are displayed with the comma separated values in the format

<File1Size,"File1Name">,<File2Size,"File2Name">.

Syntax
TEKEXP:INFO? WFM (Query)

Returns
<FileSize>:: <String>

<FileName>:: <String>

Examples
TEKEXP:INFO? WFM command returns the information of the generated waveform in the format (20000858,"X:\Thunderbolt \Untitled
Session\DUT001\20200916_041609\Iter1_Short Record‐length for SCOPE Period_NoSSC_DIFF.wfm”).

Query the information of the generated image files
This command queries the information of the generated image files in the format.

<File1Size,"File1Name”>.

If there are more than one image, the image file names are displayed with the comma separated values in the format

<File1Size,"File1Name">,<File2Size,"File2Name">.

Syntax
TEKEXP:INFO? IMAGE (Query)

Returns
<FileSize>:: <String>

<FileName>:: <String>
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Examples
TEKEXP:INFO? IMAGE command returns the information of the generated image in the format (109058, "X:\Thunderbolt
\Untitled Session\DUT001\20200916_041609\Iter1_Short Record‐length for SCOPE Period_NoSSC_DIFF.png";22794,"X:\Thunderbolt
\UntitledSession\DUT001\20 200916_041609\ScopePeriodPlot_Iteration1WithCursor.png").

Query the active TekExpress application name
This command queries the active TekExpress application name running on the oscilloscope.

Syntax
TEKEXP:*IDN? (Query)

Returns
<String>

Examples
TEKEXP:*IDN? command returns the active TekExpress application name running on the oscilloscope.

Set or query the DUTID of application
This command sets or queries the DUTID of the application.

Syntax
TEKEXP:VALUE DUTID,"<Value>" (Set)

TEKEXP:VALUE? DUTID (Query)

Command arguments
Argument Name Argument Type
<Value> <String>

Returns
<String>

Examples
TEKEXP:VALUE DUTID,"DUT001" command sets the DUTID of the application to DUT001.

TEKEXP:VALUE? DUTID command returns the DUTID of the application.

Sets or query the acquire mode status
This command sets or queries the acquire mode status.

Syntax
TEKEXP:ACQUIRE_MODE <Mode> (Set)

TEKEXP:ACQUIRE_MODE? (Query)
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Command arguments
Argument Name Argument value
<Mode> • LIVE

• PRE‐RECORDED

Returns
LIVE | PRE‐RECORDED

Examples
TEKEXP:ACQUIRE_MODE LIVE command sets the acquire mode to the Live mode.

TEKEXP:ACQUIRE_MODE? command returns the current acquire mode.

Set or query the execution mode status
This command sets or queries the execution mode status.

Syntax
TEKEXP:MODE <Mode> (Set)

TEKEXP:MODE? (Query)

Command arguments
Argument Name Argument value
<Mode> • COMPLIANCE

• USER‐DEFINED

Returns
COMPLIANCE | USER‐DEFINED

Examples
TEKEXP:MODE COMPLIANCE command sets the execution mode to the compliance mode.

TEKEXP:MODE? command returns the current execution mode.

Generate the report for the current session
This command generates the report for the current session.

Syntax
TEKEXP:REPORT GENERATE(Set)

Arguments
N/A

Examples
TEKEXP:REPORT GENERATE command generates the report for the current session.
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Query the value of specified report header field in the report
This command queries the value of specified report header field in the report.

Syntax
TEKEXP:REPORT? ”<Device Field>” (Query)

Command arguments
Argument Name Argument Type
<Device Field>

Device field is the header name of each field in the setup
information section of the report.

<String>

Returns
<String>

Examples
TEKEXP:REPORT? "DUT ID" command returns the value of DUT ID field in the report.

Query the value of specified result detail available in report summary/details
table
This command queries the value of specified result detail available in report summary/details table.

Syntax
TEKEXP:RESULT? "<TestName>" (Query)

TEKEXP:RESULT? "<TestName>","<ColumnName>" (Query)

TEKEXP:RESULT? "<TestName>","<ColumnName>",<RowNumber> (Query)

Command arguments
Argument Name Argument Type
<TestName>

It is the test name of which the details are required in the report.

<String>
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Argument Name Argument Type
<ColumnName>

It is the column header name of which the details are required in the
report.

<String>

<RowNumber>

It is the row number of which the details are required in the report.

<String>

Returns
<String>

Examples
TEKEXP:RESULT? "<TestName>" will return the pass fail status of test.

TEKEXP:RESULT? "<TestName>","<ColumnName>" will return all the row values of specific column for the test with
comma separated values.

TEKEXP:RESULT? "<TestName>","<ColumnName>",<RowNumber> will return the column value of specified row
number.

Restore the setup to default settings
This command restores the setup to default settings.

Syntax
TEKEXP:SETUP Default(Set)

Arguments
N/A

Examples
TEKEXP:SETUP Default command restores the setup to default settings.

Save the setup
This command saves the setup.

Syntax
TEKEXP:SETUP Save (Set)

Examples
TEKEXP:SETUP Save command saves the setup.

Save the settings to a specified session
This command saves the settings to a specified session.

Syntax
TEKEXP:SETUP Save,"<SessionName>"
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Command arguments
Argument Name Argument value
<SessionName> <String>

Examples
TEKEXP:SETUP Save,"<SessionName>" command saves the settings to a specified session.

Open the setup from a specified session
This command opens the setup from a specified session.

Syntax
TEKEXP:SETUP Open,"<SessionName>"(Set)

Command arguments
Argument Name Argument value
<SessionName> <String>

Examples
TEKEXP:SETUP Open,"<SessionName>" command opens the setup from a specified session.

Query the current setup file name
This command queries the current setup file name.

Syntax
TEKEXP:SETUP? CURRENT (Query)

Returns
<String>

Examples
TEKEXP:SETUP? CURRENT command returns the current setup file name.

Run/stop/pause/resume the selected measurements execution in the application
This command run/stop/pause/resume the selected measurements execution in the application.

Syntax
TEKEXP:STATE <operation mode> (Set)
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Command arguments
Argument Name Argument value
<operation mode> • RUN

• STOP
• PAUSE
• RESUME

Returns
RUN | STOP | PAUSE | RESUME

Examples
TEKEXP:STATE RUN command runs the execution for the selected measurements.

Query the current measurement execution status
This command queries the current measurement execution status.

Syntax
TEKEXP:STATE? (Query)

Returns
RUNNING | PAUSED | WAIT | ERROR | READY

Examples
TEKEXP:STATE? command returns the current measurement execution status.

Query whether the current setup is saved or not saved
This command queries whether the current setup is saved or not saved.

Syntax
TEKEXP:STATE? SETUP (Query)

Returns
Saved or Not‐Saved

Examples
TEKEXP:STATE? SETUP command returns whether the current setup is saved or not saved.

Exit or close the application
The command exits or close the application

Syntax
TEKEXP:EXIT(Set)
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Examples
TEKEXP:EXIT command close the application.

Query the status of the previous command execution
This command queries whether the previous command execution is completed successfully.

Syntax
TEKEXP:*OPC? (Query)

Returns
{0 | 1} or {True | False}

1 or True indicates that command execution is successful.

0 or False indicates that command execution is failed.

Examples
TEKEXP:*OPC? command returns whether the previous command operation is completed successfully.

Query the last error occurred
This command queries the last error occurred.

Syntax
TEKEXP:LASTERROR? (Query)

Returns
<String>

Examples
TEKEXP:LASTERROR? command returns the last error occurred.

Set or query the popup details
This command sets or queries the popup details.

Syntax
TEKEXP:POPUP? (Query)

TEKEXP:POPUP "<PopupResponse>" (Set)

Command arguments
Argument Name Argument value
<PopupResponse> • Yes

• No

Returns
The pop‐up details return in the following format:
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"<Tittle>","<message>","<response1>,<response2>".

Where,

<Tittle> :: <String>

<message> :: <String>

<response1>,<response2> :: <String>

Examples
TEKEXP:POPUP? command returns the popup details in following format ": "Do you really want to exit TekExpress?";Responses: "Yes,
No".

TEKEXP:POPUP "Yes" command sets the popup response to Yes.

Sets or query the limit values in the limits editor window
This command sets or queries the limit values in the limits editor window.

Syntax
TEKEXP:VALUE LIMIT,<TestName>,<LimitHeader>,<Value1>,<CompareString>,<Value2>(Set)

TEKEXP:VALUE? LIMIT,<TestName>,<LimitHeader> (Query)

Returns
<String> or <NRf>

Examples
TEKEXP:VALUE LIMIT,<TestName>,<LimitHeader>,<Value1>,<CompareString>,<Value2> command
sets the limits value for the specified testname and limit header.

TEKEXP:VALUE? LIMIT,<TestName>,<LimitHeader> command returns the limits value for the specified testname and
limit header.

Set or query the waveform file recalled for the specified test name and acquire
type
This command set or queries the waveform file recalled for the specified test name and acquire type.

If there are more than one waveform, the waveform file names are displayed with the symbol "$" separated values in the format

<WaveformFileName1$ WaveformFileName2>.

Syntax
TEKEXP:VALUE WFMFILE,<TestName>,<AcquireType>,<WaveformFileName> (Set)

TEKEXP:VALUE? WFMFILE,<TestName>,<AquireType> (Query)

Returns
<String>

Examples
TEKEXP:VALUE WFMFILE,<TestName>,<AquireType>,<WaveformFileName> command recalls the sepcified
waveform file for the specified testname and acquire type.
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TEKEXP:VALUE? WFMFILE,<TestName>,<AquireType> command returns the waveform file name recalled for the
specified testname and acquire type.

Set or query the enable/disable status of Continuous Run function
This command sets or queries the enable/disable status of Continuous Run function.

Syntax
TEKEXP:VALUE ContinuousRun,"<Value>" (Set)

TEKEXP:VALUE? ContinuousRun (Query)

Arguments
Argument Name Argument value
<Value> {True | False} or {1 | 0}

It represents enabled or disabled.

Where,

• True or 1 - enabled
• False or 0 - disabled

Returns
{True | False} or {0 | 1}

Examples
TEKEXP:VALUE? ContinuousRun command returns the enable or disable status of Continuous run function.

TEKEXP:VALUE ContinuousRun,"<Value>" command enable or disable the Continuous run function.

Query the enable or disable status of Continuous run function.
This command queries the enable or disable status of Continuous run function.

Syntax
TEKEXP:VALUE? GENERAL,"Enable Continuous Run" (Query)

Returns
{True | False} or {0 | 1}

Where,

1 or True indicates that the continuous run function is enabled.

0 or False indicates that the continuous run function is disabled.

Examples
TEKEXP:VALUE? GENERAL,"Enable Continuous Run" command returns the enable or disable status of continuous run
function.
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Set or query the enable/disable status of Verbose function
This command sets or queries the enable/disable status of Verbose function.

Syntax
TEKEXP:VALUE VERBOSE,"<Value>" (Set)

TEKEXP:VALUE? VERBOSE (Query)

Arguments
Argument Name Argument value
<Value> {True | False} or {1 | 0}

It represents enabled or disabled.

Where,

• True or 1 - enabled
• False or 0 - disabled

Returns
{True | False} or {0 | 1}

Examples
TEKEXP:VALUE VERBOSE,"<Value>" command enable or disable the Verbose function.

TEKEXP:VALUE? VERBOSE command returns the enable or disable status of Verbose function.

Set or query the continuous run duration time value
This command sets or queries the continuous run duration time value.

Syntax
TEKEXP:VALUE? ContinuousRun_Duration (Query)

TEKEXP:VALUE ContinuousRun_Duration,"<Value>" (Set)

Arguments
Argument Name Argument value
<Value> Infinite | hh:mm

Infinite sets the radio on button to infinite.

hh:mm sets the continuous run duration to the specified time in
hours and minutes. The minimum time duration you can set is
00:30.

Returns
Infinite | hh:mm
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Examples
TEKEXP:VALUE? ContinuousRun_Duration command returns the continuous run duration time value.

TEKEXP:VALUE ContinuousRun_Duration,"<Value>" command sets the continuous run duration time value.

Set or query the session create option in the continuous run function
This command sets or queries the option for session creation in the continuous run function.

Syntax
TEKEXP:VALUE? ContinuousRun_RunSessionOptions (Query)

TEKEXP:VALUE ContinuousRun_RunSessionOptions,"Value" (Set)

Arguments
Argument Name Argument value
<Value> NewSession | SameSession_ClearResults

NewSession - creates new session for each run.

SameSession_ClearResults - Clears the test results of the current
session and starts the test execution. The session results will be
added in the same session, by erasing the previous run results.

Returns
NewSession | SameSession_ClearResults

Examples
TEKEXP:VALUE? ContinuousRun_RunSessionOptions command returns the option for session creation in the
continuous run function.

TEKEXP:VALUE ContinuousRun_RunSessionOptions,"Value" command sets the option for session creation in the
continuous run function.

Set or query the View report after generating option status
This command sets or queries the enable/disable status of the View report after generating function.

Syntax
TEKEXP:VALUE? GENERAL,"View Report After Generating" (Query)

TEKEXP:VALUE GENERAL,"View Report After Generating",<value> (Set)
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Arguments
Argument Name Argument value
<Value> {True | False} or {1 | 0}

It represents enabled or disabled.

Where,

• True or 1 - enabled
• False or 0 - disabled

Returns
{True | False} or {0 | 1}

Examples
TEKEXP:VALUE? GENERAL,"View Report After Generating" command returns the enable or disable status of
view report after generating option.

TEKEXP:VALUE GENERAL,"View Report After Generating",<value> command enable or disable the view
report after generating option.

Returns the report as XML string
This command returns the report as XML string.

Syntax
TEKEXP:REPORTASXML? (Query)

Returns
<String>

Examples
TEKEXP:REPORTASXML? command returns the report XML string.

Copies all the images from current run session to the given destination location
This command copies all the images from current run session to the given destination location.

Syntax
TEKEXP:COPYIMAGES <DestinationPath> (Set)

Command argument
<DestinationPath> :: <String>

Returns
NA

Examples
TEKEXP:COPYIMAGES C:\Temp command copies all the images from current run session to the mentioned location.
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Selects the specified test(s) and deselect all other tests
This command selects the specified test(s) and deselect all other tests.

Syntax
TEKEXP:SELECTID <”TestID”> (Set)

Command argument
Argument Name Argument value
TestID String

Returns
NA

Examples
TEKEXP:SELECTID "11101"This command select the test associated with the ID and deselects all other tests in the application.

TEKEXP:SELECTID “11101,11102”This command selects the tests associated with the IDs and other tests will be deselected.

Returns the complete information about the selected test
This command returns the complete information about the selected test.

The information includes application name, TestID, Device selected, Suite selected, version, Test name, Test description.

Syntax
TEKEXP:TESTINFO? (Query)

Returns
<String>

Examples
TEKEXP:TESTINFO? This command returns the following details:

<TekExpress> <Test Id="11101" Device="TX-Device" Suite="Group1" Version="Spec 1.0" Name="Algorithm Library Measurement"
Description="This is Algorithm Library measurement test. Refer Section-B of TekExpress SampleApp Development Guide for more details.

Set the default session
Sets the application configurations to default value.

Syntax
TEKEXP:SESSION DEFAULT (set)

Examples
TEKEXP:SESSION DEFAULT, sets the application configurations to default value.

Save the run/config sessions
Enter the name to save/config the session.
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Syntax
TEKEXP:SESSION SAVE,“Session Name” (set)

Command arguments
Argument Name Argument value
<Session Name> <String>

Examples
TEKEXP:SESSION SAVE,“Session Name” saves the session.

Load the run/config session
Load the selected config/run session.

Syntax
TEKEXP:SESSION LOAD, “Session Name” (set)

Command arguments
Argument Name Argument value
<Session Name> <String>

Examples
TEKEXP:SESSION LOAD, “Session Name”, load the selected config/run session.

Delete the run/config session
Deletes the selected config/run session.

Syntax
TEKEXP:SESSION DELETE, "Session1, Session2" (set)

Command arguments
Argument Name Argument value
<Session Name> <String>

Examples
TEKEXP:SESSION DELETE, "Session1, Session2", deletes the selected config/run session.

Run the run/config saved session
Run the selected config/run session.

Syntax
TEKEXP:SESSION RUN, “Session Name’s separated by comma” (set)
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Command arguments
Argument Name Argument value
<Session Name> <String>
Session Name’s separated by comma (to run the multiple run
sessions)

<String>

Examples
TEKEXP:SESSION RUN, “Session Name’s separated by comma”, runs the selected config/run session.

Query the available list in the run/config session
Returns the list of available config/run session.

Syntax
TEKEXP:SESSION? LIST
Returns
Returns the list of available config/run session.

Examples
TEKEXP:SESSION? LIST, returns the list of available config/run session.

Query the current run/config session
Returns the selected config/run session.

Syntax
TEKEXP:SESSION? CURRENT
Returns
Returns the selected config/run session.

Examples
TEKEXP:SESSION? CURRENT, returns the selected config/run session.

Override the run/config session
Overrides the selected config/run session.

Syntax
TEKEXP:SESSION SAVE,"SessionName", "True" (set)
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Command arguments
Argument Name Argument Type Argument Value
<Session Name> <String> {True | False} or {1 | 0}

It represents enabled or disabled.

Where,

• True or 1 - enabled
• False or 0 - disabled

Returns
{True | False} or {0 | 1}

Examples
TEKEXP:SESSION SAVE,"SessionName", "True", overrides the selected config/run session.

Query the statistics value for a test measurement
This query command returns the statistics for test name which is passed as argument.

Syntax
TEKEXP:RESULT:STATISTICS? “Test Name” (Query)

Returns
Returns statistics for test name which is passed as argument.

Examples
TEKEXP:RESULT:STATISTICS? “Test Name”, returns measurement results separated by ";" if it has multiple sub
measurements. Sample: <Meaurement Detail>, Min : <min value>, Max : <max value>, Avg.Value : <avg. value>, Std.Dev : <std.dev>,
Units : <unit> for test name which is passed as argument.

Query the statistics value for all test measurements
This query command returns statistics for all tests which are passed as argument.

Syntax
TEKEXP:RESULT:STATISTICS? “ALL” (Query)

Returns
Returns statistics for all tests which are passed as argument.

Examples
TEKEXP:RESULT:STATISTICS? “ALL”, returns measurement results separated by ";" if it has multiple sub measurements.
Sample: TestName : <Test Name>, Details : <Measurement Detail>, Iter.Count : <Iteration Count>, Min : <min value>, Max : <max value>,
Avg.Value : <avg. value>, Std.Dev : <std.dev>, Units : <unit> for all test name which are passed as argument.
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Examples
This section provides the examples for the SCPI commands.

Example Description
TEKEXP:*IDN? It returns the active TekExpress application name running on the scope.
TEKEXP:*OPC? It returns the last command execution status, if status is executed it returns "1" else "0".
TEKEXP:SELECT TEST It selects the test.
TEKEXP:ACQUIRE_MODE PRE-
RECORDED

It sets the acquire mode as pre-recorded.

TEKEXP:ACQUIRE_MODE? It returns LIVE when acquire mode is set to live or it returns pre-recorded when acquire
mode is set to pre-recorded.

TEKEXP:EXPORT REPORT It returns the report file in bytes. This can be written into another file for further analysis.
TEKEXP:INFO? REPORT It returns “100,”ReportFileName.mht”", when 100 is the file size in bytes for the filename

ReportFileName.
TEKEXP:INFO? WFM It returns “100,“WfmFileName1.wfm”";“200, “WfmFileName2.wfm”" when 100 is the filesize

in bytes for the filename WfmFileName1.wfm and 200 is the file size in bytes for the
filename WfmFileName2.wfm.

TEKEXP:INSTRUMENT "Real
Time Scope",DPO73304SX
( GPIB8::1::INSTR)

It sets the instrument value as DPO73304SX( GPIB8::1::INSTR ) for the selected
instrument type Real Time Scope.

TEKEXP:INSTRUMENT? "Real
Time Scope"

It returns "DPO73304SX ( GPIB8::1::INSTR ), when DPO73304SX ( GPIB8::1::INSTR )" is
the selected instrument for the instrument type Real Time Scope.

TEKEXP:LASTERROR? It returns ERROR: INSTRUMENT_NOT_FOUND, when no instrument is found.
TEKEXP:LIST? DEVICE It returns "Thunderbolt" when TX-Device, RXDevice are the available device.
TEKEXP:LIST?
INSTRUMENT,"Real Time
Scope"

It returns "DPO73304SX ( GPIB8::1::INSTR ), DPO73304DX ( TCPIP::
134.64.248.91::INSTR )" when DPO73304SX ( GPIB8::1::INSTR ), DPO73304DX
( TCPIP::134.64.248.91::INSTR ) are the list of available instruments.

TEKEXP:MODE COMPLIANCE It sets the execution mode as compliance.
TEKEXP:MODE? It returns COMPLIANCE when the execution mode is compliance or It returns USER-

DEFINED when the execution mode is user defined.
TEKEXP:POPUP OK It sets OK as the response to active popup in the application.
TEKEXP:POPUP? It returns "OK", when OK is the active popup information shown in the application.
TEKEXP:REPORT GENERATE It generates report for the current session.
TEKEXP:REPORT? "Scope Model
Number"

Returns "DPO73304SX" when DPO73304SX is the scope model.

TEKEXP:REPORT? DUT ID It returns "DUT001" when DNI_DUT001 is the DUT ID.
TEKEXP:RESULT? "Total
Jitter"

It returns Pass when the test result is Pass.

TEKEXP:RESULT? "Total
Jitter",1

It returns the 2nd Sub measurements Margin L and H values.

TEKEXP:SELECT DEVICE,
Thunderbolt, TRUE

It selects Thunderbolt.
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Example Description
TEKEXP:SELECT? DEVICE It returns Thunderbolt
TEKEXP:SETUP DEFAULT It restores the application to default setup.
TEKEXP:STATE STOP It stops the test execution.
TEKEXP:STATE? It returns as READY when the application is ready to run next measurement.
TEKEXP:STATE? SETUP It returns as NOT_SAVED when the current setup is not saved else it returns SAVED.
TEKEXP:VALUE GENERAL,"Test
Method","DPOJET"

It sets the Test Method parameter value to DPOJET.

TEKEXP:VALUE? GENERAL,"Test
Method"

It returns "DPOJET" when DPOJET is the Test Method value.

TEKEXP:SELECT TEST ,"Total
Jitter",True

Execute this command to select an individual test. This command will select "Total Jitter"
test in the Signal Test tab.
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References

Application directories
You can find the application files at C:\Program Files\Tektronix\TekExpress Thunderbolt3. The application directory and associated files are
organized as follows:

The following table lists the default directory names and their usage:

Table 21: Application directories and usage

Directory names Usage
Bin Contains application libraries
Compliance Suites Contains test suite specific files
DUT Automation Contains batch files to run DUT in Automated mode
ICP Contains instrument and application specific interface libraries
Images Contains images of the application
Lib Contains utility files specific to the application
Licenses Contains all the license files
Plot Files Contains DPOJET and scope period plots csv
Plugins Contains the dll path for DUT automation
Report Generator Contains style sheets for report generation
Tools Contains instrument and application specific files
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File name extensions
The TekExpress Thunderbolt software uses the following file name extensions:

Table 22: File name extension

File name extension Description
*.TekX Application session files (the extensions may not be displayed)
*.py Python sequence file.
*.xml Test-specific configuration information (encrypted) files.

Application log files

*.csv Test result reports

Plot data

*.mht Test result reports (default)

Test reports can also be saved in HTML format

*.pdf Test result reports

Application help document

*.xslt Style sheet used to generate reports
*.png Captured images
.wfm Test waveform file

View test-related files
Files related to tests are stored in My Documents\TekExpress Thunderbolt\Untitled session folder. Each test setup in this folder has both a
test setup file and a test setup folder, both with the test setup name. The test setup file is preceded by the TekExpress icon.

Inside the test setup folder is another folder named for the DUT ID used in the test sessions. The default is DUT001.

Inside the DUT001 folder are the session folders and files. Each session also has a folder and file pair, both named for the test session
using the naming convention (date)_(time). Each session file is stored outside its matching session folder:

Each session folder contains image files of any plots generated from running the test session. If you selected to save all waveforms or ran
tests using prerecorded waveform files, these are included here.
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The first time you run a new, unsaved session, the session files are stored in the Untitled Session folder located at X:\TekExpress
Thunderbolt. When you name and save the session, the files are placed in a folder with the name that you specify. A copy of the test files
stay in the Untitled Session folder until you run a new test or until you close the application.

Handle error codes
The return value of the remote automations at the server-end is OP_STATUS, which changes to a string value depending on its code, and
is returned to the client. The values of OP_STATUS are as follows:

Code Value Description

-1 FAIL The operation failed

1 SUCCESS The operation succeeded

2 NOT FOUND Server not found

3 LOCKED The server is locked by another client, so the operation cannot be performed

4 UNLOCK The server is not locked; lock the server before performing the operation

0 NULL Nothing

Note: The Fail condition for PI commands occurs in any of the following cases:

If the server is locked, the application displays "Server is locked by another client".

If the session is unlocked, the application displays "Lock session to execute the command".

If the server is not found, the application displays " Server not found-Disconnect!".

If the fail condition is not one of the above types, the application displays "Failed".

DUT Initialization
Note: The following steps are applicable, when there is a change in connections to the DUT Setup or if the DUT and/or
Microcontroller is power cycled.

Note: The following steps are applicable only for Ice Lake DUT.

1. Ensure that the connections are made to the DUT and Microcontroller, Click the Setup > Test Selection > Schematic to open a PDF
file that shows the compliance test setup diagrams.

2. Power ON the DUT and Microcontroller.
3. Login to the DUT.
4. Launch the command prompt by performing a right-click on the CMD icon and selecting the “Run as Administrator” option.
5. Enter the following italicized command

cd C:\TBT Electrical\Thunderbolt_Integrated_Electrical_Scripts_ver0.7\Host

tclsh85 Host_Enable_Compliance.tbc <Device ID>

Where <Device ID> = 0x8A17 / 0x8A0D / 0x9A1B / 0x9A1D
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