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Introduction

Overview of the product
The Talker Listener application provides a way for you to observe the detailed communications between the PC and the instrument(s),
to send individual commands to an instrument, to run commands scripts, and to create and save scripts. You can open more than one
instance of the Talker Listener application. You can save many commands in a script (text format) and also open scripts for running. You
can run the entire script at a time or can single step through it. You can also send a selected command continuously using the Loop button.

You can talk to instruments connected over either Serial Port (ASRL), GPIB, Network (TCPIP), and USB. You can send GPIB commands
or receive responses. The application logs the communication between instruments in the Talker Listener Readout for later viewing. You
can copy and paste the Talker Listener Readout into any text editor and save it.

You can set and get the current values of supported VISA attributes using the Attribute Explorer.

Supported information
Refer to Contacting Tektronix at the beginning of the online help.

Please have the following information available when you contact Tektronix:

• Model and serial number of your instrument.
• Firmware version of your instrument.
• TekVISA or OpenChoice VISA versions operating on both your PC and instrument.
• Communications protocols you are using (Ethernet, GPIB, USB, Serial).
• Driver version if you are using VXI plug and play or IVI-COM.
• Software development environment and language of your application (Visual Studio, .NET 2003 using C#.NET).

Introduction
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Operating basics

Application view
The following image shows the application screen and the areas of the screen.

Starting and Exiting the application
Invoke the Talker Listener application from Start > Programs > TekVisa > Talker Listener.

Select File > Exit to exit from the application or click .

Menus

File Menu

The following menu items are available in the File menu.

Operating basics
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Menu item Description
New Script Opens a new script file in Notepad for editing. The file includes the Talker Listener Script header. You

can type or cut-and-paste the commands and save the script.
Open Script Opens a File Open dialog box to select and open an existing script file. The application adds the

commands from that script to the command history.
Save Script Saves the commands in a script.

Print Opens a Print dialog box and prints the whole or the selected portion of the Talker Listener Readout.
Exit Exits the application.

Edit Menu

The following menu items are available in the Edit menu.

Menu item Description
Copy All Copies the contents of all the rows and columns in the Talker Listener Readout. The shortcut key is

Ctrl+A.
Copy Commands & Data Copies the contents of only the Commands and Data column in the Talker Listener Readout. The

shortcut key is Ctrl+D.
Copy Commands Only Copies only the Commands in the Talker Listener Readout. The shortcut key is Ctrl+C.
Copy Selected Copies the contents of only the selected row in the Talker Listener Readout. The shortcut key is Ctrl+S.
Clear Clears or deletes the entire contents in the Talker Listener Readout. The shortcut key is Del.

The menu items conform to the shortcut menu in the Talker Listener Readout area.

Operating basics
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See also
Shortcut menu

Tools Menu

The Tools menu has the following options.

Menu item Description
Instrument Manager Opens an instance of Instrument manager.
Call Monitor Opens an instance of Call Monitor.
Notepad... Opens Notepad for creating Talker Listener scripts.
Options... Opens the Talker Listener options dialog.
Attribute Explorer Opens the Attribute Explorer dialog.

Help Menu

The following menu items are available in the Help menu.

Menu item Description
Talker Listener Help Opens the Talker Listener Online Help file.
Customer Support Opens the Contacting Tektronix topic in the help file.
About Talker Listener... Displays the About Talker Listener dialog box.

Shortcut Menus

Right-click within the Command/Script History area, for a shortcut menu.

Operating basics
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The shortcut menu options are:

Menu item Description
Cut Cuts the selected command or script. The shortcut key is Ctrl+X.
Copy Copies the selected command or script. The shortcut key is Ctrl+C.
Paste Pastes the cut or copied command or script. The shortcut key is Ctrl+V.
Clear Removes the selected command or script. The shortcut key is Del.

Right-click within the Talker Listener Readout area, for a shortcut menu. This menu is the same as the Edit Menu.

The shortcut menu options are:

Menu item Description
Copy All Copies the contents of all the rows and columns in the Talker Listener Readout. The shortcut key is

Ctrl+A.
Copy Commands & Data Copies the contents of only the Commands and Data column in the Talker Listener Readout. The

shortcut key is Ctrl+D.
Copy Commands Only Copies only the Commands in the Talker Listener Readout. The shortcut key is Ctrl+C.
Copy Selected Copies the contents of only the selected row in the Talker Listener Readout. The shortcut key is Ctrl+S.
Clear Clears or deletes the entire contents in the Talker Listener Readout. The shortcut key is Del.

Talker Listener Options

Select Tools> Options to invoke Talker Listener options dialog.

Operating basics
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Option Description
Timeout Timeout is a duration in seconds, which indicates the time duration after which the application times

out while waiting for a response from a connected instrument. The default timeout value is 10 seconds.
AutoQuery If the selected command is a query command, then the Write command is always followed by a Read

command. AutoQuery is enabled by default .
Termination Character This is the character appended to every command. The Append Term Char is enabled by default and

the termination character is line feed.
Colors Specifies the colors for Talker Listener Readout. The default ASCII text and HEX text colors are black

and blue.

Attribute Explorer

Select Tools> Attribute Explorer to explore the attributes of the selected instrument. If the attribute is a Read Only attribute, the Set
Attribute area is disabled.

Operating basics
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Option Description
VISA Attribute Select the attribute from a list of supported VISA attributes. The application displays the scope of the

attribute (All Sessions or This Session) and the access of the attribute (Read Only, Read Write).
Get Attribute Click GetAttribute to display the current value of the selected attribute.
Set Attribute Click SetAttribute to set the specified value for the selected attribute.
Boolean Enabled only when you select an attribute of type Boolean. Allows you to select True of False values.
viString Based on the data type of the selected attribute, you can enter integer or string type values.

The following VISA attributes are supported.

Attribute Description
VI_ATTR_INTF_INST_NAME Human-readable text describing the given interface.
VI_ATTR_INTF_NUM Board number for the given interface.
VI_ATTR_RSRC_CLASS Specifies the resource class (for example, “INSTR”).
VI_ATTR_RSRC_NAME The unique identifier for a resource compliant with the address structure.
VI_ATTR_RSRC_SPEC_VERSI
ON

Resource version that uniquely identifies the version of the VISA specification to which the
implementation is compliant.

VI_ATTR_RSRC_IMPL_VERSIO
N

Resource version that uniquely identifies each of the different revisions or implementations of a
resource.

VI_ATTR_RSRC_MANF_ID A value that corresponds to the VXI manufacturer ID of the manufacturer that created the
implementation.

VI_ATTR_RSRC_MANF_NAME A string that corresponds to the VXI manufacturer name of the manufacturer that created the
implementation.

VI_ATTR_TMO_VALUE Minimum timeout value to use, in milliseconds.
VI_ATTR_ASRL_BAUD This is the baud rate of the interface. It is represented as an unsigned 32-bit integer so that any baud

rate can be used, but it usually requires a commonly used rate such as 300, 1200, 2400, or 9600 baud.
VI_ATTR_ASRL_DATA_BITS This is the number of data bits contained in each frame (from 5 to 8). The data bits for each frame are

located in the low order bits of every byte stored in memory.
VI_ATTR_ASRL_END_IN This attribute indicates the method used to terminate read operations.
VI_ATTR_ASRL_END_OUT This attribute indicates the method used to terminate write operations.
VI_ATTR_ASRL_FLOW_CNTRL This attribute indicates the flow control method used in Serial port data transfer.
VI_ATTR_ASRL_PARITY This is the parity used with every frame transmitted and received.
VI_ATTR_ASRL_STOP_BITS This is the number of stop bits used to indicate the end of a frame.
VI_ATTR_GPIB_ADDR_STATE This attribute shows whether the specified GPIB interface is currently addressed to talk or listen, or is

not addressed.
VI_ATTR_GPIB_ATN_STATE This attribute shows the current state of the GPIB ATN (ATtentioN) interface line.
VI_ATTR_GPIB_CIC_STATE This attribute shows whether the specified GPIB interface is currently CIC (controller in charge).
VI_ATTR_GPIB_NDAC_STATE This attribute shows the current state of the GPIB NDAC (Not Data ACcepted) interface line.
VI_ATTR_GPIB_PRIMARY_ADD
R

Primary address of the local GPIB controller used by the given session.

VI_ATTR_GPIB_READDR_EN This attribute specifies whether to use repeat addressing before each read or write operation.
Table continued…
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Attribute Description
VI_ATTR_GPIB_RECV_CIC_ST
ATE

Notification that the GPIB controller has gained or lost CIC (controller in charge) status.

VI_ATTR_GPIB_REN_STATE This attribute returns the current state of the GPIB REN (Remote ENable) interface line.
VI_ATTR_GPIB_SECONDARY_
ADDR

Secondary address of the local GPIB controller used by the given session

VI_ATTR_GPIB_SRQ_STATE This attribute shows the current state of the GPIB SRQ (Service ReQuest) interface line.
VI_ATTR_GPIB_SYS_CNTRL_S
TATE

This attribute shows whether the specified GPIB interface is currently the system controller. In some
implementations, this attribute may be modified only through a configuration utility. On these systems,
this attribute is read only (RO).

VI_ATTR_GPIB_UNADDR_EN This attribute specifies whether to unaddress the device (UNT and UNL) after each read or write
operation.

VI_ATTR_SEND_END_EN Whether to assert END during the transfer of the last byte of the buffer.
VI_ATTR_SUPPRESS_END_EN Whether to suppress the END indicator termination. If this attribute is set to VI_TRUE, the END

indicator does not terminate read operations. If this attribute is set to VI_FALSE, the END indicator
terminates read operations.

VI_ATTR_TERMCHAR Termination character. When the termination character is read and VI_ATTR_TERMCHAR_EN is
enabled during a read operation, the read operation terminates.

VI_ATTR_TERMCHAR_EN Flag that determines whether the read operation should terminate when a termination character is
received.

VI_ATTR_TCPIP_ADDR This is the TCPIP address of the device to which the session is connected. This string is formatted in
dot-notation.

VI_ATTR_TCPIP_DEVICE_NAM
E

This specifies the LAN device name used by the VXI-11 protocol during connection.

VI_ATTR_TCPIP_HOSTNAME This specifies the host name of the device. If no host name is available, this attribute returns an empty
string.

VI_ATTR_TCPIP_PORT This specifies the port number for a given TCPIP address. For a TCPIP SOCKET resource, this is a
required part of the address string.

Buttons
The following buttons are available when the Talker Listener application opens.

Button Description
The Read button is available in the Enter Command or Script area. Click the Read button
to connect to an instrument and Read data from it.

The Write button is available in the Enter Command or Script area. Click the Write button to
write selected command to an instrument.

Table continued…
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Button Description
The Query button is available in the Enter Command or Script area. Click the send a
command and read the response from an instrument.

The Update button is available in the Instruments area. Click the Update button to update
the instrument list.

The Reset Communications button is available in the Instruments area. Click the Reset
Communications button to reset the communication with the selected instrument. This
closes the session with the instrument, clears the buffers, and opens a new session with
the same instrument.
The Run button is available in the Command/Script History area. Click the Run button to
run the selected script.

The Single Step button is available in the Command/Script History area. Click the Single
Step button to execute the commands in a script one at a time.

The Loop button is available in the Command/Script History area. Click the Loop button to
execute the selected command or script continuously till you click the Loop button again.
While the command is executing in a loop, the button changes to green.

Operating basics
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How to

Create and Open a Script
To create a new script, select File > New Script. This action opens a Notepad file with the Talker Listener header.

The Talker Listener header in a script is the text "Talker Listener Script: Script <n>" where n (an integer) is the script id.

To open a script file, select File > Open Script. This opens a dialog box, which allows you to select a text file. The application checks for
the existence of the header in the file. For an invalid file, script are added to the Command/Script History area. If the header does not exist,
an error message is displayed.

Save a Script
The commands that you can save are available in the Command/Script History area.

The commands that are included in the script begin from the current selection until the application encounters a script header or the end of
tree. If the current selection is a script header, then the entire script is saved. If there are no scripts but only individual commands, then all
the commands are saved under a default script name <<Script "n">> where n indicates the script id. The next time you save a script, the
header would be <<Script "n+1">>, indicating the OpenChoice Talker Listener has so far created n+1 scripts in the current session.

Display and Select an Instrument
Select an instrument from the Instrument List located at the top left of the Talker Listener application.

How to
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The Instrument List displays all the instruments available for communication over a Serial port (ASRL), GPIB, Network (TCPIP), and USB.
The icon next to the instrument name indicates the mode of communication between the application and the instrument.

When you click Update, the instrument list is updated and the last updated time is displayed in the text box below the instrument list. Any
connected session remains unaffected.

When you click Reset Communications, any open session is closed and then reopened. If, at the time of reset, the selected instrument is
different from the opened instrument, the session with the opened instrument is closed and the session with the newly selected instrument
is opened.

Read, Write, or Query a Command
The Enter Command or Script area is located at the top right of the Talker Listener application.

How to

16



The Read, Write, and Query buttons act on the selected command in the command history.

You can type in any command in the text box. The command can be of either Set type or the Query type.

After you type the command, and press Enter or click the Write button, the command is added to the command history, if it does not
already exist, and then sent to the instrument. If the AutoQuery option is enabled and the entered command is a Query command, then a
Read command is followed by the Write command.

When you click Read, the application reads the response from the instrument. Upon receiving the response, the application adds it to the
Talker Listener Readout. If there is no response from the instrument within the specified timeout period, the application adds a timeout
error message to the Talker Listener Readout.

When you click Query, the application writes the command and waits for a response from the instrument irrespective of the AutoQuery
option.

If Hex Entry Enabled is checked, the command text box accepts only hex characters. By default, the Hex Entry Enabled is unchecked.

Note: The command entered in the command text box will be added to the command history only if it does not already exist.

See also
Buttons

Options

Run, Single Step, or Loop a Command
Run and Single Step are applicable for scripts. Loop is applicable to a script and a command.

You can open a script file using the File menu and display it in the Command history.

When you click Run, the selected script is executed fully - all the commands within the script will be sent to the instrument and responses
received.

How to
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When you click Single Step, the command following the selected command is executed. This can be used for debugging the script.

When you click Loop, the selected command or script is executed continuously till you click Loop again.

The text box below the command history displays the selected options - the AutoQuery, the Termination Character (if enabled), and the
Loop Count. If the loop is currently executing, the loop counts increments.

Talker Listener Readouts and Display Options
The Talker Listener Readout records all the communication that occurs between the Talker Listener application and the selected
instrument. The communication record consists of date and time, the duration for each command, the source, the command/data, and the
command type.

Source is the computer name that initiated the communication. Command/Data is the actual command or data that was sent or received.

Command type can be either Write or Read, indicating a write to the instrument or a read from the instrument. Open session indicates
the session open command, while the close session indicates a session close command and an error-write indicates a error in write and
similarly an error-read indicates a error in reading.

Display Options
In the Talker Listener Readout, you have an option to display all the write-read communications in either ASCII alone or in both Hex and
ASCII. The default display option is “ASCII” indicating that the Talker Listener Readout displays the communication in ASCII format. You
can choose to display the communication in Hex and ASCII indicating that the communication between the Talker Listener application and
the target instrument is displayed both in hex and ASCII formats using the colors that you specify in the Options dialog.

How to
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